home *** CD-ROM | disk | FTP | other *** search
/ PC World 2001 April / PCWorld_2001-04_cd.bin / Software / TemaCD / webclean / debian / rules < prev    next >
Text File  |  2001-01-14  |  2KB  |  91 lines

  1. #! /usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # GNU copyright 1997 to 1999 by Joey Hess.
  4. PACKAGE=webcleaner
  5. DOCDIR = debian/$(PACKAGE)/usr/share/doc/$(PACKAGE)
  6.  
  7. # Uncomment this to turn on verbose mode.
  8. #export DH_VERBOSE=1
  9.  
  10. # This is the debhelper compatability version to use.
  11. export DH_COMPAT=2
  12.  
  13. # This has to be exported to make some magic below work.
  14. export DH_OPTIONS
  15.  
  16. configure: configure-stamp
  17. configure-stamp:
  18.     dh_testdir
  19.     ./setup.py config
  20.     touch configure-stamp
  21.  
  22. build: configure-stamp build-stamp
  23. build-stamp:
  24.     dh_testdir
  25.     ./setup.py build
  26.     touch build-stamp
  27.  
  28. clean:
  29.     dh_testdir
  30.     rm -f build-stamp configure-stamp
  31.     $(MAKE) clean
  32.     dh_clean
  33.  
  34. install: build
  35.     dh_testdir
  36.     dh_clean -k
  37.     dh_installdirs
  38.     ./setup.py install --root=`pwd`/debian/$(PACKAGE) --no-compile
  39.     # delete man pages, we install them with dh_installmanpages
  40.     rm -rf debian/$(PACKAGE)/usr/man
  41.     # move webcleaner binaries to /usr/sbin
  42.     mv -f debian/$(PACKAGE)/usr/bin/webcleaner debian/$(PACKAGE)/usr/sbin
  43.     mv -f debian/$(PACKAGE)/usr/bin/webcleanerconf debian/$(PACKAGE)/usr/sbin
  44.     # remove example and config files, we install them ourselves
  45.     rm -rf debian/$(PACKAGE)/usr/share/webcleaner
  46.     # install configuration
  47.     install -c -m 644 config/*.zap config/*.dtd debian/$(PACKAGE)/etc/webcleaner
  48.  
  49.  
  50. # Build architecture-independent files here.
  51. binary-indep: build install
  52. #    dh_testversion 1.1.17
  53.     dh_testdir
  54.     dh_testroot
  55.     dh_movefiles --sourcedir=debian/$(PACKAGE) -pwebcleanerconf \
  56.             usr/sbin/webcleanerconf
  57.     dh_installdebconf
  58.     dh_installdocs
  59.     dh_installexamples filtertest filtertest.html
  60. #    dh_installmenu
  61. #    dh_installemacsen
  62. #    dh_installpam
  63.     dh_installinit
  64. #    dh_installcron
  65.     dh_installmanpages webcleanerconf.1
  66.     dh_installmanpages -pwebcleanerconf webcleaner.1
  67. #    dh_installinfo
  68. #    dh_undocumented webcleaner.1
  69. #    dh_undocumented -pwebcleanerconf webcleanerconf.1
  70.     dh_installchangelogs 
  71.     dh_link
  72.     dh_strip
  73.     dh_compress
  74.     dh_fixperms
  75.     # You may want to make some executables suid here.
  76. #    dh_suidregister
  77. #    dh_makeshlibs
  78.     dh_installdeb
  79. #    dh_perl
  80. #    dh_shlibdeps
  81.     dh_gencontrol
  82.     dh_md5sums
  83.     dh_builddeb
  84.  
  85. # Build architecture-dependent files here.
  86. binary-arch: build install
  87. # We have nothing to do by default.
  88.  
  89. binary: binary-indep binary-arch
  90. .PHONY: build clean binary-indep binary-arch binary install configure
  91.