Núcleo principal do Programador de tarefas

Programador de tarefas

Pode utilizar o Programador de tarefas para agendar a execução de comandos, programas ou scripts a horas específicas:

  • Antes de utilizar o Programador de tarefas, consulte Lista de verificação.
  • Para obter ajuda relativamente a tarefas específicas, consulte Como.
  • Para obter informações genéricas, consulte Conceitos.
  • Para obter instruções com vista à resolução de problemas, consulte Resolução de problemas.


Lista de verificação do Programador de tarefas

Lista de verificação

A tabela que se segue enumera as acções mais frequentemente efectuadas com o Programador de tarefas. Para obter uma lista completa das instruções do Programador de tarefas, consulte Como.

Passo | Referência
Para poder agendar a execução de uma tarefa, terá primeiro de adicionar a tarefa. | Agendar uma nova tarefa
Uma vez criadas as tarefas agendadas, poderá modificar o programa, a agenda ou as especificidades de uma tarefa em particular. | Modificar uma tarefa agendada
Todas as arefas agendadas cuja utilidade esteja ultrapassada poderão ser removidas em definitivo. | Remover uma tarefa agendada
Na eventualidade de se registar o início de uma tarefa agendada enquanto está a utilizar o computador, poderá parar a tarefa e, em seguida, reiniciá-la mais tarde. | Parar uma tarefa agendada presentemente em execução
Poderá parar ou desactivar temporariamente a execução de todas as tarefas agendadas e, em seguida, retomá-las mais tarde. | Desactivar temporariamente todas as tarefas agendadas


Como...

  • Agendar tarefas
  • Gerir o Programador de tarefas


Agendar tarefas
  • Iniciar o Programador de tarefas
  • Agendar uma nova tarefa
  • Modificar uma tarefa agendada
  • Remover uma tarefa agendada
  • Parar uma tarefa agendada presentemente em execução
  • Executar uma tarefa imediatamente


Iniciar o Programador de tarefas

Para iniciar o Programador de tarefas

  • Pode iniciar o Programador de tarefas clicando duas vezes em O meu computador e, em seguida, clicando duas vezes em Tarefas agendadas.
  • Clique duas vezes em Tarefas agendadas e, em seguida, clique duas vezes em Adicionar tarefa agendada para abrir o assistente Tarefa agendada, que o ajudará a agendar uma tarefa.


Agendar uma nova tarefa

Para agendar uma nova tarefa
  1. Inicie o Programador de tarefas.
  2. Clique duas vezes em Adicionar tarefa programada.
  3. Siga as instruções indicadas no assistente Adicionar tarefa programada.

Notas

  • Se pretender configurar definições avançadas para a tarefa, seleccione a caixa de verificação Abrir propriedades avançadas da tarefa quando clicar em 'Concluir' que se encontra no último ecrã do assistente.
  • Para fazer com que uma tarefa seja repetidamente executada sempre que é iniciada, seleccione a caixa de verificação Abrir propriedades avançadas da tarefa quando clicar em 'Concluir' que se encontra no último ecrã do assistente e, em seguida, clique no separador Agenda e clique em Avançadas.
  • Se o programa da tarefa requerer parâmetros, seleccione a caixa de verificação Abrir propriedades avançadas da tarefa quando clicar em 'Concluir' no último ecrã do assistente e, em seguida, clique no separador Tarefa e especifique-os em Executar, a seguir ao caminho da tarefa.
  • Certifique-se de que a data e hora do sistema estão certas. O Programador de tarefas baseia-se nessa informação para executar as tarefas agendadas. Para verificar ou alterar a data e hora, clique duas vezes na hora na barra de tarefas.


Modificar uma tarefa agendada

Para modificar uma tarefa agendada
  1. Inicie o Programador de tarefas.
  2. Clique com o botão direito do rato na tarefa que deseja modificar e, em seguida, clique em Propriedades.
  3. Efectue um ou mais dos seguintes procedimentos:
    • Para alterar o programa que deseja executar, na caixa Executar, escreva o caminho para o novo programa.
    • Para alterar a agenda da tarefa, clique no separador Agenda.
    • Para personalizar as definições da tarefa, clique no separador Definições.

Notas

  • Se alterar a conta de utilizador ou o programa que está a ser executado, terá de indicar a palavra-passe da conta de utilizador.
  • Se o programa da tarefa requerer opções da linha de comandos, especifique-as na caixa Executar, a seguir ao caminho da tarefa.
  • Se o caminho para o programa da tarefa incluir espaços, coloque todo o caminho da tarefa entre aspas (").
  • Certifique-se de que a data e hora do sistema estão certas. O Programador de tarefas baseia-se nessa informação para executar as tarefas agendadas. Para verificar ou alterar estas informações, clique duas vezes no indicador de hora na barra de tarefas.


Remover uma tarefa agendada

Para remover uma tarefa agendada
  1. Inicie o Programador de tarefas.
  2. Clique com o botão direito do rato na tarefa que pretende remover e, em seguida, clique em Eliminar.

Notas

  • A remoção de uma tarefa agendada apenas remove a agenda da lista de agendas. O ficheiro de programa não é removido da unidade do disco rígido.
  • Também pode remover uma tarefa agendada premindo a tecla DELETE.


Parar uma tarefa agendada presentemente em execução

Para parar uma tarefa agendada presentemente em execução
  1. Inicie o Programador de tarefas.
  2. Clique com o botão direito do rato na tarefa que deseja parar e, em seguida, clique em Terminar tarefa.

Notas

  • Se uma tarefa agendada iniciar outro programa, este comando apenas pára a tarefa agendada original, não pára a segunda tarefa.
  • Para reiniciar uma tarefa interrompida, clique com o botão direito do rato na mesma e, em seguida, clique em Executar.


Executar uma tarefa imediatamente

Para executar uma tarefa imediatamente
  1. Inicie o Programador de tarefas.
  2. Clique com o botão direito do rato na tarefa que deseja iniciar e, em seguida, clique em Executar.

Notas

  • Pode parar a tarefa clicando em Terminar tarefa no menu Ficheiro.
  • Se uma tarefa devia ter sido executada e não foi, no menu Avançadas, clique em Ver registo para examinar o registo da tarefa.


Gerir o Programador de tarefas
  • Ver um registo das tarefas agendadas efectuadas
  • Ver tarefas agendadas em computadores remotos
  • Desactivar temporariamente todas as tarefas agendadas
  • Desactivar o Programador de tarefas
  • Definir a AT Service Account


Ver um registo das tarefas agendadas efectuadas

Para ver um registo das tarefas agendadas efectuadas
  1. Inicie o Programador de tarefas.
  2. No menu Avançadas, clique em Ver registo.


Ver tarefas agendadas em computadores remotos

Para ver tarefas agendadas em computadores remotos
  1. No Ambiente de Trabalho, clique duas vezes em Vizinhança na rede.
  2. Clique no computador em que deseja ver as tarefas agendadas.
  3. Clique em Tarefas agendadas.

Notas

  • Só poderá ver as tarefas de um computador remoto que tenha o Windows instalado se for um administrador desse computador remoto.
  • Só poderá editar tarefas num computador remoto que tenha o Windows instalado se esse computador remoto tiver software de registo remoto instalado e partilhar a partilha x$, em que x é o disco rígido onde reside a pasta Tarefas agendadas. O computador com o Windows tem também de listar especificamente a sua conta de utilizador como tendo acesso de registo remoto. Pode especificar que utilizadores têm acesso de registo remoto a um computador com o Windows clicando duas vezes no ícone Palavras-passe no Painel de controlo.


Desactivar temporariamente todas as tarefas agendadas

Para desactivar temporariamente todas as tarefas agendadas
  1. Inicie o Programador de tarefas.

  2. No menu Avançadas, clique em Interromper o 'Programador de tarefas'.

Notas

  • Este comando revela-se útil se estiver a executar outro programa (por exemplo, um jogo) ou a instalar software e não quiser que sejam executadas tarefas agendadas ao mesmo tempo.
  • As tarefas que deveriam ser executadas durante o tempo em que o Programador de tarefas está em pausa só serão executadas na hora agendada seguinte.
  • Para retomar as agendas de todas as tarefas, no menu Avançadas, clique em Retomar o 'Programador de tarefas'.


Desactivar o Programador de tarefas

Para desactivar o Programador de tarefas
  1. Inicie o Programador de tarefas.
  2. No menu Avançadas, clique em Parar de utilizar o 'Programador de tarefas'.

Nota

  • Se o Programador de tarefas for desactivado, as tarefas agendadas deixarão de ser executadas e o Programador de tarefas não será iniciado automaticamente da próxima vez que o Windows for iniciado.


Definir a AT Service Account

Para definir a AT Service Account
  1. Inicie o Programador de tarefas.
  2. No menu Avançadas, clique em At Service Account.
  3. Clique em This Account e, em seguida, escreva a conta de utilizador que irá executar as tarefas agendadas utilizando o comando at.
  4. Em Password e Confirm Password, escreva a palavra-passe correcta da conta de utilizador.

Notas

  • O serviço AT só está disponível no Windows NT.
  • Como alternativa, poderá clicar em System Account. Se o fizer, o Programador de tarefas executará tarefas do comando at utilizando a conta LocalSystem, que requer direitos administrativos.

  • A conta de utilizador que especificar tem de ter as permissões adequadas para executar todas as tarefas que agendar utilizando o comando at. Por exemplo, se agendar programas que só podem ser executados por administradores, a conta de utilizador que especificar terá de ser uma conta de administrador.


Conceitos do Programador de tarefas

Conceitos

Esta secção fornece informações genéricas sobre o Programador de tarefas:

  • Introdução ao Programador de tarefas
  • Utilizar o Programador de tarefas
  • O Programador de tarefas e o comando At
  • O Programador de tarefas e a segurança
  • Resolução de problemas


Introdução ao Programador de tarefas

Mediante a utilização do Programador de tarefas, poderá agendar tarefas (como, por exemplo, o desfragmentador de disco) para serem executadas de acordo com as suas necessidades. O Programador de tarefas é iniciado sempre que o Windows é iniciado, sendo executado em segundo plano.

Com a ajuda do Programador de tarefas, poderá:

  • Agendar uma tarefa para execução diária, semanal, mensal ou em determinadas alturas, (como, por exemplo, o arranque do sistema).
  • Alterar a agenda de uma tarefa.
  • Parar uma tarefa agendada.
  • Personalizar a forma como uma tarefa é executada na hora agendada.


Utilizar o Programador de tarefas

O sistema operativo Windows instala o Programador de tarefas automaticamente. Para utilizar o serviço de agendamento, clique duas vezes na pasta Tarefas agendadas em O meu computador.

Pode adicionar tarefas clicando duas vezes em Adicionar tarefa agendada, que dá início ao assistente Tarefa agendada. Poderá adicionar tarefas arrastando scripts, programas ou documentos do Explorador do Windows ou do Ambiente de Trabalho para a janela Tarefas agendadas.

Pode, igualmente, utilizar o Programador de tarefas para modificar, eliminar, desactivar ou parar as tarefas agendadas, para ver um registo das tarefas agendadas efectuadas ou para ver tarefas que estejam agendadas num computador remoto.

Para obter instruções detalhadas sobre como utilizar o Programador de tarefas, consulte Como.

Utilizações de eleição do Programador de tarefas

No sistema operativo Windows, poderá utilizar o Programador de tarefas para agendar a execução de qualquer aplicação. Para tirar o máximo partido do Programador de tarefas, certifique-se de que a data e hora do sistema estão certas antes de adicionar uma tarefa.


Utilizar o Programador de tarefas e o comando at

O Programador de tarefas e o comando At

Para além de poder utilizar o Programador de tarefas, poderá igualmente utilizar o comando at para executar tarefas automaticamente.

O Programador de tarefas não é o mesmo que o comando at, mas os dois funcionam em conjunto. Quando agenda uma tarefa utilizando o comando at, esta aparece na lista de tarefas da janela do Programador de tarefas.

Pode utilizar o programador de tarefas para modificar as propriedades de uma tarefa agendada utilizando o comando at. No entanto, se o fizer, terá de continuar a utilizar o Programador de tarefas para aceder à tarefa. Deixará de poder ter acesso à mesma através do comando at.

Para especificar a conta de utilizador que irá executar as tarefas agendadas com o comando at, em O meu computador, clique em Tarefas agendadas e, no menu Avançadas, clique em AT Service Account.

Nota

  • O serviço AT só está disponível no Windows NT.


A segurança do Programador de tarefas

O Programador de tarefas e a segurança

No Programador de tarefas, poderá configurar a segurança mediante a atribuição de um nome de utilizador e palavra-passe a uma tarefa em particular. Uma vez definidos o nome de utilizador e a palavra-passe, a tarefa não poderá ser cancelada nem eliminada por outro utilizador.

Notas

  • Esta função de segurança só está disponível no Windows NT.
  • Terá de indicar um nome de utilizador no assistente Tarefa agendada para poder continuar o agendamento de uma tarefa. Não são necessárias palavras-passe.
  • Pode alterar ou definir uma nova palavra-passe seleccionando a caixa de verificação Abrir propriedades avançadas da tarefa quando clicar em 'Concluir' no último ecrã do assistente.


Resolução de problemas do Programador de tarefas

Resolução de problemas relacionados com o Programador de tarefas

Se a tarefa agendada não for executada quando é esperado, clique com o botão direito do rato na mesma na lista de tarefas e, em seguida, clique em Propriedades. No separador Tarefa, certifique-se de que a caixa de verificação Activada está seleccionada. No separador Agenda, certifique-se de que a agenda está correctamente definida.

Se o programa de uma tarefa não for executado correctamente, poderá ter de adicionar opções da linha de comandos. Para saber mais sobre um programa em particular e respectivas opções da linha de comandos, tente um dos seguintes procedimentos:

  • Se o programa tiver ajuda online, consulte essa ajuda.

  • Na linha de comandos, escreva o seguinte: (em que programa é nome do programa)

    • programa /?


Componente do Windows NT não instalado

Não foi possível instalar este programa.

Razões possíveis:

    • Foi removido por um administrador de sistema.
    • O administrador de sistema alterou a política associada ao ficheiro.
    • O programa não está instalado no computador.
    • Foi acidentalmente eliminado.
    • O ficheiro está danificado.

Se o seu computador é controlado por um administrador de sistema, tem de entrar em contacto com o mesmo para saber por que razão não consegue iniciar o programa.