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PowerQuest® Server License Agreement

IMPORTANT: Read this before using your copy of PowerQuest software.

This document is a legal agreement between you (an individual or business) and PowerQuest Corporation (PowerQuest). Use of the 
software indicates your acceptance of these terms. As used in this License Agreement, the term "Software" means the software 
included on the CD or disk media provided with this License Agreement. The term "Software" does not include any software that is 
covered by a separate license offered or granted by a person other than PowerQuest.

IF YOU DO NOT AGREE TO THESE TERMS AND CONDITIONS, EITHER DESTROY OR RETURN, INTACT, THE 
SOFTWARE PACKAGE, CONTAINING THE CD OR DISK MEDIA, TOGETHER WITH THE OTHER COMPONENTS OF 
THE PRODUCT TO THE PLACE OF PURCHASE FOR A REFUND OF THE PURCHASE PRICE.

1. PROPRIETARY RIGHTS. The Software and any accompanying documentation are the proprietary products of PowerQuest or 
its licensors and are protected under national laws and international treaty provisions. Ownership of the Software and all copies, 
modifications, translations, and merged portions thereof shall at all times remain with PowerQuest or its licensors.

2. GRANT OF LICENSE. The Software and accompanying documentation are being licensed to you, which means you have the 
right to use the Software only in accordance with this License Agreement. The Software is considered in use on a computer when it 
is loaded into temporary memory or installed into permanent memory. This License may not be assigned or otherwise transferred 
without prior written consent from PowerQuest, and any unauthorized transfer is null and void.

PERSONAL LICENSE. This license is personal to you. You may not sublicense, lease, sell, or otherwise transfer the Software or 
any of the accompanying documentation to any other person. You may use the Software only for your own personal use if you are 
an individual, or for your own internal business purposes if you are a business. If you are a service bureau, integrator, value added 
reseller, or other type of service provider and wish to use this software on your clients’ computers, you must purchase a 
Configuration License.

SERVER-SPECIFIC LICENSE. Each permitted copy of the Software may be used only in connection with one network server 
owned or leased by you. Once a copy of the Software has been used on a server, it may not be used on any other server. If the 
Software is made available on a network, it may be accessed only by ONE specific computer. Once the Software has been accessed 
by ONE specific computer it may not be used on any additional computers without purchasing additional licenses.

NUMBER OF COPIES LICENSED. You are authorized to use ONLY a single copy of the Software on the number of servers for 
which you have purchased a license as indicated on the accompanying license certificate. All copies of the Software must include 
the copyright, trademark, and patent notices.

BACKUP COPY. In addition to any copies authorized under this license agreement, you may make a single copy of the Software 
solely for backup purposes.

UPDATES, UPGRADES AND SUPPORT. You are entitled to receive complimentary technical support as outlined in the 
Software documentation. You are entitled to receive Software updates (updates are indicated by version number changes to the 
right side of the decimal) in accordance with PowerQuest policies as announced from time to time on terms comparable to those 
offered to other users of the Software under the server licenses.

TERM. This license is effective from your date of purchase and shall remain in force until terminated. You may terminate the 
license and this License Agreement at any time by destroying the Software and the accompanying documentation, together with all 
copies in any form.

3. NONPERMITTED USES. Without the express prior written permission of PowerQuest, you may not (a) use, copy, modify, 
alter or transfer, electronically or otherwise, the Software or documentation except as expressly permitted in this License 
Agreement, or (b) translate, reverse program, disassemble, decompile, or otherwise reverse engineer the Software.

4. EXPORT CONTROLS. Certain uses of the Software by you may be subject to restrictions under U.S. regulations relating to 
exports and ultimate end uses of computer software. You agree to fully comply with all applicable U.S. laws and regulations, 
including but not limited to the Export Administration Act of 1979 as amended from time to time and any regulations promulgated 
thereunder.

5. U.S. GOVERNMENT RESTRICTED RIGHTS. If you are acquiring the Software on behalf of any unit or agency of the 
United States Government, the following provision applies:  It is acknowledged that the Software and the documentation were 
developed at private expense and that no part is in the public domain and that the Software and documentation are provided with 
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) 
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of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/Manufacturer is 
PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

6. LIMITED WARRANTY. (a) PowerQuest warrants to you, the original end user, (i) that the Software, other than third-party 
software, will perform substantially in accordance with the accompanying documentation and (ii) that the Software is properly 
recorded on the disk media. This Limited Warranty extends for ninety (90) days from the date of purchase. PowerQuest does not 
warrant any third-party software that is provided with the Software, but PowerQuest agrees to pass on to you any warranties of the 
owner or licensor to the extent permitted by the owner or licensor. (b) This Limited Warranty does not apply to any Software that 
has been altered, damaged, abused, mis-applied, or used other than in accordance with this license and any instructions included on 
the Software and the accompanying documentation. (c) PowerQuest's entire liability and your exclusive remedy under this Limited 
Warranty shall be the repair or replacement of any Software that fails to conform to this Limited Warranty or, at PowerQuest's 
option, return of the price paid for the Software. PowerQuest shall have no liability under this Limited Warranty unless the 
Software is returned to PowerQuest or its authorized representative, with a copy of your receipt, within the warranty period. Any 
replacement Software will be warranted for the remainder of the original warranty period or 30 days, whichever is longer. (d) THIS 
WARRANTY IS IN LIEU OF AND EXCLUDES ALL OTHER WARRANTIES NOT EXPRESSLY SET FORTH HEREIN, 
WHETHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, OR WARRANTIES ARISING FROM USAGE OF 
TRADE OR COURSE OF DEALING. (e) THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS; YOU MAY HAVE 
OTHERS WHICH VARY FROM STATE TO STATE. (f) Your failure to return the enclosed registration card or complete the 
electronic registration included with the Software may result in PowerQuest's inability to provide you with updates to the Software, 
and you assume the entire risk of performance and result in such an event.

7. LIMITATION OF LIABILITY. IN NO EVENT SHALL POWERQUEST'S LIABILITY RELATED TO ANY OF THE 
SOFTWARE EXCEED THE LICENSE FEES ACTUALLY PAID BY YOU FOR THE SOFTWARE. EXCEPT FOR A RETURN 
OF THE PURCHASE PRICE UNDER THE CIRCUMSTANCES PROVIDED UNDER THE LIMITED WARRANTY, 
NEITHER POWERQUEST NOR ITS SUPPLIERS SHALL IN ANY EVENT BE LIABLE FOR ANY DAMAGES 
WHATSOEVER ARISING OUT OF OR RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE, 
INCLUDING BUT NOT LIMITED TO DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, 
AND DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, 
OR OTHER PECUNIARY LOSS, EVEN IF POWERQUEST CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES, WHETHER SUCH LIABILITY IS BASED ON CONTRACT, TORT, WARRANTY, OR ANY OTHER 
LEGAL OR EQUITABLE GROUNDS. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION 
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO 
YOU.

8. NO WAIVER. Any failure by either party to this agreement to enforce a specific part of the agreement in a specific situation is 
not a waiver of rights under the agreement. The party may still enforce the rest of the agreement in that situation and may still 
enforce some or all of the agreement in other situations.

9. This License Agreement constitutes the entire agreement between you and PowerQuest pertaining to its subject matter. This 
License Agreement is governed by the laws of the State of Utah. Any litigation arising from this license will be pursued only in the 
state or federal courts located in the State of Utah. Even if part of the agreement is held invalid, the rest of the agreement is still 
valid, binding and enforceable.

Should you have any questions concerning this Agreement, or if you desire to contact PowerQuest Corporation for any reason, 
please write:  PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

© 1994-2000, PowerQuest Corporation. All rights reserved. The Software is protected by U.S. patents, with other patents pending 
in the U.S.A. and elsewhere. PowerQuest is a registered trademark of PowerQuest Corporation.
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About This Guide

This user guide can help you set up and use PowerQuest® ServerMagic™.

The ServerMagic CD includes a searchable PDF version of this manual in the 
English/Docs folder. The filename is SM4_NT.PDF. PowerQuest recommends that you 
have Adobe® Acrobat® version 4.0 or later for best viewing quality. You can download the 
current version of Acrobat for free from the Adobe web site, www.adobe.com. In the PDF 
version of this manual, you can click cross-references (including page numbers in the 
table of contents and index) to jump to the relevant material. You can also click references 
to web sites to start your browser and go to the web site. The hand pointer in Acrobat 
changes to a pointing finger when it is located over text that is linked to other material.

The user guide consists of the following sections: 

• The Introduction provides an overview of ServerMagic and includes a list of features 
that are new for version 4.0.

• Chapter 1: Getting Started includes system requirements, step-by-step instructions 
for installing and starting ServerMagic, and information for system administrators.

• Chapter 2: ServerMagic Basics includes a description of the main window, an 
overview of the process you use for making changes with ServerMagic, and steps for 
tasks that are common to all ServerMagic operations.

• Chapter 3: Completing Disk Operations provides information about and 
step-by-step instructions on using the Operations menu options, such as Resize/Move, 
Create, and Format.

• Chapter 4: Completing Advanced Operations explains how to use advanced 
partitioning operations, such as setting an active partition and resizing clusters.

• Chapter 5: Managing Volumes explains features that make it easier for you to 
move, copy, or change volumes on your server.

• Chapter 6: Converting Partitions provides step-by-step instructions on converting 
from one file system to another, for example, converting FAT to FAT32.

• Chapter 7: Automating Tasks explains the wizards you can use to perform some 
common tasks and includes an overview of ServerMagic scripting.

• Chapter 8: Remote Agent explains how you can perform ServerMagic operations 
across the wire to a remote server.

• Chapter 9: Creating a New Boot Drive explains how to use ServerMagic when you 
replace a disk on your server or add another disk to your server.

http://www.adobe.com
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• Appendix A: Using ServerMagic with Other Programs provides information 
about using ServerMagic with programs such as operating system boot utilities and 
virus protection software.

• Appendix B: Troubleshooting provides answers to problems you may encounter 
while using ServerMagic and describes error messages and their solutions.

• Appendix C: PowerQuest Technical Support provides information on various 
technical support options.

• The Index helps you locate topics discussed in the user guide.
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Introduction

What Is ServerMagic?

With ServerMagic™, you can quickly and easily create partitions on your hard 
disks for storing valuable information such as data files, applications, and 
operating systems. Storing information in separate partitions helps you organize 
and protect your data and reclaim wasted disk space.

ServerMagic enables you to secure your data by physically separating it from 
other files. Separate partitions also make backups easy.

In addition to powerful partitioning features, ServerMagic offers a variety of 
other options. For instance, you can perform partitioning operations and view the 
changes that will be made before applying them to your system. Additionally, 
you can view comprehensive information about your hard disk geometry and 
your hardware system, and you can resize root directories to make room for more 
long filenames.

New Features

PowerQuest ServerMagic 4.0 for Windows NT® includes the following new 
features: 

• Volume-level operations

• Across-the-wire support for performing some operations on a remote server

• Ability to undelete partitions
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• Ability to merge FAT and FAT32 partitions

• Ability to split partitions

• Improved interface: Explorer-like tree view of the disks and volumes on your server, 
ability to display “maps” of multiple disks, color key to indicate file system type, 
indicators for the 2 GB boot boundary and 1024 cylinder boundary, used and unused 
space indicators within partitions

• More options for converting file systems for a partition: NTFS to FAT, NTFS to 
FAT32, primary to logical, and logical to primary

• Wizards for common tasks: create new partition, merge partitions, redistribute free 
space, resize partitions, and copy partitions.

• Ability to view and modify a list of pending operations

• Added automatic error-fixing

• Improved user-interface for scripting
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Getting Started
This chapter includes the following information:

• ServerMagic System Requirements

• Installing ServerMagic on a Windows NT Server

• Creating ServerMagic Rescue Disks

• Before Running ServerMagic

• Running ServerMagic

• Setting a Password for ServerMagic

• Uninstalling ServerMagic
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ServerMagic System Requirements

To run under Windows® 2000 Server, ServerMagic requires: Pentium-compatible 133 
MHz or faster processor, 128 MB RAM, 54 MB hard drive space, a high-density 3.5-inch 
diskette drive, a CD-ROM or DVD-ROM drive, and a VGA-compatible monitor.

Installing ServerMagic on a Windows NT Server

IMPORTANT! ServerMagic must be installed on a local drive, not on a network drive.

1 Insert the ServerMagic CD into your CD-ROM drive.

2 If the installation program does not start automatically, click Start ➤ Run on the 
Windows taskbar.

3 Type drive:\AUTORUN, where drive is the drive letter of your CD-ROM drive.

4 Click Install, and follow the on-screen installation instructions.

ServerMagic for Windows ServerMagic rescue disks

Processor Intel 486 DX or above (33 
MHz)

Intel 486 DX or above (33 MHz)

RAM 32 MB minimum supported* 32 MB*

Hard-disk 
space

54 MB 1.4 MB (if installing to hard disk 
instead of running from floppy 
disks)

Operating 
system

Windows NT 4.0 Server with 
SP4 applied

MS-DOS 6.2 or compatible DOS 
(Caldera DOS is included on the 
rescue disks.)

3.5-inch 
diskette drive

High-density High-density

CD-ROM drive 4 x None

Monitor VGA-compatible VGA-compatible

* More memory may be required to manipulate FAT32 and NTFS partitions on hard 
disks larger than 4 GB.
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Creating ServerMagic Rescue Disks

You can create rescue disks to run ServerMagic from if your operating system fails or your 
computer becomes unbootable. See “Running ServerMagic from Rescue Disks” on page 
20 for information about how the rescue disks vary from the Windows NT executable.

You must have two blank 1.44 MB floppy disks available before you begin this procedure 
(three disks for double-byte languages).

1 You can create rescue disks three ways:

2 Insert a blank formatted 1.44 MB disk into your 3.5-inch disk drive and click OK.

3 Follow the prompts and the instructions on the progress bar (located at the bottom of 
the window).

The rescue disks contain the following files:

If you create rescue disks for a double-byte language, the third disk includes fonts.

To create rescue 
disks from: Do this:

ServerMagic CD Open the DOS-OS2 folder on the ServerMagic CD. Type 
MAKEDISK A:, where A: is the drive letter for your floppy 
disk drive.

ServerMagic 
main window

Click Tools ➤ Create Rescue Disks on the menu bar.

Windows Click Start ➤ Programs ➤ PowerQuest ServerMagic 4.0 
➤ Create Rescue Disks.

ServerMagic 4.0 Disk 1 ServerMagic 4.0 Disk 2

• Partinfo.exe (utility program)
• PTEDIT (utility program)
• Keyb.com
• Mode.com
• Miscellaneous system files

• Mouse.com
• SMHelp.dat (help file)
• SMagic.exe
• SMagic.ovl
• SMagic.pqg
• PQPB.rtc
• Rescue.txt
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If you run out of space on the first rescue disk as a result of adding network, SCSI, or 
CD-ROM drivers to your boot sequence, you can delete the following files from the disk: 
chkdsk.com, fdisk.exe, ptedit.exe, and partinfo.exe. We recommend that you delete the 
files in that order, freeing up only the space that you need to accommodate additional files. 
These files are included in the Utilities folder on the ServerMagic CD where you can 
access them later, if necessary.

If you use an international keyboard or character set, you will need to modify the 
AUTOEXE2.BAT and CONFIG.SYS files on the rescue disks. Refer to “Using 
International Keyboards” on page 38 for additional information.

Before Running ServerMagic

Before the start of a ServerMagic session, you should always complete the following 
items:

• Apply the most recent Windows NT/2000 service pack

Make sure you have applied the most recent service pack when running either 
Windows NT or Windows 2000.

• Back up your hard disk

You should back up your hard disk before using ServerMagic. While ServerMagic 
has been thoroughly tested to be safe and reliable, other factors, (such as power 
failures, operating system bugs, and hardware defects), can put your data at risk. 
Before using any utility that makes extensive changes to your hard disk, you should 
back up your data.

• Back up BOOT.INI

Before you modify the hard disk that contains the boot partition, back up the 
BOOT.INI file. If the disk contains the boot partition, the BOOT.INI file may be 
changed.

• Shut down all applications

You should not run ServerMagic with other applications, including virus scanners 
and server-based computing tools.

• Run Check for Errors option regularly

Before you manipulate any partitions or volume sets, you should always click 
Operations ➤ Check for Errors. Although ServerMagic checks partitions and 
volume sets for errors and can repair minor problems, more serious errors cause 
ServerMagic to abruptly end an operation. 
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Check for Errors can find and fix most common errors you will encounter. The Check 
for Errors option is dimmed (unavailable) on the Windows NT boot partition because 
there are always open files. For this partition, click Operations ➤ Windows 
CheckDisk. If errors are found, run CHKDSK /F from a command prompt to fix 
them before running ServerMagic.

• Take the server offline

Having connected clients to the server increases the likelihood that ServerMagic will 
have to reboot the computer to perform an operation. You may want to consider 
scheduling ServerMagic sessions for off hours and notify clients that the system will 
be unavailable during that time.

Or, if you must make changes during regular business hours and there are users 
connected to the server, ServerMagic will give you the option to disconnect all users 
from the server.

• Create a Windows NT boot disk

The boot disk lets you boot Windows NT if your BOOT.INI file becomes corrupt. For 
information about creating a boot disk, refer to the Microsoft Knowledge Base on the 
Internet, article Q119467, "Creating a Boot Disk for an NTFS or FAT partition."

• Connect to a UPS (Uninterruptible Power Supply)

ServerMagic will not be able to recover if a power failure occurs during 
repartitioning. By having the server and all connected hard drives protected by UPSs, 
you can avoid the problems caused by power failures.

Running ServerMagic

IMPORTANT! ServerMagic must be run from a local drive, not from a network drive.

1 Click Start ➤ Programs ➤ PowerQuest ServerMagic 4.0 ➤ ServerMagic 4.0.

If you attempt to run ServerMagic on a Windows 2000 machine where the boot partition 
(the partition where Windows 2000 is installed) is on a dynamic disk, you will receive the 
following error message: “Init failed: Error 183. Unable to identify the Windows 
partition.” To remedy this problem, you must place the boot partition on a basic disk.
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Running ServerMagic from Rescue Disks

Create Rescue Disks is a wizard that helps you create diskettes you can use to boot your 
computer and run ServerMagic for DOS (SMAGIC.EXE). Rescue disks are useful when:

• You have hidden the partition where ServerMagic is installed and need to run 
ServerMagic to unhide the partition.

• You have accidently converted a partition to FAT32 and your operating system does 
not support FAT32, so your computer will not boot. (You can use the rescue disks to 
convert the partition back to FAT.)

• Other occasions arise when you do not have access to ServerMagic on the CD or hard 
drive.

When you boot your computer from the first rescue disk, SMAGIC automatically runs. 
You must insert the second rescue disk when prompted. The main screen appears different 
when you run ServerMagic from rescue disks than it does when you run ServerMagic 
from Windows. See “Rescue Disk Main Window” on page 29.

If you run ServerMagic from the rescue disks, you will not have access to the following 
features:

• Volume management (Volume Set view)
• Remote Agent (across the wire)
• Split partitions
• Shred partitions
• Undelete partitions
• Undo last change
• Wizards

Before you run ServerMagic from DOS, you should:

• Turn off third-party disk caches.
• Deactivate/unload any TSR programs that access or modify partitions being changed.

Do not run ServerMagic from a compressed drive.

You cannot run ServerMagic on a Windows 2000 Server that is in hibernation. To use the 
rescue diskette, Windows 2000 must have been shut down normally.

Checking an NTFS partition with the DOS version of ServerMagic may take an unusually 
long time. Since ServerMagic performs checks both before and after the move, copy, and 
resize operations, these operations may be slower with the DOS version of ServerMagic 
than with the Windows version.
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IMPORTANT! The number of computers on which you can run the DOS-based version of 
ServerMagic is specified in your ServerMagic license agreement. Refer to 
your license agreement before using a rescue diskette.

Running a Script from the Rescue Disks

You can modify the rescue disks to run ServerMagic with a script file automatically.

1 Open the AUTOEXEC.BAT file on ServerMagic 4.0 Disk 1.

2 Edit the line that includes SMAGIC as follows, where SCRIPT.TXT is the name of 
the script file you want to execute:

SMAGIC /CMD=SCRIPT.TXT

IMPORTANT! Do not include a hard return at the end of the line that includes the 
SMAGIC command. Do not make any other modifications to the 
AUTOEXEC.BAT file.

3 Save the AUTOEXEC.BAT file.

4 Copy the AUTOEXEC.BAT file to ServerMagic 4.0 Disk 2.

The file must be identical on both disks, or ServerMagic will not function properly.

When you boot from the first disk, ServerMagic will execute the script file you 
specified. See “Scripting” on page 102 or the ServerMagic help.

Running ServerMagic Inside Windows Explorer 

1 From Windows, click Start ➤ Programs ➤ Windows Explorer.

The Exploring window appears.

2 Right-click on any drive object.

A quick menu appears.

3 Click ServerMagic 4.0.

The program loads, and the ServerMagic main window appears.

Running ServerMagic from My Computer

This option lets you start ServerMagic from My Computer.

1 Double-click on the My Computer icon.
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The My Computer menu appears.

2 Right-click on any drive object. 

A quick menu appears.

3 Click ServerMagic 4.0.

The program loads, and the ServerMagic main window appears.

You can also right-click on the My Computer icon to access the quick menu.

Setting a Password for ServerMagic

You can assign a password that must be entered before ServerMagic will start.

1 Click General ➤ Set Password.

The Set Password dialog box appears.

2 Type a new password, then press <Tab>.

3 Confirm the new password, then press <Tab>.

4 (Optional) Add a hint.

5 Click OK.

Each time you start ServerMagic, you will be prompted for a password before the program 
will run.
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Entering a Password

When you start ServerMagic and there is a password assigned, the Enter Password dialog 
appears.

1 Type the password assigned to ServerMagic.

You can click Hint to display a reminder. If you still cannot remember the password, 
refer to documentation for error 996 on page 138.

2 Click OK.

Changing a Password

1 Click General ➤ Set Password.

2 Type the old password, then press <Tab>.

3 Type the new password, then press <Tab>.

4 Confirm the new password, then press <Tab>.

5 (Optional) Change the hint.

6 Click OK.

Removing Password Protection

1 Click General ➤ Set Password.

2 Type the old password, and leave the remainder of the fields blank.

3 Click OK.

Uninstalling ServerMagic

1 On the Windows taskbar, click Start ➤ Settings ➤ Control Panel. 

2 Double-click Add/Remove Programs.
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3 Select ServerMagic 4.0.

4 Click Add/Remove.
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C H A P T E R2
ServerMagic Basics
This chapter includes the following information:

• ServerMagic Main Window

• Rescue Disk Main Window

• Process Overview

• Selecting a Hard Disk

• Selecting a Volume Set

• Selecting an Operation

• Undoing an Operation

• Viewing Pending Operations

• Applying Changes to Your System

• Supported File Systems

• Changing ServerMagic Preferences

• Using International Keyboards

• Getting Help
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ServerMagic Main Window

The main window includes an Explorer-like tree view of the disks or volumes on your 
server, a map of each disk or volume, and a list of the partitions on the selected disk or 
volume. You control whether the screen displays disks or volumes by clicking the Disks or 
Volume Sets tab in the Explorer pane.

The menu bar and a toolbar appear at the top of the window. The menu bar gives you 
access to all of ServerMagic’s features. When you choose a menu command, the status bar 
at the bottom of the screen shows what the command does. The toolbar gives you quick 
access to commonly used options. When the pointer is over a toolbar, the status bar shows 
what the button does.

Note that the main screen is different if you run ServerMagic from the rescue disks. See 
“Rescue Disk Main Window” on page 29.

Disk View

Menu Bar
Toolbar

Status Bar

Disks View

Partition Map 
(scrollable to 
display all 
disks)

Partition List

Wizards
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Volume View

Partition Information

The partition area displays information about the selected hard disk’s partitions. It consists 
of two areas: the partition map, which displays information graphically; and the partition 
list, which displays partition information in text form.

Partition Map 

The partition map shows the partitions approximately to scale. (You can also display disks 
by scale by clicking View ➤ Scale Disk Map.) Each partition is represented by a different 
color according to the file system it uses. If the selected hard disk contains logical 
partitions, the logical partitions are shown within an extended partition.

Each partition is color-coded to show the file system it uses and the used and unused space 
within the partition. Note that the operations you can perform on white (unformatted) or 
yellow (unknown) partitions are limited. A key at the bottom of the screen shows which 
file system each color represents.

The partition map also shows unallocated space (space not assigned to any partition).
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There are triangle indicators to mark the 2 GB boot boundary and the 1024 cylinder limit. 
The boundary markers can help you as you create, move, or resize partitions, so you will 
not make primary partitions unbootable by accident. For additional information about the 
boot boundaries, refer to “Understanding the BIOS 1024 Cylinder Limit” or 
“Understanding the 2 GB Boot Code Boundary” in the ServerMagic online help.

Partition List 

The partition list displays the following information about each partition: drive letter, 
volume label, file system type, size, amount of used and unused space, status, and whether 
the partition is a primary or logical partition.

Primary partition drive letters are flush left, followed by a colon and the volume name. 
Logical partition drive letters and volume labels are indented. An asterisk (*) appears in 
place of a drive letter for:

• Hidden partitions 
• Extended partitions 
• Partitions with file systems not supported by the active operating system
• Unallocated space 

The partition size, used space, and unused space values are displayed in megabytes.

A partition’s status can be:

• Active: The partition the computer boots from.

• Hidden: Under Windows NT, hidden partitions do not have a drive letter. Partitions 
can be hidden by the operating system (which may hide all primary partitions except 
the active one), or you can hide partitions with ServerMagic. Under Windows 2000, 
hidden partitions are allowed to have a drive letter.

• None: Partitions that are not active or hidden.

Wizards

To help you quickly and easily complete several common partitioning tasks, ServerMagic 
includes these wizards:

• Create new partition
• Redistribute free space
• Resize partitions
• Merge partitions
• Copy partition
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To start a wizard, click the wizard icon or choose a command on the Wizards menu. For 
more information about using the wizards, see “Wizard Overview” on page 100. 

You do not have access to the wizards if you run ServerMagic from the rescue disks.

Rescue Disk Main Window

The main screen appears different when you run from rescue disks than it does when you 
run ServerMagic from Windows NT.

• Menu bar — gives you access to all of ServerMagic’s features.

• Toolbar — gives you quick access to commonly used options.

• Partition information — provides both a visual and text description of the partitions 
on the disk.

• Status bar — shows you how many operations are pending; also includes a brief 
description of the currently selected option.

Menu Bar

Toolbar

Partition Map

Status Bar

Partition List
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Process Overview

To complete a task, follow this general process:

1 Select a hard disk and partition, or select a volume.

2 Select an operation and enter details about the changes you want to perform.

3 Apply changes to your system.

You can also perform some tasks using the wizards. Refer to “Automating Tasks” on page 
99 for information about the wizards.

Note that the steps for selecting a hard disk and partition or a volume are included in this 
chapter of the user guide. You must follow these steps before you can perform any 
operation within ServerMagic.

Selecting a Hard Disk

Before you can select a disk, you must click the Disks tab in the tree view or click View ➤ 
Disks. There are three ways to select a hard disk:

• In the tree view on the left side of the main window, click the icon for the disk. If the 
tree view is not displayed, click View ➤ Tree View.

• On the disk map, click the title bar for the disk. You may need to scroll through the 
disk map area if you have several hard disks on your server.

• From the Disks menu, choose the disk you want.

When you select a disk, its partitions display in the partition list in the main window.

Using ServerMagic with Removable Media

ServerMagic is not designed to work on removable media. PowerQuest technical support 
does not guarantee they will be able to resolve problems you encounter when partitioning 
removable media.

Windows 2000 Disks

Windows 2000 uses basic disks and dynamic disks. You cannot perform ServerMagic 
operations on dynamic disks.
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Selecting a Partition 

Before you select a partition, click the Disks tab in the tree view. There are three ways to 
select a partition:

• In the tree view on the left side of the main window, click the partition. If the tree 
view is not displayed, click View ➤ Tree View.

• On the disk map, click the partition. You may need to scroll through the disk map area 
if you have several hard disks on your server.

• In the partition list, click the partition.

The selected partition is highlighted in all three locations. 

If Remote Agent is running, you can select a partition on a remote server. See “Remote 
Agent” on page 103.

Selecting a Volume Set

Before you can select a volume set, you must click the Volume Sets tab in the tree view or 
click View ➤ Volume Sets. There are two ways to select a volume:

• In the tree view, click the volume.

• In the volume map, click the volume.

The segments for the selected volume display in the segment list.

The volume set must reside on a hard disk attached to a Windows NT 4.0 server. You 
cannot use ServerMagic to manipulate a volume set that was converted from Windows NT 
Server to Windows 2000 Server.

Selecting an Operation

After you have selected a partition or volume, you can select an operation using the 
toolbar, the context menu, the menu bar, or the keyboard. If an operation cannot be 
performed on the selected partition or volume, the operation appears dimmed on the menu.

• Click one of the operations buttons on the toolbar. 

When you place the pointer on a toolbar button, a pop-up window displays the 
button’s function.
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• In the partition map or partition list, right-click the partition or volume segment you 
want to change, then click the desired operation on the context menu.

• On the menu bar, click Operations, then choose the desired operation. 

• Press <Alt+O>, then type the underlined letter of the desired operation.

For more information about the items on the Operations menu, see Chapters 3 through 6 
of this user guide.

Undoing an Operation

There are three ways to undo or reverse the last operation performed:

• Click on the toolbar.

• Click General ➤ Undo Last Change on the menu bar.

• Press <Ctrl+Z>.

If you have performed an operation using a wizard, Undo Last will undo all the changes 
made by the wizard.

To discard all the changes performed and start over, click General ➤ Discard all 
Changes, or press <Ctrl+D>. 

Viewing Pending Operations

ServerMagic queues operations until you apply them. You can view the operations that are 
pending at any time.

1 Click Operations ➤ View Operations Pending.
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The Operations Currently Pending dialog appears.

From the list of pending operations, you can choose to undo the last change, discard 
all changes, apply all changes, or close the window.

If you are running ServerMagic from the rescue disks, you cannot modify pending 
operations from this window.

Applying Changes to Your System

As you complete tasks using the Operations menu, the partition map and partition list 
reflect the changes you have made. However, no changes physically take place on your 
system until you apply them. You can perform several operations and then apply all the 
changes at once.

You can tell when changes have been made but not yet applied to your system when the 
status box in the lower right corner of the main window indicates that operations are 
pending. If the wizard icons are displayed, the Apply Changes and Undo Last icons also 
display at the bottom of the window when there are operations pending.

To apply changes to your system, click General ➤ Apply Changes, or click  on the 
toolbar. If the wizard icons are displayed, you can also click the Apply Changes icon at 
the bottom of the window. If you have open files, ServerMagic may need to reboot your 
computer and apply the changes in boot mode.
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You can click Apply Changes ➤ Details to view a list of the operations that will be 
applied.

To discard the changes and start over, click General ➤ Discard All Changes. With the 
exception of being able to undelete some partitions, you cannot discard or undo changes 
after you have applied them.

Forcing Users to Log Off

Before ServerMagic can apply any changes from within the ServerMagic program, it must 
have exclusive use of the system disk drives (no users logged on). If any users are 
connected to the server, ServerMagic will prompt you to do one of the following when 
applying changes:

• Click Yes to automatically disconnect remote users from the system, disable future 
logons, and apply changes. Several services are stopped. After applying the changes, 
ServerMagic restarts the stopped services and remote users are again allowed access 
to the server.

The system administrator should notify users and allow them to log off before 
selecting Yes.

• Click No to stop the operation. ServerMagic will not apply changes or disconnect 
remote users.

• Click Ignore to apply changes without automatically disconnecting remote users.  
Under this condition, if ServerMagic cannot get control of the required drives or 
volumes, it will reboot your server to apply the changes in boot-mode.

Since Windows NT always has some open files, if you make changes to the partition 
containing the Windows NT operating system (or any partition which uses files from the 
Windows NT operating system) without logging off the users, you will need to reboot 
your system. However, if you make changes to a partition that does not share any 
Windows NT files, you do not need to log off remote users and your system will not need 
rebooting. For example, if you create a new partition in unallocated space, you do not need 
to log off the remote users before applying the change.

Administrative Shares

When you create, delete, move, format, merge, copy, or hide an NTFS or FAT partition, 
ServerMagic applies or deletes (depending on the function performed) administrative 
shares for the partition. This allows administrators remote access to the partition.
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Supported File Systems

IMPORTANT! ServerMagic does not generally support stripe sets, stripe sets with parity, 
or partitions located on disk mirror/duplex sets configured using Windows 
NT Disk Administrator. However, you can resize partitions that are part of 
a mirrored/duplexed set. On Windows 2000, ServerMagic supports 
standard partitions located on basic disk sets only.

ServerMagic supports the following partition types.

Partition 
Type Description

Extended The extended partition gets around the arbitrary four-partition limit 
for a disk. An extended partition is a container in which you can 
further divide your disk space by creating logical partitions. An 
extended partition does not directly hold data. You must create logical 
partitions within the extended partition to store data.

Extended-X An extendedx partition functions like an extended partition but is not 
limited to the first 1024 cylinders on a drive.

Linux kernels below 2.2 do not support Extended-X partitions.

FAT Uses file allocation table (FAT) and clusters. The FAT file system is 
used by DOS, Windows 3.x, and most Windows 95 installations. A 
FAT partition is also accessible by Windows 98/Me/NT/2000 and by 
OS/2.

FAT16x FAT16x is a proprietary file system developed by Microsoft to enable 
FAT partitions beyond 1024 cylinders (~8GB).

FAT32 FAT32 is an enhancement of the FAT file system. It uses 32-bit file 
allocation table entries, rather than the 16-bit entries used by the FAT 
system, so FAT32 supports larger disk or partition sizes (up to 2 
terabytes). The minimum size for a FAT32 partition is 256 MB.

A FAT32 partition is only accessible by Windows 95 OSR2 (version 
4.00.950B), Windows 98/Me/2000. However, DOS, Windows 3.x, 
Windows NT 3.51/4.0, earlier versions of Windows 95, and OS/2 do 
not recognize FAT32 and cannot use files on a FAT32 partition.
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FAT32x FAT32x is a proprietary file system developed by Microsoft to enable 
FAT32 partitions beyond 1024 cylinders (~8GB). Windows 95 OSR2, 
and Windows 98/Me/2000 may use FAT32x partitions.

HPFS The High Performance File System (HPFS) is accessible only by 
OS/2, older versions of Windows NT (v. 3.51 and earlier), or versions 
of Windows NT that were upgraded from v. 3.51 or earlier. 

HPFS/386 HPFS/386 is a file system used by OS/2 Advanced Server. The only 
difference from HPFS is that HPFS/386 uses Access Control Lists 
(ACLs), and HPFS does not. In both file systems, each file and 
directory structure is anchored on a structure called an fnode. In 
HPFS/386, each fnode has internal storage space for ACLs and 
Extended Attributes. If a file has more than 16 ACLs, they are stored 
outside of the fnode on disk, and the fnode has a pointer telling where 
to find the ACLs.

Linux Ext2 The Linux Ext2 file system is only accessible by Linux, a freeware 
version of UNIX. The Linux Ext2 file system supports a maximum 
partition size of 4 terabytes. 

Linux Swap Holds a Linux swap file. The maximum usable size of a Linux swap 
file is 2 GB. The default size shown when you create a Linux swap 
partition may be slightly larger because of the physical geometry on 
the hard disk.

NTFS The NTFS (New Technology File System) is accessible only by 
Windows NT and Windows 2000. NTFS is not recommended for use 
on partitions less than 400 MB because it uses a great deal of space 
for system structures.

Unformatted Unformatted partitions reserve a portion of the disk but are not 
assigned a file structure.

Unallocated 
space

Unallocated space is the portion of a hard disk that is not currently 
assigned to any partition.

Partition 
Type Description



PowerQuest ServerMagic for Windows NT 37

Changing ServerMagic Preferences

1 In the main window, click General ➤ Preferences.

A check mark next to a preference indicates it is enabled.

2 Click checkboxes to enable or disable preferences, then click OK.

Allow 64K FAT Clusters for Windows NT/Windows 2000

This preference lets you create FAT partitions with 64 KB clusters, which allows you to 
use ServerMagic to create FAT partitions up to 4 GB.

IMPORTANT! Because DOS, Windows 3.x/95/98/Me do not support cluster sizes larger 
than 32K, you cannot access a 64K partition using these operating systems. 
You should only use 64K partitions with Windows NT and Windows 2000. 
If you are using multiple operating systems, PowerQuest recommends not 
using 64K clusters.

When enabled, the 64K cluster size is available in the Resize/Move Partition and Resize 
Clusters dialogs.

Ignore OS/2 EA Errors on FAT

This preference tells ServerMagic whether to ignore OS/2 Extended Attribute errors when 
it checks a FAT partition.

WARNING! If OS/2 is on your computer, do not enable this preference. Data loss could 
occur because problems might go undetected.

Indicates whether 
the current 
operating system 
supports FAT32 
partitions.
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Skip Bad Sector Checks

When ServerMagic modifies partitions, it performs extensive testing to detect bad sectors 
on your hard disk. Newer disk types (such as Enhanced IDE and SCSI) often handle bad 
sectors internally, making such testing superfluous. For this reason, ServerMagic lets you 
bypass these tests with Skip Bad Sector Checks. When this preference is enabled, the 
Resize/Move, Create, Copy, and Format operations run faster.

WARNING! If you skip bad sector checks and your hard disk has bad sectors, data loss 
can result.

Bad sector checking is on by default. ServerMagic lets you set this preference individually 
for each of your hard disks. If your system has an older disk and a newer one, you could 
check the older disk and skip the newer one. A check mark next to a disk means to skip 
bad sector checking for that disk. 

Set as Read-Only for ServerMagic

This preference lets you prevent ServerMagic from making any changes to a hard disk. 
You can set this preference individually for each of your hard disks.

If the disk contains the boot partition, some files may be changed, such as the Windows 
NT boot initialization (BOOT.INI) file.

Using International Keyboards

When you use the DOS version of ServerMagic (see “Running ServerMagic from Rescue 
Disks” on page 20), you may lose the ability to use your keyboard the way you are 
accustomed to or to view extended characters properly. The ServerMagic rescue disks 
include the files you need to resolve these problems.

If you use an international keyboard or character set, you must edit the AUTOEXE2.BAT 
and CONFIG.SYS files on the rescue disks.

1 The following lines are remarked in the AUTOEXE2.BAT file. Delete the REM from 
the beginning of the line, and replace the variables xx and yyy with the keyboard 
code and character set code page for your language.

MODE CON CP PREP=((yyy)EGA.CPI)
MODE CON CP SEL=yyy
KEYB xx,yyy

xx = two-letter keyboard code (for example, US or FR)
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yyy = character set code page (for example, 437)

2 Save the AUTOEXE2.BAT file.

3 The following line is remarked in the CONFIG.SYS file. Delete the REM from the 
beginning of the line, and replace the variable yyy with the character set code page 
for your language.

DEVICE=DISPLAY.SYS CON=(EGA,yyy,)

4 Save the CONFIG.SYS file.

5 Reboot from the first rescue disk.

Getting Help

ServerMagic Help provides in-depth information on features as well as step-by-step 
instructions for specific tasks.

To access Help, click Help ➤ Contents on the menu bar in the ServerMagic main 
window.

The PowerQuest ServerMagic Help is organized into books and pages.

Find information 
with the Index 
(key) and Find 
(binoculars) 
tabs.

Double-click a 
page to read 
the help topic.

Double-click a 
book to view the 
pages in it.
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Each book focuses on a different aspect of ServerMagic, so you can quickly locate the 
information you need. When you double-click a topic, the information displays in the right 
window.

You can click the key tab to search for a topic using keywords.

Context-Sensitive Help

By clicking Help in the lower right corner of a dialog, you can open context-sensitive help 
for the dialog. Clicking Hints in a wizard dialog displays helpful information about the 
task the wizard is performing.

Readme File

The READMESM.TXT file includes information that changed since this guide was 
written, corrections to the manual or help system, and information specific to installation 
or configuration issues.
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C H A P T E R3
Completing Disk Operations
This chapter includes the following information:

• Integrity Checks

• Resizing and Moving Partitions

• Creating Partitions

• Deleting Partitions

• Undeleting Partitions

• Changing Partition Labels

• Formatting Partitions

• Copying Partitions

• Checking Partitions for Errors

• Merging Partitions

• Splitting Partitions

• Getting Information About Partitions

• Scanning a Disk for Errors

IMPORTANT! Before you perform any operations in ServerMagic, you should 
be familiar with the material explained in “ServerMagic Basics,” 
which begins on page 25.
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Integrity Checks

ServerMagic checks disk integrity with a sophisticated system of analysis and validation 
that operates behind the scenes every time you start the program or complete an operation. 
An initial integrity check scans your disk and reports any partition problems that may 
prevent ServerMagic from operating properly. This integrity check acts as an early 
warning system that informs you of your disk’s status and assures that the disk’s structure 
is thoroughly analyzed and verified before you alter it.

If your physical disk passes the initial integrity check, you can select the disk’s partitions 
and use ServerMagic’s options; otherwise, an error message appears instead of the 
partition list. This indicates a problem with your disk, not with ServerMagic (because no 
disk modification operations have been initiated). If ServerMagic finds errors that it can 
fix automatically, you will be prompted. It is safe to allow ServerMagic to fix errors. 
Correct the disk problem, and then restart ServerMagic. For additional information, see 
“Resolving Partition Table Errors” on page 122.

In addition to the integrity check at startup time, ServerMagic performs two integrity 
checks during any operation. The first check tests the integrity of the file system in the 
partition before an operation begins (similar to CHKDSK), and the second check validates 
your disk’s data after an operation is completed. From start to finish, ServerMagic 
examines your disk and informs you immediately if it detects any irregularities.

Resizing and Moving Partitions

The Resize/Move operation lets you change the size of a partition and/or move it to 
another location on a hard disk.

1 Select the partition you want to resize/move.

You cannot move Windows NT volume or stripe sets with parity created by Disk 
Administrator.

To move a volume segment, see “Moving Volume Segments” on page 85.

2 Click Operations ➤ Resize/Move.
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The Resize/Move Partition dialog appears.

The current size of the partition is shown on a partition map at the top of the dialog. 
The map also depicts the used (dark gray) and unused (green) space within the 
partition and the unallocated space surrounding the partition (if any exists). The 
minimum and maximum sizes to which you can resize the partition appear below the 
map. 

3 Choose whether to resize or move the partition.

To do this: Do this:

Move 1 Place the pointer on the partition. 

The pointer changes to .

2 Drag the partition to the desired location.

There must be unallocated space adjacent to the partition to move 
it. If there is none, and the partition contains unused space, make 
the partition smaller and then move the partition.

You cannot move unknown partitions, partitions failing the Check 
for Errors operation, or unallocated space.

Unallocated 
space 
outside 
partition

Left 
partition 
handle
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If you know your disk has no bad sectors, Skip bad sector checks in Preferences to 
make Resize/Move operations faster. 

3 (Optional) Click the Cluster Size drop-down list and select a new size.

ServerMagic changes the Free Space Before, New Size, and Free Space After 
values to show how the partition size is affected.

Move 
(continued)

Your Windows NT system partition cannot be moved past 4 GB, 
or Windows NT will not be bootable.

IMPORTANT! Exercise caution when moving a bootable 
partition. Operating systems can become 
unbootable if moved beyond certain boundaries. 
For more information, see “Creating Bootable 
Partitions” on page 48.

Resize 1 Place the pointer on the left or right partition handle. 

The pointer changes to .

2 Drag the handle until the desired partition size is reached.

You can also resize the partition by typing new values in the Free 
Space Before, New Size, and Free Space After boxes or by 
clicking the arrows next to the boxes. The values you enter may 
change slightly to values supported by the drive’s geometry. The 
arrow buttons resize the partition by the minimum increment, 
allowing you to make very fine adjustments. Changes are 
reflected in the partition map. 

To make a partition smaller, unused space must exist within the 
partition. To enlarge a partition, there must be unallocated space 
adjacent to it. For additional information about resizing 
partitions, refer to “Notes about Resizing Partitions” below.

IMPORTANT! Resizing your NTFS system partition over 7.8 GB 
may render your server unbootable. If you resize 
an NTFS system partition over this limit by 
accident, you can recover your system by using 
the ServerMagic rescue disks to resize the NTFS 
system partition below 7.8 GB.

To do this: Do this:
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This option is only available for FAT and FAT32 partitions. For more information, 
see “Resizing Clusters” on page 72.

4 Click OK.

Notes about Resizing Partitions

When you resize a partition, data is consolidated, not compressed. To make a partition 
smaller, unused space must exist within the partition. To enlarge a partition, there must be 
adjacent unallocated space. If there is unallocated space on the disk, but it is not adjacent 
to the partition you want to enlarge, adjust the location of the space by moving other 
partitions.

IMPORTANT! Exercise caution when resizing partitions smaller, especially a partition 
containing an operating system. Leave at least 50 MB more space in the 
partition than the operating system requires. Swap files, drivers, and other 
files may require the extra space. Additionally, operating systems can 
become unbootable if moved beyond certain boundaries. For more 
information, see “Creating Bootable Partitions” on page 48.

Resizing FAT and FAT32 partitions smaller may reduce the amount of wasted space on a 
hard disk. When you resize a FAT or FAT32 partition, ServerMagic automatically resizes 
the clusters to their optimal size for the partition. For more information, see “Resizing 
Clusters” on page 72.

You should be aware of the following limitations when resizing partitions:

• You cannot make a partition smaller unless it contains unused space. You can only 
reduce a partition to the used size shown in the partition map plus a small buffer area. 
During a Resize/Move operation, data is consolidated to the front of the partition as 
needed, but no data compression takes place. Because of the way a FAT partition is 
structured, you can often resize a partition a second time and make it even smaller or 
larger than the first time you resized it.

• In certain instances, you cannot make a FAT partition larger when the partition 
contains no unused space. If you have a full partition and plenty of unallocated space 
adjacent to it, yet are not able to enlarge your partition, you may have to delete some 
files in the partition so that ServerMagic has room to work. You may be able to 
slightly enlarge the partition (1 MB or less) and then enlarge the partition a second 
time to provide the necessary buffer area for ServerMagic. To see how much space is 
needed in a partition to resize past a cluster boundary, see the table in “Freeing Disk 
Space Before Enlarging a FAT Partition” in Help.
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• It is difficult to calculate in advance the minimum size to which an NTFS or HPFS 
partition may be resized. During an NTFS or HPFS Resize/Move operation, if 
ServerMagic runs out of space, it returns an error without completing the operation. 
The integrity of the NTFS or HPFS partition and data is never compromised.

Resizing Partitions in Mirrored Sets

ServerMagic does not support any partitions located in mirrored sets configured using 
Windows NT Disk Administrator. However, you can use ServerMagic to ultimately 
manipulate the size of a mirrored set.

1 Use Disk Administrator to break the mirrored set.

You will have to reboot your server.

2 Use ServerMagic to change the size of the master portion of the previously mirrored 
set.

3 Use Disk Administrator to re-establish a mirror.

Creating Partitions

The Create operation lets you create primary partitions, extended partitions, and logical 
partitions.

If you have multiple hard disks and partitions, the process and available options may differ 
slightly from the following steps. 

1 Select a block of unallocated space.

If no unallocated space exists, you must resize or delete an existing partition to create 
unallocated space. For instructions on resizing and deleting partitions, see “Resizing 
and Moving Partitions” on page 42 and “Deleting Partitions” on page 50.

If Remote Agent is running, you can create a partition on a remote server.

On a single hard disk, you can have up to four primary partitions or three primary 
partitions and one extended partition. Within an extended partition, you can create 
unlimited additional subdivisions called logical partitions. 

2 Click Operations ➤ Create.
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The Create Partition dialog appears.

3 From the Create as drop-down list, select Logical Partition or Primary Partition.

You should create primary partitions to install operating systems and logical 
partitions for all other purposes (such as storing data and applications). If you have 
multiple hard disks, you can improve speed by installing operating systems and 
applications on separate disks. If you do not know what type of partition you want to 
create, see “Understanding Partitions” in Help.

You should create a primary partition if you plan to install an operating system. Refer 
to “Creating Bootable Partitions” on page 48.

If you select Logical Partition, ServerMagic automatically creates an extended 
partition to enclose the logical partition, or, if you already have an extended partition, 
resizes the extended partition larger to encompass the logical partition (the free space 
must be inside of or adjacent to the extended partition).

If Logical Partition is unavailable, you may already have four primary partitions on 
the hard disk. Or, if you have an extended partition, you may not have selected a 
block of free space inside of or adjacent to the extended partition.

If you create a second, third, or fourth primary partition on a physical disk, 
ServerMagic will create the new primary partition as unhidden. However, 
ServerMagic will automatically hide the other primary partitions on that disk when 
performing a Set Active operation.

4 From the Partition Type drop-down list, select the desired file system type:

FAT is the most common file system type. It is used by DOS, OS/2, and all versions 
of Windows.

FAT32 is used by Windows 95 OEM Service Release 2, Windows 98, Windows Me, 
and Windows 2000.
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HPFS is used by OS/2 and Windows NT 3.51 (and earlier versions).

NTFS is used by Windows NT and Windows 2000.

Linux Ext2 and Linux Swap are used only by Linux.

Extended creates an extended partition which can contain any number of logical 
partitions. Extended is not an option if the hard disk already contains an extended 
partition or four primary partitions.

Unformatted creates an unformatted partition on your hard drive.

5 (Optional) Enter a label (up to 11 alphanumeric characters for FAT and 32 
alphanumeric characters for NTFS) for the new partition.

6 In the Size box, enter the desired size for the partition.

ServerMagic automatically calculates a recommended size (based on the most 
efficient use of disk space), which you can accept or change.

7 If the size you specified for the new partition is smaller than the available unallocated 
space, you can position the partition at the beginning (recommended) or end of the 
unallocated space. In the Position box, click Beginning of free space or End of free 
space.

8 In the Drive Letter box, type or select the drive letter you wish to assign to the 
partition.

9 Click OK. 

WARNING! Because of conflicts that can result from different hardware and system 
configurations, do not create a partition on a hard disk and then move that 
hard disk to another computer. Data loss may occur.

Creating Bootable Partitions

Before creating a partition where you plan to install an operating system (a bootable 
partition), you should understand the information outlined in the following table.

Operating System

Boots from 
Primary or 
Logical

Supported 
Partition Types

Boot Code 
Boundary

Space 
Required

DOS 6.22 and 
earlier

Primary FAT 2 GB 8 MB
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IMPORTANT! When you create, move, or resize a bootable partition, the partition must 
begin below the boot code boundary specified in the above table in order 
for the operating system to boot. With the exception of DOS 6.22 (or 
earlier) and OS/2, partitions beyond 8 GB are visible to the current 
operating system. For more information, see “Understanding the BIOS 
1,024 Cylinder Limit” and “Understanding the 2 GB Boot Code 
Boundary” in Help. The partition map in the ServerMagic main window 
displays indicators for the 2 GB boot boundary and the 1024 cylinder (8 
GB) limit.

Windows 95 Primary FAT or FAT32* 8 GB 90 MB

Windows 98 Primary FAT or FAT32 >8 GB 175 MB

Windows Me Primary FAT or FAT32 >8GB 295 MB

Windows NT Primary** FAT or NTFS 4 GB 125 MB

Windows 2000 Primary** FAT, FAT32, or 
NTFS

>8 GB 1 GB

Linux Either Linux Ext2 8 GB 250 MB

OS/2 Either FAT or HPFS 4 GB 110 MB

* A FAT32 partition is only accessible from Windows 95 if you have a version OSR2 
(4.00.950B) or above.

**Windows NT and Windows 2000 must boot from a primary partition on the first 
drive. However, only a few Windows NT/Windows 2000 files must reside on that 
partition; the remaining files can reside on a logical partition, which can be located on 
the first or a subsequent drive. The Windows NT/Windows 2000 boot partition can be 
shared with another operating system. Additionally, Windows NT must be installed on 
a FAT partition, and Windows 2000 must be installed on a FAT or FAT32 partition. 
During the installation, you can convert the partition to NTFS.

Operating System

Boots from 
Primary or 
Logical

Supported 
Partition Types

Boot Code 
Boundary

Space 
Required
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ServerMagic displays a warning if you attempt to create, move, or resize a bootable 
partition outside of the 2 GB boot code boundary. If you continue with the operation, you 
may not be able to boot or to see the partition. In either case, you can resolve the problem 
by moving the partition back within the boot code boundary with the ServerMagic rescue 
disks.

Some I/O cards (typically older RAID cards) only provide access to the first 8 GB of a 
disk under DOS. Consequently, if you resize the operating system partition beyond 8 GB 
and it becomes unbootable, the ServerMagic rescue disks may not allow you to manipulate 
partitions on that drive. You should be cautious about resizing any operating system 
partition beyond 8 GB.

Deleting Partitions

The Delete operation deletes a partition and makes its data inaccessible. The Delete and 
Shred operation destroys the data in a selected partition by overwriting the disk sectors. 
Once a partition has been shredded, it cannot be undeleted.

1 Select the partition you want to delete.

To delete an extended partition, you must first delete all logical partitions within the 
extended partition. You cannot shred unallocated space.

If Remote Agent is running, you can delete a partition on a remote server.

2 Click Operations ➤ Delete.

The Delete Partition dialog appears.

3 Click Delete or Delete and Shred.

Be aware that deleting and shredding a partition takes much longer than deleting a 
partition.

4 Click OK. 
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Undeleting Partitions

The Undelete operation restores FAT, FAT32, and NTFS partitions that have been deleted 
on disk. Undelete works best when you use it to restore a partition that you just deleted by 
accident. If you are undeleting partitions after you have made other changes (written data 
to them, resized existing partitions, etc.), see “Restrictions on Undeleting Partitions” on 
page 52.

1 Select the unallocated space to be searched.

If Remote Agent is running, you can search unallocated space on a remote server.

2 Click Operations ➤ Undelete.

IMPORTANT! You can undelete a partition only if no other operations are pending on 
the unallocated space selected.  If any operations are pending, the 
undelete icon and menu option will be dimmed (inaccessible).

The Undelete dialog appears, and the selected unallocated space is searched.

All primary and logical partitions that can be undeleted are listed. If no partitions are 
found within the unallocated space or none can be undeleted, a message appears 
indicating no partitions can be undeleted.

3 Within the scrollable list, click the checkbox of the partitions you wish to undelete.

While it is possible to undelete more than one partition at once, PowerQuest 
recommends that you undelete partitions one at a time, beginning with the one that 
you want most. Doing so helps ensure the integrity of the data within the partition.

4 Click OK.
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Restrictions on Undeleting Partitions

There are some situations in which a partition that has been deleted cannot be undeleted 
and will not be displayed in the scrollable list. They include the following:

• You cannot undelete a primary partition if your hard disk contains four primary 
partitions.

• You cannot undelete a logical partition that was deleted and now is not within an 
extended partition.

• You cannot undelete a primary partition that was deleted and now is within an 
extended partition.

• The partition includes file system errors. If ServerMagic finds a partition, it checks 
for errors before undeleting it. If the partition has errors, it cannot be undeleted.

• You cannot undelete a partition that has been completely or partially overwritten by 
another partition or file system. Because of this limitation, if you see two partitions in 
the Undelete dialog and undelete one of them, the other may no longer appear in the 
list.

• If two deleted partitions claim some of the same disk space, PowerQuest cannot 
guarantee the integrity of the data in those partitions when they are undeleted. For 
example, suppose you had two partitions, a 500 MB E: and a 500 MB F:, and you 
deleted F: and resized E: to claim all the space (1 GB). Then you saved data to E:. 
Later, you deleted E:. Now you want to undelete partitions, and you can see both E: 
and F: in the Undelete dialog. If you restore E:, it is fine and F: is no longer displayed 
in the dialog (because its space has been claimed). However, if you undelete F: 
instead of E:, you may get some data that you had saved to E:. Undeleting F: could 
make your computer unbootable or cause applications not to run.

Changing Partition Labels

The Label operation lets you change a partition’s label. Meaningful names make partition 
management easier.

1 Select the partition with the label you want to change.

If Remote Agent is running, you can label partitions on a remote server.

2 Click Operations ➤ Label.
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The Label Partition dialog appears.

3 In the New Label box, type the new label.

NTFS volume labels can contain up to 32 alphanumeric characters. FAT volume 
labels can contain up to 11 alphanumeric characters and cannot contain the following 
characters:* ? [ ] < > | + = : ; , . \ / ”.

4 Click OK.

Formatting Partitions

The Format operation formats a partition, destroying all its data in the process. Formatting 
enables you to put a different file system on a partition.

ServerMagic has several conversion options that let you convert from one file system to 
another without destroying existing files in a partition. See “Converting Partitions” on 
page 89.

1 Select the partition you want to format.

If Remote Agent is running, you can format partitions on a remote server.

2 Click Operations ➤ Format.

The Format Partition dialog appears.
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3 From the Partition Type drop-down list, select the desired file system type. 

If the partition is too small or too large, some partition types may not be available.

4 (Optional) Type a label for the partition. 

5 Click OK.

Copying Partitions

The Copy operation lets you to make an exact duplicate of a partition. To copy a partition, 
you must have unallocated space that is equal to or larger than the partition you are 
copying.

Reasons why you might want to copy a partition include:

• To duplicate your operating system before upgrading to a new version or a different 
operating system (so that you can remember how the old operating system’s 
windows, program icons, and properties were set up).

• To quickly move a smaller hard disk’s contents to a larger, new hard disk.

• To change the relative order of partitions.

• To back up a partition.

1 Select the partition you want to copy.

The Copy command is dimmed if there is not enough unallocated space on your disk 
for the partition.

If Remote Agent is running, you can copy partitions to or from a remote server.

You cannot use ServerMagic to copy Windows NT stripe sets, stripe sets with parity, 
or duplex/mirrored sets. 

2 Click Operations ➤ Copy.



PowerQuest ServerMagic for Windows NT 55

The Copy Partition dialog appears.

3 From the Disk drop-down list, select the disk where you want to copy the partition.

4 In the partition list, select the unallocated space where you want to copy the partition.

5 If the partition you specified is smaller than the available unallocated space, you can 
position the partition at the beginning (recommended) or end of the unallocated space. 
Under Position, click Beginning of free space or End of free space.

6 Click OK.

The copy is the same size (or slightly different if copied to a disk with a different 
geometry) and file system type and contains the same data as the original.

Copying the Boot Partition

If you copy the Windows NT boot partition to a different drive and Windows NT is booted 
to run from the new location, all the user-assigned drive letters will be dropped. When 
Windows NT boots, it compares current disk geometries to those stored in the registry for 
all user-assigned drive letters. When the stored values do not match a partition, the drive 
letter assignment is reset. Consequently, if Windows NT is booted from the copied 
partition, you could see error messages about services not starting. In Event Viewer, you 
may see Stop errors with event IDs 2511 and 7000.

To fix the problem, you must reassign the boot partition its original drive letter. You may 
need to reboot Windows NT more than once to completely reassign all drive letters to their 
original designations.
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Checking Partitions for Errors

The Check for Errors operation checks the integrity of a partition.

Each time ServerMagic is started, it performs a check on all attached drives and their 
partitions. If the check finds a problem, “Check failed” appears in the partition list window 
under the Type column. This check is separate from the Check for Errors operation and is 
not as exhaustive.

1 Select the partition you want to check.

ServerMagic can only check partitions that it can lock (that is, partitions that do not 
have open files on them). If there are open files on a partition, the Check for errors 
command on the menu will be dimmed.

If Remote Agent is running, you can check partitions on a remote server.

2 Click Operations ➤ Check for Errors.

The Check Partition Results dialog appears.

If Check for Errors does not discover any errors, an Info entry appears with “Check 
Complete” in the Description column. 

If a Check for Errors operation fails, “Check Failed” appears in the Used and Unused 
columns in the partition list. You should fix any errors encountered. For more 
information, see “Resolving Check Errors” on page 121.

If Check for Errors finds an error, such as cross-linked files, lost clusters, or bad 
directory information on an NTFS volume and can fix it, a Fix button appears at the 
bottom of the dialog. For each error found, ServerMagic displays the following:
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• Severity describes the seriousness of the problem, which can be one of the 
following:

• Fixed displays Yes for each problem you fix on an NTFS volume. Not applicable 
for FAT, FAT32, or HPFS partitions.

• Number shows a number corresponding to the error. For more information, see 
“Error Messages and Solutions” on page 125.

• Description gives a brief description of the problem.

3 To fix an error, highlight the problem and click Fix.

4 If you want to skip one listed error, click Skip.

If you want to skip all listed errors, click Skip All.

5 When you are finished viewing the check results and fixing NTFS errors, click Close.

Check for Errors does not display information about the status and structure of a partition 
as do the DOS, Windows, and OS/2 CHKDSK utilities. To view that information, use the 
Info operation. For details, see “Getting Information About Partitions” on page 61.

ServerMagic checks for OS/2 Extended Attribute errors on FAT partitions. If you do not 
use OS/2 or previously used OS/2 but no longer do, consider enabling the Ignore OS/2 
EA Errors on FAT preference, as these errors are not a concern. For more information, 
see “Changing ServerMagic Preferences” on page 37. OS/2 users should not enable 
Ignore OS/2 Errors on FAT, as undetected errors could cause data loss.

Severity Description

Info The information given is helpful but not critical. Does not 
correspond to any error.

Warning The error may or may not cause problems.

Error A problem was encountered, but ServerMagic may still be 
able to make changes to the partition. Run CHKDSK to fix the 
error, or click Fix, if available.

Critical A catastrophic problem. ServerMagic cannot make any 
changes to the partition.
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Merging Partitions

You can merge two FAT or FAT32 partitions that are adjacent to each other on a disk. It is 
useful to merge partitions if you have reached the maximum number of partitions on your 
disk, but you do not want to delete a partition. It is also useful if you want to combine FAT 
partitions and convert them to one large FAT32 partition.

IMPORTANT! Merging partitions may take a long time (possibly hours), depending on 
the partition sizes and amount of data they contain. If you wish to check 
whether your machine is still operating, you can press the NumLock key 
and see if the light toggles. It may take a few seconds to register activation 
of the NumLock key on your keyboard. If you plan to merge partitions, 
you may wish to schedule it for a time when you will not need to use your 
system for an extended period of time. If you shut down or turn off your 
computer while ServerMagic is still working, it will cause corruption 
to the file system, which will result in data loss. Do not shut down the 
system until after the process is complete.

1 Select one of the two partitions you want to merge with another partition.

2 Click Operations ➤ Merge.

The Merge Adjacent Partitions dialog appears.
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3 Under Merge options, choose the partitions you would like to merge.

The contents of one partition will be moved into a folder within the other partition.

You should not merge partitions that contain different operating systems.

4 Under Merge Folder, type a name for the new folder that will be created in the 
partition you are keeping.

5 Choose FAT for FAT32 for the format of the partition you are keeping.

If you are combining FAT partitions, be careful not to convert them to FAT32 unless 
you have access to FAT32 partitions. Windows 95b or later, Windows 98, Windows 
Me and Windows 2000 can access FAT32 partitions.

6 Click OK.

The partition map in the main window changes to show the merged partitions.

Splitting Partitions

Use Split to divide a FAT or FAT32 partition into two contiguous partitions. The new 
partition is created to the right of the original partition; the original and new partitions 
together occupy the same amount of hard disk space as the original partition. The file 
system for the partition does not change. For example, if you had a 2 GB FAT partition and 
you split it, the left and right partitions together would use 2 GB and both would be FAT 
partitions.

When you split a partition, you can select the files and folders that you want the new 
partition to include. You can also label the new partition and specify whether it is primary 
or logical.

1 Select the partition you want to split.

You cannot split a partition that is smaller than 100 MB.

A FAT partition must have at least 5% unused space, or the Split command will be 
dimmed on the menu. A FAT32 partition requires 10% unused space to split.

PowerQuest does not recommend splitting your operating system partition.
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2 Click Operations ➤ Split.

3 Under Original Partition, select the files and folders you want to move to the new 
partition, then click the single right arrow.

Click the left arrow to remove selected files and folders from the new partition. To 
move all files and folders to the new partition, click the double right arrow. You can 
also click the left arrow to move selected files and folders back to the original 
partition if you change your mind. You must, however, have at least one file or folder 
remaining in each partition.

4 (Optional) Type a name for the new partition in the Label text box.

5 Select a partition type for the new partition from the Pri/Log drop-down list.

You cannot use the Split operation to convert the original partition from primary to 
logical or vice versa.

6 Click OK.

The size of the new partition is based on the minimum possible size and the total byte size 
of the files you are adding to the new partition. Any remaining free space is split 
proportionally between the two partitions according the data in the partitions. For 
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example, if the two partitions used 2 GB and you included 700 MB of data in the original 
(left) partition and 300 MB of data on the new (right) partition, you would have 1 GB of 
free space available; the original partition would get 700 MB of unused space, and the new 
partition would get 300 MB of unused space.

Both the original and new partitions must be at least 40 MB. On hard disks larger than 4 
GB, ServerMagic will round the size of the partition up to at least 47 MB.

Getting Information About Partitions

The Info operation displays information about the status and structure of a selected 
partition.

If you select a volume segment (in Disk view), the Info operation displays information 
about the selected volume segment, not the entire volume set. To display information 
about an entire volume set, see “Displaying Information About Volume Sets” on page 79.

1 Select the partition you want information about.

If Remote Agent is running, you can get information about a partition on a remote 
server.

2 Click Operations ➤ Info.
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The Partition Information dialog appears.

Information is displayed in tabbed pages. To view a page, click its associated tab, 
which is always visible at the top of the pages. Based on the file system the partition 
uses, different pages appear.

3 Click the tab for the page you wish to view.

Each page is described in the following sections.

4 Click Close when you are finished viewing information.

Usage

The Usage page is available for the FAT, FAT32, NTFS, and HPFS file systems. This page 
displays the following information in bytes, megabytes, and as a percentage:

• Used space on the partition, including space wasted by clusters
• Unused space on the partition
• Bad space on the partition
• Total space on the partition (the sum of Used, Unused, and Bad space)

ServerMagic also displays this information in a pie chart.
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Cluster Waste

The Cluster Waste page applies only to partitions using the FAT or FAT32 file systems.

This page displays the following information:

• Current Cluster Size in bytes or kilobytes
• Data stored on the partition in bytes and megabytes
• Wasted space on the partition in bytes and megabytes
• Total used space in bytes and megabytes (the sum of Data and Wasted space)

ServerMagic also displays this information in a bar chart.

Partition Info

The Partition Info page is available for all types of partitions, including unallocated space 
and extended partitions. Information on this page includes the following:

• Partition type is shown in hexadecimal followed by a text description of the partition 
or file system type (such as FAT, FAT32, NTFS, or HPFS). The hexadecimal 
designation is the conventional way to display partition types.

• Serial Number is shown if the partition’s file system uses serial numbers.

The lower portion of the page shows physical information about the partition:

• First physical sector shows the logical number and the location (cylinder, head, and 
sector) where the partition begins.

• Last physical sector shows the logical number and the location (cylinder, head, and 
sector) where the partition ends.

• Total physical sectors displays the number of sectors in the partition.

• Physical Geometry shows the total number of cylinders, heads, and sectors on the 
physical disk where the partition resides.

File System-Specific Info Pages

The last page in the Partition Information dialog corresponds to the file system used on 
the selected partition. For example, if the file system is FAT or FAT32, the page is FAT 
Info; if the file system is NTFS, the page is NTFS Info, and so forth.

FAT Info

This page applies to partitions using the FAT or FAT32 file systems.
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The first section provides the following information:

• Sectors per FAT shows the number of sectors in each file allocation table and the 
number of file allocation tables on the selected partition.

• Root directory capacity shows the number of possible entries and the number of 
sectors in the root directory. Because a FAT32 root directory can grow as needed, this 
line is blank for FAT32 partitions.

• First FAT sector shows the logical sector number within the partition where the FAT 
begins.

• First Data sector shows the logical sector number within the partition where the data 
portion of the partition begins.

The next section provides the following information:

• The number of bytes in files on the partition, the number of files, and the number of 
those files that are hidden

• The number of bytes in directories on the partition, the number of directories, and the 
number of those directories that are hidden

The final section of this page, FAT Extensions, provides the following information: 

• The number of bytes used for OS/2 Extended Attributes and the number of files and 
directories affected by Extended Attributes

• The number of bytes used for long filenames and the number of files and directories 
using long filenames

NTFS Info

This page applies to partitions using the NTFS file system. The first section shows the 
following information:

• NTFS Version shows the version number. The NTFS version does not match the OS 
version. For example, Windows NT 4.0 uses NTFS version 1.3.

• Bytes per NTFS sector displays the number of bytes in each logical sector on the 
selected partition. (There are always 512 bytes in each physical sector.)

• Cluster size displays the size of each cluster and the number of sectors in each cluster 
on the selected partition.

• First MFT Cluster shows the logical number of the first cluster in the master file 
table (MFT).

• File Record Size gives the size of file records in the MFT.
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The next section displays information similar to that shown by NT CHKDSK:

• The number of files on the partition and the bytes and clusters allocated to them
• The number of wasted bytes in file clusters
• The number of indexes (directories) and the bytes and clusters allocated to them
• The number of bytes and clusters reserved for other system structures

HPFS Info

This page applies to partitions using the HPFS file system.

The first section displays the following information:

• Partition status shows one or more of these values:
• Active: OS/2 is running and data has been written to the partition.
• Dirty: Windows NT or OS/2 was shut down improperly and is not running. 
• Corrupt: One or more sectors are bad, and the partition needs to be checked. 
• Hot Fixes: Problems have been hot fixed.
• Not Active: The partition is not in use. 

• DirBlock sectors shows the range of sectors in the DirBlock band. The DirBlock 
band is usually preallocated near the center of the disk to reduce head movement.

• Free DirBlocks displays the number of unused DirBlocks in the DirBlock band and 
the total number of DirBlocks. If the DirBlock band fills up, additional DirBlocks are 
allocated from the data area. 

• HotFixes used displays the number of hotfix sectors used and the total number of 
hotfix sectors available. Hotfix sectors are used temporarily to handle write errors. 
CHKDSK /F transfers the data from a hotfix sector to a good sector and makes the 
hotfix sector available again. 

The last section displays information similar to that shown by OS/2 CHKDSK, including:

• The number of bytes and files on the partition and the number of sectors used for files

• The number of unused bytes in file sectors, which is equivalent to wasted bytes in 
FAT clusters. (Because HPFS allocates space by sectors, less space is wasted than in 
FAT clusters.)

• The number of bytes in directories, the number of directories on the partition, and the 
number of sectors used for directories

• The number of bytes in file/dir Fnodes, also shown as a number of sectors

An Fnode is a key structural element of the HPFS file system. Each Fnode is 512 
bytes (one sector). One Fnode exists for each file or directory in the partition.
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• Number of bytes reserved by the system, also shown as a number of sectors

• Number of bytes used for Extended Attributes (EAs)

Scanning a Disk for Errors

You can run the Windows NT CheckDisk utility (CHKDSK.EXE) from ServerMagic. Use 
CheckDisk to scan a disk or volume set for errors.

1 Select the disk or volume set you want to scan for errors.

2 Click Operations ➤ Windows CheckDisk.

CheckDisk only scans drives, partitions, and volumes with assigned drive letters; it 
does not scan unallocated space, and volumes and partitions with file systems not 
supported by Windows NT. (Windows NT supports FAT and NTFS. Windows 2000 
supports FAT, FAT32, and NTFS.)

ServerMagic invokes CheckDisk in read-only mode. In most instances, including the 
/F switch to fix errors on an NTFS partition requires a system reboot. If you want to 
fix discovered volume errors, you should exit ServerMagic and run CHKDSK /F 
from a command window. For more information about NT CheckDisk, consult 
Windows NT help.

3 When NT CheckDisk is finished, the results appear in the command window.

4 When you are finished viewing the results, press any key to close the command 
window.
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C H A P T E R4
Completing Advanced Disk 
Operations
This chapter includes the following information:

• Changing a Drive Letter

• Retesting Bad Sectors

• Hiding and Unhiding Partitions

• Resizing the Root Directory

• Setting an Active Partition

• Resizing Clusters
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Changing a Drive Letter

The Change Drive Letter operation lets you change the drive letter assigned to any 
partition visible to and supported by Windows NT.

1 Select the partition whose drive letter you want to change.

2 Click Operations ➤ Advanced ➤ Change Drive Letter.

The Change Drive Letter dialog appears. 

3 In the New drive letter box, type or select the drive letter you want to assign to the 
partition.

4 Click OK.

Retesting Bad Sectors

The Bad Sector Retest operation lets you check sectors on FAT and FAT32 partitions that 
have been marked bad and recover sectors that are usable.

The FAT and FAT32 file systems allocate disk space for file storage in units called 
clusters, which are composed of a fixed number of sectors. Because the FAT or FAT32 file 
system tracks bad sectors at the cluster level, it marks an entire cluster bad even though the 
problem may exist in a single sector. Use Info to discover whether a partition contains bad 
clusters. For more information, see “Getting Information About Partitions” on page 61.

As a conservative measure, when you move or resize a partition or increase cluster size, 
ServerMagic marks all new clusters containing any part of old bad clusters as bad (even 
though the clusters may not actually contain bad sectors). Likewise, when you decrease a 
partition’s cluster size, ServerMagic divides bad clusters into multiple bad clusters. If, 
after you complete these tasks, ServerMagic reports bad sectors, you can perform Bad 
Sector Retest and reclaim the good sectors that were marked bad.

1 Select the partition you want to retest.
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2 Click Operations  ➤ Advanced  ➤ Bad Sector Retest.

The Bad Sector Retest dialog appears.

3 To continue with the test, click OK.

Some sectors marked as bad are “marginally bad,” meaning that one time the sector 
works fine and another time it does not. Bad Sector Retest may mark a marginally bad 
sector as good. This can result in data loss if the marginally bad sector fails in the 
future. Most modern hard drives detect bad sectors and automatically remap the 
sector, so in general, you do not see bad sectors on modern hard drives. If you do get 
bad sector errors on a modern hard drive, it is recommended that you replace the 
drive.

Hiding and Unhiding Partitions

The Hide Partition operation lets you secure partitions against unwanted user access. You 
can perform this operation on FAT, FAT32, NTFS, and HPFS partitions. 

When you hide a partition, it will not be assigned a drive letter the next time you boot your 
computer.

1 Select the partition you wish to hide.

If Remote Agent is running, you can hide or unhide a partition on a remote server.

2 Click Operations ➤ Advanced ➤ Hide Partition (or Unhide Partition).

Note that unless you are running Windows NT or Windows 2000, unhiding multiple 
primary partitions may cause data loss.



Chapter 4: Completing Advanced Disk Operations70

The Hide Partition dialog appears, warning you that drive letters may change.

3 To confirm that you want to hide the partition, click OK.

Under Windows NT, partitions are not hidden automatically; therefore, you can have 
multiple visible primary partitions. 

Resizing the Root Directory

The Resize Root operation lets you change the maximum number of entries that can be 
placed in the root directory of a FAT partition. The number of root entries is set at the time 
the partition is formatted; the limit does not expand automatically as it does in a 
subdirectory or in a FAT32 partition. Consider increasing this number if you use Microsoft 
long filenames in the root directory. During this operation, data within the partition is 
unaffected.

1 Select the partition whose root directory you wish to resize.

2 Click Operations ➤ Advanced ➤ Resize Root.

The Resize Root dialog appears, displaying the number of used entries and the 
current capacity.
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3 In the New capacity box, type or select the number of entries you want the root 
directory to have.

The number you type will be rounded to one that preserves the current cluster 
alignment.

4 Click OK.

Occasionally, enlarging the root directory displaces the first few files on the partition (such 
as IO.SYS and MSDOS.SYS if the partition contains an operating system). If the root 
directory is on a boot partition and the partition fails to boot after resizing the root 
directory, you should run SYS.COM to move the displaced files back to the front of the 
disk.

Setting an Active Partition

The Set Active operation lets you make a partition the active partition (the partition the 
computer boots from). Only one partition can be active at a time. To boot your computer 
from a partition, the partition must be on the first disk, and it must contain an operating 
system. When your computer boots, it reads the partition table of the first disk to find out 
which partition is active and boots from that partition.

IMPORTANT! Before you make a partition active, it must be bootable. If the partition is 
not bootable or if you are not certain if it is, have a boot diskette ready.

ServerMagic hides inactive FAT, NTFS, and HPFS primary partitions (unlike Windows 9x 
and DOS FDISK programs which cannot hide or unhide partitions). Hiding inactive 
primary partitions makes it easy to install multiple operating systems and choose the one 
you want to set active. For example, if you have Windows 95 and want to install Windows 
NT in a separate partition, you can make the Windows 95 partition smaller, create another 
primary partition, set it as the active partition, and then boot from the Windows NT 
installation diskettes.

1 Select the partition you want to make active.

2 Click Operations ➤ Advanced ➤ Set Active on the context menu.

In a configuration with mixed IDE and SCSI hard disks, Windows NT does not 
always see the boot drive as the first disk. ServerMagic displays drives in the order 
that Windows NT reports them. As a result, you may see your boot device as drive 1, 
2, etc. ServerMagic may also incorrectly report that there is no active partition. Be 
sure you identify which which drive is the boot drive.
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The Set Active Partition dialog appears.

3 Click OK.

Resizing Clusters

The Resize Clusters operation lets you change the cluster size on FAT and FAT32 
partitions. Reducing cluster size may help you reclaim wasted space on your hard disk.

All files on FAT and FAT32 partitions are stored in allocation units called clusters. Each 
file on a partition is allotted at least one cluster. The size of a partition determines cluster 
size. Unless the size of a file is an exact multiple of cluster size on the partition where the 
file is located, the file includes wasted space. Larger partitions have larger clusters, and, 
therefore, more wasted space. For more information, see “Making Efficient Use of Disk 
Space” in Help.

1 Select the partition where you want to resize clusters.

2 Click Operations ➤ Advanced ➤ Resize Clusters.
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The Resize Clusters dialog appears.

For each cluster size, ServerMagic displays the following:

• A bar graph and percentages represent how much space would be used and how 
much space would be wasted if you chose that cluster size for the currently 
selected partition

• Wasted space (in megabytes)

• The range of allowable partition sizes (in megabytes) or other information

• If a cluster size requires a partition that is too small for the data and files on the 
partition, “Not Available” appears in the Notes column. “Not Enabled” appears in 
the Notes column for the 64 K cluster size because it is only used for Windows 
NT/2000. You can enable the 64 K cluster size, but it is not recommended. For 
more information, see “Allow 64K FAT Clusters for Windows NT/Windows 
2000” on page 37.

The lower portion of the Resize Clusters dialog displays information about the 
current and new cluster size and the current and new partition size (based on the new 
cluster size).

3 Using the information in the dialog, decide which cluster size you want to use (and 
can use) and select it from the New cluster size drop-down list.

ServerMagic adheres to the established limits for partition and cluster sizes. You 
cannot select a cluster size that is invalid for the selected partition.
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It is not recommended that you use the smallest cluster size on partitions containing a 
single, large file, such as a database or swap file.

Choosing a smaller cluster size may resize the partition smaller, creating unallocated 
space next to the partition. You can use this unallocated space by creating a new 
partition.

4 Click OK.

Default Cluster Sizes

A partition’s cluster size is set by the DOS FORMAT operation, based on the size of the 
partition, as shown in the following tables.

DOS and Windows default FAT cluster sizes

Partition Size (MB) FAT Type Sectors Per Cluster Cluster Size

0-15 12-bit 8 512 bytes

16-127 16-bit 4 2 K

128-255 16-bit 8 4 K

256-511 16-bit 16 8 K

512-1,023 16-bit 32 16 K

1,024-2,047 16-bit 64 32 K

2,048-4,096 16-bit 128 64 K*

*Only available with Windows NT and Windows 2000 and a 2-4 GB disk.

Windows 95 OEM Service Release 2, Windows 98, Windows 
Me, and Windows 2000 default FAT32 cluster sizes

Partition Size (GB) Sectors Per Cluster Cluster Size

0.256- 8.01 8 4 K

8.02-16.02 16 8 K

16.03-32.04 32 16 K

> 32.04 64 32 K
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C H A P T E R5
Managing Volume Sets
This chapter includes the following information:

• Copying Volume Sets

• Resizing Volume Sets

• Formatting Volume Sets

• Changing Volume Set Labels

• Displaying Information About Volume Sets

• Deleting Volume Sets

• Checking Volume Sets

• Moving Volume Segments

IMPORTANT! Before you perform any operations in ServerMagic, you should 
be familiar with the material explained in “ServerMagic Basics,” 
which begins on page 25. All but one of the operations in this 
chapter require that you select a volume from the Volume Sets 
window in ServerMagic. The Move Segment operation is 
available from the Disks window.
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Copying Volume Sets

The Copy and Consolidate operation copies all the data from a volume set and 
consolidates it to an unallocated space you specify. This procedure creates a new partition 
which can be accessed from the Disks window (not the Volume Sets window).

IMPORTANT! To copy and consolidate a volume set, you must have unallocated space 
that is equal to or larger than the volume set.

1 Select the volume set you want to copy.

If Remote Agent is running, you can copy and consolidate volume sets to a remote 
server.

2  Click Operations ➤ Copy and Consolidate.

The Copy and Consolidate Volume Set dialog appears.

3 From the Disk drop-down list, select the disk where you want to copy and consolidate 
the volume set. 

The type and size of the space available  is reflected in the partition map and partition 
list. The disk you select must have a sufficient amount of unallocated space. 

4 In the Position box, click Beginning of unallocated space or End of unallocated 
space.

5 Click OK to add the operation to the ServerMagic queue.
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ServerMagic changes the view from the Volume Sets window to the Disks window.

Resizing Volume Sets

The Resize operation lets you change the size of a volume set by resizing the last segment 
within the set. If you are decreasing the size of the volume, data is shifted from the last 
segment to other segments in the volume set as needed. If you are increasing the size of the 
volume, the last segment is expanded.

1 Select the volume set you want to resize.

IMPORTANT! You cannot resize FAT16 volume sets.

2 Click Operations ➤ Resize.

The Resize Volume Set dialog appears.

The current size of the volume set is shown on the volume set map at the top of the 
dialog. The minimum and maximum sizes to which you can resize the volume set also 
appear in the dialog.

3  Place the pointer on the volume set handle (the right edge) and drag the handle to the 
left or right until you reach  the desired size. 

The pointer changes to a double-headed arrow when it is positioned over the handle.

You can also resize the volume set by typing new values in the New Size, and Free 
Space After boxes or by clicking the arrows next to the boxes. The arrow buttons 
resize the set by the minimum increment, allowing you to make fine adjustments. 
Changes are reflected in the volume set map.
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When you enlarge a set, there must be free space adjacent to it. If, for example, there 
is a  partition next to the last volume segment, you cannot resize larger, only smaller. 

When you reduce the size of a set, ServerMagic shifts the data from the last segment 
to one or more other segments in the volume set. The amount by which you can 
reduce the size of a volume set is dependent on either the amount of data in the 
volume set or the sum total of all the segments minus the size of the last segment plus 
one cylinder (which ever scenario is greater). 

4 Click OK.

Formatting Volume Sets

The Format operation formats a volume set, destroying all its data in the process. 
Formatting lets you  put a different file system on a volume set.

1 Select the volume set you want to format.

2 Click Operations ➤ Format.

The Format Volume Set dialog appears.

3 From the Volume Set Type drop-down list, select the desired file system type.

You can only choose between FAT or NTFS. FAT is unavailable if the volume set is 
greater than 2 GB (or 4 GB if 64K clusters are enabled in preferences).

4 (Optional) Type a label for the volume.

Changing Volume Set Labels

Use the Label operation to change a volume set label. Giving your volumes meaningful 
names makes managing them easier.
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1 Click Volume Sets to display the Volume Sets window.

2 From the volume map, list, or tree view, select the volume set you want to label.

3 Click Operations ➤ Label.

The Label Volume Set dialog appears.

4 In the New Label box, type the new label.

NTFS volume labels can contain up to 32 alphanumeric characters. FAT volume 
labels can contain up to 11 alphanumeric characters and cannot contain the following 
characters:*?[]<>|+=:;,.\ /”.

5 Click OK.

Displaying Information About Volume Sets

The Info operation displays information about the status of a selected volume set.

1 Click Volume Sets to display the Volume Sets window.

2 From the volume map, list, or tree view, select the volume set on which you want 
information.

3 Click Operations ➤ Info.

The Volume Set Information dialog appears.
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Information is displayed in tabbed pages. To view a page, click its associated tab, 
which is always visible at the top of the page. Based on the file system the volume set 
uses, different pages appear.

4 Click the tab for the page you want to view.

Each page is described in the following sections

5 Click Close when you are finished viewing information.

Usage

The Usage page displays the following information in bytes, megabytes, and as a 
percentage:

• Used space in the volume set, including space wasted by clusters.

• Unused space in the volume set.

• Bad space in the volume set.

• Total space in the volume set (the sum of Used, Unused, and Bad space)

ServerMagic also displays this information in a pie chart.
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FAT Info

The page applies to volume sets using the FAT16 file systems.

The first section provides the following information:

• Sectors per FAT shows the number of sectors in each file allocation table and the 
number of file allocation tables in the volume set.

• Root directory capacity shows the number of possible entries and the number of 
sectors in the root directory. 

• First FAT sector shows the logical sector number within the volume set where the 
FAT begins.

• First Data sector shows the logical sector number within the volume set where the 
portion of the volume begins.

The next section provides the following information:

• The number of bytes in files in the volume set, the number of files, and the number of 
those files that are hidden.

• The number of bytes in directories in the volume set, the number of directories, and 
the number of those directories that are hidden.

The final section of this page FAT Extensions, provides the following information.

• The number of bytes used for long filenames and the number of files and directories 
using long filenames.
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NTFS Info

This page applies to volume sets using the NTFS file system.

• NTFS Version shows the version number as reported by the file system. Note that the 
file system version is not the same as the operating system version.

• Bytes per NTFS sector displays the number of bytes in each logical sector on the 
selected volume set. (There are always 512 bytes in each physical sector.)

• Cluster size displays the size of each cluster and the number of sectors in each cluster 
on the selected partition.

• First MFT Cluster shows the logical number of the first cluster in the master file 
table (MFT).

• File Record Size gives the size of the file records in the MFT.

The next section displays information similar to that shown by NT CheckDisk:

• The number of files in the volume set and the bytes and clusters allocated to them
• The number of wasted bytes in file clusters
• The number of indexes (directories) and the bytes and clusters allocated to them
• The number of bytes and clusters reserved for other system structures
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Deleting Volume Sets

The Delete operation deletes a volume set and makes its data inaccessible. The Delete and 
Shred operation destroys the data on a volume set by overwriting the disk sectors occupied 
by the volume set. 

You cannot delete a volume segment, only a volume set. Additionally, you cannot undelete 
a volume set.

1 Select the volume set you want to delete.

2 Click Operations ➤ Delete.

The Delete Volume Set dialog appears.

3 Click Delete or Delete and Shred.

4 Click OK.

Checking Volume Sets

The Check for Errors operation checks the integrity of a volume set.

1 Click Operations ➤ Check for Errors.

ServerMagic can only check volumes that it can lock (that is volumes that have no 
open files on them). Consequently, sometimes the Check for Errors option is 
disabled.
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The Check Volume Set for Errors dialog appears.

If ServerMagic does not discover any errors, an Info entry appears with “Check 
Complete” in the Description column.

If a Check operation fails, “Check Failed” appears in the Used and Unused columns 
in the partition list. You should fix any errors encountered. For more information, see 
“Resolving Check Errors” on page 121.

If Check  for Errors finds an error (such as cross-linked files, lost clusters, or bad 
directory information on an NTFS volume ) and can fix it, the Fix button is enabled at 
the bottom of the dialog.

For each error found, Check for Errors displays the following:

• Severity describes the seriousness of the problem, which can be one of the following:

• Fixed displays Yes for each problem you fix on an NTFS volume. 

Info The information given is helpful but not critical. Does not correspond 
to any error.

Warning The error may or may not cause problems.

Error A problem was encountered, but ServerMagic may still be able to 
make changes to the volume set. If available, click Fix to fix the error. 
If ServerMagic is unable to fix the error, run CHKDSK /F from the 
command prompt.

Critical A catastrophic problem. ServerMagic cannot make any changes to the 
partition.
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• Number shows a number corresponding to the error. For more information about 
error messages, see “Error Messages and Solutions” on page 125.

• Description gives a brief description of the problem.

2 To fix an error on an NTFS volume, select the problem and click Fix.

3 If you want to skip one listed error, click Skip. If you want to skip all listed errors, 
click Skip All.

4 When you are finished viewing the check results and fixing NTFS errors, click Close.

Check for Errors does not display information about the status and structure of a volume 
as does DOS, Windows, and OS/2 CHKDSK utilities. To view that information, use the 
Info option.

ServerMagic checks for OS/2 Extended Attribute errors on FAT partitions. If you do not 
use OS/2 or previously used OS/2 but no longer do, consider enabling the Ignore OS/2 
EA Errors on FAT preference, as these errors are not a concern. See “Integrity Checks” 
on page 42.

Each time SeverMagic is started, it performs a check on all attached drives and their 
partitions. If the check finds a problem, “Check Failed” appears in the partition list 
window under the Type column. This check is separate from the Check for Errors 
operation and is not as exhaustive.

Moving Volume Segments

The Move Segment operation lets you move a volume set segment (not a volume set) to 
the left, right, or a new location. Note that this operation is available from the Disks 
window, not the Volume Sets window.

Left or Right

You can move a volume segment to a new location by selecting the segment from the tree 
view or partition map then dragging and dropping it to adjacent unallocated space on the 
same hard disk.

1 Click Disks to display the Disks window.

This operation is available from the Disks Window, not the Volume Sets window.

2 Select the volume segment you want to move.
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3 Click Operations ➤ Move Segment ➤ Left/ Right.

The Move Segment Left/Right dialog appears. The current size of the volume 
segment is shown on the volume segment map at the top of the dialog.

4 To move a volume segment, place the pointer on the segment and drag it to the desired 
location.

The hard disk must have free space adjacent to the segment.

The pointer changes when it is located over a segment.

You can also move the segment by typing new values in the Free Space Before, and 
Free Space After, boxes or by clicking the arrows next to the boxes. The arrow button 
moves the segment by the minimum increment, allowing you to make fine 
adjustments. Changes are reflected in the volume segment map.

5 Click OK.

New Location

1 Click Disks to display the Disks window.

2 Select the volume segment you want to move.

3 Click Operations ➤ Move Segment ➤ New Location.
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The Move Segment to New Location dialog appears.

4 From the Disk drop-down list, select the disk where you want to move the volume 
segment.

The type and size of the space available is reflected in the partition map and partition 
list. The disk you select must have a sufficient amount of unallocated space.

5 In the Position box, click Beginning of unallocated space or End of unallocated 
space.

6 Click OK.
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C H A P T E R6
Converting Partitions
This chapter includes the following information:

• Procedure for Converting Partitions

• Converting FAT Partitions to FAT32

• Converting FAT Partitions to HPFS

• Converting FAT Partitions to NTFS

• Converting FAT32 Partitions to FAT

• Converting FAT32 to NTFS

• Converting NTFS Partitions to FAT or FAT32

• Converting Partitions to Logical or Primary
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Procedure for Converting Partitions

You can convert the following file formats:

• FAT partitions to FAT32
• FAT partitions to HPFS
• FAT partitions to NTFS (Windows NT/2000 only)
• FAT32 partitions to FAT
• FAT32 partitions to NTFS (Windows 2000 only)
• NTFS partitions to FAT
• NTFS partitions to FAT32

You can also convert primary partitions to logical and logical partitions to primary.

You cannot convert FAT or FAT32 partitions to NTFS if you are running ServerMagic 
from the rescue disks.

You should not convert file system types on compressed drives. First, uncompress the 
drive, then run the conversion.

The basic conversion steps (1-5) are found below. However, for each file type there is  
specific information you need to know before beginning any conversion. Please see the 
appropriate heading listed in this section before completing the conversion procedure.

1 Select the partition you want to convert.

2 Click Operations ➤ Convert.

The Convert Partition dialog appears.

3 Under Convert to, choose the file system to which you want to convert the partition.



PowerQuest ServerMagic for Windows NT 91

Depending on the file format of the partition you are converting, some options may 
appear dimmed.

 If you want to convert your partition to primary or logical, see “Converting Partitions 
to Logical or Primary” on page 97. 

4 Click OK.

Converting FAT Partitions to FAT32

FAT32 partitions have less wasted disk space than FAT partitions. (For more information, 
see “Resizing Clusters” on page 72.) However, you should be aware of these issues:

• You must have Windows 95 OEM Service Release 2, or Windows 98/Me/2000 to 
access files on a FAT32 partition. If you run an operating system other than these, 
FAT32 partitions will be inaccessible when the other operating system is running, 
even if one of these operating systems is installed on your machine.

• Some laptops have a sleep mode that saves all memory to disk. Because this function 
sometimes requires a FAT partition, consult your laptop manual or contact the 
manufacturer before converting to FAT32.

• The minimum recommended size for a FAT32 partition is 256 MB.

The steps for this process are listed on page 90.

Converting FAT Partitions to HPFS

During this operation, ServerMagic preserves data, long filenames (created by Microsoft 
Windows NT/95/98/Me), and Workplace shell long name Extended Attributes. 

WARNING! You must have OS/2 to access files on an HPFS partition. Without it, you 
will lose all files on the converted partition. Proceed with caution when 
performing this conversion, as it cannot be reversed.

1 Before you convert, back up the data on your boot drive.

Because the conversion cannot be reversed, we strongly recommend that you take this 
precautionary step. 

If a Corrective Service Facility (CSF) has been applied to your version of OS/2, you 
must make new Install/Utility diskettes and use them in place of your original OS/2 
diskettes. 
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2 Reboot your system from a diskette, from a partition other than the one you are 
converting, or from DOS. 

3 Run ServerMagic from a partition other than the one you are converting.

4 Follow the conversion steps listed on page 90.

5 If you have open files, a prompt appears indicating that the changes you have made 
require rebooting. Click OK to make the changes. After the changes are made, the 
computer is rebooted.

If you do not have any open files, the Batch Progress dialog appears. When all 
operations are complete, click OK to return to the ServerMagic main window. 

IMPORTANT! Complete the remaining steps only if the partition you converted to 
HPFS contains OS/2.

6 Copy SYSINSTX.COM from the OS/2 Installation Disk to the root of the new HPFS 
partition. 

7 Copy UHPFS.DLL from the OS/2 Disk 2 to the root of the new HPFS partition.

If you have an OS/2 CD-ROM, consult your IBM documentation for instructions on 
creating a diskette from the disk image. 

8 Change to the new HPFS partition by typing drive: (where drive  is the drive 
letter of the partition you converted from FAT to HPFS). 

9 From the root of the new HPFS partition, type SYSINSTX drive: (where drive 
is the drive letter of the partition you converted from FAT to HPFS). 

10 Verify that HPFS.IFS is listed in the CONFIG.SYS file similar to the following: 

IFS=C:\OS2\HPFS.IFS /CACHE:256 /CRECL:4 /AUTOCHECK:C 

If this line is not present, add it, replacing C: and :C with the drive letter of the 
partition you just converted. 

IMPORTANT! If you want to be able to boot to the command line using <Alt+F1>, 
make this change to all CONFIG.* files in \OS2\BOOT. 

11 Verify that HPFS.IFS is present in the OS2 directory. If not, copy it from OS/2 
Installation Disk 1.

Your HPFS partition is now bootable.
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Converting FAT Partitions to NTFS

The Convert FAT to NTFS operation launches the Microsoft Convert utility to convert a 
FAT partition to NTFS. You must be running Windows NT/2000 to complete this 
conversion. This cannot be performed from the rescue diskette.

If you boot multiple OSs, you must be careful converting FAT to NTFS. NTFS is only 
accessible from Windows NT or Windows 2000; therefore, the data in this partition will 
not be accessible if you boot DOS or Windows 95/98/Me.

After clicking OK, if you have no operations pending and if Windows NT/2000 can lock 
the partition (no open files), the FAT partitionis converted. If you have operations pending, 
you must apply them first before converting from FAT to NTFS. If you do not apply the 
operations, a prompt appears asking if you want to apply the changes now before 
converting your FAT partition. Click OK to apply the changes and continue with the 
conversion.

If you have any open files a message appears indicating that the convert utility cannot gain 
exclusive access to the drive and asks if you want to schedule the conversion the next time 
the system restarts. If you type Y, the conversion takes place automatically the next time 
you reboot your computer. It is recommended that after typing Y, you close ServerMagic 
and manually reboot to convert the partition.

Converting FAT32 Partitions to FAT

To complete this conversion, the partition must have at least 300-400 MB of unused space 
because of how the FAT file system allocates disk space for file storage.

If the FAT menu option is dimmed, your FAT32 partition contains over 2 GB of data. If the 
partition size is over 2 GB but it contains less than 2 GB of data, you can convert the 
partition (without data loss), but the new partition will be 2039 MB.

During the conversion, ServerMagic may report too many root directory entries (the 
maximum number of entries in a FAT partition’s root directory is limited, unlike a FAT32 
partition’s root directory). In this case, move or copy some of the files in the root directory 
to another location and then start the conversion again.
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Converting FAT32 to NTFS

The Convert FAT32 to NTFS operation launches the Microsoft Convert utility to convert a 
FAT32 partition to NTFS. You must be running Windows 2000 to complete this 
conversion.

Be aware that data in an NTFS partition will not be accessible if you boot DOS or 
Windows 95/98/Me.

The steps for this process are listed on page 90.

After clicking OK, if you have no operations pending and if Windows 2000 can lock the 
partition (no open files), the FAT32 partition is converted. If you have operations pending, 
you must apply them first before converting from FAT32 to NTFS. If you do not apply the 
operations, a prompt appears asking if you want to apply the changes now before 
converting your FAT partition. Click OK to apply the changes and continue with the 
conversion.

If you have any open files a message appears indicating that the convert utility cannot gain 
exclusive access to the drive and asks if you want to schedule the conversion the next time 
the system restarts. If you type Y, the conversion takes place automatically the next time 
you reboot your computer. It is recommended that after typing Y, you close ServerMagic 
and manually reboot to convert the partition.

Converting NTFS Partitions to FAT or FAT32

Converting an NTFS partition to FAT allows you to view the contents of the partition from 
DOS, Windows 9x, or Windows Me, as well as Windows NT and Windows 2000.

Converting an NTFS partition to FAT32 allows you to view the contents of the partition 
from Windows 95b/98/Me/2000. However, a FAT32 partition will not be accessible to 
Windows NT.

IMPORTANT! You will lose file system-specific information when converting from 
NTFS to FAT. Refer to “NTFS Information Lost When Converting to FAT 
or FAT32” on page 95 for additional information.

If the conversion fails when you apply changes, refer to the bulleted list on page 95 for a 
list of possible reasons.
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Restrictions on Converting NTFS Partitions to FAT or FAT32

NTFS is an advanced version of FAT and FAT32. Therefore, depending on the NTFS 
features used on the partition, the type of data, and partition size, you may or may not be 
allowed to complete the conversion.

If you receive an error message and the conversion stops, it is usually caused by one or 
more of the following:

• The file system for conversion is not allowed for the current partition size. A FAT32 
partition should be greater than 256 MB, and a FAT partition must be less than 2 GB.

• The NTFS partition has data in memory that has not yet been written to the hard disk.

• The file system has errors, such as lost clusters and cross-linked files. You can fix 
these problems, then try the conversion again.

• There is not enough temporary space in the partition to do the conversion. The 
conversion will require the NTFS system and the FAT32 system files until the last 
step of the conversion. Also, there is data in NTFS File Replication Services that must 
be moved to external clusters and saved.

NTFS Information Lost When Converting to FAT or FAT32

If you can complete the conversion from NTFS to FAT or FAT32, you may receive a 
warning about the quality of data and feature loss, depending on the features used on the 
partition, the type of data, and the partition size.

Warning Description

Error The conversion is not allowed. Because the partition being converted 
is using advanced features in NTFS, you could experience unintended 
data and feature loss. You will receive an error in one or more of the 
following cases:

• There is more than one data stream for any file.
• Any links.
• Any extended attributes.
• Any user-defined attributes in any file.
• Device entries.
• There are sparse files on the volume. Any sparse files, except for 

the bad sector file, will stop the conversion.
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Warning The conversion is allowed. Although a conversion warning is not as 
serious as an error, you may still experience the loss of NTFS-specific 
features that are not supported in FAT32. You will receive a 
conversion warning in one or more of the following cases:

• Disk usage quotas - NTFS supports limiting the amount of disk 
space for a user. After conversion, all users will have full access 
to all free hard disk space.

• Access control lists - This is a file attribute that lists all the users 
that can access a file. After conversion, all users will have full 
access to all files.

• Index of access control lists - A list of all files that have specific 
access rights assigned to them. After conversion, all users will 
have full access to all files.

• FAST index file - This file is sometimes created on Windows 
2000 computers. After conversion, all indexing of keywords will 
be lost.

• Old versions of files - NTFS has the ability to keep versions of 
files, however, only the current version of the file is converted 
and saved.

No Warning The conversion is allowed. The most basic NTFS partition still gives 
files more features than are found in FAT or FAT32. When Windows 
NT 4.0 is used to copy files from an NTFS partition to a FAT 
partition, no warning is given about the features you are losing. Also, 
the conversion will not give you a warning about specific features that 
cannot be converted. These features include:

• Standard journal file (only used internally by NTFS) - This file is 
a transaction log of changes to the NTFS file system. After 
conversion, the journal file will be lost.

Warning Description
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Converting Partitions to Logical or Primary

You might want to convert a primary partition to a logical partition if you have reached the 
limit of primary partitions on your hard disk. If you create a logical partition, ServerMagic 
will automatically place it in an extended partition. You can then create more logical 
partitions within that extended partition, expanding the maximum number of partitions on 
the disk.

You might want to convert a logical partition to a primary partition if you plan to install an 
operating system on it. The partition must be a primary partition to be bootable.

IMPORTANT! If you convert a primary active partition to logical (such as your Windows 
NT/2000 system partition), your computer will not boot from the hard 
drive.

1 From the Disk drop down list (located on the toolbar), select the disk containing the 
partition you wish to convert.

2 On the partition map, list, or tree view, select the partition you want to convert.

3 On the toolbar Operations ➤ Convert.

• NTFS-specific file attributes - NTFS and FAT both have 
standard file attributes, such as Read-only, Archive, Hidden, and 
System. NTFS has additional file attributes that can be set. After 
conversion, however, these additional file attributes will be lost.

• NTFS-specific file dates - The last edit date is converted to the 
FAT date. After conversion, the creation date, last access date, 
and last edit date (date change only) will be lost.

• Reliable change journal - This journal file is new to Windows 
2000. After conversion, this file will be lost.

Warning Description
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The Convert Partition dialog appears.

4 Click either Primary or Logical.

5 Click OK.

You cannot convert from primary to logical if another primary partition exists between the 
chosen partition and an existing logical partition.

You cannot convert from logical to primary if the conversion would result in more than 
four primary partitions or if the selected partition has one or more logical partitions to the 
left. For example, if you had a primary partition C: and logical partitions D:, E:, and F:, 
you could convert D: to primary, but you could not convert E: or F:.
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C H A P T E R7
Automating Tasks
This chapter includes the following information:

• Wizard Overview

Running Wizards

Applying Changes

Create New Partition Wizard

Resize Partitions Wizard

Redistribute Free Space Wizard

Merge Partitions Wizard

Hiding Wizard Icons

• Scripting
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Wizard Overview

ServerMagic includes five wizards for common tasks. The wizards provide an alternative 
to performing the tasks manually using the commands on the Operations menu.

Running Wizards

There are two ways to run a wizard:

• Click Wizards on the menu bar, then click the wizard you want to run.
• Click the appropriate wizard icon in the ServerMagic main window.

Applying Changes

When you complete a wizard, the partition map and partition list in the main window 
reflect the changes you entered. However, the changes do not actually affect your system 
until you apply them.

You can apply (or discard) changes that you enter using wizards in three ways:

• Click  on the toolbar to apply the changes, or click  on the toolbar to undo 
the changes and start over.

• Click General ➤ Apply Changes (or Discard All Changes or Undo Last Change).

• Click the Apply Changes or Undo Last icon at the bottom of the main window.

After running a wizard, you can run other wizards or perform other partition operations 
and then apply or discard all the pending changes at once.

Create New Partition Wizard

The Create new partition wizard creates a new primary or logical partition.

You should be aware of the following considerations when creating a new partition:

• The file system you choose for the new partition will affect which operating systems 
can access the partition. The wizard dialogs will instruct you about the choices you 
make. For example, if you choose to create a FAT32 partition, the wizard will inform 
you that FAT32 partitions are used by Windows 95 OEM Service Release 2, and 
Windows 98/Me/2000 but that Windows 3.x and DOS cannot access them. Pay close 
attention to the information in the dialog boxes, or you may inadvertently make your 
data inaccessible.



PowerQuest ServerMagic for Windows NT 101

• Before installing Windows NT, make sure that all the partitions that you want 
Windows NT to recognize end prior to cylinder 1024. Otherwise, Windows NT will 
not install and will report that all the partitions are corrupted. If you cannot resize and 
move all partitions, you must obtain updated drivers (Service Pack 5) from Microsoft 
before installing Windows NT.

• After you apply the changes, your computer may reboot if the wizard resized any 
existing partitions. Also, on recognized partition types, the wizard will make the drive 
letter assignments, not the operating system.

Resize Partitions Wizard

The Resize Partitions wizard helps you resize a partition and lets you specify how the 
resize will affect other partitions on the same disk. For example, if you have C: and D: 
partitions and you choose to enlarge C:, the wizard could take space from D: and allocate 
it to C:.

For information about resizing partitions without the wizard, see “Resizing and Moving 
Partitions” on page 42.

Redistribute Free Space Wizard

The Redistribute free space wizard spreads the free space on a hard disk evenly across 
partitions. Free space refers to unused space within partitions and space that is not 
allocated to any partition.

You can redistribute free space on one hard disk at a time. You cannot redistribute free 
space across several disks.

For information about redistributing free space without the wizard, see “Resizing and 
Moving Partitions” on page 42.

Merge Partitions Wizard

The Merge Partitions wizard helps you merge two adjacent FAT or FAT32 partitions. You 
choose two partitions, and the first will be expanded to include the second. The contents of 
the second partition are added as a folder inside the first partition.

Copy Partition Wizard

The Copy Partition wizard Helps you make an exact duplicate of a partition. The copy is 
the same size (or slightly different if copied to another physical disk with a different 
geometry) and file type and contains the same data as the original. When you copy a 
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partition, you specify the hard disk and the unallocated space where you want to place the 
copy. If necessary, the wizard will resize neighboring partitions to create sufficient space 
to perform the copy.

Hiding Wizard Icons

You can choose whether to display the wizard buttons near the bottom of the ServerMagic 
main window. Hiding the wizard buttons increases the display area of the partition list.

1 Click View ➤ Wizard Buttons.

A check mark displays by the menu command if the wizard buttons are displayed. 
Choose the command again to redisplay the buttons.

The setting you choose will remain in effect until you reset it.

Scripting

ServerMagic includes the ability to change the partitions on a computer by running a script 
that you create with ScriptBuilder. The script is an ASCII file with text statements that 
define the operations to take place. To run a script, you pass the script filename to the 
program on the command line.

For additional information about script processing, refer to the ServerMagic online help or 
the SMSCRIPT.PDF file on the ServerMagic CD.
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C H A P T E R8
Remote Agent
This chapter includes the following information:

• Remote Agent Overview

• Creating Remote Agent Boot Disks

• Using the Remote Agent Boot Disk

• Accessing a Remote Server
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Remote Agent Overview

Remote Agent (RA) is a DOS application that is executed on a server that ServerMagic 
can contact across the wire using a TCP/IP connection. Using Remote Agent, you can:

• Copy or move partitions between the remote server running the Remote Agent boot 
disk and the Windows NT/2000 server running ServerMagic

• Copy and consolidate a volume set on the Windows NT/2000 Server running 
ServerMagic to a new partition on the remote server running the Remote Agent boot 
disk

• Delete a remote partition

• Create a remote partition

• Check the integrity of a remote partition

You cannot copy or move partitions from one hard disk on the remote server to another 
hard disk using Remote Agent because it would cause too much network traffic. Instead, 
after you have copied or moved data to a remote server, you should reboot the server 
without using Remote Agent, start Windows NT, and use ServerMagic locally. You can 
also run ServerMagic locally to resize partitions and perform other operations that are not 
available with the Remote Agent. (This scenario assumes that you have ServerMagic 
licenses for both servers.)

Three-Step Process

Using the Connect Remote Agent involves three steps:

1 Create the remote agent boot disks using the Boot Disk Builder program. Refer to the 
Boot Disk Builder online Help file for instructions on creating the remote agent boot 
disks.

You will use the disks to boot the remote server, so the NetWare or Windows 
NT/2000 server running ServerMagic can communicate with the remote server.

2 Boot the remote server using the Remote Agent boot disks you created in step 1.

3 Access the remote server (using the Connect Remote Agent option) from the 
Windows NT server running ServerMagic.

You are ready to perform operations between the Windows NT/2000 server and the 
remote server.

Partitions on the remote drive will appear in the tree view on the left side of the main 
window, so you can choose them like you would any local partition.



PowerQuest ServerMagic for Windows NT 105

Creating Remote Agent Boot Disks

You must create Remote Agent boot disks to run Remote Agent. You can create the disks 
with Boot Disk Builder or with a DOS batch file.

Boot Disk Builder

Boot Disk Builder helps you build a boot disk to run Remote Agent. Boot Disk Builder is 
installed when you install ServerMagic.

1 From the Windows taskbar, click Start ➤ Program Files ➤ ServerMagic 4.0 ➤ 

Boot Disk Builder.

2 From the Boot Disk Builder window, click Next.

To retrieve a configuration file, click File ➤ Load Configuration from the main 
Boot Disk Builder screen, choose the configuration file (*.BDC) you want, then click 
Open.
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3 If your network adapter is listed, go to step 8. If your network adapter is not listed, 
click Add, specify the location of the driver information file (*.INF) for your network 
adapter, then click Next.

4 Choose one or more adapters from the list, then click Next.

5 Specify the Novell NetWare DOS client driver file, then click Next.

6 Specify the Microsoft TCP/IP NDIS DOS driver file, then click Next.

7 Click Finish.

8 Select the network adapter you are using from the list box.
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9 Click Next.

10 Click Obtain an IP address from a DHCP server if a DHCP server is used (the net 
mask and default gateway are automatically provided).

Or specify the IP address and subnet mask if there is no DHCP server.

Ethernet II will display as the frame type for your network.
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11 Click Next.

12 Click the drive letter where you are creating the DOS boot diskette, or click Copy 
boot disk contents to a folder and specify the full path to the folder you want.

13 Insert a formatted diskette.

If you have a boot disk and you want to use your regular DOS files instead of the 
Caldera DOS files included with Boot Disk Builder, complete the following items:

a Insert your boot disk, then click Tools ➤ Load DOS Reference Diskette ➤ From 
A:. The files from your boot disk will be copied to a REFDISK directory where 
Boot Disk Builder is installed. If there are too many to incude along with the 
necessary files that Remote Agent needs, you can delete everything but 
CONFIG.SYS and any drivers started within the CONFIG.SYS file.

b Select Use Reference Disk for DOS Files at the bottom of the dialog box.

c Remove your original boot disk and insert a formatted disk that will become the 
Remote Agent boot disk. (If you do not remove your original disk, Boot Disk 
Builder will overwrite the files on it.)

14 If you want to save your choices for later use, click File ➤ Save Configuration, then 
name and save the file.
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15 Click Back to make any changes, or click Finish to build the boot disk.

Depending on the network interface card selected, the network and Remote Agent 
files may require two diskettes. You will be prompted if a second diskette is needed.

After the boot disk has been created, you can create another boot disk.

When you use the boot disk, Remote Agent will start, and you can specify the IP address 
settings. You can then perform operations “across the wire.”

Boot Disk Files

The Remote Agent boot disk will contain the following files:

• COMMAND.COM
• Device drivers for your network card
• AUTOEXEC.BAT
• LSL.COM
• MOUSE.COM
• NET.CFG
• RA.EXE
• WATTCP.CFG

If the remote server has a bootable partition, you can copy the files from the boot disk to 
that partition and run the Remote Agent from the hard disk.

Using the Remote Agent Boot Disk

1 Insert the RA boot disk into the floppy drive of the remote server, and boot the server.

The Remote Agent dialog box appears. Notice that it is waiting for a connection from 
ServerMagic on the Windows NT/2000 server.

Specifying the IP Address of the Remote Server

The first time you run RA on the remote machine, you may need to specify network 
configuration settings.

1 From the Remote Agent dialog box, click Settings.

2 Click Obtain an IP address from a DHCP server if a DHCP server is used.
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Or, click Specify an IP address, then enter a static local address, net mask, and 
default gateway.

3 Click Save. 

The information you specify in the Local Settings dialog is saved in the 
WATTCP.CFG file on the boot disk.

Notice that the Remote Agent is now ready and waiting for a connection from 
ServerMagic on a Windows NT/2000 server. After a connection is established, you can 
send operations (such as copying a partition) from the Windows NT/2000 server to the 
remote server.

Accessing a Remote Server

After you have booted the remote server using the Remote Agent boot disk, you are ready 
to access the remote machine from ServerMagic on the Windows NT/2000 server.

1 From the Windows NT/2000 server machine, run ServerMagic.

2 Click General ➤ Connect Remote Agent, or click  on the toolbar.

3 Type the local IP address of the server running the Remote Agent.

4 Click Connect.

5 Choose the operations you want to perform on the remote machine.

Operations that are not available are dimmed on the menu.
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C H A P T E R9
Creating a New Boot Drive
This chapter includes the following information:

• Installing a New Server Disk

• Reusing the Old Server Disk
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Installing a New Server Disk

ServerMagic is particularly useful if you have a new, larger hard disk that you want to 
become the boot disk for your server. Not only does ServerMagic save you the time of 
reinstalling Windows NT, it also ensures that the new server disk contains exactly the 
same information as the old server disk.

To move your server installation from an old hard disk to a new hard disk: 

1 Install any drivers you may need for the new drive onto the server operating system.

Usually this step is required only if you are installing a new I/O card on your system 
and you did not install the drivers previously.

2 Shut down the server and turn off the power.

3 Install the new drive as a non-boot device.

This step may require changes to the drive jumper, BIOS, or I/O card settings. 
Consult your hardware manuals for more information.

4 Power on the server and configure the drive.

This step is necessary only if you are adding a new RAID system and need to set the 
RAID level before booting to the operating system.

5 Boot the server to the operating system.

6 Use ServerMagic to copy all partitions on the current drive to the new drive.

7 Resize the partitions as desired.

8 Designate the operating system partition on the new drive as the active partition.

9 Apply all your changes in ServerMagic.

ServerMagic will reboot the server and apply all changes in boot-time mode.

10 Immediately after ServerMagic applies all the operations and reboots the server, turn 
off the power.

11 Remove the old drive from the server. Keep the drive unchanged until you confirm 
that the new disk boots properly.

12 Change the new drive to be the boot device.
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This step may require changes to the drive jumper, BIOS, or I/O card settings. 
Consult your hardware manuals for more information.

13 Turn on the server.

The server should boot from the new disk. Make sure that all drive letters on your 
server match the drive letters previously assigned.

Windows NT/2000 will detect changes to the operating environment and may reassign 
drive letters on the new drive to a different order from what you had previously. The drive 
letters must be in the same order on your new drive for your server to function properly. If 
the Windows NT/2000 operating system partition drive letter is incorrect you may need to 
reboot your server more than once to return it back to the desired letter.

Reusing the Old Server Disk

After confirming that the new hard disk is working properly, you can reuse the old server 
hard disk.

1 Shut down the server and turn off the power.

2 Install the old drive as a non-boot device.

This step may require changes to the drive jumper, BIOS, or I/O card settings. 
Consult your hardware manuals for more information.

3 Boot the server to the operating system.

4 Use ServerMagic to delete all partitions and create new partitions on the old drive.
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A P P E N D I XA
Using ServerMagic With Other 
Programs
This appendix includes the following information:

• Virus Protection Software

• Operating System Boot Utilities

• Compaq Insight Manager (CIM)
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Virus Protection Software

Norton AntiVirus

Because Norton AntiVirus (NAV) interprets changes to partition tables and boot records as 
potential virus attacks, ServerMagic takes steps so that NAV automatically reinoculates. If 
NAV gives you the choice of repairing the changes, do not select Repair. Instead, 
inoculate after using ServerMagic.

Other Virus Protection Software

ServerMagic modifies the master boot record and partitions’ boot sectors. Virus protection 
software should be able to detect that ServerMagic is changing partition tables and not 
boot code; however, virus protection programs could mistake ServerMagic’s changes as 
attempts to install a virus. If this occurs, turn off the virus protection program while using 
ServerMagic and inform the virus protection software manufacturer of the problem. 

Some motherboards contain virus protection software within the BIOS. If this causes a 
problem when you are running ServerMagic, disable the BIOS virus protection, then 
restart ServerMagic.

Operating System Boot Utilities

Both OS/2’s Dual Boot and System Commander 2.0 accommodate boot sector changes 
made by ServerMagic. To install System Commander on drives that ServerMagic has 
modified, you may have to use System Commander 2.06 or later.

If you use System Commander, you must configure it so that it does not simultaneously 
unhide multiple primary partitions. Complete these steps for each operating system 
selection on the System Commander menu:

1 On the Operating System Selection menu, select an operating system.

2 Press <Alt+S>. 

3 From the resulting menu, select the Local Special Options menu.

4 Click Primary partitions accessible on drive 0. 

A screen appears with three options: ALL, AUTO, and NONE. AUTO is the default. 
Select NONE. 

The other primary partitions will now be hidden when this operating system boots.
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Compaq Insight Manager (CIM)

When you attempt to run ServerMagic on a Compaq server in which CIM Agents are 
installed and running, you may receive error 10,032. This error occurs because 
ServerMagic must access your drives at levels CIM Agents do not allow. To avoid this 
problem, you must stop all CIM Agents on the server and then run ServerMagic. (Refer to 
your CIM Agent documentation if you are unsure how to stop CIM Agents.) After 
ServerMagic has completed all operations, you can safely restart the CIM Agents.
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A P P E N D I XB
Troubleshooting
This appendix includes the following information:

• General Troubleshooting

Freeing Memory to Run ServerMagic under DOS

Assigning a CD-ROM Drive Letter

Using ServerMagic With a SCSI Hard Disk

Resolving Check Errors

Resolving Partition Table Errors

Partition Tables and Viruses

Partition Will Not Boot After Resizing

• Generating Diagnostic Reports with PartitionInfo

• Error Messages and Solutions
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General Troubleshooting

This section addresses the following situations:

• Freeing Memory to Run ServerMagic under DOS

• Assigning a CD-ROM Drive Letter

• Using ServerMagic With a SCSI Hard Disk

• Resolving Check Errors

• Resolving Partition Table Errors

• Partition Tables and Viruses

Freeing Memory to Run ServerMagic under DOS

The DOS ServerMagic executable requires a minimum of 585 KB of memory in the first 
640 K of the computer’s address space (conventional memory). If you do not have 
sufficient conventional memory, there are several ways you can free additional memory.

Running MEMMAKER

MEMMAKER is a program that automatically configures your computer to save 
conventional memory (while still loading all of the device drivers and other programs you 
usually load when booting DOS). MEMMAKER frees conventional memory by moving 
as many programs as possible out of conventional memory into high memory. Run 
MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen 
instructions.

MEMMAKER is only available in DOS 5.0 to 6.22. It is not available in Windows 95 or 
Windows 98 DOS mode.

Using the F8 Key to Keep Programs From Loading

Press <F8> immediately after booting your computer (while DOS is booting). As DOS 
reads the each command in the CONFIG.SYS and AUTOEXEC.BAT files, it asks if you 
want the command executed. When you see commands that load device drivers or TSR 
programs not needed to run ServerMagic, press N so that the software is not loaded into 
memory.
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Deleting Operating System Compression Files

If you use DOS 6.22, Windows 95, or Windows 98 and your system does not have any 
compressed drives (using programs such as DriveSpace, DoubleSpace, and Stacker), you 
can delete the operating system compression files, DRVSPACE.BIN or DBLSPACE.BIN, 
from any boot diskette you create. This frees conventional memory because DOS 6.22, 
Windows 95, and Windows 98 load these files into memory, regardless of the contents of 
CONFIG.SYS and AUTOEXEC.BAT.

DRVSPACE.BIN and DBLSPACE.BIN are hidden system files. To delete them, complete 
the following:

1 Place your boot diskette in your diskette drive.

1 Go to a DOS prompt. 

2 Type A: and press <Enter>. You should see A:\> on your screen.

3 Type ATTRIB -R -H -S *.BIN, and press <Enter>.

4 Type DEL *.BIN and press <Enter>.

Assigning a CD-ROM Drive Letter

ServerMagic does not allow you to assign drive letters to CD-ROM drives or other 
removable media drives. Use Disk Administrator to perform these operations.

Using ServerMagic With a SCSI Hard Disk

To use ServerMagic on a SCSI hard disk, you must have a SCSI controller card that 
supports software Interrupt 13. Most SCSI controller cards let you enable software 
Interrupt 13 support in the BIOS through the card. If your SCSI controller card does not, 
contact the manufacturer to determine if your adapter can support software Interrupt 13. 
As a general rule, if you are able to use FDISK to partition the disk, you will also be able 
to use ServerMagic.

Resolving Check Errors

ServerMagic checks the integrity of a partition thoroughly before making changes to it. 
The Check for Errors and Info operations perform the same checks and display error 
messages when they discover problems. For more information, see “Checking Partitions 
for Errors” on page 56 and “Getting Information About Partitions” on page 61. These 
checks are similar to those made by Windows NT CHKDSK.
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ServerMagic also checks a partition after modifying it. While data loss is possible, it is not 
typical. The problem is usually a minor file system error that CHKDSK /F can correct 
without data loss. For more extensive errors, you may need to restore your files from a 
backup copy. If problems persist, report the problem to PowerQuest technical support.

If you receive an error message on any partition, back up your hard disk and then run 
CHKDSK on that partition; do not use the /F switch on the initial run. CHKDSK generally 
discovers the same problems as ServerMagic. 

If CHKDSK does not show the same errors as the Check for Errors operation, contact 
PowerQuest technical support.

If CHKDSK and the Check for Errors operation detect the same errors, which is usually 
the case, run CHKDSK /F to fix the problems. Then run CHKDSK again without the /F 
switch to ensure that the partition is error free.

When CHKDSK reports no errors on the partition, run the Check for Errors operation. If 
ServerMagic still reports a problem, reformat the partition and restore your files from the 
backup copy.

Resolving Partition Table Errors

Partition table errors are errors in the 100 - 199 range. In most cases, you must resolve 
partition table errors by creating new, error-free partition tables. The general steps are: (1) 
ensure you have no viruses (see below), (2) back up the data on the affected partitions, (3) 
delete the partitions, (4) recreate them, and (5) restore their contents. You may need to use 
the FDISK program from a recent DOS version, as earlier versions may refuse to delete 
HPFS or hidden partitions, and the OS/2 FDISK program may recognize the partition’s 
corruption and refuse to modify it.

In some cases, you can resolve partition table errors manually. Run PartitionInfo to 
determine the errors on your partitions. PowerQuest technical support can help resolve 
partition table errors if you e-mail the PartitionInfo report to help@powerquest.com. 
Refer to “Generating Diagnostic Reports with PartitionInfo” on page 123 for additional 
information about PartitionInfo.

Partition Tables and Viruses

If partition changes made under one operating system are not reflected under another, and 
vice versa, a master boot record (MBR) virus may be present.

Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is 
likely. Before removing the virus, boot each operating system and use the Check for Errors 
operation to evaluate the integrity of the partition. Back up the files on any partition that 
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passes the Check for Errors operation. Then remove the virus and perform the Check for 
Errors operation on the partitions again. Delete and recreate any partitions that fail the 
check. Finally, reinstall the operating systems and restore the backup files as necessary.

Partition Will Not Boot After Resizing

Occasionally, resizing a FAT partition displaces the first few files on the partition (such as 
IO.SYS and MSDOS.SYS if the partition contains an operating system). If you resize a 
boot partition and then it fails to boot, run SYS.COM from DOS or from the ServerMagic 
rescue diskettes.

Generating Diagnostic Reports with PartitionInfo

PartitionInfo generates a report showing the contents of your hard disk partition table. This 
information is helpful in resolving various partitioning problems. 

You can run PartitionInfo under Windows 95, Windows 98, Windows Me, Windows NT, 
and Windows 2000. Under DOS or Windows 3.x, run PARTINFO.EXE (see page 125).

Every time you run ServerMagic, it creates a snapshot file PQ_DEBUG.TXT that includes 
information about all the disks and partitions on your machine. The file is saved in the 
%SystemRoot%\system32 directory. The PQ_DEBUG.TXT file may be beneficial for 
PowerQuest technical support if you call PowerQuest for help resolving problems with 
ServerMagic.

1 Click Start ➤ Program Files ➤ PowerQuest ServerMagic 4.0 ➤ PartitionInfo. 

The PartitionInfo window appears, displaying partition and disk geometry 
information and disk and partition errors. Disk geometry information includes data 
from the master boot record and the extended partition boot records.



Appendix B: Troubleshooting124

Only errors that display in the box near the top of the screen indicate problems. Do 
not be concerned with Warnings and Infos in the bottom two boxes.

2 From the Physical Drive drop-down list, select the disk for which you wish to view 
information.

3 You can save the PartitionInfo report as a file, or you can print it.

To do this: Do this:

Save the report as a file Click Save As. In the Filename box, type a name 
for the file. Click Save. (Columns of information 
are separated by tabs, so you can open the file in a 
word processor and easily format the report.)

To change the font for a 
printed report

Click Printer Font. Select the desired font, font 
style, size, and so forth. Click OK.

To change printer setup Click File ➤ Printer Setup. We recommend that 
you set the page orientation to landscape to avoid 
text being cut off at the right margin.

To print a report Click Print, then click OK.
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4 To exit PartitionInfo, click Close.

Generating Diagnostic Reports with PARTINFO.EXE

You can also run PARTINFO.EXE from the first rescue disk to get partition information. 
The PARTINFO program provides essentially the same information as the PartitionInfo 
program but without the Windows interface.

1 Boot the computer to DOS.

2 Insert the first rescue diskette, and change to the drive the diskette is in.

3 You have several options for running PARTINFO. 

Error Messages and Solutions

ServerMagic error messages and possible solutions are listed below by number. The 
messages are also grouped in number ranges by error category. 

If you encounter an error not mentioned in this appendix, visit PowerQuest’s web site at 
support.powerquest.com and click Master Error List to display for a current listing. 
Error message information on the web site is available in English only.

Miscellaneous Errors (3–38)

#3 Not enough memory

This error can occur when you are resizing, moving, or copying an extremely 
large partition (60 GB) or when manipulating smaller partitions in DOS with 
EMM386 loaded. EMM386 limits the amount of memory the program can 
access. To solve the problem, modify your CONFIG.SYS file by commenting the 
EMM386 line. For more information about memory requirements, see 
“ServerMagic System Requirements” on page 16.

To do this: Do this:

To display partition 
information on your screen

Type PARTINFO, then press <Enter>.

To send a report directly to 
your printer

Type PARTINFO >LPT1 or PARTINFO 
>PRN, then press <Enter>.

To save the report as a text file 
on a floppy disk

Type PARTINFO >A:\PARTINFO.TXT, 
then press <Enter>.

http://www.powerquest.com/support
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The DOS ServerMagic executable requires a minimum of 585 KB of memory in 
the first 640 KB of the computer’s address space (conventional memory) and 8 
MB of total memory. For possible solutions if you have insufficient conventional 
memory, see “Freeing Memory to Run ServerMagic under DOS” on page 120.

#8 Could not allocate/deallocate DOS real mode memory

The DOS ServerMagic executable running under DOS, Windows 3.x, Windows 
95, and Windows 98 requires some memory in the first 1 MB of the computer’s 
address space. (ServerMagic uses a DOS extender.) If not enough memory is 
available, ServerMagic cannot access the hard disk. For possible solutions, see 
“Freeing Memory to Run ServerMagic under DOS” on page 120.

#27 Cannot lock drive 

Under multitasking operating systems such as Windows 95, ServerMagic must 
lock a partition before it can safely modify it. If the hard disk contains files that 
are in use by another process, ServerMagic cannot lock the partition. 

#29 Cannot lock a locked drive

Verify that the partitions you are attempting to modify are not on a locked hard 
disk.

#34 The time has expired on this evaluation version

PowerQuest occasionally releases beta versions and evaluation versions of 
ServerMagic. Both versions are not as safe as release versions; therefore, 
PowerQuest builds an expiration date into each version. After a predetermined 
test period, the beta or evaluation version no longer functions. 

Disk Access Errors (40–56)

Errors in the 40–56 number range indicate that accessing your disk is not possible, and 
often result from hardware problems. Some problems may have simple solutions; for 
others, the only solution may be replacing the hard disk. When possible, ServerMagic 
detects major errors before any changes have been made so you can back up your data 
before replacing the hard disk.

#45 CRC error in data

When ServerMagic or any other program reads information off of a hard                     
disk, it checks the CRC (cyclic redundancy check) information contained in                     
each sector. If it performs a CRC test and the result is different from the                     
value stored on that sector, there is a CRC error. This usually means one of                     
two things.
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• The file being read has become corrupted by some other means.
• A sector used in the file’s storage has become bad and corrupted                     

that part of the stored file.

The solution is to do a surface test to make sure any bad sectors are marked as 
bad, then reinstall the software involved to ensure that files on the system are not 
corrupted. You may also want to try running ServerMagic with an /IRE switch. 

#48 Sector not found

This error can be reported when a given sector cannot be read or written to.                     
There are many possible causes.

If you are encountering this error, make sure that your BIOS supports the 
operating system and hard disk on the system. Also run a thorough ScanDisk on 
the drive to prevent data from being written to bad sectors. 

#49 Write fault 

#50 Read fault

(The following information applies to errors 49 and 50.) 

ServerMagic is unable to write to/read from a specific sector on the hard disk. 
Possible causes include:

• If your PC beeps or displays a black box in the middle of the screen, virus 
protection is enabled in your computer’s BIOS. Disable virus or boot sector 
protection in the BIOS.

• A virus protection application (which may be a TSR or DLL program) is in 
use. Disable the application before using ServerMagic.

• There is a bad sector on the hard disk (this is usually the case only with older 
hard disks). Run ScanDisk on the hard disk to perform a surface scan to verify 
the existence of bad sectors. If your drive has bad sectors, we recommend you 
replace it.

• You have set up disk mirroring with PC-Tools. Disable the disk mirroring 
option.

Miscellaneous Errors

#70 Changes to the drive cannot be made under Windows

If you are using Windows 3.x, you cannot run ServerMagic for Windows 95, 
Windows 98, or Windows NT Workstation. You must run ServerMagic for DOS 
from a DOS prompt.
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#89 EZ-Drive has been detected on the drive but is not running
#90 EEZ-Drive has been detected on the drive but EZ-Drive is corrupt
#91 Disk Manager has been detected on the drive but is not running

These errors are “first head” errors. They can be resolved with assistance from 
PowerQuest technical support. Before calling technical support, please type the 
following at a DOS prompt: wrprog /bak >x:head1.dat, where x: is 
one of the drives on your machine.

The wrprog.exe file can be found in the Utility\DOS folder under your 
PowerQuest product folder. If you are running under Windows NT and do not 
have DOS available, you can use the DOS rescue diskettes you created for your 
PowerQuest software.

#98 Hibernate Windows 2000
#99 Hibernate Windows Me

Hibernation saves the system RAM to a file, then uses Advanced Power 
Management to shut the system down. When the machine is subsequently booted, 
the hibernation file is read into RAM, and execution begins where it left off.

A hibernated system assumes when it is booted that the system is in the same 
state as when hibernation occurred. Any changes made to the system’s hardware 
(including disks and disk partitions) may cause unexpected results.

See Microsoft’s Knowledge Base article #241354 for more information about 
making modifications to a system while in hibernation mode.

To avoid this error, shut down your machine normally and then restart.

Partition Table Errors (100–199)

Errors in the 100–199 number range are partition table errors. For general information 
about resolving these errors, see “Resolving Partition Table Errors” on page 122 and 
“Partition Tables and Viruses” on page 122.

#100 Partition table is bad

The master boot record (MBR) can contain, at most, one extended partition, and 
each extended partition boot record (EPBR) can contain, at most, one link to 
another EPBR. This error occurs when a partition table violates the foregoing 
rule. It can also occur if you have more than one active partition. Since any 
modifications ServerMagic makes may decrease the amount of data that is 
recoverable from the hard disk, ServerMagic does not recognize any of the hard 
disk’s partitions. If you must create new, error-free partition tables to resolve 
your problem, see “Resolving Partition Table Errors” on page 122 for 
instructions.
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#104 No sectors in partition 

No partition should contain zero sectors. Delete the partition before using 
ServerMagic. 

#105 Partition starts on wrong boundary 

The hard-disk partition table contains erroneous values. ServerMagic expects 
partitions to begin and end on the correct cylinder boundaries. If they do not, the 
disk may be partially corrupted. In this circumstance, if ServerMagic were to 
make any modifications it might cause the loss of data. Therefore, ServerMagic 
refuses to recognize any of the hard disk’s partitions. To resolve this problem, see 
the instructions in “Resolving Partition Table Errors” on page 122.

#106 Partition doesn’t start with sector one

See error #105.

#107 Partition begins after end of disk 

This error can occur if a partition erroneously extends beyond the physical end of 
the hard disk. This may happen if the hard disk has been used on a different 
computer or with a different hard-disk controller or if BIOS settings have been 
changed. Be advised that the physical geometry of the hard disk may differ from 
the logical geometry assigned to the hard disk by the operating system.

#108 Partition doesn’t end at end of cylinder 

See error #105.

#109 Partition ends after end of disk 

See error #107.

#110 Partition table number of sectors is inconsistent 

The hard-disk partition table contains two inconsistent descriptions of the number 
of sectors on the hard disk. This error is serious if both DOS and another 
operating system use the hard disk. Because DOS uses one description and other 
operating systems may use the other, data loss is likely once the partition is 
almost full. To resolve this error, see the instructions in “Resolving Partition 
Table Errors” on page 122.

#111 The order of entries in the EPBR is not correct.

An extended partition boot record (EPBR) is a sector on the hard disk that 
contains a partition table. The EPBR partition table is special because it generally 
only has two valid entries: one for the logical partition and one that is a pointer to 
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the next EPBR. The standard is for the logical partition's entry to be the first entry 
in the table and the second entry is the pointer to the next EPBR. The third and 
fourth entries are not used. For some utilities, such as IBM's Boot Manager, the 
order of these entries is important because the utilitiy expects the first entry to be 
the logical and the second entry to be the pointer to the next EPBR. If 
ServerMagic detects that the EPBR entries are out of order, you will be prompted 
to fix the error. If you choose to fix the error, ServerMagic will reorder the EPBR 
entries for you automatically.

#112 Logical partition ends outside Extended 

See error #111. 

#113 Partitions overlap 

The hard-disk partition table contains erroneous values. If data partitions overlap, 
writing to one may destroy data in another.

This error is sometimes the result of an OS/2 FDISK bug. If free space exists 
within the extended partition, OS/2’s FDISK program allows a primary partition 
to be created that overlaps the extended partition. A logical partition is 
subsequently created in the space occupied by the overlapping primary partition. 

If a primary partition overlaps the end of the extended partition but does not 
overlap any logical partitions within the extended partition, the problem can be 
remedied by patching the partition table. Only qualified individuals should 
attempt this repair! An incorrect patch could destroy all data on the hard 
disk! In most instances, you should resolve the problem as explained in 
“Resolving Partition Table Errors” on page 122.

#116 Partition table Begin and Start inconsistent

The hard-disk partition table contains two inconsistent descriptions of the 
partition’s starting sector. This error can occur if the operating system reports a 
hard-disk geometry that is different than the geometry in use when the partition 
table was written. Possible causes include: (1) different operating systems (for 
example, DOS and OS/2) report different hard-disk geometries, (2) you boot 
from a diskette that loads a different driver than is loaded when you boot from the 
hard disk, (3) upgrading the operating system (for example, from OS/2 2.x to 
OS/2 Warp) causes a different driver to be used, (4) the hard disk or controller 
has been changed, (5) the BIOS has been upgraded, (6) the BIOS LBA setting has 
been changed, or (7) there is a partition table virus present on the hard disk.
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In most instances, you should resolve the problem as explained in “Resolving 
Partition Table Errors” on page 122. You can also use a virus scanning program 
to remove any partition table virus. Data loss is possible if the number of heads or 
sectors per track has changed since you first created your partitions.

#120 The logical drive chain is incompatible 

This error occurs under some operating systems when logical partitions are not 
chained together in the expected order. DOS, OS/2, Windows 95, Windows 98, 
and Windows NT require that logical partitions be chained together in ascending 
order. Some other operating systems do not require this. For example, some 
versions of the Linux FDISK utility chain logical partitions together in the order 
they are created. This error message identifies a very dangerous situation; using 
the DOS FDISK in this situation can cause loss of one or more partitions. 

For solutions to this problem, see the instructions in “Resolving Partition Table 
Errors” on page 122. If you decide to back up your data and recreate your 
partitions, you may have to use the same partitioning program that you used to 
create the partitions in order to delete them.

#121 The first sector of the drive cannot be read 

The first sector of the hard disk (cylinder 0, head 0, sector 1) contains the master 
boot record (MBR) and the primary partition table. ServerMagic cannot make 
changes to this hard disk because an error occurred when it read the first sector. 
See error #50 for information on resolving this error.

#122 A bad sector was found in the current or new partition area 

The partition cannot be moved safely because there is a bad sector in the new or 
current partition area. When you see this error message, the move operation is 
aborted before any corruption can occur. Try moving the partition to a different 
place. If your hard disk has bad sectors, we recommend that you replace the hard 
disk.

#140 Overlapping partitions found. No partitions can be undeleted.

Two or more deleted file systems were found in the unallocated space. However, 
each file system claims space that another file system also claims. There are no 
other partitions that can be undeleted.
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Networking Errors (200-299)

#202 Network read failed
#203 Network write failed

Socket read or write was unable to read or write the requested amount of data. Be 
sure the network connection is working properly. If this error occurs during an 
operation, the destination partition and partition table may be corrupted. If this 
happens, you must delete the affected partition, repair the partition table, and redo 
the operation.

#215 The connection was aborted due to timeout or other failure

The established connection was locally aborted. Be sure that the network 
connection is working properly. If this error occurs during an operation, the 
destination partition and partition table may be corrupted. If this happens, you 
must delete the affected partition, repair the partition table, and redo the 
operation.

#217 Attempt to connect timed out without establishing a connection

The network connection timed out. Be sure that the network connection is 
working properly. If this error occurs during an operation, the destination 
partition and partition table may be corrupted. If this happens, you must delete 
the affected partition, repair the partition table, and redo the operation.

#218 The attempt to connect was forcibly rejected

The network connection was refused. No connection could be made because the 
target machine actively refused it. This error occurs when you attempt to connect 
to a remote machine from ServerMagic but there is already another server 
connected to it. You must wait until the other server has disconnected from the 
remote machine.

#220 The Link Support Layer (LSL) driver and supporting NIC driver are not 
loaded.

Ensure that the LSL driver and appropriate NIC driver are on the Remote Agent 
boot disk and are being loaded before you run Remote Agent.

#221 The connection was reset by peer executing a hard or abortive close

The connection was forcibly closed by the remote host. This error generally 
indicates that the peer application on the remote host was suddenly stopped or the 
host was rebooted. This error may also result if a connection is broken due to 
keep-alive activity detecting a failure while one or more operations are in 
progress. Operations that were in progress fail. If this error occurs during an 
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operation, the destination partition and partition table may be corrupted. If this 
happens, you must delete the affected partition, repair the partition table, and redo 
the operation.

#223 No buffers declared for Link Support Layer (LSL) driver in NET.CFG.

No buffers have been declared for the Link Support Layer (LSL) driver in 
NET.CFG on the Remote Agent boot disk. Edit the NET.CFG file to ensure that 
the link support section has buffers declared.

#224 Buffer size for Link Support Layer (LSL) driver in NET.CFG is too small

The buffer size for the Link Support Layer (LSL) driver in NET.CFG on the 
Remote Agent boot disk is too small. Edit the NET.CFG file, and ensure that the 
link support buffer size is at least 1600.

#225 The Link Support Layer (LSL) driver does not support ETHERNET_II 
frames

In NET.CFG on the Remote Agent boot disk, the Link Support Layer (LSL) 
driver does not support ETHERNET_II frames. Edit the NET.CFG file on the 
Remote Agent boot disk, and ensure that the link driver section specifies the 
ETHERNET_II frame type.

Check Errors (500–599)

Check errors occur when ServerMagic checks the integrity of a partition. For general 
information about resolving these errors, see “Resolving Check Errors” on page 121.

#500 Subdirectory is corrupted 

This error message reveals the name of the corrupted subdirectory. Back up the 
contents of that directory and its subdirectories. You can then delete the corrupted 
subdirectory.

#501 Cross-linked files were found

Multiple files claim the same clusters. ServerMagic can fix this error when it 
occurs on an NTFS partition. For more information, see “Checking Partitions for 
Errors” on page 56. ServerMagic lets you fix this error by: (1) copying the shared 
clusters to each affected file, (2) deleting all affected files, or (3) keeping one file 
and deleting the other affected files.
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#506 Not enough free space on partition to shrink

Some free space (which is dependent on the hard disk’s current contents) is 
required to resize a partition smaller. Delete unneeded and duplicate files in the 
partition and then attempt the operation again.

#508 As specified, the operation does not change the partition

You have entered a value that is the same as or (when rounded to the required 
cylinder boundary) rounds to the same as the partition’s present value. Enter a 
larger change.

#509 A bad sector was detected in the current or new FS area 

In order to perform the resize operation that you requested, ServerMagic 
attempted to expand the file system area. However, the program found a bad 
sector in the new area. Try moving the partition before you resize it. No 
corruption occurs when you encounter this error.

#510 The version of the file system is not supported

An updated version of ServerMagic is required to operate on this new version of 
the file system. Visit www.powerquest.com/updates for information about 
updated versions of ServerMagic.

Batch Errors (600–633)

#600 Error trying to create batch file 
#601 Error trying to write batch file
#602 Batch file not found

(The following information applies to errors 600–602.) 

ServerMagic lets you specify a series of changes you want to make to your 
partitions, and then executes all the changes when you click Apply. At this point, 
ServerMagic writes out a command list file (called a “batch file”) to disk in 
preparation for execution, and then reads the file upon execution (immediately if 
a lock can be secured on all impacted partitions, or in a special “reboot” mode 
after rebooting your computer if not all locks can be secured). In the 
Windows 95, Windows 98, and Windows NT Workstation versions of 
ServerMagic, the batch file is located in your Windows\System directory. In the 
DOS versions, it is located in the directory from which ServerMagic is running. 
The batch filename is PQ_SM40.PQB.

http://www.powerquest.com/updates
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If the batch file cannot be created, cannot be written, or cannot be located when 
ServerMagic attempts to execute the command file, the above error messages 
appear. You should contact PowerQuest technical support. See Appendix C of 
this user guide for more information.

#603 Unknown batch operation

The batch file contained an operation unknown to ServerMagic. Contact 
PowerQuest technical support. See Appendix C of this user guide for more 
information.

#625 Changes cannot be applied

Generally error 625 only occurs when the system needs to go into boot-mode to 
execute your commands. A 625 error occurs when your disk geometry is seen 
differently in your native Windows version of ServerMagic than it is in the 
boot-mode version. For security reasons, ServerMagic cannot apply your changes 
without risking data loss.

One common configuration that will cause a 625 error is a system that has a hard 
disk (such as a SCSI or removable drive) that is visible in Windows but that 
cannot be seen in the boot-mode environment.

Some possible solutions include:

• Make sure the operation executes in native Windows mode (without resorting 
to boot-mode execution). ServerMagic will only go into boot-mode if it cannot 
lock a partition (that is, if there are any open files on the partition). Try to 
confine all operations to drives ServerMagic can lock before clicking the 
Apply Changes button.

• Change the configuration of the offending disk (most likely the SCSI or 
removable drive) by changing the BIOS setup for that disk. Doing so will 
ensure that the native and boot-mode environments detect identical hard disk 
configurations. If this does not work, you can try temporarily disabling the 
offending disk.

This error usually indicates that some other application has modified your disk 
configuration while you were running ServerMagic. Make sure no other 
applications are loaded while ServerMagic is running.
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User Interaction Errors (950–999)

#950 Unable to detect any disk drives 

No partitionable hard disks were found on your computer. Diskette drives and 
many removable media drives do not support partitioning. ServerMagic cannot 
perform operations on disks in such drives.

#951 An invalid value was entered

The value entered is outside the range or (when rounded to the required cylinder 
boundary) rounds to a value that is outside the range for the operation specified. 
Check the displayed range and reenter the value.

#952 Value entered is the same as the current value 

See error #508.

#963 Selected operation is currently invalid

Not all ServerMagic operations can be performed on all partitions. For example, 
you cannot convert an HPFS partition to NTFS, and you cannot create a partition 
if there is not enough unallocated space on the hard disk.

Under Windows, options that are not available either do not appear on the menus 
or they appear dimmed. However, if you are running scripts with the DOS 
version, there are no menus so you cannot see which operations are available. 
Refer to the relevant information in this user guide or the online Help for 
restrictions that explain why an operation is not available.

#967 Could not perform operation to the value specified 

This error occurs only when you run ServerMagic from a script. If the value 
specified on a resize or move operation is not between the minimum and 
maximum possible, script execution stops and this error displays.

#968 Incorrect Volume Label entered, Deletion not performed

To delete a partition, ServerMagic requires you to type OK to confirm that you 
want to delete the partition. If the volume label you enter does not match the 
volume label of the partition you want to delete, this error appears. 

#969 Incorrect Volume Label entered, Unable to proceed. 

To format an existing partition, ServerMagic requires you to type OK to confirm 
that you want to format the partition. If the volume label you enter does not match 
the volume label of the partition you are attempting to format, this error appears.
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#970 Invalid Bad Sector Check value specified 

This error occurs only in the enterprise version of ServerMagic from a running 
script. If the script command SET DEFAULT BAD SECTOR TEST STATE is 
not followed by either ON or OFF, this error appears. 

#971 The label entered was too long 

When you enter a volume label, the process that checks the validity of the label 
displays this message if the label is too long. The label must be no longer than 11 
characters.

#972 Invalid characters in the label

When you enter a volume label, the process that checks the validity of the label 
displays this message if the label has characters that are invalid. Invalid 
characters include the following: [ * ? : < > | + = ; \ / ” , ].

#973 Volume Label cannot have leading spaces 

When you enter a volume label, the process that checks the validity of the label 
displays this message if you enter a label in which a space or spaces are the 
leading characters. 

#974 Root size specified was not in the valid range 

This error occurs only when you run ServerMagic from a script. If you use the 
Create, Format, or Resize Root operations, and the number of root entries 
specified is not within the acceptable range for that partition, this error appears. 
Generally, the valid range is from 64 to 1,024.

#975 The cluster size specified was invalid for this partition

This error message displays only in the enterprise version of ServerMagic from a 
running script. Many commands have a cluster size option. If a script command 
specifies an invalid cluster size (for the type and size of the partition), this error 
appears.

#976 Cannot create the file system specified in the current space 

This error message displays only in the enterprise version from a running script. 
When you use the Create or Format commands, you must also choose a file 
system type. If the file system or partition type you specified cannot be created in 
the space available, this error appears.
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#977 Partition selected is invalid 

This error message displays only in the enterprise version of ServerMagic from a 
running script. If the partition selected from the Select Partition command is not a 
valid partition, this error appears.

#978 Unable to set to proper partition after last operation. Script halted.

This error message appears only in the enterprise version of ServerMagic from a 
running script. After each operation, ServerMagic ensures that the right partition 
is still selected. If ServerMagic is not able to select the proper partition, it ends 
script processing and displays this error.

#986 Unable to get information for the specified partition

ServerMagic reports this error most commonly when MS-DOS-based                     
terminate-and-stay-resident programs (TSRs), are running in the background. 
These TSRs will be located in the CONFIG.SYS or AUTOEXEC.BAT files.

One such TSR is the SUBST command. The SUBST can be used to associate a 
path with a drive letter. This creates a "virtual drive" that can be accessed as an 
additional local drive. The SUBST command is classified as a "dirty" or "deadly" 
TSR, and cannot be loaded at the same time that ServerMagic is running.

To solve the problem, you must remark out the Config.sys or Autoexec.bat line 
that is loading the SUBST command. This command can be reinstated after 
running ServerMagic.

There are other “dirty” or “deadly” TSRs that may cause a problem. If you are 
experiencing this error and are not using the SUBST command, find and remark 
out any of the following commands: Join, Append, or Assign. 

This error can also be reported if your C: drive is compressed. If the C: drive is 
compressed, you will need to either uncompress the drive, or run ServerMagic 
from the rescue diskettes.

This error can also be caused by multiple partition table errors. If any of the 
above solutions do not apply, run PartitionInfo and send the report to PowerQuest 
technical support. Refer to “Generating Diagnostic Reports with PartitionInfo” 
on page 123 for information about PartitionInfo and PARTINFO.

#996 Invalid password

If you forget your ServerMagic password, go to the directory that contains 
SMAGIC.EXE and delete PQMAGIC.PSW. Deleting this file removes the 
password protection from ServerMagic. You can then restart ServerMagic and, if 
you wish, set a new password.
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NTFS Check Errors (1500–1699)

Errors 1500–1699 are NTFS-specific check errors, which can occur when ServerMagic 
checks the integrity of a partition. ServerMagic can fix certain errors when you perform 
the Check operation. For more information, see “Checking Partitions for Errors” on page 
56 and “Resolving Check Errors” on page 121.

In this section, “attribute” does not mean read-only, hidden, system, etc. Rather, 
“attribute” means one of a file’s data streams.

#1501 Wrong version of NTFS 

The partition was created using a version of the NTFS file format that 
ServerMagic cannot work with.

#1503 Bad NTFS cluster size 

The NTFS cluster size must be 512, 1,024, 2,048, 4,096, 8,192, 16,384, 32,768, 
or 65,536 bytes.

#1512 Restart record mismatch

The two restart entries in the journal file are different. This may happen if 
Windows NT Workstation is not properly shut down. To fix this problem, restart 
Windows NT Workstation and shut it down using the Shut Down command.

#1516 Partition improperly dismounted

The partition dirty flag is set in a restart record in the journal file. This error may 
have been caused by a power failure or system crash while the Windows NT 
operating system was writing the partition. Reboot Windows NT and execute 
CHKDSK /F to repair the damage.

#1527 Bad update sequence number

A buffer contains mismatched update sequence numbers. This error may have 
been caused by a power failure or system crash while the Windows NT operating 
system was writing to the partition. Reboot Windows NT Workstation and 
execute CHKDSK /F to repair the damage.

#1529 Information mismatch in directory entry

A file attribute stored in a file record is different from the attribute stored in its 
directory entry. If this error is in a system file (file 0–10), Windows NT 
CHKDSK does not fix it, but Windows NT rebuilds the root directory on the 
partition the next time the operating system is started.



Appendix B: Troubleshooting140

#1538 Can’t find contiguous space to move

The partition does not contain enough contiguous free space to hold the new copy 
of a file that must be contiguous. You normally encounter this error when you use 
the Resize option to resize a partition smaller.

#1539 File size mismatch

The size of a system file (file 0–15) recorded in its file record does not match 
either the size recorded in its directory entry in the root directory or the size of its 
data stream.

#1544 External attribute list in external attribute

An external file record has an external attribute list.

#1545 File attributes out of order

The attributes in a file must appear in order of increasing numeric type.

#1546 Attribute neither resident nor nonresident

The attribute resident flag has a value other than resident or nonresident.

#1547 Wrong run limits

A run has more clusters than the difference between its highest and lowest 
cluster.

#1548 File table has fewer than 16 entries

The file table must have at least 16 entries.

#1549 File table has more than 4 billion entries

The file table must have fewer than 4 billion entries.

#1604 File’s parent does not contain the file

The file’s parent directory does not contain a reference to the file, or a file’s size, 
date, or time information does not match the file’s parent directory information. 
This error can be fixed when you perform the Check operation. For more 
information, see “Checking Partitions for Errors” on page 56. When you fix this 
error, ServerMagic updates the file’s parent directory information.

#1609 Lost cluster(s)

The volume bitmap shows clusters as being used which are not used (no file 
claims them). This error can be fixed when you perform the Check operation. For 
more information, see “Checking Partitions for Errors” on page 56. ServerMagic 
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lets you fix this error by either deleting the lost clusters or by saving them in a file 
in the root directory. The filename is FILEXXXX.PQE, where XXXX is a 
number between 0000 and 9999.

#1630 Inconsistent sizes in attribute header

File size information is incorrect. This error can be fixed when you perform the 
Check operation. For more information, see “Checking Partitions for Errors” on 
page 56. When you fix this error, ServerMagic computes the correct file size 
information.

#1644 Bad system file sequence number

A system file has a bad sequence number. System files must have a sequence 
number from 1 to 15. A partition with this problem may pass Windows NT 
CHKDSK, but Windows NT does not mount the partition the next time the 
operating system is started.

#1647 Error in root directory index

There is an error in the root directory’s index. Running Windows NT CHKDSK 
does not fix this problem, but Windows NT automatically rebuilds the root 
directory on the partition the next time it is started.

#1681 Data is compressed or sparse

The NTFS file system cannot be converted to FAT or FAT32 because a file has 
been compressed. The conversion cannot run unless all files are decompressed. 
(The FRS number for the compressed file is shown.)

#1687 An object index is present

A file with an object index created by Windows 2000 was found. For example, 
users may have been assigned disk space quotas. When converting a partition to 
FAT or FAT32, this information will not be saved, since FAT and FAT32 file 
systems do not support object indexes. (The FRS number for the compressed file 
found is shown.)

FAT Check Errors (2000–2099)

Check errors occur when ServerMagic checks the integrity of a partition. For general 
information about resolving these errors, see “Resolving Check Errors” on page 121.

#2001 FAT copies are not identical

Run ScanDisk to fix this error.
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This problem may also be caused by a virus. Run a virus checker and remove the 
virus if possible.

#2002 There are invalid entries in the FAT

This error can generally be fixed by running a thorough ScanDisk on the 
partitions reporting the error.

#2003 File size does not match FAT allocation for file

Run ScanDisk or CHKDSK to fix this error.

#2005 One or more lost clusters are present

Run ScanDisk or CHKDSK to fix this error.

#2012 Formatted FAT file system too big for partition

This error can occur when:

• The number of sectors in the partition is larger than 65,536, and the 
bsHugeSects field of the boot sector (“Big total number of sectors” in Norton’s 
DISKEDIT utility) shows that there are more sectors in the partition than the 
partition table shows.

• The number of sectors in the partition is less than 65,536, and the bsSects field 
of the boot sector (“Total sectors on disk” in Norton’s DISKEDIT utility) 
shows that there are more sectors in the partition than the partition table shows.

This situation can result in data loss when the FAT file system tries to use space 
outside the partition that does not exist or that belongs to another partition. Since 
file data may exist outside the partition boundary, you cannot fix the problem by 
simply patching the boot sector.

To correct the error, back up all data on the partition, delete the partition, recreate 
the partition, and restore the data. Alternately, it has been reported that you can 
use Norton Disk Doctor to fix this problem.

#2013 A component of FAT geometry is bad

This error can occur when:

• The number of clusters on the hard disk is greater than the FAT limits allow. 
This can result from bad values in the boot sector for the number of sectors, 
FATs, root entries, reserved sectors, and sectors per cluster.

• The number of sectors in the FAT is not large enough to hold the number of 
clusters present on the hard disk.
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A qualified consultant may be able to fix the hard disk by performing simple 
patches. Alternately, you can back up the data on the partition, delete the 
partition, recreate the partition, and restore the files.

#2024 The OS/2 Extended Attribute file is corrupt

This error only occurs if you are running OS/2 and a program mistakenly writes 
to or overwrites the OS/2 Extended Attribute file. If this error occurs, you should 
back up your data, delete the partition, recreate the partition, and restore your  
data.

#2027 Too many root entries in the FAT32 partition to convert it to FAT16

Long filenames may be causing this problem, since they use multiple entries per 
file. To fix this error, move some of the root directory entries into a subdirectory 
and defragment the disk. 

#4002 Out of Memory

See error #3.

Operating System Errors (over 10,000)

Any number over 10,000 indicates an operating system error.

1 To determine the number of the operating system error, subtract 10,000. (For 
example, 10,032 - 10,000 = 32)

2 Open a command prompt window, and type net helpmsg x, where x is the error 
number you calculated in step 1. (For example, net helpmsg 32)

3 Consult your Windows NT system documentation or Microsoft’s TechNet web site 
(www.microsoft.com/technet/default.asp) for information about resolving the error.

For additional information about error 10,032, see “Compaq Insight Manager (CIM)” on 
page 117.

http://www.microsoft.com/technet
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A P P E N D I XC
PowerQuest Technical Support
This appendix includes the following information:

• Before Contacting Technical Support

• Term of Technical Support

• Contact Information
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Before Contacting Technical Support

Before contacting PowerQuest, please try to resolve problems you encounter by using the 
online Help, the user guide, the README file, and PowerQuest's corporate web site.

Tips
• Your problem may be resolved by applying the most recent patch or upgrade of the 

software.

• PowerQuest technical support engineers may request information from the 
PartitionInfo utility program to help you resolve problems with PartitionMagic. See 
“Generating Diagnostic Reports with PartitionInfo” on page 123 for more 
information about PartitionInfo and PARTINFO. The PartitionInfo report is always 
required for errors 100-199, 986, and drive detection errors of any kind.

• Your product serial number is required to obtain technical support.

• If you received a demo or trial version of the product, you are not entitled to 
complimentary technical support.

Term of Technical Support

Technical support is available to all registered users throughout the life of the product, 
which began when PowerQuest released the software to manufacturing and ends six 
months after the release of the next version of the software or when PowerQuest 
discontinues its development.

Upon registration, PowerQuest provides 45 days of complimentary technical support from 
the day of your first call.

Contact Information

Corporate Web Site

The technical support web site, support.powerquest.com, includes an overview of support 
options, an e-mail support request form, a list of error messages and information to resolve 
problems you encounter, and answers to frequently asked questions about the product.

http://www.powerquest.com/support
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E-mail

To obtain e-mail technical support for specific technical questions, you can fill out the 
form at support.powerquest.com/emsupport.html (available in English only).

E-mail on Demand

PowerQuest maintains an e-mail on demand system to resolve common problems. You can 
view a list of available documents at support.powerquest.com. To request one of the 
documents, send an e-mail message to support@powerquest.com with the index number 
of the document in the subject of the message. You can only request one document per 
e-mail message. E-mail on demand documents are available only in English.

Fax

Fax a description of your problem to the technical support fax number. This service is 
available in the U.S., Canada, and Europe 24 hours a day, 7 days a week. PowerQuest 
technicians try to respond to all fax requests within 24 hours.

Language
E-mail (for specific 
technical problems)

Dutch eurots@powerquest.com

English help@powerquest.com
eurots@powerquest.com

French france@powerquest.com

German germany@powerquest.com

Italian italian@powerquest.com

Portuguese latina@powerquest.com

Spanish spanish@powerquest.com

Location Number

U.S.A. (801) 437-4218

Europe +31 (0)20 581 9270

http://www.powerquest.com/support/emsupport.html
http://www.powerquest.com/support
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Telephone

The U.S.A. call center is open Monday through Friday from 7:00 a.m. to 6:00 p.m., 
MST/MDT. Our European call center, located in the Netherlands, is open Monday through 
Friday from 9:00 to 18:00, CET.

Postal Service Mail

Include a detailed description of your problem and a return address, a daytime phone 
number, or other relevant contact information.

Language Location Number

Dutch Netherlands +31 (0)20 581 3906

English Netherlands +31 (0)20 581 3907

English UK +44 (0)17 1341 5517

English U.S.A. (801) 226-6834

French France +33 (0)1 69 32 49 30

German Germany +49 (0)69 66 568 516

Italian Italy +39 (0)2 45 28 1312

Spanish Spain +34 (0)91 662 31 46

Spanish U.S.A. (801) 226-6834

U.S.A. Europe

PowerQuest Corporation
P.O. Box 1911
Orem, Utah 84059-1911
U.S.A.

PowerQuest Customer Service
P.O. Box 58287
1040 HG
Amsterdam, Netherlands
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across the wire  104

See also Remote Agent
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batch error messages  134
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batch files
See scripting
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Boot Disk Builder  105
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creating under Windows  105
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boot partition, copying  55

bootable partitions
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FAT, troubleshooting  123
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CheckDisk  66
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checking for errors
partitions  56
volume sets  83

CHKDSK  121
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converting to FAT32  91
converting to HPFS  91
converting to NTFS  93
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partitions, information about  62
partitions, resizing  45

FAT information  63

FAT16x  35

FAT32 file system  35
determining if current operating system 

supports  37
partitions, converting to FAT  93
partitions, information about  62
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formatting  53
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help
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README file  40
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hiding wizard buttons  102
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file system  36
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HPFS/386 file system  36
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icons, hiding wizard  102

index, error in root directory  141
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FAT information  63
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partition info  63

installing
new server disk  112
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ServerMagic, Windows  16

integrity checks, disk  42

integrity checks, partition  56

interface, overview of  26
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Internet technical support  146
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labeling
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letters, drive See drive letters
Linux

creating a bootable partition, requirements  49
file system  36

list, partition See partition list
long filenames  70

Windows, created by  91

M
main window, status bar  29

main window, overview  26

main window, rescue disk  29

master boot record  128,  131

master boot record viruses, removing  122

master file table  64

memory, freeing to run ServerMagic  120

merging partitions  58
wizard  101

mirrored sets
resizing partitions in  46

moving
data  65
partitions  42
partitions, bootable  44
volume set segments  85

moving partitions to or from a remote server  103

MS CheckDisk  66

multiple visible primary partitions  116
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networking errors  132

new features  13

Norton AntiVirus, compatibility with ServerMagic  
116

NTFS
check error messages  139
file system  36
partitions, checking  20
partitions, information about  64

NTFS partitions
converting to FAT  94
converting to FAT32  94
information about  62
minimum size of  46
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online help  39

operating system boot utilities
Dual Boot  116
System Commander  116

operating systems
creating new partitions for  48,  100
installing multiple  71
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copy  54
create  46
delete  50
info  61
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move  42
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resize  42
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operations process overview  30
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removing viruses  122
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creating  46
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moving  42
multiple primary  116
multiple visible primary  69
naming  52
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removing  23,  138

passwords, forgotten  138

pending changes  33

pending operations, viewing  32

physical disk, selecting  30

physical geometry  63

PowerQuest web site  146

PQ_DEBUG.TXT file  123

preferences  37
allow 64K FAT clusters for Windows NT  37
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