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SYMANTEC LICENSE AND WARRANTY
NOTICE: SYMANTEC LICENSES THE ENCLOSED SOFTWARE 
TO YOU ONLY UPON THE CONDITION THAT YOU ACCEPT 
ALL OF THE TERMS CONTAINED IN THIS LICENSE 
AGREEMENT.  PLEASE READ THE TERMS CAREFULLY 
BEFORE OPENING THIS PACKAGE, AS OPENING THE 
PACKAGE WILL INDICATE YOUR ASSENT TO THEM.  IF YOU 
DO NOT AGREE TO THESE TERMS, THEN SYMANTEC IS 
UNWILLING TO LICENSE THE SOFTWARE TO YOU, IN 
WHICH EVENT YOU SHOULD RETURN THE FULL PRODUCT 
WITH PROOF OF PURCHASE TO THE DEALER FROM WHOM 
IT WAS ACQUIRED WITHIN SIXTY DAYS OF PURCHASE, 
AND YOUR MONEY WILL BE REFUNDED.

 LICENSE AND WARRANTY:
The software which accompanies this license (the "Software") 
is the property of Symantec or its licensors and is protected by 
copyright law.  While Symantec continues to own the 
Software, you will have certain rights to use the Software after 
your acceptance of this license.  Except as may be modified by 
a license addendum which accompanies this license, your 
rights and obligations with respect to the use of this Software 
are as follows: 
• You may: 
(i) use only one copy of one version of the various versions of 
the Software contained on the enclosed CD-ROM on a single 
computer; 
(ii) make one copy of the Software for archival purposes, or 
copy the software onto the hard disk of your computer and 
retain the original for archival purposes;
(iii) use the Software on a network, provided that you have a 
licensed copy of the Software for each computer that can 
access the Software over that network; 
(iv) after written notice to Symantec, transfer the Software on a 
permanent basis to another person or entity, provided that you 
retain no copies of the Software and the transferee agrees to 
the terms of this agreement; and 
(v) if a single person uses the computer on which the Software 
is installed at least 80% of the time, then  after returning the 
completed product registration card which accompanies the 
Software, that person may also use the Software on a single 
home computer. 
• You may not:
(i) copy the documentation which accompanies the Software;
(ii) sublicense, rent or lease any portion of the Software;
(iii) reverse engineer, decompile, disassemble, modify, 
translate, make any attempt to discover the source code of the 
Software, or create derivative works from the Software; or
(iv) use a previous version or copy of the Software after you 
have received a disk replacement set or an upgraded version  
as a replacement of the prior version, unless you donate a 
previous version of an upgraded version to a charity of your 
choice, and such charity agrees in writing that it will be the 
sole end user of the product, and that it will abide by the 
terms of this agreement.  Unless you so donate a previous 
version of an upgraded version, upon upgrading the Software, 
all copies of the prior version must be destroyed.
(v) use the MS-DOS Boot Files in any way other than as part of 
the Norton Emergency Disk Products and may use such files 
only for the purpose of booting and running the Norton 
Emergency Disk Products.
•  Sixty Day Money Back Guarantee:
If you are the original licensee of this copy of the Software and 
are dissatisfied with it for any reason, you may return the 
complete product, together with your receipt, to Symantec or 

an authorized dealer, postage prepaid, for a full refund at any 
time during the sixty day period following the delivery to you 
of the Software.
• Limited Warranty:
Symantec warrants that the media on which the Software is 
distributed will be free from defects for a period of sixty (60) 
days from the date of delivery of the Software to you. Your 
sole remedy in the event of a breach of this warranty will be 
that Symantec will, at its option, replace any defective media 
returned to Symantec within the warranty period or refund the 
money you paid for the Software.  Symantec does not warrant 
that the Software will meet your requirements or that 
operation of the Software will be uninterrupted or that the 
Software will be error-free. 
THE ABOVE WARRANTY IS EXCLUSIVE AND IN LIEU OF ALL 
OTHER WARRANTIES, WHETHER EXPRESS OR IMPLIED, 
INCLUDING THE IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE 
AND NONINFRINGEMENT.  THIS WARRANTY GIVES YOU 
SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, 
WHICH VARY FROM STATE TO STATE.
• Disclaimer of Damages:
REGARDLESS OF WHETHER ANY REMEDY SET FORTH 
HEREIN FAILS OF ITS ESSENTIAL PURPOSE, IN NO EVENT 
WILL SYMANTEC BE LIABLE TO YOU FOR ANY SPECIAL, 
CONSEQUENTIAL, INDIRECT OR SIMILAR DAMAGES, 
INCLUDING ANY LOST PROFITS OR LOST DATA ARISING 
OUT OF THE USE OR INABILITY TO USE THE SOFTWARE 
EVEN IF SYMANTEC HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES.
SOME STATES DO NOT ALLOW THE LIMITATION OR 
EXCLUSION OF LIABILITY FOR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES SO THE ABOVE LIMITATION 
OR EXCLUSION MAY NOT APPLY TO YOU.
IN NO CASE SHALL SYMANTEC’S LIABILITY EXCEED THE 
PURCHASE PRICE FOR THE SOFTWARE.  Thedisclaimers and 
limitations set forth above will apply regardless of whether 
you accept the Software.
• U.S. Government Restricted Rights:
RESTRICTED RIGHTS LEGEND. Use, duplication, or disclosure 
by the Government is subject to restrictions as set forth in 
subparagraph (c) (1) (ii) of the Rights in Technical Data and 
Computer Software clause at DFARS 252.227-7013 or 
subparagraphs (c) (1) and (2) of the Commercial Computer 
Software-Restricted Rights clause at 48 CFR 52.227-19, as 
applicable, Symantec Corporation, 20330 Stevens Creek 
Boulevard, Cupertino, CA 95014.
• General:
This Agreement will be governed by the laws of the State of 
California.  This Agreement may only be modified by a license 
addendum which accompanies this license or by a written 
document which has been signed by both you and Symantec.  
Should you have any questions concerning this Agreement, or 
if you desire to contact Symantec for any reason, please write: 
Symantec Customer Sales and Service, 20330 Stevens Creek 
Boulevard, Cupertino, CA 95014. 



SYMANTEC SOFTWARE LICENSE ADDENDUM
END-USER LICENSE AGREEMENT FOR 

Distributed COM for Windows® 95
IMPORTANT READ CAREFULLY: This Microsoft End-User 
License Agreement (EULA) is a legal agreement between you 
(either an individual or a single entity) and Microsoft 
Corporation for the Microsoft software product identified 
above, which includes computer software and associated 
media and printed materials (if any), and may include online 
or electronic documentation (SOFTWARE PRODUCT or 
SOFTWARE). By installing, copying, or otherwise using the 
SOFTWARE PRODUCT, you agree to be bound by the terms of 
this EULA. If you do not agree to the terms of this Agreement, 
you are not authorized to use the SOFTWARE PRODUCT.
The SOFTWARE PRODUCT is protected by copyright laws and 
international copyright treaties, as well as other intellectual 
property laws and treaties. The SOFTWARE PRODUCT is 
licensed, not sold.
1. GRANT OF LICENSE. This EULA grants you the following 
rights:
    Use and Copy. Microsoft grants to you the right to use 
copies of the SOFTWARE PRODUCT only in conjunction with 

validly licensed copies of Microsoft Windows® 95. You may 
make copies of the SOFTWARE PRODUCT for use on all 

computers for which you have licensed Microsoft Windows® 
95. You may also make copies of the SOFTWARE PRODUCT 
for backup and archival purposes.
2.  RESTRICTIONS.
--You must maintain all copyright notices on all copies of the 
SOFTWARE PRODUCT.   
--You may not distribute copies of the SOFTWARE PRODUCT 
to third parties.   
--You may not reverse engineer, decompile, or disassemble the 
SOFTWARE PRODUCT, except and only to the extent that such 
activity is expressly permitted by applicable law 
notwithstanding this limitation.
--You may not separate the SOFTWARE PRODUCT into its 
component parts for use on more than one computer.
--You may not rent or lease the SOFTWARE PRODUCT. 
--You may permanently transfer all of your rights under this 
EULA only in conjunction with a permanent transfer of your 

validly licensed copy or copies of Microsoft Windows® 95.

3.  TERMINATION. Your rights under this EULA terminate 

upon the termination of your Microsoft Windows® 95 
operating system EULA, or without prejudice to any other 
rights, Microsoft may terminate this EULA if you fail to comply 
with the terms and conditions of this EULA. In such event, you 
must destroy all copies of the SOFTWARE PRODUCT.
4.  COPYRIGHT. All title and copyrights in and to the 
SOFTWARE PRODUCT and any copies thereof are owned by 
Microsoft or its suppliers. All title and intellectual property 
rights in and to the content which may be accessed through 
use of the SOFTWARE PRODUCT is the property of the 
respective content owner and may be protected by applicable 
copyright or other intellectual property laws and treaties.  This 
EULA grants you no rights to use such content.
5.  U.S. GOVERNMENT RESTRICTED RIGHTS.
The SOFTWARE PRODUCT is provided with RESTRICTED 
RIGHTS. Use, duplication, or disclosure by the Government is 
subject to restrictions as set forth in subparagraph (c)(1)(ii) of 
the Rights in Technical Data and Computer Software clause at 
DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the 

Commercial Computer Software Restricted Rights at 48 CFR 
52.227-19, as applicable. Manufacturer is Microsoft 
Corporation/One Microsoft Way/Redmond, WA 98052-6399. 
6. EXPORT RESTRICTIONS.
You agree that you will not export or re-export the SOFTWARE 
PRODUCT to any country, person, entity or end user subject 
to U.S.A. export restrictions.  Restricted countries currently 
include, but are not necessarily limited to Cuba, Iran, Iraq, 
Libya, North Korea, Syria, and the Federal Republic of 
Yugoslavia (Serbia and Montenegro, U.N. Protected Areas and 
areas of Republic of Bosnia and Herzegovina under the 
control of Bosnian Serb forces).  You warrant and represent 
that neither the U.S.A. Bureau of Export Administration nor 
any other federal agency has suspended, revoked or denied 
your export privileges.
7.  NO WARRANTY. ANY USE OF THE SOFTWARE PRODUCT 
IS AT YOUR OWN RISK.  THE SOFTWARE PRODUCT IS 
PROVIDED FOR USE ONLY WITH MICROSOFT OPERATING 
SYSTEM PRODUCTS. TO THE MAXIMUM EXTENT 
PERMITTED BY APPLICABLE LAW, MICROSOFT AND ITS 
SUPPLIERS DISCLAIM ALL WARRANTIES AND CONDITIONS, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT 
LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, AND 
NONINFRINGEMENT.
8.  NO LIABILITY FOR CONSEQUENTIAL DAMAGES.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE 
LAW, IN NO EVENT SHALL MICROSOFT OR ITS SUPPLIERS 
BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR 
CONSEQUENTIAL DAMAGES WHATSOEVER (INCLUDING, 
WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS 
PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS 
INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING 
OUT OF THE USE OF OR INABILITY TO USE THE 
SOFTWARE PRODUCT, EVEN IF MICROSOFT HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  
BECAUSE SOME STATES AND JURISDICTIONS DO NOT 
ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR 
CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE 
LIMITATION MAY NOT APPLY TO YOU.
9.  LIMITATION OF LIABILITY.  MICROSOFT'S ENTIRE 
LIABILITY AND YOUR EXCLUSIVE REMEDY UNDER THIS 
EULA SHALL NOT EXCEED FIVE DOLLARS (US$5.00).
10.  MISCELLANEOUS
This EULA is governed by the laws of the State of Washington, 
U.S.A.
Should you have any questions concerning this EULA, or if 
you desire to contact Microsoft for any reason, please contact 
the Microsoft subsidiary serving your country, or write: 
Microsoft Sales Information Center/One Microsoft Way/
Redmond, WA 98052-6399.
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C H A P T E R
 1
Installing 
Norton Utilities

Installing Norton Utilities
Before installing Norton Utilities, take a moment to review the system 
requirements listed in this section. Windows 95, Windows 98, and 
Windows Me users should have some blank floppy disks available to make 
Rescue Disks (or a Zip™ disk and a floppy disk to make a Norton Zip 
Rescue™ disk set). 

Note: Before running Setup for Norton Utilities, uninstall any previous 
versions of Norton Utilities from your system. 

Caution: If you have an emergency, do not install Norton Utilities and do 
not start Windows. Any new files copied to your hard drive might 
overwrite existing data. Starting Windows also writes to your hard drive. 
The Windows swap file could overwrite data you wish to recover. See 
“Emergency procedures” on page 9.
7



Installing Norton Utilities 
System requirements

To use Norton Utilities, your computer must meet the following minimum 
requirements.

Windows 95 OSR2 and Windows 98
� Intel 80486DX/66 processor

� 32 MB of memory

� 90 MB of hard disk space for standard installation

� 50 MB of hard disk space for compact installation

� CD-ROM disk

Windows Me
� Intel Pentium 150MHz processor

� 32 MB memory

� 90 MB of hard disk space for standard installation

� 50 MB of hard disk space for compact installation

� CD-ROM disk

Windows NT 4.0 Workstation
� Service Pack 4

� Intel Pentium processor

� 32 MB of memory (64 MB recommended)

� 35 MB of hard disk space

� CD-ROM disk

Windows 2000 Professional
� Intel Pentium 133MHZ processor

� 64 MB of memory

� 35 MB of hard disk space

� CD-ROM disk

While not required, an Iomega Zip drive is a definite advantage when 
making a Rescue Disk set.
8



Installing Norton Utilities
Note: Norton Utilities does not support Iomega Zip or Jaz drives with a 
USB interface because there are no DOS drivers available.

Emergency procedures

If you have an emergency, do not install Norton Utilities and do not start 
Windows. Any new files copied to your hard drive might overwrite existing 
data. Starting Windows also writes to your hard drive. The Windows swap 
file could overwrite data you wish to recover.

Make Emergency Disks from the Norton Utilities CD to help you recover 
from the emergency. You will need several formatted 1.44 MB disks.

You can use the CD that contains Norton Utilities as an Emergency Disk if 
your computer can start up from the CD-ROM drive. See “Using the CD as 
an Emergency Disk” on page 10.

Warning: Perform the following procedure on a different computer from 
the one with the problem. Executing these steps might cause additional 
problems.

To make Emergency Disks:

1 Insert the Norton Utilities CD into the CD-ROM drive. 

2 Click Browse the CD.

3 Double-click the Support folder.

4 Double-click the Edisk folder.

5 Double-click Ned.exe

6 Follow the on-screen instructions.

To use the Emergency Disks:

1 If your computer is running, click the Start button, select Shut Down, 
and then select the Shut Down option. When Windows has shut down, 
switch off your computer using the power switch.

2 Insert Emergency Disk 1 in your floppy drive, and then switch on your 
computer.
9



Installing Norton Utilities 
3 When the menu appears, use the options in order. 

For more information, see “Norton Utilities emergency procedures” on 
page 49.

If you cannot start up from drive A, see “I cannot start up from my A: 
drive” on page 108.

Using the CD as an Emergency Disk

You can use the Norton Utilities CD as an Emergency Disk if your 
computer can start up from the CD-ROM drive. Wherever the instructions 
say to insert Emergency Disk 1 and restart your computer, follow these 
steps instead.

To use the CD as an Emergency Disk:

1 Insert the Norton Utilities CD into your CD-ROM drive.

2 Restart your computer. 

You may need to change your computer’s BIOS Setup options to start 
up from the CD-ROM drive. Refer to your computer manual to see 
how to change the startup device.

When you are running from the CD, you can skip instructions to insert 
other Emergency Disks. All the information for all the Emergency Disks 
is on the CD.

Installation procedure

Norton Utilities gives you several installation options:

� Standard installs the most commonly used set of Norton Utilities 
programs. 

� Compact installs the most essential Norton Utilities programs. 

� Custom lets you choose which components to install.

� Express automatically selects the appropriate options for you.

When installing on Windows NT or Windows 2000 you must be logged on 
as an administrator.
10



Keeping your system protected
To install:

1 Start Windows (if it is not already running).

2 Close all Windows programs to prevent conflicts.

3 Insert the Norton Utilities CD in the CD-ROM drive. An opening screen 
appears.

4 Click Install Norton Utilities and follow the on-screen instructions.

The preselected options in Setup are the correct choices for most 
people. You should accept the preset choices unless you have a very 
unusual need.

If the opening screen does not appear:

1 Double-click the My Computer icon.

2 Double-click the icon for your CD-ROM drive.

3 Double-click CDSTART.EXE.

4 Click Install Norton Utilities and follow the on-screen instructions.

The last step of installation is for you to create Rescue Disks. Rescue Disks 
are an important part of your protection. For example, they can help you 
recover from a system crash. See “Creating Rescue Disks” on page 25.

While this user’s guide contains helpful information, there is additional 
information in online help that is not covered here. There is also a wealth 
of information at http://service.symantec.com.

Keeping your system protected
Norton Utilities gives you the tools you need to keep your system 
protected. 

LiveUpdate

The LiveUpdate button at the top of the main screen updates 
Norton Utilities programs. See “Updating Norton Utilities with LiveUpdate” 
on page 24.
11



Installing Norton Utilities 
Rescue Disks

Rescue Disks contain critical information your computer needs to start and 
run properly. This information changes as you change the configuration of 
your computer, so it is important to keep your Rescue Disk set up-to-date. 
You should update your Rescue Disks at least once a month, plus any time 
you update your virus protection, install new software, or make changes to 
your hardware. See “Creating Rescue Disks” on page 25.

Uninstalling Norton Utilities 
You can easily remove Norton Utilities from your computer.

To remove Norton Utilities from your computer:

1 Click the Start button, and then select Settings > Control Panel.

2 Double-click Add/Remove Programs.

3 In the list of installed programs, select Norton Utilities. Click Add/
Remove.

4 Follow the on-screen instructions.

You might also want to uninstall LiveUpdate and LiveReg if you have 
no other Symantec products installed.
12



C H A P T E R
 2
Introducing 
Norton Utilities

Norton Utilities finds and fixes problems with your computer. It optimizes 
your computer to run at peak efficiency, prevents major and minor 
computer problems, and detects and repairs Windows problems. Norton 
Utilities helps you recover from computer emergencies.

What’s new in Norton Utilities 2001?
You can install and use Norton Utilities on Windows 95 OSR2, 
Windows 98, Windows Me, Windows NT 4.0, and Windows 2000.

Norton Utilities
Norton Utilities is really several programs in one:

� Continuous-monitoring system that prevents problems by finding and 
correcting them

� Most effective disaster recovery tools available

� Highly effective tools that help make your computer run better and 
faster
13



Introducing Norton Utilities 
Optimize performance

Some Norton Utilities programs can improve performance of your hard 
drives, optimize the Windows Registry and swap file, make all your 
programs start up faster, and make the best possible use of your available 
hard drive space. The programs that improve performance are:

� Speed Disk

� Norton Optimization Wizard

� Speed Start

Speed Disk 

Speed Disk works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

When you save your work, your computer stores the information that 
makes up your files as small bits of data called clusters. As you continue to 
create, modify, and delete files, these clusters get spread all over the disk. 
When this happens, your disk is fragmented. Over time, as disk 
fragmentation increases, your hardware has to work harder and 
performance suffers. Speed Disk improves system performance by 
reorganizing the contents of your drive so your files are stored in adjacent 
clusters. Norton Speed Disk lays out the files on your disk so the ones you 
use most are more quickly accessible, and it works with Windows 98 
Application Launch Accelerator to make your programs load faster. 

Norton Optimization Wizard

Norton Optimization Wizard works on Windows 95, Windows 98, and 
Windows Me.

The Windows Registry and swap file are two Windows components that 
can greatly affect the speed at which Windows runs. The Registry stores 
startup and configuration information for every Windows program you run, 
as well as for Windows itself. Norton Optimization Wizard optimizes the 
internal structure of the Registry, reducing its size on your hard drive and 
speeding up access time to the vital information it contains.

The swap file is a special file Windows uses to create the virtual memory 
space in which your programs run. Normally, Windows manages the size 
of this file, enlarging it and shrinking it according to memory needs. Swap 
file size-management overhead can sometimes slow down your computer. 
Norton Optimization Wizard sets your swap file’s minimum size to the 
14



Norton Utilities
optimum setting for your system and works with Speed Disk to move the 
swap file to the front of your hard drive for maximum efficiency.

Speed Start

Speed Start automatically improves the startup time of every program you 
run in Windows 95. In many cases, Speed Start—part of Norton 
Optimization Wizard—cuts startup times by 50% or more. You do not have 
to do anything, just start your programs as usual and Speed Start optimizes 
the load time in the background.

Note: Because functionality similar to Speed Start is built in to Windows 98, 
Windows Me, Windows NT and Windows 2000, Speed Start is only 
installed in Windows 95.

Find and fix problems

Norton Utilities repairs common disk problems, recovers from application 
crashes, repairs Windows problems, and recovers deleted files. Norton 
Utilities programs that find and fix problems are:

� Norton System Check

� Norton System Doctor

� UnErase Wizard

� Norton Disk Doctor

� Norton WinDoctor

� Norton Protection

Norton System Check

Norton System Check works on Windows 95, Windows 98, and Windows 
Me.

Norton System Check provides an alternative to Norton System Doctor. 
While Norton System Doctor provides continuous monitoring of the health 
of your system, Norton System Check provides an immediate or scheduled 
system checkup. Norton System Check finds disk problems and Windows 
problems, it improves performance, and it gives your computer a 
preventive maintenance checkup. Run Norton System Check whenever 
you think you may have a problem. Schedule Norton System Check to run 
at regular intervals to ensure that your computer stays in top shape.
15



Introducing Norton Utilities 
Norton System Doctor

Norton System Doctor works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

Detect potential disk and system problems and take preventive measures 
to avoid serious trouble automatically. Norton System Doctor monitors and 
analyzes various parts of your computer, including disk and CPU usage, 
disk integrity, system integrity, network throughput, Internet site access 
time, and more. You determine when and how Norton System Doctor 
reacts to certain conditions or problems. 

If a Norton System Doctor sensor encounters a preset alert condition or 
detects a problem with your system, an alert identifies the problem. Norton 
System Doctor either recommends a course of action or, if you prefer, 
corrects the problem automatically. With Norton System Doctor, total 
system monitoring, protection, and recovery is as simple as running one 
program.

UnErase Wizard

UnErase Wizard works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

UnErase Wizard is your best choice when trying to recover lost or deleted 
files. It can locate and recover files that are protected by Norton Protection, 
or the Windows Recycle Bin. UnErase Wizard also recovers many 
overwritten files (Windows 95, Windows 98, and Windows Me only). This 
can be helpful when you accidentally delete a critical file, or even from the 
Recycle Bin. Recovering files can be as easy as displaying a list of the most 
recently deleted files or answering questions about the files you are 
looking for.

Norton Disk Doctor

Norton Disk Doctor works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

The integrity of your hard drive is vital to trouble-free computing. In 
addition to checking the integrity of logical disk structures—such as your 
boot records, file allocation tables, and directories—Norton Disk Doctor 
performs a series of surface analysis tests to ensure the integrity of your 
disks. You can configure Norton Disk Doctor to repair various disk 
problems automatically, even while it runs in the background. Norton 
16



Norton Utilities
System Doctor works with Norton Disk Doctor, continuously monitoring 
for disk problems and alerting you when they occur.

Norton WinDoctor

Norton WinDoctor works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

The introduction of Windows 95 solved many of the problems that had 
plagued users of previous versions of Windows. At the same time, it 
introduced a new set of problems. Norton WinDoctor performs a series of 
tests to diagnose and fix most Windows problems. These problems include 
all types of software errors, hardware configurations, Registry problems, 
clutter from failed uninstalls, and much more. With Norton WinDoctor, you 
can automatically fix every problem or you can pick and choose, 
specifying which problems to fix and how to repair them. Norton 
WinDoctor works with Norton System Doctor, continuously monitoring for 
Windows problems and alerting you when they occur. 

Norton Protection

Norton Protection works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

Norton Protection adds extra, configurable data recovery protection to the 
Recycle Bin to help you recover deleted files that the Recycle Bin cannot 
find. Norton Protection loads automatically when Windows starts and, 
when used in conjunction with UnErase Wizard, provides the most 
complete recovery system for all deleted and overwritten files.

System maintenance

Prevent disasters and detect problems before they become serious. Norton 
Utilities programs that prevent problems are:

� System Information

� Norton WipeInfo

� Image

� Norton File Compare

� Norton Diagnostics

� Rescue Disk
17



Introducing Norton Utilities 
System Information

System Information works on Windows 95, Windows 98, Windows Me, 
Windows NT, and Windows 2000.

System Information gives you access to common device information as 
well as hard-to-find details about every area of your computer, including 
memory, logical and physical characteristics of your disks (including 
partitions), network connections, multimedia devices, and your Internet 
connection. Specific components—such as System and Drive—have 
benchmarks that let you compare their speed on your computer to the 
speed of similar components on other standard computers. Benchmarks 
and Internet information is only available in Windows 95, Windows 98, 
and Windows Me.

Norton WipeInfo

Norton WipeInfo works on Windows 95, Windows 98, and Windows Me.

Norton WipeInfo removes all traces of selected files or folders from your 
hard drive. It can also wipe the free space on your hard drive, ensuring 
that previously deleted information is not left on your hard drive.

You can use the Fast Wipe, which writes all zeros or any other character 
you choose. Alternately, you can use the Government Wipe, which is a 
7-pass procedure that conforms to the method specified in DoD document 
5220-22-M, National Industrial Security Program Operating Manual.

Image

Image works on Windows 95, Windows 98, and Windows Me.

Having an accurate picture or image of your disk ensures complete 
recovery from accidental folder or file deletion. Image creates a snapshot 
of critical disk information: the boot record, file allocation tables (FAT), and 
root directory data. The UnErase Wizard can use this information to help 
restore erased files. The Norton Utilities DOS-based program, UnFormat, 
can use this information to restore a damaged or accidentally formatted 
disk. Norton System Doctor works with Image, continuously monitoring 
the age of your image files. 
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Norton Utilities
Norton File Compare

Norton File Compare works on Windows 95, Windows 98, and Windows 
Me.

Norton File Compare lets you examine the differences—items added, items 
deleted, and items moved or changed—between two versions of a file. 
Norton File Compare also displays changes to the Windows Registry file 
and to Windows .INI files.

Norton Diagnostics

Norton Diagnostics works on Windows 95, Windows 98, and Windows Me.

Norton Diagnostics gives your computer a complete hardware checkup. It 
identifies hardware problems quickly. Norton Diagnostics tests your system 
board, memory, video, CD-ROM drive, diskette drive, mouse, 
communications ports, modem, PC card slots, printer, sound card, and 
speakers.

Rescue Disk

Rescue Disk works on Windows 95, Windows 98, and Windows Me.

Rescue Disks keep you prepared to deal with a variety of unforeseen 
problems that can occur without warning. Rescue Disk records a duplicate 
set of system startup files and disk partition information, and stores rescue 
items on an Iomega Zip disk, across multiple floppy disks, or on a network 
drive.

A Norton Zip Rescue Disk set consists of one Zip disk and one bootable 
floppy disk. With this disk set, you can start Windows and use Norton 
Utilities to fix startup and disk-related problems.

A basic Rescue Disk set consists of one bootable floppy disk and one or 
more additional disks. With this kind of Rescue Disk set, you can start your 
computer in DOS mode and use the included DOS-based Norton Utilities 
programs to fix startup and disk-related problems.

Norton System Doctor can monitor the viability of your Rescue Disks and 
remind you when it is time to update them. Rescue disks are most effective 
if the information about your computer is current. You should update them 
regularly.
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Registry management

Track changes to, and edit the Windows Registry. Norton Utilities programs 
that provide this information are:

� Norton Registry Tracker

� Norton Registry Editor

Norton Registry Tracker

Norton Registry Tracker works on Windows 95, Windows 98, and Windows 
Me.

Norton Registry Tracker lets you monitor changes to your computer’s 
critical setup data and startup files, including Windows Registry keys and 
.INI files. Use Norton Registry Tracker to take a snapshot of all your system 
files and to review subsequent changes made by Setup, by the Control 
Panel, or by other applications.

Norton Registry Editor

Norton Registry Editor works on Windows 95, Windows 98, and Windows 
Me.

Use Norton Registry Editor to get behind the Windows user interface to 
modify, troubleshoot, or repair startup files. Norton Registry Editor lets you 
edit the Windows Registry, the master record containing your system 
hardware, software, and personal preference configuration settings. Use 
Norton Registry Editor to change and enhance areas inaccessible through 
the Windows user interface. Norton Registry Editor’s Undo feature makes it 
safer to use than other Registry editing tools.
20
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Norton Utilities programs for DOS

Norton Utilities programs for DOS work on Windows 95, Windows 98, and 
Windows Me.

Norton Utilities also includes a number of DOS-based programs such as 
Disk Editor and Unformat. For information about these programs, see 
“DOS procedures” on page 54.

Note: Because Windows NT and Windows 2000 are not based on MS-DOS, 
the Norton Utilities programs for DOS are not installed on these operating 
systems.
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C H A P T E R
 3
Norton Utilities basics

This chapter provides you with the basics of using Norton Utilities. These 
are tasks that you will use with all the Norton Utilities programs.

Navigating Norton Utilities 
To start Norton Utilities:

1 On the Windows taskbar, click Start > Programs > Norton Utilities > 
Norton Utilities Integrator.

The Norton Utilities main screen is the starting point for all your 
activities. 
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Norton Utilities basics 
2 From here you can do the following:

� Click an option on the left to see a description of what it provides 
on the right. 

� Click one of the buttons at the top for features that apply to more 
than one area of the program.

Additional Symantec products might appear if you have them installed.

Setting options

There are many options you can set in Norton Utilities. For example, you 
can choose to have System Doctor display a large alert in addition to the 
red light on the sensor icon when it finds a problem.

To set options:

1 Click the Options button at the top of the Norton Utilities main 
window.

2 Choose the feature for which you want to set options.

Updating Norton Utilities with LiveUpdate

Click the LiveUpdate button to update Norton Utilities programs. 
LiveUpdate connects to Symantec to see if updates are available for 
Norton Utilities. LiveUpdate requires an Internet connection.

Note: Your normal Internet access fees apply.

To update Norton Utilities using LiveUpdate:

1 Click the LiveUpdate button at the top of the Norton Utilities main 
window. 

2 The LiveUpdate window appears. Follow the on-screen instructions.

Tip: If you connect to the Internet through AOL, CompuServe, or Prodigy 
Internet, first connect to the Internet, and then run LiveUpdate.
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Creating Rescue Disks
Rescue Disks contain critical information your computer needs to start and 
run properly. This information changes as you change the configuration of 
your computer, so it is important to keep your Rescue Disks up-to-date. 

If you have an Iomega Zip drive, Rescue Disk can use it to make Rescue 
Disks that let you start Windows even when your computer will not start 
up normally after a system crash. This lets you make emergency repairs.

You can also make Rescue Disks using your standard floppy drive and 
several floppy disks. This floppy-based set lets you start up to the DOS 
operating system only, and access DOS-based utilities. Both kinds of 
Rescue Disks provide you with an easy-to-use interface for recovering from 
a system crash.

Caution: Never use Rescue Disks made on another computer. Rescue 
Disks contain information specific to the computer on which they were 
made. 

Tip: The more recent your Rescue Disks, the better your chances of a full 
recovery. Update your Rescue Disks whenever you update your virus 
protection, install new software, or make changes to your hardware.

Creating Norton Zip Rescue Disks

A Norton Zip Rescue Disk set consists of two disks:

� Bootable floppy disk

� Zip disk

You need both of these disks to successfully restore your system after a 
crash. The floppy disk contains the DOS system files necessary to start up 
your computer. The Zip disk contains the Windows operating system, as 
well as the startup files, configuration information, and Norton Utilities 
programs necessary to restore your computer.
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Norton Utilities basics 
Note: Some computer manufacturers replace the standard floppy disk drive 
with a Zip drive. In this case, your Rescue Disk set will not include a 
bootable floppy disk. Rescue Disk creates a bootable Zip disk that contains 
all required Rescue Disk information.

Tip: Rescue disks contain system settings and rescue files. They do not 
back up your data. Be sure to make adequate backups of all your data.

To create a Norton Zip Rescue Disk set:

1 Click the Rescue button at the top of the Norton Utilities main window.

2 Insert a Zip disk in your Zip drive and a floppy disk in your A: drive.

Note: Do not use disks that contain data that you want to save. Rescue 
Disk overwrites all information on the disks.

Tip: You can also use an Iomega Jaz drive when making this kind of 
Rescue Disk.

3 Select Norton Zip Rescue in the Choose Rescue Type group box.

Caution: If you have multiple Zip drives installed on one computer, 
make sure to always use the same Zip drive when creating, updating, 
and using your Norton Zip Rescue Disks.
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Creating Rescue Disks
4 Click Create.

Rescue Disk formats both the floppy and Zip disks and copies your 
computer’s essential startup information to the disks.

5 Click Restart to test your newly created Rescue Disks. 

6 If the Rescue Disk window appears on the screen, the Rescue Disk 
works properly. If the Rescue Disk window does not appear, the 
Rescue Disk does not work properly.

Caution: Do not continue with the rescue process when you are 
testing Rescue Disks. “Repairing” a system that is functioning properly 
can cause problems.

If your Rescue Disk does not work, see “My Rescue Disk does not 
work” on page 107.

7 Remove the disk from the A: drive and slide open the plastic tab on 
the back of the disk to write-protect it. This prevents you from 
accidentally changing the data stored on the disks.

8 Shut down Windows if it is running. Turn the power off and on again 
to restart your computer. 

Creating basic Rescue Disks

Basic Rescue Disks give protection that is indispensable in protecting your 
computer from disasters. Basic Rescue Disks let you start up your computer 
to DOS after a system crash and use the DOS-based utilities to fix many 
problems.

You save your Rescue Disk set to a series of 1.44 MB floppies or a hard 
drive to which you have access.

To create basic Rescue Disks:

1 Click the Rescue button at the top of the Norton Utilities main window.

2 Select Basic Rescue in the Choose Rescue Type group box.

3 Select the drive you want Rescue Disk to use to create the Rescue Disk 
set. To create a floppy-based disk set select your A: drive.
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Norton Utilities basics 
Caution: If you select a network drive, a second physical hard disk, or 
some other large capacity disk drive, your Rescue Disk set is placed in 
a folder on the selected disk. Make sure to make a bootable floppy or 
Zip disk and keep it in a safe location. This disk should contain the 
network drivers or other files necessary to start your computer and 
access the drive on which you placed your Rescue Disk set. Do not 
create your Rescue Disk set on your C: drive.

4 Insert a floppy disk into your A: drive.

5 Click Create.

Rescue Disk formats the disk and copies your computer’s essential 
startup information to the disk.

6 Insert additional disks as required. Label the disks as you insert them.

7 Click Restart to test your newly created Rescue Disks.

8 If the Rescue Disk screen appears on the screen, the Rescue Disk 
works properly. If the Rescue Disk screen does not appear, the Rescue 
Disk does not work properly.

Caution: Do not continue with the rescue process when you are 
testing Rescue Disks. “Repairing” a system that is functioning properly 
can cause problems.

If your Rescue Disk does not work, see “My Rescue Disk does not 
work” on page 107.

9 Remove the disk from the A: drive and slide open the plastic tab on 
the back of the disk to write-protect it. This prevents you from 
accidentally changing the data stored on the disks.

10 Shut down Windows if it is running. Turn the power off and on again 
to restart your computer. 

Updating Rescue Disks

Because your Rescue Disks contain information about your computer that 
can change, it is vital that you keep your Rescue Disks current. 

You can update your Rescue Disks as often as you like. Rescue Disk lets 
you quickly and easily update Zip and basic Rescue Disks without having 
to recreate them.
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Caution: The update feature can track one set of each type of Rescue 
Disk. If for some reason you choose to keep more than one basic Rescue 
Disk set or more than one Norton Zip Rescue Disk set, do not use this 
feature. 

To update your Rescue Disks:

1 Click the Rescue button at the top of the Norton Utilities main window.

2 Select the type of Rescue Disk set you are updating in the Choose 
Rescue Type group box.

3 Specify the location of your Rescue Disks:

� For Norton Zip Rescue Disks, insert the Zip disk into your Zip drive 
and the floppy disk into your floppy drive.

� For basic Rescue Disks, select the drive in the Select Destination 
Drive list box. If you are updating floppy-based Rescue Disks, slide 
closed the plastic tab on the back of the disk and insert the first 
disk of the set into your A: drive.

Caution: If you have multiple Zip drives installed on one computer, 
make sure to always use the same Zip drive when creating, updating, 
and using your Norton Zip Rescue Disks.

4 Click Update.

Rescue Disk updates your computer’s essential startup information on 
the disks.

5 Click Restart to test the newly updated Rescue Disks.

6 If the Rescue Disk screen appears on the screen, the Rescue Disk 
works properly. If the Rescue Disk screen does not appear, the Rescue 
Disk does not work properly.

Caution: Do not continue with the rescue process when you are 
testing Rescue Disks. “Repairing” a system that is functioning properly 
can cause problems.

If your Rescue Disk does not work, see “My Rescue Disk does not 
work” on page 107.

7 Remove the disk from the A: drive and slide open the plastic tab on 
the back of the disk to write-protect it. This prevents you from 
accidentally changing the data stored on the disks.
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8 Shut down Windows if it is running. Turn the power off and on again 
to restart your computer. 

Using help to learn more about Norton Utilities
Norton Utilities provides extensive online help. This help system gives you 
detailed instructions about how to use all of Norton Utilities.

Norton Utilities includes three kinds of help:

� Help with program dialog boxes

� How To help

� What’s This? help

Help with program dialog boxes

The Help dialog box provides information about the area of the program 
you are using. This kind of help is context-sensitive, meaning that it 
displays help for the specific dialog box that you are currently using.
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To get help with a dialog box:

� Click the Help button located in the dialog box.

A help topic pertaining to the current dialog box appears.

How To help

How To help explains step-by-step procedures you are likely to perform 
using Norton Utilities. You can access these topics through the Contents or 
Index tabs. Open the Contents and Index by clicking the Help Topics, 
Contents, or Index button at the top of any help topic.

What’s This? help

What’s This? help provides a quick definition of an individual component 
of a window or dialog box. 

To access What’s This? help:

� Right-click anywhere you need help in a window or dialog box and 
choose What’s This?

Information about 
the dialog box and 
how to use it

Complete table of 
contents and index
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Getting help from the Help menu 

Some of the Norton Utilities programs have a Help menu instead of a Help 
button.

To access the Help menu:

� Click Help at the top of the main Norton Utilities window, or on a 
menu bar available in some Norton Utilities programs.

.

Visit Symantec 
websites for more 
information

Version and 
registration 
information

Online help table of 
contents and index
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C H A P T E R
 4
Responding to 
Norton Utilities alerts

When Norton Utilities detects a problem with your system it displays a 
message on your screen. These messages, called alerts, take several forms. 
These alerts may appear when you are running other programs and 
Norton Utilities detects a problem. This chapter shows examples of the 
various types of alerts that you may see, and tells you what actions you 
should take to respond to them.

Norton Utilities alerts 
Norton System Doctor monitors your system for trouble. When it spots a 
problem, it displays an alert like this.

To respond to a Norton System Doctor alert, click the bottom of the dialog 
box where is says “Click here for details.” An information screen appears 
that explains the problem and includes links to help you solve the problem 
and also a “More info” link for additional information about the problem.

Note: Normally, Norton System Doctor notifies you of a problem by 
displaying a red light on the sensor. Alerts like this do not appear unless 
you have selected Display Alarm Message in the sensor properties.
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C H A P T E R
 5
Solving your computer 
problems with 
Norton Utilities

All you need to keep your computer running at peak efficiency is the 
continuous monitoring provided by Norton System Doctor. While Norton 
System Doctor watches over your computer’s long-term health, you can 
use the individual Norton Utilities programs for more immediate acute care, 
such as:

� Diagnosing and fixing problems using Norton Disk Doctor and Norton 
WinDoctor

� Speeding up your computer using Speed Disk and Norton 
Optimization Wizard

� Giving your system a checkup with Norton System Check

� Restoring erased files using UnErase Wizard

� Getting information about your computer with System Information

� Testing your computer hardware with Norton Diagnostics

Tip: The Norton Utilities Integrator provides an easy-to-use graphical 
interface from which you can access all of the Norton Utilities programs. 
You can use it instead of the Start Menu in the following procedures. To 
open Norton Utilities Integrator, Click the Start button, and then select 
Programs > Norton Utilities > Norton Utilities Integrator.
35
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Diagnosing and fixing problems
Trouble-free computing depends on the integrity of your computer. This 
integrity is based on an error-free hard drive and a correctly installed copy 
of Windows. The trouble is, although most computers start out this way, 
over time both Windows and your hard drive are likely to degrade. This 
degradation, if not corrected, can ultimately lead to data loss.

The best cure for any problem is prevention. If you keep Norton System 
Doctor running all the time, it will spot problems early and recommend 
corrective action. Whenever you encounter a problem, or just feel like 
giving your system a quick checkup, Norton Utilities has the immediate 
solution.

Fixing disk problems

To find and fix disk problems using Norton Disk Doctor:

1 Click the Start button, and then select Programs > Norton Utilities > 
Norton Disk Doctor.

2 Select the drive you want to diagnose.

Tip: It is okay to select more than one drive to diagnose.

3 Click Diagnose.

Norton Disk Doctor checks the various components of your disk.

4 Follow the on-screen prompts as Norton Disk Doctor identifies and 
fixes any problems found on your disk.

If you want Disk 
Doctor to fix all errors 
that it finds, check 
Automatically Fix 
Errors
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Fixing Windows problems

To find and fix Windows problems using Norton WinDoctor:

1 Click the Start button, and then select Programs > Norton Utilities > 
Norton WinDoctor.

2 Follow the Norton WinDoctor Wizard instructions to check your 
system for problems.

3 Click Finish.

Norton WinDoctor displays a checklist of the problems it found.

4 You can choose to fix all or some of the problems:

� Click Repair All to automatically correct all problems.

� Select a specific problem and click Repair.

Note: The recommended repair method is selected by default in the Repair 
dialog box. You may optionally select alternate repair methods.

Information 
about the 
selected 
high-level 
problem

Sub-problems for 
the high-level 
problem selected 
in the Problems 
Found list
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Solving your computer problems with Norton Utilities 
Speeding up your computer’s performance
When your computer is operating at peak efficiency, so are you. A sluggish 
computer is more than just an annoyance. It may be a symptom of more 
serious problems to come.

Your computer’s hard drive stores all of your files, applications, and the 
Windows operating system. Over time, the bits of information that make 
up your files get spread all over the disk. This is known as fragmentation, 
and is a very inefficient way to store and retrieve information on a hard 
drive. The more you use your computer, the worse it gets. Before long, a 
fragmented hard drive can cause the entire system to slow down.

To speed up your hard drive using Speed Disk:

1 Click the Start button, and then select Programs > Norton Utilities > 
Speed Disk.

2 Click Start (Start Optimizing in Windows NT and Windows 2000) to 
optimize your drive.

Speed Disk optimizes your disk drive.

Note: By default, Speed Disk optimizes your primary hard drive (usually 
drive C:). To optimize another drive, select it, and then click Start or Start 
Optimizing.

Some kinds of fragmentation need special attention. Windows creates a 
special file on your hard drive called a swap or paging file. This file is used 
to create additional memory so your Windows programs can make 
maximum use of available system resources. The size of the swap file 
changes dynamically in response to demand for memory space. This can 
cause significant fragmentation of the swap file, which in turn reduces 
performance.

Another Windows component that can affect system performance is the 
Windows Registry. The Registry is a dynamic database of configuration 
settings for both the operating system and applications. Over time, the 
internal structure of this database can become disordered. This disorder 
can affect system performance.

Norton Optimization Wizard sets an appropriate minimum swap file size to 
reduce file fragmentation, and reorganizes the Windows Registry data for 
efficient storage and retrieval. On Windows 95, Norton Optimization 
Wizard also enables Speed Start to make your programs start faster.
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Giving your system a checkup
To speed up your system using Norton Optimization Wizard:

1 Click the Start button, and then select Programs > Norton Utilities > 
Norton Optimization Wizard.

2 Click Next.

After offering to benchmark your drives (if they are not already 
benchmarked), Norton Optimization Wizard checks your swap file and 
makes a recommendation.

3 Click Next.

Norton Optimization Wizard offers to track and speed up application 
loading by enabling Speed Start. If you accept, an icon in the taskbar 
notifies you that Speed Start is running. 

Note: Because functionality similar to Speed Start is built in to later 
versions of Windows, this screen only appears in Windows 95.

4 Click Next.

Norton Optimization Wizard offers to optimize your Registry.

5 Click Next.

Norton Optimization Wizard summarizes the choices you have made.

6 Close any other programs you may have running and click Restart.

Norton Optimization Wizard implements your choices and restarts your 
computer.

Giving your system a checkup
When you want to give your system a complete checkup, Norton System 
Check is the tool to use. It performs all the same tests as Norton System 
Doctor, but Norton System Check doesn’t need to be running all the time. 

To check the overall health of your system with Norton System 
Check:

1 Click the Start button, and then select Programs > Norton Utilities > 
Norton System Check.

2 Follow the Norton System Check Wizard instructions to check your 
system for problems.

3 Click Finish.

Norton System Check displays a checklist of the problems it found.
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4 You can choose to fix all or some of the problems:

� Click Repair All to automatically correct all problems.

� Select a specific problem and click Repair.

Note: The recommended repair method is selected by default in the 
Repair dialog box. You may optionally select alternate repair methods.

Recovering erased files

Caution: If you have an emergency, do not install Norton Utilities and do 
not start Windows. Any new files copied to your hard drive might 
overwrite existing data. Starting Windows writes to your hard drive as well. 
The Windows swap file could overwrite data you would like to recover. 
For information on emergency procedures, see “Norton Utilities emergency 
procedures” on page 49.

When you erase a file using Windows Explorer, Windows keeps a 
temporary copy of the file in the Recycle Bin. However, Windows does not 
detect files erased or overwritten by applications running under Windows 
or erased from a command prompt. Norton Utilities can help you get these 
files back. Norton Protection guards against losing the files the Recycle Bin 

Sub-problems 
for the high-level 
problem selected 
in the Problems 
Found list

Information about 
the selected 
high-level problem
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Getting more information about your computer
does not protect. On Windows 95, Windows 98, and Windows Me, 
UnErase Wizard can help you restore even unprotected files.

To recover a file you recently erased:

1 Click the Start button, and then select Programs > Norton Utilities > 
UnErase Wizard.

The Find Recently Deleted Files button should be selected.

2 Click Next.

UnErase Wizard displays a list of the 25 most recently deleted files.

3 Locate the file you want to recover and select it.

4 Click Recover.

If your deleted file is not listed (Windows 95, Windows 98, and 
Windows Me only):

1 Click Next to continue through UnErase Wizard.

UnErase Wizard steps you through the process of creating a more 
complete list of deleted files from which to choose.

2 When the file you want to recover is located, select it.

3 Click Recover.

4 Click Finish to close UnErase Wizard.

Tip: Your file may appear in the list with a question mark (?) in place of the 
first letter of the filename. If so, you are prompted to type the first letter of 
the original filename. If you do not know what it is, type any letter from A 
to Z as a substitute. Make a note of the filename so you can find it later.

Getting more information about your computer
No matter what your level of computer expertise, questions about your 
system arise occasionally. For example, when you call for help installing 
new hardware or software, you may be asked questions about your 
system’s BIOS, bus type, processor, ports, video and multimedia 
capabilities, or memory capacity. Knowing a little detailed information 
about your computer can be a big help at such times.

System Information gives you quick and easy access to information about 
your system. It provides hundreds of basic and technical details about your 
computer, the peripherals (keyboard, mouse, printers and multimedia 
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devices) attached to your computer, and your computer’s Internet and 
network connections. 

To find out about your computer using System Information:

1 Click the Start button, and then select Programs > Norton Utilities > 
System Information.

2 Click a tab to display a category of information.

System Information can print reports about your system and its 
components. These reports provide a complete description of your system 
and are helpful when you call a vendor for technical support.

Testing your computer hardware
Norton Diagnostics tests your computer hardware to be sure it is working 
correctly. You can perform a complete test of all your hardware or you can 
test individual components.

To test your computer hardware with Norton Diagnostics:

1 Click the Start button, and then select Programs > Norton Utilities > 
Norton Diagnostics.

2 Click Do All Tests.

3 Click Test.

Tip: You can test individual components by selecting the component 
on the left side of the screen, and then clicking Test.
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4 The Run All Diagnostics screen appears and Norton Diagnostics starts 
testing.

Each component is added to the list on the right as it is tested. If a 
problem is found, a red circle with a line through it appears next to the 
component name.
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C H A P T E R
 6
Finding the solution 
to your problem

This section is provided to help you find solutions to your problems 
quickly.

Note: Because Windows NT and Windows 2000 are not based on MS-DOS, 
many of the Norton Utilities procedures identified in this section are only 
available in Windows 95, Windows 98, and Windows Me.
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Help! Windows won’t start 

See “Scenario 3: 
Recovering startup data” on 
page 62.

Is Norton Utilities 
installed?

See “Scenario 3: 
Recovering startup data” on 
page 62.

Do you have Zip Rescue 
Disks?

Does your computer start 
up, but won’t start 
Windows?

See “Startup errors” on 
page 56.

See “Startup errors” on 
page 56.

Do you have basic Rescue 
Disks?

Are your Rescue Disks on 
floppy disks?

See “To recover from a 
crash with a basic Rescue 
Disk set on other media:” 
on page 53.

Yes

No

Yes

No

No

Yes

Yes

No

No

See “To recover from a 
crash with basic 
(floppy-based) Rescue 
Disks:” on page 53.

Yes
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I need to recover files or folders
I need to recover files or folders 

Is Windows running?

See “To unformat a disk 
with UnFormat:” on page 58 
or “To recover erased files 
with UnErase:” on page 58.

Is Norton Utilities 
installed?

Yes

No

No

See “Unerasing files 
before you install 
Norton Utilities” on 
page 50.

See “Recovering erased 
files” on page 40.

Yes
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I have a disk problem

Will Windows start?

See “To repair a hard drive 
with Norton Disk Doctor:” 
on page 59.

Is Norton Utilities 
installed?

Yes

No

No

See “Fixing disk problems 
before you install 
Norton Utilities” on 
page 51.

See “Fixing disk problems” 
on page 36.

Yes
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C H A P T E R
 7
Norton Utilities 
emergency procedures

Unexpected problems can sometimes wreak havoc with even the best 
protected computer. The logical structures of your hard drive might 
become corrupted. You might accidentally delete an important file, or an 
entire folder of important files. A system crash might even erase startup 
and configuration settings, making your computer unusable. Norton 
Utilities gives you the very best chance of recovering from these problems.

Tip: “Finding the solution to your problem” on page 45 includes 
troubleshooting charts to help you find the correct solution to your 
problems.

This chapter explains how to get your system up and running even when 
you cannot start Windows, including:

� Determining which Norton Utility to use

� Recovering files before installing Norton Utilities

� Fixing disk problems before installing Norton Utilities

� Using a Rescue Disk set

� Using the DOS-based Norton Utilities programs

� Using the Norton Utilities Emergency Disks

Caution: If you have an emergency, do not install Norton Utilities and do 
not start Windows. Any new files copied to your hard drive might 
overwrite existing data. Starting Windows also writes to your hard drive. 
The Windows swap file could overwrite data you would like to recover. To 
find a solution to your problem, see “Finding the solution to your problem” 
on page 45.
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Caution: A Dynamic Drive Overlay (DDO) may be required for your 
computer to work properly. A DDO, such as Ontrack Disk Manager, 
Max*Blast, Microhouse EZ-Drive or Pro-Drive, provides support for large 
hard drives. It is critical that you determine if you have a DDO before 
attempting to use any recovery procedures described in this chapter.

A DDO, if present, loads from your hard drive. Booting from a floppy disk 
such as an Emergency Disk or Rescue Disk will not load the DDO. Without 
the DDO, all hard drive recovery steps will fail and may result in additional 
damage to your system.

All DDOs display a message when you start your computer. To start up 
from a floppy disk you must first let the DDO load, and then insert the 
floppy disk you want to start up from. All DDOs let you start up from a 
floppy disk by pressing a key during the startup process. Consult your 
DDO documentation or watch for a message when you start up to 
determine which key to press.

None of the Norton Utilities utilities can repair a damaged DDO. If your 
DDO is damaged you will need to consult your computer’s manufacturer 
or the DDO publisher directly.

If you don’t know if a DDO is present on your system, contact your 
hardware manufacturer or Symantec technical support before trying any 
recovery procedures described in this user’s guide. Most newer systems do 
not use a DDO.

Unerasing files before you install Norton Utilities
When you erase a file using Windows Explorer, Windows keeps a 
temporary copy of the file in the Recycle Bin. However, Windows does not 
detect files erased or overwritten by applications running under Windows 
or erased from a command prompt. Norton Unerase can help you get these 
files back. 

Because installing Norton Utilities can overwrite erased files on your hard 
drive, Norton Utilities provides a way to recover files before you install 
Norton Utilities.
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Fixing disk problems before you install Norton Utilities
To recover a file (Windows 95, Windows 98, and Windows Me only):

1 Put your installation CD into the CD-ROM drive. 

2 When the first screen appears, click Launch Utilities From CD.

Caution: Do not click Install Norton Utilities. Doing so will overwrite 
information on your hard drive.

3 When the Norton Utilities CD Utilities screen appears, click Norton 
Unerase.

4 When the Norton UnErase Wizard starts, select Find Any Recoverable 
Files Matching Your Criteria and click Next.

UnErase Wizard steps you through the process of creating a list of 
deleted files from which to choose.

5 When the file you want to recover is located, click the filename to 
select it.

6 Click Recover.

7 Click Finish to close UnErase Wizard.

Tip: Your file may appear in the list with a question mark (?) in place of the 
first letter of the filename. If so, you are prompted to type the first letter of 
the original filename. If you do not know what it is, type any letter from A 
to Z as a substitute. Make a note of the filename so you can find it later.

Fixing disk problems before you install 
Norton Utilities

To find and fix disk problems using Norton Disk Doctor:

1 When the first screen appears, click Launch Utilities From CD.

Do not click Install Norton Utilities. Doing so will overwrite 
information on your hard drive.

2 When the Norton Utilities CD Utilities screen appears, click Norton 
Disk Doctor.

3 Select the drives you want to diagnose.

4 Click Diagnose.

Norton Disk Doctor checks the various components of your disk.
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5 Follow the on-screen prompts as Norton Disk Doctor identifies and 
fixes any problems found on your disk.

Recovering from a system crash
The small amount of time invested in creating and maintaining a Rescue 
Disk set pays off when you have a system crash. With a current Rescue 
Disk set, you should be back up and running in no time.

Note: Because Windows NT and Windows 2000 are not based on MS-DOS, 
the procedures in this section are only available in Windows 95, Windows 
98, and Windows Me.

This section covers system crash recovery using several different types of 
Rescue Disk sets:

� Norton Zip Rescue Disks

� Basic Rescue Disks (floppy-based)

� Basic Rescue Disks (stored on large-capacity media)

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See Caution on page 50.

Caution: Never use Rescue Disks made on another computer. Rescue 
Disks contain information specific to the computer on which they were 
made. 

Tip: The more recent the Rescue Disks, the better your chances of a full 
recovery.

To recover from a crash with Norton Zip Rescue Disks:

1 Insert the Zip Rescue Disk in your Zip drive.

Caution: If you have multiple Zip drives installed on one computer, 
make sure to always use the same Zip drive when creating, updating, 
and using your Norton Zip Rescue Disks.

2 Insert the floppy Rescue Boot Disk in your A: drive.
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3 Restart your computer.

Windows starts and the Rescue Recovery Wizard appears.

Note: Windows will take longer than usual to start up.

4 Follow the on-screen prompts to recover your system.

To recover from a crash with basic (floppy-based) Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk Screen to appear.

3 Follow the instructions on the screen to run Rescue Recovery. The 
Restore Rescue Information dialog box appears.

Caution: If Rescue Restore does not detect any startup file problems, 
the Items To Restore check boxes will be clear. Do not proceed with 
the restore process. Press Esc to exit.

4 Press R to restore the selected items.

For information on using the DOS-based Norton Utilities programs to 
recover your system, see “DOS procedures” on page 54.

To recover from a crash with a basic Rescue Disk set on other media:

If you chose to place your basic Rescue Disks in a folder on a network 
drive or other large-capacity disk drive, you were instructed to also make a 
bootable floppy disk. This disk should contain the network drivers or other 
files necessary to start your computer and access the drive on which you 
placed your Rescue Disk set. For more information see “Creating Rescue 
Disks” on page 25.

Candidates to 
be restored are 
checked by 
default
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1 Insert a bootable floppy disk in your A: drive and restart your 
computer.

Note: This disk must contain the network drivers or other files 
necessary to start your computer and access the drive on which you 
placed your Rescue Disk set. 

2 Access the network or other drive on which you stored your Rescue 
Disk set.

3 Type RSHELL and press Enter.

4 The Rescue Disk screen appears. Follow the on-screen instructions.

For information on using the DOS-based Norton Utilities programs to 
recover your system, see “DOS procedures” on page 54.

DOS procedures
This section covers procedures using the DOS-based Norton Utilities 
programs.

Note: Because Windows NT and Windows 2000 are not based on MS-DOS, 
the procedures in this section are only available in Windows 95, 
Windows 98, and Windows Me.

If you have made Norton Zip Rescue Disks, see “Recovering from a system 
crash” on page 52 for recovery procedures.

Norton Utilities DOS-based programs

Caution: If you have an emergency, do not install Norton Utilities and do 
not start Windows. Any new files copied to your hard drive might 
overwrite existing data. Starting Windows also writes to your hard drive. 
The Windows swap file could overwrite data you would like to recover.

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.
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The following DOS-based programs come with Norton Utilities:

� Disk Editor (DISKEDIT.EXE)

Full-featured sector editor, for advanced users, that lets you manually 
examine and modify files, directories, clusters, sectors, and systems 
areas of your disk. Use Disk Editor to edit, save, or undo changes to 
your disk parameters and to search an area of your disk for a particular 
data string. 

� Norton Disk Doctor (NDD.EXE)

Easy-to-use program that diagnoses and repairs common disk 
problems.

� UnErase (UNERASE.EXE)

Program that recovers erased files automatically or manually.

� UnFormat (UNFORMAT.EXE)

Program for restoring an accidentally formatted disk or repairing a 
severely damaged disk.

To find detailed information about the DOS-based Norton Utilities 
programs online while using them, press F1.

Levels of DOS recovery

This section explains four levels of DOS recovery procedures using 
DOS-based Norton Utilities programs:

� Recovery procedures

How to repair a hard drive, recover accidentally deleted files, or 
unformat a disk.

� Startup procedures 

How to repair common hardware, setup data, startup data, operating 
system, and hard drive problems.

� Common procedures

How to repair common disk problems.

� Advanced procedures

How to repair less common disk problems with Disk Editor, a 
full-featured disk sector editor.
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Before you begin

Many of these procedures using the DOS-based programs—Disk Editor, 
Norton Disk Doctor, UnErase, and UnFormat—require you to have a blank, 
formatted floppy disk available to create an undo file, just in case the 
corrections you made are not what you expected.

In addition, the procedures using the DOS-based programs require you to 
insert the Emergency or Rescue Disk that has the program’s .EXE file. To 
save time, make directory printouts of your Emergency and Rescue Disks 
so you will know where the .EXE files are located.

Finally, some procedures recommend using either your basic Rescue Disk 
set or your Emergency Disks. If you have a basic Rescue Disk set, try that 
first, since your Rescue Disks have more up-to-date files for your computer. 
Otherwise, use the Emergency Disks.

Startup errors

The following list includes many of the errors you may see when you have 
problems starting your computer. Turn to the page indicated to see how to 
solve your problem.

Problem Scenario Page

Battery Discharged Scenario 2 page 61

CMOS Checksum error Scenario 2 page 61

CMOS Information not found Scenario 2 page 61

Data Error Reading Drive X Scenario 5 page 66

Date and Time not set Scenario 2 page 61

Disk Boot Failure Scenario 2 page 61

Drive X error Scenario 2 page 61

Error loading Operating System (O/S) Scenario 3 page 62

Hard Disk # error Scenario 2 page 61

Hard Disk Boot sector invalid Scenario 3 page 62

Hard Drive # Controller failure, hard drive 
absent or missing 

Scenario 1 page 60
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HDD Controller Failure Scenario 2 page 61

Hardware Information Lost Scenario 2 page 61

Faulty…. Scenario 1 page 60

Illegal instruction trapped Scenario 1 page 60

Insert a (valid) boot disk Scenario 3 page 62

Invalid Media Type Scenario 9 page 72

Invalid Media Descriptor Byte Scenario 9 page 72

Invalid Partition Table Scenario 3 page 62

Invalid System Disk Scenario 3 page 62

Missing Operating System Scenario 3 page 62

Memory Size Mismatch Scenario 2 page 61

No ROM BASIC – System halted Scenario 3 page 62

NON-DOS Disk Error on Bootup Scenario 9 page 72

Non System Disk or disk error Scenario 4 page 65

Parity error at address Scenario 1 page 60

ROM Checksum invalid Scenario 1 page 60

Sector Not Found reading Drive X Scenario 5 page 66

Seek error Scenario 1 page 60

Segment boundary overrun Scenario 1 page 60

Unexpected amount of memory found Scenario 2 page 61

Problem Scenario Page
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Recovery procedures

Caution: If you have an emergency and you have purchased 
Norton Utilities to restore your hard drive, recover accidentally deleted 
files, or unformat a disk, do not install Norton Utilities. Any new files 
copied to your hard drive might overwrite existing data, preventing 
complete recovery. 

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Follow the procedures below for recovering data. These procedures 
provide you with the basic steps for using UnFormat, UnErase, and Norton 
Disk Doctor from the Emergency Disks included with Norton Utilities. Use 
Emergency Disk 1 to start your computer, if necessary.

To unformat a disk with UnFormat:

1 Insert Emergency Disk 1 into the startup drive and restart your 
computer.

2 Use the UpArrow and DownArrow keys to select UnFormat and press 
Enter.

3 Read the UnFormat message and press Enter.

4 Use the UpArrow and DownArrow keys to select the drive you want to 
unformat and press Enter.

5 Follow the on-screen instructions to recover your disk automatically.

To recover erased files with UnErase:

1 Restart the computer in MS-DOS mode.

If your computer does not start from your hard drive because you have 
deleted COMMAND.COM or the Windows system files, restart your 
computer using Emergency Disk 1 in the A: drive. Use the UpArrow 
and DownArrow keys to select UnErase and press Enter.

2 At the command line, change to the directory from which your file was 
erased.

Note: If you have deleted a full directory of files and also removed the 
directory, first recover the directory. Then use the same procedure to 
recover the erased files.
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3 Insert Emergency Disk 1 into the appropriate drive and press Enter.

4 At the command prompt, type A:UNERASE and press Enter.

(Substitute B: for A: if using the B: drive.)

UnErase checks for erased files. UnErase displays the name, size, date, 
time, and recovery prognosis for each erased file. Each filename begins 
with a question mark (?) because DOS overwrites the first letter of a 
filename when erasing a file.

5 Do one of the following:

� To recover a displayed file, use the UpArrow and DownArrow keys 
to select it.

� To select a file that is not displayed, press Alt+A to activate the 
UnErase File menu’s View All Directories command. Then, select 
the file you want to recover. (If the erased file is on a different 
drive, press Alt+D to select another drive.)

6 Press U to select the UnErase command button.

UnErase prompts you to type a new first letter for the filename.

7 Type a first letter for the filename.

The letter does not have to be the original letter; any letter will do. You 
can rename the recovered file later. UnErase automatically recovers the 
file.

To repair a hard drive with Norton Disk Doctor:

If you cannot start your computer, have trouble accessing your hard drive, 
or cannot find files or directories that you never deleted, follow the steps 
below:

1 Do one of the following:

� If your computer does not start from your hard drive, insert 
Emergency Disk 1 into the A: drive and restart your computer. Use 
the UpArrow and DownArrow keys to select Disk Doctor and press 
Enter.

� If your computer starts from your hard drive, insert Emergency Disk 
1 in the appropriate drive. Type A:NDD at the command prompt 
and press Enter. (Substitute B: for A: if you are using the B: drive.)

The Norton Disk Doctor main menu appears with Diagnose Disk 
selected.

2 Press Enter.
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3 Use the UpArrow and DownArrow keys to select the drive to diagnose 
and press Enter.

If Norton Disk Doctor finds any errors, follow the on-screen 
instructions to correct the errors.

Startup procedures

Follow the procedures below to repair common hardware, setup data, 
startup data, operating system, and hard drive problems with DOS-based 
Norton Utilities programs.

Note: Many of the following procedures include an instruction to insert the 
Basic Rescue Boot Floppy Disk. In all cases, this refers to the first disk of a 
floppy-based basic Rescue Disk set, not a Norton Zip Rescue Disk set. If 
you have an Iomega Zip drive installed, see “Creating Norton Zip Rescue 
Disks” on page 25 for information on creating a Norton Zip Rescue Disk 
set that lets you start Windows even when your computer will not start in 
the normal way.

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Scenario 1: Repairing general hardware problems

When you turn your computer on, it performs the Power-On Self Test 
(POST). This process verifies the existence and operation of hardware—
hard drives, video hardware, memory, and the keyboard—that is critical to 
starting your computer. If a problem is found, it is reported to you on the 
screen or as a series of beeps if the video display is disconnected or not 
working. Refer to your computer manufacturer’s documentation to 
decipher beep codes.

Many hardware problems that are found display messages similar to these:

� Fault

� Hard disk # controller failure

� Hard disk absent or failed

� Illegal instruction trapped

� Parity error at address
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� ROM checksum invalid

� Segment boundary overrun

Warning: Observe your computer manufacturer’s safety guidelines before 
opening your computer. For proper handling instructions, refer to your 
computer manufacturer’s documentation.

Checking inside your computer

Before suspecting a defective device, check inside your computer to:

� Make sure adapter cards, such as video and disk controller cards, are 
seated properly in the correct expansion slots.

� Make sure memory modules are seated correctly.

� Make sure drive cables are connected properly.

� Make sure multiple hard drives are configured to work together. For 
more information on properly configuring multiple hard drives, refer to 
your computer manufacturer’s documentation as well as any 
documentation you might have on your additional hard drives.

� Make sure additional adapter cards, such as multimedia or tape backup 
controller cards, are configured properly. For information on properly 
configuring these devices, refer to the manufacturer’s documentation.

After checking these items, close the computer and turn it on to see if your 
computer starts normally.

If you cannot repair general hardware problems

If the problem persists, contact your computer manufacturer or the 
manufacturer of the device that you suspect is faulty.

Scenario 2: Correcting computer setup data

The Power-On Self Test (POST) process, discussed in Scenario 1, checks 
the settings of many hardware components against values stored in a 
CMOS chip. CMOS chips store vital information about your computer. Even 
when your computer is turned off, the CMOS chip continuously stores this 
information using a battery. If a discrepancy is found, a message similar to 
one of the following displays:

� Battery discharge

� CMOS checksum error
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� CMOS information not found using defaults

� Date and time not set—run setup

� Drive x error

� Hard disk # error

� Hardware information lost—run setup

� HDD controller failure

� Memory size mismatch—run setup

� Unexpected amount of memory found—run setup

The error may also be related to a partition table or boot record problem. 
For more information, see “Scenario 3: Recovering startup data” on 
page 62.

To correct computer setup data:

1 Turn on your computer.

2 As your computer starts, press the key combination to enter the setup 
program. 

The correct key or key combination is usually shown on the screen as 
the computer first starts.

3 Update the CMOS settings. 

For more information, see your computer manufacturer’s 
documentation.

Many computers will update the CMOS with appropriate settings 
simply by running the setup program and saving the values when you 
exit.

Scenario 3: Recovering startup data

When the Power-On Self Test (POST) process discussed in Scenarios 1 and 
2 is complete, the hard drive is accessed for startup information if your A: 
drive does not contain a disk. The first piece of startup information is the 
master boot record, which contains the partition table. The next piece of 
startup information is the boot record of the startup partition.
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If any of the information in the master boot record, partition tables, or boot 
record is corrupt or missing, a message similar to the following displays:

� Hard disk boot sector invalid

� Please insert a boot disk

� Please insert a valid boot disk and press any key

To recover startup data with Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

Caution: Never use Rescue Disks made on another computer. Rescue 
Disks contain information specific to the computer on which they were 
made. If you don’t have Rescue Disks, see “To recover startup data 
with the Emergency Disks:” on page 64.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Use the DownArrow key to select Rescue Recovery and press Enter.

The Restore Rescue Information dialog box appears. Rescue Restore 
examines your computer’s boot records and partition table information 
and automatically selects any damaged Rescue Restore items to be 
restored. 

Caution: If Rescue Restore does not detect any startup file problems, 
the Items To Restore check boxes will be cleared. Do not proceed with 
the restore process. Press Esc to exit.

4 If Boot Records, Partition Tables, or both is selected, press Alt+R to 
restore the information.

A confirmation box appears (twice) that lets you verify the information 
you are about to restore.

5 Press Enter and follow the on-screen instructions.

6 Remove the disk from the startup drive and restart your computer.

If the problem has been fixed, your computer will start normally.
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To recover startup data with the Emergency Disks:

Tip: You can use the CD that contains Norton Utilities as an Emergency 
Disk if your computer can start up from the CD-ROM drive. See “Using the 
CD as an Emergency Disk” on page 10.

1 Insert Emergency Disk 1 into the startup drive and restart your 
computer.

2 Use the DownArrow key to select Disk Doctor.

3 At the prompt, type: /REBUILD and press Enter.

4 Insert Emergency Disk 2 when requested.

The Norton Disk Doctor main dialog box appears.

5 Press Enter to diagnose the drive.

A message box appears indicating that your hard drive has no 
partitions.

6 Press Enter to have Norton Disk Doctor rebuild the partition table.

A message box appears indicating that a partition has been found and 
asks you if you would like to revive it.

7 Do one of the following:

� If the partition size indicated is correct, press Enter to revive the 
partition table.

The partition table is revived. 

� If the partition size indicated is incorrect, click No.

Norton Disk Doctor continues to search.

8 To revive more partition tables, press Enter to search for them. 
Otherwise, press Alt+N.

Before changes are made to the disk, you are prompted to create an 
undo file.

9 Press Enter to create an undo file.

The Undo File dialog box appears.

10 Use the UpArrow and DownArrow keys to select the drive on which to 
store the undo data.

Note: Do not store undo data on the same physical drive you are 
attempting to repair. The best place to store undo data is on a blank 
formatted floppy disk.
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11 Insert a formatted floppy disk with at least 100K of free space into the 
appropriate drive and press Enter.

Note: Do not reuse Undo disks. Overwriting the same disk means that 
previous changes cannot be undone.

Norton Disk Doctor saves the undo data to disk and repairs your 
partition tables. When Norton Disk Doctor has finished, a message box 
appears, indicating the partition information has been changed.

12 Remove the disk from the startup drive and restart your computer.

If the problem has been fixed, your computer will start normally.

If you cannot recover startup data

If the problem persists, it is possible that the disk’s operating system files 
are missing or corrupt. For more information, see “Scenario 4: Recovering 
operating system files” on page 65.

Scenario 4: Recovering operating system files

When your computer successfully completes the Power-On Self Test 
(POST), your computer loads the master boot record program that passes 
control to the disk’s boot record. The boot record then loads IO.SYS, which 
carries out the rest of the startup process. To start Windows, both 
COMMAND.COM and MSDOS.SYS files must be present. If they are not, 
your computer will not start Windows properly. 

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

To recover operating system files:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

Press Esc to go to the DOS command prompt.

3 Insert the NU Emergency Utility Disk 1 (it contains the SYS.COM file).
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4 At the command prompt, type SYS C: and press Enter.

Note: If the message “Insert system disk in drive A:\” appears, insert 
the Basic Rescue Boot Floppy Disk into the startup drive and press any 
key.

The SYS program copies the system files from your Rescue Disk to 
your hard drive. 

5 Insert the labeled “Basic Rescue Boot Floppy Disk,” which contains the 
MSDOS.SAV file. 

At the command prompt, type:
C:\WINDOWS\COMMAND\ATTRIB -R -S -H C:\MSDOS.SYS

If Windows is installed in a location other than C:\WINDOWS, modify 
the command line with the proper location (for example, 
C:\WIN95\COMMAND\ATTRIB -R -S -H C:\MSDOS.SYS).

6 At the command prompt, type: 

COPY A:\MSDOS.SAV C:\MSDOS.SYS and press Enter.

Your MSDOS.SYS file is restored. 

7 Remove the Rescue Disk from the drive and restart your computer.

If the problem has been fixed, your computer will start normally.

If you cannot recover operating system files

If the problem persists, it is possible that the disk itself has a problem.

Scenario 5: Repairing a malfunctioning hard drive

A hard drive that is not working properly can result from many different 
problems. Possible causes include a corrupt partition table or boot record, 
physical defects in the disk surface, or bad system files.

Caution: If the drive parameters were entered incorrectly into the CMOS, 
you may also experience this problem. If this is the case, do not run 
Norton Disk Doctor. Fix your CMOS settings using your computer’s CMOS 
setup program.

If you have unsuccessfully tried to fix a problem listed in the scenarios in 
this chapter, run the DOS version of Norton Disk Doctor. 
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To repair a malfunctioning hard drive with Norton Disk Doctor and 
basic Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose Disk Doctor from the menu. NDD.EXE appears on the 
command line.

4 At the prompt, complete NDD.EXE [drive:] /C and press Enter. 

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

5 Insert the NU Emergency Utilities Disk 1 when requested.

Norton Disk Doctor performs a diagnosis of the specified drive.

6 Follow the on-screen instructions.

7 Remove the Rescue Disk from the startup drive and restart your 
computer.

If the problem has been fixed, your computer will start normally.

To repair a malfunctioning hard drive with Norton Disk Doctor and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear. 

3 Use the UpArrow and DownArrow keys to select Disk Doctor.

4 At the prompt, complete NDD.EXE [drive:] /C and press Enter. 

For example, NDD.EXE D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

5 Insert the NU Emergency Utilities Disk 2 when requested.

Norton Disk Doctor performs a diagnosis of the specified drive.

6 Follow the on-screen instructions.

7 Remove Emergency Disk 1 from the startup drive and restart your 
computer.

If the problem has been fixed, your computer will start normally.
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If you cannot repair a malfunctioning hard drive

If the problem persists, call your computer’s manufacturer or a local 
professional.

Tip: Symantec provides data recovery in the United States and Canada for 
PC and Macintosh hard drives that are not physically damaged. If you want 
highly-trained and dedicated professionals to recover your data, contact the 
Symantec Data Recovery Team at http://www.symantec.com/techsupp/
recovery/. Or, call our Fax-on-Demand system at (541) 984-2490 and 
request document #4132.

Common procedures

Follow the procedures below to access data on a damaged floppy disk, 
recover files on a disk that appears empty, recover a formatted or severely 
damaged disk, repair a disk with incorrect media descriptor byte 
information, recover lost or damaged directories, recover overwritten files, 
recover corrupt Registry files, or recover an inaccessible disk.

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Scenario 6: Accessing data on a damaged floppy disk

You try to access a floppy disk that you know contains data but it cannot 
be read by Windows or Norton Disk Doctor. Generally, you can copy the 
data from a bad floppy disk to another floppy disk using the DISKCOPY 
program. Unfortunately, the data residing in the damaged areas of the bad 
floppy disk remains damaged on the new disk.

Tip: You can perform the following procedure within Windows by 
opening a DOS dialog box. To open a DOS dialog box click the Start 
button, and then select Programs > MS-DOS Prompt.
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To access data on a damaged floppy disk using DISKCOPY:

1 Insert the bad disk into the appropriate drive.

2 At the command prompt, type DISKCOPY A: A: and press Enter.

(Substitute B: for A: if you are using the B: drive.)

This command causes you to swap source and destination disks. Your 
computer reads from the source disk to see if it has any errors.

3 Continue to follow the on-screen instructions. 

4 Verify the integrity of the new floppy disk with either the DOS- or 
Windows-based Norton Disk Doctor.

Scenario 7: Recovering files on a disk that appears empty

If you know files exist on a disk, but either nothing displays or what 
displays makes no sense when you view the disk contents, then the root 
directory and possibly other directories have been damaged or destroyed.

For the best results, use Norton Disk Doctor, create an undo file, and repair 
the problem. 

To recover files on a disk that appears empty with Norton Disk 
Doctor and basic Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose Disk Doctor from the menu.

4 At the prompt, type NDD [drive:] /C and press Enter. 

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove the Rescue Disk from the startup drive and restart your 
computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 6, 
but replace /C with /UNDO. For example, NDD D: /UNDO. 

If the results of the repair are not what you expected, undo the repairs 
using the undo file and use UnFormat from your Emergency Disks or your 
Rescue Disks. For more information, see “To recover files on a disk that 
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appears empty with UnFormat and basic Rescue Disks:” on page 70. If 
UnFormat locates an image file, which is possible if you are using Norton 
System Doctor, total recovery is possible. If UnFormat does not find an 
image file, UnFormat will recover the directories and the files contained 
within those directories in the root directory. Files in the root directory are 
lost.

To recover files on a disk that appears empty with Norton Disk 
Doctor and Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear. 

3 Use the UpArrow and DownArrow keys to select Norton Disk Doctor.

4 At the prompt, and after NDD, type [drive:] /C and press Enter. 

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove Emergency Disk 1 from the startup drive and restart your 
computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 4, 
but replace /C with /UNDO. For example, NDD D: /UNDO. 

If the results of the repair are not what you expected, undo the repairs 
using the undo file and use UnFormat using your Emergency Disks or your 
Rescue Disks. For more information, see “To recover files on a disk that 
appears empty with UnFormat and Emergency Disks:” on page 71. If 
UnFormat locates an image file, which is possible if you are using Norton 
System Doctor, total recovery is possible. If UnFormat does not find an 
image file, UnFormat will recover the directories and the files contained 
within those directories in the root directory. Files in the root directory are 
lost.

To recover files on a disk that appears empty with UnFormat and 
basic Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Press Esc to go to the DOS command prompt.
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4 Insert the Rescue Disk that contains the UNFORMAT.EXE file into the 
startup drive.

5 At the DOS command prompt, type
UNFORMAT [drive:] /IMAGE and press Enter.

For example, UNFORMAT D: /IMAGE.

6 Follow the on-screen instructions.

7 Remove the Rescue Disk from the startup drive and restart your 
computer.

To recover files on a disk that appears empty with UnFormat and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select UnFormat.

4 At the prompt and after UnFormat, type:
[drive:] /IMAGE and press Enter.

For example, UNFORMAT D: /IMAGE.

5 Follow the on-screen instructions.

6 Remove the Emergency Disk from the startup drive and restart your 
computer.

Scenario 8: Recovering a formatted or severely damaged 
disk 

You accidentally formatted a disk that contained important data. Repairing 
a formatted disk is the same for both floppy and hard drives. However, if 
you formatted a floppy disk using a format program’s “full format” feature, 
the data areas of a floppy disk are completely overwritten, preventing any 
recovery. If you did not “full format” a floppy disk, you may be able to 
recover the data.

To recover a formatted or severely damaged disk with UnFormat and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select UnFormat.
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4 At the prompt, and after UnFormat, type [drive:] and press Enter. 

For example, UNFORMAT D: means that UnFormat will try to unformat 
your D: drive.

5 Follow the on-screen instructions.

6 Remove Emergency Disk 1 from the startup drive and restart your 
computer.

7 Check the disk.

Scenario 9: Repairing a disk with incorrect media descriptor 
byte information

An “Invalid media type” or “Non-DOS disk” message indicates the media 
descriptor byte on the first copy of the file allocation table (FAT) does not 
match the media descriptor byte on the boot record of the disk. This 
message also may appear if you try accessing or formatting a damaged 
floppy disk or a floppy disk formatted for some other operating system.

To repair a disk with incorrect media descriptor byte information with 
Norton Disk Doctor and Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose Disk Doctor from the menu.

4 At the prompt, type NDD [drive:] /C and press Enter. 

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove the Rescue Disk from the startup drive and restart your 
computer.

7 Check the disk.

To repair a disk with incorrect media descriptor byte information with 
Norton Disk Doctor and Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Norton Disk Doctor.
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4 At the prompt, and after NDD, type [drive:] and press Enter.

For example, NDD D: means Norton Disk Doctor will diagnose your 
D: drive based upon the options you select.

The Norton Disk Doctor main dialog box appears. 

5 Select an option and follow the on-screen instructions.

6 Remove Emergency Disk 1 from the startup drive and restart your 
computer.

7 Check the disk.

Scenario 10: Recovering lost or damaged directories

You try to locate a directory (containing files) but cannot, or you suddenly 
have a new directory with garbage text as the directory name.

To recover lost or damaged directories with Norton Disk Doctor and 
basic Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose Disk Doctor from the menu.

4 At the prompt, type NDD [drive:] /C and press Enter.

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove the disk from the startup drive and restart your computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 6, 
but replace /C with /UNDO. For example, NDD D: /UNDO.

To recover lost or damaged directories with Norton Disk Doctor and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Disk Doctor.
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4 After NDD.EXE, type [drive:] /C and press Enter.

For example, NDD.EXE D: /C means Norton Disk Doctor will diagnose 
your D: drive completely.

5 When requested, insert Emergency Disk 2.

Norton Disk Doctor performs a diagnosis of the specified drive.

6 Follow the on-screen instructions to create an undo file and repair 
your disk.

Note: Do not reuse Undo disks. Overwriting the same disk means that 
previous changes cannot be undone.

7 Remove the disk from the startup drive and restart your computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 4, 
but replace /C with /UNDO. For example, NDD D: /UNDO.

Scenario 11: Recovering overwritten files

Caution: Do not start Windows. Starting Windows writes to your hard 
drive. The Windows swap file could overwrite data you would like to 
recover.

You saved a file using the same name as an old file, and now you realize 
you need the old file’s data. However, all you can access is the new file’s 
data.

Fortunately, Windows writes new files using the same name as the deleted 
file to another area of the disk (if the disk has enough room). Because of 
this, the clusters for the original file probably have not been overwritten 
and are recoverable. However, the file’s type may make a big difference in 
how successful the recovery actually is. 

For example, you can recover a text-based file easier than a graphics file. A 
text editor or word processor can use the recovered data from a text file 
“as is.” Typically, a graphics file must be recovered completely to allow the 
program in which the graphics file was created to read the file. 
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To recover overwritten files with UnErase and basic Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose UnErase from the menu.

4 At the DOS prompt, type UNERASE.EXE [path] and press Enter. 

For example, UNERASE.EXE C:\MYDOCU~1. Include all the folders up 
to the file, but do not include the name of the file.

Note: You must use short filenames with DOS.

UnErase checks your hard drive for the file. The Erased Files dialog 
box appears with the files that were erased from the directory you 
specified.

5 Use the UpArrow and DownArrow keys to select the file to recover 
and press Alt+U.

The UnErase dialog box appears asking you to supply a new first letter 
for the file.

6 Type the new first letter.

If UnErase can recover the file, RECOVERED appears in the Prognosis 
column.

7 If UnErase is unable to recover the file automatically, press Alt+M to try 
to recover the file manually.

8 Type a new first letter for the filename and press Enter.

The Manual UnErase dialog box appears.

9 Press Alt+A to add clusters.

In the Add Clusters dialog box, you can select from a variety of 
options. See online help for an explanation of the options available.

10 To browse all clusters, press Alt+B.

The View File dialog box appears with the number of the current 
cluster at the top.

11 Use Alt+P and Alt+N to view clusters.

12 Press Alt+A to add a cluster.

Repeat steps 12, 13, and 14 until you have added all the clusters that 
make up the file.
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13 Press Alt+D when finished.

The added clusters appear in the Added Clusters box of the Manual 
UnErase dialog box.

14 Press Alt+S to save the file.

The file is now recovered to its original directory. Use the program that 
created the file to verify the data.

To recover overwritten files with UnErase and Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select UnErase.

4 At the prompt, and after UnErase, type [path] and press Enter. 

For example, UNERASE C:\MYDOCU~1. Do not include the name of 
the file.

Note: You must use short filenames with DOS.

5 When prompted, insert Emergency Disk 2 and press Enter.

UnErase checks your hard drive for the file. The Erased Files dialog 
box appears with the files that were erased from that directory. 

6 Use the UpArrow and DownArrow keys to select the file to recover 
and press Alt+U.

If UnErase can recover the file, RECOVERED appears in the Prognosis 
column.

7 If UnErase is unable to recover the file automatically, press Alt+M to try 
to recover the file manually.

8 Type a new first letter for the filename and press Enter.

The Manual UnErase dialog box appears.

9 Press Alt+A to add clusters.

In the Add Clusters dialog box, you can select from a variety of 
options. For additional information about each option, press F1.

10 To browse all clusters, press Alt+B.

The View File dialog box appears with the number of the current 
cluster at the top.

11 Use Alt+P and Alt+N to view clusters.
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12 Press Alt+A to add a cluster.

Repeat steps 10, 11, and 12 until you have added all the clusters that 
make up the file.

13 Press Alt+D when finished.

14 Press Alt+S to save the file.

The file is now recovered to its original directory. Use the program that 
created the file to verify the data.

Scenario 12: Recovering corrupt Registry files

While starting your computer, you receive a message similar to one of the 
following:

� Registry access error

� Warning: Windows has detected a Registry or configuration error

Windows stores a backup of the Registry files each time you successfully 
start your system, so first try to have Windows restore the files by selecting 
the Restore From Backup And Restart button on the error message dialog 
box. If this procedure fails to resolve the problem, restore the Registry data 
from your Registry backup, usually found in C:\WINDOWS\SYSTEM.RSC 
and C:\WINDOWS\USER.RSC.

Note: When restoring the Registry, always restore both of the Registry files: 
SYSTEM.DAT and USER.DAT.

There may be several backups of the SYSTEM and USER files, with 
extension such as .NS0, .NS1, .SW0 or .NU0. Try all of these, in the order of 
newest to oldest.

Warning: There is a potential for data loss when you restore the registry. 
You may lose settings for programs that have been installed, and program 
options that have been saved since the backup of the registry was made.
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To recover corrupt Registry files with the Windows 95/98 Registry 
backup:

Try to restore the Windows Registry with a backup copy Windows made of 
the Registry the last time you successfully started your computer.

1 Start or restart your computer.

2 While “Starting Windows...” is on your screen, press and release the F8 
key. 

Alternately, you can hold the Ctrl key down while your computer 
starts.

3 Choose the Command Prompt Only option.

4 At the command prompt, change to the directory where Windows is 
installed (usually C:\WINDOWS). 

For example, type:
C: and press Enter. Then type: 
CD \WINDOWS and press Enter.

5 Type the following commands and press Enter after each one: 
(SYSTEM.DA0 and USER.DA0 contain zeroes.)

attrib -h -r -s system.dat

attrib -h -r -s system.da0

attrib -h -r -s user.dat

attrib -h -r -s user.da0

6 Rename system.dat and user.dat to system.bak and user.bak. Type the 
following commands and press Enter after each one:

ren system.dat system.bak 
ren user.dat user.bak

7 Then type the following commands and press Enter after each one:

copy system.da0 system.dat
copy user.da0 user.dat

8 Restart your computer.

To recover corrupt Registry files with Rescue Disks:

If you are unable to restore the Registry files with the Windows 95/98 
Registry backup, try this using your Rescue Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Press Esc to go to the DOS command prompt.
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4 Change directories to C:\WINDOWS (or to the directory where 
Windows is installed). 

For example, if Windows is in C:\WINDOWS, type:

C: and press Enter. Then type: 

CD \WINDOWS and press Enter.

5 Type the following commands and press Enter after each one:

command\attrib -h -r -s system.dat

command\attrib -h -r -s user.dat

6 Rename system.dat and user.dat to system.bak and user.bak. Type the 
following commands and press Enter after each one:

ren system.dat system.bak 
ren user.dat user.bak

7 Type the following commands and press Enter after each one:

copy system.rsc system.dat
copy user.rsc user.dat

8 Remove the Rescue Disk from the floppy drive and restart your 
computer.

If you cannot recover corrupt Registry files

If the problem persists, reinstall Windows to recreate your Windows 95/98 
Registry files.

Scenario 13: Recovering an inaccessible disk

A disk is damaged so badly that DOS or Windows cannot read the disk. 
Typical error messages include:

� Sector not found

� Seek error

If you have this problem with a floppy disk, refer to “Scenario 6: Accessing 
data on a damaged floppy disk” on page 68.

Tip: Extracting data from a disk can be time consuming. Try to recover 
only files you have not backed up or do not have copies of elsewhere.
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To recover an inaccessible disk with Norton Disk Doctor and Rescue 
Disks:

1 Insert the Basic Rescue Boot Floppy Disk into the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Choose Disk Doctor from the menu.

4 At the prompt, type NDD [drive:] /C and press Enter.

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely. 

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove the Rescue Disk from the startup drive and restart your 
computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 4 
but replace /C with /UNDO (for example, NDD D:/UNDO). 

To recover an inaccessible disk with Norton Disk Doctor and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Norton Disk Doctor.

4 At the prompt, type [drive:] /C and press Enter. 

For example, NDD D: /C means Norton Disk Doctor will diagnose 
your D: drive completely. 

Norton Disk Doctor performs a diagnosis of the specified drive.

5 Follow the on-screen instructions to create an undo file and repair 
your disk.

6 Remove Emergency Disk 1 from the startup drive and restart your 
computer.

If the contents of the drive still appear incorrect, repeat steps 1 through 4 
but replace /C with /UNDO (for example, NDD D:/UNDO). 
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Advanced procedures

Disk Editor (DISKEDIT.EXE) is a full-featured, sector-editing tool capable 
of accessing virtually any area of a hard or floppy disk. You can edit files 
and directories, the partition table, the boot record, and the file allocation 
tables (FATs) on most hard drives. You can treat any group of clusters or 
sectors as an object to view and edit.

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Caution: This section assumes that you are knowledgeable about the 
logical structure of disks. You must understand what you are doing before 
you edit any area of a disk. Otherwise, you could make the data on the 
disk inaccessible. 

To use Disk Editor, you should have Norton Utilities installed. If not, use 
Disk Editor from your Rescue Disks or from your Emergency Disks.

Starting Disk Editor 

Disk Editor always starts in read-only mode. To be able to write changes to 
your disk or file, do one of the following:

� Start Disk Editor from Windows, choose Configuration from the Tools 
menu, and clear the Read Only check box. 

� Start Disk Editor from the DOS command line and type:
DISKEDIT /W and press Enter.

When the Volume Lock message appears, press Enter.

The following procedures offer various ways of starting Disk Editor.

To start Disk Editor from the Norton Utilities directory:

1 Change to the Norton Utilities directory.

2 Double-click DISKEDIT.EXE.

To start Disk Editor using basic Rescue Disks: 

1 Insert the Basic Rescue Boot Floppy Disk in the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Press Esc to go to the DOS command prompt.
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4 Remove the Basic Rescue Boot Floppy Disk.

5 Insert the NU Emergency Utilities Disk 1, which contains the 
DISKEDIT.EXE file, into the startup drive.

6 At the command prompt, type DISKEDIT and press Enter.

To start Disk Editor using Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Disk Editor.

DISKEDIT appears in the command line. 

4 Press Enter.

Scenario 14: Recovering an unbootable hard drive

You may not be able to start up from a hard drive for two major reasons. 
The first reason is the absence or corruption of the two hidden system files 
(IO.SYS and MSDOS.SYS for MS-DOS) or the absence or corruption of 
COMMAND.COM, the default command processor. If you have been using 
a third-party replacement—such as NDOS.COM, 4NT.EXE, or 
4DOS.COM—for COMMAND.COM, corruption or absence of those files 
also can cause startup problems.

The second reason is when the value of the partition table field called Boot 
is modified to “NO.” This tells Windows that a partition is not a startup 
partition, even if the partition actually is. Disk Editor can edit the partition 
table to mark a partition as the startup partition.

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

To recover an unbootable hard drive with Disk Editor and 
Rescue Disks: 

1 Insert the Basic Rescue Boot Floppy Disk in the startup drive.

2 Turn on your computer and wait for the Rescue Disk screen to appear. 

3 Press Esc to go to the DOS command prompt.

4 Remove the Basic Rescue Boot Floppy Disk.
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5 Insert the NU Emergency Utilities Disk 1, which contains the 
DISKEDIT.EXE file, into the startup drive.

6 At the command prompt, type DISKEDIT /W and press Enter.

The Volume Lock message appears.

7 Press Enter.

8 Choose Drive from the Object menu. 

The Select The Disk You Wish To Edit dialog box appears.

9 Select the disk with the partition you want to mark as the startup 
partition and press Enter.

The Volume Unlock message appears.

10 Press Enter.

Disk Editor scans the disk.

11 Choose Partition Table from the Object menu. 

12 Press Y to toggle the value in the Boot column to Yes.

13 Choose Write Changes from the Edit menu.

The Write Changes dialog box appears.

14 Select Write to write the change.

15 Choose Exit from the Object menu to quit Disk Editor.

To recover an unbootable hard drive with Disk Editor and 
Emergency Disks: 

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Disk Editor.

4 At the prompt, type /W and press Enter.

5 When prompted, insert Emergency Disk 2 and press Enter.

6 Choose Drive from the Object menu. 

The Select The Disk You Wish To Edit dialog box appears.

7 Select the disk with the partition you want to mark as the startup 
partition and press Enter.

8 Choose Partition Table from the Object menu. 

9 Press Y to toggle the value in the Boot column to Yes.
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10 Choose Write Changes from the Edit menu.

The Write Changes dialog box appears.

11 Select Write to write the change.

12 Choose Exit from the Object menu to quit Disk Editor.

13 Restart your computer.

Scenario 15: Recovering lost subdirectories from a corrupt 
directory

Caution: This section assumes that you are knowledgeable about the inner 
workings of disks. You must understand what you are doing before you 
edit any area of a disk. Otherwise, you could make the data on the disk 
inaccessible. 

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Directories are special kinds of files that contain file and directory 
information. These special files can become corrupted and unreadable if 
the cluster they reside in is damaged. 

When a directory is unreadable, the files and directories it contains are 
inaccessible. Norton Disk Doctor considers them lost clusters instead of the 
files and directories they actually are.

The Sample directory structure below shows a directory structure before 
one of its directories, REPORT, becomes unreadable. 
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Sample directory structure

Assume the cluster the REPORT directory occupies is physically damaged 
and is no longer readable. All directories and files contained in REPORT 
are inaccessible. Disk Editor can link the lost directories back to the root 
directory, as shown in the Repaired directory structure.
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Repaired directory structure

To recover subdirectories from a corrupt directory:

Track information on paper as you complete the following procedures by 
creating three columns. Label them:

� Corrupt directory cluster number

� Good sectors

� Lost directories

To recover subdirectories from a corrupt directory, follow these 
procedures:

1 “To locate the cluster for the corrupt directory:” on page 87.

2 “To find all of the readable sectors:” on page 87.

3 “To copy the good entries to the root directory:” on page 88.

4 “To find lost directories:” on page 88.

5 “To link the lost directories to the root directory:” on page 89.

6 “To adjust the parent directory pointers within each recovered 
directory:” on page 90.
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To locate the cluster for the corrupt directory:

1 Start Disk Editor.

For instructions on starting Disk Editor, refer to “Starting Disk Editor” 
on page 81.

2 Choose Drive from the Object menu.

The Select The Disk You Wish To Edit dialog box appears.

3 Select the drive with the corrupt directory and press Enter.

Disk Editor scans the disk.

4 Choose Directory from the Object menu.

The Change Directory dialog box appears.

5 Select the parent of the corrupt directory and press Enter. 

The Disk Editor screen displays the contents of the directory in the 
Directory View. (Under Scenario 15, Sample directory structure, the 
parent of the REPORT directory is the root directory.)

6 Select the corrupt directory and press Enter.

In most cases, you get read errors immediately after you press Enter. 
Usually only one or two sectors that make up the cluster are damaged, 
letting you read the remaining good sectors. The good sectors cut 
down your workload, since you can copy the data within them to the 
root directory. To re-create the data in the corrupt sectors, see “To find 
lost directories:” on page 88.

7 Record the number shown in the Cluster field for the corrupt 
directory’s entry on the piece of paper in the “Corrupt directory cluster 
number” column. 

Disk Editor tries to read the cluster the corrupt directory occupies. 

To find all of the readable sectors:

1 If you immediately get a read error from Disk Editor, press Enter to 
clear the message. 

2 Press PageDown to read the next sector of the cluster. 

3 Record the good sector number on the piece of paper in the “Good 
sectors” column. 

The current sector number is displayed at the beginning of each sector 
in logical mode.
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4 Continue pressing PageDown until you reach the end of the cluster or 
cannot advance past the read errors.

Using the good sector numbers, you can relocate the valid entries to the 
root directory.

To copy the good entries to the root directory:

1 Choose Sector from the Object menu. 

2 The Select Sector Range dialog box appears.

3 Type the first sector number from your “Good sectors” list into both 
the Starting Sector and Ending Sector text boxes and press Enter. 

Disk Editor displays the sector in Directory View.

4 Choose As Directory from the View menu.

5 Choose Mark from the Edit menu.

6 Select all the valid entries and exclude entries labeled “Unused 
Directory Entry.”

7 Choose Copy from the Edit menu to copy the selected entries to the 
Disk Editor Clipboard.

8 Choose Directory from the Object menu.

The Change Directory dialog box appears. 

9 Press Enter to select the root directory.

Disk Editor displays the root directory in Directory View.

10 Select the first entry labeled “Unused Directory Entry.”

11 Choose Paste Over from the Edit menu to append the directory entries 
from the Clipboard to the root directory. 

12 Choose Write Changes from the Edit menu.

13 Repeat the above procedure for all the sectors you recorded.

To find lost directories:

1 Choose Cluster from the Object menu. 

The Select Cluster Range dialog box appears.

2 Type 2 in the Starting Cluster text box and press Enter.

3 Choose Find Object from the Tools menu and choose Subdirectory 
from the submenu.

Disk Editor searches for the cluster string.
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4 When Disk Editor finds the search string, choose As Directory from the 
View menu.

5 Do one of the following:

� If the screen does not resemble the contents of a directory, choose 
Find Again from the Tools menu until the information on the screen 
does resemble a directory. 

� If the screen does resemble a directory, look at the number in the 
Cluster field for the “. . ” (two periods followed by six spaces) 
entry. If this number is the same as the number you recorded for 
the “Corrupt directory cluster number,” record the number next to 
the Cluster label on the status line on the piece of paper in the 
“Lost directories” column. 

6 Choose Find Again from the Tools menu and repeat step 5 to search 
for additional lost directories until you locate all the top-level child 
directories you want to recover.

To link the lost directories to the root directory:

1 Choose Directory from the Object menu.

The Change Directory dialog box appears.

2 Select the root directory and press Enter.

Disk Editor displays the root directory in Directory View. 

3 Select the first entry labeled “Unused Directory Entry.”

4 Type a unique name for the current top-level directory in the Name 
field. 

5 Type 0 in the Size field. 

6 Type the current date and time in the Date and Time fields.

7 In the Cluster field, type the cluster number for the lost directory you 
are currently working with from the “Lost directory” column.

8 With the cursor in the “D” column, press the space bar to toggle the 
directory attribute on.

9 Repeat the above procedure for all of the lost directories in the “Lost 
directories” column. 

10 Choose Write Changes from the Edit menu and press Enter.

The Write Changes dialog box appears.

11 Select Write to write the change.

You have recovered the directories.
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To adjust the parent directory pointers within each recovered 
directory:

1 Select one of the recovered directory entries and press Enter.

You should see the contents of the directory with the first two entries 
being “.” and “..”. 

2 Type 0 in the Cluster field for the “..” entry.

3 Choose Write Changes from the Edit menu and press Enter.

The Write Changes dialog box appears.

4 Press Enter to write the change.

5 Select the “..” entry once again and press Enter. 

This confirms the link by returning you to the root directory and puts 
you where you need to be for the next recovered directory.

6 Repeat the above procedure for each of the recovered directories. 

Use Norton Disk Doctor to clean up any lost clusters left on your disk. If 
you save the lost clusters as files, you can examine these files and recover 
any additional lost files. Simply rename the files you want and delete the 
rest. Norton Disk Doctor uses the file naming scheme FILE0000._DD, 
FILE0001._DD, and so on for the filenames representing lost clusters.

Now that you have recovered the directories, re-create the directory they 
originally resided in and move them back. You do not have to worry about 
the directory being re-created in the same spot. Thanks to Norton Disk 
Doctor, Windows avoids the bad area on the disk.

Scenario 16: Lifting data from a corrupt or physically 
damaged hard drive

Caution: A special procedure is required if your computer uses a Dynamic 
Drive Overlay. See the Caution on page 50.

Caution: This section assumes that you are knowledgeable about the inner 
workings of disks. You must understand what you are doing before you 
edit any area of a disk. Otherwise, you could make the data on the disk 
inaccessible. 

Extracting data from a disk is a time-consuming process, so you should 
only try to recover files that you have not backed up or do not have copies 
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of elsewhere. Reinstall any program files from their original disks rather 
than trying to recover them with Disk Editor from a corrupt hard drive.

Tip: Symantec provides data recovery in the United States and Canada for 
PC and Macintosh hard drives that are not physically damaged. If you want 
highly-trained and dedicated professionals to recover your data, contact the 
Symantec Data Recovery Team at http://www.symantec.com/techsupp/
recovery/. Or, call our Fax-on-Demand system at (541) 984-2490 and 
request document #4132.

Neither Windows nor Norton Disk Doctor can access a corrupt disk. 
However, Disk Editor can access most bad disks and let you “lift” the data 
they contain. 

There are two classes of bad disk problems: 

� Logical problems

Involve write errors that result in scrambled data on the disk. 
Fortunately, Norton Disk Doctor fixes most of these problems for you 
automatically. 

� Physical problems

Usually involve physically damaged sectors in the partition table, boot 
record, the first copy of the file allocation table (FAT), any combination 
of these system areas, or even the entire disk. When sectors in the 
system areas become physically damaged, Windows cannot access the 
disk normally. Since even Norton Disk Doctor usually cannot repair 
physically damaged sectors, you may never gain normal access to a 
disk with damaged sectors in the system area unless you perform a 
low-level format. However, traditional low-level formatters for older 
hard drives destroy the existing data and do not work with today’s 
sector-translating IDE, SCSI, and ESDI hard drives. If the disk is 
physically damaged it will need to be repaired by a qualified service 
center.

Note: Error 129 indicates that a disk is physically damaged and that no 
recovery is possible using Norton Utilities.

Disk Editor classifies a disk as either a logical or a physical disk. If a disk 
can be accessed as a logical disk, Disk Editor uses clusters, usually 
composed of four or more sectors, as the smallest data allocation unit. This 
makes manual recovery easier. Disk Editor treats severely damaged disks 
as physical disks automatically.
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Disk Editor lets you access data around the damaged areas, cluster by 
cluster, file by file. This way, you can recover critical data files that you 
have not backed up and cannot afford to do without.

To lift data from a corrupt or physically damaged hard drive:

1 See “To determine whether Disk Editor is accessing your disk as a 
logical or physical disk:” on page 92.

2 See “To extract data from a logical disk:” on page 93.

3 See “To extract clusters from a physical disk:” on page 94.

4 See “To find the rest of the clusters:” on page 97.

Once you fix the problem, make sure that a virus is not causing the 
problem.

To determine whether Disk Editor is accessing your disk as a logical 
or physical disk:

Disk Editor estimates the correct values of your disk’s physical and logical 
parameters. The number of sides, cylinders, sectors, and so on are inserted 
into the appropriate fields of the Advanced Recovery Mode dialog box 
automatically and used to treat the disk as a logical disk. 

If the disk’s parameters are incorrect, the resulting logical disk may have 
structural problems. If you consistently run into problems accessing the 
disk, re-enter the disk’s physical and logical parameters into the Advanced 
Recovery Mode dialog box. For example, if you select the first copy of the 
FAT but do not see it, the number of total sectors may be incorrect.

1 Start Disk Editor.

For instructions on starting Disk Editor, refer to “Starting Disk Editor” 
on page 81.

2 Choose Drive from the Object menu. 

The Select The Disk You Wish To Edit dialog box appears.

3 Select Logical Disks from the Type box. 

4 Do one of the following:

� If the bad disk can be accessed as a logical disk, you should see the 
disk listed in the drives list box. Skip to “To extract data from a 
logical disk:” on page 93. 

� If the bad disk is not listed in the drives list box, continue with the 
next step.
92



DOS procedures
5 Choose Advanced Recovery Mode from the Tools menu.

The Advanced Recovery dialog box appears.

6 Press Alt+R. 

The Select The Disk You Wish To Review dialog box appears.

7 Select the bad disk and press Enter.

The Advanced Recovery dialog box reappears.

8 Press Alt+V. 

Disk Editor rescans the disk as a logical disk. When complete, you 
should see the root directory of the disk in Directory View.

Caution: If you cannot see the root directory of the disk in Directory View, 
do not continue. The following procedures will not work.

To extract data from a logical disk:

If Disk Editor can access your bad disk as a logical disk directly or by using 
Advanced Recovery Mode, use the following procedure. To recover a file, 
you must find, select, and write it out to another disk.

1 Choose Directory from the Object menu.

The Change Directory dialog box appears.

2 Select the directory that contains the file you want to recover and press 
Enter.

The directory listing appears in Directory View.

3 Find the file in the directory listing:

� If the file exists, you can write the file out as described in 
step 4. 

� If the file does not exist in this directory, try looking in other 
directories.

4 Select the name of the file you want to recover and press Enter. 

The contents of the file appear in Hex View.

5 Choose Write Object To from the Tools menu.

The Write dialog box appears.

6 Select To A File and press Enter.

The Save dialog box appears.
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7 Remove your disk from the drive and insert the disk you want to write 
to.

8 Type a drive letter followed by a filename in the text box and press 
Enter.

A confirmation box appears asking if you want to write the file out.

9 Select Yes to continue.

A “Copying…” progress box appears for the duration of the copy 
function.

Perform this procedure again for each of the files you want to recover.

To extract clusters from a physical disk:

When Disk Editor cannot access the disk as a logical disk, you can still lift 
individual clusters, starting with the first cluster of the file. This is possible 
since the Virtualize command button in the Advanced Recovery Mode 
dialog box lets Disk Editor work with clusters instead of sectors. 

To extract clusters from a physical disk, try each of the following methods 
in the order listed:

1 “Method 1: To find the starting cluster by searching for the filename:” 
on page 94.

2 “Method 2: To find the starting cluster by browsing all directories:” on 
page 95.

3 “Method 3: To search for unique text in the file:” on page 96.

Method 1: To find the starting cluster by searching for the filename:

When the directory structure of a disk is still intact, you can find the 
starting cluster number by searching the disk for the directory entry of the 
file, which contains the starting cluster number.

1 Choose Cluster from the Object menu.

The Select Cluster Range dialog box appears.

2 Type 2 in the Starting Cluster text box and press Enter.

3 Choose Find from the Tools menu. 

The Enter Search Text dialog box appears.

4 Type the filename in the ASCII text box and press Enter. 

Do not type the filename in the format you are used to. Instead, type 
the filename followed by enough spaces to make eight characters. 
Then, type the file extension as the next three characters. Do not put a 
94



DOS procedures
period between the name and the extension. For example, type 
NAME.EXT as:

NAME****EXT (do not type the asterisks)

There are four spaces between NAME and EXT because NAME has 
four characters already. The Search Progress dialog box appears. Disk 
Editor finds the search string, selects it, and displays it in Hex View.

5 Choose As Directory from the View menu to switch to Directory View. 

6 Do one of the following:

� If the data you see appears to be a directory, record the filename, 
starting cluster number, and the file size of the file from those fields 
on a piece of paper labeled “Files To Recover.” 

The starting cluster number is the number in the Cluster field on 
the same line as the filename.

� If the data contains unrecognizable characters, such as happy faces, 
hearts, and other non-standard characters, search for another 
occurrence of the filename by choosing Find Again from the Tools 
menu.

7 Find and record the starting cluster numbers and file sizes for all the 
files you want to recover. Then find the rest of the clusters for each file 
as described in “To find the rest of the clusters:” on page 97.

Method 2: To find the starting cluster by browsing all directories:

You can locate the file you want to recover by browsing through all 
directories on the disk. To locate all directories on the disk except the root 
directory, search for “..      ” (two periods followed by six spaces). Every 
directory other than the root has “..      ” as its second entry. As you find 
each directory, scan the directory listing for the file you want to recover.

1 Choose Cluster from the Object menu.

The Select Cluster Range dialog box appears.

2 Type 2 in the Starting Cluster text box and press Enter.

3 Choose Find Object from the Tools menu.

4 Choose Subdirectory from the submenu.

The Search Progress dialog box appears.

5 Once the search completes, choose As Directory from the View menu 
to switch to Directory View.
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6 Do one of the following:

� If the display is a directory and the file you want to recover is 
listed, record the name, starting cluster number, and size of that file 
on a piece of paper labeled “Files To Recover.”

� If the display is not a directory or you cannot locate the file you 
want to recover, choose Find Again from the Tools menu to 
continue searching for more directories.

If this method is unsuccessful, try method three below, which searches for 
a unique text string that appears in the starting cluster of the file. 

Method 3: To search for unique text in the file:

When the directory structure is damaged, the best way to find the starting 
cluster is to search for embedded text in the starting cluster.

Tip: This method works best for text files such as word processing files.

1 Choose Cluster from the Object menu. 

The Select Cluster Range dialog box appears.

2 Type 2 in the Starting Cluster text box and press Enter.

3 Choose Find from the Tools menu.

The Enter Text To Search For dialog box appears.

4 Type a unique string that appears at the beginning of the file in the 
ASCII text box and select Find to begin the search. 

For example, if you are looking for a word processor file with the title 
“Year End Report,” type the string “Year End Report” in the text box. 

If found, Disk Editor displays the search string in Hex View.

5 Choose As Text from the View menu to switch to Text View. 

6 Do one of the following:

� If the cluster that contains the string appears to be the first cluster in 
the file, record the starting cluster’s number and a name for the file 
on a piece of paper labeled “Files To Recover.” Mark the number 
and name as the starting cluster. 

� If the cluster that contains the string belongs to the file but does not 
appear to be the first cluster, record the cluster number on the same 
piece of paper next to the filename. Do not mark the number as the 
starting cluster. 
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� If the cluster with the search string does not belong to the file you 
are looking for, choose Find Again from the Tools menu to 
continue the search. If you have not found any clusters from your 
file, try searching for a different text string.

To find the rest of the clusters:

Now that you have found the starting cluster, you need to find the rest of 
the clusters in the file. If you found the starting cluster, the filename, and 
the file size using method one or method two in “To extract clusters from a 
physical disk:” on page 94, use method one of this section. Otherwise, use 
method two of this section. 

1 “Method 1: To find the rest of the clusters with the file size:” on 
page 97.

2 “Method 2: To find the rest of the clusters without the file size:” on 
page 99.

Method 1: To find the rest of the clusters with the file size:

With the file size, you can calculate the number of clusters the file contains. 
Then you can locate and record the individual clusters that you later write 
out to a file.

1 Choose Drive Info from the Info menu.

The Drive Info dialog box appears.

2 Multiply the values for Bytes Per Sector and Sectors Per Cluster. 

The result is the size of each cluster in bytes.

3 Divide the file size by the cluster size.

4 Round off the value to the next integer value. 

For example, if the file size is 100,000 bytes and your disk’s cluster size 
is 8196 bytes, the file has thirteen clusters (12.2 rounded up to 13).
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5 Choose 1st Fat from the Object menu.

If you cannot find the FAT or if it is very corrupt, continue to the next 
step.

6 Use the PageDown and Tab keys until the Cluster label on the status 
line matches the starting cluster number of the file you want to 
recover.

When you find the starting cluster, its position on the screen (not Disk 
Editor’s status line) should display <EOF>, which marks the last cluster 
in the file or the number for the next cluster. If it is marked <EOF>, 
you have found the first and last cluster of the file. You can write the 
cluster to disk as described below.

7 If it has the cluster number of the next cluster in the file, use the 
PageDown and Tab keys to move to that cluster and select it.

Remember to use the Cluster label on the status line as the cluster 
number reference.

8 Record the number indicated by the Cluster label on the status line 
next to the filename on your “Files To Recover” list. 

Unless the file is composed of multiple cluster chains, the next cluster 
is usually immediately to the right of the current cluster. If this cluster 
position is marked with <EOF>, it is the last cluster of the file. You can 
write the cluster to disk as described in Step 15 on page 100.

9 Continue finding and recording clusters for the file until you find the 
<EOF> marker.
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10 Compare the number of clusters you recorded from the FAT with the 
number you calculated earlier (by dividing the file size by the cluster 
size). 

� If they are not the same, double-check your calculations or try this 
procedure again. 

� If they are the same, you can write the clusters to disk by choosing 
Cluster from the Object menu.

Method 2: To find the rest of the clusters without the file size:

Unless the disk is very fragmented, the rest of the clusters of the file should 
be near and after the starting cluster. Locate the rest of the file by browsing 
near the starting cluster or search for text that appeared somewhere after 
the starting cluster.

Tip: This procedure works best for text files.

1 Choose Cluster from the Object menu. 

The Select Cluster Range dialog box appears.

2 Type the starting cluster number from your “Files To Recover” list in 
the Starting Cluster text box and press Enter.

Disk Editor displays the contents of the starting cluster in Hex View.

3 Choose As Text from the View menu.

4 Scroll to the next cluster using the PageDown and DownArrow keys.

The cluster markers on the screen (not on the status line) differentiate 
cluster numbers. 

5 When you find a cluster belonging to the file, record the cluster 
number displayed next to the Cluster label on the status line on your 
“Files To Recover” list. 

Record the number next to the name of the file to which the cluster 
belongs.

6 Using the data in the newest cluster to figure out what should be in the 
next cluster, continue browsing for clusters until you have found the 
expected number of clusters for the original file.
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7 Do one of the following:

� If you have found all the clusters from the original file, skip to 
step 15.

� If you could not locate additional clusters near the starting cluster, 
continue to the next step.

8 Press the Home key once.

Disk Editor returns to the starting cluster. 

9 Choose Find from the Tools menu. 

The Enter Search Text dialog box appears.

10 Type the text to search for in the ASCII text box and select Find to 
begin the search.

11 When the search string is found, record the cluster number that 
contains the search string if the number belongs to the file on your 
“Files To Recover” list. 

Record the number next to the name of the file to which the cluster 
belongs. 

12 Start a new search for text you expect to be in the next cluster or 
manually browse the next several clusters for the next cluster using the 
PageDown and DownArrow keys.

13 If no clusters are found, choose Find from the Tools menu and type a 
new search string.

14 Continue searching until you have reached the expected end of the 
file.

15 To write the clusters to disk, choose Cluster from the Object menu.

The Select Cluster Range dialog box appears.

16 Type the starting cluster number of the first filename from your “Files 
To Recover” list into both the Starting Cluster and Ending Cluster text 
boxes and press Enter.

17 Choose Write Object To from the Tools menu.

The Write dialog box appears.

18 Select To A File and press Enter.

The Write Object To File dialog box appears.

19 Insert a blank floppy disk into either the A: or B: drive.
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20 Type the drive letter of the drive that contains the blank floppy disk, 
followed by a filename for the file created with the clusters you have 
found and press Enter. 

For example, A:MYFILE.DOC.

A confirmation dialog box appears asking if you want to write the file 
out.

21 Click Yes.

The write progress screen appears for the duration of the write 
operation.

22 Repeat steps 15 through 21 for each cluster in your “Files To Recover” 
list and when you get to step 20, use the same filename. 

This causes a message box to appear, telling you the file already exists.

23 Press Enter to append the file. 

Scenario 17: Repairing cross-linked files

You run Norton Disk Doctor or ScanDisk and two or more files are 
reported to be cross-linked. When two or more (usually only two) files are 
cross-linked, they are sharing the same cluster or chain of clusters. The 
cross-linkage can take place anywhere along the cluster chain, not just on 
the first or last cluster.

Since each cluster can only belong to one file at a time, one of the 
cross-linked files is unusable until you eliminate the cross-linkage. 
Furthermore, one of the cross-linked files is almost always the real owner 
of the cross-linked clusters. Usually, you can recover the missing clusters 
for the other file as lost clusters and link them into the correct file. 

First, you need to identify the files that are cross-linked and the clusters on 
which they are cross-linked. 

To repair cross-linked files:

1 See “To identify the cross-linked files and recover the _DD or CHK file 
with Norton Disk Doctor:” on page 102.

If you cannot access Windows or your computer will not start, see “To 
identify the cross-linked files with Norton Disk Doctor and Emergency 
Disks:” on page 103.

2 See “To examine the clusters to see where they belong:” on page 104.

3 See “To link a _DD or CHK file back to the corrupt file to which it 
belonged:” on page 105.
101



Norton Utilities emergency procedures 
To identify the cross-linked files and recover the _DD or CHK file with 
Norton Disk Doctor:

1 Open Norton Disk Doctor.

2 Check the drive to diagnose and click Diagnose. 

Caution: Follow the directions to continue. However, do not make any 
corrections to the disk.

3 When Norton Disk Doctor locates the cross-linked files, record their 
names.

4 Copy the cross-linked files to another disk. 

If a file is too big, you can copy it to another directory, though this is 
not preferred. 

5 Verify whether the files you copied (not the original file) are corrupt:

� For a data file, open it with the application that created the data file 
(or one that at least recognizes the type of data in the file).

� For a program file, try running it. 

6 Delete the cross-linked files from the original disk. 

7 Copy the good files back to the same directory of the original disk. 

8 Copy the corrupt files back to the same directory of the original disk.

9 In Norton Disk Doctor, check the drive to diagnose and click 
Diagnose. 

10 Follow the directions to continue and let Norton Disk Doctor make any 
corrections necessary to the disk.

Norton Disk Doctor saves chains of lost clusters to the root directory as 
files with _DD extensions. For example, five lost cluster chains would 
be saved as FILE0000._DD, FILE0001._DD, and so on to 
FILE0004._DD. ScanDisk uses the same naming convention as Norton 
Disk Doctor, except the extension CHK is used instead of _DD.

11 Skip to “To examine the clusters to see where they belong:” on 
page 104.
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To identify the cross-linked files with Norton Disk Doctor and 
Emergency Disks:

1 Insert Emergency Disk 1 into the startup drive.

2 Turn on your computer and wait for the Norton Utilities screen to 
appear.

3 Use the UpArrow and DownArrow keys to select Norton Disk Doctor 
and press Enter.

The Norton Disk Doctor main dialog box appears.

4 Press Enter to diagnose the disk.

The Select Drives To Diagnose dialog box appears.

5 Select the drive to diagnose and press Enter.

Caution: Follow the directions to continue. However, do not make any 
corrections to the disk.

6 When the cross-linked files are located, record their names.

7 Copy the cross-linked files to another disk. 

If a file is too big, copy it to another directory, though this is not 
preferred. 

8 Verify whether the files you copied (not the originals) are corrupt:

� For a data file, open it with the application (or one that at least 
recognizes the type of data in the file) that created the file.

� For a program file, try running it. 

9 Delete the cross-linked files from the original disk. 

10 Copy the good files back to the same directory of the original disk. 

11 Copy the corrupt files back to the same directory of the original disk. 

12 Insert Emergency Disk 1 into the startup drive.

13 Turn on your computer and wait for the Norton Utilities screen to 
appear.

14 Use the UpArrow and DownArrow keys to select Norton Disk Doctor 
and press Enter.

The Norton Disk Doctor dialog box appears.

15 Select Diagnose Disk and press Enter.

16 Check the drive to diagnose and press Enter. 
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17 Follow the directions to continue and let Norton Disk Doctor make any 
corrections necessary to the disk.

Tip: Norton Disk Doctor saves chains of lost clusters to the root 
directory as files with _DD extensions. For example, five lost cluster 
chains would be saved as FILE0000._DD, FILE0001._DD, and so on to 
FILE0004._DD. ScanDisk uses the same naming convention as Norton 
Disk Doctor, except the extension CHK is used instead of _DD.

To examine the clusters to see where they belong:

1 Start Disk Editor with the /W command-line option.

For instructions on starting Disk Editor, refer to “Starting Disk Editor” 
on page 81.

2 Choose Drive from the Object menu.

The Select The Disk You Wish To Edit dialog box appears.

3 Select the disk that contains the _DD or CHK files using the UpArrow 
and DownArrow keys and press Enter.

The root directory of the disk displays in Directory view. You may not 
see the _DD or CHK in the directory listing immediately.

4 Use the UpArrow and DownArrow keys to scroll up and down the 
listing to locate the files. (Use the PageUp and PageDown keys to 
scroll a screen at a time.)

5 Select a _DD or CHK file and press Enter. 

The contents of the file appear in Hex View. 

6 If the file is a text file, choose As Text from the View menu.

7 If you know which corrupt file the data belongs to, do one of the 
following:

� Return to the root directory by choosing Directory from the Link 
menu.

� Otherwise, select another _DD or CHK file.

8 Record the filename, file size, and starting cluster number of the _DD 
or CHK file on a piece of paper. 

The starting cluster number for each _DD or CHK file is in the Cluster 
field on the same line as the _DD or CHK filename.

9 Repeat steps 5 through 8 for each of the _DD or CHK files in your root 
directory.
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To link a _DD or CHK file back to the corrupt file to which it 
belonged:

1 Choose Directory from the Object menu.

The Change Directory dialog box appears.

2 Select the directory containing the corrupt file and press Enter.

The directory appears.

3 Select the corrupt file and press Enter.

The file is displayed in Hex View.

4 Scroll through the file until you notice a discontinuity. 

Note the cluster that the cursor is in by using the value in the status bar 
and press Enter to return to the directory. 

5 Add the size of the _DD or CHK file to the size of the corrupt file and 
type the total in the Size field for the corrupt file.

6 Press Ctrl+W to write the changes and select Write.

7 Press Ctrl+T to view the cluster chain for the file. 

8 Select the cluster noted on the status line in step 4 and note its value.

9 Type the cluster number you recorded on paper for the _DD or CHK 
file here and press Ctrl+W.

10 Make sure Synchronize FATs is checked in the dialog box and select 
Write.

11 When the Rescan dialog box appears, press Cancel.

12 Move the cursor to the cluster for the _DD or CHK file in the current 
view.

13 Use the Tab and DownArrow keys to traverse the cluster chain for this 
file until you reach <EOF>. 

14 Change <EOF> to the value noted in step 8.

15 Press Ctrl+W and press Enter.

The Rescan dialog box appears.

16 Choose Directory from the Object menu.

The Change Directory dialog box appears.

17 Select the root directory and press Enter.

18 Move to the Name field of the _DD or CHK file and press F2 to display 
the Hexadecimal view.

19 Without moving the cursor, type: E5.
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20 Press Ctrl+W to write the change and then select Write.

The files should now be fully recovered. Open Norton Disk Doctor and 
diagnose the affected drive to validate the corrections you made.
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 8
Troubleshooting

The information in this chapter will help you solve the most frequent 
problems that you may experience. If you can’t find the solution to your 
problem here, there is a wealth of information on the Symantec Web site. 
You can find a troubleshooter, updates, patches, online tutorials, 
knowledge base articles and virus removal tools. Go to 
http://service.symantec.com.

My Rescue Disk does not work

Due to the number of product-specific technologies used by manufacturers 
to configure and initialize hard drives, we cannot always create a bootable 
Rescue Disk automatically. If your Rescue Boot Disk does not work 
properly, do one of the following:

� If you have a special startup disk for your computer, add it to your 
Rescue Disk set. In an emergency, start up from that disk (first slide 
open the plastic tab on the back of the disk to make sure it is 
write-protected). Remove the disk and insert your Rescue Boot Disk. 
At the DOS prompt, type A:RSHELL, press Enter, and then follow the 
on-screen instructions. 

� Use the Disk Manager or similarly named program that came with your 
computer to make your Rescue Boot Disk bootable. Make sure to test 
your modified Rescue Boot Disk.

� If you are having trouble with a Norton Zip Rescue Disk set, check the 
TROUBLE.TXT file on the Rescue Boot Disk. At the DOS prompt, type 
A:VIEW < TROUBLE.TXT and then press Enter.

Sometimes, your Rescue Boot Disk does not work properly because you 
have more than one operating system installed, such as Windows NT and 
Windows 95. To modify the disk, do the following:

� Start up from your hard drive, insert your Rescue Boot Disk into the A: 
drive, and, from a DOS prompt, type SYS A: and press Enter. This 
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transfers the operating system to the Rescue Boot Disk. Be sure to 
retest your Rescue Disks.

Tip: See “Creating Rescue Disks” on page 25.

The alert tells me to use my Rescue Disks, but I did not 
create them

With your Norton Utilities CD you can create Emergency Disks. Although 
they are not as powerful as the Rescue Disks you create, you can use the 
Emergency Disks to recover from most common emergencies. See “To 
make Emergency Disks:” on page 9.

You can use the CD that contains Norton Utilities as an Emergency Disk if 
your computer can start up from the CD-ROM drive. See “Using the CD as 
an Emergency Disk” on page 10.

Once you have created the Emergency Disks, use them to solve the 
problem. See “DOS procedures” on page 54.

I cannot start up from my A: drive
There are three likely reasons for this:

� If your computer does not check your A: drive first on startup, you 
need to change settings, usually using your computer’s Setup program. 

Caution: Be careful when making changes using your computer’s 
Setup program. If you have never used it before, you may want to 
refer to your computer manufacturer’s documentation.

Complete these steps to change the setting: 

a Restart your computer.

A message like this appears telling you the key or keys to press to 
run SETUP:

Press <DEL> if you want to run SETUP.

b Press the key or keys to launch the Setup program.

c Set the Boot Sequence to A: C:.

Setup programs vary from one manufacturer to the next. If you 
cannot find the Boot Sequence option, use the Setup program’s 
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help system, refer to the documentation that came with your 
system, or contact your system’s manufacturer.

d Save the changes, and then exit the Setup program.

� You need to use a special Boot Disk rather than the Rescue Boot Disk. 
In this case, use the boot disk or startup disk that came with your 
computer.

� Your computer is set up with more than one operating system, such as 
Windows NT and Windows 95. For more information, see “My Rescue 
Disk does not work” on page 107.

I get an error when testing basic Rescue Disks

If you get the message "Non-system disk, replace disk and press any key" 
when testing your Rescue Disks, Rescue may not have prepared the floppy 
boot files correctly. 

To repair this without having to reformat the disk and create a new 
Rescue Disk set:

1 Remove the Rescue Disk and restart your computer.

2 Insert the Rescue Disk into the floppy drive.

3 On the Windows taskbar, click Start > Run.

4 In the Run dialog box, type:

SYS A: 

5 Click OK. 

Norton Disk Doctor, Speed Disk, or other Norton Utilities 
keep restarting 

Since Windows is a multithreading, multitasking environment, many 
applications can access the hard drive simultaneously. When an application 
writes to the hard drive, this process changes the drive's directories. Since 
some of the Norton Utilities programs, such as Norton Disk Doctor and 
Speed Disk, need up-to-date directory information, they must reread these 
structures any time another application accesses the drive. To solve this 
problem you can do one of the following:

� Close other applications that are accessing the disk.

� Start Windows without starting the applications that normally start. If 
you hold down the Shift key when you start Windows 95, Windows 98, 
or Windows Me, the normal startup programs are not started.
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Troubleshooting 
� Start Windows in Safe Mode. See Windows help to learn how to start 
your version of Windows in Safe Mode.

My drive might not be configured properly

If Norton Disk Doctor or Norton Speed Disk displays the message “Drive C: 
may not be configured properly,” there are several things you can check. 
The detailed procedures are covered in a Knowledge Base article titled 
Error: “Drive X: may not be configured properly” when running Norton 
Disk Doctor or Norton Speed Disk. You can find this article at 
http://www.symantec.com/techsupp/
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S U P P O R T
Service and support solutions

Service and support information is available from the Help system of your 
Symantec product. Click the Service and Support topic in the Help index.

Technical support
Symantec offers several technical support options:

� StandardCare support

Connect to the Symantec Service & Support Web site at 
http://service.symantec.com, then select your product and version. 
This gives you access to product knowledge bases, interactive 
troubleshooter, Frequently Asked Questions (FAQs), and more.

� PriorityCare, GoldCare, and PlatinumCare support

Fee-based telephone support services are available to all registered 
customers. For complete information, please call our automated fax 
retrieval service at (800) 554-4403 and request document 933000.

For telephone support information, connect to 
http://service.symantec.com, select your product and version, and 
click Contact Customer Support.

� Automated fax retrieval

Use your fax machine to receive general product information, fact 
sheets, and product upgrade order forms by calling (800) 554-4403. For 
technical application notes, call (541) 984-2490.
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Service and support solutions 
Support for old and discontinued versions

When a new version of this software is released, registered users will 
receive upgrade information in the mail. Telephone support will be 
provided for the old version for six months after the release of the new 
version. Technical information may still be available through the Service & 
Support Web site (http://service.symantec.com).

When Symantec announces that a product will no longer be marketed or 
sold, telephone support will be discontinued 60 days later. Support will be 
available for discontinued products from the Service & Support Web site 
only.

Customer service
Visit Symantec Customer Service online at http://www.symantec.com/
techsupp/news/custserv.html for assistance with non-technical questions 
and for information on how to do the following:

� Subscribe to the Symantec Support Solution of your choice.

� Obtain product literature or trialware.

� Locate resellers and consultants in your area.

� Replace missing or defective CD-ROMS, disks, manuals, and so on.

� Update your product registration with address or name changes.

� Get order, return, or rebate status information.

� Access customer service FAQs.

� Post a question to a Customer Service representative.

For upgrade orders, visit the online upgrade center at:
http://www.symantec.com/upgrades/ or call the Customer Service Order 
Desk at (800) 568-9501.

Worldwide service and support
Technical support and customer service solutions vary by country. For 
information on Symantec and International Partner locations outside of the 
United States, please contact one of the service and support offices listed 
below, or connect to http://www.symantec.com, select the country you 
want information about, and click Go!
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Service and support offices

North America

Argentina, Chile, and Uruguay

Asia/Pacific Rim

Brazil

Columbia, Venezuela, the Caribbean, and Latin America

Symantec Corporation
175 W. Broadway
Eugene, OR 97401

http://www.symantec.com/
(Fax: (541) 984-8020

Automated Fax Retrieval (800) 554-4403
(541) 984-2490

Symantec Region Sur
Cerrito 1054 - Piso 9
1010 Buenos Aires
Argentina

http://www.symantec.com/region/mx
+54 (11) 4315-0889
Fax: +54 (11) 4314-3434

Symantec Australia Pty. Ltd.
408 Victoria Road
Gladesville, NSW 2111
Australia

http://www.symantec.com/region/reg_ap/
+61 (2) 9850 1000
Fax: +61 (2) 9817 4550

Symantec Brazil
Av. Juruce, 302 - cj 11
São Paulo - SP
04080 011
Brazil

http://www.symantec.com/region/br/
+55 (11) 531-7577
Fax: +55 (11) 5530 8869

Symantec América Latina
2501 Colorado, Suite 300
Santa Monica, CA 90404

http://www.symantec.com/region/mx/
+1 (541) 334-6050 (U.S.A.)
Fax: (541) 984-8020 (U.S.A.)
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Service and support solutions 
Europe, Middle East, and Africa

Mexico

Virus protection subscription policy
If your Symantec product includes virus protection, you might be entitled 
to receive free virus protection updates via LiveUpdate. The length of the 
free subscription could vary by Symantec product.

When you near the end of your virus protection subscription, you will be 
prompted to subscribe when you start LiveUpdate. Simply follow the 
instructions on the screen. After your free subscription ends, you must 
renew your subscription before you can update your virus protection. 
Renewal subscriptions are available for a nominal charge.

To order a subscription, do one of the following:

� Visit our Web site at: http://www.shop.symantec.com.

� Outside the United States, contact your local Symantec office or 
representative.

Every effort has been made to ensure the accuracy of this information. 
However, the information contained herein is subject to change without 
notice. Symantec Corporation reserves the right for such change without 
prior notice.

May 2000

Symantec Customer Service Center
P.O. Box 5689
Dublin 15
Ireland

http://www.symantec.com/region/reg_eu/
+353 (1) 811 8032
Fax: +353 (1) 811 8033

Automated Fax Retrieval +31 (71) 408-3782

Symantec Mexico
Periferico Sur No. 3642, Piso 14
Col. Jardines del Pedregal
09100 Mexico, D.F.

http://www.symantec.com/region/mx
+52 (5) 661-6120; +1 (800) 711-8443
Fax: +52 (5) 661-8819
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Norton Utilities™

CD Replacement Form

FOR CD REPLACEMENT
Please send me:    ___ CD Replacement

Name ________________________________________________________________________________________________________________

Company Name _______________________________________________________________________________________________________

Street Address (No P.O. Boxes, Please)_____________________________________________________________________________________

City ______________________________________________________________________ State _______ Zip/Postal Code _________________

Country* _________________________________________________________Daytime Phone _______________________________________

Software Purchase Date _________________________________________________________________________________________________

*This offer limited to U.S., Canada, and Mexico. Outside North America, contact your local Symantec office or distributer.

Briefly describe the problem:_____________________________________________________________________________________________

______________________________________________________________________________________________________________________

FORM OF PAYMENT ** (CHECK ONE):
___  Check (Payable to Symantec)  Amount Enclosed  $ _________ __ Visa       __ Mastercard      __  American Express

Credit Card Number ___________________________________________________________________________________Expires __________

Name on Card (please print) ________________________________________________ Signature ___________________________________

**U.S. Dollars. Payment must be made in U.S. dollars drawn on a U.S. bank.

MAIL YOUR CD REPLACEMENT ORDER TO:
Symantec Corporation

Attention:  Order Processing

175 West Broadway

Eugene, OR  97401-3003    (800) 441-7234

Please allow 2-3 weeks for delivery within the U.S.

Symantec and Norton Utilities are trademarks of Symantec Corporation.
Other brands and products are trademarks of their respective holder/s.
 2000 Symantec Corporation. All rights reserved. Printed in the U.S.A.

CD REPLACEMENT: After your 60-Day Limited Warranty, if your CD becomes unusable, fill out and return 1) this form, 2) your
damaged CD, and 3) your payment (see pricing below, add sales tax if applicable), to the address below to receive replacement CD.
DURING THE 60-DAY LIMITED WARRANTY PERIOD, THIS SERVICE IS FREE.  You must be a registered customer in order to receive CD
replacements.

CD Replacement Price   $ 10.00
Sales Tax (See Table) ______
Shipping & Handling $   9.95

TOTAL DUE ______

SALES TAX TABLE: AZ (5%), CA (7.25%), CO (3%), CT (6%), DC (5.75%), FL (6%), GA (4%), IA (5%), 
IL (6.25%), IN (5%), KS (4.9%), LA (4%), MA (5%), MD (5%), ME (6%), MI (6%), MN (6.5%), MO (4.225%),
NC (6%), NJ (6%), NY (4%), OH (5%), OK (4.5%), PA (6%), SC (5%), TN (6%), TX (6.25%), VA (4.5%), WA (6.5%), 
WI (5%).  Please add local sales tax (as well as state sales tax) in AZ, CA, FL, GA, MO, NY, OH, OK, SC, TN, TX, WA, 
WI. 
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