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Introduction

What Is Drive Image Pro 3.0?

Setting up multiple PCs is a time-consuming and costly process. Long hours can be spent installing 
and configuring operating systems and software on each individual machine. IS professionals in 
both industry and education need a fast, inexpensive solution for setting up multiple workstations.

Drive Image Pro 3.0 is a complete hard-disk imaging solution for IS professionals. Unlike file-by-
file copying utilities, Drive Image Pro uses SmartSector imaging to create an exact image of a 
hard-drive or hard-drive partition. That exact image can then be used to deploy Windows 
workstations, upgrade existing workstations, manage changing desktop environments, and 
quickly and easily back up and restore hard drives. Drive Image Pro also includes PowerQuest’s 
award-winning PartitionMagic Pro, allowing IS professionals to create, resize, move, and convert 
partitions without leaving Windows.

Using SmartSector imaging and TCP/IP multicasting, an IS professional can “PowerCast” a single image 
over a network to simultaneously set up and configure multiple Windows workstations across an 
enterprise. And with Drive Image Pro’s exclusive DeltaNow, IS professionals can easily manage changing 
desktop environments and distribute individual software applications as part of the imaging process.

Drive Image Pro can easily create and store a compressed image file of an entire hard drive or 
individual partition of a hard drive on a network, Jaz, Zip, CD-ROM or other removable media 
device and apply images to drives of the same size or resized to fit drives of different size and 
geometry. Because Drive Image Pro uses SmartSector imaging, it will ensure that your Windows 
optimizations are preserved on target PCs. Drive Image Pro provides SmartSector imaging support 
for FAT, FAT32, NTFS, HPFS, and sector-by-sector support for LINUX, UNIX, and NetWare.

What’s New in 3.0?

• PowerCasting

• DeltaNow

• BootDisk Builder

• Converting Ghost Image Files

• PartitionMagic 4.0

• Restoring Individual Files and Folders with Drive Image Pro File Editor

• Improved Resize Technology
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What’s Coming Soon?

• CD-R Support

• Remote Boot

Drive Image Pro System Requirements  

IMPORTANT!  Because of operating system conflicts that can result from different hardware 
configurations, Drive Image Pro was not intended to copy or image a hard 
drive that will be used in a system with different hardware configurations.

NOTE:  You must have Windows 3.x, 95/98, or NT to run DriveMapper and MagicMover. 
Drive Image Pro File Editor requires Windows 95/98 or Windows NT.

NOTE:  DeltaNow requires the following or later versions: Windows for Workgroups 3.11,  
Windows 95, or Windows NT 3.5.

NOTE:  Any discussion of deployment, including hard-disk imaging, assumes that the 
software, including the operating system, is being copied in accordance with the 
license agreements with the software manufacturer.

Hardware/Software Minimum Recommended

Processor Intel 386SX Intel 486 or above

RAM 32 MB (16 MB required for FAT32 
or NTFS)

32 MB

3.5-inch diskette drive None 3.5-inch diskette drive

CD-ROM drive Any speed Any speed

Hard drive free space 5 MB 5 MB

Operating System Windows 3.x, 95, NT, DOS 5.0, 
OS/2*

Windows 3.x, 95, NT, DOS 5.0, 
OS/2*

Monitor VGA SVGA

Pointing Device No pointing device is required to 
operate Drive Image Pro.

Microsoft mouse (or compatible 
pointing device)

* For Windows NT and OS/2 users, Drive Image Pro must be run from a bootable floppy or from a bootable 
DOS partition on your hard drive. You can create bootable DOS diskettes using the Drive Image Pro 
installation program. For more information, see “Installing Drive Image Pro” in Chapter 1.
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Installing Drive Image Pro

You can install Drive Image Pro from any of the following operating systems:

• Windows 95/98 

• Windows NT 

• Windows 3.x

NOTE:  If you are using DOS or OS/2, you can install Drive Image Pro to a DOS boot 
diskette. See “Installing on an OS/2 or DOS Only Computer” on page 5.

To install Drive Image Pro, 

1. Insert the CD into your CD-ROM drive.

2. Start the installation program.

a. If you are using Windows 95/98 or Windows NT 4.0 and if CD auto-run is 
enabled, the installation program automatically launches when you place the 
Drive Image Pro CD in your CD-ROM drive.

b. If the CD auto-run is not enabled, insert the CD, click Star > Run > drive:\SETUP 
(where drive is the drive letter of your CD-ROM drive), then click OK.

c. If you are using Windows 3.x or Windows NT 3.51, click Run from the Program 
Manager File menu. Type drive:\SETUP (where drive is the drive letter of your 
CD-ROM drive), then click OK.

NOTE:  For Windows 3.1 or Windows 3.11, a swap file is required for installation.

If you are installing on Windows 3.x, you can select from the following options:

• Install Drive Image

• Create Diskettes

• Display Technical Support Helps
Chapter 1:  Getting Started



             
If you are installing on Windows 95/98 or Windows NT, you can select from the 
following:

• Install Drive Image

• Create Rescue Diskettes

• Documentation

• Install Other Applications

3. Select the option you want, and follow the on-screen instructions.

Installing on an OS/2 or DOS Only Computer

Because OS/2 or DOS only computers cannot run the Windows based Install Shield, you 
can run the MAKEDISK.BAT file (found on the Drive Image Pro CD in the 
SETUP\OS2DOS directory) to install Drive Image Pro on OS/2 or DOS only systems.

This batch file creates two diskettes. The first diskette is a DOS boot diskette. It also 
contains the removable media device drivers. The second diskette contains the Drive 
Image Pro program.

Installing Removable Device Drivers

During Setup, Drive Image Pro allows you to install drivers for Iomega, SyQuest, and 
Fujitsu removable media storage devices.

• To install Iomega drivers, select Iomega drivers during installation.

• To install SyQuest drivers, select SyQuest drivers and the required driver type (EIDE, 
SCSI, IEPP, or SEPP).

• To install Fujitsu drivers, select Fujitsu drivers and then the required drive type 
(ATAPI or SCSI).

For specific information on individual device drivers, contact your manufacturer directly. 
See “Hard Drive Manufacturers” in Appendix E. For more information on setting up 
Iomega, SyQuest, and Fujitsu drivers, see “Setting Up Removable Storage Devices” in 
Appendix C.
Installing on an OS/2 or DOS Only Computer 5
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Using Parallel Port Devices with a NetWare Client
Loading a parallel port device driver with a network client installed may cause the 
system to hang. To successfully load the device driver for a parallel port drive, you must 
reboot the system without loading the network client. You can use the boot diskette set 
created by the install program to do this. For more information to resolve this problem, 
contact your network administrator.

Before Running Drive Image Pro

Before running Drive Image Pro, PowerQuest recommends that you:

• Run a disk utility such as ScanDisk or CHKDSK on each partition of the source 
drive(s) to check for file system errors.

• Verify that each FAT partition containing OS/2 extended attributes has a minimum of 
5 MB of free space within the partition if it will be resized during the restore process.

• Run CHKDSK/F if you are on a Windows NT system.

• Create rescue and DOS boot disks. See “Creating DOS Boot Disks” on page 119.

Running Drive Image Pro

You can run Drive Image Pro from a floppy diskette or from the hard drive if you booted 
in DOS or MS-DOS mode. The following two procedures describe how to run Drive 
Image Pro in interactive mode. To run Drive Image Pro from a batch file or using scripts, 
see Chapter 8.

Running Drive Image Pro from a Floppy Diskette
To run Drive Image Pro from a floppy diskette,

1. Insert a bootable diskette.

NOTE:  To create boot diskettes and a Drive Image Pro floppy, see “Installing on an 
OS/2 or DOS Only Computer” on page 5.

2. Reboot your machine.

3. After DOS loads and boots, insert the Drive Image Pro program floppy. Type 
A:\PQDI, then press <ENTER>.
Chapter 1:  Getting Started



                             
Running Drive Image Pro from a Hard Drive
To run Drive Image Pro from your hard drive,

1. If you are using Windows 95/98, click Start > Programs > PowerQuest > Drive Image 
Pro 3.0 > Drive Image 3.0.

2. If you are using Windows 3.x, open the Drive Image 3.0 Pro program group and 
double-click the Drive Image Pro 3.0 program icon.

NOTE:  If you are using Windows NT, you must boot to DOS from either a bootable 
floppy or from a bootable DOS partition on your hard drive. The Drive Image 
Pro install can create bootable DOS diskettes when run under Windows NT. 

Uninstalling Drive Image Pro

To uninstall Drive Image Pro, 

1. Launch the uninstall program.

a. If you are using Windows 95/98 or Windows NT 4.0, click Start > Programs > 
PowerQuest > Drive Image Pro 3.0 > Uninstall Drive Image Pro.

OR

Click Start > Settings > Control Panel > Add/Remove Programs>Drive Image Pro 
3.0.

b. If you are using Windows 3.x or Windows NT 3.51, double-click the Uninstall 
Drive Image icon in the Drive Image Pro 3.0 program group.

2. Follow the instructions on the screen.

Getting Online Help

Drive Image Pro includes online help to assist you in performing various tasks. The Help 
menu on the Drive Image Pro main screen gives you a brief overview of the online help 
system, lets you access the Help Index, and provides information about Drive Image Pro.
Uninstalling Drive Image Pro 7



8

Help Contents

1. Select Help > Contents to display general instructions for using Drive Image Pro Help.

2. Click Show Index to display a list of all help topics. Double-click a topic to display 
information on that subject.

NOTE:  You can also press <F1> at any time to access the Help Index.

3. Click Close to exit Help and return to the Drive Image Pro main screen.

About
Click Help > About to display Drive Image Pro’s version, copyright, and patent 
information as well as PowerQuest contact information.
Chapter 1:  Getting Started
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Image Files and Hardware Configurations

Because of operating system conflicts that can result from different hardware 
configurations, Drive Image Pro was not intended to copy or image a hard drive that will 
be used in a system with different hardware configurations.

If you create an image on one machine and you wish to restore the image on a machine 
with a different configuration (for example, a different motherboard or video card), the 
operating system may not boot correctly. Therefore, we recommend imaging and 
restoring to identical hardware configurations.

Any discussion of deployment, including hard-disk imaging, assumes that the software, 
including the operating system, is being copied in accordance with the license 
agreement with the software manufacturer.

Preparation

1. Before running Drive Image Pro, use a disk utility program such as ScanDisk or 
Norton’s Disk Doctor to identify and repair any errors on your hard drive.

NOTE:  NT users should run CHKDSK /F.

2. You may also choose to run a disk defragmenting utility to further optimize your hard 
drive.

NOTE:  If you are running under Windows 98 or Windows NT, see Microsoft 
documentation on running the Microsoft Windows 98 Preparation Tool or the 
Windows NT 4.0 System Preparation Tool. This documentation is included as 
TOOLS.PDF on the Drive Image Pro CD. To view this file, run Setup, then click 
Documentation > Preparation Tools.
Chapter 2:  Creating Image Files



Procedure

To create an image of the contents of any partition, perform the following:

1. At the Drive Image Pro main screen, click Create Image.

Drive Image Pro Main Screen

If you have only one hard drive, skip to step 4.
Procedure 11
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2. If you have more than one hard drive, select the drive that contains the partitions you 
wish to include in the image file.

A check appears to the left of the selected drive.

Select Source Drive

3. Click Next.

NOTE:  At any point prior to actual image file creation, you may click Back to return to 
the previous step and change your settings.
Chapter 2:  Creating Image Files



4. Select the source drive partition you wish to include in the image file, or click Select 
All to automatically select all partitions.

A check appears to the left of the selected partitions.

Select Source Partition

To deselect partitions, click again on a partition or click Select None to deselect all 
partitions at once.

The Total Selected field displays the disk space for all selected partitions, as well as 
the total used and free space within the partitions.

5. Click Next.
Procedure 13
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6. Type the desired path and image filename in the Image File field, for example: 
D:\MYIMAGE.PQI. You can also type brief comments about your image file in the 
Image File Comments field

Make sure there is no existing file with the same name, unless you want the existing 
file to be overwritten.

NOTE:  You must save your image file to a partition that you are not including in your 
image file.

Drive Image Pro uses .PQI as the default image filename extension.

Name Image File

If the drive and directory are not specified with the filename, Drive Image Pro 
automatically saves the image file to the Drive Image Pro program directory. 

You may also click Browse to browse the directory tree for your desired path or 
filename. 

You can save your image file to any physical or logical drive which has a drive letter. 
That includes floppy drives, secondary hard drives, network drives, and removable 
media storage devices such as Jaz, Zip, MO, and SyQuest drives. (For more 
information about saving image files to removable media storage devices, see 
“Scenarios” on page 19.)

7. Click Next.
Chapter 2:  Creating Image Files



8. Select the desired compression level.

• No Compression is usually the fastest method for creating an image file and is 
useful if storage space is not an issue. However, if you are saving your image file 
to a busy network drive or to a relatively slow removable media device, high 
compression may be faster than no compression since there is less data to write to 
the file. Drive Image Pro selects No Compression by default.

• Low compression offers a 40% average compression ratio.

• High compression offers a 50% average compression ratio.

Compress Image File

NOTE:  In general, compressed image files created with later versions of Drive Image Pro 
are not compatible with earlier versions. However, to create a compressed 
image in a later version that can be restored using Drive Image 1.0, specify the 
/ZLB command line switch. For more information about switches, see Chapter 8.

9. Click Next.

Drive Image Pro displays all the information you have entered to this point:

• Source Drive

• Source Partitions (partitions to be included in the image file are marked with an 
“X”)
Procedure 15
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• Image Filename

• Compression Level

Ready to Create Image File

To modify any settings, click Back.

10. Click Advanced Options to set such options as disabling file system error-checking or 
password-protecting your image file.

For information on Advanced Options settings, see “Advanced Options” on page 17.

11. Click Finish to begin creating the image file.

NOTE:  If you entered a name of a current file (step 6), Drive Image Pro displays a 
message that <path and filename> already exists. You can replace the existing 
file or choose a new filename.

If Drive Image Pro detects that you are saving your image file to a floppy drive or 
removable media, it enables a media-spanning feature that spreads the image file 
over a series of disks. You must have at least 100K of available space on each disk in 
the series. If you use the media-spanning feature, be sure to number the disks in 
order, since you must insert them in sequence when restoring the image file. For 
more information, see “Creating an Image File on a Zip Drive” on page 19. 
Chapter 2:  Creating Image Files



The Creating the Image dialog appears:

Creating the Image

Upon completion, the following message appears: “Image was copied successfully to 
file: <image filename>.“

12. Click OK to return to the Drive Image Pro main screen.

Advanced Options

The Create Image Advanced Options dialog box appears when you click Advanced 
Options at the Ready To Create Image File screen. The following options are available:
Advanced Options 17
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Create Image Advanced Options

Check for File System Errors
Clear the Check for File System Errors check box if you want to disable error checking.

If you have already used a disk utility program such as ScanDisk to check your hard drive 
for errors, it is not necessary to have Drive Image Pro check for file system errors. 
Clearing Check for File System Errors saves time in creating the image file.

If you did not run a disk utility program before loading Drive Image Pro, leave the Check 
for File System Errors check box selected.

Disable SmartSector Copying
Drive Image Pro’s SmartSector technology speeds up the imaging process by only 
copying clusters and sectors which contain data. However, in some cases, such as 
high-security environments, it may be desirable to copy all clusters and sectors in their 
original layout, whether or not they contain data.

If you wish to copy both used and unused clusters and sectors, click Disable 
SmartSector Copying. Disabling SmartSector Copying increases processing time.

Verify Disk Writes
Click Verify Disk Writes if you want to enable DOS disk write verification.

NOTE:  Disk write verification is not critical to safely create image files. Enabling disk write 
verification can slow the image file creation by as much as seven times.
Chapter 2:  Creating Image Files



ImageShield
To password-protect your image file, click Password Protect Image File and type a 
password in the Password field. To change or undo a password, use the Drive Image File 
Editor. For more information, see “Working with Passwords” on page 92.

IMPORTANT!  Note image file passwords and store them in a safe place. If you forget an 
image file’s password, you cannot restore the file.

Split Image File Into Multiple Files
Sometimes it is useful to force Drive Image Pro to split a large image file into smaller 
files. To do so, click Split Image File Into Multiple Files and enter the maximum byte size 
for each file in the File Size (bytes) field. If you wish to save the files to CDs, specify a file 
size of 650,000,000 bytes (650 MB) or less.

Scenarios

Creating an Image File on a Zip Drive

Sample System Configuration
One 1.2 GB hard drive containing:

• One active primary partition (C:) running Windows 95; 300 MB used and 500 MB 
unused.

• One extended partition containing one logical partition (D:); 400 MB used and 0 MB 
unused.

One Zip drive (E:).

Objective
Create an image file of your hard drive’s logical partition (D:) and store it on your Zip drive.

Procedure

1. When you run Setup to install Drive Image Pro on your computer, select the option to 
install Iomega drivers.
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2. Since the image file will be too large to fit on one Zip disk, you must create a series 
of Zip disks.

Label the first Zip disk as “MYIMAGE DISK #1.” During image file creation, Drive 
Image Pro prompts you to insert new media as needed. Label each successive disk 
“MYIMAGE DISK #2,” “MYIMAGE DISK #3,” etc.

3. Run ScanDisk to identify and repair any errors on the D: partition.

4. Run Drive Image Pro.

As Drive Image Pro automatically loads the Zip drivers, be sure to note the drive 
letter assigned to the Zip drive. In this case, we are referring to the Zip drive as E:.

5. Insert the Zip disk labeled “MYIMAGE DISK #1” into your Zip drive.

6. On the title screen, click Create Image.

7. Disk 1 (your hard drive) should already be selected.

8. Click Next.

9. Select the logical partition (D:).

10. Click Next.

11. In the Image File field, type E:\MYIMAGE.PQI.

12. Click Next.

13. Select High compression.

High compression compacts the image of your 400 MB logical partition by 
approximately 50%.

14. Click Next.

15. On the Ready To Create Image File screen, click Advanced Options.

16. Clear the Check for File System Errors check box.

17. Click OK.

18. Click Finish.
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19. When Drive Image Pro prompts you to insert the next media in the series, wait until 
the busy light on the Zip drive goes out, remove “MYIMAGE DISK #1” from the Zip 
drive, and insert “MYIMAGE DISK #2”.

20. After Drive Image Pro has completed the image create process, click OK to return to 
the Drive Image Pro main screen and exit the program.

Result
Your 400 MB logical partition is stored on two or more Zip disks (depending on how 
much data was in the partition) in a spanned image file. You can restore this logical 
partition to any hard drive that has at least 400 MB of available space.

Creating an Image File for Use on CD-ROM

Sample System Configuration
One 3 GB hard drive containing:

• One active primary partition (C:) running Windows 95; 1.5 GB used and 300 MB unused.

• One extended partition containing one logical partition (D:); 1.2 GB unused.

One CD-ROM drive (E:).

Objective
Create an image file of your hard drive’s active primary partition (C:) and store it on 
CD-ROM.

Procedure

1. Since the image file will be too large to fit on one CD, you must create a series of two 
CDs.

Label the first CD as “MYIMAGE DISK #1” and the second as “MYIMAGE DISK #2”.

2. Run ScanDisk to identify and repair any errors on your C: partition.

3. Run Drive Image Pro.

4. On the Drive Image Pro title screen, click Create Image.

5. Disk 1 (your hard drive) should already be selected.

6. Click Next.

7. Select the active primary C: partition.
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8. In the Image File field, type D:\MYIMAGE.PQI.

You must first save the image file to a partition on your hard drive, a secondary hard 
drive, a network drive, or a removable media device. In this scenario, you must save 
MYIMAGE.PQI to the D: partition because Drive Image Pro locks the partition you 
are imaging (C:) in order to get an accurate image.

NOTE:  If you have only one hard drive and only one partition on that drive, you can use 
PowerQuest’s PartitionMagic to resize your existing partition and create a logical 
partition that is large enough to accommodate the image file.

9. Click Next.

10. Select Low compression.

Low compression compacts the image of your 1.8 GB primary partition by 
approximately 40%. 

11. Click Next.

12. On the Ready To Create Image File screen, click Advanced Options.

13. Clear the Check for File System Errors check box.

14. Click the Split Image File Into Multiple Files check box and enter 650,000,000 in the 
File Size (bytes) field.

15. Click OK.

16. Click Finish.

17. After Drive Image Pro has completed the image create process, click OK to return to 
the Drive Image Pro main screen and exit the program.

18. Start Windows 95 and open the D: drive from Windows Explorer.

You will find two separate image files, MYIMAGE.PQI and MYIMAGE.002, on your 
D: drive.

19. Using a third-party CD authoring program, such as Adaptec’s CD Creator, burn 
MYIMAGE.PQI into your CD labeled “MYIMAGE DISK #1” and MYIMAGE.002 into 
the CD labeled “MYIMAGE DISK #2.”
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Result
Your 1.8 GB primary partition is stored on two CD-ROMs in two separate image files. 
You can restore this primary partition to any hard drive that has at least 1.8 GB of 
available space.

Creating an Image File on a Secondary Hard Drive

Sample System Configuration
Disk 1 — One 3.5 GB hard drive containing:

• One active primary partition (C:) running Windows 95; 500 MB used and 1 GB 
unused.

• One extended partition containing one logical partition (E:); 400 MB used and 600 
MB unused.

• 1 GB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:

• One primary partition (D:); 1 GB unused.

• One extended partition containing one logical partition (F:); 600 MB used and 400 
MB unused.

Objective
Create an image file of the 1 GB logical partition (E:) that is on Disk 1 and store it in the 
primary partition (D:) on Disk 2.

1. Run ScanDisk to identify and repair any errors on both hard drives.

2. Run Drive Image Pro.

3. From the Drive Image Pro title screen, click Create Image.

4. Select Disk 1.

5. Click Next.

6. Select the E: partition.

7. Click Next.

8. In the Image File field, type D:\MYIMAGE.PQI.
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9. Select No Compression.

No Compression is the fastest method for creating an image file. You may use it if 
space is not an issue.

10. Click Next.

11. On the Ready To Create Image File screen, click Advanced Options.

12. Clear the Check for File System Errors check box.

13. Click OK.

14. Click Finish.

15. After Drive Image Pro has completed the image create process, click OK to return to 
the Drive Image Pro main screen and exit the program.

Result
An image of your 1 GB logical partition (E:) from Disk 1 is stored in an image file named 
MYIMAGE.PQI on the primary partition (D:) of Disk 2. You can restore the logical 
partition to any hard drive that has at least 1 GB of available space.
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C H A P T E
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Restoring Image Files

This chapter contains the following information:

Methods

Procedure

Resize Options

Advanced Options

Scenarios
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Methods

This chapter describes restoring a Drive Image File to a different drive or partition 

NOTE:  If you create an image on one machine and you wish to restore the image on a 
machine with a different configuration (for example, a different motherboard, video 
card, etc.), the operating system may not boot correctly. Therefore, we recommend 
restoring to similar hardware configurations.

Other Methods:

• If you are restoring an image file to set up a new hard drive on a machine with a 
BIOS older than 1994, see “Using Drive Image Pro with an Older Computer BIOS 
that Requires Drive Overlay Software” in Appendix B.

• To restore image files created with Ghost, see “Converting Ghost Image Files to 
Drive Image Pro” in Appendix B.

• To restore selected files from a compressed or spanned image file, see “Restoring 
Files from spanned or Compressed Images” in Chapter 7.

• If you want to restore images to multiple machines as clients log on and thus reduce 
network traffic, see Chapter 4.
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Procedure

To restore an image file to a different drive or partition,

1. Start Drive Image Pro, then click Restore Image.

2. In the Image File field, enter the path and filename of the image file you want to 
restore, or click Browse to select the path and image file.

Select Image File

3. Click Next.

NOTE:  At any point prior to actual image file restore, you may click Back to return to 
the previous step and change your settings.
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4. If you have more than one partition, you can select the partitions you want to restore. 
Select the image file partitions, or click Select All.

A check appears to the left of the selected partitions.

Select Image File Partition

To deselect partitions, click again on a partition or click Select None.

The Total Selected field keeps a running total of the disk space for all selected 
partitions, including total used and free space.

5. Click Next.
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6. Select the drive where you want to restore the image file.

Select Destination Drive

7. Click Next.

8. Select an existing partition or free space (non-partitioned disk space).

Select Destination Partition or Free Space
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9. If the destination partition or free space is not large enough to accommodate the 
partitions you wish to restore, or if you are restoring the image file to a larger drive 
and want to set a specific size for partitions rather than use the proportional resize 
option, you may want to resize the partitions:

a. Click Resize Source Partitions.

The Resize Partitions window displays.

Resize Partitions: Main Window

The Selected Source Partitions group box displays the partitions you selected to 
restore.

The Totals field displays the disk space for the source partitions.

A formula box below the Totals field displays:

• Destination Size

• Current Size of Selected Partition

• Remaining Space in Destination
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b. Click Resize.

The Resize Partition window appears.

Resize Partition: Enter New Size

The Maximum Size field displays the largest possible size the source partitions can 
have and still fit in the destination space.

The Minimum Size field shows the smallest possible size the source partitions can 
occupy.

c. In the New Size field, enter a number that is less than the Maximum Size and 
greater than or equal to the Minimum Size.

d. Click OK.

Since partitions must end on a cylinder boundary, Drive Image Pro rounds the 
New Size up to the next cylinder boundary.

e. Click Accept.

Later, when you restore the image file, Drive Image Pro resizes the partition.
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10. Click Next.

If you selected an existing partition as the destination, the following message appears: 

Delete Partition to Create Free Space: Confirmation Dialog

NOTE:  Drive Image Pro does not delete the partition until you click Finish on the 
Ready to Restore Image File screen.

If the free space on the destination drive is greater than the space required to restore 
the selected partitions, the Resize Options dialog appears. For more information, see 
“Resize Options” on page 34.

11. Drive Image Pro displays all the information you have entered to this point:

Ready to Restore Image File
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If you wish to alter any settings, click Back to backtrack and make changes.

12. If you wish to enable bad-sector checking, turn on DOS disk write verification, or 
hide partitions after restore, click Advanced Options. For more information on 
Advanced Options, see “Advanced Options” on page 35.

WARNING!  Restoring multiple logical partitions can cause the drive letters of 
subsequent partitions to change. This may make the computer unbootable 
or cause applications to fail. For information on why drive letters change, 
see “Basic Concepts” on the Drive Image Pro CD. To view this file, run 
Setup, then click Documentation > Understanding Hard Drives.

13. Click Finish to begin restoring the image file.

If you assigned a password to the image file when you created it, the Get Image File 
Password dialog appears. You must enter the password in order to restore the image 
file.

If Drive Image Pro detects that you are restoring your image file from a floppy drive or 
removable medium, it enables a media-spanning feature that is capable of reading 
the image file from a series of disks. As Drive Image Pro prompts you for each media, 
be careful to insert the disks sequentially. For more information, see “Restoring an 
Image File from a Zip Drive” on page 36.

The Restoring the Image dialog appears, tracking the following items:

• Image filename

• Estimated megabytes to restore

• Total megabytes copied

• Entire process progress bar

• Information about current partition (volume, type, size MB, used MB, free MB)

• Sub-process progress bar

• Transfer rate for current partition

• Total megabytes copied for current partition

• Time elapsed

• Estimated time remaining

Upon completion, the following message appears: “Image was restored successfully.”

14. Click OK to return to the Drive Image Pro main screen.
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Resize Options

The following options are available when restoring partitions if the free space on the 
destination drive is greater than the space required by the partitions.

Resize Options

Automatically resize partitions proportionally to fit
Click this option to allow Drive Image Pro to automatically expand the partitions in 
equal proportions to occupy the destination drive’s remaining free space.

Leave remaining free space
Click this option if you want to leave any remaining free space unused on the destination 
drive after the partitions are restored.

Resize partitions manually to fit
Click this option to display the Resize Partition window where you can manually set the 
size of the partitions to fit in the destination drive’s remaining free space.

NOTE:  For more information on resizing partitions, see step 9 of “Procedure” which begins 
on page 27.
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Advanced Options

At the Ready To Restore Image File screen, click Advanced Options to access the 
following:

Restore Image Advanced Options

Check for File System Errors
Clear the Check for File System Errors check box to disable error checking.

If you have already used a disk utility program such as ScanDisk to check your hard drive 
for errors, it is not necessary to have Drive Image Pro check for file system errors. 
Clearing this option saves time in restoring images. Note that Drive Image Pro cannot 
restore partitions with file system errors.

Skip Bad Sector Check
This is selected by default to save time in restoring the image file.

Although most drives do not have bad sectors, the potential for problems increases 
during the lifetime of the hard drive. If you have an older hard drive, it is wise to enable 
bad-sector checking by clearing the Skip Bad Sector Check box.

Verify Disk Writes
Click Verify Disk Writes if you want to enable DOS disk write verification.

NOTE:  Disk write verification is not critical to safely restore image files. Enabling disk write 
verification can slow the image restore process by as much as seven times.

Hide Partition After Restore
Restoring multiple logical partitions can cause the drive letters of subsequent partitions 
to change. This may make the computer unbootable or cause applications to fail.
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Most operating systems only allow one primary partition to be visible (bootable) at a 
time. If you are restoring an image of a primary partition, and you do not want to make 
that partition your visible (bootable) partition, click Hide Partition After Restore. 

For example, if you are using your secondary hard drive as a complete backup of your 
primary drive, clicking Hide Partition After Copy preserves all the secondary drive 
information without changing any drive letters. When the computer boots up, a drive 
letter will not be assigned to the hidden partition.

For more information on why drive letters change, see “Basic Concepts” on the Drive 
Image Pro CD. To view this file, run Setup, then click Documentation > Understanding 
Hard Drives. 

Scenarios

Restoring an Image File from a Zip Drive

Sample System Configuration
One 2.1 GB hard drive containing:

• One active primary partition (C:) running Windows 95; 600 MB used and 500 MB unused. 

• 1 GB unpartitioned free space.

One CD-ROM drive (D:).

One Zip drive (E:).

Objective
Restore a 400 MB logical partition from an image file (MYIMAGE.PQI) that spans two 
Zip disks. You wish to restore the logical partition to the unpartitioned free space on your 
hard drive and to resize it to 1 GB.

Procedure

1. Run Drive Image Pro.

As Drive Image Pro automatically loads the Zip drivers, be sure to note the drive 
letter assigned to the Zip drive. In this case, we will refer to the Zip drive as E:.

2. From the Drive Image Pro title screen, click Restore Image.
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3. Insert the Zip disk you labeled as “MYIMAGE DISK #1” into your Zip drive.

4. In the Image File field, type E:\MYIMAGE.PQI.

You may also click Browse to browse the directory tree for your Zip drive and the 
desired image file.

5. Click Next.

6. Select the 400 MB logical partition.

7. Click Next.

8. Disk 1 should already be selected.

9. Click Next.

10. Select the 1 GB unpartitioned free space.

11. Click Next.

12. When the Resize Options window appears, select Automatically resize partitions 
proportionally to fit, then click OK.

13. Click Finish.

14. When Drive Image Pro prompts you to insert the next media in the series, remove 
“MYIMAGE DISK #1” from the Zip drive and insert “MYIMAGE DISK #2”.

15. After Drive Image Pro has completed the image restore, click OK to return to the 
Drive Image Pro main screen and exit the program.

16. Reboot your computer.

Result
After reboot, your hard drive has an active primary partition (C:) and an extended 
partition containing a 1 GB logical partition (D:). Your CD-ROM is now drive E: and your 
Zip drive is F:.
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Restoring an Image File from a CD-ROM Drive

Sample System Configuration
One 3 GB hard drive containing:

• One damaged, unbootable active primary partition (C:) containing Windows 95; 1 
GB used and 800 MB unused.

• One extended partition containing one logical partition (D:); 1.2 GB unused.

One CD-ROM drive (E:).

Objective
Replace your damaged active primary partition (C:) with a backup image of the partition 
stored on CD-ROM.

Procedure

IMPORTANT!  You must copy the DOS drivers for your CD-ROM onto the bootable floppy 
that you created during Drive Image Pro installation. Refer to your CD-ROM 
user guide or contact your CD-ROM manufacturer for instructions on 
loading CD-ROM drivers in DOS and making DOS assign the CD-ROM 
drive a letter.

1. Insert the bootable floppy and start the computer.

2. When the computer has booted to the A: prompt, insert the Drive Image Pro program 
floppy you created during Drive Image Pro installation.

3. At the A: prompt, type PQDI and press <ENTER>.

4. From the Drive Image Pro title screen, click Restore Image.

5. Insert the CD-ROM you labeled as “MYIMAGE DISK #1” into your CD-ROM drive.

6. In the Image File field, type E:\MYIMAGE.PQI.

You may also click Browse to browse the directory tree for your CD-ROM drive and 
the desired image file.

7. Click Next.

8. Select the 1.8 GB primary partition (C:).

9. Click Next.
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10. Disk 1 should already be selected.

11. Click Next.

12. Select the 1.8 GB damaged primary partition (C:) on your hard drive.

13. Click Next.

The following message appears: 

“Item selected is not free space. Disk Images can only be restored into existing free 
space. Drive Image Pro will delete this partition before restoring disk image. 
WARNING: Deleting a partition will DESTROY any existing data on that partition.”

14. Click OK.

Drive Image Pro deletes the C: partition and labels it as free space.

15. Click Finish.

16. When Drive Image Pro prompts you to insert the next media in the series, remove 
“MYIMAGE DISK #1” from the CD-ROM drive and insert “MYIMAGE DISK #2.”

17. After Drive Image Pro has completed the image restore, it prompts you to select a 
primary partition to set active (bootable). Select the partition you just restored.

18. Click OK to return to the Drive Image Pro main screen and exit the program.

19. Reboot your computer.

Result
The restored primary partition (C:) has replaced the damaged active primary partition (C:). 
You should now be able to boot to Windows 95 and operate normally again. Your C: partition 
contains all the data that was present on it when you originally created the image file.
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Restoring an Image File from a Secondary Hard Drive

Sample System Configuration
Disk 1 — One 3.5 GB hard drive containing:

• One active primary partition (C:) running Windows 95; 500 MB used and 1 GB 
unused.

• One extended partition containing one logical partition (E:); 400 MB used and 600 
MB unused.

• 1 GB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:

• One primary partition (D:); 1 GB used by the image file, MYIMAGE.PQI, and 0 MB 
unused.

• One extended partition containing one logical partition (F:); 600 MB used and 400 
MB unused.

Objective
Restore the 1 GB logical partition from the image file, D:\MYIMAGE.PQI to the 
unpartitioned free space on Drive 1.

Procedure

1. Run Drive Image Pro.

2. From the Drive Image Pro title screen, click Restore Image.

3. In the Image File field, type D:\MYIMAGE.PQI.

You may also click Browse to browse the directory tree for your secondary drive and 
the desired image file.

4. Click Next.

5. Select the 1 GB logical partition.

6. Click Next.

7. Select Disk 1.

8. Click Next.
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9. Select the 1 GB unpartitioned free space.

10. Click Next.

11. Click Finish.

12. After Drive Image Pro has completed the image restore, click OK to return to the 
Drive Image Pro main screen and exit the program.

13. Reboot your computer.

Result
After reboot, Disk 1 has a 1.5 GB active primary partition (C:) and an extended partition 
containing two 1 GB logical partitions (E: and F:). Disk 2 has a 1 GB primary partition 
(D:) and an extended partition containing one 1 GB logical partition (G:).
Scenarios 41





C H A P T E
 R 4

PowerCasting

This chapter contains the following information:

Overview

Assigning IP Addresses

Running the PowerCast Server

Running the PowerCast Client

Advanced Options

Command Line Operation

Building PowerCast DOS Boot Diskettes
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Overview

Drive Image Pro combines SmartSector imaging technology together with Ethernet 
multicasting to provide a fast and robust method for deploying workstations. 
PowerCasting sends an image file to one or more Drive Image Pro clients simultaneously. 
The image file is sent only once by the server to all the client computers, rather than 
separately to each client. This decreases network traffic by eliminating duplicate restore 
processes when preparing multiple workstations and when performing computer rollouts 
and migrations.

NOTE:  PowerCasting currently supports only Ethernet networks. Drive Image Pro 
PowerCasting does not currently support bus or Token Ring networks.

Drive Image Pro contains both the PowerCast Server and Client. You can select either 
mode through the graphical user interface or command line switches. The Drive Image 
PowerCast Server reads the PQI image file from either local storage media or from a 
network server and then PowerCasts the image file to the client computers. The client 
computers receive and write the image file to the client disks. The image file can also be 
optionally resized to fit the various disk sizes on different client computers.

To enable Drive Image Pro PowerCasting, the driver for your network interface card 
(NIC) must be loaded and properly configured. If it is not properly installed and 
configured, you will receive error #1864 when you click PowerCast on the main Drive 
Image Pro dialog and then select client or server mode.

This error can be caused by Drive Image Pro not being able to find an IP address or by 
invalid configuration settings such as the line FRAME ETHERNET_II missing from the 
configuration files.

Assigning IP Addresses

In order for the Drive Image Pro PowerCast Server to communicate with each of the 
client computers on the network, the server and each client computer must have a 
unique IP address on the same local network subnet. Drive Image Pro will request an IP 
address from a DHCP or BOOTP server, or use the IP address specified in the optional 
WATTCP.CFG file. 

When starting Drive Image Pro in PowerCast mode, it first looks for a WATTCP.CFG file 
for its IP address. If that file does not exist, it looks for a DHCP server. If the client fails to 
get an IP address, it will display error #1864 and disable the PowerCasting features.
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The DHCP server method of assigning IP addresses is preferred because it saves time and 
is more versatile. For example, say you have 100 computers to configure. If you use the 
WATTCP.CFG method, you will need to build 100 different boot diskettes, each with its 
own IP address in the WATTCP.CFG file. But with DHCP, all the boot disks can be 
identical. Then when each computer boots up, it gets its IP address from the DHCP 
server.

In addition, the Drive Image Pro PowerCast Server contains a built-in BOOTP server for 
use where no DHCP server is available. The IP address range used by the built-in BOOTP 
server is specified in the PowerCast server Advanced Options window. We recommend 
you use addresses in the range of 192.168.0.0 through 192.168.255.255 or 172.16.0.0 
through 172.31.255.255.

Valid local subnet IP addresses are specified by the subnet mask. It is common to use a 
mask of 255.255.255.0 to specify that IP addresses in the range 0 through 255 are in the 
subnet and are accessible. For example: if a computer’s IP address is 192.168.2.4 and the 
subnet mask is 255.255.255.0, then all IP addresses from 192.168.2.0 through 
192.168.2.255 are in the same local subnet and are accessible. Any IP addresses outside 
this range are not accessible from this computer.

Running the PowerCast Server

The server operation includes selecting a client mode, naming the session, and selecting 
the image file and partitions to be made available to PowerCast clients.

To create a session,

1. Start Drive Image Pro, then click PowerCast.

2. Click Server.

3. Select a client mode.

• Click Express if you want to eliminate a decision step on the client side and have 
the image file replace the contents of the drive chosen by the client. The client 
does not have to choose a destination partition or free space.

• Click Custom if you want to allow the client to choose the destination (partition or 
free space) and partition resize values. 

4. Click Next.
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5. Type any name you want for the PowerCast session, then click Next. This name will 
be used by the clients to select a session to join.

6. Specify the name of the image file to be PowerCast during this session, then click 
Next.

Select Image File

7. One of two things can happen:

a. If there is only one partition, the Resize Options dialog appears. Skip to step 8 to 
select resize option.

b. If the image file contains more than one partition, the partitions are displayed.

Use one of the following methods to select the part of the image file you want to 
PowerCast: 

• Click the partitions you want to include.

• Or click Select All to include the entire image file.

• Or click Select None to clear the selections.

After selecting partitions, click Next. The Resize Options dialog then appears.
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8. Specify how you want to configure the remaining free space on the client computers.

• Click Automatically resize partitions proportionally to fit, if you want the 
selected image file to fill all available space.

• Click Leave remaining free space, if you want the selected image file to occupy 
equal space and leave the remaining space free.

9. Click OK.

Ready to Restore Image File

10. You can review your selections. If you want to disable file system checking, enable 
bad-sector checking, turn on DOS disk write verification, hide partitions after restore, 
or specify an IP address range, click Advanced Options. For more details about 
options, see “Advanced Options” on page 51.
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11. After reviewing selections, click Finish.

The Drive Image PowerCast Server dialog appears. Here you can quickly see how 
many clients have connected to the session and control when you want the session to 
start.

Drive Image PowerCast Server - MySession

12. To have the restore process start when a specified number of clients join the session, 
specify an Autostart client count.

13. To begin the session without waiting for a specified number to join, click Start.

Once started, the client status, server status, and PowerCast image transmission 
progress are displayed.

Running the PowerCast Client

The client operation includes logging in to a PowerCast session and selecting restore 
options.

To log on and restore an image,

1. Start Drive Image Pro, then click PowerCast.
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2. Click Client.

The active PowerCast session names are listed in the Available PowerCast Sessions 
box.

3. Select the PowerCast session you want to join. The comments attached to the image 
file are displayed in the Image File Comments window. Click Next.

Select PowerCast Session 

4. If the session prompts you to select a destination drive, select the physical drive 
where you want to restore the image file, then click Next.

If you selected Custom on the server and if the drive you have selected contains more 
than one partition or free space, the following dialog appears. (If you did not select 
Custom on the server, go to step 6.)
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Select Destination Partition or Free Space

5. Select the partition or free space where you want to restore the image file. You can 
also select from the following two options to alter partitions:

• Resize Source Partitions: Lets you specify new sizes for the partitions in the 
received image file. The partitions will be restored to the destination disk and then 
resized to the selected sizes.

• Delete Disk Partitions: Lets you delete partitions on the destination disk.

When done selecting partitions and options, click Next.

6. Review your selections or change them by clicking Back. If you wish to ignore file 
system errors, enable bad-sector checking, turn on DOS disk write verification, or 
hide partitions after restore, click Advanced Options. For more information on 
options see “Advanced Options” on page 51.

7. To complete the client setup, attach to the server and wait for the server to start 
sending the image, then click Finish.

The Receiving PowerCast Image dialog displays and tracks the following:

• Image filename (session name)

• Estimated megabytes to restore

• Total megabytes copied

• Entire process progress bar
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• Information about current partition (volume name, type, size MB, used MB, free 
MB)

• Sub-process progress bar

• Transfer rate for current partition

• Total megabytes copied for current partition

• Time elapsed

• Estimated time remaining

Upon completion, the following message appears: “Image was restored successfully. 
Would you like to view results?”

If you click No, the PowerCast session ends immediately.

If you click Yes, the Display Drive Information dialog will show the destination disk’s 
current partition information. Click Close to end the PowerCast client session.

8. Click OK.

Advanced Options

At the Ready To PowerCast Image File screen, click Advanced Options to access the 
following:

Advanced Options
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Check for File System Errors
Clear the Check for File System Errors check box if you want to ignore file system errors. 
This can be used to allow a partition with errors to be PowerCast. However, you cannot 
restore a partition with file system errors.

Skip Bad Sector Check
This is selected by default to save time in restoring the image file.

Although most drives do not have bad sectors, the potential for problems increases 
during the lifetime of the hard drive. If you have an older hard drive, it is wise to enable 
bad-sector checking by clearing the Skip Bad Sector Check box.

Verify Disk Writes
Click Verify Disk Writes if you want to enable disk write verification.

NOTE:  Disk write verification is not critical to safely restore image files. Enabling disk write 
verification can slow the image restore process by as much as seven times.

Hide Partition After Restore
Restoring multiple logical partitions can cause the drive letters of subsequent partitions 
to change. This may make the computer unbootable or cause applications to fail.

Most operating systems only allow one primary partition to be visible (bootable) at a 
time. If you are restoring an image of a primary partition, and you do not want to make 
that partition your visible (bootable) partition, click Hide Partition After Restore. 

For example, if you are using your secondary hard drive as a complete backup of your 
primary drive, clicking Hide Partition After Restore preserves all the secondary drive 
information without changing any drive letters. When the computer boots up, a drive 
letter will not be assigned to the hidden hard drive.

For more information on why drive letters change, see “Basic Concepts” on the Drive 
Image Pro CD. To view this file, run Setup, then click Documentation > Understanding 
Hard Drives. 
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PowerCast Server Options (Server Only) 
When a network DHCP server or WATTCP.CFG file cannot be found, Drive Image Pro 
acts as a DHCP server. These options let you specify the IP address range used. You can 
enter a range or use the defaults.

• Start IP Address: Enter the first IP address to be leased out to a client (lowest 
number).

• End IP Address: Enter the last IP address to be leased out to a client (highest number).

Command Line Operation

Both the PowerCast server and client operate from either the graphical user interface or 
from the command line. To start the Drive Image PowerCast server from the command 
line specify:

PQDI /MSN= session name  /IMG= image filename

This will start Drive Image Pro in PowerCast server mode and display the server progress 
screen, wait for the specified number of clients to attach, and PowerCast the specified 
image file. Upon completion, the server will wait for additional clients to attach until 
Close is selected.

To start the Drive Image PowerCast client from the command line specify:

PQDI /MSN= session name  /DSK= n

This will start Drive Image Pro in PowerCast client mode, display the PowerCast client 
progress screen, attach to the specified PowerCast session, delete all partitions on the 
specified disk, and restore the partitions from the image file received from the PowerCast 
server. Upon completion, the computer will reboot.

Additional command line switches may also be specified to modify the behavior of Drive 
Image Pro. For more information on running Drive Image Pro from the command line, 
see Chapter 8.
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Building PowerCast DOS Boot Diskettes

Drive Image Pro provides the BootDisk Builder utility to assist in building Drive Image 
Pro DOS boot diskettes. After installing Drive Image Pro, you can run the BootDisk 
Builder from the Drive Image Pro program group. For more information on running 
BootDisk Builder, see “Creating DOS Boot Disks” in Appendix A.

The BootDisk Builder builds DOS boot diskettes with the necessary NIC drivers and 
network configuration files for either PowerCasting or for Microsoft or Novell network 
connectivity. It will not create boot disks that allow simultaneous PowerCasting and 
network connectivity. To simultaneously connect to a Windows NT or NetWare server, 
the network client software must also be properly configured on the boot disk. Because 
of wide variations in interface cards and network configurations, this process will not be 
explained in detail here. You will need to obtain additional help from your network 
administrator.

The required steps to manually build Drive Image PowerCast DOS boot diskettes for both 
NDIS 2.01 and ODI/MLID network interface drivers are detailed on the following pages. 
You can obtain the NIC drivers from the driver diskette that came with your network 
card, from your network administrator or Information Systems technician, or from the 
card manufacturer’s web site. The other required network client software pieces can be 
obtained from your network administrator or Information Systems technician.

NDIS 2.01 NIC Driver
You can create a Drive Image Pro PowerCast DOS boot disk with your network interface 
card's NDIS 2.01 NIC driver.

Use the MAKEDISK.BAT file found found on the Drive Image Pro CD in the 
\SETUP\OS2DOS subdirectory to create a two-diskette Drive Image Pro set. The first 
diskette is the DOS boot diskette and the second is the Drive Image Pro program 
diskette. The following steps outline how to add the network drivers to the boot diskette. 
You need to alter the example configuration and system files for use with different 
network interface cards.

1. Copy the NDIS 2.01 NIC driver from your network interface card diskette to the boot 
diskette. For example, the 3Com 3x905 NIC driver is found on disk #1 in 
subdirectory \NDIS2\DOS and is named “EL90X.DOS.”

2. Copy the DIS_PKT.DOS and the PROTOCOL.INI files to the boot diskette. These files 
are located on the Drive Image Pro CD in the \SETUP\OS2DOS subdirectory.
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3. Change the “drivername=” line in the PROTOCOL.INI file [NIC_CARD] section to 
match your NIC's driver name. The following sample is for the EL90X.DOS driver.

Sample PROTOCOL.INI file contents:

[PROTMAN]

drivername = PROTMAN$

[PKTDRV]

drivername = PKTDRV$

bindings = NIC_CARD

intvec = 0x60

chainvec =0x66

[NIC_CARD]

drivername = EL90X$

4. Copy the PROTMAN.DOS, PROTMAN.EXE and NETBIND.COM programs to the 
boot diskette. You can obtain these files from the Windows NT Server 4.0 CD in the 
CLIENTS\MSCLIENT\NETSETUP directory or at the Microsoft FTP site at: 
ftp://ftp.microsoft.com/msclient/

5. Modify the CONFIG.SYS file to look as follows:

DEVICE=HIMEM.SYS

DEVICE=PROTMAN.DOS /I:A:\

DEVICE=DIS_PKT.DOS

DEVICE=xxxxx.DOS (Change to match your NIC driver)

LASTDRIVE=Z 
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6. Add the NETBIND line to the AUTOEXEC.BAT file.

@ECHO OFF

PROMPT $P$G

NETBIND

The following files should now be on the boot diskette.

• <Hidden DOS system files -- IO.SYS and MSDOS.SYS>

• COMMAND.COM

• HIMEM.SYS

• CONFIG.SYS

• AUTOEXEC.BAT

• xxxxxx.DOS (NDIS network card NIC driver, must match your card.)

• DIS_PKT.DOS

• PROTMAN.DOS

• PROTMAN.EXE

• NETBIND.COM

• PROTOCOL.INI

7. On the Drive Image Pro program diskette (the second diskette) you can create a 
PQDI.BAT file to start Drive Image Pro and to optionally specify command line 
switches. To start Drive Image Pro in user interface mode, specify PQDI. The user 
interface is then used to select Server mode and options.

PQDI (Starts Drive Image Pro in GUI mode.)

To start Drive Image Pro in PowerCast client mode, specify both the disk number and 
the PowerCast session name. Specify the disk number with the /DSK=n command 
line switch. Warning! The entire disk will be erased. Specify the PowerCast session 
name with the /MSN=nnnnn command line switch. The session name specified must 
match the name used by the server.

PQDI /DSK=1 /MSN=SESSION (Starts Drive Image Pro in PowerCast client mode)
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8. Skip this step if a DHCP server is available on the network segment that will be used 
for PowerCasting or if you don’t want to use the Drive Image Pro BOOTP server.

If no DHCP server is available on the network segment, create a WATTCP.CFG file on 
the boot diskette to specify the IP address for this computer to use.

WATTCP.CFG file contents:

IP = 192.168.1.xxx

NETMASK = 255.255.255.0

HOSTNAME = WRKST001

IP is the workstation's unique IP address.

NETMASK is the proper network mask.

HOSTNAME is the workstation's unique name.

The second diskette should now contain the following files:

• MOUSE.COM

• PQDI.EXE

• PQDI.OVL

• PQDI.PQG

• PQDI.RTC

• PQDI.BAT (Optional)

• WATTCP.CFG (Optional)

Use the first diskette to boot DOS and then insert the second diskette and enter PQDI at 
the command prompt to start Drive Image Pro. 

If all the files will fit on one diskette, you can copy the files from disk #2 to disk #1 and 
edit the AUTOEXEC.BAT file to automatically start Drive Image Pro.

ODI/MLID NIC Driver
To create a Drive Image PowerCast DOS boot disk with your network interface card's 
ODI/MLID NIC driver, perform the following steps:

Use the MAKEDISK.BAT file found in the \SETUP\OS2DOS subdirectory to create a two 
diskette Drive Image Pro set. The first diskette is the DOS boot diskette and the second is 
the Drive Image Pro program diskette. The following steps outline how to add the 
network drivers to the boot diskette. You need to alter the example configuration and 
system files for use with different network interface cards.
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1. Copy the ODI/MLID NIC driver from your network interface diskette to the boot 
diskette. For example, the 3Com 3x905B NIC driver is found on disk #1 in 
subdirectory \NWCLIENT and is named 3C90X.COM.

2. Copy the LSL.COM program to the boot diskette.

LSL.COM can be obtained from your network administrator, information systems 
technician, or from the Novell Web site at: http://www.novell.com/download

Get the Novell® Client™ v2.6 for DOS and Windows 3.1x, unzip the DW26EN.ZIP 
file, and copy the LSL.COM file from the \NIOS subdirectory.

3. Modify the CONFIG.SYS file to look as follows:

DEVICE=HIMEM.SYS

LASTDRIVE=Z

4. Modify the AUTOEXEC.BAT file to look as follows: 

@ECHO OFF

PROMPT $P$G

LSL (Loads LSL program)

3C90X (Loads ODI driver)

5. Create a NET.CFG file with the following contents: 

LINK SUPPORT

BUFFERS 6 1600

LINK DRIVER 3C90X (Change to match your network card driver.)

FRAME ETHERNET_802.2

FRAME ETHERNET_II

NOTE:  The FRAME ETHERNET_II line is required for PowerCasting.
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The following files should now be on the boot diskette:

• <Hidden DOS system files -- IO.SYS and MSDOS.SYS>

• COMMAND.COM

• HIMEM.SYS

• CONFIG.SYS

• AUTOEXEC.BAT

• 3C90X.COM (ODI/MLID network card NIC driver, must match your card.)

• LSL.COM

• NET.CFG

6. On the Drive Image Pro program diskette (the second diskette) you can create a 
PQDI.BAT file to start Drive Image Pro and to optionally specify command line 
switches. To start Drive Image Pro in user interface mode, specify PQDI. The user 
interface is then used to select Server mode and options.

PQDI (Starts Drive Image Pro in GUI mode)

To start Drive Image Pro in PowerCast client mode, specify both the disk number and 
the PowerCast session name. Specify the disk number with the /DSK=n command 
line switch. Warning! The entire disk will be erased. Specify the PowerCast session 
name with the /MSN=nnnnn command line switch. The session name specified must 
match the name used by the server.

PQDI /DSK=1 /MSN=SESSION1 (Starts Drive Image Pro in PowerCast client mode)

7. Skip this step if a DHCP server is available on the network segment that will be used 
for PowerCasting or if you don’t want to use the Drive Image Pro BOOTP server.

If no DHCP server is available on the network segment, create a WATTCP.CFG file on 
the boot diskette to specify the IP address for this computer to use.

WATTCP.CFG file contents:

IP = 192.168.1.xxx

NETMASK = 255.255.255.0

HOSTNAME = WRKST001

IP is the workstation's unique IP address.

NETMASK is the proper network mask.

HOSTNAME is the workstation's unique name.
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The second diskette should now contain the following files:

• MOUSE.COM

• PQDI.EXE

• PQDI.OVL

• PQDI.PQG

• PQDI.RTC

• PQDI.BAT (Optional)

• WATTCP.CFG (Optional)

Use the first diskette to boot DOS and then insert the second diskette and enter PQDI at 
the command prompt to start Drive Image Pro.

If all the files will fit on one diskette, you can copy the files from disk #2 to disk #1 and 
edit the AUTOEXEC.BAT file to automatically start Drive Image Pro.
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Preparation

1. If you are upgrading to a new hard drive, refer to the appendix for the following 
information:

• “Hard Drive Manufacturers” in Appendix E

• “Using Drive Image Pro with SCSI Hard Drives” in Appendix B

• “Using Drive Image Pro with an Older Computer BIOS that Requires Drive 
Overlay Software” in Appendix B

2. It is strongly recommended that you perform the following steps before upgrading to 
a new hard drive or using Drive Image Pro to copy disk to disk.

a. Create a bootable DOS diskette. Use the install program Create Rescue Diskettes 
option or See “Creating DOS Boot Disks” in Appendix A.

b. Before running Drive Image Pro, use a disk utility program such as ScanDisk or 
Norton’s Disk Doctor to identify and repair any errors on your hard drive.

c. Verify that the destination drive or partition is the same size or larger than the 
source drive.

NOTE:  You can copy a partition or drive from a larger to a smaller partition or drive. 
However, there must be enough free space on the smaller destination to 
accomodate the used space on the larger source.

3. If you are copying from one partition to another partition on the same hard drive, 
skip directly to the “Procedure” section.

4. To set up a dual hard drive system,

a. Get the manufacturer’s installation guides for both drives.

The installation guides provide information on installing the drives, setting up the 
BIOS, and changing the jumper settings. If you do not have access to these guides, 
contact the hard drive manufacturers directly. Most drive manufacturers maintain 
sites on the World Wide Web that offer setup information. For contact information 
of some popular hard drive manufacturers, see “Hard Drive Manufacturers” in 
Appendix E.

b. Turn off the computer’s power.
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c. Discharge static electricity by touching a grounded metal object such as a metal 
filing cabinet.

WARNING!  Do not allow static electricity to contact the inner parts of your 
computer. Static electricity can damage or destroy your computer’s 
electronic components.

d. Remove the computer’s cover.

e. Determine which drive you want to be master and which drive you want to be 
slave, then follow the manufacturer’s instructions to change the jumper settings on 
your hard drives accordingly.

f. Attach the interface cable and the power supply cable to the second drive.

g. Mount the second drive.

h. Start the computer and enter its Basic Input/Output System (BIOS) Setup program 
before the computer completes startup.

This is usually accomplished by pressing <DEL>, <F1>, or <F2>, according to the 
prompt that appears at the bottom of your screen during initial startup.

i. If the BIOS Setup program includes an Auto-Detect option, select it to detect both 
the master and slave drives.

If there is no Auto-Detect option, you may be required to enter the specific 
number of heads, cylinders, and megabytes of the drives. This information is 
usually printed on the drive’s outside cover. If it is not, contact the drive 
manufacturer. (See “Hard Drive Manufacturers” in Appendix E.)

j. If the BIOS does not support hard drives larger than 504 megabytes, follow the destination 
drive manufacturer’s instructions to install any software included with the drive.

IMPORTANT!  Computer BIOS made before 1994 usually do not support the EIDE 
standard and cannot address hard drives larger than 504 MB. Hard 
drives larger than 504 MB typically include software such as 
OnTrack Disk Manager, Maxtor Max-Blast Disk Manager, or Micro 
House EZ-Drive which allow computers to see larger hard drives.

If your machine does not support the EIDE standard, make sure the software 
included with the destination drive is correctly installed.

When running Drive Image Pro, make sure the disk sizes reported in the Total Selected 
fields are accurate before continuing. If Drive Image Pro lists a drive size that is much 
smaller than its actual size, the EIDE support software is not functioning properly.

k. Turn off the computer and restart it.
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Procedure

NOTE:  Please be aware that it is NOT necessary to format your destination partition or to 
partition your hard drives before performing a Disk To Disk Copy. Drive Image Pro 
automatically performs both these functions.

To directly copy partitions within the same drive or from one hard drive to another 
without creating an image file,

1. At the Drive Image Pro main screen, click Disk To Disk.

2. Select the drive that contains the partition you wish to copy.

A check appears to the left of the selected drive.

Select Source Drive

3. Click Next.

NOTE:  At any point prior to actually copying partitions, you may click Back to return 
to the previous step and change your settings.
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4. Select the source partition you wish to copy, or click Select All to automatically 
select all partitions.

A check appears to the left of the selected partition. 

Select Source Partition

To deselect partitions, click again on a partition or click Select None to deselect all 
partitions at once.

The Total Selected field keeps a running total of the disk space for all selected 
partitions, as well as the total used and free space within the partitions.

IMPORTANT!  In order to copy partitions, the destination partition or drive must have 
free space equivalent to the total used space of the selected source 
partition.

5. Click Next.
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6. Select the drive to which you wish to copy the partition.

Select Destination Drive

7. Click Next.
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8. Select an existing partition or free space (non-partitioned disk space) on the 
destination drive.

Select Destination Partition or Free Space

NOTE:  If your destination drive is new and does not contain any partitions, disregard 
this step.
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9. If the destination partition or free space is not large enough to accommodate the 
partition you wish to copy, or if you are copying the partition to a larger drive and 
want to set a specific size for the partition rather than use the proportional resize 
option, you can click Resize Source Partitions to specify a different size for the 
copied partition. To resize partitions, perform the following:

a. Click Resize Source Partitions.

The Resize Partitions window appears.

Resize Partitions: Main Window

The Selected Source Partitions group box displays the partition you selected to 
copy.

The Totals field displays the disk space for the selected partition, as well as the 
total used and free space within the partition.

A formula box below the Totals field displays the following information:

• Destination Size

• Current Size of Selected Partition

• Remaining Space in Destination
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b. Click Resize.

The Resize Partition window appears.

Resize Partition: Enter New Size

The Maximum Size field displays the largest possible size the source partition can 
be and still fit in the destination space.

The Minimum Size field shows the smallest possible size the source partition can 
occupy.

c. In the New Size field, enter a number that is less than the Destination Size (from 
the previous dialog’s formula box) and greater than the Minimum Size.

d. Click OK.

Since partitions must end on a cylinder boundary, Drive Image Pro rounds the 
New Size up to the nearest cylinder boundary.

e. Click Accept.

Later, when you copy the partition, Drive Image Pro resizes them.

10. Click Next.

If you selected an existing partition as the destination, the following message 
appears: 

“Destination selected is not free space. Partitions can only be copied into existing 
free space. This partition will be deleted before copying. WARNING: Deleting a 
partition will DESTROY any existing data on that partition.”

Drive Image Pro does not delete the partition until you click Finish on the Ready 
to Copy Disk to Disk screen.

If the free space on the destination drive is greater than the space required to copy 
the selected partition, the Resize Options dialog appears.

NOTE:  For information on resize option settings, see “Resize Options” on page 71.
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11. Drive Image Pro displays all the information you have entered to this point.

• Source drive

• Source partitions

• Destination drive

• Destination space

• Resize

Ready to Copy Disk to Disk

If you wish to alter any settings, click Back to backtrack and make changes.

12. If you wish to set options such as disabling file system error-checking or hiding 
partitions after copy, click Advanced Options. For more information, see “Advanced 
Options” on page 72.

NOTE:  Copying multiple logical partitions can cause the drive letters of subsequent 
partitions to change. This may make the computer unbootable or cause 
applications to fail. For information on why drive letters change, see “Basic 
Concepts” on the Drive Image Pro CD. To view this file, run Setup, then click 
Documentation > Understanding Hard Drives.
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13. Click Finish to begin copying the selected partition.

The Copying Disk To Disk dialog tracks the following items:

• Estimated megabytes to copy

• Total megabytes copied

• Entire process progress bar

• Information about current partition (volume, type, size MB, used MB, free MB)

• Sub-process progress bar

• Transfer rate for current partition

• Total megabytes copied for current partition

• Time elapsed

• Estimated time remaining

Upon completion, the following message appears: “Selected partition(s) copied 
successfully. Would you like to view the results?”

14. Click OK to return to the Drive Image Pro main screen.

Resize Options

The following Resize Options are available when copying partitions if the free space on 
the destination drive is greater than the space required by the partition.

Resize Options
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Automatically resize partitions proportionally to fit
Click this option to allow Drive Image Pro to automatically expand the partitions in 
equal proportions to occupy the destination drive’s remaining free space.

Leave remaining free space
Click this option if you want to leave any remaining free space unused on the destination 
drive after the partitions are copied.

Resize partitions manually to fit
Click this option to display the Resize Partition window where you can manually set the 
size of the partitions to fit in the destination drive’s remaining free space.

Advanced Options

The Disk to Disk Advanced Options group box appears when you click Advanced 
Options at the Ready To Copy Disk To Disk screen. The following options are available 
from the Disk To Disk Advanced Options group box:

Disk to Disk Advanced Options

Source Options

Check for File System Errors
Clear the Check for File System Errors check box if you want to disable error checking.

If you have already used a disk utility program such as ScanDisk to check your hard drive 
for errors, it is not necessary to have Drive Image Pro check for file system errors. 
Clearing Check for File System Errors saves time in copying the partitions.
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If you did not run a disk utility program before loading Drive Image Pro, leave the Check 
for File System Errors check box selected.

Disable SmartSector Copying
Drive Image Pro’s SmartSector technology speeds up the imaging process by only 
copying clusters and sectors that contain data. However, in some cases, such as 
high-security environments, it may be desirable to copy all clusters and sectors in their 
original layout, whether or not they contain data.

If you wish to copy both used and unused clusters and sectors, click Disable 
SmartSector Copying. Disabling SmartSector Copying increases processing time.

Destination Options

Skip Bad Sector Check
This is selected by default to save time in copying the partitions.

Although most drives do not have bad sectors, the potential for problems increases 
during the lifetime of the hard drive. If you have an older hard drive, it is wise to enable 
bad-sector checking by clearing the Skip Bad Sector Check box.

Verify Disk Writes
Click Verify Disk Writes if you want to enable DOS disk write verification.

NOTE:  Disk write verification is not critical to safely copy image files. Enabling disk write 
verification can slow the image copying process by as much as seven times.

Hide Partition After Copy
Most operating systems only allow one primary partition to be visible (bootable) at a 
time. If you are copying a primary partition and you do not want to make that partition 
your visible (bootable) partition, click the Hide Partition After Copy box.

For example, if you are using your secondary hard drive as a complete backup of your 
primary drive, selecting Hide Partition After Copy preserves all the secondary drive 
information without changing any drive letters. When the computer boots up, a drive 
letter will not be assigned to the hidden hard drive.

For more information on why drive letters change, see “Basic Concepts” on the Drive 
Image Pro CD. To view this file, run Setup, then click Documentation > Understanding 
Hard Drives. 
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Scenarios

Copying from Partition to Partition in a Single Hard Drive System

Sample System Configuration
One 2 GB hard drive containing one active primary partition (C:) running Windows 98; 
500 MB used and 1.5 GB unused.

Objective
Create a backup of the active partition by copying it to the same hard drive.

Procedure

1. Use PowerQuest’s PartitionMagic to resize the existing primary partition to about half 
the total size of the hard drive (1 GB).

2. Run Drive Image Pro.

3. From the Drive Image Pro title screen, click Disk To Disk.

4. Disk 1 should already be selected.

5. Click Next.

6. Select the primary partition (C:).

7. Click Next.

8. Disk 1 should already be selected.

9. Click Next.

10. Select the free space (non-partitioned disk space) you created when you resized the 
primary partition.

11. Click Next.

If the Resize Options window appears, select Automatically resize partitions 
proportionally to fit, then click OK.

12. From the Ready To Copy Disk To Disk screen, click Advanced Options.

13. Under the Source Options, clear the Check for File System Errors box.

14. Under the Destination Options, click Hide Partition After Copy.
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15. Click OK.

16. Click Finish.

17. After Drive Image Pro has completed the copying process, click OK to return to the 
Drive Image Pro main screen and exit the program.

Result
The computer reboots and returns to Windows 98. Because only one primary partition 
may be visible at a time, the new partition does not appear in Windows Explorer.

If you ever wish to replace the active partition with the hidden backup partition (for 
instance, if you lose data from your C: partition), run Drive Image Pro Disk To Disk again. 
Select the hidden partition as the source and the active partition as the destination. After 
Drive Image Pro completes the copying process, it prompts you to set an active partition. 
Select the newly copied partition.

Copying from Drive to Drive in a Dual Hard Drive System

Sample System Configuration
Disk 1 — One 3 GB hard drive containing:

• One active primary partition (C:) running Windows 98; 500 MB used and 1 GB 
unused.

• One extended partition containing one logical partition (E:); 400 MB used and 600 
MB unused.

• 500 MB unpartitioned free space.

Disk 2 — One 2 GB hard drive containing:

• One primary partition (D:); 400 MB used and 600 MB unused.

• One extended partition containing one logical partition (F:); 200 MB used and 800 
MB unused.

Objective
Copy the E: partition from Disk 1 to the F: partition on Disk 2.
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Procedure

1. Run Drive Image Pro.

2. From the Drive Image Pro title screen, click Disk To Disk.

3. Select Disk 1.

4. Click Next.

5. Select the E: partition.

6. Click Next.

7. Select Disk 2.

8. Click Next.

9. Select the F: partition.

10. Click Next.

The following message appears: 

“Destination selected is not free space. Partitions can only be copied into existing 
free space. This partition will be deleted before copying. WARNING: Deleting a 
partition will DESTROY any existing data on that partition.”

Click OK.

11. From the Ready To Copy Disk To Disk screen, click Advanced Options.

12. Under the Source Options, clear the Check for File System Errors box.

13. Click OK.

14. Click Finish.

15. After Drive Image Pro has completed the copying process, click OK to return to the 
Drive Image Pro main screen and exit the program.

Result
The computer reboots and returns to Windows 98. Drive letters stay the same, but the F: 
partition now contains the same data as the E: partition.
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The Tools drop-down menu on the Drive Image Pro main screen lets you manually 
perform some common partition-management tasks that Drive Image Pro automatically 
performs when it processes image files or when it copies partitions. The Tools menu gives 
you access to these useful features without requiring you to create or restore image files, 
or copy partitions.

Displaying Drive Information

The Display Drive Information option lets you view information about the partitions on 
your current hard drive. You can view:

• Drive letters

• Volume (partition) labels

• Color-coded volume (partition) types

• Status (active partition)

• Partition size

• Used MB in partitions

• Free MB in partitions

• Primary or logical drive

To display drive information,

1. At the Drive Image Pro main screen, click Tools > Display Drive Information.

2. If you have more than one hard drive on your system, select the drive you want to 
view from the Physical Drive drop-down list.

Creating Extended Partitions

If you create an image of a primary partition and want to restore it as a logical partition, 
you must first have an extended partition on your hard drive. For information about 
partition types and requirements, see “Basic Concepts” on the Drive Image Pro CD. To 
view this file, run Setup, then click Documentation > Understanding Hard Drives.

NOTE:  It is not necessary to manually create an extended partition when you restore an 
image of a logical partition. Drive Image Pro automatically creates an extended 
partition if one does not already exist.
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To create an extended partition,

1. At the Drive Image Pro main screen, click Tools > Create Extended Partition.

The Create Extended Partition window appears.

Create Extended Partition

2. If you have more than one hard drive on your system, select the desired drive from 
the Physical Drives drop-down list.

3. Select a free space.

A check mark appears to the left of the selected free space.

NOTE:  If there is no free space (unpartitioned area) on your drive, you must delete an 
existing partition to create free space. 

4. Click Create.

Drive Image Pro creates an extended partition in the selected free space.

5. Click Close to return to the Drive Image Pro main screen.
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Deleting Partitions

This feature deletes existing partitions to create free space on your hard drive. 

WARNING!  Be aware that deleting existing partitions destroys any data they contain.

To delete partitions,

1. At the Drive Image Pro main screen, click Tools > Delete Disk Partition(s).

The Delete Partition(s) window appears.

Delete Partitions

2. If you have more than one hard drive on your system, select the desired drive from 
the Physical Drives drop-down list.

3. Click the partitions you wish to delete.

A check mark appears to the left of selected partitions.
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4. Click Delete, or to delete all partitions click Delete All.

The following message appears: 

Delete Partition Confirmation

5. Type the volume label exactly as it appears, then click OK. 

Drive Image Pro deletes the partition and displays the message: “Volume <volume 
name> was deleted successfully.”

6. Click Close to return to the Drive Image Pro main screen.

Hiding Partitions

The Hide/Unhide feature allows you to protect partitions from unwanted user access. 
Hidden partitions are not accessible because they are not assigned drive letters when 
you boot your computer. If you unhide a partition, it is assigned a drive letter the next 
time you boot your computer and becomes accessible again.

Before hiding and unhiding partitions, be aware of the following restrictions.

• Hiding or unhiding a partition can cause the drive letters of subsequent partitions to 
change. This may make the computer fail to boot or cause applications to fail. For 
information on why drive letters change and how to fix them, see “Basic Concepts” 
on the Drive Image Pro CD. To view this file, run Setup, then click Documentation > 
Understanding Hard Drives.
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• If your hard drive contains more than one primary partition, only one is visible by 
default. When you use the Set Active Partition feature, Drive Image Pro unhides the 
selected primary partition and automatically hides all other primary partitions. See 
“Setting the Active Partition” on page 83.

• Because a hidden partition is not bootable or accessible, if you hide the partition 
where Drive Image Pro is installed, you must re-install Drive Image Pro on your new 
active (bootable) partition to run it again.

To hide/unhide partitions,

1. At the Drive Image Pro main screen, click Tools > Hide/Unhide Partition(s).

The Hide Partition(s) window appears.

Hide Partition(s)

2. Click the partition you want to hide.

A check mark indicates that the partition is selected.

NOTE:  Normally when you select a partition, the Hide button becomes available. If the 
button is not available, the partition can’t be hidden.

3. Click Hide to hide the selected partition.

The partition status changes to “Hidden.”
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4. Click a hidden partition. 

NOTE:  Normally when you select a partition, the Unhide button becomes available. If 
the button is not available, the partition can’t be unhidden.

5. Click Unhide to unhide the selected partition.

The partition status changes to “None.”

6. Click Close to return to the Drive Image Pro main screen.

7. Click Exit to exit Drive Image Pro.

8. Reboot your computer.

Setting the Active Partition

The Set Active Partition feature allows you to make a primary partition the active 
(bootable) partition. Only one primary partition can be active at a time. To be bootable 
under most operating systems, a primary partition must be located on the first (master) 
drive, and it must contain an operating system. When your computer boots, it scans the 
partition table of the first drive to find the active partition, then boots from that partition.

WARNING!  Before you set an active partition, be sure it is bootable. If it is not bootable or 
if you are not sure, locate the boot disk you created when you installed Drive 
Image Pro. If you restart your computer and it does not boot normally, you 
must boot from the floppy disk, run Drive Image Pro from the program disk 
you created during Drive Image Pro install, and set a different partition active.
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1. At the Drive Image Pro main screen, click Tools > Set Active Partition.

The Set Active Partition window appears.

Set Active Partition

2. Select a primary partition that is not currently active.

A check mark appears to the left of the selected partition.

3. Click Set Active.

The status of the selected partition changes to “Active.”

4. Click Close.

5. Click Exit to exit Drive Image Pro.

6. Reboot your computer.
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PowerQuest’s Drive Image File Editor simplifies management of your image files. 
Working within a single screen, Drive Image File Editor gives you total image file control, 
allowing you to create and copy image files, copy or delete partitions within files, 
compress and uncompress partitions, and restore individual program and data files from 
imaged partitions. Drive Image File Editor also provides name and comment capabilities, 
for easy identification of individual image files and partitions.

NOTE:  Drive Image File Editor requires Windows 95/98 or Windows NT.

Drive Image File Editor—Main Screen

Drive Image File Editor’s main screen is divided into three sections: Recent Images, 
Image File Information, and Partitions.

Image File Editor Main Screen
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Recent Images 
Recent Images lists the PowerQuest image files most recently accessed. Click any 
filename in this list to view the corresponding image file and partition information. You 
can also right-click anywhere in the Recent Images list box to access a quick menu of all 
the commands in the Image menu. Double-click any image file or partition to activate 
File Restore.

The Recent Images list holds up to 64 filenames. Additional filenames bump the oldest 
items from the list. To clear this list, select Image > Recent Images > Clear List from the 
menu bar. To remove a single list entry, select Image > Recent Images > Remove Entry.

Image File Information
Image File Information displays user-assigned Name and Comment information for the 
selected image file. You may specify a name by typing directly in the Name field, or by 
selecting Image > Name from the menu bar. If no name is assigned, this field remains 
blank. 

You may also specify a comment by typing directly in the Comment field, or by selecting 
Image > Comment from the menu bar. If no comment is assigned, this field remains 
blank.

Partitions
Partitions displays the partitions in the selected image file. The following information is 
provided for each partition:

• Name identifies a user-assigned name for the selected partition. You may specify a 
name by selecting Partition > Name from the menu bar. If no name is assigned, this 
field remains blank. 

NOTE:  The default name for the partition is the volume label assigned to the partition 
when the image was created. If you change the partition name here, it does not 
change the volume label when the image is restored.

• Drive Letter identifies the drive letter associated with the selected partition.

• Type specifies the file system type (e.g. FAT, NTFS, etc.) of the selected partition.

• Status identifies the selected partition’s drive status as either Primary or Logical.

• Date identifies the date the selected partition’s image file was created.

• Size specifies the selected partition’s file size.
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• Compressed identifies whether the selected partition is compressed or 
uncompressed. If the partition is compressed, the level of compression (Low or High) 
is also specified.

NOTE:  Low compression yields an approximate 40% compression rate. High 
compression is approximately 50%.

Opening Image Files

To open a new image file,

1. From the menu bar, select Image > Open or click the Open Image File icon.

The Open dialog appears.

NOTE:  You may also right-click inside the Recent Images list box and select Open 
from the quick menu.

2. Navigate to the folder where the image file is located.

3. Select the desired image file.

NOTE:  Drive Image File Editor can only open files created with Drive Image, Drive 
Image Pro, or Drive Image File Editor.

4. Click Open.

The filename appears in the Recent Images list.

Deleting Image Files

To delete an image file,

1. From the menu bar, select Image > Open or click the Open Image File icon.

The Open dialog appears.

NOTE:  You can also select Image > New or click the Create New Image icon.

The New Image File dialog appears. The following steps apply to both the Open and 
New Image File features.

2. Navigate to the folder where the image file is located.
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3. Select the desired image file.

4. Press <DEL>.

The following message appears: “Are you sure you want to send [*.PQI] to the 
Recycle Bin?”

5. Click Yes.

The image file is deleted.

6. Click Cancel to exit without deleting.

NOTE:  Image files may also be deleted using Microsoft’s Windows Explorer utility. 

Creating New Image Files

Drive Image File Editor allows you to create empty image files, which may then be 
customized by copying desired partitions from other files. To create a new image file:

1. From the menu bar, select Image > New or click the Create New Image icon.

The New Image File dialog appears.

NOTE:  You may also right-click inside the Recent Images list box and select New from 
the quick menu.

2. Navigate to the folder where you want to create the image file.

3. Specify a new image filename.

4. Click Save.

The new filename appears in the Recent Images list. 

NOTE:  Drive Image File Editor does not support HPFS partitions.
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Creating Spanned Image Files
Drive Image File Editor allows you to save an existing image file across a series of disks 
(e.g. floppy disks and removable media storage devices such as Jaz, Zip, Mo, and SyQuest 
disks) in a spanned format. To span an existing image file, perform the following:

1. In the Recent Images list, select the file you want to span.

NOTE:  If the file is not listed, you must first open the file. For more information, see 
“Opening Image Files” on page 88.

2. From the menu bar, select Image > Span.

The Create Spanned Image dialog appears.

NOTE:  You may also right-click the selected image file in the Recent Images list box 
and select Span from the quick menu.

3. Navigate to the location where you want to save the spanned image.

NOTE:  You must have at least 100 KB free on the destination drive.

4. Specify the spanned image filename.

5. Click Save.

The Copy Options dialog appears.

6. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

Drive Image File Editor creates the spanned image file, prompting you for each new 
diskette. Drive Image Pro permits you to span a maximum of 50 disks with a limit of 
12 partitions per image file. You must have at least 100K of available space on each 
disk in the series. If you use the media-spanning feature, be sure to number the disks 
in order, since you must insert them in sequence when restoring the image file. 

Combining Spanned Images Files
Drive Image File Editor allows you to recombine a spanned image file into a single, 
unified file. To combine a spanned image file,

1. In the Recent Images list, select the file you want to combine.

NOTE:  If the file is not listed, you must first open the file. For more information, see 
“Opening Image Files” on page 88.
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2. From the menu bar, select Image > Combine.

The Combine Spanned Image dialog appears.

NOTE:  You may also right-click the selected image file and select Combine from the 
quick menu.

3. Navigate to the location where you want to save the combined image.

4. Specify the combined image filename.

5. Click Save.

The Copy Options dialog appears.

6. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

The image file is combined and saved under the specified filename.

Copying Image Files

Although image files cannot be directly copied within Drive Image File Editor, file copies 
may be made in one of two ways. To copy partitions within an image file, see 
“Uncompressing Partitions” on page 98. To copy an image file by creating a new file,

1. From the menu bar, select Image > New or click the Create New Image icon.

The Create New Image dialog appears.

2. Navigate to the folder where you want to create the image file.

3. Specify a new image filename.

4. Click Save.

The new filename appears in the Recent Images list.

5. In the Recent Images list, select the file you want to copy.

The file’s partition information appears in the Partitions group box.

6. Shift-click to select contiguous partitions or Ctrl-click to select non-contiguous 
partitions. 
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7. Drag-and-drop the partitions to the newly-created filename in the Recent Images list. 

The Copy Options dialog appears.

8. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

The copied partitions appear in the newly-created image file.

NOTE:  Image files may also be copied using Microsoft’s Windows Explorer utility.

Changing Copy Options

Setting Compression Levels
Compressing files can save disk space and time over a busy network. Every time you save 
an image file or partition using Drive Image File Editor, you are prompted with the 
following compression options:

• No Change keeps the same compression level.

• No Compression is usually the fastest method for saving the image file and is useful if 
storage space is not an issue. However, if you are saving your image file to a busy 
network drive or to a relatively slow removable media device, high compression may 
be faster than no compression since there is less data to write to the file. 

• Low compression offers a 40% average compression ratio.

• High compression offers a 50% average compression ratio.

Working with Passwords
When you create an image file in Drive Image Pro, you have the option to assign a 
password to that file. Once assigned, the password is encrypted into the file and can only 
be changed one of two ways. You can use Drive Image Pro to restore the protected image 
file, then create a new image file with a different password. Or you can use Drive Image 
File Editor to make password changes.
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Every time you save an image file or partition using Drive Image File Editor, you are 
prompted with the following password options:

• Use Same Password

• No Password Protection

• Set New Password—If you choose this option, you then type the password in the 
Password and the Confirm Password fields.

NOTE:  Password-protected partitions retain their passwords. Although they can be copied 
or saved into other image files, they cannot be restored or downloaded until the 
proper password is entered.

Also, partitions which already have a password cannot have the password removed 
using No Password Protection or have a new password set using Set New Password 
without correctly entering the original password when prompted during the copy.

Splitting an Image File Into Multiple Files
Sometimes it is useful to split a large image file into smaller files, for example when 
saving very large image files to removable media. You can split an image when you 
create it using Drive Image Pro, as you are automatically prompted for new media when 
media in a removable device is full. Or you can use the Drive Image File Editor to split 
image files after they have been created.

It is especially useful to save the split image files to a network drive and later transfer the 
files to removable media, such as a CD-ROM. The split image files can be sized in 
advance on the network to fit the removable media where they will be placed later.

Every time you save an image file using Drive Image File Editor, you are prompted with 
the following option.

• Split Image File into Multiple Files specifies the maximum byte size that your saved 
image file can be. For example, enter the size of your media in the File Size (bytes) 
field. If you want to save the file to CD, you could specify a file size of 650,000,000 
bytes (650 MB) or less. When the file being saved reaches this size, it begins another 
file.
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Accessing Partition Properties

To access a partition’s properties information,

1. In the Recent Images list, click the file that contains the desired partition. 

NOTE:  If the file is not listed, you must first open the file. See “Opening Image Files” on 
page 88 for more information.

2. In the Partitions group box, select the desired partition.

3. From the menu bar, select Partition > Properties.

NOTE:  You may also right-click the partition and select Properties from the quick menu.

The Properties dialog appears.

4. To exit the Properties dialog, click OK.

Properties Information
Displays the properties of the selected partition. The following information is provided 
on each partition:

• Name identifies a user-assigned name for the partition.

• Comment specifies a user-assigned comment associated with the partition.

• Drive Letter identifies the partition drive letter.

• Partition Type specifies the type of the partition.

• File System Type specifies the file system type used within the partition.

• Status identifies the selected partition’s drive status as either Primary or Logical.

• Spanned identifies whether the partition is spanned over several disks.

• Compression identifies whether the selected partition is compressed or 
uncompressed. The level of compression (Low or High) is also specified. 

NOTE:  Low compression yields an approximate 40% compression rate. High 
compression is approximately 50%.

• Password Protected identifies whether the selected partition is password protected.

• Partition Size specifies the total size of the partition. This total includes both used 
and free space.
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• Used Space in Partition specifies the amount of used space within the partition.

• Free Space in Partition specifies the amount of free or unused space within the 
partition.

• Physical Size in Image identifies the actual size of the partition within the image file. 
This physical size may differ from the Partition Size depending upon the amount of 
used and free space within the partition and the compression level.

Copying Partitions

You may copy single or multiple partitions between image files. Copied partitions will 
not overwrite any partition already in the file. Therefore, you may have several partitions 
with the same name, drive letter, etc., within one image file.

You can copy partitions using either the drag-and-drop method or the menu method. 
When you use the menu method, the Copy to Image File dialog displays so that you can 
specify folder and filename information.

Drag and Drop Method
To copy a partition,

1. In the Recent Images list, select the file that contains the partitions you want to copy. 

NOTE:  If the file is not listed, you must first open the file. See “Opening Image Files” on 
page 88 for more information.

2. In the Partitions group box, select the desired partitions.

3. Drag and drop the partitions to the desired file in the Recent Images list.

The Copy Options dialog appears.

4. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

The copied partitions appear in the image file.
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Menu Method
To copy a partition,

1. From the menu bar, select Partition > Copy or click the Copy Partition icon.

NOTE:  You can also right-click the partitions and select Copy from the quick menu.

The Copy to Image File dialog appears.

2. Navigate to the folder where you want to create the image file.

3. Specify a new image filename.

4. Click Save.

The Copy Options dialog appears.

5. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

The new filename appears in the Recent Images list.

Deleting Partitions

To delete single or multiple partitions,

1. In the Recent Images list, click the file that contains the partitions you want to delete. 

NOTE:  If the file is not listed, you must first open the file. See “Opening Image Files” on 
page 88 for more information.

2. In the Partitions group box, select the desired partitions.

3. From the menu bar, select Partition > Delete or click the Delete Partition icon.

NOTE:  You may also right-click the partitions and select Delete from the quick menu.

One of the following messages appears: “Delete partition?” or “Delete all selected 
partitions?”

4. Click Yes.

The partitions are deleted from the image file.
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Compressing Partitions

Drive Image File Editor allows you to compress individual partitions and save them to 
another image file. Compressed partitions will not overwrite any partition already in the 
file. Therefore, you may have several partitions with the same name, drive letter, etc. 
within one image file.

To compress a partition,

1. In the Recent Images list, select the file that contains the partition you want to compress. 

NOTE:  If the file is not listed, you must first open the file. See “Opening Image Files” on 
page 88 for more information.

2. In the Partitions group box, select the desired partition.

3. From the menu bar, select Partition > Compress.

NOTE:  You may also right-click the partition and select Compress from the 
quick menu.

The Compress to Image File dialog appears.

4. Navigate to the location of the image file in which you want to save the compressed 
partition.

5. Select the desired image file.

6. Click Save.

The Copy Options dialog appears.

7. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

NOTE:  Selecting Low compresses partitions by approximately 40%. High increases the 
compression ratio to approximately 50%.
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Uncompressing Partitions

Drive Image File Editor allows you to uncompress individual partitions and save them to 
another image file. Uncompressed partitions will not overwrite any partition already in 
the file. Therefore, you may have several partitions with the same name, drive letter, etc., 
within one image file.

To uncompress a partition,

1. In the Recent Images list, select the file that contains the partition you want to 
uncompress. 

NOTE:  If the file is not listed, you must first open the file. See “Opening Image Files” on 
page 88 for more information.

2. In the Partitions group box, select the desired partition.

3. From the menu bar, select Partition > Uncompress.

NOTE:  You may also right-click the partition and select Uncompress from the quick menu.

The Uncompress to Image File dialog appears.

4. Navigate to the location of the image file in which you want to save the 
uncompressed partition.

5. Select the desired image file.

6. Click Save.

The Copy Options dialog appears.

7. Specify a compression level, change the password as needed, or split the image into 
multiple files, then click OK. For more information, see “Changing Copy Options” on 
page 92.

The uncompressed partition appears in the image file.
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Restoring Files or Folders from a Partition

Drive Image File Editor lets you restore individual files or folders from image partitions 
and save them to any directory or folder. You can restore single files and folders, or you 
can restore multiple files and folders.

To restore files,

1. In the Recent Images list, select the image file that contains the partition with the files 
you want to restore. 

NOTE:  If the image file is not listed, you must first open it. For more information, see 
“Opening Image Files” on page 88.

2. In the Partitions group box, select the desired partition.

3. From the menu bar, select Partition > File Restore, or click the File Restore icon.

NOTE:  You may also double-click any image file or partition to activate File Restore.

4. Depending on the type of image file or partition you select, the following displays:

a. If you have selected a spanned or compressed image, the Associate Image Index 
dialog appears. For more information, see “Restoring Files from Spanned or 
Compressed Images” on page 100. If you assigned a password to your image file 
when you created it, Drive Image File Editor prompts you for a password. Enter the 
password you assigned to the image file, then click OK to continue.

After specifying options, the File Restore dialog appears.

b. If you have selected any other image file or partition, the File Restore dialog 
appears.

5. Use one of the following methods to select the files or folders you want to restore:

• Click to select a single file.

• Shift-click to select contiguous files.

• Ctrl-click to select non-contiguous files. 

• Double-click a folder to browse its contents. 
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• To return to the previous directory level, click the folder button to the right of the 
Look In field, or backtrack using the list in the Look In field or pressing 
<Backspace>.

• Type the filename directly into the File name field or use wildcard characters such 
as “*” and “?” to reduce the number of files listed.

NOTE:  The name of the selected file appears in the File name field. If multiple files 
are selected, (multiple files) appears in the File name field.

6. In the Target Directory field, enter the location where you want to save the restored 
files.

NOTE:  You may also click Browse to browse the directory tree for the desired target 
folder. Double-click on the target folder, then click Select.

7. Click Restore to restore the files. 

If you specified target folders that do not exist, you will be prompted to create new 
directories. Click Yes if you want to be prompted for each new directory, or click 
Create All if you want all selected folders to be created on the target drive.

Drive Image File Editor displays the following information:

• “Restoring File: <filename>”

• “To Directory: <directory name>”

• Progress indicator bar

8. When Drive Image File Editor completes restoring the files, click OK.

9. Click Close to return to the Drive Image File Editor main window.

Restoring Files from Spanned or Compressed Images

You can restore individual files or folders from spanned or compressed images without 
restoring the entire image file. You can select files and folders using a temporary index, or 
you can create a full index which will be saved for later use.

When you select spanned or compressed images and activate File Restore, the Associate 
Image Index dialog box appears. 
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Choose from the following image index options:

• Continue creates a temporary index. This temporary index is generated as needed 
and shows all files and folders. When you select a folder, it will take a few minutes to 
decompress the image and expand the index. The temporary index may be fully 
expanded and saved upon exiting File Restore.

• Create generates the complete index and saves it for future use. Creating a complete 
index will take several minutes depending on the size of the image file. Specify a 
directory and filename, then click Save.

• Browse lets you select an index if one has already been created and reassociate it 
with the image file. An image file ends with the extension .PQI. An index file ends 
with the extension .PQX.
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Overview

Drive Image Pro may be run in one of two modes: interactive (the default) or batch 
mode. Interactive mode requires user input at discrete intervals, resulting in greater 
control and efficiency when working with one or two workstations. To run Drive Image 
Pro in interactive mode, for example, you type PQDI at the DOS prompt.

Batch mode allows the user to control the operation of Drive Image Pro with a file of 
script commands. Scripting is especially useful for system administrators when loading 
image files onto a large number of workstations, as it automates the loading process and 
saves time by eliminating the need for user intervention.

Command Line Switches

To run in script mode, Drive Image Pro uses a series of command line switches. To use 
these switches, type PQDI  /switch, where switch is one or more of the available 
commands. For example, to invoke the command interpreter, use the /CMD=<scriptfile> 
command. If the name of the text file containing the script commands were 
C:\SCRIPTS\LABS.TXT, you would type

PQDI /CMD=C:\SCRIPTS\LABS.TXT

at the command line or in your batch file.

NOTE:  Because Drive Image Pro is run at a DOS prompt, you are limited to 128 characters 
on the command line.

Command Line 
Parameter

Description

/? Displays all available command line switches, their 
syntax, and a short description.

/IMG=<imagefilename> Designates an image file. The STORE and RESTORE 
commands will encounter an error if this option is not 
specified.

/CMD=<scriptfilename> Designates a script text file; the script file contains 
arguments that are passed to the program.

/LOG=<logfilename> Designates a log file. Because scripts execute without user 
intervention, these files are important for checking results.
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/ERR=<errorfilename> Designates an error file. Because scripts execute without 
user intervention, these files are important for checking 
errors.

/MSN=<sessionname> Specifies the name of the PowerCast session. Use together 
with /DSK to start Drive Image Pro in multicast client 
mode. Use together with /IMG to start Drive Image Pro in 
PowerCast server mode.

/ACC=<number> Specifies the number of PowerCast clients that must attach 
before the PowerCast server will automatically start 
sending the image file.

/SCO Syntax Check Only parameter; this switch causes the 
syntax of each command in the script file to be checked 
without executing the command. This is important when 
writing and debugging the script file.

/RPP Resizes partitions proportionally.

/WFS Wipes the first sector after deleting all partitions. This will 
insure that a fresh master boot record will be written to the 
destination disk; only accessible using scripting.

/HPC Hide partitions after copy.

/PWD=<password> Designates a password that must be given to restore the 
partition’s data. The password may be either a number or a 
string. This command will not password encrypt an image 
in a STORE script.

/ZLB Specifies to use the ZLIB compression used in Drive Image 
Pro 1.x and 2.x image files.

/CAS Switch causes every sector within a partition to be saved 
and restored. This will include all information in a 
partition including the deleted files. This option 
significantly slows down the imaging process and 
increases file size.

/SSO Store system structures only. This creates an image file that 
contains only the file system structures and no file data.

/IFC Ignores file system checks. This allows a partition with a 
known file system error (e.g. cross-linked files) to be 
stored in an image. Likewise, that same partition can be 
restored if this switch is used and if during the restore 
process the partition does not need to be resized.

/DSK Specifies disk number to use for restore or save operation.

/CMD=STORE_ALL This will store all partitions on the specified drive to the 
file specified by the /IMG= switch.

Command Line 
Parameter

Description
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Command Line Example
To specify SCRIPT.TXT as the script file, ERROR.TXT as the error file and 
E:\IMAGES\DRIVE2.PQI as the image file, enter the following:

PQDI /CMD=SCRIPT.TXT /ERR=ERROR.TXT /IMG=E:\IMAGES\DRIVE2.PQI

Script Files

The script file designated in the command line contains arguments or instructions that 
are passed to the program, determining which operations are executed. 

Because the scripts execute without user intervention, use extra care when developing 
the script file. For example, if the DELETE ALL command is encountered, all the 
partitions on the currently selected drive will be deleted without any warning or 
confirmation messages which would normally allow the user to cancel the operation.

/CMD=RESTORE_ALL This will restore all partitions in the image file to the 
specified drive.

/MFS=nnnnn Designates the maximum number of bytes that an 
individual image file can be. (nnnnn is the number of 
bytes in each file. The mininum number is 10000000.) 
When the specified size is reached, a second image is 
started.

/NBS Disables bad sector checking. By default bad sector 
checking is disabled.

/CBS Enables bad sector checking.

/UEB Forces the extended BIOS to be used for disk reads and 
writes.

/CEC Checks for an extra cylinder. This corrects a problem of the 
BIOS and DOS reporting different maximum cylinder 
numbers.

/RAV Equivalent of Verify Disk Writes. Causes each sector 
restored to disk to be read back and compared as an extra 
security precaution. Using this parameter will significantly 
increase restore time.

/NRB Suppresses the normal reboot during program exit.

Command Line 
Parameter

Description
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Script Argument Action

SELECT DRIVE {<number>} Selects the drive of the number specified. For example, 
SELECT DRIVE 1 selects the first hard drive in the system. 
After this command, all other commands refer to drive 1 
until another SELECT DRIVE command is given.

SELECT PARTITION <number> Selects the specified partition by number on the currently 
selected drive. Partitions are numbered in the order of 
their starting sector number on the disk, excluding any 
extended partitions or free spaces.

SELECT PARTITION <driveletter> Selects the partition assigned the specified drive letter by 
DOS. Since DOS only assigns drive letters to visible FAT 
partitions, only these types of partitions can be selected 
using this command.

SELECT PARTITION <volumelabel> Selects the first partition with the specified volume label. 
For example, SELECT PARTITION “DATA” selects the first 
partition labeled “DATA.” If more than one partition has 
this label (including FAT32, NTFS, and HPFS partitions), 
only the first one is selected.

SELECT PARTITION FIRST Selects the first partition.

SELECT PARTITION NEXT Selects the partition immediately following the last 
selected partition regardless of the syntax used to select 
that partition.

SELECT PARTITION ALL Selects all the partitions on the currently selected drive.

SELECT FREESPACE {first | last | 
next | largest}

Selects the specified free space on the currently selected 
drive. When selecting the largest free space, it does not 
matter whether the free space is inside or outside of the 
extended partition.

SELECT IMAGE {<number> | all} Selects the specified image in the image file. For 
example, SELECT IMAGE 3 or SELECT IMAGE ALL.

PROTECT PARTITION FIRST Protects the first partition from being deleted.

PROTECT PARTITION LAST Protects the last partition from being deleted.

PROTECT PARTITION 
DIAGNOSTIC

Protects the first valid partition of an unknown type from 
being deleted.

DELETE Deletes the last partition selected using any of the 
SELECT PARTITION commands.

DELETE ALL Deletes all partitions on the currently selected drive 
without having to select them.

DELETE EXTENDED Deletes the extended partition; the extended partition 
can only be deleted after all the logical drives within it 
have been deleted.
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SECTOR CHECK ON Enables Bad Sector Checking for all restore operations 
following the command. An alternative to /CBS if you 
need Bad Sector Checking off for some partitions and on 
for others.

SECTOR CHECK OFF Disables Bad Sector Checking for all restore operations 
following the command. An alternative to /NBS if you 
need Bad Sector Checking on for some partitions and off 
for others.

SET ACTIVE Sets the last partition selected as the active partition 
(meaning it will be the boot partition).

STORE Stores selected partitions with no compression.

STORE WITH COMPRESSION OFF Stores selected partitions with no compression.

STORE WITH COMPRESSION LOW Stores selected partitions with low compression.

STORE WITH COMPRESSION 
HIGH 

Stores selected partitions with high compression.

RESIZE IMAGE NO Causes the last selected image to not be resized when the 
RESTORE command is encountered.

RESIZE IMAGE PROPORTIONAL Proportionally resizes the last selected image when the 
RESTORE command is encountered.

RESIZE IMAGE <number> Resizes the last selected image to the specified number 
(in MB) when the RESTORE command is encountered.

RESIZE IMAGE MAX Resizes the last selected image to the maximum size 
possible. If this is used in a situation where the partition 
can take up the rest of the drive, it will fill up the drive.

RESIZE IMAGE MOST SPACE Resizes the partition with the most free space. 1) Ignores 
“Resize Image Proportional” and treats it as “Resize 
Image No.” 2) Ignores “Resize Image Max” and treats it 
as “Resize Image No” and 3) Considers “Resize Image 
<value> as valid, causing the partition to be excluded 
from consideration when calculating the MOST SPACE.

RESTORE Downloads all selected images into the free space and 
resizes them accoring to the RESIZE commands, if any.

REBOOT Reboots the computer; any commands following this 
command will not be executed.

Script Argument Action
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Script File Examples
Scenario 1: To store all the partitions on drive 2 to the file, E:\IMAGES\DRIVE2.PQI:

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVE2.PQI

SCRIPT.TXT file contents:

SELECT DRIVE 2
SELECT PARTITION ALL
STORE

Scenario 2: To store partition 3 from drive 1, and partitions 1, 4 and 5 from drive 2 to the 
file, E:\IMAGES\DRIVES.PQI and have the image file split up into multiple files each 
650 MB so each can be transferred to a CD-ROM:

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI /MFS=650000000

SCRIPT.TXT file contents:

SELECT DRIVE 1
SELECT PARTITION 3
STORE
SELECT DRIVE 2
SELECT PARTITION 1
SELECT PARTITION 4
SELECT PARTITION 5
STORE

Scenario 3: To restore all the images in the file, E:\IMAGES\DRIVES.PQI, to the first free 
space on drive 2:

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI

SCRIPT.TXT file contents:

SELECT DRIVE 2
SELECT FREESPACE FIRST
SELECT IMAGE ALL
RESTORE

Scenario 4: To restore the first two images in the file, E:\IMAGES\DRIVES.PQI, to the 
largest free space on drive 1 and resize them both proportionally:

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI
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SCRIPT.TXT file contents:

SELECT DRIVE 1
SELECT FREESPACE LARGEST
SELECT IMAGE 1
SELECT IMAGE 2
RESIZE IMAGE PROPORTIONAL
RESTORE

Scenario 5: To restore the first two images in the file, E:\IMAGES\DRIVES.PQI, to the last 
free space on drive 1 and resize them to 500 MB each (the image was encrypted using 
the password 12345678):

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI /PWD=12345678

SCRIPT.TXT file contents:

SELECT DRIVE 1
SELECT FREESPACE LAST
SELECT IMAGE 1
RESIZE IMAGE 500
SELECT IMAGE 2
RESIZE IMAGE 500
RESTORE

Scenario 6: To delete all existing partitions on drive 2 and then restore all the images in 
the file, E:\IMAGES\DRIVES.PQI, to the free space (the image was encrypted using the 
password HELLO):

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI /PWD=HELLO

SCRIPT.TXT file contents:

SELECT DRIVE 2
DELETE ALL
SELECT FREESPACE FIRST
SELECT IMAGE ALL
RESTORE

Scenario 7: To restore the first four images in the file, E:\IMAGES\DRIVES.PQI, to the last 
free space on drive 1, and then resize the first image to 500 MB, keep the second the 
same size, and resize the third and fourth images to proportionally take up the remaining 
free space:

PQDI /CMD=SCRIPT.TXT /IMG=E:\IMAGES\DRIVES.PQI
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SCRIPT.TXT file contents:

SELECT DRIVE 1
SELECT FREESPACE LAST
SELECT IMAGE 1
RESIZE IMAGE 500
SELECT IMAGE 2
RESIZE IMAGE NO
SELECT IMAGE 3
SELECT IMAGE 4
RESIZE IMAGE PROPORTIONAL
RESTORE

Scenario 8: To start Drive Image Pro as a server, then start a PowerCast session named 
SESSION_1 and an image file named IMAGE_1,

PQDI /MSN=SESSION_1 /IMG=IMAGE_1

To start Drive Image Pro as a client, then start a PowerCast session named SESSION_1 
and restore the current image to drive 1,

PQDI /MSN=SESSION_1 /DSK=1

More Script File Examples
You can find additional script file examples at the PowerQuest web site at 
http://support.powerquest.com/di/di1011.html.
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Overview

PowerQuest’s DeltaNow works in conjunction with Drive Image Pro to help manage 
changing desktop environments. Using Drive Image Pro, an IS manager creates a 
standard desktop image file, for example, of just the operating system. Then using 
DeltaNow, the IS manager creates a custom installation of selected applications. The 
resultant “packaged install” can then be distributed to client computers along with the 
image file.

Using Drive Image Pro and DeltaNow together in this way, you can use one image file to 
configure the same operating system to all computers then use DeltaNow to create 
custom application installations to different subsets of these computers.

Setting Up the Platform Computer

The platform computer may be a standalone computer or a computer attached to a 
peer-to-peer network. This is the computer that will be running the application 
installations and building the DeltaNow installation executable.

Since DeltaNow uses the platform computer as a baseline, it is important to choose a 
computer or prepare one that is similar to or has less than up-to-date configuration 
information than the computers that you will be installing to. PowerQuest recommends 
that you use a dedicated machine with only the operating system and network 
connectivity and no other applications installed.

1. Install DeltaNow on the platform computer. To do so, start the Drive Image Pro 
installation program (for Windows 95/98/NT), click Install Other Applications > 
Install DeltaNow, then finish the installation.

2. Disable any programs that are running in the background.

3. If you expect a reboot at the end of the installation program you will be packaging, 
disable any programs that execute during the rebooting process, except for network 
connectivity.

Limitations
Please not the following limitations of DeltaNow-created application installations.

• Some applications allow for a rescue disk to be built at the end of their install. When 
DeltaNow creates a custom install of these applications, the user will not be able to 
make rescue disks from the DeltaNow-created application.
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• Some applications, such as graphics software, may still access the CD after it is 
installed. This will still be the case from the DeltaNow-created application of that 
software.

• A few software applications require the CD if the user chooses to uninstall the 
software. If the user decides to uninstall one of these software applications, which 
was installed from a DeltaNow-created application, they will still require the original 
CD to uninstall the software.

Creating the Installation Package

DeltaNow first reads the configuration of the platform computer’s hard drive and uses it 
as the baseline. Then you specify the installation programs you want in the package and 
run them as you would have users do. DeltaNow monitors this installation for 
duplication in the installation package.

Finally, DeltaNow compares the baseline with changes made by the installed 
applications (to file systems and system registry), then builds the installation package.

1. Click the DeltaNow icon.

2. Click Options if you want to change any of the following:

a. Click Add to specify a search path that will limit or expand the monitoring 
process. Restricting the drives or partitions will speed the process.

b. To delete a search path, select it, then click Remove.

c. Specify a destination for writing temporary files. This is a working directory and 
should be empty as it is automatically purged at regular intervals, except for the 
resultant installation packages.

3. Click OK if specifying options. Click Next to begin reading the configuration.

DeltaNow checks the file system and registry information.

4. At the Start your installation dialog, specify the location of the installation program 
you want DeltaNow to monitor.

5. Click Monitor to begin the application’s installation program.
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6. As the installation program runs, select the options that would be needed to install 
the program on client computers.

If the installation program requires or suggests that the computer be rebooted, do so. 
After the computer has rebooted and any additional installation programs have run, 
the DeltaNow dialog displays. Click Yes to continue.

After clicking Yes or after an ordinary installation, the Compare dialog appears.

7. The default package name is INSTALL. Type in a new name if you want to change it.

8. If you want to add another installation program to the package, click Back and run 
another installation program.

For example, you could add applications to create a customized suite of software, or 
you could install a software package and its corresponding service pack.

9. Click Back and run the installation program for as many programs as you want to 
add.

10. When finished adding software, click Next in the Compare dialog.

DeltaNow scans your file system and registry for changes created during the 
installation and places these changes into the INSTALL.CFG file. When the CFG file 
has been created, an information screen displays the location of the file.

11. Click OK to continue.

The Ready to build dialog appears.

12. Click Build to create the DeltaNow executable from the INSTALL.CFG.

A progress dialog appears showing the build process. Once the build is complete, a 
Process Complete dialog appears notifying you where the DeltaNow executable can 
be found.

13. Click Finish to exit DeltaNow.

14. Copy the packaged installation to the distribution server where clients can access the 
DeltaNow executable.

The packaged installation file can be placed onto a distribution server where the clients 
can access and execute it, or it can be included in a new image file for direct distribution 
to client computers. If the packaged installation file is accessed from the distribution 
server, it should be executed after the client computer is booted and logged onto the 
network. If the packaged installation file is included in a new image file, it can be 
executed on the client computer after first boot-up.
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Scenarios

Scenario 1
The IS department must install a new company-wide application of Intuit’s Expensible 
program on 50 workstations. It needs to be done by Monday morning. Each install, done 
manually, takes 15 minutes. The product ships on floppy disks. To visit each workstation 
and perform the installation manually will take hours. All of these systems are connected 
to the network and have e-mail.

Using DeltaNow, the IS department could create an executable program for the 
complete installation of Expensible. They could then attach the executable to an e-mail 
message, have the users point to it on the network, or burn it to a CD and run the install 
on each workstation. With DeltaNow, the complete installation of Expensible takes 
about 45 seconds.

Scenario 2
A configuration center responsible for setting up hundreds of systems every day is running 
out of disk space because of all the image files they must maintain. They have hundreds of 
different images because of the wide variety of offerings that they give the customer. This 
is a waste of disk space and time.  Deploying large images also takes a lot of time.  

With Drive Image Pro 3.0 and DeltaNow, the configuration center could have baseline 
images for the main operating systems and a variety of DeltaNow files for the custom 
setups. For example, one DeltaNow file could contain Microsoft Office 97, while 
another could contain Corel’s WordPerfect Suite 8. To update something as simple as a 
driver on the systems, they can use DeltaNow. To install the complete Microsoft Office 
97 could take 18 minutes; with DeltaNow, it takes 3 minutes and 10 seconds.

Scenario 3
A network administrator reads about a security loophole that can be closed by making a 
registry change in Windows 95/98. Using DeltaNow, the security admin makes the 
appropriate change, places the DeltaNow package on the network, and changes the 
network login script to automatically apply the change at startup. Now all of the systems 
will be automatically updated without human intervention.

Scenario 4
A new driver is available for a network card that greatly improves performance.  The 
network administrator applies the new driver and generates a DeltaNow package. 
Looking at the NET.CFG or a registry key, the administrator can determine the system 
setup and automatically deploy the driver update via the network login script.
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Overview

The PowerQuest Drive Image Pro BootDisk Builder helps you build DOS boot disks 
specific to your network and network interface card. The DOS boot disks are required for 
PowerCasting. To restore image files from a network, all client computers must boot from 
DOS and have a network connection. Therefore, all client computers need a DOS boot 
diskette configured for their specific network needs.

BootDisk Builder is installed during the Drive Image Pro installation, and an icon is 
created for the desktop. When you run BootDisk Builder, it gathers information from 
your responses, then builds the boot disks.

The BootDisk Builder utility must be run on a Windows 95 or Windows 98 system.

Creating DOS Boot Disks for PowerCasting

1. Click the BootDisk Builder icon, then click Create PowerCast Diskettes.

2. Specify the path and filename of the Drive Image Pro EXE (PDQI.EXE), then click 
Next.

3. Select the type of network card you are using from the list. If it is not listed, click 
Have Disk and specify the location of the DOS ODI or NDIS driver for your network 
card. After selecting the network card, click Next.

4. Specify whether the network card is plug-n-play, then click Next.

If you have selected No for plug-n-play, the following dialog displays:

Specify IRQ and Base I/O Address information, then click Next. It is important to 
avoid conflicts with other devices. For more information, check your DOS 
documentation. 

5. Specify the client IP address and hostname.

a. If you are using a DHCP server, click DHCP. If not, specify an IP address and 
Subnet mask.

On a DHCP server, the IP address is leased out temporarily on a first-come, 
first-served basis and increments automatically. If you are typing in a permanent IP 
address, you can also click Auto increment. When this option is selected, the IP 
address will increment each time another boot disk is created.
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b. Click Auto assign to have BootDisk Builder assign a hostname, or specify one of 
your own.

c. Click Next.

6. Specify the disk number and session name parameters.

7. Specify the drive letter where you are creating the DOS boot diskette.

a. If the diskette has not been formatted, you can click Format and format the diskette now. 
You must select Copy system files in the Other options group box of the Format dialog.

NOTE:  Before starting the build process, you can format disks from the main 
BootDisk Builder screen by clicking Tools > Format.

b. Click Next.

8. If you want to save your choices for use at a later time, click Save Configuration, then 
name and save the file.

NOTE:  To retrieve a configuration, click File > Load Configuration on the main 
BootDisk Builder screen.

9. Click Back if you want to make any changes. When you are ready to build the boot 
disk, click Finish. The status bar displays the progress.

Depending on the network interface card selected, the network and Drive Image Pro 
files may require two diskettes. You will be prompted if a second diskette is needed.

After the boot disk has been created, can choose to create another boot disk.

When a client computer is booted from the boot diskettes, Drive Image Pro will start in 
PowerCast client mode, connect to a PowerCast session named SESSION1, and restore 
the image to the first hard drive. This will completely erase any existing information on 
the first hard drive. To change these options, edit the AUTOEXEC.BAT file.

Creating DOS Boot Disks for NetWare

1. Click the BootDisk Builder icon, then click Create Standalone Diskettes.

2. Select Novell NetWare, then click Next.

3. Select the correct Ethernet frame type for your network, then click Next.

The Novell NetWare information dialog displays.
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4. Specify Novell network information.

a. To map a network drive, specify the drive letter, or click Do Not Map. You can also 
type a path to add to the drive-letter mapping. 

b. Specify your network login drive (existing drive, not a drive to map) and login name, 
or click Do Not Login to network. 

c. Click Next.

5. Specify the path and filename of the Drive Image Pro EXE (PDQI.EXE), then click Next.

6. Select the type of network card you are using from the list. If it is not listed, click 
Have Disk and specify the location of the DOS ODI or NDIS driver for your network 
card. After selecting the network card, click Next.

7. Specify whether the network card is plug-n-play, then click Next.

a. If you have selected No for plug-n-play, specify IRQ and Base I/O Address 
information, then click Next. It is important to avoid conflicts with other devices. 
For more information, check your DOS documentation.

8. Specify the IP address and host name.

9. Specify the drive letter where you are creating the DOS boot diskette.

a. If the diskette has not been formatted, you can click Format and format the 
diskette now. You must select Copy system files in the Other options group box of 
the Format dialog.

NOTE:  Before starting the build process, you can format disks from the main 
BootDisk Builder screen by clicking Tools > Format.

b. Click Next.

10. If you want to save your choices for use at a later time, click Save Configuration, then 
name and save the file.

NOTE:  To retrieve a configuration, click File > Load Configuration from the main 
BootDisk Builder screen.
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11. Click Back if you want to make any changes. When you are ready to build the boot 
disk, click Finish. The status bar displays the progress.

NOTE:  Depending on the network interface card selected, the network and Drive 
Image Pro files may require two diskettes. You will be prompted if a second 
diskette is needed.

After the boot disk has been created, you can create another boot disk.

When you boot a computer from these diskettes, Drive Image Pro will start in graphical 
user interface (GUI) mode. You can then select any operations.

Creating DOS Boot Disks for Microsoft TCP/IP

1. Click the BootDisk Builder icon, then click Create Standalone Diskettes.

2. Select Microsoft TCP/IP, then click Next.

The Microsoft network information dialog displays.

3. Specify Microsoft network information.

a. Select the drive letter, and type the path of the Server drive.

b. Type the user’s Login name.

c. Select which login you are using: workgroup or domain. Then type in the name.

d. Click Next.

4. Specify the path and filename of the Drive Image Pro EXE (PDQI.EXE), then click Next.

5. Select the type of network card you are using from the list. If it is not listed, click 
Have Disk and specify the location of the DOS ODI or NDIS driver for your network 
card. After selecting the network card, click Next.

6. Specify whether the network card is plug-n-play, then click Next.

a. If you have selected No for plug-n-play, specify IRQ and Base I/O Address 
information, then click Next. It is important to avoid conflicts with other devices. 
For more information, check your DOS documentation.
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7. Specify the client IP address and hostname.

a. If you are using a DHCP server, click DHCP. If not, specify an IP address and 
Subnet mask.

On a DHCP server, the IP address is leased out temporarily on a first-come, 
first-served basis and increments automatically. If you type in a permanent IP 
address, you can also click Auto increment. When this option is selected, the IP 
address will increment each time a boot disk is created.

b. Click Auto assign to have BootDisk Builder assign a hostname, or specify one of 
your own.

c. Click Next.

8. Specify the drive letter where you are creating the DOS boot disk.

a. If the diskette has not been formatted, you can click Format and format the 
diskette now. You must select Copy system files in the Other options group box of 
the Format dialog.

NOTE:  Before starting the build process, you can format disks from the main 
BootDisk Builder screen by clicking Tools > Format.

b. Click Next.

9. If you want to save your choices for use at a later time, click Save Configuration, then 
name and save the file.

NOTE:  To retrieve a configuration, click File > Load Configuration from the main 
BootDisk Builder screen.

10. Click Back if you want to make any changes. When you are ready to build the boot 
disk, click Finish. The status bar displays the progress.

Depending on the network interface card selected, the network and Drive Image Pro 
files may require two diskettes. You will be prompted if a second diskette is needed.

11. After the boot disk has been created, you will have an option to create another boot 
disk.

When you boot a computer from these diskettes, Drive Image Pro will start in 
graphical user interface (GUI) mode. You can then select any operations.
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Creating DOS Boot Disks With No Network

1. Click the BootDisk Builder icon, then click Create Standalone Diskettes.

2. Select No Network, then click Next.

3. Specify the path and filename of the Drive Image Pro EXE (PDQI.EXE), then click 
Next.

4. Specify the drive letter where you are creating the DOS boot disk.

a. If the diskette has not been formatted, you can click Format and format the 
diskette now. You must select Copy system files in the Other options group box of 
the Format dialog.

NOTE:  Before starting the build process, you can format disks from the main 
BootDisk Builder screen by clicking Tools > Format.

b. Click Next.

5. If you want to save your choices for use at a later time, click Save Configuration then 
name and save the file.

NOTE:  To retrieve a configuration, click File > Load Configuration from the main 
BootDisk Builder screen.

6. Click Back if you want to make any changes. When you are ready to build the boot 
disk, click Finish. The status bar displays the progress.

After the boot disk has been created, you can create another boot disk.

When you boot a computer from these diskettes, Drive Image Pro will start in graphical 
user interface (GUI) mode. You can then select any operations.
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Modifying Existing DOS Boot Disks

To change the client IP address or hostname on existing disks, 

1. Click the BootDisk Builder icon, then click Modifying Existing Diskettes.

The Update Client IP Address and Hostname dialog displays.

2. Change the client IP address and hostname, then click Next.

3. Specify the drive letter where you are modifying the DOS boot disk, then click Next.

4. Click Finish to modify the boot disk.

After the boot disk has been modified, you will have an option to modify another 
boot disk.
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Additional Tasks

This appendix contains the following information: 

Using FDISK and FORMAT to Create and Format Partitions

Using Drive Image Pro with SCSI Hard Drives

Using Drive Image Pro with an Older Computer BIOS that Requires 
Drive Overlay Software 

Making the Operating System Assign a CD-ROM Drive Letter

Converting Ghost Image Files to Drive Image Pro

About PartitionMagic
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Using FDISK and FORMAT to Create and Format 
Partitions

NOTE:  Although FDISK and FORMAT do not offer the functionality and flexibility of 
PartitionMagic, these free utilities are capable of creating new FAT partitions or 
deleting existing partitions.

This section explains how to create and delete partitions for the following situations:

Scenario 1:
If you copied a single FAT partition (C: drive) from your source hard drive to a destination 
hard drive larger than 2.1 GB, you now have unallocated disk space and need to create a 
partition. To create and format a partition using FDISK and FORMAT, follow these simple 
steps:

NOTE:  Using FDISK to create partitions from unallocated disk space is simple and will 
NOT destroy any existing data on the hard drive. FDISK, however, will NOT allow 
you to change partition sizes without destroying data.

1. At a DOS or MS-DOS prompt, type FDISK and press <ENTER>.

2. Select 1 to Create DOS partition or Logical DOS Drive and press <ENTER>.

3. Select 2 to Create Extended DOS partition and press <ENTER>.

4. Press <ENTER> again to create the extended DOS partition.

5. Press <ESC>.

6. Press <ENTER> to create the logical DOS drive within the extended partition.

7. If your hard drive is larger than 4 GB, you can create a second logical DOS partition 
with the remaining disk space. To do so press <ENTER>.

8. Press <ESC> twice to return to a DOS or MS-DOS prompt.

To format your new partition type FORMAT drive: at a DOS or MS-DOS prompt, 
where drive: is the drive letter of the new partition. You will now have additional 
partitions on your destination hard drive (example D:, E:).
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Scenario 2:
If you want to leave your source drive in as a secondary or Slave drive after the copy, you 
need to delete and recreate partitions so that drive letters will not conflict. To delete and 
recreate partitions on your source hard drive after the copy process is finished, follow 
these steps:

NOTE:  This process will delete the data on this hard drive; however, you have a complete 
copy on your destination drive.

1. If you have not already done so, change the jumper settings on the original source 
drive to reflect a secondary or Slave setting in a two drive system. Then switch the 
jumper settings on the destination drive to reflect a primary or Master setting in a two 
drive system.

2. At a DOS or MS-DOS prompt type FDISK and press <ENTER>.

NOTE:  If you are asked whether you wish to enable large disk support, click YES and 
press <ENTER> UNLESS you plan on using other operating systems on your PC, 
including some versions of Windows 95 and Windows NT, as well as earlier 
versions of Windows and MS-DOS.

3. Select 5 to Change Current Fixed Disk Drive and press <ENTER>.

4. At the Change Current Disk Drive screen, choose 2 to change to your second disk 
drive and press <ENTER>.

5. Select 3 to Delete partition or Logical DOS drive, then press <ENTER>.

6. Choose to delete your logical drives first, then your extended partition, and finally 
your primary partition. Or if you only have one partition on your source hard drive, 
choose to delete the single primary partition.

7. Select 1 to Create DOS partition or Logical DOS Drive and press <ENTER>.

8. Select 2 to Create Extended DOS partition and press <ENTER>.

9. Press <ENTER> again to create the extended DOS partition.

10. Press <ESC>. 

11. Press <ENTER> to create the logical DOS Drive within the extended partition.

12. If your hard drive is larger than 4 GB, you can create a second Logical DOS partition 
with the remaining disk space. To do so press <ENTER>.
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13. Press the <ESC> key twice to return to a DOS or MS-DOS prompt.

14. To format your new partition, type FORMAT <drive:> at a DOS or MS-DOS prompt, 
where drive is the drive letter of the new partition.

You now have a new empty partition in which to store your applications and data.

Using Drive Image Pro with SCSI Hard Drives

To use Drive Image Pro on a SCSI hard drive, you must have a SCSI controller card that 
supports software Interrupt 13. Most SCSI controller cards let the user enable software 
Interrupt 13 support in the BIOS through the card. If your SCSI controller card does not 
allow you to set it to use software Interrupt 13, Drive Image Pro will not work on drives 
attached to your SCSI adapter. Contact the manufacturer of the SCSI adapter to determine 
if your adapter can support software Interrupt 13. As a general rule, if FDISK can be used 
to partition the drive, you can use Drive Image Pro.

Using Drive Image Pro with an Older Computer BIOS 
that Requires Drive Overlay Software

Drive overlay software is needed, such as Disk Manager or EZ-Drive, if the system has an 
older BIOS and the disk copy is being made from IDE to IDE or IDE to SCSI. 

NOTE:  If copying SCSI to SCSI, the older BIOS does not come into play because SCSI has 
its own translation mechanism. 

This section provides information on both IDE and SCSI hard drive installations. The 
following are scenarios which outline, step-by-step, the installation procedures for a 
variety of system configurations.

Scenario 1:

• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive that is smaller than 504 MB. It does not have a drive 
overlay program.

• The destination drive is an IDE drive that is larger than 504 MB and needs to have a 
drive overlay program in order to be recognized by the older BIOS.
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Steps:

1. Install the destination drive as the Master and the source drive as the Slave and run 
the auto-detect in the BIOS.

2. Restart the computer with the drive overlay boot disk.

3. Install the drive overlay program to the destination drive that is now set as the Master 
(check with manufacturer).

4. Restart the computer again, allowing the drive overlay program to load.

5. Put your Drive Image Pro bootable diskette in your diskette drive (A:).

6. In the drive overlay boot menu, select the option to boot from a floppy disk.

7. Make sure that Drive Image Pro is showing the correct size for each drive and the 
correct order for the copy sequence.

8.  Finish the copy process.

Scenario 2:

• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
loaded.

• The destination is a SCSI drive and will not need a drive overlay program.

Steps:

1. Leave the source drive set as the Master.

2. Install the SCSI drive with the lowest SCSI ID in the SCSI chain.

3. Run the BIOS auto-detect and make sure it recognizes the IDE drive.

4. Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.

5. Restart the computer and allow the drive overlay program to load. 

6. Put your Drive Image Pro bootable diskette in your diskette drive (A:).

7. In the drive overlay boot menu, select the option to boot from a floppy disk.
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8. Make sure that Drive Image Pro is showing the correct size for each drive and the 
correct order for the copy sequence.

9. Finish the copy process.

Scenario 3:

• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
installed.

• The BIOS is upgraded to a BIOS that supports larger drives.

• The destination drive is a SCSI drive that is larger than 504 MB.

Steps:

1. Leave the source drive set as the Master.

2. Install the destination drive and set it as drive 0.

3. Run the BIOS and auto-detect the drives.

4. Make sure that LBA is off for the source drive.

5. Run the SCSI BIOS to make sure the SCSI drive is recognized correctly.

6. Restart the computer and allow the drive overlay program to load. 

7. Put your Drive Image Pro bootable diskette in your diskette drive (A:).

8. In the drive overlay boot menu, select the option to boot from a floppy disk.

9. Make sure that Drive Image Pro is showing the correct size for each drive and the 
correct order for the copy sequence.

10. Finish the copy process.

Scenario 4:

• The system has a BIOS that does not support drives over 504 MB in size.

• The source drive is an IDE drive larger than 504 MB and a drive overlay program is 
installed.
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• The BIOS is upgraded to a BIOS that supports larger drives.

• The destination is an IDE drive that is larger than 504 MB.

Steps:

1. Set the source drive as the Master.

2. Set the destination drive as the Slave.

3. Run the new BIOS and auto-detect the drives.

4. Make sure that LBA is turned on for the destination drive and off for the source drive.

5. Restart the computer and allow the drive overlay program to load. 

6. Put your Drive Image Pro bootable diskette in your diskette drive (A:).

7. In the drive overlay boot menu, select the option to boot from a floppy disk.

8. Make sure that Drive Image Pro is showing the correct size for each drive and the 
correct order for the copy sequence.

9. Finish the copy process.

Making the Operating System Assign a CD-ROM 
Drive Letter

If your computer has a CD-ROM drive or any form of removable media, you should be 
aware of potential problems with the way drive letters are assigned to these devices.

Drive Image Pro does not make drive letter assignments; this is a function of the 
operating system. The operating system assigns drive letters in the following order: The 
first recognized primary partition on each hard drive will receive a letter, followed by all 
logical partitions on each hard drive. Next, the CD-ROM drive and any other form of 
removable media will be assigned a letter.

Because the CD-ROM is one of the last drives to receive a letter, any partitions that you 
create or delete on any of your hard drives will affect the drive letter assignment of your 
CD-ROM drive. This change in drive letter assignments is usually performed by the 
operating system automatically. Occasionally, however, the operating system will fail to 
assign a new drive letter to the CD-ROM drive. If this should occur, please follow the 
steps:
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If you are using DOS/Windows 3.11 or are loading your CD-ROM drivers under DOS 
with Windows 95, perform the following:

1. At a DOS prompt, type EDIT C:\CONFIG.SYS.

This starts the DOS editor program and opens your CONFIG.SYS file. 

2. Change LASTDRIVE=drive (in which drive is any letter of the alphabet) to Z.

This allows the OS to assign all drive letters through Z.

3. Click File > Exit.

4. Click Yes to save the file.

5. You should now be back to a C:\ prompt. Type EDIT C:\AUTOEXEC.BAT.

The DOS editor program starts and opens your AUTOEXEC.BAT file. 

6. Look for a line that includes the word MSCDEX. The /L:drive parameter (in which 
drive is the drive letter that was assigned to your CD-ROM before you made changes 
with Drive Image Pro) may appear at the end of this line. Change this letter to Z. 

Because the OS assigns all other available drive letters before assigning Z, this 
ensures that partition changes you make in the future will not invalidate your 
CD-ROM drive letter. 

For more information, type HELP MSCDEX at a DOS prompt.

NOTE:  If your computer is on a network, when you log in to the network the letter Z 
and other letters at the end of the alphabet may be assigned to network search 
drives. In this case, assign your CD-ROM a letter just before the first letter used 
by the network search drives.

7. Select File > Exit. When you are asked whether you want to save the file, click Yes.

8. When you see the DOS prompt (C:\), reboot your machine.

If you are using Windows 95 and Windows 95 drivers for the CD-ROM:

1. Click Start > Settings > Control Panel > System.

2. From the System Properties screen, select Device Manager.

This brings up a list of the devices in your computer. 

3. Double-click CDROM.
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4. Click the Settings tab.

5. At the bottom of the Settings page is the heading, Reserved Drive Letters. Under this 
heading are two listings, Start Drive Letter and End Drive Letter. Change the values 
for these listings to Z. 

Because the OS assigns all other available drive letters before assigning Z, this 
ensures that partition changes you make in the future will not invalidate your 
CD-ROM drive letter.

6. Click OK to close the Settings page. 

7. Click OK to close the System Properties page.

8. Click Yes to restart your computer.

Converting Ghost Image Files to Drive Image Pro

Three sample batch files are included on the Drive Image Pro CD in the 
\SETUP\OS2DOS directory to help you convert existing Ghost Image files to Drive 
Image Pro files. This process requires a computer with a connection to a scratch hard 
drive which is large enough to contain the largest restored Ghost image.

The batch files restore the Ghost image to the scratch hard drive, then create a Drive 
Image Pro file from that hard drive using Drive Image Pro. Any existing data on the 
scratch hard drive is overwritten when the Ghost image is restored to it. To preserve a 
computer’s primary hard drive, the scratch drive can be a second drive.

The batch files are PQCVT.BAT, PQCVT2.BAT, and PQCVT3.BAT.

Using PQCVT.BAT
Use PQCVT.BAT when you want to specify program paths, image filenames, and 
working disk information on the command line.
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To run the batch file, provide the following arguments:

PQCVT <Ghost exe path > < Ghost image file path > < Drive Image Pro exe 
path > < Drive Image Pro image file path > < disk drive number >

For Example

PGCVT S:\BIN\GHO210 T:\OLD\I12345.GHO S:\BIN\DM T:\NEW\I12345.PQI 2

This example runs the Ghost program found at s:\bin\gho210 , then restores the image 
file t:\old\i12345.gho  to disk drive 2. It then runs the Drive Image Pro program found 
at s:\bin\dm  and builds a new image file at t:\new\i12345.pqi  from drive 2.

A log file can be created by executing the batch file from the command shell and 
redirecting the output. For example,

COMMAND/C PQCVT IMAGE.GHO >CVT.LOG

Modifying PQCVT2.BAT
Use the PQCVT2.BAT file when you want to “hard wire” program paths and working 
disk information. When you enter this information in the batch file itself, you only need 
to enter one argument in the batch command line: the image file name. For example,

PQCVT2 I12345

After the paths are edited in the PQCVT2.BAT file, it will run the Ghost Image program, 
restore the image file I12345.GHO to the second hard drive, then run the Drive Image 
Pro program and create the new image file.

Arguments Description

<Ghost EXE path> Full path to Ghost EXE program

<Ghost image file path> Full path to existing Ghost image file to be converted

<Drive Image Pro EXE path> Full path to Drive Image Pro EXE program

<Drive Image Pro image file 
path>

Full path to the new Drive Image Pro file 

<disk drive number> Working disk drive number, 1=first, 2=second, etc.
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To modify the batch file,

1. Retrieve the PQCVT2.BAT file into a DOS text editor such as Notepad or DOS Editor.

2. Edit the file and replace all occurrences of ggg1, ggg2, ddd1, ddd2, and 9999, with 
the path information for the Ghost executable, new image files, and drive number 
respectively.

3. Remove the first GOTO line following the REM statements, then save the file.

Converting Multiple Files

To convert several existing Ghost Image files, use the PQCVT3.BAT file as follows:

PQCVT3 <file path and pattern >

This batch command scans the directory looking for Ghost image files and calls the 
PQCVT2 batch command for each file that matches the file pattern specified. Rather than 
specify an exact file, use MS-DOS conventions where “*” equals any number of 
characters and “?” equals any single character.

About PartitionMagic

In addition to Drive Image Pro, PowerQuest Corporation makes PartitionMagic. 
PartitionMagic is a utility that lets you reclaim wasted disk space, safely boot and run 
multiple operating systems, and organize and protect your data. 

Reclaim Wasted Disk Space
Up to 40% of your hard drive may be wasted due to inefficient storage methods. 
PartitionMagic increases your usable disk space by shrinking large FAT partitions and 
restructuring cluster sizes to reclaim up to hundreds of megabytes of lost disk space.

Safely Run Multiple Operating Systems
PartitionMagic makes it easy to run multiple operating systems on the same machine 
without compatibility problems. Explore the world of Windows 95/98 or NT while still 
relying on the security of your current operating system.
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Organize and Protect Data
Create physically separate partitions for your valuable data files to protect them from 
potentially unstable applications and operating systems. This simplifies backups, 
especially to devices like Zip drives. PartitionMagic includes a utility that lets you move 
applications from one partition to another with their files and operating system settings in 
place. With PartitionMagic it’s easy to create, resize, move, and convert hard drive 
partitions on the fly.

Additional Benefits
Once you organize, optimize, and secure your hard drive, you can take advantage of 
PartitionMagic's other useful features. For instance, you can view comprehensive 
information about your hard-disk geometry and your hardware system. You can also 
resize root directories in Windows 95/98 to make room for more long filenames. With 
PartitionMagic, configuring your hard drive has never been simpler.
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Setting Up Removable Storage 
Devices

This appendix describes removable media device drivers included with Drive 
Image Pro and how to manually install them on a hard drive or diskette.

Both the Drive Image Pro install program (for Windows) and the 
MAKEDISK.BAT file (for OS/2 and DOS) install and configure the drivers for 
removable storage devices. This information is provided for those who want to 
manually configure these drivers or alter the standard configuration. For more 
information about MAKEDISK.BAT, see “Installing on an OS/2 or DOS Only 
Computer” on page 5.

Iomega Drivers

Iomega provides a driver loader program that allows you to load drivers from 
the AUTOEXEC.BAT file. Each time the Iomega driver program loads, it must 
also load an ASPI manager to communicate with the Zip or Jaz drive. The Drive 
Image Pro install program copies a large set of ASPI managers to the DRIVERS 
directory for SCSI, IDE, and Parallel Port interfaces.

The Iomega driver program tries to load each ASPI manager until it finds one 
that matches. If it does not have to use this trial-and-error process to find the 
correct ASPI manager, it can load more quickly.
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Editing Your GUEST.INI File
If you use only one or two specific host adapters, you may want to edit the GUEST.INI 
file and remark (using the REM command) the ASPI managers you do not need. This way 
only the ASPI managers you normally use will be loaded and tested.

1. From the DRIVERS directory where you installed Drive Image Pro, locate the 
GUEST.INI file and open it using Notepad in Windows, DOS EDIT, or any other ASCII 
text editor.

2. Find the ASPI manager line for the Iomega driver that supports your drive. For 
example, if you routinely use an Iomega PC1616 adapter, use the line that reads 
ASPI=ASPI1616.SYS.

The following table lists the supported Iomega Adapters and their corresponding ASPI 
managers.

        

3. Add a REM at the beginning of each ASPI manager line you do not want to load.

For example, in a case where the Zip or Jaz drive is connected to an Iomega PC1616 
adapter, you would remark all ASPI manager lines except ASPI1616.SYS:

REM ASPI=ASPIPPM1.SYS /INFO FILE=NIBBLE.ILM SPEED= 1

REM ASPI=ASPIIDE.SYS /INFO

REM ASPI=ASPI8DOS.SYS /D

REM ASPI=ADVASPI.SYS

Iomega Adapter ASPI Manager

Jaz jet PCI (PC/Mac model) ADVASPI.SYS

Jaz jet (PC-only model) ASPI8DOS.SYS

Jaz jet ISA ASPIPC16.SYS

Jaz Traveller ASPIPPM1.SYS

Parallel Port Zip drive ASPIPPM1.SYS

Zip zoom SCSI Accelerator ASPIPC16.SYS

Zip Card PCMCIA SCSI adapter ASPIPC16.SYS

Zip IDE drive ASPIIDE.SYS

PC1616 adapter ASPI1616.SYS

PC1600 adapter ASPIPC16.SYS
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REM ASPI=ASPIPC16.SYS INFO

ASPI=ASPI1616.SYS /SCAN /INFO

4. Save the changes to the GUEST.INI file and exit the text editor. If you are using a 
word processor, be sure to save the file as ASCII or DOS text.

NOTE:  If you later need to use an ASPI manager which has been remarked, edit the 
GUEST.INI file again and remove the REM command at the beginning of the 
ASPI manager line.

ASPI Manager Reference

Detailed reference information on the ASPI managers used by the Iomega driver program 
is located in the electronic "Installation Manual" (MANUAL.EXE) on the Iomega 
installation diskette.

1. For either Windows or DOS, go to a DOS prompt, type A: then press <ENTER>.

2. Type MANUAL then press <ENTER>.

Assigning Specific Drive Letters for Iomega Drives
To specify the first drive letter you want the Iomega drive to use, add the LETTER= option 
to the command line. For example, if you type GUEST.EXE LETTER=G then G will be 
assigned to the first supported drive it finds.

If you have more that one Iomega drive, each additional drive will receive a drive letter 
following G in alphabetical order. (When supporting more than one drive, drive letters 
are assigned in order of SCSI ID number, from lowest to highest.)

More Information
More information can be obtained from the install diskettes that came with your Iomega 
product and from the Iomega web site http://www.iomega.com.

SyQuest Drivers

There are four interface types used by SyQuest products: EIDE, EIDE Parallel Port (IEPP), 
SCSI, and SCSI Parallel Port (SEPP).

Each interface type requires a different driver or combination of drivers. The drivers may 
be loaded in either the CONFIG.SYS or the AUTOEXEC.BAT.
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Loading Drivers in the CONFIG.SYS

1. Open the CONFIG.SYS file in a text editor such as Notepad or DOS Editor.

2. List the driver in a DEVICE= command. For example:

DEVICE=XXXXXX.SYS [ switches ]

Where XXXXXX.SYS represents one of the drivers described below and [switches] 
represents optional driver switches. Most drivers accept the /D switch to display 
additional debug information. For example:

DEVICE=XXXXXX.SYS /D

Loading Drivers in the AUTOEXEC.BAT

1. Open the AUTOEXEC.BAT file in a text editor such as Notepad or DOS Editor.

2. In a separate line, enter the SyQuest driver loader program SQLOAD.COM. For 
example:

SQLOAD XXXXXX.SYS [switches ]

Where XXXXXX.SYS represents one of the drivers described below and [switches] 
represents optional driver switches. For example:

SQLOAD EPATSYQ.SYS /DE

SQLOAD SQPPDRVR.SYS /S

EIDE Driver
The EIDE driver, SQATDRVR.SYS, supports the EIDE products SparQ, SyJet, EZ230, 
EZ135, SQ3270, and SQ3105. To load the driver in your CONFIG.SYS file add the 
following line:

DEVICE=SQATDRVR.SYS /S

EIDE Parallel Port Drivers
The EIDE Parallel Port drivers, EPATSYQ.SYS and SQPPDRVR.SYS, support the SparQ 
and EZFlyer 230 products. The EPATSYQ.SYS driver must be loaded before the 
SQPPDRVR.SYS driver in order to function properly.
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To load the drivers in your CONFIG.SYS file add the following lines:

DEVICE=EPATSYQ.SYS /DE

DEVICE=SQPPDRVR.SYS /S

SCSI Driver
The SCSI driver, SQDRIVER.SYS, along with the SCSI adapter ASPI manager supports the 
SCSI products SyJet, EZ230, SQ3270, SQ3105, SQ200, SQ88, and SQ44.

Many ASPI managers are included and are loaded to auto-detect the SCSI interface card. 
The ASPI manager must be loaded before the SQDRIVER.SYS driver in order to function 
properly.

To load the drivers in your CONFIG.SYS file add the following lines, using the ASPI 
manager that supports your SCSI card in place of ASPI8DOS.SYS:

DEVICE=ASPI8DOS.SYS /D

DEVICE=SQDRIVER.SYS /S

For more information, see “List of ASPI Managers and Supported Adapters” on page 146 
and your SCSI host adapter documentation.

SCSI Parallel Port Drivers
The SCSI Parallel Port drivers, EPST.SYS and SQDRIVER.SYS, support the SyJet parallel 
port product. The EPST.SYS driver must be loaded before the SQDRIVER.SYS driver in 
order to function properly.

To load the drivers in your CONFIG.SYS file add the following lines:

DEVICE=EPST.SYS /DE

DEVICE=SQDRIVER.SYS /S

Loading a parallel port device driver with a network client installed may cause the 
system to hang. To successfully load the device driver for a parallel port drive, reboot the 
system without loading the network client. You can also reboot from the boot diskette 
created by the install program.

More Information
More information can be obtained from the install diskettes that came with your SyQuest 
product and the SyQuest web site http://www.syquest.com.
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Fujitsu Magneto-Optical Disk Drives

The Fujitsu 3.5-inch Megneto-Optical (MO) drive is available with either a SCSI or ATAPI 
interface. Separate DOS device drivers are supplied for each interface type. The device 
driver supports the FAT (File Allocation Table) file system, read/write, and disk change 
status.

The SCSI device driver requires a SCSI host adapter card and its matching ASPI manager 
software. For more information, see the “List of ASPI Managers and Supported Adapters” 
on page 146 and your SCSI host adapter documentation.

The 3.5-inch Magneto-Optical disks are available in five capacities:

128 Mbytes size, 512 byte sectors

230 Mbytes size, 512 byte sectors

540 Mbytes size, 512 byte sectors

640 Mbytes size, 2048 byte sectors

1.3 Gbytes size, 2048 byte sectors

The volume format may be Super floppy or AT Hard disk format. The driver 
automatically detects the volume format and assigns logical drive letters (such as D:). If 
no valid formats or partitions are detected, the device driver identifies the disk as 
unformatted. See the driver documentation supplied with the product for additional 
information about formatting MO disks.

Installation of Fujitsu Magneto-Optical Drivers
The ATAPI MO device driver is loaded in the CONFIG.SYS file using the following 
command:

DEVICE[HIGH]=( path )\MODISKAP.SYS [/P][/Ii][/Rr]

The SCSI MO device driver is loaded in the CONFIG.SYS file using the following:

DEVICE[HIGH]=( path )\ASPIXXX.SYS

DEVICE[HIGH]=( path )\MODISK2.SYS [/P][/Ii][/Rr]

ASPIXXX.SYS represents the ASPI manager that matches your SCSI host adapter.
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Optional Switches

/P
Pauses screen messages after the driver has been loaded and initialized. Press any key to 
continue the operation. Use this option to check the messages displayed by the driver.

/Ii ATAPI driver
Only the device connected to port IDE i is mounted. Otherwise, all ports are scanned 
MO devices. 

i is defined as:

1 = Primary Master

2 = Primary Slave

3 = Secondary Master

4 = Secondary Slave

/Ii SCSI driver
Only the SCSI device with ID i is mounted. Otherwise all SCSI IDs are scanned. To also 
specify the host adapter number, enter /Ih:i (h is the host adapter number and i is the 
SCSI-ID). To specify multiple devices, use the “+” character as a delimiter. For example: 
/I0:1+1:2

/Rr
Reserves the specified number of logical drive letters (r=1 to 10) for a single drive. 
Otherwise, a single drive letter is reserved. The number of reserved drive letters is 
independent of the number of disk partitions. The driver can access only as many 
partitions as the number of reserved drive letters.

NOTE:  If the inserted disk contains more partitions than specified by the /r option, as many 
drive letters are assigned to the disk drive as there are defined partitions. If the disk 
has fewer partitions than the number of drive letters reserved, an error occurs only 
when the driver attempts to access the additional drive letters.

LASTDRIVE
The CONFIG.SYS last drive command does not affect the drive letter assignment in the 
MO disk drive. If the driver assigns a drive letter higher than the one specified by the 
LASTDRIVE command (default is E:), the CD-ROM drive cannot be accessed. To enable 
access to the CD-ROM drive, specify a larger value in the LASTDRIVE command.
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If the following conditions exist, the device driver will not be loaded into memory and 
the message “Driver not loaded” will display.

• No ASPI manager loaded

• Cannot find MO drive (with or without a disk inserted)

• Driver already loaded

IMPORTANT!  The SMARTDRV cache is turned off by default for MO disk drives. If you 
attempt to write data to a write-protected disk while the SMARTDRV 
write cache is on, you will need to reset the computer.

At the driver loading, a disk with 2048-byte sectors will be ejected. Insert the disk after 
the driver loading

You can read more about Magneto-Optical disk drivers from the install diskettes that 
came with the product and from the Fujitsu web site http://www.fujitsu.com.

List of ASPI Managers and Supported Adapters

The following is a list of several popular ASPI managers and the cards they support. Drive 
Image Pro will use the ASPI manager you install to support your SCSI card.

ASPI8DOS.SYS
PCI Bus

Adaptec AHA-2910A/2910B

Adaptec AHA-2930A/2930B

Adaptec AHA-2940/2940AU/2940W/2940U/2940UW

Adaptec AHA-2944W/2944UW

Adaptec AHA-3940/3940U/3940W/3940UW

Adaptec AVA-2904, AVA-2902E/I

Adaptec AIC-7850/7855/7860/7870/7880 based SCSI host adapters

Jaz jet (PC-only model)
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ASPI7DOS.SYS
EISA Bus

Adaptec AHA-1740/1742/1744

Adaptec AHA-1740A/1742A

Adaptec AHA-2740/2742/2740T/2742T

Adaptec AHA-2740A/2742A/2740AT/2742AT

Adaptec AHA-2740W/2742W

Adaptec AIC-7770 based SCSI host adapters

VL BUS

Adaptec AVA-2825

Adaptec AHA-2840VL/2842VL

Adaptec AHA-2840A/2842A

ASPI4DOS.SYS
ISA Bus

Adaptec AHA-1540B/1542B

Adaptec AHA-1540C/1542C

Adaptec AHA-1540CF/1542CF

Adaptec AHA-1540CP/1542CP

Microchannel  Adaptec AHA-1640

ASPI2DOS.SYS
ISA Bus

Adaptec AVA-1502P/AP

Adaptec AVA-1505

Adaptec AVA-1515

Adaptec AHA-1510/1520/1522

Adaptec AHA-1510A/1520A/1522A

Adaptec AHA-1510B/1520B/1522B
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Adaptec AHA-1530P/1532P

Adaptec AVA-1502AE/AI, AVA-1505AE/AI, AVA-1505AES

Adaptec AIC-6260/6360/6370 based SCSI host adapters

Adaptec AVA-1502AE/AI, AVA-1505AE/AI, AVA-1505AES

PCMCIA Bus

Adaptec SlimSCSI (APA-460 & APA-1425/50/50A/60/60A)

MCAM18XX.SYS
PCI Bus

Adaptec AHA-2920/2920A

MA160.SYS
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.

ISA Bus

Trantor T160

Microchannel  Trantor T260

MA348.SYS
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.

Parallel Port Trantor MiniSCSI Plus (T348)

Adaptec MiniSCSI Plus (APA-348)

MA358.SYS 
If needed, add this adapter to the ASPI manager lines in your GUEST.INI or 
LDSQSCSI.BAT files.

Parallel Port Trantor MiniSCSI EPP (T358)

Adaptec MiniSCSI EPP (APA-358)

Adaptec MiniSCSI EPP (APA-358A)
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ASPIIDE.SYS
IDE

SCSI to IDE ASPI Manager

Zip IDE drive

ASPIATAP.SYS
SCSI to ATAPI ASPI Manager

ASPIPPM1.SYS and ASPIPPM2.SYS
SCSI to Parallel Port Zip Drivers

Jaz Traveller

ASPIEDOS.SYS
Adaptec AHA-1740/1742/1744 (in Enhanced Mode only)

ASPIPC16.SYS
PC1600 adapter Zip Zoom SCSI Accelerator

Adaptec APA-1460 and other AIC-6260/5360 based adapters

Jaz jet ISA adapter

Zip zoom SCSI Accelerator

Zip Card PCMCIA SCSI adapter

ASPI1616.SYS
PC1616 adapter and other NCR-53C406A based adapters

ASPI2930.SYS
AHA-2930 adapter
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Troubleshooting

This appendix gives solutions to problems that you may encounter while using 
PowerQuest's Drive Image Pro. Included are the following:

Frequently Asked Questions

Accessing Your CD-ROM Drive

Freeing Conventional Memory to Run Drive Image Pro

Increasing Windows NT Server Speed

Fixing SyQuest Driver Load Failure

Resolving Check Errors

Resolving Partition Table Errors

Partition Tables and Viruses

Error Messages and Solutions
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Frequently Asked Questions

PowerQuest maintains the latest Frequently Asked Questions on their Web site at 
http://support.powerquest.com/er/er0000.html. 

Accessing Your CD-ROM Drive

If you need to access your CD-ROM drive from Drive Image Pro, you will need to add 
the command in the CONFIG.SYS file to load your CD-ROM driver. You will also need to 
add the command in the AUTOEXEC.BAT file to load the CD-ROM extensions.

1. At the DOS prompt, change to the directory of the CONFIG.SYS you want to edit. For 
example, if you are editing the CONFIG.SYS on a boot diskette, type drive: (where 
drive is the drive letter of the boot diskette), then press <ENTER>.

2. Type EDIT CONFIG.SYS and press <ENTER> to start the DOS Editor and retrieve the 
CONFIG.SYS file.

3. Add either the DEVICE or DEVICEHIGH command. For example, type

DEVICE=[drive:][path]filename [dd-parameters]

or

DEVICEHIGH=[drive:][path]filename [dd-parameters]

where [drive:][path]filename specifies the location and name of the CD-ROM device 
driver and [dd-parameters] specifies any command-line information the device driver 
requires.

NOTE:  You may want to use DEVICEHIGH if you need to conserve conventional memory. 
See “Freeing Conventional Memory to Run Drive Image Pro” on page 153.

For more information on your device driver, consult the documentation that came 
with your CD-ROM.

4. Click File > Save to save the file.

5. Click File > Open and retrieve the AUTOEXEC.BAT file.

6. Add the command line MSCDEX.EXE.

7. Click File > Save to save the file.

8. Click File > Exit to exit the editor.
Appendix D:  Troubleshooting



Freeing Conventional Memory to Run Drive Image Pro

The Drive Image Pro executable running under DOS requires a minimum of 400KB of 
memory in the first 640KB of the computer's address space (conventional memory). If 
you try to run Drive Image Pro from DOS and find you do not have enough free 
conventional memory, you can free enough additional memory in a number of ways.

Running MEMMAKER
MEMMAKER is a program that automatically configures your computer to save 
conventional memory (while still loading all of the device drivers and other programs 
you usually load when booting DOS). MEMMAKER frees conventional memory by 
moving as many programs as possible out of conventional memory into high memory. 
Run MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen 
instructions.

NOTE:  MEMMAKER is only available with DOS versions prior to DOS 6.0. MEMMAKER is 
not available with Windows 95.

Using the F8 Key to Keep Programs From Loading
If running MEMMAKER does not free enough conventional memory, you can free more 
by pressing <F8> right after booting your computer (while DOS is booting). If you press 
<F8>, when DOS reads the commands from the CONFIG.SYS and AUTOEXEC.BAT files 
on your hard drive, DOS will ask you if you want it to execute each command. When 
you see commands that load device drivers or TSR programs that you will not need to 
run Drive Image Pro, answer N (no) to tell DOS not to execute that command (not load 
that software into memory). This will conserve conventional memory. 

Creating an Operating System Boot Diskette
If running MEMMAKER and using <F8> does not free enough conventional memory, you 
can create a boot diskette that allows you to boot using a very minimal amount of 
conventional memory.

You can create a boot diskette for any version of DOS by performing the following:

1. Place in your diskette drive (A:) any diskette that does not contain information you 
want to keep. 

2. Go to a DOS prompt, type FORMAT drive: /S (where drive is the drive letter of the 
diskette drive).

3. Press <ENTER>.
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After the diskette is formatted and the operating system files are transferred, you will be 
able to boot the computer from the diskette. If you restart your computer with the 
diskette in the diskette drive, your computer boots using a minimal amount of 
conventional memory. After you boot from the diskette, you can run Drive Image Pro 
from either the diskette or your hard drive. 

If you want to create and restore images across a network, you will need to create a 
network boot diskette. See “Creating DOS Boot Disks” in Appendix A.

Creating a CONFIG.SYS File on the Boot Diskette
If making an ordinary boot diskette doesn't free enough conventional memory, you can 
create a customized boot diskette that will free even more conventional memory. (With 
the customized diskette, you will free more conventional memory by loading some of 
the DOS operating system into high memory.) To customize the diskette, you must create 
a CONFIG.SYS file in the root directory (A:\). To create a CONFIG.SYS in the root 
directory, perform the following:

1. At the DOS prompt, type drive: (where drive is the drive letter of the diskette drive), 
then press <ENTER>. 

Verify that you have changed to the diskette drive (you see the drive:\> prompt).

2. Type EDIT CONFIG.SYS and press <ENTER>. 

This starts the DOS editor. (You will see a blank screen if no CONFIG.SYS currently 
exists.)

3. In the editor, type the following:

DEVICE=C:\DOS\HIMEM.SYS

DEVICE=EMM386.EXE

DOS=HIGH,UMB

NOTE:  All lines must be entered in the order shown. Windows users: substitute 
DEVICE=C:\WINDOWS\HIMEM.SYS.

4. Click File > Save to save the file. 

5. Click File > Exit to exit the editor.

You can now reboot your computer from the customized boot diskette. When DOS 
loads, much of it is loaded into high memory, saving a maximum amount of 
conventional memory.
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Deleting Operating System Compression Files
If you use DOS 6.22 and your system doesn't have any compressed drives (for example, 
DriveSpace, DoubleSpace, or Stacker), you can delete the operating system compression 
files DRVSPACE.BIN or DBLSPACE.BIN from any boot diskette you create. This frees 
more conventional memory because DOS 6.22 loads the contents of these files into 
memory, regardless of what's in the CONFIG.SYS or AUTOEXEC.BAT. These files are 
hidden system files, so if you wish to delete them you will have to perform the following:

1. From the DOS prompt, type drive: (where drive is the drive letter of the diskette 
drive).

2. Type ATTRIB -R -H -S *.BIN.

3. Type DEL *.BIN.

Increasing Windows NT Server Speed

If your Windows NT server slows to a crawl when running Drive Image Pro, it may be 
that the server is trying to cache the whole image file in memory. With one or more 
clients on the network trying to restore images, the NT server fills up its RAM with the 
image files. With very little RAM left to handle further requests, the NT server slows 
down.

Microsoft suggests that one might add more RAM on the server. You can also add the 
/MFS=100000000 switch to the command line when starting the Drive Image Pro 
executable. This limits each image file size to around 100 MB. This will help because 
each file is closed after moving to the next file, and NT can re-use the memory cache. 
The NT server no longer tries to cache the whole image file in memory.

This is not an issue with NetWare servers.

Fixing SyQuest Driver Load Failure

When you start Drive Image Pro, the batch file loads the Iomega and SyQuest drivers. 
You may receive the following message when loading your SyQuest removable drive: 
“Removable Drives(s) Not Found. See Readme for ways to correct this problem. Driver 
Not Installed.” Please refer to “SyQuest Drivers” in Appendix C.
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If your SyQuest driver is a SCSI drive and is connected by an adapter not supported by 
the ASPI8DOS, ASPI7DOS, ASPI4DOS, ASPI2DOS, or ASPIEDOS ASPI managers, edit 
the LDSQSCSI.BAT file to include the correct ASPI manager.

Resolving Check Errors

Drive Image Pro checks the integrity of a partition very thoroughly prior to creating an 
image file or copying a partition. These checks are substantially the same as those made 
by the operating system's CHKDSK, SCANDISK, or AUTOCHK utility.

If you receive a Check error message for any partition, after backing up your hard drive, 
run your operating system's CHKDSK program on that partition. CHKDSK usually shows 
the same problems as Drive Image Pro.

NOTE:  Run SCANDISK if you have MS-DOS 6.x or Windows 95. 

NOTE:  The DOS CHKDSK program does not detect problems in Extended Attributes.

NOTE:  If you are using Windows NT CHKDSK, DO NOT use the /F switch on the initial 
run. 

If CHKDSK (or SCANDISK) does not show the same errors that Drive Image Pro shows, 
contact PowerQuest at the numbers listed in Appendix E.

If the CHKDSK (or SCANDISK) program and Drive Image Pro detect the same errors 
(which is usually the case), run CHKDSK with the /F switch to fix the problem. 

NOTE:  Run SCANDISK if you have DOS 6.x, or run CHKDSK if you have Windows NT.

After running CHKDSK with the /F switch, try running CHKDSK without using the /F 
switch to make sure the partition is free of errors. Under OS/2, you should perform this 
procedure twice before proceeding.

If Drive Image Pro still reports a problem, reformat the partition and restore your files 
from the backup copy to correct the error.

Drive Image Pro also checks a partition after restoring it. If this check fails, report the 
problem to PowerQuest at the numbers provided in Appendix E. While data loss is 
possible, in this case it is not typical. The problem is usually a minor file system error that 
CHKDSK /F can correct without data loss. For more extensive errors, you may need to 
restore your files from a backup copy.
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Resolving Partition Table Errors

To resolve partition table errors, you must create new, error-free partition tables.

NOTE:  In some cases, PowerQuest technical support can help you fix partition table errors 
without data loss. Check with them first before proceeding to the following steps.

To create new partition tables, perform the following:

1. Make sure you have no viruses. 

NOTE:  See “Partition Tables and Viruses” on page 157.

2. Back up the data on the affected partitions.

3. Delete the partitions.

NOTE:  You may need to use the FDISK program from a recent DOS version because 
earlier versions of DOS may refuse to delete HPFS or hidden partitions.

NOTE:  If using OS/2, the OS/2 FDISK program may recognize the partition's corruption 
and refuse to modify it. In this case, use the FDISK program from a recent DOS 
version.

4. Recreate the partitions.

5. Restore the contents of the partitions. 

Partition Tables and Viruses

If partition changes made under one operating system are not reflected under the other, 
and vice versa, it is possible that a master boot record (MBR) virus is present.

Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is 
likely. If a virus is found, perform the following:

1. Before removing the virus, run ScanDisk or CHKDSK under each of the operating 
systems to evaluate the integrity of the partition. 

2. Back up the files from any partition that passes the Check operation.

3. After backing up the files from all operating systems, remove the virus.

4. Run ScanDisk or CHKDSK under each of the operating systems again.
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5. Delete and recreate any partitions which fail the check. 

6. Reinstall the operating systems.

7. Restore the backup files as necessary.

Error Messages and Solutions

For a list of error messages and solutions, run Setup, then click Documentation > Error 
Documentation on the Drive Image Pro CD.

You can also view a complete list of error messages and solutions at the PowerQuest 
Knowledge Base at http://support.powerquest.com/er/er0000/html.
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Hard Drive Manufacturers

To find the jumper settings for hard drives, consult your hard drive installation guide or 
contact your hard drive manufacturer directly. This section contains the World Wide Web 
site addresses and phone numbers for the most common hard drive manufacturers. In 
most cases, the hard drive manufacturer's web site will contain the information you need 
to install the hard drive correctly.

Another valuable resource is the web page, http://blue-planet.com/tech/index.html. In 
addition to listing the most common hard drive manufacturers, this site provides the 
jumper settings for every hard drive ever made.

Additional jumper information is available from OnTrack at http://www.ontrack.com.

Contact Information

NOTE:  The following contact information was correct at the time this manual was printed. 
Information is subject to change.

Fujitsu 

• URL: http://www.fcpa.com/support/su_support_frame.html

• Tech Support Phone: 800-626-4686

• Fax Back Support: 408-428-0456

Hitachi

• URL: http://www.hitachi.com/storage

• Tech Support Phone: 800-HITACHI or 800-448-2244

• Fax: 408-235-8942

• E-mail: drwesupport@hal.hitachi.com
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IBM

• URL: http://www.storage.ibm.com/techsup/hddtech/hddtech.htm

• Phone: 888-IBM-5214

• Automated Fax: 408-256-5418

• Fax: 507-253-DRIVE

• E-mail: drive@us.ibm.com

Maxtor

• URL: http://www.maxtor

• Tech Support Phone: 800-2-Maxtor or 800-262-9867

• Tech Support Fax: 303-260-2260 or 408-922-2050

• E-mail: Technical Assistance@Maxtor.com

NEC Technologies

• URL: http://cssweb.nectech.com/customersupport/finals/index.htm

• Tech Support Phone: 978-742-7049

• Fast Facts Fax: 800-366-0476

• E-mail: tech-support@nectech.com

Quantum

• URL: http://support.quantum.com

• Tech Support Phone: 800-826-8022

• Fax Back Support: 800-434-7532

• E-mail: qsupport@qntm.com
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Samsung Electronics America

• URL: http://www.sec.samsung.co.kr/support/faqs/index.html

• Tech Support Phone: 800-726-7864

• Fax Back Support: 800-229-2239

Seagate/Conner

• URL: http://www.seagate.com/support/disc/specs/qickspec.shtml

• Tech Support Phone: 408-456-4496 

• Tech Support Fax: 405-936-1685

• Fax Back Support: 405-936-1600

• Automated Voice System: 800-732-4283

Western Digital

• URL: http://www.wdc.com/support

• Tech Support Phone: 800-275-4932

• Automated Voice System: 949-932-4900

• Fax Back Support: 949-932-4300
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External Drive Manufacturers

Fujitsu 

• URL: http://www.fcpa.com/support/su_support_frame.html

• Tech Support Phone: 800-626-4686

• Fax Back Support: 408-428-0456

Iomega

• URL: http://www.iomega.com/support

• Automated Voice System: 888-879-7660

• Fee-based Phone Support: 888-879-4-IOMEGA

($15/incident for Zip)

($19/incident for Jaz)

• Automated Fax Back: 801-778-5763

SyQuest

• URL: http://www.syquest.com/support/index.html

PowerQuest Technical Support

Before You Contact Technical Support
PowerQuest is committed to providing you with comprehensive technical support. 
However, before calling our technical support department, try to resolve your problem 
by using this guide, the online Help system, or check PowerQuest's Web site for 
Frequently Asked Questions at http://support.powerquest.com/index.htm, or for 
international customers, see http://www.powerquest.com/intnl/index.html. Also, check 
the README.TXT file for information that has changed since this guide was printed.
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PowerQuest Problem Report
If you cannot find the solutions you need in this guide, please have the following 
information ready or send it along when you contact technical support:

Your Company Name ________________________________________________________________

Your Name _________________________________________________________________________

Your Phone Number _________________________________________________________________

Your Fax Number ____________________________________________________________________

Drive Image Pro Serial Number ________________________________________________________

Computer Manufacturer ______________________________________________________________

Computer Model and Model Number ___________________________________________________

Date of Computer Manufacture ________________________________________________________

Processor Type (386, 486, Pentium) ________________________________________________________

Amount of Memory (RAM) ____________________________________________________________

Operating System(s) / Version Number (DOS 6.21, etc.) _______________________________________________  

File System(s) (FAT, FAT32, HPFS, etc.) ______________________________________________________

Other Hardware. Include bus type (ISA, EISA, MCA, PCI, VESA), hard drive model, and external drives.

____________________________________________________________________________________

Memory Resident Software. Include memory managers and list their version numbers (for example, 

OnTrack’s Disk Manager Version 6.0 or EZ-Drive Version 7.0).

____________________________________________________________________________________

____________________________________________________________________________________
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Contacting PowerQuest Technical Support
If you cannot get the help you need from this guide, you can contact our technical 
support department in any of the ways listed below. You must be a registered Drive Image 
Pro user to receive the following types of technical support. PowerQuest offers free 
support for 45 days from the date of your first call to PowerQuest’s technical support.

Fax

Fax the information listed on the pages above and a description of your problem to the 
technical support fax number. This service is available in the U.S., Canada, and Europe 
24 hours a day, 7 days a week. We try to respond to all fax requests within 24 hours.

Faxback

BBS

Call the PowerQuest bulletin board for product information and answers to frequently 
asked technical questions. The correct modem setup is N-8-1. Our BBS supports 
transmission speeds from 1200bps to 28.8Kbps.

Location Number

USA (801) 437-4218

Europe (+31) 20 582 9260

Location Number

USA (801) 437-7921

USA Toll Free (800) 720-0391

Location Number

USA (801) 226-5608
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Postal Service Mail

Please include the information from the PowerQuest Problem report with a description 
of your problem. Be sure to also include a return address, a daytime phone number, or 
other relevant contact information.

Corporate Web Site 
http://www.powerquest.com

E-mail

Please include the information from the PowerQuest Problem Report with a description 
of your problem in your e-mail message.

USA Europe

PowerQuest Corporation

PO Box 1911

Orem, Utah 84059-1911

PowerQuest

Orlyplein 85

1043 DS

Amsterdam

The Netherlands

Language Location E-mail

English USA support@powerquest.com

Italian USA italian@powerquest.com

Portuguese USA latina@powerquest.com

Spanish USA spanish@powerquest.com

Dutch Netherlands eurots@powerquest.com

English Netherlands eurots@powerquest.com

English UK eurots@powerquest.com

French France france@powerquest.com

German Germany germany@powerquest.com
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Telephone

Our USA call center is open Monday through Friday, 7 a.m. to 6 p.m. MST/MDT. Our 
European call centers are open Monday through Friday, 9:00 to 18:00 CET. Please have 
the information from the PowerQuest Problem report ready for the technical support 
technician.

PowerQuest Newsletter and Internet Address

PowerQuest has a monthly electronic newsletter that is dedicated to official 
announcements regarding PowerQuest products. It also contains tips and techniques for 
getting the most out of your PowerQuest products. Signing up on the list will give you all 
the information you need regarding product tips, bugs, and patches. Just go to the 
PowerQuest home page (http://www.powerquest.com), enter your email address in the 
space provided, then click Sign me up.

You will be e-mailed a response verifying your subscription.

Language Location Number

Dutch Netherlands (+31) 20 581 3906

English Netherlands (+31) 20 581 3907

English UK (+44) 0171 341 55 17

English USA (801) 226-6834

French France (+33) 1 69 32 49 30

German Germany (+49) 069 66 568 516

Italian Italy (+39) 02 45 28 1312

Portuguese USA (801) 226-6834

Spanish Spain (+34) 91 622 3146

Spanish USA (801) 226-6834
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Glossary

ATA
A standard used by hard drives to communicate with the controller ports or cards that allow the 
hard drive to interface with the computer. Before ATA, there were numerous incompatible 
methods for interfacing hard drives to computers. ATA simplifies this process, thus reducing the 
cost of developing and purchasing related hardware. ATA is the proper term for Integrated Drive 
Electronics (IDE).

ATA-2
ATA-2 is the common name for a new, enhanced IDE standard. This standard is still evolving and 
has not yet been submitted for approval as an official standard.

Batch Mode
Switches in a normally interactive program that prepare it to receive non-interactive command 
input.

BIOS (Basic Input/Output System)
The BIOS is the program code stored in a PC-compatible ROM to boot the computer and provide 
basic services such as low-level hard drive access.

Client Computer
In a PowerCast session, the computer that downloads an image file from the server and restores it 
to a destination partition or free space on its hard drive.

Cloning 
Copying a hard drive to an image file or destination disk to create an exact duplicate.

Destination
The destination hard drive is the drive that is copied to during a copy or restore operation.

Disk
A hardware device to store data. A disk contains a Master Boot Record and partitions.

EIDE (Enhanced Integrated Drive Electronics)
A marketing program that promotes certain features of ATA-2.
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Extended Partition
One of the four primary partitions on a hard drive can be an extended partition. 
Extended partitions do not directly hold data; rather, you can create an unlimited 
number of logical partitions within the extended partition to store data. An extended 
partition cannot be the active partition.

FAT File Allocation Table
File system used by DOS, Windows 95/98, NT and sometimes OS/2 to store and retrieve 
files and directories.

FAT32
FAT32 is the file system used by updated versions of Windows 95 (version 4.00.950B or 
above and Windows 98). FAT32 is an enhancement of the FAT file system and is based 
on 32-bit file allocation table entries, rather than on the 16-bit entries the FAT file system 
uses. As a result, FAT32 supports much larger volumes (up to 2 terabytes).

GB (Gigabyte)
1,073,741,824 bytes.

IDE
See ATA.

Image
An image is a snapshot of a drive’s partitions that can be used to back up a system, install 
a new hard drive, or configure a new system.

Jumper 
Metal prongs and a circuit completion cap on the outside of a hard drive. You can 
remove, reposition, and then replace the cap to create various jumper settings such as 
Master and Slave.

HPFS
High Performance File System, an alternative to a FAT file system which is used by OS/2.

Interactive Mode
An operation mode where the program's responses alternate with user commands, each 
being dependent upon the other.

LBA (Logical Block Addressing)
1) In EIDE, a means of specifying sector addresses by replacing CHS values with a single 
linear 28-bit number. 2) Generically, a one-dimensional address of a hard-disk sector; 
contrast with CHS.
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Linux
Linux Ext2 file system was developed for the Linux operating system (a free-ware version 
of the UNIX operating system). Linux Ext2 file system supports a maximum volume size 
of 4 terabytes.

Logical Drive
A contiguous area inside an extended partition that can be used by the operating system 
to store and retrieve files.

Master 
The first hard drive on an IDE hard drive controller.

MB (Megabyte)
1,048,576 bytes.

Multicasting
The ability to create a session and simultaneously send an image file from the server to 
one or more networked clients.

NetBIOS
A high level Network programming interface which is supported by lower level network 
protocols such as IP/SP and TCP/IP.

NetWare
The Novell NetWare network operating system uses the NetWare File System, which was 
developed specifically for use by NetWare servers.

NTFS New Technology File System. 
An alternative to FAT and HPFS file systems used by WinNT.

Partition
An uninterrupted area on a disk, defined in the Master Boot Record. Every partition 
contains a specific file system such as FAT, FAT32, HPFS, or NTFS.

PowerCasting 
see Multitasking
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Primary Partition
A partition referenced in the Master Boot Record partition table. Four primary partitions 
can exist on a hard drive. One of these may be an extended partition. Only one primary 
partition on a drive may be active at time. Data and applications are often placed on a 
logical partition inside an extended partition. This enables the data to be accessed by all 
primary partitions.

Restore
Downloading an image file to a destination drive. The Restore and Download script 
arguments are interchangeable and accomplish the same function.

Slave
The second hard drive on an IDE hard drive controller.

Script File
A series of instructions, usually in text file format, written to be passed to a program 
running in batch mode.

Server
In a PowerCast session, the computer that creates the session and sends the image file to 
one or more networked client computers.

Source
The Source hard drive is the drive from which the image is made.

Spanned Image
An image file that has been created in two or more segments so that it can be placed on 
media that is smaller than the image itself.

Volume
This User Guide uses the term volume interchangeably with partition.
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A
accessing CD-ROM drive 152
active partition 83
adapters for ASPI managers 146
advanced options

copying disk to disk 72
creating images 17
hide partition after restore 52
restoring images 35
skip bad sector checking 52
verify disk writes 52

applications
installing customized 113
installing multiple 113
keep from loading 153

arguments in script files 106
ASPI managers

list and supported adapters 146
reference 141

AUTOEXEC.BAT, editing for SyQuest drivers 142

B
bad sector check, skip 35, 52, 73
batch mode

running Drive Image Pro 103
scripting 106

BIOS, computers with older 130
boot diskettes

creating 119
creating a CONFIG.SYS 154
creating a system diskette 153
modifying 126
NetWare 121
no network 125
PowerCasting, automated 120
TCP/IP 123
using 153

BootDisk Builder
creating DOS boot disks 119
modifying boot disks 126
NetWare 121
no network 125
PowerCasting 120
TCP/IP 123

C
CD-ROM

accessing drive 152
creating image files 21
restoring image files from 38

Check 72
check errors 158
check for file system errors 18, 52

copying disk to disk 72
CHKDSK 6, 156
client operations, PowerCasting 48
clients

restoring images to multiple
using NetWare with parallel port devices 6

combing spanned image files 90
command line switches 104

running in batch mode 103
common partition management tasks 77
compressing

image files 15
partitions 97
uncompressing partitions 98

compression
deleting OS files 155
level 15
setting while copying 92

CONFIG.SYS, creating on the boot diskette 154
configuring hardware 10
Conner, contact information 162
contact information

external drive manufacturers 163
hard drive manufacturers 160
PowerQuest technical support 165
technical support 163

conventional memory 153
converting Ghost image files 135
copying

image files 91
partitions 95
setting compression levels 92
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copying disk to disk 61
advanced options 72
between partitions on same drive 74
check for file system errors 72
disabling SmartSector 73
drive to drive 75
hiding partitions after 73
resizing options 71
resizing partitions 68
skip bad sector checks 73
verify disk writes 73

creating
boot diskettes 153
boot disks 119
extending partitions 78
image files 89
partitions 128
spanned images 90

creating image files 9
advanced options 17
for CD-ROM 21
on secondary hard drive 23
on Zip drives 19
scenarios 19

custom installs using DeltaNow 113

D
deleting

compression files 155
image files 88
partitions 80, 96

DeltaNow
creating an installation package 115
creating custom installs 113
operating systems supported 2
setting up target computer 114

device drivers, removable
installing 5

devices, using parallel port with NetWare 6
disabling SmartSector copying 18, 73
disk

creating DOS boot disks 119
disk access errors 158
disk writes, verify while copying disk to disk 73
disk, copying 61
displaying drive information 78

DOS boot disks
modifying 126
NetWare 121
no network 125
PowerCasting, automated 120
TCP/IP 123

downloading, see restoring image files
Drive Image File Editor 85

combining spanned images 90
compressing partitions 97
copy options 92
copying image files 91
copying partitions 95
creating image files 89
creating spanned images 90
deleting image files 88
deleting partitions 96
opening image files 88
partition properties 94
restoring individual files from a partition 99
uncompressing partitions 98

Drive Image Pro
batch mode 103
converting Ghost image files 135
File Editor 85
partition management 77
using computers with older BIOS 130
using with SCSI hard drives 130

drive letter
assigning for Iomega 141
assignment by operating system 133

drive overlay software 130
DriveMapper, supported operating systems 2
drivers

fixing SyQuest load failure 155
installing for removable devices 5
removable storage devices 139

drives
copying between drives 75
displaing information 78
older computer BIOS 130

E
editing, managing files 85
EIDE drivers

parallel port 142
setup 142

error messages 158
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creating image files 19
see also scenarios

extended partitions, creating 78
external drives, manufacturer contact information 

163

F
F8 Key, to keep programs from loading 153
FAT check errors 158
FDISK 128
file system errors, check for 18, 52
files

managing 85
restoring single files 99
see also image files

FORMAT 128
formatting partitions 128
frequently asked questions 152
Fujitsu drivers

installing 5
setup 144

Fujitsu, contact information 160

G
Ghost image files conversion 135
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GUEST.INI, edit 140

H
hard drives

creating image files on 23
manufacturer contact information 160
restoring images from 40
SCSI 130

hardware configurations 10
help online 7
hiding

partitions 81
partitions after copying 73
partitions after restore 35, 52

Hitachi, contact information 160
HPFS check errors 158

I
IBM, contact information 161

image files
combining 90
compressing 15
converting Ghost files 135
copying 91
creating 9, 89
deleting 88
deleting OS compression files 155
hardware configurations 10
opening 88
passwords 19
restoring 25
restoring individual files from a partition 99
spanning media 16
splitting into multiple 93

ImageShield 19
information

about partitions 87
displaying for drives 78
partition properties 94

installation package 115
installing

Drive Image Pro 4
multiple applications 113
removable device drivers 5
see also restoring image files
uninstalling 7

internet address, PowerQuest 167
Iomega

contact information 163
installing drivers for 5

Iomega drivers 139
ASPI managers 141
assigning drive letters 141
editing GUEST.INI 140

K
keep programs from loading 153

L
list of ASPI managers and adapters 146
load failure, SyQuest 155
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M
MagicMover 16-Bit version 2
MagicMover 32-Bit version 2
management tasks

Drive Image File Editor 85
image files 85
partitions 77

managing partitions, about PartitionMagic 137
Maxtor, contact information 161
MEMMAKER 153
memory required 2
multicasting

see PowerCasting
multiple files

splitting image files 19
splitting images 93

N
NEC Technologies, contact information 161
NetWare

boot disks 121
NetWare Client

using with parallel port devices 6
newsletter

sign up 167
NTFS check errors 158

O
online help 7
opening image files 88
operating systems

boot diskettes 153
deleting compression files 155
for install 4
supported 2

optical disk drives, Fujitsu 144
organizing partitions

about PartitionMagic 137
overlay software on older computers 130

P
package installation 115
parallel port devices, NetWare Client 6
partition

properties 94
partition information 87
partition table, resolving errors 157

PartitionMagic 137
partitions

common management tasks 77
compressing 97
copying 95
copying between partitions on same hard 

drive 74
deleting 80, 96
FDISK 128
format 128
hiding 81
hiding after copying 73
hiding after restore 35, 52
manage with PartitionMagic 137
resizing 30, 68
restoring individual files 99
setting active 83
table errors 158
uncompressing 98

password protection 92
passwords, image files 19
platform computer, DeltaNow 114
port devices, using with NetWare Client 6
PowerCasting 43

boot disks, automated 120
client operations 48
restoring images to multiple clients
skip bad sector checking 52
verify disk writes 52

PowerQuest 165
internet address 167
newsletter 167
problem report 164
technical support 163, 165

preparation
before running Drive Image 6, 10

problem report, submitting to PowerQuest 164
programs

see applications
properties of partitions 94

Q
Quantum, contact information 161
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removable storage devices

installing drivers 5, 139
requirements 2
resize options 34, 71
resizing partitions 30, 68
Resolving Partition Table Errors 157
restoring image files 25

advanced options 35
from CD ROM 38
PowerCasting 43
resize options 34
resizing partitions 30
scenarios 36
to multple clients

restoring images from secondary hard drives 40
restoring individual files from a partition 99
running Drive Image preparation 10
running Drive Image Pro

from a floppy diskette 6
from a hard drive 7
preparation 6

S
Samsung Electronics America, contact 

information 162
ScanDisk, before running Drive Image 6
scenarios

creating image files 19
creating image files for CD-ROM 21
creating image files on secondary hard drive 

23
creating image files on Zip drives 19
restoring image files 36
restoring image files from a Zip drive 36
restoring images from secondary hard drives 

40
script files 106
scripting 106

running in batch mode 103
SCSI drivers

parallel port 143
setup 143

SCSI hard drives 130
Seagate/Connor, contact information 162
setting active partition 83
setting up removable storage devices 139
single files, restoring from a partition

sizing partitions 68
skip bad sector check 35, 52, 73
SmartSector

disable copying 18, 73
spanned images

combining 90
creating 90

spanning
media-spanning feature 16

spanning images
splitting image files 19
splitting images into multiple 93

splitting an image file 19, 93
switches, command line 104
SyQuest

contact information 163
fixing load failure 155
installing drivers for 5

SyQuest drivers
editing CONFIG.SYS 142
setup 141

system requirements 2

T
target computer, DeltaNow 114
TCP/IP

boot disks 123
Technical Support

BBS 165
E-mail 166
Fax 165
Faxback 165
Mail 166
Telephone 167

technical support
contact information 163
PowerQuest 165
problem report 164

troubleshooting 151
accessing CD-ROM drive 152
creating a CONFIG.SYS on boot disks 154
creating boot diskettes 153
deleting OS compression files 155
fixing SyQuest driver load failure 155
keep from loading programs
running MEMMAKER 153
using operating system boot disks 153
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U
uncompressing partitions 98
uninstalling Drive Image 7

V
verify disk writes

copying disk to disk 73
creating images 18
PowerCasting 52
restoring images 35

W
Western Digital, contact information 162

Z
Zip drives

creating image files 19
restoring image files from 36
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