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Quick Reference 

Toolbox overview
 Shift      
 Key

Toolbox and palette shortcuts
•      Alt + click tool or  + press shortcut key to cycle through hidden tools (except 

 
 

).
•      Double-click tool or select tool and press Return to display Options palette.
•      Right-click to display context-sensitive menu.
•      Press  to constrain dragging or drawing to straight line or multiples of 45°.
•      Press Caps Lock to use precise cross hair for brushes.
•      Press Enter to apply, or press Esc or Ctrl +  to cancel, an operation of a magnetic tool.

•      Tab shows/hides all palettes.
•       + Tab shows/ hides all palettes except the toolbox.

•      Spacebar activates hand tool.



Quick Reference 

Selecting & moving
 Shift      
 Key

Repositions marquee while 
selecting

Any marquee tool + spacebar + 
drag

Adds to or subtracts from a 
selection 

Any selection tool +  or Alt + drag

Intersects a selection Any selection tool +  + Alt + drag 

Constrains marquee to square or 
circle 

 + drag

Draws marquee from center Alt + drag

 Ctrl (except when  tool is 
selected)

Switches from  to Alt + drag

Switches from  to Alt + click

Moves copy of a selection   + Alt + drag selection

Moves selection 1 pixel Any selection tool or  +  
  *

Moves layer 1 pixel Ctrl +     * 

Accepts cropping or exits cropping  + Enter or Esc

*Hold down  to move 10 pixels.



Quick Reference 

Painting
 Shift      
 Key

Any painting or editing tool + Alt 

Selects background color  + Alt + click

Sets opacity, pressure, or exposure 
for painting mode or active layer

Any painting or editing tool + 
number keys(e.g., 0 = 100%, 1 = 
10%, 4 then 5 in quick succession =
45%)

Cycles through painting and layer 
blending modes

 +  

Fills selection/layer with foreground 
or background color

Alt + Backspace, or Ctrl + 
Backspace*

Fills selection with layer 
transparency or background color

Backspace

Displays Fill dialog box  + Backspace

Turns Preserve Transparency 
option on/off

/

Connects points with a straight line Any painting tool +  + click

*Hold down  to fill with Preserve Transparency on.



Quick Reference 

Viewing
 Shift      
 Key

Fits image on screen Double-click , or Ctrl + Ø (zero)

100% magnification Double-click , or Alt + Ctrl + Ø 
(zero)

Zoom in or out Ctrl +  or 

 or Ctrl + spacebar, or Alt + spacebar

Applies zoom percentage and 
keeps zoom percentage box active

 + Enter in Navigator palette

Zooms in on specified area of 
image

Ctrl + drag over preview in 
Navigator palette

Magnifies or reduces image without 
resizing window

Alt + Ctrl +  or 

Scrolls image with hand tool Spacebar + drag, or drag view area 
box in Navigator palette

Scrolls up or down 1 screen Page Up or Page Down*

Scrolls up or down 10 units  + Page Up or Page Down*

Moves view to upper left corner or 
lower right corner

Home or End

*Hold down Ctrl to scroll left or right.



Quick Reference 

Type Tool dialog box
 Shift      
 Key

Selects 1 character to the left/right 
or 1 line below/above

 +    

Selects characters from insertion 
point to mouse click point

 + click

Moves 1 character left/right, 1 line 
down/up, or 1 word left/right

  ,  , or Ctrl +  



Quick Reference 

Blending and Layer modes*
 Shift      
 Key

Selects the next or previous 
blending mode from the Options 
palette pop-up menu or layer mode 
from the Layers palette pop-up 
menu

 +  or 

Normal  + Alt + N

Threshold (on Bitmap or Indexed 
Color image)

 + Alt + L

Dissolve  + Alt + I

Behind (on layer with transparency)  + Alt + Q

Clear (for paint bucket and line tool)  + Alt + R

Multiply  + Alt + M

Screen  + Alt + S

Overlay  + Alt + O

Soft Light  + Alt + F

Hard Light  + Alt + H

Color Dodge  + Alt + D

Color Burn  + Alt + B

Darken  + Alt + K

Lighten  + Alt + G

Difference  + Alt + E

Exclusion  + Alt + X

Hue  + Alt + U

Saturation  + Alt + T



Color  + Alt + C

Luminosity  + Alt + Y

*Sets painting blending modes (if the active tool supports this) or sets layer blending modes.
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Other shortcuts
 Shift      
 Key

Creates new file with default 
settings

Alt + Ctrl + N

Displays dialog box for the previous
filter

Alt + Ctrl + F

Resets dialog box to last settings 
used

Alt + click Reset

Displays last-viewed Preferences 
dialog box

Alt + Ctrl + K

Loads last color adjustment settings
used

Alt + choose Image > Adjust 
(Levels, Curves, Color Balance, 
etc.) 

Increases/decreases selected value
in dialog box by 1 unit (except in 
filters)

 *

Switches between  and  Alt

Switches between  and  Alt

*Hold down  to increase/decrease value by 10 units.



Looking at the Work Area

The Adobe Photoshop Limited Edition work area includes the command menus at the top of your 
screen, the window containing the image you are editing, and a variety of tools and palettes that let 
you edit images and add    elements such as paint fills and layers. You can also add commands and 
filters to the menus by installing plug-in modules—software programs designed to extend the 
functionality of Adobe Photoshop.

See also: 

Using the toolbox 

Using palettes 

Using context menus 

Viewing images 

Using plug-in modules 

Setting preferences 

Using Adobe Online Services 



Looking at the Work Area 

Using the toolbox

The tools in the toolbox let you select, paint, edit, and view images. The toolbox also contains controls 
for choosing the foreground and background colors, creating quick masks, and changing the screen 
display mode. The settings in the Brushes and Options palettes affect the painting or editing effects of 
most tools. 

For information on the foreground and background color controls, see Choosing the foreground and 
background colors. For information on the Quick Mask mode control, see Using Quick Mask mode.

To move the toolbox:

Drag the toolbox by its title bar.

See also: 

Selecting tools 

Using the tool pointers 



Using the toolbox 

Selecting tools

You select a tool by clicking its icon in the toolbox or dragging to select its icon from a pop-up menu. A 
small triangle to the right of a tool icon indicates that the tool has a pop-up menu of hidden tools. 

To select a tool:

Do one of the following:
•      To select a visible tool, click its icon in the toolbox.
•      To select a hidden tool, position the pointer on the overlying tool in the toolbox, and drag to 
highlight the tool you want.

 Use the following shortcuts to select tools: 
• To select a tool quickly, press its keyboard shortcut on the keyboard. 
• To cycle through a set of hidden tools, press Option (Macintosh) or Alt (Windows) and click the visible tool, or press 
Shift + the hidden tool’s keyboard shortcut repeatedly. (The marquee tool shortcut cycles through only the rectangle 
and ellipse marquee tools.) 



Using the toolbox 

Using the tool pointers

When you select most tools and position the mouse pointer on the image, the pointer matches the 
tool’s icon. This is the default standard tool pointer. The standard marquee, line, and gradient pointers 
appear as crosshairs. 

Each of the default pointers has a different hot spot, the point where an effect or action begins. To use 
a tool with greater accuracy, you can switch to precise pointers, which appear as crosshairs centered 
around the hot spot. When you’re using the painting tools, you can also display the pointer as a brush 
shape reflecting the current brush size.

To set the tool pointer appearance:

1    Choose File > Preferences > Display & Cursors.

2    Do one of the following:
•      Click Standard under Painting Cursors, Other Cursors, or both to display pointers as tool icons.
•      Click Precise under Painting Cursors, Other Cursors, or both to display pointers as crosshairs. 
•      Click Brush Size under Painting Cursors to display the painting tool pointers as brush shapes 
representing the size of the current brush.

3    Click OK.

When you’re using the brush size pointer with very small brushes, the brush shape is surrounded by 
four dots for finer accuracy.

The Painting Cursors options control the pointers for the eraser, pencil, airbrush, paintbrush, rubber 
stamp, smudge, blur, sharpen, dodge, burn, and sponge tools. 

The Other Cursors options control the pointers for the marquee, lasso, polygon lasso, magic wand, 
crop, eyedropper, gradient, line, and paint bucket tools.

    To change the appearance of some tool pointers, press Caps Lock. Press Caps Lock again to return to your 
original setting. The following list outlines the pointer changes: 
• Standard changes to precise. 
• Precise changes to brush size (painting tools only). 
• Brush size changes to precise (painting tools only).



Looking at the Work Area 

Using palettes

Adobe Photoshop includes a number of palettes to help you monitor and modify images. By default, 
these palettes appear stacked together in several groups. You can display and hide these palettes as 
you work with an image.

See also: 

Changing the palette display 

Setting the positions of palettes and dialog boxes 

Using the Options palette 

Using the Info palette 

Customizing the Info palette 



Using palettes 

Changing the palette display

You can change the arrangement and display of palettes and palette groups to optimize the work area 
on your desktop. Use the following techniques to organize palettes:
•      Press Tab to hide or display all open palettes and the toolbox. Press Shift+Tab to hide or display 
all open palettes, excluding the toolbox.
•      To make a palette appear at the front of its group, click the palette’s tab.
•      To move an entire palette group, drag its title bar.
•      To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette outside of an 
existing group creates a new group. 
•      To move a palette to another group, drag the palette’s tab to that group.
•      To display a palette menu, position the pointer on the triangle in the upper right corner of the 
palette, and hold down the mouse button. 
•      To change the height of a palette (except the Color, Options, or Info palette), drag the size box at 
the lower right corner of the palette (Macintosh) or drag the lower right corner of the palette 
(Windows). To return the palette to the default size, click the zoom box (Macintosh) or the 
minimize/maximize box (Windows) in the right of the title bar. (If you have resized the palette, the first 
click restores the default size and the second click collapses the palette group.)
•      To collapse a group to the palette titles only, Option-click the zoom box (Macintosh) or Alt-click the 
minimize/maximize box (Windows). You can also double-click a palette’s tab. You can still access the 
palette menu from a collapsed palette.



Using palettes 

Setting the positions of palettes and dialog boxes

Adobe Photoshop saves the positions and groupings of all open palettes and the positions of 
moveable dialog boxes when you exit the program. If you prefer, you can make Photoshop always 
start with its default palette positions. You can also restore the palettes to these default positions at 
any time when working with the program.

To reset palettes to the default positions:

1    Choose File > Preferences > General.

2    Click Reset Palette Locations to Defaults.

To always start with the preset palette and dialog box positions: 

1    Choose File > Preferences > General.

2    Deselect Save Palette Locations. The change takes effect the next time you start Adobe 
Photoshop.



Using palettes 

Using the Options palette

Each tool in the toolbox (with the exception of the type and type mask tools) has its own set of options,
which appear in the Options palette. The name and appearance of this palette change, depending on 
the currently selected tool.

The Options palette contains some settings that are common to several tools (such as painting modes
and opacity), as well as specialized options like the cloning settings for the rubber stamp tool. 

To display the Options palette:

Do one of the following:
•      Choose Window > Show Options. 
•      Double-click a tool in the toolbox (except the zoom or hand tool) to display the Options palette for 
that tool. 
•      Click a tool in the toolbox or press its keyboard shortcut, and press Return (Macintosh) or Enter 
(Windows) to display the Options palette for that tool.

To return to a tool’s default settings:

Choose from the following:
•      To return a tool to its default settings, click the tool in the toolbox and choose Reset Tool from the 
Options palette menu. 
•      To return all the tools to their default settings, choose Reset All Tools from the Options palette 
menu. 



Using palettes 

Using the Info palette

The Info palette provides information on the selected tool and on the color values of the image area 
beneath the pointer. Depending on the tool you’re using, you can also use the Info palette to measure 
size, distance, and angle of rotation. In most cases when a tool is in use, the Info palette displays the x
and y coordinates of the pointer’s position in the image using the units of measurement you specify.

The Info palette also displays the following information: 
•      When the marquee tool is in use, the Info palette displays the x and y coordinates of your starting 
position and the width (W) and height (H) of the marquee as you drag. This marquee size information 
is displayed as long as the image contains a selection. 
•      When the crop tool or zoom tool is in use, the Info palette displays the width (W) and height (H) of 
the marquee as you drag. The palette also shows the angle of rotation of the crop marquee.
•      When the line tool or gradient tool is in use, or when you move a selection, the Info palette 
displays the x and y coordinates of your starting position, the change in X (DX), the change in Y (DY), 
the angle (A), and the distance (D) as you drag. 

 To use the line tool to measure distances in an image, define a line width of 0 in the Line Tool Options palette. 
•      When you use the Scale or Rotate command, the Info palette displays the percentage change in 
width (W) and height (H), and the angle of rotation (A).
•      When you move the pointer over the pixels in your image while using any of the color adjustment 
dialog boxes, the Info palette displays the before and after color values of the pixels. 



Using palettes 

Customizing the Info palette

The Info palette displays two color readouts. You can change the color mode used for each of these 
readouts. You can also change the units of measurement used to display distance and size in the Info 
palette. 

To change the Info palette options:

1    Choose Palette Options from the Info palette menu.

2    For First Color Readout, choose one of the following display options: 
•      Actual Color to display values in the current color mode of the image.
•      Any other option to display the color values in that color mode. See Color modes and models for 
more information.

3    For Second Color Readout, choose one of the display options listed in step 2.

4    For Ruler Units, choose a unit of measurement.

5    Click OK.

 To change the measurement units and the color readout modes, click the crosshair or eyedropper icon, 
respectively, in the Info palette to display a menu with these options.



Looking at the Work Area 

Using context menus

In addition to the menus that appear at the top of your screen, Adobe Photoshop contains a number of
context-sensitive menus. These menus display commands that relate to the active tool, selection, or 
palette. You can use context menus as a quick way to choose commonly used commands. 

To display context menus:

1    Position the pointer over an image or palette item.

2    Do one of the following:
•      On the Macintosh, press Control and hold down the mouse button.
•      In Windows, click with the right mouse button.



Looking at the Work Area 

Viewing images

The hand tool, the zoom tools, and the Zoom commands let you view different areas of an image at 
different magnifications. You can also use the Navigator palette to control your view of an image, and 
you can open additional windows to display several views at once. 

See also: 

Controlling the window display 

Opening multiple views of the same image 

Arranging multiple windows (Windows only) 

Moving the view of an image 

Magnifying and reducing the view 

Using the Navigator palette 



Viewing images 

Controlling the window display

The window controls at the bottom of the toolbox control how image windows in Adobe Photoshop are 
displayed.

To change the display of image windows:

Click one of the following window controls:
•      The left window control to display the image in a standard window, with a menu bar at the top and 
scroll bars on the sides. This is the default mode.
•      The center window control to display the image in a full-screen window with a gray background 
and a menu bar but with no title bar or scroll bars. To scroll through the image, use the hand tool or the
Navigator palette.
•      The right window control to display the image in a full-screen window with a black background, but 
with no title bar, menu bar, or scroll bars. To scroll through the image, use the hand tool or the 
Navigator palette.



Viewing images 

Opening multiple views of the same image

Each image in Adobe Photoshop can have several open windows showing different views. For 
example, you might want to have multiple windows open for a single image to view the image at 
different zoom levels. The number of images and windows you can have open depends on the amount
of memory you have available. A list of all open windows appears at the bottom of the Window menu.

To open additional windows:

Choose View > New View. 



Viewing images 

Arranging multiple windows (Windows only)

In Windows, you can control how Adobe Photoshop displays multiple windows on-screen.

To arrange multiple windows:

Do one of the following:
•      Choose Window > Cascade to display windows stacked and cascading from the top left to the 
bottom right of the screen.
•      Choose Window > Tile to display windows edge to edge.



Viewing images 

Moving the view of an image

You can view different areas of an image using the image window scroll bars or the hand tool.

To scroll with the hand tool:

1    Select the hand tool.

2    Drag in the image to move the image in its window.

 To use the hand tool while another tool is selected, hold down the spacebar as you drag in the image.



Viewing images 

Magnifying and reducing the view

The zoom tool and the Zoom commands let you magnify and reduce the view of an image. You can 
also zoom to an exact percentage of the original view by entering values in the zoom percentage box 
at the lower left of the window. The image window’s title bar displays the magnification or reduction 
percentage at all times. You can magnify up to 1600% of the original image view.

Note: The 100% view of an image displays an image based on the monitor resolution and the image 
resolution, not on the actual image dimensions. See About resolution and image size for more 
information.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To zoom in:

Do one of the following:
•      Select the zoom tool, and click the area of the image you want to magnify. Each click magnifies the
image to the next preset percentage, and the magnified display is centered around the point you click. 
When you reach the maximum magnification, the center of the zoom tool appears empty.
•      Choose View > Zoom In to magnify to the next preset percentage.

See also: 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To zoom out:

Do one of the following:
•      Select the zoom tool. Hold down Option (Macintosh) or Alt (Windows) to activate the zoom-out 
tool, and click the area of the image you want to reduce. Each click reduces the view to the previous 
preset percentage.
•      Choose View > Zoom Out to reduce to the previous preset percentage.

    Use the following shortcuts to zoom in or out with any tool selected:
• To activate the zoom-in tool, press Command+spacebar (Macintosh) or Ctrl+spacebar (Windows). 
• To activate the zoom-out tool, press Command+Option+spacebar/Ctrl+Alt+spacebar.

See also: 

To zoom in 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To magnify by dragging:

1    Select the zoom tool.

2    Drag over the part of the image you want to magnify.

The part of the image enclosed by the zoom marquee is displayed at the maximum magnification 
possible. 

 Press Command+[+] (Macintosh) or Ctrl+[+] (Windows) to zoom in to the next preset percentage. Press 
Command+[-]/Ctrl+[-] to zoom out to the previous preset percentage.

See also: 

To zoom in 

To zoom out 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To magnify or reduce to a specified percentage:

Enter a percentage value in the zoom percentage box at the lower left of the window.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To display an image at 100%:

Do one of the following:
•      Double-click the zoom tool.
•      Choose View > Actual Pixels.
•      Click Actual Pixels in the Zoom Tool Options palette. 

 Press Command+Option+0 (Macintosh) or Ctrl+Alt+0 (Windows) to display the image at 100%.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To change the view to fit the screen 

To constrain the window size 



Magnifying and reducing the view 

To change the view to fit the screen:

Do one of the following:
•      Double-click the hand tool. 
•      Click Fit on Screen in the Zoom Tool Options palette.

These options scale the zoom percentage and window size to the largest that can fit on your monitor 
and still contain the entire image.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To constrain the window size 



Magnifying and reducing the view 

To constrain the window size:

Deselect Resize Windows To Fit in the Zoom Tool Options palette. Deselecting this option maintains 
the same window size regardless of the image’s magnification, and can be helpful when using smaller 
monitors or when working with tiled views of an image.

    Use the following shortcuts to change the image magnification without resizing the window:
• Press Command+0 [zero] (Macintosh) or Ctrl+0 [zero] (Windows) to fit the image in the window.
• Press Command+Option +[+] (Macintosh) or Ctrl+Alt+[+] (Windows) to magnify the image without resizing the 
window.
• Press Command+Option+[-] (Macintosh) or Ctrl+Alt+[-] (Windows) to reduce the image view without resizing the 
window.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 



Viewing images 

Using the Navigator palette

The Navigator palette lets you quickly view different areas of an image and change the magnification 
of your view. This palette displays a thumbnail of the image and a rectangle, the view box, 
representing the boundaries of the image window. You can change the color of the view box from its 
default red.

To move the view of the image:

Do one of the following:
•      Drag the view box in the Navigator palette.
•      Click in the thumbnail. The new view includes the area you click.

To magnify or reduce the view:

Do one of the following:
•      Click the zoom in or zoom out button.
•      Drag the zoom slider at the bottom of the palette.
•      Enter the percentage of magnification or reduction you want, and press Return (Macintosh) or 
Enter (Windows).

    To zoom to the specified percentage and keep the zoom percentage box highlighted, hold down Shift while 
pressing Return/Enter.

•      Hold down Command (Macintosh) or Ctrl (Windows) and drag over the area of the thumbnail that 
you want to magnify.

To change the color of the view box:

1    Choose Palette Options from the Navigator palette menu.

2    Do one of the following:
•      To use a preset color, choose an option for Color.
•      To define your own color, click the color box or choose Custom from the Color pop-up menu; then 
choose a color (see Using the Swatches palette), and click OK.



Looking at the Work Area 

Using plug-in modules

Adobe Photoshop plug-in modules are software programs developed by Adobe Systems, and by other
software developers in conjunction with Adobe Systems, to extend the functionality of the Adobe 
Photoshop program. Adobe Photoshop includes plug-in modules for importing and exporting images 
and for producing special effects. 

See also: 

Installing plug-in modules 

Setting plug-ins preferences 



Using plug-in modules 

Installing plug-in modules

To use a plug-in module that has been developed by Adobe Systems, you must first install it into the 
plug-ins folder for Adobe Photoshop. To install a third-party plug-in module, follow the installation 
instructions included with the module. Once installed, the modules appear in the Import or Export 
menu, as file formats in the Open, Save As, and Save a Copy dialog boxes, or as filters in the Filter 
submenus.

To install an Adobe Systems plug-in module:

Do one of the following:
•      On the Macintosh, drag a copy of the moduleto the Plug-Ins folder inside the Adobe Photoshop 5.0
LE folder. 
•      In Windows, copy the module into the Plug-Ins subdirectory in the Photoshop 5.0 LE directory.



Using plug-in modules 

Setting plug-ins preferences

When you install Adobe Photoshop LE and include the plug-in modules in the installation, these files 
are automatically placed in the Adobe Photoshop Plug-Ins folder (Macintosh) or the Plug-Ins directory 
(Windows). You can add new plug-ins or move the modules to a new location. 

If you move the plug-ins to a different location, you must change the Plug-Ins preference setting to 
enable the application to locate the plug-ins. (But if you change the preference setting to point 
Photoshop to a different folder than the Plug-Ins folder, you won’t be able to see the default plug-ins 
installed with Photoshop.) Alternatively, you can create a shortcut to the plug-ins: inside your Plug-Ins 
folder, you can create a shortcut to another folder with plug-ins.

To set plug-ins preferences:

1    Choose File > Preferences > Plug-Ins & Scratch Disk. 

2    Click Choose, and select a folder or directory from the list. (Do not select a location inside the Plug-
Ins folder. If you do, you won’t be able to see all of your plug-ins.) To display the contents of a folder, 
click Open (Macintosh); double-click the directory (Windows) to display its contents.

3    When you have highlighted the new plug-ins folder, click Select (Macintosh) or OK (Windows).

4    Restart Adobe Photoshop.
    On the Macintosh, to select the plug-ins location immediately upon starting Adobe Photoshop, press 

Command+Option as you launch the program.



Looking at the Work Area 

Setting preferences 

Adobe Photoshop includes numerous program settings, which are stored in a preferences file. This file
is located in the Preferences folder in your System Folder (Macintosh) or in the Prefs subdirectory 
inside the Photosle folder (Windows). The settings stored in this file include general options, display 
options, tool options, ruler units, and options for exporting information from the Clipboard. Most of 
these options are set in dialog boxes that can be opened through the Preferences submenus in the 
File menu. Preference settings are saved each time you exit Adobe Photoshop.

To restore all of Adobe Photoshop’s preferences to their default settings:

Do one of the following:
•      On the Macintosh, open the Preferences folder in the System Folder and drag the Adobe 
Photoshop 5.0 LE Prefs file to the Trash. 
•      In Windows, delete the Adobe Photoshop 5 LE Prefs.psp file, located in Program 
files/Adobe/Photoshop 5.0 LE/Prefs. 

A new Preferences file will be created when you next start Adobe Photoshop.



Looking at the Work Area 

Using Adobe Online Services

For more information about Adobe products, you can access extensive customer support information 
on the Adobe Web site on the World Wide Web. 

To open the Adobe Web site, enter the URL http://www.adobe.com in your Web browser. To launch the
Adobe Home Page directly from Photoshop LE, choose File > Adobe Online or click the icon at the top
of the tool bar.



Getting Images into Photoshop

Images can be brought into the Adobe Photoshop Limited Edition program by importing in a variety of 
file formats; by scanning a photograph, a slide, or an image; or by capturing images from video.

See also: 

About bitmap images and vector graphics 

Determining image size and resolution 

Scanning images 

Opening and importing images 

Viewing copyright and authorship information 

Creating new images 

Cropping an image 

Increasing the size of the work canvas 
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About bitmap images and vector graphics

Computer graphics fall into two main categories—bitmap images and vector graphics. Understanding 
the difference between these two types of images is useful when you’re creating and editing digital 
images.

See also: 

Bitmap images 

Vector graphics 



About bitmap images and vector graphics 

Bitmap images

Bitmap images, also called raster images, use a grid, or raster, of small squares known as pixels to 
represent graphics. Each pixel in a bitmap image has a specific location and color value assigned to it.
For example, a 1-inch circle in the lower left corner of the page is made up of the collection of pixels in
that location, colored to give the appearance of a circle. When working with bitmap images, you edit 
groups of pixels rather than objects or shapes. Images created in Adobe Photoshop are bitmap 
images.

Because they can represent subtle gradations of shades and color, bitmap images are the most 
common electronic medium for continuous-tone images, such as photographs or images created in 
painting programs. Bitmap images are resolution-dependent—that is, they represent a fixed number of
pixels. As a result, they can appear jagged and lose detail if they are scaled on-screen, or if they are 
printed at a higher resolution than they were created for.



About bitmap images and vector graphics 

Vector graphics

Vector graphics consist of lines and curves defined by mathematical objects called vectors. Vectors 
describe graphics according to their geometric characteristics. For example, when you draw a 1-inch 
circle in a vector-based program, the program creates the circle based on its shape and size. You can 
then move, resize, or change the color of the circle without losing the quality of the graphic. Graphics 
created in Adobe Illustrator(R) are vector graphics.

Vector graphics are resolution-independent—that is, they are not defined by a fixed number of pixels 
and so are automatically scaled to appear crisp and sharp on any output device at any resolution. As a
result, vector graphics are the best choice for type (especially small type) and bold graphics, such as 
logos, which require crisp, clear lines that can be scaled to many sizes.

Note that because computer displays are made up of a grid of pixels, both vector and pixel images are
displayed as pixels on-screen. Vector-based pro-grams render their shapes into pixels for display.
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Determining image size and resolution

In Adobe Photoshop, you determine the size of an image either by specifying pixel dimensions—to 
determine the size of the image on a monitor or video display, or by specifying print dimensions and 
image resolution—to determine the maximum size and resolution at which you can print the image.

An understanding of the relationship between pixel dimensions, resolution, and file size is key to 
understanding how Adobe Photoshop displays and produces output.

See also: 

About resolution and image size 

About file size and resolution 

Displaying the file size and resolution of an image 

Previewing the page layout and print size 

About resampling 

Changing the pixel dimensions of an image 

Changing the print dimensions and resolution of an image 

Determining a recommended resolution for an image 

Choosing an interpolation method 



Determining image size and resolution 

About resolution and image size

Several concepts are important when discussing the characteristics of bitmap images: pixel 
dimensions, image resolution, output resolution, screen frequency, and pixel depth (also called bit 
resolution).

See also: 

Pixel dimensions 

Image resolution 

Monitor resolution 

Printer resolution 

Screen frequency and image resolution 



About resolution and image size 

Pixel dimensions 

Every bitmap image contains a fixed number of pixels, measured in pixel height and pixel width (the 
number of pixels displayed along the height and width of the image, respectively). The total number of 
pixels determines the file size, or the amount of data in the image. Pixel dimensions, along with the 
size and setting of the monitor, determine how large an image appears on-screen. A typical 13-inch 
monitor displays 640 pixels horizontally and 480 vertically. Larger monitors can usually be set to 
display a varying number of pixels, for example, from 640 by 480 pixels, at which setting the pixels 
may be quite large, to 1152 by 870 pixels, at which setting the pixels are small.

If you’re planning to display an image online (on a Web page, for example), your maximum image size
is determined by the lowest pixel dimensions of the monitors used to display your image. For example,
if your audience will view your image on a 13-inch monitor, you will probably want to limit the size of 
your image to 640 by 480 pixels.

See also: 

Image resolution 

Monitor resolution 

Printer resolution 

Screen frequency and image resolution 



About resolution and image size 

Image resolution

The number of pixels displayed per unit of length in an image is called the image resolution, usually 
measured in pixels per inch (ppi). An image with a high resolution contains more, and therefore 
smaller, pixels than an image of the same dimensions with a low resolution. For example, a 1-inch-by-
1-inch image with a resolution of 72 ppi contains a total of 5184 pixels (72 pixels wide x 72 pixels high 
= 5184). The same image with a resolution of 300 ppi would contain a total of 90,000 much smaller 
pixels. 

Because they use more pixels to represent each unit of area, higher-resolution images can usually 
reproduce more detail and subtle color transitions when printed than lower-resolution images. 
However, once an image has been scanned or created at a given resolution, increasing the resolution 
in Photoshop will not usually improve the image quality because in this case, Photoshop must in effect
spread the same pixel information across a greater number of pixels. 

The proper image resolution to use for an image depends on how you intend to display or distribute 
the image. Using too low a resolution for a printed image results in pixelation—large pixels that 
produce very coarse-looking output. Using too high a resolution (pixels smaller than what an output 
device can reproduce) increases the file size unnecessarily and may increase the time required to 
print or distribute the image. 

See also: 

Pixel dimensions 

Monitor resolution 

Printer resolution 

Screen frequency and image resolution 
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Monitor resolution

The pixel setting of the monitor along with the size of the monitor determines the size (and therefore 
density) of the monitor pixels. When converting printed images to on-screen images and translating 
image resolution into pixel dimensions, it’s useful to know that the default resolution of a Macintosh 
monitor is typically 72 dpi; the default resolution of a PC monitor is typically 96 dpi.

In Photoshop, image pixels are translated directly into monitor pixels. This means that when the 
resolution of an image is higher than the monitor resolution, the image appears larger on-screen than 
its specified dimensions. For example, when you display a 1-inch-by-1-inch image with a resolution of 
144 ppi on a 72-dpi monitor, it appears in a 2-inch-by-2-inch area on-screen. Because the monitor can 
display only 72 pixels per inch, it needs 2 inches to display the 144 pixels that make up one edge of 
the image.

See also: 

Pixel dimensions 

Image resolution 

Printer resolution 

Screen frequency and image resolution 
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Printer resolution

If you are preparing images for print, it’s important to understand that printer resolution—that is, the 
number of dots per inch (dpi) that an imagesetter or laser printer produces —is usually proportional to,
but not the same as, image resolution—that is, the number of pixels that make up an image and that 
determine the size of the image on-screen. Most laser printers have output resolutions of 300 dpi to 
600 dpi and produce good results with images from 72 ppi to 150 ppi.

High-end imagesetters can print at 1200 dpi, 2400 dpi, or higher and produce good results with 
images from 200 ppi to 300 ppi.

See also: 

Pixel dimensions 

Image resolution 

Monitor resolution 

Screen frequency and image resolution 
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Screen frequency and image resolution

Many commercial and desktop printers use halftone screens, which consist of printer dots called 
halftone cells, to print grayscale images and color separations. Screen frequency, also known as 
screen ruling, refers to the number of halftone cells per inch in a halftone screen, and is measured in 
lines per inch (lpi). 

The relationship between image resolution and screen frequency determines the quality of detail in the
printed image. As a general rule, to produce a halftone image of the highest quality, use an image 
resolution that is 1.5 to 2 times the screen frequency. In some cases, however, depending on the 
image and the output device, using a lower resolution produces good results. 

Note: Some imagesetters and 600-dpi laser printers use screening technologies other than halftoning.
If you are printing the image on a non-halftone printer, consult your service provider or your printer 
documentation for the recommended image resolutions.

See also: 

Pixel dimensions 

Image resolution 

Monitor resolution 

Printer resolution 
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About file size and resolution

The file size of a digital image is measured in kilobytes (K) or megabytes (MB) and is proportional to 
the total number of pixels in the image. Although images with more pixels may produce more detail at 
a given size, they also result in larger file sizes. A 1-inch-by-1-inch 200-ppi image contains four times 
as many pixels as a 1-inch-by-1-inch 100-ppi image and so is four times as large. 

File size is an important factor in determining the disk space you need to store a file and the speed 
with which you can edit and print a file. Choosing an image resolution needs to be a compromise 
between capturing all the data you need to produce a good-quality image and keeping file size to a 
minimum.

Adobe Photoshop supports maximum pixel dimensions of 30,000 by 30,000 pixels per image. For 
example, if an image is 14 by 14 inches, it can have a resolution of at most 2142 ppi (30,000 pixels / 
14 inches = 2142 ppi). 



Determining image size and resolution 

Displaying the file size and resolution of an image

Adobe Photoshop displays the file size for each image in the lower left of the window. You can also 
display the dimensions, number of channels, and resolution information about a file. 

To display the file size:

Position the pointer over the triangle in the bottom border of the image window (Macintosh) or program
window (Windows), hold down the mouse button, and choose Document Sizes from the menu.

The file size values appear in the box at the lower left of the window.

The first value indicates the file size of the final file as it would be sent to the printer, a flattened file 
that contains no layer data. The second value shows the size of the file including all layers and 
channels, that is, the file size if the file were saved with all its layers. For more information on how 
layers affect file size, see Keeping track of file sizes.

To display dimensions, channel information, and resolution information: 

Press Option (Macintosh) or Alt (Windows), position the pointer over the box in the lower left of the 
window where the file size is displayed, and hold down the mouse button.

The box displays the height and width of the image (both in pixels and in the units of measurement 
currently selected for the rulers), the number of channels, and the image resolution.
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Previewing the page layout and print size

Before you change the size of an image, you may want to preview how the image will appear on the 
printed page. You may also want to preview the print size of the image—that is, the physical size that 
the image will have when printed.

To preview a page: 

Position the pointer over the box in the lower left of the window where the file size is displayed and 
hold down the mouse button.

The dimensions of the page shown in the page preview box correspond to the page size that you 
select when you choose File > Page Setup. Options selected in the Page Setup dialog box, such as 
calibration bars, appear as gray boxes. 

To preview the print size:

Choose View > Print Size.

Photoshop adjusts the magnification of the image to display it at its actual printed size, as specified in 
the Print Size section of the Image Size dialog box. For more information, see Changing the print 
dimensions and resolution of an image.
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About resampling

Resampling refers to changing the pixel dimensions (and therefore file size) of an image. In Adobe 
Photoshop, you can change the pixel dimensions directly, or you can change the pixel dimensions by 
changing either the print dimensions or the resolution while the Resample Image option is selected. 
When you downsample (or decrease the number of pixels), Photoshop deletes information from the 
image. When you resample up (or increase the number of pixels), Photoshop creates new pixel 
information based on the color values of the existing pixels. In both cases, Photoshop uses an 
interpolation method to determine how pixels are added or deleted (see Choosing an interpolation 
method).

Downsampling and then resampling up to the original resolution causes a deterioration in the quality of
the image. This is because once an image has been downsampled, some of the original color 
information is lost. When Photoshop resamples the image back up, it attempts to reconstruct the file 
based on the new color information. Because the added pixels are interpolated from the new image 
data, they can make the image appear blurry or out of focus, resulting in a poorer quality image than 
the original.

It’s best to scan in or create your image using a high enough resolution so that you don’t need to 
increase the pixel dimensions from within Adobe Photoshop. If you want to preview the effects of 
changing the pixel dimensions on-screen, or print proofs at different resolutions, resample a duplicate 
of your original file. See Duplicating images for instructions.



Determining image size and resolution 

Changing the pixel dimensions of an image

If you are preparing images for online use, such as for a Web site or a presentation, it’s most useful to 
specify image size in terms of the image’s pixel dimensions, that is, the number of pixels along each 
edge of the image. See About resolution and image size.

When you change the pixel dimensions of an image, you also change its printed characteristics—
either its printed dimensions or its image resolution. See About resampling for information on how 
Adobe Photoshop resamples images. 

To change the pixel dimensions of an image:

1    Choose Image > Image Size.

2    Make sure that Resample Image is selected, and choose an interpolation method, as described in 
Choosing an interpolation method.

3    To maintain the current proportions of pixel width to pixel height, select Constrain Proportions. This 
option automatically updates the width as you change the height, and vice versa.

4    Under Pixel Dimensions, enter values for Width and Height. To enter values as percentages of the 
current dimensions, choose Percent as the unit of measurement.

The new file size for the image appears at the top of the Image Size dialog box; the old file size 
appears in parentheses.

5    Click OK to change the pixel dimensions and resample the image.
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Changing the print dimensions and resolution of an image

If you are preparing images for print, it’s most useful to specify image size in terms of the printed 
dimensions and the image resolution. These two measurements determine the total pixel count and 
therefore the file size of the image. See About resolution and image size for information on pixel 
dimensions and resolution.

When you select Resample Image in the Image Size dialog box, Photoshop lets you change the print 
dimensions and resolution of an image independently of each other. In this case, Photoshop changes 
the total pixel count of the image to account for the new print dimensions or resolution. If you deselect 
Resample Image in the Image Size dialog box, Photoshop holds the pixel count of the image constant 
and adjusts the resolution as you change the dimensions and vice versa. For the best printed quality, 
it’s generally best to change the dimensions and resolution first with Resample Image deselected. 
Then resample only as necessary.

Note: If your image resolution is more than 2.5 times the screen ruling, an alert message appears 
when you try to print the image. This means that the image resolution is higher than necessary for the 
printer (see About resolution and image size). Save a copy of the file, and then lower the resolution. 

To change the print dimensions and resolution of an image:

1    Choose Image > Image Size.

2    Do one of the following:
•      To change only the print dimensions or only the resolution and adjust the total number of pixels in 
the image proportionately, make sure Resample Image is selected. Then choose an interpolation 
method (see Choosing an interpolation method).
•      To change the print dimensions and resolution without changing the total number of pixels in the 
image, deselect Resample Image.

3    To maintain the current proportions of image width to image height, select Constrain Proportions. 
This option automatically updates the width as you change the height, and vice versa.

4    Under Print Size, enter new values for the height and width. If desired, choose a new unit of 
measurement. Note that for Width, the Columns option uses the width and gutter sizes specified in the
Units & Rulers preferences.

5    For Resolution, enter a value for the new resolution. If desired, choose a new unit of measurement.

6    Click OK.
    To return to the original values displayed in the Image Size dialog box, hold down Option (Macintosh) or Alt 

(Windows) and click Reset. 
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Determining a recommended resolution for an image

If you plan to print your image using a halftone screen, the range of suitable image resolutions 
depends on the screen frequency of your output device (see About resolution and image size). You 
can have Photoshop determine a recommended resolution for your image based on your device’s 
screen frequency.

To determine a suggested resolution for an image:

1    Choose Image > Image Size.

2    Click Auto. 

3    For Screen, enter the screen frequency for the output device. If desired, choose a new unit of 
measurement. Note that the screen value is used only to calculate the image resolution; it does not set
the screen for printing.

Important: To specify the halftone screen ruling for printing, you must use the Halftone Screens dialog
box, accessible through the Page Setup dialog box. For more information on defining screen rulings, 
see Selecting halftone screen attributes.

4    For Quality, select one of the following options:
•      Draft to produce a resolution that is the same as the screen frequency (no lower than 72 pixels per
inch).
•      Good to produce a resolution that is 1.5 times the screen frequency.
•      Best to produce a resolution that is 2 times the screen frequency.

5    Click OK to enter the recommended resolution in the Image Size dialog box.
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Choosing an interpolation method 

When you resample an image using the Image Size command, Adobe Photoshop determines how 
pixels are added or deleted by using one of three interpolation methods. These methods look at the 
color values of the existing pixels in the image and adjust the color values of the new pixels to 
accommodate the added or deleted pixels. The more sophisticated interpolation methods attempt to 
choose color values that better preserve the quality and detail in the original image. 

You use the Interpolation setting in the General preferences to specify the default interpolation method
used to resample images with the Image > Image Size command and with the Edit > Transform 
command. The Image Size command also lets you specify an interpolation method other than the 
default. For more information, see Changing the pixel dimensions of an image and Changing the print 
dimensions and resolution of an image.

To specify the default interpolation method: 

1    Choose File > Preferences > General.

2    For Interpolation, choose one of the following options:
•      Nearest Neighbor to use the fastest, but least precise, method of interpolation. The lack of 
precision is evident in the jagged appearance of modified selections, especially when you’re distorting 
or scaling an image or performing multiple manipulations on a selection. 
•      Bilinear to use a medium-quality interpolation method.
•      Bicubic to use the most precise form of interpolation. This method results in the smoothest tonal 
gradations but is also the slowest form of interpolation. 

Applying the Unsharp Mask filter to the image after interpolation can help to refocus the image. For 
detailed instructions for using the Unsharp Mask filter, see Step 5: Sharpen the image.
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Scanning images

Adobe Photoshop software works with any scanner that has an Adobe Photoshop-compatible plug-in 
module or supports the TWAIN interface. The scanner plug-in modules that you have installed appear 
in the File > Import submenu. See Looking at the Work Area for more information about using and 
installing plug-in modules. 

Scanner drivers are provided and supported by the manufacturers of the scanners, not Adobe 
Systems. If you have problems with a scanner or during scanning, make sure that you have the latest 
version of the driver from the scanner manufacturer.

If the scanner you are using does not have an Adobe Photoshop-compatible scanner driver, you can 
use the manufacturer’s software to scan your images and then save the images as TIFF, PICT, or 
BMP files. Then open the files in Adobe Photoshop. 

Adobe Photoshop software supports the Microsoft push model for scanners under Windows 98. Check
with your scanner manufacturer to find out if your scanner supports this scanning model. You can use 
the Windows 98 Scanners and Cameras Control Panel to notify an application that a scanner wants to
initiate a data transfer. 

To have a scanner choose Adobe Photoshop as the application to initiate a data transfer:

1    In Windows 98, choose Start Menu > Settings > Control Panel > Scanners and Cameras.

2    Select the scanner you want to configure and select Properties.

3    Click the Event tab.

4    From the pop-up menu list, choose Scanner Event. Select Photoshop.

5    On scanner, push the Scan button to activate the scanner’s date transfer. Windows 95 launches 
Adobe Photoshop and displays the scanner’s Import dialog box. 

See also: 

About scan quality 

Importing an image using the TWAIN interface 

Determining the scan resolution 

Scanning using the file size setting 

Scanning using the resolution setting 

Optimizing the dynamic range of the scan 

Eliminating unwanted color casts 



Scanning images 

About scan quality

When you scan an image, you make several choices that affect the quality and usefulness of the 
resulting file. Before you scan an image, be sure to follow the instructions in this chapter for 
determining the scanning resolution and optimal dynamic range, and for developing a procedure for 
eliminating unwanted color casts.
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Importing an image using the TWAIN interface 

TWAIN is a cross-platform interface for acquiring images captured by certain scanners and frame 
grabbers. The manufacturer of the TWAIN device must provide a Source Manager and TWAIN Data 
source for your device; otherwise, the module will not work. 

Adobe Photoshop supports the current TWAIN_32 standard for scanning. Photoshop does not support
TWAIN software used with Windows 3.1. Contact the scanner manufacturer for information on the 
availability of TWAIN source modules that are compatible with Windows NT or Windows 95.

To import an image using the TWAIN interface:

1    If you’re using the TWAIN device for the first time with Adobe Photoshop, choose File > Import and 
choose the appropriate Select Source command from the submenu. Then select the device you’re 
using. You do not need to repeat this step for subsequent use of the TWAIN module.

If more than one TWAIN device is installed in your system and you want to switch devices, use the 
Select Source command to choose the new device. 

2    Choose File > Import and choose TWAIN Acquire (Macintosh) or the appropriate TWAIN command
(Windows) to use the TWAIN interface.
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Determining the scan resolution

Scan resolution, as it is used here and in following sections, is the same as image resolution—that is, 
the number of pixels per inch in the image when you open the file in Adobe Photoshop. For 
information on resolution and pixel dimensions, see About resolution and image size.

The scan resolution you use for printed output depends on the quality of output that you need as well 
as on the resolution of your printer and the size of the original image compared with the final image. 
For more information, see About resolution and image size.



Scanning images 

Scanning using the file size setting 

The best way to ensure that you have all the data you need for your Adobe Photoshop image is to 
create a dummy file that tells you exactly how much data— that is, what file size—you need for your 
final output. 

To calculate the file size before scanning an image:

1    Open Adobe Photoshop, and choose File > New. 

2    Enter the width, height, and resolution for your final printed image. The resolution should be 1.5 to 
2 times the screen frequency you will use to print. Make sure that the mode you plan to work with is 
selected. For more information, see Color modes and models.

The new dialog box displays the resulting file size above the dimensions. To produce the scan, select 
the area of the image you want to scan. Then adjust the resolution up or down until the file size is 
equal to or larger than the file size in the Photoshop File > New dialog box. You can fine-tune the 
image size and resolution later.

Once you have scanned the image and imported it into Photoshop, use the Image Size command to 
enter the correct width and height for the image.
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Scanning using the resolution setting

If you cannot use file size as the determining factor in choosing your scanner settings, you can 
calculate a scan resolution using the original and final image dimensions and the screen frequency of 
your output device.

To estimate scan resolution:

1    Multiply the screen frequency by 2. (2 is the typical ratio of image resolution to screen frequency 
needed to produce a good-quality image.)

2    Multiply the result in step 1 by the size change factor to get the estimated scan resolution you 
need.

For example, suppose you are scanning an image that is 2 inches wide by 3 inches high. You want to 
produce a final image that is 6 inches wide by 9 inches high. You are using a screen frequency of 85 
lpi.

To calculate the scan resolution, you first multiply 85 (the screen frequency) by 2 to get 170. You then 
multiply 170 by 3 (the ratio of final to original image dimensions) to get a scan resolution of 510 ppi. 

Different printing procedures might require different ratios of image resolution to screen frequency. It’s 
a good idea to check with your service provider or printer to finalize your requirement before you scan 
the image.
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Optimizing the dynamic range of the scan

When scanning an image, keep in mind that the human eye can detect a wider tonal range than can 
be printed. If your scanner lets you define the black and white points, set the points before scanning 
the file to produce the best tonal range and capture the widest dynamic range. After opening the file in 
Adobe Photoshop, use the color correction tools to set the white and black points for the digitized 
image. See Making Color and Tonal Adjustments for more information about setting the black and 
white points for an image. 
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Eliminating unwanted color casts

If your scanned image contains an unwanted color cast, you can perform a simple test to determine 
whether the cast has been introduced by your scanner. If you find that it has, you can use the same 
test file to create a color cast correction for all images scanned using that scanner.

To identify and correct a color cast introduced by a scanner:

1    Open a new Photoshop file and use the gradient tool ( ) to create a blend from pure black to 
pure white.

2    Choose Image > Adjust > Posterize and posterize the blend using 11 levels.
3    Print the 11-step gray wedge and then scan it into Photoshop.

Note: You can also perform this test using an 18-percent neutral gray card or an 11-step gray wedge 
from a photography store.

4    Open the Info palette and read the RGB values on-screen for each of the gray levels. Uneven R, 
G, and B values indicate a color cast. See Choosing a Color Display Mode for more information on 
color and color values. 

5    Use Levels to correct the color cast (see Making Color and Tonal Adjustments for instructions), and
then save the dialog box settings.

6    Open the scanned image you want to correct, reopen the Levels dialog box, and load the saved 
settings.
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Opening and importing images

Adobe Photoshop lets you open images in a variety of file formats. You can have multiple image 
windows open at one time. 

Import choices appear in the file format list in the Open dialog box or in the File > Import submenu. If a
file format does not appear, install the format’s plug-in module, as described in Installing plug-in 
modules.

See also: 

Opening files 

Opening PhotoCD files 

Opening Raw files 

Importing an anti-aliased PICT file (Macintosh only) 

Acquiring PICT Resources (Macintosh only) 



Opening and importing images 

Opening files

You can open files in the following ways:
•      The Open command lets you open files saved in formats that are supported by Photoshop (except 
for those that use Import modules). On the Macintosh, you can use the Open command to open files 
in the format that you specify.
•      In Windows, the Open As command lets you open a file that has a missing or incorrect file 
extension, or a file that does not appear in the Open dialog box. 
•      The Import command lets you open files saved in formats that use plug-in import modules. You 
can open anti-aliased PICT files and PICT Resource files (Macintosh), and files scanned using the 
TWAIN interface. You also use the Import command to use any third-party import modules you’ve 
installed. 

See also: 

To open a file on the Macintosh 

To open a file in Windows 

To specify the file format in which to open a file 

To use an import module 



Opening files 

To open a file on the Macintosh:

1    Choose File > Open.

2    To display all files in the selected folder, select Show All Files. To locate files in other folders, click 
Find and type the filename.

3    To preview files before opening them (if a preview has been saved with the image), select Show 
Thumbnail. This option requires the Apple(R) QuickTime(R) extension. Files created with a version of 
Adobe Photoshop prior to 2.5.1 must be resaved for the preview to appear. 

4    Select the file.

5    Click Open. In some cases, a dialog box appears, letting you set the open options.

For more information on a specific file format, see About file formats.

See also: 

To open a file in Windows 

To specify the file format in which to open a file 

To use an import module 



Opening files 

To open a file in Windows:

1    Choose File > Open.

2    For Files of Type, choose one of the following options:
•      All Formats to display all the files in the selected directory.
•      Any individual format to display only files saved in that format.

3    Select the file.

4    Click Open. In some cases, a dialog box appears, letting you set the open options.

For more information on a specific file format, see About file formats.

See also: 

To open a file on the Macintosh 

To specify the file format in which to open a file 

To use an import module 
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To specify the file format in which to open a file:

Do one of the following:
•      On the Macintosh, choose File > Open and select Show All Files. For Format, choose the desired 
file format and click Open.
•      In Windows, choose File > Open As. For Open As, choose the desired format and click Open.

Note: If the file does not open, then the chosen format may not match the file’s true format, or the file 
may be damaged.

See also: 

To open a file on the Macintosh 

To open a file in Windows 

To use an import module 



Opening files 

To use an import module:

Choose File > Import; then choose the import module from the submenu.

See also: 

To open a file on the Macintosh 

To open a file in Windows 

To specify the file format in which to open a file 
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Opening PhotoCD files 

To open PhotoCD files in Adobe Photoshop, choose the Kodak(R) PhotoCD(TM) format in the Open 
dialog box. The PhotoCD plug-in module can open 4096-by-6144-pixel resolution (64Base, 72 MB) 
images from Kodak Pro PhotoCD disks.

Note: The Kodak Precision Color Management System (KPCMS), required to use the Kodak CMS 
PhotoCD format, is automatically installed in your System Folder (Macintosh) or on your installation 
drive (Windows) when you install Adobe Photoshop. You cannot save files in the PhotoCD format from
Adobe Photoshop.

The Kodak PCMS PhotoCD plug-in module lets you read Photo YCC data from the disk and convert it 
to an Adobe Photoshop RGB color space. You can transform both the source image and the 
destination image using the profiles (or PT) you have installed. Using the Kodak PCMS application lets
you deliver the highest-quality image to Adobe Photoshop.

To open a Photo CD file:

1    Choose File > Open.

2    Select the file you want to open, and click Open. 

If the file does not appear, for Format, choose Show All Files (Macintosh) or All Formats from the Files 
of Type list (Windows).

3    Choose a resolution.

4    Click Source. Choose a device profile and an attribute from the list, and then click OK.

The first time you open a PhotoCD file, it opens using the default Source and Destination profiles. 
After you choose the profiles, they remain selected until you change them.

If you are unsure of the source profile, click Image Info and note the number next to Product Type of 
Original. On Windows, click Source and choose the profile that displays the same number for Device 
Settings.

5    Click Destination, and for Device, choose an RGB profile; then click Open. 

6    To display scanner information about the image, click Image Info; then click OK.

7    Click OK to open the image.
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Opening Raw files

The Raw format is designed to accommodate images saved in undocumented formats, such as those 
created by scientific applications. Compressed files, such as PICT, LZW, and GIF, cannot be opened 
using this format. For more information on Raw options, see About file formats.

To open a file using the Raw format:

1    Choose File > Open (Macintosh) or File > Open As (Windows).

2    Choose Raw from the file format list and click Open.

3    For Width and Height, enter values for the dimensions of the file.

4    To reverse the order of the width and height, click Swap.

5    Enter the number of channels.

6    Select Interleaved if the file was saved with a progressive display option. 

7    Select a color depth and, if necessary, a byte order.

8    For Header, enter a value.

9    If you are missing the dimensions or header value, you can have Adobe Photoshop estimate the 
parameters. Either enter the correct height and width values to estimate the header size, or enter the 
correct header size to estimate the height and width, and then click Guess.

10    To have Photoshop retain the header when you save the file, select Retain When Saving.

11    Click OK.
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Importing an anti-aliased PICT file (Macintosh only)

Choose File > Import > Anti-aliased PICT to import object-oriented PICT files, such as those created 
with MacDraw(R) and Canvas, as soft-edged, or anti-aliased, files. Because the entire PICT file must 
be in memory for this module to operate, you may not be able to use the module with large PICT files. 

The Anti-aliased PICT dialog box indicates the current file size and dimensions. To change the image 
dimensions, enter new values for Width and Height; the file size is updated to reflect the new 
dimensions. To maintain the same image proportions, select Constrain Proportions. You can choose to
open the Anti-aliased PICT file in either Grayscale or RGB mode.
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Acquiring PICT Resources (Macintosh only)

The PICT Resource module lets you read PICT resources from a file—for example, to read resources 
from another application. For more information, see About file formats. You specify the resources you 
want to read using the PICT dialog box. 

To preview a resource, click Preview; click the arrow buttons to step forward and backward through 
the resources. Note that the number displayed for Resource refers to the resource’s position in 
ascending order in the resource fork and not to the resource’s identification number.

Note: You can also open a file in the PICT Resource file format by choosing File > Open and, for 
Format, choosing PICT Resource. Using the Open command, however, automatically opens the first 
resource in the file in an Adobe Photoshop document and does not display any other PICT resources 
in the file.



Getting Images into Photoshop 

Viewing copyright and authorship information

Adobe Photoshop LE lets you view copyright and authorship information for an image that has been 
copyright-protected, or watermarked, using Digimarc PictureMarc(TM) technology. The watermark—a 
digital code embedded in the image—can be virtually invisible, and does not affect image integrity. 
Most filter and image operations—including color corrections, printing, and cropping—don’t affect the 
watermark. Copying an image with an embedded watermark also copies the watermark and any 
information associated with it.

Installing Adobe Photoshop LE using the Easy Install option (Macintosh) or Typical option (Windows) 
installs the Read Watermark filter automatically in the Plug-Ins folder. 

To read a watermark:

1    Choose Filter > Digimarc > Read Watermark. If the filter finds a watermark, a dialog box displays 
the creator ID, type of use, and whether the image has adult content.

Note: A message may appear that “a watermark was found but not readable” if you’re reading a 
scanned image from an inkjet printer or if you’re reading a small selection of an image. This message 
means that the PictureMarc technology was unable to decode the creator ID and usage information. 
For more information, contact Digimarc or visit its home page at www.digimarc.com. 

2    Click OK, or for more information choose from the following options:
•      If you have a Web browser installed, click Web Lookup to launch the browser, link to the Digimarc 
Web site, and display the artist’s contact information corresponding to the creator ID.
•      Call the phone number listed in the Watermark Information dialog box to get information faxed 
back to you.
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Creating new images 

The New command lets you create a blank, untitled Photoshop image. 

To create a new image:

1    Do one of the following:
•      To base the image dimensions and resolution on the Clipboard contents, choose File > New.
•      To base the image size on the default dimensions and resolution or the last entered parameters, 
hold down Option (Macintosh) or Alt (Windows) as you choose File > New.
•      To base the image size on an open window, choose File > New. With the New dialog box open, 
choose the image whose size you want to match from the Window menu. 

2    Type a name for the image and if desired, set the width, height, resolution, and mode. See Color 
modes and models for information on modes.

3    For Contents, select one of the following:
•      White to fill the background with white, the default background color.
•      Background Color to fill the image with the current background color.
•      Transparent to create an image containing a single layer with no color values. 

Note: Because images created with the transparent option contain a single layer instead of a 
background, they must be saved in Photoshop format. Photoshop is the only format that supports 
layers. See Saving files for more information.
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Cropping an image

Adobe Photoshop provides two ways for you to select part of an image and discard the rest:
•      The Image > Crop command discards the area outside of a rectangular selection and keeps the 
resolution of the resulting image constant. 
•      The crop tool ( ) lets you crop an image by dragging over the area you want to keep. You can 
also define the size and resolution of the cropped area. The advantage of using the crop tool is that 
you can rotate and resample the area as you crop.

See also: 

To crop an image using the Crop command 

To use the crop tool 

To specify the size and resolution of the cropped area 



Cropping an image 

To crop an image using the Crop command: 

1    Use the rectangle marquee tool to select the part of the image you want to keep. Make sure that 
the Feather option is set to 0 pixels. For more information, see Feathering a selection.

2    Choose Image > Crop.

See also: 

To use the crop tool 

To specify the size and resolution of the cropped area 



Cropping an image 

To use the crop tool:

1    Position the pointer on the marquee ( ) tool in the toolbox, and drag to select the crop tool (
). 

2    Drag over the part of the image you want to keep.
When you release the mouse button, the crop marquee appears as a bounding box with handles at the 
corners and sides. 
3    Use the following methods to adjust the crop marquee:

•      To move the marquee to another position, position the pointer inside the bounding box and drag. 
•      To scale the marquee, drag a handle. To constrain the proportions, hold down Shift as you drag a 
corner handle.
•      To rotate the marquee, position the pointer outside the bounding box (the pointer turns into a 
curved arrow) and drag.

4    To crop the image, press Return (Macintosh) or Enter (Windows). To cancel the cropping operation,
press Esc. 

Note: You can’t rotate the crop tool marquee for an image in Bitmap mode.

See also: 

To crop an image using the Crop command 

To specify the size and resolution of the cropped area 



Cropping an image 

To specify the size and resolution of the cropped area:

1    Double-click the crop tool ( ) in the toolbox to display its Options palette.
2    Select Fixed Target Size.
3    To begin with the size and resolution values of the current image, click Front Image.
4    Choose the units of measurement you want from the menus. Note that for Width, the Columns option 
uses the width and gutter sizes specified in the Units & Rulers preferences
5    Enter values for the size and resolution you want for the cropped area. 
The Fixed Target Size option constrains the pixel count of the image. As a result, if you specify a size but 
not a resolution, Adobe Photoshop changes the image resolution to compensate for the size change. If 
you specify a resolution but not a size, Photoshop changes the size to compensate for the change in 
resolution. 

6    Drag over the area you want to keep with the crop tool and then press Return (Macintosh) or Enter 
(Windows). 

The final image has the specified size and resolution.

See also: 

To crop an image using the Crop command 

To use the crop tool 
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Increasing the size of the work canvas

The Canvas Size command lets you add or remove work space, or extra canvas area, around an 
existing image. You increase the canvas area by specifying the height and width you want the canvas 
to be. 

You can also use the Canvas Size command to crop an image by decreasing the canvas area; 
however, if you want to adjust the size and resolution of an image, you should use the Image Size 
command or the crop tool. If you use the Canvas Size command to crop an image, you might 
inadvertently lose image information that you cannot recover.

To use the Canvas Size command: 

1    Choose Image > Canvas Size.

2    Choose the units of measurement you want from the menus. Note that for Width, the Columns 
option uses the width and gutter sizes specified in Units & Rulers preferences

3    Enter the dimensions in the Width and Height boxes. The value above the text boxes reflects the 
new file size.

4    For Anchor, click a square to indicate where you want the existing image to be positioned on the 
new canvas. 

5    Click OK.

Added canvas appears in the background color. If the background is transparent, the added canvas is 
also transparent.



Choosing a Color Display Mode

Familiarity with color theory and terminology can help you understand how color is measured and how
Adobe Photoshop Limited Edition uses this information to define, display, and print color values.

See also: 

Color modes and models 

About color channels 

Measuring color values in the Info palette 

Adjusting the monitor display 

Converting between bit depths 

Converting from one mode to another 

Converting to Bitmap mode 

Converting a Bitmap-mode image to grayscale 

Converting to indexed color 

Manipulating the color table of an indexed-color image 



Choosing a Color Display Mode 

Color modes and models

Adobe Photoshop LE can use a number of color modes for displaying, printing, and storing images. 
The red, green, and blue (RGB) mode and the hue, saturation, and brightness (HSB) mode are based 
on established color models for describing and reproducing color. In addition to modes based on color 
models, Photoshop includes modes with restricted color ranges, such as Bitmap, Grayscale, and 
Indexed color modes. 

See also: 

HSB model 

RGB model 

RGB mode 

Bitmap mode 

Grayscale mode 

Indexed color mode 



Color modes and models 

HSB model

The HSB model is based on the human perception of color. In the HSB model, all colors are described
in terms of three fundamental characteristics:
•      Hue is the wavelength of light reflected from or transmitted through an object. More commonly, 
hue is identified by the name of the color such as red, orange, or green. Hue is measured as a 
location on the standard color wheel and is expressed as a degree between 0° and 360°.
•      Saturation, sometimes called chroma, is the strength or purity of the color. Saturation represents 
the amount of gray in proportion to the hue and is measured as a percentage from 0% (gray) to 100% 
(fully saturated). On the standard color wheel, saturation increases as one approaches the edge of the
wheel; saturation decreases as one approaches the center.
•      Brightness is the relative lightness or darkness of the color and is usually measured as a 
percentage from 0% (black) to 100% (white).

In Photoshop, you can use the HSB model to define a color in the Color palette or Color Picker dialog 
box. 



Color modes and models 

RGB model

A large percentage of the visible spectrum can be represented by mixing three basic components of 
colored light in various proportions and intensities. These components are known as the primary 
colors: red, green, and blue (RGB). When the three primary colors overlap, they create the secondary 
colors: cyan, magenta, and yellow. 

Since the primary colors combine to create white, they are also called additive colors. Adding all the 
colors together creates white—that is, all the light is reflected back to the eye. Additive colors are used
for lighting, video, film recorders, and monitors. Your monitor, for example, creates color by emitting 
light through red, green, and blue phosphors.



Color modes and models 

RGB mode

Photoshop’s RGB mode uses the RGB model, assigning an intensity value to each pixel ranging from 
0 (black) to 255 (white) for each of the RGB components in a color image. For example, a bright red 
color might have an R value of 246, a G value of 20, and a B value of 50. When the values of all three 
components are equal, the result is a shade of gray. When the value of all components is 255, the 
result is pure white; when all components have values of 0, the result is pure black. 

RGB is the default mode for new Photoshop images. RGB Images use three colors to reproduce up to
16.7 million colors on-screen. RGB images are three channel images, so they contain 24 (8 x 3) bits 
per pixel.



Color modes and models 

Bitmap mode

Bitmap mode uses one of two color values (black or white) to represent the pixels in an image. Images
in Bitmap mode are called bitmapped, or 1-bit, images because they have a pixel depth of 1. 



Color modes and models 

Grayscale mode

Grayscale mode uses up to 256 shades of gray to represent an image. In Adobe Photoshop, every 
pixel of a grayscale image has a brightness value ranging from 0 (black) to 255 (white). The values 
between 0 and 255 correspond to points on the grayscale spectrum. Grayscale values can also be 
measured as percentages of black ink coverage (0% is equal to white and 100% is equal to black). 
Images produced using black-and-white or grayscale scanners are typically displayed in Grayscale 
mode.

You can convert both Bitmap-mode and color images to grayscale. Grayscale mode lets you convert a
color image to a high-quality black-and-white image. In this case, Adobe Photoshop discards all color 
information in the original image; the gray levels (shades) of the converted pixels represent the 
luminosity of the original pixels. 

When you convert a grayscale image to an RGB image, the color values for each pixel are assigned 
that pixel’s previous gray value. 
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Indexed color mode

An indexed-color image is a single-channel image and is based on a palette of at most 256 colors. 
When you convert an image to indexed color, Photoshop builds a color lookup table, which stores and 
indexes the colors in the image. If a color in the original image does not appear in the table, the 
program matches the color to the closest color in the color table or simulates the color using the 
available colors. 

Indexed color mode is useful when you want to limit the palette of colors used in an image—for 
example, when you want to use the image in a multimedia animation application or on a Web page. 
Using an indexed color table lets you reduce the file size of an image while maintaining the visual 
quality that you need. For more information on color tables and converting images to indexed color, 
see Converting to indexed color.
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About color channels

Every Adobe Photoshop image contains one or more channels, which represent information about the 
color elements in the image. For example, an RGB image has three channels: one for red information,
one for green information, and one for blue information. In this sense, a channel is analogous to a 
plate in the printing process in which a separate plate is used to apply each layer of color. 

By default, Bitmap-mode, grayscale, and indexed-color images have one channel; RGB mode images 
contain three channels. 
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Measuring color values in the Info palette

You can determine the color values of any part of your image using the Info palette. Depending on 
your Info palette setup, you can select any tool, position the pointer over any part of an image, and 
determine the color value under the pointer. You can customize the Info palette to express color values
using the HSB or RGB models or Grayscale mode without changing the mode of the image itself. For 
more information on measuring color with the Info palette, see Previewing color values and 
Customizing the Info palette.



Choosing a Color Display Mode 

Adjusting the monitor display

Although the RGB color model is capable of displaying a large portion of the visible spectrum, the 
video system that sends data to a monitor often limits the number of colors that can be displayed at 
one time. By understanding the way color data is measured in digital files and on-screen, you can 
adjust Photoshop’s preferences to offset the limitations of your monitor.

See also: 

About pixel depth 

Color display options for 8-bit color displays 



Adjusting the monitor display 

About pixel depth

Pixel depth, also called bit resolution or color depth, measures how much color information is available
for each pixel in an image. Greater pixel depth (more bits of information per pixel) means more 
available colors and more accurate color representation in the digital image. For example, a pixel with 
a pixel depth of 1 has two possible values: black and white. A pixel with a pixel depth of 8 has 28, or 
256, possible values; and a pixel with a bit depth of 24 has 224, or roughly 16 million, possible values. 
Common values for pixel depth range from 1 to 48 bits per pixel. 
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Color display options for 8-bit color displays

Each image mode in Adobe Photoshop uses a different color lookup table, or color palette, to store the
colors used in the image. When you’re working with a display system that supports 8-bit color (or 
fewer colors), the video card displays only 256 different colors at one time. For example, an RGB 
image can display 16.7 million colors in any image at one time. However, if the monitor can display 
only 256 of the 16.7 million colors, Adobe Photoshop uses a technique called dithering to simulate the 
257th color and each additional color thereafter. Dithering adjusts adjacent pixels of different colors to 
give the illusion of a third color, which simulates the display of colors that are not in the current color 
palette.

By default, Adobe Photoshop uses pattern dithering to display colors not in the current color palette, 
which can result in a distinctive pattern of darker or lighter areas in the image. In contrast, diffusion 
dithering spreads out the inaccuracy in representing a pixel’s color to the surrounding pixels and 
eliminates distinctive patterning. Diffusion dithering, however, can cause visual inconsistencies when 
only part of a screen is redrawn (for example, when you scroll, edit, or paint). However, when you print
the image, the on-screen dithering effects will not be printed. You can set this and other display 
options in the Preferences dialog box. 

To select a color display option:

1    Choose File > Preferences > Display & Cursors.

2    Choose either or both of the following options:
•      Use System Palette to make the display of inactive images more accurate.
•      Use Diffusion Dither to minimize dither patterns produced by dithering.



Choosing a Color Display Mode 

Converting between bit depths

In most cases, RGB and grayscale images contain 8 bits of data per color channel. With three 
channels in an RGB image, this translates to a 24-bit RGB bit depth (8 bits x 3 channels) and an 8-bit 
grayscale bit depth (8 bits x 1 channel). Photoshop can also read and import 48-bit RGB and 16-bit 
grayscale images (each with 16 bits of data per color channel). 

Note:    A 16-bit-per-channel image provides finer distinctions in color, but its file size is much larger 
than an 8-bit-per-channel image.

Photoshop supports these tools and commands in 16-bit-per-channel images: the marquee, lasso, 
zoom, hand, and eyedropper tools; and the Duplicate, Levels, Auto Levels, Curves, and Rotate 
Canvas commands. To take full advantage of Photoshop’s features, you can convert a 16-bit-per-
channel image to an 8-bit-channel image. 

To convert from 8 bits per channel to 16 bits per channel:

1    Flatten the image you want to convert, as explained in Flattening all layers.

2    Choose Image > Mode >16 Bits/Channel.

To convert from 16 bits per channel to 8 bits per channel:

Choose Image > Mode > 8 Bits/Channel.
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Converting from one mode to another

When you convert an image from one mode to another, the transition between modes creates a 
permanent change to the color values in the image. For example, when you convert an RGB image to 
Indexed color mode, the RGB colors that do not appear in the color table are converted to the nearest 
matching colors in the table. Consequently, it’s best to convert to another mode only after doing as 
much editing as possible in the image’s original mode. If you think you may need an image for more 
than one purpose, save a backup copy of that image before converting it. 

Important: Converting an image between certain modes flattens the image. Be sure to save a copy of
your image that includes all layers if you want to be able to edit the original version of the image after 
the conversion. 

To convert an image to another mode:

Choose Image > Mode and choose the mode you want from the submenu. Images in certain modes 
cannot be converted directly to other modes. Modes not available for the active image appear dimmed
in the menu. 

The following mode conversions cause a file to be flattened: RGB to Indexed color mode, and 
Grayscale to Bitmap or Indexed color mode.
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Converting to Bitmap mode

To convert a color image to Bitmap mode, you must first convert it to grayscale. This removes the hue 
and saturation information from the pixels and leaves the brightness values. Because few editing 
options are available for Bitmap-mode images, it’s usually best to edit the image in Grayscale mode 
and then convert it to Bitmap mode if necessary to export the image to another application.

To convert a grayscale image to Bitmap mode:

1    Open the grayscale image; then choose Image > Mode > Bitmap.

2    For Output, enter a value for the output resolution of the Bitmap-mode image and choose a unit of 
measurement. By default, the current image resolution appears as both the input and the output 
resolutions.

3    Select a bitmap conversion method, and click OK. If you choose Halftone Screen, see the following
section. The other conversion methods are described in Additional bitmap conversion options.

See also: 

Specifying a halftone screen for a Bitmap-mode image 

Additional bitmap conversion options 
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Specifying a halftone screen for a Bitmap-mode image

The Halftone Screen option in the Bitmap dialog box lets you convert the pixels in a grayscale image 
to simulated halftone dots.

To specify the halftone screen for a Bitmap-mode image: 

1    Choose Image > Mode > Bitmap.

2    Click Halftone Screen; then click OK.

3    For Frequency, enter a value for the screen frequency and choose a unit of measurement. Values 
can range from 1.0 to 999.999 for lines per inch and from 0.400 to 400.000 for lines per centimeter. 
You can enter decimal values. 

The screen frequency is the ruling of the halftone screen. The frequency depends on the paper stock 
and type of press used for printing. Newspapers commonly use an 85-line screen. Magazines use 
higher resolution screens, such as 133 and 150. Check with your print shop for the correct screen 
frequency to use.

4    Enter a value for the screen angle in degrees. Values can range from –180 to +180. 

The screen angle refers to the orientation of the screen. Continuous-tone and black-and-white halftone
screens commonly use a 45° angle. 

5    For Shape, choose the dot shape you want.

6    Click OK.

You can save the halftone screen settings and reuse them with other images by using the Save and 
Load buttons in the Halftone Screen dialog box.
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Additional bitmap conversion options

Like the Halftone Screen option, the other four bitmap conversion options determine the quality of the 
Bitmap-mode image, ranging from a high-contrast image to a textured or halftone-screen effect for 
output on non-PostScript(R) printers. 

50% Threshold

Converts pixels with gray values above the middle gray level (128) to white, and converts pixels below
the middle gray level to black. The result is a very high-contrast, black-and-white representation of the 
image.

Pattern Dither

Converts an image by organizing the gray levels into geometric configurations of black and white dots.

Diffusion Dither

Uses an error-diffusion process to convert the image. The program starts at the pixel in the upper left 
corner of the image and evaluates its gray-level value. If the value is above middle gray (128), the 
pixel is changed to white. If the value is below 128, the pixel is changed to black. There is some error 
in the conversion because the original pixel is usually not pure between black and white, and the 
conversion changes it to either a black or a white value. The amount of error is transferred to 
surrounding pixels before they are converted. In this way, the error is diffused throughout the image. 
The result is a grainy, filmlike texture. This option is useful for viewing images on a black-and-white 
screen.
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Converting a Bitmap-mode image to grayscale 

A Bitmap-mode image converted to grayscale consists of one gray level (black). Since few editing 
options are available in Bitmap mode, you might convert a Bitmap-mode image to a grayscale image 
for editing and then convert it back to a Bitmap-mode image to export it to other applications. 
However, keep in mind that the appearance of a Bitmap-mode image edited in grayscale mode may 
change when you convert it back to Bitmap mode. 

To convert a Bitmap-mode image to grayscale:

1    Choose Image > Mode > Grayscale.

2    Enter a value for the size ratio.

The size ratio is the factor by which you want to scale down the size of the image. For example, to 
reduce the size of the grayscale image by 50%, enter 2 for the size ratio. If you enter a number greater
than 1, the program averages multiple pixels in the Bitmap-mode image to produce a single pixel in 
the grayscale image. This lets you generate multiple shades of gray from an image scanned on a 1-bit
scanner. 
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Converting to indexed color

At times, you might want to convert an RGB image to an indexed-color image to edit an image’s color 
table or to export an image to an application that supports only 8-bit color. This is useful, for example, 
for multimedia animation applications and World Wide Web pages. When you convert an RGB image 
to indexed color, all but 256 colors are deleted from the image. 

To convert an RGB image to an indexed-color image:

1    Choose Image > Mode > Indexed Color.

2    Select the desired palette, color depth, and dither methods. These options are described in the 
following sections.

3    Click OK.

See also: 

Specifying a palette 

Specifying the color depth 

Specifying dithering options 
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Specifying a palette 

Eight palette types are available for converting an image to indexed color. Choose Image > Mode > 
Color Table to view the results of each palette option.

Exact

Uses exactly the same colors for the palette as those that appear in the RGB image. Since all the 
colors in the image are present in the image’s palette, there is no dithering. This option is available 
only if 256 or fewer colors are used in the RGB image.

System (Macintosh)

Uses the Macintosh system’s default 8-bit palette, which is based on a uniform sampling of RGB 
colors. 

System (Windows)

Uses the Windows system’s default 8-bit palette, which is based on a uniform sampling of RGB colors.

Web

Uses the palette most often used by Web browsers to display 8-bit images. 

Uniform

Creates a palette based on a uniform sampling of colors from the color spectrum. For example, if you 
choose an 8-bit color depth, Adobe Photoshop takes six evenly spaced color levels each of red, green,
and blue, and calculates the combinations of these colors to produce a uniform palette of 216 colors (6
x 6 x 6 = 216). To create a uniform palette composed of fewer colors, choose a lower color depth. The 
total number of colors displayed in the image corresponds to the perfect cube (8, 27, 64, 125, or 216) 
nearest to the chosen color depth.

Adaptive

Creates a palette by sampling colors from the more commonly used areas of the color spectrum that 
appears in the image. For example, if you have an RGB image that has only the colors green and 
blue, the resulting palette is made up primarily of green and blue colors. Because the colors in most 
images are concentrated in particular areas of the spectrum, this table can be useful. 

To control more precisely how the Adaptive palette is built, select a part of the image that contains the 
colors you want to use in the palette before you make the conversion. When you have an active 
selection in the image, Adobe Photoshop weights the conversion toward the colors in the selection.

Custom

Lets you create your own palette. When you select this option, the program displays the Color Table 
dialog box. You can then edit the color table and save it for later use or click Load to load a previously 
created color table. Editing a color table is described in Manipulating the color table of an indexed-
color image.

Previous

Converts the image by using the custom palette from the previous conversion. This option makes it 
easy to convert a number of images using the same custom palette. This option is available only after 
you have converted an image using the Custom or Adaptive option.



Converting to indexed color 

Specifying the color depth

When you choose the Uniform or Adaptive palette, you can specify the color depth (also known as 
pixel depth), or the number of bits of color information per pixel, for the indexed-color image. The color
depth you choose determines the number of colors used to display (or print) an image. For example, if
you choose 4 bits per pixel, the image is composed of 16 colors; if you choose 6 bits per pixel, the 
image is composed of 64 colors; if you choose 8 bits per pixel, the image is composed of 256 colors. 
(The number of colors used is displayed in the Colors text box.) In addition, you can specify the exact 
number of colors to be displayed (up to 256) by choosing Other for Color Depth and entering a value 
for Colors. 

The options in the Indexed Color dialog box control only how the indexed color table is created. Adobe
Photoshop still treats the image as an 8-bit, 256-color image.



Converting to indexed color 

Specifying dithering options

Unless you’re using the Exact color table option, the color table may not contain all the colors used in 
the image. To simulate colors not in the color table, you can choose to dither the colors. Dithering 
mixes the pixels of the available colors to simulate the missing colors. You can choose from three 
dithering options:
•      None: Does not dither colors but instead uses the color closest to the missing color. This tends to 
result in sharp transitions between shades of color in the image, creating a posterized effect.
•      Diffusion: Uses a less structured method than does the Pattern option to dither colors.
•      Pattern: Adds random pixels in patterns to simulate the colors that are not in the color table. This 
option is available only when you’re using the Macintosh System palette.



Choosing a Color Display Mode 

Manipulating the color table of an indexed-color image

When you convert an RGB image to an indexed-color image, or when you work in an original indexed-
color image, you might want to change one or more colors in the table. You can also model the colors 
after a predefined color table. Each indexed-color image has its own color table, and you can save a 
color table for reuse with other indexed-color images. 

There are two types of indexed-color images: those with a limited number of colors (fewer than 256), 
and pseudocolor images (grayscale images that display variations in gray levels with color rather than 
shades of gray). Pseudocolor images are often used in scientific and medical applications. The color 
table editing features discussed in the following sections are most useful with pseudocolor indexed 
images. These features can also be used to produce special effects with indexed-color images that 
have a limited number of colors.

Note: If you just want to change the colors in an image, choose Image > Adjust, and use the color 
correction commands in the submenus.    for a description of these commands.

See also: 

Editing colors in the indexed color table 

Choosing a color-table option 

Saving and loading a color table 



Manipulating the color table of an indexed-color image 

Editing colors in the indexed color table 

To edit a color table, you select the colors you want to change. Although our example shows the 
editing of a color table for a pseudocolor image, the following procedure applies to all indexed-color 
images. 

To edit colors in the color table:

1    Open the indexed-color image.

2    Choose Image > Mode > Color Table.

3    Click or drag in the table to choose the color or range of colors you want to change. 

4    Choose the color you want, see Using the Adobe Photoshop Color Picker, and click OK. 

If you are changing a range of colors, AdobePhotoshop creates a gradient in the color table between 
the starting and ending colors. The first color you choose in the Color Picker is the beginning color for 
the range. When you click OK, the Color Picker reappears so you can choose the last color in the 
range.

The colors you selected in the Color Picker are placed in the range you selected in the Color Table 
dialog box.

5    Click OK in the Color Table dialog box to apply the new colors to the indexed-color image.



Manipulating the color table of an indexed-color image 

Choosing a color-table option

Your indexed color table can be modeled after one of six predefined color tables. You select a 
predefined color table from the Table menu in the Color Table dialog box. 
•      Custom: Used whenever the table is not one of Adobe Photoshop software’s built-in color tables.
•      Black Body: Displays a transition of colors based on the different colors a black-body radiator 
emits as it is heated—from black to red, orange, yellow, and white. 
•      Grayscale: Displays a smooth transition from black to white in 256 levels of gray. 
•      Spectrum: Displays a smooth transition between the colors that result when white light passes 
through a prism: violet, blue, green, yellow, orange, and red. 
•      Macintosh System: Displays the standard Macintosh 256-color system palette. 
•      Windows System: Displays the standard Windows 256-color system palette. 



Manipulating the color table of an indexed-color image 

Saving and loading a color table 

You use the Save and Load buttons in the Color Table dialog box to save your indexed color tables for 
use with other Adobe Photoshop images. Once you load a color table into an image, the colors in the 
image are changed to reflect the color positions they reference in the new color table. 

Note: You can also load saved color tables into the Swatches palette. See Saving, loading, and 
replacing swatches for more information.



Making Color and Tonal Adjustments

Adobe Photoshop Limited Edition offers a number of color correction tools that let you adjust the color 
and tonal values of your image. You can use these tools to correct unwanted color casts, to sharpen a 
narrow tonal contrast, or to create special effects.

See also: 

Using the Adobe Photoshop color correction tools 

Step 1: Check the scan quality and tonal range 

Step 2: Set the highlight and shadow values 

Step 3: Adjust the midtones and fine-tune the tonal correction 

Step 4: Adjust the color balance 

Step 5: Sharpen the image 

Using the Variations command for generalized tonal and color adjustments 

Using the Brightness/Contrast command 

Special-purpose color adjustment tools 



Making Color and Tonal Adjustments 

Using the Adobe Photoshop color correction tools

All of the Adobe Photoshop color correction tools work essentially the same way: by mapping existing 
ranges of pixel values to new ranges of values. The difference between the tools is the amount of 
control you have over the ranges of values. For example, the Brightness/Contrast command makes 
the same adjustment to every pixel in the selection or image—if you increase the brightness value by 
30, 30 is added to the brightness value of every pixel. Curves, on the other hand, replicates high-end 
color correction systems and lets you isolate 16 ranges of pixel values (colors) between pure highlight 
and pure shadow.

See also: 

Using color adjustment commands 

Previewing color adjustments 

Previewing with a 24-bit or 32-bit video card (Macintosh only) 

Previewing color values 

Saving and loading color adjustment settings 



Using the Adobe Photoshop color correction tools 

Using color adjustment commands

To use most color adjustment tools, choose a command from the Image > Adjust submenu. The 
commands under the Adjust submenu apply only to the selected layer. When you adjust the color 
values in the selected layer, you permanently alter the pixels in this layer.

Most color adjustment tools have a dialog box associated with them.

To open a color adjustment dialog box:

Choose Image > Adjust and choose the command you want from the submenu.
 To cancel color changes without closing a color adjustment dialog box, hold down Option (Macintosh) or Alt 

(Windows) to change the Cancel button to the Reset button, and then click Reset.



Using the Adobe Photoshop color correction tools 

Previewing color adjustments

In most cases, when you make color changes to a selection, Adobe Photoshop displays the changes 
throughout the entire screen. The program modifies the video card’s color lookup table (VLUT) in 
response to the changes you specify. Color table animation, also called video table lookup, is 
controlled by the video card, not by Adobe Photoshop. Color table animation allows faster previewing 
of color adjustments when you are making changes to a Photoshop image; however, it does not 
always preview the image accurately. 

Note: On most systems running Windows, color table animation works only if the monitor is set to 256 
colors. For color table animation to work in 24-bit mode with Windows, you must have installed a color 
table animation extension, supplied by your video card manufacturer, in the Plug-Ins directory. 

You can display an accurate preview by selecting the Preview option in one of the color adjustment 
dialog boxes. When you select Preview, you turn off the color table animation; only the image or the 
selected area of the image is shown with the color correction. This allows you to see accurately the 
effect of color adjustments on a selected area.

To turn on previewing and deactivate color table animation:

Select the Preview option in any color correction dialog box. 

The color table animation is deactivated, and Adobe Photoshop displays the effects of the changes on 
the current selection only. 

To turn off color table animation:

1    Choose File > Preferences > Display & Cursors.

2    Deselect Video LUT Animation and click OK.



Using the Adobe Photoshop color correction tools 

Previewing with a 24-bit or 32-bit video card (Macintosh only)

The color table animation feature can cause problems if you are using a 24-bit or 32-bit video card for 
which certain color QuickDraw(TM) commands have not been properly implemented. If you have a 
problem, contact your video card manufacturer for ROM updates. You should also reset the video 
mode, and turn off the Video LUT Animation option in the Display & Cursors preferences dialog box. 

To reset the video mode to preview changes using a 24-bit or 32-bit video card:

1    Choose Control Panels from the Apple menu, and double-click Monitors.

2    Click one of the other color display options (such as 256 Colors), and perform a preview to see the 
results.

3    Click your original color display option.

4    Close the Control Panel.

5    In Photoshop, choose File > Preferences > Display & Cursors and deselect Video LUT Animation; 
then click OK.

Although you will be able to preview changes correctly with the Preview option selected, you will not 
be able to turn the color table animation off and on by clicking the Preview option in the dialog box.



Using the Adobe Photoshop color correction tools 

Previewing color values

You can use the Color palette and the Info palette to preview the color values of pixels affected by the 
color adjustments you’re making. 

When you move the pointer over an area of your image that contains pixels while working with one of 
the color adjustment dialog boxes, the Info palette displays two values. The value in the left column is 
the original pixel’s color value; the value in the right column is the color value after the adjustment is 
made. 

To use the Info palette to preview color changes:

1    Choose Window > Show Info. (See Customizing the Info palette for information on the Info palette 
display options.)

2    Open a color adjustment dialog box (see Using color adjustment commands).

3    Move the pointer over an area of the image you want to examine. The eyedropper reads the value 
of a single screen pixel, a 3-by-3 screen pixel area, or a 5-by-5 screen pixel area, depending on the 
Sample Size option you have chosen in the Eyedropper Options palette.

Note: While a color adjustment dialog box is open, the eyedropper tool is automatically active outside 
the dialog box; however, you still have access to the scroll controls and to the hand and zoom tools 
when using keyboard modifier keys.

The Info palette displays the before and after color values at the location under the pointer.

To use the Color palette to preview color values: 

1    Choose Window > Show Color.

2    Open a color adjustment dialog box (see Using color adjustment commands).

3    Click the pixel you want to preview. The color values of the pixel after the adjustment has been 
made are shown in the Color palette. 

 To cancel color changes without closing a color adjustment dialog box, hold down Option (Macintosh) or Alt 
(Windows) to change the Cancel button to the Reset button, and then click Reset.



Using the Adobe Photoshop color correction tools 

Saving and loading color adjustment settings

The Save and Load buttons in the Levels, Curves, and the Hue/Saturation dialog boxes let you save 
the color corrections you make using those dialog boxes and let you apply the corrections to other 
images.

To apply a color correction adjustment to another image: 

1    Click the Save button in the color correction dialog box you are using and name and save the color 
correction settings. 

2    Close the color correction dialog box, and open the image to which you want to apply the 
corrections. 

3    Reopen the color correction dialog box and click the Load button. Locate and open the saved color 
correction file.

4    Click OK to apply the corrections to the image.



Making Color and Tonal Adjustments 

Step 1: Check the scan quality and tonal range

Although you can use Photoshop to correct certain scanning flaws, if not enough detail has been 
captured in the original image, it’s difficult if not impossible to produce high-quality printed output. See 
Scanning images for information on making a scan.

A histogram is a graphic representation of the number of pixels at each brightness level in an image. 
You can use the histogram to verify that the image contains enough detail to make a good correction. 
Too little detail in an image may be the result of a bad scan or photograph, or it may be caused by too 
many color corrections, which result in loss of pixel values. If you think that an image may have been 
overcorrected, revert to the original image before applying the color correction procedures described 
in this chapter.

The histogram also gives you a quick picture of the tonal range of the image, also known as the image
key type. An image whose detail is concentrated in the shadows is known as a low-key image; an 
image whose detail is concentrated in the highlights is known as a high-key image. Identifying the 
tonal range of the image helps determine the appropriate tonal corrections.

 To determine whether enough information has been captured in the scanning process, check the pixel values of 
your highlight and shadow areas in the Info palette. In general, RGB highlight values of about 240 and shadow values
of about 10 indicate that the scan contains enough detail to produce high-quality output. 

To check the histogram for an image: 

Open the image you want to examine, and choose Image > Adjust > Levels.

The x axis of the histogram represents the color values from darkest (0) at the far left to brightest (255)
at the far right; the y axis represents the total number of pixels with that value. 



Making Color and Tonal Adjustments 

Step 2: Set the highlight and shadow values

The first task in professional tonal correction is to assign values to the extreme highlight and shadow 
pixels in the image, so that the overall tonal range provides the sharpest detail possible throughout the
image. This process is known as setting the highlights and shadows or setting the white and black 
points. You can set highlights and shadows in Adobe Photoshop using several different methods. 

See also: 

Setting the highlights and shadows using target values 

Setting the highlights and shadows using the Levels sliders 

Setting the highlights and shadows automatically 



Step 2: Set the highlight and shadow values 

Setting the highlights and shadows using target values

Professional color technicians typically set the highlights and shadows in the image by assigning the 
lightest and darkest printing ink values to the lightest and darkest areas of detail in the image. When 
identifying these areas of the image, it’s important to identify a truly representative highlight and 
shadow area so that the tonal range is not expanded unnecessarily to include extreme pixel values 
that don’t give the image detail. 

See also: 

To set the highlight and shadow using target values 

To use Threshold mode to identify the lightest and darkest areas in the image 



Setting the highlights and shadows using target values 

To set the highlight and shadow using target values:

1    Double-click the eyedropper tool, and set the Sample Size option in the Eyedropper Options 
palette to 3 by 3 Average. This option tells Adobe Photoshop to display the average value of each 3-
by-3-screen-pixel area and ensures that you get a truly representative sample of an area in the image 
rather than a single screen-pixel value. 

2    Do one of the following:
•      Open the Info palette, and move the pointer around the image to help identify the lightest neutral 
areas in the image (See Previewing color values).
•      Use Threshold mode in the Levels dialog box to identify the highlight area in the image.

Note that your goal in this step is to identify a representative highlight area in the image—a printable 
highlight—and not an area that is simply pure white with no detail, such as a spot of glare in the 
image. White with no detail, also called specular white, is reproduced by printing no ink on paper.

3    Choose Image > Adjust > Levels or Curves to open the Levels or Curves dialog box, and double-
click the white eyedropper tool to display the color picker. In the color picker, enter the value that you 
want to assign to the highlight you identified in step 2. 

In most situations when you are printing on white paper, you can achieve a good highlight in an 
average-key image using RGB values of 244, 244, and 244, respectively. (The grayscale equivalent is 
a 4% dot.) 

You can reproduce these target values quickly by entering a value of 96% in the Brightness text box.

4    Click OK in the Color Picker dialog box when you’ve entered the values; then click the highlight 
area that you identified in step 2. If you accidentally click the wrong highlight, hold down Option 
(Macintosh) or Alt (Windows) and click Reset in the dialog box.

The pixel values throughout the image are adjusted proportionately to the new highlight values. Any 
pixels lighter than the area you clicked, such as any pixels in a spot of glare, become specular white. 
The Info palette shows the values both before and after the color adjustment.

5    Now use the Info palette to help identify a representative shadow area in the image. (Don’t click the
area yet.) 

6    Double-click the black eyedropper tool in the Levels or Curves dialog box, and enter a target 
shadow value. In a typical situation where you are printing on white paper, you can achieve a good 
shadow in an average-key image using RGB values of 10, 10, and 10, respectively. (The grayscale 
equivalent is a 96% dot.) 

You can reproduce these same values quickly by entering a value of 4 in the Brightness text box. 

7    Click OK when you’ve entered the values; then click the shadow area that you identified in step 5. 

See also: 

To use Threshold mode to identify the lightest and darkest areas in the image 



Setting the highlights and shadows using target values 

To use Threshold mode to identify the lightest and darkest areas in the image:

1    Choose Image > Adjust > Levels to display the Levels dialog box. Make sure that the Preview 
option is deselected.

Note: On most systems running Windows, Threshold mode works only if the monitor is set to 256 
colors. The Video LUT Animation option in the Display & Cursors preferences dialog box must be on 
for Threshold mode to work. See Previewing color adjustments for more information.

2    Hold down Option (Macintosh) or Alt (Windows) and drag the white or black Input Levels triangle.

The image changes to Threshold mode, and a high-contrast preview image appears. The visible areas
of the image indicate the lightest parts of the image if you are dragging the white slider and the darkest
parts of the image if you are dragging the black slider. If you have a channel of a color image selected 
in the Levels dialog box, the black area indicates where none of the given color component exists.

3    Slowly drag the slider to the center of the histogram to identify the light or dark areas in the image.

See also: 

To set the highlight and shadow using target values 



Step 2: Set the highlight and shadow values 

Setting the highlights and shadows using the Levels sliders

An alternative way to set the highlights and shadows in an image that shows a lack of pixels on either 
end of the histogram is simply to move the Levels input sliders to the first group of pixels on both ends 
of the histogram. Doing so maps these pixels—the darkest and lightest pixels in each channel—to 
black and white. The corresponding pixels in the other channels are adjusted proportionately so as not
to affect the color balance.

Using the Levels sliders to set highlights and shadows is less exact than assigning target values, but it
often gives good results. In addition, because it doesn’t affect the color balance of the image, this 
method is preferable if you want to maintain a color cast in the highlights and shadows. 

To set the highlights and shadows using the Levels sliders:

1    Choose Image > Adjust > Levels to reopen the Levels dialog box if necessary, and drag the input 
Levels sliders to the edge of the first group of pixels on either end of the histogram. Then click OK. 

2    To view the new histogram, reopen the Levels dialog box. Notice that the histogram has been 
stretched out to accommodate the new white and black points, causing gaps in the histogram. 

These gaps do not indicate a perceptible problem in the image unless they are large or accompanied 
by a low pixel count.

Notice that although both adjustments improved the contrast in the image, setting the highlights and 
shadows to neutral color values also eliminated the color cast, whereas adjusting the Levels sliders 
did not affect the color balance. 

In this example, eliminating the color cast by assigning target values was useful. However, in another 
image—for example, one without neutral highlights— using the Levels sliders to set the highlights and 
shadows might produce better results precisely because it does not affect the color balance.



Step 2: Set the highlight and shadow values 

Setting the highlights and shadows automatically

The Auto Levels command and Auto button in the Levels and Curves dialog boxes automatically 
adjust the levels or curves, respectively. These Auto commands perform the equivalent of the Levels 
slider adjustment automatically; that is, these features automatically define the lightest and darkest 
pixels in the image as white and black and then redistribute the intermediate pixel values 
proportionately. 

In general, the Auto feature gives good results when a simple contrast adjustment is needed to an 
image with an average distribution of pixel values; however, this feature does not provide the more 
precise control that can be achieved by adjusting the Levels or Curves controls manually.

To set the black and white points automatically:

Choose an Auto option:
•      Choose Image > Auto Levels.
•      Choose Image > Adjust > Levels or Curves. In the Levels or Curves dialog box, click Auto. 

By default, the Auto feature clips the white and black pixels by 0.5%—that is, when identifying the 
lightest and darkest pixels in the image, it ignores the first 0.5% of either extreme. This clipping of 
color values ensures that the program bases its white and black values on truly representative light 
and dark pixels rather than on a single extreme pixel value in the image.

To change the amount of white and black values clipped:

1    Hold down Option (Macintosh) or Alt (Windows), and click the Options button in the Levels or 
Curves dialog box. 

2    In the Auto Range Options dialog box, enter the percentage of extreme highlight pixels and 
extreme shadow pixels you want the Auto feature to ignore; then click OK. A value between 0.5% and 
1% is recommended.



Making Color and Tonal Adjustments 

Step 3: Adjust the midtones and fine-tune the tonal correction

Once you have set the highlights and shadows, you may want to adjust the midtones or otherwise 
fine-tune the contrast. Most often, this step is not necessary with average-key images; setting the 
highlights and shadows typically redistributes the midtone pixel values appropriately. When pixel 
values are concentrated on either end of the grayscale, however, further adjustments to the midtones 
are often needed to redistribute where the midtones fall.

In addition, you can use the gray eyedropper button in the Levels or Curves dialog box to set the 
intermediate points along the grayscale and eliminate color casts in the midtones. (See Setting the 
highlights and shadows using the Levels sliders for a description of how the eyedropper buttons work.)
For precise control over midtone adjustments, however, it is recommended that you adjust the Levels 
midtone slider or the midtone values in the Curves dialog box.

The Levels sliders let you make gradual adjustments to the brightness, contrast, and midtones in an 
image. Adjusting the midtones lets you change the brightness values of the middle range of gray tones
without dramatically altering the shadows and highlights. 

To use the Levels sliders:

1    Choose Image > Adjust > Levels.

The Levels dialog box displays a histogram of the image.

2    Adjust the contrast:
•      Use the Input Levels slider controls directly below the histogram to increase the contrast in the 
image. The black triangle controls the shadows, the gray triangle controls the midtones, and the white 
triangle controls the highlights. You can also enter values directly into the Input Levels text boxes.
•      Use the Output Levels slider controls at the bottom of the Levels dialog box to reduce the contrast 
in the image. The black triangle controls the shadows, and the white triangle controls the highlights. 
You can also enter the values directly into the Output Levels text boxes. 

For example, suppose your image contains pixels that cover the entire 0-to-255 scale and you want to 
increase the contrast in the image. If you drag the Input Levels white triangle to 233, pixels with 
brightness values of 233 and higher are mapped to 255, and pixels with lower brightness values are 
mapped to corresponding lighter values. This lightens the image and increases the contrast in the 
highlight areas. 

On the other hand, suppose you want to decrease the contrast of the image. If you drag the Output 
Levels white triangle to 220, pixels with brightness values of 255 are remapped to 220, and pixels with
lower brightness values are mapped to corresponding darker values. This darkens the image and 
decreases the contrast in the highlight areas.

See also: 

Using Curves 



Step 3: Adjust the midtones and fine-tune the tonal correction 

Using Curves 

Like Levels, Curves lets you adjust the tonal range of an image. However, instead of making the 
adjustments using just three variables (highlights, shadows, and midtones), you can adjust any point 
along the 0–255 scale while keeping up to 15 other values constant.

You can also use the Arbitrary Map option in the Curves dialog box to draw a tonal curve by dragging. 
This feature lets you create a variety of interesting tonal and color effects.

See also: 

To use the Curves dialog box 

To use the Arbitrary Map option in the Curves dialog box 



Using Curves 

To use the Curves dialog box:

1    Choose Image > Adjust > Curves. 

The horizontal axis of the graph represents the original brightness values of the pixels (input levels); 
the vertical axis represents the new brightness values (output levels). The diagonal line that appears 
by default shows the current relationship between the input and output values: no pixels have been 
mapped to new values, so all pixels have the identical input and output values.

Note: By default, Curves displays brightness values from 0–255 with shadows (0) on the left in RGB 
mode. To reverse the curve and change the display at any time, click the double arrow below the 
curve.

2    Move the pointer to the area you want to correct, and hold down the mouse button.

A circle appears to mark the pixel’s position on the graph, and the output and input values are 
displayed at the bottom of the dialog box. This step identifies the portion of the curve you want to 
adjust. 

3    Click any points on the curve that you want to remain fixed. For example, if you want to adjust the 
midtones while minimizing the effect on the highlights and shadows, click the quarter and three-
quarter points on the curve. 

You can add up to 15 points to the curve to lock those values as you make adjustments. To keep 
values constant, add points to the grid where the input and output points are equal. To remove a fixed 
point from the curve, drag it off the graph. 

Avoid sharp curves (which posterizes color) or clustering points in front of locked points (which can 
cause colors to blend together or shift unevenly).

4    Drag the curve until the image looks as you want it. 

Changes to the curve becomes the new default, until you reset the curve. 
    To make the Curves grid finer, hold down Option (Macintosh) or Alt (Windows), and click the grid. Option/Alt-click

again to make the grid larger.

See also: 

To use the Arbitrary Map option in the Curves dialog box 



Using Curves 

To use the Arbitrary Map option in the Curves dialog box:

1    Click the pencil at the bottom of the Curves dialog box. 

2    Drag to draw the curve you want in the Curves graph area.

The pencil pointer appears automatically when you move into the graph. To constrain the curve to a 
straight line, hold down Shift and click to define the endpoints of the curve. You can create a negative 
of an image, for example, by holding down Shift and clicking the upper left corner of the graph and 
then the lower right corner.

3    If desired, click Smooth to smooth the curve you’ve drawn.

See also: 

To use the Curves dialog box 



Making Color and Tonal Adjustments 

Step 4: Adjust the color balance

With the tonal correction complete, you can accurately examine and diagnose any problems with color
in the image, such as a color cast or oversaturated or undersaturated colors. 

See also: 

About adjusting color balance 

Using the Color Balance command 

Using the Hue/Saturation command 



Step 4: Adjust the color balance 

About adjusting color balance

When adjusting the individual color components in an image, it’s important to understand that every 
color adjustment affects the overall color balance in the image, and that there are numerous ways to 
achieve similar effects. If you’re not yet used to adjusting individual color components in an image, it 
helps to keep a diagram of a color wheel on hand as you work. 

You can use the color wheel to help predict how changing one color component will affect the other 
colors in the image. For example, you can decrease the amount of any color in an image by increasing
the amount of the opposite color on the color wheel—and vice versa. Similarly, you can increase and 
decrease a color by adjusting the two adjacent colors on the color wheel, or even by adjusting the two 
colors adjacent to the opposite color on the color wheel. 

For example, you can decrease the magenta in an image by removing red and blue or by adding 
green. All of these adjustments result in an overall color balance that contains less magenta. How you 
choose which adjustment is appropriate for your image depends on the image and on the particular 
effect you want.



Step 4: Adjust the color balance 

Using the Color Balance command

The Color Balance command lets you change the mixture of colors in a color image. Like the 
Brightness/Contrast command, this tool provides generalized color correction. For precise control over
individual color components, use Levels, Curves, or the Hue/Saturation command.

To adjust the levels of a particular color in an image: 

1    Choose Image > Adjust > Color Balance. 

2    Do one of the following:
•      Click Shadows, Midtones, or Highlights to select the tonal range on which you want to focus the 
changes. 
•      With RGB images, click Preserve Luminosity to prevent changing the brightness values in the 
image as well as changing the color. This option maintains the tonal balance in the image.

3    Drag a triangle toward a color if you want to increase that color in the image; drag the triangle away
from the color if you want to decrease the color.

The values at the top of the Color Balance dialog box show the color changes for the red, green, and 
blue channels. Values can range from –100 to +100.



Step 4: Adjust the color balance 

Using the Hue/Saturation command

The Hue/Saturation command lets you adjust the hue, saturation, and lightness of individual color 
components in an image. Like the Color Balance command, the Hue/Saturation command is based on
the color wheel. Adjusting the hue, or color, represents a move around the color wheel; adjusting the 
saturation, or purity of the color, represents a move across the diameter of the color wheel. You can 
also use the Colorize option to add color to a grayscale image you have converted to RGB or to create
a monotone effect.

See also: 

To adjust an image using Hue/Saturation 

To colorize a grayscale image or create a monotone effect 



Using the Hue/Saturation command 

To adjust an image using Hue/Saturation: 

1    Choose Image > Adjust > Hue/Saturation to display the Hue/Saturation dialog box. 

Along the left side of the dialog box are six color swatches of the additive and subtractive colors in the 
order in which they appear on the color wheel: red, yellow, green, cyan, blue, and magenta. 

In addition, the Sample swatch at the bottom of the dialog box lets you monitor the adjustment’s effect 
on a selected color (by default, the foreground color). Click a color in the image to change the swatch 
color. 

2    Select the button next to the color component you want to adjust, or select Master to adjust all 
colors at once. 

3    Drag the Hue slider until the colors appear the way you want them. You can also type a value into 
the Hue text box.

The values displayed in the text box reflect the number of degrees of rotation around the wheel from 
the pixel’s original color. A positive value indicates a clockwise rotation; a negative value indicates a 
counterclockwise rotation. 

4    Drag the Saturation triangle to the right to increase the saturation; drag to the left to decrease the 
saturation. This shifts the color away from or toward the center of the color wheel, relative to the 
beginning color values of the selected pixels. 

5    Drag the Lightness slider to the right to increase the lightness; drag to the left to decrease the 
lightness. Values can range from –100 to +100.

See also: 

To colorize a grayscale image or create a monotone effect 



Using the Hue/Saturation command 

To colorize a grayscale image or create a monotone effect: 

1    If you are colorizing a grayscale image, choose Image > Mode > RGB to convert the image to 
RGB.

2    Open the Hue/Saturation dialog box, as described under Using color adjustment commands.

3    Click Colorize. The image is converted to shades of red, the 0° point on the color wheel, at 100% 
saturation. Note that the lightness value of each pixel does not change.

4    Use the Hue slider to select the new color. 

5    Use the Saturation and Lightness sliders to adjust the saturation and lightness of the pixels; then 
click OK. 

See also: 

To adjust an image using Hue/Saturation 



Making Color and Tonal Adjustments 

Step 5: Sharpen the image

Unsharp masking, or USM, is a traditional film compositing technique used to sharpen edges in an 
image. The Unsharp Mask filter corrects blurring in the original photograph or scan, and it 
compensates for blurring that occurs during the resampling and printing process. Applying the 
Unsharp Mask filter is recommended whether your final destination is print or online.

The Unsharp Mask filter locates every two adjacent pixels with a difference in brightness values that 
you specify, and then increases the pixels’ contrast by an amount that you specify. In addition, you 
specify the number of surrounding pixels to which the sharpening effect is applied.

When sharpening an image, it’s important to understand that the effects of the Unsharp Mask filter are
far more pronounced on-screen than in high-resolution output. 

To sharpen an image using the Unsharp Mask filter: 

1    Choose Filter > Sharpen > Unsharp Mask. 

2    In the Unsharp Mask dialog box, select the following options:
•      Choose an Amount to determine how much the contrast of pixels is increased. For high-resolution 
printed images, an amount between 150% and 200% is recommended. 
•      Choose a Radius to determine the number of pixels surrounding the edge pixels that are affected 
by the sharpening. For high-resolution images, a Radius between 1 and 2 is recommended.
•      Choose a Threshold to determine how different the brightness values between two pixels must be 
before they are considered edge pixels and are sharpened by the filter. For images with fleshtones 
and other areas in which you want to avoid introducing noise, experiment with Threshold values 
between 2 and 20. The default Threshold value (0) sharpens all pixels in the image.



Making Color and Tonal Adjustments 

.Using the Variations command for generalized tonal and color adjustments

The Variations command lets you visually adjust the color balance, contrast, and saturation of an 
image or selection. This command is most useful when you’re working in an average-key image that 
doesn’t require precise color adjustments. 

To use the Variations command:

1    Choose Image > Adjust > Variations to display the Variations dialog box.

Note: If the Variations command does not appear in the Adjust submenu, the Variations plug-in 
module may not have been installed. See Using plug-in modules for more information.

The two thumbnails at the top of the dialog box show the original selection (Original) and the selection 
with its currently selected adjustments (Current Pick). When you first open the dialog box, these two 
images are the same. As you make adjustments, the Current Pick image changes to reflect your 
choices. 

2    Choose the following options:
•      Deselect Show Clipping if you do not want to see a neon preview of the areas in the image that 
will be clipped—that is, converted to pure white or pure black when the adjustment is applied. Clipping
does not occur when you adjust midtones. 
•      Select Shadows, Midtones, or Highlights to indicate whether you want to adjust the dark, middle, 
or light areas of the selection, respectively.
•      Select Saturation to change the degree of hue in the image. Note that if the Show Clipping option 
is selected, and the image shows clipping after the adjustment, you have exceeded the maximum 
saturation for the color.
•      Use the Fine/Coarse slider to determine the amount of each adjustment. Moving the slider one tick
mark to the right or left doubles the adjustment amount. 

3    Adjust the color and brightness as follows:
•      To add a color to the image, click the appropriate color thumbnail. 
•      To subtract a color, click its opposite, located in the opposite position on the color wheel; for 
example, to subtract cyan, click the red thumbnail.

4    Click the thumbnails on the right of the dialog box to adjust the brightness in the image. 

Note that each time you click a thumbnail, all thumbnails change. The center thumbnail always reflects
the current choices. 



Making Color and Tonal Adjustments 

Using the Brightness/Contrast command

Using the Brightness/Contrast command is the easiest way to make simple adjustments to the tonal 
range of the image. Unlike Curves and Levels, this command adjusts all pixel values in the image—
highlights, shadows, and midtones—at once and so is not recommended for high-end output or for 
subtle color adjustments. 

To use the Brightness/Contrast dialog box: 

1    Choose Image > Adjust > Brightness/Contrast to display the Brightness/Contrast dialog box. 

2    Drag the sliders to adjust the brightness and contrast.

Dragging to the left decreases the level; dragging to the right increases it. The number at the right of 
each slider value displays the brightness or contrast value. Values can range from –100 to +100. 

3    When you’ve finished making adjustments, click OK.



Making Color and Tonal Adjustments 

Special-purpose color adjustment tools

The Invert, Equalize, Threshold, and Posterize commands also change the colors or brightness values
in an image. In most cases, these commands provide dramatic overall effects that are applied to the 
selected layer. These commands are typically used for color enhancement and for producing special 
effects rather than for color correction. 

See also: 

Using the Invert command 

Using the Equalize command 

Using the Threshold command 

Using the Posterize command 



Special-purpose color adjustment tools 

Using the Invert command 

The Invert command creates a negative of an image. You might use this command to make a positive 
image negative or to make a positive from a scanned negative.

When you invert an image, the brightness value of each pixel in the image is converted to the inverse 
value on the 256-step color-values scale. For example, a pixel in a positive image with a value of 255 
is changed to 0, and a pixel with a value of 5 is changed to 250.

To invert an image:

Choose Image > Adjust > Invert.



Special-purpose color adjustment tools 

Using the Equalize command

The Equalize command redistributes the brightness values of the pixels in an image so that they more 
evenly represent the entire range of brightness levels. When you choose this command, Adobe 
Photoshop finds the brightest and darkest values in the image and averages all the brightness values 
so that the darkest value represents black (or as close to it as possible) and the brightest value 
represents white. Photoshop then attempts to equalize the brightness— that is, to distribute the 
intermediate pixel values evenly throughout the grayscale. 

You might use this command when a scanned image appears darker than the original and you want to
balance the values to produce a lighter image. 

To equalize the brightness values of pixels: 

1    Choose Image > Adjust > Equalize. 

If you have an area of the image selected, the Equalize dialog box appears. 
•      Select Selected Area Only to equalize only the pixels in the selection.
•      Select Entire Image Based on Area to equalize the pixels in the entire image based on the pixels 
in the selected area. 

2    Click OK to equalize the image or the selection.



Special-purpose color adjustment tools 

Using the Threshold command

Use the Threshold command to convert grayscale or color images to high-contrast black-and-white 
images. This command lets you specify a certain level as a threshold. All pixels lighter than the 
threshold are converted to white. All pixels darker than the threshold are converted to black.

To use the Threshold command: 

1    Choose Image > Adjust > Threshold. 

The Threshold dialog box displays a histogram of the luminance levels of the pixels in the current 
selection.

2    Drag the slider below the histogram until the threshold level you want appears at the top of the 
dialog box. As you drag, the image changes to reflect the new threshold setting.

Note: On the Macintosh, the Video LUT Animation option in the Display & Cursors preferences must 
be on to preview the Threshold adjustment. See Previewing color adjustments for more information.



Special-purpose color adjustment tools 

Using the Posterize command

The Posterize command lets you specify the number of tonal levels (or brightness values) for an 
image and then maps pixels to the level that is the closest match. This command is useful for creating 
special effects, such as large, flat areas in a photograph. The effects of this command are most 
evident when you reduce the number of gray levels in a grayscale image; however, you can also use 
this command to produce some interesting effects in color images. Posterize can also be useful for 
reducing the number of colors in an image you want to distribute over the Web.

To specify the number of levels in an image: 

1    Choose Image > Adjust > Posterize. 

2    Enter the number of levels you want; then click OK.

3    When you’ve finished making adjustments, click OK.



Selecting

To modify part of an image in Adobe Photoshop Limited Edition, you must first select the area you 
want to edit. A selected area is indicated by its surrounding selection border, also called a selection 
marquee. Once you have made a selection, you can move, copy, paint, or apply numerous special 
effects to the selected area. See Editing for information on editing selections.

See also: 

Making selections 

Using the magic wand tool 

Adjusting selections 

Softening the edges of a selection 

Hiding a selection border 

Using Quick Mask mode 



Selecting 

Making selections

You make selections by clicking and dragging with the marquee, lasso, polygon lasso, or magnetic 
lasso tool, or by targeting color areas with the magic wand tool. The choices associated with a 
selection tool appear in its Options palette. Making a new selection replaces the existing one.

Note: When making a selection in a file that contains layers, make sure that the layer you want is the 
active layer.

To select all pixels on a layer within the canvas boundaries:

1    Select the layer in the Layers palette, as explained in Using the Layers palette.

2    Choose Select > All. 

This command selects all the pixels that fall inside the boundaries of the canvas. 

To deselect selections:

Do one of the following:
•      If you are using the rectangular marquee, elliptical marquee, or lasso tool, click anywhere in the 
image outside the selected area.
•      Choose Select > None. 

See also: 

Using the marquee tool 

Using the lasso tool 

Using the polygon lasso tool 

Using the magnetic lasso tool 



Making selections 

Using the marquee tool

The marquee tool ( /
/
/
) lets you select rectangular or elliptical areas by dragging over an area of the image. By default, the 

marquee is dragged from its corner.

To use the marquee tool:

1    Drag to select one of the following marquee tools from the toolbox:
•      Rectangle marquee to make a rectangular selection. 
•      Ellipse marquee to make an elliptical selection.
•      Single row or single column marquee to define the selection marquee as a 1-pixel-wide row or 
column. 

    To switch between the rectangle and ellipse marquees quickly, Option-click (Macintosh) or Alt-click (Windows) 
the marquee tool, or press Shift+M.

2    If you’ve selected the rectangle or ellipse marquee, choose one of the following options for Style in 
the Marquee Options palette:
•      Normal to determine the proportions of the marquee by dragging. 
•      Constrained Aspect Ratio to set a height-to-width ratio for the marquee. Enter the values (including
decimal values) for the aspect ratio. For example, to draw a marquee that is twice as wide as it is high,
you would enter 2 for the width and 1 for the height in the marquee. 
•      Fixed Size to specify set values for the marquee’s height and width. Enter the pixel values for the 
fixed-size marquee in whole numbers. Keep in mind that the number of pixels needed to create a 1-
inch selection depends on the resolution of the image. For a file that has 72 pixels per inch, for 
example, you need 72 pixels to make 1 inch. See About resolution and image size for information on 
image resolution.

3    To define a feather edge as you make a selection, enter a pixel value for Feather. See Softening 
the edges of a selection for more information.

4    To make a selection, do one of the following:
•      If you’re using the rectangle or ellipse marquee, drag over the area you want to select. Hold down 
Shift as you drag to constrain the marquee to a square or circle. To drag a selection marquee from its 
center, begin dragging; then hold down Option (Macintosh) or Alt (Windows), and continue to drag.
•      If you’re using the Single Row or Single Column marquee, click near the area you want to select; 
then drag the marquee to the exact location. If no marquee is visible, increase the magnification of 
your image view.

    To adjust the position of a rectangular or elliptical marquee, first drag to create the marquee, keeping the mouse 
button depressed; then hold down the spacebar and continue to drag.



Making selections 

Using the lasso tool

The lasso tool ( ) lets you make a selection by dragging a freehand outline around an area. You can 
also constrain all or part of the outline to straight-edged segments.

To use the lasso tool:

1    Double-click the lasso tool to open its Options palette.

2    To define a feathered edge as you make a selection, enter a pixel value for Feather.

3    To turn off anti-aliasing, deselect Anti-aliased.

See Softening the edges of a selection for more information on feathering.

4    To draw a freehand selection border, drag around the area in the image. 

5    To draw a straight-edged selection border, start dragging; then hold down Option (Macintosh) or Alt
(Windows), and click where you want the segments to begin and end.

You can switch between drawing a freehand and straight-edged selection border while making a 
selection. When you release the mouse without holding down Option/Alt, Photoshop closes the 
selection border.



Making selections 

Using the polygon lasso tool

The polygon lasso tool lets you make a selection outline by clicking to set straight-edged segments 
and Option-dragging (Macintosh) or Alt-dragging (Windows) to draw freehand segments. 

To use the polygon lasso tool:

1    Drag to select the polygon lasso tool in the toolbox.

2    To define a feathered edge as you make a selection, enter a pixel value for Feather in the Options 
palette.

3    To turn off anti-aliasing, deselect Anti-aliased. 

See Softening the edges of a selection for more information on feathering.

4    Click in the image to set the starting point for the selection.

5    Position the pointer where you want the first straight segment to end, and click. Continue clicking to
set endpoints for subsequent straight segments.

6    To draw a freehand segment, hold down Option (Macintosh) or Alt (Windows) and drag. When you 
are finished with the freehand segment, release Option/Alt and the mouse button.

7    Continue to click and Option/Alt-drag to finish making the selection. Double-click to close the 
selection border.



Making selections 

Using the magnetic lasso tool

Like the lasso and polygon lasso tools, the magnetic lasso tool lets you draw both straight-edged and 
freehand segments of a selection border. With the magnetic lasso tool, the border snaps to the edges 
of defined areas in the image. The magnetic lasso tool is especially useful for quickly selecting objects
with complex edges set against high-contrast backgrounds.

To use the magnetic lasso tool:

1    Position the pointer next to the lasso tool in the toolbox, and drag to the right to select the magnetic
lasso tool ( ). 

    To switch lasso tools quickly, press Shift+L.

2    To select options for the tool, double-click the magnetic lasso tool to display its Options palette, and
set any of these options:
•      To define a feathered edge as you make a selection, enter a pixel value for Feather.
•      To turn off anti-aliasing, deselect Anti-aliased. See Softening the edges of a selection for more 
information on feathering.

3    Click in the image to set the first fastening point. Fastening points anchor the selection border in 
place.

4    To draw a freehand segment, move the pointer along the edge you want to trace. (You can also 
drag with the mouse button depressed.) 

The most recent segment of the selection border remains active. As you move the pointer, the active 
segment snaps to the strongest edge in the image. Periodically, the magnetic lasso tool adds 
fastening points to the selection border to anchor previous segments.

5    If the border doesn’t snap to the desired edge, click once to add a fastening point manually. 
Continue to trace the edge and add fastening points as needed.

6    To switch temporarily to the other lasso tools, do one of the following:
•      To activate the lasso tool, hold down Option (Macintosh) or Alt (Windows) and drag with the mouse
button depressed.
•      To activate the polygon lasso tool, hold down Option/Alt and click.

7    To erase recently drawn segments and fastening points, press Delete. 

8    Close the selection border:
•      To close the border with a freehand magnetic segment, double-click, or press Return (Macintosh) 
or Enter (Windows).
•      To close the border with a a straight segment, hold down Option (Macintosh) or Alt (Windows), and
double-click.



Selecting 

Using the magic wand tool

The magic wand tool ( ) lets you select portions of an image based on the color similarities of 
adjacent pixels. This tool can be useful for selecting a consistently colored area (for example, a red 
flower) without having to trace the outline with the lasso tool. When you use the magic wand tool, 
Adobe Photoshop determines whether the adjacent pixels are within the color range, or tolerance, that
you specify. 

Note: You cannot use the magic wand tool on an image in Bitmap mode.

To use the magic wand tool:

1    Double-click the magic wand tool to display its Options palette.

2    For Tolerance, enter a value in pixels.

The tolerance can range from 0 to 255. Enter a low tolerance value to select colors very similar in 
color value to the pixel you click. Enter a higher tolerance to select a broader range of colors. 

3    To turn off anti-aliasing, deselect Anti-aliased.

4    In the image, click the color you want to select. 

All adjacent pixels within the tolerance range are selected.

See also: 

Selecting non-transparent pixels on a layer 



Using the magic wand tool 

Selecting non-transparent pixels on a layer

You can quickly load a selection (called a transparency mask) of all non-transparent areas on a layer, 
that is, all pixels that have color values. This is useful for making selections on a layer that contains 
both transparent and non-transparent areas.

To select all non-transparent pixels on a layer:

Do one of the following:
•      In the Layers palette, Command-click (Macintosh) or Ctrl-click (Windows) the layer containing the 
pixels you want to load as a selection. See Using the Layers palette for more information.
•      To add the pixels to an existing selection, press Command+Shift/Ctrl+Shift and click the layer in 
the Layers palette.
•      To subtract the pixels from an existing selection, press Command+Option/Ctrl+Alt and click the 
layer in the Layers palette.
•      To load the intersection of the pixels and an existing selection, press Command+Option+ 
Shift/Ctrl+Alt+Shift and click the layer in the Layers palette.
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Adjusting selections

Adobe Photoshop provides a variety of ways for you to adjust and refine your selections. You can 
refine a selection based on color similarity, or you can adjust the selection borders and add or subtract
selections. You can also invert selections to select all the areas that were previously unselected. 
Before adding to or subtracting from a selection, make sure you have the same feather and anti-
aliased settings in the Options palette that you used when you made the original selection so that the 
new selection border appears uniform.

See also: 

Moving a selection border 

Adding to a selection 

Subtracting from a selection 

Selecting parts of selections 

Using the Grow and Similar commands 

Smoothing a selection 

Expanding and contracting a selection border 

Selecting a border around an area 

Inverting a selection 



Adjusting selections 

Moving a selection border

You can easily move a selection border so that it encloses a different area of the image. This feature is
useful for fine-tuning selections that are slightly misplaced.

You can drag a selection border partially beyond the canvas boundaries without clipping the selection 
border. The original border remains intact when you drag it back within the canvas boundaries.

To move just the selection border: 

1    With any selection tool selected, position the pointer inside the selection border (the pointer 
becomes the selection pointer).

2    Drag the selection border to the locationyou want. 
    Use the following methods to control the movement of a selection:

• To constrain the direction of movement to a multiple of 45, begin dragging; then hold down Shift as you continue to 
drag. 
• To move the selection in 1-pixel increments, use the arrow keys on the keyboard.
• To move the selection in 10-pixel increments, hold down Shift and press an arrow key.



Adjusting selections 

Adding to a selection

You can add to an existing selection or select more than one area of an image at a time. The resulting 
selection contains all the pixels in both the original and the new selection.

To add to a selection:

1    Make a selection.

2    With any selection tool selected, hold down Shift and select the area you want to add to the 
selection. 



Adjusting selections 

Subtracting from a selection

You subtract from an existing selection by selecting the area you want to subtract. The resulting 
selection contains all the pixels in the original selection that are not in the new selection.

To subtract from a selection:

1    Make a selection. 

2    With any selection tool selected, hold down Option (Macintosh) or Alt (Windows) and select the 
area you want to subtract from the selection. 



Adjusting selections 

Selecting parts of selections

You can use any selection tool to select a portion of an existing selection. The area that intersects the 
original selection and the new selection becomes the resulting selection.

To select a portion of an existing selection: 

With a selection tool selected, press Option+Shift (Macintosh) or Alt+Shift (Windows) and drag over 
the areas of the original selection you want to keep. 



Adjusting selections 

Using the Grow and Similar commands

The Grow and Similar commands let you expand a selection to include areas similar in color to the 
current selection. These commands use the tolerance specified in the Magic Wand Options palette to 
define the color range of pixels to be included in the expanded selection. 

Note: You cannot use the Grow and Similar commands on images that are in Bitmap mode.

To extend a selection based on color:

Do one of the following:
•      Choose Select > Grow to include adjacent pixels that fall within the specified tolerance range. 
•      Choose Select > Similar to include pixels throughout the image, not just the ones next to the 
selection, that fall within the specified tolerance range. 

You can choose either command more than once to increase the selection in increments.



Adjusting selections 

Smoothing a selection

In some instances, making a color-based selection leaves stray pixels both inside and outside the 
selected area. You can clean up a selection by using the Smooth command to include or eliminate 
stray pixels in the selection. Smoothing is especially effective when you are blending, cloning, or 
making other changes that you want to appear seamless in the final selection.

To smooth a selection:

1    Choose Select > Modify > Smooth. 

2    For Sample Radius, enter a pixel value between 1 and 16 and click OK.

Adobe Photoshop checks the area around each pixel to find any unselected pixels that fall within the 
specified range. For example, if you enter 16 for the sample radius, the program uses each pixel as 
the center of a 33-by-33-pixel area (16 pixels in the horizontal and vertical directions). If most of the 
pixels in the range are selected, any unselected pixels are added to the selection. If most of the pixels 
are unselected, any selected pixels are deleted from the selection.

Note: The relationship between physical distance and pixel distance varies, depending on the 
resolution of the image. For example, 5 pixels is a longer distance in an image with a resolution of 72 
ppi than it is in an image with a resolution of 300 ppi. See About resolution and image size for more 
information.



Adjusting selections 

Expanding and contracting a selection border

Once you have made a selection, you can modify it by expanding or contracting the selection border. 

To expand a selection border:

1    Choose Select > Modify > Expand. 

2    For Expand By, enter a pixel value between 1 and 16 and click OK.

The selection border is increased by the specified number of pixels. 

To contract a selection border:

1    Choose Select > Modify > Contract.

2    For Contract By, enter a pixel value between 1 and 16 and click OK.

The selection border is decreased by the specified number of pixels. If part of the selection border 
runs along an edge of the image, that part is not affected by the Contract command.



Adjusting selections 

Selecting a border around an area

You can define a selection and then select an area of a specified width framing the original selection. 

To select an area around an existing selection border: 

1    Choose Select > Modify > Border. 

2    Enter a value between 1 and 64 pixels for the width of the border, and click OK.



Adjusting selections 

Inverting a selection

Sometimes it is more convenient to select part of an image by first selecting the parts you don’t want 
and then inverting the selection. For example, if you want to select an object that is placed against a 
solid-colored background, you can use the magic wand tool to select the background first and then 
invert to select the foreground object. 

To select the unselected parts of an image:

Choose Select > Inverse. You can choose Inverse again to return to the original selection.



Selecting 

Softening the edges of a selection

In some cases, you might want to smooth the hard edges of a selection you plan to modify. You can 
make the transition between the pixels in the selection and the surrounding pixels more gradual by 
feathering or anti-aliasing.

See also: 

Feathering a selection 

Using the Anti-aliased option 



Softening the edges of a selection 

Feathering a selection

Feathering blurs the edges of the selection by building a transition boundary between the selection 
and the surrounding pixels. The transition gradually blends the edges of the selection. This smoothing 
can cause some loss of detail at the edge of the selection. You can define a feathered edge for 
selections you make with the lasso tool, polygon lasso tool, or marquee tool, or you can add feathering
to the edges of an existing selection. Be sure to feather a selection before you apply any editing 
changes. 

To define a feathered edge for the marquee tool or the lasso tool:

Enter a Feather value in the Marquee Options palette, the Lasso Options palette, or the Polygon 
Lasso Options palette. This value defines the width of the feathered edge and can range from 1 to 250
pixels.

To define a feathered edge for an existing selection:

1    Choose Select > Feather.

2    Enter a value for the Feather Radius and click OK.

Note: When you make a small selection with a large feather radius, it’s possible to create such a faint 
selection that the selection edges are invisible. If a message appears stating “No pixels are more than 
50% selected,” decrease the feather radius for the active selection tool, or increase the size of the 
selection.



Softening the edges of a selection 

Using the Anti-aliased option

Anti-aliasing produces a smooth-edged selection by partially filling edge pixels so that they are 
semitransparent. Because anti-aliasing removes jagged edges, it is especially useful when you’re 
creating composite images by cutting and pasting. No detail is lost, since only the edge pixels change.
You can specify anti-aliasing for the lasso tool, polygon lasso tool, elliptical marquee tool, and magic 
wand tool. You must specify this option before using the selection tool; once the selection is made, you
cannot add anti-aliasing to it.

To use anti-aliasing:

Make sure that Anti-aliased is selected in the Lasso Options palette, the Polygon Lasso Options 
palette, the Marquee Options palette, or the Magic Wand Options palette before using the tool. 

The following illustration shows a selection pasted into another image with and without anti-aliasing.
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Hiding a selection border 

When you want to view a selection without the border—for example, to preview a moved selection—
you can temporarily hide the selection border. Any changes you specify, such as fills or color 
adjustments, are still applied to the current selection, but the border remains hidden. 

The Hide Edges command affects the current selection only. The selection border reappears when 
you make another selection.

To hide or show a selection border:

Choose View > Hide Edges or Show Edges.
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Using Quick Mask mode

Quick Mask mode lets you isolate and refine a selection by covering the unselected areas of your 
image with a temporary mask. Color differentiates the protected (masked) and unprotected (selected) 
areas. 

You can start with a selected area and then use Quick Mask mode to add to or subtract from it to 
make the mask. Or you can create the mask entirely in Quick Mask mode. Once you leave Quick 
Mask mode, the unprotected areas become a selection.

See also: 

To create a quick mask 

To change the Quick Mask options 



Using Quick Mask mode 

To create a quick mask:

1    Using any selection tool, select the part of the image you want to change.

2    Click the Quick Mask mode button ( ) in the toolbox.
A color overlay (similar to a piece of rubylith) covers the masked area outside the selection. By default, 
Quick Mask mode colors the masked area using a red, 50% opaque overlay. 
3    To edit the mask, select a painting tool from the toolbox, and do one of the following:

•      To subtract from the selection and increase the masked area, paint with black in the image.
•      To subtract from the masked area and add to the selection, paint with white in the image.

Note: If you have selected the Selected Areas option in the Quick Mask Options dialog box, the 
painting effects are reversed. 

4    Click the Standard mode button ( ) in the toolbox to turn off the quick mask and return to your 
original image. The unprotected area of the quick mask is now surrounded by a selection border.

5    Apply the desired changes to the image. Changes affect only the selected area. 
6    Choose Select > None to deselect the selection. 

See also: 

To change the Quick Mask options 



Using Quick Mask mode 

To change the Quick Mask options:

1    Double-click the Quick Mask mode button ( ) in the toolbox.
2    Choose one of the following display options:

•      Masked Areas to color only the protected areas. This default option colors the areas outside the 
selection. Painting with black adds to the mask, while painting with white subtracts from the mask.
•      Selected Areas to color only the selected, or unprotected, areas. Painting with white adds to the 
mask, and painting with black subtracts from the mask.

 To toggle between the Masked Areas and Selected Areas options, Option-click (Macintosh) or Alt-click (Windows) 
the Quick Mask mode button.

3    To choose a different color for the mask, click the color swatch and choose a new color, as 
explained in Using the Adobe Photoshop Color Picker. Then click OK.

4    Enter an Opacity value for the mask color. Use this setting to change the transparency of the mask 
color. This setting controls only the mask’s appearance; it does not indicate how much of the 
underlying area is actually protected.

When the Masked Areas option is selected in the Quick Mask Options dialog box, the Quick Mask 
button in the toolbox appears as a white circle on a gray background ( ). When the Selected Areas 
option is selected, the icon appears as a gray circle on a white background (

).

See also: 

To create a quick mask 



Editing

Adobe Photoshop Limited Edition lets you edit and modify selections and layers of images in many 
ways.

Keep in mind that pixels can exist beyond the visible canvas when you drag or paste a selection onto 
a layer, apply a transformation, or create artwork or type. You can move the pixels back onto the 
visible canvas using the move tool or selection arrow; modify or reposition the pixels using the Scale, 
Rotate, or Flip Transform commands; or increase the canvas size to incorporate the pixels without 
discarding them. But as long as the pixels are beyond the visible canvas, you cannot paint or modify 
them (for example, using filters or the Levels command). 

See also: 

Indicating when tasks finish 

Interrupting operations 

Correcting a mistake 

Restoring an image 

Duplicating images 

Moving selections 

Using rulers 

Copying a selection 

Copying between applications 

Pasting a selection 

Deleting a selection 

Rotating and flipping an image 

Applying transformations 

Using the rubber stamp tool 

Using the smudge tool 

Using the focus tools 

Using the toning tools 

Using the type and type mask tools 
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Indicating when tasks finish

The Beep When Done preference setting causes Adobe Photoshop to sound a beep whenever the 
program finishes performing a task requiring a progress bar. After the beep, you can continue working 
with the program.

To set the beep:

1    Choose File > Preferences > General.

2    Select Beep When Done, and click OK.



Editing 

Interrupting operations

When trying to cancel an operation in progress (when Adobe Photoshop displays a progress bar), 
press Command+[.] (Macintosh) or hold down Esc until the operation in progress has stopped 
(Windows).



Editing 

Correcting a mistake

You don’t need to be overly concerned about making mistakes while using the Adobe Photoshop 
program. Most operations can be undone using the Undo command. 

In some cases, the information held in memory by the Undo command or Clipboard can be so large 
that it prevents Photoshop from performing the next operation. The Purge command clears the 
operation stored by the Undo command or the Clipboard to free up memory, preventing you from 
undoing an operation or reapplying the information held on the Clipboard. 

To undo the last performed operation only:

Choose Edit > Undo. 

If an operation can’t be undone, the Undo choice is dimmed and reads “Can’t Undo.”

To free memory used by the Undo command or by the Clipboard:

Choose Edit > Purge, and choose Undo to clear the operation stored by the Undo command or 
Clipboard to free up memory. 

If the Undo buffer or Clipboard is empty, it appears dimmed.

You cannot undo the Purge command.
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Restoring an image

You can undo a series of operations that you have performed by restoring all or part of an image to its 
last saved version.

To reverse all changes made to the image since it was last saved:

Choose File > Revert, and click Revert.

To restore part of an image to its previously saved version:

Use the eraser tool with the Erase to Saved option selected in its Options palette. For more 
information, see Using the eraser tool.
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Duplicating images

You can copy an entire image (including all layers) into the available memory on your system without 
saving the image to disk by using the Duplicate command or by dragging and dropping. Duplicating is 
useful when you want to experiment with different effects on an image without permanently changing 
it. For example, you can duplicate an image, modify it, and then compare the results to the original.

To duplicate an image using the Duplicate command:

1    Open the image you want to duplicate.

2    Choose Image > Duplicate.

3    Enter a name for the duplicate image.

4    Click OK.
    To duplicate an image without naming it, hold down Option (Macintosh) or Alt (Windows) as you choose Image > 

Duplicate.
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Moving selections

You move a selection by dragging it to a new location using the move tool. 

To move a selection:

1    Select the move tool ( )in the toolbox. 
To activate the move tool when any other tool is selected, hold down Command (Macintosh) or Ctrl 
(Windows). 
2    Move the pointer inside the selection border, and drag the selection to the position you want. If you 
have selected multiple areas, all move as you drag.
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Using rulers

Photoshop includes rulers to help you align artwork. When visible, rulers appear along the top and left 
side of the active window. Markers in the ruler display the pointer’s position when you move it. 

Changing the ruler origins (the 0, 0 mark on the top and left ruler) lets you measure from a specific 
point on the image.

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

To change the rulers’ zero origin:

Position the pointer over the intersection of the rulers in the upper left corner of the window and drag 
diagonally down onto the image. To make the ruler origin snap to the ruler ticks, hold down Shift as 
you drag. A set of crosshairs appears, marking the new origin on the rulers.

Note: To reset the ruler origin to its default value, double-click the upper left corner of the rulers.

To change the rulers’ settings:

1    Do one of the following:
•      Double-click a ruler. 
•      Choose File > Preferences > Units & Rulers.

2    For Units, choose a unit of measurement.

3    For Width and Gutter, enter values for the column size. If desired, you can change the units for 
these options.

Some layout programs use the column width setting to specify the display of an image across 
columns. The Image Size and Canvas Size commands also use the column width setting; for more 
information, see Changing the print dimensions and resolution of an image and Increasing the size of 
the work canvas.

4    For Point/Pica Size, choose from the following options:
•      PostScript (72 points per inch) if you are printing to a PostScript device.
•      Traditional to use 72.27 printer’s points per inch.

5    Click OK.
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Copying a selection

You can copy a selection by choosing Edit > Copy. You can also copy a selection as you move it within
an image, or as you drag it from one image to another.    A valid drag-and-drop destination appears 
outlined in boldface when you drag over it. 

See also: 

Copying a selection as you move it 

Copying a selection from one Photoshop image to another 



Copying a selection 

Copying a selection as you move it

You can copy a selection as you use the move tool to drag it, or you can use the arrow keys to create 
multiple duplicates of the selection. 

To copy a selection while dragging: 

1    Select the move tool or hold down Command (Macintosh) or Ctrl (Windows) to activate the move 
tool. 

2    Hold down Option (Macintosh) or Alt (Windows), and drag the selection you want to copy and 
move.

To create multiple copies of a selection: 

1    Select the move tool or hold down Command (Macintosh) or Ctrl (Windows) to activate the move 
tool.

2    Do one of the following:
•      To copy the selection and offset the duplicate by 1 pixel, hold down Option (Macintosh) or Alt 
(Windows), and press an arrow key.
•      To copy the selection and offset the duplicate by 10 pixels, press Option+Shift/Alt+Shift, and press 
an arrow key.

As long as you hold down Option/Alt, each press of an arrow key creates a copy of the selection and 
offsets it by the specified distance from the last duplicate. 
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Copying a selection from one Photoshop image to another

You can use the Edit > Copy and Paste commands to copy selections between Photoshop images. 
However, it is often faster and easier to drag a selection from one Photoshop image and drop it into 
another; it also saves memory by not using the Clipboard. The drag-and-drop method requires that 
both images be open, and creates a new layer when the selection is dropped. 

To copy a selection from one open Adobe Photoshop image to another:

Select the move tool, and drag the selection from the active image window into the destination image 
window. If nothing is selected, the entire active layer is copied. A valid drag-and-drop destinations 
appears outlined in boldface when you drag over it.
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Copying between applications

In some cases, you can copy selections between a Photoshop image and another application by 
dragging and dropping. You can also use the Clipboard to copy a selection in Adobe Photoshop and 
paste it in another application, or vice versa. 

See also: 

Dragging selections between applications 

Copying selections between Adobe Photoshop and another application 



Copying between applications 

Dragging selections between applications

On the Macintosh, you can drag and drop images between Adobe Photoshop and other applications 
that support Macintosh Drag Manager, provided that your system is running System 7.0. or 7.1 or 
higher with the Drag Manager Extension or System 7.5 or higher. Dragging vector artwork from Adobe 
Illustrator or from other applications that use the Illustrator Clipboard rasterizes the artwork.
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Copying selections between Adobe Photoshop and another application

A selection cut or copied using the Edit > Cut or Edit > Copy command remains on the Clipboard until 
you copy or cut another selection. By default, when you quit Adobe Photoshop, or switch to another 
application, the contents of the Clipboard are converted to bitmap format (that is, rasterized). This 
conversion lets you paste the Clipboard’s contents into a file created in another application.

To save time, you can disable this automatic conversion if you don’t plan to paste the Clipboard 
contents into other applications. The automatic conversion does not affect the pasting of selections 
between Photoshop images. 

To change the Export Clipboard preference:

1    Choose File > Preferences > General. 

2    Do one of the following:
•      Select Export Clipboard to save the contents of the Clipboard upon quitting Photoshop 
(Macintosh) or to display a prompt upon quitting Photoshop asking you whether to make the contents 
of the Clipboard available to other applications (Windows). 
•      Deselect Export Clipboard to delete the Clipboard contents upon quitting the program. In 
Windows, the Clipboard contents are also deleted when you switch applications.

3    Click OK.
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Pasting a selection 

Adobe Photoshop offers a range of pasting options that control how the pasted selection appears in 
the image. The Paste command pastes a cut or copied selection into another part of the image or into 
another image as a new layer. You can then control the opacity of the pasted pixels using the Layers 
palette.

See also: 

Pasting using different resolutions 



Pasting a selection 

Pasting using different resolutions

When you’re pasting between images that have different resolutions, the pasted data retains its 
current pixel dimensions when pasted. This can make the pasted contents appear out of proportion to 
the new image. To match the images, use the Image Size command to make the source and 
destination images the same resolution before copying and pasting. 
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Deleting a selection

To delete a selection, choose Edit > Clear or press Delete (Macintosh) or Backspace (Windows). To 
cut a selection to the Clipboard, choose Edit > Cut. Deleting a selection on a background or on a layer
with the Preserve Transparency option selected replaces the original location with the background 
color; deleting a selection on a layer with the Preserve Transparency option deselected replaces the 
original area with the layer transparency.
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Rotating and flipping an image

The Image > Rotate Canvas commands let you rotate or flip the entire contents of an image.

To rotate or flip an image:

Choose Image > Rotate Canvas and, from the submenu, choose one of the following commands:
•      180° to rotate by a half-turn.
•      90° CW to rotate clockwise by a quarter-turn.
•      90° CCW to rotate counterclockwise by a quarter-turn.
•      Arbitrary to enter an amount of rotation between 0 and 359.99°; then select CW to rotate clockwise
or CCW to rotate counterclockwise, and click OK. 

Note: Entering a negative number between –359.99° and 359.99° rotates the image in the opposite 
direction specified.
•      Flip Horizontal to flip horizontally, along the vertical axis.
•      Flip Vertical to flip vertically, along the horizontal axis.
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Applying transformations

Using the Edit > Transform commands, you can transform a selection or layer by rotating, scaling, or 
flipping it. When you transform a linked layer, the transformation affects all the layers in the linking 
group.

Note: You cannot apply transformations to the background as a layer. You can, however, transform 
selections on the background.

See also: 

Using interpolation 

Applying a specific transformation 



Applying transformations 

Using interpolation

To calculate the color values of pixels that are added or deleted during transformation, Adobe 
Photoshop uses the interpolation method selected in the General Preferences dialog box.

This option directly affects the speed and quality of the transformation. The default Bicubic 
interpolation is the slowest method, but yields the best results. For more information on different 
interpolation options, see Choosing an interpolation method.



Applying transformations 

Applying a specific transformation

The commands under the Transform submenu let you apply specific transformations to a selection or 
layer. When you use the Scale or Rotate command, Photoshop previews the effect and surrounds the 
selected area with a bounding border. You drag the handles at the corners and sides of the bounding 
border to manipulate the selection or layer according to the specified transformation. 

You can manipulate a selection or layer using several transformation commands in succession before 
applying the cumulative transformation. For example, you can choose Edit > Transform > Scale, and 
drag a handle to scale; you can then choose Edit > Transform > Rotate, drag to rotate, and press 
Return (Macintosh) or Enter (Windows) to apply both transformations. 

See also: 

To scale or rotate 

To flip or rotate a selection or layer 



Applying a specific transformation 

To scale or rotate:

1    Do one of the following:
•      To transform part of a layer, select that area of the layer.
•      To transform an entire layer, make the layer active and make sure that nothing is selected. 

2    Choose Edit > Transform > Scale or Rotate.

3    Drag the handles to achieve the desired effect.

4    To apply additional transformations, repeat steps 2 and 3.

5    Press Return (Macintosh) or Enter (Windows) to apply the cumulative transformation. Press Esc to 
cancel the transformation.

See also: 

To flip or rotate a selection or layer 



Applying a specific transformation 

To flip or rotate a selection or layer:

1    Do one of the following:
•      To transform part of a layer, select that area of the layer.
•      To transform an entire layer, make the layer active (seeUsing the Layers palette), and make sure 
that nothing is selected.

2    Choose Edit > Transform and, from the submenu, choose one of the following commands:
•      Rotate 180° to rotate by a half-turn.
•      Rotate 90° CW to rotate clockwise by a quarter-turn.
•      Rotate 90° CCW to rotate counterclockwise by a quarter-turn.
•      Flip Horizontal to flip horizontally, along the vertical axis.
•      Flip Vertical to flip vertically, along the horizontal axis.

See also: 

To scale or rotate 
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Using the rubber stamp tool 

The rubber stamp tool ( ) lets you paint a copy, or a modified copy, of an image or color into the 
same image or into another image. The Clone options of the rubber stamp tool make a copy of, or 
sample, an image and paint an exact duplicate of that image. 

To use the rubber stamp tool:

1    Double-click the rubber stamp tool ( ) to display its Options palette.
2    Choose a mode, as explained in Selecting a blending mode.
3    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.
4    Choose a Clone option. The Clone options determine how the tool takes a sample of the image, which
you can then apply, or paint, over another image or over another part of the same image. Each stroke of 
the tool paints on more of the sampled image. See the following sections on the Clone options.
5    Position the pointer on the part of the image you want to sample, and Option-click (Macintosh) or Alt-
click (Windows). This sample point is the location from which the image will begin to be duplicated as you 
paint. 

 Option-click (Macintosh) or Alt-click (Windows) with the rubber stamp tool to sample from any open Adobe 
Photoshop window without changing the active window. 

6    Drag to paint with the rubber stamp tool.

See also: 

Clone (aligned) option 

Clone (nonaligned) option 



Using the rubber stamp tool 

Clone (aligned) option

The Clone (aligned) option applies the entire sampled area once, regardless of how many times you 
stop and resume painting. This option is useful when you want to use different sized brushes to paint 
an image. You can also use the Clone (aligned) option for duplicating two halves of a single image and
placing them at different locations. 



Using the rubber stamp tool 

Clone (nonaligned) option

This option applies the sampled area from the initial sampling point each time you stop and resume 
painting. Because the rubber stamp tool samples the entire image, this option is useful for applying 
multiple copies of part of an image to different locations. 
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Using the smudge tool

The smudge tool ( ) simulates the actions of dragging a finger through wet paint. The tool picks up 
color from where the stroke begins and pushes it in the direction in which you drag. 

Note: The smudge tool cannot be used with Bitmap or Indexed color mode images.

To use the smudge tool:

1    Double-click the smudge tool ( ) to display its Options palette.
2    Choose a mode, as explained in Selecting a blending mode.
3    Drag the slider to set the pressure, as explained in Specifying the opacity, pressure, or exposure.
4    To smudge using the foreground color at the beginning of each stroke, select Finger Painting. If you 
leave this option deselected, the smudge tool uses the color under the pointer at the beginning of each 
stroke.
5    Drag in the image to smudge color in the direction of the drag.

 Press Option (Macintosh) or Alt (Windows) as you drag with the smudge tool to use the Finger Painting option.
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Using the focus tools

The focus tools include the blur tool ( ), which lets you blur hard edges or areas in an image to 
reduce detail, and the sharpen tool (
), which lets you sharpen soft edges to increase clarity or focus. 

Note: The blur and sharpen tools cannot be used with Bitmap or Index color mode images.

For other ways to adjust image sharpness, see Step 5: Sharpen the image or Choosing a filter effect.

To use the blur or sharpen tool:

1    Double-click the blur or sharpen tool ( /
) in the toolbox to display the Focus Tools Options palette. 

2    For Tool, choose Blur or Sharpen.
3    Choose a mode, as explained in Selecting a blending mode.
4    Drag the slider to set the pressure, as explained in Specifying the opacity, pressure, or exposure.
5    Drag over the part of the image you want to blur or sharpen.
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Using the toning tools

The toning tools include the dodge and burn tools ( /
), which let you lighten or darken, respectively, specific areas of an image, and the sponge tool (
), which lets you change the color saturation of an area. 

The dodge and burn tools are based on the traditional photographer’s technique of increasing the amount
of exposure given to a specific area on a print. Photographers hold back light during an exposure to 
lighten an area on the print (dodging) or increase the exposure to darken areas on a print (burning-in). 
The sponge tool is useful for subtly increasing or reducing the saturation in an area. In Grayscale mode, 
the sponge tool increases or decreases contrast by moving gray levels away from or toward the middle 
gray.

Note: The dodge, burn, and sponge tools cannot be used with Bitmap or Index color mode images.

See also: 

To use the dodge or burn tool 

To use the sponge tool 



Using the toning tools 

To use the dodge or burn tool:

1    Double-click the dodge, burn, or sponge tool in the toolbox to display the Toning Tools Options 
palette. 

2    For Tool, choose Dodge or Burn.

3    Choose one of the following modes to limit the changes to specific parts of the image:
•      Midtones to change only the middle range of grays in the image.
•      Shadows to alter the dark portions of the image.
•      Highlights to modify only the light pixels. 

4    Drag the slider to set the exposure, as explained in Specifying the opacity, pressure, or exposure.

5    Drag over the part of the image you want to lighten or darken.

See also: 

To use the sponge tool 



Using the toning tools 

To use the sponge tool:

1    Double-click the dodge, burn, or sponge tool in the toolbox to display the Toning Tools Options 
palette.

2    For Tool, choose Sponge.

3    Choose one of the following modes to define the action of the sponge:
•      Saturate to intensify the color’s saturation.
•      Desaturate to dilute the color’s saturation. 

4    Drag the slider to set the pressure, as explained in Specifying the opacity, pressure, or exposure.

5    Drag over a portion of the image to change its saturation.

See also: 

To use the dodge or burn tool 
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Using the type and type mask tools

Adobe Photoshop lets you add bitmap type to an image using the type tool ( ). You can specify the 
leading, spacing, type styles, and alignment of the type. Normally, large bitmap characters appear 
jagged on the screen. However, if you use the Adobe Type Manager(R) (ATM(R)) program installed 
with Adobe Photoshop, or if you use TrueType(TM) fonts, characters appear almost as smooth and as 
well-defined as outline type. 

Bitmap type differs from the outline type generated in object-oriented applications such as Adobe 
Illustrator. In bitmap applications such as Adobe Photoshop, type is rendered at the resolution of the 
image. For example, if the resolution of the image is 100 ppi, the resolution of the type will also be 100 
ppi. You can’t edit the text contents of the bitmap type after you have placed it into the image.

For best results, import your Adobe Photoshop image into a page-layout program that supports 
PostScript language type, and create the type using that program.

See also: 

Adding type to an image 

Changing type opacity 

Setting the leading 

Setting the letterspacing 

Selecting style options for type 

Aligning type 

Adjusting individual characters 



Using the type and type mask tools 

Adding type to an image

You use the type tool to create bitmap type, which is added to the image as a new layer using the 
foreground color. You can also use the type mask tool to create a selection border in the shape of the 
type. This type selection can be moved, edited, filled, or stroked just like any other selection. 

See also: 

To add type filled with the foreground color 

To create a type selection border 



Adding type to an image 

To add type filled with the foreground color: 

1    Select the type tool ( ).
2    Click where you want the type to appear.
3    Choose a font, and specify a size for the type. 
If you’ve added or removed fonts from your system since starting Photoshop, you can update the Font 
menu in the Type Tool dialog box by holding down Shift and clicking in the image with the type tool.
4    Enter values for the leading and spacing. See Setting the leading and Setting the letterspacing for 
information on these options.
5    Select a style and alignment for the type. See Selecting style options for type and Aligning type for 
information on these options.

6    Type the text in the text box. Press Return (Macintosh) or Enter (Windows) to create a line break.

The type automatically wraps in the dialog box, but it appears as a single line in the image unless you 
press Return/Enter. You can enter up to 32,000 characters (or as much as the Windows text box 
holds, whichever is smaller).

7    To display the text in the text box as it will appear in the image, select Font and Size for Show. 
(When working with very large type sizes, deselect Size to prevent the pointer or type fro disappearing
from the text box.)

8    Click OK. Type appears in the foreground color on a new layer.

Note: In Windows, incompatibilities with some video drivers may cause TrueType fonts to rasterize 
incorrectly or not at all. (Type 1 fonts rasterized with ATM are not affected.) To work around the 
problem, create type at a large point size and then scale it down as desired using the Scale command.
Contact your video driver manufacturer for an updated driver that addresses this problem.

See also: 

To create a type selection border 



Adding type to an image 

To create a type selection border:

1    Select the type mask tool ( ).
2    Click where you want the type selection border to appear.
3    Specify type options and enter the text as described in steps 3 through 6 in the previous procedure.
4    Click OK. The type selection border appears in the image on the active layer.

See also: 

To add type filled with the foreground color 



Using the type and type mask tools 

Changing type opacity

Type created using the type tool appears as a new layer in the Layers palette. To change the type’s 
opacity, choose a different opacity from the Layers palette. 



Using the type and type mask tools 

Setting the leading 

You control the spacing between lines of text, called leading, using the Leading option in the Type Tool
dialog box. Leading is measured from baseline to baseline. The leading setting uses the same unit of 
measurement you specify for the font size (either points or pixels); by default, the leading built into the 
font is used. Values can range from 1 to 1000.



Using the type and type mask tools 

Setting the letterspacing 

You can control the spacing between letters using the Spacing option in the Type Tool dialog box. The 
Spacing setting uses the same unit of measurement that is specified for the font size (either points or 
pixels). Positive values increase the spacing; negative values reduce the spacing. Spacing increments
can be as small as tenths of a point or pixel (from –99.9 to 999.9).



Using the type and type mask tools 

Selecting style options for type 

You can apply six Style options for type—bold, italic, underline, outline, strikethrough, and anti-aliased
—individually or in combination.

Type, like all images in Adobe Photoshop, is composed of pixels. The Anti-aliased option in the Type 
Tool dialog box lets you minimize the pixel contrast at the edges of the text. When you select this 
option, the edges of the text appear smooth and blend into the background. You’ll probably want to 
use anti-aliased type in your images, unless you are working with type in small point sizes.



Using the type and type mask tools 

Aligning type 

Adobe Photoshop aligns type in reference to the last point you clicked with the type tool. For example, 
to center type on the image, select the type tool, click the center of the image, and then click the 
Center Alignment option in the Type Tool dialog box.

The Type Tool dialog box includes the following Alignment options:
•      The left column of Alignment options aligns text horizontally. 
•      The right column aligns text vertically.
•      The top alignment options begin the text at the insertion point that you click in the image.
•      The center alignment options center the text around the insertion point.
•      The bottom alignment options end the text at the insertion point. 



Using the type and type mask tools 

Adjusting individual characters 

When a text block is on its own layer, you can select individual characters and words in the text block. 
You then can move these characters to another position on the image and adjust letterspacing. You 
use a similar technique for deselecting characters in a type mask.

See also: 

To select type characters or to deselect characters in a type mask 

To adjust letterspacing manually 



Adjusting individual characters 

To select type characters or to deselect characters in a type mask:

Do one of the following:
•      To select type characters, select the lasso tool, and drag around the character or characters you 
want selected. To add additional characters to the selection, hold down Shift and drag the lasso 
around the additional characters.
•      To deselect characters in a type mask, select the lasso tool, hold down Option (Macintosh) or Alt 
(Windows), and drag around the character or characters you want to deselect. 

Note: Be sure to encircle the entire character you want to select or deselect; any part of a character 
outside the lasso is not changed.

 To move characters in a type mask, switch to Quick Mask mode. Then select the characters you want to move, 
press Command+Option (Macintosh) or Ctrl+Alt (Windows) and press an arrow key. Deselect the characters and exit 
Quick Mask mode. 

See also: 

To adjust letterspacing manually 



Adjusting individual characters 

To adjust letterspacing manually:

Do one of the following:
•      Hold down Command (Macintosh) or Ctrl (Windows) to activate the move tool, position the pointer 
inside one of the selected characters, and drag the characters to their new positions. To constrain the 
direction of movement to a multiple of 45°, hold down Shift as you drag.
•      Hold down Command (Macintosh) or Ctrl (Windows) to activate the move tool, and press the arrow
keys to move the selected characters in 1-pixel increments (or hold down Shift and press an arrow key
to move the type in 10-pixel increments).

See also: 

To select type characters or to deselect characters in a type mask 



Painting 

The painting tools and fill commands let you change the color of pixels to modify and create areas in 
your image.

See also: 

Choosing the foreground and background colors 

Using the painting tools 

Using the line tool 

Erasing 

Using the Brushes palette 

Specifying painting and editing options 

Using the paint bucket tool 

Using the gradient tool 

Filling a selection, layer, or work canvas 

Stroking a selection 

Using the eyedropper tool 

Using the Color palette 

Using the Swatches palette 

Using the Adobe Photoshop Color Picker 

Using the Apple Color Picker 

Using the Windows Color Picker 

Using plug-in color pickers 



Painting 

Choosing the foreground and background colors

Adobe Photoshop Limited Edition uses the foreground color, which appears in the top color selection 
box in the toolbox, to paint, fill, and stroke (paint the border of) selections. The background color, 
shown in the lower color selection box, is used for making gradient fills and for filling in the erased 
areas of an image. The default foreground color is black, and the default background color is white. (If 
you are in Quick Mask Mode, the default foreground and background colors are white and black, 
respectively.)

To reverse the foreground and background colors:

Click the Switch Colors icon in the toolbox. 

To return to the default foreground and background colors:

Click the Default Colors icon in the toolbox.

To change the foreground or background color:

1    Do one of the following:
•      To change the foreground color, click the top color selection box in the toolbox.
•      To change the background color, click the lower color selection box in the toolbox.

2    Choose a color, as explained in Using the Adobe Photoshop Color Picker, and click OK.
 To switch between the foreground and background colors, press X on the keyboard.



Painting 

Using the painting tools

The painting tools include the paintbrush tool, the airbrush tool, and the pencil tool. Each painting tool 
paints with the specified brush and tool pointer. For more information, see Using the Brushes palette 
and Using the tool pointers.

To save time when working with painting tools, make sure that the Navigator/Info/Options palette 
group and the Color/Swatches/Brushes palette group are open on your desktop. 

See also: 

Using the paintbrush tool 

Using the airbrush tool 

Using the pencil tool 



Using the painting tools 

Using the paintbrush tool

The paintbrush tool ( ) lets you create soft strokes of color.

To use the paintbrush tool:

Select the paintbrush tool and drag in the image.
 To draw a straight line with any painting tool, click a starting point in the image; then hold down Shift and click an 

endpoint.

To choose options for the paintbrush tool:

1    Double-click the paintbrush tool ( ) in the toolbox to display its Options palette. 
2    Choose a mode, as explained in Selecting a blending mode.
3    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.
4    Select Fade to set a fade-out rate, as explained in Specifying the paint fade-out rate.
5    Select Wet Edges to paint with a watercolor effect. With this option selected, the paint builds up along 
the edges of the brush stroke. 



Using the painting tools 

Using the airbrush tool

The airbrush tool ( ) lets you apply gradual tones (including sprays of color) to an image. It 
simulates the effect produced by traditional airbrush techniques. The edges of the stroke are more 
diffused than those created with the paintbrush tool. The pressure setting for the airbrush tool 
determines how quickly the spray of paint is applied.

To use the airbrush tool:

Select the airbrush tool and drag in the image. To build up color, hold down the mouse button without 
dragging.

To choose options for the airbrush tool:

1    Double-click the airbrush tool in the toolbox to display its Options palette. 

2    Choose a mode, as explained in Selecting a blending mode.

3    Drag the slider to set the pressure, as explained in Specifying the opacity, pressure, or exposure.

4    Select Fade to set a fade-out rate, as explained in Specifying the paint fade-out rate.



Using the painting tools 

Using the pencil tool

The pencil tool ( ) creates hard-edged freehand lines and is most useful for bitmapped images. See 
Using the Auto Erase option for information on erasing with the tool.

To draw a freehand line:

Select the pencil tool and drag in the image.

To choose options for the pencil tool:

1    Double-click the pencil tool ( ) to display its Options palette.
2    Choose a mode, as explained in Selecting a blending mode.
3    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.
4    Select Fade to set a fade-out rate, as explained in Specifying the paint fade-out rate.



Painting 

Using the line tool

The line tool ( ) draws straight lines on an image. Line tool options let you specify the width of lines, 
set anti-aliasing, and create lines with arrowheads. 

To draw a line:

Select the line tool and drag in the image. To constrain the line angle to a multiple of 45°, hold down 
Shift as you drag. 

To choose options for the line tool: 

1    Double-click the line tool in the toolbox to display its Options palette. 

2    Choose a mode, as explained in Selecting a blending mode.

3    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.

4    Enter the line width in pixels.

5    To draw anti-aliased lines, make sure that Anti-aliased is selected. 

6    To include arrowheads, select Start, End, or both to specify where you want arrowheads.

7    To edit the appearance of arrowheads, click Shape and do the following:
•      Enter a value from 10 to 1000% of the line width for the width of the arrowhead. 
•      Enter a value from 10 to 5000% of the line width for the length of the arrowhead. 
•      Enter a value from –50 to +50% for the concavity of the arrowhead. The concavity value defines 
the amount of curvature on the widest part of the arrowhead, where the arrowhead meets the line. 



Painting 

Erasing

The eraser tool and the Auto Erase option for the pencil tool let you replace colors in an image either 
with the background color or with transparency.

See also: 

Using the eraser tool 

Using the Auto Erase option 



Erasing 

Using the eraser tool

The eraser tool changes pixels in the image as you drag through them. You can choose to change the 
color and transparency of the affected pixels, or to revert the affected area to its previously saved 
version.

To use the eraser tool:

Select the eraser tool ( ) and drag through the area you want to erase.
If you’re working in the background, the pixels are changed to the background color. If you’re working in a 
layer, the color is replaced by transparency.

To choose options for the eraser tool:

1    Double-click the eraser tool to display its Options palette. 

2    Choose the tool type you want to use as an eraser—paintbrush, airbrush, pencil, or block. 
 To cycle through the eraser tool types, Option-click (Macintosh) or Alt-click (Windows) the eraser tool, or press 

Shift+E on the keyboard.

3    Drag the slider to set the opacity or pressure, as explained in Specifying the opacity, pressure, or 
exposure.

4    Select Fade to set a fade-out rate, as explained in Specifying the paint fade-out rate.

Note: If you’re using the paintbrush option, you can select Wet Edges to erase with a watercolor 
effect. With this option selected, the erased effect builds up along the edges of the brush stroke. 

5    To erase to a saved version of the image, select Erase to Saved. 
 To use the eraser tool in Erase to Saved mode, hold down Option (Macintosh) or Alt (Windows) as you drag in the 

image.

6    To erase an entire layer to transparency or to erase a background to the background color, click 
Erase Layer. (If the image has no layers, this button becomes Erase Image.)



Erasing 

Using the Auto Erase option

The Auto Erase option for the pencil tool ( ) lets you paint the background color over areas containing
the foreground color.

To use the Auto Erase option:

1    Double-click the pencil tool to display its Options palette.

2    Select Auto Erase.

3    Drag over the image. 

If you drag over the foreground color, the area is erased to the background color (according to the 
tool’s opacity). If you begin dragging from an area that doesn’t contain the foreground color, the area is
painted with the foreground color. 



Painting 

Using the Brushes palette

The brushes you use for the painting and editing tools appear in the Brushes palette. Round brush 
shapes for the painting and editing tools are available in several sizes. Adobe Photoshop retains the 
brush settings for each painting and editing tool, so you can select a different default brush for each 
tool. The Brushes palette also contains commands for creating and deleting brushes, defining brush 
options, and saving and loading sets of brushes. 

See also: 

Choosing a brush 

Creating and deleting brushes 

Creating custom brushes 

Setting brush options 

Saving, loading, and replacing brushes 



Using the Brushes palette 

Choosing a brush 

You use the Brushes palette to choose a brush shape for any painting tool. When a brush is too large 
to fit in a square on the palette, it appears in a reduced size with a number that indicates the brush 
diameter in pixels.

To choose a brush:

1    Select the tool you want to use.

2    Choose Window > Show Brushes. 

3    Click the brush you want to use.



Using the Brushes palette 

Creating and deleting brushes

If the Brushes palette does not contain the brushes you need, you can create new brushes. New 
brushes are added at the bottom of the palette. If you find that you no longer use a brush, you can 
delete it from the Brushes palette. 

To create a brush:

1    Do one of the following:
•      Click in the empty area outside the brush squares in the Brushes palette.
•      Choose New Brush from the Brushes palette menu.

The preview box in the lower right corner of the New Brush dialog box shows the current brush tip. 
The box in the lower left corner shows the current brush angle and roundness. These boxes change to
reflect the new brush as you enter brush options. 

2    Set the brush options. (See Setting brush options for a description of these options.)

3    Click OK.

To delete a brush:

Do one of the following:
•      Press Command (Macintosh) or Ctrl (Windows) (the pointer turns into scissors) and click the brush
you want to delete.
•      Click the brush in the Brushes palette and choose Delete Brush from the palette menu.



Using the Brushes palette 

Creating custom brushes

You can use part of an image to create a custom brush shape. If you want to define brushes with soft 
edges, select brush shapes composed of pixels with gray values. 

To create a custom brush shape: 

1    Select the part of the image you want to use as a custom brush. The brush shape can be up to 
1000 pixels by 1000 pixels in size. To be most effective, the shape should appear on a solid white 
background.

2    Choose Define Brush from the Brushes palette menu. 

3    Double-click the newly created brush in the Brushes palette to open the Brush Options dialog box.

4    Specify Spacing as described in the next section.

5    To make the brush placement more accurate, make sure that Anti-aliased is selected. Then click 
OK.

The Anti-aliased option is not available for large brushes.



Using the Brushes palette 

Setting brush options

You can define a number of options for the default brushes and any brushes you create. Only the 
spacing option can be changed for custom brushes.

To set brush options:

1    Do one of the following:
•      Double-click the brush you want to edit. 
•      Select the brush in the Brushes palette you want to edit, and choose Brush Options from the 
palette menu.

2    Set the Diameter, Hardness, Spacing, Angle, and Roundness. Then click OK. 

Diameter

Controls the size of the brush. Enter a value in pixels or drag the slider.

Hardness

Controls the size of the hard center of the brush. Type a number or use the slider to enter a value that 
is a percentage of the brush diameter.

Spacing

Controls the distance between the brush marks in a stroke. To change the spacing, type a number or 
use the slider to enter a value that is a percentage of the brush diameter. To paint strokes without 
defined spacing, deselect this option.

Angle

Specifies the angle by which an elliptical brush’s long axis is offset from horizontal. Type a value in 
degrees, or drag the horizontal axis in the left preview box to set a new angle.

Roundness

Specifies the ratio between the brush’s short and long axes to determine its shape. Enter a 
percentage value or drag the points in the left preview box. A value of 100% indicates a circular brush, 
a value of 0% indicates a linear brush, and intermediate values indicate elliptical brushes.



Using the Brushes palette 

Saving, loading, and replacing brushes

The Brushes palette can hold as many brushes as you want. However, to make the palette more 
manageable and to group related or special brushes, you might want to create your own sets of 
brushes. A number of files containing different brush sets are included in the Adobe Photoshop 
program folder.

To save and use custom brush sets:

Choose one of the following commands from the Brushes palette menu:
•      Reset Brushes to return to the default brushes. You can either replace the current brush set or 
append the default brushes to the current set.
•      Load Brushes to add the brushes stored in a file to the current palette. 
•      Replace Brushes to replace the current brush set with brushes stored in a file.
•      Save Brushes to save a brush set in a file. 

When you exit Adobe Photoshop, the current Brushes palette is saved in the Preferences file.



Painting 

Specifying painting and editing options

You specify options for a painting or editing tool by using the Options palette for that tool. See the 
following topics for more information.

See also: 

Specifying the opacity, pressure, or exposure 

Specifying the paint fade-out rate 

Specifying stylus pressure options 

Selecting a blending mode 



Specifying painting and editing options 

Specifying the opacity, pressure, or exposure

The slider in the Options palette lets you specify the opacity, pressure, or exposure for various painting
and editing tools. You can determine the opacity used by the gradient fill, pencil, paintbrush, and 
rubber stamp tools. You can adjust the pressure of action applied by the airbrush, smudge, blur, 
sharpen, and sponge tools. You can also adjust the amount of exposure used by the dodge and burn 
tools. 

Opacity can range from 1 to 100%. To use transparent paint, specify a low percentage value. To use 
more opaque paint, specify a high value. 

Pressure and exposure can range from 1 to 100%. To create a strong effect, specify a high 
percentage value. To create a weaker effect, specify a low value.

 To set the opacity, pressure, or exposure for any selected painting or editing tool in multiples of 10%, press a 
number from 0 through 9. For example, press 5 to choose 50%. Press 0 to choose 100%. To set an exact opacity or 
pressure, quickly type the desired value on the keyboard.



Specifying painting and editing options 

Specifying the paint fade-out rate 

You can specify the rate at which the pencil, paintbrush, airbrush, and eraser strokes fade out to 
simulate actual brush strokes. 

To set a fade-out rate:

1    Select Fade in the tool’s Options palette.

2    Enter a value for the number of steps of the fade.

The steps determine the rate of the fade from the beginning to the end of the stroke. Each step is 
equal to one mark of the brush tip. The value can range from 1 to 9999. For example, entering 10 
steps produces a fade in 10 increments. 

3    Choose one of the following options:
•      Transparent to fade the stroke from the foreground color to transparency.
•      Background to fade the stroke from the foreground color to the background color. 



Specifying painting and editing options 

Specifying stylus pressure options

Adobe Photoshop supports pressure-sensitive digitizing tablets such as the Wacom(R) and Calcomp 
tablets. If the Control Panel software for your tablet is installed, you can specify the type of effect that 
results from varying the stylus pressure. These stylus pressure options affect the pencil, paintbrush, 
airbrush, eraser, rubber stamp, smudge, blur, sharpen, dodge, burn, and sponge tools. 

To set the effect of different stylus pressures:

Display the tool’s Options palette, and select from the following options:
•      Size if you want increasing pressure to result in a bigger brush stroke.
•      Opacity/Pressure/Exposure if you want increasing pressure to result in more opaque paint or a 
more intense effect.
•      Color if you want increasing pressure to add more of the foreground color.

Note: The highest pressure of your stylus may not reach 100%. This problem is due to the driver 
software and is not caused by the Adobe Photoshop program. If you experience this problem, contact 
your tablet vendor for more information. 



Specifying painting and editing options 

Selecting a blending mode

You can control which pixels are affected by a painting or editing tool by choosing a blending mode in 
the tool’s Options palette. When using blending modes, it’s helpful to think of the effects in terms of the
following three colors:
•      The base color is the original color in the image. 
•      The blend color is the color being applied with the painting or editing tool.
•      The result color is the color resulting from the blend. 

Note: To select the next or previous blending mode from the Options palette using the keyboard, 
press Shift+[+] or Shift+[-], respectively.

The following sections describe each of the painting and editing modes. 

See also: 
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Selecting a blending mode 

Normal

Edits or paints each pixel to make it the result color. (To set the mode from the keyboard, press 
Shift+Option+N (Macintosh) or Shift+Alt+N (Windows).) This is the default mode. (Normal mode is 
called Threshold when you’re working with a bitmapped or indexed-color image.)

See also: 
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Selecting a blending mode 

Dissolve

Edits or paints each pixel to make it the result color; however, the result color is a random replacement
of the pixels with the base color or the blend color, depending on the opacity at any pixel location. 
(Press Shift+Option/Alt+I.) This mode works best with the paintbrush or airbrush tool and a large 
brush.

See also: 
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Selecting a blending mode 

Behind

Edits or paints only on the transparent part of a layer. (Press Shift+Option/Alt+Q.) This mode works 
only in layers that contain transparency. When you apply paint, it appears that you’re painting on the 
back of the transparent areas in a sheet of acetate.

See also: 
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Selecting a blending mode 

Clear

Edits or paints each pixel and makes it transparent. (Press Shift+Option/Alt+R.) This mode is available
for the line tool (l), the paint bucket tool (t), the Fill command, and the Stroke command. You must be 
in a layer to use this mode. 

See also: 
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Selecting a blending mode 

Multiply

Looks at the color information in each channel and multiplies the base color by the blend color. (Press 
Shift+Option/Alt+M.) The result color is always a darker color. Multiplying any color with black 
produces black. Multiplying any color with white leaves the color unchanged. When you’re painting 
with a color other than black or white, successive strokes with a painting tool produce progressively 
darker colors. The effect is similar to drawing on the image with multiple magic markers. 

See also: 
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Selecting a blending mode 

Screen

Looks at each channel’s color information and multiplies the inverse of the blend and base colors. 
(Press Shift+Option/Alt+S.) The result color is always a lighter color. Screening with black leaves the 
color unchanged. Screening with white produces white. The effect is similar to painting over an area 
with bleach. 

See also: 
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Selecting a blending mode 

Overlay

Multiplies or screens the colors, depending on the base color. (Press Shift+Option/Alt+O.) Patterns or 
colors overlay the existing pixels while preserving the highlights and shadows of the base color. The 
base color is not replaced but is mixed with the blend color to reflect the lightness or darkness of the 
original color. 

See also: 
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Selecting a blending mode 

Soft light

Darkens or lightens the colors, depending on the blend color. (Press Shift+Option/Alt+F.) The effect is 
similar to shining a diffused spotlight on the image. 

If the blend color (light source) is lighter than50% gray, the image is lightened, as if it were dodged. If 
the blend color is darker than 50% gray, the image is darkened, as if it were burned in. Painting with 
pure black or white produces a distinctly darker or lighter area but does not result in pure black or 
white. 

See also: 
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Selecting a blending mode 

Hard light

Multiplies or screens the colors, depending on the blend color. (Press Shift+Option/Alt+H.) The effect 
is similar to shining a harsh spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were screened. 
This is useful for adding highlights to an image. If the blend color is darker than 50% gray, the image is
darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting with pure 
black or white results in pure black or white.

See also: 
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Selecting a blending mode 

Darken

Looks at the color information in each channel and selects the base or blend color—whichever is 
darker—as the result color. (Press Shift+Option/Alt+K.) Pixels lighter than the blend color are 
replaced, and pixels darker than the blend color do not change.

See also: 
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Selecting a blending mode 

Lighten

Looks at the color information in each channel and selects the base or blend color—whichever is 
lighter—as the result color. (Press Shift+Option/Alt+G.) Pixels darker than the blend color are 
replaced, and pixels lighter than the blend color do not change.

See also: 
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Selecting a blending mode 

Difference

Looks at the color information in each channel and subtracts either the blend color from the base color
or the base color from the blend color, depending on which has the greater brightness value. (Press 
Shift+Option/Alt+E.) 

See also: 
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Selecting a blending mode 

Exclusion

Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts 
the base color values. Blending with black produces no change.

See also: 
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Selecting a blending mode 

Hue

Creates a result color with the luminance and saturation of the base color and the hue of the blend 
color. (Press Shift+Option/Alt+U.) 

See also: 

Normal 

Dissolve 

Behind 

Clear 

Multiply 

Screen 

Overlay 

Soft light 

Hard light 

Darken 

Lighten 

Difference 

Exclusion 

Saturation 

Color 

Luminosity 



Selecting a blending mode 

Saturation

Creates a result color with the luminance and hue of the base color and the saturation of the blend 
color. (Press Shift+Option/Alt+T.) If you paint with this mode in an area with a saturation of zero (gray),
there is no change. 

See also: 
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Selecting a blending mode 

Color

Creates a result color with the luminance of the base color and the hue and saturation of the blend 
color. (Press Shift+Option/Alt+C.) This preserves the gray levels in the image and is useful for coloring
monochrome images and for tinting color images.

See also: 
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Selecting a blending mode 

Luminosity

Creates a result color with the hue and saturation of the base color and the luminance of the blend 
color. (Press Shift+Option/Alt+Y.) This mode creates an inverse effect from that of the Color mode.

See also: 
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Painting 

Using the paint bucket tool

The paint bucket tool ( ) fills adjacent pixels that are similar in color value to the pixels you click. The
paint bucket options let you specify a mode and opacity, and indicate the color range, or tolerance, of 
pixels to be filled. You can also choose to create smooth edges for the filled selection.

Note: The paint bucket tool cannot be used with images in Bitmap or Index color mode. 

If you’re working on a layer and do not want to fill transparent areas, make sure that Preserve 
Transparency is selected in the Layers palette. See Preserving a layer’s transparency.

To use the paint bucket tool:

Select the paint bucket tool and then click the part of the image you want to fill. All adjacent pixels 
within the specified tolerance are filled with the foreground color.

To choose options for the paint bucket tool: 

1    Double-click the paint bucket tool to display its Options palette.

2    Choose a mode, as explained in Selecting a blending mode.

3    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.

4    Enter the tolerance for the fill.

The tolerance defines how similar in color a pixel must be to be filled. Values can range from 0 to 255. 
A low tolerance fills pixels that have color values very similar to the pixel you click. A high tolerance fills
pixels within a broader range of colors.

5    To smooth the edges of the filled selection, select Anti-aliased. See Using the Anti-aliased option 
for more information on anti-aliasing.



Painting 

Using the gradient tool

The gradient tool ( ) lets you create a gradual transition between two colors. If you don’t select a 
specific part of the image to fill, the gradient tool applies the fill to the entire active layer. 

A gradient fill can be applied as either a radial or a linear fill. A linear gradient fill creates a gradient from 
one point to another in a straight line. A radial fill creates a gradient fill from a center point outward in all 
directions.

Note: The gradient tool cannot be used with bitmap or indexed-color images.

To apply a gradient fill: 

1    Select the part of the image you want to fill. If you do not make a selection, the gradient fill is 
applied to the entire active layer. 

2    Double-click the gradient tool ( ) in the toolbox to display its Options palette.
3    Choose a mode, as explained in Selecting a blending mode.
4    Drag the slider to set the opacity, as explained in Specifying the opacity, pressure, or exposure.
5    If you want to create a smoother blend with less banding, select Dither.
6    For Type, choose one of the following options:

•      Linear to create a linear fill.
•      Radial to create a radial fill.

7    Select a gradient fill from the list.

8    Position the pointer in the image where you want to set the starting point of the gradient, and drag 
to define the length and direction of a linear fill or to define the radius of a radial fill. To constrain the 
line angle to a multiple of 45°, hold down Shift as you drag.

9    Release the mouse button where you want to set the ending point of the gradient.

If you’re creating a linear fill, the portion of the layer or selection before the starting point is filled with 
the starting color; the portion after the ending point is filled with the ending color. If you’re creating a 
radial fill, the ending color fills the portion after the ending point.



Painting 

Filling a selection, layer, or work canvas

The Fill command lets you fill a selection or a layer with a color or a saved portion of an image. You 
can also use keyboard shortcuts to fill a selection or layer quickly, and you can use the paint bucket 
tool to fill the work canvas.

To fill the work canvas:

1    Set the foreground color to the color you want to use for the canvas. See Choosing the foreground 
and background colors for more information. 

2    Select the paint bucket tool. Then hold down Shift and click in the work canvas area.

To fill a selection or layer using shortcuts: 

1    Select the area or layer you want to fill.

2    Do one of the following:
•      To fill with the foreground color, press Option+Delete (Macintosh) or Alt+Backspace (Windows).
•      To apply a foreground color fill only to the areas that contain pixels, press Option+Shift+Delete 
(Macintosh) or Alt+Shift+Backspace (Windows). This operation preserves the transparency of the 
layer.
•      To fill with the background color, press Delete (Macintosh) or Backspace (Windows). 
•      To apply a background color fill only to the areas that contain pixels, press Shift+Command+Delete
(Macintosh) or Shift+Ctrl+Backspace (Windows).

To fill a selection or a layer: 

1    Select the area you want to fill. To fill an entire layer, select the layer in the Layers palette.

2    Choose Edit > Fill to fill the selection or layer. 
 To display the Fill dialog box, press Shift+Delete (Macintosh) or Shift+Backspace (Windows). 

3    Choose a mode, as explained in Selecting a blending mode.

4    Set the opacity, as explained in Specifying the opacity, pressure, or exposure.

5    Click OK to fill the selection.



Painting 

Stroking a selection

The Stroke command uses the foreground color to paint a border around a selection or around the 
edge of a layer. As with the Fill command, you can specify the opacity and blending mode of the fill. 

To stroke a selection or layer:

1    Select the area or layer you want to stroke. 

2    Choose Edit > Stroke. 

3    Specify the width and location of the border. Values for the width can range from 1 to 16 pixels. 

4    Set the opacity, as explained in Specifying the opacity, pressure, or exposure.

5    Choose a mode, as explained in Selecting a blending mode.

6    If you’re working in a layer and want to stroke only areas containing pixel values, select the 
Preserve Transparency option. See Preserving a layer’s transparency.

7    Click OK to stroke the selection or layer.
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Using the eyedropper tool

The eyedropper tool ( ) lets you sample color from an area of an image to designate a new 
foreground or background color. You can sample from the active image or from another image. (When 
you’re using the eyedropper, you can click in a background window without making it the active 
window.)

You can also specify the sample area that the eyedropper tool reads. For example, you can set the 
eyedropper to sample the color values of a 3-by-3-screen-pixel area under the pointer. 

To select the foreground or background color using the eyedropper:

1    Click the eyedropper tool ( ).
2    Do one of the following:

•      To select a new foreground color from an image, click the color you want.
•        To select a new background color from an image, Option-click (Macintosh) or Alt-click (Windows) 
the color you want.

If you drag the eyedropper tool, the foreground color selection box changes dynamically as you drag. 
Option-drag (Macintosh) or Alt-drag (Windows) to activate the background color selection box. 
Release the mouse button to pick the new color.

 To use the eyedropper tool temporarily while using any painting tool, hold down Option (Macintosh) or Alt 
(Windows). 

To change the sample size of the eyedropper:

1    Double-click the eyedropper tool to display the Eyedropper Options palette.

2    Choose one of the following options from the Sample Size menu: 
•      Point Sample to read the precise value of the pixel you click.
•      3 by 3 Average or 5 by 5 Average to read the average value of the specified number of screen 
pixels within the area you click.
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Using the Color palette 

The Color palette displays the color values for the current foreground and background colors. Using 
the sliders in the Color palette, you can edit the foreground and background colors according to 
several different color models. 

To edit the foreground or background color using the Color palette: 

1    Choose Window > Show Color. 

2    From the Color palette menu, choose the color model you want to use for color readout values. 
See Setting color readout values for a discussion of these models.

3    To edit the foreground or background color, make sure that its color selection box is active (outlined
in black). To make the foreground or background color selection box active, click the box. 

4    To specify a new color, do one of the following:
•      Drag the color sliders.

By default, the slider colors change as you drag. If you want to turn off this preview feature to improve 
performance, choose File > Preferences > General and deselect Dynamic Color Sliders.
•      Enter values next to the color sliders. 
•      Click the color selection box, choose a color as described in Using the Adobe Photoshop Color 
Picker, and click OK. 

See also: 

Choosing a color from the color bar 

Setting color readout values 



Using the Color palette 

Choosing a color from the color bar

The color bar along the bottom of the Color palette lets you quickly choose a background or 
foreground color from a specified spectrum of colors. 

To sample colors from the color bar:

1    To edit the foreground or background color, make sure that its color selection box is active (outlined
in black). To make the foreground or background color selection box active, clickthe box. 

2    Position the pointer over the color bar (the pointer turns into the eyedropper), and click to sample a 
color.

To change the display of the color bar:

1    Choose Color Bar from the Color palette menu. 

2    For Style, choose a model and then click OK. The Current Colors option displays a transition from 
the current foreground color to the current background color. 

 To change the display style of the color bar quickly, Shift-click in the color bar until you see the style you want.



Using the Color palette 

Setting color readout values

The Color palette and the Adobe Photoshop Color Picker let you display color values using a number 
of different color models. See Color modes and models for more information on these color models.
•      Grayscale: Lets you choose a color with a gray value from 0% to 100%.
•      RGB: Lets you choose a color with red, green, and blue values ranging from 0 to 255.
•      HSB: Lets you choose a color with a hue from 0° to 360° and with saturation and brightness 
values from 0 to 100%. The angle for hue is defined as an angle relative to pure red on the color 
wheel. See HSB model.
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Using the Swatches palette

The Swatches palette contains the current color palette. You can choose a foreground or background 
color from the swatches, or you can add or delete colors to create a custom palette. You can also save
a set of swatches and reload them for use in another image.

To display the Swatches palette:

Choose Window > Show Swatches.

To choose a color:

Do one of the following:
•      To choose a foreground color, click a color in the Swatches palette. 
•      To choose a background color, Option-click (Macintosh) or Alt-click (Windows) a color in the 
Swatches palette.

See also: 

Adding or deleting a color 

Saving, loading, and replacing swatches 



Using the Swatches palette 

Adding or deleting a color

You can add, delete, and insert colors in the Swatches palette to create a customized palette. 
Swatches can be added to the blank areas in the palette. 

See also: 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 



Adding or deleting a color 

To add a color to the Swatches palette: 

1    Use the eyedropper tool, the Color palette, or the Color Picker to select the color you want to add. 

2    Position the pointer over an empty space in the bottom row of the Swatches palette (the pointer 
turns into the paint bucket tool), and click to add the color.

See also: 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 



Adding or deleting a color 

To replace or insert a color in the Swatches palette:

1    Use the eyedropper tool ( ), the Color palette, or the Color Picker to select the color you want to 
add. 

2    Do one of the following:
•      To replace an existing swatch, hold down Shift, position the pointer over a swatch (the pointer 
turns into a paint bucket), and click the swatch. 
•      To insert a new swatch, press Shift+Option (Macintosh) or Shift+Alt (Windows) and click a swatch.

See also: 

To add a color to the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 



Adding or deleting a color 

To delete a color from the Swatches palette:

Hold down Command (Macintosh) or Ctrl (Windows), position the pointer over a swatch (the pointer 
turns into scissors), and click.

See also: 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To return to the default Swatches palette 



Adding or deleting a color 

To return to the default Swatches palette:

1    Choose Reset Swatches from the Swatches palette menu.

2    Do one of the following:
•      Click OK to replace the current swatches with the default set.
•      Click Append to attach the default swatches to the end of the current set.

See also: 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 



Using the Swatches palette 

Saving, loading, and replacing swatches 

The Swatches palette can hold as many colors as you want. However, to make the palette more 
manageable and to group related or special colors, you might want to create your own Swatches 
palettes. A number of files containing different swatch sets are included in the Adobe Photoshop 
program folder.

To save and use custom swatch sets:

Choose one of the following commands from the Swatches palette menu:
•      Reset Swatches to use the default set of swatches. You can either replace the current swatch set 
or append the default swatches to the current set.
•      Load Swatches to append the swatches stored in a file to the current set of swatches.
•      Replace Swatches to replace the current swatch set with the swatches stored in a file.
•      Save Swatches to save the current swatches in a file. 

When you exit the program, the current Swatches palette is saved in the Adobe Photoshop 
preferences file.
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Using the Adobe Photoshop Color Picker 

The Adobe Photoshop Color Picker lets you select the foreground or background color from a color 
spectrum or to define color components for a color numerically. In addition, you can select colors 
based on the HSB or RGB color models.

By default, the Photoshop program uses the Adobe Photoshop Color Picker. You can also use plug-in 
and system color pickers to select foreground and background colors. For more information, see 
Using the Apple Color Picker, Using the Windows Color Picker, and Using plug-in color pickers.

To display the Adobe Photoshop Color Picker:

Do one of the following:
•      Click the foreground or background color selection box in the toolbox.
•      Click the active color selection box in the Color palette. 

To return to the Adobe Photoshop Color Picker after using another color picker:

1    Choose File > Preferences > General.

2    For Color Picker, choose Photoshop.

See also: 

Specifying a color using the color field and color slider 

Specifying a color using numeric values 



Using the Adobe Photoshop Color Picker 

Specifying a color using the color field and color slider

With the HSB and RGB color models, you can use the color field and the color slider in the Color 
Picker dialog box to select a color. The color slider displays the range of color levels available for the 
selected color component (for example, R, G, or B). The color field displays the range for the 
remaining two components—one on the horizontal axis and one on the vertical axis.

For example, if the current color is black and you click the red component (R) using the RGB color 
model, the color slider displays the range of color for red (0 is at the bottom of the slider and 255 is at 
the top). The color field displays the values for blue along its horizontal axis and the values for green 
along its vertical axis. 

To choose a color:

Do one of the following:
•      Drag the white triangles along the slider.
•      Click inside the color slider.
•      Click inside the color field. 

When you click in the color field, a circular marker indicates the color’s position in the field. 

As you adjust the color using the color field and color slider, the numerical values change to reflect the
new color. The color rectangle to the right of the color slider displays the new color in the top section of
the rectangle. The original color appears in the bottom of the rectangle.



Using the Adobe Photoshop Color Picker 

Specifying a color using numeric values

In the Adobe Photoshop Color Picker, you can select a color in either color model by specifying 
numeric values for each color component. 

To specify colors using numeric values:

Do one of the following:
•      In the RGB color model (this is the model your monitor uses), specify component values from 0 to 
255 (0 is black, and 255 is the pure color). 
•      In the HSB color model, specify saturation and brightness as percentages; and specify hue as an 
angle, from 0° to 360°, that corresponds to a location on the color wheel. (See Color modes and 
models for information on the color wheel.)
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Using the Apple Color Picker

On the Macintosh, you can use the Apple Color Picker (also known as the color wheel) to change the 
foreground or background color. The Apple Color Picker lets you select colors based on the HSB or 
the RGB color model. 

This section briefly describes how to use the Apple Color Picker. For more information, see your 
Macintosh documentation.

To use the Apple Color Picker: 

1    Choose File > Preferences > General.

2    For Color Picker, choose Apple and click OK.

3    Click the foreground or background color selection box in the toolbox. 

4    Enter values for Hue, Saturation, and Lightness, or click the color you want in the color wheel. 

To select colors based on the RGB model, click Apple RGB at the left of the dialog box and enter 
values for Red, Blue, and Green. 
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Using the Windows Color Picker

In Windows, you can use the Windows Color Picker to change the foreground or background color. 
The Windows Color Picker lets you select colors from an array of basic colors or define up to 16 
custom colors based on the HSB or the RGB color model.

This section briefly describes how to use the Windows Color Picker. For more information, see your 
Windows documentation.

To use the Windows Color Picker: 

1    Choose File > Preferences > General. 

2    For Color Picker, choose Windows and click OK.

3    Click the foreground or background color selection box in the toolbox. 

4    To choose a color from the Basic Colors palette, click the color you want.

5    To specify a custom color, click Define Custom Colors to bring up the Custom Color Selector. This 
dialog box functions similarly to the Adobe Photoshop Color Picker. Specify a color by using the color 
field and color slider or by entering numerical values for each color component. 

The new color is displayed on the left side of the Color/Solid box. The right side of this box displays 
the solid color closest to the color you have specified. (You can choose the displayed solid color by 
double-clicking the right side of the box.)

6    When you are satisfied with the color, click Add to Custom Colors to add it to the Custom Colors 
palette.

7    To choose a custom color from the Windows Color Picker, click the color you want.

8    Click OK.
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Using plug-in color pickers

In addition to the default Adobe Photoshop Color Picker and the Apple or Windows Color Picker, you 
can install and use plug-in color pickers. Any plug-in color pickers you install appear under Color 
Picker when you choose File > Preferences > General. For information on installing and using a plug-
in color picker, see the documentation that came with the plug-in.



Using Layers

When you create a new Adobe Photoshop Limited Edition document, the image consists of a 
background, which is analogous to the canvas under a painting. You can add one or more layers to 
the document. Layers let you edit specific areas of your image without affecting any other data. You 
can draw, edit, paste, use masks, and reposition elements on a layer without disturbing any other 
layers in the image. 

With layers, you can experiment freely with different combinations of graphics, type, special effects, 
and opacities. Until you merge (that is, combine) the layers, each one remains independent of the 
other layers in the image.

Note: Images created using the Transparent option in the New dialog box are created without a 
background. Images with no background, as well as images with layers, can be saved only in the 
Photoshop format.

Layers are not available for 16-bit mode images.

Images created in versions of Adobe Photoshop earlier than 3.0 consist only of a single background 
layer. If you add layers to such images using this version of Photohsop LE, you can save them only in 
the Photoshop format. 

See also: 

Using the Layers palette 

Creating a layered image 

Viewing layers 

Moving and copying layers 

Converting and adding backgrounds 

Editing layers 

Deleting layers 

Specifying layer options 

Creating clipping groups 

Using layer masks 

Managing layered documents 



Using Layers 

Using the Layers palette

The Layers palette lists all the layers in the image, starting with the topmost layer. A thumbnail of the 
layer contents appears to the left of the layer name. This thumbnail is updated as you edit the layer. 
Use the scroll bars or resize the palette to see additional layers.

You use the Layers palette to create, hide, display, copy, merge, and delete layers. (Additional 
commands appear in the menu.) When you modify an image, the changes affect only the active layer, 
that is, the highlighted layer in the Layers palette. You select a layer to make it active, and only one 
layer can be active at a time. The name of the active layer also appears in the image window’s title 
bar. 

To select a layer:

Do one of the following:
•      In the Layers palette, click a layer to make it active.
•      Select the move tool and Control-click (Macintosh) or right-click (Windows) in the image and 
choose the layer you want from the context menu. The context menu lists all the layers that have 
pixels under the current pointer location.



Using Layers 

Creating a layered image

Adobe Photoshop lets you create up to 99 layers in an image, each with its own blending mode and 
opacity. However, the amount of memory in your system may put a lower limit on the number of layers 
you can have in a single image. 

You can create new layers by using the New Layer button or command, by dragging or pasting 
selections into your image, or by converting selections into layers. You can also copy layers between 
two open Adobe Photoshop images (see Duplicating layers in a single image). 

See also: 

Adding new layers 

Adding selections as layers 



Creating a layered image 

Adding new layers

You add layers to an image using the New Layer button at the bottom of the Layers palette or the New
Layer command, which appears in the Layer > New menu or in the Layers palette menu. New layers 
appear above the active layer in the Layers palette.

To create a new layer using default options:

Click the New Layer button ( ) at the bottom of the Layers palette. The layer uses Normal mode with 
100% opacity and is named according to the order in which it was created.

To add a new layer and specify options:

1    Do one of the following:
•      Choose Layer > New > Layer.
•      Choose New Layer from the Layers palette menu.
•      Option-click (Macintosh) or Alt-click (Windows) the New Layer button at the bottom of the Layers 
palette.

2    Name the layer, and select mode, opacity, and fill options as described in Specifying layer options. 
Then click OK.



Creating a layered image 

Adding selections as layers

When you drag or paste a selection into a document, the selection is automatically pasted into a new 
layer. The new layer is created using the default options of Normal mode and 100% opacity and 
appears above the active layer in the Layers palette. You can also convert a selection to a layer.

To turn a selection into a new layer: 

1    Make a selection. 

2    Choose Layer > New and choose one of the following commands from the submenu:
•      To copy the selection from the existing layer onto a new layer, choose Layer Via Copy.
•      To cut the selection from the existing layer and paste it into a new layer, choose Layer > New > 
Layer Via Cut. 



Using Layers 

Viewing layers

You use the Layers palette to show, hide, and preview layers. You can also control how transparent 
areas in a layer appear in your image. 

See also: 

Showing and hiding layers 

Hiding and resizing layer thumbnails 

Setting transparency preferences 



Viewing layers 

Showing and hiding layers

You can make layers temporarily invisible to speed performance as you edit or print other parts of the 
image. Only visible layers are printed. When a layer is visible, an eye icon appears in the leftmost 
column of the Layers palette for that layer. 

To show or hide a layer:

Do one of the following:
•      In the Layers palette, click the eye icon next to a layer to hide that layer. Click in the column again 
to redisplay the layer. 
•      Drag through the eye column to show or hide multiple layers.
•      Option-click (Macintosh) or Alt-click (Windows) the eye icon for a layer to display just that layer. 
Option/Alt-click in the eye column again to redisplay all the layers. 

Note: You can use this procedure to hide the active layer; if you do, however, you won’t be able to edit
it.



Viewing layers 

Hiding and resizing layer thumbnails

You can change the size or turn off the display of thumbnails in the Layers palette. Thumbnails are the
most convenient way of monitoring layer contents, but turning off thumbnails can improve performance
and save disk space. Using smaller thumbnails reduces the space required by the Layers palette and 
can be helpful when you’re working on a smaller monitor. 

To change the display of layer thumbnails:

1    Choose Palette Options from the Layerspalette menu.

2    Click a size or click None to turn off the thumbnails, and then click OK.



Viewing layers 

Setting transparency preferences

A layer is transparent until you add pixels to it. By default, the transparent areas of a document appear
as a checkerboard pattern. You can change the appearance of this pattern. 

To change the transparency settings:

1    Choose File > Preferences > Transparency. 

2    For Grid Size, select a new size for the pattern. If you choose None, transparent areas in the layer 
appear white. 

3    For Grid Colors, select one of the following options:
•      Light, Medium, or Dark to specify a gray pattern. 
•      Any other color from the list to display the checkerboard in that color.
•      Custom to choose a color that does not appear in the list. 

4    If you chose Custom, click either of the color selection boxes (with the current pattern colors) to 
choose a custom color from the Color Picker. 

5    Click OK.



Using Layers 

Moving and copying layers

You can move, copy, and change the stacking order of layers. 

See also: 

Changing the order of layers 

Moving layers 

Duplicating layers in a single image 

Copying layers between images 



Moving and copying layers 

Changing the order of layers

You can use the Layer menu or the Layers palette to change the stacking order of layers in an image.

To change the order of a single layer:

1    In the Layers palette, select the layer that you want to move.

2    Choose Layer > Arrange, and choose one of the following options from the submenu:
•      Bring to Front to make the layer the topmost layer.
•      Bring Forward to move the layer one level up in the stacking order.
•      Send Backward to move the layer one level down in the stacking order.
•      Send to Back to make the layer the bottommost layer in the image (except for the background).

 To move a selected layer one level up in the Layers palette, press Command+] (Macintosh) or Ctrl+] (Windows). 
To move one level down, press Command+[ or Ctrl+[. To move to the topmost level, press Command+Shift+] or 
Ctrl+Shift+]. To move to the bottommost level (above the background), press Command+Shift+[ or Ctrl+Shift+[.

To change the order of layers by dragging:

1    In the Layers palette, select the layer that you want to move.

2    Drag the layer up or down in the Layers palette. When the highlighted line appears in the position 
where you want to position the layer, release the mouse button. 

Note: By default, the background cannot be moved and is always at the bottom of the layer list. To 
move the background to a different location, first convert the background into a layer by double-
clicking the background name, typing a new name, and clicking OK. 



Moving and copying layers 

Moving layers

You can move the contents of a layer within its image window. You can also link multiple layers and 
move their contents together. 

To move a layer in an image:

1    In the Layers palette, select the layer that you want to move to make it the active layer.

2    Select the move tool. To activate the move tool when any other tool is selected, hold down 
Command (Macintosh) or Ctrl (Windows).

3    Drag anywhere in the image to move the selected layer into the desired position. To constrain the 
direction of movement to a multiple of 45°, hold down Shift as you drag.

 To move the layer contents in 1-pixel increments when the move tool is selected, press the arrow keys on the 
keyboard. To move the layer in 10-pixel increments (or to move one frame if you’re editing an Adobe Photoshop 
filmstrip file), press Shift and an arrow key.

To move multiple layers:

1    In the Layers palette, select one of the layers you want to move.

2    Click in the column immediately to the left of any additional layers you want to move. The link icon 
appears in the column. 

3    Use the move tool to move the linked layers in the image window.

4    To unlink a layer, click the link icon next to the layer’s name.



Moving and copying layers 

Duplicating layers in a single image

You can duplicate any layer (including the background) in the same image using the Duplicate Layer 
command (which prompts you for the new layer name) or by dragging and dropping the layer onto the 
New Layer button (without any prompt).

To duplicate a layer in an image without naming it:

Drag the layer name in the Layers palette to the New Layer button ( ) at the bottom of the palette.
The new layer is named according to the order in which it was created.



Moving and copying layers 

Copying layers between images

You can copy any layer or the background from one Adobe Photoshop image to another using copy 
and paste, drag and drop, or the Duplicate Layer command. The Duplicate Layer command also lets 
you create a new image with the copied layer.

See also: 

To copy a layer between images 

To copy a layer between images by dragging 

To copy multiple layers into another image 

To copy a layer into another image or a new image 



Copying layers between images 

To copy a layer between images:

1    Open the two images you want to use.

2    In the Layers palette of the source image, select the name of the layer that you want to copy.

3    Choose Select > All to select all of the pixels on the layer that fall inside the canvas boundaries. 
Pixels beyond the visible canvas are not included in the selection.

4    Choose Edit > Copy.

5    Make active the image window into which you want to paste the layer.

6    Choose Edit > Paste to paste the layer as a new layer in the destination image. 

See also: 

To copy a layer between images by dragging 

To copy multiple layers into another image 

To copy a layer into another image or a new image 



Copying layers between images 

To copy a layer between images by dragging:

1    Open the two images you want to use. 

2    In the Layers palette of the source image, select the name of the layer that you want to copy. 

3    Do one of the following:
•      Drag the layer’s name from the Layers palette into the destination image. 
•      Select the move tool and drag the layer from the source image to the destination image. 

A new layer appears in the Layers palette of the image into which you copied the layer. 

If the layer you’re dragging is larger than the image into which you’re copying, only part of the layer is 
visible, although all the layer contents are still available. To see other sections of the layer, use the 
move tool to drag the layer into position. 

 Hold down Shift as you drag a layer to copy it in the same position it occupied in the source image (if the source 
and destination images have the same pixel dimensions) or to the center of the destination image (if the source and 
destination images have different pixel dimensions).

See also: 

To copy a layer between images 

To copy multiple layers into another image 

To copy a layer into another image or a new image 



Copying layers between images 

To copy multiple layers into another image:

1    Make sure that both the source and destination images are open, and select one of the layers you 
want to copy.

2    In the Layers palette, click in the column immediately to the left of any additional layers you want to
move. The link icon appears in the column. 

3    Use the move tool to drag the linked layers from the source image to the destination image.

See also: 

To copy a layer between images 

To copy a layer between images by dragging 

To copy a layer into another image or a new image 



Copying layers between images 

To copy a layer into another image or a new image:

1    If you plan to copy a layer to an existing image, open both the source and destination images.

2    In the source document’s Layers palette, select the name of the layer you want to duplicate.

3    Do one of the following:
•      Choose Layer > Duplicate Layer.
•      Choose Duplicate Layer from the Layers palette menu. 

4    Type a name for the duplicate layer.

5    For Document, choose a destination for the layer. To create a new document for the layer, choose 
New and type a name for the new document. 

6    Click OK.

A new image created with a duplicate layer doesn’t have a background. 

See also: 

To copy a layer between images 

To copy a layer between images by dragging 

To copy multiple layers into another image 



Using Layers 

Converting and adding backgrounds

At times you may want to convert a background to a layer—for example, to change its position in the 
Layers palette or to apply a mode or opacity to it. You can also add a background to an image without 
a background. An image can contain only one background.

To convert a background into a layer:

1    Double-click Background in the Layers palette. 

2    Enter a name, opacity, and mode for the layer. See the section, Specifying layer options for 
information on layer options. 

3    Click OK.

To add a background to an image:

Choose Layer > New > Background.



Using Layers 

Editing layers

You can use the painting and editing tools to draw on a layer, and you can copy and paste selections 
to a layer. 

All editing occurs on the active layer. To keep track of your editing, you should keep the Layers palette 
open and refer to it as you edit.

See also: 

Adding pixels to a layer 

Using blending modes and opacity on a layer 

Preserving a layer’s transparency 



Editing layers 

Adding pixels to a layer

When you add a layer to an image, the new layer has no pixels. Pasting, painting, and editing in a 
layer fills the selected areas with pixels. Once an area on a layer contains pixels, you can paint or edit 
the pixels, apply filters, or use special effects to modify the layer. 



Editing layers 

Using blending modes and opacity on a layer

When you use the painting and editing tools to draw on a layer, keep in mind that the opacity and 
mode settings for these tools interact with the opacity and mode settings for the active layer, and that 
the actions affect the active channel.

For example, suppose you have a layer that uses the Dissolve mode and an opacity of 50%. You paint
on this layer using the paintbrush with a Normal mode and an opacity of 100%. As it is displayed on 
the layer, the paint appears in Dissolve mode with a 50% opacity because this is the maximum the 
layer can display.

On the other hand, if you were working on a layer created using Normal mode and 100% opacity, but 
were using the eraser tool with the paintbrush option set to 50% opacity, only 50% of the paint would 
disappear as you painted. 



Editing layers 

Preserving a layer’s transparency

You can confine editing only to areas of a layer that already contain pixels. For example, if you have 
added type to a transparent layer, you may want to edit the type (for example, by adding special 
effects or changing its color) without adding pixels to the transparent areas of the layer.

To confine editing to the opaque portions of a layer:

1    Select the layer in the Layers palette.

2    Select Preserve Transparency in the Layers palette.

The pencil, paintbrush, airbrush, rubber stamp, paint bucket, and gradient tools affect only the opaque 
areas of a layer that contain pixels.

Note: When you use the type tool to create a new layer, Preserve Transparency is selected by default.



Using Layers 

Deleting layers

Because layers increase a file’s size, it’s important to delete layers that you no longer need. 

To delete a layer:

1    Select the layer in the Layers palette.

2    Do one of the following:
•      Click the Trash button at the bottom of the Layers palette and click Yes.
•      Choose Layer > Delete Layer.
•      Choose Delete Layer from the Layers palette menu. 

 To delete a selected layer automatically without a confirmation dialog box. Option-click (Macintosh) or Alt-click 
(Windows) the Trash button at the bottom of the Layers palette. You can also drag the layer name in the Layers 
palette to the Trash button.



Using Layers 

Specifying layer options

The layer options let you change a layer’s name and opacity.

See also: 

Renaming a layer 

Specifying opacity 

Specifying blending modes 

Filling a new layer with a neutral color 



Specifying layer options 

Renaming a layer

You can rename a layer at any time.

To rename a layer:

1    Do one of the following:
•      Double-click the layer’s name in the Layers palette. 
•      Select the layer in the Layers palette and choose Layer > Rename Layer.
•      Select the layer in the Layers palette and choose Rename Layer from the palette menu.

2    Enter a new name for the layer, and click OK. 



Specifying layer options 

Specifying opacity

You can use the Opacity option in the New Layer dialog box or the Opacity slider in the Layers palette 
to specify the opacity of a layer. A layer with 0% opacity is completely transparent, while a layer with 
100% opacity is completely opaque. Each layer can be created with its own opacity.

 If you have selected a tool that does not have a slider option in its Options palette, you can change the opacity of 
the active layer in multiples of 10% by pressing a number key from 0 to 9 (for example, pressing 1 sets the opacity to 
10%). Pressing 0 sets the opacity to 100%. To specify an exact opacity, type the two-digit number quickly or enter the
desired value using the keyboard.



Specifying layer options 

Specifying blending modes

You use blending modes to determine how the pixels in a layer are blended with underlying pixels on 
other layers. By applying modes to individual layers, you can create a variety of special effects. For 
example, if you create a layer using Darken mode, the pixels in the layer that are darker than the 
underlying pixels are blended into the image. 

The Layers palette modes include the modes that appear in the Options palette when you paint or edit
an image. For a description of these modes, see Selecting a blending mode.



Specifying layer options 

Filling a new layer with a neutral color

Some Adobe Photoshop effects (such as the Lighting Effects filter) cannot be applied to layers that do 
not contain pixels. Selecting Fill with Neutral Color in the New Layer dialog box lets you apply these 
effects to empty layers by first filling the layer with a preset, neutral color. If no effect is applied, filling 
with a neutral color has no effect on the remaining layers. The Fill with Neutral Color option is 
unavailable when you create a layer using the Normal, Dissolve, Hue, Saturation, Color, or Luminosity 
modes.

You fill a layer with a neutral color when you create a new layer. For more information, see Adding 
new layers.

Note: Not all filters produce a visible effect when applied to a layer filled with a neutral color.



Using Layers 

Creating clipping groups

Clipping groups let you define a layer as a mask for one or more layers above that layer. For example,
if you have a shape on one layer, a texture on the overlying layer, and some text on the topmost layer, 
you can define all three layers as a clipping group so that the texture and the text appear only through 
the shape. In a layer group, the bottom layer in the group (called the base layer) affects the mode and 
opacity of all other layers in the group; this blending applies only to the layers within the group. Note 
that only successive layers can be included in a clipping group. 

In the Layers palette, dotted lines separate the layers in a clipping group. The base layer in a clipping 
group is indicated by its underlined name, and the thumbnails for the overlying layers are indented. 

See also: 

To create a clipping group 

To add a layer to a clipping group 

To remove a layer from a clipping group 

To ungroup all layers in a clipping group 



Creating clipping groups 

To create a clipping group:

1    In the Layers palette, select one of the layers that you want.

2    Click in the column immediately to the left of the layers you want to add to the clipping group. Link 
icons appear in the column.

3    Choose Layer > Group Linked to create a clipping group from the linked layers.

See also: 

To add a layer to a clipping group 

To remove a layer from a clipping group 

To ungroup all layers in a clipping group 



Creating clipping groups 

To add a layer to a clipping group:

1    Do one of the following:
•      Hold down Option (Macintosh) or Alt (Windows), position the pointer over the solid line dividing two
layers in the Layers palette (the pointer changes to two overlapping circles), and click.
•      Select a layer in the Layers palette and choose Layer >    Group with Previous.

The layer is grouped with the layer below it and is assigned the opacity and mode attributes of the 
bottommost layer in the group.

2    Repeat step 1 for each layer that you want to add to the clipping group.

See also: 

To create a clipping group 

To remove a layer from a clipping group 

To ungroup all layers in a clipping group 



Creating clipping groups 

To remove a layer from a clipping group:

Do one of the following:
•      Hold down Option (Macintosh) or Alt (Windows), position the pointer over the dotted line 
separating two grouped layers in the Layers palette (the pointer changes to two overlapping circles), 
and click.
•      In the Layers palette, select the topmost layer in the clipping group and choose Layer > Ungroup.

See also: 

To create a clipping group 

To add a layer to a clipping group 

To ungroup all layers in a clipping group 



Creating clipping groups 

To ungroup all layers in a clipping group:

1    In the Layers palette, select any layer in the clipping group.

2    Choose Layer > Ungroup.

See also: 

To create a clipping group 

To add a layer to a clipping group 

To remove a layer from a clipping group 



Using Layers 

Using layer masks

A layer mask lets you control how different areas of a layer are hidden and revealed. By making 
changes to the layer mask, you can apply a variety of special effects to the layer without actually 
affecting the pixels on that layer. You can then apply the mask and make the changes permanent, or 
remove the mask without applying the changes. You can save all layer masks with a layered 
document.

In the Layers palette, a layer mask appears as an additional thumbnail to the right of the layer 
thumbnail. Black indicates the portions of the layer that are hidden and white indicates the portions of 
the layer that are revealed. Gray indicates portions of the layer that are partially visible.

See also: 

Adding a layer mask 

Unlinking layers and layer masks 

Turning off the layer mask 

Viewing the layer mask 

Applying and removing a layer mask 



Using layer masks 

Adding a layer mask

You can add one layer mask per layer. By painting the mask, you can control which areas of the layer 
are hidden or revealed. 

See also: 

To add a mask to a layer 

To edit a layer mask 



Adding a layer mask 

To add a mask to a layer:

1    In the Layers palette, select the layer to which you want to add a mask.

2    If you want to base the boundaries of the mask on a selection, select the desired area in the image.

3    Do one of the following:
•      To create a mask that reveals the entire layer, choose Layer > Add Layer Mask > Reveal All.
•      To create a mask that hides the entire layer, choose Layer > Add Layer Mask > Hide All. 
•      To create a mask that reveals the selected area and hides the remaining portion of the layer, 
choose Layer > Add Layer Mask > Reveal Selection.
•      To create a mask that hides the selected area and reveals the remaining portion of the layer, 
choose Layer > Add Layer Mask > Hide Selection.
•      To create a layer mask that reveals the entire selection or layer, click the New Layer Mask ( ) 
button at the bottom of the Layers palette.
•      To create a mask that hides the entire selection or layer, Option-click (Macintosh) or Alt-click 
(Windows) the New Layer Mask button.

A layer mask thumbnail appears to the right of the layer thumbnail in the Layers palette. The layer 
mask is selected, as indicated by the mask icon that appears to the left of the layer thumbnail. The 
layer mask thumbnail represents the temporary mask.

See also: 

To edit a layer mask 



Adding a layer mask 

To edit a layer mask:

1    Click the layer mask thumbnail in the Layers palette to make it active (the mask icon appears to the
left of the layer thumbnail).

2    Select any of the editing or painting tools.

Because the layer mask is an 8-bit grayscale channel, the foreground and background colors default 
to grayscale values when the mask is active. As you edit, the mask thumbnail displays the changes. 

3    Do one of the following:
•      To hide the layer and add to the mask, paint the mask with black.
•      To reveal the layer and subtract from the mask, paint the mask with white.
•      To make the layer partially visible, paint the mask with gray.

To edit the layer instead of the layer mask, make the layer active by clicking its thumbnail in the Layers
palette. The paintbrush icon appears to the left of the thumbnail to indicate that you are editing the 
layer. Inverting the contents of the layer mask reverses the masking effect.

See also: 

To add a mask to a layer 



Using layer masks 

Unlinking layers and layer masks

By default, a layer is linked to its layer mask—that is, both the layer and layer mask move together in 
the image when you move either one with the move tool. In the Layers palette, a link icon appears 
between the layer and layer mask thumbnails to indicate this linking behavior. 

You can unlink the layer from its layer mask by clicking the link icon. Unlinking a layer from its layer 
mask lets you move the layer and the layer mask independently. You can click between the layer and 
layer mask thumbnails to redisplay the link icon and return to the linking behavior.



Using layer masks 

Turning off the layer mask

As you edit a layer mask, all editing changes appear on the layer. If you want to view the layer without 
the mask, you can temporarily turn off the mask in the document window. 

To turn off the layer mask temporarily:

1    Do one of the following:
•      Press Shift and click the layer mask thumbnail in the Layers palette. 
•      Choose Layer > Disable Layer Mask.

A red X appears over the layer mask thumbnail in the Layers palette, and the entire underlying layer is
visible. 

2    To turn on the mask, do one of the following:
•      Click the layer mask thumbnail in the Layers palette.
•      Choose Layer > Enable Layer Mask.



Using layer masks 

Viewing the layer mask

By default, the layer mask is not visible as you edit the layer mask. However, you can view and edit 
the mask without viewing the layer contents.

To view the layer mask channel:

Do one of the following:
•      Option-click (Macintosh) or Alt-click (Windows) the layer mask thumbnail to view only the mask. 
The eye icons in the Layers palette are dimmed because you are not seeing any of the layers. Click 
an eye icon to redisplay the layers.
•      Hold down Option+Shift (Macintosh) or Alt+Shift (Windows) and click the layer mask thumbnail to 
view the mask on top of the layer in the red masking color. Hold down Option+Shift/Alt+Shift and click 
the layer mask thumbnail again to turn off the color display.



Using layer masks 

Applying and removing a layer mask

When you have finished creating a layer mask, you can either apply the mask and make the changes 
permanent or remove the mask without applying changes. Applying and removing layer masks may 
help reduce file size. 

To remove a layer mask:

1    Click the layer mask thumbnail in the Layers palette.

2    Do one of the following:
•      Click the Trash button at the bottom of the Layers palette.
•      Choose Layer > Remove Layer Mask.

3    Do one of the following:
•      To remove the layer mask and make the changes permanent, click Apply.
•      To remove the layer mask without applying the changes, click Discard.



Using Layers 

Managing layered documents

Adding layers to an image increases the file size. (Transparent areas in a layer, however, do not add 
to the file size.) To conserve disk space, you can merge two or more layers together, or flatten all the 
layers in an image into one layer. 

See also: 

Keeping track of file sizes 

Merging layers 

Flattening all layers 

Saving layered documents 



Managing layered documents 

Keeping track of file sizes

Adobe Photoshop lets you monitor file size as you add, delete, and edit layers.

To track file size:

Check the values in the Document Sizes box at the lower left corner of the image window (Macintosh) 
or the screen (Windows).

The first (left) value indicates the size the file will have when it is flattened. The second (right) value 
shows the estimated file size of the unflattened file, including any layers.

 To track the use of the Adobe Photoshop scratch disk (temporary disk space used for storing data when RAM is 
insufficient), position the pointer over the triangle at the bottom of the image window, hold down the mouse button, 
and choose Scratch Sizes. See Using RAM, scratch disks, and system virtual memory for more information.



Managing layered documents 

Merging layers

Merging layers combines several layers into one and keeps the file size manageable, especially when 
you’re working in large files. When you’ve finalized the characteristics and positioning of the layer 
contents, you can merge a layer with one or more other layers to create partial versions of your 
composite image. You can also merge linked layers into one layer.

If you merge layers into an image with a transparent background, the intersection of all transparent 
areas remains transparent. 

To merge a layer with the layer below it:

1    Make sure that the two layers you want to merge are visible. Select the top layer in the Layers 
palette.

2    Do one of the following:
•      Choose Layer > Merge Down.
•      Choose Merge Down from the Layers palette menu.

To merge all visible linked layers:

1    Make visible all the linked layers you want to merge. 

2    Select one of the visible linked layers.

3    Choose Layer > Merge Linked.

To merge all the visible layers in an image:

1    Hide any layers you do not want to merge. 

2    Do one of the following:
•      Choose Layer > Merge Visible.
•      Choose Merge Visible from the Layers palette menu.



Managing layered documents 

Flattening all layers

A flattened image contains only a background with no layers, and thus has a greatly reduced file size. 
You can save a flattened version of the file when you have finished creating the composite image. In 
most cases, you won’t want to flatten a file until you are absolutely sure that you no longer want to 
change individual layers. 

Note: Converting an image between some modes flattens the file. Be sure to save a copy of your file 
that includes all layers if you want to edit the image after the conversion.

To flatten an image:

1    Make sure that all the layers you want to keep are visible.

In a flattened image, all the visible layers are merged into the background. Hidden layers are 
discarded, and the final image contains only a background. If the background is transparent, the 
transparent areas are filled with white.

2    Do one of the following:
•      Choose Flatten Image from the Layers palette menu.
•      Choose Layer > Flatten Image.



Managing layered documents 

Saving layered documents

If you plan to send files out for proofs, you may want to save two versions of the file—one version with 
all the layers and layer masks intact so that you can easily incorporate editing changes, and another 
version with flattened layers to send to the printer. 

The Save a Copy command in the File menu lets you save a flattened version of your file while 
keeping the original source file intact. The Save a Copy command saves in any of the file formats 
supported by Adobe Photoshop. Unlike Save As, the Save a Copy command allows you to keep 
working in the original file. The copy is saved to your disk but does not replace the active window. For 
more information on saving documents and for a complete description of the file formats, see Saving 
files.



Using Filters

The filters that are built into Adobe Photoshop Limited Edition let you apply special effects to your 
images. For example, you can apply an impressionistic or mosaic effect, add or reduce noise (pixels 
with randomly distributed color values), distort images, and produce many other interesting visual 
effects.

See also: 

About plug-in filters 

Previewing and applying filters 

Tips for creating special effects 

Improving performance with filters 

Choosing a filter effect 

Using the Color Halftone filter 

Using the Custom filter 

Using the Dust & Scratches filter 

Using the Extrude filter 

Using the Displace filter 

Using the Lighting Effects filter 

Using the Trace Contour filter 



Using Filters 

About plug-in filters

Adobe Photoshop supports plug-in filters developed by non-Adobe software developers. For 
information on installing these plug-in modules, see Using plug-in modules. Once installed, plug-in 
filters appear in the Filter menu and work the same as built-in filters. If you are interested in creating 
Adobe Photoshop-compatible plug-in modules, please contact Adobe Systems Developer Support.



Using Filters 

Previewing and applying filters

To use a filter, choose the appropriate submenu command from the Filter menu. The last filter chosen 
appears at the top of the menu.

Note: Filters cannot be applied to Bitmap-mode, indexed-color, 48-bit RGB, or 16-bit grayscale 
images.

Some Photoshop filters let you preview a filter effect on the active layer before applying the filter. 
Because applying a filter—especially to large images—can be time-consuming, use the Preview 
option to save time and prevent unintended results. Several filter dialog boxes also have a built-in 
preview box that shows the filter’s effect on the active layer. 

See also: 

To preview and apply a filter 

Using filter shortcuts 

Loading images and textures 

Defining undistorted areas 

Using texture and glass surface controls 



Previewing and applying filters 

To preview and apply a filter:

1    To apply a filter to an area of a layer, select that area. To apply a filter to the entire layer, leave the 
image unselected. 

2    Choose a filter from the submenus in the Filter menu. If a filter name has ellipses, a dialog box 
appears. 

3    If a dialog box appears, enter values or select options.

4    To preview the effect using the filter’s preview box, use the following navigation methods:
•      Drag in the image window to center a specific area of the image in the preview box. 
•      To see part of the layer that is not visible, move the cursor inside the preview box to activate the 
hand tool. Drag to move the layer preview. 
•      Use the + or – button under the preview box to zoom in or zoom out on the preview. 

A flashing line beneath the preview size indicates that Adobe Photoshop is still rendering the preview. 

5    If the Preview option is available, select the option to preview the filter effect on the image.

6    Click OK to apply the filter. 

When a filter takes a while to be applied, Adobe Photoshop displays a progress bar (Macintosh) or 
progress indicator in the status bar (Windows) so that you can gauge the time remaining until the filter 
is applied.

See also: 

Using filter shortcuts 

Loading images and textures 

Defining undistorted areas 

Using texture and glass surface controls 



Previewing and applying filters 

Using filter shortcuts

These techniques can help save time when working with filters:
•      To cancel a filter as it is being applied, press Command-period (Macintosh) or Esc (Windows). 
•      To undo a filter, press Command+Z (Macintosh) or Ctrl+Z (Windows). 
•      To reapply the most recently used filter with its last values, press Command+F (Macintosh) or 
Ctrl+F (Windows).
•      To display the dialog box for the last filter you applied, press Command+Option+F (Macintosh) or 
Ctrl+Alt+F (Windows).
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Loading images and textures

Some filters let you load other images, such as textures and displacement maps, to use with a filter. 
These filters include the Conté Crayon, Displace, Glass, Lighting Effects, Rough Pastels, Texture Fill, 
Texturizer, Underpainting, and Custom filter dialog boxes. Not all these filters load images or textures 
in the same way; see Using the Displace filter and Using the Lighting Effects filter.

To load images and textures:

1    Choose the filter you want from the appropriate filter submenu.

2    For Texture, choose Load Texture, and locate and open a texture image. The texture must be in the
Photoshop format. If you choose a color file, most filters will use only its grayscale information.

3    Click OK in the filter dialog box to apply the settings.
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Defining undistorted areas

The Displace, Shear, and Wave filters in the Distort submenu, and the Offset filter in the Other 
submenu let you choose the following ways to treat areas undefined by the filter:
•      Wrap Around copies the image to fill the undefined space so that the area is filled with content 
from the opposite side of the image.
•      Repeat Edge Pixels extends the colors of the pixels along the edge of the image in the direction 
specified. Banding may result if the edge pixels are different colors.
•      Set to Background fills the selected area with the current background color (available for the Offset
filter only).
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Using texture and glass surface controls

Five filters included in Adobe Photoshop have texturizing options—the Conté Crayon, Glass, Rough 
Pastels, Texturizer, and Underpainting filters. The texturizing options can make an image appear as 
though painted onto various textures, such as canvas and brick, or viewed through glass blocks. 

To use texture and glass surface controls:

1    From the Filter menu, choose Artistic > Rough Pastels, Artistic > Underpainting, Distort >Glass, 
Sketch > Conté Crayon, or Texture > Texturizer.

2    For Texture, choose a texture type or choose Load Texture to specify a Photoshop file.

3    Drag the Scaling slider to enlarge or reduce the effect on the image surface. 

4    Drag the Relief slider (if available) to adjust the depth of the texture’s surface.

5    Select Invert to reverse the surface’s light and dark colors.

6    For Light Direction, indicate the direction of the light source on the image.

7    Click OK.
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Tips for creating special effects

Try the following techniques to create special effects with filters.

See also: 

Create edge effects 

Apply filters to layers 

Create backgrounds 

Combine multiple effects with duplicate images 

Improve image consistency 



Tips for creating special effects 

Create edge effects

When you apply an effect to only a selected part of an image, you can use various techniques to blend
the effect into the original image. 

For a distinct edge, apply the filter effect as is, to contrast it with the rest of the image. For a soft edge,
feather the edge and then apply a filter. 



Tips for creating special effects 

Apply filters to layers

Another way to vary filter effects is by applying them to individual layers or to several layers in 
succession to build up an effect. For a filter to affect a layer, the layer must be visible and it must 
contain pixels with color values.



Tips for creating special effects 

Create backgrounds

By applying effects to solid-color or grayscale shapes, you can generate a variety of backgrounds and 
textures. You can also apply a texture, and then blur it. Try these filters to create background texture: 
Add Noise, Chalk & Charcoal, Clouds, Conté Crayon, Craquelure, Difference Clouds, Glass, Grain, 
Graphic Pen, Halftone Pattern, Mezzotint, Mosaic, Note Paper, Patchwork, Pointillize, Reticulation, 
Rough Pastels, Sponge, Stained Glass, Texture Fill, Texturizer, and Underpainting. Note that some 
filters, such as Glass, have little or no visible effect when applied to a solid color.



Tips for creating special effects 

Combine multiple effects with duplicate images

Use two duplicate images to apply various effects to selected areas in each image, and then 
recombine the two images. For example, apply a different effect to each of two copies of an image, 
and then use the Clone option of the rubber stamp tool to paint one copy onto the other copy.



Tips for creating special effects 

Improve image consistency

If you’re working with a series of photos of varying or poor quality, you can achieve a unified look in 
the final piece by applying the same effect to each image to disguise the faults of the original or to 
alter or enhance the mode of the image. 
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Improving performance with filters

Some filter effects can be memory intensive, especially when applied to a high-resolution image. You 
use these techniques to improve performance when applying filters:
•      Try out a filter on a small portion of an image.
•      Change the settings. Some filters are extremely memory intensive, such as the Lighting Effects, 
Cutout, Stained Glass, Chrome, Ripple, Spatter, Sprayed Strokes, and Glass filters. Try different 
settings to increase the speed of the filter. (For example, with the Stained Glass filter, increase the cell 
size; with the Cutout filter, increase the Edge Simplicity or decrease the Edge Fidelity, or both.)
•      If you plan to print to a grayscale printer, convert a copy of the image to grayscale before applying 
filters. Note, however, that in some cases applying a filter to a color image and then converting it to 
grayscale may not have the same effect as applying the same filter to a grayscale version of the 
image.
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Choosing a filter effect

The Adobe Photoshop filters fall into 13 general categories. In addition, third-party filters appear at the 
bottom of the Filter menu. 

See also: 

Artistic filters 

Blur filters 

Brush Strokes filters 

Distort filters 

Noise filters 

Pixelate filters 

Render filters 

Sharpen filters 

Sketch filters 

Stylize filters 

Texture filters 

Video filters 

Other filters 

Digimarc filter 



Choosing a filter effect 

Artistic filters

Give an image the appearance of different media for a more organic (and less computer-generated) 
look. For specific information on the Rough Pastels and Underpainting filters, see Using texture and 
glass surface controls.



Choosing a filter effect 

Blur filters

Soften a selection or an image and are useful for retouching images. Blur filters smooth transitions by 
averaging the pixels next to the hard edges of defined lines and shaded areas where significant color 
transitions occur in an image. 



Choosing a filter effect 

Brush Strokes filters

Give an image a painterly or fine-arts look using different brush and ink stroke effects. Some of the 
filters add grain, paint, noise, edge detail, or texture to an image for a pointillist effect. 



Choosing a filter effect 

Distort filters

Geometrically distort an image and can be used to create 3-D or other plastic effects. For more 
information on the Displace filter, see Using the Displace filter. For specific information on individual 
filters, see Using texture and glass surface controls and Defining undistorted areas.



Choosing a filter effect 

Noise filters

Add or remove noise from an image and help make a selection into the surrounding pixels. Noise in an
image is pixels with randomly distributed color levels. You can use the Noise filters to remove problem 
areas from an image, such as dust and scratches, and to create unusual textures, such as those used 
as backgrounds behind title text. The Add Noise filter can also be useful in reducing banding in 
feathered selections and graduated fills and in giving a more realistic look to heavily retouched areas. 
For specific information on the Dust & Scratches filter, see Using the Dust & Scratches filter.



Choosing a filter effect 

Pixelate filters

Sharply define a selection by clumping pixels of similar color values in cells. For specific information 
on Color Halftone filter, see Using the Color Halftone filter.



Choosing a filter effect 

Render filters

Create blending cloud patterns by varying the foreground and background color (the Clouds and 
Difference Clouds filters), create refraction patterns simulating light reflections in the image (the Lens 
Flare filter), and create fills from a grayscale file or part of a file (the Texture Fill filter). You can also 
create 3-D-like lighting effects; see Using the Lighting Effects filter.

 When using the Clouds filter, generate a more stark cloud pattern by holding down Option (Macintosh) or Alt 
(Windows) as you choose Filter > Render > Clouds. 



Choosing a filter effect 

Sharpen filters

Focus blurry images by increasing the contrast of adjacent pixels. These include the Sharpen and 
Sharpen More filters, and the Sharpen Edges and Unsharp Mask filters—both of which find the areas 
in the image where significant color changes occur (such as at the edges) and sharpen them. The 
Unsharp Mask filter is commonly used for high-end color correction; for more information, see Step 5: 
Sharpen the image.
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Sketch filters

Add fine-arts and hand-drawn effects to an image. For specific information on the Conté Crayon filter, 
see Using texture and glass surface controls.

 When using the Conté Crayon filter, for a truer effect, change the foreground color to one of the common Conté 
Crayon colors (black, sepia, sanguine) before applying the filter. 
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Stylize filters 

Produce bold, exaggerated effects by displacing pixels and by finding and heightening contrast in an 
image. 



Choosing a filter effect 

Texture filters

Add texture to an image. For specific information about the Texturizer filter controls, see Using texture 
and glass surface controls.
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Video filters

Include the National Television Standards Committee Colors and De-Interlace filters. The NTSC 
Colors filter restricts the gamut of colors to those acceptable for television reproduction, to prevent 
oversaturated colors from bleeding across television scan lines. The De-Interlace filter smooths 
moving images captured on video by removing either the odd or even interlaced lines in a video 
image; the filter gives you the option of replacing the discarded lines by duplication or interpolation. 



Choosing a filter effect 

Other filters

Let you create your own filters using the Custom filter, use filters to modify masks (the Minimum and 
Maximum filters), offset a selection within an image (Offset filter), and make quick color adjustments 
(the High Pass filter, which emphasizes very bright areas and highlights and removes shading in a 
selection). 

For more information about defining empty areas left by the Offset filter, see Defining undistorted 
areas. For more information about the Custom filter, see Using the Custom filter.



Choosing a filter effect 

Digimarc filter

Lets you read copyright and authorship information for an image that has been embedded with a 
digital watermark using the Digimarc PictureMarc technology. For more information, see Viewing 
copyright and authorship information.
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Using the Color Halftone filter

The Pixelate > Color Halftone filter simulates the effect of using an enlarged halftone screen on each 
channel of the image. For each channel, the filter divides the image into rectangles and replaces each 
rectangle with a circle. The circle size is proportional to the brightness of the rectangle. To use the 
Color Halftone filter, you specify a screen-angle value for each channel of the image.

To use the Color Halftone filter:

1    Choose Filter > Pixelate > Color Halftone.

2    Enter a value in pixels for the maximum radius of a halftone dot, from 4 to 127.

3    Enter a screen-angle value (the angle of the dot from the true horizontal) for each channel, as 
follows:
•      Grayscale images use only channel 1. 
•      In RGB images, channels 1, 2, and 3 correspond to the red, green, and blue channels. 
•      In CMYK images, the four channels correspond to the cyan, magenta, yellow, and black channels, 
respectively. 
•      Click Defaults to return all the screen angles to their default values. 

4    Click OK.
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Using the Custom filter 

The Other > Custom filter lets you change the brightness values of each pixel in the image according 
to a predefined mathematical operation known as convolution. Each pixel is reassigned a value based 
on the values of surrounding pixels. This operation is similar to the Add and Subtract calculations for 
channels. 

You can save the custom filters you create and use them with other Adobe Photoshop images. 

To create a Custom filter: 

1    Choose Filter > Other > Custom. 

2    Select the center text box, which represents the pixel being evaluated. Enter the value by which 
you want to multiply that pixel’s brightness value, from –999 to +999.

3    Select a text box representing an adjacent pixel to which to assign a weighted value. Enter the 
value by which you want the pixel in that position multiplied. 

For example, to multiply the brightness value of the pixel to the immediate right of the current pixel by 
2, enter 2 in the text box to the immediate right of the center text box. 

4    Repeat steps 2 and 3 for all pixels to include in the operation. You don’t have to enter values in all 
the text boxes.

5    For Scale, enter the value by which to divide the sum of the brightness values of the pixels 
included in the calculation. 

6    For Offset, enter the value to be added to the result of the scale calculation. 

7    Click OK. The custom filter is applied to each pixel in the image, one at a time. 

Use the Save and Load buttons to save and reuse custom filters. 
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Using the Dust & Scratches filter

The Noise > Dust & Scratches filter reduces noise by changing dissimilar pixels. You specify how 
different pixel values should be before they are eliminated, and a radius for how far the filter should 
search for them. Finding the desired trade-off between sharpness and hiding defects may require 
trying different combinations of radius and threshold settings. If you can’t make the image sharp 
enough, try selecting specific areas on which to use the filter.

To use the Dust & Scratches filter:

1    Choose Filter > Noise > Dust & Scratches.

2    If necessary, adjust the preview zoom ratio until the area containing the noise is visible. 

3    Drag the Threshold slider to the left to 0 levels to turn off the value so that you can examine all 
pixels in the selection or the image. 

The Threshold option determines the degree of difference among pixels that will be affected by the 
filter.

Note: The Threshold slider gives greater control for values between 0 and 128—the most common 
range for images—than for values between 128 and 255.

4    Drag the Radius slider left or right, or enter a value in the text box from 1 to 16 pixels to set how far
to search for differences among pixels, until the defects disappear from the image. 

Adjusting the radius makes the image blurry; stop when the value is the smallest that eliminates the 
defects.

5    Increase the threshold gradually by entering an exact number or by dragging the Threshold slider 
until it is as high as possible without displaying the defects.

6    Click OK.
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Using the Extrude filter

The Stylize > Extrude filter gives a three-dimensional texture to a selection or layer. You choose a type
of three-dimensional object on which the filter is based.

To use the Extrude filter:

1    Choose Filter > Stylize > Extrude. 

2    Choose from the following types of three-dimensional objects:
•      Blocks creates objects with a square front face and four side faces. To fill the front face of each 
block with the average color of the block, select the Solid Front Faces option. To fill the front face with 
the image, keep the Solid Front Faces option deselected. 
•      Pyramids creates objects with four triangular sides that meet at a point.

3    Enter a value in the Size box to determine the length of any side of the object’s base, from 2 to 
255.

4    Enter a value in the Depth box to indicate how far the tallest object appears to protrude from the 
screen, from 1 to 255.

5    Choose a depth option: Random to give each block or pyramid an arbitrary depth, or Level-based 
to make each object’s depth correspond to the overall brightness of the object; brighter objects appear
to protrude more than dark objects.

6    Select Mask Incomplete Blocks to hide any object that extends beyond the selection.

7    Click OK.
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Using the Displace filter

The Distort > Displace filter uses a second image (called a displacement map) to determine how to 
distort the selection. For example, using a parabola-shaped displacement map, you can create an 
image that appears as though it were printed on a cloth held at its corners. You can use any file in the 
Adobe Photoshop format, except one in Bitmap mode, for a displacement map. The Adobe Photoshop
software also includes several maps useful for experimenting (search for the Displacement Maps 
folder on the Macintosh or the Dispmaps folder in Windows). 

The Displace filter shifts a selection using a color value from the displacement map: 0 is the maximum 
negative shift, 255 is the maximum positive shift, and a gray value of 128 produces no displacement. 
(You can use the Curves dialog box to modify a gradient to get a particular effect.) If a map has one 
channel, the image shifts along a diagonal defined by the horizontal and vertical scale ratios. If the 
map has more than one channel, the first channel controls the horizontal displacement, and the 
second channel controls the vertical displacement. 

See also: 

To use the Displace filter 

To make a parabola-shaped displacement map and create an arching image effect 



Using the Displace filter 

To use the Displace filter:

1    Choose Filter > Distort > Displace.

2    Enter the scale for the magnitude of the displacement.

When the horizontal and vertical scale are set to 100%, the greatest displacement is 128 pixels 
(because middle gray produces no displacement).

3    If the displacement map is not the same size as the selection, choose how the map will fit the 
image: Stretch to Fit to resize the map, or Tile to fill the selection by repeating the map in a pattern.

4    Choose from the following options to determine how to treat areas of the image undefined by the 
distortion:
•      Wrap Around copies the image to fill the undefined space so that the area is filled with content 
from the opposite side of the image.
•      Repeat Edge Pixels extends the colors of the pixels along the edge of the image in the direction 
specified. Banding can result if the edge pixels are different colors.

5    Click OK.

6    Select and open the displacement map. The distortion is applied to the image.

See also: 

To make a parabola-shaped displacement map and create an arching image effect 



Using the Displace filter 

To make a parabola-shaped displacement map and create an arching image 
effect:

1    Start with a new grayscale image. (For best performance, use small images.) 

2    Set the foreground color to black and the background color to white.

3    Double-click the gradient tool and choose Foreground to Background for Gradient in the Gradient 
Tool Options palette. Then drag the gradient tool from left to right in the image window to make a 
linear gradient fill. 

4    Using the Curves dialog box, draw a parabola that dips down from the upper left corner of the 
dialog box and back to the upper right corner. Then click OK.

5    Save the image to disk in the Photoshop format; this is the shape of the displacement map.

6    To apply the displacement map, open the image you want to displace, and choose Filter > Distort >
Displace. 

7    Set the horizontal scale to 0% and the vertical scale to 50%. Select the Stretch to Fit option. 

8    Select the displacement map that you saved in step 5. 

9    Click Open.

See also: 

To use the Displace filter 
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Using the Lighting Effects filter

The Render > Lighting Effects filter lets you apply up to 17 different light styles to an RGB image. You 
can choose from three different types of lights and from four sets of properties for each image. You 
can also save your own styles for use in other images.

By varying the number of lights, the light types, and the light properties, you can produce myriad 
lighting effects. You can also use textures from grayscale files (called bump maps) to produce 3-D-like 
lighting effects.

Note: The Lighting Effects filter works only on RGB images.

See also: 

To use the Lighting Effects filter 

To delete a light 

Choosing a Lighting Effects type 

Choosing a Lighting Effects style 

Using a Lighting Effects texture 



Using the Lighting Effects filter 

To use the Lighting Effects filter:

1    Choose Filter > Render > Lighting Effects. 

2    For Style, choose a style. Press Tab to cycle through the lights in a style. For more information, see
Choosing a Lighting Effects style.

3    For Light Type, choose a type. For more information, see Choosing a Lighting Effects type. If 
you’re using multiple lights, select and deselect On to turn individual lights on and off. 

4    To change the color of the light, click the color swatch in the Light Type section of the dialog box. 

The color picker chosen in the General Preferences dialog box opens. For more information, see 
Using the Adobe Photoshop Color Picker, Using the Apple Color Picker, or Using the Windows Color 
Picker.

5    To set light properties, drag the corresponding slider for the following options:
•      Gloss determines how much the surface reflects light (as on the surface of a piece of photographic
paper) from Matte (little reflectance) to Glossy (high reflectance). 
•      Material determines whether the light or the object on which the light is cast reflects more light: 
choose Plastic to reflect the light’s color or choose Metallic to reflect the object’s color.
•      Exposure increases the light (positive values) or darkens the light (negative values). A value of 0 
has no effect.
•      Ambience diffuses the light as if it were combined with other light in a room, such as sunlight or 
fluorescent light. Choose a value of 100 to use only the light source; a value of –100 removes the light 
source. To change the color of the ambient light, click the color swatch and use the Color Picker that 
appears.

    To duplicate a light, Option-drag (Macintosh) or Alt-drag (Windows) the light within the preview box.

6    To use a texture fill, choose a channel for Texture Channel. See Using a Lighting Effects texture.

7    Click OK to apply the filter.

See also: 

To delete a light 

Choosing a Lighting Effects type 

Choosing a Lighting Effects style 

Using a Lighting Effects texture 



Using the Lighting Effects filter 

To delete a light:

In the Lighting Effects dialog box, drag the light by its center circle to the Trash icon at the bottom right
of the preview box.

See also: 

To use the Lighting Effects filter 

Choosing a Lighting Effects type 

Choosing a Lighting Effects style 

Using a Lighting Effects texture 



Using the Lighting Effects filter 

Choosing a Lighting Effects type

You can choose from three light types.
•      Omni shines in all directions from directly above the image, as if a light bulb were over a piece of 
paper. 
•      Directional shines light from far away, like the sun, so that the light angle does not change. 
•      Spotlight casts an elliptical beam of light. The line in the preview box defines the light direction and
angle, and four boxes define the edges of the ellipse. 

See also: 

To adjust an Omni light 

To adjust the angle and height of the directional light using the preview box 

To adjust the angle and height of the spotlight using the preview box 



Choosing a Lighting Effects type 

To adjust an Omni light:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Omni.

3    Choose from the following:
•      To move the light, drag the center circle. 
•      To increase or decrease the size of the light (as if the light were moving closer to or farther away 
from the paper), drag one of the four boxes, which define the edges of the effect.

4    Click OK to apply the filter.

See also: 

To adjust the angle and height of the directional light using the preview box 

To adjust the angle and height of the spotlight using the preview box 



Choosing a Lighting Effects type 

To adjust the angle and height of the directional light using the preview box:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Directional.

3    Choose from the following:
•      To move the light, drag the center circle. 
•      To change the direction of the light, drag the black square at the end of the line to rotate the light’s 
angle. Command-drag (Macintosh) or Ctrl-drag (Windows) to keep the light’s height (line length) 
constant.
•      To change the light’s height, drag the square at the end of the line that represents the height of the
light: Shorten the line to create a very bright light; if the line gets too short, it produces pure white light.
Lengthen the line for a less intense light; a very long line produces no light. Shift-drag to keep the 
angle constant and change the light’s height (line length).

4    Click OK to apply the filter.

See also: 

To adjust an Omni light 

To adjust the angle and height of the spotlight using the preview box 
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To adjust the angle and height of the spotlight using the preview box:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Spotlight.

3    Choose from the following:
•      To move the light, drag the center circle. 
•      To increase or decrease the light angle, drag the black square at the end of the line to shorten or 
lengthen the line, respectively
•      To stretch the ellipse or rotate the light, drag one of the four boxes. Shift-drag to keep the angle 
constant and change only the size of the ellipse. Command-drag (Macintosh) or Ctrl-drag (Windows) 
to keep the size constant and change the angle or direction of the spotlight.
•      To set the light focus (or spotlight intensity), and control how much of an ellipse is filled with light, 
drag the Intensity slider: Full intensity (a value of 100) is brightest; Normal intensity is about 50; a 
negative intensity takes away light; –100 intensity produces no light. Use the Focus slider to control 
how much of the ellipse is filled with light.

4    Click OK to apply the filter.

See also: 

To adjust an Omni light 

To adjust the angle and height of the directional light using the preview box 
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Choosing a Lighting Effects style

Use the Style menu in the Lighting Effects dialog box to choose from 17 light styles. You can also 
create your own lighting style by adding lights to the Default setting. The Lighting Effects filter requires 
at least one light source. Only one light can be active for editing at a time, but all of the lights will be 
used to create the effect.

Note: The names of these styles are abbreviated in Windows.

Default

One yellow spotlight with a medium intensity and a wide focus. 

2 o’clock Spotlight

One yellow spotlight with medium (17) intensity and wide (91) focus.

Blue Omni

One blue overhead omni light with full (85) intensity and no focus.

Circle of Light

A spotlight made up of red, blue, yellow, and white lights with full (100) intensity and a concentrated (8)
focus.

Crossing

A white spotlight with medium (35) intensity and a concentrated (8) focus.

Crossing Down

Two white spotlights with medium (35) intensity and wide (100) focus.

5 Lights Down/5 Lights Up

Five white spotlights down or up, respectively, with full (100) intensity and wide (60) focus.

Flashlight

An omni yellow light with medium (46) intensity.

Flood Light

A white spotlight with medium (35) intensity and wide (69) focus.

Parallel Directional

A directional blue light with full (98) intensity and no focus.

RGB Lights

A red, blue, and green light that produces a white spotlight of medium (60) intensity and wide (96) 
focus.

Soft Direct Lights

Two unfocused whitish and blue directional lights of soft (20) intensity.

Soft Omni

A soft omni light of medium (50) intensity.

Soft Spotlight

A white spotlight with full (98) intensity and white (100) focus.



Three Down

Three white spotlights with soft (35) intensity and wide (96) focus.

Triple Spotlight

Three spotlights with slight (35) intensity and wide (100) focus.

To add a light: 

In the Lighting Effects dialog box, drag the light icon at the bottom of the dialog box into the preview 
area. Repeat as desired for a maximum of 16 lights. 

To create a new style:

1    In the Lighting Effects dialog box, choose Default for Style. 

2    Drag the light icon at the bottom of the dialog box into the preview area. Repeat as desired for a 
maximum of 16 lights. 

To save a style:

1    In the Lighting Effects dialog box, click Save. 

2    Name the style, and click OK.

Saved styles include all the settings for each light and appear in the Style menu whenever you open 
the image. 

To delete a style:

1    In the Lighting Effects dialog box, choose a style for Style. 

2    Click Delete.
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Using a Lighting Effects texture

The Texture Channel in the Lighting Effects dialog box lets you use a grayscale texture such as paper 
or water to control how light reflects off an image. You can use a layer from any image as a texture, or 
create your own texture, such as 3-D bumps that bounce light from their surface; the texture channel 
sets the height of the bumps. For an embossed text effect, use a layer with white text on a black 
background, or vice versa.

To use the Texture Channel in the Lighting Effects dialog box:

1    If necessary, create a layer in your image and add texture to it. To use a texture from another 
image, copy and paste the image as a new layer. 

2    In the Lighting Effects dialog box, choose a channel from the Texture Channel menu. Choose the 
image’s Red, Green, or Blue channel, or any layer added to the image.

3    Select White is High to raise the white parts of the texture channel from the surface. Turn off this 
option to raise the dark parts of the texture channel from the surface.

4    Drag the Height slider to vary the texture from Flat (0) to Mountainous (100). 

5    Click OK.



Using Filters 

Using the Trace Contour filter

The Stylize > Trace Contour filter finds the transitions of major brightness areas and thinly outlines 
them, similar to the Find Edges filter. 

To use the Trace Contour filter:

1    Choose Filter > Stylize > Trace Contour.

2    Choose an Edge option to outline areas in the selection: Lower outlines where the color values of 
pixels fall below the specified level; Upper outlines where the color values of pixels are above the 
specified level. 

3    Enter a threshold (Level) for evaluating color values (its tonal level), from 0 to 255. You can 
experiment to see what values bring out the best detail in the image. 

4    Use the Info palette in Grayscale mode to identify a color value that you want traced; then enter the
value in the Level text box. For more information, see Customizing the Info palette.

5    Click OK.



Saving and Exporting Images

Adobe Photoshop Limited Edition supports a variety of file formats to suit a wide range of output 
needs. You can save or export your image to any of these formats. 

File format and export choices appear either in the Save As or Save a Copy dialog box or in the Export
menu. If a file format does not appear, install the format’s plug-in module following the instructions in 
Using plug-in modules.

See also: 

Saving files 

Exporting images 

About file formats 

Placing Photoshop images in other applications 



Saving and Exporting Images 

Saving files

Adobe Photoshop provides several ways for you to save files:
•      The Save command saves the file in its current file format.
•      The Save As command lets you save an alternate version of the file in a different format or 
location.
•      The Save a Copy command lets you save an identical or flattened copy of the file. This command 
leaves the original file intact.

Note: Some formats are available only for certain color modes. In addition, many formats are available
only if an image has no additional layers. 

To save a file in its current format:

Choose File > Save. 

To save a file in a different file format:

1    Choose File > Save As.

2    For Format (Macintosh) or Save As (Windows), choose a format. Unavailable formats are dimmed 
(Macintosh) or not visible (Windows).

3    Type a filename, and choose a location for the file.

4    Click Save.

With some image formats, a dialog box appears. For information on the options available forspecific 
file formats, see About file formats.

To save a duplicate of a file:

1    Choose File > Save a Copy.

2    For Format (Macintosh) or Save As (Windows), choose a format.

3    To flatten all visible layers, select Flatten Image. See Flattening all layers for more information.

4    Click Save. 

Note: To copy an image without saving it to your hard disk, use the Duplicate command. See 
Duplicating images.

See also: 

Using image previews on the Macintosh 

Using image previews in Windows 

Using file extensions (Macintosh only) 

Saving Adobe Photoshop files 

Saving Adobe Photoshop 2.0 files (Macintosh only) 

Saving Adobe Photoshop files as Adobe Photoshop 2.5 files 

Saving files in Photoshop EPS format 

Saving files in JPEG format 



Saving files 

Using image previews on the Macintosh

On the Macintosh, you can choose to save your files with the following types of image previews:
•      File icons are the preview icons you see on the desktop.
•      Thumbnails are the image previews that appear in the Open dialog box.
•      Full size previews are images intended for use in applications that open Adobe Photoshop images 
but require 72 ppi images. For non-EPS files, this is a PICT preview. 

The Full Size preview option is off by default. Turning off the other preview options can make saving 
faster and requires less file storage space on your disk.

To set options for image previews:

1     Choose File > Preferences > Saving Files.

2    For Image Previews, choose one of the following options:
•      Never Save to save files without previews.
•      Always Save to save files with the specified preview or previews.
•      Ask When Saving to assign previews on a file-by-file basis when you save. 

3    If you chose Always Save, select the preview or previews you want to use.

4    Click OK.



Saving files 

Using image previews in Windows

In Windows, you can choose to save images with a thumbnail preview that appears in the Open dialog
box. In Windows NT 4.0 and Windows 95, you can also generate preview icons for files that have 
been saved.

To set options for thumbnail previews:

1    Choose File > Preferences > Saving Files.

2    For Image Previews, choose one of the following options:
•      Never Save to save files without previews.
•      Always Save to save files with the specified preview or previews.
•      Ask When Saving to assign previews on a file-by-file basis when you save. 

3    Click OK.

To generate a preview icon for a file (Windows NT 4.0 and Windows 95 only):

1    Save the file.

2    Choose File > Save As.

3    Position the pointer on the filename in the file list, click the right mouse button, and choose 
Properties from the context menu that appears.

4    Click the Photoshop Image tab.

5    For Icon Thumbnails, select the desired preview icon. To have the file appear without a preview 
icon, select Don’t Generate.

6    Click OK.



Saving files 

Using file extensions (Macintosh only)

On the Macintosh, you can have Adobe Photoshop append the file extension to the name of a file 
when you save it. This three-character file extension refers to the file’s format (for example, the 
extension for a JPEG file is.jpg). Saving files with extensions is useful when you want to use the files 
on a system running Windows. 

To append file extensions to filenames:

1    Choose File > Preferences > Saving Files.

2    For Append File Extension, choose one of the following options:
•      Never to save files without file extensions.
•      Always to append file extensions to filenames.
•      Ask When Saving to append file extensions on a file-by-file basis when you save. 

3    Click OK.

To append the file extension to the current filename:

1    Choose File > Save As or File > Save a Copy.

2    Hold down Option, and choose a file format from the list.

3    Save the file.



Saving files 

Saving Adobe Photoshop files

Adobe Photoshop is the default file format for newly created images. This encoded format is the only 
format that supports all available Adobe Photoshop LE image modes (Bitmap, Grayscale, Indexed 
color, and RGB) and layers.

If you’re exporting Photoshop files to a page-layout program that doesn’t support the Adobe 
Photoshop format, use the Save a Copy command to save a duplicate file in a format supported by the
page-layout program. 



Saving files 

Saving Adobe Photoshop 2.0 files (Macintosh only)

Choose the Photoshop 2.0 format when you need to open a Photoshop file in version 2.0 of Adobe 
Photoshop, or when you are exporting to an application that supports only Photoshop 2.0 files. Saving 
in Photoshop 2.0 format flattens your file and discards layer information.



Saving files 

Saving Adobe Photoshop files as Adobe Photoshop 2.5 files

If you’re planning to use a file created in Adobe Photoshop LE in an application that supports only 
Photoshop 2.5 files, you can still save the file in Photoshop format. By default, the Photoshop format 
saves a copy of the flattened data that can be used by programs that read Photoshop 2.5 files. 

Saving a Photoshop file with Photoshop 2.5 compatibility turned on does increase the file size. If you 
plan to work only in Adobe Photoshop LE, you can turn off Photoshop 2.5 compatibility to minimize the
file size of saved files.

To turn off Photoshop 2.5 compatibility:

1    Choose File > Preferences > Saving Files.

2    Deselect 2.5 Format Compatibility, and click OK. 



Saving files 

Saving files in Photoshop EPS format

When you save a file in Encapsulated PostScript (EPS) format, you can choose from a variety of 
options, as described in the following sections. 

Preview

You can save a TIFF preview of a Photoshop EPS file. On the Macintosh, you can also save a PICT 
preview. These preview images give you an idea of how the image will look when it is printed and help
you accurately place the image on the page. On the Macintosh, choose a TIFF option to save a 
preview for use with an IBM(R) PC-compatible application.

Encoding

When saving images in Photoshop EPS format and when printing to PostScript output devices, you 
can choose from several types of encoding options: ASCII encoding is the most generic, but creates 
the largest output files. If you’re working in Windows, use ASCII encoding. Binary encoding makes a 
smaller output file (speeding the transfer of the file to your output device) without modifying the original
data.

Some page-layout applications may not support binary Photoshop EPS files. For these applications, 
you should select the ASCII encoding option. Some commercial print spooling and network printing 
software does not support binary encoding. If you experience printing errors, it may be that your print 
spooler requires ASCII encoding.

Halftone Screen

You can choose to include the EPS file halftone screen information (including the frequency and angle
of the screen) when you save the file. If you include the halftone screen information and place the file 
into another application, such as Adobe Separator(TM), the PostScript language interpreter uses 
these screen settings when the color separations are generated. 



Saving files 

Saving files in JPEG format

When saving in JPEG format, you can specify an image quality and compression level for the file. To 
specify image quality, enter a value between 0 and 10 or choose an option for Quality; to specify the 
amount of compression, drag the slider. A trade-off exists between the image quality and the amount 
of compression; an image compressed using Maximum quality is less compressed (and thus takes up 
more disk space) than an image compressed using the Low quality option. 

In addition, you can select a format option for the JPEG file. To optimize the color quality of the image, 
select Baseline Optimized. To save the file as a progressive JPEG, select Progressive. This option 
displays the image gradually as it is downloaded from a Web browser, using a series of scans to show
increasingly detailed versions of the entire image until all of the data has finished downloading. 
However, progressive JPEG images require more RAM for viewing and are not supported by all Web 
browsers. When you select Progressive, you can also specify the number of progressive scans. 

Note: If you are using a JPEG file with a Java application and find that the application cannot read 
your file, try saving the file without a thumbnail preview. See Using image previews on the Macintosh 
and Using image previews in Windows for more information.



Saving and Exporting Images 

Exporting images 

The GIF89a Export module lets you convert RGB images to indexed-color GIF files and specify the 
number of colors you want the file to have. In addition, the command lets you designate transparent 
areas in your GIF images for use in hypertext markup language (HTML) documents used on the World
Wide Web. Adobe Photoshop LE can open and save CompuServe GIF files that are either 8-bit 
indexed color or grayscale.

See also: 

Exporting RGB images to GIF 

Exporting indexed-color images to GIF 



Exporting images 

Exporting RGB images to GIF

When you export an RGB image to GIF, you can use layers in Adobe Photoshop to define what parts 
of the image you want to appear transparent. The GIF89a export feature then lets you convert the 
image to indexed color, choose a transparency color for the Web browser, and save the image as a 
GIF file.

To export an RGB image to GIF:

1    If you want to include only part of the RGB image in your HTML document, select that part of the 
image and feather it if desired. Copy the selection onto a new, transparent layer. Be sure to hide any 
layers that you do not want to include in the GIF file. For more information, see Using Layers.

2    Choose File > Export > GIF89a Export.

3    To display transparent areas of the image as a solid color, do one of the following:
•      To make transparent areas the same color as the Web browser window background, leave the 
Transparency Index Color box at the default color. The default color is Netscape(TM) gray, which is 
192 R, 192 G, and 192 B.
•      To change the color used for displaying transparent areas, click the Transparency Index Color box,
and choose a new color, see Using the Adobe Photoshop Color Picker. Click OK.

4    For Palette, choose one of the following options:
•      Exact to create a palette using the colors in the image. This option is not dimmed (Macintosh) or 
visible (Windows) only if the image contains 256 or fewer colors.
•      Adaptive to create a palette using a representative sample of colors in the image. (This gives the 
best image quality if Exact is unavailable.) Then choose or enter the least number of colors that 
retains the necessary detail in your image.

The effect on file size of reducing the number of colors varies depending on dimensions and color 
content. For small-sized images, the effect on file size is insignificant.
•      System to create a color table using the computer’s built-in color palette. Then select Use Best 
Match. The System palette option may produce unexpected results when the image is displayed on an
8-bit monitor using a different built-in palette.
•      To use a custom palette, click Load, locate and select a custom palette, and click OK. Then select 
Use Best Match.

5    To see how the image will appear in the Web browser, click Preview. 

6    To navigate the preview, use the following methods:
•      To move the image within the preview window, select the hand tool ( ) and drag over the image. 
To fit all of the image in the window, double-click the hand tool.

•      To increase the magnification, select the zoom-in tool ( ) and click the part of the preview that you 
want to magnify. For a 100% preview, double-click the zoom-in tool.
•      To reduce the magnification, hold down Option (Macintosh) or Alt (Windows) and click the part of the 
preview you want to reduce.

 To use the viewing tools quickly when working in the GIF89a Export Preview, move the pointer to the preview area
and use these shortcuts: 
• To activate the zoom-in tool, press Command (Macintosh) or Ctrl (Windows). 
• To activate the zoom-out tool, press Option (Macintosh) or Alt (Windows).
• To activate the hand tool, press the spacebar.

7    Click OK to close the preview window.

8    If dissatisfied with the results, hold down Option (Macintosh) or Alt (Windows) and click Reset to 
restore the colors in the image. Repeat steps 3 through 8 as needed.



9    To determine how the image displays as it is downloaded in the Web browser, do one of the 
following:
•      Select Interlaced to display the image gradually in increasing detail as it is downloaded. 
•      Deselect Interlaced to use your image as a background or texture.

10    Click OK to export the file. Choose a location for the exported file, and click Save. 



Exporting images 

Exporting indexed-color images to GIF

When you export an indexed-color image to GIF, you can assign background transparency to areas in 
the image. All areas containing the colors you specify are recognized as transparency by Web 
browsers. 

For the most control, however, you may want to convert your image to RGB, create transparency in 
Photoshop using layers, hide the background, and then export the RGB image to GIF. Converting the 
image to RGB also lets you feather your selection and reduce the number of colors in an adaptive 
palette image when you convert the image to GIF (see Exporting RGB images to GIF). See Using 
Layers for more information on working with layers.

To export an indexed-color image to GIF:

1    Choose File > Export > GIF89a Export.

2    Assign transparency to desired colors in the image:

•      To add to the background transparency, click the eyedropper-plus tool ( ), and click the desired 
areas in the preview or the desired swatches. The selected colors appear highlighted in the swatches.

•      To remove a colored area from the background transparency, Command-click (Macintosh) or Ctrl-click
(Windows) the eyedropper-plus tool to toggle to the eyedropper-minus tool. Click the desired color 
swatch. 
•      To remove all areas from the background transparency, hold down Alt (Windows) or Option 
(Macintosh), and click Reset.

•      To navigate the image preview, follow the guidelines described in step 6 of Exporting RGB images 
to GIF.

To activate the eyedropper-minus tool while the eyedropper-plus tool is selected, press Command (Macintosh) or 
press Ctrl (Windows). To activate the eyedropper-plus tool while the eyedropper-minus tool is selected, press Shift.

3    Do one of the following:
•      To preview the background transparency as the gray background color used by many Web 
browsers, leave the Transparency Index Color box at the default color.
•      To preview the background transparency as a different color, click the Transparency Index Color 
box. Specify a color, as described in Using the Adobe Photoshop Color Picker, and click OK.

Note: The Transparency Index Color is used only to preview the background transparency, and does 
not affect the final appearance of the file.

4    Specify Interlaced and Export Caption options, as described in steps 7 and 8 of Exporting RGB 
images to GIF.

5    Click OK to export the file. Choose a location for the exported file, and click Save.
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About file formats

Click a file format to view more information.

See also: 
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PDF 

PICT File 

PICT Resource (Macintosh only) 

PIXAR 

PNG 

Raw 

Targa 

TIFF 



About file formats 

BMP 

BMP is the standard Windows bitmap image format on DOS and Windows-compatible computers. 
When saving an image in this format, you can specify either Microsoft(R) Windows or OS/2(R) format 
and a 1-bit to 24-bit depth for the image. For 4-bit and 8-bit images, you can also choose to use Run-
Length-Encoding (RLE) compression; this compression scheme is lossless, that is, it does not discard 
detail from the image.



About file formats 

Photoshop EPS 

The Encapsulated PostScript (EPS) language file format is supported by most illustration and page-
layout programs, and in most cases is the preferred format for these applications. Note that Photoshop
EPS also supports transparent whites in Bitmap mode. For more information on EPS options, see 
Saving files in Photoshop EPS format.
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EPS TIFF or EPS PICT Preview

You can use these formats to open files saved in applications that create previews but are not 
supported by Adobe Photoshop (such as QuarkXPress(R)). An opened preview file can be edited and 
used like any other low-resolution file. 



About file formats 

Filmstrip

The Filmstrip format is used for animation or movie files created by Adobe Premiere(R). Only images 
that were exported from Adobe Premiere in the Filmstrip file format can be saved in the Filmstrip file 
format in Adobe Photoshop. When editing a Filmstrip file in Adobe Photoshop, you must not resize or 
crop if you plan to export the image back into Adobe Premiere. For further guidelines, see the Adobe 
Premiere User Guide.
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CompuServe GIF 

The CompuServe Graphics Interchange Format (GIF) is the file format commonly used to display 
indexed-color graphics and images in hypertext markup language (HTML) documents over the World 
Wide Web and other online services. GIF is a compressed format that is designed to minimize file 
transfer time over phone lines.

Adobe Photoshop can save Bitmap mode, grayscale, or indexed-color images in the CompuServe GIF
format. When saving an image as GIF, you can specify how the image appears as it is downloaded. 
Select Interlaced to display the image gradually in increasing detail as it is downloaded. 

The GIF89a Export command lets you specify the appearance of transparent areas in the image and 
save an RGB image in the GIF format. For more information, see Exporting images.
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IFF 

The Amiga(TM) Interchange File Format (IFF) is used for working with Video Toaster and transferring 
files to and from the Commodore Amiga system. In addition, this format is supported by a number of 
paint programs on IBM-compatible computers, including DeluxePaint from Electronic Arts; IFF is the 
best export format to use with that program. 
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JPEG 

The Joint Photographic Experts Group (JPEG) format is commonly used to display photographs and 
other continuous-tone images in hypertext markup language (HTML) documents over the World Wide 
Web and other online services. Unlike the GIF format, JPEG retains all the color information in an 
RGB image. JPEG also uses a compression scheme that effectively reduces file size by identifying 
and discarding extra data not essential to the display of the image. Opening a JPEG image 
automatically decompresses it.

Because it discards data, the JPEG compression scheme is referred to as lossy. This means that 
once an image has been compressed and then decompressed, it will not be identical to the original 
image. A higher level of compression results in lower image quality, while a lower level of compression
results in better image quality. In most cases, compressing an image using the Maximum quality 
option produces a result that is indistinguishable from the original. For information on choosing JPEG 
options, see Saving files in JPEG format.



About file formats 

PCX 

PCX format, established by Z-Soft(R) for its PCPaintbrush(R) software, is commonly used by IBM PC-
compatible computers. Most PC software supports version 5 of the PCX format. Version 3 files do not 
support a custom color palette. For this reason, when you open a version 3 PCX file, the palette is 
ignored, and a standard VGA color palette is used instead.
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PDF

The PDF format is used by Adobe Acrobat(R), Adobe’s electronic publishing software for Macintosh, 
Windows, UNIX(R), and DOS. You can view PDF files using the Acrobat Reader(R) software included 
on your Adobe Photoshop CD-ROM.

Based on the PostScript Level 2 language, PDF can represent both vector and bitmap graphics. For 
the purposes of representing pages, PDF pages are identical to PostScript pages, but PDF files can 
also contain electronic document search and navigation features. PDF files, for example, can contain 
hypertext links and an electronic table of contents.

For more information on PDF and Adobe Acrobat, see the Adobe Systems website 
(http://www.adobe.com).
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PICT File

The PICT format is widely used among Macintosh graphics and page-layout applications as an 
intermediary file format for transferring files between applications. The PICT format is especially 
effective at compressing images that contain large areas of solid color.

When saving an RGB image in PICT format, you can choose either a 16-bit or 32-bit pixel resolution. 
For a grayscale image, you can choose from 2, 4, or 8 bits per pixel. If you’re using a Macintosh with 
QuickTime installed, you can also choose from four JPEG compression options for the file.
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PICT Resource (Macintosh only)

A PICT resource is a PICT file contained in a Macintosh application’s resource fork; examples of PICT 
resources include the Adobe Photoshop splash screen and the contents of the Scrapbook. You can 
open a PICT resource by choosing File > Import > PICT Resource (see Importing an anti-aliased PICT
file (Macintosh only)). When saving a file as a PICT resource, you can specify the resource ID and 
resource name. You can also specify bit depth and compression options as you would for the PICT 
format.
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PIXAR 

The PIXAR format is designed specifically for exchanging files with PIXAR image computers. PIXAR 
workstations are designed for high-end graphics applications, such as those used for three-
dimensional images and animation. 
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PNG

The PNG format was developed as an alternative to the GIF format and, like GIF, is used for 
displaying images on the World Wide Web and other online services. PNG preserves all color 
information in an image and uses a lossless compression scheme to reduce file size. 

When saving an image in PNG format, you can choose to display the image in gradually increasing 
detail as it is downloaded. To do this, select Adam7 for Interlace. You can also select a filtering 
algorithm, which is used to prepare the image data for compression.
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Raw 

The Raw format is a flexible file format for transferring files between applications and computer 
platforms. Raw format consists of a stream of bytes describing the color information in the file. Each 
pixel is described in binary format, in which 0 equals black and 255 equals white. You can specify the 
file extension (Windows), file type (Macintosh), file creator (Macintosh), and header information.

On the Macintosh, the file type is generally a four-character ID that identifies the file; for example, 
TEXT identifies the file as an ASCII text file. The file creator is also generally a four-character ID. Most 
Macintosh applications have a unique file creator ID that is registered with the Apple Computer 
Developer Services group. 

The header parameter is the number of bytes of information that will appear at the beginning of the 
file, before the actual image information. This value defines the number of zeros that will be placed at 
the beginning of the file as placeholders. By default, there is no header (header size = 0). You can 
enter a header when you open the file in the Raw format (see Opening Raw files). You can also save 
the file without a header and then use a file-editing program, such as Norton Utilities(R) (Macintosh) or
HEdit (Windows), to replace the zeros with header information. 

You can choose to save the image in an interleaved or noninterleaved format. If you choose the 
interleaved format, the color values (red, green, and blue, for example) are stored sequentially. The 
choice you make depends on the requirements of the application you plan to use to open the file. 



About file formats 

Targa 

The TGA (Targa(R)) format is designed for use on systems that use the Truevision(R) video board and
is commonly supported by MS-DOS color applications. If you are saving an RGB image in this format, 
you can choose the color depth you want.



About file formats 

TIFF 

The Tagged-Image File Format (TIFF) is used to exchange files between applications and computer 
platforms. The TIFF format supports LZW compression, a lossless compression method that does not 
discard detail from the image.

When you save an Adobe Photoshop image in TIFF format, you can choose to save in a format that 
can be read either by Macintosh or by IBM PC-compatible computers. You can also choose to 
compress the file to a smaller size automatically by clicking the LZW Compression check box.
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Placing Photoshop images in other applications

Photoshop supports several features that help you use images in other applications. If you’re using a 
Macintosh, the Edit Graphic Object (EGO) AppleEvent feature lets you embed Photoshop images in 
certain word-processor files.

See also: 

Embedding Photoshop images in word-processor applications (Macintosh only) 



Placing Photoshop images in other applications 

Embedding Photoshop images in word-processor applications (Macintosh 
only)

Adobe Photoshop supports the EGO AppleEvent, which allows the embedding of Adobe Photoshop 
images in word-processor files. 

Word-processor applications that work with EGO include Full Write Professional(TM), Nisus, MacWrite
Pro(R), WordPerfect(R), and Claris(R) Works(TM).

To use the Edit Graphic Object (EGO) AppleEvent to update images in word-processor files:

1    Paste the Photoshop image into your word-processor file. 

2    Double-click the image in your word-processor application to launch Adobe Photoshop (if it is not 
already running) and open the image for editing. 

3    When you have finished making changes, close the Photoshop file to update the image in your 
word-processor application.



Printing

In most instances, the default print settings in Adobe Photoshop Limited Edition produce excellent 
results. However, depending on the type of image you want to print and your output device, you may 
want to adjust the print settings.

See also: 

Printing: An overview 

General printing options 

Selecting halftone screen attributes 

Additional printing options 



Printing 

Printing: An overview

The most common way to output images is to produce a positive or negative image on paper or film, 
print prepress proofs, and then transfer the image to a printing plate to be run on a press. 

Note: Generally, for best printing results, use the latest printer software available for your printer and 
your operating system.

See also: 

About halftones 

Setting up to print 



Printing: An overview 

About halftones

To produce the appearance of continuous tone in an image, the image must be broken down into a 
series of dots. These dots are created during the printing process when a halftone screen is applied to
the image. The dots in a halftone screen control how much ink is deposited at a specific location. 
Varying the size and density of the dots creates the optical illusion of variations of gray or continuous 
color in the image. For a process color image, four halftone screens are used: cyan, magenta, yellow, 
and black—one for each ink used in the printing process.

In traditional print production, a halftone is produced by placing a halftone screen between a piece of 
film and the image and then exposing the film. In Adobe Photoshop, you specify the attributes for the 
halftone screen immediately prior to producing the film or paper output. To achieve the best results, 
the output device you use, such as a PostScript imagesetter, should be set to the correct density limit, 
and the processor should be properly calibrated. If these factors are inconsistent, the results can be 
unpredictable. 



Printing: An overview 

Setting up to print

To print any type of image in Adobe Photoshop, you first select the printing options you want and 
specify settings for the particular image type. 

Important: Photoshop always prints images at the center of the page—you cannot change the 
position of the artwork to print it at a different location on the page. If you want to print an image at a 
precise location on a page, you must export it to a page-layout program and reposition it there.

By default, Adobe Photoshop prints all visible layers. To print an individual layer, make it the only 
visible layer before choosing the Print command. 



Printing 

General printing options

For any type of image you print, you can choose to print page crop marks. You can also select a 
background color for the image. 

These printing options appear in the Page Setup dialog box, which appears when you choose File > 
Page Setup. The exact appearance of this dialog box varies with different printers. In general, on the 
Macintosh, the top half of the Page Setup dialog box contains the standard printing options for paper 
type, printer effects, reduction and enlargement, and orientation. In Windows, some print features are 
available in the File > Page Setup dialog box; others, such as reduction and enlargement options, are 
available in the Properties dialog box (choose Start > Printers and select your printer; then choose File
> Properties). See your printer documentation for more information on these options. 

Not all options are available for all printers. For example, if you are printing to a non-PostScript printer,
the Calibration Bars option is not available.

See also: 

Previewing the page layout 

Speeding up landscape printing 

Setting additional page setup options 

Printing crop marks 

Printing calibration bars 

Using interpolation 

Printing a border 

Selecting a background color 



General printing options 

Previewing the page layout

To preview the results of your printing options, click the page preview box at the lower left of the 
window. The box with the x in it represents the image. Note that Photoshop always prints images from 
the center of the page (you can’t adjust the image to print on another part of the page). See 
Previewing the page layout and print size for more information on the page preview feature.



General printing options 

Speeding up landscape printing

Adobe Systems recommends that, rather than using Landscape orientation, you rotate the image 90 
degrees by choosing Image > Rotate Canvas, choose an option from the submenu, and then print 
using Portrait orientation. Depending on the printer and printer software, printing a page with the 
Portrait setting can be much faster than printing with the Landscape setting.



General printing options 

Setting additional page setup options

In the Page Setup dialog box, click the Options button or the Properties button (the button name varies
with different operating systems) to set specific options for the printer you have selected. For more 
information on using the printing options, see your printer documentation.



General printing options 

Printing crop marks 

The Crop Marks option in the Page Setup dialog box prints crop marks that indicate where the page is 
to be trimmed. You can choose to print crop marks at the corners of the image, at the center of each 
edge of the image, or both.



General printing options 

Printing calibration bars 

The Calibration Bars option in the Page Setup dialog box prints an 11-step grayscale. The steps 
represent a transition in density from 0 to 100% in 10% increments.



General printing options 

Using interpolation

Some PostScript Level 2 printers can reduce the jagged appearance of a low-resolution image by 
automatically resampling up an image while it is printing. If your printer does not have this capability, 
this option has no effect.



General printing options 

Printing a border 

You can specify the width of a border you want to have appear around an image by using the Border 
button. The border is printed in black. 

To specify the width of a border: 

1    Click Border in the Page Setup dialog box.

2    For Width, enter a value for the width of the border; then choose a unit of measurement and click 
OK. You can specify decimal values for the width.



General printing options 

Selecting a background color

The Background button in the Page Setup dialog box lets you select a background color to be printed 
on the page outside the image area. This option is especially useful if you are printing slides to a film 
recorder, because a black or colored background is often desirable for slides. To use this option, click 
Background; then select a color from the Color Picker dialog box. The Background option is a printing 
option only and does not affect the image area itself.



Printing 

Selecting halftone screen attributes 

Halftone screen attributes include the screen frequency and dot shape for the screen used in the 
printing process. Check with your print shop for the preferred frequency, angle, and dot settings before
creating your halftone screens. (In general, the default angle settings should be used unless your 
printer specifies that they be changed.) 

If you are printing to a color printer, Adobe Systems recommends that you use the printer’s default 
halftone screen settings.

To use default screens for a color printer:

1    Click Screen in the Page Setup dialog box.

2    Select Use Printer’s Default Screens.

To define the screen attributes: 

1    Click Screen in the Page Setup dialog box. 

2    Deselect Use Printer’s Default Screens, and set the screen frequency and angle for the screen. 

Note: To use the default halftone screen built into the printer, select Use Printer’s Default Screens. 
The specifications from the Halftone Screens dialog box are then ignored when the halftone screens 
are generated. 

3    For Shape, choose the dot shape you want. 

Choosing Custom from the Shape menu displays the Custom Spot Function dialog box, which lets you
define your own dot shapes by entering PostScript commands. The Custom Spot Function is useful for
printing with nonstandard halftone algorithms. For information about using PostScript language 
commands, consult the imagesetter’s manufacturer.

For optimal printing, the image resolution should be twice the halftone screen frequency. If the 
resolution is more than 2.5 times the screen frequency, Adobe Photoshop displays an alert message. 
See About resolution and image size for more information.

See also: 

Selecting screen attributes for a grayscale halftone 

Saving and loading halftone screen settings 



Selecting halftone screen attributes 

Selecting screen attributes for a grayscale halftone

For a grayscale image, enter a screen frequency from 1 to 999.999 for Frequency; then choose the 
unit of measurement you want.

For Angle, enter a screen angle from –180 to +180 degrees.



Selecting halftone screen attributes 

Saving and loading halftone screen settings

You can save your halftone screen settings foruse with other Adobe Photoshop files by clicking the 
Save and Load buttons in the Halftone Screens dialog box. To save the new settings as the default, 
hold down Option (Macintosh) or Alt (Windows), and click the —> Default button. To return to the 
original default settings, hold down Option/Alt and click <— Default. 



Printing 

Additional printing options

You can also set printing options by using the Print dialog box, which appears when you choose File > 
Print. These options let you print only a selected area of an image, transfer image data to the output 
device in ASCII format, print a color-corrected composite image on a color printer, and create an EPS 
or PostScript file. The appearance of this dialog box varies with different printers.

See also: 

Printing a selected area 

Printing with print spoolers and across networks (PostScript printers) 



Additional printing options 

Printing a selected area

You can print a rectangular selection of an image.

To print a selected part of an image: 

1    Use the rectangular marquee tool to select the part of an image you want to print.

2    Choose File > Print.

3    In the Print Range options, click Selection; then click OK.



Additional printing options 

Printing with print spoolers and across networks (PostScript printers)

If you have a PostScript printer, you can choose to transfer information to printers in either binary (the 
Macintosh default) or ASCII (the Windows default) format.

Some print spooler programs, computer networks, and third-party printer drivers don’t support files 
that are binary-encoded, and some PostScript output devices accept binary-encoded image data only 
through their AppleTalk(R) and Ethernet ports, and not their parallel or serial ports. In these situations, 
you can choose to transfer the file in ASCII format. 

Files that are encoded in ASCII format require about twice as much time to transfer as binary files, 
because they contain about twice as many characters. 

To select a binary or ASCII encoding option:

1    Choose File > Print.

2    Choose Adobe Photoshop from the pop-up menu. 

3    Choose an Encoding option and click OK.



Improving Performance

A program’s “performance” is the amount of time that it takes the program to complete certain 
operations, such as opening a file, sending a file to a printer, or redrawing the screen after you edit an 
image. 

To a great extent, your computer processor speed and the amount of RAM you have affect the 
performance of Adobe Photoshop Limited Edition. Other factors that can dramatically affect the 
application’s performance are how you set up your software, how you use virtual memory, and the size
and complexity of your files.

See also: 

Using RAM, scratch disks, and system virtual memory 

Displaying file size and memory status 

Additional tips for improving performance on the Macintosh 

Additional tips for improving performance with Windows 

Tips for working efficiently 



Improving Performance 

Using RAM, scratch disks, and system virtual memory

The best way to improve performance when using Adobe Photoshop is to increase the amount of 
random access memory (RAM) installed on your system. Testing at Adobe Systems has shown that 
increasing the amount of installed RAM tremendously improves the overall performance of Adobe 
Photoshop. 

See also: 

Determining the amount of RAM required 

Determining the amount of scratch disk space required 

Assigning scratch disks 

Using the operating system’s virtual memory 



Using RAM, scratch disks, and system virtual memory 

Determining the amount of RAM required

The amount of RAM that Photoshop requires depends on numerous factors, including the pixel 
dimensions of your image (see Determining image size and resolution), its color mode (see Choosing 
a Color Display Mode), the number of layers in the file (see Using Layers), as well as on the 
operations you’re performing. Copying part of an image or performing other operations in Photoshop 
may require 2 to 3 times the image size in RAM. 

In most cases, it’s a good idea to give Photoshop at least 3 to 5 times your file size in RAM, plus about
5 to 10 MB. 

The RAM available to Photoshop is determined in the following ways:
•      On the Macintosh, Photoshop is set to a default application size determined by the type of 
Macintosh you have. If you have more RAM available, you can increase the amount of RAM allocated 
to Photoshop in the Finder. See Increase the application memory size for instructions.
•      In Windows, Photoshop’s default setting allocates 50% of available RAM (RAM not being used by 
the operating system or by disk-caching software) for its own use. You can change this amount in the 
Memory & Image Cache Preferences dialog box (choose File > Preferences > Memory & Image 
Cache).

Note: In Windows NT, a RAM setting of 70% or lower may improve performance. To achieve optimal 
performance, experiment with different RAM settings.



Using RAM, scratch disks, and system virtual memory 

Determining the amount of scratch disk space required

When your system does not have enough RAM to perform an operation, Adobe Photoshop uses 
virtual memory, also called the scratch disk. Virtual memory is disk space used for storing data during 
a work session when the amount of RAM is insufficient. The Photoshop virtual memory technology lets
you open and manipulate large images by swapping image data to a hard drive if there is not enough 
RAM to contain the data. Keep in mind, however, that copying data to and from the scratch disk 
requires significantly more time than processing files in RAM. Allocating enough RAM to Photoshop to 
avoid using the scratch disk will keep Photoshop operating at peak performance.

Whether or not Photoshop is using the scratch disk, the amount of free space on the scratch disk must
be greater than or equal to the amount of RAM you have allocated to Photoshop. To ensure good 
performance, Photoshop writes the entire RAM contents to the scratch disk during idle times. If the 
scratch disk runs out of free space, Photoshop quits taking additional RAM—regardless of what you 
have allocated to the program. This means that if you’ve allocated 60 MB to Photoshop but you have 
only 10 MB of free space on your scratch disk, Photoshop will use only 10 MB of RAM.



Using RAM, scratch disks, and system virtual memory 

Assigning scratch disks

By default, Photoshop uses the hard drive that the operating system is installed on as its primary 
scratch disk. You can change the primary scratch disk or designate a secondary scratch disk, to be 
used when the primary disk is full. Your primary scratch disk should be your fastest hard disk, and 
should have plenty of defragmented space available. 

The following guidelines can help you assign scratch disks:
•      For best performance, scratch disks should be on a different disk than any large files you are 
editing.
•      Scratch disks should be on a different disk than the one used for the Macintosh or Windows virtual
memory.
•      Scratch disks should be local. That is, they should not be accessed over a network.
•      Scratch disks should be conventional (non-removable) media.
•      Raid disks/disk arrays are good choices for dedicated scratch disk volumes.
•      Scratch disks should be defragmented regularly.

To change the scratch disk assignment:

1    Choose File > Preferences > Plug-Ins & Scratch Disks.

2    Select the desired disk from the menu. Then restart Adobe Photoshop for the change to take effect.

Important: Adobe recommends that you use a disk tool utility, such as Norton Utilities or Defrag, to 
optimize and defragment your hard drive on a regular basis. See your Macintosh or Windows 
documentation for information. 



Using RAM, scratch disks, and system virtual memory 

Using the operating system’s virtual memory

In addition to Photoshop’s virtual memory, both Apple System software (version 7.5 or later required 
for the Macintosh) and Windows use their own virtual memory schemes. These virtual memory 
schemes swap active application programs to a hard disk when there is not enough RAM to hold them
all simultaneously. Increasing the system virtual memory will not speed up operations within 
Photoshop; it may, in fact, take needed scratch disk space from Photoshop and seriously degrade 
performance. Use the following guidelines for setting up system virtual memory:
•      On the Macintosh, turn off System 7 or 8 virtual memory. See Disabling virtual memory on the 
Macintosh for instructions.
•      On Windows, if you have plenty of RAM for Photoshop (see Determining the amount of RAM 
required), you should manually set the Windows swap file to twice the amount of installed RAM. See 
Increase the virtual memory allocation for more information.



Improving Performance 

Displaying file size and memory status

The display in the lower left of the window lets you view different information related to disk space and 
memory. It’s important to note that the amount of data in an image and the amount of RAM that 
Photoshop is using to process the image may be very different values. 

To display file size and memory status:

1    Move the pointer to the  in the lower left of the window, and hold down the mouse button.
2    Choose from the following options:

•      Document Sizes to display information on the amount of data in the image. (See the following 
section for more information.)
•      Scratch Sizes to display information on the amount of RAM used to process the image. See 
Scratch sizes for more information.
•      Efficiency to display the percentage of Photoshop operations being performed using RAM (as 
compared to using scratch disk space). An Efficiency display below 100% indicates that Photoshop is 
using the scratch disk and so is operating more slowly than if only RAM were being used. See 
Determining the amount of scratch disk space required for information on the scratch disk.
•      Timing to display the amount of time it took to complete the last operation. 

See also: 

Document sizes 

Scratch sizes 



Displaying file size and memory status 

Document sizes 

When you display Document Sizes, the number on the left represents the printing size of the image—
that is, the amount of data that will be sent to a printer if you print the file. The printing size is the same
as the saved, flattened file in Adobe Photoshop format; however, it is usually somewhat smaller than 
the uncompressed file size on disk. This discrepancy is caused by other factors—such as your 
preview options and the type of disk you have—which can add to the size of the file on disk. On the 
other hand, if you save in a compressed format, such as JPEG, the printing size displayed here may 
be significantly larger than the file size on disk.

The number on the right indicates the file’s approximate size in its layered format. This number is 
usually greater than the file size on disk because Photoshop is able to compress certain data when it 
saves the file to disk. The larger the image, the greater the difference between this number and the 
saved file size. For more information on how layers affect file size, see Keeping track of file sizes.

Important: If the 2.5 Format Compatibility option is turned off in the Saving Files Preferences dialog 
box (it’s on by default), the saved file size will be significantly smaller with layered files because the 
2.5 compatibility option saves a flattened version of the file with the layered file. Some applications, 
such as Adobe Illustrator, can open only a flattened version saved in the Photoshop format.



Displaying file size and memory status 

Scratch sizes

When you display scratch sizes, the number on the left represents the amount of memory that is 
currently being used by the program to display all open images, including layers and any information 
on the Clipboard.

The number on the right represents the total amount of RAM available for processing images. This 
number is equal to the amount of memory available to Photoshop minus the amount that Photoshop 
needs to run. See Determining the amount of RAM required for more information.

With Scratch Sizes, when the number on the left is greater than the number on the right, Photoshop is 
using the scratch disk in addition to RAM. At this point, you’ll probably notice a dramatic decline in 
Photoshop’s performance because Photoshop must read and write files to the scratch disk. See 
Determining the amount of scratch disk space required for more information.



Improving Performance 

Additional tips for improving performance on the Macintosh

You can optimize Adobe Photoshop’s performance on the Macintosh by changing a variety of system 
settings.

See also: 

Increase the application memory size 

Disabling virtual memory on the Macintosh 

Turn on the Modern Memory Manager in the Memory control panel 

Decrease the disk cache setting 

Turn off system extensions and control panels 



Additional tips for improving performance on the Macintosh 

Increase the application memory size

If your computer has more RAM than Photoshop’s default RAM allocation, you can significantly 
improve Photoshop’s performance by increasing the application memory size. See Determining the 
amount of RAM required for more information.

To change the application memory size:

1    Start all applications—except Adobe Photoshop—that you must use at the same time as Adobe 
Photoshop. Keep in mind, however, that running other applications with Photoshop uses RAM that 
could be allocated to Photoshop.

2    Return to the Finder. Choose About This Computer from the Apple menu. 

3    Note the Largest Unused Block value. (You will use this result in step 5.) This value shows the 
amount of memory currently available. 

4    In the Finder, select the Adobe Photoshop LE program icon (not the folder or the alias icon), and 
choose File > Get Info. 

You cannot increase the application memory size while Photoshop is running.

5    In the Adobe Photoshop LE Info window, set the Preferred Size option to no more than 90% of the 
Largest Unused Block value you noted in step 3. 

Important: Using RAM Doubler(TM) will improve performance when running Photoshop with other 
applications. However, Photoshop’s memory allocation must be based only on installed RAM.

6    Close the Adobe Photoshop Info window. 



Additional tips for improving performance on the Macintosh 

Disabling virtual memory on the Macintosh

In addition to Photoshop’s virtual memory, both Windows and Apple System software (version 7.1.2 
and later) use their own virtual memory technologies. These swap active application programs to a 
hard disk when there is not enough RAM to hold them all simultaneously. Using the system virtual 
memory in the Mac(R) OS won’t speed up operations in Photoshop. In fact, it will take needed scratch 
disk space from Photoshop and seriously degrade performance. Use the following guidelines for 
setting up system virtual memory: 

Unless you don’t have enough memory to run Photoshop otherwise, Adobe strongly recommends that 
you turn off virtual memory for much better performance with Photoshop. (For instructions on using the
Memory control panel, see your Mac OS documentation.)



Additional tips for improving performance on the Macintosh 

Turn on the Modern Memory Manager in the Memory control panel

Adobe Photoshop is designed to use the Modern Memory Manager in System 7.5.1 and later. This 
capability enables applications to use more than 8 MB of RAM, thus allowing a larger portion of a file 
to be stored in RAM instead of on a comparatively slower hard disk. 

Only if RAM is so limited that Photoshop cannot run, it may be useful to turn on virtual memory to 
prevent RAM from being used up by the application code. Set the virtual memory to 1 MB more than 
physical memory.

If RAM is not this limited, Adobe strongly recommends that you turn off virtual memory in System 7 or 
later as described in Using the operating system’s virtual memory.



Additional tips for improving performance on the Macintosh 

Decrease the disk cache setting

The disk cache setting in the Memory control panel sets aside memory for common operating system 
tasks. Adobe Systems recommends that you set the disk cache to a maximum of 128K. If you have 
limited RAM allocated to Photoshop, setting the disk cache higher may significantly degrade 
Photoshop’s performance.

To set the disk cache size:

1    Choose Control Panels > Memory from the Apple menu.

2    If necessary, click the arrow keys to change the disk cache size to no higher than 128K.

3    Close the Memory control panel.



Additional tips for improving performance on the Macintosh 

Turn off system extensions and control panels

Like any application running at the same time as Photoshop, system extensions and control panels 
use RAM that could be allocated to Photoshop. If you are running Photoshop with limited RAM, use 
Extensions Manager to turn off as many extensions and control panels as possible, or run with the 
Mac OS Only or Mac OS Base extension presets. See your Macintosh documentation for instructions.



Improving Performance 

Additional tips for improving performance with Windows

The first time you launch Adobe Photoshop, the program automatically checks the amount of RAM 
and warns you if you need to change the virtual memory allocation. By default, Adobe Photoshop 
allocates 50% of all available RAM (that is, RAM not being used by the operating system or by disk-
caching software) for its own use.

See also: 

Increase the virtual memory allocation 



Additional tips for improving performance with Windows 

Increase the virtual memory allocation

Although you can’t improve the performance of Photoshop operations by increasing the Windows 
virtual memory allocation, adequate virtual memory lets Windows swap Photoshop out of RAM when 
launching other applications, performing other Windows operations, or printing.

Windows manages its own virtual memory, by default. However, you can manually adjust amount of 
memory you assign to the Windows virtual memory disk, called the permanent swap file (or Paging 
File in Windows NT), as follows:
•      In Windows 95, select the option to Let Me Specify My Own Virtual Memory Settings; then set the 
swap file to at least the size of virtual memory, and preferably, to double the RAM. 
•      In Windows NT, set the initial size of the Windows Paging File to the amount of your installed RAM
plus 12 MB. For the Maximum size, enter twice the amount of installed RAM. 

If more memory is needed to run other applications at the same time as Photoshop, you can lower the 
percentage of RAM allocated to Adobe Photoshop in the Memory & Image Cache Preferences dialog 
box. Adjusting the RAM percentage will probably degrade the program’s performance, but it may make
it easier to run other applications with Adobe Photoshop.

For more information on increasing the virtual memory setting in Windows, see your Windows 
documentation.



Improving Performance 

Tips for working efficiently

In addition to the amount of RAM and your system configuration, the single most important factor 
affecting performance is the size of your files. File size is determined chiefly by the pixel dimensions of
an image and its color mode (see Determining image size and resolution and Color modes and 
models). In addition, the number of layers in an image can significantly increase file size. 

See also: 

Minimize file size 

Clear data from RAM 

Turn off palette previews 

Use shortcuts 

Working in two windows 

Work on low-resolution copies of files 

Adjust the image cache setting 



Tips for working efficiently 

Minimize file size

The most important factor in determining file size is the pixel dimensions of the image. If you are 
preparing your image for printed output, make sure that the print resolution and dimensions are the 
size you need for your final file. In general, the recommended image resolution is 1.5 to 2 times the 
screen frequency you will use to print the image. See Screen frequency and image resolution for more
information. 

Also, merge layers as you no longer need them. Layers may add significantly to the size of the file.



Tips for working efficiently 

Clear data from RAM

The images and selections you cut or copy to the Clipboard are stored in RAM. Keeping large 
amounts of data in RAM can significantly degrade Adobe Photoshop’s performance. 

To clear cut and copied data from RAM:

Choose Edit > Purge and then choose an option from the submenu:
•      Undo to remove from RAM a copy of the image before the last-performed operation.
•      Clipboard to remove from RAM any data copied or cut from an image. 

Note: To avoid filling the Clipboard with data, use the program’s drag-and-drop capability to drag 
elements (images, selections, and layers) from one file to another or from the Layers palette to 
another file.



Tips for working efficiently 

Turn off palette previews

The preview thumbnails on the Layers palette can be turned off for a slight performance improvement.
To turn off these previews, choose Palette Options from the Layers palette menu and select None 
from the Thumbnail Size options.



Tips for working efficiently 

Use shortcuts

Learn to use the command shortcuts that appear to the right of the commands in the menus. These 
are especially useful for operations that you perform frequently, such as displaying a specific 
command’s dialog box or adjusting color levels. 



Tips for working efficiently 

Working in two windows

You can save time by using the View > New View command to open a second window for a document.
For example, you can work on a magnified version of an image in one window while viewing the entire
image in a second window.



Tips for working efficiently 

Work on low-resolution copies of files

Another way to save time and space is to create a low-resolution version of your file. Be sure to give 
this copy a unique name when you create it so that you don’t overwrite your original high-resolution 
image.

A low-resolution image is useful for making initial editing and color corrections. If you’re adjusting 
color, save the settings by using the Save buttons in the color-adjustment dialog boxes. Once you 
know which features and dialog box settings produce the results you want, open the original file and 
repeat the steps; then use the Load button to apply saved settings to the original file.



Tips for working efficiently 

Adjust the image cache setting

Photoshop uses a technology called image caching to help speed the redraw of high-resolution 
images. With image caching, Photoshop uses lower-resolution versions of an image to update the 
image on-screen when performing basic operations, such as layering and applying color adjustments. 
You can adjust the image cache setting and determine whether or not Photoshop uses the image 
cache to display histograms.

To change the cache settings:

1    Choose File > Preferences > Image Cache.

2    For Cache Levels, enter a value between 1 and 8. A higher value results in more caching and 
quicker screen redraw, but also uses more hard disk space and RAM, and can increase the time it 
takes to open a file.

If you are working with small files (for example, frames of QuickTime movies or screen images), you 
may want to use a Cache Levels setting of 2 or 3. If you are working with large files (for example, files 
larger than 4096 pixels high or wide), you may want to use a setting higher than 4.

3    To increase the speed of histogram displays, select Use Cache for Histograms. Selecting this 
option produces a faster, though slightly less accurate, histogram display when you choose Image > 
Adjust > Levels.

4    Click OK.



Troubleshooting

This appendix contains common solutions to problems you may encounter when using the Adobe 
Photoshop Limited Edition program. 

See also: 

Before you call Adobe Technical Support 

Additional technical support resources 

Setup and performance problems 

Problems with image appearance 



Troubleshooting 

Before you call Adobe Technical Support

There are several steps you can take before calling technical support to receive assistance. 
Performing these steps can solve many problems and often eliminates the need for telephone 
assistance.

See also: 

Reinstall Adobe Phtoshop Limited Edition 

Check for new software or setting conflicts 

Check for an extension conflict 

Deactivate the preferences file 

Check SCSI device connections 

Optimize and defragment your hard disk 



Before you call Adobe Technical Support 

Reinstall Adobe Phtoshop Limited Edition

If you are experiencing installation problems, delete all of your Photoshop applications files, including 
the preferences file (located in the System Folder/Preferences folder on the Macintosh and in the 
Photoshop/Prefs folder on Windows), and then try the following:
•      Copy the entire Adobe Photoshop 5.0 LE folder (Macintosh) or Photosle folder (Windows) from the
CD-ROM to your hard disk, and then install from the hard disk after following the instructions in the 
next paragraphs. 
•      On the Macintosh, hold down the Shift key and restart to turn off all extensions; then reinstall 
Adobe Photoshop LE.

To reinstall Adobe Photoshop Limited Edition in Windows:

1    Uninstall the program by choosing Start > Programs > Photoshop 5.0 Limited Edition > Uninstall 
Photoshop Limited Edition.

2    From the Windows Explorer, delete the Photoshop 5.0 LE folder and any remaining folders under it
(the uninstaller doesn't always delete all the folders and files), as follows:
•      In Windows 95, remove all items from the startup group. (Choose Windows\Start Menu\Programs\
Startup folder.) 
•      In Windows NT, remove all items from the startup group. (From Windows Explorer, select the 
folder Winnt > Profiles > your login name > Start Menu> Programs > Startup, where “your login name” 
is your user name.

You must remove the startup items from the username you are logged in as well as from the 
username called All Users. 

3    Reinstall Adobe Photoshop LE.

4    Restart your computer; if you’re running Windows NT, restart in VGA mode.

See your Windows documentation for instructions on deactivating startup software and changing 
restart options.



Before you call Adobe Technical Support 

Check for new software or setting conflicts

Very often problems with Adobe Photoshop can be traced to recent installation of new software or 
utilities that are running at the same time as Photoshop. If you have recently installed new software or 
changed other system configuration settings, such as your monitor setting, try de-installing the 
software or restoring your original settings. (If you de-install software, you must also reinstall 
Photoshop following the instructions in the previous section. This will ensure that any Photoshop files 
that might have been damaged by your new software installation are restored.) If the problem 
disappears, you can try reinstalling the problem software or system utility or contact the manufacturer 
for a new version and for compatibility information.



Before you call Adobe Technical Support 

Check for an extension conflict

On the Macintosh, hold down the Shift key and restart the computer to restart with extensions off. In 
Windows, remove all items from the startup group and remark out the load/run lines in the win.ini file. 
(See your Macintosh or Windows documentation for more information on deactivating startup 
software.) If the problem disappears after restarting Photoshop, try restarting your computer with 
selected startup items reactivated until you have identified the problem software. You can then try 
reinstalling the software, or remove the software and contact the software manufacturer for a new 
version and for compatibility information.



Before you call Adobe Technical Support 

Deactivate the preferences file

To check whether your problem is caused by a corrupted preferences file, quit Adobe Photoshop, 
deactivate the preferences file, and restart Photoshop. (Deactivating the preferences file before 
starting causes Photoshop to generate a new preferences file with default settings.)

To deactivate the preferences file on the Macintosh, drag the Adobe Photoshop 5 LE Prefs file (located
in the Preferences folder in your System Folder) to the Trash. To deactivate the preferences file in 
Windows, make sure that file extensions are displayed, and then rename the Adobe Photoshop 5 LE 
Prefs.psp file (located in your Photoshop 5.0 LE/Prefs directory). If the problem disappears, delete the 
preferences. If the problem persists, restore the preferences file to its original location (Macintosh) or 
names (Windows) to preserve your preferences settings.



Before you call Adobe Technical Support 

Check SCSI device connections

Make sure that the devices you are using are securely and fully connected to your computer, and that 
device cords are not damaged. The cause of the problem could be a bad connection.

Important: Be sure to turn off your computer and SCSI devices before checking cord connections. 
Failure to do so can damage your hardware.



Before you call Adobe Technical Support 

Optimize and defragment your hard disk

Use a disk tool utility, such as Norton Utilities or Scandisk, to check whether your hard disk contains 
bad sectors that may be causing the crashes. You can then use the Norton Speed Disk or Defrag 
utility to optimize and defragment the hard drive. (Defragmenting cleans up any leftover file fragments 
and orders data contiguously so that it can be accessed quickly.) For instructions, see the utility’s 
documentation. 



Troubleshooting 

Additional technical support resources

For more information about Adobe products and services, you can use forums through Internet 
services. Forums vary by country. You can access extensive customer support information on the 
Adobe Home Page on the World Wide Web, or on the technical support Web page. 

To open the Adobe Home Page, enter the URL http://www.adobe.com in your Web browser. To launch 
the Adobe Home Page directly from Photoshop LE, choose File > Adobe Online or click the icon at the
top of the tool bar. 



Troubleshooting 

Setup and performance problems

Commands don’t appear in menus; Filter (or Import or Export) menu and submenus are gray or 
missing 

Tool icons don’t change when another tool is selected 

Operations seem unusually slow, or out-of-memory messages appear frequently 

Scratch disk full messages appear 

Space on hard disk appears lost 



Setup and performance problems 

Commands don’t appear in menus; Filter (or Import or Export) menu and 
submenus are gray or missing.

Choose File > Preferences > Plug-Ins & Scratch Disks, and make sure that you have selected the 
plug-ins folder containing the modules that you want to use. Also make sure that all the plug-ins you 
want to use are within a single umbrella folder. Although you can nest plug-ins in folders within folders,
you can select only one umbrella plug-in folder at a time. See Looking at the Work Area for information
on choosing the plug-ins folder.



Setup and performance problems 

Tool icons don’t change when another tool is selected.

This problem may occur with some Windows video card drivers that conflict with the Photoshop 
application. Contact the card manufacturer for an updated driver.



Setup and performance problems 

Operations seem unusually slow, or out-of-memory messages appear 
frequently.

Your system settings—such as the amount of RAM and use of the system’s virtual memory—may be 
slowing down Adobe Photoshop operations. For information on setting up RAM and virtual memory in 
Photoshop and for other tips on improving performance, see Improving Performance. 



Setup and performance problems 

Scratch disk full messages appear.

This error usually occurs when you are low on hard drive space, which Photoshop needs to process 
your images. Choose File > Preferences > Plug-Ins & Scratch Disks to determine where your scratch 
disks are located. Then use Windows Explorer or the Mac OS Finder to determine the amount of 
space available on those hard drives. Set the primary scratch disk space to a drive which contains 
contiguous free space that equals at least 3 to 5 times the size of your document in Photoshop.

For more information on the scratch disk, see Determining the amount of scratch disk space required.



Setup and performance problems 

Space on hard disk appears lost.

If a system error occurs when a Photoshop file is open, the system creates a temporary (.tmp) file to 
hold the information about the open images. Normally, the temporary file is deleted when you quit the 
program. However, sometimes when the system crashes the file is not deleted. On the Macintosh 
these temporary files are automatically placed in the Trash. 

To restore the hard disk space on your Macintosh, empty the Trash to delete the temporary files. For 
more information, see your Macintosh documentation.

To restore the hard disk space in Windows, search for *.tmp (all files with a .tmp extension) on all hard 
drives from the root directory, including subfolders. Then delete the .tmp files and run the Scandisk 
utility. (Note that you will not be able to delete the active Windows .tmp file.) 

For more information, see your Windows documentation.



Troubleshooting 

Problems with image appearance

Painting tools don’t work 

The pointer disappears (Macintosh only) 

Brush Size icon doesn’t work at all brush sizes (Macintosh only) 

Only 16 pixels are available for the brush size (Macintosh only) 



Problems with image appearance 

Painting tools don’t work.

Painting tools work only on the target layer and inside areas that are parts of the current selection or 
when no part of the layer is selected. 

Check to make sure that you are not painting outside a selected area. Check to make sure that you 
have not previously hidden the edges of the selection by pressing Command/Ctrl+H. If you are 
painting outside a selected area, choose Select > None to deselect everything or Select > Inverse to 
switch the selected and unselected areas. 

You might also be attempting to paint or fill a layer that has the Preserve Transparency option 
selected. In this case, painting is limited to the areas of the layer that contain pixels. Deselect this 
option in the Layers palette to edit anywhere on the layer.



Problems with image appearance 

The pointer disappears (Macintosh only).

Try either disabling or enabling the Direct Cursors extension in the Extensions folder. To turn off the 
extension, first create a new folder; then drag the Direct Cursors extension out of the Extensions folder
(located in the Plug-Ins folder) and into a new folder. Then restart Adobe Photoshop.



Problems with image appearance 

Brush Size icon doesn’t work at all brush sizes (Macintosh only).

Reinstall the Director Cursors plug-in by dragging it from the Adobe Photoshop Application CD to the 
Extensions folder within the Plug-Ins folder.



Problems with image appearance 

Only 16 pixels are available for the brush size (Macintosh only).

Disabling the Direct Cursors extension restricts the number of pixels available for the brush size. To fix
this problem, turn on the Direct Cursors extension by placing it in the Extensions folder within the 
Plug-Ins folder.



The rectangular marquee tool (M) makes rectangular selections.



The move tool (V) moves selections, layers, and guides.



The lasso tool (L) makes freehand selections.



The magic wand tool (W) selects similarly colored areas.



The airbrush tool (A) paints soft-edged strokes.



The paintbrush tool (B) paints brush strokes.



The eraser tool (E) erases pixels and restores parts of an image to a previously saved state.



The pencil tool (Y) draws hard-edged strokes



The rubber stamp tool (S) paints with a copy of an image.



The smudge tool (J) smudges data in an image.



The blur tool (R) blurs hard edges in an image.



The dodge tool (O) lightens areas in an image.



The type mask tool (P) creates selection borders in the shape of type.



The type tool (T) creates type on an image.



The line tool (N) draws straight lines.



The linear gradient tool (G) creates a straight-line blend between colors.



The paint bucket tool (K) fills similarly colored areas with the foreground color.



The eyedropper tool (I) samples colors in an image.



The hand tool (H) moves an image within its window.



The zoom tool (Z) magnifies and reduces the view of an image.



The elliptical marquee tool (M) makes elliptical selections.



The single row and single column marquee tools make 1 - pixel wide selections.



The crop tool (C) trims images.



The polygon lasso tool (L) makes freehand and straight-edged selections.



The magnetic lasso tool (L) draws selection borders that cling to the edges of objects.



The sharpen tool (R) sharpens soft edges.



The burn tool (O) darkens areas in an image.



The sponge tool (O) changes the color saturation of an area.



The Switch Foreground and Background Colors button (X) reverses the foreground and 
background colors.



The Foreground Color button displays the color for painting, filling, and stroking selections.



The Background Color button displays the color for making gradient fills and for filling in the erased 
areas of an image.



The Default Foreground and Background Colors button (D) returns to the default color mode 
(black foreground and white background).



The Edit in Standard Mode button (Q) lets you make selections using a selection border..



The Edit in Quick Mask Mode button (Q) lets you isolate a selection by covering the unselected 
areas with a temporary mask color.



The Standard Screen Mode button (F) displays artwork in a standard window, with a menu bar at 
the top and scroll bars on the sides.



The Full Screen Mode with Menu Bar button (F) displays artwork in a full-screen window with a 
menu bar but with no title bar or scroll bars.



The Full Screen Mode button (F) displays artwork in a full-screen window, but with no title bar, menu 
bar, or scroll bars.




