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Consumer Product General Information......................201-348-9090
Office Automation Product Manuals/Sales Locations and
Support Contracts/Product Consumables/Accessories.........800-346-4768
Telephone Product Help Line...............................800-922-0028
Consumer Accessory Order Line.............................800-332-5368
Consumer Products Parts/Servicer Referral.................800-545-2672
Consumer Fax Help Line....................................800-435-7329
Printer/Computer Help Line................................800-222-0584
Industrial Fax (PANAFAX) Help Line........................800-225-5329
PCSC Industrial Products Customer Care....................800-854-4536
Office Automation Group Dealer Referral...................800-742-8086
Industrial Cellular Phone Accessory Order Line............800-382-3709
Laptop Computer Service Referral..........................800-457-7291
Peripheral Computer Products Line.........................800-457-7291
Check Printing Accountant Product Line....................800-272-7033
Industrial Video Products Line............................800-524-1448
Office Automation Group Accessory Order Line..............800-346-4768
Industrial Audio, Video, Fax, & Cellular Phone
Servicer Referral.........................................800-526-6610
Industrial Fax Servicer Referral..........................800-874-4322
Jetwriter/Typewriter Servicer Referral....................800-544-5008
Industrial Cellular Phone Dealer Referral.................800-441-7262
Digital Business Systems Dealer Referral..................800-435-4327
Laptop Computer Help Line.................................800-527-8675
Industrial Video Dealer Referral..........................800-524-0864
PanaTech BBS..............................................201-863-7845
PanaTech LapTop BBS.......................................201-348-7560
Panasonic Data Collection Computers (Data Partner)........708-468-4905
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HelpBreeze Example #1
Tutorial    

This example file provides a brief introduction to HelpBreeze and will walk you through the 
basic commands.    You should complete each of the lessons in order.    Once you've 
completed this tutorial, you can move on to the other examples in any order you wish.    
Most users will want to at least complete Example 3 (secondary windows) and Example 5 
(automatically importing a Word document).    

This tutorial is reproduced in Chapter 1 of the HelpBreeze User's Guide.    If you have never 
created a Windows help file before, we suggest that you read "An Overview of Creating 
Windows Help Files" in Chapter 1, before you begin this tutorial.

You should also refer to the HelpBreeze on-line Help.    You can access the HelpBreeze 
floating help palette by pressing the question mark "?" icon on the Word for Windows 
toolbar.    You can "roll-up" the help palette so that it takes up less space on the screen; this 
allows you to leave the palette open for convenient access to the on-line help while you are 
working.    In addition, each HelpBreeze dialog box has a help button which will take you 
directly to step-by-step instructions for a given task.    

HelpBreeze emulates hypertext jumps and pop-ups within Word for Windows with red test 
buttons: <+>.    You can execute the jump by double clicking the test button.    You can 
return to the origin of the last jump by pressing the GoBack button (the footsteps) on the 
toolbar. 

This tutorial includes the following topics:

1. Setting the Help Project
2. Compiling and Viewing Your Help File
3. Creating and Editing Jumps and Pop-ups
4. Creating and Editing Help Topics
5. Jumping to a Specific Help Topic
6. Inserting and Editing Graphics
7. Using Bullet Points and Numbering
8. Inserting and Editing SHED hypergraphics
9. Inserting and Editing Hotspot Macros
10. Setting Compiler Options and HelpBreeze Preferences
11. Converting Help Topic Files to Printed Documentation
12. Generating Help Topic Reports
13. Editing Topic Groups and Browse Sequences



Setting the Help Project
When you open or create a document for the first time, you must let HelpBreeze know which
help project you want to use.    The help project you select will automatically be opened the 
next time you open the document.

The help project for this example is called "example1."    Select this project now:

1. Press the Folder icon on the Word for Windows toolbar, or select Set Help Project from
the Tools menu.    The Set Help Project dialog will appear.

2. Press the Select button and select the file EXAMPLE1.HPJ.    

3. Check to be sure that the help compiler version selected in the dialog box matches your
compiler (the default is HC31).    Then press OK to put away the Set Help Project dialog 
box.    Once you select a help project, it remains active for subsequent sessions until 
you change it.    The current help project is displayed on the Word status bar when you 
use a HelpBreeze command.



Compiling and Viewing Your Help File
To compile your help file, click the "C" button on the toolbar.    This will start the help 
compiler. (The help compiler must be installed in a directory which is included in your path.)  
Try this now.

By default, HelpBreeze will compile your help file in the background, so that you can 
continue working while the compilation takes place.    A small caption box will be displayed at
the top-left of your screen while the compilation is in progress.    When the compiler finishes, 
the caption box will disappear, and a beep will sound.    If you wish, you can turn off the beep
or set HelpBreeze to compile in the foreground (displaying a DOS box with compiler 
messages) in the Compiler Options dialog box (see Lesson #10 of this tutorial).    

Once compilation is complete, you can investigate any warnings or errors by using the View
Compiler Errors command.

This example includes one warning in topic #15:    There is a jump to an undefined topic: 
"idx_an_undefined_topic."

To view compiler errors

1. From the View menu, choose Help Compiler Errors.    The Compiler Errors dialog will 
appear.

2. To move directly to the topic which caused an error or warning, double click on the line in
the Compiler Errors dialog. 

To view and test the resulting help file, click the "H" button. 



Creating and Editing Jumps and Pop-ups
Every Windows help file is divided into topics.    You can easily identify the topics in a 
HelpBreeze document: each topic is preceded by a "hard" page break as well as one or more
footnote reference marks (i.e. #, $, +, etc.).    The help compiler uses these footnotes to 
construct the help file.    Don't worry about the details of this formatting; HelpBreeze will take
care of this for you. 

Each topic deals with a specific subject and has a unique identifier called a context string.  
When you create a hypertext jump, you link the jump to the proper topic by selecting a 
context string from the database maintained by HelpBreeze.

The first two items in the list below have been defined as hypertext jumps.    The green 
underlined text is called the hotspot text.    When you compile and view your help file, you 
will be able to click this text to execute the jump.

With HelpBreeze, you can execute hypertext jumps within Word for Windows.

Topic A <--- Double click the red "test button" to execute the jump in WinWord    
Topic B 

 Topic C    
Topic D    

You can use the red test buttons and the "GoBack" button (the footsteps) on the toolbar to 
move around your document and test the linkage of your jumps.    This is a very useful way 
to navigate while you are developing your help file.    HelpBreeze will keep track of up to 20 
nested jumps; cursor movements other than hypertext jumps will not affect the operation of 
the GoBack function.

Try making the "Topic C" text above into a hypertext jump.    

To do this, you simply select the text, press "J" on the toolbar and then, when the Insert 
Jump dialog box appears, select the identifier (context string) for Topic C.    This will appear 
as "idx_topic_c" in the list.    Double click or press OK to confirm your choice.

If you succeeded, "Topic C" above should now be formatted similarly to the other two jumps. 
Try double clicking on the test button to see if the linkage is correct. 

You can edit the hypertext linkage for an existing jump using the same command.    Place 
the cursor anywhere on the underlined portion of the hotspot text and press the "J" on
the toolbar.    HelpBreeze extracts the necessary information from your document and 
displays it in the dialog, where you can edit it. 

Pop-up definitions work in a similar fashion to jumps:

Topic A
Topic B    

 
Note that the test buttons treat pop-ups as though they are jumps.    Try making "Topic B" 
into a pop-up definition word by selecting the text and pressing the "D" (for definition) 
button on the toolbar.    

A number of advanced options are available when creating jumps and pop-ups.    For 
example, you can specify custom colored hotspot text, use secondary windows, or create 
jumps to other help files.    You can also use the search utility (magnifying glass icon) to 



quickly select the proper context string in a large help file with many topics.    For more on 
these features, please see Chapter 6 of the User's Guide, or if you prefer, try experimenting 
with the various options on your own.

If you make a mistake when creating a jump or pop-up hotspot, you can use the Undo 
Hotspot command to convert the hotspot back to plain text and then try again.    Here's an 
example of a hotspot in which we missed the end of the click text:

This is the click text.

To fix this hotspot:

1. Place the cursor anywhere on the double underlined portion of the text and Select 
Undo Hotspot from the Edit menu.

2. Select "This is the click text" and use the Insert Jump command to create a new 
hotspot.



Creating and Editing Help Topics
Now try inserting a new topic.    We'll use the line below as the heading for the new topic.
    

A New Topic

To insert a new topic, you need to follow these steps:

1. Move the cursor to the point where you want to start the new topic.    This could be the 
end of the document, but you can insert a new topic at any point.    If a heading for the 
topic already exists in your document, place the cursor anywhere on this line.    If a 
heading hasn't yet been entered for the new topic, place the cursor at the beginning of 
a blank line.

For this example, we'll use "A New Topic," above as the heading for the new topic.    
Place the cursor on this line. 

2. Press "T" on the toolbar to bring up the Insert Topic dialog box.    

3. Note that the heading, "A New Topic," appears in the title box.    If no heading is present 
in the document, you can type the title after you bring up the dialog box.

4. Note that HelpBreeze has suggested a context string identifier based on the topic 
title.    You can change this if you wish.    

5. If you wish, set the browse sequence for the topic.    The browse sequence determines
the order in which the topic will be displayed when the user clicks the << or >> 
buttons on the WinHelp button bar.    You can set the browse sequence relative to 
another topic by simply selecting the topic in the "Existing Topics" list.    Try clicking on 
the various context strings in this list and notice how the browse sequence number for 
the new topic changes to follow the topic you select.    You can also type in a new 
browse group and sequence number. 

As an alternative, you can set browse sequences on a global basis by using the Edit 
Group command; this command is covered in the last lesson of this tutorial.

6. Add keyword(s) (search words) for the topic by entering the word and pressing the 
Add button.    By default, HelpBreeze will use your topic title as keyword text.    You can 
change this in the HelpBreeze Preferences dialog (see Lesson #10 of this tutorial).

7. Press OK to insert the topic.    Note that HelpBreeze inserts the necessary footnotes and 
formats the topic heading.

Note: A number of more advanced options, such as specifying build tags and topic entry 
macros and attaching the help topic to a specific help window, are available by pressing the 
More button in the Insert Topic dialog.    These options are covered in Chapter 5 of the User's 
Guide and in Examples 2-6. 

As with hypertext jumps, you can edit existing help topics by using the same command 
you use to insert them.    To edit a topic, place the cursor anywhere on the topic heading line 
(the line with the footnote reference marks: #, $, etc.).    Press the "T" on the toolbar, and 
HelpBreeze will extract the topic information and display it in the Insert Topic dialog.    Try 
this with any of the topics defined in this file.





Jumping to a Specific Help Topic
The test buttons inserted with hypertext jumps and pop-ups provide one useful method of 
navigating while you are developing your help file.    A second method is the Goto Topic 
command.    This command allows you to jump directly to any topic in your help file.    If you 
choose a topic which is located in another Word document, the file will automatically be 
opened for you.

Try using the Goto Topic command:

1. From the Edit menu, choose Goto Topic.

2. Double Click any topic in the list.    You will jump directly to the start of the topic.



Inserting and Editing Graphics
You can also insert graphics into your help files either just as illustrations or to be used as 
clickable hotspots for jumping to other topics.

 This bitmap displays Topic B in a pop-up window.

 This bitmap is not used as a hotspot.    HelpBreeze uses the magenta color to identify 
bitmap references.

You can edit an existing graphic by placing the cursor between the brackets {} and pressing 
the "G" (for graphic) on the toolbar.    Try this with the two happy face bitmaps above.    
Notice that the first bitmap has the Use as Hotspot box checked and is specified to be a pop-
up definition.

To try inserting a bitmap, place the cursor at the point where you want to insert a new 
bitmap and click the "G" button on the toolbar.    When the Insert Graphic dialog box 
appears, use the Select button to find a bitmap file with a .BMP extension.

After you select the file, the image should be displayed in the dialog box.    Press OK to insert
the bitmap.    When you compile and view your help file, you will see the actual graphic.    



Using Bullet Points and Numbering

HelpBreeze modifies the standard Word for Windows bullet and numbering tools so that you 
can use these commands while developing help files.    To create a numbered list, you simply
use the normal Word for Windows procedure.    

HelpBreeze provides two choices for bullet points: 

· You can use normal Word for Windows bullets from font sets such as the Symbol font.    
This option generally limits you to a few round bullet styles.    You cannot use bullet 
characters from fonts such as WingDings because these fonts are not available to the 
help engine.

You can use bitmaps as bullet points.    This method provides maximum flexibility.    

You can use square bullets, which generally look better in help files.    

You can also use special bullet characters for specific purposes.    

Using bullet points is a two-step process.    You first select the type of bullet you want to use. 
Then you create the bullet(s) using the normal Word for Windows bullet tool.

To select the bullet style

1. From the Format menu, choose Select Bullet Style.    The Select Bullet Style dialog will 
appear.

2. Select either standard Word for Windows bullets or one of the available bitmap styles and
press OK to confirm your selection.    This selection will remain in effect for all future 
bullet points until you change it. 

To create a bullet list

1. Select the paragraph(s) you want to convert to a bullet list.    If you are converting a 
single paragraph, you can place the cursor anywhere in the paragraph. 

2 Press the Bullet Tool on the Word for Windows toolbar.



Inserting and Editing SHED hypergraphics
You can also insert segmented hypergraphics created with the Microsoft Hotspot Editor 
(SHED.EXE).    Hypergraphics can contain a number of specific hotspots which are linked to 
help topics.    

You insert hypergraphics using the Insert Graphic command.    Try editing the graphic 
reference below by placing the cursor between the brackets {} and pressing "G" on the 
toolbar:

Notice that this bitmap is not defined to be a hotspot.    This is because the hypertext links 
are already defined inside the graphic file itself.

If you compile and view this file, you will see that this graphic shows a sample dialog box.    
The "One" and "Two" radio buttons are linked to Topic A and Topic B respectively.    If you click
on these controls while viewing the help file, the corresponding topic will be displayed in a 
pop-up window.

To create hypergraphics, you must have the Microsoft Hotspot Editor (SHED.EXE) installed in 
a directory referenced in your DOS path.    If you have the Hotspot Editor installed on your 
system, try editing the file "dialog.shg" now:

1. From the Tools menu, select Hotspot Editor.    The Hotspot Editor will appear, together 
with a floating palette containing a listbox with the context strings for the help project.

2. From the Hotspot Editor's File menu, choose Open.    Then use the Open dialog to select 
the file "dialog.shg."    This file should be located in the same directory as this document. 

3 Using the mouse, draw a box around radio button "Three."    While holding down the left 
button, drag the mouse to form a box.    This box will constitute the hotspot area you are 
about to define. 

4. Double click the new box with the mouse.    The Attributes dialog will appear.    Select the 
type of link you want to create--either pop-up or jump.

5. In the floating palette, double click the context string    "idx_topic_c."    This value will be 
inserted into the Context String area of the Attributes dialog.    Press the OK button in the 
Attributes dialog.

6. Exit the Hotspot Editor and save your changes to "dialog.shg."

7. Re-compile and view the help file.    Radio button "Three" should now be linked to Topic C.



Inserting and Editing Hotspot Macros
You can create hotspot macros in a similar fashion to jumps and pop-ups.    Here is an 
example of a macro to execute the Windows Calculator:

Click Here to See the Calculator

Try editing this hotspot by placing the cursor on the underlined portion of the text and 
choosing Macro Hotspot from the Insert menu.    When the Insert Macro dialog appears, 
press the Edit button to bring up the Macro Editor.    Notice that this hotspot is linked to the 
ExecProgram (EP) macro.    Try executing this macro after you compile the help file.    

For more on macros, see Chapter 9 of the User's Manual and Examples 2-4.



Setting Compiler Options and HelpBreeze Preferences
Take a quick look at some of the options available from the Set Help Project command 
under the Tools menu.    You used this dialog earlier to set the project.    A number of 
functions are accessible through this dialog:

You can set Compiler Options for the help compiler.    There are several levels of dialog 
boxes to cover all the options.    Your choices will be incorporated into the help project file 
generated by HelpBreeze when you compile your help project.    

You can define start-up macros to configure your help file and create custom buttons.    
Example 2 covers the use of the Button Editor for creating and managing WinHelp buttons 
visually.

You can define the characteristics of the main and secondary windows.    Example 3 
shows how to use help windows.    

You can set HelpBreeze preferences.    These are items which govern the way specific 
procedures work within HelpBreeze.    

Take a few moments to explore these dialog boxes.    Remember that every dialog box is 
linked to the HelpBreeze help file via the Help button.



Converting Help Topic Files to Printed Documentation
The HelpBreeze Convert to Document command provides a quick way to get a printed 
copy of any portion of your help file without all the cryptic formatting and footnotes required
by the help compiler.    This command is also very useful for incorporating material in your 
help files into users manuals and other printed documentation.

To get a hard copy of this file, first choose Select All from the Edit menu, then choose 
Convert To Doc from the Tools menu.    Check the Remove Hard Page Breaks box.    Then 
Press OK.    HelpBreeze will create a copy of this document and remove all the special 
formatting.    You can then print and close the new document. 



Generating Help Topic Reports
HelpBreeze will generate a report listing all the topics and hotspots in your help file.    This 
is very useful if you are working on a large file.    You can print these reports and use them as
an aid in the development process.

To try generating a report, select Topic Report from the Tools menu.    When the Report 
dialog appears, press OK.    After the report has been generated, it will be opened as a Word 
document.

Note that you can sort the report based on a number of different parameters.



Editing Topic Groups and Browse Sequences
 
One of the most powerful HelpBreeze features is the Edit Group command.    This command
allows you to manipulate groups of topics and browse sequences on a global basis.    You can
do one or both of the following:

· Define, reorder, or renumber a browse sequence.    Often it is easier to quickly set a 
browse sequence using this command than to do it on a topic-by-topic basis using the 
Insert Topic command.

· Automatically create a parent topic for a group of topics.    The parent topic has a 
hypertext jump to each of the topics in the group.

Lets try using the Edit Group command to redefine the browse sequence and create a parent
topic for the group consisting of Topic A, Topic B, and Topic C.

<<<Create a a group topic here>>>

  
1. Position the cursor on the "Create a group topic here" line above.    The parent topic will 

be created immediately after this line.

2. From the Edit menu, choose Group.    The Edit Topic Group dialog box will appear.

3. In the "Topics in this Document" list, select the three topics which will form the group 
(idx_topic_a, idx_topic_b, and idx_topic_c).    You can select all three topics by selecting 
idx_topic_a and dragging down with the mouse.

4. Press the Add button.    The topics will appear in the Define Group list.    Try changing the 
order of the topics in the group by dragging a line in the list to a new position. 

5. Check the Set Browse Sequence box.

6. The current browse group name for these topics is "grp1."    This will be displayed in the 
Group Name box.    Change this to something else (for example "brws1").    If you wish, 
you can also change the starting number and the increment.    

7. Check the Create Parent Topic for Group at Current Cursor Location box.

8. Type a title for the group topic to be created and press OK.    HelpBreeze will set the 
browse sequence and create the group topic.

When you are finished, try editing Topic A through C with the Insert Topic command to see 
how the browse sequence has been changed.
 



Topic A

This is Topic A.

If you got here by double clicking a test button, you can return to where you came from by 
using the "GoBack" button (the footsteps) on the toolbar. 

The help compiler will generate a warning here because no topic has been defined to 
correspond to context string "idx_an_undefined_topic."        

You can view the target context string for a jump or pop-up by clicking the Show All button 
on the Word for Windows Ribbon (below the toolbar).    This is the button with the paragraph 
symbol on the far right.      When you click this button, the context string, which is formatted 
as hidden text, will appear.

If you prefer to work with the target context strings for jumps and pop-up always visible, you
can select Options from the Tools menu, click the View icon on the left side of the dialog box,
and then check the Hidden Text box.      

Notice that if you use the Insert Topic command to create or edit a topic, you will see the 
following line at the top of the existing topics list:

--undef-- #idx_an_undefined_topic

This indicates that this context string has not yet been defined in the help file.    HelpBreeze 
allows you to define context strings at the time you create jumps or pop-ups.    To do this, 
you type a new context string in the Insert Jump or Insert Pop-up Definition dialog, rather 
than selecting one of the existing context strings.    This capability is useful because it is 
difficult (or impossible) to define every topic before it is referenced elsewhere in the help 
file.

When you define a new context string in this way, HelpBreeze flags it as undefined in the 
Insert Topic dialog as shown above.    When you get around to implementing the 
corresponding topic, you can use the context string by double clicking it in the Existing 
Topics list. 



Topic B

This is Topic B.

If you got here by double clicking a test button, you can return to where you came from by 
using the "GoBack" button (the footsteps) on the toolbar. 



Topic C

This is Topic C.

If you got here by double clicking a test button, you can return to where you came from by 
using the "GoBack" button (the footsteps) on the toolbar. 




