Abakt?

Abakt Logo Manuale di Abakt
Indice dei contenuti | Successivo: Modifica profilo

Abakt?

Abakt è un programma libero (licenza GPL) e gratuito per Windows.

Per una breve panoramica, vai all'Introduzione.

Caratteristiche principali
Filtri

Potrete selezionare file o cartelle usando i caratteri jolly, impostazioni ed altre maschere avanzate.
Potrete applicare filtri basati sugli attributi, dimensione, età e data di modifica dei file.

Backup (Archivio)

Creerete un archivio zip nello standard PKZIP per mezzo della libreria integrata.
O richiamerete, da linea di comando, il programma 7-Zip, per creare archivi.
Potrete anche copiare, spostare o eliminare i file selezionati.

Automazione

Abakt accetta gli argomenti da linea di comando.
Userete le opzioni della linea di comando per pianificare le operazioni, ma potrete anche scrivere i vostri script batch.

  • Introduzione
  • Requisiti
  • Installazione
  • Donazioni
  • Licenza

Generated using AurigaDoc


Introduzione

Indice dei contenuti | Su: Abakt? | Prossimo: Requisiti

Introduzione
Cosa è possibile fare con Abakt:

A dispetto del suo nome e delle sue prime intenzioni, Abakt può fare qualcosa di più che creare backup:

Lo scopo di Abakt è di selezionare i file e permettere ulteriori 'operazioni', utilizzando le potenti capacità di filtraggio del programma.

Selezionare i file e...
Scegliere i file (usando i filtri)...

  • Scegliere le cartelle da includere nella pagina Origine Dati [F6].

  • Creare Filtri per specificare su quali file intervenire.

    I file nelle cartelle non selezionate (non spuntate) saranno ignorate per tutto il resto del processo di filtraggio.

  • Anteprima della lista dei file selezionati

    Prima di eseguire un'Azione, date uno sguardo alla lista dei file creata accedendo al menu Strumenti/ Anteprima filtro... Se un file che dovrebbe esserlo non è presente nella lista, potrete rivedere le impostazioni del filtro attivo.

Eseguire ulteriori 'operazioni' sui file selezionati...

  • Scegliere il tipo di Azione che si vuole eseguire sui file selezionati. Potrete archiviare, copiare, spostare o eliminare file.

    Facoltativo: potrete istruire Abakt come trattare un file in base al proprio attributo. Utile per creare backup Interi, Differenziali o Incrementali.

  • Modificare le impostazioni dell'Azione scelta a vostro piacimento.

  • Impostare la Destinazione.

  • Decidere che cosa fare quando un'Azione si conclude con successo, impostando le opzioni alla pagina Concludi.

Eseguire il profilo

  • Cliccare sul pulsante 'Esegui profilo' posto in alto a destra della finestra principale.

  • Si aprirà la finestra Azione e mostrerà l'avanzamento del profilo attuale.


Requisiti

Indice dei contenuti | Su: Abakt? | Precedente: Introduzione | Successivo: Installazione

Requisiti

Abakt richiede i seguenti requisiti:

  • Windows 95, 98, 98SE, ME, XP (SP1/SP2) o 2003.
  • Una CPU Pentium.

Abakt può essere eseguito anche su piattaforma Unix/Linux usando wine [http://www.winehq.org].


Installazione

Indice dei contenuti | Su: Abakt? | Precedente: Requisiti | Successivo: Donazioni

Installazione
Installatione

Per installare Abakt, eseguire il file di setup e seguire le istruzioni.
Non è necessario disinstallare le versioni precedenti di Abakt, prima di installare una nuova versione.

Disinstallazione

Usare l'uninstaller: 'Pannello di Controllo / Installazione applicazioni'.

Durante la disinstallazione, Abakt rimuove tutti i file nella cartella del programma. Saranno altresì rimossi tutti i riferimenti ad Abakt dal Registro di Windows.

Opzionale: i file salvati nella cartella "Dati Applicazioni" potranno essere eliminati permanentemente.


Donazioni

Indice dei contenuti | Su: Abakt? | Precedente: Installazione | Successivo: Licenza

Donazioni
Abakt è un software gratis

Io passo più tempo possibile a lavorare ad Abakt e a rispondere alle vostre domande, consigli e segnalazioni di errori.
Se usate Abakt regolarmente, considerate la possibilità di donare una piccola somma di denaro.

Come fare una donazione:

Cliccate sull'immagine qui sotto per accedere alla pagina di pagamento sicuro di PayPal.com:
Se non avete un account PayPal, potrete fare ugualmente una donazione usando la vostra carta di credito o il vostro conto bancario.

Per maggiori informazioni, vai alla pagina per le donazioni del mio sito: http://www.xs4all.nl/~edienske/abakt/donate.html.

Grazie per il vostro incoraggiamento ad Abakt! - Erik

Nota: L'indirizzo e-mail che io uso per le donazioni PayPal non è quello che uso per l'invio di report di bug del programma, ecc. L'indirizzo per le donazioni di PayPal inizia con ediesoft-, che significa "E(rik) Die(nske) Soft(ware)".


Licenza

Indice dei contenuti | Su: Abakt? | Precedente: Donazioni

Licenza

Abakt è un programma gratuito, coperto dalla GNU General Public License.

Dove trovare la licenza

La licenza GNU General Public License è inclusa nell'installer e può essere letta all'indirizzo http://www.xs4all.nl/~edienske/abakt/license.html. È anche disponibile come file di testo (LICENSE.TXT) nella distribuzione del codice sorgente di Abakt.

Ulteriori informazioni sul Software Libero:
  • Wikipedia: GNU General Public License.
  • www.gnu.org
  • www.opensource.org


Modifica profilo

Indice dei contenuti | Precedente: Abakt? | Successivo: Strumenti

Modifica profilo

Per una breve panoramica sull'uso di Abakt, vedi l'Introduzione.

  • 1 - Origine dati
  • 2 - Filtri
  • 3 - Azione
    • Tipo di Azione
    • Impostazioni tipo di Azione
      • Zip
      • 7-Zip
      • Operazioni sui file
    • Destinazione
  • 4 - Concludi
    • Registro eventi


1 - Origine dati [F6]

Indice dei contenuti | Su: Modifica profilo | Successivo: 2 - Filtri

1 - Origine dati [F6]

Scegliete le cartelle e i file desiderati da processare.

Le cartelle non selezionate saranno ignorate durante l'intero processo di filtraggio.

Cartelle

Questo pannello mostra l'albero delle cartelle di ogni directory radice.

Potrete contrassegnare una cartella che dev'essere inclusa o esclusa nelle successive operazioni. Le nuove cartelle (che non esistono al momento della creazione del profilo) ereditano lo stato di selezione della cartella superiore.

Ulteriori importanti funzioni sono a disposizione cliccando sul pulsante 'Altro...'. Queste funzioni sono anche accessibili cliccando col pulsante destro del mouse.

File

Questo pannello mostra tutti i file (e le proprietà) nella cartella aperta.

Cliccate sull'intestazione di una colonna o su un'icona del filtro per cambiare l'ordinamento.

La colonna 'Regole filtro' mostra le prime Regole filtro applicate a quel file (se esistono). Potrebbe apparire la scritta 'Cartella non selezionata', che non è una Regola filtro.

Le icone filtro

Abakt usa le seguenti icone per mostrare lo stato del filtro:

  • Escluso (X gialla)
    Il file sarà ignorato durante l'intero processo di filtraggio.
  • Incluso (quadrato blu chiaro)
    Il file è selezionato (e sarà incluso nel backup).
  • Non compresso (quadrato blu scuro)
    Il file sarà incluso ma non compresso.

Cliccate sul pulsante 'Regole filtro...' per far apparire un menu che vi aiuta nella scelta o per modificare le Regole filtro. Questo menu apparirà anche se usate il pulsante destro del mouse.


2 - Filtri [F7]

Indice dei contenuti | Su: Modifica profilo | Precedente: 1 - Origine dati | Successivo: 3 - Azione

2 - Filtri [F7]

Modifica e crea i filtri che Abakt userà per scegliere i file.

Le cartelle non selezionate saranno ignorate per l'intero resto del processo di filtraggio.

Vedi la sezione Introduzione per una breve panoramica su come si usa Abakt.

Regole filtro
Cosa sono le Regole filtro?

Le Regole filtro sono un insieme di proprietà e condizioni:

  • Le Proprietà dichiarano le Regole filtro e indicano ad Abakt come si dovrà comportare quando le condizioni si verificheranno.
  • Le Condizioni consistono in un gruppo di filtri delle proprietà dei file. Ogni condizione dovrà essere soddisfatta, perchè le Regole filtro siano applicate.

CONSIGLIO: Se pensate che le Regole filtro siano troppo complesse, vi converrà usare prima la Maschera del percorso.

Come funzionano?

Abakt verifica le seguenti condizioni, per determinare se un file debba essere incluso oppure no:

  • Ogni condizione non-vuota deve essere vera perchè queste Regole filtro siano applicate (operatore logico AND).
  • Una condizione vuota comporterà che le proprietà del file saranno ignorate.
  • Le espressioni delle condizioni devono essere separate da un punto e virgola (;), e saranno interpretati come operatori logici OR.
Un esempio :

Le condizioni sono interpretate in modo logico come AND (ogni condizione deve essere vera perchè le Regole filtro siano applicate). Le espressioni delle condizioni (separate da un punto e virgola) saranno interpretate in modo logico come OR.

Condizioni delle Regole filtro:

Percorso = "*.doc";
Dimensione Size = "<1024; >312k"

Pseudo codice:
SE (
     (il nome del file ha l'estensione '.doc')
     E (
         (la dimensione del file è inferiore a 1024 Bytes)
         OPPURE (la dimensione del file è maggiore di 312 kiloBytes) )
) ALLORA l'azione sarà eseguita
Regole filtro - Proprietà
Nome

Il nome che descrive l'Azione. Può essere qualsiasi testo si vuole.

Azione

L'Azione può avere i seguenti valori:

  • Esclusi
    Questa regola è usata per specificare i file da escludere.
  • Inclusi
    Questa regola è usata per specificare i file da includere, sempre.
  • Nessuna compressione
    Non influenza il processo di filtraggio, ma solo il livello di compressione dei file inclusi.
Abilitato

Potete attivare o meno le Regole filtro, impostando questa opzione.

Regole filtro - Condizioni
Percorso (Maschera)

Sintassi: MASCHERA

Creare una MASCHERA per scegliere i file in base al percorso e/o al nome del file.
Una MASCHERA può contenere caratteri jolly, il carattere pipa e serie di caratteri.

Caratteri jolly : * ?
  • * : Un insieme di caratteri.
  • ? : Un singolo carattere.
  • Se la maschera contiene un \ i file corrisponderanno al loro completo percorso (unità incluse).

Dovrete usare * per scegliere un qualsiasi file, e non *.* .

Carattere pipa: |

Usare il carattere pipa per separare la parte indicante il nome di quella cartella dal nome del file. Ciò permette di creare filtri più complessi.

Sintassi:maschera-cartella|maschera-nomefile

Serie di caratteri : [a-z] [!0-9] [12.ad#$]
  • Ogni serie dev'essere racchiusa tra parentesi quadre: [serie].
    Tra le parentesi quadre ci sono gli elementi della serie. Ogni elemento dev'essere un carattere letterale o un intervallo.
  • Gli intervalli sono specificati da un valore iniziale, un trattino (-), e un valore finale: [a-z].
    Non inserire spazi o virgole per separare gli elementi della serie.
  • Una serie deve corrispondere ad un solo carattere della stringa. Il carattere corrisponde alla serie se è uguale ad uno dei caratteri letterali nella serie, o se è compreso nell'intervallo della serie.
  • Un carattere è compreso in un intervallo se corrisponde al valore iniziale, finale, o se è compreso tra i due valori. Ogni comparazione non è sensibile alle maiuscole/minuscole.
  • Se il primo carattere dopo la parentesi di apertura di una serie è un punto esclamativo (!), la serie sarà comparata con qualsiasi carattere che non sia nella serie stessa.
  • Esempio di una maschera con il carattere [ : *[[]*
    Esempio di una maschera con il carattere ] : *]*
Esempi di maschere:
  • *\temp\*|*
    Seleziona tutti i file nelle cartelle con il nome 'temp'.
  • C:\Documents and Settings*\temp\*|*
    Seleziona tutti i file nelle cartelle nominate 'temp' sotto 'C:\Documents and Settings'.
  • *parte-di-nomecartella*|*.doc
    Seleziona tutti i file .doc nelle cartelle con il nome che contiene 'parte-di-nome-cartella'.
Dimensione (Bytes)

Sintassi: [ < <= == != >= > ] VALORE[K|M|G] [;]

VALORE è la dimensione del file espresso in bytes, e deve essere un numero positivo o 0.

Le altre dimensioni consentite sono: '1K', '2M' or '3G'. Non dovranno essere inseriti spazi tra i numeri e [K|M|G].

Formato in virgola mobile: '1.23M' non sono ancora permessi.

Esempio:

Se l'Azione è "Escludi" questa condizione: "<1024; >2G" escluderà tutti i file più piccoli di 1024 bytes o più grandi di 2 GB.

Data (yyyy-mm-dd)

Sintassi: [ < <= == != >= > ] VALORE [;]

VALORE è la data di modifica del file, e dev'essere formattata come yyyy-mm-dd'.

Età (giorni)

Sintassi: [ < <= == != >= > ] VALORE [;]

VALORE è l'età del file in giorni, e dev'essere un numero positivo o 0.

Attributi (H,R,S)

Sintassi: [ == != ] VALORE [;]

VALORE l'attributo del file indicato con una tra le seguenti lettere H, R, S (sensibili alle maiuscole).
Dove H='Nascosto', R='Sola lettura' e S='Sistema'.

Se un attributo non è specificato, questa opzione sarà ignorata.

Sebbene sia possibile usare la lettera -A-, non è consigliabile: il bit archivio -A- è condiviso da Abakt quando esegue un backup. Vedi Tipo d'Azione / Tipo di backup.

Esempi:

Eseguire l'Azione se gli attributi R e H sono impostati: '==RH'.
Eseguire l'Azione se l'attributo S non è impostato: '!=S'.

Un diagramma

Questo diagramma rappresenta graficamente il funzionamento del motore di un filtro di Abakt:


3 - Azione [F8|F9|F10]

Indice dei contenuti | Su: Modifica profilo | Precedente: 2 - Filtri | Successivo: 4 - Concludi

3 - Azione [F8|F9|F10]

Sceglie e specifica il tipo di Azione che Abakt dovrà eseguire.

  • Tipo di Azione
  • Impostazioni tipo di Azione
    • Zip
    • 7-Zip
    • Operazioni sui file
  • Destinazione


3a - Tipo di Azione [F8]

Indice dei contenuti | Su: 3 - Azione | Successivo: Impostazioni tipo di Azione

3a - Tipo di Azione [F8]
Tipo di Azione

Scegliere tra creare un archivio o eseguire una operazione sui file.

Per maggiori informazioni, vedi Impostazioni tipo di Azione.

Crea Archivio
  • Zip
    Usa la libreria integrata in Abakt (ZipBuilder) per creare un archivio.
    Vedi Impostazioni tipo di Azione- Zip.
  • 7-Zip
    Chiama l'applicazione 7-Zip da linea di comando (se installata) per creare archivi Zip o 7-Zip.
    Vedi Impostazioni tipo di Azione - 7-Zip.
Operazioni sui file
  • Copia
    Copia i file selezionati dall'Origine dati alla Destinazione.
  • Sposta
    Sposta i file selezionati dall'Origine dati alla Destinazione.
  • Elimina
    Elimina i file selezionati (!).

Vedi Impostazioni tipo di Azione - Operazioni sui file .

Tipo di backup
Come trattare l'attributo archivio (A)?
  • Default
    Usa tutti i file selezionati (ignorando l'attributo archivio).
    Non modifica l'attributo archivio.
  • Completo
    Usa tutti i file selezionati (ignorando l'attributo archivio).
    Resetta l'attributo archivio dopo l'Azione.
  • Differenziale
    Usa solo i file -A-. (I file con l'attributo archivio impostato).
    Non modifica l'attributo archivio.
  • Incrementale
    Usa solo i file -A-. (I file con l'attributo archivio impostato).
    Resetta l'attributo archivio dopo l'Azione.
  • Inverso
    Usa solo i file non -A-. (I file senza l'attributo archivio impostato).
    Non modifica l'attributo archivio.


3b - Impostazioni tipo di Azione [F9]

Indice dei contenuti | Su: 3 - Azione | Precedente: Tipo di Azione | Successivo: Destinazione

3b - Impostazioni tipo di Azione [F9]

A seconda del Tipo di Azione selezionato, Abakt mostra automaticamente la pagina appropriata.

  • Zip
  • 7-Zip
  • Operazioni sui file


Zip

Indice dei contenuti | Su: Impostazioni tipo di Azione | Successivo: 7-Zip

Zip

Il tipo di Azione 'Zip' usa la libreria integrata per creare archivi compressi.

Le limitazioni di un archivio Zip creato con la libreria integrata sono:
  • La dimensione totale dell'archivio è limitata a 4 GB.
  • Il numero totale di file in un archivio è di 65535.
  • Ogni singolo file che sarà aggiunto in un archivio, non potrà essere più grande di 2 GB.
Modalità archivio

Indica ad Abakt come trattare i file nei (se già esistenti) archivi Zip.

  • Nuovo
    Crea un nuovo archivio Zip che non sovrascrive un archivio Zip già esistente con lo stesso nome di file.
    Se un archivio Zip con lo stesso nome esiste già, il nuovo nome del file avrà un suffisso quale (++nr).
  • Sostituisci
    Sarà creato un nuovo archivio Zip, sovrascrivendo (se esiste) un archivio Zip esistente con lo stesso nome.
    Se esiste già un archivio Zip con lo stesso nome, esso sarà copiato in un file temporaneo. (Potrete disabilitare questa opzione nella pagina delle Preferenze.) Quando l'Azione si concluderà con successo, la copia temporanea sarà eliminata.
  • Aggiorna
    I file in un archivio Zip già esistente, saranno aggiornati con quelli di versione più recente.
    I nuovi file (che non sono stati trovati nell'archivio Zip) saranno aggiunti.
    I file nell'archivio Zip che non esistono più su disco, non saranno eliminati dall'archivio Zip.
  • Meno recenti
    I file in un archivio Zip che hanno versioni più recenti su disco, saranno sostituiti (aggiornati).
    Non sarà aggiunto nessun file nuovo all'archivio Zip.

Le opzioni 'Aggiorna' o 'Meno recenti' non hanno influenza sul nome dell'archivio Zip che usa un nome di modello con data/ora dinamici.

Informazioni sul percorso

È l'informazione sul percorso da memorizzare in ogni file dell'archivio Zip.

  • Completo
    Nell'archivio sarà contenuta l'intera struttura (tutte le sottocartelle) della cartella di origine (senza informazioni sull'unità).
  • Relativo
    Sarà memorizzato solo il percorso relativo della cartella di origine.
    Questo significa che l'archivio conterrà comunque l'informazione del percorso della cartella di origine.
    Potrebbero verificarsi dei conflitti se alcuni file in due cartelle di origine differenti (non importa di quale unità) condivideranno la stessa combinazione di percorso/nome.
  • Nessuno
    Nessuna informazione sul percorso.
    In altre parole, i file saranno memorizzati nell'archivio Zip così come sono, senza percorso o informazioni sull'unità.
    Potrebbero verificarsi dei conflitti se i file nella cartella di origine (non importa di quale unità) condivideranno la stessa combinazione di percorso/nome.
Compressione

Un valore tra 0 e 9:
0=Nessuna; 1=Veloce; 6=Normale; 9=Massima

Password

Abakt immagazzina la password nel profilo (file .abp) come testo normale. Assicuratevi che la vostra cartella Data/Profiles non sia accessibile a qualcun'altro.

Divisione (e Distribuzione)

Un archivio Zip può essere diviso in più parti. La dimensione di ogni parte è definita dalla dimensione dell'unità.

  • Se la dimensione dell'unità è impostata su 'Personalizzata', potrete modificare la dimensione di ciascuna parte, richiamando l'editor 'Dimensione personalizzata', cliccando sul pulsante '...'.
  • Ogni parte avrà un nome tipo: '[NomeProfilo].z##', dove ## è un numero da 01 a 99.
  • L'ultima parte sarà nominata '[NomeProfilo].zip'.
    Sarà questo file di cui avrete bisogno per aprire e ripristinare un backup (usando qualsiasi decompressore compatibile PKZIP, o Abakt).
La differenza tra Divisone e Distribuzione è che:
Un archivio Zip diviso può essere salvato dovunque, il più delle volte su dischi non removibili (dischi rigidi).
Un archivio Zip distribuito è diviso in più parti che dovranno essere salvate su un disco removibile (floppy disk).
Aggiungi commenti

Usa le stesse regole di formattazione come nel modello creato nella pagina Destinazione.


7-Zip

Indice dei contenuti | Su: Impostazioni tipo di Azione | Precedente: Zip | Successivo: Operazioni sui file

7-Zip

Questo tipo di Azione usa la lista dei file generata da Abakt come input per l'applicazione 7z.exe, lanciata da linea di comando.

Dovrete prima scaricare ed installare 7-Zip voi stessi.

Consiglio: Potrete "ingannare" Abakt ed usare Rar.exe invece che 7z.exe, impostando l'opzione nella pagina Preferenze/Azione. Rar non è gratis.

Limitazioni degli archivi creati con 7-Zip:
  • Archivi Zip (.zip):
    Dal manuale: "7-Zip supporta le estensioni Zip64 del formato ZIP". Io penso che sia una modalità automatica. Ho usato 7-Zip, versione 4.32 e ho creato archivi zip più grandi di 4 GB senza alcun problema.
    Questi grandi archivi zip non possono però essere estratti con la libreria interna di Abakt. Si dovrà usare 7-Zip Manager, IZArc o WinZip.
  • Archivi 7-Zip (.7z)
    Praticamente nessuno.
    Vai all'indirizzo www.7-zip.org, per i dettagli sul formato 7z.
Linea di comando
Anteprima

I parametri da linea di comando che userete quando chiamerete l'eseguibile 7-Zip.

Modello

Vi aiuterà a scrivere la linea di comando con la quale sarà chiamato 7z.exe.
Usate le variabili qui sotto elencate, per rendere più facile il compito..
Esempio: "$C $T $N -mx=5 $P $W $L".
Consultare il manuale di 7-Zip per ulteriori informazioni sulla sintassi della linea di comando.

Variabili

Di seguito troverete le variabili che potrete usare nel modello della linea di comando.
Le variabili sono sensibili alle maiuscole/minuscole.

$C - Comando

a=Aggiungi; u=Aggiorna

$T - Tipo archivio

7z.exe supporta molti tipi di compressione. Essi sono passati a 7z.exe, usando l'opzione -t nella linea di comando. I più comuni sono '7z' e 'zip'.
Il tipo scelto influenza anche l'estensione dell'archivio (non inserire alcun punto '.').
Consultate il manuale di 7-Zip per una descrizione dell'opzione -t della linea di comando.

$N - Nome

Destinazione.Cartella + Destinazione.Nome

$P - Password

Abakt memorizza la password nel profilo (file .abp) come testo normale. Fate attenzione che la vostra cartella Data/Profiles non possa essere accessibile a sconosciuti.

$W - Cartella di lavoro

Questa è la cartella temporanea definita nelle Preferenze.

$L - Lista dei file

Obbligatorio! Senza questa variabile, 7z.exe non saprebbe quale file usare.

$$ - $

Usate $$ se vorrete una '$' nella linea di comando.


Operazioni sui file

Indice dei contenuti | Su: Impostazioni tipo di Azione | Precedente: 7-Zip

Operazioni sui file

Usate questa tipo di Azione per eseguire operazioni sui file selezionati.

Modalità

Potrete selezionare la modalità desiderata alla pagina Tipo di Azione.

  • Copia
    Copia i file selezionati nella cartella di destinazione.
  • Sposta
    Sposta i file selezionati nella cartella di destinazione.
  • Elimina
    Elimina i file selezionati.
    Potrete usare questa modalità creando un profilo che serva per ripulire alcune cartelle che abbisognano della rimozione di file inutili.
    Fate moltissima attenzione usando questa operazione!
Sovrascrivi file esistenti

Applicato alle operazioni di Copia e Sposta.
Se abilitato, i file di destinazione esistenti saranno sostituiti.

Sovrascrivi anche i file di 'Sola lettura'

Abilitate questa opzione per sovrascrivere i file di sola lettura.

Usa il 'Cestino', se possibile

Applicato alle operazioni di Elimina.
Per le operazioni di eliminazione, Windows non garantisce l'infallibilità del Cestino.

Usa la funzione SHFileOperation di Windows

Applicato alle operazioni di Copia, Sposta e Elimina.
Fornisce meno controllo, ma è spesso più veloce.
Questa opzione è simile alle operazioni sui file effettuate con Windows Explorer.
Non usare con molti file (migliaia); SHFileOperation() fallirà per ragioni sconosciute.


Destinazione [F10]

Indice dei contenuti | Su: 3 - Azione | Precedente: Impostazioni tipo di Azione

Destinazione [F10]
Cartella

Specifica la cartella di destinazione per l'Azione scelta.

Crea automaticamente la cartella

Abilitando questa opzione, se quando eseguirete l'Azione, la cartella di destinazione non esiste, sarà creata automaticamente.
Ignorato per le operazioni di eliminazione sui file.

Nome
Anteprima

Riguarda il file di destinazione o cartella.
La destinazione attuale è: 'Cartella + Anteprima'.

Modello

Utilizzerete un modello per creare il nome dalla cartella di destinazione. Questo nome sarà usato anche durante la creazione di un archivio o di una cartella, durante le operazioni di Copia/Sposta.

Variabili speciali (notare le virgolette singole obbligatorie)
  • '$N'
    Nome del profilo
  • '$M'
    Tipo di bakcup.
  • '$V'
    Informazioni sulla versione di Abakt (come mostrato nella finestra Informazioni su...).
  • '$$'
    Carattere $.
  • Stringhe in formato testo
    Per maggiori informazioni, vedi Formato testo.

    • I caratteri non validi saranno rimossi dalla stringa risultante.

Aggiungi le estensioni

Se disabilitato, l'estensione di default per il tipo di Azione non sarà aggiunta al nome di destinazione.
Ciò è valido solo per gli archivi Zip. Non è applicabile agli archivi Zip divisi.


Concludi [F11]

Indice dei contenuti | Su: Modifica profilo | Precedente: 3 - Azione

Concludi [F11]

Scegliete il comportamento da tenere, dopo che un'Azione è stata completata con successo.

Registro eventi

Vedi Registro eventi.

Lista dei file

Se abilitato, nella cartella di destinazione, sarà creato un file di testo contenente la lista dei file processati con successo. Questo file avrà lo stesso nome di Destinazione.Nome, con estensione ".txt".

Attualmente non applicabile al tipo di Azione 'Zip'.

Rimuovi le cartelle vuote

Abilitare questa opzione per rimuovere le cartelle che fossero vuote, dopo un'Azione 'Copia' o 'Sposta'.
Le cartelle saranno rimosse solo dopo che un'Azione si è conclusa con successo.

Saranno rimosse solo le cartelle rimaste vuote come risultato di un'Azione. Le cartelle che erano già vuote prima che l'Azione sia cominciata saranno ignorate.

Verifica archivio

Abilitare questa opzione per verificare un archivio zip appena creato, dopo che un'Azione si è conclusa.

Funziona solo con archivi zip (sia creati con il motore integrato che con 7-Zip).

L'opzione non esegue una comparazione binaria dei file nell'archivio con quelli della lista nell'origine dati, essa verifica semplicemente se un archivio zip sia corrotto o no.

  • Registro eventi


Registro eventi [Ctrl+H]

Indice dei contenuti | Su: 4 - Concludi

Registro eventi [Ctrl+H]

Il modulo Registro eventi mantiene una lista degli archivi creati con successo, di tipo 'Zip' e '7-Zip'.

Catalogo archivio
Note:

Solo i nuovi archivi creati con successo saranno aggiunti al Registro. Per aggiungere altri (più vecchi) archivi alla lista, premere il pulsante 'Aggiungi file alla lista...'

Le relative voci saranno verificate ed inserite dopo che ogni Azione si è conclusa con successo, o su richiesta, quando si preme il pulsante 'Applica le impostazioni adesso'.

Il modulo Registro memorizza il tipo di backup che è stato usato per creare l'archivio.

Il modulo Registro memorizza l'ultimo archivio creato con successo; questa informazione è usata dal comando 'Ripristina archivio da Zip'.

Il modulo Registro non memorizza alcuna informazione per il tipo di Azione 'Operazioni sui file'.

  • Il file registro (.abh) è salvato nella stessa cartella del file del profilo associato (.abp). Questo comportamento non può essere modifcato.
  • I backup archiviati su dischi rimovibili, non saranno memorizzati nel Registro.
Abilitato

Se deselezionato, non sarà mantenuta nessuna informazioni nel Registro.
Ciò significa che il file del Registro associato con il profilo attuale non sarà (ri-)creato o aggiornato: potete eliminare tranquillamente qualsiasi file *.abh nella cartella "Profiles".

Rimuovi i backup più vecchi di N giorni

I backup più vecchi di N giorni saranno rimossi, fino a raggiungere il valore specificato nell'impostazione 'Mantieni un minimo di N backup'.
Disabilitato se impostato a 0.

Mantieni un minimo di N backup

Mantiene sempre un minimo di N backup.
Disabilitato se impostato a 0.

Mantieni un massimo di N backup

L'ammontare dei backup memorizzati su disco non eccederanno N.
Disabilitato se impostato a 0.

Usa il 'Cestino', se possibile

Se spuntato, i backup rimossi saranno spostati nel Cestino di Windows.
Windows non garantisce l'infallibilità del Cestino.

Pulsanti:
Mostra la Lista dei file

Mostra i file elencati nel Registro eventi nel pannello di stato, e la loro età (in giorni).
Con questo pulsante non viene eseguita alcuna azione (nessun file sarà rimosso).

Aggiungi file alla lista

Aggiunge manualmente i nomi dei file degli archivi già creati, memorizzati nel Registro.
Usa questa opzione per aggiungere i nomi degli archivi creati prima che il modulo Registro eventi è stato introdotto in Abakt.
Non sarà memorizzata alcuna informazione sul tipo di backup.

Applica le impostazioni adesso

Forza una verifica immediata.
I nomi dei file coinvolti saranno istantaneamente rimossi, in base alle impostazioni.

Catalogo file

Non ancora implementato.


Strumenti

Indice dei contenuti | Precedente: Modifica profilo | Successivo: Preferenze

Strumenti

  • Anteprima filtro
  • Ripristina archivio da Zip
  • Gruppo di profili
  • Editor modello


Anteprima filtro [Ctrl+Shift+F]

Indice dei contenuti | Su: Strumenti | Successivo: Ripristina archivio da Zip

Anteprima filtro [Ctrl+Shift+F]

Usate Anteprima filtro per vedere quali file saranno inclusi ed esclusi.

Crea la lista dei file

Creerete le liste in base alle impostazioni del filtro attuale e alle opzioni qui sotto.
Potrete vedere le liste nei pannelli Inclusi e Esclusi.

Senza lettera unità (es. C:)

Abilitate questa opzione per generare la lista dei file senza l'informazione sulle unità ('C:\').

Virgoletta i file

Abilitate questa opzione per generare la lista dei file dove ogni file sarà racchiuso tra virgolette doppie (").

Esamina le cartella escluse

Se abilitato, il motore di filtro di Abakt esaminerà anche le cartelle che sono escluse (non spuntate). Il risultato sarà una lista piuttosto lunga di file esclusi nel pannello della lista dei file Esclusi.

Salva lista dei file selezionati

Salva i file selezionati mostrati nella lista dei file, in un file di testo ".txt".


Ripristina archivio da Zip [Ctrl+Shift+R]

Indice dei contenuti | Su: Strumenti | Precedente: Anteprima filtro | Successivo: Gruppo di profili

Ripristina archivio da Zip [Ctrl+Shift+R]

Ripristina gli archivi Zip creati precedentemente.

Archivio Zip

Scegliete o modificate un archivo Zip aperto.
Il menu a discesa mostrerà tutti gli archivi che sono stati memorizzati nel Registro eventi.

Non è possibile aprire/ripristinare gli archivi .7z. Dovrete usare il File Manager di 7-Zip.

Apri

Apre l'archivio Zip mostrato nel menu a discesa.

Cartella di destinazione

Scegliete o modificate dove saranno estratti i file.

Sovrascrivi file e cartelle esistenti

Scegliete se sovrascrivere i file o cartelle che abbiano lo stesso nome, nella cartella di destinazione.

Ripristina i file selezionati

Cliccate su questo pulsante per cominciare l'estrazione dei file selezionati nella cartella di destinazione.


Gruppo di profili [Ctrl+G]

Indice dei contenuti | Su: Strumenti | Precedente: Ripristina archivio da Zip | Successivo: Editor modello

Gruppo di profili [Ctrl+G]

Userete un gruppo per eseguire una serie di profili.

Specificare (facoltativo) la configurazione e/o le Regole filtro personalizzate che dovranno essere applicate ad ogni profilo scelto.
Questa è una funzionalità molto potente.

Profili

Aggiungete e selezionate i profili che volete che siano eseguiti come gruppo.

I profili saranno eseguiti nell'ordine nel quale sono stati selezionati.

Configurazione personalizzata

Adattate la configurazione s elezionata impostata in questa pagina, per ogni profilo scelto.

Se viene selezionata una impostazione, l'impostazione corrispondente del profilo sarà sostituita con il valore di questa pagina.

Se non viene selezionata una impostazione, l'impostazione esistente nel profilo non sarà modificata.

Per esempio, volete sostituire "Cartella.Destinazione" con "C:\Masterizza-su-cd\" per tutti i profili scelti. Molto utile se vorrete inserire un certo numero di backup in una certa cartella di destinazione.

Regole filtro personalizzate

Queste Regole filtro (selezionate e non selezionate) saranno usate per modificare la lista delle Regole filtro di ciascun profilo scelto.

Se la serie di Regole filtro di un profilo ha esattamente le stesse condizioni di una serie di Regole filtro del modello, le proprietà della Regola filtro del modello 'nome', 'azione', e 'abilitato' preverranno sulle proprietà delle Regole filtro esistenti.

Saranno usate nella comparazione solo le condizioni di una serie di Regole filtro, non le proprietà (Nome, Azione, Abilitato).


Editor modello [Ctrl+Shift+T]

Indice dei contenuti | Su: Strumenti | Precedente: Gruppo di profili

Editor modello [Ctrl+Shift+T]

Usa un modello di Abakt per regolare le impostazioni di un profilo Abakt.

Il comportamento è simile al modo in cui funziona un gruppo di backup. Saranno usate solo le impostazioni selezionate.

I modelli salvati (con estensione *.abt) possono essere usati per modificare alcune specifiche impostazioni in un profilo, quando Abakt è eseguito usando i parametri da linea di comando.

Vai alla pagina Linea di comando (opzione -T) per gli esempi.

Filtri personalizzati

Essi contengono le impostazioni che saranno usate per la messa a punto del filtro di quel profilo.

Se un filtro in un profilo ha esattamente le stesse impostazioni della configurazione del modello, le proprietà del modello 'Nome', 'Azione' e 'Abilitato' prevarranno sulle proprietà del filtro esistente.
Nota: Saranno usate solo le condizioni di un filtro, non le proprietà (Nome, Azione, Abilitato).

Le restanti regolazioni saranno semplicemente aggiunte alla lista delle regolazioni del profilo.

Configurazione personalizzata

Selezionare le impostazioni della configurazione che si vuole regolare quando si usa un modello.

Saranno usati soltanto i valori delle impostazioni selezionate (spuntate), al posto dei valori registrati in un profilo.


Preferences [Ctrl+P]

Indice dei contenuti | Precedente: Strumenti | Successivo: Linea di comando

Preferenze [Ctrl+P]

Qui si trovano le impostazioni globali che saranno valide per l'utente attivo.

  • All'avvio
  • Applicazione
  • Azione
  • Tracciatura
  • Avanzate


All'avvio

Indice dei contenuti | Su: Preferenze | Successivo: Applicazione

All'avvio
Utilizza un profilo

Determina quale profilo aprire quando si avvia Abakt.

  • Nuovo
    Usa 'default.abp' come nuovo profilo. Questo file si trova nella cartella dell'utente attivo "Application Data\Abakt". (Windows XP: "C:\Documents and Settings\[user]\Application Data\Abakt\default.abp").
  • L'ultimo aperto o salvato
    Usa l'ultimo file che è stato aperto o salvato da Abakt.
  • Personalizzato
    Imposta un file personalizzato che dovrà essere usato come nuovo profilo.
Ripristina le associazioni dei file al prossimo riavvio

La prossima volta che Abakt sarà avviato, l'opzione ripristinerà le associazioni dei file con le seguenti estensioni: .ABP, .ABG, .ABT e .ABH.

Se cliccherete due volte su questi file in Windows Explorer, sarà lanciato Abakt e aperto con i file già selezionati.

Queste associazioni saranno rimosse dal registro di Windows qualora disinstallaste Abakt.


Applicazione

Indice dei contenuti | Su: Preferenze | Precedente: All'avvio | Successivo: Azione

Applicazione
Cartella dei dati

Questa è la cartella dove saranno salvati i vostri dati (profili, gruppi, modelli e file di log).
Se modificherete questa cartella, le nuove sottocartelle saranno create automaticamente.
Nessun file sarà copiato quando cambierete questa cartella, quindi dovrete farlo manualmente.

Mostra riquadri descrizioni

Disattivate questa opzione se non pensate di averne bisogno.

File recenti
Numero di file in elenco

Imposta il numero dei file visibili nei vari menu 'File | File recenti'.

Mostra info sul percorso

Se abilitata, questa opzione visualizzerà l'intero percorso di ogni file.

Lingua

Cambia la lingua che usa Abakt. Abakt necessiterà di un riavvio perchè i cambi abbiano effetto.

Vai alla pagina Translation Status per una panoramica delle lingue disponibili.

Leggete la pagina How to translate Abakt se vorrete aiutarmi nella traduzione.

File delle preferenze

Mostra il percorso del file delle preferenze globali di Abakt.

Potrete istruire Abakt ad usare un file delle preferenze personalizzato tramite l'opzione -I della linea di comando.


Azione

Indice dei contenuti | Su: Preferenze | Precedente: Applicazione | Successivo: Tracciatura

Azione
Cartella di destinazione di default

Opzione usata per i nuovi profili (Senza nome).

Cartella temporanea

Specifica la cartella dove Abakt salverà temporaneamente i file che contengono la lista dei file che dovranno essere inclusi/esclusi.
Questa sarà anche la cartella che ZipBuilder userà quando dovrà aggiornare e verificare i backup.
Se vuota, sarà usata la cartella temporanea del sistema operativo.

Eseguibile 7-Zip

Impostare il percorso di 7z.exe. Scaricate 7-Zip da http://sourceforge.net/projects/sevenzip/

Converti i nomi di file in @listafile in OEM

Abilitare per convertire i nomi di file della @listafile (parametro della linea di comando di 7-Zip) nel set DOS (OEM) di caratteri di Windows.

Se disabilitato, i nomi dei file saranno codificati come UTF-8 da Abakt. Questa è l'impostazione di default di 7-Zip, a partire dalla versione 4.33.

Conferma sulle azioni 'Operazioni sui file | Cancella'

Se abilitato Abakt mostrerà un popup che chiederà conferma per una operazione 'Cancella'.

Abakt non chiederà conferma se è avviato con parametro da linea di comando, perchè ciò potrebbe interferire sull'automazione delle operazioni.


Tracciatura

Indice dei contenuti | Su: Preferenze | Precedente: Azione | Successivo: Avanzate

Tracciatura
Azione

È l 'informazione che sarà caricata dalla finestra Azione.

Creazione lista dei file dettagliata

Per ogni file: mostra SE e PERCHÈ esso è incluso o escluso.

Abilitando questa opzione, l'Azione sarà più lenta e i file di log saranno più grandi.

Avanzamento dettagliato

Mostra le proprietà di ogni file nel log, durante l'esecuzione dell'Azione.
Se non abilitato, saranno riportati solo gli errori.
Applicato all'opzione Verifica archivio.

Abilitando questa opzione, l'Azione sarà più lenta. E come risultato si avrà un file di log più grande.

Salva il Log in '<NomeProfilo>.log'

Abilitate questa opzione se vorrete salvare automaticamente le informazioni (selezionate sopra) in un file di log (sotto).
Il file di log '[NomeProfilo]' sarà salvato nella cartella di registro delle Azioni.

Cartella di registro delle Azioni

Imposta la cartella dove saranno salvati i file di log.

Applicazione
Salva messaggi di stato

Se questa opzione è abilitata, i messaggi del pannello di stato nella finestra principale, saranno salvati nella cartella dati dell'utente attivo.
(Windows XP: "\Documents and Settings\[utente]\Application Data\Abakt\Abakt.log".)

Dimensione massima (kB)

È la dimensione massima del file contenente i messaggi di stato.
Quando il file "Abakt.log" avrà raggiunto la metà della dimensione massima, il file di log sarà rinominato in "Abakt.log.old". La tracciatura continuerà nel file "Abakt.log".


Avanzate

Indice dei contenuti | Su: Preferenze | Precedente: Tracciatura

Avanzate
Nascondi le cartelle d'origine che non esistono dal profilo

Abilitate questa opzione per rimuovere le cartelle di origine inesistenti dal profilo quando viene aperto, e dall'albero delle cartelle nella pagina 'Origine dati'..

  • Queste cartelle non saranno rimosse fisicamente, ma semplicemente non saranno visualizzate.
Includi cartelle vuote

Abilitate questa opzione per includere le cartelle vuote durante l'Azione in esecuzione.

  • Per il momento, si applica solo al tipo di Azione 'Zip'.
  • Le cartelle vuote non possono essere aggiunte ad un archivio che abbia le 'Informazioni sul percorso' impostato su 'Nessuno'.
  • DA FARE: Implementare per '7-Zip', 'Copia' e 'Sposta'.
Crea una copia temporanea se l'archivio Zip esiste

Se abilitato, Abakt creerà una copia dell'archvio Zip esistente, prima che l'Azione cominci.

Applicato alla modalità Zip 'Sostituisci'.
Disabilitare questa opzione se non avete abbastanza spazio sul disco di destinazione.

  • L'opzione sarà sempre disabilitata per i dischi rimovibili.
  • Attenzione: se il backup fallisce e questa opzione è disabilitata, perderete la vostra copia originale.
Esegui operazioni di ZipBuilder sicure

Se abilitato, ZipBuilder userà un file temporaneo quando modificherà gli archivi Zip esistenti. In caso contrario, opererà direttamente con il file originale e qualsiasi errore potrebbe corromperlo.

Applicato solo alle Azioni Zip.

  • L'opzione sarà sempre disabilitata per i dischi rimovibili.
  • DA FARE : Decidere se questa opzione dovrà sostituire 'Crea una copia temporanea se l'archivio Zip esiste'.
Tratta gli avvisi come errori

Se questa opzione è abilitata, semmai un file non possa essere archiviato, l'Azione si interromperà con un errore irreversibile.
Ciò avrà un impatto su molteplici aspetti del comportamento di Abakt:
- L'Azione verrà interrotta.
- Il codice di ritorno della linea di comando sarà ERRORE, invece che AVVISO.
- Nessuna operazione prevista nella pagina 'Concludi' sarà eseguita. In altre parole: le operazioni Registro eventi, Verifica archivio, Resetta attributo archivio, ecc., non saranno eseguite.

Applicato solo alle Azioni Zip.

Usa la nuova visualizzazione UI BrowseForFolder

Disabilitate questa opzione, se preferite l'interfaccia vecchio stile di Windows, o se si verificano errori.


Linea di comando

Indice dei contenuti | Precedente: Preferenze | Successivo: Formato testo

Linea di comando

Abakt accetta argomenti da linea di comando.

Utile quando si creano script .BAT per automatizzare le operazioni, o per avviare Abakt con impostazioni personalizzate.

Sintassi

Abakt.exe [opzioni] NOMEFILE

NOMEFILE dev'essere un file di tipo .abp o .abg.
- È obbligatoria l'estensione.
- Se non viene fornita alcuna informazione sul percorso, Abakt proverà a cercare un NOMEFILE nelle sottocartelle 'Profiles' o 'Groups' della cartella Dati di default (vedi Preferenze).

Opzioni

Le opzioni sono "sensibili alle maiuscole/minuscole" (-m non è lo stesso di -M).

Opzione
Descrizione
-b AutoEsecuzione
Esegue automaticamente l'Azione (un profilo o un gruppo).
Se omessa, Abakt si avvierà normalmente ed aprirà il profilo o gruppo.
-x AutoUscita
Chiude automaticamente Abakt appena si conclude l'operazione.
- Opzione ignorata se AutoEsecuzione è omessa.
-m Minimizza
Minimizza Abakt durante le operazioni.
- Opzione ignorata se AutoEsecuzione è omessa.
-l Crea file di Log
Scrive il Log nel file profilo-nomefile.log nella cartella di Log di default (vedi Preferenze).
Questa opzione sovrascrive le impostazioni di default della finestra delle Preferenze.
- Opzione ignorata se AutoEsecuzione è omessa.
-L Non creare un file di Log
Questa opzione sovrascrive le impostazioni di default della finestra delle Preferenze.
- Opzione ignorata se AutoEsecuzione è omessa.
-o "TESTO" Usa 'Destinazione/Nome modello' personalizzati
Sostituisci il nome del modello della Destinazione nel profilo con TESTO.
Prende il posto del valore stabilito dalla opzione -T.

- Opzione ignorata per le Azioni sui gruppi (file .abg), si applica solo ai profili.
- Quando AutoUscita è omessa, il profilo sarà aperto come un profilo modificato.
- Non dimenticarsi di usare le virgolette singole, se servono. Vedi Formato testo per maggiori informazioni.

Esempio:
"C:\Programmi\Abakt\Abakt.exe" -o "'mioNomeModello'" "mioProfilo.abp"

-I "FILE" Usa un file di Preferenze globali personalizzato
Indica a Abakt di usare FILE invece del file di default delle preferenze 'Abakt.ini'. Usato per debugging.
Se il file non esiste, sarà creato.
- FILE dovrà contenere le informazioni sui percorsi (per es. "C:\Debug\TestAbakt.prefs").
- La cartella dovrà esistere, non sarà creata automaticamente.
-T "FILE"

Usa un modello di Abakt (FILE dovrà puntare ad un file .abt esistente) per sovrascrivere le impostazioni specifiche del profilo che sarà eseguito.
- Se non viene fornita alcuna informazione sul percorso e/o sulla estensione, Abakt proverà a cercare FILE nelle sottocartelle 'Templates' della cartella Dati di default (vedi Preferenze). Non è obbligatorio includere l'estensione '.abt'.
- Quando AutoUscita è omessa, il profilo sarà aperto come un profilo modificato.
- Opzione ignorata per le Azioni sui gruppi (file .abg), si applica solo ai profili.

Esempi:

  • Abakt.exe -T FaiBackupIncrementale MieiDocs.abp
  • "C:\Programmi\Abakt\Abakt.exe" -T "C:\AbaktData\Profiles\FaiBackupCompleto.abt" "C:\AbaktData\Profiles\MieiDocs.abp"
Codici di ritorno

Quando Abakt viene chiamato da linea di comando, restituisce alcuni utili codici di ritorno. In uno script .BAT, essi possono essere ottenuti con %ERRORLEVEL%, dopo aver chiamato Abakt.exe.

Per un esempio, vedi Come mandare una e-mail quando si conclude un backup.

Se l'impostazione globale 'Tratta avvisi come errori' è abilitata, il codice di ritorno sarà OK o ERRORE, ma mai AVVISO.

Si applica ai profili (.abp), non ai gruppi (.abg). Non funziona con 7-Zip.

Codici di ritorno:
  • 0: OK
  • 1: ERRORE
  • 2: AVVISO (OK)
Oppure una combinazione :
  • 3: ERRORE+AVVISO


Formato testo

Indice dei contenuti | Precedente: Linea di comando | Successivo: Come fare per ...

Formato testo

Create il vostro 'Formato testo' in base alle seguenti regole:

Valore | Significato
(illegale) | Questi caratteri non possono essere usati: \ / : * ? " < > |
c | Mostra la data usando il formato passato dalla variabile globale ShortDateFormat, seguito dall'ora usando il formato passato dalla variabile globale LongTimeFormat. L'ora non è mostrata se la parte frazionaria del valore di DateTime è zero.
d | Mostra il giorno sotto forma di numero, senza lo 0 davanti (1-31).
dd | Mostra il giorno sotto forma di numero, con lo 0 davanti (01-31).
ddd | Mostra il giorno sotto forma di abbreviazioni (Dom-Sab), usando la stringa passata dalla variabile globale ShortDayNames.
dddd | Mostra il giorno con il nome completo (Domenica-Sabato), usando la stringa passata dalla variabile globale LongDayNames.
ddddd | Mostra la data usando il formato passato dalla variabile globale ShortDateFormat.
dddddd | Mostra la data usando il formato passato dalla variabile globale LongDateFormat.
m | Mostra il mese sotto forma di numero senza senza lo 0 davanti (1-12). Se lo specificatore "m" segue immediatamente gli specificatori "h" o "hh", sarà mostrato il minuto al posto del mese.
mm | Mostra il mese sotto forma di numero con lo 0 davanti (01-12). Se lo specificatore "mm" segue immediatamente gli specificatori "h" o "hh", sarà mostrato il minuto al posto del mese.
mmm | Mostra il mese sotto forma di abbreviazione (Gen-Dic), usando la stringa passata dalla variabile globale ShortMonthNames.
mmmm | Mostra il mese con il nome completo (Gennaio-Dicembre), usando la stringa passata dalla variabile globale LongMonthNames.
yy | Mostra l'anno sotto forma di numero a due cifre (00-99).
yyyy | Mostra l'anno sotto forma di numero a quattro cifre (0000-9999).
h | Mostra l'ora senza lo 0 davanti (0-23).
hh | Mostra l'ora con lo 0 davanti (00-23).
n | Mostra il minuto senza lo 0 davanti (0-59).
nn | Mostra il minuto con lo 0 davanti (00-59).
s | Mostra il secondo senza lo 0 davanti (0-59).
ss | Mostra il secondo con lo 0 davanti (00-59).
t | Mostra i tempi usando il formato passato dalla variabile globale ShortTimeFormat.
tt | Mostra i tempi usando il formato passato dalla variabile globale LongTimeFormat.
'testo' | I caratteri chiusi tra virgolette singole, saranno restituiti così come sono, non venendo coinvolti nella formattazione.
 | [Fonte: Borland Help File]


Come fare per ...

Indice dei contenuti | Precedente: Formato testo | Successivo: FAQ

Come fare per ...

Alcuni esempi su come usare Abakt.

  • Creare il primo backup
  • Includere solo un file in una cartella
  • Usare l'utility di Windows "Operazioni pianificate"
  • Mandare una e-mail quando si conclude un backup
  • Creare file Zip più grandi di 4 GB.


Creare il primo backup

Indice dei contenuti | Su: Come fare per... | Successivo: Includere solo un file in un backup

Creare il primo backup

Una semplice guida passo a passo per aiutarvi ad effettuare il vostro primo backup.

Supponiamo che vogliate fare il backup compresso della cartella "Documenti".
I passi seguenti descrivono come creare ed eseguire un profilo per fare tutto ciò:

  1. Avviate Abakt e creare un nuovo profilo. [File | Nuovo profilo].

  2. Andate alla pagina di origine dati [F6]:
    Cliccate sul pulsante 'Aggiungi'.
    Sfogliate le cartelle fino ad evidenziare "Documenti" e confermate con OK. Abakt mostrerà una cartella tipo: "C:\Documents and Settings\erik\Documenti" e le sue sottocartelle.

    All'esecuzione dell'Azione scelta, tutti i file nelle cartelle non selezionate saranno ignorati.

  3. [Facoltativo] Nel pannello File: Clic destro su un file; apparirà un menu a scomparsa che vi aiuterà a creare nuove Regole filtro.
    Potrete rivedere/modificare le Regole filtro alla pagina Filtri [F7].

  4. Andate alla pagina Azione/Tipo di Azione[F8]:
    Scegliete l'Azione desiderata: "Zip".

  5. Andate alla pagina Azione/Impostazioni tipo di Azione [F9]:
    Controllate le impostazioni dell'Azione ("Zip") scelta. Le impostazioni di default dovrebbero andarvi bene.

  6. Andata alla pagina Destinazione [F10]:
    Cliccate sul pulsante 'Cartella' e scegliete una cartella esistente o createne una nuova.

  7. Per creare un backup, cliccate sul pulsante 'Esegui Azione'..


Includere un solo file in una cartella

Indice dei contenuti | Su: Come fare per ... | Precedente: Creare il primo backup | Successivo: Usare l'utility di Windows 'Operazioni pianificate'

Includere un solo file in una cartella

O meglio : Escludere tutti i file in una cartella, tranne uno (o più) file specifico(i).

Di seguito trovate un esempio di come escludere tutti i file in "C:\Test", eccetto il file "C:\Test\conservami.txt".

  1. La cartella "C:\Test\" deve essere selezionata (casella gialla).

    Le cartelle non selezionate saranno ignorate durante tutto il resto del processo di filtraggio.

  2. Clic-destro su ogni file nel pannello File: apparirà un menu a scomparsa.

  3. Seleziona 'Escludi.../ tutti i file in questa cartella'.
    A questo punto, tutti i file nella cartella "C:\Test\" sono esclusi.

  4. Poi, clic-destro sul file che vuoi includere ("C:\Test\conservami.txt"), quindi scegliete 'Includi (sempre).../ questo file'.

  5. Ecco fatto!
    A questo punto, tutti i file nella cartella "C:\Test\" sono esclusi eccetto il file "conservami.txt".
    Potrete ripetere il passaggio 2 per altri file di cui vorrete forzarne l'inclusione.


Usare l'utility di Windows 'Operazioni pianificate'

Indice dei contenuti | Su: Come fare per ... | Precedente: Includere solo un file in una cartella | Successivo: Mandare una e-mail quando un backup si è concluso

Usare l'utility di Windows 'Operazioni pianificate'

Potrete usare le opzioni da linea di comando per lanciare le 'Operazioni pianificate' di Windows.

  1. Create un file di collegamento ad Abakt con un Obiettivo tipo questo:

    "C:\Programi\Abakt\Abakt.exe" -b "C:\Profili\MioProfilo.abp"

    O come questo:

    "C:\Programi\Abakt\Abakt.exe" -b -x -m "MioGruppoDiProfili.abg"

  2. Poi, indicate all'utility di Windows 'Operazioni pianificate' di richiamare il collegamento che avete appena creato.

Forse il modo migliore è quello di creare e richiamare un file .BAT, invece che un collegamento.


Mandare una e-mail quando un backup si è concluso

Indice dei contenuti | Su: Come fare per ... | Precedente: Usare l'utility di Windows 'Operazioni pianificate' | Successivo: Creare file Zip più grandi di 4 GB

Mandare una e-mail quando un backup si è concluso

Di seguito troverete un esempio di uno script .BAT che chiama Abakt e manda una e-mail contenente informazioni utili.
Voi dovrete, probabilmente, modificare un po' lo script perchè funzioni sul vostro sistema.

Lo script usa blat, una utility da linea di comando per inviare e-mail. Scaricate blat.zip ed estraetene i file in "C:\Programmi\blat\".

Esempio:
set BLAT="C:\Programmi\blat\smtp\blat.exe"
set ABAKT="C:\Programmi\Abakt.exe"
set PROFILE=MyProfile
set HOME=C:\Documents and Settings\erik
set LOGFILE="%HOME%\Application Data\Abakt\Log\%PROFILE%.log"
set EMAIL=mioNome@mioProvider.net

@rem == Prepare blat:
%BLAT% -install smtp.mioprovider.net %EMAIL%

@rem == Call Abakt:
%ABAKT% -b -x -l -m "%PROFILE%.abp"

goto result%ERRORLEVEL%
:result0
    @rem OK (0x00)
    %BLAT% %LOGFILE% -s "%PROFILE% Ok" -to %EMAIL%
    @goto end
:result2
    @rem OK+WARNING (0x02)
    %BLAT% %LOGFILE% -s "%PROFILE% Ok + Warnings" -to %EMAIL%
    @goto end
:result1
    @rem ERROR (0x01)
:result3
    @rem ERROR+WARNING (0x03)
    %BLAT% %LOGFILE% -s "%PROFILE% Failed!" -to %EMAIL%
    @goto end

:end


Creare file Zip più grandi di 4 GB

Indice dei contenuti | Su: Come fare per ... | Precedente: Mandare una e-mail quando un backup si è concluso

Creare file Zip più grandi di 4 GB

Lo standard originale PKZIP non pemette che i file .ZIP siano più grandi di 4 GB.

Provate ad usare 7-Zip per creare archivi .zip o .7z più grandi di 4 GB.
Dalla documentazione di 7-Zip: "7-Zip supporta le estensioni Zip64 del formato ZIP".
Io penso che avvenga automaticamente. Usando 7-Zip 4.32, ho provato a creare archivi .ZIP più grandi di 4 GB senza problemi.

Questi archivi non possono essere estratti con la libreria zip integrata in Abakt. Usate invece 7-Zip Manager, IZArc o WinZip.

Nota: I sistemi operativi Windows 95/98(SE)/ME non supportano comunque file più grandi di 4 GB.


Frequently Asked Questions

Indice dei contenuti | Precedente: Come fare a...

Frequently Asked Questions

In questa sezione troverete alcune tra le più frequenti domande.

Se desiderate condividere altre informazioni con gli altri utenti di Abakt, fatemelo sapere.

  • 'File lock violation' ('Violazione di ifle bloccato')
  • 'Incorrect wildcard in listfile' (Caratteri jolly non validi nella lista dei file')


File lock violation

Indice dei contenuti | Su: FAQ | Successivo: 'Incorrect wildcard in listfile'

File lock violation (Violazione di file bloccato)

Ho letto un messaggio come questo nel log di Abakt, contestualmente un'Azione di Zip:

Tf_Action::ZipBuilderMessage: ErrCode=0x21 (33), Message="Warning: File lock violation: C:\Documents and Settings\erik\Local Settings\Application Data\Microsoft\Outlook\Microsoft\Outlook\mailbox.pst"

Questo errore proviene da Windows, ZipBuilder lo riprende. Ecco il messaggio attuale:

ERROR_LOCK_VIOLATION 33: "Il proceso non può accedere al file perchè un altro processo ha bloccato una porzione del file."

Potete usare un programma tipo Unlocker (http://ccollomb.free.fr/unlocker/) per trovare quale programma ha bloccato il file mailbox.pst.

Trovare il file che sta bloccando il file non vuole dire che Abakt possa archiviare quel file, ma aiuta semplicemente a trovare la causa del messaggio di errore.


Incorrect wildcard in listfile

Indice dei contenuti | Su: FAQ | Precedente: 'Violazione File Bloccato''

Incorrect wildcard in listfile (Caratteri jolly non validi nella lista file)

Ho letto un messaggio nel file di log di Abakt, contestualmente all'esecuzione di un'Azione 7-Zip:

Error: Incorrect wildcard in listfile

Questo errore significa che state usando una versione di 7-Zip più recente di 4.33. Da questa versione, 7-Zip si aspetta che la lista dei file sia formattata come UTF-8 invece che in formato OEM.

Potete istruire Abakt di formattare la lista dei file come UTF-8, disabilitando l'opzione 'Preferenze/Azione/Converti i nomi di file in @listafile a OEM'.


INDICE

Indice dei contenuti

INDICE
  • Abakt
    • Requisiti
    • Setup
    • Installazione
    • Disinstallazione
    • Donazioni
    • Licenza
  • Filtri
    • Regole filtri

  • Strumenti
    • Anteprima filtro
    • Ripristina archivi Zip
    • Gruppo di profili
    • Editor modello


Manuale di Abakt

Autore : Erik Dienske

Internet : http://www.xs4all.nl/~edienske/abakt/

E-mail : Vai alla finestra 'Aiuto/Informazioni su...' dell'applicazione

Ultima modifica : 24 maggio 2006

Traduzione italiana : Ringo

Abakt Logo Manuale di Abakt
Indice dei contenuti
  • Abakt?
    • Introduzione
    • Requisiti
    • Installazione
    • Donazioni
    • Licenza
  • Modifica profilo
    • 1 - Origine dati
    • 2 - Filtri
    • 3 - Azione
      • Tipo di Azione
      • Impostazioni tipo di Azione
        • Zip
        • 7-Zip
        • Operazioni sui file
      • Destinazione
    • 4 - Concludi
      • Registro eventi
  • Strumenti
    • Anteprima filtro
    • Ripristina archivio da Zip
    • Gruppo di profili
    • Editor modello
  • Preferenze
    • All'avvio
    • Applicazione
    • Azione
    • Tracciatura
    • Avanzate
  • Linea di comando
  • Formato testo
  • Come fare per ...
    • Creare il primo backup
    • Includere un solo file in una cartella
    • Usare l'utility di Windows 'Operazioni pianificate'
    • Mandare una e-mail quando un backup si è concluso
    • Creare file Zip più grandi di 4 GB
  • FAQ
    • 'File lock violation' (Violazione di file bloccato)
    • 'Incorrect wildcard in listfile' (Caratteri jolly non validi nella lista dei file)
  • INDICE