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Rychlokurzech jsem vás již mnohokrát upo-
zorňoval na nutnost zálohovat data; ještě in-

tenzivněji pak poté, co jsem kvůli hardwarové
chybě přišel o spoustu cenných souborů. Podle
přísloví „kovářovic kobyla chodí bosa“ jsem zá-
lohování odkládal na dobu „až bude čas“. Pak už
čas byl, ale nebylo co zálohovat. Jsem tedy
opravdu rád, že vám dnes mohu představit jeden
z těch lepších nástrojů pro zálohování.

NovaBACKUP je na trhu již poměrně dlouho
– autoři na svých stránkách uvádějí 17 let, a to
v je oblasti počítačů už opravdu hodně hodně
dlouhá doba. Může se pochlubit podporou všech
možných i nemožných zálohovacích zařízení – od
disket přes ZIPky, pásky, CD, DVD až po BlueRay
disky, Dual Layer DVD media a zálohování po sí-
ti na takzvaná NAS (Network Access Storage).
My si jistě vystačíme s přepisovatelnými CD
a DVD a zálohováním na druhý pevný disk.

Kromě hardwarové podpory mnoha zařízení
je největším kladem programu snadná obsluha
(povede vás průvodce), možnost obnovení zálo-
hy bez nainstalovaného NovaBACKUPu i ope-
račního systému (např. po havárii pevného dis-
ku) či možnost nastavení automatického záloho-
vání bez zásahu uživatele (což doporučuji). Pro-
tože kompletní popis aplikace by vystačil na men-
ší knížku, povíme si jen to nejdůležitější.

Instalace
Po spuštění instalačního souboru budete vyzvá-
ni k výběru jazyka instalace. Dále [Další>] >>
„I accept…“ (odsouhlasení licence), [Další>] >>
zadejte User Name a Organization a zvolte, zda
má být program dostupný pouze pro vás (Only for
me) nebo zda jej dovolíte používat všem uživa-
telům vašeho PC (Anyone who uses this compu-
ter).

Následuje vyplnění registračních údajů – jde
přece o komerční produkt. Po stisknutí [OK] bu-
dou údaje zabezpečenou cestou odeslány na we-
bové stránky výrobce. Dále zvolte styl instalace
Complete (Kompletní), [Další>] >> [Install] >> [Fi-
nish].

Po instalaci najdete nově v nabídce [START]
adresář nazvaný NovaStor a v něm adresář apli-
kace NovaBackup.

Spuštění
Při prvním spuštění vám své služby nabídne tak
zvaný Wizard (česky Průvodce). Základní akce
(zálohování a obnovu ze zálohy) můžete provádět
jednoduše právě s jeho pomocí. To, zda se po
spuštění programu má objevit průvodce, řídí vol-
ba na první stránce (Always start in wizard mo-
de). Pokud by vás průvodce spíše obtěžoval, de-

aktivujte ho odškrtnutím této volby. Průvodce
můžete kdykoli spustit kliknutím na tlačítko

Wizard v hlavním okně.

DISASTER RECOVERY
(Obnovení po katastrofě)
Podle mého názoru jedna z nejdůležitějších funk-
cí NovaBACKUPu je skryta právě pod tímto ná-
zvem. Jde o možnost vytvořit si zálohu (systému)
pro případ katastrofy. Katastrofy kalibru totální-
ho selhání operačního systému, ať už z důvodu
hardwarové chyby, útoku viru nebo třeba činnosti
uživatele s fatálním následkem. K obnovení dat
z Disaster zálohy totiž nepotřebujete nainstalo-
vaný NovaBACKUP, nepotřebujete ani operač-
ní systém – stačí jen přimět vaše PC, aby nabo-
otovalo z vytvořeného Disaster média. Z toho lo-
gicky vyplývá, že by mělo jít o CD (spíše však
DVD), pevný disk či cokoli, z čeho lze bootovat.

Jak tedy vytvořit takovou zálohu?
Asi nejjednodušší cestou je využít průvodce.
Spusťte NovaBACKUP (menu [START] > Nova-
Stor > NovaBakup > NovaBackup). Pokud se vám
automaticky nespustil průvodce (Wizard), může-
te ho aktivovat kliknutím na ikonu v hor-
ní části hlavního okna. V průvodci stiskněte [Dal-

ší>]. Na následující obrazovce se zobrazí základ-
ní rozcestník.
● Backup files (zálohovat soubory) – jak název
napovídá, slouží pro zálohování souborů do ar-
chivu. 
● Restore files (obnovit soubory) – opačná funk-
ce, rozbalí soubory z archivu.
● Create a Disaster Recovery backup (vytvořit
zálohu pro případ katastrofy) – protože nás v tu-
to chvíli tato volba zajímá nejvíce, zaškrtněte jí
a klikněte na [Další>].

V následujícím kroku uvedeme, co chceme
zálohovat.

All of my C:\ – všechny soubory z disku C:.
All of my local hard drives – všechny sou-

bory ze všech lokálních disků.
Let me select items manualy – tato univer-

zální volba umožní vybrat konkrétní soubory.
Use previously saved script – dovolí použít

již nějaké předem připravené nastavení zálohy.
All of my documents – vybere všechny sou-

bory z adresáře Dokumenty aktuálně přihlášené-
ho uživatele.

My jsme zvolili položku Let me select items
manualy, která je nejuniverzálnější. V tomto pří-
padě se po kliknutí na [Další>] objeví obrazovka
se strukturou disků a adresářů – všeho, co je do-

stupné. Zde si označíte, co vše chcete mít zálo-
hováno. Ale pozor, předem zaškrtnuté volby po-
nechte! Jde o soubory aplikace NovaBACKUP
a ty jsou nezbytné. V tomto případě chceme vy-
tvořit zálohu systému, proto zaškrtněte políčko
System State a dále alespoň adresář, kde máte
nainstalována Windows. Takto budete mít sy-
stém zabezpečený pro případ katastrofy. Pokud
časem nastavení systému výrazně změníte (při-
dáte zařízení, nainstalujete důležitý patch…),
bude potřeba vytvořit zálohu systému znovu.

V dalším kroku určíme, kam budeme záloho-
vat. Nejprve zálohu pojmenujte (pole Backup Na-
me) a v seznamu dostupných médií vyberte zaří-
zení, na něž chcete zálohu uložit (pole Backup
Device). Pole Backup Destination se vyplní au-
tomaticky. Pokud byste přece jen chtěli něco
upřesnit, můžete kliknout na tlačítko [Select], ale
obejdete se i bez toho. Pokračujte obligátním
[Další>].

Na další stránce najdeme volby pro zálohu.
V podstatě doporučuji zaškrtnout vše. Enable vi-
rus scaning (kontrola virů vestavěným Nova an-
tivirem) ještě obsahuje podvolby, co dělat v pří-
padě nalezení viru. Buď Skip (daný soubor nebu-
de zálohován) nebo Ignore (soubor bude zahrnut
do zálohy a vy na něj budete upozorněni). Tla-
čítkem [Další>] se pak dostaneme na souhrnnou
stránku.

Na následující obrazovce určíme, kdy provést
zálohu. První volba je jasná – Backup Now spus-
tí zálohování hned. Druhá volba, Backup Later,
znamená naplánování zálohy na později – třeba
opakovaně. Plánování probereme v následující
části, takže nyní zaškrtněte pouze Backup Now,
vložte médium (pokud jste si nastavili zálohová-
ní třeba na CD či DVD) a stiskněte [Dokončit].

Ve stavovém okně můžeme sledovat, co se
děje. Nejprve se vytvoří zálohový soubor, do něj
se začnou kopírovat (a zároveň komprimovat) vy-
brané soubory a nakonec se vše vypálí třeba na
DVD.

Pokud někdy dojde ke katastrofě a váš ope-
rační systém bude v troskách, vložte záložní disk,
v BIOSu nastavte bootování z příslušné mecha-
niky a nechte nabootovat ze záložního Disaster
média. Potom vyberete pevný disk, jenž chcete
obnovit, a spusťte obnovu. Nechte se vést prů-
vodcem. Po skončení se počítač restartuje a už
by měl být schopen bootovat z pevného disku.
Poté lze sáhnout po záloze dokumentů, obnovit
ji, a to nejhorší máte za sebou.

Zálohování souborů
Systémové soubory už tedy máme v „relativním“
bezpečí. Nyní obraťme pozornost na dokumenty.
Dokumenty se obvykle mění mnohem častěji než
systémové soubory, takže s jednorázovou zálo-
hou toho příliš nepořídíme. Potřebujeme jinou
strategii, chce to plánování…

Základní (a nejpoužívanější) strategie zálo-
hování vypadá takto: v určitých intervalech (na-
př. týdně) vytváříte tzv. plnou zálohu, Full Back-
up, tedy kopírování všech souborů 1 : 1. Mezi tě-
mito intervaly pak děláte denně tzv. rozdílové zá-
lohy, Incremental/Differential Backup, tedy ko-
pírujeme pouze to, co se změnilo. Z toho také
vyplývá způsob plánování. Jednou týdně (třeba
v pátek) provedete plnou zálohu a v ostatních
dnech v týdnu zálohu rozdílovou.

Nejprve si vysvětlíme, co konkrétně zname-
nají jednotlivé typy záloh (Backup Type):
■ Full – záloha všech zaškrtnutých souborů,
u všech zazálohovaných souborů je odstraněn
příznak „archive“.
■ Incremental – zálohuje pouze změněné a no-
vé soubory. To program pozná tak, že u nových
a změněných souborů je automaticky systémem
nastaven příznak „archive“ (neboli vhodný k ar-
chivování). Inkrementační záloha tedy vezme tak-
to označené soubory, zálohuje je a daný příznak
smaže. Změněný soubor se tak objeví pouze v zá-
loze z toho dne, kdy byl změněn. Tento způsob
produkuje co do velikosti nejmenší zálohy, ale

obnova dat potom znamená, že musíte ve správ-
ném pořadí zpětně aplikovat všechny inkremen-
tační zálohy. Změněný soubor je jen na jedné
z nich.
■ Differential – stejné jako Incremental, avšak
nemaže se příznak „archive“. To způsobí, že když
se v úterý nějaký soubor změní, bude v úterní zá-
loze a v každé následující. Velikost zálohy tedy
bude narůstat. Obnova dat je však velmi jedno-
duchá – stačí k ní pouze plná počáteční záloha
a poslední diferenční.
■ Snapshot – stejné jako Full, avšak bez sma-
zání příznaku „archive“.

Začněme tedy nastavením plné zálohy.
Spustíme průvodce kliknutím na . Tlačít-
kem [Další>] se přesuneme na další stránku, kde
zvolíme Backup files. Všechny další stránky jsou
velice podobné jako v případě zálohy Disaster,
proto je probereme jen stručně:
■ Backup files > [Další>].
■ Co chceme zálohovat: buď zaškrtněte All of
My Documents, nebo si je ručně vyberte zaškrt-
nutím Let me select items manualy > [Další>].
■ Jméno zálohy a umístění: jméno zapište
např. „Plna patecni“ a zvolte zálohovací zaříze-
ní. Může to být třeba kombinace přepisovatel-
ných DVD a CD, nebo lze zálohovat na pevný disk. 
Avšak pozor! Vždy zálohujte na jiný disk než na

ten, na němž jsou soubory určené k záloze. Přes-
něji řečeno na jiný fyzický disk – nestačí soubo-
ry z diskového oddílu C: zálohovat na D:, pokud
jsou oba na stejném pevném disku. > [Další>]

Jak na to
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NovaBACKUP
Jednoduchý způsob, jak předejít katastrofě (CD)
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■ Nastavení voleb: zde ponechte zaškrtnuté
vše > [Další>].
■ Přehled nastavení > [Další>].
■ Nastavíme naplánování automatického pro-
vádění záloh. Zaškrtněte Backup Later (Záloho-
vat později) a nastavte volby podle obrázku.

Celý proces uzavřete kliknutím na tlačítko
[Dokončit]. Pokud se nyní podíváte do sekce 
Schedule, uvidíte nový řádek se záznamem o na-
plánované záloze „Plna patecni“ a informaci, že
je ve stavu Waiting (tedy že čeká).

Nyní se soustřeďme na vytváření rozdílo-
vých záloh. Jak bylo popsáno dříve, existují dvě
metody rozdílových záloh – inkrementační a di-
ferenční. Inkrementační znamená vytvoření ma-
lých záloh v pondělí až čtvrtek, diferenční pak vy-
tvoření jedné zálohy, která se bude od pondělí do
čtvrtka zvětšovat (nabalovat). My si zde předve-
deme vytvoření té diferenční, neboť postup vy-
tvoření inkrementační je analogický. Pouze musí-
me pro každý den vytvořit zálohu s jiným jménem
a nastavit typ Incremental místo Differential.

Asi nejrychlejším způsobem je využít již exi-
stující „Plne patecni“ zálohy, jen je třeba ji upra-
vit a uložit pod novým jménem. V hlavním okně
zvolte v menu File >> Open Backup Job a vyber-
te „Plna patecni“ (je v adresáři NovaBackup\
Scripts\Backup). Otevře se právě definovaná pl-
ná záloha. Nyní změňte její název na „Diferenc-
ni po–ct“ (v poli Backup Job Name) a klikněte na
tlačítko Schedule v dolní části okna. Naplá-
nujte spouštění týdně (Schedule Type = Weekly)
a zaškrtejte dny pondělí až čtvrtek (Monday, Tu-
esday, Wednesday, Thursday). Zaškrtněte volbu
Overwrite Backup, aby nový soubor se zálohou
vždy přepsal ten starý. Ještě nastavte čas spou-
štění zálohování (Start Time) a sekci Schedule
máme připravenu (klikněte na [Save]). Ještě je

ovšem potřeba změnit typ zálohy. Klikněte na 
Settings a na záložce Backup nastavte Backup
Type na Differential. To je veškeré nastavování,
kliknutím na Save všechny změny uložíme.

Celé plánováni zkontrolujeme pohledem na
stránku s Schedule. Měli bychom tam najít
naši „Plnou patecni“ a „Diferencni po-ct“. Klik-
nete-li na „Plna patecni“ pravým tlačítkem myši,
budete si moci z kontextového menu vybrat vol-
bu Run now a okamžitě definovanou zálohu spus-
tit a tím ji vyzkoušet. Pak do svých dokumentů při-
kopírujte nějaké další dokumenty, popř. existují-
cí upravte, aby proběhla nějaká změna, a stejným
způsobem spusťte i diferenční zálohu.

Chování zálohování ovlivňuje nastavení do-
stupné přes menu View > Global Setting, zálož-
ky Backup, Filters, Encryption a Anti-virus. Jed-
notlivé volby si stručně popišme:
• Backup – zde nalezneme základní nastavení
zálohování. Doporučuji ponechat všechny volby
zaškrtnuté.
• Filters – v této sekci nastavujeme filtry, kte-
ré řídí výběr souborů do zálohy. V části Exclude
files definujete (podle přípony) typy souborů, kte-
ré zálohovány nebudou. Pokud tedy nebudete
chtít zálohovat soubory MP3, stačí přidat do Ex-
clude listu příponu. Klikněte na tlačítko [Add], na-
jděte MP3 a stiskněte [OK].
• Encryption – možnost námi vytvořené zálohy
chránit heslem. Stačí jen zaškrtnout Encrypt fi-
les in backup a zadat dvakrát heslo. Toto heslo
pak bude vyžadováno pro práci se souborem zá-
lohy.
• Anti-virus – nastavení interního antivirového
systému NovaStor.

Nakonec se pojďme podívat na vytvořené zá-
lohy a při té příležitosti si i ukážeme, jak soubo-
ry ze zálohy obnovit.

Kontrola záloh a obnovení
souborů
Jak zjistíme, co máme v záloze? V hlavním okně
klikneme na tlačítko Restore. Tato sekce
zprostředkuje jednotný přístup k zálohám, ať už
je máte uložené na jakýchkoli médiích. Klikněte
na Refresh, v horní části okna se objeví se-
znam záloh, uspořádaný do stromové struktury
podle zařízení. Pokud tam vámi hledaný soubor
se zálohou nenajdete, klikněte na menu File >
Import Backup Set > Import from file, vyhledejte
soubor se zálohou a stiskněte [Otevřít]. Soubor
by se měl přidat do seznamu. Nyní na něj dva-
krát klikněte levým tlačítkem myši.

V dolních dvou oknech se objeví obsah zá-
ložního souboru: v levém okně adresářová struk-
tura, v pravém soubory z aktuálně označeného
adresáře. Jestliže některé (nebo všechny) adre-
sáře či soubory označíte, zpřístupní se tlačítko

Restore v pravém dolním rohu okna. Pokud
na něj kliknete, označené soubory a adresáře se
ze zálohy obnoví, a to na místo podle aktuální-
ho nastavení (o čemž budete informováni dialo-
gem).

Chování obnovy dat ze zálohy ovlivňuje na-
stavení dostupné přes menu View > Global Set-
tings, záložka Restore. Zde najdeme dvě sekce:
■ Sekce [When restoring a file…] obsahuje vol-
by řídící chování v případě, že na cílovém místě
již existuje soubor se stejným jménem. Možné
akce jsou:
• Do not overwrite existing file – nepřepisovat
existující soubory,
• Overwrite existing files if they are older –
přepsat existující soubory, pokud jsou starší,
• Overwrite existing files – přepsat existující
soubory.
■ Sekce [Restore file placement]:
• Restore file(s) to original location – obnovit
soubory ze zálohy na původní místo (do původ-
ního adresáře),
• Restore file(s) to temporary location – obno-
vit soubory ze zálohy do pomocného adresáře.

Logy
Protože v ideálním případě mají všechny zálohy
probíhat automaticky bez zásahu uživatele (ten
maximálně dohlíží na to, aby v mechanice bylo
vždy připravené správné médium), jediný způsob,
jak se dozvědět, zda vše proběhlo správně, jsou
právě logy. Klikněte na Logs a v okně se
zobrazí seznam proběhlých operací. Dvojitým
kliknutím na řádek pak soubor s podrobnými in-
formacemi o záloze otevřete.

Závěr
Vše podstatné jsem řekl na začátku. Věřte nebo
ne, zálohování je mimořádně důležité! Všechny,
které nepřesvědčím já, přesvědčí až první větší
ztráta dat. A pokud alespoň jednomu z vás pro-
gram NovaBACKUP zachrání data, pak naše prá-
ce měla smysl.

URL: www.novastor.com/pcbackup 5 0324/OK ❏
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• Datum dalšího spuštění podle plánu
• Periodicita

spouštění• Jméno zálohy
• Výsledek

posledního
běhu

• Datum 
posledního 
běhu

• Uvítací obrazovka

• Průvodce
• Zálohování souborů

• Obnova ze zálohy

• Záznamy o činnosti

• Plánování

• Obnovit 
obsah 
okna

• Smazat 
plán

• Upravit 
plán

• Přidat
nový 
plán

• Záznamy
o výsledcích
backupu
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