О создателях

AIMP classic
О создателях

Автор программы: | Артем Измайлов
Дизайн: | Сергей Рюмин
Составление справки: | Артем Измайлов Губарев Александр

Так же хочется выразить благодарность всем людям, которые поддерживали развитие данного проекта, делились своими идеями, присылали свои замечания и предложения. Без вашего участия проект просто не может существовать!

  • BASS Library (+ дополнения) (c) 1999-2006 Ian Luck (www.un4seen.com)

  • WavPack(с)1998-2006 Conifer Software (http://www.wavpack.com)

  • Ogg Vorbis (c) 1994-2006 the Xiphophorus Company (www.vorbis.com)

  • FLAC (c) 2000-2006 Josh Coalson (www.flac.sourceforge.net)

  • Monkey's Audio (c) 2000-2006 Matthew T. Ashland ( http://www.monkeysaudio.com)

  • LAME MP3 Encoder (http://lame.sourceforge.net)


AIMP Classic: Help

Что такое AIMP?

Программа AIMP - это многофункциональный аудио центр. Благодаря встроенным утилитам, вы легко с можете перекодировать музыку из одного формата в другой, записать звук с микрофона или другого звукового устройства, отредактировать тэги музыкальных файлов, а так же группой переименовать или отсортировать их. AIMP Classic базируется на известном аудио движке BASS (www.un4seen.com) - вы с легкостью можете подключить плагины от этой библиотеки к AIMP.
Здесь вы сможете найти всё, что хотели от аудио плееров и даже больше...

Какие преимущества?
  • Технология воспроизведения принципиально отличается от Winamp и WMP
  • Чувствительный 18-ти полосный эквалайзер
  • Огромная функциональность
  • Минимальное потребление системных ресурсов.
  • Размер проги всего 2,5 Mb!
  • Многоязычная поддержка
  • Встроенный аудио конвертер
  • Встроенный аудио граббер
  • Встроенный редактор тэгов
  • Встроенный модуль "Звукозапись"
  • Поддержка большого кол-ва форматов
  • Выключение компьютера в заданное время
  • Множество функций и удобный интерфейс позволит вам всего парой кликов мыши проиграть вашу любимую музыку, перевести ее в другой формат
  • Данная программа грузится намного быстрее, чем другие плэйеры.
  • Настройка глобальных и локальных горячих клавиш ( + шаблоны от WinAmp и WMP )
  • Гибкие настройки программы, плагины и различные обложки позволят вам сделать AIMP полностью индивидуальным
  • AIMP включает в себя дополнительные утилиты, которые делают его не только проигрывателем,а целым Мультимедиа Центром
    Вверх
Расширь возможности с помощью плагинов!
  • Поддержка плагинов, с помощью которых можно расширить возможности программы: добавить новые утилиты и изменить уже имеющиеся!
  • AIMP поддерживает Input, DSP и GPP плагины от WINAMP
    Чтобы установить плагины достаточно скопировать их в папку "Plugins" и перезапустить AIMP
    Вверх
Поддержка множества форматов!
  • Поддержка множества форматов аудио: wav; ogg; wma; cda; mp3; mp2; mp1; mtm; mod; xm; it; aif; umx; s3m; mo3; и др.
    Данный список поддерживаемых форматов можно пополнить, подключив плагины.
    Вверх
Эквалайзер и эффекты
  • Медиа плеер имеет 18-ти полосной эквалайзер, позволяющий изменять звучание до наилучшего качества. Также имеются стандартные заготовки для некоторых типов музыки, портированные из WINAMP.
  • Кроме эквалайзера также имеется 4 спецэффекта: Chorus, Echo, Flanger, Reverb. Каждый из которых имеет собственные настройки, которые сохраняются при завершении работы программы.
    Вверх
Дополнительные возможности:
  • Аудио Конвертер позволяет конвертировать музыку из самых разных форматов в популярные wma,mp3,wav,ogg.
  • АудиоГраббер позволяет "грабить" AudioCD (CDA) в MP3,OGG,WAV или WMA
  • Звукозапись позволит вам записать звук с любого аудио устройства в системе в mp3, ogg, wav и wma!
  • Имеется встроенный редактор тэгов, с помощью которого вы легко можете редактировать теги аудио файлов, а также переименовать файлы группой, отсортировать по заданному шаблону или применить значения тэгов к группе файлов.
    Вверх

Возможность участия в разработке программы:
  • появилась хорошая идея или вам нравится какая-нибудь особенность другого плеера? - мы всегда рады выслушать ваши замечания и предложения.
  • здесь вас ждёт полное понимание и поддержка разработчика
  • у вас есть хорошая идея, способная улучшить AIMP - пишите на E-mail
  • вы хорошо знаете какой-либо язык (кроме уже имеющихся :) ) - сделайте локализацию AIMP и пришлите её нам, на 100% она появиться в комплекте с программой.
  • возможны и другие сферы сотрудничества и если вы человек творческий, то найдёте их сами
    Вверх


Не работают мультимедиа клавиши

Ча.Во.
  1. При воспроизведении файлов вверху экрана выскакивает черная полоска, как ее отключить?
  2. Как записать радио в AIMP?
  3. У меня почему-то не работают мультимедиа клавиши?
  4. Как подключить плагины к AIMP?
  5. Использование AIMPа как autorun'а
  6. При сворачивании плеера в трей появляется панель, мне она очень мешает, можно ли ее убрать?
  7. Где AIMP хранит свои настройки?
  8. Плеер не переходит на следующий трек! (Повтор файла и плейлиста)
  9. Очень не хватает такой функции, как очередь воспроизведения...


Главное окно

Главное окно

Основные элементы дисплея:

  1. Главное меню программы
  2. Вызов окна настроек программы
  3. Запуск дополнительных утилит программы - аудио конвертера, звукозаписи или редактора тегов.
  4. Информационная полоса - отображает информацию о проигрываемом файле, настроить ее можно здесь: Настройка - Воспроизведение - информация.
  5. Битрейт играемого файла
  6. Частота играемого файла
  7. Скопировать текущий файл в буфер обмена - вы сможете вставить данный в файл в любом окне "проводника".
  8. Редактировать тег.
  9. Кнопка захвата интернет-потока, работает, когда вы слушаете интернет-радио или интернет-файл. Настроить параметры захвата можно здесь: Настройка - Воспроизведение - потоковое аудио
  10. Кнопка включения режима "случайный файл", т.е. воспроизведение в плэйлисте будет иметь не последовательный, а случайный характер.
  11. Кнопка включения режима "повтор файла". Один и тот же файл будет играть, пока не надоест пользователю.
  13. Текущая позиция воспроизведения
  14. Кнопки управления воспроизведением - Старт/Пауза/Стоп. Если во время воспроизведения файла нажать кнопку старт, то воспроизведение начнется с начала.
  15. Следующий/Предыдущий файл.
  16. Регулятор громкости плеера (не глобальной)
  17. Кнопка "открыть файлы" для воспроизведения
  18. Кнопка "Поверх все окон" определяет будет ли плеер всегда поверх всех окон или нет.
  19. Свернуть плеер. По умолчанию - сворачивание происходит в трей, чтобы свернуть плеер на панель задач, нужно нажать на данную кнопку с зажатым Alt.
  20. Закрыть плеер.
  21. Кнопка включения/отключения режима "автовыключение компьютера".
  22. Текущее состояние плеера.
  23. Время текущей композиции. Может быть настроено - оставшееся/прошедшее. (Для смены настройки достаточно щелкнуть левой кнопкой мыши)
  24. Таймер отображает состояние режима "автовыключение компьютера". В том случае, если режим отключен - таймер будет показывать 00:00:00. Если режим включен и отключение должно произойти при завершении плейлиста - таймер будет мигать. Если режим включен и отключение должно произойти в заданное время - таймер будет показывать оставшееся время до выключения компьютера.
  25. Spectrum Visualization
  26. Скрыть/показать эквалайзер (эквалайзер имеет настройки звуковых эффектов)
  27. Дисплей для отображения 3D-визуализаций.
  28. Выбор текущей визуализации.
  29. Регулятор баланса.
  30. Следующий/предыдущий плейлист
  31. Выбор действия по окончанию текущего плейлиста
  32. Пункт "менеджер плэйлистов" - содержит функции для работы с плэйлистами - очистить, сохранить, открыть, переименовать и т.п.
  33. Информация о текущем плейлисте
  34. Статус файла в плейлисте - стоит в очереди на воспроизведение или нет.
  35. Список всех загруженных плейлистов
  36. Пункт "добавить файлы" - добавление в плэйлист файлов, целых папок, url, плэйлистов.
  37. Удаление файлов.
  38. Пункт разное - содержит следующие команды:
    • Инфо о файле - показать информацию о выбранном файле.
    • Пересканировать плэйлист - сканирует файлы из плэйлиста на наличие тэгов и выводит обновленные данные в плэйлисте.
    • Показать текущий - переход к текущему (проигрываемому) файлу в плэйлисте.
    • Генерация трек листа
    • Отправить файлы - отправка файлов в утилиты (редактор тегов/конвертер) или на внешние устройства, например, флешки.
  39. Пункт "сортировка" - позволяет сортировать файлы в плэйлисте по заданному параметру.
  40. Пункт "поиск" - содержит функции для поиска файлов в плэйлисте, имеется быстрый и расширенный поиск.

Вверх

Эквалайзер

  1. Включение/Отключение эквалайзера - удобная функция, позволяющая отключить эквалайзер, не сбрасывая все настройки.
  2. Чувствительность эквалайзера
  3. 18-ти полосный эквалайзер
  4. Меню эквалайзера, здесь можно загрузить/сохранить и сбросить настройки эквалайзера.
  5. Графическое отображение настроек эквалайзера(для быстрой подстройки эквалайзера вы можете редактировать график мышкой)
  6. Звуковые эффекты
  7. Список звуковых эффектов от винампа (плагинов DSP) и кнопка их настроек. При выборе эффекта из списка он автоматически включается. Чтобы отключить эффекты, необходимо выбрать из списка "(отключено)".
  8. Регулятор скорости воспроизведения
  9. Регулятор баланса
Вверх


Настройка всплывающего окна "Track Info"

Настройка всплывающего окна "Track Info"

Всплывающее окно "Track Info" - при старте проигрывания файла показывается по верх всех окон информация о данном файле в виде небольшой ленты.

Отключение всплывающего окна

Отключить (или наоборот, включить) появление данного окошка можно в настройках программы: Настройка - Система - Компоненты, вкладка "информационная полоса", опция "при старте воспроизведения показывать информацию о текущем файле"

Настройка всплывающего окна

Для настройки всплывающего окна, перейдите в настройки программы: Настройка - Система - Компоненты, вкладка "информационная полоса" Вы можете выбрать шрифт, которым будет выводиться информация о проигрываемом файле.

Назад


Всплывающие подсказки (hints)

Всплывающие подсказки (hints)

При наведении курсора к какому-либо элементу AIMPа, появляется всплывающая подсказка (hint).
Вы можете отключить или настроить окно всплывающей подсказки, а именно ее цветовую гамму - цвет рамки, цвет фона, шрифт и т.п.
(Настройка -> система -> компоненты, вкладка "всплывающие подсказки")


Управление плеером

Управление плеером

Горячие клавиши
В AIMP имееются два вида горячих клавиш - локальные и глобальные.

Локальные - горячие клавиши, которые работают, только если AIMP является активным окном. По умолчанию локальные горячие клавиши настроены по схеме AIMPа, но вы так же можете настроить их посхеме WinAmpа, нажав кнопку "схемы".

Глобальные - горячие клавиши, которые работают всегда, даже если AIMP не является активным окном. Стоит отметить, что теперь в качестве глобальных клавиш вы можете использовать мультимедиа клавиши. Если глобальная клавиша не может быть назначена, то скорее всего она уже задействована в другой программе.
(Настройка - управление - горячие клавиши)
Вверх

Информация о файле

Для быстрого получения информации о проигрываемом в данный момент времени, достаточно подвести указатель мыши к иконке в трее и подождать (зависит от настроек) 1,5 сек. После чего появляется окно с информацией.

Можно вызвать данное окно еще двумя способами:
  • 1-ый способ: В плеере щелкнуть левой кнопкой мыши по кнопке "информация о файле"
  • 2-ой способ: Щелкнуть правой кнопкой мыши на иконке в трее и выбрать пункт меню "Инфо о файле".

Так же вы можете в данном диалоге вызвать информацию о любом файле из плэйлиста, для этого нужно выбрать файл в плэйлисте, нажать правую кнопку мыши и, в появившемся контекстном меню, выбрать пункт меню "Инфо о файле".

Настройки иконки в трее можно найти здесь: Настройки - Система - трей. В данном окне вы можете не только получить информацию о данном треке, но и быстро перейти к редактору тэгов или скопировать данный файл в буфер обмена.
Вверх

Управление громкостью

Управление громкость может осуществляться как обычным изменением положения ползунка громкости, так и использованием горячих глобальных или локальных клавиш. Так же вы можете вызвать регулятор громкости, два раза щелкнув по иконке в трее левой кнопкой мыши. Стоит отметить, что события, которые должны происходить по нажатию на иконке в трее, можно настроить: Настройки - Система - трей.
Вверх

Автоматическое выключение компьютера

Благодаря данной функции, вы можете лечь спать, включив свою любимую музыку, AIMP сам завершит его работу в заданное время или по окончанию плейлиста.

Для включения таймера:
  • Способ 1: - Главное меню, пункт меню "автовыключение компьютера".
  • Способ 2: - воспользоваться кнопкой быстрого доступа.

Вверх

Управление из трей-меню

  • Правая кнопка мыши по иконке в трее - вызов контекстного меню, из которого можно управлять программой - вызвать информацию о текущем файле, вкл/выкл горячие клавиши, управлять воспроизведением, перейти к меню плагинов, обложек, утилит и настройкам.
  • Левая кнопка мыши (одиночный клик) - свернуть/развернуть программу из трея.(данная команда может быть настроена в меню опций: Настройки - Система - трей);
  • Левая кнопка мыши (двойной клик) - вызов окошка управления громкостью и скоростью воспроизведения (данная команда может быть настроена в меню опций: Настройки - Система - трей);
  • Средняя кнопка мыши- переместить AIMP на передний план, даже если он свернут в трей. (данная команда может быть настроена в меню опций: Настройки - Система - трей);
    Вверх

            •


Подключение плагинов

Подключение плагинов

Для расширения возможностей, AIMP имеет возможность подключения плагинов.

Все плагины можно разделить на несколько типов:
  • AIMP Audio Players - плагины поддержки новых звуковых форматов (в том числе IN плагины от винампа).
  • AIMP Playlists - плагины, позволяющие читать новые форматы плэйлистов и записывать в них.
  • AIMP Visualization - плагины поддержки новых визуализационных форм (в том числе плагины от Sonique).
  • AIMP Addons - плагины "дополнения", не имеют какого-либо точного назначения, они могут выступать как новые модули утилиты, новые функции, как поддержка дополнительных плагинов и т.п (в том числе GPP плагины от винампа).
  • WinAmp DSP - плагины DSP от винампа, выступающие в качестве плагинов звуковых эффектов.
  • AIMP Encoders - плагины "конверторы", используются в таких модулях как "аудио конвертер" и "звукозапись" для чтения/записи в поддерживаемый аудио формат.

Подключение/отключение плагинов

По умолчанию плеер подключает все плагины, которые лежат в его рабочей папке \Plugins. Поэтому для установки плагины достаточно скопировать его в папку Plugins и перезапустить плеер.
Если опция автоматической загрузки отключена, то плагин можно подгрузить вручную:

Подключение плагинов:

  • Выбираем Главное меню, пункт меню Плагины (рис. слева)
  • Далее выбираем слева, в списке нужный плагин (№1)
  • Нажимаем кнопку "Загрузить" (№2)
  • Если плагин успешно загружен, то он будет показан в списке справа. (№4)

Отключение плагинов:

  • Выбираем Главное меню, пункт меню Плагины (рис. слева)
  • Далее выбираем справа, в списке нужный плагин (№4)
  • Нажимаем кнопку "Выгрузить" (№3)
  • Если плагин успешно выгружен, то он будет показан в списке слева.
Стоит отметить, что полная отгрузка плагина произойдет после перезагрузки плеера.

Назад


Управление плеером

Обложки

Установка обложек

По умолчанию включена автоматическая установка обложек, т.е. достаточно кликнуть два раза мышкой по файлу с обложкой, и она установлена.
Если автоматическая установка по каким-либо причинам отключена, то для установки обложки достаточно скопировать ее в папку AIMP\Skins\. Далее достаточно кликнуть по дисплею визуализации правой кнопкой мыши,

и в появившемся контекстном меню, в пункте "обложки" выбрать нужную обложку.
Вверх


Аудио конвертор

Аудио конвертор

Модуль "Аудио конвертер" позволяет преобразовать аудио файлы из формата wav; ogg; wma; cda; mp3; mp2; mp1; mtm; mod; xm; it; umx; s3m; mo3; в WMA, MP3, WAV или OGG. Также данный модуль позволит вам "грабить" аудио диски (CDA) в MP3, WMA, OGG, WAV.

Чтобы начать процесс конвертирования Для начала записи звука необходимо:
1. Добавить исходные файлы в рабочий лист, используя различные виды команд (кнопки "Добавить", "Загрузить файлы из плейлиста" или контекстное меню рабочего листа). Для извлечения звуковых дорожек с аудио диска необходимо выбрать привод-источник (куда помещён аудио диск) из меню выпадающего списка в верхней части конвертера.

2.Выбрать кодек, которым будет обрабатываться аудио данные.
3.Настроить параметры аудио данных выходных файлов ("Качество").
4.Выбрать путь сохранения: папку, в которую будет произведено сохранение и формат имени сохраняемых файлов.
5.Нажать кнопку "Старт".

Вверх

Прекращение процесса конвертирования файлов

Для прекращения процесса конвертирования файлов необходимо нажать кнопку "Стоп".

Вверх

Выбор имени выходного файла.

При преобразовании файлов вы можете выбрать шаблон, согласно которому будет генерироваться имя выходного файла. Переменные для данного шаблона берутся из тэгов файлов-источником. В случае, если в файле-источнике отсутствует тэг, то имя выходного файла будет такое же как и у файла-источника.

Вверх

Дополнительные опции

Удалить исходный файл после преобразования - программа удаляет исходные файлы после конвертирования с жесткого диска (внимание: удаление происходит _не в корзину_).

  • Показывать отчёт об ошибках - при возникновении проблем в конвертировании, программа оповестит вас о них.
  • Разрешить подключение к базе данных - при преобразовании обычных CDA дисков программа может подключится к глобальной базе данных CDDB и скачать информацию о исполнителе, альбоме ... , и занести ее в тэги выходных файлов. (требуется подключение к интернет).
  • Использовать тэги из файлов источников - выходные файлы преобретут тэги файлов источников (эта опция должна быть включена, если вы хотите использовать CDDB).
  • Размер буфера - объем памяти выделяемый для хранения преобразованных данных в течении одного шага конвертирования, не рекомендуется изменять его значения, т.к. некоторые плагины могут не поддерживать эту опцию.
  • Использовать тэги заданые пользователем - присваивает композициям тэги, введённые пользователем.

Вверх

Панель статуса

Статус: - отображает текущее состояние конвертера.
Верхняя полоса прогресса - индикатор прогресса выполнения полной работы.
Нижняя полоса прогресса - индикатор прогресса выполнения работы над текущей композицией.
Верхняя правая строка - имя конвертируемого файла.
Нижняя правая строка - имя выходного файла.
N/M - текущий номер файла из общего числа конвертируемых файлов.

    1. Процент сжатия относительно файла-источника.
    2. Процент сжатия относительно не сжатых данных файла-источника, т.е. если бы файл-источник хранился в формате: WAV 44.1 kHz, 2 ch, 16 bit.
    3. Объем обработанных данных из файла-источника.
    4. Объем обработанных не сжатых данных из файла-источника.
    5. Размер выходного файла на жестком диске в текущий момент
    6. Скорость обработки не сжатых данных из файла-источника.

Вверх


Звукозапись

Звукозапись

Модуль "Звукозапись" позволяет записать аудио данные с любого звукового устройства в системе. Сохранить аудио данные можно в один из четырех (по умолчанию) форматов: MP3; OGG; WMA; WAV;

Чтобы начать запись звука

Для начала записи звука необходимо:

  • Выбрать кодек, которым будет обрабатываться аудио данные.
  • Настроить параметры сжатия ("качество").
  • Выбрать папку, в которую будет произведено сохранение. Обратите внимание, что имя файла программа по умолчанию устанавливает сама - время, когда была начата запись, при желании вы можете его изменить в соответсвующем поле ввода или сгенерировать случайное имя файла нажав кнопку "?".
  • Выбрать аудио устройство, с которого будет осуществлена запись
  • Выбрать аудио вход (у устройств входов несколько, как правило: WaveOut, LineIn, Microphone и др.)
  • Нажать на кнопку "Старт"

Вверх

Фильтр уровня сигнала

Иногда, бывает нужно записывать не все аудио данные, а только те, амплитуда которых больше заданного параметра. Итак, опция "Уровень сигнала" и регулирует данный параметр. (по умолчанию - регулятор должен стоять в крайнем левом положении). Если опция включена, то при старте записи вы увидите на дисплее красную линию - уровень, ниже которого данные будут игнорироваться.

Вверх

Статус

    Свободное место - отображает заполнение жесткого диска, когда места будет не хватать, то AIMP остановит запись автоматически.
    Вход - объем данных, который был получен с звукового устройства
    Выход - объем данных, уже сжатых выбранным кодеком, сохраненных на диск.
    Пропущенно - объем данных, который был пропущен - это возможно в двух случаях:
    1.Используется фильтр уровня сигнала.
    2.Кодек, которым ведется обработка, не успевает обрабатывать все данные.
    Сжатие - коэф. сжатия данных
    Время - продолжительность записи.

Вверх


Редактор тегов

Редактор тегов

Поддерживаемые форматы

Редактор тэгов AIMPа поддерживает следующие форматы: *.mp3;*.ogg;*.wma;*.aac;*.flac; а так же файлы, содержащие ID3v1 и ID3v2 тэги.
Вверх

Добавление файлов

Добавить файлы для обработки можно:

  • загрузить плэйлист;
  • добавить файлы, воспользовавшись кнопкой "добавить".
  • использовав быструю навигацию по папкам (панель слева).
Стоит отметить, что в редакторе имеется два подкаталога: файлы выбранные пользователем; файлы на жестком диске. В первый из них файлы добавляются первыми двумя способами (описаны чуть выше), во второй - через быструю навигацию по папкам, стоит отметить, что последний - отображает все аудио файлы (возможные для редактирования), находящиеся в этой папке (подпапки игнорируются).

Для добавления нужно воспользоваться соответствующими кнопками на панелe инструментов.
Вверх

Работа с редактором тэгов.

Редактирование одного файла

Прежде всего вам необходимо добавить файлы в редактор тэгов. Далее, чтобы отредактировать тэг, необходимо выбрать из списка нужный файл, при этом в закладке "редактирование одного файла" станут активны закладки, в которых вы можете отредактировать и сохранить тэги в соответствующем формату файла.

Редактирование группы файлов.

Прежде всего вам необходимо добавить файлы в редактор тэгов. Далее, чтобы отредактировать тэги сразу у нескольких файлов, необходимо выбрать из списка нужные файлы, в закладке "редактирование группы файлов" необходимо выбрать нужные поля (которые нужно отредактировать сразу у выбранных файлов), поставив напротив них галочки, а так же ввести необходимые значения в соответствующие поля. И наконец, нажать кнопку "сохранить".

Переименование группы файлов.

Прежде всего вам необходимо добавить файлы в редактор тэгов. Далее, чтобы переименовать файлы, необходимо выбрать из списка нужные файлы, в закладке "Переименование группы файлов" необходимо задать общий шаблон, по которому будет происходить переименование. Все переменные параметры, которые вы можете использовать в шаблоне указаны справа от поля ввода, стоит отметить, что остальной текст так же будет учитываться при переименовании файлов, кроме запрещенных 7 символов, а символ "\" будет оценен как путь к каталогу, его можно использовать для сортировки по папкам.

Также вы можете задать папку, в которую будут перемещаться файлы, в противном случае файлы будут оставаться в текущей папке (в которой и находились, если в форматной строке не используется символ "\").

Вы можете использовать кнопку "предпросмотр", чтобы увидеть как будут переименованы файлы.
Вверх


Техническая поддержка

Техническая поддержка

Официальный сайт: http://www.aimp.ru
Автор: Артем Измайлов

Все вопросы, пожелания и замечания вы можете направить автору или оставить на форуме.
Ваши предложения будут с удовольствием рассмотрены и учтены при разработке новых версий.


Запись плеера на диск в качестве autorun`а

Подключение плагинов

AIMP можно использовать в качестве авторана при записи музыкальных дисков, т.е. при запуске диска загрузится плеер с плэйлистом (плэйлистами), в которых загружена музыка, содержащаяся на компакт диске.
Итак, как же это сделать? Делается это так:

  • Создаем временную папку, например, C:\temp.

  • Создаем в ней папку для музыки, например, audio, помещаем туда всю музыку, которую нужно записать на компакт диск, например, создадим 2 папки: C:\temp\audio\album1 и C:\temp\audio\album2, в обоих разместим какую-то музыку.

  • Теперь создадим папку для самого плеера: C:\temp\player\>. Далее создаем командный файл: aimp.bat в папке с установленным плеером ( по умолчанию: Program Files\AIMP Classic\ ), в него необходимо прописать следующее:
    cAIMP.exe /acpy "C:\temp\player\". Далее просто запускаем aimp.bat и плеер сам скопирует в указанную папку необходимые файлы для автозапуска.

  • Далее нам нужно создать плэйлист(ы), содержащие эту музыку. В данном примере рассмотрим создание двух плэйлистов из соответствующих папок: album1 и album2. Итак, запускаем сам плеер (тот, что установлен в системе, а _не_ подготовленный для записи!). Идем в опции и отключаем сохранение прямых путей: Настройки - плэйлист - "сохранять полные пути к файлам." Далее добавляем файлы из папки album1 в новый плэйлист и после его сканирования сохраняем в формате plc в папку C:\temp\. Тоже самое проделываем со второй папкой - album2.

  • Теперь остается прописать эти плэйлисты для автозагрузки в плеер:заходим в папку player\data\AllUsers\ и открываем файл aimp.ini в блокноте, идем в конец файла и прописываем следующие строки:
    [playlists]
    Count=2
    pls0=..\..\..\..\album1.plc
    pls1=..\..\..\..\album2.plc
    Count - кол-во плэйлистов. pls# - адрес к #-ому плэйлисту. Заметьте, что адреса к плэйлистам заданы относительно папки player\data\AllUsers\PLS\.

  • И последний завершающий штрих - информация для автозапуска, т.е. autorun.inf - создаем его в папке C:\temp\ и прописываем:
    [autorun]
    open=player\caimp.exe
    icon=player\caimp.exe

  • Теперь остается все содержимое папки (_не_ саму папку!) c:\temp записать на диск.

    Назад


Расположение файлов конфигурации

Расположение файлов конфигурации

В зависимости от выбранного режима плеера, AIMP хранит настройки в разных местах.

  • Многопользовательский - плеер хранит настройки и пользовательские плейлисты, автоматически сохраненные, в папке "Documents and Settings\<UserName>\Application Data\AIMP". Данное размещение настроек позволяет разным пользователям системы настраивать плеер на свой вкус, не мешая при этом другим пользователям.

  • Однопользовательский - плеер хранит настройки в собственной папке: "<AIMP Classic>\Data\". Для всех пользователей данные настройки едины.

Стоит отметить, что в пользователях с ограниченным доступом (запретом на запись и т.п) рекомендуется использовать многопользовательский режим, т.к. зачастую запись в папку "Program Files" запрещена - это приведет к не сохранению настроек и плейлистов.

Назад


Не работают мультимедиа клавиши

Мультимедиа клавиши
Не работают мультимедиа клавиши в AIMP.
Такая проблема может возникать только в одном случае - данные клавиши уже перехвачены другой программой

1. Как правило - это стандартные драйвера для мультимедиа клавиатур. Их нужно отключить, если вы хотите, чтобы AIMP реагировал на мультимедиа клавиши.
2. Так же это может быть из-за другого плеера, который поддерживает MM-клавиши, например, Winamp или WMP.

Для настройки мультимедиа клавишь в AIMP: Настройки - управление - горячие клавиши.

Назад


Не работают мультимедиа клавиши

Очередь воспроизведения
Очень не хватает такой функции, как очередь воспроизведения....
На самом деле функция давно уже присутствует в программе, как сказал один из тестеров, она хорошо спрятана. Добраться до нее очень просто - нажать правую кнопку мыши в плейлисте, выбрать пункт "Переход" - Пункты "Очередь/Добавить в очередь/Очистить очередь"
Назад


Запись интернет-радио в AIMP'е

Запись интернет-радио в AIMP'е

Имееются 2 способа записи, включаются они так:
1) Alt + C или кнопочкой "RADIO CAP" на плеере (одно нажатие - включение записи, второе нажатие - выключение записи).
2) Ctrl + R или открываем "AIMP_Utils.exe" и переходи в утилиту "Звукозапись".

Теперь поподробнее:
1) первый способ схватывает звук интерент-радио налету. Настроить качество записи, формат и папку для выходных файлов можно в настройках по адресу: "AIMP Classic" - "Воспроизведение" - "Потоковое аудио" - "Захват интернет-радио". Названия выходных файлов будут генерироваться из информации пересылаемой по интернет-радио, например: "[Nightwish - Wishmaster (Live)] at 22-15-07.mp3", то что в квадратных скобках - это информация из радио, далее идет время записи "час-минута-секунда".
2) второй способ открывает утилиту звукозаписи. В ней можно настроить устройство с которого будет идти запись (аудио карту), аудио вход (то есть будет писаться звук с микрофона, или весь звук на компьютере, или радио и др.), кодеры, качество записи, папку и названия выходных файлов. По умолчанию название файла - это время открытия утилиты звукозаписи в формате "час-минута-секунда.mp3".

Первый способ удобен, именно при записи радио, потому что он быстрый: одно нажатие - вкючение, второе - выключение. А второй способ удобен для записи с микрофона или с компьютера. Радио тоже можно записывать, просто пока откроется утилита звукозаписи и вы все настроите, можно пропустить что-нибудь интересненькое.

Назад


Не работают мультимедиа клавиши

Повтор файла и плейлиста
Плеер не переходит на следующий трек.
Переходя с других программ воспроизведения музыки, пользователи часто путают кнопку "Повтор" на главном окне программы с "Повтором списка воспроизведения". Повтор списка воспроизведения в AIMPвключен по умолчанию, а кнопка "Повтор" на главном окне программы отвечает за повтор текущего файла.

Настроить действие по окончанию списка воспроизведения вы можете в настройках - (Настройки - События - По окончанию воспроизведения плейлиста), а также - воспользовавшись кнопкой быстрого доступа (см. рис):

Назад


Запись плеера на диск в качестве autorun`а

Подключение плагинов

Вопрос: ... при сворачивании плеера в трей появляется панель, мне она очень мешает, можно ли ее убрать?

Ответ: Да, у брать панельку можно. Для этого щелкаете по иконке в трее правой кнопкой мыши - появится меню. В нем выберите пункт "скрывать TrayControl" и поставьте напротив него галочку. Теперь при сворачивании данная панель показываться не будет. Включить при необходимости ее можно также.

Назад