Help index

Shisen-sho för Windows

  • Programmet och dess funktioner

  • Spelets histora och tekniska data

  • Spela Shisen-sho

  • Spara spelplaner

  • Mus och tangetnbord

  • Andra inställningar

  • Hantera Bitar

  • Symbolen Sjöhäst

  • Kända problem

  • Licens

  • Språk

Version 1.30

Kopieringsrättigheter Daniel F Valot October 30, 2006

E-post: r

http://dvalot.free.fr

Denna hjälpfil har översatts till Svenska av Jan-Erik Lärka


Programmet och dess funktioner

Detta program har översatts till Svenska av Jan-Erik Lärka

Syftet med programmet:

Detta är ett solitärspel.

Shisen-shogår ut på att para ihop och ta bort bitar två och två.

För att bitarna skall kunna tas bort, måste bitrna kunna “länkas” samman av maximalt tre sammanhängande linjer.

Figur 1 Sammanlänka bitar

Spela Shisen-sho:

  1. Linjerna som utgör länkarna kan inte korsa bitar.

  2. Du kan välja olika storlekar på pelplanen från menyn Inställningar.

  3. För det mesta är det enklare att lösa större spelplaner än mindre.

  4. Bästa spelarnaär de som löser spelet på kortast tid.

De flesta metoderna för fusk är inte tillgängliga för att spelet skall vara rättvist.


Spelets histora och tekniska data

Spelets historia

Var spelet kommer ifrån:

Jag vet inte var spelet kommer ifrån.

Vad betyder Shisen-sho:

Någon har berättat att namnet betyder “Delstaten Shisen” som ligger i Kina.

Designen av spelet Shisen-sho:

Jag såg spelet första gången på skrivbordet under Linux KDE.(Skapat 1997 av Mario Weilguni mweilguni@sime.com med hjälp av qt-teknologi)

Det finns flera Japanska varianter för Windows på Internet.

Programmet har utformats utifrån spelet KDE Kshisen, men är ingen portering därifrån.This is not a port. The program has totally been re-written using .NET WPF framework .(Detta program,uppbyggnad och lösningar, har skrivits från grunden med Windows APIer.)

Jag har även tagit hjälp och ideér från andra program:

Sisen för Win32 av Ono Shinji (1998)

Shisen Sho för Java av Barry Neilsen (1999) barry@redsand.demon.co.uk

Några bitar har satts samman med hjälp av delar från exempel Mahjong från IBM VisualAge Toolkit.

Några av bitarna kommer från allmänna samlingar som Ron Balewski tagit fram för hans spel Mahjong (MJVGA och MJWIN)(Ron Balewski 412 E. Ridge St. Nanticoke, PA 18634-2915) ; utifrån vilka jag har byggt 3D-bitar och kopierat orginalbilden.

Från början skrev jag programmet för mig själv så att jag inte skulle behöva starta Linux.

Utveckling:

Microsoft Visual C# 2005 Express Edition har använts för att skapa detta spel.

Profiler och poäng:

Information sparas i systemets register under

C:\Documents and Settings\User_Name\Local Settings\Application Data\TheSeaHorse\ShisenCS.exe_Url_idkttb4ign45k02ia1a22wznel4lec1a\4.3.4.0...

Figur 2 Registerdata för Shisen-sho

OS/2 Version:

Det finns en version för OS/2 tillgänglig på min hemsida.

Funktioner:

Denna version av Shisen-sho har fler funktioner än någon annat liknande spel. Det går bl.a. att ändra storleken på fönster och brickor under spelets gång. Jag vet inte av finns i något annat spel och är därför intresserad av information om nya funktioner.


Spela Shisen-sho

Spelplanens utformning:

Spelplanen byggs upp olikaberonede på:

1-Storlek och bitar

Storleken kan sättas till 14*6, 18*8, 24*12, 26*14 or 30*16. (med Inställningar->Storlek)

Två olika motiv på bitarna medföljer.

2-Svårighetsgrad

Kan sättas till “Lätt”,” Medium” eller “Svår”. Det är ingen större skillna mellan lätt och medelsvår nivå. Svår innebär att spelet undviker att placera ut bitar som hör samman intill varandra.(med Inställningar->Nivå).

3-Lösbart spel:

Programmet kontrollerar att spelet kan lösas när bitarna placeras ut. Spelet är definitivt lösbart om programmet anger att spelet är lösbart. Ett spel som anges som ej lösbart kan ändå vara lösbart då det är mycket svårt att utforma en modul för lösningar som på en kort stund och på ett pålitligt sätt kan lösa ett spel.

4-Gravitation:

Bitarna sjunker ner mot botten. Ångra och gör om kan fortfarande användas. Inställningen kan endast göras innan spelet påbörjas.

5-Sjunk samman:

Kombinerar Gravitation och att bitarna omfördelas och sjunker ner. När ett par bitar tagits bort jämförs staplarna med de närliggande staplarna. Från den högsta staplen faller därefter en bit. Om två eller flera staplar innehållerflest bitar, faller en bit från den stapel som ligger längst till vänster.

6-Håll ihop:

Gör att bitarna flyttas samman och tar bort tomma rader och kolumner.

Detta gör at spelet blir svårare.

7-Undvik pip:

Spela utan ljud.

8-Undvik 3D:

Alternativ för långsamma datorer.

9-Bakgrundsbild på Asama:

Bild över vulkanen Asama i närheten av Tokyo.

10-Handikappade:

Gör att man kan spela spelet med et finger. (Utan att behöva använda musen) Läs om inställningarna för tangenter

11-Använd förvald bakgrund:

Inställningen “Använd förvald bakgrund” gör att den inbyggda bakgrunden visas. Välj alternativet “Ladda in bakgrundbild” på menyn för “Fil” för att välja en egen bakgrund. Endast bilder av typen Windows RLE kan användas. Vad som händer om bilder av andra typer används kan inte förutsägas.Vissa bilder av typen OS/2 kan även användas.

Ångra / Gör om

Varje bit som tas bort kan återställas med alternativet Ångra.

Varje bit som återställts med alternativet ångra kan tas bort igen med Gör om.

Alternativen är endast tillgängliga om de kan användas.

Ångra/Gör om aktiverar fuskläget, men eftersom det vanligtvis tar längre tid att använda ångra och gör om så räknas det inte in i poängsammanställningen.

Demoläge:

Demoläget kan användas för att gör det svårare för dig genom att du får starta med ett delvis löst spel. Du kan starta och stoppa demoläget med mellanslagstangenten och svara på en fråga om du vill stanna spelet. Speltiden sparas i poängtabellen för demoläget.

Fullskärm / Fönste:

You can toggle switch from windowed view to Full screen mode with the F11 key .(ESC or F11 to quit).


Spara spel, Ladda in spel

Spelplan:

Innan spelet påbörjas måste ett spel läggas upp. Shisen-sho gör det åt dig.

Om spelet som lagts ut inte passar dig kan du få ett nytt upplagt.

Spara och Ladda in spel:

Du kan även spara ett pågående spel som du senare kan öppna på nytt och spela vidare. När spelet sparas, sparas information om storlek, borttagna bitar och bitar som finns kvar men även vissa inställningar.

Du kan spela klart ett spel som har återställts eller ändra om det till början med samtliga bitar på plats.och även återställa Ångra/Gör om samt tidtagningen.


tangenter för Shisen-Sho

Tangenter

Tangenter för Shisen-sho:

Tillgängliga tangenter är:

  • Ctrl-A Alla tips (Fuska)

  • Ctrl-F Sjunk samman. (Av/På)

  • Ctrl-G Gravitation. (Av/På)

  • Ctrl-H Slumpvis tips och antal träffar

  • Ctrl-I Är spelet lösbart ?

  • Ctrl-N Nytt spel

  • Ctrl-P Paus/Fortsätt spela

  • Ctrl-R Gör om det som ångrades

  • Ctrl-S Stara om från början (samma som att upprepa Ctrl-X)

  • Ctrl-C Starta om från början (samma som att upprepa Ctrl-X) och rensa historiska data och tidtagningen.

  • Ctrl-T Håll ihop. (Av/På)

  • Ctrl-X Ångra

  • Alt-F4 Avsluita och stäng spelet

  • Alt-F11 Bästa poäng

  • Alt-F12 Om

  • F1 Hjälp(Kan användas för samtliga menyalternativ)

  • F3 Avsluta och stäng spelet

  • F10 väljer menyn

  • F11 Fullskärm / Fönster

  • Mellanslag stoppar programmet när det söker lösningen på ett spel eller avbryter demoläge.

  • Pause/Break Paus/Fortsätt spela

Handikappade

Handikappade kan spela Shisen-sho med ett finger

Tillgängliga tangenter är:

Numeriska tangentbordet (in numeriskt läge) (8 riktningar)

  • Teckendelen av tangentbordet med 'e', 'r','t','d','g','c','v','b' ' för de 8 riktningarna

  • Markera bitarna genom att trycka på tangent '5' på den numeriska delen eller 'f' och därefter på Enter.

  • Tips med 'Ctrl-h'

  • 'n'- och Delete-tangenterna motsvarar högerklick på musen för att visa bitar av samma typ.

  • Alla tips visas med 'Ctrl-a'

  • Använd 'Alt' och därefter piltangenterna för att visa menyerna.

  • Välj ett menyalternativ och tryck därefter Enter på tangentbordet.

Shisen-sho funktioner, mus:

Vänster-klick: Välj eller avmarkera bit som skall paras ihop.

Avmarkera bit som valts tidigare.

Höger-klick: Visa alla bitar av samma typ.

Knapprad:

Knapparna motsvarar några av menyalternativen som används mest.


Andra inställningar

Andra inställningsmöjligheter är:

Några alternativ finns där bara som underhållning:

  1. Hastighet, anger hastigheten på animationen och är bara visuell. Varje par bitar kan väljas oberoende av varandra.

  2. Animerade länkar.

  3. Visa högsta poäng. Du kan ta bort poäng.

Det finns en poängberäkning på spelplan för varje storlek. Poängtabellen visar spelmodell som användes (Normal, Gravitation; Sjunk samman eller Håll ihop).


Hantera bitar

Var sparas bitarna ?

Det finns ett eller två sätt (beroende på version) bitarna sparas med programmet för att kunna användas vilket sparar diskutrymme

De flesta andra bitarna sparas i en DLL i installationsmappen för programmet.

Versionen för Irina Allegrova fan club innehåller endast en fast font och inga DLL-fonter.

Fr.o.m. version 1.14 kan du rita och göra dina egna bitar.

Du kan få inspiration från några av bitarna som medföljer SHISEN-SHO.

Hur utformar man egan bitar ?

Bilder 8 bit (256 färger) av typen bitmap.

Bitarna placeras i sex rader om nio bitar.

Varje bit visas med EN extra pixel till vänster och nertill.

Bilderna som medföljer spelet kan användas som mall. Storleken på bilden får inte vara för stor. Bilden WALTE256.BMP som medföljer är för stor för de flesta datorer för att visas bra. Jag rekomenderar att du använder filen TEMPLATE.BMP som utgångspunkt när du skapar dina egna bitar.

Hur lägger man till bitarna ?

Placera bilden i installationsmappen för SHISEN-SHO.

Välj därefter menyalternativet “Hantera bitar” i spelet.

Välj därefter din bild.

Ändra därefter namnet som skall visas på menyerna och skriv in ditt namn som den som gjort bilden.

Justera färgen för högersidan av bitarna.

Du kan ändra detta alternativ senare om det visar sig att det bhövs.

Tryck OK för att spara informationen till SHISENTS.LST

Hur tar man bort oönskade bitar från listan ?

Välj alternativet “Hantera bitar” under menyn Filer.

Använd kanpparna nästa / föregående för att välja bild och tryck “ta bort” för att ta bort den.

Detta tar dock inte bort bilden från hårddisken.

Hur förändrar man färgen på bitarna ?

Välj alternativet “Hantera bitar” under menyn Filer.

Använd kanpparna nästa / föregående för att välja bild och ändra Röd, Grön och Blå och tryck därefter OK för att spara.


Sjöhästen

Hippocampus eller Sjöhäst:

Sjöhästen är symbolen och namnet på familjen av program från mig. Detta är inte ett företagsnamn eller ett registrerat.

Figur 3 En riktigt glad hippocampus jag hittade i havet när jag var tolv. (storlek 5 cm)


Kända problem

Spelplanen visas inte riktigt:

PÅ äldre och långsamare datorer med äldre grafikkort kan hela eller delar av spelplanen se skadad ut. Ändra fönstrets storlek för att rätta till problemet

Åtgärdadse problem:

Programversion:

1.02 Fixade ett problem där menyn inte visades under Windows 95

1.03 Nya fönster och en version för OS/2.

1.04 Sjunk samman och en ny knapprad.

1.05 Håll ihop, hjälp för handikappade, 3D, bakgrundsbilder, två typer av bitar.

1.06 Samma innehåll. Omarbetade kod för versionen för OS/2 för att undvika problem med GRADD. Underhåll av kod.

1.07 Samma innehåll. Omarbetade kod för versionen för OS/2 för att undvika problem med GRADD. Underhåll av kod.

1.08 Lade till 7 olika typer av bitar i en DLL-fil. Filen måste finnas i samma mapp som programmet.

1.09 Lade till möjlighet att ändra bakgrundsbild

1.10 Stängde av flera av fuskmöjligheterna. Lade till omstart med möjlighet att rensa.

1.11 Fixade en 3D bug från 1.10. Bilder på knappar av Klaus Staedtler-Przyborski.

1.12-Fixade problem med SDD drivrutiner

1.13-Placerade profilen i programmappen för OS/2 (OS/2 version)

1.14-Lade till möjlighet att rita egna bitar.

1.15 Justerade knapprad och storlek (Windows XP)

1.15 Skapade en version Irina Allegrovas fan club

1.16-Underhållsversion.

1.17 Add National Language Support

1.20 Add Full screen view – Program Re-Write in UNICODE

1.30 Full re-Write in C# using Windows Presentation Fundation (.Net version 3) inside a Windows Form application.


Språk

Ändra språk:

Shisen-Sho kan användas på de språk den har översatts till.

Språket kan användas så snart en översättning i form av en DLL finns tillgänglig i intallationsmappen.

Om flera DLLer med olika språk finns tillgänglig visar menyalternativet “Språk” som man kan välja mellan.

Du kan växla mellan språk unde rspelets gång.

Programmet startar med det språk som användes när spelet avslutades senast.

  • German av Christian Hennecke
  • French av Daniel F Valot
  • Hungarian av Leonard Nimoy
  • Italian av Marco D›Amato
  • Norwegian av Vegard Krog Petersen
  • Russian av Iren Matsenko
  • Swedish av Jan-Erik Lärka
  • Uzbek av Sherzod Mamatkulov


Licensinformation

Licens

<<Daniel F Valot Software>> Programfamiljen ARDI

License and Legal Information

  • Shisen-sho is refered to as the Shisen software hereafter.

  • This Shisen Software is owned by Daniel Valot

  • You are granted a nonexclusive license to use this Shisen Software solely for your own business purposes. The user shall not commercially distribute, sublicense, resell, or otherwise transfer for any consideration, or reproduce for any such purposes, the Shisen software or any modification or derivation thereof, either alone or in conjunction with any other product or program. Further, the user shall not modify the Shisen Software, other than for his own business use.

THE Shisen SOFTWARE IS PROVIDED TO THE USER "AS IS". THE AUTHOR MAKES NO WARRANTIES, EITHER EXPRESSED OR IMPLIED, WITH RESPECT TO THE Shisen SOFTWARE AND/OR ASSOCIATED MATERIALS PROVIDED TO THE USER, INCLUDING BUT NOT LIMITED TO ANY WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND AGAINST INFRINGEMENT.

==LIMITATION OF LIABILITY --THE AUTHOR SHALL NOT BE LIABLE FOR ANY CLAIMS OR DAMAGES WHATSOEVER, INCLUDING PROPERTY DAMAGE, PERSONAL INJURY, INTELLECTUAL PROPERTY INFRINGEMENT, LOSS OF PROFITS, OR INTERRUPTION OF BUSINESS, OR FOR ANY SPECIAL, CONSEQUENTIAL OR INCIDENTAL DAMAGES, HOWEVER CAUSED, WHETHER ARISING OUT OF BREACH OF WARRANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT LIABILITY, OR OTHERWISE.

På Svenska:

Du garanteras en icke exclusiv licens för att använda programvaran SHISEN. för din egen personliga användning. Användaren får inte Användaren får inte distrubiera programvaran för komerciellt ändamål, licensiera vidare, försälja eller på annat sätt överföra för utprovning eller reproducera för sådana ändamål, programvaran SHISEN eller modifierad eller variant därav, antingen ensam eller tillsammans med någon annan produkt eller program. Vidare, användaren får inte modifiera programvaran SHISEN, annat för eget bruk.

PROGRAMVARAN SHISEN TILLHANDAHÅLLS TILL ANVÄNDAREN "SOM DEN ÄR." UTVECKLAREN GER INGEN GARANTI AV NÅGOT SLAG, VARKEN UTTRYCKT ELLER ANTYTT, INKLUSIVE, MEN INTE BEGRÄNSAT TILL PROGRAMVARAN SHISEN OCH/ELLER TILLHÖRANDE MATERIAL SOM TILLHANDAHÅLLS ANVÄNDAREN, NÅGRA ANTYDDA GARANTIER FÖR SÄLJBARHET, LÄMPLIGHET FÖR ETT SPECIFIKT ÄNDAMÅL ELLER ÖVERTRÄDELSER.

BEGRÄNSNINGAR ANSVARSFRIHET --UTVECKLAREN SKALL INTE HÅLLAS ANSVARIG FÖR NÅGRA SOM HELST ANSPRÅK ELLER SKADOR ÖVER HUVUD TAGET, INNEFATTANDE MATERIELLA SKADOR, PERSONSKADOR, ÖVERTRÄDELSE AV INTELLEKTUELL EGENDOM, FÖRLUST AV KAPITAL, ELLER AVBROTT I ARBETE, ELLER FÖR NÅGON SOM HELST SPECIELL, TILL FÖLJD AV ELLER TILLFÄLLIGA SKADOR, HUR ÄN FÖRORSAKAD, VARE SIG UPPKOMMEN I BRIST PÅ GRANTIER, KONTRAKT, FÖRSEELSE (INNEFATTANDE FÖRSUMLIGHET), STRIKT ANSVAR, ELLER PÅ ANNAT SÄTT.

==Programmet Shisen är vaken betalvara (shareware) eller gratisvara (freeware). Du kan endast få det från mig (Daniel F Valot) eller från min hemsida. Du behöver inte betala någonting för version 1.30

Shisen (c) Kopieringsrättigheter Daniel F Valot 2000-2006