.::Willkommen

Willkommen in der A-Coder 2 ChecksumCreator Hilfe

hier finden sie eine umfangreiche Hilfe zu dem Programm.

Falls dennoch Fragen auftauchen, schicken sie mir eine E-Mail
Das selbe gilt für Kritik und Anregungen zu dem Programm.

Copyright 2002-2004 Nettraxx.de.vu Software


Über Checksumcreator

.::Über A-Coder2 Checksum Creator

ChecksumCreator ist ein Teil aus dem Projekt A-Coder2, welches inzwischen fertiggestellt wurde.
Mit diesem Programm hat man die Möglichkeit einen Text oder eine Datei mit einer eindeutigen Checksumme zu versehen oder mit einer bereits vorhandenen Checksumme zu vergleichen.
Selbst wenn sie nur die Datei und die Checksumme haben, und sie nicht wissen um welchen Checksummentyp es sich handelt ist dies für den ChecksumCreator kein Problem, er findet den passenden Checksummen-Typ automatisch.
Ebenso müssen sie sich keine Gedanken über die Formatierung der Checksumme machen, das passende Format wird ebenfalls automatisch ausgewählt.

Es wir außerdem die Möglichkeit geboten die generierte Checksumme mit allen relevanten Daten in eine Datei zu speichern und diese wieder zu laden.

Folgende Prüfsummen lassen sich mit diesem Tool überprüfen oder erstellen:

Message Digest 5 (MD 5)
Message Digest 4 (MD 4)
Secure Hash Algorithm (SHA)
Snefru (256bit)
Square
Tiger

Ripe Message Digest (128bit-320bit)
Haval (128bit - 256bit)
Sapphire II (128bit - 320bit)
XOR-16
XOR-32
CRC-16 ( CCITT und Standard )
CRC-32


.::History

History:
1.0.0.0 -07.11.2003
Grundversion von ChecksumCreator -Auskopplung aus dem A-Coder2 Projekt
1.0.0.1 -08.11.2003
Die Möglichkeit des speichern und landen der Checksummen Daten in eine Datei hinzugefügt
1.0.0.2 -08.11.2003
Hinzufügung von zusätzlichen Fehlermeldungen und Sicherheitsschleifen
Programmablauf bereinigt und beschleunigt
1.0.0.3 -10.11.2003
Hyperlink und Statusbartext hinzugefügt
Programmfenster mit leichter Tranzparenz versehen (Windows 2000 + WindowsXP)
1.0.0.4 -11.11.2003
Kontexthilfe eingefügt
Längere Verzögerung bis die Kontexthilfe erscheint (10 Sekunden)
1.0.0.5 -29.12.2003
Rechtschreibfehler in Messagedialogen behoben
Benutzer kann nun in die Combobox Daten eingeben, und nicht nur auswählen
Shell-Parameterübergabe implementiert
mehrere Dateiextentions möglich (chksum,ini,txt)
1.0.0.6 -20.02.2004
Der Fehler, das nur Ordner ohne Leerzeichen geöffnet werden können, ist behoben.
1.0.1.0 -17.04.2004
Verändertes Design
Es ich nun nicht mehr möglich einen falsche Checksumme zu speichern
Quelltextoptimierungen: 30% weniger Quelltext
Intelligentere Fehlerbehandlung
Es ist nun möglich beim Laden einer falschen Checksummen-Datei (Text/Datei) zu der korrekten Anzeige zu wechseln
1.1.0.0 -30.09.2004
Umfangreiche Parameterübergabe eingefügt
Mehr und intelligentere Sicherheitsroutinen
1.1.1.0 -20.03.2005
Checksummen-Datei den Wert "Valve" in "Value" korrigiert. Alte Checksummen-Dateien können dennoch eingelesen werden.
Englische Sprachversion hinzugefügt
Relative Dateipfade werden unterstützt
Neuer Parameter -silent
1.1.2.0 -29.05.2005
ErrorLog eingeführt
Benutzerausgaben umstrukturiert.
Weitere Quelltextoptimierung (Gesamtquelltext nun um 13% kleiner)


Systemvorrausetzungen

.::Systemvorraussetzungen

Systemvorraussetzungen:

A-Coder2 wurde so konzipiert, auch bei langsamen PCs noch effektiv arbeiten zu können. Dennoch ist das berechenen einer Checksumme eine umfangreiche mathematische Funktion. Dem entsprechend ist die Berechnungsgeschwindigkeit von der Prozessorgeschwindigkeit abhängig. In der Regel sollte die Berechnung jedoch nicht länger als ein paar Sekunden dauern.

Minimum:

  • 400Mhz
  • 64MB RAM
  • 16 Bit Grafikkarte
  • Strom aus der Steckdose (ganz wichtig)
  • Windows 98/ NT oder höher


.::Lizenz

WICHTIG - SORGFÄLTIG LESEN:

(!) Dieses Software-Produkt wird als Freeware verbreitet. Es kann frei benutzt, kopiert und verbreitet werden, solange es nicht verkauf wird und alle original Dateien enthalten sind - inklusive diese Lizenzvereinbarung.

(!) Die Verbreitung dieses Software-Produktes auf kostenpflichtigen CD's oder über kostenpflichtige Dienste ist nur nach Rücksprache mit dem Autor möglich.

(!) Der Autor übernimmt keinerlei Haftung für das Software-Produkt. Das Programm wird so zur Verfügung gestellt, "wie es ist", ohne irgendeine Haftung, weder ausdrücklich noch implizit, einschließlich - aber nicht begrenzt auf - Marktreife oder Verwendbarkeit für einen bestimmten Zweck. Das volle Risiko bezüglich Qualität und Leistungsfähigkeit des Software-Produktes liegt bei Ihnen.

(!) Sollten Sie irgendwelche Fragen bezüglich dieses Software-Produktes haben, so setzen Sie sich bitte mit mir über meine Homepage in Verbindung

(!) Die aktuelle Version des Software-Produktes bekommen Sie auf www.nettraxx.de.vu


.::Kontakt

Homepage: | www.nettraxx.de.vu
Mail: | nettraxx@oleco.net

Falls sie Fragen, Kritik oder Anregungen zu dem Programm haben, senden sie mir eine E-Mail. Ich freue mich über jede Resonanz zu dem Programm
Vergessen sie nicht den Namen des Programm's sowie die Version zu erwähnen.


.::Das A-Coder2 Projekt

A-Coder 2 ist mein Mamutprojekt, zu welchem ich letzter Zeit leider viel zu selten komme.

A-Coder2 ist eine Freeware-Verschlüsselung Suite welche eine maximale Sicherheit für die verschlüsselten Texte und Dateien ermöglichen soll.
Anders als andere Programme, welche sich auf ein Verschlüsselungstyp bauen, verschlüsselt A-Coder die Daten gleich mit 3 vollkommen verschiedenen Verschlüsselungstypen und das mit bis zu 30% Geschwindigkeitssteigerung gegenüber der üblichen Verschlüsselungsweise.
näheres zu dem Programm und den aktuellen Fortschritt der Arbeiten finden sie auf meiner Homepage


erstellen

.::Dateichecksumme erstellen

Um eine Dateichecksumme zu erstellen gehen sie wie folgt vor:

  1. Wählen sie unter "Checksummen-Verfahren" die Checksumme aus, mit der sie beabsichtigen die Datei zu berechnen.
    Tip:

    Wenn sie die Checksumme zu öffentlichen Zwecken verwenden wollen, sollten sie bekannte Checksummen-Verfahren wie

    Message Digest 5(MD5)
    Secure Hash Algorithm(SHA)
    oder CRC32 verwenden

  2. Klicken sie auf die rechte Schaltfläche unter "Datei" um den Öffnen-Dialog zu öffnen und wählen sie die Datei aus.

  3. Nun noch auf "Erstellen" klicken und die Checksumme wird erstellt.
    Die erstellte Checksumme wird in dem Feld "Checksumme" dargestellt.

  4. Ich empfehle die erstellte Checksumme von den Programm speichern zu lasssen.
    Wie das geht, steht im Beitrag "speichern"


speichern

.::Dateichecksumme speichern

Wenn sie ein Checksumme erstellt haben und sie speichern wollen, müssen sie nicht in irgendein Dokument kopieren.
Der ChecksumCreator bietet die Möglichkeit die Checksumme mit allen relevanten Daten zu speichern.

So gehen sie vor:

  1. Klicken sie auf die Schaltfläche "Speichern"

  2. Nun öffnet sich der Speichern-Dialog, in dem sie in das Eingabefeld den Namen der Datei eingeben.
    Hinweis

    Unter "Dateityp" können sie zwischen folgenden Dateiformaten wählen:
    - Checksummen-Datei
    - INI-Datei
    - TXT-Datei
    Der Unterschied zwischen den Formaten?- es gibt keinen, alle enthalten die selben Daten.
    Während sie die Checksumme als TXT-Datei oder INI-Datei speichern wollen, haben sie den Vorteil das sie auf alle Daten leicht zugreifen können.
    Wenn sie jedoch die Checksumme als Checksummen-Datei, also als eigene Dateiklasse speichern, haben sie den Vorteil, dass das Verzeichnis übersichtlicher erscheint( vor allem wenn sie in diesem Verzeichnis mehrere Dateien abgelegt sind).

  3. Klicken sie in dem Dialog auf "Speichen" um den die Datei zu speichern


vergleichen

.::Dateichecksumme vergleichen

Eine Checksumme zu vergleichen ist genauso einfach wie eine zu erstellen.

Dieser Beitrag bezieht sich auf folgende Situation:
Sie haben die Checksumme sowie das passende Checksummen-Verfahren

  1. Wählen sie unter "Checksummen-Verfahren" das passende Verfahren aus.

  2. Klicken sie auf die rechte Schaltfläche unter "Datei" um den Öffnen-Dialog zu öffnen und wählen sie die Datei aus.

  3. Fügen sie in das Eingabefeld "Checksumme" die Checksumme ein

  4. Klicken sie auf die Schaltfläche "Vergleichen"

  5. Falls die Checksumme mit der Datei übereinstimmt erhalten sie die entsprechene Meldung.
    Falls die Checksumme nicht mit der Datei übereinstimmt, werden sie gefragt, ob sie alle verfügbaren Checksummen-Verfahren mit der Checksumme vergleichen wollen. Dies dient dazu sicherzustellen, das sie nicht ausversehen das falsche Checksummen-Verfahren ausgewählt haben oder man ihnen das falsche Checksummen-Verfahren mitgeteilt hat.


vergleichen mit Checksumme-Datei

.::Dateichecksumme mit Hilfe einer Checksummen-Datei vergleichen

Der einfachste Weg eine Checksumme zu vergleichen ist, einfach die entsprechende Checksummen-Datei zu laden.

Alles was sie in dieser Situation dazu benötigen ist die Checksummen-Datei

  1. Klicken sie auf die Schaltfläche "Laden", wählen sie Checksummen-Datei aus und schließen sie den Dialog mit "Laden"
    Nun werden alle Daten aus der Checksummen-Datei geladen und in das Programm eingefügt.

  2. Klicken sie auf die rechte Schaltfläche unter "Datei" um den Öffnen-Dialog zu öffnen und wählen sie die Datei aus.

  3. Klicken sie auf "Vergleichen" um die Datei mit der geladenen Checksumme zu vergleichen.


vergleichen mit unbekannten Verfahren

.::Dateichecksumme vergleichen, wenn ihnen das Checksummen-Verfahren unbekannt ist

Dieser Beitrag bezieht sich auf folgende Situation:
Sie haben die Checksumme jedoch sie wissen nicht um welches Checksummen-Verfahren es sich handelt

  1. Falls in dem Feld "Checksummen-Verfahren" ein Verfahren ausgewählt ist, löschen sie den Inhalt ersatzlos.

  2. Klicken sie auf die rechte Schaltfläche unter "Datei" um den Öffnen-Dialog zu öffnen und wählen sie die Datei aus.

  3. Fügen sie in das Eingabefeld "Checksumme" die Checksumme ein

  4. Klicken sie auf die Schaltfläche "Vergleichen"

  5. Bestätigen sie die darauf folgende Meldung mit "Ja"


erstellen

.::Textchecksummen erstellen

Um eine Textchecksumme zu erstellen gehen sie wie folgt vor:

  1. Wählen sie unter "Checksummen-Verfahren" die Checksumme aus, mit der sie beabsichtigen den Text zu berechnen.
    Tip:

    Wenn sie die Checksumme zu öffentlichen Zwecken verwenden wollen, sollten sie bekannte Checksummen-Verfahren wie

    Message Digest 5(MD5)
    Secure Hash Algorithm(SHA)
    oder CRC32 verwenden

  2. Fügen sie in das Eingabefeld "Text" den Text ein

  3. Nun noch auf "Erstellen" klicken und die Checksumme wird erstellt.
    Die erstellte Checksumme wird in dem Feld "Checksumme" dargestellt.

  4. Ich empfehle die erstellte Checksumme von den Programm speichern zu lasssen.
    Wie das geht, steht im Beitrag "speichern"


speichern

.::Textchecksumme speichern

Wenn sie ein Checksumme erstellt haben und sie speichern wollen, müssen sie nicht in irgendein Dokument kopieren.
Der ChecksumCreator bietet die Möglichkeit die Checksumme mit allen relevanten Daten zu speichern.

So gehen sie vor:

  1. Klicken sie auf die Schaltfläche "Speichern"

  2. Nun öffnet sich der Speichern-Dialog, in dem sie in das Eingabefeld den Namen der Datei eingeben.
    Hinweis

    Unter "Dateityp" können sie zwischen folgenden Dateiformaten wählen:
    - Checksummen-Datei
    - INI-Datei
    - TXT-Datei
    Der Unterschied zwischen den Formaten?- es gibt keinen, alle enthalten die selben Daten.
    Während sie die Checksumme als TXT-Datei oder INI-Datei speichern wollen, haben sie den Vorteil das sie auf alle Daten leicht zugreifen können.
    Wenn sie jedoch die Checksumme als Checksummen-Datei, also als eigene Dateiklasse speichern, haben sie den Vorteil, dass das Verzeichnis übersichtlicher erscheint( vor allem wenn sie in diesem Verzeichnis mehrere Dateien abgelegt sind).

  3. Klicken sie in dem Dialog auf "Speichen" um den den Text zu speichern


vergleichen

.::Textchecksumme vergleichen

Eine Checksumme zu vergleichen ist genauso einfach wie eine zu erstellen.

Dieser Beitrag bezieht sich auf folgende Situation:
Sie haben die Checksumme sowie das passende Checksummen-Verfahren

  1. Wählen sie unter "Checksummen-Verfahren" das passende Verfahren aus.

  2. Fügen sie in das Eingabefeld "Text" den Text ein

  3. Fügen sie in das Eingabefeld "Checksumme" die Checksumme ein

  4. Klicken sie auf die Schaltfläche "Vergleichen"

  5. Falls die Checksumme mit dem Text übereinstimmt erhalten sie die entsprechene Meldung.
    Falls die Checksumme nicht mit dem Textübereinstimmt, werden sie gefragt, ob sie alle verfügbaren Checksummen-Verfahren mit der Checksumme vergleichen wollen. Dies dient dazu sicherzustellen, das sie nicht ausversehen das falsche Checksummen-Verfahren ausgewählt haben oder man ihnen das falsche Checksummen-Verfahren mitgeteilt hat.


vergleichen mit Checksumme-Datei

.::Textchecksumme mit Hilfe einer Checksummen-Datei vergleichen

Der einfachste Weg eine Checksumme zu vergleichen ist, einfach die entsprechende Checksummen-Datei zu laden.

Alles was sie in dieser Situation dazu benötigen ist die Checksummen-Datei

  1. Klicken sie auf die Schaltfläche "Laden", wählen sie Checksummen-Datei aus und schließen sie den Dialog mit "Laden"
    Nun werden alle Daten aus der Checksummen-Datei geladen und in das Programm eingefügt.

  2. Fügen sie in das Eingabefeld "Text" den Text ein

  3. Klicken sie auf "Vergleichen" um den Text mit der geladenen Checksumme zu vergleichen.


vergleichen mit unbekannten Verfahren

.::Textchecksumme vergleichen, wenn das Checksummen-Verfahren unbekannt ist

Dieser Beitrag bezieht sich auf folgende Situation:
Sie haben die Checksumme jedoch sie wissen nicht um welches Checksummen-Verfahren es sich handelt

  1. Falls in dem Feld "Checksummen-Verfahren" ein Verfahren ausgewählt ist, löschen sie den Inhalt ersatzlos.

  2. Fügen sie in das Eingabefeld "Text" den Text ein

  3. Fügen sie in das Eingabefeld "Checksumme" die Checksumme ein

  4. Klicken sie auf die Schaltfläche "Vergleichen"

  5. Bestätigen sie die darauf folgende Meldung mit "Ja"


.::Die Parameterübergabe

Bei der Übergabe von Parametern an den ChecksumCreator sind folgende Dinge zu beachten:

  • Vor jedem Befehl muss ein Minus "-" stehen
  • Dem "-" muss unmittelbar der Befehl folgen (ohne Leerzeichen oder sonstige Zeichen)
  • Der Befehl muss mit einem Doppelpunkt ":" abgeschlossen werden.
  • Nach dem ":" muss unmittelbar der Wert folgen (ohne Leerzeichen oder sonstige Zeichen)
  • Die Werte selbst können Leerzeichen enthalten
  • Falls ein Befehl mehrfach vorhanden ist, wird immer der letzte Befehl verwendet
  • Die Groß-/Kleinschreibund der Befehle und Werte ist egal
  • Alle Befehle können in beliebiger Reihenfolge eingelesen werden. Diese werden intern neu geordnet


.::Die Parameter

Parameter: <Dateipfad>
Werte: -

Beschreibung:
Wird ein Dateipfad ohne einen Befehl übergeben, wird diese als die zu überprüfende Datei erkannt und in das Feld "Datei" übergeben.
Werden mehrere Dateien übergeben, wird nur die letzte übergebene Datei verwendet
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe C:\ein Pfad\zu_überprüfende_Datei.txt

Parameter: load
Werte: Pfad einer Checksummen-Datei

Beschreibung:
Mit diesem Parameter kann man einer gespeicherte Checksummendatei geladen werden.
Wenn zusätzlich zu dem Befehl "load" noch die Befehle "checksum" und "mode" übertragen werden, werden anstatt die Werte der Checksummendatei die Werte der jeweiligen Befehle verwendet.
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -load:C:\ein Pfad\ChecksummenDatei.chksum

Wird eine Checksummen-Datei und ein Dateipfad übergeben, wird die Checksumme automatisch überprüft.
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe C:\ein Pfad\zu_überprüfende_Datei.txt -load:C:\ein Pfad\ChecksummenDatei.chksum

Parameter: mode
Werte: Ein Checksummenverfahren

Beschreibung:
Hiermit kann man das gewünschte Checksummenverfahren ausgewählt werden. Während die Groß-/Kleinschreibung egal ist, ist es wichtig das der Text mit der in dem Drop-Down-Feld verfügbaren übereinstimmt. Ein Leerzeichen an falscher Stelle und das Verfahren kann nicht mehr erkannt werden.
Beispiel
<ChecksumCreatorPfad>/ChecksumCreator.exe -mode:Ripe Message Digest 128

Wird der Befehl zusammen mit einem Dateipfad übergeben, wird automatisch eine Checksumme erstellt.
Beispiel
<ChecksumCreatorPfad>/ChecksumCreator.exe -mode:Ripe Message Digest 128 C:\ein Pfad\zu_überprüfende_Datei.txt

Parameter: checksum
Werte: Eine Checksumme (Beliebige Zeichenfolge)

Beschreibung:
Mit diesem Parameter wird eine Checksumem direkt an den ChecksumCreator übergeben
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -checksum:123Osterei

Wird zusätzlich noch ein Dateipfad und der Befehl "mode" übergeben, so wird der Dateipfad automatisch mit der Checksumme verglichen.
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -checksum:123Osterei -mode:Tiger C:\ein Pfad\zu_überprüfende_Datei.txt

Parameter: save
Werte: Pfad einer Checksummen-Datei

Beschreibung:
Wurde eine Checksumme beim übergeben der Parameter automatisch generiert.(siehe "mode" )
kann das Ergebnis sofort als Checksummendatei gespeichert werden.
Hinweis: die Dateiendung nicht vergessen
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -mode:Ripe Message Digest 128 C:\ein Pfad\zu_überprüfende_Datei.txt -save:C:\ein Pfad\AndereChecksummenDatei.chksum

Parameter: exit
Werte: Beliebige Zeichenfolge

Beschreibung:
Mit diesem Parameter kann das Programm sofort wieder geschlossen werden.
Ein Wert ist nicht erforderlich es reicht nur der Parameter.
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -exit:
<ChecksumCreatorPfad>/ChecksumCreator.exe -exit:<:irgendwas>

Parameter: silent
Werte: Beliebige Zeichenfolge

Beschreibung:
Beim Starten des Programms mit diesem Parameter, wir das Fenster unsichtbar gemacht und kann nur noch durch die Startparameter gesteuert werden.
Alle Fehlermeldungen werden unterbunden und die Fehlerausgabe erfolgt nurnoch über das Fehlerprotokoll (Errorlog).
Beispiel:
<ChecksumCreatorPfad>/ChecksumCreator.exe -silent:
<ChecksumCreatorPfad>/ChecksumCreator.exe -silent:<:irgendwas>


About HTMLHelp ePublisher

This eDocument Was Created Using:
HTMLHelp ePublisher
Electronic-Documentation Creation Made Easy

Free to Download From:
http://www.htmlhelp-epublisher.co.uk

Also Available Web2HTMLHelp (Freeware)