
About Apply Changes
Use Apply Changes to execute all pending operations on your computer.
As you complete operations, the disk map and partition list reflect the changes you have made. However, no 
changes physically take place on your computer until you apply them.
{button ,JI(`',`H_To_apply_changes_to_your_computer')} To apply changes to your computer 



To apply changes to your computer
1 Click General > Apply Changes.

Tips
· You can view the list of pending changes before you apply them by clicking View > Operations Pending.



About Discard All Changes
Use Discard Changes to cancel all pending operations on your computer.
{button ,JI(`',`H_To_discard_changes_to_your_computer')} To discard all changes to your computer 



To discard all changes to your computer
>    Click General > Discard All Changes.

Tips
· You can view the list of pending changes by clicking View > Operations Pending.
· You can also press <Ctrl+D>.
· To discard only the last change made, click General > Undo Last Change, or press <Ctrl+Z>.



About Preferences
Use Preferences to find out if your current OS (operating system) supports FAT32. Windows 95 OEM Service 
Release 2, Windows 98/Me/2000/XP support FAT32 partitions; other operating systems do not.
You can also use Preferences to change your default settings in PartitionMagic. For example, you can specify 
which disks on your system that you do not want to check for bad sectors or that you want set as read only.
{button ,JI(`',`H_To_change_PartitionMagic_preferences')} To change PartitionMagic preferences 



To change PartitionMagic preferences
1 Click General > Preferences.
2 Select Allow 64K FAT Clusters for Windows NT/2000/XP if you want to create FAT partitions with 64K 

clusters. This lets you use PartitionMagic to create FAT partitions up to 4GB.
Because DOS and Windows 3.x, Windows 95, Windows 98, and Windows Me do not support cluster sizes larger 
than 32K, you cannot access a 64K partition using these operating systems.

3 In the Skip bad sector checks group box, select the disks that you do not want PartitionMagic to check for 
bad sectors.
If you disable bad sector checking and your hard disk has bad sectors, data loss can result. This option is 
selected by default.

4 In the Set as Read-Only for PartitionMagic group box, select the disks that you do not want PartitionMagic 
to change.

Tips
· When you select (enable) the option in step 2, the 64K cluster size is available in the Resize/Move Partition and

Resize Clusters dialog boxes.
· If you are using multiple operating systems, we recommend that you do not use 64K clusters.
· When PartitionMagic modifies partitions, it performs extensive testing to detect bad sectors on your hard disk. 

Newer disk types (such as Enhanced IDE and SCSI) often handle bad sectors internally, making such testing 
superfluous. For this reason, PartitionMagic lets you bypass these tests with Skip bad sector checks. When 
this option is enabled, the Resize/Move, Create, Copy, and Format operations run faster.

· In step 4, if your computer has an older disk and a newer one, you could check the older disk and skip the 
newer one.

· In step 5, there are several exceptions in which PartitionMagic will make changes even if you have selected 
disks in this option. For example, if the disk contains the boot partition, some files may be changed, such as 
the Windows NT boot initialization file. Or, if you tell PartitionMagic to run DriveMapper automatically, certain 
files (such as initialization and shortcut files), may be changed.



About Exit
Use Exit to quit PartitionMagic. If you have any pending operations when you exit PartitionMagic, you can either 
apply them to your system before exiting or you can discard the changes.
{button ,JI(`',`H_To_exit_PartitionMagic')} To exit ParititionMagic 



To exit PartitionMagic
1 Click General > Exit.

Tips
· When you exit PartitionMagic, you may be prompted to apply or discard any pending changes to your system.



Hard Disk Integrity Checks
PartitionMagic checks disk integrity with a sophisticated system of analysis and validation that operates behind 
the scenes every time you start the program or complete an operation. An initial integrity check scans your disk 
and reports any partition problems that may prevent PartitionMagic from operating properly. This integrity check 
acts as an early warning system that informs you of your disk's status and assures that the disk's structure is 
thoroughly analyzed and verified before you alter it.
If your physical disk passes the initial integrity check, you can select the disk's partitions and use 
PartitionMagic's features; otherwise, an error message appears instead of the partition list. This indicates a 
problem with your disk, not with PartitionMagic (because no disk modification operations have been started). 
Correct the disk problem, and then restart PartitionMagic. For more information, click See Also on the Help 
toolbar.
In addition to the integrity check at startup time, PartitionMagic performs two integrity checks during any 
operation. The first check tests the integrity of the file system in the partition before an operation begins (similar
to CHKDSK or MS ScanDisk), and the second check validates your disk's data after an operation is completed. 
From start to finish, PartitionMagic analyzes your disk and informs you immediately if it detects any irregularities.



About Resize/Move
Use Resize/Move to change the size of a partition and move it to another location on a hard disk.

Resizing a Partition
When you resize a partition, data is consolidated, not compressed. To make a partition smaller, unused space 
must exist within the partition. To enlarge a partition, there must be adjacent unallocated space on the disk. If 
there is unallocated space on the disk, but it is not adjacent to the partition you want to enlarge, adjust the 
location of the unallocated space by moving other partitions.
You should exercise caution when resizing partitions smaller, especially a partition containing an operating 
system. Leave at least 50 MB more space in the partition than the operating system requires. Swap files, 
drivers, and other files may require the extra space. Additionally, operating systems can become unbootable if
moved beyond certain boundaries. For more information, click See Also on the Help toolbar.
Resizing FAT and FAT32 partitions smaller may reduce the amount of wasted space on a hard disk. When you 
resize a FAT or FAT32 partition, PartitionMagic automatically resizes the clusters to their optimal size for the 
partition. For more information, click See Also on the Help toolbar.
Important: Occasionally, resizing a FAT partition displaces the first few files on the partition (such as IO.SYS 
and MSDOS.SYS if the partition contains an operating system). If you resize a boot partition and then it fails to 
boot, run SYS.COM to move the displaced files back to the front of the disk.

Moving a Partition
When you move a partition, the partition's data (and data on other partitions) is unaffected. The unallocated 
space adjacent to a partition determines the distance you can move it; if there is no unallocated space, you 
cannot move the partition. Additionally, you cannot move unknown partitions, partitions failing the Check 
operation, or unallocated space.
You should exercise caution when moving a bootable partition. Operating systems can become unbootable if 
moved beyond certain boundaries. For more information, click See Also on the Help toolbar.

Limitations of Resize/Move
· You cannot make a partition smaller unless it contains unused space. You can only reduce a partition to the 

used size shown in the disk map plus a small buffer area. During a Resize/Move operation, data is consolidated
to the front of the partition as needed, but no data compression takes place. Because of the way a FAT 
partition is structured, you can often resize a partition a second time and make it even smaller or larger than 
the first time you resized it.

· In certain instances, you cannot make a FAT partition larger when the partition contains no unused space. If 
you have a full partition and plenty of free space adjacent to it, yet are not able to enlarge your partition, you 
may have to delete some files in the partition so that PartitionMagic has room to work. You may be able to 
slightly enlarge the partition (1 MB or less) and then enlarge the partition a second time to provide the 
necessary buffer area for PartitionMagic. To see how much space is needed in a partition to resize past a 
cluster boundary, see the table in Freeing Disk Space Before Enlarging a FAT Partition.

· It is difficult to calculate in advance the minimum size to which an NTFS partition may be resized. During an 
NTFS Resize/Move operation, if PartitionMagic runs out of space, it returns an error without completing the 
operation. The integrity of the NTFS partition and data is never compromised.

· A FAT partition has a 2 GB size limit; however, a FAT partition under Windows NT (service pack 6 or higher) or 
Windows 2000/XP can be sized up to 4 GB and have a 64 KB cluster size.

{button ,JI(`',`H_To_resize_a_partition')} To resize a partition 
{button ,JI(`',`H_To_move_a_partition')} To move a partition 
{button ,JI(`',`H_Resize_Scenario_To_add_free_space_to_a_logical_partition')} Resize Scenario: To add free space 
to a logical partition 
{button ,JI(`',`H_Resize_Move_Scenario_To_add_free_space_to_a_primary_partition')} Resize/Move Scenario: To 
add free space to a primary partition 



To resize a partition
1 Select a disk and a partition.
2 Click Partition > Resize / Move.

The current size of the partition is shown on a disk map at the top of the dialog box. The map also depicts the 
used and unused space within the partition and the free space surrounding the partition (if any exists). The 
minimum and maximum sizes that you can resize a partition appears below the map.

3 Position the mouse pointer on the left or right partition handle.
The mouse pointer changes to a double-headed arrow .

4 Drag the handle to the partition size you want.
5 Click OK.

Tips
· In step 4, you can also resize the partition by specifying new values in the Free Space Before, New Size, and 

Free Space After text boxes. The values you type may change slightly to values supported by your drive's 
geometry.

· To make a partition smaller, unused space must exist within the partition. To enlarge a partition, there must be 
free space adjacent to it.

· If desired, click the Cluster Size drop-down list and select a new size or use the recommend cluster size that 
is already selected. PartitionMagic changes the values in the Free Space Before, New Size, and Free Space 
After text boxes to show how the partition size is affected. This option is only available for FAT and FAT32 
partitions. NTFS cluster resize is available in Partition > Advanced > Resize Clusters.



To move a partition
1 Select a disk and a partition.
2 Click Partition > Resize / Move. 

The current size of the partition is shown on a disk map at the top of the dialog box. The map also depicts the 
used and unused space within the partition and the free space surrounding the partition (if any exists). The 
minimum and maximum sizes for the partition appears below the map.

3 Position the mouse pointer on the partition.
The mouse pointer changes to a four-headed arrow .

4 Drag the partition to the location you want.
5 Click OK.

Tips
· In step 4, you can also move the partition by specifying new values in the Free Space Before, and Free Space 

After text boxes. The values you type may change slightly to values supported by your drive's geometry.
Also, there must be free space adjacent to the partition in order to move it. If there is none, and the partition 
contains unused space, make the partition smaller and then move the partition.

· If you know your disk has no bad sectors, you can select Skip bad sector checks in the PartitionMagic 
Preferences dialog box to make moving a partition faster.

· If you want, click the Cluster Size drop-down list and select a new size or use the recommend cluster size that 
is already selected. PartitionMagic changes the values in the Free Space Before, New Size, and Free Space 
After text boxes to show how the partition size is affected. This option is only available for FAT and FAT32 
partitions.



Resize Scenario: To add free space to a logical partition
You have one 3 GB hard disk that contains the following:
· One active primary FAT32 partition (C:) running Windows 98
· One extended partition enclosing one logical FAT partition (D:)

 

In this scenario, you will resize drive C: smaller and add the newly created unallocated space to drive D: as show 
in the following example.

 

Steps
1 Resize drive C: smaller by the amount you want to add to drive D:.

Resize C: so that the free space is on the right.
2 Resize drive D: to occupy the free space that was just created.

The extended partition is automatically enlarged to accommodate drive D:.
3 Apply the changes to your system.

Result
Drive D: has room for additional files.



Resize/Move Scenario: To add free space to a primary partition
You have one 3 GB hard disk that contains the following:
· One active primary FAT32 partition (C:) running Windows 98
· One hidden primary NTFS partition
· One extended partition enclosing one logical FAT partition (D:) and a block of unallocated space

 

In this scenario, you want to add the block of free space to the NTFS partition as shown in the following example.

 

Steps
1 Move drive D: to the right (so the free space is on the left).
2 Resize the NTFS partition to occupy the free space.

The extended partition is automatically resized down to accommodate the new NTFS partition size.
3 Apply the changes to your system.

Result
The NTFS partition has room for growth and adequate space for operating system files such as drivers and swap 
files.



About Create
Use Create operation to create primary partitions, extended partitions, and logical partitions. On a single hard 
disk, you can have up to four primary partitions, or three primary partitions and one extended partition. Within 
an extended partition, you can create unlimited additional subdivisions called logical partitions.

Before You Create a Partition
Generally, you should create primary partitions to install operating systems and logical partitions for all other 
purposes, such as storing data and applications. If you have multiple hard disks, you can improve speed by 
installing operating systems and applications on separate disks. If you do not know what type of partition you 
want to create, it may help you to read the topic Understanding Partitions. However, you can install Windows NT,
2000, and XP to logical partitions as long as their boot files are in a primary partition.
In Windows 95, 98 and Me, creating a new partition can make your drive letters change, causing applications not
to run because application shortcuts, initialization files, and registry entries refer to incorrect drives. 
DriveMapper, a utility included with PartitionMagic, helps you easily update drive letter references. Under certain
conditions, DriveMapper runs automatically after you create a partition.
While you can use DriveMapper to update references to files, for the least impact on your system, consider 
creating all new partitions on the highest disk (for example, disk 3 in a three-disk system) and to the right of 
existing partitions.

Creating Bootable Partitions
Before creating a partition where you plan to install an operating system (a bootable partition), you should 
understand the information outlined in the following table.

Operating 
System

Boots 
from 
Primary or
Logical

Supported 
Partition 
Types

Boot 
Code 
Boundary

Space 
Required

DOS 6.22 (and
earlier)

Primary FAT 2 GB 8 MB

Windows 95a Primary FAT 2 GB 90 MB
Windows 95b Primary FAT or FAT32 8 GB 90 MB
Windows 98 Primary FAT or FAT32 8 GB 175 MB
Windows 98 
SE

Primary FAT or FAT32 8 GB** 190 MB

Windows Me Primary FAT or FAT32 8 GB** 300 MB
Windows NT Primary* FAT or NTFS 

version 1.2
2 GB 120 MB

Windows 2000 Primary* FAT, FAT32, or 
NTFS version 
3.0

8 GB** 650 GB

Windows XP Primary* FAT, FAT32, or 
NTFS version 
3.1

8 GB** >1 GB

Linux (LILO)† Either Linux Ext2, 
Ext3‡, and 
Linux Swap

8 GB >250 MB

*    Windows NT/2000/XP must boot from a primary partition on the first drive. However, only a few Windows 
NT/2000/XP files must reside on that partition; the remaining files can reside on a logical partition, which can 
be located on the first or a subsequent drive. The Windows NT/2000/XP boot partition can be shared with 
another operating system. When a second OS shares a boot partition with the first OS, it is called 
bootstrapping.

** Having an LBA-compatible (Logical Block Addressing) MBR (Master Boot Record) will make the boot code 



boundary null with Windows Me/2000/XP.
†    If you install LILO to a logical partition, it must be the first logical partition in the extended partition.
‡    Linux also supports the partition types FAT, FAT32, and NTFS (read-only) if Linux is installed to a Linux Ext2 

partition.
Important: When you create, move, or resize a bootable partition, the partition must begin below the boot 
code boundary specified in the above table in order for the operating system to boot. With the exception of 
DOS 6.22 (or earlier) and OS/2, partitions beyond 8 GB are visible to the current operating system. For more 
information, see Understanding the BIOS 1,024 Cylinder Limit and Understanding the 2 GB Boot Code 
Boundary. The disk map in the PartitionMagic main window displays indicators for the 2 GB boot boundary and
the 1024 cylinder (8 GB) limit.

PartitionMagic displays a warning if you attempt to create, move, or resize a bootable partition outside of the 2 
GB boot code boundary. If you continue with the operation, you may not be able to boot or see the partition. In 
either case, you can resolve the problem by moving the partition back within the boot code boundary with the 
PartitionMagic rescue disks.
If your system includes SCSI disks and you create a partition before a bootable Linux partition, Linux may no 
longer be bootable. In this situation, you may need to create Linux rescue disks, boot from the rescue disks, and 
repair the Linux boot information on the Linux partition.
Some I/O cards (typically older RAID cards) only provide access to the first 8 GB of a disk under DOS. 
Consequently, if you resize the operating system partition beyond 8 GB and it becomes unbootable, the 
PartitionMagic rescue disks may not allow you to manipulate partitions on that drive. You should be cautious 
about resizing any older operating system partition beyond 8 GB (Windows 95, 98 (pre-SE), NT).
{button ,JI(`',`H_To_create_a_partition')} To create a partition 
{button ,JI(`',`H_Create_Scenario_To_create_a_logical_partition_on_a_secondary_hard_disk')} Create Scenario: To 
create a logical partition on a secondary hard disk 
{button ,JI(`',`H_Create_Scenario_To_create_a_Linux_logical_partition')} Create Scenario: To create a Linux logical
partition 
{button ,JI(`',`H_Create_Scenario_To_create_a_primary_partition_for_Windows_NT')} Create Scenario: To create a 
primary partition for Windows NT 



To create a partition
The steps outlined below are for a single hard disk, single partition system. If you have a different configuration, 
the exact process and available options may differ slightly. For examples of creating partitions on more complex 
systems, see the scenarios listed under About Create.
1 Select a disk.
2 Select a block of unallocated space on the disk map or in the partition list.

If no unallocated space exists, you must resize or delete an existing partition to create unallocated space.
3 Click Partition > Create. 

The current size of the partition is shown on a disk map at the top of the dialog box. The map also depicts the 
used and unused space within the partition and the free space surrounding the partition (if any exists). The 
minimum and maximum sizes that you can resize a partition appears below the map.

4 Click Logical Partition or Primary Partition.
If you select Logical Partition, PartitionMagic automatically creates an extended partition to enclose the logical 
partition. Or, if you already have an extended partition, PartitionMagic resizes the extended partition larger to 
encompass the logical partition (the free space must be inside of or adjacent to the extended partition).
If Logical Partition is unavailable, you may already have four primary partitions on the hard disk. Or, if you 
have an extended partition, you may not have selected a block of free space inside of or adjacent to the 
extended partition.
If you are installing an operating system on the partition, it must be a primary partition.

5 Select the file system type you want from the Partition Type drop-down list.
Option Description
FAT The most 

common file 
system type. It
is used by 
DOS, and 
Windows 
3.x/95/98/Me/
NT/2000/XP.

FAT32 Used by 
Windows 95 
OEM Service 
Release 2, 
Windows 98, 
and Windows 
2000/XP.

NTFS Used by 
Windows 
NT/2000/XP.

Linux 
Ext2, 
Ext3, or
Linux 
Swap

Used only by 
Linux.

Extende
d

Creates an 
extended 
partition, 
which can 
contain any 
number of 
logical 



partitions. 
Extended is 
not an option 
if the hard disk
already 
contains an 
extended 
partition or 
four primary 
partitions.

formatt
ed

Creates 
unformatted 
free space on 
your hard 
drive.

6 (optional) Type a label (up to 11 alphanumeric characters for FAT/FAT32 or 32 for NTFS) for the new partition in 
the Label text box.
A descriptive label can help remind you what is stored in the partition (for example, DATA, APPS, WIN95, and 
so forth).

7 Specify the size of the new partition in the Size text box.
PartitionMagic automatically calculates a recommended size (based on the most efficient use of disk space), 
which you can accept or change.

8 Click Beginning of unallocated space or End of unallocated space.
If the size you specified for the new partition is smaller than the available unallocated space, you can position 
the partition at the beginning or the end of the unallocated space. Usually, it is best to position the partition at 
the beginning of the unallocated space.

9 Note the drive letter that will be assigned to the new partition after you reboot your machine. Or, if you are 
running Windows NT, specify the drive letter you want to assign the partition, in the Drive Letter text box.
Under Windows 9x or Windows Me, a new primary partition will automatically be hidden and will not be 
assigned as drive letter because these operating systems cannot handle multiple, visible primary partitions.

10 Click OK.

Tips
· If you created a new primary partition, follow this general process to install an operating system on it:

1 Make the partition active (click See Also on the Help toolbar for more information).
2 Close all programs and reboot the computer using an operating system installation disk. 
3 Install the operating system. See your operating system documentation for specific details.
4 Add the operating system to your BootMagic Menu so that you can select the operating system you want to 
boot. For more information, click See Also on the Help toolbar.

· PowerQuest recommends running DriveMapper when you are prompted. Creating a partition can make your 
drive letters change, causing applications not to run because application shortcuts, initialization files, and 
registry entries refer to incorrect drives. DriveMapper, a utility included with PartitionMagic, helps you easily 
update drive letter references. Under some conditions, DriveMapper runs automatically after you delete a 
partition.

· If your system includes SCSI disks and you create a partition before a bootable Linux partition, Linux may no 
longer be bootable. In this situation, you may need to create rescue disks, boot from the rescue disks, and 
repair the Linux boot information on the Linux partition.



Create Scenario: To create a logical partition on a secondary hard disk
One CD-ROM drive (F:).
Disk 1 - One 3 GB disk that contains the following:
· One active primary FAT32 partition (C:) running Windows 98.
· One extended partition enclosing one logical FAT partition (E:).

 

Disk 2 - One 3 GB hard disk that contains the following:
· One 1,500 MB FAT32 primary partition (D:).
· 1,500 MB unpartitioned free space.

 

For this scenario you want to create a 1,500 MB logical FAT partition on Disk 2.

 

Steps
1 Select Disk 2.
2 Create a logical partition in the 1,500 MB free space using the following information:

Op
tio
n

Action

Par
titi
on 
typ
e

Select 
FAT.

La
bel

(optional) 
Specify 
the label 
or name 
of the 
partition.

Siz
e

Accept 
the pre-
calculated
size that 
is 
specified.

The partition will be assigned drive F: after reboot. Also, an extended partition will automatically be created to 



enclose the logical partition.
3 Apply the changes to your system.

Result
After the computer reboots, the new logical partition is drive F: and the CD-ROM is drive G:. DriveMapper 
automatically updates all drive letter references that pointed to the CD-ROM.



Create Scenario: To create a Linux logical partition
One 6 GB hard disk that contains the following:
· One active primary FAT partition (C:) running Windows 98.
· One extended partition enclosing one logical FAT partition (D:) and one logical FAT32 partition (E:).

 

In this scenario you want to resize drive E: smaller. In the newly created free space, create one logical Linux Ext2
partition and one logical Linux Swap partition.

 

Steps
1 Resize drive E: smaller by 550 MB. 
2 Create a logical partition in the free space using the following information:

Op
tio
n

Action

Par
titi
on 
typ
e

Select 
Linux 
Ext2.

La
bel

(optional)
Specify 
the label 
or name 
of the 
partition.

Siz
e

Type 500.

3 Create a second logical partition in the free space using the following information:
Op
tio
n

Action

Par
titi
on 
typ
e

Select 
Linux 
Swap.

Siz
e

Type 50.

4 Apply the changes to your system.
5 Reboot the computer using your Linux installation disk.
6 Complete the Linux installation.



PowerQuest technical support does not provide help for installing operating systems.
Important: If you are using a boot utility like BootMagic, LILO (Linux Loader) must be installed to the Linux 
Ext2 partition containing the root directory and not installed to the master boot record. If you install LILO to 
the master boot record, other operating systems may become unbootable.

7 Add Linux to your BootMagic configuration so that each time you start or restart your computer, you can select
the operating system you want to boot.

Result
When the computer restarts, BootMagic presents a list of the available operating systems, in this case, Windows 
95 and Linux. Select the operating system you want to boot.



Create Scenario: To create a primary partition for Windows NT
One 3 GB hard disk containing one active primary FAT32 partition (C:) running Windows 98.

For this scenario, you want to resize drive C: smaller. In the newly created free space, you will create a primary 
FAT partition where Windows NT can be installed. At the end of this scenario, your disk map will appear 
(approximately) like this.

Steps
1 Resize drive C: smaller by 780 GB.

The partition where you want to install Windows NT must begin in the first 2 GB of the disk, or Windows NT will
not be bootable. You may need to move your existing partition to the end of the disk, then create the Windows
NT partition at the beginning of the disk. The arrow markers on the disk map, delimit the 2GB boundary of the 
hard disk.

2 Create a primary partition in the free space using the following information:
Op
tio
n

Action

Par
titi
on 
typ
e

Select FAT.
Do not select 
FAT32 unless 
you are using 
Windows 
2000/XP. 
Earlier 
versions do 
not recognize 
FAT32 
partitions. 
Also, do not 
select NTFS. 
When you 
install 
Windows NT, 
you can 
convert the 
partition to 
NTFS.

La
bel

(optional) 
Specify the 
label or name 
of the 



partition.
Siz
e

Type 1250.

Before performing the next step, make sure you have the Windows NT installation CD and disks; otherwise, 
you will not be able to boot your computer.

3 Set the new partition active.
4 Apply the changes to your system.

Before installing Windows NT, make sure that all partitions end prior to cylinder 1024. Otherwise, Windows NT 
will not install and will report that all the partitions are corrupted. If you cannot resize and move all partitions, 
you must obtain updated drivers from Microsoft (see article ID: Q197667 on the Microsoft web site).

5 Reboot the computer using the first Windows NT installation disk.
6 Complete the Windows NT installation.

PowerQuest technical support does not help install operating systems. See your operating system 
documentation for details.

7 Add Windows NT to your BootMagic configuration so that each time you start or restart your computer, you 
can select the operating system you want to boot.

Result
When the computer restarts, BootMagic presents a list of the available operating systems, in this case, Windows 
98 and Windows NT. Select the operating system you want to boot. 



About Delete
Use Delete to remove a partition from a hard disk. While the data within the partition will continue to reside on 
the hard disk, it can only be made accessible by applying the Undelete operation.
If you prefer to remove a partition from a hard disk and destroy all the data, you can use the Delete and Secure 
Erase option. Once a partition has been securely erased, it cannot be brought back using the Undelete operation.
Deleting a partition can make your drive letters change, causing applications not to run because application 
shortcuts, initialization files, and registry entries refer to incorrect drives. DriveMapper, a utility included with 
PartitionMagic, helps you easily update drive letter references. Under certain conditions, DriveMapper runs 
automatically after you delete a partition.
To delete or securely erase an extended partition, you must first delete all logical partitions within the extended 
partition. You cannot securely erase unallocated space.
{button ,JI(`',`H_To_delete_a_partition')} To delete a partition



To delete a partition
Performing the following steps will destroy all data on the selected partition and may change drive letter 
assignments.
1 Select a disk and a partition.
2 Click Partition > Delete.
3 Click Delete or Delete and Secure Erase.
4 Click OK.

Tips
· To delete an extended partition, you must first delete all logical partitions within the extended partition.
· In step 3, you can also right-click the partition you want to delete, then click Delete. You should be aware that 

using the Delete and Secure Erase option takes much longer than simply deleting a partition.
· To delete or securely erase an extended partition, you must first delete all logical partitions within the 

extended partition. You cannot securely erase unallocated space.
· PowerQuest recommends running DriveMapper when you are prompted. Deleting a partition can make your 

drive letters change, causing applications not to run because application shortcuts, initialization files, and 
registry entries refer to incorrect drives. DriveMapper, a utility included with PartitionMagic, helps you easily 
update drive letter references. Under some conditions, DriveMapper runs automatically after you delete a 
partition.

· If your system includes SCSI disks and you delete a partition before a bootable Linux partition, Linux may no 
longer be bootable. If this happens, you will need to create Linux rescue disks, boot from the rescue disks, and
repair the Linux boot information on the Linux partition.



About Label
Use Label to change a partition's label (or name). Giving your partitions meaningful names can help you manage
them easier.
{button ,JI(`',`H_To_change_a_partition_label')} To change a partition label 



To change a partition label
1 Select a disk and a partition.
2 Click Partition > Label.
3 Type the label you want in the New Label text box. Some partition types cannot contain certain characters.

Partition 
Type

Maximum Number of 
Alphanumeric Characters

Invalid 
Characters

FAT, FAT32 11 [ ] * ? : < > | + . 
= ; \ / " ,

NTFS 32 None
Linux Ext2 16 None

4 Click OK.



About Format
Use Format to format a partition, destroying all its data in the process. Formatting lets you put a different file 
system on a partition.
PartitionMagic has several conversion options that let you convert from one file system to another without 
destroying existing files in a partition. For more information about converting partitions, click See Also on the 
Help toolbar.
{button ,JI(`',`H_To_format_a_partition')} To format a partition 



To format a partition
1 Select a disk and a partition.
2 Click Partition > Format.
3 Select the file system type you want from the Partition Type drop-down list.

If the partition is too small or too large, some partition types may not be available.
4 (optional) Type the label you want in the Label text box.

Labels cannot contain the following special characters: [ ] * ? : < > | + = ; \ / " , . 
5 Type OK to confirm that you want to format the partition.
6 Click OK.



About Copy
Use Copy to make an exact duplicate of a partition. The copy is the same size (or slightly different if copied to 
another physical disk with a different geometry) and file type and contains the same data as the original. When 
you copy a partition, you specify the hard disk and the unallocated space where you want to place the copy.
To copy a partition, you must have unallocated space that is equal to or larger than the partition.
Some of the reasons you may want to copy a partition include the following:
· To duplicate your operating system before upgrading to a new version or a different operating system (so that 

you can remember how the old operating system's windows, program icons, and properties were set up) or so 
that you can recover the original partition if the upgrade fails or is unsatisfactory.

· To quickly move a smaller hard disk's contents to a larger, new hard disk.
· To make a primary partition a logical partition, or vice versa.
· To change the relative order of partitions.
· To back up a partition.
{button ,JI(`',`H_To_copy_a_partition')} To copy a partition 



To copy a partition
1 Select a disk and a partition.
2 Click Partition > Copy.
3 Select the unallocated space where you want to copy the partition, in the partition list.
4 If the partition you specified is smaller than the available unallocated space, you can position the partition at 

the beginning (recommended) or end of the unallocated space. Under Position, click Beginning of free 
space or End of free space.

5 Click OK.

Tips
· The Copy option is dimmed (unavailable) if there is not enough unallocated space on your hard disks for the 

partition.
· In step 4, if you are copying a logical partition and want to ensure that it remains logical, make sure 

unallocated space is available within the extended partition. Or, after copying the partition, you can convert it 
to a logical partition.



About Merge
You can use Merge to join two FAT, FAT32, or NTFS partitions that are adjacent to each other on a hard disk. This 
is useful if you have reached the maximum number of partitions on your disk, but you do not want to delete a 
partition. It is also useful if you want to combine FAT partitions and convert them to one large FAT32 or NTFS 
partition. There can be unallocated space between the two partitions you want to merge.
Important: Merging partitions may take a long time (possibly hours), depending on the partition sizes and 
amount of data they contain. If you want to check whether your machine is still operating, you can press the 
NumLock key and see if the light toggles. It may take a few seconds to register activation of the NumLock key on
your keyboard. If you plan to merge partitions, you may want to schedule it for a time when you will not need to 
use your system for an extended period of time. If you shut down or turn off your computer while PartitionMagic 
is still working, it will cause corruption to the file system, which will result in data loss. Do not shut down the 
system until after the operation is complete.
You can merge left to right or right to left, with one exception. You cannot merge a primary partition at the 
beginning of your hard disk into a logical partition; however, you can merge a logical partition into a primary 
partition.
Please note the following important points about Merge:
· You cannot merge a FAT/FAT32 partition with an NTFS partition.
· If you merge two partitions and then want them separate again, you can use the Split operation to "undo" the 

merge.
· Do not merge two operating system partitions.
· If you are using Windows NT 4.0, you should not merge two FAT partitions that will result in a FAT32 

partition. Only Windows 95b or later, Windows 98/Me/2000/XP can access FAT32 partitions.
· If you plan to merge two adjacent NTFS partitions, they must be the same version type and have the same 

cluster size. If the cluster sizes are different, you will not be able to merge the partitions. See "Converting 
FAT/FAT32 Partitions to 4K Aligned" in the "About Convert Help topic.

· If you have one empty partition and one that contains data, it is better to delete the empty partition and resize
the other one larger than it is to merge the two partitions.

{button ,JI(`',`H_To_merge_a_partition')} To merge a partition 



To merge a partition
1 Select a disk and a partition that you want to merge with another partition.
2 Click Partition > Merge.
3 Click the Merge option you want.

Do not merge two operating system partitions or two compressed partitions.
4 Type a name for the new folder that will be created in the partition you are keeping, in the Folder Name text 

box.
5 Click the file system type you want to use for the partition you are keeping. The NTFS option will automatically 

be selected if you are merging two NTFS partitions.
6 Click OK.

Tips
· If you are using Windows NT 4.0, you should not merge two FAT partitions that will result in a FAT32 

partition. Only Windows 95b or later, Windows 98/Me/2000/XP can access FAT32 partitions.
· If you plan to merge two adjacent NTFS partitions, they must be the same version type and have the same 

cluster size. If the cluster sizes are different, you will not be able to merge the partitions. See "Converting 
FAT/FAT32 Partitions to 4K Aligned" in the "About Convert" Help topic.
To view the version type and cluster size of a partition, right-click the partition in the disk map, select 
Properties, then click the NTFS Info tab.

· In step 2, the contents of one partition will be moved into a folder within the other partition.
· Once you apply the merge operation to your system, there is no method for undoing a merge.



About Check for Errors
Use Check for Errors to inspect the integrity of a partition. If a check operation fails, "Check Failed" appears in 
the Used and Free columns in the partition list. You should fix any errors encountered. For more information, see 
Resolving Check Errors below.
Check for Errors does not display information about the status and structure of a partition as does the DOS, 
Windows, and OS/2 CHKDSK utilities. To view such information, click Partition > Properties.

Check Partition Results
If errors are found (such as cross-linked files, lost clusters, or bad directory information on an NTFS or Linux Ext-2
volume) and PartitionMagic can fix it, you can click Fix in the dialog box.
For each error found, Check for Errors displays a table with the following column headings:

Column 
heading

Description

Severity Describes the 
seriousness of the 
problem, which can be 
one of the following 
entries:
· Info - The 

information given is 
helpful, but not 
critical. Does not 
correspond to any 
error.

· Warning - The error 
may or may not 
cause problems.

· Error - A problem 
was encountered, 
but PartitionMagic 
may still be able to 
make changes to 
the partition. Run 
MS ScanDisk or 
CHKDSK to fix the 
error, or click Fix, if 
available.

· Critical - A 
catastrophic 
problem. 
PartitionMagic 
cannot make any 
changes to the 
partition.

Fixed Displays Yes for each 
problem you fix on an 
NTFS or Linux Ext-2 
volume. Not applicable 
for FAT, or FAT32 
partitions.

Number Shows a number 
corresponding to the 
error. For more 



information about error 
messages and 
solutions, you can visit 
Support on the 
PowerQuest web site 
and search on a 
particular error code.

Descripti
on

Gives a brief 
description of the 
problem.

If no errors are found, an Info entry appears with "Check Complete" in the Description column.

Resolving Check Errors
PartitionMagic checks the integrity of a partition thoroughly before making changes to it. The Check and Info 
operations perform the same checks and display error messages when they discover problems. These checks are
similar to those made by an operating system's CHKDSK, MS ScanDisk, or AUTOCHK utility.
PartitionMagic also checks a partition after modifying it. If problems persist, you should report the problem to 
PowerQuest technical support. 
While data loss is possible, it is not typical. The problem is usually a minor file system error that CHKDSK /F /R (or
MS ScanDisk, if you are using Windows 95 or Windows 98) can correct without data loss. For more extensive 
errors, you may need to restore your files from a backup copy. 
If you receive a Check error message on any partition, back up your hard disk and then run your operating 
system's CHKDSK program on that partition (do not use the /F switch on the initial run). If you have MS-DOS 6.x, 
Windows 95, or Windows 98, run MS ScanDisk. CHKDSK and MS ScanDisk typically discover the same problems 
as PartitionMagic (except that CHKDSK does not detect problems in Extended Attributes). 
If CHKDSK or MS ScanDisk does not show the same errors as the Check operation, contact PowerQuest technical 
support..
If CHKDSK or MS ScanDisk and the Check operation detect the same errors, which is usually the case, run 
CHKDSK with the /F switch or run MS ScanDisk to fix the problems. Then run CHKDSK again without the /F switch 
to ensure that the partition is error free. Under OS/2, perform this procedure (running CHKDSK without /F) twice.
When CHKDSK reports no errors on the partition, run the Check operation. If PartitionMagic still reports a 
problem, reformat the partition and restore your files from the backup copy.
{button ,JI(`',`H_To_check_a_partition_for_errors')} To check a partition for errors 



To check a partition for errors
1 Select a disk and a partition.
2 Click Partition > Check for Errors.
3 To fix an error on an NTFS or Linux Ext-2/Ext3 volume, highlight the problem > click Fix.



About Properties
Use Properties to display data about disk usage, cluster waste, partition information, and FAT, and NTFS 
information.

· Usage 
· Cluster Waste 
· Partition Information 
· File System Information 
· NTFS 

To view partition information 



To view partition information
1 Select a disk and a partition.
2 Click Partition > Properties.
3 Click the tab whose information you want to view.

Tips
· Based on the file system that the partition uses, different pages appear.



About MS ScanDisk and Windows CheckDisk
Use MS ScanDisk to scan a partition for errors and fix them. MS Scandisk is a system tool included with Windows 
9x and Windows Me that you can run from PartitionMagic. The Check for Errors operation will also scan for errors,
but it does not fix them for FAT or FAT32 partitions.
MS ScanDisk only scans partitions with assigned drive letters; it does not scan hidden partitions, extended 
partitions, free space, or partitions with file systems not supported by the active operating system.
For more information about MS ScanDisk and some of the advanced options you can use, see the Windows 95 or 
Windows 98 online Help.

Windows CheckDisk
Use Windows CheckDisk to scan a partition for errors. Windows CheckDisk is a system tool that you can run from 
PartitionMagic if you are running Windows NT/2000/XP.
Windows CheckDisk only scans partitions with assigned drive letters; it does not scan hidden partitions, 
extended partitions, unallocated space, or partitions with file systems not supported by the active operating 
system.
PartitionMagic invokes Windows CheckDisk in read-only mode. In most instances, including the /F switch, to fix 
errors on an NTFS partition requires a system reboot. If you want to fix discovered partition errors, you should 
exit PartitionMagic and run CHKDSK /F from the command prompt.
For more information about Windows CheckDisk and some of the advanced options you can use, see the 
Windows NT, Windows 2000, or Windows XP online Help.
{button ,JI(`',`H_To_use_MS_ScanDisk_to_check_for_errors')} To use MS Scandisk to check for errors 
{button ,JI(`',`To_use_Windows_CheckDisk_to_check_for_errors_Windows_NT_2000_only_')} To use Windows 
CheckDisk to check for errors (Windows NT/2000/XP only)



To use MS ScanDisk to check for errors
1 Select a partition.
2 Click Partition > MS ScanDisk.
3 Click Standard or Thorough.

The Thorough option scans the partition for bad sectors.
4 (optional) Select Automatically fix errors.
5 Click Start.



To use Windows CheckDisk to check for errors (Windows NT/2000/XP only)
1 Select a disk and a partition.
2 Click Partition > Windows CheckDisk.
When Windows CheckDisk is finished, the results appear in the command window. When you are finished viewing
the results, press any key to close the command window and return to PartitionMagic.



About Convert
Use Convert to change the file system type used in a partition.
Important: You cannot convert file system types on compressed drives. First, uncompress the driven, then run 
the conversion operation.

FAT to FAT32
Use to convert a FAT partition to FAT32. FAT32 partitions have less wasted disk space than FAT partitions. 
However, you should be aware of the following issues:
· You must have Windows 95 OEM Service Release 2, Windows 98/Me/2000/XP to access files on a FAT32 

partition. If you run an operating system other than these, FAT32 partitions will be inaccessible when the other
operating systems is running, even if one of these operating systems is installed on your machine.

· Some computers have a sleep mode that saves all memory to disk. Because this function sometimes requires 
a FAT partition, consult your computer manual or contact the manufacturer before converting to FAT32.

· The minimum recommended size for a FAT32 partition is 256 MB.

FAT to NTFS (Windows NT/2000/XP only)
The FAT to NTFS operation launches the Microsoft Convert utility to convert a FAT partition to NTFS. You must be 
running Windows NT/2000/XP to complete this conversion. The conversion cannot be performed from the rescue 
disks.
If you boot multiple operating systems, you must be careful when you convert FAT to NTFS. NTFS is only 
accessible with Windows NT/2000/XP; therefore, the data in this partition will not be accessible if you boot DOS 
or Windows 95/98/Me.

FAT32 to FAT
Use to convert a FAT32 partition to a FAT partition. To complete this conversion, the partition must have at least 
300-400 MB of unused space because of how the FAT file system allocates disk space for file storage.

FAT32 to NTFS (Windows 2000/XP only)
The FAT32 to NTFS operation launches the Microsoft Convert utility to convert a FAT32 partition to NTFS. You 
must be running Windows 2000/XP to complete this conversion.
If you boot multiple operating systems, you must be careful when you convert FAT32 to NTFS. NTFS is only 
accessible from Windows NT/2000/XP; therefore, the data in this partition will be unavailable if you boot DOS or 
Windows 95/98/Me. You cannot perform this conversion from the rescue disk.

FAT/FAT32 to 4K Aligned
Unlike an NTFS partition, the first cluster in a FAT or FAT32 partition is not located at the beginning of the 
partition. Instead, all the FAT clusters come after a group of sectors that are designated as a system area. 
Because the number of sectors needed for this system area varies, the first cluster may not be aligned on any 
particular boundary.
During a convert operation from FAT or FAT32 to NTFS, all the sectors in the system area must be converted to 
clusters. The cluster size of the resulting NTFS partition is dependent on how many sectors are in the system 
area. If the number of sectors in the system area is a multiple of eight, then the NTFS cluster size can be up to 
4K in size (8 sectors x 512 bytes per sector equals 4K). If the number of sectors is not a multiple of eight, then a 
smaller cluster size must be used when converting to NTFS.
When you convert a FAT or FAT32 partition to 4K aligned, the operation will check the number of sectors in the 
system area to see if it is a multiple of eight. If it is not, it will adjust the value by padding the number of sectors 
in the system area and shifting all the data clusters accordingly. This will ensure that if you decide to convert the 
partition to NTFS at a later time, it is possible to have 4K clusters on the resulting partition.



NTFS to FAT or FAT32
Use to convert an NTFS partition to a FAT. This type of conversion lets you access the partition's files using a DOS
or Windows 9x/Me/NT/2000/XP.
Converting an NTFS partition to FAT32 lets you view the contents of the partition from Windows 
95b/98/Me/2000/XP. However, a FAT32 partition will not be accessible to Windows 95a and Windows NT.

Conditions of conversion
NTFS is a more advanced file system than FAT and FAT32. Therefore, depending on the NTFS features used on 
the partition, the type of data, and partition size, you will either be allowed to complete the conversion or not.
If you receive an error message and the conversion stops, one or more of the following usually causes it:
· The file system for conversion is not allowed for the current partition size. The FAT32 partition must be 

greater than 256 MB and the FAT partition must be less than 2 GB.
· The Windows 2000/XP NTFS partition has compressed files, sparse files, reparse points, or encrypted files. In

such cases, you can uncompress and/or move (or delete) the files or points, then repeat the conversion.
· The NTFS partition has data in memory that has not yet been written to the hard disk.
· The file system has errors, such as lost clusters and cross-linked files. You can fix these problems, then try 

the conversion again.
· There is not enough temporary space in the partition to do the conversion. The conversion will require the 

NTFS system and the FAT32 system files until the last step of the conversion. Also, there is data in NTFS 
FRS's that must be moved to external clusters and saved.

If you can complete the conversion, you may receive a warning about the quality of data and feature loss, 
depending on the features used on the partition, the type of data, and the partition size.

Warni
ng

Description

Error The conversion is 
not allowed. 
Because the 
partition being 
converted is using 
advanced features 
in NTFS, you may 
experience 
unintended data 
and feature loss. 
You will receive an 
error warning in 
one or more of the 
following cases:
· Hard-links are 

found that the 
conversion will 
not allow if 
there are:
--Two or more 
hard-links to the
same file. Links 
with the same 
or different 
parent.
--Two or more 
long filenames 
to the same file.



Links with the 
same parent.
--Any hard-links 
to the same file 
with different 
parent 
directories.

· There are 
sparse files on 
the volume. 
Any sparse 
files, except for 
the bad sector 
file, will stop 
the conversion.

· There is more 
than one data 
stream for any 
file.

· Any links.
· Any EA's.
· Any user-

defined 
attributes in 
any file.

· Device entries.
Warni
ng

The conversion is 
allowed. Although a
conversion warning
is not as serious as 
an error, you may 
still experience the 
loss of NTFS-
specific features 
that are not 
supported in 
FAT/FAT32. You will 
receive a 
conversion warning
in one or more of 
the following cases:
· Disk usage 

quotas - NTFS 
supports 
limiting the 
amount of disk 
space for a 
user. After 
conversion, all 
users will have 
full access to all
free hard disk 
space.



· Access control 
lists - This is a 
file attribute 
that lists all the 
users that can 
access a file. 
After 
conversion, all 
users will have 
full access to all
files.

· Index of access 
control lists - A 
list of all files 
that have 
specific access 
rights assigned 
to them. After 
conversion, all 
users will have 
full access to all
files.

· FAST index file -
This file is 
sometimes 
created on 
Windows 2000 
computers. 
After 
conversion, all 
indexing of 
keywords will 
be lost.

· Old versions of 
files - NTFS has 
the ability to 
keep versions of
files, however, 
only the current
version of the 
file is converted
and saved.

No 
warni
ng

The conversion is 
allowed. The most 
basic NTFS partition
still gives files more
features than are 
found in FAT or 
FAT32. When 
Windows NT 4.0 is 
used to copy files 
from an NTFS 
partition to a FAT 
partition, no 



warning is given 
about the features 
you are losing. 
Also, the 
conversion will not 
give you a warning 
about specific 
features that 
cannot be 
converted. These 
features include:
· Standard 

journal file - 
This file is a 
transaction log 
of changes to 
the NTFS file 
system. After 
conversion, the 
journal file will 
be lost.

· NTFS-specific 
file attributes - 
NTFS and FAT 
both have 
standard file 
attributes, such 
as Read-only, 
Archive, 
Hidden, and 
System. NTFS 
has additional 
file attributes 
that can be set. 
After 
conversion, 
however, these 
additional file 
attributes will 
be lost.

· NTFS-specific 
file dates - On 
the last edit 
time is 
converted to 
the FAT date. 
After 
conversion, the 
creation date, 
last access 
date, and last 
edit date (date 
change only) 
will be lost.



· Reliable change
journal - This 
journal file is 
new to Windows
2000 and XP. 
After 
conversion, this
file will be lost.

Primary to Logical
If you have reached the limit of primary partitions on your hard disk, you can use Primary to Logical to convert a 
primary partition to a logical partition. If you create a logical partition, PartitionMagic will automatically place it in
an extended partition. You can then create more logical partitions within the extended partition, expanding the 
maximum number of partitions on the disk.

Logical to Primary
You can use Logical to Primary to convert a logical partition to a primary partition if you plan to install an 
operating system on it. The partition must be a primary partition to be bootable.
{button ,JI(`',`H_To_convert_FAT_to_FAT32')} To convert FAT to FAT32 
{button ,JI(`',`H_To_convert_FAT_to_NTFS')} To convert FAT to NTFS 
{button ,JI(`',`H_To_convert_FAT_to_NTFS')} To convert FAT32 to NTFS (Windows 2000/XP only)
{button ,JI(`',`H_To_convert_FAT_FAT32_to_4K_aligned')} To convert FAT/FAT32 to 4K Aligned 
{button ,JI(`',`H_To_convert_FAT32_to_FAT')} To convert FAT32 to FAT 
{button ,JI(`>Main',`H_To_convert_FAT_to_FAT32')} To convert NTFS to FAT 
{button ,JI(`>Main',`H_To_convert_FAT_to_FAT32')} To convert NTFS to FAT32 
{button ,JI(`',`H_To_convert_Primary_to_Logical')} To convert a partition to Primary/Logical 



To convert FAT to FAT32 or NTFS to FAT/FAT32
1 Select a disk and a FAT or NTFS partition.

You can see which partitions are labeled FAT or NTFS by looking at the Type column in the partition list.
2 Click Partition > Convert.
3 Click FAT or FAT32 (the option available depends on the partition you selected in step 1).
4 Click OK.

Tips
· Converting a partition from NTFS to FAT or FAT32 will cause you to lose all security settings on all files and 

directories that you may have created on that partition. This is because FAT and FAT32 do not support security 
attributes inherent with the NTFS file system.
Windows 2000/XP NTFS partitions that have sparse files, reparse points, or encrypted files should not be 
converted to FAT or FAT32 with this version of PartitionMagic.



To convert FAT/FAT32 to NTFS (Windows 2000/XP only)
1 Select a disk and a FAT/FAT32 partition.

You can see which partitions are labeled FAT or FAT32 by looking at the Type column in the partition list.
2 Click Partition > Convert.
3 Click NTFS.
4 Click Yes to continue with the conversion.

Because Windows NT (FAT to NTFS) or Windows 2000/XP (FAT32 to NTFS) performs the conversion, when you 
click Yes, PartitionMagic automatically applies any pending changes that are listed in the Operations Pending 
dialog box and exits. The Convert utility is then started.

5 If you have open files, a message appears indicating that the convert utility cannot gain exclusive access to 
the hard disk and asks if you want to schedule the conversion the next time the computer restarts. If you type 
Y, the conversion will automatically take place when you reboot the computer. After typing Y you should close 
PartitionMagic and manually reboot the computer to complete the conversion.
If you do not have any open files, the Batch Progress dialog box appears. Click OK to return to the 
PartitionMagic main window. The partition is converted.

Tips
· The convert FAT or FAT32 to NTFS option is available only if you are running the Windows NT version of 

PartitionMagic, there is sufficient free space, the partition is large enough, and the partition has a drive letter 
assigned. The convert FAT32 to NTFS option is available only if you are running Windows 2000/XP.



To convert FAT/FAT32 to 4K aligned
1 Select a disk and a FAT/FAT32 partition.

You can see which partitions are labeled FAT or FAT32 by looking at the Type column in the partition list.
2 Click Partition > Convert.
3 Click FAT32 (4K aligned).
4 Click OK.

Tips
· If you are converting a FAT partition to 4 K aligned, not that FAT partitions greater than 2GB can only be 

accessed by Windows NT/2000/XP.
· If you are converting a FAT32 partition to 4 K aligned, you must have Windows 95 (OEM Service Release 2), or 

Windows 98/Me/2000/XP to access files on a FAT32 partition.



To convert FAT32 to FAT
1 Select a FAT32 partition.

You can see which partitions are labeled FAT32 by looking at the Type column in the partition list.
2 Click Partition > Convert.
3 Click FAT.

The menu command is dimmed if your FAT32 partition contains over 2 GB of data. If the partition size is over 2
GB but contains less than 2 GB of data, you can convert the partition (without data loss), but the new partition 
will be 2039 MB.

4 Click OK.

Tips
· After step 3, PartitionMagic may report too many root directory entries (the maximum number of entries in a 

FAT partition's root directory is limited, unlike a FAT32 partition's root directory). In this case, move or copy 
some of the files in the root directory to another location and then start the conversion with step 1 again. After
completing the conversion, you can increase the number of files in the root directory and move the files back.



To convert a partition to Primary/Logical
1 Select a disk    partition.

You can see which partitions are labeled Primary or Logical by looking at the Pri/Log column in the partition list.
2 Click Partition > Convert.
3 Click Primary or Logical (the option available depends on the partition you selected in step 1).
4 Click OK.



About Bad Sector Retest
Use Bad Sector Retest to check sectors on FAT and FAT32 partitions that have been marked bad and recover 
sectors that are usable.
The FAT file system allocates disk space for file storage in units called clusters, which are composed of a fixed 
number of sectors. Because the FAT file system tracks bad sectors at the cluster level, it marks an entire cluster 
bad even though the problem may exist in a single sector. Use the Info option to discover whether a partition 
contains bad clusters. For more information, click See Also on the Help toolbar.
As a conservative measure, when you move or resize a partition or increase cluster size, PartitionMagic marks all
new clusters containing any part of old bad clusters as bad (even though the clusters may not actually contain 
bad sectors). Likewise, when you decrease a partition's cluster size, PartitionMagic divides bad clusters into 
multiple bad clusters. If, after you complete these tasks, PartitionMagic reports bad sectors, you can perform Bad
Sector Retest and reclaim the good sectors that were marked bad.
You should be aware that some sectors marked as bad are "marginally bad," meaning that one time the sector 
works fine and another time it does not. Bad Sector Retest may mark a marginally bad sector as good. This can 
result in data loss if the marginally bad sector fails in the future. Most modern hard drives detect bad sectors and
automatically remap the sector, so in general, you do not see bad sectors on modern hard drives. If you do get 
bad sector errors on a modern hard drive, it is recommended that you replace the drive.
{button ,JI(`',`H_To_retest_bad_sectors')} To retest bad sectors 



To retest bad sectors
1 Select a partition.
2 Click Partition > Advanced > Bad Sector Retest.
3 Click OK.

Tips
· The Bad Sector Retest operation applies to FAT and FAT32 partitions only.
· If you have open files on the partition being retested, PartitionMagic will reboot your machine and run the 

operation in boot time mode.



About Hide Partition
Use Hide Partition to secure partitions against unwanted user access. You can perform this operation on FAT, 
FAT32, and NTFS partitions. 
When you hide a partition, the next time you boot your computer the partition is not assigned a drive letter. 
Conversely, when you unhide a partition, the next time you boot your computer the partition is assigned a drive 
letter. 
Hiding and unhiding partitions (under DOS or Windows 95/98/Me) can cause the drive letters of other partitions 
to change. When this happens, your computer may not boot and applications may not run. PowerQuest 
recommends that you allow DriveMapper (a utility included with PartitionMagic) to run automatically to update 
drive letter references that change as a result of hiding or unhiding partitions.
If your hard disk has more than one primary partition, only one is visible by default. When you use the Set 
Active operation, PartitionMagic unhides the selected primary partition and hides other primary partitions. While
you can unhide more than one primary partition, we recommend that you do not.
If you are running Windows NT/2000/XP, partitions are not hidden automatically; therefore, you can have 
multiple visible primary partitions.
{button ,JI(`',`H_To_hide_a_partition')} To hide a partition 



To hide a partition
1 Select a disk and a partition.
2 Click Partition > Advanced > Hide Partition.
3 Click OK.

Tips
· To unhide a partition, repeat the steps above but click Unhide Partition in step 3.
· If you hide a Windows NT boot partition, you must manually edit your BOOT.INI file to point to a new Windows 

NT boot partition.
· Unless you are running Windows NT/2000/XP, unhiding multiple primary partitions may cause your machine to 

be unbootable.
· PowerQuest recommends running DriveMapper when you are prompted. Hiding a partition can make your 

drive letters change, causing applications not to run because application shortcuts, initialization files, and 
registry entries refer to incorrect drives. DriveMapper, a utility included with PartitionMagic, helps you easily 
update drive letter references. Under most conditions, DriveMapper will run automatically after you hide or 
unhide a partition.

· Windows 2000 does not recognize a partition you have hidden using PartitionMagic. Therefore, the only 
effective method to hide a partition from use under Windows 2000/XP-without deleting it-is to remove the 
partition's assigned drive letter.



About Resize Root
Use Resize Root to change the maximum number of entries that can be placed in the root directory of a FAT 
partition. The number of root entries is set at the time the partition is formatted; the limit does not expand 
automatically as it does in a subdirectory or in a FAT32 partition. Consider increasing this number if you use 
Microsoft long filenames in the root directory. During this operation, data within the partition is unaffected.
Occasionally, enlarging the root directory displaces the first few files on the partition (such as IO.SYS and 
MSDOS.SYS if the partition contains an operating system). If the root directory is on a boot partition and the 
partition fails to boot after resizing the root directory, you should move the displaced files back to the front of the
disk (for instructions, contact technical support).
{button ,JI(`',`H_To_resize_the_root_directory')} To resize the root directory 



To resize the root directory
1 Select a disk and a partition.
2 Click Partition > Advanced > Resize Root.
3 Specify the number of entries you want the root directory to have, in the New capacity text box.

The number you specify is rounded to one that preserves the current cluster alignment.
4 Click OK.

Tips
· This operation applies to FAT partitions only.



About Set Active
Use Set Active to make a partition the active partition, or in other words, the partition the computer boots from. 
Only one partition can be active at a time. To boot your computer from a partition, the partition must be on the 
first drive, and it must contain an operating system. When your computer boots, it reads the partition table of 
the first drive to find out which partition is active and boots from that partition.
Before you make a partition active, it must be bootable. If the partition is not bootable or you are not certain that
it is, have a boot disk or CD ready. To create a boot disk, click See Also on the Help toolbar.
PartitionMagic hides any other FAT, FAT32, and NTFS primary partitions (unlike Windows 95, Windows 98, and 
DOS FDISK programs which cannot hide or unhide partitions). Hiding other primary partitions makes it easy to 
install multiple operating systems and choose the one you want to use with Set Active. For example, if you 
have Windows 95 and want to install Windows NT in a separate partition, you can make the Windows 95 partition
smaller, create another primary partition, set it as the active partition, and then boot from the Windows NT 
installation disks.
{button ,JI(`',`H_To_set_the_active_partition')} To set the active partition 



About Creating an Operating System Boot Disk
Boot disks are an invaluable tool for diagnosing and repairing certain OS problems. Some operating systems, 
such as Windows 95/98 and Windows NT, give you an opportunity to create a rescue boot disk during 
installation. This is the disk that should be used if you ever experience OS failure. 
DOS does not automatically provide an option for creating a boot disk. However, you can easily create a boot 
disk for DOS. You can also create a boot disk for Windows 95/98, if necessary.
{button ,JI(`',`H_To_create_an_operating_system_boot_disk')} To create an operating system boot disk 



To create an operating system boot disk
1 Insert a blank, formatted disk into drive A.
2 From the Windows taskbar, click Start > Run.
3 Type SYS A: in the Open text box, then click OK.
4 Copy the following files from your hard disk to the A: drive: SYS.COM, EDIT.COM, FDISK.EXE, FORMAT.COM, and

ATTRIB.EXE.
In Windows 95/98, these files are usually located in the \WINDOWS\COMMAND subdirectory. In DOS, these files
can be found in the \DOS subdirectory.

Tips
· If you are running DOS, type SYS A: at the DOS prompt, then press <Enter>. The system files are copied onto 

the floppy disk.
· You may also want to copy additional files, such as a CD-ROM driver, SCANDISK.EXE, CHKDSK.EXE, or 

XCOPY.COM. These files extend the capabilities of your boot disk.
· Be sure to write-protect the disk and clearly label it for easy identification.



To set the active partition
1 Select a partition.

Important: If the partition you select is not bootable or you are not certain if it is, have an operating system 
boot disk ready.

2 Click Partition > Advanced > Set Active.
3 Click OK.



About Resize Clusters
Use Resize Clusters to change the cluster size on FAT, FAT32, and NTFS partitions. Reducing cluster size may help
you reclaim wasted space on your hard disk.
All files on FAT and FAT32 partitions are stored in allocation units called clusters. Each file is allocated at least 
one cluster, resulting in wasted space in clusters containing small files. The size of a partition determines cluster 
size. Larger partitions have larger clusters, and, therefore, more wasted space. For more information about 
managing your hard disk space, click See Also on the Help toolbar.
It is not recommended that you use the smallest cluster size on partitions containing a single, large file, such as 
a database or swap file.

Default Cluster Sizes
A partition's cluster size is set by the DOS FORMAT operation, based on the size of the partition, as shown in the 
following tables.

DOS and Windows default FAT cluster sizes
Partition 
Size (MB)

FAT
Typ
e

Secto
rs 
Per 
Clust
er

Clu
ste
r 
Siz
e

0-15 12-
bit

8 512
byt
es

16-127 16-
bit

4 2 K

128-255 16-
bit

8 4 K

256-511 16-
bit

16 8 K

512-1,023 16-
bit

32 16 
K

1,024-2,047 16-
bit

64 32 
K

2,048-4,096 16-
bit

128 64 
K*

*Only available with Windows NT and Windows 2000/XP.

Windows FAT32 cluster sizes
Partition 
Size (GB)

Sect
ors 
Per 
Clus
ter

Cl
us
ter
Siz
e

0.256-8.01 8 4 K
8.02-16.02 16 8 K
16.03-
32.04

32 16 
K

> 32.04 64 32 
K

Resize Clusters Information



The Resize Clusters dialog box displays the possible cluster sizes from 512 bytes to 64 KB. For each cluster size, 
PartitionMagic displays the following:
· A bar graph and percentages represent how much space would be used and how much space would be wasted

if you chose that cluster size for the currently selected partition
· Wasted space (in megabytes)
· The range of allowable partition sizes (in megabytes) or other information
· If a cluster size requires a partition that is too small for the data and files on the partition, "Not Allowed" 

appears in the Notes column. "Not Enabled" appears in the Notes column for the 64 KB cluster size because it 
is only used for Windows NT. You can enable the 64 KB cluster size, but it is not recommended. 

The lower area of the Resize Clusters dialog box displays information about the current and new cluster size, as 
well as the current and new partition size (based on the new cluster size). You can click the New cluster size 
drop-down list to change the cluster size.
PartitionMagic adheres to the established limits for partition and cluster sizes. You cannot select a cluster size 
that is invalid for the selected partition.
Choosing a smaller cluster size may resize the partition smaller, creating free space next to the partition. You can
use this free space to create a new partition.
{button ,JI(`',`H_To_resize_clusters')} To resize clusters 



To resize clusters
1 Select a disk and a partition.
2 Click Partition > Advanced > Resize Clusters.
3 Select the cluster size you want to use (and can use) from the New cluster size drop-down list.
4 Click OK.

Tips
· In step 3, do not choose the 64 KB cluster size unless you have Windows NT or Windows 2000/XP.
· FAT16 partitions are resized automatically to fit the cluster size.



About Operations Pending
Use View Operations Pending to view a description of what changes you have specified on your system, but have
not yet put into effect.
{button ,JI(`',`H_To_view_pending_operations')} To view pending operations 



To view pending operations
1 Click View > Operations Pending.

Tips
· You may also look at the operations pending window located in the bottom of the left pane.
· Click Apply to apply all pending operations that are listed.
· Click Undo Last to remove the last operation you added to the list.
· Click Discard All to remove all pending operations and start over.
· Operations that must be run at boot time are marked with an icon. If any operation requires going into boot 

mode, it will be run at boot time.



About Change Drive Letter
Use Change Drive Letter to change the drive letter assigned to any partition visible to and supported by Windows
NT. This operation is only available when you are running Windows NT/2000/XP.
{button ,JI(`',`H_To_change_a_drive_letter_NT_only_')} To change a drive letter (NT only) 



To change a drive letter (NT only)
1 Select a disk and a partition.
2 Click Partition > Advanced > Change Drive Letter.
3 Specify the drive letter you want to assign to the partition, in the New drive letter text box.
4 Click OK.



About DriveMapper
When you create, delete, hide, and unhide partitions, your drive letters can change, causing applications not to 
run because application shortcuts, initialization files, and registry entries refer to incorrect drives. DriveMapper is
a wizard that lets you easily update drive letter references.
Important: DriveMapper does not change drive letter assignments; it only changes references to the drive 
letters, which are assigned by your operating system.
You can run DriveMapper from the PartitionMagic main window. DriveMapper also runs automatically if the 
following conditions are all met:
· You apply changes to your system that affect drive letter assignments
· You are running Windows 95 or Windows 98
· Your hard disk contains only FAT or FAT32 partitions
· You have no more than one CD-ROM drive and no more than one removable drive.
If you are using Windows NT or Windows 2000/XP Professional as your only operating system, we recommend 
using the Change Drive Letter operation (Operation > Advanced > Change Drive Letter) rather than 
DriveMapper. Change Drive Letter lets you permanently set the drive letters for your partitions so that adding 
and removing partitions does not affect drive letters. Note that if you merge or split partitions, drive letters will 
change even if you are using Windows NT and the Change Drive Letter operation.
If you have installed an alternative desktop on Windows 3.11 or Windows 95 with the desktop files residing on a 
different drive than the Windows system files, DriveMapper may not be able to adjust your paths. Because 
DriveMapper is a Windows program, it must have Windows loaded to run. If the drive letter has been changed for
the drive that holds your desktop files, you may not be able to start Windows.

Using DriveMapper with Multiple Operating Systems
If you run multiple operating systems, you should reinstall applications rather than use DriveMapper. The 
following issues make using DriveMapper in a multiple operating system environment difficult and error-prone:
· Drive letter assignments are based on the file systems supported by an operating system. If you do not put all 

FAT32, and NTFS partitions after all FAT partitions, drive letters will change depending on the operating system
currently running, and DriveMapper may be unable to correctly identify which changes should be made. 

· Registry settings are changed for the current operating system only. If you manually run DriveMapper from 
another operating system, references in files will already be changed in the current operating system and 
further changes will introduce errors in the other operating systems.

· When DriveMapper is running, files contained in hidden partitions are not updated. If you are using multiple 
primary partitions for different operating systems, only the active primary partition may be visible. Thus, only 
files in that primary partition will be updated.

Changing Drive Letters in the Correct Order
You must change drive letter in the correct order to avoid destroying original references before they are used to 
make changes for other drive letters. 
For example, assume you have two partitions on your hard disk (a primary partition assigned the drive letter C: 
and a logical partition assigned D:) and a CD-ROM drive assigned E:. Suppose you create a logical partition 
between C: and D:. The drive letter of D: changes to E:, and the drive letter of E: changes to F:; however, 
references in certain files continue to reflect the old drive letter assignments. Using DriveMapper, you must first 
change the drive E: references to F: and then change the drive D: references to E:.
When you make a change to your hard disk that adds drive letters, always change the highest affected drive 
letter first (drive E: in the previous example). Likewise, when you make a change to your hard disk that 
decreases the number of drive letters, always change the lowest affected drive letter first. Changing them in a 
different order changes source references needed to modify other drive mappings.
{button ,JI(`',`H_To_change_drive_letter_references')} To change drive letter references 



To change drive letter references
1 From the PartitionMagic main window, click Tools > DriveMapper.
2 Follow the on-screen instructions in the wizard to change one or more drive letter references.

When you are finished with the wizard, you may need to reboot your computer for all the changes to take 
effect.

Tips
· In step 1, you can also start DriveMapper from the Windows taskbar by clicking Start > Programs > 

PowerQuest PartitionMagic 8.0 > PartitionMagic 8.0 Tools > DriveMapper.
DriveMapper also runs automatically if the following conditions are all met:
· You apply changes to your system that affect drive letter assignments
· You are running Windows 95 or Windows 98
· Your hard disk contains only FAT or FAT32 partitions
· You have no more than one CD drive and no more than one removable drive.



About BootMagic Configuration
BootMagic is a PowerQuest application included with PartitionMagic that helps you run multiple operating 
systems on a single computer. Each time you start or restart your computer, BootMagic presents a list of 
available operating systems from which you can select the operating system you want to boot.
BootMagic has a configuration window you can access from PartitionMagic that lets you select and arrange the 
operating systems you want to appear as boot-up choices.
For more information about installing BootMagic and changing your BootMagic configuration, refer to 
BootMagic's online help or see the PartitionMagic User Guide.



About Create Rescue Disk
Use Create Rescue Disk to create disks you can use to boot your computer and run PartitionMagic for DOS 
(PQMAGIC). The rescue disks are useful when you have:
· Hidden the partition where PartitionMagic is installed and need to run PartitionMagic to unhide the partition.
· Accidentally converted a partition to FAT32 or NTFS and your operating system does not support that file 

system, so your computer will not boot. (You can use the rescue disks to convert the partition back to FAT.)
· Other occasions arise when you do not have access to PartitionMagic on the CD or hard drive.
The rescue disks contain the following files:

Disk 1 Disk 2
·

AUTOEXEC2.B
AT

·

AUTOEXEC.BA
T

·

COMMAND.CO
M

· EGA.CPI
· KEYB.COM
· MODE.COM
· MSCDEX.EXE
· PARTINFO.EXE 

(utility 
program)

· PTEDIT.EXE 
(utility 
program)

· Miscellaneous 
system (.SYS) 
files

· CHKDSK.EXE

·

AUTOEXEC.BA
T

·

COMMAND.CO
M

· MOUSE.COM
· PMHELP.DAT 

(help file)
· PQMAGIC.EXE
· PQMAGIC.OVL
· PQMAGIC.PQG
· PQPB.RTC
· RESCUE.TXT
· ZABOUT.PQG

If you create rescue disks for a double-byte language, you will need a third disk for the fonts.

{button ,JI(`',`H_To_create_rescue_disks')} To create rescue disks 
{button ,JI(`',`H_To_run_PartitionMagic_from_rescue_disk')} To run PartitionMagic from rescue disks 



To create rescue disks
1 Be sure you have two blank 1.44 MB floppy disks before you continue (three disks for double-byte languages).

To create
rescue 
disks 
from:

Do this:

PartitionM
agic main 
window

Click Tools > 
Create Rescue 
Disks.

Microsoft 
Windows

Click Start > 
Programs > 
PowerQuest 
PartitionMagic 
8.0 > 
PartitionMagic 
8.0 Tools > 
Create Rescue 
Diskettes.

DOS Run 
MAKEDISK.BAT 
from the \
<language>\
DOS-OS2 folder 
on the 
PartitionMagic CD
by typing 
MAKEDISK A: 
where A: is the 
drive letter for 
your floppy disk 
drive.
You can also 
install the DOS 
version of 
PartitionMagic to 
your hard disk 
using this 
process. If you 
install to your 
hard disk, the 
PartitionMagic 
files (but not the 
system files) will 
be installed to a 
PQMAGIC 
directory at the 
root of the disk, 
and you will not 
need floppy 
disks.

2 Insert a blank, formatted 1.44 MB disk into your 3.5-inch disk drive, then click OK.
3 Follow the on-screen instructions to create the disk.





To run PartitionMagic from rescue disk
When you boot your computer from the first rescue disk, PQMAGIC automatically runs. You must insert the 
second rescue disk when prompted.

Preparation
Before you run PartitionMagic from the rescue disks, you should:
· Turn off third-party disk caches.
· Deactivate/unload any TSR programs that access or modify partitions being changed.
You cannot run PartitionMagic on a Windows 2000 Professional, Windows XP Professional, or Windows Me 
machine that is in hibernation. To use the rescue disk or PartitionMagic for Windows, Windows 2000, Windows 
XP, or Windows Me must have been shut down normally.

Rescue Disk Limitations
The following features are unavailable when you run PartitionMagic from the rescue disks.
· Split partitions
· Secure erase of partitions
· Undo last change
· Wizards
If you run out of space on the first rescue disk as a result of adding network, SCSI, or CD-ROM drivers to your 
boot sequence, you can delete the following files from the disk: chkdsk.com, fdisk.exe, ptedit.exe, and 
partinfo.exe. We recommend that you delete the files in that order, freeing up only the space that you need to 
accommodate additional files. These files are included in the Utilities folder on the PartitionMagic CD where 
you can access them later, if necessary.
If you use an international keyboard or character set, you will need to modify the AUTOEXE2.BAT and 
CONFIG.SYS files on the rescue disks. See Using International Keyboards for additional information.
Checking an NTFS partition with the rescue disk version of PartitionMagic may take an unusually long time. 
Because PartitionMagic performs checks both before and after the move, copy, and resize operations, these 
operations may be slower with the rescue disk version of PartitionMagic than with the Windows version.



About Tasks
Use Tasks to guide you step by step through some common partitioning tasks. PartitionMagic includes the 
following wizards.

Create New Partition
Helps you create a new primary partition or a logical partition within an extended partition. On a single hard 
disk, you can have up to four primary partitions, or three primary partitions and one extended partition. Within
an extended partition, you can create unlimited additional subdivisions called logical partitions.

Create Backup Partition
Helps you create a location where you will back up your data files. You can then install DataKeeper to back up 
your data on a regular basis.

Install Another Operating System
Helps you install additional operating systems on your computer. You can install any Windows OS or Linux. The
new OS is installed to a partition created by this wizard, created in a location you specify. You can then use a 
boot manager (such as BootMagic) to boot to either operating system when you turn on your computer.

Resize Partitions
Helps you resize a partition and lets you specify how the resize will affect other partitions on the same disk.

Redistribute Free Space
Helps you redistribute free space among the partitions on a hard disk. Free space includes both unused space 
within partitions and space that has not been allocated to any partition.

Merge Partitions
Helps you merge two adjacent FAT or FAT32 partitions. You choose two partitions and the first will be expanded
to include the second. The contents of the second partition are added as a folder inside the first partition.

Copy Partition
Helps you make an exact duplicate of a partition. The copy is the same size (or slightly different if copied to 
another physical disk with a different geometry) and file type and contains the same data as the original. 
When you copy a partition, you specify the hard disk and the unallocated space where you want to place the 
copy.

{button ,JI(`',`H_To_use_a_wizard')} To use a task 



To use a task
1 Click Tasks, then select the task you want to use.
2 Follow the instructions in the dialog boxes to complete the wizard.

Tips
· At any time during the wizard, you can click Cancel to return to the main PartitionMagic window.
· After you complete a wizard, be sure you click Apply changes in the lower right corner of the PartitionMagic 

main window to apply the changes to your hard disk. Or, if you prefer to discard all virtual changes made by 
the wizard, click General > Discard All Changes or Undo Last.



About Help
When you are in PartitionMagic you can get help by clicking the Help button (or Tips button) in a dialog box or 
accessing Contents from the Help pull-down menu. You can look up keywords in the Help Index, or Find text in 
Help topics. 

Additional Resources 
The following additional resources contain information on installing, configuring, and using PartitionMagic.
· PartitionMagic Quick Start Guide - Your quick start guide provides in-depth explanations of the installation 

process, and gives a brief overview of PartitionMagic key tasks and best practices.
· PartitionMagic User Guide - Your user guide provides in-depth explanations of the PartitionMagic tools and 

features. The guide also provides step-by-step instructions on performing specific tasks.
· README.TXT File - PartitionMagic's README.TXT is an invaluable resource for the most current information 

at the time the product shipped. It includes information that may have changed since the user guide was 
printed, corrections to the user guide or online Help system, and information specific to installation or 
configuration issues.

· PowerQuest Web Site - PowerQuest's corporate web site located at www.powerquest.com contains a wide 
array of information, including technical white papers, frequently-asked questions, support information, and 
news about product updates.

{button ,JI(`',`H_To_find_Help_topics')} To find Help topics 



To find Help topics
1 Click Help > Contents.
2 Click the Contents tab for help with a task (How Do I...?), help with a feature or understanding hard drives, 

and other partitioning information.
3 Click the Index tab to look up information in an alphabetical list.
4 Click the Search tab or Find button to search for one or more words in the text of all Help topics.
5 Click Glossary in the Contents tab to look up the definition of a word.

Tips
· When you search with Find, all topics containing the word you type are listed. Type a second or third word to 

narrow the search.
· To print a displayed Help topic, click Print on the Help toolbar.
· To keep the Help window displayed on top of PartitionMagic, click Options > Keep Help on Top > On Top on 

the Help toolbar.



What is a Hard Disk?
A hard disk or drive is the part of your computer responsible for long-term storage of information. Unlike volatile 
memory (often referred to as RAM) which loses its stored information once its power supply is shut off, a hard 
disk stores information permanently, allowing you to save programs, files, and other data. Hard disks also have 
much greater storage capacities than RAM; in fact, current hard disks may contain over 20 GB of storage space. 

Basic Components of a Hard Disk 
A hard disk is comprised of four basic parts: platters, a spindle, read/write heads, and integrated electronics. 

 
· Platters are rigid disks made of metal or plastic. Both sides of each platter are covered with a thin layer of 

iron oxide or other magnetizable material. 
· The platters are mounted on a central axle or spindle, which rotates all the platters at the same speed. 
· Read/write heads are mounted on arms that extend over both top and bottom surfaces of each disk. There is

at least one read/write head for each side of each platter. The arms jointly move back and forth between the 
platters' centers and outside edges; this movement, along with the platters' rotation, allows the read/write 
heads to access all areas of the platters.

· The integrated electronics translate commands from the computer and move the read/write heads to 
specific areas of the platters, thus reading and/or writing the needed data.

How Is Data Stored and Retrieved?
Computers record data on hard disks as a series of binary bits. Each bit is stored as a magnetic charge (positive 
or negative) on the oxide coating of a disk platter. 
When a computer saves data, it sends the data to the hard disk as a series of bits. As the disk receives the bits, 
it uses the read/write heads to magnetically record or "write" the bits on the platters. Data bits are not 
necessarily stored in succession; for example, the data in one file may be written to several different areas on 
different platters.
When the computer requests data stored on the disk, the platters rotate and the read/write heads move back 
and forth to the specified data area(s). The read/write heads read the data by determining the magnetic field of 
each bit, positive or negative, and then relay that information back to the computer.
The read/write heads can access any area of the platters at any time, allowing data to be accessed randomly 
(rather than sequentially, as with a magnetic tape). Because hard disks are capable of random access, they can 
typically access any data within a few millionths of a second.



What is Disk Formatting?
Computers must be able to access needed information on command; however, even the smallest hard disk can 
store millions and millions of bits. How does the computer know where to look for the information it needs? To 
solve this problem, hard disks are organized into discrete, identifiable divisions, thus allowing the computer to 
easily find any particular sequence of bits. 
The most basic form of disk organization is called formatting. Formatting prepares the hard disk so that files can 
be written to the platters and then quickly retrieved when needed. Hard disks must be formatted in two ways: 
physically and logically.
{button ,JI(`',`H_Physical_Disk_Formatting')}       Physical Disk Formatting 
{button ,JI(`',`H_Logical_Disk_Formatting')}       Logical Disk Formatting 

Physical Disk Formatting
A hard disk must be physically formatted before it can be logically formatted. A hard disk's physical formatting
(also called low-level formatting) is usually performed by the manufacturer.
Physical formatting (pictured below) divides the hard disk's platters into their basic physical elements: tracks, 
sectors, and cylinders. These elements define the way in which data is physically recorded on and read from 
the disk.

 

· Tracks are concentric circular paths written on each side of a platter, like those on a record or compact disc. 
The tracks are identified by number, starting with track zero at the outer edge.

· Tracks are divided into smaller areas or sectors, which are used to store a fixed amount of data. Sectors are 
usually formatted to contain 512 bytes of data (there are 8 bits in a byte).

· A cylinder is comprised of a set of tracks that lie at the same distance from the spindle on all sides of all the 
platters. For example, track three on every side of every platter is located at the same distance from the 
spindle. If you imagine these tracks vertically connected, the set forms the shape of a cylinder.
Computer hardware and software frequently work using cylinders. When data is written to a disk in cylinders, it
can be fully accessed without having to move the read/write heads. Because head movement is slow 
compared to disk rotation and switching between heads, cylinders greatly reduce data access time. 
After a hard disk is physically formatted, the magnetic properties of the platter coating may gradually 
deteriorate. Consequently, it becomes more and more difficult for the read/write heads to read data from or 
write data to the affected platter sectors. The sectors that can no longer be used to hold data are called bad 



sectors.    Fortunately, the quality of modern disks is such that bad sectors are rare. Furthermore, most 
modern computers can determine when a sector is bad; if this happens, the computer simply marks the sector
as bad (so it will never be used) and then uses an alternate sector.

Logical Disk Formatting
After a hard disk has been physically formatted, it must also be logically formatted. Logical formatting places a
file system on the disk, allowing an operating system (such as DOS, Windows, or Linux) to use the available 
disk space to store and retrieve files. Different operating systems (OS) use different file systems, so the type of
logical formatting you apply depends on the OS you plan to install.
Formatting your entire hard disk with one file system necessarily limits the number and types of operating 
systems you can install on the disk. Luckily, there is a solution to this problem. Before a disk is logically 
formatted, it can be divided into partitions. Each partition can then be formatted with a different file system, 
allowing you to install multiple operating systems. Dividing your hard disk into partitions also allows you to use
disk space more efficiently.



Understanding File Systems
All file systems consist of structures necessary for storing and managing data. These structures typically include 
an operating system boot record, directories, and files. A file system also performs three main functions: 1) 
tracking allocated and unused space, 2) maintaining directories and filenames, and 3) tracking where each file is
physically stored on the disk.
Different file systems are used by different operating systems. Some operating systems can recognize only one 
file system, while others can recognize several. Some of the most common file systems are:
{button ,JI(`',`H_FAT')} FAT (File Allocation Table) 
{button ,JI(`',`H_FAT32')} FAT 32 (File Allocation Table 32) 
{button ,JI(`',`H_NTFS')} NTFS (New Technology File System) 
{button ,JI(`',`H_Linux')} Linux Ext2 and Linux Swap 

FAT (File Allocation Table)
The FAT file system is used by DOS, Windows 3.x, and Windows 95 (in most installations). The FAT file system 
can also be used by Windows 98/Me/NT/2000/XP.
The FAT file system is characterized by the use of a file allocation table (FAT) and clusters. The FAT is the heart 
of the file system; for safety, the FAT is duplicated to protect its data from accidental deletion or corruption. 
Clusters are the FAT system's smallest unit of data storage; one cluster consists of a fixed number of disk 
sectors. The FAT records which clusters are used, which are unused, and where files are located within the 
clusters.
The FAT file system supports disk or partition sizes up to 2 GB, but only allows a maximum of 65,525 clusters. 
Therefore, whatever the size of the hard disk or partition, the number of sectors in one cluster must be large 
enough so that all available space can be included within 65,525 clusters. The larger the available space, the 
larger the cluster size must be. 
In general, large clusters tend to waste more space than small clusters. For more information on managing 
cluster size, click See Also on the Help toolbar.
The FAT file system also uses a root directory. This directory has a maximum allowable number of entries and 
must be located at a specific place on the disk or partition. Operating systems that use the FAT file system 
represent the root directory with the backward slash character (\), and initially display this directory at boot-
up.
The root directory stores information about each sub-directory and file in the form of individual directory 
entries. For example, a file's directory entry holds information such as the filename, the size of the file, a date 
and time stamp that indicates when the file was last changed, the starting cluster number (which cluster holds
the first portion of the file), and the file's attributes (for example, hidden, system, and so forth).
You can use PartitionMagic's Resize Root option to change the size (number of root entries) available in a FAT 
root directory, within predefined limits.
All PartitionMagic features can be used on FAT disks or partitions.

FAT 32 (File Allocation Table 32)
FAT32 is a file system that can be used by Windows 95 OEM Service Release 2 (version 4.00.950B), Windows 
98/2000/XP. However, DOS, Windows 3.x, Windows NT 3.51/4.0, and earlier versions of Windows 95 cannot 
recognize FAT32, and are thus unable to boot from or use files on a FAT32 disk or partition.
FAT32 is an enhancement of the FAT file system and is based on 32-bit file allocation table entries, rather than 
the 16-bit entries used by the FAT system. As a result, FAT32 supports much larger disk or partition sizes (up to
2 terabytes).
The FAT32 file system uses smaller clusters than the FAT file system, has duplicate boot records, and features 
a root directory that can be any size and can be located anywhere on the disk or partition.
On a FAT32 disk or partition, you can use all PartitionMagic features except Resize Root, which is unnecessary 
for FAT32.



NTFS (New Technology File System)
The New Technology File System (NTFS) is accessible by Windows NT/2000/XP. NTFS is not recommended for 
use on disks less than 400 MB because it uses a great deal of space for system structures.
The central system structure of the NTFS file system is the master file table (MFT). NTFS keeps multiple copies 
of the critical portion of the MFT to protect against corruption and data loss. 
Like FAT and FAT32, NTFS uses clusters to store data files; however, the size of the clusters is not dependent 
on the size of the disk or partition. A cluster size as small as 512 bytes can be specified, regardless of whether 
a partition is 500 MB or 5 GB. Using small clusters not only reduces the amount of wasted disk space, but also 
reduces file fragmentation, a condition where files are broken up over many noncontiguous clusters, resulting 
in slower file access. Because of its ability to use small clusters, NTFS provides good performance on large 
drives.
Finally, the NTFS file system supports hot fixing, a process through which bad sectors are automatically 
detected and marked so that they will not be used.
All PartitionMagic features can be used with NTFS, except those features that are specific to the FAT and FAT32 
file systems.

Linux Ext2, Ext3, and Linux Swap
The Linux Ext2 and Linux Swap file systems were developed for the Linux OS (a freeware version of UNIX). The
Linux Ext2 file system supports a maximum disk or partition size of 4 terabytes. Linux Swap is used for the 
Linux swap file. The Ext3 file system is a journaling extension to the Ext2 file system. Journaling dramatically 
reduces time spent recovering a file system after a crash, thus allowing faster recovery times on single 
machines and recovery of a machine's file system on another machine when a cluster of nodes share a disk.
All PartitionMagic features can be used with Linux Ext2, Ext3, and Linux Swap, except those features that are 
specific to the FAT and FAT32 file systems.



Understanding Partitions
After a disk has been physically formatted, it can be divided into separate physical sections or partitions. Each 
partition functions as an individual unit, and can be logically formatted with any desired file system. Once a disk 
partition has been logically formatted, it is referred to as a volume. 
As part of the formatting operation, you are asked to give the partition a name, called the "volume label." This 
name helps you easily identify the volume.

Why Use Multiple Partitions?
Many hard disks are formatted as one large partition. This setup, however, does not always provide the best 
possible use of your disk space or resources. The alternative is to separate your hard disk into partitions. Using 
multiple partitions, you can:
· install more than one OS (operating system) on your hard disk;
· make the most efficient use of your available disk space;
· make your files as secure as possible;
· physically separate data so that it is easy to find files and back up data. 
The following information discuss partitions in greater detail, helping you create and use partitions to get the 
most out of your hard disk.

Types of Partitions
There are three types of partitions:
{button ,JI(`',`H_Primary_Partitions')}       Primary Partitions 
{button ,JI(`',`H_Extended_Partitions')}       Extended Partitions 
{button ,JI(`',`H_Logical_Partitions')}       Logical Partitions 
Primary and extended partitions are the main disk divisions; one hard disk may contain up to four primary 
partitions, or three primary partitions and one extended partition. The extended partition can then be further 
divided into any number of logical partitions.
The illustration below shows a hard disk that contains four main partitions: three primary partitions and one 
extended partition. The extended partition has been further divided into two logical partitions. Each primary 
partition has been formatted to use a different file system (FAT and NTFS). The two logical partitions have both 
been formatted to use the FAT file system. 

 

Although the illustration shows all partitions on a single side of one platter, in actual use the partitions would 
probably be spread across the sides of several platters.



Primary Partitions
A primary partition may contain an operating system along with any number of data files (for example, 
program files, user files, and so forth). Before an OS is installed, the primary partition must be logically 
formatted with a file system compatible to the OS.
If you have multiple primary partitions on your hard disk, only one primary partition may be visible and active 
at a time. The active partition is the partition from which an OS is booted at computer startup. Primary 
partitions other than the active partition are hidden, preventing their data from being accessed. Thus, the data
in a primary partition can be accessed (for all practical purposes) only by the OS installed on that partition.
If you plan to install more than one operating system on your hard disk, you probably need to create multiple 
primary partitions; most operating systems can be booted only from a primary partition.

Extended Partitions
The extended partition was invented as a way of getting around the arbitrary four-partition limit. An extended 
partition is essentially a container in which you can further physically divide your disk space by creating an 
unlimited number of logical partitions.
An extended partition does not directly hold data. You must create logical partitions within the extended 
partition in order to store data. Once created, logical partitions must be logically formatted, but each can use a
different file system.

Logical Partitions
Logical partitions may exist only within an extended partition and are meant to contain only data files and 
operating systems that can be booted from a logical partition (for example, Linux, Windows NT, and so forth).



Understanding How a Computer Boots
The way a computer boots from a hard disk depends on the way the hard disk is partitioned and on the operating
system being booted.

The Basic Boot Process 
When you turn on the power to your computer, the central processing unit (CPU) takes control. The CPU 
immediately executes the instructions built into the computer's ROM BIOS, a program that contains the startup
procedures. The last part of the BIOS instructions contains the boot routine. This routine is programmed to 
read the master boot record (MBR) from the first sector of the first physical hard disk.

 

The MBR contains a master boot program and a partition table that describes all of the hard disk's partitions. 
The BIOS boot routine executes the master boot program, which then continues the boot process. The master 
boot program looks at the partition table to see which primary partition is active. If there is only one primary 
partition, that partition's OS is loaded and booted into operation.
If the hard disk has more than one primary partition, each bootable partition has its own boot record stored in 
its first sector. This boot record holds a boot program designed specifically to start that partition's installed OS.
This OS-specific boot record is usually written to the partition when the partition is logically formatted, but can 
also be added later with an OS-specific utility (for example, the DOS SYS utility, and so on).
After identifying the active partition, the master boot program starts that partition's boot program. In turn, the 
boot program loads the necessary OS files and starts the OS.

Operating System-Specific Boot Information
Most operating systems, including DOS, Windows 3.x, Windows 95/98, and Windows NT, rely on the active 
primary partition when they boot from a hard disk. However, different operating systems rely on the active 
primary partition in different ways.
· DOS, Windows 3.x, and Windows 95/98 must boot from an active primary partition on the first hard disk 

drive. 
· Windows NT can boot from a logical partition, but the Windows NT boot program must be in the active 

primary partition on the first hard disk.



Managing Your Partitions
The following concepts and activities can help you manage your disk partitions.

Setting an Active Primary (Boot) Partition
When you create multiple primary partitions to hold different operating systems, you must tell the computer 
which primary partition to boot from. The primary partition from which the computer boots is called the active 
partition. If there is not an active primary partition on the first physical hard disk, your computer will not be 
able to boot from your hard disk. 
Before you make a primary partition active, make sure that it is a bootable partition. Bootable partitions are 
logically formatted and have the necessary OS files installed. Partitions without an OS cannot be booted.
PartitionMagic's Set Active feature (Partition > Advanced > Set Active) lets you easily choose which 
primary partition you want to be the active partition.

Making Good Use of Logical Partitions 
By creating an extended partition and then dividing it into logical partitions, you can:
{button ,JI(`',`H_Accessing_the_Same_Files_from_Multiple_Operating_Systems')} Access the Same Files from 
Multiple Operating Systems 
{button ,JI(`',`H_Making_Efficient_Use_of_Disk_Space')} Make Efficient Use of Disk Space 
{button ,JI(`',`H_Simplify_File_Access_and_Enhance_File_Security')} Simplify File Access and Enhance File 
Security 

Accessing the Same Files from Multiple Operating Systems
Multiple logical partitions do not need to be hidden like primary partitions. You can have many logical 
partitions visible at the same time. Therefore, you can access data stored in a logical partition from multiple 
operating systems installed in different primary or logical partitions, provided that the logical partition uses a 
file system that the operating systems recognize.
For example, refer to the partitioned hard disk graphic shown below. Because DOS/Windows, and Windows NT 
all recognize FAT partitions, any of those three primary partitions could be active and still be able to recognize 
and use the files saved within either of the logical partitions.

 

Making Efficient Use of Disk Space
If you have a large hard disk and want to use the FAT file system on all or most of the disk, you can prevent 
wasted space by using several small FAT partitions.



All data on a FAT partition are stored in allocation units called clusters. Each cluster is made up of a fixed 
number of disk sectors.
The FAT file system supports disk or partition sizes up to 2 GB, but only allows a maximum of 65,525 clusters. 
Therefore, whatever the size of the hard disk or partition, the number of sectors in one cluster must be large 
enough so that all available space can be included within 65,525 clusters. The larger the available space, the 
larger the cluster size must be. 
However, using a large cluster size wastes disk space. Even if a data file (or the last portion of a data file) is 
much smaller than the cluster size, the computer must still use a complete cluster to store the data. The rest 
of the cluster space goes unused.
The following table shows the minimum cluster size and typical wasted space for various partition sizes.

Partition 
Sizes

Minimum 
Required 
Cluster Size

% Wasted 
Space 
(approx.)

16-127 MB 2 KB 2%
128-255 MB 4 KB 4%
256-511 MB 8 KB 10%
512-1,023 
MB

16 KB 25%

1,024-2,047 
MB

32 KB 40%

2,048-4,096 
MB

64 KB 50%

You can prevent wasted disk space by using smaller partitions, because smaller partitions use smaller cluster 
sizes. For example, a 1,024 MB partition has a cluster size of 32 KB. If you saved a 2 KB file to this partition, an
entire 32 KB cluster would be used to save the file, wasting 30 KB of space. However, if you divide your 
storage space into 120 MB partitions, these partitions would only use 2 KB clusters. When you save the same 
2 KB file, the file would fit neatly into a 2 KB cluster, with no wasted space.

Tips
· 64 KB clusters are only available in Windows NT. Other operating systems cannot use 64 KB clusters, no 

matter how large the partition.
· If you have large FAT partitions, either primary or logical, you can probably recover wasted storage space by 

resizing them with the PartitionMagic Resize Cluster option. Any recovered space can then be divided into 
other small partitions.

Simplifying File Access and Enhancing File Security
If you have a large hard disk, placing all your files and subdirectories under one root directory quickly results in
a large and complex directory structure. The larger and more complex the root directory, the harder it is for 
you to keep track of your files. Organization becomes difficult, forcing you to sort through numerous directories
and subdirectories just to find the files you want. 
Smart use of logical partitions can help you avoid this problem. Simply separate your files into groups, storing 
each group in an individual logical partition. When you need a particular group of files, you can easily switch to
the corresponding logical partition. The complexity of your directory structure is minimized, allowing you to 
access desired files much more quickly.
You can also use additional partitions to enhance security for sensitive files. For example, if you want to limit 
access to a particular group of files, you can store those files on a logical partition and then hide that partition 
from access.
If you use multiple operating systems, you could also format a logical data partition with the file system of the 



OS that provides the best security features. The OS could then be used to limit access to the data partition.
Logical partitions can also be used to store additional copies of critical files. For example, if you put copies of 
your critical files on a FAT logical partition, this partition could be accessed by any of your operating systems 
that recognize FAT. If one OS crashed or became corrupted, you could boot another OS and still have access to 
the critical files.



Freeing Disk Space Before Enlarging a FAT Partition
If you want to make a FAT partition larger using the PartitionMagic Resize option, you must first understand that 
the resulting partition may require a larger cluster size. In general, larger cluster sizes cause a greater 
percentage of wasted space in the partition.
When resizing a partition, PartitionMagic must allocate space for any increase in the required cluster size. 
Therefore, there must be unused space available inside the partition. If the partition is almost full, there may not 
be enough space to allow you to resize the partition. If this is the case, you can create free space by either 
deleting files from the partition or by moving files to a different partition.
The following table approximates the amount of free space necessary to resize a partition within the listed size 
ranges. The actual amount of free space needed may vary, depending on the number and sizes of the files in the
partition.

Partition Size        
(within this range)

Required
Cluster Size

% Wasted
Space

Free Space
Needed for

Resize
128 MB to 255 MB  4 KB 4% 5.1 MB
256 MB to 511 MB  8 KB 10%  25.6 MB
512 MB to 1,023 MB 16 KB 25% 128.0 MB
1,024 MB to 2,047 MB 32 KB 40% 409.6 MB
2,048 MB to 4,096 MB 64 KB 50% 1024.0 MB



Understanding Hidden Partitions
PartitionMagic allows you to hide a partition from OS detection. When you hide a partition, that partition is not 
assigned a drive letter during OS boot up. Therefore, the partition is invisible to the OS and all connected 
applications. Subsequent partitions that are still visible to the OS are assigned a new drive letter.
Hiding a partition is useful when you need to protect sensitive data from other users or you want to prevent 
others from inadvertently deleting critical files. You can hide any primary or logical FAT, FAT32, or NTFS partition.
Of course, PartitionMagic also allows you to unhide any partitions that you have hidden. Making a partition 
visible allows the booted OS to detect the partition, and therefore assign it a drive letter. Once a partition is 
unhidden, subsequent partitions are again assigned a new drive letter.

Tips
· Operating systems can only detect partitions that recognize the partition's file system. Unhiding a partition 

with an unrecognized file type will not make the partition visible to the OS.
· You must be careful when unhiding primary partitions. In general, you should not make two primary partitions 

on the same physical hard disk visible at the same time, as this can cause data loss in some operating 
systems.



Understanding Drive Letters
The OS that you boot assigns drive letters to the primary and logical partitions on each hard disk. These drive 
letters are used by you, your system, and all your applications to reference files on the partition.
Your OS may change the drive letter assignments if you add or remove a second hard disk. Drive letter 
assignments may also be altered if you add, remove, or copy a disk partition; reformat a partition with a different
file system; or boot a different OS. These kinds of drive letter changes can sometimes invalidate parts of your 
system configuration. For example, applications that are programmed to look for startup files on a specific drive 
may no longer launch.
To avoid configuration changes and/or fix configuration problems, you need to understand the following:
{button ,JI(`',`H_How_an_OS_Assigns_Drive_Letters')}       How an OS Assigns Drive Letters 
{button ,JI(`',`H_Drive_Letter_Change_Scenarios')}       Drive Letter Change Scenarios 
{button ,JI(`',`H_Problems_Caused_by_Drive_Letter_Changes')}       Problems Caused by Drive Letter Changes 
{button ,JI(`',`H_Partitioning_to_Avoid_Drive_Letter_Changes')}       Partitioning to Avoid Drive Letter Changes 
{button ,JI(`',`H_Fixing_Configuration_Problems_Caused_by_Drive_Letter_Changes')}       Fixing Configuration 
Problems Caused by Drive Letter Changes 

How an OS Assigns Drive Letters

DOS, Windows 3.x, and Windows 95/98
These operating systems assign drive letters in a fixed sequence that cannot be changed. This sequence is as 
follows:

1 The OS begins by assigning a drive letter to the first primary partition that it recognizes on the first system 
hard disk. The OS then assigns drive letters to the first primary partition recognized on each successive hard 
disk. For example, imagine you have three hard disks in your system. When you boot your OS, it assigns drive 
letter C: to the active primary partition on the first hard disk. Drive letter D: is assigned to the first primary 
partition that the OS recognizes on the second hard disk, and drive letter E: is likewise assigned to the first 
primary partition on the third disk.
If you have multiple visible primary partitions on a single hard disk, the OS assigns the drive letter to the 
active partition. If none of the partitions are active, the drive letter is assigned to the first visible primary 
partition recognized by the OS.
WARNING!    Making multiple primary partitions visible on the same drive can cause data loss in DOS, 
Windows 3.x, and Windows 95/98/Me.

2 Next, all logical partitions recognized by the OS are assigned drive letters, starting with the logical partition(s) 
on the first hard disk and proceeding in order. For example, suppose you have two hard disks in your system, 
each with one primary and two logical partitions. The OS first assigns C: and D: to the two primary partitions, 
then assigns drive letters E: and F: to the first and second logical partitions on the first hard disk. Drive letters 
G: and H: are assigned to the two logical partitions on the second disk. 

3 The OS then assigns drive letters to any remaining visible primary partitions, starting with those on the first 
hard disk. The OS proceeds to any visible primary partitions on the second disk, then the third disk, and so on.

4 Finally, CD-ROM drives and other types of removable media are assigned a drive letter.
Because the OS always follows this sequence to assign drive letters, adding or removing a second hard disk 
can cause changes to your drive letter assignments. Likewise, drive letters can change if you add, remove, or 
copy a disk partition; reformat a partition with a different file system, or boot a different OS.

Windows 2000/XP
For information on how Windows 2000/XP assigns drive letters, please see the Microsoft Knowledge Base on 
the Internet (support.microsoft.com) and go to article ID: Q234048. The article is titled, "How Windows 2000 
Assigns, Reserves, and Stores Drive Letters."

Windows NT



When Windows NT is first installed, it assigns drive letters in the same manner as described above. Once 
assigned, however, these drive letters do not change, regardless of changes to the hard disks or partitions in 
your system. The drive letters are "sticky," so to speak, and remain permanently assigned to the same 
partitions. 
If you want to reassign or remove a drive letter in Windows NT, you can use either PartitionMagic or the 
Windows NT Disk Administrator utility.

Drive Letter Change Scenarios
To illustrate how drive letters are assigned, consider the following scenarios. 

Scenario 1 - A computer has one hard disk, on which Windows 95 is installed. The partitioned disk is shown 
below.

 

The disk is sectioned into a primary partition and an extended partition that contains two logical partitions. 
The primary partition is formatted with the FAT file system and has Windows 95 installed. The first logical 
partition is formatted with the FAT file system, which Windows 95 recognizes, but the second logical partition is
formatted with NTFS, a file system that Windows 95 does not recognize.
On this disk, Windows 95 would assign the drive letter C: to the primary partition and the drive letter D: to the 
first logical partition. It would not assign a drive letter to the second logical partition because it does not 
recognize the file system on that drive.
Scenario 2 - Now consider a computer identical to the first example except that a second hard disk has been 
installed.



 

The first hard disk is partitioned in exactly the same way as in the first example. It has the same file systems 
on the partitions, and Windows 95 is installed on the single primary partition.
The second disk also has one primary partition and an extended partition; however, its extended partition 
contains three logical partitions. There is no OS installed on the primary FAT partition of the second hard disk. 
The first logical partition is an NTFS partition with Windows NT installed. The two remaining logical partitions 
are FAT partitions.
When the computer is booted from Windows 95, the drive letter C: is assigned to the active primary partition 
on the first hard disk. Next, Windows 95 assigns the letter D: to the first recognized primary partition on the 
second hard disk (i.e., the FAT primary partition). Windows 95 then assigns drive letters to each logical 
partition it recognizes. Therefore, it assigns drive letter E: to the first logical FAT partition on the first disk, but 
skips the second logical partition because Windows 95 does not recognize the NTFS file system. On the second
disk, it skips the first logical NTFS partition, assigns drive letter F: to the second logical partition (a FAT 
partition), and assigns drive letter G: to the third logical partition (also a FAT partition).
In this second example, it is important to notice that the drive letter assigned to the first logical partition on 
the first hard disk changed, even though the computer was booted with the same OS as in the first example, 
and the partitioning of the first disk did not change. The drive letter change is the result of a second drive 
being installed in the computer; Windows 95 must assign a drive letter (D:) to the first recognized primary 
partition on that second drive before assigning one to the first logical partition on the first drive.
Scenario 3 - In this final scenario, consider how drive letters are assigned on the same computer, with exactly
the same hard disks and partitions as used in the previous scenario. This time, however, the computer is 
booted with a newly installed version of Windows NT (installed in the first logical partition on the second disk).



 

Because Windows NT recognizes the FAT file system, it assigns the drive letter C: to the primary partition on 
the first hard disk. The letter D: is assigned to the primary partition on the second hard disk, which is also FAT. 
Windows NT then assigns drive letters to each logical partition in order, because all these partitions contain 
file systems that Windows NT recognizes (either FAT or NTFS). On the first disk, Windows NT assigns E: to the 
first logical partition and F: to the second logical partition. Windows NT then assigns G: to the first logical 
partition, H: to the second logical partition, and I: to the last logical partition.
It is important to notice in the above example that the drive letters assigned to the recognized logical 
partitions changed from those assigned in example two, even though the number of hard disks and partitions 
are exactly the same. The only difference is that the computer was booted with a new installation of Windows 
NT, which recognized the file system on all partitions and thus assigned them all letters.
Drive letter changes can occur for other reasons than those illustrated in the above examples. Adding, 
deleting, hiding/unhiding, or reformatting a partition can also cause changes in drive lettering.

Tips
· Once Windows NT is installed, its assigned drive letters do not change, regardless of changes to the hard disks

or partitions in your system. The drive letters are    "sticky," so to speak, and remain permanently assigned to 
the same partitions. See How an OS Assigns Drive Letters above for more information.

Problems Caused by Drive Letter Changes
Changes in your computer's drive letter can disable your application configurations. For example, suppose you 
install several programs to a logical partition with the drive letter D:. You decide to create icons for these 
programs, so you can start them from your Windows 95 OS. Each time you double-click an icon, Windows looks 
on drive D: to find and launch the corresponding program. If the drive letter for the logical partition changes, 
however, your icons will no longer point to the correct partition. When you double-click an icon, Windows 95 
continues to look on drive D: for the program files, even though D: now identifies a different partition.
Changing the drive letter of a partition also affects all system configurations that are based on the original drive 
letter of the partition. For instance, commands based on a drive letter that are entered in your AUTOEXEC.BAT, 



CONFIG.SYS, WIN.INI, SYSTEM.INI, or other system files might be invalidated by drive letter changes. Likewise, 
Windows 95/98 registry entries that include drive letter references may become inoperative if those letters 
change.

Partitioning to Avoid Drive Letter Changes
Using the following partitioning strategies can help you avoid unwanted drive letter changes when using DOS, 
Windows 3.x, and Windows 95/98/Me.

Preventing Changes Caused by Adding Primary Partitions
To avoid drive letter assignment changes caused by adding a primary partition, add primary partitions only to 
hard disks that already have at least one primary partition. The additional primary partitions can be hidden, 
thus keeping only one primary partition visible on each drive. While not always possible, this strategy prevents
changes in partition letter assignments.

Preventing Changes Caused by Adding Logical Partitions
Whenever possible, add a new logical partition as the last logical partition on the last hard disk. By doing so, 
you ensure that the drive letter assignments for all existing partitions remain the same. If the partition must 
be added to a hard disk other than the last, try adding it as the last logical partition on the target disk. The 
drive letter assignments for the logical partitions on that disk remain unchanged, as do the drive letters for 
any previous hard disks; however, all the logical partitions on subsequent disk drives are assigned new drive 
letters.
If there is free space between existing partitions on a hard disk, move all the partitions to the left until all the 
free space is shifted to the right end of the disk. You can then use this space to create a new logical partition 
at the end of the disk. 

Preventing Changes Caused by Booting a Different OS
You can prevent many drive letter changes caused by booting different operating systems. If you have 
partitions formatted with file systems recognized by only one or two of your operating systems, simply place 
them after any partitions with file systems recognized by all your operating systems.
For example, suppose you use both DOS and Windows NT. Some of your partitions are FAT partitions, while 
others are NTFS partitions. Because both DOS and Windows NT recognize FAT partitions, place these partitions 
first on your drive(s). The NTFS partitions can then be positioned at the ends of the drive(s). Now whenever 
you boot up, the drive letters assigned to your FAT partitions remain the same, regardless of whether you boot 
with DOS or Windows NT.
FAT partitions are recognized by the greatest number of operating systems. Therefore, we recommend placing 
all FAT partitions before any FAT32, or NTFS partitions.

Fixing Configuration Problems Caused by Drive Letter Changes
You can fix application configuration problems caused by drive letter changes with PartitionMagic's DriveMapper 
utility. DriveMapper quickly and automatically replaces all invalidated (reassigned) drive letter references with 
the newly assigned partition drive letter. For more information on using DriveMapper, click See Also on the Help 
toolbar.

Tips
· Because Windows NT does not reassign drive letters once they have been assigned, DriveMapper is not 

normally needed with Windows NT.
· After a partition is created or deleted, the OS sometimes fails to assign a drive letter to the CD-ROM drive upon

reboot. If this happens, click See Also on the Help toolbar, then click To make the operating system 
assign a CD-ROM drive letter.



Understanding the BIOS 1024 Cylinder Limit
The BIOS 1024 cylinder limitation exists because the start and end cylinder values in the partition table (and 
some BIOSs) have a maximum value of 1024. Because some operating systems such as DOS 6.22 use the CHS 
(Cylinder, Head, and Sector) values to address sectors on the disk, they cannot access sectors beyond the 1024 
cylinder. When you start your computer the BIOS boots the operating system using the CHS values to locate the 
first sector of the bootable partition. If the partition starts past the 1024 cylinder, the BIOS may not be able to 
boot it because it cannot address a cylinder number higher than 1024.
With PartitionMagic, you can safely partition any drive, regardless of the number of cylinders on the drive. In 
fact, to prevent you from performing partition operations that might cause problems, PartitionMagic is careful to 
observe the BIOS 1,024 cylinder limit on computer systems where one or more of the following applies:
· The hard disk has a capacity 504 MB or more and the BIOS translation mode is set to Normal or CHS.
· The hard disk has a capacity 504 MB or more and the BIOS was manufactured prior to 1994 (approximately).
· The hard disk has a capacity 8 GB or more.
If you have such a computer system and you use only DOS, neither the DOS FDISK utility nor PartitionMagic lets 
you see cylinders beyond the 1,024th cylinder or include them in any partition. Space beyond the 1,024th 
cylinder always remains invisible.
Even if the BIOS 1,024 cylinder limit applies to your system, you can use PartitionMagic without difficulty. The 
only instance where you may encounter a problem is if all the following criteria apply:
· You use DOS and another OS.
· The other OS can "see" and use disk space past the first 1,024 cylinders on the disk.
· You use PartitionMagic or the FDISK utility of the other OS to create a partition extending beyond the 1,024th 

cylinder.
· You then run the DOS PartitionMagic executable.
When you run the DOS PartitionMagic executable, you may or may not be able to see the newly created partition
that extends beyond the 1,024 cylinder limit. Even if you can see the partition, you cannot use the DOS 
PartitionMagic executable to perform any operations on that partition. This restriction applies to both primary 
and extended partitions that contain space beyond the 1,024th cylinder. If an extended partition exceeds the 
cylinder limit, you cannot perform operations on any one of the contained logical partitions, even if the logical 
partition itself does not extend past the 1,024th cylinder.
The disk map in the PartitionMagic main window displays an arrow indicator at the 1024 cylinder boundary (and 
the 2 GB boot boundary), so you can see where your partitions are located relative to the 1024 cylinder limit. Be 
sure that all OS partitions on a disk start prior to cylinder 1024. This ensures that you can boot the OS. Also, use 
caution when moving a bootable partition; if the partition is moved beyond cylinder 1024 it may no longer be 
bootable. To fix this problem you can move the partition below the 1024 cylinder marker.

Tips
· If you use DOS, but your system has the INT 13 BIOS extensions, PartitionMagic lets you see cylinders past the

normal 1,024 limit and perform operations on partitions extending beyond this boundary.



Understanding the 2 GB Boot Code Boundary
An operating system's boot code is stored in both the master boot record (MBR) and the partition boot record, 
enabling the OS to boot properly. In some operating systems, however, this boot code is written is such a way 
that it inadvertently imposes a limit on the location of both the partition boot record and the files needed to boot 
the OS.
DOS (versions 6.x and earlier) and Windows NT (versions 4.0 and earlier) are both affected by this boot code 
limitation. When booting these two operating systems, the cylinder-head-sector (CHS) address of the beginning 
boot code sector must be calculated in order to retrieve the sector's information and load and execute the next 
part of the boot process. The CHS value for the needed sector is calculated as follows:

Sector Number / Sectors Per Track

Because of the way the boot code is written, the product of this calculation must fit in a 16-bit register. The 
largest value a 16-bit register can contain is 64K. If the number is larger than 64K, the number is truncated, 
resulting in an incorrect value that skews the remaining calculations. The boot process fails to load and execute 
the needed sector, thus preventing the OS from booting.
Most current hard disks have 63 sectors per track, creating a 64K boot code boundary at 2 GB. If your disk is 
older and/or uses drive overlay software, this boundary may be lower. 
If a partition begins or extends beyond this boundary, the CHS value of the partition's boot code sector cannot 
be correctly calculated; therefore, the partition and its OS cannot boot.
This same limit applies to the DOS IO.SYS file and the Windows NT file, NTLOADER.EXE. If either of these files are 
installed or moved beyond the 64K boot code boundary, the corresponding OS fails to boot. To boot properly, 
DOS requires that the first three sectors of IO.SYS be below the 2 GB boot code boundary.
Both the IO.SYS and NTLOADER.EXE files are usually located near the beginning of the partition in which they are
installed. When you resize partitions using PartitionMagic, this area of the partition may be vacated to make 
room for a larger FAT or other file system structures. As a result, IO.SYS or NTLOADER.EXE may be moved beyond
the 2 GB boundary, thus preventing the OS from booting.
The disk map in the PartitionMagic main window displays an arrow indicator at the 2 GB boot boundary, so you 
can see where your partitions are located. 



Changing the BIOS LBA Mode Setting
Caution: Never change the LBA mode in your system BIOS once data is present on any hard disk. Changing this 
setting may cause data corruption and loss.
Most modern system BIOS designs support LBA or Logical Block Addressing. The LBA mode setting, whether 
enabled or disabled on your system, determines how your computer translates logical cylinder-head-sector (CHS)
addresses. If you change this setting, the resulting shift in CHS values may corrupt all the files and partitions on 
your hard disk(s).
If you must change the LBA mode setting in your system BIOS, first back up all data on your hard disk(s). 
Contact the BIOS and/or disk manufacturer's technical support departments to ensure you understand how to 
proceed safely.



Restoring System Files
When you use PartitionMagic to create or modify your computer's partitions, PartitionMagic makes the necessary
changes to your system files, allowing your computer to recognize the new or modified partition. Because these 
files are changed, any previous system backups you have made are no longer accurate. Restoring system files 
from a backup created prior to using PartitionMagic may cause problems. 
Whenever you make changes using PartitionMagic, be sure to create new backups for your system files. Never 
use a previous backup to restore the following files: BOOT.DOS, BOOT.OS2, BOOTSECT.DOS, BOOTSECT.W95, or 
BOOTSECT.W98.

Tip
· PartitionMagic only modifies system files. Therefore, previous backups can safely be used to restore user files.



Before You Run PartitionMagic
Before the start of a PartitionMagic session in which you will be applying one or more operations to your system, 
you should always complete the following items:
· Install the most recent Windows 95, 98, Me, NT Workstation, or 2000, XP Professional patches.

Make sure you have all the most recent patches installed when running Windows 95/98/Me/NT 
Workstation/2000/XP Professional.

· Back up your hard disk.
Your data is the most valuable part of your machine. Although it is unlikely that PartitionMagic would damage 
your data, other system failures, such as hardware, software, or power, can put your data at risk if they occur 
during PartitionMagic operations. PowerQuest's Drive Image is useful for creating an image backup of the 
partitions you want to change. You can also use Drive Image to restore the image partitions to their original 
state.

· Create a Windows boot disk.
The boot disk lets you boot Windows if you have problems. For information about creating a boot disk, refer to 
the Microsoft knowledge base article Q119467, "Creating a Boot Disk for an NTFS or FAT partition."

· Run Check for Errors option.
For all partitions that you plan to manipulate, click Partition > Check for Errors. Although PartitionMagic 
checks partitions for errors and can repair minor problems, more serious errors cause PartitionMagic to 
abruptly end an operation. 
Check for Errors can find and fix most common errors. The Check for Errors option is dimmed (unavailable) on 
the Windows boot partition because there are always open files. For this partition, click Partition > MS 
ScanDisk.

· Shut down all applications.
You should not run PartitionMagic with other applications, including virus scanners. If you are running Windows
NT Workstation, make sure no other users are attached to your workstation (in a peer-to-peer network) before 
running PartitionMagic.

· Connect to a UPS (Uninterruptible Power Supply).
PartitionMagic will not be able to recover if a power failure occurs during repartitioning. By having the machine
and all connected hard drives protected by UPSs, you can avoid the problems caused by power failures.

Tips
· Because of conflicts that can result from different hardware and system configurations, do not create an 

application or operating system partition on one computer and then move that hard disk to another computer.
Data loss may occur.



PartitionMagic Interface
The PartitionMagic interface is composed of the action panel, the menu bar, toolbar, disk map, partition list, 
wizard buttons, and the legend. You can display/hide and size different parts of the interface to organize the 
PartitionMagic window just the way you want.

Menu Bar and Toolbar
In the PartitionMagic main window, the menu bar and a toolbar appear at the top of the window. The menu bar 
gives you access to all of PartitionMagic's features, while the toolbar gives you quick access to commonly used 
options. You can display or hide the toolbar. Hiding the toolbar increases the display area of partition information.
The option "Disks" on the menu bar will only appear if you have more than one hard disk to choose from on your 
system.

Menu Bar and Toolbar

Partition Information
The partition information area displays all the partition data for the selected hard disk. It consists of the action 
panel, disk map, and partition list.

Action Panel
The Action Panel lets you choose a task, begin a partition operation, and view the pending operations.

Disk Map 
The disk map shows the partitions graphically and to approximate scale. (You can also scale the disk map 
display by clicking View > Scale Disk Map.) Each partition is represented by a different color according to 
the file system it uses. If the selected hard disk contains logical partitions, the logical partitions are shown 
within an extended partition. The disk map will also show unallocated space (space that is not assigned to any 
partition) as a solid dark gray block (see image below).
If your system has more than one disk, you may need to scroll the disk map to see all available disks.
Drag the bar that separates the disk map from the partition list, up or down to adjust the viewing area.



 

Partition List 
The partition list shows you text information about each partition on your machine such as the drive letter, 
label, file system type, size in megabytes, amount of used and unused space in megabytes, status, and 
whether the partition is primary or logical.

 

Primary partition drive letters are flush left, followed by a colon and the volume name. Logical partition drive 
letters and volume labels are indented. An asterisk (*) appears in place of a drive letter for:
· Hidden partitions
· Extended partitions
· Partitions with file systems not supported by the active operating system
· Unallocated space
A partition's status can be:
· Active: The partition the computer boots from.
· Hidden: Partitions that do not have a drive letter and, therefore, cannot be accessed by the current 

operating system. Partitions can be hidden by the operating system (which may hide all primary partitions 
except the active one), or you can hide partitions yourself using PartitionMagic. Under Windows 2000/XP 
Professional, hidden partitions are permitted to have a drive letter.

· None: Partitions that are not active or hidden.

Legend
The legend is displayed just above the status bar located at the bottom of the PartitionMagic window. You can 
use the legend to help you understand the different colors used in the action panel, disk map, and partition list.
You can display or hide the Legend. Hiding the Legend increases the display area of partition information.



Four Steps to Complete a Task
You complete a task (or operation) two different ways in PartitionMagic. You can use a wizard from the Tasks pull-
down menu to guide you through a task or you can complete a task manually. 
To complete a task manually, you do the following:
1 Select a hard disk or partition.
2 Select an operation.
3 Apply the changes to your system.

Selecting a hard disk and partition
You can select a partition without first selecting a hard disk. To select a partition, click it in the disk map or 
partition list on the main screen.
To select a hard disk, click the title bar on the disk map. There are two operations that can be performed on a 
hard disk: delete all the partitions or display information about the hard disk. When you select a hard disk, its 
partitions display in the partition list in the main window.

Selecting an operation
After you have selected a disk and a partition, you can select an operation using the menu bar, toolbar, the 
Operations panel of the action panel, or the quick menu.
To select an operation, do one of the following:
· From the menu bar, click Partition, then choose an operation. The steps in this Help use the menu bar as the 

preferred method.
· From the toolbar, click the button for the operation.
· From anywhere inside the disk map, or partition list, right-click the partition you want to change, then click the

operation from the context menu.
If an operation cannot be performed on the selected partition, the operation is dimmed (unavailable).
PartitionMagic performs status operations--Info, Check for Errors, and MS ScanDisk--immediately. All other 
operations are stored in a queue in the Operations Pending dialog box until you apply them.

Undoing the last operation
You can undo the last operation that was added to the queue in the Operations Pending dialog box by doing 
one of the following:
· Click General > Undo Last Change.
· Click Undo last to the right of the Wizard buttons in the bottom area of the PartitionMagic window.
· Click View > Operations Pending > Undo Last.
· Click the Undo button on the toolbar.
· Press <Ctrl+Z>.

Discarding all operations
To discard all operations that you have added to the queue in the Operations Pending dialog box, do one of the
following:
· Click General > Discard All Changes.
· Click View > Operations Pending > Discard All.
· Press <Ctrl+D>.

Applying the changes to your system
As you complete tasks using the Operations menu, the disk map, and partition list reflect the changes you have 
made. However, no changes physically take place on your system until you apply them.
You can tell when changes have been made but not yet applied to your system when the Apply option appears in
the main window and the status box in the lower right corner of the main window indicates that operations are 
pending.
To apply changes to your system, do one of the following:



· Click General > Apply Changes.
· Click Apply changes to the right of the Wizard buttons in the bottom area of the PartitionMagic window.
· Click the Apply button on the toolbar.
· Press <Ctrl+A>.
Progress bars that display when you apply changes are an estimation only and can pause for several minutes, 
even though PartitionMagic is still working correctly. If you think your computer has locked up, be patient and 
PartitionMagic will finish the operation.



About PartitionInfo
Use PartitionInfo (available in English only) to create a report of the contents of your hard disk partition table. 
This report can help you diagnose and fix various disk partition problems. You can print the report, or save the 
information to a disk or the clipboard. 
You can run PartitionInfo under Windows 95, Windows 98, Windows 2000, Windows XP, and Windows NT 4.0 
workstations. If you are using DOS or Windows 3.x, you should use PartInfo. The PartInfo program provides 
basically the same information as the PartitionInfo program but without the GUI interface.
Every time you run PartitionMagic on your machine, it creates a "snapshot" file PQ_DEBUG.TXT that includes 
information about the disks and partitions on your machine. The file is saved in the Windows\System folder (for 
Windows 95/98. 2000, XP) or the %system root%\system32 directory (for Windows NT). The PQ_DEBUG.TXT file 
may be beneficial for PowerQuest technical support if you call PowerQuest for help resolving problems with 
PartitionMagic.
For more information about error messages and solutions, visit technical support on the PowerQuest web site 
(available in English only) and search on a particular error code.
{button ,JI(`',`H_To_run_PartitionInfo_for_Windows_95_98_and_NT_4.0')} To run PartitionInfo for Windows 95, 98, 
and NT 4.0 
{button ,JI(`',`H_To_run_PartInfo_for_DOS_or_Windows_3_x')} To run PartInfo for DOS or Windows 3.x 



To run PartitionInfo
1 From the Windows taskbar, click Start > Programs > PowerQuest PartitionMagic 8.0 > PartitionMagic 

8.0 Tools > PartitionInfo.
Disk geometry information includes data from the master boot record and the extended partition boot records 
(EPBR).
Only errors that display in the pane near the top of the screen indicate problems. Do not be concerned with 
Warnings and Infos in the lower two panes.

2 Select the disk whose information you want to view, from the Physical Drive drop-down list.

Tips
· To save the report, click File > Save As, specify the path and filename for the new file, then click Save.

When you save a PartitionInfo report, tabs separate the columns of information. You can open the file in a word
processor and format the report.

· To make changes to your printer setup, click File > Printer Setup. You should set the page orientation to 
landscape to avoid cutting off the right margin.



To run PartInfo for DOS or Windows 3.x
1 Go to a DOS prompt.
2 Insert the second PartitionMagic rescue disk.
3 Type A:\PARTINFO, then press <Enter>.

Tips
· To send a report directly to your printer, in step 3 type PARTINFO >LPT1, then press <Enter>.
· To save the report as a text file (PARTINFO.TXT) in the C:\ directory, type PARTINFO > C:\PARTINFO.TXT, then 

press <Enter>.



PowerQuest Technical Support
PowerQuest offers a variety of technical support solutions. You can choose the level of technical support that 
best fits your needs.
When you encounter a problem, you can often find solutions by consulting the product’s online help, the quick 
start guide, the README file, or PowerQuest’s technical support web site (www.powerquest.com/support) or by 
applying the most recent patch or upgrade of the software (www.powerquest.com/updates).
You must furnish your product license (serial) number when you contact PowerQuest for technical support.
To better assist you in resolving problems, PowerQuest technical support engineers may request information 
from the PARTINFO utility program. See "Generating Diagnostic Reports with PARTINFO" in the product online 
help. 
Technical support for PowerQuest products is available beginning with the release of the product and ending six 
months after the release of the next major version of the product or after PowerQuest discontinues the product 
line.

Complimentary Technical Support
PowerQuest’s complimentary technical support consists of self-help support tools that are available at 
www.powerquest.com/support (in English only).
An easy-to-use, powerful knowledge base that helps you find answers to the most frequently asked product 
questions, as well as "how-to" procedures and technical information about all PowerQuest products. 
Dozens of easy-to-use video clips that step you through product features. 
Product updates and patches for the most recent versions of PowerQuest products.
An automated e-mail form you can fill out to request written assistance from a PowerQuest technician. (Requests
for e-mail support in North America are processed 8:00 am to 5:00 pm MST (GMT -07:00), Monday through 
Friday.) To obtain e-mail technical support for specific technical questions, fill out the form at the web site 
specified below

Lang
uage

Location of E-mail 
Support Form

Engli
sh

http://
www.powerquest.com/
support/emsupport.cfm 

Frenc
h

http://
www.powerquest.com/
support/emsupport.cfm?
language=FR    

Germ
an

http://
www.powerquest.com/
support/emsupport.cfm?
language=DE

Fee-Based Support
PowerQuest’s fee-based technical support program consists of live telephone support during regular business 
hours (8:00 a.m. to 5:00 p.m. MST (GMT -07:00)), Monday through Friday).
Step-by-step consultations on product features and functionality fall under the fee-based support program. 

Lang
uage

Location Number

Engli
sh

UK +44 (0)20 7341 
5517 at $30.00 
USD per incident, 
charged to a credit
card. Your credit 



card will show the 
dollar equivalent 
in your currency.

Engli
sh

USA 800-757-5049 at 
$30.00 USD per 
incident, charged 
to a credit card
900-328-8324 at 
$2.95 USD per 
minute, charged 
to your phone bill 
(first two minutes 
are free)

Frenc
h

France +33 (0)1 69 32 49
30 at $30.00 USD 
or an equivalent 
amount in your 
currency per 
incident, charged 
to a credit card

Germ
an

Germany +49 (0)69 66 568 
516 at $30.00 USD
or an equivalent 
amount in your 
currency per 
incident, charged 
to a credit card

Fee-Based After-Hours Support
PowerQuest offers fee-based after-hours support by telephone only. After-hours support is designed for anyone 
who requires support outside of regular business hours (8:00 a.m. to 5:00 p.m. MST (GMT -07:00)), Monday 
through Friday). The price is $95.00 USD per incident.



About PQBoot
Use PQBoot to easily and quickly switch between bootable primary partitions. PQBoot is for users who only 
occasionally change the active partition and do not want to use BootMagic.
Use PQBoot for Windows to change operating systems while in your current operating system.
PQBoot offers several command-line switches that are useful when you know the ID number or volume label of 
the partition you want to make active. To use a switch, run PQBoot from a DOS prompt. \
1 Go to a DOS prompt.
2 Change to the directory containing PQBOOT (usually C:\Program Files\PowerQuest\PartitionMagic 8.0\DOS).
3 (DOS) Type PQBOOT switch or PQBOOTX switch (where switch is the appropriate command line switch).

(Windows 95 or later) Type PQBOOT32 switch .
Supported switches include:

Switch Description
/A Marks a 

partition 
active 
without 
rebooting.

/M Maintains the
hidden/visibl
e status of 
each 
partition. If 
you have a 
Windows NT 
installation 
that looks for
multiple, 
visible 
primary 
partitions, 
you should 
run PQBoot 
with the /M 
switch.

/
P:<num
ber>

Selects the 
active 
partition 
using the 
partition's ID 
number.

/S Shows 
partition 
information, 
including ID 
numbers and
volume 
names.

/
V:<labe
l>

Selects the 
active 
partition 
using the 
partition's 



volume label.
/? Displays a 

brief 
description of
the switches 
and 
examples of 
how to use 
them.

 For example, to set the second available bootable partition active without rebooting, you would type PQBOOTX
/P:2 /A.

4 Press <Enter>.

Tips
· In step 3, under DOS, you can run either PQBOOT or PQBOOTX.

· Use PQBOOT if you want a small, fast executable that will fit on a floppy disk that has limited free space. Be 
aware, however, that PQBOOT may not display volume labels correctly for FAT or FAT32 partitions and 
volume labels for NTFS partitions will not display at all.

· Use PQBOOTX if the executable file size and speed are not critical. PQBOOTX will display all volume labels in
FAT, FAT32, and NTFS partitions.

{button ,JI(`',`H_To_change_bootable_primary_partitions')} To change bootable primary partitions 



To change bootable primary partitions
1 (Windows 95/98/Me, Windows NT Workstation, or Windows 2000/XP Professional) Click Start > Programs > 

PowerQuest PartitionMagic 8.0 > PartitionMagic 8.0 Tools > PQBoot.
(DOS) Go to a DOS prompt. Change to the directory containing PQBOOT.EXE or PQBOOTX.EXE, type PQBOOT or 
PQBOOTX, then press <Enter>.

2 If you are using Windows, click Yes to continue.
3 Type the ID number of the partition (shown in the first column) you want to make the bootable primary 

partition.
4 Press <Enter>.

PQBoot makes the partition active and reboots the computer. If you need to maintain multiple, visible primary 
partitions under Windows NT, you should run PQBoot with the /M switch.

Tips
· In step 1, under Windows, PQBoot32 will only run if PQVXD.VXD is in the same directory as PQBOOT32.EXE.
· In step 1, under DOS, you can run either PQBOOT or PQBOOTX.

· Use PQBOOT if you want a small, fast executable that will fit on a floppy disk that has limited free space. Be 
aware, however, that PQBOOT may not display volume labels correctly for FAT or FAT32 partitions and 
volume labels for NTFS partitions will not display at all.

· Use PQBOOTX if the executable file size and speed are not critical. PQBOOTX will display all volume labels in
FAT, FAT32, and NTFS partitions.



Freeing Memory to Run PartitionMagic
The DOS PartitionMagic executable running under DOS, Windows 3.x, Windows 95, and Windows 98, requires a 
minimum of 585 KB of memory in the first 640 KB of the computer's address space (conventional memory). If 
you do not have sufficient conventional memory, there are several tasks listed below that you can use to free 
additional memory.
{button ,JI(`',`H_To_run_MEMMAKER')} To run MEMMAKER 
{button ,JI(`',`H_To_use_F8_to_keep_programs_from_loading')} To use F8 to keep programs from loading 
{button ,JI(`',`H_To_create_an_operating_system_boot_disk')} To create an operating system boot disk 
{button ,JI(`',`H_To_delete_operating_system_compression_files')} To delete operating system compression files 



To run MEMMAKER
MEMMAKER is a program that automatically configures your computer to save conventional memory (while still 
loading all of the device drivers and other programs you usually load when booting DOS). MEMMAKER frees 
conventional memory by moving as many programs as possible out of conventional memory into high memory. 
Run MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen instructions.
MEMMAKER is only available in DOS 5.0 to 6.22. It is not available in Windows 95 or Windows 98 DOS mode.



To use F8 to keep programs from loading
You can press <F8> immediately after you boot your computer (while DOS is booting). As DOS reads the each 
command in the CONFIG.SYS and AUTOEXEC.BAT files, it asks if you want the command executed. When you see
commands that load device drivers or TSR programs not needed to run PartitionMagic, press <N> to prevent the
software from loading into memory.



To delete operating system compression files
If you use DOS 6.22, Windows 95, or Windows 98 and your system does not have any compressed drives (using 
programs such as DriveSpace, DoubleSpace, and Stacker), you can delete the operating system compression 
files, DRVSPACE.BIN or DBLSPACE.BIN, from any boot disk you create. This frees conventional memory because 
DOS 6.22, Windows 95, and Windows 98 load these files into memory, regardless of the contents of CONFIG.SYS 
and AUTOEXEC.BAT.
DRVSPACE.BIN and DBLSPACE.BIN are hidden system files that you can delete.
1 Insert your boot disk in your disk drive.
2 Go to a DOS prompt. 
3 Type A:, then press <Enter>. 
4 Type ATTRIB -R -H -S *.BIN, then press <Enter>.
5 Type DEL *.BIN, then press <Enter>.



To make the operating system assign a CD-ROM drive letter
If your computer has a CD-ROM drive or any form of removable media, you should be aware of potential 
problems caused by the way drive letters are assigned to these devices.
If you are using Windows NT, you can change drive letter assignments with PartitionMagic; otherwise, this is a 
function of the operating system. The operating system assigns drive letters in this order: (1) the first recognized
primary partition on each hard disk, (2) all logical partitions on each hard disk, (3) any other primary partitions 
on each hard disk, and (4) the CD-ROM drive and any other forms of removable media. 
Because the CD-ROM is one of the last drives to receive a letter, any partition you create or delete on any of 
your hard disks affects the drive letter assignment of your CD-ROM drive. Occasionally, the operating system 
may not assign a drive letter to the CD-ROM drive. If this occurs, complete the steps outlined below.
If you are using Windows 95/98 and Windows 95/98 drivers for the CD-ROM:
1 From the Windows taskbar, click Start > Settings > Control Panel.
2 Double-click System.
3 Click the Device Manager tab.
4 Double-click CD-ROM. 
5 Double-click the name of your CD-ROM drive.
6 Click the Settings tab. 
7 Type Z in the Start drive letter and End drive letter text boxes.

Because the OS assigns all other available drive letters before assigning Z, this ensures that partition changes 
you make in the future do not invalidate your CD-ROM drive letter. 

8 Click OK twice. 
9 Click Yes to restart your computer.

If you are using DOS or Windows 3.x or you are loading your CD-ROM drivers under DOS with Windows 95 or 
Windows 98,
1 Go to a DOS prompt.
2 Type EDIT C:\CONFIG.SYS. 

Your CONFIG.SYS file opens in the DOS editor program. Look for this line: LASTDRIVE=drive (where drive is any
letter of the alphabet). Change the drive to Z. This allows the OS to assign all drive letters through Z.
If your CONFIG.SYS file does not contain the LASTDRIVE=drive statement, you can add it by simply typing 
LASTDRIVE=Z.

3 Select File > Exit. 
4 Select Yes to save the file.

You should be back to a C:\> prompt. 
5 Type EDIT C:\AUTOEXEC.BAT. 

Look for a line in your AUTOEXEC.BAT file that includes the word "MSCDEX." The /L:drive parameter (where 
drive is the drive letter assigned to your CD-ROM before you made changes with PartitionMagic) may appear 
at the end of this line. 

6 Change the drive to Z. 
Because the OS assigns all other available drive letters before assigning Z, this ensures that partition changes 
you make in the future do not invalidate your CD-ROM drive letter. For more information, you can type HELP 
MSCDEX at a DOS prompt.
If your computer is on a network, when you log in to the network, the letter "Z" and other letters at the end of 
the alphabet may be assigned to network search drives. In this case, assign your CD-ROM a letter immediately
preceding the last letter used by the network search drives.

7 Select File > Exit. 
8 Select Yes to save the file.
9 Reboot your machine.





Using PartitionMagic with Other Software
Click a link below for more information about using PartitionMagic with certain software.
{button ,JI(`',`H_Norton_Utilities')} Norton Utilities 
{button ,JI(`',`H_Disk_Compression_Utilities')} Disk Compression Utilities 
{button ,JI(`',`H_Operating_System_Boot_Utilities')} Operating System Boot Utilities 
{button ,JI(`',`H_Virus_Protection_Software')} Virus Protection Software 
{button ,JI(`',`H_Drive_Overlay_Software')} Drive Overlay Software 
{button ,JI(`',`H_SoundBlaster')} SoundBlaster 
{button ,JI(`',`H_GoBack')} GoBack 

Norton Utilities
You can safely use PartitionMagic and Norton products together. The following information will help you avoid any
problems.

Norton Disk Doctor
If an extended partition ends at the end of a drive, NDD (Norton Disk Doctor) will sometimes display this 
message: "An extended partition has invalid parameters and probably is inaccessible. Correct this situation if 
you are unable to access partitions on hard disk 1. Do you wish to correct this problem?" To eliminate this 
message, use PartitionMagic to resize the logical and extended partitions at the end of the drive to leave some
free space before the end of the drive.
Additionally, when you delete, move, or resize partitions, it appears to NDD that you could have inadvertently 
deleted a partition. NDD displays the following message: "If you are unable to access a disk that you 
previously could, you should revive this partition. Would you like to revive this partition?" If you deleted a 
partition by mistake, select Yes. If you do not want this message to appear every time you run NDD,

1 Click No. 
NDD displays this message: "You have chosen not to revive the partition. Do you want Norton Disk Doctor to 
mark the partition so it doesn't ask about it again?"

2 Click Yes. 
3 Click Skip Undo File. Creating an undo file uses many disks.

NDD displays this message: "If you wish to undelete this partition at a later time, use the /UNDELETE switch."
4 Click OK. 

NDD displays this message: "Partition information has been changed. Would you like to restart your 
computer?"

5 Click Restart Your Computer.

Norton AntiVirus
Because Norton AntiVirus (NAV) interprets changes to partition tables and boot records as potential virus 
attacks, PartitionMagic takes steps so that NAV automatically reinoculates. Should NAV give you the choice of 
repairing the changes, do not select Repair. Instead, inoculate after using PartitionMagic.

Norton SystemWorks
You can use PartitionMagic on a system where Norton SystemWorks is installed. However, you must run 
PartitionMagic from the rescue disks. If you attempt to run PartitionMagic under Windows with Norton 
SystemWorks installed, you may receive a disk-write error.

Disk Compression Utilities
You can safely use PartitionMagic and some disk compression utilities together. The following information will 
help you avoid any problems.

DriveSpace and DriveSpace 3



To use PartitionMagic with DriveSpace, you must first change the size of a DriveSpace or DriveSpace 3 drive in 
Windows 95 or Windows 98.

1 From the Windows desktop, double-click My Computer.
2 Right-click the drive you want to change, then click Properties from the menu.
3 Click the Compression tab.
4 From the Compression menu, click Advanced.
5 From the Advanced Properties menu, click Run DriveSpace. 
6 Select the compressed volume you want to change.
7 Click Drive at the top of the menu,.
8 From the Drive menu, click Adjust Free Space. 
9 To increase compressed space (enlarge the compressed volume), move the slide bar to the left. To increase 

uncompressed space (shrink the compressed volume), move the slide bar to the right.
If you want to shrink the host for a compressed drive, move the bar to the right to create more uncompressed 
space on the host. You can then use PartitionMagic's Resize/Move operation to make the host partition smaller.
If you have already used Resize/Move to resize the partition larger and want to add more space to the 
compressed volume, move the slide bar to the left.

Operating System Boot Utilities
Both OS/2’s Dual Boot and System Commander 2.0 and above accommodate boot sector changes made by 
PartitionMagic. To install System Commander on drives that PartitionMagic has modified, you may need to use 
System Commander 2.06 or later.
If you have System Commander on your computer, you must configure it so that it does not simultaneously 
unhide multiple primary partitions. To configure System Commander so that it does not create multiple visible 
primary partitions, complete these steps for each operating system selection on the System Commander menu:
1 On the Operating System Selection menu, select an operating system.
2 Press <Alt+S>.
3 Click Local Special Options > Primary partitions accessible on drive 0. 

A screen appears with three options: All, Auto (the default), and None.
4 Select None.
The other primary partitions will now be hidden when this operating system boots. 
5 Repeat steps 1-4 for all operating system selections on the menu.

Virus Protection Software
PartitionMagic modifies the MBR and partitions' boot sectors. Virus protection software should be able to detect 
that PartitionMagic is changing partition tables and not boot code; however, it is possible that unsophisticated 
virus protection programs may mistake PartitionMagic's changes as attempts to install a virus. If this occurs, turn
off the virus protection program while using PartitionMagic and inform the virus protection software 
manufacturer of the problem. 
Some motherboards contain virus protection software within the BIOS. If this causes a problem when you are 
running PartitionMagic, disable the BIOS virus protection, and then restart PartitionMagic.

Drive Overlay Software
Drive overlays, such as Ontrack DDO, Microhouse EZ-Drive or Pro-Drive, Maxblast, WD DDO, and Seagate DDO, 
provide your computer with access to larger disk drives. PartitionMagic is compatible with these programs only if 
the drive overlay program is loaded before PartitionMagic.
If you boot your computer from a disk, the overlay will not load, and PartitionMagic will not get the correct 
information from your drive. You can boot from a disk and still load the drive overlay by completing the following:
1 Start your computer as if you were going to boot from the hard disk. 



2 Press <Space> or <Ctrl> when prompted.
3 The drive overlay information appears with an option of booting from a disk. Select this option and insert the 

boot disk when prompted.

SoundBlaster
The DOS drivers for a SoundBlaster Live sound card may conflict with PartitionMagic operations that require 
going into boot-mode. PowerQuest recommends that you unload the SoundBlaster drivers (by remarking them in
your CONFIG.SYS and AUTOEXEC.BAT files) until after you have finished using PartitionMagic.

GoBack
If you need to modify partitions on a hard disk that is being monitored by Roxio’s GoBack software, you must first
disable (turn off) GoBack.
1 From GoBack’s main menu, click Options > Disable GoBack. 
Before you begin modifying partitions on your hard disk, you must first reboot your computer, then start 
PartitionMagic. When you are finished making your changes in PartitionMagic, you can re-enable GoBack.



To use PartitionMagic with a SCSI hard disk
To use PartitionMagic with a SCSI hard disk, you must have a SCSI controller card that supports software Interrupt
13. Most SCSI controller cards let you enable software Interrupt 13 support in the BIOS through the card. If your 
SCSI controller card does not, contact the manufacturer to determine if your adapter can support software 
Interrupt 13. As a general rule, if FDISK cannot access the entire SCSI disk, PartitionMagic will be unable to 
access it too.



PqRP Partitions
If your computer fails during a PartitionMagic operation, you may see a partition that displays as PqRP or PQFLEX
in the partition list in the main screen. PartitionMagic flags a partition with a PqRP file system and a PQFLEX 
label, so you know that the partition has been modified. You should assume that a PqRP partition is not stable. 
Contact PowerQuest technical support for help in recovering data from a PqRP partition.



To resolve partition table errors
Unless instructions outlined elsewhere specify otherwise, you must resolve partition table errors by creating new,
error-free partition tables. You should,
· Ensure you have no viruses (click See Also on the Help toolbar for more information)
· Back up the data on the affected partitions
· Delete the partitions
· Re-create the partitions
· Restore the partition contents
You may need to use the FDISK program from a recent DOS version, because earlier versions may refuse to 
delete hidden partitions. If you are running Windows NT/2000/XP, you may need to use Disk Administrator or 
Disk Management, respectively.
In some cases, you can resolve partition table errors manually. Run PartitionInfo to determine the errors on your 
partitions. PowerQuest technical support can help resolve partition table errors if you e-mail the PartitionInfo 
report to help@powerquest.com.



Partition Tables and Viruses
If partition changes made under one operating system are not reflected under another, and vice versa, it is 
possible that a MBR virus is present.
Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is likely. To remove the 
virus,
· Boot each operating system and use the Check operation in PartitionMagic to evaluate the integrity of the 

partition.
· Back up the files on any partition that passes the Check operation.
· Remove the virus and perform the Check operation on the partitions again.
· Delete and recreate any partitions that fail the check.
· Reinstall the operating systems and restore the backup files as necessary.



Create New Partition Wizard
Use the Create New Partition wizard to help you create a new primary partition or a logical partition within an 
extended partition. On a single hard disk, you can have up to four primary partitions, or three primary partitions 
and one extended partition. Within an extended partition, you can create unlimited additional subdivisions called
logical partitions.
You should be aware of the following considerations when creating a new partition:
· (Windows 9x and Windows Me only) Creating a new partition may cause your drive letters to change. For 

example, if you have one primary partition (C:) on your hard drive and a CD-ROM drive (D:), and you create a 
new logical partition on your hard drive, the new partition becomes D: and the CD-ROM drive changes to E: 
after you reboot your computer. As a result, any programs on your hard disk that were linked to the CD-ROM 
no longer function because the file paths have changed. 
PowerQuest recommends that you let DriveMapper automatically update your drive letter references, when 
prompted to do so. However, you can update drive letter references manually. For more information about 
changing drive letter references with DriveMapper, click See Also on the Help toolbar, then click 
Understanding Drive Letters.

· The file system you choose for the new partition will determine which operating systems can access the 
partition. The wizard dialogs will instruct you about the choices you make. For example, if you choose to create
a FAT32 partition, the wizard will inform you that FAT32 partitions are used by Windows 95 OEM Service 
Release 2, Windows 98/Me/2000/XP but that Windows 3.x and DOS cannot access them. Pay close attention to 
the information in the dialog boxes, or you may inadvertently make your data inaccessible.

· Before installing Windows NT, make sure that on the disk ends prior to cylinder 1024. Otherwise, Windows NT 
will not install and will report that all the partitions are corrupted. If you cannot resize and move all partitions, 
you must obtain updated drivers from Microsoft (see article ID: Q197667 on the Microsoft web site) before 
installing Windows NT.

· After you apply the changes from the wizard and reboot your computer, the operating system assigns the new 
partition a drive letter. You can then save data or an operating system to your new partition.

If you created a new primary partition and plan to install an operating system on it, see the "Installing Another 
Operating System" task on the Action Panel.



Resize Partitions Wizard
The Resize Partitions wizard helps you resize a partition and lets you specify how the resize will affect other 
partitions on the same disk. For example, if you have C: and D: partitions and you choose to enlarge C:, the 
wizard could take space from D: and allocate it to C:.
For information about resizing partitions without the wizard, see About Resize/Move.



Redistribute Free Space Wizard
The Redistribute free space wizard evenly spreads the free space on a hard disk across partitions. Free space 
refers to unused space within partitions and space that is not allocated to any partition.
You can redistribute free space on one hard disk at a time. You cannot redistribute free space across several 
disks.
For information about redistributing free space without the wizard, see About Resize/Move.



Merge Partitions Wizard
The Merge Partitions wizard helps you merge two adjacent FAT, FAT32, NTFS partitions. You can merge FAT and 
FAT32 partitions with each other, and you can merge an NTFS partition with another NTFS partition. You cannot 
merge FAT/FAT32 partition with an NTFS partition. You choose two partitions, and one will be expanded to include
the second. The contents of the second partition are added as a folder inside the first partition.
PowerQuest recommends that you run DriveMapper to update drive letter references after you merge partitions. 
The wizard will prompt you to run DriveMapper automatically.



Copy Wizard
The Copy Partition wizard helps you duplicate a partition. The copy is the same size and file type and contains 
the same data as the original partition.
When you copy a partition using the wizard, you specify the hard disk and the unallocated space where you want
to place the copy. You also get to select the partition type (primary or logical) and whether the partition will be 
hidden or unhidden. You can keep the partition the same size as the original copy (or slightly different if copied 
to another physical disk with a different geometry), or you can resize the partition to the size you want.



active partition
One primary partition (usually on the first hard disk) is marked "active," meaning it is the partition from which an
operating system will be booted when the computer starts up.



BIOS (Basic Input/Output System)
BIOS is a program code stored in ROM that provides the lowest-level access to peripheral devices and controls 
the first stage of a computer's boot process. 



bootable partition
A partition from which an operating system can be started.



BootMagic
A program that lets you choose the active operating system partition upon starting or rebooting your system. 
BootMagic is included in the PartitionMagic installation and can be accessed from the PartitionMagic menu.



boot sector
The first sector of a hard-disk partition. If the partition is bootable, the boot sector contains a boot record, which 
is code used to boot the operating system installed on that partition.



cluster
The smallest allocation unit in the FAT, FAT32, and NTFS file systems. One cluster consists of a fixed number of 
disk sectors. 



cylinder
The set of all tracks, one on each side of each platter of a hard disk, that are located at the same distance from 
the center of a hard disk. 



drive letter
A single character in the range A to Z that identifies a partition or logical drive for use by an operating system. 
Not all partitions or logical drives are accessible by all operating systems. Also, the drive letters assigned by 
different operating systems to the same partition or logical drive may not be the same.



EPBR (Extended Partition Boot Record)
The IBM/Microsoft implementation of logical partitions makes each logical partition resemble a physical hard 
disk. On this "logical" hard disk, an EPBR occupies the same position as the MBR of a physical hard disk. The 
EPBR may contain two entries. One is a logical partition, corresponding to a physical partition on a physical drive.
The other may be an entry for another EPBR, corresponding to the extended partition on a physical drive.



extended partition
An extended partition is a special kind of primary partition that was developed to overcome the four partition 
limit. The extended partition is a container inside of which you can create logical partitions. The extended 
partition itself does not hold any data, nor is it assigned a drive letter. But logical partitions inside the extended 
partition can hold applications and data and are assigned drive letters.



file system
The method an operating system uses to organize files on a disk. Common file systems are FAT, FAT 32, NTFS, 
Linux Ext2, and Linux Swap.



free space
A section of your hard disk that is not currently assigned to a partition. Free space appears as a dark gray block 
of space on the PartitionMagic disk map. Free space is not recognized by the operating system. Usually, you do 
not want free space because that section of your hard drive will not be used. You can either resize a partition 
larger to incorporate free space or create a new partition in the free space. Do not confuse free space, which 
resides outside any partition, with unused space within a partition.



head
A side of a hard-disk platter. More specifically, the hardware assembly that reads and writes data on a hard-disk 
platter.



hexadecimal
A system of numbers with base 16 that uses the 16 digits 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, and F. The 
letters A, B, C, D, E, and F correspond to the numbers 10, 11, 12, 13, 14, and 15.



hidden partition
A partition that is not assigned a drive letter by an operating system when it boots. A hidden partition is invisible 
to the operating system and all connected applications; therefore, data on a hidden partition cannot be 
accessed. 



LBA (Logical Block Addressing)
1) In EIDE, a means of specifying sector addresses by replacing CHS values with a single linear 28-bit number. 2) 
Generically, a one-dimensional address of a hard-disk sector; contrast with CHS.



logical partition
A contiguous area inside an extended partition that can be used by the operating system to store and retrieve 
files. The operating system typically assigns a letter (for example, D:, E:) to each logical partition. 



lost clusters
Data areas on FAT partitions that are not part of any file's cluster chain. Lost clusters can occur when the file 
system does not completely update the FAT due to a system failure or power failure.



MBR (Master Boot Record)
The MBR is contained in the first sector of the first physical hard disk. The MBR consists of a master boot 
program and a partition table that describes the disk partitions. The master boot program looks at the partition 
table to see which primary partition is active. It then starts the boot program from the boot sector of the active 
partition.



partition boot record
The partition boot record is located in the first sector of a hard-disk partition. It contains code used to boot the 
operating system installed on that partition.



partition list
The section of the PartitionMagic main window that displays a selected hard disk's partition information in text 
form. The partition list (pictured below) displays the following information about each partition: drive letter, label,
file system type, size, amount of used and free space, status, and whether the partition is a primary or logical 
partition.

 



disk map
The section of the PartitionMagic main window that graphically displays a selected hard disk's partition 
information. The disk map (pictured below) shows the partitions approximately to scale. Each partition is 
represented by a different color according to the file system it uses. If the hard disk contains logical partitions, 
the logical partitions are shown within an extended partition. 

 



primary partition
A partition referenced in the master boot record (MBR) partition table. Only four primary partitions can exist on a
hard disk. One of these may be an extended partition. Only one primary partition on a drive may be active at a 
time. When one primary partition is active, the other primary partitions are typically not accessible. Data and 
programs are often placed on a logical partition inside an extended partition. This enables the data to be 
accessed by all primary partitions.



sector
The smallest addressable section on a disk. It is used to record one block of a program or data. Each head on 
each track is typically divided into 17 or more sectors.



volume
1) A partition that has been high-level formatted by a particular operating system; a logical partition. 2) A set of 
partitions handled by the operating system as if they were a single logical partition.



volume label
The name that you give to a partition or volume. Volume labels can help you quickly identify the volumes you 
want to work with in PartitionMagic.
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A
Action Panel
The left tab of the PartitionMagic main screen, containing tasks, operations, and pending 
operations.

active partition
One primary partition (usually on the first hard disk) is marked "active," meaning it is the partition from which an
operating system will be booted when the computer starts up.

ANSI (American National Standards Institute)
A department of the United States government responsible for approving U.S. standards in computers and 
communications. ANSI also works with the International Organization for Standards, or ISO.

ATA (Advanced Technology Attachment)
A standard used by hard-disk drives to communicate with the controller ports or cards, allowing the drive to 
interface with the computer. Before ATA, there were numerous incompatible methods for interfacing hard-disk 
drives to computers. ATA simplifies this process, thus reducing the cost of developing and purchasing related 
hardware. ATA is the official ANSI name for Integrated Drive Electronics (IDE).

ATA-2 (ATA Interface with Extensions)
ATA-2 is the common name for a new EIDE standard. Also dubbed "Fast ATA," ATA-2 extends the ATA interface 
while maintaining compatibility with current BIOS designs. The most noticeable result is increased speed. ATA-2 
is still evolving and has not yet been approved as an official standard. 

B



BIOS (Basic Input/Output System)
BIOS is a program code stored in ROM that provides the lowest-level access to peripheral devices and controls 
the first stage of a computer's boot process. 

boot
To load and initialize an operating system on a computer.

bootable partition
A partition from which an operating system can be started.

BootMagic
A PowerQuest program that lets you choose the active operating system partition when you start or reboot your 
system.

boot record
See master boot record and partition boot record.

boot sector
The first sector of a hard-disk partition. If the partition is bootable, the boot sector contains a boot record, which 
is code used to boot the operating system installed on that partition.

byte
One byte is equal to 8 bits of information.

C
CHS
Cylinder, head, sector. A three-dimensional address of a hard-disk sector.

cluster
The smallest allocation unit in the FAT, FAT32, and NTFS file systems. One cluster consists of a fixed number of 
disk sectors. 

cylinder
The set of all tracks, one on each side of each platter of a hard disk, that are located at the same distance from 
the center of a hard disk.

D
disk map
The section of the PartitionMagic main window that graphically displays a selected hard disk's partition 
information. The disk map, pictured below, shows the partitions approximately to scale. Each partition is 
represented by a different color according to the file system it uses. If the hard disk contains logical partitions, 
the logical partitions are shown within an extended partition. 



DOS
An acronym for Disk Operating System, and is the name of a number of operating systems that include facilities 
for storing files on disk. It coordinates physical disk I/O, mapping of file names to disk addresses, and protection 
of files from unauthorized access.
A DOS usually presents a uniform interface to different storage devices such as floppy disks, hard disks, 
magnetic tape drives, and CD-ROM drives. It may also provide file locking to prevent unintentional simultaneous 
access by two processes. A DOS also manages other computer resources such as memory, printers, and 
networks.

drive
1) Short for hard-disk drive. 2) Short for logical drive.

drive letter
A single character in the range A to Z that identifies a partition or logical drive for use by an operating system. 
Not all partitions or logical drives are accessible by all operating systems. Also, the drive letters assigned by 
different operating systems to the same partition or logical drive may not be the same.

DriveMapper
A PowerQuest tool that helps you easily update drive letter references. For example, if you create, delete, hide, 
or unhide a partition, your drive letters can change, causing applications not to run because application 
shortcuts, initialization files, and registry entries refer to incorrect drives. DriveMapper updates these drive letter
references, allowing your applications to run correctly. DriveMapper also runs automatically under the following 
conditions: (1) you apply changes to your system that affect drive letter assignments, (2) you are running 
Windows 95 or Windows 98, (3) your hard disk contains only FAT or FAT32 partitions, and (4) you have no more 
than one CD-ROM drive and no more than one removable drive.

dual boot
A generic term referring to the ability to boot multiple operating systems from a single partition by replacing the 
boot sector code of the partition. This is also called "multi-boot."

E
EIDE (Enhanced Integrated Drive Electronics)
A marketing program that promotes certain features of ATA-2.

EB
Exabyte (Ebyte, E-byte). One exabyte is equal to 1,024 petabytes or 1 quintillion bytes of information.

extended partition
An extended partition is a special kind of primary partition that was developed to overcome the four partition 
limit. The extended partition is a container inside of which you can create logical partitions. The extended 
partition itself does not hold any data, nor is it assigned a drive letter. But logical partitions inside the extended 
partition can hold applications and data and are assigned drive letters.



EPBR (Extended Partition Boot Record)
The IBM/Microsoft implementation of logical partitions makes each logical partition resemble a physical hard 
disk. On this "logical" hard disk, an EPBR occupies the same position as the MBR of a physical hard disk. The 
EPBR may contain two entries. One is a logical partition, corresponding to a physical partition on a physical drive.
The other may be an entry for another EPBR, corresponding to the extended partition on a physical drive.

F
FAT (File Allocation Table)
A file system developed for MS-DOS by Microsoft. The FAT file system is named after the file allocation table, one 
of the key architectural elements of the FAT file system. DOS, Windows 95/98/Me, Windows NT/2000/XP, and 
Linux can use partitions formatted with the FAT file system.

FAT32
A file system used by Windows 95 OEM Service Release 2, Windows 98/Me/2000/XP. FAT32 is an 
enhancement of the FAT file system and is based on 32-bit file allocation table entries, rather than the 16-bit 
entries used by the FAT system. As a result, FAT32 supports much larger disk or partition sizes (up to 2 
terabytes).

file system
The method an operating system uses to organize files on a disk. Common file systems are FAT, FAT 32, NTFS, 
Linux Ext2, and Linux Swap.

format
1) v. To construct the framework on the partition necessary for a file system to name, store, and retrieve files. 2) 
n. An operating system command that formats a partition.

free space
Unused space within a partition. Do not confuse free space with unallocated space, which resides outside a 
partition.

G
GB
Gigabyte. One gigabyte is equal to 1,024 megabytes or 1 billion bytes of information.

H
head
A side of a hard-disk platter. More specifically, the hardware assembly that reads and writes data on a hard-disk 
platter.

hexadecimal
A system of numbers with base 16 that uses the 16 digits 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, and F. The 
letters A, B, C, D, E, and F correspond to the numbers 10, 11, 12, 13, 14, and 15.

hidden partition



A partition that is not assigned a drive letter by an operating system when it boots. A hidden partition is invisible 
to the operating system and all connected applications; therefore, data on a hidden partition cannot be 
accessed. 

I
IDE (Integrated Drive Electronics)
See ATA.

J

K
KB
Kilobyte. One kilobyte is equal to 1,024 bytes. A kilobyte is also a unit of measurement for computer file sizes.

L
label
The name that you give to a volume or partition.

LBA (Logical Block Addressing)
1) In EIDE, a means of specifying sector addresses by replacing CHS values with a single linear 28-bit number. 2) 
Generically, a one-dimensional address of a hard-disk sector; contrast with CHS.

Linux 
A freeware version of the UNIX operating system. It can access primary and logical partitions formatted with 
Linux Ext2 and Linux Swap.

Linux Ext2
A file system developed for Linux.

Linux Swap
A file system developed for Linux; used for the Linux swap file.

logical drive
1) A contiguous area inside an extended partition that can be used by the operating system to store and retrieve
files. The operating system typically assigns a letter (for example, D:, E:) to the logical drive. In this help system,
the term "logical partition" is used in place of "logical drive." 2) Any partition, CD-ROM, or other storage device 
that contains a file system and is assigned a drive letter.

logical partition
This help system uses the term "logical partition" in place of "logical drive" to refer to a partition inside an 
extended partition.

LFN (Long Filename)



Windows 95/98/Me/NT/2000/XP and other operating systems do not have to adhere to DOS's file naming system, 
in which a filename can have no more than eight characters and a three-character extension. Filenames that 
violate this DOS format are considered LFNs. LFNs can have as many as 254 characters. Windows 
95/98/Me/NT/2000/XP use additional directory entries. See VFAT.

lost clusters
Data areas on partitions that are not part of any file's cluster chain. Lost clusters can occur when the file system 
does not completely update the partition type due to a system failure or power failure.

M
MB
Megabyte. One megabyte is equal to 1,048,576 bytes (1,024 x 1,024).

MBR (Master Boot Record)
The master boot record is contained in the first sector of the first physical hard disk. The MBR consists of a 
master boot program and a partition table that describes the disk partitions. The master boot program looks at 
the partition table to see which primary partition is active. It then starts the boot program from the boot sector of
the active partition.

multi-boot
See dual boot.

N
NTFS (New Technology File System)
A file system developed by Microsoft and accessible only through Windows NT/2000/XP. NTFS eliminates many of
the shortcomings of the FAT file system, such as wasteful cluster sizes and a slow CHKDSK execution time.

O
operating system
An operating system allows programs to cooperatively use a computer's resources (for example, disks, memory, 
printers, and networks). Common operating systems are MS-DOS, Linux, and Windows 95/98/Me/NT/2000/XP.

P
partition
A contiguous area of a hard disk that the operating system can format with a file system. The term "partition" 
can refer to either a primary or logical partition.

partition boot record
The partition boot record is located in the first sector of a hard-disk partition. It contains code used to boot the 
operating system installed on that partition.

partition list
The section of the PartitionMagic main window that displays a selected hard disk's partition information in text 
form. The partition list, pictured below, displays the following information about each partition: drive letter, 



volume label, file system type, size, amount of used and free space, status, and whether the partition is a 
primary or logical partition.

PB
Petabyte (Pbyte, P-byte). One petabyte is equal to 1,024 terabytes or 1 quadrillion bytes of information.

primary partition
A partition referenced in the master boot record (MBR) partition table. Only four primary partitions can exist on a
hard disk. One of these may be an extended partition. Only one primary partition on a drive may be active at a 
time. When one primary partition is active, the other primary partitions are typically not accessible. Data and 
programs are often placed on a logical partition inside an extended partition. This enables the data to be 
accessed by all primary partitions.

Q

R

S
sector
The smallest addressable section on a disk. It is used to record one block of a program or data. Each head on 
each track is typically divided into 17 or more sectors.

T
TB
Terabyte (Tbyte, T-byte). One terabyte is equal to 1,024 gigabytes or 1 trillion bytes of information.

track
A circular path on a disk to which data can be written and from which data can be read.

U
unallocated space
A section of your hard disk that is not currently assigned to a partition. Unallocated space is not recognized by 



the operating system. Usually, you do not want unallocated space because that section of your hard disk will not 
be used. You can either resize a partition larger to incorporate unallocated space or create a new partition in the 
unallocated space. Do not confuse unallocated space, which resides outside any partition, with free space within 
a partition.

V
VFAT
VFAT is an extension to the FAT file system that adds support for long filenames. Although the term "VFAT" 
originated as the name of the Windows for Workgroups FAT file system driver, it has come to refer to the 
extensions to the FAT file system added by Windows NT 3.51 and Windows 95.

visible partition
A partition that is assigned a drive letter by an operating system when it boots. You can access files, 
applications, and other data from visible partitions.

volume
1) A partition that has been high-level formatted by a particular operating system; a logical partition. 2) A set of 
partitions handled by the operating system as if they were a single logical partition.

volume label
The name that you give to a partition or volume.    

W
Windows 95
An operating system developed by Microsoft. Windows 95 is a descendant of DOS and Windows 3.x. It can 
access primary and logical partitions formatted with the FAT file system. It supports long filenames using the 
VFAT extension to FAT.

Windows 98
An operating system developed by Microsoft operating system that uses the FAT32 file system, allowing it to 
access primary and logical partitions larger than 2 GB and support filenames longer than 254 characters. 
Windows 98 can also access partitions formatted with FAT.

Windows Me
The newest Microsoft operating system for the home user and the upgrade from Windows 98.

Windows 2000
A Microsoft operating system for corporate network use and the upgrade from Windows NT 4.0. Windows 2000 
uses NTFS (version 5.0) and can access FAT and FAT32 file systems.

Windows NT
An operating system developed by Microsoft. Windows NT can access primary and logical partitions formatted 
with FAT and NTFS.

Windows XP
The newest Microsoft operating system for corporate network and home use and the upgrade from Windows 



NT/2000, Windows Me, and Windows 98 SE. It features a 32-bit computing architecture that is built on the code 
base of Windows 2000 and Microsoft's other popular consumer operating systems. See the Microsoft website for 
more information about Windows XP Professional and Home Edition.



sparse
A file that has empty spaces where data can later be entered.



About Undo Last Change
Use Undo Last Change to undo or reverse the last operation that was added to the Operations Pending dialog 
box. If you have performed an operation using a wizard, Undo Last Change will reverse all the changes made by 
the wizard.
{button ,JI(`',`H_To_undo_last_operation')} To undo last operation 



To undo last operation
1 Click General > Undo Last Change.

Tips
· You can also press <Ctrl+Z>.
· To discard all the changes performed and start over, click General > Discard All Changes, or press 

<Ctrl+D>.



About Set Password
Use Set Password to assign a password that must be entered before PartitionMagic will start. Once you set a 
password, you will be prompted for a password before PartitionMagic will run.
{button ,JI(`',`H_To_password_protect_PartitionMagic')} To password-protect PartitionMagic 
{button ,JI(`',`H_To_change_a_password')} To change a password 
{button ,JI(`',`H_To_remove_password_from_PartitionMagic')} To remove a password from PartitionMagic 



To password-protect PartitionMagic
1 Click General > Set Password.
2 Type a new password, then press <Tab>.
3 Confirm the new password., then press <Tab>.
4 (optional) Add a password hint.
5 Click OK.



To change a password
1 Click General > Set Password.
2 Type the old password, then press <Tab>.
3 Type the new password, then press <Tab>.
4 Confirm the new password, then press <Tab>.
5 (optional) Change the password hint.
6 Click OK.

Tips
· If you forget the password, you can delete PQMAGIC.PSW (located in the same folder as PMAGIC9X.EXE), then 

set a new password.



To remove a password from PartitionMagic
1 Click General > Set Password.
2 Type your current password in the Old Password text box.
3 Click OK.

Tips
· If you forget the password, you can delete PQMAGIC.PSW (located in the same folder as PMAGIC9X.EXE), then 

set a new password.



About the View Menu
Use the View menu to display or hide different parts of the PartitionMagic interface, such as the toolbar or 
legend.
You can also use the View menu to review all pending operations that have not yet been applied to your 
computer.
{button ,JI(`',`H_To_display_hide_parts_of_the_interface')} To display/hide parts of the interface 



To display/hide parts of the interface
1 Click View > Toolbar, Action Panel, Legend, Scale Disk Map.

A check mark is displayed next to the option name when the option is displayed. To hide an interface item, 
repeat the step above.

Option Description
Toolbar The toolbar gives 

you quick access to
frequently used 
commands in 
PartitionMagic. 
Move the mouse 
pointer over a 
toolbar button (or a
pull-down menu 
item) to read a 
brief description of 
what the option 
does, in the status 
bar located at the 
bottom of the 
window. Also, when
the mouse pointer 
is over a toolbar 
button, a pop-up 
description is 
displayed next to 
the button.

Action Panel Click Action Panel
to view a list of 
tasks and 
operations you can
perform on 
partitions, and 
view the 
operations pending
on those partitions.

Legend The Legend is 
displayed just 
above the status 
bar located at the 
bottom of the 
PartitionMagic 
window. You can 
use the Legend to 
help you 
understand the 
different colors 
used in the disk 
map, and partition 
list. Hiding the 
Legend increases 
the display area of 
the disk map and 



partition list.
Disk Map 
Location

Click Disk Map 
Location, then 
click the location 
on the main screen
you want the Disk 
Map to display in.

Scale Disk Map Click Scale Disk 
Map to display the 
relationship 
between the size of
what is actually on 
the selected hard 
disk and a 
representation of 
it, in the disk map.



About Split
Use Split to divide a FAT or FAT32 partition into two contiguous partitions: a "parent" partition (which is the 
original partition) and a new "child" partition. The new partition is created to the right of the original partition; 
the parent and child partitions together occupy the same amount of hard disk space as the original partition. The
file system for the child partition does not change. For example, if you had a 2 GB FAT partition and you split it, 
the parent and child partitions together would use 2 GB and both would be FAT partitions.
When you split a partition, you can select the files and folders that you want the new partition to include. You can
also give the new partition a name (label), specify whether the new partition is primary or logical, and specify 
the new size of the partition.
The Split operation is designed to move data files, not system files. You should not move folders from the 
operating system partition (usually C:) to the new partition unless they ONLY include data files. If you copy a 
folder that is used by the operating system (such as C:\Documents and Settings\username\My Documents), you 
may be prompted to reboot your computer an extra time for Windows to apply the changes or Windows may not 
allow you to split the partition. If Windows allows you to move a standard folder, you will need to redirect files to 
the new partition from within the applications that used the original partition. 
The size of the new partition is based on the minimum possible size and the total byte size of the files you are 
adding to the new partition. Any remaining free space is split proportionally between the parent and child 
partitions according to the data in both partitions. For example, if the two partitions used 2 GB and you included 
700 MB of data in the parent partition and 300 MB of data on the child partition, you would have 1 GB of free 
space available; the parent partition would get 700 MB of unused space, and the child partition would get 300 
MB of unused space.
Both the parent and child partitions must be at least 40 MB. On hard disks larger than 4 GB, PartitionMagic will 
round up the size of the partition to at least 47 MB.
You can split a partition if it is 100 MB or larger.
PowerQuest does not recommend splitting your operating system partition or moving your Windows folders or 
program files into the new partition.
{button ,JI(`',`H_To_split_a_partition')} To split a partition 



To split a partition
1 Select a partition.
2 Click Partition > Split.
3 Click the Data tab.
4 From the Original Partition group box, select the files and folders you want to move to the new partition, then 

click the single right arrow.
Click the left arrow to remove selected files and folders from the new partition. To move all files and folders to 
the new partition, click the double right arrow. You can also click the left arrow to move selected files and 
folders back to the original partition. You must, however, have at least one file or folder remaining in the 
original partition.

5  (Optional) Type a name for the new partition in the Label text box.
6 Select a partition type from the Pri/Log drop-down list.
7 Click the Size tab.
8 Size the new partition by moving the bar on the far right in the disk map, or by typing the number of MB in the

Size text box. 
The original partition will be adjusted to use the remaining space.

9 Click OK.

Tips
· PowerQuest does not recommend splitting the partition that includes your operating system.
· If Split is dimmed (unavailable) on the Partition menu, it is most likely because you are trying to split a 

primary partition when you have already reached the maximum four primary partitions (such as three primary 
partitions and one extended partition) allowed on a hard disk. You can, however, use Split on a logical partition
within an extended partition.

· You can split partitions if they are 100 MB or larger.
· A FAT partition must have at least 5% unused space, or the Split operation will be dimmed (unavailable) on the

Partition pull-down menu. A FAT32 partition requires 10% unused space to split.
· You cannot use the Split operation to convert the original partition from primary to logical or vice versa.



About Undelete
Use Undelete to restore partitions that have been deleted on a hard disk. You can undelete FAT, FAT32, NTFS, and
Linux partitions. Undelete works best when you use it to restore a partition that you just deleted by accident.
Important: You can undelete a partition only if no other operations are pending on the selected unallocated 
space. If any operations are pending, the undelete icon and menu option will be dimmed (unavailable).
All partitions that can be undeleted may not be listed at the same time. For example, if your hard disk had three 
primary partitions and all three were deleted, you would only see the first partition listed the first time you used 
the Undelete feature. However, after you apply the Undelete operation on the first (active) partition, you can run 
the Undelete feature again and the remaining two partitions will be listed.

Restrictions on Undeleting Partitions
There are some situations in which a partition that has been deleted cannot be undeleted and will not be 
displayed in the Undelete dialog box. They include the following:
· You cannot undelete a primary partition if your hard disk contains four primary partitions.
· You cannot undelete a logical partition that was deleted and now is not within the extended partition.
· You cannot undelete a primary partition that was deleted and now is within the extended partition.
· The partition includes file system errors. If PartitionMagic finds a partition to undelete, it will check for errors 

before undeleting it. If the partition has errors, it cannot be undeleted.
· You cannot undelete a partition that has been completely or partially overwritten by another partition or file 

system. Because of this limitation, if you see two partitions in the Undelete dialog and undelete one of them, 
the other may no longer appear in the list.

· If two deleted partitions claim some of the same disk space, PowerQuest cannot guarantee the integrity of the 
data in those partitions when they are undeleted.
For example, suppose you had a 500 MB partition (E:) and another 500 MB partition (F:) and you deleted F: and
resized E: to claim all the space (1 GB). Then you saved data to E:. Later, you deleted E:. Now you want to 
undelete partitions, and you can see both E: and F: in the Undelete dialog box. You restore E: and F: is no 
longer displayed in the Undelete dialog box (because its space has been claimed). However, if you restore F:, 
you may get some of the data that you had saved to E:. Undeleting F: could make your computer unbootable 
or cause applications not to run.

{button ,JI(`',`H_To_undelete_a_partition')} To undelete a partition 



To undelete a partition
1 On the disk map or the partition list, select the unallocated space to be searched.
2 Click Partition > Undelete.

All primary and logical partitions that can be undeleted are displayed in the list box of the Undelete dialog box.
If no partitions are found within the unallocated space or none can be undeleted, a message appears 
indicating that no partitions can be undeleted.

3 In the list box, select the partitions you want to undelete.
4 Click OK.

Tips
· You can undelete a partition only if no other operations are pending on the unallocated space selected. If any 

operations are pending, the Undelete icon and menu option will be dimmed (unavailable).
· While it is possible to undelete more than one partition at once, PowerQuest recommends that you undelete 

partitions one at a time, beginning with the partition that you want most. Doing so helps ensure the integrity 
of the data within the partition.

· All partitions that can be undeleted may not be listed at the same time. For example, if your hard disk had 
three primary partitions and all three were deleted, you would only see the first partition listed the first time 
you used the Undelete feature. However, after you apply the Undelete operation on the first (active) partition, 
you can run the Undelete feature again and the remaining two partitions will be listed.



Select a disk and a partition
Selecting a Hard Disk and Partition
You can select a partition without first selecting a hard disk. To select a partition, click it in the disk map or 
partition list on the main screen.
To select a hard disk, click the title bar on the disk map. There are two operations that can be performed on a 
hard disk: delete all the partitions or display information about the hard disk. When you select a hard disk, its 
partitions display in the partition list in the main window.



Documentation guide is unavailable
If the PDF guide you requested cannot be found or opened, it will usually be caused by one of the following 
scenarios.

Scenario 1
You have not installed the PDF guides, but the Adobe® Acrobat® Reader is installed. To fix this issue,
1 Run the PartitionMagic installation program.
2 When you get to the Setup Type dialog box, click Custom.
3 Click Next.
4 Deselect PartitionMagic for Windows 95/98/Me and PartitionMagic for Windows 3.1/DOS.
5 Make sure PDF Documents is selected.
6 Complete the remainder of the installation as usual.

The guide will now be available from the "Reference Center" in the Contents tab of PartitionMagic online Help.

Scenario 2
You have installed the PDF guides, but the Adobe Acrobat Reader is not installed. When the reader is not 
installed and you try to open a PDF guide, you may get an error stating that Windows Help could not find or run 
the file or program. To fix this issue,
1 Download and install the Adobe Acrobat Reader found at 

http://www.adobe.com/products/acrobat/readstep2.html.
2 Immediately following the installation, run the Adobe Acrobat Reader at least once before you attempt to open

the PDF guides from the Reference Center book in the Contents tab of online Help.
If you open the PDF guides from the online Help the first time you run Acrobat, the Acrobat splash screen will 
appear, display a license agreement, then disappear. When you make a second attempt to open the PDF 
guides, you should not encounter any display problems.

Scenario 3
You have not installed the PDF files or the Adobe Acrobat Reader. To fix this issue,
1 Complete steps 1-6 in Scenario 1.
2 Complete steps 1 and 2 in Scenario 2.

Tip
· In scenario 1, you should run Adobe Acrobat Reader at least once before you attempt to open any of the PDF 

guides from the Reference Center book in the Contents tab of online Help. If you open PDF guides from the 
online Help the first time you run Acrobat, the Acrobat splash screen will appear, display a license agreement, 
then disappear. When you make a second attempt to open the PDF guides however, you should not encounter 
any display problems.

· You can also view the guides directly from the PartitionMagic CD. From the opening PartitionMagic installation 
program screen, click Documentation, then click a guide.
Or, from the Windows Start menu, click Programs > PowerQuest PartitionMagic 8.0 > PDF Documents, 
then click a guide.



Using International Keyboards
When you use the DOS version of PartitionMagic, you may lose the ability to use your keyboard the way you are 
accustomed to or to view extended characters properly. The PartitionMagic rescue disks include the files you need 
to resolve these problems.
If you use an international keyboard or character set, you must edit the AUOTEXEC2.BAT and CONFIG.SYS files on 
the rescue disks.
1 The following lines are remarked in the AUOTEXEC2.BAT file. Delete the REM from the beginning of the line, 

and replace the variables xx and yyy with the keyboard code and character set code page for your language.
MODE CON CP PREP=((yyy)EGA.CPI)
MODE CON CP SEL=yyy
KEYB xx,yyy
xx=two-letter keyboard code (for example, US or FR)
yyy=character set code page (for example, 437)

2 Save the AUTOEXEC2.BAT file.
3 The following line is remarked in the CONFIG.SYS file. Delete the REM from the beginning of the line, and 

replace the variable yyy with the character set code page for your language.
DEVICE=DISPLAY.SYS CON=(EGA,yyy,)

4 Save the CONFIG.SYS file.
5 Reboot from the first rescue disk.



About the File Browser
Use the File Browser to view and/or modify the files and folders found in any partition with a file system supported 
by PartitionMagic.This includes hidden partitions.
From within the File Browser, you can copy, move, rename, or delete files, and create or delete folders to or from 
any partition on your system if the partition is one of the following file system types:

· FAT/FAT32
· NTFS
· Linux Ext2/Ext3
· Hidden partitions of any of the above



To browse the files in a partition
1 In the disk map, right-click the partition you would like to browse > click Browse.
2 Browse the partition, its folders, or files > click Close.
Tips

· Any changes will be made when you close the File Browser. These changes may take some time.



Install Another Operating System Wizard
This wizard helps you install another operating system (OS) on your computer. For example, you can install 
Windows XP on your computer yet still keep a copy of Windows 98. You can create a partition for your data that 
different operating systems can both access. This way, if your primary OS should crash, you could still access 
your data through the additional OS.
The wizard begins by asking you what OS you want to install.    It then asks you where you want to install the OS, 
only showing those locations that are valid for the OS type selected, and makes suggestions (which disk, before 
or after a certain partition). It selects the correct file system type, checks the OS size against available free 
space, and warns you if there is not enough space available for the OS. The wizard will not resize existing 
partitions making them too small to function. The wizard checks the location (including the boot code boundary 
in effect) for the existing OS and prevents you from allowing an additional OS to disable the original operating 
system on the computer.
The wizard does not place the new OS in the boot menu of any boot manager (BootMagic included). If you want 
to boot to the new OS through a boot manager when you start your computer, you must configure the boot 
manager yourself.



Installing Another Operating System - Additional Instructions
When you click Finish, your computer will reboot to the new partition. This will not be successful because there is
no operating system on that new partition. Print these steps for reference in installing the new operating system 
and adding the new OS to the BootMagic Configuration menu.

· Scenario 1: BootMagic Installed and Enabled
· Scenario 2: PowerQuest BootMagic Installed and Disabled or Not Installed

Scenario 1: BootMagic Installed and Enabled
1 When you reboot the computer at the end of this wizard, BootMagic overrides the settings made by 

PartitionMagic, so you see the BootMagic menu with your existing operating system (or systems) seen as 
startup options.

2 Boot into the existing operating system, so you can get to the BootMagic Configuration screen.
3 Open the BootMagic Configuration program (click Start > Programs > PowerQuest BootMagic 8.0 > 

BootMagic Configuration).
4 Click Edit > Add.

The BootMagic Add OS dialog lists all the system operating systems detected by BootMagic.
5 Click the Advanced button to view all your system’s partitions, including those that BootMagic doesn’t 

recognize as containing an OS (for example, Linux on a logical partition).
6 Select the new partition you want to add to the menu.
7 Click OK.
8 Define the menu properties you want > click OK.
9 Boot from the operating system CD or diskette for the operating system you are adding.

a. Make sure that the boot sequence in your system's BIOS is set to boot from either floppy diskette or CD first 
and hard drive second. Some machines may not be able to boot from the CD drive, or the CD itself may not be
bootable. Check your documentation to verify this.
b. Upon reboot, place disk 1 of your operating system’s installation floppy disk or CD in the appropriate drive 
to start the installation.
Important (Windows NT 4.0 only): If NTLDR.EXE is installed or moved beyond the 64K boot code boundary,
Windows NT will fail to boot. NTLDR.EXE is usually located near the beginning of the partition in which it is 
installed. When you create partitions using PartitionMagic, if NTLDR.EXE is not located within the 2 GB 
boundary, the OS will not boot. If you hide a Windows NT boot partition, you must manually edit the Windows 
NT boot initialization file (BOOT.INI) to point to a new Windows NT boot partition. This can be done by opening 
the file in a program such as Notepad and resaving it with the same file extension.

10Install the operating system into the new partition, as directed by the on-screen instructions.
11Reboot, and choose the old operating system from the BootMagic menu at startup.
12Go back into the BootMagic Configuration screen, and set up the new operating system options.

When you reboot the next time, the BootMagic menu will display both the old operating system and the new 
one. You will be able to choose either operating system.

Scenario 2: PowerQuest BootMagic Installed and Disabled or Not Installed
1 When you reboot the computer at the end of this wizard, it will hang because there is no operating system in 

the new active partition.
2 Reboot again using the operating system CD or diskette for the operating system you are adding.

a. Make sure that the boot sequence in your system's BIOS is set to boot from either floppy diskette or CD first 
and hard drive second. Some machines may not be able to boot from the CD drive, or the CD itself may not be
bootable. Check your documentation to verify this.
b. Upon reboot, place disk 1 of your operating system’s installation floppy disk or CD in the appropriate drive 
to start the installation.
Important (Windows NT 4.0 only): If NTLDR.EXE is installed or moved beyond the 64K boot code boundary,
Windows NT will fail to boot. NTLDR.EXE is usually located near the beginning of the partition in which it is 
installed. When you create partitions using PartitionMagic, if NTLDR.EXE is not located within the 2 GB 



boundary, the OS will not boot. If you hide a Windows NT boot partition, you must manually edit the Windows 
NT boot initialization file (BOOT.INI) to point to a new Windows NT boot partition. This can be done by opening 
the file in a program such as Notepad and resaving it with the same file extension.

3 Install the operating system into the new partition, as directed by the on-screen instructions.
At this point, you could reboot and use the new operating system, but there would not be an easy way to 
choose between operating systems at startup. The following steps enable you to configure BootMagic, so both 
operating systems are available as choices at startup.

4 Reboot with the first PartitionMagic rescue disk, and insert the second rescue disk when directed to do so.
5 From PartitionMagic, set the partition that includes your old operating system active.

If you are planning to install BootMagic and you do not have a FAT or FAT32 partition to install it on, you can 
also use PartitionMagic to create that partition.

6 If you do not have BootMagic installed, install it.
7 Open the BootMagic Configuration program (click Start > Programs > PowerQuest BootMagic 8.0 > 

BootMagic Configuration).
8 Click Edit > Add.

The BootMagic Add OS dialog lists all the system operating systems detected by BootMagic.
9 (optional) Click the Advanced button to view all your system’s partitions, including those that BootMagic 

doesn’t recognize as containing an OS (for example, Linux on a logical partition).
10Select the new partition you want to add to the menu.
11Click OK.
12Define the menu properties you want > click OK.

When you reboot the next time, the BootMagic menu will display both the old operating system and the new 
one. You will be able to choose either operating system.



Installing Another Operating System - Windows 98
If you are installing Windows 98 as an additional operating system, here are some tips that can help you. These 
tips are categorized by wizard screen titles in the order you will see the screens.
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations valid for Windows 98 are displayed.
· Do not move any Windows 98 or NT partition to the right of the 8 GB boot code boundary for Windows 98 or 2 

GB boot code boundary for Windows NT (indicated by the second triangle marker on the disk map), or the 
operating system will be unbootable.

· If you are installing Windows 98 (pre-SE version), it must be installed below the boot code boundary for 
Windows 98. This is automatically done by the wizard.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, deselect any partitions 
containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen.
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Windows 98 requires for

installation and how much free space is available on the disk.
· A Windows 98 installation requires a minimum of 175 MB of space. We recommend having at least double or

triple this space available to have room for applications and data you will create under Windows 98.

Label
· Giving your partitions meaningful labels helps you manage them.
· The maximum number of alphanumeric characters for a FAT or FAT32 label is 11.
· You cannot use the following characters in a label: * ? [ ] < > | + = : ; . \ / "

Primary/Logical
· Because Windows 98 must be installed to a primary partition on disk 1, this is selected for you.

File System Type
· Windows 98 must be installed on a FAT or FAT32 file system type. FAT32 is recommended. Historically, FAT 

was the preferred file system for installation because it is universally visible. However, it only supports disk 
sizes up to 2 GB and many disks are larger than that currently, so FAT32 is recommended.

· Only valid file system types for Windows 98 are displayed.
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active



· Setting a partition active means that you will boot to it.
· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD 

for Windows 98 in the CD drive and continue with the installation.
· If you set a partition active, the other primary partitions on that disk will be hidden. Having multiple, visible 

primary partitions under Windows 98 causes problems.

Confirm Choices
· This screen displays two disk maps; one showing the hard disk before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.



Installing Another Operating System - Windows Me
If you are installing Windows Me as an additional operating system, here are some tips that can help you. These 
tips are categorized by wizard screen titles in the order you will see the screens.
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations valid for Windows Me are displayed.
· Do not move any Windows 98 or NT partition to the right of the 8 GB boot code boundary (indicated by the 

second triangle marker on the disk map), or the operating system will be unbootable.
· Windows Me must be installed below the boot code boundary for Windows Me. This is automatically done by 

the wizard.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, deselect any partitions 
containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen.
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Windows Me requires for

installation and how much free space is available on the disk.
· A Windows Me installation requires a minimum of 300 MB of space. We recommend having at least double 

or triple this space available to have room for applications and data you will create under Windows Me.

Label
· Giving your partitions meaningful Label names helps you manage them easier.
· The maximum number of alphanumeric characters for a FAT or FAT32 label is 11.
· You cannot use the following characters in a FAT/FAT32 label: * ? [ ] < > | + = : ; . \ / "

Primary/Logical
· Because Windows Me must be installed to a Primary partition on Disk 1, this is selected for you.

File System Type
· Windows Me must be installed on a FAT or FAT32 file system type. FAT32 is recommended. Historically, FAT 

was the preferred file system for installation on because it is universally visible. However, it only supports 
disk sizes up to 2 GB and many disks are larger than that currently, so FAT32 is recommended.

· Only valid file system types for Windows Me are displayed.
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active
· Setting a partition active means that you will boot to it.



· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD of

Windows Me in the CD drive and continue with the installation.

Confirm Choices
· This screen displays two disk maps; one showing the hard disk before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.



Installing Another Operating System - Windows NT 4.0
If you are installing Windows NT 4.0 as an additional operating system, here are some tips that can help you. 
These tips are categorized by wizard screen titles in the order you will see the screens.
· Select Disk 
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 

Select Disk
· Note that USB, FireWire, CD, and removable drives are not displayed.
· If there is only one physical disk in the machine, this screen will not be shown.
· NT uses two different partitions: a boot partition (having most of the actual OS files), and a system partition 

(having just a few files for booting: BOOT.INI, NTLDR.COM, NTDETECT.COM, etc.) If you are installing NT 4.0 to 
a primary partition on disk 1, the system partition and boot partitions can be the same partition. However, if 
you are installing NT to a logical partition on disk 1, or to any partition NOT on disk 1, you need to be sure that 
there is a primary FAT partition on disk 1 that can be used as the NT system partition.

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations that are valid for Windows NT are displayed.
· Do not move any Windows 98 or NT partition to the right of the 8 GB boot code boundary (indicated by the 

second triangle marker on the disk map), or the operating system will be unbootable.
· Windows NT 4.0 must be installed below the boot code boundary for Windows NT 4.0. This is automatically 

done by the wizard.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, deselect any partitions 
containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen.
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Windows NT 4.0 

requires for installation and how much free space is available on the disk.
· A Windows NT 4.0 installation requires a minimum of 120 MB of space. We recommend having at least 

double or triple this space available to have room for applications and data you will create under Windows 
NT 4.0.

Label
· Giving your partitions meaningful labels helps you manage them easier.
· The maximum number of alphanumeric characters for a FAT label is 11, and 32 for an NTFS label.

Primary/Logical
· Windows NT 4.0 can be installed to either a primary or logical partition. See Select Disk, third bullet.



File System Type
· Windows NT 4.0 must be installed to either a FAT or NTFS version 1.3 file system type. If installed to FAT, you

can convert to NTFS during the Windows NT installation. We recommend you install to FAT and convert to 
NTFS during the NT installation.

· Only valid file system types for Windows NT 4.0 are displayed. 
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active
· Setting a partition active means that you will boot to it.
· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD

for Windows NT 4.0 in the CD drive and continue with the installation.

Confirm Choices
· This screen displays two disk maps; one showing the hard disk before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.



Installing Another Operating System - Windows 2000
If you are installing Windows 2000 as an additional operating system, here are some tips that can help you. 
These tips are categorized by wizard screen titles in the order you will see the screens.
· Select Disk 
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 

Select Disk
· Note that USB, FireWire, CD, and removable drives are not displayed.
· If there is only one physical disk in the machine, this screen will not be shown.
· Windows 2000 uses two different partitions: a boot partition (having most of the actual OS files), and a system 

partition (having just a few files for booting: BOOT.INI, NTLDR.COM, NTDETECT.COM, etc.) If you are installing 
Windows 2000 to a Primary partition on disk 1, the system partition and boot partitions can be the same 
partition. However, if you are installing Windows 2000 to a Logical partition on disk 1, or to any partition NOT 
on disk 1, you need to be sure that there is a Primary FAT partition on disk 1 that can be used as the Windows 
2000 system partition.

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations that are valid for Windows 2000 are displayed.
· Do not move any Windows 98 or NT partition to the right of the 8 GB boot code boundary (indicated by the 

second triangle marker on the disk map), or the operating system will be unbootable. If you have a Logical 
Block Addressing-compatible Master Boot Record, the boot code boundary is not applicable.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, deselect any partitions 
containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen.
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Windows 2000 requires 

for installation, how much free space is available on the disk.
· A Windows 2000 installation requires a minimum of 650 MB of space. We recommend having at least double

or triple this space available to have room for applications and data you will create under Windows 2000.

Label
· Giving your partitions meaningful labels helps you manage them easier.
· FAT and FAT32 labels are limited to 11 alphanumeric characters. NTFS labels can be up to 32 characters.

Primary/Logical
· Windows 2000 can be installed to either a primary or logical partition. See Select Disk, third bullet.

File System Type



· Windows 2000 must be installed to either a FAT, FAT32, or NTFS partition. If installed to FAT, you can convert
to NTFS during the Windows 2000 installation. Historically, FAT is the preferred file system to install on 
because it is universally visible. However, it only supports disk sizes up to 2 GB, and many disks are larger 
than that currently, so FAT32 or NTFS is recommended.

· Only valid file system types for Windows 2000 are displayed.
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active
· Setting a partition active means that you will boot to it.
· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD 

for Windows 2000 in the CD drive and continue with the installation.

Confirm Choices
· This screen displays two disk maps: one showing the system before you created the new drive and one 

displaying how the disk will appear after the new drive is created.



Installing Another Operating System - Windows XP
If you are installing Windows XP as an additional operating system (OS), here are some tips that can help you. 
These tips are categorized by wizard screen titles in the order you will see the screens.
· Select Disk 
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 

Select Disk
· Note that USB, FireWire, CD, and removable drives are not displayed.
· If there is only one physical disk in the machine, this screen will not be shown.
· Windows XP uses two different partitions: a boot partition (having most of the actual OS files), and a system 

partition (having just a few files for booting: BOOT.INI, NTLDR.COM, NTDETECT.COM, etc.). If you are installing 
Windows XP to a primary partition on disk 1, the system partition and boot partitions can be the same 
partition. However, if you are installing XP to a logical partition on disk 1, or to any partition NOT on disk 1, 
there must be a Primary FAT partition on disk 1 that can be used as the XP system partition.

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations that are valid for Windows XP are displayed. 
· If you move any Windows 98 or NT partitions to the right of the disk map, you may leave them unbootable 

because they will have been pushed outside of the 8-gigabyte boot code boundary.
· If you have a Logical Block Addressing-compatible Master Boot Record, the boot code boundary is not 

applicable.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave Selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, it would be best to 
deselect any partitions containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen. 
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Windows XP requires for

installation, how much free space is available on the disk.
· A Windows XP installation requires a minimum of 1 GB of space. We recommend having at least double or 

triple this space available to have room for applications and data you will create under Windows XP.

Label
· Giving your partitions meaningful labels helps you manage them easier.
· FAT and FAT32 labels are limited to 11 alphanumeric characters. NTFS labels can be up to 32 characters.

Primary/Logical
· Windows XP can be installed to either a primary or logical partition. See Select Disk, third bullet. We 

recommend Primary.



File System Type
· Windows XP must be installed to either a FAT, FAT32, or NTFS file system type. Historically, FAT was the 

preferred file system to install on because it is universally visible. However, it only supports disk sizes up to 
2 GB, and most disks are larger than that currently, so FAT32 or NTFS is recommended. You can install to FAT
and convert to NTFS during the Windows XP installation.

· Only valid file system types for Windows XP are displayed.
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active
· Setting a partition active means that you will boot to it.
· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD 

for Windows XP in the CD drive and continue with the installation.

Confirm Choices
· This screen displays two disk maps: one showing the system before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.



Installing Another Operating System – Linux
If you are installing Linux as an additional operating system OS, here are some tips that can help you. These tips 
are categorized by wizard screen titles in the order you will see the screens.
· Select Disk 
· Where to Create 
· Take Space From 
· Partition Properties 
· Set Partition Active 
· Confirm Choices 
· Create Linux Swap Partition? 

Select Disk
· Note that USB, FireWire, CD, and removable drives are not displayed.
· If there is only one physical disk in the machine, this screen will not be shown.
· If possible, you should place the Swap partition on a different disk than the Linux installation to enhance 

performance.

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations that are valid for Linux are displayed. 
· If you move any Windows 98 or NT partitions to the right of the disk map, you may leave them unbootable 

because they will have been pushed outside of the 8-gigabyte boot code boundary.
· Linux will perform better on most computers if the Swap partition is toward the beginning of the hard disk.
· When creating Linux partitions, do not set them up with Linux FDISK or Disk Druid. These programs render 

partition tables unreadable to other operating systems. They can be used to change partition types and set 
partition mount points. Newer versions of these programs will not cause these problems; consult your 
operating system documentation for more details.

Take Space From
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default, with the exception of the Linux installation partition.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the new partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the system 

partition) housing your existing OS so that the partitions will remain viable. If possible, deselect any partitions 
containing operating systems.

Partition Properties

Size
· The maximum size of the new partition is dependent upon your selections in the Take Space From screen. 
· The Partition Size, Minimum, and Maximum sizes are derived from how much space Linux requires for 

installation, how much free space is available on the disk.
· A Linux installation requires a minimum of 250 MB of space. We recommend having at least double or triple 

this space available to have room for applications and data you will create under Linux.
· The Linux Swap partition size should be 1 ½ to 3 times the amount of RAM on your system, but should not 

be greater than 500 MB.

Label
· Giving your partitions meaningful labels helps you manage them easier.
· Linux partition labels are limited to 16 alphanumeric characters.



Primary/Logical
· Linux can be installed to either a primary or logical partition. We recommend primary.

File System Type
· Linux must be installed to either an Ext2 or Ext3 file system type. To boot to Linux, the Linux Loader (usually

called LILO) must be installed in the root of the Linux Ext2 partition.
· Only valid file system types for Linux are displayed.
· Linux Swap must be installed to a Linux Swap file system type. If you selected a Linux Swap file type, this is 

selected for you.
· Click here for additional information on file system types (scroll down to the table in topic) and hidden 

partitions.

Set Partition Active
· Setting a partition active means that you will boot to it.
· Only a partition on the first hard disk can be active.
· Even if the partition is set active, you cannot boot to it until there is an operating system on it.
· If you set the new partition active, at the end of this wizard you will be prompted to place the installation CD 

for Linux in the CD drive and continue with the installation.

Confirm Choices
· This screen displays two disk maps: one showing the system before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.

Create Linux Swap Partition?
· Linux Swap files are recommended in conjunction with a Linux installation to increase performance.



About bootstrapping
Bootstrapping (also known as "dual-boot") is a method of installing an operating system (OS) where only the 
boot code is placed on the existing primary partition, and the majority of the OS code is located on a logical 
partition or a primary partition on another hard disk. Since many operating systems have requirements for being 
physically placed in the first X amount of a hard disk, bootstrapping is a way to maximize the use of that space.
Windows NT can be installed using bootstrapping. If you install Windows NT 4.0 in its own primary partition, it 
must be installed to a primary FAT partition on the first physical hard disk. After the OS has been installed, or 
during the installation process, you can convert the partition to NTFS to take advantage of the additional 
features inherent in that file system.
Using bootstrapping, the Windows boot files, such as NTLDR, NTDETECT.COM, and BOOT.INI, are contained in a 
primary partition that resides within the first 2 gigabytes of the primary hard disk. If this method is used, it is not
necessary to create a separate primary partition on the first hard disk and set it active. If you run the Windows 
NT setup program from within Windows 95/98, the bootstrapping method is used by default. This process will use
the NT Loader menu to select which OS to which you want to boot. To install NT to a separate primary partition, 
use PartitionMagic, the Install Another Operating System wizard, and BootMagic to complete the following items 

· Resize/move existing partitions on first physical hard disk with PartitionMagic.
· Create enough unallocated space to host the second OS.
· Create a primary partition, and add it to the boot management utility menu of BootMagic.
· Obtain necessary boot diskettes and installation media.
· Boot to the first installation disk, and follow the on-screen prompts.

Note: Only Windows NT, Windows 2000, and Windows XP can read data from an NTFS partition; should Windows 
become unbootable, you will not be able to access your data on the NTFS partition by booting to a system 
diskette. There are utilities that allow you to read and copy data from an NTFS partition if Windows NT suffers a 
catastrophic failure and cannot be repaired, but there is no guarantee of the utilities’ reliability.



Install Another Operating System Wizard
The following table provides a summary of the requirements of the partition to be created for a given operating 
system. This information is either covered by the wizard by default or provided again for reference when you 
need it for making a decision.
Operating 
System

Boots from 
Primary or 
Logical

Supported 
Partition Types

Boot Code 
Boundary

Space 
Required

DOS 6.22 and 
earlier

Primary FAT 2 GB 8 MB

Windows 95a Primary FAT 2 GB 90 MB
Windows 95b Primary FAT or FAT32 8 GB 90 MB
Windows 98 Primary FAT or FAT32 8 GB 175 MB
Windows 98se Primary FAT or FAT32 8 GB** 190 MB
Windows Me Primary FAT or FAT32 8 GB** 300 MB
Windows NT Primary* FAT or NTFS 2 GB 120 MB
Windows 2000 Primary* FAT, FAT32, or 

NTFS
8 GB** 650 MB

Windows XP Primary* FAT, FAT32, or 
NTFS

8 GB** > 1 GB

Linux (LILO***) Either Ext2, Ext3, and 
Linux Swap****

8 GB > 250 MB

*Windows NT/2000/XP must boot from a primary partition on the first drive. However, only a few Windows 
NT/2000/XP files must reside on that partition; the remaining files can reside on a logical partition, which can be 
located on the first or a subsequent drive. The Windows NT/2000/XP boot partition can be shared with another 
operating system .
**Having an LBA-compatible (Logical Block Addressing) MBR (Master Boot Record) will make the boot code 
boundary null with Windows Me/2000/XP.
***If you install LILO to a logical partition, it must be the first logical partition in the extended partition.
****Linux also supports the partition types FAT, FAT32, and NTFS (read - only).



Install Another Operating System - Select Operating System
Each operating system has its own requirements for installation. In general, you will need to boot with a CD, and 
then follow the on-screen prompts to complete the installation. PartitionMagic does not install the new OS for 
you; you must have the media necessary to do so. This wizard will walk you through each of these requirements.
The rest of the wizard will display different screens depending on the OS you choose on this screen.



Create Backup Partition - Tips
Use this wizard to create a backup partition used solely for your personal data files (items like personal letters or 
emails, lists, budgets, image files, and so forth). Click on the title below to see tips for that screen of the wizard.

· Select Disk 
· Where to Create 
· Take Space From Which Partitions? 
· Partition Properties 
· Confirm Choices 
· Configuration Help 

Select Disk
· Note that USB, FireWire, CD and removable drives are not displayed.
· If there is only one physical disk in the machine, this screen will not be shown.

Where to Create
· If your disk is empty, you will not see this screen in the wizard.
· Only locations that are valid for the operating system you have booted into are displayed.

Take Space From Which Partitions
· If the disk is empty, or if only one partition exists on the specified disk, you will not see this screen.
· All partitions are selected by default.
· To keep a partition from being resized, deselect it.
· The more partitions you leave selected, the larger the backup partition can be.
· PartitionMagic will try to not let you take too much space away from any other partition (especially the 

system partition) housing your existing OS so that the partitions will remain viable. If possible, deselect 
any partitions containing operating systems.

Partition Properties

Size
· The maximum size of the backup partition is dependent upon your selections in the Take Space From 

Which Partitions screen. 
· The Partition Size, Minimum, and Maximum sizes are derived from how much free space is available on 

the disk.

Label
· Giving your partitions meaningful labels helps you manage them easier.
· FAT and FAT32 labels are limited to 11 alphanumeric characters. NTFS labels can be up to 32 characters.

Primary/Logical
· Whether primary or logical is recommended depends on the operating system you are booted into.

File System Type
· The recommended file system type is based on your current OS, and only valid file system types for 

your current OS are displayed.

Confirm Choices
· This screen displays two disk maps: one showing the system before you created the new drive and one 

displaying how the hard disk will appear after the new drive is created.

Configuration Help
Tips on configuration can be found here.



DataKeeper Configuration Tips
When you click Finish, the machine may reboot automatically. The first time you run DataKeeper, you will go 
through a brief wizard to set up backup locations.
Help for DataKeeper is available from the Help menu or Help buttons on the dialog boxes.
To set up backup locations
1 Read the introductory screen. Click Next.
2 Select a Primary backup location. Click Next.

This is the location DataKeeper will back up to first.
3 Select a Secondary backup location. Click Next.

This location will be backed up to should the primary location be unavailable.
4 Click Finish.
To change backup locations, use the Backup Locations box on the DataKeeper main screen.
To save data to the backup partition
It is recommended that you back up to a partition on a physically different hard disk, if possible. If you save to a 
partition on same hard disk and experience a hard disk failure, you could lose your data. Below are two tips to 
save data to a backup partition.

· Most applications by default either save user data to the folder in which they are installed (typically the 
C:\ or the My Documents folders). When saving a file, you may need to select "File > Save As" and 
select the recently created backup partition as the destination.

· Change the default file location of your applications as well as the My Documents folder location setting
so that all of your data is being saved to the recently created partition. For example, in Microsoft Word 
2000, click Tools > Options > File Locations > click the Documents File Type > click Modify > select
the backup partition > click OK.

To save data directly to a removable media device
Use this option if 

· You want to back up your data to a separate location
· You have a removable media device (such as a CD-R or CD-RW) 
· You do not have a second hard disk or do not want to use a dedicated backup partition. 

You can configure DataKeeper to locate files in their current locations and save them to a removable media 
device. See the DataKeeper Help for more information.



Create Backup Partition
Use the Create Backup Partition wizard to create a location where you will save your data files. You can then 
install DataKeeper to save your data on a regular basis.
The backup partition can be 1) on the same hard disk, or 2) on a separate hard disk. It is recommended that you 
save your data on a separate hard disk. Separating data from the operating system partition has significant 
benefits:

· Backups are easier and faster.
· Data is protected from system crashes.
· Data is protected from some viruses.
· System migrations are simpler.
· Finding data is easier and faster.
· Data is accessible from multiple operating systems.

You can save your data to a partition on the same hard drive (similar to saving to C:/My Documents), and access 
and recovery of this data would be seamless. However, should you experience a hard disk failure, all the data on 
the failed disk could be lost.



NTFS Version Numbers
PartitionMagic cannot merge partitions that have different NTFS version numbers.

Where do version numbers come from?
The Windows operating system assigns version numbers to NTFS partitions when they are created. Windows NT 
4.0 creates version 1.2, Windows 2000 creates version 3.0, and Windows XP creates version 3.1. You cannot 
change NTFS version numbers for existing NTFS partitions using PartitionMagic.
If you create an NTFS partition using PartitionMagic, the version number for the partition will match the operating
system. (For example, if you create an NTFS partition while running under Windows 2000, the partition will be 
NTFS version 3.0.) If you create an NTFS partition under Windows 9x or with the PartitionMagic rescue diskettes 
(which run under DOS), the new partition will be NTFS version 3.1. 
Be aware that if you are running Windows NT 4.0 (prior to SP6) and you install Windows XP as a second 
operating system, Windows XP will promote the NTFS partitions to version 3.1, which could make Windows NT 
4.0 inoperable. This is a feature of Windows XP and is not related to PartitionMagic.

So if the version numbers don’t match, what can I do to fix them?
If you install Windows XP, it automatically "promotes" NTFS partitions to version 3.1. Then you can merge the 
partitions with PartitionMagic. If you do not want to upgrade to Windows XP, you cannot merge the mismatched 
NTFS partitions.



To move a file or folder from one partition to another
1 In the File Browser, right-click the file or folder you want to move > click Copy or Cut.
2 In the Look In drop-down list, click the partition you want to move the file or folder to.
3 Right-click anywhere in the new partition > click Paste.



To rename a file or folder
1 In the File Browser, right-click a file or folder > click Rename.
2 Type a new name > press <Enter>.
You can also double-click a name slowly to rename it.



To view the properties of a file or folder
1 In the File Browser, right-click a file or folder > click Properties.
2 View the properties, or change the attributes > click OK.

To view help for the attributes, click ? in the upper-right corner, and click the attribute.



To view another partition
1 In the File Browser, in the Look In drop-down list, click the down arrow > click the partition you want to view.



About USB, USB2, and FireWire Support
PartitionMagic supports external USB, USB2, and FireWire hard drives under Windows. Operations that are 
executed in boot mode are not supported on these devices.
You can see if an operation will be performed in boot mode by clicking View > Operations Pending. If an 
operation displays with the boot mode icon, it will not work on a USB, USB2, or FireWire drive. If any of the 
queued operations display with the boot mode icon, all of the queued operations will be applied in boot mode.



Additional Help

Error Messages
Error messages are documented in the online user guide. Please see User Guide below for places to access it.

User Guide
There are three ways to open the online user guide.

· From the PartitionMagic Help menu (Help > User Guide).
· From the Start menu (Start > Programs > PowerQuest PartitionMagic 8.0 > PartitionMagic 8.0 

Documentation > PartitionMagic User Guide.
· From the /English/Docs folder on the PartitionMagic CD.

Flash Tutorial
The PartitionMagic 8.0 Flash tutorial is a multimedia presentation of what partitions are and how you can use 
them. There are two ways to view it.

· From the PartitionMagic Help menu (Help > Flash Tutorial).
· From the /English/Docs folder on the PartitionMagic CD (pm8flash.exe).



To delete a file or folder
1 In the File Browser, click the file or folder you want to delete > click Delete > Yes.



About PartitionMagic
Imagine how disorganized your office would be if you kept all your files in one drawer. Surprisingly, this is similar 
to the way many people organize the space on their hard disks. With PartitionMagic, you can quickly and easily 
create partitions, which act as "file drawers," on your hard disks for storing valuable information such as data 
files, applications, and operating systems. Storing information in separate partitions helps you organize and 
protect your data, safely run multiple operating systems, and reclaim wasted disk space.
PartitionMagic enables you to secure your data by physically separating it from other files. Separate partitions 
also make backups to networks and removable drives easy.
PartitionMagic helps you reliably run multiple operating systems on the same computer. Some versions of 
PartitionMagic also include BootMagic, a powerful boot manager that helps you safely install new operating 
systems and lets you choose which operating system you want to use when starting your computer.
Because of limitations with the FAT file system which is DOS, Windows 95, and Windows 98, as much as 40 
percent of your hard disk space can be wasted. PartitionMagic reclaims wasted space quickly and safely by using
more efficient partition sizes. It can also convert FAT partitions to FAT32 and vice versa.
In addition to powerful partitioning features, PartitionMagic offers a variety of other options. For instance, you 
can perform partitioning operations and view the changes that will be made before applying them to your 
system. Additionally, you can view comprehensive information about your hard disk geometry and your 
hardware system, and you can resize root directories (in FAT) to make room for more long filenames.

Starting PartitionMagic
Besides starting PartitionMagic from the Windows Start menu, you can also start it from inside Windows Explorer 
or My Computer.
· From inside Windows Explorer or My Computer, right-click any drive object, then click PartitionMagic 8.0 

from the quick menu. You can also right-click on the My Computer icon on the desktop, then click 
PartitionMagic 8.0 from the quick menu.

What is new in PartitionMagic 8.0?
· New file management features that include the ability to browse files, and view and manipulate files or folders 

on multiple types of file systems.
· New NTFS features enabling you to choose the cluster size on creating a new NTFS partition or changing the 

cluster size of an existing NTFS partition, and NTFS format versioning (NTFS 1.4 to the latest). (This feature 
requires 256 MB of RAM for drives over 120 GB in size).

· Enhanced Copy Partition functionality letting you choose the partition type (logical or primary) for the 
destination partition and whether that partition is to be resized.

· Changes in the UI, primarily in the main screen, that adopts a Windows XP look and feel.
· Support for Linux EXT2 and EXT3 file systems.
· Support for partitions up to 160 GB, containing up to 145 GB of data.
· New and improved wizards.
· Macromedia Flash presentation to help you understanding partitions, operating systems, file systems, 

installing an additional operating system, and PartitionMagic best practices.
· Ability to boot into another operating system directly from the OS you are currently running with BootMagic for

Windows, and a "boot once" feature that lets you boot into a new OS and then reboot automatically to the 
original OS.

· PowerQuest DataKeeper, included with PartitionMagic 8.0, provides an easy way for you to back up your 
important data files for safekeeping.

{button ,JI(`',`H_Before_You_Run_PartitionMagic')} Before You Run PartitionMagic
{button ,JI(`',`H_PartitionMagic_Window')} The PartitionMagic Interface 
{button ,JI(`',`H_Four_Steps_to_Complete_a_Task')} Four Steps to Complete a Task 
{button ,JI(`',`H_To_change_PartitionMagic_preferences')} Change PartitionMagic Preferences 





Properties - Usage
The Usage property page is available for the FAT, FAT32, EXT2, EXT3, and NTFS file systems. This page displays 
the following information in bytes, megabytes, and as a percentage.

Nam
e

Shows the

Used Amount of 
used space on 
the selected 
partition, 
including 
space wasted 
by clusters

Unuse
d

Amount of 
unused space 
on the 
selected 
partition

Bad Amount of bad
space on the 
selected 
partition

Total Total amount 
of space on 
the partition 
(the sum of 
Used, Free, 
and Bad 
space)

PartitionMagic also displays this information in a pie chart.



Properties - Cluster Waste
The Cluster Waste property page applies only to partitions using the FAT or FAT32 file systems.

Nam
e

Shows the

Curre
nt 
Cluste
r Size

Current cluster 
size in bytes or 
kilobytes

Data Amount stored 
on the partition 
in bytes and 
megabytes

Waste
d

Amount of 
space on the 
partition in 
bytes and 
megabytes

Total Total amount of
space used in 
bytes and 
megabytes (the
sum of Data 
and Wasted 
space)

PartitionMagic also displays this information in a bar chart.



Properties - Partition Information
The Partition Info property page is available for all types of partitions, including free space and extended 
partitions.

Name Shows the
Partitio
n type

Partition type 
in hexadecimal
followed by a 
text 
description of 
the partition or
file system 
type (such as 
FAT, FAT32, 
NTFS, and so 
forth). The 
hexadecimal 
designation is 
the 
conventional 
way to display 
partition types.

Serial 
Numbe
r

Serial number 
of the 
partition's file 
system, if 
used.

First 
physic
al 
sector

Logical 
number and 
the location 
(cylinder, 
head, and 
sector) where 
the partition 
begins.

Last 
physic
al 
sector

Logical 
number and 
the location 
(cylinder, 
head, and 
sector) where 
the partition 
ends.

Total 
physic
al 
sectors

Number of 
sectors in the 
partition.

Physic
al 
Geome
try

Total number 
of cylinders, 
heads, and 
sectors on the 
physical disk 
where the 
partition 



resides.



Properties - File System Information
The file system property page that is displayed will correspond with the file system being used on the currently 
selected partition. For example, if the file system is FAT or FAT32, the page is FAT Info; if the file system is NTFS,
the page is NTFS Info, and so forth.

FAT
The FAT property page applies to partitions using the FAT or FAT32 file systems.

Name Shows the
Sector
s per 
FAT

Number of 
sectors in each 
file allocation 
table and the 
number of file 
allocation tables
on the selected 
partition.

Root 
directo
ry 
capacit
y

Number of 
possible entries 
and the number
of sectors in the
root directory. 
Because a 
FAT32 root 
directory can 
grow as 
needed, this 
line is blank for 
FAT32 
partitions.

First 
FAT 
sector

Logical sector 
number within 
the partition 
where the FAT 
begins.

First 
Data 
sector

Logical sector 
number within 
the partition 
where the data 
portion of the 
partition begins.
Number of 
bytes in files on 
the partition, 
the number of 
files, and the 
number of 
those files that 
are hidden.
Number of 
bytes in 
directories on 
the partition, 
the number of 



directories, and 
the number of 
those 
directories that 
are hidden.
Number of 
bytes used for 
OS/2 Extended 
Attributes and 
the number of 
files and 
directories 
affected by 
Extended 
Attributes
Number of 
bytes used for 
long filenames 
and the number
of files and 
directories 
using long 
filenames



Properties - NTFS
This property page applies to partitions using the NTFS file system.

Name Shows the
NTFS 
Version

NTFS version 
number. The 
NTFS version 
number does 
not match the 
OS version. For 
example, 
Windows NT 4.0
uses NTFS 
version 1.3.

Bytes 
per 
NTFS 
sector

Number of 
bytes in each 
logical sector on
the selected 
partition. (There
are always 512 
bytes in each 
physical sector.)

Cluster
size

Size of each 
cluster and the 
number of 
sectors in each 
cluster on the 
selected 
partition.

First 
MFT 
Cluster

Logical number 
of the first 
cluster in the 
master file table
(MFT).

File 
Record
Size

Size of file 
records in the 
MFT.
Number of files 
on the partition 
and the bytes 
and clusters 
allocated to 
them
Number of 
wasted bytes in 
file clusters
Number of 
indexes 
(directories) 
and the bytes 
and clusters 
allocated to 
them



Number of 
bytes and 
clusters 
reserved for 
other system 
structures



About PQBoot for Windows
You can use PQBoot for Windows in conjunction with PowerQuest BootMagic to switch to another operating 
system without changing your BootMagic configuration settings. 
You can also use PQBoot for Windows without having BootMagic installed. Then the settings you choose are 
"sticky" and will be in effect until you run PQBoot again or change the active partition with PartitionMagic.

1 Click Start > Programs > PowerQuest PartitionMagic 8.0 > PartitionMagic 8.0 Tools > PQBoot for 
Windows.
Under Windows 95/98/Me, PQBoot for Windows will only run if PQVXD.VXD is in the same directory as 
PQBOOT32.EXE.
PQBoot for Windows displays the primary partitions on your first hard disk.    

2 Choose the partition that you want to boot to.
PQBoot for Windows will enable you to choose a partition that does not include an operating system. If there is
no operating system on the active partition, you must have rescue disks or a boot disk to perform any 
operations.

3 Click Restart Now to reboot to the new partition immediately, or click Restart Later to boot to that partition 
the next time you boot the computer.

4 Click OK.
5 If you select Restart Now, a confirmation dialog appears. Click Yes to confirm.

When you reboot, PQBoot makes the selected partition active and hides the other primary partitions on the 
hard disk.
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