FireTune Information
Top Next

firefoxlustregelb
FireTune für Mozilla Firefox v1.x
© 2005 by Totalidea Software
http://www.totalidea.com

Diese Software ist Freeware! Sie darf frei verwendet, kopiert und verteilt werden, kommerzielle Verwendung ist untersagt! Bitte beachten sie bei der Weitergabe das alle Dateien vollständig bleiben, inklusive dieser Lizenz. Es ist strengstens untersagt kommerziellen Nutzen aus der Weitergabe dieses Programms (unabhängig davon ob es um Gewinn oder Kostenausgleich für die Weiterverbreitung der Software geht) zu ziehen. Dies gilt unabhängig davon, ob die Software als Einzelprodukt oder Teil einer Softwaresammlung angeboten wird. Es bedarf daher immer der ausdrücklichen Zustimmung der Rechteinhaber. Mit Installation bzw. Nutzung dieser Software stimmen Sie der Lizenzvereinbarung zu.

Bitte beachten Sie das Totalidea Software keinerlei Produktsupport für seine Freeware-Produkte gewährt. Für die aktuellste Version dieser Software besuchen Sie bitte:

http://www.firetune.com

oder schauen Sie ins Forum unter:

http://board.firetune.com

Übersetzung dieser Hilfedatei: © Carsten Becker & Johannes Radig, Team www.emulemasters.net

Inhaltsverzeichnis:

1. Was ist FireTune?
2. Was macht FireTune?
3. Wie kann man feststellen ob Firefox nach der Optimierung schneller ist?
4. Welche Veränderungen nimmt FireTune vor?
5. Benutzer Anleitung
6. Pläne für zukünftige Versionen
7. Sprach Unterstützung

1.) Was ist FireTune?

FireTune ist eine kostenlose Software-Anwendung die es ermöglicht verschiedenste Software-Einstellungen des Mozilla Firefox Browsers auf einfache Weise zu optimieren. FireTune basiert auf einem Artikel, erschienen bei TweakFaktor (http://www.tweakfaktor.com); es finden sich jedoch ähnliche Optimierungsanleitungen für den Firefox Browser auf verschiedensten Webseiten. Letztendlich optimiert FireTune ganz automatisch die Browser-Einstellungen für ein schnelleres surfen mit dem Firefox.

Systemanforderungen:

Diese Software wurde lediglich unter Windows XP getestet, sollte aber auch unter Windows 2000/2003 einwandfrei funktionieren, mit Ausnahme von Funktionen die als nicht kompatibel mit einem der genannten Betriebssystem Versionen bezeichnet sind.

Um diese Software zu nutzen, wird der Firefox Browser benötigt. Auf einigen Systemen wird zusätzlich die Microsoft Visual Basic Laufzeitbibliotheken benötigt. Normalerweise sind diese Dateien auf Windows 2000/XP/2003 bereits vorinstalliert. Sollten Sie eine Fehlermeldung beim Starten von FireTune erhalten, laden sie bitte die Laufzeitumgebung von der Microsoft Internetseite und installieren sie diese. Download hier.

2.) Was macht FireTune?

Anstatt alle wichtigen Einstellungen mühsam per Hand zu ändern, wie im TweakFactor Artikel beschrieben, braucht man nur FireTune, welches alle Änderungen automatisch im Firefox vollzieht.

Bekannte Probleme:

Einige FireTune-Anwender berichteten, daß nach der Optimierung alle installierten Erweiterungen deaktiviert und Cookies gelöscht waren. Der Fehler lies sich leider nicht von uns nachvollziehen, daher raten wir unbedingt zu einer Sicherung der aktuellen Konfiguration bevor eine Optimierung vorgenommen wird. So lässt sich später bei Problemen die alte Konfiguration ganz einfach wiederherstellen.

3.) Wie kann man feststellen ob Firefox nach der Optimierung schneller ist?

Es gibt eine ganz einfache Möglichkeit zu testen ob die Optimierung mit FireTune erfolgreich war. Einfach diese Anweisungen ausführen:

· Löschen Sie den Cache des Firefoxes im Einstellungs-Menü. Das ist sehr wichtig !!
· Bevor Sie den Firefox optimieren, besuchen sie http://www.nurmion.com/stopwatch und machen einen Geschwindigkeitstest mit http://www.mozilla.org/products/firefox
· Die benötigte Zeit um die Seite komplett zu laden wird im Browser-Fenster angezeigt. Notieren Sie sich diese Zeit.
· Löschen Sie den Cache des Firefoxes erneut. Das ist sehr wichtig !!
· Jetzt schließen Sie den Firefox und optimieren ihn mit FireTune.
· Starten Sie den Firefox erneut und wiederholen sie die Geschwindigkeitsmessung mit der Seite http://www.mozilla.org/products/firefox.
· Vergleichen Sie das angezeigte Ergebnis mit dem notierten Ergebnis vor der Optimierung.

Auf unseren Testgeräten erreichten wir eine Geschwindigkeitssteigerung von 1.25 Sekunden – die Ladezeit betrug 3,99 Sekunden vor der Optimierung und 2,74 Sekunden nach der Optimierung.

4.) Welche Veränderungen nimmt FireTune vor?

Performance Einstellungen

Eine Einschränkung bei allen Computeranwendungen ist die Notwendigkeit sich auf generelle Merkmale aufgrund der großen Bandbreite an Komponenten und der Netzwerk-Struktur zu beschränken. Das ist der Punkt an dem die Optimierung ansetzt. Der Firefox Browser mit Standardeinstellungen ist auch an ein breites Publikum gerichtet und wir hoffen, ihn mehr auf die individuellen Bedürfnisse einrichten zu können. Der Großteil der Informationen stammt aus dem hervorragenden Thread des MozillaZine Forum. Der erste Beitrag zeigt sehr detailliert, was jede der Einstellung bewirkt. Der Beitrag wird natürlich lang und unübersichtlich, daher haben wir die Inhalte aus mehreren Quellen zusammengefasst um es so angenehmer und einfacher zu gestalten.

Die Einstellungen auf der nachfolgenden Seite werden in die user.js Datei kopiert. Wir gehen dabei nicht bis ins kleinste Detail der Einstellungen, weil der Forumartikel sehr genau darauf eingeht, was die Einstellungen, die im ersten Beitrag beschrieben sind, bedeuten. Stattdessen wurden die Konfigurationen aus dem Forenbeiträgen ausgewählt, die sich als nützlich erwiesen haben – verbunden letztendlich mit ein paar Modifikationen unsererseits.

Schnelleinstellungen (nicht in Firetune enthalten)

user_pref("network.http.pipelining", true);
user_pref("network.http.pipelining.firstrequest", true);
user_pref("network.http.pipelining.maxrequests", 8);
user_pref("nglayout.initialpaint.delay", 0);

Dies sind einige Einstellungen mit denen wir vor einiger Zeit gearbeitet haben. Pipelining stellt mehrere Daten-Anfrage auf einmal und soll so die Geschwindigkeit erhöhen. Wir denken, daß der Internet Explorer dies früher auch tat und dass dies teilweise der Grund dafür war, daß er schneller gegenüber älteren Mozilla/Netscape Versionen war. Initial Paint Delay verlangsamt das darstellen der gesamten Seite, aber seit dem die User beginnen die Seite bereits zu betrachten, bevor sie vollständig geladen ist, sorgt scheinbar ein niedrigerer Wert für den Eindruck das sich die Seite schneller aufbaut.

Die folgenden Konfigurationen basieren auf den Empfehlungen der Forumbeiträge im Mozillazine-Thread, mit einigen speziellen Änderungen bei denen wir nicht mit der Allgemeinheit im Bezug auf alle Konfigurationen übereinstimmen.

Diese Einstellungen scheinen überall gleich zu sein, unabhängig von der Internet-Anbindung oder der Rechnergeschwindigkeit, kombiniert mit einigen Erweiterungen. Plug-In Verzeichnisse können mit „about:plugins" gefunden werde und die Verzögerung beim Öffnen der Favoriten ist ausgeschaltet.

user_pref("network.http.pipelining", true);
user_pref("network.http.proxy.pipelining", true);
user_pref("network.http.pipelining.maxrequests", 8);
user_pref("content.notify.backoffcount", 5);
user_pref("plugin.expose_full_path", true);
user_pref("ui.submenuDelay", 0);

Schneller Computer, schnelle Internetverbindung

Schneller Computer: CPU größer 1,5 Ghz und mindestens 512 MB Arbeitsspeicher ausgestattet.
Schnelle Verbindung: DSL, Kabel oder schneller.

In Bezug darauf bedeutet 'Langsamere' Verbindung ISDN oder ähnliche Verbindungen über zwei Leitungen, und 'Langsame' Verbindungen über ein analoges Modem um 57k.
Ein 'Langsamer' Computer ist ein Computer mit einer CPU langsamer als 1.5Ghz, und mit weniger als 512MB RAM.

user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("browser.cache.memory.capacity", 65536);

Firefox beansprucht 4MB Ram standardmäßig und in dieser Konfiguration haben wir ungefähr 65MB veranschlag (letzte Zeile). Dies kann aber geändert werden, entsprechend der Ausstattung.

Schneller Computer, Langsamere Internetverbindung

Diese Konfiguration ist für Leute gedacht mit einer weniger schnellen Anbindung. Damit meinen wir keine Wählverbindungen sondern eher langsame DSL (light)/Kabel-Verbindungen oder ISDN Verbindungen über zwei Leitungen.

user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("browser.cache.memory.capacity", 65536);

Schneller Computer, Langsame Internetverbindung

user_pref("browser.xul.error_pages.enabled", true);
user_pref("content.interrupt.parsing", true);
user_pref("content.max.tokenizing.time", 3000000);
user_pref("content.maxtextrun", 8191);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("network.http.max-connections", 32);
user_pref("network.http.max-connections-per-server", 8);
user_pref("network.http.max-persistent-connections-per-proxy", 8);
user_pref("network.http.max-persistent-connections-per-server", 4);
user_pref("nglayout.initialpaint.delay", 0);
user_pref("browser.cache.memory.capacity", 65536);

Langsamer Computer, Langsame Internetverbindung

user_pref("content.max.tokenizing.time", 3000000);
user_pref("content.notify.backoffcount", 5);
user_pref("content.notify.interval", 1000000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 1000000);
user_pref("content.maxtextrun", 4095);
user_pref("nglayout.initialpaint.delay", 1000);
user_pref("network.http.max-connections", 48);
user_pref("network.http.max-connections-per-server", 16);
user_pref("network.http.max-persistent-connections-per-proxy", 16);
user_pref("network.http.max-persistent-connections-per-server", 8);
user_pref("dom.disable_window_status_change", true);

Eine Änderung in dieser speziellen Konfiguration ist die Schlusszeile, in der die Statuszeile deaktiviert wird beim Seitenwechsel um Prozessorzeit zu sparen.

Langsamer Computer, Langsame Verbindung

Wir haben die „Tiefen" der Modem-User erreicht ;)

user_pref("content.max.tokenizing.time", 2250000);
user_pref("content.notify.interval", 750000);
user_pref("content.notify.ontimer", true);
user_pref("content.switch.threshold", 750000);
user_pref("nglayout.initialpaint.delay", 750);
user_pref("network.http.max-connections", 32);
user_pref("network.http.max-connections-per-server", 8);
user_pref("network.http.max-persistent-connections-per-proxy", 8);
user_pref("network.http.max-persistent-connections-per-server", 4);
user_pref("dom.disable_window_status_change", true);

Einige der Optionen, die wir nicht implementiert haben, trotz der Vorschläge und Wünsche im Mozillazine Beitrags, sind z.B. das cachen von SSL Seiten. Unabhängig von der Rechnerleistung bleibt zu sagen das Pipelining sinnvoll ist. Jene mit schnellen Rechnern und großem Arbeitsspeicher wünschen sich vielleicht einen größeren Speicherbereich für den Firefox während jene mit langsameren Rechnern den Speicherwert bei 4 MB belassen oder alternativ erhöhen können. Dies wurde jedoch in unseren Konfigurations-Dateien nicht umgesetzt. „Poweruser" können selbstverständlich auch die Status-Anzeige deaktivieren, um die CPU etwas zu entlasten.

5.) Benutzer-Anleitung

FireTune ist sehr einfach zu benutzen. Das Einzige was Sie tun müssen ist ein Back-up der aktuellen Firefox-Konfiguration zu erstellen. Dies lässt sich sehr einfach mit der integrierten Back-up Routine von FireTune machen. Anschließend brauchen Sie nur noch eine Auswahl der möglichen Optimierungs-Optionen treffen und FireTune wird den Browser entsprechend ihrer Auswahl optimieren.

· Beenden Sie den Firefox
· Starten Sie FireTune - wenn Sie die portable Version von Firefox nutzen und optimieren möchten, dann müpssen Sie FireTune zeigen wo sich die portable Firefox Version auf Ihrem Rechner befindet
· Falls noch kein Backup der Konfiguration (vor der Optimierung) gemacht wurde, sollten Sie das jetzt tun.
· Nachdem die Konfiguration gesichert wurde, treffen Sie ihre Auswahl aus den Optimierungs-Optionen. Für nähere Details zu den verschiedenen Optionen, bitte die oberen Abschnitte lesen.
· Klicken Sie auf den „Optimieren!" Button.
· FireTune wird den Firefox Browser gemäß ihrer Auswahl optimieren. Nach der Optimierung, einfach den Firefox Browser neu starten.
· Bitte bedenken Sie, daß FireTune nicht anzeigt, welche Konfiguration Sie bei der letzten Verwendung der Software ausgewählt hatten. Beachten Sie bitte ebenfalls, dass Sie ein
· Benutzerprofil auswählen müssen bevor sie die Konfiguration im Firefox ändern können.

Hinweise:

· Falls Sie ein Update von einer älteren FireTune-Version vornehmen, können Sie einfach die Einstellungen ihrer aktuellen Konfiguration überschreiben. Sie brauchen nicht extra die Originalkonfiguration wiederherstellen, bevor Sie mit der aktuellsten Version von FireTune arbeiten
· Wenn Sie zwischen einer installierten und einer portablen Version von Firefox wechseln möchten, dann können Sie dies über das 'Einstellungen' Menü tun

6.) Zukünftige Entwicklungen

Sie wissen eine interessante Optimierung für den Mozilla Firefox 1.x Browser? Etwas was auch andere Firefox Nutzer interessieren könnte? Sie möchten, dass wir es in die nächste Version mit einbinden? Falls ja, senden Sie uns eine email mit allen Details. Wir werden Ihre Vorschläge lesen und entscheiden ob wir Ihren Vorschlag mit einer der nächsten Versionen von FireTune umsetzen. Bitte bedenken Sie, dass wir nicht jede Mail die wir erhalten, beantworten können. Vielen Dank für Ihre Ideen!

7.) Sprach-Unterstützung

Wenn Sie FireTune in ihrer Sprache nutzen möchten, übersetzen Sie doch einfach die Sprach-Datei. Die Sprach-Dateien können im FireTune- Verzeichnis gefunden werden. Sie sind einfach zu bearbeiten mit z.B. Windows Wordpad oder einem beliebigen anderen Texteditor. Senden Sie uns ihre Übersetzung per Email damit wir sie der nächsten Version von FireTune hinzufügen können.

© 2005 by Totalidea Software. Alle Rechte vorbehalten. Sie stimmen mit dem Lizenzabkommen überein, wenn Sie Firefox verwenden. http://www.firetune.com


License Information
Previous Top

SOFTWARE LIZENZVERTRAG *FREEWARE*

SIE MÜSSEN DIESEM VERTRAG ZUSTIMMEN BEVOR SIE DIE SOFTWARE BENUTZEN!

1. ALLGEMEINES

Dieser Software Lizenzvertrag (nachfolgend "Vertrag" genannt) ist ein bindender Vertrag zwischen Ihnen, dem Endbenutzer (entweder natürliche oder juristische Person) und Totalidea Software NZ, Ltd. (nachfolgend "Totalidea Software"). Das Urheberrecht dieser Software (nachfolgend "die Software" genannt) und seine dazugehörigen Dokumente (einschließlich aller Dateien, Bilder, enthaltener Texte der Software) sowie alles begleitende schriftliche Material gehören, soweit nicht anders angegeben, Totalidea Software ("Hersteller") und sind durch nationale und internationale Rechtsvorschriften geschützt.

Durch Installation, kopieren, herunterladen oder anderweitige Nutzung der Software erklären Sie sich dem Hersteller gegenüber einverstanden, an die Bedingungen und Konditionen dieses Vertrages gebunden zu sein, welcher Ihre Benutzung der Software regelt. Wenn Sie mit dem Vertrag nicht einverstanden sind, dürfen Sie die Software nicht installieren.

Der Nutzer sollte die folgenden Bedingungen und Konditionen sorgfältig durchlesen:

2. LIZENZ

Totalidea Software gewährt, und der Kunde akzeptiert, eine nicht übertragbare und nicht exklusive Lizenz, die Software nach den folgenden Bedingungen und Konditionen zu nutzen:

· Sie dürfen die Software weitergeben.
· Sie dürfen beliebig viele Kopien der Software erstellen.

Was Sie nicht dürfen:

a) Die Software ohne schriftliche Genehmigung auf kostenpflichtige Datenträger oder auf Webseiten mit kostenpflichtigem Inhalt stellen. Wir bitten im allgemeinem um die Einholung einer Erlaubnis bei der Bereitstellung der Software auf öffentlichen Internetseiten oder Datenträgern.

b) Die Software vermieten, verleasen, weiterlizenzieren, modifizieren, verändern, adaptieren/portieren, zusammenführen, übersetzen, Reverse Engineering betreiben, dekompilieren oder in ein anderes Produkt mit aufnehmen sowie disassemblieren, um ähnliche Software herzustellen. Das gilt sowohl für die ganze Software als auch für alle einzelnen Teile der Software und ihrer zugehörigen Dokumentation.

3. BEDINGUNGEN

Diese Lizenzvereinbarung ist solange gültig, bis sie durch Vernichtung der Software und der dazugehörigen Dokumentation und aller Kopien beendet wird. Diese Lizenz wird ohne Benachrichtigung durch Totalidea Software mit sofortiger Wirkung beendet, wenn Sie den Bedingungen und Voraussetzungen dieser Lizenz nicht vollständig Folge leisten. Bei Nichteinhaltung einer dieser Bedingungen müssen Sie die Software und alle zugehörigen schriftlichen Materialien sowie sämtliche Kopien hiervon vernichten.

4. EIGENTUMSVORBEHALT

Die Software ist nur für Sie lizenziert, sie gehört Ihnen aber nicht. Der Hersteller behält sich sein Eigentumsrecht vor, auch auf alle folgenden Kopien davon, ungeachtet der Form oder des Mediums. Der Hersteller behält die Rechte am Titel, alle geschützten Rechte an der Software, inklusive, aber nicht limitiert, an allen Patenten, Urheberrechten, Geschäftsgeheimnissen, Markennamen, Handelsmarken und registrierten Handelsmarken.

5. GEWÄHRLEISTUNG

DER HERSTELLER GARANTIERT NICHT: DASS DIE SOFTWARE FREI VON FEHLERN UND AUSLASSUNG IST, DASS SIE OHNE UNTERBRECHUNG ARBEITET, DASS DIE SOFTWARE IHREN ANSPRÜCHEN ENTSPRICHT, DASS DIE ARBEIT MIT DER SOFTWARE UNUNTERBROCHEN ODER FEHLERFREI IST, DASS FEHLER IN DER SOFTWARE BEHOBEN WERDEN, ODER DASS NEUE VERSIONEN UND/ODER UPGRADES DER SOFTWARE ZUR VERFÜGUNG GESTELLT WERDEN. DIE SOFTWARE, JEDE INFORMATION, CODES, UND/ODER AUSFÜHRBARE DATEIEN WERDEN GELIEFERT "WIE SIE SIND" OHNE GARANTIE JEGLICHER ART. ZUM MAXIMALEN GESETZLICH ERLAUBTEN UMFANG, WEIST DER HERSTELLER ALLE GARANTIEN, SEIEN SIE AUSDRÜCKLICH ODER STILLSCHWEIGEND, INKLUSIVE, ABER NICHT LIMITIERT, ZUSICHERUNG ALLGEMEINER GEBRAUCHSTAUGLICHKEIT, TAUGLICHKEIT FÜR EINEN BESTIMMTEN ZWECK UND RECHTSVERLETZUNG VON SICH. DER KUNDE AKTZEPTIERT, DASS DIE NUTZUNG DER SOFTWARE UND IHRE LEISTUNG, SOWIE DOKUMENTATIONEN AUSSCHLIESSLICH AUF EIGENES RISIKO ERFOLGT. FÜR SCHÄDEN, DIE AUS DEM GEBRAUCH DIESER SOFTWARE RESULTIEREN, WIE Z.B. DATENVERLUST, ENTGEGANGENEM GEWINN, BETRIEBSUNTERBRECHUNG, VERLUST VON GESCHÄFTLICHEN INFORMATIONEN ODER ANDERE FINANZIELLE VERLUSTE, UNGEACHTET DEREN VORHERSEHBARKEIT, ÜBERNIMMT DIE FIRMA POLARSOFT KEINE HAFTUNG. DIE NUTZUNG ERFOLGT AUSSCHLIESSLICH AUF EIGENES RISIKO. DIE SOFTWARE WIRD SO LIZENSIERT "WIE SIE IST". DAS EINZIGE IHNEN ZUKOMMENDE RECHTSMITTEL IST DIE ERSTATTUNG DES KAUFPREISES (MAXIMALE HAFTUNG). ANSPRÜCHE AUF GESETZLICH UNABDINGBARE VORSCHRIFTEN ZUR PRODUKTHAFTUNG BLEIBEN UNBERÜHRT.