IMON

Modul IMON slouží k antivirovému monitorování komunikace mezi systémem a venkovním světěm (Internetem).

Okno IMON otevřete kliknutím na ikonu IMON v hlavním okně Control Centra.
Název IMON je zložen ze slov „Internetový MONitor“. Slouží na monitorování komunikace počítače s Internetem. Jeho nejdůležitější úlohou je testování přicházející pošty. IMON pracuje na úrovni winsocket a proto je nezávislý na používaném poštovním klientu.
V hlavním okně se zobrazuje počet testovaných, infikovaných a vyléčených objektů. Datum verze virové databáze je zobrazeno v závorce.

Kontrola aktivní – toto zaškrtávací políčko umožňuje zapnutí / vypnutí kontroly Internetu.
Nastavení – zobrazí seznam nastavení IMON.


Nastavenie Imona

Nastavení modulu IMON

Okno s nastavením modulu IMON má tři záložky:

  • POP3 - nastavení protokolu POP3
  • HTTP - nastavení protokolu HTTP
  • Rozšířené - dodatečné nastavení modulu


pop3

Nastavení protokolu POP3

Záložka POP3 umožňuje nastavit způsob kontroly elektronické pošty přicházející skrze protokol POP3.

Aktivovat kontrolu pošty – zapne/vypne kontrolu elektronické pošty přicházející pomocí protokolu POP3.

Porty používané protokolem POP3 – seznam portů, které jsou použity protokolem POP3. Standardní hodnota je 110. Pokud zadáváte více portů, oddělte je mezerou, čárkou nebo středníkem.

V části Úprava kontrolovaných zpráv můžete nastavit, jakým způsobem bude IMON označovat testované a infikované zprávy.

Volbou Přidávat upozornění do textu e-mailových zpráv nastavíte, zda se má na konec zpráv přidávat informace o vykonané kontrole antivirovým systémem NOD32. Varianty jsou tři: nikdy, jen do infikovaných zpráv, do všech kontrolovaných zpráv.

Modifikovat předmět infikovaných zpráv řetezcem - na začátek předmětu každé infikované zprávy se umístí zadaný text (v rámci textu zadejte "%VirusName%" na místo, na které se má vložit název nalezeného viru). V poštovním klientu lze potom nastavit, aby se infikované zprávy (začínající tímto textem) ukládaly do speciální složky, popřípadě rovnou mazaly.

Tlačítkem Nastavit v části Skener vyvoláte dialog pro nastavení vlastností skeneru.

Tlačítkem Nastavit v části Nastavení kompatibility vyvoláte dialog pro nastavení kompatibility modulu IMON s ostatnímím softwarem. Tuto volbu používejte pouze v případě, že je modul IMON v konfliktu s jiným programem.

Záložka Nastavení umožňuje nastavit metody a cíle testování.

Metody diagnostiky – umožňuje zvolit používané metody testování. Doporučujeme používat obě metody.
Citlivost heuristiky – doporučuje se Standardní citlivost. Při hloubkové heuristice může dojít ke zvýšení pravděpodobnosti falešného poplachu.
Cíle – umožňuje zapnout / vypnout testování speciálních druhů souborů. Doporučuje se testovat všechny druhy.
Přípony – spustí editor seznamu přípon testovaných souborů. Pokud je zvolena tato volba, doporučujeme ponechat standardní seznam přípon.

Pod záložkou Akce můžete zvolit akci, která se vykoná v případě zachycení infekce v poště. Rozdílným druhům objektů (soubory, archivy, ...) lze přiřadit rozličné akce.
Pokud je nalezen virus – zvolte akci, která se vykoná v případě nalezení infekce. Pokud by byla léčba neúspěšná, lze navolit alternativní akci.
Neléčitelné viry – zvolte akci, která se vykoná v případě, že se nepodaří vyléčit infikovaný soubor.
Standardní – nastaví standardní hodnoty doporučené výrobcem.


pop3 kompatibilita

Kompatibilita protokolu POP3

Při standardním nastavení je modul IMON nastaven v režimu maximální efektivnosti, což znamená, že je k dispozici celý jeho potenciál. Pokud se po instalaci NOD32 vyskytují problémy při komunikaci s poštovním klientem, je možné, že některé činnosti vykonané modulem IMON působí rušivě vůči cílové aplikaci. V takovém případě zkuste posunout ukazatel směrem doleva, potvrdit nové nastavení a opět vyzkoušet stahování pošty. Maximální kompatibilita znamená, že některé funkce modulu nebudou k dispozici.


http

Nastavení protokolu HTTP

Záložka HTTP umožňuje nastavit způsob kontroly dat, přicházejících přes protokol HTTP (webové stránky).

Aktivovat kontrolu protokolu HTTP – zapne/vypne kontrolu dat, přicházejících přes protokol HTTP.

Porty používané protokolem HTTP – seznam portů, které používá protokol HTTP. Pokud zadáte větší množství portů, oddělte je mezerou, čárkou nebo středníkem.

Automaticky detekovat HTTP komunikaci i na jiných portech - zapne automatickou detekci HTTP komunikace na všech portech. Komunikace HTTP může záviset i na prezentované stránce a proto je bezpečnější kontrolovat všechny porty.

V části Akce nastavíme stupeň interakce modulu IMON při zachycení infiltrace přicházející z Internetu.

Zobrazit varovné okno a nechat vybrat akci - IMON zobrazí okno s upozorněním o infiltraci a umožní uživateli přerušit spojení.

Automaticky zabránit stažení infikovaného souboru - pokud je nalezen infikovaný soubor, IMON automaticky přeruší komunikaci s danou stránkou.

Tlačítkem Nastavit v části Nastavení kompatibility vyvoláte dialog pro nastavení pracovního režimu modulu IMON při spolupráci s jednotlivými HTTP klienty.

Modul IMON pracuje ve dvou základních režimech: „pasivním“ a „aktivním“ . V pasivním režimu průběžně odevzdává procházející části stahovaného souboru cílové aplikaci a uchovává si jejich dočasnou kopii. Při zachycení poslední části souboru proběhne testování a pokud je nalezena infekce, zobrazí se varovné okno a přeruší spojení. Nevýhodou tohoto postupu je, že již přenesená část programu může obsahovat podstatnou část škodlivého kódu. Mimo to, pokud se aplikace pokusí opakovaně stáhnout infikovaný soubor, může využít již v minulosti staženou část a z Internetu vyžádat pouze zbytek souboru; IMON v takovém případě nemusí být schopen ve zbytku souboru infekci najít.

V aktivním režimu stáhne IMON celý soubor, ten následně otestuje a až potom předá cílové aplikaci. Tento postup je bezpečnější, protože v případě infiltrace se do cílové aplikace nedostane žádná část stahovaného souboru. Nevýhodou je, že aplikace dostane všechny data naráz, takže nemůže správně zobrazit průběh stahování (proto IMON při stahování delším než 5 sekund zobrazuje průběh v samostatném okně). Pro určitý typ údajů, které vyžadují průběžný tok (například multimedia) se tento způsob nehodí.

Automaticky přepnout do pasivního (kompatibilního) režimu pro soubory větší než ... KB - při stahování větších souborů než je uvedeno se automaticky využije pasivní režim.


http kompatibilita

Nastavení kompatibility HTTP

Dialog Nastavení kompatibility HTTP umožňuje individuální nastavit pracovní režim modulu IMON podle používané aplikace.

Vyšší efektivnost - IMON bude pracovat v aktivním režimu.

Vyšší kompatibilita - IMON bude pracovat v pasivním režimu.


IMON - rozšířené nastavení

Rozšírené nastavení modulu IMON

Zaznamenávat pokusy o útok na tento počítač do virového protokolu - pokud je tato volba zapnuta, pokusy o útok infekce budou zaznamenány do virového protokolu. Některé infiltrace se snaží o zneužití bezpečnostních děr v operačním systému útokem na porty PC. Vypnutí této volby neovlivní chod paketového skeneru jako takového.

Automaticky detekovat změny síťových nastavení a automaticky opravit nastavení programu - pokud je tato volba zapnuta, IMON se pokusí opravit LSP pro zajištění správné funkce síťového (paketového) a poštovního skeneru. Pokud dochází k problémům s dostupností sítě, zkuste tuto volbu vypnout.

Oprav teď – vykoná výše popsanou činnost okamžitě.

Tlačítkem Editovat otevřete dialog s aplikacemi vyloučenými z testování modulem IMON.

Posuvníkem v části Zobrazení nastavíte transparentnost okna, ve kterém se zobrazuje průběh stahování dlouhých souborů.


Vyloučení aplikací

V dialogu Vyloučené aplikace můžete zadat aplikace, které budou kompletně vyloučeny z testování internetovým modulem IMON.

Přidat - zobrazí se systémový dialog pro výběr souboru. Vybraný soubor se přidá do seznamu vyloučených aplikací.

Odebrat - označený soubor se vymaže ze seznamu vyloučených aplikací.

OK - potvrdí všechny vykonané změny v seznamu vyloučených aplikací.

Zrušit - zruší všechny změny.


Nastavenie Imona

Nastavení IMON

Porty používané protokolem POP3 – seznam portů, které jsou použity protokolem POP3. Standardní hodnota je 110. Pokud zadáváte více portů, oddělte je mezerou, čárkou nebo středníkem.

Povolit možnost odstraňování infiltrací – pokud je toto políčko zaškrtnuto, IMON se pokusí odstraňovat viry z napadených e-mailů.

Pokus o modifikaci přijímané pošty je zásahem do komunikace mezi poštovním klientem a POP3 serverem. V některých případech může dojít k problémům s přijímáním pošty. Pokud se po instalaci NOD32 začaly vyskytovat problémy s příjmem pošty, vypněte toto nastavení.
Přidávat upozornění do textu e-mailových zpráv - ve zvoleném případě bude IMON zapisovat do e-mailu informace o vykonané kontrole.
Nastavit – umožňuje nastavit další možnosti modulu IMON, především strategii vyhledávání virů.

Automaticky detekovat změny síťových nastavení - při změně nastavení sítě se IMON pokusí automaticky přizpůsobit nové situaci.
Oprav teď – po stisku tlačítka se IMON pokusí přizpůsobit nové situaci okamžitě.

Záložka Nastavení umožňuje nastavit metody a cíle testování.

Metody diagnostiky – umožňuje zvolit používané metody testování. Doporučujeme používat obě metody.
Citlivost heuristiky – doporučuje se Standardní citlivost. Při hloubkové heuristice může dojít ke zvýšení pravděpodobnosti falešného poplachu.
Cíle – umožňuje zapnout / vypnout testování speciálních druhů souborů. Doporučuje se testovat všechny druhy.
Přípony – spustí editor seznamu přípon testovaných souborů. Pokud je zvolena tato volba, doporučujeme ponechat standardní seznam přípon.

Pod záložkou Akce můžete zvolit akci, která se vykoná v případě zachycení infekce v poště. Rozdílným druhům objektů (soubory, archivy, ...) lze přiřadit rozličné akce.
Pokud je nalezen virus – zvolte akci, která se vykoná v případě nalezení infekce. Pokud by byla léčba neúspěšná, lze navolit alternativní akci.
Neléčitelné viry – zvolte akci, která se vykoná v případě, že se nepodaří vyléčit infikovaný soubor.
Standardní – nastaví standardní hodnoty doporučené výrobcem.