Modul NOD32

Okno NOD32 otevřete kliknutím na ikonu NOD32 v hlavním okně Control Centra.
Modul NOD32 se aktivuje požadavkem uživatele, proto se někdy označuje jako on-demand skener. (Jeho doplňkem je AMON, on-access skener, tedy modul, který se aktivuje při pokusu o přístup k souborům.)

Spustit NOD32 - spustí modul NOD32 a umožní zvolit cíle testování.
Lokální - spustí testování lokálních disků modulem NOD32.
Diskety - spustí testování disket modulem NOD32.

Modul je NOD32 možno spustit i kliknutím na ikonu pracovní plochy (v případě, že jste při instalaci zvolili tuto možnost) nebo v menu START - Programy - Eset - NOD32.
Testování disku, adresáře nebo souboru modulem NOD32 je možno spustit i v průzkumníkovi Windows tak, že na daný disk, adresář nebo soubor kliknete pravým tlačítkem myši a zvolíte Antivirový systém NOD. Tuto vymoženost lze aktivovat během instalace.

Po spuštění modulu NOD32 se zahájí automaticky test integrity modulu a následně i test přítomnosti virů v operační paměti.


Hlavní okno

On-demand scanner (též nazýván jako NOD32, skener na požádání) se používá na kontrolu různých cílů určených uživatelem. NOD32 můžete manuálně spustit, když kliknete na ikonu NOD32 na Vaší pracovní ploše. Spuštěním skeneru se začne automaticky kontrolovat operační paměť na přítomnost virů. Kontrola vlastní integrity NOD32 se spustí taktéž automaticky po spuštění skeneru.

NOD32 skener může být taky spuštěn přes NOD32 Control Center bez zásahu uživatele - pomocí plánovaného testu. Na nastavení plánovaného testu je určen Plánovač. Plánovač se nachází v hlavním okně NOD32 Control Center v sekci Nástroje systému NOD32.

Hlavní okno NOD32 skeneru obsahuje pět záložek (Cíle diagnostiky, Protokol, Akce, Nastavení, Profily). Podrobné informace o jednotlivých částech jsou uvedeny níže.

Dolní část hlavního okna NOD32 skeneru zůstává bez ohledu na vybranou záložku shodná. Specifikace a popis je uveden níže.

Řídící tlačítka

Diagnostika

Toto tlačítko vyvolá testování všech označených cílů. Pokud máte před spuštěním diagnostiky otevřenou záložku Cíle diagnostiky, tato je automaticky nahrazena po spuštění záložkou Protokol, ve které se zobrazují informace o výsledku testování. Během testování se tlačítko Diagnostika změní na tlačítko Přerušení, kterým můžete test ukončit. Pokud bude během testování nalezen infikovaný soubor, nebo pravděpodobně infikovaný soubor, informace se o této skutečnosti zobrazí červeným písmem. Léčit infikovaný soubor můžete až po ukončení diagnostiky. Léčení můžete vykonat kliknutím na tlačítko Léčit, které je popsáno níže, nebo přechodem kurzoru na infikovaný soubor v protokolu a kliknutím na něj pravým tlačítkem a následným zvolením volby Léčit z menu

Léčení

Kliknutím na tlačítko Léčení spustíte testování všech označených cílů. V případě, že se během testu objeví virus, uplatní se akce, které jsou definovány v záložce Akce. Záložka akce je popsána níže. Během testování se tlačítko Léčení změní na tlačítko Přerušení, kterým můžete testování ukončit.

Konec

Tímto tlačítkem můžete ukončit program NOD32 - on-demand skener. Pokud byly během chodu programu vykonány změny v nastavení, před ukončením budete na tuto skutečnost upozorněny dotazem, zda je chcete uložit do aktuálního profilu.

Informace o verzi

V levém spodním rohu jsou zobrazeny informace o nainstalované verzi virové databáze a datumu uveřejnění této verze. Na konci se nachází verze operačního systému.

Nápověda

Volbou této možnosti vyvoláte nápovědu. Shodného efektu dosáhnete i po stlačení klávesy F1.

Záložky nastavení

  • Cíle diagnostiky
  • Protokol
  • Akce
  • Nastavení
  • Profily


Cíle diagnostiky

V záložce Cíle diagnostiky můžete nastavit disky, adresáře a soubory, které se mají testovat. Jednotlivé položky označíme dvojím kliknutím.

Disky:
Lokální - umožňuje naráz označit nebo odznačit všechny lokální disky.
Diskety - umožňuje naráz označit nebo odznačit všechny diskety.
Všechny - označí vše.
Odznač - odznačí vše.

Adresáře a soubory:
Přidat - zobrazí dialog, který umožňuje přidat adresář nebo soubor.
Smazat - odstraní označený adresář nebo soubor ze seznamu testovaných cílů.
Všechny - označí všechny zobrazené adresáře a soubory.
Odznačit - odznačí všechny zobrazené adresáře a soubory.

Tlačítka ve spodní části okna (zůstávají stále stejná):
Diagnostika - spustí testování označených cílů. Okno se přepne na záložku Protokol, ve kterém se zobrazují průběžné výsledky testu. Během testování se tlačítko Diagnostika změní na Přerušení, kterým lze test přerušit.
Léčení - spustí test označených cílů. V případě, že je během testování nalezen virus, vykoná se akce definovaná v záložce Akce.
Konec - ukončí modul NOD32. Pokud jste během testu programu změnili nastavení, objeví se dotaz, zda ho chcete uložit do aktuálního profilu.
Nápověda - vyvolá nápovědu programu. Nápovědu lze vyvolat i stiskem klávesy F1.

Nalevo od tlačítek je zobrazena informace o využívané virové databázi (v závorce datum uveřejnění) a o operačním systému.


Protokol o kontrole

V záložce Protokol se zobrazuje průběh a výsledky testování. Okno lze posouvat pomocí vertikální lišty. Další vlastnosti protokolu můžete nastavit v záložce Nastavení.
Součástí protokolu jsou: informace o nainstalované verzi modulu NOD32, datum a čas diagnostiky, infikované soubory (zobrazují se červenou barvou), soubory, které nebylo možné kontrolovat z důvodů některé z chyb (zobrazují se modrou barvou), celkový počet testovaných a infikovaných souborů. Protokol se přikládá do protokolového systému Control Centera v záložce Protokoly skeneru NOD32.

Během testování se ve spodní části okna zobrazují informace o právě kontrolovaném adresáři.
Rolování - aktivuje automatické rolování okna protokolu.

Pokud kliknete pravým tlačítkem do protokolu, zobrazí se kontextové menu:
Smazat protokol - smaže protokol.
Léčit - pokusí se vyléčit označený soubor.
Informace - zobrazí podrobnější informace o označeném řádku protokolu.

Tlačítka ve spodní části okna:
Diagnostika - spustí testování označených cílů. Okno se přepne na záložku Protokol, ve kterém se zobrazují průběžné výsledky testování. Během testování se tlačítko Diagnostika změní na Přerušení, kterým lze test ukončit.
Léčení - spustí testování označených cílů. Pokud je během testu nalezen virus, vykoná se akce definovaná v záložce Akce.
Konec - ukončí modul NOD32. Pokud jste během chodu programu změnili nastavení, zobrazí se dotaz, zda je chcete uložit do aktuálního profilu.
Nápověda – vyvolá nápovědu programu, kterou lze vyvolat i klávesou F1.

Nalevo od tlačítek se zobrazuje informace o využité virové databázi (v závorce datum uveřejnění) a o verzi operačního systému.

Protokol o kontrole je první záložka, která se Vám zobrazí po spuštění skeneru NOD32. Po kontrole operační paměti a souboru nod32.exe se záložka zamění za Cíle diagnostiky.

Protokol o kontrole obsahuje cenné informace o každé spuštěné diagnostice. Vlastnosti zobrazení uvedených informací můžete nastavit ve spodní části záložky Protokol v Nastavení. Rolování protokolu zajistíte aktivací políčka rolování. Zobrazené informace lze prohledávat i pomocí vertikální lišty na pravé straně okna.

Pokud je spuštěna diagnostika, ve spodní části se zobrazuje informace o momentálně kontrolovaných adresářů. Rotující znak v pravé dolní části indikuje činnost.

V záložce Nastavení jsou další možnosti nastavení protokolu - formát a parametry souboru. Protokol diagnostiky má standardně jméno nod32.log a nachází se v adresáři do kterého se nainstaloval NOD32. Název soubory lze změnit. Informace o diagnostice jsou do souboru uloženy i v případě, že je test přerušen nebo program ukončen. Informace mohou být do souboru uloženy dvěma způsoby: připojením, nebo přepsáním starého záznamu.

Obsah protokolu o kontrole

Každý protokol o kontrole obsahuje informace o aktuální verzi testovacího nástroje. Taktéž obsahuje informace o datumu, čase diagnostiky, zobrazuje infikované soubory (červené), soubory, které nebyly testovány kvůli chybě (modře) a celkové informace - počet testovaných souborů, počet nalezených virů, čas ukončení a celkový čas testu. Sekce Poznámky poskytuje vysvětlení k chybám, které se během objevily.

Protokol o kontrole je integrován do protokolového systému v NOD32 Control Center pod názvem Protokoly skeneru NOD32. Pro další podrobnosti o všech log souborech vytvořených NOD32 Control Centerem klikněte sem.

Užitečná rada: informace v protokolu můžete smazat tak, že pravým tlačítkem myši kliknete do protokolu a vyberete možnost Smazat protokol. Léčit infikovaný soubor můžete po kliknutí pravým tlačítkem do prostoru a vybráním volby Léčit. Pokud NOD32 dokáže tento virus léčit, tato akce se uplatní.


Akce NOD32

V záložce Akce můžete nastavit události, které se vykonají v případě zachycení viru. Akce je možno nastavit odlišně pro každý druh objektu.

Soubory / Boot sektory / Paměť - vyberte typ objektu, pro který chcete nastavit akci. V záložce Nastavení můžete přidat další druhy testovaných objektů.
Léčit - antivirový systém se pokusí vyléčit napadaný soubor. Tato možnost nemusí být vždy k dispozici. Ve sloupci neléčitelné viry nastavte alternativní akci, která se vykoná v případě, že soubor není možno vyléčit.
Upozornit / nabídnout akci - program zobrazí varovné okno a nabídne různé akce.
Ponechat beze změny - program bude ignorovat virovou infiltraci.
Přejmenovat - program změní příponu napadeného souboru.
Smazat - program smaže infikovaný soubor.
Nahradit - program se pokusí nahradit zavirovaný boot sektor původním. (Tato možnost je k dispozici pouze pro boot sektory).
Uložit do karantény - pokud je zaškrtnuto, infikovaný soubor se uloží do karantény.
Standardní - nastaví standardní akce doporučené výrobcem.

Pokud se jakákoliv z vybraných akcí liší od standardního nastavení, upozorní Vás na to zpráva ve spodní části okna. Na uplatnění standardního nastavení pro všechny objekty můžete využít tlačítka Standardní.

Tlačítka ve spodní části okna (zůstávají shodné u všech záložek):
Diagnostika - spustí testování označených cílů. Okno se přepne na záložku Protokol, ve které se zobrazují průběžné výsledky testování. Během testu se tlačítko Diagnostika změní na Přerušit, kterým je test možné ukončit.
Léčení - spustí testování označených cílů, ovšem při nalezení viru během testu se vykonají akce definované v záložce Akce.
Konec - ukončí modul NOD32. Pokud jste během chodu programu změnili nastavení, zobrazí se dotaz, zda je chcete uložit do aktuálního profilu.
Nápověda - vyvolá nápovědu programu. Nápovědu můžete vyvolat i stiskem klávesy F1.

Nalevo od tlačítek se zobrazuje informace informace o použité virové databázi (v závorce je datum uveřejnění databáze) a verze operačního systému.


Nastavení NOD32

Nastavení

V záložce nastavení můžete můžete ovlivnit strategii detekce virové infiltrace a dalšího chování modulu NOD32.

Objekty diagnostiky - umožňuje nastavit, které typy objektů má modul NOD32 testovat.
Metody diagnostiky – umožňuje označit, které metody má modul NOD32 využívat. Doporučuje se využít obě metody.
Citlivost heuristiky – umožňuje nastavit citlivost heuristického algoritmu. Doporučuje se hodnota Standardní. Při hloubkové heuristice dochází ke zvýšení pravděpodobnosti falešného poplachu.

Vypisovat všechny soubory - v případě zatržení tohoto pole budou do protokolu zapisovány všechny testované soubory. Tato možnost výrazně zvyšuje velikost protokolu na disku, lze ji proto doporučit jen ve výjimečných případech. Pokud je pole neaktivní, do protokolu se zapisují pouze soubory, u kterých došlo k závažné události (zavirovaný soubor nebo chyba při testování daného souboru).
Zvukový signál - v případě, že je toto pole zaškrtnuto, při nalezení viru bude vydán zvukový signál.
Používat MAPI rozhraní - umožňuje modulu přistupovat k poštovním souborům, které využívají rozhraní MAPI. Příkladem je MS Outlook nebo MS Exchange.

Protokol povolen - pokud je políčko aktivní, modul NOD32 generuje protokol o diagnostice.
Zarovnání výpisu - pokud je políčko aktivní, příliš dlouhé řádky v protokolu budou zarovnány.
Připojení - výsledky následujícího testu budou připojeny za konec existujícího protokolu.
Přepsání - před následujícím testem dojde k vymazání protokolu.
Maximální délka - zadejte maximální délku protokolu v KB.
Název - zadejte název souboru, do kterého se bude ukládat protokol.
Přípony - zobrazí editor přípon testovaných souborů. Seznam přípon je aktualizován výrobcem a doporučuje se ho měnit.
Rozšířené - zobrazí dialog s rozšířeným nastavením modulu NOD32.

Tlačítka ve spodní části okna (zůstávají shodná):
Diagnostika - spustí testování označených cílů. Okno se přepne na záložku Protokol, ve které se zobrazují průběžné výsledky testování. Během testování se tlačítko Diagnostika změní na Přerušení, kterým lze testování ukončit.
Léčení - spustí testování označených cílů. V případě, že bude během testu nalezen virus, vykoná se akce definovaná v záložce Akce.
Konec – ukončí modul NOD32. V případě, že jste během chodu programu změnili nastavení, objeví se dotaz, zda je chcete uložit do aktuálního profilu.
Nápověda – vyvolá nápovědu programu. Nápovědu můžete vyvolat i stiskem F1.

Nalevo od tlačítek je zobrazena informace o využívané virové databázi (v závorce je datum uveřejnění) a o verzi operačního systému.


Editor přípon

Editor přípon slouží pouze pro výjimečné případy a jeho nastavení se nedoporučuje měnit. Odstraněním některé z přednastavených přípon můžete negativně ovlivnit činnost antivirové ochrany a můžete tak způsobit infikování Vašeho počítače. Naopak přidáním zbytečné přípony a nebo zaškrtnutím možnosti Testovat všechny soubory snižujete rychlost počítače. Seznam přípon je pravidelně aktualizován.

Hlavní část okna tvoří seznam testovaných přípon. Otazník ("?") v příponě znamená libovolný znak, hvězdička ("*") znamená libovolnou posloupnost znaků.

Potvrdit - potvrdí změny vykonané v seznamu přípon a ukončí dialog.
Zrušit - ukončit dialog bez vykonání změn.
Přidat - umožňuje přidat novou příponu do seznamu, pomocí speciálního dialogu.
Odstranit - odstraní příponu ze seznamu.
Standardní - obnoví standardní nastavení.
Testovat soubory bez přípon - pokud je toto políčko zaškrtnuto, budou se testovat i soubory bez přípony.
Testovat všechny soubory - po zaškrtnutí tohoto políčka se začnou zobrazovat přípony, které se nemají testovat.


Přidání nové přípony

Zadejte příponu a potvrďte tlačítkem Potvrdit.
V názvu přípony můžete využít zvláštní znaky: otazník ("?") a hvězdičku ("*"). Otazník představuje libovolný znak, takže například "OV?" vyjadřuje všechny troj-písmenné přípony začínající písmeny OV. Hvězdička představuje libovolnou posloupnost znaků, takže například "A*" vyjadřuje všechny přípony, začínající písmenem A, včetně samotného písmena A.
Testování souborů bez přípony zadáte tak, že zrušíte tento dialog a v editoru přípon zaškrtnete políčko Testovat soubory bez přípony.


NOD32 - Rozšířená nastavení

V rozšířeném nastavení modulu NOD32 můžete definovat, kdy se budou zasílat zprávy o virových infiltracích a chybách při testování. Podrobnosti o odesílání zpráv nastavíte v Control Centera v menu Nastavení – Upozornění.

V případě detekce infiltrace, objevení se chybového stavu, dokončení aktualizace, nebo při jiné důležité události může být zaslána zpráva o této skutečnosti na předdefinovanou e-mailovou adresu, popřípadě na zvolený počítač. Okno rozšířených nastavení slouží pro rychlé spuštění upozorňujícího systému. Pokud chcete znát další detaily o bližších nastaveních upozorňujícího systému, nahlédněte do odpovídající sekce manuálu NOD32 Control Center.


Nod32 Profily

Profily

V záložce Profily si můžete vybrat profil, popřípadě vytvořit novou. Jednotlivé profily mohou obsahovat odlišná nastavení diagnostiky, metod detekce a akcí.

Standardní - změní nastavení aktuální profil na standardní.
Ochránit tento profil heslem - při pokusu o změnu profilu bude program vyžadovat heslo. Heslo je společné pro všechna nastavení antivirového systému NOD32 a nastavuje se v Control Center, v záložce Všeobecné.

Záložka Profil slouží k vytvoření, nebo k selekci profilu. Do jednotlivých profilů můžete uložit různé parametry, které se uplatní při testování.

Vytvoření profilu:

  • Nastavte parametry v záložkách tak, jak chcete, aby byly nastaveny v profilu
  • Klikněte na ikonu Profil v záložce Profil
  • Změnit aktuální profil můžete kliknutím na tlačítko Uložit. V případě vytvoření nového tlačítko Nový
  • Zadejte Název nového profilu
  • Klikněte na tlačítko Uložit

Tlačítka ve spodní části okna (zůstávají totožná ve všech záložkách):
Diagnostika - spustí testování označených cílů. Okno se přepne na záložku Protokol, ve kterém se zobrazují průběžné výsledky testování. Během testování se tlačítko Diagnostika změní na Přerušení, kterým lze test ukončit.
Léčení - spustí testování označených cílů. V případě nalezení viru je vykonána akce definovaná v záložce Akce.
Konec - ukončí modul NOD32. Pokud jste během chodu změnili nastavení, objeví se dotaz, zda je chcete uložit do aktuálního profilu.
Nápověda - vyvolá nápovědu programu. Nápovědu lze vyvolat i stlačením klávesy F1.

Nalevo od tlačítek se zobrazuje informace o využívané virové databázi (v závorce je datum uveřejnění) a verzi operačního systému.


Výběr konfigurace

Výběr profilu

Při plánování testování vyberte profil s vhodnou konfiguraci. Profily lze vytvářet v dialogu NOD32 – Spustit NOD32 – Profily.


Uložení profilu

Tlačítkem OK lze v tomto dialogu potvrdit a tím i uložit zadaný profil na disk.


Co dělat, pokud byl nalezen virus

V první řadě si je potřeba zapamatovat: zmatek nepomůže. Počet virů se neustále zvyšuje, přibližně o sto nových virů měsíčně a proto je napadení virem velice pravděpodobné. NOD32 je velmi spolehlivou ochranou.

Antivirový Systém NOD32 obsahuje velmi silný heuristický prostředek s minimálním počtem falešných poplachů. Heuristický prostředek detekuje velké množství neznámých (dosud neanalyzovaných) virů. Pokud taková situace nastane, virový protokol systému NOD32 bude tento virus označovat za neznámý. Pokud byl takový virus (infikovaný soubor) nalezen, doporučujeme ho poslat e-mailem naši laboratoři k podrobnější analýze. Pošlete prosím vzorek na adresu:

sample@eset.com

Jakmile bude dokončena analýza souboru, po následující aktualizaci systému NOD32 můžete tento soubor léčit, popřípadě smazat.

Pokud je diagnostika dokončena a byl nalezen virus, spusťte skenování ještě jednou. Tentokrát ovšem vyberte tlačítko Léčení, nikoliv Diagnostika. V případě, že bude nalezen virus v režimu Léčení, budou Vám nabídnuty další akce. Ve většině případů NOD32 dokáže léčit detekované viry. Velké množství dnešních červů je léčeno metodou mazání - infikovaný soubor obsahuje jen samotného červa.

Pokud si nejste jisti některými soubory, pošlete je prosím opět na výše uvedenou adresu.


Přidání adresáře / souboru do seznamu skenovaných objektů

V záložce Cíle diagnostiky můžete kromě skenovaných disků zvolit i skenování jednotlivých adresářů nebo souborů.

Přidání adresáře / souboru mezi skenované objekty on-demand skeneru:

  1. Klikněte na tlačítko Přidat.
  2. Zadejte adresář / soubor, nebo klikněte na tlačítko Adresář / Soubor (k procházení se po disku) a najděte adresář / soubor, který chcete přidat.
  3. Označte adresář / soubor a potvrďte.


O programu NOD32

NOD32™ Antivirový Systém

© 1992-2003 Eset ®

V tomto dialogu se dozvíte základní informace o Vašem programu.


Parametry příkazové řádky

NOD32 skener může být spuštěn šesti způsoby:

  1. Přes hlavní okno NOD32 Control Centera
  2. Automaticky jako plánovanou úlohu
  3. Z pracovní plochy - kliknutím na ikonu NOD32
  4. Z menu START - Programy - Eset - NOD32
  5. Kliknutím pravého tlačítka na disk, adresář nebo soubor v prostředí průzkumníku a volbou Antivirový systém NOD32
  6. Přes příkazový řádek

Při spouštění modulu NOD32 přes příkazový řádek můžete využít několik parametrů a přepínačů:

Seznam parametrů a jejich popis:

Všeobecné

  • /help Zobrazí seznam programových přepínačů
  • /selfcheck+ Zapnutí vlastní kontroly
  • /selfcheck- Vypnutí vlastní kontroly
  • /expire+ Zapnutí zobrazení expirace programu
  • /expire- Vypnutí zobrazení expirace programu
  • /subdir+ Zapnutí kontroly podadresářů
  • /subdir- Vypnutí kontroly podadresářů
  • /multi+ Zapnutí hromadného testování disket
  • /multi- Vypnutí hromadného testování disket
  • /sound+ Zapnutí zvukového signálu
  • /sound- Vypnutí zvukového signálu
  • /list+ Vytvoření seznamu všech testovaných objektů v protokolu
  • /list- Vložit pouze infikované objekty do protokolu
  • /break+ Zapnutí testování přerušení
  • /break- Vypnutí testování přerušení
  • /scroll+ Zapnutí rolování protokolu o kontrole
  • /scroll- Vypnutí rolování protokolu o kontrole
  • /quit+ Vypnutí programu po testovaní
  • /quit- Po testování se program nevypne

Detekce

  • /pattern+ Zapnutí testování s použitím virových vzorků
  • /pattern- Vypnutí testování s použitím virových vzorků
  • /heur+ Zapnutí heuristické analýzy
  • /heur- Vypnutí heuristické analýzy
  • /scanfile+ Zapnutí testování souborů
  • /scanfile- Vypnutí testování souborů
  • /scanboot+ Zapnutí testování boot sektorů
  • /scanboot- Vypnutí testování boot sektorů
  • /scanmbr+ Zapnutí testování MBR
  • /scanmbr- Vypnutí testování MBR
  • /arch+ Zapnutí testování archivů (ZIP, ARJ a RAR)
  • /arch- Vypnutí testování archivů
  • /pack+ Zapnutí testování runtime pakovačů
  • /pack- Vypnutí testování runtime pakovačů
  • /local Testování všech lokálních pevných disků
  • /network Testování všech síťových pevných disků
  • /ext=<LIST> Přidání nové přípony do seznamu testovaných souborů. (Zadání více přípon, příklad: /ext=EXT1,EXT2)
  • /all Testování všech souborů

Heuristická analýza

  • /heursafe Nastavení bezpečné citlivosti heuristiky (minimum falešných poplachů)
  • /heurstd Nastavení standardní citlivosti heuristiky
  • /heurdeep Nastavení hloubkové citlivosti heuristiky

Protokol

  • /log+ Zapnutí vytváření protokolu
  • /log- Vypnutí vytváření protokolu
  • /wrap+ Zapnutí zarovnání výpisu v protokole
  • /wrap- Vypnutí zarovnání výpisu v protokole
  • /logappend Zapnutí připojení nového záznamu do protokolu
  • /logrewrite Zapnutí přepsání protokolu
  • /logsize=N Nastavení maximální velikosti protokolu (N = KB)
  • /log=<FILENAME> Nastavení jména protokolu (př.: /log=NOD.LOG)

Léčení

  • /clean Léčení infikovaných objektů (pokud lze)
  • /prompt Nabídnout akci při nalezení viru
  • /rename Přejmenovat infikovaný soubor
  • /delete Smazat infikovaný soubor
  • /replace Nahradit záznam infikovaného boot sektoru standardním

Poznámka: V případě použití přepínačů: /prompt, /rename, /delete/, alebo /replace společně s přepínačem /clean, léčení bude uplatněno pouze v případě, že lze infikovaný soubor vyléčit.


NOD32DOS

Program NOD32DOS slouží k detekci infiltrace ve vybraných objektech v operačním systému MS-DOS.
Po spuštění programu se zobrazí obrazovka Cíle. Nejprve je potřeba označit, co vlastně chceme prohledávat. Nejednodušší je zaškrtnout políčko Lokální v pravém horním rohu. Tím se automaticky označí všechny lokální disky. Je možno označit i jakékoliv jiné zařízení dvojím kliknutím na řádek s popisem zařízení v seznamu disků. Potom již jen stačí stisknout tlačítko Diagnostika a NOD32DOS zobrazí Protokol a začne s prohledáváním označených objektů. Soubory, ve kterých byl identifikován virus, popřípadě byly podezřelé, jsou v protokolu označeny červenou barvou. V případě, že NOD32DOS odhalil v některém souboru virus, je možné po skončení diagnostiky stisknout tlačítko Léčení a v závislosti od aktuálního nastavení proběhne proces léčení označených oblastí.
Program lze spustit i z příkazové řádky

Cíle diagnostiky

Umožňuje nastavit, které objekty a za jakých podmínek budou kontrolovány.
V horní části se nachází okno Disky. Slouží na volbu kontrolovaných disků. Po přepnutí do tohoto okna myší můžete kurzor ovládat prostřednictvím kurzorových kláves. Zmiňované okno informuje o názvu disku a jeho typu.

Vpravo od okna Disky se nachází dvě zaškrtávací pole:
Lokální - označí (případně odznačí) jen lokální pevné disky
Síťové - označí (případně odznačí) jen síťové disky

Dále se nacházejí tlačítka:
Všechny – označí všechny disky
Odznač – odznačí všechny disky

Ve spodní části je okno Adresáře. Zobrazuje se v něm seznam samostatně definovaných adresářů, které se mají kontrolovat na přítomnost virů.
Vpravo jsou další dvě tlačítka, kterými lze upravovat seznam kontrolovaných adresářů:
Přidat - zobrazí panel přidávání adresářů
Smazat - odstraní adresář ze seznamu kontrolovaných adresářů

Protokol

Hlavním prvkem záložky je okno protokolu. Do tohoto okna se vypisuje protokol o kontrole. Protokol obsahuje důležité informace o průběhu kontroly a je ji po ukončení programu k dispozici v souboru s protokolem (standardně "nod32.log").
Informace v protokolu jsou barevně odlišeny. Černou barvou jsou vypsány méně důležité informace, červenou pak objekty infikovány viry a modrou chyby při přístupu k souborům. Hnědou jsou označeny smazané, vyléčené, nebo přejmenované soubory.

Nastavení

Slouží k základnímu nastavení parametrů programu. Obsahuje sedm sekcí a čtyři samostatná tlačítka.

Sekce Objekty diagnostiky obsahuje tři políčka:
Soubory - aktivuje kontrolu spustitelných souborů a souborů obsahujících makra
Boot sektor - aktivuje kontrolu zaváděcích sektorů logického disku
Paměť - aktivuje kontrolu operační paměti počítače

Sekce Citlivost heuristiky obsahuje přepínač s volbou:
Bezpečná - analýza s minimem falešných poplachů
Standardní - volba pro vyváženou detekci
Hloubková - nastavení maximální hloubky analýzy

Sekce Metody diagnostiky obsahuje čtyři zaškrtávací políčka:
Vzorky – aktivuje detekci specifických kódů virů
Heuristika – povoluje heuristickou analýzu kódu
Runtime pakovače – kontroluje přítomnost virů uvnitř souboru komprimovaného "runtime" pakovačem (například PKLITE, LZEXE, Diet...)
Archivy – hledá viry i v souborech komprimovaných v archivech (ZIP, ARJ a RAR)

Sekce protokol obsahuje více prvků. Na začátku jsou dvě zaškrtávací pole::
Povolený - povoluje zápis souboru s protokolem na disk
Zarovnání výpisu – zarovná řádek v souboru s protokolem na 60 znaků

Protokolu se týká následující přepínač:
Připojení - nový protokol se připojí na konec starého (pokud starší soubor s protokolem existuje)
Přepsání - starý soubor s protokolem bude vždy přepsán novým

Poslední v sekci protokolu jsou dvě vstupní pole:
Maximální délka - určuje maximální délku souboru s protokolem v KB
Název - sem je možné zadat nové jméno protokolu v případě, že nevyhovuje jméno "Nod32.log"

Sekce Systém má dvě zaškrtávací políčka:
Vypisovat všechny soubory - zabezpečí výpis všech kontrolovaných souborů do protokolu, tedy i neinfikovaných
Zvukový signál – aktivuje zvukový signál při nalezení viru

Sekce Pokud je nalezen virus obsahuje tyto volby:
léčit - soubory vyléčí automaticky
nabídnout akci - zobrazí se panel, ve kterém je možno vybrat akci dle potřeby
ponechat beze změny - ponechá infikované soubory beze změny
přejmenovat - přejmenuje všechny infikované soubory
smazat - všechny infikované soubory smaže

Poslední sekcí je sekce Neléčitelné. Nacházejí se zde totožné možnosti jako v předcházející. Tato skupina je k dispozici pouze v případě, že je aktivována možnost automatického léčení. Zvolená akce bude vykonána, pokud NOD nedokáže daný soubor vyléčit.

V pravém dolním rohu záložky jsou čtyři samostatné tlačítka:
Uložení - uloží aktuální konfiguraci
Načtení - načte uloženou konfiguraci
Standardní - nastaví standardní konfiguraci
Přípony - vyvolá editor přípon kontrolovaných souborů

Editor přípon

Slouží k zadávání přípon souborů, které mají být testovány na přítomnost virových infiltrací.
V levé části okna je zobrazen aktuální seznam přípon uspořádaný podle abecedy.

V pravé je pět tlačítek s následující funkcí:
Potvrdit - ukončí editování přípon a zaznamená aktuální stav seznamu přípon
Zrušit - ukončí editování bez jakýchkoliv změn v seznamu přípon
Přidat - umístí příponu ze vstupního pole do seznamu přípon
 Odstranit - odstraní příponu, na které se nachází kurzor
Standardní - zruší aktuální seznam přípon a nahradí ho standardním

V dolní části se nachází zaškrtávací políčko Testovat všechny soubory. V případě jeho aktivace bude NOD testovat všechny soubory bez ohledu na příponu. Seznam přípon a tlačítka Přidat, Odstranit nejsou v tomto případě dostupné. Tuto volbu používejte jen ve výjimečných případech.

Nachází se zde i pole Testovat soubory bez přípony. V zaškrtnutém stavu přikazuje NODu testovat i ty soubory, které nemají žádnou příponu.

Po stisku tlačítka Přidat se zobrazí okno, ve kterém uživatel uvede novou příponu do vstupního pole (max. 3 znaky) a stiskem Potvrdit ji zařadí do seznamu testovaných přípon.

Aktuální seznam přípon kontrolovaných souborů se uschová společně s konfigurací po stisku tlačítka Uložit v okně Nastavení.

Nalezen virus

V horní části okna je text s informací, ve kterém souboru se virus našel. Dále se nachází jméno, případně charakteristika viru a informace o tom, zda je možno daný virus léčit.

Zmiňované okno dále obsahuje čtyři tlačítka:
Ponechat - zanechá soubor beze změny
Vyléčit - zahájí léčení viru
Přejmenovat - přejmenuje soubor s virem tak, aby nemohlo dojít k jeho náhodnému spuštění.
Smazat - nakažený soubor smaže

Pod tlačítky se nachází zaškrtávací pole Použít zvolenou akci pro všechny další objekty. Tuto volbu lze vhodně využít především v případě, že se infiltrace rozšířila na větší množství souborů.

Ve spodní části okna je tlačítko Ukončit detekci, které okamžitě ukončí další vyhledávání virů.


Vložení retězce

Vložení řetězce

Tento dialog se zobrazí v případě, že chce program od uživatele zadat nějaký textový řetězec.


Nalezen virus

Léčit – antivirový systém se pokusí daný odstranit virus z daného souboru. Některé viry poškodí soubor natolik, že ho není možné obnovit do původního stavu. V tomto případě není tato volba k dispozici.
Přejmenovat - změní název souboru. Změnou přípony se ze souboru může stát blíže neurčený datový typ, ze kterého nehrozí šíření infekce.
Smazat - vymaže soubor z disku.

Poslední možností je nezvolit žádnou činnost z uvedených voleb a zavřít okno.

Uložit do karantény - v případě, že je toto pole zaškrtnuto, soubor se před zvolenou akcí uloží do karantény.
Zobrazovat výstražné okno - ve výjimečných okolností (v případě odhalení infekce v obrovském rozsahu) je možno dočasně vypnout zobrazování výstražných oken. Po zvolení této možnosti se zobrazí tento dialog.


Vir v paměti

Tímto Vás program upozorňuje na skutečnost, že v paměti počítače se nachází aktivní virus.