.Uvod - Spravce office

SPRÁVCE office

Programy pro všechny, kteří mají na starost provoz a údržbu výpočetní techniky.

Pro tyto uživatele je určen komplexní balík programů SPRÁVCE OFFICE. Znamená pro ně zdroj důležitých informací, které potřebují pro zajištění provozu výpočetní techniky. Jedná se především o konfigurace počítačů, evidence oprav výpočetní techniky, evidence zakoupeného a skutečně nainstalovaného software, podklady pro inventury a kontroly legálního software, evidence odpovědných osob a další informace.

Kromě tohoto okruhu uživatelů je program dále určen i vedoucím pracovníkům, kterým muže sloužit jako podklad pro řízení dalšího rozvoje výpočetní techniky organizace. Naleznou zde počty počítačů, příslušenství a software na jednotlivých organizačních úrovních a další důležité informace.

Licenční podmínky


Uvod - Spravce office (single)

SPRÁVCE office – základní licence

Základní licence je určena pro malé a střední firmy, které mají výpočetní techniku umístěnou v jedné lokalitě nebo mají více drobných lokalit, ale pouze jeden tým správců, techniků který má na starosti celou výpočetní techniku.

V tomto případě postačí firmě 1 základní licence celého balíku programů SPRÁVCE office, která se skládá z těchto modulů :

SPRÁVCE - hlavní evidenční modul. Obsahuje i generátor uživatelských sestav

Scan HW, SW - načtení konfigurace hardware, software a klient pro vzdálené scanování

GRAFY - vyjádření dat programu Správce formou grafů

PROOPEN - zobrazení objektů (počítačů, tiskáren, routrů, hubů apod.) v grafických mapách


Uvod - Spravce

SPRÁVCE

Základní funkce

1) okamžitý komplexní přehled o stavu výpočetní techniky

2) zdokumentovaná technická konfigurace počítače (procesor, disky)

3) evidence oprav a upgrade PC (historie počítače)

4) evidence datumu záruky, odpisu, poslední inventury, aktualizace

5) evidence výrobních, inventárních a specifických čísel

6) informace nutné při haváriích HW, napadení viry (počty a setupy disku)

7) evidence síťového příslušenství (huby, ups, repeatery)

8) evidence volného příslušenství (databanky, vysílačky, faxy, kopírky)

9) základní informace o sítích, instalovaných počítačích, síťových kartách

10) přesné informace o nainstalovaném a volném SW, počtu volných licencí

11) přehled o instalacích SW na konkrétních počítačích

12) inventární sestavy podle organizačního členění, umístění, odpovědné osoby

13) tisk předávacích protokolů

14) tisk pasportních listů (karet hardware, software)

15) evidence příruček a dokumentace, včetně případného zapůjčení

16) evidence dodavatelských firem

17) evidence požadavků na nákup výpočetní techniky, software apod.

18) podpora scanu HW - načtení technických parametrů počítačů

19) podpora scanu SW - načtení a vyhodnocení nainstalovaného software

20) import číselníku organizačního členění, umístění, osob a firem z TXT souboru

21) export libovolného souboru do formátu TXT, DBF, XLS

Technologie

technologie zpracování umožňuje jak samostatnou dílčí evidenci pro menší firmy, tak i evidenci na více řídících úrovních pro velké firmy. Tok dat ve velkých firmách jde zdola nahoru. To znamená, že každý správce PC na podřízeném závodě vlastní jednu základní verzi programu SPRÁVCE. Na této úrovni probíhá konkrétní aktualizace dat a správce PC je za ni odpovědný. V dohodnutých intervalech pak formou diskety nebo emailem zasílá datové soubory na nadřízený orgán.

Zde se provádí kumulace dat kumulačním programem KSPRÁVCE. Nadřízený orgán v kumulační verzi nemůže dělat zásahy (aktualizaci), získá okamžitě pouze výpisy, sestavy a přehledy za celou organizaci. V programu NADSTAVBA uživatelé provádí centrální údržbu zablokovaných číselníků, převody dat mezi závody a výstup na nadřízenou organizaci.

Hlavní soubory

1) hardware

2) software

3) dokumentace

4) firmy

5) příslušenství – klasické, síťové, samostatné

6) sítě

7) požadavky

8) opravy

Číselníky

1) odpovědných osob

2) organizačního členění - ředitelství, ekonomické oddělení, PaM

3) umístění - účtárna, číslo dveří

4) servisů - pravidelné kontroly, profylaxe, revize

5) značek hardware - BM, DELL

6) typů použití hardware - CAD, Server, Aplikační PC, Pracovní stanice

7) operačních systémů HW - MS-DOS, Windows

8) typů příslušenství - Procesor, Paměť, Disky

9) názvy příslušenství - Epson FX-1050, HP LaserJet 6L

10) názvů software - Norton Utilities, Word, Excel

11) operačních systémů SW - MS-DOS, Windows

12) oblastí software - Účetnictví, Operační systémy

13) výrobců software - Microsoft, IBM

14) aplikací - Intranet, Síť, IS, Účetnictví


Uvod - Hwscan

Audit HW

Seznam scanovacích modulů :

scan HW se skládá z několika modulů, které jsou určeny pro operační systémy MS-DOS a Windows 95/98/ME/NT/2000/XP. Moduly umožňují automatické scanování po sítí s možností nastavení intervalu spouštění a možností tvorby změnových souborů. Program obsahuje také modul pro scanování počítačů, které nejsou zapojeny do sítě.

· ScanCFG

konfigurační modul, který generuje všechny potřebné konfigurační soubory

· ScanWin

hlavní modul pro scanování HW,SW (stanice pouze se systémy WINDOWS 32-bit.)

· ScanDos

hlavní modul pro scanování HW,SW (stanice se systémy MS-DOS)

· ScanView

modul pro prohlížení výsledků scanování HW a SW

Příklad načtených parametrů

HARD.OSOBA =

NETPC_NAME = NOVAK

MAC_ADDR = 005004ED7382

USER = NovakJ

DOMENA = DOMA

PORTY = 2S/1P

KOPROCESOR = Ano

TICK_TIME = 750

PAMET = 256 MB PAMĚŤ

PAGE_MEM = 1792 MB

VIRTUA_MEM = 2044 MB

DISKC = 7891 MB / FREE= 2124 MB / TYP = hard disk / FAT32

DISKD = 23434 MB / FREE= 2016 MB / TYP = hard disk / FAT32

DISKE = 650 MB / FREE= 0 MB / TYP = cd rom / CD ROM

DISKG = 33657 MB / FREE= 814 MB / TYP = LAN disk / OS2

DISKH = 33657 MB / FREE= 814 MB / TYP = LAN disk / OS2

DISKX = 33657 MB / FREE= 814 MB / TYP = LAN disk / OS2

DISKY = 980 MB / FREE= 409 MB / TYP = LAN disk / OS2

DISKZ = 980 MB / FREE= 409 MB / TYP = LAN disk / OS2

K001.NAZEV = NONANE MAINBOARD

SBERNICE = ISA-PCI

BIOS_DATE = 05/12/00

BIOS_NAME = Award

BIOS_VERS = Award Medallion BIOS v6.0

ON_BOARD = Hostitelská redukce CPU pro standard PCI

ON_BOARD = Řadič VIA Tech V82C598 CPU pro AGP

ON_BOARD = VIA Tech VT82C686 PCI to ISA bridge

ON_BOARD = VIA Tech VT82C586B PIC

ON_BOARD = Řadič VIA Tech 3038 PCI pro USB Universal Host

ON_BOARD = Řadič VIA Tech 3038 PCI pro USB Universal Host

ON_BOARD = VIA Tech VT82C686 Power Management Controller

K002.NAZEV = Athlon 750 MHz PROCESOR

VYROBCE = AMD

CPUID = AuthenticAMD

CPU_ID = 6.2.2

MMX = Ano

FPU = Ano

K004.NAZEV = NVIDIA RIVA TNT2 Model 64/Model 64 VIDEO KARTA

BUS = PCI

PCI_INF = 10DE.002D.000003

IRQ = 11

K005.NAZEV = NONAME FD

TYP = 3 1/2" 1.44MB

K006.TYP = IDE HDD

IDE_POZICE = P-Master

NAZEV = IC35L040AVER07-0

VC = SX0SXMJ8377

FIRMWARE = ER4OA44A

PAR_SKUT = 16383 C/ 16 H/ 63S

VELIKOST = 40209 MB

K007.TYP = IDE CD-ROM

IDE_POZICE = S-Master

NAZEV = PIONEER DVD-ROM DVD-103

VYROBCE = PIONEER

VC =

FIRMWARE = 1.14

K008.NAZEV = 3COM Fast Etherlink XL 905B LAN KARTA

BUS = PCI

IRQ = 11

TCP/IP = 195.70.136.6

NODE = 005004ED7382

K009.NAZEV = NONAME KLÁVESNICE

TYP = IBM enhanced (101- or 102-key) keyboard

K010.NAZEV = NONAME MYŠ

TYP = Present

BUTTON = 2

K011.NAZEV = Flatron795FT MONITOR

AKTROZLISENI = 1024,768

COLOR = 16 bits

K014.NAZEV = Creative SB Live! Series ZVUKOVÁ KARTA

BUS = PCI

IRQ = 11

SOFT.OP_SYSTEM = Windows 98

SER_CISLO = 51657-028-9496167-01428

VERZE = 4.10

REG_USER = OEM User

SER_ORG = Studio, a.s.

PLUS_PACK = IE 5 5.00.2614.3500

RELEASE = 4.10.2222

END.

Vyhodnocení

vyhodnocení nascanovaných souborů se provede přímo v programu SPRÁVCE.


Uvod - Swscan

Audit SW

Seznam scanovacích modulů :

Scan SW se skládá ze dvou modulů, které jsou určeny pro operační systémy MS-DOS a Windows 95/98/ME/NT/2000/XP. Moduly umožňují automatické scanování po sítí s možností nastavení intervalu spouštění a možností tvorby změnových souborů. Je možné scanovat lokální disky, síťové. Program vždy scanuje soubory EXE a COM, je možné je doplnit o další přípony nebo lze scanovat úplně všechny soubory. Výsledek scanování se zapisuje do textového souboru.

· ScanCFG

konfigurační modul, který generuje všechny potřebné konfigurační soubory

· ScanWin

hlavní modul pro scanování HW,SW (stanice pouze se systémy WINDOWS 32-bit.)

· ScanDos

hlavní modul pro scanování HW,SW (stanice se systémy MS-DOS)

· ScanView

modul pro prohlížení výsledků scanování HW a SW

Vyhodnocení

vyhodnocení nascanovaných souborů se provede přímo v programu SPRÁVCE. Při tomto zpracování se seznam zjištěných souborů porovná s databází vzorů SW. Výsledkem porovnání je rozdělení nalezených souborů na software Nelegální, Licence, Bez licence a Neurčené soubory.


Uvod - RemoteScan

REMOTESCAN

Základní funkce

RemoteScan slouží ke scanování HW a SW po síti z jednoho místa, bez nutnosti obcházet počítače apod. Skládá ze dvou částí :

1. první částí je modul pro vzdálené scanování pojmenovaný RemoScan, který je součástí programu SPRÁVCE. Tento modul spouští pouze znalý uživatel a může být spuštěn současně pouze jednou (nemůže ho spustit současně druhý uživatel).

2. druhou částí je klient pojmenovaný ClientRS, který musí být nainstalován na všech počítačích, které chcete scanovat. Pokud je zaveden v paměti, nic nedělá, pouze čeká na příkazy z modulu RemoScan.

Omezení

· komunikace mezi a ClientemRS je možná pouze na protokolu TCP/IP.

Veškeré scany, které jsou prováděny, jsou zapisovány a v případě, že RemoteScan bude ukončena dříve, než bude zaslán výsledek, budou při příštím spuštění výsledky vyžádány po příslušných Clientech. V momentě, kdy dojde při provádění scanu k chybě nebo je scan stornován, je rozpracovaný soubor na vzdálené stanici smazán.


Uvod - Sestavy

SESTAVY

Skládá se ze dvou částí

a) v první části lze nadefinovat libovolný filtr. K tomu slouží dialogový režim, který uživatele vede jednotlivými kroky k poskládání požadované podmínky filtru. Lze mít vytvořeno libovolný počet filtrů ke každému souboru.

b) ve druhé části se definují sestavy. Zde je možné vybrat jednotlivé položky do sestavy, zvolit setřídění, skupiny apod. Dále je možné zvolit sloupcovou, řádkovou nebo sumární sestavu. Výstup lze také směrovat do souboru (DBF, TXT, XLS). Po nadefinování výše uvedených podmínek program vygeneruje sestavu, kterou lze pomocí návrháře sestav vývojového prostředí VISUAL FOXPRO ještě graficky upravit. Takto nadefinovaných sestav lze opět mít libovolné množství ke každému souboru.


Uvod - Grafy

GRAFY

Základní funkce

tento modul umožňuje prohlédnout data z programu SPRÁVCE formou grafů.

Program se skládá ze dvou částí

a) první část je obsažena přímo v programu SPRÁVCE. Jedná se Export všech důležitých údajů pro grafické zobrazení. Do určeného adresáře se vyexportují pouze potřebné soubory a pouze potřebné položky.

b) druhou částí je samostatný program MicosGrf, který si vyexportované údaje načte a umožní jejich zobrazení formou grafů. Na ose Y se pak zobrazují položky Kusy nebo Ceny, na ose X pak Datumy (zakoupení, uvedení, …) nebo Názvy.


Uvod - ProOpen

PROOPEN

Základní funkce

Jednou z možností, jak dosáhnout zvýšení efektivnosti a přehlednosti systému SPRÁVCE office, je propojení databázových souborů s grafickým systémem, který umožní lokalizaci hardwarových prvků systému v mapě, projektu, nákrese, případně fotografickém podkladu. Možnost provázanosti a vzájemného ovlivňování grafického a databázového systému tvoří nejen užitečné a velmi přehledné, ale zároveň i atraktivní pracovní prostředí, které je vizuálně mnohem bližší uživateli nežli popisná informace v jakékoliv podobě.

Takovým grafickým systémem je program PROOPEN, který ve spojení s databázovým systémem SPRÁVCE office vytvoří takovýto systém. Jeho vazba na databázový systém SPRÁVCE office je definována přes standardní rozhraní DDE, pomocí něhož program poskytne k dispozici funkce pro napojení k libovolnému programovému systému s využitím standardních komunikačních nástrojů operačního systému Microsoft Windows.

Pro běžnou práci postačí : Pentium 400MHz, operační paměť 128MB RAM nebo více, monitor 17” s rozlišením min. 1024x768, 5MB místa na pevném disku pro vlastní systém plus místo potřebné pro uživatelská data, operační systém Windows 95/98/ME/2000/NT/XP.

Program PROOPEN je nástroj pro práci s geografickými daty, který :

a) disponuje standardními funkcemi

· zobrazení rastrových a vektorových dat

· pořízení, správa a manipulace s vektotovými objekty

· práce s mapami v různých měřítcích

· import a export vektorových a grafických formátů :

· základní grafické objekty jsou čára, lomená čára, oblouk, kružnice, text, symbol, plocha, spline a kóta.

b) spolupracuje se systémem SAP přes aplikaci GAPIS

· umožňuje graficky zobrazit umístění objektu z evidence SAP

· umožňuje vyhledat datové informace o objektu v ProOpnu

c) spolupracuje s programem SPRÁVCE office pro evidenci výpočetní techniky

· umožňuje graficky zobrazit umístění objektu z evidence výpočetní techniky SPRÁVCE office

· umožňuje vyhledat datové informace o objektu v ProOpnu


Uvod - Spravce office (multilicence)

SPRÁVCE office – multilicence

Multilicence je určena pro střední a velké firmy, které mají výpočetní techniku umístěnou ve více lokalitách (samostatných závodech, střediscích apod.). Na každé takovéto lokalitě je samostatný tým správců, techniků který má na starosti svěřenou výpočetní techniku.

V tomto případě firma potřebuje zakoupit tzv. multilicenci, kde počet licencí je dán počtem lokalit, ve kterých je tým správců, techniků. Např. firma, která má 10 poboček po celé republice, takže potřebuje multilicenci na 10 instalací. Kde každá instalace obsahuje celý balík tvořený stejnými moduly jako Základní licence.

Kromě základní licence potřebuje ještě firma v takovém případě 1 licenci programu KSPRÁVCE - tento modul umí sehrávat a distribuovat data podřízených programů SPRÁVCE


.Uvod - Kspravce

KSPRÁVCE

Základní funkce

program KSPRÁVCE je určen pouze pro větší firmy a organizace, které mají zakoupeno více instalací programu SPRÁVCE. Počet instalací programu KSPRÁVCE, které je nutné zakoupit, je dán strukturou organizace. Principiálně lze program použít na libovolné úrovni organizace (např. okres, kraj apod.), kde chcete provádět sloučení dat za podřízené jednotky. Z těchto podřízených jednotek jsou data zasílána v pravidelných intervalech formou diskety nebo mailu z programu SPRÁVCE.

V programu KSPRÁVCE dojde k jejich sehrání, přičemž původní data jsou smazána a nová data jsou nahrána. Z programu lze data zasílat také do programu KSPRÁVCE v nadřízené struktuře.

Program KSPRÁVCE dále také slouží k údržbě a návrhu centrálních číselníků, které musí být jednotné v celé organizaci. Zde se číselníky navrhnou a lze je rozeslat všem podřízeným jednotkám, kde je umístěn program SPRÁVCE.


Uvod - Nadstavba

NADSTAVBA

Základní funkce

tento modul je určen pouze pro větší firmy a organizace, které mají zakoupeno více instalací programu SPRÁVCE. Slouží ke komunikaci mezi programy SPRÁVCE a KSPRÁVCE. Je automaticky implementován v případě zakoupení více licencí programu SPRÁVCE a je zdarma.

Umožňuje provádět :

1) příjem centrálních číselníků z programu KSPRÁVCE. Číselníky se přijímají formou diskety nebo mailu z nadřízené organizace. Pomocí nich se zaktualizují zablokované číselníky v programu SPRÁVCE.

2) výstup dat na nadřízenou organizaci do programu KSPRÁVCE. V tomto programu se provádí sehrání dat ze všech instalací programu SPRÁVCE. Nadřízená organizace tak má přehled o stavu výpočetní techniky za celou oblast nebo za celou organizaci.

3) převody dat mezi jednotlivými instalacemi programu SPRÁVCE. Např. pracovník odchází z Brna do Ostravy a bere si sebou i přidělenou výpočetní techniku. Program umožňuje provést výstup dat z jedné instalace programu a v jiné instalaci tyto data zase přijmout.

4) rušení neschválených vět centrálně udržovaných číselníků, které nemají vazby v hlavních datových souborech.


Licencni podminky

Licenční podmínky

Licenční podmínky programu SPRÁVCE OFFICE je souhrn pravidel pro správné používání.


Licencni podminky - Spravce

SPRÁVCE OFFICE, GRAFY

Licenční podmínky

Softwarový program je chráněn autorským zákonem a mezinárodními dohodami o autorských právech. Na základě těchto licenčních podmínek se udělují následující práva :

1) program SPRÁVCE je síťová verze. Lze ho nainstalovat pouze na jeden počítač nebo na jeden server (základní síťové služby programu mohou být zpřístupněny jakémukoliv počtu pracovních stanic dané sítě). Jestliže se jedná o síťovou multilicenci, lze ji nainstalovat a provozovat na stanoveném počtu počítačů (serverů).

2) v programu SPRÁVCE lze evidovat pouze stanovený počet počítačů, pro který byl program zakoupen.

3) moduly GRAFY je určen pro stejný počet počítačů jako je zakoupená licence programu SPRÁVCE.

4) scanovací moduly scanu HW, SW a RemoteScanu smíte nainstalovat a provozovat na libovolném množství počítačů, které spadají do jediné evidence programu SPRÁVCE. Jinak řečeno, firmy, jenž mají zakoupenou jedinou licenci programu SPRAVCE, mohou scanovat libovolné množství počítačů, které odpovídají zakoupené licenci ( podle počtu PC).

5) výrobce nepovoluje provozovat druhou kopii programu na domácím počítači. Pokud instalační program povoluje provést více než 1 instalaci, dovoluje výrobce provozovat jednu kopii na přenosném počítači.

6) uživatel si nesmí pořizovat záložní kopii instalačního CD. Pokud dojde k jeho poškození, zašle poškozené CD výrobci a ten mu zdarma zašle nové.

7) uživatel nesmí provádět zpětnou analýzu, dekompilaci a převod ze zdrojového kódu.

8) uživatel nesmí program pronajímat, instalovat ani půjčovat třetím osobám. Taktéž nesmí program nabízet prostřednictvím Internetu apod.

9) uživatel smí veškerá svoje práva trvale převést výhradně v souvislosti s prodejem programu, a to za předpokladu, že si neponechá žádné kopie. S prodejem programu uživatel musí převést celý produkt, včetně instalačních médií, příruček, licenčního ujednání apod. Pokud program představuje aktualizovanou verzi (tzv. upgrade), musí prodej obsahovat převod všech předchozích verzí (uživatel si nesmí ponechat žádnou součást programu).

10) v případě převodu práv v souvislosti s prodejem programu si musí nový nabyvatel programu vyžádat u výrobce souhlas k převodu.

11) jedná-li se o převod programu, který byl zakoupen jako multilicence, nesmí uživatel převést jenom jednu licenci, nýbrž musí převést celou multilicenci (multilicence se nesmí dělit).

12) pokud uživatel nesplní výše uvedené licenční podmínky, může výrobce zrušit právo k užívání programu a vyžadovat finanční náhradu v případě ušlého zisku. V tomto případě musí uživatel respektovat rozhodnutí vyrovnání mezi uživatelem a výrobcem, eventuálně rozhodnutí soudu.


Licencni podminky - ProOpen

ProOpen

Licenční podmínky

· program PROOPEN je samostatný program firmy TESCO SW a řídí se jejími licenčními podmínkami.

· není závislý na počtu evidovaných počítačů v licencí programu SPRÁVCE. Pro single licenci SPRÁVCE postačí jedna licence PROOPEN. Pro multilicenci programu SPRÁVCE je potřebné zakoupit stejnou multilicenci programu PROOPEN.

· na program PROOPEN se nevztahují žádné slevy, které poskytuje firma MiCoS SOFTWARE s.r.o. na programy SPRÁVCE office.


Licencni podminky - Reklamace

Reklamační pokyny

1) po vyplnění registračních údajů na webu vzniká uživateli nárok na záruku. Záruční doba na každý programový produkt trvá 24 měsíců ode dne jeho koupě a vztahuje se pouze na vady, které nedovolují jeho správnou funkci a provoz.

2) v případě, že programový produkt není zcela v pořádku (např. nejde provést počáteční instalace), zašlete prosím instalační média přímo na adresu autorské firmy. Spolu s tím zašlete krátkou charakteristiku vady a adresu uživatele. Obratem bude vadný kus vyměněn.

3) v případě, že se během provozu vyskytne „Neošetřená chyba programu“, zašlete instalační média přímo na adresu výrobce. Spolu s tím zašlete popis chyby (hlavně číslo chyby a číslo řádku, na kterém se chyba vyskytla), název, verzi programu a popis jak k chybě došlo. Pokud uvedená chyba způsobuje nefunkčnost části programu, bude ihned odstraněna a výrobce obratem zašle zdarma novou verzi programu. V případě, že uvedená chyba nezpůsobuje nefunkčnost programu, bude oprava zahrnuta do nejbližší aktualizace programu a uživateli bude zaslána v okamžiku vytvoření nové verze.


Zpusoby nasazeni

Způsoby nasazení

Programový balík SPRÁVCE office lze nasadit jak v malých a středních firmách, tak i ve velkých firmách. Nasazení se liší v počtu zakoupených licencí a v zakoupených modulech.


Zpusoby nasazeni - male firmy

Malé a střední firmy

Programy Správce office můžete nasadit v malých a středních firmách, kde má evidenci VT na starost pouze jeden správce. V tomto případě potřebujete pouze jednu instalaci.


Zpusoby nasazeni - male firmy (poznamka)

Malé a střední firmy – poznámka

Práce s programem Správce office je v malých a středních firmách snadnější :

· kupuje se pouze jedna licence.

· odpadá komunikace mezi více instalacemi.

· odpadá nutnost návrhu a distribuce centrálních číselníků.

· s programem pracuje méně uživatelů, takže není nutné nějaké zvláštní organizační opatření.


Zpusoby nasazeni - velke firmy

Velké firmy

Velké firmy potřebují ke své práci více než jednu instalaci programového balíku SPRÁVCE office + jednu licenci programu KSPRÁVCE. Program KSPRÁVCE umožňuje kumulace dat ze všech instalací programů SPRÁVCE. Dále ještě umožňuje údržbu a distribuci centrálních číselníků.


Zpusoby nasazeni - velke firmy (pocet instalaci)

Velké firmy

Volba počtu instalací

1) podle rozsahu struktury organizace musíte navrhnout počet instalací, které potřebujete zakoupit. Program SPRÁVCE je určen tzv. správcům počítačů. Takže počet instalací by se měl odvíjet od počtu organizačních jednotek, na kterých je alespoň jeden správce.

2) pro nadřízenou nejvyšší úroveň organizace je nutné nasadit program KSPRÁVCE, který umí sehrávat dat z podřízených programů

3) scanovací moduly scanu HW, SW a RemoteSCAN jsou vázány k jedné instalaci programu SPRÁVCE. Uživatel si smí programy nainstalovat a provozovat na libovolném množství počítačů, které spadají do této jediné evidence programu SPRAVCE (omezeno počtem počítačů zakoupené licence).

4) program SPRÁVCE lze nasadit na i úrovni nadřízené organizace (jako sklad). Což umožňuje řešit centrální nákup výpočetní techniky a její distribuci na podřízené jednotky.


Zpusoby nasazeni - velke firmy (udrzba ciselniku)

Velké firmy

Údržba číselníků

1) nejprve je nutné na nejvyšší úrovni stanovit odpovědnou osobu, která bude mít na starosti centrální údržbu číselníků a sehrávání dat z podřízených závodů (nazveme ji správce číselníků).

2) na tuto nejvyšší úroveň je nutné nasadit program KSPRÁVCE, kde správce číselníků navrhne první verze číselníků a také navrhne, které číselníky budou centrálně udržované a zablokované.

3) dále zde správce číselníků vytvoří tzv. číselník závodů (pod pojmem závod se rozumí místo, kde je program SPRÁVCE nasazen na nejnižších úrovních). V tomto číselníku přidělí jednotlivým lokalitám, kde bude program SPRÁVCE nasazen, číslo závodu. Toto číslo závodu musí být v rámci celé organizace jedinečné. V případě podstatných změn v organizaci (rušení, sloučení, přejmenování apod.) pak musí správce číselníků v programu KSPRÁVCE provést patřičné úpravy.

4) ve volbě Komunikace – Výstup dat do Správce se vytvořené číselníky nakopírují do adresáře, ze kterého si je všechny závody budou sami průběžně stahovat (stažení číselníků záleží pouze na organizačním zajištění konkrétní firmy).

5) v okamžiku, kdy si závody stáhnou aktuální číselníky, musejí v programu SPRÁVCE - NADSTAVBA provést přihrání těchto číselníků ke svým číselníkům. Během tohoto přihrání dochází k porovnávání starých číselníků s nově staženými číselníky. Pokud se věta starého číselníku shoduje, označí se symbolem Schváleno. Pokud se neshoduje, zůstává v nově zaktualizovaném číselníku jako neschválená. Na konci přihrání je vytištěn seznam neschválených vět jednotlivých číselníků.

6) po přihrání číselníků z nadřízené organizace, musí uživatel programu SPRÁVCE projít neschválené věty a zkontrolovat, zda tyto věty nejsou ve schválených větách pod jiným názvem (např. neschválený název tiskárny je EPS FX-1050 a schválený je EPSON FX-1050). Pomocí tlačítek Změnit vazbu musí v takových případech vazby neschválených vět převést na schválené a neschválenou větu číselníku vymazat. Takto si číselníky vyčistí tak, aby odpovídaly schválených číselníkům.

7) pokud uživatel programu SPRÁVCE trvá na zařazení svých neschválených vět mezi věty schválené, musí vytisknout sestavu neschválených vět v programu SPRÁVCE a tuto sestavu zaslat na nadřízenou organizaci správci číselníků.

8) správce číselníků posoudí navrhnuté změny a rozhodne, jestli je zařadí mezi schválené. Pokud ano, provede úpravu navrhnutých změn do číselníků programu KSPRÁVCE a zašle nové číselníky do adresáře, ze kterého si je jednotlivé závody mohou opět stahovat.

9) správce číselníků při práci s programem KSPRÁVCE vidí v jednotlivých číselnících neschválené věty a může uživatele programu SPRÁVCE požádat, aby si věty upravil podle jeho vzoru nebo určité věty schválit, aniž by musel obdržet sestavu neschválených vět. Toto záleží na organizačním řádu provozu programů SPRÁVCE OFFICE.


Zpusoby nasazeni - velke firmy (spravce ciselniku)

Velké firmy

Správce číselníků

by měl dodržovat následující rady :

a) pracovat často a poctivě s číselníky, aby nedošlo k tomu, že vzorové číselníky nebudou odpovídat požadavkům podřízených závodů a vývoji výpočetní techniky. V tomto případě to dopadne tak, že se číselníky rozjedou a v programu KSPRÁVCE se podle nich nebude dát nic najít.

b) sledovat závody, které nerespektují vzorové číselníky a trvají na svých údajích, které jsou obsahem podobné, ale díky nejednotné syntaxi se v programu KSPRÁVCE nedají sloučit s ostatními závody.

c) sledovat, zda závody zasílají data v určeném termínu.


Zpusoby nasazeni - velke firmy (harmonogram)

Velké firmy

Harmonogram zasílání dat

pro správnou funkčnost programů SPRÁVCE a KSPRÁVCE má význam pouze pravidelné zasílání dat z podřízených závodu. Interval tohoto zasílání je individuální u každé organizace. Závisí na změnách výpočetní techniky a dalších parametrech. Obecně doporučujeme, aby tento interval byl v rozmezí 1-2 měsíců.


Zpusoby nasazeni - velke firmy (org. opatreni)

Velké firmy

Organizační opatření

pro správnou funkčnost programu v rámci celé organizace je nutné přijmout určitá organizační opatření, která by měla být jednoznačně stanovena a podložena písemnou formou (např. příkaz ředitele apod.). V následujících bodech je naznačeno několik důležitých pokynů, které by se měly v organizačním opatření objevit :

a) postup nákupu výpočetní techniky a software u organizace

b) přidělení osobní odpovědnosti uživatelů za svěřenou techniku

c) tvar předávacích protokolu

d) práva a povinnosti uživatelů při použití výpočetní techniky

e) práva a povinnosti správců počítačů

f) pokyny pro použití programu SPRÁVCE

g) pokyny pro zabezpečení jednotnosti číselníků

h) označení počítačů viditelným štítkem s evidenčním číslem (nebo dalšími údaji)

i) časový harmonogram zasílání dat na nadřízenou organizaci

j) postihy za nezaslání dat v uvedeném termínu

k) zda a jakým způsobem budou sledovány opravy výpočetní techniky


Zpusoby nasazeni - popis

Způsoby nasazení – SPRÁVCE office

Následující řádky obsahují standardní postup :

1) První spuštění programu

a) Konfigurace

po vytvoření datových souborů se spustí formulář Konfigurace. V tomto formuláři musíte nastavit všechny potřebné parametry. Tyto parametry jsou celkem srozumitelné, proto se zde zaměříme pouze na ty nejdůležitější :

· Karta Obecné - Tvar evidenčních čísel

zde musíte nastavit způsob vytváření evidenčních čísel. Můžete zvolit :

o        číslování programem – evidenční číslo bude začínat od “1“ a postupně se zvětšovat. Program Vám při vytváření nových vět hlavních datových souborů automaticky nabídne další číslo. V této konfiguraci můžete určit první čtyři znaky v evidenčním čísle jako tzv. prefix. Následující příklady ukazují možnosti použití prefixu :

· jestliže určíte 1-4 úvodní znaky např. HARD, pak zbytek čísla bude vždy doplněn nulami např. “HARD0001“. Pozor na příslušenství. Pokud budete mít v evidenci více než 500 počítačů, kde každý počítač má několik příslušenství, můžete se snadno s číslováním příslušenství dostat nad 9999. V tomto případě nesmíte mít prefix 4-místný.

· není vhodné na konci prefixu používat číslic. Ve výsledném čísle pak splývá prefix s vlastním číslováním (např. HAR10010 - není na první pohled zřejmé o jaké číslo se jedná).

· pokud na začátku prefixu použijete mezery, zůstanou zachovány, např. " H0001" (kompatibilita s verzí 4.*). Jedině tímto způsobem můžete nastavit délku evidenčního čísla menší než 8 znaků.

· jestliže neurčíte žádný znak v prefixu, pak program automaticky doplní nuly tak, aby počet znaků byl 8 ( číslo bude “00000001“ ).

· pokud potřebujete změnit prefix, stiskněte tlačítko Změna prefixu ev. čísel. Toto tlačítko Vám zpřístupní jednotlivé prefixy a Vy můžete provést změny. Po stisknutí tlačítka OK celého formuláře se pak provedená změna promítne do všech vět všech souborů. POZOR - dojde k přečíslování všech vět odpovídajících původnímu prefixu na nový prefix. Což při podstatné změně prefixu může ovlivnit předávací protokoly, inventární sestavy, popisy počítačů apod.

o        libovolné číslo - program Vám při vytváření nových vět hlavních datových souborů nabídne prázdné evidenční číslo a Vy musíte zapsat libovolný počet 1-8 znaků. Pozor není vhodné tuto volbu nastavit u příslušenství, kterého je hodně.

POZOR - v průběhu práce není vhodné střídat tyto dva způsoby tvorby evidenčního čísla. Program není na toto střídání naprogramován, mohlo by dojít ke kolizím.

· Karta Sestavy

na této kartě máte možnost nastavit vlastní nadpisy pro některé sestavy, text předávacích protokolů s specifikačního listu. Text předávacích protokolů bude u každého předávacího protokolu umístěn za úvodní pevný text na samostatnou stranu. Pokud máte zakoupenou multilicenci programu Správce, může být tento text určen pouze ke čtení (bude mít šedý podklad). To nastane v případě, že Vaše organizace bude požadovat jednotné předávací protokoly. V tomto případě Vám pošle jejich obsah z programu KSPRAVCE a zakáže Vám aktualizaci.

b) Správa uživatelů

dále doporučujeme spustit volbu Údržba-Správa uživatelů. V této volbě vytvoříte další uživatele, kteří budou mít přístup do programu. Každý uživatel musí mít svoje jméno, program neumožňuje přihlásit jednoho uživatele vícekrát. Zároveň všem uživatelům musíte nastavit příslušná práva. Práva se rozdělují na 3 typy :

· právo spustit - umožňuje formulář pouze spustit

· právo zápisu - umožňuje data aktualizovat

· funkce - právo spustit funkci programu

c) Návrh číselníků

po úvodní instalaci jsou všechny hlavní datové soubory prázdné. Také většina číselníků je také prázdná. Naplněné číselníky jsou :

· číselník typů příslušenství - používá ho program scan HW, proto je částečně naplněný

· číselník servisů - je naplněna pouze jedna věta pro dokupování licencí SW

· číselníky software - používá jej scan SW

· číselník lokalizací software - je naplněný základními lokalizacemi

Doporučujeme projít všechny číselníky. V první fázi stačí hrubě nastínit obsah jednotlivých číselníků. Hlavně se jedná o následující číselníky :

· umístění - fyzické umístění výpočetní techniky

· organizační členění - organizační struktura firmy

· příslušenství - typy a názvy příslušenství

Podrobnější údaje o těchto číselnících naleznete v helpu. Důraz položte na číselník příslušenství (zejména na typy příslušenství). A to proto, aby jste měli při aktualizaci představu o tom, co tento číselník obsahuje a zbytečně jste nenavrhovali nevhodné typy. Ostatní číselníky je vhodné naplňovat až při pořizování hardware, software atd.

2) Scanování HW a SW

po seznámení s programem SPRÁVCE a hrubým nadefinováním číselníků můžete přistoupit ke scanování HW a SW. Před použitím scanů musíte nejprve spustit program SCANCFG.EXE, pomocí kterého nastavíte všechny potřebné parametry a vytvoříte konfigurační soubory. Scanování můžete provádět třemi způsoby :

  • ručně - pomocí programu ScanCFG vygenerujete disketu pro ruční scanování počítačů mimo síť.
  • automaticky - pomocí programu ScanWin spustíte scanování v login scriptu při přihlášení uživatelů k síti.
  • vzdáleně - pomocí programu RemoteScan můžete provádět vzdálené scanování přes protokol TCP/IP nebo NetBeui.

Všechny scanovací moduly ukládají výsledky do TXT souborů, které se v programu SPRÁVCE zpracují.

3) Zpracování scanů HW

v programu SPRÁVCE v menu HW audit spustíte volbu Zpracování scanu HW. Na kartě Konfigurace musíte nejprve nastavit parametry pro zpracování. Tyto parametry umožňují generovat nebo negenerovat věty do příslušenství. Rozhodnutí závisí na podmínkách organizace (někde se např. neevidují samostatné klávesnice, myši apod.).

Po spuštění zpracování se obsah nascanovaných souborů převede do databází. Při prvním zpracování program všechny počítače zavede do evidence a vygeneruje automaticky všechno nastavené příslušenství (komponenty, ze kterých se počítače skládají). Při dalším zpracování se porovnává stav v evidenci programu SPRÁVCE s obsahem nascanovaného souboru. Při zjištění rozdílu se výsledky zobrazí na kartě Změny v PŘ, ze které se dají ručně zpracovat. Při zjištěných a potvrzených rozdílech se automaticky generují do souboru oprav příslušné věty (upgrade, oprava, přiřazení apod.).

Jestliže se v nascanovaném souboru naleznou síťové tiskárny s vlastní síťovou kartou, jsou automaticky generovány do síťového příslušenství.

Při zpracování jsou do evidence hardware vygenerovány pouze technické údaje. Proto po zpracování musíte ručně doplnit ostatní údaje (odp. osobu, umístění, inv. číslo, výrobní číslo, …)

4) Zpracování scanů SW

v programu SPRÁVCE v menu SW audit spustíte volbu Zpracování SW-scanu. Na kartě Konfigurace musíte nejprve nastavit parametry pro zpracování.

Po spuštění zpracování se obsah nascanovaných souborů porovnává s databází vzorů software. Nalezené instalace se podle druhu software (licenční, shareware, freeware) automaticky nastaví na karty :

  • Bez licence - software druhu freeware, instalace, ovladače, hw utility
  • Nelegální - software druhu licenční, aplikační, vlastní, shareware

Legální Licence software si můžete v Evidenci software vytvořit ještě před zpracováním nascanovaných souborů. V těchto licencích můžete nastavit všechny potřebné údaje. Přiřazení na jednotlivé počítače můžete provést dvěma způsoby :

  • V evidenci software na kartě Vazby HW přiřadíte jednotlivé licence rovnou na všechny počítače, kde víte, že jsou nainstalované. Při zpracování SWT souborů se pak nalezené instalace spárují s předem nastavenými licencemi. Pokud se při zpracování instalace na počítači nenalezne, je na kartě Licence zobrazena červeně. Pozor – tento způsob je velice rychlý a méně pracný, horší je to však s přesností. Pokud na počítače předem nastavíte např. licenci MS OFFICE 97 a pak se tam nalezne MS OFFICE 2000, máte nepřesné výsledky a další práci s jejich opravou.
  • Přiřazení licencí na počítače provádíte až při zpracování nascanovaných souborů. Tento způsob je pracnější, protože musíte procházet jednotlivé počítače a všechny licence přiřazovat postupně. Avšak tento způsob je přesnější neboť vidíte přesně vše, co se na počítači nachází a přiřadíte tedy správnou licenci.

Při zpracování nascanovaných souborů umí program SPRÁVCE zjistit u operačního systému nejenom verzi, ale i service pack a lokalizaci. Jsou-li na počítači nalezeny i soubory jiné verze operačního systému, je aktuální systém zobrazen tučným písmem. Lokalizace operačního systému se zjišťuje pomocí API funkcí a mezinárodních číselných kódů. Základní lokalizace naleznete v číselníku lokalizací. Lokalizaci lze určit zatím pouze u operačních systémů, u ostatních instalací ji musíte určit ručně. Pokud není lokalizace vyplněna, předpokládá se anglická. Lokalizaci lze přednastavit v číselníku názvů software. V tomto číselníku můžete např. u českého software nastavit lokalizaci CZ, pak se při zpracování SWT souborů tento software nastaví automaticky s lokalizací CZ.

V číselníku názvu software lze u software nastavit, zda se jedná o SW balík (např. MS Office). Pokud je software označen jako SW balík, má v evidenci balíků nastavené jméno a seznam modulů, ze kterých se skládá (např. MS Word, MS Excel). Při zpracování se nejprve zjistí název software (např. MS Office), pak se zjistí, které moduly jsou nainstalovány a z registrů se zjistí název balíku (např. Standard).

Jestliže chcete licence čerpat pomocí tzv. Downgrade, musíte v evidenci software u těchto licencí nastavit parametr Downgrade. Tento parametr signalizuje, že licenci lze použít i pro nalezené nižší verze. Při zpracování SWT souborů se na počítačích nalezne nižší verze (např. MS Office 97). Pomocí volby Downgrade lze zobrazit seznam licencí, které lze použít na downgrade. Po výběru se na kartu Licence přenese vyšší verze a v pomocných položkách je zobrazena skutečně nalezená nižší verze.

Karta Nelegální obsahuje také zbytkové instalace, které vznikly např. špatným odinstalováním, instalací upgrade apod. Pokud nevíte, jestli nalezené soubory můžete smazat, lze je přesunout na kartu Nevedený. Instalace na kartě Nevedený nevstupují v programu SPRÁVCE do předávacích protokolů a dalších sestav.

Na kartě Registry je výpis z registrů Windows, který slouží jako pomocná informace při analýze neurčených souborů.

Zpracování SWT souborů je vhodné provést nejprve na vzorku cca 10 počítačů, které obsahují typické instalace v organizaci. Po zpracování tohoto vzorku musíte projít kartu Neurčené, kde se nacházejí neurčené soubory. Z těchto souborů lze vytvořit vlastní vzory (např. vlastní aplikační software) nebo doplnit již existující vzory. Po doplnění vzorů o další soubory musíte spustit volbu Aktualizovat sdílené soubory, která nastaví soubory, které jsou sdílené ve více aplikacích. Potom teprve můžete spustit zpracování na všechny počítače.

5) Doplnění údajů

po zpracování nascanovaných souborů HW a SW máte zhruba základní parametry hardware, software a příslušenství nastavené. Nyní zbývá doplnit údaje, které nelze nascanovat. Tyto údaje můžete doplnit jednotlivě v každé větě (hardware, software, …) nebo hromadně v jednotlivých číselnících.

Při naplňování datových souborů jsou položky, které mají číselník, vždy ve tvaru Seznam. Tyto položky lze pořizovat několika způsoby :

· Pomocí kurzorových šipek lze listovat nahoru a dolů

· Přímo psaním textu se Vám nabídne nejbližší vhodný údaj

· Stiskem levého tlačítka na pravém konci položky (šipka dolů) se Vám rozbalí seznam hodnot daného číselníku

· Stiskem pravého tlačítka myši se Vám spustí celý formulář pro aktualizaci příslušného číselníku.

· Pokud do tohoto Seznamu začnete přímo psát, pak při opuštění program zkontroluje, zda je hodnota v příslušném číselníku. Pokud není, nabídne formulář pro její zavedení. Takže nemusíte mít dopředu všechny hodnoty daného číselníku nadefinovány.

a) Naplňování začnete pravděpodobně souborem Hardware. Po vyplnění všech chybějících údajů a uložení věty se při změně technických parametrů, osob, org. členění apod. vygeneruje zároveň věta do souboru Opravy (historie změn). Program tak sleduje historii podstatných změn – upgrade, oprava, převod, změna tech. parametrů.

b) Po doplnění údajů z hardware můžete přikročit k doplnění údajů jednotlivých Příslušenství. Pokud u příslušenství nastavíte, že bylo součástí PC při nákupu, pak do jeho ekonomických údajů automaticky dotáhnou všechny ekonomické údaje z přiřazeného hardware. Příslušenství, které je součástí PC při nákupu má vždy nulovou cenu (jeho cena je zahrnuta v ceně hardware), ostatní příslušenství má vlastní cenu, která se u hardware sčítá do položky Cena příslušenství.

c) Dále musíte doplnit údaje Software. V jednotlivých licencích doplňte chybějící údaje (ekonomické, dokoupení chybějících licencí apod.).

d) Pokud máte vyplněné všechny potřebné údaje, máte hotový vzorový počítač. Nakupuje-li firma více počítačů stejné konfigurace a instaluje-li na ně stejné softwarové prostředí, můžete pomocí funkce Duplik snadno vytvořit další počítače bez velké námahy. Při duplikaci se vytvoří zcela identický počítač, pouze všechna výrobní, inventární a specifická čísla se vynulují.

e) Většinu číselníků budete aktualizovat průběžně při aktualizaci dat souborů hardware, software a příslušenství. Pozor – při vyplňování hlavních souborů může být rychlejší položky typu umístění, organizační členění, správce, dodavatel nevyplňovat. Po aktualizaci hlavních souborů stačí spustit aktualizace výše uvedených číselníků a naplnění provést hromadným přiřazováním.

f) Máte-li počítače propojené do sítě, měla by dalším krokem být aktualizace souboru Sítí. Zde pořídíte jednotlivé sítě a přepnutím na kartu Vazby HW k nim přiřadíte jejich počítače. Přepnutím na kartu Vazby PŘ k sítím přiřadíte síťové typy příslušenstvím. Na kartě Ostatní lze ke každé síti přiřadit důležitým uživatelům jejich přístupové jméno a heslo. Tyto údaje jsou na disku kódovány, takže nemusíte mít strach o jejich vyzrazení.

g) Posledním krokem je evidence požadavků Vašich uživatelů na nákup výpočetní techniky, software…

h) Tím je zhruba postup aktualizace ukončen.

i) Nyní můžete dále pracovat s programem, prohlížet, tisknout, exportovat apod.

j) Nezapomeňte na pravidelnou zálohu. K tomu můžete využít automatické procedury, které se nastavují v menu Údržba-konfigurace.


Cenik

Ceník software

SPRÁVCE OFFICE

LICENČNÍ SOFTWARE


Cenik

Ceník software

Aktuální ceník je umístěn na web stránkách v sekci Ceník - Správce.


Cenik - ostatni software

Licenční software

Aktuální ceník je umístěn na web stránkách v sekci Ceník - ostatní sw.


Instalace

Instalaci programu provedete vložením instalačního CD-ROMu do mechaniky a spuštěním instalačního programu MICOS.EXE. Dále postupujte podle pokynu instalačního programu.

· Instalace je síťová, lze ji bez problému provozovat jak na síťovém, tak i na lokálním počítači.

· Na instalačním CD naleznete některé z následujících variant instalace :

SPRÁVCE - instalace modulů SPRÁVCE, SESTAVY a GRAFY

Scany HW, SW - instalace modulů pro scan HW, SW a RemoteScan

SPRÁVCE client - instalace Clienta pro spouštění programu SPRÁVCE z lokálního disku pracovní stanice

Má význam pouze na pomalých a přetížených sítích.

BDE - instalace a konfigurace Borland Database Engine pro modul GRAFY

Doporučená konfigurace pro program SPRÁVCE

k svému provozu potřebuje program počítač s nainstalovaným operačním systémem Windows 95/98/ME/NT/2000/XP. Z hlediska náročnosti programu je vhodné použít počítač s minimálně 128MB RAM (čím více, tím lépe), rychlým diskem a procesorem Pentium 600MHz a výše. Program samozřejmě poběží i na slabší konfiguraci, ale odezva v některých situacích a při větším počtu vět může být delší. Pro síťové použití to platí především. Dále program vyžaduje nastavené rozlišení VGA 1024 × 768 (a vyšší), myš, CD-ROM.

Doporučená konfigurace pro scanovací moduly

scanovací moduly vyžadují pro svou práci nainstalovaný operační systémem Windows 95/98/ME/NT/2000/XP nebo MS-DOS (a kompatibilní) a minimálně 1MB RAM.


Instalace - popis instalace

Popis instalace

1. Pokud provádí instalaci upgrade, pak před začátkem instalace proveďte nejprve ve staré verzi zálohu datových souborů, konfiguračních souborů, filtrů a sestav.

2. Pokyny před instalací programu SPRÁVCE :

· při instalaci se řiďte pokyny instalačního programu.

· neinstalujte program do adresáře, který používá diakritiku (např. C:\Správce), vyhnete se problémům.

· nikdy neinstalujte program přímo do root adresáře lokálního disku (např. D:\).

3. Instalace je síťová, lze ji bez problémů provozovat jak na síťovém disku, tak i na lokálním disku.

4. Pokud chcete mít přístup k programu SPRÁVCE pouze jednouživatelský, nainstalujte program na lokální stanici.

5. Pokud chcete program SPRÁVCE provozovat síťově, musíte modul SPRÁVCE nainstalovat na síťový disk.

6. Instalační program při počáteční instalaci nainstaluje všechny zakoupené moduly programu SPRÁVCE office. Pokud to nezměníte, nainstaluje moduly do následujících adresářů :

· \MICOS\SPRAVCE8 - moduly SPRÁVCE, SESTAVY

· \MICOS\SCANY8 - scanovací moduly scanu HW, SW a RemoteScanu

· \MICOS\GRAFY - moduly GRAFY

· \MICOS\PROOPEN - externí grafický program PROOPEN

7. Instalace ODBC se neprovádí automaticky, naleznete ji na instalačním CD v adresáři \UTILITY.

8. V obalu instalačního CD naleznete Licenční číslo a Kód programu, které musíte vyplnit při prvním spuštění a pomocí nich se zaregistrovat na webu.

9. Uživatel a heslo programu - jméno základního uživatele a jeho heslo pro přístup do programu SPRÁVCE naleznete na papírovém licenčním ujednání nebo na začátku instalace přímo v instalačním programu..

10. Licenční číslo je jednotné pro všechny moduly. Při nákupu více instalací dostáváte jedno licenční číslo pro každý typ instalace (do 50 PC, do 150 PC apod.). Licenční číslo naleznete na přiložené licenční kartě nebo na instalačním CD.


Instalace - prvni spusteni SPRAVCE

První spuštění - SPRÁVCE

1. Při úvodním spuštění programu SPRÁVCE musíte zadat licenční číslo a klíč.

2. Po zadání údajů Vám program automaticky vygeneruje dvoje datové soubory :

a) \DEMO - naplněná zkušební data, na kterých si můžete program nejprve vyzkoušet.

b) \OSTRA - prázdná ostrá data.

c) pokud chcete evidovat více závodů (středisek), pak musíte pomocí tlačítka NOVÝ na úvodním formuláři zadat postupně adresáře pro všechny závody.

3. Po aktivaci ostrých dat se můžete přihlásit do programu. Pokud jste instalaci provedli do nového adresáře, program neumí rozpoznat, zda je o novou instalaci nebo upgrade. Proto se Vás zeptá, zda se jedná o novou instalaci. Nyní mohou nastat následující situace :

a) provádíte upgrade z jakékoliv verze :

v tomto případě odpovězte NE a pomocí následujícího formuláře vyberte umístění datových souboru staré verze. Po výběru datového adresáře (…\DATA) staré verze si program stará data překopíruje do nového adresáře a provede úpravu položek nové verze.

b) provádíte novou instalaci aktuální verze :

v tomto případě odpovězte ANO a program Vám vytvoří prázdné datové soubory. Po spuštění hlavního menu můžete začít pracovat.

4. Načtení databáze vzorů software (nová instalace) nebo jejich úpravu (upgrade). Výsledkem je aktuální stav databáze vzorů software.

5. Po vytvoření datových souborů a indexů spustí program formulář pro nastavení Konfigurace.

6. Nakonec program otevře všechny datové soubory a můžete začít pracovat.

7. Prvním krokem po počáteční instalaci nebo po každém upgrade by mělo být spuštění volby Správa uživatelů :

a) Po počáteční instalaci musíte vytvořit všechny uživatele, kteří budou s programem SPRÁVCE pracovat a nastavit jim přístupy k jednotlivým funkcím programu.

b) Po instalaci upgrade musíte pro nadefinované uživatele zkontrolovat jejich přístupy k jednotlivým volbám a funkcím programu. Při upgrade se mohou vytvořit nové přístupy a ty jsou implicitně pro všechny uživatele zakázány.


Instalace - prvni spusteni SCANY

První spuštění - Scany

Při počáteční instalaci nainstaluje instalační program všechny zakoupené moduly programu SPRÁVCE office.

Scanovací moduly najdete v následujících adresářích :

· \MICOS\SCANY8\ - hlavní scanovací moduly pro scanování pomocí login scriptu a instalace ClientaRS pro RemoteScan

· \MICOS\SCANY8\MS-DOS - scanovací moduly pro scanování DOS stanic

· \MICOS\SCANY8\PRIRUCKA - adresář s uživatelskou příručkou

Ihned po úvodním nainstalování všech modulů musíte spustit program ScanCFG.EXE, kterým nastavíte potřebné parametry a vygenerujete všechny potřebné konfigurační soubory. Podrobnosti naleznete v uživatelské příručce SCANY HW a SW.

Teprve potom můžete začít scanovat !!!


Instalace - Client Spravce

Instalace CLIENTA na pracovní stanice

Jestliže jste nainstalovali program SPRÁVCE na síťový disk, můžete program spouštět z dalších počítačů přímo z tohoto disku bez nutnosti dalších instalací. Pokud se Vám zdá, že je provoz pomalý (pomalá nebo přetížená síť), můžete na pracovní stanice nainstalovat modul SPRAVCE client.

Tento modul je určen pro spouštění z pracovních stanic sítě. Modul Client nainstaluje do zvoleného adresáře (implicitně C:\MicCoS\Client) spouštěcí moduly, které umožňují spustit program SPRÁVCE z lokálního disku pracovní stanice a data natáhnout ze sítě (tento způsob je rychlejší na pomalých nebo vytížených sítích). Zároveň také nainstaluje i Runtime modul VFP 8.0.

Instalace SPRAVCE client :

-------------------------------------------

a) CLIENTA musíte nainstalovat na všechny pracovní stanice, ze kterých budete chtít program SPRÁVCE později spustit. Je vhodné si z instalačního CD instalaci překopírovat na síťový disk, aby jste nemuseli nosit sebou instalační CD nebo si mapovat sdílené CD. Instalaci najdete na instalačním CD v adresáři \OSTRA\SprCli.exe.

b) Instalace na pracovní stanici nainstaluje do zvoleného adresáře (implicitně C:\MiCoS\Client) následující soubory:

· CONFIG.EXE - program pro nastavení cesty k programu SPRÁVCE na síťovém disku

· CLIENT.EXE - program pro spuštění programu SPRÁVCE

· knihovny programu VISUAL FOXPRO 8.0

b) Po instalaci CLIENTA musíte spustit program CONFIG, ve kterém musíte zadat cestu k síťové instalaci programu SPRÁVCE. Program zkontroluje, zda v zadaném adresáři existuje programu SPRAVCE8.EXE. Pokud ano, pak na lokálním disku vytvoří soubory CONFIG.FPW a CONFIG.MEM, ve kterých uloží příslušné parametry a cestu k síťové instalaci programu SPRÁVCE.

c) Po vytvoření výše uvedených souborů můžete normálně spouštět program SPRÁVCE z lokálního disku, a to modulem CLIENT. Existence souboru CONFIG.MEM způsobí, že při spuštění programu CLIENT se přečte adresář s datovými soubory na síti. Program se pak automaticky přepne do tohoto adresáře. Tím je zajištěno, že program spustíte z pracovní stanice a data se převezmou ze síťového disku.

d) Pokud je na síťovém disku zjištěna nová verze programu SPRÁVCE, je tato verze automaticky stažena na lokální stanici.


Instalace - prava na adresare

Práva na adresáře

K nastavení přístupových práv můžete přistoupit až po spuštění programu všemi nadefinovanými uživateli a po nastavení všech důležitých cest. Úvodní spuštění programu SPRÁVCE a konfiguračního souboru SCANCFG musí provést správce s plnými právy k hlavnímu adresáři \MICOS.

Nastavení práv pro ostatní uživatele :

1. SPRÁVCE

Hlavní adresář

\MICOS\SPRAVCE8

může být Read only jen za těchto podmínek :

· v souboru CONFIG.FPW zůstane parametr RESOURCE nastaven tak, jak je (RESOURCE = .\CONFIG\FOXUSER.DBF), případně na nějaký jiný existující adresář.

· v souboru CONFIG.FPW zůstane parametr TMPFILES a nebude mít na začátku hvězdičku (bude mít vyplněný adresář pro umístění TMP souborů).

· dále musí být spuštěn alespoň jednou program SPRÁVCE, aby se vytvořily všechny potřebné podadresáře.

Vhodnější je ponechat právo zápisu.

Konfigurační adresář

\MICOS\SPRAVCE8\CONFIG

musí mít všechna přístupová práva.

Generátor lib. sestav

\MICOS\SPRAVCE8\GEN_SEST

musí mít všechna přístupová práva.

Update vzorů SW

\MICOS\SPRAVCE8\UPG_VZOR

musí mít právo zápisu.

Adresář s DEMO daty

\MICOS\SPRAVCE8\DEMO

musí mít všechna přístupová práva.

Adresář s OSTRÝMI daty

\MICOS\SPRAVCE8\OSTRA

- (příklad adresáře s ostrými daty) musí mít všechna přístupová práva.

Adresář s helpem

\MICOS\SPRAVCE8\HLP

může být Read only.

Adresář s OCX soubory

\MICOS\SPRAVCE8\GEN_SEST

musí mít všechna přístupová práva.

2. SCANY HW, SW

Hlavní adresář

\MICOS\SCANY8

může být Read only, pokud byly již vytvořeny všechny konfigurační soubory a nastaven soubor ScanWin.INI.

Adresář pro TXT soubory

\MICOS\SCANY8\TXT

musí mít všechna přístupová práva.


Instalace - multilicence

Multilicence

Pokud máte zakoupeno více instalací programu SPRÁVCE a používáte program KSPRÁVCE k sehrávání dat, musíte při nasazení programu dodržet následující postup:

1. nainstalovat program KSPRÁVCE na nadřízené organizační jednotce.

2. v programu KSPRÁVCE naplnit číselník závodů. Tento číselník je nutný, aby jste podřízeným programům SPRÁVCE mohli přiřadit Číslo závodu. Každá instalace programu SPRÁVCE vyžaduje přidělit tzv. Číslo závodu. Toto číslo musí být jednoznačné v celé organizaci, a proto se přiděluje v programu KSPRÁVCE, a to v číselníku závodů.

3. navrhnout v programu KSPRÁVCE ostatní centrální číselníky a předávací protokoly.

4. ve volbě Centrální soubory - Export centrálních souborů programu KSPRÁVCE musíte rozhodnout, které číselníky chcete centrálně udržovat a které můžete nechat neudržované.

5. provést EXPORT centrálních souborů z programu KSPRÁVCE. Při tomto exportu nastavíte parametry, které chcete mít jednotné pro všechny programy SPRÁVCE. Export vytvoří do zvoleného adresáře všechny centrálně udržované číselníky a konfigurační soubory, které se jmenují podle čísla závodů.

6. nainstalovat program SPRÁVCE na podřízených organizačních jednotkách.

7. při prvním spuštění programu SPRÁVCE je nutné mít přichystané centrální soubory z programu KSPRÁVCE. Program Vám totiž nahlásí, že chybí soubor KONFIG2.DBF a nabídne možnost jej vytvořit nový (všechny nastavené parametry budou zakázány), obnovit ze záložní kopie nebo jej načíst z přichystaných centrálních souborů programu KSPRÁVCE.

8. pokud jste v programu KSPRÁVCE navrhli centrální číselníky, je nutné v programu SPRÁVCE spustit menu Nadstavba – Přihrání centrálních číselníků. Tato volba naplní prázdné číselníky hodnotami z centrálních číselníků.


Instalace - upgrade

Upgrade

Instalaci upgrade SPRÁVCE office musíte provést :

1. z verzí nižších než 8.00 do nového adresáře – byla změněna celková struktura adresářů. Po nainstalování upgrade, spuštění programu a nastavení všech parametrů musíte zkontrolovat obsah původních podadresářů staré verze. Program neumí nakopírovat všechny uložené sestavy, filtry, pomocné soubory apod. ze staré verze do nových adresářů. Po zkopírování potřebných souborů můžete původní adresář smazat.

2. z verzí 8.* do stávajícího adresáře – upgrade všech verzí 8.* lze instalovat do původních adresářů.


Struktury souboru

Struktury souborů

SPRÁVCE

KSPRÁVCE


Struktury souboru - Spravce

Struktury souborů - SPRÁVCE

Hlavní datové soubory

HARDWARE - seznam počítačů

SOFTWARE - seznam software

PŘÍSLUŠENSTVÍ hardware - seznam příslušenství hardware

SÍŤOVÁ technika - seznam síťové techniky

OSTATNÍ technika - seznam ostatní techniky

DOKUMENT - seznam dokumentace

SÍTĚ - seznam sítí

POŽADAVKY - seznam požadavků

FIRMY - seznam firem

SCAN SW - soubory pro scan SW

SCAN HW - soubory pro scan HW

ČÍSELNÍKY - seznam všech číselníků

VAZBY - seznam všech vazebních souborů

KONFIGURACE - seznam konfiguračních souborů

PROGRAMOVÉ SOUBORY - seznam programových souborů


Struktury souboru - Kspravce

Struktury souborů - KSPRÁVCE

Centrální soubory KSPRÁVCE - podadresář \CISELNIK

Soubory načtené ze SPRÁVCE - podadresář \OSTRA\DATA


.Uvod do aplikace Spravce

Úvod do aplikace SPRÁVCE

Program slouží k evidenci výpočetní techniky u organizace. Umožňuje nasazení v několika řídících úrovních. Nejnižší úrovni (tzv. SPRÁVCI PC) slouží pro přehlednou evidenci stavu výpočetní techniky v provozu, při opravách poškozených součástí počítačů, při haváriích počítačů, kontrole software, při plánování požadavků na další rozvoj, při statistikách pro vedoucí pracovníky apod. Dále je program samozřejmě určen i oblasti vedoucích pracovníků, kterým slouží jako podklad pro plánování a další rozvoj výpočetní techniky.


.Spusteni programu

Spuštění programu

Při spuštění programu se provádějí následující kroky:

Výběr datových souborů

Přihlášení uživatele

Kontroly souborů

Nastavení Konfigurace - spouští se pouze při prvním spuštění


.Spusteni programu - vyber datovych souboru

Úvod - výběr datových souborů

Po spuštění programu se objeví formulář pro výběr datových souborů.

Při prvním spuštění se přes tento formulář zobrazí formulář Registrace na kterém musíte zadat licenční číslo a klíč programu, jinak se nedostanete dále. Formulář Registrace lze kdykoliv později vyvolat pomocí tlačítka Klíč.

Další činnost na tomto formuláři je daná zakoupenou licencí programu SPRÁVCE.

1. SPRÁVCE office – Standard

Tuto standardní licenci můžete využít k evidenci jedné firmy, závodu nebo střediska (dále jen firmy) nebo ji můžete rozdělit mezi více firem. Celkový počet evidovaných počítačů (u všech firem dohromady) nesmí překročit velikost zakoupené licence. Počet počítačů pro jednotlivé firmy nastavíte ve sloupci Licen HW. Ve sloupci Vět HW je uveden skutečný počet vět v souboru hardware.

Pokud celkový počet vět v souborech hardware překročí velikost zakoupené licence nelze program spustit. Musíte kontaktovat autorskou firmu a případně rozšířit licenci na více počítačů.

Při prvním spuštění programu se automaticky vytvoří tyto datové adresáře:

· první tzv. DEMO DATA (adresář \DEMO) jsou určena pouze pro úvodní seznámení s funkcemi programu. Tato data se vytvářejí při instalaci a jsou naplněná cvičnými údaji. Při práci s těmito daty se program chová jako DEMO verze, tzn. že lze evidovat pouze 10 počítačů a nelze tisknout sestavy.

· druhá tzv. OSTRÁ DATA jsou vytvořena prázdná a slouží pro Vaše ostré soubory. Tyto první OSTRÁ data jsou vždy v podadresáři \OSTRA.

Ostré datové soubory dalších firem musíte vytvořit pomocí tlačítka NOVÝ. Všechny tyto firmy/závody jsou samostatné evidence, tzn. mají vlastní číselníky, sestavy, filtry apod.. Data těchto firem jsou umístěná v adresářích \OSTRA01, \OSTRA02, … Pokud budete chtít v několika závodech používat stejné číselníky, lze si je navzájem nakopírovat volbou EXPORT v menu Údržba.

Program si pamatuje, která data byla naposledy spuštěna a při dalším spuštění stojí kursor na těchto datech.

Jestliže program používáte pouze pro jednu firmu a zaškrtnete parametr Nezobrazovat tuto obrazovku, budou při dalším spuštění nabíhat vždy OSTRÁ DATA a program nebude nabízet formulář pro výběr dat.

Pokud máte evidenci rozdělenou na více firem, je parametr Nezobrazovat tuto obrazovku zablokován, tento formulář je spuštěn pokaždé a Vy si musíte vybrat data, se kterými chcete pracovat.

Demoverze neumožňuje práci s více firmami.

2. SPRÁVCE office - Prohlížeč

Tato licence umožňuje pouze prohlížení údajů a tisk sestav bez možnosti jakékoliv aktualizace.

Kromě datových adresářů se vytvářejí uživatelské adresáře a další pevné adresáře. Všechny tyto následující adresáře se vytvářejí pod zvoleným adresářem pro datové soubory (např. \SPRAVCE8\OSTRA).

A) UŽIVATELSKÉ ADRESÁŘE

Každý uživatel programu má svůj vlastní adresář podle svého jména, ve kterém se vytvářejí pomocné a pracovní soubory (adresář \PRAC - pracovní soubory při zálohování, obnově,...) a adresář pro výstup tiskových sestav do souboru (adresář \TISKY). Tyto adresáře jsou pro každého uživatele samostatné. Například : uživatel spravce má tedy adresář \SPRAVCE\PRAC a \SPRAVCE\TISKY. Tyto adresáře vždy vytvářejí v datovém adresáři např. (C:\MICOS\SPRAVCE8\OSTRA\SPRAVCE\...).

Vytvoření uživatelských adresářů si vynutila síťová verze programu, kde bylo třeba zabezpečit ochranu pomocných a pracovních souborů. Jejich použití přináší omezení, že do programu může být přihlášen jeden uživatel pouze jednou. Další přístup stejného uživatele je odmítnut. Tzn. že je třeba vhodně nadefinovat uživatele pro přístup k programu.

B) PEVNÉ ADRESÁŘE

\EXPORT

- adresář pro Export souborů do formátu TXT, DBF a XLS

\FILTRY

- adresář s nadefinovanými Filtry

\IMPORT

- adresář pro Import některých číselníků

\SESTAVY

- adresář s vygenerovanými libovolnými sestavami programu SPRÁVCE ( Libovolná sestava )

\QSESTAVY

- adresář s vygenerovanými sestavami programu SESTAVY

\ZALOHA

- adresář pro Archivace dat

Tyto adresáře si program sám vytváří a při smazání je při dalším spuštění opět vytvoří.


.Spusteni programu - prihlaseni uzivatele

Úvod - přihlášení uživatele

Tento formulář slouží k přihlášení uživatele, který má přístup k programu. Po zadání jména uživatele se kurzor přesune na položku Heslo. Zde můžete zadat heslo nebo stiskem kláves ALT+H provést změnu hesla zadaného uživatele. Pokud je zadán správně uživatel a jeho heslo, program nastaví přístupová práva na hlavní datové soubory a otevře hlavní menu.

Přihlášený uživatel může být do programu přihlášen jen jednou (kvůli pracovním a pomocným adresářům). Při přihlášení se vytvoří a otevře textový soubor podle jména aktuálně přihlášeného uživatele (např. spravce.txt), který se při ukončení programu zavře a smaže. Při nekorektním uzavření programu tento soubor zůstane na disku. Při dalším spuštění programu je tento soubor zkontrolován, zda jde otevřít. Pokud ano program pokračuje, pokud ne znamená to, že tento uživatel je ještě stále přihlášen a přihlášení je odepřeno.

!!! POZOR !!!

******************************

Pokročilé rozhraní menu

tento parametr ovlivňuje, zda budou v menu a toolbaru zapnuty všechny volby (pokročilé menu) nebo jen základní.


.Spusteni programu - kontroly souboru

Kontroly souborů

Po spuštění programu a výběru datových souborů jsou provedeny následující kontroly :

Test existence datového adresáře :

pokud zadaný datový adresář neexistuje, následuje dotaz, zda se jedná o první instalaci. Odpovíte-li Ano, je vytvořen zadaný adresář a v něm prázdné datové soubory. Pokud odpovíte Ne, program Vás vyzve, aby jste zadali původní adresář s Vašimi datovými soubory.

Test existence všech datových souborů :

pokud některý ze souborů neexistuje, program se spustí, ale zablokují se všechny volby kromě Obnovy dat. souborů ze záložní kopie. Pokud záložní kopie nemáte, program nebude fungovat.

Kontrola indexních souborů :

neexistuje-li některý indexní soubor, je automaticky spuštěna volba Údržba - Reindex .

Kontrola konfiguračních souborů :

konfigurační soubory SPRAVCE.MEM, FORMULAR.DBF, PRISTUPY.DBF, AUTO.MEM, PROTOKOL.DBF a PROTOKOL.FPT (popř. HW_SCAN.MEM, SW_SCAN.MEM) nejsou součástí databáze. Pokud některý z nich neexistuje, nabídne program formulář Obnova konfiguračních souborů

Kontrola souboru KONFIG2.DBF pro multilicence :

pokud soubor KONFIG2.DBF neexistuje, pak program nabízí :

· při prvním spuštění se program na nic neptá a vygeneruje nový soubor KONFIG2.DBF. V tomto souboru nastaví všechny hodnoty na NE.

· při dalším spuštění nabídne na formuláři Chybí soubory, ve kterém máte možnost vytvořit prázdný s default hodnotami (stejné jako bod a)) nebo obnovit soubor ze zálohy.


Udrzba - Konfigurace

Konfigurace

Tato volba slouží k nastavení základních parametrů programu. Obsahuje následující karty :

Obecné - základní parametry

Formuláře - nastavení vzhledu formulářů

Sestavy - text předávacích protokolů

Automatické procedury - nastavení automatických procedur

Multilicence - parametry určené pouze pro multilicence


. Ovladani programu

Ovládání programu

K ovládání programu slouží hlavní nabídka (menu), panel nástrojů a jednotlivé objekty na formulářích.

Hlavní nabídka (menu)

Formuláře

Ovládací tlačítka

Hromadné výběry


. Ovladani programu - menu

Ovládání programu - menu

Hlavní nabídka a panel nástrojů

z hlavní nabídky (menu) programu lze spouštět všechny funkce programu. Stručný popis každé volby je zobrazen na spodním řádku aktivního okna.

Pod hlavní nabídkou je panel nástrojů, který umožňuje spustit aktualizace hlavních datových souboru a dále obsahuje společná tlačítka pro rušení vět, hledání, nastavení výběru, tisk a nápovědu. Tato tlačítka jsou přístupná pouze tehdy, pokud je aktivní formulář hlavních souboru nebo číselníku.

Pokud je uplatněno alespoň jedno hromadné zadávání hodnot oprav, je datum zobrazované v panelu nástrojů zobrazeno červeně.

Parametr ARCHIV LIKVIDACE slouží pro přepnutí do archivu zlikvidovaných vět. Pokud je pole zaškrtnuté je text zobrazen červeně.

Zrušení věty - zrušení aktuální věty

Hledání - hledání věty v aktivním souboru

Nastavení filtru - nastavení filtru pro zobrazení vět

Tisk sestav - tisk sestav

Generátor sestav - tisk sestav


.Ovladani programu - formulare

Ovládání programu - formuláře

Formuláře

základními objekty v celé aplikaci jsou formuláře. Jejich prostřednictvím probíhá komunikace uživatele s programem. V programu jsou dva typy formulářů. První slouží pro aktualizaci jednotlivých datových souboru, druhý typ se používá jako dialogová okna.

V titulku formuláře pro aktualizaci je uveden název souboru, pro který se aktualizace provádí, počet vět v tomto souboru, a popis aktuálně nastaveného filtru. Hlavní část formuláře zaujímá listovací rámeček s kartami. Na první kartě se nachází mřížka, v níž jsou zobrazeny jednotlivé věty daného souboru. Ve spodní části formuláře jsou umístěny tlačítka, pomocí nichž se lze pohybovat po větách v souboru, přidávat a opravovat údaje, ukládat změny atd.

Formulář pro dialog obsahuje sdělení o prováděné akci a seznam tlačítek pro možné činnosti. Např. :

Změna třídění mřížek

změnu třídění lze provést dvojitým kliknutím myší na hlavičce sloupce, který vedle názvu ikonu označující změnu třídění.

Výběr vět

pokud je v mřížkách zelený sloupec s bílým čtverečkem (tzv. chkbox), slouží tento čtvereček pro výběr věty k nějaké činnosti. Výběr provedete stiskem levého tlačítka myši v tomto čtverečku.

Likvidace

věty v mřížkách zobrazené zelenou barvou označují, že dané zařízení (příslušenství, hardware, …) bylo zlikvidováno. V souboru oprav má toto zařízení STAV=8. S tímto zařízením nelze již manipulovat.


.Ovladani programu - ovladaci tlacitka

Ovládání programu - tlačítka

Ovládací tlačítka

Nová přidání nové věty

Oprava oprava aktuální věty

Duplik přidání nové věty s naplněním obsahu položek

Uložit uložení provedených změn v datech

Vrátit zrušení provedených změn

Konec ukončení formuláře

potvrzení akce, změn apod.

opuštění formuláře bez provedení akce

zobrazení dalších detailních údajů

zobrazení celého souboru pro výběr hodnoty

navigační tlačítka pro pohyb po větách


. Ovladani programu - specialni tlacitka

Ovládání programu – speciální tlačítka

Poznámka - zápis libovolné poznámky k aktuálnímu zařízení

Hromadná změna - provedení změny u více vět najednou

Hromadné rušení - zrušení více vět najednou

Provedení servisu - hromadné provedení servisů

Rychlé hledání

pomocí tohoto prvku můžete provádět rychlé hledání podle aktuálně nastaveného třídění. Stačí pouze zadat hledanou hodnotu a stisknout tlačítko >>.


.Ovladani programu - formulare

Ovládání programu - mřížka

Mřížka

Mřížka je základní prvek pro zobrazení seznamu dat.

Změna třídění mřížek

změnu třídění lze provést dvojitým kliknutím myší na hlavičce sloupce, který vedle názvu ikonu označující změnu třídění.

Definování vzhledu mřížek

U některých mřížek (především těch, které jsou na hlavních formulářích), lze definovat pořadí a výběr sloupců, které budou viditelné v mřížce. Definovaní se provádí pomocí volby Změna sloupců z menu pravého tlačítka myši vyvolaného nad hlavičkami mřížky.

Volbou Změna sloupců se spustí formulář pro změnu vzhledu mřížky. Volba Obnovení standardního vzhledu vrátí nastavení mřížky, do stavu který je nadefinován přímo v programu.

Při ukončení formuláře se uloží aktuální nastavení sloupců a při příštím spuštění se tento stav nastaví.

Inkrementální vyhledávání

Ve sloupcích mřížek je možné inkrementálně vyhledávat. Nastavením do požadovaného sloupce, ve kterém chcete vyhledávat a stiskem hledaného písmene se nalezne první věta která odpovídá požadavkům. Záznamy se prohledávají vždy od první věty


.Ovladani programu - hromadny vyber

Ovládání programu - výběry

Hromadný výběr

hromadný výběr vět provedete vždy pomocí pravého tlačítka myši a výběrem volby Označ vše nebo Odznač vše.


Hledani

Ovládání programu - hledání

Vyhledávat lze dvěma způsoby :

a) Podle třídění

pokud hledáte podle třídění souboru, musíte nejdříve určit setřídění souboru. Implicitně je nabízeno aktuálně nastavené třídění. Toto setřídění můžete samozřejmě změnit. Program nabízí seznam všech položek, které mají vytvořený index. Po zadání třídění, musíte zadat hledaný řetězec a potvrdit tlačítkem OK. Daný soubor se automaticky setřídí podle zvoleného třídění (zadaný index se nastaví jako první sloupec) a program se pokusí najít hledaný řetězec. Při tomto způsobu lze vyhledávat pouze podle řetězce zleva (nelze vyhledat libovolný podřetězec). Pokud se zadaný řetězec nalezne, program nastaví kursor na danou větu. Nenajde-li se tento řetězec, program na to upozorní a zůstane na původní větě.

Po vyhledání daného řetězce se okno formuláře Hledej zavře.

b) Podle podřetězce

při hledání podle podřetězce je nutno zadat položku, ve které se má daný řetězec hledat. Program nabízí seznam všech položek daného souboru. Pokud se hledaná hodnota najde, ukazatel v tabulce se nastaví na tuto větu a tlačítkem Pokračovat lze vyhledat případně další výskyt, v opačném případě zůstane kursor na původní větě.

Po vyhledání daného řetězce se okno formuláře Hledej nezavře a lze pokračovat dalším hledáním.

POZOR -

· datumové položky - je nutné je zadávat ve tvaru DD.MM.RRRR (např. 23.05.1998)

· logické položky - je nutné je zadávat ve tvaru .F. (.f.) nebo .T. (.t.)

Inkrementální vyhledávání

Ve sloupcích mřížek je možné inkrementálně vyhledávat. Nastavením do požadovaného sloupce, ve kterém chcete vyhledávat a stiskem hledaného písmene se nalezne první věta která odpovídá požadavkům. Záznamy se prohledávají vždy od první věty


Filtr

Nastavení filtru

Formulář pro definování filtru je rozdělen na dvě části. Levá část formuláře obsahuje seznam uložených filtru a pravá část prvky pro definování podmínky filtru.

Podmínku pro filtr sestavíte tak, že ze seznamu položek vyberete jednu z položek příslušného souboru. Dále zvolíte typ OPERÁTORU a pak zadáte požadovanou HODNOTU. Pokud chcete vybrat hodnotu, která se v souboru stoprocentně vyskytuje, musíte stisknout tlačítko NACTI (tlačítko se třemi tečkami). Stiskem tohoto tlačítka dojde k načtení všech hodnot dané položky z celého souboru. Pak stačí jen ze seznamu HODNOT vybrat požadovanou hodnotu.

Stiskem tlačítka AND nebo OR se sestavený výraz přenese do pole označené PODMÍNKA, v němž se zobrazuje podmínka filtru. Nyní lze opět od začátku zadávat další požadavek. Přenesení sestaveného výrazu do pole PODMÍNKA se provede pouze stisknutím tlačítka AND nebo OR, a to i v případě, že se jedná o jednoduchý výraz. V poli PODMÍNKA lze také normálně psát. Takže pokud znáte syntaxi příkazu FOXPRO pro práci s řetězci, můžete si zde zapsat libovolnou podmínku přímo. Chcete-li použít závorky, musíte je rovněž zadat ručně.

Položka NÁZEV FILTRU slouží ke stručnému popisu nadefinovaného filtru. Zobrazí se v titulku daného formuláře, v nadpisu sestav a případně se pod tímto názvem uloží. Zadání je povinné.

Pokud již máte sestavenou celou podmínku filtru, stisknete tlačítko Nastav filtr a nastavení filtru se provede. Pokud stisknete tlačítko Zpět, nastavení filtru se neprovede. Stiskem tlačítka Zruš filtr provedete zrušení předchozího filtru, tzn. že se ukončí formulář definování filtru a v mřížce se seznamem vět daného souboru budou zobrazeny všechny věty. Jestliže chcete zrušit pouze nadefinovanou podmínku a začít definovat novou, musíte se kursorem přemístit do pole PODMÍNKA a v něm můžete všechno smazat nebo tam provést libovolnou úpravu.

Nadefinované podmínky filtrů lze ukládat do databáze pomocí tlačítek Uložit filtr a Načíst filtr. Tlačítko Importovat starý filtr slouží k načtení filtru ze souborů s příponou FIL, které sloužily k uložení filtrů v předchozích verzích programu Správce.

Pokud je nad formulářem nastaven filtr, který je uložen v databázi, tak při příštím startu tohoto formuláře se filtr nastaví.

POZOR :

V seznamu DOSTUPNÁ POLE jsou zobrazeny všechny položky aktuální souboru (např. hardware) a položky souborů, které mají k tomuto souboru vazby, podle kterých lze nadefinovat logickou podmínku. Soubory, které sice k tomuto hlavnímu souboru mají vazbu, ale nejde v nich vytvořit logickou vazbu, v tomto seznamu nejsou obsaženy. Jestliže je podmínka založena na vazebních souborech, jedná se většinou o vazbu typu 1:N (kromě číselníku, kde je vazba 1:1) a při aplikování filtru na daný soubor se v mřížce na první kartě formuláře objeví řádky s hvězdičkami (*******), které signalizují tuto vazbu (např. hardware má k sobe přiřazeno více příslušenství). Tato možnost je tu proto, aby jste například mohli provést filtr na všechny počítače, které mají přiřazenu tiskárnu EPSON nebo nainstalovaný software NC 5.0. V okamžiku zrušení filtru se řádky s hvězdičkami v mřížce vrátí do původního stavu.

V položce HODNOTA se musí údaje zadávat ve tvaru :

datumové položky - je nutné je zadávat ve tvaru DD.MM.RRRR (např. 23.05.1998)

logické položky - je nutné je zadávat ve tvaru .F. (.f.) nebo .T. (.t.)

numerické položky - desetinné číslo je nutné zadávat s desetinnou tečkou (např. 1500.50)

Pokud v textovém řetězci potřebujete uvést dvojité uvozovky (např. MONITOR 15") je nutné vnější uvozovky přepsat na jednoduché. Nelze mít text uvozen dvojitými uvozovkami a uprostřed mít další jednu dvojitou uvozovku. Obecně platí, že pokud máte v textu nějakou uvozovku (' nebo "), ohraničení textu musí mít opačnou uvozovku.


Tisky

Tlačítko pro tisky je přístupné pouze v okamžiku otevření formuláře hlavních datových souborů nebo číselníků. Po stisku se v dialogovém okně zobrazí seznam dostupných sestav daného souboru. Výběr sestavy lze provést levým tlačítkem myši a stiskem tlačítka OK nebo přímo dvojitým klikem myši na vybrané sestavě.

Setřídění sestavy

všechny sestavy, pokud v tomto formuláři neurčíte jinak, se tisknou setříděny podle aktuálně nastaveného třídění. Pokud změníte tento parametr, budou se tisknout podle zvoleného třídění.

Období pro sestavu

pro některé sestavy lze zvolit období od – do, které umožňuje vytisknout pouze věty za dané období.

Nastavení pasportu

u sestav Pasportní list HW a Předávací protokol HW lze zvolit, zda se mají vytisknout kompletní (volba Všechno) nebo jen částečné (volby Software, Příslušenství a Hardware). U hardware lze zvolit, zda chcete tisknout Ekonomické údaje a zda chcete tisknout jen Legální SW.

Obor vět pro tisk

sestavy lze tisknout buď pro aktuální větu nebo pro všechny věty daného souboru.

Stavy oprav

sestavu Seznam oprav lze tisknout pro libovolný stav opravy (stavy 1-10).

Nastavení výstupu

Výstup sestavy lze směřovat na :

Obrazovka

vybraná sestava se zobrazí na obrazovce. Při prohlížení sestavy lze zjistit čísla stránek a při přímém výstupu na tiskárnu lze zadat pouze čísla stránek, které chcete vytisknout. Po spuštění sestavy na obrazovku se v horní části obrazovky zobrazí panel Print Preview, pomocí kterého lze skákat na další strany dopředu i dozadu.

Tiskárna

vybraná sestava se vytiskne na tiskárnu. Před vlastním tiskem se zobrazí dialog tiskáren z Windows. V tomto dialogovém formuláři lze nastavit kvalitu tisku, počet kopií, čísla vybraných stránek a zvolit libovolnou tiskárnu, která je připojena.

Soubor (DOC)

vybraná sestava se vytiskne do formátu MS WORD. Automaticky je generován název výstupního souboru, který můžete opravit. Sestava se generuje do adresáře ...\uživatel\TISKY. Pokud má sestava méně než 15 stran, vytiskne se celá do jednoho souboru a po vygenerování se zobrazí na obrazovku. Pokud má sestava více než 15stran, generuje se do více souborů (max. po 15-ti stránkách) a po vygenerování se neotvírá, musíte ji otevřít ručně. V okamžiku generování a otvírání sestavy není vhodné cokoliv dělat v aplikaci.

Soubor (HTM)

vybraná sestava se vytiskne do souboru typu HTM. Automaticky je generován název výstupního souboru, který můžete opravit. Sestava se generuje do adresáře ...\uživatel\TISKY. Pokud je asociován program na spuštění, je sestava automaticky po vygenerování spuštěna.

Soubor (PDF)

vybraná sestava se vytiskne do souboru typu PDF. Automaticky je generován název výstupního souboru, který můžete opravit. Sestava se generuje do adresáře ...\uživatel\TISKY. Pokud je asociován program na spuštění, je sestava automaticky po vygenerování spuštěna.

Soubor (RTF)

vybraná sestava se vytiskne do souboru typu RTF. Automaticky je generován název výstupního souboru, který můžete opravit. Sestava se generuje do adresáře ...\uživatel\TISKY. Pokud je asociován program na spuštění, je sestava automaticky po vygenerování spuštěna.

Soubor (XML)

vybraná sestava se vytiskne do souboru typu XML. Automaticky je generován název výstupního souboru, který můžete opravit. Sestava se generuje do adresáře ...\uživatel\TISKY.

Tisk vět bez vazeb

pokud je hodnota .T., pak sestava obsahuje všechny věty daného souboru, bez ohledu na to, zda mají nějaké vazby (např. přiřazené příslušenství, nainstalovaný software). Jestliže je hodnota .F., pak sestava obsahuje pouze věty, které mají nějakou vazbu (např. přiřazené příslušenství, nainstalovaný software).

Tisk výplně rámečků

tento parametr určuje, zda se bude tisknout výplň rámečků. Výplň rámečků je šedá. Na některých tiskárnách může být tato šedá barva stejně tmavá jako písmo v rámečku a tisk je potom nečitelný. Tento jev nastává pouze v některých případech (záleží na nastavení tiskárny - kvalita tisku apod.). Pokud nechcete měnit toto nastavení, můžete tisk výplně rámečků raději vypnout.

Tisk přílohy před. prot. HW

určení, zda přílohu (volitelnou část) Předávacího protokolu HW (nastavenou v Konfiguraci programu) chcete tisknout ihned za pevnou částí nebo na samostatné straně. Pokud je hodnota nastavena na .T., tiskne se příloha na samostatném straně.

Tisk downgrade názvů SW

tento parametr slouží k výběru, zda při tisku sestav SW se v případě použití tzv. downgrade bude tisknout skutečně čerpaná licence nebo skutečně nalezená licence.

Lokalizace

určuje lokalizaci ve které se bude sestava tisknout.


Hromadna zmena dat

Hromadná změna dat

Tento formulář umožňuje v hlavních datových souborech provádět hromadné změny v některých položkách. Jsou vybrány pouze ty položky, u kterých má hromadná změna význam a logiku. Pokud byl na původním formuláři nastaven nějaký filtr, je zachován i v tomto formuláři.

Na formuláři pro změnu je nutno nejprve zvolit položku, ve které se bude změna provádět. Pak je třeba zadat původní hodnotu a dále hodnotu novou. Po zadání původní hodnoty se ve spodní části formuláře zobrazí seznam záznamů odpovídajících této podmínce. V tomto seznamu je třeba zatrhnout záznamy, kterých se má změna týkat. V mřížce jsou zobrazeny i zlikvidované věty zeleně (STAV=8), nelze je označit a tudíž u nich ani nelze provádět jakékoliv změny. Hromadnou změnu dat nelze provést na věty software, které jsou označeny jako multilicenci a mají vyplněnou položku Mateřská licence. V dolní části se aktualizuje počet vybraných vět. Samotnou změnu provedeme kliknutím na tlačítku Změnit. Po provedení změny se formulář automaticky nezruší, takže můžete pokračovat v dalších změnách. Tlačítkem Konec ukončíte formulář.


Hromadny servis

Hromadný servis

Tento formulář umožňuje v Hardware, Software, Příslušenství a Sítí provádět hromadné zadávání servisů. Při spuštění této volby se zobrazí formulář s vybranými větami, u kterých se může servis provést. Vyberou se věty, u kterých je datum příštího servisu menší než dnešní datum z počítače, pokud požadujeme výběr k jinému datu, to lze zadat ve formuláři v pravém horním rohu.


Ukonceni programu

Konec programu

Tato volba slouží ke správnému ukončení programu. Nejprve dojde k uzavření všech datových souborů. Tím jsou chráněny před poškozením, ke kterému může dojít nesprávným ukončením programu. Potom následuje uzavření programu. Po tomto ukončení lze počítač vypnout.

Nikdy nevypínejte nebo nepoužívejte tlačítko RESET (nebo tzv. teplý start), pokud jste program neukončili touto volbou. Při těchto situacích většinou dochází k poškození indexních souborů a někdy i k poškození datových souborů.


Likvidace

Rušení, Likvidace vět

U hlavních souborů hardware, software, příslušenství hw, síťová technika, ostatní technika a sítě lze smazat větu několika způsoby :

a) zrušení jedné věty pomocí tlačítka v toolbaru – věta se fyzicky smaže bez možnosti návratu.

Toto rušení funguje i u všech číselníků.

b) hromadné zrušení několika vět pomocí tlačítka v dolní části formuláře hlavních souborů – věty se fyzicky smažou bez možnosti návratu.

c) likvidací pomocí pravého tlačítka myši na kartě Seznam hlavních souborů.

Zlikvidované věty zůstávají v souborech, dají se přesunout do archivu, případně vrátit zpět.


Ruseni vet - jednotlive

Rušení vět - jednotlivě

Rušení jednotlivých vět lze u hlavních souborů a číselníků provádět pouze na prvních kartách, které neobsahují vazby na jiné soubory.

Rušení se provádí pomocí tlačítko v horním toolbaru. Před zrušením každé věty jste dotázání, zda tuto větu chcete opravdu zrušit. Pokud odpovíte ANO, tato věta bude označena příznakem zrušení, ale v souboru zůstane. Odstranění takových vět ze souborů provedete ve volbě Údržba - Setřepání dat. Budete-li provádět rušení více vět, je dobré tuto volbu spustit po jejich zrušení.

Jestliže chcete z nějakého číselníku zrušit větu, jejíž hodnota se nachází v některé z hlavních evidencí, program to odmítne a vypíše seznam souborů, v nichž se hodnota nachází.

HARDWARE

pokud je na rušeném počítači nainstalován nějaký software nebo je k němu přiřazeno nějaké příslušenství, program nabídne formulář pro Zrušení nebo odřazení přiřazeného software a příslušenství , ve kterém je nutné určit, který software/příslušenství se odřadí a který se fyzicky zruší. Dále je uvolněna veškerá přiřazená dokumentace a jestliže je počítač v síti, pak se přepočítá počet stanic na síti. Pokud k počítači existují nascanované textové soubory, máte možnost na konci rušení určit, zda se mají rovněž smazat. Současně s rušeným hardware a příslušenstvím jsou zrušeny také všechny jejich opravy.

SOFTWARE

je-li software nainstalován alespoň na jeden počítač, program Vás na to upozorní a máte možnost zrušení odvolat. Pokud se jedná o software, na který byl proveden upgrade, nelze zrušení provést. Rušení také nelze provést, jestliže máte aktuální software označen jako multilicenci a máte vyplněnou položku Mateřská licence. Při zrušení software je uvolněna veškerá přiřazená dokumentace a pokud je tento software upgrade jiného software, pak se u původního vymaže číslo upgrade.

PŘÍSLUŠENSTVÍ

jestliže k příslušenství byla zakoupena OEM verze software, je tato vazba zrušena. Do položky jako OEM zakoupeno k je zapsán odkaz na toto zrušené příslušenství. Dále dojde k odřazení přiřazené dokumentace. Současně s příslušenstvím jsou zrušeny také všechny jeho opravy.

SÍTĚ

při rušení sítí se smažou veškeré vazby na hardware, příslušenství a dokumentaci. Současně s rušenou sítí jsou zrušeny také všechny její opravy.


Ruseni vet - hromadne

Hromadné rušení vět

Hromadné rušení vět lze provést pouze v hlavních souborech. Nelze rušit věty, které mají vyplněnou položku Datum zařazení do účetnictví.

Pokud byl na původním formuláři nastaven nějaký filtr, je zachován i v tomto formuláři a je doplněn o podmínku, aby se nezobrazily věty, které mají vyplněnou položku Datum zařazení do účetnictví. Uprostřed formuláře je zobrazen seznam vět, ve kterém je třeba zatrhnout věty, které chcete zrušit. Věty zobrazené zelenou barvou označují zařízení, které již bylo zlikvidováno (v souboru oprav má STAV=8). Máte možnost je označit a tudíž i zrušit. Samotné zrušení provedete kliknutím na tlačítku Zrušit.

Rušení HW

automaticky je odřazen software, dokumentace a příslušenství, které není součástí počítače při nákupu. Příslušenství, které je součástí počítače při nákupu je zrušeno. Parametrem Zrušit nascanované soubory lze zvolit, zda se z disku mají smazat příslušné nascanované soubory HW a SW scanu.

Rušení SW

provede se odřazení od počítače. V souboru SW_NALEZ bude tento software označen jako nelegální. Rušení software nelze provést na věty software, které jsou označeny jako multilicenci a mají vyplněnou položku Mateřská licence.

Po zrušení vět je vytištěn protokol o zrušených větách (pokud máte v Konfiguraci nastaven jeho tisk).


Likvidace - oznaceni vet

Likvidace – označení vět

Likvidaci věty lze provést pomocí pravého tlačítka myši spuštěním volby Likvidace.

Tím je věta označena jako zlikvidovaná, na kartě Opravy je vygenerován Stav=8 Likvidace a věta je označena zelenou barvou. Při likvidaci hardware nabízí program i likvidaci přiřazeného příslušenství a software. Vše co vyberete k likvidaci bude označeno stavem=8. S takto označenými větami nelze nic dále dělat – nelze instalovat software, nelze přiřadit příslušenství apod. Tyto věty se budou zobrazovat ve všech sestavách. Pokud je nechcete zobrazovat, musíte si v požadovaném souboru nastavit filtr na věty, které nemají položku STAV=8.

Licence programu SPRÁVCE je závislá na počtu evidovaných počítačů. Máte-li např. licenci pro 50PC, můžete v ní evidovat celkem 50PC a to včetně i zlikvidovaných. Takže pokud zrušíte několik počítačů, budou Vám ubírat počet evidovaných počítačů.

Proto se v menu se nachází volba Přesun likvidace do archivu, pomocí které můžete zlikvidované věty přesunout do archivu a uvolnit si licenci pro nové počítače.

Práce s archivem zlikvidovaných vět :

Pokud provedete přesun zlikvidovaných vět do archivu a chcete s těmito zlikvidovanými větami pracovat, musíte se přepnout do těchto souborů. To provedete v horním toolbaru programu zatrhnutím parametru ARCHIV LIKVIDACE.


Presun likvidaci

Přesun do archivu likvidace a zpět

Ovládací tlačítka Hromadné výběry

Tento formulář se používá ve dvou případech :

1) pro přesun zlikvidovaných vět z hlavních souborů do archivu likvidace. Archivní soubory se jmenují : LIK_*.DBF

2) pro vrácení zlikvidovaných vět z archivních souborů zpět do hlavních souborů

Spuštění formuláře je závislé na horním toolbaru programu na parametru ARCHIV LIKVIDACE (viz. obrázek) :

· Pokud je parametr ARCHIV LIKVIDACE vypnutý (zobrazený modrou barvou), pracujete v programu v normálním režimu v ostrých datech. V tomto případě tento formulář spustíte v okamžiku, kdy budete chtít zlikvidované věty přesunout do archivu a v hlavních (ostrých datech) je smazat

Pak je na tomto formuláři v mřížce zobrazen seznam zařízení (hardware, software, příslušenství hw, síťová technika, ostatní majetek, sítě), které byly zlikvidovány. Musíte zde vybrat věty a stisknout tlačítko Přesunout. Program smaže tyto věty z hlavních souborů (už Vám nebudou ubírat počet zakoupených licencí) a přesune tyto věty do archivních souborů.

· Pokud je parametr ARCHIV LIKVIDACE zapnutý (zobrazený červenou barvou), pracujete v archivu, kde se nacházejí pouze zlikvidované věty. Tento formulář spustíte pomocí pravého tlačítka myši na kartě Seznam a výběrem volby Přesun vět do běžných dat. Tímto způsobem lze zlikvidované věty vrátit zpět do hlavních (ostrých) souborů.


Likvidace - prace s archivem

Likvidace - práce s archivem

Ovládací tlačítka

Pokud chcete pracovat se zlikvidovanými větami, musíte se přepnout do archivních souborů. To provedete v horním toolbaru programu :

zatrhnutím parametru ARCHIV LIKVIDACE. Parametr se zobrazí červeně a informuje, že od této chvíle pracujete se zlikvidovanými větami. Práce s archivem přináší tato omezení :

a) je zakázána jakákoliv aktualizace všech hlavních souborů i číselníků

b) je zakázán generátor libovolných sestav

c) jsou zakázány volby Ostatní a údržba

d) je zakázáno Zpracování scanu SW a Zpracování scanu HW

Aktualizace všech souborů slouží pouze na prohlížení a tisk sestav zlikvidovaných vět.

Jestliže jste do archivu přesunuli věty omylem, lze pomocí pravého tlačítka myši na kartě Seznam stisknout volbu Přesun vět do běžných dat a věty tak vrátit zpět.

Přepnutí do archivu likvidace platí do ukončení programu nebo do vypnutí parametru ARCHIV LIKVIDACE v toolbaru.


RemoteScan - uvod

RemoteScan - úvod

POPIS

Program RemoteScan se skládá ze dvou částí :

1) první částí je modul pro vzdálené scanování, který je nedílnou součástí programu SPRÁVCE (pro další popis ho nazvěme ServerRS). Tento modul může spustit pouze uživatel, který k tomu má oprávnění (lze nastavit v menu Údržba – Správa uživatelů)..

2) druhou částí je klient ClientRS, který musí být nainstalován na všech počítačích, které chcete scanovat. Tento klient musí být na stanicích nainstalován a zaveden v paměti. Pokud je zaveden v paměti, nic nedělá, pouze čeká na příkazy z modulu ServerRS.

POZOR :

· komunikace mezi ServerRS a ClientRS je možná pouze na protokolu TCP/IP.

· komunikaci lze zapnout podle Názvu PC nebo podle IP adresy. Podle volby musí být v datovém souboru hardware správně vyplněn Název PC nebo IP adresa.

· ClientRS je určen pouze pro stanice se systémy Windows 95/98/98SE/ME/NT/2000/XP, stanice s MS-DOS nebo Windows 3.* musíte nascanovat ručně.

· pokud nemáte zaplacený RemoteScan, je v OSTRÝCH datech přístupná pouze neplacená volná verze, která neumožňuje provádět scanování a ostatní síťové funkce. V DEMO datech je pro vyzkoušení plná verze pro max. 10PC.

· komunikace mezi ServerRS a ClientRS probíhá implicitně na portech 8888, 8887, 8886. Tyto porty lze na začátku používání změnit.


RemoteScan - server

serverová část programu RemoteScan je součástí programu SPRÁVCE. Není ji nutno samostatně instalovat. Nainstaluje se současně s programem SPRÁVCE. Tato serverová část zobrazuje graficky stromovou strukturu sítě. Je naprogramovaná ve formátu OCX, proto musí být zaregistrována v registrech. Při spuštění programu SPRÁVCE se tato registrace provede automaticky. Pokud však nemáte dostatečná práva k zápisu do registrů, registrace se neprovede a serverovou část nelze spustit.

1) Spuštění serveru

2) Přístupy k funkcím

3) Popis serveru

4) Způsob naplnění stromu

5) Popis funkcí serveru


RemoteScan - komunikacni port

RemoteScan – Konfigurace

Tento formulář umožňuje nastavení vlastností pro RemoteScan. Spustí se automaticky při prvním spuštění formuláře RemoteScan, kdy není nastaven komunikační port, nebo lze formulář spustit pomocí tlačítka Konfigurace na formuláři RemoteScanu.

Komunikační porty :

Komunikační port slouží ke komunikaci mezi Serverem a Clientem. Implicitně je při prvním spuštění nastaven port 8888. Pokud Vám tato hodnota nevyhovuje, můžete si ji změnit.

POZOR :

· po úvodním nastavení komunikačního portu nelze port změnit jinak než novou instalaci klientů !!!

· nastavený komunikační port (např. 8888) slouží ke komunikaci od serveru ke klientovi. Pro komunikaci zpět je vždy použit port o jedno číslo menší (např. 8887).

· pro Update klienta se používá další port, který je nastavený o další jedno číslo níže (např. 8886).

· stejné komunikační porty musí být nastaveny i při instalaci ClientaRS, nastavující se v programu ScanCFG (viz. následující obrázek).

Adresáře scanů :

Pro plnou funkci RemoteScanu je nutné zadat dva adresáře :

  • Adresář s TXT, SWT soubory – Tento adresář udává kam se budou ukládat výsledné nascanované soubory a následně z něj zpracovávat. Adresář by měl být síťový, zadaný v UNC tvaru a přístupný všem uživatelům. Uživatelé musí mít do tohoto adresáře právo zapisovat a číst. Splnění těchto pravidel usnadní klientům ukládání výsledků scanů. Soubory se nebudou muset přenášet po síti pomocí protokolu TCP/IP. Pokud adresář nebude klientům přístupný, automaticky klient toto rozezná a výsledné soubory se přenesou po síti. Obvykle se jedná o adresář ..\Scany8\TXT.
  • Adresář s moduly scanů – adresář obsahující moduly scanů a instalaci ClientRS (…\Scany8). Tento adresář se využívá pro automatický update klienta a vzdálenou instalaci. Adresář by měl být síťový, zadaný v UNC tvaru, nebo jako namapovaná jednotka a přístupný všem uživatelům. Uživatelé musí mít do tohoto adresáře právo pro čtení. Pokud adresář nebude klientům přístupný nebude fungovat funkce automatického update.

Připojení k Active Directory :

RemoteScan umožňuje načítat počítače z Active Directory. Pro připojení k Active Directory se používá protokol LDAP. K připojení je potřeba zadat název serveru na kterém je databáze umístěna a název domény, ze které se budou údaje načítat (např. Server = PCServer122, Domena = micos-sw.cz). Pro přístup k LDAP je nutné mít příslušná síťová oprávnění.

Vzdálená instalace ClientRS :

Na systémy Windows 2000/XP a případně Windows NT (pokud je na nich instalováno rozhraní WMI) lze klienta instalovat vzdáleně. K tomu je však potřeba zadat administrátorské jméno a heslo. Tyto údaje se z důvodu bezpečnosti nikam neukládají (uchovávají se pouze v paměti po dobu spuštění programu), proto tyto údaje zadávejte až při vzdálené instalaci.

Před instalací je nutné zadat zda se má klient instalovat jako servis a nastavit parametry instalace. Parametry instalace se nastavují pomocí programu ScanCfg.exe.


RemoteScan - server (spusteni)

RemoteScan – spuštění serveru

server nebo-li formulář RemoteScan se spustí v toolbaru pomocí červené ikony úplně vlevo :

Při prvním spuštění programu je formulář nastaven tak, aby se automaticky spouštěl jako první při každém dalším startu programu. Pokud nechcete, aby se jako první vždy spouštěl formulář RemoteScan, musíte v levém dolním rohu zatrhnout parametr Příště nezobrazovat při startu.

Funkce RemoteScanu jsou závislé na tom, zda máte zakoupenou jeho licenci. Pokud ji nemáte zakoupenou, máte k dispozici pouze volnou verzi pro prohlížení. Tato verze neumožňuje scanovat vzdáleně počítače a ani další síťové funkce. Pokud licenci RemoteScanu máte zakoupenou, máte přístupné všechny funkce.


RemoteScan - server (pristupy)

RemoteScan – přístupy k serveru

serverová část programu RemoteScan umožňuje funkce, které musíte chránit pomocí přístupových práv. Toto nastavení provedete ve volbě Údržba – Správa uživatelů. Přístupová práva pro RemoteScan lze rozdělit na dvě kategorie :

a) Zpracování scanů HW a SW :

b) Funkce RemoteScanu :

Jedná se o možnost scanování HW (SW), VNC přístup (převzetí klávesnice, myši a obrazovky), Souborový přístup (přístup na lokální disky stanic) apod.


RemoteScan - server (popis)

RemoteScan – popis serveru

v levé části formuláře RemoteScan je zobrazena stromová struktura počítačů. Tato stromová struktura odpovídá skutečné evidenci počítačů v souboru hardware. Pokud začínáte s programem SPRÁVCE teprve pracovat, je tato stromová struktura při prvním spuštění prázdná, v opačném případě máte ve stromu seznam počítačů :

Stromová struktura počítačů obsahuje :

1) název stromu (root) - je dán názvem firmy, který lze nastavit v menu Údržba – Konfigurace

2) skupiny stromu - jsou jednotlivé hodnoty číselníku organizačního členění. Je proto vhodné věnovat tomuto číselníku pozornost a navrhnout ho nejen s ohledem na skutečnou organizační strukturu firmy, ale i na to, že se podle něj vytvářejí skupiny v programu RemoteScan a na tyto skupiny lze potom praktikovat skupinové funkce (scanování, zpracování apod.). Je vhodné, aby skupiny obsahovaly cca 10-20 počítačů, aby práce se stromem byla jednoduchá a přehledná.

3) položky stromu – jsou jednotlivé počítače, které jsou uvedeny v souboru hardware.

4) subpoložky stromu – jsou údaje z vazebních souborů software, příslušenství, oprav, … Aby se rozbalily, musíte na daném počítači provést doubleclik myší.

Sloupce stromu :

Ve stromu lze u hardware zobrazit kromě názvu PC navíc položky IP Adresa, odpovědná osoba, procesor a specifické číslo. Tyto informace jsou zobrazeny ve sloupcích stromu. Jejich zobrazení se provádí stiskem pravého tlačítka myši nad hlavičkami.

POZOR :

***********

· při komunikaci podle jména počítače, pokud provedete přeinstalování počítače a přidělíte mu jiný název, musíte to ručně v programu SPRÁVCE opravit, jinak Vám komunikace s tímto počítačem nebude fungovat! Nesmíte tento přeinstalovaný počítač zavést do evidence jako nový, vznikla by Vám tam duplicita.

· nedoporučuje se v názvech počítačů používat duplicitní název a ani, aby název jednoho počítače byl obsažen zleva v názvu druhého (např. Novak a Novak01). Takovéto počítače by občas komunikovaly a občas ne. Z hlediska praktického používání a snadné údržby je vhodné pro názvy počítačů zvolit např. jejich inventární číslo apod.

· komunikace mezi klientem a serverem funguje jak při zapnutém DHCP, tak i při pevných IP adresách (pokud je zapnuta komunikace podle názvu počítače)

· při klikání myší ve stromě se podle aktuální pozice aktualizuje pravá strana formuláře. Pokud např. přecházíte ze software na příslušenství, musí se nejprve zrušit pravá strana pro software a pak vytvořit pravá strana pro příslušenství. Tyto operace chvíli trvají a nelze přitom zakázat kliknutí někam jinam. Proto Vám doporučujeme neklikat ve stromě příliš rychle za sebou. Počkejte až se Vám překreslí pravá strana. Mohlo by se stát, že ve stromu stojíte kursorem např. na software a na pravé straně máte seznam příslušenství.

POPIS IKON STROMU

ikony zobrazující jednotlivé počítače ve stromu mohou nabývat následujících barev :

zelená - spojení se navázalo, počítač je zapnutý a má nainstalovaného klienta. Vše je OK.

červená - spojení se nenavázalo, počítač nemá nainstalovaného klienta.

žlutá - spojení se navázalo, ale došlo ke změně evidenčního čísla počítače (H00000xx). Klient má totiž u sebe poznamenané evidenční číslo, které měl počítač při posledním spojení. Pokud jste z nějakého důvodu v programu SPRÁVCE změnili evidenční číslo počítače, server zjistí tuto změnu a nepovolí práci s tímto počítačem, dokud tuto změnu neopravíte. Musíte proto na tyto počítače spustit volbu Oprava evidenčního čísla, která sladí evidenční čísla poznamenané u klientů s evidenčními čísly v databázi hardware.

modrá - spojení se navázalo, ale ClientRS je starý.

černá - spojení se nenavázalo, počítač je vypnut, nebo nedostupný po síti.

ŘEŠENÍ CHYBNÝCH STAVŮ

Červená – komunikace nebyla navázána, počítač je buď vypnutý nebo nemá nainstalovaného klienta. V tomto případě je nutné prověřit zapnutí počítače, případně instalaci klienta.

Žlutá – v programu SPRÁVCE došlo ke změně evidenčního čísla (ruční oprava evidenčního čísla ve volbě HW audit – Evidence hardware). Komunikace s tímto počítačem je funkční, ale nelze provádět scanování a ani další funkce. Musíte spustit volbu Administrace klienta - Oprava evidenčního čísla aktuálního počítače, která zašle klientovi nové evidenční číslo.

Modrá – komunikace byla navázána, program ale signalizuje, že na daném počítači je starý klient. Scanování a ostatní funkce mohou fungovat (záleží to velikosti změn nové verze klienta), ale také nemusí. Musíte provést UPDATE klienta. K tomu slouží volba Administrace klienta – Update klienta.

Černá – komunikace nebyla navázána, počítač je vypnut, nebo nedostupný po síti. Řešení je zapnout počítač, nebo připojit ho do sítě.

POPIS KARET STROMU

strom obsahuje následují karty :

Klienti - obsahuje seznam počítačů aktuálně vybrané skupiny

Síť - umožňuje přidat nový počítač procházením okolních počítačů v síti

Procesy - umožňuje zobrazit a případně shodit aktivní procesy vybraného počítače

Log - zobrazuje spuštěné akce. Připravena pro příští verzi.


RemoteScan - server (naplneni stromu)

RemoteScan – způsob naplnění stromu

následující body ukazují jak provést naplněním stromu serveru :

1) vytvoření skupiny počítačů

2) přidání nového počítače :

o      ručně jedno PC

o      hromadně ze sítě

o      hromadně zadáním IP adresy

o      hromadně načtením z Active Directory

3) změna skupiny ve stromu

4) přeřazení počítače do jiné skupiny

5) zapnutí/vypnutí komunikace


RemoteScan - server (popis funkci)

RemoteScan – popis funkcí serveru

Pomocí pravého tlačítka myši lze spustit menu (viz. následující obrázek). Jednotlivé volby menu jsou přístupné podle toho, zda :

· máte danou volbu právo spustit

· je zapnuta nebo vypnuta komunikace

· může volba fungovat na všech úrovních

Popis jednotlivých funkcí :

o      Zjistit stav – umožňuje zjistit stav klientů a zobrazit ikony klientů podle skutečného aktuálního stavu.

o      Scanování HW, SW – umožňuje spustit scanování HW nebo SW. Po spuštění se ikona změní, signalizuje, že se provádí scan. Po skončení scanu se ikona vrátí zpět do své původní barvy. Přenos výsledných nascanovaných souborů může probíhat dvěma způsoby :

1. Pokud jste v Konfiguraci RemoteScanu zadali adresář do kterého se mají ukládat výsledné nascanované soubory ve tvaru UNC a tento adresář je přístupný uživatelům pro čtení í zápis, jsou výsledné soubory vytvářeny přímo do tohoto adresáře.

2. Pokud uložení výsledných souborů neproběhne podle bodu 1., jsou soubory přenášeny po síti pomocí protokolu TCP/IP.

o      Stažení starých scanů – pokud ukončíte formulář RemoteScan nebo vypnete komunikaci dříve, než doběhnou spuštěné scany na počítačích, zůstanou nascanované soubory na lokálních discích scanovaných počítačů. Touto volbou máte možnost je při dalším spuštění stáhnout k serveru.

o      Zpracování scanů HW, SW

o      Přidání/oprava počítačů :

· Ruční přidání jednoho PC

· Ruční přidání více PC pomocí IP adresy

· Oprava všech údajů aktuálního počítače

· hromadně načtením z Active Directory

· Zápis IP adresy aktuálního PC – pokud se používá DHCP, nemusí být v databázi hardware uvedena aktuální IP adresa. Touto volbou lze aktuální IP adresu ze stromu zapsat do databáze hardware. Podmínkou je zapnutá komunikace.

o      Ukaž – tato funkce nejprve celý strom sbalí a pak rozbalí jen vybranou část (skupiny nebo počítače).

o      Vzdálená instalace :

· Spuštění instalace – volba slouží k vzdálené instalaci klienta na počítač, na kterém klient dosud není instalován. Této instalace lze využít pouze pokud je na cílovém počítači operační systém Windows 2000 nebo Windows XP (pokud je na systému Windows NT 4.0 doinstalováno rozhraní WMI lze použít instalaci i na tento operační systém). Další podmínkou pro úspěšnou instalaci je být přihlášen jako administrátor dané stanice.

Instalace by měla probíhat v těchto krocích :

1. Ve volbě Konfigurace RemoteScanu musíte nastavit parametry instalace a zadat administrátorský účet

2. Po spuštění instalace proběhne kontrola:

a. Zda je na dané stanici instalováno rozhraní WMI (RemoteScan se pokusí připojit k počítači pomocí zadaného administrátorského účtu).

b. Zda je na dané stanici přístupné systémové sdílení (na disk C$). Systémové sdílení existuje na systémech NT/2000/XP. Podmínkou pro přístup je být přihlášen jako administrátor dané stanice.

3. Pokud úspěšně proběhly kontroly z bodu 2., vytvoří se na cílové stanici adresář C:\Micos.ins\ClientRS. Do něj se nakopírují soubory potřebné pro instalaci klienta.

4. Z adresáře C:\Micos.ins\ClientRS se spustí instalace klienta pomocí souboru SeturRSC.exe.

5. Pokud vše proběhlo na stanici v pořádku měl by daný počítač po vyvolání volby Zjistit stav zezelenat.

· Smazání instalačních souborů – touto volbou se na vybraném počítači smaže adresář C:\Micos.ins vytvořený ve volbě Vzdálená instalace – Spuštění instalace.

o      Administrace klienta :

· Update z klienta – klient má zabudovánu funkci, která mu umožňuje automatickou aktualizaci jeho součástí (např. scanovací knihovny) a aktualizaci sama sebe. Tato aktualizace se vyvolává automaticky při zavedení klienta do paměti, nebo ji lze vyvolat pomocí této volby. Podmínkou aktualizace je, aby byl klientům přístupný (postačují práva pro čtení) adresář se scanovacími moduly (..\Scany8). Tento adresář jste před instalací klientů zadávali v programu ScanCFG, nebo jej lze později zaslat na klienty pomocí volby Změna cesty pro update z klienta.

Aktualizace probíhá takto:

1. V adresáři Scany8 musí existovat soubor Update.Ini. V tomto souboru jsou informace, podle kterých se řídí update a má tvar:

Nazev_souboru;datum - např. scanwinh.dll;04.08.2004

2. Tento soubor se porovnává proti údajům, které má klient u sebe. Pokud se např. liší datum u souboru scanwinh.dll, tento souboru se přenese ke klientovi.

3. Pokud je klient nainstalován jako service, neprovádí se update automaticky. Lze jej vyvolat pouze z menu.

· Změna cesty pro automatický update – pošle klientovi cestu k modulům scanu pro volbu Update z klienta. Tato cesta se nastavuje v Konfiguraci RemoteScanu.

· Update ze serveru – umožňuje zaslat klientovi novou verzi klienta. Tato verze půjde stáhnout z Internetu. Bude uložena v souboru UPDATE.ZIP, který musí být umístěn v podadresáři \OCX programu SPRÁVCE (např.C:\MICOS\SPRAVCE8\OCX). Po zaslání je soubor u klienta rozbalen, klient je shozen z paměti a následně restartován. Update klienta je možné provést na jednotlivý počítač, nebo na skupinu počítačů. Po výběru této volby se objeví formulář se seznamem IP adres počítačů na které je zasílán update soubor. Po úspěšném update klienta se daná IP adresa odškrtne. Tlačítkem zavřít okno se přeruší update klientů.

· Restart klienta – restartuje klienta v paměti. Má význam v případě, že klient komunikuje, ale má problémy provést např. scany nebo některé jiné funkce.

· Shození klienta – umožňuje shodit klienta z paměti. Při následujícím restartu počítače je klient zaveden do paměti znovu.

· Odinstalace klienta – umožňuje klienta kompletně odinstalovat na dálku. Klient se shodí z paměti, smaže z disku a z registrů.

· Změna parametrů scanu SW – umožňuje klientům zaslat nové parametry pro scanování SW (např. scanování nových přípon apod.).

· Zaslání souborů k aut. mazání SW – umožňuje zaslat klientů DEL soubory k automatickému mazání SW. Pokud vám funguje automatický update klienta, nemusíte tuto volbu používat. Klient si sám kontroluje přítomnost DEL souborů, a pokud existuje soubor pro něj, automaticky si jej stáhne.

· Oprava evidenčního čísla aktuálního počítače

o      Administrace -

· VNC přístup

· Změna VNC hesla

· Souborový manažer

· Scanování HW, SW s log souborem


RemoteScan - hledani

RemoteScan - hledání

Tento formulář umožňuje hledání pouze podle položek Název PC, Evidenční číslo a IP adresa. Zadání hledaného řetězce musíte potvrdit tlačítkem OK. Program se pokusí najít hledaný řetězec. Při tomto způsobu lze vyhledávat pouze podle řetězce zleva (nelze vyhledat libovolný podřetězec). Pokud se zadaný řetězec nalezne, program nastaví kursor na danou větu. Nenajde-li se tento řetězec, program na to upozorní a zůstane na původní větě.

Po vyhledání daného řetězce se okno formuláře Hledej zavře.

POZOR -

· IP adresa - lze ji hledat i když není ve stromě načtena.


RemoteScan - zmena parametru scanu SW

RemoteScan – změna parametrů scanu SW

Tento formulář umožňuje změnit na klientech parametry pro scanování SW.

Mazat soubory označené ke zrušení

tento parametr znamená, že před vlastním scanováním počítače zkontroluje scanovací modul nejprve přítomnost souboru, který má příponu "DEL". Pokud tento soubor existuje, načte z něho názvy souborů, které má smazat a tyto soubory se pokusí smazat. Pokud se mu to nepovede, vytvoří soubor s příponou "!!!", ve kterém je uveden seznam souborů, jenž se mu nepodařilo smazat. Potom teprve spustí scanování.

Scanovat archivy

umožňuje scanovat všechny archivy (ARJ, ZIP, PAK, …) pouze podle přípony a ne podle obsahu.

Scanovat další přípony

standardně se scanují pouze soubory s příponami EXE a COM. Tímto parametrem lze scanovat i další typy přípon (MP3,WAV,FXP). Pokud jako přípona bude uveden znak * budou se scanovat všechny soubory.


RemoteScan - pridani PC pomoci IP adres

RemoteScan – přidání PC pomocí IP adres

Tento formulář umožňuje přidat do stromu RemoteScanu a do databáze hardware nové počítače. Tento způsob je vhodný v případě, že na kartě Síť nevidíte všechny počítače a přitom znáte jejich IP adresy (musí být pevně přidělené).

Na formuláři jsou dvě volby :

  1. Spustit – touto volbou spustíte externí program Host_Detector, pomocí kterého se hledají počítače v zadaném rozsahu IP adres.

V programu musíte zadat startovní IP adresu (od které se začne hledat) a počet dalších adres, které se mají hledat. Po stisku tlačítka detekovat se program pokusí s danými počítači spojit a zjistit jejich názvy. Výsledek hledání je uložen do souboru a musí se zpracovat 2. volbou.

Programem můžeme detekovat i více segmentů za sebou. Výsledky se ukládají do zvláštních souborů a v 2. volbě se zpracují všechny najednou.

2. Zpracovat – touto volbou se zpracují nalezené počítače z 1. bodu.

Pokud se programu podaří zjistit názvy počítačů, zobrazí formulář se seznamem všech připojených počítačů ze zadaného rozsahu IP adres, které nejsou ještě v evidenci (viz následující obrázek).

V prvním sloupci tohoto formuláře musíte označit počítače, které chcete zavést do nastavené skupiny. Pozor – jelikož můžete počítače vybrat náhodně z celého seznamu, nebudou mít evidenční čísla souvislou řadu. Je výhodné v prvním sloupci navržená evidenční čísla opravit.

Po odsouhlasení evidenčních čísel a stisku tlačítka OK, jsou všechny označené počítače vygenerovány do souboru hardware a zařazeny do nastavené skupiny.

Je-li zapnuta komunikace, pokusí se server po začlenění počítačů navázat spojení s klienty a zobrazí ikony odpovídající jejich stavu.


RemoteScan - client

RemoteScan - klient

POPIS

modul ClientRS (dále označován jen jako klient) je část programu RemoteScan, která musí být nainstalována na všech počítačích, jenž budou scanovány. Popis instalace tohoto klienta naleznete v uživatelské příručce.

Po nainstalování se klient po restartu automaticky zavede do paměti. Zároveň je zapsán do registrů tak, aby byl zaveden při dalších restartech počítače.

Klient zavedený v paměti nic nedělá, pouze čeká na spojení se serverem. Pokud k tomuto spojení dojde, dostává klient na příkazy ze serveru, které provede.


HW Audit

HW audit je vlastně inventura počítačů. Následující text je vlastně návod, jak při něm postupovat :

1. Nastavení scanů hardware – postup naleznete v tištěné příručce SCANY HW a SW

2. Spuštění scanů hardware – postup naleznete v tištěné příručce SCANY HW a SW

a. pomocí RemoteScanu – vzdálené scanování stanic po síti

b. pomocí login scriptu – scanování stanic v síti v okamžiku přihlášení uživatele

c. ruční scan počítačů mimo síť

3. Spuštění volby Údržba – Konfigurace – kontrola správné cesty k nascanovaným TXT souborům ze scanovacích modulů.

4. Postupné spuštění voleb v menu HW audit (viz. následující obrázek) :

a. Zpracování HW-scanu – umožňuje zavést hromadně počítače do evidence tím, že se zpracují nascanované TXT soubory. Toto zpracování poskytne základní technické údaje. Po zpracování musíte doplnit údaje, které se nedají nascanovat.

b. Hlavní evidence hardware – umožňuje ručně zavádět počítače, které nebudete scanovat. Dále umožňuje postupně doplňovat všechny údaje, které se nedají nascanovat, a to vždy ke konkrétnímu počítači. Tato volba není určena pro hromadné naplnění dat, ale pro komplexní doplnění dat jednoho počítače. Hlavní evidence umožňuje kromě doplnění základních položek hardware (odpov. osoba, umístění, ekonomické údaje apod.) evidovat také další informace :

· Servisy – evidence pravidelných servisů, profylaxí a revizí

· Opravy – historie změn a oprav hardware

· Licence SW - ruční přiřazení licencí

· Příslušenství – doplnění příslušenství, která nelze nascanovat

· Dokumentace – přiřazení dokumentace

· Poznámky – neomezená poznámka pro vlastní potřebu

· Elektronické dokumenty – seznam důležitých dokumentů v elektronické podobě

c. Doplnění IČ, VČ, SČ – umožňuje hromadně doplnit inventární, výrobní a specifická čísla a další údaje pro více počítačů najednou. Dále lze také hromadně doplnit u příslušenství, zda jsou Interní, Servisní a zda byly zakoupeny jako Součást počítače při nákupu (velmi důležité z hlediska ekonomických údajů – podrobnosti naleznete na Doplnění IČ, VČ, SČ).

d. Doplnění údajů z dalších databází hardware – následující volby Operační systémy hardware, Značky hardware a Typy použití hardware umožňují hromadné zadání údajů pro více počítačů najednou.

5. Naplnění ze společných číselníků – jednotlivé číselníky opět umožňují hromadné zadání údajů na více počítačů najednou.

6. Import údajů – ve volbě Údržba – Import lze importovat některé číselníky, ekonomické údaje a technické údaje z externích evidencí. Import lze provést pouze z formátů XLS, TXT a DBF.

7. Inventura – ve volbě Ostatní – Inventární sestavy můžete provést a vytisknout inventuru hardware.


Zpracovani Hw-scanu

Zpracování scanu HW

Scanovací moduly scanu HW provedly scanování požadovaných počítačů a výsledky uložily do souborů. Tyto soubory musí být uloženy v adresáři, který je nastaven ve volbě Konfigurace.

Před spuštěním zpracování TXT souborů se nejprve provede Kontrola údajů jednotlivých souborů proti evidenci hardware. Po této kontrole se spustí vlastní formulář pro zpracování výsledků scanu HW.

Tento formulář zpracování má následující karty :

Hardware

Přiřazené PŘ

Změny v PŘ

Nevedené PŘ

Další údaje

Síťová technika

Konfigurace


Zpracovani Hw-scanu - hardware

Zpracování scanu HW - hardware

Tato karta obsahuje mřížku, ve které je seznam všech evidovaných počítačů. Řádky označené červeným písmem jsou počítače, které je nutné zpracovat. Jsou to buď počítače, jejichž TXT soubory ještě nikdy nebyly zpracovány nebo jsou to počítače, jejichž TXT soubory mají datum novější než datum posledního zpracování. Modré řádky znamenají změnu na kartě Přiřazené PŘ proti předchozímu zpracování.

Řádky označené zeleným písmem jsou počítače, které jsou zlikvidované a které nelze zpracovávat.

K označení souboru ke zpracování slouží první (zelený) sloupec. Pomocí něho můžete označit a odznačit počítače ke zpracování.

Sloupec Odpovědná osoba je označen žlutou barvu, lze v něm přímo vybírat odpovědnou osobu jak před vlastním zpracování, tak i po něm. Důležitým předpokladem je, aby byl číselník odpovědných osob předem naplněný.

Podmínky zpracování

v pokud je na kartě Konfigurace zatržen některý z parametrů Nová PC – negenerovat PŘ, nebudou pro tyto typy příslušenství generovány věty, ale údaje budou pouze zobrazeny na kartě Nevedené PŘ.

v Procesor a PCI karty mají vlastní konfigurační soubory. Při zpracování těchto příslušenství se název příslušenství bere z těchto souborů. Projděte si dobře popis konfiguračních souborů pro Procesory a PCI karty.

v Hard disky mají vlastní konfigurační soubor. Při zpracování tohoto příslušenství se kapacita disku bere z těchto souborů. Projděte si dobře popis konfiguračního souboru pro Hard disky.

v pokud je v systému Windows NT a výše detekován více než jeden procesor, je automaticky vytvořeno tolik příslušenství, kolik procesorů bylo detekováno.

v pokud se zpracovává nový počítač, jsou jednotlivá příslušenství generována automaticky, není třeba každá kontrola. Program předpokládá, že při zavádění nového počítače do evidence není v evidenci zavedeno ani žádné jeho příslušenství.

v pokud se zpracovává již jednou zpracovaný počítač, program postupně prochází jednotlivá příslušenství ze scanovaného souboru a provádí porovnání s evidencí :

· pokud zpracovávaný počítač nemá toto příslušenství přiřazeno (jedná se o nově přidané příslušenství), je to považováno za změnu a proto se toto příslušenství přesune na kartu Změny v PŘ.

· pokud stejný typ příslušenství je na počítači již přiřazen, provede se kontrola nascanovaných hodnot (název, výrobce apod.) :

ð jestliže došlo ke změně doplňujících parametrů (např. IRQ, MMX apod.), program staré hodnoty přepíše novými hodnotami a pokračuje dalším příslušenstvím.

ð jestliže došlo ke změně základních parametrů (např. název a výrobní číslo), program ponechá na kartě Přiřazené PŘ původní příslušenství a zobrazí je fialově. Nové hodnoty zároveň zapíše na kartu Změny v PŘ. Na této kartě pak musíte rozhodnout, co s příslušenstvím udělat.

Postup zpracování souborů

zpracování označených počítačů je provedeno zcela automaticky bez zásahu obsluhy. Po zpracování jsou všechny údaje z nascanovaných souborů rozděleny na jednotlivé karty :

1. karty Přiřazené PŘ, Změny PŘ a Nevedené PŘ – obsahují údaje o příslušenství hardware (disky, paměť, procesor apod.)

a. na kartu Přiřazené PŘ se generují pouze jednoznačně identifikovatelné příslušenství (K001 – K010)

b. na kartu Změny v PŘ jsou generovány následující typy příslušenství :

· Hard-Disk – jen pokud nemá vyplněnou kapacitu.

· Monitor – údaj se vyčítá z registrů a není stoprocentně jistý.

· Zvuková karta – v případě, že obsahuje duplicitní věty.

· Video karta – v případě, že obsahuje duplicitní věty.

· Modem – v případě, že obsahuje duplicitní věty.

· Paměť – v případě, že na scanovaném počítači není implementováno rozhraní WMI a nelze zjistit počty kusů paměti.

· Tiskárna – pouze všechny lokální tiskárny – je nutné určit správnou.

· Řadič – v případě, že obsahuje duplicitní věty

c. na kartu Nevedené PŘ jsou generovány následující typy příslušenství :

· CD-ROM – virtuální emulace CD-ROMu.

· Síťová karta – typu RAS a PPP.

· Tiskárny – síťové, faxy, Fineprint, Acrobat distiller, Symantec fax

· Řadič – virtuální řadič Virtual CloneDrive, Nero Image.

2. karta Další údaje – obsahuje údaje o logických discích, konektorech a slotech počítačů

3. karta Síťová technika – obsahuje seznam všech síťových komponent, ať už ručně přidaných (routry, huby apod.) nebo nascanovaných (síťové tiskárny)


Zpracovani Hw-scanu - prirazene prisl.

Zpracování scanu HW – Přiřazené PŘ

Tato karta obsahuje seznam příslušenství, které je přiřazeno k aktuálnímu hardware (buď ručně nebo zpracováním scanu). V tomto seznamu jsou barevně rozlišeny následující stavy :

1) červené písmo – příslušenství je v opravě (nemá ukončenou opravu)

2) zelené písmo – příslušenství je zlikvidované

3) fialové písmo – příslušenství nebylo zjištěno scanem. Buď jste ho přiřadili ručně nebo u něj došlo ke změně základních parametrů (k jeho výměně).

4) modrý podklad – příslušenství je označeno jako Součást PC při nákupu

Menu na pravé tlačítko myši :

Detail příslušenství

program spustí formulář pro zobrazení detailních informací s možností jejich opravy. Pomocí této volby lze u nascanovaného příslušenství změnit název. Tato oprava je důležitá např. u klávesnic, myší a FD, u kterých nelze nascanovat jejich název. Jestliže ho takto opravíte, pak při dalším zpracování Vám program toto příslušenství neidentifikuje jako nové. Má totiž v pomocné položce uložen původní název a pokud se tento nezmění, je příslušenství považováno za totožné.

Nové příslušenství

touto volbou máte možnost vytvořit nové příslušenství a ručně ho přiřadit na aktuální počítač.

Volné příslušenství

program spustí formulář Volná zařízení, pomocí kterého můžete k aktuálnímu počítači přiřadit jakékoliv volné příslušenství nebo vytvořit nové.

Odřadit příslušenství

program provede odřazení vybraných příslušenství z aktuálního počítače.

Přeřadit příslušenství

program spustí formulář pro přeřazení příslušenství na jiný počítač.

Součást PC

Touto volbou změníte u všech vybraných příslušenství příznak, zda byly zakoupeny jako součást počítače při nákupu. Pokud nastavíte tento parametr na Ano, budou tato příslušenství označena modrou barvou.


Zpracovani Hw-scanu - zmeny v prisl.

Zpracování scanu HW – Změny v PŘ

Tato karta obsahuje po zpracování 3 druhy údajů :

1) příslušenství, u kterého došlo proti minulému zpracování ke změně základních parametrů (Název, Výrobní číslo), např. jste vyměnili video kartu. Program při zpracování zjistí, že došlo ke změně a provede :

a. na kartě Přiřazené PŘ Vám změněné příslušenství zobrazí fialovou barvou

b. na kartě Změny v PŘ Vám zobrazí údaje :

· nového příslušenství (horní mřížka)

· původního příslušenství (dolní mřížka)

2) zcela nové příslušenství, tj. příslušenství, které při předchozím zpracování v nascanovaném souboru (např. jste přikoupili další disk, cd apod.)

3) příslušenství, které nelze při zpracování automaticky vygenerovat. Jedná se např. o :

a. duplicitní monitory nebo monitory bez přesného určení názvu

b. duplicitní lokální tiskárny, u nichž musíte rozhodnout, která je ta správná

c. paměť načtená bez rozlišení počtu kusů

Obrázek ukazuje například stav, kdy byl vyměněn procesor a přidán monitor. Nad horní i dolní mřížkou funguje pravé tlačítko myši, které vyvolá příslušné funkce.

Po zpracování TXT souboru by jste si tuto kartu měli dobře prohlédnout. Měla by totiž v konečné fázi zůstat prázdná. To znamená, že příslušenství, které patří k počítači k němu skutečně přiřadíte a ostatní, které tam nepatří převedete na kartu Nevedené PŘ.

Menu na pravé tlačítko myši obsahuje v obou mřížkách tyto funkce :

Přiřadit jako nové příslušenství

touto volbou máte možnost označené příslušenství přeřadit na kartu Přiřazené PŘ (přiřadit ho k počítači). Pokud přeřazujete příslušenství typu Hard-Disk, které nemá vyplněnu Oblast 1 budete vyzváni k zadání kapacity disku.

Pozor – vybrané příslušenství bude vygenerováno jako zcela nové. To znamená, že si pro přidávané příslušenství nejprve dobře prohlédněte spodní mřížku Ručně přiřazené PŘ. Pokud v ní najdete nějaké příslušenství, musíte se rozhodnout, zda chcete původní příslušenství přepsat nebo vygenerovat nové :

a) pokud chcete vygenerovat zcela nové, stačí v horní mřížce spustit volbu Přiřadit jako nové příslušenství a program vygeneruje nové příslušenství a naplní ho nascanovanými údaji.

b) jestliže však ve spodní mřížce najdete správné příslušenství, kterému byly pouze změněny nějaké údaje, můžete ve spodní mřížce aktivovat volbu Aktualizace změn, která umožní buď přepsat nebo ponechat původní údaje.

c) také může nastat situace, že jste při předchozím zpracování vybrané příslušenství na počítači vůbec neměli. Nyní se při zpracování našlo a vložilo se na kartu Změny PŘ. Vy ale nechcete, aby toto příslušenství bylo vygenerováno jako zcela nové. Máte ho již v evidenci nachystané, ale nebylo přiřazené k tomuto počítači. V tomto případě musíte takovéto příslušenství vložit na kartě Přiřazené PŘ a to volbou Volné příslušenství.

Přiřadit jako nové PŘ + Změna názvu

funkčně stejná volba jako předchozí, ale s možností opravit nascanovaný název příslušenství (např. je nepřesný – údaj se vyčetl ze registrů – např. název tiskárny).

Nevedené PŘ

touto volbou máte možnost označené příslušenství přeřadit na kartu Nevedené PŘ. Jedná se o příslušenství, které nechcete evidovat.

Rozdělit paměť RAM

pokud na zpracovaném PC není aktivní rozhraní WMI, nelze zjistit počet kusů paměti. Proto je paměť vygenerována na kartu Změny v PŘ jako jeden kus s celou kapacitou.

Touto volbou máte možnost tento jeden kus ručně rozdělit na skutečný počet obsazených banků. Program Vám nabídne formulář Rozdělení paměti RAM, kde máte možnost rozdělit paměť na požadované kusy. Po rozdělení paměti jsou automaticky jednotlivé kusy přiřazeny na kartu Přiřazené PŘ.


Zpracovani Hw-scanu - rozdeleni pameti RAM

Zpracování scanu HW – rozdělení paměti RAM

Jestliže se při zpracování TXT souboru nepodařilo identifikovat rozložení pamětí do jednotlivých banků (lze to zjistit pouze na systémech, které mají zapnutou podporu WMI – např. automaticky Windows 2000/XP nebo nižší v případě, že podpora byla speciálně nainstalovaná), zobrazí se pouze celková paměť na kartě Změny PŘ.

V tomto případě lze celkovou nascanovanou velikost paměti rozdělit na požadovaný počet kusů. Tento formulář zobrazuje celkovou velikost paměti a tuto povoluje rozdělit až na čtyři kusy.

Rozdělení paměti provedete označením požadovaných kusů a zapsáním velikosti jednotlivých pamětí. Program nekontroluje, zda rozdělení na jednotlivé kusy dává dohromady celkovou velikost. Tato totiž nemusí být přesná (BIOS může část paměti použít např. pro video kartu apod.).


Zpracovani Hw-scanu - zmena nazvu prisl.

Zpracování scanu HW – změna názvu příslušenství (kapacity příslušenství)

Jestliže se při zpracování TXT souboru nepodařilo přesně identifikovat název příslušenství, lze ho tady opravit. Jedná se např. o údaje vyčítané z registrů (např. monitor, tiskárna apod.). Tento formulář se také využívá pro zadávání kapacity u příslušenství typu Hard-Disk (pokud se daný údaj nepodaří nascanovat).


Zpracovani Hw-scanu - prepis polozek prislusenstvi

Zpracování scanu HW – přepis položek příslušenství

Jestliže při zpracování TXT souborů došlo u některých příslušenství ke změně některé ze základních položek (Název, Oblast1, Výr. číslo), jsou na kartě Přiřazené PŘ zobrazeny tato příslušenství fialovou barvou (zobrazují se jejich původní hodnoty uložené v databázi). Na kartě Změny PŘ vidíte jejich nové hodnoty (z nascanovaného souboru – viz. následující obrázek).

Pokud jste se pomocí pravého tlačítka myši ve spodní mřížce rozhodli změněné údaje opravit (volba Aktualizace změn), nabídne Vám program tento formulář :

Zde Vám ve dvou sloupcích zobrazuje původní hodnoty (uložené v evidenci příslušenství) a nové hodnoty (z nascanovaného souboru). U každé položky jsou vpravo tlačítka pro Výběr, pomocí kterého lze zapsat buď původní nebo novou hodnotu :

1. Většinou by jste měli zapsat nově nascanované hodnoty. Program proto automaticky po spuštění nabízí označená tlačítka Výběr pro nové hodnoty. V tomto případě nemusíte tlačítka měnit, stačí stisknout OK.

2. Může však nastat situace, že potřebujete původní hodnotu ponechat. Pokud tedy chcete u některé položky původní hodnotu ponechat, musíte u požadované položky nastavit tlačítko Výběr ve sloupci Původní hodnoty.

Stiskem tlačítka OK potvrdíte zápis původních hodnot.


Zpracovani Hw-scanu - rozdeleni pameti RAM

Zpracování scanu HW – hromadné zpracování změn v PŘ

Formulář slouží k hromadnému zpracování změn příslušenství při scanu HW. Na formuláři je seznam všech změn v příslušenství ze všech počítačů. Pomocí menu na pravém tlačítku myši můžete tyto změny hromadně přesunout na kartu Přiřazené PŘ, nebo na kartu Nevedené PŘ. Volby v menu mají stejný význam jako na kartě Změny v PŘ.


Zpracovani Hw-scanu - nevedene prisl.

Zpracování scanu HW – Nevedené PŘ

Tato karta obsahuje údaje načtené z nascanovaného souboru, které nechcete zapsat do souboru Příslušenství. Tyto údaje se zde dostanou dvěma způsoby :

1) při zpracování TXT souboru jsou některé typy příslušenství přímo odmítnuty ze zpracování. Předpokládá se, že nemá význam je zavádět do souboru příslušenství. Jedná se např. o :

a) lokální tiskárny sdílené po síti jinými počítači, než ke kterým jsou připojeny

b) tiskárny typu Fax, FinePrint

2) převodem z karty Změny v PŘ.

Menu na pravé tlačítko myši :

Přiřadit jako nové příslušenství

touto volbou máte možnost označenou větu s technickými údaji vygenerovat jako nové příslušenství a přeřadit na kartu Přiřazené PŘ (přiřadit ji k počítači). Tato operace by měla být výjimečná, a to pouze v případech, že jste se zmýlili a příslušenství jste přeřadili omylem z karty Změny v PŘ (viz. bod 2)). Pokud bylo příslušenství odmítnuto již při zpracování (viz. bod1)), pak k tomu byly důvody a pravděpodobně se nejedná o fyzické příslušenství, které lze přiřadit k počítači (např. ovladač faxu).

Přiřadit jako nové PŘ + Změna názvu

funkčně stejná volba jako předchozí, ale s možností opravit nascanovaný název příslušenství (např. je nepřesný – údaj se vyčetl ze registrů – např. název tiskárny).


Zpracovani Hw-scanu - dalsi udaje

Zpracování scanu HW – další údaje

Tato karta obsahuje údaje načtené z nascanovaného souboru, které se nezapisují do souboru Příslušenství, ale do samostatných souborů. Tyto údaje jsou načteny scanovacími moduly pouze v případě, že na daném počítači je aktivní rozhraní WMI, které tyto údaje umí poskytnout.

Jedná se o informace týkající se :

a) slotů

b) konektorů

c) logických disků

Tyto údaje jsou pouze zobrazeny pro informaci o dalších důležitých technických parametrech.


Zpracovani Hw-scanu - sitova technika

Zpracování scanu HW – síťová technika

Tato karta obsahuje seznam síťové techniky. Jedná se jednak o síťové tiskárny, které se zjistily při zpracování TXT souborů, ale také ostatní síťové prvky, které jste v evidenci pořídili ručně (huby, routry, …). Na kartě je možno zvolit zda se budou zobrazovat pouze síťové tiskárny, nebo všechna síťová technika.


Zpracovani Hw-scanu - konfigurace

Zpracování scanu HW– konfigurace

Tato karta slouží k nastavení parametrů pro zpracování.

Adresář s TXT soubory

tento adresář určuje umístění TXT souborů ze scanovacích modulů. Tento adresář lze nastavit pouze ve volbě Údržba - Konfigurace. Při zpracování souborů je tento adresář na kartě Konfigurace zakázán, protože je formulář již spuštěn a nelze změnit umístění TXT souborů.

Nová PC – negenerovat PŘ

označené parametry určují, že se při zpracování nových počítačů nebudou tyto typy příslušenství automaticky generovat jako nové příslušenství na kartu Přiřazené PŘ, ale pouze se uvedou na kartu Nevedené PŘ. Zde je možné kdykoliv z nich vygenerovat příslušenství na kartu Přiřazené PŘ. Pozor – tyto parametry fungují pouze pro nové počítač. Pokud jste již jednou příslušenství dali na kartu Přiřazené PŘ, zapnutím tohoto parametru se nic nestane, příslušenství zůstane nadále na kartě Přiřazené PŘ.

V dolní části karty naleznete informativní údaje o tom, jak se nastavuje parametr Interní/Externí příslušenství a co je třeba provést po zpracování nascanovaných údajů.


Hardware

Evidence hardware

Evidence hardware obsahuje informace o počítačích. Jedná se o základní technické parametry (velikost paměti, název počítače, MAC adresu apod.). Protože rozvoj výpočetní techniky je velmi rychlý, jsou všechny komponenty, ze kterých se celý počítač skládá, řešeny jako samostatné příslušenství, které lze kdykoliv přeřadit na jiný počítač. To umožňuje technikům maximální volnost při opravách (upgrade) počítačů.

Dále se v souboru hardware evidují ekonomické údaje (faktura, dodavatel, …), organizační údaje (odpovědná osoba, umístění, organizační členění, …), servisy, opravy a další.


Hardware - Seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

slouží k vytvoření kopie daného počítače. Po stisku se spustí formulář Duplikace příslušenství, software a dokumentace, na kterém rozhodnete, co všechno chcete duplikovat. Duplikace vytvoří stejný počítač, přičemž vynuluje výrobní, inventární a specifická čísla počítače. Vygeneruje se (nebo ručně zadá) nové evidenční číslo. Stav počítače je nastaven na OK. Přiřazená příslušenství přebírají odpovědnou osobu, umístění, organizační členění a síť z duplikovaného počítače. Duplikované příslušenství, které není součástí PC při nákupu, přebírá ekonom. údaje z PŘ z něhož je duplikované. Příslušenství, které je součástí PC při nákupu, přebírá ekonom. údaje a inventární číslo z nového počítače.

Program ProOpen

toto tlačítko slouží ke spuštění grafického programu ProOpen.

Zobrazit interní příslušenství

tento parametr ovlivňuje zobrazení přiřazeného příslušenství. Pokud je tento parametr vypnutý, pak se v mřížkách s příslušenstvím zobrazuje pouze příslušenství externí. Pokud je zapnutý, zobrazuje se příslušenství interní i externí. Nastavení, zda je příslušenství interní nebo externí provedete přímo u každého příslušenství.

C) Tisky :

Parametry tisku

SESTAVY

Seznam hardware

jednoduchý seznam počítačů.

Seznam hardware dle konfigurace

seznam počítačů s udáním velikosti paměti, operačního systému a pevných disků.

Pasportní list

zobrazení všech položek (údajů) o počítači. Lze si vybrat, zda se mají zobrazit všechny údaje (hardware, příslušenství, software) nebo jen hardware, příslušenství nebo software. Rovněž lze určit, zda se bude tisknout i nelegální software a downgrade názvy nainstalovaného SW.

Záruka a odpisy

sestava hardware s přiřazeným příslušenstvím, ve které jsou zobrazena data záruky a odpisu. Pokud je zařízení po záruce, obsahuje v sestavě značku „P“, pokud je odepsáno, obsahuje značku „O“.

Seznam oprav

sestava oprav (historie) počítače. Lze vybrat, zda se mají tisknout všechny opravy nebo pouze některé. Také lze vybrat období. Tím lze sledovat např. technické zhodnocení zařízení během roku.

Deník oprav

sestava všech oprav počítače s podrobným popisem za zvolené období.

Rozpracované opravy

sestava všech počítačů, které mají rozpracovanou opravu (jsou v opravě).

Příslušenství

seznam příslušenství přiřazeného k jednotlivým počítačům. Je zde uvedeno, zda příslušenství je součástí počítače.

Příslušenství (oblasti)

seznam příslušenství přiřazeného k jednotlivým počítačům. Je zde uvedeno, zda příslušenství je součástí počítače, typ, název příslušenství, oblast1 a oblast2.

Dokumentace

seznam přiřazené dokumentace.

Předávací protokol

předávací protokol se skládá z několika částí :

· technické údaje počítače - tisknou se vždy

· ekonomické údaje počítače - tisk je volitelný

· seznam příslušenství - tisk je volitelný

· seznam nainstalovaného software - tisk je volitelný

· volitelný text na konci protokolu - text se nastavuje ve volbě Údržba - konfigurace a pokud je nastaven, tak se tiskne vždy.

Pomocí následujících výběrů můžete vzhled předávacího protokolu přizpůsobit Vašim požadavkům :

- lze nastavit obsah předávacího protokolu

- nastavení tisku ekonomických údajů

- nastavení tisku nelegálního sw

- nastavení tisku downgrade

- nastavení tisku přílohy předávacího protokolu

Rovněž je možno nastavit jazyk v jakém bude předávací protokol vytištěn (česky, anglicky, slovensky).

Volitelný text na konci předávacího protokolu lze nastavit v konfiguraci programu ve volbě Údržba - konfigurace. Tato část může být v každé organizaci jiná. Pokud tuto text nenastavíte, program automaticky na konci první části vytiskne následující text :

Pokud volitelnou část nastavíte, bude na konci sestavy vytištěna přesně podle zadaného textu. Může vypadat např. takto :

Tuto volitelnou část můžete vytisknou buď na konci první části nebo na samostatné straně. Při prohlížení sestavy na obrazovku se tato část zobrazí pouze v případě, že nebude tištěna na samostatné straně. Na obrazovku se druhá část nezobrazuje, tiskárnu se druhá část tiskne vždy.

Součet kapacit

zobrazuje počet procesorů, pamětí a pevných disků. Dále pro paměť a pevné disky zobrazí jejich celkovou kapacitu. Tyto údaje se načtou z přiřazeného příslušenství typu Procesor, Paměť a Hard disk. Celková kapacita pamětí a disků se spočítá z položky Oblast1, kde uvedená hodnota musí být ve tvaru : 1200 MB nebo 1,2 GB.

Cenový odhad SW

tato sestava zobrazuje cenový odhad nalezeného software. Pro každý počítač se vytisknou názvy nalezeného software a součty cen software legálního, nelegálního a software bez licence. Cena licencí se bere z ceny licence uvedené v souboru software, cena software nelegálního a bez licence se bere z číselníku názvů software, kde je uvedena průměrná cena software.

Prošlé servisy

tato sestava zobrazuje seznam hardware, kterému k určenému datu již vypršel servis či revize.

Provedené servisy

tato sestava zobrazuje seznam hardware, u kterých již byl proveden servis či revize.

Nastavené servisy

tato sestava zobrazuje seznam hardware, u kterých je nastaven servis či revize.

Specifikační list

úvodní pevná část specifikačního listu je stejná jako u předávacího protokolu - důležité parametry počítače, organizační a ekonomické údaje. Potom následuje seznam přiřazeného příslušenství a nainstalovaného software. Druhou volitelnou část specifikačního listu lze nastavit v konfiguraci programu ve volbě Údržba - konfigurace. Tato část může být v každé organizaci jiná. Pokud tuto část nenastavíte, program automaticky na konci první části vytiskne následující text :

Specifikační list (na šířku)

druhá varianta specifikačního listu.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivému hardware.

Nainstalovaný SW (legální)

seznam nainstalovaného legálního software (má vytvořenou licenci v souboru software).

Nainstalovaný SW (nelegální, bez licence)

seznam nainstalovaného Nelegálního software a software Bez licence.

Nainstalovaný SW (vše)

seznam legálního i nelegálního software.

Neschválené položky

tato sestava je zobrazena jen v případe, že máte zakoupenou multilicenci programu SPRÁVCE. Neschválené položky se vybírají pouze pro centrálně udržované číselníky, které mají povolenou aktualizaci.


Hardware - Zakladni udaje

Hardware - Základní údaje

Ovládání programu

Evidenční číslo

je určeno k jednoznačné identifikaci počítače (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Výrobní číslo, Inventární číslo, Specifické číslo

tyto položky mohou být kontrolovány na duplicitu. Výběr, zda budou položky kontrolovány na duplicitu, provedete ve volbě Konfigurace .

Inventární číslo

zadané inventární číslo počítače přebírá i všechno přiřazené příslušenství, které je označeno jako součást počítače při nákupu. Při změně inventárního čísla počítače se tato změna promítne do uvedeného příslušenství a vygeneruje se oprava stav = 9 (změna inv. čísla)

Specifické číslo

je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Rok výroby

je důležitý pouze v případě, že chcete tisknout revizní protokoly podle ČSN 33 1610, kde se tento údaj vyplňuje.

Lokální PC

název nascanovaných TXT a SWT souborů pro počítače mimo síť.

Operační systém

určuje název nainstalovaného operačního systému na počítači. Při použití scanu HW je tato položka automaticky naplněna z nascanovaného TXT souboru. Jinak ji lze zadat ručně.

Typ použití

určuje charakter použití počítače (např. kancelářské aplikace, server, CAD, …).

Značka

určuje značku počítače.

Procesor, provedení, MAC adresa

tyto položky nelze editovat. Naplní se automaticky až v okamžiku přiřazení daného příslušenství k počítači. Pokud máte více procesorů, je zde uveden první, který byl přiřazen. Příslušenství Provedení může být pouze jednou.

Název PC

určuje název počítače z ovládacích panelů sítě Windows. Automaticky se naplňuje při zpracování TXT souboru nebo ho lze zadat ručně. Podle nastavení parametru v konfiguraci lze zadat stejný název PC u více počítačů, v tomto případě pak nelze zapnout komunikaci v RSClientovi.

IP adresa

určuje IP adresu počítače. Lze ji zadat ručně nebo se automaticky načte v okamžiku zpracování scanu HW.

Zásuvka

je určená pro přesnější identifikaci místa např. v rámci strukturované kabeláže.

Doména

název domény, ve které je počítač umístěn.

Vztah k doméně

určuje přesnější typ a vztah počítače k doméně :

WORKSTATION/SERVER/DOMAIN CONTROLLER - typ počítače

MEMBER = počítač je začleněn do domény

STANDALONE = počítač není začleněn do domény

Součty PŘ

tyto položky nelze zadat ručně. Jsou určeny pro celkový součet počtu procesorů, pamětí, hard disků a pro celkovou kapacitu pamětí a hard disků. Pokud používáte scan SW, jsou údaje načteny automaticky při zpracování nascanovaných souborů.

Jestliže scan HW nepoužijete, musíte dané typy příslušenství (paměť, procesor, hard disk) ručně vytvořit na kartě Vazby PŘ nebo v evidenci PŘ.

Podmínkou správného načtení celkových kapacit příslušenství typu pevný disk je uložení kapacity v položce OBLAST1 a to ve tvaru :

„1000 MB“ nebo „1 GB“

(syntaxe : nejprve je číselný údaj udávající velikost, pak následuje mezera, a nakonec zkratka udávající jednotku a to MB nebo GB)

U příslušenství typu paměť se kapacita vezme z položky velikost, která je u tohoto typu příslušenství přístupná.

Organizační členění, Umístění, Odpovědná osoba, Síť

při změně některé z těchto položek se pro daný počítač automaticky vygeneruje do souboru oprav věta STAV=6 (Převod). Pokud byla změněna síť, vygeneruje se věta STAV=7 (Přiřazení/Odřazení) také do souboru sítí.


Hardware - Ekonomicke udaje

Hardware - Ekonomické údaje

Ovládání programu

Datum zakoupení a uvedení

datum zakoupení může být menší nebo stejný jako datum uvedení. Datum uvedení se zadává při zpracování výsledků scanu HW, SW nebo při ručním vytvoření věty hardware. V těchto případech se do souboru oprav vygeneruje věta STAV=1 Uvedení do provozu.

Základní ekonomické údaje

Nákupní cena

stanoví celkovou cenu počítače při zakoupení. V této ceně je zahrnuta i cena příslušenství, které má označeno, že bylo součástí počítače při nákupu.

Cena příslušenství

znamená celkovou cenu samostatně zakoupeného příslušenství. Tato cena je zablokovaná a aktualizuje se automaticky v okamžiku přiřazení příslušenství k danému počítači. A to pouze příslušenství, které není součástí počítače při nákupu

Celková cena včetně příslušenství

znamená celkovou cenu počítače + celkovou cenu samostatně zakoupeného příslušenství.

Datum zařazení a vyřazení z účetnictví

tyto položky nelze editovat. Aktualizují se automaticky při provedení exportu do účetnictví. Pokud je vyplněna položka Datum zařazení, nelze u tohoto zařízení opravovat cenu a rušit větu. Pokud je vyplněna položka Datum vyřazení, je zařízení v evidenci zlikvidováno (má STAV=8).

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na Volný číselník.


Evidence - ekonomicke udaje (servisy)

Servisy

Servisy

každý počítač, licence software, příslušenství a síť může mít naplánovány až 4 servisy.

Jsou zde uvedeny jejich čísla, názvy, intervaly a datumy provedení.

Při přiřazení servisu se do položky Datum servisu (což je datum nejbližšího servisu) uloží počáteční datum z číselníku servisů, pokud není prázdné. Jestliže je datum v číselníku servisů prázdné, vloží se datum uvedení do provozu nebo datum zakoupení nebo dnešní datum z počítače. Pokud ještě nebyl proveden servis, tak lze tento datum kdykoliv aktualizovat. Servis lze nahradit jiným servisem, případně zrušit. Položka Další servis se vypočte podle nastaveného intervalu servisu z číselníku servisů.

Servisy jsou barevně rozlišeny. Je-li servis již alespoň jednou proveden, tak je datum servisu zbarven modře, je-li datum dalšího servisu menší než dnešní datum z počítače, tak je zbarven červeně.

Na tlačítko Proveď u každého servisu nebo na tlačítko pro hromadný servis [image] se zobrazí formuláře pro možnost zadání provedení Servisu nebo Revize. Zadané hodnoty se ukládají do souborů oprav.


Hardware - Scany

Ovládání programu

Sloty

v mřížce jsou zobrazeny všechny sloty počítačů (jen pokud na daném počítači bylo implementováno rozhraní WMI).

Konektory

v mřížce jsou zobrazeny všechny konektory počítačů (jen pokud na daném počítači bylo implementováno rozhraní WMI).

Logické disky

v mřížce jsou zobrazeny logické disky aktuálního počítače, jejich název, velikost, volné místo, souborový systém logického disku (FAT32, NTFS ....) další údaje.

Zpracování souborů

položky zobrazují datumy vzniku (nascanování) TXT a SWT souborů a dále datumy jejich zpracování.


Hardware - Opravy

Ovládání programu

Tato karta obsahuje seznam (historii) oprav daného počítače. Zobrazuje soubor OPR_HW.DBF, ve kterém jsou uloženy všechny opravy hardware. Podrobnější popis naleznete v kapitole Opravy.


Hardware - Vazby SW

Hardware – Vazby SW

Ovládací tlačítka Hromadné výběry

Ve stromu je seznam licencí software, které jsou nainstalovány na daném počítači (má v souboru Software vytvořenou licenci). Po aktivaci karty jsou vždy vidět jen poslední verze licencí přiřazených k počítači. Pokud chcete vidět i předchozí verze musíte rozbalit další větve stromu. Je zde aktivní pravé tlačítko myši. Pomocí tohoto tlačítka zobrazit podrobné informace o software, zobrazit seznam volných licencí software Volný software, pořídit nový software.

Pokud licenci přiřazujete ručně (nenajdou se soubory při zpracování SWT souborů), je tato licence označena modrou tečkou před jejím názvem. Centrální licence zakoupená v nadřízené organizaci má v pravé části tučně zobrazeno číslo mateřské licence.

Detail / Oprava

pomocí pravého tlačítka a volby Detail software lze na této kartě zobrazit (i opravit) software, na němž se nachází kurzor.

Nová licence

provedete stiskem pravého tlačítka myši a výběrem volby Nový software. Spustí se formulář, ve kterém vytvoříte novou licenci SW a po jeho uložení následuje dotaz, zda tuto novou licenci hned přiřadit na aktuální počítač.

Volné licence

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volný software. Najednou se přiřadí všechen označený software.

Odřadit SW

pravým tlačítkem myši a výběrem volby Odřadit software odřadíte od počítače licenci nad níž se aktuálně nachází kurzor myši. Nelze provádět hromadné odřazení

Pozor :

· nelze odřadit SW z počítače, který byl zlikvidován (STAV=8).

· nelze odřadit SW, který je označen jako OEM a byl zakoupen k aktuálnímu počítači.

· pokud odřadím SW z PC a tento SW byl zjištěn při zpracování SW-scanu, pak se tato licence z PC odřadí a příslušné nalezené soubory se přesunou na kartu Nelegální.


Hardware - Vazby prislusenstvi

Hardware – Vazby PŘ

Ovládací tlačítka Hromadné výběry

V mřížce je seznam příslušenství přiřazeného k danému počítači. K počítači lze přiřadit pouze příslušenství typu K - klasické a O - ostatní. Příslušenství, které má STAV=8 (zařízení bylo zlikvidováno), je zobrazeno zelenou barvou, nelze jej odřadit. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechno příslušenství k odřazení, zobrazit podrobné informace o příslušenství, zobrazit seznam nepřiřazeného příslušenství Volné příslušenství, pořídit nové příslušenství, zobrazit nascanovaný textový soubor, přeřadit příslušenství na jiný hardware.

Detail / Oprava

pomocí pravého tlačítka a volby Detail příslušenství lze na této kartě zobrazit (i opravit) příslušenství, na němž se nachází kurzor.

Nové příslušenství hw

provedete stiskem pravého tlačítka myši a výběrem volby Nové příslušenství. Spustí se formulář, ve kterém vytvoříte nové příslušenství.

Volné příslušenství hw

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volné příslušenství. Program Vám nabídne formulář Volné zařízení, ve kterém musíte vybrat nový hardware. Po stisku tlačítka Přiřadit musíte zadat datum přiřazení, cenu práce a stanovit, zda se jedná o Opravu, Upgrade nebo Přidání. Podle posledního parametru je do souboru oprav vygenerována věta se STAVEM 3, 4 nebo 7.

Pozor :

· je vhodné přiřazovat najednou příslušenství, které bude mít stejný stav (oprava, upgrade), protože se vygeneruje pouze jedna věta pro všechno příslušenství.

· pokud přiřazované příslušenství není součásti počítače při nákupu, přičte se jeho cena k ceně samostatného příslušenství ve větě hardware.

Odřadit příslušenství hw

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit příslušenství. Program Vám nabídne formulář, ve kterém musíte zadat datum odřazení, cenu práce a stanovit, zda se jedná o Opravu, Upgrade nebo Přidání. Podle posledního parametru je do souboru oprav vygenerována věta se STAVEM 3, 4 nebo 7.

Pozor :

· před odřazením musíte označit PŘ, které chcete odřadit (zelený sloupec)

· je vhodné odřazovat najednou příslušenství, které bude mít stejný stav (oprava, upgrade), protože se vygeneruje pouze jedna věta pro všechno příslušenství.

· pokud odřazované příslušenství není součásti počítače při nákupu, odečte se jeho cena od ceny samostatného příslušenství ve větě hardware.

· pokud odřazované příslušenství je součásti počítače při nákupu, pak při odřazení se označení součást PC při nákupu zruší, ale ponechá se mu původní inventární číslo.

Přeřadit příslušenství hw

přeřazení vybraného příslušenství z jednoho počítače na druhý provedete stiskem pravého tlačítka myši a výběrem volby Přeřadit příslušenství. Program nabídne formulář Seznam HW pro přeřazení, ve kterém musíte vybrat nový hardware, na který má být vybrané příslušenství přeinstalováno. Program Vám nedovolí vybrat stejnou větu nebo hardware, který je zlikvidován.

Pozor :

· pokud přeřazované příslušenství není součásti počítače při nákupu, připočítá se cena příslušenství k ceně samostatného příslušenství ve větě hardware.

· pokud odřazované příslušenství je součásti počítače při nákupu, pak při odřazení se označení součást PC při nákupu zruší, ale ponechá se mu původní inventární číslo.

Smazat příslušenství hw

smazání vybraného příslušenství provedete stiskem pravého tlačítka myši a výběrem volby Smazat příslušenství hw.

Zlikvidovat příslušenství hw

touto volbou provedete likvidaci příslušenství, nad kterým se aktuálně nachází kurzor myši.

Součást PC

pomocí pravého tlačítka a volby Součást PC provedete označení všech vybraných příslušenství jako součásti při nákupu počítače. Pozor - vynuluje se cena aktuálního příslušenství a převezmou se všechny ekonomické údaje z ekonomických údajů hardware. Tyto údaje se zablokují a nelze je opravit nikde jinde, než v evidenci hardware.

TXT soubor

pravým tlačítkem myši a volbou TXT soubor zobrazíte TXT soubor z modulu scanu HW (samozřejmě pokud scanování modulem proběhlo).


Hardware - Vazby dokumentace

Hardware – Vazby dokumentace

Ovládací tlačítka Hromadné výběry

V mřížce je seznam dokumentace přiřazené k danému počítači. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit Volná dokumentace, pořídit novou dokumentaci.

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Evidence - dokumenty, poznamka

Poznámka, dokumenty

V horní části formuláře je obsah Poznámky náležící aktuálnímu záznamu. Poznámka je neomezeně dlouhá, můžete tam libovolně zapisovat.

V dolní části je mřížka se seznamem Dokumentů v elektronické podobě souvisejících s aktuálním zařízením. Tyto dokumenty musí být předem umístěny v adresáři (nebo jeho podadresářích), který je zadán v konfiguraci.

Stiskem pravého tlačítka myši nad mřížkou lze vyvolat menu, kde lze dokument přidat, odebrat a zrušit další nascanované dokumenty. Pomocí double clicku nad mřížkou, lze zobrazit formulář s obrázkem dokumentu.


Hardware - Nalezeny SW

Hardware – Nalezený SW

Ovládací tlačítka

Tato karta obsahuje seznam nalezeného software scanem SW. Je viditelná pouze tehdy, pokud máte tento program zakoupen.

V horní mřížce je zobrazen pouze legální SW tj. software, který je na počítači legálně nainstalován a v souboru SOFTWARE má vytvořenou licenci. Pokud byla licence přiřazena ručně (nenašla se pomocí programu SW-SCAN), je tato licence označena modrou barvou. Licence označená kurzívou je centrální licence zakoupená v nadřízené organizaci.

Ve spodní mřížce je tzv. nelegální SW a SW Bez licence (software Bez licence je v mřížce zobrazen modrou barvou). Je to software, který se nalezl scanem SW a nemá vytvořenou licenci. Přepnutí provedete pomocí přepínače pod mřížkou :


Hardware - Doplneni IC, VC, SC

Doplnění IČ, VČ, SČ

Při zpracování nascanovaných souborů scanu HW se načtou pouze technické údaje, ostatní netechnické údaje musíte doplnit buď v Hlavní evidenci hardware nebo v Doplnění IČ, VČ, SČ.


Hardware - Doplneni IC, VC, SC

Doplnění IČ, VČ, SČ

Při zpracování nascanovaných souborů scanu HW se načtou pouze technické údaje, ostatní netechnické údaje musíte doplnit v evidenci hardware. Tento formulář umožňuje doplnit následující údaje :

V horní mřížce je seznam evidovaného hardware. Ve žlutých sloupcích můžete provést doplnění následujících údajů :

a) odpovědná osoba - lze vybrat osobu z číselníku osob. Číselník musí být předem naplněný (ve mřížce nelze přidávat nové osoby).

b) inventární číslo - při vyplnění inventárního čísla počítače se ve spodní mřížce zapíše stejné inventární číslo pro všechno příslušenství, které je označeno jako Součást PC při nákupu. Při opuštění položky se provede kontrola na duplicitu podle nastavené konfigurace.

c) výrobní číslo - při opuštění položky se provede kontrola na duplicitu podle nastavené konfigurace.

d) specifické číslo - při opuštění položky se provede kontrola na duplicitu podle nastavené konfigurace.

e) rok výroby - má význam pro evidencí revizí podle ČSN.

f) název počítače - při opuštění položky se provede kontrola na duplicitu

V dolní mřížce je k aktuálně nastavenému počítači z horní mřížky zobrazeno všechno přiřazené příslušenství. Příslušenství, které má nastaveno, že je Součásti PC při nákupu, je zobrazeno modrou barvou.

První tři sloupce slouží k označení, zda je příslušenství :

a) Interní - zabudované uvnitř počítače

b) Servisní - používá se jako servisní pro dočasnou výměnu

c) Součástí při nákupu PC - bylo zakoupeno jako součást počítače.

Ve dalších žlutých sloupcích na konci mřížky lze doplnit inventární a výrobní číslo pro každé příslušenství. Je-li příslušenství označeno jako Součást PC při nákupu, pak inventární číslo nelze změnit.

Při označení příslušenství, že bylo Součástí PC při nákupu (sloupec P), se provedou následující operace :

a) všechny ekonomické údaje příslušenství se naplní údaji z počítače a nelze je nikde editovat.

b) cena příslušenství se vynuluje, je totiž obsažena v ceně počítače.

c) inventární číslo příslušenství se převezme z počítače.


Prislusenstvi hardware

Příslušenství hardware

Evidence příslušenství obsahuje :

· seznam komponent, ze kterých se počítač skládá (např. paměť, mainboard, video karty)

· samostatné komponenty pro upgrade (servis) počítačů

Před tím, než začnete pořizovat nová příslušenství si projděte Číselník typů příslušenství. Zde dobře navrhněte jednotlivé typy příslušenství. Číslo typu příslušenství začíná písmeny K nebo O.

V souboru příslušenství se evidují technické, ekonomické (faktura, dodavatel, …), a organizační údaje (odpovědná osoba, umístění, organizační členění, …). Dále je možno vést ke každému příslušenství jeho historii (seznam oprav, přiřazení k počítači, …), doklady k danému příslušenství zobrazit v elektronické podobě.


Prislusenstvi hardware - Seznam

Příslušenství - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie daného příslušenství. Duplikace je závislá na nastaveném Tvaru evidenčních čísel (volba Údržba – Konfigurace). Pokud je zapnuté libovolné číslování, vytvoří program stejnou větu, pouze vynuluje výrobní, inventární a specifické čísla a vygeneruje (nebo ručně zadá) evidenční číslo. Stav zařízení je přepsán na OK. Pokud je zapnuto automatické generování evidenčních čísel, nabídne Vám program formulář, ve kterém můžete zadat počet kusů duplikovaného příslušenství a zda chcete také duplikovat ekonomické údaje.

Zobrazení stavu příslušenství

Pokud je dané příslušenství v pořádku (není otevřena žádná oprava), svítí tam OK, jinak jsou tam hodnoty Závada, Oprava, Upgrade, Servis, Převod/Zapůjčení, Převod, Likvidace, které odpovídají souboru oprav. Položka je aktualizovaná automaticky v okamžiku aktualizace souboru oprav.

Pravé tlačítko myši

Toto tlačítko je funkční na mřížkou se seznamem příslušenství. Pomocí něj lze editovat poznámku k danému příslušenství nebo pokud je příslušenství přiřazeno k počítači zobrazit o něm detailní informace.

C) Tisky :

Parametry tisku

SESTAVY

Seznam příslušenství

jednoduchý seznam příslušenství.

Pasportní list

zobrazení všech položek (údajů) o příslušenství.

Záruka a odpisy

sestava příslušenství, ve které jsou zobrazena data záruky a odpisu. Pokud je zařízení po záruce, obsahuje v sestavě značku „P“, pokud je odepsáno, obsahuje značku „O“.

Seznam oprav

sestava oprav (historie) příslušenství. Lze vybrat, zda se mají tisknout všechny opravy nebo pouze některé. Také lze vybrat období. Tím lze sledovat např. technické zhodnocení zařízení během roku.

Deník oprav

sestava všech oprav příslušenství s podrobným popisem za zvolené období.

Rozpracované opravy

sestava všech příslušenství, které mají rozpracovanou opravu (jsou v opravě).

Nepřiřazené příslušenství

sestava příslušenství, které nejsou zatím přiřazeny na žádný počítač.

Dokumentace

seznam přirazené dokumentace.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny důležité parametry příslušenství, organizační a ekonomické údaje. Druhou volitelnou část předávacího protokolu lze nastavit v konfiguraci programu ve volbě Údržba - konfigurace. Tato část může být v každé organizaci jiná. Pokud tuto část nenastavíte, pak program automaticky na konci první části vytiskne text Datum předání …, Předal…, Převzal ….

Podřízené vazby

seznam podřízených příslušenství.

Prošlé servisy

tato sestava zobrazuje seznam příslušenství, která k určenému datu již měla mít proveden servis či revizi.

Provedené servisy

tato sestava zobrazuje seznam příslušenství, u kterých již byl proveden servis či revize. Údaje jsou z posledního zpracování.

Nastavené servisy

tato sestava zobrazuje seznam příslušenství, u kterých je nastaven servis či revize.

Seznam IP adres

tato sestava zobrazuje seznam všech síťových karet, které mají vyplněnou IP adresu.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivému příslušenství.

Neschválené položky

tato sestava je zobrazena jen v případe, že máte zakoupenou multilicenci. Neschválené položky se vybírají pouze pro centrálně udržované číselníky, které mají povolenou aktualizaci.


Prislusenstvi - duplikace vice kusu

Příslušenství – duplikace více kusů

Pokud máte v Konfiguraci programu nastaven tvar evidenčních čísel na číslování programem, můžete při duplikaci příslušenství hardware provést duplikaci více kusů najednou.

Program Vám spustí tento formulář, ve kterém stačí zadat počet kusů a po stisku tlačítka OK bude automaticky vygenerován požadovaný počet kusů. Před generací můžete ještě zadat, zda chcete duplikovat i ekonomické údaje.

Nově vytvořené příslušenství má vynulováno přiřazení k počítači a také má nastaveno, že nebylo zakoupeno jako součást PC při nákupu.


Prislusenstvi hardware - Zakladni udaje

Příslušenství hardware - základní údaje

Ovládání programu

Evidenční číslo

evidenční číslo je určeno k jednoznačné identifikaci příslušenství (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Výrobní číslo, Inventární číslo, Specifické číslo

tyto položky mohou být kontrolovány na duplicitu. Výběr, zda budou položky kontrolovány na duplicitu, provedete ve volbě Konfigurace .

Inventární číslo

pokud je příslušenství označeno jako součást PC při nákupu, přebírá inventární číslo z přiřazeného počítače. Při změně inventárního čísla počítače se tato změna promítne do uvedeného příslušenství.

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Rok výroby

v této položce je uveden rok, ve kterém bylo příslušenství vyrobeno.

Součást PC při nákupu

pokud je příslušenství označeno jako součást PC při nákupu, pak se provedou následující akce :

a) ekonomické údaje příslušenství se naplní ekonomickými údaji z vybraného počítače.

b) cena příslušenství se vynuluje (je obsažena v ceně počítače).

c) všechny položky karty Ekon. údaje se zablokují.

d) inventární číslo příslušenství se převezme z počítače.

Interní

tato položka určuje, zda příslušenství se nachází uvnitř skříně počítače.

Integrované

tato položka určuje, zda příslušenství je součástí boardu. Integrované příslušenství může být pouze interní příslušenství.

Servisní

položka označuje, zda příslušenství je používáno jako servisní za jiné poškozené.

Typ příslušenství

položka Typ příslušenství je na této kartě nejdůležitější. Podle ní se nastavují filtry na příslušné číselníky názvů a oblastí (ve výběrech jsou pouze věty, které odpovídají zadanému typu). V případě, že PŘ není přiřazeno na nějaký hardware, jsou přístupné položky síť, org. členění, umístění a odp. osoba. Pokud se PŘ přiřadí na hardware, naplní se tyto položky údaji z hardware a zablokují se. Kusy jsou nastaveny na 1. U příslušenství typu K013 (CASE) se přiřazení nebo odřazení promítne do položky Provedeni, u typu K002 (PROCESOR) do položek Typ a Ks_Proc, u typu K003 (PAMĚŤ) do položek Ks_Pam a Kap_Pam a u typu K006 (HDD) do položek Ks_HD a Kap_HD v souboru hardware.

Název příslušenství

po výběru typu příslušenství se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající názvy. Položka je kontrolovaná proti číselníku názvů příslušenství, pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka slouží ke sjednocení názvů příslušenství.

Velikost

tato položka je přístupná pouze pro příslušenství typu K003 (PAMĚŤ). Obsahuje kapacitu paměti v MB. Tato velikost se používá pro počítání celkové kapacity paměti u hardware.

Oblast1

po výběru typu příslušenství se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku oblastí 1 příslušenství, pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka slouží u klasického PŘ typu K k podrobnější identifikaci zařízení, využívá se scanem HW. U typu klasické – ostatní (O) je k libovolnému použití.

Oblast2

po výběru typu příslušenství se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku oblastí 2 příslušenství, pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka se nevyužívá programem HW-SCAN, lze ji použít libovolně.

Hardware

při výběru nebo změně hardware se do věty příslušenství dotáhnou položky : odpovědná osoba, umístění, org. členění a síť nového hardware. Tyto položky nelze editovat.

Organizační členění, Umístění, Odpovědná osoba, Hardware nebo Síť

při změně některé z těchto položek se pro dané příslušenství automaticky vygeneruje do souboru OPR_PR věta STAV=6 (Převod). Pokud byl změněn počítač nebo síť, vygeneruje se věta také pro změněný počítač nebo síť STAV=7 (Přiřazení/Odřazení).

Volné položky

jsou položky, které jsou závislé na zvoleném typu příslušenství. Pro příslušenství typu klasické (K...) jsou některé z těchto položek pojmenovány. To jsou položky, do kterých se načítají hodnoty ze scanu HW. Ostatní položky jsou označené jako Volné a v závorce mají jméno položky ze struktury souboru. To je pro případné vybírání položek při definování filtru nebo tvorbě vlastní sestavy. POZOR - pokud používáte scan HW, prohlédněte si v konfiguraci údaje, které se do těchto položek načítají.

Nadřízené příslušenství

informace o příslušenství, ke kterému je aktuální příslušenství přiřazeno. Tyto položky nelze editovat.


Prislusenstvi hardware - Ekonomicke udaje

Příslušenství hardware - ekonomické údaje

Ovládání programu

Datum zakoupení a uvedení

datum zakoupení může být menší nebo stejný jako datum uvedení. Datum uvedení se zadává při zpracování výsledků scanu HW nebo při ručním vytvoření věty příslušenství. V těchto případech se do souboru oprav vygeneruje věta STAV=1 Uvedení do provozu.

Ek. údaje načíst z HW

za předpokladu, že příslušenství má mít stejné ekonomické údaje jako přiřazený počítač, lze tímto tlačítkem načíst ekonomické údaje z věty hardware a ušetřit si tak práci. Tlačítko je funkční pouze, pokud je příslušenství přiřazeno na nějaký počítač.

Základní ekonomické údaje

pokud je příslušenství označeno jako Součást PC při nákupu, pak je většina základních ekon. údajů na této kartě zablokována. Přístupná je pouze položka Záruka (může být jiná než u počítače).

Nákupní cena

tato cena se vyplňuje pouze v případě, že příslušenství není součástí počítače.

Datum zařazení a vyřazení z účetnictví

tyto položky nelze editovat. Aktualizují se automaticky při provedení exportu do účetnictví. Pokud je vyplněna položka Datum zařazení, nelze u tohoto zařízení opravovat cenu a rušit větu. Pokud je vyplněna položka Datum vyřazení, je zařízení v evidenci zlikvidováno (má STAV=8).


Prislusenstvi hardware - Ostatni

Příslušenství hardware - ostatní

Ovládání programu

Servisy

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na volný číselník.

Přiřazený OEM software

tato položku zobrazuje OEM licenci software, která byla zakoupena současně s daným příslušenstvím.


Prislusenstvi hardware - Opravy

Příslušenství hardware - opravy

Ovládání programu

Tato karta obsahuje seznam (historii) oprav daného příslušenství. Zobrazuje přímo soubor OPR_PR.DBF, ve kterém jsou uloženy všechny opravy evidovaných příslušenství. Podrobnější popis naleznete v kapitole Opravy.


Prislusenstvi hardware - Vazby dokumentace

Příslušenství hardware – vazby dokumentace

Ovládání programu Hromadné výběry

V mřížce je seznam dokumentace přiřazené k danému příslušenství. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit Volná dokumentace, pořídit novou dokumentaci.

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Prislusenstvi hardware - Vazby prislusenstvi

Příslušenství – vazby příslušenství

Ovládání programu Hromadné výběry

Tato karta umožňuje k aktuálnímu příslušenství přiřazovat jiné příslušenství. To je vhodné v případě, že se příslušenství skládá z dalších příslušenství. Toto přiřazení se provádí směrem od nadřízeného příslušenství k podřízenému (např. k tiskárně se přiřadí tisková hlava, páska, ...).

V mřížce je zobrazeno všechno podřízené příslušenství aktuálnímu příslušenství. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechno příslušenství k odřazení, zobrazit podrobné informace o příslušenství, zobrazit seznam nepřiřazeného příslušenství (Volné příslušenství), zobrazit další podřízené příslušenství.

Detail příslušenství

pomocí pravého tlačítka a volby Detail příslušenství lze na této kartě zobrazit (i opravit) příslušenství, na němž se nachází kurzor.

Další příslušenství

pokud je k některému podřízenému příslušenství v mřížce přiřazeno další podřízené příslušenství, je možno zobrazit pomocí této volby formulář Podřízené vazby.

Podřízené příslušenství

pomocí pravého tlačítka a volby Podřízené příslušenství lze na této kartě zobrazit seznam příslušenství, ze kterého lze vybrat všechna podřízená příslušenství.

Odřadit příslušenství

program odřadí najednou všechna vybraná podřízená příslušenství (vynuluje jim položku Nad_Pris).


Typy prislusenstvi a techniky

Typy příslušenství a techniky

Ovládání programu Parametry tisku Hromadné výběry

Soubor příslušenství a techniky se skládá vlastně ze čtyř samostatných souborů, a to ze souborů typů, názvů, oblastí1 a oblastí2.

Typy příslušenství a techniky slouží ke sjednocení výpočetní techniky jako je paměť, procesor, tiskárna apod. Pro každý typ pak v souboru názvů příslušenství a techniky existuje seznam všech názvů, který sjednotí názvy. Soubory oblastí 1 a oblastí 2 slouží pouze ke sjednocení dalších důležitých údajů jako je např. kapacita paměti, hard disku apod.

Při spuštění formuláře je zobrazen celý soubor typů. Pomocí přepínače ve spodní části formuláře je možno zobrazit pouze určitý typ.

SESTAVY

Seznam typů příslušenství

sestava celého číselníku typů příslušenství.

Seznam názvu příslušenství

sestava celého číselníku názvů příslušenství.

Seznam oblastí 1

sestava celého číselníku oblastí 1.

Seznam oblast 2

sestava celého číselníku oblastí 2.

Vazby - typy příslušenství

sestava vazeb číselníku typů příslušenství.

Vazby - názvy příslušenství

sestava vazeb číselníku názvů příslušenství.

Vazby - oblasti 1

sestava vazeb číselníku oblastí 1.

Vazby - oblasti 2

sestava vazeb číselníku oblastí 2.

Neschválené položky - typy PŘ

sestava neschválených typů příslušenství (pouze pro multilicenci).

Neschválené položky - názvy PŘ

sestava neschválených názvů příslušenství (pouze pro multilicenci).

Neschválené položky - oblastí PŘ

sestava neschválených oblastí příslušenství (pouze pro multilicenci).


Typy prislusenstvi a techniky - soubor typu

Typy příslušenství, síťové techniky a majetku

Ovládání programu Hromadné výběry

Číslo typu příslušenství se skládá ze čtyř znaků, prvním znakem je jedno z následujících písmen (K,O,L,S,V – podle druhu techniky). Další tři znaky čísla typu jsou čísla v rozsahu 001 - 999. Jejich návrh je pouze Vaší záležitostí. Název typu může být v číselníku duplicitní. Z hlediska logiky se to však nedoporučuje.

Příslušenství hardware

K001 - K023

klasické příslušenství je určeno k přiřazení na hardware. Při použití scanu HW je nutné přesně určit typy příslušenství, aby se nascanované hodnoty přiřadily správně. K tomuto účelu byly proto vytvořeny tyto typy, které nelze opravovat, přidávat ani rušit. Toto příslušenství aktualizuje pouze autorská firma programu.

O001 – O999

ostatní klasické příslušenství je taktéž určeno k přiřazení na hardware. Tyto typy jsou určeny pro případ, že v klasických typech nenajdete všechny typy příslušenství, které v organizaci používáte. Tyto typy můžete libovolně aktualizovat i rušit. Jedná se např. o filtry, reprobedny, ups apod.

Síťová technika

L001

síťová technika je určena k přiřazení na sítě. Scan HW umí určit síťové tiskárny, které mají označení L001. Další typy bude aktualizovat dodavatelská firma, a to pouze v případě úpravy scanu HW.

S001 – S999

ostatní síťová technika se rovněž přiřazuje k sítím. Tyto typy jsou určeny pro všechny ostatní techniky – routry, huby, repeatry apod.

Ostatní majetek

V001 – V999

ostatní majetek nepatří ani k hardware ani k síti. Jedná se např. o kopírky, faxy, záznamníky, databanky, mobily apod.

V pravé mřížce karty souboru typů jsou zobrazeny vazby na soubor příslušenství nebo techniky. Tato mřížka zobrazuje veškeré příslušenství (techniku), které nabývá dané hodnoty ze souboru typů.


Typy prislusenstvi a techniky - soubor nazvu

Názvy příslušenství, síťové techniky a majetku

Ovládání programu Hromadné výběry

Tento soubor slouží ke sjednocení názvů příslušenství a techniky, čímž by nemělo docházet ke stavu, že název daného příslušenství (techniky) napíšete pokaždé jinak (např. Tiskárna Epson FX-1050, Tiskárna FX1050 apod.) a již nikdy nezjistíte, kolik např. tiskáren Epson FX-1050 vlastně máte. Ke každému typu můžete mít libovolný počet názvů.

Pozor :

většinu názvů klasických typů (K...) příslušenství a některé síťové typy (L…) lze nascanovat pomocí scanu HW. Proto se držte těchto názvů a další názvy dodávejte s ohledem na tyto nascanované hodnoty.

Pokud máte vybrán určitý druh příslušenství (techniky) je v pravé části karty jsou zobrazena mřížka s vazbami na soubor příslušenství (techniky). Tato mřížka zobrazuje veškeré příslušenství (techniku), které nabývá dané hodnoty ze souboru.

Změna vazby

Sloupec OK ve mřížce, který je zobrazen pouze pro multilicence, ukazuje věty schválené nadřízenou organizací.


Typy prislusenstvi a techniky - soubor Oblasti1

Oblasti 1 příslušenství, síťové techniky a majetku

Ovládání programu Hromadné výběry

Tento soubor je pro většinu klasických typů příslušenství ( K... ) určen hodnotami nascanovanými scanem HW.

Např.: pro typ K002 - Procesor je ”číselník oblastí 1” používán pro položku Výrobce. Což znamená, že při zpracování nascanovaných souborů scanu HW se do tohoto číselníku načítají následující hodnoty výrobce procesoru : Intel, AMD, Cyrix. A to znamená, že nesmíte pro tento typ použít ”číselník oblastí 1” k ničemu jinému.

Podmínky aktualizace :

a) pro typy příslušenství K001-K023 nesmíte libovolně použít vlastní hodnoty.

b) pro ostatní typy můžete tento soubor použít libovolně.

Pokud máte vybrán určitý typ příslušenství (techniky), je v pravé části karty jsou zobrazena mřížka s vazbami. Tato mřížka zobrazuje veškeré příslušenství (techniku), které nabývá dané hodnoty e souboruu. V posledním sloupci této mřížky je číslo hardware, které ukazuje, zda dané příslušenství je již přiřazeno k nějakému počítači.

Změna vazby


Typy prislusenstvi a techniky - soubor Oblasti2

Oblasti 2 příslušenství, síťové techniky a majetku

Ovládání programu Hromadné výběry

Tento soubor je pro všechny typy příslušenství (techniky) a můžete jej použít libovolně. Např. pro monitory, v něm můžete sledovat jejich velikost (14”,15”) nebo pro tiskárny způsob tisku (jehličkové, laserové) apod.

Pokud máte vybrán určitý druh příslušenství (techniky), je v pravé části karty jsou zobrazena mřížka s vazbami. Tato mřížka zobrazuje veškeré příslušenství (techniku), které nabývá dané hodnoty z číselníku. V posledním sloupci této mřížky je číslo hardware, které ukazuje, zda dané příslušenství je již přiřazeno k nějakému počítači.

Změna vazby


Typy prislusenstvi a techniky - volne vazby

Typy příslušenství, síťové techniky a majetku – volné vazby

Ovládání programu Hromadné výběry

Tato karta zobrazuje věty souboru příslušenství (síťové techniky, ostatního majetku), které nemají vyplněné položky Oblast 1 a Oblast 2. Přepínačem Oblast1/Oblast2 měníte zobrazení vět ve mřížce.

Změna vazby


Urceni disku

Názvy položek příslušenství, síťové techniky a ostatního majetku

Formulář slouží k dvěma účelům.

1. K seznámení s položkami, které lze nascanovat scanem HW

2. K definování názvů položek, které se nepoužívají při zpracování scanů a které můžete použít pro vlastní potřebu.

Mřížka obsahuje v prvních dvou sloupcích seznam všech typů příslušenství a techniky. V dalších sloupcích jsou pak jejich skutečně nascanované hodnoty (hardwarovým scanem), nebo editovatelné názvy položek.

V hlavičkách sloupců mřížky jsou uvedeny názvy položek ze souboru Příslušenství, Síťové techniky a ostatního majetku, do kterých se nascanované hodnoty jednotlivých typů příslušenství načítají.

Nascanované hodnoty, které jsou zobrazeny červeně jsou tzv. základní – provádí se podle nich analýza při zpracování scanů, zda v daném počítači došlo k výměně příslušenství.

Buňky mřížky, které jsou zobrazeny žlutou barvou lze editovat. Tyto buňky označují položky, které se nepoužívají při zpracování scanů a které můžete použít pro vlastní potřebu. Pokud tyto položky nevyplníte, bude se na ně program všude odkazovat skutečným názvem položky uzavřeným v závorkách – např. (Volne1). Tento způsob je nešikovný, protože nevíte jaké údaje do těchto položek zapisovat. Proto je výhodné si typ údaje, který tam bude vyplňovat, zde zapsat. Pak se program všude bude odkazovat tímto údajem – např. Úhlopříčka.

Stiskem tlačítka Tisk můžete vytisknout seznam všech položek.


Operacni systemy hardware

Operační systémy hardware

Soubor operační systémy hardware slouží k určení toho, jaký operační systém je na hardware nainstalován. Na rozdíl od operačních systémů software musí být operační systém hardware jednoznačný. Při použití scanu HW je výsledek jednoznačný, pokud scan HW nepoužíváte, měli by jste dodržet při ruční aktualizaci podobný princip.

Příklad hodnot :

MS-DOS 6.0

Windows 95

Windows 2000

Podrobnější popis


Ciselniky - hardware (operacni systemy)

Operační systémy hardware

1. Karta Seznam

zobrazuje seznam všech hodnot operačních systémů hardware. Pro aktualizaci platí následující pravidla :

a) název operačního systému nesmí být v seznamu duplicitní.

b) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Operační systémy hardware

seznam všech operačních systémů hardware.

Vazby - hardware

sestava jednotlivých operačních systémů s vazbami hardware.

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Vazby HW

zobrazuje seznam hardware, který odpovídá aktuální hodnotě operačního systému hardware. Lze zde provést hromadnou Změna vazby.

3. Karta Volný HW

karta obsahuje vazby, ve kterých není položka operační systém hardware vyplněna. Lze zde provést hromadnou Změna vazby.


Znacky hardware

Značky hardware

Soubor Značky hardware slouží k rozlišení počítačů podle značky výrobce hardware.

Příklad hodnot :

IBM

DELL

COMPAQ

Podrobnější popis


Znacky hardware

Značky hardware

1. Karta Seznam

zobrazuje seznam všech hodnot značek hardware. Pro aktualizaci platí následující pravidla :

a) název značky nesmí být v seznamu duplicitní.

b) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Značky hardware

seznam všech značek hardware.

Vazby - hardware

sestava jednotlivých značek s vazbami na hardware.

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Vazby HW

zobrazuje seznam hardware, který odpovídá aktuální hodnotě značky hardware. Lze zde provést hromadnou Změnu vazby.

3. Karta Volný HW

karta obsahuje vazby, ve kterých není položka značka hardware vyplněna. Lze zde provést hromadnou Změnu vazby.


Typy pouziti hardware

Typy použití hardware

Soubor typů použití hardware slouží k rozlišení počítačů podle použití počítače k určité činnosti.

Příklad hodnot :

Kancelářské práce

Server sítě

CAD stanice

Bezdisková stanice

Router

Podrobnější popis


Ciselniky - hardware (typy pouziti)

Typy použití hardware

1. Karta Seznam

zobrazuje seznam všech hodnot typu použití hardware. Pro aktualizaci platí následující pravidla :

a) název typu použití nesmí být v seznamu duplicitní.

b) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy :

Typy použití hardware

seznam všech typů použití hardware.

Vazby - hardware

sestava jednotlivých typů použití s vazbami na hardware

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Vazby HW

zobrazuje seznam hardware, který odpovídá aktuální hodnotě typu použití hardware. Lze zde provést hromadnou Změnu vazby.

3. Karta Volný HW

karta obsahuje vazby, ve kterých není položka typ použití hardware vyplněna. Lze zde provést hromadnou Změnu vazby.


SW Audit

SW audit je vlastně inventura nainstalovaného software. Následující text je vlastně návod, jak při něm postupovat :

1. Nastavení scanů software – postup naleznete v tištěné příručce SCANY HW a SW

2. Spuštění scanů software – postup naleznete v tištěné příručce SCANY HW a SW

a. pomocí RemoteScanu – vzdálené scanování stanic po síti

b. pomocí login scriptu – scanování stanic v síti v okamžiku přihlášení uživatele

c. ruční scan počítačů mimo síť

3. Spuštění volby Údržba – Konfigurace – kontrola správné cesty k nascanovaným TXT souborům ze scanovacích modulů.

4. Postupné spuštění voleb v menu SW audit (viz. následující obrázek) :

V SW auditu se můžete setkat s těmito pojmy :

· Licence SW - řádně zakoupená instalace SW podložená fakturou

· Nelegální SW - software, který se nalez na počítači a který není podložen fakturou

· SW bez licence - jde o software nevyžadující licence (freeware, ovladače, instalace, hw utility)

· Upgrade - nová verze, zakoupená se slevou na předchozí verzi

· Downgrade - software jenž umožňuje mít na počítači nainstalovanou nižší verzi (dočasně nebo z důvodu slabé konfigurace počítače) a instalaci této nižší verze pokrýt z licence vyšší verze.

· OEM licence - software zakoupená jako součást počítače nebo jeho příslušenství

· Multilicence - jakýkoliv software, který umožňuje instalaci na více než jeden počítač.

Tyto pojmy jsou dále vysvětleny v okamžiku, kdy se používají. Velmi důležitou informací je, ale jakým co nejjednodušším způsobem vytvořit licenci. Na tento problém najdete odpověď zde : Kdy a jak vytvořit Licence software?

a. Zpracování scanu SW – toto zpracování poskytne základní údaje o nainstalovaném software. Dále umožní vygenerovat a přiřadit legálně zakoupené licence. Po zpracování musíte doplnit údaje, které se nedají nascanovat (ekonomické údaje, licenční čísla apod.) ve volbě Evidence licencí software.

b. Evidence licencí software – umožňuje ručně zavádět licence software. Dále umožňuje postupně doplňovat všechny údaje, které se nedají nascanovat, a to vždy ke každé licenci. Tato volba není určena pro hromadné naplnění dat, ale pro komplexní doplnění dat jedné licence software. Evidence umožňuje kromě doplnění základních položek evidovat také další informace :

· Servisy – evidence ročních servisů, software assurance.

· Opravy – historie změn a oprav software

· Vazby Hw - ruční přiřazení licencí na hardware

· Dokumentace – přiřazení dokumentace

· Poznámky – neomezená poznámka pro vlastní potřebu

· Upgrade – doplnění posloupnosti upgrade/update.

· Elektronické dokumenty – seznam důležitých dokumentů v elektronické podobě

c. Bilance software – zobrazuje celkovou bilanci využití software

d. Doplnění údajů z dalších databází software – následující volby Operační systémy software, Oblasti a podoblasti software, Výrobci software a Lokalizace software umožňují hromadné zadání údajů pro více vět najednou.

5. Naplnění ze společných číselníků – jednotlivé číselníky opět umožňují hromadné zadání údajů na více počítačů najednou.

6. Import údajů – ve volbě Údržba – Import lze importovat některé číselníky, ekonomické údaje a technické údaje z externích evidencí. Import lze provést pouze z formátů XLS, TXT a DBF.

7. Sestavy – software má největší množství sestav. Bohužel není možné je soustředit na jedno místo, takže je najdete v různých evidencích. Následující řádky Vám pomohou se v tom zorientovat :

a. Sestavy v Evidenci hardware – tyto sestavy se vztahují ke konkrétním počítačům. Takže mají strukturu seznamu počítačů a k nim jsou zobrazeny potřebné údaje o software. Jedná se o sestavy – předávací protokol, seznamy nainstalovaného software.

b. Sestavy v Evidenci licencí software – tyto sestavy zobrazují pouze legální licence software, nenajdete zde nelegální software nebo software bez licence

c. Sestavy v Bilanci software – tyto sestavy dávají přehled za všechen nainstalovaný software bez ohledu, zda je legální nebo není.

d. Sestavy v Zpracování scanu SW – tyto sestavy zobrazují vždy pouze aktuální kartu software (licenci, nelegální apod.) konkrétního nebo všech počítačů.

8. Inventura – ve volbě Ostatní – Inventární sestavy můžete provést a vytisknout inventuru software.


Zpracovani Sw-scanu

Scan SW– zpracování scanu SW

Scanovací moduly scanu SW provedly scanování požadovaných počítačů a výsledky uložily do souborů. Tyto soubory musí být uloženy v adresáři, který je nastaven ve volbě Konfigurace.

Před spuštěním zpracování SWT souborů se nejprve provede Kontrola údajů jednotlivých souborů proti evidenci hardware. Po této kontrole se spustí vlastní formulář pro zpracování výsledků scanu SW.

Tento formulář zpracování má následující karty :

Hardware - provádí se zpracování nascanovaných souborů

Licence - seznam legálních licencí

Nelegální - seznam nelegálních instalací

Bez licence - seznam instalací, které nevyžadují licenci

Nevedené - seznam nepřesností, které nebudou vstupovat do sestav

Neurčené - seznam neurčených souborů (nenalezených v databázi vzorů SW).

Porovnání - porovnání výsledků proti uloženému čistému stavu

Registry - výpis instalací z registrů

Zrušené - seznam souborů označených ke zrušení

Archiv - seznam souborů v archivních adresářích, které se nezpracovávají

Přípony - seznam souborů jiných přípon než EXE a COM

Konfig. - nastavení konfigurace zpracování

Dočasné - seznam dočasných vzorů pro multilicence programu Správce


Zpracovani Sw-scanu - standardni tlacitka

Scan SW – Zpracování SWT souborů

STANDARDNÍ TLAČÍTKA :

Vzory SW

stiskem tohoto tlačítka vyvoláte formulář Aktualizace ostrých vzorů, který umožňuje prohlédnout, případně aktualizovat ostré vzory SW bez nutnosti ukončit formulář zpracování.

Akt. sdílené

tlačítko Akt. sdílené slouží k nastavení parametru SDÍLEN u sdílených souborů (soubor se podle názvu, velikosti a verze v hlavičce vyskytuje ve více vzorech). Je vhodné jej spustit po přidání většího počtu neurčených souborů do vzorů. Nemusíte toto tlačítko spouštět po přidání každého souboru. Stačí spustit občas, hlavně po přidání souborů, o kterých víte, že existují ve více vzorech a že je nutné zkontrolovat sdílení souborů.

Po jeho stisku se objeví dotaz, jestli chcete aktualizovat pouze nově přidané soubory. Pokud odpovíte :

· ANO - zaktualizují se pouze nově přidané soubory od poslední aktualizace.

· NE - zaktualizují se všechny soubory.

Hrom. licence

stiskem tohoto tlačítka se vyvolá formulář Hromadné vytvoření a přiřazení licencí, který umožňuje prohlédnout všechny Nelegální instalace a přiřadit (nebo vytvořit) legální licence na vybrané počítače.

SW_dočas

toto tlačítko není standardně viditelné. Vidí ho pouze multilicence programu Správce, a to jen když mají zablokovanou aktualizaci číselníku názvů SW. Stiskem tohoto tlačítka vyvoláte formulář Aktualizace dočasných vzorů, který umožňuje prohlédnout a aktualizovat dočasné vzory SW bez nutnosti ukončit formulář zpracování.


Zpracovani Sw-scanu - vzoru SW docasne

Scan SW – vzory SW dočasné

Tato volba slouží k ruční úpravě dočasných vzorů software, které nemáte právo zařadit do centrálních vzorů. Není vhodná pro pořizování jednotlivých vzorů, pouze k jejich úpravě. Pomocí tlačítka Nová lze vytvořit další soubor, ale je nutné znát všechny jeho údaje - velikost, datum a čas. Takže se pravděpodobně nebude používat často. V jednom vzoru nesmí být soubor stejného názvu a velikosti vícekrát než jednou. Program nedovolí takovou duplicitu zadat. Tlačítko Oprava slouží především k úpravě následujících údajů :

Adresář

tento údaj je pouze informativní, při určování nalezených instalací se na něj bere zřetel pouze při odhadu nebo při nalezení jednoho vzoru vícekrát na počítači. Obecně by zde měl být adresář, který standardně používáte pro instalaci daného software. Při přiřazování neurčených souboru ke vzoru je do této položky zapsán údaj, který se nalezl na prvním zpracovaném počítači. Na ostatních počítačích tento adresář může být úplně jiný.

Hlavní soubor

tímto parametrem lze označit libovolný soubor daného vzoru a to ten, pomocí kterého se celá aplikace spouští. Pokud nemá aplikace jednoznačný hlavní soubor (např. MS Office), můžete označit více souborů nebo ponechat vzor bez hlavního modulu. Tento parametr má význam pouze při zpracování textových souborů, kde na kartě Nelegální a Licence je software bez hlavního souboru označen fialovou barvou.

Sdílen

tento parametr nemáte možnost změnit. Mění se programově při ukončení tohoto formuláře nebo na kartě Zpracování SWT souborů. Tento parametr označuje soubory, které se stejnou velikostí a názvem existují u různých verzí software (např. WINDOWS 95, 98, VISUAL FOXPRO apod.).

Menu na pravé tlačítko myši :

Zruš vzor

pomocí této volby lze najednou zrušit všechny soubory aktuálního vzoru. Jinak se rušení jednotlivých souborů provádí přes horní toolbar jako v ostatních formulářích (např. hardware, software,...).

Změna adresáře

pomocí této volby lze pro aktuální vzor změnit adresář, který se tam dostal při zpracování počítače, kde instalace vzoru byla provedena do nestandardního adresáře. Adresář umístění souborů není při zpracování směrodatný. Používá se pouze pro odhad a pravděpodobné stanovení ve vzorech. Obecně lze říci, že je jedno, jaký ten adresář je. Pro přesnější přiřazení ke vzoru je výhodné, aby tento adresář byl shodný s nascanovanými soubory. Což však je problém, protože na každém počítači to může být jiné. Výhodné je vzít adresář ze vzoru jako základ a na všech počítačích se snažit instalovat software do tohoto adresáře. Tento problém je však velice individuální, každému vyhovuje něco jiného.

Výstup do KSPRÁVCE

dočasné vzory lze zaslat nadřízené organizaci do programu KSPRÁVCE, ve kterém dojde k jejich oficiálnímu schválení. Po schválení v programu KSPRÁVCE se přes program NADSTAVBA dostanou zpátky do programu SPRÁVCE jako schválené centrální vzory a v dočasných vzorech se smažou.

Před provedením výstupu musíte v 1.sloupci mřížky vybrat soubory, které chcete odeslat. Stiskem tlačítka Výstup se spustí formulář Výstup dočasných vzorů do KSPRÁVCE, ve kterém zvolíte adresář, kam se výstup provede. Implicitně je nabízen adresář pro nadřízenou organizaci (viz Konfigurace programu SPRÁVCE ). Výstup se provede ve formě textového souboru, který se jmenuje podle čísla závodu a příponu má VZR (např. ZAVOD1.VZR).

Při příjmu centrálních souborů z programu KSPRÁVCE ve volbě NADSTAVBA – Příjem číselníků se schválené dočasné vzory smažou ze souboru SW_DOCAS přesunou se do souboru SW_LIST (ostré vzory).

SESTAVY

Seznam dočasných vzorů

seznam názvu dočasného software.

Seznam dočasných vzorů (+seznam souborů)

seznam názvu dočasného software i s jednotlivými soubory.


Zpracovani Sw-scanu - vystup docasnych vzoru do Kspravce

Scan SW – výstup dočasných vzorů do Ksprávce

Tento formulář slouží k vytvoření výstupního souboru se všemi dočasnými vzory pro nadřízenou organizaci do programu KSPRÁVCE. Program vezme všechny dočasné vzory a vytvoří soubor se jménem daného závodu a příponou VZR (např. Zav01.VZR).

Tento soubor je nutné dodat do programu KSPRÁVCE, kde provede přihrání. Přihrání se provádí v menu Centrální soubory ve volbě SW vzory. Dole pod mřížkou je tlačítko Nové soubory, které Vám zaslaný soubor zobrazí a povolí Vám provést přihrání. Po přihrání je nutné v programu KSPRÁVCE tyto vzory schválit a exportem centrálních souborů je poslat zpátky do programu SPRÁVCE.


Zpracovani Sw-scanu - ostre vzory SW

Scan SW – ostré vzory SW

Tato volba slouží k ruční úpravě vzorů software, které vznikly při zpracování textových souborů. Není vhodná pro pořizování jednotlivých vzorů, pouze k jejich úpravě. Pomocí tlačítka Nová lze vytvořit další soubor, ale je nutné znát všechny jeho údaje - velikost, datum a čas. Takže se pravděpodobně nebude používat často. V jednom vzoru nesmí být soubor stejného názvu a velikosti vícekrát než jednou. Program nedovolí takovou duplicitu zadat. Tlačítko Oprava slouží především k úpravě následujících údajů :

Adresář

tento údaj je pouze informativní, při určování nalezených instalací se na něj bere zřetel pouze při odhadu nebo při nalezení jednoho vzoru vícekrát na počítači. Obecně by zde měl být adresář, který standardně používáte pro instalaci daného software. Při přiřazování neurčených souboru ke vzoru je do této položky zapsán údaj, který se nalezl na prvním zpracovaném počítači. Na ostatních počítačích tento adresář může být úplně jiný.

Hlavní soubor

tímto parametrem lze označit libovolný soubor daného vzoru a to ten, pomocí kterého se celá aplikace spouští. Pokud nemá aplikace jednoznačný hlavní soubor (např. MS Office), můžete označit více souborů nebo ponechat vzor bez hlavního modulu. Tento parametr má význam pouze při zpracování textových souborů, kde na kartě Nelegální a Bez licence je software bez hlavního souboru označen fialovou barvou.

Sdílen

tento parametr nemáte možnost změnit. Mění se programově při ukončení tohoto formuláře nebo na kartě Zpracování SWT souborů. Tento parametr označuje soubory, které se stejnou velikostí a názvem existují u různých verzí software (např. WINDOWS 95, 98, VISUAL FOXPRO apod.).

Menu na pravé tlačítko myši :

Zruš vzor

pomocí této volby lze najednou zrušit všechny soubory aktuálního vzoru. Jinak se rušení jednotlivých souborů provádí přes horní toolbar jako v ostatních formulářích (např. hardware, software,...).

Změna adresáře

pomocí této volby lze pro aktuální vzor změnit adresář, který se tam dostal při zpracování počítače, kde instalace vzoru byla provedena do nestandardního adresáře. Adresář umístění souborů není při zpracování směrodatný. Používá se pouze pro odhad a pravděpodobné stanovení ve vzorech. Obecně lze říci, že je jedno, jaký ten adresář je. Pro přesnější přiřazení ke vzoru je výhodné, aby tento adresář byl shodný s nascanovanými soubory. Což však je problém, protože na každém počítači to může být jiné. Výhodné je vzít adresář ze vzoru jako základ a na všech počítačích se snažit instalovat software do tohoto adresáře. Tento problém je však velice individuální, každému vyhovuje něco jiného.

SESTAVY

Seznam vzorů

seznam názvů vzorů software.

Seznam vzorů (+seznam souborů)

seznam názvů vzorů software i s jednotlivými soubory.


Zpracovani Sw-scanu - uprava adresare

Scan SW – úprava adresáře

Tento formulář slouží k úpravě adresáře zvoleného vzoru software. Pokud se vzor software skládá z několika různých adresářů, změna se provede pouze pro ten adresář, na kterém stál kursor před spuštěním. Takže je nutné projít celý vzor a jednotlivé různé adresáře postupně upravit.

Adresář umístění souborů není při zpracování směrodatný. Používá se pouze pro odhad a pravděpodobné stanovení ve vzorech. Obecně lze říci, že je jedno, jaký ten adresář je. Pro přesnější přiřazení ke vzoru je výhodné, aby tento adresář byl shodný s nascanovanými soubory. Což však je problém, protože na každém počítači to může být jiné. Výhodné je vzít adresář ze vzoru jako základ a na všech počítačích se snažit instalovat software do tohoto adresáře. Tento problém je však velice individuální, každému vyhovuje něco jiného.


Zpracovani Sw-scanu - sdilene soubory

Scan SW – sdílené soubory

Aktualizace sdílených souborů znamená, že program prochází celou databázi vzorů SW a hledá soubory, které jsou shodné v položkách Název, Velikost a Verze z hlavičky souboru. Tyto soubory hledá v jakémkoliv vzoru SW. Pokud takové soubory najde, znamená to, že jsou tyto soubory sdílené ve více aplikacích a při zpracování se k nim přistupuje odlišně.

Tuto operaci má význam provádět pouze tehdy, když jste do databáze vzorů zavedli nové soubory a je nutné pro přesnější zpracování textových souborů označit sdílené soubory. Není nutné provádět při zavedení malého počtu souborů nebo souborů, o kterých víte, že se vyskytují pouze u jednoho vzoru.

Po spuštění se Vás program zeptá, zda chcete provést aktualizaci pouze pro nově zavedené soubory (pamatuje si všechny nově zavedené soubory od poslední aktualizace) nebo pro všechny soubory (prochází celou databázi, tudíž je to časově delší).


Zpracovani Sw-scanu - hromadne vytvoreni licenci

Scan SW – hromadné vytváření licencí

Formulář slouží k hromadnému přiřazení nebo vytvoření nových licencí software z nelegálních instalací, nebo z instalací bez licence. Formulář lze vyvolat z několika míst:

1. Volba Downgrade z karty Nelegální instalace

2. Volba Karta licence z karty Nelegální instalace

3. Volba Downgrade z karty Bez licence

4. Volba Karta licence z karty Bez licence

5. Tlačítko Hrom. licence z formuláře SW-SCAN – zpracování souborů

V závislosti odkud byl daný formulář vyvolán se mění obsah mřížky Seznam instalací. Pokud byl vyvolán podle 1., 2. nebo 5. bodu obsahuje mřížka seznam nelegálních instalací, které se vyskytují na všech PC. Pokud byl vyvolán podle 3. nebo 4. budu obsahuje mřížka seznam instalací bez licence.

Formulář obsahuje následující tří mřížky :

a) Seznam instalací

tato mřížka obsahuje seznam všech nalezených instalací (nelegálních / bez licence) zpracovaných počítačů. Při pohybu kursoru v této mřížce se v pravé mřížce zobrazuje seznam všech počítačů, kde se daná instalace nalezla.

Pokud byl formulář vyvolán podle 1., 2., 3., nebo 4. bodu je pod mřížkou přepínač, který určuje jaký SW se v mřížce zobrazí.

· Vybraný SW - v mřížce se zobrazí pouze SW, který byl označen na kartě ze které byl formulář vyvolán

· Vše - v mřížce se zobrazí seznam všech nalezených instalací (nelegálních / bez licence) zpracovaných počítačů

b) Seznam hardware s aktuálním SW

tato mřížka obsahuje seznam počítačů vybrané nelegální instalace z levé mřížky. V prvním sloupci lze označit počítače, na které chcete přiřadit licenci ze spodní mřížky.

Pokud byl formulář vyvolán podle 1., 2., 3., nebo 4. bodu je pod mřížkou přepínač, který určuje zda se zobrazí pouze aktuální PC, nebo všechna PC.

· Vybraný HW - v mřížce bude pouze jeden počítač, který byl aktuální na kartě ze které byl formulář vyvolán

· Vše - v mřížce se zobrazí seznam všech počítačů které mají nainstalován SW který je aktuální v levé mřížce Seznam instalací

c) Seznam volných licencí software

tato mřížka obsahuje seznam volných licencí software. Její obsah se mění v závislosti na vybraném SW v mřížce Seznam instalací a na poloze přepínače, který je zobrazen pod mřížkou.

· Shodný název+verze - mřížka obsahuje seznam volných licencí SW, které mají shodný název a verzi jako aktuální SW v mřížce Seznam instalací

· Shodný název - mřížka obsahuje seznam volných licencí SW, které mají shodný název (nemusí mít shodnou verzi) jako aktuální SW v mřížce Seznam instalací

· Downgrade - mřížka obsahuje seznam všech licencí (i těch které nejsou volné) SW u kterých je povoleno čerpání jako downgrade

· Vše - mřížka obsahuje seznam všech volných licencí SW

V posledním sloupci Down. mřížky je možnost přímo povolit z licence SW čerpat jako downgrade.

Pomocí pravého tlačítka myši zde můžete provést následující akce :

a) Přiřadit licenci - přiřadí aktuální licenci na všechny vybrané počítače.

b) Přiřadit licenci jako downgrade - přiřadí aktuální licenci na všechny vybrané počítače jako downgrade.

c) Přiřadit k ručně přiřazené licenci jako downgrade - tato volba slouží k přiřazení SW jako downgrade k licenci, která již byla dříve přiřazena ručně.

d) Nová licence FULL - vytvoří novou licenci FULL pro případ, že už máte všechny licence vyčerpané.

e) Nová licence OEM - vytvoří novou licenci OEM a přiřadí ji na jeden předem vybraný počítač.

f) Oprava licence - můžete opravit parametry existující licence.

Pokud licence neexistuje nebo má vyčerpáno počet volných instalací, musíte vytvořit novou licenci. Při vytváření nové licence jste trochu omezeni. Můžete vytvořit pouze FULL nebo OEM licenci, ostatní typy licencí musíte vytvořit v evidenci licencí software.


Zpracovani Sw-scanu - vlastni zpracovani

Scan SW – vlastní zpracování

Tento formulář zpracování má následující karty :

Hardware - provádí se zpracování nascanovaných souborů

Licence - seznam legálních licencí

Nelegální - seznam nelegálních instalací

Bez licence - seznam instalací, které nevyžadují licenci

Nevedené - seznam nepřesností, které nebudou vstupovat do sestav

Neurčené - seznam neurčených souborů (nenalezených v databázi vzorů SW).

Porovnání - porovnání výsledků proti uloženému čistému stavu

Registry - výpis instalací z registrů

Zrušené - seznam souborů označených ke zrušení

Archiv - seznam souborů v archivních adresářích, které se nezpracovávají

Přípony - seznam souborů jiných přípon než EXE a COM

Konfig. - nastavení konfigurace zpracování

Dočasné - seznam dočasných vzorů pro multilicence programu Správce


Zpracovani Sw-scanu - hardware

Scan SW – hardware

Tato karta obsahuje mřížku, ve které je seznam všech evidovaných počítačů. Řádky označené červeným písmem jsou počítače, které je nutné zpracovat. Jsou to buď počítače, jejichž SWT soubory ještě nikdy nebyly zpracovány nebo jsou to počítače, jejichž SWT soubory mají datum novější než datum posledního zpracování. Modré řádky určují počítače u kterých se změnil počet software proti předchozímu zpracování.

VÝZNAM POLOŽEK MŘÍŽKY

Číslo HW - evidenční číslo počítače

Název PC - jméno počítače z Windows

Odp. osoba - jméno odpovědné osoby – lze si vybrat osobu z číselníku odpovědných osob

Typ PC - název procesoru počítače

Datum SWT - datum nascanování SWT souboru

SWT - počet SWT souborů. Pokud je 0, počítač nemá nascanovaný soubor.

Zprac. - datum posledního zpracování

Neurč. - počet neurčených souborů po zpracování

Neleg. - počet nelegálních instalací

Licen. - počet legálních licencí v SOFTWARE.

Bez lic. - počet nalezených instalací software druhu Freeware, Instalace a Ovladače

VÝBĚR KE ZPRACOVÁNÍ

v prvním sloupci této mřížky musíte označit jednotlivé počítače, které chcete zpracovat. Stiskem myši můžete vybrat jednotlivé počítače ke zpracování.

FILTR

tyto parametry umožňují nastavením na hodnotu ANO zobrazit pouze ty počítače, které splňují uvedenou podmínku.

KONEC

stiskem tlačítka KONEC ukončíte zpracování SWT souborů. Pokud máte na kartě Zrušené označeny nějaké soubory pro automatické smazání, musíte se před ukončení formuláře zpracování přepnout na kartu Zrušené a stiskem tlačítka Smazat pod spodní mřížkou vygenerovat soubory *.DEL.

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

Umožňují provést některé základní operace :

ZPRACOVAT

Postup zpracování

a) nezpracovávejte poprvé najednou všechny soubory. Zpracujte nejprve 5-10 souborů, doplňte neurčené soubory do vzorů, zaktualizujte sdílené soubory a teprve potom spusťte zpracování dalších počítačů.

b) před vlastním zpracováním SWT souborů se nejprve seznamte s kartou Konfigurace, kde najdete parametry ovlivňující vlastní zpracování.

c) na začátku zpracování jsou nejprve vyřazeny soubory, které se nemusí zpracovat. Jedná se o soubory, které negativně ovlivňují výsledky zpracování a v podstatě se nejedná o nelegální instalace. Může se jednat o soubory, které :

  • přijdou smazat (např. adresáře \TEMP, \TMP)
  • jsou uloženy v archivních a pomocných adresářích (např. \INSTALL, \ARCHIV)
  • jsou smazány a uloženy v koši (\RECYCLED, …)

Vyřazení souborů nastavujete na kartě Konfigurace.

d) potom se vyřadí ze zpracování speciální vzor SW nazvaný "- Nezpracovávané soubory ". Jedná se o soubory, které se vyskytují ve více instalacích software a při zpracování dělají problémy (většinou jsou to soubory operačního systému Windows). Pokud se totiž tyto soubory do počítače dostanou ze SW, který není ve vzorech uveden, mohou při zpracování zobrazit software, který vůbec nikdy na počítači nebyl. Tyto soubory nejsou důležitými pro určování instalace software. Jedná se např. o soubory : SETVER.EXE, ODBCCAD32.EXE, REGSVR32.EXE, CLICONF.EXE, ODCCONF.EXE (standardně označené autorskou firmou). Rozpoznání těchto souborů vyžaduje určitou praxi při vytváření vzorů. Tyto soubory se před zpracováním přesunou na kartu Nevedené.

e) dále se zpracuje software, který má nastaven druh I – Instalace a O – Ovladače. Tento software se umístí na kartu Bez Licence.

f) nakonec se zpracují všechny zbylé soubory z nascanovaného SWT souboru. Postupně se procházejí jednotlivé soubory z nascanovaného SWT souboru a porovnávají se s databází ostrých vzorů (v případě multilicence programu SPRÁVCE i s databází dočasných vzorů). Pokud se soubor v žádné databázi vzorů nenalezne, zůstane na kartě Neurčené k případné pozdější analýze. Pokud se soubor v databázi nalezne, vytvoří se na kartách Nelegální nebo Bez licence instalace tohoto software. Rozhodnutí, na kterou kartu se instalace vytvoří, je dáno druhem software, který se nastavuje v číselníku názvů software :

· Pokud se jedná o Freeware, Instalace, Ovladače a HW utility, pak se instalace vytvářejí na kartu Bez licence (nejedná se o nelegální sw a není nutno takovému sw vytvářet licenci v souboru Software).

· Pokud se jedná o Licenční, Aplikační, Shareware a Vlastní, pak se instalace vytvářejí na kartu Nelegální, na které zůstanou do té doby, dokud se jim nevytvoří licence v souboru Software.

Je-li nelegální software označen jako SW balík (např. MS Office 2000), pokusí se program zjistit jeho název. Při zpracování program nejprve zjistí např. instalaci Microsoft Office 2000. Podle softwarových balíků a výpisu z registrů se pokusí zjistit typ balíku (např. Standard). Pokud se mu to povede, zapíše do názvu balíku jeho skutečný název (MS Office 2000 Standard). Pokud se mu to nepovede, vyhledá v registrech názvy samostatných modulů a do názvu balíku zapíše názvy nainstalovaných modulů (MS Word 2000, MS Excel 2000).

g) pokud máte v Konfiguraci nastavený parametr Provádět porovnání při zpracování, tak se na konci zpracování porovná nový stav s uloženým čistým stavem a na kartě Porovnání se zobrazí rozdíly proti čistému stavu.

h) pokud máte v Konfiguraci nastavený parametr Automatické odřazování licencí při zpracování, tak se při zpracování automaticky odřadí všechny nenalezené licence.

Postup po zpracování

1. prohlédnout kartu Bez licence – software nevyžaduje licenci, takže stačí opravdu pouhá kontrola.

2. zpracovat kartu Nelegální – vytvořit licence, smazat nelegální instalace, převést nepřesnosti (zbytky) na kartu Nevedené apod.

3. zpracovat Neurčené soubory

APLIKOVAT ŠABLONU

Volba aplikovat šablonu slouží k přiřazení licencí software na vybrané počítače. Seznam licencí, které se budou přiřazovat je dán vybranou šablonou. Šablony se tvoří ze vzorových počítačů na kartě Licence.

SESTAVY

SW-SCAN - licence SW

seznam vytvořených licencí v souboru SOFTWARE.

SW-SCAN - licence SW (soubory)

seznam vytvořených licencí v souboru SOFTWARE (soubory).

SW-SCAN - nelegální SW

seznam nalezeného nelegálního software.

SW-SCAN - nelegální SW (soubory)

seznam nalezeného nelegálního software (soubory).

SW-SCAN - bez licence SW

seznam nalezeného software, který nemá licenci.

SW-SCAN - bez licence SW (soubory)

seznam nalezeného software, který nemá licenci (soubory).

SW-SCAN - nevedený SW

seznam neevidovaných instalací SW.

SW-SCAN - nevedený SW (soubory)

seznam neevidovaných instalací SW (soubory).

SW-SCAN - neurčené soubory

seznam všech neurčených (nepřiřazených) souborů.

SW-SCAN - porovnání SW

porovnání instalací Nelegálních, Licencí a Bez Licencí proti minulému zpracování.

SW-SCAN - porovnání SW (soubory)

porovnání Neurčených souborů proti minulému zpracování.

SW-SCAN – čistý stav (SW)

uložený čistý stav instalací

SW-SCAN – čistý stav (soubory)

uložený čistý stav souborů

SW-SCAN - SW z registrů

seznam software, který je evidován v registrech.

SW-SCAN - SW ke zrušení

seznam neurčených souborů ke zrušení.

SW-SCAN – ostatní přípony

seznam nascanovaných přípon (jiné než EXE a COM) a jejich celkové počty.

SW-SCAN - ostatní přípony (soubory)

seznam nascanovaných přípon (jiné než EXE a COM) a seznam všech souborů jednotlivých přípon.

SW-SCAN - SW v archivu

seznam souborů na kartě Archiv.

SW-SCAN - dočasný SW

seznam dočasných vzorů (pouze pro multilicence).

SW-SCAN - dočasný SW (soubory)

seznam dočasných vzorů (soubory) -pouze pro multilicence.


Zpracovani Sw-scanu - licence SW

Scan SW – Licence SW

Na této kartě naleznete software, který je legálně nainstalovaný, který má vytvořenou licenci v souboru SOFTWARE a který má tuto licence přiřazenou k počítači. Licence zobrazené na této kartě jsou odlišeny :

a) licence bez tečky jsou licence nalezené pomocí scanu SW a přiřazené v jeho zpracování.

b) licence s modrou tečkou jsou licence přiřazené ručně v evidenci hardware nebo evidenci licencí software.

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

SW balík

pokud nalezený software má v číselníku názvů software označeno, že se jedná o SW balík (např. MS OFFICE), pak se při zpracování SWT souboru program pokusí zjistit název SW balíku. Jestliže je tento název nepřesný nebo zcela chybí, lze spustit formulář Změna názvu softwarového balíku, pomocí kterého lze provést jeho opravu.

Soubory

slouží k pouhému zobrazení seznamu souborů a k úpravě vzoru (k přeřazení souboru z jednoho vzoru do druhého).

Vzory SW

tato volba vyvolá formulář Výpis vzorů - zobrazí seznam všech souborů vybraného vzoru SW. Na tomto formuláři můžete ve sloupci Hlavní soubor označit hlavní soubory aplikace.

Detail SW

pomocí tohoto tlačítka si můžete prohlédnout nebo opravit detailní informace aktuální licence.

Karta Licence – všechna PC

po zpracování SWT souborů je software obvykle zařazen na kartě Nelegální (pokud nebyl přeřazen jinam). Pokud jste provedli přiřazení multilicence alespoň na jeden počítač a chcete přiřadit tuto multilicenci na více PC, nemusíte to dělat pro každé PC zvlášť. Lze to provést hromadně touto volbou. Volbu lze spustit pouze :

· pokud je aktuální licence multilicencí

· má multilicence alespoň jednu licenci volnou nebo má povoleno čerpání licencí do záporna.

Po jejím spuštění se spustí formulář pro Hromadné přiřazování licencí.

Odřadit licenci

slouží k odřazení licencí.

Nová licence

Spustí se formulář, ve kterém vytvoříte novou licenci SW a po jeho uložení následuje dotaz, zda tuto novou licenci hned přiřadit na aktuální počítač.

Volné licence

přiřazení volných licencí.

Vytvořit šablonu

Z aktuálně přiřazených multilicencí se vytvoří šablona, kterou je pak možné aplikovat na ostatní počítače. Pro vytvoření šablony se dají použít pouze MULTILICENCE!


Zpracovani Sw-scanu - hromadne prirazeni licence

Scan Sw – hromadné přiřazení licence

Mřížka zobrazuje seznam počítačů, které mají po zpracování TXT souborů na kartě Nelegální software stejného názvu a verze jako je vybraná multilicence (její název je nad mřížkou). Je to pro případ, že potřebujete hromadně přiřadit multilicenci na všechny počítače, kde je nainstalovaná a nechcete procházet všechny počítače a hledat ji.

Přiřazení multilicence můžete samozřejmě provést jen na některé počítače. Proto musíte nejprve v prvním sloupci označit všechny počítače, na které chcete multilicenci přiřadit. Stiskem pravého tlačítka myši a spuštěním volby Přiřadit provedete hromadné přiřazení multilicence na vybrané počítače. Program projde všechny označené počítače a Nelegální instalace přiřadí na danou multilicenci.


Zpracovani Sw-scanu - nelegalni instalace

Scanu SW – Nelegální instalace

Tato karta obsahuje seznam nalezených instalací software (zatím označených jako nelegální) aktuálního počítače. V předposledních sloupcích mřížky se nachází počet souborů tvořící instalaci software na tomto počítači a počet souborů v úplné instalaci (počet souborů ze vzorů). Software na této kartě je pro přehlednost barevně rozlišen podle položky Druh z číselníku názvů software :

plná instalace Licenčního, Aplikačního a Vlastního SW = bílá barva

neúplná instalace předchozích druhů = modrá barva

Shareware = červená barva

Zjištěný aktuální operační systém v době scanování = tučné černé písmo

Hlavním úkolem na této kartě je kompletně ji vyčistit. Tato karta by měla být prázdná. Takže musíte postupovat po jednotlivých instalacích a provést s nimi některou z následujících operací :

· Vytvořit licenci - pro instalace, které jsou na počítači legálně nainstalované

· Vytvořit novou verzi - pro instalace, které jsou na počítači legálně nainstalované (ale při zpracování se našly pouze zbytky souborů předchozí verze).

· Smazat instalaci - pro instalace, které jsou na počítači nelegálně (soubory lze odstranit pouhým smazáním)

· Odinstalovat instalaci - pro instalace, které jsou na počítači nelegálně (soubory lze odstranit pouze plnou odinstalací)

· Přesun na kartu nevedené - pro instalace, které nelze smazat a nelze pro ně vytvořit licence (zbytky, nepřesnosti, neúplné)

K těmto operacím použijte tlačítka a menu na pravé tlačítko myši, jejichž popis následuje dále.

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

DownGrade

touto volbou lze pro vybrané instalace software vytvořit licence. Tyto licence nebudou čerpány přímo z licencí stejného názvu a verze, ale budou čerpány jako tzv. Downgrade. Po aktivaci se spustí formulář Hromadné vytváření licencí, pomocí kterého lze Downgrade licence vytvořit. Po vytvoření downgrade se nelegální instalace software přesune na kartu Licence, kde v názvu a verzi software je vybraná licence Downgrade. Původně nalezená instalace je uložena v položkách DG, které jsou na konci mřížky.

SW balík

pokud nalezený software má v číselníku názvů software označeno, že se jedná o SW balík (např. MS OFFICE), pak se při zpracování SWT souboru program pokusí zjistit název SW balíku. Jestliže je tento název nepřesný nebo zcela chybí, lze touto volbou spustit formulář Změna názvu softwarového balíku, pomocí kterého lze provést jeho opravu.

Soubory

pokud budete chtít vyjmout soubor z nalezeného software, například pokud patří k jiné verzi software, stiskněte volbu Soubory. Zobrazí se seznam souborů v mřížce, ze které vyberete vyjímaný soubor a po spuštění volby Přeřadit vyberete vzor software, ke kterému soubor patří a soubor přiřadíte. Po přiřazení si můžete vybrat, zda soubor v původní instalaci zrušíte nebo ho tam ponecháte. Pokud soubor zrušíte a v instalaci nezůstane žádný soubor, tato instalace se z počítače odřadí. Tato změna se provádí pouze na aktuálním počítači. Volbou Karta Zrušené lze označené soubory přesunout na kartu Zrušené.

Vzory SW

tato volba vyvolá formulář Výpis vzorů, který zobrazí seznam všech souborů vybraného vzoru. Na tomto formuláři můžete ve sloupci Hlavní soubor označit hlavní soubory aplikace.

Vytvoření nové verze SW

tato volba vyvolá formulář Vytvoření nové verze, který umožní z aktuální verze vytvořit verzi novou. Používá se v případě, že se na kartě Nelegální objeví zbytky staré verze a potřebujte z nich vytvořit verzi novou. Většinou se bude jednat o neúplné instalace označené modrou barvou.

Karta Licence

nejdůležitější volba. Pomocí ní lze z nelegální instalace vytvořit legální licenci. Po aktivaci této volby se spustí formulář Hromadné vytváření licencí, na kterém lze provést přiřazení.

Po přiřazení licence program smaže nelegální instalaci na kartě Nelegální a zobrazí legální licenci na kartě Licence.

Karta Bez licence

tato volba slouží pro přesun nalezené nelegální instalace na kartu Bez licence. Jedná se o výjimečný případ, kdy chcete nalezenou instalaci opravdu přesunout na kartu Bez licence (nevyžaduje vytvoření licence v souboru licencí software). Pokud se Vám na kartu Nelegální dostane software, který tam nepatří, zkontrolujte nejprve nastavený druh SW (volba Bilance software). Podle tohoto druhu se nastavují instalace na kartu Nelegální nebo na kartu Bez licence.

Karta Nevedené

označený software lze přesunout na kartu Nevedené, která obsahuje instalace, které se nebudou objevovat v programu SPRÁVCE. Jedná se o instalace, které mohou vzniknout v důsledku nepřesných vzorů software, zbytkových instalací, nemožností přesného určení mateřské instalace, špatné odinstalace apod.

Karta Nevedené – všechna PC

označený software lze přesunout na kartu Nevedené a to najednou pro všechny zpracované počítače. Program projde všechny zpracované nascanované soubory a pokud na nich nalezne označený software, automaticky ho na všech počítačích převede na kartu Nevedené.

Karta Zrušené

touto volbou lze všechny soubory označeného software přesunout na kartu Zrušené. Slouží pro výjimečný případ, kdy chcete celou nalezenou instalaci smazat (lze použít pouze pro DOS programy nebo jednoduché Windows programy, které nezapisují do registrů a nemají další doprovodné soubory).


Zpracovani Sw-scanu - vyber SW baliku

Scan SW – výběr SW balíku

Program umí zjistit název některých SW balíků (např. MS Office, Norton SystemWorks). Pokud se náhodou název balíku určí špatně, dá se opravit. Musíte spustit tento formulář, který slouží k opravě názvu SW balíku.

Nejdříve musíte vybrat vlevo nahoře Typ instalace, která určuje, zda se jedná o balík nebo pouze o modul :

· Pokud vyberete Balík, pak jako novou hodnotu můžete vybrat název ze seznamu názvů balíků (např. Professional apod.).

· Pokud vyberete Modul, pak jako novou hodnotu můžete vybrat název ze seznamu názvů modulů (např. MS Word apod.).

Stiskem tlačítka Vybrat provedete výběr požadovaného názvu. Pokud se jedná o balík, můžete vybrat jen jeden název. Pokud se jedná o moduly, můžete vybrat několik modulů.

Stiskem tlačítka Vymazat se vymaže Aktuální název balíku.

Po výběru nového názvu nebo jeho vymazání se aktualizuje položka Aktuální název balíku (viz. obrázek), neprovede se však jeho změna.

Skutečná oprava názvu SW balíku se provede až po stisku tlačítka OK !!!


Zpracovani Sw-scanu - vypis souboru nalezene instalace

Scan SW – výpis souborů nalezené instalace

Tento formulář obsahuje výpis všech souborů dané instalace software. Standardně jsou zobrazeny pouze nesdílené soubory. Zobrazení všech souborů je možné změnit pomocí přepínače, který je umístěn pod mřížkou. Z tohoto formuláře lze soubory, které označíte v prvním sloupci mřížky, převést k jinému vzoru,

nebo na kartu Zruš. Převod se provádí pomocí menu, které se vyvolá stiskem pravého tlačítka myši nad mřížkou.

Po úspěšném převedení budete dotázáni, zda chcete převedené soubory vyřadit z instalace, ze které jste převod prováděli.

· Pokud Ano, soubory se z původní instalace smažou.

· Pokud Ne, soubory v instalaci zůstanou.

Pokud vyřadíte všechny soubory z původní instalace (Nelegální nebo Bez licence), bude celá instalace zrušena. Pokud vyřadíte všechny soubory z Licence, zůstane licence k PC přiřazena (dokud neprovedete nové zpracování).


Zpracovani Sw-scanu - vypis vzoru SW

Scan SW – výpis vzoru

Tento formulář obsahuje výpis všech souborů daného vzoru. Slouží pouze k nahlédnutí do seznamu souborů a k určení hlavního souboru.

Hlavní soubor

soubor, který spouští celou aplikaci. Pokud má vzor více souborů, které jsou na stejné úrovni, lze je označit všechny. Toto označení má pouze informativní charakter a slouží na kartě nalezeného software k barevnému rozlišení celých a částečných instalací. Hlavním souborem může být označeno několik souborů.

Sdílen

tato položka označuje, že soubor je sdílen více vzory. Tento parametr nemáte možnost změnit ručně!!! Mění se automaticky při spuštění tlačítka Akt. sdílené.


Zpracovani Sw-scanu - nova verze SW

Scan SW – Nová verze SW

Na formuláři jsou zobrazeny dvě mřížky :

· horní mřížka obsahuje seznam souborů vybrané nelegální instalace

· spodní mřížka obsahuje seznam všech neurčených souborů.

Tento formulář použijte v případě, že na kartě nelegální naleznete např. software Adobe PhotoShop 6.0. Tato instalace bude modrá (neúplná) a bude ji chybět hlavní modul. Budete vědět, že na daném počítači se nachází nová verze 7.0. Hlavní modul, případně další nové soubory najdete na kartě Neurčené. Aby jste nemuseli prohledávat více karet a přepínat se mezi nimi (než najdete všechny potřebné soubory), lze spustit tento formulář.

Vytvoření nové verze provedete tak, že v horní mřížce označíte soubory, které používá nová verze (mohou to být všechny nebo jen část). V dolní mřížce potom označíte soubory, které jsou jedinečné pro novou verzi. Většinou je naleznete a adresáři podobného jména.

Pokud máte v obou mřížkách označeny všechny potřebné soubory, lze stiskem tlačítka Nová verze, vytvořit novou verzi software.


Zpracovani Sw-scanu - presun souboru ke zruseni

Scan SW - přesun souborů ke zrušení

Tento formulář slouží k rozhodnutí, jakým způsobem se mají označené soubory zrušit. Na kartě Zrušené jsou dvě mřížky, které obsahují soubory k ručnímu odinstalování nebo k automatickému smazání.

Na tomto formuláři máte následující možnosti :

Ručně

označené soubory se přesunou do horní mřížky karty Zrušené. Tyto soubory jsou určeny pro ruční odinstalování. Musíte fyzicky dojít k danému počítači a spustit odinstalaci daného programu. Takto lze odinstalovat programy, které zapisují do registru. Před vlastní odinstalací lze vytisknout sestavu, aby jste nezapomněli odinstalovat všechny potřebné programy.

Automaticky

označené soubory se přesunou do spodní mřížky karty Zrušené. Tyto soubory jsou určeny pro automatické smazání při následujícím scanování. Scanovací modul ScanWinS při následujícím spuštění nejprve smaže soubory označené ke zrušení a teprve pak provede vlastní scanování.

Zpět

program se vrátí zpět a označené soubory zůstanou na původním místě.


Zpracovani Sw-scanu - bez licence

Scan SW – Bez licence

Tato karta obsahuje po zpracování mřížku s nalezenými instalacemi software typu Bez licence. Jedná se o software druhu Freeware, Instalace, Ovladače a HW utility, který se nastavuje v číselníku názvů software v položce Druh. Tento software lze mít na počítači nainstalován bez nutnosti mít k tomu licenci. Proto většinou s touto kartou po zpracování není velká práce. Stačí si jen prohlédnout, zda to odpovídá skutečnosti.

Pro snadnější přehled jsou jednotlivé druhy barevně rozlišeny :

freeware = žlutá barva

ovladače = světle modrá barva

instalace = růžová barva

hw utility = zelená barva

Pokud při přeřazování z karty Nelegální byl některý software přeřazen na kartu Bez licence, mohou se na této kartě objevit i následující druhy software :

plná instalace Licenčního, Aplikačního a Vlastního SW = bílá barva

neúplná instalace předchozích typů = fialová barva

Shareware = červená barva

Pokud byl počítač již zpracován a zpracuje se znovu, zůstane software přiřazený na kartu Bez licence i nadále na této kartě (pokud se při zpracování opět najde).

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

DownGrade

touto volbou lze pro vybrané instalace software vytvořit licence. Tyto licence nebudou čerpány přímo z licencí stejného názvu a verze, ale budou čerpány jako tzv. Downgrade. Po aktivaci se spustí formulář Hromadné vytváření licencí, pomocí kterého lze downgrade licence vytvořit. Po vytvoření downgrade se nelegální instalace software přesune na kartu Licence, kde v názvu a verzi software je vybraná licence Downgrade. Původně nalezená instalace je uložena v položkách DG, které jsou na konci mřížky.

SW balík

pokud nalezený software má v číselníku názvů software označeno, že se jedná o SW balík (např. MS OFFICE), pak se při zpracování SWT souboru program pokusí zjistit název SW balíku. Jestliže je tento název nepřesný nebo zcela chybí, lze touto volbou spustit formulář Změna názvu softwarového balíku, pomocí kterého lze provést jeho opravu.

Soubory

pokud budete chtít vyjmout soubor z nalezeného software, například pokud patří k jiné verzi software, stiskněte volbu Soubory. Zobrazí se seznam souborů v mřížce, ze které vyberete vyjímaný soubor a po spuštění volby Přeřadit vyberete vzor software, ke kterému soubor patří a soubor přiřadíte. Po přiřazení si můžete vybrat, zda soubor v původní instalaci zrušíte nebo ho tam ponecháte. Pokud soubor zrušíte a v instalaci nezůstane žádný soubor, tato instalace se z počítače odřadí. Tato změna se provádí pouze na aktuálním počítači. Volbou Karta Zrušené lze označené soubory přesunout na kartu Zrušené.

Vzory SW

tato volba vyvolá formulář Výpis vzorů, který zobrazí seznam všech souborů vybraného vzoru. Na tomto formuláři můžete ve sloupci Hlavní soubor označit hlavní soubory aplikace.

Karta Licence

nejdůležitější volba. Pomocí ní lze z nelegální instalace vytvořit legální licenci. Po aktivaci této volby se spustí formulář Hromadné vytváření licencí, na kterém lze provést přiřazení.

Po přiřazení licence program smaže nelegální instalaci na kartě Nelegální a zobrazí legální licenci na kartě Licence.

Karta Nevedené

označený software lze přesunout na kartu Nevedené, která obsahuje instalace, které se nebudou objevovat v programu SPRÁVCE. Jedná se o instalace, které mohou vzniknout v důsledku nepřesných vzorů software, zbytkových instalací, nemožností přesného určení mateřské instalace, špatné odinstalace apod.


Zpracovani Sw-scanu - nevedene instalace

Scan SW – Nevedené instalace

Tato karta obsahuje software, který nechcete zapsat a evidovat v programu SPRÁVCE. Jedná se především o instalace, které mohou vzniknout v důsledku nepřesných vzorů software, zbytkových instalací, nemožnosti přesného určení mateřského programu apod.

Tuto kartu by jste měli používat pouze k vyčištění karet Nelegální a Bez licence od zbytkových a nepřesně nalezených instalací. Neměli by jste ji používat pro schování nelegální instalace.

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

SW balík

pokud nalezený software má v číselníku názvů software označeno, že se jedná o SW balík (např. MS OFFICE), pak se při zpracování SWT souboru program pokusí zjistit název SW balíku. Jestliže je tento název nepřesný nebo zcela chybí, lze touto volbou spustit formulář Změna názvu softwarového balíku, pomocí kterého lze provést jeho opravu.

Soubory

pokud budete chtít vyjmout soubor z nalezeného software, například pokud patří k jiné verzi software, stiskněte volbu Soubory. Zobrazí se seznam souborů v mřížce, ze které vyberete vyjímaný soubor a po spuštění volby Přeřadit vyberete vzor software, ke kterému soubor patří a soubor přiřadíte. Po přiřazení si můžete vybrat, zda soubor v původní instalaci zrušíte nebo ho tam ponecháte. Pokud soubor zrušíte a v instalaci nezůstane žádný soubor, tato instalace se z počítače odřadí. Tato změna se provádí pouze na aktuálním počítači. Volbou Karta Zrušené lze označené soubory přesunout na kartu Zrušené.

Vzory SW

tato volba vyvolá formulář Výpis vzorů, který zobrazí seznam všech souborů vybraného vzoru. Na tomto formuláři můžete ve sloupci Hlavní soubor označit hlavní soubory aplikace.

Karta Nelegální a Bez licence

nevedený software lze vrátit zpět na karty Nelegální nebo Bez licence.


Zpracovani Sw-scanu - neurcene soubory

Scan SW – Neurčené soubory

Tato karta obsahuje mřížku se seznamem Neurčených souborů, tj. souborů, které se nenašly při zpracování ve vzorech SW. Tyto soubory lze rozdělit na dva druhy :

1) soubory s bílým podkladem – jedná se o soubory, jejichž jméno se nevyskytuje v žádném vzoru SW. Tyto soubory lze zařadit do existujících vzorů nebo do nového vzoru bez zkoumání, kde všude se již tento soubor vyskytuje. Podle názvu adresáře, ve kterém se nacházejí a podle údajů z hlavičky exe souboru lze odhadnout, jak se jmenuje jejich aplikace. Lze také nahlédnout na kartu Registry, kde je seznam aplikací, které při instalaci zapisují svůj název do registrů.

2) soubory s fialovým podkladem, jsou soubory, které se podle názvu nacházejí již v nějakém vzoru SW, ale neodpovídá jejich velikost nebo verze v hlavičce souboru. Seznam vzorů SW, ve kterých se tyto soubory nacházejí, je zobrazen ve spodní mřížce.

Při analýze neurčených souborů si musíte dobře prohlédnout spodní mřížku, a to hlavně poslední tři sloupce. Tyto sloupce obsahují datum souboru, jeho velikost a verzi uvedenou v hlavičce souboru. Podle těchto údajů se dá odhadnout, kam neurčený soubor asi patří. Soubor je jednoznačně identifikován svým jménem a položkami Velikost a Verze (z hlavičky exe souboru). Datum souboru není podstatný, dá se podle něj pouze rozhodnout, zda v tomto období mohla tato aplikace vůbec existovat. Rozhodující tedy je Velikost a Verze. Pokud má neurčený soubor některý z těchto dvou údajů jiný než ve vorech, je ve spodní mřížce tento údaj zobrazen modrým podkladem.

VÝBĚR SOUBORŮ PRO NOVÝ VZOR

v prvním sloupci mřížky můžete označit soubory, které chcete vybrat pro přiřazení ke vzoru nebo k označení ke zrušení. Levým tlačítkem myši označíte jeden aktuální soubor. Pravým tlačítkem myši lze označit celý adresář.

A) FUNKCE NA TLAČÍTKÁCH :

v dolní části formuláře jsou Standardní tlačítka, která lze vyvolat z libovolné karty.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

umožňuje provést některé základní operace. Menu je závislé na tom, ve které mřížce formuláře ho aktivujete :

· horní mřížka – seznam neurčených souborů

· dolní mřížka – seznam vzorů SW, ve kterých se vyskytuje vybraný soubor z horní mřížky.

Přiřaď SW

tato volba funguje pouze v horní mřížce. Nejprve musíte horní mřížce označit soubory, které chcete přiřadit do vzoru. Po aktivaci se zobrazí formulář Seznam vzorů se seznamem vzorů z číselníku software. Tento formulář zobrazuje na 1.kartě seznam všech vzorů (tj. číselník názvů software). Na 2.kartě je seznam použitých vzorů (tj. vzorů, které jste během zpracování již použili a existuje předpoklad, že se k nim budete ještě vracet). Na tomto formuláři provedete výběr požadovaného software nebo vytvoříte nový software.

Karta Zrušené

tímto převedete označené soubory na kartu Zrušené, která obsahuje soubory navržené k ruční odinstalaci nebo k automatickému zrušení při následujícím scanování. Proto po aktivaci této volby následuje dotaz, zda vybrané soubory přijdou zrušit Ručně nebo Automaticky.

Vzory SW

touto volbou vyvoláte formulář, který umožňuje prohlédnout seznam všech vzorů SW.

Přiřaď k odhadu

tato volba funguje pouze ve spodní mřížce. Umožňuje přiřadit označené soubory z horní mřížky do vzoru SW, na kterém stojí kursor v dolní mřížce. Tento způsob je rychlejší pro přidávání jednotlivých souborů do již existujícího vzoru. Odpadne tím nutnost hledat správný název vzoru, ke kterému chcete soubory přiřadit.

Přiřaď k odhadu + označení hl. souboru

tato volba funguje pouze ve spodní mřížce. Funguje stejně jako v předchozím bodě, navíc umožňuje po přidání souboru označit hlavní soubory.


Zpracovani Sw-scanu - prirazení souboru ke vzoru SW

Scan SW – přiřazení souborů ke vzoru

Tento formulář zobrazuje seznam všech vzorů tj. číselník názvů software. Na 1. kartě Všechny vzory je seznam, který obsahuje kompletní číselník. Na 2. kartě Použité vzory je seznam pouze použitých vzorů (tj. vzorů, ke kterým byl přidán nějaký soubor od posledního vyčištění).

Obsah obou karet lze ovlivnit nastavením filtru podle druhu software :

FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

Umožňuje provést některé základní operace :

PŘIŘADIT

provedete pouze přiřazení označených souborů do zvoleného vzoru, neprovádí se označení hlavního souboru. Použijete v případě, že přidáváte do vzoru soubory, u kterých víte, že nejsou hlavní a nepotřebujete je označovat. Pokud je program SPRÁVCE zakoupen jako multilicence a máte zablokovanou aktualizaci číselníku názvů software, nemůžete neurčené soubory přiřadit přímo do centrálních vzorů, ale do tzv. Dočasných.

PŘIŘADIT + označení hl. souboru

provedete přiřazení označených souborů do zvoleného vzoru a zároveň označení hlavních souborů. Použijete v případě, že mezi označenými soubory je i hlavní soubor aplikace a potřebujete ho označit. Pokud je program SPRÁVCE zakoupen jako multilicence a máte zablokovanou aktualizaci číselníku názvů software, nemůžete neurčené soubory přiřadit přímo do centrálních vzorů, ale do tzv. Dočasných.

NOVÝ SW

slouží k vytvoření nového názvu vzoru. Všechny položky budou prázdné a musíte je vyplnit.

OPRAVA SW

tímto můžete opravit údaje jakéhokoliv vzoru (číslo verze, výrobce apod.).

DUPLIKACE SW

můžete vytvořit nový vzor se stejnými hodnotami všech položek. To je vhodné zejména pro novou verzi software. Před uložením musíte změnit název nebo verzi, aby nevznikl duplicitní vzor.

VÝPIS VZORU

slouží k detailnímu zobrazení všech souborů vybraného Vzoru. Při tomto zobrazení lze zároveň určit, který soubor je hlavním modulem.


Zpracovani Sw-scanu - porovnani

Scan SW – Porovnání

Tato karta obsahuje porovnání proti uloženému čistému stavu. Obsah je závislý na tom, zda porovnání proběhlo. Pokud neproběhlo, jsou obě mřížky prázdné. Pokud porovnání proběhlo, obsahují mřížky seznam rozdílů :

· horní mřížka obsahuje seznam software (licence, nelegální, bez licence, nevedený) barevně rozlišený. V prvním sloupci označují znaménka -/+, zda soubory přibyly nebo naopak chybí.

· dolní mřížka obsahuje seznam souborů (neurčených, zrušených, archivních, přípon), opět barevně rozlišený.

Porovnání můžete provést dvěma způsoby :

1) zapnutím parametru Provádět porovnání nastaveném v Konfiguraci – tímto provedete porovnání najednou na všech zpracovávaných počítačích. Má to však nevýhodu – zpomaluje to zpracování. Takže nemá cenu tento parametr zapínat, dokud nemáte vyčištěné karty Nelegální, Neurčené apod. a nemáte uložený čistý stav.

2) stiskem tlačítka Porovnat na tomto formuláři – provádí porovnání pouze pro aktuální počítač.

Pomocí tlačítka Uložit aktuální provedete uložení aktuálního stavu všech instalací a souboru do pomocného souboru pro aktuální počítač. Tento čistý stav potom slouží k porovnání nových změn.

Pomocí tlačítka Uložit vše se provede uložení aktuálního stavu na všech počítačích.

Pomocí tlačítka Zobrazit čistý stav spustíte formulář, ve kterém uvidíte uložený čistý stav.


Zpracovani Sw-scanu - registry

Scan SW – Registry

Tato karta obsahuje výpis nainstalovaného software z registrů Windows. Tyto údaje jsou pouze informativní a slouží k nahlédnutí při analýze Neurčených souborů na kartě Neurčené.


Zpracovani Sw-scanu - zrusene soubory

Scan SW – Zrušené soubory

Tato karta obsahuje soubory, které chcete dříve nebo později smazat. Jedná se např. o soubory v adresářích jako jsou \TEMP, \TMP, \RECYCLED. Dále to mohou být soubory nových aktualizací software (jako např. AVG). Taky tam mohou být soubory, které jste nalezli jako nelegální a chcete je smazat.

· Horní mřížka nazvaná Soubory k ruční odinstalaci, obsahuje všechny soubory, které chcete ručně zrušit (odinstalovat). Jedná se o celé (např. nelegální instalace), které nemůžete smazat automaticky. Musíte si vytisknout seznam a přijít k tomuto počítači a provést řádnou odinstalaci (výmaz souborů, výmaz registrů apod.). Soubory se do mřížky dostanou :

a) nastavením speciálních adresářů na kartě Konfigurace.

b) označením souborů nebo celé instalace na ostatních kartách pomocí tlačítka Karta Zrušené. Po jeho stisku se spustí dotaz, jak chcete soubory smazat. Zde musíte odpovědět Ručně.

Jestliže chcete soubory označené k ruční odinstalaci skutečně z daného počítače odinstalovat, je vhodné si vytisknout sestavu SW ke zrušení a na daném počítači se pokusit tyto soubory odinstalovat.

· Spodní mřížka, nazvaná Soubory k automatickému smazání při následujícím scanování, obsahuje seznam souborů, které chcete nechat automaticky smazat při následujícím scanování. Tyto soubory musí být zcela samostatné tak, aby jejich smazáním nezůstaly na počítači nějaké zbytky. Mohou to být např. zpakované aktualizace software, archivy, updaty, samostatné utility (NU, NC) apod. Dále to mohou být DOS programy a hry. Soubory se na tuto mřížku dostanou :

a) soubory z horní mřížky se označí a volbou Smazat automaticky se přesunou do spodní mřížky.

b) označením souborů nebo celé instalace na ostatních kartách pomocí tlačítka Karta Zrušené. Po jeho stisku se spustí dotaz, jak chcete soubory smazat. Zde musíte odpovědět Automaticky.

Na rozdíl od předchozích verzí programu Správce, nejsou soubory pro automatické smazání generovány vždy při ukončení formuláře zpracování. Kvůli zvýšené bezpečnosti zůstávají soubory pouze označeny a vygenerování se musí provést ručně. K tomu slouží tlačítko Smazat.

Stiskem tlačítka Smazat vše na této kartě (pod spodní mřížkou) program projde všechny počítače a pro ty, které mají ve spodní mřížce označeny nějaké soubory k automatickému smazání, vygeneruje soubor, jenž má stejný název jako původní soubor s nascanovanými soubory, pouze má příponu ”DEL”. Stiskem tlačítka Smazat aktuální se vygeneruje DEL soubor pouze pro aktuální PC. Pokud mají scanovací moduly nastaven parametr pro mazaní souborů, pak před vlastním scanováním nejprve projdou soubor s příponou ”DEL” a v něm uvedené soubory smažou. Teprve potom proběhne vlastní scanování. Pokud se nepodaří nějaké soubory smazat (jsou otevřené, Read only, nedostatečná práva), vytvoří se soubor s příponou ”!!!”, v němž je uveden seznam nesmazaných souborů.

A) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI PRO HORNÍ MŘÍŽKU :

Smazat automaticky

přesunete označené soubory z horní mřížky do spodní. Takto přesunuté soubory budou určeny k automatickému smazání.

Karta Neurčené

přesunete označené soubory na kartu Neurčené. Pozor - toto tlačítko přesouvá vždy soubory na kartu Neurčené. Pokud soubory přišly z jiné karty (např. Nelegální, Bez licence apod.) jsou vráceny na kartu Neurčené. Chcete-li je vrátit na původní místo, musíte spustit znovu zpracování SWT souborů.

B) FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI PRO DOLNÍ MŘÍŽKU :

Smazat ručně

přesune označené soubory z dolní mřížky zpět do horní.

Karta Neurčené

přesune označené soubory na kartu Neurčené. Pozor - toto tlačítko také přesouvá vždy soubory na kartu Neurčené.

Smazat ručně – všechna PC

přesune všechny soubory z dolní mřížky zpět do horní, a to na všech počítačích. Je to vhodné pro případ, že máte na více počítačích označené soubory pro automatické smazání a chcete to najednou vrátit na ruční smazání. Aby jste nemuseli pracně hledat, na kterých počítačích jsou tato označené soubory, stačí spustit tuto volbu. Program projde všechny počítače a soubory označené k automatickému smazání přesune k ručnímu smazání.


Zpracovani Sw-scanu - pripony SW

Scan SW – Přípony

Při scanování nainstalovaného software zjišťují scanovací moduly standardně pouze soubory EXE a COM. Databáze softwarových vzorů dodaná autorskou firmou obsahuje také pouze EXE a COM soubory.

V praxi může nastat případ, že můžete potřebovat nascanovat i další přípony. Nejznámější důvody :

1. potřebujete nascanovat vlastní aplikační software (např. FXP, APP, …)

2. potřebujete zjistit výskyt určitých přípon (obrázky, MP3, WAV, …)

3. potřebujete zjistit využitelnost kancelářských balíků (DOC, XLS, …)

Tato karta obsahuje seznam souborů, které byly zjištěny scanovacími moduly a nemají příponu EXE a COM. Vytištěním sestav lze získat celkový přehled za jednotlivé přípony.

FUNKCE V MENU PRAVÉHO TLAČÍTKA MYŠI :

Karta Zrušené

všechny označené soubory lze přesunout na kartu Zrušené, která obsahuje soubory navržené ke zrušení.

Karta Neurčené :

přesunete označené soubory na kartu Neurčené.

Přiřaď SW :

označené soubory zapíšete do vzorů SW. Vytvoříte si tak vlastní vzor i ze souborů ostatních přípon. Takovýto vzor si musíte dále aktualizovat sami, autorská firma bude aktualizovat vzory SW pouze z EXE a COM souborů.


Zpracovani Sw-scanu - archiv

Scan SW – Archiv

Tato karta obsahuje soubory, které jsou uloženy v pomocných, instalačních, archivačních adresářích. Tyto adresáře slouží na počítačích k pomocným účelům (jedná se např. o adresáře \INSTALL, \ARCHIV, \POMOC apod.).

Tyto soubory se do mřížky dostanou nastavením adresářů na kartě Konfigurace. Na začátku zpracování nascanovaného souboru jsou tyto soubory vyloučené ze zpracování. Tímto vyloučením dojde ke zpřesnění celého zpracování.

Karta Archiv by se neměla používat pro schování nelegálních instalací, ale opravdu pouze k vyloučení adresářů, které neovlivní negativně zpracování.


Zpracovani Sw-scanu - konfigurace

Scan SW – konfigurace

Automatické odřazování licencí

tento parametr slouží při zpracování SWT souborů k určení, jak naložit s nenalezenými licencemi. Pokud je nastaven na kladnou hodnotu, pak se nenalezené licence automaticky odřadí. Tím můžete přijít o licence ručně pořízené nebo o historii (upgrade) licencí. Máte-li parametr nastaven na zápornou hodnotu, ponechají se všechny nenalezené licence, pouze se označí modrou barvou. Po zpracování je nutné ručně určit, které přijdou odřadit a které ponechat.

Provádět porovnání

tento parametr ovlivní způsob Zpracování SWT souborů. Pokud je nastaven na kladnou hodnotu, provádí se na konci zpracování porovnání nascanovaného stavu s uloženým čistým stavem. Rozdíl je pak zobrazen na kartě Porovnání. Tento parametr nemá cenu zapínat dříve, než budete mít vyčištěné všechny karty a uložený čístý stav všech počítačů.

Zpracovávat soubory v koši

tento parametr ovlivní způsob Zpracování SWT souborů. Pokud je nastaven na kladnou hodnotu, budou zpracovány i soubory umístěné v koši (adresáře \RECYCLED, \RECYCLERS).

Upgrade SW vzoru – adresář s novými vzory

tento adresář slouží k nastavení cesty k souboru, který obsahuje data s novými vzory software. Určeno pouze pro aktualizace ostrých vzorů stažených z internetu.

Adresář s SWT soubory

tento adresář určuje uložení nascanovaných SWT souborů. Tento parametr je zakázán měnit (soubory jsou již načteny a nelze měnit adresář). Změnu lze provést pouze v menu Údržba – Konfigurace.

Podadresáře pro přesun souborů na kartu Zrušené nebo Archiv

tyto podadresáře slouží k automatickému přesunu souborů na kartu Zrušené nebo kartu Archiv. Při zpracování počítače se tyto adresáře a všechny jejich podadresáře prochází a soubory se přesouvají na uvedenou kartu. To vše se provede na začátku zpracování, takže tyto podadresáře jsou vlastně vyřazeny ze zpracování. U každého podadresáře lze určit, zda se bude brát název adresáře odkudkoliv ve stromové struktuře nebo jen od root adresáře.

Příklad pro adresář \TEMP :

a) pokud bude podadresář označen jako Od rootu, budou přesunuty soubory např. z následujících adresářů :

C:\TEMP

D:\TEMP

Název adresáře musí být přímo v root adresáři (nalevo nesmí být žádný nadřízený adresář).

b) pokud nebude označen jako Od rootu, budou přesunuty soubory např. z následujících adresářů :

C:\WINDOWS\TEMP

D:\POKUS\TEMP

E:\TEMP apod.

Název adresáře může být kdekoliv ve stromové struktuře

Na kartu Zrušené přesuňte soubory jenž chcete zrušit, na kartu Archiv soubory, které tam chcete ponechat (např. archivní, pomocné nebo instalační).

Na počátku podadresáře nesmíte zadávat označení disku !!!

Pokud jednou označené podadresáře pro přesun na karty Zrušené a Archiv zrušíte, budou při následujícím zpracování soubory z těchto karet smazány a vráceny do zpracování.

Tlačítkem Uložit konfiguraci provedete uložení aktuální konfigurace do pomocného souboru. Pokud se konfigurace změní a nebude uložená, vrátí se konfigurace na formuláři do původního stavu.


Zpracovani Sw-scanu - docasne vzory SW

Scan SW – Dočasné vzory SW

Na této kartě se zobrazuje software, který je legálně nainstalovaný, ale nebyl pro něj vytvořen nadřízenou organizací softwarový vzor. V okamžiku, kdy tento softwarový vzor bude nadřízenou organizací dodán, převede se tento software z dočasných vzorů do centrálních.

Tato karta je určena pouze pro multilicence programu SPRÁVCE. V případě, že je z nadřízené organizace zablokována aktualizace číselníku názvů software, není možné ve scanu SW aktualizovat vzory software. Proto existují tzv. dočasné vzory.

Pokud se při scanování naleznou neurčené soubory a Vy je chcete přiřadit, můžete postupovat stejně jako u centrálních vzorů. Rozdíl je pouze v tom, že se tyto neurčené soubory nezapíší do centrálních vzorů (soubor SW-LIST), ale do souboru dočasných vzorů (soubor SW-DOCAS). V tomto souboru budou do té doby, dokud se v nadřízené organizaci nezavedou do centrálních vzorů.

Přiřazení dočasných vzorů do ostrých provedete ve volbě Aktualizace dočasných vzorů, kde vytvoříte soubor, který zašlete do nadřízeného programu KSPRÁVCE. Pokud se tyto soubory v KSPRÁVCI schválí, pak při přihrání nových centrálních souborů ve volbě NADSTAVBA – Příjem číselníků, se dočasné vzory přesunou do ostrých.


Zpracovani Sw-scanu - prace se vzory

Scan SW– práce se vzory

Několik rad pro práci se vzory

1. V číselníku názvů software je na začátku vzor “-Nezpracovávané soubory”. Tento vzor obsahuje soubory, které chcete vyloučit ze zpracování. Jedná se o soubory, které se vyskytují ve více vzorech, většinou jsou součástí operačního systému WINDOWS a při zpracování dělají problémy. Pokud se totiž tyto soubory do Windows dostanou ze SW, který není ve vzorech a mají velikost odpovídající jinému SW, který ve vzorech je, mohou při zpracování zobrazit software, který vůbec nikdy na počítači nebyl. Pokud nejsou tyto soubory důležitými pro určování názvu SW, je vhodné je přeřadit do tohoto vzoru a vyloučit je ze zpracování. Jedná se např. o soubory : SETVER.EXE, ODBCCAD32.EXE, REGSVR32.EXE, CLICONF.EXE, ODCCONF.EXE apod. Rozpoznání takovýchto souborů vyžaduje určitou praxi při vytváření vzorů.

2. Všechny instalační a odinstalační soubory jsou dány do vzoru Instalace - instal. a odinstal. soubory. Je to proto, že hodně software využívá stejné instalační programy. Ale i v těchto instalačních programech jsou různé verze a různé datumy instalace. Při zpracování se pak stávalo, že se na disku našel pouze instalační program (např. u jiné instalace, nebo neodinstalovaný soubor apod.) a byla vyhodnocena špatná instalace. Proto jsme všechny instalační a odinstalační soubory zahrnuli do jednoho vzoru. Při zpracování dalších nových souborů do vzoru by jste měli nové instalační a odinstalační soubory zapisovat do tohoto jednoho vzoru a nezapisovat je k vlastní instalaci.

3. Všechny instalace software začínají v názvu textem “Instalace –”. Tyto instalace musí mít v číselníku názvů software označenu položku Druh SW = Instalace.

4. Všechny ovladače tiskáren, myší, síť. karet, … začínají v názvu textem “Ovladače”. Tento software musí mít v číselníku názvů software označenu položku Druh SW = Ovladače.

5. Pozor na položku Verze software při tvorbě vlastních vzorů. Není vhodné dělat podrobné členění verzí (např. 2.12, 2.13, 2.45). Autorské firmy v takovém případě používají v jednotlivých verzích software dost často společné soubory (mají stejný název, velikost a verzi v hlavičce souboru). Tyto soubory se potom při zpracování označí jako tzv. Sdílené a nastává problém. Pokud se na počítači naleznou jen sdílené soubory nějaké aplikace, nelze stoprocentně určit o jakou aplikaci se jedná. Proto je mnohem výhodnější slučovat příliš jemné členění verzí do verzí např. 1.0, 1.5, 3.0 nebo 1.*, 2.*, 3.*.

6. Softwarové balíky programů jako je např. MS Office obsahují ve vzorech software všechny moduly za všech balíků (Standart, Professional, …). Rozlišení balíků se provádí v souboru SW_BALIK.DBF, kde je uložen text, který instalace SW balíku zapisuje do registrů. Z uvedeného vyplývá, že mezi softwarové balíky má význam dávat software, který do registrů Windows zapisuje jinou hodnotu když je nainstalovaná kompletní instalace (např. MS OFFICE 2000 Premium) a jinou hodnotu, když je zakoupen pouze samostatný modul (MS WORD 2000).

7. Velmi nepřesné jsou výsledky, pokud stejný software je na počítači nainstalován několikrát (např. na disku C: a na disku D:) nebo pokud v případě software typu WINDOWS, OFFICE, EXPLORER existuje na počítači kromě aktuální verze i verze předchozí. V tomto případě doporučujeme tyto duplicitní instalace při nejbližší příležitosti z disku smazat a provést nové scanování.

8. Dodané vzory byly získány vlastní instalací většinou na systému WINDOWS 95/98/NT/2000. Jelikož některé instalace jsou závislé na operačním systému, muže se stát, že některé vzory nebudou obsahovat nějaký soubor nebo některé soubory budou mít jinou velikost.

9. Pokud při scanování budete scanovat i jiné přípony než EXE a COM, musíte si je sami zařadit do vzorů a také sami ve vzorech aktualizovat. Autorská firma bude udržovat ostré vzory pouze s příponami EXE a COM.


Software

Evidence licencí software

Evidence licencí software obsahuje informace o licencích software, které se nacházejí ve firmě.

Evidují se zde základní údaje o software (název, verze, licenční číslo, inventární číslo, typ instalace, …), informace o licenci (počty kusů, platnost, jazyková mutace, …), ekonomické údaje (faktura, dodavatel, dokupování licencí, …) a další.


Software - karta Seznam

Licence software - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

při duplikaci licence software se vytvoří nová licence software, kde je přepsáno evidenční číslo, vynulováno licenční číslo, specifické číslo, inventární číslo, typ instalace je nastaven na FULL, je vynulována vazba na zařízení. Dodaný počet instalací se vytvoří podle původní věty, počet instalovaných a převedených kusů je roven nule, počet volných instalací je stejný jako počet dodaných. Rovněž je vynulován datum inventury.

Upgrade

před vytvořením licence typu UPGRADE musíte mít na zřeteli následující pravidla :

· licenci UPGRADE lze provést jako zcela novou licenci nebo změnit položku typ licence u již existujících licencí typu FULL a OEM.

· při vytváření licence UPGRADE musí již existovat předchozí verze licence. Program neumožní vytvořit licenci UPGRADE pokud mu neoznačíte předchozí verzi licence, na které se upgrade provádí.

· při vytváření licence UPGRADE musíte postupovat směrem nahoru od první verze, kterou chcete evidovat. V okamžiku, kdy začnete např. od verze 4.0, se nelze vrátit a napojit upgrade na verze 2.0, 3.0 apod.

· taktéž přiřazení dosud nepřiřazených licencí typu UPGRADE na počítač musíte provádět postupně od první verze.

· na začátku si vyzkoušejte vytváření licencí UPGRADE se stejným počtem kusů. Až zvládnete tyto licence, můžete přikročit k licencím typu m : n.

· v případě používání scanu SW doporučujeme následující postup :

o        nejprve zpracujte scany SW ze všech počítačů.

o        potom vytvořte všechny legální licence jako FULL nebo OEM a přiřaďte je na všechny počítače.

o        dále k těmto licencím vytvořte všechny licence předchozích verzí, které chcete evidovat.

o        změňte příslušné licence typu FULL na UPGRADE a nastavte, na které licence byl upgrade zakoupen.

Postup vytvoření licence typu UPGRADE :

1) vytvořením zcela nové licence, kde zadáte Typ licence = UPGRADE (viz. následující obrázek)

2) opravou již existující licence typu FULL. Zde taktéž musíte zadat Typ licence = UPGRADE (viz. následující obrázek)

Při uložení změn v obou případech program spustí formulář Upgrade SW, který nabízí seznam všech licencí, na něž lze upgrade pořídit. Jedná se o všechny licence typu FULL, OEM, OEM-old a UPGRADE (zde pouze ty, které nemají ještě vyčerpány všechny kusy pro upgrade, na které lze pořídit UPGRADE). Stačí pouze vybrat jednu nebo několik požadovaných licencí.

Pozor :

  • licence typu UPGRADE lze podle předchozích bodů vytvořit v Evidenci hardware, Evidenci licencí software nebo Zpracování scanu SW.
  • pořízením UPGRADE na OEM verzi se původní typ licence OEM změní na OEM – upg, která říká, že původně to byla OEM verze a že na ní byl proveden upgrade.
  • pokud je licence označena jako UPGRADE a jedná se o MULTILICENCI, musíte případně ještě zadat počet kusů, o které byla licence navýšena v rámci upgrade (např. licence jako bonus od dodavatele, …) proti původní verzi. Tyto navýšené kusy by totiž nešly přiřadit na počítače (program kontroluje umístění a počet předchozích instalací a když tyto počty nesouhlasí, nepovolí licence přiřadit). Zadáním počtu navýšených kusů se tato kontrola obchází.

3) stiskem pravého tlačítka myši nad seznamem a volbou Nastavení upgrade :

tato volba spustí stejný formulář Upgrade SW jako v prvním případě. Rozdíl je jen v tom, že nemůžete změnit žádnou dříve vytvořenou (např. omylem) licenci FULL. Nyní totiž formulář nabízí pouze licence typu UPGRADE, a to jen ty, které mají ještě volnou alespoň jednu instalaci, na které nebyla přiřazena předchozí verze.

Pozor :

  • výběr licence typu UPGRADE (výše uvedené tlačítko) lze vytvořit pouze v Evidenci licencí software.
  • pořízením UPGRADE na OEM verzi se původní typ licence OEM změní na OEM – upg, která říká, že původně to byla OEM verze a že na ní byl proveden upgrade.

4) stiskem pravého tlačítka myši nad seznamem a volbou Vytvoření upgrade :

tato volba automaticky spustí opravou aktuální licence a dále postupujete jako v bodě 2.

C) Tisky :

Parametry tisku

SESTAVY

Seznam software

jednoduchý seznam licencí software.

Pasportní list

zobrazení veškerých údajů o licencích software spolu se seznamem počítačů, na kterých je licence software nainstalována.

Seznam instalací

přehled o počtech provedených a volných instalací (multilicence se zobrazují vždy)

Volné instalace

přehled licencí software, kde je již vyčerpán počet instalací.

Seznam oprav

sestava oprav (historie) licencí software. Lze vybrat, zda se mají tisknout všechny opravy nebo pouze některé. Také lze vybrat období.

Deník oprav

sestava všech oprav licence s podrobným popisem za zvolené období.

Rozpracované opravy

sestava všech licencí, které mají rozpracovanou opravu (jsou v opravě).

Hardware

seznam počítačů, na kterých je licence software nainstalována.

Dokumentace

seznam přiřazené dokumentace.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny parametry licence software a seznam počítačů, na kterých je licence software nainstalována. Text, který potom následuje a který může být v každé organizaci jiný, se zadává v konfiguraci programu ve volbě Údržba - konfigurace.

Upgrade/Update

v této sestavě je zobrazena posloupnost aktualizací licence software novými verzemi.

Dokoupení licencí

v této sestavě je zobrazeno postupné dokupování dalších instalací k licenci

Prošlé servisy

tato sestava zobrazuje seznam licencí software, které k určenému datu již měly mít proveden servis.

Provedené servisy

tato sestava zobrazuje seznam licencí software, u kterých již byl proveden servis.

Nastavené servisy

tato sestava zobrazuje seznam licencí, u kterých je nastaven servis.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivé licenci software.

Neschválené položky

tato sestava je zobrazena jen v případě, že máte zakoupenou multilicenci. Neschválené položky se vybírají pouze pro centrálně udržované číselníky, které mají povolenou aktualizaci (viz. nastavení v volbě Údržba - konfigurace karta pro multilicenci). V sestavě lze zobrazit neschválené hodnoty pro název a verzi SW, operační systém.


ComboSeznam

Výběr

Ovládací tlačítka

Na tomto formuláři je v mřížce zobrazen seznam vět souboru, ze kterých lze vybrat požadovanou hodnotu a přesunout ji zpět do předchozího formuláře. Tento formulář se používá v případě, že klasický tzv. ComboSeznam nelze použít (mnoho vět, špatná přehlednost, nemožnost hledání apod.).

Používá se v následujících případech :

Výběr názvu licence software

v okamžiku, kdy vytváříte licenci software, můžete její název zadat celý učně. Pokud neznáte přesně název, je výhodné použít tento formulář, ve kterém můžete snadno listovat a vyhledat požadovaný název. Jestliže jste před vstupem do tohoto formuláře zadali úvodní část názvu licence, program Vás automaticky nastaví na nejbližší vhodný název. Formulář obsahuje tlačítka pro :

Hledání - umožňuje vyhledat požadovaný název licence

Detail - zobrazí detailní informace z číselníku názvů software

Výběr - vybere aktuální název a přenese ho do nadřízeného formuláře.


Software - karta Zakladni udaje

Licence software - základní údaje

Ovládání programu

Evidenční číslo

evidenční číslo je určeno k jednoznačné identifikaci licence software (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Mateřská licence

tato položka je vyplněna pouze u velkých organizací, které mají zakoupeno více instalací programu SPRÁVCE a alespoň jednu licenci programu KSPRÁVCE. Číslo mateřské licence se určuje v nadřízené úrovni v programu KSPRÁVCE. Položku nelze editovat. Jestliže máte u aktuálního licence vyplněnou položku mateřská licence, nelze tuto licenci software aktualizovat a nebo jí zrušit.

Konkrétní příklad :

firma má centrum v Praze, kde se zakoupí multilicence Microsoft Office pro 100 PC. Firma má po celé republice celkem 10 závodů (středisek apod. kde je program SPRÁVCE), na které tuto multilicenci rozdělí rovnoměrně po 10-ti. Této multilicenci přidělí číslo mateřské licence. Každý správce si do své evidence načte data z programu KSPRÁVCE. Licence software Microsoft office dané mateřské licence má nastaveno : počet zakoupených mateřských licencí = 100, licence k dispozici = 10. Tím je dáno, že správce bude hospodařit pouze s 10-ti licencemi. Při výstupu na nadřízenou organizaci se do programu KSPRÁVCE dostane skutečný počet nainstalovaných kusů. V programu KSPRÁVCE lze vytisknout sestavu mateřských licencí, která zobrazí přehled čerpání licencí v rámci celé organizace.

Mateřská licence (ks)

udává se zde počet kusů zakoupených centrálně v nadřízené organizaci. Pokud Vaše firma nepoužívá program KSPRÁVCE, je hodnota položky stejná jako licence k dispozici. Pokud program KSPRÁVCE používáte, nelze položku editovat.

Název a verze

tyto položky spolu souvisí a jsou společně kontrolovány proti číselníku názvů software. Nelze pořídit software, který není v číselníku.

SW balík

název softwarového balíku, ke kterému zadaný SW patří (např. MS Office 2000 Standart, MS Office 2000 Premium).

Typ instalace

FULL - plná instalace

OEM - OEM verze. Je nutné stanovit k čemu (hardware nebo příslušenství) byla zakoupena. Výběr lze provést pomocí tlačítka pro detail zařízení. Pokud bude vybrané číslo HW nebo PŘ někdy v budoucnu fyzicky zrušeno, pak v položce Jako OEM zakoupeno k zůstanou zapsány údaje z původní vazby při zakoupení. Po výběru HW nebo PŘ pro OEM verzi následuje dotaz, zda doplnit ekonomické údaje z vybrané věty HW nebo PR.

OEM-Old - stará OEM verze, u které nejste schopni stanovit k čemu byla zakoupena.

OEM-Upg - nelze vybrat ručně. Vznikne automaticky při upgrade OEM verze.

UPGRADE - u tohoto typu instalace je nutno zadat předchozí verzi SW.

Vazba na zařízení

pokud byl SW koupen spolu s nějakým zařízením je možno tady uvést číslo tohoto zařízení. U OEM verzí SW je číslo zařízení povinné. Pokud se jedná o OEM verzi s vazbou na hardware je tato licence software automaticky přiřazen k zadanému počítači.

Platnost licence

pokud je licence software platná jen po určitou dobu (např. jen pro rok 2001), zadá se zde datum konce platnosti licence. Je možno vytisknout sestavu licencí software, kterým vyprší platnost licence k určitému datu.

Forma nákupu

do formy nákupu lze uvést jakýkoli údaj. Jako formy nákupu lze uvést např. : krabicový, SELECT, MOLP, …

Lokalizace

u každé licence software lze zadat dva typy lokalizace. První typ je nutno vybrat z číselníku lokalizací, do položky pro druhý typ lokalizace lze zapsat libovolný text.

Downgrade

označení, zda místo zakoupené verze licence software lze použít některou z nižších verzí SW.

Seznam SW pro downgrade

seznam verzí licencí software, které lze použít jako downgrade. Je to pouze poznámka. Neprovádí se podle ní analýza při zpracování scanu SW.

Multilicence

tato položka rozhoduje o počtu instalací. Pokud zadáte, že licence software není multilicence, pak lze licenci software nainstalovat pouze na jeden počítač. Počty instalací jsou zablokovány a program si sám hlídá, aby byla licence software nainstalována pouze jednou. Jestliže zadáte, že licence software je multilicence, pak jí lze instalovat podle typu multilicence. Počty zakoupených instalací lze aktualizovat pomocí dokupování licencí.

Typy multilicencí

Pokud je licence software označena jako multilicence, je třeba určit její typ :

· Omezená počtem instalací

lze ji nainstalovat jen na určitý počet počítačů. Je třeba uvést počet zakoupených licencí. U některých forem nákupu multilicencí je povoleno provést více instalací než je zakoupeno licencí a chybějící licence dodatečně dokoupit. Toto lze označit zatržením položky, že Volné licence mohou být záporné.

· Omezená současně pracujícími

lze ji nainstalovat na libovolný počet počítačů, ale současně může s touto licencní pracovat jen určitý počet uživatelů. Počet zakoupených licencí je vygenerován (999 999), ale je nutno zadat počet uživatelů. Hlídání počtu současně pracujících uživatelů si firma musí hlídat sama.

· Neomezená

lze ji nainstalovat na libovolný počet počítačů a její používání uživateli není nijak omezeno.

Omezení multilicence

poznámka k omezení multilicence .

Licence k dispozici

udává počet instalací, které jsou k dispozici. Pokud firma používá KSPRAVCE a jedná se o centrálně udržovanou licenci, je tento počet určen v nadřízeném KSPRAVCI a nelze ho měnit.

Instalované a volné licence

tyto hodnoty nelze editovat, program je sám přepočítává v okamžiku zadání počtu licencí k dispozici nebo při přiřazení licence k počítači.

Nárůst při UPG

v této položce musíte při upgrade multilicence ručně zadat počet kusů, o které byla multilicence případně navýšena proti předchozí verzi. Program totiž standardně umožňuje přiřadit na počítače pouze stejný počet kusů, jako měla předchozí verze. Zadáním nárůstu se uvedený počet kusů nebude kontrolovat a navýšené kusy lze přiřadit na počítače i když v předchozí verzi tyto kusy nebyly.

Operační systém

tato položka určuje typ operačního systému, pro který je licence software určena. Na rozdíl od operačního systému u hardware může tento údaj obsahovat několik operačních systémů např. Windows 95/98/NT/2000.


Software - karta Ekonomicke udaje

Licence software - ekonomické údaje

Ovládání programu

Základní ekonomické údaje

Dokupování licencí

dokupovat licence lze pouze pro software typu multilicence a nelze je dokupovat k neomezené multilicenci. Neomezená multilicence má počet licencí nastaven na hodnotu 999 999 a nemá význam dokupovat licence. Seznam dokoupených licencí ke každému software je zobrazen v mřížce. Tlačítka pro dokoupení licencí jsou přístupná pouze pokud se jedná o multilicenci, uživatel má povolenu aktualizaci SW a nejedná se o centrálně udržovanou licenci (položka číslo mateřské licence je prázdná).

Při pořízení nové multilicence nebo při změně licence ze single na multilicenci je automaticky vygenerovaná věta do souboru dokoupených licencí. Tato věta je mřížce zobrazena modrou barvou a nelze ji zrušit (znamená úvodní nákup). U multilicence nelze opravit počet zakoupených licencí a cenu přímo ve větě software. Také nelze u multilicence změnit typ omezení. Pokud chcete některý z těchto údajů změnit, musíte zvolit opravu dokoupené úvodní licence.

Při pořízení dalších licencí je nutno zadat datum nákupu a počet dokoupených licencí, program automaticky přepočítá počet zakoupených licencí a cenu software. Totéž se provede při rušení dokoupené licence.

Pokud budete rušit dokoupené licence a zrušením dokoupení se počet volných instalací dostane do záporné hodnoty, nelze tuto operaci provést pokud není povoleno čerpat licence do záporných hodnot.

Při vytvoření singl licence z multilicence jsou ze souboru dokoupených licencí vymazány všechny věty týkající se dané licence software.


Software - karta Ostatni

Software – ostatní údaje

Ovládání programu

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na Volný číselník.

Odpovědná osoba

jedná se o odpovědnou osobu za software (ne za instalace). V okamžiku, kdy se software nainstaluje na počítače, má každý počítač svoji odpovědnou osobu.

Servisy


Software - karta Opravy

Software - opravy

Ovládání programu

Tato karta obsahuje seznam (historii) daného software. Zobrazuje přímo soubor OPR_SW.DBF, ve kterém jsou uloženy všechny opravy software. Podrobnější popis naleznete v kapitole Opravy.


Software - karta Vazby HW

Software – přiřazení HW

Ovládací tlačítka Hromadné výběry

V mřížce je seznam hardware, na kterém je licence software nainstalována. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechen HW k odřazení, zobrazit podrobné informace o hardware, zobrazit seznam hardware (Volný hardware), pořídit nový hardware.

Detail hardware

pomocí pravého tlačítka a volby Detail hardware nebo double klikem myší lze na této kartě zobrazit (i opravit) hardware, na němž se nachází kurzor.

Nový hardware

provedete stiskem pravého tlačítka myši a výběrem volby Nový hardware. Spustí se formulář, ve kterém vytvoříte nový počítač a po jeho uložení následuje dotaz, zda tuto licenci chcete hned přiřadit na nový počítač.

Volný hardware

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volný hardware. Najednou se přiřadí licence software na všechen označený hardware.

Odřadit hardware

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit hardware. Najednou se odřadí licence ze všech označený počítačů.

Pozor :

· před odřazením musíte označit počítač, ze kterého chcete licenci odřadit (zelený sloupec)

· nelze odřadit licenci z počítače, který byl zlikvidován (STAV=8).

· nelze odřadit licenci, která je označena jako OEM a byl zakoupena k vybranému počítači.

· pokud odřadíte licenci z počítače a tato licence byla zjištěna při zpracování scanu SW, pak se tato licence z počítače odřadí a příslušné nalezené soubory se přesunou na kartu Nelegální.


Software - karta Vazby dokumentace

Software – vazby dokumentace

Ovládací tlačítka Hromadné výběry

V mřížce je seznam dokumentace přiřazené k danému software. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit (Volná dokumentace), pořídit novou dokumentaci.

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Software - karta Upgrade/update

Software – upgrade

Ovládací tlačítka

Na této kartě je zobrazen seznam předchozích verzí, které se vztahují k aktuálnímu software. Tento seznam je seřazen tak, jak verze SW následovaly po sobě. Sudá pořadí jsou pro snadnější orientaci zobrazeny na žlutém podkladu. V mřížce je zobrazeno kromě dalších položek také pořadí (Poř.), ve kterém byla verze pořízena.

V případě, že původní počet licencí je větší než počet licencí uvedených ve sloupci UPG, je možno k software pořizovat ještě další upgrade (rozdělení jedné licence na více).

Pomocí tlačítka Detail SW lze zobrazit software, na kterém se nachází kurzor.


Prehled nazvu software

Bilance software

Soubor Bilance software slouží ke dvěma účelům :

a) sjednocení názvů software – pro používání scanu SW, musíte dodržovat určitá pravidla. Dodavatelská firma uvádí název software malými písmeny, pouze začáteční písmena jsou velká např. PowerQuest Drive Image. Dále u velkých firem typu Microsoft, Corel Adobe apod. je na začátku názvu uváděn název firmy, aby se všechen software jedné firmy zatřídí k sobě. Verze software je uváděna do položky verze. Pokud se jedná o servise pack, je uváděn většinou ve verzi software. Dobře si prohlédněte dodané vzory software a jejich názvy, tak aby jste si vlastní vzory mohli správně pojmenovat. Nepoužíváte-li scan SW, můžete si názvosloví software volit libovolně.

b) bilanci software – ukazuje celkovou bilanci používaného software podle názvu+verze software. Program sečte všechny zakoupené licence a porovná je se skutečně nainstalovanými. Výsledkem je celkový přehled zakoupených licence, jejich nainstalování, nelegální instalace apod. s barevným rozlišením záporných hodnot (licencí, které je nutno dokoupit).

Příklad hodnot :

MS Windows 95

MS Windows 2000

Borland Delphi 6.0

Podrobnější popis


Nazvy software - Seznam

Bilance software - Seznam

Tato karta slouží ke dvěma účelům :

1) přehledně zobrazuje celkovou bilanci software (viz. obrázek) :

Mřížka pro každý software zobrazuje celkové součty (pokud máte např. zakoupeny 2 licence po 10 instalacích, najdete ve sloupci jejich celkový součet = 20).

Vysvětlení jednotlivých sloupců :

a) Bezlic - celkový počet instalací Bez licence

b) Licence - celkový počet zakoupených licencí

c) Instal - celkový počet instalovaných licencí

d) Upg. - celkový počet licencí, na které byl proveden upgrade

e) Ruční - celkový počet licencí, které byly přiřazeny ručně

f) Volné - celkový počet volných licencí (možných použít k instalaci)

g) Neleg. - celkový počet nelegálních instalací (nepokrytých licencí)

h) Rozdíl - celková bilance (Rozdíl = Licence – Instal – Neleg.)

Po spuštění Vám mřížka zobrazuje seznam všech názvů software. Pomocí ovládacího prvku nad mřížkou :

můžete zapnout filtr a zobrazit jen určitou část :

– Licen - zobrazí jen seznam software, jehož bilance je záporná (nutno dokoupit licence nebo odinstalovat nelegální instalace).

+ Licen - zobrazí jen seznam software, jehož bilance je kladná (máte ještě nějaké licence k dispozici)

BezLic - zobrazí jen software, který nevyžaduje zakoupení licence.

Aby byla bilance aktuální je potřeba provést přepočet pomocí tlačítka Přepočet licencí.

2) karta dále umožňuje aktualizaci názvů software. Pro aktualizaci platí následující pravidla :

a) název a verze software nesmí být v seznamu duplicitní.

b) oblast, podoblast a výrobce jsou kontrolovány na číselníky.

c) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Přehled názvů software

seznam všech názvů software.

Vazby – licence SW

sestava jednotlivých názvů software s vazbami na licence software.

Vazby – hardware (nelegální SW)

sestava nelegálního software podle názvu software

Vazby – hardware (bez licence)

sestava SW bez licencí podle názvu software

Vazby - hardware (licence)

sestava zobrazující instalace licencí na jednotlivé počítače

Vazby - hardware (vše)

sestava zobrazující instalace licencí, nelegálního SW a SW bez licence na jednotlivé počítače software

Seznam vzorů software

seznam souborů ve vzorech.

Seznam SW balíků

seznam softwarových balíků.

Bilance software

celkový přehled počtu zakoupených licencí, nainstalovaných legálních i nelegálních instalací a celkovou bilanci.

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).


Nazvy software - Zakl. udaje

Přehled názvů software – Základní údaje

Ovládání programu

Druh

velmi důležitá položka. Slouží k určení druhu software (licenční, aplikační, shareware...), který je nutný pro správné rozlišení nalezeného software ve scanu SW.

Při zpracování scanu SW bude software označený jako :

· licenční, aplikační, vlastní a shareware - vložen na kartu Nelegální (bude později vyžadovat přidělení licence)

· freeware, ovladače, instalace a Hw utility – vložen na kartu Bez licence (nebude vyžadovat přidělení licence)

Hlavní soubor, Počet souborů

tyto položky nelze editovat. Aktualizují se samy v okamžiku zpracování výsledků scanu SW.

Průměrná cena

průměrná cena je důležitá pro cenový odhad nainstalovaného software na počítačích. Pokud nemá zjištěný nainstalovaný software vytvořenou licenci, pak v sestavě pro cenový odhad je cena nelegálního software a software bez licence určena z číselníku názvů software.

SW balík

tato položka určuje, zda se software skládá z několika modulů (programů) např. MS Office 2000 Premium. Při použití scanu SW lze pak nadefinovat složení těchto balíků. Při zpracování výsledků scanu SW umí program zjistit i název balíku, ze kterého byla instalace provedena.

Oblast, podoblast

v položce oblast máte možnost určit hrubě oblast použití software (např. textové editory, účetnictví apod.) a v položce podoblast určit jeho jemné členění (např. pro účetnictví - jednoduché, podvojné apod.).

Lokalizace

v položce lokalizace máte možnost označit software, který se buď vyskytuje pouze v dané lokalizaci nebo který ve firmě používáte pouze v uvedené lokalizaci. Při zpracování nascanovaných souborů scanu SW umí program SPRÁVCE vyhodnotit správně pouze lokalizaci u operačního systému Windows. U ostatního software to musíte po zpracování doplnit ručně. Pokud si tady vyplníte položku lokalizace, bude její hodnota automaticky dotažena při zpracování scanu SW do všech nalezených instalací. Je to vhodné např. u českého software, který se vyskytuje pouze v české verzi.


Nazvy software - vazby licence

Přehled názvů software – vazby Licence

Na této kartě jsou zobrazeny všechny licence daného názvu ze souboru software.

Licence si lze prohlédnout nebo provést Změna vazby (změnu názvu licence)


Nazvy software - vazby nelegalni

Přehled názvů software – vazby Nelegální

Tato karta zobrazuje seznam tzv. nelegálního software, který se zjistil scanováním ve scanu SW. Tento software nemá vytvořenou licenci v souboru software.

Software pro legalizaci vyberete myší v prvním sloupci mřížky nebo pomocí tlačítka Označ vše a Odznač vše. Stiskem pravého tlačítka myši a spuštěním volby Licence (je přístupné pouze v případě, že je označena některá věta) dostanete formulář Volné licence, pomocí kterého můžete označený software zlegalizovat.


Nazvy software - vazby bez licence

Přehled názvů software – vazby Bez licence

Tato karta zobrazuje seznam tzv. software Bez licence, který se zjistil scanem SW. Tento software nemusí mít vytvořenou licenci v souboru software.

V některých případech (legalizace freeware apod.) můžete chtít i z tohoto software vytvořit legální licenci. Software pro legalizaci vyberete myší v prvním sloupci mřížky nebo pomocí tlačítka Označ vše a Odznač vše. Stiskem pravého tlačítka myši a spuštěním volby Licence (je přístupné pouze v případě, že je označena některá věta) dostanete formulář Volné licence, pomocí kterého můžete označený software zlegalizovat.


Nazvy software - vazby hw

Přehled názvů software – vazby HW

na této kartě jsou pouze zobrazeny instalace daného názvu software na všech počítačích. Tyto instalace nemáte možnost změnit.


Nazvy software - SW vzory

Přehled názvů software – SW vzory

Tato karta zobrazuje seznam souborů ze vzoru patřící k aktuálnímu software. Tato karta slouží pouze k prohlížení.


Nazvy software - SW baliky

Přehled názvů software – SW balíky

Tato karta zobrazuje seznam softwarových balíků patřící k aktuálnímu software. Tato karta slouží pouze k prohlížení.


Operacni systemy software

Operační systémy software

Soubor operační systémy software slouží k určení toho, pro jaký operační systém je daný software určen. Na rozdíl od operačních systémů hardware nemusí být operační systém software jednoznačný, může být určen pro provoz na více operačních systémech.

Příklad hodnot :

MS-DOS

Windows 3.*

Windows 95/98

Windows NT/2000

Linux

Podrobnější popis


Ciselniky - software (operacni systemy)

Operační systémy software

1. Karta Seznam

zobrazuje seznam všech hodnot operačních systémů software. Pro aktualizaci platí následující pravidla :

a) název operačního systému nesmí být v seznamu duplicitní.

b) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Operační systémy software

seznam všech operačních systémů software.

Vazby - software

sestava jednotlivých operačních systémů s vazbami software.

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Vazby SW

zobrazuje seznam software, který odpovídá aktuální hodnotě operačního systému software. Lze zde provést hromadnou Změna vazby.

3. Karta Volný SW

karta obsahuje vazby, ve kterých není položka operační systém software vyplněna. Lze zde provést hromadnou Změna vazby.


Oblasti a podoblasti software

Soubor oblastí software slouží k určení oblasti a podoblasti, pro kterou je software určen. V oblasti můžete software označit hrubé rozdělení jako např. účetnictí. Pomocí podoblasti můžete toto členění ještě upřesnit např. účetnictví - podvojné účetnictví.

Příklad hodnot :

Účetnictví Jednoduché

Podvojné

Mzdy

Textový editor

Internet

Databáze

Podrobnější popis


Ciselniky - software (oblasti)

Oblastí a podoblasti software

1. Karta Seznam

zobrazuje seznam všech hodnot oblastí a podoblastí software. Pro aktualizaci platí následující pravidla :

a) název oblasti a podoblasti nesmí být v seznamu duplicitní.

b) sloupec OK ve mřížce je zobrazen pouze pro multilicence programu SPRÁVCE a ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy :

Oblasti software

seznam všech typů oblastí a podoblastí software.

Vazby - software

sestava jednotlivých oblastí s vazbami na software

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Vazby SW

zobrazuje seznam software, který odpovídá aktuální hodnotě oblasti software. Lze zde provést hromadnou Změnu vazby.

3. Karta Volný SW

karta obsahuje vazby, ve kterých není položka oblast software vyplněna. Lze zde provést hromadnou Změnu vazby.


Vyrobci software

Výrobci software

Soubor výrobci software slouží k určení výrobce (autora) software.

Příklad hodnot :

Software602

Microsoft

Borland

Podrobnější popis


Ciselniky - software (vyrobci)

Výrobci software

1. Karta Seznam

zobrazuje seznam všech výrobců software. Pro aktualizaci platí následující pravidla :

a) název výrobce nesmí být v seznamu duplicitní.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy :

Výrobci software

seznam všech výrobců software.

Vazby - software

sestava jednotlivých výrobců s vazbami na software.

Www stránky

seznam všech výrobců software s jejich www stránkami.

Neschválené položky

sestava neschválených hodnot nadřízenou organizací (pouze pro multilicence).

2. Karta Zákl. údaje

zobrazuje základní údaje o výrobci (název, adresa, …)

3. Karta Vazby SW

zobrazuje seznam software, který odpovídá aktuální hodnotě oblasti software. Lze zde provést hromadnou Změnu vazby.

4. Karta Volný SW

karta obsahuje vazby, ve kterých není položka oblast software vyplněna. Lze zde provést hromadnou Změnu vazby.


Vyrobci software

Lokalizace software

Soubor lokalizací software slouží k určení lokalizace (země původu) software.

Příklad hodnot :

CZ Česká

FR Francouzská

DE Německá

Podrobnější popis


Ciselniky - software (lokalizace)

Lokalizace software

1. Karta Seznam

zobrazuje seznam všech lokalizací software. Seznam lokalizací software aktualizuje dodavatelská firma. Je možné ji ručně doplnit o vlastní hodnoty. Pro aktualizaci platí následující pravidla :

a) kód lokalizace nesmí být v seznamu duplicitní.

b) název lokalizace nesmí být prázdný.

c) číslo lokalizace je naplněné pouze od dodavatelské firmy a odpovídá skutečnému kódu mezinárodně používanému. Pokud si doplníte vlastní hodnoty, je číslo prázdné.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy :

Lokalizace software

seznam všech lokalizací software.

Vazby - software

sestava jednotlivých lokalizací s vazbami na software.

2. Karta Licence SW

zobrazuje seznam software, který odpovídá aktuální hodnotě oblasti software. Lze zde provést hromadnou Změnu vazby.


Zpracovani Sw-scanu - softwarove baliky

Scan SW – softwarové balíky

Tento formulář slouží k určení názvů softwarových balíků a modulů ze kterých se skládají. Tyto informace se používají při zpracováváni SWT souborů, a to pro rozpoznávání softwarových balíků (např. MS Office 97 Standard, Professional) nebo jejich jednotlivých částí (např. MS Word 97).

Pozor :

do softwarových balíků má význam dávat pouze takové balíky programů, které obsahují zcela samostatné moduly a tyto samostatné moduly zapisují vlastní název do registrů např. :

balík MS Office 2000 Standard - celý balík má v registrech zápis Microsoft Office 2000 Standard

jeho modul MS Outlook 2000 - má v registrech zápis Microsoft Outlook 2000

Při zpracování SWT souborů program nejprve zjistí instalaci Microsoft Office 2000. Podle softwarových balíků a výpisu z registrů se pokusí zjistit typ balíku (např. Standard). Pokud se mu to povede, zapíše do názvu balíku jeho skutečný název. Pokud se mu to nepovede, vyhledá v registrech názvy samostatných modulů a do názvu balíku zapíše názvy nainstalovaných modulů.

Podmínky pro aktualizaci

1. nelze opravovat balíky a moduly, které byly dodány autorskou firmou (tyto věty jsou v mřížce bílé, vlastní věty, které lze opravovat jsou žluté).

2. název a verze software je kontrolována proti číselníku software (tento SW musí být v číselníku software označen jako balík).

Význam jednotlivých položek u modulů :

Název - název modulu (např. MS Word)

Verze - verze modulu (např. 97)

Hlavní soubor - soubor, kterým se modul spouští (např. WinWord.exe)

Výpis registru modulu - název, kterým se samostatný modul zapisuje při instalaci do registru počítače. Jedná se o situaci, kdy je modul zakoupen jako samostatný software, tj. není součásti balíků (např. MS Word 97).

Výpis registru balíku - název, kterým se balík zapisuje při instalaci do registru počítače (např. MS Office 97 Standard).

SESTAVY

Seznam balíků

seznam jednotlivých balíků.

Seznam balíků (+seznam modulů)

seznam jednotlivých balíků a jejich modulů.


Zpracovani Sw-scanu - novy SW balik

Scan SW – nový SW balík

Tento formulář slouží k přidání nového balíku do souboru softwarových balíků (SW_BALIK.DBF).

V položce Název software se objeví pouze software, který je v číselníku názvů software označen jako SW balík. Pokud se Vám tam neobjeví potřebný software, musíte spustit volbu Číselníky – názvy software, kde najdete potřebný software a opravíte mu položku SW balík = .T.

Do položky Název balíku musíte zapsat správný název balíku (např. Standard, Professional, Premium apod.).


Zpracovani Sw-scanu - novy modul SW baliku

Scan SW – nový modul SW balíku

Tento formulář slouží k přidání nového modulu aktuálního balíku (např. modul MS Word 97 pro balík MS Office 97 Standard) do souboru softwarových modulů (SW_MODUL.DBF).

Jednotlivé položky znamenají :

Název - název modulu (např. MS Word)

Verze - verze modulu (např. 97)

Hlavní soubor - soubor, kterým se modul spouští (např. WinWord.exe)

Výpis registru modulu - název, kterým se samostatný modul zapisuje při instalaci do registru počítače. Jedná se o situaci, kdy je modul zakoupen jako samostatný software, tj. není součásti balíků (např. MS Word 97).

Výpis registru balíku - název, kterým se balík zapisuje při instalaci do registru počítače.

U položek Registr modulu a Registr balíku lze pro snadnější zápis vyvolat formulář Software z registrů.


Zpracovani Sw-scanu - vypis z registru

Scan SW – výpis z registrů

Tento formulář slouží k prohlédnutí seznamu názvů software, který se načetl z registrů všech zpracovaných počítačů. Pokud se v tomto seznamu názvů software nachází název softwarového balíku nebo jeho modulu, lze stiskem tlačítka OK přenést tento název do předchozího formuláře pro aktualizaci modulů softwarových balíků.


Zpracovani Sw-scanu - update ostrych vzoru SW

Scan SW – update vzorů SW

Tato volba slouží pro update vzorů software pro scan SW dodávaných autorskou firmou. Je přístupná pouze pokud není otevřený jiný formulář a pokud má přihlášený uživatel právo aktualizovat software..

Pro správnou funkci hledá program v podadresáři \UPG_VZOR soubory obsahující soubory pro update. Tyto soubory je nutné stáhnout z Internetu a do tohoto adresáře je rozbalit ručně. Pro každý update jsou určeny tři soubory :

LIST-???.DBF - seznam vzorů software, kde ??? je pořadí update.

SOFT-???.DBF - seznam názvů software, kde ??? je pořadí update.

UPGR-???.TXT - kontrolní seznam názvů software, kde ??? je pořadí update.

Po spuštění této volby vyhledá program všechny soubory UPGR-???.TXT a zobrazí jejich obsah. Na následujícím obrázku jsou v mřížce zobrazeny obsahy všech těchto souborů.

Věty zobrazené červeně Vám signalizují název software, který neexistuje ve Vašem číselníku názvů software.

Sloupec Číslo zobrazuje seznam aktualizačních souborů UPGR-???.TXT pro update, sloupce Název a Verze pak jednotlivý software, sloupec Zprac. pak ukazuje, zda byl SW již zpracován. Poslední sloupec Počet zobrazuje počet přihrávaných souborů.

V prvním zeleném sloupci musíte označit software, který chcete přihrát. Můžete si vybrat pouze ten software, který Vás zajímá, nemusíte vybírat všechen software. Také si můžete vybrat software z libovolné aktualizace (UPGR-001, UPGR-003 apod.).

Stiskem tlačítka OK se spustí vlastní přihrání. Program prochází nejprve nový číselník názvů software (SOFT-???). Pokud se přihrávaný software ve Vašem číselníku nenachází, tak jej tam program vloží. Pak se prochází nový soubor vzorů software (LIST-???) a vkládá do aktuálního souborů vzorů pouze ty soubory, které tam ještě nejsou (tzn. Vaše dodané soubory tam ponechá a vloží pouze nové soubory).

Na konci zpracování pak program do kontrolních aktualizačních souborů UPGR-???.TXT zapíše příznak zpracování pro všechny zpracované věty.


Evidence

Formuláře pro aktualizaci hlavních datových souborů mají několik karet. Na první kartě je seznam všech vět, další 2-3 karty jsou určeny pro vkládání a opravy vět, zbývající karty zobrazují vazby k dalším souborům.

Při vkládání nových vět do hlavních datových souborů je možno nechat evidenční číslo generovat automaticky nebo ho pořídit ručně. Toto číslo musí být vždy vyplněno a nesmí být duplicitní. Tvar evidenčních čísel lze nastavit v Údržbě - Konfigurace programu. Dále nesmí být zavedeno duplicitní inventární a specifické číslo. Do nové věty je nutno dále uvést datum zakoupení zařízení. Při uložení nové věty souboru hardware, software, příslušenství nebo sítí je do souboru oprav automaticky generována věta Stav=1 (Uvedení do provozu).

Pokud v síťové verzi programu při opravě věty libovolného datového souboru, tuto větu během Vaší opravy jiný uživatel zruší, Vaše data budou smazána.

Položky kontrolované proti číselníku - jestliže do takovéto položky uvedete výraz nenacházející se v daném číselníku, program Vás na tuto skutečnost upozorní a nabídne Vám možnost číselník doplnit. Pokud na této položce stisknete pravé tlačítko myši, spustí se Vám formulář příslušného číselníku a Vy máte možnost vybrat požadovanou hodnotu přímo z číselníku.

Karty označené Vazby slouží k přiřazení (odřazení) vzájemných vazeb. Na kartě jsou zobrazeny dvě mřížky. V horních (nebo levých) mřížkách jsou zobrazena přirazená data, v dolních (nebo pravých) jsou data, která je možno přiřadit.


Site

Sítě

Evidence sítí obsahuje informace o počítačových sítích, ve kterých máte evidované počítače zapojené. Mohou to být malé lokální sítě, ale i velké sítě WAN. Jedná se o evidenci základních parametrů jako je název sítě, licenční číslo, počet uživatelů, kabeláž apod.

Dále se evidují ekonomické údaje (faktura, dodavatel, …), organizační údaje (odpovědná osoba, umístění, organizační členění, …), servisy, opravy a další.

Také lze evidovat uživatelská jména a hesla všech důležitých uživatelů těchto sítí.


Site - Seznam

Sítě - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie dané sítě. Program vytvoří stejnou větu, pouze vynuluje specifické číslo a vygeneruje (nebo ručně zadá) evidenční číslo. Stav zařízení je přepsán na OK.

Program ProOpen

toto tlačítko slouží ke spuštění grafického programu ProOpen.

C) Tisky :

Parametry tisku

SESTAVY

Seznam sítí

sestava zobrazí jednoduchý seznam sítí.

Pasportní list

zobrazení všech údajů o síti.

Záruka a odpisy

sestava sítí, ve které jsou zobrazena data záruky a odpisu. Pokud je síť po záruce, obsahuje v sestavě značku „P“, pokud je odepsána, obsahuje značku „O“.

Seznam oprav

sestava oprav (historie) sítě. Je možné určit období, za které se změny mají tisknout.

Deník oprav

sestava všech oprav sítě s podrobným popisem za zvolené období.

Rozpracované opravy

sestava všech sítí, které mají rozpracovanou opravu (jsou v opravě).

Hardware

seznam přirazeného hardware.

Síťová technika

seznam přirazené síťové techniky.

Dokumentace

seznam přirazené dokumentace.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny všechny údaje sítě, seznam hardware a síťové techniky. Text, který potom následuje a který muže být v každé organizaci jiný, se zadává v konfiguraci programu ve volbě Údržba - konfigurace.

Prošlé servisy

tato sestava zobrazuje seznam sítí, které k určenému datu již měly mít proveden servis či revizi.

Provedené servisy

tato sestava zobrazuje seznam sítí, u kterých již byl proveden servis či revize. Údaje jsou z posledního zpracování

Nastavené servisy

tato sestava zobrazuje seznam sítí, u kterých je nastaven servis či revize.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivým sítím.

Seznam hesel

sestava všech hesel aktuální sítě.


Site - Zakladni udaje

Sítě - základní údaje

Ovládání programu

Evidenční číslo

evidenční číslo je určeno k jednoznačné identifikaci sítě (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.). Výběr, zda bude kontrolováno na duplicitu, provedete ve volbě Konfigurace .

Název, Verze, Počet uživatelů

jestliže změníte název, verzi síťového systému nebo počet uživatelů, bude do souboru OPR_LN vygenerována věta STAV=3,4 nebo 7 (oprava/upgrade/přidání). Vy musíte pouze rozhodnout, o jaký typ opravy se jedná.

Organizační členění, Umístění, Odpovědná osoba

při změně některé z těchto položek se pro danou síť automaticky vygeneruje do souboru OPR_LN věta STAV=6 Převod.

Počet stanic

tento počet nelze aktualizovat. Počet se vypočítá automaticky v okamžiku přiřazení počítačů na kartě Vazby HW.


Site - Ekonomicke udaje

Sítě – ekonomické údaje

Ovládání programu

Datum zakoupení a uvedení

datum zakoupení může být menší nebo stejný jako datum uvedení. Datum uvedení se zadává při ručním vytvoření nové sítě. V těchto případech se do souboru oprav vygeneruje věta STAV=1 Uvedení do provozu.

Základní ekonomické údaje


Site - Ostatni

Sítě - ostatní

Ovládání programu

Servisy

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na Volný číselník.

Hesla

horní mřížka obsahuje seznam uživatelů sítě, jejich login name a heslo. Pomocí tlačítek Nová, Oprava a Zrušit v pravé horní části lze provádět aktualizaci nejdůležitějších uživatelů sítě a jejich hesel.

Ochrana

pokud uživatel programu nemá právo aktualizovat sítě, neuvidí také žádné údaje o heslech a nevytiskne sestavu Seznam hesel.


Site - Opravy

Sítě - opravy

Ovládání programu

Tato karta obsahuje seznam (historii) oprav dané sítě. Zobrazuje přímo soubor OPR_LN.DBF, ve kterém jsou uloženy všechny opravy evidovaných sítí. Podrobnější popis naleznete v kapitole Opravy.


Site - Vazby HW

Sítě – vazby HW

Ovládání programu Hromadné výběry

V mřížce je seznam počítačů, které jsou v síti nainstalovány. Hardware, který má STAV=8 (počítač byl zlikvidován), je zobrazen zelenou barvou, nelze jej odřadit. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechen hardware k odřazení, zobrazit podrobné informace o hardware, zobrazit seznam nepřiřazeného hardware (počítače, které nejsou v žádné sítí) (Volný hardware).

Detail hardware

pomocí pravého tlačítka a volby Detail hardware nebo double klikem myší lze na této kartě zobrazit (i opravit) hardware, na němž se nachází kurzor.

Nový hardware

provedete stiskem pravého tlačítka myši a výběrem volby Nový hardware. Spustí se formulář, ve kterém vytvoříte nový počítač a po jeho uložení následuje dotaz, zda tuto licenci chcete hned přiřadit na nový počítač.

Volný hardware

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volný hardware. Najednou se přiřadí licence software na všechen označený hardware.

Odřadit hardware

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit hardware. Najednou se odřadí licence ze všech označený počítačů.

Pozor :

· před odřazením musíte označit počítač, který chcete ze sítě odřadit

· nelze odřadit počítač, který byl zlikvidován (STAV=8).


Site - Vazby sit. technika

Sítě – vazby síť. techniky

Ovládání programu Hromadné výběry

V mřížce je seznam síťové techniky přiřazené k dané síti. K síti lze přiřadit pouze techniku typu S... - síťová. Technika, která má STAV=8 (zařízení bylo zlikvidováno), je zobrazena zelenou barvou, nelze jí odřadit. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit techniku k odřazení, zobrazit podrobné informace, zobrazit seznam nepřiřazené techniky apod.

Detail techniky

pomocí pravého tlačítka a volby Detail techniky lze na této kartě zobrazit (i opravit) techniku, na níž se nachází kurzor.

Nová technika

provedete stiskem pravého tlačítka myši a výběrem volby Nová technika. Spustí se formulář, ve kterém vytvoříte novou techniku.

Volná technika

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná technika. Program Vám nabídne formulář Volné zařízení, ve kterém musíte vybrat volnou techniku. Po stisku tlačítka Přiřadit musíte zadat datum přiřazení, cenu práce a stanovit, zda se jedná o Opravu, Upgrade nebo Přidání. Podle posledního parametru je do souboru oprav vygenerována věta se STAVEM 3, 4 nebo 7.

Odřadit techniku

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit techniku. Program Vám nabídne formulář, ve kterém musíte zadat datum odřazení. Do souboru oprav je vygenerována jednu věta pro síť (STAV=7 odebrání techniky) a pro techniku je vygenerována věta STAV = 7 (odebrání ze sítě).

Smazat techniku

smazání vybrané síťové techniky provedete stiskem pravého tlačítka myši a výběrem volby Smazat techniky.

Zlikvidovat techniku

touto volbou provedete likvidaci síťové techniky, nad kterou se aktuálně nachází kurzor myši.


Site - Vazby dokumentace

Sítě – vazby dokumentace

Ovládání programu Hromadné výběry

V mřížce je zobrazena dokumentace přiřazená k dané síti. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit (Volná dokumentace).

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Sitova technika

Síťová technika

Evidence síťové techniky obsahuje :

· síťové komponenty (huby, routry, konektory, tiskárny)

Před tím, než začnete pořizovat nová příslušenství si projděte Číselník typů příslušenství. Zde dobře navrhněte jednotlivé typy příslušenství. Číslo typu síťového příslušenství začíná písmeny S nebo L (L001 Síťová tiskárna – používá se ve scanu HW).

V souboru příslušenství se evidují technické, ekonomické (faktura, dodavatel, …), a organizační údaje (odpovědná osoba, umístění, organizační členění, …). Dále je možno vést ke každému příslušenství jeho historii (seznam oprav, přiřazení k počítači, …), doklady k danému příslušenství zobrazit v elektronické podobě.


Sitova technika - Seznam

Síťová technika - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie dané síťové techniky. Program vytvoří stejnou větu, pouze vynuluje výrobní, inventární a specifické čísla a vygeneruje (nebo ručně zadá) evidenční číslo. Stav techniky je přepsán na OK.

Zobrazení stavu

Pokud je daná síťová technika v pořádku (není otevřena žádná oprava), svítí tam OK, jinak jsou tam hodnoty Závada, Oprava, Upgrade, Servis, Převod/Zapůjčení, Převod, Likvidace, které odpovídají souboru oprav. Položka je aktualizovaná automaticky v okamžiku aktualizace souboru oprav.

Pravé tlačítko myši

Toto tlačítko je funkční na mřížkou se seznamem síťové techniky. Pomocí něj lze editovat poznámku k danému síťové technice nebo pokud je síťová technika přiřazena k síti, zobrazit o ní detailní informace.

Program ProOpen

toto tlačítko slouží ke spuštění grafického programu ProOpen.

C) Tisky :

Parametry tisku

SESTAVY

Seznam síťové techniky

jednoduchý seznam síťové techniky.

Pasportní list

zobrazení všech položek (údajů) síťové techniky.

Záruka a odpisy

sestava síťové techniky, ve které jsou zobrazena data záruky a odpisu. Pokud je technika po záruce, obsahuje v sestavě značku „P“, pokud je odepsáno, obsahuje značku „O“.

Seznam oprav

sestava oprav (historie) síťové techniky. Lze vybrat, zda se mají tisknout všechny opravy nebo pouze některé. Také lze vybrat období. Tím lze sledovat např. technické zhodnocení během roku.

Deník oprav

sestava všech oprav síťové techniky s podrobným popisem za zvolené období.

Rozpracované opravy

sestava síťové techniky, která má rozpracovanou opravu (je v opravě).

Nepřiřazená síťová technika

sestava síťové techniky, jenž není zatím přiřazena na žádný počítač.

Dokumentace

seznam přirazené dokumentace.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny důležité parametry síťové techniky, organizační a ekonomické údaje. Druhou volitelnou část předávacího protokolu lze nastavit v konfiguraci programu ve volbě Údržba - konfigurace. Tato část může být v každé organizaci jiná. Pokud tuto část nenastavíte, pak program automaticky na konci první části vytiskne text Datum předání …, Předal…, Převzal ….

Podřízené vazby

seznam podřízených vazeb.

Prošlé servisy

tato sestava zobrazuje seznam síťové techniky, která k určenému datu již měla mít proveden servis či revizi.

Provedené servisy

tato sestava zobrazuje seznam síťové techniky, u které již byl proveden servis či revize. Údaje jsou z posledního zpracování.

Nastavené servisy

tato sestava zobrazuje seznam síťové techniky, u které je nastaven servis či revize.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivé síťové technice.

Neschválené položky

tato sestava je zobrazena jen v případe, že máte zakoupenou multilicenci. Neschválené položky se vybírají pouze pro centrálně udržované číselníky, které mají povolenou aktualizaci.


Sitova technika - Zakladni udaje

Síťová technika - základní údaje

Ovládání programu

Evidenční číslo

evidenční číslo je určeno k jednoznačné identifikaci techniky (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Rok výroby

v této položce je uveden rok, ve kterém byla technika vyrobena.

Výrobní číslo, Inventární číslo, Specifické číslo

tyto položky mohou být kontrolovány na duplicitu. Výběr, zda budou položky kontrolovány na duplicitu, provedete ve volbě Konfigurace .

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Servisní

položka označuje, zda technika je používána jako servisní za jiné poškozené

Typ

položka Typ je na této kartě nejdůležitější. Podle ní se nastavují filtry na příslušné číselníky názvů a oblastí (ve výběrech jsou pouze věty, které odpovídají zadanému typu).

Název

po výběru typu se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající názvy. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku.

Oblast1

po výběru typu se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka slouží u sítové techniky typu L k podrobnější identifikaci zařízení, využívá se scanem HW.

Oblast2

po výběru typu se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka se nevyužívá programem HW-SCAN, lze ji použít libovolně.

Organizační členění, Umístění, Odpovědná osoba nebo Síť

při změně některé z těchto položek se pro danou techniku automaticky vygeneruje do souboru OPR_PL věta STAV=6 (Převod). Pokud byla změněna síť, vygeneruje se věta také pro změněnou síť STAV=7 (Přiřazení/Odřazení).

Volné položky

jsou položky, které jsou závislé na zvoleném typu a jsou k volnému použití. V závorce mají jméno položky ze struktury souboru. To je pro případné vybírání položek při definování filtru nebo tvorbě vlastní sestavy.

Nadřízená technika

informace o technice, ke které je aktuální technika přiřazena. Tyto položky nelze editovat.


Sitova technika - Ekonomicke udaje

Síťová technika - ekonomické údaje

Ovládání programu

Datum zakoupení a uvedení

datum zakoupení může být menší nebo stejný jako datum uvedení. Datum uvedení se zadává při zpracování scanu HW nebo při ručním vytvoření věty příslušenství. V těchto případech se do souboru oprav vygeneruje věta STAV=1 Uvedení do provozu.

Základní ekonomické údaje

Datum zařazení a vyřazení z účetnictví

tyto položky nelze editovat. Aktualizují se automaticky při provedení exportu do účetnictví. Pokud je vyplněna položka Datum zařazení, nelze u tohoto zařízení opravovat cenu a rušit větu. Pokud je vyplněna položka Datum vyřazení, je zařízení v evidenci zlikvidováno (má STAV=8).


Sitova technika - Ostatni

Síťová technika - ostatní údaje

Ovládání programu

Servisy

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na volný číselník.

Přiřazený OEM software

tato položku zobrazuje OEM licenci software, která byla zakoupena současně s danou technikou.


Sitova technika - Opravy

Síťová technika - opravy

Ovládání programu

Tato karta obsahuje seznam (historii) oprav dané techniky. Zobrazuje přímo soubor OPR_PL.DBF, ve kterém jsou uloženy všechny opravy evidované techniky. Podrobnější popis naleznete v kapitole Opravy.


Sitova technika - Vazby dokumentace

Síťová technika – vazby dokumentace

Ovládání programu Hromadné výběry

V mřížce je seznam dokumentace přiřazené k dané technice. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit Volná dokumentace, pořídit novou dokumentaci.

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Sitova technika - Vazby prislusenstvi

Síťová technika – vazby příslušenství

Ovládání programu Hromadné výběry

Tato karta umožňuje k aktuální technice přiřazovat jinou techniku. To je vhodné v případě, že se technika skládá z další techniky. Toto přiřazení se provádí směrem od nadřízené techniky k podřízené.

V mřížce je zobrazeno podřízená technika k aktuální technice. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit techniku k odřazení, zobrazit podrobné informace, zobrazit seznam nepřiřazené techniky (Volné techniky), zobrazit další podřízené vazby apod..

Detail techniky

pomocí pravého tlačítka a volby Detail techniky lze na této kartě zobrazit (i opravit) techniku, na níž se nachází kurzor.

Další technika

pokud je k některé podřízené technice v mřížce přiřazena další podřízená technika, je možno zobrazit pomocí této volby formulář Podřízené vazby.

Podřízené technika

pomocí pravého tlačítka a volby Podřízená technika lze na této kartě zobrazit seznam techniky, ze které lze vybrat všechny podřízené vazby.

Odřadit techniku

program odřadí najednou všechnu vybranou podřízená techniku (vynuluje jim položku Nad_Pris).


Ostatni technika

Ostatní majetek

Evidence ostatního majetku obsahuje :

· samostatná zařízení (databanky, kopírky, faxy, mobily)

Před tím, než začnete pořizovat nový majetek si projděte Číselník typů majetku. Zde dobře navrhněte jednotlivé typy majetku. Číslo typu majetku začíná písmenem V.

V souboru ostatního majetku se evidují technické, ekonomické (faktura, dodavatel, …), a organizační údaje (odpovědná osoba, umístění, organizační členění, …). Dále je možno vést ke každému majetku jeho historii (seznam oprav, přiřazení k počítači, …), doklady k danému majetku zobrazit v elektronické podobě


Ostatni technika - Seznam

Ostatní majetek – seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie ostatního majetku. Program vytvoří stejnou větu, pouze vynuluje výrobní, inventární a specifické čísla a vygeneruje (nebo ručně zadá) evidenční číslo. Stav techniky je přepsán na OK.

Zobrazení stavu

Pokud je daný majetek v pořádku (není otevřena žádná oprava), svítí tam OK, jinak jsou tam hodnoty Závada, Oprava, Upgrade, Servis, Převod/Zapůjčení, Převod, Likvidace, které odpovídají souboru oprav. Položka je aktualizovaná automaticky v okamžiku aktualizace souboru oprav.

Pravé tlačítko myši

Toto tlačítko je funkční na mřížkou se seznamem ostatního majetku. Pomocí něj lze editovat poznámku k danému majetku.

C) Tisky :

Parametry tisku

SESTAVY

Seznam ostatního majetku

jednoduchý seznam ostatního majetku.

Pasportní list

zobrazení všech položek (údajů) ostatního majetku.

Záruka a odpisy

sestava ostatního majetku, ve které jsou zobrazena data záruky a odpisu. Pokud je majetek po záruce, obsahuje v sestavě značku „P“, pokud je odepsán, obsahuje značku „O“.

Seznam oprav

sestava oprav (historie) ostatního majetku. Lze vybrat, zda se mají tisknout všechny opravy nebo pouze některé. Také lze vybrat období. Tím lze sledovat např. technické zhodnocení během roku.

Deník oprav

sestava všech oprav ostatního majetku s podrobným popisem za zvolené období.

Rozpracované opravy

sestava ostatního majetku, který má rozpracovanou opravu (je v opravě).

Dokumentace

seznam přirazené dokumentace.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny důležité parametry ostatního majetku, organizační a ekonomické údaje. Druhou volitelnou část předávacího protokolu lze nastavit v konfiguraci programu ve volbě Údržba - konfigurace. Tato část může být v každé organizaci jiná. Pokud tuto část nenastavíte, pak program automaticky na konci první části vytiskne text Datum předání …, Předal…, Převzal ….

Podřízené vazby

seznam podřízených vazeb.

Prošlé servisy

tato sestava zobrazuje seznam ostatního majetku, který k určenému datu již měl mít proveden servis či revizi.

Provedené servisy

tato sestava zobrazuje seznam ostatního majetku, u kterého již byl proveden servis či revize. Údaje jsou z posledního zpracování.

Nastavené servisy

tato sestava zobrazuje seznam ostatního majetku, u které je nastaven servis či revize.

Elektronické dokumenty

seznam elektronických dokumentů.

Poznámky

výpis poznámek k jednotlivému ostatnímu majetku.

Neschválené položky

tato sestava je zobrazena jen v případe, že máte zakoupenou multilicenci. Neschválené položky se vybírají pouze pro centrálně udržované číselníky, které mají povolenou aktualizaci.


Samostatne prislusenstvi - karta Zakladni udaje

Ostatní majetek - základní údaje

Ovládání programu

Evidenční číslo

evidenční číslo je určeno k jednoznačné identifikaci majetku (nesmí být duplicitní). Jeho tvar je určen nastavenou Konfigurací.

Výrobní číslo, Inventární číslo, Specifické číslo

tyto položky mohou být kontrolovány na duplicitu. Výběr, zda budou položky kontrolovány na duplicitu, provedete ve volbě Konfigurace .

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Rok výroby

v této položce je uveden rok, ve kterém byl majetek vyroben.

Servisní

položka označuje, zda technika je používána jako servisní za jiný poškozený majetek.

Typ

položka Typ je na této kartě nejdůležitější. Podle ní se nastavují filtry na příslušné číselníky názvů a oblastí (ve výběrech jsou pouze věty, které odpovídají zadanému typu).

Název

po výběru typu majetku se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající názvy. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku. Položka slouží ke sjednocení názvů majetku

Oblast1

po výběru typu majetku se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku.

Oblast2

po výběru typu majetku se nastaví filtr na tento typ, takže lze vybrat pouze odpovídající oblasti. Položka je kontrolovaná proti číselníku. Pokud zadáte novou, musíte ji nejprve zařadit do číselníku.

Organizační členění, Umístění, Odpovědná osoba

při změně některé z těchto položek se pro daný majetek automaticky vygeneruje do souboru OPR_PV věta STAV=6 (Převod).

Volné položky

jsou položky, které jsou závislé na zvoleném typu majetku. V závorce mají jméno položky ze struktury souboru. To je pro případné vybírání položek při definování filtru nebo tvorbě vlastní sestavy.

Nadřízená technika

informace o majetku, ke kterému je aktuální majetek přiřazen. Tyto položky nelze editovat.


Samostatne prislusenstvi - karta Ekonomicke udaje

Ostatní majetek - ekonomické údaje

Ovládání programu

Datum zakoupení a uvedení

datum zakoupení může být menší nebo stejný jako datum uvedení. Datum uvedení se zadává při vytvoření věty majetku. V tomto případě se do souboru oprav vygeneruje věta STAV=1 Uvedení do provozu.

Základní ekonomické údaje

Datum zařazení a vyřazení z účetnictví

tyto položky nelze editovat. Aktualizují se automaticky při provedení exportu do účetnictví. Pokud je vyplněna položka Datum zařazení, nelze u tohoto majetku opravovat cenu a rušit větu. Pokud je vyplněna položka Datum vyřazení, je zařízení v evidenci zlikvidováno (má STAV=8).

Číslo a datum instalačního protokolu

tyto položky jsou určeny pro firmy, které mají vlastní číslování protokolů o instalaci výpočetní techniky.


Ostatni technika - Ostatni

Ostatní majetek - ostatní údaje

Ovládání programu

Servisy

Volný číselník

tuto položku lze použít k zadání libovolného údaje. Její název lze nadefinovat v Konfiguraci programu. Zadaná hodnota je kontrolována na volný číselník.

Přiřazený OEM software

tato položku zobrazuje OEM licenci software, která byla zakoupena současně s daným majetkem.


Ostatni technika - Opravy

Ostatní majetek - opravy

Ovládání programu

Tato karta obsahuje seznam (historii) oprav daného majetku. Zobrazuje přímo soubor OPR_PV.DBF, ve kterém jsou uloženy všechny opravy evidovaného majetku. Podrobnější popis naleznete v kapitole Opravy.


Ostatni technika - Vazby dokumentace

Ostatní majetek – vazby dokumentace

Ovládání programu Hromadné výběry

V mřížce je seznam dokumentace přiřazené k danému majetku. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechnu dokumentaci k odřazení, zobrazit podrobné informace o dokumentaci, zobrazit seznam dokumentace, kterou lze přiřadit Volná dokumentace, pořídit novou dokumentaci.

Detail dokumentace

pomocí pravého tlačítka a volby Detail dokumentace nebo double klikem myší lze na této kartě zobrazit (i opravit) dokumentaci, na níž se nachází kurzor.

Nová dokumentace

provedete stiskem pravého tlačítka myši a výběrem volby Nová dokumentace. Spustí se formulář, ve kterém vytvoříte novou dokumentaci.

Volná dokumentace

přiřazení provedete stiskem pravého tlačítka myši a výběrem volby Volná dokumentace. Najednou se přiřadí všechna vybraná dokumentace.

Odřadit dokumentace

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit dokumentaci. Najednou se odřadí všechna vybraná dokumentace.


Ostatni technika - Vazby prislusenstvi

Ostatní majetek – vazby ostatní majetek

Ovládání programu Hromadné výběry

Tato karta umožňuje k aktuálnímu majetku přiřazovat jiný majetek. To je vhodné v případě, že se majetek skládá z dalšího majetku. Toto přiřazení se provádí směrem od nadřízeného majetku k podřízenému.

V mřížce je zobrazen podřízený majetek k aktuálnímu majetku. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit techniku k odřazení, zobrazit podrobné informace, zobrazit seznam nepřiřazeného majetku (Volný majetek), zobrazit další podřízené vazby apod..

Detail techniky

pomocí pravého tlačítka a volby Detail lze na této kartě zobrazit (i opravit) techniku, na níž se nachází kurzor.

Další technika

pokud je k některé podřízené technice v mřížce přiřazena další podřízená technika, je možno zobrazit pomocí této volby formulář Podřízené vazby.

Podřízené technika

pomocí pravého tlačítka a volby Podřízený majetek lze na této kartě zobrazit seznam majetku, ze které lze vybrat všechny podřízené vazby.

Odřadit techniku

program odřadí najednou všechen vybraný podřízený majetek (vynuluje jim položku Nad_Pris).


Pozadavky

Požadavky

Evidence požadavků obsahuje informace o požadavcích uživatelů na nákup výpočetní techniky, provedení upgrade, nákup software, zajištění školení apod.

Každý požadavek obsahuje popis požadavku, osobu, která ho požaduje, případně vazbu na počítač, kterého se požadavek týká. V okamžiku splnění požadavku, lze evidovat údaje o plnění (faktura, cena, popis, …).


Pozadavky - Seznam

Požadavky - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie daného požadavku. Program vytvoří stejnou větu a vygeneruje (nebo ručně zadá) evidenční číslo.

C) Připojení k HelpDesku

Připojení k HelpDesku slouží k importu požadavků a k exportu údajů do aplikace HelpDesk. Pro připojení je nutné zadat název SQL serveru, kde jsou uložena data HelpDesku. Při importu nebo exportu se nejdříve musí program Správce spojit s SQL serverem. Pokud je název serveru špatně zadán, zobrazí se chybové hlášení a poté okno s výběrem dostupných serverů.

  1. Import z HelpDesku

Při importu se do Správce přenáší všechny nové požadavky a jejich reklamace z aplikace HelpDesk.

  2. Export do HelpDesku

Při exportu se do HelpDesku přenášejí Útvary, Uživatelé a Počítače.

a) Seznam útvarů odpovídá číselníku organizačního členění

b) Seznam uživatelů odpovídá číselníku osob. Exportují se pouze osoby, které mají v číselníku osob vyplněno uživatelské jméno. Pokud chcete tedy číselník odpovědných osob vyexportovat do Helpdesku, musíte všem osobám vyplnit uživatelské jméno. V další verzi Helpdesku se předpokládá automatický import dat Active Directory.

c) Seznam počítačů odpovídá seznamu PC v evidenci hardware. Přenášejí se pouze počítače, které mají vyplněnu odpovědnou osobu, nebo název PC.

D) Tisky :

Parametry tisku

SESTAVY

Seznam požadavků

Sestava seznamu požadavků.

Pasportní list

zobrazení všech položek (údajů) o požadavku.

Nové požadavky

sestava nových požadavků.

Zpracovávané požadavky

sestava zpracovávaných požadavků.

Reklamované požadavky

sestava reklamovaných požadavků.

Vyřešené požadavky

sestava vyřešených požadavků.

Uzavřené požadavky

sestava uzavřených požadavků.

Odstraněné požadavky

sestava odstraněných požadavků.


Pozadavky - Zakladni udaje

Požadavky - základní údaje

Ovládání programu

Předmět požadavku

položka blíže určuje čeho se daný požadavek týká (např. tiskárna, kopírka, …)

Kategorie a typ požadavku

slouží k upřesnění požadavku.

Stav požadavku

určuje v jakém stádiu řešení se požadavek nachází.

Číslo počítače, org. členění, umístění

určuje přesné místo, pro koho je požadavek určen.

Řešitel

osoba, která má na starosti řešení požadavku

Žadatel

osoba, která podala požadavek.

Detail

přesnější popis požadavku. Položka má libovolný počet řádků, takže můžete lépe specifikovat požadavek uživatele.


Pozadavky - Plnení

Požadavky - řešení

Ovládání programu

Karta řešení obsahuje datumové údaje vztahující se k řešní požadavku, popis řešení požadavku a zprávu pro žadatele.


Pozadavky - Plnení

Požadavky - reklamace

Ovládání programu

Karta obsahuje seznam reklamací k aktuálnímu požadavku.


Ciselniky

Číselníky

Formuláře pro aktualizaci číselníků mají také několik karet podobně jako hlavní datové soubory. První dvě karty většinou slouží k vlastní aktualizaci daného číselníku. Další karty obsahují Vazby z hlavních datových souboru a poslední karta označená jako Volné obsahuje věty z příslušného hlavního souboru, které nemají danou položku vyplněnou (např. v číselníku osob jsou to věty, ve kterých není vyplněna položka odpovědná osoba apod.). Karta Volné vazby je určena pro všechny hlavní datové soubory, které mají vlastní kartu Vazby. Volbu potřebného datového souboru provedete výběrem z listovacího seznamu Výběr vazby ve spodní části karty.

Rušení věty

pokud se pokusíte zrušit položku číselníku, jejíž hodnota se nachází v některém z hlavních datových souborů, nebude tato operace provedena.

Oprava věty

jestliže opravíte text v položce, tato změna bude provedena i ve všech příslušných větách hlavních datových souborů. Pokud v síťové verzi programu při opravě věty libovolného datového souboru, tuto větu během Vaší opravy jiný uživatel zruší, Vaše data budou smazána.


Firmy

Soubor firem obsahuje informace o dodavatelských firmách. Jedná se o základní údaje jako je název, adresa, kontaktní osoby, maily, telefony apod. Kromě evidence těchto základních údajů, zobrazuje přehled o dodané výpočetní technice.


Firmy - seznam

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam firem

sestava všech evidovaných firem.

Vazby - hardware

seznam firem, které dodaly hardware.

Vazby - software

seznam firem, které dodaly software.

Vazby - příslušenství

seznam firem, které dodaly příslušenství.

Vazby – síťová technika

seznam firem, které dodaly síťovou techniku.

Vazby – ostatní majetek

seznam firem, které dodaly ostatní majetek

Vazby - dokumentace

seznam firem, které dodaly dokumentaci.

Vazby - sítě

seznam firem, které dodaly sítě.

Vazby - opravy

seznam firem, které provedly opravy.

Vazby - požadavky

seznam firem, které jsou dodavatelem pro požadavky.

Vazby - součet cen

seznam firem s celkovým součtem cen pro jednotlivé vazby.


Firmy - Zakladni udaje

Firmy - základní údaje

Ovládání programu

V základních údajích o firmě lze evidovat adresu firmy, IČO, DIČ, odpovědné osoby. V položce Poznámka lze mít doplňující informace o firmě.

Název firmy nesmí být duplicitní. Pokud máte více firem stejného názvu a jsou např. z různých měst, musíte je označit jednoznačně v názvu (např. Autocont Praha, Autocont Brno).


Firmy - Vazby

Firmy – vazby

Ovládání programu Hromadné výběry

Karty označené jako Vazby zobrazují seznam všech dodaných počítačů, software, příslušenství, dokumentace, sítí a požadavků dané firmy

Přiřadit

pokud chcete změnit u některých vět název dodavatele, musíte nejprve provést výběr vět ke změně. Výběr provedete jednotlivě myší v prvním sloupci nebo hromadně. Potom musíte vybrat v dolní části karty Novou hodnotu, tj. nového dodavatele a volbou Přiřaď provedete konečnou změnu dodavatele u všech vybraných vět.

Odřadit

pokud chcete smazat název dodavatele, musíte nejprve provést výběr vět ke změně. Výběr provedete jednotlivě myší v prvním sloupci nebo hromadně. Potom stačí spustit volbu Odřadit a program u všech označených vět vynuluje dodavatele.

Cena celkem

pomocí volby Cena celkem zjistíte celkovou sumu všech vazeb aktuální firmy.


Firmy - Vazby oprav

Firmy - vazby opravy

Ovládání programu Hromadné výběry

Tato karta zobrazuje seznam oprav hardware, software, příslušenství nebo sítí dané firmy.

Soubor oprav

nejprve musíte vybrat soubor oprav. Po výběru volby Soubor oprav obsahuje mřížka seznam oprav vybraného souboru (hardware, software, příslušenství nebo sítí).

Přiřadit

pokud chcete změnit u některých vět název dodavatele, musíte nejprve provést výběr vět ke změně. Výběr provedete jednotlivě myší v prvním sloupci nebo hromadně. Potom musíte vybrat v dolní části karty Novou hodnotu, tj. nového dodavatele a volbou Přiřaď provedete konečnou změnu dodavatele u všech vybraných vět.

Odřadit

pokud chcete smazat název dodavatele, musíte nejprve provést výběr vět ke změně. Výběr provedete jednotlivě myší v prvním sloupci nebo hromadně. Potom stačí spustit volbu Odřadit a program u všech označených vět vynuluje dodavatele.

Cena celkem

pomocí volby Cena celkem zjistíte celkovou sumu všech vazeb aktuální firmy.


Firmy - karta Volné vazby

Firmy – volné vazby

Ovládací tlačítka Hromadné výběry

Karta Volné vazby slouží ke stanovení vět, ve kterých není položka Dodavatel vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor, u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Přeřadit

pokud chcete změnit u některých vět název dodavatele, musíte nejprve provést výběr vět ke změně. Výběr provedete jednotlivě myší v prvním sloupci nebo hromadně. Potom musíte vybrat v dolní části karty Novou hodnotu, tj. nového dodavatele a volbou Přeřaď provedete konečnou změnu dodavatele u všech vybraných vět.


Odpovedne osoby

Odpovědné osoby

Soubor odpovědných osob obsahuje evidenci všech osob, které se vyskytují v celém programu jako odpovědné osoby, správcové apod. ve všech souborech (hardware, software, příslušenství, …).

Podrobnější popis


Odpovedne osoby

Odpovědné osoby

1. Karta Seznam

zobrazuje seznam všech odpovědných osob. Pro aktualizaci platí následující pravidla :

a) při zavádění nové věty nesmí být jméno odpovědné osoby duplicitní.

b) pro multilicence - tento číselník nelze udržovat centrálně.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Číselník odpovědných osob

celkový seznam všech odpovědných osob.

Předávací protokol

předávací protokol všech zařízení, které má uvedená osoba přiřazené.

Vazby - hardware

sestava s vazbou na odpovědnou osobu a správce hardware. Rozlišení, jestli se jedná o odpovědnou osobu nebo správce, je za sloupcem Typ PC, kde pro správce je uvedena hodnota "SPR".

Vazby - software

sestava s vazbou na odpovědnou osobu za software. Tato odpovědná osoba zodpovídá za software a nemusí být totožná s osobou, která je zodpovědná za počítač, na kterém je software nainstalován.

Vazby - příslušenství

sestava odpovědných osob za příslušenství.

Vazby – síťová technika

sestava odpovědných osob za síťovou techniku.

Vazby – ostatní majetek

sestava odpovědných osob za ostatní majetek.

Vazby - dokumentace

sestava odpovědných osob za dokumentace a osob, kterým byla dokumentace zapůjčena. Rozlišení, jestli se jedná o odpovědnou osobu nebo zapůjčenou osobu, je za sloupcem Název, kde pro zapůjčenou osobu je uvedena hodnota ”ZAP”.

Vazby - sítě

sestava odpovědných osob a správců sítí. Rozlišení, jestli se jedná o odpovědnou osobu nebo správce, je za sloupcem Verze, kde pro správce je uvedena hodnota ”SPR”.

Vazby - požadavky

sestava odpovědných osob za požadavky a osob požadujících tyto požadavky. Rozlišení, jestli se jedná o odpovědnou osobu nebo požadující, je za sloupcem Umístění, kde pro požadující osobu je uvedena hodnota ”POŽ”.

Vazby - hardware s nainstalovaným SW

sestava obsahuje seznam instalací software na všech počítačích, na kterých figuruje daná odpovědná osoba.

Vazby - aplikace

sestava obsahuje seznam odpovědných osob a aplikací, ke kterým má odpovědná osoba přístup.

2. Karty Vazby

zobrazují seznamy vazeb na hlavní datové soubory. Na každé kartě lze v mřížce provést hromadnou Změnu vazby.

Vaz. HW

na kartě s vazbami hardware je hardware, u kterého uvedená osoba figuruje jako odpovědná osoba. Pokud chcete zobrazit hardware, kde uvedená osoba je správcem počítače, je třeba označit položku SPRÁVCE v přepínači v levém horním rohu formuláře.

Vaz. SW

na kartě s vazbami software je uveden software, u kterého uvedená osoba figuruje jako odpovědná osoba. Jedná se o odpovědnou osobu za software. Nemá to nic společného s odpovědnou osobou za hardware, na kterém je daný software nainstalován.

Vaz. PŘ

na kartě s vazbami příslušenství je uvedeno příslušenství, u kterého je aktuální osoba uvedena jako odpovědná osoba. Příslušenství, které je přiřazeno k počítači, je zobrazeno šedě. U tohoto příslušenství nelze odpovědnou osobu změnit. Musíte ji změnit pouze při aktualizaci hardware. Příslušenství, které je zobrazeno bílou barvou, není přiřazeno k počítači a lze u něho změnit odpovědnou osobu.

Vaz. Síť. Tech.

na kartě s vazbami síťové techniky je uvedena technika, u které je aktuální osoba uvedena jako odpovědná osoba.

Vaz. Ost.majetek

na kartě s vazbami ostatního majetku je uveden majetek, u které je aktuální osoba uvedena jako odpovědná osoba.

Vaz. DOK

na kartě s vazbami dokumentace je seznam dokumentace pro danou odpovědnou osobu. Pokud chcete zobrazit dokumentaci, která je zapůjčena této osobě, je třeba označit položku ZAPÚJČENO v přepínači v levém horním rohu formuláře.

Vaz. LAN

na kartě s vazbami sítí je seznam sítí, kde daná osoba figuruje jako odpovědná osoba. Pokud chcete zobrazit sítě, kde je daná osoba správcem sítě, je třeba označit položku SPRÁVCE v přepínači v levém horním rohu formuláře.

Vaz. POŽ

na kartě s vazbami požadavků je seznam požadavků, za které je daná osoba odpovědná. Pokud chcete zobrazit požadavky, které daná osoba požaduje, je třeba označit položku POŽADUJE v přepínači v levém horním rohu formuláře.

Vaz. Aplikace

na kartě s vazbami aplikací je seznam aplikací, které jsou pro odpovědnou osobu přístupné pro zpracování.

3. Karta Volné

karta obsahuje vazby, ve kterých není položka osoba vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Ve mřížce můžete provést hromadnou Změnu vazby.


Umisteni

Umístění

Soubor umístění je určen především pro ”Správce”, kterým má usnadnit přehled o stavu výpočetní techniky. Proto je třeba při návrhu zohlednit především jejich potřeby, na rozdíl od souboru organizačního členění, který by měl odpovídat organizační struktuře. Soubor umístění lze proto navrhnout např. podle některého z následujících kritérií :

a) členění podle oddělení - účtárny, dílny, dispečink, výpočetní středisko apod.

b) členění podle budov - budova, patro, chodba, číslo dveří.

Podrobnější popis


Umisteni

Umístění

1. Karta Seznam

zobrazuje seznam všech hodnot umístění. Pro aktualizaci platí následující pravidla :

a) číslo umístění nesmí být duplicitní, název nesmí být prázdný

b) pro multilicenci - tento číselník nelze udržovat centrálně.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam umístění

sestava celého souboru umístění.

Vazby - hardware

sestava umístění a přiřazeného hardware.

Vazby - software

sestava umístění a přiřazeného software.

Vazby - příslušenství

sestava umístění a přiřazeného příslušenství.

Vazby – síťové techniky

sestava umístění a přiřazené síťové techniky.

Vazby – ostatní majetek

sestava umístění a přiřazeného ostatního majetku.

Vazby - dokumentace

sestava umístění a přiřazené dokumentace.

Vazby - sítě

sestava umístění a přiřazených sítí.

Vazby - požadavky

sestava umístění a přiřazených požadavků.

2. Karty Vazby

zobrazují seznamy vazeb na hlavní datové soubory. Na každé kartě lze v mřížce provést hromadnou Změnu vazby.

Vaz. HW

karta zobrazuje seznam hardware, které je na daném umístění instalováno.

Vaz. SW

karta zobrazuje seznam software, které je na daném umístění instalován. Vazba je realizována přes počítač. Takže se zobrazuje seznam software, který je nainstalován na počítačích, které jsou na daném umístění instalovány. Protože je zde vazba přes počítač, nelze zde vazbu změnit. Musí se změnit vazba na počítač a s ní se provede změna vazby software.

Vaz. PŘ

karta zobrazuje seznam příslušenství, které je na daném umístění instalováno. Příslušenství, které je přiřazeno k počítači, je zobrazeno šedě. U tohoto příslušenství nelze vazbu změnit. Musíte ji změnit pouze při aktualizaci hardware. Příslušenství, které je zobrazeno bílou barvou, není přiřazeno k počítači a lze u něho vazbu změnit.

Vaz. Síť. Tech.

karta zobrazuje seznam síťové techniky, která je na daném umístění instalována.

Vaz. Ost.majetek

karta zobrazuje seznam ostatního majetku, který je na daném umístění.

Vaz. DOK

karta zobrazuje seznam dokumentace, která je na daném umístění dodána.

Vaz. LAN

karta zobrazuje seznam sítí, které jsou na daném umístění instalovány.

Vaz. POŽ

karta zobrazuje seznam požadavků, které se týkají daného umístění.

3. Karta Volné

karta obsahuje vazby, ve kterých není položka umístění vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Ve mřížce můžete provést hromadnou Změnu vazby.


Organizacni cleneni

Organizační členění

Soubor organizačního členění je určen převážně pro větší firmy a organizace, ve kterých má význam sledovat výpočetní techniku podle organizačního členění. Jeho návrh je proto specifický pro každou organizaci. Číslo organizační členění může být až 8-mi místné, což je dostačující pro většinu organizací. Soubor je důležitý zejména pro nadřízené složky organizace, které podle něj mohou plánovat další rozvoj výpočetní techniky. Menší organizace mohou tento soubor využít libovolně.

Pozor – tento soubor je důležitý pro RemoteScan, provádí se podle něho výběr počítačů do skupin

Podrobnější popis


Organizacni cleneni

Organizační členění

1. Karta Seznam

zobrazuje seznam všech hodnot organizačního členění. Pro aktualizaci platí následující pravidla :

a) číslo organizačního členění nesmí být duplicitní, název nesmí být prázdný.

b) soubor lze pro multilicence programu SPRÁVCE udržovat centrálně.

c) sloupec OK ve mřížce, který je zobrazen pouze pro multilicence, ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam org. členění

sestava celého souboru organizačního členění.

Vazby - hardware

sestava organizačního členění a přiřazeného hardware.

Vazby - software

sestava organizačního členění a přiřazeného software.

Vazby - příslušenství

sestava organizačního členění a přiřazeného příslušenství.

Vazby – síťové techniky

sestava organizačního členění a přiřazené síťové techniky.

Vazby – ostatního majetku

sestava organizačního členění a přiřazeného ostatního majetku.

Vazby - dokumentace

sestava organizačního členění a přiřazené dokumentace.

Vazby - sítě

sestava organizačního členění a přiřazených sítí.

Vazby - požadavky

sestava organizačního členění a přiřazených požadavků.

Neschválené položky

sestava neschválených vět podle nadřízené organizace (pouze pro multilicence).

2. Karty Vazby

zobrazují seznamy vazeb na hlavní datové soubory. Na každé kartě lze v mřížce provést hromadnou Změnu vazby.

Vaz. HW

karta zobrazuje seznam hardware, které je na daném organizačního členění instalováno.

Vaz. SW

karta zobrazuje seznam software, které je na daném organizačního členění instalován. Vazba je realizována přes počítač. Takže se zobrazuje seznam software, který je nainstalován na počítačích, které jsou na daném organizačního členění instalovány. Protože je zde vazba přes počítač, nelze zde vazbu změnit. Musí se změnit vazba na počítač a s ní se provede změna vazby software.

Vaz. PŘ

karta zobrazuje seznam příslušenství, které je na daném organizačního členění instalováno. Příslušenství, které je přiřazeno k počítači, je zobrazeno šedě. U tohoto příslušenství nelze vazbu změnit. Musíte ji změnit pouze při aktualizaci hardware. Příslušenství, které je zobrazeno bílou barvou, není přiřazeno k počítači a lze u něho vazbu změnit.

Vaz. Síť. Tech.

karta zobrazuje seznam síťové techniky, která je na daném organizačního členění instalována.

Vaz. Ost. Tech.

karta zobrazuje seznam ostatní techniky, která je na daném organizačního členění instalována.

Vaz. DOK

karta zobrazuje seznam dokumentace, která je na daném organizačního členění dodána.

Vaz. LAN

karta zobrazuje seznam sítí, které jsou na daném organizačního členění instalovány.

Vaz. POŽ

karta zobrazuje seznam požadavků, které se týkají daného organizačního členění.

3. Karta Volné

karta obsahuje vazby, ve kterých není položka organizačního členění vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Ve mřížce můžete provést hromadnou Změnu vazby.


Servisy

Soubor servisů slouží k nastavení plánovaných pravidelných servisů, profylaxí, revizí apod. Servisem se v tomto případě rozumí nějaká pravidelná údržba, kontrola či hlídání platnosti. Servis je jednoznačně definován typem servisu, názvem, poznámkou, intervalem servisu (počet měsíců mezi dalším servisem), počátečním datem (slouží k určení počátku sledování servisu, uloží se do hlavní věty příslušného souboru jako datum zahájení sledování servisu).

Revize je zvláštní případ servisu, slouží k vedení evidence o revizi elektrických zařízení, k tomu slouží další rozšiřující položky :

Revize skupina - hodnota A, B, C, D, E.

Revize třída - hodnota 1, 2, 3.

Napětí - doporučeno 220.

Výkon - doporučeno 150.

Návrh celého číselníku servisů záleží na podmínkách Vaší organizace.

Servis se vztahuje k souborům HARDWARE, SOFTWARE, PŘÍSLUŠENSTVÍ, SÍŤOVÉ TECHNIKY, OSTATNÍHO MAJETKU a SÍTÍ. Ke každému zařízení (software, síti) mohou být současně přiřazeny čtyři různé servisy, jsou označeny jako servis 1, 2, 3 a 4. Přiřazení je možno provést na hlavních formulářích výše uvedených souborů v ekonomických údajích nebo u formuláře pro číselník servisů na kartách Vazby. Na těchto kartách je přiřazování rozděleno na další čtyři karty pro servis 1 až 4.

Podrobnější popis


Servisy

Číselník servisů

Návrh souboru servisů záleží na podmínkách Vaší organizace.

Servis se vztahuje k souborům HARDWARE, SOFTWARE, PŘÍSLUŠENSTVÍ, SÍŤOVÉ TECHNIKY, OSTATNÍHO MAJETKU a SÍTÍ. Ke každému zařízení (software, síti) mohou být současně přiřazeny čtyři různé servisy, jsou označeny jako servis 1, 2, 3 a 4. Přiřazení je možno provést na hlavních formulářích výše uvedených souborů v ekonomických údajích nebo u formuláře pro soubor servisů na kartách Vazby. Na těchto kartách je přiřazování rozděleno na další čtyři karty pro servis 1 až 4.

Revize je zvláštní případ servisu, slouží k vedení evidence o revizi elektrických zařízení, k tomu slouží další rozšiřující položky :

Revize skupina - hodnota A, B, C, D, E.

Revize třída - hodnota 1, 2, 3.

Napětí - doporučeno 220.

Výkon - doporučeno 150.

Soubor servisů je dodáván naplněný s jednou větou, sloužící u SOFTWARE k uchování údajů o dokupování licencí. Typ tohoto servisu je označen §01 a tuto nelze aktualizovat ani rušit a je zobrazena červeně.

1. Karta Seznam

zobrazuje seznam všech hodnot servisů. Pro aktualizaci platí následující pravidla :

a) číslo servisu nesmí být duplicitní, název nesmí být prázdný.

b) číslo servisu se skládá ze tří znaků, kde první znak musí být písmeno z abecedy A-Z, druhý a třetí znak může být číslice.

c) sloupec OK ve mřížce, který je zobrazen pouze pro multilicence, ukazuje věty schválené nadřízenou organizací

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam servisů

sestava celého souboru servisů.

Vazby - hardware

sestava seznamu servisů pro hardware.

Vazby - software

sestava seznamu servisů pro software.

Vazby - příslušenství

sestava seznamu servisů pro příslušenství.

Vazby – síťová technika

sestava seznamu servisů pro síťovou techniku.

Vazby – ostatní majetek

sestava seznamu servisů pro ostatní majetek.

Vazby - sítě

sestava seznamu servisů pro sítě.

Neschválené položky

sestava neschválených položek souboru servisů.

2. Karty Vazby

zobrazují seznamy vazeb na hlavní datové soubory. Na každé kartě lze v mřížce provést hromadnou Změnu vazby.

Vaz. HW

karta zobrazuje seznam hardware, který má nastaven daný servis.

Vaz. SW

karta zobrazuje seznam software, který má nastaven daný servis.

Vaz. PŘ

karta zobrazuje seznam příslušenství, které má nastaven daný servis.

Vaz. Síť. Tech.

karta zobrazuje seznam síťové techniky, která má nastaven daný servis.

Vaz. Ost. majetku

karta zobrazuje seznam ostatního majetku, která má nastaven daný servis.

Vaz. LAN

karta zobrazuje seznam sítí, které mají nastaven daný servis.

Každý hardware, software, příslušenství a síť může mít nastavené až 4 servisy, přičemž servis může být nastaven na 1. až 4. pozici. Proto každá karta obsahuje další 4 karty pro pozici servisu na 1.-4. místě (Servis 1, 2, 3, 4).

3. Karta Volné

karta obsahuje vazby, ve kterých není položka servisu vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Ve mřížce můžete provést hromadnou Změnu vazby.


Volny ciselnik

Volný číselník

Volný číselník je určen pro libovolné použití v každé organizaci. Jeho návrh je proto specifický pro každou organizaci.

Číslo může být až 30-ti místné, název až 60-ti místný.

Je zde možné použít např. evidenci nomenklatur, evidenci SAP údajů apod.

Podrobnější popis


Ciselniky - volny

Volný číselník

1. Karta Seznam

zobrazuje seznam všech hodnot volného číselníku. Pro aktualizaci platí následující pravidla :

a) číslo nesmí být duplicitní, název nesmí být prázdný.

b) soubor lze pro multilicence programu SPRÁVCE udržovat centrálně.

c) sloupec OK ve mřížce, který je zobrazen pouze pro multilicence, ukazuje věty schválené nadřízenou organizací.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Volný číselník

sestava celého volného číselníku.

Vazby - hardware

sestava volného číselníku a přiřazeného hardware.

Vazby - software

sestava volného číselníku a přiřazeného software.

Vazby - příslušenství

sestava volného číselníku a přiřazeného příslušenství.

Vazby – síťová technika

sestava volného číselníku a přiřazené síťové techniky.

Vazby – ostatní majetek

sestava volného číselníku a přiřazeného ostatního majetku.

Vazby - sítě

sestava volného číselníku a přiřazených sítí.

Neschválené položky

sestava položek volného číselníku, které nejsou schváleny nadřízenou organizací.

2. Karty Vazby

zobrazují seznamy vazeb na hlavní datové soubory. Na každé kartě lze v mřížce provést hromadnou Změnu vazby.

Vaz. HW

karta zobrazuje seznam hardware, u kterého je vyplněn číselník volný.

Vaz. SW

karta zobrazuje seznam software, u kterého je vyplněn číselník volný.

Vaz. PŘ

karta zobrazuje seznam příslušenství, u kterého je vyplněn číselník volný.

Vaz. Síť. Tech.

karta zobrazuje seznam síťové techniky, u které je vyplněn číselník volný.

Vaz. Ost. majetku

karta zobrazuje seznam ostatního majetku, u které je vyplněna položka číselník volný.

Vaz. LAN

karta zobrazuje seznam sítí, u které je vyplněn číselník volný.

3. Karta Volné

karta obsahuje vazby, ve kterých není položka volného číselníku vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Ve mřížce můžete provést hromadnou Změnu vazby.


Typy dokumentu

Typy dokumentů

Číselník slouží k evidenci typů elektronických dokumentů (faktur, hospodářských smluv, fotografií apod.

Podrobnější popis


Typy dokumentu

Typy dokumentů

Název typu nesmí být prázdný a duplicitní.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam typů dokumentů

sestava celého souboru typů dokumentů.


Ciselniky - Aplikace

Aplikace

Soubor aplikací slouží k evidenci aplikací používaných na počítačích, sítích, Internetu apod.

Podrobnější popis


Aplikace

1. Karta Seznam

zobrazuje seznam všech hodnot aplikací. Pro aktualizaci platí následující pravidla :

a) název nesmí být prázdný a duplicitní.

K této kartě se v toolbaru zpřístupní tlačítka :

Zrušení aktuální věty

Hledání věty

Nastavení filtru

Tisk sestav – obsahuje následující sestavy

Seznam aplikací

sestava celého souboru sledovaných aplikací.

Vazby - odp. osoby

přístupy odpovědných osob k jednotlivým aplikacím.

2. Přístupy k aplikacím

Na této kartě se pro každou aplikaci zobrazí seznam odpovědných osob, které k aktuální aplikaci mají přístup. Je zde aktivní pravé tlačítko myši, pomocí kterého lze označit všechny osoby k odřazení, zobrazit podrobné informace o odpovědné osobě, zobrazit seznam odpovědných osob pro které lze nastavit přístup k aplikaci Odpovědné osoby. Osoby lze označit/odznačit také jednotlivě zaškrtnutím prvního sloupce v mřížce.

Odřazení

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit osobu. Najednou se odřadí všechny vybrané odpovědné osoby.

Oprava přístupu

pomocí pravého tlačítka a volby Detail přístupu lze opravit jméno uživatele, heslo a datum změny hesla.

3. Osoby

Na této se zobrazuje celý číselník odpovědných osob. Je zde aktivní pravé tlačítko myši, pomocí kterého lze volbou Přiřadit najednou nastavit všechny osoby, které mají přístup k aplikaci.


Upravy

Úpravy

Toto menu je přístupné pouze v případě, že ve formulářích potřebujete používat clipboard pro kopírování obsahu položky. Menu se v tomto případě samo zpřístupní a Vy v takovém formuláři můžete používat kombinace kláves CTRL+C, CTRL+X a CTRL+V pro usnadnění přenosu obsahu jedné položky do jiné.


Upravy

Úpravy - CTRL+X

CTRL+X

tato volba umožňuje zkopírovat vybraný (označený) text do clipboardu a zároveň ho v původní položce smazat.


Upravy

Úpravy - CTRL+C

CTRL+C

tato volba umožňuje zkopírovat vybraný (označený) text do clipboardu.


Upravy

Úpravy - CTRL+V

CTRL+V

tato volba umožňuje vložit text z clipboardu do aktuálního místa.


Ostatni

Ostatní

Menu Ostatní obsahuje důležité sestavy (inventární, kontrola SW, libovolné, duplicitní čísla, prázdné evidenční čísla apod.) a přehledy (sítí, typů příslušenství, oprav a faktur).


Ostatni - Inventarni sestavy

Inventární sestavy

Tato volba je určena pro tisk inventárních sestav. Inventární sestavy se dělí na dva druhy. První sestava je předinventární, která se tiskne před vlastní inventurou a slouží jako podklad pro provedení inventury. Obsahuje současný stav ve Vaší evidenci. Během inventury si do ní provádíte změny, které objevíte. Po provedení inventury by jste měli opravit zjištěné změny ve Vaší evidenci. Nakonec můžete vytisknout druhou sestavu - inventární, která bude obsahovat změny, které jste během inventury zjistili.

Při tisku inventární sestavy musíte zadat datum inventury a členy inventární komise. Po vytvoření inventární sestavy (i v případě, že jste si ji nechali zobrazit na obrazovce) se Vás program zeptá, zda proběhl tisk v pořádku. Jestliže odpovíte ANO, program automaticky zapíše datum inventury do všech vět, které prošly inventurou. V případě, že odpovíte NE, v datumu inventury vybraných vět nedojde k žádným změnám a inventární sestavu můžete provést znovu. Datum inventury a členy komise, které jste zadali v tomto formuláři, budou vytištěny na konci sestavy. Po vytištění sestavy se Vám také vytiskne (nebo nabídne k tisku) příloha, ve které je vyznačen rozsah sestavy a seznam vybraných položek z daného číselníku.

Podle druhu probíhající inventury si můžete vybrat z následujících sestav :

- hardware s přiřazeným příslušenstvím hw

- software

- dokumentace

- sítě s přiřazenou síťovou technikou

- ostatní majetek (faxy, kopírky, databanky apod.)

- nepřirazené příslušenství hardware (příslušenství, které není přiřazeno k počítači)

- nepřiřazená síťová technika (technika, která není přiřazena k žádné sítí)

Setřídění sestav lze zvolit z následujících možností :

- organizační členění

- umístění

- odpovědná osoba

- inventární číslo

- evidenční číslo

Rozsah sestav lze zvolit z následujících možností :

- organizační členění

- umístění

- odpovědná osoba

- vše

Jestliže si zvolíte rozsah inventární sestavy z prvních třech možností, dostanete formulář Inventární sestavy - výběr z číselníku, ve kterém si vyberete z číselníku věty, pro které chcete vytvořit sestavu. V případe, že označíte volbu VŠE, inventární sestava se Vám vytvoří pro všechny věty vybraného souboru.

Dále je zde možné pro sestavy HW nastavit následující parametry sestav :

- zda chcete hardware tisknout za sebou nebo každý na novou stranu.

- zda se vytiskne veškeré přiřazené příslušenství nebo zda se bude tisknout jen to přiřazené příslušenství, které má jiné inventární číslo na HW .


Ostatni -Sestavy dle druhu majetku

Sestavy dle druhu majetku

Tato volba je určena pro tisk sestav dle druhu majetku. Je možno zvolit pro jaká zařízení (hardware, software, příslušenství hw, síťová technika, ostatní majetek) a jaký druh majetku (hmotný majetek, drobný hmotný majetek, nehmotný majetek, drobný nehmotný majetek, finanční pronájem, operativní pronájem, operativní evidence, investiční nehmotný majetek) se sestava bude tisknout. Každý typ zařízení se tiskne na nové stránce. Vždy se tiskne zařazené, vyřazené a nezařazené zařízení.


Ostatni - Sestava volnych cisel

Sestava volných čísel

Tento formulář umožňuje vytisknout sestavu volných čísel, což jsou díry v číselné řadě jednotlivých souborů, které vznikly rušením vět nebo použitím scanu HW.

Před vlastním tiskem sestavy je nutné vybrat soubory, pro které chcete sestavu tisknout. Program automaticky nabízí všechny soubory. Stiskem tlačítka OK se vytiskne sestava na obrazovku. Po prohlédnutí lze sestavu vytisknout pomocí ikony v toolbaru sestavy.


Ostatni - sestava duplicitnich cisel

Sestava duplicitních čísel

Tento formulář umožňuje vytisknout sestavu duplicitních inventárních, výrobních, specifických a licenčních čísel. Před vlastním tiskem sestavy je nutné vybrat soubory, pro které chcete sestavu tisknout. Program automaticky nabízí všechny soubory. Stiskem tlačítka OK se vytiskne sestava na obrazovku. Po prohlédnutí lze sestavu vytisknout pomocí ikony v toolbaru sestavy.

Vytištěná sestava zobrazuje postupně duplicity inventárních, výrobních a specifických čísel jednotlivých souborů. Pouze u software se místo výrobního čísla tiskne číslo licenční.


Ostatni - Sestava volnych IP adres

Sestava volných IP adres

Tento formulář umožňuje vytisknout sestavu volných IP adres, to znamená seznam zařízení, které nemají vyplněnou IP adresu. Jedná se o následující zařízení :

a) příslušenství hardware typu K008 (Síťová karta)

b) všechna síťová technika (síťové tiskárny, routry apod.)

Před vlastním tiskem sestavy je nutné zadat interval IP adres, který se bude prohledávat. Interval lze stanovit pouze podle posledního čísla IP adresy. První tři čísla IP adresy jsou stejné pro interval Od – Do.

Stiskem tlačítka OK vytisknete sestavu.


Ostatni - Prehled oprav

Přehled oprav

Ovládání programu Parametry tisku

Tento formulář slouží pouze k prohlížení všech oprav. Obsahuje následující karty:

Hardware - seznam všech oprav počítačů

Software - seznam všech oprav software

Příslušenství - seznam všech oprav příslušenství

Sítě - seznam všech oprav sítí

Jestliže si na kterékoliv kartě nastavíte filtr, při opuštění této karty je nastavený filtr automaticky zrušen.


Ostatni - Prehled faktur

Přehled faktur

Ovládání programu Parametry tisku

Tato volba Vám přehledným způsobem ukazuje vazby mezi firmami a přijatými fakturami. Nemá vlastní aktualizaci. Tzn., že v ní nelze faktury pořídit ani opravovat. Po spuštění program načte faktury ze všech souborů (hardware, software, …) a na formuláři zobrazí v horní mřížce seznam všech dodavatelských firem. V dolní části formuláře je několik karet, na kterých jsou údaje o fakturách.

Na první kartě Faktury jsou základní údaje jako číslo faktury, datum vystavení faktury, cena faktury (jde o celkovou cenu faktury) a interní číslo faktury. Na ostatních kartách jsou podrobnější údaje o jednotlivých položkách faktury.

SESTAVY

Seznam faktur

sestava faktur za dodavatele.

Seznam faktur - vše

sestava faktur za dodavatele s rozpisem jednotlivých položek.

Seznam faktur - hardware (software, …)

sestavy faktur za dodavatele pouze s vybraným typem dodávky (hardware, software,…) s rozpisem jednotlivých položek.


Ostatni - ProOpen

Komunikace s programem ProOpen

1. Aby mohla komunikace mezi programy Správce a ProOpen správně fungovat, musíte nejprve v menu Údržba-Konfigurace nastavit správně cestu k programu Open32.exe.

2. Po spuštění komunikace s programem ProOpen se zobrazí seznam všech počítačů, sítí nebo síťového příslušenství. Při prvním spuštění jsou položky Open-Projekt a Open-ID prázdné. Tyto položky obsahují vazbu na grafická data v programu ProOpen. Položka Open-Projekt označuje název projektu (plánu budovy apod.), položka Open-ID označuje číslo objektu.

3. Pod mřížkou je zobrazen seznam všech projektů, které program načetl. Tyto projekty se automaticky načtou podle nastavené cesty k programu ProOpen. Jako název projektu se použije název adresáře, ve kterém je projekt umístěn.

4. Aby se mohlo zařízení identifikovat v grafických datech, musíte nejprve přiřadit všechna zařízení k jednotlivým projektům.

Pomocí pravého tlačítka myši vyvoláte menu (viz. následující obrázek), pomocí kterého provedete všechny potřebné operace.

5. Pomocí volby Označ vše nebo jednotlivým výběrem označíte všechna zařízení, která patří danému projektu. Pod mřížkou vyberete název tohoto projektu a pomocí volby Přiřadit projekt provedete hromadné přiřazení. Takto musíte postupně označit všechny zařízení.

6. Pokud máte zařízení přiřazena k projektu, můžete pracovat s volbami v dolní části menu. Tyto volby umožňují :

Otevřít ProOpen

otevře se program ProOpen a spustí se komunikace s programem Správce. Zároveň se v programu ProOpen otevře projekt, ve kterém je zařízení umístěno.

Zobrazit polohu

umožňuje najít aktuálně vybrané zařízení z programu Správce jako objekt v programu ProOpen. Lokalizace objektu se provádí podle čísla objektu (Open-ID). Pokud nebylo toto číslo ještě přiřazeno, objekt se nenajde.

Přiřadit polohu

Touto volbou se k vybranému zařízení v programu Správce přiřadí číslo objektu (položka Open-ID). Postup je následující :

· Nejprve v programu ProOpen nastavte kursor na požadovaný objekt. K tomu slouží menu Nástroje, které se většinou vytvoří samo po spuštění programu ProOpen. V tomto menu musíte vybrat ikonu Chytání. Jestliže se menu nevytvoří, musíte ho vyvolat ručně přes menu Zobrazení / Nástroje.

Potom se musíte nastavit na objekt.

Pokud stojíte na jiné položce, pak

se přiřazení polohy neprovede.

· Potom se přepněte do programu Správce a v něm se nastavte na požadované zařízení. Spuštěním volby Přiřadit polohu se vygeneruje číslo (položka Open-ID), které je jedinečné a toto číslo se zapíše jak v programu Správce, tak i v programu ProOpen. Tím je nastavena vazba mezi těmito programy a můžete v obou programech vyhledávat požadované objekty.

Zavřít ProOpen

uzavře se program ProOpen a ukončí se komunikace s programem Správce.

7. Pokud máte v programu Správce nastavené názvy projektů (položka Open-Projekt) a čísla objektů (položka Open-ID), můžete jak v programu Správce, tak i v programu ProOpen vyhledávat požadovaná zařízení.

· V programu Správce musíte umístit kursor na požadované zařízení a spustit volbu Zobrazit polohu, která najde příslušný objekt v programu ProOpen.

· V programu ProOpen stačí umístit kursor pomocí ikony Chytání na daný objekt a kursor se v programu Správce sám nastaví na příslušné zařízení. Pokud se objekt v programu Správce nenalezne, program vypíše chybovou zprávu.

8. Zrušení spojení (vymazání čísla objektu) v programu ProOpen by se mělo provádět při spuštěné komunikaci s programem Správce. Tím bude zaručeno, že se číslo objektu vymaže v obou programech najednou.


Ostatni - Grafy

Grafy

Modul Grafy vytváří grafické zobrazení dat z programu Správce. Bohužel nemůže pracovat přímo s aktuálními daty. Proto je nutné nejprve data z programu Správce vyexportovat. Pomocí tlačítka Export program Správce vyexportuje všechny potřebné soubory, se kterými umí modul Grafy pracovat. Vyexportují se jen potřebné položky a některé položky se spočítají z více souborů.


Udrzba

Údržba

Menu Údržba obsahuje všechny důležité funkce programu, které jsou nutné pro jeho správný chod. Jedná se především o nastavení konfigurace programu, opravy dat, zálohování, nastavení přístupů k programu, exporty, převody apod.


Udrzba - Konfigurace (obecne)

Konfigurace - Obecné

Tato volba slouží k nastavení obecných parametrů programu.

Firma / Umístění souborů - nastavení cest a názvu firmy

Tvar evid. čísel - nastavení tvaru evidenčních čísel

Ostatní - ostatní parametry


Udrzba - Konfigurace (obecne - umisteni souboru)

Konfigurace – Obecné (Firma / Umístění souborů)

Firma

Název aktuální firmy. Tento název se použije ve všech sestavách a v RemoteScanu.

Archivní soubory

adresář, do kterého se budou kopírovat data při Archivaci. Tento adresář bude implicitně nabídnut při spuštění volby Archivace dat a Obnova dat.

Adresář s aktuálními daty

pouze zobrazuje aktuální datový adresář.

Adresář s TXT, SWT soubory

adresář, ve kterém se nachází výstupní soubory scanu HW a SW.

Adresář s elektronickými dokumenty

adresář, ve kterém jsou uloženy elektronické dokumenty.

Adresář programu ProOpen

adresář, ve kterém se nachází hlavní soubor Open32.Exe programu ProOpen.

Adresář programu MiCoSGrf

adresář, ve kterém se nachází hlavní soubor MicosGrf.Exe modulu Grafy.

Adresář pro Import souborů

adresář, ve kterém se nacházejí soubory pro import.

Adresář pro Export souborů

adresář, ve kterém se nacházejí soubory pro export.


Udrzba - Konfigurace (obecne - Tvar ev. cisel)

Konfigurace – Obecné (Tvar evidenčních čísel)

Zde se nastavuje způsob vytváření evidenčních čísel pro všechny hlavní soubory (hardware, software, …). Lze zvolit :

Číslování programem

číslování bude u každého souboru začínat od ”1” a postupně se zvětšovat. Program Vám při vytváření nových vět hlavních datových souborů automaticky nabídne další číslo. V této konfiguraci můžete určit první čtyři znaky v evidenčním čísle jako tzv. prefix. Následující příklady ukazují možnosti použití prefixu :

a) jestliže určíte 1-4 úvodní znaky např. HARD, pak zbytek čísla bude vždy doplněn nulami např. ”HARD0001”. Pozor na příslušenství. Pokud budete mít v evidenci více než 500 počítačů, kde každý počítač má několik příslušenství, můžete se snadno s číslováním příslušenství dostat nad 9999. V tomto případe nesmíte mít prefix 4-místný.

b) není vhodné na konci prefixu používat číslic. Ve výsledném čísle pak splývá prefix s vlastním číslováním (např. HAR10010 - není na první pohled zřejmé o jaké číslo se jedná).

c) pokud na začátku prefixu použijete mezery, zůstanou zachovány, např. " H0001" (kompatibilita s verzí 4.*). Jedině tímto způsobem můžete nastavit délku evidenčního čísla menší než 8 znaků.

d) jestliže neurčíte žádný znak v prefixu, pak program automaticky doplní nuly tak, aby počet znaků byl 8 ( číslo bude ”00000001” ).

e) pokud potřebujete změnit prefix, stisknete tlačítko Změna prefixu ev. čísel. Toto tlačítko Vám zpřístupní jednotlivé prefixy a Vy můžete provést změny. Po stisknutí tlačítka OK celého formuláře se pak provedená změna promítne do všech vět všech souborů. POZOR - dojde k přečíslování všech vět odpovídajících původnímu prefixu na nový prefix. Což při podstatné změně prefixu muže ovlivnit předávací protokoly, inventární sestavy, popisy počítačů apod.

Libovolné číslo

program Vám při vytváření nových vět hlavních datových souborů nabídne prázdné evidenční číslo a Vy můžete zapsat libovolný počet 1-8 znaků. Pozor - tento způsob neplatí při použití scanu HW – aby Vás totiž zpracování nových příslušenství nezdržovalo tím, že budete muset zadat pro každé příslušenství nové evidenční číslo, je při zpracování HW-SCANU zapnuta automatická generace evidenčních čísel pro nová příslušenství.. Pokud Vám navržená evidenční čísla nevyhovují, můžete si je po zpracování opravit.

Povolit změnu tvaru čísel

parametr, který je vidět pouze v případě multilicence. Je nepřístupný a nastavuje se v programu KSPRÁVCE. Slouží k tomu, zda je uživateli programu SPRÁVCE povoleno v průběhu práce změnit tvar evidenčních čísel.


Udrzba - Konfigurace (obecne - ostatni)

Konfigurace – Obecné (Ostatní)

Povolení duplicity čísel

tyto parametry určují, zda při aktualizaci hlavních souborů (hardware, software, …) budou kontrolovány položky Výrobní číslo, Inventární číslo, Specifické číslo a Licenční číslo na duplicitu. Parametry mohou nabývat tyto hodnoty :

Zakázat = duplicita údaje je zakázána, program nepovolí vložit duplicitní údaj.

Upozornit = uživatel je na duplicitu upozorněn, ale sám rozhodne, zda bude pokračovat.

Povolit = duplicita se nekontroluje, uživatel není na ní upozorněn.

Povolení duplicity názvu PC

tento parametr určuje, zda v souboru hardware je možno zadat více stejných názvů počítačů. Pokud je tato duplicita povolena nelze v RSClientovi zapnout komunikaci. Pokud chcete duplicitu zakázat a v souboru hardware existují duplicitní názvy počítačů je třeba nejprve tyto duplicity odstranit a teprve pak lze parametr změnit.

Tvar oddělovače desetinných míst

tento parametr slouží k určení tvaru desetinných míst při zadávání ceny.

Ostatní parametry

Nezobrazovat úvodní obrazovku

při prvním spuštění programu se zobrazí formulář Výběr datových souborů, který umožňuje před pořízením vlastních dat si program vyzkoušet na demonstračních datech. Pokud již DEMO data nebudete potřebovat, můžete buď na úvodním formuláři Výběr datových souborů nebo zde zaškrtnout tento parametr a úvodní formulář s možností použít DEMO data se Vám při spouštění již nebude objevovat a vždy se spustí ostrá data. Pokud máte v evidenci data více firem/závodů je tento parametr nepřístupný a úvodní obrazovka se vždy spustí.

Maximalizovat obrazovku

tímto parametrem můžete ovlivnit velikost hlavní obrazovky přes celý monitor nebo v okně.

Zobrazit interní příslušenství

tento parametr ovlivňuje, zda v mřížkách příslušenství bude zobrazeno i interní příslušenství (např. board, paměť,...). O tom, které příslušenství je interní, rozhodujete v číselníku typu příslušenství. Tento parametr má význam, jen pokud v mřížkách s vazbami nechcete vidět interní příslušenství.

Pokročilé rozhraní menu

tento parametr ovlivňuje, zda budou v menu a toolbaru všechny volby (pokročilé menu) nebo jen základní.

Tisk protokolu hromadného rušení vět

tento parametr slouží k výběru, zda při hromadném rušení vět bude vytištěn protokol o rušení.

Tisk vět bez vazeb

při tisku umožňuje ignorovat věty, které nemají podřízené vazby (např. počítač, který nemá žádný nainstalovaný software).

Tisk výplně rámečků

při tisku umožňuje ignorovat výplně rámečků sestav.

Tisk přílohy předávacího protokolu HW

tento parametr slouží k výběru, zda přílohu předávacího protokolu HW chcete tisknout na zvláštním listu nebo na konci sestavy.

Tisk downgrade názvů SW

tento parametr slouží k výběru, zda při tisku sestav SW se v případě použití tzv. downgrade bude tisknout skutečně čerpaná licence nebo skutečně nalezená licence.

Zobrazovat pozadí programu

tímto parametrem se zapíná, nebo vypíná pozadí programu.

Lokalizace vybraných sestav

určuje implicitní nastavení lokalizace u vybraných sestav, které jsou lokalizovány.

Generovat soubory pro ScanView

Určuje, zda při ukončení programu jsou generovány soubory pro modul ScanView.


Udrzba - Konfigurace (sestavy)

Konfigurace – Sestavy

Tato volba slouží k nastavení hlaviček sestav předávacích protokolů, pasportních listů hardware, software, příslušenství, dokumentace a sítí (u hardware také specifikačního listu) a k nastavení vlastního textu předávacích protokolů výše uvedených souborů.

Parametry sestav - nastavení vlastních nadpisů sestav (předávacích protokolů, pasportních listů a specifikačních listů a nastavení vlastního textu předávacích protokolů

Texty položek - nastavení textu pro popis obecných položek

Specifikační list Hw - nastavení vlastního textu specifikačního listu


Udrzba - Konfigurace (sestavy - hlavicky sestav)

Konfigurace – Sestavy (Parametry sestav)

Na této kartě lze změnit texty nadpisů sestav předávacích protokolů, pasportních listů a specifikačního listu.

Dále na této kartě lze nastavit vlastní text předávacích protokolů hardware, software, příslušenství, dokumentace a sítí. Tento text bude u každého předávacího protokolu umístěn za úvodní pevný text.

Pokud máte zakoupenou multilicenci programu Správce, může být tento text určen pouze ke čtení (bude mít šedý podklad). To nastane v případě, že Vaše organizace bude požadovat jednotné předávací protokoly. V tomto případe Vám pošle jejich obsah z programu KSPRAVCE a zakáže Vám jejich aktualizaci.

Texty pro hardware a odpovědné osoby lze nastavit v několika jazykových verzích.


Udrzba - Konfigurace (sestavy - texty polozek)

Konfigurace – Sestavy (Texty položek)

Na této kartě lze nastavit vlastní text pro některé popisy položek na formulářích a v sestavách. Lze nastavit vlastní text pro tyto položky :

· Volný číselník – číselník, který slouží každému uživateli k libovolnému použití (např. nomenklatury, SAP evidence apod.)


Udrzba - Konfigurace (sestavy - specifikacni list Hw)

Konfigurace – Sestavy (Specifikační list Hw)

Na této kartě lze nastavit vlastní text Specifikačního listu HW. Tento text bude u každého specifikačního listi umístěn za úvodní pevný text.

Pokud máte zakoupenou multilicenci programu Správce, může být tento text určen pouze ke čtení (bude mít šedý podklad). To nastane v případě, že Vaše organizace bude požadovat jednotné specifikační listy. V tomto případe Vám pošle jejich obsah z programu KSPRAVCE a zakáže Vám jejich aktualizaci.


Udrzba - Konfigurace (automatické procedury)

Konfigurace – Automatické procedury

Tato karta umožňuje nastavit spouštění automatických procedur. Jedná se o procedury :

Archivace

archivace datových souborů

Reindex

oprava indexních souborů

Kontrola dat

provede se oprava dat

Zpracování SWT souborů

provede zpracování nových SWT souborů

Zpracování TXT souborů

provede zpracování nových TXT souborů

Příjem centrálních číselníků

příjem dat z programu KSPRÁVCE (pouze pro multilicence)

Výstup na nadřízenou organizaci

výstup dat do programu KSPRÁVCE (pouze pro multilicence)

U každé procedury je po zvolení nutné nastavit frekvenci spouštění. Tato frekvence může být v rozsahu 0-99 dní. Pokud proceduru zatrhnete k provádění a zapomenete nastavit frekvenci, nebude se procedura spouštět.

Za frekvencí spouštění je uveden datum posledního spuštění a údaj, kdy se automatická procedura spouští (zda na začátku nebo konci programu).


Udrzba - Konfigurace (multilicence)

Konfigurace - Multilicence

Tato karta je přístupná pouze v případě, že máte zakoupenou tzv. multilicenci programu SPRÁVCE. Na této kartě vidíte v levé části číselníky, které jsou zablokované a centrálně udržované v nadřízené organizaci.

Dále zde najdete parametry závodu, tj. číslo a název závodu, které je nutno zadat na začátku používání. Číslo závodu musí být v rámci celé organizace jednoznačné.

Dále se na této kartě nacházejí implicitní cesty pro program NADSTAVBA a parametr Výstup ze závodu, kterým se stanoví, zda převáděná data budou v původním závodě smazána.


Udrzba - Reindex

Reindex

Volba slouží k obnově indexových souborů tabulek. Při nestandardních situacích (např. výpadek proudu, stisk tlačítka RESET apod.) muže dojít k poškození indexních souborů. Program se podaří normálně spustit, ale mohou se objevit situace, kdy dojde k nečekaným výsledkům. Tato volba je rychlá a opravuje pouze všechny indexní soubory. Neopravuje vazby mezi soubory. Pokud je poškozená hlavní databáze, kde jsou uloženy všechny vazby, musíte spustit volbu Údržba - Oprava databáze.

Při reindexaci se vytváří soubor REINDEX.TXT v datovém prostředí. Tento soubor se po ukončení reindexace smaže. Pokud dojde k výpadku proudu, jsou datové soubory obnoveny z pracovních adresářů.


Udrzba - archivace dat

Archivace dat

V této volbě se provádí bezpečnostní kopie všech používaných souborů na zvolené zařízení. Před vlastní archivací se všechny soubory uzavřou. Máte možnost zvolit některou z následujících variant archivace :

Datové soubory + generátor sestav

tato volba provádí archivaci všech datových souborů (DBF, FPT, MEM). Pokud zvolené zařízení pro archivaci nemá dostatek místa, musíte sami zvolit tlačítko "Komprimovat data" a program provede komprimaci.

Tato volba provádí automaticky i archivaci nadefinovaných filtrů a generátoru uživatelských sestav.

Je nutné často archivovat!!! Pozor – nelze udělat obnovu z archivu starší verze programu SPRÁVCE!!!

Konfigurační soubory programu

tato volba provádí archivaci konfiguračních souborů :

PROTOKOL.* - text předávacích protokolů

PRISTUPY.DBF - přístupová práva uživatelů programu

FORMULAR.DBF - nastavení velikosti a umístění formulářů

AUTO.MEM - parametry pro automatické procedury

SPRAVCE.MEM - všechny konfigurační parametry programu

HW-SCAN.MEM - parametry scanu HW

SW-SCAN.MEM - parametry scanu SW

IMPORT.MEM - parametry pro import souborů

Tyto soubory jsou bezpodmínečně nutné pro funkci programu. Pokud jsou během práce poškozeny nebo smazány, program si vyžádá jejich kopii, proto je vhodné tyto soubory archivovat v okamžiku jejich změn. Tyto soubory se archivují vždy v nekomprimované podobě.

Je nutné je občas archivovat, hlavně po upgrade programu SPRÁVCE!!!


Udrzba - Obnova dat

Obnova dat

V případě poškození některého z datových nebo konfiguračních souborů lze tyto soubory obnovit. Tuto obnovu lze provést pouze v případe, že byla provedena Archivace dat a archivní soubory jsou ze stejné verze programu jakou máte aktuálně nainstalovanou.

POZOR

a) obnova provede vždy obnovení všech souborů - tím je pro datové soubory zaručeno obnovení všech vzájemných vazeb mezi nimi.

b) pokud máte spuštěný program s DEMO daty, provede se obnova těchto DEMO dat.

Při obnově budou nejprve všechny soubory uzavřeny a poté překopírovány do pomocného adresáře (pro případ násilného přerušení obnovy). Pak se provede obnova požadovaných souborů. Aby nedošlo k nesrovnalostem v indexních souborech, provede se reindexace a znovuotevření všech souborů. Pokud obnova proběhne úspěšně, smažou se soubory z pomocného adresáře.

Při obnově konfiguračních souborů je program ukončen a musíte ho znovu spustit. Nelze totiž za chodu programu změnit některé konfigurační parametry.


Udrzba - setrepani dat

Setřepání dat

Věty, které zrušíte v aktualizacích hlavních datových souborů a číselníků, jsou pouze označeny ke rušení. Fyzicky se stále nacházejí v jednotlivých souborech. Pomocí této volby je ze souboru definitivně odstraníte.


Udrzba - Oprava databaze

Oprava databáze

Pokud se poškodila hlavní databáze nebo některá vazba mezi jednotlivými tabulkami, musíte spustit tuto volbu. Tato volba vytvoří novou databázi, nové tabulky, indexy a nastaví relace mezi nimi.

Jestliže ani po této opravě program nepracuje správně, došlo asi k vážnějšímu poškození datových souborů a bude nutné provést Obnovu dat nebo volat autorskou firmu.

Tato volba je pomalejší (hlavně po síti a při velkých souborech), ale vytváří znovu všechny soubory, čímž eliminuje daleko lépe případné chyby než pouhá oprava indexů.


Udrzba - Kontrola dat

Kontrola dat

Formulář obsahuje několik voleb, které slouží k úpravě položek souborů, které by se v důsledku nestandardních situací mohly dostat navzájem do nesouladu a normálními funkcemi programu je nelze opravit.

1) Kontrola hardware

a) kontrola ceny počítače a ceny samostatně zakoupeného příslušenství - pokud se v průběhu práce s programem stane, že tyto ceny nesouhlasí, tato volba projde příslušné soubory a přepočte správné ceny.

b) kontrola položek Procesor a Provedení – tyto položky se naplňují v okamžiku přiřazení příslušenství typu PROCESOR a CASE k danému hardware. Pokud nesouhlasí hodnoty těchto položek ve větě hardware s přiřazeným příslušenstvím, tato volba projde příslušné soubory a tyto údaje uvede do souladu.

c) kontrola počtu a kapacity procesorů, pamětí a HDD - tato volba projde celý soubor hardware a pro každou větu projde přiřazené příslušenství a spočítá počty kusů procesorů, paměti a pevných disků. Tyto hodnoty pak zapíše do souboru hardware. Dále se pro paměť a pevné disky zkontroluje položka Oblast1 v daném příslušenství. Pokud je v této položce údaj o velikosti paměti nebo pevného disku, sečte hodnoty za všechny pamětí a pevné disky a uloží je opět do souboru hardware. Podmínkou pro součet je, že hodnota v položce Oblast1 obsahuje text MB (pro paměť) a MB nebo GB (pro pevné disky)

d) kontrola duplicity položky Název PC – v programu SPRÁVCE nelze mít duplicitní název PC (z důvodu používání programu REMOTESCAN. Tato volba projde všechny počítače a pokud některé budou mít stejný název, provede vynulování všech duplicitních názvů počítačů. Na konci kontroly lze vytisknout sestavu smazaných názvů počítačů.

2) Kontrola software

a) kontrola počtu instalací – program provede přepočet instalací uvedených ve větě Software a kontrolu označení, že na software byl proveden upgrade/update. Pokud je ve větě software uvedeno, že se jedná o OEM licenci vázanou na hardware, je zkontrolováno, zda v souboru vazeb na hardware je vygenerována věta. Pokud se věta nenalezla, je automaticky vygenerována. Dále se prochází soubor vazeb na hardware, kde jsou uloženy jednotlivé instalace SW na počítačích a provede se přepočet volných instalací software. Zároveň se smažou instalace neexistujících počítačů nebo neexistujícího software.

b) kontrola upgrade - dále se provede kontrola souboru upgrade, ve kterém je uveden software, který byl pořízen jako upgrade/update k aktuálnímu software a opraví se položka UPG_KS2, ve které je uvedeno na kolik licencí aktuálního software byl pořízen upgrade/update.

c) kontrola bilance software - na konec se provede přepočet počtu kusů licencí, instalací a celkové bilance software.

3) Kontrola sítí

provede přepočet přiřazených počítačů na sítích. V souboru sítí je uvedena položka Počet stanic, která udává počet připojených počítačů. Pokud nesouhlasí se seznamem počítačů na kartě Vazby HW, tato volba projde příslušné soubory a uvede tuto položku do správného stavu.

4) Kontrola typu, přiřazení příslušenství a nadřízeného příslušenství

provede sjednocení položky Název typu příslušenství (MODEM, TISKÁRNA, …) v souboru Příslušenství s číselníkem Typu příslušenství. Tato položka je v souboru Prisluse kvůli správnému zobrazení ve všech mřížkách s vazbami příslušenství. Pokud tato položka neodpovídá číselníku, provede tato volba jejich sjednocení. Dále je kontrolována položka Prirad a Site. V těchto položkách je uvedena vazba na hardware a sítě. V případě, že se číslo hardware nebo sítě nenajde v hlavním souboru je položka vynulována. Poslední kontrola provede správné přiřazení nadřízeného a podřízeného příslušenství.

5) Kontrola generování evid. čísel

provede kontrolu souboru SETUP.DBF, do kterého se ukládají poslední čísla pro generování evidenčních čísel. Při nějaké nestandardní situaci může dojít k tomu, že se nově přidělené číslo nezapíše do tohoto souboru. Při generování nové věty hlavních souborů pak může program hlásit Porušení primárního klíce nebo Duplicita údajů. Touto volbou se soubor SETUP.DBF opraví a chyby se již nebudou vyskytovat.

6) Kontrola instalací software

ve starších verzích nemusel soubor s instalacemi software obsahovat správné údaje z číselníků org. členění, umístění a odpovědných osob. Touto volbou se tyto položky v souboru SOFT_PRI přepíší údaji ze souboru hardware.

7) Kontrola pomocných položek

při změnách vazeb v číselnících se může někdy stát, že označenou větu nelze odznačit a ani nelze provést změnu. Touto volbou se projdou všechny hlavní soubory a pomocné položky POMOC, POMOC1, pomocí kterých se změna vazeb provádí, se nastaví na .F. .

8) Kontrola PŘ – součást PC při nákupu

tato kontrola projde všechno příslušenství, které je součástí počítače při nákupu a načte položky org. členění, umístění, odpovědná osoba a číslo sítě z údajů počítače jehož je součástí. Tyto údaje pak zapíše do věty příslušenství. Také provede úpravu inventárního čísla, a to tak, že všechno přiřazené příslušenství označené jako součást počítače při nákupu převezme automaticky inventární číslo počítače.

9) Kontrola oprav

tato volba dává do souladu výše uvedené soubory a jejich příslušné soubory oprav. Nejdříve se zjišťuje, zda v opravách existuje právě jedna věta, kde STAV = 1 (Uvedení do provozu). Pokud jich je více, zůstává věta s nejnižším datem uvedení, ostatní věty se Stavem=1 budou smazány. Jestliže v souboru oprav neexistuje věta se Stavem=1, vytvoří se věta uvedení s datem zakoupení prvku (v případě, že datum zakoupení není prázdné) nebo s datem první opravy. Pokud nedojde ani k jedné z výše uvedený situací, naplní se datum uvedení do provozu datem aktualizace věty. V případě, že i toto datum je prázdné, program zde vyplní datum, které máte nastaveno na svém počítači. V dalším kroku program projde hlavní soubory a zkontroluje v každé větě položku Stav, která určuje aktuální stav (OK, oprava, upgrade, …). Kontrola probíhá tak, že pro každou větu výše uvedených hlavních souboru se prochází soubor oprav. Pokud je mezi větami souboru oprav i oprava se Stavem=8 (Likvidace), další kontrola se již neprovádí a hlavní větě se nastaví Stav=8 (Likvidace). Pokud pro danou větu hlavního souboru existují v souboru oprav nějaké rozpracované opravy (nemají vyplněn datum ukončení opravy), vezme se poslední (nejmladší) a její stav se zapíše do hlavního souboru (např. pokud poslední rozpracovaná oprava má Stav=3, což je oprava, pak se tento stav přepíše i do hlavního souboru). Na závěr jsou ze souboru oprav zrušeny věty, které nemají vazbu na příslušný hlavní soubor. Pro multilicenci Software se ještě provádí kontrola existence STAV = 5, nákup licencí. Kontrola probíhá obdobně jako pro STAV = 1.

10) Nastavení základních velikostí a umístění formulářů

tato volba umožňuje vrátit uživatelsky upravený vzhled formulářů do původního stavu po počáteční instalaci.

11) Kontrola exportu do účetnictví

tato volba umožňuje provést Kontrolu a opravu položek Datum zařazení a vyřazení z účetnictví a Cenu zařízení.

12) Nastavení základního vzhledu mřížek

tato volba umožňuje vrátit uživatelsky upravený vzhled mřížek do původního stavu po počáteční instalaci.

13) Kontrola volných vět v centrálních číselnících

tato kontrola je určena pouze pro multilicence. Prochází všechny centrálně udržované číselníky a jejich neschválené věty. Pokud se neschválená věta (např. značka počítače NONAME) nevyskytuje v žádném hlavním souboru (např. hardware), je tato věta automaticky zrušena.


SESTAVY - Udrzba

Sestavy – Údržba

V této volbě se provádí úprava všech souborů používaných modulem SESTAVY. Úprava se provádí pomocí souboru QM_U_DICT. Tento soubor se při upgrade na vyšší verzi, nebo při prvním použití sestav, nahraje do adresáře GEN_SEST, pokud tomu tak není, je třeba před prvním spuštěním této volby, do adresáře s úlohou SPRAVCE.EXE z příslušné instalace nakopírovat adresář UDR_SEST, který obsahuje potřebný soubor QM_U_DICT, a při spuštění volby “Údržba” v menu Sestavy se tento soubor připraví pro zpracování.

Zpracování volá formulář, kde je možnost udělat archiv sestav, provést údržbu, či jít zpět. Před úpravou souborů sestav se do adresáře …GEN_SEST\UDRZBA nakopírují všechny soubory z adresáře …GEN_SEST, pokud vše proběhne dobře, tak se adresář UDRZBA zruší. Na závěr se spouští REINDEX. Při zpracování údržby se z QM_U_DICT stává QM_DICT a podle něj se upravují ostatní soubory sestav. Pokud není nalezen soubor QM_U_DICT v …GEN_SEST, či v …UDR_SEST, to vše v programovém adresáři, a pokud nesouhlasí verze programu sestav s verzí v souboru QM_U_DICT, tak zpracování údržby není provedeno. Jestliže zpracování skončí chybou, jsou soubory sestav obnoveny z adresáře …GEN_SEST\UDRZBA, a tím jsou data sestav vrácena do původního stavu. Je-li při spuštění volby nalezen adresář …GEN_SEST\UDRZBA, pak je zpracování opět ukončeno, a uživatel musí rozhodnout, v jakém stavu jsou data, pokud je adresář …GEN_SEST\UDRZBA prázdný, je možno adresář UDRZBA jen zrušit a pracovat dále, pokud jsou v adresáři …GEN_SEST\UDRZBA data, je třeba je nakopírovat zpět do adresáře …GEN_SEST a adresář UDRZBA zrušit.

POZOR

datové soubory Visual FoxPro není snadné obnovovat, jejich poškození muže vést k definitivní ztrátě. Proto nezapomeňte pravidelně provádět archivaci všech datových souboru. V případe, že dojde k jejich poškození a Vy nebudete mít provedenou archivaci, přijdete o svá data, program nemá možnost záchrany poškozených dat.


Udrzba - sprava uzivatelu

Správa uživatelů

Ovládání programu Parametry tisku

V této volbě lze zadat do programu jména a hesla uživatelů pracujících s programem SPRÁVCE a nastavit jejich přístupová práva pro aktualizaci. Protože přístup k programu může mít v současné chvíli pouze jeden uživatel stejného jména, musíte zde nadefinovat další uživatele.

Právo přístupu k této volbě má pouze uživatel, který je označen jako administrátor. Ostatní uživatelé mají tuto volbu zablokovanou. Uživateli spravce lze změnit pouze jeho heslo a jeho přístupy, nelze ho však zrušit. Ostatní uživatele lze libovolně přidávat, rušit a upravovat.

Ve jméně uživatele nepoužívejte diakritiku, mohly by vzniknout problémy!!!!

Přístupová práva se nastavují na :

A) Přístupy k souborům :

Spustit - uživatel má právo spustit daný soubor. Vidí všechny údaje (výjimkou jsou pouze hesla sítí, která jsou těmto uživatelům skryta), nemůže údaje aktualizovat..

Zápis - uživatel má plný přístup k aktualizaci daného souboru.

B) Funkce

Uživatel má právo spustit danou funkci (akci, volbu v menu apod.). Jedná se např. o právo editovat ekonomické údaje, spustit zpracování scanů, spustit volbu Údržba apod.

Změnu hesla si uživatel může provést sám, a to stiskem tlačítek ALT+H na úvodním formuláři při spuštění programu. Na tomto formuláři musí nejprve zadat svoje jméno a teprve na položce Heslo stisknout kombinaci tlačítek ALT+H ke změně hesla.

SESTAVY

Přístupy uživatelů - seznam

seznam všech uživatelů a jejich přístupů.


Udrzba - zmena aktualniho uzivatele

Změna aktuálního uživatele

Touto volbou lze změnit aktuálně přihlášeného uživatele v průběhu práce s programem. Nemusíte ukončovat celý program, ale stačí uzavřít všechny formuláře a pak zde změnit aktuálního uživatele.


Udrzba - Import

Import

Program umožňuje provést import některých údajů nebo souborů. Jedná se o následující možnosti :

Ekonomické údaje - import ekonomických údajů (faktura, dodavatel, inv. číslo apod.).

Ostatní údaje - import umístění, org.členění, osob apod.

Číselníky z jiných evidencí - import celých číselníků (např. umístění, org.členění, firem, osob apod.).

Číselníky z programu Správce - import celých čísleníků z jiné licence nebo ze starší zálohy


Import - ekonomicke udaje

Import - ekonomické údaje

V této volbě lze importovat z externích evidencí pouze ekonomické údaje. Předpokladem je vytvoření správného vstupního souboru, který je správného formátu, obsahuje všechny potřebné položky a obsahuje klíčovou položku, podle které lze data externí evidence spojit s daty programu Správce.

Předpokládaný postup :

1. Volba typu souboru

FoxPro 2.x - klasický formát DBF (Dbase, FoxPro DOS)

  • není nutné dodržet pořadí položek.
  • je nutné dodržet správné názvy položek (musí mít stejný název jako mají položky v programu Správce).

Microsoft Excel - formát XLS ve třech typech :

  • MS Excel 2.0 - verze 2.0
  • MS Excel 5.0 - verze 3.0, 4.0, 5.0 (95)
  • MS Excel 97 - verze 8.0 (97), 9.0 (2000), 10.0 (XP)
  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

  • Pozor – na prvním řádku importovaného souboru mohou být názvy položek (viz. kontrolní exportní soubor) nebo mohou začínat přímo hodnoty. Máte-li v prvním řádku uvedeny názvy položek, kontroluje program před importem správný název prvních dvou sloupců (musí být stejný jako jsou názvy v kontrolních souborech). Pokud jsou názvy shodné, první řádek se ignoruje a import se provede až od druhého řádku. Nejsou-li názvy položek (sloupců) shodné s kontrolním souborem, je importován i první řádek.

Textový soubor - s oddělovači

  • je nutné dodržet správné pořadí položek.
  • nezáleží na správné délce položek (nesmí být pouze delší, jinak dojde k useknutí).
  • oddělovačem jednotlivých položek musí být čárka.
  • textové položky musí být uzavřeny do uvozovek (pokud by totiž v textu položky byla čárka, text by se usekl a přetáhl do další položky).
  • numerická položka Cena musí být uzavřena do uvozovek (pokud by obsahovala desetinná místa, text by se usekl a přetáhl do další položky).
  • datumové položky musí ve tvaru DD-MM-RRRR (oddělovačem může být tečka nebo pomlčka).

CSV formát

  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

2. Volba Kódové stránky

Windows - 1250

Latin II - 852

Kamenický - 895

3. Výběr souboru

Import lze provést pouze pro následující soubory :

· Hardware

· Příslušenství hw

· Síťová technika

· Ostatní majetek

· Software

4. Desetinná místa

Tento parametr je viditelný a má význam pouze při importu typu souboru Textový soubor s oddělovači. Správný oddělovač míst znamená, že se správně načtou i desetinná místa. Pokud zvolíte špatný oddělovač, budete mít cenu useknutou o desetinná místa.

5. Klíč pro Import

Velmi důležitá položka, podle které se provede vlastní Import. Tento klíč musí být v obou evidencích (externí a Správce) jedinečný a totožný. Což znamená, že v obou musí existovat stejné klíče. Program potom může provést importování dat podle tohoto klíče. Pokud v jedné z evidencí nějaké klíče chybí, neprovede se Import automaticky, ale je nutné ručně tyto údaje opravit a přiřadit. Jedinou položkou podle, které lze importovat je inventární číslo.

6. Kontrolní export dat

Tímto tlačítkem si můžete do podadresáře \OSTRA\EXPORT vygenerovat kontrolní soubor, který Vám slouží jako vzorek pro vytvoření vstupního souboru z externí evidence. Syntaxe názvu souboru je následující : EK_HW_FP

kde první dva znaky (EK) znamenají, že jde o import ekonomických údajů, další dva znaky (HW) druh souboru a poslední dva znaky typ souboru (vybraného podle volby v bodě 1.)

Kontrolní export generuje kontrolní soubor z aktuálních dat, tzn. že aby jste v kontrolním souboru něco viděli, musíte mít v programu Správce vyplněno prvních 1-5 vět podle evidenčního čísla (kontrolní soubor obsahuje max. 5 vět). Doporučujeme proto si do první až 5-té věty podle evidenčního čísla naplnit kontrolně všechny údaje tak, aby jste v kontrolním souboru viděli nějaký výsledek. Data v kontrolním souboru můžete opravit a provést jejich načtení do mřížky. Tak se nejlépe přesvědčíte o správnosti údajů.

7. Adresář se soubory pro import

Tento údaj nelze přímo editovat. Musíte pomocí tlačítka na konci vybrat soubor z disku. Pokud v dialogu soubor vyberete, načte se Vám soubor do položky. Pokud dáte Storno, položka se vynuluje.

8. Načti soubor

Pokud máte vybrány všechny ostatní potřebné údaje (předchozí volby), můžete stiskem tohoto tlačítka provést načtení vstupního souboru. Program načte soubor do mřížky, ve které si můžete prohlédnout obsah importovaného souboru.

Ve mřížce jsou barevně rozlišeny následující stavy :

· Fialová barva = v datovém souboru existují duplicity inventárních čísel

· Modrá barva = v importovaném souboru existují duplicity inventárních čísel

· Zelená barva = pouze u importu software. Znamená, že v importovaném souboru je inv. číslo, které neexistuje v datech programu SPRÁVCE.

· Červená barva = pouze u importu software. Znamená, že importovaná věta má vyplněnou mateřskou licenci (byla přidělena z nadřízené organizace) a tuto licenci nelze importovat.

Všechny věty, které lze importovat jsou v prvním sloupci automaticky označeny. Věty, které nejsou označeny mají prázdné inventární číslo a tyto věty nelze importovat. Je nutné je v externí evidenci opravit a vygenerovat nový soubor pro import.

Pozor :

· v souboru Příslušenství hardware nelze importovat příslušenství, které je označeno jako Součást PC při nákupu. Toto příslušenství má totiž duplicitní inventární číslo, a proto nelze importovat.

· v souboru Software nelze importovat věty, které mají vyplněnou mateřskou licenci (pouze v případě multilicence programu SPRÁVCE, kdy licence byla zakoupena a přidělena z nadřízené organizace). Dále nelze importovat věty, které mají nové inventární číslo (nejsou v datech SPRÁVCE)

Je-li obsah v pořádku, musíte na druhé kartě označené Výběr položek pro import vybrat položky, které chcete importovat. Automaticky je vždy vybrána klíčová položka, která se musí vždy importovat. Ostatní položky můžete nebo nemusíte importovat. Položky, které vyberete pro import jsou na první kartě zobrazeny tučně.

Teprve po výběru položek pro import se Vám zpřístupní tlačítko Import, jenž Vám povolí provést vlastní import. Jednou vybrané položky si program pamatuje a při příštím importu je automaticky nastaví.

9. Import

Import provede načtení dat ze vstupního souboru ve dvou částech :

a) první část importu se provede automaticky. Jedná se o věty, které mají shodnou klíčovou položku v obou evidencích (inventární číslo) a ve mřížce Data pro import nejsou zobrazeny barevně. Tyto importované věty lze stoprocentně přiřadit, proto lze import provést automaticky.

b) druhá část importu se provádí ručně. Program se zastaví a nabídne formulář Ruční import se seznamem vět, jejichž klíčová položka se v evidenci programu Správce nenašla. Jedná např. o :

  • novou techniku
  • techniku, která nemá v evidenci programu Správce požadovanou klíčovou položku (nebo má špatnou hodnotu).

V tomto formuláři se musíte rozhodnout, co s těmito větami provedete. Můžete je zavést jako nové věty nebo je přiřadíte správně k již existujícím větám.

Druhá část (Ruční import) se neprovádí pro software – nelze zavádět nový software, protože název v importovaném souboru nemusí souhlasit s názvem, který vyžaduje scan SW.


Import - rucni import

Import – ruční import

Formulář obsahuje dvě mřížky :

· horní mřížka obsahuje seznam vět z importovaného souboru, které neprošly automatickým importem

· spodní mřížka obsahuje seznam všech vět hlavní datového souboru, do kterého se import provádí.

Ruční import znamená ručně spárovat věty z importovaného souboru s datovým souborem. Proto musíte v horním souboru označit importovanou větu a ve spodním souboru najít větu, do které se import provede. Pomocí pravého tlačítka myši lze nad oběma mřížkami vyvolat menu, kterým lze označené věty spárovat a provést tak ruční import.

Pokud ve spodní mřížce nenajdete příslušnou větu, do které chcete import provést, lze pomocí pravého tlačítka myši vygenerovat novou větu a pak provést ruční import.

Pozor –

*********

pokud importujete ekonomické údaje příslušenství , síťové techniky nebo ostatního majetku a máte v horní mřížce uvedený název příslušenství (techniky,majetku) a vytváříte novou větu (ve spodní mřížce není žádná odpovídající věta), spustí se Vám formulář pro přidání nové věty.

Tomuto formuláři nelze předat název příslušenství (techniky,majetku) automaticky. Musíte nejprve určit správný typ příslušenství (techniky, majetku). Po určení typu máte v pravé části formuláře v jedné z Volných položek uložen název, který pomocí clipboardu můžete přenést do názvu. Ostatní položky na kartě Ekon. údaje jsou přeneseny automaticky, stačí jen nové příslušenství (techniku, majetek) uložit.


Import - ciselniky

Import – číselníky z jiných evidencí

V této volbě lze importovat z externích evidencí některé celé číselníky. Tento import provede importování číselníků bez nastavení vazeb. To znamená, že např. po importování číselníku umístění musíte každému počítači nebo jiné technice přiřadit umístění ručně v programu Správce.

Předpokladem je vytvoření správného vstupního souboru, který je správného formátu, obsahuje všechny potřebné položky a obsahuje klíčovou položku, podle které lze data externí evidence spojit s daty programu Správce.

Předpokládaný postup :

1. Volba typu souboru

FoxPro 2.x - klasický formát DBF (Dbase, FoxPro DOS)

  • není nutné dodržet pořadí položek.
  • je nutné dodržet správné názvy položek (musí mít stejný název jako mají položky v programu Správce).

Microsoft Excel - formát XLS ve třech typech :

  • MS Excel 2.0 - verze 2.0
  • MS Excel 5.0 - verze 3.0, 4.0, 5.0 (95)
  • MS Excel 97 - verze 8.0 (97), 9.0 (2000), 10.0 (XP)
  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

  • Pozor – na prvním řádku importovaného souboru mohou být názvy položek (viz. kontrolní exportní soubor) nebo mohou začínat přímo hodnoty. Máte-li v prvním řádku uvedeny názvy položek, kontroluje program před importem správný název prvních dvou sloupců (musí být stejný jako jsou názvy v kontrolních souborech). Pokud jsou názvy shodné, první řádek se ignoruje a import se provede až od druhého řádku. Nejsou-li názvy položek (sloupců) shodné s kontrolním souborem, je importován i první řádek.

Textový soubor - s oddělovači

  • je nutné dodržet správné pořadí položek.
  • nezáleží na správné délce položek (nesmí být pouze delší, jinak dojde k useknutí).
  • oddělovačem jednotlivých položek musí být čárka.
  • textové položky musí být uzavřeny do uvozovek (pokud by totiž v textu položky byla čárka, text by se usekl a přetáhl do další položky).

CSV formát

  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

2. Volba Kódové stránky

Windows - 1250

Latin II - 852

Kamenický - 895

3. Výběr souboru

Import lze provést pouze pro následující soubory :

· Organizační členění

· Umístění

· Odpovědné osoby

· Volný číselník (pro libovolné vlastní použití)

· Dodavatelské firmy

· Aplikace

· Značky a použití hardware

4. Klíč pro Import

Všechny číselníky, kromě číselníku osob, mají jedinečný klíč. Ten se nastaví automaticky a nemusíte nic vybírat. U číselníku osob můžete zvolit zda klíč bude jméno, nebo osobní číslo.

5. Kontrolní export dat

Tímto tlačítkem si můžete do podadresáře \OSTRA\EXPORT vygenerovat kontrolní soubor, který Vám slouží jako vzorek pro vytvoření vstupního souboru z externí evidence. Syntaxe názvu souboru je následující : C_OSO_FP

kde první znak (C) znamená, že jde o import číselníků, další tři znaky (OSO) druh souboru a poslední dva znaky typ souboru (vybraného podle volby v bodě 1.)

Kontrolní export generuje kontrolní soubor z aktuálních dat, tzn. že aby jste v kontrolním souboru něco viděli, musíte mít v programu Správce vyplněno prvních 1-5 vět. Doporučujeme proto si do první až 5-té věty podle klíčové položky naplnit kontrolně všechny údaje tak, aby jste v kontrolním souboru viděli nějaký výsledek. Data v kontrolním souboru můžete opravit a provést jejich načtení do mřížky. Tak se nejlépe přesvědčíte o správnosti údajů.

6. Adresář se soubory pro import

Tento údaj nelze přímo editovat. Musíte pomocí tlačítka na konci vybrat soubor z disku. Pokud v dialogu soubor vyberete, načte se Vám soubor do položky. Pokud dáte Storno, položka se vynuluje.

7. Načti soubor

Pokud máte vybrány všechny ostatní potřebné údaje (předchozí volby), můžete stiskem tohoto tlačítka provést načtení vstupního souboru. Program načte soubor do mřížky, ve které si můžete prohlédnout obsah importovaného souboru.

Ve mřížce jsou barevně rozlišeny následující stavy :

· Modrá barva = v importovaném souboru existují duplicity inventárních čísel nebo prázdné klíčové položky.

Věty, které jsou modré (mají prázdnou nebo duplicitní klíčovou položku), nelze importovat. Je nutné je v externí evidenci opravit a vygenerovat nový soubor pro import.

Je-li obsah v pořádku, musíte na druhé kartě označené Výběr položek pro import vybrat položky, které chcete importovat. Automaticky je vždy vybrána klíčová položka, která se musí vždy importovat. Ostatní položky můžete nebo nemusíte importovat. Položky, které vyberete pro import jsou na první kartě zobrazeny tučně.

Teprve po výběru položek pro import se Vám zpřístupní tlačítko Import, jenž Vám povolí provést vlastní import. Jednou vybrané položky si program pamatuje a při příštím importu je automaticky nastaví.

8. Import

Import provede načtení dat ze vstupního souboru automaticky. Pokud mají věty v obou evidencích shodnou klíčovou položku, provede program v evidenci Správce opravu údajů (přepis). Pokud se v programu Správce klíčová položka nenajde, je daná věta zavedena jako nová.


Import - ciselniku ze Spravce

Import – číselníky ze Správce

Tato volba slouží k importu číselníků z různých instalací programu SPRÁVCE nebo KSPRÁVCE nebo z dat vytvořených z jiných aplikací.

Pro import musíte vybrat adresář s číselníky vyexportovanými z jiné instalace programu SPRÁVCE nebo KSPRÁVCE. Při výběru program nepovolí vybrat adresář s aktuálně spuštěnými ostrými daty (nelze importovat číselníky na sebe). Po výběru adresáře s vyexportovanými číselníky se na formuláři zpřístupní pouze číselníky, které ve vybraném adresáři existují a máte na ně má právo zápisu (nastavený přístup zápisu ve volbě Správa uživatelů). Ostatní číselníky, které nesplňují výše uvedené podmínky mají výběr nepřístupný.

Nyní stačí vybrat číselníky, které chcete přihrát. Po stisku tlačítka OK program projde označené číselníky a doplní aktuálně otevřené číselníky o nové věty. Pokud je aktivována volba Přepisovat nalezené hodnoty, položky vět se shodným primárním klíčem jsou přepsány novými hodnotami.

Importované soubory mohou mít strukturu popsanou ve strukturách souborů, povinné jsou však pouze následující položky (mají primární index) :

CISLO - pro číselníky Organizačního členění, Umístění, Typů příslušenství, Volný

NAZEV - pro číselníky Operační systémy SW, Výrobci SW, Operační systémy HW, Značky HW, Použití HW, Aplikace, Dokumenty, Firmy

OSOBA - pro číselník Odpovědných osob

TYP a NAZEV - pro číselníky Názvů příslušenství, Oblasti 1, Oblasti 2

NAZEV a PODOBLAST - pro číselník Oblastí SW

NAZEV a VERZE - pro číselník Názvů SW

NAZEV, VERZE, SOUBOR, VELIKOST a VERZE_PROD - pro Softwarové vzory

KOD - pro číselník Lokalizací SW

TYP_SERVC - pro číselník Servisů


Import - rucni import

Import dat z programu AuditPro

Formulář slouží k importu dat z programu AuditPro. Pro připojení k databázi s daty je nutné zadat název SQL serveru, na kterém jsou data uložena.

Pokud se úspěšně provede připojení k datům, je z nich importován seznam počítačů, seznam uživatelů, seznam licencí a přiřazení licencí k jednotlivým počítačům.

Import provádějte do prázdných dat. Pokud provedete import dvakrát za sebou do stejných dat, budou všechny věty duplicitní.


Import - rucni import

Import dat z programu PcInfo

Formulář slouží k importu dat z programu PcInfo. Před importem je potřeba připravit v programu PcInfo datové soubory, které se budou importovat.

Z programu se přenáší seznam počítačů, seznam licencí + ekonomické údaje z faktur, seznam uživatelů a přiřazení licencí k počítačům.

Import provádějte do prázdných dat. Pokud provedete import dvakrát za sebou do stejných dat, budou všechny věty duplicitní.

Postup přípravy datových souborů v programu PcInfo :

1. Spusťte program PcInfo a z menu Databáze spusťte volbu SQL konzole

2. Na spuštěném formuláři vyberte volbu Nahrát SQL a vyberte soubor KONV_02.SQL z adresáře \SPRAVCE8\INS_DATA

Do pravé části formuláře (Zásobník SQL příkazů) se nahraje šest dotazů.

Postupně se musíte kurzorem nastavit na jednotlivé sql příkazy (select…) a zvolit pro každý dotaz volbu Spustit SQL. Tím se dotaz vykoná a jeho výsledek se zobrazí ve spodní mřížce.

Tento výsledek přenesete tlačítkem Kopírovat do schránky a poté jej musíte vložit do prázdného textového souboru (např. v programu Notepad).

Tímto způsobem postupně vytvoříte soubory CisSoft.TXT, CisBal.TXT, Osoby.TXT, Pocitace.TXT, Faktury.TXT, PrirazeniSW.TXT


Import - rucni import

Import – Active Directory

Formulář slouží k importu osob a počítačů z databáze Active Directory.

Osoby se importují do číselníku odpovědných osob a importuje se jméno osoby, osobní číslo, přihlašovací jméno, mobil, telefon a email. Navíc můžete zvolit zda chcete importovat oddělení jako organizační členění osoby a kancelář jako umístění.

Počítače se importují do evidence hardware a to pouze tehdy pokud neexistuje hardware se stejným názvem PC.

Pro připojení k Active Directory se používá protokol LDAP. K připojení je potřeba zadat název serveru na kterém je databáze umístěna a název domény, ze které se budou údaje načítat (např. Server = PCServer122, Domena = micos-sw.cz). Pro přístup k LDAP je nutné mít příslušná síťová oprávnění.


Export

Export umožňuje vyexportovat data pro jiné (externí) evidence. Jedná se o následující typy :

Datové soubory

Do účetnictví

Číselníky do programu Správce


Export - datové soubory

Export – datové soubory

V této volbě převedete vybranou tabulku programu SPRÁVCE z formátu dat Visual FoxPro do jiného formátu. Data můžete převést do následujících formátů :

FoxPro 2.x

Microsoft Excel

Textový soubor s oddělovači

Textový soubor s pevnou délkou věty

Pro výstupní soubor lze kromě formátu zadat i druh kódování češtiny, a to tyto následující druhy :

Windows - 1250

Latin II - 852

Kamenický - 895

Export souboru má dvě možnosti, jak exportovat datové soubory:

Všechny soubory

v tomto případě stačí zadat jen výstupní adresář (implicitně je nabízen podadresář \EXPORT). Program do něj vyexportuje všechny soubory najednou.

Jednotlivě

v tomto případě je nutné vybrat jméno vstupního souboru a zadat název výstupního souboru a výstupního adresáře (implicitně je opět nabízen podadresář \EXPORT). Program do něj vyexportuje zadaný soubor.


Export - do ucetnictvi

Export - do účetnictví

Tento formulář slouží pro výběr druhu exportu dat do účetnictví. Můžete si vybrat některou z následujících možností, a to pro hardware, software, příslušenství hw, síťovou techniku nebo ostatní majetek :

Zařazení

vybraný majetek bude zařazen do účetnictví. Ve větě pro dané zařízení bude vyplněna položka Datum zařazení. Export můžete provést pro libovolný druh majetku, pokud jsou splněny následující podmínky :

- položka Druh majetku = odpovídá vybranému druhu majetku

- prázdný Datum zařazení a Datum vyřazení

- v případě exportu příslušenství hw se exportují jen samostatná příslušenství hw (neexportují se PŘ označená jako součást PC při nákupu)

- musí být vyplněné inventární číslo

- cena je větší než zadaná cena nebo není uvedena

Vyřazení

vybraný majetek bude vyřazen z účetnictví. Ve větě pro dané zařízení bude vyplněna položka Datum vyřazení. Zároveň bude pro tento majetek do souboru oprav vygenerována věta STAV=8 LIKVIDACE. Majetek bude zlikvidován, zůstane v evidenci a nepůjde již zrušit. Výběr vět se řídí stejnými podmínkami jako při zařazení, jen Datum zařazení do účetnictví nesmí být prázdný.

Po výběru druhu exportu se spustí vlastní Export dat.


Udrzba - export dat do ucetnictvi (provedeni)

Export dat do účetnictví - provedení

Tento formulář zobrazuje seznam majetku v závislosti na vybraném druhu exportu. Ve mřížce jsou zobrazeny všechny věty splňující podmínky vybraného druhu exportu. Ve sloupci Cena lze před provedením exportu provést opravu ceny majetku. V posledním sloupci lze vybrat majetek pro export (vybrat lze jen majetek, který nemá nulovou cenu). Po výběru je ve spodní části formuláře proveden součet cen pro export. V položce Datum zařazení/vyřazení pod mřížkou lze nastavit datum, které se zapíše do vět hardware/příslušenství jako datum Zařazení/Vyřazení do účetnictví.

Stiskem tlačítka Export provedete vygenerování souboru UCTO-EXP.DBF ve tvaru DOS s kódovou stránkou 1250 do podadresáře \UCTO_EXP. Tento soubor se při prvním exportu založí a při dalších jsou do něj věty přidávány. Tento soubor si potom musíte sami naimportovat do účetnictví. Struktura výstupního souboru je následující :

TYP | C(1) | P=zařazení, V=vyřazení
DRUHMAJETK | C(40) | hmotný majetek, drobný hmotný majetek
EVIDCISLO | C(8) | evidenční číslo
INVCISLO | C(20) | inventární číslo
CENA | Currency | cena
ZARAZENO | Date | datum zařazení
EXPORT | Date | datum vyřazení
ZAKOUPENO | Date | datum zakoupení
PORADI | Integer | pořadí exportu
NAZEV | C(40) | značka PC nebo název příslušenství
PRIHRANO | C(15) | datum přihrání (exportuje se prázdný)

Exportovaným větám hardware nebo příslušenství je zapsána položka UctoZarad nebo UctoVyrad a UctoExport (pořadí exportu). S těmito větami je v programu SPRÁVCE omezena manipulace, a to :

a) pokud je vyplněn Datum zařazení do účetnictví, nelze již opravovat cenu a druh majetku.

b) pokud je vyplněn Datum zařazení do účetnictví, nelze již větu zrušit. Zůstává v evidenci bez možnosti ji zrušit.

c) pokud je vyplněn Datum vyřazení z účetnictví, je do souboru oprav vygenerována věta Likvidace a věta je označena jako zlikvidovaná. Tuto likvidaci již nelze zrušit.


Export - ciselniku ze Spravce

Export – číselníky do Správce

Tato volba slouží k exportu číselníků z různých instalací programu SPRÁVCE nebo KSPRÁVCE nebo z dat vytvořených z jiných aplikací.

Volba Export slouží k exportu vybraných číselníků do zadaného adresáře, který nesmí být stejný jako je adresář s aktuálně otevřenými ostrými daty. Zvolené číselníky jsou do zvoleného adresáře vyexportovány ve formátu DBF a pod stejným názvem jako mají v programu SPRÁVCE.

Při výběru číselníků Názvy příslušenství, Oblasti 1 nebo Oblasti 2 se automaticky vybere i číselník Typy příslušenství.

Obdobně při výběru číselníku Názvy SW, se vyberou číselníky Výrobci SW a Oblasti SW.

Při výběru Softwarové vzory se vyberou Názvy SW, Výrobci SW a Oblasti SW.

Tyto podmínky jsou proto, že mezi uvedenými soubory existují vazby.


Udrzba - ciselníky (vymaz vet)

Kontrola číselníků

Tato volba umožňuje ve všech číselnících smazat věty, které nemají vazbu v hlavních souborech. Tzn. že číselníky budou obsahovat pouze věty, které se alespoň jednou vyskytují v hlavních souborech. Volba nabídne seznam všech číselníků a Vy musíte vybrat ty, u kterých chcete smazat věty bez vazeb. Po spuštění volba smaže všechny vět, které se nevyskytují v hlavních souborech bez rozlišení, jestli se jedná o schválené nebo neschválené věty (pro multilicence programu SPRÁVCE ).


Napoveda

Nápověda

Menu Nápověda obsahuje celý help, popis struktur podadresářů a základní informace o programu.


Napoveda - Zmeny

Změny

Na formuláři je zobrazen seznam změn a novinek poslední verze. Tyto změny jsou uloženy v souboru \HLP\ZMENY.RTF a zde je lze prohlédnout a vytisknout.

Nepodceňujte prohlédnutí těchto změn. Některé mohou být v programu skryté a zde jste na ně upozorněni. Tento formulář se automaticky spustí při každém upgrade.


Napoveda - o aplikaci

Nápověda – o aplikaci

Tato volba zobrazí důležité informace o aplikaci. Jedná se o následující údaje :

Název programu

Verzi programu

Datum kompilace

Licenční číslo

Přihlášený uživatel

Typ instalace

Kromě toho zobrazí i kontaktní údaje na autorskou firmu.


Napoveda - struktura podadresaru

Nápověda – struktura podadresářů

Tento formulář zobrazuje strukturu podadresářů programu SPRÁVCE. Barevně jsou rozlišeny typy adresářů :

Červené

datové adresáře. Tyto mají další strukturu, kterou lze zobrazit pomocí tlačítka Zobraz data.

Modré

různé konfigurační adresáře, sestavy, filtry apod.

Zelené

uživatelské adresáře všech uživatelů programu.

Černé

adresáře, které lze smazat. Mohou to být pozůstatky minulých verzí. Před smazáním je dobré prověřit, jaká data obsahují a potom je lze tlačítkem Smaž adresář nenávratně smazat.

Tento formulář Vám má pomoci v orientaci v jednotlivých adresářích.


.Uvod - nadstavba

NADSTAVBA

Program NADSTAVBA je určen jako doplňující modul pro organizace, které mají zakoupeno více instalací programu SPRÁVCE. Je určen pro centrální údržbu číselníků, výstup dat na nadřízenou organizaci a převody mezi závody.

Hlavní volby :

Přihrání centrálně udržovaných číselníků

Výstup dat na nadřízenou organizaci

Příjem na závod

Výstup ze závodu

Rušení v číselnících


Prihrani centralnich ciselniku

NADSTAVBA – přihrání centrálně udržovaných číselníků

Tato volba slouží k načtení číselníků dodaných nadřízenou organizací z programu KSPRÁVCE. Z tohoto nadřízeného programu budou dodány všechny centrálně udržované číselníky a konfigurační soubor (KONFIG2.DBF). Tento konfigurační soubor je pojmenován podle čísla závodu, pro který je určen (např. ZAVOD1. DBF). Přihrát lze pouze číselníky, které byly vytvořeny ve stejné verzi programu KSPRÁVCE jako je verze Vašeho programu SPRÁVCE.

Pro přihrání číselníků je vhodné nejprve ve volbě ÚDRŽBA - Konfigurace - šestá karta Multilicence nastavit adresář, ve kterém se nacházejí dodané soubory (parametr Centrální číselníky). Po výběru adresáře s centrálními číselníky je nutné vybrat konfigurační soubor závodu. Pokud nedošlo k organizační změně, je název konfiguračního souboru dán číslem závodu, které je nastaveno v Konfiguraci (např. ZAVOD1.DBF). Jestliže došlo k organizačním změnám a číslo závodu je jiné, je nutné vybrat soubor s novým číslem závodu (např. ZAVOD10.DBF). Dále je ještě nutné zatrhnout, zda chcete tisknout Protokol.

Nejdříve se zaktualizuje soubor KONFIG2.DBF podle dodaného konfiguračního souboru s centrálními parametry.

Při vlastním přihrávání centrálních číselníků jsou nejprve všechny položky každého aktuálního číselníku označené jako neschválené. Pak se aktuální a dodaný centrální číselník porovnají. Položky nalezené v centrálním číselníku se v aktuálním číselníku označí jako schválené, ostatní jsou ponechány neschválené.

Jestliže program při přihrávání centrálních číselníků organizačního členění, typů příslušenství, servisů a volného číselníku nalezne jejich duplicitní hodnoty, nabídne formulář Duplicitní hodnoty v číselnících, který umožní provést opravu.

Pokud byl z centra dodán soubor s centrálními licencemi SW (např.ZAVOD01.LIC), zaktualizuje se o dodané položky soubor software. Pokud je v dodaných větách nějaká nová licence, je tato automaticky vložena do souboru software. Centrální licence, které z centra nebyly dodány, budou odřazeny od počítačů a věta v software bude smazána. Při aktualizaci software centrálními licencemi je rovněž zaktualizován soubor oprav. Automaticky jsou u centrálních licencí smazány z oprav věty se stavem 1 (uvedení), 5 (servis) a 8 (likvidace) a soubor je zaktualizován daty oprav dodanými z centra. Dále bude zaktualizován soubor firem.

Na konci přihrání číselníků lze vytisknout protokol o provedené aktualizaci číselníků.

Seznam možných centrálních číselníků

CIS_ORGA.DBF - číselník organizačního členění

CIS_SOFT.DBF - číselník názvů software

CIS_OBLA.DBF - číselník oblastí software

CIS_OSSW.DBF - číselník operačních systémů software

CIS_VYR.DBF - číselník výrobců software

CIS_PTYP.DBF - číselník typů příslušenství

CIS_PNAZ.DBF - číselník názvů příslušenství

CIS_POB1.DBF - číselník oblastí příslušenství

CIS_HPOU.DBF - číselník použití HW

CIS_HZNA.DBF - číselník značek HW

CIS_OSHW.DBF - číselník operačních systémů hardware

CIS_SERV.DBF - číselník servisů

CIS_VOLNY.DBF - číselník volný

PROTOKOL.* - předávací protokoly

SW_LIST.DBF - vzory software


Vystup na nadrizenou organizaci

NADSTAVBA – výstup na nadřízenou organizaci

V této volbě se vytváří soubor pro Nadřízenou organizaci (pro program KSPRÁVCE). Tento výstup obsahuje všechny důležité soubory z programu SPRÁVCE. Struktura těchto souborů je stejná, s tím rozdílem, že u většiny souborů je doplněna položka Závod, která určuje odkud byla data zaslána. Položka Závod není v číselnících, u kterých není důležitá (např. číselník Značek HW, Použití HW apod.)

Všechny vytvořené soubory jsou automaticky zkomprimovány. Název výstupního souboru je určen číslem Vašeho závodu nastaveného v Konfiguraci. Výstupní soubor se vytvoří do zvoleného adresáře, který máte nastaven taktéž v této konfiguraci.


Prijem na zavod

NADSTAVBA – příjem na závod

Tato volba slouží k přihrání datových souborů z jiného závodu (jiné instalace programu SPRÁVCE). Soubor dodaný z jiného závodu má v názvu číslo dodávajícího závodu a předponu V_. Tyto datové soubory musí být vytvořeny ve stejné verzi programu SPRÁVCE jako verze, kde se přihrávají. Datové soubory jsou komprimovány.

Před spuštěním příjmu je vhodné nejprve ve volbě ÚDRŽBA - Konfigurace - šestá karta Multilicence nastavit adresář, ve kterém se nacházejí přijímané soubory (parametr Příjem ze závodu). Po spuštění a nastavení adresáře s dodanými soubory je nutné uvést číslo závodu, ze kterého data pocházejí a zvolit, zda bude tištěn přijímací protokol.

Při vlastním příjmu jsou věty dodaných souborů přečíslovány v souladu s číslováním Vašeho přijímajícího závodu. Nejprve se zjistí poslední číslo Vašeho souboru (např. H0020). Přihrávané věty jsou potom číslovány od následujícího čísla (např. H0021). Pokud se u číselníku typů příslušenství objeví duplicitní hodnota, spustí se formulář Duplicitní hodnoty v číselnících, který umožní provést opravu.


Vystup ze zavodu

NADSTAVBA – výstup ze závodu

Formulář slouží pro převod dat na jiný závod a má tři karty. První karta slouží k vlastnímu převodu, jsou na ní zobrazeny celkové počty převáděných zařízení. Na druhé kartě je zobrazen přehled vět ze všech souborů, které jsou vybrány pro vlastní převod. Třetí karta je určena pro výběr jednotlivých vět pro převod.

Výběr vět

při výběru převáděných vět lze na třetí kartě nastavit výběr jednotlivých kusů nebo podle odpovědné osoby, umístění nebo organizačního členění. To je vlastně hrubý filtr. Další jemnější výběr lze specifikovat výběrem souboru hardware, software, příslušenství, dokumentace, sítě a požadavků.

Konečný výběr provedete zaškrtnutím pole v prvním sloupci mřížky zvolené věty zvoleného souboru. Takto označená položka se zobrazí modrou barvou a současně se spolu s přiřazenými vazbami objeví v seznamu převáděných dat na druhé kartě formuláře. Hardware, software, příslušenství a sítě, které jsou zlikvidované (STAV = 8), nelze převádět. Takto lze vybírat věty ze všech souborů pomocí různých kombinací. Pro jednotlivé hlavní soubory při výběru platí následující omezení :

1) při vybrání hardware se automaticky převádí všechno přiřazené příslušenství, nainstalovaný software a dokumentace přiřazená k počítači, jeho příslušenství a software. Pokud je počítač v sítí, pak se u této sítě zmenší počet stanic. U nainstalovaného software se o počet převáděných instalací zmenší počet instalací k použití a tento počet je připočten k počtu převedených instalací. Rovněž u převáděné dokumentace se změní počet kusů. Pokud nechcete nainstalovaný software převádět, je nutné jej před převodem nejprve odinstalovat.

2) příslušenství lze samostatně převádět jen pokud není přiřazené k žádnému počítači, dále lze převádět samostatné a síťové příslušenství. S vybraným příslušenstvím je současně převedena i příslušná dokumentace. Pokud nechcete přiřazené příslušenství převádět, musíte jej před převodem nejprve odřadit.

3) u software můžete převádět jen takový software, který má volnou instalaci (nejedná se o multilicenci) nebo pokud se jedná o multilicenci. Převedené instalace budou odečteny od volných instalací a přičteny do položky převedených instalací. Spolu se softwarem bude automaticky převedena přiřazená dokumentace. Software, který je nainstalovaný na počítači, lze převést pouze při převedení počítače nebo se musí předem odinstalovat.

4) u převodu software a dokumentace se spustí formulář Kolik kusů, který umožní zadat počet převáděných kusů multilicencí software nebo dokumentace

5) při převodu sítí se převede jen síť s příslušnou dokumentací bez počítačů a příslušenství.

6) u hardware, software, příslušenství a sítí se převádějí i příslušné údaje o opravách.

Převod vět

tlačítkem Výstupní soubory na první kartě se vytvoří soubor s převáděnými daty. Tento soubor se ukládá do Vámi zvoleného adresáře a je komprimován. Tento adresář lze přednastavit ve volbě ÚDRŽBA - Konfigurace - šestá karta Multilicence - parametr Výstup ze závodu. Název souboru je určen číslem Vašeho závodu s předponou V_.

POZOR

Převedené věty ve Vašich souborech mohou zůstat nebo mohou být smazány. To je závislé na parametru Po převodu na závod převádění data zrušit, který si nastavíte ve volbě ÚDRŽBA - Konfigurace - šestá karta Multilicence. Převedené věty jsou rovněž zapsány do archivních souborů bez ohledu na to, zda jsou v hlavních souborech zrušeny a nebo tam zůstanou.


Ruseni v centralnich ciselnicich

NADSTAVBA – rušení v centrálně udržovaných číselnících

Tato volba umožňuje zrušit ve všech číselnících neschválené věty, které nemají žádnou vazbu. Tzn. že tyto hodnoty nejsou v žádném hlavním souboru. Např. neschválenou větu číselníku umístění můžete zrušit pouze v případě, že její hodnota neexistuje v souborech hardware, příslušenství, dokumentace, sítí apod.

Po stisku tlačítka OK program projde postupně všechny vybrané číselníky a zjistí, zda neschválené věty mají nějaké vazby. V číselníku příslušenství se neruší typy začínající na "K". Pokud neschválené věty nemají vazby v ostatních souborech, program je zruší. Tím dojde k vyčištění číselníků o nepotřebné neschválené věty.


Konfigurace - parametry

Parametry Konfigurace a hromadné zadávání hodnot Oprav

Tento formulář lze vyvolat stiskem příslušného tlačítka na Panelu nástrojů vždy. Jsou zde umístěny vybrané parametry Konfigurace a hodnoty Oprav, pokud bylo použito hromadné zadávání hodnot Oprav.

Parametry Konfigurace

Zachovat velikost a umístění

pokud je nastaven tento parametr, program si při zavírání každého formuláře uloží velikost a umístění formuláře na obrazovce. Při následujícím spuštění bude formulář nastaven v té samé podobě a poloze.

Nezobrazovat úvodní obrazovku

při prvním spuštění programu se zobrazí formulář Výběr datových souborů, který umožňuje před pořízením vlastních dat si program vyzkoušet na demonstračních datech. Pokud již DEMO data nebudete potřebovat, můžete buď na úvodním formuláři Výběr datových souborů nebo zde zaškrtnout tento parametr a úvodní formulář s možností použít DEMO data se Vám při spouštění již nebude objevovat a vždy se spustí ostrá data. Pokud máte v evidenci data více firem/závodů je tento parametr nepřístupný a úvodní obrazovka se vždy spustí.

Zobrazit interní příslušenství

tento parametr ovlivňuje, zda v mřížkách příslušenství bude zobrazeno i interní příslušenství (např. board, paměť,...). O tom, které příslušenství je interní, rozhodujete v číselníku typu příslušenství. Tento parametr má význam, jen pokud v mřížkách s vazbami nechcete vidět interní příslušenství.

Tisk protokolu hromadného rušení vět

tento parametr slouží k výběru, zda při hromadném rušení vět bude vytištěn protokol o rušení.

Tisk vět bez vazeb

při tisku umožňuje ignorovat věty, které nemají podřízené vazby (např. počítač, který nemá žádný nainstalovaný software).

Tisk grafických rámečků

při tisku umožňuje ignorovat výplně rámečků sestav.

Tisk přílohy předávacího protokolu HW

tento parametr slouží k výběru, zda přílohu předávacího protokolu HW chcete tisknout na zvláštním listu nebo na konci sestavy.

Opravy

pokud je uplatněno příslušné hromadné zadání hodnot je položka Hromadné zadání zaškrtnuta a přístupná. V tomto případě je možno indikaci příslušného hromadného zadání oprav zrušit, pak se bude formulář pro zadávání hodnot oprav opět zobrazovat. Ostatní hodnoty pouze zobrazují svou aktuální hodnotu.


Zpracovani Hw-scanu - vysledky zpracovani

Zpracování scanů – výsledky zpracování

Jestliže jste při zpracování označili ke zpracování více než jeden počítač, provede program nejprve kontrolu všech nascanovaných souborů s evidencí hardware. Po této kontrole provede automaticky zpracování všech počítačů, které jsou v pořádku (nedošlo ke změně Názvu PC nebo MAC adresy).

Po zpracování TXT souborů program zobrazí tento formulář, a to pouze v následujících případech :

1. při spuštění v programu RemoteScan vždy

2. při spuštění ve volbě Zpracování scanu HW jen tehdy, pokud se nezpracoval alespoň jeden soubor. V případě, že byly všechny soubory v pořádku a zpracovaly se, se tento formulář neobjeví.

Formulář zobrazuje všechny počítače, které byly označeny ke zpracování. V posledním sloupci je zobrazen výsledek, zda bylo zpracování provedeno v pořádku nebo ne.


Zpracovani Hw-scanu - prohlizeni TXT souboru

Scan HW – prohlížení TXT souborů

Tento formulář slouží pouze k prohlédnutí nascanovaného TXT souboru.


Zpracovani Hw-scanu - konfiguracni soubory

Zpracování scanu HW – konfigurační soubory

Scanovací moduly scanu HW jsou při zjišťování některých údajů závislé na aktuálním operačním systému. Může se stát, že některý údaj na různém operačním systému může nabývat jiných hodnot. Proto vznikly konfigurační soubory HH_*.DBF, které Vám umožňují tyto údaje sjednotit a nastavit podle Vašich představ. Tato volba zobrazuje tyto konfigurační soubory a umožňuje jejich úpravu. Každá karta obsahuje jeden konfigurační soubor :

Procesory – Název

Hard disky - Kapacita

PCI karty - Název

Pozor :

úprava názvu nebo kapacity se nepromítne přímo do existujících dat. Je nastavena v konfiguračním souboru a do již existujících názvů příslušenství se promítne až při dalším zpracování TXT souborů.


Zpracovani Hw-scanu - konfiguracni soubory (Procesory)

Zpracování scanu HW – konfigurační soubory

Procesory – Název

· Konfigurační soubor se jmenuje HH_PROC.DBF.

· Jedná se o soubor pro úpravu položky NAZEV v souboru příslušenství.

· Výsledný název procesoru má 40 znaků, skládá se z typu procesoru (29 znaků+“ “) a jeho frekvence (10 znaků).

· Sloupec Výrobce a ID určují jednoznačně výrobce a typ procesoru. Tyto položky jsou zkompilované ve scanovacích modulech a mění je pouze autorská firma v okamžiku vzniku nového typu procesoru.

· Sloupec Původní název slouží pro Vaši orientaci, aby jste věděli o jaký typ procesoru se jedná. V okamžiku totální změny sloupce Název by jste nevěděli, o jaký typ procesoru jde.

· Sloupec Název se použije pro Název, který se vygeneruje a uloží do souboru Příslušenství. Můžete ho ve mřížce přímo editovat.

· Postup vygenerování názvu procesoru při zpracování TXT souborů z Hw-scanu :

o        ve výstupním souboru se přečte položka ID ( např. 63I )

o        v souboru HH_PROC se najde ID=63I a vezme položka NÁZEV. Z této se odstraní všechny mezery na začátku a na konci ( např. “Pentium III“ ).

o        k této hodnotě se přidá jedna mezera ( např. “Pentium III “ ).

o        k této hodnotě se přidá z výstupního souboru položka FREK (frekvence procesoru) ve tvaru “99 999 MHz“ ( např. “Pentium III 10 000 MHz“ ).

o        frekvence procesoru je vždy na 10 znaků tak, aby byly frekvence správně setříděny podle velikosti (frekvence menší než 10 000 MHz mají na začátku doplněny mezery).

· Z výše uvedeného vyplývá, že položku Název v souboru HH_PROC, která má 29 znaků, můžete libovolně upravovat podle Vašich představ a zvyků (můžete využít všech 29 znaků). Rada – možná je vhodné na konec textu Název dát nějaké oddělovací znaménko (např. pomlčku). Takže název procesoru může pak vypadat “Pentium III – 10 000 MHz“.

· Ze souboru HH_PROC nemůžete žádný procesor zrušit, rušení vět je zakázáno.

· Pozor – při prvním zpracování TXT souborů již zaevidovaných počítačů (po provedení upgrade na verzi 8.03b nebo po Vašich úpravách) Vám bude program signalizovat, že došlo ke změně názvu procesoru a budete muset starý formát názvu procesoru přepsat novým.


Zpracovani Hw-scanu - konfiguracni soubory (Hard disky)

Zpracování scanu HW– konfigurační soubory

Hard disky – Kapacita

· Konfigurační soubor se jmenuje HH_HARD.DBF.

· Jedná se o soubor pro úpravu položky OBLAST1 v souboru příslušenství. Do této položky se načítá sloupec Kapacita.

· Sloupec Název určuje jedinečný název disku.

· Sloupec Kapacita určuje kapacitu disku udanou výrobcem, je udávána v MB. U kapacity není stanovena nějaká jednotnost při udávání velikosti, každý výrobce udává velikost podle sebe (hodnoty pro disky stejných velikostí se mohou lišit např. 51MB, 52MB apod.). Hodnoty ve sloupci lze editovat, takže můžete rozličné velikosti sjednotit podle vlastních potřeb ( např. kapacita 50, 100, 500, 1000 MB apod. ).

· Postup určení kapacity disku při zpracování TXT souborů z Hw-scanu :

o        v nascanovaném souboru se přečte položka Název disku.

o        v souboru HH_HARD se bude hledat tato hodnota. Pokud se :

· najde stejný NÁZEV, vezme se hodnota položky Kapacita a vloží se do příslušenství do položky OBLAST1.

· nenajde stejný NÁZEV, vezme se z nscanovaného souboru údaj VELIKOST (jedná se o kapacitu disku vypočtenou matematicky – nemusí být stoprocentně přesná) a tato hodnota se vloží do příslušenství do položky OBLAST1. Zároveň se do konfiguračního souboru HH_HARD vloží název disku a vypočtená velikost. Vypočtenou velikost si můžete v konfiguračním souboru později upravit.

· Disky vložené do konfiguračního souboru během zpracování jsou označeny modrou barvou a nemají doplňující údaje.

· Pod mřížkou je přepínač, kterým můžete přepnout na seznam všech disků nebo jen nově přidaných během zpracování.

· Ostatní údaje v konfiguračním souboru jsou informativní a do příslušenství se nedotahují.

· Doporučení -

o        upravte si kapacity disků rozumně (např. 10000MB, 20000MB, …).

o        v souboru HH_HARD můžete disky, které víte, že nikde nepoužíváte klidně zrušit. Slouží k tomu ikona v horním toolbaru (stejná jako pro rušení vět v hlavních datových souborech a číselnících).

· Pozor – kapacita disku není brána jako základní parametr při zpracování (tím je pouze název disku a jeho výrobní číslo). To znamená, že pokud upravíte v konfiguračním souboru kapacity a provedete nové zpracování, bude nová hodnota automaticky zapsána bez nějakého dotazu.

Pozor :

úprava kapacity se nepromítne přímo do existujících dat. Je nastavena v konfiguračním souboru a do již existujících názvů příslušenství se promítne až při dalším zpracování TXT souborů.


Zpracovani Hw-scanu - konfiguracni soubory (PCI karty)

Zpracování scanu HW – konfigurační soubory

PCI karty – Název

· Konfigurační soubor se jmenuje HH_PCI.DBF.

· Jedná se o soubor pro úpravu položky NAZEV v souboru příslušenství.

· Sloupec ID určuje jednoznačně PCI kartu.

· PCI karta se může objevit u typů K004 (video karta), K008 (síťová karta), K014 (zvuková karta) a K019 (řadič)

· Postup určení názvu PCI karty při zpracování TXT souborů z Hw-scanu :

o        v nascanovaném souboru se přečte položka PCI_INF ( např. 1002.4755 )

o        v souboru HH_PCI se bude hledat ID= 1002.4755. Pokud se :

· najde, vezme se hodnota položky Název a vloží se do příslušenství do položky Název.

· nenajde, vezme se Název přímo z nascanovaného souboru (jedná se o název PCI karty zjištěný z registrů Windows nebo přímo z ovladače) a do příslušenství se vloží do položky Název. Zároveň se do konfiguračního souboru HH_PCI vloží název ID a název PCI karty z nscanovaného souboru.

· PCI karty vložené do konfiguračního souboru během zpracování jsou označeny modrou barvou.

· Pod mřížkou je přepínač, kterým můžete přepnout seznam všech PCI karet nebo jen nově přidaných během zpracování.

· Doporučení -

o        upravte si názvy PCI karet podle vlastní potřeby

o        v souboru HH_PCI můžete PCI karty, které víte, že nikde nepoužíváte klidně zrušit. Slouží k tomu ikona v horním toolbaru (stejná jako pro rušení vět v hlavních datových souborech a číselnících).

· Pozor – při prvním zpracování TXT souborů již zaevidovaných počítačů (po provedení Vašich úprav) Vám bude program signalizovat, že došlo ke změně názvu PCI karty a budete muset starý formát názvu přepsat novým.

Pozor :

úprava názvu se nepromítne přímo do existujících dat. Je nastavena v konfiguračním souboru a do již existujících názvů příslušenství se promítne až při dalším zpracování TXT souborů.


Vystup ze zavodu (archiv)

Archivní soubory

Tyto soubory se nacházejí v adresáři ARCH_ZR a jejich název začíná znaky A_. Tyto soubory se nekontrolují při spuštění programu, ale až v okamžiku zápisu do nich. Pokud soubor neexistuje je automaticky vytvořen nový prázdný soubor. Do těchto souborů se zapisují věty, které byly převedeny na jiný závod. V budoucnu se zde budou zapisovat např. rušené věty nebo výběry pro některé další operace. Struktura souborů je totožná se strukturou hlavních souborů a jsou k ní přidány položky pro zapsání data a času operace, názvu operace a uživatele, který ji provedl.


Duplicita

NADSTAVBA – duplicita v číselnících

Tento formulář se objeví pouze v okamžiku, kdy aktuální číselník nesouhlasí s přihrávaným. Formulář nabízí možnost upravit aktuální číselník nebo přihrávaný číselník. Mohou nastat následující možnosti :

Příjem dat z jiného závodu :

· možné duplicity se týkají pouze číselníku typů příslušenství

· v okamžiku duplicity můžete provést :

o        upravit na aktuální - název ze zaslaného číselníku se přepíše názvem z aktuálního číselníku

o        dodané přečíslovat - číslo ze zaslaného číselníku se přepíše číslem z aktuálního číselníku


Prevod dokumentace

NADSTAVBA – převod dokumentace

Tento formulář slouží ke stanovení počtu převáděných kusů dokumentace nebo software.


Duplicita

NADSTAVBA – duplicita v číselnících

Tento formulář se objeví pouze v okamžiku, kdy aktuální číselník nesouhlasí s přihrávaným. Formulář nabízí možnost upravit aktuální číselník. Mohou nastat následující možnosti :

v okamžiku duplicity můžete provést :

· změnit původní číslo - u původní věty se přepíše číslo a označí se jako neschválena, nová věta bude vložena

· přepsat původní název - původní název se přepíše názvem ze zaslaného centrálního číselníku


RemoteScan - vytvoreni skupiny

RemoteScan – vytvoření skupiny

Skupiny počítačů ve stromu jsou vlastně jednotlivé organizační jednotky, které odpovídají číselníku organizačního členění. Pro snadnou práci by měl být tento číselník navržen tak, aby každá organizační jednotka obsahovala kolem 10-30 počítačů. Tento počet je optimální pro snadnou orientaci a práci při scanech a zpracování.

Vytvořit novou skupinu lze :

1. importem celého číselníku organizačního členění ve volbě Údržba - Import

2. vytvořením nových vět ručně ve volbě Číselníky – Organizační členění

3. na formuláři RemoteScan tak, že spustíte přidání nového počítače nebo opravu dat nějakého počítače a na pravé straně zadáte u organizačního členění novou neexistující hodnotu. Program se zeptá, zda tuto hodnotu chcete zavést do číselníku.


RemoteScan - novy pocitac (rucne)

RemoteScan – nový počítač (ručně)

Nový počítač lze ručně na formuláři RemoteScanu vytvořit dvěma způsoby :

1. kursor nastavíte ve stromu buď na :

a) jeho kořen (root = název firmy). V tomto případě se nový počítač vytvoří s nevyplněným org. členěním (pokud ho dále ručně neopravíte)

b) na skupinu. V tomto případě se nový počítač začlení automaticky do této skupiny.

  • vytvoření počítače provedete stiskem tlačítka Přidání nové věty v horním toolbaru na konci (modrá ikona na následujícím obrázku) :

  • po stisku tlačítka Přidání nové věty se na pravé straně formuláře zpřístupní položky k editaci. Pokud je nastaveno automatické číslování evidenčních čísel, přidělí program novému počítači evidenční číslo a musíte vyplnit název počítače. Pokud chcete změnit zařazení do skupiny, musíte vyplnit nebo opravit položku organizační členění.

2. kursor nastavíte na požadovanou skupinu a pomocí pravého tlačítka myši vyvoláte následující menu :

Pomocí volby Ruční přidání jednoho PC spustíte stejnou volbu jako v předchozím bodě (jako by jste stiskli ikonu Přidání nové věty). Opět musíte vyplnit evidenční číslo a název počítače, ostatní údaje nejsou povinné.

Uložení nového počítače pro oba způsoby lze provést na konci horního toolbaru pomocí zelené ikony Uložení provedených změn. Pomocí červené ikony Návrat bez uložení změn lze provedené změny nezapisovat :

Po uložení změn je počítač začleněn do skupiny stromu podle vyplněného organizačního členění. Je-li zapnuta komunikace, pokusí se server po začlenění nového počítače navázat spojení s klientem a zobrazí ikonu odpovídající jeho stavu.


RemoteScan - novy pocitac (ze site)

RemoteScan – nový počítač (načtení z Active Directory)

Nový počítač lze na formuláři RemoteScanu vytvořit načtením z Active Directory:

1. předem se ve stromu přepněte na skupinu, do které chcete počítače přidávat (ve výběru org. členění nad stromem). Pokud chcete, aby nově přidané počítače neměly vyplněné organizační členění, přepněte skupinu ve stromu na Nevyplněné organizační členění. Výhodnější je však přepnout se na určité organizační členění a nové počítače přidávat přímo do něj.

2. v konfiguraci RemoteScanu musí být zadán název serveru s databází Active Directory a doména.

3. Program načte všechny počítače z Active Directory a pokud najde počítač který ještě není v evidenci zobrazí se formulář se seznamem všech neexistujících počítačů.

4. v prvním sloupci tohoto formuláře můžete označit počítače, které chcete zavést do nastavené skupiny. Pozor – jelikož můžete počítače vybrat náhodně z celého seznamu, nebudou mít evidenční čísla souvislou řadu. Je výhodné v prvním sloupci navržená evidenční čísla opravit.

5. po odsouhlasení evidenčních čísel a stisku tlačítka OK, jsou všechny označené počítače vygenerovány do souboru hardware a zařazeny do nastavené skupiny.

6. je-li zapnuta komunikace, pokusí se server po začlenění počítačů navázat spojení s klienty a zobrazí ikony odpovídající jejich stavu.


RemoteScan - novy pocitac (pomoci IP adresy)

RemoteScan – hromadné zadání IP adres

Pokud neznáte jména jednotlivých počítačů a nevidíte je na kartě Síť , můžete nové počítače zadat ručně. Pomocí pravého tlačítka myši spusťte volbu Ruční přidání více PC pomocí IP adresy.

Touto volbou se vyvolá formulář ze kterého lze spustit externí program Host_Detector, který slouží k vyhledání PC v zadaném rozsahu IP adres. Po zpracování výstupů z programu Host_Detector se zobrazí seznam počítačů pro přidání do databáze :

· v prvním sloupci tohoto formuláře můžete označit počítače, které chcete zavést do nastavené skupiny. Pozor – jelikož můžete počítače vybrat náhodně z celého seznamu, nebudou mít evidenční čísla souvislou řadu. Je výhodné v prvním sloupci navržená evidenční čísla opravit.

· po odsouhlasení evidenčních čísel a stisku tlačítka OK, jsou všechny označené počítače vygenerovány do souboru hardware a zařazeny do nastavené skupiny.

· je-li zapnuta komunikace, pokusí se server po začlenění počítačů navázat spojení s klienty a zobrazí ikony odpovídající jejich stavu.


RemoteScan - novy pocitac (ze site)

RemoteScan – nový počítač (ze sítě)

Nový počítač lze na formuláři RemoteScanu vytvořit také přímo ze sítě:

1. předem se ve stromu přepněte na skupinu, do které chcete počítače přidávat (ve výběru org. členění nad stromem). Pokud chcete, aby nově přidané počítače neměly vyplněné organizační členění, přepněte skupinu ve stromu na Nevyplněné organizační členění. Výhodnější je však přepnout se na určité organizační členění a nové počítače přidávat přímo do něj.

2. pro přidávání počítačů musí být vypnuta komunikace. Přepnete se na kartu Síť, kde přejdete ve struktuře až na doménu (skupinu) počítačů nebo na jednotlivé počítače. Pomocí pravého tlačítka spustíte menu, které Vám umožní přidat najednou celou skupinu nebo jednotlivý počítač.

3. pokud přidáváte více počítačů do jedné skupiny, je výhodnější je přidat najednou přes volbu Přidat celou skupinu. Program bude chvíli procházet celou skupinu a nakonec Vám program zobrazí formulář se seznamem všech připojených počítačů (odpojené počítače přeskočí).

4. v prvním sloupci tohoto formuláře můžete označit počítače, které chcete zavést do nastavené skupiny. Pozor – jelikož můžete počítače vybrat náhodně z celého seznamu, nebudou mít evidenční čísla souvislou řadu. Je výhodné v prvním sloupci navržená evidenční čísla opravit.

5. po odsouhlasení evidenčních čísel a stisku tlačítka OK, jsou všechny označené počítače vygenerovány do souboru hardware a zařazeny do nastavené skupiny.

6. je-li zapnuta komunikace, pokusí se server po začlenění počítačů navázat spojení s klienty a zobrazí ikony odpovídající jejich stavu.


RemoteScan - zmena skupiny ve stromu

RemoteScan – změna skupiny ve stromu

Změnu skupiny lze provést :

1. nad stromem je seznam označený Org. členění.

2. při jeho rozbalení se kromě vlastního číselníku organizačního členění objeví i následující dvě hodnoty :

a) Nevyplněná org. členění - seznam počítačů, které nepatří do žádné organizační skupiny

b) Všechny org. členění - ve stromu se objeví všechny organizační skupiny

3. po výběru některé hodnoty z rozbaleného seznamu nastaví program ve stromu pouze vybranou skupinu.

4. je-li zapnuta komunikace, pokusí se server po změně skupiny navázat spojení s klienty a zobrazí ikony odpovídající jejich stavu.

5. pokud máte větší počet počítačů, je výhodné pracovat pouze s jednou skupinou. Práce a výsledky jsou přehlednější.


RemoteScan - zmena skupiny pocitace

RemoteScan – změna skupiny počítače

Změnu skupiny u počítače lze na formuláři RemoteScanu vytvořit takto:

1. kursor nastavíte ve stromu na požadovaný počítač

2. stisknete tlačítko Oprava aktuální věty v horním toolbaru na konci (druhá ikona zleva) :

3. po stisku tlačítka se na pravé straně formuláře zpřístupní položky k editaci. Musíte změnit zařazení do skupiny - musíte opravit položku organizační členění.

4. po uložení změny, je počítač začleněn do stromu podle vyplněného organizačního členění.

5. je-li zapnuta komunikace, pokusí se server po začlenění počítače navázat spojení s klientem a zobrazí ikonu odpovídající jeho stavu.


RemoteScan - komunikace

RemoteScan – komunikace

Zapnout komunikaci podle je parametr umístěný nad stromem a má následující význam :

1. znamená vlastně zapnutí/vypnutí komunikace mezi serverem a jednotlivými klienty. Je možné zvolit zda se bude s klienty komunikovat pomocí Názvu PC nebo IP adresy. Pokud zvolíte podle Názvu PC, musíte mít v databázi hardware vyplněné správné názvy PC a při přidávání nových PC, musíte znát zase jejich správné názvy. Pokud zvolíte komunikaci podle IP adresy, musíte mít v databázi vyplněnou správnou IP adresu. Název PC v tomto případě musíte zvolit libovolně. Při první scanu si strom zjistí správné názvy PC a zapíše je do databáze.

2. při prvním spuštění formuláře RemoteScanu je komunikace vždy vypnutá. Navíc pokud nemáte zakoupený program RemoteScan, je změna (zapnutí) komunikace zakázána a máte pouze povolené funkce stromu, které nevyžadují komunikaci (nemůžete scanovat a ovládat klienta).

3. komunikaci může zapnout současně pouze jeden uživatel. Program je ošetřen tak, že pokud má již komunikaci někdo zapnutou, nikdo jiný ji nezapne, dokud ji držitel neuvolní. Pokud tedy pracuje současně několik uživatelů, je vhodné mít komunikaci zapnutou jen na nezbytně nutnou dobu.

4. zapnutí komunikace způsobí, že server se pokusí navázat spojení se všemi počítači, které má zobrazené ve stromu. Podle toho, jak spojení dopadlo, zobrazí server jednotlivé počítače příslušnou barvou :

zelená - spojení se navázalo, počítač je zapnutý a má nainstalovaného klienta

červená - spojení se nenavázalo, počítač nemá nainstalovaného klienta

černá - spojení se nenavázalo, počítač je vypnutý, nebo po síti nedostupný

žlutá - spojení se navázalo, ale došlo ke změně evidenčního čísla počítače (H00000xx). Klient má totiž u sebe poznamenané evidenční číslo, které měl počítač při posledním spojení. Pokud jste z nějakého důvodu v programu SPRÁVCE změnili evidenční číslo počítače, server zjistí tuto změnu a nepovolí práci s tímto počítačem, dokud tuto změnu neopravíte. Musíte proto na tyto počítače spustit volbu Změna UID, která sladí evidenční čísla poznamenané u klientů s evidenčními čísly v databázi hardware.

modrá - spojení se navázalo, ale ClientRS je starý.

Dále je při zapnutí komunikace vypnuta karta Síť (nelze přidávat nové počítače, když např. probíhá scan celé skupiny počítačů).

Naopak je zapnuta karta Procesy, která při nastavení kursoru na nějaký počítač umožňuje zobrazit všechny procesy v paměti daného počítače a případně je shodit.

Řešení chybných stavů :

Červená – komunikace nebyla navázána, nemá nainstalovaného klienta. V tomto případě je nutné prověřit instalaci klienta.

Žlutá – v programu SPRÁVCE došlo ke změně evidenčního čísla (ruční oprava evidenčního čísla ve volbě HW audit – Evidence hardware). Komunikace s tímto počítačem je funkční, ale nelze provádět scanování a ani další funkce. Musíte spustit volbu Administrace klienta - Oprava evidenčního čísla aktuálního počítače, která zašle klientovi nové evidenční číslo.

Modrá – komunikace byla navázána, program ale signalizuje, že na daném počítači je starý klient. Scanování a ostatní funkce mohou fungovat (záleží to velikosti změn nové verze klienta), ale také nemusí. Musíte provést UPDATE klienta. K tomu slouží volba Administrace klienta – Update klienta.

5. vypnutí komunikace způsobí, že server přeruší komunikaci se všemi klienty a zapne kartu Síť.

6. Pozor – z důvodu minimalizace zatížení sítě a jednotlivých PC není zapnutá komunikace ON LINE. To znamená, že počítače, které se zapnou až po zapnutí komunikace se automaticky nezobrazí zeleně. Musíte občas komunikaci vypnout/zapnout nebo použít funkci Zjistit stav.


RemoteScan - oprava hardware

RemoteScan – oprava hardware

Formuláři RemoteScan je vytvořen nejen pro scanování HW,SW a další síťovou komunikaci, ale také k prohlížení a editaci všech údajů. Obsahuje všechny možnosti, které Vám nabízí v menu HW audit volba Evidence hardware.

Můžete zde počítače rušit, hledat a tisknout všechny sestavy (pozor – sestavy, u kterých nastavíte rozsah = všechny věty, tisknou všechny počítače zobrazené ve stromu. Pokud máte např. nastavenou jednu skupinu, vytisknou Vám tyto sestavy pouze tuto skupinu).

1. pokud se myší pohybujete ve stromu po počítačích, na pravé straně formuláře se Vám objevují kompletní údaje o počítači.

2. pro změnu údajů stiskněte tlačítko Oprava aktuální věty v horním toolbaru na konci (druhá ikona zleva) :

3. po stisku tlačítka se na pravé straně formuláře zpřístupní položky k editaci, zde můžete editovat všechny přístupné položky. Položky, které jsou nepřístupné, nelze editovat, jejich změna se provede např. automaticky při zpracování scanu HW.

4. pokud jste v rámci editace změnili organizační členění, je počítač po uložení změn začleněn do stromu podle vyplněného organizačního členění.


RemoteScan - software

RemoteScan – software

Pravá strana formuláře RemoteScan pro vazby software obsahuje vlastně zmenšenou a trochu upravenou variantu formuláře pro hromadné zpracování nascanovaných souborů ze scanu SW.

Princip práce je stejný, takže podrobnosti naleznete v helpu SW audit – Zpracování scanu SW.


RemoteScan - prisluse

RemoteScan – příslušenství

Pravá strana formuláře RemoteScan pro vazby příslušenství obsahuje vlastně zmenšenou a trochu upravenou variantu formuláře pro hromadné zpracování nascanovaných souborů ze scanu HW.

Princip práce je stejný, takže podrobnosti naleznete v helpu HW audit – Zpracování scanu HW.


RemoteScan - opravy (historie oprav)

RemoteScan – opravy (historie oprav)

Pravá strana formuláře RemoteScan pro vazby opravy obsahuje vlastně kartu Opravy z Evidence hardware.

Princip práce je stejný, jen funkce nejsou umístěny na samostatných tlačítkách, ale fungují přes menu pravého tlačítka myši :


RemoteScan - dokumentace

RemoteScan – dokumentace

Pravá strana formuláře RemoteScan pro vazby dokumentace obsahuje vlastně kartu vazby DOK z Evidence hardware.

Princip práce je stejný, příslušné funkce naleznete přes menu pravého tlačítka myši.


RemoteScan - pozadavky

RemoteScan – požadavky

Pravá strana formuláře RemoteScan pro vazby požadavky obsahuje seznam požadavků na aktuální počítač.

Příslušné funkce naleznete přes menu pravého tlačítka myši.


RemoteScan - VNC pristup

RemoteScan – VNC přístup

Funkce VNC přístup umožňuje převzít na vzdáleném počítači obrazovku, klávesnici a myš.

Pro správnou funkci VNC přístupu je nutné dodržet následující postup :

1. před instalací ClientaRS musíte spustit program ScanCFG, ve kterém se definují všechny potřebné parametry. Zde musíte v dolní části obrazovky nastavit parametr VNC přístup na hodnotu Ano. Dále zde musíte zadat heslo, které se bude používat pro VNC přístup na vzdálený počítač.

2. při spuštění VNC přístupu ze serveru musíte zadat správné heslo :

3. Pokud bylo správně zadáno heslo je automaticky navázáno spojení a převzata obrazovka, klávesnice a myš vzdáleného počítače.

4. ukončení VNC přístupu provedete pomocí tlačítka Ukončit.


RemoteScan - souborovy manazer

RemoteScan – souborový manažer

Funkce Souborový manažer umožňuje přistoupit na vzdáleném počítači na jeho disky. Funkce je chráněna přístupem, takže nepovolaný uživatel nemá k této funkci přístup. Přístup k souborům je umožněn i bez nutnosti nastaveného sdílení disků.

Po spuštění funkce se zobrazí formulář, který zobrazuje souborový systém disku C:. V horní části lze kdykoliv změnit diskový oddíl. Po jeho změně se v levé části zobrazí adresářová struktura, v pravé části aktuální soubory.

V pravé části lze změnit setřídění souborů. Změna se provede doublecklikem myši na hlavičce sloupce (viz. sloupec se žlutou hlavičkou).

Funkce Souborový manažer má dvě varianty :

1. standardní – umožňuje pouze soubory zobrazit a přetřídit

2. standardní + čtení dat – umožňuje navíc spustit všechny soubory, které mají na počítači odkud je Souborový přístup spuštěn asociován příslušný spouštěcí program (např. soubory typu INI, TXT, PDF, DOC, XLS, ZIP, HTM apod.). Spouštění EXE a COM je zakázáno.

Pozor – spouštění probíhá tak, že se soubor stáhne ze vzdáleného počítače a spustí se. Pokud jde např. o soubory typu DOC, XLS TXT, INI, lze je zároveň editovat, ale výsledek se ukládá na server (na původním místě zůstane nezměněn).


RemoteScan - scany HW,SW s logem

RemoteScan – scanování HW,SW + log soubor

Funkce Scanování HW (SW) + log soubor je funkce, která se standardně nemusí vůbec používat. Má význam ji použít pouze v případě, že scan HW nebo SW neproběhl v pořádku nebo neobsahuje všechny údaje.

Tato funkce spustí stejný scan HW (SW), ale navíc kromě výstupního souboru TXT (SWT) vytvoří zároveň log soubor, ve kterém je podrobný popis akcí, které proběhly. Log soubor má stejné jméno a příponu má :

· *.LogHw – pro scan Hw. Tento log soubor je malý, takže se stahuje společně s TXT souborem.

· *.LogSw – pro scan Sw. Tento log soubor může být hodně velký (i několik MB), proto se nestahuje společně s SWT souborem, ale zůstává u klienta na lokálním PC. Musíte si jej stáhnout sami!!!

Tento Log soubor zašlete společně s vytvořeným TXT (SWT) souborem autorské firmě k analýze. Nezapomeňte připsat problém, který při scanování nastal.


RemoteScan - oprava evidencniho cisla

RemoteScan – oprava evidenčního čísla

Tato funkce umožňuje upravit komunikaci mezi serverem a klientem.

Klient má totiž na lokálním disku v souboru CLIENT.INI uloženou položku nazvanou UID. Tato obsahuje vlastně evidenční číslo z programu SPRÁVCE (např. H0001245). Pokud došlo ke změně evidenčního čísla – ruční oprava evidenčního čísla ve volbě HW audit – Evidence hardware komunikace je zablokovaná.

Spuštěním této funkce provedete opravu evidenčního čísla v souboru CLIENT.INI uloženého na lokálním disku klienta.


RemoteScan - zpracovani scanu HW,SW

RemoteScan – zpracování HW,SW

Funkce Zpracování HW, SW umožňuje provést zpracování nascanovaných souborů. Je závislá na poloze kursoru ve stromu :

1. pokud stojíte na konkrétním počítači, provede se zpracování jen tohoto počítače.

2. pokud stojíte na celé skupině nebo na rootu, provede se zpracování všech podřízených počítačů.

V obou případech proběhne zpracování automaticky a na jeho konci se zobrazí výsledek zpracování. Počítače, u kterých zpracování proběhlo v pořádku, jsou umístěny v horní části mřížky a v posledním sloupci mají příznak OK. Počítače, u kterých zpracování neproběhlo v pořádku, mají v posledním sloupci uveden důvod chyby (nejčastěji to může být, že neexistuje nascanovaný soubor).

Po zpracování jsou naplněny datové soubory příslušenství nebo software. Obsah naleznete po rozbalení počítače ve složkách Software a Příslušenství (viz. obrázek).


RemoteScan - server (spusteni)

RemoteScan – Změna VNC hesla

Tento formulář slouží ke změně hesla pro přístup na vzdálenou stanici pomocí VNC. Nové heslo je zasláno na aktuální organizační členění, nebo hardware ve stromě.


SESTAVY - uvod

SESTAVY

Modul SESTAVY je určen vytváření libovolných uživatelských sestav. Hlavní menu obsahuje následující volby :

Generátor sestav

Archivace

Obnova

Reindex

Údržba


SESTAVY - Archivace dat

Sestavy – Archivace dat

V této volbě se provádí bezpečnostní kopie všech souborů používaných modulem SESTAVY na Vámi zvolené zařízení. Archivace se vždy provádí pomocí komprimačního programu nastaveného ve volbě Údržba - Konfigurace, který vytvoří záložní soubor _SESTAVQ. Při archivaci se zálohují všechny datové soubory v adresáři \GEN_SEST (*.DBF) a zároveň všechny vytvořené sestavy v podadresáři \OSTRA\QSESTAVY (název každé sestavy začíná označením souboru a následuje pořadové číslo. Každá sestava musí mít dva soubory *.FRT a *.FRX.).

POZOR

Datové soubory Visual FoxPro není snadné obnovovat, jejich poškození může vést k definitivní ztrátě. Proto nezapomeňte pravidelně provádět archivaci všech datových souborů. V případě, že dojde k jejich poškození a Vy nebudete mít provedenou archivaci, přijdete o svá data, program nemá možnost záchrany poškozených dat.


SESTAVY - Generator sestav

SESTAVY - generátor sestav

Tato volba nemá společný help. Help pro jednotlivé formuláře je umístěn přímo na tlačítkách těchto formulářů.


SESTAVY - Obnova dat

Sestavy – Obnova dat

V případě poškození některého z datových souborů nebo definičních souborů sestav lze tyto soubory obnovit. Tuto obnovu lze provést pouze v případě, že byla provedena Archivace dat.

POZOR :

obnova provede vždy obnovení všech souborů.

Při obnově budou nejprve všechny soubory uzavřeny a poté překopírovány do pomocného adresáře (pro případ násilného přerušení obnovy). Pak se provede obnova požadovaných souborů. Aby nedošlo k nesrovnalostem v indexních souborech, provede se reindexace a znovuotevření všech souborů. Pokud obnova proběhne úspěšně, smažou se soubory z pomocného adresáře.


SESTAVY - Reindex

Sestavy – Reindex

Volba slouží k obnově indexových souborů. Při nestandardních situacích (např. výpadek proudu, stisk tlačítka RESET apod.) může dojít k poškození indexních souborů. Program se podaří normálně spustit, ale mohou se objevit situace, kdy dojde k nečekaným výsledkům.


Ciselniky - aplikace (volba Detail)

Přístupy k aplikacím [ volba Detail ]

Ovládání programu

Volba nabídne odpovědnou osobu s přístupem k určité aplikaci. Položku aplikace a odpovědná osoba nelze opravit, tyto položky se doplní při přiřazení odpovědných osob k aktuální aplikaci. Ve formuláři je možno opravit jméno uživatele, jeho heslo, datum změny hesla, typ přístupu k aplikaci a poznámku.

Potvrzení operace provedete pomocí tlačítka Ok, tlačítkem Zpět se program vrátí zpět do formuláře s číselníkem aplikací.


Typy prislusenstvi a techniky - zmena typu

Změna typu příslušenství, síťové techniky a majetku

Ovládání programu

Pokud máte ke konkrétnímu typu příslušenství (techniky) již přiřazeny nějaké věty příslušenství a zjistíte, že název je správný, ale špatně jste zvolili typ, lze zde provést změnu typu příslušenství (např. změnit typ K006 na typ K010). Tato změna je výjimečná. Používá se pouze v případě, že jste při definování vlastních typů příslušenství udělali chybu a chcete tuto chybu odstranit najednou v celém souboru. Např. jste zvolili typ S001 Router a pak chcete Router přejmenovat na typ S002.

Funkce je chráněná, takže pokud uživatel nemá k této funkci nastaven přístup, změnu nemůže provést.

Po spuštění zobrazuje formulář původní číslo a název typu příslušenství. Musíte zadat nový typ. Pokud zadáte neexistující typ, program Vám povolí tento nový typ vložit do číselníku. Stiskem tlačítka OK provedete změnu. Při této změně se zkontrolují číselníky názvů příslušenství, oblastí 1, oblastí 2. Pokud nová hodnota není v těchto číselnících, pak je tam automaticky vložena. Stiskem tlačítka Zpět se změny neprovedou a výběr označených vět se zruší.


Nazvy software -vytvoreni licence

Vytvoření licence

Tento formulář slouží k hromadnému vytvoření licencí software z nalezeného nelegálního software. V horní části formuláře se nacházejí informace o aktuálním software, jehož instalace chcete zlegalizovat (název a verze software, počet vybraných nelegálních instalací a celkový počet instalací určených k legalizaci).

V mřížce formuláře je zobrazen seznam licencí, které jsou k dispozici. Ve sloupci Legalizovat (žluté barvy) je možno měnit počet instalací určených k legalizaci. Celkový počet instalací určených k legalizaci se pak automaticky spočítá a nesmí být větší než počet kusů nelegálních instalací.

Jestliže není ve mřížce dostatek licencí, lze je tlačítkem Nová vygenerovat novou licenci.


Ciselniky - volne vazby

Číselníky – volné vazby

Ovládací tlačítka

Tato karta obsahuje tzv. Volné vazby. To jsou vazby, ve kterých není položka daného číselníku vyplněna. V listovacím seznamu Výběr vazby musíte nejprve vybrat hlavní datový soubor (popř. i název položky), u kterého chcete volné vazby zobrazit. Po výběru vazby se Vám na kartě zobrazí mřížka s odpovídajícími větami.

Změna vazby


Ciselniky - zmena vazby

Číselníky – změna vazby

1. Nejprve si vpravo dole pod mřížkou v seznamu Nová hodnota vyberte požadovanou novou hodnotu.

2. Potom se přesuňte do mřížky, kde můžete výběr vět ke změně vazby provést buď jednotlivě klikem myší v prvním sloupci mřížky nebo hromadně pomocí pravého tlačítka myši. Pokud použijete pravé tlačítko myši, vyvoláte menu, ve kterém pomocí voleb Označ vše a Odznač vše provedete výběr nebo zrušení výběru všech vět najednou.

3. Změnu vazby pak dokončíte pravým tlačítkem myši :

a) Volbou Přeřadit provedete přeřazení vybraných vět na novou hodnotu (musí být předem vybraná – viz. bod 1.)

b) Volbou Odřadit provedete odřazení vybraných vět a jejich přesun na kartu Volné. Pro tuto operaci nemusí být vybraná žádná nová hodnota).


Dokumentace - seznam

tato karta zobrazuje přehledně seznam všech vět daného souboru. Nabízí následující funkce :

A) Standardní funkce :

Ovládání programu

Speciální tlačítka

Menu na pravé tlačítko

B) Specifické funkce :

Duplikace

toto tlačítko slouží k vytvoření kopie dané dokumentace. Program vytvoří stejnou větu, pouze vygeneruje (nebo ručně zadá) evidenční číslo.

C) Tisky :

Parametry tisku

* SESTAVY

Seznam dokumentace

sestava zobrazí jednoduchý seznam dokumentace.

Pasportní list

zobrazení veškerých údajů o dokumentaci.

Předávací protokol

v úvodní pevné části předávacího protokolu jsou uvedeny všechny údaje o dokumentaci. Text, který potom následuje a který může být v každé organizaci jiný, se zadává v konfiguraci programu ve volbě Údržba - konfigurace.

Zapůjčení dokumentace

seznam dokumentace s údaji o zapůjčení.


Dokumentace - Zakladni udaje

Dokumentace- základní údaje

Ovládání programu

Specifické číslo

specifické číslo je určeno pro speciální potřeby, které mohou být v každé firmě jiné (např. číslo různých projektů, informačních systémů apod.).

Vazba na

určuje k čemu se dokumentace vztahuje - k hardware, software, příslušenství, síťovému příslušenství, samostatnému příslušenství, síti nebo je volná.


Dokumentace - Ekonomicke udaje

Dokumentace - ekonomické údaje

Ovládání programu

Kusy

položka určující počet kusů dokumentace. Pokud se zakoupí více kusů stejné dokumentace, vyplňte položku Kusy. Program automaticky spočítá počet volných kusů. Protože ve větě příslušenství je pouze jedna cena, musíte se rozhodnout, zda bude obsahovat cenu za jeden kus nebo za všechny kusy.

Nákupní cena

ve větě příslušenství je pouze jedna cena, musíte se rozhodnout, zda bude obsahovat cenu za jeden kus nebo za všechny kusy.

Zapůjčení

zde můžete zadat datum a osobu, které byla dokumentace zapůjčena.


Dokumentace - vazby

Ovládací tlačítka Hromadné výběry

Pokud je u dokumentace určena vazba na hardware, software apod., je na této kartě zobrazena mřížka se seznamem přiřazených vazeb k dané dokumentaci. Na této kartě je aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechno zařízení k odřazení, zobrazit podrobné informace o zařízení, zobrazit seznam nepřiřazeného zařízení (Volný hardware, software, příslušenství, sítě), pořídit nové zařízení. Pokud není vazba určena, nejsou na této kartě žádné mřížky. V tomto případe je nutné provést opravu a na kartě Základní údaje nastavit vazbu.

Odřazení

odřazení provedete stiskem pravého tlačítka myši a výběrem volby Odřadit. Program najednou odřadí všechny označené věty.

Oprava hardware, software, příslušenství nebo sítí

pomocí pravého tlačítka a volby Detail … nebo double klikem myší lze na této kartě zobrazit (i opravit) větu hardware, software, příslušenství nebo sítě, na němž se nachází kurzor.


Elektronicke dokumenty

Dokumenty

Formulář slouží k pořízení a opravě záznamů o nascanovaných papírových dokumentech, které se přiřazují k zařízením se kterými souvisí.

V levé části formuláře se zobrazuje náhled reprezentující dokument (pouze pro grafické obrázky)

V pravé části se zadávají údaje o dokumentu :

1) Výběr souboru reprezentující dokument. Soubory musí být uloženy v adresáři (případně v jeho podadresářích), který se zadává v konfiguraci (Adresář k el. dokumentům).

2) Typ dokumentu – výběr z číselníku typů dokumentů.

3) Popis dokumentu.


Dokumentace - prirazeni

Přiřazení dokumentace

Tento formulář slouží ke stanovení počtu kusů dokumentace, které budou připsány k dané větě souboru hardware, software, příslušenství nebo sítí. Zadat můžete maximálně pouze počet kusů, které máte ještě volné.


Hardware - duplikace

Duplikace příslušenství, software a dokumentace

Tento formulář slouží k duplikaci počítače včetně přiřazeného příslušenství, nainstalovaného software a přiřazené dokumentace. Na formuláři je třeba zatrhnout, co chcete duplikovat.

Pokud duplikovaný hardware nemá žádné přiřazené příslušenství, nainstalovaný software nebo přiřazenou dokumentaci, jsou příslušné výběry zablokovány. Také volba software je zablokovaná, pokud jsou data software aktualizovaná pomocí programu AW-SCAN. Jednotlivé volby také mohou být zablokovány, jestliže nemáte povolenu aktualizaci daného souboru.

Pokud zvolíte duplikaci příslušenství, spustí se formulář Duplikace příslušenství.

Pokud zvolíte duplikaci software, spustí se formulář Duplikace software.

Pokud zvolíte duplikaci dokumentace, spustí se formulář Duplikace dokumentace.

Nezatrhnete-li žádný parametr, program provede duplikaci hardware bez příslušenství, software a dokumentace.


Ciselniky - aplikace (prirazeni odpovedne osoby)

Přiřazení odpovědné osoby [ volba Duplik ]

Ovládání programu

Volba nabídne seznam odpovědných osob, kterým je možné nastavit přístup k nové aplikaci. Tyto osoby měly přístup k aplikaci, nad kterou byla provedena volba Duplik. Přes pravé tlačítko myši lze vyvolat nabídku Označit/Odznačit vše. Osoby lze označit/odznačit také jednotlivě zaškrtnutím prvního sloupce v mřížce.

Potvrzení operace provedete pomocí tlačítka Přiřadit, tlačítkem Zpět se program vrátí zpět do formuláře s číselníkem aplikací.


Hardware - duplikace dokumentace

Duplikace dokumentace

Formulář nabízí mřížku se seznamem dokumentace, která je přiřazena u původního počítače. První (zelený) sloupec slouží pro výběr jednotlivé dokumentace. Dále Vám program umožňuje rozhodnout se, zda chcete zdupliovat i ekonomické údaje přiřazené dokumentace. K tomu slouží druhý (modrý) sloupec mřížky. Pro duplikaci ekonomických údajů nelze označit dokumentaci, kterou ještě nemáte označenu k duplikaci. Potvrzením tlačítka OK, budou všechny označené věty dokumentace zduplikovány do nového počítače.


Hardware - duplikace prislusenstvi

Duplikace příslušenství

Formulář nabízí mřížku se seznamem příslušenství, které je přiřazeno u původního počítače. Pokud je příslušenství součástí počítače při nákupu, je zaškrtnut poslední sloupec mřížky. V tomto případě je toto příslušenství automaticky nabídnuto k duplikaci (zaškrtnut první sloupec). Pokud není příslušenství součástí počítače při nákupu, je poslední sloupec prázdný a příslušenství není nabídnuto k duplikaci. Jestliže ho chcete duplikovat, musíte ho v prvním sloupci ručně označit.

První (zelený) sloupec slouží k označení vět pro duplikaci. Druhý (modrý) sloupec lze použít v okamžiku, kdy chcete duplikovat ekonomické údaje u příslušenství, které není součástí počítače při nákupu. Pro duplikaci ekonomických údajů tedy nelze označit příslušenství, které je součástí počítače při nákupu (údaje jsou doplněny podle údajů HW) a také příslušenství, které ještě nemáte označeno k duplikaci. Potvrzením tlačítka OK, budou všechny označené věty příslušenství zduplikovány do nového počítače.


Hardware - duplikace software

Duplikace software

Formulář nabízí mřížku se seznamem software, který je nainstalován u původního počítače. První (zelený) sloupec slouží pro výběr duplikovaného software. Dále Vám program umožňuje se rozhodnout, zda chcete zdupliovat i ekonomické údaje nainstalovaného software. K tomu slouží druhý (modrý) sloupec mřížky. Pro duplikaci ekonomických údajů nelze označit software, které ještě nemáte označen k duplikaci. Potvrzením tlačítka OK, budou všechny označené věty software zduplikovány do nového počítače.

POZOR:

Jestliže používáte scan SW, je vhodnější neduplikovat takto SW, ale raději provést nascanování a výsledky zpracovat. Celkový výsledek bude jistě přesnější než pouhá duplikace.


Ostatni - Prazdne formulare

Prázdné formuláře

Tato volba umožňuje vytisknout prázdné formuláře hardware a příslušenství pro případ, že by jste při provádění inventury nebo použití scanu HW potřebovali zachytit ručně stav daného počítače.


Hardware - prerazeni prislusenstvi

Hardware – vazby PŘ (přeřazení PŘ)

Tento formulář slouží k přeřazení vybraného příslušenství z jednoho počítače na druhý. Mřížka obsahuje seznam všech počítačů. Kursorem se nastavte na požadovaný počítač a stiskem tlačítka Výběr potvrdíte nový počítač. Na tento počítač bude následovně přeřazeno příslušenství, které jste měli označené pro přeřazení.

Program Vám pro změnu počítače nedovolí vybrat stejný počítač nebo zlikvidovaný počítač.


Datum instalace SW

Instalace SW na HW

Tento formulář slouží k zadání datumu instalace software a odpovědné osoby za instalaci. Tyto údaje jsou stejné pro všechen označený software k instalaci. Zadají se jen jednou, pro všechny instalace software pak budou stejné.


Hardware - prirazeni software

Instalace SW na HW

Tento formulář zobrazuje údaje software, který bude nainstalován na vybraný počítač. Slouží k zadání počtu nainstalovaných licencí. Objeví se pouze v případě, že software je multilicence a vybraný počítač je server sítě. Je nutné zadat počet licencí, které budou na serveru přístupné pro uživatele. Zadaný počet licencí může být větší než je počet zakoupených licencí (v případě, že licence lze čerpat do záporna).


Hardware - zruseni HW (i prirazeneho prislusenstvi)

Zrušení přiřazení příslušenství

Tento formulář se objeví v případě, že provedete likvidaci (STAV = 8). Rozdíl mezi zrušením a likvidací je, že likvidovaný počítač zůstává v souboru a má příznak LIKVIDACE. Naproti tomu zrušený počítač je fyzicky smazán ze souboru.

Po spuštění se objeví seznam přiřazeného příslušenství k rušené větě hardware a Vy musíte rozhodnout, které příslušenství se má fyzicky zrušit (v případě rušení) nebo se má likvidovat (v případě likvidace). Pokud je příslušenství součástí počítače při nákupu (poslední sloupec mřížky), je automaticky nabídnuto k zrušení (první sloupec). Vybrané příslušenství bude zrušeno (likvidováno), neoznačené příslušenství je pouze odřazeno od rušeného počítače a je tudíž volné k přiřazení na jiný počítač.


Import - ostatni udaje

Import - ostatní údaje

V této volbě lze importovat z externích evidencí pouze ostatní údaje (např. org. členění, umístění, odpovědnou osobu, volný číselník apod.). Na rozdíl od importu celých těchto číselníků jsou v tomto importu importovány hodnoty přímo k daným počítačům a ostatní výpočetní technice (např. se každému počítači importuje jeho umístění, org. členění apod.).

Předpokladem je vytvoření správného vstupního souboru, který je správného formátu, obsahuje všechny potřebné položky a obsahuje klíčovou položku, podle které lze data externí evidence spojit s daty programu Správce.

Předpokládaný postup :

1. Volba typu souboru

FoxPro 2.x - klasický formát DBF (Dbase, FoxPro DOS)

  • není nutné dodržet pořadí položek.
  • je nutné dodržet správné názvy položek (musí mít stejný název jako mají položky v programu Správce).

Microsoft Excel - formát XLS ve třech typech :

· MS Excel 2.0 - verze 2.0
  • MS Excel 5.0 - verze 3.0, 4.0, 5.0 (95)
  • MS Excel 97 - verze 8.0 (97), 9.0 (2000), 10.0 (XP)
  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

  • Pozor – na prvním řádku importovaného souboru mohou být názvy položek (viz. kontrolní exportní soubor) nebo mohou začínat přímo hodnoty. Máte-li v prvním řádku uvedeny názvy položek, kontroluje program před importem správný název prvních dvou sloupců (musí být stejný jako jsou názvy v kontrolních souborech). Pokud jsou názvy shodné, první řádek se ignoruje a import se provede až od druhého řádku. Nejsou-li názvy položek (sloupců) shodné s kontrolním souborem, je importován i první řádek.

Textový soubor - s oddělovači

  • je nutné dodržet správné pořadí položek.
  • nezáleží na správné délce položek (nesmí být pouze delší, jinak dojde k useknutí).
  • oddělovačem jednotlivých položek musí být čárka.
  • textové položky musí být uzavřeny do uvozovek (pokud by totiž v textu položky byla čárka, text by se usekl a přetáhl do další položky).

CSV formát

  • záleží na :

· správném formátu souboru

· na správném formátu a pořadí sloupců (textový, numerický, datumový).

2. Volba Kódové stránky

Windows - 1250

Latin II - 852

Kamenický - 895

3. Výběr souboru

Import lze provést pouze pro následující soubory :

· Hardware

· Příslušenství hw

· Síťová technika

· Ostatní majetek

4. Klíč pro Import

Velmi důležitá položka, podle které se provede vlastní Import. Tento klíč musí být v obou evidencích (externí a Správce) jedinečný a totožný. Což znamená, že v obou musí existovat stejné klíče. Program potom může provést importování dat podle tohoto klíče. Pokud v jedné z evidencí nějaké klíče chybí, neprovede se Import automaticky, ale je nutné ručně tyto údaje opravit a přiřadit. Jedinou položkou podle, které lze importovat je inventární číslo.

5. Kontrolní export dat

Tímto tlačítkem si můžete do podadresáře \OSTRA\EXPORT vygenerovat kontrolní soubor, který Vám slouží jako vzorek pro vytvoření vstupního souboru z externí evidence. Syntaxe názvu souboru je následující : OS_HW_FP

kde první dva znaky (OS) znamenají, že jde o import ostatních údajů, další dva znaky (HW) druh souboru a poslední dva znaky typ souboru (vybraného podle volby v bodě 1.)

Kontrolní export generuje kontrolní soubor z aktuálních dat, tzn. že aby jste v kontrolním souboru něco viděli, musíte mít v programu Správce vyplněno prvních 1-5 vět podle evidenčního čísla (kontrolní soubor obsahuje max. 5 vět). Doporučujeme proto si do první až 5-té věty podle evidenčního čísla naplnit kontrolně všechny údaje tak, aby jste v kontrolním souboru viděli nějaký výsledek. Data v kontrolním souboru můžete opravit a provést jejich načtení do mřížky. Tak se nejlépe přesvědčíte o správnosti údajů.

6. Adresář se soubory pro import

Tento údaj nelze přímo editovat. Musíte pomocí tlačítka na konci vybrat soubor z disku. Pokud v dialogu soubor vyberete, načte se Vám soubor do položky. Pokud dáte Storno, položka se vynuluje.

7. Načti soubor

Pokud máte vybrány všechny ostatní potřebné údaje (předchozí volby), můžete stiskem tohoto tlačítka provést načtení vstupního souboru. Program načte soubor do mřížky, ve které si můžete prohlédnout obsah importovaného souboru.

Ve mřížce jsou barevně rozlišeny následující stavy :

· Fialová barva = v datovém souboru existují duplicity inventárních čísel

· Modrá barva = v importovaném souboru existují duplicity inventárních čísel

Všechny věty, které lze importovat jsou v prvním sloupci automaticky označeny. Věty, které nejsou označeny mají prázdné inventární číslo a tyto věty nelze importovat. Je nutné je v externí evidenci opravit a vygenerovat nový soubor pro import.

Pozor :

v souboru Příslušenství hardware nelze importovat příslušenství, které je označeno jako Součást PC při nákupu. Toto příslušenství má totiž duplicitní inventární číslo, a proto nelze importovat.

Je-li obsah v pořádku, musíte na druhé kartě označené Výběr položek pro import vybrat položky, které chcete importovat. Automaticky je vždy vybrána klíčová položka, která se musí vždy importovat. Ostatní položky můžete nebo nemusíte importovat. Položky, které vyberete pro import jsou na první kartě zobrazeny tučně.

Teprve po výběru položek pro import se Vám zpřístupní tlačítko Import, jenž Vám povolí provést vlastní import. Jednou vybrané položky si program pamatuje a při příštím importu je automaticky nastaví.

8. Import

Import provede načtení dat ze vstupního souboru ve dvou částech :

a) první část importu se provede automaticky. Jedná se o věty, které mají shodnou klíčovou položku v obou evidencích (inventární číslo) a ve mřížce Data pro import nejsou zobrazeny barevně. Tyto importované věty lze stoprocentně přiřadit, proto lze import provést automaticky.

b) druhá část importu se provádí ručně. Program se zastaví a nabídne formulář Ruční import se seznamem vět, jejichž klíčová položka se v evidenci programu Správce nenašla. Jedná např. o :

  • novou techniku
  • techniku, která nemá v evidenci programu Správce požadovanou klíčovou položku (nebo má špatnou hodnotu).

V tomto formuláři se musíte rozhodnout, co s těmito větami provedete. Můžete je zavést jako nové věty nebo je přiřadíte správně k již existujícím větám.


Ostatni - Inventarni sestavy (vyber z ciselníku)

Inventární sestavy - výběr z číselníku

Tento formulář obsahuje mřížku se seznamem číselníku organizačního členění, umístění nebo odpovědných osob. Zde si můžete v prvním sloupci mřížky označit věty, pro které chcete inventární (předinventární) sestavu vytisknout. Pomocí tlačítka Tisk potvrdíte výběr vět a program dále pokračuje vytvořením sestavy. Tlačítkem ZPĚT se vrátíte na předcházející formulář, aniž by došlo k vytvoření sestavy.


.Uvod do aplikace Spravce

Registrace

Formulář slouží k vyplnění licenčního čísla a klíče programu. Bez správného vyplnění těchto údajů nebudete moci program spustit.

Klíč programu získáte registrací na stránkách http://www.micos-sw.cz/registrace.php. K úspěšné registraci potřebujete znát licenční číslo a kód programu, který vám byl přidělen. Tyto údaje naleznete na obalu od CD programu Správce.

Postup registrace :

  1. Na úvodní stránce vyplňte licenční číslo programu a kód programu. Vyplněné údaje odešlete stiskem tlačítka odeslat. Pokud se po odeslání údajů objeví hláška „chybné licenční číslo, nebo kód programu“ prosím zkontrolujte správnost vyplněných údajů. Pokud se vám nepodaří údaje odeslat kontaktujte autorskou firmu.

  2. Po úspěšném odeslání se objeví formulář, kde budete muset vyplnit některé údaje o uživateli (Jméno uživatele, telefon a email).

  3. Po odeslání vyplněných údajů se vypíší údaje o firmě společně s klíčem k programu. Tento klíč si uschovejte pro další použití.


.Uvod do aplikace Spravce

Konfigurace vzhledu formuláře

Formulář slouží k nastavení vzhledu a chování aktuálního formuláře. Umožňuje zakázat zobrazování vybraných karet na formuláři.


Evidence - Poznamky

Poznámky

Tento formulář umožňuje zápis libovolně dlouhé poznámky k aktuálnímu zařízení.


Ciselniky - volny (import dat)

Načtení dat do volného číselníku

Tento formulář slouží k načtení nových dat do číselníku volný. Nejprve si zde musíte vybrat soubor, ze kterého chcete data načíst. Tento soubor musí být s příponou .TXT nebo . DBF a musí mít následující strukturu : CISLO C(30) a NAZEV C(60).

Poté si zvolte Typ souboru :

a) FoxPro 2.* - tento typ si vyberte v případě, že importovaný soubor má příponu .DBF.

b) TXT – tabelátor - tento typ zvolte, pokud importovaný soubor má příponu .TXT. Tento typ vytvoříte např. v MS EXCELu volbou Export.

Pomocí tlačítka Načti program načte data z Vámi zvoleného souboru do horní mřížky formuláře. Pozorně si je prohlédněte a pokud jsou v pořádku, stiskem tlačítka OK proveďte načtení dat do volného číselníku. Jestliže data zobrazená v mřížce neodpovídají Vašim představám, ukončete formulář tlačítkem Zpět.


Ciselniky - vzory SW (update ostrych vzoru)

SW-SCAN - update ostrých vzorů

Tato volba slouží pro update centrálních vzorů software. Tento update lze provést v programu SPRÁVCE (pro normální licence) nebo v programu KSPRÁVCE (pro multilicence).

Soubory pro update musí být uloženy v podadresáři \UPG_VZOR. Tyto soubory je nutné stáhnout z Internetu a do tohoto adresáře je rozbalit ručně. Každý update obsahuje tři soubory :

LIST-???.DBF - seznam jednotlivých souborů vzorů software, kde ??? je pořadí update.

SOFT-???.DBF - seznam názvů software (číselník názvů software), kde ??? je pořadí update.

UPGR-???.TXT - kontrolní seznam názvů software, kde ??? je pořadí update.

Po spuštění této volby vyhledá program všechny soubory UPGR-???.TXT a zobrazí jejich obsah. Ve mřížce jsou zobrazeny obsahy všech těchto souborů. Sloupec Číslo zobrazuje pořadí aktualizačních souborů pro update, sloupce Název a Verze pak jednotlivý software, sloupec Zprac. pak ukazuje seznam SW, který již byl zpracován a sloupec Počet udává počet souborů daného vzoru.

V prvním sloupci musíte označit software, kterým chcete aktualizovat Vaše datové soubory. Můžete si vybrat pouze ten software, který Vás zajímá, nemusíte vybírat všechen software. Také si můžete vybrat software z libovolné aktualizace (UPGR-001, UPGR-003 apod.).

Stiskem tlačítka OK spustíte vlastní přihrání. Pak program prochází číselník názvů software (CIS_SOFT). Pokud se přihrávaný software v číselníku nenachází, tak jej tam program vloží. Pak se prochází původní soubor vzorů software (SW_LIST) a vkládá do něj jednotlivé soubory, které tam ještě nejsou. Pokud v uvedeném software máte své vlastní soubory, aktualizace je tam ponechá. Pouze vloží nové soubory.


Pridani nove vety

Přidání nové věty

Tento formulář slouží k zavedení nové věty příslušného souboru. Po vyplnění všech položek máte možnost pomocí tlačítek OK a Zpět rozhodnout o tom, zda nová věta bude do souboru zapsána.


Opravy - nova oprava

Opravy – přidání (oprava)

Tento formulář umožňuje ruční přidání věty do oprav. Nejprve se musí zvolit typ opravy, teprve pak jsou přístupné ostatní položky dle zvoleného typu.

· Opravu stav=1 Uvedení do provozu lze pořídit jen, pokud z nějakého důvodu nevznikla automaticky.

· K zařízení, na které je provedena Likvidace, již nelze provádět přiřazení, odřazení a změny.

· Položka datum Ukončení se automaticky rovná datu zahájení pro Uvedení do provozu a Likvidaci.

· Položka Dny opravy je pro Opravu automaticky vypočtena při Ukončení opravy, a nelze ji měnit. Tato hodnota je zároveň přesunuta do položky Dny záruky, kde ji lze upravit směrem dolů, pokud firma nepřiznala prodloužení záruky za celou dobu opravy.


Ostatni - Prehled siti

Přehled sítí

Tato volba Vám přehledným způsobem ukazuje vazby mezi sítí, hardware a příslušenstvím. Po spuštění se Vám zobrazí seznam všech evidovaných sítí.

Stiskem myši na znaménku ”+” se rozbalí seznam počítačů, které jsou na této síti zapojeny a seznam síťové techniky. Pokud síť nemá žádné počítače nebo žádnou síťovou techniku, pak příslušný seznam chybí. Stiskem myši na další znaménkách ”+” rozbalíte jednotlivé seznamy až na nejnižší úroveň. Tlačítka ”+” se pak změní na ”-” a jejich stiskem pak zase seznamy sbalíte nazpátek.

Pokud na větě sítě, počítače nebo příslušenství stisknete tlačítko Detail, zobrazí se Vám detailní informace o daném zařízení, které si můžete pouze prohlédnout.


Ostatni - prehled typu prislusenstvi

Přehled typů příslušenství

Tato volba přehledným způsobem ukazuje počty příslušenství podle typů, názvů a oblastí. Po spuštění se v levé mřížce zobrazí číselník typů příslušenství, který po rozbalení obsahuje číselník názvů, oblastí 1 a oblastí 2 příslušenství. Po rozbalení těchto číselníků se dostanete až na konečné hodnoty, které jednotlivé číselníky nabývají. V pravé mřížce se Vám potom zobrazuje seznam příslušenství v souboru PRISLUSE.DBF podle hodnot z levé mřížky.

Tlačítka Detail Hw a Detail Př slouží k zobrazení detailních informací o počítačích nebo příslušenství z pravé mřížky. Před jejich stiskem musíte v pravé mřížce nastavit kursor na požadovaný počítač nebo příslušenství.


Opravy - prevod

Opravy - převod

Při změně organizačního členění, umístění, odpovědné osoby nebo části zařízení (např. odřazení počítače z počítačové sítě) je do souboru oprav vygenerována věta s příznakem STAV = 6, která udává, že dané zařízení bylo převedeno někam jinam. Program Vám zobrazuje, o jaký převod se jedná a Vy máte pouze možnost zadat datum převodu a odpovědnou osobu za převod.

Parametr - Dále nezobrazovat tento formulář, použít stejné hodnoty, jeho zatržení způsobí odpamatování stávajících hodnot, a to, že tento formulář se dále nebude zobrazovat. Nastavení lze zrušit na formuláři Konfigurace, nebo Parametry Konfigurace…


Opravy - revize

Tento formulář umožňuje zapsat údaje o provedené revizi. Automaticky nabízí datum revize, který byl vypočtený z číselníku servisů. Samozřejmě můžete tento datum změnit podle skutečně provedené revize. Podle tohoto datumu se pak vypočte datum příští revize.

Dále můžete vyplnit ostatní položky týkající se obecně každého servisu : Osoba, Cena, Faktura a Interní číslo faktury. Dále ještě další položky týkající se revize : Odpor ochr. vodiče, Měřící přístroj, Izolační odpor a další.


Opravy - servis

Tento formulář umožňuje zapsat údaje o provedeném servisu. Automaticky nabízí datum servisu, který byl vypočtený z číselníku servisů. Samozřejmě můžete tento datum změnit podle skutečně provedeného servisu. Podle tohoto datumu se pak vypočte datum příštího servisu.

Dále můžete vyplnit ostatní položky servisu : Dodavatel, Osoba, Popis servisu, Cena, Faktura a Interní číslo faktury.

Parametr - Dále nezobrazovat tento formulář, použít stejné hodnoty, jeho zatržení způsobí odpamatování stávajících hodnot, a to, že tento formulář se dále nebude zobrazovat. Nastavení lze zrušit na formuláři Konfigurace, nebo Parametry Konfigurace…


Opravy - oprava, upgrade nebo pridani

Opravy – oprava, upgrade nebo přidání

V případě, že při opravě technických parametru věty nebo při zpracování TXT souborů program zjistí změny proti poslednímu stavu, automaticky vygeneruje do souboru oprav větu opravy. V tomto případě program nabídne tento formulář, na kterém Vám zobrazuje evidenční číslo daného zařízení. Vy musíte rozhodnout, jak ke změně došlo (jedná-li se o opravu, upgrade nebo přidání zařízení). Podle toho program vygeneruje větu s příznakem STAV = 3, 4 nebo 7. Dále máte ještě možnost zadat cenu práce a odpovědnou osobu za opravu.

Parametr - Dále nezobrazovat tento formulář, použít stejné hodnoty, jeho zatržení způsobí odpamatování stávajících hodnot, a to, že tento formulář se dále nebude zobrazovat. Nastavení lze zrušit na formuláři Konfigurace, nebo Parametry Konfigurace…


Opravy - uvedeni do provozu

Opravy - uvedení do provozu

Při pořízení nové věty hardware (software, příslušenství, sítě) se automaticky generuje do souboru oprav věta s příznakem STAV = 1 Uvedení zařízení do provozu. Program Vám nabízí název a evidenční číslo nově zaváděného zařízení, dále také datum zakoupení, datum uvedení zařízení do provozu a odpovědnou osobu za uvedení. Máte možnost změnit tato data a odpovědnou osobu. Odpovědná osoba je kontrolována proti číselníku odpovědných osob.

Parametr - Dále nezobrazovat tento formulář, použít stejné hodnoty, jeho zatržení způsobí odpamatování stávajících hodnot, a to, že tento formulář se dále nebude zobrazovat. Nastavení lze zrušit na formuláři Konfigurace, nebo Parametry Konfigurace…


Opravy

Kartu Opravy mají pouze formuláře souborů Hardware, Software, Příslušenství, Síťová technika , Ostatní majetek a Sítě. Obsahuje seznam (historii) oprav daného zařízení. Některé typy oprav jsou generovány automaticky při změně např. technických parametrů (oprava nebo upgrade počítače), při uvedení počítače do provozu nebo při změně organizačního členění, umístění, odpovědné osoby. Tyto generace nemůžete ovlivnit, pouze můžete u nich upřesnit některé údaje. V levé části karty Opravy je seznam všech provedených oprav (historie).

V pravé části formuláře jsou uvedeny všechny důležité položky vybrané opravy. Položka Způsob v pravé části říká, jak byla věta oprav měněna a jak vznikla. Věty automaticky vzniklé či změněné by se neměly rušit, protože při jejich vzniku se v systému stala nějaká událost (například odřazení počítače ze sítě). Při zrušení takovéto věty nelze již opravy uvést do původního stavu. Narušila by se tím historie provedených změn v systému.

Položka STAV opravy má tyto základní typy :

1 = Uvedení do provozu

tento stav se automaticky generuje v okamžiku zavedení zařízení do evidence.

2 = Závada

zařízení je funkční, má ale nějaké problémy. Tyto problémy je nutné později opravit.

3 = Oprava

zařízení je v opravě.

4 = Upgrade

modernizace zařízení.

5 = Servis

byl proveden servis. U signalizace stavu opravy je signalizován typ servisu.

6 = Převod/Zapůjčení

převod odpovědné osoby, umístění, organizačního členění, sítě. Generuje se automaticky při změně uvedených položek. Pokud se věta vytvoří ručně, jedná se o zapůjčení.

7 = Přidání/odebrání

generuje se automaticky v okamžiku přidání/odebrání příslušenství z hardware, přidání/odebrání hardware ze sítě nebo přidání/odebrání software z hardware.

8 = Likvidace

zařízení bylo fyzicky likvidováno, ale chcete jej ponechat v evidenci.

9 = Změna inv. čísla

tento stav se automaticky generuje v okamžiku změny inventárního čísla.

10 = Ostatní náklady

tento stav umožňuje evidovat ostatní náklady, např. dokupování cartridge.

Stavy typu Uvedení do provozu a Likvidace se mohou pro jedno zařízení vyskytovat pouze jednou. Ostatní stavy se mohou vyskytovat vícekrát. Pokud jsou vytvořeny ve stejný den, načítají se do jedné věty všechny stavy stejného typu (každý stav může mít tedy v jednom dni pouze jednu větu).

Při likvidaci hardware je zobrazen seznam přiřazeného příslušenství a software. V tomto seznamu lze určit, které příslušenství a software se má odřadit a které zlikvidovat zároveň s hardware. Pokud je k hardware přiřazen OEM bude automaticky zlikvidován. Licence software, která patří k nějaké multilicenci bude odřazena.

Při likvidaci příslušenství je spolu s tímto příslušenstvím zlikvidován i OEM software, který byl k němu zakoupen.

Pokud některá z oprav (stav = 2,3,4,5,6) zůstane otevřená (není vyplněn datum ukončení), přenese se tento stav i do věty hlavního souboru. Stav se objeví na druhé kartě souborů hardware, software, příslušenství nebo sítí. V hlavním souboru lze pak snadno filtrem najít např. zařízení, které mají stav=3 (oprava) apod.

V dolní části karty naleznete ovládací tlačítka :

Pomocí tlačítek Nová a Oprava, Rušení opravy, Tisk Vám program umožní ruční práci s opravami.


. Ovladani programu - prave tlacitko mysi

Ovládání programu – menu na pravé tlačítko

Volby menu

pomocí tohoto menu můžete provádět rychlé operace na aktuálně nastavené pozice kursoru.

Konfigurace vzhledu formuláře


. Ovladani programu – specialni tlacitka

Speciální tlačítka - Poznámka

umožňuje zápis libovolné poznámky k aktuálnímu zařízení. Tato poznámka se zapisuje do memo položky, takže je neomezeně dlouhá.


Prislusenstvi - nove cislo

Nové příslušenství

Tento formulář slouží pro vytvoření nového příslušenství. Pokud máte v konfiguraci programu nastaven parametr "Tvar evidenčních čísel" na libovolnou hodnotu, je nutné při vytvoření nového příslušenství zadat ručně evidenční číslo. V tomto formuláři zadáte nové evidenční číslo.


Prislusenstvi – podrizene vazby

Příslušenství – podřízené vazby

Tento formulář zobrazuje seznam veškerého podřízeného příslušenství.


Prirazeni odpovedne osoby

Přiřazení odpovědné osoby

Ovládání programu

Volba nabídne seznam odpovědných osob, kterým je možné nastavit přístup k aplikaci. Přes pravé tlačítko myši lze vyvolat nabídku Označit/Odznačit vše, Přidat odpovědnou osobu. Osoby lze označit/odznačit také jednotlivě zaškrtnutím prvního sloupce v mřížce.

Potvrzení operace provedete pomocí tlačítka Přiřadit, tlačítkem Zpět se program vrátí zpět do formuláře s číselníkem aplikací.


Ruseni vet

Rušení vět

Rušení vět lze provádět dvěma způsoby

Jednotlivě - pro hlavní soubory a číselníky

Hromadně - pouze pro hlavní soubory


Ruseni vet - ciselniky

Rušení vět - číselníky

Rušení jednotlivých vět lze provádět pouze na první kartě Seznam. Před zrušením každé věty jste dotázání, zda tuto větu chcete opravdu zrušit. Pokud odpovíte ANO, bude tato věta zrušena. Fyzické odstranění takových vět ze souborů provedete později ve volbě Údržba - Setřepání dat.

Jestliže chcete zrušit větu, jejíž hodnota se nachází v některém jiném souboru, program to odmítne a vypíše seznam souborů, v nichž se hodnota nachází.


Opravy - ruseni opravy

Opravy - rušení

Zrušit lze všechny typy oprav kromě Uvedení do provozu. Nedoporučujeme rušení vět, které vznikly automaticky (je to vlastně historie změn).


Kontrola vystupnich souboru HW/SW

Kontrola nascanovaných souborů scanu HW a SW

Po spuštění zpracování HW a SW scanu program provede nejprve kontrolu shodnosti položek Název PC, MAC adresa a Lokální PC. Pro síťové počítače se použijí položky Název PC a MAC adresa, které jedinečně identifikují shodnost počítače. Pro lokální počítače se použije pouze položka Lokální PC, která obsahuje název, který byl počítači přiřazen v okamžiku scanování a při následujících scanech musí být vždy shodný.

Kontrola provede následující akce :

1) nejprve zkontroluje, zda každý počítač nemá duplicitní nascanované soubory (podle názvu počítače). Tato situace může nastat v okamžiku, kdy přejmenujete název počítače nebo vyměníte síťovou kartu. Na disku pak mohou zůstat nové i staré scany. Program neumí zjistit, který soubor má ponechat a který smazat. Proto pro jistotu všechny scany daného počítače smaže a musíte tento počítač nascanovat znovu. Aby jste věděli, které počítače máte znovu nascanovat, zobrazí je program ve mřížce vpravo, která má nadpis PC s duplicitními soubory.

2) Počítače, které se shodují v položkách uvedených na začátku, jsou označeny za shodné, jejich nascanované soubory jsou správně přiřazeny a tyto počítače se na tomto formuláři vůbec nezobrazují. Počítače, u kterých došlo ke změně (které se neshodují v některé z těchto položek) jsou umístěny v dolní mřížce.

V horní mřížce je seznam všech nascanovaných souborů, které nemají v evidenci hardware shodné údaje. Jedná se např. o :

a) nové počítače

b) počítače, u kterých došlo k nějaké změně (výměna síťové karty nebo změna názvu počítače)

Počítače zapojené do sítě jsou v horní mřížce signalizovány ve sloupci Název PC a MAC adresa. Počítače, které nejsou zapojeny do sítě, jsou signalizovány sloupcem Lokální PC.

Postup práce :

a) nejprve si v pravé horní mřížce prohlédněte seznam počítačů, u kterých musíte provést znovu scan (viz bod 1).

b) v levé horní mřížce označte nejprve všechny počítače (ať už jsou síťové nebo lokální), o kterých víte, že jsou nové. Stiskem tlačítka Nová PC vyvoláte formulář k Zavedení nových PC do evidence hardware. Tímto způsobem zavedete nové počítače do evidence hardware a levá mřížka se Vám zmenší.

c) po zavedení nových počítačů Vám v horní levé mřížce zůstanou pouze počítače, u kterých došlo k nějaké změně. Musíte proto projít tuto mřížku a u každého nascanovaného souboru zkontrolovat, zda ve spodní mřížce neexistuje počítač, kterému nascanovaný soubor odpovídá. Při pohybu kursoru v horní mřížce se ve spodní mřížce u všech počítačů zobrazí změněné údaje modrou barvou. Můžete tak velice snadno identifikovat, jaká změna na uvedeném počítači asi proběhla a který počítač odpovídá zvolenému nascanovanému souboru.

Pokud jste našli odpovídající počítač, označte ho v prvním sloupci spodní i horní mřížky a stiskněte tlačítko Přiřadit. Po jeho stisku se údaje z nascanovaného souboru (horní mřížky) přepíší do věty hardware, daný počítač má správně přiřazený soubor a z horní mřížky zmizí. Takto projděte celou horní mřížku a přiřaďte všem zbylým nascanovaným souborům správné počítače.


Scany HW/SW - prideleni evid. cisel

Zavedení nových PC do evidence a přidělení evid.čísla

Pokud jste se rozhodli zavést do evidence hardware nové počítače, spustí se Vám formulář, který obsahuje seznam všech počítačů z nově nascanovaných souborů. Tyto počítače můžete přidat do evidence buď všechny najednou nebo žádný. V případě, že jste se zmýlili a některý počítač nechcete zavést do evidence, stiskněte tlačítko Zpět. Program se vrátí na původní formulář, kde musíte provést opravu.

Popis sloupců :

V prostředních (bílých) sloupcích jsou údaje z nascanovaných souborů (název PC, MAC adresa, Lokální PC). Tyto slouží pouze pro správnou identifikaci počítače.

V prvním (žlutém) sloupci jsou navržená evidenční čísla, která program sám vygeneroval. Tato generace je závislá na nastaveném parametru Tvar evidenčních čísel v konfiguraci v programu SPRÁVCE. Navržená evidenční čísla lze přímo ve sloupci změnit. Pokud zde zadáte evidenční číslo, které již v souboru hardware existuje, program provede kontrolu a nahlásí, že takové evidenční číslo již existuje a nepovolí Vám ho zařadit.

Podle nastavené generace evidenčních čísel mohou nastat dva případy :

a) číslování programem - tvar čísel bude např. H0000001, kde H je prefix nastavený v Konfiguraci programu.

b) libovolné číslování - tvar čísel bude XXXX0001, kde XXXX je programově nastavený prefix

V posledních dvou sloupcích Vám program nabízí datum Zakoupení a Uvedení do provozu, který odpovídá datumu nascanování. Pokud Vám tyto datumy nevyhovují, můžete je opravit u jednotlivých počítačů přímo v mřížce. Pokud chcete u všech počítačů nastavit stejný datum, můžete použít tlačítko Změnit vše.

Stiskem tlačítka OK budou vygenerovány nové počítače podle přidělených evidenčních čísel. Od této chvíle budou tyto počítače v evidenci a tento formulář je již nebude nabízet. Pro nové počítače bude do souboru OPR_HW vygenerována věta STAV=1 Uvedení do provozu.


ScanView

Modul SCANVIEW slouží k zobrazení technických parametrů počítačů a jejich nainstalovaného software. Protože není závislý na spuštění programu SPRÁVCE, lze jej kdykoliv spustit, a to odkudkoliv bez nutnosti nějaké instalace. Slouží k rychlému přehledu o počítačích. Podle zakoupených programů mohou nastat následující situace :

Pouze scan HW

v tomto případě program vyžaduje přímo nascanované textové soubory programu HW-SCAN. Všechny ostatní karty kromě Hardware jsou prázdné.

Pouze scan SW

v tomto případě program vyžaduje soubory SW_BEZLI.DAT, SW_LEG.DAT, SW_NELEG.DAT, SW_REG.DAT, které vzniknou až po zpracování SWT souborů (při ukončení formuláře Zpracování SWT souborů). Karta Hardware je prázdná.

Scan HW a SW

v tomto případě program SCANVIEW vyžaduje umístění nascanovaných textových souborů obou programů ve stejném adresáři. Program upřednostňuje textové soubory hardware. To znamená, že pokud budete mít nascanováno např. pouze 5 počítačů HW_SCANem a např. 150 počítačů SW_SCANem, zobrazí Vám program SCANVIEW pouze 5 počítačů. Ostatní Vám nezobrazí dokud nebudou mít provedené nascanování technických parametrů. Jestliže Vám program naopak nezobrazuje nascanovaný software, znamená to, že jste neprovedli zpracování textových souborů programu SW-SCAN.

V konfiguračním souboru SCANVIEW.CFG musí být uvedena cesta k nascanovaným souborům. Implicitně je uveden podadresář \TXT. Tlačítkem Změnit adr. se lze přepnout do jiného adresáře. Ten se musí do souboru SCANVIEW zapsat ale ručně.

Karta Hardware

zobrazuje seznam nascanovaných počítačů.

Karta Nelegální SW

zobrazuje seznam nelegálně instalovaného software.

Karta Licence

zobrazuje seznam software, který je legálně nainstalován a je mu přidělena licence.

Karta SW z Registru

zobrazuje výpis nainstalovaného software v registrech Windows.

Karta Bez licence

zobrazuje seznam software typu freeware, instalace, ovladače apod.

Karta ADDR.TXT

zobrazuje obsah souboru ADDR.TXT, který obsahuje seznam všech počítačů, na nichž proběhlo scanování. Tato karta přehledně zobrazuje všechny počítače, názvy výstupních souborů, přihlášené uživatele a MAC adresy síťových karet. Tento přehled lze kdykoliv přetřídit. Při změně třídění jsou automaticky v prvním sloupci seznamu zobrazeny duplicitní záznamy. Pomocí tlačítka Zrušit, lze libovolný záznam ze souboru ADDR.TXT označit ke zrušení. Pomocí tlačítka Opravit, lze opravit název výstupního souboru nebo jméno uživatele. Při ukončení programu lze všechny provedené změny potvrdit nebo se vrátit na původní hodnoty. Tato karta je vhodná zejména pro zjištění duplicitních záznamů názvů počítačů nebo duplicitních MAC adres. Tyto situace mohou nastat zejména při větším pohybu počítačů mezi více uživateli, při přehazování síťových karet apod.


Firmy - Celkova suma vazeb

Firmy - celková suma vazeb

Pomocí tohoto formuláře zjistíte celkovou cenu všech dodaných počítačů, software, příslušenství, dokumentace, sítí a požadavků dodaných aktuální firmou. Tato celková suma vazeb hardware, software, příslušenství a sítí je rozdělena na Cenu nezlikvidovaného zařízení a Cenu zlikvidovaného zařízení.


Firmy - Celkova suma oprav

Firmy - celková suma oprav

Pomocí tohoto formuláře zjistíte celkovou cenu všech oprav provedených aktuální firmou. Tato celková cena vazeb hardware, software, příslušenství a sítí je rozdělena na Cenu nezlikvidovaného zařízení a Cenu zlikvidovaného zařízení.


Software - dokoupeni licenci

SW - dokoupení licencí

Ovládání programu

V horní části formuláře je zobrazeno evidenční číslo, název a verze aktuálního software. Dále jsou pak zobrazeny údaje pro dokoupení dalších licencí (datum nákupu, dodavatel, licenční číslo, číslo faktury, interní číslo faktury, cena a počet licencí nebo uživatelů). Při dokoupení dalších licencí je nutno zadat datum nákupu a počet dokoupených licencí, program automaticky přepočítá počet celkově zakoupených licencí a celkovou cenu software.

Pokud jste ještě nedokoupili žádné instalace, objeví se tento formulář pouze v případě, že chcete opravit úvodní nákup. V tomto případě se pod vybraným názvem aktuálního software objeví možnost změnit omezení multilicence (omezená instalacemi, pracujícími nebo neomezená). Tento typ omezení můžete libovolně měnit pouze do té doby, dokud nedokoupíte alespoň jednu licenci.


Hardware - prirazeni sw

Instalace SW na HW

Tento formulář zobrazuje údaje software, který bude nainstalován na vybraný počítač. Slouží k zadání počtu nainstalovaných licencí. Tento formulář se zobrazí pouze v případě, že software je multilicence a vybraný počítač je server sítě.

Je nutné zadat počet licencí, které budou na serveru přístupné pro uživatele. Zadaný počet licencí může být větší než je počet zakoupených licencí pouze v případě, že licence umožňuje čerpat instalace do záporna.


Software - OEM verze

SW – OEM verze

Ovládání programu

Tento formulář slouží k výběru vazby hardware nebo příslušenství v případě, že software byl zakoupen jako OEM verze nebo jako součást nějakého zařízení. V mřížce je zobrazen seznam všeho hardware nebo příslušenství. Musíte vybrat jedno zařízení a stiskem tlačítka Výběr se vybraná hodnota přenese do formuláře software, kde bude označovat zařízení, se kterým byl software zakoupen.


Upgrade/update SW

Upgrade

Tento formulář slouží k výběru licencí pro provedení upgrade. V horní části formuláře se zobrazuje nová verze a pod ní je mřížka ze seznamem předchozích licencí, na které lze provést upgrade nové verze. Nová verze může nabývat dvou stavů :

· nová verze je již pevně vybrána a výběr nelze změnit

jedná se o nově vytvořenou licenci typu UPGRADE nebo změnu licence FULL na UPGRADE. Proto je licence již vybrána a výběr nelze změnit.

· novou verzi lze vybrat ze seznamu volných licencí typu UPGRADE

jedná se o výběr z již existujících licencí typu UPGRADE. Proto lze výběr nové licence kdykoliv změnit.

Pro nabízené předchozí licence ve spodní mřížce platí, že mají ještě nějaké volné licence pro upgrade. Počet volných kusů je zobrazen v předposledním sloupci mřížky.

Pokud máte v horní části vybranou novou licenci typu Upgrade, musíte ve spodní mřížce v prvním sloupci zaškrtnout jednu nebo několik licencí na něž se upgrade provádí. Po zaškrtnutí se v posledním sloupci mřížky zapíše maximální možný počet kusů k čerpání upgrade (můžete ho samozřejmě zmenšit). Celkový počet kusů pro upgrade je pak uveden pod mřížkou.

Stiskem tlačítka < OK > potvrdíte vybrané licence. Program ještě zkontroluje posloupnost předchozích verzí. Je-li všechno v pořádku, potvrdí nastavený upgrade. Je-li v posloupnosti chyba, vyzve vás k její opravě.

Stiskem tlačítkem < Zpět > formulář ukončíte bez provedení změn.

Pokud předchozí verze SW je nainstalovaná na nějakém počítači je zobrazen dotaz, zda novou verzi chcete rovněž přiřadit k tomuto počítači. Pokud odpovíte ANO je přiřazení automaticky provedeno. V případě, že původní verze je přiřazena k více počítačům je zobrazen formulář se seznam těchto počítačů a Vy vyberete ty počítače, ke kterým chcete novou verzi přiřadit.


Tisky

Nastavení podmínek tisku

Formulář slouží k nastavení parametrů pro tisk aktuální sestavy.


Opravy - tisky

Opravy – tisky

SESTAVY

Karta opravy

zobrazuje všechny položky pouze aktuální opravy.

Protokol uvedení zařízení (software) do provozu

zobrazuje protokol o uvedení do provozu pro aktuální opravu (pro stav 1 – Uvedení do provozu).

Protokol o upgrade

zobrazuje protokol o upgrade pro aktuální opravu (pro stav 4 – Upgrade).

Protokol o přeřazení

zobrazuje protokol o přeřazení pro aktuální opravu (pro stav 6 – Převod/Zapůjčení).

Protokol o instalaci / odinstalaci (přiřazení / odřazení)

zobrazuje protokol o přidání / odebrání pro aktuální opravu (pro stav 7 – Přidání / odebrání).

Likvidační protokol

zobrazuje protokol o likvidaci pro aktuální opravu (pro stav 8 – Likvidace).

Protokol o revizi / kontrole elektrických zařízení

zobrazuje protokol o revizi či kontrole elektrického spotřebiče nebo prodlužovacího přívodu dle normy ČSN 33 1610.


Tisk prevodu

Tisk převodu

Tento formulář Vám umožňuje vytisknout protokol o převodu dat. Výběr sestavy lze provést levým tlačítkem myši a stiskem tlačítka OK nebo přímo dvojitým klikem myši na vybrané sestavě.


Udrzba - export dat do ucetnictvi (kontrola dat)

Export dat do účetnictví – kontrola dat

Po spuštění této volby se objeví mřížky se seznamem hardware a samostatného příslušenství. V těchto mřížkách se objeví pouze věty s vyplněným datumem zařazení do účetnictví. Pro tyto věty lze provést opravu :

1) cenu

2) datum zařazení do účetnictví a vyřazení z účetnictví.

Cenu hardware nebo samostatného příslušenství lze opravit přímo ve sloupci Cena. Datum zařazení a vyřazení lze jednotlivě opravit také přímo v daných sloupcích nebo hromadně pomocí tlačítek Změň zařazení/Změň vyřazení. Pro hromadnou změnu je třeba vyplnit datum zařazení/vyřazení a jednotlivě nebo hromadně vybrat věty, pro které se má změna provést.

Pro změnu datumu zařazení nebo vyřazení platí následující podmínky :

a) datum zařazení do účetnictví nesmí být menší než datum zakoupení

b) datum zařazení do účetnictví nesmí být vetší než datum vyřazení z účetnictví

c) datum zařazení do účetnictví nesmí být prázdný (pokud není prázdné datum vyřazení)

d) datum vyřazení z účetnictví nesmí být menší než datum zakoupení a datum zařazení

e) datum vyřazení z účetnictví nesmí být vyplněno, pokud bylo prázdné.


.Spusteni programu - novy zavod

Úvod - nový závod

Tento formulář se spustí při vytvoření datových souborů pro jednotlivé evidované firmy/závody. Pro vytvoření dat pro další firmu/závod musíte zadat číslo a název firmy/závodu. Adresář, ve kterém budou umístěny datové soubory je vygenerován automaticky.


.Spusteni programu - kontrola souboru (chybi soubory)

Úvod - konfigurační soubory

Při kontrole konfiguračních souborů může nastat situace, že některý z nich chybí. V tomto případě program nabídne tento formulář. V horním titulku zobrazuje názvy chybějících souborů a nabízí tyto možnosti:

Vytvořit prázdný

tato možnost vygeneruje příslušný soubor s default hodnotami (default hodnoty mají všechny parametry zakázány nebo vynulovány).

Obnovit ze zálohy

pokud máte provedenou archivaci konfiguračních souborů, program spustí volbu Obnova konfiguračních souborů.


.Spusteni programu - upgrade dat

Úvod - upgrade dat

Pokud provedete instalaci nové verze programu do nového adresáře a chcete načíst data z předchozí verze, objeví se tento formulář. Umožňuje najít data předchozí verze a provést načtení dat do nových adresářů, současně se kopírují i adresáře \FILTRY a \SESTAVY. Pro modul Sestavy je možno zadat požadavek na kopírování původních sestav, a najít příslušný adresář \GEN_ŠEST, v tomto případě se kopíruje i adresář \QSESTAVY ze struktury kde jsou DATA. Po stisku tlačítka OK se provede kontrola, zda zadaný adresář obsahuje správná data a pak se data překopírují z původního adresáře do nového. Pokud stisknete tlačítko Zpět, vytvoří se Vám prázdné datové soubory a k původním datům se nedostanete.


Volna zarizeni

Volná zařízení

Ovládací tlačítka Hromadné výběry

Na tomto formuláři je v mřížce zobrazen seznam volného zařízení (hardware, software, příslušenství, dokumentace, sítě), které lze přiřazovat. V případě volného příslušenství si v levém horním rohu můžete ze seznamu vybrat, jaký typ příslušenství chcete v mřížce zobrazit. Na tomto formuláři je nad mřížkou aktivní pravé tlačítko myši. Pomocí tohoto tlačítka lze označit/odznačit všechno zařízení k přiřazení, zobrazit podrobné informace o zařízení, vytvořit nové zařízení.

Přiřazení software k hardware

přiřadit lze software, který má ještě nějaké volné instalace (lze ho tedy ještě instalovat). Mezi volné instalace se počítají všechny nevyčerpané multilicence, všechny multilicence, u kterých lze jít do záporných hodnot a singl instalace, které ještě nebyly nainstalovány. Stiskem tlačítka Přiřaď najednou přiřadíte všechen vybraný software. V nabídnutém formuláři musíte zadat datum instalace. V případě, že vybraný software je multilicence a vybraný počítač je označen jako server, musíte zadat ještě počet instalovaných kusů. Při přiřazení program vygeneruje do oprav hardware jednu větu se stavem 7 (přiřazení SW) a jednu větu do oprav software se stavem 7 (přiřazení k počítači).

Pozor :

· nelze instalovat software na počítač, který byl zlikvidován (STAV=8).

· na počítač nelze přiřadit software stejného názvu a verze vícekrát.

Přiřazení DOKUMENTACE

přiřadit lze jen takovou dokumentaci, u které je určeno k čemu se vztahuje a která má počet volných kusů > 0. Stiskem tlačítka Přiřaď najednou přiřadíte všechnu označenou dokumentaci. Program Vám nabídne formulář, ve kterém musíte zadat počet kusů. Jestliže najednou přiřazujete více dokumentací, pak je tento zadaný počet kusu platný pro všechny vybrané dokumentace. Zadáte-li více kusů než má dokumentace s nejmenším počtem volných kusů, pak bude zadaný počet kusů snížen na tuto hladinu.

Přiřazení hardware k software

stiskem tlačítka Přiřaď najednou přiřadíte všechen vybraný hardware na aktuální software. V nabídnutém formuláři musíte zadat datum instalace. V případě, že vybraný software je multilicence a vybraný počítač je označen jako server, musíte zadat ještě počet instalovaných kusů. Při přiřazení program vygeneruje do oprav hardware jednu větu se stavem 7 (přiřazení SW) a jednu větu do oprav software se stavem 7 (přiřazení k počítači).

Pozor :

· nelze instalovat software na počítač, který byl zlikvidován (STAV=8).

· na počítač nelze přiřadit software stejného názvu a verze vícekrát.

Přiřazení hardware a příslušenství k síti

stiskem tlačítka Přiřaď se všechno označené zařízení přiřadí na aktuální síť. Program vygeneruje do souboru oprav jednu vetu pro síť (STAV=7 přidání/odebrání hardware/příslušenství) a pro hardware/příslušenství je vygenerována věta STAV = 7 (změna sítě).

Přiřazení zařízení k dokumentaci

po stisku tlačítka Přiřaď požádá program o určení počtu přiřazených kusů. Přiřazovat můžete samozřejmě pouze do vyčerpání počtu volných kusů dokumentace. Pokud se pokusíte přiřadit více kusů, přiřadí se pouze dostupné kusy, ostatní vybrané věty zůstanou označeny a program vypíše upozornění.

Přiřazení podřízeného příslušenství k příslušenství

po stisku tlačítka Přiřaď se automaticky pro všechna vybraná podřízená příslušenství naplní položka Nad_Pris číslem nadřízeného příslušenství. Příslušenství lze přiřadit pouze k jednomu příslušenství !!!

Oprava zařízení

pomocí pravého tlačítka a volby Detail nebo double klikem myší lze na této kartě zobrazit (i opravit) zařízení, na němž se nachází kurzor.


.Ovladani programu - formulare

Změna zobrazení mřížky

Formulář slouží k výběru sloupců, které budou zobrazeny v upravované mřížce. Jsou na něm umístěny dvě mřížky. Levá obsahuje seznam všech položek, které mohou být v mřížce zobrazeny. V pravé mřížce jsou vybrané položky pro zobrazení. Přidáváním, nebo odebíráním položek z pravé mřížky se určuje které položky budou v mřížce ve formě sloupců dostupné.

Poslední sloupec v obou mřížkách říká zda k dané položce existuje v odpovídající tabulce index (zda bude možné podle této položky třídit).


Zamknute soubory

Zamknuté soubory

Tento formulář se objeví v okamžiku, kdy chcete v síťové instalaci spustit volbu, která vyžaduje exclusivní otevření souborů (např. Reindex, Obnova dat apod.) a program má již někdo otevřen sdíleně. V tomto okamžiku nelze pro jednoho uživatele otevřít data exclusivně. Formulář zobrazí dalšího uživatele, který má soubory otevřené a čeká 15 sekund na další pokus o otevření. Takto bude čekat do té doby, než se mu podaří data otevřít nebo než formulář ukončíte stiskem tlačítka Přerušit.


Udrzba - Prodlouzeni verze

Prodloužení licence

Pokud je Vaše licence programu SPRÁVCE zakoupena formou ročního pronájmu, pak na začátku dalšího kalendářního roku vyprší její platnost. Autorská firma Vám automaticky zašle fakturu na další rok a po jejím zaplacení Vám sdělí heslo na prodloužení licence.

Toto heslo stačí na tomto formuláři zadat a program Vám rozšíří platnost na další kalendářní rok.


.Spusteni programu - zmena hesla

Změna hesla

V programu lze mít libovolný počet uživatelů, kteří mohou mít různá přístupová práva k aktualizaci datových souborů. Při úvodní instalaci programu je nastaven pouze jeden uživatel programu, a to uživatel spravce. Tento uživatel je v programu bezpodmínečně nutný, a proto ho nelze zrušit ani přejmenovat. Tento uživatel má totiž jako jediný právo zavádět další uživatele programu SPRÁVCE a nastavovat jejich práva. Taktéž má právo změnit hesla všem ostatním uživatelům.

Pro změnu hesla platí

při zadávání písmen jména a hesla záleží na malých a velkých písmenech (např. PoRad # porad)

heslo uživatele ”spravce” může být prázdné <Enter>

jméno a heslo může mít maximálně 8 znaků

uživatele "spravce" nelze zrušit ani přepsat

Pro změnu hesla je nutné nejprve zadat staré heslo. Pokud je toto staré heslo správně zadáno, dovolí program zadat nové heslo. Toto nové heslo je nutné zadat dvakrát správně, aby nedošlo k překlepu. Pokud je nové heslo dvakrát zadáno správně, je zapsáno na disk. V opačném případě zůstává v platnosti staré heslo.


Ruseni hardware

Rušení hardware

Pokud je na rušeném počítači přiřazena nějaká licence nebo je k němu přiřazeno nějaké příslušenství, je nutno určit, která licence/příslušenství se má pouze odřadit a která zrušit.

Jestliže rušíte pouze jeden záznam hardware je při spuštění formuláře tento záznam automaticky označen ke zrušení, při hromadném rušení musíte záznamy označit. Současně s označením hardware je označeno ke zrušení všechno přiřazené příslušenství, které je součástí počítače při nákupu a OEM software nainstalovaný na tomto počítači.

Pokud k počítači existují nascanované textové soubory, máte možnost na konci rušení určit, zda se mají rovněž smazat.

Rušení/odřazení licencí – OEM licence jsou vždy zrušeny, multilicence se pouze odřadí.


Hardware - ruseni SW

Zrušení přiřazení software

Tento formulář se objeví v případě, že provedete zrušení věty hardware nebo jeho likvidaci (STAV = 8). Rozdíl mezi zrušením a likvidací je, že likvidovaný počítač zůstává v souboru a má příznak LIKVIDACE. Naproti tomu zrušený počítač je fyzicky smazán ze souboru.

Po spuštění se objeví seznam přiřazeného software k rušené větě hardware a Vy musíte rozhodnout, který software se má fyzicky zrušit (v případě rušení) nebo se má likvidovat (v případě likvidace). Pokud se jedná o OEM verzi software je automaticky zlikvidována, u multilicence dojde automaticky k odřazení.. Vybraný software bude zrušen (likvidován), neoznačený software je pouze odřazen od rušeného počítače a je tudíž volný k přiřazení na jiný počítač.


Urceni disku

Určení disku

Tento formulář slouží k určení lokálního disku s pracovními soubory. Pokud totiž používáte ke komprimaci souborů program ARJ a datový adresář máte zadán ve tvaru UNC (např. \\Server\DiskC\Spravce\Ostra\Data), je nutno převést název disku na klasický (C:\...).

Program tento převod provede bez problému v případě, že datový adresář je uložen na síťovém disku. Pokud však disk je zároveň Vaším lokálním diskem, je nutno zadat označení disku ručně.


Dokumentace

Evidence dokumentace obsahuje informace o důležité (hlavně asi drahé) dokumentaci. Kromě dokumentace typu manuály, příručky apod. lze v této evidenci uchovávat informace o knihách, časopisech, CD apod.

Kromě základních údajů (název, autor, obsah, …), umístění a vazby lze evidovat také zapůjčení (datum, osoba).


Evidence - ekonomicke udaje

Ekonomické údaje

Číslo faktury a Interní číslo faktury

číslo faktury je číslo dodavatelské faktury, Interní číslo faktury je číslo firemního číslování faktur.

Záruka

dobu platnosti záruky lze zadávat buď v měsících nebo k určitému datumu. Pokud je záruka zadána v měsících, pak se konec záruky vypočítá z datumu zakoupení + zadaný počet měsíců.

Inventura

datum inventury lze zadat ručně pouze v okamžiku pořízení nové věty. Jinak se tato položka aktualizuje sama pouze v okamžiku vytištění inventární sestavy ve volbě Ostatní - Inventární sestavy.

Druh majetku

tato položka je určená k označení zařízení z účetního hlediska. Muže nabývat těchto hodnot :

· hmotný majetek

· drobný hmotný majetek

· nehmotný majetek

· drobný nehmotný majetek

· finanční pronájem

· operativní pronájem

· operativní evidence

Pro hardware je předdefinována hodnota hmotný majetek.

Pro licence software je předdefinována hodnota drobný nehmotný majetek.

Pro příslušenství je předdefinována hodnota drobný hmotný majetek.


HW Audit - opravy

HW,SW Audit – opravy (historie změn)

Opravy mohou nabývat následujících stavů :

1. Program automaticky hlídá změnu všech důležitých údajů a v případě jejich změny automaticky generuje větu do oprav. Jedná se např. o změnu odpovědné osoby, změnu umístění, přidání nebo odebrání příslušenství, likvidaci, uvedení do provozu apod.

2. Program samozřejmě umožňuje také opravy zadat ručně. Ručně je lze zadat vždy na kartě Opravy.

Program umožňuje zaevidované opravy vytisknout, lze zadat období a program v sestavě uvede i celkové náklady za zvolené období.


HW Audit - servisy

HW,SW Audit – servisy

Program umožňuje sledovat a provádět plánované servisy (roční servisy, profylaxe, revize dle ČSN, roční servisy pro software, software assurance apod.). Program Vám barevně zobrazuje servisy provedené, prošlé a k provedení. Umožňuje vše také vytisknout.

Nastavení servisů :

a. Jednotlivě – nastavuje se vždy na kartě Servisy nebo na kartě Ostatní (viz. obrázek). Označení servisu se provede ve sloupci Servisy. Ke každému zařízení lze zadat až 4 různé servisy (řádky 1-4).

b. Hromadně – nastavuje se v číselníku Servisů. Nové servisy se zadávají na kartě Volné. Zde máte seznam počítačů, které servis ještě nemají servis nastaven. Výběr provedete v prvním sloupci (vybrané věty se označí zeleně).

V pravé dolní části formuláře musíte vybrat požadovaný servis. Pak jen stačí pravým tlačítkem myši kdekoliv ve mřížce rozbalit menu a spustit volbu Přeřadit.

Provedení servisů :

c. Jednotlivě – stejně jako u nastavení, viz. obrázek a). Slouží k tomu tlačítko Proveď na konci řádku. Po jeho stisku se vygeneruje věta do Oprav, můžete v ní nastavit další potřebné údaje (cena, firma,…) a označí se azurovou barvou, viz. servis na řádku 3 obrázku a). Podle zvoleného intervalu nastaví termín dalšího provedení servisu.

d. Hromadně – k tomu slouží ikona v pravé dolní části formuláře

Jedná se o ikonu :

Po jejím stisku se spustí formulář, ve kterém nastavíte datum k provedení servisu a ve mřížce se vám zobrazí seznam počítačů(zařízení), u kterých by se servis měl provést.


HW Audit - licence SW

HW, SW Audit – licence SW

Program umožňuje ručně přiřadit licence SW. Toto ruční přiřazení má význam v těchto případech :

· přiřazení licence, kterou nelze nascanovat scanem SW. Jedná se např. o licence, které mají jádro na serveru a na lokální stanici je pouze klient. Tento klient nemá soubor, který lze nascanovat a podle něj licenci přiřadit.

· odřazení licence


HW Audit - prislusenstvi

HW Audit – příslušenství

Při zpracování nascanovaného TXT souboru lze k počítači přiřadit pouze základní typy příslušenství (mainboard, paměť, disk, …). Ostatní typy (např. filtry, reproduktory, ups, …) nascanovat nelze. Na kartě Vazby PŘ v hlavní evidenci hardware lze přiřadit tyto typy a provádět další funkce. Důležitou funkcí je nastavení, zda nascanovaná příslušenství byla součástí PC při nákupu.


HW Audit - dokumentace

HW, SW Audit – dokumentace

Program umožňuje ke každému počítači evidovat přiřazenou dokumentaci.


HW Audit - poznamky

HW, SW Audit – poznámky

Program umožňuje u každého počítače udržovat neomezenou poznámku. Jedná se o MEMO položku, do které si můžete zapisovat Vaše poznámky, poznatky a další údaje, pro které nemá evidence hardware vlastní položku.

Editaci poznámky spustíte pomocí ikony, kterou naleznete v dolní části formuláře hardware.

Jedná se o ikonu :

Pokud má počítač vyplněnou poznámku, má karta Poznámka červenou barvu :


HW Audit - elektr. dokumenty

HW, SW Audit – elektronické dokumenty

Program umožňuje evidovat některé důležité dokumenty v elektronické podobě. Toto je vhodné např. pro :

· evidenci nascanovaných faktur, smluv, dodacích listů apod. při zakoupení hardware

· evidenci nascanovaných faktur, smluv, licenčních ujednání pro nainstalovaný software

· fotky havárií, poškození počítače apod.

· texty smluv a jiných důležitých dokumentů

Tyto dokumenty musí být umístěny v adresáři \MICOS\SPRAVCE8\OSTRA\DOKUMENT. Podporovány jsou následující formáty :

a) DOC, XLS, PDF, HTM

b) všechny grafické formáty, které lze na PC spustit – JPG, GIF, BMP, apod.


Struktury souboru - Kspravce (centralni soubory)

Struktury souborů – KSPRÁVCE (centrální)

CIS_ZAVO.DBF - číselník závodů (středisek)

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

číslo závodu

NAZEV

Character

30

název závodu

HWO

Integer

4

počet vět HW - starý

HWN

Integer

4

počet vět HW - nový

SWO

Integer

4

počet vět SW - starý

SWN

Integer

4

počet vět SW - nový

PRO

Integer

4

počet vět přísl. - starý

PRN

Integer

4

počet vět přísl. - nový

PRLANO

Integer

4

počet vět přísl. lan - starý

PRLANN

Integer

4

počet vět přísl. lan – nový

PRSAMO

Integer

4

počet vět přísl. sam. – starý

PRSAMN

Integer

4

počet vět přísl. sam. - nový

DOKO

Integer

4

počet vět dokumentace - starý

DOKN

Integer

4

počet vět dokumentace - nový

LANO

Integer

4

počet vět sítí - starý

LANN

Integer

4

počet vět sítí - nový

POZO

Integer

4

počet vět požadavků - starý

POZN

Integer

4

počet vět požadavků - nový

MINULE

Date

8

Minulé období zpracování

AKTUALNI

Date

8

aktuální období zpracování

VYBER

Logical

1

pomocná položka

POMOC

Logical

1

pomocná položka

CIS_ORGA.DBF - číselník organizačního členění

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

číslo organizačního členění

NAZEV

Character

30

název organizačního členění

POZNAMKA

Character

20

poznámka

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_SERV.DBF - číselník servisů

Název

Typ položky
Délka

Význam položky

TYP_SERVC

Character

3

číslo servisu

NAZEV

Character

20

název servisu

INT_SERV

Integer

4

interval provedení dalšího servisu

DAT_ZAHAJ

Date

8

datum zahájení servisu

REVIZE

Logical

1

příznak, zda jde o revizi

POZNAMKA

Character

80

poznámka

SKUPINA

Character

1

revize – skupina používání

TROCHR

Character

1

revize – třída ochrany

NAPETI

Integer

4

revize – napětí

VYKON

Integer

4

revize – výkon

PROUD

Integer

1

revize – proud

SCHVALIL

Logical

1

pomocná položka

CIS_PTYP.DBF - číselník typů příslušenství

Název

Typ položky

Délka

Význam položky

CISLO

Character

4

číslo typu příslušenství 001,S001, ...

NAZEV

Character

20

název typu příslušenství

DRUH

Character

1

druh typu

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_PNAZ.DBF - číselník názvů příslušenství

Název

Typ položky

Délka

Význam položky

TYP

Character

4

číslo typu příslušenství

NAZEV

Character

40

název příslušenství

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_POB1.DBF - číselník oblastí 1 příslušenství

Název

Typ položky

Délka

Význam položky

TYP

Character

4

číslo typu příslušenství

NAZEV

Character

30

název oblasti 1

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_HPOU.DBF - číselník typu použití hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

20

typ použití - CAD, Server

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_HZNA.DBF - číselník značek hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

značka počítače

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_OSHW.DBF - číselník typu operačních systémů hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název operačního systému

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_SOFT.DBF - číselník názvů software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

50

název software

VERZE

Character

10

verze software

OBLAST

Character

30

oblast - hrubé členění

PODOBLAST

Character

30

podoblast - jemné členění

DRUH

Character

1

licenční, aplikační, ...

VYROBCE

Character

40

výrobce software

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

COUNT

Integer

4

počet souboru ve vzorech

MAINFILE

Character

30

hlavní soubor

OS

Logical

1

zda je SW operačním systémem

MAEXE

Logical

1

zda je ve vzorech soubor, kterým se SW spouští

VSESDIL

Logical

1

pomocná položka (všechny soubory využívá I jiný SW)

VSEZAPIS

Logical

1

pomocná položka (soubory mění datum, čas a velikost)

DOCAS

Logical

1

pomocná položka

ID

Character

10

pomocná položka

SW_LOKAL

Character

2

lokalizace (CZ, SL, …)

BALIK

Logical

1

zda je SW balík programů (např. MS Office)

CENA

Integer

4

průměrná cena software

POMOC

Logical

1

pomocná položka

CIS_OBLA.DBF - číselník oblastí určení software

Název

Typ položky
Délka

Význam položky

NAZEV

Character

30

název oblasti

PODOBLAST

Character

30

název podoblasti

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_OSSW.DBF - číselník typu operačních systémů software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název operačního systému

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

CIS_VYR.DBF - číselník výrobců software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název výrobce

STAT

Character

40

Stát

MESTO

Character

25

Město

ULICE

Character

25

Ulice

PSC

Character

6

Psč

ICO

Character

8

IČO

DIC

Character

14

DIČ

WWW

Character

50

název www stránek

JMENO

Character

30

odpovědná osoba

TELEFON

Character

50

telefon

EMAIL

Character

50

e-mail

FAX

Character

50

fax

POZNAMKA

Character

80

poznámka

POMOC

Logical

1

pomocná položka

SCHVALIL

Logical

1

pomocná položka

CIS_LOKA.DBF - číselník lokalizací software

Název

Typ položky

Délka

Význam položky

KOD

Character

2

číslo typu příslušenství 001,S001, ...

NAZEV

Character

20

název typu příslušenství

KOD_CISLO

Character

4

mezinárodní číslo lokalizace

POMOC

Logical

1

pomocná položka

SCHVALIL

Logical

1

zda je věta schválená

CIS_VOLNY.DBF – číselník volný

Název

Typ položky

Délka

Význam položky

CISLO

Character

30

číslo

NAZEV

Character

60

název

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace

SW_LIST.DBF - soubor softwarových vzorů

Název

Typ položky

Délka

Význam položky

SOUBOR

Character

30

souboru

CESTA

Character

100

adresář, ve kterém se soubor obvykle nachází

VELIKOST

Integer

4

velikost souboru

DATUM

Date

8

datum vytvoření souboru

CAS

Character

8

čas vytvoření souboru

NAZEV

Character

50

název SW, ke kterému soubor patří

VERZE

Character

10

verze SW, ke kterému soubor patří

ID

Character

8

pomocná položka

HLAVNI_SOU

Logical

1

určení, zda se jedná o hl. modul SW

ZAPIS

Logical

1

pomocná položka (soubor do sebe zapisuje)

SDILEN

Logical

1

pomocná položka (soubor muže používat I jiný SW)

VYRID

Logical

1

pomocná položka

VYROBCE

Character

60

výrobce produktu (programu) z hlavičky EXE souboru

PRODUKT

Character

60

název produktu

VERZE_PROD

Character

20

verze produktu

POPIS

Character

60

stručný popis souboru z hlavičky EXE souboru

NOVA

Logical

1

pomocná položka

POMOC

Logical

1

pomocná položka

SW_LICEN.DBF - centrálně udržované licence SW

Název

Typ položky

Délka

Význam položky

CISLO

Character

30

číslo licence

BASELICEN

Character

30

číslo mateřské licence

NAZEV

Character

50

název licence

VERZE

Character

10

verze licence

BALIK_NAZ

Character

30

název softwarového balíku

DODAVATEL

Character

30

název dodavatele

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

SMLOUVA

Character

25

číslo smlouvy

DODAK

Character

15

číslo dodacího listu

DOKLADY

Character

40

umístění dokladů - správce, účtárna

STAV

Integer

4

aktuální stav licence 0-8

DATUM

Date

8

datum zakoupení

UVEDENO

Date

8

datum uvedení do provozu

CENA

Currency

8

cena celkem

CENAKS

Currency

8

cena za 1 kus

LICEN

Character

30

licenční číslo

SC

Character

20

specifické číslo

IC

Character

20

inventární číslo

LIC_NAKUP

Character

15

forma nákupu (krabice, MOLP)

LIC_MINUS

Logical

1

čerpání licencí do záporna

LIC_TYP

Character

15

typ instalace SW (FULL, OEM, …)

LIC_DOBA

Date

8

časové omezení licence

LIC_UZIV

Character

25

typ multilicence

LIC_PRAC

Integer

4

počet uživatelů současně pracující

LIC_ZARIZ

Character

7

číslo a typ zařízení, na nějž byla licence zakoupena

OEM

Character

8

číslo HW nebo PR k OEM verzi

OEMPUVOD

Character

50

původní číslo OEM zařízení

DOWNGRADE

Logical

1

povolení DownGrade

DOWN_POZN

Character

50

seznam sw pro použití DownGrade

JAZYK

Character

30

programovací jazyk

PRISLUS

Character

50

příslušenství

MULTILIC

Logical

1

multilicence

OMEZENI

Character

30

popis omezení multilicence

PC_PUVOD

Integer

4

celkový počet licencí

PC_DODANO

Integer

4

dodané licence k dispozici

PC_INST

Integer

4

počet instalovaných licencí

PC_ZBYVA

Integer

4

počet volných licencí

PC_PREVOD

Integer

4

počet převedených licencí

UPG_KS1

Integer

4

počet, ze kterých byl proveden upgr.

UPG_KS2

Integer

4

počet, na které byl proveden upgr.

UPG_KOD

Character

5

pomocná položka pro upgrade

UPG_TYP

Character

1

typ upgrade

AKT_VERZE

Logical

1

označení poslední verze licence

INVENTURA

Date

8

datum poslední inventury

ZARUKA

Date

8

datum záruky

ZAR_TYP

Integer

4

typ zadávání záruky

ZAR_MES

Integer

4

záruka v měsících

ODPIS

Date

8

datum odpisu

SIT_SOFT

Logical

1

sítový software A/A

POZNAMKA

Character

90

poznámka

SW_LOKAL

Character

2

lokalizace – kód (CZ, SL)

SW_LOKAL2

Character

30

lokalizace – poznámka

SW_SYS

Character

40

operační systém

AKTUAL

Date

8

datum poslední aktualizace

AKTUAL_NAM

Character

8

jméno aktualiz. Uživatele

MEDIA

Character

20

typ médií – diskety, CD, …

UCTOZARAD

Date

8

datum zařazení do účetnictví

UCTOVYRAD

Date

8

datum vyřazení z účetnictví

UCTOEXPORT

Integer

4

pořadí exportu do účetnictví

UCTOMAJET

Character

40

druh majetku

TYP_SERV1

Character

3

číslo servisu

DAT_SERV1

Date

8

datum servisu

PRV_SERV1

Logical

1

zda byl servis proveden

TYP_SERV2

Character

3

číslo servisu

DAT_SERV2

Date

8

datum servisu

PRV_SERV2

Logical

1

zda byl servis proveden

TYP_SERV3

Character

3

číslo servisu

DAT_SERV3

Date

8

datum servisu

PRV_SERV3

Logical

1

zda byl servis proveden

TYP_SERV4

Character

3

číslo servisu

DAT_SERV4

Date

8

datum servisu

PRV_SERV4

Logical

1

zda byl servis proveden

POMOC

Logical

1

pomocná položka

POMOC1

Logical

1

pomocná položka

NPOMINST

Integer

4

pomocná položka

PR_LICEN.DBF - soubor přidělených licencí k určitému závodu

Název

Typ položky

Délka

Význam položky

CISLO

Character

30

číslo licence

ZAVOD

Character

8

číslo závodu

DODANO

Integer

4

počet dodaných instalací na závod

INST

Integer

4

počet instalovaných instalací

VOLNE

Integer

4

počet volných instalací

POMOC

Logical

1

pomocná položka

UPGRADE.DBF – pomocný soubor pro vytváření upgrade SW

Název

Typ položky
Délka

Význam položky

CISLO

Character

30

aktuální číslo SW

KS

Integer

4

Kusy, na které byl proveden upgrade

KOD

Character

5

vazební položka na soubor SOFTWARE

PORADI

Integer

4

pořadí upgrade

POMOC

Logical

1

pomocná položka

LICENCE.DBF – soubor dokoupených licencí

Název

Typ položky
Délka

Význam položky

CISLO

Character

30

evidenční číslo SW

LICEN

Character

30

licenční číslo SW

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo FA

DODAVATEL

Character

30

dodavatel

KUSY

Integer

4

počet dokoupených licencí

DATUM

Date

8

datum dokoupení licencí

CENA

Currency

8

cena

CENA_KS

Currency

8

cena za 1 ks dokoupené licence

PRVNÍ

Logical

1

pomocná položka – první nákup

POMOC

Logical

1

pomocná položka

OPR_LC.DBF – soubor oprav software

Název

Typ položky
Délka

Význam položky

CISLO

Character

30

číslo software

DATUM

Date

8

datum začátku opravy

PRIZNAKY

Character

60

příznaky opravy

PRIZNAKY2

Character

60

příznaky opravy

DODAVATEL

Character

30

dodavatelská firma

OSOBA

Character

30

odpovědná osoba

UKONCENI

Date

8

ukončení opravy

PORUCHA

Memo

4

popis odstranění opravy

POZNAMKA

Character

60

poznámka

STAV

Integer

4

stav opravy

TYP_SERVC

Character

3

typ servisu pro STAV = 5

DNY_OPR

Integer

4

počet dnů opravy

DNY_ZAR

Integer

4

počet dnů prodloužení záruky

CENA

Currency

8

cena opravy

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

CISPROT

Integer

4

revize – číslo protokolu

VYPR

Logical

1

revize – výsledek prohlídky

VYZK

Logical

1

revize – výsledek zkoušky

VYCELK

Logical

1

revize – výsledek celkem

SEST

Character

1

revize – sestava přístroje

DELKA

Currency

8

revize – délka síťového přívodu

OCHRODP

Currency

8

revize – odpor ochranného vodiče

MPOCHRO

Character

10

revize – měřící přístroj ochranného vodiče

CMPOCHRO

Character

20

revize – číslo měřícího přístroje ochr. vodiče

IZODP

Currency

8

revize – izolační odpor

MPIZO

Character

10

revize – měřící přístroj izolačního odporu

CMPIZO

Character

20

revize – číslo měřícího přístroje izol. odporu

METUNP

Character

1

revize – metoda měření proudu

UNPROUD

Currency

8

revize – unikající proud

MPUNP

Character

10

revize – měřící přístroj unikajícího proudu

CMPUNP

Character

20

revize – číslo měřícího přístroje unik. proudu

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

AKTUAL

Date

8

datum aktualizace

AKTUAL_ZP

Character

2

způsob aktualizace

POMOC

Logical

1

pomocná položka

FIRMY.DBF - číselník dodavatelů licencí SW

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

název firmy

ICO

Character

8

IČO

DIC

Character

14

DIČ

JMENO

Character

30

odpovědná osoba

TELEFON1

Character

50

telefon

EMAIL1

Character

50

e-mail

JMENO2

Character

30

odpovědná osoba

TELEFON2

Character

50

telefon

EMAIL2

Character

50

e-mail

FAX

Character

50

fax

ULICE

Character

25

ulice

MESTO

Character

25

město

PSC

Character

6

PSC

WWW

Character

50

název www stránek

POZNAMKA

Memo

4

poznámka

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

AKTUAL_D

Date

8

datum aktualizace

KONFIG2.DBF - konfigurační parametry pro Multilicenci

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

číslo závodu

NAZEV

Character

30

název závodu

ORG

Logical

1

centrální údržba čís. org. členění

PRTYP

Logical

1

centrální údržba čís. typu přísl.

PRNAZ

Logical

1

centrální údržba čís. názvu přísl.

PROB1

Logical

1

centrální údržba čís. oblastí 1 přísl.

HWPOU

Logical

1

centrální údržba čís. použití hardware

HWZNA

Logical

1

centrální údržba čís. značek hardware

HWSYST

Logical

1

centrální údržba čís. OS hardware

SWNAZ

Logical

1

centrální údržba čís. názvu software

SWSYST

Logical

1

centrální údržba čís. OS software

SWOB

Logical

1

centrální údržba čís. oblastí software

PP

Logical

1

centrální údržba předávacích protokolů

SWVYR

Logical

1

centrální údržba čís. výrobců

AWSCAN

Logical

1

Aktualizace SW pouze AW-SCANem

TVARHW

Character

4

tvar evidenčních čísel hardware

TVARSW

Character

4

tvar evidenčních čísel software

TVARPR

Character

4

tvar evidenčních čísel příslušenství

TVARPRLAN

Character

4

tvar evidenčních čísel síťového přísl.

TVARPRVOL

Character

4

tvar evidenčních čísel samost. přísl.

TVARDO

Character

4

tvar evidenčních čísel dokumentace

TVARLAN

Character

4

tvar evidenčních čísel sítí

TVARPOZ

Character

4

tvar evidenčních čísel požadavků

IHW

Integer

4

automat. vytváření evid. čísel HW

ISW

Integer

4

automat. vytváření evid. čísel SW

IPR

Integer

4

automat. vytváření evid. čísel PŘ

IPRLAN

Integer

4

automat. vytváření evid. čísel síť. PŘ

IPRVOL

Integer

4

automat. vytváření evid. čísel sam. PŘ

IDO

Integer

4

automat. vytváření evid. čísel DOK

ILAN

Integer

4

automat. vytváření evid. čísel SÍTÍ

IPOZ

Integer

4

automat. vytváření evid. čísel POŽ

NELEGALNI

Logical

1

načtení nelg. SW z AW-SCANu

BLOKAW

Integer

4

blokace parametrů pro AW-SCAN

BLOKCISLO

Integer

4

povolení změny tvaru evidenčních čísel

TXTEVC

Logical

1

evid. čísla HW vytvářet z TXT souborů

VERZE

Character

5

aktuální verze programu SPRÁVCE

NACTENO

Logical

1

načtení konfiguračního souboru

HARDWARE

Logical

1

pomocná položka

SRV

Logical

1

centrální údržba čís. servisů

VOLNY

Logical

1

centrální údržba čís. Volný

CLOKAL

Logical

1

pomocná položka

VazbyUpg

Logical

1

pomocná položka

PROTOKOL.DBF - text všech předávacích protokolů

Název

Typ položky

Délka

Význam položky

TXT_HW

Memo

4

text předávacího protokolu HW

TXT_SW

Memo

4

text předávacího protokolu SW

TXT_PR

Memo

4

text předávacího protokolu přísl.

TXT_PRLAN

Memo

4

text předávacího protokolu síť. přísl.

TXT_PRVOL

Memo

4

text předávacího protokolu samost. přísl.

TXT_DO

Memo

4

text předávacího protokolu dokumentace

TXT_SIT

Memo

4

text předávacího protokolu sítě

SETUP.DBF - soubor pro generování evidenčních čísel

Název

Typ položky

Délka

Význam položky

SOUBOR

Character

8

datový soubor - sw

HODNOTA

Integer

4

poslední hodnota čísla

SW_BALIK.DBF - soubor softwarových balíků

Název
Typ položky
Délka
Význam položky

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

VYRID

Logical

1

zda byl balík pořízen dodavatelskou firmou

POMOC

Logical

1

pomocná položka

ID

Integer

4

vazba na soubor SW_MODUL

SCHVALIL

Logical

1

věta je schválená z nadřízené organizace


Struktury souboru - ciselniky

Struktury souborů – SPRÁVCE (číselníky)

CIS_OSOB.DBF - číselník odpovědných osob

Název

Typ položky

Délka

Význam položky

OSOBA

Character

30

příjmení, jméno a titul odpovědné osoby

OS_CISLO

Character

10

Osobní číslo odpovědné osoby

TELEFON

Character

20

Telefon

FAX

Character

20

Fax

MOBIL

Character

20

Mobil

EMAIL

Character

40

e-mail

ORG_CS

Character

8

Číslo org. členění

MISTO_CS

Character

8

Číslo umístění

FUNKCE

Character

20

Funkce

TITULPR

Character

10

Titul před jménem

TITULZA

Character

10

Titul za jménem

TYPOS

Character

20

Stupeň org. zařazení

USERJM

Character

20

Uživatelské jméno

POHLAVI

Integer

Pohlaví

POZNAMKA

Character

20

poznámka

POMOC

Logical

pomocná položka

CIS_ORGA.DBF - číselník organizačního členění

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

číslo organizačního členění

NAZEV

Character

30

Název organizačního členění

POZNAMKA

Character

30

poznámka

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_UMIS.DBF - číselník umístění

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

číslo umístění

NAZEV

Character

30

Název umístění

POZNAMKA

Character

30

poznámka

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_SERV.DBF - číselník servisů

Název

Typ položky
Délka

Význam položky

TYP_SERVC

Character

3

Číslo servisu

NAZEV

Character

20

název servisu

INT_SERV

Integer

interval provedení dalšího servisu

DAT_ZAHAJ

Date

datum zahájení servisu

REVIZE

Logical

příznak, zda jde o revizi

POZNAMKA

Character

80

poznámka

SKUPINA

Character

1

revize – skupina používání

TROCHR

Character

1

revize – třída ochrany

NAPETI

Integer

revize – napětí

VYKON

Integer

revize – výkon

PROUD

Integer

revize – proud

SCHVALIL

Logical

pomocná položka

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_PTYP.DBF - číselník typů příslušenství

Název

Typ položky
Délka

Význam položky

CISLO

Character

4

číslo typu příslušenství 001,S001, ...

NAZEV

Character

20

název typu příslušenství

DRUH

Character

1

druh typu

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_PNAZ.DBF - číselník názvů příslušenství

Název

Typ položky

Délka

Význam položky

TYP

Character

4

číslo typu příslušenství

NAZEV

Character

40

název příslušenství

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_POB1.DBF - číselník oblastí 1 příslušenství

Název

Typ položky

Délka

Význam položky

TYP

Character

4

číslo typu příslušenství

NAZEV

Character

30

název oblasti 1

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_POB2.DBF - číselník oblastí 2 příslušenství

Název

Typ položky

Délka

Význam položky

TYP

Character

4

číslo typu příslušenství

NAZEV

Character

30

název oblasti 2

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_HPOU.DBF - číselník typů použití hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

20

typ použití - CAD, Server

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_HZNA.DBF - číselník značek hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

značka počítače

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_OSHW.DBF - číselník typů operačních systémů hardware

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název operačního systému

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_SOFT.DBF - číselník bilance software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

50

název software

VERZE

Character

10

verze software

OBLAST

Character

30

oblast - hrubé členění

PODOBLAST

Character

30

podoblast - jemné členění

DRUH

Character

1

licenční, aplikační, ...

VYROBCE

Character

40

výrobce software

POMOC

Logical

pomocná položka

SCHVALIL

Logical

věta je schválená z nadřízené organizace

COUNT

Integer

počet souborů ve vzorech v daném SW

MAINFILE

Character

30

hlavní soubor

OS

Logical

určení, zda SW je operačním systémem

MAEXE

Logical

určení, zda ve vzorech je soubor, kterým se SW spouští

VSESDIL

Logical

pomocná položka (všechny soubory využívá i jiný SW)

VSEZAPIS

Logical

pomocná položka (soubory mění datum, čas a velikost)

DOCAS

Logical

pomocná položka

BALIK

Logical

zda je SW balík samostatných programů

ID

Character

10

pomocná položka

SW_LOKAL

Character

2

lokalizace (CZ, SL, …)

CENA

Currency

průměrná cena software

NOVY

Logical

pomocná položka

LICENCE

Integer

počet zakoupených licencí

NELEG

Integer

počet nelegálních instalací

BEZLIC

Integer

počet instalací bez licence

INSTAL

Integer

počet instalovaných licencí

ZBYVA

Integer

počet volných licencí

ROZDIL

Integer

celková bilance

CIS_OSSW.DBF - číselník typu operačních systémů software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název operačního systému

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_OBLA.DBF - číselník oblastí software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

název oblasti

PODOBLAST

Character

30

název podoblasti

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_VYR.DBF - číselník výrobců software

Název

Typ položky

Délka

Význam položky

NAZEV

Character

40

název výrobce

STAT

Character

40

stát

MESTO

Character

25

město

ULICE

Character

25

ulice

PSC

Character

6

psč

ICO

Character

8

IČO

DIC

Character

14

DIČ

WWW

Character

50

název www stránek

JMENO

Character

30

odpovědná osoba

TELEFON

Character

50

Telefon

EMAIL

Character

50

e-mail

FAX

Character

50

Fax

POZNAMKA

Character

80

poznámka

POMOC

Logical

pomocná položka

SCHVALIL

Logical

pomocná položka

NOVY

Logical

CIS_LOKA.DBF - číselník lokalizací SW

Název

Typ položky

Délka

Význam položky

KOD

Character

2

kód lokalizace (CZ, SL, …)

NAZEV

Character

30

název lokalizace

KOD_CISLO

Character

4

mezinárodní číslo lokalizace

POMOC

Logical

pomocná položka

SCHVALIL

Logical

schválená věta

NOVY

Logical

pomocná položka

CIS_VOLN.DBF - číselník volný

Název

Typ položky

Délka

Význam položky

CISLO

Character

30

číslo

NAZEV

Character

60

název

SCHVALIL

Logical

věta je schválená z nadřízené organizace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_APLI.DBF - číselník aplikací

Název

Typ položky

Délka

Význam položky

NAZEV

Character

50

název aplikace

POMOC

Logical

pomocná položka

NOVY

Logical

pomocná položka

CIS_DOKU.DBF - číselník druhů elektronických dokumentů

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

název elektronického dokumentu

POMOC

Logical

pomocná položka


Struktury souboru - dokumentace

Struktury souborů – SPRÁVCE

DOKUMENT.DBF – seznam dokumentace

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

evidenční číslo

NAZEV

Character

50

název

DODAVATEL

Character

30

dodavatel

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

DODAK

Character

15

číslo dodacího listu

DATUM

Date

datum zakoupení

CENA

Currency

cena

ORG_CS

Character

8

číslo organizačního členění

MISTO_CS

Character

8

číslo umístění

OSOBA

Character

30

odpovědná osoba

OBSAH

Character

70

obsah dokumentace

AUTOR

Character

30

autor dokumentace

JAZYK

Character

15

jazyk - čeština, angličtina

EDICE

Character

15

edice

VYDANI

Integer

rok vydání

DAT_ZAP

Date

datum zapůjčení

OSOBA_ZAP

Character

30

dokumentace zapůjčena

INVENTURA

Date

datum poslední inventury

VAZBA

Character

2

vazba na hw, sw

KUSY

Integer

počet kusu

VOLNEKUSY

Integer

počet volných kusu

POZNAMKA

Character

90

poznámka

AKTUAL

Date

datum poslední aktualizace

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

SC

Character

30

specifické číslo

POMOC

Logical

pomocná položka

POMOC1

Logical

pomocná položka


Struktury souboru - firmy

Struktury souborů - SPRÁVCE

FIRMY.DBF - dodavatelské firmy

Název

Typ položky

Délka

Význam položky

NAZEV

Character

30

název firmy

ICO

Character

8

IČO

DIC

Character

14

DIČ

JMENO

Character

30

jméno

TELEFON1

Character

50

telefon

EMAIL1

Character

50

e-mail

JMENO2

Character

30

jméno

TELEFON2

Character

50

telefon

EMAIL2

Character

50

e-mail

FAX

Character

50

fax

ULICE

Character

25

ulice

MESTO

Character

25

město

PSC

Character

6

psč

WWW

Charakter

50

název www stránek

POZNAMKA

Memo

poznámka

AKTUAL_NAM

Character

8

jméno uživatele, který naposledy aktualizoval

AKTUAL

Date

datum poslední aktualizace


Struktury souboru - hardware

Struktury souborů - SPRÁVCE

HARDWARE.DBF – seznam počítačů

LIK_HARD.DBF – seznam zlikvidovaných počítačů

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

evidenční číslo

SOUBOR

Character

16

jméno TXT souborů ze scanů Hw,Sw

DODAVATEL

Character

30

dodavatel

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

SMLOUVA

Character

25

číslo smlouvy / číslo objednávky

DODAK

Character

15

číslo dodacího listu

DOKLADY

Character

40

umístění dokladu

DATUM

Date

datum zakoupení

UVEDENO

Date

datum uvedení do provozu

CENA

Currency

cena počítače

CENA_PRIS

Currency

cena samostatného příslušenství

CENA_CELK

Currency

celková cena (počítač + příslušenství)

ORG_CS

Character

8

číslo organizačního členění

ORG_NAZEV

Character

30

název organizačního členění

MISTO_CS

Character

8

číslo umístění

STAV

Integer

aktuální stav hardware 0-9

SERVER

Logical

zda je HW server sítě - A/N

SERVER_NAM

Character

15

jméno počítače

SITE

Character

8

číslo sítě

TYP

Character

40

Typ počítače

ZNACKA

Character

30

značka počítače

PROVEDENI

Character

40

provedení počítače

POUZITI

Character

20

Typ použití počítače

OS

Character

40

operační systém

KOPROCESOR

Logical

koprocesor A/N

PORTY

Character

11

pocty portu

PAMET

Integer

velikost paměti RAM

KS_PROC

Integer

počet procesoru

KS_PAM

Integer

počet pamětí

KS_HD

Integer

počet hard disků

KAP_HD

Currency

celková kapacita pamětí

OSOBA

Character

30

odpovědná osoba

SPRAVCE

Character

30

správce počítače

VC

Character

40

výrobní číslo

IC

Character

20

inventární číslo

SC

Character

30

specifické číslo

ZARUKA

Date

datum záruky

ZAR_TYP

Integer

typ záruky (1=měsíce, 2=datum)

ZAR_MES

Integer

záruka v měsících

ODPIS

Date

datum odpisu

INVENTURA

Date

datum poslední inventury

AKTUAL

Date

pomocná položka

POZNAMKA

Memo

poznámka

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

DATHW

Date

datum zpracování HW

POCTXTHW

Integer

počet změnových TXT souborů HW

DATTXTHW

Date

datum TXT souboru HW

ZPRACOVAN

Logical

zda TXT soubor byl zpracován

NOVYHW

Logical

zda se jedná o nový HW

DATSW

Date

datum zpracování SW

POCTXTSW

Integer

počet změnových TXT souborů SW

DATTXTSW

Date

datum TXT souboru SW

POCNEURC

Integer

počet neurčených souborů SW

POCINST

Integer

počet nelegálního SW

POCLICEN

Integer

počet legálního SW

POCBEZLIC

Integer

počet SW bez licence

ZASUVKA

Charakter

20

číslo zásuvky (strukturovaná kabeláž)

PRIPOJ

Logical

přípojné místo

INS_PROT

Character

10

číslo instalačního protokolu

VYSKLAD

Date

datum instalačního protokolu

MAC_ADR

Character

12

MAC adresa

IP

Character

15

IP adresa

UCTOZARAD

Date

datum zařazení do účetnictví

UCTOVYRAD

Date

datum vyřazení z účetnictví

UCTOEXPORT

Integer

pořadí exportu do účetnictví

UCTOMAJET

Character

40

druh majetku

TYP_SERV1

Character

3

typ servisu

DAT_SERV1

Date

datum servisu

PRV_SERV1

Logical

příznak provedení servisu

TYP_SERV2

Character

3

typ servisu

DAT_SERV2

Date

datum servisu

PRV_SERV2

Logical

příznak provedení servisu

TYP_SERV3

Character

3

typ servisu

DAT_SERV3

Date

datum servisu

PRV_SERV3

Logical

příznak provedení servisu

TYP_SERV4

Character

3

typ servisu

DAT_SERV4

Date

datum servisu

PRV_SERV4

Logical

příznak provedení servisu

CISVOLNY

Character

30

číslo z volného číselníku

ROKVYR

Character

4

rok výroby

OPENPROJ

Character

230

název projektu PROOPEN

OPENID

Numeric

10,0

ID objektu v projektu PROOPEN

SWZPRAC

Logical

zda byl zpracován SW-SCAN

HWZPRAC

Logical

zda byl zpracován HW-SCAN

MODEL

Character

20

model počítače

VYROBCE

Character

20

výrobce počítače

DOMENA

Character

25

název domény

DOMENA_VZ

Character

25

vztah k doméně

NAZEVSOUB

Character

30

název souboru z HW, SW scanů

POMOC

Logical

pomocná položka

POMOC1

Logical

pomocná položka


Struktura souboru - Hw-scan

SPRÁVCE – Scan HW

HH_HARD.DBF – konfigurační soubor kapacit pevných disků

Název
Typ položky
Délka
Význam položky

MODEL

Character

20

Název disku

PRODUCT

Character

20

Název produktu disku

CAPACITY

Character

9

Kapacita disku

INTERFACE

Character

20

Interface

CACHE

Character

10

Cache

TRANSFER

Character

15

Transfer

I

Character

2

Pomocná položka

OTACKY

Character

8

Otáčky

TYP

Character

4

Typ disku IDE/SCSI

VERZE

Character

6

Verze programu Správce

HH_PCI.DBF – konfigurační soubor názvů PCI karet

Název
Typ položky
Délka
Význam položky

ID

Character

9

ID karty

NAZEV

Character

40

Název karty

NAZEV_PUV

Character

40

Původní název karty (autorská firma)

VERZE

Character

6

Verze programu Správce

HH_PROC.DBF – konfigurační soubor názvů procesorů

Název
Typ položky
Délka
Význam položky

ID

Character

3

ID procesoru

NAZEV

Character

29

Název procesoru

NAZEV_PUV

Character

29

Původní název procesoru

VYROBCE

Character

5

Výrobce procesoru Intel/Amd/Cyrix

VYROBCEID

Character

1

Pomocné ID výrobce

VERZE

Character

6

Verze programu Správce

HH_LOGHD.DBF – seznam logických disků

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

VELIKOST

Numeric

8

velikost disku

VOLNE

Numeric

8

volné místo na disku

POMOC

Logical

pomocná položka

DISK

Character

1

označení disku

SYSTEM

Character

10

file systém disku

PARAMETRY

Character

4

doplňující parametry disku

HH_ZMENY.DBF – změny v příslušenství

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

40

název

TYP

Character

4

typ příslušenství

TYPNAZ

Charakter

20

název typu příslušenství

OBLAST1

Character

30

oblast 1 příslušenství

IRQ

Character

2

IRQ

PORT

Character

10

port – adresa

NODE

Character

12

node adresa

NETWORK

Character

9

network adresa

VC

Character

40

výrobní číslo

IC

Character

20

inventární číslo

IP

Character

15

IP adresa

VOLNE1

Character

40

volná položka

VOLNE2

Character

40

volná položka

BUS

Character

10

BUS - pozice ID na SCSI

VYROBCE

Character

20

výrobce příslušenství

RUCNEPRIR

Logical

zda bylo PŘ přiřazeno ručně

POMOC

Logical

pomocná položka

HH_NEURC.DBF – příslušenství neurčené

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

40

název

TYP

Character

4

typ příslušenství

TYPNAZ

Charakter

20

název typu příslušenství

OBLAST1

Character

30

oblast 1 příslušenství

IRQ

Character

2

IRQ

PORT

Character

10

port – adresa

NODE

Character

12

node adresa

NETWORK

Character

9

network adresa

VC

Character

40

výrobní číslo

IC

Character

20

inventární číslo

IP

Character

15

IP adresa

VOLNE1

Character

40

volná položka

VOLNE2

Character

40

volná položka

BUS

Character

10

BUS - pozice ID na SCSI

VYROBCE

Character

20

výrobce příslušenství

VIRTUALNI

Logical

zda je PŘ skutečné nebo virtuální

POMOC

Logical

pomocná položka

HH_SLOTY.DBF – seznam slotů počítače

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

10

název slotu

SLOT

Character

20

označení slotu

USING

Charakter

20

zda je slot použit

NUMBER

Integer

pořadí slotu

NAPETI

Character

15

napětí

HH_KONEK.DBF – seznam konektorů počítače

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

20

název konektoru

KON_TYPE

Character

30

typ konektoru

INT_REF

Character

30

interface

PORT_TYPE

Character

30

typ portu


Struktury souboru - konfiguracni soubory

Struktury souborů – SPRÁVCE (konfigurační soubory)

PROTOKOL.DBF - text všech předávacích protokolů

Název

Typ položky

Délka

Význam položky

TXT_HW

Memo

text předávacího protokolu HW

TXT_SW

Memo

text předávacího protokolu SW

TXT_PR

Memo

text předávacího protokolu klasického PŘ

TXT_DO

Memo

text předávacího protokolu dokumentace

TXT_SIT

Memo

text předávacího protokolu sítě

TXT_PRLAN

Memo

text předávacího protokolu síťového PŘ

TXZ_PRVOL

Memo

text předávacího protokolu samost. PŘ

TXT_HWSL

Memo

text specifikačního list HW

SETUP.DBF - soubor pro generování evidenčních čísel

Název

Typ položky

Délka

Význam položky

SOUBOR

Character

8

datový soubor - hw, sw, ...

HODNOTA

Integer

poslední hodnota čísla

PRISTUPY.DBF - přístupová práva k programu

Název

Typ položky

Délka

Význam položky

JMENO

Character

8

jméno uživatele

HESLO

Character

8

heslo

HARDWARE

Logical

1

zápis do hardware

SOFTWARE

Logical

1

zápis do software

DOKUMENT

Logical

1

zápis do dokumentace

PRISLUSE

Logical

1

zápis do příslušenství

SITE

Logical

1

zápis do sítí

POZADAVKY

Logical

1

zápis do požadavků

HWSW

Logical

1

právo přiřadit SW na HW a opačně

CO

Logical

1

zápis do číselníku osob

CU

Logical

1

zápis do číselníku umístění

CG

Logical

1

zápis do číselníku org. členění

CZ

Logical

1

zápis do číselníku značek

CP

Logical

1

zápis do číselníku použití

CS

Logical

1

zápis do číselníku SW

CTH

Logical

1

zápis do číselníku systému HW

CB

Logical

1

zápis do číselníku oblastí

CV

Logical

1

zápis do číselníku výrobců

EU

Logical

1

zápis ekonomických údajů

FI

Logical

1

zápis do firem

PT

Logical

1

zápis do číselníku příslušenství typu

PN

Logical

1

zápis do číselníku příslušenství názvu

P1

Logical

1

zápis do číselníku příslušenství oblastí1

P2

Logical

1

zápis do číselníku příslušenství oblastí2

NADSTAV

Logical

1

přístup k modulu Nadstavba

ARCHIV

Logical

1

přístup k Archivaci dat

OBNOVA

Logical

1

přístup k Obnově dat

CTS

Logical

1

zápis do číselníku systému SW

UCTO

Logical

1

přístup k exportu do účetnictví

TYPPR

Logical

1

přístup ke změně typu příslušenství

CSRV

Logical

1

zápis do číselníku servisů

CX

Logical

1

zápis do číselníku volný

CAPLI

Logical

1

zápis do číselníku aplikací

PRIS_LAN

Logical

1

zápis do síťového příslušenství

PROS_VOL

Logical

1

zápis do samostatného příslušenství

C_DOKU

Logical

1

zápis do číselníku dokumentů

CLOKAL

Logical

1

zápis do číselníku lokalizací

ADMIN

Logical

1

admin. oprávnění definovat přístupy

KONFIG

Logical

1

přístup k menu Konfigurace

OSTATNI

Logical

1

přístup k menu Ostatní

UDRZBA

Logical

1

přístup k menu Údržba

SESTAVY

Logical

1

přístup k menu Sestavy

PROOPEN

Logical

1

přístup k volbě ProOpen

GRAFY

Logical

1

přístup k volbě Grafy

SWSCAN

Logical

1

přístup k menu SW-SCAN

HWSCAN

Logical

1

přístup k menu HW-SCAN

S_CO

Logical

1

přístup k číselníku osob

S_CU

Logical

1

přístup k číselníku umístění

S_CG

Logical

1

přístup k číselníku org. členění

S_CZ

Logical

1

přístup k číselníku značek

S_CP

Logical

1

přístup k číselníku použití

S_CS

Logical

1

přístup k číselníku SW

S_CTH

Logical

1

přístup k číselníku systému HW

S_CTS

Logical

1

přístup k číselníku systému SW

S_CB

Logical

1

přístup k číselníku oblastí

S_CV

Logical

1

přístup k číselníku výrobců

S_FI

Logical

1

přístup k firem

S_CPR

Logical

1

přístup k číselníku příslušenství

S_CSRV

Logical

1

přístup k číselníku servisů

S_CVOLNY

Logical

1

přístup k číselníku volný

S_CAPLI

Logical

1

přístup k číselníku aplikací

S_CDOKU

Logical

1

přístup k číselníku dokumentů

S_CLOKAL

Logical

1

přístup k číselníku lokalizací

S_HW

Logical

1

přístup k hardware

S_SW

Logical

1

přístup k software

S_PR

Logical

1

přístup k dokumentaci

S_DO

Logical

1

přístup k příslušenství

S_LAN

Logical

1

přístup k sítím

S_POZ

Logical

1

přístup k požadavkům

S_PRLAN

Logical

1

přístup k síťovému příslušenství

S_PRVOL

Logical

1

přístup k samostatnému příslušenství

SPUSTHW

Logical

1

přístup ke spuštění HW

SPUSTSW

Logical

1

přístup ke spuštění SW

PRISTVNC

Logical

1

přístup k VNC přístupu

PRISTFILE

Logical

1

přístup k souborovému manažeru

PRISFILLER

Logical

1

přístup k souborovému man.ke spuštění souborů

FORMULAR.DBF – nastavení vzhledu formulářů

Název

Typ položky

Délka

Význam položky

NAME

Character

20

jméno formuláře

UZIV

Character

10

jméno uživatele

WIDTH

Integer

1

šířka formuláře

HEIGHT

Integer

1

výška formuláře

LEFT

Integer

1

levý okraj formuláře

TOP

Integer

1

pravý okraj formuláře

RECNO

Character

60

pořadí věty

ORDER

Integer

1

pořadí třídění


Struktury souboru - Kspravce (data ze Spravce)

Struktury souborů – KSPRÁVCE (data ze SPRÁVCE)

Struktura souborů v podadresáři \OSTRA\DATA je skoro stejná jako u programu SPRÁVCE.

Výjimky :

· u hlavních datových souborů je navíc položka ZAVOD, která identifikuje, odkud data pocházejí.

· U některých souborů jsou vypuštěné položky, které nemají význam (pomocné položky nebo u hardware např. položky identifikující datum zpracování HW a SW scanu)


Struktury souboru - klasicke prislusenstvi

Struktury souborů - SPRÁVCE

PRISLUSE.DBF – příslušenství hardware

LIK_HARD.DBF – zlikvidované příslušenství hardware

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

evidenční číslo

NAZEV

Character

40

název

DODAVATEL

Character

30

dodavatel

SMLOUVA

Character

25

číslo smlouvy / číslo objednávky

DODAK

Character

15

číslo dodacího listu

DOKLADY

Character

40

umístění dokladu

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

DATUM

Date

datum zakoupení

UVEDENO

Date

datum uvedení do provozu

CENA

Currency

cena

ORG_CS

Character

8

číslo organizačního členění

MISTO_CS

Character

8

číslo umístění

OSOBA

Character

30

odpovědná osoba

TYP

Character

4

typ příslušenství

TYPNAZ

Charakter

20

název typu příslušenství

OBLAST1

Character

30

oblast 1 příslušenství

OBLAST2

Character

30

oblast 2 příslušenství

PRIRAD

Character

8

vazba na hardware (číslo počítače)

SITE

Character

8

číslo sítě

STAV

Integer

aktuální stav příslušenství

IRQ

Character

30

IRQ

PORT

Character

30

port – adresa

NODE

Character

30

node adresa

NETWORK

Character

30

network adresa

IP

Character

30

IP adresa

IC

Character

20

inventární číslo

VC

Character

40

výrobní číslo

SC

Character

30

specifické číslo

ZARUKA

Date

datum záruky

ZAR_TYP

Integer

typ záruky (1=měsíce, 2=datum)

ZAR_MES

Integer

záruka v měsících

ODPIS

Date

datum odpisu

INVENTURA

Date

datum poslední inventury

AKTUAL

Date

datum poslední aktualizace

POZNAMKA

Memo

poznámka

SOUCAST_PC

Logical

součást PC při nákupu

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

VOLNE1

Character

40

volná položka

VOLNE2

Character

40

volná položka

BUS

Character

10

BUS - pozice ID na SCSI

PRIPOJ

Logical

přípojné místo

INTER

Logical

interní příslušenství

INTEG

Logical

integrované příslušenství

SERVIS

Logical

servisní příslušenství

NAD_PRIS

Charakter

8

číslo nadřízeného příslušenství

HWSCAN

Logical

1

zda bylo zpracováno HW-SCANem

INS_PROT

Character

10

číslo instalačního protokolu

VYSKLAD

Date

datum instalačního protokolu

UCTOZARAD

Date

datum zařazení do účetnictví

UCTOVYRAD

Date

datum vyřazení z účetnictví

UCTOEXPORT

Integer

pořadí exportu do účetnictví

UCTOMAJET

Character

40

druh majetku

TYP_SERV1

Character

3

typ servisu

DAT_SERV1

Date

datum servisu

PRV_SERV1

Logical

příznak provedení servisu

TYP_SERV2

Character

3

typ servisu

DAT_SERV2

Date

datum servisu

PRV_SERV2

Logical

příznak provedení servisu

TYP_SERV3

Character

3

typ servisu

DAT_SERV3

Date

datum servisu

PRV_SERV3

Logical

příznak provedení servisu

TYP_SERV4

Character

3

typ servisu

DAT_SERV4

Date

datum servisu

PRV_SERV4

Logical

příznak provedení servisu

CISVOLNY

Character

30

číslo z volného číselníku

ROKVYR

Character

4

rok výroby

HH_NAZEV

Character

40

původní název PŘ ze scanu

HH_OBLAST1

Character

30

původní oblast1 PŘ ze scanu

HH_VC

Character

40

původní VC PŘ ze scanu

HH_NODE

Character

12

původní NODE PŘ ze scanu

HH_NETWORK

Character

9

původní NETWORK PŘ ze scanu

VYROBCE

Character

20

výrobce příslušenství

POMOC

Logical

pomocná položka

POMOC1

Logical

pomocná položka


Struktury souboru - programove soubory

Struktury souborů – SPRÁVCE (programové soubory)

Název souboru | Význam souboru
SPRAVCE8.EXE | hlavní program
CONFIG.FPW | konfigurační soubor Visual FoxPro
TISKRESO.* | soubory Visual FoxPro
CREADBC.KRT | podprogram
FOXRUN.PIF | soubor Visual FoxPro
MAZCREATE.EXE | pomocný program
SESTAVY.EXE | podprogram
DESIFR.DLL | pomocná knihovna
QXPACK.DLL | pomocná knihovna
VFP8*.* | Runtime modul VFP 87.0
FOXHELP8*.* | Knihovny pro fungování helpu
*.DLL | Podpůrné knihovny
\HLP\*.* | Help, změny
\OCX\*.OCX | podpůrné programy OCX


Struktury souboru - site

Struktury souborů - SPRÁVCE

SITE.DBF – seznam sítí

LIK_SITE – seznam zlikvidovaných sítí

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

evidenční číslo

NAZEV

Character

30

název

VERZE

Character

10

verze síťového operačního systému

DODAVATEL

Character

30

dodavatel

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

DODAK

Character

15

číslo dodacího listu

SMLOUVA

Character

25

číslo smlouvy / číslo objednávky

DOKLADY

Character

40

umístění dokladu

DATUM

Date

datum zakoupení

UVEDENO

Date

datum uvedení do provozu

CENA

Currency

cena

ORG_CS

Character

8

číslo organizačního členění

MISTO_CS

Character

8

číslo umístění

STAV

Integer

aktuální stav sítě 0-9

SPRAVCE

Character

30

správce sítě

OSOBA

Character

30

odpovědná osoba za sít

LICEN

Character

30

licenční číslo

SC

Character

30

specifické číslo

SITE_TYP

Character

typ sítě - etherlink, peer-to-peer, apod.

UZIV

Integer

počet uživatelů

STANICE

Integer

počet připojených počítačů

KABELAZ

Character

70

typ kabeláže

INS_DAT

Date

datum instalace sítě

ZARUKA

Date

datum záruky

ZAR_TYP

Integer

typ záruky (1=měsíce, 2=datum)

ZAR_MES

Integer

záruka v měsících

ODPIS

Date

datum odpisu

INVENTURA

Date

datum poslední inventury

AKTUAL

Date

datum poslední aktualizace

AKTUAL_NAM

Character

8

jméno uživatele, který naposledy aktualizoval

POZNAMKA

Memo

poznámka

TYP_SERV1

Character

3

typ servisu

DAT_SERV1

Date

datum servisu

PRV_SERV1

Logical

příznak provedení servisu

TYP_SERV2

Character

3

typ servisu

DAT_SERV2

Date

datum servisu

PRV_SERV2

Logical

příznak provedení servisu

TYP_SERV3

Character

3

typ servisu

DAT_SERV3

Date

datum servisu

PRV_SERV3

Logical

příznak provedení servisu

TYP_SERV4

Character

3

typ servisu

DAT_SERV4

Date

datum servisu

PRV_SERV4

Logical

příznak provedení servisu

CISVOLNY

Character

30

číslo z volného číselníku

OPENPROJ

Character

230

název projektu PROOPEN

OPENID

Numeric

10,0

ID objektu v projektu PROOPEN

POMOC

Logical

1

pomocná položka

POMOC1

Logical

1

pomocná položka


Struktury souboru - software

Struktury souborů - SPRÁVCE

SOFTWARE.DBF – seznam licencí software

LIK_SOFT.DBF – seznam zlikvidovaných licencí

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

evidenční číslo

NAZEV

Character

50

název SW

VERZE

Character

10

verze SW

BALIK_NAZ

Character

30

název balíku

DODAVATEL

Character

30

dodavatel

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

SMLOUVA

Character

25

číslo smlouvy / číslo objednávky

DODAK

Character

15

číslo dodacího listu

DOKLADY

Character

40

umístění dokladů - správce, účtárna

STAV

Integer

aktuální stav software 0-8

UVEDENO

Date

datum uvedení do provozu

DATUM

Date

datum zakoupení

CENA

Currency

cena celkem

CENAKS

Currency

cena za 1 kus

LICEN

Character

30

licenční číslo

SC

Character

20

specifické číslo

IC

Character

20

inventární číslo

LIC_NAKUP

Character

15

forma nákupu (krabice, MOLP)

LIC_MINUS

Logical

možnost čerpání licencí do záporna

LIC_TYP

Character

15

typ instalace SW (FULL, OEM, …)

LIC_DOBA

Date

časové omezení licence

LIC_UZIV

Character

25

typ multilicence

LIC_PRAC

Integer

počet současně pracujících uživ.

LIC_ZARIZ

Character

7

číslo a typ zařízení OEM

OMEZENI

Character

30

omezení multilicence

OEM

Character

8

číslo HW nebo PR k OEM verzi

OEMPUVOD

Charakter

50

původní číslo OEM zařízení

DOWNGRADE

Logical

povolení DownGrade

DOWN_POZN

Character

70

seznam SW pro DownGrade

JAZYK

Character

30

programovací jazyk

PRISLUS

Character

50

příslušenství

OSOBA

Character

30

odpovědná osoba

MULTILIC

Logical

multilicence

PC_PUVOD

Integer

celkový počet licencí

PC_DODANO

Integer

dodané licence k dispozici

PC_INST

Integer

počet instalovaných licencí

PC_VOLNE

Integer

počet volných licencí

PC_ZBYVA

Integer

pomocná položka

PC_PREVOD

Integer

počet převedených licencí

UPG_KS1

Integer

počet, ze kterých byl proveden upgr.

UPG_KS2

Integer

počet, na které byl proveden upgrade

UPG_KOD

Character

5

pomocná položka pro UPGRADE

INVENTURA

Date

datum poslední inventury

ZARUKA

Date

datum záruky

ZAR_TYP

Integer

typ záruky (1=měsíce, 2=datum)

ZAR_MES

Integer

záruka v měsících

ODPIS

Date

datum odpisu

SIT_SOFT

Logical

sítový software A/N

POZNAMKA

Memo

poznámka

SW_LOKAL

Character

2

lokalizace SW

SW_LOKAL2

Character

30

lokalizace SW

SW_SYS

Character

40

operační systém

AKTUAL

Date

datum poslední aktualizace

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

BASELICEN

Character

30

číslo materské licence

MEDIA

Character

20

typ médií DISKEM CD-ROM

UCTOZARAD

Date

datum zařazení do účetnictví

UCTOVYRAD

Date

datum vyřazení z účetnictví

UCTOEXPORT

Integer

poradí exportu do účetnictví

UCTOMAJET

Character

40

druh majetku

TYP_SERV1

Character

3

typ servisu

DAT_SERV1

Date

datum servisu

PRV_SERV1

Logical

příznak provedení servisu

TYP_SERV2

Character

3

typ servisu

DAT_SERV2

Date

datum servisu

PRV_SERV2

Logical

příznak provedení servisu

TYP_SERV3

Character

3

typ servisu

DAT_SERV3

Date

datum servisu

PRV_SERV3

Logical

příznak provedení servisu

TYP_SERV4

Character

3

typ servisu

DAT_SERV4

Date

datum servisu

PRV_SERV4

Logical

příznak provedení servisu

CISVOLNY

Character

30

čslo z volného číselníku

POMOC

Logical

pomocná položka

POMOC1

Logical

pomocná položka

NPOMINST

Integer

pomocná položka


Struktura souboru - Swscan

SPRÁVCE – Scan SW

SW_LIST.DBF - soubor centrálních vzorů

SW_DOCAS.DBF - soubor dočasných vzorů (jen pro multilicence)

Název
Typ položky
Délka
Význam položky

SOUBOR

Character

30

jméno souboru

CESTA

Character

100

cesta k souboru

VELIKOST

Integer

velikost souboru

DATUM

Date

datum

CAS

Character

8

čas

NAZEV

Character

50

název software

VERZE

Character

10

verze software

ID

Character

8

pomocná položka

HLAVNI_SOU

Logical

zda má software hlavní modul

ZAPIS

Logical

zda soubor mění datum, čas

SDILEN

Logical

zda je soubor sdílen více aplikacemi

VYRID

Logical

zda je vzor firemní (jen u SW_LIST.DBF)

VYROBCE

Character

60

výrobce z hlavičky EXE souboru

PRODUKT

Character

60

název programu z hlavičky EXE souboru

VERZE_PROD

Character

20

verze programu z hlavičky EXE souboru

POPIS

Character

60

stručný popis z hlavičky EXE souboru

NOVA

Logical

Pomocná položka

POMOC

Logical

Pomocná položka

SW_REG.DBF - soubor software v registrech

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

Číslo počítače

NAZEV

Character

150

Název software v registrech

POMOC

Logical

1

Pomocná položka

SW_NALEZ.DBF - soubor Nelegálních instalací SW

SW_LICSW.DBF – soubor legálních licencí SW

SW_BEZLI.DBF – soubor instalací Bez licence

SW_DOCSW.DBF – soubor dočasného SW

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

DATUM

Date

datum instalace

SW_LOKAL

Character

2

lokalizace SW

POCSOUBORU

Integer

počet souborů

COUNTINS

Integer

pomocná položka

MAEXE

Logical

zda má software hlavní modul

KS

Integer

počet kusů při tvorbě licence

POMOC

Logical

pomocná položka

PRIRAD

Logical

pomocná položka

CISLOLIC

Character

8

evidenční číslo SW (licence)

DRUHSW

Integer

určuje druh SW

SP

Character

4

service pack

OS

Logical

operační systém

SW_NEURC.DBF - soubor Neurčených souborů

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

Číslo počítače

SOUBOR

Character

30

Název souboru

CESTA

Character

100

Cesta

VELIKOST

Integer

Velikost souboru

DATUM

Date

Datum

CAS

Character

8

Čas

DAT_INST

Date

Datum instalace

SDILEN

Logical

Zda je soubor sdílen více aplikacemi

VYROBCE

Character

60

Výrobce produktu (programu) z hlavičky EXE souboru

PRODUKT

Character

60

Název produktu (programu) z hlavičky EXE souboru

VERZE_PROD

Character

20

Verze produktu (programu) z hlavičky EXE souboru

POPIS

Character

60

Stručný popis souboru produktu z hlavičky EXE souboru

POMOC

Logical

Pomocná položka

SW_ZRUS.DBF - soubor nalezených souborů označených ke zrušení

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

Číslo počítače

SOUBOR

Character

30

Název souboru

CESTA

Character

100

Cesta

VELIKOST

Integer

Velikost souboru

DATUM

Date

Datum

CAS

Character

8

Čas

DAT_INST

Date

Datum instalace

SDILEN

Logical

Zda je soubor sdílen více aplikacemi

VERZE_PROD

Character

20

Verze produktu (programu) z hlavičky EXE souboru

SMAZAT

Logical

zda soubor bude automaticky smazán

RUCNE

Logical

zda bude smazán ručně

POMOC

Logical

Pomocná položka

SW_SOUB.DBF - soubor nalezených souborů pro ostré vzory

SW_DSOUB.DBF - soubor nalezených souborů pro dočasné vzory

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

SOUBOR

Character

30

název souboru

CESTA

Character

50

cesta

VELIKOST

Integer

velikost souboru

DATUM

Date

datum

CAS

Character

8

čas

POMOC

Logical

pomocná položka

VERZE_PROD

Character

20

verze produktu (programu) z hlavičky EXE souboru

CISLOLIC

Character

8

číslo licence (jen u SW_SOUB.DBF)

SW_PORSW.DBF - soubor pro porovnání SW proti minulému zpracování

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

SW_LOKAL

Character

lokalizace SW

SP

Character

service pack

DATUM

Date

datum zpracování

POMOC

Logical

pomocná položka

ZMENA

Character

1

druh změny (+/-)

KARTA

Numeric

1

pořadí karty

DRUHSW

Character

1

druh software (licenční, aplikační, …)

SW_PORSO.DBF - soubor porovnání Neurčených souborů proti minulému zpracování

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

SOUBOR

Character

30

jméno souboru

CESTA

Character

100

cesta k souboru

VELIKOST

Integer

velikost souboru

DATUM

Date

datum

CAS

Character

8

čas

VYROBCE

Character

60

výrobce produktu (programu) z hlavičky EXE souboru

PRODUKT

Character

60

název produktu (programu) z hlavičky EXE souboru

VERZE_PROD

Character

20

verze produktu (programu) z hlavičky EXE souboru

POPIS

Character

60

stručný popis souboru produktu z hlavičky EXE souboru

ZMENA

Character

1

druh změny (+/-)

KARTA

Numeric

1

pořadí karty

POMOC

Logical

pomocná položka

SW_NEVED.DBF - soubor Nevedených instalací

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

DATUM

Date

datum zpracování

SW_LOKAL

Character

2

lokalizace SW

POCSOUBORU

Integer

počet nalezených souborů

COUNTINS

Integer

počet souborů ve vzoru

MAEXE

Logical

zda má hlavní modul

KS

Integer

počet kusů

POMOC

Logical

pomocná položka

PRIRAD

Logical

pomocná položka

CISLOLIC

Character

8

číslo licence SW

DRUHSW

Integer

4

pruh software (licenční, aplikační, …)

SP

Character

4

service pack

OS

Logical

pomocná položka

SW_NSOUB.DBF - soubor Nevedených instalací SW (jednotlivé soubory)

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

SOUBOR

Character

30

jméno souboru

CESTA

Character

50

cesta k souboru

VELIKOST

Integer

velikost souboru

DATUM

Date

Datum

CAS

Character

8

Čas

POMOC

Logical

pomocná položka

VERZE_PROD

Character

20

verze produktu (programu) z hlavičky EXE souboru

SW_BALIK.DBF – soubor SW balíků (např. MS Office)

Název
Typ položky
Délka
Význam položky

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

VYRID

Logical

zda byl balík pořízen dodavatelskou firmou

POMOC

Logical

pomocná položka

ID

Integer

vazba na soubor SW_MODUL

SW_MODUL.DBF - soubor jednotlivých modulů SW balíků (např. MS Word)

Název
Typ položky
Délka
Význam položky

NAZEV

Character

50

název modulu

VERZE

Character

10

verze modulu

MAINFILE

Character

30

hlavní soubor modulu

REGISTRMOD

Character

100

zápis modulu v registrech

REGISTRBAL

Character

100

zápis balíku v registrech

SDILEN

Logical

sdílení

VYRID

Logical

zda byl modul pořízen dodavatelskou firmou

POMOC

Logical

pomocná položka

ID

Integer

vazba ze souboru SW_BALIK

SW_PRIP.DBF - soubor nascanovaných libovolných přípon (např. SYS, BAT, DOC, XLS)

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

SOUBOR

Character

30

název souboru

PRIPONA

Character

10

název přípony

CESTA

Character

100

cesta k souboru

VELIKOST

Integer

velikost souboru

DATUM

Date

datum souboru

CAS

Character

8

čas souboru

VERZE_PROD

Character

20

verze produktu (programu) z hlavičky EXE souboru

POMOC

Logical

pomocná položka

SW_ARCH.DBF - soubor archivních instalací

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

Číslo počítače

SOUBOR

Character

30

Název souboru

CESTA

Character

100

Cesta

VELIKOST

Integer

Velikost souboru

DATUM

Date

Datum

CAS

Character

8

Čas

DAT_INST

Date

Datum instalace

SDILEN

Logical

Zda je soubor sdílen více aplikacemi

VERZE_PROD

Character

20

Verze produktu (programu) z hlavičky EXE souboru

POMOC

Logical

Pomocná položka

SW_CISSW.DBF – soubor pro porovnání

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název balíku

SW_LOKAL

Character

2

lokalizace SW

SP

Character

4

service pack

DATUM

Date

datum instalace

POCSOUBORU

Integer

počet souborů

COUNTINS

Integer

pomocná položka

POMOC

Logical

pomocná položka

KARTA

Numeric

1

pořadí karty

DRUHSW

Integer

určuje druh SW

SW_CISSO.DBF - soubor pro porovnání

Název
Typ položky
Délka
Význam položky

CISLO

Character

8

číslo počítače

SOUBOR

Character

30

jméno souboru

CESTA

Character

100

cesta k souboru

VELIKOST

Integer

velikost souboru

DATUM

Date

datum

CAS

Character

8

čas

VYROBCE

Character

60

výrobce produktu (programu) z hlavičky EXE souboru

PRODUKT

Character

60

název produktu (programu) z hlavičky EXE souboru

VERZE_PROD

Character

20

verze produktu (programu) z hlavičky EXE souboru

POPIS

Character

60

stručný popis souboru produktu z hlavičky EXE souboru

KARTA

Numeric

1

pořadí karty

POMOC

Logical

pomocná položka

SW_SABLO.DBF – uložené šablony

Název
Typ položky
Délka
Význam položky

NAZEV

Character

30

Název šablony

POMOC

Logical

pomocná položka

SW_SABSW.DBF – přiřazený sw k šablonám

Název
Typ položky
Délka
Význam položky

NAZEV

Character

30

Název šablony

SOFTWARE

Character

8

Evidenční číslo software

POMOC

Logical

pomocná položka


Struktury souboru - vazebni soubory

Struktury souborů – SPRÁVCE (vazby)

DOK_HW.DBF - vazba přiřazené dokumentace na hardware

DOK_SW.DBF - vazba přiřazené dokumentace na software

DOK_PR.DBF - vazba přiřazené dokumentace na příslušenství hardware

DOK_PRL.DBF - vazba přiřazené dokumentace na síťovou techniku

DOK_PRV.DBF - vazba přiřazené dokumentace na ostatní techniku

DOK_LN.DBF - vazba přiřazené dokumentace na síť

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

číslo dokumentace

NAZEV

Character

50

název dokumentace

VAZBA

Character

8

číslo vazby hw, sw, př, lan

VAZBANAZEV

Character

71

název vazby

KUSY

Integer

počet přiřazených kusů

POMOC

Logical

pomocná položka

SOFT_PRI.DBF - vazba nainstalovaného software

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

číslo hardware

SOFTWARE

Character

8

číslo software

SOF_NAZEV

Character

50

název software

VERZE

Character

10

verze software

BALIK_NAZ

Character

30

název SW balíku, do kterého je SW zařazen

ORG_CS

Character

8

číslo organizačního členění

MISTO_CS

Character

8

číslo umístění

OSOBA

Character

30

odpovědná osoba

INST

Integer

počet instalací

DATUM

Date

datum instalace

NASEL

Logical

pomocná položka pro zpracování Swscanem

AKT_VERZE

Logical

označení poslední verze SW

DOWNGRADE

Logical

povolení DownGrade

DOWN_NAZEV

Character

50

název zakoupené licence (DownGrade)

DOWN_VERZE

Character

10

verze zakoupené licence (DownGrade)

DOWN_BALIK

Character

30

balík zakoupené licence (DownGrade)

SW_LOKAL

Character

2

lokalizace SW

SP

Character

4

service pack

IDCISLO

Character

10

pomocná položka

PARENT

Character

10

pomocná položka

POMOC

Logical

pomocná položka

OPR_HW.DBF - soubor oprav hardware

OPR_SW.DBF - soubor oprav software

OPR_PR.DBF - soubor oprav příslušenství hardware

OPR_PL.DBF - soubor oprav síťové techniky

OPR_PV.DBF - soubor oprav ostatní techniky

OPR_LN.DBF - soubor oprav sítí

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

číslo hardware, software, příslušenství, sítě

DATUM

Date

datum začátku opravy

DODAVATEL

Character

30

dodavatelská firma

OSOBA

Character

30

odpovědná osoba

UKONCENI

Date

ukončení opravy

PORUCHA

Memo

popis odstranění opravy

STAV

Integer

4

stav opravy

TYP_SERVC

Character

3

typ servisu pro STAV = 5

DNY_OPR

Integer

počet dnů opravy

DNY_ZAR

Integer

počet dnů prodloužení záruky

CENA

Currency

cena opravy

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo faktury

CISPROT

Integer

revize – číslo protokolu

VYPR

Logical

revize – výsledek prohlídky

VYZK

Logical

revize – výsledek zkoušky

VYCELK

Logical

revize – výsledek celkem

SEST

Character

1

revize – sestava přístroje

DELKA

Currency

revize – délka síťového přívodu

OCHRODP

Currency

revize – odpor ochranného vodiče

MPOCHRO

Character

10

revize – měřící přístroj ochranného vodiče

CMPOCHRO

Character

20

revize – číslo měřícího přístroje ochr. vodiče

IZODP

Currency

revize – izolační odpor

MPIZO

Character

10

revize – měřící přístroj izolačního odporu

CMPIZO

Character

20

revize – číslo měřícího přístroje izol. odporu

POCHVP

Currency

revize – měření proudu prot. ochr. vodičem

POCHVR

Currency

revize – měření proudu prot. ochr. vodičem

DOTPP

Currency

revize – měření dotykového proudu

DOTPR

Currency

revize – měření dotykového proudu

UNPROUD

Currency

8

revize – měření unikajícího proud

MPUNP

Character

10

revize – měřící přístroj unikajícího proudu

CMPUNP

Character

20

revize – číslo měřícího přístroje unik. proudu

UCTODUVLIK

Character

30

důvod likvidace

ZAR_TYP

Integer

typ záruky

ZAR_MES

Integer

počet měsíců záruky

ZARUKA

Date

datum záruky

AKTUAL_NAM

Character

8

jméno aktualiz. uživatele

AKTUAL

Date

8

datum aktualizace

AKTUAL_ZP

Character

2

způsob aktualizace

POMOC

Logical

pomocná položka

UPGRADE.DBF - pomocný soubor pro vytváření upgrade SW

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

aktuální číslo SW

KS

Integer

počet kusů instalací, na které byl proveden upgrade

KOD

Character

5

vazební položka na soubor SOFTWARE

PORADI

Integer

pořadí upgrade

POMOC

Logical

pomocná položka

LICENCE.DBF – soubor dokoupených licencí

Název

Typ položky
Délka

Význam položky

CISLO

Character

8

evid. číslo SW

LICEN

Character

30

licenční číslo

FAKTURA

Character

20

číslo faktury

INTER_FA

Character

20

interní číslo FA

DODAVATEL

Character

30

dodavatel

KUSY

Integer

počet dokoupených licencí

DATUM

Date

datum dokoupení licencí

CENA

Currency

Cena

CENA_KS

Currency

cena za 1 ks dokoupené licence

PRVNI

Logical

pomocná položka – první nákup

POMOC

Logical

pomocná položka

SIT_HESL.DBF - soubor hesel uživatelů sítí

Název

Typ položky
Délka

Význam položky

OSOBA

Character

30

příjmení a jméno uživatele

JMENO

Character

30

login jméno uživatele

HESLO

Character

10

heslo

SIT

Character

8

číslo sítě

APLI_PRI.DBF - soubor přístupů k aplikacím

Název

Typ položky
Délka

Význam položky

OSOBA

Character

30

příjmení a jméno uživatele

UZIVATEL

Character

10

login jméno uživatele pro přihlášení do aplikace

HESLO

Character

10

heslo

APLIKACE

Character

50

název aplikace

DATUM

Date

datum změny uživatele nebo hesla

PRISTUP

Charakter

30

typ přístupu

POZNAMKA

Charakter

90

poznámka

POMOC

Logical

pomocná položka

DOKUSCAN.DBF – seznam přiřazených elektr. dokumentů

Název

Typ položky

Délka

Význam položky

CISLO

Character

8

číslo hw, sw, př, lan, …

DRUH

Character

2

druh evidence (HW, SW, …)

TYP

Character

30

typ dokumentu

POMOC

Logical

pomocná položka

SOUBOR

Character

20

název souboru

POZNAMKA

Character

50

Poznámka

ADRESAR

Character

100

Podadresář se soubory


Zpracovani Sw-scanu - novy modul SW baliku

Scan SW – Podadresář pro přesun souborů

Formulář slouží k zadávání a opravě podadresářů. Tyto podadresáře slouží k automatickému přesunu souborů na kartu Zrušené nebo kartu Archiv. Při zpracování počítače se tyto adresáře a všechny jejich podadresáře prochází a soubory se přesouvají na uvedenou kartu. To vše se provede na začátku zpracování, takže tyto podadresáře jsou vlastně vyřazeny ze zpracování. U každého podadresáře lze určit, zda se bude brát název adresáře odkudkoliv ve stromové struktuře nebo jen od root adresáře.

Příklad pro adresář \TEMP :

a) pokud bude podadresář označen jako Od rootu, budou přesunuty soubory např. z následujících adresářů :

C:\TEMP

D:\TEMP

Název adresáře musí být přímo v root adresáři (nalevo nesmí být žádný nadřízený adresář).

b) pokud nebude označen jako Od rootu, budou přesunuty soubory např. z následujících adresářů :

C:\WINDOWS\TEMP

D:\POKUS\TEMP

E:\TEMP apod.

Název adresáře může být kdekoliv ve stromové struktuře

Na kartu Zrušené přesuňte soubory jenž chcete zrušit, na kartu Archiv soubory, které tam chcete ponechat (např. archivní, pomocné nebo instalační).

Na počátku podadresáře nesmíte zadávat označení disku !!!

Pokud jednou označené podadresáře pro přesun na karty Zrušené a Archiv zrušíte, budou při následujícím zpracování soubory z těchto karet smazány a vráceny do zpracování.


Zpracovani Sw-scanu - hledani

Scan Sw – hledání

Tento formulář slouží k vyhledání požadovaného údaje. Nejdříve musíte určit setřídění souboru. Program nabízí seznam všech položek, které mají vytvořený index. Po zadání třídění, musíte zadat hledaný řetězec a potvrdit tlačítkem OK. Pokud se zadaný řetězec nalezne, program nastaví kursor na danou větu. Nenajde-li se tento řetězec, program na to upozorní a zůstane na původní větě.

POZOR -

datumové položky - je nutné je zadávat ve tvaru DD.MM.RRRR (např. 23.05.1998)

logické položky - je nutné je zadávat ve tvaru .F. (.f.) nebo .T. (.t.)


Zpracovani Sw-scanu - zobrazeni instalaci

Scan SW – zobrazení instalací

Tento formulář slouží pouze k zobrazení všech instalací daného počítače. Program zobrazuje jednotlivé karty podle typu instalace a neumožňuje žádnou aktualizaci. Slouží pouze k nahlédnutí a rychlému zjištění, co je na vybraném počítače nainstalováno.


Zpracovani Sw-scanu - vypis z registru

Scan SW – Šablony

Formulář obsahuje seznam vytvořených šablon. Vrchní mřížka obsahuje názvy šablon a spodní mřížka seznam multilicencí, které šablonu tvoří. Jako šablonu lze použít pouze multilicence, které mají povoleno čerpání do záporna.

Při aplikaci šablony na jednotlivé počítače se z těchto multilicencí přiřadí k daným počítačům licence (pokud již licence stejného názvu a verze na daném PC není).


Zpracovani Sw-scanu - seznam licenci

Scan SW – seznam licencí

Mřížka zobrazuje seznam počítačů, na kterých je vybraná licence (její název je nad mřížkou) již nainstalovaná. Je to pro případ, že potřebujete vědět, kde všude je již tato licence použita.

Pokud při prohlížení seznamu instalací zjistíte, že by jste potřebovali licenci z nějakého počítače odinstalovat, lze to provést přes pravé tlačítko myši spuštěním volby Odřadit. Tím se licence uvolní k použití na jiný počítač.


Zpracovani Sw-scanu - porovnani (cisty stav)

Scan SW – Porovnání (zobrazení čistého stavu)

Tento formulář slouží pouze k zobrazení uloženého čistého stavu počítače.


Zpracovani Sw-scanu - tvorba licence

SW Audit – vytvoření licence SW

Jednou z nejdůležitější částí SW auditu je vytvoření licencí legálního software a jejich přiřazení na správný počítač. Toto lze provést v několika místech. Následující popis Vám má pomoci se rozhodnout kdy a kde licenci vytvoříte :

1) Licence lze vytvářet ještě před spuštěním zpracování SW-SCANu. Lze to provést :

a. V Evidenci hardware na kartě Vazby SW. Tento způsob je vhodný pouze pro single instalace, a to v případě, že kompletně editujete údaje nějakého počítače a stoprocentně víte, jakou instalaci software na něj chcete přiřadit. Ihned po vytvoření licence se Vás program zeptá, zda ji chcete přiřadit na aktuální počítač. Takže stačí stisknout Ano a máte vytvořenou a zároveň přiřazenou licenci

b. V Evidenci licencí software na kartě Seznam. Zde můžete vytvářet licence pro jakékoliv typy instalací software. Z praktického hlediska je výhodné tento způsob použít pro multilicence. Zde je postup následující : vytvoříte licenci nějakého software. Přepnete se na kartu Vazby HW, kde pomocí volby Volný hardware spustíte formulář, který Vám nabídne seznam volných počítačů a Vy hromadně přiřadíte tuto multilicenci najednou na vybrané počítače.

Způsob vytvoření licence před spuštěním zpracování scanu je obecně výhodnější pouze pro multilicence a občasné vytvoření konkrétní instalace.

Pozor – tento způsob by měl znamenat ulehčení práce proti pořízení licencí až po zpracování SW-SCANu. Předpokladem tohoto ulehčení však je, že zadáte správně název a verzi software. Pokud tyto údaje zadáte špatně a SW-SCAN najde úplně něco jiného, budete muset špatně zadanou licenci odřazovat nebo opravovat apod. Takže pokud se rozhodnete licence vytvářet předem, seznamte se dobře s názvoslovím software, aby jste si práci nepřidělali.

2) Licence lze vytvářet po spuštění zpracování Scanu SW. Principem je, že spustíte volbu Zpracování Scanu SW. Zde označíte jeden vzorový počítač a provedete jeho zpracování. Po jeho zpracování najdete na kartě Nelegální software, z něhož chcete vytvořit licenci. Pomocí volby Karta Licence vytvoříte jeho legální licenci. Pokud je to single instalace, tak je to všechno a můžete pokračovat dalším softwarem nebo dalším počítačem.

Je-li to multilicence, zbývá Vám ji přiřadit na další počítače. Tady máte několik možností :

a. opustit zpracování scanu SW a vrátit se do Evidence licencí software a postupovat jako v bodě 1b). Tento způsob je méně praktický, protože musíte zavřít formuláře zpracování, otevřít evidenci, najít software atd. Následující způsob b) je praktičtější.

b. spustíte zpracování na všechny ostatní počítače. Po jejich zpracování se nastavíte kursorem na počítač (musíte si jej zapamatovat), na němž jste vytvořili danou multilicenci a přepnete se na kartu Licence. Zde najdete volbu Karta licence – všechna PC, která Vám spustí seznam počítačů a vy si vyberete ty, na které chcete licenci přiřadit. Pozor – program nabízí skutečně jen ty počítače, na kterých se daný software po zpracování nalezl na kartě Nelegální. To znamená, že pokud jste některý počítač nezpracovali nebo na něm není uvedená multilicence nainstalována, pak v tomto seznamu chybí.

c. U tohoto způsobu nemusíte zpracovávat žádný vzorový počítač. Prostě spustíte zpracování na všechny ostatní počítače. Po jejich zpracování najdete v dolní části formuláře Hrom. Licence, které Vám zobrazí seznam všech nelegálních instalací na všech počítačích a umožní Vám hromadné vytvoření a přiřazení licencí (může se jednat jak o single, tak i o multilicence.