
What is Power File
Power File is a power replacement for the Explorer program that comes with Windows.    In Addition to the
file management tools that comes with Windows Explorer, Power File gives you.    

· Stand alone copy, move and delete functions with browse options.

· Optional horizontal or vertical dual display.

· Configurable tool bar with configurable hot keys.

· Configurable single drive display, like the old Windows file manager

· Completely integrated FTP client.    Transfers files, changes permissions, renames and deletes 
files on ftp servers.

· File Preview Pane

· Listings for files on multiple drives and directories.

· Printing of file and directory listings.

· Complex filter sets using multiple file specifications, date, time and size.

· Directory synchronization.

· File encryption.

· File compare.

· Associating a file type with more than one application.

· Optional display of directory tree sizes

· Modifying file dates and times.

· Launch bars and app bars.

· DOS command line.

· Automatic sending of email attachments

Power File Gold
Power File Gold is a special version of Power File that in addition to Power File contains a specially 
integrated version of our Zip file manager Drag And Zip.
When you are running Power File Gold, ZIP, LZH, TAR, GZ, CAB    and more types of archives will appear
as folders on the directory tree.    When you highlight one of these folders, the contents of these folders 
will appear in the file window.    You can treat these file listings just like they were regular files.    You can 
select them and copy, view, move, and delete them.    The file will be extracted from the archive 
automatically and the operation will happen just like with regular files.
To create a Zip file all you have to do is select the files that you want to Zip and click on the Zip button.    
Drag And Zip will come up and you can make the Zip file.



Running Power File 
When you run Power File the program comes up giving you a listing of your available drives on the left 
hand side and showing the files in the highlighted directory on the right.    Kind of like Windows Explorer.

Power File Main Window

Unlike Explorer you see a toolbar with your available drives. You can click on one of these drive buttons 
and immediately go to that drive.    The left hand drive display by default gives the Explorer view of the 
Desktop and all the available drives.    However, from the Options menu, you can configure Power File so 
that it only displays one drive at a time in the left hand window, like the old Windows file manager.    From 
the Options menu you can also configure Power File to display two drive and two file windows like the 
picture below.



Power File in Split Screen Mode, Displaying One Drive at a Time

The split screen can also be split vertically with a file manager on the left and a file manager on the right.

Power File has an optional Preview pane where you can view the contents of the selected file.    From the 
Preview menu choose Preview File or click on the Binocular Button on the toolbar.



Power File Main Window and Preview Pane

File Views
Like Explorer you can have the Power File display list files in different ways.    There is a button on the 
right of the toolbar that you can click on and choose the different file views.    New to this version is the 
expanded Thumbnail view.



Power File Main Window in Thumbnail View



File Operations
File operations are available from the File menu.    Many of them are also available from the toolbar.

Selecting Files and Directories
Power File allows you to select files and directories with the keyboard and the mouse.    With the keyboard
you can select files and directories with the right arrow key or the space bar.    In addition you can select 
or deselect files with the Control key and the left mouse button.    The Shift key and the right mouse allow 
you to select groups of files.

Copying and Moving Files and Directories
Power File gives you numerous methods for copying and moving files.    
There are copy and move buttons on the toolbar and the same operations are available from the file 
menu.    These commands bring up a dialog box where you are asked to enter a destination path.    Your 
10 previous destination paths are remembered for convenience.
From the Copy/Move dialog, you can easily change your operation from copy to move by choosing the 
radio button on the left hand side.
In the settings dialog box available from the Options menu you have an option to have Power File warn 
you before overwriting files on copy and move operations.    Those settings are global.    However you can 
easily turn on and off the warning on a particular operation by checking or unchecking the “Warn duplicate
files” button.
If you are in split screen mode, the “Perform operation on all windows” button will allow you to copy the 
selected files from both windows in one operation.    In addition you can choose the “Copy new and newer
files only” option to only copy the files that don’t exist on the destination directory or files with later dates.
In addition to copy and moving with the Power File dialog boxes, Power File supports dragging and 
dropping files to directories in Power File, to directories in Windows Explorer and to the Windows desktop.
Dragging and Dropping files with the right mouse button will give the same pop up dialogs with the same 
choices as if you dragged the files from Explorer.
Also like Explorer you can copy files to the clipboard and paste them into another directory.    You can do 
this with Ctrl+C and Crrl+V.    In addition, copy and paste options are available from popup menus when 
you right click on files.
You can copy directory and directory branches just like you copy files.    Unlike Explorer you can select 
more than one directory to copy or move.    

Deleting Files
To delete files or directories in Power File, select the files and directories that you want to delete.    Then 
click on the delete button, press the Del key or choose Delete from the file menu. The delete dialog box 
will appear.
If you don’t want a confirm delete dialog box to come up every time you delete files you can turn this off in
the Settings dialog.

Encrypting and Decrypting Files
Power File allows you to encrypt any number of selected files in a single action.    Encryption renders the 
files unreadable by any program.    When you encrypt a file you give the file a password.    Then when you 
want to decrypt the file, you need to enter the password or you won’t be able to.    Take care to write down
and remember your password because if you forget it, we won’t be able to help you get your file back.    
Encrypted files have the same name as the originals but have an .encr extension added to them.    As part
of the encryption process you can also elect to delete the original files.    If you highlight an encrypted file, 
choose the same option Encypt/Decrypt do decrypt the file

Renaming Files and Directories



Like Explorer, you can click on a highlighted file or directory and the name will change into a field that can 
be edited and you can type in the new name that you want.    You can also activate this option with the F2 
key.    In addition to the Explorer method you can click on the Rename button on the toolbar or the 
Rename menu option from the File menu and a rename dialog box will come up.    With the rename dialog
box it’s possible to select multiple files and directories and rename them all with wild cards.

Launching Files
You can most easily launch a file by double clicking on it. There is also a launch option on the File menu 
and a launch button that can be added to the toolbar.    When the file you are launching is a program, 
Power File will run the program.    If the file you are launching is a data file, Power File will ask Windows to
launch the program that is associated with that file and open up the data file.    If the data file does not 
have a program associated with it, Power File will give you an option to choose a file to associate.

Multi Launching Files
Use the Multi Launch command to associate more than one program with filenames of a specified 
extension. If you want to choose among different word processors to edit files with a .TXT extension, for 
example, you would use this command to list those word processors.

When you double click on a file with such an extension, Power File opens a dialog box which allows you 
to choose one of the designated programs associated with this filename extension.
To record multiple launches:

1. Click on the Multi launch option from the File menu.

2. Type the full pathname (including drive, directory, and filename) of the new program.

• OR-

Click on Browse to select a program file from another directory.

3. Click Add to add the program to those displayed in the current associations window.

1. Click OK to close the window and record your choices.

2. Add Multi Launch is also available from the right button context menus.

Making Directories
To make a new directory, first highlight the directory that you want to be the parent of the directory.    Then 
click on the make directory button or choose Make Directory from the File menu.    A dialog box will come 
up where you can enter the directory name.

Finding Files
The easiest way to find files in Power File is to right click on a directory or directory and choose “Find…” 
from the pop up menu.    This will bring up Explorer’s find program which is quite powerful and better than 
the one built in to Power File.    To use Power File’s built in find, you can click on the find button or choose 
“Find” from the file menu.

File Attributes
To change the attributes of a file, choose File Attributes from the File menu.
Use choices in the popup dialog box to change the attributes of the selected files.
The choices are

· Archive

· Read Only

· System



· Hidden

· Normal Attribute

The Archive attribute is a lefter from the DOS days.    It’s supposed to designate a file which has changed
after being backed up.
Read-only prevents a file from being edited or deleted.
System files, designated by DOS, contain information about hardware and system configuration. They 
cannot normally be deleted or changed.
Hidden prevents a file from being included in a DOS directory listing. Power File, however, does include 
hidden files in its display of files in a directory.    

Files with no attribute options checked are considered Normal Attribute.

Windows 2000 and XP have additonal attribute for compressing and encrypting files as part of the 
operating system.    To add these attributes to files, right click on the file and choose properties from the 
pop up menu.    Then follow the instruction to compress or encrypt the files or directories.

Comparing Files
To compare two text files, choose Compare Files from the File menu.    A compare files button can also be
added to the toolbar.
If you are in split screen mode, the current file in each window will be put in the edit fields automatically. 
There is also a browse button that can help you select each file to compare.    When you click OK, the files
will be compared and a window will come up showing you the differences in the two files.    The window 
will be split vertically showing one file on the left and the other file on the right.    The parts of the files that 
are different from one another will be highlighted.

Copy to and Paste from Clipboard
This commands are available from the menu that pops up when you right click on files.    This is an easy 
way to copy files from one directory and paste them into another directory.    You can add buttons to the 
toolbar for these commands.    You can also access copy and paste through the keyboard commands 
Ctrl+C and Ctrl+V.

Open With/Associate
Use the Open With command to launch a particular data file with a particular program.    The dialog box 
that comes up will have a check box where you can make this association permanent so in the future you 
can just double click on the file and launch it.

List All Files
With the list all files, you can list all the files from a selected drive or drives.    



Power File List All Files Window

From this window you can copy, delete, move and perform all the file operations that you can do in the 
regular Power File window but from this window you can do them with files from multiple files and 
directories.

Viewing Files from Multiple Directories
In Power File you can get a listing of files in selected directories.    You can even select directories in split 
screen windows and list all the files from them.    To view files from both windows you have to turn that on 
in the settings dialog.    To display the file listings, first select the directories that you want to view.    
Directory branches can be selected with the “Tag Branch” option from the Actions menu.    Then choose 
“View Selected Directories” from the “File” menu.    A window will like the List All Files window will come up
displaying the files in the selected directories.
You can also add a button to View Selected Directories to the toolbar.

Duplicate and Unique Files



From the List All Files window or the window displaying selected directories, you can toggle the display of 
duplicate files and unique files.    From the Actions menu choose File Display/Duplicate Files, Unique Files
or All Files.    You can also add buttons for these commands to the toolbar.



Disk Operations
Disk Operations are available from the disk menu or the toolbar

Copy Diskette
To make a copy of a floppy diskette, choose Copy Diskette from the Disk menu.    The copy disk dialog 
box will come up.    Set the pull down boxes to point to the disk that you want to copy and click on Start.

Format Disk
Choose Format Disk from the Disk menu and choose the disk that you want to format from the dialog box.
The Windows format box will then come up.    Make your options selections and click on Start to initiate 
the format operation.

Label Disk
Choose this option to add or modify the volume label of a diskette or drive.    Power File shows the volume
label of hard disks on the root directory folder.

Map Network Drive
This option will only be available when you are connected to a network. Choosing this option will bring up 
a dialog box allowing you to choose network drives to connect to.

Disconnect Network Drive
This option will only be available when you are connected to a network. Choosing this option will bring up 
a dialog box allowing you to disconnect from any connected network drives.



FTP Sessions with Power File

Adding and Modifying FTP Sites
Before starting an FTP session it is a good thing to make sure that you have the FTP Settings Dialog box 
filled out.    You can do this from the FTP Settings tab in the Power File Settings dialog or the Settings 
button on the FTP Session dialog..

If you are currently displaying a site and want to add a new site, click on the New button.    When you are 
finished entering the site information, click on Save to save the site.

You can modify a site by just typing in new information into a field.    The newly entered information will be 
used when you connect to the site.    If you want to save the new information for a future session you will 
have to click on the Save button.

The Site Name field contains a listing of the sites that you have configured.    The site name field is just 
the name you use to refer to the site and is not used to connect to the site.

The Host Name field contains the name of the ftp site.    For Canyon Software the site name is 
ftp.canyonsw.com.    For Microsoft, the name is ftp.microsoft.com.

Most FTP sessions are what is called “Anonymous”.    In an anonymous session the password is your 
email address and the user id is “anonymous”.    For an anonymous session, click on the Anonymous 
Login box.

If your session is not anonymous, you need to enter a user id in the User ID field and your password in 
the Password field.

FTP Sessions
Use the FTP Session command to open a full FTP session in Power File.    You can access the FTP 
Session command from the File menu or add a button for it to the toolbar.    When you choose the FTP 
Session command, the FTP dialog will appear.

Power File FTP Session Dialog

Choose the site that you want to connect to and click on the Connect button and Power File will initiate an



FTP session.    Depending on how you have you have configured your FTP settings Power File will either 
split the screen and show the FTP session in a second window or Power File will replace the current 
display with a view of the FTP connection.
To close the FTP session, choose Close FTP Session from the File menu.    This command can also be 
added to a button on the toolbar.    When the FTP session is closed, Power File will go back to its original 
display.
You will notice that the drive bar is no longer available and many of Power File’s commands are also not 
available when the FTP Session window is the active one.    The only commands available in an FTP 
window are Copy Delete and Rename.
Navigating around an FTP session is a little different than navigating a local or network drive.    In an FTP 
session you do not see the whole directory structure of the drive.    All you see is the current directory and 
the subdirectories.    Like a local drive you can highlight a particular directory and see the files in that 
directory.
There will always be an arrow and two dots as the first directory.    This is the up one level command.    To 
move up to the previous directory, double click on this.
There will be no plus signs on the directories to indicate if they have subdirectories.    If you want to open 
up a directory and see the subdirectories, double click on it.    This will result in that directory becoming 
the root of the view and the subdirectories of that directory will now be shown.
Most FTP servers currently use UNIX as their operating system and unlike Windows, case must be 
matched exactly on a UNIX system for web page links.    Windows 95 showed all filenames in lower case 
and starting with a capital letter.    With the growth of the internet, Microsoft realized that it wasn’t a good 
idea to pretty up filenames like that since most of the servers on the internet run some form of UNIX 
where filenames are case sensitive and Pfile.exe is a different name than pfile.    To compensate for 
Windows 95s silliness we put in an option to display “True Filenames”      on the “Options” menu.    When 
doing FTP uploads under Windows 95 and 98 it is probably good to turn on “True Filenames”.



Power File Connected to an FTP Site

FTP File Transfers
The easiest way to copy files to and from an FTP session is to drag and drop them between windows.    If 
you have the overwrite warning turned on, you will get a dialog box displaying the size and dates of both 
files so you can decided if you want to continue the transfer or not.
You can also choose Copy from the File menu or click on the copy button.    If you choose Copy when the 
FTP window is active, you will get a dialog box where you can enter a destination directory.    The 
destination does not have to be the other window.    If the local window is active you will get a regular file 
copy dialog which will allow you to copy files locally.    There will be a button on the dialog labeled FTP 



Copy if you want to copy files to the FTP session, click on click on this button.
During copy operations, a dialog box will show the status of the operation.      There will be a minimize 
button on this dialog box.    Clicking on this button will minimize Power File to the task bar.    The ftp 
operation will still continue.    Right clicking on Power File on the task bar and choosing restore from the 
popup menu will restore Power File.

Other FTP Operations
Besides copying files you can also view, delete and rename files, create and remove directories on an 
FTP site.    You will need to have special permissions to delete and rename files and directories and will 
generally not be able to do this in an anonymous session.    You delete files on an FTP site the same way 
you do on a local drive.    Tag the files and choose the delete command.    To rename a file, highlight the 
file and choose Rename from the File menu or click on the Rename button.    You can only rename one 
file at a time during an FTP session.
Creating and deleting of directories is done in the same manner as on a local drive with the Make 
Directory option and the Delete option.
To view a file, choose View from the Actions menu or click on the View button.    The file will be 
downloaded to a temporary directory and displayed in whatever viewer you have configured to use.
Some FTP servers allow you to change file permissions from an FTP session.    

Changing File Permissions
If the server permits this operation you can use the File Attributes or right click on the file that you want to 
change and choose Change File Permissions from the pop up menu. 

Every file has read, write and execute permissions for yourself, (Owner), group and the world (Public).    
Not all ftp servers support changing file permissions in this way.

Closing an FTP Session
To close an FTP session, choose Close FTP Session from the File menu.    This command can also be 
added to the toolbar.    When the FTP session is terminated, Power File will go back to its original layout.



Internet Actions Manager

Performing FTP Uploads, Downloads and HTTP Gets
Power File internet file transfers are performed by a separate program, CYNNET.EXE, that acts as an 
internet download and upload manager.    When you initiate a file transfer, CYNNET.EXE is run and starts 
the transfer.    Since Cynnet is a separate program, you can continue to use Power File while performing 
the transfer.    You can log off the internet site, connect to other sites or just close Power File and the file 
transfer will continue.    With Cynnet you can save uploads and downloads for a later date.    Then when 
you want to transfer the file, choose Internet Actions from the Actions menu or run Cynnet from the start 
menu.    Of if you are forced to terminate a download, you can resume the download with Cynnet.    By 
default, Cynnet will save a record of up to 100 of your transfers.    Then when you run Cynnet, you can 
choose to transfer the files again or delete the transfer information.    You can turn off the saving of    these
transfers from the Ftp Settings dialog available from the Options menu.    Any transfer that’s not completed
will automatically be saved regarding of the save configuration.    The save transfer files have ACTN 
extension and they are kept in the Power File install Directory.

Power File Download Manager

Resuming an Interrupted Download
Power File’s internet actions manager, Cynnet will save all incomplete file transfers.    The easiest way to 
resume a download that for some reason was not completed is to run Cynnet from the start menu or 



choose Internet Actions from the Actions menu. Pick the download from the listing and click on the GO 
button. Power File will restart the download automatically.

Getting a File from an HTTP or FTP Server
If you know the URL of the file that you want to download, you don’t even have to log on to the ftp site or 
load your web browser if you just want to download something.    Choose FTP/HTTP Get from the File 
menu and enter the URL in the dialog box that comes up.    Power File’s download manager will load and 
start downloading the file. 



Performing Other Types of Actions in Power File

Filtering Files
The filter command allows you to specify file specifications and date and size criteria for which files Power
File displays.    These filtering parameters can be saved as a Filter Set and easily reloaded when you wish
to have the same filter in effect without having to specify all the parameters again.

Filter Dialog Box    File Spec Tab

The first tab allows you can specify the files specifications and attributes for the filter.    Multiple file 
specifications can be used as long as they are separated by a comma.
When Power File first loads it will always use the “Default”: filter for displaying files.    The Default filter has
a file specification of “*.*” and will show directories and all file attributes.    If you wish to change this, 
choose the attributes and files specs that you want to use and click on the “Save” button.
You can also create additional Filter Sets for use with Power File.    To do so, choose the Filter Set tab.



Filter Dialog Box    Filter Set Tab

To create a new filter, choose the “Add” button.    You will be prompted for a filter set name and a set of file
specifications.    Multiple file specifications must be separated by commas.    In addition you can add a 
date range and size range to the filter set.    The option “Only allow files with today’s date” will always use 
the current date on your computer when displaying files.    That way you can display just the files that 
have been modified today.
To save the filter set, click on the “Save” button.    To put the filter set into effect, click on the “Apply” button
or the “OK” button. 

Filter Set
The Filter Set menu will display a listing of the filter sets that you have created in addition to the Default 
filter set.    You can make any of these sets active by choosing it from the menu.    In addition you can put 
filter sets on the toolbar.
Power File will have to be restarted before it will display new filter sets in the menu.

Preview
Choose “Preview Files’ from the “Preview” menu or click on the button showing binoculars and a 
document and a preview window will open up on the bottom of the Power File Window.    Power File will 
show most graphics, spreadsheet and word processing files.    What Power File can’t show, it will show in 
a Hex viewer.    To close the Preview window just click again on “Preview Files” or the preview files button.

Synchronize Directories
The synchronize directory feature allows you to make sure that the files in one directory are updated with 
newer and newly created files from another directory.
To synchronize two directories first highlight the directory with that has the new and newly modified files.    



Choose Synchronize Directories from the Actions menu or click on the Synchronize Directories button.
From the dialog box choose the directory that you want the files copied to and then click on List Files.    
You will then have a list views displaying the files in the source and destination directories.    The files that 
are different will be highlight and the difference between them will also be listed.    You can select which 
files to copy by clicking on the files with the Ctrl button held down or just use the default which will copy all
the files where the size is different, the date is more recent or the file doesn’t yet exist on the destination 
directory.

Set File Date and Time
You can set the date and time of any group of selected files through this feature. Set the desired date and
time in the dialog box and choose OK.    All of the selected files will be modified.

Print Dir List Print File List
Use the appropriate Print command to print a list of either the directory window or the file window.

Edit File
The Edit command allows you to activate the text editor specified in the Options/Settings dialog box and 
load the highlighted file into the editor.

Tag
The Tag command tags a file or directory currently highlighted.    Tags look the same as the currently 
highlighted file.

Untag
The Untag command untags the tagged file or directory currently highlighted.

Tag All
The Tag All command tags all entries in the currently active window, directory or file.

Untag All
The Untag All command untags all tagged files or directories in the currently active window.

Tag Branch
The Tag Branch command tags a selected directory and all of its branches.

Tag Files
The Tag Files command opens a File specification dialog box, which allows you to specify the name, 
types, and attributes of files to be tagged.

Invert Tags
This command will invert the selection to select the files that weren’t previously selected and deselect the 
files that were selected.



Installing Power File

Requirements
Power File is designed to run on an IBM type PC running any 32 bit version of Windows.    The program 
requires 15 megabytes of disk space for a typical installation. 

Installation procedures
If you are installing from a floppy diskette or CD ROM run the setup program SETUP.EXE.    If you are 
installing a program downloaded from the internet, the file name will probably be pfile.exe or pfgold.exe.    
When you run the install program you will be prompted to give an install folder where Power File should 
be installed.    Power File will check if there is enough disk space and then copy the files to the install 
folder.    It will put a Power File option in the Start Menu as well as a Help option and Ftp Actions option.

Uninstalling Power File
To remove Power File:

Open up the My Computer folder from that folder open up the Control Panel Folder.    From the Control 
Panel Folder choose Add/Remove Programs.    The dialog box that comes up will list the programs that 
you can uninstall.    One of them should be Power File.    Choose that option and choose Uninstall.    The 
program will be uninstalled.



Modifying Power File’s Settings

Regular View/Explorer View
Power File offers 2 different file manager layouts.    Regular View is like the file manager in Windows 3.1 
and programs like Xtree.    In Regular View, you view only one drive at a time and you can change drives 
with the drive bar.    Explorer View follows the layout of Windows Explorer where all the drives are on the 
tree on the left hand side.    You can still change drives with the drive bar or you can just expand the drive 
from the tree.

Large Icons/Small Icons/List/Details/Thumbnails
This option is the same on from the view menu in Explorer.    With this you can choose how the file display
is shown in the right had window of Power File.    By default, there is a button on the toolbar that you can 
use to select the file view.

Single Pane/Dual Pane Horizontal/Dual Pane Vertical
These options configure the Power File window.    You can have a single view with one drive tree and one 
file window.    Or, you can have a split view with two drive trees and two file windows.

True Filenames
Earlier versions of Windows Explorer didn’t show you the exact case of your filenames.    If all the letters 
of a file are in lower or upper case, very often Windows Explorer would show it with the first letter 
capitalized and the rest small.    For example, CANYON.EXE will appear as Canyon.exe in Explorer. This 
“prettying up” of filenames causes no problem unless you are uploading files to the internet where they 
are linked to web pages.    Most web links are case sensitive and a link to CANYON.EXE will fail if the file 
is actually named Canyon.exe.    Therefor we have provided the option of displaying files with their names 
not “prettyied up” but the way they actually appear.    Choose this option is you desire to see and use the 
filenames as they actually are.    This should not be necessary for Windows 2000 and XP.

Show Toobar
This options toggles the display of the Power FileToolbar on and off.

Show Drive Bar
This option toggles the display of the Power File Drive Bar on and off.

Show DOS Command Line
For those of you who what access to a command shell where you can enter DOS commands, this option 
will add a command line to the bottom of the Power File Window.    This command line will accept all DOS 
command.

Changing Default Font
Select Fonts from the Options menu.
The Fonts dialog box displays. Available fonts are those which are installed under Windows, or under a 
type manager working with Windows.



Font options dialog box

Make whatever changes you wish and click OK.
The changes take effect immediately and remain when you exit the program.

Changing Other Settings
Select Settings from the Options menu.
The Settings dialog box displays.    The Settings dialog box has five pages for configuring Power File 
Options.    In addition if you have our programs Drag And Zip or Drag And View installed, there will be 
pages for configuring them too.      You select a page by clicking the mouse on one of the tabs at the top.    
The first page is for general settings.

General Settings



General    Settings page

Enter your choices for warnings, multiple windows operations and window appearance, file delete and 
editor.
Warnings./ Confirmations.  When enabled, these warnings appear when the files you are copying or 
moving are about to overwrite files of the same name.      These warnings can always be overridden at 
copy or move time.
Default Drag And Drop. In Power File all drag and drop file operations default to a copy operation.    This 
is different than Explorer which will default to a move when the operation is performed between folders on
the same drive.    Check the box that says Drag and Drop on Same Drive Defaults to Move to mimic 
Explorer’s operation
Multi-Threaded File Updates.    This will default to checked under Windows NT, 2000 and XP and 
unchecked under Windows 95, 98 and ME.    Windows 95’s thread management is not very robust and 
we’ve found putting file system updates in another thread can make the program seem to run very slowly.
File Delete. When checked, files deleted in Power File will be send to the RECYCLE BIN.    When not 
checked, you will have to use an undelete program to recover deleted files.    
Scale Graphics to Preview Window:    When this option is turned on all graphics that are too large to be 
displayed in the preview window will be scaled to fit.
Show Archives as Folders:  This option will be visible only if you have Power File Gold installed.    With 
Power File Gold, Files with the extension ZIP, GZ and TAR will appear as blue folders on the directory 
tree.    Highlighting these files will show the contents of the folder in the file pane.    Extracting files from 
the archives are as easy as performing a copy or move.    This option will be checked by default.    If you 
don’t want files listed this way, uncheck it.
Drag Over Plus Sign:    We’ve added a new feature where when you’re dragging files or directories and 
you drag them over the plus sign of an unexpanded directory, the directory will expand automatically.    
This can be disconcerting so we’ve turned it off by default.    However you can easily activate this option 
by checking “Expand Directory”.
Editor:    Enter your editor of choice in this field and you can edit a highlighted file when you choose the 
edit file option.
Default Launch:    Normally when you launch a file, the associated program will run and load the 



highlighted file.    If no program is associated with a file, then the Open With dialog will come up.    You can
change this behavior and have Power File always run a particular program such as note pad if there is no 
associated program for a file.    If you want this feature, add the program name in the default launch field.

Window Operations

Windows page

Window Appearance: These choices follow the pattern for Microsoft Windows: cascaded windows are 
overlapped slightly, and tiled windows are fully visible.
Multiple Window Operations. Power File lets you perform operations on tagged files in more than one 
window. These choices allow you to specify which operations you would like to perform in multiple 
windows.
When View directories from multiple windows is 
che********************************************************************************************************************
************************************************************************************************************************
************************************************************************************************************************
************************************************************************************************************************
************************************epend on the configuration for the action of the particular button.    For 
example, if you have Power File configured to copy from only the active window, dragging files to the copy
button will only work on the active window no matter what you have configured for drag and drop.

Visible Drives



Drives Page

In the drives page you can configure the drives that are available to Power File.    This is particularly 
useful on networks where you might want to limit the drives available to different users.    The settings in 
this dialog box will be reflected in both Power File and the Power File Drive Bar.
Select the drives that you want to have available.    To make drive selection easier, there are check boxes 
where you can turn on or off the different drive types.    Drives that have been selected will be displayed 
below the drive list box.

DOS Command Line



DOS Command Page

You can turn on Power File’s DOS Command Line by choosing Show DOS Command Line from the 
Options menu.    In this page you can set the DOS command Line defaults.
DOS In Window:    You can run most DOS commands with the SmilerShell and can choose to have these
commands run full screen or in a DOS window.    The default is to run the commands in a DOS Window.
Inactive DOS Windows Stay Visible:    This options determines whether the DOS windows will stay 
around or close after DOS commands are run.    If you choose to have the DOS windows stay around you 
can easily close them all at once by pressing Ctrl+Shift+K from the keyboard.
Insert Mode: Use this to toggle between Insert or Overtype mode

Zipper
If you have Power File Gold you’ll have a Zipper page.    From this page you can set the default Output 
Directory for zipping operations. You have two choices of the default output directory that Drag And Zip 
will enter into the zip dialogs.    One is the current directory, which is the directory that you dragged the 
files from.    The other is the directory that you used the last time that you used Drag And Zip.



FTP Settings

Power File allows you to connect to FTP (File Transfer Protocol) over the Internet.    These dialogs allow 
you to configure the FTP setting for your own use.

General Settings

FTP Settings Page

Warn Before Overwriting Files. When this option is checked, you will be presented with a warning when
the ftp copy operation you are about to perform will cause a file on the server to be overwritten.    The 
warning that you will get is very similar to the one you will get if you have warnings turned on form regular 
copy and move operations.    The dialog box will show you the file name that you are about to overwrite 
and the date, time and size of the target and source files.
Email Address.    Anonymous FTP uses your email address as the password to connect to a remote FTP
server.    Enter you email address in this field.
FTP Window. By default, when Power File connects to an FTP server, it will split the screen horizontally 
and show the local directory and files in the top window and the ftp directory and files in the lower window.
If Power File is already running in split screen, the current window will become the FTP window.    If you 
normally don’t run in split screen mode, you can configure how and where Power File displays the FTP 
connection.    Use Current Window will replace the current display with the display of the FTP server.    
Then you will have to open another window to drag and drop files.    Split Window Horizontally, the 
default, will open up a second window for the FTP session below the current one.    Split Window 
Vertically, will open up the FTP window to the right of the current one.



Uploading Files.    Windows will preserve case in a file name but they are not truly case sensitive 
platforms.    In Windows you cannot have a 2 files, one named pfile.exe and the other PFILE.EXE.    Under
UNIX, the operating system for most ftp and web servers you can.    Therefor it is important to make sure 
the case of the files you are uploading exactly match expectation of the programs that will be accessing 
them.. You can also specify in this dialog that all the files that you upload are changed to upper case or 
lower case.    
Keep Log File.    You can have Power File keep a record of your FTP sessions by checking this option.    
Power File will create the file PFFTP.LOG in its home directory.    You can have a new log file written for 
each session or appended for each session.

Power File has the ability to open Zip Files remotely.    And from this remote listing of the contents of the 
Zip file, you can download and extract individual files is so desired.    It will take Power File longer to open 
Zip files on an FTP server rather than just giving you a file listing so if you don’t need this feature, it’s best 
to uncheck Open Zip Files Remotely.

The Power File Internet Actions Manager saves each action to a file. The file names for these files are 
inet1.actn where the number 1 indicates which number file this is.    Internet Actions Manager does this so 
you can redo an upload or download at a later date and save notes to an actions file.    If you don’t need 
this feature and you don’t want the *actn files cluttering up your hard disk, see that Save Download 
Information remains unchecked.

FTP Extensions Page

Convert These Extensions.    Use this option to have Power File convert extensions when uploading and
downloading files.    The most common extension desired is to convert htm to html.    When this 
conversion is specified all files with htm extensions will be convert to html when uploaded and converted 
back to htm when downloaded.
ASCII Filenames and Extensions.    In this area you can specify which filenames and extension will 



automatically be uploaded in text mode.    Very often ftp and web severs are running operating systems 
that store text files differently.    When you upload files containing ASCII text like html files to them, you 
usually want to want the files to be stored in the conventions appropriate to the operating system that the 
server is running.    You can make sure this happens by adding the names and extensions to this box and 
choosing Auto Detect from the upload dialog box.

Firewall Settings

FTP Firewall Page

Firewall Settings.    Use these settings to connect through a firewall.
Host: Enter the host address of the firewall host in this field.
Userid: Enter the user id that you use to log in.
Port Number: If not using the standard FTP port, enter the port number here.
Password: Enter your password here.
Pasv Mode: This option will use passive mode for data connections.    No other firewall settings 

are used.
SITE site:    After connecting to the firewsll host, connection is made to the remote ftp server with 

a SITE command specifying the name of the ftp site. Firewall host, user id and password are used
Open site:  After connecting to the firewall host, connection is made to the remote ftp server with 

an OPEN command specifying the name of the ftp site. Firewall host, user id and password are used
User user@site:    After initial connection to the firewall host, a USER command is sent also 

specifying the ftp site to connect to. Only the firewall host is needed.
USER with login:    This is similar to User user@site but host name, user id and password are 

used here.

Sounds



FTP Sounds Page

Sounds. You can configure Power File so that certain sounds (wav files) will be played after the 
completion of a particular FTP operation.    You can use the default sounds that are supplied or add your 
own.    If you don’t want any sounds, see that the Enable Sounds check box isn’t checked.    Or if you don’t
want a sound for just one operation, see that the field is blank.



Configuring The Toolbar

Power File’s button toolbar is very easily modified allowing you to add and delete different buttons.    
Programs can also be added to toolbar buttons.    All toolbar buttons can be configured to user Alt or Ctrl 
key combinations as hot keys.    Alt hot keys are shown in the lower right of the button as black on gray.    
Ctrl hot keys are shown as white on black.    There is also an option to completely hide the toolbar.    If the 
toolbar is hidden, the configured hot keys are still active.

To modify the toolbar:
Choose Customize Toolbar from the Options menu.
The Toolbar Customize dialog appears:

Toolbar Customize dialog

In the list box on the left appear the available button choices.    The top two entries are SEPARATOR and 
NEW PROGRAM.    SEPARATOR adds a space between two buttons.    NEW PROGRAM allows you to 
install a program as a button choice.    In the list box on the right appear the buttons that are currently part 
of the toolbar along with their hot keys.    
To add a new button
Select the position in the Toolbar buttons list box where you want the button to appear.    The new button 
will appear before the selected button.    You can also drag buttons in the Toolbar buttons list box to 
modify their position.
Select the button that you want to add from the Available buttons list box.    You can also choose 
SEPARATOR or NEW PROGRAM.    If a command button is already in the Toolbar buttons list box, it 
won’t be in the Available buttons list.
Choose Add or drag the button to the right hand list box.    The button will be added.
To remove a button
Select the button that you want to remove from the Toolbar buttons list box.    Click on Remove or drag the
button to the left hand list box.    The button will be removed.
To add a program
Select NEW PROGRAM and choose Add.    The Add Program dialog will appear.



Add Program dialog box

Browse through the directories and files and pick the program that you want to associate with the button.   
If you want the file that’s currently highlighted to be launched with the program check the Launch 
Highlighted File With Program box.    When the mouse cursor is over any of the toolbar buttons, a little 
window will come up saying what the button does.    You can enter a custom button description in the 
Button Description field.    If no description is entered, the program name will be used.
Choose OK and the button will be added to the Toolbar buttons list box.    If the program has an 
embedded icon like most Windows programs, that icon will be placed on the button.
To modify a program button
Highlight the button in the Toolbar buttons list box.    Choose the Program button and the Add Program 
dialog will appear.    Follow the directions for adding a program.
To add a filter set
Select    the Filter Set button and then click on the Add button.    The Add Filter Set dialog will appear.



Add Filter dialog box
The available filters are shown in a list box.    When you highlight a particular filter, that filter’s file spec 
and other parameters are shown below.
Choose OK and a filter set button will be added to the Toolbar buttons list box.    The name of the filter set 
will appear in the tool tip window when you place the cursor over the button.
To add or change a button hot key
Highlight the button whose hot key you want to change or add.    Select the letter of the hot key that you 
want to use from the drop down list box in the lower right of the Customize Toolbar dialog box.    Choose 
Alt or Ctrl if you want the hot key to use the Alt key or the Ctrl key.    
When you are finished making changes to the toolbar, choose OK.    All changes will be saved and 
windows updated.    If you choose a hotkey that is already in use, you will be warned before saving the 
new hot key.



Additional Programs

PF Drive Bar
The PF Drive Bar, PFBB32.EXE is a little floating window that contains buttons for the available drives in 
Power File.    You can click on one of these buttons to run Power File and open it up on that drive.    The 
boarder of the button bar can be dragged to make a line of buttons that is to your liking. 

Drivebar

PF Launch Bar
Power File Desktop come with two launch bars.    The first launch bar, PFBar, works like the Windows 95 
Taskbar.    It can dock on any edge of your screen and also be made to auto hide.    It can also be made to
float like a regular window.

PF Launch Bar

The second launch bar sits on the Windows Taskbar.    The PF Task Launch bar sits next to the Tray Icon 
area at the end of the Taskbar.    This launch bar gives the convenience of having a launch bar without 
taking up additional screen space.

PF Task Launch Bar
Power File includes an Uninstaller to remove the program and changes made during installation. 

When Power File exits, it will save the drive and directory it was last displaying.    When you run Power 
File again, from the Start Menu or a shortcut, it will open the directory it was last displaying.    However, if 
you run Power File from the drive bar or one of the launch bars, it will open up on the drive requested but 
will ignore the saved directory information and instead op up on the current directory for that drive.

PF Task Launch Bar



Getting Help

User help
The easiest way to get help is to post a question in the comments section of our web page, Error! 
Reference source not found. or sending email to Error! Reference source not found..    Most of the 
time your question will be answered the same day or by morning the next day.




