Evidence počítačů 2002

  1. Copyright(c) 1997-2003 ALC, spol. s r.o.


Popis databáze Příklad.mdb

V kořeni stromu ukázkové databáze najdete objekt Naše firma a další standardní speciální objekty. Speciální objekty nejsou běžně zobrazeny. Jejich zobrazení můžete povolit povelem Pomůcky - Nastavení - Zobrazení.

Naše firma

Objekt Naše firma a.s. představuje celou firmu, která je členěna na úseky: Generální ředitelství, Obchodní, Výroba. Jako příklad dalšího členění je v rámci gen. ředitelství uveden útvar Informatika. Na libovolné organizační úrovni mohou být umístěni jednotliví uživatelé a počítačové sestavy jako jejich podobjekty. Toto je náznak jednoho z možných členění, které program podporuje, viz. Návrh struktury stromu.

V databázi jsou pro ukázku uvedeny dvě počítačové sestavy. Jedna patří Světlaně Vašátkové z útvaru Informatika, úsek Gen. ředitelství, druhá Petrovi Prokopovi z obchodního úseku. Sestavy se skládají z monitoru, klávesnice, myši, vlastního počítače a případně tiskárny. Uvnitř počítače najdete komponenty jako je základní deska, paměť RAM, procesor, pevný disk atd.

Tisk evidenčních karet

  1. Ve Stromu objektů ukažte myší na:
    1. konkrétní počítačovou sestavu;
    2. nebo na útvar, úsek příp. celou firmu pro vytisknutí evidenčních karet všech sestav ze zadaného okruhu.
  2. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Tisk.
  3. Na obrazovce se otevře seznam tiskových sestav, ve kterém vyberte položku Evidenční karta.rep.
  4. Tisková sestava se připraví a na obrazovce se objeví náhled v okně Internet Exploreru, ze kterého můžete sestavu vytisknout na papír.

Přesun počítačové sestavy mezi uživateli

  1. Ve Stromu objektů myší vyberte počítačovou sestavu PC1 (Naše firma a.s. - Obchodní - Petr Prokop).
  2. Stiskněte a podržte levé tlačítko myši.
  3. Přesuňte kurzor myši na uživatele Václava Kopečka a pusťte tlačítko myši.
  4. Počítačová sestava se přesune pod uživatele Václava Kopečka a automaticky se vytvoří následující záznamy v historii objektu PC1:
    Přesunut do /Naše firma a.s./Obchodní/Václav Kopeček
  • Další operace s objekty ve Stromu objektů
  • Založit novou databázi
  • Návrh struktury stromu


Otevření databáze

Povelem Soubor - Databáze... z hlavní nabídky programu otevřete Správce databáze.

Na obrazovce se otevře dialogové okno se seznamem naposled otevřených databází.

Databázi otevřete tak, že v seznamu vyberete požadovanou položku a stisknete tlačítko Otevřít.

Význam dalších tlačítek:
Upravit - změna názvu a popisu vybrané položky v seznamu. Název a popis se týká pouze tohoto seznamu a nijak neovlivňuje vlastní databázi.
Odstranit ze seznamu - odstraní vybrané položky ze seznamu. V žádném případě nedojde ke smazání databáze. Databázi, kterou odstraníte ze seznamu, můžete do seznamu znovu přidat tlačítkem Přidat jinou....
Přidat jinou... - přidání jiné databáze do seznamu. Povel umožňuje přidání existující databáze, nebo vytvoření nové.


Vytvoření nové databáze

Vytvoření nové evidence

Založení databázového souboru

  1. Povelem Soubor - Databáze otevřete okno Správce databáze.
  2. Stiskněte tlačítko Přidat jinou...
  3. Na obrazovce se otevře další okno, ve kterém vyberte Vytvořit novou databázi - Microsoft Access.
  4. Zadejte název nového .mdb souboru.
  5. Program vytvoří nový soubor a naplní ho základními daty.
  6. V seznamu v okně Správce databáze změňte název a popis nově vytvořené databáze tlačítkem Upravit a otevřete ji tlačítkem Otevřít.
  7. Pro otevření nové databáze použijte jméno uživatele Správce (ve slovenské verzi Správca), bez hesla.

Připravení šablon objektů

  1. Nejdříve zvažte budoucí strukturu stromu a míru podrobnosti informací o jednotlivých sledovaných objektech. Při návrhu se držte pravidel pro vytváření struktury stromu.
  2. Povelem Pomůcky - Nastavení otevřete okno Nastavení.
  3. V záložce Zobrazení vyberte volbu Zobrazit skryté objekty a stiskněte talčítko OK pro potvrzení a uzavření okna. Ve stomu objektů se zobrazí speciální objekty.
  4. Nalezněte objekt Šablony objektů a Šablony scanneru, ve kterých se nacházejí šablony objektů používaných při vytváření jednotlivých objektů stromu evidence.
  5. Upravte nebo přidejte nové objekty do šablon objektů.

Vytvoření stromu objektů organizace

  1. Vybudujte požadovaný strom pomocí šablon, které jste si vytvořili podle pokynů v předchozím odstaci. Při návrhu se držte pravidel pro vytváření struktury stromu.

Detekce počítačů a jejich přidání do stromu

  1. Do struktury vaší organizace nakonec vložte jednotlivé počítačové sestavy. Počítačové sestavy můžete vytvořit buď ručně, nebo pomocí vzdáleného sběru údajů.
  2. Načtěte údaje o počítačích pomocí Vzdáleného sběru údajů. V kořeni stromu objektů se objeví nová složka "Nové počítače".
  3. Metodou Táhni a pusť (Drag & Drop) přesuňte načtené počítače ze složky "Nové počítače" na příslušná místa ve stromu organizace (do kanceláří, nebo přímo pod jména zodpovědných osob).

Vyplnění hodnot ručně zadávaných vlastností

  1. Nyní, když máte přesunuty počítačové sestavy jednotlivým uživatelům, můžete přistoupit k zadání hodnot vlastností např. inventárního čísla, které nelze zjistit automaticky.
  2. Poklepáním na počítačovou sestavu rozbalíte její strom (sestava se skládá z periférií a počítače). Klepnutím levým tlačítkem myši vyberte počítač, v okně Seznam vlastností vyberte poklepáním levým tlačítkem myši požadovanou vlastnost a upravte její hodnotu. Stejně postupujte i s periferiemi. Pokud budete chtít přidat další vlastnost k objektu, stiskněte pravé tlačítko v okně seznam vlastností a zvolte Přidat nový - Vlastnost.

Zjednodušená detekce software

  1. Proveďte Zjednodušenou detekci software na stanicích a výsledky zaneste do databáze.

Zapsání nakoupených licencí

  1. V Evidenci softwarových produktů upravte typ licence produktu podle skutečného stavu (komerční, shareware, freeware).
  2. V Evidence licencí zapište nakoupené licence k softwarovým produktům (OEM verze přiřaďte jednotlivým počítačům).
  3. V okně Přehled licencí vs. instalací porovnejte stav nainstalovaných programů proti počtu licencí.


Vytvoření nové databáze

Založení nové databáze

  1. Povelem Soubor - Databáze otevřete okno Správce databáze.
  2. Stiskněte tlačítko Přidat jinou...
  3. Na obrazovce se otevře další okno, ve kterém vyberte Vytvořit novou databázi - Microsoft Access.
  4. Zadejte název nového .mdb souboru.
  5. Program vytvoří nový soubor a naplní ho základními daty.
  6. V seznamu v okně Správce databáze změňte název a popis nově vytvořené databáze tlačítkem Upravit a otevřete ji tlačítkem Otevřít.
  7. Pro otevření nové databáze použijte jméno uživatele Správce (ve slovenské verzi Správca), bez hesla.
  8. Nyní můžete přistoupit k návrhu struktury stromu, viz kapitola Návrh struktury stromu.
  9. Do struktury vaší organizace nakonec vložte jednotlivé počítačové sestavy. Počítačové sestavy můžete vytvořit buď ručně, nebo pomocí vzdáleného sběru údajů.


Návrh struktury stromu

V této kapitole jsou popsány základní doporučené zásady pro návrh struktury stromu. Na úvod je třeba uvést, že každý objekt musí obsahovat vlastnost Druh, tzv. klasifikační vlastnost která určuje, co daný objekt ve stromu představuje.

V kořeni stromu by měly být umístěny tyto objekty:

Organizace vlastnosti:
Druh=Organizace
Název organizace=název (dědit)
Kód organizace=zkratka (dědit)
Adresa=adresa

Objekt Organizace představuje celou organizaci, pro kterou bude evidence vedena. Uvnitř tohoto objektu budou umístěny evidované počítačové sestavy v určité struktuře objektů kopírující buď organizační strukturu firmy, místní členění nebo strukturu počítačové sítě.

Členění objektu Organizace

Již při vytváření nového stromu je třeba zvážit, jaké podobjekty s jakým členěním bude obsahovat objekt Organizace. Program podporuje 3 typy členění:

  1. podle organizační struktury
  2. podle lokality
  3. podle struktury sítě

Členění podle organizační struktury

Obecná hierarchie objektů vypadá takto:

Organizace
 vlastnosti:
Druh=Organizace
Název organizace=název (dědit)
Kód organizace=zkratka (dědit)
Adresa=adresa
Závod vlastnosti:
Druh=Závod
Útvar=název (dědit)
Závod - úroveň 1 vlastnosti:
Druh=Závod1
Závod1=název (dědit)
Závod - úroveň 2 vlastnosti:
Druh=Závod2
Závod2=název (dědit)
Závod - úroveň 3 vlastnosti:
Druh=Závod3
Závod3=název (dědit)
Úsek vlastnosti:
Druh=Úsek
Úsek=název (dědit)
Úsek - úroveň 1 vlastnosti:
Druh=Úsek1
Úsek1=název (dědit)
Úsek - úroveň 2 vlastnosti:
Druh=Úsek2
Úsek2=název (dědit)
Úsek - úroveň 3 vlastnosti:
Druh=Úsek3
Úsek3=název (dědit)
Středisko vlastnosti:
Druh=Středisko
Středisko=název (dědit)
Středisko - úroveň 1 vlastnosti:
Druh=Středisko1
Středisko1=název (dědit)
Středisko - úroveň 2 vlastnosti:
Druh=Středisko2
Středisko2=název (dědit)
Středisko - úroveň 3 vlastnosti:
Druh=Středisko3
Středisko3=název (dědit)
Útvar vlastnosti:
Druh=Útvar
Útvar=název (dědit)
Útvar - úroveň 1 vlastnosti:
Druh=Útvar1
Útvar1=název (dědit)
Útvar - úroveň 2 vlastnosti:
Druh=Útvar2
Útvar2=název (dědit)
Útvar - úroveň 3 vlastnosti:
Druh=Útvar3
Útvar3=název (dědit)
Uživatel vlastnosti:
Druh=Uživatel
Uživatel=jméno uživatele (dědit)
PC vlastnosti:
Druh=Sestava
...

Při návrhu stromu není samozřejmě nutné dodržet celou tuto strukturu v uvedené podobě, ale stačí si vybrat určité druhy objektů, např. takto:

Organizace (Druh=Organizace)
Závod (Druh=Závod)
Úsek (Druh=Úsek)
Útvar - úroveň 1 (Druh=Útvar1)
Útvar - úroveň 2 (Druh=Útvar2)
Uživatel (Druh=Uživatel)
PC (Druh=Sestava)

Pro rozdělení organizační složky na několik úrovní používejte druhy zakončené číselným indexem, který určuje úroveň (např. Útvar1, Útvar2,...). Druhy bez indexu používejte pouze v případě, že složka není členěna na úrovně (např. Úsek). Pro lepší přehlednost nekombinujte druh bez indexu s druhy s indexy (např. Útvar, Útvar1), ale raději použijte pouze indexované druhy (Útvar1, Útvar2).

Zachovejte pořadí objektů, např. objekt Úsek musí být umístěn nad objektem Útvar, apod.

Různé organizační složky mohou být různě členěny. Např. Závod A může používat členění pomocí objektů Úsek a Útvar. Závod B může být členěno na Úsek, Útvar1 a Útvar2. Přesto doporučujeme používat pokud možno jednotnou strukturu. Usnadní vám to práci při vytváření výstupních sestav za celou organizaci.

Příklad, který je uveden nahoře, ilustruje nejsložitěji členěnou strukturu v organizaci. Úsek, který je členěn pouze na útvary prvního stupně bude obsahovat pouze objekty druhu Útvar1, které již nebudou dále členěny pomocí objektů Útvar2. Podobně, Úsek, který není vůbec členěn na Útvary, již nebude obsahovat objekty druhu Útvar1, ale přímo jednotlivé uživatele.

Členění podle lokality

Členění podle lokality se řídí rozdělením organizace do budov, poschodí a místností:

Organizace
 vlastnosti:
Druh=Organizace
Název organizace=název (dědit)
Kód organizace=zkratka (dědit)
Adresa=adresa
Budova vlastnosti:
Druh=Budova
Budova=název (dědit)
Poschodí vlastnosti:
Druh=Poschodí
Poschodí=název (dědit)
Místnost vlastnosti:
Druh=Místnost
Místnost=název (dědit)
PC vlastnosti:
Druh=Sestava
...

Stejně jako v předchozím případě si můžete vybrat pouze ty objekty, které mají význam, např. vynechat objekt Poschodí v jednopodlažních budovách, apod.

Členění podle struktury sítě

Členění podle struktury sítě kopíruje fyzickou strukturu počítačové sítě:

Organizace
 vlastnosti:
Druh=Organizace
Název organizace=název (dědit)
Kód organizace=zkratka (dědit)
Adresa=adresa
Síť vlastnosti:
Druh=Síť
Název sítě=název (dědit)
Podsíť vlastnosti:
Druh=Podsíť
Název podsítě=název (dědit)
Větev sítě vlastnosti:
Druh=Větev sítě
Název větve sítě=název (dědit)
PC vlastnosti:
Druh=Sestava
...


Hlavní okno

Pracovní plocha hlavního okna je rozdělena na 3 části:

  • Překreslit obsah hlavního okna
  • Skrýt nebo zobrazit panel nástrojů resp. stavový řádek


Strom objektů

Strom objektů najdete v levé části hlavního okna.

Každý objekt je ve stromu zobrazen jako jeden řádek s ikonou a názvem. Objekty mohou dále obsahovat:

  • jednu nebo více vlastností
  • poznámky
  • záznamy historie
  • podobjekty, tj. další objekty

Když ve stromu objektů myší vyberete některý objekt, v seznamu vlastností se objeví vlastnosti zvoleného objektu a v sekci poznámky a historie se zobrazí příslušné poznámky a záznamy historie.

Evidence se pomocí objektů sestavuje tak, aby každý objekt v evidenci reprezentoval nějaký reálný předmět, např. počítač, procesor apod. Některé objekty ve stromu mají svůj speciální význam - viz. speciální objekty.

Každý objekt musí obsahovat tzv. klasifikační vlastnost "Druh", která určuje typ objektu, např. monitor, procesor, místnost, apod.

  • Vytvořit nový objekt
  • Upravit existující objekt
  • Odstranit objekt
  • Zkopírovat existující objekt
  • Přesunout objekt
  • Vyhledat objekt
  • Automaticky generovat název resp. ikonu objektu
  • Tisk


Vytvoření nového objektu

  1. Ve Stromu objektů ukažte myší na objekt, do kterého chcete nový objekt vložit. Pokud chcete vytvořit kořenový objekt, může být ve stromu objektů vybrán libovolný objekt.
  2. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Vložit nový - Objekt.
  3. Na obrazovce se otevře okno Nabídka šablon objektů, ve kterém vyberte druh nového objektu. Po rozbalení objektu kliknutím na symbolu [+] můžete vybírat také podobjekty.
    Pokud chcete vytvořit kořenový objekt, ve spodní části Nabídky šablon vyberte volbu Umístit jako kořenový objekt.
  4. Ve stromu se objeví nový objekt. V Seznamu vlastností nyní můžete upravit vlastnosti nového objektu a případně změnit jeho název a ikonu.

Nový objekt můžete také vytvořit zkopírováním existujícího objektu.


Úprava existujícího objektu

Vlastnosti objektu upravíte tak, že objekt vyberete ve Stromu objektů a v Seznamu vlastností potom upravíte jeho vlastnosti.

Pokud chcete změnit název, ikonu nebo další nastavení pro objekt, postupujte takto:

  1. Ve Stromu objektů ukažte myší na objekt, který chcete upravit
  2. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Upravit.
  3. Na obrazovce se otevře dialogové okno, ve kterém můžete změnit nastavení objektu.


Odstranění objektu

  1. Ve Stromu objektů ukažte myší na objekt, který chcete odstranit.
  2. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Odstranit.
  3. Po potvrzení kontrolního dotazu bude objekt odstraněn.

Objekty, které odstraníte ze stromu jsou ve skutečnosti pouze přesunuty do objektu Koš.
Objekty, které odstraníte z Koše ať jednotlivě nebo vysypáním Koše, budou nenávratně ztraceny.


Vytvoření kopie objektu

A. Kopírování s použitím schránky

  1. Ve Stromu objektů ukažte myší na objekt, který chcete zkopírovat, a stiskněte pravé tlačítko myši. Z nabídky vyberte povel Kopírovat.
  2. Ve Stromu objektů ukažte na objekt, do kterého chcete vložit vzniklou kopii. Kopie bude vytvořena jako podobjekt vybraného objektu. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Vložit.

B. Kopírování myší

  1. Ve Stromu objektů ukažte myší na objekt, který chcete zkopírovat. Stiskněte a držte levé tlačítko myši. Na klávesnici stiskněte a držte klávesu Shift.
  2. Přesuňte ukazatel myši na objekt, ve kterém chcete vytvořit kopii objektu vybraného v bodě 1, a pusťte tlačítko myši. Nakonec uvolněte klávesu Shift.


Přesunutí objektu

Pro přesunutí objektu jsou k dispozici dvě možnosti:

  • myší metodou chytni a pusť (drag & drop)
  • povelem Objekt - Přesunout objekt

Chytni a pusť

  1. Ve Stromu objektů ukažte myší na objekt, který chcete přesunout. Stiskněte a držte levé tlačítko myši.
  2. Přesuňte ukazatel myši na objekt, do kterého chcete vybraný objekt přesunout, a pusťte tlačítko myši.

Povel Objekt - Přesunout objekt

Na obrazovce se otevře okno, ve kterém vyberte cílový objekt. Přesouvaný objekt bude bude vložen jako podobjekt cílového objektu.


Automatické vytvoření názvu a ikony objektu

Název objektu

Název objektu může být automaticky sestaven z aktuálních hodnot určitých vlastností objektu.

Příklad: Název objektu, představujícího procesor, bude vytvořen spojením hodnot jeho dvou vlastností: Název a Frekvence. Hodnota vlastnosti Název bude tvořit kmen názvu objektu, hodnota vlastnosti Frekvence bude tvořit příponu. Vlastnost Druh se na tvorbě názvu objektu neúčastní. Spojením vznikne název objektu: "Pentium III, 500 MHz".
Pokud uživatel změní hodnotu vlastnosti Frekvence na 600 MHz, automaticky se změní i název objektu na "Pentium III, 600 MHz".

objekt:
název objektu: Pentium III, 500 MHz
vlastnost | hodnota | část názvu objektu
Název | Pentium III | kmen
Frekvence | 500 MHz | přípona
Druh | Procesor | -

Ikona objektu

Podobně jako název objektu, také jeho ikona může být převzata z některé jeho vlastnosti. U dané vlastnosti musí být zapnuta volba Tato vlastnost určuje ikonu objektu. Ikona objektu může být určena nejvýše jednou jeho vlastností.


Aktualizovat název a ikonu

  1. Ve stromu objektů vyberte objekt, jehož název a ikonu chcete zaktualizovat.
  2. Vyberte povel Objekt - Aktualizovat název a ikonu.
  3. Obsahuje-li vybraný objekt alespoň jednu vlastnost, která má určovat název nebo ikonu objektu, nastaví se název a ikona podle hodnot příslušných vlastností.

Automatické vytvoření názvu a ikony objektu


Jak zapnout automatickou tvorbu názvu a ikony objektu

  1. Ve Stromu objektů myší vyberte příslušný objekt.
  2. Pokud v Seznamu vlastností nevidíte všechny vlastnosti objektu, které mají tvořit jeho název, zvolte záložku Vlastní ve spodní části seznamu.
  3. Myší dvakrát klikněte na vlastnost, která má tvořit název. Na obrazovce se otevře dialogové okno, ve kterém zapněte volbu Tato vlastnost určuje název objektu a vyberte, jakou část názvu má vlastnost tvořit - předponu, kmen nebo příponu. V tomto okně můžete vybrat také volbu Tato vlastnost určuje ikonu objektu.


Vysypání Koše

  1. Ve Stromu objektů ukažte myší na objekt Koš.
  2. Stiskněte pravé tlačítko myši a z nabídky vyberte povel Vysypat koš.

Vysypáním Koše se z databáze definitivně vymažou všechny dosud odstraněné objekty.


Použít funkci

  1. Ve stromu objektů vyberte objekt, na který chcete použít funkci.
  2. Vyberte povel Objekt - Použít funkci.
  3. Na obrazovce se otevře okno pro výběr funkce:

    Aktualizace názvů a ikon objektů - zaktualizují se názvy a ikony vybraného objektu a všech jeho podobjektů. Tato funkce má stejný efekt, jako by jste na všech objektech příslušného podstromu použili funkci Objekt - Aktualizovat název a ikonu.
    Součet - v okně vyberte ještě vlastnost, jejíž součet chcete spočítat. Způsob, jakým je součet počítán je popsán v kapitole Použití součtu pro výpočet hodnoty vlastnosti.


Tisk objektu

  1. Ve Stromu objektů vyberte objekt, který má být podkladem pro tiskovou sestavu. Může to být jedna počítačová sestava, jeden organizační útvar nebo celá firma, případně jiné objekty.
  2. Na položce stiskněte pravé tlačítko myši a z nabídky vyberte povel Tisk.
  3. V seznamu souborů vyberte požadovanou tiskovou sestavu (přípona .rep) nebo připravený dotaz (přípona .epq).
  4. Další postup je závislý na předchozím výběru.
    1. Pokud jste si vybrali dotaz, na obrazovce se otevře dialogové okno pro bližší určení způsobu vyhodnocení dotazu.
    2. V případě některých tiskových sestav se otevírá dialogové okno pro zadání dalších hodnot.
  5. Na obrazovce se otevře okno Internet Exploreru® s náhledem na výslednou tiskovou sestavu. Sestavu můžete vytisknout na tiskárně povelem Soubor - Tisk.


Speciální objekty

Následující objekty ve Stromu objektů mají speciální účel. Tyto objekty jsou skryté. Jejich zobrazení můžete povolit pomocí povelu Pomůcky - Nastavení - Zobrazení.

Koš - do koše se přesouvají všechny odstraněné objekty. Obsah Koše můžete vysypat.

Šablony objektů - obsahuje vzorové objekty, podle kterých uživatel vytváří nové objekty ve stromu. Nový objekt se vytvoří okopírováním objektu v šablonách.

Záložky seznamu vlastností - definuje obsah záložek v Seznamu vlastností.

Šablony scanneru - vzor počítačové sestavy pro scanner.


Seznam vlastností

Seznam vlastností najdete v pravé horní části hlavního okna.

V seznamu vlastností jsou uvedeny vlastnosti objektu, který je právě vybrán ve stromu objektů. Zděděné a vlastní vlastnosti jsou rozlišeny první ikonou:
vlastní vlastnost
zděděná vlastnost

Na spodním okraji seznamu je umístěna řada záložek. Na každé záložce je zobrazena určitá podmnožina vlastností. Na první záložce Všechny jsou uvedeny všechny vlastnosti objektu, vlastní i zděděné. Druhá záložka Vlastní obsahuje pouze vlastní vlastnosti objektu. Další záložky jsou uživatelsky definované a obsahují určitou skupinu vlastností, jako např. technické, účetní, atd.

  • Vložit novou vlastnost
  • Změnit hodnotu vlastnosti
  • Odstranit vlastnost
  • Spočítat celkovou cenu
  • Upravit záložky


Nabídka vlastností

Seznam obsahuje všechny vlastnosti, které můžete vložit do objektů.

Nabídku vlastností můžete otevřít povelem Pomůcky - Seznamy - Definice vlastností z hlavní nabídky programu. V tom případě jsou tlačítka ve spodní části okna nasvícena a seznam můžete upravovat.

  • Vytvořit novou definici vlastnosti
  • Upravit definici vlastnosti
  • Odstranit definici vlastnosti


Vytvoření nové definice vlastnosti

A. Vytvoření zcela nové definice

  1. Povelem Pomůcky - Seznamy - Definice vlastností otevřete okno Nabídka vlastností
  2. V okně Nabídka vlastností stiskněte tlačítko Přidat.
  3. Na obrazovce se otevře dialogové okno Definice vlastnosti. V tomto okně zvolte název a ikonu vlastnosti a zapněte další volby pro nastavení vlastnosti jako je dědičnost, heslo, jedinečnost, implicitní hodnoty.

B. Vytvoření nové definice podle již existující definice

  1. Z hlavního menu vyberte volbu Pomůcky - Seznamy - Definice vlastností
  2. V okně Nabídka vlastností vyberte položku, podle které chcete vytvořit novou vlastnost, a stiskněte tlačítko Kopírovat.
  3. Na obrazovce se otevře dialogové okno nové Definice vlastnosti s přednastavenými hodnotami podle kopírované vlastnosti, které můžete změnit.


Úprava definice vlastnosti

  1. Z hlavního menu vyberte volbu Pomůcky - Seznamy - Definice vlastností
  2. Otevře se okno Nabídka vlastností, ze kterého vyberte vlastnost, jejíž definici chcete změnit, a stiskněte tlačítko Upravit.
  3. Na obrazovce se otevře dialogové okno Definice vlastnosti. V tomto okně zvolte název a ikonu vlastnosti a zapněte další volby pro nastavení vlastnosti jako je dědičnost, heslo, jedinečnost, implicitní hodnoty.


Odstranění definice vlastnosti

  1. Z hlavního menu vyberte volbu Pomůcky - Seznamy - Definice vlastností
  2. V okně Nabídka vlastností vyberte vlastnost, kterou chcete odstranit.
  3. Stiskněte tlačítko Odstranit.

Odstranit je možné pouze definice těch vlastností, které nejsou vloženy do žádného objektu (včetně objektů v Koši).


Vložení nové vlastnosti do objektu

  1. V seznamu vlastností klepněte pravým tlačítkem myši a z nabídky vyberte povel Vložit nový - Vlastnost.
  2. Na obrazovce se otevře Nabídka vlastností, ve které vyberte novou vlastnost. Pokud chcete vytvořit novou vlastnost, která ještě není v seznamu uvedena, musíte ji nejprve definovat.
  3. Poklepáním na vybranou vlastnost otevřete dialogové okno Vlastnost a zadejte hodnotu nové vlastnosti, případně upravte další nastavení.


Úprava vlastnosti objektu

  1. V Seznamu vlastností dvakrát klikněte levým tlačítkem na vlastnost, kterou chcete upravit.
  2. Na obrazovce se otevře dialogové okno Vlastnost ve kterém můžete změnit hodnotu vlastnosti a další nastavení.


Odstranění vlastnosti z objektu

  1. V Seznamu vlastností vyberte vlastnost, kterou chcete odstranit. Odstranit můžete pouze vlastní vlastnost objektu.
  2. Stiskněte klávesu Del nebo z nabídky Upravit vyberte povel Odstranit.

Upozornění:

Odstraněné vlastnosti jsou úplně vymazány a nepřesouvají se do Koše.


Použití součtu pro výpočet hodnoty vlastnosti

Příklad - výpočet celkové ceny počítačové sestavy

Tabulka znázorňuje objekt počítačová sestava s jeho podobjekty. Některé podobjekty obsahují vlastnost Cena. Celková cena počítačové sestavy bude součtem cen jejích podobjektů.

objekt |  | objekt má vlastnost Cena | hodnota vlastnosti Cena
počítačová sestava |  | ano | 41000
 | monitor | ano | 12000
 | počítač | ano | 15000
 | klávesnice | ne | -
 | myš | ne | -
 | tiskárna | ano | 14000

Hodnotu vlastnosti Cena u objektu počítačová sestava si můžete nechat spočítat takto:

  1. Ve stromu objektů vyberte počítačovou sestavu.
  2. V seznamu vlastností ukažte myší na vlastnost Cena a stiskněte pravé tlačítko myši.
  3. Z nabídky vyberte povel Funkce - Součet.
  4. Program oznámí spočítanou hodnotu. Dále si můžete vybrat, jestli chcete spočítanou hodnotu zapsat do vlastnosti Cena.

nebo:

  1. Ve stromu objektů vyberte počítačovou sestavu.
  2. Vyberte povel Objekt - Použít funkci.
  3. V okně vyberte funkci Součet a vlastnost Cena.
  4. Program oznámí spočítanou hodnotu. Dále si můžete vybrat, jestli chcete spočítanou hodnotu zapsat do vlastnosti Cena.


Záložky seznamu vlastností

Na spodním okraji Seznamu vlastností je umístěna řada záložek. První dvě záložky, Všechny a Vlastní, jsou pevné a všechny zbývající jsou uživatelsky definované.

Definice záložek najdete ve speciálním objektu Záložky seznamu vlastností. Každý jeho podobjekt představuje jednu záložku. Na záložce se potom zobrazují pouze vlastnosti, které jsou vloženy do příslušného podobjektu. Na hodnotách vlastností nezáleží. Název podobjektu se zobrazuje jako nápis na záložce.

Vlastnost __pořadí má v definici záložek speciální význam. Její číselná hodnota určuje pořadí záložky.

Tipy pro úpravu záložek

Podobjekty objektu Záložky seznamu vlastností představují jednotlivé záložky. Každý podobjekt obsahuje pouze ty vlastnosti, které se mají na záložce zobrazovat. Úpravy vlastností (vytvoření, odstranění, přesuny mezi záložkami,...) je vhodné provádět v seznamu vlastností vždy pouze na záložce Vlastní.

Po dokončení úprav stiskněte klávesu F5 nebo z hlavní nabídky vyberte povel Zobrazit - Obnovit. Teprve potom se provedené změny použijí.


Seznam poznámek a historie

Seznam poznámek a historie najdete v pravé spodní části hlavního okna.

V seznamu jsou zobrazeny poznámky a záznamy historie vztahující se k objektu, který je právě vybrán ve stromu objektů. Poznámky a záznamy historie jsou odlišeny ikonou:

  • poznámky
  • , [image], [image], [image] historie

Ve spodní části seznamu jsou umístěny záložky, kterými můžete volit režim zobrazení:

  • Historie - pouze záznamy historie
  • Poznámky - pouze poznámky
  • Vše - poznámky i záznamy historie
  • Vložit novou poznámku
  • Upravit existující poznámku
  • Odstranit poznámku
  • Změnit datum u záznamu historie
  • Najít objekt související se záznamem historie


Vložení nové poznámky do objektu

  1. V seznamu poznámek a historie stiskněte pravé tlačítko myši a z nabídky vyberte povel Nová poznámka.
  2. Na obrazovce se otevře dialogové okno, ve kterém můžete zadat datum a text poznámky.


Úprava poznámky

  1. V seznamu poznámek a historie vyberte poznámku, kterou chcete upravit.
  2. Stiskněte klávesu Enter nebo na poznámku poklepejte myší.
  3. Na obrazovce se otevře dialogové okno pro úpravu poznámky.


Odstranění poznámky

  1. V seznamu poznámek a historie vyberte poznámku, kterou chcete odstranit.
  2. Stiskněte klávesu Del nebo na poznámce stiskněte pravé tlačítko myši a z nabídky vyberte povel Odstranit poznámku.


Změna data záznamu historie

  1. V Seznamu poznámek a historie vyberte záznam historie, u kterého chcete změnit datum.
  2. Na záznamu stiskněte pravé tlačítko myši a z nabídky vyberte povel Upravit.
  3. Na obrazovce se otevře dialogové okno, ve kterém zadejte nové datum a případně také čas.


Označení objektu souvisejícího se záznamem historie

Záznam historie objektu může být vázán na jiný objekt. Například při přesunutí objektu A z objektu B do C se do historie objektu A vloží záznam z informací "objekt byl vložen do objektu C". V tomto případě je souvisejícím objektem objekt C.

Související objekt můžete ve Stromu objektů rychle vyhledat tak, že na záznamu historie poklepáte myší. Název objektu bude ve stromu zobrazen tučným písmem.


Panel nástrojů

Panel nástrojů je sada tlačítek, kterou najdete většinou v horní části hlavního okna.

Význam jednotlivých tlačítek zjistíte tak, že na tlačítko ukážete myší (bez použití tlačítek myši) a po chvíli se vedle tlačítka objeví malý popis.

Povely vyvolané prostřednictvím panelu nástrojů můžete najít také v hlavní nabídce programu.

  • Skrýt nebo zobrazit panel nástrojů


Skrýt nebo zobrazit Panel nástrojů

Panel nástrojů skryjete nebo zobrazíte povelem Panel nástrojů z nabídky Zobrazit.


Skrýt nebo zobrazit Stavový řádek

Stavový řádek skryjete nebo zobrazíte povelem Stavový řádek z nabídky Zobrazit.


Vyhledávání podle textu

  1. Z hlavní nabídky programu vyberte povel Upravit - Najít.
  2. Na obrazovce se otevře dialogové okno pro zadání hledaného textu.
    Popis okna:
    Hledaný text - zadejte text, který chcete hledat. Můžete použít znak * místo libovolného úseku textu.
    Příklady:
    Hledaný text: Program najde: Program nenajde:
    32 32 32 MB
    RAM 32 MB
    32* 32
    32 MB     		RAM 32 MB
    *32* 32
    32 MB
    RAM 32 MB
    Prohledat - označte sekce, ve kterých se může hledaný text nacházet.
    vlastnosti
    poznámky
    objekty

  3. Stiskněte tlačítko Hledat.
  4. Na obrazovce se otevře okno Parametry dotazu, ve kterém můžete změnit okruh prohledávaných objektů.
  5. Na závěr se otevře okno s Výsledky vyhledávání.


Vytvoření nového dotazu

  1. Z hlavní nabídky programu vyberte povel Dotaz - Nový.
  2. Na obrazovce se otevře Průvodce vytvořením dotazu - krok 1.
  3. Po dokončení práce s Průvodcem se otevře dialogové okno Vyhledávání - záložka Dotaz, ve kterém můžete vytvořený dotaz vyhodnotit, uložit do souboru na disk apod.


Úprava dotazu

  1. Z hlavní nabídky programu vyberte povel Dotaz - Upravit.
  2. Na obrazovce se otevře dialogové okno Vyhledávání - záložka Dotaz, ve kterém můžete upravit text dotazu, se kterým se pracovalo naposledy. Pokud chcete upravit dotaz uložený v souboru na disku, stiskněte tlačítko Načíst dotaz a vyberte příslušný soubor. Po provedení úprav dotaz můžete znovu uložit do souboru pomocí tlačítka Uložit dotaz.

Viz. Syntaxe dotazovacího jazyka


Vyhodnocení dotazu

  1. Pokud chcete dotaz vyhodnotit pouze pro určitý objekt, příslušný objekt vyberte ve stromu objektů.
  2. Z hlavní nabídky programu vyberte povel Dotaz - Upravit.
  3. Na obrazovce se otevře dialogové okno Vyhledávání - záložka Dotaz s naposled použitým dotazem. Pokud chcete pracovat s dotazem, který je uložen v souboru na disku, stiskněte tlačítko Načíst dotaz a vyberte příslušný soubor.
  4. Stiskněte tlačítko Vyhodnotit.
  5. Na obrazovce se otevře dialogové okno Parametry dotazu, ve kterém můžete určit rozsah prohledávaných objektů.
  6. Dotaz se vyhodnotí a na obrazovce se otevře okno s Výsledky vyhledávání.


Tisk výsledku dotazu

Tisk dotazu, který je uložen v souboru na disku

  1. Pokud chcete dotaz vyhodnotit pouze pro určitý objekt, příslušný objekt vyberte ve Stromu objektů.
  2. Z hlavní nabídky programu zvolte povel Soubor - Tisk.
  3. V seznamu souborů vyberte soubor s dotazem (přípona .epq).
  4. Na obrazovce se otevře dialogové okno pro bližší určení způsobu vyhodnocení dotazu.
  5. Na obrazovce se otevře okno Internet Exploreru® s náhledem na výslednou tiskovou sestavu. Sestavu můžete vytisknout na tiskárně povelem Soubor - Tisk.

Tisk aktuálního dotazu

  1. V hlavní nabídce programu zvolte povel Dotaz - Upravit.
  2. Na obrazovce se otevře dialogové okno Vyhledávání - záložka Dotaz, ve kterém stiskněte tlačítko Vyhodnotit.
  3. Případně upravte parametry pro vyhodnocení v dialogovém okně Parametry dotazu.
  4. V okně Výsledky vyhledávání, které se otevře, stiskněte tlačítko Tisková sestava.
  5. Na obrazovce se otevře okno Internet Exploreru® s náhledem na výslednou tiskovou sestavu. Sestavu můžete vytisknout na tiskárně povelem Soubor - Tisk.


Syntaxe dotazovacího jazyka

Dotaz=

[PARAMETERS Parametr [, Parametr ...] ]

SELECT [Dotaz_Typ] [AS [Nadpis=] Dotaz_Id]
[DOWN | UP | DEEP | SHALLOW | NEAREST | ALL]
[Sloupec_Nadpis [, Sloupec_Šířka %]=] [Dotaz_Id.] Vlastnost [Sloupec_Operátory]
[, [Sloupec_Nadpis [, Sloupec_Šířka %]=] [Dotaz_Id.] Vlastnost [Sloupec_Operátory] …]

[WHERE
[NOT] Filtr [AND | OR [NOT] Filtr …]]

[WITH
Dotaz [, Dotaz …]
[HAVING [NOT] Dotaz_Id [AND | OR [NOT] Dotaz_Id …]]
ENDWITH]

[GROUP BY
[Dotaz_Id.] Vlastnost ]

[ORDER BY
[Dotaz_Id.] Vlastnost [ASC | DESC]
[, [Dotaz_Id.] Vlastnost [ASC | DESC] ...]]

symbol: | význam:
| | nebo
[] | nepovinné
… | opakování

Popis argumentů

Parametr

Parametr dotazu je datová hodnota, kterou uživatel zadává v okamžiku vyhodnocení dotazu.

Parametr = Název_Parametru Typ_Parametru

kde

Název_Parametru
 Identifikuje parametr. Jednotlivé názvy parametrů musí být jedinečné a nesmí se shodovat s identifikátory sloupců. Pokud je název parametru složen z více slov, je nutné jej zapsat do hranatých závorek.

Typ_Parametru

T_TEXT | text
T_DOUBLE | reálné číslo
T_DATETIME | datum, čas

Příklad:
Chcete vypsat zásahy do počítačových sestav v zadaném časovém intervalu. Program se před vyhodnocením dotazu zaptá na hodnoty parametrů Od data a Do data.

PARAMETERS [Od data] T_DATETIME, [Do data] T_DATETIME
SELECT AS "Přehled zásahů"=S "Název sestavy"=[Název sestavy]
WHERE druh="Sestava"
WITH
SELECT HISTORY AS S1 "Provedl"=@user,"Popis"=@description
WHERE @date>=[Od data] AND @date<=[Do data]
HAVING s1
ENDWITH
Dotaz_Typ
Typ dotazu.
HISTORY | dotaz na položky historie objektu
NOTICE | dotaz na poznámky objektu
SWINST | dotaz na nainstalované softwarové produkty.

Dotaz typu HISTORY, NOTICE nebo SWINST může být použit pouze jako poddotaz a nesmí obsahovat další poddotazy. Navíc dotaz typu SWINST má význam pouze pokud je poddotazem dotazu, který vrací objekty druhu "sestava".

Příklad:
Chcete vypsat všechny poznámky objektů Počítačová sestava seřazené chronologicky.

SELECT AS "Poznámky objektů"=S0 WHERE druh="Sestava"
WITH
SELECT NOTICE AS S1 @date, @user, @description
ENDWITH
ORDER BY S1.@date

Příklad:
Chcete vypsat přehled všech počítačových sestav a nainstalovaných operačních systémů. Dále požadujete, aby výsledek byl seskupen podle nainstalovaných operačních systémů.

SELECT AS "Přehled nainstalovaných operačních systémů"=S "OS"=S1.@product, "Počítač"=@object, "Inventářní číslo"=[inventární číslo], "Uživatel"=[uživatel]
WHERE druh="sestava"
WITH
SELECT SWINST AS S1
WHERE @category=SW_OS
HAVING S1
ENDWITH
GROUP BY S1.@product

Nadpis
Nadpis výstupní sestavy.

Příklad:
Chcete vypsat všechny počítačové sestavy. V hlavičce sestavy bude text “Počítačové sestavy”.

SELECT AS "Počítačové sestavy"=S0 [Název sestavy]
WHERE Druh="Sestava"

Dotaz_Id

Identifikátor dotazu nebo poddotazu v sekci WITH. Pokud se ve dvou poddotazech vyskytují vlastnosti se stejným názvem, můžete k jejich rozlišení použít zápis Dotaz_Id.Vlastnost, např. "S0.Kapacita". V případě, že je identifikátor dotazu složen z více slov, zapište ho do hranatých závorek.

Příklad:
Chcete vypsat všechny počítačové sestavy a zajímají vás pouze údaje: Název sestavy, Klávesnice, Monitor. Vlastnosti Název z objektů monitor a klávesnice je třeba rozlišit identifikátorem poddotazu.

SELECT AS S0 [Název sestavy], S1.Název, S2.Název
WHERE Druh="Sestava"
WITH
SELECT AS S1 WHERE Druh="Klávesnice",
SELECT AS S2 WHERE Druh="Monitor"
ENDWITH

DOWN | UP | DEEP | SHALLOW | NEAREST | ALL
Modifikátory určují způsob vyhledávání objektů v poddotazech v sekci WITH.
DOWN | prohledávání směrem dolů, tj. prohledávání podstromu řídícího objektu (implicitní hodnota)
UP | prohledávání směrem nahoru, tj. prohledávají se všechny objekty na cestě ke kořeni stromu
DEEP | hledat ve všech potomcích řídícího objektu (implicitní hodnota)
SHALLOW | hledat pouze v přímých potomcích řídícího objektu (ne v potomcích potomků)
NEAREST | při nalezení nejbližšího objektu ukončit prohledávání do hloubky (implicitní hodnota)
ALL | prohledat celý podstrom řídícího objektu

Modifikátory NEAREST a ALL smysl pouze v kombinaci s modifikátorem DEEP, který zajistí prohledávání do hloubky.

Příklad:
Chcete vypsat počítačové sestavy a zajímají vás pouze údaje: Název sestavy, paměť RAM, HDD.
Dalším omezením je, že vás zajímá pouze paměť RAM umístěná na základní desce. Jako řídící objekt určíte objekt počítač PC.

Sestava 1 |  |  | Sestava 2
 | PC |  |  | PC
 |  | paměť RAM |  |  | paměť RAM
 |  | HDD |  |  | zvuková karta
 |  |  |  |  |  | paměť RAM
 |  |  |  |  | HDD

Z příkladu dvou počítačových sestav je patrné, že v sestavě 2 je ve zvukové kartě umístěna paměť. Abychom zabránili výpisu této paměti, je v dotazu S2 použit modifikátor SHALOW, který zajistí prohledávání pouze na úrovni objektu PC.
Modifikátor UP použity v dotazu S1 zajistí nalezení objektu Sestava, který se nachází nad objektem PC (počítač).

SELECT AS S0 S1.[Název sestavy], S2.@object, S3.@object
WHERE Druh="Počítač"
WITH
SELECT AS S1 UP WHERE Druh="Sestava",
SELECT AS S2 DOWN SHALLOW WHERE Druh="paměť RAM",
SELECT AS S3 DOWN WHERE Druh="Pevný disk"
ENDWITH

Sloupec_Nadpis
Určuje nadpis sloupce ve výstupní sestavě.

Příklad:
Chceme vypsat počítačové sestavy a zajímají vás údaje: Název sestavy, Pevný disk, Paměť RAM, Procesor. Sloupce ve výstupní sestavě budou mít nadpisy: Sestava, HDD, RAM , CPU.

SELECT AS S0 "Sestava"=[Název sestavy], "HDD"=S1.@object, "RAM"=S2.@object, "CPU"=S3.@object
WHERE Druh="Sestava"
WITH
SELECT AS S1 WHERE Druh="Pevný disk",
SELECT AS S2 WHERE Druh="Paměť RAM",
SELECT AS S3 WHERE Druh="Procesor"
ENDWITH

Pokud by jste nespecifikovali žádné nadpisy sloupců, sloupce by byly nadepsány: S1.Název, S2.Název, S3.Název.

Sloupec_Šířka
Specifikuje šířku sloupce ve výstupní sestavě. Šířka se zadává v procentech vzhledem k šířce celé sestavy.

Příklad:
Chcete vypsat počítačové sestavy a zajímají vás údaje: Název sestavy, Uživatel, Poschodí.
Dále vyžadujete, aby sloupec Název sestavy měl název Sestava a šířku 40% z šířky tiskové strany a sloupec Poschodí 20% z šířky strany.

SELECT "Sestava",50%=[Název sestavy], Uživatel, 20%=Poschodí
WHERE Druh="Sestava"

Vlastnost
Název vlastnosti. Pořadí sloupců v dotazu odpovídá jejich pořadí ve výstupní sestavě. Pokud je název vlastnosti složen z více slov, je nutné jej zapsat do hranatých závorek.

Jako Vlastnost můžete použít také tyto speciální hodnoty:

@notice | poznámky objektu
@property | libovolná vlastnost objektu
@object | název objektu
@date | datum záznamu historie, poznámky objektu nebo instalace sw produktu
@user | autor poznámky, záznamu historie objektu nebo instalace sw produktu
@flags | typy záznamu historie objektu (Pro dotazování na typy záznamů historie objektů použijte speciální konstanty viz Konstanty.)
@description
typ dotazu (Dotaz_Typ): | význam vlastnosti @description:
HISTORY | popis záznamu historie
NOTICE | text poznámky
SWINST | poznámka u záznamu historie instalací
@product | název softwarového produktu
@category | kategorie softwarového produktu (např. operační systém)
@type | typ softwarového produktu (např. vyžadující licenci, trial, ...)
@language | jazyková verze softwarového produktu
@producer | výrobce softwarového produktu
@serialnumber | sériové číslo softwarové licence

Speciální hodnoty lze použít pouze v dotazech typu HISTORY, NOTICE nebo SWINST.

Sloupec_Operátory
Uveďte jeden nebo více operátorů. Jednotlivé operátory se oddělují pouze mezerou.

Operátory:

SUM | součet hodnot
COUNT | počet položek
AVG | průměrná hodnota
MIN | minimální hodnota
MAX | maximální hodnota

Příklad:
Zjištění průměrné kapacity paměti v počítačových sestavách.

SELECT [Název sestavy], S1.Velikost AVG
WHERE Druh="Sestava"
WITH
SELECT AS S1 WHERE Druh="Paměť RAM"
ENDWITH

Na konci tiskové sestavy bude ve sloupci Velikost uveden průměr všech hodnot.

Filtr
Filtr je logický výraz určující podmínku. Podmínka se vyhodnocuje pro každý objekt. Objekt je vybrán do výsledku dotazu v případě, že je pro něho podmínka splněna.

Filtr= Vlastnost Porovnání Konstanta | OWN(Vlastnost) | INHERITED(Vlastnost)

kde

Porovnání

= | rovnost
like | výskyt podřetězce
<> | nerovnost
< | menší
> | větší
<= | menší nebo rovno
>= | větší nebo rovno

Funkce OWN() je splněna v případě, že vlastnost je vlastní vlastností objektu. Funkce INHERITED() je splněna pro zděděné vlastnosti.

Příklad:
Pro vyhledání všech tiskáren značky HP použijeme filtr omezující seznam tiskáren na tiskárny, jejichž název začíná dvojicí znaků "HP".

Druh=”Tiskárna” AND Název LIKE ”HP*”

Příklad:
Vyhledání všechny pamětí RAM menších než 64 MB.

Druh=”paměť RAM” AND Velikost<64
Konstanta
Konstanta může být reálné číslo nebo textový řetězec. V textovém řetězci lze použít hvězdičkovou notaci ‘*‘ pro určení libovolného počtu znaků.

Speciální konstanty - typy záznamů historie objektu

H_MOVEDEST | sem přesunut objekt "x"
H_MOVESRC | odtud přesunut objekt "x"
H_TO | objekt přesunut do "x"
H_INSERTNEW | sem vložen nový objekt "x"
H_TONEW | objekt vytvořen v "x"
H_SCANMMOVEDEST | sem přesunut objekt "x" - scannerem
H_SCANMOVESRC | odtud přesunut objekt "x" - scannerem
H_SCANTO | objekt přesunut do "x" - scannerem
H_SCANINSERTNEW | sem vložen nový objekt "x" - scannerem
H_SCANTONEW | objekt vytvořen v "x" - scannerem

Speciální konstanty - typy softwarových produktů

SW_NEEDSLIC | komerční - uživatel musí zakoupit licenci k používání prodiktu
SW_NOLIC | freeware (nevyžaduje licenci) - produkt je možné používat bez licence
SW_TRIALLIC | shareware/trial - produkt je možné vyzkoušet bez licence

Speciální konstanty - kategorie softwarových produktů

SW_OS softwarový produkt je operační systém

Příklad:
Vyhledání všech pamětí RAM menších než 64 MB.

Druh=”paměť RAM” AND Velikost<64

Příklad:
Vyhledání záznamů historie odstraněných (přesunutých) objektů po 1.1.2001.

@date>"1.1.2001" AND ( @flag=H_MOVESRC OR @flags=H_SCANMOVESRC )

Příklad:
Vyhledání všech freewarových softwarových produktů.

@type=SW_NOLIC

Příklad:
Vyhledání všech operačních systému nainstalovaných po 1.1.2001.

@category=SW_OS AND @date>"1.1.2001"

WITH ... WNDWITH
Mezi klíčová slova WITH a ENDWITH se zapisuje seznam poddotazů. Jednotlivé poddotazy se oddělují čárkami.

Kluzule HAVING určuje, které poddotazy v seznamu musí obsahovat alespoň jeden objekt proto, aby byl řídící objekt vybrán.

Příklad:
Chcete vypsat počítačové sestavy, které nemají pevný disk.

SELECT AS "Sestavy bez HDD"=S0 [Název sestavy]
WHERE Druh="Sestava"
WITH
SELECT AS HDD WHERE Druh="Pevný disk"
HAVING NOT HDD
ENDWITH

GROUP BY
Určuje sloupec, podle kterého se budou nalezené položky seskupovat. Sloupec musí být uveden v seznamu sloupců za klíčovým slovem SELECT.

Příklad:
Chcete vypsat počítačové sestavy a seskupit je podle Poschodí.

SELECT AS "Sestavy seskupené podle poschodí"=S0 [Název sestavy], Poschodí
WHERE Druh="Sestava"
GROUP BY Poschodí

ORDER BY
Složí k řazení hodnot sloupců ve výstupní sestavě. Priorita řazení je dána pořadím sloupců za klíčovým slovem ORDER BY. Všechny sloupce, podle kterých se bude řadit, musí být uvedeny v seznamu sloupců za klíčovým slovem SELECT.

Modifikátory ASC a DESC určují směr řazení:

ASC | vzestupně (implicitně)
DESC | sestupně

Příklad:
Seznam počítačových sestav seřazený podle sloupců Poschodí, Uživatel.

SELECT AS "Sestavy počítačů seřazené podle poschodí a uživatele"=S0 [Název sestavy], Uživatel, Poschodí
WHERE Druh="Sestava"
ORDER BY Poschodí, Uživatel


Adresář organizací

Adresář organizací slouží k evidování prodejců a výrobců od kterých nakupujete software a hardware. Tato evidence je přimo propojena s evidencí Doklady (hlavní menu - pomůcky - seznamy - doklady), kde se používá především pro evidování nákupu licencí software.

Do okna Adresář organizací se dostanete z hlavní nabídky povelem Pomůcky - Seznamy - Adresář organizací

Jak udělat ...

  • Přidat novou firmu
  • Upravit údaje o firmě
  • Smazat firmu
  • Nastavit zařazení firmy mezi prodejce/výrobce


Vložení nové firmy do databáze

  1. Povelem Pomůcky - Seznamy - Adresář organizací otevřete okno Adresář organizací.
  2. Myší klepněte na tlačítko Přidat které otevře okno Nová organizace.
  3. V okně vyplňte následující údaje:
    • Do vstupního pole Název napište jméno firmy.
    • Do vstupního pole Web (http://..) napište adresu Internetových stránek firmy.
    • Do vstupního pole Telefon napište telefonní číslo firmy.
    • V položce zařezení vyberte klepnutím do checkboxu zda jde o výrobce, prodejce, nebo obojí.
    • Do vstupních polí Ulice napište ulici sídla firmy (k dispozici jsou dvě vstupní pole).
    • Do vstupního pole Město napište město, ve kterém firma sídlí.
    • Do vstupního pole PSČ/ZIP napište poštovní směrovací číslo (ČR), nebo ZIP kód (zahraničí).
    • Do vstupního pole Země napište ve které zemi firma sídlí.
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.

Poznámka:

Všechna pole vyjma položky Název jsou nepovinná.


Úprava údajů o firmě v databázi

  1. Povelem Pomůcky - Seznamy - Adresář organizací otevřete okno Adresář organizací.
  2. Myší vyberte položku kterou chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit.
  4. V okně vyplňte následující údaje:
    • Do vstupního pole Název napište jméno firmy.
    • Do vstupního pole Web (http://..) napište adresu Internetových stránek firmy.
    • Do vstupního pole Telefon napište telefonní číslo firmy.
    • V položce zařezení vyberte klepnutím do checkboxu zda jde o výrobce, prodejce, nebo obojí.
    • Do vstupních polí Ulice napište ulici sídla firmy (k dispozici jsou dvě vstupní pole).
    • Do vstupního pole Město napište město, ve kterém firma sídlí.
    • Do vstupního pole PSČ/ZIP napište poštovní směrovací číslo (ČR), nebo ZIP kód (zahraničí).
    • Do vstupního pole Země napište ve které zemi firma sídlí.
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.

Poznámka:

Všechna pole vyjma položky Název jsou nepovinná.


Vymazání firmy z databáze

  1. Povelem Pomůcky - Seznamy - Adresář organizací otevřete okno Adresář organizací.
  2. Klepnutím levého tlačítka myši vyberte firmu (s klávesou ctrl, nebo shift je možné vybrat více položek) kterou chcete smazat.
  3. Myší klepněte na tlačítko Odstranit.
  4. V dialogovém okně klepněte levým tlačítkem myši na tlačítko Ano (pro kontrolu je v okně uveden počet záznamů, které chcet smazat).


Zařazení firmy mezi prodejce/výrobce

  1. Povelem Pomůcky - Seznamy - Adresář organizací otevřete okno Adresář organizací.
  2. Myší vyberte položku kterou chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit.
  4. V položce zařezení vyberte klepnutím do checkboxu zda jde o výrobce, prodejce, nebo obojí.
  5. Pro uložení změn klepněte levým tlačítkem myši na položku Ok, pro zrušení změn na Storno.


Číselné řady

Evidence slouží k editaci číselných řad, podle kterých se budou číslovat doklady a média. Umožňuje před (a za) číslo umístit textovou předponu (a příponu).

Do okna Číselné řady se dostanete z hlavní nabídky povelem Pomůcky - Seznamy - Číselné řady

Jak udělat ...

  • Upravit číselnou řadu


Úprava číselné řady

  1. Povelem Pomůcky - Seznamy - číselné řady otevřete okno Číselné řady.
  2. Vyberet řadu, kterou chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit doklad.
  4. V okně vyplňte následující údaje:
    • Do vstupního řádku Předpona můžete napsat textovou předponu (nepovinné).
    • Do vstupního řádku Další číslo napište číslo, od kterého bude začínat číselná řada.
    • Do vstupního řádku Přípona můžete napsat textovou příponu (nepovinné).
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Doklady

Doklady slouží k zanesení podkladů (např. faktury) o koupi software nebo hardware do databáze. Jejich hlavní využití spočívá v evidenci zakoupených licencí (hlavní menu - software - přehled licencí vs. instalací).

Do okna doklady se dostanete z hlavní nabídky povelem Pomůcky - Seznamy - Doklady

Jak udělat ...

  • Vytvořit nový doklad
  • Upravit existující doklad
  • Smazat doklad


Vytvoření nového dokladu o koupi

  1. Povelem Pomůcky - Seznamy - Doklady otevřete okno Doklady.
  2. Myší klepněte na tlačítko Přidat které otevře okno Nový doklad.
  3. V okně vyplňte následující údaje:
    • Ze vstupního řádku se seznamem vyberte Datum vystavení dokladu.
    • Ze vstupního řádku se seznamem vyberte Dodavatele (zobrazí se pouze firmy označené jako prodejce – tip: pokud v seznamu firmu nenajdete, přes ikonu [image] se dostanete do adresáře organizací, kde je možné zadat novou firmu, nebo přes položkou upravit změnit zařazení existující firmy).
    • Do pole Poznámky napište poznámky k dokladu.
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Změna údajů v dokladu o koupi

  1. Povelem Pomůcky - Seznamy - Doklady otevřete okno Doklady.
  2. Myší vyberte doklad který chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit doklad.
  4. V okně vyplňte následující údaje:
    • Ze vstupního řádku se seznamem vyberte Datum vystavení dokladu.
    • Ze vstupního řádku se seznamem vyberte Dodavatele (zobrazí se pouze firmy označené jako prodejce – tip: pokud v seznamu firmu nenajdete, přes ikonu [image] se dostanete do adresáře organizací, kde je možné zadat novou firmu, nebo přes položkou upravit změnit zařazení existující firmy).
    • Do pole Poznámky napište poznámky k dokladu.
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Smazání dokladu o koupi

  1. Povelem Pomůcky - Seznamy - Doklady otevřete okno Doklady.
  2. Klepnutím levého tlačítka myši vyberte doklad (s klávesou ctrl, nebo shift je možné vybrat více dokladů) který chcete smazat.
  3. Myší klepněte na tlačítko Odstranit.
  4. V dialogovém okně klepněte levým tlačítkem myši na tlačítko Ano (pro kontrolu je v okně uveden počet dokladů, které chcet smazat).


Média

Evidence média slouží k evidování literatury a datových nosičů. Jejím hlavním účelem je spolupráce s evidencí zakoupených licencí (hlavní menu - software - přehled licencí vs. instalací).

Do okna doklady se dostanete z hlavní nabídky povelem Pomůcky - Seznamy - Média

Jak udělat ...

  • Přidat nové médium
  • Upravit údaje o médiu
  • Smazat údaje o médiu


Přidání nového média

  1. Povelem Pomůcky - Seznamy - Média otevřete okno Média
  2. Myší klepněte na tlačítko Přidat které otevře okno Nové médium.
  3. V okně vyplňte následující údaje:
    • Ze vstupního pole se seznamem vyberte Typ média (Literatura, CD, DVD, ...).
    • Do vstupního pole Název napište název média.
    • Do vstupního pole Autor napište Autora popřípadě výrobce média (produktu).
    • Do vstupního pole Poznámky napište poznámky k médiu.
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Změna údajů o médii

  1. Povelem Pomůcky - Seznamy - Média otevřete okno Média
  2. Myší vyberte médium které chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Nové médium.
  4. V okně vyplňte následující údaje:
    • Ze vstupního pole se seznamem vyberte Typ média (Literatura, CD, DVD, ...).
    • Do vstupního pole Název napište název média.
    • Do vstupního pole Autor napište Autora popřípadě výrobce média (produktu).
    • Do vstupního pole Poznámky napište poznámky k médiu.
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Vymazání záznamu o médiu

  1. Povelem Pomůcky - Seznamy - Média otevřete okno Média.
  2. Klepnutím levého tlačítka myši vyberte médium (s klávesou ctrl, nebo shift je možné vybrat více položek) který chcete smazat.
  3. Myší klepněte na tlačítko Odstranit.
  4. V dialogovém okně klepněte levým tlačítkem myši na tlačítko Ano (pro kontrolu je v okně uveden počet dokladů, které hodláte smazat).


Co je to Ikona

Ikony

Seznam obsahuje ikony, které můžete použít při zobrazení objektů a vlastností.

Do okna doklady se dostanete z hlavní nabídky povelem pomůcky - seznamy - ikony

Jak udělat ...

  • Vytvořit novou ikonu
  • Upravit obrázek ikony
  • Změnit název ikony
  • Odstranit ikonu


Vytvoření nové ikony

  1. Nejprve je třeba ikonu nakreslit a uložit ji do souboru jako obrázek ve formátu BMP. Ikona by měla mít rozměry 16x16 bodů a 16 barev ze standardní palety barev systému Windows®. K nakreslení ikony můžete použít program Malování, který je součástí Windows.
  2. Povelem Pomůcky - Seznamy - Ikony otevřete Nabídku ikon.
  3. V Nabídce ikon klepněte pravým tlačítkem myši, tak aby nebyla vybrána žádná existující ikona, a z nabídky vyberte povel Načíst ikonu ze souboru.
  4. Vyberte soubor s obrázkem ikony.
  5. Do nabídky ikon se přidá nová položka s názvem Nová ikona.
  6. Myší ukažte na nápis Nová ikona a jednou na něm klepněte myší.
  7. V nápisu se objeví textový kurzor. Na klávesnici napište název nové ikony a stiskněte klávesu Enter.


Změna názvu ikony

  1. Povelem Pomůcky - Seznamy - Ikony otevřete Nabídku ikon.
  2. V Nabídce ikon vyberte ikonu, jejíž název chcete změnit.
  3. Na položku poklepejte levým tlačítkem myši.
  4. Po chvíli se v názvu ikony objeví textový kurzor. Změňte název ikony a zadání ukončete klávesou Enter.


Úprava obrázku existující ikony

  1. Povelem Pomůcky - Seznamy - Ikony otevřete okno Nabídku ikon.
  2. V okně Nabídka ikon vyberte ikonu, jejíž obrázek chcete upravit.
  3. Na položku klepněte pravým tlačítkem myši a z nabídky vyberte povel Uložit ikonu do souboru.
  4. Zadejte název souboru, do kterého se má obrázek dočasně uložit.
  5. Upravte obrázek externím programem, např. programem Malování, který je součástí Windows®. Po skončení úprav obrázek uložte zpět do souboru.
  6. V Nabídce ikon opět klepněte pravým tlačítkem my myši na upravovanou ikonu a z nabídky vyberte povel Načíst ikonu ze souboru.
  7. Vyberte soubor s upraveným obrázkem.
  8. Dotaz zda chcete obrázek vložit do vybraných položek, potvrďte stiskem tlačítka Ano.


Odstranění ikony

  1. Povelem Pomůcky - Seznamy - Ikony otevřete Nabídku ikon.
  2. V Nabídce ikon vyberte ikonu, kterou chcete odstranit.
  3. Klepněte myší na tlačítko Odstranit.

Poznámka:

Odstranit je možné pouze ikonu, která není použita v žádném objektu ani definici vlastnosti.


Uživatelé

Evidence uživatelé slouží ke správě uživatelských účtů programu Evidence počítačů (je to obdoba účtů pro přístup do počítačové sítě). Umožňuje přidat dalšího správce (případně změnit heslo stávajícího), nebo vytvořit uživatele s plným, případně omezeným přístupem (pouze čtení, atp.).

Do okna doklady se dostanete z hlavní nabídky povelem Pomůcky - Seznamy - Uživatelé

Jak udělat ...

  • Přidat nového uživatele
  • Upravit práva nebo heslo existujícího uživatele
  • Smazat uživatele
  • Přidat správcovská práva uživateli


Přidání nového uživatele

  1. Povelem Pomůcky - Seznamy - Uživatelé otevřete okno Uživatelé.
  2. Myší klepněte na tlačítko Přidat které otevře okno Nový uživatel.
  3. V okně vyplňte následující údaje:
    • Do vstupního pole Jméno a Příjmení zadejte jméno a příjmení uživatele, pro kterého vytváříte účet (toto jméno se bude zobrazovat v seznamu uživatelů).
    • Do vstupního pole Přihlašovací jméno zadejte jméno, kterým se bude identifikovat uživatel při přihlášení.
    • Do vstupního pole Heslo zadejte heslo, kterým se bude identifikovat uživatel při přihlášení. Heslo se při zápisu bude ukazovat ve formě hvězdiček. Pozor: Dobře si zapamatujte správcovské heslo!
    • Do vstupního pole E-mail zadejte e-mailový účet uživatele.
    • Kliknutím do checkboxu zvolte práva uživatele.
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Změna hesla a přístupových práv uživatele

  1. Povelem Pomůcky - Seznamy - Uživatelé otevřete okno Uživatelé.
  2. Myší vyberte uživatele kterého chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit.
  4. V okně vyplňte následující údaje:
    • Do vstupního pole Jméno a Příjmení zadejte jméno a příjmení uživatele, pro kterého vytváříte účet (toto jméno se bude zobrazovat v seznamu uživatelů).
    • Do vstupního pole Přihalšovací jméno zadejte jméno, kterým se bude identifikovat uživatel při přihlášení.
    • Do vstupního pole Heslo zadejte heslo, kterým se bude identifikovat uživatel při přihlášení. Heslo se při zápisu bude ukazovat ve formě hvězdiček. Pozor: Dobře si zapamatujte správcovské heslo!
    • Do vstupního pole E-mail zadejte e-mailový účet uživatele.
    • Kliknutím do checkboxu zvolte práva uživatele.
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Vymazání uživatele z databáze

  1. Povelem Pomůcky - Seznamy - Uživatelé otevřete okno Uživatelé.
  2. Klepnutím levého tlačítka myši vyberte uživatele (s klávesou ctrl, nebo shift je možné vybrat více položek) kterého chcete smazat.
  3. Myší klepněte na tlačítko Odstranit.
  4. V dialogovém okně klepněte levým tlačítkem myši na tlačítko Ano (pro kontrolu je v okně uveden počet uživatelů, které chcet smazat).


Změna přístupových práv uživatele na správcovská

  1. Povelem Pomůcky - Seznamy - Uživatelé otevřete okno Uživatelé.
  2. Myší klepněte na tlačítko Upravit které otevře okno Upravit.
  3. Kliknutím do checkboxu zvolte položku správce, tak aby byla zaškrtnutá.
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Produkty

Produkt je software (aplikace), případně softwarový balík jako Evidence počítačů, Word 2000, Office 2000, nebo AutoCAD.
Evidence produkty slouží k evidování nakoupených licencí k softwarovým produktům a evidování instalací software na jednotlivých počítačích.

Jak udělat ...

  • Přidat nový produkt
  • Upravit údaje o produktu
  • Odstranit produkt z databáze
  • Změnit licenci (freeware, shareware, komerční) produktu


Vložení nového produktu do databáze

  1. Povelem Pomůcky - Seznamy - Produkty (software) otevřete okno Produkty.
  2. Myší klepněte na tlačítko Přidat které otevře okno Nový produkt.
  3. V okně vyplňte následující údaje:
    • Do vstupního pole Název napište název produktu (programu).
    • Ze vstupního řádku se seznamem Jazyková mutace vyberte jazykovou mutaci produktu.
    • Ze vstupního řádku se seznamem vyberte Dodavatele (zobrazí se pouze firmy označené jako výrobce – tip: pokud v seznamu firmu nenajdete, přes ikonu [image] se dostanete do adresáře organizací, kde je možné zadat novou firmu, nebo přes položkou upravit změnit zařazení existující firmy)
    • Klepnutím na přepínač Typ produktu - licence zvolte licenci produktu (Komerční - Shareware/Trial - Freeware).
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.

Poznámka:

Všechna pole vyjma položky Název jsou nepovinná, pokud nevyberete žádnou položku v přepínači licence, je produkt automaticky považován za komerční.


Úprava údajů o produktu v databázi

  1. Povelem Pomůcky - Seznamy - Produkty (software) otevřete okno Produkty.
  2. Myší vyberte položku kterou chcete upravit.
  3. Myší klepněte na tlačítko Upravit které otevře okno Upravit (produkt).
  4. V okně vyplňte následující údaje:
    • Do vstupního pole Název napište název produktu (programu).
    • Ze vstupního řádku se seznamem Jazyková mutace vyberte jazykovou mutaci produktu.
    • Ze vstupního řádku se seznamem vyberte Dodavatele (zobrazí se pouze firmy označené jako výrobce – tip: pokud v seznamu firmu nenajdete, přes ikonu [image] se dostanete do adresáře organizací, kde je možné zadat novou firmu, nebo přes položkou upravit změnit zařazení existující firmy)
    • Klepnutím na přepínač Typ produktu - licence zvolte licenci produktu (Komerční - Shareware/Trial - Freeware).
  5. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.

Poznámka:

Všechna pole vyjma položky Název jsou nepovinná, pokud nevyberete žádnou položku v přepínači licence, je produkt automaticky považován za komerční.


Vymazání záznamu o produktu

  1. Povelem Pomůcky - Seznamy - Produkty otevřete okno Produkty.
  2. Klepnutím levého tlačítka myši vyberte produkt (s klávesou ctrl, nebo shift je možné vybrat více dokladů) který chcete smazat.
  3. Myší klepněte na tlačítko Odstranit.
  4. V dialogovém okně klepněte levým tlačítkem myši na tlačítko Ano (pro kontrolu je v okně uveden počet produktů, které chcet smazat).


Změna licence produktu

  1. Povelem Pomůcky - Seznamy - Produkty (software) otevřete okno Produkty.
  2. Myší klepněte na tlačítko Upravit které otevře okno Upravit (produkt).
  3. Klepnutím na přepínač Typ produktu - licence zvolte licenci produktu (Komerční - Shareware/Trial - Freeware).
  4. Pro uložení změn klepněte levým tlačítkem myši na tlačítko Ok, pro zrušení změn na Storno.


Evidence software

Přístup k součásti Evidence software je podmíněn zakoupením odpovídající licence k používání programu.

Evidence software je založena na evidenci nakoupených licencích softwarových produktů a evidenci instalací/odinstalací produktů na jednotlivých počítačích.

Na základě těchto evidovaných údajů lze sestavit softwarový audit v organizaci.

  • Evidence licencí
  • Evidence instalací
  • Porovnání stavu licencí se stavem instalací (softwarový audit)


Evidence licencí

Okno pro správu nakoupených licencí softwarových produktů vyvoláte povelem Evidence licencí z hlavní nabídky programu.

  • Zapsat novou licenci
  • Zapsat zrušení licence
  • Upravit údaje licence
  • Odstranit licenci z evidence


Okno Evidence licencí

Filtry:
filtr Produkt - vstupní pole se seznamem, ve kterém můžete vybrat produkt ke kterému se má zobrazit seznam licencí. Pokud je pole prázdné, zobrazí se všechny licence.
filtr Počítač - pro zjištění OEM verzí vázaných na konkrétní počítač, vyberte 1 počítač ze vstupního pole se seznamem. (tento filtr lze kombinovat s filtrem produkt).

Tabulka s daty:
sloupec Produkt - udává název produktu (software, nebo softwarového balíku).
sloupec Jazyk - udává jazykovou mutaci produktu.
sloupec Datum - udává datum, kdy byla licence zakoupena.
sloupec Datum platnosti- udává datum, do kdy je licence platná.
sloupec Změna - udává počet nakoupených, případně prodaných licencí. Zároveň indikuje typ licence - OEM, multi (multilicence).
sloupec Počítač - pokud se jedná o OEM licenci, je v poli uveden počítač, ke kterému je licence vázána, jinak je pole prázdné.
sloupec Poznámka - v poli se ukazuje poznámka k licenci.

Nová - otevře Průvodce zapsáním nové licence.
Upravit - otevře okno pro úpravu údajů vybrané licence.
Zrušit - otevře Průvodce zrušením licence. Pokud nechcete evidovat historií nakoupených licencí, odstraňte neplatné licence z evidence povelem Odstranit z evidence.
Odstranit z evidence - nevratné odstranění vybraných záznamů z evidence.
Zavřít - ukončí dialogové okno.


Zapsání nové licence

  1. Z hlavní nabídky programu vyberte povel Software - Evidence licencí.
  2. Na obrazovce se otevře dialogové okno Evidence licencí. Stiskněte tlačítko Nová.
  3. Na obrazovce se otevře Průvodce zapsáním nové licence.
  4. Po dokončení práce s Průvodcem se do databáze vloží záznam o nové licenci.


Zapsání nové licence

Zrušení licence

  1. Z hlavní nabídky programu vyberte povel Software - Evidence licencí.
  2. Na obrazovce se otevře dialogové okno Evidence licencí. Označte nakoupenou licenci, kterou chcete zrušit a stiskněte tlačítko Zrušit.
  3. Na obrazovce se otevře Průvodce zrušením licence.
  4. Po dokončení práce s Průvodcem se do databáze vloží záznam o zrušení licence.


Úprava údajů licence

  1. Z hlavní nabídky programu vyberte povel Software - Evidence licencí.
  2. Na obrazovce se otevře dialogové okno Evidence licencí.
  3. V seznamu vyberte záznam, který hodláte upravit, a stiskněte tlačítko Upravit.
  4. Na obrazovce se otevře dialogové okno Upravit pro úpravu údajů.

Záznamy o nakoupené a zrušené licenci se liší pouze ve znaménku položky počet licencí. Zrušené licence mají znaménko záporné.


Odstranění licence z evidence

  1. Z hlavní nabídky programu vyberte povel Software - Evidence licencí.
  2. Na obrazovce se otevře dialogové okno Evidence licencí.
  3. V seznamu vyberte záznam, který hodláte z evidence odstranit, a stiskněte tlačítko Odstranit z evidence.


Evidence instalací

Okno pro správu instalací softwarových produktů vyvoláte povelem Evidence instalací z hlavní nabídky programu.

  • Přidat nový záznam do Evidence instalací
  • Upravit údaje záznamu
  • Odstranit záznam z Evidence instalací


Okno Evidence instalací

Filtry:
filtr Produkt - vstupní pole se seznamem, ve kterém můžete vybrat produkt ke kterému se má zobrazit seznam instalací na počítačích. Pokud je pole prázdné, zobrazí se instalace všech produktů.
filtr Počítač - vstupního pole se seznamem, ve kterém si můžete zvolit počítač ke kterému chcete vypsat seznam nainstalovaného software. Pokud je pole prázdné - filtr není aktivní. (tento filtr lze kombinovat s filtrem produkt).

Tabulka s daty:
sloupec Produkt - udává název produktu (software, nebo softwarového balíku).
sloupec Jazyk - udává jazykovou mutaci produktu.
sloupec Počítač - udává jméno počítače, na který je produkt nainstalován.
sloupec Datum - udává datum vytvoření záznamu (instalace, odinstalace, ...).
sloupec Typ - udává typ záznamu (instalace, odinstalace, ...).
sloupec Provedl - udává jméno uživatele, který tento záznam vytvořil.

Seznam instalací/odinstalací - obsahuje seznam záznamů o instalacích a odinstalacích softwarových produktů. Jednotlivé typy záznamů jsou odlišeny ikonou.
Produkt - filtr Seznamu. V seznamu se zobrazí jen záznamy týkající se vybraného produktu.
Počítač - filtr Seznamu. V seznamu se zobrazí jen záznamy týkající se vybraného počítače.
Přidat - otevře Průvodce přidáním záznamů o instalaci nebo odinstalaci softwarového produktu.
Upravit - otevře okno pro úpravu údajů vybraného záznamu.
Odstranit - odstraní vybraný záznam z evidence.
Zavřít - ukončí dialogové okno.


Zapsání nového záznamu Evidence instalací

  1. Z hlavní nabídky programu vyberte povel Software - Evidence instalací.
  2. Na obrazovce se otevře dialogové okno Evidence instalací. Stiskněte tlačítko Nová.
  3. Na obrazovce se otevře Průvodce přidáním nového záznamu Evidence instalací.
  4. Po dokončení práce s Průvodcem se do databáze vloží záznam.


Úprava údajů záznamu Evidence instalací

  1. Z hlavní nabídky programu vyberte povel Software - Evidence instalací.
  2. Na obrazovce se otevře dialogové okno Evidence instalací.
  3. V seznamu vyberte záznam, který hodláte upravit, a stiskněte tlačítko Upravit.
  4. Na obrazovce se otevře dialogové okno Upravit pro úpravu údajů.


Odstranění záznamu z Evidence instalací

  1. Z hlavní nabídky programu vyberte povel Software - Evidence instalací.
  2. Na obrazovce se otevře dialogové okno Evidence instalací.
  3. V seznamu vyberte záznam, který hodláte z evidence odstranit, a stiskněte tlačítko Odstranit z evidence.


Přehled licencí vs. instalací

Evidence Přehled licencí vs. instalací (software) slouží k evidování a porovnávání stavů nakoupených instalací a skutečně nainstalovaných programů v počítačích, které byly zjištěny vzdáleným sběrem údajů. V tomto okně se dozvíte v jednom řádku kolik máte přesně nakoupených licencí k danému programu normálních/OEM/multilicencí, na kolika počítačích máte program nainstalovaný a případný rozdíl (přebívající/chybějící licence).

Do okna přehled licencí vs. instalací se dostanete z hlavní nabídky povelem Software - Přehled licencí vs. instalací

Popis jednotlivých částí okna (hlavní nabídka):

nabídka Licence
  • Použít licenci z počítače - některé produkty je možné legálně nainstalovat na stolní počítač i notebook a vlastnit pouze 1 licenci (např. MS Office). Položka spustí dialog, ve kterém vyberete stolní počítač, ze kterého má být licence použita. Indikuje se ve spodní části okna - sloupec Licence z počítače
  • Evidence licencí - otevře okno pro správu nakoupených licencí softwarových produktů.
nabídka Instalace
  • Zkušební instalace - označí vybranou instalaci programu na počítači jako zkušební (časově, nebo jinak omezenou - nevyžaduje licenci). Indikuje se ve spodní části okna - sloupec Zkušební verze/trial
  • Evidence instalací - otevře okno pro správu instalací softwarových produktů.
nabídka Zobrazit
  • Panel nástrojů - zobrazí nebo skryje panel nástrojů [image]. Zatržítko značí, že má být panel zobrazen.
  • Detail produktu - otevře okno s informacemi o softwarovem produktu a možností jejich úpravy.
  • Nezobrazit freeware - filtr, který zabrání zobrazování freeware/trial produktů v seznamu.
  • Obnovit - znovu načte všechny údaje do tabulky.
nabídka Tisk
  • Porovnání instalací a licencí - vytvoří (nabídne k tisku) tabulku se seznamem všeho nainstalovaného software a licencí. Vypíše, jaké licence vám přebývají a jaké vám chybí.

Popis jednotlivých částí okna (tabulka produktů):

sloupec Product - udává název produktu (software, nebo softwarového balíku).
sloupec Jazyk - označuje jazykovou mutaci daného produktu (software, nebo softwarového balíku).
sloupec Normální licence - udává počet vámi vlastněných licencí k danému produktu.
sloupec OEM licence - udává počet vámi vlastněných OEM licencí k danému produktu.
sloupec Multilicence - udává počet vámi vlastněných multilicencí k danému produktu.
sloupec Celkem instalací - udává počet instalací vybraného produktu.
sloupec Normální instalace - udává počet normálních instalací vybraného produktu.
sloupec OEM instalací - udává počet OEM instalací vybraného produktu.
sloupec Trial instalace - udává počet zkušebních instalací vybraného produktu.
sloupec Notebook instalace - některé produkty je možné legálně nainstalovat na stolní počítač i notebook a vlastnit pouze 1 licenci (např. MS Office). Sloupec slouží k evidování instalací na notebooku.
sloupec Chybí celkem - vás upozorňuje, že máte nainstalováno více prouktů, než máte instalací. Číslo udává počet chybějících licencí.
sloupec Normální přebývá - vám ukazuje počet normálních licencí které máte navic (nejsou nainstalovány na žádném počítači).
sloupec OEM přebývá - vám ukazuje počet OEM licencí které máte navic (nejsou nainstalovány na počítačích, ke kterým patří).
sloupec Typ - udává druh licence software (komerční/shareware/trial/freeware).
sloupec Výrobce - udává výrobce produktu (software).

Slovník pojmů:

OEM - software nakoupený přímo s počítačem, který může být instalován pouze na počítač se kterým byl koupen.
Multilicence - je v této tabulce chápána jako licence pro neomezený počet počítačů.
Instalace - je v této tabulce chápána jako nainstalovaný produkt (software) v počítači.
Trial - zkušební verze programů, většinou časově, nebo funkčně omezená.
Notebook instalace - některé produkty je možné legálně nainstalovat na stolní počítač i notebook a vlastnit pouze 1 licenci (např. MS Office).

Popis jednotlivých částí okna (tabulka instalovno na počítač):

sloupec Instalováno na - názvy počítačů, na kterých je nainstalován vybraný produkt.
sloupec Zkušební instalace/trial - označí vybranou instalaci programu na počítači jako zkušební (časově, nebo jinak omezenou - nevyžaduje licenci). Indikuje se ve spodní části okna - sloupec Zkušební verze/trial.
sloupec Licence z počítače - některé produkty je možné legálně nainstalovat na stolní počítač i notebook a vlastnit pouze 1 licenci (např. MS Office). Sloupec slouží k indikaci, ze kterého stolního počítače licence pochází.
sloupec Počítač v objektu - udává počet vámi vlastněných OEM licencí k danému produktu.


Detekce - přehled

Přístup k součásti Detekce - vzdálený sběr údajů je podmíněn zakoupením odpovídající licence k používání programu.

Detekce lze rozdělit na 3 skupiny:

  1. Vzdálené detekce s použitím Agenta
    Na detekovaných počítačích musí být nainstalován Agent. Komunikace mezi Agenty a počítačem s Evidencí probíhá přes sdílenou složku. Do sdílené složky uživatel nejprve vloží požadavek na provedení detekce. Agenti na základě tohoto požadavku provedou detekce a výsledky uloží opět do sdílené složky, odkud si je program Evidence počítačů vyzvedne.
  2. Vzdálené detekce bez použití Agenta
    Tyto typy detekcí může použít pouze síťový administrátor pro získání údajů o počítačích s operačními systémy Windows 2000 nebo XP. (K provedení detekce se také používá sdílená složka, ale pouze interně v rámci programu Evidence počítačů.)
  3. Ruční detekce
    Tato metoda je určena pro detekci údajů o počítačích, které nejsou připojeny do počítačové sítě.

V každé ze 3 výše uvedených skupin najdeme následující 3 typy detekcí:

  • Detekce zařízení (viz. Detekce zařízení počítačů, Aktualizace údajů zařízení počítačů)
  • Zjednodušená detekce software
  • Úplná detekce software

V případě zjednodušené evidence se nainstalované programy zjišťují pouze na základě údajů z registru počítačů. Údaje z registru lze získat tzv. Zjednodušenou detekcí software.
Při úplné evidenci se sledují soubory na discích počítačů. Pomocí vzorů software se potom na základě souborů určuje, jaké aplikace jsou na počítači nainstalovány. Seznam souborů na disku počítače se získá tzv. Úplnou detekcí software.
Režim evidence software přepnete povelem Pomůcky - Nastavení - záložka Evidence software. Možnost volby režimu může být omezena sadou, pro jakou máte zakoupenu licenci.
V obou režimech můžete vést pouze Evidenci instalací a Evidenci licencí nechat prázdnou, pokud vás nezajímá srovnání nakoupených a nainstalovaných programů.

Před zadáním požadavků na detekci nastavte sdílenou složku.


Vzdálený sběr údajů o počítačích a jejich přidání do evidence

Detekce zařízení počítačů

Při prvotním načtení zařízení počítačů v síti postupujte takto:

  1. V hlavní nabídce programu vyberte položku Detekce a povel Vzdálená. Na obrazovce se po chvíli otevře okno Seznam požadavků.
  2. Stiskněte tlačítko Nový pro otevření Průvodce vytvořením nového požadavku. V kroku výběru typu požadavku zvolte detekce zařízení. Po dokončení práce s Průvodcem se do seznamu požadavků vloží nový požadavek.
  3. Počkejte na odpovědi od jednotlivých klientský počítačů. Čas potřebný pro získání odpovědí je odvislý od frekvence detekce nových požadavků Agenty jednotlivých klientských počítačů.
  4. V seznamu požadavků vyberte požadavek, jehož odpovědi chcete zanést do databáze.
  5. V seznamu odpovědí vyberte požadované odpovědi a stiskněte tlačítko Zanést do databáze.
  6. Program otevře okno s nadpisem Rozdíly, ve kterém jsou ve stromu uvedeny jednotlivé počítačové sestavy. Počítače, které byly načteny, obsahují složku Operace, ve které najdete seznam operací pro zápis údajů o počítači do databáze.
  7. Stiskněte tlačítko Zavřít a potvrďte zápis navržených operací do databáze.
  8. V kořeni ve Stromu objektů se vytvoří pomocná složka "Nové počítače". V této složce jsou vytvořeny všechny načtené počítačové sestavy.


Aktualizace evidence pomocí vzdáleného sběru údajů

Aktualizace údajů zařízení počítačů

V této kapitole je popsán postup aktualizace evidence hardwarové konfigurace počítačů.

  1. V hlavní nabídce programu vyberte položku Detekce a povel Vzdálená. Na obrazovce se po chvíli otevře okno Seznam požadavků.
  2. Stiskněte tlačítko Nový pro otevření Průvodce vytvořením nového požadavku. V kroku výběru typu požadavku zvolte detekce zařízení. Po dokončení práce s Průvodcem se do seznamu požadavků vloží nový požadavek.
  3. Počkejte na odpovědi od jednotlivých klientský počítačů. Čas potřebný pro získání odpovědí je odvislý od frekvence detekce nových požadavků Agenty jednotlivých klientských počítačů.
  4. V seznamu požadavků vyberte požadavek, jehož odpovědi chcete zanést do databáze.
  5. V seznamu odpovědí vyberte požadované odpovědi a stiskněte tlačítko Zanést do databáze.
  6. Program otevře okno s nadpisem Rozdíly, ve kterém jsou ve stromu uvedeny jednotlivé počítačové sestavy. Sestavy, u kterých program zjistil nějaké odlišnosti oproti údajům v databázi, obsahují složku Rozdíly. Na jednotlivých položkách ve složce Rozdíly můžete pomocí pravého tlačítka myši otevřít nabídku a vybrat operaci, kterou se má zjištěný rozdíl odstranit. Tím se v dané sestavě objeví vedle složky Rozdíly nová složka Operace, jejíž položky popisují navržené operace.
    Takto postupně odstraňte zjištěné rozdíly, které chcete zanést do databáze.
  7. V průběhu odstraňování můžete stisknout tlačítko Zapsat operace do databáze, čímž se všechny připravené operace ve složkách Operace zapíší do databáze.
  8. Nakonec stiskněte tlačítko Zavřít a případně potvrďte zápis navržených operací do databáze.


Okno Rozdíly

Rozdíly

Okno slouží k zobrazení a odstranění rozdílů mezi konfiguracemi počítačových sestav uloženými v databázi a konfiguracemi načtenými vzdáleným sběrem. Princip odstranění rozdílů je založen na postupné eliminaci rozdílů navržením operací.

Strom rozdílů - strom rozdílů zobrazuje rozdíly mezi údaji počítačových sestav uloženými v databázi a údaji načtenými vzdáleným sběrem. Kořenové objekty představují počítače, jejichž konfigurace jsou uloženy v databázi nebo počítače dostupné v síti, které nejsou do databáze zaneseny. Jednotlivé počítače jsou od sebe odlišeny ikonou, viz. význam ikon. Sestavy, u kterých program zjistil nějaké odlišnosti oproti údajům v databázi, obsahují složku Rozdíly. Na jednotlivých položkách ve složce Rozdíly můžete pomocí pravého tlačítka myši otevřít nabídku a vybrat operaci, kterou se má zjištěný rozdíl odstranit. Tím se v dané sestavě objeví vedle složky Rozdíly nová složka Operace, jejíž položky popisují navržené operace. Podobně jako na položkách ve složce Rozdíly, můžete pomocí pravého tlačítka myši otevřít nabídku na jednotlivých položkách ve složce Operace a vybrat povel, kterým se připravená operace zruší. Připravenou operaci lze také zrušit poklepání levým tlačítkem myši na vybrané operaci. Položky rozdíly a operace jsou ve stromu pro přehlednost zvýrazněny tučně.
Operace
 | Navrhnout - stisknutím tlačítka spustíte návrhář operací pro automatické odstranění rozdílů. Program postupně odstraňuje rozdíly a navrhuje operace. Pokud program nedokáže rozdíl odstranit, vyzve Vás k jeho odstranění.
 | Zrušit - stisknutím tlačítka zrušíte všechny připravené operace včetně složky Operace. Zrušením operací se v sestavě objeví složka Rozdíly se všemi rozdíly, které tyto operace eliminovaly.
 | Zapsat do databáze - stisknutím tlačítka zapíšete všechny připravené operace ve složkách Operace do databáze.
 | Nastavení - stisknutím tlačítka otevřete okno pro nastavení návrháře operací
Rozdíly
 | počet rozdílů - číslo představuje celkový počet rozdílů ve všech počítačových sestavách.
 | tlačítka pro přechod mezi položkami rozdíly - stisknutím jednoho z tlačítek vyberete předcházející respektive následující rozdíl ve stromu rozdílů.
Zavřít - stisknutím tlačítka zavřete okno.

Jak udělat ...

  • Jak vytvořit vazbu mezi počítačem v databázi a skutečným počítačem na síti
  • Jak odstranit rozdíl na vlastnosti objektu
  • Jak odstranit rozdíl na objektu
  • Jak zrušit připravenou operaci


Ikony v seznamu počítačových sestav

ikona | popis | v databázi | v okolních počítačích
 | Počítač, který není zanesen do databáze, ale byl nalezen v seznamu okolních počítačů nebo do něj byl ručně přidán. | ne | ano
 | Počítač, který byl do databáze vložen ručně, tzn. že je bez vazby na skutečný počítač v seznamu okolních počítačů. | ano | ne
 | Počítač v databázi, který je navázán na skutečný počítač v seznamu okolních počítačů. | ano | ano
 | Počítač, který bude v databázi nově vytvořen podle údajů získaných ze skutečného počítače. | bude vytvořen | ano
 | Tato ikona symbolizuje, že jsou načteny údaje o tomto počítači pomocí vzdáleného sběru údajů. | - | -


Jak vytvořit vazbu mezi počítačem v databázi a skutečným počítačem na síti

Do databáze byl manuálně vložen objekt představující počítačovou sestavu. Navázání na skutečný počítač v síti provedete podle následujícího postupu.

  1. V okně Rozdíly ve stromu otevřete pravým tlačítkem myši na požadovaném počítači nabídku a vyberte povel Přiřadit sestavu (Počítač, který se nachází v databázi a nemá vazbu na skutečný počítač je označen ikonou [image], viz. význam ikon).

  2. Na obrazovce se otevře okno Seznam počítačů, ve kterém vyberte skutečný počítač ze sítě a potvrďte tlačítkem Ok.

  3. Odstraňte případně vzniklé rozdíly.


Jak odstranit rozdíl na vlastnosti objektu

  1. V okně Rozdíly ve stromu otevřete pravým tlačítkem myši na požadovaném rozdílů nabídku a vyberte povel podle typu rozdílu. Rozdíl na vlastnosti můžete odstranit také poklepání levým tlačítkem myši na položce rozdílu.


Jak odstranit rozdíl na objektu

  1. V okně Rozdíly ve stromu otevřete pravým tlačítkem myši na požadovaném rozdílu nabídku a vyberte povel podle typu rozdílu.
  2. Na obrazovce se otevře okno Návrhář operací, ve kterém vyberte požadovanou operaci


Jak zrušit připravenou operaci

  1. V okně Rozdíly ve stromu otevřete pravým tlačítkem myši na požadované operaci nabídku a vyberte povel podle Odstranit operaci. Operaci na vlastnosti nebo objektu můžete zrušit také poklepání levým tlačítkem myši na položce operace.


Návrhář operací

Okno Návrhář operací

Okno návrhář operací slouží pro manuální navržení operací k odstranění rozdílů mezi objekty položek okna Rozdílů. Mohou nastat dva případy.

A. V sestavě přebývá objekt

V počítačové sestavě, uložené v databázi, je objekt, který nemá adekvátní obraz v načteném počítači.

Ponechat - stisknutí tlačítka znamená ignorování rozdílu tj. nebude se navrhovat operace.
Přiřadit - stisknutí tlačítka znamená navržení operací pro přiřazení vybraného chybějícího objektu (objekt, který je vzdáleně načten a nemá protějšek v databázi) ze seznamu chybějících objektů. Jinými slovy přebývající objekt se přesune do sestavy, ve které by se měl nacházet chybějící objekt.
Přesunout do objektu - stisknutím tlačítka otevřete okno, ve kterém vyberete cílový objekt v databázi, do kterého se přesune přebývající objekt.
Smazat - stisknutí tlačítka znamená navržení operací pro přesunutí přebývajícího objektu do koše.

B. V sestavě chybí objekt

V počítačové sestavě, uložené v databázi, chybí objekt, který se nachází v aktuální načtené konfiguraci počítače.

Nevytvářet - stisknutí tlačítka znamená ignorování rozdílu tj. nebude se navrhovat operace.
Přiřadit - stisknutí tlačítka znamená navržení operací pro přiřazení vybraného přebývajícího objektu (objekt, který je v databázi a nemá protějšek v načtené konfiguraci) ze seznamu přebývajících objektů. Jinými slovy zmíněný přebývající objekt se přesune do sestavy, ve které by se měl nacházet chybějící objekt.
Přiřadit jiný objekt - stisknutím tlačítka otevřete okno, ve kterém vyberete objekt v databázi, který se použije pro navržení operací přiřazení k chybějícímu objektu. Jinými slovy vybraný objekt se přesune do sestavy, ve které by se měl nacházet chybějící objekt.
Vytvořit - stisknutí tlačítka znamená navržení operací pro vytvoření nového objektu tj. v sestavě se vytvoří nový objekt.

Příklad:
Z počítače A byl odebrán jeden paměťový modul a vložen do počítače B. Tato změna nebyla zanesena do databáze. Při aktualizaci konfigurací obou počítačů program zjistí, že v počítači A přebývá paměťový modul a v počítači B chybí paměťový modul oproti načteným údajům.


Produkty

Zjednodušená detekce software

Zjednodušená detekce software slouží k rozpoznání nainstalovaných softwarových produktů analýzou údajů z registru sledovaných počítačů.

  • Pořízení detekce údajů z registru souborů a její uložení do databáze
  • Vyhodnocení softwarových detekcí

Vedení Evidence licencí v režimu zjednodušené evidence má jedno úskalí způsobené tím, že se evidované programy rozlišují podle názvu, který se získá z registru počítače. Pokud bude na stanici nainstalován např. Microsoft Office 2000 Premium, v evidenci instalací se pro tento produkt vytvoří záznam a pro stejný produkt vytvoříte záznam také v evidenci licencí. Potom program bezplatně upgradujete na Office SR1. Zjednodušená detekce software vrátí jako název produktu Microsoft Office 2000 Premium SR1. Do Evidence instalací ze zapíše odinstalování původní verze a současně se vytvoří záznam o nainstalování verze SR1. Pokud budete chtít, aby program správně spároval licence a instalace, v evidenci licencí budete muset ručně změnit licenci na verzi SR1.


Produkty

Pořízení zjednodušené detekce software a její uložení do databáze

  1. V hlavní nabídce programu vyberte položku Detekce a povel Vzdálená. Na obrazovce se po chvíli otevře okno Seznam požadavků.
  2. Stiskněte tlačítko Nový pro otevření Průvodce vytvořením nového požadavku. V kroku výběru typu požadavku zvolte Zjednodušená detekce software. Po dokončení práce s Průvodcem se do seznamu požadavků vloží nový požadavek.
  3. Počkejte na odpovědi od jednotlivých klientský počítačů. Čas potřebný pro získání odpovědí je odvislý od frekvence detekce nových požadavků Agenty jednotlivých klientských počítačů.
  4. V seznamu požadavků vyberte požadavek, jehož odpovědi chcete zanést do databáze.
  5. V seznamu odpovědí vyberte požadované odpovědi a stiskněte tlačítko Zanést do databáze.
  6. Program spustí proces načtení výsledků detekcí do databáze. Načtení výsledků může trvat několik minut.
  7. V hlavní nabídce programu vyberte položku Detekce a povel Načtené v databázi. Na obrazovce se po chvíli otevře okno Detekce se seznamem právě načtených detekcí.


Produkty

Vyhodnocení načtených zjednodušených detekcí software

  1. V hlavní nabídce programu vyberte položku Detekce a povel Načtené v databázi. Na obrazovce se po chvíli otevře okno Detekce se seznamem načtených detekcí.
  2. Vyberte požadované detekce a stiskněte tlačítko Porovnat se stavem instalací pro otevření okna Evidence instalací vs. detekce software pro porovnání stavu evidovaných a nově nadetekovaných softwarových produktů.


Produkty

Úplná detekce software

Úplná detekce software slouží k rozpoznání nainstalovaných softwarových produktů analýzou všech spustitelných souborů a programových knihoven, které se nachází na detekovaných počítačích. Při analýze těchto souborů se využívá databáze vzorů softwarových produktů.

  • Pořízení detekce spustitelných souborů a její uložení do databáze
  • Vyhodnocení softwarových detekcí
  • Načtení vzorů softwarových produktů do databáze

V režimu úplné evidence tento problém nenastane, protože podle vzorů software se soubory verze SR1 detekují jako Office 2000 Premium. Verze SR1 se nerozlišuje, protože je kryta stejnou licencí jako Office 2000 Premium.


Produkty

Pořízení detekce spustitelných souborů a její uložení do databáze

  1. V hlavní nabídce programu vyberte položku Detekce a povel Vzdálená. Na obrazovce se po chvíli otevře okno Seznam požadavků.
  2. Stiskněte tlačítko Nový pro otevření Průvodce vytvořením nového požadavku. V kroku výběru typu požadavku zvolte Úplná detekce software. Po dokončení práce s Průvodcem se do seznamu požadavků vloží nový požadavek.
  3. Počkejte na odpovědi od jednotlivých klientský počítačů. Čas potřebný pro získání odpovědí je odvislý od frekvence detekce nových požadavků Agenty jednotlivých klientských počítačů.
  4. V seznamu požadavků vyberte požadavek, jehož odpovědi chcete zanést do databáze.
  5. V seznamu odpovědí vyberte požadované odpovědi a stiskněte tlačítko Zanést do databáze.
  6. Program spustí proces načtení výsledků detekcí do databáze. Načtení výsledků může trvat několik minut.
  7. V hlavní nabídce programu vyberte položku Detekce a povel Načtené v databázi. Na obrazovce se po chvíli otevře okno Detekce se seznamem právě načtených detekcí.


Produkty

Vyhodnocení načtených úplných detekcí software

  1. V hlavní nabídce programu vyberte položku Detekce a povel Načtené v databázi. Na obrazovce se po chvíli otevře okno Detekce se seznamem načtených detekcí.
  2. V seznamu vyberte požadovanou detekci a stiskněte tlačítko Vyhodnotit podle vzorů. Program provede analýzu načtených spustilených souborů podle databáze vzorů a rozpoznaným souborům přiřadí softwarové produkty. Ve sloupci Nepřiřazené soubory seznamu se zobrazí celkový počet souborů, ke kterým program nedokázal najít odpovídající produkt.
  3. Stiskněte tlačítko Upravit pro otevření okna Detekce software, ve kterém lze přiřadit nerozpoznané soubory produktům. Nerozpoznané soubory přiřaďte odpovídajícím stávajícím nebo nově vámi vytvořeným produktům. Po uzavření okna Detekce software se upraví hodnota ve sloupci Nepřiřazené soubory seznamu.
  4. Stiskněte tlačítko Porovnat se stavem instalací pro otevření okna Evidence instalací vs. detekce software pro porovnání stavu evidovaných a nově nadetekovaných produktů.

Po přiřazení nerozpoznaných souborů novým produktům se automaticky rozšíří databáze vzorů sotwarových produktů.


Detekce software

Přiřazení nalezených souborů ke vzorům

Okno Detekce software slouží k přiřazování nalezených souborů při úplné detekci software k produktovým vzorům. Pokud produkt ke kterému chcete nadetekované soubory přiřadit neexistuje v databázi, můžete jej přidat v okně Produkty.

Okno se skládá ze 3 částí:
Nepřiřazené soubory | - seznam všech nadetekovaných souborů, které nebyl program schopen přiřadit k některému z existujících vzorů.
Všechny soubory na discích | - všechny soubory na počítači. V levé části se nachází strom adresářů a v pravém soubory jednotlivých adresářů. Soubory přiřazené konkrétnímu produktu mají ikonu [image] a soubory nepřiřazené [image] .
Vzory | - v levé části je seznam vzorů produktů a v pravé soubory přiřazené k jednotlivým produktům.

Do okna Detekce software se dostanete z hlavní nabídky povelem Detekce - Načtené v databázi a výběrem z nadetekovaných údajů v databázi.

Jak udělat ...

  • Přidat nový produkt
  • Přidat nový produkt v průběhu přiřazování souboru
  • Přiřadit soubor k produktu
  • Zrušit přiřazení produktu
  • Zobrazit vzory odpovídající jednomu souboru
  • Zobrazit záznamy o programech v registru


Přidat nový produkt v průběhu přiřazování souboru

  1. Najděte soubor který chcete přiřazovat mezi nepřiřazenými soubory, nebo ve stromu adresářů a souborů.
  2. Klepněte na něj pravým tlačítkem a vyberte položku Přiřadit produkt.
  3. Pokud produkt není na seznamu, klepněte na tlačítko Jiný produkt...
  4. Otevře se Vám okno Produkty, jde o seznam všech produktů, které Evidence počítačů zná. Pokud nenajdete ani v tomto seznamu to co potřebujete, klepněte na tlačítko Přidat pro přidání nového záznamu.

  5. V okně Nový produkt napište údaje o novém produktu a stiskněte OK.
  6. V okně Produkty vyberte nově vytvořený produkt a stiskněte OK
  7. V okně Přiřadit soubory k produktu vyberte nově vložený produkt a stiskněte tlačítko OK.


Přiřazení souboru k produktu

  1. Najděte soubor který chcete přiřazovat mezi nepřiřazenými soubory, nebo ve stromu adresářů a souborů.
  2. Klepněte na něj pravým tlačítkem a vyberte položku přiřadit produkt.
  3. Vyberte produkt ze seznamu a stiskněte tlačítko OK.


Produkty

Zrušení přiřazení produktu

Zrušení přiřazení souboru - najděte soubor u kterého chcete zrušit přiřazení ve stormu adresářů a souborů, nebo v seznamu vzorů, klepněte na něj pravým tlačítkem a vyberte položku Zrušit přiřazení.


Zobrazit vzory odpovídající jednomu souboru

  1. Pravým tlačítkem klepněte na soubor u kterého chcete zobrazit ke kterým programům je přiřazen a vyberte položku vzory.


Produkty

Zobrazit záznamy o programech v registru

Zobrazit záznamy o programech v registru - V okně Detekce software stiskněte klávesu F4 a zobrazí se následující okno.


Vzdálený sběr údajů po síti

Vzory softwarových produktů

Vzory softwarových produktů slouží pro vyhodnocení údajů úplných detekcí software pořízených vzdáleným sběrem údajů.

  • Načíst vzory produktů do databáze
  • Uložit uživatelské vzory produktů do souboru


Vzdálený sběr údajů po síti

Načtení vzorů produktů do databáze

  1. Z hlavní nabídky programu vyberte povel Pomůcky - Vzory produktů (software) - Načíst.
  2. Na obrazovce se otevře Průvodce načtením vzorů produktů.
  3. Projděte postupně všechny kroky průvodce.


Vzdálený sběr údajů po síti

Uložení vzorů do souboru

  1. Z hlavní nabídky programu vyberte povel Pomůcky - Vzory produktů (software) - Uložit.
  2. Na obrazovce se otevře Průvodce uložením vzorů produktů.
  3. Projděte postupně všechny kroky průvodce.


Požadavek

Požadavek je příkaz pro vzdálený sběr údajů z počítačů v síti. Údaje z počítačů lze číst přímo prostřednictvím služby WMI nebo pomocí programových Agentů běžících na jednotlivých klientských stanicích.

Typy požadavků:

ikona | popis | Agent | vzdáleně přes WMI
 | Detekce zařízení. | ano |
 | Úplná detekce software. | ano |
 | Zjednodušená detekce software. | ano |
 | Detekce zařízení po síti (bez Agenta). |  | ano
 | Úplná detekce software po síti (bez Agenta). |  | ano
 | Zjednodušená detekce software po síti (bez Agenta). |  | ano
 | Instalace softwarového balíčku. | ano |

Ostatní:

ikona | popis
 | Odstranění požadavku.

  • Vytvoření nového požadavku
  • Odstranění požadavku


Seznam požadavků

Okno slouží k řízení vzdáleného sběru údajů.

Seznam požadavků - obsahuje seznam požadavků. Jednotlivé typy požadavků jsou odlišeny ikonou.
  • Typ - typ požadavku který jste zadali.
  • Poč. odpovědí/z - Počet zodpovězených požadavků / celkový počet požadavků.
  • Popis - vámi zvolený popis požadavku.
  • Datum - datum vytvoření požadavku.
  • Vytvořil - osoba zodpovědná za vytvoření požadavku.
  • Identifikace - identifikace požadavku.
Seznam odpovědí - seznam odpovědí na požadavek, který je právě vybrán v Seznamu požadavků.
  • Počítač - počítač, ke kterému se požadavek vztahoval.
  • Datum - datum zpracování požadavku.
  • Text zprávy - informace o stavu zpracování požadavku.

Nový - otevře Průvodce vytvořením nového požadavku.
Odstranit - v Seznamu požadavků vyberte požadavek, který chcete odstranit, a stiskněte toto tlačítko. Odstraněním požadavku odstraníte současně i všechny odpovědi na požadavek.
Zanést do databáze - v Seznamu odpovědí vyberte požadované odpovědi a stiskněte toto tlačítko. Na obrazovce se otevře dialogové okno Rozdíly, ve kterém můžete zapsat nově pořízené údaje z odpovědí do databáze.
Skrýt odpovědi - skryje/zobrazí Seznam odpovědí. Seznam požadavků se překreslí tak, aby vyplnil místo po Seznamu odpovědí.
Podrobnosti - v Seznamu odpovědí vyberte položku a stiskněte toto tlačítko. Na obrazovce se otevře dialogové okno Odpověď, ve kterém jsou zobrazeny detailní informace o vybrané odpovědi.
Obnovit - po stisknutí tohoto tlačítka se aktualizují informace v Seznamu požadavků a Seznamu odpovědí.
Zavřít - ukončí dialogové okno.


Vytvoření nového požadavku

  1. Z hlavní nabídky programu vyberte povel Detekce - Vzdálená.
  2. Na obrazovce se otevře dialogové okno Seznam požadavků. Stiskněte tlačítko Nový.
  3. Na obrazovce se otevře Průvodce vytvořením požadavku.
  4. Po dokončení práce s Průvodcem se do sdílené složky vloží nový požadavek.


Odstranění požadavku

  1. Z hlavní nabídky programu vyberte povel Detekce - Vzdálená.
  2. Na obrazovce se otevře dialogové okno Seznam požadavků. V seznamu požadavků vyberte požadavek a stiskněte tlačítko Odstranit.

Odstraněním požadavku se současně odstraní všechny odpovědi na tento požadavek!


Vzdálený sběr údajů po síti

Detekce - ruční načtení údajů

Ruční detekce údajů slouží pro pořízení a načtení výsledků detekcí z počítačů, které nejsou připojeny do počítačové sítě.

  • Pořízení detekce
  • Načtení výsledků detekce do databáze


Produkty

Pořízení detekce

Načtení údajů

  1. Na samostatném počítači spusťte program Agent z nabídky Start/Programy/Evidence počítačů/Agent. Na obrazovce se otevře Průvodce načtením údajů.
  2. Vyberte volbu Ruční detekce a stiskněte tlačítko Další.
  3. Zapněte volbu Zařízení a stiskněte tlačítko Další.
  4. Do vstupního řádku napište Název výstupního souboru a stiskněte tlačítko Další.
  5. Proběhne načtení údajů, které se uloží do výstupního souboru.
  6. Stiskněte tlačítko Dokončit pro dokončení Průvodce.

Proto, aby bylo možné načíst údaje ze samostatného počítače, nemusí na něm být nainstalován Agent, stačí pouze spustit soubor Agent.exe. Předpokladem je však nainstalovaná služeba WMI.


Produkty

Načtení souborů ruční detekce

  1. V hlavní nabídce programu vyberte položku Detekce a povel Načíst soubory. Na obrazovce se po chvíli otevře okno Soubory ruční detekce.
  2. Stiskněte tlačítko Procházet a vyberte adresář s výsledky ruční detekce.
  3. V seznamu odpovědí vyberte požadované odpovědi a stiskněte tlačítko Načíst do databáze.
  4. Program spustí proces načtení výsledků detekcí do databáze. Načtení výsledků může trvat několik minut.


Nastavení

Nastavení programu lze měnit povelem Pomůcky - Nastavení.

Na obrazovce se otevře okno s těmito záložkami:

  • Zobrazení
  • Obecné
  • Vazby
  • Klasifikace objektů
  • Záložky v seznamu vlastností
  • Síť
  • Komunikace
  • Evidence software


Ep.exe - parametry příkazové řádky

ep.exe [<databáze.mdb>] [/b]

<databáze.mdb> | Úplná cesta k souboru s databází, která se má otevřít při spuštění programu. Pokud není zadáno, program otevře naposledy použitou databázi.
/b | Neotevírat naposledy otevřenou databázi.


Instalace

Aktuální návod k instalaci najdete na http://www.alc.cz/ep/download.asp.


Adresář organizací

Okno Adresář organizací

Popis okna ...

Přidat - otevře dialog pro přidání nové firmy.
Upravit - otevře dialog pro změnu údajů vybrané firmy.
Odstranit - odstraní záznam vybrané firmy / firem – vyžaduje potvrzení..
Zavřít - ukončí dialogové okno.

Tip ...

- Klepnutím do nadpisu sloupce (např. Název) setřídíte celou tabulku podle zvoleného klíče (v tomto případě podle Názvu od A do Z).
- Opětovným kliknutím do stejného nadpisu sloupce obrátíte pořadí setřídění (tj. od Z do A).


Okno Nová organizace

Popis okna ...

Název - do pole zadejte název vkládané firmy.
Web (http://..) - do pole zadejte internetové stránky firmy.
Telefon - do pole zadejte telefonní číslo firmy.
Zařazení - klepnutím do zaškrtávacího políčka zařaďte firmu mezi výrobce / prodejce (je možné zvolit obě možnosti zároveň).
Ulice - do pole zadejte adresu vkládané firmy (možno i do dvou polí).
Město - do pole zadejte město ve kterém firma sídlí.
PSČ/ZIP - do pole zadejte poštovní směrovací číslo (ČR), nebo ZIP kód (svět).
Země - do pole zadejte zemi, ve které firma sídlí.

Všechna pole vyjma položky Název jsou nepovinná.


Okno Upravit (údaje o organizaci)

Popis okna ...

Název - do pole zadejte nový název firmy.
Web (http://..) - do pole zadejte nové internetové stránky firmy.
Telefon - do pole zadejte nové telefonní číslo firmy.
Zařazení - kliknutím do checkboxu zvolte zařazení firmy mezi výrobce / prodejce.
Ulice - do pole zadejte novou adresu vkládané firmy (možno i do dvou polí).
Město - v poli změňte město ve kterém firma sídlí.
PSČ/ZIP - do pole zadejte změněné poštovní směrovací číslo (ČR), nebo ZIP kód (svět).
Země - do pole zadejte zemi, ve které firma sídlí.

Všechna pole vyjma položky Název jsou nepovinná.


Okno Číselné řady

Popis okna ...

Upravit - otevře dialog pro úpravu vybrané číselné řady.
Zavřít - ukončí dialogové okno.


Okno Upravit (číselnou řadu)

Popis okna ...

Předpona - do vstupního pole můžete zapsat textovou předponu, která se bude zobrazovat před číslem.
Další číslo - do vstupního pole napište číslo, od kterého bude začínat číselná řada.
Přípona - do vstupního pole můžete zapsat textovou příponu, která se bude zobrazovat za číslem.


Okno Doklady

Popis okna ...

Přidat - otevře dialog pro přidání nového dokladu.
Upravit - otevře dialog pro změnu vybraného dokladu.
Odstranit - odstraní vybraný doklad(y) – vyžaduje potvrzení.
Zavřít - ukončí dialogové okno.

Tip ...

- Klepnutím do nadpisu sloupce (např. Vystaven) setřídíte celou tabulku podle zvoleného klíče (v tomto případě podle data vystavení od nejnovějšího po nejstarší).
- Opětovným kliknutím do stejného nadpisu sloupce obrátíte pořadí setřídění (tj. od nejstaršího po nejnovější).


Okno Nový doklad

Popis okna ...

Datum vystavení - ze vstupního řádku se seznamem vyberte datum vystavení dokladu.
Dodavatel - ze vstupního řádku se seznamem vyberte dodavatele (zobrazí se pouze firmy označené jako prodejce v Adresáři organizací).
Poznámky - do pole můžete zadat poznámky k dokladu.


Okno Upravit (doklad)

Popis okna ...

Datum vystavení - ze vstupního řádku se seznamem vyberte datum vystavení dokladu.
Dodavatel - ze vstupního řádku se seznamem vyberte dodavatele (zobrazí se pouze firmy označené jako prodejce v Adresáři organizací).
Poznámky - do pole můžete zadat poznámky k dokladu.


Okno Média

Popis okna ...

Přidat - otevře dialog pro přidání nového média.
Upravit - otevře dialog pro změnu údajů vybraného média.
Odstranit - odstraní vybrané médium(a) – vyžaduje potvrzení.
Zavřít - ukončí dialogové okno.

Tip ...

- Klepnutím do nadpisu sloupce (např. Název) setřídíte celou tabulku podle zvoleného klíče (v tomto případě podle Názvu média od A do Z).
- Opětovným kliknutím do stejného nadpisu sloupce obrátíte pořadí setřídění (tj. od Z do A).


Okno Nové médium

Popis okna ...

Typ média - ze vstupního pole se seznamem vyberte typ vkládaného média.
Název - do pole napište název vkládaného média.
Autor - do pole napište Autora popřípadě výrobce média (produktu)
Poznámky - do pole napište poznámky k médiu.


Okno Upravit (médium)

Popis okna ...

Typ média - ze vstupního pole se seznamem vyberte typ vkládaného média.
Název - do pole napište název vkládaného média.
Autor - do pole napište Autora popřípadě výrobce média (produktu)
Poznámky - do pole napište poznámky k médiu.


Okno Nabídka ikon

Popis okna ...

Přidat - otevře dialog pro přidání nové ikony.
Upravit - otevře nabídku pro úpravu vybrané ikony.
Odstranit - odstraní vybranou ikonu(y) – vyžaduje potvrzení.
Zavřít - ukončí dialogové okno.


Okno Nabídka ikon (upravit ikonu)

Popis nabídky ...

Kopírovat - zkopíruje ikonu do schránky.
Vložit - vloží ikonu ze schránky.
Změnit název - umožní vám změnit název ikony.
Uložit ikonu do souboru - umožní vám vyexportovat ikonu ve formátu obrázku bmp. Funkce je užitečná když chete například změnit obrázek ikony.
Načíst ikonu ze souboru - změní obrázek vybrané ikony na obrázek ze zvoleného soboru soboru. Obrázek musí mít prametry uvedené v postupu jak změnit obrázek ikony.
Uložit ikonu a upravit - uloží ikonu a nabídne vám její editaci v asociovaném grafickém programu.


Okno Uživatelé

Popis okna ...

Přidat - otevře dialog pro přidání nového uživatele.
Upravit - otevře dialog pro změnu přístupových práv a hesla vybraného uživatele.
Odstranit - odstraní vybrané uživatele – vyžaduje potvrzení.
Zavřít - ukončí dialogové okno.


Okno nový uživatel

Popis okna ...

Jméno a Příjmení - do pole zadejte jméno a příjmení uživatele, pro kterého vytváříte účet (toto jméno se bude zobrazovat v seznamu uživatelů).
Přihlašovací jméno - do pole zadejte jméno, kterým se bude identifikovat uživatel při přihlášení.
Heslo - do pole zadejte heslo, kterým se bude identifikovat uživatel při přihlášení. Heslo se při zápisu bude ukazovat ve formě hvězdiček.
E-mail - do pole zadejte e-mailový účet uživatele.
Práva - kliknutím do checkboxu zvolte práva uživatele:
  • Přesouvat - umožňuje uživateli přesouvat záznamy.
  • Vytvářet/upravovat - umožňuje uživateli vytvářet a upravovat záznamy.
  • Odstraňovat - umožňuje uživateli odstraňovat záznamy.
  • Správce - přiděluje uživateli správcovská práva.
  • Zablokovat přístup - zablokuje uživatelský účet.

Dobře si zapamatujte správcovské heslo!


Okno Upravit (uživatele)

Popis okna ...

Jméno a Příjmení - do pole zadejte jméno a příjmení uživatele, pro kterého vytváříte účet (toto jméno se bude zobrazovat v seznamu uživatelů).
Přihlašovací jméno - do pole zadejte jméno, kterým se bude identifikovat uživatel při přihlášení.
Heslo - do pole zadejte heslo, kterým se bude identifikovat uživatel při přihlášení. Heslo se při zápisu bude ukazovat ve formě hvězdiček.
E-mail - do pole zadejte e-mailový účet uživatele.
Práva - kliknutím do checkboxu zvolte práva uživatele:
  • Přesouvat - právo přesouvat objekty na jiné místo ve stromu.
  • Vytvářet/upravovat - právo vytvářet nové a upravovat existující objekty.
  • Odstraňovat - právo odstraňovat objekty.
  • Správce - správce programu. S tímto právem uživatel získá všechna ostatní práva včetně možnosti upravovat seznam uživatelů programu, měnit definice vlastností a seznam ikon (povely Pomůcky - Ikony, Pomůcky - Definice vlastností, Pomůcky - Uživatelé, Pomůcky - Nastavení).
  • Zablokovat přístup - zablokuje uživatelský účet.

Dobře si zapamatujte správcovské heslo!


Okno Produkty (software)

Popis okna ...

Přidat - otevře dialog pro přidání nového produktu (software).
Upravit - otevře dialog pro změnu údajů o produktu (software).
Odstranit - odstraní vybraný produkt(y) – vyžaduje potvrzení.
Zavřít - ukončí dialogové okno.

Tip ...

- Klepnutím do nadpisu sloupce (např. Produkt) setřídíte celou tabulku podle zvoleného klíče (v tomto případě Produkty od A do Z).
- Opětovným kliknutím do stejného nadpisu sloupce obrátíte pořadí setřídění (tj. od Z do A).


Okno Nový produkt

Popis okna ...

Název - do pole zadejte název produktu.
Jazyková mutace - ze vstupního řádku se seznamem vyberte jazykovou mutaci produktu.
Výrobce - ze vstupního řádku se seznamem vyberte výrobce (zobrazí se pouze firmy označené jako výrobce v Adresáři organizací).
Typ produktu - licence - klepnutím na přepínač vyberte druh licence programu:
  • Komerční - komerční (placený) produkt včetně OEM verzí.
  • Shareware/Trial - časově omezená (zkušební) verze produktu.
  • Freeware - plná verze programu distribuovaná zdarma.

Implicitní hodnota pro Typ programu - licenci je "komerční".


Okno Upravit (produkt)

Popis okna ...

Název - do pole zadejte název produktu.
Jazyková mutace - ze vstupního řádku se seznamem vyberte jazykovou mutaci produktu.
Výrobce - ze vstupního řádku se seznamem vyberte výrobce (zobrazí se pouze firmy označené jako výrobce v Adresáři organizací).
Typ produktu - licence - klepnutím na přepínač vyberte druh licence programu:
  • Komerční - komerční (placený) produkt včetně OEM verzí.
  • Shareware/Trial - časově omezená (zkušební) verze produktu.
  • Freeware - plná verze programu distribuovaná zdarma.

Implicitní hodnota pro Typ programu - licenci je "komerční".


Nastavení - Zobrazení

Seznam vlastností:
 | Zobrazit podobjekty - je-li tato volba vybrána, na každé záložce Seznamu vlastností budou zobrazeny kromě vlastností také podobjekty vybraného objektu. Tato volba je implicitně vypnutá.
 | Zobrazit zděděné vlastnosti - je-li tato volba vybrána, na záložkách Seznamu vlastností se budou zobrazovat zděděné vlastnosti (s výjimkou záložky Vlastní, která obsahuje pouze vlastní vlastnosti). Tato volba je implicitně zapnutá.
Strom objektů:
 | Zobrazit skryté objekty - je-li tato volba vybrána, zobrazují se i skryté objekty ve Stromu objektů.


Nastavení - Obecné

Zadávat ručně datum a čas pro záznamy historie - zapnutím této volby se při změnách otevře okno pro zadání datumu a času pro záznamy historie.

Potvrzovat přesuny objektů - zapnutím této volby se při přesunu objektu bude otevírat okno pro potvrzení přesunu objektu.


Nastavení - Vazby

Třída "Uživatel"- hodnota klasifikační vlastnosti (Druh) pro objekty představující uživatele.
Sériové číslo - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Sériové číslo".
Inventární číslo - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Inventární číslo".
Adresa - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Adresa".
Kód společnosti - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Kód organizace".
Typové označení - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Typové označení
Osobní - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Osobní číslo".
Umístění - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Umístění".
Uživatel - vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Uživatel".


Nastavení - Klasifikace objektů

Klasifikační vlastnost - vyberte vlastnost, která určuje typ objektu. Implicitně je jako klasifikační zvolena vlastnost "Druh".


Nastavení - Záložky v seznamu vlastností

Vlastnost pořadí - vlastnost, která určuje pořadí jednotlivých záložek v objektu Záložky seznamu vlastností.


Nastavení - Scanner

Nastavení - Síť

Klasifikační vlastnost scanneru - vlastnost, která slouží ke klasifikaci objektů ve WMI.
Klíčová vlastnost - vlastnost, která identifikuje objekt ve WMI.
Hodnotící - vlastnost, která určuje klíč k porovnávání podobnosti objektů.
Vlastnost - přihlašovací jméno - vlastnost s přístupovým jménem pro přihlášení do WMI.
Vlastnost - heslo - vlastnost s přístupovým heslem pro přihlášení do WMI.
Třída "Počítačová sestava" - hodnota klasifikační vlastnosti (Druh) pro objekty představující počítačovou sestavu.
Třída "Počítač" - hodnota klasifikační vlastnosti (Druh) pro objekty představující počítač.


Nastavení - Komunikace

Cesta ke sdílené složce - sdílená složka sloužící k výměně dat mezi Evidencí počítačů a jednotlivými Agenty na klientských stanicích. Program EP do této složky umisťuje požadavky a softwarové balíčky. Agenti do této složky umísťují své odpovědi na požadavky.
Procházet - stisknutím tlačítka otevřete okno Vybrat složku pro výběr sdílené složky.
Číslo portu pro spojení přes TCP/IP - číslo portu, pomocí kterého program Evidence počítačů komunikuje s jednotlivými agenty na klientských stanicích.


Průvodce přidáním nové licence - krok 1

Nová licence - produkt

Vyberte softwarový produkt.
Pokračujte stisknutím tlačítka Další.


Průvodce přidáním nové licence - krok 2

Nová licence - licence

Multilicence - vyberte tuto volbu pokud se jedná o multilicenci.
OEM licence - vyberte tuto volbu pokud se jedná o OEM licenci.
Počet licencí - počet licencí k užívání softwarového produktu.
Platnost od - začátek platnosti licence (většinou datum nákupu).
Platnost do - naplánování ukončení platnosti licence (pokud je časově omezena).
Poznámka - poznámka k licenci.
Pokračujte stisknutím tlačítka Další.


Průvodce přidáním nové licence - krok 3

Nová licence - položky licence

OEM licencí / sériových čísel - zobrazuje počet zapisovaných OEM licencí / sériových čísel.
Přiřazených OEM licencí / sériových čísel - zobrazuje počet přiřazených OEM licencí / sériových čísel.
Seznam počítačů - seznam přiřazených počítačů.
Přiřadit - stiskněte toto tlačítko pro přiřazení dalšího počítače k OEM licenci.
Odstranit - stiskněte toto tlačítko pro odstranění počítače ze seznamu přiřazených počítačů.
Pokračujte stisknutím tlačítka Další.


Průvodce přidáním nové licence - krok 4

Nová licence - dokumenty a média

Doklady - seznam dokladů např. faktur majících vztah k licenci.
Média - seznam medií např. CD, DVD a tištěných příruček majících vztah k licenci
Přidat - stiskněte toto tlačítko pro přidání nové vazby media nebo dokladu k licenci.
Odstranit - stiskněte toto tlačítko pro odstranění vazby media nebo dokladu k licenci.
Nakonec stiskněte tlačítko Dokončit.


Okno Upravit licenci

Základní

Počet licencí - počet nakoupených nebo zrušených licencí. Zrušené licence mají zápornou hodnotu.
Typ licence - typ nakoupené licence (normální, OEM, multi).
Platnost od - datum začátku platnosti licence
Platnost do - datum ukončení platnosti licence.
Poznámka - poznámka k licenci.

Položky licence

Položky licence- Seznam zapsaných sériových čísel nebo OEM licencí k produktu.
Přidat - stiskněte toto tlačítko pro přidání nové položky k licenci.
Odstranit - stiskněte toto tlačítko pro odstranění položky k licenci.

Ostatní

Doklady - seznam dokladů např. faktur majících vztah k licenci.
Média - seznam medií např. CD, DVD a tištěných příruček majících vztah k licenci
Přidat - stiskněte toto tlačítko pro přidání nové vazby media nebo dokladu k licenci.
Odstranit - stiskněte toto tlačítko pro odstranění vazby media nebo dokladu k licenci.


Nový záznam Evidence instalací - typ operace - krok 1

Nový záznam Evidence instalací - typ operace

Vyberte typ operace, kterou chcete zapsat do evidence.
ikona | typ operace
 | instalace
 | odinstalování
 | ostatní
Pokračujte stisknutím tlačítka Další.


Nový záznam Evidence instalací - počítače - krok 2

Nový záznam Evidence instalací - počítače

Nabídka - seznam obsahuje všechny dostupné počítače v evidenci.
Vybrané počítače - seznam obsahuje vybrané počítače do kterých chcete přidat záznamy o instalaci.
>> - stiskněte toto tlačítko pro přesun vybraného počítače ze seznamu Nabídka do seznamu Vybrané počítače.
<< - stiskněte toto tlačítko pro přesun vybraného počítače ze seznamu Vybrané počítače do seznamu Nabídka.
Pokračujte stisknutím tlačítka Další.


Nový záznam Evidence instalací - produkty - krok 3

Nový záznam Evidence instalací - produkty

Nabídka produktů - seznam obsahuje všechny dostupné produkty v evidenci.
Vybrané produkty - seznam obsahuje vybrané produkty, které chcete "nainstalovat" na počítač.
>> - stiskněte toto tlačítko pro přesun vybraného produktu ze seznamu Nabídka produktů do seznamu Vybrané produkty.
<< - stiskněte toto tlačítko pro přesun vybraného produktu ze seznamu Vybrané produkty do seznamu Nabídka produktů.
Pokračujte stisknutím tlačítka Další.


Nový záznam Evidence instalací - další údaje pro instalaci - krok 4

Nový záznam Evidence instalací - další údaje pro instalaci

Pro tuto instalaci na přenosný počítač použít licenci ze stolního počítače - vyberte tuto volbu pro případy kdy pro licenci platí, že je-li produkt nainstalován na stolním počítači, může být v rámci stejné licence nainstalován i na přenosném počítači téhož uživatele.
Vybraný počítač - stolní počítač, ze kterého se bude čerpat licence.
Pokračujte stisknutím tlačítka Další.


Nový záznam Evidence instalací - další údaje pro instalaci - krok 5

Nový záznam Evidence instalací - další údaje pro instalaci

Jedná se o zkušební instalaci produktů typu shareware/trial - zvolte, pokud se jedná o software na vyzkoušení (shareware nebo trial).
Pokračujte stisknutím tlačítka Další.


Nový záznam Evidence instalací - základní údaje - krok 6

Nový záznam Evidence instalací - základní údaje

Datum - datum záznamu.
Zodpovědná osoba - osoba odpovídající za správnost záznamu.
Poznámky - poznámka k záznamu.
Nakonec stiskněte tlačítko Dokončit.


Okno Upravit záznam evidence instalací

Datum - datum záznamu.
Zodpovědná osoba - osoba zodpovědná za vložení záznamu.
Sériové číslo licence - sériové číslo licence produktu viz. Evidence licencí.
Poznámka - poznámka k záznamu.


Okno Nabídka šablon objektů

Popis okna ...

Vložit včetně podobjektů - do stromu se vloží vybraný objekt šablony včetně celého podstromu.
Umístit jako kořenový objekt - vybraná šablona bude vložena do kořene stromu. Pokud tato volba není vybrána, nový objekt bude vložen jako podobjekt právě vybraného objektu ve stromu objektů.


Okno Objekt

Název - název objektu.
Změnit ikonu - stiskněte tlačítko a v Seznamu ikon vyberte novou ikonu objektu (funguje pouze u některých objektů).
Atributy:
 | Nepřesouvatelný - je-li tato volba vybrána, objekt není možné přesunout na jiné místo ve stromu.
 | Chráněn před odstraněním - je-li tato volba vybrána, program uživatele při pokusu o odstranění objektu upozorní na to, že objekt je chráněn. Pokud uživatel operaci přesto potvrdí, objekt bude odstraněn.
Zobrazení:
 | Skrytý objekt - objekty s touto volbou jsou ve Stromu objektů vidět pouze v případě, že je povoleno zobrazení skrytých objektů - viz. Nastavení - Zobrazení.


Okno Použít funkci

Funkce:
Aktualizace názvů a ikon objektů - zaktualizují se názvy a ikony vybraného objektu a všech jeho podobjektů. Tato funkce má stejný efekt, jako by jste na všech objektech příslušného podstromu použili funkci Objekt - Aktualizovat název a ikonu.
Součet - v okně vyberte ještě vlastnost, jejíž součet chcete spočítat. Způsob, jakým je součet počítán je popsán v kapitole Použití součtu pro výpočet hodnoty vlastnosti.


Okno Seznam vlastností


Okno Nabídka vlastností

Popis okna ...

Přidat - otevře dialog pro definování nové vlastnosti.
Upravit - otevře nabídku pro úpravu definice vlastnosti.
Odstranit - odstraní vybranou definici(e) – vyžaduje potvrzení.
Kopírovat - vytvoří kopii vybrané vlastnosti (uloží ji pod jiným názvem).
Zavřít - ukončí dialogové okno.


Okno Definice vlastnosti

Název - zadejte název vlastnosti, např. "Velikost", "Kapacita", "Jméno", "Příjmení" apod.
Změnit ikonu - stiskněte toto tlačítko a v Seznamu ikon vyberte ikonu pro tuto vlastnost.
Dědit vlastnost - zapněte tuto volbu pokud chcete, aby se tato vlastnost implicitně dědila do podobjektů.
Heslo - pokud zapnete tuto volbu, hodnota vlastnosti bude utajená a na obrazovce se místo ní bude zobrazovat text ***. Pozor: Tuto volbu není možné po jejím zapnutí vypnout.
Jedinečnost - nastaví vlastnost jako jedinečnou v celé databázi, tzn. že program bude kontrolovat, jestli tato vlastnost není uvedena ve více objektech se stejnou hodnotou (např. vlastnost inventární číslo)
Implicitní hodnoty:
 | Využívat implicitní hodnoty vlastnosti - zapněte tuto volbu pokud chcete, aby uživatel mohl vybírat hodnoty pro tuto vlastnost ze seznamu (číselníku). Použití seznamu je vhodné například pro vlastnost Uživatel, kde seznam obsahuje jména jednotlivých uživatelů. Množina hodnot ale není nutně omezena na položky seznamu a uživatel může zapsat hodnotu, která není v seznamu uvedena. Z nabídky na konci řádku můžete vybrat vlastnost, ze které chcete použít seznam hodnot. Standardně je v této položce vybrána hodnota <tato vlastnost> která říká, že se použije vlastní seznam hodnot této vlastnosti. Pokud vyberete jinou vlastnost, tato vlastnost bude sdílet seznam hodnot s vybranou vlastností.
 | Číselník implicitních hodnot - seznam hodnot, který můžete upravovat pomocí tlačítek v jeho spodní části.
 |  | Přidat Upravit Odstranit


Okno Vlastnost

Vlastnost - název vlastnosti (nelze měnit).
Hodnota - zadejte hodnotu vlastnosti. V seznamu, který je připojen k tomuto vstupnímu řádku, můžete vybrat hodnotu z číselníku implicitních hodnot pro tuto vlastnost. V seznamu jsou také uvedeny všechny hodnoty této vlastnosti zapsané u ostatních objektů v databázi.
Vazba na objekt:
 | Tato vlastnost určuje ikonu objektu - pokud vyberete tuto volbu, objekt, který obsahuje tuto vlastnost, bude mít stejnou ikonu jako tato vlastnost. Ikony jsou vlastnostem přiřazeny v definici vlastnosti. Ikonu objektu může určovat nejvýše jedna jeho vlastnost.
 | Tato vlastnost určuje název objektu
 |  | Předpona Kmen Přípona
 | Po zapnutí této volby bude název objektu, který obsahuje tuto vlastnost, automaticky vytvořen podle hodnoty této vlastnosti. Název objektu může být tvořen několika jeho vlastnostmi - v tom případě se hodnoty vlastností řadí za sebe v pořadí předpona - kmen - přípona. Pokud změníte hodnotu vlastnosti, která určuje název objektu, změní se i název objektu.
Dědičnost:
 | Dědit vlastnost - je-li tato volba zapnutá, vlastnost se bude dědit do všech podobjektů objektu, který obsahuje tuto vlastnost.


Okno Poznámka

Datum - zadejte datum a případně čas.
Text poznámky - zadejte text.


Okno Historie

Datum - zadejte datum a případně čas.


Okno - Vyhledávání

Popis okna ...

Hledaný text - - zadejte text, který chcete hledat. Můžete použít znak * místo libovolného úseku textu.

Příklady:
Hledaný text: | Program najde: | Program nenajde:
32 | 32 | 32 MB RAM 32 MB
32* | 32 32 MB | RAM 32 MB
*32* | 32 32 MB RAM 32 MB |
Prohledat - označte sekce, ve kterých se může hledaný text nacházet.
vlastnosti
poznámky
objekty
historie


Okno Vyhledávání - Dotaz

Dotaz - do textového pole v levé části okna můžete ručně zapsat dotaz - viz. Dotazovací jazyk. Pohodlnější způsob pro vytvoření dotazu je použít tlačítko Sestavit nový dotaz.
Vyhodnotit - vyhodnocení dotazu a zobrazení výsledku.
Sestavit nový dotaz - spustí průvodce pro vytvoření nového dotazu.
Načíst dotaz - načtení dotazu, který byl dříve vytvořen a uložen do souboru.
Uložit dotaz - uložení hotového dotazu do souboru.


Okno Parametry dotazu

Vyhledávat v
 | vybraný objekt - dotaz prohledá pouze objekt, který je právě vybrán ve Stromu objektů, a všechny jeho podobjekty.
 | všechny objekty - dotaz prohledá celý strom
Prohledat včetně
 | speciální objekty - zapněte tuto volbu, pokud chcete prohledávat také speciální objekty jako koš, šablony atd.


Okno Výsledky vyhledávání

Označit objekt - ve stromu v horní části okna vyberte nalezenou položku. Stiskněte tlačítko Označit objekt nebo poklepejte na konkrétní položku a ve Stromu objektů se zvýrazní objekt, ze kterého nalezená položka pochází.
Nové vyhledávání - stiskněte toto tlačítko pokud chcete zadat nové podmínky pro vyhledávání nebo nový dotaz.
Tisková sestava - na obrazovce se otevře náhled na tiskovou sestavu výsledku vyhledávání.
Export - uložení výsledku do souboru.


Průvodce vytvořením dotazu - krok 1

Ve stromu myší vyberte řídící objekt, tj. objekt, jehož údaje budete chtít sledovat.

Příklady:
požadavek | řídící objekt | poznámka
Seznam všech monitorů | monitor |
Seznam všech počítačových sestav s uvedením velikosti pevného disku | počítačová sestava | Pevné disky se budou dohledávat pomocí poddotazu v rámci každé počítačové sestavy.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením dotazu - krok 2

Seznam objektů - v seznamu je na začátku uveden pouze řídící objekt vybraný v kroku 1. Tlačítkem Přidat objekt do seznamu vložte další objekty, jejichž vlastnosti se mají objevit ve výsledku dotazu.
Seznam vlastností - seznam vlastností objektu, který je právě vybrán v Seznamu objektů vlevo. Pro jednotlivé objekty označte všechny vlastnosti, které chcete buď zobrazit ve výsledku dotazu, nebo pro ně bude stanovena nějaká podmínka, např. "velikost paměti RAM menší než 64 MB".
Směr hledání - v Seznamu objektů vyberte objekt a zvolte směr hledání objektu vzhledem k řídícímu objektu. Většinou se vyhledávají podobjekty.
 | podobjekt - hledání směrem dolů, tj. mezi podobjekty řídícího objektu.
 | nadobjekt - hledání směrem nahoru, tj. mezi nadobjekty.
Hladina - v Seznamu objektů vyberte objekt a zvolte pro něho hloubku vyhledávání.
 | do hloubky - objekt může být kdekoliv ve stromu podobjektů řídícího objektu.
 | povrchové - objekt musí být přímým podobjektem řídícího objektu, tj. ne podobjektem podobjektu.
Kvalita - v Seznamu objektů vyberte objekt a zvolte pro něho kvalitu vyhledávání.
 | všechny - vyberte tuto volbu pokud chcete prohledat celý podstrom řídícího objektu.
 | nejbližší - pokud zapnete tuto volbu, budou nalezeny pouze objekty na nejbližší hladině v podstromu řídícího objektu.
Pouze neprázdné objekty - v Seznamu objektů vyberte objekt. Potom můžete zapnout tuto volbu pokud chcete, aby se ve výsledku dotazu objevil řídící objekt pouze v případě, že vybraný podobjekt/nadobjekt existuje.
Přidat objekt - přidání dalšího objektu do seznamu vlevo nahoře. Po stisknutí tohoto tlačítka se na obrazovce otevře Nabídka šablon objektů, ze které vyberte požadovaný objekt.
Odstranit objekt - v Seznamu objektů vlevo nahoře vyberte objekt, který chcete odstranit, a stiskněte toto tlačítko.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením dotazu - krok 3

Položky seznamu představují sloupce tiskové sestavy, která bude výsledkem dotazu. V seznamu vyberte sloupec, který chcete upravit, a změňte hodnoty v položkách tohoto okna, nebo stiskněte tlačítko Upravit. Dvě šipky při pravém spodním okraji seznamu použijte pro posunutí vybrané položky v seznamu směrem nahoru nebo dolů. Pořadí položek určuje pořadí sloupců ve výsledné tiskové sestavě.
Zahrnout pouze řádky kde - má-li být pro hodnoty vybraného sloupce splněna nějaká podmínka, vyberte operátor a zadejte hodnotu pro porovnání, např. pro velikost paměti RAM můžete zadat podmínku "< 64".
Zobrazit v sestavě - zapněte tuto volbu, má-li být vybraný sloupec skutečně zobrazen ve výsledné tiskové sestavě.
Typ vlastnosti - určete požadavek na vlastnost vybraného sloupce.
 | nerozlišovat - vlastnost může být vlastní nebo zděděná
 | vlastní - použijí se pouze vlastní vlastnosti
 | zděděné - použijí se pouze zděděné vlastnosti
Agregační funkce - zvolte jaké funkce chcete spočítat v patičce vybraného sloupce.
 | počet součet průměr min max
Upravit - v seznamu vyberte sloupec a stiskněte toto tlačítko. Na obrazovce se otevře dialogové okno, ve kterém můžete změnit nadpis a šířku sloupce.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením dotazu - krok 4

Seskupovat podle - ze seznamu vyberte sloupec, podle kterého mají být řádky výsledné tiskové sestavy seskupeny.
Řadit podle - ze seznamu vyberte sloupce, podle kterých mají být řádky tiskové sestavy seřazeny. Pro každý vybraný sloupec zadejte směr řazení - vzestupně nebo sestupně.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením dotazu - krok 5

Název tiskové sestavy - zadejte nadpis, který bude uveden na začátku tiskové sestavy.
Náhled - po stisknutí tohoto tlačítka se otevře dialogové okno Parametry dotazu pro určení způsobu jeho vyhodnocení. Potom se otevře náhled na výslednou tiskovou sestavu.
Nakonec stiskněte tlačítko Dokončit.


Průvodce vytvořením požadavku

Průvodce vytvořením požadavku - typ požadavku

Zadejte popis požadavku - stručný popis požadavku.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením požadavku

Průvodce vytvořením požadavku - instalační balíček

Zadejte název souboru - cesta k msi instalačnímu souboru.
Pokračujte stisknutím tlačítka Další.


Průvodce vytvořením požadavku

Průvodce vytvořením požadavku - počítače

Seznam počítačů - seznam počítačů, na které se bude vztahovat vytvářený požadavek.
Přidat - přidání dalšího počítače do seznamu. Po stisknutím tohoto tlačítka se na obrazovce otevře okno Počítač pro zadání počítače.
Odstranit - v Seznamu počítačů vyberte počítač, který chcete ze seznamu odstranit, a stiskněte toto tlačítko.
Upravit - po stisknutí tohoto tlačítka se na obrazovce otevře okno Počítač, ve kterém můžete změnit zadání počítače.
Pokračujte stisknutím tlačítka Dokončit.


Přidat počítač

Počítač

Název počítače - do vstupního řádku zadejte název počítače nebo IP adresu.
Vybrat - po stisknutí tohoto tlačítka se na obrazovce otevře dialog Najít počítač procházením, ve kterém je možné vybrat počítač.
Všechny - po stisknutí tlačítka se do vstupního řádku název počítače vloží symbol "*" znamenající všechny počítače v síti.


Okno Odpověď

Odpověď

Počítače - jméno počítače, který poskytl odpověď.
Vytvořeno - čas vytvoření odpovědi.
Hlášení - zobrazuje detailní informace o výsledku odpovědi.
Předchozí/Další - tlačítka slouží pro přechod mezi jednotlivými výsledky odpovědi.


Okno Najít počítač procházením

Najít počítač procházením

Strom zobrazuje hierarchické uspořádání počítačů v síti. Označte počítače, se kterými hodláte pracovat. Označením domény se automaticky označí i počítače dané domény.


Okno Nastavení návrháře operací

Nastavení návrháře operací

V tomto okně můžete nastavit chování návrháře operací. Návrhář operací automaticky odstraňuje rozdíly mezi vzdáleně načtenými údaji o počítačích a údaji v databázi v okně Rozdíly.

Generovat operace:
 | Vlastnosti - zapnutím této volby návrhář automaticky odstraní všechny rozdíly ve vlastnostech, tj. přidá chybějící, odstraní přebývající vlastnosti příp. změní hodnoty u existujících vlastností. Tato volba je implicitně zapnutá.
 | Objekty - touto volbou se zapíná automatické odstranění rozdílů v objektech. Tato volba je implicitně zapnutá.
 | Automatické přiřazování podobných objektů - je-li tato volba zapnutá, program se bude snažit pro každý přebývající objekt nalezený při vzdáleném sběru údajů najít odpovídající existující objekt v počítačové sestavě v databázi. Pokud ho najde, automaticky přiřadí nalezený objekt přebývajícímu objektu. Doporučení: Tato volba je určena pro usnadnění prvního načtení údajů do databáze po přechodu na novější verzi programu. Po prvním načtení údajů do všech počítačů doporučujeme tuto volbu vypnout.


Evidence instalací vs. detekce software

Okno slouží pro porovnání stavu instalací evidovaných produktů v evidenci instalací a nově nadetekovaných produktů.

Evidence instalací - otevře okno Evidence instalcí, které slouží k evidenci nainstalovaných programů na počítačích.
Vytvořit chybějící záznamy - pokud byly detekcí nalezeny produkty, u kterých ještě neexistuje záznam o instalaci, tímto tlačítkem potřebné záznamy vytvoříte a vložíte do Evidence instalcí, kde je můžete dále upravovat.


Detekce - Načtené v databázi

Okno slouží k zobrazení a zpracování detekcí software načtených v databázi.
Počítač - počítač, na kterém byla prováděna detekce.
Typ - typ detekce souborů (úplná/zjednodušená).
Nepřiřazené soubory - v případě že se jedná o úplnou detekci souborů, zobrazí se počet souborů, které program nedokázal přiřadit k jednotlivým vzorů. Dodatečné přiřazení provedete vybráním řádku s nepřiřazenými soubory a klepnutím na tlačítko Upravit.

Upravit - otevře Okno pro přiřazení souborů nalezených úplnou detekcí k vzorům produktů.
Odstranit - odstraní výsledky (odpovědi) vybrané detkce z databáze.
Porovnat se stavem instalací - porovná vybrané výsledky detekce se záznamy o instalovaných programech na počítači v evidenci software a otevře okno Evidence instalací vs. detekce software.
Znovu vyhodnotit podle vzorů - provede nové porovnání detekovaných souborů s knihovnou vzorů - např. pokud načtete novou databázi vzorů.


Soubory ruční detekce

Okno slouží k načítání detekcí z jiného místa než sdíleného adresáře. Využijete ho při načítání detekovaných údajů ze stanic, které nejsou ve stejné síti jako Evidence počítačů (nevidí sdílený adresář), nebo nejsou na síti vůbec.

Procházet - vyberte zdroj, ze kterého chcete načítat údaje (disketa, ZIP, CD, atp.)
Podrobnosti - otevře okno Odpověď ve kterém Vám podá informaci o průběhu a datu detekce.
Načíst do databáze - načte detekované údaje do databáze. Pokud nalezne rozdíly, otevře okno Rozídly pokud se jedná o detekci hardware, nebo okno Evidence instalací vs. detekce software pokud se jedná o detekci software.
Odstranit - smaže soubor.


Slovník

agent
Agent je aplikace (Win9x) nebo služba (NT, 2000, XP) běžící na klientském počítači a zabezpečující vzdálený sběr údajů, instalaci softwarových balíčků a komunikaci s programem Evidence počítačů.
dědičnost
viz. vlastnost zděděná
jedinečnost
Vlastnost může být nastavena jako jedinečná, viz. Úprava definice vlastnosti. Pokud je jedinečnost zapnuta, potom lze použít funkci Kontrola jedinečnosti. Tato funkce zjistí, zda se vybraná vlastnost vyskytuje se stejnou hodnotou vícekrát a vypíše seznam porušení jedinečnosti u všech vlastností, které byli takto definovány.
klasifikační vlastnost
Vlastnost, která určuje typ objektu, např. "monitor", "procesor", "místnost" atd. Každý objekt musí mít tuto vlastnost. Implicitně slouží jako klasifikační vlastnost Druh.
objekt
Objekt je základním stavebním kamenem stromové databáze. Každý objekt představuje jeden uzel stromu.
Objekt se skládá z:
- názvu objektu
- ikony
- vlastností
- poznámek
- záznamů historie
- podobjektů
objekt kořenový
Objekt, který není podobjektem žádného jiného objektu, tj. nemá nadobjekt.
podstrom
Část stromu zahrnující jeden určitý objekt (kořen podstromu), jeho podobjekty, podobjekty podobjektů, atd.
strom
Hierarchická struktura složená z objektů. Každý objekt může mít jeden nebo více podobjektů (synů) a současně být podobjektem jiného objektu (nadobjektu, otce).
šablona objektů
Vzor, podle kterého se vytvářejí nové objekty.
vlastnost
Informace, která popisuje určitou charakteristiku objektu. Každý objekt může být popsán několika vlastnostmi, jako např. Velikost, Barva.
vlastnost vlastní
Vlastnost, která je součástí objektu, je vlastní vlastností tohoto objektu (viz. zděděná vlastnost).
vlastnost zděděná
Vlastnost, která není součástí objektu, ale je součástí některého jeho nadobjektu, se může objevit v seznamu vlastností objektu jako tzv. zděděná vlastnost.
WMI
Windows Management Instrumentation (WMI) je systém pro správu systémových informací založený na standardizovaném objektově orientovaném rozhraní.
záložka
Ve spodní části okna Vlastností a okna Historie jsou záložky, které slouží jako filtr.


Licenční podmínky
Produkt Evidence počítačů 2002

Všeobecné

  1. Platnost licence začíná dnem vystavení licenčního klíče pro spuštění programu.
  2. Výrobce je povinen vystavit uživateli licenční klíč do 7 dnů od obdržení fakturované částky na účet výrobce.
  3. Licence se uděluje pouze po celých násobcích 50 počítačů.
  4. Uživatel je oprávněn evidovat v programu jen tolik počítačů, na které má zakoupenou licenci.
  5. Uživatel je oprávněn nainstalovat produkt na neomezeném počtu počítačů ve svém majetku.
  6. Uživatel je oprávněn pořizovat kopie programu a instalačních disket pro archivní účely.
  7. Uživatel nesmí licenci pronajímat, poskytovat na leasing ani propůjčovat.
  8. Uživatel se zavazuje používat produkt tak, aby nedošlo k porušení či ohrožení autorských práv výrobce.

Licence na jeden rok

  1. Uživatel je oprávněn používat všechny nové verze produktu vydané výrobcem po celou dobu platnosti licence.
  2. Uživatel může v průběhu roku rozšířit licenci o nové počítače příp. přejít na vyšší sadu rozdílovým doplatkem.
  3. Po vypršení platnosti licence uživatel není oprávněn produkt dále používat.
  4. Další platbou se licence prodlužuje na další rok.

Časově neomezený typ licence

  1. Uživatel je oprávněn používat pouze verzi produktu, kterou si zakoupil. Výrobce negarantuje nárok na cenové zvýhodnění při nákupu některé budoucí verze produktu.
  2. Uživatel může rozšířit licenci o nové počítače příp. přejít na vyšší sadu rozdílovým doplatkem.


Seznam počítačů

Okno Seznam počítačů

Seznam počítačů - zobrazuje seznam vzdáleně načtených počítačů, které je možné přiřadit počítači v databázi.


Průvodce vytvořením dotazu - krok 2

Okno Správce databáze

Seznam - seznam databází
Otevřít - v seznamu vyberte databázi, kterou chcete otevřít, a stiskněte toto tlačítko
Upravit - v seznamu vyberte databázi a stiskněte toto tlačítko. Na obrazovce se objeví dialogové okno, ve kterém můžete změnit název a popis vybrané databáze.
Odstranit ze seznamu - v seznamu vyberte databázi, kterou chcete ze seznamu odstranit, a stiskněte toto tlačítko
Přidat jinou - stisknutím tlačítka otevřete na obrazovce Průvodce pro přidání nové databáze nebo otevření stávající databáze.
Zavřít - ukončení dialogového okna.


Okno Porušení jedinečnosti

Ve stromové struktuře jsou objekty, u kterých byla porušena jedinečnost hodnot. Poklepáním na objektu v seznamu se zvolený objekt vybere ve Stromu objektů.


Přihlášení

Zadejte své přihlašovací jméno a heslo.

Pro přihlášení do ukázkové databáze použijte jméno "správce" (ve slovenské verzi "správca"). Řádek pro heslo nechte volný.


Okno Vyhledávání - Dotaz

Okno Návrhář operací

Okno návrhář operací slouží pro manuální navržení operací k odstranění rozdílů mezi objekty položek okna Rozdílů. Mohou nastat dva případy.

A. V sestavě přebývá objekt

V počítačové sestavě, uložené v databázi, je objekt, který nemá adekvátní obraz v načteném počítači.

Ponechat - stisknutí tlačítka znamená ignorování rozdílu tj. nebude se navrhovat operace.
Přiřadit - stisknutí tlačítka znamená navržení operací pro přiřazení vybraného chybějícího objektu (objekt, který je vzdáleně načten a nemá protějšek v databázi) ze seznamu chybějících objektů. Jinými slovy přebývající objekt se přesune do sestavy, ve které se by se měl nacházet chybějící objekt.
Přesunout do objektu - stisknutím tlačítka otevřete okno, ve kterém vyberete cílový objekt v databázi, do kterého se přesune přebývající objekt.
Smazat - stisknutí tlačítka znamená navržení operací pro přesunutí přebývajícího objektu do koše.

A. V sestavě chybí objekt

V počítačové sestavě, uložené v databázi, chybí objekt, který se nachází v aktuální načtené konfiguraci počítače.

Nevytvářet - stisknutí tlačítka znamená ignorování rozdílu tj. nebude se navrhovat operace.
Přiřadit - stisknutí tlačítka znamená navržení operací pro přiřazení vybraného přebývajícího objektu (objekt, který je v databázi a nemá protějšek v načtené konfiguraci) ze seznamu přebývajících objektů. Jinými slovy zmíněný přebývající objekt se přesune do sestavy, ve které by se měl nacházet chybějící objekt.
Přiřadit jiný objekt - stisknutím tlačítka otevřete okno, ve kterém vyberete objekt v databázi, který se použije pro navržení operací přiřazení k chybějícímu objektu. Jinými slovy vybraný objekt se přesune do sestavy, ve které by se měl nacházet chybějící objekt.
Vytvořit - stisknutí tlačítka znamená navržení operací pro vytvoření nového objektu tj. v sestavě se vytvoří nový objekt.

Příklad:
Z počítače A byl odebrán jeden paměťový modul a vložen do počítače B. Tato změna nebyla zanesena do databáze. Při aktualizaci konfigurací obou počítačů program zjistí, že v počítači A přebývá paměťový modul a v počítači B chybí paměťový modul oproti načteným údajům.


Okno Předávací protokol

Nadpis - zadejte nový nebo ze seznamu vyberte přednastavený nadpis sestavy.
Odesílatel/Příjemce - v horním řádku můžete vybrat adresu ze seznamu kontaktů definovaných v databázi, nebo můžete napsat adresu ručně do víceřádkového vstupního pole.
Číslo objednávky
Zařízení - označení předávaného předmětu
Sledovaná vlastnost - vyberte vlastnost, jejíž hodnoty mají být uvedeny u předávaného předmětu a případně také všech jeho součástí (podobjektů).
Typové označení - hodnota vlastnosti Typové označení.
Požadavek - popis závady - další poznámky.


Okno Vyberte cílový objekt

Ve stromu vyberte cílový objekt pro přesun. Přesouvaný objekt se vloží jako podobjekt do vybraného objektu.


Okno Sloupec

Nadpis - zadejte nadpis sloupce, který se použije ve výsledné tiskové sestavě.
Šířka - šířka sloupce v procentech celkové šířky tiskové sestavy.


Průvodce vytvořením dotazu - krok 2

Okno Přesun objektu

Objekt - objekt, který hodláte přesunout
Z objektu (zdroj) - zdrojový rodičovský objekt
Do objektu (cíl) - cílový objekt přesunu
Zaškrtněte volbu Příště toto okno nezobrazovat a automaticky přesunou objekt pro ignorování tohoto dialogu.


Průvodce vytvořením dotazu - krok 2

Okno Protokol o předání (vnitřní)

Číslo dokladu - vstupní řádek pro zadání čísla dokladu
Datum převodu - datum převodu
Datum vystavení - datum vystavení dokladu
Text - doprovodný text dokladu
Předávající - údaje o předávající osobě
Přejímající - údaje o příjemci


Průvodce vytvořením dotazu - krok 2

Okno Protokol o předání (vnější)

Číslo dokladu - vstupní řádek pro zadání čísla dokladu
Datum převodu - datum převodu
Datum vystavení - datum vystavení dokladu
Text - doprovodný text dokladu
Předávající - údaje o předávající firmě
Přejímající - údaje o příjemci


Překreslení obsahu hlavního okna

Obsah všech částí hlavního okna překreslíte povelem Obnovit z nabídky Zobrazit nebo stiskem klávesy F5.


Okno Evidence licencí

Okno Položka licence

Vazba na počítač (OEM licence)- počítač, ke kterému se vztahuje OEM licence.
Sériové číslo licence - sériové číslo licence produktu.
Zapsat další položku - vyberte tuto volbu pro přidání další položky.


Průvodce zrušením licence - krok 1

Zrušení licence - licence

Počet rušených licencí - zobrazuje počet rušených licencí.
Počet aktivních licencí - zobrazuje celkový počet licencí, které lze zrušit.
Aktivní položky licence - seznam aktivních položek licence, které lze zrušit.
Pokračujte stisknutím tlačítka Další.


Průvodce zrušením licence - krok 2

Zrušení licence - dokumenty

Doklady - seznam dokladů např. faktur majících vztah k licenci.
Přidat - stiskněte toto tlačítko pro přidání nové vazby dokladu k licenci.
Odstranit - stiskněte toto tlačítko pro odstranění vazby dokladu k licenci.
Pokračujte stisknutím tlačítka Další.


Průvodce zrušením licence - krok 3

Zrušení licence - ostatní

Datum - datum zrušení licence.
Poznámka - poznámka k záznamu rušení licence.
Nakonec stiskněte tlačítko Dokončit.


Nastavení - Odstraňování objektů

Při odstranění přesunout do koše - je-li tato volba vybraná, všechny odstraněné objekty jsou přesunuty do koše.


Nastavení - Zobrazení

Nastavení - Evidence software

Zjednodušená evidence software: je-li tato volba vybrána, program umožňuje detekovat software pouze na základě údajů načtených z registru sledovaných počítačů.


Okno Objekt

Název - název objektu.
Změnit ikonu - stiskněte tlačítko a v Seznamu ikon vyberte novou ikonu objektu.
Atributy:
 | Nepřesouvatelný - je-li tato volba vybrána, objekt není možné přesunout na jiné místo ve stromu.
 | Chráněn před odstraněním - je-li tato volba vybrána, program uživatele při pokusu o odstranění objektu upozorní na to, že objekt je chráněn. Pokud uživatel operaci přesto potvrdí, objekt bude odstraněn.
Zobrazení
 | Skrytý objekt - objekty s touto volbou jsou ve Stromu objektů vidět pouze v případě, že je povoleno zobrazení skrytých objektů - viz. Nastavení - Zobrazení.


Vzdálený sběr údajů po síti

Uložit vzory produktů (software) - krok 1

Seznam - zobrazuje seznam uživatelských vzorů sw. produktů. Vyberte produkty, jejichž vzory chcete uložit.
Pokračujte stisknutím tlačítka Další.


Vzdálený sběr údajů po síti

Uložit vzory produktů (software) - krok 2

Vzory produktů uložit ze souboru - výstupní soubor se vzory sw. produktů.
Pokračujte stisknutím tlačítka Další.


Vzdálený sběr údajů po síti

Uložit vzory produktů (software) - krok 3

Probíhá ukládání vybraných vzorů sw. produktů. Ukládání může trvat několik minut.
Nakonec stiskněte tlačítko Dokončit.


Vzdálený sběr údajů po síti

Načíst vzory produktů (software) - krok 1

Vzory produktů načíst ze souboru - soubor obsahující vzory sw. produktů
Pokračujte stisknutím tlačítka Další.


Vzdálený sběr údajů po síti

Načíst vzory produktů (software) - krok 2

Seznam - zobrazuje seznam dostupných vzorů softwarových produktů. Vyberte produkty, jejichž vzory chcete načíst.
Pokračujte stisknutím tlačítka Další.


Vzdálený sběr údajů po síti

Načíst vzory produktů (software) - krok 3

Probíhá načítání vybraných vzorů sw. produktů. Načítání může trvat několik minut.
Nakonec stiskněte tlačítko Dokončit.


Dotazy

Pomocí dotazů můžete:

  • vyhledávat objekty podle složitějších kritérií než dovoluje zadat jednoduché vyhledávání v textech
  • vytvářet vlastní tabulkové tiskové sestavy
  • Vytvořit nový dotaz
  • Upravit existující dotaz
  • Vyhodnotit dotaz
  • Vytisknout výsledek dotazu