Služba Windows Media Services

Služba Windows Media Services umožňuje vysílání multimediálního obsahu v sítích v rozmezí od nízké šířky pásma (telefonické připojení k síti Internet pomocí modemů s vytáčením) až po vysokou šířku pásma (místní sítě). Při instalaci služby Windows Media Services je možné v Průvodci součástmi systému Windows zvolit položku Služba Windows Media Services a nainstalovat služby Windows Media Component Services a Správce Windows Media. Chcete-li nainstalovat pouze Správce Windows Media, klepněte na tlačítko Podrobnosti a vyberte pouze položku Správa služby Windows Media Services. Pokud chcete vzdáleně spravovat server Windows Media, nainstalujte pouze Správce Windows Media.

Tato dokumentace obsahuje informace týkající se vysílání obsahu zpracovaného technologií Windows Media pomocí služeb Windows Media Component Services. Dokumentace je k dispozici také ve formátu DOC v adresáři Systémová_jednotka\Kořenový_adresář_systému\system32\Windows Media\docs\print a je možné ji zobrazit pomocí programu Microsoft WordPad nebo Microsoft Word.

Poznámka

  • Uvedené názvy společností a produktů, jména osob a údaje jsou smyšlené a bez jakékoli souvislosti se skutečnými osobami, společnostmi, produkty či událostmi, není-li uvedeno jinak.

© 1996-1999 Microsoft Corporation. Všechna práva vyhrazena.


Úvodem

Služba Windows Media Services funguje podobně jako server WWW. Tato služba může rozšířit možnosti serveru WWW přidáním nabídky programů rádia a televize, prezentací, přenosu souborů, videa a multimediálních prezentací.

Správce služby Windows Media Services zodpovídá za zpřístupnění obsahu uživatelům vytvořením příslušné konfigurace a za způsob poskytování tohoto obsahu. Následující schéma obecně popisuje způsob poskytování obsahu ve formátu ASF uživatelům.

Doporučujeme vyhradit samostatný svazek NTFS pro uložení obsahu na požádání. Lepších výsledků dosáhnete umístěním tohoto svazku na samostatný fyzický disk. Svazky NTFS jsou z hlediska využití prostoru pro ukládání a operací spojených se čtením z disku efektivnější než oddíly systému FAT16. Svazek NTFS také umožňuje u souborů s obsahem použití kontroly seznamu řízení přístupu (ACL).

Poznámka

  • Aplikace určené pro počítače s nainstalovanými nástroji Windows Media si můžete stáhnout ze stránky Windows Media Technologies umístěné na serveru WWW společnosti Microsoft.


Použití v sítích Internet a intranet

Služba Windows Media Services slouží k poskytování obsahu uživatelům sítě Internet a sítí intranet. V závislosti na cílovém publiku se však některé potřebné činnosti liší.

Rozhodnete-li se poskytovat obsah prostřednictvím sítě Internet, nezapomeňte na následující možné potíže:

  • Velká část sítě Internet neumožňuje vysílání typu Multicast a pro všechny obsahy vysílání Multicast je proto třeba poskytovat také alternativu ve formě vysílání Unicast.
  • Šířka pásma sítě Internet není spolehlivě zajištěna. Provoz v síti Internet značně kolísá a typ získaného připojení se může u každého připojení lišit.
  • Sítě používající proxy server budou pravděpodobně potřebovat speciální konfiguraci, která umožní přístup klienta v síti Internet na server Windows Media.
  • Pokud používáte program serveru WWW současně se službou Windows Media Services (to znamená, že sdílejí stejný počítač), ověřte, že nedochází ke kolizi portů HTTP a že při přístupu klientů v síti Internet lze rozpoznat všechna připojení.

Jestliže se rozhodnete poskytovat obsah prostřednictvím sítě intranet, mějte na paměti následující možné potíže:

  • Některé součásti systému mohou být odděleny bezpečnostní bránou firewall.
  • Chcete-li poskytovat obsah pomocí vysílání Multicast, musí být součástí sítě směrovače umožňující vysílání Multicast.
  • Zvažte, kolik správců budete potřebovat pro určitý server a zda nebudete potřebovat vzdálené správce.
  • Zvažte počet uživatelů, kterým bude povolen přístup k obsahu.


Obecné informace

Služba Windows Media Services nabízí možnost poskytování multimediálního obsahu velkému počtu uživatelů, kteří používají formáty ASF, WMA, MP3 a WAV.

Použití datových proudů umožňuje klientům vykreslovat obsah během příjmu ze sítě, aniž by bylo nutné tento obsah nejprve stáhnout. Datové proudy významně snižují čekací dobu na straně klienta a požadavky na úložný prostor. Umožňují také vysílání prezentací neomezené délky a živé vysílání.

Tato část poskytuje přehled nejdůležitějších pojmů týkajících se služby Windows Media Services a součástí, které slouží k vytváření, doručování a přehrávání vysílaných mediálních datových proudů.

Poznámka

  • Při vysílání a příjmu datových proudů je doporučeno používat formát ASF. Vysílání ve formátu WAV nebo MP3 může výrazně ovlivnit výkon serveru. V takovém případě také například nejsou dostupné funkce přidání obrázků a příkazů skriptu.


Formát ASF

Formát ASF používaný službou Windows Media Services je otevřený standard, který podporuje doručování dat prostřednictvím různých sítí a protokolů. Formát ASF je možné použít k sestavení, organizaci a synchronizaci multimediálních dat určených k vysílání v síti. Ačkoliv formát ASF slouží jako formát souboru, je možné jej použít také jako formát živě vysílaných prezentací. Tento formát je optimalizován pro vysílání multimediálních datových proudů v síti, je však vhodný i pro místní přehrávání.

Ke kódování datových proudů formátu ASF je možné použít libovolný kompresní a dekompresní algoritmus (kodek). Informace uložené v datovém proudu ASF umožňují klientům určit kodek potřebný k dekompresi daného datového proudu. Datové proudy ASF mohou být navíc přenášeny prostřednictvím libovolného přenosového protokolu sítě.

Zvukové soubory Windows Media Audio (soubory s příponou WMA) jsou soubory ve formátu ASF obsahující pouze zvuk komprimovaný pomocí kodeku Windows Media Audio. Tento soubor se od souboru ve formátu ASF liší pouze příponou. Server Windows Media může vysílat soubory WMA ve formě datových proudů. Pro tyto soubory lze pomocí správce programů odesílat oznámení prostřednictvím souborů s příponou WAX. Soubory WMA byly společností Microsoft vytvořeny pro klienty přehrávající pouze zvukové soubory.


Kodek Windows Media Audio

Soubory Windows Media Audio jsou soubory ve formátu ASF obsahující pouze zvuk komprimovaný pomocí kodeku Windows Media Audio. Přípona těchto souborů se změní na WMA. Obsah zpracovaný kodekem Windows Media Audio nelze vytvořit pomocí nástrojů Windows Media a serveru Windows Media. Chcete-li obsah ve formátu ASF převést na obsah zpracovaný kodekem Windows Media Audio, změňte příponu souboru ASF na WMA. Součástí všech souborů WMA jsou soubory přesměrovače datového proudu s příponou WAX. Tyto soubory WAX fungují stejným způsobem jako soubory přesměrovače datového proudu ASF (soubory s příponou ASX) s tou výjimkou, že soubory WAX jsou určeny k oznámení obsahu ve formátu Windows Media Audio. Soubory WAX lze vytvořit změnou přípony souboru ASX na WAX.


Formát MP3

Služba Windows Media Services vysílá soubory MP3 stejným způsobem jako soubory ASF a WMA. To znamená, že soubory MP3 můžete umístit do virtuálního kořenového adresáře (Systémová_jednotka\ASFRoot) nebo do libovolného adresáře pro publikování vysílání Unicast a uživatelům bude umožněn příjem souborů MP3 namísto jejich stahování. Soubory MP3 lze využít také jako zdroj pro vysílání Multicast. Toho dosáhnete překódováním souboru MP3 do souboru ASF pomocí programu Windows Media Encoder nebo konfigurováním stanice tak, aby používala soubory MP3 umístěné v adresáři pro publikování.

Použití souborů MP3 v seznamu položek k přehrání

Pokud v seznamu souborů ASX odkazujete pomocí adresy URL protokolu HTTP na soubor MP3, je třeba použít u odkazu na soubor MP3 příponu ASF. Všimněte si odkazu HTTP na soubor2.mp3 v následujícím seznamu:

<ASX version = "3.0">
<Entry><Ref href = "mms://server/soubor1.asf" /> </Entry>
<Entry><Ref href =  "http://server/soubor2.mp3?ext=.asf" /> </Entry>
<Entry><Ref href =  "mms://server/soubor3.mp3" /> </Entry> </asx>

Odkaz HTTP na soubor MP3 vyžaduje přidání výrazu ?ext=.asf za název souboru. Tímto způsobem je zajištěno, že k přehrávání souborů MP3 bude použit program Windows Media Player.


Datové proudy vysílání Unicast a Multicast

Služba Windows Media Services používá výrazy vysílání Unicast a vysílání Multicast při popisu způsobu, jakým klienti získávají pakety dat ze serveru Windows Media.

Vysílání Unicast

Vysílání Unicast je spojení typu point-to-point mezi klientem a serverem. Spojení typu point-to-point znamená, že každý klient přijímá ze serveru samostatný datový proud. Datový proud vysílání Unicast je odesílán pouze klientovi, který vznesl příslušný požadavek.

Datové proudy vysílání Unicast mohou být klientům distribuovány dvěma způsoby:

  • na požádání,
  • kontinuálním vysíláním.

Vysílání Multicast

Vysílání Multicast představuje datový proud s obsahem doručovaný prostřednictvím sítí umožňujících vysílání Multicast. Pro všechny klienty v síti je společný jeden datový proud. Největší výhodou tohoto způsobu vysílání obsahu ve formátu ASF je úspora šířky pásma sítě.

Pomocí nastavení serverů Windows Media pro každý segment dané sítě lze vysílání Multicast rozšířit i na oblasti sítě, které vysílání Multicast neumožňují. Tento způsob se nazývá distribuce prostřednictvím serveru. Jako část vysílání Multicast ze serveru je možné distribuovat jeden datový proud (tohoto vysílání Multicast) na jiné servery Windows Media nacházející se v dalších segmentech sítě. Tyto servery pak vysílají datový proud do příslušných segmentů sítě prostřednictvím vysílání Unicast nebo Multicast. Tento způsob se nazývá opakovaná distribuce. Spojením serverů za sebou lze obejít směrovače, které vysílání Multicast neumožňují. Tento model je možné také použít v prostředí s bezpečnostní bránou firewall.

K zajištění podpory vysílání Multicast musí být správcem služby Windows Media Services vytvořeny tři položky: stanice, program a datový proud. Stanice slouží jako referenční bod klientům, kteří se chtějí připojit k datovému proudu. Program uspořádá položky obsahu vysílané prostřednictvím stanice. Datový proud je aktuální obsah. Jsou-li tyto tři položky vytvořeny, vytvoří Správce Windows Media soubor ASX propojující klienty se správnou adresou IP dané stanice. Tento soubor se také nazývá oznámení. Soubor s oznámením je možné umístit do veřejného adresáře pro publikování na síti, odeslat klientům elektronickou poštou nebo se k němu lze připojit ze stránky WWW.


Datové proudy na požádání a datové proudy kontinuálního vysílání

Služba Windows Media Services používá výrazy vysílání na požádání a kontinuální vysílání k popisu vztahu mezi klientem a serverem. Datový proud vysílaný na požádání umožňuje uživateli aktivní řízení přehrávání, zatímco datový proud kontinuálního vysílání poskytuje pouze pasivní příjem.


Vysílání datového proudu na požádání

Vysílání datového proudu na požádání představuje jeden ze způsobů, jakým lze získat vysílané informace ze serveru Windows Media. Připojení na požádání je aktivní spojení klienta a serveru. U připojení na požádání iniciuje připojení k serveru klient vybráním položky obsahu. Obsah je ze serveru ke klientovi přenášen ve formě datového proudu ASF. Pokud je soubor indexován, může uživatel datový proud spustit, zastavit, rychle převinout vpřed a vzad nebo jej pozastavit. Připojení na požádání nabízí více možností řízení datového proudu, ale také z důvodu samostatného připojení jednotlivých klientů k serveru rychleji vyčerpá šířku pásma sítě.

Příkladem vysílání Unicast na požádání může být například požadavek uživatele na uložený soubor ASF. Klient se připojuje k serveru za účelem získání určitého obsahu, který je vysílán pouze jednomu klientovi. K identifikaci adresy URL souboru ASF používá klient název serveru a název souboru ASF.

Vysílání Unicast na požádání


Kontinuální vysílání datového proudu

Kontinuální vysílání umožňuje uživateli pasivní příjem datového proudu. V průběhu vysílání klient datový proud přijímá, ale nemůže jej řídit. Datový proud není například možné pozastavit či převinout vpřed ani vzad. Existují dva typy kontinuálního vysílání - vysílání Unicast a vysílání Multicast. Oba dva typy jsou pasivní.

Kontinuální vysílání Unicast

Při kontinuálním vysílání Unicast se klient připojuje k datovému proudu prostřednictvím aliasu v adresáři pro publikování. Uživatel může na stránce WWW klepnout na odkaz nebo jiným způsobem získat adresu URL aliasu a připojit se k datovému proudu. Každý uživatel je k datovému proudu vysílanému ze serveru připojen samostatně.

Program Windows Media Encoder například vysílá datový proud s obsahem do adresáře pro publikování vysílání umístěného na serveru Windows Media. Pro všechny adresáře pro publikování existuje alias. Alias adresáře pro publikování vysílání je v tomto případě TV1. Název TV1 slouží klientovi k identifikaci cesty ke zdroji datového proudu. Vzhledem k tomu, že datový proud ASF televizní stanice lze identifikovat pomocí adresáře pro publikování, je odkaz adresy URL na datový proud ASF podobný odkazu na uložený soubor ASF. Namísto názvu souboru ASF je však identifikován alias adresáře pro publikování - TV1. V tomto případě uživatel používá pro přístup k datovému proudu cestu mms://Server1/TV1.

Kontinuální vysílání Unicast

Kontinuální vysílání Multicast

U kontinuálního vysílání Multicast přijímá klient datový proud ASF pasivně pomocí sledování určité adresy IP (princip podobný příjmu radiového nebo televizního signálu na samostatné frekvenci). Výhodou vysílání Multicast je, že jeden datový proud může poskytnout obsah ASF mnoha klientům v síti. Tento způsob šetří šířku pásma sítě a je proto vhodný zejména pro místní sítě s nízkou šířkou pásma.

Chcete-li použít v síti kontinuální vysílání Multicast, musí směrovače sítě podporovat přenos dat pomocí vysílání Multicast. Bez ohledu na fakt, zda směrovače sítě podporují vysílání Multicast, můžete použít službu Windows Media Services pro vysílání Multicast prostřednictvím místního segmentu místní sítě.


Adresář pro publikování a obsah stanice

V souvislosti se službou Windows Media Services slouží výrazy adresáře pro publikování a stanice k popisu způsobu poskytování obsahu klientům.

Adresář pro publikování slouží pro přístup k obsahu vysílání Unicast. Jde o virtuální adresář s uloženým obsahem umístěný na serveru. Obsah tohoto adresáře je zpřístupněn klientům. Ve Správci Windows Media existují dva typy adresářů pro publikování sloužící k poskytování obsahu klientům.

  • Adresáře pro publikování vysílání Unicast na požádání jsou určeny k poskytování souborů ASF.
  • Adresáře pro publikování kontinuálního vysílání Unicast slouží k poskytování živě vysílaných datových proudů ASF.

Při vytváření adresářů pro publikování lze nastavit maximální počet klientů, kteří budou mít v určitý okamžik k adresáři pro publikování přístup, a maximální šířku pásma, kterou může adresář využít. Tato omezení jsou užitečná při správě šířky pásma, kterou adresář pro publikování spotřebuje. Pokud jsou nároky adresáře pro publikování příliš vysoké, zvažte možnost poskytování obsahu tohoto adresáře prostřednictvím stanice vysílání Multicast, která šířku pásma šetří.

Stanice slouží pro přístup k obsahu vysílání Multicast.. Stanice se skládá minimálně z jednoho programu a datového proudu. Stanice bez přidružených programů a datových proudů je bez obsahu. Vzhledem k tomu, že stanice fungují na principu vysílání Multicast, může datový proud sdílet neomezený počet klientů, kteří chtějí datový proud přijímat. Síť ani datový proud nejsou počtem klientů ovlivněny. Z tohoto důvodu není třeba omezovat počet klientů, kteří mohou datový proud přijímat.


Oznámení obsahu ve formátu ASF

Proces požadavku a získání obsahu ve formátu ASF lze zjednodušit poskytováním oznámení - souboru s příponou ASX přidruženého k příslušnému obsahu ASF. Oznámení je textový soubor zformátovaný speciálním způsobem a uložený s příponou ASX. Tento soubor je vytvořen tak, aby bylo možné jej distribuovat klientům prostřednictvím elektronické pošty, umístit na serveru pro přístup prostřednictvím adresy UNC a stahovat ze stránek WWW. Bez ohledu na způsob zpřístupnění souboru ASX představuje jedinou činnost, kterou musí uživatelé pro přístup k obsahu ve formátu ASF provést, spuštění souboru ASX.

Služba Windows Media Services používá oznámení pro živě vysílané datové proudy a pro soubory ASF a WMA. Jako oznámení pro soubory WMA slouží soubory WAX. Oznámení nelze použít pro přenosy souborů.


Použití seznamů položek k přehrání

Seznam položek k přehrání slouží jako sada ukazatelů na více souborů ASF nebo datových proudů ASF. Na každý soubor nebo datový proud odkazuje určitá adresa URL. Služba Windows Media Services podporuje dva typy seznamů - seznam položek na straně klienta a seznam položek na straně serveru.


Protokoly služby Windows Media Services

Následující schéma znázorňuje použití protokolů ke komunikaci mezi součástmi systému služby Windows Media Services.

Protokoly Windows Media

Všechny součásti lze vzájemně spojit prostřednictvím protokolu HTTP, který umožňuje komunikaci i v případě, že jsou tyto součásti odděleny bezpečnostní bránou firewall.

Klienti, kteří se připojují k vysílání Multicast., nepoužívají protokol. Data získávají v té podobě, v jaké jsou vysílána pomocí adresy IP vysílání Multicast a nemusí žádat o připojení.

Poznámka

  • Aplikace určené pro počítače s nainstalovanými nástroji Windows Media si můžete stáhnout ze stránky Windows Media Technologies umístěné na serveru WWW společnosti Microsoft.


Protokol MMS

Protokol MMS slouží pro přístup k obsahu vysílání Unicast z adresáře pro publikování Windows Media. Protokol MMS je výchozí způsob připojení ke službě Windows Media Unicast Service. Chcete-li se připojit k obsahu pomocí adresy URL zadané v programu Windows Media Player místo použití hypertextového odkazu, musí existovat odkaz na datový proud a je třeba použít protokol MMS.

Za účelem získání nejvyšší možné kvality připojení k adresáři pro publikování pomocí protokolu MMS je použito přecházení mezi protokoly. Funkce přecházení mezi protokoly se nejprve pokusí o připojení klienta k serveru prostřednictvím protokolu MMSU. Protokol MMSU je kombinací protokolu MMS s protokolem pro přenos dat UDP. Pokud se připojení pomocí protokolu MMSU nezdaří, pokusí se server použít protokol MMST. Protokol MMST je kombinací protokolu MMS s protokolem pro přenos dat TCP.

Jestliže se připojujete k indexovanému souboru ASF a chcete umožnit v datovém proudu použití funkcí rychlého posunu vpřed, vzad, pozastavení, spuštění nebo zastavení, je nutné použít protokol MMS. K převinutí vpřed a vzad nelze použít cesty podle konvence UNC.

Pokud se připojujete k adresáři pro publikování ze samostatného programu Windows Media Player, je třeba zadat adresu URL obsahu vysílání Unicast. Jestliže je obsah publikován na požádání prostřednictvím kořenového adresáře pro publikování, skládá se adresa URL z názvu serveru a z názvu souboru ASF. Příklad:

mms:// server_windows_media/vzor.asf

kde server_windows_media je název serveru Windows Media a vzor.asf název souboru ASF, který chcete přijímat.

Chcete-li publikovat živě vysílaný obsah prostřednictvím kontinuálního vysílání Unicast, skládá se adresa URL z názvu serveru a z aliasu adresáře pro publikování. Příklad:

mms://server_windows_media/Zive_Udalosti

kde server _windows_media je název serveru Windows Media a Zive_Udalosti název adresáře pro publikování.


Protokol MSBD

Protokol MSBD slouží k distribuci datových proudů mezi programem Windows Media Encoder a součástmi Windows Media Server Components a k přenosu datových proudů mezi servery. Protokol MSBD je protokol orientovaný na připojení určený především k vysílání a příjmu mediálních datových proudů. Tento protokol je vhodný pro testování kvality obsahu ve formátu ASF a připojení klienta a serveru. Neměl by však být používán jako hlavní způsob příjmu obsahu ASF. Program Windows Media Encoder podporuje maximálně 15 klientů připojených pomocí protokolu MSBD, server Windows Media maximálně 5.


Protokol HTTP

Server Windows Media je možné nakonfigurovat tak, aby k vysílání obsahu ve formě datového proudu používal protokol HTTP. Vzhledem k tomu, že většina bezpečnostních bran firewall umožňuje průchod protokolu HTTP, usnadňuje vysílání datových proudů HTTP překonání překážek tohoto druhu. Vysílání datových proudů HTTP lze také použít k vysílání obsahu z programu Windows Media Encoder přes bezpečnostní bránu firewall na server Windows Media a k připojení serverů Windows Media oddělených bezpečnostní bránou firewall. Pokud jste spustili službu Windows Media Services ve stejném počítači jako server WWW, například službu IIS (Microsoft Internet Information Services), ujistěte se, že na portu 80 nevznikl konflikt.


Použití přecházení

V některých situacích, například z důvodu potíží se sítí, údržby serveru apod., se nebude moci program Microsoft Windows Media Player připojit k serveru Windows Media a získat přístup k vysílání Unicast. Pokud použijete k publikování souboru ASF protokol MMS, je přecházení mezi protokoly z protokolu MMS a použití protokolu UDP (MMSU) na protokol MMS za použití protokolu TCP a následně k protokolu HTTP automatické. Při pokusu o připojení ke zdroji datového proudu zkouší program Windows Media Player postupně jednotlivé protokoly, dokud se připojení nezdaří. Tímto způsobem je pro program Windows Media Player zajištěna dostupnost dat.

Způsob přecházení mezi protokoly určuje značka REF v souboru ASX. Pomocí značky REF lze k dosažení stejného zdroje určit různé protokoly. Jestliže například první značka REF určuje protokol MMS a druhá odkaz HTTP, mohou se klienti, kteří k připojení nemohou použít protokol MMS (protože se nachází vně bezpečnostní brány firewall), automaticky pokusit o připojení pomocí protokolu HTTP. Program Windows Media Player provede tento typ přechodu automaticky v případě, že při vytváření adresáře pro publikování vysílání Unicast zadáte protokol MMS.

Přecházení mezi adresami URL také slouží k určování různých serverů Windows Media se stejným obsahem. Pokud například první značka REF určuje soubor ASF na serveru s názvem pes1 a druhá značka REF určuje kopii tohoto souboru na serveru pes2, může program Windows Media Player použít k získání souboru oba servery. Pokud je server pes1 zaneprázdněn nebo není funkční, připojí se program Windows Media Player automaticky k serveru pes2.


Součásti Windows Media

Technologie Microsoft Windows Media poskytuje integrovanou sadu služeb a nástrojů sloužících k vytváření, správě, vysílání a příjmu plně multimediálních prezentací vysílaných ve formě datových proudů prostřednictvím sítě Internet a podnikových sítí intranet. Tato část obsahuje podrobné informace o součástech Windows Media Server Components. Do aplikací technologie Windows Media dále patří nástroje Windows Media a program Windows Media Player.


Součásti Windows Media Server Components

Součásti Windows Media Server Components se skládají ze služeb Windows Media Component Services a Správce Windows Media.

Služby Windows Media Component Services

Služby Windows Media Component Services tvoří sadu služeb určených pro systém Microsoft Windows 2000 Server. Tyto služby zajišťují vysílání zvukového a obrazového obsahu klientům prostřednictvím vysílání Unicast nebo Multicast. Mezi služby Windows Media Component Services patří Služba Windows Media Monitor Service, Služba Windows Media Program Service, Služba Windows Media Station Service a Služba Windows Media Unicast Service.

Správce Windows Media

Správce Windows Media je představován sestavou stránek WWW, které lze zobrazit v okně prohlížeče Microsoft Internet Explorer verze 5. Pomocí Správce Windows Media lze také spravovat služby Windows Media Component Services. Správce Windows Media umožňuje spravovat místní server nebo se lze jeho prostřednictvím připojit k libovolnému počtu vzdálených serverů Windows Media a spravovat je. Chcete-li spravovat více serverů, přidejte je do seznamu serverů a poté se připojte k požadovanému serveru.

Správce Windows Media je možné spustit v operačních systémech Microsoft Windows 2000 Server, Microsoft Windows 2000 Professional, Microsoft Windows 98 a Microsoft Windows NT 4 s aktualizací Service Pack 4 (SP4) nebo vyšší. Správce Windows Media lze spustit také v operačním systému Microsoft Windows 95 a v aplikaci Internet Explorer 4.01, nejedná se však o podporované platformy.


Klientský software služby Windows Media Services

Klientský software představovaný programem Windows Media Player vykresluje datový proud přijímaný ze serveru Windows Media. Program Windows Media Player slouží k vykreslování datových proudů ASF, mezi něž patří zvukový obsah, obsah videa, obrázky, adresy URL a skripty. Klient může přenosy souborů vysílání Multicast přijímat pouze v případě, že je v klientském počítači nainstalován a nakonfigurován soubor Nsfile.ocx. Soubor Nsfile.ocx není součástí instalace programu Windows Media Player. Ovládací prvek pro přenos souborů je možné stáhnout ze serveru WWW společnosti Microsoft.

Klientský software lze získat pro operační systémy Microsoft Windows, Apple Macintosh a UNIX.

Inovace klientského softwaru z programu NetShow Player verze 2.0

V případě, že nechcete zajistit podporu programu Microsoft NetShow Player verze 2.0, můžete pomocí souboru fupgrade.asf informovat klienty služby Windows Media Services o nutnosti aktualizace programu NetShow Player verze 2.0 na program Microsoft Windows Media Player. Po instalaci služby Windows Media Services je soubor fupgrade.asf umístěn do kořenového adresáře pro publikování (jako výchozí adresář slouží adresář Systémová_jednotka\ASFRoot). Po připojení k adresáři pro publikování umístěnému na serveru Windows Media je klientům představovaným programem NetShow Player odeslán namísto požadovaného datového proudu soubor fupgrade.asf. Tento soubor ASF obsahuje informace týkající se nutnosti aktualizace klientského softwaru. Soubor také spustí v klientském počítači prohlížeč, který se připojí k serveru WWW společnosti Microsoft, kde je k dispozici nejnovější verze programu Windows Media Player určená ke stažení.

Aktualizace starších verzí programu Windows Media Player

Starší verze programu Windows Media Player neumožňují přehrání obsahu používajícího nový kodek, kódování s více přenosovými rychlostmi nebo technologii DRM (Digital Rights Management). Pokud se však uživatel starší verze k serveru Windows Media připojí, spustí se soubor fupgrade.asf a vyzve uživatele ke stažení nejnovější verze programu Windows Media Player ze serveru WWW věnovaného tomuto programu. Nejnovější verze programu Windows Media Player umožňuje uživatelům přehrát celý obsah ASF včetně obsahu s více přenosovými rychlostmi a chráněného obsahu.

Poznámka

  • Pokud nechcete uživatele vyzývat k aktualizaci klientského softwaru, přejmenujte nebo odstraňte soubor fupgrade.asf a restartujte službu.


Nástroje Windows Media

Součástí služby Windows Media Services jsou následující nástroje, které umožňují vytvářet a upravovat obsah vysílaný ze serveru Windows Media ve formě datového proudu.

  • Program Windows Media Encoder slouží k převodu živě vysílaného i uloženého zvukového obsahu a obsahu videa do podoby datového proudu ASF, který je poté vysílán do sítě prostřednictvím serveru Windows Media. Obsah datového proudu je možné zdokonalit přidáním příkazů skriptu. Příkazy skriptu slouží k přechodu na určitý server WWW, k inicializaci odkazů na stránky WWW, poskytování informací o hodnocení nebo k vytvoření zpráv elektronické pošty. Vytvořený obsah ve formě datového proudu lze zapsat do souboru ASF a přehrát později.
  • Nástroj Windows Media Author vyvinula společnost Microsoft ve spolupráci se společností Digital Renaissance, Incorporated. Tento nástroj slouží k seskupení, synchronizaci a komprimaci zvukových souborů a souborů s obrázky do jednoho souboru ve formátu ASF. Obsah vytvořený pomocí nástroje Windows Media Author se nazývá zvukový proud s obrázky, protože připomíná snímky prezentace doprovázené zvukem. Nástroj Windows Media Author je možné použít také k přidání příkazů skriptu a adres URL do souborů ASF.
  • Rozšíření Windows Media Presenter pro aplikaci Microsoft PowerPoint 97 je doplněk určený pro aplikaci PowerPoint, který spolu s programem Windows Media Encoder umožňuje převést prezentaci vytvořenou v aplikaci PowerPoint do datového proudu ASF.
  • Nástroj Doplněk Windows Media pro publikování formátu ASF pro aplikaci Microsoft PowerPoint 97 je doplněk, který převádí prezentace aplikace PowerPoint s mluveným komentářem do souboru ASF.
  • Modul Plug-In Windows Media pro program Adobe Premiere umožňuje snadnou kompresi a převod souborů s videozáznamy z programu Adobe Premiere do formátu ASF. Další informace naleznete v nápovědě k programu Adobe Premiere.
  • Program Windows Media ASF Indexer slouží k úpravě počátečního a koncového času souborů ASF a k jejich indexování. Je ho také možné použít k přidání značek, vlastností a příkazů skriptu do souboru ASF.
  • Nástroje VidToAsf a WavToAsf jsou nástroje pro převod spouštěné z příkazového řádku serveru. Slouží k převodu existujících zvukových souborů a souborů s videozáznamy do formátu ASF.
  • Nástroje ASFCheck a ASFChop jsou nástroje pro soubory spouštěné z příkazového řádku serveru. Nástroj ASFCheck ověřuje platnost formátu souboru ASF a v případě nutnosti tento soubor opraví. Pomocí nástroje ASFChop lze přidat do souboru ASF vlastnosti, značky, rejstříky a příkazy skriptu a odstranit z něj konkrétní časové úseky. Další informace týkající se vytváření souborů ASX naleznete v tématu Informace o metasouborech ASX.

Poznámka

  • Celou výše uvedenou sadu nástrojů Windows Media je možné stáhnout ze stránky Windows Media Technologies umístěné na serveru WWW společnosti Microsoft.


Vysílání prezentací aplikace PowerPoint 2000

Součástí aplikace Microsoft PowerPoint 2000 je funkce Vysílání prezentací, která umožňuje vysílání prezentace aplikace PowerPoint v reálném čase uživatelům v síti ve formě datového proudu. Kromě snímků lze souběžným vysíláním videa a zvuku doručovat online živě vysílanou multimediální prezentaci. Funkce Vysílání prezentací aplikace PowerPoint 2000 kombinuje možnosti aplikace PowerPoint, aplikace Microsoft Outlook, služby Windows Media Services a programu Windows Media Player.

Podpora vysílání prezentací aplikace PowerPoint 2000 je zajištěna službou Vysílání prezentací online instalovanou spolu se službou Windows Media Services. Tato služba umožňuje použití funkce Vysílání prezentací aplikace Microsoft PowerPoint 2000 k vysílání prezentací v reálném čase v síti intranet pomocí serveru Windows Media. K vysílání prezentací je třeba službu Windows Media Services použít ve všech případech, kdy chcete pomocí funkce Vysílání prezentací vysílat prezentace více než 15 uživatelům nebo hodláte-li vložit do prezentace video.


Příprava síti pro vysílání prezentací aplikace PowerPoint 2000

Titulek služby Windows Media Services

Příprava sítě pro vysílání prezentací aplikace PowerPoint 2000

Chcete-li povolit v síti službu Vysílání prezentací online a upravit ji pro publikum s více než 15 uživateli, doporučujeme použít dva servery sdílející stejnou doménu systému Windows 2000:

  • Server se systémem Microsoft Windows 2000 Server pro sdílení souborů. Snímky aplikace PowerPoint budou na tomto serveru umístěny ve sdíleném souboru a budou v průběhu vysílání prezentace dostupné uživatelům.
  • Server se systémem Windows 2000 Server s nainstalovanou službou Windows Media Services. Z tohoto serveru budou vysílány prezentace videa a zvuku ve formě datového proudu prostřednictvím vysílání Unicast nebo Multicast. Je také možné distribuovat snímky aplikace PowerPoint prostřednictvím vysílání Multicast.

Na serveru se spuštěnou službou Windows Media Services proveďte následující činnosti:

  • Nakonfigurujte službu Vysílání prezentací online tak, aby se přihlašovala pomocí uživatelského jména v doméně a odpovídajícího hesla. Další informace naleznete v tématu Konfigurace služby Vysílání prezentací online na serveru Windows Media.
  • Přidejte uživatelský účet v doméně, který služba Vysílání prezentací online používá k přihlášení, do skupiny NetShow Administrators a Administrators.

Na serveru, který slouží ke sdílení souborů, proveďte následující činnosti:

  • Přidělte uživatelskému účtu v doméně používanému službou Vysílání prezentací online přístup pro čtení do sdílené složky s uloženými soubory ASD aplikace PowerPoint.

Poznámka

  • Pokud není doména systému Windows 2000 dostupná, vytvořte uživatelský účet v doméně na obou serverech (na serveru Windows Media a na serveru používanému ke sdílení souborů). Zkontrolujte, zda jsou hesla uživatelského účtu na obou serverech shodná a přidejte službu Vysílání prezentací online do skupiny NetShow Administrators a Administrators na serveru se spuštěnou službou Windows Media Services. Pak nakonfigurujte službu na serveru Windows Media tak, aby byla spuštěna po zadání právě vytvořeného uživatelského jména a hesla. Další informace naleznete v tématu Konfigurace služby Vysílání prezentací online na serveru Windows Media.


Konfigurace služby Vysílání prezentací online na serveru Windows Media

  1. Přihlaste se k počítači se spuštěnou službou Windows Media Services pomocí účtu s oprávněními správce.
  2. V okně Ovládací panely poklepejte na panel Nástroje pro správu a potom poklepejte na panel Služby.
  3. V okně Služby klepněte pravým tlačítkem myši na službu Vysílání prezentací online a klepněte na příkaz Vlastnosti.
  4. V okně Vysílání prezentací online - vlastnosti klepněte na kartu Přihlásit se.
  5. V části Přihlásit se jako klepněte na přepínač Tento účet.
  6. Zadejte název uživatelského účtu v doméně a heslo, který bude služba používat při přihlášení do systému.

Poznámky

  • Je třeba ověřit, zda je síť správně nakonfigurována pro vysílání prezentací online. Další informace naleznete v tématu Příprava sítě pro vysílání prezentací aplikace PowerPoint 2000.
  • Pokud změníte heslo účtu, jehož prostřednictvím se přihlašujete k počítači se spuštěnou službou Windows Media Services, je nezbytné změnit heslo také v dialogovém okně služby Vysílání prezentací online.
  • Pokud jako Typ spouštění služby Vysílání prezentací online zvolíte možnost Ručně (výchozí nastavení), bude se služba spouštět automaticky při spuštění uživatelem a nebude-li to nutné, nebude používat systémové prostředky.


Další informace týkající se vysílání prezentací aplikace PowerPoint 2000

Další informace týkající se vysílání prezentací aplikace PowerPoint 2000 a způsobu konfigurace této aplikace naleznete v článku sítě MSDN na serveru WWW společnosti Microsoft.

Informace týkající se použití funkce vysílání prezentací aplikace PowerPoint naleznete v dokumentaci k sadě Resource Kit pro sadu Office 2000 na serveru WWW společnosti Microsoft.


Zdroje informací

Po instalaci služby Windows Media Services je možné informace týkající se funkcí a jejich použití při přípravě obsahu získat z několika zdrojů:

  • Nápověda služby Windows Media Services. Pro službu Windows Media Services je k dispozici úplná dokumentace online. Tuto dokumentaci lze otevřít pomocí Správce Windows Media. Z důvodu usnadnění tisku jsou k dispozici také soubory ve formátu aplikace Microsoft Word (soubory s příponou DOC), které jsou umístěny v adresáři Systémová_jednotka\Kořenový_adresář_systému\system32\Windows Media\docs\print. Dokumenty určené k tisku jsou shodné s dokumenty poskytovanými online a měly by být tištěny v následujícím pořadí: srvr_admin1.doc, srvr_admin2.doc, srvr_admin3.doc, srvr_admin4.doc a srvr_admin5.doc.
  • Stránka WWW Windows Media Technologies. Stránka WWW Windows Media Technologies na serveru WWW společnosti Microsoft poskytuje přehledy, ukázky a nejnovější informace všem uživatelům technologie Windows Media. Vaší pozornosti by neměla ujít ani sada Windows Media Technologies Software Development Kit (SDK), ve které najdete ukázky, průvodce a referenční informace určené vývojářům.


Součásti Windows Media Server Components

Součásti Windows Media Server Components se skládají ze služeb Windows Media Component Services a Správce Windows Media. Služby Windows Media Component Services tvoří skupinu služeb, které slouží k vysílání zvukového a obrazového obsahu klientům prostřednictvím vysílání Unicast a Multicast.

Tento přehled popisuje použití Správce Windows Media založeného na síti WWW k řízení služeb Windows Media Component Services a k vysílání obsahu zpracovaného technologií Windows Media ve formě datového proudu. Dokumentace zahrnuje tyto části:

Správce Windows Media
Použití Správce Windows Media ke správě libovolného serveru Windows Media, ke kterému máte přidělena oprávnění správce.
Vysílání Unicast
Popis konfigurace součástí Windows Media Server Components zajišťující doručování datových proudů na požádání a živě vysílaných datových proudů vysílání Unicast klientům a popis možností sledování těchto klientů.
Vysílání Multicast
Popis konfigurace součástí Windows Media Server Components zajišťující snížení nároků na šířku pásma pomocí doručování datových proudů klientům ve formě vysílání Multicast a popis možností sledování těchto klientů.
Sledování událostí Windows Media
Popis možností sledování činností serveru Windows Media včetně připojení klientů, stavu a omezení serveru a funkcí správy.
Čítače výkonu služby Windows Media
Popis použití upravených čítačů výkonu služby Windows Media v programu Výkon technologie Windows Media k měření výkonu a efektivnosti serveru Windows Media.
Informační protokoly
Popis způsobu uložení informací o klientech přijímajících vysílání Unicast nebo Multicast ve formě protokolu.
Správa a zabezpečení služeb technologie Windows Media
Popis použití integrovaných funkcí zabezpečení součástí Windows Media Server Components v systému Microsoft Windows 2000 Server k řízení přístupu k obsahu zpracovanému technologií Windows Media.


Správce Windows Media

Správce Windows Media je představován sestavou stránek WWW, které lze zobrazit v okně prohlížeče Microsoft Internet Explorer 5. Tento správce umožňuje řídit libovolný server Windows Media, ke kterému máte v doméně systému Microsoft Windows oprávnění správce. Chcete-li vzdáleně spravovat jiné servery Windows Media, musíte být členem skupiny NetShow Administrators nebo být správcem příslušného vzdáleného počítače.

Správce Windows Media používá ke komunikaci se součástmi Windows Media Server Components, které jsou spravovány vzdáleně, model DCOM (Distributed Component Object Model). Chcete-li zajistit správu serveru Windows Media, který se nenachází ve stejné doméně systému Windows, nebo je od Správce Windows Media oddělen bezpečnostní bránou firewall, je nutné otevřít v bezpečnostní bráně firewall port, který modelu DCOM umožní komunikaci.

Správce Windows Media je nainstalován spolu se součástmi Windows Media Server Components. Tohoto správce je možné spustit v operačních systémech Microsoft Windows 2000 Server nebo Windows 2000 Professional.


Běžné postupy

Tato část obsahuje výčet často používaných postupů pro práci se Správcem Windows Media.Tyto postupy slouží k rychlému provedení úkolu. Část následující po seznamu postupů obsahuje podrobný přehled informací o Správci Windows Media. Chcete-li zobrazit podrobnější informace o Správci Windows Media, přejděte na následující část.


Postup při spuštění Správce Windows Media

  • Klepněte na tlačítko Start, přejděte na příkaz Programy, potom na položku Nástroje pro správu a klepněte na položku Windows Media.


Připojení k serveru Windows Media

  • V rámci s nabídkou Správce Windows Media klepněte na šipku v rozevíracím seznamu a vyberte server, ke kterému se chcete připojit.

Poznámka

  • Pokud seznam požadovaný server neobsahuje nebo neobsahuje-li žádný server, příslušný server do seznamu přidejte.


Přidání serveru do seznamu serverů

  • V rámci s nabídkou Správce Windows Media klepněte na tlačítko Přidat server a do pole Server zadejte název serveru.


Odebrání serveru ze seznamu serverů

  • Klepněte na název serveru v seznamu serverů a klepněte na tlačítko Odebrat server.

    Připojení Správce Windows Media k serveru bude ukončeno a název serveru bude odebrán ze seznamu.


Úpravy portu využívaného službou Windows Media Unicast Service pro vysílání datového proudu HTTP

  1. Spusťte Editor registru.
  2. V Editoru registru přejděte pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nsunicast\Parameters

  3. Poklepejte na klíč HTTPPort.

    Zobrazí se okno Upravit hodnotu DWORD.

  4. V dialogovém okně Upravit hodnotu DWORD klepněte na přepínač Desítková.

    Pole Data musí obsahovat hodnotu 80.

  5. Zadejte číslo portu, který chcete pro vysílání datového proudu HTTP použít.

Poznámka

  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Úpravy portu využívaného službou Windows Media Station Service pro vysílání datového proudu HTTP

  1. Spusťte Editor registru.
  2. V Editoru registru přejděte pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nsstation\Parameters

  3. Poklepejte na klíč HTTPPort.

    Zobrazí se okno Upravit hodnotu DWORD.

  4. V dialogovém okně Upravit hodnotu DWORD klepněte na přepínač Desítková.

    Pole Data musí obsahovat hodnotu 80.

  5. Zadejte číslo portu, který chcete pro vysílání datového proudu HTTP použít.

Poznámka

  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Povolení vysílání datových proudu HTTP pro součásti Windows Media Server Components spuštěné na stejném serveru jako služba IIS 5.0

Titulek služby Windows Media Services

Povolení vysílání datových proudů HTTP pro součásti Windows Media Server Components spuštěné na stejném serveru jako služba IIS 5.0

  1. Přečtěte si informace uvedené v tématu Použití součástí Windows Media Server Components a služby IIS na stejném serveru.
  2. Přiřaďte serveru WWW služby IIS (Internet Information Services) adresu IP. Další informace naleznete v tématu Přiřazení adresy IP serveru WWW služby IIS.
  3. Zakažte pro server WWW služby IIS sdružování soketů. Další informace naleznete v tématu Zakázání sdružování soketů pro server WWW služby IIS.
  4. Povolte vysílání datového proudu HTTP pro součásti Windows Media Server Components. Vysílání datového proudu HTTP lze povolit pro datový proud vysílání Unicast i Multicast.
  5. Upravením registru vytvořte závislost služby Windows Media Component Services na službě publikování ve WWW. Další informace naleznete v tématu Vytvoření závislosti služby Windows Media Unicast Service na serveru WWW úpravou registru.
  6. Restartujte počítač.

Poznámka

  • Pokud je na serveru nainstalována služba IIS verze 3.0 nebo nižší, nelze ze součástí Windows Media Server Components odesílat obsah datového proudu ASF pomocí protokolu HTTP. Server WWW služby IIS je v takovém případě totiž na všech adresách IP, které jsou k dispozici, vázán na port 80. Chcete-li vysílání datového proudu HTTP povolit pro jednu ze služeb Windows Media Component Services, je nutné nekonfigurovat server WWW služby IIS verze 4 nebo vyšší pro použití se všemi nepřiřazenými adresami IP.


Přiřazení adresy IP serveru WWW služby IIS

  1. V okně služby Internet Information Services vyberte server Windows Media.
  2. Klepněte pravým tlačítkem myši na složku Výchozí server WWW a v místní nabídce klepněte na příkaz Vlastnosti.

    Zobrazí se dialogové okno Výchozí server WWW - vlastnosti.

  3. V dialogovém okně Výchozí server WWW - vlastnosti klepněte na kartu Server WWW.
  4. Na kartě Server WWW zadejte do pole Adresa IP adresu IP pro službu IIS.
  5. Chcete-li přiřadit adresu IP dalším serverům WWW spuštěným se službou IIS, včetně serveru WWW pro správu, opakujte kroky 2 až 4.

Poznámka

  • Pokud je na serveru nainstalována služba IIS verze 3.0 nebo nižší, nelze ze součástí Windows Media Server Components odesílat obsah datového proudu ASF pomocí protokolu HTTP. Server WWW služby IIS je v takovém případě totiž na všech adresách IP, které jsou k dispozici, vázán na port 80. Chcete-li vysílání datového proudu HTTP povolit pro jednu ze součástí Windows Media Server Components, je nutné nekonfigurovat server WWW služby IIS verze 4.0 nebo vyšší pro použití se všemi nepřiřazenými adresami IP.


Zakázání sdružování soketu pro server WWW služby IIS 5.0

Titulek služby Windows Media Services

Zakázání sdružování soketů pro server WWW služby IIS 5.0

  1. Do příkazového řádku zadejte tuto cestu: cd Systémová_jednotka\inetpub\adminscripts
  2. Ve adresáři Systémová_jednotka\Inetpub\AdminScripts zadejte následující příkaz:

    cscript adsutil.vbs set w3svc/disablesocketpooling true

    Na příkazovém řádku se zobrazí se následující odpověď:

    disablesocketpooling : (BOOLEAN)  TRUE


Vytvoření závislosti služby Windows Media Unicast Service na serveru WWW úpravou registru

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedt32.
  2. Chcete-li pomocí Editoru registru aktualizovat službu Windows Media Unicast Service, přejděte pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\nsunicast

  3. Poklepejte na klíč DependOnService.

    Zobrazí se okno Editor řetězců.

  4. Na konec seznamu služeb zadejte hodnotu W3SWC.

    Nastavením hodnoty W3SVC zajistíte závislost součástí Windows Media Server Components na službě Microsoft Internet Information Services (IIS).

  5. Restartujte počítač.

Poznámky

  • Vytvořením závislosti služby Windows Media Component Services na službě WWW zajistíte vazbu služby WWW na port 80. Pokud tuto závislost nevytvoříte, je možné, že proběhne nejdříve vazba portu 80 se součástmi Windows Media Server Components a server WWW nebude fungovat správně. Tento postup je určen pro použití služby Windows Media Services se službou IIS 4.0 nebo vyšší. Používáte-li službu Windows Media Services s jiným serverem WWW a chcete nastavit závislosti, naleznete podrobnější informace v dokumentaci daného serveru.
  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Vytvoření nového typu MIME pro službu IIS

  1. Ve Správci služeb sítě Internet vyberte požadovaný počítač se serverem.
  2. Klepněte pravým tlačítkem myši na složku Výchozí server WWW a v místní nabídce klepněte na příkaz Vlastnosti.

    Zobrazí se dialogové okno Výchozí server WWW - vlastnosti.

  3. Klepněte na kartu Hlavička protokolu HTTP.
  4. Ve skupinovém rámečku Mapování MIME klepněte na tlačítko Typy souborů.

    Zobrazí se dialogové okno Typy souborů.

  5. Klepněte na tlačítko Nový typ.
  6. V dialogovém okně Typ souboru zadejte do pole Přidružená přípona hodnotu ASF a do pole Typ obsahu (MIME) zadejte hodnotu video/x-ms-asf.
  7. V dialogovém okně Typy souborů klepněte na tlačítko Nový typ.
  8. V dialogovém okně Typ souboru zadejte do pole Přidružená přípona hodnotu ASX a do pole Typ obsahu (MIME) zadejte video/x-ms-asf.
  9. Restartujte server.

Poznámka

  • Tento postup předpokládá, že součásti Windows Media Server Components a služba Microsoft Internet Information Services (IIS) nejsou nainstalovány na stejném počítači se serverem. Nainstalujete-li před součástmi Windows Media Server Components službu IIS, budou typy MIME (Multipurpose Internet Mail Extensions) pro službu IIS vytvořeny automaticky. Vytvoříte-li typy MIME pro výchozí server WWW, bude mít toto vytvoření vliv na všechny servery WWW. Typy MIME lze pomocí těchto pokynů vytvořit pro libovolné servery WWW na daném serveru.


Zálohování programů služby Windows Media Services

  1. Archivujte soubor NSP daného programu do adresáře určeného pro zálohy.

    Soubory NSP příslušných programů nejsou archivovány automaticky a je proto nutné archivovat tyto soubory ručně. Další informace naleznete v tématu Postup při uložení programu.

  2. Spusťte program Microsoft Windows Backup.

Poznámka

  • Chcete-li zálohovat programy služby Windows Media Services, je nutné použít tento postup. Pro ostatní data serveru Windows Media server je možné použít zálohování systému Windows.


Obnovení programů služby Windows Media Services

  1. Ujistěte se, zda byly provedeny kroky uvedené v tématu Zálohování programů služby Windows Media Services.
  2. Spusťte program Microsoft Windows Restore.

    Následující soubory nebudou obnoveny:

    %SystemRoot%\system32\Windows Media\Server\ASDB\mdsas.mdb
%SystemRoot%\system32\Windows Media\Server\ASDB\mdsas.ldb
  3. V operačním systému Windows 2000 Server spusťte program Správa počítače a zastavte všechny spuštěné služby Windows Media Component Services.
  4. Odstraňte všechny soubory v následujících adresářích:
    %SystemRoot%\system32\Windows Media\Server\ASDB
%SystemRoot%\system32\Windows Media\Server\ASDB\NSP
  5. Zkopírujte soubor Mdsas.1st do adresáře ASDB a přejmenujte jej na Mdsas.mdb.
    Copy "%SystemRoot%\system32\Windows Media\Server\mdsas.1ST" "%SystemRoot%\system32\Windows Media\Server\ASDB\mdsas.mdb"
  6. V konzole služby restartujte službu Windows Media Component Services.
  7. Obnovte archivovaný soubor NSP pro data programu pomocí Správce Windows Media. Další informace naleznete v části Postup při obnovení uloženého programu.


Spuštění Správce Windows Media

Po spuštění Správce Windows Media dojde k pokusu o připojení k serveru Windows Media v místním počítači. Jestliže je Správce Windows Media nainstalován v počítači, který neobsahuje součásti Windows Media Server Components, je nutné server Windows Media přidat do seznamu serverů. Tento postup lze také použít, chcete-li měnit připojení Správce Windows Media mezi dvěma servery Windows Media.


Použití součástí Windows Media Server Components s bezpečnostními bránami firewall

Jestliže máte problémy s komunikací přes bezpečnostní bránu firewall, je možné v bráně firewall otevřít jiné porty. Pokud nevíte, zda je pro přijímání datového proudu ASF ze služby Windows Media Services nutné bránu upravit, obraťte se na dodavatele bezpečnostní brány firewall a seznamte se s údaji uvedenými v následující tabulce. Tato tabulka je sestavena z pozice klienta umístěného uvnitř brány firewall, který přijímá datové proudy ASF ze serveru Windows Media umístěného vně bezpečnostní brány. Port Vstup je port, který je využíván serverem k průchodu bezpečnostní bránou firewall. Port Výstup je port, který využívá program Microsoft Windows Media Player ke komunikaci se serverem.

Protokol | Port Vstup | Port Výstup
MMS (vysílání Multicast) | adresa IP 224.0.0.1 - 239.255.255.255 | 1 - 65000
MMS-UDP (vysílání Unicast) | 1755 (TCP) | 1024 - 5000 (UDP)
MMS-TCP (vysílání Unicast) | 1755 (TCP) | 1755 (TCP)
HTTP | 80 |
MSBD(1) | Port 7007 (TCP) nebo libovolný port vytvořený ke komunikaci mezi serverem a programem Windows Media Encoder, který nevyužívá model DCOM | 7007 (TCP)
DCOM(2) | 135 (TCP) |
(1) Pokud je ze serveru Windows Media šířen datový proud, který je odesílán z jiného serveru Windows Media, a tento server již využívá port 7007, bude první připojení provedeno přes port 7007 a další připojení přes náhodně vybraný port v rozsahu portů od 1024 do 5000.
(2) Model DCOM (Distributed Component Object Model) dynamicky přiděluje každé komunikaci jeden port. Chcete-li povolit průchod všech komunikací modelu DCOM bezpečnostní bránou firewall, je nutné přiřadit takový počet portů, který odpovídá počtu současně probíhajících komunikací modelu DCOM přes bránu firewall. Otevřete pro každou komunikaci porty UDP a TCP, které odpovídají číslům používaných portů. Dále je nutné otevřít port TCP/UDP 135 využívaný pro mapování koncových bodů vzdáleného volání procedur (RPC). Vytvořte klíč registru HKEY_LOCAL_MACHINES\Software\Microsoft\Rpc\Internet a určete v tomto klíči vyhrazené porty.

Příklad omezení rozsahu portů modelu DCOM na 10 portů:

Named Value: Ports
Type: REG_MULTI_SZ
Setting: Rozsah portu. Je možné zadat více řádků, například:
3001-3010
135

Named Value: PortsInternetAvailable
Type: REG_MULTI_SZ
Setting:"Y"

Named Value: UseInternetPorts
Type: REG_MULTI_SZ
Setting:"Y"

Poznámka

  • Počítač umístěný vně bezpečnostní brány firewall musí mít umožněn přístup k počítači uvnitř brány pomocí adresy IP počítače. Převod adres a použití proxy serveru nejsou povoleny.


Konfigurace serveru Windows Media s bezpečnostní bránou firewall

Nainstalujete-li součásti Windows Media Server Components, bude ve výchozím nastavení povoleno vysílání datového proudu pomocí protokolu MMS pro vysílání Unicast a služby stanic. Protokol MMS lze použít s protokolem UDP nebo TCP - záleží na tom, který protokol byl zadán. Správce Windows Media použije ke komunikaci se součástmi Windows Media Server Components model DCOM. Tímto způsobem lze pomocí vysílání Unicast posílat obsah datového proudu ASF libovolnému uživateli v síti intranet. Chcete-li vysílat obsah v podobě datového proudu ASF v síti intranet, je nutné pro směrovače sítě povolit vysílání Multicast. V opačném případě datový proud nepronikne za místní segment, odkud je vysílán.


Scénář 1: Server Windows Media a klienti jsou uvnitř bezpečnostní brány firewall

Bezpečnostní brána firewall v tomto typickém příkladě podnikové sítě odděluje podnikovou místní síť a síť Internet.


Scénář 2: Server Windows Media a klienti jsou vně bezpečnostní brány firewall

Chcete-li povolit klientům v síti Internet odesílání datového proudu ASF ze serveru Windows Media, je nutné umístit server vně podnikové bezpečnostní brány firewall. Pokud umístíte server Windows Media uvnitř podnikové bezpečnostní brány firewall, je nutné pro komunikaci klientů v síti Internet se serverem otevřít v bráně firewall konkrétní port. Komunikace mezi klienty a serverem Windows Media probíhá v příkladu znázorněném na obrázku pomocí standardních protokolů služby Windows Media Services.


Scénář 3: Server Windows Media a klienti jsou odděleni bezpečnostní bránou firewall

Chcete-li odeslat datový proud klientům odděleným bezpečnostní bránou firewall, je nutné tento datový proud poslat přes otevřený port v bráně. Port, který server Windows Media používá k vysílání datových proudů pomocí protokolu MMS (obvykle port 1755), lze změnit. Můžete také nastavit server Windows Media tak, aby vysílal datový proud pomocí protokolu HTTP. Výchozí port pro vysílání datového proudu HTTP je port 80. Další informace naleznete v tématu Použití vysílání datového proudu HTTP.

Konfigurace programu Windows Media Player (server Windows Media a klienti jsou odděleni bezpečnostní bránou firewall)

Ve výchozím nastavení využívá program Windows Media Player pro přístup k datovým proudům ASF, které se nacházejí za bezpečnostní bránou firewall, nastavení proxy serveru nakonfigurované v použitém prohlížeči sítě WWW. Pokud je aplikace Internet Explorer 5 nakonfigurována k automatickému rozpoznávání proxy serveru sítě, bude program Windows Media Player po nainstalování používat toto nastavení také. Jestliže je automatické rozpoznávání úspěšné, použije program Windows Media Player pro přístup k obsahu nacházejícího se za bezpečnostní bránou firewall stejný proxy server jako prohlížeč sítě WWW. Pokud nelze nastavení proxy serveru určit pomocí automatického rozpoznávání v prohlížeči, je nutné nakonfigurovat nastavení proxy serveru v programu Windows Media Player ručně.

Jestliže se změní server nastavený jako proxy server, nebude možné k novému proxy serveru program Windows Media Player připojit. Pokud nebylo pomocí programu Windows Media Player automatické rozpoznávání nastavení proxy serveru v prohlížeči spuštěno déle než týden, bude znovu spuštěno při dalším použití programu Windows Media Player k načítání datového proudu. Automatické rozpoznávání bude použito k nalezení a konfiguraci nového nastavení proxy serveru.

Chcete-li, aby bylo programem Windows Media Player automatické rozpoznávání spuštěno před uplynutím týdenního intervalu, klepněte v programu Windows Media Player na kartě Upřesnění nastavení přehrávání pro vysílání datového proudu HTTP na přepínač Bez proxy serveru a potom na přepínač Nastavení proxy serveru v prohlížeči. Jestliže problémy s automatickým rozpoznáváním přetrvávají, klepněte na přepínač Používat proxy server a požadovaný proxy server nakonfigurujte.


Použití vysílání datového proudu HTTP

Vysílání datového proudu HTTP obvykle využívá port 80, a je proto vhodné k vysílání datového proudu přes bezpečnostní bránu firewall. Bezpečnostní bránou firewall není ve většině případů port 80 blokován. Součásti Windows Media Server Components jsou ve výchozím nastavení nakonfigurovány pro vysílání datového proudu pomocí protokolu MMS. Je však také možné nakonfigurovat vysílání datového proudu pomocí protokolu HTTP. V případě, že potřebujete obsah vysílat přes bezpečnostní bránu firewall, představuje vysílání datového proudu ASF pomocí protokolu HTTP doporučenou metodu.

Součásti Windows Media Server Components obsahují dvě služby: službu Windows Media Unicast Service a službu Windows Media Station Service. Změníte-li nastavení součástí Windows Media Server Components tak, aby bylo používáno vysílání datového proudu HTTP, bude tomuto vysílání nutné přiřadit jednu z těchto služeb. Služby Windows Media Unicast Service a Windows Media Station Service nelze vázat na stejný port, je proto nutné každou službu nakonfigurovat jinak.


Změna portu vázaného na službu HTTP

Výchozí port pro službu HTTP je u služby IIS port 80. Pokud jsou součásti Windows Media Server Components umístěny ve stejném počítači jako server WWW a je pro tyto součásti povoleno vysílání datového proudu pomocí protokolu HTTP, je možné, že dojde při vazbě na port 80 mezi součástmi Windows Media Server Components a serverem WWW ke konfliktu.

Změnou portu, na který bude služba HTTP vázána, lze vyřešit konflikty portu, je však také možné, že touto změnou dojde k nesprávné funkci služby HTTP. Měli byste si být vědomi, že většina příchozích dat HTTP se pokusí využít port 80. Pokud tento port není průchozí, budou data ztracena.


Použití součástí Windows Media Server Components a služby IIS na stejném serveru

Pokud použijete výchozí hodnoty, lze používat součásti Windows Media Server Components a službu IIS (Microsoft Internet Information Services) ve stejném počítači. Služba Windows Media Unicast Service je vázána na port 1755, služba Windows Media Station Service na port 7007 a služba IIS na port 80.

Chcete-li odesílat obsah datového proudu ASF pomocí protokolu HTTP, je nutné mít pro služby Windows Media Unicast Service a Windows Media Station Service k dispozici adresu IP na portu 80. Pokud je na serveru nainstalována služba IIS verze 3.0 nebo nižší, nelze ze součástí Windows Media Server Components odesílat obsah datového proudu ASF pomocí protokolu HTTP. Služba IIS je na všech dostupných adresách IP vázána na port 80. Služba IIS verze 4.0 a vyšší však umožňuje určit adresu IP, kterou lze pro odesílání datového proudu HTTP při navázání služby IIS na port 80 použít. Tímto způsobem lze zajistit, aby byla pro službu Windows Media Unicast Service a službu Windows Media Station Service k odesílání obsahu datového proudu pomocí protokolu HTTP využita jiná adresa IP, která je k dispozici. Chcete-li pro službu Windows Media Unicast Service nebo Windows Media Station Service povolit vysílání datového proudu pomocí protokolu HTTP, je nutné nekonfigurovat servery WWW služby IIS verze 4.0 nebo vyšší pro použití se všemi nepřiřazenými adresami IP.

Pokud chcete použít vysílání datového proudu HTTP v počítači s nainstalovanými součástmi Windows Media Server Components a službou IIS 4.0 nebo vyšší, je nutné splnit následující požadavky:

  • na síťovou kartu musí být vázány nejméně dvě adresy IP,
  • musí existovat jedinečný server DNS (Domain Name Server), záznamy zdroje adres IP serveru Windows Media a služby IIS.

Poznámka

  • Vysílání datového proudu HTTP lze pro služby Windows Media Unicast Service a Windows Media Station Service povolit na stránce Vlastnosti Serveru ve Správci Windows Media.


Definování typu MIME technologie Windows Media ve službě IIS

Titulek služby Windows Media Services

Definování typů MIME technologie Windows Media ve službě IIS

Typy MIME (Multipurpose Internet Mail Extension) je nutné na serveru WWW definovat. Obdrží-li server WWW požadavek obsahující neznámou příponu souboru (například ASF a ASX), bude možné pomocí typů MIME problém vyřešit. Server WWW nemůže bez tohoto záznamu soubor převést.


Spuštění programu Windows Backup pro službu Windows Media Services

Pokud je služba Windows Media Program Service spuštěna, je databáze programů uzamčena pro výhradní použití, a programu Microsoft Windows Backup není proto k této databázi umožněn přístup Obnovíte-li po spuštění programu Microsoft Windows Backup systém, nebudou obnoveny následující konfigurační soubory programu:

%SystemRoot%\system32\Windows Media\Server\ASDB\mdsas.mdb
%SystemRoot%\system32\Windows Media\Server\ASDB\mdsas.ldb

Chcete-li, aby bylo zálohování a obnovení dat konfigurace programu provedeno správně, je nutné postupovat podle kroků uvedených v následujících tématech:

  • Zálohování programů služby Windows Media Services
  • Obnovení programů služby Windows Media Services


Vysílání Unicast

Připojení vysílání Unicast je spojení typu point-to-point mezi klientem a serverem, které klientovi zajistí doručení samostatného datového proudu. Toto téma obsahuje informace o vytváření a správě adresářů pro publikování a správě a sledování událostí a klientů adresářů pro publikování pomocí Správce Windows Media.


Běžné postupy

Tato část obsahuje často používané postupy při vytváření a správě vysílání Unicast. Tyto postupy slouží k rychlému provedení úkolu. Část následující za tímto seznamem postupů obsahuje přehled informací popisujících vysílání Unicast podrobněji. Chcete-li zobrazit podrobnější informace o vysílání Unicast, přejděte na následující část.


Konfigurace a přístup k souborům ASF na požádání

  1. Spusťte program Microsoft Windows Media Player.
  2. V nabídce Soubor klepněte na příkaz Otevřít.
  3. Do rozevíracího pole v dialogovém okně Otevřít zadejte adresu URL (mms://server_Windows_Media/soubor.asf) a klepněte na tlačítko OK.

    Program Windows Media Player načte soubor do vyrovnávací paměti a soubor soubor.asf přehraje.

Poznámka

  • Součásti Windows Media Server Components jsou po instalaci připraveny k vysílání obsahu datového proudu na požádání. Výchozí kořenový adresář pro publikování je adresář Systémová_jednotka\ASFRoot.


Konfigurace a přístup k datovým proudům (živého) kontinuálního vysílání Unicast

  1. Spusťte program Microsoft Windows Media Player.
  2. V nabídce Soubor klepněte na příkaz Otevřít.
  3. Do rozevíracího pole v dialogovém okně Otevřít zadejte adresu URL aliasu adresáře pro publikování kontinuálního vysílání Unicast (mms://server_Windows_Media/alias_adresáře_pro_publikování) a klepněte na tlačítko OK.

    Program Windows Media Player načte datový proud do vyrovnávací paměti a přehraje datový proud z adresáře pro publikování kontinuálního vysílání Unicast.

Poznámka

  • Obsah datového proudu s živým vysíláním je možné vytvořit pomocí programu Windows Media Encoder, vzdálené stanice nebo vzdáleného adresáře pro publikování vysílání Unicast a šířit pomocí adresářů pro publikování kontinuálního vysílání Unicast. Program Windows Media Player se připojí k adresářům pro publikování kontinuálního vysílání Unicast a získá přístup k obsahu.


Vytvoření adresáře pro publikování vysílání Unicast na požádání pomocí Rychlého nastavení

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. Přesvědčte se, zda je zaškrtnuto políčko Vytvořit nový adresář pro publikování na požádání pomocí průvodce, klepněte na tlačítko Na požádání a potom na příkaz Nový.

    Zobrazí se okno Průvodce rychlým nastavením - datové proudy vysílání Unicast na požádání.

  3. Na obrazovce Výběr adresáře pro publikování klepněte na přepínač Vytvořit adresář pro publikování.
  4. Na obrazovce Vytvoření nového adresáře pro publikování zadejte alias nového adresáře pro publikování vysílání Unicast na požádání do pole Alias. Do pole Cesta zadejte cestu k adresáři pro publikování vysílání Unicast na požádání. Tento adresář může být umístěn na místní jednotce nebo v jiném počítači.
  5. Na obrazovce Vyhledání cílového souboru s příponou ASF zadejte cestu k souboru ASF, který chcete publikovat. Zadejte název a příponu souboru ASF.
  6. Na obrazovce Výběr způsobu publikování vyberte požadovaný protokol pro publikování. Vyberte možnosti publikování, které umožní programu Microsoft Windows Media Player přístup k vysílání Unicast na požádání.

    Další informace o protokolech pro publikování naleznete v tématu Protokoly služby Windows Media Services.

    Ve výchozím nastavení vytvoří součásti Windows Media Server Components v adresáři pro publikování vysílání Unicast na požádání oznámení. Další informace o oznámeních naleznete v tématu Oznámení vysílání Unicast pomocí souboru ASX.

    Informace o dalších možnostech publikování naleznete v tématu Publikování datového proudu vysílání Unicast.

  7. Na obrazovce Připraveno k publikování je zobrazen seznam možností, které byly vybrány. Chcete-li některou z těchto možností upravit, můžete zobrazit odpovídající informace adresáře pro publikování vysílání Unicast na požádání pomocí tlačítka Zpět.
  8. Pokud nechcete soubor ASX odesílat uživatelům elektronickou poštou, uložte ho do přístupného adresáře. Soubory HTM vytvořené vybraným způsobem publikování uložte do adresářů, které mohou uživatelé otevřít přímo nebo prostřednictvím serveru WWW.

Poznámka

  • Na obrazovce Publikování je dokončeno lze datový proud z adresáře pro publikování vysílání Unicast na požádání vyzkoušet. Chcete-li funkci vysílání obsahu adresáře pro publikování vysílání Unicast na požádání vyzkoušet, klepněte tlačítko Test adresy URL, Test souboru ASX, Test souboru HTM - <HREF> nebo Test souboru HTM - <OBJECT>. Obsah bude otevřen v programu Windows Media Player.


Vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí Rychlého nastavení

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. Přesvědčte se, zda je zaškrtnuto políčko Vytvořit nový adresář pro publikování vysílání pomocí průvodce, klepněte na tlačítko Vysílání a pak na příkaz Nový.

    Zobrazí se okno Průvodce rychlým nastavením - datové proudy vysílání Unicast.

  3. Na obrazovce Výběr adresáře pro publikování klepněte na přepínač Vytvořit adresář pro publikování vysílání.
  4. Na obrazovce Zadání zdroje vyberte zdroj vysílaného obsahu.
  5. Na obrazovce Nový adresář pro publikování vysílání (vybraný zdroj pro vysílání obsahu) zadejte alias nového adresáře pro publikování kontinuálního vysílání Unicast do pole Alias. Do pole Cesta zadejte odpovídající cestu. Pokud je zdrojem vysílání program Windows Media Encoder, přesvědčte se, zda pole Port obsahuje odpovídající hodnotu.

    Ve výchozím nastavení využívá cesta adresáře pro publikování kontinuálního vysílání Unicast ke zdrojům z programu Windows Media Encoder nebo vzdálené stanici Windows Media protokol MSBD. Výchozí protokol pro cestu adresáře pro publikování kontinuálního vysílání Unicast ke zdrojům vzdáleného adresáře pro publikování vysílání Unicast je protokol MMS. Příklady použití těchto typů cest naleznete v tématu Použití adresářů pro publikování kontinuálního vysílání Unicast.

    Adresář pro publikování kontinuálního vysílání Unicast lze k libovolnému z těchto zdrojů obsahu vysílání připojit také pomocí protokolu HTTP. Další informace o použití protokolu HTTP naleznete v tématu Nastavení a správa vysílání datových proudů HTTP a distribuce pomocí protokolu HTTP.

  6. Na obrazovce Výběr způsobu publikování vyberte požadovaný protokol pro publikování. Vyberte možnosti publikování, které programu Microsoft Windows Media Player umožní přístup k obsahu s živým vysíláním z adresáře pro publikování kontinuálního vysílání Unicast.

    Další informace o protokolech pro publikování naleznete v tématu Protokoly služby Windows Media Services.

    Ve výchozím nastavení vytvoří součásti Windows Media Server Components oznámení. Další informace o oznámeních naleznete v tématu Oznámení vysílání Unicast pomocí souboru ASX.

    Informace o dalších možnostech publikování naleznete v tématu Publikování datového proudu vysílání Unicast.

  7. Na obrazovce Připraveno k publikování se zobrazí možnosti, které byly vybrány. Chcete-li některou z těchto možností upravit, můžete zobrazit odpovídající informace adresáře pro publikování vysílání Unicast na požádání pomocí tlačítka Zpět.
  8. Pokud nechcete soubor ASX odesílat uživatelům elektronickou poštou, uložte ho do přístupného adresáře. Soubory HTM vytvořené vybraným způsobem publikování uložte do adresářů, které mohou uživatelé otevřít přímo nebo prostřednictvím serveru WWW.

Poznámka

  • Na obrazovce Publikování je dokončeno lze datový proud z adresáře pro publikování vysílání Unicast na požádání vyzkoušet. Chcete-li funkci vysílání obsahu adresáře pro publikování vysílání Unicast na požádání vyzkoušet, klepněte tlačítko Test adresy URL, Test souboru ASX, Test souboru HTM - <HREF> nebo Test souboru HTM - <OBJECT>. Obsah bude otevřen v programu Windows Media Player.


Vytvoření adresáře pro publikování vysílání Unicast na požádání pomocí upřesňujícího postupu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. Ujistěte se, že na stránce Adresáře pro publikování vysílání Unicast není zaškrtnuto políčko Vytvořit nový adresář pro publikování na požádání pomocí průvodce.
  3. Klepněte na tlačítko Na požádání a potom na příkaz Nový.

    Zobrazí se stránka Nový adresář pro publikování na požádání vysílání Unicast.

  4. Do pole Alias zadejte název nového adresáře pro publikování na požádání.
  5. Do pole Cesta adresáře zadejte cestu k fyzickému adresáři, ve kterém je možné uložit soubor ASF.
  6. (Nepovinné) Chcete-li omezit počet klientů, které bude možné k adresáři pro publikování připojit, vyberte v rozevíracím seznamu Maximální počet klientů položku Omezit na a do příslušného pole zadejte počet klientů.
  7. (Nepovinné) Jestliže chcete omezit maximální šířku pásma sítě, kterou bude možné z adresáře pro publikování vysílat, klepněte v rozevíracím seznamu Maximální šířka pásma na položku Omezit na a do pole kb/s zadejte maximální hodnotu šířky pásma.


Vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí upřesňujícího postupu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. Ujistěte se, že na stránce Adresáře pro publikování vysílání Unicast není zaškrtnuto políčko Vytvořit nový adresář pro publikování vysílání pomocí průvodce.
  3. Klepněte na tlačítko Vysílání a potom na příkaz Nový.

    Zobrazí se stránka Nový adresář pro publikování vysílání.

  4. Do pole Alias zadejte název nového adresáře pro publikování vysílání.
  5. V rozevíracím seznamu Typ cesty vyberte součást Windows Media Component, pomocí které bude živý datový proud vysílán - program Windows Media Encoder, vzdálený adresář pro publikování nebo vzdálená stanice.
  6. Do pole Adresa URL zadejte cestu ke zdroji, který je uveden v rozevíracím seznamu Typ cesty.

    V adrese URL je nutné použít protokol MSBD.

  7. Jestliže v rozevíracím seznamu Typ cesty vyberete program Windows Media Encoder, zadejte do pole Port číslo portu, který kodér používá k doručení zdroje.
  8. (Nepovinné) Chcete-li omezit počet klientů, které bude možné k tomuto adresáři pro publikování připojit, klepněte v rozevíracím seznamu Maximální počet klientů na položku Omezit na a do pole zadejte počet klientů.
  9. (Nepovinné) Jestliže chcete omezit maximální šířku pásma sítě, kterou bude možné z adresáře pro publikování vysílat, klepněte v rozevíracím seznamu Maximální šířka pásma na položku Omezit na a do pole kb/s zadejte maximální hodnotu šířky pásma.


Povolení vysílání datového proudu HTTP pro službu Windows Media Unicast Service

  1. Ukončete všechny aplikace a zastavte všechny služby, které jsou vázány na port 80.
  2. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Vlastnosti serveru.

  3. Na stránce Konfigurace serveru - vlastnosti serveru klepněte na kartu Vysílání a distribuce HTTP.
  4. Klepněte na přepínač Povolit vysílání datových proudů HTTP pro službu Windows Media Unicast Service.
  5. Klepněte na tlačítko Použít.

    Zobrazí se zpráva s upozorněním, že nové nastavení se projeví až po restartování počítače, ve kterém jsou nainstalovány součásti Windows Media Server Components.

  6. V dialogovém okně zprávy klepněte na tlačítko OK a restartujte hostitelský počítač součástí Windows Media Server Components.

Poznámka

  • Povolíte-li pro službu Windows Media Unicast Service vysílání datového proudu HTTP, bude pomocí Správce Windows Media vysílání datového proudu HTTP nakonfigurováno na používání portu 80. Pokud nevytvoříte závislost služby Windows Media Services na službě WWW a bude povoleno vysílání datového proudu prostřednictvím portu 80, nebude možné spustit součásti Windows Media Server Components a server HTTP na stejném počítači. Další informace o vytvoření závislosti naleznete v tématu Vytvoření závislosti služby Windows Media Unicast Service na serveru WWW úpravou registru. Port 80 je využíván součástmi Windows Media Server Components i službou HTTP.


Zakázání vysílání datového proudu HTTP pro službu Windows Media Unicast Service

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Vlastnosti serveru.

  2. Na stránce Konfigurace serveru - vlastnosti serveru klepněte na kartu Vysílání a distribuce HTTP.
  3. Klepněte na přepínač Zakázat vysílání datových proudů a distribuci HTTP.
  4. Klepněte na tlačítko Použít.

    Zobrazí se zpráva s upozorněním, že nové nastavení se projeví až po restartování počítače, ve kterém jsou nainstalovány součásti Windows Media Server Components.

  5. V dialogovém okně zprávy klepněte na tlačítko OK a restartujte hostitelský počítač součástí Windows Media Server Components.

Poznámka

  • Ve výchozím nastavení je vysílání datového proudu HTTP zakázáno. U tohoto postupu platí předpoklad, že je pro součásti Windows Media Server Components vysílání datového proudu HTTP povoleno.


Vytvoření souboru oznámení pro vysílání Unicast na požádání

  1. Otevřete textový editor (například program Poznámkový blok) a do nového dokumentu zkopírujte a vložte následující syntaxi:
    <asx version = "3.0">
  <title>název</title>
  <entry>
    <ref href = "mms://název_serveru/cesta_adresáře/soubor.asf"/>
  </entry>
</asx>
  2. Syntaxi je možné upravit nahrazením vzorů vlastními informacemi podle následující tabulky.
    Vzor | Popis
    Název | Název, který chcete po zpracování souboru ASF zobrazit v programu Microsoft Windows Media Player jako název Prezentace.
    Mms | Pokud jsou součásti Windows Media Server Components nakonfigurovány pro vysílání datového proudu HTTP, je možné nahradit protokol MMS protokolem HTTP.
    Název_serveru | Název serveru Windows Media obsahujícího adresář pro publikování vysílání Unicast na požádání, na který chcete vytvořit odkaz.
    Cesta_adresáře | Cesta k adresáři pro publikování vysílání Unicast na požádání, na který chcete vytvořit odkaz, pokud tímto adresářem není kořenový adresář pro publikování.
    Soubor.asf | Název souboru ASF v adresáři pro publikování vysílání Unicast na požádání, který chcete oznámit.

  3. Dokument uložte jako soubor s prostým textem a příponou ASX do sdíleného adresáře nebo na server HTTP.

    Soubor oznámení lze nyní použít. Tento soubor je možné připojit ke zprávě elektronické pošty, použít jako objekt syntaxe HREF na stránce WWW nebo uložit na místním serveru.

Poznámky

  • Jestliže k vytvoření adresáře pro publikování vysílání Unicast na požádání použijete Průvodce rychlým nastavením, budou soubory oznámení (soubory ASX) vytvořeny automaticky. Další informace naleznete v kroku 6 tématu Vytvoření adresáře pro publikování vysílání Unicast na požádání pomocí Rychlého nastavení.
  • Tento postup předpokládá, že adresář pro publikování vysílání Unicast na požádání nebyl vytvořen pomocí Průvodce rychlým nastavením a že chcete oznámení uloženého souboru ASF vytvořit.


Vytvoření souboru oznámení pro kontinuální vysílání Unicast

  1. Otevřete textový editor (například program Poznámkový blok) a do nového dokumentu zkopírujte a vložte následující syntaxi.
    <asx version = "3.0">
  <title>název</title>
  <entry>
    <ref href = "mms://název_serveru/adresář_pro_publikování"/>
  </entry>
</asx>
  2. Syntaxi je možné upravit nahrazením vzorů vlastními informacemi podle následující tabulky.
    Vzor | Popis
    Název | Název, který chcete po zpracování datového proudu zobrazit v programu Microsoft Windows Media Player jako název Prezentace.
    Mms | Pokud jsou součásti Windows Media Server Components nakonfigurovány pro vysílání datového proudu HTTP, je možné nahradit protokol MMS protokolem HTTP.
    Název_serveru | Název serveru Windows Media obsahujícího adresář pro publikování kontinuálního vysílání Unicast, na který chcete vytvořit odkaz.
    Adresář_pro_publikování | Alias adresáře pro publikování kontinuálního vysílání Unicast.

  3. Dokument uložte jako soubor s prostým textem a příponou ASX do sdíleného adresáře nebo na server HTTP.

    Soubor oznámení lze nyní použít. Tento soubor je možné připojit ke zprávě elektronické pošty, použít jako objekt syntaxe HREF na stránce WWW nebo uložit na místním serveru.

Poznámky

  • Jestliže k vytvoření adresáře pro publikování kontinuálního vysílání Unicast použijete Průvodce rychlým nastavením, budou soubory oznámení (soubory ASX) vytvořeny automaticky. Další informace naleznete v kroku 6 tématu Vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí Rychlého nastavení.
  • Tento postup předpokládá, že adresář pro publikování kontinuálního vysílání Unicast nebyl vytvořen pomocí Průvodce rychlým nastavením a že chcete oznámení živého datového proudu vytvořit.


Úpravy adresáře pro publikování vysílání Unicast na požádání

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. V seznamu klepněte na adresář pro publikování na požádání, který chcete aktualizovat, a klepněte na tlačítko Na požádání.
  3. Klepněte na příkaz Vlastnosti.
  4. Chcete-li změnit alias adresáře pro publikování, zadejte nový název do pole Alias.
  5. Pokud chcete změnit umístění adresáře pro publikování na požádání, zadejte nové umístění do pole Cesta adresáře nebo k zadání nové cesty použijte tlačítko Procházet. Pokud jde o adresář v jiném počítači, můžete také zadat cestu ke vzdálenému umístění pomocí adresy UNC.
  6. Jestliže chcete z daného adresáře pro publikování vysílání Unicast na požádání vytvořit nový kořenový adresář pro publikování, klepněte na přepínač Domovský.
  7. Chcete-li nastavit omezení počtu klientů, kterým bude k adresáři pro publikování umožněn přístup, vyberte v rozevíracím seznamu Maximální počet klientů položku Omezit na a do pole klientů zadejte požadovaný počet. Pokud chcete omezit šířku pásma využitou vysíláními Unicast, která jsou vysílána z tohoto adresáře pro publikování, vyberte v rozevíracím seznamu Maximální šířka pásma položku Omezit na a do pole kb/s zadejte požadovanou hodnotu.

    Další informace o nastavení omezení pro klienty a šířku pásma naleznete v tématu Řízení připojení klientů a využití šířky pásma.

Poznámka

  • Pokud nastavíte některý adresář pro publikování jako nový kořenový adresář pro publikování, bude aktuální kořenový adresář pro publikování odstraněn. Jestliže přiřadíte adresáři pro publikování alias a nastavíte tento adresář pomocí přepínače Domovský jako kořenový adresář pro publikování, bude použitý alias nahrazen aliasem Domovský adresář. Změníte-li kořenový adresář pro publikování, nebudou soubory ASF z předchozího kořenového adresáře již publikovány a nebude je možné vysílat.


Úpravy adresáře pro publikování kontinuálního vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. V seznamu klepněte na adresář pro publikování kontinuálního vysílání, který chcete aktualizovat, a klepněte na tlačítko Vysílání.
  3. Klepněte na příkaz Vlastnosti.
  4. Chcete-li změnit alias adresáře pro publikování vysílání, zadejte nový název do pole Alias.
  5. Pokud vzdálené vysílání šíří datový proud z nového zdroje, zadejte aktualizovanou adresu URL do pole Adresa URL. Jestliže program Windows Media Encoder vysílá vzdálené vysílání z nového umístění, přesvědčte se, zda je datový proud z programu Windows Media Encoder vysílán prostřednictvím výchozího portu (7007). Pokud tomu tak není, zadejte příslušné číslo portu do pole Port.
  6. Chcete-li nastavit omezení počtu klientů, kterým bude k adresáři pro publikování vysílání umožněn přístup, vyberte v rozevíracím seznamu Maximální počet klientů možnost Omezit na a do pole klientů zadejte požadovaný počet. Pokud chcete omezit šířku pásma využitou vysíláním, vyberte v rozevíracím seznamu Maximální šířka pásma položku Omezit na a do pole kb/s zadejte požadovanou hodnotu.

    Další informace o nastavení omezení pro klienty a šířku pásma naleznete v tématu Řízení připojení klientů a využití šířky pásma.


Odebrání adresáře pro publikování vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Adresáře pro publikování vysílání Unicast.

    Zobrazí se stránka Adresáře pro publikování vysílání Unicast.

  2. Klepněte na adresář pro publikování Na požádání nebo Vysílání, který chcete ze seznamu adresářů pro publikování odebrat.
  3. Podle typu vybraného adresáře pro publikování klepněte na tlačítko Na požádání nebo Vysílání a potom klepněte na příkaz Odstranit.

Poznámka

  • Kořenový adresář pro publikování vysílání Unicast na požádání nelze odebrat.


Řízení počtu připojení klientů k serveru Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Konfigurace serveru - vlastnosti serveru. Jako výchozí se zobrazuje obsah na kartě Obecné.

  2. V rozevíracím seznamu Maximální počet klientů vyberte položku Omezit na a do pole klientů zadejte požadovaný počet připojení klientů.
  3. Chcete-li změny uložit, klepněte na tlačítko Použít.

Poznámka

  • Server Windows Media může použít menší počet připojení, než bylo zadáno. Další informace naleznete v tématu Výpočet maximálního počtu efektivních připojení klientů.


Řízení celkové šířky pásma vysílané serverem Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Konfigurace serveru - vlastnosti serveru. Jako výchozí se zobrazuje obsah na kartě Obecné.

  2. V rozevíracím seznamu Maximální šířka pásma vyberte položku Omezit na a do pole kb/s zadejte hodnotu pro maximální šířku pásma, se kterou bude možné ze serveru Windows Media vysílat.
  3. Chcete-li změny uložit, klepněte na tlačítko Použít.

Poznámka

  • Omezení maximální šířky pásma nesmí přesahovat 85 procent kapacity síťové karty. Zadaná hodnota může mít také vliv na počet připojení klientů k serveru. Další informace naleznete v tématu Výpočet maximálního počtu efektivních připojení klientů.


Omezení šířky pásma využitelné soubory ASF

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Konfigurace serveru - vlastnosti serveru. Jako výchozí se zobrazuje obsah na kartě Obecné.

  2. V rozevíracím seznamu Maximální přenosová rychlost souborů vyberte položku Omezit na.
  3. Do pole kb/s zadejte maximální šířku pásma, která bude povolena pro obsah ASF vysílaný ze serveru Windows Media ve formě datového proudu.
  4. Chcete-li změny uložit, klepněte na tlačítko Použít.

Poznámka

  • Pokud některý obsah ASF překročí hodnotu nastavenou v poli Maximální přenosová rychlost souborů, nebude tento obsah ze serveru Windows Media vysílán.


Zadání maximálního počtu připojení klientů za sekundu

  1. V dialogovém okně Spustit zadejte příkaz regedit. Bude spuštěn Editor registru.
  2. Přejděte na následující klíč registru: HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Services\ nsunicast\ Parameters\.
  3. V nabídce Úpravy přejděte na příkaz Nový a klepněte na položku Nová hodnota DWORD. V seznamu klíčů registru se zobrazí položka Nová položka #1.
  4. Klepněte na položku Nová položka #1, v nabídce Úpravy klepněte na příkaz Přejmenovat a přejmenujte tuto položku na MaxConnectionsPerSecond.
  5. V nabídce Úpravy klepněte na příkaz Změnit.
  6. Do pole Údaj hodnoty zadejte požadovaný maximální počet připojení klientů za sekundu. Výchozí hodnota je 25.
  7. Ve skupinovém rámečku Číselná soustava klepněte na přepínač Desítková. Klepněte na tlačítko OK.


Zobrazení připojení klientů adresáře pro publikování vysílání Unicast na serveru Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Klienti adresářů pro publikování.

    Zobrazí se stránka Klienti adresáře pro publikování.

  2. Zaškrtněte políčko Povolit sledování klientů.

    Všichni klienti, kteří jsou aktuálně připojeni k serveru, se po uplynutí intervalu nastaveného po zaškrtnutí políčka Automaticky obnovit každých zobrazí v seznamu Klienti adresářů pro publikování. Výchozí nastavení automatického obnovení je 30 sekund.

    Počet připojení klientů k serveru je zobrazen nad seznamem, například:

    Existuje 5 připojení.

Poznámka

  • Na této stránce lze seřadit seznam klientů připojených k serveru, určit interval pro aktualizaci seznamu a ukončit připojení klientů k serveru. Další informace naleznete v tématu Správa klientů adresáře pro publikování vysílání Unicast.


Ukončení připojení klientů adresáře pro publikování vysílání Unicast na serveru Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Klienti adresářů pro publikování.

    Zobrazí se stránka Klienti adresáře pro publikování.

  2. Chcete-li zobrazit seznam klientů, kteří jsou k serveru připojeni, postupujte podle pokynů v tématu Zobrazení připojení klientů adresáře pro publikování vysílání Unicast na serveru Windows Media.
  3. Pokud chcete ukončit připojení některého klienta k serveru, vyberte požadovaného klienta v seznamu a klepněte na tlačítko Ukončit výběr.
  4. Jestliže chcete ukončit všechna připojení klientů k serveru, klepněte na tlačítko Vybrat vše a potom na tlačítko Ukončit výběr.


Vytvoření vysílání Unicast pomocí Správce Windows Media

Obsahem vysílání Unicast může být multimediální obsah uložený jako soubor ASF, datový proud ASF s živým vysíláním vytvořený programem Windows Media Encoder nebo stanice vysílaná ze vzdáleného serveru Windows Media.

Chcete-li vytvořit vysílání Unicast, je třeba provést následující činnosti:

  • Vytvoření multimediálního obsahu uloženého jako soubor ASF nebo datového proudu s živým vysíláním z programu Windows Media Encoder. Doporučujeme vyhradit samostatný svazek NTFS pro uložení obsahu na požádání. Nejlepších výsledků dosáhnete umístěním tohoto svazku na samostatný fyzický disk. Svazky NTFS jsou z hlediska využití prostoru pro ukládání a operací spojených se čtením z disku efektivnější než oddíly systému FAT16. Svazek NTFS také umožňuje u souborů s obsahem použití kontroly seznamu řízení přístupu (ACL).
  • Vytvoření a správa adresářů pro publikování vysílání Unicast. K uložení obsahu ASF je u vysílání Unicast, pro které je zdrojem uložený soubor ASF, používán adresář pro publikování vysílání Unicast na požádání. Pro směrování klientů ke zdroji datového proudu je u vysílání Unicast, pro které je zdrojem obsah datového proudu s živým vysíláním, používán adresář pro publikování kontinuálního vysílání Unicast. Tyto adresáře pro publikování vysílání Unicast lze vytvořit a spravovat pomocí Správce Windows Media.

    Další informace o adresářích pro publikování kontinuálního vysílání Unicast a vysílání Unicast na požádání naleznete v tématu Datové proudy na požádání a datové proudy kontinuálního vysílání.

  • Konfigurace součástí Windows Media Server Components. Počet připojení klientů k serveru Windows Media, šířku pásma sítě, kterou server spotřebuje, a šířku pásma, kterou spotřebuje datový proud, lze nastavit pomocí Správce Windows Media.

Poznámka

  • Chcete-li vytvořit adresáře pro publikování a uložit obsah do fyzických adresářů počítače, je nutné zajistit, aby uživatelský účet, pomocí kterého se přihlašujete ke správě součástí Windows Media Server Components, umožňoval zápis do fyzických adresářů, které slouží jako adresáře pro publikování. Pokud chcete vysílat obsah ASF, je nutné pro účet využívaný službou Windows Media Services (ve výchozím nastavení jde o účet NetShowServices) zajistit práva pro čtení těchto adresářů. Účet, který bude využíván součástmi Windows Media Server Components, lze vybrat při instalaci součástí Windows Media Server Components. Chcete-li upravit přístupová oprávnění účtu, který je využíván službou Windows Media Services, je nutné mít oprávnění správce. Další informace naleznete v tématu Správa součástí Windows Media Server Components.


Přehled nástrojů pro správu vysílání Unicast

Správce Windows Media obsahuje pro správu vysílání Unicast následující stránky:

  • Adresáře pro publikování vysílání Unicast. pomocí stránky Adresáře pro publikování vysílání Unicast lze vytvořit, upravit nebo odebrat adresáře pro publikování kontinuálního vysílání Unicast nebo vysílání Unicast na požádání. Při vytváření adresářů pro publikování vysílání Unicast je možné určit maximální počet současně připojených klientů a omezení maximální šířky pásma (celkové maximální šířky pásma všech datových proudů doručovaných z daného adresáře pro publikování vysílání Unicast).
  • Vlastnosti serveru. Karty na stránce vlastností serveru umožňují provést následující činnosti:
    • Na kartě Obecné lze omezit počet klientů připojených k serveru, celkovou šířku pásma serveru a maximální šířku pásma spotřebovanou datovým proudem.
    • Na kartě Zabezpečení adresáře pro publikování lze nastavit ověřování přehrávačů pomocí předem nastaveného nebo vlastního způsobu ověřování.
    • Chcete-li distribuovat obsah na jiný server Windows Media s využitím zabezpečení, je nutné pro ověření proxy serveru zadat na serveru vysílání Unicast potřebné informace. Tyto informace je možné zadat na kartě Ověřování distribuce.
    • Na kartě Protokol adresáře pro publikování lze povolit protokolování služby Windows Media Unicast Service, určit interval pro vytvoření nového souboru s protokolem a určit umístění souboru s protokolem.
    • Na kartě Vysílání a distribuce HTTP lze nakonfigurovat službu Windows Media Unicast Service tak, aby využívala vysílání pomocí protokolu HTTP, který umožňuje přijímat datový proud pomocí programu Windows Media Player přes bezpečnostní bránu firewall.
  • Události adresářů pro publikování. Pomocí stránky Události adresářů pro publikování je možné zajistit sledování služby Windows Media Unicast Service pro události klienta, serveru, správce a výstražné události.
  • Klienti adresářů pro publikování. Na stránce Klienti adresářů pro publikování je možné zobrazit připojení klientů k serveru v reálném čase a odhlásit klienty.


Použití adresářů pro publikování vysílání Unicast

Správné vytvoření a správa adresářů pro publikování je základem úspěšného šíření vysílání Unicast, kterým může být uložený soubor ASF z adresáře pro publikování vysílání Unicast na požádání nebo datový proud s živým vysíláním z adresáře pro publikování kontinuálního vysílání Unicast. Tato část obsahuje odkazy na témata nápovědy v tomto dokumentu týkající se adresářů pro publikování.

  • Běžné postupy
  • Adresáře pro publikování vysílání Unicast
  • Použití adresářů pro publikování vysílání Unicast na požádání
  • Použití adresářů pro publikování kontinuálního vysílání Unicast
  • Vytvoření adresářů pro publikování vysílání Unicast pomocí Správce Windows Media
  • Oznámení vysílání Unicast pomocí souboru ASX
  • Úpravy vlastností adresáře pro publikování vysílání Unicast
  • Distribuce datových proudů ASF ze serveru Windows Media
  • Konfigurace serveru pro vysílání Unicast
  • Správa klientů adresáře pro publikování vysílání Unicast
  • Poradce při potížích s vysíláním Unicast

Poznámka

  • Služba Windows Media Services je navržena jako otevřená, rozšiřitelná platforma, pomocí které lze vytvářet vlastní aplikace a uživatelská rozhraní, stejně jako integrovat technologii Windows Media do jiných softwarových produktů. Sada Windows Media Technologies Software Development Kit (SDK) popisuje velké množství funkcí, které platforma služby Windows Media Services vývojářům nabízí. Sadu Windows Media Technologies SDK je možné stáhnout ze stránky Windows Media Technologies na serveru WWW společnosti Microsoft.


Adresáře pro publikování vysílání Unicast

Služba Windows Media Services umožňuje pomocí adresářů pro publikování publikovat (zpřístupnit) soubory a datové proudy ASF ze serveru Windows Media programům Windows Media Player. Existují dva typy adresářů pro publikování: adresáře pro publikování na požádání a adresáře určené pro kontinuální vysílání.

Adresáře pro publikování vysílání Unicast na požádání

Adresáře pro publikování vysílání Unicast na požádání představují ukazatele na odpovídající adresáře na serveru Windows Media. Soubory ASF jsou v adresáři a podadresářích adresáře k dispozici pro publikování. Součásti Windows Media Server Components jsou po instalaci připraveny k vysílání obsahu datového proudu na požádání. Další konfigurace není nutná. Chcete-li přehrát ukázku vysílání na požádání, postupujte podle kroků v tématu Konfigurace a přístup k souborům ASF na požádání.

Pokud chcete přehrát vlastní obsah vysílání Unicast na požádání, zkopírujte příslušný soubor ASF do kořenového adresáře pro publikování, který lze určit při instalaci součástí Windows Media Server Components. Pokud potřebujete zjistit cestu ke kořenovému adresáři pro publikování, klepněte v rámci s nabídkou Správce Windows Media na položku Adresáře pro publikování vysílání Unicast. V seznamu Adresáře pro publikování vysílání Unicast na požádání vyhledejte alias <Domovský> adresář pro publikování vysílání Unicast a přidejte požadovaný soubor ASF do kořenového adresáře pro publikování, který je uveden ve sloupci Cesta.

Adresáře pro publikování kontinuálního vysílání Unicast

Datové proudy s živým vysíláním vytvořené pomocí programu Windows Media Encoder, vzdálené stanice Windows Media a vzdáleného adresáře pro publikování vysílání Unicast lze publikovat pomocí adresáře pro publikování kontinuálního vysílání Unicast. Přístup k adresáři pro publikování kontinuálního vysílání Unicast a tedy k datovému proudu s živým vysíláním je umožněn pomocí programu Windows Media Player. Během instalace nelze součásti Windows Media Server Components nakonfigurovat na vysílání datových proudů s živým vysíláním. Chcete-li nakonfigurovat vysílání datových proudů s živým vysíláním, je nutné vytvořit adresář pro publikování kontinuálního vysílání Unicast. Jestliže chcete rychle vytvořit adresář pro publikování kontinuálního vysílání Unicast, postupujte podle kroků v tématu Konfigurace a přístup k datovým proudům (živého) kontinuálního vysílání Unicast.

Adresář pro publikování kontinuálního vysílání Unicast je definován aliasem a cestou. V adresáři pro publikování kontinuálního vysílání Unicast lze pomocí vlastností omezit počet klientů, kterým bude umožněno připojení k adresáři pro publikování, maximální šířku pásma tohoto adresáře a velikost publikovaného datového proudu.


Použití adresářů pro publikování vysílání Unicast na požádání

Služba Windows Media Services používá, podobně jako jiné služby Internetu (například HTTP a FTP), pro vysílání souboru ASF ve formě datového proudu virtuální adresář označovaný jako adresář pro publikování vysílání Unicast na požádání.

Služby Internetu mají domovský adresář, který představuje kořenový adresář dané služby. Při instalaci serveru Windows Media je vytvořen domovský adresář označovaný jako Kořenový adresář pro publikování, což je kořenový adresář služby Windows Media Unicast Service. Výchozí kořenový adresář pro publikování je adresář Systémová_jednotka\ASFRoot.

Výchozí kořenový adresář pro publikování slouží pouze jako adresář pro publikování vysílání Unicast na požádání. U kořenového adresáře není možné nastavit alias. Jako název kořenového adresáře pro publikování, který lze zadat jako cestu v programu Microsoft Windows Media Player, slouží název počítače se serverem. Chcete-li například v programu Windows Media Player otevřít vysílání datového proudu představované souborem zanzibar.asf z kořenového adresáře pro publikování (kde fyzická cesta k adresáři je Systémová_jednotka\ASFRoot) serveru s názvem Mapy, zadejte v tomto programu následující cestu:

mms://Mapy/zanzibar.asf

Pokud chcete uživatelům ulehčit uspořádání obsahu ASF, je možné vysílat soubory ASF z podadresářů kořenového adresáře pro publikování. V tomto případě byl vybrán skutečný kořenový adresář pro publikování, ale soubor předpověď.asf bude publikován z podadresáře Počasí:

mms://Mapy/Pocasi/predpoved.asf

Chcete-li lépe uspořádat obsah, je také možné vytvořit nové adresáře pro publikování vysílání Unicast na požádání. Jestliže chcete vytvořit další adresáře pro publikování vysílání Unicast na požádání, můžete zadat alias a určit cestu k novému adresáři pro publikování vysílání Unicast pomocí stránky Adresáře pro publikování vysílání Unicast. Soubory ASF je možné umístit do adresáře, který se nachází na kterékoli místní jednotce, do jiného počítače pomocí namapování jednotky na tento adresář, nebo do umístění na jiném serveru pomocí sdílení adresáře na tomto serveru. Potom je možné pro daný obsah vytvořit adresář pro publikování vysílání Unicast na požádání.

Poznámka

  • Na serveru Windows Media lze vytvořit pouze jeden kořenový adresář pro publikování. Adresáře pro publikování vysílání Unicast na požádání umožňují, stejně jako virtuální adresáře serveru HTTP, zabezpečit uložené soubory ASF omezením přístupu k adresářům, ve kterých je daný obsah uložen. Další informace o zabezpečení obsahu ASF pomocí adresářů pro publikování vysílání Unicast naleznete v tématu Nastavení zabezpečení adresáře pro publikování vysílání Unicast.


Použití adresářů pro publikování kontinuálního vysílání Unicast

Adresáře pro publikování kontinuálního vysílání Unicast slouží k uspořádání datových proudů ASF s živým vysíláním. Při použití adresářů pro publikování kontinuálního vysílání Unicast vytváříte ukazatele na datové proudy s živým vysíláním z programu Windows Media Encoder, vzdálené stanice Windows Media nebo vzdálené adresáře pro publikování vysílání Unicast. Následující tabulka obsahuje příklady jednotlivých typů. Server Windows Media je označen jako server Mapy.

Typ zdroje | Alias | Cesta | Příkaz pro spuštění datového proudu ASF
Program Windows Media Encoder | Hokej | msbd://kodér:7007 | mms://Mapy/Hokej
Vzdálená stanice | Tenis | msbd://vzdálený_server/stanice1 | mms://Mapy/Tenis
Vzdálený adresář pro publikování vysílání Unicast na požádání | Střelba | mms://vzdálený_server/alias1 | mms://Mapy/Strelba/soubor.asf
Vzdálený adresář pro publikování kontinuálního vysílání Unicast | Bruslení | mms://vzdálený_server/alias2 | mms://Mapy/Brusleni

Adresáře pro publikování kontinuálního vysílání Unicast vytváří, stejně jako adresáře pro publikování vysílání Unicast na požádání, pouze jeden datový proud ze serveru ke klientovi. Typy datových proudů adresáře pro publikování kontinuálního vysílání Unicast:

  • Datový proud z programu Windows Media Encoder. Vytvořte alias a cestu k programu Windows Media Encoder pomocí následující syntaxe: protokol://název_počítače_kodéru(:číslo_portu).

    Použijte protokol MSBD a jako název kodéru použijte název počítače, ve kterém je spuštěn program Windows Media Encoder. Pokud jste změnili výchozí číslo portu (7007) používané programem Windows Media Encoder, je nutné zadat také číslo portu. Chcete-li například zadat cestu k počítači s názvem Zanzibar a použít port 1480, zadejte cestu tímto způsobem: msbd://Zanzibar:1480.

  • Datový proud ze vzdálené stanice Windows Media. Vytvořte alias a cestu ke stanici pomocí následující syntaxe: protokol://název_počítače/název_stanice.

    Použijte protokol MSBD, jako název počítače použijte název počítače, ve kterém jsou spuštěny součásti Windows Media Server Components, a jako název stanice použijte název stanice Windows Media. Chcete-li například zadat cestu k počítači s názvem Server_Stanice, který vysílá stanici nazvanou Stanice1, zadejte cestu tímto způsobem: msbd://server_stanice/stanice1.

    Pokud nelze klientům datový proud doručit pomocí vysílání Multicast, použije server Windows Media pro připojení datového proudu k vysílání Unicast adresáře pro publikování vysílání Unicast, které odkazují na danou stanici. Další informace naleznete v tématu Vytváření přecházení pro vysílání Unicast pro stanici vysílání Multicast.

  • Vzdálený adresář pro publikování vysílání Unicast na požádání. Vytvořte alias a cestu k adresáři pro publikování vysílání Unicast na požádání pomocí následující syntaxe: protokol://název_serveru/alias_adresáře_pro_publikování.

    Použijte protokol MMS. Jako název serveru použijte název serveru Windows Media, který vysílá obsah adresáře pro publikování vysílání Unicast na požádání, a potom zadejte alias tohoto adresáře pro publikování. Chcete-li například zadat cestu k počítači s názvem Server_Unicast, který obsahuje adresář pro publikování vysílání Unicast na požádání s názvem psi, zadejte cestu tímto způsobem: mms://server_unicast/psi. Pokud chcete vytvořit odkaz na soubor ASF umístěný ve vzdáleném adresáři pro publikování na požádání, je nutné zadat název souboru ASF do adresy URL adresáře pro publikování kontinuálního vysílání. Alias adresáře pro publikování vysílání Unicast na požádání odkazuje pouze na adresář, nikoli na datový proud ASF. Na serveru s názvem server1 například vytvoříte adresář pro publikování kontinuálního vysílání s názvem psovité_šelmy. Jestliže chcete pro přehrávání souboru ASF psi.asf, který je uložen ve vzdáleném adresáři pro publikování na požádání s názvem šelmy, použít adresář pro publikování kontinuálního vysílání s názvem psovité_šelmy, je třeba zadat adresu URL následujícím způsobem: mms://server1/psovite_selmy/psi.asf.

  • Vzdálený adresář pro publikování kontinuálního vysílání Unicast. Vytvořte alias a cestu k adresáři pro publikování kontinuálního vysílání Unicast pomocí následující syntaxe: protokol://název_serveru/alias_adresáře_pro_publikování.

    Použijte protokol MMS. Jako název serveru použijte název serveru Windows Media, který vysílá obsah adresáře pro publikování vysílání Unicast na požádání, a pak zadejte alias adresáře pro publikování kontinuálního vysílání Unicast. Chcete-li například zadat cestu k počítači s názvem Server_Unicast, který obsahuje adresář pro publikování kontinuálního vysílání Unicast s názvem kočky, zadejte cestu tímto způsobem: mms://server_unicast/kocky.


Vytvoření adresářů pro publikování vysílání Unicast pomocí Správce Windows Media

Stránka Adresáře pro publikování vysílání Unicast Správce Windows Media je rozdělena na část Adresáře pro publikování vysílání Unicast na požádání a na část Adresáře pro publikování vysílání Unicast. V každé z těchto částí lze vytvořit požadovaný adresář pro publikování pomocí Průvodce rychlým nastavením. Průvodce rychlým nastavením také umožňuje automaticky vytvořit oznámení (soubor ASX), které nasměruje program Microsoft Windows Media Player přímo k souboru ASF vysílanému na požádání, který chcete publikovat, nebo k adresáři pro publikování kontinuálního vysílání Unicast, ze kterého je vysílán obsah s živým vysíláním. Oznámení je potom možné uložit do vybraného adresáře. Při vytváření oznámení pomocí průvodce lze také vybrat další možnosti (například vytvoření souboru HTML, který bude obsahovat hypertextový odkaz HREF na dané oznámení).

Chcete-li vytvořit adresáře pro publikování vysílání Unicast pomocí Průvodce rychlým nastavením, naleznete potřebný postup v následujících tématech:

  • Vytvoření adresáře pro publikování vysílání Unicast na požádání pomocí Rychlého nastavení
  • Vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí Rychlého nastavení

Chcete-li vytvořit adresáře pro publikování a uložit obsah do fyzických adresářů počítače, je nutné zajistit, aby uživatelský účet, pomocí kterého se přihlašujete ke správě součástí Windows Media Server Components, umožňoval zápis do fyzických adresářů, které slouží jako adresáře pro publikování. Pokud chcete vysílat obsah ASF, je nutné pro účet využívaný službami Windows Media Component Services (ve výchozím nastavení jde o účet NetShowServices) zajistit práva pro čtení těchto adresářů. Účet, který bude využíván službami Windows Media Component Services, lze vybrat během instalace součástí Windows Media Server Components. Chcete-li upravit přístupová oprávnění účtu, který je využíván službami Windows Media Component Services, je nutné mít oprávnění správce. Další informace naleznete v tématu Správa součástí Windows Media Server Components.

Jestliže víte, jakým způsobem lze adresáře pro publikování vysílání Unicast vytvořit a nechcete při zadávání zobrazovat vysvětlující informace, zrušte před zahájením vytváření zaškrtnutí políčka Vytvořit nový adresář pro publikování vysílání pomocí průvodce nebo Vytvořit nový adresář pro publikování na požádání pomocí průvodce, podle typu adresáře pro publikování vysílání Unicast, který chcete vytvořit. Chcete-li vytvořit adresář pro publikování bez použití Průvodce rychlým nastavením a chcete vytvořit pro daný obsah oznámení, naleznete další informace v tématu Publikování datového proudu vysílání Unicast. Vytváříte-li adresář pro publikování bez použití Průvodce rychlým nastavením, je nutné mít na paměti také podmínky popsané v následujících upřesňujících tématech.


Vytvoření nových adresářů pro publikování vysílání Unicast (upřesňující témata)

Pokud vytváříte nový adresář pro publikování vysílání Unicast, je nutné, aby byl alias zvolený pro adresáře pro publikování kontinuálního vysílání Unicast a adresáře pro publikování vysílání Unicast na požádání jedinečný. Jestliže vytvoříte adresář pro publikování kontinuálního vysílání Unicast nazvaný Praha a tento název bude shodný s již existujícím adresářem pro publikování vysílání Unicast na požádání, zobrazí Správce Windows Media dotaz, zda chcete nahradit existující adresář pro publikování vysílání Unicast na požádání novým adresářem pro publikování kontinuálního vysílání Unicast.

Vytvoříte-li adresář pro publikování bez použití Průvodce rychlým nastavením, bude ve Správci Windows Media možné nastavit pro tento adresář omezení maximálního počtu klientů a maximální šířky pásma. Tyto možnosti nastavení se liší od možností nastavení pro celý systém, které lze nastavit na kartě Obecné na stránce Konfigurace serveru - vlastnosti serveru. Další informace naleznete v tématu Řízení připojení klientů a využití šířky pásma.


Vytvoření adresáře pro publikování vysílání Unicast na požádání (upřesňující témata)

Na serveru lze vytvořit pouze jeden kořenový adresář pro publikování vysílání Unicast na požádání. Chcete-li změnit výchozí kořenový adresář pro publikování vysílání Unicast na požádání (Systémová_jednotka\ASFRoot), zadejte cestu k novému kořenovému adresáři pro publikování do pole Cesta adresáře, klepněte na přepínač Domovský a potom na tlačítko OK. Alias Domovský adresář se zobrazí v seznamu Adresáře pro publikování vysílání Unicast na požádání spolu s cestou k novému adresáři pro publikování vysílání Unicast na požádání.

Ujistěte se, zda adresář zadaný jako adresář pro publikování vysílání Unicast na požádání na spravovaném serveru existuje. Správce Windows Media neověřuje existenci adresáře, který je zadán jako nový adresář pro publikování vysílání Unicast na požádání.


Vytvoření adresáře pro publikování kontinuálního vysílání Unicast (upřesňující témata)

Adresáře pro publikování kontinuálního vysílání Unicast lze vytvořit pomocí stránky Adresáře pro publikování vysílání Unicast nebo stránky Stanice vysílání Multicast. Chcete-li vytvořit adresář pro publikování datového proudu s živým vysíláním, použijte stránku Adresáře pro publikování vysílání Unicast.

Jestliže chcete vytvořit adresář pro publikování kontinuálního vysílání, vytvořte alias pro cestu k datovému proudu s živým vysíláním, například cestu k programu Windows Media Encoder (příklad: msbd://kodér:port), stanici (například mms://název_stanice) nebo jinému adresáři pro publikování kontinuálního vysílání Unicast (například mms://server/alias_adresáře_pro_publikování). Jakmile jsou adresáře pro publikování kontinuálního vysílání Unicast vytvořeny, lze uživatelům zpřístupnit datové proudy s živým vysíláním pomocí programu Microsoft Windows Media Player, který připojení k adresářům pro publikování zprostředkuje. Vytvořili jste například adresář pro publikování kontinuálního vysílání Unicast s aliasem Lobby. Chcete-li získat přístup k obsahu adresáře pro publikování kontinuálního vysílání Unicast, zadejte v programu Windows Media Player adresu mms://server/Lobby. Další informace naleznete v tématu Vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí Rychlého nastavení.

Použijete-li Průvodce rychlým nastavením stanic a vyberete při vytváření stanice možnost vysílání Multicast i distribuce, bude pomocí průvodce adresář pro publikování kontinuálního vysílání Unicast vytvořen automaticky. Další informace o vytvoření adresáře pro publikování kontinuálního vysílání Unicast pomocí Průvodce rychlým nastavením stanic naleznete v tématu Postup při vytvoření stanice vysílání Multicast pomocí Rychlého nastavení.


Oznámení vysílání Unicast pomocí souboru ASX

Zadáním cesty k uloženému souboru ASF nebo adresáři pro publikování kontinuálního vysílání Unicast do pole Otevřít v programu Microsoft Windows Media Player se lze připojit k obsahu vysílání Unicast (obsahu na požádání i obsahu kontinuálního vysílání). Mnoho uživatelů však často neví, jakým způsobem je možné získat k tomuto obsahu přístup, nebo dokonce ani neví, že obsah existuje.

Soubor ASX slouží jako odkaz na obsah ASF představovaný soubory ASF, které jsou uloženy v adresáři pro publikování vysílání Unicast nebo adresáři pro publikování kontinuálního vysílání Unicast, ze kterého je vysílán obsah s živým vysíláním. Soubory ASX poskytují programu Microsoft Windows Media Player potřebné informace, pomocí kterých se lze připojit k obsahu vysílání Unicast na serveru. Pokud stránka WWW se souborem ASF nebo datovým proudem s živým vysíláním neobsahuje vložený přehrávač, jsou pro připojení programu Windows Media Player k souboru ASF nebo datovému proudu s živým vysíláním tyto informace nezbytné.

Chcete-li uživatelům ulehčit přístup k obsahu ASF, je možné vytvořit oznámení (soubor s příponou ASX), které poskytne programu Windows Media Player potřebné informace pro připojení k serveru Windows Media a k příjmu obsahu ASF. Oznámení je možné připojit ke zprávě elektronické pošty, použít jako odkaz na stránce WWW nebo uložit jako samostatný soubor na pevném disku. Uživatelé mohou program Windows Media Player spustit poklepáním na soubor ASX nebo daný soubor ASX otevřít v programu Windows Media Player klepnutím na příkaz Otevřít. Program Windows Media Player poté extrahuje cestu k obsahu ASF a obsah přehraje.

Vytvoříte-li adresář pro publikování vysílání Unicast pomocí Průvodce rychlým nastavením, bude soubor ASX tvořící odkaz na datový proud ASF vytvořen automaticky.

Soubory oznámení mohou být také konstruovány složitěji. Můžete například vytvořit přechod na adresu URL (cestu) stejného souboru ASF pomocí různých protokolů nebo na stejný soubor ASF umístěný na různých serverech, případně v různých seznamech položek k přehrání představujícím pak cesty k více souborům ASF, které mají být přehrány v zadaném pořadí.


Publikování datového proudu vysílání Unicast

Vyberete-li způsob publikování na obrazovce Výběr způsobu publikování v Průvodci rychlým nastavením, vytvoří průvodce soubor HTM nebo zkopíruje kód HTML do schránky systému Microsoft Windows, což umožní vložit tento kód na stránku HTML. Soubor ASX, který tvoří odkaz na adresář pro publikování, bude vytvořen pomocí průvodce automaticky. Následující metody publikování poskytují syntaxi pro síť WWW, pomocí které lze vytvořit odkaz na soubor ASX.

Vytvoření souboru HTM obsahujícího značku <HREF> s odkazem na soubor ASX

Jestliže v Průvodci rychlým nastavením vyberete tuto možnost oznámení, bude Správcem Windows Media vytvořen soubor HTM obsahující syntaxi HTML, která je potřebná k vytvoření odkazu na soubor oznámení ASX pro program Microsoft Windows Media Player.

Vytvoření souboru HTM obsahujícího značky <EMBED> a <OBJECT> pro program Windows Media Player

Pokud vyberete v Průvodci rychlým nastavením tuto možnost oznámení, vytvoří Správce Windows Media soubor HTM, který propojí vložený ovládací prvek ActiveX programu Microsoft Windows Media Player se souborem oznámení ASX.

Výhodou této možnosti publikování je, že program Windows Media Player není spuštěn jako vnější aplikace. Místo toho je obsah datového proudu po načtení stránky WWW přehrán v rámci prohlížeče. Tato syntaxe je kompatibilní s většinou standardních prohlížečů.

Zkopírování syntaxe <HREF> nebo <OBJECT> a <EMBED> do schránky systému Windows

Jestliže vyberete v Průvodci rychlým nastavením jednu z možností oznámení souboru HTM zaškrtnutím políček Zkopírovat syntaxi <HREF> či Zkopírovat syntaxi <OBJECT> a <EMBED>, bude možné zkopírovat vybranou syntaxi HTML do schránky systému Windows za účelem pozdějšího otevření v textovém editoru. Pomocí textového editoru (například programu Poznámkový blok) můžete také vytvořit nové soubory.


Úpravy vlastností adresáře pro publikování vysílání Unicast

Adresáře pro publikování kontinuálního vysílání Unicast a vysílání Unicast na požádání je možné upravit změnou aliasu adresáře pro publikování vysílání Unicast, změnou cesty k adresáři pro publikování vysílání Unicast na požádání nebo změnou adresy URL ke vzdálenému adresáři pro publikování kontinuálního vysílání Unicast.

Vlastnosti kořenového adresáře pro publikování vysílání Unicast na požádání lze upravit stejně jako u ostatních adresářů pro publikování vysílání Unicast na požádání s následujícími výjimkami:

  • Alias Domovský adresář kořenového adresáře pro publikování vysílání Unicast na požádání nelze měnit.
  • Můžete vytvořit nový kořenový adresář pro publikování z jiného adresáře pro publikování vysílání Unicast na požádání, původní kořenový adresář pro publikování však bude nahrazen novým a alias adresáře pro publikování vysílání Unicast na požádání bude nahrazen aliasem Domovský adresář.
  • Kořenový adresář pro publikování vysílání Unicast na požádání nelze odebrat.

Je možné nastavit omezení počtu klientů, kterým bude umožněn přístup k adresáři pro publikování vysílání Unicast, a omezení celkové šířky pásma, kterou spotřebuje obsah vysílaný z tohoto adresáře. Další informace o nastavení těchto omezení naleznete v tématu Řízení připojení klientů a využití šířky pásma.


Distribuce datových proudů ASF ze serveru Windows Media

Služba Windows Media Services umožňuje distribuovat datový proud ASF mezi dvěma servery Windows Media. Distribuci datového proudu lze provádět ze serveru vysílání Unicast a doručit dalšímu serveru vysílání Unicast, serveru vysílání Multicast nebo libovolné kombinaci těchto serverů. Distribucí obsahu ASF pomocí služby Windows Media Unicast Service lze vyřešit následující problémy:

  • Distribuce obsahu přes bezpečnostní bránu firewall do organizace, ve které pak lze tento datový proud šířit prostřednictvím vysílání Unicast nebo Multicast.
  • Poskytnutí datového proudu velkému počtu klientů. Pomocí jednoho serveru Windows Media je datový proud rozeslán na další servery Windows Media, které umožňují zpracovat požadavky odpovídajícího množství klientů.

Distribuce obsahu ASF ze serveru Windows Media je podmíněna následujícími základními kroky:

  1. Chcete-li distribuovat soubor ASF ze serveru Windows Media, je nutné vytvořit adresář pro publikování vysílání Unicast na požádání. Pokud chcete distribuovat obsah datového proudu s živým vysíláním, který je vytvářen programem Windows Media Encoder, stanicí Windows Media nebo pomocí vzdáleného adresáře pro publikování vysílání Unicast, je nutné vytvořit adresář pro publikování kontinuálního vysílání Unicast.
  2. Na cílovém serveru Windows Media vytvořte pro příjem distribuovaného obsahu stanici, program a datový proud.


Konfigurace serveru pro vysílání Unicast

Jednotlivé karty na stránce Vlastnosti serveru ve Správci Windows Media umožňují zobrazit určité vlastnosti součástí Windows Media Server Components.

Karta Obecné umožňuje nastavit vlastnosti celého systému serveru pro maximální počet klientů, které lze připojit k serveru Windows Media, celkovou maximální šířku pásma a maximální přenosovou rychlost souborů, kterou lze ze serveru vysílat. Další informace naleznete v tématu Řízení připojení klientů a využití šířky pásma.

Karta Zabezpečení adresáře pro publikování umožňuje vybrat způsob ověřování pro součásti Windows Media Server Components a povolit kontrolu seznamu řízení přístupů (ACL). Další informace naleznete v tématu Nastavení zabezpečení adresáře pro publikování vysílání Unicast.

Karta Ověřování distribuce umožňuje zadat informace, které musí datové proudy poskytnout pro ověření proxy serveru. Další informace naleznete v tématu Vytvoření ověřování distribuce.

Karta Protokol adresáře pro publikování umožňuje protokolovat informace o činnostech vysílání Unicast provedených klienty, kteří se k danému adresáři pro publikování vysílání Unicast připojí. Interval pro vytvoření nového souboru s protokolem a umístění uložených protokolů je možné vybrat. Další informace naleznete v tématu Protokolování informací o klientech vysílání Unicast.

Karta Vysílání a distribuce HTTP umožňuje konfigurovat pro službu Windows Media Unicast Service vysílání prostřednictvím protokolu HTTP, pomocí kterého lze přijímat datový proud programem Windows Media Player přes bezpečnostní bránu firewall. Další informace naleznete v tématu Nastavení a správa vysílání datových proudů HTTP a distribuce pomocí protokolu HTTP.


Řízení připojení klientů a využití šířky pásma

Karta Obecné ve Správci Windows Media umožňuje řídit omezení maximálního počtu připojení klientů a využití šířky pásma na serveru. Nastavená omezení jsou stanovena pro celý systém a mají vliv na všechny datové proudy ASF vysílané ze serveru. Následující tabulka obsahuje popis vlastností serveru, které lze nastavit.

Vlastnost | Popis
Maximální počet klientů | Omezení počtu klientů, které lze k serveru připojit v určitém okamžiku. Minimum = 0, maximum = neomezeno.
Maximální šířka pásma | Omezení šířky pásma, kterou server vysílá (celková šířka pásma). Maximální šířka pásma se měří v kilobitech za sekundu (kb/s). Horní omezení maximální šířky pásma nesmí přesahovat 85 procent kapacity síťové karty. Minimum = 1, maximum = neomezeno.
Maximální přenosová rychlost souborů | Omezení šířky pásma, ve které je možné vysílat libovolný soubor. Maximální přenosová rychlost souborů je udávána v kilobitech za sekundu (kb/s). Minimum = 1 kb/s, maximum = neomezeno. Pokud je obsah ASF větší než hodnota zadaná v poli Maximální přenosová rychlost souborů, nebude jej server vysílat. Stejné pravidlo platí i pro datové proudy ASF s živým vysíláním.


Výpočet maximálního počtu efektivních připojení klientů

Součásti Windows Media Server Components omezí počet připojení klientů na menší z následujících hodnot:

  • Hodnota zadaná na kartě Obecné pro omezení Maximální počet klientů do pole Aktuální hodnota.

    nebo

  • Maximální možný počet efektivních připojení klientů.

Pokud například zadáte omezení Maximální počet klientů na hodnotu 500, je možné, že součásti Windows Media Server Components použijí nižší hodnotu omezení na základě hodnoty zadané v poli Maximální šířka pásma a průměru rychlosti připojení klientů k serveru Windows Media.

Chcete-li vypočítat maximální počet efektivních připojení klientů k serveru Windows Media, je nutné nejdříve určit průměrnou rychlost vysílání obsahu přijímaného klienty ze serveru. Vzhledem k tomu, že průměr se může vychylovat vlivem vysokého počtu pomalých připojení klientů a průměrného počtu rychlých připojení klientů k serveru, je obtížné tuto hodnotu přesně určit. Průměrnou rychlost přijímaného vysílání bude pravděpodobně možné pouze odhadnout. V následujícím příkladu platí pro zjednodušení předpoklad, že jsou všichni klienti připojeni rychlostí 28,8 kb/s a průměrná rychlost příjmu obsahu vysílaného ze serveru klienty je odhadnuta na 24 kb/s.

Maximální počet efektivních připojení klientů lze vypočítat vydělením hodnoty zadané na kartě Obecné v poli Maximální šířku pásma průměrnou rychlostí příjmu obsahu vysílaného ze serveru klienty.

maximální počet efektivních připojení = maximální šířka pásma / průměrná rychlost příjmu

Jestliže tedy nastavíte na kartě Obecné omezení Maximální šířka pásma například na hodnotu 5000 kb/s, maximální počet efektivních připojení bude možné určit následujícím způsobem:

maximální počet efektivních připojení = 5000 / 24 = 208

Pokud omezíte Maximální počet klientů na hodnotu 500 a hodnotu Maximální šířku pásma na 5000 kb/s, ale průměrná rychlost příjmu obsahu ASF ze serveru klienty bude 24 kb/s, omezí součásti Windows Media Server Components počet připojení klientů na 208 místo zvolené hodnoty 500. Chcete-li zvýšit počet efektivních připojení klientů, je nutné zvážit změnu vyvolanou zvýšením maximální šířky pásma na serveru Windows Media. Maximální šířka pásma nesmí přesahovat 85 procent kapacity síťové karty.


Konfigurace rychlosti připojení klientů na serveru Windows Media

Na serveru se spuštěnou službou Windows Media Services lze zpracovávat 25 požadavků na připojení klientů za sekundu. Požadavky na připojení klientů jsou zpracovány pomocí systémových prostředků (cykly procesoru a paměť) a v závislosti na konfiguraci hardwaru počítače může toto zpracování nepříznivě ovlivnit výkon serveru a kvalitu vysílaných mediálních datových proudů přijímaných ze serveru připojenými klienty.

Hodnota pro počet zpracovaných požadavků na připojení klientů za sekundu je nastavena na 25, protože počítač, který splňuje minimální požadavky na server Windows Media, umožňuje zpracovat bez vlivu na kvalitu datových proudů doručovaných připojeným klientům 25 požadavků na připojení za sekundu. Používáte-li počítač s více procesory a velkým množstvím paměti, je možné, že bude počítač schopen zpracovat větší počet připojení za sekundu. Rozhodnete-li se však zvýšit tuto hodnotu, je doporučeno využití paměti a procesoru počítače důkladně vyhodnotit. Jestliže je ze serveru doručován obsah většímu počtu uživatelů, je možné, že vzhledem k omezeným prostředkům klesne počet požadavků na připojení zpracovaných serverem.

Pokud je z klienta vyslán požadavek na připojení k serveru Windows Media, bude tento požadavek zařazen do fronty připojení. Požadavky na připojení jsou po doručení na server a zařazení do fronty následně zpracovány. Pokud přesahuje rychlost požadavků vysílaných klienty, kteří se k serveru pokouší připojit, rychlost připojení klientů, pomocí které jsou požadavky na připojení zpracovávány, fronta se zaplní. Počet požadavků na připojení klientů, které lze do fronty umístit, se rovná dvacetinásobku hodnoty zpracovaných požadavků na připojení za sekundu (nebo hodnotě 500 jako výchozí). Tato hodnota je nastavena na dvacetinásobek rychlosti připojení z důvodu kompatibility s programem Windows Media Player, který před pokusem o připojení pomocí adresy URL přepojení při selhání (failover) vyčká 20 sekund. Všechny požadavky ve frontě budou během této doby zpracovány.

Server zachovává počet klientů zařazených ve frontě. Pokud je vyčerpán maximální povolený počet požadavků, které lze do fronty zařadit, bude na serveru zastaven příjem požadavků na připojení. Všem dalším klientům, kteří se pokusí připojit, nebude server k dispozici a zobrazí se odpovídající zpráva. Uživatel, který vytvořil požadavek na připojení, není nucen čekat na výsledek ve frontě, informace o neúspěšném připojení se zobrazí ihned. Jestliže tato situace nastane, je vytvořena položka protokolu Windows Media obsahující kód chyby 503. Bude také vytvořena položka protokolu událostí systému Windows 2000 Server a následující zpráva:

Služba Windows Media Services dosáhla hodnoty maximálního počtu
čekajících připojení <X>. Tato položka je však vytvořena pouze
pokud server zastavil zpracování požadavků a nebyla-li vytvořena
položka protokolu během předchozí minuty.
Vyhledejte v dokumentaci informace o nastavení této hodnoty tak,
aby lépe odpovídala podmínkám sítě a serveru.

Hodnota <X> je proměnná a zobrazený počet je zadaná hodnota nebo výchozí hodnota 500. Server bude potom kontrolovat každé 2,5 sekundy, zda je fronta stále plná. Jakmile jsou některé požadavky klientů zpracovány, začne server opět přijímat další požadavky na připojení.


Stanovení nejvhodnějšího nastavení rychlosti připojení klientů

Jestliže se položky protokolu popsané v tématu Konfigurace rychlosti připojení klientů na serveru Windows Media v protokolech serveru nezobrazují, není nutné nastavení rychlosti připojení klientů upravovat. Pokud však vzniknou s připojeními klientů potíže, je možné rychlost upravit zadáním vlastní hodnoty MaxConnectionsPerSecond v systémovém registru.

Nastavená hodnota závisí na použitém hardwaru a počtu připojených klientů. V různých systémech je třeba použít různé rychlosti. Chcete-li zjistit nejvhodnější hodnotu, zvyšujte a snižujte postupně hodnotu připojení, dokud nedojde k vyvážení mezi počtem úspěšných připojení a výkonem serveru.

Poznámka

  • Je nutné pochopit, že neexistuje hodnota pro rychlost připojení klientů, která by byla vhodná pro všechny servery, a to ani v případě stejných prostředků. Vliv, který má rychlost připojení klientů na kvalitu datového proudu přijímaného již připojenými klienty závisí na prostředcích, které jsou v době zpracování požadavků k dispozici. Server s více procesory a velkým množstvím paměti umožňuje podporu více klientů. Jestliže však využití systémových prostředků dosahuje vysokého procenta, může zvýšení rychlosti připojení snížit kvalitu datového proudu přijímaného připojenými klienty. Koncový server s menším zatížením by měl být schopen, vzhledem k menšímu zatížení serveru, zpracovat 50 připojení za sekundu. Stanovujete-li hodnotu pro rychlost připojení, je nutné zvážit využití prostředků v době zpracování požadavků. Počet požadavků klientů, které je možné na serveru zpracovat bez vlivu na kvalitu datového proudu, se mění v závislosti na počtu klientů, kteří z tohoto serveru právě přijímají obsah.


Nastavení a správa vysílání datových proudů HTTP a distribuce pomocí protokolu HTTP

Součásti Windows Media Server Components umožňují vysílat datové proudy ASF pomocí vysílání Unicast prostřednictvím protokolu HTTP. Největší výhodou vysílání datových proudů HTTP na serveru Windows Media je možnost příjmu datových proudů klienty umístěnými v síti za bezpečnostní bránou firewall. Vysílání datových proudů HTTP není ve výchozím nastavení povoleno.

Pokud je na serveru nainstalována služba IIS verze 3.0 nebo nižší, nelze ze součástí Windows Media Server Components odesílat obsah datového proudu ASF pomocí protokolu HTTP. Služba IIS je totiž na všech dostupných adresách IP vázána na port 80. Služba IIS verze 4.0 a vyšší však umožňuje určit adresu IP, kterou lze pro odesílání datového proudu HTTP při navázání služby IIS na port 80 použít. Tímto způsobem lze zajistit, aby byla pro službu Windows Media Unicast Service a službu Windows Media Station Service k odesílání obsahu datového proudu pomocí protokolu HTTP využita jiná adresa IP, která je k dispozici. Další informace o použití služby Windows Media Services se službou IIS na stejném počítači pro vysílání obsahu datových proudů ASF pomocí protokolu HTTP prostřednictvím portu 80 naleznete v tématu Použití součástí Windows Media Server Components a služby IIS na stejném serveru.

Vysílání datového proudu HTTP lze nakonfigurovat na jiný port, což umožní spustit součásti Windows Media Server Components a další službu HTTP (například službu IIS) ve stejném počítači. Tato konfigurace je obvykle vyhrazena komunikacím mezi servery, kdy je datový proud vysílání Unicast z jednoho serveru Windows Media šířen přes bezpečnostní bránu firewall na další server Windows Media, odkud je dále vysílán jednomu nebo více klientům. Tímto způsobem je port 80 vyhrazen pro přímé připojení serveru ke klientovi. Další informace o konfiguraci vysílání datového proudu HTTP pro použití jiného portu naleznete v tématu Použití vysílání datového proudu HTTP.


Správa klientů adresáře pro publikování vysílání Unicast

Připojení klientů k adresáři pro publikování vysílání Unicast lze v součástech Windows Media Server Components sledovat v reálném čase pomocí stránky Klienti adresářů pro publikování ve Správci Windows Media. Připojení klientů je možné na této stránce také ukončit. Chcete-li zobrazit připojení vysílání Unicast mezi serverem a klienty, postupujte podle následujících pokynů:

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Klienti adresářů pro publikování.

    Zobrazí se stránka Klienti adresáře pro publikování.

  2. Zaškrtněte políčko Povolit sledování klientů.

    Všichni klienti, kteří jsou aktuálně připojeni k serveru, se po uplynutí intervalu nastaveného po zaškrtnutí políčka Automaticky obnovit každých zobrazí v seznamu Klienti adresářů pro publikování. Výchozí nastavení automatického obnovení je 30 sekund.

    Počet připojení klientů k serveru je zobrazen nad seznamem, například:

    Existuje 5 připojení.

Poznámka

  • Sledování více než sta klientů najednou může nepříznivě ovlivnit výkon serveru.

Stránka Klienti adresáře pro publikování umožňuje o připojeních klientů k serveru vysílání Unicast zobrazit následující informace.

Popisek sloupce | Popis
ID klienta | Číslo, které identifikuje připojený klientský počítač.
Adresa IP klienta | Adresa IP klientského počítače.
Port | Port využívaný klientským počítačem.
Stav | Stav vysílání Unicast vůči klientskému počítači. Pokud je pomocí vysílání Unicast vysílán datový proud, změní se stav na Vysíláno. Jestliže probíhá dokončení vysílání datového proudu, změní se stav na Otevřeno.
Název souboru | Zdroj vysílání Unicast, které je vysíláno do klientského počítače (název souboru ASF nebo alias datového proudu ASF).

Na stránce Klienti adresáře pro publikování lze seřadit seznam klientů připojených k serveru, určit interval pro aktualizaci seznamu a ukončit připojení klientů k serveru.

Seřazení seznamu klientů adresářů pro publikování

Součásti Windows Media Server Components rozpoznávají klienty podle přiřazených identifikátorů – ID klienta (číselné hodnoty ve vzestupném pořadí podle pořadí připojení klienta k serveru). Prvnímu klientovi je přiřazeno ID klienta 0, druhému ID klienta 1 atd. Ve výchozím nastavení je seznam klientů adresáře pro publikování seřazen podle sloupce ID klienta. Chcete-li seznam klientů seřadit podle údajů ve sloupcích Port, Stav nebo Název souboru, poklepejte na záhlaví požadovaného sloupce.

Aktualizace seznamu klientů adresářů pro publikování

Výchozí nastavení obnovení seznamu Klienti adresářů pro publikování je 30 sekund. Chcete-li časový interval pro obnovení seznamu upravit, zadejte novou hodnotu do pole Automaticky obnovit. Používání funkce Automaticky obnovit lze také zakázat. Chcete-li seznam klientů aktualizovat ručně, klepněte na tlačítko Obnovit.

Ukončení připojení klienta adresáře pro publikování

  • Chcete-li odhlásit klienta, který je připojen k serveru, klepněte v seznamu Klienti adresářů pro publikování na požadovaného klienta a potom klepněte na tlačítko Ukončit výběr.
  • Jestliže chcete ukončit všechna připojení klientů k serveru, klepněte na tlačítko Vybrat vše a pak na tlačítko Ukončit výběr.

Připojení k serveru bude ztraceno a v klientském počítači se zobrazí zpráva Chyba programu Windows Media Player.


Poradce při potížích s vysíláním Unicast

Následující tabulka obsahuje některé obecné problémy, které se mohou u adresářů pro publikování projevit.

Problém | Možné řešení
Po připojení k adresáři pro publikování kontinuálního vysílání Unicast nelze přijímat žádný obsah. | Na serveru hostícím adresář pro publikování zjistěte, který typ zdroje (například program Windows Media Encoder, vzdálenou stanici nebo adresář pro publikování) adresář pro publikování využívá a ověřte, zda tento zdroj pracuje správně. Ověřte, zda byla správně zadána cesta pro alias. Ověřte, zda nebylo překročeno omezení maximálního počtu klientů. Ověřte, zda zdroj obsahu s živým vysíláním nepřekročil omezení maximální šířky pásma. Ověřte, zda má daný uživatel přístupová práva k příslušnému adresáři pro publikování kontinuálního vysílání Unicast. Ověřte, zda je spuštěna služba Windows Media Unicast Service.
Po připojení k adresáři pro publikování na požádání nelze přijímat správný obsah. | Ověřte, zda je k adresáři pro publikování na požádání správně zadána cesta. Ověřte, zda soubor ASF, ke kterému se uživatel pokouší připojit, ve zdrojovém adresáři existuje.


Vysílání Multicast

Součásti Windows Media Server Components lze nakonfigurovat tak, aby vysílání datových proudů klientům probíhalo pomocí vysílání Multicast, které nevyžaduje použití velké šířky pásma sítě. Pro vysílání datových proudů vysílání Multicast klientům slouží stanice. Bez použití stanic lze datové proudy vysílat pomocí vysílání Unicast. Při tomto způsobu každý klient, který přijímá datový proud ve formátu ASF, má k serveru vytvořeno samostatné připojení.

Stanice obsahuje všechny informace potřebné k doručení obsahu datového proudu ASF v odpovídající podobě do programu Microsoft Windows Media Player nebo na jiný server Windows Media. Definování potřebných informací usnadňuje Průvodce rychlým nastavením pro stanice. Pokud znáte charakteristiky stanice, použijte k jejímu vytvoření místo Průvodce rychlým nastavením stanice stránku Stanice vysílání Multicast ve Správci Windows Media.

nastavení


Běžné postupy

V této části jsou uvedeny nejběžnější postupy pro vytváření a správu vysílání Multicast. Tyto postupy slouží k rychlému provedení úkolu. Část následující za tímto seznamem postupů obsahuje přehled informací popisujících vysílání Multicast podrobněji. Chcete-li se zobrazit podrobnější informace o vysílání Multicast, přejděte na následující část.


Postup při vytvoření stanice vysílání Multicast pomocí Rychlého nastavení

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

Zobrazí se stránka Stanice vysílání Multicast.

  2. Ověřte, zda je zaškrtnuto políčko Vytvořit novou stanici pomocí průvodce, klepněte na tlačítko Stanice a potom na příkaz Nová.

    Zobrazí se okno Průvodce rychlým nastavením - datové proudy vysílání Multicast.

  3. Na obrazovce Výběr stanice klepněte na přepínač Vytvořit novou stanici.
  4. Na obrazovce Vytvoření nové stanice zadejte název a popis stanice. Potom vyberte režim distribuce.
  5. Na obrazovce Zadání názvu datového proudu a programu zadejte příslušné názvy do polí Název programu a Název datového proudu. Můžete také aktivovat dvě možnosti programu:
    • Pokud chcete, aby program bylo možné zobrazit ihned po vytvoření stanice, zaškrtněte políčko Po ukončení průvodce spustit program.
    • Pokud chcete program po jeho spuštění opakovaně přehrávat, zaškrtněte políčko Po skončení datového proudu přehrát objekty znovu (smyčka).
  6. V Průvodci rychlým nastavením je k dispozici několik obrazovek k výběru a konfiguraci zdroje datového proudu pro stanici vysílání Multicast.
    • Na obrazovce Zadejte zdroj objektu datového proudu vyberte zdroj datového proudu.
    • Na obrazovce Zadání adresy URL zdroje objektu datového proudu zadejte adresu URL zdroje datového proudu.
    • Na obrazovce Zadání informací o formátu datového proudu zadejte cestu ke zdroji datového proudu. Tímto způsobem zajistíte přidání informací o formátu datového proudu k definici stanice.
  7. Soubor s informacemi o stanici vysílání Multicast (soubor NSC) uložte na místo přístupné programu Microsoft Windows Media Player.
    • Na obrazovce Cesta pro export souboru informací o stanici zadejte cestu k umístění souboru NSC.
    • Na obrazovce Adresa URL souboru informací o stanici zadejte adresu URL nebo cestu UNC, pomocí kterých program Windows Media Player uložený soubor NSC otevře.
  8. Na obrazovce Výběr způsobu publikování vyberte způsob publikování datového proudu. Další informace o způsobech publikování naleznete v tématu Publikování obsahu stanice.
  9. Na obrazovce Připraveno k publikování se zobrazí seznam možností, které byly vybrány. Chcete-li některou z těchto možností upravit, můžete zobrazit odpovídající informace o dané stanici pomocí tlačítka Zpět.
  10. Pokud nechcete soubor ASX odesílat uživatelům elektronickou poštou, uložte ho do přístupného adresáře. Soubory HTM vytvořené vybraným způsobem publikování uložte do adresářů, které mohou uživatelé otevřít přímo nebo prostřednictvím serveru WWW.

Poznámka

  • Na obrazovce Publikování je dokončeno lze datový proud z dané stanice vyzkoušet. Chcete-li funkci vysílání stanice vyzkoušet, klepněte na tlačítko Test souboru ASX, Test souboru HTM - <HREF> nebo Test souboru HTM - <OBJECT>. Obsah bude otevřen v programu Windows Media Player.


Postup při vytvoření stanice vysílání Multicast pomocí upřesňujícího postupu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na této stránce zrušte zaškrtnutí políčka Vytvořit novou stanici pomocí průvodce.
  3. Klepněte na tlačítko Stanice a potom na příkaz Nová.

    Zobrazí se stránka Nová stanice.

  4. Chcete-li vytvořit stanici, zadejte do textových polí informace o jejích vlastnostech.

    Další informace o vlastnostech stanice naleznete v tématu Úpravy vlastností stanice.


Povolení vysílání datového proudu HTTP pro službu Windows Media Station Service

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.
  2. Na stránce Vlastnosti serveru vyberte kartu Vysílání a distribuce HTTP.
  3. Na kartě Vysílání a distribuce HTTP klepněte na přepínač Povolit distribuci HTTP pro službu Windows Media Station Service a potom klepněte na tlačítko Použít.
  4. Změna se projeví po restartování serveru. Služba bude automaticky spuštěna a vytvoří vazbu k odpovídajícímu portu.

Poznámka

  • Pokud se v počítači se serverem nacházejí součásti Windows Media Server Components i server WWW, lze součásti Windows Media Server Components nastavit tak, aby byly na serveru WWW závislé. Toto nastavení zajistí, že server WWW a součásti Windows Media Server Components budou moci fungovat ve stejném počítači. Další informace o nastavení této závislosti naleznete v tématu Vytvoření závislosti služby Windows Media Unicast Service na serveru WWW úpravou registru.


Postup při úpravě stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V seznamu stanic poklepejte na název stanice, jejíž vlastnosti chcete upravit.

    Zobrazí se stránka Úprava stanice, která obsahuje všechny vlastnosti stanice.

  3. Proveďte požadované změny.

Poznámka

  • Zobrazí se zpráva s dotazem, zda chcete uložit změny do souboru NSC. Chcete-li tyto změny do souboru NSC uložit, je třeba tento soubor exportovat do stejného adresáře, kde se nachází i jeho starší verze.


Postup při exportování stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na stránce Stanice vysílání Multicast klepněte na název stanice, kterou chcete exportovat, potom klepněte na tlačítko Stanice a na příkaz Exportovat.
  3. V dialogovém okně Exportovat stanici vyhledejte adresář, do kterého chcete uložit soubor NSC, a klepněte na tlačítko Uložit.

Poznámka

  • Před exportováním stanice musí být všechny aktivní datové proudy této stanice zastaveny. Datový proud zastavíte zastavením jeho programu. Další informace naleznete v tématu Postup při zastavení programu.


Postup při importování stanice ze souboru NSC

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na stránce Stanice vysílání Multicast klepněte na tlačítko Stanice a potom na příkaz Importovat.
  3. Klepněte na přepínač Importovat novou stanici z existujícího souboru stanice (NSC) a potom klepněte na tlačítko Importovat.
  4. V dialogovém okně Správce Windows Media vyhledejte požadovaný soubor NSC a klepněte na tlačítko Otevřít.

Poznámka

  • Při importování stanice ze souboru NSC jsou importovány jen informace o stanici. Nejsou zahrnuty žádné informace o programech ani o datových proudech. Pokud chcete ke stanici přidružit datové proudy, vytvořte buď nové datové proudy, které mají za Cíl importovanou stanici, nebo upravte stávající datové proudy tak, aby jejich cílem byla importovaná stanice.


Postup při importování stanice z jiného serveru Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na stránce Stanice vysílání Multicast klepněte na tlačítko Stanice a potom na příkaz Importovat.
  3. Klepněte na přepínač Importovat stanici ze vzdáleného serveru Windows Media.
  4. Do pole Název vzdáleného serveru na stránce Import nové stanice ze serveru Windows Media zadejte název serveru, ze kterého chcete importovat jednu nebo více stanic a klepněte na tlačítko Připojit.

    Zobrazí se seznam stanic dostupných na příslušném serveru.

  5. Klepněte na název jedné nebo více stanic, které mají být importovány, a potom klepněte na tlačítko Kopírovat stanici.

    Stanice bude přidána do seznamu.

Poznámka

  • Při importování stanice ze vzdáleného serveru Windows Media jsou importovány jen informace o stanici. Nejsou zahrnuty žádné informace o programech ani o datových proudech. Pokud chcete ke stanici přidružit datové proudy, vytvořte buď nové datové proudy, nebo upravte stávající datové proudy tak, aby jejich cílem byla importovaná stanice.


Postup při kopírování stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V seznamu stanic na stránce Stanice vysílání Multicast klepněte na název stanice s požadovanými informacemi, potom klepněte na tlačítko Stanice a na příkaz Kopírovat.
  3. Do pole v dialogovém okně Kopírovat stanici zadejte název nové stanice.
  4. Na stránce Nová stanice zadejte do pole Port nový port. Můžete upravit také informace ve všech dalších polích.

Poznámky

  • Před kopírováním stanice musí být všechny aktivní datové proudy této stanice zastaveny. Datový proud zastavíte zastavením jeho programu. Další informace naleznete v tématu Postup při zastavení programu.
  • Jestliže bude kopírovaná stanice sloužit pouze k distribuci, nevyžaduje nová stanice žádné hodnoty adres IP a portu a bude do seznamu stanic přidána automaticky. Další informace o úpravách vlastností stanice naleznete v tématu Úpravy vlastností stanice.
  • K nové stanici nejsou přidruženy žádné informace o programu ani o datovém proudu. Další informace o rychlém přidání programu a datového proudu k nové stanici naleznete v tématu Postup při vytvoření programu a datového proudu pro stanici pomocí Rychlého nastavení.


Postup při odebrání stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na stránce Stanice vysílání Multicast klepněte v seznamu stanic na název stanice, kterou chcete odebrat.
  3. Klepněte na tlačítko Stanice a na potom na příkaz Odstranit.

Poznámka

  • Před odstraněním souboru stanice je vhodné stanici exportovat. Tento způsob totiž umožňuje v případě, že chcete znovu použít stanici, kterou jste již odebrali, tuto stanici importovat.


Postup při vytvoření programu a datového proudu pro stanici pomocí Rychlého nastavení

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Otevře se stránka Stanice vysílání Multicast.

  2. Ověřte, zda je zaškrtnuto políčko Vytvořit novou stanici pomocí průvodce, klepněte na tlačítko Stanice a potom na příkaz Nová.

    Zobrazí se okno Průvodce rychlým nastavením - datové proudy vysílání Multicast.

  3. Na obrazovce Výběr stanice klepněte na přepínač Vybrat existující stanici a v seznamu stanic klepněte na název stanice, ke které chcete přidat program a datový proud.
  4. Postupujte podle kroků 5 až 10 v tématu Postup při vytvoření stanice vysílání Multicast pomocí Rychlého nastavení.

Poznámka

  • U tohoto postupu platí předpoklad, že jste vytvořili stanici, ke které nejsou přidruženy žádné programy ani datové proudy, nebo že jste stanici importovali. Stanice si zachová své vlastnosti, například režim distribuce, adresu IP nebo hodnotu TTL (Time-To-Live).


Postup při vytvoření programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V seznamu stanic klepněte na název stanice, pro kterou chcete vytvořit program.
  3. Klepněte na tlačítko Programy a potom na příkaz Nový.

    Zobrazí se dialogové okno Program.

  4. Do pole Název zadejte název programu.
  5. (Nepovinné) Do polí Popis, Autor a Autorská práva zadejte příslušné informace o programu.
  6. Do pole Přehrát ve skupinovém rámečku Možnosti přehrávání zadejte, kolikrát má být program přehrán. Chcete-li program přehrávat opakovaně, dokud ho nezastavíte, klepněte na přepínač Přehrávat neustále.
  7. Přidejte k programu jeden nebo více datových proudů. Další informace naleznete v tématu Postup při přidání datových proudů k programu.

Poznámky

  • Před vytvořením programu je třeba vytvořit nejméně jednu stanici. Další informace naleznete v tématu Postup při vytvoření stanice vysílání Multicast pomocí Rychlého nastavení.
  • Pokud se nedaří datový proud přehrát, program se pokusí přehrát další datový proud v pořadí. Zaškrtnutím políčka Zastavit program při chybě v dialogovém okně Program zajistíte zastavení programu při výskytu takovéto chyby.


Postup při přidání datových proudů k programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. Na stránce Stanice vysílání Multicast klepněte na název programu, ke kterému chcete přidat datový proud.
  3. Klepněte na tlačítko Datové proudy a potom na příkaz Nový.
  4. V dialogovém okně Advanced Streaming Format klepněte na kartu Obecné.
    • Do pole Název zadejte název datového proudu.
    • (Nepovinné) Do pole Popis zadejte popis datového proudu.
  5. Klepněte na kartu Zdroj a cíl.
    • Do pole Adresa URL ve skupinovém rámečku Zdroj zadejte cestu ke zdroji datového proudu. Jestliže je zdrojem datového proudu program Windows Media Encoder a kodér byl nakonfigurován pro vytvoření připojení a doručení datového proudu ASF na server Windows Media, zadejte alias připojení do pole Alias.

    Další informace o určení zdroje pro datový proud naleznete v tématu Určení zdrojů pro datové proudy.

    • V rozevíracím seznamu Stanice ve skupinovém rámečku Cíl vyberte požadovanou stanici pro datový proud.
  6. (Nepovinné) Klepněte na kartu Upřesnit.

    Další informace o nastavení možností datového proudu na kartě Upřesnit naleznete v tématu Úpravy vlastností datového proudu.


Postup při úpravě vlastností datového proudu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název datového proudu, který chcete upravit.
  3. Klepněte na tlačítko Datové proudy a potom na příkaz Vlastnosti.
  4. Proveďte požadované změny.

    Další informace o úpravách informací v jednotlivých polích naleznete v tématu Úpravy vlastností datového proudu.

Poznámka

  • Pro tento postup platí předpoklad, že jsou upravovány vlastnosti datového proudu ve formátu ASF, který je přidružen k programu.


Postup při úpravě seznamu položek k přehrání

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název datového proudu, který chcete přesunout.
    • Chcete-li datový proud přesunout v seznamu výše, klepněte na tlačítko Datové proudy a na příkaz Přesunout nahoru, nebo na šipku nahoru v pravé části podokna Programy a datové proudy ASF vysílání Multicast.
    • Chcete-li datový proud přesunout v seznamu níže, klepněte na tlačítko Datové proudy a potom na příkaz Přesunout dolů, nebo na šipku dolů v pravé části podokna Programy a datové proudy ASF vysílání Multicast.
    • Pokud chcete datový proud ze seznamu odstranit, klepněte na tlačítko Datové proudy a potom na příkaz Odstranit.


Postup při vytvoření oznámení o programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, který chcete oznámit.
  3. Klepněte na tlačítko Programy a potom na příkaz Oznámit program.

    Zobrazí se dialogové okno Uložit jako.

  4. Do pole Název souboru zadejte cestu a název souboru oznámení (souboru s příponou ASX).
  5. Klepněte na tlačítko Uložit.

Poznámka

  • Soubor oznámení musí být uložen na místo přístupné danému uživateli, například do sdíleného adresáře UNC nebo do adresáře serveru WWW. Soubor ASX umožní programu Microsoft Windows Media Player přístup k datovému proudu ASF.


Postup při uložení programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, který chcete uložit.
  3. Klepněte na tlačítko Programy a potom na příkaz Archivovat program.

    Zobrazí se dialogové okno Uložit jako.

  4. Vyhledejte adresář, kam má být soubor programu uložen.
  5. Do pole Název souboru zadejte název souboru.
  6. Klepněte na tlačítko Uložit.


Postup při obnovení uloženého programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na tlačítko Programy a potom na příkaz Obnovit programy ASF.
  3. Do dialogového okna Otevřít zadejte úplnou cestu k souboru.
  4. Klepněte na tlačítko Otevřít.


Postup při úpravě vlastností programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, jehož vlastnosti chcete změnit.
  3. Klepněte na tlačítko Programy a potom na příkaz Vlastnosti.

    Zobrazí se dialogové okno Program.

  4. Proveďte požadované změny vlastností.

    Další informace o vlastnostech programů naleznete v tématu Postup při vytvoření programu.

Poznámka

  • Spuštěný program upravovat nelze. Další informace naleznete v tématu Postup při zastavení programu.


Postup při odstranění programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, který chcete odstranit.
  3. Klepněte na tlačítko Programy a potom na příkaz Odstranit.


Postup při spuštění programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, který chcete spustit.
  3. Klepněte na tlačítko Spustit program.


Postup při zastavení programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  2. V části Programy a datové proudy ASF vysílání Multicast klepněte na název programu, který chcete zastavit.
  3. Klepněte na tlačítko Zastavit program.


Postup při vytvoření programu přenosu souboru

Titulek služby Windows Media Services

Postup při vytvoření programu přenosu souborů

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Přenosy souborů vysílání Multicast.

    Zobrazí se stránka Přenosy souborů vysílání Multicast.

  2. V části Vysílání souborů Multicast klepněte na tlačítko Programy a potom na příkaz Nový.

    Zobrazí se dialogové okno Program.

  3. Do pole Název zadejte název programu.
  4. (Nepovinné) Do polí Popis, Autor a Autorská práva zadejte příslušné informace o programu.
  5. Do pole Přehrát ve skupinovém rámečku Možnosti přehrávání zadejte, kolikrát má být program přehrán. Chcete-li program přehrávat opakovaně (to znamená, že datové proudy přenosu souborů budou klientům stále k dispozici), dokud ho nezastavíte, klepněte na přepínač Přehrávat neustále.

    V seznamu souborů se zobrazí program přenosu souborů.

Poznámky

  • Přenos souborů vysílání Multicast lze uskutečnit až po přidání datového proudu přenosu souborů k programu a po spuštění tohoto programu. Program přenosu souborů může obsahovat pouze datové proudy přenosu souborů, datové proudy ve formátu ASF obsahovat nesmí. Další informace naleznete v tématu Postup při přidání datového proudu přenosu souborů k programu.
  • Jestliže se datový proud přenosu souborů nedaří přehrát, program se pokusí přehrát další datový proud přenosu souborů v pořadí. Zaškrtnutím políčka Zastavit program při chybě v dialogovém okně Program zajistíte zastavení programu při výskytu chyby.


Postup při přidání datového proudu přenosu souborů k programu

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Přenosy souborů vysílání Multicast.

    Zobrazí se stránka Přenosy souborů vysílání Multicast.

  2. V části Vysílání souborů Multicast klepněte na název programu, ke kterému chcete přidat datový proud.
  3. Klepněte na tlačítko Datové proudy a potom na příkaz Nový.
  4. Na kartě Obecné zadejte název a popis datového proudu.
    • Do pole Název zadejte název datového proudu.
    • Do pole Popis zadejte popis datového proudu.
  5. Chcete-li určit zdroj a cíl datového proudu, klepněte na kartu Zdroj a cíl.
  6. Ve skupinovém rámečku Zdroj proveďte tyto činnosti:
    • Pokud chcete přenést soubory a adresáře, klepněte na přepínač Soubor.

    Do pole Soubor zadejte cestu a název souboru a adresáře, které chcete přenést.

    Chcete-li provést přenos všech souborů v adresáři, zadejte název adresáře. Soubory jsou přeneseny na místo zadané ve skupinovém rámečku Cíl, pokud tento cíl není klientem přepsán.

    Jestliže potřebujete určit v adresáři více souborů, použijte zástupné symboly.

    Chcete-li přenést podadresáře určitého adresáře a soubory, které v nich jsou uloženy, zaškrtněte políčko Včetně podadresářů. Podadresáře jsou vytvořeny pod umístěním, které zadáte ve skupinovém rámečku Cíl. Prázdné podadresáře nejsou přeneseny.

    • Chcete-li přenést soubor pomocí odkazu na jeho adresu URL, klepněte na přepínač Adresa URL. Do pole Adresa URL zadejte adresu souboru, který má být přenesen, v síti Internet. Soubor je přenesen do mezipaměti prohlížeče v klientském počítači.
  7. Ve skupinovém rámečku Cílová adresa proveďte následující činnosti:
    • Do pole Adresa IP zadejte cílovou adresu IP.
    • Do pole Port zadejte cílový port.

    Další informace o určení adres IP a portů pro přenos souborů vysílání Multicast naleznete v tématu Konfigurace přenosu souborů vysílání Multicast.

  8. Chcete-li určit dosah vysílání, klepněte na některou z možností Hodnota TTL (Time To Live):
    • Klepnutím na přepínač Místní síť omezíte vysílání na místní síťový uzel.
    • Klepnutím na přepínač Intranet omezíte vysílání na vlastní síť.
    • Klepnutím na přepínač Internet rozšíříte dosah vysílání na síť Internet.
    • Po klepnutím na přepínač Jiná můžete zadat vlastní hodnotu. Povoleny jsou hodnoty v rozsahu od 1 do 255.

    Další informace o nastavení dosahu vysílání naleznete v tématu Nastavení dosahu vysílání Multicast.

  9. Ve skupinovém rámečku Cíl vyberte cíl přenosu souboru.
    • Klepněte na přepínač Adresář a do pole zadejte název adresáře. Do tohoto adresáře budou klientovi přeneseny zadané soubory a adresáře. K určení umístění na straně klienta lze použít proměnné prostředí. Ve výchozím nastavení jsou soubory a podadresáře přeneseny do adresáře na straně klienta určeného proměnnou prostředí temp.
    • Klepněte na přepínač Soubor a do pole zadejte název souboru, který má být přenesen. Tímto způsobem zajistíte přejmenování souboru a jeho přenos ke klientovi.
    • Klepněte na přepínač Základní adresa URL a zadejte adresu URL. Určené soubory budou přeneseny do mezipaměti aplikace Microsoft Internet Explorer na straně klienta. Zadaná adresa URL je používána jako rozlišovací údaj pro jednotlivé přenášené soubory.

    Pomocí této možnosti lze načíst do mezipaměti klienta soubory dříve, než jsou třeba. Pokud jsou například vysílány ve formě datových proudů soubory ASF, které obsahují adresy URL a grafické soubory, mohou být grafické soubory přesunuty ke klientovi dříve, než je třeba je zobrazit. Protože se již nacházejí v mezipaměti, klient je může rychle zobrazit.

  10. Chcete-li zobrazit upřesňující možnosti, klepněte na kartu Upřesnit.

    Další informace o zadávání údajů na kartě Upřesnit naleznete v tématu Použití karty Upřesnit pro přenos souborů.

Poznámka

  • Na soubory lze odkazovat pomocí cesty UNC nebo adresy URL. Pokud je použita adresa URL, jsou příslušné soubory a adresy URL přeneseny do klientského počítače. Soubory jsou uloženy do adresáře určeného datovým proudem a adresami URL do mezipaměti prohlížeče. Tento postup se nazývá plnění mezipaměti. Plnění mezipaměti je funkční jen v aplikaci Microsoft Internet Explorer verze 3.0 nebo vyšší. Nastavení zabezpečení prohlížeče klientského počítače musí umožňovat příjem přenášených souborů.


Přehled stanic, programů a datových proudů

Součásti Windows Media Server Components mohou zahájit vysílání datových proudů ASF vysílání Multicast až po zadání informací o stanicích, programech a datových proudech. Bez těchto informací může server Windows Media vysílat pouze datové proudy ASF na požádání.

Následující schéma znázorňuje, jak získává program Microsoft Windows Media Player přístup k datovému proudu ASF vysílání Multicast.

Krok | Operace
1 | Klientský počítač otevře soubor ASX ze zprávy elektronické pošty pomocí cesty UNC nebo pomocí odkazu na stránce WWW.
2 | Program Windows Media Player extrahuje adresu URL souboru NSC ze souboru ASX. Adresa URL je cesta, která je k dispozici na obrazovce Adresa URL souboru informací o stanici v Průvodci rychlým nastavení stanice, nebo vlastnost Cesta k souboru stanice na stránce Úprava stanice.
3 | Program Windows Media Player stáhne soubor NSC a vyhledá adresu IP a port pro vysílání Multicast. Program Windows Media Player sleduje data vysílaná z této adresy IP a portu. Pokud server Windows Media odešle data v určitém časovém intervalu, program Windows Media Player data zobrazí a datový proud přehraje.
4 | Pokud program Windows Media Player neobdrží data v zadaném časovém limitu, vyhledá adresu URL v souboru NSC (ve Vlastnostech stanice), připojí se k adresáři pro publikování a přijme datový proud ASF ve formě vysílání Unicast. Není-li adresa URL vysílání Unicast k dispozici, zobrazí se chybová zpráva.


Princip stanic vysílání Multicast

Stanice slouží k vysílání datového proudu ASF pomocí vysílání Multicast klientům představovaným programy Microsoft Windows Media Player. Vysílání Multicast minimalizuje použitou šířku pásma sítě. Pokud klienti pro příjem datového proudu ASF stanici nepoužívají, musí mít každý z nich vytvořeno vlastní připojení k serveru. Při tomto způsobu je šířka pásma sítě rychle vyčerpána a schopnost sítě doručit informace je omezena.

Režim distribuce je charakteristika stanice, která určuje, zda bude stanice použita k vysílání Multicast, distribuci nebo pro obě možnosti.

  • Stanice vysílání Multicast vysílají datové proudy ASF velkému počtu klientů, využívají však šířku pásma jediného datového proudu.
  • Stanice určené k distribuci vysílají datové proudy ASF dalším serverům Windows Media pomocí vysílání Unicast. Stanice, která je určena pouze k distribuci, nemá adresu IP a port. Klienti tak nemohou doručený datový proud zobrazit.
  • Stanice, u kterých je povoleno vysílání Multicast i distribuce, doručí datové proudy ve formátu ASF na další servery Windows Media pomocí vysílání Unicast. Klienti mohou obsah ASF vysílaný na této stanici pomocí vysílání Multicast také zobrazovat.

Stanice obsahuje všechny informace potřebné k doručení datového proudu ASF do programu Windows Media Player, včetně adresy IP, portu, formátů datových proudů, hodnoty TTL (Time-To-Live) atd. Tyto informace jsou uloženy v souboru NSC.

Program Windows Media Player musí mít k souboru NSC přístup, tak, aby mohl vyhledat adresu IP, která stanici slouží k vysílání obsahu ve formátu ASF. Soubor NSC je pro program Windows Media Player obvykle k dispozici ve sdíleném síťovém adresáři nebo v adresáři serveru WWW. Program Windows Media Player extrahuje adresu URL do souboru NSC při otevření oznámení, které bylo doručeno elektronickou poštou, prostřednictvím cesty UNC nebo odkazu na stránce WWW.

Přístupovým bodem pro vytváření a správu stanic je stránka Stanice vysílání Multicast ve Správci Windows Media. Tato stránka také obsahuje rozhraní pro uspořádání datových proudů do programů vysílaných z vytvořených stanic.


Principy distribučních stanic

Distribuční stanice je pomocná stanice. Tato stanice vysílá datový proud ASF ze serveru Windows Media A na stanici na serveru Windows Media B. Server Windows Media B pak může tento obsah ASF vysílat pomocí vysílání Multicast. Distribuční stanice umožňuje:

  • distribuci datového proudu mezi síťovými segmenty, které nejsou propojeny směrovači umožňujícími vysílání Multicast,
  • distribuci datového proudu přes bezpečnostní bránu firewall.

Ostatní stanice mohou získat přístup k distribuční stanici vytvořením připojení k souboru NSC distribuční stanice pomocí protokolu MSBD. Chcete-li například, aby Stanice 2 na serveru B vysílala obsah ASF pomocí vysílání Multicast z distribuční stanice, kterou je Stanice 1 na serveru A, použijte Stanici 1 jako zdroj datového proudu. To znamená, že zdroj datového proudu pro Stanici 2 je msbd://ServerA/Stanice1.

Poznámka

  • Při distribuci datových proudů mezi servery nesmí být překročen limit distribuce, představující počet připojení MSBD, které může distribuční stanice zpracovat. Ve výchozím nastavení může distribuční stanice podporovat pouze pět připojení MSBD k ostatním stanicím. Při konfiguraci stanic na vzdálených serverech Windows Media pro použití distribuovaného datového proudu ASF musí být změněn Limit distribuce distribuční stanice tak, aby zahrnul další vzdálená připojení, nebo musí být jako zdroj pro vzdálenou stanici použita více než jedna distribuční stanice. Další informace o změnách hodnoty Limit distribuce naleznete v tématu Úpravy vlastností stanice.


Odesílání datových proudů v síti neumožňující vysílání Multicast

Jestliže síť nepoužívá směrovače umožňující vysílání Multicast, lze datový proud vysílat pomocí vysílání Multicast pouze v rámci síťových segmentů, které obsahují součásti Windows Media Server Components. Klienti v jiných segmentech sítě nemohou vysílání datových proudů ASF šířených pomocí vysílání Multicast přijímat, protože vysílání nevzniká v jejich segmentu.

Klienti v celé síti však přesto mohou tento datový proud přijímat, pokud je obsah ASF šířen pomocí vysílán Multicast v místním segmentu a distribuován na servery Windows Media v dalších síťových segmentech. Stanice v místním síťovém segmentu musí v tomto případě umožňovat vysílání Multicast i distribuci.

Do dalších síťových segmentů, pro které chcete povolit vysílání Multicast, musíte nainstalovat samostatný počítač se součástmi Windows Media Server Components. Na každém serveru Windows Media vytvořte pomocí Průvodce Rychlým nastavením stanici umožňující použití vysílání Multicast, která jako zdroj datového proudu použije vzdálenou distribuční stanici. Každý z těchto serverů Windows Media pak může daný datový proud ASF šířit pomocí vysílání Multicast v rámci místního segmentu.

Poznámka

  • Formát datového proudu určený ve vzdálené distribuční stanici musí být použit také pro stanice vysílání Multicast vytvořené v jednotlivých síťových segmentech. Další informace naleznete v tématu Importování stanice.


Odesílání datových proudů přes bezpečnostní bránu firewall

Nemáte-li k dispozici server WWW a chcete vysílat obsah klientům přes bezpečnostní bránu firewall, lze povolit v součástech Windows Media Server Components vysílání datového proudu HTTP. Vysílání datového proudu HTTP obvykle využívá port 80 a je proto vhodné k vysílání datového proudu přes bezpečnostní bránu firewall, protože ve většině případů není port 80 bezpečnostní branou firewall blokován.

Součásti Windows Media Server Components obsahují dvě služby pro vysílání datových proudů - službu Windows Media Station Service a službu Windows Media Unicast Service. Součásti Windows Media Server Components mohou být nakonfigurovány pro vysílání datového proudu HTTP. Vysílání datového proudu pomocí protokolu HTTP však může v daný okamžik probíhat pouze v rámci jedné služby - služby Windows Media Station Service nebo Windows Media Unicast Service. Na port 80 totiž může být vázána jen jediná služba.

Služba IIS verze 4.0 nebo vyšší však umožňuje určit adresu IP, kterou lze pro odesílání datového proudu HTTP při navázání služby Microsoft Internet Information Services (IIS) na port 80 použít. Tímto způsobem lze zajistit, aby byla pro službu Windows Media Unicast Service a službu Windows Media Station Service k odesílání obsahu datového proudu pomocí protokolu HTTP prostřednictvím portu 80 využita jiná adresa IP, která je k dispozici. Další informace o použití služby Windows Media Services a služby IIS ve stejném počítači k vysílání obsahu ASF pomocí protokolu HTTP a portu 80 naleznete v tématu Použití součástí Windows Media Server Components a služby IIS na stejném serveru.

Vysílání datového proudu HTTP je možné nakonfigurovat na jiný port, což umožní spustit součásti Windows Media Server Components a další službu HTTP (například službu IIS - Internet Information Services) ve stejném počítači. Jediným nedostatkem je, že většina bezpečnostních bran firewall ve výchozím nastavení umožňuje průchod vysílání datového proudu HTTP jen prostřednictvím portu 80. Proto je tato funkce obecně rezervována pro distribuci mezi servery, kdy je port 80 rezervován pro přímé propojení mezi serverem a klientem. Další informace o konfiguraci vysílání datového proudu HTTP pro použití jiného portu naleznete v tématu Použití vysílání datového proudu HTTP.


Vytváření stanic vysílání Multicast pomocí Správce Windows Media

Stanici pro vysílání Multicast, distribuční stanici nebo stanici pro vysílání Multicast i distribuci lze vytvořit pomocí Průvodce rychlým nastavením - datové proudy vysílání Multicast na stránce Stanice vysílání Multicast ve Správci Windows Media, nebo pomocí upřesňujícího postupu. Pokud k vytvoření jedné z těchto stanic použijete průvodce, budou k definici stanice na obrazovce Zadání informací o formátu datového proudu přidány informace o formátu datových proudů.

Jestliže použijete k vytvoření stanice upřesňující postup, je možné stanici vytvořit bez přidání informací o formátu datových proudů k definici stanice. Server Windows Media program této stanice přesto přehraje. Vytvoříte-li distribuční stanici, mohou datový proud pro distribuci přijímat ostatní stanice, protože při distribuci datového proudu nejsou informace o formátu datového proudu vyžadovány. Pokud však vytvoříte stanici určenou pro vysílání Multicast, klienti vysílání Multicast se ke stanici nemohou připojit, protože chybí informace o formátu datového proudu.

Klientům vysílání Multicast je umožněno zobrazit datový proud vysílání Multicast dané stanice, pokud k definici stanice vysílání Multicast přidáte informace o formátu datového proudu pro všechny datové proudy příslušného programu. Jestliže v definici programu stanice vysílání Multicast neuvedete informace o formátu datového proudu pro všechny datové proudy programu, server Windows Media nedoručí datové proudy, pro které nebyly tyto informace uvedeny, do seznamu položek k přehrání, a ohlásí chybu. Na stránce Stanice vysílání Multicast se v části zobrazující stav datových proudů zobrazí u těchto datových proudů zpráva „Stanice nepodporuje tento formát datového proudu“.

Jestliže vytvoříte stanici umožňující vysílání Multicast i distribuci a neuvedete v definici stanice informace o formátu datového proudu pro všechny datové proudy programu, klienti vysílání Multicast i distribuční stanice budou přijímat jen ty datové proudy ze seznamu, jejichž informace o formátu jsou v definici stanice uvedeny. Zbývající datové proudy se jim přijmout nepodaří.

Další informace naleznete v tématu Přidání informací o formátu datového proudu.

nastavení


Výběr zdrojů datového proudu pro stanice

Při vytváření stanice je nutné pro vysílaný obsah zadat adresu URL zdroje a informace o formátu datového proudu. Tento obsah může mít podobu souboru ASF, souboru MP3, datového proudu z programu Windows Media Encoder, vzdálené stanice nebo vzdáleného adresáře pro publikování kontinuálního vysílání. Adresu URL zdroje je třeba zadat na stránce Zadání adresy URL zdroje objektu datového proudu v Průvodci rychlým nastavením - datové proudy vysílání Multicast. Informace o formátu datového proudu je třeba zadat na obrazovce Zadání informací o formátu datového proudu v průvodci.


Zadání adresy URL zdroje objektu datového proudu

Požadovaný formát adresy URL pro soubor ASF nebo MP3 v kořenovém adresáři pro publikování na serveru Windows Media vysílání Unicast je <protokol>://<server_vysílání_Unicast>/<název_souboru>. Požadovaný formát adresy URL pro soubory ASF nebo MP3 uložené v jiných adresářích pro publikování je <protokol>://<server_vysílání Unicast>/<alias_adresáře_pro_publikování>/název_souboru>. Je používán protokol MMS nebo HTTP (pokud byl server vysílání Unicast nakonfigurován pro vysílání pomocí protokolu HTTP).

Požadovaný formát adresy URL k instalaci programu Windows Media Encoder je <protokol>://<název_kodéru>[:port]. Je používán protokol MSBD nebo HTTP (pokud byl kodér nakonfigurován pro vysílání pomocí protokolu HTTP). Jestliže kodér nepoužívá výchozí port (7007), je třeba zadat také správný port.

Požadovaný formát adresy URL vzdálené stanice je <protokol>://<název_serveru>/<název_stanice>. Je používán protokol MSBD.

Požadovaný formát adresy URL adresáře pro publikování kontinuálního vysílání je <protokol>://<název_serveru>/<alias_adresáře_pro_publikování>. Je používán protokol MMS nebo HTTP (pokud byl server vysílání Unicast nakonfigurován pro vysílání pomocí protokolu HTTP).


Přidání informací o formátu datového proudu

V programu Microsoft Windows Media Player jsou formáty datového proudu používány k dekódování datového proudu ASF vysílání Multicast. Formáty datového proudu jsou uloženy v souboru NSC dané stanice a mohou být staženy do programu Windows Media Player. Formát datového proudu zahrnuje informace o datovém proudu, médiu, které datový proud obsahuje, a použitém kodeku. Formát datového proudu je vyžadován pro každý typ datového proudu, který je stanicí vysílán. Jsou-li pro stanici určeny dva nebo více objektů datových proudů s odlišnými kodeky, přenosovými rychlostmi a velikostmi rámce datového proudu, je třeba zadat informace o formátu datového proudu pro všechny typy datových proudů. Pokud informace o formátu datového proudu pro některý datový proud programu stanice chybí nebo nejsou správné, program Windows Media Player nemůže datový proud spustit, nebo nemůže přehrát některé datové proudy uvedené v seznamu programu. Další informace naleznete v tématu Vytváření stanic vysílání Multicast pomocí Správce Windows Media.

Pokud k vytvoření stanice použijete Průvodce rychlým nastavením - datové proudy vysílání Multicast na stránce Stanice vysílání Multicast ve Správci Windows Media, budou k definici stanice na obrazovce Zadání informací o formátu datového proudu informace o formátu datového proudu přidány automaticky.

Pokud k vytvoření stanice použijete upřesňující postup nebo pokud přidáváte datové proudy ke stávající stanici, je třeba informace o formátu datového proudu k definici stanice přidat ručně. Další informace naleznete v tématu Úpravy vlastností stanice.


Vytváření přecházení pro vysílání Unicast pro stanici vysílání Multicast

Přecházení pro vysílání Unicast je možné použít v případě, že program Windows Media Player nemůže přijímat pakety ze stanice vysílání Multicast. Tato situace může nastat například jestliže směrovače sítě neumožňují vysílání Multicast nebo pokud program Windows Media Player překročil hodnotu TTL (Time-To-Live) rozsahu vysílání Multicast. Pokud stanice vysílání Multicast nevysílá žádný obsah, přecházení pro vysílání Unicast se neuplatní, protože stanice vysílání Multicast vysílá signální pakety i v situaci, kdy pro ni není definován žádný program. Pokud je program Windows Media Player v rozsahu hodnoty TTL vysílání Multicast, vytvoří vazbu na signální pakety, které jsou bez obsahu.

Pokud program Windows Media Player otevře soubor ASX stanice vysílání Multicast, stáhne pomocí pokynů uvedených v tomto souboru soubor NSC, který může obsahovat adresu URL přecházení pro vysílání Unicast. Jestliže program Windows Media Player nemůže přijmout datový proud ASF vysílaný pomocí vysílání Multicast, připojí se prostřednictvím adresy URL přecházení pro vysílání Unicast k serveru a přijme datový proud z adresáře pro publikování kontinuálního vysílání Unicast.

Použijete-li k vytvoření stanice určené pro vysílání Multicast i distribuci Průvodce rychlým nastavením - datové proudy vysílání Multicast, vytvoří tento průvodce adresář pro publikování kontinuálního vysílání Unicast (s aliasem identickým se jménem stanice), který odkazuje na danou stanici. Průvodce přidá adresu URL přecházení pro vysílání Unicast k tomuto adresáři pro publikování kontinuálního vysílání Unicast v definici stanice.

Jestliže vytvoříte stanici vysílání Multicast pomocí průvodce nebo stanici určenou pro vysílání Multicast a případně i distribuci vytvoříte pomocí upřesňujícího postupu a chcete pro tuto stanici povolit přecházení pro vysílání Unicast, je třeba vytvořit adresář pro publikování kontinuálního vysílání Multicast, pro který je zdrojem datového proudu daná stanice vysílání Multicast. Další informace naleznete v tématu Použití adresářů pro publikování kontinuálního vysílání Multicast. Chcete-li pro stanici povolit přecházení pro vysílání Unicast, je třeba zadat adresu URL vysílání Unicast adresáře pro publikování kontinuálního vysílání Unicast v podobě mms://název_serveru/alias, kde název_serveru je název serveru s adresářem pro publikování kontinuálního vysílání Unicast a alias je alias tohoto adresáře. Další informace naleznete v tématu Úpravy vlastností stanice.


Publikování obsahu stanice

Po výběru metody publikování vytvoří průvodce soubor HTM nebo příslušný kód HTML zkopíruje do schránky systému Windows. Potom je možné vložit tento kód na stránku HTML. Jako výchozí je vytvořen soubor ASX obsahující odkaz na odpovídající datový proud ASF. Následující metody publikování využívají syntaxi sítě WWW, která tvoří odkaz na soubor ASX.

Vytvoření souboru HTM se značkou <HREF> a odkazem na soubor ASX

V Průvodci rychlým nastavením stanice se zobrazí výzva k určení místa pro uložení souboru HTM nebo k jeho případnému přejmenování. Pokud má být tento soubor dostupný ostatním, uložte ho na server WWW. Výchozí název souboru HTM je název_stanice_href_tag.htm.

Chcete-li ověřit správnou funkci stránky WWW vytvořené pomocí tohoto souboru, klepněte na tlačítko Test souboru HTM - <HREF> na poslední obrazovce v průvodci. Bude otevřena ukázková stránka WWW, která obsahuje odkaz na soubor ASX. Klepnutím na odkaz spustíte program Microsoft Windows Media Player. Program Windows Media Player získá přístup ke stanici a přehraje datový proud.

Vytvoření souboru HTM se značkami <OBJECT> a <EMBED> pro program Windows Media Player

V Průvodci rychlým nastavením stanice se zobrazí výzva k určení místa pro uložení souboru HTM nebo k jeho případnému přejmenování. Pokud má být tento soubor dostupný ostatním, uložte ho na server WWW. Výchozí název souboru HTM je název_stanice_object_tag.

Chcete-li vyzkoušet stránku WWW vytvořenou pomocí tohoto souboru, klepněte na tlačítko Test souboru HTM - <OBJECT> na poslední obrazovce v průvodci. Bude otevřena stránka WWW v prohlížeči. Po otevření stránky WWW se zobrazí ovládací prvek programu Windows Media Player. Program Windows Media Player automaticky získá přístup ke stanici a přehraje datový proud.

Zkopírování syntaxe <HREF> do schránky systému Windows

Tato možnost umožňuje vložit název a cestu k danému souboru ASX do kódu, který tvoří odkaz na obsah dané stanice. Vložením tohoto kódu HTML ze schránky systému Windows na libovolnou stránku WWW vytvoříte odkaz na danou stanici.

Zkopírování syntaxe <OBJECT> a <EMBED> do schránky systému Windows

Tato možnost umožňuje vložit název souboru ASX a cesty k tomuto souboru do kódu, který slouží k vložení ovládacího prvku programu Windows Media Player. Po vložení tohoto kódu HTML ze schránky systému Windows na libovolnou stránku WWW bude obsah dané stanice při otevření této stránky WWW automaticky přehrán.


Úpravy vlastností stanice

Chcete-li vytvořit stanici bez pomoci Průvodce rychlým nastavením stanice, lze zadat jednotlivé vlastnosti stanice pomocí stránky Nová stanice. Stránka Úprava stanice umožňuje zobrazovat a upravovat vlastnosti stávající stanice. Tyto dvě stránky jsou identické, kromě polí pro vlastnosti, která jsou na stránce Nová stanice prázdná.

Vlastnosti stanice jsou popsány v následující tabulce. Vlastnosti Název, Port, TTL a Cesta k souboru stanice musí být vždy zadány. Bez vyplnění těchto polí nelze vytvořit soubor NSC. Ostatní vlastnosti jsou nepovinné.

Vlastnost | Definice vlastnosti | Příklad
Název | Text, který se zobrazí na kartě Stanice v programu Microsoft Windows Media Player. | Rádio Bohemia
Popis | Text, který se zobrazí na kartě Stanice v programu Windows Media Player. | Nejnovější zprávy pro středočeský kraj.
Kontaktní adresa | Text, který se zobrazí na kartě Stanice v programu Windows Media Player. | www.radio**bohemia.cz
Kontaktní telefon | Text, který se zobrazí na kartě Stanice v programu Windows Media Player. | (123) 456 78 90
Kontaktní elektronická adresa | Text, který se zobrazí na kartě Stanice v programu Windows Media Player. | radio**bohemia@msn.cz
Režim distribuce | Režim distribuce používaný danou stanicí – Vysílání Multicast, Distribuce nebo Obojí. |
Adresa IP vysílání Multicast | Adresa IP využívaná touto stanicí. | Další informace naleznete v tématu Nastavení cílové adresy IP a portu vysílání Multicast.
Adresa adaptéru | Číslo adresy adaptéru (nebo síťové karty). Pokud máte jen jednu síťovou kartu, použijte hodnotu Výchozí. | Výchozí
Port | Port využívaný danou stanicí. | 27125
TTL | Číslo, které představuje dosah vysílání Multicast – libovolné číslo od 1 do 255. | Další informace naleznete v tématu Nastavení dosahu vysílání Multicast.
Limit distribuce | Maximální počet distribučních serverů, které mohou být k tomuto serveru připojeny. Jakmile zdrojový server dosáhne limitu distribuce, nemůže se žádný další server připojit, dokud nebude jiný distribuční server odpojen. Toto nastavení je používáno jen při distribuci stanice na jiné servery Windows Media. | 5
Adresa URL vysílání Unicast | Server Windows Media a adresář pro publikování, ke kterým se klienti automaticky připojí, jestliže požadují příjem datových proudů vysílání Unicast, nelze-li přijímat vysílání Multicast. | Další informace naleznete v tématu Vytváření přecházení pro vysílání Unicast pro stanici vysílání Multicast.
Cesta k souboru stanice | Umístění v síti, odkud klienti načtou soubor NSC. Před vytvořením stanice se rozhodněte, kam soubory stanice uložíte. Vhodným umístěním pro uložení je obvykle adresář na serveru HTTP. Je třeba vytvořit příslušný adresář a umístění jeho uložení. Správce Windows Media zobrazí požadavek na exportování souboru NSC, který obsahuje informace o vlastnostech stanice. Exportujte soubor NSC do adresáře, který jste uvedli v dialogovém okně Cesta k souboru stanice. | http://server/adresář/soubor.nsc nebo \\server\sdílený_adresář\soubor.nsc
Adresa URL pro protokolování | Adresa URL pro knihovnu DLL, kterou server využívá ke generování souborů protokolů. Tato adresa URL musí být představována cestou HTTP. Chcete-li protokolovat informace o stanici, musí být protokolovaná součást dostupná na serveru HTTP nebo ve sdíleném adresáři. | Další informace naleznete v tématu Protokolování informací o klientech vysílání Multicast.
Povolit automatickou archivaci | Tato možnost umožňuje vytvořit soubor ASF, který uloží kopii všech informací o datových proudech doručených do stanice. Po povolení automatické archivace lze zvolit, zda omezovat nebo neomezovat velikost vytvářeného souboru ASF. Do pole Adresář archivu zadejte adresář, kde má být soubor ASF vytvořen. Zadaný adresář musí skutečně na cílové jednotce fyzicky existovat; tento adresář nebude programem Správce Windows Media vytvořen automaticky. |
Přidat či odebrat formát datového proudu | Formáty v seznamu formátů datového proudu, jejichž vysílání daná stanice umožňuje. | Chcete-li do seznamu přidat formát datového proudu pro soubor ASF, je třeba zadat cestu UNC k souboru ASF, který má být vysílán. Pokud je zdrojem datového proudu program Windows Media Encoder a kodér nebyl nastaven pro použití šablony formátu datového proudu (TSF), je třeba zadat cestu UNC k souboru ASD, který popisuje konfiguraci kodéru.


Nastavení cílové adresy IP a portu vysílání Multicast

Program vysílání Multicast je směrován k cíli pomocí adresy IP stanice a portu stanice. Síťové karty očekávají podle instrukcí klientů na této adrese IP a portu pakety a klienti pak mohou přijímat program vysílání Multicast.

Cílová adresa IP a port pro obsah ve formátu ASF jsou nastaveny po vytvoření stanice na stránce Stanice ve Správci Windows Media. Klienti zjistí správnou adresu a port pro sledování paketů stáhnutím souboru NSC.

Pro jednu adresu IP lze vytvořit více programů vysílání Multicast, tyto programy však nesmí být vysílány současně. Odeslání souboru do stejného cíle jako vysílání Multicast zvukového záznamu může například kolidovat s datovým proudem zvuku.

Adresy IP vysílání Multicast se mohou vyskytovat v rozmezí od 224.0.0.0 do 239.255.255.255. Doporučená adresa IP pro sítě intranet je v rozmezí 239.*.*.*. Nepoužívejte adresy v rozmezí 224.*.*.*. Tyto adresy jsou rezervovány pro nízkoúrovňové protokoly.

Povolená čísla portů IP jsou v rozmezí od 1 do 65535.

Poznámka

  • Cílová adresa IP a port pro datové proudy přenosu souborů jsou nastaveny pro každý datový proud v programu při přidání datových proudů pomocí stránky Přenosy souborů vysílání Multicast ve Správci Windows Media. Aby klient mohl přijímat vysílání Multicast, musí se adresa IP a port nastavené pro datový proud přenosu souborů shodovat s adresou IP a portem danými síťovou kartou klienta. Další informace naleznete v tématu Konfigurace přenosu souborů vysílání Multicast.


Nastavení dosahu vysílání Multicast

Vysílání Multicast lze omezit na bezprostřední podsíť nebo rozšířit jeho dosah na celou síť Internet. Dosah je nastaven zadáním hodnoty TTL (Time-To-Live). Tato hodnota, někdy zvaná počet směrování, se snižuje při každém průchodu vysílání Multicast síťovým směrovačem. Po dosažení hodnoty 1 směrovač přesměrování vysílání Multicast zastaví. Mohou se vyskytovat hodnoty v rozmezí od 1 do 255.

Služba Windows Media Services poskytuje pro dosah následující výchozí hodnoty.

Možnost | Hodnota
Místní síť | 5
Intranet | 32
Internet | 127

Skutečnou hodnotu, která musí být užita k omezení dosahu, určuje počet a konfigurace směrovačů v síti. Proto lze nastavit vlastní hodnotu. Správce sítě může určit hodnotu pro omezení dosahu na síť intranet.


Exportování stanice

Při exportování stanice jsou ukládány informace o stanici jako soubor NSC do sdíleného adresáře nebo do adresáře v síti WWW, který je přístupný programu Microsoft Windows Media Player.

Soubor NSC obsahuje všechny informace, které program Windows Media Player potřebuje k vyhledání a zobrazení datového proudu ve formátu ASF. Přehrávač obvykle tento soubor stáhne ze serveru HTTP nebo síťové sdílené položky otevřením souboru ASX v elektronické poště, na stránce WWW nebo ze sdíleného adresáře. Soubor ASX obsahuje odkaz na soubor NSC, který je pak stažen do klientského počítače. Uživatelé musí mít k souborům NSC uloženým v síťové sdílené položce minimálně přístup pro čtení.


Importování stanice

Importováním stanice se lze nejsnadněji ujistit, že server je schopný distribuovat stanice. Při nastavení součástí Windows Media Server Components pro vysílání datových proudů pomocí vysílání Multicast z distribučního serveru Windows Media musí stanice pro vysílání Multicast obsahovat identické informace o formátu datového proudu. V závislosti na konfiguraci sítě mohou stanice využívat pro vysílání Multicast stejnou cílovou adresu IP a port – lze například využívat stejnou adresu, pokud to nepovede ke konfliktům, v situaci, kdy stanice vysílá pomocí vysílání Multicast klientům v izolované podsíti. Místo nového vytvoření jednotlivých stanic je možné pro každou stanici importovat soubor NSC nebo importovat informace o stanici přímo z jiného serveru Windows Media.

Importování stanice ze vzdáleného serveru

Chcete-li importovat stanici ze vzdáleného serveru, připojte se k danému serveru. Stanice se automaticky zobrazí v seznamu, není třeba znát umístění souborů NSC. Soubor NSC pro stanici na vzdáleném serveru není do místního adresáře importován. Tyto soubory jsou obvykle uloženy na serverech WWW. Přestože byla stanice importována, server odkazuje na informace o stanici z jejího zdroje.


Princip programů a datových proudu

Titulek služby Windows Media Services

Princip programů a datových proudů

Při konfiguraci součástí Windows Media Server Components k doručení vysílání mediálního obsahu ve formě datových proudů uživatelům je třeba nastavit a konfigurovat tři položky: stanici, program a datový proud. Po vytvoření stanice je třeba vytvořit program, který si lze představit jako kontejner umožňující organizovat, seskupovat a řídit datové proudy ASF. Potom je třeba pro daný program vytvořit datové proudy nebo použít stávající datové proudy přidružené k jiným programům. K programu je možné přidružit více souborů ASF a datových proudů.

V některých případech nelze určit, kdy bude datový proud spuštěn a zastaven. Nelze například určit, kdy vzdálená instalace programu Windows Media Encoder spustí nebo zastaví datový proud ASF vysílaný živě. Chcete-li tento datový proud řídit, musíte ho přidružit k programu, který máte možnost kontrolovat. Při spuštění nebo zastavení programu je spuštěn nebo zastaven kódovaný obsah ASF vysílaný ze stanice prostřednictvím sítě.

Program řídí datové proudy jinými způsoby. Program například může určit, jak dlouho a kolikrát bude datový proud přehráván.

Dokud není program spuštěn, nemohou klienti vysílání mediálních datových proudů přijímat. Datové proudy jsou přehrávány v pořadí určeném programem. Pokud datový proud není připraven v okamžiku, kdy k němu program získá přístup, program na datový proud počká nebo se zastaví, v závislosti na stavu zaškrtnutí políčka Zastavit program při chybě pro daný program. Při zastavení programu se klient přestane pokoušet získat přístup k danému datovému proudu.

nastavení


Přidání datových proudů k programu

Jestliže chcete k programu přidat datový proud, musí být zadána adresa URL zdroje, alias obsahu datového proudu a určena stanice pro doručení datového proudu. Před vytvořením programu a přidáním datových proudů vytvořte stanici, která podporuje příslušné formáty pro přidávané datové proudy.

Po vytvoření programu k němu lze připojit tolik datových proudů, kolik je třeba. Často je možné datové proudy seskupovat, protože spolu logicky souvisejí. Příklad:

  • Projev volebního kandidáta číslo 1 vysílaný živě.
  • Reklama uložená jako soubor ASF.
  • Projev volebního kandidáta číslo 2 vysílaný živě.
  • Reklama uložená jako soubor ASF.
  • Projev volebního kandidáta číslo 3 vysílaný živě.
  • Závěrečný komentář volebního úředníka vysílaný živě.

Chcete-li uspořádat a řídit tyto živě vysílané a uložené události, vytvořte program a potom k němu přidejte příslušné datové proudy.


Určení zdrojů pro datové proudy

Jestliže chcete k programu přidat datové proudy, musí být zadána adresa URL zdroje a alias obsahu daného datového proudu. K programu lze přidat následující typy datových proudů:

  • živě vysílané datové proudy z programu Windows Media Encoder,
  • soubory ASF, MP3 a WAV,
  • stanice Windows Media,
  • datové proudy vysílání Unicast z adresáře pro publikování kontinuálního vysílání Unicast.

Živě vysílané datové proudy z programu Windows Media Encoder

Pokud má server Windows Media vytvořit připojení k programu Windows Media Encoder, aby mohl při spuštění programu vysílat obsah ve formátu ASF, musí být definována adresa URL. Požadovaný formát adresy URL programu Windows Media Encoder je <protokol>://<název_kodéru>[:port]. Je používán protokol MSBD nebo HTTP (pokud byl kodér nakonfigurován pro vysílání pomocí protokolu HTTP). Jestliže kodér nepoužívá výchozí port (7007), je třeba zadat také správný port.

Pokud byl program Windows Media Encoder nakonfigurován na vytvoření připojení a doručení datového proudu ASF na server Windows Media, je třeba zadat alias zdroje. Připojení programu Windows Media Encoder k serveru Windows Media obsahuje logický název čili alias. Zadáním názvu aliasu je konfigurace ukončena. Pomocí připojení iniciovaného programem Windows Media Encoder pak server přijímá příslušný datový proud ASF. Před spuštěním programu je nutné zadat alias programu Windows Media Encoder.

Soubory ASF, MP3 a WAV

Chcete-li k programu přidat soubor ASF, MP3 nebo WAV, je třeba zadat adresu URL zdroje. Požadovaný formát adresy URL pro soubor uložený v kořenovém adresáři pro publikování na serveru Windows Media vysílání Unicast je <protokol>://<server_vysílání_unicast>/<název_souboru>. Adresář pro publikování je vynechán.

Požadovaný formát adresy URL Windows Media pro soubor uložený v jiných adresářích pro publikování je <protokol>://<server_vysílání_ unicast>/<alias_adresáře_pro_publikování>/<název_souboru>. Je používán protokol MMS nebo HTTP (pokud byl server vysílání Unicast nakonfigurován pro vysílání pomocí protokolu HTTP).

Stanice Windows Media

Při přidávání stanice k programu musí být zadána adresa URL zdroje. Požadovaný formát adresy URL vzdálené stanice je <protokol>://<název_serveru>/<název_stanice>. Je používán protokol MSBD.

Datové proudy vysílání Unicast z adresáře pro publikování kontinuálního vysílání Unicast

Chcete-li přidat datový proud vysílání Unicast ze vzdáleného adresáře pro publikování kontinuálního vysílání Unicast k programu, je třeba zadat adresu URL zdroje. Požadovaný formát adresy URL pro vzdálený adresář pro publikování vysílání je <protokol>://<název_serveru>/<alias_adresáře_pro_publikování>. Je používán protokol MMS nebo HTTP (pokud byl server vysílání Unicast nakonfigurován pro vysílání pomocí protokolu HTTP).


Úpravy vlastností datového proudu

Po přidání datového proudu k programu lze změnit jeho vlastnosti. Tyto úpravy lze provést pouze v situaci, kdy program není přehráván. Vlastnosti je možné upravit na kartě Upřesnit při přidávání datového proudu k programu. Následující tabulka popisuje vlastnosti datového proudu ASF.

Karta | Vlastnost | Definice
Obecné | Název | Název datového proudu ASF. Odkaz na datový proud je v seznamu datových proudů představován jeho názvem. Název se zobrazí v poli Klip v programu Microsoft Windows Media Player.
Obecné | Popis | Popis datového proudu ASF. Popis slouží jen pro server Windows Media. Tyto informace nejsou v programu Windows Media Player zobrazeny.
Zdroj a cíl | Adresa URL | Adresa URL pro soubor ASF, MP3 nebo datový proud ASF. Další informace naleznete v tématu Určení zdrojů pro datové proudy.
Zdroj a cíl | Alias | Alias instalace programu Windows Media Encoder, který je použit jako zdroj datového proudu. Další informace naleznete v tématu Určení zdrojů pro datové proudy.
Zdroj a cíl | Stanice | Stanice, kterou je obsah ASF vysílán. Datový proud ASF může být přiřazen pouze jedné stanici.
Upřesnit | Uložit do souboru formátu ASF | Možnost, která umožňuje vytvořit z datového proudu ASF soubor ASF.
Upřesnit | Soubor ASF | Název a cesta k souboru ASF vytvořenému pomocí možnosti Uložit do souboru formátu ASF.
Upřesnit | Maximální velikost | Limit velikosti souboru ASF vytvořeného pomocí možnosti Uložit do soboru formátu ASF. Zadejte hodnotu maximální velikosti souboru ASF v megabajtech (MB).
Upřesnit | Trvání | Možnost, která časově omezuje vysílání datového proudu ASF prostřednictvím sítě. Pokud zvolíte tuto možnost, zadejte maximální časový limit v podobě hh:mm:ss (kde hh=hodiny, mm=minuty a ss=sekundy).
Upřesnit | Časový limit otevření | Možnost, která časově omezuje čekání serveru při výskytu chyby před přehráním dalšího datového proudu v seznamu.
Upřesnit | Ignorovat zastavení zdrojového datového proudu ze stanice | Možnost, která zajistí, že datový proud pokračuje v přehrávání, i když se zdrojový datový proud dočasně zastaví. Tuto možnost vyberte, pokud je zdrojem datového proudu jiná stanice.


Úpravy seznamů programu

Datové proudy v programu jsou přehrávány v pořadí, v jakém se nacházejí v seznamu položek k přehrání. Po skončení jednoho datového proudu je zahájeno přehrávání dalšího. Pořadí datových proudů v seznamu je možné změnit. Datové proudy lze ze seznamu také odstranit, avšak pouze v situaci, kdy není daný program přehráván.


Oznámení programu

Titulek služby Windows Media Services

Oznámení programů

Program Microsoft Windows Media Player potřebuje k vyhledání stanice, na které je program přehráván, soubor oznámení programu. Oznámení programů vytvořená Správcem Windows Media jsou soubory uložené s příponou ASX. Oznámení obsahuje odkaz na soubor NSC obsahující informace o stanici daného programu, včetně adresy IP, portu a informací o formátu datového proudu. Pomocí oznámení vyhledá program Windows Media Player soubor NSC a načte příslušné informace o stanici.

Vytvořené oznámení může být distribuováno různými způsoby:

  • Uložení v rámci služby Microsoft Internet Information Services (IIS), odkud si mohou uživatelé soubor ASX stáhnout pomocí protokolu HTTP.
  • Uložení do veřejného adresáře v místní síti, kde mohou uživatelé získat přístup k danému souboru ASX pomocí cesty UNC.
  • Distribuce klientům prostřednictvím elektronické pošty. Uživatelé mohou soubor ASX spustit přímo ze svého programu elektronické pošty, nebo ho uložit na disk a spustit později.

Poznámka

  • Oznámení nelze použít při přenosech souborů pomocí datových proudů vysílání Multicast. V takových případech musí být pro příjem vysílání konfigurován ovládací prvek Microsoft ActiveX (Nsfile.ocx).


Uložení programu

Archivováním programu je uložena kopie vlastností programu. Program je archivován jako soubor NSP. Při archivování programu nejsou stanice a datové proudy přidružené k danému programu uloženy.

Při ukončení a restartování Správce Windows Media zůstanou vytvořené programy v seznamu programů. Pokud chcete uložit kopii programu a znovu ji později použít (obnovit ji), nebo ji použít na jiném serveru, archivujte ji. Při archivování programu je program uložen jako soubor programu Windows Media s příponou názvu souboru NSP. Datové proudy přidružené k programu jsou také uloženy. Archivováním nedojde k odstranění programu ze seznamu programů.

Všechny archivované programy Windows Media lze obnovit. Po obnovení programu je program přidán do seznamu programů a jsou obnoveny datové proudy přidružené k danému programu.


Úprava vlastností programu

Vlastnosti vybraného programu, včetně jeho názvu a možností přehrávání, je možné změnit. Před změnou vlastností programu program zastavte. Datové proudy přidružené k programu nejsou považovány za vlastnost. Datové proudy tedy nelze upravovat pomocí tlačítka Programy.


Odstranění programu

Po odstranění programu je program odebrán ze seznamu programů dostupných pro vysílání. Datové proudy přidružené k tomuto programu jsou také odstraněny. Před odstraněním musí být program zastaven.


Spuštění a zastavení programu

Spuštěním programu se spustí první datový proud v programu. Po skončení prvního datového proudu je zahájeno přehrávání dalšího. Program končí po ukončení vysílání posledního datového proudu. Pokud nastavíte program na opakování, je po skončení posledního datového proudu automaticky znovu spuštěno vysílání prvního datového proudu.

Zastavením programu dojde k ukončení vysílání. Klienti přestanou datový proud přijímat. Program se zastaví po počtu opakování zadaném ve skupinovém rámečku Možnosti přehrávání, není-li aktivován přepínač Přehrávat neustále. Program lze také zastavit klepnutím na tlačítko Zastavit program na stránce Stanice vysílání Multicast.


Vytvoření programu Vítá vás služba Windows Media Services

Za účelem procvičení obsahuje tato část pokyny umožňující vytvoření programu Vítá vás služba Windows Media Services. Tento program bude obsahovat tři soubory nainstalované v rámci součástí Windows Media Server Components: Vítejte1.asf, Vítejte2.asf a Vítejte3.asf.

V tomto cvičení vytvoříte také stanici, která bude program Vítá vás služba Windows Media Services vysílat. Na konci cvičení spustíte program Windows Media Player a budete přijímat vysílání Multicast nebo Unicast programu Vítá vás služba Windows Media Services.


Vytvoření programu Vítá vás služba Windows Media Services

  1. Na kořenové jednotce místního serveru vytvořte dva sdílené adresáře, Soubory ASX a Soubory NSC. V těchto adresářích budou uloženy soubory ASX a NSC. Pro tento postup musí být do těchto adresářů umožněn přístup všem.
  2. Zadejte informace popsané níže a postupujte přitom podle kroků v tématu Postup při vytvoření stanice vysílání Multicast pomocí Rychlého nastavení. Pro všechny ostatní možnosti použijte výchozí hodnoty.

    Na obrazovce Vytvoření nové stanice proveďte tyto činnosti:

    • Do pole Název zadejte Vítejte.
    • Do pole Popis zadejte Stanice vysílání Multicast nebo Unicast pro vysílání souborů ASF.

    Na obrazovce Zadání názvu datového proudu a programu:

    • Do pole Název programu zadejte Vítá vás služba Windows Media Services.
    • Zrušte zaškrtnutí políčka Po ukončení průvodce spustit program.
    • Do pole Název datového proudu zadejte Vítejte.

    Na obrazovce Zadání adresy URL zdroje objektu datového proudu přidejte v poli Adresa URL zdroje k adrese URL položku Vítejte1.asf.

    Na obrazovce Zadání informací o formátu datového proudu zadejte do pole Cesta cestu k souboru Vítejte1.asf v příslušném kořenovém adresáři pro publikování.

    Do pole Cesta na obrazovce Cesta pro export souboru informací o stanici zadejte cestu \\název_serveru\Soubory NSC\Vítejte.nsc, kde název_serveru je název místního serveru, nebo zadejte Systémová_jednotka\Soubory NSC\Vítejte.nsc.

    Na obrazovce Adresa URL souboru informací o stanici:

    • Klepněte na přepínač Určit soubor informací o stanici pomocí cesty k síťové sdílené položce.
    • Zadejte cestu \\název_serveru\Soubory NSC\Vítejte.nsc, kde název_serveru je název místního serveru.

    Do pole Název souboru v dialogovém okně Uložit soubor ASX zadejte cestu \\název_serveru\Soubory ASX\Vítejte, kde název_serveru je název místního serveru.

  3. Chcete-li k programu Vítá vás služba Windows Media Services přidat datový proud Vítejte2.asf, postupujte podle kroků v tématu Postup při přidání datových proudů k programu. Během tohoto postupu zadejte následující informace; pro všechny ostatní možnosti použijte výchozí hodnoty.
    • Do pole Název zadejte Vítejte2.
    • Do pole Adresa URL zdroje a cíle zadejte mms://název_serveru/Vítejte2.asf, kde název_serveru je název místního serveru.
  4. Krok 3 opakujte i pro datový proud Vítejte3.asf.
  5. Přidejte formáty datového proudu dalších souborů Vítejte*.asf ke stanici Vítejte.
    • Na stránce Stanice vysílání Multicast poklepejte v seznamu stanic na stanici Vítejte.
    • Klepněte na stránce Úprava stanice v části Formáty datových proudů na tlačítko Přidat.
    • V dialogovém okně Přidat soubor formátu datového proudu vyhledejte soubory Vítejte*.asf uložené v kořenovém adresáři pro publikování (obvykle Systémová_jednotka\ASFRoot). Vyberte soubory Vítejte2.asf a Vítejte3.asf a potom klepněte na tlačítko Otevřít. Pokud nejsou soubory ASF zobrazeny, vyberte v rozevíracím poli Typ souborů položku Soubory ASF (*.asf).
  6. V části Programy a datové proudy ASF vysílání Multicast na stránce Stanice vysílání Multicast vyberte v seznamu programů program Vítá vás služba Windows Media Services a klepněte na tlačítko Spustit program.

    Ve sloupci Stav v seznamu programů a v seznamu datových proudů se zobrazí zelená šipka.

  7. V jiném počítači spusťte program Microsoft Windows Media Player.
    • V nabídce Soubor přehrávače klepněte na příkaz Otevřít a zadejte cestu \\název_serveru\Soubory ASX\Vítejte.asx, kde název_serveru je název počítače se serverem.

    Program Windows Media Player uloží informace do vyrovnávací paměti a začne přehrávat první soubor ASF v programu Vítá vás služba Windows Media Services. Při vysílání souborů ASF je možné zjistit jejich Stav na stránce Stanice vysílání Multicast. Klienti, kteří přijímají datové proudy ASF pomocí souborů ASX, přijímají vysílání Multicast. Pokud chcete zobrazit program Vítá vás služba Windows Media Services pomocí vysílání Unicast, spusťte program Windows Media Player, klepněte na nabídku Soubor, potom na příkaz Otevřít a zadejte cestu mms://název_serveru/Vítejte, kde název_serveru je název serveru Windows Media.


Konfigurace přenosu souborů vysílání Multicast

Chcete-li vytvořit přenos souborů vysílání Multicast, je nutné nakonfigurovat součásti Windows Media Server Components na přenos souborů a ovládací prvek přenosu souborů ActiveX (Nsfile.ocx) k přijímání přenášených souborů.

Server a klientský počítač musí být nakonfigurovány pro použití stejné adresy IP; v opačném případě soubory nemohou být ze serveru na klientský počítač přeneseny. Server Windows Media vysílá soubory na adresu IP vysílání Multicast v rozmezí od 224.x.x.x do 239.x.x.x, kde x je libovolné číslo od 1 do 255. Fyzická zařízení nemohou adresu IP v tomto rozmezí používat, proto mohou být data doručena na kteroukoli z těchto adres a přijímána klienty vysílání Multicast.

Chcete-li nakonfigurovat součásti Windows Media Server Components pro přenos souborů pomocí vysílání Multicast, je nutné vytvořit program přenosu souborů vysílání Multicast a potom k programu přidat jeden nebo více datových proudů přenosu souborů. Programy a datové proudy vytvořené za účelem doručení obsahu ve formátu ASF použít nelze. Programy pro přenos souborů vytvoříte a upravíte pomocí stránky Přenosy souborů vysílání Multicast ve Správci Windows Media.

Ovládací prvek přenosu souborů ActiveX (Nsfile.ocx) byl vytvořen tak, aby umožňoval sledování určité adresy IP a následně příjem souborů přenesených prostřednictvím sítě. Další informace naleznete v tématu Konfigurace ovládacího prvku Nsfile.ocx pro příjem přenosu souborů vysílání Multicast.


Přidání datového proudu přenosu souborů k programu

Přidáním datového proudu přenosu souborů k programu zajistíte vysílání určeného souboru nebo souborů klientům v síti. Při přidání datového proudu přenosu souborů je možné:

  • přenést všechny soubory v adresáři,
  • přenést adresář a všechny příslušné podadresáře a soubory,
  • určit skupiny souborů pomocí zástupných znaků,
  • určit soubor k přenosu jeho adresou URL,
  • určit cílový adresář v klientském počítači názvem nebo proměnnou prostředí,
  • soubor při přenosu přejmenovat,
  • přenést soubory s příslušnou adresou URL do mezipaměti v aplikaci Microsoft Internet Explorer.


Použití karty Upřesnit pro přenos souboru

Titulek služby Windows Media Services

Použití karty Upřesnit pro přenos souborů

Při vytváření nového programu přenosu souborů a při úpravách již existujícího programu můžete nastavit pomocí karty Upřesnit v okně Přenos souborů následující možnosti:

  • V poli Adresa adaptéru pro vysílání Multicast vyberte adresu síťového adaptéru pro vysílání Multicast na daném serveru. Pokud má server pouze jeden adaptér, neměňte výchozí hodnotu. U počítačů s více adaptéry lze tuto možnost využít k vysílání samostatných programů vysílání Multicast současně, zadáte-li pro každý program adresu jiného adaptéru.
  • Zadejte maximální hodnotu šířky pásma pro vysílání Multicast daného souboru do pole Maximální šířka pásma.

    Pokud má vysílání Multicast vysílat klientům připojeným k síti pomocí modemu, je doporučeno zadat hodnoty v rozmezí od 10 kb/s (kilobitů za sekundu) do 20 kb/s.

    Pro vysílání Multicast klientům v typické místní síti Ethernet je doporučeno zadat hodnoty menší než 1 000 kb/s.

  • Do pole Nadbytečnost zadejte hodnotu pro opravy chyb, která má být při vysílání programu použita.

    Hodnota, kterou do pole Nadbytečnost zadáte, je zaokrouhlena na procenta. Je možné ji nastavit v rozmezí od 0,4 % do 100 %.

    Vyšší procentuální hodnota pro opravu chyb pomáhá zajistit, že klient přijme soubor bezchybně, zároveň však prodlužuje dobu odesílání souboru. Nadbytečnost 100 % například dobu odesílání souboru zdvojnásobí.

  • Do pole Trvání zadejte dobu, po kterou má být datový proud spuštěn. Použijte formát hh:mm:ss, kde hh představuje hodiny, mm minuty a ss sekundy.
  • V poli Protokolování vytvořte protokol přenosu souborů vysílání Multicast. Do pole Cesta k souboru zadejte cestu a název souboru pro soubor protokolu. Při přenosu souborů je vytvořen soubor protokolu, který obsahuje seznam přenesených souborů a informace o cíli pro všechny soubory.
  • Zaškrtnutím políčka Úplná spolehlivost umožníte zcela spolehlivý přenos souborů.

    Díky zcela spolehlivému přenosu souborů mohou klienti požadovat, aby server znovu odeslal data, která se jim nepodařilo přijmout. Po obdržení žádosti o nové odeslání server všem klientům odešle požadovaná data pomocí vysílání Multicast. Zcela spolehlivý přenos souborů může zvýšit šířku pásma sítě využívanou systémem.


Konfigurace ovládacího prvku Nsfile.ocx pro příjem přenosu souboru vysílání Multicast

Titulek služby Windows Media Services

Konfigurace ovládacího prvku Nsfile.ocx pro příjem přenosu souborů vysílání Multicast

Nsfile.ocx je ovládací prvek ActiveX přenosu souborů, který umožňuje příjem vysílaných souborů pomocí sítě. Standardním způsobem použití tohoto ovládacího prvku je jeho vložení na stránku WWW a umístění této stránky na server WWW. Pokud chce uživatel přijímat přenos souborů vysílání Multicast, stáhne stránku WWW obsahující vložený ovládací prvek.

Nastavení vlastností ovládacího prvku pro příjem souborů není předmětem této dokumentace. Sada Windows Media Technologies Software Development Kit (SDK) obsahuje ukázky programování tohoto ovládacího prvku pomocí jazyka HTML nebo aplikace Microsoft Visual Basic, Scripting Edition (VBScript). Ovládací prvek Nsfile.ocx a sadu Windows Media Technologies SDK lze stáhnout ze stránky Windows Media Technologies umístěné na serveru WWW společnosti Microsoft.


Správa připojení stanice

Připojení pomocí protokolu MSBD uskutečněná pomocí součástí Windows Media Server Components, programu Windows Media Encoder nebo programu Microsoft Windows Media Player ke stanici lze sledovat pomocí stránky Připojení stanice ve Správci Windows Media. Tato stránka zobrazuje všechna připojení k serveru, včetně posledních událostí připojení a odpojení. Tato připojení jsou připočítávána do distribučního limitu stanice.

Připojení stanice nezahrnují klienty připojené k adresářům pro publikování vysílání Unicast na požádání nebo k adresářům pro publikování kontinuálního vysílání Unicast. Připojení ke stanici také neobsahuje odkazy na klienty, kteří přijímají datový proud ASF prostřednictvím vysílání Multicast.

Můžete určit také časový úsek, za který bude seznam stanic aktualizován, vymazat seznam posledních událostí připojení a odpojení nebo ukončit připojení uskutečněná pomocí protokolu MSBD k serveru Windows Media.

Aktualizace seznamu připojení stanice

Ve výchozím nastavení je seznam Připojení stanice aktualizován každých 30 sekund. Interval aktualizace seznamu upravíte zadáním nové hodnoty do pole sekund zaškrtávacího políčka Automaticky obnovit každých. Chcete-li seznam klientů aktualizovat ručně, zrušte zaškrtnutí políčka Automaticky obnovit každých a klepněte na tlačítko Obnovit.

Vymazání seznamu událostí připojení a odpojení

Ze seznamu posledních událostí připojení a odpojení je možné vymazat všechny položky. Seznam událostí vymažte, pokud je stávající seznam zastaralý nebo příliš dlouhý.

Ukončení připojení pomocí protokolu MSBD ke stanici

Ostatní servery a klienti připojení ke stanici se započítávají do distribučního limitu dané stanice a někdy je nutné tato připojení ukončit.

Chcete-li ukončit jedno připojení, vyberte na stránce Připojení stanice požadované připojení a klepněte na tlačítko Ukončit výběr. Chcete-li ukončit všechna připojení, klepněte na tlačítko Vybrat vše a potom na tlačítko Ukončit výběr.


Správa datových proudů stanice

Datový proud ASF, který slouží jako zdroj pro stanici, lze sledovat pomocí stránky Datové proudy stanice ve Správci Windows Media. Pomocí této stránky je také možné ukončit připojení datového proudu ASF. Chcete-li zobrazit datové proudy ASF používané některou stanicí, klepněte v rámci s nabídkou Správce Windows Media na položku Datové proudy stanice. Zobrazí se stránka Datové proudy stanice, kde se automaticky zobrazí aktivní stanice a doručované datové proudy.

Stránka Datové proudy stanice poskytuje o datových proudech stanic následující informace.

Popisek sloupce | Popis
ID datového proudu | Jedinečné číslo, které identifikuje daný datový proud ASF.
Stanice | Název stanice.
Stav | Existují čtyři stavy stanice: Otevřeno, Zavřeno, Vysíláno a Restartování.
Zdroj datového proudu | Adresa URL, která stanici slouží pro příjem zdroje datového proudu.

Ukončení datových proudů stanice

Chcete-li ukončit připojení stanice k datovému proudu ASF, klepněte na požadovanou stanici v seznamu a potom klepněte na tlačítko Ukončit výběr.

Aktualizace seznamu datových proudů stanice

Seznam Datové proudy stanice je ve výchozím nastavení aktualizován každých 30 sekund. Interval aktualizace můžete změnit zadáním nové hodnoty do pole Automaticky obnovit každých. Pokud chcete aktualizovat seznam datových proudů stanice ručně, zrušte zaškrtnutí políčka Automaticky obnovit každých a klepněte na tlačítko Obnovit.


Poradce při potížích se stanicemi

V následující tabulce jsou uvedeny některé běžné problémy, které se při vytváření a používání stanic mohou vyskytnout.

Problém | Možné řešení
Nevíte, co zadat do pole na stránce Nové stanice. Při vytváření stanice nebylo zaškrtnuto políčko Vytvořit novou stanici pomocí průvodce. Při použití Průvodce rychlým nastavením stanice je řada vlastností stanice již nastavena a vlastnosti, které je třeba nastavit, jsou podrobně popsány.

Další informace o vlastnostech stanice naleznete v tématu Úpravy vlastností stanice.
Vytvořená stanice odkazuje na živě vysílaný datový proud z programu Windows Media Encoder, ale datový proud nelze spustit. Ověřte, zda v programu Windows Media Encoder probíhá kódování.

Ověřte, zda stanice používá správný odkaz datového proudu (soubor ASD). Stanice musí odkazovat na stejný soubor ASD, který používá kodér.

Po vytvoření stanice, programu a datového proudu se v seznamu datových proudů nezobrazí žádný datový proud. | Klepněte na vytvořený program. Datový proud by se měl zobrazit.
Klientům se nedaří získat přístup k datovému proudu vysílání Multicast. Klienti nemohou získat přístup k souboru ASX. Uživatelům je třeba poskytnout soubor ASX prostřednictvím elektronické pošty, vložením do dokumentu nebo uložením do adresáře.

Klienti nemohou získat přístup k souboru NSC. Soubor NSC je třeba uložit na server HTTP nebo do sdíleného adresáře. Pokud není server HTTP spuštěn a není umožněno sdílení adresáře, ve kterém je soubor NSC uložen, pro všechny uživatele, nemůže klient získat přístup k souboru NSC a přijímat vysílání Multicast.

V definici stanice vysílání Multicast schází informace o formátu datového proudu. Další informace naleznete v tématu Přidání informací o formátu datového proudu.

Směrovače sítě neumožňují vysílání Multicast. Směrovače musí umožňovat vysílání Multicast, aby datový proud mohl přecházet z jedné podsítě do jiné.

Klient je od serveru oddělen bezpečnostní bránou firewall. Konfigurace bezpečnostních bran firewall musí umožňovat vysílání datových proudů pomocí vysílání Multicast.

Není nastavena dostatečně vysoká hodnota Time-To-Live (TTL). Aktuální hodnota neumožňuje doručení datového proudu ke klientovi.
Zvuk a video stanice jsou poškozeny nebo chybí. | Chcete-li ověřit, zda problém není způsoben stanicí, připojte se pomocí programu Microsoft Windows Media Player přímo k programu Windows Media Encoder a vyzkoušejte správnou funkci datového proudu. Měli byste vidět a slyšet stejné závady.


Sledování událostí Windows Media

Sledování událostí slouží k zobrazení celkové činnosti systému, například připojení klientů, stavu a omezení serveru a funkce správy.


Běžné postupy

V této části jsou uvedeny nejběžnější postupy při používání Sledování událostí vysílání Unicast Windows Media a Sledování událostí stanice Windows Media. Tyto postupy slouží k rychlému provedení úkolu. Část následující po seznamu postupů obsahuje podrobný přehled informací o Sledování událostí Windows Media. Chcete-li zobrazit podrobnější informace o Sledování událostí Windows Media, přejděte na následující část.


Spuštění Sledování událostí vysílání Unicast Windows Media

  • V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.


Filtrování zpráv událostí vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.

    Zobrazí se stránka Události adresářů pro publikování.

  2. Na stránce Události adresářů pro publikování klepněte na tlačítko Vlastnosti.

    Zobrazí se dialogové okno Vlastnosti. Ve výchozím nastavení jsou ve skupinovém rámečku Filtrování událostí zaškrtnuta všechna políčka. Z tohoto důvodu jsou zobrazeny všechny události.

  3. U typů zpráv událostí, které nechcete zobrazovat, zrušte zaškrtnutí příslušného políčka ve skupinovém rámečku Filtrování událostí.


Omezení zobrazovaných zpráv událostí vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.

  2. Na stránce Události adresářů pro publikování klepněte na tlačítko Vlastnosti.
  3. V dialogovém okně Vlastnosti zadejte do pole Maximální velikost vyrovnávací paměti počet zpráv událostí vysílání Unicast, které chcete zobrazovat.


Řízení posunování zpráv událostí vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.

    Zobrazí se stránka Události adresářů pro publikování.

  2. Chcete-li zastavit posunování zpráv na obrazovce, klepněte na stránce Události adresářů pro publikování na tlačítko Pozastavit. Jestliže chcete posunování znovu spustit, klepněte na tlačítko Obnovit sledování.


Odstranění zpráv událostí vysílání Unicast z obrazovky

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.

    Zobrazí se stránka Události adresářů pro publikování.

  2. Na stránce Události adresářů pro publikování klepněte na tlačítko Vymazat.

    Z obrazovky sledování událostí budou odstraněny všechny zprávy o událostech.


Otevření nového okna Sledování událostí vysílání Unicast Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události adresářů pro publikování.

    Zobrazí se stránka Události adresářů pro publikování.

  2. Na stránce Události adresářů pro publikování klepněte na tlačítko Nové okno.

    Toto okno lze přesouvat a měnit jeho velikost.


Spuštění Sledování událostí stanice Windows Media

  • V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.


Filtrování zpráv událostí stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.

    Zobrazí se stránka Události stanice.

  2. Na stránce Události stanice vyberte ve skupinovém rámečku Konfigurace možností sledování požadovaný typ události.


Nastavení barev zpráv událostí stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.

    Zobrazí se stránka Události stanice.

  2. Na stránce Události stanice klepněte ve skupinovém rámečku Konfigurace možností sledování na typ zprávy události, u které chcete nastavit barvy.
  3. V dialogovém okně Barva klepněte na požadovanou barvu.


Řízení posunování zpráv událostí stanice

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.

    Zobrazí se stránka Události stanice.

  2. Chcete-li zastavit posunování zpráv událostí na obrazovce, klepněte na stránce Události stanice na tlačítko Pozastavit posun. Jestliže chcete posunování znovu spustit, klepněte na tlačítko Posunovat.


Odstranění zpráv událostí stanice z obrazovky

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.

    Zobrazí se stránka Události stanice.

  2. Na stránce Události stanice klepněte na tlačítko Vymazat vše.

    Z okna budou odstraněny všechny zprávy.


Otevření nového okna Sledování událostí stanice Windows Media

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Události stanice.

    Zobrazí se stránka Události stanice.

  2. Na stránce Události stanice klepněte na tlačítko Nové okno.

    Toto okno lze přesouvat a měnit jeho velikost.


Sledování událostí vysílání Unicast Windows Media

Sledování událostí vysílání Unicast Windows Media obsažené ve Správci Windows Media slouží k zobrazení událostí adresáře pro publikování. Chcete-li sledovat události vysílání Unicast serveru Windows Media, musíte být členem skupiny NetShow Administrator na požadovaném serveru.


Správa zobrazení událostí vysílání Unicast Windows Media

Sledování událostí vysílání Unicast Windows Media přijímá pro adresáře pro publikování vysílání na požádání a kontinuálního vysílání zprávy typu Události správce, Výstražné události, Události klienta a Události serveru. Z těchto typů můžete zvolit události, které chcete sledovat, a počet zpráv událostí, které chcete zobrazit. Ve výchozím nastavení jsou sledovány všechny čtyři typy událostí a je nastaveno zobrazení 200 zpráv událostí. Počet zpráv událostí načtených do vyrovnávací paměti a zobrazených na obrazovce se rovná hodnotě zadané v číselníku Maximální velikost vyrovnávací paměti. Zprávy jsou zobrazovány postupně vždy shora v pořadí, v jakém vznikly. Po dosažení maximální kapacity vyrovnávací paměti jsou události nacházející se v dolní části obrazovky odstraněny a v horní části se zobrazí nové události.

Při zaneprázdnění serveru Windows Media se někdy mohou události zobrazovat tak rychle, že je nebude možné číst. Posunování zpráv v okně obrazovky lze proto pozastavit a znovu spustit. Události však budou nadále zaznamenávány i v případě zastavení posunování. Staré zprávy je také možné z okna obrazovky odstranit.

Události vysílání Unicast lze na serveru sledovat i v případě, že jsou spuštěny další funkce služby Windows Media Services. Můžete otevřít nové okno sledování, které zůstane otevřeno i v průběhu provádění dalších úloh služby Windows Media Services.

Poznámka

  • Pokud zatížení procesoru serveru Windows Media dosahuje téměř jeho plné kapacity, může sledování velkého počtu událostí vysílání Unicast způsobit potíže s jejich vyřízením a s virtuální pamětí. Toto riziko lze snížit filtrováním nepotřebných událostí. Jako dlouhodobé řešení je doporučeno zvýšit výkon procesoru serveru tak, aby bylo možné v průběhu sledování událostí vysílání Unicast provádět i další úlohy.


Přehled zpráv událostí vysílání Unicast Windows Media

Sledování událostí vysílání Unicast Windows Media obsažené ve Správci Windows Media sleduje a zobrazuje zprávy typu Události správce, Výstražné události, Události klienta a Události serveru. Součástí všech zpráv jsou údaje o datu a čase každé události.


Události správce

Událost | Zpráva
OnAdminBandWidthLimit | Správce nastavil maximální šířku pásma nebo maximální šířku pásma pro alias adresáře pro publikování na rychlost v kb/s (kilobity za sekundu). Zpráva se zobrazí v případě změny maximální celkové šířky pásma určené pro server nebo pro adresář pro publikování.
OnAdminClientLimit | Správce nastavil maximální počet klientů nebo maximální počet klientů pro alias adresáře pro publikování na počet klientů. Zpráva se zobrazí v případě změny omezení počtu klientů určeného pro server nebo pro adresář pro publikování.
OnAdminFileBitRateLimit | Správce nastavil maximální přenosovou rychlost souboru na rychlost v kb/s. Zpráva se zobrazí v případě změny maximální přenosové rychlosti jednoho souboru.
OnAdminKillClient | Správce ukončil připojení určené ID klienta. Zpráva se zobrazí v případě ukončení připojení klienta k adresáři pro publikování.


Výstražné události

Událost | Zpráva
OnMaxBandwidth | Byla překročena maximální šířka pásma. Aktuální limit: rychlost v kb/s (kilobity za sekundu).
OnMaxClients | Byl překročen maximální povolený počet klientů nebo maximální povolený počet klientů pro alias adresáře pro publikování. Aktuální limit: počet klientů. Zobrazí aktuální nastavení maximálního počtu klientů serveru nebo adresáře pro publikování, jehož limit byl překročen.
OnMaxFileBitRate | Došlo k pokusu přehrát soubor, který překračuje maximální přenosovou rychlost. Aktuální maximum je rychlost v kb/s.


Události klienta

ID klienta je číslo, které je klientovi přiřazeno součástmi Windows Media Server Components.

Událost | Zpráva
OnClientConnect | Klient určený ID klienta byl připojen k adrese IP číslo adresy a k portu číslo portu.
OnClientDisconnect | Klient ID klienta byl odpojen od adresy IP číslo adresy a od portu číslo portu.
OnClientPlay | Klient určený ID klienta přehrává titul: název souboru a cesta.
OnClientStop | Klient určený ID klienta zastavil přehrávání titulu: název souboru a cesta.
OnClientStride | Klient určený ID klienta vyhledává v souboru: název souboru a cesta. Klient vyhledává umístění v indexovaném souboru ASF pomocí rychlého převinutí vpřed nebo vzad.


Události serveru

Událost | Zpráva
OnServerFault | Zpráva je aktivována v případě výskytu závažných potíží se službou Windows Media Unicast Service. Popis chyby je třeba vyhledat pomocí hodnot NSTrace a NSLog.
OnServerOffline | Server je ve stavu offline. Tato zpráva informuje o skutečnosti, že služba Windows Media Unicast Service byla zastavena.
OnServerOnline | Server je ve stavu online. Zpráva se zobrazí po restartování služby Windows Media Unicast Service. Pokud například použijete balíček pro ověřování, projeví se provedené změny až po restartování služby Windows Media Unicast Service.


Sledování událostí stanice Windows Media

Sledování událostí stanice Windows Media obsažené ve Správci Windows Media slouží k zobrazení událostí stanic serveru Windows Media. Chcete-li sledovat události stanice serveru Windows Media, musíte být členem skupiny NetShow Administrators na příslušném serveru.


Správa zobrazení událostí stanice Windows Media

Sledování událostí stanice Windows Media pracuje se zprávami typu Události klienta, Události datového proudu a Události stanice. Ve výchozím nastavení jsou vybrány všechny typy zpráv. Typy zpráv, které chcete zobrazovat, můžete vybrat. Ke snadnému odlišení jednotlivých typů zpráv na obrazovce lze použít různé barvy.

Při zaneprázdnění serveru Windows Media se někdy mohou události zobrazovat tak rychle, že je nebude možné číst. Posunování zpráv v okně obrazovky lze proto pozastavit a znovu spustit. Události však budou nadále zaznamenávány i v případě zastavení posunování. Z okna obrazovky je také možné odstranit staré zprávy.

Události vysílání Unicast lze na serveru sledovat i v případě, že jsou spuštěny další funkce služby Windows Media Services. Můžete otevřít nové okno sledování, které zůstane otevřeno i v průběhu provádění dalších úloh služby Windows Media Services.


Přehled zpráv událostí stanice Windows Media

V následující tabulce jsou uvedeny zprávy zobrazované při sledování událostí stanice serveru Windows Media. Nástroj pro sledování zobrazuje události v podobě textových zpráv. Součástí všech zpráv jsou údaje o datu a čase každé události.

Typ události | Zpráva
Událost stanice | Byla přidána nová stanice. Její název je název stanice.
Událost stanice | Stanice byla odstraněna. Její název byl název stanice a popis byl popis stanice.
Událost stanice | Vlastnost stanice se změnila. Název stanice je název stanice.
Událost datového proudu | Datový proud ze zdroje alias datového proudu nebo adresa URL datového proudu na stanici název stanice byl aktivován.
Událost datového proudu | Datový proud ze zdroje alias datového proudu nebo adresa URL datového proudu na stanici název stanice byl dezaktivován.
Událost datového proudu | Byl otevřen nový datový proud. Jeho zdroj je alias datového proudu nebo adresa URL datového proudu.
Událost datového proudu | Datový proud byl ukončen. Jeho zdroj byl alias datového proudu nebo adresa URL datového proudu a popis byl popis datového proudu.
Událost datového proudu | Datový proud byl spuštěn. Jeho zdroj je alias datového proudu nebo adresa URL datového proudu.
Událost datového proudu | Datový proud byl zastaven. Jeho zdroj je alias datového proudu nebo adresa URL datového proudu.
Událost datového proudu | Vlastnost datového proudu se změnila. Jeho zdroj je alias datového proudu nebo adresa URL datového proudu.
Událost datového proudu | Archiv datového proudu je zavřen..
Událost klienta | Klient byl připojen. Jeho adresa nebo port je: adresa IP/Port.
Událost klienta | Klient byl odpojen. Jeho adresa nebo port je: adresa IP/Port.


Čítače výkonu služby Windows Media

Čítače výkonu součástí Windows Media Server Components je možné zobrazit v programu Výkon technologie Windows Media.

Program Výkon technologie Windows Media je nainstalován společně se službami Windows Media Component Services. Program využívá soubor wmtperf.msc obsahující upravenou sadu čítačů výkonu, které jsou specifické pro součásti Windows Media Server Components.


Běžné postupy

V této části jsou uvedeny nejběžnější postupy při sledování čítačů výkonu služby Windows Media Unicast Service a služby Windows Media Station Service. Tyto postupy slouží k rychlému provedení úkolu. Část následující za tímto seznamem postupů obsahuje přehled informací popisujících čítače výkonu podrobněji. Chcete-li zobrazit podrobnější informace o čítačích výkonu služeb Windows Media Component Services, přejděte na následující část.


Spuštění programu Výkon technologie Windows Media

  • Klepněte na tlačítko Start, přejděte na příkaz Programy, potom na položku Nástroje pro správu a klepněte na položku Výkon technologie Windows Media.

    Zobrazí se okno programu sledování výkonu s nastavením souboru wmtperf.msc, které zahrnuje čítače služby Windows Media Unicast Service a služby Windows Media Station Service.


Čítače výkonu služby Windows Media Unicast Service

Následující odkazy umožňují zobrazit témata, která se týkají čítačů výkonu služby Windows Media Unicast Service. Pomocí prvního odkazu je možné zobrazit tabulku obsahující seznam čítačů, které jsou v programu sledování výkonu aktivovány jako výchozí, pomocí druhého odkazu lze zobrazit tabulku obsahující seznam dalších čítačů, které je možné do zobrazení v programu sledování výkonu přidat.

  • Přehled výchozích čítačů výkonu
  • Přehled volitelných čítačů výkonu


Přehled výchozích čítačů výkonu

Čítač výkonu | Popis
Aktivní živé datové proudy Unicast | Počet živých datových proudů vysílání Unicast, které jsou v daný okamžik vysílány.
Aktivní datové proudy | Počet aktivních souborů nebo datových proudů, které jsou v daný okamžik odesílány klientům. Představuje celkový ukazatel aktivity systému. Nezapomeňte, že klienti zůstávají připojeni i po zastavení přehrávání souboru. Služba Windows Media Unicast Service zachovává vymezenou šířku pásma klienta 60 sekund po zastavení přehrávání klientem (tato funkce se nazývá Časový limit nečinnosti klienta). Vyprší-li časový limit nečinnosti klienta, zkontroluje server aktivně stav každého klienta pomocí zprávy, kterou bude jednotlivým klientům pravidelně odesílat. Pokud klient odpovídá na zprávu do tří minut po obdržení, udržuje server spojení s klientem otevřené (tato funkce se nazývá Časový limit ukončení připojení klienta).
Aktivní datové proudy TCP | Počet datových proudů TCP, které jsou v daný okamžik odesílány klientům.
Aktivní datové proudy UDP | Počet datových proudů UDP, které jsou aktuálně odesílány klientům.
Agregovaná rychlost čtení | Součet rychlostí čtení všech souborů, které jsou odesílány klientům, v bitech za sekundu (b/s). Označuje rychlost, jakou server čte data z disku. Doba čtení bloku je kratší než doba odesílání bloku, zobrazení grafu se proto většinou jeví jako zubaté.
Agregovaná rychlost přenosu | Součet rychlostí přenosu všech souborů, které jsou odesílány klientům, v bitech za sekundu (b/s). Označuje rychlost přenosu dat klientům ze serveru. Zobrazení grafu by mělo být poměrně jemné. Pokud se zobrazení grafu jeví jako zubaté, je možné, že mezi datovými proudy došlo ke konfliktu týkajícímu se šířky pásma.
Připojení klienti | Počet aktuálně připojených klientů. Znázorňuje všechna připojení programu Microsoft Windows Media Player k systému. Zahrnuje klienty, kteří přijímají datový proud, klienty ve stavu pozastavení a připojení, a klienty, které server ještě neoznačil jako odpojené. Poslední uvedená situace může nastat v případě, že byla na straně klienta přerušena dodávka elektrické energie nebo byl klient odpojen od sítě a není možné na ukončení připojení server upozornit. Služba Windows Media Unicast Service zkontroluje po uplynutí časového limitu nečinnosti klienta (60 sekund) aktivně stav každého klienta pomocí zprávy, která bude jednotlivým klientům pravidelně odesílána. Pokud má být zachováno připojení k serveru, je nutné, aby klienti na tuto zprávu odpověděli do tří minut po obdržení zprávy (tato funkce se nazývá Časový limit ukončení připojení klienta).
Frekvence připojování | Frekvence, jakou se klienti připojují k serveru. Tato frekvence slouží k určení počtu okamžitých připojení spravovaných serverem. Výchozí počet připojení je 25 připojení za sekundu. Tento čítač je vhodný pro stanovení vztahu mezi připojením klientů a využitím systémových prostředků.
Datové proudy HTTP | Počet aktivních datových proudů HTTP, které jsou v daný okamžik odesílány klientům.
Pomalé čtení | Počet pozdě dokončených čtení za sekundu. Pomalé čtení je operace čtení z disku, jejíž dokončení trvalo déle než bylo předpokládáno. Pokud je server velmi zatížen, není většinou hodnota tohoto čítače rovna nule. Jestliže není hodnota tohoto čítače nulová často, je možné, že systém není správně nakonfigurován nebo že došlo ke konfliktu při využívání disku mezi součástmi Windows Media Server Components a jinou aplikací.
Čekající připojení | Počet klientů, kteří ještě nejsou připojeni a pokouší se k serveru připojit. Jestliže je kapacita serveru téměř zcela využita, je možné, že bude hodnota tohoto čítače vysoká, protože server není schopen zpracovat vysoký počet požadavků na připojení v očekávaném čase.
Chyby datového proudu | Počet chyb za sekundu. Chyby datového proudu představují počet paketů datového proudu, které byly znehodnoceny serverem. Tyto chyby jsou vytvářeny serverem v situacích, kdy nelze dostát všem požadavkům na data a některé pakety je nutné vyřazovat, aby bylo možné předejít nevratnému zpoždění. Chyby datového proudu většinou vznikají v důsledku pomalého čtení. Tyto chyby upozorňují na nesprávnou konfiguraci systému nebo konflikt systémových prostředků s dalšími aplikacemi. K vytváření chyb datového proudu může také negativně přispívat vysoký provoz v síti.


Přehled volitelných čítačů výkonu

Čítač výkonu | Popis
Vyhrazená šířka pásma | Šířka pásma, kterou server vymezí na základě počtu aktuálních připojení programu Windows Media Player. Jestliže jsou klienti připojeni k serveru Windows Media, ale nepřijímají datový proud, zůstává obvykle klientům příslušná šířka pásma stále vyhrazena. Pokud je programu Windows Media Player vyhrazena určitá šířka pásma a během časového limitu nečinnosti klienta (60 sekund) není tímto programem odeslán příkaz, bude vyhrazení šířky pásma zrušeno.
Požadavky na ověření | Počet vyvolání modulu plug-in pro ověřování používaného pro ověření klienta. V závislosti na tom, zda je používán protokol HTTP nebo MMS, může být během přístupu k jednotlivým částem obsahu vysílání Unicast jeden klient ověřován jednou i několikrát. Jedná se o obecný ukazatel četnosti použití modulu plug-in pro ověřování.
Odmítnutá ověření | Počet odmítnutí přístupu klientů k obsahu vysílání Unicast modulem plug-in pro ověřování. Jestliže nelze ověřit identifikátor (ID) klienta, pokud neexistuje uživatelský účet nebo nepracuje-li modul plug-in pro ověřování správně, bude klientům modulem plug-in pro ověřování přístup odmítnut.
Požadavky na autorizaci | Počet vyvolání modulu plug-in pro autorizaci používaného k autorizaci klienta. Každá operace klienta (například otevření nebo přehrávání obsahu vysílání Unicast) je autorizována odděleně. Celkový počet požadavků na autorizaci proto bude vyšší než počet připojených klientů. Jedná se o obecný ukazatel četnosti použití modulu plug-in pro autorizaci.
Odmítnuté autorizace | Počet odmítnutí přístupu klientů k obsahu vysílání Unicast modulem plug-in pro autorizaci. Moduly plug-in odmítnou přístup klientům na základě určené funkce. Pokud například uživatelský účet neobsahuje požadovanou finanční částku, umožňuje modul plug-in pro účtování přístup k obsahu vysílání Unicast odmítnout.
Čtená záhlaví datových proudů HTTP | Počet klientů, kteří jsou připojeni k serveru pomocí protokolu HTTP, čtou záhlaví souboru, ale ještě nepřijímají obsah vysílání Unicast. Součet hodnot Čtená záhlaví datových proudů HTTP a Přijímané datové proudy HTTP se rovná celkovému počtu klientů připojených k serveru pomocí protokolu HTTP, který udává čítač Datové proudy HTTP.
Přijímané datové proudy HTTP | Počet připojených klientů, kteří již přečetli záhlaví souboru a aktivně přijímají obsah vysílání Unicast pomocí protokolu HTTP. Součet hodnot Přijímané datové proudy HTTP a Čtená záhlaví datových proudů HTTP se rovná celkovému počtu klientů připojených k serveru pomocí protokolu HTTP, který udává čítač Datové proudy HTTP.
Chyby modulů plug-in | Počet selhání modulů plug-in. Modul plug-in například nemohl použít příslušnou databázi uživatelů, v modulu plug-in došlo k chybě apod.
Události modulů plug-in | Počet událostí nahlášených modulům plug-in. Ukazatel využití externích modulů plug-in serverem.
Rychlost plánování | Rychlost vytváření požadavků na plánování úkolů v úkolech za sekundu. Plánované úkoly zahrnují čtení dat z disku a zapisování dat v síti. Rychlost plánování je přibližně úměrná rychlosti odesílání paketů serverem (tato rychlost nepředstavuje korespondenci jednoho serveru s jedním klientem).
Ukončené datové proudy | Rychlost, jakou jsou datové proudy z důvodu chyb ukončeny. Ukončení datových proudů může být způsobeno nesprávnou konfigurací systému nebo poškozením vysílaného souboru. Server jednostranně ukončí datový proud za určitých okolností, nejčastěji v případě, že se server zpožďuje. Jestliže je nutné z důvodu udržení časového plánu vyřadit z datového proudu několik paketů za sebou, bude datový proud ukončen. Datový proud lze také ukončit, pokud se během vysílání datového proudu vyskytnou neplatná data.
Požadavky na opakované odeslání UDP | Počet požadavků vytvořených klienty na opakované odeslání paketů dat, které nebylo možné přijmout, ze serveru Windows Media. Pokud server neumožňuje spolehlivé odesílání paketů pomocí protokolu UDP, může být tato hodnota vysoká. Tento čítač je spolehlivým ukazatelem přetížení serveru a sítě.
Opakovaná odeslání UDP | Počet požadavků znázorněných čítačem Požadavky na opakované odeslání UDP zpracovaných serverem Windows Media. Pokud je server vysoce zatížen, nebudou všechny Požadavky na opakované odeslání UDP zpracovány.


Čítače výkonu služby Windows Media Station Service

Následující tabulka obsahuje čítače výkonu služby Windows Media Station Service. Tyto čítače jsou zobrazeny v programu Výkon technologie Windows Media jako výchozí.

Čítač výkonu | Popis
Stanice | Počet objektů stanic, které aktuálně existují na serveru.
Řadiče | Počet řadičů aktuálně připojených k serveru.
Datové proudy | Počet objektů datových proudů, které aktuálně existují na serveru.


Informační protokoly

Součásti Windows Media Server Components ukládají informace o klientech, kteří zobrazují obsah datových proudů ve formátu ASF, do informačních protokolů. Pomocí těchto informací lze určit, který soubor ASF je nejčastěji sledován, jak dlouho klient přijímá datový proud ASF, adresu IP klienta přijímajícího datový proud ASF, poskytovatele služeb sítě Internet, kterého klient využívá, a podobně.

Klienti zobrazující obsah datových proudů ASF vysílání Unicast jsou připojeni k serveru Windows Media. Služba Windows Media Services je po instalaci připravena k protokolování informací o klientech vysílání Unicast. Další informace naleznete v tématu Protokolování informací o klientech vysílání Multicast.

Klienti zobrazující obsah datových proudů vysílání Multicast k serveru Windows Media připojeni nejsou. Přesto je možné vytvářet pro klienty, kteří přijímají datový proud ASF vysílání Multicast, informační protokoly. Před vytvořením protokolu o klientech vysílání Multicast je však třeba nakonfigurovat server Windows Media. Další informace naleznete v tématu Protokolování informací o klientech vysílání Multicast.

Pokud klient používá pro připojení k adresáři pro publikování vysílání Unicast nebo ke stanici vysílání Multicast protokol MSBD, nejsou informace o klientovi do souboru protokolu ukládány.


Běžné postupy

V této části jsou uvedeny nejběžnější postupy při protokolování informací o klientech vysílání Unicast a Multicast. Tyto postupy slouží k rychlému provedení úkolu. Část následující po seznamu postupů obsahuje podrobný přehled informací o protokolování. Chcete-li zobrazit podrobnější informace o protokolování, přejděte na následující část.


Postup při protokolování informací o klientech vysílání Unicast

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Vlastnosti serveru.

  2. Na stránce Vlastnosti serveru klepněte na kartu Protokol adresáře pro publikování.
  3. Chcete-li povolit protokolování, zaškrtněte políčko Povolit protokolování.
  4. Ve skupinovém rámečku Perioda vyberte interval (Denně, Týdně nebo Měsíčně) nebo maximální velikost souboru protokolu.
  5. Do pole Adresář se souborem protokolu zadejte umístění, na které má být soubor protokolu uložen.
  6. Klepnutím na tlačítko Použít zahájíte protokolování informací o klientech vysílání Unicast.

Poznámka

  • Název informačního protokolu o klientech vysílání Unicast má formát NetShow.rrmmddiii.log, kde rr znamená rok, mm měsíc a dd den. Přípona iii určuje verzi souboru, jestliže bylo v jednom kalendářním dni vytvořeno více souborů protokolu.


Postup při protokolování informací o klientech vysílání Multicast

  1. Ověřte, zda adresář, který obsahuje rozšíření rozhraní ISAPI (Internet Server Application Programming Interface) technologie Windows Media, Nsiislog.dll, je sdílen jako adresář v síti WWW. Síťoví klienti musí mít k tomuto souboru přístup.
  2. V rámci s nabídkou programu Správce Windows Media klepněte na položku Stanice vysílání Multicast.

    Zobrazí se stránka Stanice vysílání Multicast.

  3. V podokně Stanice klepněte na stanici, pro kterou chcete vytvořit soubor protokolu, potom klepněte na tlačítko Stanice a na příkaz Vlastnosti.

    Zobrazí se stránka Úprava stanice.

  4. Do pole Adresa URL pro protokolování na stránce Úprava stanice zadejte adresu URL knihovny DLL Nsiislog.dll a klepněte na tlačítko OK.

    Zadejte například http:/název_serveru/scripts/Nsiislog.dll, kde název_serveru je název počítače služby IIS (Microsoft Internet Information Services). Knihovna Nsiilog.dll se nemusí nacházet ve stejném počítači jako server Windows Media, musí však být nainstalována v adresáři přístupném v síti WWW.

  5. Po zobrazení výzvy uložte změny do souboru NSC.

Poznámky

  • Tento postup předpokládá, že součásti Windows Media Server Components byly instalovány v počítači, ve kterém již byla nainstalována služba IIS. Další informace naleznete v tématu Protokolování informací o klientech vysílání Multicast.
  • Název informačního protokolu o klientech vysílání Multicast má formát NetShow.rrmmddiiii.log, kde rr znamená rok, mm měsíc a dd den. Přípona iiii určuje verzi souboru, jestliže bylo v jednom kalendářním dni vytvořeno více souborů.


Protokolování informací o klientech vysílání Unicast

Pomocí programu Správce Windows Media lze protokolovat informace o činnostech prováděných klienty, kteří jsou připojeni k příslušným adresářům pro publikování vysílání Unicast. Soubory informačních protokolů o klientech vysílání Unicast jsou textové soubory obsahující pole oddělená mezerami. Nemáte-li k dispozici aplikaci určenou pro čtení souborů protokolu, je možné soubor protokolu otevřít pomocí programu Poznámkový blok. Pokud chcete informace uspořádat do řádků a sloupců, lze soubor otevřít také v aplikaci Microsoft Excel. Popis obsahu uloženého v souborech protokolů naleznete v tématu Vysvětlivky k souborům protokolů Windows Media.

Do souborů informačních protokolů o klientech vysílání Unicast jsou položky ukládány po zadanou dobu nebo dokud není dosaženo určené velikosti. Tyto soubory jsou uloženy na zvoleném místě na serveru Windows Media, který spravujete. Další informace o nastavení následujících možností naleznete v tématu Postup při protokolování informací o klientech vysílání Unicast .

Možnost | Popis
Povolit protokolování | Spuštění nebo zastavení protokolování. Ve výchozím nastavení není protokolování povoleno.
Perioda | Slouží k vytváření nových protokolů se zadanou četností. Po dosažení příslušného intervalu nebo velikosti souboru služba soubor protokolu uzavře a vytvoří ve stejné složce nový soubor s odlišným názvem. Při výběru možností Denně, Týdně a Měsíčně je soubor protokolu uzavřen po vytvoření prvního záznamu po půlnoci posledního dne intervalu aktuálního souboru protokolu. Název souboru protokolu je NetShow.rrmmddiii.log, kde rrmmdd znamená rok, měsíc a den vytvoření souboru protokolu a iii je číslo, které začíná hodnotou 000 a s každým protokolem vytvořeným v aktuálního den se zvyšuje o hodnotu jedna. Pokud chcete vytvářet soubory protokolu na základě velikosti, vyberte možnost Jakmile velikost souboru dosáhne a zadejte hodnotu mezi 8 kilobajty (kB) a 1 000 000 kB včetně. Nový soubor protokolu je vytvořen při každém spuštění služby, nezávisle na tomto nastavení.
Adresář se souborem protokolu | Určuje adresář serveru obsahující soubor protokolu. Ve výchozím nastavení je použit adresář Kořenový _adresář_systému\system32\logfiles.

Poznámky

  • Použije-li správce vzdálený počítač, představuje cesta v poli Adresář se souborem protokolu cestu v počítači se serverem, nikoli v počítači správce.
  • Pokud klient používá pro připojení k adresáři pro publikování vysílání Unicast protokol MSBD, nejsou informace o klientovi do souboru protokolu ukládány.


Protokolování informací o klientech vysílání Multicast

Protokolování informací o klientech vysílání Multicast umožňuje zobrazit informace o klientovi, který přijímá datový proud ASF, a o připojení tohoto klienta. Pokud chcete protokolovat informace o klientech vysílání Multicast, použijte rozšíření rozhraní ISAPI technologie Windows Media (Nsiislog.dll). Jestliže jsou součásti Windows Media Server Components nainstalovány v počítači, ve kterém je již nainstalována služba IIS, je rozšíření Nsiislog nainstalováno v adresáři Systémová_jednotka\Kořenový_adresář_systému\system32\Windows Media\Server i v adresáři Systémová_jednotka\Inetpub\scripts. Není-li služba IIS v počítači se serverem nainstalována, je knihovna Nsiislog.dll nainstalována pouze do adresáře Systémová_jednotka\Kořenový_adresář systému\system32\Windows Media\Server. Další informace o zajištění protokolování činností stanice naleznete v tématu Postup při protokolování informací o klientech vysílání Multicast.

Protokol je také možné vytvořit pomocí skriptu CGI (Common Gateway Interface).

Je-li pro určitou stanici povoleno protokolování, je soubor protokolu uložen do adresáře Kořenový_adresář systému\system32\logfiles. Název souboru protokolu je NetShow.rrmmddiiii.log, kde rrmmdd znamená rok, měsíc a den vytvoření souboru protokolu a iiii je číslo, které začíná hodnotou 0000 a s každým protokolem vytvořeným v aktuální den se zvyšuje o hodnotu jedna.

Soubor protokolu je textový soubor obsahující pole oddělená mezerami. Nemáte-li k dispozici aplikaci určenou pro čtení souborů protokolu, je možné soubor protokolu otevřít pomocí programu Poznámkový blok. Pokud chcete informace uspořádat do řádků a sloupců, lze soubor otevřít také v aplikaci Microsoft Excel. Popis obsahu uloženého v souboru protokolu naleznete v tématu Vysvětlivky k souborům protokolů Windows Media.

Poznámka

  • Pokud klient používá pro připojení ke stanici vysílání Multicast protokol MSBD, nejsou informace o klientovi do souboru o protokolu ukládány.


Analýza souborů protokolů Windows Media

Činnost uživatele je definována jako všechny činnosti, které uživatel v klientovi vykoná během zobrazování datového proudu. Pokud je klient připojen k adresáři pro publikování vysílání Unicast na požádání, může být jedna činnost uživatele v souboru informačního protokolu o klientovi vysílání Unicast představována více položkami. Jestliže například klient přehrává soubor ASF po dobu jedné minuty, převíjí ho zpět, opět soubor ASF přehrává po dobu 10 sekund, převíjí ho vpřed a potom přehrává zbývající část souboru, tyto činnosti (přehrávání, převíjení vzad, přehrávání, převíjení vpřed, přehrávání a zastavení) vytvoří v souboru informačního protokolu o klientovi vysílání Unicast pět položek. Jsou-li k serveru Windows Media připojeni další klienti a jejich činnosti jsou protokolovány, nemusí se položky pro činnost jednoho uživatele v protokolu zobrazit společně.

Pokud je klient připojen k adresáři pro publikování kontinuálního vysílání Unicast nebo ke stanici vysílání Multicast, je činnost uživatele zaznamenaná v souboru informačního protokolu o klientovi vysílání Unicast nebo v souboru informačního protokolu o klientovi vysílání Multicast reprezentována jen jednou položkou, protože uživatel nemůže živě vysílaný datový proud rychle převíjet vpřed, vzad ani pozastavovat; může ho pouze zastavit. Položka souboru protokolu je vytvořena v případě, že uživatel zastaví klienta, který přijímá živě vysílaný obsah.

Klient není při příjmu datových proudů Multicast k serveru Windows Media fyzicky připojen. Položky obsahující pole, která ukládají informace o připojení klient - server, jsou proto v informačním protokolu o klientovi prázdná. Další informace naleznete v tématu Scénář 3: Činnosti uživatele při vysílání Multicast.

Poznámky

  • Soubor protokolu je textový soubor obsahující jako oddělovače mezery, který lze importovat do tabulky aplikace Microsoft Excel. Potom je možné položky souboru protokolu v tabulce aplikace Excel seřadit podle typu polí. Další informace naleznete v tématu Vyhledání činností uživatele v souboru protokolu Windows Media.
  • Další software technologie Windows Media, včetně nástrojů pro analýzy protokolů, poskytují jiní výrobci. Další informace naleznete na stránce Windows Media Technologies na serveru WWW společnosti Microsoft.


Vyhledání činností uživatele v souboru protokolů Windows Media

Titulek služby Windows Media Services

Vyhledání činností uživatele v souboru protokolu Windows Media

Chcete-li zobrazit činnosti uživatele v souboru protokolu Windows Media, je možné změnit uspořádání řádků na základě polí c-dns nebo c-playerid (uživatel) a cs-uri-stem (datový proud) v aplikaci Microsoft Excel. Pole c-dns identifikuje klientský počítač na základě názvu podle konvence DNS (Domain Name System) a lze pomocí něj identifikovat uživatele. Uživatel však může přijímat obsah ve formě datového proudu v klientském počítači pomocí více klientů. Pole c-playerid je jedinečné, proto položky se stejnou hodnotou c-playerid byly vytvořeny jedním klientem. Pole cs-uri-stem obsahuje informace o vysílaném obsahu: soubor ASF pro vysílání Unicast na požádání, adresu URL kontinuálního vysílání Unicast nebo soubor ASX pro vysílání Multicast. Takto uspořádaný soubor protokolu zobrazuje činnosti uživatele: seznam uživatelů nebo klientů, vysílaný obsah a sekvenci událostí, provedených klientem k zajištění příjmu vysílání obsahu ve formě datového proudu. Další informace naleznete v tématu Činnosti uživatele v souboru protokolu Windows Media.

Poznámka

  • Před seřazením položek souboru protokolu odstraňte záhlaví #Fields: v tabulce aplikace Excel. Vyberte příslušnou buňku a v nabídce Úpravy klepněte na příkaz Odstranit. Potom klepněte na přepínač Posunout buňky vlevo. Tímto způsobem zajistíte, že záhlaví s názvy polí a jejich hodnoty si budou odpovídat.


Činnosti uživatele v souboru protokolů Windows Media

Titulek služby Windows Media Services

Činnosti uživatele v souboru protokolu Windows Media

Posloupnost činností (událostí) provedených jednotlivými klienty k zajištění zobrazení datového proudu zobrazují v souboru informačního protokolu o klientech Windows Media tři pole: c-starttime, x-duration a c-rate.

U souboru ASF vysílaného na požádání představuje hodnota c-starttime časové razítko (v sekundách) tohoto souboru při provedení některé z činností klienta (zastavení, rychlý posun vpřed a vzad). U kontinuálního vysílání datového proudu vysílání Unicast nebo Multicast je hodnota c-starttime vždy nula.

Hodnota x-duration je doba (v sekundách), po kterou klient zobrazoval datový proud. Za zobrazování datového proudu je považováno i rychlé převíjení datového proudu vpřed a vzad. Pro hodnotu x-duration je proto protokolována rovněž doba (v sekundách) vynechaná v klientovi při rychlém převíjení indexovaného souboru ASF vpřed a vzad.

Hodnota c-rate představuje kód události klienta vytvářející položku souboru protokolu. Pokud uživatel zobrazuje datový proud kontinuálního vysílání Unicast nebo vysílání Multicast, je hodnota c-rate je vždy 1, protože klient nemůže živě vysílaný datový proud pozastavit ani rychle převíjet vpřed či vzad. Může datový proud pouze zastavit. Jestliže uživatel zobrazuje datový proud vysílání Unicast na požádání, může pole c-rate nabývat několika hodnot:

C-rate | Definice
1 | Uživatel zobrazoval datový proud po dobu x-duration.
-5 | Uživatel zobrazoval datový proud po dobu x-duration během převíjení vzad.
5 | Uživatel zobrazoval datový proud po dobu x-duration během převíjení vpřed.

Pokud obsahují dvě za sebou následující položky činností uživatele v informačním protokolu o klientovi vysílání Unicast pole c-rate s hodnotou 1, zobrazoval uživatel obsah po dobu rovnou hodnotě x-duration v první položce před zastavením nebo pozastavením klienta. Provedenou činnost lze určit z druhé položky:

  • Je-li hodnota c-starttime ve druhé položce nula, uživatel klienta zastavil.
  • Jestliže je hodnota c-starttime ve druhé položce součtem hodnot c-starttime a x-duration v první položce, uživatel klienta pozastavil.

Pokud poslední položka činnosti uživatele v informačním protokolu o klientovi vysílání Unicast obsahuje pole c-rate s hodnotou 1, zobrazoval uživatel obsah po dobu rovnou hodnotě x-duration dané položky před zastavením nebo ukončením činnosti klienta.

Poznámka

  • Obsahují-li dvě po sobě následující položky činností klienta v informačním protokolu o klientovi vysílání Unicast hodnotu c-rate rovnou 1, ale hodnota c-starttime ve druhé položce je větší nebo menší než součet hodnot c-starttime a x-duration v první položce, použil uživatel v klientovi pro rychlé převíjení vpřed nebo vzad datového proudu vysílání Unicast na požádání panel hledání. Při použití panelu hledání pro rychlé převíjení vpřed či vzad datového proudu vysílání Unicast na požádání nejsou do informačního protokolu o klientovi vysílání Unicast uloženy informace o rychlém převíjení vpřed a vzad.


Scénář 1: Činnosti uživatele při vysílání Unicast na požádání

Uživatel se připojí k serveru Windows Media, začne přijímat soubor ASF s délkou 60 sekund (soubor ASF s hodnotou filelength rovnou 60) a vykoná v klientovi následující činnosti:

  • Po odvysílání deseti sekund soubor ASF pozastaví.
  • Klepne na tlačítko Přehrát.
  • Jakmile soubor ASF dosáhne čtyřiceti sekund, klepne na tlačítko Převinout a převine soubor ASF zpět o dvacet sekund.
  • Když soubor ASF dosáhne třiceti sekund, klepne na tlačítko Rychle vpřed a rychle převíjí vpřed na čtyřicet sekund.
  • Nechá datový proud přehrávat, dokud se nezastaví na jedné minutě (šedesát sekund).

Část položek souboru protokolu klienta vysílání Unicast pro tyto činnosti uživatele je zobrazena v následující tabulce.

c-starttime | x-duration | c-rate | Popis
0 | 10 | 1 | Uživatel přehrává soubor ASF po dobu 10 sekund, potom datový proud pozastaví.
10 | 30 | 1 | Uživatel přehrává soubor ASF po dobu 30 sekund.
40 | 20 | -5 | Pomocí tlačítka Převinout v klientovi převíjí uživatel soubor ASF ze 40 sekund na 20 sekund.
20 | 10 | 1 | Uživatel přehrává soubor ASF po dobu 10 sekund.
30 | 10 | 5 | Pomocí tlačítka Rychle vpřed v klientovi převíjí uživatel soubor ASF rychle vpřed ze 30 sekund na 40 sekund.
40 | 20 | 1 | Uživatel přehrává zbývající část souboru ASF. Klient zastaví na konci souboru ASF přijímání datového proudu.

Uživatel přijímal celý soubor datového proudu (60 sekund) a prohlížel soubor mezi časovými razítky 20 a 30 sekund (po dobu 10 sekund); zobrazoval tak soubor ASF v režimu normálního přehrávání po dobu 70 sekund. Chcete-li pokládat převíjení vzad a rychlé převíjení vpřed za součást činností uživatele, můžete přidat také hodnotu x-duration, kdy uživatel převíjel soubor vzad (20 sekund), a hodnotu x-duration, kdy uživatel soubor převíjel vpřed (10 sekund). Tak získáte pro tyto činnosti uživatele celkovou dobu zobrazování (součet všech hodnot pro x-duration) 100 sekund. Pokud nebudete převíjení vzad a rychlé převíjení vpřed považovat za součást zobrazování, můžete všechny položky protokolu, kde hodnota c-rate je -5 (převíjení vzad) a 5 (rychlé převíjení vpřed), přeskočit.


Scénář 2: Činnosti uživatele při kontinuálním vysílání Unicast

Uživatel se připojí k serveru Windows Media, otevře odkaz na živě vysílaný datový proud vysílání Multicast prostřednictvím vysílání Unicast (kontinuálního vysílání Unicast) a po dobu pěti minut přijímá datový proud v programu Windows Media Player. V následující tabulce je zobrazena část položky souboru protokolu klienta vysílání Unicast pro tuto činnost uživatele.

čas | c-starttime | x-duration | c-rate | Popis
18:10:57 | 0 | 300 | 1 | Uživatel se připojí k živě vysílanému datovému proudu vysílání Multicast prostřednictvím vysílání Unicast (kontinuálního vysílání Unicast) a přehrává ho po dobu pěti minut. Potom klepne v klientovi na tlačítko Stop.

Pokud uživatel použije v klientovi tlačítko Stop nebo ukončí činnost klienta, zobrazí se v souboru informačního protokolu o klientovi vysílání Unicast odpovídající položka. Skutečnou dobu, kdy byl uživatel připojen ke kontinuálnímu vysílání Unicast, lze určit odečtením hodnoty v poli x-duration od hodnoty v poli čas v souboru informačního protokolu o klientovi vysílání Unicast.

Uživatel se za účelem příjmu živého vysílání Multicast ve formě datového proudu připojil k adresáři pro publikování vysílání Unicast na serveru Windows Media. Proto obsahují pole v informačním protokolu o klientovi vysílání Unicast, ve kterých jsou uloženy informace o připojení klient - server, příslušné hodnoty. Další informace naleznete ve Scénáři 3: Činnosti uživatele při vysílání Multicast.


Scénář 3: Činnosti uživatele při vysílání Multicast

Uživatel se připojí k serveru Windows Media, otevře odkaz na datový proud vysílání Multicast a přijímá tento datový proud v klientovi představovaném programem Windows Media Player po dobu tří minut. V následující tabulce je zobrazena část položky souboru protokolu klienta vysílání Multicast pro tuto činnost uživatele.

čas | c-starttime | x-duration | c-rate | Popis
21:10:00 | 0 | 180 | 1 | Uživatel se připojí k živě vysílanému datovému proudu vysílání Multicast ve 21:07 hodin a přehrává ho po dobu tří minut. Potom klepne v klientovi na tlačítko Stop.

Pokud uživatel použije v klientovi tlačítko Stop nebo ukončí činnost klienta, zobrazí se v souboru informačního protokolu o klientovi vysílání Multicast odpovídající položka. Skutečnou dobu, kdy byl uživatel připojen k vysílání Multicast, lze určit odečtením hodnoty v poli x-duration od hodnoty v poli čas v souboru informačního protokolu o klientovi vysílání Multicast.

Pokud klient přijímá datový proud vysílání Multicast, není k serveru Windows Media fyzicky připojen. Proto neobsahují následující pole v informačním protokolu o klientovi vysílání Multicast, ve kterých jsou uloženy informace o připojení klient - server, žádné hodnoty:

  • s-cpu-util
  • s-dns
  • s-ip
  • s-pkts-sent
  • s-totalclients
  • sc-bytes

Další informace naleznete v tématu Vysvětlivky k souborům protokolů Windows Media.


Ztracené pakety

Ke ztrátě paketu může v datovém proudu ze serveru ke klientovi dojít v důsledku přetížení sítě, potíží se směrovači a dalších potíží. Pakety jsou klientem považovány za ztracené také v případě, že jsou doručeny pozdě a nemohou být včas přehrány. Následující schéma znázorňuje, jak mohou být pakety odeslané serverem Windows Media doručeny klientovi. Pod schématem jsou popsána příslušná pole informačního souboru protokolu o klientovi Windows Media.

Pomocí souboru informačního protokolu o klientovi Windows Media lze určit, zda byly některé pakety ztraceny, kde se ztratily a zda byly některé pakety obnoveny. Následující pole souboru protokolu obsahují informace o tom, kolik paketů se ztratilo, kde se ztratily a zda byl podniknut pokus ztracené pakety obnovit:

s-pkts-sent | Pakety odeslané serverem Windows Media připojenému klientovi. V souboru informačního protokolu o klientovi vysílání Multicast toto pole neobsahuje žádnou hodnotu, protože klient se při zobrazení datového proudu vysílání Multicast k serveru nepřipojuje.
c-pkts-received | Pakety (s-pkts-sent) bezchybně přijaté klientem na první pokus. Pakety, které nebyly na první pokus bezchybně přijaty, mohou být obnoveny, jsou-li znovu odeslány pomocí protokolu UDP. Opakované odeslání protokolem UDP je k dispozici, pokud je k vysílání daného obsahu ve formě datového proudu použit protokol MMS. Pakety, které nejsou pomocí protokolu UDP obnoveny, jsou považovány za ztracené v síti a mohou být obnoveny, je-li pro soubor ASF nebo datový proud vysílání Multicast zapnuta oprava chyb.
c-pkts-recovered-resent | Pakety (s-pkts-sent), které klient nepřijal na první pokus bezchybně, ale které byly obnoveny, protože klient si vyžádal od serveru Windows Media jejich opakované odeslání pomocí protokolu UDP.
c-pkts-lost-net | Pakety, které nebyly obnoveny opakovaným odesláním pomocí protokolu UDP. Tyto pakety se pokládají za ztracené v síti. Takovéto pakety lze obnovit v případě, že je pro soubor ASF nebo datový proud vysílání Multicast zapnuta oprava chyb.
c-pkts-recovered-ECC | Pakety ztracené v síti (c-pkts-lost-net), které byly opraveny a obnoveny v klientské vrstvě pomocí opravy chyb. Pro datové proudy vysílání Multicast je oprava chyb jediným způsobem obnovení paketů.
c-pkts-lost-client | Pakety, které nebyly obnoveny v klientské vrstvě pomocí opravy chyb nebo v síťové vrstvě pomocí opakovaného odeslání protokolem UDP, ztracené během přenosu ze serveru ke klientovi. Tyto pakety byly odeslány serverem Windows Media, ale nebyly klientem nikdy přehrány.
c-pkts-lost-cont-net | Maximální počet paketů ztracených v síti za sebou. Pokud je tato hodnota vysoká, existovaly v síti špatné podmínky, s dlouhými časovými úseky, během kterých klient nepřijímal žádné pakety.

Není-li žádná z metod obnovy (oprava chyb a opakované odeslání pomocí protokolu UDP) úspěšná, nemohou uživatelé zobrazování žádným způsobem zlepšit (obnovit ztracené pakety).


Vysvětlivky k souborům protokolů Windows Media

Soubory protokolu vytvořené po povolení protokolování vysílání Unicast nebo Multicast jsou textové soubory, které obsahují pole oddělená mezerami. Následující tabulka obsahuje seznam všech polí, jejich popis a vzorovou hodnotu pro každou položku, která se v souboru protokolu může vyskytovat.

Pole | Popis | Vzorová hodnota
audiocodec | Použitý zvukový kodek datového proudu. | Voxware_MetaSound
avgbandwidth | Průměrná šířka pásma (v bitech za sekundu), se kterou byl klient připojen k serveru. | 24300
c-buffercount | Počet ukládání dat do vyrovnávací paměti v klientovi při přehrávání datového proudu. | 4
c-bytes | Počet bajtů přijatých klientem ze serveru. Pro vysílání Unicast musí být hodnoty c-bytes a sc-bytes identické. V opačném případě nastane ztráta paketu. Další informace naleznete v tématu Ztracené pakety. | 28583
c-cpu | Typ procesoru klientského počítače. | Pentium
c-dns | Název klientského počítače podle konvence DNS. | praha2.dns.spolecnost.cz
c-hostexe | Hostitelská aplikace. Například stránka WWW v prohlížeči (iexplore.exe), aplet jazyka Microsoft Visual Basic (vb.exe) nebo samostatný program Windows Media Player (mplayer2.exe). | iexplore.exe
c-hostexever | Číslo verze hostitelské aplikace. | 4.70.1215
c-ip | Adresa IP klientského počítače. Klient, který není řádně připojen, poskytuje adresu IP klientského proxy serveru, nikoli adresu IP klienta. | 157.56.219.146
c-os | Operační systém klientského počítače. | Windows_NT
c-osversion | Číslo verze operačního systému klientského počítače. | 4.0.0.1381
c-pkts-lost-client | Počet paketů ztracených během přenosu ze serveru ke klientovi a neobnovených v klientské vrstvě pomocí opravy chyb nebo v síťové vrstvě pomocí opakovaného odeslání protokolem UDP. | 5
c-pkts-lost-cont-net | Maximální počet paketů ztracených v síťové vrstvě za sebou během přenosu ze serveru ke klientovi. | 2
c-pkts-lost-net | Počet paketů ztracených v síťové vrstvě. Pakety ztracené v síťové vrstvě mohou být obnoveny, pokud je klient znovu vytvoří pomocí opravy chyb. Rozdíl mezi hodnotou c-pkts-lost-net a c-pkts-lost-client je rovný hodnotě c-pkts-recovered-ECC. | 2
c-pkts-received | Počet paketů ze serveru (s-pkts-sent), které klient přijal bezchybně na první pokus. | 50
c-pkts-recovered-ECC | Počet paketů opravených a obnovených v klientské vrstvě. Tento počet se rovná rozdílu mezi hodnotami c-pkts-lost-net a c-pkts-lost-client. | 3
c-pkts-recovered-resent | Počet paketů obnovených na základě opakovaného odeslání pomocí protokolu UDP. | 5
c-playerid | Globálně jedinečný identifikátor (GUID) přehrávače. | {c579d042-cecc-11d1-bb31-00a0c9603954}
c-playerlanguage | Kód země jazyka klienta. | en-US
c-playerversion | Číslo verze přehrávače. | 6.2.5.415
c-quality | Procentuální hodnota určující počet paketů, které byly klientem přijaty, označující kvalitu datového proudu. Pokud je hodnota cPacketsRendered rovna všem paketům přijatým klientem, včetně paketů obnovených pomocí opravy chyb a opakovaného odeslání protokolem UDP (c-pkts-received + c-pkts-recovered-ECC + c-pkts-recovered-resent), lze hodnotu c-quality vypočítat následujícím způsobem: [cPacketsRendered / (cPacketsRendered + c-pkts-lost-client)] * 100. | 96
c-rate | Režim programu Windows Media Player při odeslání posledního příkazu. 1 = Program Windows Media Player byl pozastaven nebo zastaven během přehrávání, rychlého převíjení vpřed, převíjení vzad nebo skoku na značku. -5 = Program Windows Media Player byl převíjen vzad z přehrávání, zastavení nebo pozastavení. 5 = Program Windows Media Player byl převíjen vpřed z přehrávání, zastavení nebo pozastavení. | 1
c-resendreqs | Počet požadavků klienta na přijetí nových paketů. Toto pole obsahuje hodnotu jen v případě, že klient používá opakované odeslání pomocí protokolu UDP. | 5
c-starttime | Časové razítko (v sekundách) datového proudu při vytvoření nové položky v souboru protokolu. | 0
c-status | Kódy popisující stav klienta. Odpovídá kódům stavu klienta HTTP/1.1 a RTSP popsaným v dokumentech RFC (Request for Comments) 2068 a RFC 2326. Služba Windows Media Services obsahuje kódy stavu klienta, které lze rozšiřovat, číslo 480 (současná připojení klientů překročila maximální limit pro klienty serveru) a 483 (datový proud překročil maximální limit přenosové rychlosti souborů serveru). | 200
c-totalbuffertime | Doba (v sekundách), po kterou klient ukládal datový proud do vyrovnávací paměti. Pokud klient ukládá datový proud do vyrovnávací paměti před vytvořením položky protokolu více než jednou, představuje hodnota c-totalbuffertime celkovou dobu ukládání datového proudu do vyrovnávací paměti. | 6
channelURL | Adresa URL souboru NSC. Soubor informačního protokolu o klientech vysílání Unicast zaznamená pro toto pole hodnotu „-“. | http://tampico/kanal.nsc
cs(Referer) | Adresa URL stránky WWW, na kterou byl program Windows Media Player vložen (byl-li vložen). | http://www.spolecnost.cz
cs-uri-stem | Název přehrávaného souboru ASF pro vysílání Unicast nebo souboru ASX pro vysílání Multicast. | mms://zanzibar/vzor.asf
cs(User-Agent) | Typ použitého prohlížeče, pokud byl program Windows Media Player vložen do prohlížeče. | Mozilla/4.0_(compatible;_MSIE_4.01;_Windows_98)
date | Datum (středního času), kdy byla v souboru protokolu vytvořena položka. | 1999-04-19
filelength | Délka souboru (v sekundách). Pro živě vysílaný datový proud je tato hodnota 0. | 60
filesize | Velikost souboru (v bajtech). Pro živě vysílaný datový proud je tato hodnota 0. | 86000
protocol | Protokol sloužící pro přístup k danému datovému proudu: MMS, HTTP nebo ASFM (protokol vysílání Multicast). | mms
s-cpu-util | Průměrné zatížení procesoru serveru (0 % - 100 %). U více procesorů představuje tato hodnota průměr pro všechny procesory. | 40
s-dns | Server DNS. | media.server.spolecnost.cz
s-ip | Adresa IP serveru. | 224.24.41.189
s-pkts-sent | Pakety odeslané serverem. | 55
s-totalclients | Klienti připojení k serveru (někteří klienti však nemusí přijímat datové proudy). | 20
sc-bytes | Počet bajtů odeslaných serverem klientovi. | 30000
time | Čas (podle středního času), kdy byla v souboru protokolu vytvořena položka. | 15:30:30
transport | Protokol přenosu použitý k doručení datového proudu (UDP, TCP nebo UDP pomocí adresy IP vysílání Multicast). | UDP
videocodec | Videokodek použitý ke kódování datového proudu. | Microsoft_MPEG-4_Video_Codec_V2
x-duration | Doba, po kterou klient přehrával obsah před klientskou událostí (převíjení vpřed, vzad, pozastavení, zastavení nebo skok na značku). Při výskytu některé z těchto klientských událostí je vytvořena položka protokolu. | 31


Správa a zabezpečení služeb technologie Windows Media

Tato část obsahuje informace týkající se funkcí správy a zabezpečení služby Windows Media Services.


Běžné postupy

V této části je uveden seznam běžných postupů prováděných při správě a zajištění zabezpečení serveru Windows Media. Tyto postupy slouží k rychlému provedení úkolu. Část následující po seznamu postupů obsahuje přehled informací vysvětlujících správu a zabezpečení služby Windows Media Services podrobněji. Chcete-li zobrazit podrobnější informace o správě a zabezpečení služeb technologie Windows Media, přejděte na následující část.


Změna účtu a hesla používaných službami Windows Media Component Services

  1. Otevřete okno Ovládací panely.
  2. V okně Ovládací panely poklepejte na panel Nástroje pro správu a potom poklepejte na panel Služby.
  3. V okně Služby klepněte pravým tlačítkem myši na název služby Windows Media (Služba Windows Media Monitor Service, Služba Windows Media Program Service, Služba Windows Media Station Service nebo Služba Windows Media Unicast Service) a klepněte příkaz Vlastnosti.
  4. V okně Vlastnosti služby klepněte na kartu Přihlášení.

    V části Přihlásit se jako je možné změnit účet a heslo, které služba používá.

Poznámka

  • Tyto kroky je třeba provést u všech služeb Windows Media (Služba Windows Media Monitor Service, Služba Windows Media Program Service, Služba Windows Media Station Service a Služba Windows Media Unicast Service). V opačném případě se může stát, že nebude možné doručit obsah ze serveru do programu Microsoft Windows Media Player.


Použití balíčku pro ověřování

  1. V rámci s nabídkou Správce Windows Media klepněte na položku Vlastnosti serveru.

    Zobrazí se stránka Konfigurace serveru - vlastnosti serveru. Jako výchozí se zobrazuje obsah na kartě Obecné.

  2. Klepněte na kartu Zabezpečení adresáře pro publikování.
  3. V seznamu Balíčky pro ověřování vyberte požadovaný balíček.
  4. Klepněte na tlačítko Použít.

    Otevře se okno Správce Windows Media s výzvou k potvrzení použití vybraného balíčku pro ověřování.

  5. Klepněte na tlačítko Ano.

    Stav vybraného balíčku pro ověřování je nastaven na Čeká. Provedená změna se projeví až po restartování služby Windows Media Unicast Service. Než budete pokračovat, proveďte kroky uvedené v tématu Restartování služby Windows Media Unicast Service.

  6. Klepněte na tlačítko Obnovit.

    Bude obnoven rámeček s informacemi o obsahu. Údaj ve sloupci Stav vybraného balíčku pro ověřování bude nastaven na Vybráno.

Poznámka

  • Pokud je stav balíčku pro ověřování nastaven na Vybráno, je možné po zaškrtnutí políčka Povolit kontrolu seznamu řízení přístupu (ACL) použít funkci kontroly seznamu řízení přístupu. Další informace naleznete v části Omezení přístupu k datovým proudům ASF.


Restartování služby Windows Media Unicast Service

  1. Otevřete okno Ovládací panely, poklepejte na panel Nástroje pro správu a poté na panel Služby.
  2. Vyberte položku Služba Windows Media Unicast Service. Její stav je nastaven na Spuštěno.
  3. Klepnutím na tlačítko Restartovat službu zastavíte a restartujete.


Nastavení přístupových oprávnění adresářů pro publikování na požádání a oprávnění pro soubory ASF

  1. Podle postupu uvedeného v tématu Použití balíčku pro ověřování aktivujte balíček pro ověřování služby Windows Media Unicast Service.
  2. Zaškrtněte políčko Povolit kontrolu seznamu řízení přístupu (ACL).
  3. Na serveru vyhledejte adresář pro publikování nebo soubor ASF, ke kterému chcete omezit přístup. Na adresář nebo soubor klepněte pravým tlačítkem myši.

    Zobrazí se stránka Vlastnosti.

  4. Na stránce Vlastnosti klepněte na kartu Zabezpečení.

    Pro daný adresář nebo soubor bude otevřena stránka Oprávnění. Ve výchozím nastavení je úplný přístup k souboru ASF nebo k adresáři pro publikování povolen všem uživatelům.

  5. Klepnutím na tlačítko Odebrat odeberete skupinu Všichni ze seznamu Oprávnění.
  6. Chcete-li přidat do seznamu Oprávnění službu Windows Media Services, klepněte na stránce Oprávnění na tlačítko Přidat.
    • Na stránce Přidat uživatele a skupinu vyberte v poli Zobrazit názvy z požadovaný počítač se serverem a klepněte na tlačítko Zobrazit uživatele.
    • V seznamu Názvy klepněte na název účtu služby Windows Media Services a klepněte na tlačítko Přidat. Tento účet slouží pro služby Windows Media Unicast Service, Station Service, Monitor Service a Program Service a má povolen přístup pro čtení k souboru nebo adresáři pro publikování. V průběhu instalace služby Windows Media Services je vytvořen účet této služby s názvem NetShowServices. Pokud jste po instalaci zadali jiný účet služby Windows Media Services, klepněte v seznamu Názvy na název tohoto účtu.
  7. Chcete-li přidat do seznamu Oprávnění uživatele nebo skupinu uživatelů, klepněte na stránce Oprávnění na tlačítko Přidat.
    • Na stránce Přidat uživatele a skupinu vyberte doménu s uživatelem nebo skupinou uživatelů, kterým chcete povolit přístup k danému adresáři nebo souboru, a klepněte na tlačítko Zobrazit uživatele.
    • V seznamu Názvy klepněte na jméno uživatele nebo název skupiny a klepněte na tlačítko Přidat. Ve výchozím nastavení je uživateli nebo skupině povolen k adresáři nebo souboru pro publikování přístup pro čtení.

Poznámka

  • Přístupová oprávnění k obsahu uloženému v systému souborů NTFS lze nastavit pomocí přiřazení seznamu ACL souboru ASF nebo fyzickému adresáři s uloženým souborem. K obsahu na požádání uloženému v systému souborů FAT je také možné nastavit přístupová oprávnění pomocí nastavení seznamu ACL pro klíč registru spojený s příslušným adresářem pro publikování vysílání Unicast na požádání. S ohledem na fakt, že neznámé uživatele nelze autorizovat, není možné použít seznam ACL bez povolení ověřování.


Nastavení přístupových oprávnění adresářů pro publikování vysílání Unicast

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedt32.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nsunicast\Parameters\Virtual Roots

    Pro všechny adresáře pro publikování včetně adresářů pro publikování na požádání existuje virtuální kořenový adresář.

  3. Vyberte virtuální kořenový adresář, jehož oprávnění chcete nastavit.
  4. V nabídce Zabezpečení programu Editor Registru klepněte na příkaz Oprávnění.

    Otevře se dialogové okno Klíč registru - oprávnění.

  5. Vytvořte oprávnění pro příslušný adresář pro publikování vysílání.

Poznámky

  • Oprávnění můžete nastavit pro jednotlivé uživatele, skupiny nebo domény. Chcete-li získat další informace týkající se poskytování oprávnění, klepněte v dialogovém okně Klíč registru - oprávnění na tlačítko Nápověda.
  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Přidání adresy IP do seznamu pro přístup

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NetShow\AccessLists

  3. Chcete-li pracovat s některým ze seznamů pro přístup, klepněte na odpovídající klíč registru:
    • AllowDistribution
    • AllowUnicastClients
    • DisallowDistribution
    • DisallowUnicastClients
  4. V nabídce Úpravy přejděte na příkaz Nový a klepněte na položku Nová textová hodnota.
  5. Do seznamu ve sloupci Název zadejte požadovanou adresu IP a stiskněte klávesu ENTER.

Poznámky

  • Po doplnění adresy IP do seznamu pro přístup je možné zadat rozsah adres IP přidáním masky k této adrese IP.
  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Zadání rozsahu adres IP v seznamu pro přístup

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NetShow\AccessLists

  3. Chcete-li pracovat s některým ze seznamů pro přístup, klepněte na odpovídající klíč registru:
    • AllowDistribution
    • AllowUnicastClients
    • DisallowDistribution
    • DisallowUnicastClients
  4. Ve sloupci Název klepněte na příslušnou adresu IP.
  5. V nabídce Úpravy klepněte na příkaz Změnit.

    Zobrazí se dialogové okno Upravit textovou hodnotu.

  6. Do pole Údaj hodnoty zadejte hodnotu masky.

    Hodnota masky bude přidána do sloupce Data.

Poznámky

  • Stejně jako adresa IP představuje maska 32bitovou hodnotu. Při nastavování rozsahu adres odpovídá každý bit masky bitu adresy IP. V případě hodnoty 1 v masce je do seznamu zanesen odpovídající bit adresy IP. V případě hodnoty 0 v masce je přijatelná libovolná hodnota. Vyjádřeno v desítkové soustavě, pokud je například v seznamu adresa IP 134.123.123.20 a maska je 255.255.255.0, budou do seznamu přidány všechny adresy IP v rozsahu od 134.123.123.0 do 134.123.123.255. Pokud je maska 255.255.255.128, budou do seznamu přidány všechny adresy IP v rozsahu od 134.123.123.0 do 134.123.123.127. Zadání neplatné masky je ignorováno.
  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Úprava adresy IP v seznamu pro přístup

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NetShow\AccessLists

  3. Chcete-li pracovat s některým ze seznamů pro přístup, klepněte na odpovídající klíč registru:
    • AllowDistribution
    • AllowUnicastClients
    • DisallowDistribution
    • DisallowUnicastClients
  4. Ve sloupci Název klepněte na příslušnou adresu IP.
  5. V nabídce Úpravy klepněte na příkaz Přejmenovat.
  6. Ve sloupci Název upravte hodnotu a stiskněte klávesu ENTER.

Poznámka

  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Odebrání adresy IP ze seznamu pro přístup

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\NetShow\AccessLists

  3. Chcete-li pracovat s některým ze seznamů pro přístup, klepněte na odpovídající klíč registru:
    • AllowDistribution
    • AllowUnicastClients
    • DisallowDistribution
    • DisallowUnicastClients
  4. Ve sloupci Název klepněte na příslušnou adresu IP.
  5. V nabídce Úpravy klepněte na příkaz Odstranit.
  6. V dialogovém okně Potvrdit odstranění hodnoty klepněte na tlačítko Ano.

Poznámka

  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Úprava instance serveru služby Membership používané balíčkem pro ověřování databáze ověřování HTTP-BASIC a účtu služby Membership

Titulek služby Windows Media Services

Úprava instance serveru služby Membership používané balíčkem pro ověřování databáze ověřování HTTP-BASIC a účtů služby Membership

  1. Spusťte Editor registru. Klepněte na tlačítko Start, klepněte na příkaz Spustit a zadejte příkaz regedit.
  2. Přejděte v Editoru registru pomocí zobrazení stromu na následující cestu:

    HKEY_LOCAL_MACHINE\Software\Microsoft\NetShow\Servers\Default\Authentication\HTTP Basic-Membership

  3. Přidejte textovou hodnotu (reg_sz) s názvem VirtualServerInstance a datovou hodnotu odpovídající číslu instance serveru Membership.

    Chcete-li zjistit číslo instance požadovaného serveru Membership, otevřete příkazový řádek, změňte adresář na \Siteserver\bin\P&M a zadejte:

    PMAdmin list instance

  4. Do pole Údaj hodnoty u právě vytvořené hodnoty VirtualServerInstance zadejte číslo přidružené instanci požadovaného serveru Membership.

Poznámka

  • Možnost provádět změny v registru pomocí Editoru registru závisí na nastavených přístupových oprávněních. Nesprávné úpravy registru mohou systém vážně poškodit. Před provedením změn v registru je třeba zálohovat všechna důležitá data uložená v počítači.


Správa účtu služeb Windows Media Component Services

Součásti Windows Media Server Components se skládají ze služeb Windows Media Component Services (Služba Windows Media Monitor Service, Služba Windows Media Program Service, Služba Windows Media Station Service a Služba Windows Media Unicast Service) a Správce Windows Media.

Pokud jsou součásti Windows Media Components nainstalovány tak, aby byly při spuštění serveru Windows Media přihlášeny k systému, použijí služby Windows Media Component Services vytvořený uživatelský účet serveru Windows 2000 Server. Jako výchozí je při instalaci vytvořen uživatelský účet NetShowServices. Tento uživatelský účet je přidán do skupin NetShow Administrators a Administrators a jsou mu pro server Windows Media přidělena oprávnění správce.

Pokud účet používaný službami Windows Media Component Services není na úrovni účtu správce, nelze pomocí součástí Windows Media Server Components vysílat soubory ve formě datového proudu. U tohoto účtu musí být k adresáři pro publikování (pokud není umístěn na jednotce disku ve stejném počítači), sdíleným síťovým prostředkům a vzdálenému umístění povolena přístupová práva alespoň na úrovni čtení. V opačném případě nebude možné z tohoto umístění načíst pro vysílání obsah ve formátu ASF.

Poznámka

  • Vytvořenému výchozímu uživatelskému účtu NetShowServices a všem službám Windows Media Component Services je přiřazeno náhodně vygenerované heslo. Pokud změníte heslo účtu, je nutné změnit také hesla pro služby Windows Media Component Services. V opačném případě se přihlášení a provedení operací služeb nezdaří. Používáte-li pro služby Windows Media Component Services účet v doméně, je třeba změnit heslo pro jednotlivé služby Windows Media Component Services na všech počítačích s nainstalovanými součástmi Windows Media Server Components. Další informace naleznete v tématu Změna účtu a hesla používaných službami Windows Media Component Services.


Správa účtu služeb Windows Media Component Services v prostředí s více servery

Při instalaci součástí Windows Media Server Components v prostředí s více servery je v místní databázi účtů každého serveru vytvořena skupina NetShow Administrators. Tím je zajištěna jedinečnost účtu pro daný server. Přihlášení služeb Windows Media Component Services probíhá na jednotlivých serverech pomocí práv přiřazených na základě členství v této skupině.

I v případě, že použijete výchozí účet NetShowServices a změníte heslo pro služby Windows Media Component Services na každém serveru tak, aby bylo shodné, nebudou moci jednotlivé místní služby Windows Media Component Services spolupracovat se službami na jiném serveru, protože účet pro tyto služby není členem skupiny NetShow Administrators nebo Administrators na vzdáleném serveru. Z tohoto důvodu je nezbytné použít pro služby Windows Media Component Services účet v doméně přidaný na všech serverech do skupiny NetShow Administrators. V prostředí s více servery můžete také místní účet používaný službami Windows Media Component Services přidat na všech serverech do skupiny NetShow Administrators nebo Administrators.

Pro ukládání obsahu vysílání Unicast na požádání na vzdálené servery je třeba použít účet domény. U služby Windows Media Unicast Service je nezbytné povolit přístupová práva k adresáři zadanému jako umístění pro publikování alespoň na úrovni čtení. Účet domény používaný pro jednotlivé služby Windows Media Component Services musí být také členem místní skupiny na serveru s uloženým obsahem pro vysílání datového proudu na požádání, nebo je třeba u tohoto účtu povolit přístupová práva na úrovni sdílení.


Správa součástí Windows Media Server Components

Správce Windows Media je nainstalován spolu se službou Windows Media Services. Tohoto správce je možné spustit v operačních systémech Microsoft Windows 2000 Server nebo Microsoft Windows 2000 Professional. Server Windows Media mohou spravovat uživatelé, kteří mají v počítači s nainstalovanými součástmi Windows Media Server Components přiděleno oprávnění správce.


Místní správa součástí Windows Media Server Components

Pokud hodláte spravovat součásti Windows Media Server Components pomocí počítače, ve kterém jsou tyto součásti nainstalovány, doporučujeme přidat použitý účet do skupiny Administrator nebo Power Users (v systému Windows 2000) v tomto počítači. Uživatelé, kterým jsou přidělena tato práva, mohou spustit Správce Windows Media a libovolným způsobem konfigurovat součásti Windows Media Server Components.

Místní přihlášení pomocí místního účtu neumožňuje přístup k žádným síťovým prostředkům. Je možné pouze vytvářet adresář pro publikování, který odkazuje na adresář nacházející se v paměťovém zařízení spravovaném z místního počítače. Skupina NetShow Administrators nezajišťuje oprávnění na úrovni systému souborů. Z tohoto důvodu je třeba mít také práva k vytváření adresářů a k ukládání souborů na diskovou jednotku daného počítače.


Vzdálená správa součástí Windows Media Server Components

Pokud je server Windows Media součástí určité domény, mohou se uživatelé pomocí uživatelského účtu v této doméně přihlásit k libovolnému počítači v doméně (nebo v plně důvěryhodné doméně) a spravovat služby Windows Media Component Services. Ve vzdáleném počítači musí být nainstalován Správce Windows Media. Uživatelský účet v doméně musí být členem místní skupiny na serveru Windows Media, které jsou pro služby Windows Media Component Services přidělena oprávnění správce. Dostatečná práva ke správě služeb Windows Media Component Services poskytují skupiny NetShow Administrators a Administrators. K vytvoření uživatelského účtu v doméně, pomocí kterého lze spravovat služby Windows Media Components Services, je třeba oprávnění na úrovni správce domény.

Pro správu služeb Windows Media Component Services můžete také vytvořit účet skupiny v doméně a přidat tuto skupinu do místní skupiny NetShow Administrators. Činnosti spojené se správou služeb technologie Windows Media lze provádět místně i vzdáleně pomocí přihlášení k doméně prostřednictvím účtu, který je součástí skupiny v doméně patřící do místní skupiny NetShow Administrators.

Zařazení účtu uživatele nebo skupiny v doméně do skupiny NetShow Administrators neposkytuje uživateli možnost úplného řízení serveru Windows Media. Skupina NetShow Administrators pouze zajišťuje oprávnění potřebná pro úlohy služeb Windows Media Services, mezi něž patří například vytváření adresářů pro publikování vysílání Unicast na požádání, povolení nebo zákaz balíčků pro ověřování, správa stanic a další. Uživatelé domény bez oprávnění k zápisu do fyzického adresáře v daném počítači nemohou vytvářet adresáře pro publikování.

Server Windows Media lze spravovat ze vzdáleného počítače i v případě, že tento server nebo vzdálený počítač nejsou součástí domény systému Microsoft Windows. Chcete-li spravovat služby Windows Media Component Services ze vzdáleného počítače, je třeba ve vzdáleném počítači vytvořit účet a heslo, které se budou shodovat s účtem na serveru Windows Media. Musí být také zajištěn přístup k serveru Windows Media (chcete-li například server spravovat vzdáleně prostřednictvím sítě Internet, musí být oba počítače k této síti připojeny). Do vzdáleného počítače je třeba nainstalovat součásti pro správu služby Windows Media Services a připojit tento počítač prostřednictvím adresy IP serveru Windows Media k serveru s nainstalovanými součástmi Windows Media Server Components.


Vzdálená správa služeb Windows Media Component Services pomocí modelu DCOM

Ke vzdálené správě služeb Windows Media Component Services lze použít model DCOM (Distributed Component Object Model). Chcete-li používat model DCOM ke vzdálené správě přes bezpečnostní bránu firewall, je třeba v bráně firewall povolit porty umožňující průchod paketů modelu DCOM. Vzhledem k počtu portů, které model DCOM vyžaduje, nedoporučujeme vzdálenou správu přes bezpečnostní bránu firewall používat.

K úspěšné vzdálené správě je třeba na serveru s nainstalovanou bezpečnostní bránou firewall otevřít porty, které model DCOM používá. Jestliže máte s vysíláním informací přes bezpečnostní bránu firewall potíže, je možné v bráně firewall otevřít jiné porty. Potřebujete-li zjistit, zda je nutné pro vzdálenou správu součástí Windows Media Server Components pomocí modelu DCOM bezpečnostní bránu firewall určitým způsobem nastavit, obraťte se na dodavatele brány firewall. Model DCOM vyžaduje, aby byly pro komunikaci se službami Windows Media Component Services otevřeny všechny porty v rozsahu od 1024 do 5000 a port 135 pro mapování koncových bodů vzdáleného volání procedur (RPC).

Předpokladem použití modelu DCOM pro vzdálenou správu služeb Windows Media Component Services je zajištění přístupu počítače vně bezpečnostní brány firewall k počítači uvnitř brány pomocí jeho skutečné adresy IP. Možnost převodu adres a využívání proxy serveru podporována není.


Omezení přístupu k datovým proudům ASF

Přístup k uloženému souboru ASF vysílanému na požádání lze omezit pomocí konfigurace služby Windows Media Services tak, že bude před vysíláním souboru vyžadováno ověřování uživatelů. Služba Windows Media Services také používá v systému Windows 2000 Server k nastavení přístupových oprávnění k jednotlivým souborům ASF uloženým v adresářích pro publikování kontinuálního vysílání Unicast a pro publikování vysílání Unicast na požádání.kontrolu seznamu řízení přístupu (ACL). Přístup k živě vysílaným datovým proudům z adresáře pro publikování vysílání Unicast je možné omezit použitím přístupových oprávnění ke klíči registru spojeného s příslušným adresářem pro publikování. Přiřazením seznamu ACL k odpovídajícímu souboru NSC uloženému na serveru WWW lze omezit přístup ke stanicím Windows Media.

Pravděpodobně nejjednodušší způsob řízení přístupu k datovým proudům ASF představuje zamezení přístupu klientským a serverovým připojením k serveru Windows Media. Připojení klientů a serveru k serveru Windows Media lze řídit na základě adres IP klienta či serveru pokoušejících se o připojení.


Nastavení zabezpečení adresáře pro publikování vysílání Unicast

Služby Windows Media Component Services mohou před povolením přístupu k určitému datovému proudu vyžadovat ověření klientů. Ve výchozím nastavení při instalaci služeb Windows Media Component Services ověřování zapnuto není. Pro vysílání Unicast na požádání však můžete aktivovat jeden ze tří balíčků pro ověřování nainstalovaných se Správcem Windows Media.

  • Databáze ověřování HTTP-BASIC a účtů služby Membership
  • Databáze ověřování HTTP-BASIC a účtů NTLM
  • Databáze účtů a ověřování systému LAN Manager v systému Microsoft Windows NT

Ověřování HTTP-BASIC poskytuje standardní způsob ověření uživatelů HTTP pomocí kódovaných textových hesel a uživatelských jmen. Chcete-li přehrát obsah ve formátu ASF z adresáře pro publikování, je třeba v klientovi zadat uživatelské jméno a heslo. Ověřování HTTP-BASIC je ideální způsob pro aplikace využívající síť Internet.

Ověřování NTLM používá k ověření uživatele přihlášeného ke klientskému počítači schéma šifrované výzvy a odpovědi. Ověřování na základě výzvy a odpovědi je provedeno bez převodu pověření uživatelů. Z tohoto důvodu nemá server Windows Media přístup k uživatelskému jménu a heslu. Pro ověřování na základě výzvy a odpovědi jsou použity informace o přihlášení uživatele, klient i server proto musí být součástí stejné nebo důvěryhodné domény. Tento způsob ověřování je určen především pro aplikace v sítích intranet.

Jednomu klientovi může být současně přiřazen pouze jeden způsob ověřování, proto je třeba způsob ověřování určit ještě před pokusem o ověření klienta.

Jako součást zabezpečení adresářů pro publikování vysílání Unicast můžete pro všechny balíčky pro ověřování povolit kontrolu seznamu řízení přístupu (ACL). S ohledem na fakt, že neznámé uživatele nelze autorizovat, není možné použít seznam ACL bez povolení ověřování. Do seznamu ACL bude pravděpodobně třeba přidat také účet používaný službou Windows Media Services. Další informace týkající se kontroly seznamu ACL najdete v tématu Použití kontroly seznamu řízení přístupu (ACL).


Použití databáze ověřování HTTP-BASIC a účtu služby Membership

Titulek služby Windows Media Services

Použití databáze ověřování HTTP-BASIC a účtů služby Membership

Pokud je aktivován tento balíček, je ověření klienta provedeno pomocí kontroly pověření klienta vůči uživatelským účtům uloženým v databázi služby Microsoft Membership. Služba Microsoft Membership musí být nainstalována na serveru a spuštěna. V opačném případě se načtení balíčku pro ověřování nezdaří. Pokud používáte balíček pro ověřování Databáze ověřování HTTP-BASIC a účtů služby Membership, není možné nakonfigurovat službu Membership tak, aby prováděla ověřování uživatelů pomocí databáze účtů systému LAN Manager v systému Microsoft Windows NT.

Poznámka

  • Pokud je pro ověřování použit balíček Databáze ověřování HTTP-BASIC a účtů služby Membership, je ve výchozím nastavení použita druhá instance virtuálního serveru služby Membership. Z tohoto důvodu je třeba vytvořit druhou instanci virtuálního serveru nebo upravit klíč registru instance virtuálního serveru tak, aby byla použita první instance virtuálního serveru. K ověřování pomocí databáze služby Membership v síti Internet je třeba použít jinou než místní databázi systému LAN Manager v systému Microsoft Windows NT, protože uživatelé sítě Internet nemají v doméně v daném počítači vytvořen účet. Další informace naleznete v tématu Úprava instance serveru služby Membership používané balíčkem pro ověřování databáze ověřování HTTP-BASIC a účtů služby Membership.


Použití databáze ověřování HTTP-BASIC a účtu NTLM

Titulek služby Windows Media Services

Použití databáze ověřování HTTP-BASIC a účtů NTLM

Je-li aktivován tento balíček pro ověřování, hledá server Windows Media informace o uživatelském účtu v místním počítači. Chcete-li kontrolovat jinou doménu, musí být tato doména zadána. Je třeba například zadat uživatelské jméno v podobě doména\uživatelské_jméno, kde doména je nová doména, kterou chcete kontrolovat, a uživatelské_jméno představuje uživatelské jméno v této doméně.


Použití kontroly seznamu řízení přístupů (ACL)

Pomocí kontroly seznamu řízení přístupů (ACL) lze nastavit omezení oprávnění přístupu k jednotlivým souborům ASF a k adresářům. Přiřazením seznamu ACL k adresáři s uloženými soubory je možné omezit přístup k více souborům najednou. Seznam ACL pro uložený obsah lze v systému souborů NTFS nastavit přiřazením seznamu ACL souboru ASF nebo fyzickému adresáři, ve kterém je příslušný soubor uložen. Seznam ACL pro obsah na požádání uložený v systému souborů FAT je možné také nastavit, a to pomocí nastavení seznamu ACL pro klíč registru spojený s příslušným adresářem pro publikování vysílání Unicast na požádání. S ohledem na fakt, že neznámé uživatele nelze autorizovat, není možné použít seznam ACL bez povolení ověřování.

Poznámka

  • Pokud je zdroj adresáře pro publikování vysílání Unicast živě vysílaný datový proud, není obsah nikdy uložen na fyzickém paměťovém zařízení. Neuloženému souboru nelze přiřadit seznam ACL. Chcete-li omezit přístup k datovému proudu vysílání Unicast, je třeba v Editoru registru nastavit přístupová oprávnění ke klíči registru spojenému s daným adresářem pro publikování vysílání Unicast. Přiřazením seznamu ACL souboru NSC uloženému na serveru WWW lze také omezit přístup ke stanicím Windows Media.


Omezení připojení k serveru Windows Media pomocí seznamu pro přístup

Připojení klientů a serveru k součástem Windows Media Server Components lze řídit na základě adres IP klienta či serveru pokoušejících se o připojení. Tímto způsobem je možné při vysílání Multicast distribuovat vlastní obsah ve formě datového proudu na vybrané servery. Připojení je řízeno pomocí seznamu povolených adres IP vytvořeného v klíči registru seznamu pro přístup serveru Microsoft Windows Server.

Následující klíče registru seznamu pro přístup řídí přístup k serveru Windows Media. Ve výchozím nastavení jsou povolena všechna připojení.

Klíč registru | Popis
AllowDistribution | Počítače se servery používající adresy IP z tohoto seznamu se mohou připojit k serveru Windows Media a k programu Windows Media Encoder. Klientské počítače používající adresy IP z tohoto seznamu mohou prostřednictvím programu Windows Media Encoder a serveru Windows Media přijímat vysílaný datový proud. Pokud v seznamu neexistuje žádná adresa IP, mohou se připojit všechny počítače, pokud se jejich adresa nenachází v seznamu DisallowDistribution.
AllowUnicastClients | Klientské počítače používající adresy IP z tohoto seznamu mohou prostřednictvím serveru Windows Media přijímat vysílání Unicast. Pokud v seznamu neexistuje žádná adresa IP, mohou se připojit všichni klienti, pokud se jejich adresa nenachází v seznamu DisallowUnicastClients.
DisallowDistribution | Počítače se servery používající adresy IP z tohoto seznamu se nemohou připojit ani k serveru Windows Media ani k programu Windows Media Encoder. Klientské počítače používající adresy IP z tohoto seznamu nemohou prostřednictvím programu Windows Media Encoder a serveru Windows Media přijímat vysílaný datový proud.
DisallowUnicastClients | Klientské počítače používající adresy IP z tohoto seznamu nemohou prostřednictvím serveru Windows Media přijímat vysílání Unicast. Pokud se adresa současně nachází v obou seznamech (DisallowUnicastClients i AllowUnicastClients), není připojení povoleno.


Přehled ověřování součástí Windows Media Server Components

Pomocí konfigurace serveru je možné autorizaci implementovat ve formě služby nebo prostřednictvím součástí modulu plug-in. Přidělení těchto činností vyhrazeným součástem modulu plug-in umožňuje poskytovatelům služeb zajistit vyšší flexibilitu při implementaci různých ověřovacích schémat a vyhovět tak různým komerčním potřebám. Součást modulu plug-in zodpovídá za dodržování obchodní politiky a za reakci na oznámení událostí. Součásti Windows Media Server Components podporují neomezený počet současně spuštěných součástí modulu plug-in. Každá součást může určovat jedinečnou sadu událostí pro oznámení a autorizaci.

Další informace týkající se součástí pro vlastní autorizaci naleznete v sadě Windows Media Technologies Software Development Kit (SDK) na stránce Windows Media Technologies na serveru WWW společnosti Microsoft.


Autorizace klientů Windows Media

Program Windows Media Player lze autorizovat na základě čísla identifikátoru GUID (globálně jedinečný identifikátor). Toto číslo je jedinečné pro každý počítač s nainstalovaným programem Windows Media Player.

Další informace týkající se použití autorizace klientů naleznete v sadě Windows Media Technologies Software Development Kit (SDK) na stránce Windows Media Technologies na serveru WWW společnosti Microsoft.


Vytvoření ověřování distribuce

K zajištění bezpečné komunikace mezi servery Windows Media existuje ve Správci Windows Media na stránce Vlastnosti serveru karta Ověřování distribuce, na které je možné pomocí nastavení proxy serveru povolit ověřování serveru. Jestliže při pokusu o distribuci datového proudu vysílání Unicast z jednoho serveru Windows Media na jiný vyžaduje připojení proxy server, můžete doplněním následujících informací zajistit průchod kontrolou proxy serveru:

  • Proxy server. Ke kontrole informací musí být použit tento server.
  • ID uživatele. Účet nebo název, pro který jsou v databázi uloženy informace.
  • Heslo. Informace, které je nutné zadat pro ověření platnosti ID uživatele.


Kodeky Windows Media

Nástroje pro vytváření obsahu ve formátu ASF používají kompresní a dekompresní algoritmy (kodeky) ke komprimaci zvukových a obrazových médií z živých zdrojů nebo dalších formátů médií tak, aby tato média vyhovovala určité dostupné šířce pásma sítě. Program Microsoft Windows Media Player poté použije před přehráním k dekompresi informací ve formátu ASF stejný kodek. Pro zvukovou a obrazovou část datového proudu ASF jsou použity samostatné kodeky.

Kodeky jsou vytvořeny ke komprimaci zdrojových souborů pro určitou přenosovou rychlost. Z tohoto důvodu nelze některé kodeky použít ke komprimaci souboru do konkrétní velikosti. Rozdíl v kompresním poměru způsobuje rozdíl v kvalitě přehrávání. Kodeky, které komprimují zdrojové soubory v menší míře, poskytují obvykle plnější zvuk, lepší vzhled a větší dynamičnost.

Program Windows Media Encoder může použít všechny kodeky nainstalované v daném počítači za předpokladu, že také počítač s nainstalovaným programem Windows Media Player obsahuje příslušné kodeky sloužící k přehrání souboru ASF nebo datového proudu ve formátu ASF. Program Windows Media Encoder neobsahuje stejný počet kodeků jako program Windows Media Player.


Kodeky nainstalované s programem Windows Media Encoder

Program Windows Media Encoder nainstaluje do počítače několik zvukových kodeků a videokodeků. Kodeky jsou také instalovány jako součást operačního systému a někdy jsou přidány při stahování souborů ze sítě Internet. Program Windows Media Encoder může ke kódování obsahu ve formátu ASF použít libovolný kodek nainstalovaný v počítači za předpokladu, že je programu Microsoft Windows Media Player umožněno pro dekódování daného obsahu použití stejného kodeku. Chcete-li zajistit dekódování obsahu programem Windows Media Player, zvolte kodeky nainstalované spolu s programem Windows Media Encoder.


Přehled zvukových kodeků

S programem Windows Media Encoder jsou nainstalovány následující kodeky. Z důvodu obvykle nejlepší zvukové kvality souborů obsahujících různé typy médií a hudební obsah doporučujeme pro většinu obsahů použít kodek Windows Media Audio. Pokud však chcete vytvořit datový proud s nízkou šířkou pásma (menší než 20 kb/s) se zvukovým obsahem výhradně v podobě hlasu, dosáhnete pravděpodobně lepších výsledků s použitím kodeku ACELP.net společnosti Sipro Labs.

Kodek | Popis
Windows Media Audio verze 2 Kodek Windows Media Audio je vysoce přizpůsobivý kodek, který poskytuje zvukový obsah ve výborné mono i stereo kvalitě v širokém rozsahu šířek pásma. Tento kodek lze použít ke kódování zvukového obsahu vysílaného v šířce pásma v rozsahu od 5 kb/s až po 160 kb/s. Vzorkovací frekvence zvuku se pohybuje v rozmezí od 8 kHz až po 48 kHz, což umožňuje zvolit při vytváření obsahu nejvhodnější kombinaci šířky pásma a vzorkovací frekvence.

Vzhledem k velké odolnosti vůči ztrátě kvality je tento kodek velmi vhodný pro vysílání obsahu ve formě datového proudu. Z důvodu vynikající čistoty zvuku a hloubky tónů poskytuje tento kodek ve srovnání s jinými kodeky lepší kvalitu hudebního obsahu.

Kodek lze také použít k odstranění zvukové stopy z obsahu pomocí formátu zvuku 0 kb/s. Vytváříte-li zvukové soubory určené ke stažení, je kodek Windows Media Audio vhodnou volbou. Poskytuje zvuk blížící se kvalitě CD a potřebuje přitom o polovinu nižší přenosovou rychlost něž většina ostatních kodeků.

Windows Media Audio verze 1 | Tento kodek je také znám pod názvem MSAudio. Podporuje přehrávání existujícího obsahu, nelze jej však použít ke kódování obsahu.
FhG MPEG Layer-3 | Kodek MPEG (Moving Picture Experts Group) Layer-3 vytvořený společností FhG je zvukový kodek hi-fi mono vhodný zejména pro dosažení zvuku v kvalitě CD v sítích intranet a Internet. Kodek MPEG Layer-3 poskytuje několik formátů, ze kterých je možné vybrat v závislosti na zvolené šířce pásma sítě.
Sipro ACELP.net | Kodek ACELP je kodek určený pro nízkou přenosovou rychlost poskytující vynikající kompresi hlasu. Kodek ACELP obsahuje několik formátů, ze kterých je možné vybrat v závislosti na zvolené šířce pásma sítě.
Voxware | Kodek Voxware poskytuje vysokou kvalitu zvuku při použití nízkých a středních přenosových rychlostí. Součástí tohoto kodeku je mnoho formátů mono a stereo zvuku, ze kterých je možné vybrat v závislosti na šířce pásma sítě. Je také vhodný ke kódování zvuku mono obsahujícího pouze hlas pro extrémně nízké přenosové rychlosti.


Přehled videokodeků

S programem Windows Media Encoder jsou nainstalovány následující videokodeky. Pokud je to možné, používejte pro kódování obsahu videa kodek Microsoft MPEG-4 Video Codec verze 3.

Kodek | Popis
Microsoft MPEG-4 Video Codec verze 1 | Kodek Microsoft MPEG-4 slouží ke kódování videa pro přenosové rychlosti v rozsahu od nízké až po vysokou rychlost. Tento kodek vyhovuje zavedeným standardům formátu MPEG (Moving Picture Experts Group). Pokud poskytujete obsah serverům nebo přehrávačům verze 2.0, použijte kodek verze 1.
Microsoft MPEG-4 Video Codec verze 2 | Kodek Microsoft MPEG-4 slouží ke kódování videa pro přenosové rychlosti v rozsahu od nízké až po vysokou rychlost. Verze 2 tohoto kodeku je poskytována z důvodu zajištění kompatibility s konfiguracemi obsahu a kodéru vytvořenými pomocí nástrojů Windows Media verze 3.0.
Microsoft MPEG-4 Video Codec verze 3 | Kodek Microsoft MPEG-4 je vysoce přizpůsobivý videokodek podporující široký rozsah šířek pásma sítě. Nejnovější verze videokodeku Microsoft MPEG-4 je optimalizována pro použití s procesory Intel Pentium III. Použití tohoto kodeku umožňuje rychlejší kódování obsahu na požádání a kódování živého obsahu pro vyšší přenosové rychlosti, vyšší rozlišení a vyšší rychlost zobrazování snímků. I v případě použití s procesorem Intel Pentium II poskytne kodek při kódování videa mnohem vyšší výkon. Verze 3 rovněž podporuje více šířek pásma a kódování pro vysoké šířky pásma. Součástí kodeku je také antiblokační filtr videa, který kvalitu obsahu videa zlepší odstraněním blokování způsobeného kompresí videa, a to především u nízkých přenosových rychlostí (například 28,8 kb/s).
Microsoft H.263 | Kodek H.263 je vhodný pro nízké a střední přenosové rychlosti videa. Tento kodek je optimalizován pro videokonference. Z tohoto důvodu je vhodné jej použít pro prezentace a pomalu se měnící obsah videa.


Kodeky nainstalované s programem Windows Media Player

Existují dva typy instalace programu Microsoft Windows Media Player: rozšířená a základní. Rozšířená instalace obsahuje všechny kodeky, ke kterým je společnost Microsoft oprávněna udělovat licence. Při tomto způsobu instalace však program zabere na disku značné množství místa a stažení souborů zabere relativně dlouhou dobu. Součástí základní instalace je pouze minimální sada kodeků. Tuto instalaci je možné provést mnohem rychleji. V následující části je uveden seznam kodeků, které jsou součástí jednotlivých instalací. Pokud si nejste jisti, zda je v klientském počítači nainstalován kodek potřebný k vykreslení souboru ASF nebo datového proudu ve formátu ASF, je možné použít atribut značky jazyka HTML <CODEBASE> pro ovládací prvky Microsoft ActiveX. Pomocí této značky zajistíte, že stránka WWW ověří, zda klientský počítač obsahuje kodeky potřebné k přehrání souboru ASF nebo datového proudu ve formátu ASF.


Rozšiřující kodeky programu Windows Media Player

Následující kodeky jsou nainstalovány jako součást rozšířené instalace programu Microsoft Windows Media Player:

  • videokodeky Microsoft MPEG-4 verze 1, verze 2 a verze 3,
  • zvukový kodek FhG MPEG Layer-3,
  • zvukový kodek Voxware,
  • kodeky Windows Media Audio verze 1 a verze 2,
  • kodek Sipro ACELP.net.


Základní kodeky programu Windows Media Player

Následující kodeky jsou na instalovány jako součást základní instalace programu Microsoft Windows Media Player:

  • zvukový kodek Voxware,
  • zvukový kodek FhG MPEG Layer-3,
  • kodeky Windows Media Audio verze 1 a verze 2,
  • videokodek Microsoft MPEG-4.


Program Windows Media Encoder

Program Windows Media Encoder umožňuje kódovat živý nebo uložený zvuk i video do datového proudu ASF nebo souboru ASF. Můžete také vybrat obě možnosti. Program Windows Media Encoder je možné použít v těchto případech:

  • kódování živého zdroje,
  • komprimace živého nebo uloženého zdroje videa, kdy je třeba, aby výsledný datový proud ASF nebo soubor ASF odpovídal cílové šířce pásma,
  • vytvoření obsahu vyhovujícího několika cílovým šířkám pásma,
  • převod obsahu ze souboru AVI, MP3 nebo WAV při potřebě použití jiného kodeku nebo změně velikosti zobrazení videa.

Poznámka

  • Tato dokumentace poskytuje přehled o možnostech vytváření obsahu ASF pomocí programu Windows Media Encoder. Potřebujete-li zobrazit podrobnější nápovědu včetně postupů, spusťte program Windows Media Encoder a v nabídce Nápověda klepněte na příkaz Obsah.


Obecné informace

Program Windows Media Encoder slouží k vytvoření zvukového a obrazového obsahu ve formátu ASF, který lze vysílat prostřednictvím počítačové sítě. Obsah zpracovaný technologií Windows Media může existovat v podobě živě vysílaného datového proudu nebo v podobě uloženého souboru ASF.

Soubor ASF je možné vytvořit z uložených médií, například zvukových souborů nebo souborů s obrázky či videozáznamy, nebo z živě vysílaných datových proudů. Vytvořený soubor ASF lze upravit pomocí nástroje příkazového řádku ASFChop.

V této části jsou vysvětleny základní obecné pojmy týkající se vytváření obsahu pomocí technologie Windows Media. Předběžný proces přípravy a úpravy souborů pro multimédia zde popsán není.


Datové proudy ASF

Nástroj Windows Media Encoder přijímá zdrojové informace v živé nebo uložené podobě a převádí je na obsah ve formátu Windows Media, který lze vysílat ve formě datového proudu ze serveru Windows Media. Zdroji živých informací se rozumí vše, co lze připojit ke zvukové nebo grafické kartě, včetně přehrávače CD, mikrofonu, videorekordéru nebo videokamery. Zdroje uložených informací zahrnují soubory s videozáznamy a obrázky a zvukové soubory. Médium převedené do formátu ASF je možné doručit na server Windows Media a odtud jej vysílat v podobě datového proudu. Datový proud ASF je možné také uložit jako soubor ASF.


Soubory ASF

Soubor ASF je soubor proudu multimediálních dat upravený na dostupnou šířku pásma sítě.

Soubory ASF můžete vytvořit z různých zdrojů, například:

  • Videozáznamu. Soubory MOV nebo AVI.
  • Obrázků. Obrázky ve formátu BMP, DIB, RLE, JPG nebo GIF.
  • Zvukových záznamů. Soubory WAV nebo MP3 používající kodek ACM. Jedná se o zvukové soubory, které lze přehrát pomocí počítače (operační systémy Microsoft Windows obsahují několik kodeků ACM).
  • Prezentace aplikace Microsoft PowerPoint. V závislosti na používané verzi aplikace PowerPoint můžete uložit prezentaci jako soubor ASF nebo uložit snímky aplikace PowerPoint v podobě obrázků ve formátu JPG. Tyto obrázky pak můžete pomocí programu Windows Media Author začlenit do souboru ASF.
  • Živých zvukových a video záznamů. Pomocí programu Windows Media Encoder můžete libovolnou živou událost zachycenou mikrofonem nebo videokamerou převést do podoby souboru ASF.


Vysílání obsahu Windows Media ve formě datového proudu

Obsah ASF je navržen tak, aby jej bylo možné vysílat ve formě datového proudu ze serveru Windows Media klientům představovaným programem Windows Media Player. Server Windows Media a klienta Windows Media Player lze použít v síti Internet nebo intranet a lze je od sebe oddělit bezpečnostní bránou firewall. Je vhodné, aby tvůrce obsahu nejprve zvážil velikost šířky pásma sítě dostupné pro doručování obsahu.

V souvislosti s vysíláním obsahu technologií Windows Media ve formě datového proudu vyjadřují výrazy šířka pásma a přenosová rychlost v podstatě totéž. Výraz šířka pásma se často používá k popisu velikosti sítě a výraz přenosová rychlost k označení rychlosti, s jakou je obsah zpracovaný technologií Windows Media doručen. Obsah určený k vysílání ve formě datového proudu v síti se šířkou pásma 28,8 kb/s (kilobitů za sekundu) nelze vysílat vyšší rychlostí než 28,8 kb/s. To znamená, že každou sekundu může přes síť projít pouze 28 800 bitů informací. Obsah vysílaný jako datový proud určený pro vyšší šířku pásma, než jakou síťové spojení podporuje, nebude doručen.

Na rozdíl od sítě Internet je možné v sítích intranet zpracovat obsah vysílaný mnohem vyšší přenosovou rychlostí. V prostředí sítě intranet jsou omezení týkající se dostupné šířky pásma pro vysílání obsahu ve formě datového proudu dána správcem sítě nebo šířkou pásma sítě. Správce sítě může pomocí nastavení serveru Windows Media omezit množství informací, které server vysílá jako datový proud. Tímto způsobem lze v době vysokého zatížení zabránit serveru ve vysílání velkého množství informací, které by zpomalily celkový tok dat v síti. Pokud správce sítě nenastaví limitující množství informací vysílaných ze serveru Windows Media ve formě datového proudu, stává se omezujícím faktorem pro doručování obsahu šířka pásma sítě.


Šířka pásma

Před vytvořením obsahu ASF ověřte maximální povolenou šířku pásma na serveru.

Jakmile znáte maximální šířku pásma pro obsah Windows Media, můžete začít se zpracováním obsahu. Zdrojové soubory obsahu Windows Media vytvořeného pomocí jiných nástrojů než Windows Media Encoder a Windows Media Author není třeba upravovat pro konkrétní šířku pásma. Nástroje příkazového řádku Windows Media, WavToASF a VidToASF, převedou zdrojové soubory přímo do formátu ASF. U obsahu Windows Media vytvořeného z jiného typu souboru jsou ponechány požadavky na šířku pásma původního zdroje.

Chcete-li rychle zjistit šířku pásma, kterou obsah vyžaduje, přehrajte jej pomocí programu Microsoft Windows Media Player. V průběhu přehrávání souboru klepněte v nabídce Zobrazit na příkaz Statistika. V dialogovém okně se ve skupinovém rámečku Síť nachází položka Šířka pásma. Hodnota zobrazená v poli uvádí, kolik kilobitů za sekundu (kb/s) je třeba k vysílání obsahu ve formě datového proudu. Snížit velikost šířky pásma vyžadované souborem ASF lze mnoha způsoby, například pomocí úpravy zdrojových souborů nebo pomocí komprimace zdrojových souborů za použití kodeků.

Pokud vytváříte obsah pomocí nástroje sledujícího použitou šířku pásma, vyhradí tento nástroj automaticky část šířky pásma pro ostatní typy přenosu dat v síti. Jestliže například nastavíte cílovou šířku pásma na 28,8 kb/s, je možné ve skutečnosti použít šířku přibližně 22 kb/s. Používáte-li nástroj, u kterého je třeba neustále sledovat přenosovou rychlost obsahu, je nezbytné sledovat množství informací na základě skutečné přenosové rychlosti vyžadované k doručení obsahu.


Umístění souboru ASF na server Windows Media

Titulek služby Windows Media Services

Umístění souborů ASF na server Windows Media

Chcete-li vytvořené soubory ASF vysílat ve formě datového proudu, je třeba je umístit na server Windows Media nebo server HTTP. Doporučujeme umístit tyto soubory na server Windows Media, protože pouze zde lze využít všech funkcí poskytovaných formátem ASF. Ze serveru HTTP je možné soubory ASF také vysílat, nelze však duplikovat všechny funkce serveru Windows Media.

Chcete-li vytvořit na stránce WWW odkazy na soubory ASF, doporučujeme umístit tyto soubory do adresáře s obsahem na serveru Windows Media. Výchozí adresář s obsahem na serveru Windows Media je například Systémová_jednotka\ASFRoot. Jakmile server Windows Media obdrží požadavek, vyhledá v adresáři s obsahem soubor ASF určený k vysílání ve formě datového proudu. Chcete-li zjistit, který adresář na serveru Windows Media slouží pro obsah, otevřete Správce Windows Media a klepněte na položku Adresáře pro publikování vysílání Unicast. Cesta k adresáři obsahu je uvedena u položky domovského adresáře pro publikování <Home>.


Umístění souborů ASF na server WWW

Pokud máte k dispozici server WWW, který chcete použít k šíření obsahu ve formě datového proudu ASF, můžete umístit soubory ASF do adresáře v síti WWW, vytvořit na ně odkaz ze stránky WWW a pomocí protokolu HTTP vysílat obsah uživatelům. Při tomto způsobu je vysílání datového proudu řízeno serverem WWW a instalace služby Windows Media Services ani systému Windows NT není nutná. Při vysílání souborů ASF ve formě datového proudu ze serveru WWW je třeba mít na paměti následující omezení:

  • Na serverech WWW nelze použít více přenosových rychlostí videa a inteligentní vysílání datového proudu k průběžné změně šířky pásma, která je k dispozici klientům.
  • Obsah je nutné kódovat pomocí jediného datového proudu videa, například šablon formátu datového proudu (TSF) serveru WWW nebo vlastní konfigurace.
  • Obsah vysílaný ve formě datového proudu pomocí protokolu HTTP nedisponuje stejnými možnostmi opravy chyb vzniklých při vysílání. Použijete-li tuto metodu, bude mít stejný datový proud nižší kvalitu než při vysílání pomocí služby Windows Media Services.
  • Obsah publikovaný v adresáři v síti WWW mohou uživatelé místo příjmu vysílání datového proudu přímo stahovat.


Více přenosových rychlostí videa

Při vytváření obsahu pro živé vysílání nebo při distribuci na požádání je možné použitím více přenosových rychlostí videa zpřístupnit obsah uživatelům, kteří využívají připojení do sítě s různou kapacitou, od telefonického připojení prostřednictvím modemu s přenosovou rychlostí 28,8 kb/s až po místní sítě LAN s vysokou šířkou pásma. Kódování obsahu s více přenosovými rychlostmi vytváří více datových proudů videa, zvuku a příkazů skriptu (pokud je tato možnost zvolena). Datové proudy videa jsou kódovány pro různé cílové šířky pásma sítě. Pokud například zvolíte použití více přenosových rychlostí videa s cílovou šířkou pásma 56 kb/s, budou vytvořeny dva datové proudy videa používající větší a menší část dané šířky pásma. Datový proud videa s přenosovou rychlostí dostatečně nízkou tak, aby umožňovala přístup uživatelům připojeným do sítě rychlostí 28,8 kb/s, však vytvořen nebude. Chcete-li zpřístupnit obsah uživatelům připojeným do sítě rychlostí 28,8 kb/s, zvolte šablonu, která obsahuje obě cílové sítě nebo při vlastní konfiguraci zadejte oba typy cílového publika.

Při vlastní konfiguraci s více přenosovými rychlostmi videa nejprve zvolte, zda chcete podporovat cílové publikum používající nízkou (18 kb/s až 300 kb/s) nebo vysokou ( 81 kb/s až 10 Mb/s) šířku pásma pro připojení do sítě. V každé kategorii (Nízká šířka pásma, Vysoká šířka pásma) je možné pro jeden obsah zvolit až pět typů cílového publika. Každý typ cílového publika podporuje jiný rozsah šířky pásma sítě. V rámci jedné kategorie můžete také vícekrát zadat stejné cílové publikum a poté pro každé z nich zadat vyšší či nižší šířku pásma. V následující tabulce jsou uvedeny dostupné rozsahy šířky pásma a výchozí kategorie pro jednotlivé typy cílového publika.

Cílové publikum | Výchozí kategorie | Rozsah šířky pásma
Modem 28,8 kb | Nízká šířka pásma | 18 - 27 kb/s
Modem s vytáčením 56 kb | Nízká šířka pásma | 28 - 37 kb/s
Jednokanálová síť ISDN | Nízká šířka pásma | 38 - 55 kb/s
Dvoukanálová síť ISDN | Vysoká šířka pásma | 56 - 120 kb/s
Intranet | Vysoká šířka pásma | 121 - 250 kb/s
Internet - vysoká rychlost | Vysoká šířka pásma | 251 - 500 kb/s
Síť LAN | Vysoká šířka pásma | 501 - 700 kb/s
Síť LAN - vysoká rychlost | Vysoká šířka pásma | 701 kb/s - 10 Mb/s

Použití více přenosových rychlostí umožní nástroji Windows Media Player pokračovat ve vykreslování obsahu i při snížení šířky pásma sítě. Pokud server v průběhu přehrávání zjistí snížení dostupné šířky pásma sítě, začne přehrávači odesílat datový proud videa určený pro nižší šířku pásma. Na straně uživatele se snížení šířky pásma projeví o něco nižší kvalitou vysílání. Datový proud však nebude přerušen, ani nebude nutné jej načíst do vyrovnávací paměti, aby došlo k zotavení výpadku způsobeného ztrátou šířky pásma.

Při kódování datového proudu s více přenosovými rychlostmi zajistěte dostupnost dostatečné šířky pásma pro přenos úplného proudu obsahu mezi kódujícím počítačem a serverem Windows Media. Vzhledem ke kódování dalších dat a k nutnosti odesílat všechny kódované datové proudy videa na server mají datové proudy s více přenosovými rychlostmi vyšší požadavky na celkovou šířku pásma pro distribuci živě vysílaného datového proudu z kodéru na server Windows Media. Server Windows Media určí odpovídající datový proud, který bude odesílán jednotlivým klientům.

V následující tabulce jsou uvedeny celkové požadavky pro výchozí šablony formátu datového proudu (TSF) s více přenosovými rychlostmi. Sloupec Cílová šířka pásma označuje šířku pásma, při které se může klientský počítač připojit k serveru a obdržet požadovaný obsah. Celková šířka pásma představuje šířku pásma potřebnou k distribuci datového proudu z kodéru na server. Uvedené hodnoty jsou pouze orientační, skutečné hodnoty se mírně liší v závislosti na obsahu.

Šablona | Cílová šířka pásma (kb/s) | Šířka pásma pro zvuk (kb/s) | Celková šířka pásma (kb/s)
Video s více přenosovými rychlostmi pro modemy s vytáčením, ISDN | 57, 37, 34, 29, 22, 17 | 8 | 204
Intranet - Video s více přenosovými rychlostmi pro vysokorychlostní sítě LAN | 700, 500, 300, 150, 120 | 10 | 1780
Video s více přenosovými rychlostmi, 28,8 kb, 56 kb a 100 kb | 100, 35, 22, 17 | 8 | 174
Video - hlas, 28,8 kb | 22, 17 | 5 | 34
Video - důraz na zvuk, 28,8 kb | 22, 17 | 8 | 30
Video modemu s vytáčením, 56 kb | 37, 22, 17 | 10 | 52

Nejnižší šířka pásma slouží jako automatická „pojistná“ šířka pásma, která se vytváří tehdy, je-li povoleno kódování pro více přenosových rychlostí. Tato pojistná šířka pásma je vytvořena i při vlastní konfiguraci při každém použití kódování s více přenosovými rychlostmi.

Používáte-li vlastní konfiguraci kódování, můžete doplněním následujících hodnot odhadnout celkové požadavky na šířku pásma:

  • šířky pásma zadané pro jednotlivé vybrané typy cílového publika,
  • vybraná šířka pásma pro zvuk,
  • pojistná šířka pásma.

Pojistnou šířku pásma lze vypočítat jako procentuální část nejnižší vybrané šířky pásma cílového publika. V následující tabulce jsou uvedeny procentuální hodnoty používané pro jednotlivé typy cílového publika.

Cílové publikum | Procentuální hodnota
Modem 28,8 kb | 80%
Modem s vytáčením 56 kb | 70%
Jednokanálová síť ISDN | 66%
Všichni uživatelé používající vysoké šířky pásma | 66%

Nezapomeňte, že pro všechny vybrané šířky pásma videa je kódován pouze jeden datový proud zvuku. Z tohoto důvodu je nezbytné před sečtením od jednotlivých vybraných typů cílového publika odečíst šířku pásma požadovanou pro datový proud zvuku.


Rozšíření obsahu Windows Media

Při vytváření a poskytování obsahu zpracovaného technologií Windows Media lze k obsahu přidat různé doplňky a funkce. V následujícím seznamu jsou uvedeny některé z dostupných možností:

  • Indexování a značky. Umožňují vyhledávání v obsahu pomocí funkcí hledání a rychlého převinutí vpřed či vzad v souborech ASF vysílání Unicast ze serveru Windows Media.
  • Příkazy skriptu. Umožňují uživatelům snazší orientaci a vyšší efektivitu práce s odkazy WWW a tématy souvisejícími s obsahem.
  • Seznamy položek k přehrání. V seznamech jsou zobrazeny položky obsahu Windows Media v určitém pořadí. Obvykle slouží pro zpestření obsahu reklamou.


Značky

Značka slouží jako ukazatel na určitý bod na časové ose v souboru Windows Media. Program Microsoft Windows Media Player používá značky k přímému vyhledání konkrétního bodu v souboru Windows Media. Pomocí přeskakování vpřed nebo zpět k předchozí značce je možné znovu prohlédnout určitou část souboru. Značky jsou používány pouze v uložených souborech Windows Media. Značky můžete umístit pomocí souboru skriptu a nástroje příkazového řádku ASFChop.

Chcete-li vytvořit značku pomocí souboru skriptu, zadejte název značky a bod na časové ose, na který chcete značku nastavit. Značky lze pojmenovat libovolně. Soubor skriptu pro vytvoření značky vypadá podobně jako následující příklad:

; Vzorový skript značky.txt
start_marker_table
8 Marker 1
1:00 Marker 2
1:15 Marker 3
3:00:03 Marker 4
end_marker_table


Příkazy skriptu

Pomocí příkazů skriptu provádí program Windows Media Player spolu s vykreslením obsahu datového proudu další úlohy nazývané skripty. Příkazy skriptu je možné použít pro datové proudy vysílané živě i pro uložené soubory. Příkazy skriptu lze přidat k datovým proudům vysílaným živě pomocí programu Windows Media Encoder. Do uložených souborů lze tyto příkazy přidat pomocí programu Windows Media ASF Indexer nebo nástrojů příkazového řádku.

K připojení příkazů skriptu k existujícímu souboru lze také použít soubor skriptu a nástroje příkazového řádku dodávané spolu s Nástroji Windows Media. Tyto soubory skriptu je možné vytvořit v textovém editoru. Pomocí textového souboru a parametru -script lze příkazy skriptu vložit do souboru ASF.


Tabulka příkazů skriptu

Program Microsoft Windows Media Player podporuje následující typy skriptů.

Typ skriptu | Funkce
URL | Přehrávač odešle zadanou adresu URL prohlížeči, pomocí kterého je zobrazena uživateli. Pokud používáte vložený přehrávač, můžete pomocí syntaxe &&framename přidat k adrese URL určitý odkaz na rámec.
FILENAME | Adresa URL jiného mediálního souboru určeného k přehrání.
TEXT | Textový řetězec zobrazený v oblasti titulku přehrávače záznamů. Tento typ podporuje standardní formátování HTML, takže je možné text formátovat požadovaným způsobem. Příkladem použití jsou například skryté titulky.
EVENT | Název předpokládané události. Typ EVENT podporuje přizpůsobení vlastním potřebám. Přehrávač může zadanou událost provést pouze tehdy, je-li pro daný datový proud kód této události definován v souboru ASX. Příkladem použití je vkládání.
OPENEVENT | Tento skript předchází skutečné události (typ EVENT). Skript OPENEVENT umožňuje přehrávačům předběžně uložit obsah do vyrovnávací paměti. Vyskytne-li se daná událost, nedojde při přepnutí datových proudů k téměř žádnému přerušení.


Soubory skriptu

Při vytváření souborů skriptu platí následující pravidla:

  • Řádky začínající středníkem jsou považovány za komentáře.
  • Prázdné řádky a prázdné znaky navíc jsou obecně ignorovány.
  • Čas značek a adres URL je nutné zadat ve formátu hh:mm:ss,d, kde h znamená hodiny, m minuty, s sekundy a d desetiny sekund.
  • Je třeba zadat čas týkající se časové osy zdrojového souboru.

Při sestavování souborů skriptu použijte nástroj ASF Script Builder. Další informace naleznete v dokumentaci k nástroji ASF Script Builder Utility obsažené v části Windows Media Technologies Solutions Samples v sadě Windows Media Technologies Software Development Kit (SDK). Sadu Windows Media Technologies SDK si můžete stáhnout ze stránky Windows Media Technologies umístěné na serveru WWW společnosti Microsoft.


Příklady použití skriptů

V následujícím seznamu jsou uvedeny příklady použití skriptů:

  • Vytvoření odkazů na adresy URL
  • Používání titulků

Odkazy na adresy URL fungují správně bez zásahu ze strany klienta, ostatní příkazy skriptu však spolupráci s klientem vyžadují. Používání titulků uvedené ve druhém příkladu vyžaduje částečnou spolupráci ze strany klienta. Další informace týkající se zajištění spolupráce s klienty pro příkazy skriptu naleznete v dokumentaci k programu Microsoft Windows Media Player v části ScriptCommand Event umístěné na serveru WWW společnosti Microsoft.

; Tímto způsobem lze pomocí nástrojů VidToASF a WavToASF
; vložit informace o obsahu do souboru ASF.
Title: Zde je uveden titulek
Author: ASF Maker
Copyright: 1998
Description: text popisující soubor ASF
Rating: PG

; Ukázka odkazu na adresu URL a použití titulků
start_script_table
1.0 URL http://Windows Media/images/cz1.html&&Display
5.0 Caption Národní divadlo
12.0 URL http://Windows Media/images/cz2.html&&Display
15.0 Caption Propast Macocha
32.0 URL http://Windows Media/images/cz3.html&&Display
35.0 Caption Boubínský prales
end_script_table

Poznámka

  • V předcházejícím příkladu jsou pro označení rámce na stránce WWW, na které by se měla příslušná adresa URL zobrazit, použity znaky &&. K zajištění správné funkce je třeba prohlížeči umožnit přístup k dané adrese URL. Pokud bude zahrnuta neexistující adresa URL, vrátí prohlížeč chybovou zprávu.


Seznamy položek k přehrání

Seznamy položek k přehrání slouží jako ukazatele na soubory a datové proudy Windows Media. Na každý soubor nebo datový proud odkazuje adresa URL, například mms://server/vzor.asf nebo mms://server/alias. Pro službu Windows Media Services existují dva typy seznamů - seznam položek na straně klienta a seznam položek na straně serveru.

Seznamy položek na straně klienta

Seznamy položek na straně klienta jsou seznamy souborů a datových proudů v podobě souboru ASX. Seznamy jsou vytvořeny v textovém editoru. K vytvoření seznamu odkazů na soubory Windows Media v podobě souboru ASX slouží standardní syntaxe jazyka Extensible Markup Language (XML).

V některých případech je třeba vytvořit seznam položek na základě požadavků uživatelů nebo na základě demografických dat. Pomocí stránek Active Server Pages lze podle ohlasů uživatelů dynamicky vytvářet individuálně přizpůsobené soubory ASX. Pomocí funkcí Membership Server a Ad Server, které jsou součástí serveru Microsoft Site Server verze 3.0, lze také vytvořit stránky WWW, které dynamicky sestaví seznam adres URL živě vysílaných datových proudů a individuálních komerčních souborů ASF na základě osobního vkusu uživatelů.

Seznamy položek na straně serveru

Seznamy položek na straně serveru jsou seznamy souborů ASF a datových proudů v programu Windows Media. Seznamy položek na straně serveru lze použít k nastavení nepřetržitého opakování vysílání a doby jeho trvání. Tyto seznamy nelze vytvořit pomocí stránek ASP, mohou být však vysílány ve formě datového proudu vysílání Unicast nebo Multicast.


Zvukové soubory Windows Media

Soubory Windows Media Audio (WMA) jsou speciálním typem souborů ve formátu ASF (Advanced Streaming Fomat). Tyto soubory obsahují zvuková data komprimovaná pomocí nového typu vysoce kvalitní ztrátové komprese zvuku, prováděné pomocí kodeku s názvem Windows Media Audio. Soubory zpracované kodekem Windows Media Audio jsou určeny pouze pro zvukový obsah s vysokou kvalitou.

Soubory WMA lze distribuovat pomocí služby Windows Media Services. Při požadavku na soubor WMA vytvoří služba Windows Media Services automaticky speciální typ souboru oznámení (soubor s příponou WAX), který přehrávač odkáže na příslušný obsah.

Přípony WMA a WAX lze vyhradit zvolenému výchozímu přehrávači. Pokud tedy používáte k vytvoření souborů ASF obsahujících pouze zvuk Nástroje Windows Media, lze rozšířit možnosti přenosu na jiné přehrávače přejmenováním těchto souborů na soubory s příponou WMA.

V současné době je program Windows Media Player jediný přehrávač, který obsahuje dekódovací klíče pro kodek Windows Media Audio. Další informace týkající se distribuce dekódovacích klíčů naleznete v sadě Windows Media Audio Software Development Kit.

Poznámka

  • Pomocí programu Windows Media Packager lze soubor WMA zašifrovat.


Použití programu Windows Media Encoder

Program Windows Media Encoder je před použitím nutné nakonfigurovat pomocí jednoho ze tří průvodců konfigurací:

  • Rychlé nastavení. Datový proud ve formátu ASF lze nakonfigurovat pomocí šablony formátu datového proudu (TSF). Použijete-li ke konfiguraci Rychlé nastavení, platí předpoklad, že provádíte kódování živého zdroje a posíláte obsah na server Windows Media.
  • Šablona s možnostmi vstupu či výstupu. Tato šablona umožňuje vybrat vstupní zařízení a umístění výstupu. Šířka pásma a typ kodeku je nastaven pomocí šablony TSF.
  • Vlastní nastavení. Při tomto způsobu konfigurace lze nastavení kodéru libovolně upravit.

Pomocí programu Windows Media Encoder nelze klientům (kromě testování) odesílat datové proudy ASF. Datové proudy ASF jsou pomocí tohoto programu doručeny na server Windows Media, na kterém lze datovému proudu přiřadit typ vysílání Multicast nebo Unicast a poslat upravený datový proud ASF do sítě. Vytvoří-li program Windows Media Encoder soubor ASF, bude tento soubor uložen do složky zadané během konfigurace. Chcete-li soubor ASF vytvořený programem Windows Media Encoder vyzkoušet, použijte k otevření souboru program Windows Media Player.


Rychlé nastavení

Chcete-li nakonfigurovat program Windows Media Encoder pro kódování živého obsahu určeného k vysílání ze serveru Windows Media, a nevíte, který kodek použít, zvolte metodu Rychlé nastavení a proveďte nastavení kodeků výběrem jedné ze šablon TSF.

Poznámka

  • Použijete-li ke konfiguraci Rychlé nastavení, bude digitalizace obsahu živého záznamu zvuku a videa provedena pomocí výchozích vstupních zařízení počítače. Chcete-li zjistit, které digitalizační zařízení je v počítači nastaveno jako výchozí, klepněte v Ovládacích panelech na panel Zvuky a multimédia. Chcete-li vybrat jiná vstupní zařízení než výchozí, nakonfigurujte program Windows Media Encoder pomocí možnosti Šablona s možnostmi vstupu či výstupu.


Šablona s možnostmi vstupu či výstupu

Vyberete-li pro konfiguraci programu Windows Media Encoder možnost Šablona s možnostmi vstupu či výstupu, je nutné, stejně jako u konfigurace pomocí možnosti Rychlé nastavení, zvolit nejdříve šablonu TSF. Po výběru požadované šablony TSF je však dále nutné upřesnit na dalších obrazovkách konfigurace vstup videa a zvuku, port IP, server Windows Media, kterému bude datový proud ASF odesílán, a zvolit, zda má být datový proud ASF vytvořený pomocí kodéru převeden do souboru ASF. Dostupné možnosti se v závislosti na vybraném typu šablony TSF liší. Nastavení lze po dokončení konfigurace uložit jako soubor s příponou ASD.


Šablona formátu datového proudu (TSF)

Šablony formátu datového proudu (Template stream format - TSF) jsou šablony pro program Windows Media Encoder obsahující nastavení pro určitý typ datového proudu. Šablony TSF se shodují s konfigurací standardních datových proudů ASF pro službu Windows Media Component Services a program Microsoft Windows Media Player. Šablony TSF obsahují informace o následujících parametrech:

  • Cílová šířka pásma sítě. Tato hodnota určuje nejnižší šířku pásma síťového připojení uživatele. Pokud síťové připojení uživatele cílovou šířku pásma nepodporuje, nemůže tento uživatel přijímat daný datový proud. Rozsah šířky pásma šablon TSF technologie Windows Media se pohybuje v rozmezí od 28,8 kb/s (kilobity za sekundu) do 3 Mb/s (megabity za sekundu). Pokud uživatelé používají různé šířky pásma, je vhodné použít šablonu videa, která podporuje více přenosových rychlostí, a vytvořit tak datový proud podporující více šířek pásma.
  • Typ obsahu. Typ obsahu, který bude ve formě datového proudu vysílán, má významný vliv na použité kodeky zvuku a videa a na nastavení zařízení videa poskytující optimální výkon. Můžete použít celou řadu šablon TSF technologie Windows Media pro datové proudy obsahující pouze zvuk i šablony pro multimediální datové proudy.
  • Více přenosových rychlostí videa. Pomocí šablon pro více přenosových rychlostí videa lze kódovat video pro více pásem do jednotlivých datových proudů ASF, což umožňuje vysílat datové proudy do sítě s různými šířkami pásma. Tento způsob zajišťuje pro klienta nejlepší výkon pro vyšší šířky pásma, přičemž jsou podporována i připojení s nižší šířkou pásma. Tuto metodu lze použít také v případech, kdy je omezena šířka pásma sítě, která je k dispozici, a datový proud je nutné přizpůsobit různým podmínkám. Požadovaný procesor, který lze při kódování záznamu videa pro více přenosových rychlostí v šířce pásma sítě Internet použít, je minimálně procesor Pentium II pracující s kmitočtem 266 MHz. Chcete-li kódovat záznam videa pro více přenosových rychlostí ve vyšší šířce pásma, je nutné použít dva procesory Pentium II s kmitočtem 400 MHz.
  • Video na serveru WWW. Šablony TSF pro video na serveru WWW byly navrženy pro obsah ASF, který je určen pro šíření ze serveru WWW ve formě datového proudu bez použití služby Windows Media Services. Tyto šablony zajišťují vytvoření jednoho datového proudu zvuku a videa vhodného k šíření pomocí protokolu HTTP.

Poznámka

  • Službu Windows Media Services lze také použít k vysílání datových proudů pomocí protokolu HTTP. Tato služba zajišťuje spolehlivější přenos mediálních datových proudů prostřednictvím protokolu HTTP než metody používané servery WWW. Pokud použijete k vysílání datových proudů pomocí protokolu HTTP službu Windows Media Services, můžete použít ke kódování libovolnou šablonu. Další informace o aktivaci a použití služby Windows Media Services k vysílání datových proudů pomocí protokolu HTTP naleznete v tématu Použití vysílání datového proudu HTTP.


Vytváření obsahu pro verzi 2.0

Pokud někteří uživatelé, se kterými spolupracujete, stále používají program NetShow Player verze 2.0, nebo odesíláte-li obsah na server pomocí služby Windows Media Services verze 2.0, je pro vytvoření souborů ASD kompatibilních s verzí 2.0 nutné použít vlastní postup konfigurace nebo použít k vytvoření obsahu existující soubory ASD z verze 2.0.

Rozhodnete-li se vytvořit nové soubory ASD kompatibilní s verzí 2.0, postupujte podle následujících pokynů:

  • Vyberte videokodek Microsoft MPEG v1.
  • Vyberte zvukový kodek MPEG Layer-3.
  • Nepoužívejte více přenosových rychlostí videa.
  • Nepoužívejte aktuální verzi souborů oznámení (souborů s příponou ASX) služby Windows Media Services.


Vlastní konfigurace

Chcete-li provést vlastní konfiguraci programu Windows Media Encoder, je nutné určit šířku pásma sítě, kterou používáte, média, která tvoří datový proud ASF, kodeky použité pro přizpůsobení médií šířce pásma sítě a další podrobnosti kódovacího postupu.

Pokud chcete po dokončení konfigurace kodéru spustit vysílání datového proudu ASF, klepněte na tlačítko Spustit. Chcete-li však, aby server Windows Media využíval výstup z programu Windows Media Encoder, je nutné konfiguraci uložit jako soubor ASD. Soubor ASD obsahuje úplné nastavení a specifikace datového proudu ASF. Jestliže chcete tento datový proud vysílat, je nutné zajistit, aby byl daný soubor ASD k dispozici správci systému, který má oprávnění nastavovat server Windows Media. Správce systému importuje data konfigurace ze souboru ASD a nastaví vysílání. Vytvoříte-li konfiguraci pomocí šablony TSF, budou služby Windows Media Component Services nakonfigurovány pomocí nastavení a specifikací datového proudu ASF, a soubor ASD proto nebude třeba.

Poznámka

  • Metoda vlastní konfigurace je určena zkušenějším uživatelům a vyžaduje podrobnou znalost kapacity šířky pásma, nastavení médií a použití kodeků. Pro dosažení nejlepších výsledků je doporučeno používat kodek Windows Media Audio verze 2.0 pro zvuk a kodek Microsoft MPEG 4 verze 3 pro video. Přenosová rychlost, kterou pomocí zvukového kodeku vyberete, zároveň určí, jak velká část šířky pásma zůstane k dispozici pro obsah videa. Budete-li tedy například chtít zvětšit šířku pásma pro zvuk, kvalita zvuku se zlepší, ale v odpovídajícím poměru se zhorší kvalita videa.


Úpravy vlastností

Jestliže jste pro program Windows Media Encoder vytvořili konfigurační soubor ASD, můžete tuto konfiguraci měnit úpravami na stránkách vlastností. Dostupné stránky vlastností se liší podle toho, zda používáte šablonu TSF nebo vlastní konfiguraci.

Použijete-li šablonu TSF, budou k dispozici následující vlastnosti:

  • Šablona. Na kartě Šablona je možné vybrat šablonu TSF, která bude použita pro soubor ASD.
  • Vstup. Na kartě Vstup je možné určit zdroj obsahu. Můžete vybrat Živý zdroj nebo Soubor AVI/WAV/MP3.
  • Výstup. Na kartě Výstup lze určit, zda bude soubor ASF nebo datový proud ASF odesílán na server Windows Media nebo do místního souboru ASF. Můžete také zvolit obě možnosti.

Pokud použijete vlastní konfiguraci, budou k dispozici následující vlastnosti:

  • Vstup. Na kartě Vstup je možné určit zdroj obsahu. Můžete vybrat Živý zdroj nebo Soubor AVI/WAV/MP3.
  • Šířka pásma. Na kartě Šířka pásma lze nastavit šířku pásma datového proudu.
  • Komprese. Na této kartě lze vybrat zvukové kodeky a videokodeky pro kompresi obsahu. Klepnete-li na tlačítko Upřesnit, můžete dále měnit velikost obrázku, počet snímků za sekundu, počet sekund mezi snímky inline, pixelový formát, zpožďující vyrovnávací paměť a kvalitu obrázku.
  • Výstup. Na kartě Výstup lze určit, zda bude soubor ASF nebo datový proud ASF odesílán na server Windows Media nebo do místního souboru ASF. Můžete také zvolit obě možnosti.

Poznámka

  • Pokud je zdrojem obsahu soubor ve formátu MP3 s vlastnostmi ID3, budou v souboru ASF tyto vlastnosti zachovány. Uvedené vlastnosti lze upravit pomocí programu Windows Media ASF Indexer.


Použití kodeku Windows Media Audio

Kodek Windows Media Audio je nový zvukový kodek vyvinutý společností Microsoft. Program Windows Media Encoder, který je součástí služby Windows Media Services verze 4.1, obsahuje nejnovější verzi tohoto kodeku, kodek Windows Media Audio verze 2. Tento kodek byl vyvinut tak, aby umožňoval zpracovat všechny typy zvukového obsahu, od 8 kHz (mluvené slovo) až po 48 kHz (stereo hudba). Kodek nevyužívá mezirámcovou paměť, a proto je velmi odolný vůči degradaci způsobené ztrátou paketů. Vzhledem k této odolnosti vůči ztrátě kvality lze použitím tohoto kodeku dosáhnout při vysílání obsahu ve formě datového proudu výborných výsledků. Díky zlepšenému kódovacímu algoritmu probíhá kódování a dekódování u tohoto kodeku daleko rychleji. Algoritmus vytvoří z obsahu zvukový soubor, který potřebuje k uložení mnohem méně místa na disku než stejný obsah komprimovaný jinými kodeky. Obsah vytvořený pomocí kodeku Windows Media Audio je možné stáhnout mnohem rychleji a lze jej proto snadno šířit v síti Internet. Vytváříte-li proto zvukové soubory určené ke stažení, je kodek Windows Media Audio vhodnou volbou. Poskytuje zvuk blížící se kvalitě CD a potřebuje přitom pouze polovinu šířky pásma požadované většinou ostatních kodeků.

Kodek Windows Media Audio poskytl během testů s některými srovnatelnými kodeky daleko jasnější zvuk s lepším rozlišením tónů. Hudební obsah lze pomocí kombinace vynikající čistoty zvuku a hloubky tónů produkovat v lepší kvalitě ve všech podporovaných šířkách pásma. Kodek Windows Media Audio lze do značné míry přizpůsobovat. Poskytuje zvukový obsah ve výborné mono i stereo kvalitě v širokém rozsahu šířek pásma, což umožňuje zvolit při vytváření obsahu nejvhodnější kombinaci šířky pásma a vzorkovací frekvence. Tento kodek byl proto společností Microsoft vybrán jako výchozí pro většinu šablon konfigurace programu Windows Media Encoder.


Zobrazení statistiky

Program Windows Media Encoder umožňuje vyhodnotit účinnost kódování prostřednictvím různých statistik. Pomocí těchto statistik lze zajistit nejvhodnější způsob zpracování obsahu sledováním účinků provedených změn nastavení kodeků a přenosové rychlosti. Používáte-li více přenosových rychlostí videa, je také možné zobrazit a porovnat statistiky z datových proudů videa, které jsou k dispozici.

Můžete zobrazit následující statistiky:

  • ASF. Tato statistika umožňuje zobrazit množství odeslaných dat, výplní a přenosovou rychlost odesílaných dat.
  • Zvuk. Tato statistika umožňuje zobrazit množství odeslaných dat a přenosovou rychlost odesílaných dat.
  • Příkazy skriptu. Tato statistika umožňuje zobrazit počet odeslaných bajtů příkazů skriptu a zároveň lze určit počet příkazů, které tento počet bajtů představuje.
  • Video. Tato statistika umožňuje zobrazit množství odeslaných a ztracených dat. Poskytuje také souhrnnou statistiku o přenosové rychlosti a odeslaných snímcích za sekundu.
  • Aktuální připojení. V seznamu v tomto skupinovém rámečku jsou zobrazeny adresy IP počítačů, které jsou ke kodéru aktuálně připojeny.


Spuštění kodéru

Jakmile je program Windows Media Encoder nakonfigurován, lze spustit kódování obsahu ASF. Chcete-li kódování spustit, klepněte v nabídce Kódování na příkaz Spustit nebo klepněte na tlačítko Spustit.

Po dokončení konfigurace nebo po uložení souboru s konfigurací a spuštění programu Windows Media Encoder pomocí tlačítka Spustit se zobrazí hlavní dialogové okno. Toto dialogové okno tvoří panel nástrojů a tři skupinové rámečky. Panel nástrojů obsahuje zástupce často používaných příkazů nabídek v podobě tlačítek (například spuštění a zastavení kodéru, náhled videa a nápověda). Skupinové rámečky obsahují následující informace:

  • Skupinový rámeček Souhrnná statistika poskytuje informace o relaci kódování, délce trvání kódování, množství dat kódovaných v dané relaci, přenosové rychlosti aktuálně kódovaného obsahu a počtu kódovaných snímků za sekundu. Tímto způsobem lze rychle zjistit, zda relace kódování zajišťuje požadovanou kvalitu obsahu.
  • Informace o aktuálně použité konfiguraci lze nalézt ve skupinovém rámečku Souhrnné nastavení. Tato část obsahuje informace o tom, které kodeky a vstupní zdroje jsou využívány, o nastavení výstupního souboru (pokud je zvolen), a jestliže používáte šablonu TSF, pak také její název.
  • Ve skupinovém rámečku Informace o připojení se nachází informace o odkazu datového proudu kodéru. Odkaz datového proudu umožňuje připojení serveru Windows Media a klienta představovaného programem Windows Media Player k obsahu datového proudu odesílaného pomocí programu Windows Media Encoder.

Jestliže jsou povoleny příkazy skriptu, bude do hlavního okna přidáno rozevírací pole pro příkazy skriptu. Chcete-li odeslat příkaz skriptu, zadejte tento příkaz do příslušného pole, například:

URL HTTP://www.příklad.microsoft.cz

a v místě obsahu datového proudu, ve kterém chcete zadanou akci uskutečnit, klepněte na tlačítko Odeslat. Jakmile příkaz skriptu odešlete, bude tento příkaz vložen do datového proudu ASF a proveden klientem představovaným programem Windows Media Player během zobrazení obsahu datového proudu.

Hodnoty statistiky ve skupinovém rámečku Souhrnná statistika začnou po spuštění kodéru narůstat a tlačítko s ikonou kamery se změní ze stavu Nevysílá se na Vysílá se.


Vysílání datového proudu HTTP pomocí programu Windows Media Encoder

Pokud je server Windows Media chráněn bezpečnostní bránou firewall, lze obsah datového proudu z programu Windows Media Encoder nacházejícího se za bezpečnostní bránou firewall přijímat pomocí funkce vysílání datového proudu HTTP.

Datový proud HTTP umožňuje v síti Internet pomocí programu Windows Media Encoder odesílat datový proud ASF na server Windows Media, který je umístěn v oblasti chráněné bezpečnostní bránou firewall. Standardní konfigurace bezpečnostní brány firewall neumožňují distribuci datového proudu z programu Windows Media Encoder chráněného bezpečnostní bránou firewall na server Windows Media nainstalovaný v síti Internet.

Při konfiguraci pomocí Rychlého nastavení je ve výchozím nastavení vysílání datového proudu HTTP povoleno. Port pro připojení protokolu HTTP naleznete v dialogovém okně datového proudu zobrazeného při konfiguraci kodéru. Chcete-li port změnit nebo používání datového proudu HTTP zakázat, zrušte na stránce výstupních vlastností konfigurace kodéru zaškrtnutí políčka pro vysílání datového proudu HTTP.

Používáte-li šablonu nebo vlastní konfiguraci, je možné vysílání datového proudu HTTP povolit v nastavení výstupu na stránce průvodce konfigurací určené k nastavení přenosu.

Poznámka

  • Chcete-li předejít konfliktům portu protokolu HTTP nebo otevřít port v bezpečnostní bráně firewall, sdělí vám potřebné informace správce sítě.


Povolení vzdáleného připojení k programu Windows Media Encoder

Program Windows Media Encoder podporuje vzdálené připojení pomocí telefonického připojení sítě. Rozšíření Windows Media Presenter pro aplikaci Microsoft PowerPoint 97 využívá toto připojení během prezentace k odesílání příkazů pro spuštění a zastavení a příkazů skriptu do programu Windows Media Encoder.

Není-li v počítači, ve kterém je nainstalován program Windows Media Encoder, vytvořeno v době instalace programu aktivní telefonické připojení sítě, je ve výchozím nastavení programu Windows Media Encoder použití vzdálených připojení možné. Pokud bylo telefonické připojení sítě při instalaci k dispozici, zobrazí se po restartování počítače dialogové okno, ve kterém je možné vzdálené připojení povolit.

Nepovolíte-li vzdálené připojení, můžete jej povolit později spuštěním souboru Enable_Remote_Connection.reg. Soubor naleznete v adresáři Systémová_jednotka\Program Files\Windows Media Components\Tools. Tento adresář obsahuje také soubor Disable_Remote_Connection.reg, kterým lze vzdálené připojení zakázat.

Poznámka

  • Tento odstavec se týká pouze programů Windows Media Encoder používaných v počítačích, které využívají operační systémy Microsoft Windows 95 nebo Microsoft Windows 98.


Zastavení kodéru

Zastavení programu Windows Media Encoder způsobí zastavení kódování obsahu datového proudu. Všechny počítače, které přijímají obsah datového proudu, přestanou tento obsah přijímat. Obnovení nastavení karet pro digitalizaci může po zastavení kodéru trvat několik sekund. Pokusíte-li se restartovat kodér ještě před obnovením těchto nastavení, zobrazí se zpráva s informacemi, že videozařízení nelze spustit. Vyčkejte několik sekund a zkuste kodér znovu spustit.

Program Windows Media Encoder lze zastavit klepnutím na tlačítko Zastavit nebo zadáním omezení relace kódování (například omezení velikosti souboru a délky souboru).


Testování datových proudu ASF

Titulek služby Windows Media Services

Testování datových proudů ASF

Po konfiguraci a spuštění programu Windows Media Encoder je vhodné před zveřejněním obsahu vyzkoušet požadovanou funkci.

Chcete-li funkci kodéru vyzkoušet, zkuste pomocí programu Windows Media Player přijímat datový proud ASF odesílaný z programu Windows Media Encoder i ze serveru Windows Media.

Datový proud vytvořený programem Windows Media Encoder není odesílán ve formě vysílání Multicast, není proto vhodné zkoušet funkci kodéru pomocí většího počtu než patnácti klientů.


Publikování v síti WWW

Obsah ASF vytvořený pomocí programu Windows Media Encoder lze efektivně distribuovat širokému okruhu příjemců. Společnost Microsoft vytvořila program Windows Media Service Provider Program umožňující autorům obsahu využít poskytovatele služeb, kteří mohou zavádět a spravovat služby využívající mediální datové proudy založené na službě Windows Media Services.

Chcete-li publikovat obsah v síti WWW, klepněte v nabídce Soubor programu Windows Media Encoder na příkaz Publikovat v síti WWW a v seznamu schválených poskytovatelů služby Windows Media Services vyberte poskytovatele, který nejlépe vyhovuje vašim požadavkům.


Nástroj ASFChop

Nástroj ASFChop je nástroj příkazového řádku, který je možné použít k odstranění částí souboru ASF. Pomocí tohoto nástroje lze také do souboru ASF přidat indexování, příkazy skriptu, značky a obecné vlastnosti. Odstraněním částí souboru lze snížit dobu požadovanou k jeho vysílání ve formě datového proudu. Nástroj ASFChop vytvoří pro daný soubor rejstřík umožňující prohledávání souboru (podobně jako u rychlého převíjení vpřed). Soubory ASF, které lze prohledávat, je možné vytvořit také pomocí programu Windows Media Encoder. Rejstřík lze vytvořit pouze v souboru ASF s minimální délkou obsahu 10 sekund.


Parametry příkazového řádku nástroje ASFChop

Parametry příkazového řádku umožňují provést v souboru ASF určité nastavení nebo do tohoto souboru včlenit další soubory. Chcete-li zobrazit seznam parametrů online, klepněte v systému Windows na tlačítko Start, přejděte na příkaz Programy a klepněte na položku Příkazový řádek. Do pole zadejte název nástroje a stiskněte klávesu ENTER.

Název parametru | Argument parametru | Popis
-duration | čas | Určuje dobu trvání pro výstup souborů ASF. Poznámka: Použijte parametr -duration nebo -end.
-eccspan | on|off | Zapnutí nebo vypnutí opravy chyb. Pokud není tento parametr zadán, je použito nastavení opravy chyb ze vstupního souboru.
-end | čas | Požadovaný čas ukončení souboru ASF.
-in | název_souboru.asf | Požadovaný soubor ASF určený k úpravě.
-out | název_souboru.asf | Název výstupního souboru. Pokud není název výstupního souboru zadán, vytvoří nástroj ASFChop nový výstupní soubor se stejným názvem jako je název vstupního souboru.
-script | název_souboru | Název souboru skriptu, který bude použit pro přidání adres URL, příkazů skriptu a informací týkajících se obsahu a značek do výstupního souboru.
-start | čas | Odstraní začátek souboru ASF. Po nastavení počátečního času bude odstraněn veškerý obsah předcházející tomuto nastavení. Po uložení souboru ASF je tento nastavený počáteční čas považován za jeho začátek.

Poznámka

  • Čas pro všechny parametry je třeba zadat ve formátu hh:mm:ss,d, kde h znamená hodiny, m minuty, s sekundy a d desetiny sekund. Například 04:12:28,9 znamená 4 hodiny, 12 minut a 28,9 sekund.


Použití nástroje ASFChop u souboru ASF

  1. V nabídce Start systému Windows přejděte na příkaz Programy a klepněte na položku Příkazový řádek.
  2. Pomocí příkazového řádku vyhledejte adresář obsahující vstupní zdrojový soubor a zadejte následující příkaz (s názvy požadovaných souborů ASF):
     ASFChop -in název_souboru.asf -out název_souboru.asf
  3. Za parametr -out připojte požadované parametry, například -duration, -end nebo -script. Potom stiskněte klávesu ENTER.

Poznámka

  • Parametr -out je nepovinný. Pokud tento parametr nezadáte, vytvoří nástroj ASFChop výstupní soubor se stejným názvem jako je název vstupního souboru a připojí k němu příponu ASF.


Program Windows Media Player

Program Microsoft Windows Media Player je klientská softwarová aplikace, která slouží k příjmu datových proudů ve formátu ASF ze serveru Windows Media. Uživatel může program Windows Media Player použít pro přímý přístup k datovým proudům, nebo ho lze spustit otevřením souboru ASX. Tento program slouží také k přehrávání mnoha dalších typů obsahu. Další informace o použití programu Windows Media Player pro jiné aplikace naleznete v nápovědě k programu Windows Media Player.


Použití programu Windows Media Player

Pomocí programu Windows Media Player lze obsah ve formátu ASF doručit uživatelům třemi způsoby. Program Windows Media Player může být použit jako samostatný program, který bude spuštěn hypertextovým odkazem, nebo vložen na stránku WWW.

Obsah ve formátu ASF může být představován soubory ASF nebo datovými proudy ASF. Uložené soubory ASF lze pomocí tohoto programu otevřít a přehrát, tyto soubory však do něho nejsou odesílány ve formě datového proudu. Datový proud lze do programu Windows Media Player vysílat jen v podobě obsahu doručeného klientovi přímo ze serveru Windows Media.


Přístup k obsahu pomocí samostatného programu Windows Media Player

Při instalaci programu Windows Media Player je provedena konfigurace počítače a je vytvořeno přidružení konkrétních typů médií na základě protokolu a přípon souborů. To znamená, že pomocí tohoto programu lze získat přístup ke všem typům souborů, které umožňují přijímat obsah ve formátu ASF.

Chcete-li získat pomocí programu Windows Media Player přístup k určitému obsahu, klepněte v nabídce Soubor na příkaz Otevřít a v dialogovém okně Otevřít zadejte požadované umístění.

Program Windows Media Player umožňuje používat řadu různých protokolů a otevírat různé typy obsahu. Další informace o otevírání obsahu pomocí jiných aplikací než služby Windows Media Services naleznete v nápovědě k programu Windows Media Player.

Přehrávání uložených souborů ASF

Chcete-li přehrát uložený soubor ASF ze serveru Windows Media, zadejte v dialogovém okně Otevřít:

mms://server/soubor.asf

Jestliže je server Windows Media konfigurován k vysílání datového proudu pomocí protokolu HTTP, zadejte:

http://server/soubor.asf

Server odešle soubor klientovi ve formě datového proudu ze složky s obsahem ve formátu ASF (například Systémová_jednotka\ASFRoot). Je-li pro server Windows Media povoleno vysílání datových proudů pomocí protokolu HTTP, využívá server jako domovský adresář stále složku s obsahem ve formátu ASF a nepoužívá jako domovský adresář virtuální kořenový adresář protokolu HTTP (například Systémová_jednotka\wwwroot).

Přehrávání obsahu pomocí souborů ASX

Soubory ASX slouží k zajištění přístupu k souborům s příponou ASF ze serveru Windows Media a k vysílání adresářů pro publikování vysílání Unicast nebo stanic vysílání Multicast. Soubor ASX představuje ukazatel k obsahu ve formátu ASF. Chcete-li použít soubory ASX se samostatným přehrávačem, je nutné znát cestu k danému souboru ASX. Nejběžnějším způsobem získání přístupu k souboru ASX pomocí samostatného přehrávače je zadání cesty k souboru do dialogového okna Otevřít. Touto cestou může být sdílená složka nebo server WWW. Chcete-li například získat přístup ke sdílené složce, zadejte:

\\server\sdílená_složka\soubor.asx

Pokud chcete získat přístup na server WWW, zadejte:

http://server/soubor.asx

Program Windows Media Player stáhne soubor ASX, analyzuje cestu k obsahu ve formátu ASF a potom odešle obsah ze serveru ve formě datového proudu.

Přehrávání obsahu ze stránek HTML

Pokud stránka HTML obsahuje vložený přehrávač (ovládací prvek Microsoft ActiveX), není třeba použít pro přístup na příslušnou stránku WWW samostatný přehrávač. Tuto metodu je možné používat, přednostním způsobem přístupu na stránku HTML je však použití prohlížeče sítě WWW. Chcete-li získat přístup na stránky WWW pomocí programu Windows Media Player, zadejte v dialogovém okně Otevřít:

http://serverWWW/stránka.htm

Program Windows Media Player předá adresu URL místnímu prohlížeči, který otevře a vyhledá požadovanou stránku WWW. Po načtení stránky HTML se zobrazí vložený program Windows Media Player a začne přehrávat přidružený obsah ve formátu ASF.


Spuštění programu Windows Media Player z odkazu

Existují dva způsoby umožňující spustit program Microsoft Windows Media Player z odkazu na stránce WWW nebo aplikace serveru WWW a přijímat obsah vysílaný ve formě datového proudu ze serveru Windows Media:

  1. Je možné povolit vysílání datového proudu pomocí protokolu HTTP a využít odkazy HTTP na obsah ASF přímo. Metodu vysílání datového proudu pomocí protokolu HTTP je třeba použít v případě, že chcete vysílat datový proud přes bezpečnostní bránu firewall.
  2. Můžete také využít odkazy HTTP na soubory ASX obsahující instrukce, které program Windows Media Player používá pro přístup k obsahu ve formátu ASF. Soubor ASX se musí nacházet na serveru HTTP, například na serveru služby Internet Information Services (IIS), v adresáři, do kterého má daný uživatel přístup.

Chcete-li program Windows Media Player spustit z odkazu na stránce WWW nebo v aplikaci serveru WWW pomocí metasouboru ASX, vytvořte adresu URL v kódu HTML podobně jako v následujícím příkladu:

<A HREF=http://server/soubor.asx>

Tento odkaz odkáže klienta na soubor ASX, který nasměruje přehrávač k přístupovému bodu pro daný obsah.


Vložení ovládacího prvku ActiveX programu Windows Media Player

Na stránku WWW nebo do kontejneru jiné aplikace podporující ovládací prvky ActiveX můžete vložit ovládací prvek ActiveX programu Microsoft Windows Media Player, tak, aby program Windows Media Player nebyl spuštěn jako samostatná aplikace. Místo toho pak bude datový proud obsahu zadaný ve vlastnostech přehráván po vykreslení strany v rámci prohlížeče. Tato metoda umožňuje lépe řídit způsob, jakým bude uživatel přijímat obsah vysílaný ve formě datového proudu, a představuje také snadný způsob poskytnutí programu Windows Media Player uživatelům, kteří ho nemají v počítači nainstalován.

Pokud uživatel otevře stránku, do které je vložen ovládací prvek, zobrazí se certifikát identifikující vydavatele ovládacího prvku. V certifikátu se uživateli zobrazí dotaz, zda souhlasí se stažením ovládacího prvku, nebo zda chce pokračovat ve vykreslování stránky bez stažení daného ovládacího prvku. Pokud není ovládací prvek nainstalován, není obsah doručen.

Vlastnosti ovládacího prvku můžete nastavit pomocí značky HTML <OBJECT>. Tímto způsobem lze určit, který soubor ASF, adresář pro publikování nebo stanice mají být otevřeny a také způsob jejich přehrávání. Vlastnosti ovládacího prvku, například tlačítka, která budou zobrazena, lze určit také pomocí skriptů v jazyce Microsoft Visual Basic. Následující značka HTML <OBJECT> zobrazuje ID třídy ovládacího prvku programu Windows Media Player a některé jeho vlastnosti.

<OBJECT CLASSID="clsid:22d6f312-b0f6-11d0-94ab-0080c74c7e95F"
HEIGHT=240
WIDTH=320
NAME=Msshow1
ID=Msshow1
>
<PARAM NAME="FileName" VALUE="mms://MSserver/Msshow1.asf">
</OBJECT>

Další informace o ovládacích prvcích programu Windows Media Player a jejich vlastnostech naleznete v sadě Microsoft Windows Media Player Control SDK na serveru WWW společnosti Microsoft.

Nastavení vlastností určuje způsob, jakým bude program Windows Media Player fungovat. Parametr FileName identifikuje přehrávaný soubor ASF. Hodnotu tohoto parametru nastavte jako adresu URL, podobně jako při přehrávání souboru ASF pomocí příkazu Otevřít v nabídce Soubor programu Windows Media Player.


Informace o metasouborech ASX

Metasoubory ASX neboli soubory ASX jsou textové soubory, které ve své nejjednodušší formě obsahují informace týkající se adresy URL datového proudu. Tyto informace zpracuje program Windows Media Player tak, že otevře obsah uvedený v souboru ASX.

Tato část obsahuje informace týkající se nejdůležitějších funkcí souborů ASX používaných k doručování datových proudů. Další informace o souborech ASX naleznete v tématu Using ASX Metafiles (Použití metasouborů ASX) v sadě Microsoft Windows Media Player Control SDK, která je součástí sady Microsoft Platform SDK.


Princip metasouboru ASX

Titulek služby Windows Media Services

Princip metasouborů ASX

Soubory s příponou ASX jsou metasoubory obsahující informace, které program Windows Media Player využívá k přijímání datových proudů vysílání Unicast, datových proudů vysílání Multicast a dalších podporovaných médií ze sítě intranet a Internet. Tyto soubory lze pomocí programu Windows Media Player rychle načíst. Obsahují informace sloužící k následujícím účelům:

  • Přenos ovládacího prvku z prohlížeče HTTP na ovládací prvek programu Windows Media Player za účelem vysílání datových proudů přímo do programu Windows Media Player. Bez aplikace Microsoft Internet Explorer není možné na stránce WWW definovat hypertextové odkazy pomocí protokolu MMS, protože tento protokol není rozpoznán. Můžete však vytvořit odkaz na soubor ASX umístěný na serveru WWW, který poté program Windows Media Player odkáže prostřednictvím protokolu MMS na server Windows Media.
  • Poskytnutí oznámení, které program Windows Media Player použije pro přístup k programu na stanici Windows Media.
  • Poskytnutí odkazů na datové proudy a pravidel pro přecházení mezi protokoly, které program Windows Media Player používá k jejich zpracování..
  • Poskytnutí seznamu položek k přehrání, který určuje pořadí datových proudů vysílaných do programu Windows Media Player.


Použití souboru ASX k přepínání datového proudu bez přerušení

Titulek služby Windows Media Services

Použití souborů ASX k přepínání datového proudu bez přerušení

Ve většině případů je po ukončení příjmu datového proudu před otevřením dalšího datového proudu provedeno načtení do vyrovnávací paměti (pokud je obsah získán ze serveru vysílajícího mediální datové proudy). Funkce služby Windows Media Services umožňují implementaci přepínání datového proudu bez přerušení. Tím je zkrácena doba načítání do vyrovnávací paměti a je zajištěn téměř okamžitý příjem dalšího obsahu. Toto přepínání datového proudu je možné implementovat pouze pomocí souborů ASX.

Chcete-li přepínání datového proudu bez přerušení použít, je třeba, aby kodér do datového proudu zahrnul příkaz skriptu typu OpenEvent spolu s názvem události definované v prvku Event v souboru ASX. V okamžiku, kdy program Microsoft Windows Media Player obdrží příkaz skriptu z kodéru, načte obsah prvku Event v souboru ASX a otevře datový proud definovaný v tomto prvku. Program Windows Media Player tyto informace uchová, dokud nepřijme událost se stejným názvem ve formátu Event název_události. Po obdržení jmenované události přepne program Windows Media Player bez přerušení na datový proud, který je již spuštěn a načten do vyrovnávací paměti.


Vytváření seznamu položek k přehrání pomocí souborů ASX

Titulek služby Windows Media Services

Vytváření seznamů položek k přehrání pomocí souborů ASX

Seznam položek k přehrání se skládá z více položek typu Entry v souboru ASX. Program Microsoft Windows Media Player přehraje všechny položky typu Entry zadané v souboru ASX v pořadí, v jakém jsou zde uvedeny, stejným způsobem jako při ručním otevření jednotlivých klipů.

Ukázka jednoduchého seznamu položek k přehrání

<ASX version = "3.0">
    <Title>Nejžádanější tituly dne</Title>
    <Entry><Ref href = "mms://nsserver/obsah/titul1.asf" /></Entry>
    <Entry><Ref href = "mms://nsserver/obsah/titul2.asf" /></Entry>
    <Entry><Ref href = "mms://nsserver/obsah/titul3.asf" /></Entry>
    <Entry><Ref href = "mms://nsserver/obsah/titul4.asf" /></Entry>
</ASX>


Windows Media Technologies Glossary

Titulek služby Windows Media Services

Glosář technologie Windows Media

Tento glosář obsahuje mnoho užitečných výrazů, které umožňují lépe pochopit technologii Windows Media.

  • A—B
  • C—H
  • I—O
  • P—T
  • U—Z

A—B

adresa IP (Internet Protocol)
Adresa IP je jedinečné 32bitové číslo každého počítače nebo zařízení v síti Internet. Toto číslo určuje fyzické umístění nebo uzel v síti.
adresa UNC (Universal Naming Convention)
Je také označována jako adresa podle konvence UNC. Jde o konvenci pro zadávání adresářů, serverů a dalších prostředků v síti. Podle následujícího příkladu lze název počítače zadat pomocí dvou lomítek // nebo dvou zpětných lomítek \\ a cestu nebo úrovně adresářů v počítači pomocí jednoduchých lomítek: \\počítač\adresář.
adresář pro publikování
Virtuální adresář používaný k uložení obsahu, který je klientům k dispozici, nebo pro přístup k datovému proudu s živým vysíláním. Přístup k adresáři pro publikování lze získat pomocí adresy URL.
alias
Název zastupující adresu URL. Pokud například vytvoříte stanici, je možné použít alias k určení informací, které definují spojení mezi součástmi Windows Media Server Components a programem Windows Media Encoder. Například: Datový_proud1 je alias pro adresu URL msbd://server:port. Název Datový_proud1 lze do pole Alias zadat při vytváření stanice. Součásti Windows Media Server Components rozpoznají alias porovnáním aliasu s definicí v kodéru. Používání aliasů je výhodné, protože není nutné pamatovat si neustále se měnící adresy URL. Pokud budete znát alias, bude možné adresu URL vždy správně rozpoznat.
aplikace Microsoft Internet Explorer
Prohlížeč sítě WWW vyvinutý společností Microsoft určený pro operační systém Windows. Služba Windows Media Services používá aplikaci Microsoft Internet Explorer verze 5 několika způsoby. Správce Windows Media například využívá tuto aplikaci k zobrazení stránek WWW, které Správce Windows Media tvoří. Tvůrci obsahu mohou vložit ovládací prvek ActiveX programu Microsoft Windows Media Player na stránku HTML, kterou lze pomocí aplikace Internet Explorer zobrazit.
atribut
V souboru ASX jde o kvalifikátor popisující vlastnost prvku ASX. Soubor ASX může například zahrnovat prvek Repeat (Opakovat), který obsahuje atribut Count (Počet). Tento konkrétní prvek a atribut určuje počet opakování přehrávání části obsahu nebo seznamu položek k přehrání provedených klientem.
autorizace
Postup přidělení nebo odepření přístupových oprávnění uživatelům. Na serveru Windows Media je možné autorizaci požadavků klientů na obsah ASF nastavit.
bezpečnostní brána firewall
Systém nebo kombinace systémů, která vymezuje hranici mezi dvěma nebo více sítěmi a neumožňuje neoprávněným uživatelům přístup do soukromých sítí. Systém bezpečnostní brány firewall kontroluje všechny doručené a odesílané zprávy a ověřuje, zda se shodují s předem nastavenými bezpečnostními kritérii.

C—H

cílová adresa
Adresa IP a port, ze kterých může klient přijímat vysílání Multicast. Pakety, které přicházejí na cílovou adresu IP a port, lze sledovat pomocí nastavení síťové karty klientem.
datový proud
Data, která jsou přenášena prostřednictvím sítě, a libovolné vlastnosti jim přiřazené. Vysílání ve formě datového proudu umožňuje přehrávači začít zpracovávat data hned, bez čekání na stažení celého souboru.
distribuce
Doručování datového proudu ASF z jednoho serveru na druhý. Příklady použití distribuce:
  • Distribuce datového proudu na jiný server, který pak tento datový proud vysílá pomocí vysílání Unicast. Klienti mohou tímto způsobem přijímat datový proud i v části sítě, ve které není povoleno vysílání Multicast.
  • Distribuce datového proudu na server, který umožňuje vysílání datového proudu HTTP. Uživatelé, kteří jsou chráněni bezpečnostní bránou firewall, mohou tímto způsobem přijímat datový proud, který by jinak přijímat nemohli.
  • Distribuce datového proudu z jednoho serveru Windows Media na další za účelem vytvoření více datových proudů vysílání Unicast. Pokud jste například na serveru vyčerpali maximální počet datových proudů, je možné odeslat datový proud na další server, který umožní vysílat tento datový proud pomocí vysílání Unicast dalším klientům.

domovský adresář
Viz kořenový adresář pro publikování.
dosah
Dosah datového proudu u vysílání Multicast. Správce Windows Media umožňuje uživatelům dosah vysílání Multicast nastavit. Dosah datového proudu vysílání Multicast lze nastavit na bezprostřední podsíť nebo rozšířit dosah na celou síť Internet. Míra dosahu je rovna hodnotě TTL (Time-To-Live).
formát ASF (Advanced Streaming Format)
Formát dat určený k vysílání obsahu zvuku a videa, obrázků a příkazů skriptu ve formě datových proudů pomocí paketů prostřednictvím sítě. Obsah ve formátu ASF může představovat soubor ASF nebo datový proud s živým vysíláním vytvořený programem Windows Media Encoder. Obsah ASF, který prochází procesem doručení v síti, se nazývá datový proud ASF.
formát datového proudu
Informace o správném nastavení, které je nezbytné k zajištění odpovídajícího zpracování datového proudu v přehrávači. Tyto informace obsahují nastavení jako je přenosová rychlost, velikost obrázku a použitý kodek. Formáty datového proudu mohou být dány šablonami formátu datového proudu (TSF) nebo se může jednat o vlastní formáty datového proudu. Informace o formátech datového proudu jsou obsaženy v souborech NSC, ASD a ASF.
formát OCX
Název často používaný jako synonymum pro ovládací prvek ActiveX. Formát OCX je název vycházející z přípony názvu souboru ovládacího prvku.
hodnota TTL (Time-To-Live)
U vysílání Multicast představuje hodnotu určující počet směrovačů, jejichž prostřednictvím bude možné vysílání Multicast vysílat, před zastavením předávání tohoto vysílání pomocí směrovačů. Hodnota TTL se rovná hodnotě dosahu.

I—O

kanál
Viz stanice.
karta pro digitalizaci videa
Doplňková karta přidávaná na základní desku, která umožňuje zobrazit v počítači digitalizované obrázky. Pomocí karty pro digitalizaci videa lze do programu Windows Media Encoder načítat živý záznam z kamery nebo výstup z videorekordéru.
klient
Klientem je obvykle software, který vytváří v komunikaci klienta se serverem požadavky. Klientský software vytváří požadavky na připojení a komunikuje se servery.
klient Windows Media
Ovládací prvek ActiveX představovaný programem Microsoft Windows Media Player, který umožňuje přijímat a vykreslit obsah ASF ze součástí Windows Media Server Components. Klient se může nacházet ve stejném počítači jako server nebo může být umístěn v jiném počítači.
kód korekce chyb (ECC - Error Correction Code)
Metoda opravy chyb používaná ve starších verzích služby Windows Media Services. Spolu s datovým proudem jsou odesílána přebytečná (redundantní) data umožňující rozpoznání a kontrolu jednoduchých chyb (velikosti jednoho bitu) v datovém proudu. Aktuální verze služby Windows Media Services umožňuje opravit chyby vysílání pomocí opakovaného odeslání prostřednictvím protokolu UDP.
kodek
Zkratka pro kompresní a dekompresní algoritmus. Jde o algoritmus či schéma používané při záznamu digitálního videa a zvuku. Kodek je například používán při přenosu videa v síti Internet. Video je zkomprimováno v místě odesílání a dekomprimováno v místě doručení. Nástroje Windows Media poskytují pro obsah ASF široký výběr kodeků. Kodek je možné vybrat na základě kvality zvuku, obrazu a požadované velikosti zobrazení.
kodér
Viz program Windows Media Encoder.
kontrola seznamu řízení přístupu (ACL)
Součást zabezpečení systému Microsoft Windows, kterou služba Windows Media Services využívá k ověření přístupových oprávnění klientů ke konkrétnímu souboru nebo adresáři. Správce systému může pomocí kontroly seznamu ACL nastavit omezení přístupu k souborům ASF a adresářům.
korekce barev ICM (Image Color Matching)
Rozhraní aplikací, které obsahuje informace o barvách u jednotlivých zařízení. Umožňuje aplikacím přesně zobrazit, vytisknout a předat barvy dalším uživatelům a aplikacím. Jiné operační systémy mohou využívat jiné schéma shody barev. Obsah videa, který nebyl vytvořen pomocí korekce barev ICM, nebude v počítačích využívajících operační systém Windows zobrazen správně.
kořenový adresář ASF
Viz kořenový adresář pro publikování.
kořenový adresář pro publikování
Kořenový adresář pro publikování obsahu ASF. Program Microsoft Windows Media Player umožňuje přijímat libovolné soubory ASF umístěné v tomto adresáři nebo v jeho podadresářích. Kořenový adresář pro publikování je také adresářem pro publikování na požádání. Na rozdíl od ostatních adresářů pro publikování neumožňuje kořenový adresář pro publikování použití aliasu. Místo aliasu je v adrese URL, která zajišťuje přístup ke kořenovému adresáři pro publikování, uveden název počítače. Kořenový adresář pro publikování se také nazývá kořenový adresář ASF.
metadata
V systému technologie Windows Media jde o informace o obsahu, například názvu, autorovi a autorských právech. Tyto informace jsou obsaženy v souborech ASX.
metasoubor
V systému technologie Windows Media jde o textový soubor, který obsahuje informace týkající se obsahu médií. Služba Windows Media Services využívá tři druhy metasouborů: metasoubory ASD, metasoubory ASX a metasoubory NSC.
místní prvek
Snadno přístupný prvek nebo prvek omezený na určitou oblast. Místní zařízení je v oblasti komunikace to zařízení, ke kterému lze zajistit přístup přímo, nikoli pomocí prostředků komunikačního spojení. Místní operace je v oblasti zpracování informací operace, kterou lze místo vzdáleného počítače provést pomocí snadno přístupného místního počítače. Například počítač se serverem, na kterém je nainstalována služba Windows Media Services, je z hlediska tohoto serveru místní počítač.
model DCOM (Distributed Component Object Model)
Rozšíření modelu COM (Component Object Model). Model DCOM umožňuje přímou komunikaci softwarových součástí mezi sebou v síti (včetně sítě Internet a sítí intranet) spolehlivým, bezpečným a výkonným způsobem.
modul Plug-In Windows Media pro program Adobe Premiere
Nástroj, který tvůrcům obsahu umožňuje použít k vytvoření obsahu ASF technologie Windows Media program Adobe Premiere.
na požádání
Způsob vysílání uloženého obsahu médií, který je k dispozici pro vysílání v systému služby Windows Media Services. Služba Windows Media Services umožňuje vysílat uložený obsah z adresáře pro publikování nebo obsah s živým vysíláním pomocí programu Windows Media Encoder.
nástroj ASFEditor
Viz program Windows Media Author.
nástroj ASFCheck
Nástroj příkazového řádku, který umožňuje rozpoznat a opravit některé problémy často se objevující v souborech ASF verze 1.0.
nástroj ASFChop
Nástroj příkazového řádku umožňující oříznout začátek a konec datového proudu ASF ukládaného programem Windows Media Encoder.
nástroj VidToASF
Nástroj příkazového řádku, který umožňuje rychlé převádění upravených souborů AVI nebo MOV na soubor ASF, který je možné uložit na serveru Windows Media a vysílat klientům ve formě datového proudu.
nástroj WavToASF
Nástroj příkazového řádku, který umožňuje rychlé převádění upravených souborů WAV na soubor ASF, který lze uložit na serveru Windows Media a vysílat klientům v podobě datového proudu.
nástroje Windows Media
Sada nástrojů, které umožňují vytvořit obsah ASF pro službu Windows Media Services. Nástroje zahrnují program Windows Media Encoder, program Windows Media Author a program Windows Media ASF Indexer, nástroje pro převod VidToASF a WavToASF a nástroje pro práci se soubory ASFCheck a ASFChop.
objekt datového proudu
Data představující jednotlivý typ dat v datovém proudu ASF (například komprimované snímky videa).
objekt Payload
Jednotka dat obsahující jeden nebo více objektů datového proudu.
obsah
Data vysílaná klientovi nebo klientům ze serveru pomocí vysílání Unicast nebo Multicast. Obsah může tvořit prezentace s živým zvukem nebo videem, uložené zvukové soubory nebo soubory s videozáznamy, obrázky a prezentace. Chcete-li vysílat určitý obsah ze serveru ve formě datového proudu, je nutné tento obsah převést do formátu ASF. Servery Windows Media umožňují vysílat obsah v podobě datových proudů ASF s živým vysíláním nebo obsah představovaný uloženými soubory ASF.
odkazy na adresy URL
Sada pokynů prohlížeče, pomocí kterých lze změnit obsah zobrazený na stránce WWW bez ohledu na stav zobrazení. Umožňuje uživateli přeskočit na další stránku, aniž by bylo nutné čekat na úplné vykreslení předchozí stránky.
oprava chyb
Metoda řízení počtu chyb přenosu dat v jednosměrném komunikačním systému. Společně s daty jsou navíc odesílány další informace, které přijímající strana využívá ke kontrole a opravě dat.
ověřování
Postup ověřování přihlašovacích informací uživatelů. Na serveru Windows Media lze před poskytnutím přístupu k obsahu ASF a datovým proudům ASF nastavit ověřování klientů.
ovládací prvky ActiveX
Ovládací prvky využívající technologii ActiveX. Tyto ovládací prvky lze stáhnout automaticky ze stránky WWW a spustit v prohlížeči sítě WWW.
oznámení
Jednoduchý soubor s příponou ASX obsahující informace o adrese URL datového proudu. Soubory oznámení jsou ve Správci Windows Media vytvořeny společně s adresářem pro publikování vysílání Unicast nebo stanicí vysílání Multicast. Klientovi je umožněno rychle načíst soubor oznámení, otevřít datový proud ASF v adresáři pro publikování vysílání Unicast nebo extrahovat adresu URL k datovému proudu ASF ze souboru NSC a přehrát program stanice vysílání Multicast.

P—T

paket
Jednotka dat přenesená prostřednictvím sítě. Paket má pevně danou velikost a je směrován mezi zdrojem a cílem. Obsahuje binární informace představující data i záhlaví, které obsahuje identifikátor (ID), zdrojovou adresu a cílovou adresu.
port
Umístění na serveru, ze kterého je obsah ve formě datového proudu vysílán klientovi. Port je představován číslem, které je částí adresy URL. Spuštěné součásti Windows Media Server Components jsou vázány na určité porty. Ve výchozím nastavení je služba Windows Media Unicast Service vázána na port 1755 a služba Windows Media Station Service na port 7007. Pokud je pro některou službu povoleno vysílání datového proudu HTTP, bude službou nastaveno na portu 80. Port 80 je při vysílání datového proudu pomocí protokolu HTTP upřednostňován. Úpravou registru lze pro libovolnou součást Windows Media Server Component používané porty změnit.
program
Jeden nebo více datových proudů, které součásti Windows Media Server Components spravují jako jednu položku. Pod názvem program si lze představit schránku obsahující datové proudy.
program Microsoft Windows Backup
Nástroj, který umožňuje chránit data v případě náhodné ztráty, pokud v systému dojde k selhání hardwaru nebo úložiště.
program Microsoft Windows Media Player
Klientský program (ovládací prvek), který přijímá média vysílaná ze serveru Windows Media ve formě datového proudu. Tento ovládací prvek je možné spustit jako samostatný klientský program nebo ho lze vložit na stránku WWW, do programu aplikace Visual C++ nebo programu aplikace Microsoft Visual Basic, který využívá ovládací prvek ActiveX daného klienta. Program Microsoft Windows Media Player je první verzí univerzálního přehrávače.
program Windows Media ASF Indexer
Nástroj určený pro operační systém Windows, který je určen k odstranění částí datových proudů ASF uložených programem Windows Media Encoder. Program Windows Media ASF Indexer lze také použít k úpravě vlastností, značek a příkazů skriptu.
program Windows Media Author
Nástroj grafického rozhraní určený k vytváření a testování zvukového proudu s obrázky. Tento nástroj umožňuje kombinovat a synchronizovat zvukové soubory a soubory s obrázky. Objekty (zvuky, obrázky a adresy URL) lze pomocí tohoto nástroje upravovat tak, aby se během přehrávání zobrazovaly v požadovanou dobu. Tento nástroj využívá technologii společnosti Digital Renaissance, Inc.
program Windows Media Encoder
Funkce technologie Windows Media určená k vytváření datových proudů ASF s živým vysíláním. Program Windows Media Encoder převede živý obsah zvuku a videa na datový proud ASF a umožní tento datový proud šířit prostřednictvím určitého portu. Datový proud ASF lze pomocí programu Windows Media Encoder také uložit jako soubor ASF. Program Windows Media Encoder umožňuje distribuovat datový proud ASF pomocí protokolů MSBD a HTTP.
protokol
Sada formátů a postupů, které počítačům umožňují výměnu informací. Služba Windows Media Services používá protokoly HTTP, MMS a MSBD.
protokol (log)
Soubor určený ke shromažďování a ukládání dat o událostech služby Windows Media Services. Informace o vysílání Unicast, vysílání Multicast a klientech lze protokolovat pomocí Správce Windows Media.
protokol MMS (Microsoft Media Server)
Protokol používaný k vysílání souborů ASF ze serveru Windows Media.
protokol MSBD (Media Stream Broadcast Distribution)
Protokol používaný programem Windows Media Encoder, který je zdrojem datového proudu, například msbd://název_serveru. Tento protokol také slouží k vysílání pomocí služby Windows Media Station Service na server pro uložení obsahu. Používá se i při distribuci ze serveru na jiný server.
protokol UDP (User Datagram Protocol)
Protokol zásobníku protokolu TCP/IP pro přenos bez spojení, který lze, stejně jako protokol TCP, spustit v horní vrstvě sítě IP.
proxy server
Počítač se serverem, který řídí provoz založený na síti WWW mezi místní sítí a sítí Internet nebo dalšími sítěmi intranet.
prvek
V souboru ASX představuje entitu určující konkrétní nastavení nebo akci pro klienta. Prvky lze upravit pomocí atributů. Prvek ref například obsahuje atributy, které definují adresu URL odkazující na konkrétní obsah.
přehrávač
Klientský program (ovládací prvek), který přijímá obsah vysílaný ze serveru Windows Media. V rámci celé nápovědy online se tento výraz vztahuje na program Microsoft Windows Media Player.
přecházení mezi adresami URL
Metoda přecházení umožňující určit další servery Windows Media, které obsahují stejný obsah. Pokud například první značka REF v souboru ASX určuje soubor ASF na serveru pes1 a druhá značka REF určuje kopii tohoto souboru na serveru pes2, může program Windows Media Player použít k získání souboru oba servery. Pokud je server pes1 zaneprázdněn nebo není funkční, připojí se program Windows Media Player automaticky k serveru pes2.
přecházení mezi protokoly
Postup umožňující přepnutí z jednoho protokolu na jiný v případě, že se připojení k serveru Windows Media pomocí určitého protokolu nezdaří. Jestliže například klient vysílá požadavek na obsah ASF pomocí protokolu MMS, pokusí se server vysílat obsah datového proudu ASF pomocí protokolu UDP. Pokud se spojení pomocí tohoto protokolu nezdaří, pokusí se server vysílat obsah datového proudu pomocí protokolu TCP. Jestliže se spojení nezdaří ani pomocí tohoto protokolu, pokusí se server použít protokol HTTP (je-li použití protokolu HTTP povoleno). Pokud je vysílání požadavků na obsah ASF provedeno pomocí protokolu MMSU (protokol MMS za použití protokolu UDP) nebo protokolu MMST (protokol MMS při použití protokolu TCP), nelze přecházení mezi protokoly využít.
přecházení pro vysílání Unicast
Postup, podle kterého se program Microsoft Windows Media Player řídí v případě, že ze stanice na serveru Windows Media nelze přijímat vysílání Multicast. Program Windows Media Player někdy nemůže přijímat vysílání Multicast z různých příčin, například z důvodu chybějících směrovačů umožňujících v síti vysílání Multicast. Jestliže program Windows Media Player nemůže přijímat vysílání Multicast, použije pro připojení k serveru a vyslání požadavku na datový proud vysílání Unicast adresu URL přecházení pro vysílání Unicast, kterou obsahuje soubor NSC.
přenosová rychlost
Rychlost, jakou lze binární obsah vysílat ve formě datového proudu prostřednictvím sítě. Většinou se měří v kilobitech za sekundu (kb/s), například 28,8 kb/s. V programu Windows Media Encoder a ve Správci Windows Media lze přenosovou rychlost obsahu ASF nastavit.
příkazy skriptu
Speciální pokyny odesílané klientovi, které jsou zahrnuty v datových proudech ASF. Program Microsoft Windows Media Player předává příkazy skriptu zařízení nebo aplikaci, která tyto příkazy provede. Příkazy skriptu jsou využívány například k vyvolání určitých souborů nebo navigaci na určitý server WWW.
režim distribuce
Nastavení součástí Windows Media Server Components, které určuje, zda budou tyto součásti datový proud ASF vysílat pomocí vysílání Multicast, distribuovat jej pomocí vysílání Unicast nebo zda budou použity obě možnosti. Jestliže je režim distribuce nastaven pouze na vysílání Multicast, bude server vysílat datový proud ASF pomocí vysílání Unicast i Multicast. Pokud je režim distribuce nastaven pouze na distribuci, doručí server na základě požadavku datový proud ASF serveru, který bude tento datový proud ASF vysílat. Vyberete-li obě možnosti, budou k dispozici oba režimy, režim distribuce i režim vysílání Multicast.
rozhraní ISAPI (Internet Server API)
Konstrukční základ pro vytváření dynamických knihoven DLL (Dynamic Link Library) zajišťujících funkce sítě Internet na straně serveru. Služba Windows Media Services používá rozhraní ISAPI pro jednu z možností zabezpečení.
rozšíření Windows Media Presenter pro aplikaci Microsoft PowerPoint 97
Funkce technologie Windows Media, která je k dispozici v aplikaci Microsoft PowerPoint 97 a která této aplikaci umožňuje připojení k programu Windows Media Encoder. Prezentace jsou odesílány na server Windows Media, odkud je lze distribuovat do klientských počítačů.
Rychlé nastavení
Skupina průvodců, která v technologii Windows Media slouží k provedení určitých úkolů (například konfiguraci programu Windows Media Encoder a vytvoření stanic nebo adresářů pro publikování).
rychlost zobrazování snímků (frekvence snímků)
Rychlost, jakou se mění jednotlivé snímky. Vysoká rychlost zobrazování snímků obecně poskytuje vyšší kvalitu obrazu.
seznam (seznam položek k přehrání)
Seznam datových proudů, které program Microsoft Windows Media Player souvisle přehrává. Služba Windows Media Services podporuje dva typy seznamů - seznam položek na straně klienta a seznam položek na straně serveru.
  • Seznam položek na straně serveru je přehráván jako součást programu stanice. Seznam položek k přehrání lze vytvořit ve Správci Windows Media na stránce Stanice vysílání Multicast pomocí tlačítka Datové proudy. Seznam položek na straně serveru může obsahovat adresy URL odkazující na datové proudy, včetně souborů ASF.
  • Seznam položek na straně klienta je soubor ASX, který obsahuje více položek typu Entry. Program Windows Media Player přehrává položky seznamu v pořadí, ve kterém jsou uvedeny v souboru ASX.

síť intranet
Síť patřící určité organizaci. Přístup k této síti je umožněn pouze pracovníkům této organizace. Síť intranet, která je připojena k síti Internet, je obvykle chráněna bezpečnostní bránou firewall nebo jiným zařízením.
síť ISDN (Integrated Services Digital Network)
Digitální telefonní a telekomunikační síť určená k přenosu hlasu, textu, obrázků a přenosu videa vysokou rychlostí pomocí vysílání digitálně kódovaných signálů.
síť umožňující vysílání Multicast
Síť obsahující směrovače, které jsou schopny převádět adresy IP třídy D.
sledování
Sledování určité adresy IP vysílání Multicast. Program Windows Media Player sleduje adresu IP vysílání Multicast a načítá tak data, které jsou vysílána ze serveru.
sledování událostí adresáře pro publikování
Nástroj, který umožňuje sledovat a zobrazit události vysílání Unicast na serveru. Nástroj Sledování událostí adresáře pro publikování přesněji řečeno zobrazuje činnosti událostí vysílání Unicast na serveru (události adresáře pro publikování).
služba FTS (File Transfer Service)
Funkce služby Windows Media Services, která zajišťuje odesílání souborů v síti pomocí vysílání Multicast k ovládacímu prvku Active X (soubor Nsfile.ocx) umístěnému v klientském počítači.
služba Windows Media Monitor Service
Jedna ze služeb Windows Media Component Services.
služba Windows Media Program Service
Jedna ze služeb Windows Media Component Services.
služba Windows Media Services
Jiný název pro součásti Windows Media Server Components, které lze použít k vysílání prezentací obsahujících živý zvuk a video a uložených souborů do klientských počítačů pomocí vysílání Multicast a Unicast. Zahrnuje služby Windows Media Component Services, které lze spustit na serveru Windows Media, a Správce Windows Media, který je určen ke správě těchto služeb.
služba Windows Media Station Service
Jedna ze služeb Windows Media Component Services, která umožňuje vysílání Multicast, distribuci a ukládání datových proudů ASF. Tato služba přidělí každé stanici datový proud ASF jako vstup a tímto způsobem umožní spravovat více stanic a nasměrovat datový proud přímo na adresu vysílání Multicast, jeden nebo více distribučních serverů, pevný disk nebo použít kombinaci všech tří možností. Služba Windows Media Unicast Service je podobná funkce, kterou lze použít k vysílání datových proudů pomocí vysílání Unicast.
služba Windows Media Unicast Service
Jedna ze služeb Windows Media Component Services, která umožňuje vysílat datové proudy ASF pomocí vysílání Unicast. Tato služba umožňuje správu adresářů pro publikování, ke kterým se klienti požadující příjem datových proudů kontinuálního vysílání Unicast nebo datových proudů vysílání Unicast na požádání připojí. Služba Windows Media Station Service je podobná funkce, kterou lze použít k vysílání datových proudů ASF pomocí vysílání Multicast.
služby Windows Media Component Services
Skupina služeb, které lze spustit na serveru Windows Media. Tyto služby umožňují vysílat prezentace obsahující živý zvuk a video a uložené soubory na klientské počítače pomocí vysílání Multicast a Unicast.
směrovač
Zařízení, které umožňuje propojení dvou nebo více sítí a přenášení dat dále. Směrovač určí umístění cílového počítače a nejvhodnější způsob přenosu dat do tohoto počítače.
snímek
Jeden obrázek z určitého množství po sobě následujících obrázků, které tvoří obsah videa.
soubor ASF (soubor s příponou ASF)
Soubor ve formátu ASF obsahující zvuk nebo video.
soubor popisovače datového proudu ASF (ASD)
Konfigurační soubor vytvořený v programu Windows Media Encoder a určený pro tento program. Tento soubor obsahuje nastavení kodéru popisující vlastnosti multimediálního datového proudu. Soubor je také učen pro službu Windows Media Station Service, která jej využívá jako definici formátu datového proudu podporovaného danou stanicí.
soubor programu Windows Media (NSP)
Soubor obsahující informace o programu služby Windows Media Services, používaný především k zálohování a obnovování definicí programů služby Windows Media Services.
soubor přesměrovače datového proudu ASF (ASX)
Metasoubor ASX poskytující informace programu Windows Media Player, který je využívá k přijímání datových proudů vysílání Unicast, datových proudů vysílání Multicast a dalších podporovaných médií ze sítí intranet a sítě Internet. Tyto soubory lze pomocí programu Windows Media Player rychle načíst. Obsahují informace sloužící k následujícím účelům:
  • Přenos ovládacího prvku z prohlížeče HTTP na ovládací prvek programu Windows Media Player za účelem vysílání datových proudů přímo do programu Windows Media Player.
  • Poskytnutí oznámení programu Windows Media Player, které lze použít pro přístup k programu na stanici Windows Media.
  • Poskytnutí odkazů na datové proudy a pravidel pro přecházení mezi protokoly, které program Windows Media Player používá k jejich zpracování.
  • Poskytnutí seznamu, který určuje pořadí vysílaných datových proudů v programu Windows Media Player.

soubor přesměrovače zvukových souborů Windows Media (WAX)
Speciální typ metasouboru ASX, který je určen pro použití se soubory WMA. Soubor WAX obsahuje informace o umístění souboru WMA na serveru Windows Media a o vlastnostech souboru.
soubor stanice Windows Media (NSC)
Soubor, který přehrávači poskytuje popis stanice. Přístup přehrávače k souboru stanice probíhá nepřímo prostřednictvím souboru ASX, který klientovi poskytne odkaz na určitý soubor NSC.
soubor WMA (Windows Media Audio)
Speciální typ souboru ve formátu ASF, který je určen pouze pro zvukový obsah kódovaný pomocí kodeku Windows Media Audio.
součásti Windows Media Server Components
Jiný název pro službu Windows Media Services, kterou lze použít k vysílání prezentací obsahujících živý zvuk a video a uložených souborů do klientských počítačů pomocí vysílání Multicast a Unicast. Zahrnují služby Windows Media Component Services, které lze spustit na serveru Windows Media, a Správce Windows Media, který slouží ke správě těchto služeb.
Správce Audio Compression Manager (ACM)
Správce ovladačů zařízení, který řídí použití programů a aplikací pro přehrávání nebo záznam zvuků. Správce ACM umožňuje správu následujících typů ovladačů:
  • ovladače (kodeky) pro kompresi a dekompresi,
  • ovladače převaděčů formátu,
  • ovladače filtrů.

Jestliže byl zdrojový soubor vytvořen v počítači, který nevyužívá operační systém Windows, je možné, že nebude využívat kodek ACM a z tohoto důvodu nebude možné soubor technologií Windows Media zpracovat.

Správce Windows Media
Program pro správu založený na technologii sítě WWW, který je určen ke sledování využití služeb Windows Media Component Services, správě obsahu a konfiguraci systému v reálném čase.
stanice
Zadané umístění, ze kterého přehrávač přijímá datové proudy. V podstatě jde o adresu IP a port. Součásti Windows Media Server Components používají pouze stanice s datovými proudy ASF. Informace o stanici jsou ukládány jako soubor s příponou NSC.
šablona formátu datového proudu (TSF - Template Stream Format)
V technologii Windows Media představuje tato šablona předdefinovanou skupinu nastavení, která různým typům obsahu a přenosovým rychlostem přiřazuje odpovídajícími zvukové kodeky a videokodeky. Program Windows Media Encoder umožňuje pomocí této funkce rychle nakonfigurovat kodér a vytvořit obsah ASF.
šířka pásma
Množství dat, které lze přenést za určitou dobu. Větší šířka pásma znamená v počítačové síti rychlejší přenos dat. Šířka pásma sítě se vyjadřuje v bitech za sekundu (b/s).

V prostředí služby Windows Media Services lze pomocí Správce Windows Media určit omezující podmínky šířky pásma pro řadu funkcí, včetně celkové šířky pásma vysílání Unicast ze serveru, maximální šířky pásma pro samostatný datový proud vysílání Unicast ze serveru a kontinuální šířky pásma, která je využívána pro přenos souborů pomocí vysílání Multicast ze serveru.

technologie ActiveX
Technologie společnosti Microsoft, která umožňuje různým programům sdílet informace. Technologie ActiveX rozšiřuje architekturu založenou na operačním systému Microsoft Windows o funkce a možnosti sítě Internet a podnikových sítí intranet. Umožňuje vývojářům využívat v programech a na stránkách WWW uživatelskou interaktivitu.
technologie Windows Media
Skupina programů umožňující vysílání médií ve formě datových proudů, která zahrnuje službu Windows Media Services, nástroje Windows Media a program Windows Media Player. Nástroje Windows Media umožňují vytvořit obsah ASF, který lze poskytnout klientským počítačům pomocí služby Windows Media Services a přehrát pomocí programu Windows Media Player.
titulek
Funkce, která odesílá s datovým proudem ASF soubor ve formátu SAMI (Synchronized Accessible Media Interchange), což je soubor se skrytými titulky. Titulkování je funkce usnadnění, která umožňuje zobrazit spolu s videem a zvukem titulky, podobně jako skryté titulky, kterými jsou doprovázeny některé televizní programy. Tato funkce také umožňuje zobrazit titulky v jiném jazyce.

U—Z

více přenosových rychlostí videa
Funkce technologie Windows Media, která podporuje vytváření a vysílání až šesti kódovaných datových proudů videa v rámci jednoho datového proudu ASF. Použijete-li více přenosových rychlostí videa v programu Windows Media Encoder, bude možné vytvořit obsah ASF, který bude obsahovat různé datové proudy videa určené pro různé šířky pásma pro cílová publika s vysokými i nízkými šířkami pásma. Při vytváření obsahu využívajícího více přenosových rychlostí pro publika s nízkou šířkou pásma mohou mít datové proudy videa rozsah od 18 kb/s do 300 kb/s. Cílová publika s vysokou šířkou pásma mohou používat datové proudy videa v rozsahu od 81 kb/s do 10 Mb/s. Formáty pro obě cílová publika zahrnují oddělené datové proudy pro zvuk. Během kódování více přenosových rychlostí videa je kódován ještě jeden pojistný datový proud videa, který je vychází z procentuální části nejnižší vybrané šířky pásma. Při příjmu tohoto datového proudu server na základě dostupné šířky pásma sítě určí šířku, kterou bude datový proud vysílán. Více přenosových rychlostí videa není podporováno na standardních serverech HTTP.
vlastnost
Charakteristika objektu - například datového proudu. Program Windows Media Encoder například zobrazuje vlastnosti datového proudu, jako jsou použité kodeky a šířka pásma, na stránce vlastností.
výplň
Prázdné místo, které je za účelem udržení konstantní velikosti paketů přidáváno k některým paketům v obsahu datového proudu. Služba Windows Media Services podporuje různou délku paketů. Program Windows Media Encoder však délku paketů omezuje na konstantní délku, aby byla zajištěna kompatibilita s nižšími verzemi služby Windows Media Services.
vyrovnávací paměť
Část paměti vyhrazená jako zprostředkující úložiště, ve kterém jsou data během čekání na přenos mezi dvěma umístěními dočasně zadržena. Vyrovnávací paměť zajišťuje nepřerušený tok dat mezi dvěma počítači.
vysílání (kontinuální vysílání)
Způsob, jakým může být klientovi poskytnut datový proud. Datový proud vysílání může mít podobu vysílání Multicast nebo Unicast. Při použití kontinuálního vysílání je klient pasivní a není mu umožněno řídit spuštění a zastavení datového proudu. Připojení na požádání naopak umožňuje datový proud řídit. Klient je aktivní a datový proud lze spustit i zastavit.
vysílání Multicast
Spojení jednoho serveru s více klienty, které umožňuje přijímat stejný datový proud ze serveru většímu počtu klientů. Jestliže chcete používat vysílání Multicast, je nutné zajistit klientům přístup k síti umožňující vysílání Multicast. Vysílání Unicast naproti tomu představuje spojení jednoho serveru s jedním klientem, kdy každý klient přijímá ze serveru samostatný datový proud.
vysílání Multicast (kontinuální)
Doručování jednoho datového proudu ze serveru Windows Media více klientům. Datový proud je možné zobrazit sledováním adresy IP, prostřednictvím které probíhá vysílání Multicast daného datového proudu. Z pohledu klienta je kontinuální vysílání Multicast činnost bez spojení, protože klient není spojen se serverem Windows Media.
vysílání Unicast
Spojení klienta a serveru, kdy klient přijímá ze serveru uložený obsah datového proudu na požádání nebo vysílání živého obsahu. Další klienti nemají k tomuto datovému proudu přístup. Naproti tomu u vysílání Multicast je jeden datový proud k dispozici více klientům.
vysílání Unicast (kontinuální)
Spojení typu point-to-point k adresáři pro publikování na serveru Windows Media, které inicializuje klient.
vysílání Unicast na požádání
Spojení typu point-to-point k adresáři pro publikování, které inicializuje klient. U vysílání Unicast vysílá server na požádání uživateli uložený obsah.
vzdálený prvek
Prvek, který se nenachází v těsné blízkosti nebo k němu není umožněn přímý přístup. Počítač nebo jiné zařízení na jiném místě (místnost, budova či město), ke kterému je zajištěn přístup některým typem komunikačního spojení. Správce Windows Media lze například spustit v jiném počítači (vzdáleném počítači) než v počítači se serverem Windows Media a vzdálený správce může tímto způsobem zajistit správu serveru. Program Windows Media Encoder je také možné spustit ze vzdáleného počítače.
zabezpečení
Postup řízení přístupu k prostředkům na základě pověření a přístupových oprávnění uživatelů. V prostředí služby Windows Media Services znamená zabezpečení omezení a řízení přístupu k součástem Windows Media Server Components, Správci Windows Media a obsahu Windows Media (uloženému i vysílanému). Služba Windows Media Services obsahuje integrované mechanismy zabezpečení, které spolupracují se systémem zabezpečení NTLM společnosti Microsoft. Služba Windows Media Services podporuje oba typy ověřování - ověřování na straně klienta i ověřování na straně serveru.
značka
Ukazatel na určité místo v souboru ASF, který lze vyjádřit pomocí času. Program Microsoft Windows Media Player používá značky k přímému vyhledání konkrétního bodu na časové ose v souboru ASF. Chcete-li zobrazit určitou část souboru ASF znovu, lze značky při přehrávání souboru ASF použít k přeskočení vpřed na další značku nebo zpět na předchozí značku.
zvukový proud s obrázky
Datový proud obsahující kombinaci zvuku se synchronizovanými obrázky, které dohromady tvoří prezentaci. Tuto prezentaci lze spustit i při použití nižších šířek pásma.


Technologie Digital Rights Management

Technologie Digital Rights Management (DRM) slouží k zabezpečení obsahu a správě práv pro přístup k obsahu. Tato technologie je stále ve fázi vývoje a výzkumu. Zavedení programu Windows Media Rights Manager je však prvním krokem k ochraně obsahu digitálních médií před pirátstvím. Pomocí programu Windows Media Rights Manager můžete ochránit a zabezpečit zvukový obsah nebo obsah videa zašifrováním zdrojových souborů ve formátu ASF, MP3 a WAV do souborů ASF v balíčcích a poskytnutím licence uživatelům. Implementace této funkce vám umožní zjistit, kdo vlastní kopie vašeho obsahu, a každý distribuovaný obsah opatřit digitálním podpisem.

Používání programu Windows Media Rights Manager ovlivní celý systém vysílání datových proudů. Tento přehled je určen autorům obsahu, provozovatelům serverů WWW a koncovým uživatelům. Další informace naleznete na stránce Windows Media Technologies na serveru WWW společnosti Microsoft nebo v dokumentaci k programu Windows Media Rights Manager.


Autoři obsahu

Program Windows Media Rights Manager umožňuje zabezpečit obsah dříve, než ho pomocí programu Windows Media Packager odešlete poskytovatelům služeb Internetu. Pokud chcete při vytváření obsahu ve formátu ASF použít u daného souboru ASF technologii DRM, máte dvě možnosti:

  • použít pro vytvoření souboru ASF nástroje Windows Media a pomocí programu Windows Media Packager vytvořit soubor balíčku,
  • pomocí programu Windows Media Packager vytvořit soubor balíčku přímo.

Při vytváření souboru balíčku probíhají tyto činnosti:

  • soubor je zašifrován pomocí soukromého klíče,
  • je nastavena adresa URL licenčního serveru,
  • je nastavena adresa URL oficiálního serveru WWW,
  • do souboru jsou zahrnuty všechny nápisy a obrázky,
  • jsou nastaveny vlastnosti pro titul, interpreta, autorská práva a žánr.

Pokud je soubor již ve formě balíčku, nelze ho pomocí nástrojů Windows Media upravovat. Vlastnosti souboru jsou nastaveny nelze je měnit. Pokud tedy chcete určitý obsah upravovat později, vytvořte nejprve soubor pomocí nástrojů Windows Media, uložte záložní kopii a potom vytvořte soubor balíčku.


Publikování ve WWW

Program Windows Media Rights Manager obsahuje Průvodce serverem, pomocí kterého můžete obsah balíčku publikovat na serveru WWW. Pokud je obsah již ve formě balíčku, uživatelé potřebují k jeho přehrání platnou licenci. Při pokusu o přehrání obsahu proběhne ověření licence. Jestliže uživatelé nemají ve svém počítači platnou licenci, je spuštěn prohlížeč, ve kterém se zobrazí váš server WWW, na kterém se mohou zaregistrovat. Po registraci je do počítače daného uživatele stažena platná licence s klíčem k rozšifrování a obsah bude přehrán.

Každý vydavatel musí udržovat databáze licencí a uživatelů. Služba Windows Media License Service využívá databázi serveru SQL, proto musíte mít před instalací programu Windows Media Rights Manager nainstalován server SQL. Služba Windows Media Services také musí obsah balíčku vysílat ve formě datového proudu.

Při instalaci programu Windows Media Rights Manager je nainstalován i program Windows Media Packager, který umožňuje spravovat obsah a licence na serveru.


Činnosti uživatelů

Uživatelé potřebují pro přehrávání souborů balíčku program Windows Media Player verze 6.2. Soubory balíčku je možné vysílat ve formě datových proudů ze serveru Windows Media nebo je lze stáhnout a přehrávat místně. Nemá-li uživatel ve svém počítači nainstalovánu příslušnou verzi programu Windows Media Player a pokusí se přehrát chráněný obsah, otevře se okno prohlížeče, ve kterém se zobrazí server pro stahování, odkud může uživatel tento program stáhnout.

Program Windows Media Player zkontroluje, zda má uživatel licenci k přehrání daného obsahu. Pokud uživatel platnou licenci nemá, otevře se okno prohlížeče se stránkou registrace licence na vašem serveru WWW. Uživatel vyplní informace požadované k registraci, je vydána licence a program Windows Media Player pak daný obsah přehraje. Uživatel může obsah přehrávat, dokud je licence platná. O smluvních vztazích licence jsou uživatelé informováni během stahování licence. Licence může být vydána na dobu neomezenou, na dobu určitou nebo na určitý počet přehrání. Pokud však registrovaný uživatel zkopíruje obsah a sdílí ho s dalším uživatelem, musí tento uživatel také projít procesem registrace. Mezi různými počítači nemohou být licence a klíče k rozšifrování kopírovány a sdíleny.

Přehrává-li program Windows Media Player chráněný obsah, zobrazí se uživateli následující informace:

  • titul obsahu,
  • jméno interpreta,
  • upozornění na autorská práva,
  • obrázek s nápisem,
  • videozáznam,
  • ikona legitimity, která označuje, že obsah je chráněn a nebyl zfalšován.

Klepnutím na různé části okna je možné otevřít prohlížeč sítě WWW pro příslušnou adresu URL. Klepnutím na obrázek s nápisem lze například otevřít server WWW distributora a po klepnutí na titul se může otevřít server WWW interpreta.


Další informace

Program Windows Media Rights Manager představuje novou technologii s velkým významem, která slouží ke zpracování zvukového obsahu a obsahu videa. Na stránce Windows Media Technologies na serveru WWW společnosti Microsoft můžete získat příručku Windows Media Rights Manager Requirements and Installation Guide.

V této příručce jsou uvedeny požadavky na hardware a software, které musí být před instalací programu Windows Media Rights Manager splněny. Je zde také popsán průběh instalace programu Windows Media Rights Manager, požadovaná média a formáty souborů s obrázky, nastíněn proces šifrování a vysvětleny vodoznaky a možnosti zadávané před zahájením kódování daného obsahu.

Chcete-li rychle zprovoznit server WWW a využít funkce programu Windows Media Rights Manager, řiďte se pokyny v příručce Quick Start Guide.

Program Windows Media Rights Manager můžete stáhnout ze stránky Windows Media Technologies pro stahování na serveru WWW společnosti Microsoft.


Podrobnosti z právního hlediska

Informace obsažené v tomto dokumentu, včetně adres URL a jiných odkazů na servery WWW, podléhají změnám bez předchozího upozornění. Názvy společností, jména a údaje použité v ukázkách jsou smyšlené. Nemůže být vyvozováno žádné jejich spojení se skutečnou společností, organizací, osobou, událostí či produktem. Uživatel zodpovídá za dodržení všech příslušných zákonů o autorských právech. Bez omezení práv vyplývajících ze zákonů o autorských právech není dovoleno tuto dokumentaci rozširovat po částech ani jako celek, převádet do jakékoli jiné formy, ať mechanicky, nebo elektronicky včetně fotokopírování a snímání, a to pro jakékoli účely, bez předchozího výslovného písemného povolení společnosti Microsoft Corporation.

Společnost Microsoft může vlastnit patenty, přihlášky patentu, ochranné známky, autorská práva a další práva k duševnímu vlastnictví týkající se problematiky popisované v této dokumentaci. Poskytnutím této dokumentace nezískáváte žádná další práva k těmto patentům, ochranným známkám, autorským právům nebo jinému duševnímu vlastnictví.

Ó 1996-1999 Microsoft Corporation. Všechna práva vyhrazena.

Microsoft, MS-DOS, MS, Windows, Windows Media, Windows NT, ActiveX, FrontPage, JScript, Microsoft Press, NetShow, PowerPoint, Visual Basic, Visual C++, Visual InterDev, Visual J++, Win32 and Win32s jsou registrované ochranné známky nebo ochranné známky společnosti Microsoft Corporation ve Spojených státech amerických a v dalších zemích.

Macintosh je registrovaná ochranná známka společnosti Apple Computer, Inc., používaná v rámci licence.

Premiere je registrovaná ochranná známka společnosti Adobe Corporation.

Uvedené názvy dalších produktů nebo společností mohou být ochrannými známkami vlastníků těchto známek.

Na modul runtime jazyka Python Language se vztahují následující podmínky:

Copyright © 1991-1995 by Stichting Mathematisch Centrum, Amsterdam, The Netherlands. Všechna práva vyhrazena. Tímto je poskytnuto povolení k použití, kopírování, úpravám a distribuci tohoto softwaru včetně příslušné dokumentace pro jakékoli účely, pod podmínkou, že všechny kopie budou obsahovat výše uvedené informace o autorských právech a že tyto informace včetně informací o tomto povolení budou obsaženy v dokumentaci, a dále pod podmínkou, že název Stichting Mathematisch Centrum nebo CWI nebudou použity pro reklamní účely v souvislosti s distribucí tohoto softwaru bez předchozího výslovného písemného povolení.