Rozšíření FrontPage Server Extensions

Rozšíření FrontPage Server Extensions jsou sadou tří programů, které automaticky provádějí celou řadu užitečných úloh při správě, vytváření a zobrazování . Bez serverových rozšíření by některé z těchto úloh nebylo možné provést vůbec nebo jen s obtížemi.

Serverová rozšíření lze snadno nainstalovat ve všech populárních operačních systémech, včetně systémů Microsoft Windows NT Server, Digital UNIX a SunOS, což zajišťuje kompatibilitu serverů WWW na více platformách. Serverová rozšíření podporují také nejrozšířenější servery WWW, například servery Microsoft Internet Information Services (IIS), Netscape a WebSite, i servery WWW, které jsou šířeny jako freeware a shareware například společnostmi Stronghold a NCSA.

Správa rozšíření FrontPage Server Extensions se neprovádí přímo. Používá se k tomu jeden z několika nástrojů, jejichž funkce se překrývají. Jedním z nich je modul snap-in FrontPage konzoly MMC.

Podrobnější informace o rozšířeních FrontPage Server Extensions získáte v sadě FrontPage Server Extensions Resource Kit na adrese http://www.microsoft.com/frontpage/wpp/serk. Pokud jsou rozšíření FrontPage Server Extensions nainstalována ve vašem počítači, máte také přístup k této sadě, která je ve výchozím nastavení nainstalována ve složce C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm. Složka \nnnn má číselný název podle jazyka, ve kterém jste rozšíření FrontPage Server Extensions nainstalovali. Například cesta u instalace v češtině je C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1029\default.htm.


Výhody používání rozšíření FrontPage Server Extensions

Rozšíření FrontPage Server Extensions usnadňují autorům serverů WWW používat na vytvářených serverech složité funkce a správcům usnadňují podporu těchto funkcí. Serverová rozšíření umožňují provádět následující operace:

  • Umožňují autorům spolupracovat při vytváření a údržbě , upravovat server WWW přímo v počítači se serverem (a ušetřit tak čas jinak potřebný pro stahování) a snadno na server přidávat funkce, aniž by bylo třeba cokoli programovat.
  • Podporují čítače přístupů, fulltextové vyhledávání, zpracování formulářů elektronické pošty a další funkce, které může autor na server WWW pomocí aplikace FrontPage přidat. Zajistí správnou činnost funkcí, aniž by bylo třeba pro jednotlivé funkce stahovat, kupovat nebo instalovat zvláštní skripty .
  • Lze je používat na běžných serverových platformách, například Windows NT nebo UNIX, i na řadě používaných serverů WWW, jako je například Microsoft Internet Information Services (IIS), WebSite nebo Netscape.
  • Zajišťují automatickou aktualizaci hypertextových odkazů po přesunutí, odstranění nebo přejmenování serveru WWW (na server není třeba přenést celý soubor, stačí přenést pouze název souboru s obsahem stránky).
  • Podporují integraci se sadou Microsoft Office, s aplikací Visual SourceSafe a se serverem Index Server.


Modul snap-in FrontPage konzoly MMC

Modul snap-in FrontPage konzoly MMC je program určený pouze pro systém Windows, který umožňuje spravovat rozšíření FrontPage Server Extensions a . Slouží k , k vytváření , k inovaci serverových rozšíření na serverech WWW, k převádění složek na podřízené servery a naopak, k přepočítávání hypertextových odkazů na a k provádění dalších operací.

Modul snap-in FrontPage konzoly MMC je navržen jako modul konzoly MMC (Microsoft Management Console). Znamená to, že příkazy, listy vlastností a další nástroje potřebné pro správu rozšíření FrontPage Server Extensions jsou přidány do prostředí konzoly MMC. Užitečné také je, že nástroje modulu snap-in FrontPage konzoly MMC vypadají a fungují stejně jako ostatní nástroje .

Jestliže je v počítači nainstalován server Microsoft Internet Information Services (IIS) 4.0 nebo novější, stává se modul snap-in FrontPage konzoly MMC součástí modulu snap-in Správce služeb sítě Internet serveru IIS. Slouží tedy i k rozšíření funkcí modulu snap-in serveru IIS. Pokud je nainstalován jiný server WWW než IIS 4.0 nebo novější, jsou funkce modulu snap-in FrontPage konzoly MMC přidány přímo do konzoly pod názvem Správce serverových rozšíření. Všechny nástroje potřebné pro správu jsou umístěny na jednom místě.

Modul snap-in FrontPage konzoly MMC znamená výrazné vylepšení oproti nástroji Fpsrvwin, který se používal pro správu v předchozích verzích aplikace FrontPage. Pomocí modulu snap-in FrontPage konzoly MMC lze provádět většinu úkolů správy obvykle prováděných pomocí nástrojů Fpsrvadm nebo Fpremadm a některé další operace.

Informace o správě rozšíření FrontPage Server Extensions pomocí nástrojů Fpsrvadm a Fpremadm naleznete v sadě FrontPage Server Extensions Resource Kit na adrese http://www.microsoft.com/frontpage/wpp/serk. Jestliže jsou v počítači nainstalována rozšíření FrontPage Server Extensions, lze také použít sadu FrontPage Server Extensions Resource Kit, která je standardně nainstalována v umístění C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm. Název složky \nnnn tvoří číselný kód jazyka, ve kterém jste rozšíření FrontPage Server Extensions nainstalovali. V případě instalace v češtině bude tedy cesta vypadat takto: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1029\default.htm.


Modul snap-in FrontPage konzoly MMC nahrazuje nástroj FPsrvwin.exe - hlavní rozdíly

V předchozí verzi rozšíření FrontPage Server Extensions byla správa rozšíření obvykle prováděna pomocí nástroje Fpsrvwin. Nástroj Fpsrvwin sloužil k vykonávání úloh správy, jako jsou instalace, kontrola a oprava a odebírání serverových rozšíření ze serveru WWW.

Modul snap-in FrontPage konzoly MMC obsahuje nejčastěji používané funkce nástroje Fpsrvwin a umožňuje navíc provádět tyto akce:

  • nastavit vlastnosti serveru WWW, například výkon, možnosti elektronické pošty, oprávnění ke skriptování a protokoly akcí autorů,
  • vytvořit ,
  • přidat správce,
  • převést složky na podřízené servery WWW a naopak,
  • odstranit podřízené servery WWW,
  • otevřít v aplikaci FrontPage (pokud je aplikace FrontPage nainstalována ve stejném počítači jako server WWW),
  • zadat výchozí ,
  • zapisovat akce autorů do protokolu,
  • přepočítat hypertextové odkazy.


Další dostupné nástroje pro správu rozšíření FrontPage Server Extensions

Modul snap-in FrontPage konzoly MMC je program s grafickým rozhraním, který umožňuje snadnou správu rozšíření FrontPage Server Extensions. Nahrazuje a výrazně zdokonaluje nástroj Fpsrvwin, což byl program pro správu s grafickým rozhraním v předešlých verzích aplikace FrontPage. Modul snap-in FrontPage konzoly MMC však lze spustit pouze v operačních systémech Windows a nelze pomocí něho spravovat serverová rozšíření ze .

Modul snap-in FrontPage konzoly MMC je pouze jedním z několika dostupných nástrojů pro správu rozšíření FrontPage Server Extensions. Tři další nástroje, které poskytují téměř stejné funkce, lze použít v prostředích, kde tento modul nefunguje:

  • Nástroj Fpsrvadm je program spouštěný z příkazového řádku, který lze použít v systému Windows NT a různých operačních systémech UNIX. Tento program slouží ke . Nástroj Fpsrvadm je nainstalován při instalaci rozšíření FrontPage Server Extensions. Nelze jej použít ke správě serverových rozšíření ze vzdáleného počítače.
  • Nástroj Fpremadm je program spouštěný z příkazového řádku, který slouží ke správě rozšíření FrontPage Server Extensions ze vzdáleného počítače. Lze jej však spustit pouze v operačních systémech Windows NT Workstation, Windows NT Server a Windows 95/98, nikoli v systémech UNIX, jako je například Linux a SunOS. Nástroj Fpremadm je nainstalován při instalaci rozšíření FrontPage Server Extensions.
  • HTML Administration Forms jsou formuláře ve formátu HTML sloužící ke vzdálené správě rozšíření FrontPage Server Extensions z prohlížeče sítě WWW.

Další informace o těchto nástrojích získáte v sadě FrontPage Server Extensions Resource Kit na adrese http://www.microsoft.com/frontpage/wpp/serk. Pokud máte v počítači nainstalována rozšíření FrontPage Server Extensions, je sada FrontPage Server Extensions Resource Kit rovněž přístupná. Sada je standardně nainstalována ve složce C:\Program\Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\nnnn\default.htm. Složka \nnnn má číselný název podle jazyka, ve kterém jste nainstalovali rozšíření FrontPage Server Extensions. Například cesta instalace v češtině je C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Serk\1029\default.htm.


Úkoly správy, které lze provádět pomocí modulu snap-in FrontPage konzoly MMC

Pomocí modulu snap-in FrontPage konzoly MMC lze provádět tyto úkoly správy:

  • instalovat na serveru WWW rozšíření FrontPage Server Extensions,
  • pomocí rozšíření FrontPage Server Extensions,
  • kontrolovat a opravovat rozšíření FrontPage Server Extensions na ,
  • aktualizovat rozšíření FrontPage Server Extensions na serveru WWW,
  • odstranit rozšíření FrontPage Server Extensions ze serveru WWW,
  • odstranit rozšířený pomocí rozšíření FrontPage Server Extensions,
  • převést podřízený server WWW na složku a naopak,
  • přepočítat všechny hypertextové odkazy na serveru WWW,
  • přidat správce,
  • povolit nebo zakázat vytváření na serveru WWW,
  • optimalizovat ,
  • zapisovat akce autorů do protokolu,
  • vyžadovat při vytváření obsahu ,
  • určit, zda složka může či nemůže obsahovat spustitelné a programy,
  • povolit ,
  • nastavit možnosti elektronické pošty.

Modul snap-in FrontPage konzoly MMC neumožňuje provádět tyto úkoly správy:

  • spravovat rozšíření FrontPage Server Extensions ze (pro tento typ správy je třeba použít nástroj Fpremadm),
  • provádět (v takovém případě je třeba použít nástroj Fpsrvadm).


Umístění součástí modulu snap-in FrontPage konzoly MMC potřebných ke správě rozšíření FrontPage Server Extensions

Kterou nabídku, příkaz, dialogové okno nebo jinou součást modulu snap-in FrontPage konzoly MMC potřebujete k provedení úlohy a kde tuto součást naleznete?

Ke správě rozšíření FrontPage Server Extensions slouží tři hlavní součásti:

  • Nabídka Nový, ze které můžete vybírat příkazy k vytvoření nového , přidání nového správce a další příkazy v závislosti na položce vybrané ve .
  • Nabídka Úloha, ze které můžete vybírat příkazy ke kontrole chyb a jejich opravám, odebrání a inovaci rozšíření FrontPage Server Extensions a provádění jiných úloh. Položka vybraná ve stromu konzoly určuje, které příkazy se objeví v podnabídce Úloha.
  • Karta Serverová rozšíření umožňuje upravit nastavení rozšíření FrontPage Server Extensions, například možnosti elektronické pošty a nastavení zabezpečení.

V následující tabulce jsou uvedeny úlohy správy, které lze provádět pomocí modulu snap-in FrontPage konzoly MMC, a dále pak nástroje používané pro jednotlivé úlohy a jeho umístění. Výrazy v závorkách se zobrazují pouze tehdy, jestliže je serverem server WWW Microsoft Internet Information Services (IIS) verze 4.0 nebo vyšší.

Úloha | Nástroj a umístění
Rozšíření virtuálního serveru pomocí serverových rozšíření (IIS 4.0 nebo vyšší) | Místní nabídka > Úloha > Konfigurovat serverová rozšíření
Rozšíření virtuálního serveru pomocí serverových rozšíření (ne IIS nebo IIS 3.0) | Místní nabídka > Nový > Server WWW
Vytvoření podřízeného serveru WWW | Místní nabídka > Nový > Server WWW (se serverovými rozšířeními)
Přidání správce | Místní nabídka > Nový > Správce (serveru WWW se serverovými rozšířeními)
Kontrola a oprava serverových rozšíření na serveru WWW nebo podřízeném serveru WWW | Místní nabídka > Úloha > Zkontrolovat serverová rozšíření
Inovace serverových rozšíření na serveru WWW | Místní nabídka > Úloha > Inovovat rozšíření
Odebrání serverových rozšíření z kořenového serveru WWW a jeho podřízených serverů WWW | Místní nabídka > Úloha > Odebrat serverová rozšíření
Přepočet všech hypertextových odkazů na serveru WWW | Místní nabídka > Úloha > Přepočítat server WWW
Odstranění podřízeného serveru WWW | Místní nabídka > Úloha > Odstranit server WWW se serverovými rozšířeními
Převedení složky na podřízený server WWW | Místní nabídka > Úloha > Převést adresář na server WWW s rozšířeními
Převedení podřízeného serveru WWW na složku | Místní nabídka > Úloha > Převést server WWW s rozšířeními na adresář
Povolení nebo zakázání vytváření | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Povolit vytváření obsahu
Povolení správy zdrojů | Místní nabídka > Vlastnosti > karta Serverová rozšíření > pole Správa verzí
Optimalizace výkonu serveru WWW | Místní nabídka > Vlastnosti > karta Serverová rozšíření > pole Výkon
Určení, který skriptovací jazyk bude generován jako výchozí | Místní nabídka > Vlastnosti > karta Serverová rozšíření > pole Skriptování na straně klienta
Nastavení možností elektronické pošty | Místní nabídka > Vlastnosti > karta Serverová rozšíření > Nastavení
Použití nastavení zabezpečení nadřazeného serveru WWW u podřízeného serveru WWW | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Nedědit nastavení zabezpečení
Zápis akcí autorů do protokolu | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Zapisovat akce autorů do protokolu
Ruční nastavení oprávnění | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Spravovat oprávnění ručně
Vyžadování zabezpečení SSL při vytváření | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Vyžadovat při vytváření zabezpečení SSL
Určení, zda složka může obsahovat spustitelné skripty a programy | Místní nabídka > Vlastnosti > karta Serverová rozšíření > zaškrtávací políčko Povolit autorům ukládat spustitelné soubory


Model oprávnění v aplikaci FrontPage

Z důvodu usnadnění správy kontroly přístupu k obsahuje aplikace FrontPage model založených na rolích a užitečné nástroje pro správu, které umožňují jejich nastavení. Model založený na rolích znamená, že oprávnění poskytnutá uživateli závisí na jeho roli (uživatelem může být osoba, skupina nebo počítač).

U každého lze nastavit oprávnění pro uživatele s těmito třemi rolemi:

  • , kterým přidělíte oprávnění k procházení. Jedná se o oprávnění k prohlížení a používání serveru WWW s rozšířeními aplikace FrontPage po jeho publikování na serveru WWW.
  • Autoři, kterým přidělíte oprávnění k vytváření. Tito autoři budou moci otevřít server WWW s rozšířeními aplikace FrontPage a upravovat jeho obsah.
  • Správci, kterým přidělíte oprávnění ke správě. Tito správci budou moci přidávat, inovovat a odebírat rozšíření FrontPage Server Extensions ze serveru WWW s rozšířeními aplikace FrontPage, vytvářet a odstraňovat , zapisovat operace autorů do protokolu, nastavovat oprávnění pro jiné uživatele a provádět jiné úlohy správy.

Oprávnění serveru WWW s rozšířeními aplikace FrontPage jsou hierarchická. Uživatel s oprávněním ke správě má oprávnění k vytváření a procházení. Uživatel s oprávněním k vytváření má oprávnění k procházení.

Ve výchozím nastavení dědí nastavená oprávnění serveru WWW všechny podřízené servery WWW. U podřízeného serveru však můžete nastavit jednoznačná oprávnění, kterými přepíšete oprávnění zděděná z nadřazeného serveru. Díky tomu můžete určit různé úrovně přístupu k jednotlivým podřízeným serverům u jednotlivých uživatelů nebo skupin. Můžete například přidělit stejnému uživateli oprávnění k vytváření u jednoho podřízeného serveru a pouze oprávnění k procházení u jiného.

U kterých uživatelů lze nastavit oprávnění? Odpověď závisí na používaném typu serveru WWW. Server Microsoft Internet Information Services (IIS) poskytuje uživatelské účty ze seznamu účtů systému Windows NT. Oprávnění lze nastavit pouze u uživatelů z tohoto seznamu. Nelze vytvářet nové uživatelské účty. U jiných typů serverů WWW je však seznam uživatelů udržován na serveru a lze vytvářet nové uživatelské účty.

Oprávnění u serveru WWW lze nastavit v aplikaci FrontPage pomocí nástrojů rozšíření FrontPage Server Extensions, jako je například Fpsrvadm, nebo příkazu Oprávnění v nabídce Nástroje.


Způsob spolupráce modulu snap-in FrontPage konzoly MMC s různými servery WWW

Jestliže kromě serveru Microsoft Internet Information Services (IIS) používáte i jiné servery WWW, například WebSite nebo Netscape, zjistíte, že modul snap-in FrontPage konzoly MMC spolupracuje jinak se serverem IIS 4.0 nebo novějším a jinak s ostatními používanými servery (včetně IIS 3.0).

Server IIS 4.0 nebo novější obsahuje modul snap-in, který je určen ke konzolu Microsoft Management Console (MMC). Modul snap-in FrontPage konzoly MMC umožňuje spolupráci s modulem snap-in serveru IIS verze 4.0 nebo novější. Jestliže je tedy v počítači nainstalován server IIS 4.0 nebo novější, budou funkce modulu snap-in aplikace FrontPage plně integrovány s funkcemi modulu snap-in serveru IIS.

Pokud jste již pracovali s modulem snap-in MMC serveru IIS, zjistili jste, že byly do nabídky Akce a do místních nabídek přidány další příkazy a že na list Vlastnosti byla přidána stránka vlastností Serverová rozšíření. Tato nová funkce byla přidána z modulu snap-in FrontPage konzoly MMC. Jestliže se některé funkce překrývají, zobrazí se pouze příslušný příkaz serveru IIS. Ve jsou v seznamu serveru IIS zobrazeny všechny serveru IIS - i ostatní servery WWW.

Je-li modul snap-in FrontPage konzoly MMC nainstalován na jiném serveru WWW než IIS 4.0 nebo novějším, nebudou jeho funkce integrovány s funkcemi tohoto serveru WWW. Může se stát, že daný server WWW modul snap-in MMC, jehož funkce by bylo možné do konzoly přidat, neobsahuje. V takovém případě budou ve stromu konzoly zobrazeny pouze servery WWW s rozšířeními aplikace FrontPage. Nebudou zde zobrazeny všechny servery WWW v počítači.

V některých případech může být ve stejném počítači kromě serveru IIS verze 4.0 nebo novější nainstalován i jiný server. U každého takového serveru WWW se potom zobrazí položka na nejvyšší úrovni a pod ní se zobrazí její servery WWW. Jestliže vyberete , který je nainstalován na serveru IIS 4.0 nebo novějším, a zobrazíte místní nabídku, zobrazí se příkazy modulu snap-in serveru IIS společně s příkazy modulu snap-in FrontPage. Pokud vyberete server WWW jiný než IIS a zobrazíte místní nabídku, budou příkazy pro správu rozšíření FrontPage Server Extensions doplněny pouze o modul snap-in FrontPage konzoly MMC.


Rozšíření virtuálního serveru pomocí rozšíření FrontPage Server Extensions

Po vytvoření jej lze pomocí rozšíření FrontPage Server Extensions , čímž se z virtuálního serveru stane . Před vlastním rozšířením virtuálního serveru je třeba, aby v počítači se serverem byla již nainstalována serverová rozšíření.

Rozšíření virtuálního serveru pomocí rozšíření FrontPage Server Extensions

  1. Ve klepněte pravým tlačítkem myši na virtuální server, který chcete rozšířit.
  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Konfigurovat serverová rozšíření.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, klepněte v místní nabídce na příkaz Nový a potom klepněte na příkaz Server WWW.

  3. Postupujte podle pokynů Průvodce konfigurací serverových rozšíření.

Poznámka

Před vytvořením je třeba virtuální server rozšířit, tj. vytvořit z něj kořenový server WWW.


Vytvoření podřízeného serveru WWW

Podřízený server WWW je složka nebo jiného podřízeného serveru WWW, který je úplným . Jde o logické rozdělení obsahu celého .

Podřízený server WWW umožňuje určit jednotlivé možnosti správy, vytváření a procházení , zvýšit výkon dalším rozdělením obsahu WWW, použít u jednotlivých podřízených serverů WWW různé vzhledy stránek WWW a snadno spravovat hypertextové odkazy.

Podřízený server WWW lze vytvořit pouze v kořenovém serveru WWW nebo ve složce vnořené do kořenového nebo podřízeného serveru WWW. Podřízený server lze při vytváření současně pomocí rozšíření FrontPage Server Extensions. V systému bude automaticky pro tento podřízený server WWW vytvořena složka.

Vytvoření podřízeného serveru WWW a jeho rozšíření pomocí rozšíření FrontPage Server Extensions

  1. Ve klepněte pravým tlačítkem myši na (nebo složku), kde chcete podřízený server WWW vytvořit.
  2. V místní nabídce klepněte na příkaz Nový a potom klepněte na příkaz Server WWW se serverovými rozšířeními.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, klepněte v místní nabídce na příkaz Nový a potom klepněte na příkaz Server WWW.

  3. Postupujte podle pokynů Průvodce novým podřízeným serverem WWW.


Přidání správce

Jestliže zapomenete své heslo nebo chcete umožnit správu serveru WWW i jinému uživateli, lze přidat dalšího správce.

Přidání správce

  1. Ve klepněte pravým tlačítkem myši na , u kterého chcete správce přidat.
  2. V místní nabídce klepněte na příkaz Nový a potom klepněte na příkaz Správce serverových rozšíření.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, klepněte v místní nabídce na příkaz Nový a potom klepněte na příkaz Správce.

  3. Do pole Uživatelské jméno zadejte účet systému Windows NT, který chcete na server WWW přidat jako účet správce.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, zadejte do pole Uživatelské jméno uživatelské jméno a do pole Heslo i do pole Potvrzení hesla zadejte stejné heslo.


Odebrání rozšíření FrontPage Server Extensions z kořenového serveru WWW a jeho podřízených serverů

Je možné, že se někdy vy nebo autor rozhodnete, že již není potřeba, aby server WWW zahrnoval rozšíření FrontPage Server Extensions. V tom případě můžete odebrat serverová rozšíření z , čímž budou rozšíření odebrána ze všech jeho .

Po odebrání serverových rozšíření přestanou fungovat funkce serveru WWW podporované rozšířeními FrontPage Server Extensions, například čítače přístupů a popisovače formulářů elektronické pošty. Obsah serveru WWW zůstane nezměněn. Budou odebrána pouze serverová rozšíření.

Odebrání serverových rozšíření z kořenového serveru WWW a jeho podřízených serverů

  1. Ve klepněte pravým tlačítkem na kořenový server WWW, ze kterého chcete odebrat serverová rozšíření.
  2. V místní nabídce klepněte na příkaz Úloha a na možnost Odebrat serverová rozšíření.

Ve výchozím nastavení nebudou odstraněny soubory, které obsahují informace o struktuře serveru WWW, tématech a další potřebné informace, takže bude možné server WWW zcela obnovit, pokud se později rozhodnete znovu rozšíření nainstalovat. Pokud však na daném serveru nebudete rozšíření FrontPage Server Extensions nikdy znovu potřebovat, zrušte zaškrtnutí políčka Neodstraňovat soubory potřebné k opakované instalaci rozšíření.

  3. Klepněte na tlačítko OK.


Kontrola a oprava rozšíření FrontPage Server Extensions na serveru WWW nebo na podřízeném serveru WWW

Může se stát, že autor nebude schopen předat obsah serveru WWW, upravit server WWW přímo v počítači se serverem nebo provádět jiné funkce vytváření obsahu podporované v rozšířeních FrontPage Server Extensions. Příčinou tohoto problému může být náhodné odstranění nebo přejmenování potřebných souborů nebo poškození . Řadu problémů, které nastanou během vytváření, lze vyřešit zvolením příkazu Zkontrolovat serverová rozšíření, pomocí kterého budou provedeny následující operace:

  • kontrola ke čtení,
  • kontrola, zda lze soubory Service.cnf a Service.lck číst a zda do nich lze zapisovat,
  • aktualizace souboru Postinfo.html a _vti_inf.htm,
  • ověření, zda jsou nainstalovány složky _vti_pvt, _vti_log, a _vti_bin a zda je binární soubor _vti_bin spustitelný,
  • ověření aktuálnosti a správnosti nastavení kořenových adresářů nebo metabáze,
  • ověření, zda do anonymního účtu IUSR nelze zapisovat,
  • zobrazení upozornění v případě, že uživatel používá systém souborů FAT (při práci se serverem IIS tak nelze používat žádný způsob zabezpečení serveru WWW).

Kontrola a oprava rozšíření FrontPage Server Extensions

  1. Ve klepněte pravým tlačítkem myši na server WWW, u kterého chcete zkontrolovat a opravit serverová rozšíření.

Zkontrolován bude tento server WWW i všechny , které tento server obsahuje.

  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Zkontrolovat serverová rozšíření.

V dialogovém okně Zkontrolovat server WWW se pro každý kontrolovaný server WWW zobrazí soubor protokolu o stavu.


Inovace rozšíření FrontPage Server Extensions na serveru WWW

Společnost Microsoft vždy po určité době zveřejní novou verzi rozšíření FrontPage Server Extensions. Nová verze poskytuje zdokonalenou podporu pro autory a správce serverů WWW nebo odstraňuje problémy v existujících funkcích podpory. Poskytuje rovněž podporu všech existujících funkcí v aplikaci FrontPage, například čítačů přístupů.

Chcete-li využívat tuto novou podporu, musíte nejprve nainstalovat poslední verzi serverových rozšíření do počítače se serverem a potom inovovat na tuto verzi. Serverová rozšíření můžete inovovat pouze na . Při inovaci kořenového serveru však dojde k inovaci všech jeho .

Inovace na nejnovější verzi rozšíření FrontPage Server Extensions

  1. Ve klepněte pravým tlačítkem na kořenový server WWW, u kterého chcete inovovat serverová rozšíření.
  2. V místní nabídce klepněte na příkaz Úloha a potom na příkaz Inovovat rozšíření.

Poznámky

Příkaz Inovovat rozšíření se zobrazí pouze tehdy, pokud je k dispozici novější verze Serverových rozšíření.

Chcete-li rozšíření FrontPage Server Extensions inovovat u všech kořenových serverů WWW v počítači, klepněte ve stromové struktuře konzoly pravým tlačítkem na položku Tento počítač.


Odstranění serveru WWW s rozšířeními aplikace FrontPage

Odstranění podřízeného serveru WWW s rozšířeními aplikace FrontPage

Může se stát, že bude zastaralý, málo využíván nebo z jakéhokoli důvodu již nebude třeba jej udržovat. Tato situace může nastat například u projektu, o němž byly informace publikovány na podnikovém intranetu a který již skončil nebo byl změněn nebo u odběratele, který odeslal poskytovateli služeb sítě Internet, jenž přestal poskytovat služby. V těchto a dalších případech může vzniknout potřeba podřízený server WWW odstranit.

Při odstranění podřízeného serveru bude odstraněn jeho veškerý obsah, soubory, které obsahoval, i vnořené podřízené servery a budou odstraněny také rozšíření FrontPage Server Extensions. Odstranění podřízeného serveru WWW nelze vrátit zpět.

Odstranění podřízeného serveru WWW

  1. Ve klepněte pravým tlačítkem myši na podřízený server, který chcete odstranit.
  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Odstranit server WWW se serverovými rozšířeními.
  3. Klepněte na tlačítko OK.

Poznámka

Jestliže nemáte oprávnění k odstranění podřízeného serveru WWW vnořeného v odstraňovaném podřízeném serveru WWW, nebude podřízený server odstraněn.


Převedení složky na serveru WWW na podřízený server WWW

Jestliže zjistíte, že složka obsahuje již tolik stránek WWW a grafických objektů, že by bylo vhodné z ní vytvořit samostatný , lze tuto složku snadno převést na . Existuje však i jiný způsob, jak vytvořit .

Převedení složky na podřízený server WWW

  1. Ve klepněte pravým tlačítkem myši na složku, kterou chcete převést na podřízený server WWW s rozšířeními aplikace FrontPage.
  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Konfigurovat serverová rozšíření.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, klepněte v místní nabídce na příkaz Úlohy a potom klepněte na příkaz Převést adresář na server WWW.


Převedení podřízeného serveru WWW na složku

Může se stát, že zjistíte, že již není potřebný, budete však chtít zachovat jeho obsah. V takovém případě lze převést na složku . Po převedení podřízeného serveru WWW na složku budou rozšíření FrontPage Server Extensions odebrána z podřízeného serveru WWW, podřízený server WWW bude převeden na běžnou složku nadřazeného serveru WWW a všechny podřízené servery WWW vnořené v převáděném podřízeném serveru budou propojeny s příslušnými nadřazenými servery WWW.

K podřízeným serverům WWW vnořeným v převáděném podřízeném serveru WWW lze přiřadit různá nastavení motivů a . Jestliže převáděný podřízený server neobsahuje žádné další podřízené servery WWW, může u stránek převáděného serveru WWW dojít ke ztrátě některých vlastností WWW.

Převedení podřízeného serveru WWW na složku

  1. Ve klepněte pravým tlačítkem myši na podřízený server WWW s rozšířeními aplikace FrontPage, který chcete převést na složku.
  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Převést server WWW s rozšířeními na adresář.

Jestliže není jako server WWW nainstalován server IIS 4.0 nebo novější, klepněte v místní nabídce na příkaz Úlohy a potom klepněte na příkaz Převést server WWW na adresář.


Otevření serveru WWW pomocí aplikace FrontPage

Je možné, že jako správce budete potřebovat změnit téma, text, grafické objekty nebo jinou součást obsahu nebo . Pokud je aplikace FrontPage nainstalována ve stejném počítači se serverem jako nebo podřízený server, můžete server WWW otevřít přímo z a v aplikaci FrontPage změnit jeho obsah nebo provést další akce. V opačném případě nelze server WWW z konzoly otevřít.

Otevření serveru WWW pomocí aplikace FrontPage

  1. Ve klepněte pravým tlačítkem na server WWW, který chcete otevřít v aplikaci FrontPage.
  2. V místní nabídce klepněte na příkaz Úloha a na příkaz Otevřít v aplikaci FrontPage.
  3. V této aplikaci upravte obsah serveru a změny uložte.

Poznámka

Pokud aplikace FrontPage není v počítači se serverem nainstalována, příkaz Otevřít v aplikaci FrontPage se nezobrazí.


Přepočet všech hypertextových odkazů na serveru WWW

Všechny změny provedené ve struktuře mohou změnit odkazy mezi různými částmi serveru. Pokud například přidáte, přejmenujete nebo přesunete stránku z jedné složky do jiné, bude třeba hypertextové odkazy na tuto stránku ze všech ostatních stránek a dokumentů aktualizovat neboli přepočítat, aby byly obnoveny logické odkazy. Aplikace FrontPage přepočítává hypertextové odkazy automaticky. Přepočet však můžete také inicializovat ručně.

Přepočet všech hypertextových odkazů na serveru WWW

  1. Ve klepněte pravým tlačítkem na server WWW, jehož hypertextové odkazy chcete přepočítat.
  2. V místní nabídce klepněte na tlačítko Úloha a potom na kartu Přepočítat server WWW.


Určení, který skriptovací jazyk bude generován jako výchozí

Jako odpověď na některé akce autorů generují rozšíření FrontPage Server Extensions skripty na straně klienta. Ve výchozím nastavení jsou tyto skripty generovány ve JavaScript. Tento jazyk je rozpoznáván mezi jinými ve dvou nejrozšířenějších prohlížečích sítě WWW, Netscape Navigator a Microsoft Internet Explorer. Skripty můžete generovat také v jazyce VBScript, který není rozpoznáván v aplikaci Netscape Navigator. Jazyk VBScript však můžete zvolit, pokud například spravujete podnikovou síť intranet, ve které je využívána výhradně aplikaci Internet Explorer, nebo pokud tento jazyk upřednostňuje technický personál vaší společnosti.

Určení, který skriptovací jazyk bude generován jako výchozí

  1. Ve klepněte pravým tlačítkem na , u kterého chcete určit skriptovací jazyk generovaný jako výchozí.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. V rozevíracím seznamu Skriptování na straně klienta zvolte skriptovací jazyk.


Ruční nastavení oprávnění

Na roli založená , která můžete nastavit a spravovat na každém pro správce, autory a návštěvníky pomocí aplikace FrontPage, nemusí vždy splňovat vaše potřeby. Můžete například potřebovat nastavit oprávnění u souborů a složek. Nastavením oprávnění přímo v můžete ručně nastavit vlastní oprávnění. Další informace o nastavování vlastních oprávnění získáte v sadě FrontPage Server Extensions Resource Kit na adrese http://www.microsoft.com/frontpage/wpp/serk.

Použijete-li však ke správě oprávnění aplikaci FrontPage, změní tato aplikace všechna nastavená vlastní oprávnění zrušením změn v seznamech ACL. Chcete-li zajistit, abyste vy ani jiný uživatel nemohli nedopatřením přepsat vlastní oprávnění, můžete v aplikaci FrontPage oprávnění vypnout.

Ruční nastavení oprávnění

  1. Ve klepněte pravým tlačítkem na , u kterého chcete ručně nastavit oprávnění.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. Zaškrtněte políčko Spravovat oprávnění ručně.


Povolení nebo zakázání vytváření na serveru WWW

Povolení nebo zakázání vytváření na kořenovém nebo podřízeném serveru WWW

, které sestavujete, nebo které je třeba často aktualizovat, je třeba nastavit tak, aby byly přístupné pro příslušné autory. Po dokončení některých serverů je naopak třeba, aby určité základní nebo stále platné informace zůstaly beze změn. Může být také nutné zabránit ostatním uživatelům upravovat server WWW po určitou dobu, po kterou budete server přesouvat na nové umístění nebo po kterou budete provádět jiné potřebné změny. Provedení změn v informacích na serveru WWW zabráníte tak, že na něm zakážete vytváření. Na takto chráněném serveru WWW nebude možné přidávat ani měnit obsah WWW.

Povolení nebo zakázání vytváření na kořenovém nebo podřízeném serveru WWW

  1. Ve klepněte pravým tlačítkem na kořenový server WWW, u kterého chcete povolit nebo zakázat vytváření.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. Vytváření povolíte zaškrtnutím políčka Povolit vytváření obsahu.

Vytváření zakážete zrušením zaškrtnutí políčka Povolit vytváření obsahu.


Určení, zda složka může obsahovat spustitelné skripty a programy

Chce-li autor serveru WWW zahrnout nebo aktivní stránku serveru do , může se stát, že neúmyslně uloží na server WWW vadný program nebo dokonce virus. Rizikům spojeným s vadnými programy a viry se lze vyhnout tak, že autorovi zabráníte v ukládání skriptů a programů do složek, které jsou součástí .

Určení, zda složky mohou obsahovat spustitelné skripty a programy

  1. Ve klepněte pravým tlačítkem na , u kterého chcete složky označit jako spustitelné.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. Zaškrtněte nebo zrušte zaškrtnutí políčka Povolit autorům ukládat spustitelné soubory.


Zápis akcí autorů do protokolu

Uživatelé s oprávněním upravovat obsah mohou měnit text, grafické objekty, odkazy, strukturu a další informace. Chcete-li sledovat, kdo na serveru WWW provedl změny a které soubory byly změněny, můžete zapisovat akce autorů na a všech jeho do protokolu. Systém pak bude zaznamenávat čas provedení změny autorem, jeho uživatelské jméno, název serveru WWW, vzdáleného hostitele a operační data a uloží tyto informace v souboru protokolu _vti_log/Author.log v kořenovém serveru WWW. Pokud dojde k narušení zabezpečení, můžete tento protokolový soubor analyzovat a určit, jaká činnost spojená s vytvářením byla na serveru WWW prováděna.

Zápis akcí autorů do protokolu

  1. Ve klepněte pravým tlačítkem na kořenový server WWW, u kterého chcete zapisovat akce autorů do protokolu.
  2. V místní nabídce klepněte na příkaz Vlastnosti a potom na kartu Serverová rozšíření.
  3. Zaškrtněte políčko Zapisovat akce autorů do protokolu.


Vyžadování zabezpečení SSL (Secure Sockets Layer) při vytváření

Informace na serveru WWW jsou nejvíce ohroženy možností zachycení při přenosech z jedné části do jiné. Spojení lze efektivním způsobem ochránit vyžadováním při přenosech informací mezi aplikací FrontPage, prohlížeči sítě WWW a servery WWW.

Vyžadování zabezpečení SSL při vytváření

  1. Ve klepněte pravým tlačítkem na , u kterého chcete vyžadovat používání zabezpečení SSL.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. Zaškrtněte políčko Vyžadovat při vytváření zabezpečení SSL.

Poznámka

Vyžadujete-li při vytváření zabezpečení SSL, obdrží autoři, kteří se pokusí pracovat na tomto serveru WWW, zprávu, že musí používat toto zabezpečení, které mohou zvolit v aplikaci FrontPage.


Ladění výkonu serveru WWW

Rychlost, jakou odpovídá na požadavky klienta FrontPage, závisí do značné míry na velikosti serveru WWW, zvláště pak na počtu stránek a dalších souborů, které server obsahuje. Dobu odezvy lze vylepšit optimalizací. Optimalizujete-li server WWW, rezervují rozšíření FrontPage Server Extensions pro server určité množství mezipaměti v závislosti na počtu stránek. Můžete například optimalizovat server pro méně než 100 stránek nebo více než 1 000 stránek. Lze také přizpůsobit velikost mezipaměti a velikost rejstříku fulltextového vyhledávání.

Optimalizace výkonu serveru WWW

  1. Ve klepněte pravým tlačítkem myši na server WWW, jehož výkon chcete optimalizovat.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. V poli Výkon vyberte rozsah stránek, který se nejvíce blíží skutečnému počtu stránek na serveru WWW, jehož výkon chcete optimalizovat.
  4. Chcete-li server optimalizovat pomocí vlastních hodnot, klepněte na možnost Použít vlastní nastavení a potom zadejte požadovanou mezipaměť a velikost rejstříku fulltextového vyhledávání.


Povolení správy zdrojů

V případě, že obsah WWW upravuje více uživatelů, můžete pomocí správy zdrojů zjistit, který uživatel momentálně upravuje příslušný dokument WWW, zjistit provedené změny. Lze také zabránit přepsání změn jednoho autora změnami jiného a v případě potřeby použít předchozí verzi dokumentu. Budete-li chtít použít správu zdrojů u určitého , lze zvolit vestavěnou správu zdrojů nebo použít externí program správy zdrojů, který podporuje aplikaci FrontPage (například aplikaci Microsoft Visual SourceSafe).

Rozšíření FrontPage Server Extensions obsahují vestavěnou správu zdrojů. Vestavěná správa zdrojů umožňuje přidělit server WWW určitému uživateli a po provedení změn server vrátit do projektu a umožňuje také obnovit server WWW z poslední uložené verze. Aplikace Visual SourceSafe a ostatní programy správy zdrojů je třeba zakoupit a nainstalovat do počítače zvlášť. Funkce externích i vestavěných programů správy zdrojů se obvykle shodují. Externí programy správy zdrojů navíc umožňují sledovat provedené změny a obnovit několik předchozích verzí serveru WWW.

Povolení správy zdrojů

  1. Ve klepněte pravým tlačítkem na server WWW, u něhož chcete správu zdrojů povolit.
  2. V místní nabídce klepněte na příkaz Vlastnosti a potom na kartu Serverová rozšíření.
  3. V rozevíracím seznamu Správa verzí zvolte možnost Použít externí nebo Použít vestavěnou.

Jestliže jste zvolili možnost Použít externí, zadejte název projektu aplikace Visual SourceSafe nebo projektu jiné správy zdrojů, který chcete použít.

Poznámka

Aplikaci Visual SourceSafe lze s aplikací FrontPage použít pouze v případě, že je v aplikaci Visual SourceSafe zapnuta možnost Enable SourceSafe integration. Tuto možnost je třeba zvolit v rámci vlastní instalace aplikace Visual SourceSafe.


Nastavení možností elektronické pošty

Některé funkce vyžadují, aby návštěvníkům serveru, kteří procházejí server WWW, byla odesílána elektronická pošta. Příkladem takové funkce je popisovač formulářů elektronické pošty. Chcete-li tyto funkce nastavit tak, aby odesílaly elektronickou poštu, je nutné zadat poštovní adresu serveru WWW, kontaktní adresu, hostitele SMTP, schéma kódování pošty a znakovou sadu.

Nastavení možností elektronické pošty

  1. Ve klepněte pravým tlačítkem na , u kterého chcete nastavit možnosti elektronické pošty.
  2. Klepněte na příkaz Vlastnosti v místní nabídce a potom na kartu Serverová rozšíření.
  3. V poli Možnosti klepněte na možnost Nastavení.
  4. Zadejte požadované nastavení.


Podpora online od odborné pomoci společnosti Microsoft

Nejnovější odpovědi na otázky z technické oblasti lze získat v síti Internet

Máte-li dotaz z technické oblasti a odpověď nemůžete najít v souboru nápovědy systému Windows 2000, můžete navštívit server Support Online. Stačí vybrat produkt, zadat dotaz a odpověď bude vyhledána automaticky. Na tomto serveru jsou shromážděny prostředky, jako je například databáze Microsoft Knowledge Base, průvodci odstraňováním problémů a stáhnutelné soubory, u kterých je největší pravděpodobnost, že poskytnou odpověď na váš dotaz.

Chcete-li zahájit hledání, přejděte na server Support Online.


Nastavení elektronické pošty

V tomto dialogovém okně můžete určit, jakým způsobem chcete odesílat zprávy elektronické pošty ze serveru WWW, který obsahuje funkce elektronické pošty, například popisovače formulářů.

Adresa pošty serveru WWW

Umožňuje zadat adresu elektronické pošty, která se bude ve zprávách elektronické pošty odesílaných z některých součástí (například z výsledkových formulářů) v aplikaci FrontPage zobrazovat v řádku Od.

Kontaktní adresa

Slouží k zadání elektronické adresy, na kterou by měli uživatelé odesílat zprávy v případě problémů. Zadaná adresa bude uvedena v chybových zprávách zobrazených při některých problémech v aplikaci FrontPage.

Poštovní server SMTP

Slouží k zadání názvu hostitelského serveru SMTP, pomocí kterého budou přesměrovávány zprávy na server WWW nebo z něj.

Kódování pošty

Klepněte na schéma kódování pošty, které chcete používat u zpráv elektronické pošty. Výchozím kódováním je nejčastěji používané 8bitové kódování. Pokud víte, že příjemce zprávy používá jiné schéma kódování a není schopen přijímat vaše zprávy, lze zvolit jiné schéma kódování.

Znaková sada

Můžete zvolit název znakové sady, kterou chcete použít ve zprávách elektronické pošty. Každá znaková sada je abeceda některého jazyka.


Výkon

V tomto dialogovém okně lze zadat velikost mezipaměti pro typy informací, které se na serveru WWW často používají. Zadáním velikosti mezipaměti vhodné pro příslušný server WWW lze zrychlit odezvu serveru WWW na akce uživatele.

Mezipaměť pro dokumenty v paměti

Zadejte maximální počet dokumentů, jejichž vlastnosti, jako například mapy odkazů nebo parametry serveru WWW, chcete uchovat v paměti. Toto číslo představuje posledních <zadané číslo> dokumentů, se kterými jste pracovali. Jestliže například zadáte číslo 4096, budou z paměti odebrány informace o vlastnostech dokumentu číslo 4097.

Mezipaměť pro zahrnuté soubory

Zadejte počet souborů, které mají být uchovány v paměti proto, že je chcete zahrnout do dalších souborů. Může se například jednat o soubory se záhlavím, zápatím nebo s informacemi o autorských právech, které chcete vložit na některé nebo na všechny stránky serveru WWW.

Mezipaměť pro soubory s obrázky

Zadejte počet souborů s obrázky, které chcete uchovat v paměti tak, aby pomocí nich bylo možné v rozšířeních FrontPage Server Extensions vytvářet vrstvené obrázky na stránkách WWW. Jeden soubor může například obsahovat obrázek pozadí, jiný vzhled tlačítka pro navigaci. Serverová rozšíření umožňují složit obrázek z obrazu pozadí a s další vrstvy tvořené tlačítkem navigace. Obraz lze složit rychleji, jsou li tyto dílčí obrazy uloženy v mezipaměti.

Velikost rejstříku fulltextového vyhledávání

Zadejte maximální velikost místa na disku, které lze přidělit pro ukládání rejstříku fulltextového vyhledávání. Po dosažení tohoto čísla nebude možné vytvořit rejstřík dalších stránek WWW (pokud nezadáte vyšší číslo).

Maximální velikost dokumentu v mezipaměti

Zadejte maximální velikost dokumentu, kterou bude možné uložit do paměti. Toto omezení velikosti se bude vztahovat na zahrnuté soubory, soubory s obrázky a další soubory, které mohou být uloženy v mezipaměti.


Výchozí vlastnosti serveru WWW - stránka vlastností publikování

Výchozí vlastnosti serveru WWW - stránka vlastností Serverová rozšíření

Na této stránce vlastností lze nastavit ovládací prvky publikování pro server WWW s rozšířeními aplikace FrontPage.

Povolit vytváření obsahu (pouze kořenový server WWW)

Umožňuje autorům získat pomocí aplikace FrontPage přístup k vybranému serveru WWW a upravovat jeho obsah. Zrušením zaškrtnutí políčka Povolit vytváření obsahu zabráníte všem uživatelům v přístupu k tomuto serveru a jeho úpravám.

Správa verzí

Klepněte na způsob správy zdrojů, pomocí kterého chcete sledovat, kdo upravuje obsah serveru WWW, zjišťovat provedené změny a zabránit tomu, aby si uživatelé navzájem změny přepisovali. Můžete použít vestavěnou správu zdrojů nebo externí aplikaci, například Microsoft Visual SourceSafe, která poskytuje více funkcí pro správu zdrojů.

Výkon

Klepněte na rozsah stránek, který se nejvíce blíží skutečnému počtu stránek na vybraném serveru WWW. Rozšíření FrontPage Server Extensions vyhradí na základě vybraného rozsahu určité množství mezipaměti.

Skriptování na straně klienta

Klepněte na skriptovací jazyk, JScript nebo VBScript, který mají rozšíření FrontPage Server Extensions automaticky generovat na stránkách.

Zadejte způsob, jakým chcete odesílat poštu.

Klepnutím na tlačítko zobrazíte dialogové okno Nastavení elektronické pošty, ve kterém můžete určit způsob, kterým budou funkce serveru WWW založené na elektronické poště, například popisovače formulářů elektronické pošty, odesílat poštu návštěvníkům serveru WWW. V tomto dialogovém okně lze zadat elektronickou adresu serveru WWW, kontaktní elektronickou adresu, poštovní server, schéma pro kódování pošty a znakovou sadu.

Můžete konfigurovat funkce pro spolupráci aplikací Office.

Klepnutím na tlačítko zobrazíte stránky WWW pro správu rozšíření Office Server Extensions, ze kterých lze spravovat funkce pro spolupráci aplikací Office, například diskuse pracovních skupin. Tato možnost není k dispozici, pokud není v počítači nainstalován server Office Web Server (OWS).

Nedědit nastavení zabezpečení

Ve výchozím nastavení dědí každý kořenový server WWW globální nastavení zabezpečení serveru WWW. Chcete-li toto nastavení u vybraného kořenového serveru (a všech jeho podřízených serverů) přepsat, zaškrtněte toto políčko. Zaškrtnutí políčka zrušte, pokud chcete, aby vybraný kořenový server WWW dědil nastavení zabezpečení z globálních nastavení serveru WWW.

Zapisovat akce autorů do protokolu

Umožňuje systému zaznamenat čas, kdy autor provedl určitou akci, uživatelské jméno autora, název serveru WWW, vzdáleného hostitele a operační data a uložit tyto informace do souboru protokolu _vti_log/Author.log, který je uložen v kořenovém serveru WWW. Nechcete-li zapisovat akce autorů do protokolu, zrušte zaškrtnutí tohoto políčka.

Spravovat oprávnění ručně

Vypne funkce nastavení zabezpečení u nástrojů pro správu rozšíření FrontPage Server Extensions (například u modulu snap-in FrontPage konzoly MMC), aby tyto nástroje nemohly být použity k úpravě nastavení zabezpečení vybraného serveru WWW. Chcete-li změnu nastavení pomocí těchto nástrojů povolit, zaškrtnutí políčka zrušte.

Vyžadovat při vytváření zabezpečení SSL

Umožňuje používat zabezpečení SSL k ověření potenciálních autorů serveru WWW. Toto políčko doporučujeme zaškrtnout, pokud v současnosti používáte pouze základní ověřování, které pouze jednoduchým způsobem šifruje informace (například uživatelské jméno a heslo autora) odesílané v rámci serveru WWW. Nechcete-li vyžadovat od autorů zabezpečení SSL, zrušte zaškrtnutí tohoto políčka.

Povolit autorům ukládat spustitelné soubory

Umožňuje autorům ukládat skripty CGI nebo aktivní stránky serveru na vybraný server WWW. Chcete-li znemožnit ukládání spustitelných souborů na server WWW a vyhnout se rizikům spojeným s potenciálním uložením vadného skriptu nebo viru, zrušte zaškrtnutí tohoto políčka.