CuteSQL

Vážený uživateli,

Díky ti za používání produktu CuteSQL. Věříme, že ti pomůže urychlit a zejména zpříjemnit práci.

CuteSQL - Základní informace

CuteSQL je FREE utilitka, pomocí které můžete spouštět své SQL příkazy pro celou řadu databází.
Připojení k databázím je umožněno následovně:
  • Přes Nativní připojení (InterBase, Oracle, DB2, MS SQL a MySQL)
  • Přes ODBC
  • Přes ADO

Klíčové vlastnosti

  • V CuteSQL je možné spouštět příkazy pro různé databáze
  • CuteSQL si pamatuje Vámi napsané příkazy (po dobu používání)
  • Výsledky dotazů můžete vidět v přehledné tabulce

CuteSQL & Technická podpora

CuteSQL je šikovná utilitka, kterou jsme se rozhodli vydat jako FREEWARE. Jistě pochopíte, proč Vám nemůžeme zajistit plnohodnotnou technickou podporu k tomuto produktu. Avšak věříme, že ovládání je dosti intuitivní a není zapotřebí žádných vysoce profesionálních znalostí k užívání CuteSQL.
Kde tedy hledat pomoc v případě problémů? Sledujte naše internetové stránky na www.casestudio.com.
Možná narazíte na příslušnou diskusní skupinu, popřípadě Newsgroups :-)

Přejeme Vám příjemnou práci s CuteSQL!


CuteSQL - Přehled ovládacích prvků

CuteSQL - jak na to?

Přehled ovládacích prvků

Connect:

Připojení k databázi

Disconnect:

Ukončení připojení

Open Script:

Umožní spustit dříve uložený script

Execute SQL command:

Spustí Vámi napsaný SQL příkaz

Execute SQL query:

Po kliknutí na tuto ikonu můžete vidět výsledek SQL dotazu v tabulce Grid.

Connection Setup:

Tato ikona slouží pro nastavení hodnot v případě, že se nepřipojujete pomocí
nativního připojení, ale ODBC nebo ADO.

Undo a Redo:

Umožňuje vrátit změnu při psaní příkazů. Jedná se o stejnou funkci, kterou znáte
např. z textových editorů.

Previous SQL a Next SQL:

CuteSQL si pamatuje Vámi napsané SQL příkazy, dokud program neukončíte.
Pomocí šipek se jednoduše pohybujete v historii napsaných SQL příkazů.
#


CuteSQL - Jak na to?

CuteSQL - Položky hlavního menu

Actions

Connect

Připojení k databázi. Nejprve je zapotřebí specifikovat databázi a zadat
příslušné přihlašovací údaje.

Disconnect

Ukončí připojení k databázi

Execute SQL query (F9)

Zobrazí výsledek Dotazu v záložce Grid, ve formě přehledné tabulky.

Execute SQL command (CTRL + F9)

Spustí napsaný SQL příkaz.

Clear Input (CTRL + I)

Vyčistí horní okno, ve kterém píšete SQL příkazy

Clear Result (CTRL + R)

Vyčistí spodní okno, ve kterém se zobrazují výsledky SQL příkazů/dotazů.

Options

Continue after error

Při zaškrtnutí umožňuje pokračovat ve zpracování příkazu, i když došlo k chybě.

Report SQL into results

Při zaškrtnutí bude CuteSQL zapisovat do záložky Results také příslušnou část SQL příkazu. Je tedy snazší odhalit chybu v příkazu.

Autocommit

Při zaškrtnutí automaticky přidává příkaz Commit. Používá se např. u PostgreSQL, nepoužívá se např. u Sybase.

Config

Zde můžete nastavit příslušné terminátory. K čemu terminátor slouží? Pokud napíšete SQL script, složený z více příkazů, je zapotřebí terminátor nastavit, a to z toho důvodu, aby nebyl script považován pouze za dlouhý souvislý text. Při provádění příkazů by docházelo pouze k chybovým hláškám!

Spaces

Při zaškrtnutí je vyžadována mezera před terminátorem. Používá se například u MS SQL, kdy nelze napsat terminátor go inhed za textový řetězec. Je nutné před go vložit mezeru.

About

Help

Nápověda k programu CuteSQL

About

Informace o autorech a verzi programu.
#


CuteSQL - Připojení k databázi

CuteSQL - jak na to?

Připojení k databázi

Nativní připojení

Je nutno vybrat příslušnou databázi z roletkového menu a zadat název databáze. Po kliknutí na tlačítko Connect se zobrazí dialogové okno, ve kterém musíte nastavit např. Název uživatele a přístupové Heslo.

S využitím ODBC nebo ADO

Je nutno kliknout na ikonu Setup a nastavit veškeré potřebné hodnoty.
Pozn.: Vyberete-li ODBC připojení a kliknete na ikonu Setup, zobrazí se
následují dialog. Proveďte konfiguraci, je-li zapotřebí.

#


CuteSQL - Psaní příkazů

CuteSQL - jak na to?

Psaní SQL příkazů

SQL příkazy můžete buďto psát v horním okně programu CuteSQL
(jak je vidět na obrázku výše), nebo je můžete načíst ze souboru,
pomocí ikony Otevřít (Open).
V případě, že máte příkaz hotov, stiskněte tlačítko ExecuteSQL command.
V dolní části v záložce Result se vám vypíše průběh zpracování příkazu.
Zatrhnete-li položku Report SQL into results z nabídky Options, bude
v dolní části zobrazena příslušná část scriptu.
#


CuteSQL - Prohlížení výsledků

CuteSQL - jak na to?

Prohlížení výsledků

Pokud napíšete SQL dotaz (Select), můžete si také prohlédnout výsledek dotazu.
K tomu je zapotřebí stisknout tlačítko Execute SQL query. CuteSQL
vám zobrazí výsledek v přehledné tabulce v záložce Grid.
#


CuteSQL - Klávesové zkratky

CuteSQL - jak na to?

Přehled klávesových zkratek

Ovládání CuteSQL

CTRL + I

Clear Input - vyčistí vám horní část, ve které píšete příkazy

CTRL + R

Clear Result - vyčistí vám spodní část, ve které jsou zobrazeny výsledky

CTRL + F9

Spustí napsaný příkaz

F9

Zobrazí vrácené hodnoty SQL dotazu (Select) v záložce Grid

Psaní příkazů

CTRL + A

Vyber vše

CTRL + C

Kopírovat

CTRL + X

Vyjmout

CTRL + V

Vložit

CTRL + Z

Vrátit zpět
#


CuteSQL

CuteSQL - Troubleshooting

CuteSQL & PostgreSQL

CuteSQL nevypíše chybovou hlášku, přestože došlo k chybám.

Problém je v tom, že CuteSQL nedokáže přesně rozpoznat chybové hlášky z PostgreSQL konzole.
Proto je nutné důkladně sledovat i výpisy z konzole a porovnávat je s činností CuteSQL.
Doporučujeme rovněž zaškrtnout položku Autocommit v nabídce Options.

CuteSQL & MS SQL

Nezapomeňte zaškrtnout položku Spaces v nabídce Options - Config.

V MS SQL se jako terminátor používá slovo go. Před tímto terminátorem je vždy vyžadována mezera, neboť
terminátor go nemůže následovat ihned za posledním písmenem příkazu.
#


CASE Studio 2

Vážený uživateli,

rádi bychom tě také seznámili s naším stěžejním produktem CASE Studio 2.

CASE Studio 2 - základní informace

CASE Studio 2 je profesionální software pro visuální navrhování databázových struktur - jinak a jednoduše řečeno "Database modeler" či "Database designer". CASE Studio 2 pracuje pod operačním systémem Windows.
CASE Studio 2 Vám umožní visuálně navrhovat Entitně relační diagramy pro rozličné databáze. Jedná se o ideální software pro společnosti či vývojáře, kteří chtějí pracovat se svými databázemi nejpříjemnějším a časově velice úsporným způsobem.

CASE Studio 2 - Klíčové vlastnosti

  • Entitně relační diagramy (ERD)
  • Data Flow Diagramy (DFD)
  • Reverse Engineering - umožňuje vytvořit model struktury již existující databáze
  • Správce verzí - umožňuje porovnávat jednotlivé verze modelů
  • Velice detailní Logické i Fyzické HTML reporty
  • Galerie - pro uložení nejčastěji používaných částí modelů
  • Podpora Uživatelů, uživatelských skupin a uživatelských práv
  • Uživatelsky definované šablony
  • Data dictionaries
  • Submodely a mnohem více...

CASE Studio 2 - Screenshot


License Agreement

CuteSQL - License Agreement

CuteSQL (the "Software"), is protected by copyright and other international treaties.
This License Agreement (the "Agreement") is a legal agreement between You ("Licensee"), the end-user, and CHARONWARE, s.r.o.
By using the Software or storing it on a computer hard drive (or other media), You are agreeing to be bound by the terms of this Agreement.
If You do not agree to the terms of this Agreement, You must delete the Software from all storage media.
  • You may install the Software and create as many copies of the Software on storage media as You wish.
  • You may redistribute the Software freely on on-line services, bulletin boards, or other electronic media as long as the files are distributed in their entirety. The Software may not be distributed on CD-ROM, disk, or other physical media for a fee without the permission of CHARONWARE, s.r.o.
  • You may not alter the Software in any way, including changing or removing any messages or windows.
  • You may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human perceivable form. You may not modify, rent or resell for profit the Software. You may not create derivative works based upon the Software without the permission of CHARONWARE, s.r.o.
  • You may not publicize or distribute any registration code algorithms, information, or registration codes used by the Software without permission of CHARONWARE, s.r.o.
THE SOFTWARE IS PROVIDED TO LICENSEE "AS IS". ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS, AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF MERCHANTABILITY, SATISFACTORY QUALITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE LEGALLY INVALID.
CuteSQL WAS DEVELOPED WITH GREAT ACCURACY AND CARE ABOUT END-USER. BUT IN NO EVENT SHALL BE THE AUTHORS LIABLE FOR ANY INDIRECT, PUNITIVE, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGE CAUSED BY THE SOFTWARE (INCLUDING LOSS OF BUSINESS, REVENUE, PROFITS, USE, DATA OR OTHER ECONOMIC ADVANTAGE).
CuteSQL
Copyright © 2001-2002 CHARONWARE, s.r.o.
All rights reserved.


Kontact

Kontaktní informace

Internetové adresy

http://www.charonware.com

http://www.casestudio.com

Společnost

CHARONWARE s.r.o.

Perunova 14

720 00 Ostrava

Czech Republic

E-mail

info@casestudio.com

Prosíme Vás, nezasílejte nám dotazy ohledně technické podopory na CuteSQL. Děkujeme.