
Using files from previous versions of Ability
Ability Office 2000 can import, and in most case use directly, files from all previous incarnations of 
Ability, including:

· Ability Office 98 – released 1998

· Ability for Windows 1.5/1.6 - released 1995/1996

· Ability Plus 3.0 - released 1995

· Ability Plus 2.0 - released 1992

· Ability Plus 1.0 - released 1987

· Ability 1.2 - released 1985

In the first four cases, the process is identical, see Using DOS Ability files.

For Ability for Windows, see Using Ability for Windows 1.5/1.6 files.

For Ability Office 98, see Using Ability Office 98 files 



Using Ability Office 98 files

Ability Office 2000 can be installed on the same PC as an existing Ability Office 98 installation. Either 
the 98 or 2000 versions can be removed without affecting the other.

The file format has not changed for Write and Spreadsheet so these files are generally interchangeable
between the two versions. However, if you create a spreadsheet in Ability Office 2000 with more than 
one worksheet, only the first sheet will be visible in Ability Office 98. If you create a spreadsheet in 2000
with a chart or WriteFX object (or a Write file with a Write FX object) you will not be able to view the file 
in the 98 version.

Database 2000 now shares the same file format as Microsoft Access. Some of the field types have 
changed, along with their usage. See Database conversion for more details.

When opening a 98 database with 2000, you will be prompted to "convert" the file. This updates the 
field types to the 2000 format and also makes a backup copy of the original database.



Database conversion

When converting database files from Database 98 to Database 2000 the field formats are updated 
according to the table below.

Since the databases are interchangeable with Microsoft Access, the Access field equivalents are also 
listed.

98 field 
type name

Converted 
to in 2000

Notes Access 97 
equivalent

Character Character No change. Text

Memo Memo No change. Memo

Numeric Numeric No change. Number

Date Date/Time Use the Field Format options to select 
between Date and Time.

Date/Time

Time Date/Time As above. Date/Time

Enumerated Enumerated Format updated automatically. No 
action need be taken.

No equivalent 
– reads as 
Text

Incremental Incremental 
if data 
conforms, 
Numeric 
otherwise.

Note the functionality has changed. 
Ability Office 98 supported "step by 2". 
The new Incremental field type 
(equivalent to Access AutoNumber) 
only supports the concept of a unique 
sequential number. The new 
Incremental format is much better 
suited for creating Primary Key 
indexes since its uniqueness is 
managed at the database engine level 
and not at the application level (as was
previous).

AutoNumber

Logical Logical Format updated automatically. No 
action need be taken.

Yes/No

Calculated Calculated Format updated automatically. No 
action need be taken.

No equivalent 
– reads as 
Text

OLE OLE No change OLE Object

Picture OLE Use OLE instead (can do everything 
the previous Picture format could).

OLE Object



Using files from DOS versions of Ability

Ability Office will import files from all previous DOS versions. This includes most features from Write, 
Database and Spreadsheet.

See:

Using Write documents 

Using spreadsheet files 

Using databases 

What won't import
· Paper size - this is always reset to the default A4 or Letter according to your printer setup. This is 

because the paper sizes allowed in DOS versions of Ability hardly ever match those available with 
printers in Windows.

· Master forms. The layout from database won't be brought in with the database import. This will 
hopefully not cause too many problems since Ability Office has an automatic form generator and it's
easy to drag and drop fields to new positions.

· Links to other files are a general problem that this version of Ability Office has not been able to 
address properly. Single, one-way links can be re-built once both files are imported. Embedded 
spreadsheets can be reinserted, again, once both files are imported.

· Macros - Ability Office 2000 has a comprehensive set of Macro commands. Any existing macros 
won't be imported however since there so little match between Windows and DOS commands.



Using Write documents from a DOS version of Ability

To open a Write file in Ability Office 2000, follow these steps:

1. Run the Ability Office 2000 Write application - select the Windows Start button, select Programs, 
Select Ability Office 2000 and then Ability Write.

2. Select the Open button  or select the Open command from the File menu.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. In the Files of Type box set the type to Ability for DOS. 

5. Pick the file you want from the list and select OK.

Ability will open the file and display it on screen. The DOS version of Ability could only understand 
simple fonts that aren’t really used under Windows anymore. So, the first step you'll probably want to 
make is to convert the font:

1. Choose the Select All command from the Edit menu.

2. Use the Font drop-down box  to select a Windows font - try Arial or Times 
New Roman.

Now save the file: select the Save button  or select the Save command from the File menu. For 
more information, see what happens when imported files are saved.

You're now free to use any of the new formatting and layout capabilities Write.



Using spreadsheets from a DOS version of Ability

To open a spreadsheet in Ability Office 2000, follow these steps:

1. Run the Ability Office 2000 Write application - select the Windows Start button, select Programs, 
Select Ability Office 2000 and then Ability Spreadsheet.

2. Select the Open button  or select the Open command from the File menu.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. In the Files of Type box set the type to Ability for DOS. 

5. Pick the file you want from the list and select OK.

Ability will open the file and display it on screen. 

Now save the file: select the Save button  or select the Save command from the File menu. For 
more information, see what happens when imported files are saved.



What happens when imported files are saved

When saving a file from a DOS version of Ability, the following occurs:

1. A new file is created in the updated Ability Office format.

2. The old file is preserved unchanged.

For example, if you import a Write file called banklet.xtx, after saving the file in Ability Office you'll have 
two files: banklet.xtx (not changed) and banklet.aww (the new format).

Once you're happy that everything is working to your satisfaction, you can delete the old file. Or you 
can just leave it as a backup - it won't take up much disk space.



Using databases from a DOS version of Ability

To import a DOS database, you first need to create a new Ability Database to hold the information (see 
how database files are arranged for more information). If you haven't already created a new database, 
follow these steps.

1. Run the Ability Office 2000 Database application - select the Windows Start button, select 
Programs, Select Ability Office 2000 and then Ability Database.

2. Select the New button , select the New command from the File menu, and enter a new name 
for your database.

Now you can import each DOS database file to a new table.

1. Select Import from the File menu.

2. Select Ability 1.2 DOS Database or Ability Plus DOS Database from the list of source types.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. Pick the file you want from the list and select OK.



How database files are arranged

In the DOS version, you'll be used to having different files for different databases. For example, a 
simple system may look like this:

customer a list of customers

custsort sorted version of customer

products a list of products

sales a list of orders made

The databases would be stored in separate files that would appear on the Library Screen.

In the new Ability Office Database, you would usually store all these in a single database file with each 
of the imported files forming a new table. This is because they are all related - a sale is made to 
someone from the customer list who is buying an item from the product list. Even if the data is not 
related, it is usually more convenient to store them all in a single file. There is no restriction to do this 
however - you can create as many databases as you wish.

If you have created any sorted or subset files in a DOS version of Ability, you should only import the 
original. This is to avoid duplicating data. In the above example, you can import customers or custsort, 
but not both. It is much easier to sort and filter information in the new Ability Database, so don't worry 
about not importing sorted lists or subsets - the important thing is the data itself.



Finding the old directory

If you're having troubles finding files from a previous version of Ability, there's a good chance they'll be 
located in one of the default directories created during installation (or a sub-directory of one of these). 
The most likely candidates are:

c:\ability
c:\ab2
c:\ab3

To select one of the above directories in an Open dialog and make it current, follow these steps:

1. Click on the Up One Level button  until you see one of the above names in the main list.

2. Double-click on the folder name.

3. If necessary, double-click on a sub-folder as well.

Once you've located the correct directory, you'll see a list of your old files.



DOS versions of Ability
This covers any previous version DOS versions of Ability as follows:

Ability 1.2 - released 1985

Ability Plus 1.0 - released 1987

Ability Plus 2.0 - released 1992

Ability Plus 3.0 - released 1995



Using Ability for Windows 1.5/1.6 files

Ability Office will import Write documents, spreadsheets and databases from the previous Ability for 
Windows.

See:

Using Write documents 

Using spreadsheet files 

Using databases 

What won't import
Forms cannot be imported. This will hopefully not cause too many problems since Ability Office has an 
automatic form generator and it's easy to drag and drop fields to new positions.



Using Ability for Windows Write documents

To open a Write document in Ability Office 2000, follow these steps:

1. Run the Ability Office 2000 Write application - select the Windows Start button, select Programs, 
Select Ability Office 2000 and then Ability Write.

2. Select the Open button  or select the Open command from the File menu.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. Pick the file you want from the list and select OK.

Ability will open the file and display it on screen. The next time you save the file, the format will be 
updated to the new version. 



Using Ability for Windows spreadsheets

To open a spreadsheet in Ability Office 2000, follow these steps:

1. Run the Ability Office 2000 Spreadsheet application - select the Windows Start button, select 
Programs, Select Ability Office 2000 and then Ability Spreadsheet.

2. Select the Open button  or select the Open command from the File menu.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. Pick the file you want from the list and select OK.

Ability will open the file and display it on screen. The next time you save the file, the format will be 
updated to the new version. 



Using Ability for Windows databases

There are three steps to getting the databases from Ability for Windows 1.5/1.6 into the new Ability 
Database.

· Save the all the existing databases in the Ability Exchange format:

For a recap on how to do this in the previous version, see exporting 1.5/1.6 files

· Create a new Ability Office 2000 database:
1. Run the Ability Office 2000 Database application - select the Windows Start button, select 

Programs, Select Ability Office 2000 and then Ability Database.

2. Select the New button , select the New command from the File menu, and enter a new 
name for your database.

· Now you can import each of the database exchange file to a new table:
1. Select Import from the File menu.

2. Select Ability for Windows 1.5 Exchange from the list of source types.

3. Select the directory where your old Ability files are located. Trouble finding the files?.

4. Pick the file you want from the list and select OK.

5. Repeat steps 1 through 4 for each file you want to import.



Save the all the existing databases in the Ability Exchange format

This process is explained at the end of the Database Chapter in the Ability for Windows User's Guide.

1. Run the Ability for Windows 1.5 or 1.6 Database application - select Cancel when prompted to 
open an existing table.

2. Select the Export command from the File menu.

3. Select the table you want to export from the list displayed and select OK

4. Select the Ability Exchange format in the List Files of Type box (hint - it's the last in the list).

5. Enter a name for the table in the File Name box (you can simply use the table name if it is 8 
characters or less). Don't replace the AWX extension.

6. Select the OK button

7. Repeat steps 2 through 6 for each table you want to export.




