
Introduction
Photopaint is an image editing and creation program that allows you to perform a wide range of design 
tasks, from editing of family photographs for fun to creation of subtle effects in the design of 
advertisements to promote your business. To this end you will find all the necessary tools for 
manipulating and experimenting with images, allowing you to paint, tone, erase, edit and apply special 
filter effects.

The secret of successful image editing and creation lies in the use of two important Photopaint 
features: selections (see Selections) and layers (see Layers).

Most of the time when you begin to work with any image, you will find it useful to select some area that 
you want to concentrate on, while leaving the rest of the image untouched. (Selections can be seen as 
similar in concept to the highlighting of text in a word processor before changing a font.) In Photopaint 
you can select the whole image or drag the mouse over a rectangular or other shaped area. Once an 
initial selection is made, you can change the shape of that selection, proceed to select all other parts of 
the image of a similar color, and so on. Moreover, once you have made a selection you can then zoom 
in on the selected area, thereby making it easier to apply delicate and subtle effects. There are many 
powerful tools to help you select exactly what you want.

Although a printed image is a two-dimensional arrangement of colors, the creation of the image can 
utilize a feature called layers. Layers allow you to create a finished image by adding to and editing the 
image on different levels, which can be understood on the analogy of several panes of glass stacked 
together. They have a certain (controllable) transparency, and different images can be painted on each 
layer, the overall effect depending on what order you use to stack the layers. The order of the layers 
can be changed as you see fit. Mastering layers simplifies the task of combining component images.

So, the basic elements of Photopaint are:

Selections

Paint and draw tools

Filters

Layers



Starting Photopaint
Start Photopaint from the menus:

1. Select the Start button on the Windows task bar

2. Select Programs and then Ability Office
3. Select Ability Photopaint
The first thing you’ll notice about the opening screen is the lack of standard toolbars. This is because 
you need as much of your screen as possible to view the image. Photopaint has floating toolboxes that 
automatically appear according to the task in hand. The only toolbar that is immediately visible is the 
Tools bar, which contains the various paint and selection tools. In addition, there are three other basic 
toolboxes: Layers, Information and Recent Colors. These can be turned on and off in the View 
menu.



Creating a new image
Create a new image by selecting New from the File menu.

The “New” dialog is displayed.

Here you can set the width, height and resolution of the image window that is to be created and choose
a scale of measurement (pixels, inches, cm, picas, or points).

Give the image a name in the Title box if you don’t want to use the default name.

The Contents box allows you to choose a color for the default background layer: Fore color, Back 
color, or Transparent. The default is Transparent, which normally shows as a checkerboard pattern. 
(You can change the shading and size of the checkerboard pattern in File/Preferences/Grid. A grid 
size of none in effect creates a blank sheet, either light, medium or dark according to the setting.)

For now, just press OK. A new image window will be created.

Note that the background is displayed as a checkered pattern (officially called Level 1 in a new image - 
see Layers). This denotes transparency , a concept which is of great importance in Photopaint. It may 
seem odd at first, but there is an important difference between “nothing” and, say, a white background: 
you can put images onto a transparent background and whatever is beneath the background will show 
through where there are no other images. If it were solid white, any background would be obscured. Of 
course if there is only one layer, there is nothing to see beneath a transparent background. The full 
effect of transparency is best seen with the use of layers (see Layers).

Along the bottom of the image window you can see the current magnification (actual size is 100%) and 
the number of pixels available for the width and height of the image.



On the left the Tools bar is visible.

You can at this point begin using the paint tools straightaway
(see Paint Tools).

At the bottom of the Tools bar you’ll see the Foreground 
and Background Color boxes. These will be important 
throughout Photopaint. (See Color selection)

Color selection
The two boxes at the bottom of the Tools bar are the 
Foreground and Background Color boxes. They are 
interchangeable using the double-arrow button just below. 
The higher box is always the foreground color and the lower 
box the background color.

Whenever you use a paintbrush or pencil tool, it is the current foreground color that is applied. 
Whenever you erase pixels from the background or lowest layer in an image, it is the current 
background or foreground color, depending on which one you chose in the “New” dialog, that shows 
through in a printout, in Print Preview or when viewed through a higher transparent layer.

You can change the color in either of the boxes by clicking on the box to open up the “Select Color” 
dialog.



In here you can select a color by using the mouse to drag the crossed lines in the larger box or the single 
line in the tall thin box. The latter gives you an approximate color range, while the former enables greater 
fine tuning. Alternatively, you can set a color exactly by entering the right figures for Hue, Saturation, 
Brightness, Red, Green and Blue in the boxes to the right. You can also use the respective sliders to do 
this. The result will be displayed immediately in the Preview box. Whichever way you set the color all the 
relevant indicators will change together to reflect the current color: the color boxes, the Preview box, the 
sliders, and the measurement boxes. Once you are satisfied, click on OK.
The relevant color box on the Tools bar will be given the new color.

Note that    as you change the colors in the Foreground and Background Color boxes, the old ones 
are stored in the “Recent Colors” dialog. (If this is not visible, select Recent Colors from the View 
menu.)

Select any of these colors to make it the current Foreground Color.
You can use the Color Picker (see Color picker) to select a color from an image and make it the 
Foreground Color.
While we are on the topic of color it is worth mentioning that the Information dialog (select 
View/Information if this is not visible) can give you useful data about the color values in an image, 
amongst other valuable pieces of information (see Information dialog).



Opening an existing image
You’ll probably spend most of your time editing already existing images, especially photographs that 
have been scanned, rather than designing new images.

In this case, select Open from the File menu and use the “Open” dialog to locate and open the 
required file.

The image file will appear in the Photopaint window as a file of the type in which it was originally 
opened. Since there are some file types which do not preserve any layers you might have added, you 
may choose to use Save As from the File menu to convert the file into a Photopaint image file (that is, 
with extension .apx). This guarantees that any layers you add will be preserved, rather than being 
flattened onto the original image’s background (where they cannot be recovered on a subsequent 
opening of the file). Photopaint files will, of course, require more memory to preserve layers.

Once you have opened the file, the image will appear in the image window. At first it will be displayed 
using the actual pixel size and therefore might be larger than the image window. If you would like to see
the whole of the image, select Fit on Screen from the View menu.

The image will appear on a layer called Background, unlike a new image where the background layer is
called Level 1 (see Layers for some notes on the difference between the two).

At this point you can immediately begin to use the paint and selection tools on the image. However, you
probably don’t want to change the background image itself, so it is best to create a duplicate layer, hide
the background and proceed to edit the duplicate or create further layers. All this is explained in the 
section on layers (see Layers).

Another option is to create a duplicate of the image file, using Duplicate in the Image menu. You can 
then work with the duplicate and leave the original untouched. Whatever you do it is highly 
recommended that you have at least one untouched version of the original file.



Information dialog
The “Information” dialog contains useful information about the color values, selection dimensions and 
current position of the pointer in an image window. It can be a valuable source of instant information as 
you work on an image.

To open up the dialog, select Information from the View menu.

There are four sections in the dialog:
R G B in the top-left corner gives the respective values (between 0 and 255) for red, green and blue in 
any color that the pointer is currently passing over.
C M Y K in the top-right corner gives the respective percentage values for cyan, magenta, yellow and 
black in any color the pointer is currently passing over.

X Y in the bottom-left corner gives the coordinates in pixels (horizontal and vertical respectively) of the 
current pointer position.

W H in the bottom-right corner gives the width and height of a current selection, hence helping you to 
size selections accurately as you make or edit them.



Selections
Photopaint allows you to select parts of images or photographs. The advantage of selection is that you 
can work on a particular area within an image, without having to worry about altering areas outside the 
selection boundary. You may, for instance, want to change the color scheme in only one part of an 
image, leaving the rest of the image untouched. Since all images in Photopaint are pixel-based there is 
no way of automatically selecting, say, the head of a man from a picture that includes the rest of his 
body. Unlike a mere software package, only you, as perceiver, have a definite concept of parts of the 
body. This is where the selection tools come to your aid in helping you target the areas you want to 
work on.

There are several ways of making selections, each achieved through its own selection tool. The 
selection tools are grouped together at the top of the Tools bar, which is visible on the left-hand side of 
the screen when you open up a file. (If it is not visible, select Tools from the View menu).

Once you have made a selection, you can later edit it to refine its borders, change its position or alter it 
in some other way. There is a range of editing options available through the Transform Selection tool 
and the Select menu.

If you have already made a selection, the application of another selection will always override the first.

The selection tools available are:

Rectangular Selection

Elliptic Selection

Single Row Selection

Single Column Selection

Lasso

Polyline Lasso

Magic Wand

B-Spline Selection

Crop



Rectangular selection

Outline of selection is always comprised of horizontal and vertical outlines, joined in a rectangle. Click 

on Rectangular Selection  tool on the Tools bar. Hold down the mouse and drag the cross until 
required horizontal and vertical area is selected.

See:
Selections



Elliptic selection

Outline of selection is always elliptical or circular. Click on Elliptic Selection  tool on the Tools bar. 
Hold down mouse and drag the cross till required area is surrounded by ellipse or circle.

See:
Selections



Single row or single column selection

A single line selection selects one row or column of pixels. Click on Single Row  or Single Column
Selection 

 tool on the Tools bar. Click mouse once at point through which you want row or column to run. To 
reposition line just click at another point.
See:
Selections



Lasso

The lasso tool gives you the freedom to create a selection outline by hand. Click on the Lasso  tool 
on the Tools bar. Hold down mouse and drag lasso symbol around area you wish to select. When 
mouse is released the ends of an incomplete outline will automatically be connected by a straight line. 
This may cut off part of the area you wish to select, so it is best to complete the outline yourself by 
finishing off at the starting point.

See:
Selections



Polyline lasso

The outline is formed by a series of straight lines, joined point to point. Click on the Polyline Lasso 
tool on the Tools bar. Click at the point where you want the outline to start. Click at the next point. A 
straight line will immediately connect the two points. Continue clicking at various points till the outline is 
complete and then right-click. If you do not complete the outline by finishing on the start point, the start 
and finish points will automatically be connected by a straight line.

See

Selections



Magic wand

This tool automatically makes a selection based on the brightness of adjacent pixels within a certain 
threshold. For example, if you click on a solid yellow circle placed within a larger blue one the selection 
will outline the yellow smaller circle. If you click on the blue circle the outline will appear round the blue 
circle and also round the yellow circle, that is, it will select the whole of the blue area and exclude the 
yellow area (rather like a ring doughnut).

Click on the Magic Wand  tool on the Tools bar. The “Magic Wand” dialog allows you to set    the 
threshold value between 0 and 255. The default value is 32. The threshold determines what range of 
pixels will be selected by the Magic Wand in relation to the original selected pixel. A value of 0 will 
result in only the adjacent pixels of exactly the same brightness being chosen. The higher the threshold
value the greater the range of pixels selected, according to brightness. At 255 almost everything is 
guaranteed to be included in the selection.

Anti-aliasing is a technique for softening the edges of a selection by surrounding the edges of the 
selection with a one-pixel transition. You should nearly always leave the Anti-alias box checked.

See:

Selections



B-spline selection

The outline of this selection uses smooth curves to join a series of points.

Click on the B-Spline Selection  tool on the Tools bar.
Click at the point where you want the selection to begin. Click at the next point. The two points will be 
joined by a curve. Proceed with the clicking as you move around the area to be selected. Try to keep the 
points close-in to the area to ensure the accuracy of the selection. Finally click on, or at least near, the 
start point.
To finish, just right-click. The start and finish points will automatically be joined to complete the 
selection.

See:

Selections



Crop

The Crop tool allows you to draw a rectangular border round the area you want to keep, everything 
outside this selection being discarded.

Click on the Crop  tool on the Tools bar and drag the mouse until a reasonably accurate selection 
is made. Release the mouse button. You can refine the crop by moving the mouse over the handles, at 
which point a cross will appear. Depress the left button and drag till you are satisfied with the selection 
on that particular border. Do the same with the other borders, as required.

To perform the crop, right-click and select Crop.

See:

Selections



Selection editing
Once you have made a selection using any of the selection tools (see Selections), it is possible to fine 
tune the selection in various ways, for instance, to make it fit an area more closely or to expand the 
selection borders.

There are two main ways of editing selections. In the Select menu you can apply such features as 

feathering, inversion, smoothness, and so on. Using the Transform Selection  tool you can alter a 
selection dynamically, changing the selection’s position, angle, shape, and so on. Both of these will be 
dealt with.

See:

Selection menu

Transform selection tool



Selection menu

You can edit a selection in various ways through the Select menu. Most of the options in this menu are 
grayed out until you have actually made a selection using one of the selection tools, as you would 
expect. Here are some of the most important option available through the Select menu.

· All selects the whole of the visible window, putting a selection border around it. (Note that it is best 
not to use this option if it is your intention to edit the whole of the image. Although the image as it 
stands may occupy only the visible window, it is possible that at some time you may only have a 
part of the image visible, the rest stretching outside the window boundaries. In this case the 
selection will always be restricted to just that part of the image that is visible. It is best, therefore, to 
select the appropriate layer without making a selection within the layer.

· None clears any current selection. (Note that on occasions you may try to add color to an image to 
no avail, even though you are on the right layer and the layer is visible. It is more than likely that in 
these cases you have not cleared a selection properly, that is, you have clicked on the screen when
a selection tool is active and reduced the selection to a barely visible dot, outside of whose 
boundaries nothing can be done until the selection is cleared.)

· Invert reverses the area currently selected in the visible window. If, for example, you have a small 
circle selected and you then apply Invert, a selection border will appear around the whole of the 
visible window in addition to the circle selection. This means that the selection is now the area 
between the circle border and the outer selection, that is everything in the visible window excluding 
the area within the original selection.

· Feather softens the edges of a selection when color is applied at the selection boundaries. In 
effect, feathering creates a transition area of increasing transparency, which gives an appearance 
of gradual, gentle succession from the selected to the unselected pixels.

The Feather radius is set in the Radius box in the “Feather” dialog and is measured in pixels. The 
greater the radius (2 to 50 is the range) the greater the extent of the feathering.

Note that the effects of using Feather are only seen with colors applied after feathering has been 
applied to a selection. The immediate effect is merely to expand the selection boundaries in 
accordance with the radius set by you.

· Border takes the current selection as a basis for creating a new selection of a specified width. The 
original selection is then abandoned. The border width is set in the Width box of the “Border” 
dialog and is measured both in and out from the boundary of the current selection. 

If, for example, you have a circular selection and then you apply a border of 5 pixels, the new 
selection will consist of a circular band with borders 5 pixels in and five pixels out from the original 
selection, rather like a ring doughnut.

· Smooth reduces the rough edges of a selection. Only the selection outline is affected, not the 
colors within the selection. In the “Smooth Selection” dialog, set the Radius at a value from 2 to 50
pixels. The higher the radius the greater the smoothing that will occur.

· Expand increases a selection by expanding its boundaries outwards. The degree of expansion is 
determined by the value you enter in the Expand by box in the “Expand” dialog. The range is from 
2 to 50 pixels.

· Contract decreases a selection by contracting its boundaries inwards. The degree of contraction is
determined by the value you enter in the Contract by box in the “Contract” dialog. The range is 
from 2 to 50 pixels.

· Transform Selection is used for dynamic editing of selections and actually activates the Transform
Selection tool on the Tools bar (see Transform selection tool).

· Grow uses a current selection to select adjacent areas of the same color as the selection. Grow 
works best when the currently selected area contains a single color.

· Similar uses a current selection to select the same color throughout an image. The areas of color 



need not be adjacent. Similar works best when the currently selected area contains a single color.

· Selection to Alpha deletes the whole of the image on the current layer except for any areas you 
have selected.

· Alpha to Selection selects all colored areas on the current layer. On a layer which is otherwise 
transparent there will be as many selections as there are separate areas of color.

· Make Pattern uses the current selection to store a pattern in the “Pattern” dialog. This dialog is 
called upon by several of the tools, especially the Pattern brush.



Transform selection tool

This tool enables you to take a selection and transform it in various ways. Transform Selection works 
only on the selection boundaries and not on the image within the selection (use Transform Image if you 
want to transform the selected image itself). To transform a selection, obviously you need to have made
a selection first, using one of the selection tools on the Tools bar (see Selections).

Click on Transform Selection  on the Tools bar. A rectangular box is placed around the selection, 
no matter what the shape of the selection. Handles are placed on the boundaries of the box and a 
moveable star-like symbol placed at its center.

The mouse pointer becomes an arrow inside the box, a cross while placed over any of the handles, and a
curved double-headed arrow outside the box.
To move the selection as a whole, place the pointer inside the box and drag the arrow to a new position. 
The whole of the selection is moved to the new position. Note that the image within the original selection 
boundaries stays put when the selection is moved.
To stretch the selection, place the pointer over the relevant handle or handles and drag the cross to a new
position. The selection border will be repositioned.
To rotate the selection, move the pointer anywhere outside the box and drag the curved double-headed
arrow to a new position. Note that the selection rotates round the star-like symbol at the center of the 
box. You can move this symbol by clicking and dragging on it; the selection will henceforth rotate round 
the new position.

You can cancel a transformation by pressing Esc on the keyboard or selecting Undo Transform from 
the Edit menu.

The above operations are together known as Free Transforms, that is they are applied by you by 
hand, using the mouse, and are all available simultaneously. More precise and automatic transforms 
can be performed by right-clicking (or selecting Transform in the Edit menu) and choosing an option 
from the displayed menu (see Transform options). In choosing one of these options, you automatically 
make the others unavailable. For instance, while scaling you will be unable to rotate the selection.

See also:

Transform Image



Transform options

The Transform options are applicable to both Selections (see Transform Selection) and Images (see 
Transform Image).

They are available either by right clicking over a selection box or by selecting Transform in the Edit 
menu i.e. after you have selected either the Transform Selection or the Transform Image tool in the 
Tools box. Note that each of the options transforms either the selection itself or the image within the 
selection, depending on whether you have chosen Transform Selection or Transform Image 
respectively.

The options include:

Scale Scale the transformation box either horizontally or 
vertically by dragging the handles. The selection 
will be scaled to match the new box dimensions.

Rotate Rotate the transformation box by dragging the 
double-headed arrow outside the box. The 
selection will rotate with the box. Note that the 
star-like symbol acts as the center of rotation and 
can be repositioned.

Skew Skew the transformation box by dragging a handle
in the direction of the line on which it is situated. 
You can drag the handle in only one direction at a 
time. The selection will adjust to fit the skewed 
box. Note that dragging a center-of-line handle 
moves the whole of the line.

Distort Distort the transformation box by dragging any 
handle in any direction. The selection will adjust to 
fit the distorted box. Note that dragging a center-
of-line handle moves the whole of the line.

Perspective The dragged handle will move in the direction of 
the line of the transformation box. If the handle is 
at a corner, the opposite corner will move the 
same distance in the opposite direction. Note that 
dragging a center-of-line handle moves the whole 
line.



Numeric

In the “Numeric Transform” dialog set the Position 
values in the X (horizontal) and Y (vertical) boxes. 
Leave the Relative box checked if you want the 
transformation box to move relative to the current 
position, rather than move to a position starting 
from the top left-hand corner of the window i.e. X = 
0 & Y=0.
Set the Scale values in the Width and Height 
boxes. These will scale the width and height of the 
transformation box. If you want the scaling to be in 
proportion leave the Constrain Proportions box 
checked. Whatever you set for the width will also be
automatically set for the height, and vice versa. 
Uncheck the box to set these separately.
Set the Skew values, in degrees, in the Horizontal 
and Vertical boxes. You can set the angle of skew 
anywhere between -60 and 60 degrees.
Set the Rotate value, in degrees, in the Angle box. 
The possible values run through -179 (clockwise 
from the x-axis) to 180 (anti-clockwise from the x-
axis) degrees. Note that there is also an Angle 
Indicator: use your mouse to turn the little circle on 
the circumference of the big circle to set a new 
angle. The value in the Angle box will be 
automatically adjusted.

Rotate Rotate the selection by 180 degrees, 90 degrees 
clockwise or 90 degrees counter-clockwise.

Flip Flip the selection either horizontally or vertically.

Transform Image



This tool enables you to take a selected image or part of an image and transform it in various ways. 
This distinguishes this tool from the somewhat similar Transform Selection (see Transform selection 
tool), which merely transforms selection boundaries rather the image that is selected. Note that 
Transform Image only works with a selection and therefore you need to apply one of the standard 
selection tools first.

Click on Transform Image  on the Tools bar. Handles will appear on the boundaries and a 
moveable star-like symbol will appear in the center of the selection.

The mouse pointer becomes an arrow inside the selection, a cross while placed over any of the handles, 
and a curved double-headed arrow outside the selection.
To move the selected image as a whole, place the pointer inside the selection and drag the arrow to a 
new position. The whole of the selected image is moved to the new position.
To stretch the selected image, place the pointer over the relevant handle or handles and drag the cross to
a new position. The selection border will be repositioned and the image stretched to fit the new border.
To rotate the selected image, move the pointer anywhere outside the selection and drag the curved 
double-headed arrow to a new position. Note that the selection rotates round the star-like symbol at the
center of the selection. You can move this symbol by clicking and dragging on it; the selection will 
henceforth rotate round the new position.

You can cancel a transformation by pressing Esc on the keyboard or selecting Undo Transform from 
the Edit menu.

The above operations are together known as Free Transforms, that is they are applied by you by 
hand, using the mouse, and are all available simultaneously. More precise and automatic transforms 
can be performed by right-clicking (or selecting Transform from the Edit menu) and choosing an option
from the displayed menu (see Transform options).

See also:

Copy, Cut and Paste



Paint tools
The paint tools allow you to apply and edit colors and special tone effects. These tools can be found on 
the Tools bar on the left-hand side of the screen (Select Tools from the View menu if this is not 
visible).

The available paint tools are:

Pencil

Paintbrush

Airbrush

Eraser

Duplicate

Pattern Brush

Blur

Sharpen

Emboss

Dodge

Burn

Smudge

Historic Brush



Pencil

This tool enables you to draw using a brushstroke with hard edges, as with a real pencil.

Click on Pencil  on the Tools bar.
In the “Brushes” dialog choose the method of applying the pencil from the following:

· Free Hand  enables you to draw directly with the current foreground color, the path of the 
applied color following the movement of the mouse when the button is depressed.

· Spline  enables you to plot a series of connected curves by clicking at the relevant points. To 
finish, right-click and the curves are replaced with the foreground color.

· Line Drawing  enables you to plot a series of connected lines by clicking at the relevant points,
which are replaced with the foreground color when you right-click.

· Ellipse  enables you to draw an ellipse by dragging the mouse till you have the wanted shape 
and size. On releasing the mouse button the ellipse is converted into the foreground color.

· Arc  enables you to draw an arc (or incomplete circle). Click on the spot which you want to be 
the center of the arc and move the mouse (there’s no need to keep the button depressed) till you 
have the required dimensions. Click once more and use the mouse to move clockwise to reduce 
the angle of the arc from a full circle or anti-clockwise to increase the angle from zero. Click once 
more to replace the arc with the foreground color.

· Rectangle  enables you to draw a rectangle by dragging the mouse till you have the required 
dimensions. On releasing the button the sides of the rectangle are replaced with the foreground 
color.

Select a shape and size for the pencil stroke from the Brushes box (see Brushes).

Select a mode in the Mode box (see Brush modes).

Change the degree of transparency in the Opacity box.

Note that Pencil produces a “harder” outline than Paintbrush, which employs a technique called 
“dithering” to soften the edges of a painted shape. Basically, dithering consists in softening the edges 
of an area of color by fading it into the surrounding color. This results in a less stepped edge than is 
produced by Pencil. The effect of dithering becomes more apparent if you increase the size of the 
image (see Zoom).

See:

Paint Tools



Paintbrush

This tool enables you to paint using a brushstroke with soft edges, as with a real paintbrush.

Click on Paintbrush  on the Tools bar.
In the “Brushes” dialog choose the method of applying the pencil from Free Hand, Spline, Line 
Drawing, Ellipse, Arc, Rectangle (for information on each of these, see Pencil).
Select a shape and size for the brushstroke from the Brushes box (see Brushes).
Select a mode in the Mode box (see Brush modes).

Change the degree of transparency in the Opacity box.

Note that Paintbrush produces a “softer” outline than Pencil, employing a technique called “dithering” 
to soften the edges of a painted shape. Basically, dithering consists in softening the edges of an area of
color by fading it into the surrounding color. This results in a less stepped edge than is produced by 
Pencil. The effect of dithering becomes more apparent if you increase the size of the image (see 
Zoom).

See:

Paint Tools



Airbrush

This tool allows you to paint with soft, hazy brushstrokes, as with a real airbrush. Moreover, the color is 
fed out continuously and so will thicken whenever you keep the pointer in one place for a while or move
it very slowly across the page.

Click on Airbrush  on the Tools bar.
Choose a brush size and shape from the options in the “Brushes” dialog (see Brushes). You can decide 
how transparent the paint should be by altering the value in the opacity box. 100% is, of course, the 
maximum.
See:

Paint Tools



Eraser

This tool allows you to “erase” pixels. In reality the effect of the Eraser tool is to change existing color 
values by:

· applying the current background color when used on the background layer

· converting the colored pixels of an image on any other layer to fully transparent pixels

Click on Eraser  on the Tools bar.

Select a brush shape and style from the “Brushes” dialog (see Brushes). Depending on the brush 
chosen you can erase colored pixels in a variety of ways, sometimes getting a complete erasure and 
sometimes a faded effect.

Change the degree of transparency in the Opacity box. The higher the value the more pixels will be 
erased by the selected brush.

See:

Paint Tools



Duplicate

This tool allows you to “clone” a part of an image and then paste it elsewhere. It is useful if you have 
an image that needs retouching and it would be appropriate to use a similar color and pattern from 
elsewhere in the image.

Click on Duplicate  on the Tools bar.
Select a brush mode from the “Texture Brush Options” dialog (see Brushes). This will determine the 
shape of the area to be cloned.
Select a mode in Mode (see Brush modes).
Change the degree of transparency in Opacity.

Next, press Alt on the keyboard and click once on the area that you want to clone.

Move the pointer to the area you want to paste to and press on the mouse button for a couple of 
seconds. The clone will be pasted in the shape of the brushstroke you chose. Drag the mouse if you 
wish to duplicate over a larger area.

Note that cloning can duplicate every part of an image window, starting from the paste point and 
copying everything that the cross moves over. The original position of the cross coincides with the copy
point. If you wish to clone within a selected area you can use one of the selection tools first (see 
Selections).

See:

Paint Tools



Pattern brush

This tool allows you to paint with a pre-defined pattern.

Click on Pattern Brush  on the Tools bar.
In the “Pattern” dialog select the pattern you want to paint with.

In the “Duplicate Options” dialog (this contains the same brushes as in the “Brushes” dialog) select a 
brush style with which to apply the pattern.
Proceed to paint with the brush by dragging the mouse.
You can, of course, draw the pattern in a restricted area by using a selection tool.
(Note that to use the Pattern Brush you must already have created a pattern. To create a pattern, use 
one of the selection tools to select the area containing the pattern you want to paint with. Next, select 
Make Pattern from the Select menu. Alternatively, you can use a pattern from a external file by loading
the file in the Patterns Editor - see Patterns Editor.)

See:
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Blur

This tool blurs an image by reducing the contrast between adjacent colors.

Click on Blur  on the Tools bar.
Select a brush style and shape in the “Brushes” dialog (see Brushes).
Keeping the mouse button depressed, drag the pointer over the area that you want to blur.
See:
Paint Tools



Sharpen

This tool sharpens an image by increasing the contrast between adjacent colors.

Click on Sharpen  on the Tools bar.
Select a brush style from the “Brushes” dialog (see Brushes).
Keeping the mouse depressed, drag the pointer over the area you want to sharpen.
See:
Paint Tools



Emboss

This tool enables you to cause an area of an image to stand out, as in a relief made of stone or metal. 
You can choose to maintain the color of the image or convert the image to grayscale as you paint with 
the emboss tool.

Click on Emboss  on the Tools bar.
In the “Emboss Options” dialog select a style and shape for the brush (see Brushes).
Use the sliders to set an Azimuth between 0 and 360 degrees, an Elevation between 0 and 180 
degrees, and a Depth between 0 and 100%. These control the amount and direction of light and shadow 
in the embossed image. You can think of the Elevation and Azimuth as determining the angle of a single 
light source in the vertical and horizontal planes respectively. The Depth determines the depth of the 
relief. The combination of these determines the appearance of the embossed image. (As you would 
expect, an elevation of 90 degrees i.e. the light source is directly above the image, makes the embossed 
image brighter, and an elevation of 0 or 180 degrees leads to a darker image. A depth of 0%, since it 
flattens the image, reduces the contrast between lights and shadows and therefore produces a more 
uniform embossed image, whether dark or light. The azimuth, since it determines the angle of light in the 
horizontal plane, alters the direction of light and shadow.)
Select Emboss for grayscale, otherwise select Bumpmap to preserve color.

Drag the brush over the area of the image you want to emboss.

See:
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Dodge

This tool allows you to lighten the tones of the colors in an image.

Click on Dodge  on the Tools bar.

In the “Dodge Options” dialog select the style and shape of the brush (see Brushes).
Choose the tonal range on which to concentrate from the following:
· Highlights concentrates on the lighter tones, making them lighter still, but also affects the darker 

tones.

· Midtones concentrates on all tones, making them lighter, apart from the very light or dark.

· Shadows concentrates on the darker tones, making them lighter, but also affects other tones.

Adjust the value in Exposure to change the amount of tonal lightening you want to allow. A higher 
value results in a greater lightening over the tonal range chosen. (This effect is similar to a 
photographer’s use of light intensity when exposing a negative.)

Proceed to drag the brush across the relevant areas.

See:
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Burn

This tool allows you to darken the tones of the colors in an image.

Click on Burn  on the Tools bar.

In the “Burn Options” dialog select a size and shape for the brush (see Brushes).
Choose the tonal range on which to concentrate from the following:
· Highlights concentrates on the lighter tones, making them darker, but also affects the darker 

tones.

· Midtones concentrates on all tones, making them darker, apart from the very light or dark.

· Shadows concentrates on the darker tones, making them darker, but also affects other tones.

Adjust the value in Exposure to change the amount of tonal darkening you want to allow. A higher 
value results in a greater darkening over the tonal range chosen.

Proceed to drag the Burn pointer over the areas you want to change.

See:
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Smudge

This tool allows you to smear an image. The effect on the color values of the image is determined by 
the brushstroke used and amount of pressure selected. A larger sized brush will smear a greater 
amount of color and a higher pressure will redistribute the color over a wider range.

Click on Smudge  on the Tools bar.
In the “Smudge Options” dialog select a size and shape for the brush (see Brushes).
Use the slider to set the pressure in the Pressure box.
Proceed to drag the Smudge pointer through the appropriate areas of the image.

See:
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View tools
There are two tools that make it easier for you to view an image: Hand and Zoom.

See:

Hand

Zoom



Hand

This tool allows you to move an image when the image is larger than the current window. Since you 
can drag the image in any direction, this gives you more freedom than when using the scroll bars. Also 
it is handy for those times when you are using Full Screen view and the scroll bars are not visible.

Click on Hand  on the Tools bar.
Keeping the mouse button depressed, use the hand to drag the required portion of the image into view.
See:
Zoom



Zoom

This tool allows you to magnify the image in the current window.

Zoom comes with a selection outline that gives you the power to “zoom in” on a part of the image. You 
choose which part of the image you want to fill the window with after using Zoom. The smaller the 
selection the greater will be the magnification applied to the image as a whole. This is because the 
selected area is zoomed up to fill the whole of the window.

Once you have applied Zoom, you can use the Hand tool to move around the image. Alternatively use 
the vertical and horizontal scroll bars. With the magnified image before you, you can proceed to apply 
the paint tools as normal.

There are several ways of magnifying an image, as follows:

Click on Zoom  on the Tools bar. The pointer becomes a magnifying glass.
Click anywhere in the window and zoom will be applied.
To zoom in on a specific area, left click and drag the pointer till you are satisfied with the selection 
borders, that is, you have surrounded the area you want to zoom in on. Release the mouse and zoom will
be applied, the selected area filling up the window.
If you want to cancel a selection before zoom is applied, press ESC on the keyboard. You can then go 
ahead and make another selection.

For further zoom options, right-click and select from Zoom In (increases magnification), Zoom Out 
(decreases magnification), Actual Pixels (reduces image to original size) and Fit To Screen (fits 
image to screen.

The maximum magnification is 1600% or 16 times the original size.

See:
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Brushes
Every time you select a Paint tool a dialog is displayed with an array of brushes. Although the same 
brushes are common to each of the Paint tools, the dialogs in which the brushes are displayed are 
slightly different from one another, depending on the particular tool selected.

The brushes vary in size, shape and solidity, and determine how quickly color is applied, toned or erased, 
and over how large an area. This allows you to work, on the one hand, very quickly with large uniform 
patches of color, and, on the other hand, to concentrate on the details in a small area of an image. You 
can switch between brushes with ease.
The two main tools for painting are Pencil and Paintbrush (see Paint Tools). Whenever you choose a 
paint tool, you have the option to choose a brush through which the paint tool can be applied. If you do 
not specifically select a brush, the last brush used by the particular paint tool remains selected. (Pencil 
produces a “harder” outline than Paintbrush, which employs a technique called “dithering” to soften the
edges of a painted shape.)

Whenever you select a brush its name and the number of pixels in the brush shape are displayed 
above the “Brushes” box. For instance, one of the squares has this attached information: Square <10, 
10>. This means that the selected shape is a square that is 10 pixels by 10 pixels. Another option is: 
Circle, radius = 17 <35, 35>, for a circle with radius 17 pixels, and vertical and horizontal axes through
the center of the circle i.e. the diameter, of 35 and 35 pixels respectively.

There are 53 standard brush styles in all. You can create and edit your own brushes by right-clicking in 
the “Brushes” dialog and selecting an option to open up the “Brush Options” dialog. Alternatively, 
select the Brush Editor from the Tools menu, where there is a full set of tools for editing and creating 
brushes. (See Brush Editor)

The effect of applying any Paint tool and therefore the particular brush style used with a tool, is to 
change the color value of every pixel that comes into contact with the brush. Three concepts relating to 
the application of Paint tools need to be understood:

Base color: the pixel color before the brush is applied.

Blend color: the color you wish to apply.

Resultant color: the color after the blend color has been combined with the base color using a 
particular brush style.

These notions are important in understanding the way the various Brush modes work (see Brush 
modes), that is the way the applied color blends with the already existing color. The default value for 
the blending mode is Normal, as you can see in the Mode box.

Another important concept when selecting a brush style and blend mode is that of opacity, which is set 



in the Opacity box. If an applied brushstroke has opacity of 100% and the mode is set at Normal, the 
brushstroke will completely over-paint any color that it comes into contact with. The lower the opacity 
the more transparent or “see-through” the applied color will be, hence enabling you to see through to 
the colors beneath. Obviously opacity is a matter of degree and it is certainly worth experimenting with 
it to understand its full effect.

See:

Brush Editor



Brush modes
You can set a brush mode for several of the tools, for example, Pencil, Paintbrush, Duplicate, Fill and
Gradient Fill. The brush modes determine how an applied brush stroke affects the colors already in an 
image. Essentially, this can be understood in terms of the existing or base color of a pixel, the color that
will be applied by the brushstroke, and the color that results from the combination of the base and 
applied colors, as determined by the selected brush mode. For instance, if you paint a blue line over a 
patch of red in an image, do you want the red to be completely replaced by the blue, or somehow 
blended with it? The brush modes allow you to decide how and to what extent the applied color will 
affect what is already there.

The main options, which you can select in the Mode box in the “Brushes” dialog, are:

· Normal The color is applied in full, that is to say, the existing base color is totally over-painted.

· Dissolve A color applied with a less than 100% opaque brush is converted - “dissolved” - to 
100% opaque randomly scattered pixels. The effect is of a rough brushstroke rather than an evenly
transparent one.

· Multipy The brightness values of the base and applied colors can be combined to create a 
darker tone. This is done by multiplying the two brightness values when they are expressed as 
fractions. For example, white has a brightness value of 255 (the maximum) and is represented as 
255/255 or 1; black has a brightness value of 0 (the minimum) and is represented as 0/255 or 0. All
other brightness values are represented as fractions between 0 and 1 e.g. 150 is represented as 
150/255; 100 as 100/255. Therefore, using Multiply we get the result (100 * 150) / (255 * 255), 
which works out at 59/255. You can immediately see that the resultant brightness will always be 
lower than (or equal to) the brightness of either one of the multiplied fractions. This intuitively fits in 
with our experience of placing one transparent sheet on top of another, where the result is always 
darker.

Note that the above means that if the applied color is white, the resultant color is the same as the 
base color. If the base color is white, the resultant color is the same as the applied color. If either 
the base or the applied color is black, the resultant color is black. If the base color is transparent, 
the result of applying any color is black (since a transparent layer counts as 0, that is the same as 
black).

· Screen This mode has the opposite effect from Multiply, combining the base and applied colors 
to create a lighter tone.

These are some of the more important options but there are many others that it is worth experimenting 
with:

Behind, Overlay, Difference, Addition, Subtraction, Darken Only, Lighten Only, Hue, Saturation, 
Color, Luminosity, Divide, Color Burn, Color Dodge, Hard Light, Soft Light
See:
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Typing and color fill tools
In addition to the selection and paint tools, there are several other useful tools that enable you to insert 
text or color into an image.

These include:

Type Tool

Historic Brush

Fill Tool

Color Picker

Gradient Fill



Type tool

This tool allows you to enter text. The text is placed in the document as if it had been painted directly by
you i.e. it is pixel-based rather than object-based. This means that the text can be edited, using the full 
range of tools, just like any other part of an image, but cannot take normal text editing.

1. Click on Type  on the Tools bar. The pointer will turn to a T-symbol.

2. Position the T where you want the text to go and click once.

3. In the “Type Tool” dialog type your text in the top box.

4. Choose from Left, Center and Right in the Alignment box.

5. In the Angle box type a new angle or use the arrows to scroll. The angle will be measured anti-
clockwise from the horizontal.

6. If you would like the text to go on a new layer, check the Add Layer box. A Text Layer will then be 
created for the text. Note that unless you explicitly change layers all new paint or text operations 
will take place on this new layer.

7. Check the Outline box to make text appear in outline rather than as solid.

8. All the usual font commands for your text are available through the Font button.

9. The text and the applied formats will appear in the Preview box, giving you the opportunity to make
changes before clicking on OK.

See:
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Historic brush

This Historic Brush  on the Tools bar, enables you to reverse the last operation performed on an 
image. In this it is like the Undo command but limited to undoing the last operation only. However, 
unlike Undo the Historic Brush allows you to partially recover pixels from the result of the last complete 
operation rather than recover the whole result. (By “complete operation” is meant the action carried out
between one click of the mouse and the next click.) The Historic Brush can be used in conjunction with 
the History palette to recover the state before a previous incarnation of an image (see History palette).

See:
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History palette

It is possible to go back to an earlier state of an image by selecting the History option under the Edit 
menu. The “History” dialog lists the states that you can recover. The actual states are shown on the left
of the dialog and the operation that corresponds to each of the states is shown on the right.

Use the scroll bar, if necessary, to see more of the states of the image, and then click on the state you 
would like to recover. You can then proceed to work with the recovered image.
Note that any intermediate states between the current and the recovered state are lost, unless you 
choose one of them from the “History” dialog. Also there is a limit to the number of previous states 
remembered in the dialog.

You can use the History palette in conjunction with the Historic Brush (see Historic brush).

See:
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Fill tool

This tool allows you to apply color by clicking on an image. The color you click on will be taken as the 
standard, and all adjacent pixels within a certain tolerance, using either the default or one set by you, 
will be filled in with the Fill color. The tolerance is a measure of the brightness of pixels and stretches 
out in either direction from the selected color. The Fill color itself is the currently selected foreground 
color.

Click on Fill  on the Tools bar.

1. In the “Fill Options” dialog set the following options:

2. Select a mode in the Mode box (see Brush modes). The default is Normal.

3. Set the opacity in the Opacity box: 0 is total transparency, that is the underlying color shows 
through totally; 100 is total solidity, that is the fill color covers the underlying color totally.

4. The tolerance is set in the Threshold box: 0 causes only adjacent pixels with exactly the same 
color (strictly speaking, brightness) to be filled; 255 causes all pixels in the image to be filled.

5. Leave Color Fill checked to apply a color fill.

6. Pattern Fill allows you to use a pre-saved pattern instead of the selected foreground color. (To 
create a pattern you first need to use one of the selection tools to select the area containing the 
pattern you want fill with. After this, select Make Pattern from the Select menu. The selected 
pattern will then appear in the Pattern box and will also be available for future use.)

7. Once you have chosen a suitable color or pattern and set the threshold, opacity and mode, just 
place the Bucket pointer over the area to be filled and click once. The fill will go ahead according to 
the settings you chose.

See:
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Color picker

This tool allows you to define a new color for either the foreground, background or paint tools by 
clicking on a part of an image.

Click on Color Picker  on the Tools bar. The pointer turns to an eye-dropper.
Position the eye-dropper over a color and click once. The foreground color box on the Tools bar becomes 
the same color as the color you clicked on.
You can now use a paint tool to paint with this color, or redefine the background color by exchanging the 
foreground color box with the current background color box.
(Note that the Recent Colors box displays a collection of the most recent colors picked out by the 
Color Picker, or selected in the Select Color dialog - see Color selection - when you are choosing a 
color for the foreground. If it is not visible, select Recent Colors from the View menu. Selecting any of 
the colors will make it the current foreground color.)

See:

Color selection
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Gradient Fill

This tool allows you to fill an area, whether a selection or an entire layer, with a range of colors. Starting
with one color and progressing to another, the colors in between are graduated according to the 
particular gradient used. The extent of the gradient is determined by the distance you drag the pointer.

There are four basic features of Gradient Fill that you will need to understand to use it properly:

· Gradient The various gradients available are ways of determining particular color progressions. 
Some use the current background and foreground colors to generate the gradient, others use 
different color schemes, depending on the choice of gradient (the gradient name is usually 
indicative of the range of colors to be used).

· Gradient type The gradient type is the “shape” of the gradient. The default type, Linear, takes the 
gradient set in Gradient and spreads it in a straight line from the start to the finish point, that is to 
say, in a definite direction across the image window. The Spiral type forms a spiral gradient around
the start point; the shorter the distance you drag the pointer, the tighter the spiral. There are many 
other gradients types from which to choose.

· Mode The brush modes determine how the gradient will blend with any colors already there on the 
layer. Note that the mode determines a permanent state of the image and can only be undone by 
selecting Undo from the Edit menu. Some examples of blending are given in Brush modes.

· Opacity The opacity slider measures the degree of transparency or “see-throughness” of the 
applied gradient. A setting of 100% will completely cover any existing image with the applied 
gradient; anything less than this and the existing image will be visible through the gradient. Note 
that the opacity here determines a permanent state of the image and can only be undone by 
selecting Undo from the Edit menu.

All of these features are available in the “Gradient Fill” dialog.

To apply a gradient fill, do the following:

1. Click on Gradient Fill  on the Tools bar.

2. In the “Gradient Fill” dialog set the following options:

· Choose from the blend modes in Mode (see Brush modes). The default is Normal.
· In Opacity use the slider to set the transparency of the gradient. The default is 100% or 

totally opaque.

· In Gradient select a gradient. The default is FG to BG RGB mode.

· In the Gradient Type box select a gradient type. The default is Linear.
Once you have made your selections, click on a spot in the image window from where you want the 
gradient to start. Drag the gradient pointer to a finish point and release the mouse button. The gradient 
will be applied after a few seconds, in conjunction with the gradient type, mode and opacity.

Note that the shorter the distance you drag the pointer the more tightly will the band of colors be 



packed.

In addition, you can create and edit your own gradients, which can be saved for future use. To do this 
click on Edit to open up the Gradient Editor (see Gradient Editor) and set the required options.

For some examples see Gradient Fill: examples.

See:
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Gradient Fill: examples

This section continues the explanation given in Gradient Fill and also gives some examples.

1. In the Gradient box you can choose the basic colors for the gradient. The default gradient is FG to 
BG RGB (Red, Green, Blue) mode, followed by FG to BG HSB (Hue, Saturation, Brightness) 
mode. Both of these produce a gradient that runs from the foreground color through to the 
background color, blending the tones in between. The next option, Foreground to transparent, 
produces a gradient in which the foreground color gradually thins out. These three gradients all use
the current foreground and background colors to produce their effects.

There are many other gradients, most of which, like German Flag and French Flag, generate 
colors independently of the current foreground and background.

2. In the Gradient type box you can choose a shape or style for the gradient. The default type is 
Linear, which draws the gradient in a straight direction across a plane. The other options include 
Radial, Spiral Clockwise and Anti-Clockwise, Square, Conical Symmetric and Asymmetric, 
and BiLinear. Each of these defines a style for the gradient. For instance, if you select one of the 
spiral options and drag the pointer a short way across an image, a tight spiral will be drawn, of 
course using the currently selected gradient. If you drag the pointer a greater distance the spiral will
be much wider. The same general principle goes for all the other gradient types. For instance, if 
you use the gradient FG to BG RGB (Red, Green, Blue) mode with the Linear type, the 
foreground and background colors will form solid blocks before and after the start and finish points 
respectively.

3. In the Mode box you determine how the gradient will be blended with the existing image. The 
default is Normal. There are many others, including Dissolve, Multiply and Luminosity. The best 
way to get to know how the modes work is to experiment. There is more explanation and some 
examples in Brush modes. Two things worth remembering are: the mode used with the gradient is 
permanent once applied and can only be undone by using Undo from the Edit menu; in most 
cases the gradient will cover the existing image if the Opacity is set at 100%.

4. In the Opacity box you can choose the transparency of the gradient. The default is 100% opaque 
(or 0% transparent). As said above, you need to reduce the opacity from 100% in order to see the 
existing image show through the applied gradient. Remember that the effect of applying a gradient 
with an opacity is permanent and can only be undone by selecting Undo from the Edit menu.

The gradient is always applied by dragging the pointer and then releasing the mouse. Different 
gradients will take longer or shorter periods of time to be take effect. All in all the final effect depends on
the combination of settings made in the Gradient, Gradient type, Mode and Opacity boxes.

Using these settings:

this gradient can be produced:



See:
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Filters
Filters are the Photopaint equivalents of the filters used in photography to create various effects. As in 
photography, some filters are merely corrective in that they try to preserve the appearance of the 
original image while removing some defects, and others are creative in that they radically change the 
image.

The best way to understand the effects of filters is to experiment with them a bit. Here only a few of the 
filters, of the many available, will be described.

All of the filters are accessible through the Filters menu.

They are grouped into several general categories, for example, Artistic, Sharpen, Distort, Tiles, and 
others. Within these categories there is a wide range of types, many of which are editable by you.

Take a look at Super Nova under Light Effects. A dialog will open, making it possible to edit and 
preview the filter before applying it.

· Use the Radius and Spokes sliders to increase and decrease the radius and number of spokes 
respectively of the super nova. The changes will immediately be displayed in the Preview box to 
the left.

· The X and Y boxes give the horizontal and vertical positions respectively. You can set these 
precisely by typing new values into the boxes. Alternatively use the mouse to click on a spot 
anywhere in the Preview image.

· The Color box contains the current background color. If you’d like a different color click anywhere 
in the Color box to open up the “Select Color” dialog. Here you can use the mouse to select a 
color. This will not affect the current background color. Once you have designed your super nova, 
click on OK and watch the filter take effect. Depending on the size of the image, it can take 
anything from a few seconds to a couple of minutes.

Note that whenever a filter is applied it affects only the currently selected - or active - layer.

You can undo the filter by selecting Undo from the Edit menu.

You can apply as many filters as you like to an image, whether on the same layer each time or across 
some or all of the layers, using many different types of filter.

Taking the above super nova effect, you can add a page curl filter on top. This is another good filter to 
experiment with and again easily editable.

Select Filters/Artistic/Page Curl to open the “Page Curl” dialog.



· In the Parameters box use the sliders to set the Opacity, Ratio, Size and Angle of the curl.

· Click the Shadow under curl checkbox on for a shadow effect.

· (All of these effects will become obvious to you as you look at the immediate implementation of the 
changes in the Preview box.)

· You can change the color of the curl in the Curl Shading Color box, using either the current 
foreground or background color, or even a previously saved pattern.

· In the Orientation box choose between vertical and horizontal.

· Lastly, choose a corner for the curl in the Location box.

· Once again watch the changes take place in the Preview box and click on OK once you’re 
satisfied.

The filter effects will take a few seconds to be implemented. If you decide you don’t like them, just 
select Undo from the Edit menu and start again.

Note that once you’ve applied a filter you can make some further changes using the Fade … option at 
the top of the Filters menu. Thus in the case of Page Curl you can select Fade Page Curl to open the 
“Fade” dialog. In here you can change the opacity and the blend mode of the curl (or whatever was the
last filter you applied).



The effect is to fade the filtered image into the original unfiltered image by reducing the opacity from the
maximum of 100%. As the slider approaches 0 in the Opacity box the effect of the filter becomes 
fainter until at 0 the unfiltered image is restored. You can experiment with fading and immediately see 
the results in the image window.

The options in the Mode box - Normal, Dissolve, Behind, Multiply, and so on - determine how the 
filter will blend with the existing colors. The modes work pretty much as they do in Blending between 
layers, with the difference that once you’ve applied Fade the blend becomes permanent (although you 
can undo a fade or a filter by selecting Undo from the Edit menu).

Click on OK to exit the dialog and apply the Fade, otherwise click on Cancel.
For more examples of filters, see Filters: examples.



Filters: examples
In the section on Filters (see Filters) you were introduced to the concept of filters and shown a couple 
of examples (Super Nova and Page Curl). Altogether there are 93 filters divided into 10 categories. In 
addition, the Custom Filter option allows you to design your own filters. With such an extensive range of
filters there are obviously many possibilities for combining different filters to produce even more effects.
As ever, the best way for you to learn about these possibilities is to experiment.

The categories are: Artistic, Sharpen, Blur, Stylize, Edge Detect, Tiles, Distort, Noise, Light 
Effects, Effects, Custom Filter.
Here we will describe a few more of the filters:

Filter: Add Noise

Filter: Waves

Filter: Blur

Filter: Mosaic

Filter: Light Effects



Filter: Add Noise

The Add Noise filter is accessible in the Noise category in the Filters menu. This filter concentrates on
single pixels, increasing or decreasing their color values and thereby creating “noise” in the image. 
Noise can be defined as those single or small groups of pixels whose color values differ considerably 
from those of the bulk of nearby pixels. The overall effect can be like the grainy look of old film.

In the “Add Noise” dialog set the following options:
In the Parameters box:

· Use the slider to set the Amount of variation from the original colors. The lower the amount the 
closer are the pixels to the original image colors.

· Tick the Monochromatic box if you want to create noise that lightens or darkens pixels but leaves 
their hue unaffected. This results in most pixels being either black or white when Amount is set to 
high.

In the Distribution box choose the type of random distribution to be used for the noise:

· Uniform leads to a random distribution of even density throughout the image.

· Gaussian leads to a much more random distribution than Uniform, in which noise can be 
concentrated in single pixels and groups of pixels, and there can be areas of no noise at all.

All the changes you make can be seen immediately in the Preview box.

See:

Filters
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Filter: Waves

The Waves filter is accessible in the Distort category in the Filters menu. The effect    is of an image 
being distorted when viewed under ripples of water.

In the “Waves” dialog use the sliders to set the following in the Parameters box:
· Amplitude The height of the waves between 0 and 100

· Phase The point in the wave cycle in degrees between 0 and 360

· Wavelength The wavelength between 0 and 50

All the changes are immediately shown in the Preview box.

See:
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Filter: Blur

There are several filters grouped together in the Blur category in the Filters menu. All of these filters 
blur images by searching out areas of strong color contrasts and sharp edges, which are then softened 
by converting pixels in the relevant areas to an average of their total color values.

The most basic and quickest filters to use are:

· Blur
· Blur More
· Heavy Blur
None of these brings up a dialog for you to make your own settings and there is no way to preview the 
results. Essentially they are a rough and ready way of averaging the sharp contrasts in an image, 
though without being susceptible to fine control. As the names suggest they are, in ascending order, 
relatively stronger than one another in their effects.

The following Blur filters give you much more control:

Motion Blur

Gaussian Blur

Smart Blur

See also:

Filters

Filters: examples



Filter: Motion Blur

This filter, available through Filters/Blur/Motion Blur, makes the contents of an image look as if they 
were in motion.

In the Parameters box of the “Motion Blur” dialog you can do the following:
· Set the extent of the blur (between 0 and 255) by sliding the Length slider.

· Use the Angle slider to set the direction of the blur.

In the Blur Type box choose from these options:

· Linear blurs in straight lines. (Note that when you use Linear, the blur will run in the direction you 
set and in the opposite direction.)

· Radial blurs out from the center of the image.

· Zoom blurs within the original area, concentrating the colors according to the setting in Length.

All the changes you make can be seen in the Preview box.

See:

Filter: Blur

Filters

Filters: examples



Filter: Gaussian Blur

This filter, available through Filters/Blur/Gaussian Blur, gives a more naturalistic look to the 
transitions between adjacent colors when blurring. It achieves this by blurring unevenly, as is the case 
in real life, according to the distribution calculated using the Gaussian Bell Curve. Essentially this filter 
reduces detail in an image, while trying to avoid the artificial look of too smooth a blur across the image.

In the “Gaussian Blur” dialog set the following:
· Use the Blur Radius slider (or type in the value directly) to set the radius of blur, between 1 and 

100. This controls the amount of blurring by using the blur radius, as a measure from the center of 
each pixel, for averaging of color values. The greater the blur radius the greater the overall blurring 
of the image.

· The Blur Horizontally and Blur Vertically checkboxes are both checked by default. Click to 
uncheck either or both of these. As their names indicate they determine the direction of the blur. 
You would normally want to blur in both directions. Note that unchecking both boxes makes it 
impossible to blur at all.

All your settings will immediately appear in the Preview box.

See:

Filter: Blur

Filters
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Filter: Smart Blur

This filter, accessible through Filter/Blur/Smart Blur, works to remove low-intensity “noise” from an 
image. It does this by preserving the areas where there is a sharp color contrast, such as edges, and 
blurring the areas where the colors are almost the same (within a tolerance set by you). As you can 
imagine, this is useful when treating grainy photographic images, since the grainy areas are usually 
only slightly different in color from the surrounding areas. The real detail of the image is largely left 
untouched.

In the “Smart Blur” dialog set the following:
· Use the slider to set the Radius - or type it directly into the box - between 1 and 50. The radius is a 

measure of the distance from the center of each pixel and determines the extent of the color 
averaging that constitutes the blurring process. Naturally the higher the radius, the greater the 
blurring.

· Set the Maximum Delta, again by using the slider or typing, between 0 and 255. This is a measure
of the threshold for blurring. At low values there is blurring only between very similar colors; at high 
values almost any colors, no matter how dissimilar, may be blurred together.

The effects of your filter settings are displayed in the Preview box.

See:

Filter: Blur

Filters

Filters: examples



Filter: Mosaic

This filter is accessible through Filters/Artistic/Mosaic and gives you the power to apply a range of 
mosaic effects. The mosaic tiles are surrounded by a black border and the colors of the tiles 
themselves are based on the colors of the original image. Any spaces between tiles are colored black.

Once you have entered the “Mosaic” dialog you have various options.
In the Tiling Primitives box, choose the basic mosaic shape:
· Squares
· Polygons
· Polygons & Squares
In the Parameters box, set the following as you wish:

· Tile Size: the size of the tiles between 5 and 100. The higher the value the fewer the tiles used to 
comprise the image.

· Tile Height: the height of the tiles between 1 and 50.

· Tile Spacing: the spacing of the tiles between 1 and 50. The lower the value the tighter the fit 
between the tiles.

· Tile Neatness: the degree of neatness, or regularity of shape, of the tiles between 0 and 100%. 
The lower the value the more irregular the tile shapes.

· Light Direction: the angle the light falls on the tiles between 0 and 360 degrees.

· Color Variation: the color differences between the tiles can be heightened or lowered between 0 
and 100%. The lower the value the closer the tiles are in color.

In the Options box tick the boxes to set the following:

· Anti-aliasing: This is a technique for softening the edges of the individual mosaic tiles by 
surrounding their edges with a one-pixel transition.



· Color Averaging: This alter the colors of the individual tiles so that they are an average of their 
own color and the surrounding colors.

· Pitted Surfaces: The tiles are given a pitted look, rather like an image of the surface of the moon.

· FG/BG Lighting: The edges of the tiles are traced in the current foreground and background 
colors, according to the colors of the tiles they surround.

All your settings are shown in the Preview box.

See:

Filters

Filters: examples



Filter: Light Effects

The Light Effects filters all work with the qualities of light in your images. You may already have seen 
one of these, Super Nova, described in the Filters section (see Filters).

Here we will describe a few more of the light filters:

Lens Flare

Discotheque

Star

See also:

Filters: examples



Filter: Lens Flare

This filter, accessible through Filters/Light Effects/Lens Flare, makes part of an image stand out by 
brightening the pixels, with the surrounding pixels becoming progressively less bright. As the name 
implies the effect is as of a bright flare.

In the “Lens Flare” dialog set the following:

· Use the Brightness slider (or type directly into the box) to increase the brightness of the flare. The 
maximum is 500% or five times the original brightness.

· In the X and Y boxes you can set the location of the flare. The location is measured in pixels from 
the top left-hand corner of the image window.

Your settings will be displayed in the Preview box.

See:

Filter: Light Effects

Filters: examples

See also:

Filters
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Filter: Discotheque

This filter, accessible through Filters/Light Effects/Discotheque, imposes a bright disco-light effect on
top of the original image. The light source is located in the center of the image.

In the “Discotheque” dialog use the sliders (or type directly into the boxes) to set the following:
· Rotation rotates the disco-lights through 0 to 360 degrees.

· Scale increases and decreases the intensity of the light source and therefore the extent of    the 
light-spread across the image from the center.

· Transparency determines how much of the image is visible. A transparency of 0% causes the    
image to be not visible at all, with the disco-lights more or less the only thing visible, depending on 
the scale setting; at 100% the image is totally visible, with the disco-lights superimposed.

The changes you make are immediately displayed in the Preview box.

See:

Filter: Light Effects

Filters: examples

See also:

Filters
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Filter: Star

This filter, available through Filters/Light Effects/Star, allows you to apply various star-like effects. The
possible variations are created through manipulation of the colors that comprise the image.

In the “Star” dialog you can use the sliders to set the following:
· Red, Green and Blue Density
· Brightness
· Red, Green and Blue Transparency
These are all measured on a percentage scale.

The effects are immediately shown in the Preview box before you apply them to the image itself.

See:

Filter: Light Effects

Filters: examples

See also:

Filters

Filters: examples



Layers
Layers are one of the most useful features of Photopaint. They enable you to treat an image as a series
of separate superimposed images, each occupying its own transparent layer. This allows you to make 
changes to an image on one layer without upsetting the images on the other layers. In addition, the 
order of the layers can be altered. Altogether, layers are an essential tool in helping you to control how 
your images are created and edited.

The most important feature of layers is their capacity to be transparent in various degrees. Whenever 
you create a new layer it is shown as a transparent window, usually visible as a checkerboard pattern 
by default. (You can change the shading and size of the checkerboard pattern in 
File/Preferences/Grid. A grid size of none in effect creates a blank sheet, either light, medium or dark 
according to the setting. You can change the style of the layers either before or after opening a file.)

To reiterate, the essential characteristic of layers consists in the fact that whenever you create or edit 
an image on a particular layer, the images on the other layers will be visible in so far as they can be 
seen through a transparent area of the layers above. Obviously with more than two layers, the potential
for complexity increases, especially if you start changing the order of the layers.

You can keep a check on the arrangement, visibility, opacity and blend mode of the layers you have 
created by selecting Layers from the View menu. This opens up the “Layers” dialog:

The following sections will further explain how to use the various features available in “Layers”:
Background layer
Creating and working with layers
Layer options



Background layer

Each Photopaint document contains a background layer. There are several points you should be aware
of in connection with the background.

If you create a new Photopaint document from scratch, that is to say, using the New command in the 
File menu rather than opening up an already existing image file, the default layer is called Layer 1. 
Whenever you open up an already existing image file, using the Open command from the File menu, 
the default layer is called Background.

The main difference between these is that a Background layer is always opaque, no matter what 
position you place it in the hierarchy of layers. If you erase any of the pixels in a Background layer the 
current background color is used to fill them in. With a new file where the default layer is called Layer 1,
you can subsequently move this layer up the hierarchy of layers and it will behave in the same way as 
any other transparent layer. In both cases the bottom layer, whatever that is, will be opaque. This is as 
you would expect, since there is nothing to see beneath the bottom layer. Consequently, if you erase 
color from the bottom layer and it is called Background, the background color will show through, but if 
the bottom layer is any other type of layer a checkerboard pattern (or plain sheet) will show through. 
The checkerboard pattern does not mean that the bottom layer is transparent, as you can see if you 
select Print Preview from the File menu or print the document, in both of which the checkerboard 
pattern is converted into the current background color. Moreover, if you “look through” higher layers to 
parts of the bottom layer where erasure has taken place you will see the current background color.

Given the above there would obviously be not much point in changing the position of a Background 
layer in the hierarchy of layers. However, you can use the duplicate command to create a layer called 
Copy of Background, which will then act in the same way as any normal layer.

You can at any time rename any layer.

See:

Creating and working with layers



Creating and working with layers

The following section will show you how to create and work with layers, explain the relevant concepts, 
and illustrate some of the main operations that can be carried out with them.

First, you may want to edit a picture file, for example, a photograph that you have already scanned in to
your computer.

Select Open from the File menu and locate and open the relevant picture file.

The picture will be displayed in the Ability Photopaint window. If the picture is larger than the window 
and you want to see it as a whole, without having to use the scroll bars, then select Fit on Screen from
the View menu. You can always select Actual Pixels to restore the picture to its original size.

The picture occupies the Background layer, as explained in Background layer. This is the default layer
and can be edited directly or used as the basis for editing on other layers. It is best to keep the 
background layer clean; if you wish to edit it directly, work on a copy of it instead. (You might also 
choose to work on a copy of the original file: select Duplicate from the Image menu. A copy will be 
created and displayed. You can then close the original file by selecting it from the Window menu and 
continue to work with the copy, which is converted to an Ability Photopaint file. Note that 
Image/Duplicate creates a copy in which Background acts like any other layer.)

To create a copy of the Background layer, first make sure the “Layers” dialog is visible (select Layers 
from the View menu). Background will be the only layer visible in the dialog until you create another 

one. Click on the Duplicate Layer  button in the dialog to open up the “Duplicate Layer” dialog. 
Click on OK to create a copy of the background layer.

Note that though these two layers are called Background and Copy of Background, they are in effect 
Layers 1 and 2 - if you add a new layer to them it will be called Layer 3.

Any layer can be renamed by clicking on the Layer Options  button in the “Layers” dialog.
Now that you have created two layers you can see both of them listed in the “Layers” dialog. The bottom 
layer in the dialog is always the “background” layer, and the ones above are stacked on top of this. Any 
new layer is added to the top of the stack, that is, it becomes the layer furthest away from the background
layer.
The list of layers has several important features. These need to be grasped if you are to use layers 
successfully:

· At the left-hand side of each layer there is an Eye button. As you would expect, this indicates that 
the layer is presently visible. Click once to switch off the eye button (and once again to switch it 
back on). By switching off a layer you make it impossible to see any image content from that layer, 
thereby making the content of the layer below visible (in so far as it was hidden by the image on the
hidden layer). You can switch off as many layers as you like, and also have any combination of 
switched-on and switched-off layers.



· The currently selected (or highlighted) layer is the active layer. Any editing you do is always 
implemented on the active layer. Since it is not possible to have more than one active layer at a 
time, none of the inactive layers will be affected by your editing. This is, of course, the main value 
of layers in the first place. You can make any other layer the active one simply by clicking on it.

With this in mind it is important to note the following: a layer may be the active one and at the same 
time be invisible, that is with the eye button switched off. If this is the case, you will not be able to see 
the effects of editing until you switch on the eye again, but editing will be applied to the currently 
selected active layer whether or not it is currently visible.

See:

Layer options



Layer options

There are various layer options, available through the “Layers” dialog or, if not there, the Layers menu.
These options show some of the most powerful features of layers.

(The example “Layers” dialog shows an image of a house on the Background Layer - see Background 
layer - and a Super Nova filter on Layer 2. The images can be combined in the image window to show a 
house with a super nova filter, or either layer can be switched off to show only the image on the other 
layer. The active layer in the example is Layer 2 and all actions will take place on this layer until the other 
one is selected.)
We will go through the options in the “Layers” dialog not already dealt with in Creating and working 
with layers. After that we will cover some of the options available through the Layers menu.

Click on the New Layer  button in the “Layers” dialog to open up the “New Layer” dialog.

In the Name box the layer is given a default name e.g. Layer_3. You can change the name as you wish. 
(The Opacity, Group with previous and Mode options are dealt with in the account of the “Layer 
Properties” dialog later on in this section.) Click on OK to close the dialog and create the new layer.
Note that whenever you create a new layer it is placed directly above the current highest layer in the 
stack, that is it becomes the layer furthest from the background. This can be observed in the “Layers” 
dialog.

If you want to delete a layer, first select the layer in the “Layers” dialog and then click on the Delete 

Layer  button.
You can duplicate a layer by first selecting the correct layer in the “Layers” dialog and then clicking on the

Duplicate Layer  button.



In the “Duplicate Layer” dialog the layer to duplicated will be given a default name which you can change 
as you wish. In the Destination box you can choose whether to have the duplicate layer saved to the 
present document, an already existing document or to a new document.
There are several buttons that enable you to alter the order of the layers. In each case, first select the 
layer to be moved.

· Click on Layer Up  to move a layer one up the stack, that is one layer further away from the 
background.

· Click on Layer Down  to move a layer one down the stack.

· The Layer First  button takes the selected layer to the top of the stack, that is the furthest away
from the background.

· The Layer Last  button takes the selected layer to the bottom of the stack, that is makes it the 
background layer.

Click on the Layer Options  button to open up the “Layer Properties” dialog.

There are several options here which are also available in the “Layers” dialog itself, such as power to 
change the name, alter the opacity, and select a different blend mode for the layer. In addition, you can 
choose to group layers together.

· Opacity: use the slider to reduce the opacity of the active layer. In effect, 100% opacity on a layer 
prevents you seeing through an image to the layer below. As you gradually reduce the opacity the 
image fades more and more. Note that altering the opacity merely changes the appearance of a 
layer, but does not effect a permanent change unless you choose to merge or flatten an image (see



Merge operations with layers).

· Mode: the blend mode determines how colors on the active layer will blend or combine with colors 
on the layers below (see Blending between layers for more information).

· Grouping: The Group with previous checkbox should be switched on if you want to “clip” the 
active layer to the layer below. Essentially, grouping causes the information on one layer to mask 
the information on the other. So, if you have two adjacent layers, with the upper layer clipped to the
lower, the only part of any image on the lower layer that will “show through” is that which coincides 
with the image on the upper layer. The image on the upper layer will be seen as if filled with the 
colors from the image on the lower. Another way of thinking about this is to see the transparent 
areas of the upper layer as masking the equivalent areas of the lower layer. An example of the use 
of the technique is when you have some text on the upper layer, say “Happy Birthday”, which you 
want to be displayed with the colors that are directly underneath in the lower layer. You can cancel 
a grouping by clicking on the checkbox again or by selecting Ungroup from the Layers menu.

· Click on OK to close the dialog and apply the changes.

See:

Layers



Blending between layers

In the Layer Options section (see Layer options) we explained some of the various options available in 
the “Layers” dialog. One of the most useful is the Mode option, which determines how colors on the 
active layer will blend or combine with colors on the layers below. The effect of a Blend mode is usually 
obtained in conjunction with a setting for the Opacity of the layer.

There are several options for blending. The list of these is the same as for Brush modes (see Brush 
modes). There are, though, important differences:

· brush modes concern blending between colors on one layer, whereas blend modes concern 
blending between different layers;

· brush modes can be limited to a selection on a layer, whereas blend modes work on the whole of a 
layer;

· a brush mode will only take effect once you start to paint with it, leaving previously applied 
brushstrokes untouched unless you paint over them, whereas a blend mode is applied immediately
it is selected to the whole of the layer and will continue to be applied as long as it is selected;

· brush modes are permanent, unless you use the Undo option in the Edit menu, whereas blend 
modes can be changed or cancelled by selecting another blend mode.

The usefulness of blending can be gauged from the following notes.

The image window can contain many layers in a definite order. Each layer can have its own image but 
all the layers share the same “space”, namely the standard image window. However, when it comes to 
displaying or printing an image that is comprised of a series of layers, it is obviously impossible to 
display all the separate layer images. In other words, only one image can actually be displayed. 
Blending is a way of determining the final color values for an image you wish to display or print, when 
that image consists of more than one layer. Note that the Blend modes do not effect a permanent 
change and can be cancelled at any time by selecting Normal in Mode and setting the Opacity at 
100%.

For some examples of blending between layers, see Blending between layers: examples.



Blending between layers: examples

The following examples show you how to apply the techniques discussed in Blending between layers.

Since blending is applied to the color values of the pixels on more than one layer, Photopaint has to 
calculate, for each pixel, the resultant color from a combination of the base color (or color of the layer
below the active layer) and the blend color (or color of the active layer). The particular Blend mode 
used determines the way the resultant color is calculated.

The default value for the blend mode is Normal, as you can see in the Mode box.

Another important concept when selecting a blend mode is that of opacity, which is set in the Opacity 
box. For some blend modes an effect becomes apparent only if the opacity is set at less than 100% 
e.g. Dissolve.

The main blend options, which you can select in the Mode box, are:

· Normal
The resultant color is the same as on the current active layer (subject to the amount of 
transparency set in the Opacity box, therefore visibility through to the lower layer). In effect, the 
base color is not used to help calculate the resultant color where the base and blend colors 
overlap.

· Dissolve
A layer with less than 100% opacity is converted - “dissolved” - to 100% opaque randomly 
scattered pixels. The effect is of a rough brushstroke, containing a mixture of blend and base 
pixels, rather than an evenly transparent one.

· Multipy
The brightness values of the base and blend colors can be combined to create a darker tone. This 
is done by multiplying the two brightness values when they are expressed as fractions. For 
example, white has a brightness value of 255 (the maximum) and is represented as 255/255 or 1; 
black has a brightness value of 0 (the minimum) and is represented as 0/255 or 0. All other 
brightness values are represented as fractions between 0 and 1 e.g. 150 is represented as 
150/255; 100 as 100/255. Therefore, using Multiply we get the result (100 * 150) / (255 * 255), 
which works out at 59/255. You can immediately see that the resultant brightness will always be 
lower than (or equal to) the brightness of either one of the multiplied fractions. This intuitively fits in 
with our experience of placing one transparent sheet on top of another, where the result is always 
darker.

Note that the above means that if the blend color is white, the resultant color is the same as the 
base color. If the base color is white, the resultant color is the same as the blend color. If either the 
base or the blend color is black, the resultant color is black. If the base color is transparent, the 
result of blending any color is black (since a transparent layer counts as 0, that is, the same as 
black).

· Screen
This mode has the opposite effect to Multiply, combining the base and blend colors to create a 
lighter tone.

These are some of the more important options, but there are many others:

Behind, Overlay, Difference, Addition, Subtraction, Darken Only, Lighten Only, Hue, Saturation, 
Color, Luminosity, Divide, Color Burn, Color Dodge, Hard Light, Soft Light
Remember that you can always cancel or change the effect of a blend mode by selecting another one, 
especially the Normal blend mode. For information on how to make a particular blending permanent, 
see Merge operations with layers.



Merge operations with layers

The merge options, accessible in the Layers menu (see Layer options), provide a useful way of fusing 
the contents of layers to form one image on one layer.

· Flatten Image merges all visible layers into a single background layer, leaving out and discarding 
non-visible layers (the ones with the Eye switched off). At the end of this operation there is only one
layer left.

· Merge Visible merges all visible layers into the bottom-most visible layer, creating a single 
background layer and leaving non-visible layers untouched and above the background layer.

· Merge Down merges the active layer with the layer below it.

The merge operations are permanent, although if you make a mistake with a merge just select Undo 
from the Edit menu to restore the previous state.



Copy, Cut and Paste

The Copy, Cut and Paste commands in the Edit menu work in conjunction with the Layers facility. 
Whenever you copy or cut a selected image or part of an image and then use paste, the selection is 
pasted onto a new layer. The pasted selection will be slightly off-center, rather than superimposed on 
top of the copied selection.

1. The Copy, Cut and Paste commands only become active after you have made a selection, in the 
normal way, using one of the selection tools (see Selections) or an option from the Selection menu 
(see Selection menu).

2. After making your selection, click on either Copy or Cut in the Edit menu.

3. Click on Paste in the Edit menu.

The selection is pasted onto a new layer, which automatically becomes the active layer.

Note that if you want to move a selected part of an image to another area on the same layer, you can’t 
just copy and paste. Instead, you should drag the Move arrow when the selection is in Transform mode 
(see Transform Image).



Edit menu
The Edit menu enables you to perform various editing operations. Nearly all of these have been dealt 
with in other sections:

· Undo undoes the last applied command. You can undo several commands, the precise number 
depending on what part of Photopaint you’ve been using. The next command to be undone always 
appears just to the right of Undo e.g. Undo Ellipse selection.

· Redo, as the word implies, restores the last undone command. Again the number of commands it 
is possible to redo depends on the nature of the commands.

· History: see History palette.

· Cut, Copy, Paste: see Copy, Cut and Paste.

· Stroke uses the current selection border as the basis for painting a band of color around the 
selection. The color used is the current foreground color (see Color selection for information on 
how to select a new color). In the “Stroke Selection” dialog you can set the following:

· Width: enter a value for the stroke width (in pixels).

· Blending: choose a Mode and Opacity (see Brush modes for information on the various ways 
of blending colors.)

· Location: choose whether to have the stroke in the Center, Inside or Outside of the selection 
border.

· Click on OK to exit the dialog and draw the stroke.

The selection border will be traced with the foreground color, using the width and “location” chosen
by you. When the selection is cancelled the stroke remains in place.

· Fill enables you to fill in a selection using any color or pattern you like. In the “Fill” dialog set these 
options:



Choose a Fill color in the Color box:

Foreground: the current foreground color

Background: the current background color

Black: solid black

50% Gray: half white, half black

White: solid white

Custom Color: select a color in the Select Color dialog

Pattern: select a pattern in the Pattern Editor dialog

Note that the Fill color is displayed in the Preview box.

In the Blending box set the Mode and Opacity (see Brush modes for information on blending).

Once you have set the Color, Opacity and Mode click on OK to apply the Fill.

· Clear: Deletes the contents of the current selection (or layer if a selection hasn’t been made). Note 
that the deleted selection is “replaced” with the current background color, not with the transparent 
grid and not with the color of any underlying layer.

· Free Transform and Transform enable you to transform either the selection boundaries, leaving 
the image unaffected, or the image itself. They are described in Transform selection tool and 
Transform Image.



Image menu
The commands in the Image menu enable you to adjust the color values of and to resize, rotate, crop 
and duplicate images. The Adjust commands are especially useful when working with scanned images,
since the colors are usually not perfectly duplicated in computer form.

These are the main options in Image:

Adjust

Duplicate

Image Size

Canvas Size

Rotate

Histogram



Adjust Image

The Adjust command in the Image menu opens up a new menu containing a variety of commands:

Auto Levels

Levels

Curves

Color Balance

Brightness/Contrast

Hue/Saturation

Desaturate

Invert

Equalize

Posterize

Threshold

Use these to adjust the color values of the image.

See:

Image menu



Auto Levels

The Auto Levels command - from the Adjust section of the Image menu - applies an automatic tonal 
readjustment of the image by repositioning the endpoints of the tonal range. The tones are readjusted 
to fit in between the new endpoints. The effect is to increase the contrast in the image.

The lightest and darkest pixels of the image are reset as white and black respectively, and then the 
intermediate pixel values are redistributed proportionately. The dark values get darker and the light 
values get lighter, hence causing the image to have higher contrast and greater color saturation.

For more information on adjusting levels, see Levels.



Levels

The Levels command enables you to adjust the brightness of pixels, hence relocating the brightness 
values of an image. This is done by manipulating the controls which represent the shadows, mid-tones 
and highlights in the image. In effect the Levels sliders are used to expand or compress the current 
tonal range. The Histogram represents the tonal range of the image and measures how many pixels 
are colored with each of the tones between 0 (black) and 255 (white) (see Histogram for more 
explanation).

Access the Levels command in the Adjust sub-menu under Image.

In the “Levels” dialog you can set the following:
· Set the channel in Channels, choosing from Luminosity (red, green and blue combined), Red, 

Green, or Blue. Note that the histogram changes to reflect your setting.

· The Input Level boxes display values for shadows and highlights, thereby determining the range of
pixels that will be turned black or white. You set these values by dragging the sliders just below the 
boxes.

For example, if you use the left-hand slider, which adjusts the shadow value in the left-hand box, to 
set a value of 60, then all pixels with a brightness value of 60 or less will become black. Likewise, 
using the right-hand slider to set a highlight value of 200 in the right-hand box causes all pixels with
a brightness value of 200 and higher to become white. The range of values is from 0 to 255.

The middle box and slider control the brightness of the mid-tones. The default value is 1 and the 
range through which you can move the slider is 0.09 at the right side to 10 at the left side. Moving 
towards the lower value darkens and towards the higher value lightens all the tones of the image 
that aren’t either black or white (these parts of the image stay the same).

· The Output Level slider and boxes are used to compress the tonal range. This is done by 
restricting the darkest and lightest tones, hence causing a decrease in the number of possible 
tones in between the new darkest and lightest tones. The effect of this is to decrease the contrast 
in the image.

Set the shadow value by moving the left-hand slider to the right: a value of 50 reduces the darkest 
tone to 80.4% of black i.e. 0 is black and 255 white, so a setting of 50 represents a reduction of 
19.6%. Set the highlight value by moving the right-hand slider to the left: a value of 200 increases 
the darkness of the lightest tone to 21.6% of black (alternatively, 78.4% of white). The tonal range 



is adjusted to fit in between the new limits of 50 and 200, there being nothing outside of this range 
in the 0 to 255 scale.

Any changes you make are immediately applied to the image on screen. Click on Cancel to cancel 
these changes and exit the dialog; otherwise click on OK.

Note that the Levels command isn’t as accurate or powerful as the Curves command (see Curves).

See:

Adjust Image



Curves

The Curves command (Image/Adjust) enables you to change the pixel values of an image. It allows 
you to focus with greater precision on certain tonal areas and is therefore more powerful than the 
Levels command (see Levels).

The “Curves” dialog consists of a tonal graph on a grid background. The tones of the image are altered
by manipulating this graph in conjunction with the tonal range represented by a particular square or 
squares. The graph can take either of two forms: one which allows you to manipulate the graph by 
using points or markers, the other which enables you to draw a curve freehand. The two forms of curve 
can easily be converted into one another.

The “Curves” dialog contains the following options:
· Channels: Choose to edit one of the individual channels - Red, Green or Blue - or all the channels

combined - Luminosity.

· Tone Graph: This is a diagonal straight line by default. It represents the spread of tones throughout
the image. Pixel values are altered by manipulating this graph. The four-by-four grid against which 
the graph is set allows you to focus your changes on particular tonal areas. The horizontal bar at 
the bottom of the graph represents the gradual changing of the tonal range from black to white. So, 
if you would like to make the lighter tones darker you should concentrate on the squares towards 
the upper right-hand corner, but if you’d like to make the darker tones lighter concentrate on the 
squares towards the bottom lower left-hand corner. The square markers at the extreme ends of the 
graph represent the tonal end-points. It is not necessarily the case that the image contains these 
tones, so, for example, to alter the darkest tones in the image you may have to concentrate on a 
square that is further along the graph from the bottom left-hand square.

The tones can be changed by clicking on the graph in the square that contains the relevant tones 
e.g. shades, mid-tones, highlights. A marker will appear on the graph at this point. There are two 
functions of markers. The first is to make tones lighter or darker by dragging the marker upwards or
downwards respectively. The straight line graph will adjust to form a curve, using the marker as its 



point of origin, and the image will dynamically darken or lighten to reflect the new graph. With only 
one marker in place the whole graph bends into a curve and therefore affects the whole tonal 
range. Since you will usually want to concentrate on a limited range of tones, the second function 
of the markers is to anchor the graph, therefore restricting the curvature whenever you reposition a 
particular marker. To do this put several markers in place along the graph at regular intervals and 
then move the relevant marker up or down as required. Only a small section of the graph will be 
affected and hence only a small part of the tonal range will be altered. Note that the graph will 
attempt to form the smoothest curve possible between the markers when the Smooth curve option 
is set (see below for the difference between Smooth and Free curves).

You can place up to fourteen markers on the graph. Reposition a marker by dragging it along the 
graph in the required direction. Remove a marker by dragging it horizontally till it disappears 
(dragging vertically alters the graph itself, of course). Usually you will only need to make small 
adjustments to the graph, anything greater altering the image tones radically.

· Smooth and Free: The default setting is Smooth. This ensures that the curve is adjusted smoothly
i.e. no “sharp corners”, therefore causing the tonal alteration in the image to be smoother too. 
Markers can be added only to smooth curves. The Free option removes any existing markers, 
including the end-points, and allows you to use your mouse to draw a “curve” freehand, without the
rest of the graph being adjusted to remove sharp corners. You can switch between these at will. 
Note, though, that switching back to Smooth from Free smoothes out the curve and adds ten 
markers at key intervals i.e. it doesn’t return the markers that you may previously added while in 
Smooth mode.

If you continually click on Smooth you will notice that the curve gradually straightens out, eventually
returning to its original diagonal form.

· Reset: This resets the graph to its original straight diagonal form and removes any markers, apart 
from those at the end-points. The image dynamically reverts to its original state.

Once you are satisfied click on OK to save the changes and exit the dialog; otherwise click on Cancel 
to exit without saving.

See:

Adjust Image



Color Balance

The Color Balance command in the Adjust section of the Image menu allows you to make 
adjustments to colors by altering their position in the Red Green Blue (RGB)/Cyan Magenta Yellow 
(CMY) color scale.

Each of the colors is linked with its complement on the color scale, for example, Cyan with Red, and 
connected by an adjustment slider. The Color Levels boxes just above the sliders display the current 
color values, reading from left to right, for the top, middle and bottom sliders respectively. The range of 
possible values lies between -100 and 100. The default is 0. Note that your adjustments should usually 
be small i.e. within about 5 units either side of 0, so that the color balance is not radically altered.

In the “Color Balance” dialog you can adjust the colors as follows:
· Color is added (or subtracted) by moving the slider towards (or away from) the color to be added 

(or subtracted). So, to add green move the middle slider towards the green end of the 
Magenta/Green scale. To subtract blue move the slider away from the blue end towards the yellow 
end of the Yellow/Blue scale, this in effect being the same as adding yellow.

· There are three Tone buttons which allow you to concentrate change over approximate tonal 
ranges in the image. The selected button guides the changes towards the relevant tonal range, 
hence helping concentrate the changes. The tones are:

a. Shadows for tones over 75%

b. Midtones for tones between 25% and 75%

c. Highlights for tones below 25%

· The Preserve Luminosity button helps keep the current luminosity - or lightness - of the image. 
When this is unchecked the tonal values of the image are altered along with the colors.

The changes you make will be implemented while you are still in the dialog. Click on Cancel if you want
to cancel these; otherwise click on OK to keep the changes and close the dialog.

See:

Adjust Image



Brightness/Contrast

Use the Brightness/Contrast command - among the Adjust commands in the Image menu - to alter 
the overall brightness or contrast of the image.

The brightness of an image is a measure of its overall lightness; the contrast is a measure of the 
difference between lighter and darker tones. Both values are set by sliders in the “Brightness/Contrast”
dialog. Sliding to the right increases the brightness/contrast; sliding to the left decreases them. The 
current value for both brightness and contrast is shown as 0 before any changes are made. You can set
the value for each at anything between -127 and 128, these being relative to the current value.

Note that as you move the sliders the changes immediately take effect on screen. If you would like to 
cancel the changes just click on Cancel to exit the dialog and return to the previous state. Otherwise click
on OK to close the dialog and keep the changes.
Since the Brightness/Contrast command acts on all channels at once, that is you can’t make changes to 
individual color elements within the image (red, green, blue, for instance), you may want to look at 
Curves.
See:

Adjust Image



Hue/Saturation

The Hue/Saturation command in the Adjust section of the Image menu allows you to edit colors using
the Hue Saturation Brightness (HSB) model.

Basically, you can take either all the image colors together or select a single color, then change the 
hue, saturation or brightness accordingly.

In the “Hue/Saturation” dialog there are sliders for the hue, saturation and lightness (brightness). The 
setting is always 0 for each of these when you first enter the dialog. You can move the sliders through -
180 to 180 for Hue, and between -100 and 100 for Saturation and Lightness. These are measured relative
to the current setting. (Note that the Hue values can be imagined as being degrees on a circle, so that -
180 and 180 result in the same color being selected.)
On the left of the dialog there is a list of all the colors in the RGB and CMY scales. Any one of these 
can be selected and changed in its hue, saturation or brightness. The default setting is Master, that is , 
all the colors of the image are changed together.

· The Hue slider takes a selected color - or all the colors together - through the range of colors in the
RGB/CMY scales. Once the slider position is set the relevant image colors change to reflect the 
new hue settings. Note that when you next enter the dialog the color list is returned to its normal 
setting, ready for you to make more changes should you need to.

· The Saturation slider increases or decreases the intensity of colors (or a selected color). 
Decreasing the saturation causes color to become grayer; increasing the saturation causes color to
become brighter.

· The Lightness slider increases or decreases the brightness of colors (or a selected color). 
Decreasing the lightness causes color tones to become darker; increasing lightness causes them 
to become whiter.

All the changes you make in the “Hue/Saturation” dialog are immediately applied to the image on 
screen. Click on OK to exit the dialog and keep the changes; otherwise click on Cancel to close the 
dialog and abandon the changes.

See:

Adjust Image



Desaturate

The Desaturate command in the Adjust section of the Image menu causes all colors in an image to 
become gray. This is the equivalent of setting the Saturation slider to 0 while using the Hue/Saturation 
command (see Hue/Saturation).

Note that the command is immediately implemented without your needing to access a dialog.

See:
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Invert

The Invert command in the Adjust section of the Image menu inverts all the pixel values in an image, 
that is changes them to their opposite value. More exactly, it calculates a new value for each pixel by 
taking the current value and subtracting it from 255. The new value then determines the brightness of 
the pixel, and therefore the brightness of all the colors in the whole image.

Note that the command is immediately applied once selected. If you would like to revert to the original 
brightness it is usually safe to do a reverse inverse by just selecting Invert again. However, in some 
circumstances it is often safer to select Undo from the Edit menu.

See:

Adjust Image



Equalize

The Equalize command (in the Adjust section of the Image menu) is used to redistribute the tones in 
an image. It accomplishes this by examining the image for the lightest and darkest pixels and then 
changing the lightest to white and the darkest to black. The remaining pixels are adjusted so that their 
tone is spread between the new limits.

See:

Adjust Image



Posterize

The Posterize command (in the Adjust section of the Image menu) is used to reduce the number of 
tonal levels in an image. This is useful in creating a silk-screen effect, as in some of Andy Warhol’s 
pictures.

In the “Posterize” dialog set the new number of levels in the Levels box (the default is 4, the maximum 
255). The number you enter is used to give an average for the 256 levels making up each of the color 
channels. With a low number of levels the effect of posterization is to display conspicuous bands or 
areas of color, while with a high number the changes are much less obvious. At 255 the image remains 
the same.

Any changes you make are immediately applied to the image, so you should click on Cancel if you 
want to abandon the changes and exit the dialog. Otherwise click on OK to keep the changes.

See:
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Threshold

The Threshold command (in the Adjust section of the Image menu) converts all the colors in an 
image to just two: black and white. The threshold is a limit value above which tones become black and 
below which they become white. Therefore you can decide how much of the image becomes black and 
how much white.

In the “Threshold” dialog use the slider to set a threshold value anywhere between 0 and 255. Towards 
the upper end of the scale the image becomes darker and is completely black at 255; towards the lower 
end the image becomes lighter and is completely white at 0. The current threshold is displayed 
numerically in the Threshold Level box. The default threshold is 127 when you first enter the dialog i.e. 
half way between black and white.
The histogram represents the distribution of image tones and can be used as    a rough guide to help 
you set the threshold.

The command is immediately applied when you enter the dialog, initially using the 127 default threshold
value and then any other value you may set with the slider. To cancel these changes and return to the 
original image click on Cancel, otherwise click on OK to exit the dialog and keep the changes.

Once you have applied the Threshold command you can only get back to the original colored image by 
selecting Undo Threshold from the Edit menu.

See:
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Duplicate image

The Duplicate command in the Image menu copies the open image to another window. The duplicate 
is given the title Copy of (name of open image) but can be renamed when you save it.

The duplicate is in every way the same as the original and can be edited in all the usual ways, including
the addition of layers. To switch between the duplicate and the original click on the Window menu and 
select the relevant name at the bottom of the menu.

See:

Image menu



Image size

The Image Size command in the Image menu allows you to alter the size of the open image.

In the “Image Size” dialog there are several ways to do this:
· Type the new dimensions into the Width, Height and Resolution boxes in the Image size group 

box. Note that just above this the amount of space needed to store the image is displayed. The 
original measure is recorded in brackets. You can force the dimensions of the image to change in 
proportion by selecting the Preserve Ratio box, that is, typing a figure in Width will automatically 
cause the figure in Height to change in proportion.

· The Scale group box allows you to select from one of the displayed fractional scales: 1/4, 1/3, 1/2, 
2, 3.

· The Interpolation group box allows you to determine how the image will be affected when the size 
or resolution is changed. Since changing the dimensions of an image results in pixels being either 
added or removed, there needs to be a method of working out what color values the new pixels will
have. Each of the interpolation values is used to spread color over a given range of pixels, in an 
attempt to maintain the appearance of the original image. The available interpolation values are: 
Nearest Neighbor, Linear, Quadratic, Cubic, Quartic, Quintic, 6th Order, 7th Order. The higher
the order the better the result, although it takes more time of course.

Once you are satisfied with your settings, click on OK to effect the changes. If you would like to reverse
a resizing it is best to use the Undo command in the Edit menu, although you can of course resize in 
the opposite direction e.g. half the image size after a previous doubling.

See:

Image menu



Canvas size

The Canvas Size command in the Image menu allows you to alter the dimensions of an image. 
However, unlike the Image Size command, this is done without changing the resolution. In effect, when 
the width or height is reduced the image is cropped, and when it is increased transparent pixels are 
added to fill up the extra space. (Note that the image canvas is usually surrounded by a gray area if the
canvas is smaller than the image window. This gray area is inaccessible to the Photopaint tools. 
Increasing the canvas size creates a newly accessible area, hence allowing you to add a caption, say, 
to the bottom of a scanned photograph.)

1. In the “Canvas Size” dialog you can make changes in the Width and Height boxes. Note that the 
amount of space required for the image is shown just above.

2. In the Anchor box there is a grid of nine squares which helps you to choose where the image will 
be located on a resized canvas. Since changing the canvas size results in either a cropping or 
expansion of the canvas, there are two basic uses of the anchor grid:

· Use the grid to preserve a part of the image when cropping. For instance, if you are reducing 
the height by two units (of some scale) but wish to preserve the bottom of the image, you 
should click one of the bottom squares to ensure that the two units are cropped from the top of 
the image. Clicking on one of the middle (horizontal line of) squares will result in one unit being 
cropped from the top and one from the bottom of the image. The same principles can be 
applied to cropping from the left and right sides of the image. (Note that you can also crop 
using the Crop tool on the Tools bar - see Crop.)

· Use the grid to determine where in an expanded canvas the original image should appear. For 
instance, if you are adding two units to the width and height of the canvas and you would like 
these to be distributed evenly around the image, then click on the center square to create a 
one-unit band around the image. If you click the lower-left square, two units are added to the 
top and two to the right side of the image.

Once you are satisfied with the width, height and anchor grid setting click on OK to implement the 
changes.

See:
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Rotate

The Rotate command in the Image menu allows you to turn the image through an angle set by you. 
(Note that, in effect, the image canvas is rotated and therefore the image along with it. This is different 
from the rotate commands in Transform Image - see Transform Image - which turn a selection of the 
image without turning the canvas and therefore allow images to be “cropped” once they are outside the
canvas area.)

There are set options for rotating through 90 degrees clockwise (90 CW), 90 degrees counter-
clockwise (90 CCW) and 180 degrees. In addition, you can flip the image either horizontally or 
vertically. The most versatile command is Arbitrary, with which you can specify an exact angle of 
rotation, anywhere between 0 and 360 degrees, and choose to rotate either clockwise or counter-
clockwise.

See:

Image menu



Histogram

The Histogram option in the Image menu is purely there for informational purposes. It displays in 
graphical form the tonal values of the image, according to which of the channels you select. You can 
choose to see a histogram for either the Red, Green or Blue channel, or for all of them together by 
selecting Luminosity.

The graph represents the darkest to lightest pixel values (reading horizontally from left to right) between 0
and 255. There are 256 lines representing 256 possible tones. The height of the line indicates the number
of pixels in the image that have that particular tone. If a tone is not present in the image it will have no 
associated line in the histogram. For instance, if there is no pure black in the image there will be no line at
the left-hand side of the histogram, and if there is only a small number of black pixels the line will be short.
The same is true of the rest of the tonal range.
This information can be useful in guiding you in your color correction strategy.

See:

Image menu



The Tools menu
The Tools menu contains commands through which you can create or edit gradients, patterns and 
brushes. The following sections show you how to do this:

Gradient Editor

Brush Editor

Patterns Editor



Gradient Editor

Although Photopaint already contains several default gradients, which are explained in Gradient Fill, it 
is useful to be able to create new gradients - or edit existing ones -to your own design. This can be 
done through the Gradient Editor.
You can access the Gradient Editor in the Tools menu. (Alternatively, click on the Edit button at the 
bottom of the “Gradient Fill” box after selecting Gradient Fill on the Tools bar.)

Once in the “Gradient Editor” dialog you can set the following: 

· Create a new gradient by clicking on the New button. In the Gradient Name box enter a name or 
leave the default name and click on OK. The gradient name is displayed in the top box. Any 
gradient you create will be displayed here and will appear each time you enter the Gradient Editor.

· Change the name of a gradient by first selecting the gradient name and then clicking on Rename. 
Change the name in the Gradient Name box.

· Remove a gradient by selecting the gradient name and clicking on the Remove button. The 
Gradient will be deleted from the list.

· Copy a gradient by clicking on the Duplicate button. Give the duplicate a name in the Gradient 
Name box. Duplicates are useful if you plan to edit a gradient but also want to retain its original 
form.

· If you are creating many gradients you may wish to put them into a separate file. Use the Save 
button to either create a new file or save to an existing file. Likewise if you want to use gradients 
stored in an separate file, use the Load button to load the file.

When you first create a new gradient, it will have no distinguishing properties (all new gradients are 
shown as a solid line of color in the Gradient Bar). To begin creating the gradient proper, first make 
sure it is selected in the list of gradient names.

In the body of the Gradient Editor you need to select colors and transparency values for the gradient, 
as follows:

There are two Adjust checkboxes:

· Color enables you to determine the color of the gradient.

· Transparency enables you to determine the opacity of the gradient.

1. First select Color (it should be selected by default anyway).



The long box just below the Adjust commands is called the Gradient Bar. This represents the 
gradient itself, namely how its color content is spread out when you create the gradient on screen. 
By default it will be a solid block of color until you design the gradient.

Just below the Gradient Bar there are two Color Markers, one at either end of the Gradient Bar. 
Just above and half way along the bar, there is a Color Midpoint Marker.
The Color Markers determine which colors the gradient will start and finish with; the Color Midpoint 
Marker marks the point where the two colors are equally blended.

Select a color for the left-hand side of the Gradient Bar by clicking on the left-hand Color Marker. 
The little triangle on top of the marker will become black to show that it has been selected.

Next, click on the Color box just below. The Select Color dialog is opened. Select a color for the 
marker (you can read about selecting colors in Color selection). Both the Color box and the left-
hand marker are changed to the selected color. Set the color for the right-hand of the gradient in 
the same way.

Note that the gradient runs through from the first color to the second with the Color Midpoint Marker
showing where the two colors are equally blended. Initially this is half way along - select the marker
and the Location box will read 50%. You can alter the location of the Color Midpoint Marker by 
dragging it either left or right. The point of equal blending between the two colors will be situated at 
the new location, which will be reflected in the Location box. Note that the Location box shows the 
position of the currently selected marker (the Color Markers are at 0 and 100% respectively).

You are not restricted to just two Color Markers. To add another, click just below the Gradient Bar. A
new marker is displayed. You can add several markers in the same way. If you would like to 
remove a marker just drag it away from the Gradient Bar and it will disappear.

There are two important points you should note:

· As soon as you add a Color Marker an extra Color Midpoint Marker is automatically added 
above the Gradient Bar.

· This new Midpoint Marker is placed half way between the new Color Marker and an adjacent 
Color Marker. The rest of the Midpoint Markers are shifted along to take account of the new 
Color Marker.

Once you have added a Color Marker you can proceed to create gradient sections between Color 
Markers, leaving the rest of the gradient unaffected. Moreover, you can drag any Color Marker, 
except the end markers, to a new position and thereby expand or contract particular sections of the



gradient. Likewise, by dragging the Midpoint Markers you can alter the point of equal blending in 
any particular section.

Note that when you click on a Color Marker its location is always displayed as a percentage of the 
whole Gradient Bar in the Location Box. However, with the Midpoint Markers the location is 
displayed as a percentage of the section between two Color Markers. If you have previously 
dragged a Midpoint Marker so that it is, say, 80% of the distance between the adjacent Color 
Markers, then it will retain this percentage distance no matter how many markers are added, until 
you choose to drag it to a new location.

The gradient is also displayed in the Preview Bar at the bottom of the box.

2. Initially the opacity of the gradient is 100%. To alter this, click on Transparency. Note that the 
Color box changes to the Opacity box and the Gradient Bar becomes solid black. Opacity and 
transparency are set in a similar way to color, using the same tools.

As with color, you can add Markers (below the Gradient Bar) and therefore Midpoints (above the 
box). Between any two markers there is one midpoint which indicates the half way point between 
the opacity of the two markers.

Set the opacity for a marker by clicking on it and typing a percentage value in the Opacity box. 0% 
is totally transparent, 100% is totally opaque.

You can set a transparency for the section between any two markers in the following way: Drag the 
midpoint to relocate the half way point between the markers. A marker of, say, 30% and one of, say,
70% will have a midpoint value of 50%. You can drag any marker, except the end markers, to a 
new position and thereby expand or contract particular sections of the gradient. The Location box 
works in the same way as for color, with midpoints being measured between adjacent markers and 
markers being measured along the Gradient bar as a whole.

The gradient, with both its color and transparency values, is displayed in the Preview box.

Once you are satisfied with your settings, click on OK to save the gradient and close the Gradient 
Editor.
Apply the gradient by selecting Gradient Fill from the Tools bar. The new gradient will appear among 
the old gradients in the Gradient drop-down box in the “Gradient Fill” dialog. Apply the gradient by 
dragging the Gradient Pointer across the image window, as explained in Gradient Fill.

See:
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Brush Editor

Although Photopaint comes with a full set of brushes for use with the various paint tools, you may 
sometimes find it useful to be able to create your own brushes. The Brush Editor enables you to add, 
delete and edit brushes.

Open up the “Edit Brush” dialog by selecting the Brush Editor command in the Tools menu.

In the Brushes box there is a list of all the existing brushes. The currently selected brush is displayed in 
the Preview box below. Note that unless you have already created a brush all the listed brushes will be 
the standard ones displayed by default in the “Brushes” dialog (see Brushes). You cannot edit or delete a 
standard brush.
Create a new brush to your own design in the following way:

Click on New to open up the “Brush Options” dialog.

There are three basic brush types:



· Elliptical: rounded and elliptical brushes.

· Rectangular: rectangular brushes, which can be solid or hollow.

· Bitmap: bitmap brushes, which can be created from the images in a separate bitmap file (use the 
Load Bitmap button to locate and load your bitmap images).

Select one of these types before proceeding to create the brush.

Once you have selected a brush type, various tools for determining the brush’s shape and size become
available. The set of tools that can be used to create or edit a brush depends on the particular brush 
type.

· Use the Radius slider to set the radius of the brush (only Elliptical and Rectangular) between 1 
and 30 pixels. The radius is defined as half the maximum length of the brush. A long thin elliptical 
brush will therefore take as its diameter the distance between the extremities rather than the 
shorter distance.

· The Hardness slider determines how soft (0%) or hard (100%) the brush (Elliptical, Rectangular 
or Bitmap) will be: the lower the value the fuzzier the brush, the higher the value the more defined 
the brush’s edges.

· The Spacing slider determines the amount of space between the brush marks (Elliptical, 
Rectangular or Bitmap) when you use the paint tools. Note that the paint tools apply a series of 
identical brush marks in rapid succession, thereby creating the illusion of a solid line. If the spacing 
is set high enough the individual brush marks become visible. The spacing can be set at anything 
from 1 to 999%. This value is a relative measure of the spacing when compared to the radius of a 
brush shape. Anything below 100% will produce a continuous stroke; anything above will produce a
stroke with space in between the brush marks. Note that the effects of spacing are more apparent 
when the brush stroke is applied quickly. If the application is slow the stroke will be solid even 
though the spacing is high, although the edges of the stroke will be “bumpy”.

· The Width slider works only with the Rectangular selection and determines the thickness of the 
borders of the rectangle. The higher the width the thicker the border and the less space visible in 
the center of the rectangle. The width can be set at any value from 1 to 30 pixels.

You can keep a check on your adjustments by looking at the changing display in the bottom right-hand 
Preview box.

In addition to the above you can determine the roundedeness and angle of the brush (Elliptical or 
Rectangular only):

· The Roundedness box determines the shape of the brush. Use the arrows to reduce the value 
from 100% (or type in a value directly). A value of 100% indicates that the shape is a circle (using 
Elliptical) or square (using Rectangular). As the value is reduced towards 0% the shape becomes 
flatter in one direction and therefore appears elongated. (Note that the Radius setting is not 
affected. This can only be changed by using the Radius slider and is always based on a shape’s 
maximum length.)

· The Angle box determines the direction of the shape. Use the arrows to increase the angle from 0 
to anything up to 360 degrees (or type in an angle directly). Increasing the angle rotates the shape 
anti-clockwise.

· You can also set values for roundedness and angle in the Roundedeness and Angle box at the 
bottom left-hand corner. An outline of the shape is displayed, along with a direction-arrow and 
handles for adjusting the shape. Click anywhere on the boundary of the shape to set a new 
direction. Hold down the mouse and drag till the arrow is pointing in the direction you want (you can
check this by glancing at the Angle box, in which the angle changes to match). Alter the 
roundedness by dragging one of the handles in or out. Likewise, the value in the Roundedness 
box will reflect your changes.

Again, your changes can be viewed in the Preview box.

Once you’ve designed your brush you can give it a name in the Brush Name box at the bottom of the 



dialog.

Click on OK to return to the “Edit Brush” dialog. The new brush is displayed at the bottom of the 
Brushes box. Select it to see it displayed in the Preview box.

If you now click on Close and select any of the paint tools on the Tools bar, the new brush will appear 
in the “Brushes” dialog, ready to use.

The following are the remaining options available in the “Edit Brush” dialog:

· You can edit a brush shape by selecting the Edit button. This opens up the same “Brush Options” 
dialog that is used to create a new brush. The process of editing is similar to creating a new brush. 
All the techniques explained above can be used to edit an existing brush.

· Delete a brush by selecting the brush in the Brushes box and then clicking on Remove. The brush
is deleted from the list.

· Copy a brush by selecting the brush in the Brushes box and then clicking on Duplicate. It is a 
good idea to use this command when you want to use a standard brush as the basis for a creating 
a new brush.

· Use Save to save all your current brushes, including new and edited brushes, to a separate file. 
Use Load to access brushes stored in a separate file.

Once you have made all the changes you want click on Close to exit the dialog.

See:

The Tools menu



Patterns Editor

The Patterns Editor displays all your current patterns and enables you to access patterns that are 
stored in separate files.

· New enables you to access a pattern from a separate file and display it in the “Patterns Editor” 
dialog as a new pattern.

· Rename allows you to change the name of a selected pattern.

· Remove deletes a selected pattern from the current list.

· Load accesses patterns stored in a separate file.

· Save enables you to save the current patterns to a separate file.

Note that unless you load patterns from a separate file, you will have to create them from within 
Photopaint. See Pattern brush for details on how to create a pattern.

See:

The Tools menu




