Plánování pravidelných úloh

Program Plánovač úloh se používá k plánování nejvhodnější doby pro pravidelné spouštění programů (například Defragmentace disku) a jiných nástrojů. Program Plánovač úloh se spustí na pozadí při každém spuštění systému Windows.

Složku Naplánované úlohy otevřete, klepnete-li na tlačítko Start, přejdete na příkaz Programy, zvolíte položky Příslušenství, Systémové nástroje a klepnete na položku Naplánované úlohy.

Otevření složky Naplánované úlohy umožní:

  • Plánovat úlohy, které se mají spouštět denně, jednou za týden či za měsíc nebo v určenou dobu, například při spuštění počítače nebo při jeho nečinnosti.
  • Změnit naplánování nebo vypnout existující úlohu.
  • Upravit způsob, jakým se úloha v danou dobu spustí.


Plánování nové úlohy

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. Poklepejte na položku Přidat naplánovanou úlohu.
  3. Postupujte podle pokynů v Průvodci naplánovanou úlohou.

    4. Chcete-li provést upřesňující nastavení úlohy (například nastavení opakovaného spouštění úlohy při jejím každém spuštění), zaškrtněte políčko Po klepnutí na tlačítko Dokončit upřesnit vlastnosti této úlohy na poslední obrazovce průvodce.

Poznámky

  • Vyžaduje-li program úlohy parametry, zaškrtněte políčko Po klepnutí na tlačítko Dokončit upřesnit vlastnosti této úlohy na poslední obrazovce průvodce, klepněte na tlačítko Dokončit, poté klepněte na kartu Úloha a zadejte parametry za cestu v textovém poli Spustit.
  • Naplánovaná úloha je spuštěna při zapnutí počítače bez ohledu na to, je-li uživatel přihlášen v systému Windows. Jestliže nechcete, aby se úlohy spustily, pokud není uživatel přihlášen v systému, otevřete před odhlášením složku Naplánované úlohy a klepněte v nabídce Upřesnit na příkaz Zastavit službu Plánovač úloh. Chcete-li po přihlášení obnovit používání služby Plánovač úloh, otevřete složku Naplánované úlohy a klepněte v nabídce Upřesnit na příkaz Spustit službu Plánovač úloh.
  • Přesvědčte se, zda je systémové datum a čas zadán přesně. Program Plánovač úloh tyto informace používá pro určení okamžiku spuštění naplánované úlohy. Chcete-li změnit datum a čas, poklepejte na ukazatel času na hlavním panelu.

Příbuzná témata


Změna naplánované úlohy

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. Klepněte pravým tlačítkem myši na úlohu, kterou chcete upravit a potom klepněte na příkaz Vlastnosti.
  3. Proveďte jednu z následujících akcí:
    • Chcete-li změnit program, který se má spustit, zadejte do textového pole Spustit cestu k programu nebo klepněte na tlačítko Procházet.
    • Chcete-li změnit naplánování úlohy, klepněte na kartu Plán.
    • Jestliže chcete upravit nastavení úlohy, klepněte na kartu Nastavení.

Poznámky

  • Vyžaduje-li program úlohy parametry, zadejte je za cestu k úloze v poli Spustit.
  • Pokud cesta k programu obsahuje mezery, umístěte na začátek a na konec celé cesty uvozovky (“).


Odebrání naplánované úlohy

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. Klepněte pravým tlačítkem myši na úlohu, kterou chcete odebrat, a poté klepněte na příkaz Odstranit.

Poznámka

  • Odebráním naplánované úlohy odstraníte tuto úlohu pouze ze složky Naplánované úlohy. Program přidružený k dané úloze není z počítače odebrán.


Ukončení spuštěné naplánované úlohy

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. Klepněte pravým tlačítkem myši na název úlohy, kterou chcete ukončit, a poté klepněte na příkaz Ukončit úlohu.

Poznámky

  • Pokud naplánovaná úloha spustí další program, tento příkaz ukončí pouze původní plánovanou úlohu, ne však druhou úlohu.
  • Chcete-li úlohu znovu spustit, klepněte na ni pravým tlačítkem myši a poté klepněte na příkaz Spustit.
  • Naplánovaná úloha je spuštěna při zapnutí počítače bez ohledu na to, je-li uživatel přihlášen v systému Windows. Jestliže nechcete, aby se úlohy spustily, pokud není uživatel přihlášen v systému, otevřete před odhlášením složku Naplánované úlohy a klepněte v nabídce Upřesnit na příkaz Zastavit službu Plánovač úloh. Chcete-li po přihlášení obnovit používání služby Plánovač úloh, otevřete složku Naplánované úlohy a klepněte v nabídce Upřesnit na příkaz Spustit službu Plánovač úloh.


Okamžité spuštění úlohy

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. Klepněte pravým tlačítkem myši na úlohu, kterou chcete spustit, a poté klepněte na příkaz Spustit.

Poznámky

  • Úlohu můžete ukončit, klepnete-li v nabídce Soubor na příkaz Ukončit naplánovanou úlohu.
  • Pokud se úloha měla spustit, ale nestalo se tak, zjistěte důvod v protokolu. V nabídce Upřesnit klepněte na příkaz Zobrazit protokol.


Zobrazení protokolu historie naplánovaných úloh

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. V nabídce Upřesnit klepněte na příkaz Zobrazit protokol.


Zobrazení naplánovaných úloh ve vzdáleném počítači

  1. Poklepejte na ikonu Místa v síti.
  2. Poklepejte na ikonu počítače, u kterého chcete zobrazit naplánované úlohy.
  3. Poklepejte na složku Naplánované úlohy.

Poznámka

  • Ve vzdáleném počítači můžete upravovat úlohy pouze tehdy, je-li v něm nainstalován software vzdáleného registru a sdílení x$, kde x je pevný disk, na kterém je umístěna složka Naplánované úlohy. Počítač také musí mít v seznamu uživatelských účtů určeno, že váš uživatelský účet má přístup ke vzdálenému registru. Chcete-li určit, kteří uživatelé mají přístup ke vzdálenému registru počítače, poklepejte ve složce Ovládací panely na panel Hesla.


Dočasné vypnutí všech naplánovaných úloh

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. V nabídce Upřesnit klepněte na příkaz Pozastavit službu Plánovač úloh.

    Tento příkaz je užitečný zejména tehdy, spouštíte-li jiný program (například hru), nebo pokud instalujete software a nechcete, aby se úlohy spouštěly ve stejnou dobu.

Poznámky

  • Úlohy spuštěné v době, kdy byl program Plánovač úloh pozastaven, se nespustí dříve, než v dalším naplánovaném čase.
  • Chcete-li časové plány všech úloh obnovit, klepněte v nabídce Upřesnit na příkaz Pokračovat v běhu služby Plánovač úloh.


Vypnutí programu Plánovač úloh

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.
  2. V nabídce Upřesnit klepněte na příkaz Ukončit používání služby Plánovač úloh.

Poznámka

  • Vypnete-li program Plánovač úloh, nespustí se naplánované úlohy a Plánovač úloh se při následujícím spuštění systému Windows automaticky nespustí.


Odstraňování problémů s programem Plánovač úloh

Pokud se naplánovaná úloha v určené době nespustí, klepněte na ni pravým tlačítkem myši v seznamu úloh a poté zvolte příkaz Vlastnosti. Klepněte na kartu Úloha a přesvědčete se, zda je zaškrtnuto políčko Povoleno. Klepněte na kartu Plán a přesvědčete se, že naplánování je nastaveno správně.

Jestliže se program úlohy nespustí správně, bude možná nutné pro něj zadat argumenty příkazu. Chcete-li získat informace o programu a jeho argumentech, postupujte jedním z následujících způsobů:

  • Pokud program obsahuje nápovědu online, použijte ji.
  • Zadejte do příkazového řádku následující příkaz, slovo program nahraďte názvem zkoumaného programu:
    program /?


Otevření složky Naplánované úlohy

  • Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na položku Příslušenství, klepněte na položku Systémové nástroje a poté klepněte na položku Naplánované úlohy.