K čemu složí Proxomitron

Proxomitron - nápověda

Co je to proxomitron

Systémové požadavky

Filtry

FAQ

Martin Koníček © 2000


HTMLHelp File Created Using:

Web2HTMLHelp 		Free To Download From:
http://www.web2htmlhelp.co.uk

Also Available:
HTMLHelp ePublisher
HTMLHelp eDocument Creation Made Easy

Free To Download From:
http://www.htmlhelp-epublisher.co.uk

[ Back ]


FAQ - nejčastější otázky

Do prohlížeče se mi neukládají některé www stránky.

Prohlížeče občas hloupě poslouchají www server, který jím podstrčí upozornění, že by stránky nebylo vhodné ukládat do cache a prohlížeč ho poslechne. Proxomitron umožňuje tomuto zabránit zaškrtnutím políčka in u pragma: a last-modified v nabídce headers.

Při používání Proxomitrona jsem nepoznal jakkýkoliv rozdíl.

Pravděpodoně máte špatně nastavený prohlížeč. Proto by bylo vhodné u položky http v proxy serveru dát adresu 127.0.0.1 a port 8080.

Proxomitron se mi velice líbí a chtěl bych ho používat i pro Offline browsery, je to možné ?

Pokuď váš offline browser podporuje proxy server je to samozřejmě možné.

Po nainstalování proxomitrona se mi neanimují obrázky.

Je to způsobeno zaškrtnutím políčka freeze gif animation v hlavní nabídce programu. Toto políčko je pro animaci obrázků nutno odškrtnout.

Jsem uživatelem systému výměnných bannerů a s proxomitronem se mi nedaří získat výsledný html kód, který mám vložit na stránku.

Po dobu nastavování systému reklamních bannerů doporučuji deaktivovat webové filtry, které odfiltrují i kód, který máte vložit na stránku.

Při tvoření filtrů mi proxomitron padá

Je možné, že vám bude padat proxomitron, pokuď do políčka bounds budete zadávat složité filtry. Filtry je totiž nutno zadávat do políčka match i když je to mnohdy jednoduší to zadat rovnou do políčka bounds, které slouží k ohraničení filtrovaného textu.

Nefunguje mi přístup na servery https ( například VOLmail )

Proxomitron nepodporuje protokol https a proto ho na tento protokol v žádném případě nenastavujte.

Mám nějaký jiný problém.

Tak program hned nemažte a mailněte mi váš problém.


Filtry

Web Page

Banner replacer - nahrazuje reklamní bannery průhledným obrázkem. To způsobí, že stránka bude po filtrování vypadat prakticky identicky, ale nebude načítán velký banner.

Banner Blaster (limit text) - Banner nahradí alternativním textem, který by se zobrazil, kdybyste měli vypnuté zobrazování obrázků

Banner Blaster (full text) - Kompletně odstraní banner, tak aby po něm pokuď možno nezůstaly žádné stopy.

Kill JavaScript Banners - Zničí bannery, které jsou do stránek vkládány pomocí programovacího jazyka.

Kill Hyper Banner - Odstraní bannery tvořené v jazyce Java. Tyto bannery se dlouho načítají a velmi zpomalují a zatěžují počítač.

Counter Killer - Odstraní ze stránek počítadla, která o vás zjistí nejednu nepodstatnou informaci.

OnUnload unloader - Při zavření některých stránek se vám může stát, že se otevře několik dalších vyskakovacích oken. Tento filtr tomu jednoduše zamezí.

Kill All pop-up windows - Odstraní všechna vyskakovací okna známá dobře z webů typu geocities.

Restore pop-up windows after page loads - Po nahrání stránky obnoví vyskakovací okna. Tato volba je velmi užitečná, protože někdy je i ve vašem zájmu, aby se vám otevřelo další okno prohlížeče.

HTTP Headers

Last-Modified: (In) - Tento filtr zajistí, že vám nevyprší platnost stránek. Je to celkem výhodné, protože se vám nejedna stránka uloží do cache.

Pragma: Don't force reloads - S tímto filtrem už nebude problém ukládat stránky do cache prohlížeče. Snad jen abych upozornil, že tento filtr je typu in.

Jak vytvářet vlastní filtry ?

Web Page

Name - Určuje jméno filtru. Jméno si můžete určit zcela libovolně.

URL - určuje pro jaké adresy má filtr platit. Pokuď chcete adresy www.seznam.cz a www.volny.cz stačí napsat www.seznam.cz|www.volny.cz

Bounds - Určuje mezi kterými tagy se bude filtrovat. Pokuď chcete filtrovat skript tak napíšete <SCRIPT*/SCRIPT>

Limit - Zde je možnost limitace textu mezi tagy. Pokuď se mezi tagy nachází delší text než uvedený počet znaků nebude brán vzřetel. Pro skripty doporučuji minimálně 1024 znaků někdy 2048 a pro obrázek postačí bohatě 256 znaků.

Match - Určuje co se má nahradit. Pro skript na mujwebu by to bylo *SRC="http://mujweb.cz/adinclude/adinclude.js*

* - zastupu je jakkýkoliv text. například <tag*> může nahradit <tag img> nebo <tag1564> či <tag>

\s - nahrazuje jakkýkoliv počet mezer. například <tag\s> může nahradit <tag > nebo <tag >, ale ne <tag>. Pokuď chcete použít pravidlo, které nahradí všechny případné mezery, i v případě, že tam žádné nebudou zadejte (\s|)

| - nahrazuje nebo. Pokuď chcete nahradit <tag1> nebo <tag2> zapíšete to takto <tag1>|<tag2>

& - nahrazuje a. Pokuď chcete nahradit text, který obsahuje img a src a http zapíšete to takto *img* & *src* & *http*

(...) - umožňuje praktikovat jednotlivá pravidla samostatně. Pokuď chcete odstranit mezery, pokuď tam budou napíšete (\s|).

[#..-..] - umožňuje definovat interval. pro čísla od 10 do 20 by to vypadalo takto [#10-20]

[..-..] - Definuje samostatný interval. Pro písmeno od C do Z napíšete [C-Z]

\... - Umožňuje ukládat text do 10 paměťových pozicí. Pokuď do kolonku match napíšete <!-- \1 --> a do políčka replace napíšete \1 zviditelníte všechny poznámky.

Toto byl výčet nejzákladnějších nahrazovacích pravidel. Více pravidel je v nápovědě programu

Replace - Zde zadáte text, který bude nahrazen. Můj tip: Pokuď nevíte, který text zadat, zadejte te tam pro kontrolu poznámku <!-- Text byl odfiltrován -->

HTTP Header

In - Filtruje příchozí hlavičky. To jsou hlavičky, které jsou zaslány na váš počítač a určují jakého typu je dokument, či jak dlouho se má ukládat do cache.

Out - Odchozí hlavičky. Posílá jaký typ dokumentu chcete a jaký máte prohlížeč.

Key - Zapisuje se ve tvaru jménohlavičky: popishlavičky. Pro hlavičku pragma: no-cache napíšete pragma: nikdy více obnovení stránky a do filtru napíšet no-cache

Match - Zde zadáváte text, který má být nahrazen. Pro odstranění všeho použijte *

Replace - Zde zadáte text, kterým má být nahrazen text definovaný v kolonce match


Hlavní okno programu

WebPageFilters - aktivuje a deaktivuje webové filtry, které filtrují html kód stránek. Vypnutí těchto filtrů může být v některých případech skoro nezbytné. Jejich aktivací většinou zrychlíte načítání stránek více jak 1×. Proto je doporučuji mít pokuď je to možno zapnuté.

Outgoings header filters - Tyto filtry většinou slouží k získání vaší anonymity. Jejich aktivací i deaktivací většinou mnoho nezískáte.

Incoming header filters - Tyto filtry umožňují zakázat přístup na některé www stránky a povolit cachování všech stránek v prohlížeči.

Freeze gif animation - Asi nejbezpečnější způsob jak se zbavit reklam. Tímto zastavíte animaci animovaných obrázků, takže se vám načte jen první obrázek.

Use remote proxy - Touto volbou umožníte používání vzdáleného proxy serveru.

Bypass - Tímto tlačítkem můžete pozastavit činnost Proxomitrona.

Abort - Tímto ukončíte všechna aktivní spojení. Pokuď váš prohlížeč například nechce ukončit načítání stránky a na tlačitko stop nereaguje stiskem tohoto tlačítka zastavíte načítání všech stránek.

Log Window - Toto okno umožňuje zobrazit aktuální stav příchozích http hlaviček.


Systémové požadavky

Proxomitron vyžaduje počítač na kterém slušně běží Windows95, 98, NT nebo 2000. Proxomitron je naprogramován pro systémy typu Win32. Zatížení procesoru je závislé na počtu používaných filtrů. V praxi lze říci, že na počítači, na kterém běží prohlížeč vyšší verze než 4.0 je dostačující.


Proxomitron je proxy server. Proxy server slouží jako brána mezi internetem a prohlížečem. Prohlížeč spolupracuje s proxomitronem asi takto.

Pokuď napíšete do políčka v prohlížece adrese www.seznam.cz stane se toto

Prohlížeč: potřeboval bych stránku www.seznam.cz a jmenuji se Internet Explorer
Proxomitron: nemám zveřejňovat jeho jméno. Ahoj sezname, potřeboval bych stránku www.seznam.cz jmenuji se anonymous.
Seznam.cz: Tady máš stránku. Neukládej jí do cache a zobraz tyto bannery.
Proxomitron: vrátím prohlížečí stránku a zatajím mu to, že jí nemá ukládat do cache a smažu bannery, které by zpomalovaly.
Prohlížeč: OK, stránku jsem přijal. Dej mi prosímtě tyto obrázky...

A takto neustále funguje komunikace. Proxomitron se snaží podle vašeho nastavení zrychlovat načítání stránek různým způsobem. Mezi nejúčinnější postup patří mazání bannerů, které jsou mnohdy větší než samotná stránka. Mnohdy také stránky o sobě tvrdí, že se nedají uložit do cache. Prohlížeč hloupě uposlechne a neukládá je, i když je to možné. Proxomitron dokáže tato nastavení samozřejmě smazat a prohlížeč se stránku pokusí uložit za každou cenu. Pokuď chcete aktuální stránku požádáte si o ní stiskem tlačítka obnovit.

Proxomitron umí měnit i další proxy servery po zadaném intervalu. To je dobré zabezpečení proti napadení vašeho počítače. Jak napadnout váš počítač ukazuje následující příklad.

Prohlížeč: Chci stránku www.seznam.cz .
Hacker: Počítač má adrese internet 2045, praha, czech republic
Hacker: Pošlu mu neplatný příkaz a jeho počítač se zhroutí.

Pokuď se budou měnit proxy servery budeto vypadat asi takto:

Prohlížeč: Chci stránku www.seznam.cz.
Hacker: 100 počítaču má adresu internet 2045, praha, czech republic
Hacker: Budu muset zjistit, který je ten počítač, který hledám. Potrvá to 10 minut.
Hacker: Po 10 minutách --> ten počítač už tam není. Musel změnit adresu.
Hacker: Pokusím se zjistit jeho novou adresu.
Hacker: To je práce na několik hodin. On neustále mění adresu.
Hacker: Uživatel se už odpojil. Nemám šanci.

Proto je vhodné používat ještě jiný proxy server. Nejlépe proxy server poskytovatele, který je rychlý a má na sobě velké množství uživatelů, kteří prohlížejí české stránky, takže vás hacker těžko rozezná. Proxy se v tomto případě nedá měnit, protože poskytovatel má jen jednu proxy. Nevadí to ovšem tolik, protože jednu adresu ma minimálně nekolik tisíc uživatelů. Sám vím, že pokuď něco na internetu provedete, a nebudete používat proxy server, tak se může stát, že poskytovatel vyzradí vaše telefoní číslo i s adresou. Pokuď se připojíte přes proxy server, tak to poskytovatel nebude moci udělat, protože nebude vědět kdo z dané adresy to udělal. Bude mít například na výběr 1000 potenciálních lidí a to už se těžko zjišťuje.

Známé proxy servery:

Contactel - proxy.contactel.cz:3128
VOLný - proxy.vol.cz:8080

Proxy servery píšete ve tvaru adresa:port . Adresu proxy serveru můžete zjistit přímo u vašeho poskytovatele. Ale pozor, proxy server poskytovatele můžete požívat pouze pokuď se připojujete přes něj. Pokuď vám jde o bezpečnost mnohem více přidejte si několik veřejných proxy serverů. Plno jich naleznete na adrese http://neworder.box.sk .

Co proxomitron dělá ?

Proxomitron filtruje univerzálně příchozí i odchozí požadavky HTTP a těla html zpráv. Umí přerušit aktivní spojení a zakázat některé adresy sítě internet.

Jak ho má nastavit v prohlížeči ?

Proxomitron v prohlížeči nastavíte celkem jednoduše. V kolonce proxy server pro protokol http nastavíte adresu 127.0.0.1 a port 8080 ( při standartním nastavení ).