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Úvodem  
Flash je program pro vytváření interaktivních 

animací. Je to program, který si získal a stále získává 
nové příznivce pro svoji jednoduchost na jedné straně 
a rozsáhlé možnosti na straně druhé. Tato publikace 
z řady PCWorld Edition je zaměřena na rychlý úvod 
do použití Flashe a to pouze jedné z jeho stránek – 
zvládnutí základních technik práce bez použití Action-
Scriptu, tedy bez možností interaktivity. 

Pro začínající uživatele Flashe je ale především 
nutné pochopit práci s programem, který má svoje spe-
cifické nástroje a možnosti, které sice mohou mít ekvi-
valenty v jiných aplikacích, ale používají se třeba 
poněkud odlišným způsobem. 

Základem této publikace je představení pracovního 
prostředí Flashe, ukázka použití základních nástrojů, 
vysvětlení práce s časovou osou, rámečky a dalšími 
specifiky Flashe. Značná pozornost je věnována sym-
bolům a vytváření jejich instancí, práci s vrstvami... 
Závěr publikace tvoří několik ukázek základních postu-
pů, které musí zvládnout každý uživatel tohoto mocné-
ho nástroje.  

Zaměření těchto publikací máte v rukou i vy sami. 
Podívejte se na anketu na www.win.cz nebo 
www.idg.cz, kde můžete svým hlasem ovlivnit témata 
dalších připravovaných sešitů ediční řady PCWorld 
Edition. 

Svoje připomínky, náměty a poznámky zasílejte:  
UNIS Publishing, s.r.o. 
Jundrovská 33, 624 00 Brno 
tel.: 05 – 41 51 55 00    fax: 05 – 41 51 55 02 
e-mail: knihy@win.cz 
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Začínáme s programem FLASH 5 
Dříve, než se pustíme do vlastního programu, mám jedno upozornění pro ty, kteří program FLASH ne-

vlastní. Na stránce www.macromedia.cz nebo přímo na www.digitalmedia.cz/macromedia si můžete stáhnout 
třicetidenní plnou verzi tohoto programu. Můžete také použít kopii programu, která je umístěna na CD 
v PCWorldu 4/2001.  

 
Po instalaci a spuštění programu použijte tlačítko Try ke spuštění zkušební verze. Tlačítko Buy Now 

slouží k zakoupení produktu v internetovém obchodě a platbě kartou v dolarech. Pro nákup v tuzemsku si 
prohlédněte výše uvedené internetové adresy. 

Než otevřete FLASH 
Jako u celé řady jiných aplikací, i v případě programu FLASH je nutné pro zdárný postup prací na va-

šem projektu: 
• znát prostředí aplikace, se kterou pracujete, umět používat jednotlivé nástroje a vědět, kdy a které 

z těchto nástrojů použít 
• mít jasnou představu o díle, které vytváříte. Čím mlhavější tato představa bude, tím déle se bude-

te dopracovávat k výsledku. 
Animace vytvářené v programu FLASH nejsou bezpodmínečně určeny pro web, ale jejich využití je zde 

nejčastější. Před tím, než se rozhodnete pro vytvoření animovaných webových stránek (nebo alespoň strá-
nek s animovanými prvky), je důležité ujasnit si co a pro koho vytváříte. Animace by měla být integrovanou 
a přirozenou součástí stránek, a ne cizorodým, pouze efektním prvkem, který návštěvníka při dalších přístu-
pech na vaši stránku již nezaujme a naopak bude zdržovat. 
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Grafika 
V programu Flash můžete pro vytváření animací používat obrázky vytvořené mimo Flash a importovat 

je. Grafické možnosti Flashe jsou však dosti silné na vytvoření vlastních obrázků. Kdy sáhnout po možnosti 
importu a kdy tvořit obrázek přímo v programu Flash? Do jisté míry to závisí na vašich zkušenostech 
a praxi. Pokud jste velmi zruční v jiných programech (Photoshop, FreeHand, Illustrator...) můžete vytvořit 
obrázky mimo Flash a importovat je. Pokud ale nedisponujete těmito programy, nebo dobře zvládáte i práci 
s nástroji Flashe, která má přece jenom svá specifika, nic vám nebrání připravit obrázky přímo ve Flashi. Je 
samozřejmé, že možnosti Flashe nedosahují zcela schopností, kterými disponují specializované aplikace na 
tvorbu kreseb, ale i přes svoji na první pohled chudou nabídku budete možná překvapeni tím, co vše dokáží. 
Pokud zvolíte možnost importu, dávejte pozor na to, ve které verzi výsledky práce ukládáte.  

Flash podporuje import souborů v těchto grafických formátech: 
 

typ souboru grafika zdrojová aplikace poznámka 
.ai vektorová Illustrator Illustrator do verze 6.0, ne novější. Po importu 

je třeba obrázek rozdělit na části. 
.fh7, .fh8, .fh9 
.ft7, .ft8, .ft9 

vektorová FreeHand Pro import lze doporučit především verzi 7. 

.dxf vektorová AutoCAD Použijte pouze soubory do verze 10. Nepodpo-
rují se výplně ploch, soubor musí být v ASCII 
tvaru. 

.emf, .wmf metafile   
.eps postscript   

.bmp, .gif, 
.jpg, .png,.pic 

bitmapová  Formáty .gif a .png umožňují pracovat 
s průhledným pozadím. 

.psd bitmapová Photoshop Vyžaduje nainstalovaný QuickTime 4.0 
.tif, .tgf, .pict bitmapová  Vyžaduje nainstalovaný QuickTime 4.0 

 
Pokud není uvedena aplikace, můžete příslušný formát obdržet jako variantu uložení nebo exportu gra-

fiky z různých aplikací. Pokud např. používáte program CorelDRAW, můžete grafiku z tohoto programu 
exportovat do všech zde uvedených formátů (mimo vlastní formát Photoshopu .psd). 

Při importu může v jednotlivých případech dojít k řadě různých problémů – u vektorové grafiky mohou 
dělat potíže přechodové výplně nebo přechody tvarů, stejně jako vrstvy apod. Obecně se doporučuje použí-
vat pro import grafiku z aplikace FreeHand, která ale zase u nás nepatří mezi nejrozšířenější. V případě po-
tíží zkuste nejprve změnit formát souboru, nebo importovat po částech, po jednodušších objektech, a některé 
úpravy provést až ve Flashi (přechodové výplně...).  

Kdy použít bitmapu a kdy vektorovou grafiku? Bitmapová grafika se hodí zejména pro pozadí, pro ba-
revné výplně, nebo pro vytvoření dílčích částí animovaných objektů. Její použití má určité nevýhody – pře-
devším velikost souborů. Obecně je bitmapový obrázek mnohem větší než obrázek vektorový. (Nemohu se 
zde zabývat detaily, ale doporučuji naši knihu Skenování, úprava obrázků a tisk (UNIS Publishing, 2000) 
nebo Grafika a animace – kouzla na webu (UNIS Publishing, 2000).) Další nevýhodou je neprůhlednost 
„objektů“ v bitmapách. Bitmapa, ať je jejím obsahem cokoliv, je vždy tvořena obdélníkovou maticí obrazo-
vých bodů. Výjimkou je formát GIF, který dovoluje definovat jednu barvu jako průhlednou, případně formát 
.psd (interní formát Photoshopu), který ale pro import vyžaduje nainstalovaný QuickTime 4.0 a navíc lze 
importovat pouze staré verze – 2 a 3, současná verze 6, ani předchozí 5 nebo 5.5 podporovány nejsou.  Mezi 
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Bitmapa ale nemusí ani po importu do programu Flash zůstat bitmapou. Nevýhodou bitmap je poměrně 
velká velikost souboru a určitá omezení, která máte při další práci s bitmapou narozdíl od práce 
s vektorovou grafikou. Flash nabízí možnost převodu bitmapy na vektorovou grafiku, tzv. vektorizaci nebo 
trasování (anglicky Trace) bitmap. 

Bitmapu umístěnou na jevišti (např. po importu nebo přetažením z knihovny) můžete převést do vekto-
rové podoby příkazem Modify > Trase. 

 
Po spuštění příkazu se zobrazí dialogové okno, ve kterém můžete nastavit parametry řídící proces traso-

vání. Následující řada obrázků ukáže vliv jednotlivých parametrů na výsledné zobrazení: 
Color Treshold (práh barev) – nastaví citlivost rozlišování barev. Hodnota se zadává v rozsahu 0-500. Čím 
menší hodnotu zadáte, tím citlivější bude posuzován rozdíl barev a tím barevně podobnější obrázek obdržíte. 
Současně ale narůstá počet vektorových obrázků, které jsou pro popis bitmapy třeba. 

Color Treshold = 20 Color Treshold = 50 Color Treshold = 100 
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je černý, nevybraného jezdce bílý. Jakmile jezdce označíte, můžete klepnutím na ikonu s barevným ob-
délníkem vpravo otevřít barevný vzorník a nastavit barvu. 

• Tažením jezdce můžete upravit i polohu počátku nebo konce barevného přechodu. Pokud posunete např. 
levý jezdec směrem doprava, bude část přechodu od levého okraje až po pozici jezdce vyplněna pouze 
nastavenou barvou jezdce. 

 

Na obrázku vlevo jsou oba krajní jezdce přitaženy k sobě 
a lineární přechod bude v tomto případě tvořen vlastně 
pouze zcela černým a zcela bílým pruhem. 

• Lineární přechod můžete dále upravovat vložením dalších jezdců dovnitř mezi krajní jezdce. Stačí klep-
nout pod barevný proužek a přidali jste nového jezdce. Jezdce odstraníte snadno přetažením jezdce dolů 
od proužku.  

 

Pro každý jezdec můžete nastavit vlastní barvu a tak 
vytvořit přechod přesně podle svých představ. 

• Pokud potřebujete uvnitř přechodu vytvořit pouze jednobarevnou oblast, musíte přidat dva jezdce se 
stejnou barvou, které určují počátek a konec takového úseku: 

 

Na obrázku vlevo je přechod, který má uprostřed zcela 
černou část a krajní třetiny jsou tvořeny lineárním 
přechodem do bílé. 

• Klepnutím na tlačítko s ikonou diskety uložíte tento přechod do vzorníku barev – Swatches – (nikoli na 
disk) pro další použití. 
 
Postup vytvoření radiálního přechodu je podobný: 

 

Ze seznamu vyberte položku Radial Gradient a získáte 
zobrazení podobné tomu, které jsme si vysvětlili u lineárního 
přechodu. 
Jediný rozdíl je v tom, že v ukázce zobrazení vidíte skutečně 
radiální přechod (tedy změnu barev ze středu směrem ven. 
Na proužek pro definici gradientu se dívejte jako na výřez 
s tím, že levý okraj odpovídá středu gradientu a pravý okraj 
odpovídá okraji gradientu. 
Stejným postupem, jako u lineárního gradientu můžete měnit 
barvy, upravovat jejich rozložení a dle potřeby tak upravit 
vlastní radiální přechod. 
I v tomto případě můžete nastavení přechodu, který chcete 
opakovaně používat, uložit klepnutím na tlačítko s ikonou 
diskety vpravo dole. Přechod bude uložen do barevného 
vzorníku.   

Poslední položkou v rozbalovacím seznamu nastavení výplně panelu Fill je Bitmap. To vám poskytuje 
možnost použít kterýkoliv importovaný bitmapový obrázek jako výplň. Postup práce je velmi jednoduchý. 
Nejprve musíte importovat vhodný bitmapový obrázek do Flashe pomocí příkazu File > Import. Podívejte 
se do předchozí kapitolky na podporované formáty. 

Po importu jsou bitmapy uloženy v knihovně (Library), kterou můžete vyvolat příkazem Windows > Li-
brary. V minulé kapitole jsme si ukázali práci s bitmapami a možnost použití bitmapy převedené příkazem 
Modify > Break Apart jako barevného vzorku. Tuto možnost máte v podstatě i bez tohoto příkazu. Podívejte 
se na panel Fill.  
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Důležité také je, že malováním štětcem vytváříte vektorový objekt. Používám sice termín „malovat“, 
který se spíše vztahuje k bitmapovým obrázkům, ale skutečně jde o objekt zcela srovnatelný např. 
s obdélníkem.  

Tužka 
Narozdíl od nástroje pero, který kreslí matematicky definované křivky, slouží nástroj Pencil – tužka – ke 

kreslení od ruky. Tužkou můžete kreslit libovolné tvary. Další rozdíl oproti peru je ten, že i když nakreslíte 
uzavřenou křivku, nebude její obsah vyplněn výplní. Pokud budete chtít výplň vytvořit použijte nástroj kbe-
lík s barvou. 

Pro nástroj tužka můžete nastavit: 
• druh obrysové čaáry a její tloušťku v panelu Stroke; 
• barvu obrysové čáry v různých panelech – Stroke, Colors, Mixer; 
• mód kreslení. 
 

U poslední volby se pozastavím. Na panelu nástrojů najdete při výběru nástroje Pencil (tužka) v části 
Options tlačítko Pencil Mode. Stiskněte na něm tlačítko myši a můžete vybrat mód kreslení z těchto nabí-
dek:  

 

Straighten (přímý) – kreslená čára bude sestávat z přímých úseků. 
Smooth (hladký) – roztřesená čára kreslená podle ruky bude vyhlazena. 
Ink (inkoust, stopa) – čára bude odpovídat skutečné stopě, kterou tužka při volném 
kreslení od ruky zanechá. 

 Na obrázku je ukázka použití jednotlivých módů kreslení tužkou: 
Ink Smooth Straighten  

 

Pokud budete chtít kreslit pravidelné objekty 
(kružnice, obdélníky, lomené čáry...) můžete 
použít vedle nastavení kreslicího módu 
Straighten také přichytávání k mřížce. 
Stejně tak může přinést výsledky i příkaz View 
> Snap to Object (nebo stejnojmenné tlačítko 
v pruhu základních příkazů). 
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Text 
Nástroje pro práci s textem jsem nechal až jako poslední nástroj. Ve srovnání s jinými aplikacemi je zde 

jenom málo odlišností. Pro vložení textu použijte nástroj Text (má ikonu se symbolem A) z panelu pracov-
ních nástrojů. Klepněte nástrojem na plochu, kam chcete text napsat.  

 

Zobrazí se obdélníček s kolečkem v pravém horním rohu. Do tohoto 
obdélníčku můžete začít psát text. Šířka obdélníka se postupně 
zvětšuje tak, aby byl schopen pojmout napsaný text. 

 

Pokud chcete omezit šířku textového pole, přetáhnutím kolečka 
upravíte šířku textového pole. Vhodnými nástroji pro přesné určení 
potřebné šířky jsou vodítka nebo mřížka.   

 

Pokud je v pravém horním rohu textového pole čtvereček, zalamuje 
se text automaticky podle nastavení odstavců a zachovává 
nastavenou maximální šířku. 

Textové pole můžete přetažením myši umístit, můžete s ním otáčet, zkosit ho, měnit jeho velikost apod. 
Pro nastavení vlastních atributů textu máte k dispozici plovoucí panely Character (znak) a Paragraph (od-
stavec): 

 

V okně Character nastavujete vlastnosti znaků: 
- Font (písmo): můžete vybrat libovolné písmo, lze ale doporučit 

použití TrueType fontů, nejlépe běžně používaná písma (Arial, 
Times...) 

- velikost 
- vyznačovací řezy: kurzíva a nebo tučné písmo 
- lze nastavit barvu textu 
- prostrčení: proložení znaků 
- Kern (vyrovnání párů): pokud zaškrtnete toto políčko budou 

se vyrovnávat znaky, jako např. AV, které by měly být 
napsány blíže u sebe než např. dvojice MN. 

- svislé umístění: můžete nastavit horní nebo dolní index, nebo 
normální umístění 

 

Vlastnosti odstavců nastavíte v panelu Paragraph: 
- Align (zarovnání): máte na výběr zarovnání doleva, na střed, 

doprava a do bloku 
- dále můžete nastavit vzdálenost od levého a pravého okraje, 

odsazení prvního řádku a řádkový proklad. 

Jednotlivé hodnoty nastavujete buďto zapsáním příslušné číselné hodnoty do textového políčka nebo 
můžete použít táhlo. Pozor u některých hodnot je táhlo velmi citlivé a pokud vám trochu ujede ruka, zmizí 
vám text z obrazovky. Nápravu provedete nejlépe zadáním opravené hodnoty přímo do textového pole. 
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Pokud např. bude mít v tomto 
uvedeném případě obdélník 
definovanou obrysovou křivku, 
nedotýká se výplň výplně a místo 
spojení dojde k oříznutí elipsy. Nestačí 
ani to, že barva obrysu a výplně je 
stejná, nezapomeňte, že pracujeme 
s vektory! Jak vidíte na obrázku s 
posunutím, obrysová linka obdélníka 
způsobila, že objekty se nesloučily 
a původní elipsa byla oříznuta.  

  

Pokud by ale měla elipsa také obrys, 
a to ve stejné barvě jako nakreslený 
obdélník, došlo by ke spojení obrysů, 
což si můžeme názorně předvést na 
levém obrázku. 
Tím, že jsem ale obrys posunul, došlo 
nejprve k tomu, že se sloučily nyní 
sousedící výplně, a posunutý obrys 
rozdělil výplň na tři části – horní z nich 
jsem na pravém obrázku posunul. 
Druhá část ležící v eliptické části 
obrysové křivky je vybrána a má 
poněkud světlejší barvu. Zbývající část 
leží v obdélníkové části obrysové 
křivky. 

Tato alchymie probíhá pouze na jedné vrstvě, objekty ležící na různých vrstvách jsou zcela samostatné 
a mohou se vzájemně překrývat bez interakcí. Mezi objekty na různých vrstvách lze například definovat 
průhlednost: 

  

Na obrázku vlevo je u výplně 
obdélníka nastavena 50% 
průhlednost. Proto, pokud obdélník 
leží ve vyšší vrstvě, je pod ním vidět 
překrytá část elipsy na nižší vrstvě.  
Změníme-li pořadí vrstev tak, že 
obdélník bude ležet na nižší vrstvě, 
překryje neprůhledná elipsa zcela část 
obdélníka. Protože jsou ale oba 
objekty na různých vrstvách, můžete 
měnit jejich polohu aniž by došlo 
k oříznutí nebo sloučení. 

V každé vrstvě leží ještě nad touto úrovní jeviště ještě úroveň překryvná (Overlay Layer). V této úrovni, 
která je nerozdělitelně spjata s úrovní jeviště v rámci jedné vrstvy, leží objekty typu skupina, text, bitmapa 
nebo instance symbolu. Mezi objekty uvedených typů je možné definovat pořadí, tj. zařazovat je nad sebe, 
posouvat je apod. bez obav, že by se tyto objekty ořezávaly nebo spojovaly.  
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Poslední rámeček (je jedno zda je to klíčový nebo koncový rámeček) můžete tažením myší přesunout na 

další pozici. Pokud jde o koncový rámeček sprite, „natáhne se“ sprite. Pokud přetahujete jeden samostatný 
klíčový rámeček, posune se na danou pozici a prostor mezi původní pozicí a novou polohou se vyplní 
prázdnými rámečky. 

Uvnitř časové osy můžete přetahovat koncové rámečky sprite pouze na úkor prázdných rámečků. Ne-
můžete koncový rámeček přetáhnout za již existující klíčový rámeček: 

  
 V tomto případě není možné přetáhnout koncový rámeček statického sprite dále než k pozici nejbližší-

ho klíčového rámečku. Pokud byste potřebovali sprite ještě natáhnout, musíte rámečky přidat příkazem In-
sert > Frame nebo shodným příkazem z místní nabídky. Chcete-li přidávat po jednom rámečku, klepněte 
např. na statický sprite pravým tlačítkem a tím označíte jeden rámeček. Příkazem Insert > Frame přidáte 
právě jeden rámeček. Pokud na sprite klepnete levým tlačítkem označí se celý sprite a příkazem Insert > 
Frame zdvojnásobíte počet rámečků sprite:  

 

Původní délka sprite byla 1-11, 
po přidání rámečků zahrnuje nyní 
sprite rámečky 1-22. 

Se sprite (ať již jde o statický nebo tween sprite) můžete pracovat jako s jedním objektem: klepnutím ho 
označíte a tažením můžete přesunout na jinou pozici. 

  
I v tomto případě budou uvolněné rámečky vlevo zaplněny prázdnými rámečky (tj. rámečky bez obsa-

hu). Naopak, jak vidíte, byl sprite přetažen i přes existující klíčové rámečky (na pozici 23). Tento rámeček 
je ztracen. 

S rámečky můžete pracovat i mezi vrstvami. Uchopte sprite na jedné vrstvě a přetáhněte ho na jiné mís-
to jiné vrstvy. Překryté stávající rámečky na cílové pozici budou ztraceny: 
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Jednoduché animace 
V této poslední části si ukážeme jednoduché příklady animací. 

Nastavení základních parametrů 
Příkazem Modify > Movie otevřete okno vlastností animace, Movie Properties.  

 

-  

V okně Movie Properties můžete nastavit: 
• Frame Rate (snímková frekvence): rychlost, jakou se bude animace přehrávat udaná v rámečcích za vte-

řinu (frame per second, fps). Přednastavená je hodnota 12 fps, pro promítání na webu můžete tuto hodno-
tu snížit až na 8 fps. V časové ose je potom třeba sledovat, jak dlouho každá akce, kterou navrhnete, 
potrvá. Každý pohyb by měl být rozfázován tak, aby působil přirozeně. Pokud upravíte snímkovou frek-
venci, bude pravděpodobně zapotřebí upravit i počet snímků. Čas, po který bude akce probíhat, je počet 
rámečků x snímková frekvence. 

• Dimension (rozměr): udává se v obrazových bodech, pixelech. Při návrhu animace počítejte i s uživateli, 
kteří pracují na 15” monitorech s rozlišením 640 x 480 bodů. Pokud upravujete rozměr podle vytvořené 
animace, můžete klepnout na tlačítko Contents, pokud budte chtít nastavit rozměr podle aktuálního na-
stavení tiskárny a papíru, klepněte na Printer. 

• Background Color (barva podkladu): standardně je nastavena bílá barva podkladu jeviště. Můžete si ale 
nastavit barvu dle potřeby. 

• Ruler Units (jednotka pravítka): pro nastavení pravítka. K dispozici máte jednotku: obrazové body (pi-
xely, doporučuji si na tuto jednotku zvyknout), mm, palce apod. Podle tohoto nastavení se budou zobra-
zovat také údaje na panelu Info. 

• Save Default (uložit jako standardní): právě nastavené hodnoty budou uloženy jako přednastavené 
a standardně se použijí při vytváření nové animace.    

Cell animace 
Tato animace typu rám-rám (frame-to-frame) sestává z jednotlivých rámečků, které obsahují postupné 

fáze pohybu. Vytvoříme jednoduchou animaci, při které se bude uprostřed jeviště pomalu otáčet čtverec. 
později si ještě tuto animaci ukážeme jednou za použití jiného postupu. Vše, co budeme potřebovat, je jedi-
ný objekt, čtverec, který budeme postupně otáčet a vkládat do jednotlivých rámečků. 
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Vlastní vytvoření mezisnímkového přechodu: 

 

- Klepněte pravým tlačítkem na v předchozích 
krocích vytvořený statický sprite (tj. na oblast 
rámečků mezi 1-10). 

- Z místní nabídky vyberte příkaz Create 
Motion Tween – a to je vše. 

Jak vidíte na obrázku, statický sprite byl 
nahrazen pohybovým mezisnímkovým sprite. 
Symbolizuje to šipka vycházející od rámu 1 
k rámu 10. 
Všimněte si také polohy koule, která odpovídá 
poloze přehrávací hlavy. Tato poloha 
animovaného objektu již byla vytvořena 
automaticky programem jako interpolace 
krajních  poloh objektu daných klíčovými 
rámečky. 
Pokud si budete chtít prohlédnout chování 
vytvořené animace, můžete použít přetažení 
přehrávací hlavy nebo příkaz Control > Play. 

Pro prohlédnutí můžeme použít i nástroj, který jsme si uvedli v minulé ukázce – Onion Skin: 

 

- klepněte pod časovou osou na tlačítko Onion 
Skin; 

- tažením myši posuňte značky začátku a konce 
zobrazované oblasti na rámečky 1 a 10 (nebo 
použijte příkaz Onion All z nabídky tlačítka 
Modify Onion Markers – je to 5 tlačítko zleva 
pod časovou osou) 

- v mém případě jsem ještě zapnul volbu Edit 
Multiple Frames (4 tlačítko zleva pod časovou 
osou). V tomto zobrazení jasně vidíte, že 
existují pouze dva editovatovatelné objekty 
v krajních polohách tweenu. Mezilehlé polohy 
jsou zobrazeny průhledně a vytváří je počítač 
bez vašeho ovlivnění (i když za chvíli si 
ukážeme, jak toto tvrzení obejít). 

Je možné, že dodatečně zjistíte, že délka animace je nevhodná – ať již příliš dlouhá nebo krátká. Bylo by 
třeba do animace vložit rámečky nebo je ubrat. Není nic jednoduššího – klepněte na sprite pravým tlačítkem 
myši a z nabídky vyberte příkaz Insert Frame. Toto opakujte tolikrát, kolikrát bude zapotřebí. Můžete si také 
zkusit přetažení koncového řídicího rámečku: 
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Situace po 
přidání řídicí 
vrstvy 
k vrstvě 
Odraz.  

• na obrázku si všimněte, že vrstva Odraz je mírně posunuta vpravo a vyjadřuje tak spojení s vrstvou 
Guide; 

• pokud by nebyla vrstva Guide označena, označte ji klepnutím na její název; 
• nástrojem tužka (Pencil) nakreslete na tuto vrstvu křivku, podél níž se bude objekt pohybovat; 

 

Nakreslenou čáru nástrojem 
Pencil můžete upravit 
kombinací libovolných 
nástrojů, přidáváním uzlů atd. 
do podoby, která vám bude 
vyhovovat. 

 

Pro tvarování jsem použil 
nástroj Pen (pero) pro 
odstraněné uzlů a nástroj 
Subselect Tool pro úpravu 
křivostí křivky a polohy uzlů.  

• v dalším kroku pravým tlačítkem klepněte na statický sprite vrstvy Odraz, tj. někde mezi rámečky 1-13. 
Z místní nabídky vyberte Create Motion Tween. 

• pokud není zobrazeno okno Frame, použijte příkaz Modify > Frame:  

 

v panelu zaškrtněte políčka: Orient to Path a Snap. 
Protože budeme tuto animaci ještě upravovat, zaškrtněte 
i políčko Scale. 
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Na závěr 
Export a publikování 
Hotovou animaci můžete uložit příkazem File > Save ve formátu *.fla, což je interní formát Flashe. Pro 

spouštění aplikace v prohlížeči Flash Player použijte příkaz File > Export Movie do formátu *.swf. Prohléd-
něte si nabídku exportních formátů a vyberte si případně jiný, v závislosti na prohlížeči, který chcete použít 
pro spouštění animace. Velmi rozsáhlé možnosti nabízí příkaz File > Publish Settings, ve kterém můžete na-
stavit velké množství parametrů pro začlenění animace např. do HTML kódu pro spouštění na webu apod. 
Tato problematika je ale již mimo rámec této publikace. 

Vybrané klávesové zkratky 
Příkaz Nabídka Klávesová zkratka Příkaz Nabídka Klávesová zkratka 
100% View | Magnification Ctrl+1 Lock Guides View | Guides Ctrl+Alt+; 
Add Shape Hint Modify | Transform Ctrl+Shift+H Movie Modify Ctrl+M 
Align Window | Panels Ctrl+K Movie Explorer Window Ctrl+Alt+M 
Align Center Text | Align Ctrl+Shift+C New File Ctrl+N 
Align Left Text | Align Ctrl+Shift+L New Symbol Insert Ctrl+F8 
Align Right Text | Align Ctrl+Shift+R Next View | Goto Page Down 
Antialias View  Ctrl+Alt+Shift+A Open File Ctrl+O 
Antialias Text View Ctrl+Alt+Shift+T Open as Library File Ctrl+Shift+O 
Blank Keyframe Insert F7 Outlines View Ctrl+Alt+Shift+O 
Bold Text | Style Ctrl+Shift+B Paragraph Window | Panels Ctrl+Shift+T 
Break Apart Modify  Ctrl+B Paste Edit Ctrl+V 
Bring Forward Modify | Arrange Ctrl+Up Paste Frames Edit Ctrl+Alt+V 
Bring to Front Modify | Arrange Ctrl+Shift+Up Paste In Place Edit Ctrl+Shift+V 
Character Window | Panels Ctrl+T Play Control Enter 
Clear Keyframe Insert Shift+F6 Previous View | Goto Page Up 
Clear Edit Backspace Print File Ctrl+P 
Convert to Symbol Insert F8 Quit File Ctrl+Q 
Copy Edit Ctrl+C Redo Edit Ctrl+Y 
Copy Frames Edit Ctrl+Alt+C Remove Frames Insert Shift+F5 
Cut Edit Ctrl+X Remove Transform Modify | Transform Ctrl+Shift+Z 
Cut Frames Edit Ctrl+Alt+X Reset Text | Tracking Ctrl+Alt+Up 
Default File | Publish Preview F12 Rewind Control Ctrl+Alt+R 
Deselect All Edit Ctrl+Shift+A Rulers View Ctrl+Alt+Shift+R 
Duplicate Edit Ctrl+D Save File Ctrl+S 
Edit Grid View | Grid Ctrl+Alt+G Save As File Ctrl+Shift+S 
Edit Guides View | Guides Ctrl+Alt+Shift+G Scale and Rotate Modify | Transform Ctrl+Alt+S 
Edit Symbols Edit Ctrl+E Select All Edit Ctrl+A 
Fast View Ctrl+Alt+Shift+F Show All View | Magnification Ctrl+3 
First View | Goto Home Show Frame View | Magnification Ctrl+2 
Frame Modify Ctrl+F Show Grid View | Grid Ctrl+´ 
Frame Window | Panels Ctrl+F Show Guides View | Guides "Ctrl+;" 
Frame Insert F5 Snap to Grid View | Grid Ctrl+Shift+´ 
Group Modify Ctrl+G Snap to Guides View | Guides "Ctrl+Shift+;" 
Hide Edges View Ctrl+H Snap to Objects View Ctrl+Shift+/ 
Hide Panels View Tab Step Backward Control , 
Import File Ctrl+R Step Forward Control . 
Info Window | Panels Ctrl+Alt+I Test Movie Control Ctrl+Enter 
Instance Window | Panels Ctrl+I Timeline View Ctrl+Alt+T 
Instance Modify Ctrl+I Undo Edit Ctrl+Z 
Italic Text | Style Ctrl+Shift+I Ungroup Modify Ctrl+Shift+G 
Keyframe Insert F6 Unlock All Modify | Arrange Ctrl+Alt+Shift L 
Last View | Goto End Work Area View Ctrl+Shift+W 
Library Window Ctrl+L Zoom In View Ctrl+= 
Lock Modify | Arrange Ctrl+Alt+L Zoom Out View Ctrl+- 

 


