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Welcome to Altiris eXpress!

Altiris eXpress was designed with ease of use and flexibility in mind – to give you the best product on the
market for imaging, deploying, restoring, remote controlling, and managing your networked computers
from an easy-to-use Console.

Hands-off Deployment. You won’t need to make multiple trips to your computers to get them connected
to the Console, and you won’t have to manually customize each computer’s configuration after imaging.

Flexible. You no longer have to deal with static images; you can re-image computers without changing
existing registries and unique configurations. You can also back up computers, or just their registries, so
you can restore a computer to working condition easily and quickly.

Efficient. You can install new software, patches, or fixes without re-imaging. Using RapidInstall Packages
(RIPs), Personality Packages, or other packages, you can distribute software, updates, service packs, and
computer personalities to all the computers in your company—just drag and drop!
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What's New in Altiris eXpress 5.0?

Support for Multiple Consoles and More Complex Network
Environments
Altiris has reworked the product’s architectural components to provide additional flexibility and support for
more complex network configurations. In particular, Altiris eXpress now supports multiple servers,
consoles, PXE servers, and file servers in a single installation, providing increased scalability, decreased
network traffic, and overcoming router multicast limitations, which allows PCs within a network segment to
be managed by servers within that segment.

New Installation Wizard and Remote Client Install
In the past, installation has been the most difficult part of using Altiris eXpress. Altiris eXpress Version 5.0
now includes a wizard that walks you through the entire installation of your system. You can also configure
and install AClient (the Altiris client for Windows), in Windows NT and 2000 environments. Once AClient is
installed on your client computers, you can remotely install BootWorks to their local hard drives from your
eXpress Console. The Console and AClient now have the ability to install, configure, and manage
BootWorks for you.

Hardware and Software Inventory
Altiris eXpress now gathers a hardware/software inventory for managed PCs. Filter groups of PCs based
on similar hardware and software, create Conditional Events that will only execute on PCs with a specified
configuration, or that branch based on different hardware and software configurations, or take a detailed
look at each managed computer's Properties from the Console.

Available information includes:

• General Properties: name, MAC address, operating system, etc.
• Hardware: processor, RAM, display, manufacturer, serial number, Wake on LAN, drives, etc.
• Configuration: TCP/IP, Microsoft Networking, NetWare Client Settings, and User Information
• Applications: all installed applications with: description, publisher, version, product ID, etc.
• Services: all installed services, whether they are running or not
• Devices: all installed devices (in a tree, similar to what is available directly through Windows)
• Location: PC name, owner/contact name, department, location, phone number, e-mail, etc.

Remote Control and Chat
Altiris eXpress now has the ability to remotely view what is on a managed computer's screen, to take
control of one or more managed computer s keyboard and mouse, and to instigate a remote chat session.

AClient Security Enhancements
AClient can now be password protected (not displaying any computer information until the password has
been supplied), can be hidden in the system tray, and provides encryption of names and passwords.
Administrators can allow end users to defer Events to a more convenient time (up to 24 hours).
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Initial Deployment Event and Virtual Computers
There are now three ways to establish initial deployment Events for single, group, or mass computer
deployments of new computers.

• Virtual computers are set up before they come on line, and are assigned names, groups, and initial
Events. If the administrator enters a known MAC address or serial number for the new computer,
when the computer connects to the network, it will automatically begin executing its first assigned
Event.

• If the MAC address and serial number are not known ahead of time, when the computer boots to
DOS, a list of available virtual computers is displayed, allowing an administrator to choose the
computer's assignment from that list.

• From a DOS boot, administrators can select the Initial Deployment Event to choose a desired config-
uration set and task set (without having set up a virtual computer ahead of time).

Conditional Events
Altiris eXpress 5.0 also supports Conditional Events that will only execute on computers with a specified
configuration, or that branch based on different hardware and software configurations.

An easy-to-use dialog box shows the basic conditions you can specify for an Event. Clicking the Other
button allows you to build custom conditions using any combination of the gathered hardware and software
inventory information.

Integration with PC Transplant
From within the eXpress Console, administrators can now edit Personality Packages and remotely deploy
Personality Packages as part of an Event.

Integration with Compaq Insight Manager LC
If Altiris eXpress detects the Compaq agents on a computer, it adds an option to the eXpress Console
menus and toolbar that launches the Insight Manager console, allowing administrators to diagnose and
upgrade drivers on Compaq computers.
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Setting Up the Altiris Client Software

Install Clients and Connect to the eXpress Server
To register a computer with the eXpress Server, run aclient.exe on the computer. When AClient is
installed, the computer appears in the Computers list on the Console. You can install AClient locally, or
remotely from the Console (Win NT/2000 computers only). After AClient is installed, you can install
BootWorks from the Console if you want computers to run it locally.

Note: Since AClient installs and runs as an administrative service, you must have rights to install services.

Install AClient locally
1. From the computer where you want to install aclient.exe, browse for the aclient.exe program and

double-click on the file, or choose Start > Run and type in the path where you installed eXpress.

2. Enter the path where you want to install AClient, or accept the default.

3. If you don't want AClient settings to be accessible to users, select Secure modification of service
properties and enter a password when prompted.

4. If you are managing security IDs for Windows NT/2000 computers and you want to run a SID utility as
part of an imaging Event, select Enable changing of Security ID. For more information about this
option, see “Scenarios for Generating Security IDs (SIDs)” on page 20.

5. Choose Next. If you chose to enable security IDs, you will see a screen listing options you can use for
managing SIDs. Select the utility (or utilities) you want to use and enter the path where the utilities are
stored.

6. Choose Next to install AClient.

Install AClient remotely
1. Open the Remote Client Installer by choosing the icon from the Console toolbar or selecting it from

the Tools menu.

2. Choose Add.

3. Enter the username and password of the account that has administrative rights to the computers that
you will add to the remote install list.

4. Set up the AClient configuration as described in "Install AClient locally," above.

5. Browse the network and highlight the computers you want to add to the install list.

6. Choose OK. The computers appear in the installer list.

7. Choose Install.

Install BootWorks
To image a computer or back up/restore its registry, you must boot it with BootWorks. You can install
BootWorks on the computer hard drive, or you can install it on a PXE Server and run it from there.

To install BootWorks on a managed computer, right-click on the computer in the Console Computers list
and choose Advanced > Install BootWorks.

See "Using Boot Disk Creator" in the Help Contents for more information.
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Test Client Computer BootWorks/PXE Connections
1. Create an Event by choosing the New Event icon on the Console toolbar. A new Event is added to

the Events list. To name the Event, right-click on it and enter the name.

2. Double-click on the Event to bring up the properties.

3. In the Task window, choose Add > Run Script.

4. Write the following script:

Echo off

Echo PXE/BootWorks is working

Pause

5. Select the option to execute the script while in DOS (from BootWorks).

6. Choose OK. The task appears in the Tasks list. Choose OK again.

7. Assign the event to the computers whose connection you want to test.

If the connection is successful, the client computer will run the script and pause with the script
message on the screen. If the client connection did not work, you will need to check BootWorks. For
detailed information about troubleshooting BootWorks and using the BootWorks Diagnostic Utility, see
the Altiris eXpress Installation and Setup Guide.

Connect Client Computers on a Different Segment
Sometimes hubs and routers don't handle IP multicasting correctly. To solve this problem, specify the IP
address of the eXpress Server you want the computers to connect to.

Set the IP Address in Aclient.exe

If AClient has already been installed, double-click on the Altiris Client icon on the taskbar of the managed
computer to change the setting. If you are changing the settings during install, choose Advanced when the
page with the Properties tab appears.

1. Choose Properties > Transport.

2. Select Use TCP/IP to connect to the Altiris express Server.

3. Enter the server's TCP/IP address. (You don't need to change the default port setting.)

4. Choose OK to update AClient.

To make the change remotely, start the Remote Client Installer at the Console, choose Advanced, and
follow the instructions above to change the AClient settings.

AClient will update the IP address in BootWorks if it is installed locally on the client computers. If it is not
installed and you want to install it now, highlight the computer or group in the Console, right click, and
choose Advanced > Install BootWorks. Don’t install BootWorks on the clients if you are using PXE.

Connect Client Computers to a Network With Multiple
eXpress Servers
If you have multiple eXpress Servers on your network and you want client computers to connect to a
specific one, set the server name in AClient.

Set the Console Name in AClient

If the client has already been installed, double-click on the Altiris Client icon on the taskbar of the managed
computer to change the setting. If you are changing the settings during install, choose Advanced when the
page with the Properties tab appears.
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1. Choose Properties > Transport and enter the server name in the field.

2. The default option Use TCP/IP multicast to locate an Altiris eXpress Server should be selected. If
it is not, select it.

3. In the Server Name field, enter the name of the eXpress Server. (You don't need to change any of the
other settings.)

4. Choose OK to update AClient.

To make the change remotely, start the Remote Client Installer at the Console, choose Advanced, and
follow the instructions above to change the AClient settings.

AClient will update the computer name in BootWorks if it is installed locally on the client computers. If it is
not installed and you want to install it now, highlight the computer or group in the Console, right click, and
choose Advanced > Install BootWorks. Don’t install BootWorks if you are using PXE.

Manage AClient Settings
You can set up AClient properties when you install the program by choosing Advanced on the install
screen. To view or modify the settings after AClient is installed on a computer, double-click the icon in the
system tray, then choose Properties.

General Settings
If more than one user is assigned to a managed computer, you can deploy user-specific RapidInstall
Packages. Enter the user names in the field, separated by semicolons.

If you want to keep a log of operations performed on the PC, select Save log information to file. Enter a
name for the file and specify the maximum file size.

Security Settings
If you want to prevent users from accessing and modifying AClient properties, set a password on the
program. This password will be required in order to view or change settings.

You can set options to prompt users before certain commands are executed on their computers. These
are: reboot commands, commands to execute programs or copy files, and requests to control the
computer remotely.

You can select any or all of these options. The wait time applies to all of the selected options. The option to
continue with the command or abort it also applies to all of the options.

Note: The maximum wait time for remote control requests is 30 seconds. If you set a longer wait time for
the options, remote control requests will be aborted if no response is received within 30 seconds.

You can also specify what action to take if there is no user response within the wait time. To run the
command if no response is received, choose Continue. If you do not want the command to be executed,
choose Abort.

The remote control option allows you to view client activity and control input using a Console keyboard
and mouse. If this option is not selected, the client will not process remote control requests.

Transport Settings
Your managed computers can locate and connect to an eXpress Server using multicasting or by
connecting to the server's IP address.
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Note: If you make changes to these settings and you have BootWorks installed locally on the computers,
AClient will update the settings in BootWorks for you automatically. (If you are using PXE, you must
change the BootWorks settings at the PXE Server). If you do not want BootWorks transport settings
synched with AClient, you must deselect the options in the BootWorks tab. In most cases, allowing AClient
to manage these settings is best.

Managed computers can use the multicast address if they are on the same segment as the eXpress
Server and they are not using default PXE boot files.

• Use the default multicast IP address and port number if possible to avoid connection problems.
• If you have multiple eXpress Servers on the segment and you want the managed computers to

connect to a specific one, enter the Server Name.
• The TTL field specifies the number of "hops" or hubs that the client can go through to multicast.

Managed computers should use the eXpress Server IP address if they are not on the same segment as
the server, or if they are using default PXE boot files to boot computers. Use the default port number if
possible to avoid connection problems.

The connection reset time ensures that managed computers don't maintain a connection that is no longer
valid. If a client doesn't receive packets from the eXpress Server within the specified interval, it sends a
packet to determine if the server is still active. If the server does not respond, the client will disconnect and
attempt to establish a new connection.

If you change transport settings from the defaults and you start having problems with computer
connections, you can restore the settings by choosing Use Defaults.

Remote Settings
The detect slow connections option allows you to set a minimum transfer rate for running assigned
events. If a managed computer detects a transfer rate that is lower than the threshold, it will disconnect
without running the event. The event is not run until the managed computer gets a connection speed that is
greater than the minimum specified.

If the option is deselected, the computer will run assigned events regardless of the connection speed.

Advanced Settings
To force a computer to shut down or reboot regardless of whether applications are open, select the option
to forcefully close applications when rebooting or shutting down. If this option is not selected, an
event containing a reboot or shutdown task might not be completed, depending on the state of the
computer.

For example, if an application is open and it contains unsaved data, the computer might suspend the
shutdown until the user saves the data and closes the application. If an application is open and the option
is selected, the application will be closed and unsaved data will be lost.

The other options are used only for troubleshooting. In most cases, you will not need to change these
settings.

Normally, computer boot drives are automatically detected. If a computer doesn't connect to the eXpress
server, check the drive listed in the boot drive field to make sure it is correct.

The NT keyboard and mouse driver are enabled by default. If a computer is not working correctly and
you suspect that this driver is causing problems, you can deselect the option and run the computer without
the driver.
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To encrypt client communication with an eXpress Server, select the option to Encrypt Sessions with
Server. This option is not selected by default. If you select the option, the client attempts to establish a
session using encryption. If the session can't be established, the client connects without encryption. If you
select the additional option to Require Encrypted Sessions with Server, the client attempts to establish a
session using encryption, and if the session can't be established, the client doesn't connect.

BootWorks Settings
By default, AClient can now update BootWorks for you so you do not need to make configuration changes
in two places. In most cases, using this feature is recommended. If you deselect these options, you cannot
install BootWorks remotely from the Console unless you are using DHCP. Computers with static IP
addresses cannot be remotely installed because BootWorks could not get the IP address from AClient. If
you do not want AClient to synch BootWorks settings, deselect the options.

The AClient Menu
When you right-click on the AClient icon in the system tray, the following options are available:

• Shut down for imaging lets you prepare the computer for imaging while you are at the computer
(this is normally done from the Console). You will need to reboot the computer to DOS and run
ImageBlaster to upload the image. Information about running ImageBlaster is in “Ibmaster.exe and
Ibclient.exe” on page 102.

• Change name in console lets you change the name of the computer as it appears in the Console. It
does not change the Windows computer name. (The two names do not have to be the same in order
for the eXpress Server to recognize and manage the computer.)

• Remove uninstalls aclient.exe from the computer. If you use this option to uninstall the program, you
must reboot the computer afterwards.

• Exit unloads aclient.exe for the current session. When the computer is restarted, the program will
reload.

Manage Computers in Domains
Change Security IDs (SIDs)
When you image Windows NT or 2000 computers in a domain, you need to generate a unique security ID
for each one. To do this, you can use the Altiris SIDgen utility, Microsoft’s SysPrep utility, or both.

• Altiris SIDgen utility. This utility is the most thorough way to change SIDs because it searches all
registry entries and NTFS file system security permissions. Because of this, it takes longer for the
program to run (unless you choose not to check NTFS permissions).

• Microsoft SysPrep utility. This utility changes the basic SID options. SysPrep is not provided by
Altiris; you must get the utility and user information from Microsoft. The version of SysPrep that you
use must be compatible with the Windows operating system running on your client computers. For
example, if the client computers are running Windows 2000, you must use the Windows 2000
SysPrep utility.

• Both utilities. Use both utilities if you want to use SysPrep to change the basic SID options and SID-
gen to make in-depth changes.

Warning: We recommend that you don't generate a new SID for your production Primary Domain
Controller (PDC). If you generate a new SID, you will have to re-synchronize all of the computers in the
domain.

SIDgen backs up the computer registry and then generates a unique SID for the computer. It searches all
registry hives and replaces applicable entries with the new SID. It also replaces any affected NTFS file
system security permissions (unless you choose not to check them).
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SIDgen uses the NT/2000 System Account to make security ID changes. It needs all rights to this account.
If you have limited the rights on this account, SIDgen will not work.

Hint: If you want to know for sure that a new SID was generated, write down the existing SID before
running SIDgen, and then check the number again after you have run the utility. To learn how to view SIDs,
see “View Security IDs (SIDs)” on page 20.

Options for Loading a SID utility on your Client Computers
To run SIDgen or SysPrep, you must copy the utility to the client computers. You can either include it in an
image or copy it to the computers using the Copy File to Computers icon on the Console toolbar. To
determine the best option for you, consider how often you will need to change SIDs.

• Install SIDgen/SysPrep with AClient if you want to change the SID every time you image the
computer and apply configuration changes. (If you want to include it in an image but you don’t want to
run the utility every time you run the imaging Event, you will have to use ImageExplorer to modify the
image file after you have run the Event the first time.)

• Use Copy File to Computers on the Console to copy the utility to the computers. Once the SID utility
is on the computers, it can be run as needed using a simple script file.

Running Windows 2000 Sysprep
The Windows 2000 SysPrep utility requires the CD key for Windows 2000 when it runs on your client
computers. To provide this information automatically when an image is deployed, create a text file called
sysprep.w2k and put the 25-digit CD key in the first line (including the dashes). Place this file in the
eXpress directory and the server will enter the CD key automatically.

Memory Requirements for SIDgen
Since SIDgen backs up the computer registry to memory, your Maximum Registry Size setting must be set
to at least twice the size of the actual registry.

Check the Memory Settings
1. Right-click on My Computer and choose Properties from the menu.

2. For Windows NT, choose the Performance tab. For Windows 2000, choose Advanced > Perfor-
mance Options.

3. In the Virtual Memory box, choose Change.

4. In the Registry Size box, make sure the Maximum Registry Size is at least double the number of
the Current Registry Size.

How and When to Run a SID utility
Follow the applicable instructions for changing SIDs. To decide which method is best for you, see
“Scenarios for Generating Security IDs (SIDs)” on page 20.

Change a SID Every Time You Image a Computer
1. When you install aclient.exe on the computer, select Enable Changing of Security ID on the Altiris

Client install screen.

2. Choose the utility you want to use to make SID changes.

3. If you are using SIDgen and you don’t want to check NTFS permissions, deselect the box.

Note: if permissions are not checked, file restrictions set on the local computer will not be carried
forward. Access rights will have to be reset manually.

4. Enter the path to the utility you want to use. (SIDgen is in your eXpress directory).
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5. Choose Next to finish the install. Aclient.exe and the SID utility are copied to the directory you speci-
fied on the client computer.

Note: The SID utility will run on the computer each time the image is deployed. Each time the utility is
run, you should back up the registry files to save the configuration changes.

Change a SID on an as Needed Basis
When you want to change a SID, you can create a simple script file to run on a computer or a group of
computers.

1. Click on the New Event icon at the Console.

2. On the Event Properties screen, select Add > Run Script.

3. On the Script Task Properties screen, choose Run script.

4. Type in the commands. Here is an example of a simple script for running SIDgen:

start c:\altiris\sidgen.exe /start

5. Select the option to run the script from Windows.

6. Choose OK.

7. Drag the Event to the computer.

8. Choose OK to schedule the Event.

For information about how to view SIDs, see “View Security IDs (SIDs)” on page 20.

For a list of SIDgen command-line parameters, see “Appendix A: Command-Line” on page 85.

Run SIDgen From the Command Line
1. Boot the Windows NT or 2000 computer whose SID you want to regenerate.

2. Log in to the computer as Local Administrator (or equivalent user).

3. Run sidgen.exe and enter the information requested on the screens.

View Security IDs (SIDs)
View the current SID on a Windows NT or 2000 computer using the REGEDIT program as follows:

1. Log in as the Local Administrator on the computer you want to check.

2. Choose Start > Run and type regedit.

3. Select the HKEY_USERS folder to view a list of the contents. A list of folders appears.

4. You will see a folder with a long list of numbers next to it (Windows 2000 users will see two folders
with identical numbers). This number is your SID.

For information about how to change SIDs, see “Change Security IDs (SIDs)” on page 18.

Scenarios for Generating Security IDs (SIDs)
These examples show you how to generate SIDs in various circumstances.

Scenario 1: Non-Domain NT Servers or Workstations
If you are changing the SID of only Windows NT or 2000 workstations that are not installed into any
domains, you can simply run the utility on the workstation, ignoring the -data parameter involving the
synchronization file. In this case, you will not need to synchronize anything with these workstations.

Scenario 2: One PDC and Multiple Domain Members (No BDCs)
When you have a Primary Domain Controller and numerous computers booted into the domain, follow one
of these sets of steps:
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• If you are running the eXpress Server on a Win NT/2000 machine with access to the domain server,
and you have rights to create machine accounts on the primary domain controller (PDC), the eXpress
Server will manage SIDs in the domain for you. Follow the steps in Set A.

• If one of these criteria is not met, the eXpress Server cannot manage the domain for you, so you will
have to enter the information manually. Follow the steps in Set B.

Set A

1. Install Windows NT on one workstation that is logged in to the domain.

2. Install SIDgen on this workstation. (Run sidgen /name /install).

3. Image this workstation to all other workstations.

4. Boot all imaged workstations. They should launch SIDgen to change their SIDs. You are prompted for
the computer name on each computer. When complete, the computers should reboot and connect
into the domain normally.

Set B

1. Create a computer entry in the domain database for one workstation.

2. Install Windows NT on one workstation, logged into the domain.

3. Install SIDgen on this workstation (run sidgen /name /install).

4. Image this workstation to all other workstations.

5. From the PDC, remove the workstation’s domain database entry, and then add all the computer
names that will be specified in Step 6.

6. Boot all imaged workstations. They should launch SIDgen to change their SIDs. You are prompted for
the computer name on each computer. When complete, the computers should reboot and connect
into the domain normally.

Scenario 3: Synchronizing Multiple PDCs and/or BDCs
Suppose you have multiple Primary Domain Controllers and one or more Backup Domain Controllers (as
well as numerous computers installed into the domain) that have all received an image. You may change
the SIDs of all of these computers by following these steps:

1. Create a synchronization file in a network shared location or on a floppy disk by running SIDgen on
the PDC. (For example, type sidgen /data:a:\pdc.dat).

2. Once the PDC’s SID has been changed, run SIDgen on the BDCs, using the synchronization file that
you created in Step 1.

3. The utility detects whether to read or write this file based on the role of the computer.

4. To change all occurrences of the old domain, run SIDgen on all workstations installed into the domain,
specifying the same synchronization file created in Step 1.

5. If your system does not meet the criteria specified in Scenario 2, go to the PDC and remove and re-
add any domain members whose SIDs have been replaced. You can also add the /name parameter to
any of these steps to change the computer names of these computers during the process.
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Getting to Know the Console

How Do I Work with the Console?
The Console has an “explorer look and feel. It gives you access to all the tools, utilities, resources, files,
Events, and tasks you need to manage your computers. The Console is divided into several sections or
areas that contain different kinds of information. What you see and what you can do depends on which
area of the Console you have selected. Because the Console behaves like an explorer program, you can
use drag and drop and size different areas to suit your needs.

Computers Area
• When a group is highlighted, the Details window shows a list of computers in the group and gives

basic information about each computer. Also, the Filter details bar appears, which lets you view
computers by certain criteria you set.

• When a computer is highlighted, you see a gray box showing computer status, also a list of the events
run (or scheduled to run) on the computer and the status of each Event. To clear old information from
the computer status box and display an updated status, choose Edit > Clear Status.

• Computers might have different colored icons next to them. See “What Do the Computer and Event
Icons Mean?” on page 24 for more information.

Events Area
The Events Area contains several kinds of Event templates:

• Initial Deployment Event Use this template when you expect a large shipment of computers and
you want to deploy them by department or group. You can set up configuration and task sets that
apply to groups of workers. See “Deploy New Computers by Department” on page 51 for more
information.

• Drag-n-Drop Events - When you create an Event by dragging a resource to a computer (or vice
versa), an Event is created for that action and placed in a Drag-n-Drop folder.

• Restoration Events - If you restore a computer using the icon in the toolbar, an Event is created for
you and placed in a Restoration Events folder.

When an Event is highlighted, the following is displayed in the Details area:

• A description of the Event (if you enter one when you name the Event).
• A button that allows you to add conditions to the event.
• A list of tasks included in the Event, with task descriptions (if you enter them), and arrow buttons that

let you order when tasks are run.
• Buttons to add tasks to the Event, or edit and remove tasks.
• A list of computers that have run (or are scheduled to run) the Event, and the status of the Event as it

relates to the computer.

Details Area
Detail bars provide information and, in several cases, access to features and options. Selecting
Computers, Shortcuts, or Events changes the information in the Details area on the right side of the
Console. For example, the Detail bar for an Event shows the tasks and conditions in that Event and also
gives you access to features that help you modify the Event. The Detail bar appears in the upper right of
the Console. Detail bars are available for the following:
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• Events details bar displays information about the Event plus lets you set up conditions, order tasks,
add new tasks, edit or remove tasks).

• Computers get information about a computer, including IP address, MAC address, and status.
• Batch files get information about the batch file and click the Edit button to launch a text editor.
• Image files view a description of the image file (for example, Windows NT4 with Service Pack 5,

and computer hardware manufacturer), plus information about the included partitions.
• Filters click on a computer group to display the Filter details bar, which lets you create, edit, or

delete filters. The computers that match the criteria you specify in the filter display below.
• Packages see the title, description, version, creation date, and platform of a RIP or Personality

Package.

Shortcuts and Resources Area
If you like using Shortcuts in Windows, you’ll enjoy using this feature to organize the resources you use
most often.

To open a window, choose View > Shortcuts. Drag and drop the items you use most into the window. To
delete a Shortcut, just select it, right-click, and choose Remove from shortcut bar. You control your
Shortcuts because they are stored by your username. This means your Shortcuts will stay just the way you
want them, even if you share the Console with other administrators.

When you use the Shortcuts view, you can also see a list of Resources by clicking the Resources button in
the Shortcuts view. This includes all executables, images, RapidInstall Packages, Personality Packages,
scripts, batch files, etc. saved in the product directory. This gives you easy access to everything you might
want to include in Events as you define them. Or, to quickly deploy one of the files, all you have to do is
drag it to a computer or a group, and an Event is created under the Drag-n-Drop Event group and is run
immediately.

Drag and Drop
Most of the time you can organize your Console simply by dragging a resource where you want it to go.
You can move computers to or from groups as you like.

Keeping Track of Events
It is best to name events to keep them organized. However, if you don’t name them and you have a long
list of numbered events named Event X, where X is a number, you can still tell them apart by looking at
their details. Each Event has a list of the tasks included and information about the computers where it has
run or is scheduled to run.

Sorting the Details
To sort Event or computer details, just point and click on the category in the Details bar. For example, to
sort computers by status, choose Status from the heading.

What are Events?
Events are sets of specific tasks you want to execute on managed computers, such as creating images,
deploying computers, changing a configuration, or installing software. Events are flexible; They’re made up
of whatever tasks you decide to include. Once an Event is created, you can change it easily by adding,
modifying, or deleting tasks. Events can be run immediately, scheduled to run a particular time, or saved
for a later time.

You can set conditions on Events so that they will run only on computers that match the criteria you specify.
See “Define Conditions for Events” on page 36 for more information.
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The New Event Wizard lets you select from among five of the most commonly used Events and guides you
through the entire creation process.

To learn how to create and edit Events without the New Event Wizard and add or delete tasks in an Event,
see “Create and Edit Events” on page 34.

The Initial Deployment Event is a special kind of Event that you use on new computers. See “Deploy New
Computers by Department” on page 51 for more information.

What Do the Computer and Event Icons Mean?
The Computers List
The colored icons in the Computers list indicate the status of computers:

Table 1: Computers list icons

Icon Description

A blue screen means the computer is connected to the Server.

A blue screen with a user means the computer is connected to the Server and a user is
logged in.

A clock on the computer icon indicates that the computer has a time-limited user
license.

A gray screen means the computer is not currently connected to the Server, but is
known to the database.

A yellow screen means the computer is a virtual computer, which you defined. As soon
as the computer connects, the icon turns blue.
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The Events List
When an Event is highlighted, you see the status of computers that have run (or are scheduled to run) the
Event in the Details window. The icon color indicates the status of the Event on a particular computer:

Where Are My Images?
When you create image files and store them in the product directory, they appear in the Console in sev-
eral places, depending on how you want to use them. You can see a list of image files and other file
types (registry, data, executable, etc.) in the Resources list in the Shortcut window. At the Console,
you’ll also see image files listed as tasks when you highlight an Event.

View Your Images
• Choose View > Shortcuts, click the Resources button at the bottom, and then double-click the folder

that contains your images.
or

• Choose View > Resources to display the folders in the Details view. Double-click the folder that con-
tains your images.

Note: If images are stored on a separate file server, they do not appear in the Resources list.

Table 2: Computers list icons

Icon Description

A green icon means the Event was run successfully.

A blue icon means the Event is running (in progress). Notes: Sometimes the Event was
initiated but the computer might fail or experience a power failure. In this case it is
unknown if the Event was actually completed, but the icon is still blue.

A yellow icon means the Event is scheduled.

A red icon means the Event terminated because an error occurred or because a RIP
was not valid for a computer.

A white icon means the computer is not scheduled for this Event (it has only been
saved).
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How Do I Run an Event?
You can run Events in several different ways. All Events can include conditions so that they run only on
computers that match specific criteria that you specify. See “Define Conditions for Events” on page 36 for
more information.

Run an Event in the Events Window
1. Drag the Event you want to run to a computer or group, or (vice versa) drag the computer or group to the Event.

2. In the Schedule Event window, choose one of the following:

• Choose Schedule this event and enter the date, time, and frequency.
• Choose Run this event immediately to run it now.

Create and Run an Event on the Fly
If you have a batch file, image, or executable in your Resources list (in the Shortcuts view), running an
Event is simple. Just drag the file to the group or computer where you want it to run. To run the file on
multiple computers, use the Ctrl key to select them and then drag them onto the file in the Resources list.
Select Run this event immediately (the default) and choose OK.

The Event will run immediately, and a New Event will be automatically created in the Drag-n-Drop Events
folder.

Create and Run an Event Using the New Event Tool
1. Choose the New Event icon on the toolbar to create a new Event in the Events list.

2. Double-click the New Event that appears in the Events list.

3. Enter a name or accept the default. Choose Add, and select the type of task you want to run.

4. If necessary, choose the folder icon and browse for the file you want, then choose Open.

5. Select another task from the list.

6. When the tasks you want are all listed, choose OK to finish.

7. Drag the Event to the computer or group where you want it to run, or drag the computers to the Event.

8. Choose Run this event immediately, and then choose OK.

Create, Edit, and Use Filters
Filtering is a way of listing and viewing computers in the Console according to specific criteria. For
example, suppose you want to view all computers in a particular group that have Windows ME, 128M of
RAM, and 4 GB Hard disks. By applying a filter using these criteria, only those computers will be listed (by
computer name) in the Details area. The filters you create are shown in the Filter bar, in a drop-down list,
when you highlight a group of computers.

Create a Filter
1. Click the All Computers group or click a particular group of computers.

2. On the Filter bar, click Options > New.

3. Type a name for the filter, and then click Add.

4. Define the conditions you want in the filter. For example, you might choose Computer Name as the
Field, Contains as the Operation, and Sales as the Value. You can use wildcards, AND/OR operators
in the Value field. Choose OK.

5. Repeat Step 4 to include other conditions.

6. Choosing OK puts the filter into effect.
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View Computers by Filtering
1. Click the All Computers group or click a particular group of computers.

2. Select a filter you created earlier.

The computers that match the criteria in the filter are displayed.

Create a Group of Computers Using Filters
1. Click the All Computers group or click a particular group of computers.

2. Select a filter you created earlier.

3. Drag the outcome into a group.

Edit or Delete a Filter
1. Click the All Computers group or click a particular group of computers.

2. On the Filter bar, select the name of a filter from the drop-down list. Click Options > Edit

or

Click Options > Edit to change the filter.

Change Program Options
Use the Program Options dialog box to set how often the Console display is updated, set general program
options that apply to all managed computers and Consoles, and give users access to the Console.

To display the Program Options dialog box, choose View > Options.

Console Tab

Table 3: Console Tab Options Descriptions

Option Description

Scan resource files for changes
every n seconds.

Specifies how frequently (in seconds) the Console resource file is checked for updates
and the Console display is updated. This setting applies only to the current Console.
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Global Tab

Security Tab

Give a User Access to the Console
1. Choose Add, enter the user name, full name, and a password for the person to be added to the

Console user list, and choose OK.

2. Select Require individual user authentication when starting console. If this option is not selected,
the Console can be accessed with no login prompt (regardless of who is listed as a user), so it is
unsecured.

Choose Properties to see login properties of users on the list.

Choose Remove to remove access rights from a user, select the user name from the list and

Table 4: Global Tab Option Descriptions

Option Description

Delete history entries older than n days Select this option to specify the number of days an entry is kept in the history until
it is deleted. If the number of days is set to 0, no entries will be kept in the history.
If this option is not selected, log entries will remain in the history until manually
deleted.

Synchronize names for computers in
database with Windows computer names

Select this option to automatically update managed computer names used by the
Console when the managed computer name changes. If this option is not
selected, changes to managed computer names will not be reflected in the
Console. Synchronization is off by default. (The names do not have to be
synchronized for the eXpress Server to manage the computer.)

Reschedule failed image deployment
events to immediately retry the failed task

Select this option to immediately retry a failed image deployment Event. The
program will continue to retry until the Event succeeds or until the Event is
canceled.

Group disk imaging multicast sessions
based on which server the computers are
connected to

Select this option to allow managed computers to form groups during
multicasting. For this to work, all computers in the group must have direct access
to the same eXpress Server. That is, there should be no network devices in
between the eXpress Server, imaging master, and other computers that do not
support multicasting. This allows a single imaging Event to be multicast to a
group of managed computers, regardless of whether the managed computers
have direct access to the same eXpress Server or not.

Automatically install BootWorks (DOS)
clients as necessary

Select this option to automatically install BootWorks on a managed computer that
does not have BootWorks installed. BootWorks will be installed in the client’s
production partition.

Primary lookup key Specifies the lookup key type used to identify a managed computer. The options
are Serial Number (SMBIOS), Asset Tag (SMBIOS), UUID (SMBIOS), or MAC
Address.
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Explore and Edit Image Files
ImageExplorer is a Windows application that saves you time by letting view the contents of an Altiris image
file (*.img) and make changes to without recreating the image. You can:

• Modify or update existing files in the image
• Exclude and include files in the image
• View information about partitions and files contained within an image file
• Search for files in the image

View and Change an Image File
1. Choose Tools > ImageExplorer or choose the ImageExplorer icon on the toolbar.

2. Choose Open on the ImageExplorer toolbar and select the image file you want to modify.

3. Use an ImageExplorer feature:

View and Edit Properties
ImageExplorer stores property information for the objects contained within an image file. These properties
can be viewed and in some cases modified.

• To view image properties, choose File > Properties. Image File Properties displays the description of
the image file. This information cannot be edited.

• To view a partition’s properties, right-click the partition and choose Properties. You can view the
partition slot used by this partition, the file system type, and attribute information about the selected
partition. This information cannot be edited.

• To view a folder’s properties, right-click the folder and choose Properties. You can view the complete
base path that this folder is placed in when the image is downloaded to a computer. This information
cannot be edited.

• To view or edit a file, right-click on the file and choose Properties. File Properties displays the file-
name and location (folder) of the selected file, and attribute information for the file. You can edit
attribute information.

Modify a File in an Image
If the files contained in an image are associated with a text editor such as Notepad, you can modify them
by right-clicking the file and choosing Edit.

If the file isn’t associated with a text editor, you can change it by using the Extract and Replace icons on
the toolbar.

Extract a File
Extracting a file from an image makes a copy of the file in a location that you specify. You can then view
and edit this file just like any other file. After you modify the file, you can load it back into the image using
the Replace feature.

Replace a File
The Replace feature lets you replace an existing file with a file of the same name.

Note: The replaced file must already exist in the image file and can only be replaced with a file of the same
name. In other words, you can only modify existing files within the image. You cannot delete or add files;
however, you can exclude or include files.
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Exclude and Include Files
By default, all listed files are included in the imaging download process. By selecting any file or group of
files and clicking Exclude, the filenames are highlighted in blue and are ignored during the current imaging
process. When you want the files included again, select the appropriate filenames and click the Include
button to make them a part of the imaging process.

Search for a File
You can search for files within an image using specific names or wildcards. Search options include the
following wildcards:

? Represents a single character

* Represents any number of characters

Example: Searching for TEST* in an image finds all files beginning with the letters TEST. Note that
searches are limited to a single wildcard (*). No results will be returned if multiple wildcards are used.
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Using the New Event Wizard

The New Event Wizard guides you through the process of defining and scheduling events. All you have to
do is make selections from the choices you are given.

Select an Event
1. Choose File > New > Event or click the New Event Wizard icon on the toolbar.

2. Select the kind of Event you want to create.

Create an image. Create an image that you want to use for computers in your system. It can be used
to restore a computer to its original settings (in case of corruption or other problems), or to deploy a
standard image to the computers in a group or system.

Deploy and configure computers. Create an Event by providing a path to an image you want to
deploy, provide unique network configuration information, then assign it to computers, and specify a
time for it to execute.

Deploy software packages. Distribute software packages to managed computers. Use this option to
distribute and install software. You can use this option for Altiris RIPs and Personality Packages or
other setup programs.

Restore a computer. Restore a computer to a known working state by reapplying items (such as a
software package, registry, or image) that were previously deployed. These are selected from the
computer’s history, which contains all actions previously processed.

Back up Registry files. Save a computer’s registry files in known working states so they can be
easily accessed and remotely restored when you need them.

3. Give it a unique name (optional), so you can distinguish it from other Events.

Save a Disk Image to a File
Use the Save Disk Image to File dialog box when defining an Event to specify what should happen to an
image after a computer has been imaged.

1. To access the Save Disk Image to File dialog box, right-click an Event, choose Properties, click Add,
and choose Create Disk Image, or create an Event using the New Event Wizard.

2. Enter the path where you want to store the image by typing it in or browsing.

You can store image files in the shared product directory, or on a file server so computers can access
them when they are assigned an Event that includes an image file.

The default filename extension is .img. Saving image files with an .exe extension makes them self-
extracting executable files.

3. Check Local image store if you want to store the image locally on the client computer’s hard disk
(instead of a file serve). Be sure to enter the path relative to the computer (for example, c:\myim-
age.img).

4. Enter a description to help you remember what is on the image and to distinguish it from other stored
images.

5. The name of the new image Event appears in the Events list on the Console.
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Disk Image Creation Options
Media Spanning
The maximum image file size supported is 2 GB. To save an image larger than 2 GB, you must break it into
separate files, regardless of your storage capacity.

From the Maximum file size list, choose a media type that you want to save the image on. If it is not on
the list, enter the file size you want in the Specify MB field.

Other Options
Compressing an image is a trade-off between size and speed. Uncompressed images are faster to create,
but they use more disk space.

Choose Size to compress the image to the smallest file size. (This is the default.)

Choose Speed to create a larger compressed image file with a faster imaging time.

For a list of valid command-line switches, see “Appendix A: Command-Line” on page 85.

Schedule an Event
When Do You Want the Event to Run?
• If you don’t want to use or schedule the Event now, choose Store this event.
• If you want to run the Event now, choose Run this event immediately.
• If you want to run the event at a specific time, choose Schedule this event and enter the start date

and time by typing it in or by browsing.
• If you want the Event to run at regularly scheduled times, choose Repeat this event and choose a

frequency.
• If you want to delay the event to allow other processes, which might interfere with the event, to finish

running, select Allow this event to be deferred for up to and enter a time frame.

Choose Finish. The new Event appears on the Events list on the Console.

Select a Source File or Image
• If you are creating an image, select the computer whose disk you want to image. The source

computer should have the operating system, applications, and data files that you want to deploy to
your target computers.

• If you are restoring a client computer, select the computer you want to restore from the list. You can
only restore only one computer at a time.

• If you are backing up registry files, select the computer or group of computers that you want to back
up.

Restore Options
1. From the list of previously processed tasks, select one or more tasks you want to deploy to restore the

computer.

2. To view only specific types of tasks, choose Show only and select the type you want from the list.

3. To limit the list to tasks that have occurred since a specific date, select Since and choose a date from
the calendar.

The list of items that can be restored is determined by what is in the history file. See “Change Program
Options” on page 27 for information about the Delete history entries older than XX days option.
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Registry Files Storage Location
The Registry Files Storage Location dialog box shows the location where registry files will be stored when
the Backup Registry Event runs. The computers whose registry files have already had their registry files
stored in this location appear in the list below.

1. Choose OK if this is the location of where you want to store registry files.

2. If Windows was installed on computers in a directory other than the default, choose Advanced and
enter the correct path to the registry files so that they can be found and properly backed up.

Select a Disk Image Source
1. Select the location of the image to include in the Event. You can use a stored file, or you can make a

current image of a computer hard disk.

2. Choose Use image file to select a stored, static file. This is the more common approach.

3. Select Local image store if you stored the image you want to use on the computer’s hard drive
instead of a file server.

The less common approach is to choose Use a computer on the network, which makes an image of a
computer in its current state each time the Event executes. If you revise this Event, the image will refer to
the computer every time it is run, so the image will be dynamic.

If you use a computer as the image source, you can also choose to save the image to a file for later use.
Check the box to save the image and type in or browse for the location where you want to store the file.

Select Computers
1. Select the computers to which you want to apply this Event.

2. Choose Do not apply this event to any computers at this time if you want to store this Event for
later use.

3. Choose Assign this event to one or more computers and then highlight the computers you want to
include. Or, if the computers don’t exist yet, use the New Computers option to add new accounts.

Add Packages
If you have created RapidInstall Packages (RIPs), Personality Packages, or other software packages
(such as setup files), you can include them with an Event and have them execute when the Event is run.

Choose package from the current list. Or, if the package you want is not on the list, choose Add and
browse for the file, then choose Open to add it to the list. To make sure you are viewing package files,
choose Software Packages (.exe) from the Files of type option.

Highlight the package you want to use. If a password was applied to the package, or if you want to specify
users to associate with the package, choose Options and enter the required information. If these
conditions do not apply, choose Next to continue.

To learn more about creating and deploying RIPs and Personality Packages, see “Include RapidInstall
(RIP) and Personality Packages” on page 34 and “Deploy Software Packages” on page 38.

Event Summary
1. Review the options you’ve chosen for the new Event.

2. Choose Next to schedule the Event or save it for later use.

3. Choose Finish to execute the Event immediately.

The name of the new Event appears in the Events window on the Console.
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Creating, Editing, and Running Events

Include RapidInstall (RIP) and Personality Packages
While you can launch RapidInstall or PC Transplant from the Console and edit an existing RIP or
Personality Package, you should not create packages on the Console computer. Because RapidInstall and
PC Transplant capture settings on a lightly configured computer with a fresh operating system installed,
you should create them on a different computer than the Console.

Create a RIP or Personality Package
1. Go to the computer where you want to create the package.

2. Browse to the shared eXpress product installation directory and run rinstall.exe or pctransp.exe on the
computer.

3. Follow the instructions under the “Include RapidInstall (RIP) and Personality Packages” on page 34.

4. Now you can add the package to any Event or deploy it on the fly from the Console by dragging if from
the Resources view onto a computer or group of computers.

Edit an Existing RIP or Personality Package from the Console
1. Click Tools > RapidInstall Editor or PC Transplant Editor or click the appropriate icon on the

toolbar, click File > Open in the editor, browse for the package filename, and choose OK.
or
Click Resources in the Shortcut view, browse for a package, right-click it, and choose Edit to launch
the appropriate editor.

2. Follow the instructions under the “Include RapidInstall (RIP) and Personality Packages” on page 34.

To learn about deploying packages, see “Deploy Software Packages” on page 38.

Create and Edit Events
Use the Event Properties dialog box to create a new Event or edit an existing Event. If you know what you
want to do, using Event Properties is often a quicker way of creating Events when compared to the New
Event Wizard (see “Using the New Event Wizard” on page 31 for more information). You can reorder tasks
in Event (cause them to run in a particular sequence) and apply conditions to Events (cause them to run on
computers that match specific criteria that you specify).

Create or Edit an Event
1. Double-click an existing Event.

or
Click the New Event tool on the toolbar or right-click a folder in the Event window in the Console to
create a new Event entry

2. (Optional) Assign a unique Name to the Event so you can distinguish it from other events.

3. (Optional) Enter a Description of the Event to help you remember what it is.

4. Set any conditions you want to apply to this Event. You can also order conditions.

5. Choose Add to add new tasks to the Event. You can choose from the following tasks:

• Create or distribute an image (to upgrade a computer from Windows 98 to Windows 2000).
• Distribute a RapidInstall Package (to deploy a service pack, application, or a printer setting).
• Distribute a Personality Package (to migrate a computer’s personality, including unique user data

and settings, etc.).
• Change configurations (computer name, IP address, user name, and other network information).
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• Back up or restore registry files (to recover from a hard disk crash or other disaster, protect vital
settings on a computer).

• Run a script (to perform certain specific tasks on a computer).
• Copy a file (when e-mail is down or when speed and convenience are an issue).
• Reboot, shut down (and power off if available), suspend, or log off a computer.

6. Highlight a task and choose Edit to change a task’s properties (for example, add a password to a RIP,
or add command line switches to a Personality Package).

7. Highlight a task and choose Remove to delete a task from the Event. See also “Add, Edit, or Remove
Tasks in Events” on page 35.

8. Use the arrow buttons above Add to change the order of tasks in the Event.

Important! Tasks are run in the order they appear in the Event task list. If you will be deploying an
image, this task should be run first, otherwise it will overwrite RIPs, Personality Packages, and other
tasks may have already executed on the computer.

9. If you are modifying the Initial Deployment Event, you can choose the Start Options button to spec-
ify when you want the Event to run:

• Run the Initial Deployment Event on each computer when it first connects to the eXpress Server.
• Run the Initial Deployment Event after a specified number of new computers are connected, or

when a time period you specify has elapsed.
• Run the Initial Deployment Event on all new computers at a specified time.

The Event is added to the Events list. To run it, drag the Event to the computer or group where you want it
to run, or drag the computers to the Event and choose when you want to run it.

Add, Edit, or Remove Tasks in Events
When you modify the tasks in an Event, any computers already scheduled to run the Event will run the
modified one. If you want tasks to still run the original Event, leave the Event unchanged and create a new
Event with the task changes you want, instead of modifying the existing Event. Changing the files in the
tasks will still change the Event.

Add a Task to an Event on the Fly
If the task (image, batch file, executable, etc.) is saved in the product directory, it appears on your
Resources list in the Shortcuts window. Simply drag it to an existing Event and it will be added.

Add a Task by Editing the Event
1. Highlight the Event you want to change in the Events window.

2. Choose Add in the task box (upper right corner).

3. Choose the type of task you want to add and follow the prompts.

4. The new task appears in the list.

Edit a Task in an Event
1. Highlight the Event you want to change in the Events window.

2. Select the task you want to change from the list in the upper right corner.

3. Choose Edit and follow the prompts to make your changes.

Remove a Task from an Event
1. Highlight the Event you want to change in the Events window.

2. Select the task you want to remove from the list in the upper right corner.

3. Choose Remove.
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Package Properties
The Package Properties dialog box lets you choose the RapidInstall Package (RIP), Personality Package,
or other package (such as a setup file) that you want to include in an Event. It also helps you identify valid
Altiris packages and assign passwords and command-line switches to packages.

1. Enter the name of the package you want to distribute, or choose the folder icon (if available) to
browse and select the package from a list

Note: Information about the package will be displayed in the Description area for valid packages. If
no description is displayed, then the file is not a RIP or a Personality Package.

2. For RIPs, if you set the password option when you created the RIP, you must enter the password in
order for the package to run. If no password was assigned, leave the field blank.

3. Specify the users to associate with the package.

• Check Apply to all users on client to run the package on all computers.
• If you are running the package on a computer that has multiple users defined in aclient.exe,

deselect Apply to all users on client. Then, in the Additional command-line parameters field,
enter χυ followed by the usernames you want to apply the RIP to. To specify more than one
user, separate the names with semicolons.

4. Choose OK. The package appears in the list of tasks associated with the Event.

Note: When a Personality Package is executed through eXpress, the quiet mode command-line switch is
applied. This means the user will not be able to interact with the user interface on the managed computer.
If the Personality Package will run only if a particular user is logged in, and the user has an account on the
managed computer, the package will run the next time that user logs in. If the user does not have an
account, the package aborts and sends an error back to the Console via the Altiris Windows Client. If the
package is not run through eXpress, a message is displayed on the managed computer and the user is
prompted to abort or continue.

To learn more about creating and deploying RIPs and Personality Packages, see “Include RapidInstall
(RIP) and Personality Packages” on page 34 and “Deploy Software Packages” on page 38.

Rename an Event
To rename an Event, right-click the Event and choose Rename (or press F2), then enter the new name.

• Computers scheduled to run the Event are not affected by the name change. The new name will
appear in the computer details window and the Event will run as scheduled.

• The old Event name will also appear in the computer history.

Define Conditions for Events
Setting conditions on the tasks in an Event lets you intelligently apply changes to a computer or group of
computers that match certain criteria that you designate.

For example, suppose you want to apply a RIP or Personality Package to all computers in a particular
group that have Windows Me, 128M of RAM, and 4 GB hard disks. If any computers match those criteria,
the package will be applied to them and them only.

The following instructions apply to the Define Conditions dialog box, which appears when setting up an
Event when using the New Event Wizard or when modifying an Event’s properties.

Define Conditions While Using the New Event Wizard
1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose either Deploy and configure computers or Deploy software packages. Click Next.
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3. Choose Setup conditions for this set of tasks and click Next.

4. Type a name for the condition.

5. Define the general conditions you want.

For example, you might choose Windows 2000 for the operating system, 500MHz for the processor
speed, or 256MB of RAM.

6. Click Other to define more detailed conditions.

For example, you might want the task applied to computers that match a particular asset tag, Altiris
client version, IP address, etc. You can apply wildcard characters, or AND/OR operators. There are
dozens of criteria to choose from.

7. Choosing OK puts the condition in effect.

The conditions you create are shown in the Condition drop down list. You can edit or delete existing
conditions.

Define Conditions When Creating or Editing Event Properties
1. Right-click the Drag-n-Drop or Restoration Events folder.

or
Right-click an Event, choose Properties.

2. Click the Options button in the Event Details bar, and choose New.

3. Create the condition as if you were using the New Event Wizard.

Order Condition Sets
By specifying sets of conditions, and ordering the individual conditions within those sets, you can
intelligently automate the management of your computers. Each condition set is processed in order until
the computer matches the condition items defined within a set. If the computer does not meet any of the
defined conditions, it will run the default condition. Once a match is found, the set of tasks for this condition
set is processed.

For example, suppose that you need to deploy a service pack to all managed computers having 32MB,
64MB, or 128MB of RAM. You don’t want to deploy the service pack to computers with any other amount of
RAM. If there are no computers that have 32MB of RAM, then you want eXpress to find and deploy to the
ones that have 64MB of RAM. If there aren’t any of those, then you would like to find and deploy to the
128MB computers. If those don’t exist, then the Event will not run and the service pack will not be
deployed.

To edit a condition, highlight it and choose Edit.

To remove a condition, highlight it and choose Remove.

To reorder a condition, highlight it and click the Up or Down button.

Schedule, Reschedule, or Cancel an Event
Schedule an Event to Run Immediately
1. Drag the Event to the computer or group where you assigned it to run.

2. In the Schedule Event window, select Run this event immediately and choose OK.

Schedule an Event that has Been Stored
1. Drag the Event to the computer or Group where you assigned it to run.

2. In the Schedule Event window, select Schedule this event and enter the date and time you want the
Event to run. To run it regularly, specify the interval (daily, weekly, etc.).
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Reschedule When an Event will run on a Specific Computer
1. Highlight the Event.

2. Select the computers you want rescheduled.

3. Right-click and choose Reschedule from the menu.

Cancel a Scheduled Event
1. Drag the Event onto the computer or group.

2. Select Do not schedule to remove the Event from the computer.

Deploy Software Packages
You can deploy RIPs, Personality Packages, or any other software package (such as a setup file) by
simply dragging them from the Resources view to a computer or group of computers. You can also select
computers and drag them onto a package. Doing this creates a new Event in the Drag-n-Drop folder in the
Events list. If you save Personality Packages in the PC Transplant product folder or RIPs in the
RapidInstall product folder, you will need to move them to the appropriate folder under the eXpress folder
before eXpress will see them.

To include packages in scheduled events, just include them in the RapidInstall and PC Transplant
Packages screen when you are defining the Event. Instructions for how to do this are included in Help
topics for events where packages can be included, such as deploying an image, computer, printer, etc.

To add a package to an existing Event, just drag it from the Resources list (in the Shortcuts window) to the
Event icon. It will appear in the list of tasks associated with that Event.

Note: If you are deploying an older RIP through the Console, you might want to check if the RIP still works.
RapidInstall comes with a RIP updater to upgrade old RIPs with the latest options and features.

To learn more about creating and deploying RIPs, see “Create and Edit Events” on page 34 and “Include
RapidInstall (RIP) and Personality Packages” on page 34.

Store Images on a Local Hard Drive
When you store an image locally on a computer instead of a file server (formerly called course caching),
you save server disk space and decrease network traffic. If you are imaging many computers, or if you
image computers frequently, the advantage of storing images locally is easy to see.

When imaging computers where labs are cached, do not use the option to remove the BootWorks partition
unless you want to clear the lab from the computer. See “Image Deployment Options - Additional Options”
on page 64.

Prerequisite: A BootWorks partition installed on the computer hard disk, with enough disk space to hold
the images you want to cache. (You cannot store images locally with Embedded BootWorks.)

Run a Script During an Event
Use the Script Task Properties dialog box to select or define a script file that you want to run on specific
computers as part of an Event.

1. Choose the New Event icon to create a new Event, or double-click an existing Event if you want the changes to
be made in an existing Event.

2. Name the Event (optional).

3. Click Add on the Event Properties page and choose Run Script.
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4. If you have a script file defined already, choose Run the script from file and then browse from the
folder icon to select the file. To read or edit the file, choose Edit.
or
Select Run this script and type the script in the space provided. Or choose Import and select a file to
import.

5. Specify whether the script should be run from BootWorks (DOS) or from Windows.

6. Choose OK to continue defining the Event or to store or schedule the Event.

Important: When a computer is in BootWorks mode, it does not see DOS partitions. To run a script from
BootWorks, use FIRM (File-system Independent Resource Manager) commands. See “Critical Error
Messages” on page 116.

Important: Altiris utilities assume a return code of zero (0) as a success. Some programs return a code of
one (1) as success, so if a program returns a one (1), you will see an error message at the Console even
though the script ran correctly. To fix this, you can modify the script file to return a code that the Console
interprets correctly.

For examples, see “Example Script” on page 64 and “Script Variables” on page 65.

Use the Lab Builder
Use the Lab Builder to set up five events under the Lab folder in the Events view that can help you set up a
classroom or lab environment. The five events are:

• Create Disk Image
• Deploy Lab
• Restore Lab
• Update Configuration
• Upload Registries

Each of these events contains a default list of tasks. Lab Builder places these five new events under a
folder (which you name) located under the Lab folder in the Events view. All of the tasks in the events have
been assigned default paths and filenames that allow them to use the same images and configuration
information, registry data, etc. It is best that you do not change the filenames and paths. If you change the
defaults (for example, changing the image name), you must change it in all of the events where the image
is used.

Use Lab Builder
1. Click the Lab Builder (apple) icon on the toolbar, or choose File > New > Lab Builder.

2. Enter the name of the lab setup.

Note: The lab name must be unique because the program creates a default image file name based
on the name, and the image file name must be unique. The default image name is synchronized in all
of the lab events, so if you change the name later you must change it in all the events that use the
image.

3. You can also enter a lab description to help you differentiate the lab from others. This field is optional.

4. Choose OK.

5. Identify an image in the Create Disk Image Event.

6. Set computer names and addresses in the Update Configuration Event.

The following information describes the default Events. When you want to run one of these Events, simply
drag it to the computer or group you want it applied to.
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• Create Disk Image. This Event uploads an image of a computer to the server. An image name is
created automatically, based on the lab name. However, there is no actual image in the Event until
you drag the image source computer to this Event. You should not change the default name, because
it is used in the other lab tasks, and if you change it you will have to change the name in the other
events.

• Deploy Lab. This Event has three default tasks: Deploy image, Apply configuration settings, and
Back up registry files. The image that is uploaded using the Create Disk Image Event is deployed
when you use this Event. The configuration settings you specify in the Update Configuration Event
are applied to the computers, and then the computer registry files are uploaded to the eXpress Server
so it has current configuration information about each computer.

• Restore Lab. This Event restores the image and registry files to a computer where a lab was
previously deployed. It is useful if you have a classroom or lab running and one of the computers goes
down. You can quickly get it running again by restoring the lab on that computer.

• Update Configuration. This Event allows you to set unique configuration information (such as
computer names and network addresses) for computers. When a lab is deployed, each computer has
an identical image, but not the same configuration settings. This means you don’t have to visit each
computer to reset IP addresses and other settings when you deploy an image.

• Upload Registries. This Event backs up computer registry files to the eXpress Server.
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Common Usage Scenarios

Create an Image of a Computer
Prerequisites:

• Install AClient.exe on the image source computer.
• Configure the image source computer with everything you want included in the image.
• Install BootWorks on the computer, have a BootWorks boot disk available, or make sure PXE is

configured and enabled.
• If you are using domains and you are uploading an image from an image source computer, see “Manage Com-

puter Names in Domains” on page 66.

1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Create an image, name the Event (optional), and click Next.

3. Select the computer(s) that you want to create an image of. Click Next.

4. Type the full pathname of where to store the image file.

5. You can create a self-extracting image file by naming the image with a .exe extension (see “Create a
Self-Extracting Image File” on page 44 for more information).

6. Select Local image store to store the image locally in the computer (see “Store Images on a Local
Hard Drive” on page 38 for more information). Click Next.

7. Read the Summary of the options you chose for this Event. Click Next.

8. Choose Next to schedule the Event or Finish to run it immediately.

The new Event appears in the Events window. If you chose not to run the Event now, you can image
computers with it by simply dragging the Event to a computer or group, and schedule when you want it to
run.

Deploy a Software Package
Prerequisites:

• Install aclient.exe on the computer
• Create a RapidInstall Package (RIP) that includes the software or printer files to be deployed

Deploy a Package Using Drag-n-Drop
If you store RIPs in the product directory, they appear in your Resources list (in the Shortcuts view). In this
case, deploying is simple. Just drag the file to the group or computer where you want it to run. To run the
file on multiple computers, use the Ctrl key to select them and then drag them onto the file in the
Resources list. To deploy it to all the computers registered with the eXpress Server, drag it to the All
Computers icon.

Choose to run the Event immediately (optional). A New Event will be automatically created under the
Drag-n-Drop Events folder containing the Event information (task, computers assigned to the Event, and
status).

Deploy a Package Using the New Event Wizard
1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Deploy software packages, name the Event (optional), and click Next.
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3. If you want to apply certain conditions to this event, choose Setup conditions for this set of tasks.
Otherwise choose Not using conditional tasks in this event. See “Define Conditions for Events” on
page 36 for more information. Click Next.

4. Specify the software package you want to apply and click Next.

5. Select Apply this event to one or more computers and then choose the computers you want to
image from the list. If this is new computer, click New Computers to define or import new computer
accounts. Click Next.

6. Read the Summary of the options you chose for this Event. Click Next.

7. Choose Next to schedule the Event or Finish to run it immediately.

The new Event appears in the Events window. If you chose not to run the Event now, you can image
computers with it by simply dragging the Event to a computer or group, and schedule when you want it to
run.

Upgrade the OS on Computers
Prerequisites

• Install aclient.exe on the computers.
• Install BootWorks, have a BootWorks boot disk available, or make sure PXE is configured and

enabled properly.
• Prepare an image file or computer that includes the new OS.

1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Deploy and configure computers, name the Event (optional), and click Next.

3. If you want to apply certain conditions to this event, choose Setup conditions for this set of tasks.
Otherwise choose Not using conditional tasks in this event. See “Define Conditions for Events” on
page 36 for more information. Click Next.

4. Select Use image file and specify the name of the image that contains the new OS. You can browse
and select an image file or use the image of another computer on the network. Select Local image
store to store the image locally in the computer (see “Store Images on a Local Hard Drive” on
page 38 for more information). Click Next.

5. If you want to apply software packages after imaging, specify them and click Next.

6. Select Apply this event to one or more computers and then choose the computers you want to
image from the list. If this is new computer, click New Computers to define or import new computer
accounts. Click Next.

7. Read the Summary of the options you chose for this Event. Click Next.

8. Choose Next to schedule the Event or Finish to run it immediately.

Note: Once imaging is complete, the computer’s configuration (Computer name, MAC address, IP
information) will be restored to what it was originally (before the imaging Event was started). See “Create
or Change Computer Configurations” on page 48 for more information.

The new Event appears in the Events window. If you chose not to run the Event now, you can image
computers with it by simply dragging the Event to a computer or group, and schedule when you want it to
run.

Change Computer Configurations
You can create an event to modify a computer’s configuration such as Workgroup name, Domain name,
Organization name, etc. Some configurations, such as Computer name or IP address, cannot be
configured across multiple computers; these settings must be changed individually on each computer.
 2000 Altiris, Inc. page 42



When you re-configure a computer, a “reconfigure” Event is created that applies to the computer you have
selected in the Console. This new Event behaves like any other, letting you schedule, save, run
immediately, etc. You can also re-configure multiple computers simultaneously. See “Re-configure Multiple
Computers Simultaneously” on page 49 for more information.

Prerequisites

Install aclient.exe on the computer you want change configurations on.

Change a Computer’s Configuration
1. Right-click a computer and choose Configure.

2. Change a configuration and choose OK.

3. Schedule the Event, run it immediately, or choose Do not schedule and choose OK.

Note: the new Reconfigure Event that is added under the Restoration Events folder in the Events view.

Back Up a Computer Registry
You can set up an Event to automatically back up computer registries on a regular basis (daily, weekly,
monthly, or on specified dates). You can also back them up any time you want by dragging the Event to a
computer or group.

Prerequisites:

• Install aclient.exe on the computer you want to back up.
• Install BootWorks on the computer, have a BootWorks boot disk available, or make sure PXE is prop-

erly configured and enabled.

1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Backup registry files, name the Event (optional), and click Next.

3. Select the computer(s) for which you want to back up registries. Click Next.

4. Type the full pathname of where to store the registry files. If Windows was installed to a location other
than the default on these computers, select Advanced to provide the correct path. Click Next.

5. Read the Summary of the options you chose for this Event. Click Next.

6. Choose Next to schedule the Event or Finish to run it immediately.

The new Event appears in the Events window. If you chose not to run the Event now, you can image
computers with it by simply dragging the Event to a computer or group, and schedule when you want it to
run.

Restore a Computer
Restore a Computer on the Fly
Right-click a computer and choose Restore and then select the items to restore from the list.

Create an Event to Restore a Computer
1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Restore a computer, name the Event (optional), and click Next.

3. Select a computer to restore. Click Next.

4. From the list of previously processed tasks, select one or more tasks you want to deploy to restore the com-
puter. To view only specific types of tasks, choose Show only and select the type you want from the list. To limit
the list to tasks that have occurred since a specific date, select Since and choose a date from the calendar.
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5. Read the Summary of the options you chose for this Event. Click Next.

6. Choose Next to schedule the Event or Finish to run it immediately.

The Event is saved under the Restoration Events folder in the Events View. If you chose not to run the
Event now, you can image computers with it by simply dragging the Event to a computer or group, and
schedule when you want it to run.

Create a Self-Extracting Image File
When you create an image file, you can save it as either a regular image file (*.img) or a self-extracting
executable file. To make the image self-extracting, all you have to do is create the image with an “*.exe”
extension when you create (upload) the image.

Tips
• For computers connected to your network, regular image files (*.img) work well.
• For computers that are not connected to your network, such as laptops and computers in branch

offices, create self-extracting image files (*.exe). You can copy them to a bootable media, and remote
users can use the portable images to re-configure their computers at any time.

Save an Existing Image (*.img) File as a Self-Executing (*.exe) File
1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Create an image, name the Event (optional), and click Next.

3. Select the computer(s) that you want to create an image of. Click Next.

4. Type the full pathname of where to store the image file.

5. You can create a self-extracting image file by naming the image with a .exe extension.

6. Read the Summary of the options you chose for this Event. Click Next.

7. Choose Next to schedule the Event or Finish to run it immediately.

Schedule Power Control Options
1. Choose the New Event icon to create a new Event, or double-click an existing Event if you want

changes to be made in an existing Event.

2. Choose Add on the Event Properties page.

3. Choose Reboot, Shut Down, Suspend, or Log Off.

4. Select Force applications close without prompting. See “Power Control Options” on page 54 for
more information.

5. Select the type of operation you want to perform. If you need additional information about the selec-
tions, choose Help on the screen.

You can also reboot, shut down, suspend, or log off a computer without using an Event. See “Power
Control Options” on page 54 for more information.

Add or Remove Computers From Scheduled Event
You can approach this task in two ways, depending on whether your focus is on the Event (removing
computers) or the computer (removing events). Remember, the icon for a scheduled Event is yellow.

• To remove scheduled events from a computer, highlight the computer, choose the scheduled Event in
the Details window, and choose Delete. To remove multiple events, hold down the Shift or Ctrl key
while you select the Events, then press Delete.

• To delete a computer from a scheduled Event, highlight the Event in the Event view, and press
Delete.
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Deploy an Image to an Existing Desktop
Prerequisites:

• Install aclient.exe on the computer.
• Install BootWorks or have a BootWorks Boot disk available.
• If you are using domains, see “Manage Computer Names in Domains” on page 66 before you deploy

the image.

1. Choose File > New > Event Wizard or click the New Event Wizard icon on the toolbar.

2. Choose Deploy and configure computers, name the Event (optional), and click Next.

3. If you want to apply certain conditions to this event, choose Setup conditions for this set of tasks.
Otherwise choose Not using conditional tasks in this event. See “Define Conditions for Events” on
page 36 for more information. Click Next.

4. Select Use image file and specify the name of the image. You can browse and select an image file or
use the image of another computer on the network. Select Local image store to store the image
locally in the computer (see “Store Images on a Local Hard Drive” on page 38 for more information).
Click Next.

5. If you want to apply software packages after imaging, specify them and click Next.

6. Select Apply this event to one or more computers and then choose the computers you want to
image from the list. If this is new computer, click New Computers to define or import new computer
accounts. Click Next.

7. Read the Summary of the options you chose for this Event. Click Next.

8. Choose Next to schedule the Event or Finish to run it immediately.

The new Event appears in the Events window. If you chose not to run the Event now, you can image
computers with it by simply dragging the Event to a computer or group, and schedule when you want it to
run.

Note: Once imaging is complete, the computer’s configuration (Computer name, MAC address, IP
information) will be restored to what it was originally (before the imaging Event was started). See “Create
or Change Computer Configurations” on page 48 for more information.

Troubleshooting Tip: If an imaging Event fails on a client computer, the AClient configuration screen will
appear on the client with a prompt asking if you want to configure the client or restore the original settings.
Choose Cancel > Restore Original Settings. To solve the problem, check the client’s BootWorks
connection. In-depth information about troubleshooting BootWorks is available in the Altiris eXpress
Installation and Setup Guide.

Copy Files During a Scheduled Event
1. Choose File > New > Event or double-click an existing Event if you want the changes to be made in

that Event.

2. Click Add.

3. Choose Copy File to.

4. Enter the source path and filename, and then enter the destination path and filename.

5. Choose OK to finish defining tasks for the Event.

You can also copy files to computers without using an Event. See “Send a File to Computers” on page 57
for more information.
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Deploy New Computers to Specific Individuals
Altiris eXpress lets you pre-define a computer and assign customized Events to that computer even if you
don’t know that computer’s MAC address, asset tag, or serial number. This type of computer is known in
eXpress as a virtual computer.

Why a Virtual Computer?
Virtual computers offer a great deal of power and flexibility, especially when you need to deploy several
computers to individual users with specific needs. The virtual computer saves you time because you can
use your time before the actual computer arrives on site. You can set up as much configuration information
(computer name, workgroup name, and IP address, for example) that you know about the computer and
apply it to a user’s new computer. You can also preemptively prepare Events prior to the arrival of the new
computer, including customized images and RIPs based on a user’s specific needs. For example, a user
might request Windows 2000 with Office 2000 and virus scanning software installed on the new computer.
The user also might request that his or her PC personality (customized user settings, address books,
bookmarks, familiar desktop) be migrated from the old system. You can build any Event, including any of
the available tasks, and assign it to the virtual computer.

When the new computer finally arrives, you’ll be ready to deploy it because you’ve done all the homework
ahead of time. Just set the “managed computer option in PXE or BootWorks and the new computer will
connect to the Server as a managed computer. The virtual computer that you created now turns into a
regular, managed computer in the Console.

Prerequisites:

Make sure the new computer is PXE-enabled, BootWorks is installed, or you have a BootWorks boot disk
available.

Set up a Virtual Computer
1. Choose File > New > Computer.

2. Use the Create Computer Accounts dialog box to add virtual computers (new computers) and set
up the configurations (computer name, workgroup name, IP address, etc.) you want the virtual com-
puter to have. See “Create and Edit Computer Accounts” on page 47 and “Create or Change Com-
puter Configurations” on page 48 for more information.

Note: A computer with a yellow icon is added to the Console Computers area.

3. Create images, RIPs, Personality Packages, batch files, and other packages that you want to apply to
the virtual computer.

4. Create Events and include the items you created as tasks in the Event.

5. Assign the Events to the virtual computer just as if it were a managed computer. Choose Run this
event immediately so that the Event will run when PXE or BootWorks connects the new computer to
the server as a managed computer.

When the computer connects, the computer’s MAC address, serial number, and asset tag information is
populated into the computer’s configuration. The Events that you set up are run immediately. The yellow
computer icon turns blue in the Console. The virtual computer is now a regular managed computer.
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Creating New Computer Accounts

Create and Edit Computer Accounts
Use the Create Computer Accounts dialog box to add and manage new computer accounts that you add to
your eXpress system. You can also edit existing accounts or import them as a text-delimited file (.txt, .csv,
or .imp).

Create a New Computer Account
1. Choose File > New > Computer or click the New Computer icon on the toolbar.

2. Click Add and then enter the information about the new computer in the Computer Configuration
screens.

3. When you are finished entering information, choose OK.

Edit a Virtual Computer’s Configuration
1. Highlight a virtual computer (one with a yellow computer icon) in the list.

2. From the Create Computer Accounts dialog box, choose Edit.

3. Modify the computer configuration information as desired, and then choose OK.

Import Computers Using a Text-Delimited File
1. Click Import.

2. Browse for the import file and choose Open.

3. The import file populates a new computer account, which appears in the list.

Import File Format
A semicolon as the first character denotes comment lines. Quotes around fields are optional. Leaving the
event name blank will not assign the computer to any event. Leaving the start time blank will make an entry
in the event for the computer, but will not schedule it for a specific time. Leaving the computer name blank
will create an entry as “New Computer.”

If you want the event to start immediately, simply enter a past date (such as 1995/1/1). You must provide a
MAC-Address, Serial-Number, or Asset-Tag.

Sample Import File
;"Computer-Name","MAC-Address","Serial-Number","Asset-Tag","Group-Name","Event-Name","Start-Time";
"Computer 1","AAABBBCCC1","SERIALNUM1","ASSETTAG1","Group1","Deploy Win2000",""
"Computer 2","AAABBBCCC2","SERIALNUM2","ASSETTAG2","Group2","Deploy Win2000","1999/12/31 17:30"
"Computer 3","AAABBBCCC3","SERIALNUM3","ASSETTAG3","Group1","Deploy Win2000","1999/09/22 00:00"
"Computer 4","AAABBBCCC4","SERIALNUM4","ASSETTAG4","","Deploy Win2000","4:30"
"Computer 5","AAABBBCCC5","SERIALNUM5","ASSETTAG5","Group5","",""
"","AAABBBCCC6","","","","",""
"","AAABBBCCC7","","","","Deploy Win2000",""

Computer Name Range
Use the Computer Name Range dialog box if you want computer names to have a fixed name with a
range of variable numbers or letters.
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Define a Computer Name Range when Creating New Computer
Accounts
1. Choose File > New > Computer > Add.

2. Click the Microsoft Networking icon.

3. Click Define Range.

4. Enter the number of new computers to rename (this option is available only when creating new com-
puter accounts).

5. Enter a name in the Fixed text box and a starting number or letter in the Range start box.

6. Check the Append box to add numbers or letters to the end of the name (default).

7. Choose OK.

Each computer that is brought into the eXpress system will be given this name, with a number or letter
from the range you set.

Note: The computer name will be changed for the client's Windows and BootWorks configurations. You
don't need to change the BootWorks configuration separately.

Define a Computer Name Range When Defining a Configuration Set
1. Right-click the Initial Deployment Event in the Console Events list and choose Properties.

2. On the Configuration Sets tab, choose Add.

3. Click the Microsoft Networking icon.

4. Click Define Range.

5. Enter a name in the Fixed text box and a starting number or letter in the Range start box.

6. Check the Append box to add numbers or letters to the end of the name (default).

7. Choose OK.

Create or Change Computer Configurations
The New Computer Account, Define Configuration Set, and Reconfigure Computer screens let you set up
or change a managed computer’s unique configurations such as TCP/IP, OS license, networking, and user
account settings. Because the images you deploy on your network will probably contain generic
configurations, the ability to control a computer’s unique configuration is a big advantage. Use this feature
even if all you need to do is change a computer’s configuration.

Note: The Altiris Windows Client (aclient.exe) applies the configurations you set, and reboots the
computer so the changes take effect.

• To create new computer accounts, see “Create and Edit Computer Accounts” on page 47.
• To change a managed computer’s configuration, right-click that computer and choose Configure. The

information below explains the configuration options.
• You can re-configure several computers at the same time. See “Re-configure Multiple Computers

Simultaneously” on page 49 for more information.
• The Initial Deployment Event uses Configurations when deploying to new computers. See “Using the

Initial Deployment Event” on page 51 for more information.

General
The General computer configurations are available only when setting up a computer for the first time (for
example, when you choose File > New > Computer > Add). They are not available when reconfiguring a
computer or when defining a configuration set.
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General configurations include the name of the computer as it appears in the Console, MAC address,
Serial Number, Asset Tag, Computer Name, IP Address, etc. You don’t change these values on a
computer; rather, you specify them for a new computer that hasn’t connected to the eXpress Server yet.

Microsoft Networking
Networking contains workgroup and domain settings. You can choose either workgroup or domain, then
enter the name of the workgroup or domain along with the computer name. If you are using domains, you
can also change the Windows Security ID (SID) for that particular computer. Each computer in a domain
must have a different SID but after imaging, they all have the same SID. Use the SIDgen utility to generate
unique SIDs.

TCP/IP
This section contains the same type of settings that you would find in the Networking Properties and TCP/
IP settings of the computer to which you are sending or downloading an image. These settings let you
choose between DHCP or static IP addresses. You can also set up WINS and DNS options.

NetWare Client
If you are using NetWare, this section helps you apply NetWare settings on a newly imaged computer or
any configuration Event. You can select whether you want to login to a tree or a server and to specify, the
preferred tree or server name, and the NDS context. You also have the option to run login scripts.

OS Licensing
This is where you enter the license for your operating system (Windows 95, 98, NT, 2000). You can enter
the user, organization, and license key.

User Account
This is where you set up Windows user accounts for the newly imaged computer or any configuration
Event. You can enter the user name, full name, password (you must confirm the password by typing it
again in the field below it), and you can also specify the Windows groups that this user will belong to as a
comma-delimited list. For example: Administrators, Marketing, Management. You can also determine
whether the user must change their password the next time they log on, whether they can change their
password, and whether the password expires.

Re-configure Multiple Computers Simultaneously
You can re-configure multiple computers or groups of computers simultaneously. For example, you can
change the Workgroup name, Domain name, Organization name, etc., for several computers at the same
time. Some configurations, such as Computer name or IP address, cannot be configured across multiple
computers; these settings must be changed individually on each computer.

When you re-configure multiple computers, a multiple computer reconfiguration Event is created that
applies to all of the computers you have selected in the Console. This new event behaves like any other,
letting you schedule, save, run immediately, etc.

Re-configure Multiple Computers Simultaneously
1. Highlight a group of computers in the Console

or

2. While holding down the Ctrl or Shift key, select several computers.

3. Right-click any of the highlighted the computers and choose Configure.

4. Change a configuration and choose OK.
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5. Schedule the Event, run it immediately, or choose Do not schedule and choose OK.

6. Note the new Reconfigure multiple Event that is added under the Restoration Events folder in the
Events view.

Simultaneously Edit Re-configurations of Multiple Computers
1. Click a Reconfigure multiple Event

2. Highlight the Change Configuration task in the Event details bar and choose Edit.

Note: The Choose Computer Accounts dialog box displays to let you choose only the computers that
require a configuration change.

3. If you want to change the configuration of just one computer, highlight that computer and choose OK.
or
Highlight several computers in the list, or all of them, and choose OK.

4. Change the configuration and choose OK.

5. Reschedule the reconfigure multiple computer Event to run at the desired time.

Deploy New Computers on a Mass Scale
If you need to deploy large numbers of computers (100 to 5,000), consider using a barcode scanning
system to collect user information (names, OS and application needs) and computer information (MAC
address, serial numbers, asset tags). You can save this information to a file, which can then be imported
into the New Computer Account dialog box. Depending on the number of incoming computers, the amount
of information you have about those computers, and the needs of individual users, you can use either
virtual computer method (best for smaller numbers of new computers) or the Initial Deployment Event (best
when deploying generic setups by departments or groups).

If you are using an import file, make sure you know primary lookup key. This is the piece of information that
eXpress needs to set up a unique computer. The primary lookup key can be Serial Number, Asset Tag,
UUID, or MAC address. See “Change Program Options” on page 27 for more information.
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Using the Initial Deployment Event

Deploy New Computers by Department
The Initial Deployment Event in the Events view represents a system Event that exists by default. You
define what is in the Event by including an image, packages, and configuration data. The Event brings new
computers into your production environment by automatically running on computers whose information
has not been registered with the eXpress Server. New computers appear in the Console in the New
Computers group. You can move them to another group, or anywhere you want in the Computers list.

When to Use this Feature
The Initial Deployment Tasks feature is ideal for small-scale deployments (1 to 10 computers). This feature
is not recommended for large deployments (10 to 100 computers) or mass deployments (100 to 5,000)
where you’d probably want to use virtual computers, customized events, and the Altiris eXpress new
computer import feature.

Set up this Event with standard image and configuration settings to apply to all computers that register with
the eXpress Server as new computers. Computers register as new computers if they are booted with a
New Computer Boot Disk.

Deploy New Computers
1. Double-click the Initial Deployment Event icon in the Events view.

2. On the Configurations Tab,

3. Specify the image file to use in the Filename.

4. Choose Assign new configuration information to these computers to set unique configurations
for the new computers.

5. Choose Next to include RapidInstall Packages (RIPs) or Personality Packages in the Event, or
choose Finish to save the settings and return to the Console.

6. Choose Add to browse for the RIPs to include.

7. Choose Next to see a Summary of the options you chose for this Event.

8. Choose Next to save the settings and return to the Console.

You have several options for scheduling the Initial Deployment Event. You can choose to:

• Run the Event as each new computer comes online. (This is the default.)
• Run the Event when a specified number of computers come online.
• Run the Event at a specified time on all new computers available at the time.

Schedule When the Initial Deployment Event Will Run
1. Double-click the Initial Deployment Event icon in the Events list.

2. Click the Start Options button on the Configuration Sets tab.

3. Specify when you want the Event to run.

4. Choose OK to save the settings.
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Define Configuration Sets
Use the Initial Deployment Event Properties Configuration Sets dialog box to define sets of computer
configurations that will be presented to the user in a menu when the Event is processed. The user will be
able to pick the configuration set that is best for his or her new computer. Compare this tab with the Task
Sets tab.

1. Double-click the Initial Deployment Event.

2. Click the Configuration Sets tab.

3. Click Add.

4. Use the Define Configuration Set screens to set up the configurations you want applied to the new
computers. When you have finished, choose OK to return to the Configuration Sets dialog box.

5. Repeat for as many different configurations as you want to set up for users to choose from.

6. From the Default menu choice drop-down list, choose the configuration set that you want to be the
default choice.

7. If you like, set up a Timeout so that the default Event runs after the amount of time you specify.

8. To set up more precise scheduling of the Initial Deployment Event, click Start Options.

9. Choose OK or click the Task Sets tab to define a task.

Define Task Sets
Use the Initial Deployment Event Properties Task Sets dialog box to define sets of tasks (image and
package deployment) that will be presented to the user in a menu when the Event is processed. The user
will be able to pick the task set that is best for his or her new computer. Compare this tab with the
Configuration Sets tab.

1. Double-click the Initial Deployment Event.

2. Click the Task Sets tab.

3. Click Add.

4. Specify the path and name of the image you want to deploy to the new computers. Choose
Advanced to set up image resizing and partition removal options.

Note: Image need to be accessible from the drive mapped in Boot Disk Creator for BootWorks to use
at DOS. This is done in the Network Drive Mappings screen.

Example:

Mapped drive is: f:\\yourserver\eXpress

Images are in: f:\\yourserver\eXpress\images

Browse to help enter the path and filename on the Task Set screen. For example, enter

.\images\myimage.img

5. Click Add to include any software packages (RIPs or Personality Packages) you want to include.

6. Highlight a package and choose Options if you need to modify passwords or command-line switches.

7. Choose OK to return to the Task Sets menu.

8. From the Default menu choice drop-down list, choose the task set that you want to be default choice.

9. If you want, set up a timeout so that the default Event runs after the amount of time you specify runs
out.

10. Choose OK.
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Define Start Options
The Advanced Options dialog box lets you control when an Event is processed on computers.

Access the Advanced Options Dialog Box
1. Right-click the Initial Deployment Event and choose Properties.

2. Click the Configuration Sets tab.

3. Click Start Options.

• Select Process this event as each client becomes active if you want to run the Event as soon
as the computer connects to the eXpress Server.

• Select Process this event in batch mode if you want to run the Event once a certain number of
computers connect to the eXpress Server. You can set a timeout deadline so that the Event will
not run if the number of computers you specify fail to connect during a certain amount time.

• Select Hold all clients until this time if you want to process the Event on all computers at a par-
ticular time of day.
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Managing Client Computers

View Computer Properties
The Computer Properties screens let you view, and sometimes edit the properties that were established
when a computer became an Altiris eXpress-managed computer. To access this dialog box, right-click a
computer and choose Properties. You can view the following types of information:

• General view or change name of the computer as it appears in the Console, view logged in
username, operating system installed, name of the eXpress Server, whether or not BootWorks is
installed, version of the Altiris Windows Client, and other client information.

• Hardware view processor make and type, RAM available on the computer, display configuration,
manufacturer, model, product name, MAC address, serial number, asset tag, UUID, and whether or
not Wake On LAN and PXE are installed and configured. You can also get information about different
drives that are on the computer.

• Configuration view TCP/IP, Microsoft Networking, and user information. Click Change to modify
some of these settings.

• Application view the applications that are installed on the computer.
• Services view the services installed on the computer.
• Devices view the devices installed on the computer.
• Location view and edit user-specific properties such as contact name, phone number, e-mail name,

department, mail stop, and site name. As the administrator, you can enter this information manually or
you can let the user populate this screen using Prompt User for Properties.

Find a Computer in the Database
Use the Find Computer dialog box to find a managed computer or virtual computer that has been added in
the database.

Find a Computer
1. Choose Edit > Find Computer or click the Find Computer icon on the Console toolbar.

2. Type all or part of the computer’s attributes that you would like to search for.

3. Choose the field that you want to search in.

For example, to find a computer by searching for its IP address, type the address in Search For field and
then select IP Address from the In Field drop down list.

The computer you are looking for will be highlighted in the Computers window in the Console.

Power Control Options
There are several remote power control options for a managed computer:

• Wake-Up powers on a computer if the system supports Wake-on-LAN. After starting, BootWorks
performs any tasks that must be done in DOS, and then the computer boots to Windows and
connects to the eXpress Server. See “Wake Up a Computer” on page 55 for more information.

• Reboot closes any open applications and restarts the computer. After restarting, BootWorks performs
any work that must be run in DOS, and then the computer boots to Windows and connects to the
eXpress Server.

• Shutdown closes any open applications, shuts down the computer and, if the system and hardware
support it, powers off the computer. Note:Windows 98 might have trouble shutting down the
 2000 Altiris, Inc. page 54



computer, and Windows NT allows the computer to be put in a state where it is ready to be powered
off, but it will not allow a software package to complete the process.

• Log Off closes any open applications and logs the user off the computer.
• Suspend puts the computer in sleep mode if the system and hardware support it.

Note: With the Reboot, Shutdown, and Log Off power options, you have the choice to Force
applications closed without prompting the user to save data. If you use this option, any unsaved data
in open applications will be lost. If you do not use this option, open applications with unsaved data will
not close until the user chooses to save or not save the data, which means the computer will be
unable to complete the selected power option until the user makes a selection.

Use a Power Option Immediately on a Managed Computer
1. In the Console, select the computer on which you want to perform the power control operation.

2. Click Operations > Power Control > Wake-Up, Reboot, Shutdown, Log off, or Suspend.

3. If you want to force applications to close without saving unsaved data, select the Force applications
closed without prompting checkbox.

4. Click Yes to confirm your choice or No to cancel.

Set Up a Power Option While Setting Up an Event
1. Double-click an Event.

2. Click Add and choose Shutdown/Restart.

3. Choose a power control option (Reboot, Shutdown, Log off, or Suspend).

4. If you want to force applications to close without saving unsaved data, select the Force applications
closed without prompting checkbox.

5. Choose OK.

Wake Up a Computer
The Wake Up feature is hardware-dependent. Your operating system and network adapter (NIC) must be
capable of recognizing and processing the wake up packets. Non-embedded NICs must be properly
configured. For example, 3Com NICs has an extra jumper cable that enables Wake on LAN. Check the
documentation that came with your NIC for more information.

Right-click a computer in the Console and choose Power Control > Wake-Up.

How Wake on LAN works
Altiris eXpress uses a “magic packet to wake up a computer. This computer must be on a local segment in
order to receive this packet. Therefore, if your client is located on a subnet separate from your Server, the
client may never see this packet.

Prompt Users for Properties
Sometimes it is useful to gather information from users, instead of guessing. Use the Prompt Users for
Properties dialog box to query for information, which is then added to the computer's properties. The
information you can collect from the user includes:

• The name to show in the Console
• Site
• Department
• Mail Stop
• Contact Name
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• E-mail Address
• Phone Number(s)

Prompt User for Properties
1. Highlight a computer or group of computers in the Console.

2. Choose Operations > Prompt User for Properties.

3. Choose the items you want to prompt the user for.

4. Choose OK.

A form will be displayed on the users’ computers that they can fill out. When they choose OK, the
properties are recorded for their respective computers.

You can also use this information in conditions and filters. See “Define Conditions for Events” on page 36
and “Create, Edit, and Use Filters” on page 26 for more information.

Send a Remote Execution Command
Use the Send Remote Execution Command dialog box to send a command to computers as if you were
entering the command using the Run option on those computers.

Send a Remote Execution Command
1. Highlight the computer or group of computers where you want the command to be executed.

2. Choose Operations > Execute Command.

3. Enter the name of the program or command you want to run on the managed computer, or select from
a list of previously used run commands. For example, type regedit to run that program on the com-
puter(s).

Reset a Client Connection
Resetting the connection that a managed computer has with the Server simply disconnects and
reconnects the computer. This is useful for troubleshooting or if you suspect there is a bad connection.

Reset a Client Connection
Right-click a computer and click Advanced > Reset connection.

Reject or Retrieve a Computer Connection
Reject a Computer Connection
If a computer that you do not want to manage connects to your eXpress Server, you can reject it. This
removes it from the Computers list in the Console. Further attempts by the computer to connect will be
denied. Although the computer is not deleted, any history or schedule information associated with the
computer is deleted.

1. Right-click the computer you want to reject.

2. Choose Advanced > Reject Connection.

View List of Rejected Computers
Rejected computers are stored in a Rejected Computers list. Select View > Rejected Computers to view
this list.
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Retrieve a Rejected Computer
If you want to manage a previously rejected computer, you can retrieve it and connect it to the eXpress
Server.

1. Choose View > Rejected Computers.

2. From the list, select the computer you want to retrieve.

3. Select Delete to delete the computer from the rejected list (this doesn’t delete the computer, just the
history that the computer was once rejected).

The computer appears in the Computers list. Connection requests from the computer will now be allowed.

View a Computer History
Use the Computer History dialog to view a history of the events run on the managed computer.

Save the History to a File
1. Click Save As.

2. Type a path and filename or choose the folder icon to select a folder from the list.

3. Enter the filename and choose OK.

Click the Print button to print a copy of the history file.

Send a File to Computers
Use the Send File to Computers dialog box to copy a file to a managed computer or a group of managed
computers. You can also regularly copy a file as one of the tasks in an Event. See “Copy Files During a
Scheduled Event” on page 45 for more information.

Send a File to Manager Computer(s)
1. Select a computer or group of computers from the Computers list.

2. Choose Operations > Copy File To or click the Copy File To icon on the Console toolbar.

3. Type in the Source filename or choose the folder icon and select the file from the list.

4. Enter the complete path and Destination filename where the file will be copied on the computers. If
the directory does not already exist, the program will create it for you.

Note: You cannot use wildcard characters to specify an entire directory. You must choose the file itself.
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Remotely Controlling Computers

Remote Control and Chat
The Remote Control feature allows you to remotely control an Altiris client computer from the Console.
Using the Remote Control feature, you can remotely perform most of the tasks you would perform at the
managed computer.

How Remote Control and Chat Work
When you initiate a remote control session on a computer, the following happens:

• The Console computer starts listening for a client computer.
• The Console tells the Server that it wants to remote control Client A.
• The Server tells Client A that the Console (at a particular IP address) wants to remote control or chat

with it.
• Client A says “here I am” and the Console begins the remote control or chat session.

When a Computer is Remotely Controlled
• An image that represents the remotely controlled computer screen is displayed in the Remote Control

window on the Console computer. The image and Remote Control window can be resized and moved
as desired. By clicking on menus, icons, buttons, etc. in the image, the corresponding actions are
performed on the remotely controlled computer. These actions change the display, which is reflected
in an updated image in the Remote Control window.

• Input from the remotely controlled computer keyboard and mouse is allowed. If the remotely
controlled computer is running Windows 98, Me, NT, or 2000, you have the option to restrict input
from the controlled computer’s keyboard and mouse.

• A blinking red dot appears over the Altiris Windows Client icon in the system tray of the managed
computer, indicating that a remote session has been initiated.

Remote Control Prerequisites
Before you can remotely control a managed computer:

• The Console must be installed on the computer from which you want to remotely control the managed
clients, have sufficient rights, and be set up to manage the client computer.

• The client must have the Altiris Client for Windows (aclient.exe) installed and properly set up.
• The client must have the appropriate Remote Control option checked in Altiris client properties.
• The client and Console must be able to communicate to each other through TCP/IP.

Set Remote Control Security
The Altiris Client for Windows provides multiple mechanisms for ensuring privacy and security when a
managed computer is controlled remotely.

Before a managed computer can be remotely controlled, the managed computer security preferences
must be set accordingly. If this permission is not given, the managed computer cannot be remotely
controlled.

You can also set your managed computer security preferences so a dialog appears on the managed
computer that prompts for permission to initiate a remote session with the Console computer. This
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provides an opportunity for a user of a managed computer to allow or reject the request. In certain
environments, such as a lab or classroom, using this prompt might not be necessary.

Whenever a managed computer is controlled remotely, the Altiris Client for Windows icon changes and
blinks, to indicate that the client is being remotely controlled.

Set Remote Control Security on a Managed Computer
1. Right-click on the Altiris Client for Windows icon in the system tray of the client computer, and select

View Status.

2. Click on the Properties button.

3. Select the Security tab.

4. Select the Allow the computer to be remote controlled checkbox if you want to allow the computer
to be remotely controlled.

5. If you have allowed the computer to be remotely controlled and you want to be prompted for a remote
control session before it begins, select the Remote control commands checkbox in the Prompt me
for confirmation when my computer has received section of the tab.

6. Next, specify the number of seconds you want the prompt to wait. Also, specify what will happen after
the prompt time is up—the choices are to continue or to abort.

7. Click OK.

Enable the Keyboard and Mouse Drivers for Remote Control
If you have a Windows NT or Windows 2000 remotely-controlled client, you can perform a Ctrl+Alt+Delete
operation and ignore input from the keyboard and mouse as long as you enable a special keyboard and
mouse driver.

If you have a Windows 98 or Me client, you can only ignore input from the keyboard and mouse, but you
cannot perform a Ctrl+Alt+Delete. You do not need to install a special driver to do this.

If you have a Windows 95 client, you cannot remotely perform a Clrl+Alt+Delete operation or ignore input
from the keyboard and mouse.

Install the Keyboard and Mouse Driver
1. Right-click on the Altiris Windows Client icon in the system tray of the client computer and select View

Status.

2. Click on the Properties button.

3. Select the Advanced Settings tab.

4. Select the Enable NT keyboard and mouse driver checkbox.

5. Choose OK.

6. Restart the computer.

Uninstall the Keyboard and Mouse Driver
1. Right-click on the Altiris Windows Client icon in the system tray of the client computer and select View

Status.

2. Click on the Properties button.

3. Select the Advanced Settings tab.

4. Deselect the Enable NT keyboard and mouse driver checkbox.

5. Choose OK.

6. Restart the computer.
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Adjust the Remote Control Window Color Depth
The color depth used by the Remote Control window specifies the number of colors that can be used to
display the remotely controlled computer display image in the Remote Control window. Changing the color
depth of the Remote Control window does not affect the color depth used by the remotely controlled
computer.

Reducing the color depth improves communications speed between the remotely controlled computer and
the Console computer. Increasing the color depth improves the quality of the representation of the
remotely controlled computer display in the Remote Control window, but might slow down responses from
the client computer.

Note: There is no benefit to using a color depth in the Remote Control window that is greater than the color
depth used by the remotely controlled computer.

Change the Color Depth Used by the Remote Control Window
1. In the Remote Control window, click on View > Color Depth and then select a color depth option.

or,

In the Remote Control window, click on View > Properties.

2. Select a color depth and then click OK.

Start a Remote Control Session
You can open as many remote sessions as you have memory for on the Console computer. Each client
can only be remotely controlled by one Console at a time. You can also remote control several clients
simultaneously. See “Start Multiple Remote Control Sessions Simultaneously” on page 60

Initiate a Remote Control Session
1. Highlight a managed computer.

2. Choose Operations > Remote Control. This opens the Remote Control window with an image show-
ing the contents of the client computer display.

End a Remote Control Session
In the Remote Control window, click Control > Close Window.

Start Multiple Remote Control Sessions Simultaneously
When multiple client sessions are initiated simultaneously, you have two options on how the sessions will
be displayed:

• Open a separate Remote Control window for each client. This accomplishes the same results as
opening a Remote Control session for each client separately.

• Open a single Remote Control window to control all clients. If you use this option, you will need to
specify the client you want your Remote Control window to display. This client is called the master. If
the clients are the same, the client designated as the master does not matter.

In order for this second option to work properly, all of the clients should be identical in their operating
system, settings, software installation, and configuration. Any differences in screen resolution, applications
installed, window positions, etc., will limit the effectiveness of this option.

Initiate Multiple Remote Control Sessions Simultaneously
1. In the Console, select the clients you want to control. You can also select groups if you want to control

all of the clients in a group.
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2. Click Operations > Remote Control.

3. Select how you want to control the clients. There are two options:

• Control each client separately in its own window.
• Control all clients together in the same window, using the following master.

4. Click OK.

Note: The more computers you include in the session, the more memory that is consumed and the slower
the speed.

End a Remote Control Session
In the Remote Control window, click Control > Close Window.

Remote Control Window Menu Items

Table 5: Remote Control Window Control Menu

Option Description

Disable Input from the Client If this option is selected, input from the remotely controlled computer’s keyboard
and mouse is ignored. Input is ignored until this option is deselected or the remote
session ends. This option is available only to Windows 98/Me and to Windows NT
and Windows 2000 clients with the keyboard and mouse driver installed.

Close Window Closes the Remote Control window session.

Table 6: Remote Control Window View Menu

Option Description

Refresh Refreshes the Remote Control window.

Fit To Window If this option is selected, the client display image becomes the same size as the
Remote Control window. If this option is not selected, the image is the size of the
client display, unless this has been changed in the Remote Control Properties
dialog box.

Color Depth Specifies the number of colors used in the Remote Control window to display the
client image. The color depth used does not affect the client computer display
settings. The color depth choices are:
4 bpp (16 Colors)
• 8 bpp (256 Colors)
• True Color (16 Million Colors)
Note: There is no benefit to setting a color depth on the Remote Control window
greater than that of the client. The benefit of lower colors is improved speed.

Properties
Opens the Remote Control Properties dialog, which allows you to set the Remote
Control window color depth, a specific image resolution, and update interval.
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Remote Control Window Button Bar
The Remote Control Window button bar gives you quick access to frequently used features.

Copy a File to a Remotely-Controlled Computer
The Copy File to Remote Machine feature lets you to copy a file from the Console computer to the
remotely controlled computer. If you are controlling multiple clients within a single window, this dialog will
send a file to the master client only. You can access this feature by clicking Send File from the button bar
on the Remote Control window.

Note: You can also drag entire folders from the Console computer onto the remotely control window, which
will copy the files to the remote client computer

Table 7: Remote Control Window Button Bar

Option Description

Chat Starts a chat session between the Console computer and the managed computer.
The chat session opens a chat window that allows you to send messages back
and forth between the Console and the managed computer. If you are controlling
multiple computers in a single window and start a chat session, the chat session
is only between the Console and the master client.

Refresh Refreshes the Remote Control window.

Ctrl+Alt+Delete Allows you to perform a Ctrl+Alt+Delete operation on a remotely computer.
Note: The remote controlled computer must be running Windows NT and have
the keyboard and mouse driver installed, for this feature to be available.

Send File Opens the Copy File to Remote Computer feature, which allows you to copy a file
from the Console computer to a controlled computer. If you are controlling
multiple computers in a single window, you can send a file only between the
Console and the master client. If you want to send a file to multiple clients at the
same time, use the Copy File To feature.

Table 8: Copy File to Remote Machine Option Description

Option Description

Source Filename Name and path to the file you want to copy to the client computers. You can enter
the path and filename or browse for it by clicking on the browse icon.

Destination Path Path on the client computer where you want the file copied.

Compress Data If this option is checked, the copied file will be compressed before it is transferred.

Encrypt Data (default) If this option is checked, the copied file will be encrypted before it is transferred.
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Remote Control Properties
Use the Remote Control Properties dialog box to view and set Remote Control window properties. You can
access these options by clicking View > Properties from the Remote Control window.

Table 9: Remote Control Properties Option Descriptions

Option Description

Color Depth Specifies the color depth (number of colors) used by the Remote Control window.
This setting applies only to the Remote Control window at the Console, not the
client display. The color depth choices are:
• 4 bpp (16 Colors)
• 8 bpp (256 Colors)
• True Color (True Color)
Note: There is no benefit to setting a color depth on the Remote Control window
greater than that of the client. The benefit of lower colors is improvement in
speed.

Use specific image resolution Lets you to specify the width and height of the image that represents the client
display.

Update Interval Specifies how often the image in the Remote Control window is updated (in
milliseconds). The more frequently the display is updated, the more bandwidth is
used.
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Console Basics

Image Deployment Options - Additional Options
1. Select Remove BootWorks Partition if you want to remove the partition from the computer or if you

have an updated partition in the image and you want it to overwrite the old one.

Warning: If the image you are deploying includes BootWorks, the new copy of BootWorks will replace
the old one if this option is checked. If you use local image storing, you will lose the image stored in
the existing partition.

2. Select Remove Compaq System Partition if you have an older model Compaq with a system parti-
tion and you don’t want it deployed to the other computers.

Other options can be entered in the Command-line switches field. For information on valid ImageBlaster
command-line switches, see “Making Image Files” on page 99.

Image Deployment Options - Resizing
By default, whenever you deploy an image, you have the option to resize the partition to take advantage of
the available disk space. The exception is Compaq partitions, which remain a fixed size. FAT16 file
systems have a 2 GB limit and cannot be resized.

Resize a Partition to a Specific Size, Highlight the Partition and then Choose one of the following:

• Select Fixed Size and then enter the size you want.
• Select Percentage and then enter the percentage of free space that you want the partition to occupy.

The Drive Size gives you information about the size of the image, so you can determine if you need to
change partition sizes. Minimum indicates the amount of space the image will use on the target
computers. Original indicates the image source disk size.

Example Script
The process to convert NT4 from FAT16 to NTFS normally returns a 1 after a successful completion. Here
is an example of the file that is modified to return a code of 0 (which is the success code recognized by the
Altiris Console and utilities). You can make similar changes to your script files as needed.

CONVERT /FS:NTFS
if ERRORLEVEL 1 goto success
goto failure
:success
set %ERRORLEVEL% = 0
goto end
:failure
echo Failed
set %ERRORLEVEL% = 1
goto end
:end
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Script Variables
The following case-sensitive variables are supported for DOS script files that run during Events. For
information about writing script files, see “Run a Script During an Event” on page 38.

These variables are also available for use in the file path specifications.

For example, you can specify

.\packages\%OSTYPE%\office2000.exe

. . . which would translate to:

.\packages\Win9x\Office2000.exe

. . . for computers running Windows 98 or Windows ME.

Table 10: Script Variable Descriptions

Variable Description

%NAME% Complete name of the computer in the database

%COMPNAME% Microsoft networking Computer Name

%ID% ID of the computer in the database (unique)

%MACADDR% MAC address of the computer

%SERIALNUM% Serial number of the computer (if it supports SMBIOS)

%ASSETTAG% Asset Tag of the computer (if it supports SMBIOS)

%IPADDR% IP address of the computer

%NODENAME% First 8 characters of the computer's name in the database (for LE 3 compatibility)

%NODEFULL% Complete name of the computer in the database (for LE 3 compatibility)

%MANUF% Manufacturer of the computer (if supported by hardware)

%UUID% UUID of the computer (if supported by hardware)

%DOMAIN% Workgroup or domain the computer is part of

%IPNAME% Full DNS name of the computer

%OS% Operating system (Win95, Win98, WinME, WinNT, Win2000)

%OSTYPE% Operating system type (Win9x, WinNT)
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Manage Computer Names in Domains
If you use a Microsoft domain controller to manage domains on your network, the computer names in your
images must be managed in the domain controller as well as the eXpress Server.

• If the eXpress Server is installed on a Windows NT or 2000 computer and the server can connect to
the domain, the server manages computer accounts/names in the domain for you. You don’t need to
perform any of the tasks described below.

• If the eXpress Server is installed on a Windows 95 or 98 computer, or if the server (on any platform)
cannot connect to the domain, you must manually manage the computers in the domain. The tasks
below describe how to manage the computer names.

If you manually add computers to a domain, keep the following rules in mind:

• The name of the image source computer cannot be used as a target computer name.
• Computer names must be newly-created entries in the domain.
• You must add the target computer names to the domain server before you deploy the Event.

Before you upload an image:

When you create an image source computer for uploading an image, give the computer a name that will
not be included in any computer name ranges you might choose in the configuration file. (The name
Source is recommended.) You must add the computer to the domain server before you upload the image.

Before you deploy an image:

If you selected Domain (instead of Workgroup) in the Computer Names tab of the Configuration Settings
screen (when you created the image file), you must add the computers to the domain before you deploy
the image. If computers are already domain members, the account must be reset in the domain.

LabExpert Import Wizard
You can import a LabExpert 3.x database into eXpress 5.0.

1. Choose File > Import Data > LabExpert 3 Database.

2. Locate the existing LabExpert data directory.

3. Choose OK.

The Console is populated with the LabExpert 3 computers.

Define Task Conditions or Filters
Condition/Filter Definition
Define the items you want in the filter or condition. For example, you might choose Computer Name as
the Field, Contains as the Operation, and Sales as the Value.

Add Computers to a Domain Controller
In most cases, you do not need to manually add computers to your domain. See “Manage Computer
Names in Domains” on page 66 to determine if you need to manually add computers or if the eXpress
Server manages this for you.

Add Computers to a Windows 2000 Domain Controller
1. Choose Start > Programs > Administrative Tools > Active Directory Users and Computers.

2. Highlight the Computers folder under the domain where you will add the computer.
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3. Choose Action > New > Computers.

4. Enter the computer name.

5. Check the box Allow pre-Windows 2000 computers to use this account. This box must always be
checked.

Add Computers to a Windows NT Domain Controller
1. Choose Start > Programs > Administrative Tools (Common) > Server Manager.

2. Choose Computers > Add To Domain.

3. Select the Computer Type (Workstation or Server, or NT Backup Domain Controller).

4. Enter the computer name. See “Manage Computer Names in Domains” on page 66 for rules to use
when naming computers.
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Remote Client Installer

Using the Remote Client Installer
With this tool, you can install AClient on computers remotely from a Console. Remote installation is
supported by Windows NT and 2000 operating systems only.

You must have administrative rights to the computers in order to install the software remotely.

Note: For Windows 95/98/Me, you must install AClient locally. There are several ways to do this. For
example, you can add commands to the client login script to map to AClient on your file server and run the
executable, or you can e-mail the executable or a shortcut to users and have them copy the file to their
local hard drives and run it from there.

Install New Clients
Important! If you are using PXE to boot your clients, you must set up the BIOS in each computer's
hardware setup program before PXE will work. Refer to your hardware documentation for information.

1. Open the installer by choosing the Remote Client Installer icon from the console toolbar, or select it
from the Tools menu.

2. Choose Add.

3. Enter the username and password of the account that has administrative rights to the computers that
you will add to the remote install list. If you don't use an account with the appropriate rights, the install
will fail.

4. Set up the client configuration as follows:

a. Enter or browse for the path to the name of the computer where you want to install AClient.
b. If you want to prevent users from modifying AClient settings, select Secure AClient properties

with a password.
c. If you are using domains and want to change the client security ID (SID) every time you image

the computer, select Enable Changing of Security ID.
d. Choose Advanced to change AClient settings from the default. Choose Next to use default set-

tings and select clients to add to the install list.

Note: Choose Help on any of the client wizard screens for details about the configuration
settings and options.

5. Browse the network and highlight the computers you want to add. You can choose multiple computers
from the lists. Choose OK. The computers appear in the installer list.

6. Choose Install. The status of the computers is shown on the installer screen.

7. After the installation is finished, reboot the client computers from the Console.

Install Clients From an Import File
You can use import files to automate remote client installations. The file imports parameters to the installer
program so you don’t have to enter them manually.
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Create the Import File
You can create a file or use one you already have, if it is properly formatted.

You can use the file to:

• Import computer names and administrator account information, and install AClient with default
parameters.

• Specify the name of a file to import configuration settings from, if you don’t want to use the defaults.

The parameters must be entered in the following order:

-c:[computer] -u:[username] -p:[password] -i:[input file]

The password is not required if the administrator account does not have one assigned. If you are using
the default settings, you don’t need to specify an input filename. Each entry must be on a separate line.

For example:

-c:comp1 -u:admin -p:secret

-c:comp2 -u:admin -p:secret -i:client32

Import Client Install Files
1. Open the installer by choosing the Remote Client Installer icon from the console toolbar or the Tools

menu.

2. Choose Import and browse to select the import file.

3. Choose the applicable option, depending on the client settings you want to use (default or custom).
The computers appear in the remote installer list as the import file is read.

4. Choose Install to install AClient on the computers with the configuration settings you chose.

Modify Existing Client Settings
To remotely modify AClient on computers where it is already installed, you will need to reinstall it with the
settings you want to change.

1. Follow the instructions for installing new clients, and add the clients you want to change to the remote
install list.

2. Make the modifications you want in the client configuration wizard screen.

3. Choose Install.

You can also change settings for computers in the remote install list, if they did not install correctly
(according to the status shown on the list).

1. Highlight the computer and choose Properties.

2. Enter the user account and password and choose Client Settings.

3. Change the settings.

4. Choose Install to reinstall AClient with the new settings.

Modify the Default Client Configuration File
If you have previously installed AClient using the Remote Client Installer, there is an existing configuration
file that contains the settings you used for the installation. If you want to install with different settings, follow
these steps:
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1. Open the installer by choosing the Remote Client Installer icon from the console toolbar, or select it
from the Tools menu.

2. Choose Default Client Properties from the Edit menu.

3. Modify the configuration settings.

4. Add computers that you want to reinstall with new configuration settings to the remote installer list.

5. Choose Install.
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Using the Boot Disk Creator

Create a New BootWorks Configuration
These instructions include the entire process for using the Boot Disk Creator for the first time to make an
initial configuration. For subsequent configurations, you might not need to complete all of the steps.

If the configuration is for PXE boot files, you must run the Boot Disk Creator on the computer that is your
PXE Server.

Gather Information
In order to create configuration files for BootWorks, you need the following information:

• The type of file server you are using on your network (Windows or NetWare)
• The type of NIC in the computers that you're making the boot files for (3com, Intel, etc.)
• The type of eXpress Server connection the computers will use (multicasting or static IP)
• The "static" IP address to each computer if you aren't using DHCP
• The name of your workgroup/domain (for Microsoft networks) or your server name (NetWare)
• The account name and password assigned to the eXpress directory

Get DOS System Files (Windows NT/2000/Me)
The Boot Disk Creator requires some DOS system files. If you are running the Boot Disk Creator on a
Windows NT, 2000, or Me computer, you'll need to get them from a Windows 95 or 98 PC. Use the
following steps to make a floppy disk with the files you need. The Boot Disk Creator will prompt you for it
later. You will only need to use this disk the first time you run the Boot Disk Creator on the NT/2000/Me
computer.

1. At a Windows 95 or 98 PC, insert the disk to be formatted.

2. Open Windows Explorer, right-click 3 1/2 Floppy (A:), choose Format, check Copy System Files,
and choose Start.

3. Copy himem.sys, emm386.exe, and ramdrive.sys (found in the Windows directory) to the floppy
disk.

4. Eject the floppy disk.

Create a Configuration
1. Open the Boot Disk Creator by choosing it from the console tool bar, or by choosing Start >

Programs > Altiris >Altiris Express > Boot Disk Creator.

2. Choose New Configuration.

Tip: If you already have a configuration similar to the one you are creating, you can copy the
configuration and then edit it to make the new one. Just right-click on the configuration and choose
Copy from the menu, then right-click on the "copy of" configuration and choose Edit from the menu.

3. Enter a name for the new configuration file, for example. Write a brief description of the file to help you
distinguish it from your other configuration files. Choose Next.

4. On the Client Installation screen, choose the kind of configuration file you want to make. Choose the
Client Installation Help button for information about the options, since the location of the boot files
(where computers run BootWorks) determines the type of configuration you create.
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5. On the File Server Type screen, choose the type of file server you have on your network. If your PCs
connect to a Novell NetWare server, choose the option that corresponds to the type of NetWare cli-
ents you have.

6. From the list of network adapter cards, choose the type installed in the computers that will use this
configuration. Choose Next to copy the drivers to the configuration file.

Note: Configuration files are NIC-specific. You must make a configuration file for each computer that
has a different type of NIC.

Tip: If your NIC does not appear on the list and you have a disk that came with the hardware, choose
Have Disk and follow the instructions to load the driver. The latest drivers for commonly-used NICs
are available on the Altiris web site. To download a driver from the web site, choose Internet and
follow the prompts. Some drivers need additional parameter settings to work properly. To enter the
settings, choose Advanced. See the User Support Forum on the Altiris web site for the latest
information about specific drivers, known problems and workarounds, and applicable driver settings.

7. Choose how your computers will use TCP/IP to communicate on the network in DOS. (BootWorks
runs imaging and registry backup/restore events in DOS before computers boot to Windows.) If you
use DHCP to assign IP addresses, choose Obtain an IP address from a DHCP server. If you assign
IP addresses manually, choose Use a static IP address and enter the required information.

8. Choose how BootWorks will connect to your eXpress Server.

If you want computers to use multicasting to connect to an eXpress Server, accept the default
multicast option, IP multicast address, and port number. If you have multiple eXpress Servers and you
want computers to connect to a specific server, use the default multicast settings and enter the
eXpress Server name in the server field.

Choose the option to connect directly to the eXpress Server using TCP/IP and enter the server's IP
address. If you are using the Intel Universal NIC driver (UNDI), or if your NIC doesn't support
multicasting, use this option.

9. Enter the name of the server where image files are stored (for a NetWare network). Or, enter the
Domain or Workgroup (for a Microsoft network).

10. Enter the user name and password of the account you created when you set up the eXpress directory.

11. If you want the computer drive mapping to be part of the autoexec.bat file, choose Manually create
drive maps. If you are using NetWare and you want the client login scripts to create the drive map-
ping, choose Use login scripts to create drive maps. Click Next.

12. Review your configuration choices. To make changes, choose Back to get to the applicable screen.
To finish the configuration file, choose Finish.

You can now use the configuration to make boot files.

Create and Install BootWorks Boot Files
To install BootWorks using an existing configuration, follow these steps. To install BootWorks remotely on
Windows NT or 2000 computers using defaults, right-click on a computer or group at the Console and
choose Advance > Install BootWorks. This installs BootWorks using default configuration information
(entered when you installed eXpress), and settings from AClient running on the computer.

1. From the dialog box that appears after you create a configuration, select the type of boot files you
want to make.

or,

From the task bar, choose the media/boot file type you want to create (disk, PXE boot file, or windows
install package) and then choose the configuration file you want to use. Configuration files are
somewhat dependent on the boot file type; configurations do not work with all boot file types.
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Note: If you have not created a configuration yet, choose New Configuration from the taskbar and
complete the steps in “Create a New Configuration, above.

2. Follow the prompts to create the boot file.

• To install BootWorks on Windows 95, 98, or Me computers, create boot disks to install locally.
• To install BootWorks boot files for PXE, create PXE files on the computer that is your PXE Server.
• To install BootWorks on Windows NT or 2000 computers, you can create a Windows Install Package

and include it in an Event that you deploy from the console. See “Create and Edit Events” on page 34.

Edit An Existing Configuration
1. Highlight the configuration you want to edit from the Configurations list.

2. Right-click on the configuration and choose Edit Configuration from the menu.

3. Go through the screens and modify the options you want to change.

4. Choose Finish to save the new settings.

Edit BootWorks Network, System, and Batch Files
1. From the Configurations list in the Boot Disk Creator, double-click the configuration whose batch

files you want to edit.

2. Choose the batch file you want to edit.

3. Type Ctrl S to save the changes, or choose File > Save Batch file.

Add Files to a BootWorks Configuration
You can customize your configurations by adding text files and executable files (such as DOS utilities).
There are two ways to add these files.

• Add files to a single configuration
• Add files by default to all BootWorks install files (Windows install packages and install boot floppies).

Add Files to a Specific Configuration
1. From the Configurations list, highlight the configuration where the file will be added.

2. Choose the configuration to view it's list of folders.

3. Right-click on the folder where you want to add the file and choose Add File from the menu.

4. Browse for the file to add and choose Open. The file appears in the list.

5. Add the command to load or run the file to the appropriate *.bat or *.ini file.

Add Files to All BootWorks Installs
1. Choose Additional Include Files > Add File.

2. Enter the path and filename, or select it from the list.

3. Choose Open. The file appears in the file list.

4. Add the command to load or run the file to the appropriate *.bat or *.ini file.

View Configuration Settings
To view information about a configuration, highlight it in the Configuration list. The description you entered
when you created it appears in the top pane, and a summary of the settings is listed on the right.
 2000 Altiris, Inc. page 73



If you need to modify settings, see “Edit An Existing Configuration” on page 73.

Troubleshooting NIC Drivers in BootWorks
General Guidelines for using NICS in DOS
Set your NIC to half duplex. Full duplex does not always work well with DOS.

Disable Plug and Play OS in the BIOS, if you have this setting.

Look for a music note symbol on the interrupt line of the protocol.ini file. If there is one in the line, delete it.

If you have an ISA NIC, make sure the interrupt and IP address are correct.

Don't use a NIC with a DOS driver larger than 70 kb.

In most cases, modifying your config.sys with these settings works well:

DOS= High,UMB

Buffers = 30,0

Files = 40

Network Card settings you can modify
The type of settings you can modify depends on your client type.

Microsoft clients

• Emm386. Append memory address information to this line in the config.sys file.
• Advanced. Add parameters to the NIC section of the protocol.ini file.
• Memory. Add parameters to the network setup section of the protocol.ini file.
• IRQ. Add parameters to the network setup section of the protocol.ini file.

Novell VLM clients

• Emm386. Append memory address information to this line in the config.sys file.
• Advanced. Add parameters to the NIC section of the net.cfg file.

Novell Client 32

• Emm386. Append memory address information to this line in the config.sys file.
• Advanced. Add driver command-line entries to the landrv.bat file.

You can find additional driver information in the User Support Forum on the Altiris web site.

If your driver doesn't work, contact your vendor for information about using the driver in DOS.

The emm386 file has been included in the Bootworks configuration file to help resolve memory problems
with some network drivers loading on regular client PCs. However, this might cause problems on some
laptops. If you get an emm386 error, REM the line in the autoexec.bat file.

NIC drivers sometimes have memory conflicts issues that can be resolved by excluding a memory range.
You can edit the emm386 line to solve the problem. (The following setting works well in most cases.)
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emm386 auto noems x=D700-D7FF

The Boot Disk Creator automatically detects most card bus service drivers. If the service is not detected,
enter a command to load it in autoexec.bat and add it to your configuration. The service comes from the
NIC vendor. It is not the same for all NICs.

If the Boot Disk Creator does not detect a driver or has no listing for your driver type, do the following when
creating the configuration:

1. Select any driver from the current list.

2. Edit the driver name entry in the applicable files, depending on the client type:

Microsoft: protocol.ini, system.ini (netcard=drivername in [network drivers] section)

NetWare VLM: net.cfg, autoexec.bat, startnet.bat, stopnet.bat

NetWare Client 32: net.cfg, autoexec.bat, landrv.bat, stopnet.bat

3. Add the driver file to the configuration. See “Add Files to a BootWorks Configuration” on page 73.

Uninstall BootWorks
There are three ways to uninstall BootWorks.

• Using BootWorks install disks (if you used floppy disks to install BootWorks originally)
• Using a Windows Uninstall Package from the console or the Boot Disk Creator
• Using an uninstall disk

Use BootWorks Install Disks
If you have the floppy disks that you used to install BootWorks on the computer, you can use them to
uninstall as well.

1. Insert the BootWorks Install Disk (disk 1) into the computer you want to uninstall

2. When the prompt appears asking if you want to install BootWorks, type N.

3. At the command line, type bwinst -u.

From the Boot Disk Creator
1. Choose Tools > Create a BootWorks Windows Uninstall Package.

2. Enter the path and package filename, or accept the default path and name.

3. Choose Next > Close.

From the Console
1. Choose File > New > Event.

2. Locate the new event in the Events list and open it.

3. On the Event screen, choose Add > Distribute software.

4. Enter the path and filename to the Windows Uninstall Package. The default path the filename is
.\bwpkgs\bwuninstall.exe.

5. Run the event on the computer you want to uninstall.

Using an Uninstall Disk
1. If you haven't yet created an uninstall disk, make one using the Boot Disk Creator.

Choose Tools > Create a BootWorks Uninstall Disk. When prompted, insert a disk into Drive a: and
choose Next.
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2. To use the disk to uninstall BootWorks from a computer, insert the disk into the computer and start or
restart the computer from the Windows Start menu. When prompted to uninstall BootWorks, type Y.
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eXpress Server Manager

Using the eXpress Server Manager
You can use the eXpress Server Manager to:

• Stop (shut down) an eXpress Server.
• Restart an eXpress Server.
• View server activity and statistics.
• Map drives to file servers in your Altiris system (if you have images stored in more than one place).
• Set the communications protocol (multicast or TCP).
• Set imaging multicast threshold.

Run the Server Manager by logging into the eXpress Server you want to manage.

Specifying the eXpress Server Service Account
This Service Logon Account dialog is used to specify the account used by the eXpress Server service.

Specify or Change the eXpress Server Service Account
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Account.

3. Choose whether you want to use the LocalSystem account or a user-defined account. If you choose a
user-defined account, you must enter the username and password.

4. Click OK.

Table 11: Service Logon Account Dialog Descriptions

Item Description

Use the Local System account Specifies that the LocalSystem account should be used by the eXpress Server
service. You can use this option if your eXpress directory is located on the same
computer as the eXpress Server and you do not need to manage computers in a
domain.

Use the following account and password Specifies that a user-defined account should be used by the eXpress Server
service. If this option is selected, you must supply the appropriate username and
password. The account must have Administrator equivalent rights on the eXpress
Server computer. You must use this option if your eXpress directory is located on
a different server than the eXpress Server.
 2000 Altiris, Inc. page 77



Starting and Stopping the eXpress Server Service
The Altiris eXpress Service Configuration dialog allows you to view eXpress component statistics, start and
stop the eXpress Server, and access eXpress Server configuration options.

View Server Activity and Statistics
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click OK when done.

Start, Stop, or Restart the eXpress Server
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Start, Stop, or Restart.

3. Click OK.

Working with eXpress Server Drive Mappings
This Altiris eXpress Server Options dialog Drive Mappings tab is used to add, edit, and delete drive
mappings used by the eXpress Server.

Any drive mappings used by the Console to reference files need to be duplicated here.

For example, if you create an event that distributes a software package from a drive on another file server,
which is mapped to the G: drive on the Console, you will need to create a drive mapping on the eXpress
Server for a G: drive, which is mapped to the same drive as the G: drive on the Console.

Table 12: Altiris eXpress Service Configuration Dialog Description

Item Description

Server activity and statistics Lists the number of eXpress sessions (clients), servers, and Consoles currently
running on the network.

Start Starts the eXpress Server on the local computer.

Stop Stops the eXpress Server on the local computer.

Restart Restarts the eXpress Server on the local computer.

Account Opens the Server Login Account dialog, which allows you to specify the account
used by the eXpress Server service.

Options Opens the Altiris eXpress Server Options dialog, which allows you to specify
eXpress Server options

Table 13: Drive Mapping Tab Descriptions

Item Description

Drive Letter and UNC Path Displays the drive mappings with the mapped drive letters and the corresponding
UNC paths

Add Opens the Map Drive dialog, which allows you to create a drive mapping.

Edit Opens the Map Drive dialog, which allows you to edit the drive letter or UNC path
of the selected drive mapping.
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Create a Drive Mapping
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Drive Mappings tab, if it is not already selected.

3. Click Add.

4. Specify the Drive Letter and UNC Path.

5. Click OK.

6. Click OK.

7. Click Yes to restart the service, so the changes can take place.

Edit a Drive Mapping
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Drive Mappings tab, if it is not already selected.

3. Select the drive mapping you want to edit and click Edit.

4. Modify the Drive Letter and UNC Path as desired.

5. Click OK.

6. Click OK.

7. Click Yes to restart the service, so the changes can take place.

Remove a Drive Mapping
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Drive Mappings tab, if it is not already selected.

3. Select the drive mapping you want to remove and click Remove.

4. Click Yes to confirm your decision.

5. Click OK.

6. Click Yes to restart the service, so the changes can take place.

Specifying the eXpress Server Transport
This Altiris eXpress Server Options dialog Transport tab allows you to specify the eXpress Server
transport.

Remove Removes the selected drive mapping.

Data store path Specifies the path to the eXpress files. The default path is c:\express

Table 14: Transport Tab Item Descriptions

Item Description

Disable multicast support (clients must
connect using TCP)

Disables multicast support, which means clients must connect to the eXpress
Server using TCP.

Multicast Address The multicast address. This is used only if multicast is not disabled.

Multicast Port Port used for the multicast. This is used only if multicast is not disabled.

Table 13: Drive Mapping Tab Descriptions

Item Description
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Specify the eXpress Server Transport
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Transport tab.

3. Do one of the following, depending on the transport you want to use:

• If you want to use multicast, do not select the Disable multicast support checkbox.
• If you want to use TCP, select the Disable multicast support checkbox and supply the

Multicast Address, Multicast Port, Multicast TTL, and TCP Port.

4. Click OK.

Setting Disk Imaging Options
This Altiris eXpress Server Options dialog Disk Imaging tab allows you to specify when image
multicasting is used and how much bandwidth is used during multicasting.

Set When Multicasting is Used
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Disk Imaging tab.

3. Do one of the following, depending on when you want to use multicasting:

• If you do not want to use multicasting, select the Use disk image multicast threshold of n
clients checkbox and set n to 0.

Multicast TTL Specifies the number of hops or hubs that the client can go through to multicast.
This is used whether multicast is enabled or disabled.

TCP Port The TCP port. This is used whether multicast is enabled or disabled.

Automatically update clients Automatically updates the Altiris Client for Windows on managed computers if
there is a difference (older or newer) between the client available in the eXpress
directory and the managed client.

Table 15:

Item Description

Use disk image multicast threshold of n
clients

Specifies the number of clients that must be involved in an event before image
multicasting is used. If the number of clients is less than or equal to the number
specified, multicasting is not used. Set this value to 0 to disable multicasting. If
this option is not selected, multicasting will be used whenever there are two or
more clients.

When multicasting is not used, all clients become “Masters” and will read from the
image server independently. This option might be used if your clients can read an
image file from the server faster than trying to coordinate masters and clients.

Limit each disk image multicast to n
Mbps.

Limits the bandwidth used in a multicasting session to a user-defined number of
Mbps. This option prevents the multicasting operation from using all of the
available bandwidth on a network, so other network traffic can take place at a
reasonable rate.

Table 14: Transport Tab Item Descriptions

Item Description
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• If you want to use multicasting whenever there is more than one client, do not select the Use
disk image multicast threshold of n clients checkbox.

• If you want to use multicasting only when there are more than a specific number of clients, select
the Use disk image multicast threshold of n clients checkbox and set n to the number of cli-
ents there must be more than before multicasting is used.

4. Click OK.

Set the Maximum Bandwidth Used During Multicasting
1. Open the Altiris eXpress Server applet in the Control Panel of the eXpress Server computer.

2. Click Options, and select the Disk Imaging tab.

3. Select the Limit each disk image multicast to n Mbps checkbox and set n to the maximum band-
width you want a multicasting operation to use.

4. Click OK.

Map Drive
These settings are used to create or edit drive mappings.

Table 16: Map Drive Dialog Item Descriptions

Item Description

Driver Letter Drive letter to which the drive mapping is mapped.

UNC path UNC path to which the mapped drive points.
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PXE Configuration Tool

Using the PXE Configuration Tool
Run this tool on the PXE Server to change server settings or to modify the PXE boot files. Configuration
changes to the PXE Server cannot be done remotely.

• Modify the PXE boot files (network driver, IP information, etc.) used by managed and new computers.
• Manage boot menu options.
• Control which client computers your PXE Server will respond to (for installations with several eXpress

systems on the same network).

Create or Replace the PXE Boot Files
Follow these steps to modify the PXE boot files on the computer where you are running the utility. Both
boot files (Managed and New Computer) are replaced when the configuration is changed.

1. Open the PXE Configuration tool from the Windows Start menu by choosing Start > Programs >
Altiris > Altiris eXpress > PXE Config.

2. Choose Make Boot Files. The Boot Disk Creator tool is launched. Defaults indicate current options
chosen for the boot file.

3. Accept the defaults for the settings you want unchanged, and modify the settings that need to be
changed. If you need details about the options on any of the screens, choose Help.

4. Choose Finish to save the new boot files. They will be saved to the boot file area automatically. (The
directory path is not modifiable.) Client computers requesting boot services will now use these new
files.

Manage Boot Menu Options
To change boot menu items, run the PXE configuration tool on the PXE Server. Configuration changes to
the PXE server cannot be done remotely.

You can change the following behavior of the boot menu:

• Change the default boot option.
• Change the prompt that brings up the boot menu.
• Change the boot menu timeout.
• Add, change, or delete menu items.

Change the Default Boot Option
The first item in the boot option menu is the default. To change the default option, simply move the option
that you want to be the default to the top of the menu.

1. Choose Start > Programs > Altiris > Altiris eXpress > PXE Config.

2. From the PXE Boot Configuration screen, highlight the desired default and choose Up until it is at
the top of the list.

3. Choose OK to save the menu.
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Change the Boot Menu Prompt
To change the text message that appears on client computers while they are booting,

1. Choose Start > Programs > Altiris > Altiris eXpress > PXE Config.

2. Modify the Prompt text and choose OK.

Change the Boot Menu Timeout
Change the length of time the boot prompt is displayed before the boot process starts,

1. Choose Start > Programs > Altiris > Altiris eXpress > PXE Config.

2. Change the Timeout value to the number of seconds you want the prompt to be displayed.

3. Choose OK.

Note: If the F8 key is not pressed within the timeout period, the default boot option is run.

Add, Change, or Delete Menu Items
1. Choose Start > Programs > Altiris > Altiris eXpress > PXE Config.

2. Do one of the following:

• To add a new item to the menu, choose New. On the Menu Item Properties screen, enter the text
for the new menu item.

• To change an existing option, highlight it and choose Edit. On the Menu Item Properties screen,
change the menu item text if desired.

• To delete an item from the menu, highlight the option and choose Delete.

3. To have managed computers query an eXpress Server for the default boot option instead of using the
PXE Server defaults, select Query eXpress Server for boot control. Enter the IP Address and Port
of the server. By default, this option is selected and the file server is selected for you. If you decide not
to use the option, each computer uses the default boot option on the PXE Server.

Note: When a computer contacts the PXE Server for boot files, the eXpress Server determines the
computer’s boot option as follows:

• If the computer is managed (known to the eXpress Database), but no work has been assigned,
the Local Boot option is chosen.

• If the computer is managed and a DOS event (such as imaging or a registry task) is assigned,
the eXpress Server boots the computer with the managed computer boot file.

• If the computer is new (not known to the database), the new computer boot file is used.

4. Choose OK.

Control a PXE Server's Response to Client Boot Requests
Run this tool on the PXE Server to change boot menu options. Configuration changes to the PXE Server
cannot be done remotely.

PXE was designed to allow computers to boot from any PXE Server, of any type, on the network. By
default, PXE Servers respond to all client requests for boot files, lowering your management overhead.

In most cases, this model works very well, and you will not need to set advanced options for your PXE
Server. However, if you have multiple eXpress systems installed on your network, you might want to
control which client boot requests your PXE Server responds to. This prevents it from booting clients that
are not managed by your eXpress Server or require a boot file with a different configuration.
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Change advanced options as follows:

1. Choose Start > Programs > Altiris > Altiris eXpress > PXE Config.

2. Choose Advanced on the PXE Boot Configuration menu.

3. You should read the information about the options and their implications before changing any of the
defaults.

4. Choose OK.

Using BIS in your PXE Environment
If you are using PXE boot files to manage your computers and you want to secure the computers so they
accept only certified images, you can set up BIS configuration boot files and certificates to do this. BIS
allows you to "sign" boot files stored on the PXE Server with a certificate. Managed computers can be set
up to accept only boot files that have the correct certificate.

Warning! Once a certificate is installed, managed computers will require boot files with the certificate they
are assigned. If you delete the certificate from the PXE Server, the client will not boot! If you want to
remove a certificate, you must uninstall it from the managed computer before deleting it from the PXE
Server!

Requirements:

• Your hardware (managed computers and PXE Server) must be PXE and BIS compliant.
• PXE must be installed in your eXpress system.
• You can have only one PXE Server on your network.
• You must have an eXpress Console installed on the PXE Server

1. Create a BIS configuration boot file on the PXE Server.

a. Start the Boot Disk Creator on the PXE Server.
b. Select Tools > Create BIS Config Image.
c. The Create Image screen appears, showing the path where the file will be created. (The path

and filename are not modifiable.) Choose Next to create the BIS boot file.

2. Set up the certificate/signature on the PXE Server.

a. From the Console on the PXE Server, choose Tools > BIS Configuration.
b. Enter your password and choose Create.
c. Choose Sign Boot Images > Close.

3. Install the certificate on managed computers.

a. Reboot the managed computer.
b. When prompted to Select boot option (F8 for menu), press F8.
c. From the boot menu, choose Install BIS certificate.

d. At the Console on the PXE Server, locate and select the computer in the Computers list.
e. Right click and choose Install BIS certificate from the menu.
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Appendix A: Command-Line

The purpose of this section is to provide detailed usage information about Altiris eXpress 5.0 features. It
includes descriptions of how the features work, and command-line parameters and options that you can
use in script files and for troubleshooting.

For step-by-step instructions on how to do common tasks, see the Help contents. The Help buttons on
each screen also have detailed information about how to decide which options to choose and what
information to enter to complete your tasks.

Aclient (Altiris Client for Windows)

Managing Client Computers

Client Connectivity and Network Adapters (NICs)
Altiris supports all standard network adapter cards, and we include many of their drivers with our software.
However, sometimes outdated drivers (including default drivers that come with the hardware) cause
problems when clients are in BootWorks mode. To avoid problems, you should check your NIC
manufacturer’s web site to make sure you use their latest driver in your BootWorks configuration file.

Some common client problems that can be solved by updating drivers are:

• Locking when loading drivers or failing to connect to the server
• Locking when imaging (downloading, uploading, or multicasting)

Microsoft Client Drivers
The Boot Disk Creator is set up to work with drivers that follow a certain standard. Since not all NIC drivers
follow that standard, files may need to be moved to a different location. These three files must be in the
same directory:

• The DOS driver for your card (drivername.dos)
• The sample protocol.ini that comes with your driver (protocol.ini)
• The OEM setup file that specifies the DOS driver (oemsetup.inf)

For example, the OEM setup file will contain lines similar to the following:

[netcard]

NGRPCI=”NETGEAR FA310TX Fast Ethernet PCI
Adapter”,0,ndis,ethernet,real,NGRPCI,NGRPCI_NIF

[NGRPCI] (This header must be the sixth item listed in the line above)

Device=NGRPCI.DOS (If this line is missing, add it. The syntax is device=drivername.)

If there is no protocol.ini file, create a text file that contains the following command:

DriverName=drivername
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Novell Client Drivers
The Boot Disk Creator does the following:

• Searches all subdirectories for a directory that contains *.ins, *.com, and net.cfg files. (They must be
in the same directory.)
The .ins file is then opened to get information about the network card.

• The program searches the file for a line starting with a carat (^). This line must have at least two
values listed, separated by a comma. The two values needed are the description of the card (value1),
and the .com driver file name (value2).
For example, ^3Com EtherLink III Parallel Tasking Family, 3C5X9.com

Managing Computers on Different Network Segments
If you manage client computers on different network segments, you might have problems using
multicasting because some routers and hubs don’t handle it correctly.

To solve the problem, you will have to change the aclient setting on the computers from multicast (which is
the default) to communicate directly with the eXpress Server via TCP/IP. Step-by-step instructions for
setting this up are in Help. Choose Connecting Client PCs on a Different Segment from the Table of
Contents.

Managing Computers on a Network with More Than One eXpress Server
If multiple eXpress Servers are running on your network, client computers can register with and receive
work from any of them. If you want clients to communicate with a specific eXpress Server, you will have to
specify the Server name in the client settings.

How Aclient.exe Works

The aclient executable installs and runs on client computers, enabling them to be managed by an eXpress
Server. It enables clients to receive work from the eXpress Server, and it reports client status to the Server.

The program is normally installed and configured remotely using the Client Install wizard, or the program is
run at the client computer. However, you can use the command-line options to run it from a script file if you
want to. (If you use a script file, see the following section on aclient.inp for information on using an import
file to specify install parameters for aclient.)

You can use either a forward slash (/) or a dash (-) with the command-line options. Commands are not
case sensitive.

Table 17: Aclient.exe Command-Line Parameters

Parameter Details

-ver Function: Shows the version of aclient.exe running on the computer.

-install Function: Installs the client.
Option: -silent allows install to complete without sending output to the client.
Example: To install aclient.exe from the express directory without sending messages to the client, type

express /aclient /install /silent

-remove Function: Removes (uninstalls) aclient.exe from a computer.
Option: -silent removes the aclient without sending output to the client.
Example: To remove aclient, type

aclient -remove
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How Aclient.inp Works

You can use this input file to set installation parameters for aclient.exe, so you can install the client
program from a script file. The file is copied to the eXpress program directory when you install the product.
Command-line parameters are included in the file, but are marked with a REM statement.

To use the input file, open it and remove the REM commands from the parameters you want to use. When
you have the file set up the way you want it, you can run it by entering the file name as the first parameter
after the aclient command. You can also put the same line in a script file if you want to run it from a file.
Type

aclient aclient.inp

The input file name (aclient.inp) and InstallDir parameters are required; all others are optional.
Parameters are case sensitive.

-start Function: Manually starts aclient.exe on a computer.
Option: -silent starts the aclient.exe without sending output to the client.

-stop Function: Manually turns off aclient on a computer.
Option: -silent turns off aclient without sending output to the client.

Table 18: Aclient Install File Parameters

Parameter Details

ForceReboot Function: Specifies how the system should be shut down and rebooted. Applications are forced
closed and the system shuts down even if programs hang. (User data could be lost.)
Example: To force clients to reboot when a reboot task is assigned, type

ForceReboot=Yes

The default is “No.”

HardTimeout Function: Specifies the length of time (in seconds) that aclient.exe will maintain an idle connection
with the eXpress Server. After the time limit is exceeded, the client will disconnect and then
establish a new connection with the Server.
Example: To establish a new connection with the eXpress Server whenever the connection is idle
for 900 seconds, type

HardTimeout=900

InstallDir
(required)

Function: Specifies the full path name to the directory where aclient.exe will be installed. The
default location is c:\altiris\aclient.
Example: To change the default location, replace it with a new path. Type

InstallDir=c:\programs\aclient

LogFile Function: Specifies the full path name to the log file.
Example: To write log entries to a log file in your aclient directory, type

LogFile=c:\altiris\aclient\aclient.log

LogSize Function: Sets the maximum log file size (in bytes).
Example: To set the log file size limit to 4096 bytes, type

LogSize=4096

Table 17: Aclient.exe Command-Line Parameters

Parameter Details
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MCastAddr Function: Specifies the multicast group address to be used to find the eXpress Server.
Example: To set the IP address for multicasting, type

MCastAddr=225.1.2.3

MCastPort Function: Specifies the port number to use for multicasting.
Example: To use port 402 for multicasting, type

MCastPort=402

Password Function: Sets a password on the client to prevent users from accessing aclient.exe settings.
Example: To lock the settings, type

Password=clientmanager

PromptExecute Function: Sends output (messages) to the client when tasks are being executed.
Options: Yes, No
Examples: To allow prompts and messages to be sent to the client, type

PromptExecute=Yes

To suppress output, type
PromptExecute=No

PromptOverride Function: Specifies the default action to take when there is no user response to a restart prompt.
Options: Abort, Continue
Examples: To abort the client reboot, type

PromptOverride=Abort

To reboot the client, type
PromptOverride=Continue

PromptReboot Function: Prompts the user before restarting the client.
Options: Yes, No
Examples: To prompt for user input before restarting a client, type

PromptReboot=Yes

To restart a client without requiring user input, type
PromptReboot=No

PromptSeconds Function: Specifies the length of time (in seconds) that the client will wait for a response from the
user.
Example: To wait 30 seconds for user input, type

PromptSeconds=30

ShowTrayIcon Function: Specifies whether or not to show the Altiris client icon in the system tray. If the icon is
not in the tray, users can’t access Aclient.
Example: To not show the icon, type

ShowTrayIcon=No

The default is “Yes,” which loads the icon into the system tray.

SpeedLimit Function: Sets the minimum transfer rate accepted from the eXpress Server (in bytes per
second). If aclient.exe cannot receive data from the Server at this rate, it will disconnect and retry
at specified intervals. See HardTimeout below.
Example: To set a minimum ransfer rate of 7500 bytes per second, type

SpeedLimit=7500

TcpAddr Function: Specifies the IP address of the eXpress Server that the client will connect to. Using this
parameter causes the client to use TCP instead of multicasting to connect to the Server.
Example: To have the client connect to an eXpress Server using its IP address, type

TcpAddr=192.1.2.3

Table 18: Aclient Install File Parameters

Parameter Details
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BootWorks (Altiris Client for DOS)
BootWorks (bootwork.exe) manages client-server connections in DOS for imaging and registry
management tasks.

BootWorks Parameters and Switches
Parameters and switches for Altiris program files can be used in batch files and from the command line,
usually for troubleshooting. Under normal circumstances, the program interfaces and wizards provide the
tools you need to manage your network; you won’t need to manually edit files.

TcpPort Function: Specifies the port number of the eXpress Server listening for requests. Using this
parameter causes the client to use TCP to connect to the Server.
Example: To specify the port number of the eXpress Server to connect to, type

TcpPort=402

TTL Function: Sets the maximum number of hops to multicast through.
Example: To limit the number of hops to 32, type

TTL=32

UpdateFileSystemSids Function: Specifies if you want SIDgen to update permissions on any local NTFS volumes. This
parameter only applies if you have domains and use SIDgen to manage the computer IDs.
Example: To update permissions on the local NTFS volume, type

UpdateFileSystemSids=Yes

The default is “No.”

UseRCDrivers Function: Specifies whether or not to install keyboard and mouse filter drivers that enable remote
control on Windows NT and 2000 client computers. (The default is “No,” so the drivers are not
installed. This parameter is not necessary for Win 95/98 computers, because they don’t require
Ctrl-Alt-Del input to log in.
Example: To install the drivers for remote control, type

UseRCDrivers=Yes

UserName Function: Associates a computer with the primary user or users. This is used to target RIP
deployments to a specific user or group of users. To assign more than one user, separate the
names with semicolons.
Examples: To associate user Fred with the client being installed, type

UserName=Fred

To associate users Fred and Sam with the client, type
UserName=Fred;Sam

ServerName Function: Specifies the computer name of the eXpress Server that you want the client to connect
to. This is useful if you have multiple eXpress Servers on your network and you don’t want the
client to connect to the first Server it finds.
Example: To restrict client connection to a Server named “Server3,” type

ServerName=Server3

Table 18: Aclient Install File Parameters

Parameter Details
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Bootwork.exe parameters
You can use either a forward slash (/) or a dash (-) with the command-line options. Commands are not
case sensitive.

Table 19: Bootwork.exe Command-Line Parameters

Parameter Details

-dsbios Function: Disables reading of the BIOS for system information. This is typically used for
troubleshooting, if a client computer crashes when it first starts running BootWorks.
Example: To load and run BootWorks without reading the BIOS, type

bootwork -dsbios

-f Function: Causes a computer to pause during the BootWorks boot process and wait for a job from
the eXpress Server, instead of booting to production if work is not assigned. This allows new
computers that need to run the Initial Deployment Event to wait for a connection to the Server.
Example: To have a new computer wait for the eXpress Server to assign a job, type

bootwork -f

-hr Function: Specifies a hard reboot when a client computer boots to production. This is the default. It
ensures the BootWorks boot data is cleared from memory, so the computer reads the MBR when
booting to production. If this is not used, the client computer might lock up when it reboots.
Example: Because this is the default, you don’t need to enter anything.

-ip<address> Function: Specifies the IP address of the eXpress Server you want the client to connect to. Use this
if the network is not configured for multicasting, or if there is more than one eXpress Server on the
network. Specifying the Server’s IP address prevents the client from connecting to the wrong
eXpress Server. The port number must also be specified if you change this parameter. (See -
p<port>.)
Example: To connect a client directly to an eXpress Server, type

bootwork -ip207.197.28.38

-mcdelay[xx] Function: Sets the number of seconds the client waits between multicast requests for an eXpress
Server. The default is 5 seconds.
Example: To set the interval for multicast requests to10 seconds, type

-mcdelay10

-mcwait[xx] Function: Sets the length of time (in seconds) that the client searches for an eXpress Server before
rebooting to production. The default is 30 seconds. This parameter applies to multicast sessions
only. It does not apply if the clients connect using the Console IP address.
Example: To have the client search for an eXpress Server for 45 seconds, type

-mcwait45

-mip<IPaddress> Function: Specifies the multicast IP address of the eXpress Server. The default value is 225.1.2.3. If
the address is changed on the Server, use this parameter to change the address in BootWorks so
the client looks for the correct address. The port number must also be specified if you change this
parameter. (See -mp<port>.)
Example: If you changed the eXpress Server’s multicast address to 225.12.12.13, you would
change the address for BootWorks by typing

bootwork -mip225.12.12.13
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-mp<port> Function: Specifies the multicast port address of the eXpress Server. The default value is 402. If
you have changed the port number of the Server, use this parameter to change the number in
BootWorks. (Any unassigned number that is less than 65536 is valid.) The IP address must also be
specified if you change this parameter. (See -mip<address>.)
Example: If the eXpress Server’s IP address was changed and you set a new port number of 1026,
type

bootwork -mp1026

-name Function: Prompts the user to enter the name of the client computer. This name will be registered in
the Console “Computers” list. If no name is specified, the client computer’s MAC address will be
used.
Example: To prompt for a computer name, type

bootwork -name

The client computer will prompt you to enter a name. The name appears in the “Computers” list on
the Console.

-new Function: Runs the Initial Deployment Event.
Example: To run the Initial Deployment Event on a client computer, type

bootwork -new

-nologin Function: Loads the LAN drivers on the client so BootWorks can check the eXpress Server for work
without completing a user login.
Example: To load the network drivers and check the eXpress Server, type

bootwork -nologin

-p<port> Function: Specifies the port number of the eXpress Server you want the client to connect to. The
default port number is 402. If you have changed the port number of the eXpress Server, use this
parameter to change the number in BootWorks. (Any unassigned number that is less than 65536 is
valid.) The IP address must also be specified if you change this parameter. (See -ip<address>.)
Example: If the eXpress Server’s port number has been changed to 1026 and clients are not
multicasting to find the Server, type

bootwork -p1026

-pause Function: Causes the computer to pause for 5 seconds before beginning production boot
processes. This allows time to access the bootworks program before the computer boots to
production.
Example: To add a 5-second pause before a production boot, type

bootwork -pause

-s<name> Function: Specifies the computer name of the eXpress Server you want the client to connect to.
Otherwise, if you have more than one Console on the network, clients will connect to the first one
they find.
Example: If you want a client to connect only to an eXpress Server named ServerOne, type

bootwork -serverone

-sr Function: Specifies a soft reboot when a client computer boots to production.
Example: To reboot a client using a soft reboot instead of the default hard reboot, type

bootwork -sr

-wb Function: Specifies a warm reboot when a client computer boots to production.
Example: To reboot a client using a soft reboot instead of the default hard reboot, type

bootwork -wb

Table 19: Bootwork.exe Command-Line Parameters

Parameter Details
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BootWorks Install (Bwinst) parameters
BootWorks is installed by bwinst.exe, so if you have problems installing you might need to edit these
settings in the BootWorks autoexec.bat file.

Parameters are case sensitive. Use a space between the command and the switch, and between switches
if you use more than one.

Table 20: Bwinst.exe Command-line Switches

Switch Details

-mbr Function: Rewrites the BootWorks MBR code and exits.
Example: If the BootWorks code is overwritten by another program and you want to rewrite it to the boot
record, type

bwinst -mbr

-u Function: Uninstalls BootWorks.
Example: To uninstall BootWorks from a client, type

bwinst -u

-c Function: Checks for Altiris MBR code.
Example: To find out if BootWorks is installed on a client, type

bwinst -c

-s[x] Function: Works with the -old switch to set the partition size (in MB) for hidden BootWorks partitions. The
minimum size is 5 MB, which is the default.
Note: If you install embedded BootWorks (new style for 4.x versions), this switch does not apply. A 5MB
embedded partition is always installed.
Example: To set the BootWorks partition size at 10 MB for a hidden partition, type

bwinst -s10 -old

-old Function: Installs a hidden (old style) BootWorks partition instead of an embedded (new style) partition.
The default size is 5 MB. To install a larger partition, use the -s switch.
Note: When this partition is installed, it will overwrite any data on the drive it is installed to. Make sure the
drive is empty, or upload an image of the drive, and then download it to a different drive after BootWorks is
installed.
Example: To install a hidden BootWorks partition of 30 MB, type

bwinst -s30 -old

-q Function: Runs BootWorks install in “quiet mode,” so no user input is required to complete the install. This
switch is intended for use with unattended installs, so you should use it in conjunction with the -f switch to
install from a file instead of disks.
Since there are no prompts, bwinst makes the following decisions/assumptions.
• If a partition is found, you won’t be asked if you want to move or overwrite the

partition. BootWorks will automatically overwrite the partition and existing data will
be erased.

• You won’t be prompted for the second BootWorks disk. You’ll see a message that
a file could not be found.

• If you’re installing an embedded partition, it is assumed that NT Service Pack 4 is
installed.

Example: To install BootWorks unattended from a boot directory on a network drive, type
bwinst -q -f=f:\bootfile
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Client BIOS Settings for Wake-On LAN and PXE
Some network cards have their own setup utilities. If there is a Wake-On LAN option on your NIC, enable
it.

If you want to use Wake-On LAN, the motherboard and network card must support Intel’s Wired for
Management (WfM) specification. You will also have to enable the features in the BIOS. (Settings are
hardware specific.Your BIOS might not list all of these.).

File System Independent Resource Management (FIRM)
FIRM gives you basic file access to all FAT and NTFS file systems on your hard disk, regardless of the
version of DOS you are running. This is an advanced feature. You don’t have to use it to perform normal
management tasks.

FIRM serves as an interface between DOS and the hard disk(s). You can use FIRM commands to manage
both DOS drives and FIRM drives (FAT16, FAT32 and NTFS). Currently, it doesn’t work with NetWare or
HPFS.

With FIRM, it's easy to access and manage both BootWorks and production partitions. Using DOS, you
can see only the BootWorks partition (drive W:) when you are in BootWorks. When you are in production
mode, you cannot see the BootWorks partition. FIRM allows you to access both bootworks and production
partitions. This is important for copying files between operating systems. It’s also important for disaster
recovery because you can use it to back up and restore the registry and other files on the production
partition.

How FIRM Works
FIRM works on two types of drives: DOS drives and FIRM drives. DOS drives are those that DOS
recognizes, such as local drives and network drives. FIRM recognizes DOS drives in addition to other local
FAT and NTFS partitions that are present but may not be recognized by DOS. FIRM assigns drive letters in

-f= Function: Specifies the source path to the BootWorks files. The default is drive a:.
Example: To install BootWorks from a directory named “bootfile” on a network drive, type

bwinst -f=f:\bootfile

-b Function: Reads the BIOS settings for the hard drive if IDE settings fail or return incorrect values. If you
get the message, “Error creating drive map” when installing BootWorks, run bwinst with this switch to
correct the problem.
Example: To solve the “Error creating drive map” error and install bwinst, type

bwinst -b

Table 21: Wake-On LAN settings

Power Management ON/ENABLED

Suspend/Wake-up Features ON/ENABLED

Wake-On LAN ON/ENABLED

Remote Power Up ON/ENABLED

Power Switch/Wake-up ON/ENABLED

Table 20: Bwinst.exe Command-line Switches

Switch Details
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the order they are defined on the hard drive. Because FIRM and DOS both assign drive letters, they might
“see” different drives. So, the drive letter assignments might be different depending on which operating
system you use to see the mappings.

Here is an example of what you would see with several operating systems compared to what you would
see with FIRM. Note that the only way to see the location of the embedded BootWorks partition is with
FIRM.

*Drive letters are assigned according to where the drives physically reside on the disk.

FIRM uses the following logic to determine which type of drive to use:

• All network drives are DOS drives, except w:, which is the BootWorks partition drive.
• Drives a: and b: are DOS drives.
• All other drives are assumed FIRM drives unless prepended with the drive type identifier d. For

example, dc: indicates DOS drive c:.
• FIRM drives can also be manually specified by prepending the drive type identifier f. For example, fk:

indicates FIRM drive k:.
• If no drive letter is specified, the drive is assumed to be a DOS drive.

Running FIRM
Prerequisites

• The computer must be booted to DOS.
• The firm.exe program must be on a disk or a server where you have rights to the EXPRESS or

LABEXP directory.

1. Put the disk containing FIRM.EXE into drive a:, or log into the server where the program files are
located.

2. Type FIRM to run the program.

Table 22: Drive Mapping Comparison

Sample Partitions
Partitions
recognized
by Win ‘98

Partitions
recognized
by WIN NT

Partitions
recognized
by WIN 2000

Partitions
recognized
by FIRM

Embedded
BootWorkspartition
(always drive W:)

∗

FAT 32 ∗ ∗ ∗
FAT 16 ∗ ∗ ∗ ∗
NTFS ∗ ∗ ∗
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FIRM Usage
File naming conventions: Filenames must conform to the standard DOS 8.3 format.

Drive designations: Because FIRM and DOS recognize different drives, they might assign different
letters to the same drive. So, for some commands you must specify the drive type in addition to the drive
letter.

Drive types are: d (DOS drive), and f (FIRM drive).

Tokens: You can use a token in place of a drive letter wherever one is required. Tokens are just another
way of accessing a drive on the partition. FIRM replaces tokens with the appropriate drive letter.

Table 23: FIRM Tokens

Token Function

auto Function: Used in place of the BootWorks partition letter (w: drive).
Examples:
To delete the autoexec.bat file from the BootWorks partition, type

firm delete auto:\autoexec.bat

To see a directory list of the BootWorks partition, type
firm dir auto:\

prod Function: Used in place of the production partition letter (c: drive)
Examples:
To see a directory list of drive c:, type

firm dir prod:\

To copy backup files from the production partition c: to the BootWorks partition, type
firm copy prod:\backup.lst auto:\backup.lst

temp Function: This is an environment variable string that maps to wherever your TEMP directory is assigned.
Example:
To see a list of files and directories in your TEMP directory, type

firm dir temp:\

Table 24: FIRM Modes and Options

Mode Options

drives Function: Gets a list of all partitions/drives. Shows the file system and FIRM drive letters. Also shows the
percentage of the drive used by the OS.
Usage: firm drives
Example: To see a list of all FAT and NTFS drives, including the embedded BootWorks partition, type

firm drives

type Function: Sees the contents of an ascii text file. (Other file types don’t display correctly.)
Usage: firm type <filename>
Option: <filename>= path and name of the file you want to read
Syntax: firm type[drive type][drive letter or token]:[path][filename]
Example: To see the contents of a file called “disk32.txt”, enter the FIRM drive letter, path and filename,
type

firm type fc:\diskfiles\data\disk32.txt
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copy Function: Copies a file from one directory to another.
Usage: firm copy <source file><destination file>
Options:
<source file>=path and filename to be copied
<destination file>=location path and filename file will be copied to
Syntax: firm copy [drive type][drive letter or token]:[path][filename]
Examples:
To copy an autoexec.bat file from DOS drive c: to the BootWorks partition, type

firm copy dc:\autoexec.bat auto:\autoexec.bat

To copy backup files from the production partition to the BootWorks partition, type
firm copy prod:\backup.lst auto:\backup.lst

To overwrite an autoexec.bat file on FIRM drive c: to FIRM drive c:, type
firm copy fc:\autoexec.bat fc:\autoexec.old

To copy an autoexec.bat file from DOS drive c: to FIRM drive c:, type
firm copy dc:\autoexec.bat fc:\autoexec.bat

dir Function: Sees file and directory lists.
Usage: firm dir <directory>
Option: <directory>=directory letter or path
Syntax: firm dir [drive type][drive letter or token]:[path]. Don’t include a filename or you will get an error.
The drive type is optional.
Examples:
To see a list of directories and files in the BootWorks directory, type

firm dir w:\

Or, type
firm dir auto:\

(This shows the same results as dos: dir c:\ when running in BootWorks.)
When you are in the BootWorks partition, you can get a list of the contents of the TEMP directory on DOS
drive c: drive by typing

firm dir auto:\temp

To see a list of files and directories in the Windows system directory, type
firm dir prod:\windows\system

delete Function: Deletes a file.
Usage: firm delete <filename>
Option: <filename>=path & name of file to delete
Syntax: firm delete [drive type][drive letter or token]:[path][filename]. Always use the full path when
deleting a file. You can also use tokens.
Examples:
To delete the autoexec file from your BootWorks partition, type

firm delete auto:\autoexec.old

To delete the file “foo.txt” from a directory on DOS drive d:, type
firm delete d:\mydir\foo.txt

To delete the autoexec file from FIRM drive e:, type
firm delete fe:\autoexec.bat

Table 24: FIRM Modes and Options

Mode Options
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backupreg Function: Backs up registry files.
Usage: firm backupreg <dest file><local path>
Options:
-noprofile Backs up default registries without the user profiles.
<destination file>=destination filename. Must be a DOS drive reference, not a FIRM drive!
<local path>=local path to registry files (source)
(Default source path for Win NT/2000 is c:\winnt\system32\config. Default for Win 95/98 is c:\windows). If
files are stored in the default location, you don’t need to enter the path.
Syntax: firm backupreg [destination path and filename] [drive letter or token]:[local path]. Include the
complete path.
Examples:
To back up registries without user profiles to c:\regback.lst, type

firm backupreg c:\regback.lst -noprofile

To back up registries from FIRM drive e: to regback.lst, type
firm backupreg c:\regback.lst e:\winnt

restorereg Function: Restores registry files.
Usage: firm restorereg <source file> <local path>
Options:
<source file>=source filename. Must be a DOS drive reference, not a FIRM drive!
<local path>=local path to registry files
Default source path for Win NT/2000 is c:\winnt\system32\config. Default for Win 95/98 is c:\windows. If
files are stored in the default location, you don’t need to enter the path.
Syntax: firm restorereg [source path and filename][drive letter or token]:[local path]. Include the complete
path.
Examples:
To restore registries from c:\regback.lst to default location, type

firm restorereg c:\regback.lst

To restore registries from c:\regback.lst to e:\winnt
firm restorereg c:\regback.lst e:\winnt

Table 24: FIRM Modes and Options

Mode Options
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FIRM Error Messages

If you get error messages when running this program, see “Appendix B: Error Messages” on page 112.

Imaging
You can easily manage most imaging tasks from an Altiris Console, which runs on Windows. However, you
also have the option of running the imaging engine from DOS.

• To manage imaging from the Console, refer to the imaging topics in Help on the Console toolbar.
• To run the imaging program on client computers as a peer-to-peer process, run RapiDeploy. (See the

RapiDeploy User Guide.)
• To run imaging from a DOS command line or batch file, you can run ibmaster.exe and ibclient.exe

on your computers. This section explains the command line options.

How Imaging Works

When you upload an image, everything on the source computer is included in the image, including registry
settings, IP address, computer name, etc. Likewise, all of that information is included in the download. In
order for imaged computers to have unique settings without having to manually change them after
imaging, you should complete the configuration tasks for your product.

Imaging a computer overwrites the hard disk with the contents of the image, regardless of the existing
partition configuration. For example, if you have three partitions defined on the computer and the image file
contains one partition, there will be only one partition on the computer after it is imaged.

backuplist Function: Backs up a set of files.
Usage: firm backuplist <destination file> <list file>
Options:
<destination file>=destination filename<list file>=file name containing a list of files to back up (source).
Must be in a dos text/ascii file format. Both options must must be DOS drive references, not FIRM drives!
Syntax: firm backuplist [destination path and filename][list filename]. Include the full path.
Example:
To back up the files in c:\backup.lst and store them in c:\backup.txt, type

firm backuplist c:\backup.txt c:\backup.lst

The backup.lst file might contain the following:
c:\autoexec.bat
dc:\config.sys
prod:\windows\command\format.com

restorelist Function: Restores a set of files.
Usage: firm restorelist <source file><logical drive>
Options:
<source file>=source filename. Must be a DOS drive reference, not a FIRM drive!
logical drive= drive letter to overwrite default logical drive. Default logical drive = original drive.
Syntax: firm restorelist [source path and filename][logical drive letter]. Include the complete path.
Example:
To restore backup files to DOS drive c:, type

firm restorelist c:\backup.txt

Table 24: FIRM Modes and Options

Mode Options
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By default, images are multicast to client computers, meaning they are imaged simultaneously. See
“Multicasting” in this section for more information about how multicasting works.

You have several options for deploying images. You can:

• Multicast an image stored on a file server to a group of client computers
• Send an image of a computer’s hard drive directly to any number of other client computers
• Upload an image to a server while multicasting the image to client computers

Making Image Files

When you create an image file, you can make either a regular image file or a self-extracting executable file.
All you have to do is create the image with the appropriate extension when you create (upload) the image,
or you can use RapiDeploy to convert an existing image (*.img) file to an executable (*.exe) file.

• For computers connected to your network a regular image file (*.img) works well.
• For computers that are not connected to your network, such as laptops and computers in branch

offices, create a self-extracting image file (*.exe). You can copy it to a bootable media, and remote
users can use the “portable” image to configure their computers at any time.

Editing Image Files

You can view and modify Altiris image files (*.img) using ImageExplorer. You can:

• View information about partitions and files contained within an image file
• Modify existing files in the image
• Include and exclude files from imaging
• Search files

The following tasks can be completed using standard Windows menus, toolbars, buttons, hotkeys, and
context menus (right-clicking on an item).

Modifying an Image File
You can modify a file in an image in one of the following two ways:

• If image files are associated with a text editor such as Notepad, you can modify them by opening the
image, right-clicking on the file to be changed, and choosing Edit.

• If the file isn’t associated with a text editor, you can change it by selecting the file and then choosing
the Extract icon on the toolbar. Enter the path where you want to save the file to be edited. After edit-
ing, choose the Replace icon to load the modified file back into the image.

Note: Files can only be replaced with a file of the same name. In other words, you can only modify existing
files within the image. You cannot add new filenames to the image.

Excluding and Including Files
By default, all listed files are included in the imaging download process. By selecting any file or group of
files and clicking the Exclude button, the filenames are highlighted in blue and are not copied during
imaging. When you want the files included again, select the files and click the Include button.
 2000 Altiris, Inc. page 99



File Searching
You can search for files within an image using specific names or wildcards. Search options include the
following wildcards:

• ? Represents a single character.
• * Represents any number of characters.

For example, searching for TEST* in an image finds all files beginning with the letters TEST. Note that
searches are limited to a single wildcard (*). No results will be returned if multiple wildcards are used.

Viewing and Editing Image File Properties
ImageExplorer stores various property information for the objects contained within an image file. These
properties can be viewed, and in some cases modified.

• Image File Properties displays the description of the image file. Choose File > Properties.
• Partition Properties displays the partition slot used by this partition, the file system type, and

attribute information about the selected partition. This information cannot be edited. To view
properties, right-click the partition and choose Properties.

• Folder Properties displays the complete base path that this folder is placed in when the image is
downloaded to a computer. This information cannot be edited. To view properties, right-click the folder
and choose Properties.

• File Properties displays the filename and location (folder) of the selected file, and attribute informa-
tion for the file. You can edit attribute information. To view or edit a file, right-click on the file and
choose Properties.

Using Command-Line Switches with Executable Images
In rare cases, you might need to use switches with executable image files. Valid switches are: -sz, -d, -r,
and -b. Multiple switches can be used on the same command line and their order does not matter. (For
information about these switches, see Ibmaster.exe and Ibclient.exe Command Line Switches in this
section.) As with other switches, you can use them on the command line or in a batch file.

In addition, you can use the -force switch, which bypasses the default screen that prompts the user before
imaging begins.

Example: If you named your self-extracting file BASEIMAG.EXE when you created (uploaded) it, you
would type the following on the command line or in your autoexec.bat file:

baseimag.exe -force

You can combine this switch with any of the other switches.

Multicasting

The imaging programs use multicasting to deploy images to groups of computers. When a multicast
session is started, one of the client computers is designated to be the “Master computer.” The Master
computer manages the multicast session. It downloads an image from a file server (or uses the image on
its hard drive) and manages the simultaneous imaging of the client computers.

Note: The Master computer is any client computer running ibmaster.exe; clients are any computers
running ibclient.exe. The eXpress Server assigns a computer to be the Master when a multicast
session is started.
 2000 Altiris, Inc. page 100



How Multicasting Works
• The multicast transmission is synchronized by the Master computer, so it will only go as fast as the

slowest computer in the group.
• If a computer fails, it will drop out of the session and the session will continue. The computer’s status

will show that the even did not complete successfully.
• You determine when multicasting is used by setting the number of computers needed to start a

multicast session. When imaging is started, the Master computer waits 5 minutes for clients to
connect. If fewer than the minimum number of computers connect within 5 minutes, the clients will be
imaged via direct downloads from the server.

• You can only multicast to computers on the same network segment, because most routers and
switches do not allow multicasting. To image computers on another segment, run a separate Event on
that segment and connect the clients directly to the eXpress Server instead of multicasting to connect.

How Hard Disks Are Read

Hard disks are imaged differently depending on the file system that is used. The source disk or partition is
not changed.

FAT 12, 16, 32, and NTFS. Imaging is file-based. Data is copied file by file, resulting in a clean,
defragmented image that can be resized and restored to a drive of a different size.

NetWare. Imaging is done sector by sector. NetWare images can be optimized if you first run an NWPREP
module at the NetWare console. Running NWPREP before creating an image also makes downloads
faster. This prepares all of the volumes currently mounted on the server.

• Use NWPREP.NLM for NetWare 4 and NetWare 5 servers
• Use NWPREP3.NLM for NetWare 3 servers

To use an NLM, copy it to a disk or to a file on the server and follow the normal procedure for running an
NLM. For example, if you have the module on a disk, insert it at the NetWare console and type

load a:nwprep

Other file formats. For HPFS (OS/2), UNIX and other file systems, the disk is read sector by sector,
regardless of which sectors are in use. The image mirrors the contents of the hard disk. These formats are
not resizable. The partition you image must be the same size as the original image or larger. Post-
configuration is not available for these images.

File System Dependencies

Images created from FAT, NTFS, and NetWare file systems are drive geometry independent. Other file
systems, such as UNIX and HPFS, are drive geometry dependent. This means that the disk size, number
of heads, cylinders, and sectors of the client computers must be the same as the imaged hard disk.

How Partitions Are Handled

You can image a partition, a group of partitions, or an entire hard drive.

Any partition on a hard drive can be imaged.

The partition size percentage of the client computers will be the same as the image source. For example, if
you image a 1 Gigabyte disk where 40% (400 MB) of the drive is a Windows NT partition and 60% (600
MB) is a Windows 98 partition, a client computer with a 2 Gigabyte drive will use the same percentages.
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The size of the Windows NT partition will be 800 MB and the Windows 98 partition will be 1200 MB. The
only exception to this is the Bootworks partition. If a BootWorks partition is part of the image, it will retain its
original size.

When a client computer is imaged, all existing partitions are overwritten by default except two:

• BootWorks partition
• COMPAQ system partition

You can overwrite either of these partitions by selecting the appropriate option in the eXpress Console
when you create the imaging Event.

Partition slots on the client computers will be the same as the image source. A partition occupying slot 3 in
the image file will be in slot 3 on the clients.

Ibmaster.exe and Ibclient.exe

The easiest way to image client computers in eXpress is to create and deploy imaging Events at the
Console. In some cases, you might need to use RapiDeploy to image clients.

If you need to set special switches or troubleshoot your imaging process, you can add or modify these
switches in your program files. You can also run them at the DOS command line.

Switches can be entered in any order, and they are not case sensitive. When using multiple switches,
leave a space between each switch.

You can also get a list of switches and options at the DOS prompt by typing ibmaster ? or ibclient ?.

Table 25: Ibmaster.exe and Ibclient.exe Command-Line Switches

Switch [option] Details

-b Function: For troubleshooting only, when instructed by Altiris Technical Support. Instructs
RapiDeploy to use normal BIOS parameters to get drive geometry. This switch prevents clients
from using INT 13 Extended BIOS calls to get drive geometry. It also disables clients from
accessing an IDE controller directly to get the values.
Examples: To run troubleshooting on a Master computer, type

ibmaster -b

To run troubleshooting on a client computer, type
ibclient -b

-bsl[maximum
bandwidth]

Function: Determines the maximum bandwidth to be used by the multicasting session.
Example: To limit the bandwidth to 5 Megabits per second, type

ibmaster -bsl5

-cks Function: Uses checksum on the Master computer while multicasting an image.
Example: To use a checksum to verify data during imaging, type

ibmaster -cks
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-cfgfile=[filename] Function: Specifies the name of a configuration file to load. This command is useful if you want
to run imaging in a batch file using configuration information saved previously by the RapiDeploy
program. (If you select the option to save settings in the RapiDeploy program, a configuration file
will be created with the name lastrun.cfg.) You can rename lastrun.cfg and specify it in your
batch file to apply configuration settings.
Example: If you have run RapiDeploy and chosen the option to save configuration settings, you
could rename lastrun.cfg to laptop1 and use it in a batch file by typing

ibclient -cfgfile=laptop1.cfg

You can also put configuration files in a shared directory and load them from the network.

-cfgprompt Function: Brings up the RapiDeploy configuration screen so you can review and edit
configuration information. This is useful if you want to configure client computers after imaging
(and before they boot to production).
For client computers, the screen will not appear if you do not set the switch.
For the Master computer, the screen will not appear if ibmaster has enough parameters to
deploy the image. If the switches md, f, p, and szd are set, imaging will run without bringing up
the screen. (This is how it behaved in past versions). If the switch is not set, the command or
batch file will run and the program will exit.
Example: To bring up the configuration screen when imaging client computers, type

ibclient -cfgprompt

-c[compression mode] Function: Sets the compression mode for image creation.
Default: Size
Options:
off (turn compression off)
size (make smallest image size with slight speed penalty)
speed (make a less compressed image in less time)
Example: To optimize image creation for speed, type

ibmaster -cspeed

-d[hard disk number] Function: Specifies which hard disk to read from or write to, depending on whether you are
uploading or downloading. The switch is used for computers that have more than one hard disk.
Default: Disk 1
Examples: To download an image from disk 2, type

ibmaster -md -d2

To download an image to disk 2 on a client computer, type
ibclient -d2

-f[path & file name] Function: In upload mode, it specifies the filename and location for storing an image file. In
download mode it specifies which image file to send to restore.
To create (upload) a regular image file, use an .img extension. To create a self-extracting
executable image file, use an .exe extension.
Examples: To upload an image file to drive g:, type

ibmaster -mu -fg:images\win98.img

To upload a self-extracting executable image file, type
ibmaster -mu -fg:images\win98.exe

Table 25: Ibmaster.exe and Ibclient.exe Command-Line Switches

Switch [option] Details
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-i[IDnumber] Function: On a Master computer, this sets the Master ID for a multicast session. This is the ID or
name that the Master computer advertises to the clients. When set on a client computer, the
client communicates only with the Master computer advertising the same ID number.
Limit: 12 characters or less.
Default: ANY, which means a client will communicate with any Master computer.
Examples: To specify Lab 2 as the Master ID, type

ibmaster -ilab2

To specify that a client communicates only with a computer advertising the “Lab 2” master ID,
type

ibclient -ilab2

-kap Function: Prevents IBMASTER from overwriting any existing partitions on the hard drive.

-kp[n] Function: (Download only.) Prevents IBMASTER from overwriting a specified partition.
n=partition 1 - 4
Example: To keep partition 2 from being overwritten during imaging, type

ibmaster -kp2

-l Function: Displays license information on the Master computer.
Example: To see license information on the Master computer, type

ibmaster -l

-m[mode] Function: Sets the operating mode.
Options:
u (Upload)
d(Download)
b(Multicast)
ub (Upload and multicast)
db (Download and multicast)
Example: To upload an image, type

ibmaster -mu

-mcast:[protocol] Function: Specifies the protocol to use when sending an image.
Default: IP
Options:
IP
IPX
Examples: To force use of IPX, type

ibmaster -mcast:ipx

You can also specify new multicast addresses. However, the imaging programs default to two
known addresses and you usually won't need to change them.
To set new IP addresses, type

-mcast:ip=224.2.0.2,224.2.0.3

Do not use spaces between the addresses; use commas.
Valid IP addresses are in the range of 225.0.0.0 to 225.255.255.255.

-mconv Function: Converts an existing image file to a self-extracting .EXE file. (Does not Upload or
Download; just converts the file.)
Example: To convert a file named WIN98.IMG, type

ibmaster -mconv -fwin98.img

Table 25: Ibmaster.exe and Ibclient.exe Command-Line Switches

Switch [option] Details
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-nobw Function: Removes the BootWorks partition from a computer. If an image is downloaded that
includes a BootWorks partition, it will not be restored to the disk.
Example: To remove an existing BootWorks partition from a hard drive and exclude the
BootWorks partition from being downloaded with an image, type

ibmaster -nobw

-nopxe Function: Instructs the Master computer to not check if a client computer is booted with PXE.
(Normally, the Master detects PXE-booted computers and excludes BootWorks partitions in
images from being downloaded to the computer. If a BootWorks partition already exists on the
computer, it is not overwritten.)
Example: To download an image containing a BootWorks partition and have it restored to the
computer, type

ibmaster -nopxe

-nt64k
(Download only)

Function: Enables a 64K cluster size with a FAT16 partition. This allows you to resize a FAT16
partition up to 4 Gigabytes rather than the normal 2 GB limit.
Examples: To change the size on a Master computer, type

ibmaster -nt64k

To change the size on a client computer, type
ibclient -nt64k

-ntcheckdisk
(Download only)

Function: Runs ntcheckdisk when an NT computer reboots after imaging (before it boots to
production).
Examples: To run ntcheckdisk on a Master computer, type

ibmaster -ntcheckdisk

To run it on a client computer, type
ibclient -ntcheckdisk

-p[partition]
(Upload only)

Function: Specifies which partition to upload.
Options:
number (1, 2, 3, 4) uploads the partition
b uploads the BootWorks partition (works for both types)
Example: To upload an image of partition 2, type

ibmaster -mu -p2

-r [option] Function: Replaces existing BootWorks or COMPAQ partitions on a computer with a new one
from the image file.
Options:
c (replace COMPAQ system partition)
b (replace BootWorks partition)
Example: To replace both partitions with new ones from the image file, type

ibmaster -rc -rb

-ras
(Upload only)

Function: Read All Sectors. The Master computer reads and images a partition by sectors
rather than by files. This switch makes the image drive geometry dependent (must have the
same heads, cylinders, and tracks as the image source). Used mostly by Altiris Technical
Support for troubleshooting, or it could be used to make sure that any extra data residing outside
of the file system is included in the image.

-s[number of clients] Function: Specifies the number of clients needed to start a multicast session. When the Master
computer detects the specified number of clients, it automatically starts the multicast session.
Example: To set the multicast threshold to 10 computers, type

ibmaster -s10

Table 25: Ibmaster.exe and Ibclient.exe Command-Line Switches

Switch [option] Details
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-span Function: Prompts between each piece of an image file (if set using the -split command),
allowing you to insert new media.
Example: To prompt between each file in the image set, type

ibmaster -span

-split=[n] Function: Breaks an image into a group of files of a specified size during an upload (in
Megabytes).
Example: To set the file size to 500 MB, type

ibmaster -split=500

-sz[option] Function: Resizes partitions on client computers during imaging.
Options:
n=xm (Resize client partitions in MegaBytes)
n=x% (Resize client partitions as a percentage of hard disk free space)
d (Resize partitions to fill available disk space on the client. Applies to all partitions being
downloaded.)
f (Do not resize client partitions.)
When you use d or f options, they override other resize options. If both d and f are used, the last
option on the line overrides the others.
Examples:
If the size of the partition to be downloaded is 250 MB and you want the destination partition to
remain 250 MB, use the f option. If the target drive has 500 MB of free space, you'll have a 250
MB fixed partition and 250 MB of free space.
If the size of the partition being downloaded is 300 MB and you want it to fit in half of the 500 MB
of free space on the client disk, type

ibmaster -sz1=50%
This resizes the 300 MB partition to 250 MB, leaving the other 250 MB unused. However, other
factors might apply.
You can set the target size for multiple partitions on the same command line by including multiple
instances of the switch.

ibmaster -sz1=200m -sz2=50%

-w[n] Function: When multicasting, specifies the number of minutes to wait for clients to connect.
Default: 5 minutes (or until the specified number of clients is connected).
Example: To start a multicast session in 10 minutes, type

ibmaster -w10

-v Function: Shows the version of ibMaster.exe or ibclient.exe running on a computer.
Example: To see version information, type

ibmaster -v

Table 25: Ibmaster.exe and Ibclient.exe Command-Line Switches

Switch [option] Details
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Import Files

Comma-Delimited File Format for Importing Virtual Computers

This file is used to import computer information to the Console, where it is saved until the new computer is
brought online. Most of the time you will define virtual computers at the Console. However, if you want to
create a comma-delimited file to import the information, use this format. Instructions for using your import
file are in the section on importing files. All fields must be present in the file, but all data except the name is
optional.

importFile.ReadField(pRec->m_strName);
importFile.ReadField(pRec->m_strMacAddr);
importFile.ReadField(pRec->m_strSerialNum);
importFile.ReadField(pRec->m_strAssetTag);

// MS Networking
importFile.ReadField(pRec->m_strCompName);
importFile.ReadField(pRec->m_bDomain);
importFile.ReadField(pRec->m_strDomainName);

// TCP/IP
importFile.ReadField(pRec->m_bUseDHCP);
importFile.ReadField(pRec->m_strIpAddr);
importFile.ReadField(pRec->m_strIpNetmask);
importFile.ReadField(pRec->m_strIpGateway);
importFile.ReadField(pRec->m_strIpDNS1);
importFile.ReadField(pRec->m_strIpDNS2);
importFile.ReadField(pRec->m_strIpDNS3);
importFile.ReadField(pRec->m_strIpWINS1);
importFile.ReadField(pRec->m_strIpWINS2);
importFile.ReadField(pRec->m_strHostname);
importFile.ReadField(pRec->m_strIpDomain);

// NW Client
importFile.ReadField(pRec->m_bUsePrefTree);
importFile.ReadField(pRec->m_strPrefServer);
importFile.ReadField(pRec->m_strPrefTree);
importFile.ReadField(pRec->m_strNwUser);
importFile.ReadField(pRec->m_strNdsContext);
importFile.ReadField(pRec->m_bRunScripts);

// Product Licensing
importFile.ReadField(pRec->m_strLicUser);
importFile.ReadField(pRec->m_strLicOrg);
importFile.ReadField(pRec->m_strLicKey);

// User Account Creation
importFile.ReadField(pRec->m_bPwdNeverExpires);
importFile.ReadField(pRec->m_bCannotChangePwd);
importFile.ReadField(pRec->m_bMustChangePwd);
importFile.ReadField(pRec->m_strUsername);
importFile.ReadField(pRec->m_strFullName);
importFile.ReadField(pRec->m_strGroups);
importFile.ReadField(pRec->m_strPassword);

// Location
importFile.ReadField(pRec->m_strContact);
importFile.ReadField(pRec->m_strDept);
importFile.ReadField(pRec->m_strEmail);
importFile.ReadField(pRec->m_strMailstop);
importFile.ReadField(pRec->m_strPhone);
importFile.ReadField(pRec->m_strSite);
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Keyboard and Screen Lock Utility (Kbdsclk)
This utility can be used to limit user intervention while client computers are in BootWorks mode.

BootWorks connects client computers to the eXpress Server to run assigned Events (receive images, back
up and restore registries, etc.). The Server then releases control of the computers to run their regular boot
processes and come up in production mode. KBDSCLK is part of the BootWorks autoexec.bat file. The
utility runs from the file as a TSR.

How the Keyboard and Screen Lock Utility (kbdsclk) Works
During the time the computer is in BootWorks mode, the Altiris client graphic displays so the user knows
the Altiris boot processes are running. However, the keyboard is not locked, so the boot process can be
interrupted if a user “breaks in” using Ctrl-C, Ctrl-Alt-Del, Ctrl-Break, or another interrupt command.

The screen and keyboard can be locked by setting the security option when you use the Boot Disk Creator
to make BootWorks boot files. Or, you can change the settings in the BootWorks autoexec.bat file. Just
remove the REM statements for the commands you want to use. You can also add commands to set and
clear keyboard and screen locks in multiple places in the batch file. This is useful for enabling input when
applications are loaded (such as the Microsoft client, which prompts for a password), and then relocking
the screen and keyboard to complete the boot processes. You can also use KBDSCLK on the command
line if you want to temporarily override the batch file settings.

Keyboard and Screen Lock Utility Usage
Commands are not case-sensitive. The syntax is as follows:

kbdsclk [p=password] [+|-k] [+|-s] [x [h#]] [c|t] [w=file] [b]

For help when running the utility, type KBDSCLK ?

The batch file includes keyboard and screen lock commands, which are marked out (REM). When you
remove the REM commands and run the commands in a batch file, the utility behaves as a TSR. The
defaults are:

• The Altiris client graphic is displayed.
• The keyboard and screen are not locked.
• If options are added to the batch file, they are executed in the order they appear in the file.

How To Edit the BootWorks Autoexec.bat File
1. Press F8 while the computer is booting to break into the boot process. The DOS Startup menu

appears.

2. Choose Step by Step confirmation on the menu.

3. Type N at the prompts until you get to the BootWorks files.
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4. From BootWorks, use a DOS editor to edit the autoexec.bat file.

Order Of Operations
The order of operations and utility behavior when run from the command line is as follows:

• When c or t is used, it performs its functions and exits without performing any other functions,
regardless of order. KBDSCLK does not remain loaded as a TSR, so the keyboard is not locked and
no screen output is displayed.

• Use w to specify the name of a wallpaper/graphic file to replace the default. See the table above for
details on using graphics files.

• When x is used, the wallpaper/graphic is displayed and the KBDSCLK program exits, ignoring all
other commands except w and h, regardless of order. KBDSCLK does not remain loaded as a TSR,
so the keyboard is not locked.

• If the utility is loaded as a TSR (in the autoexec.bat file), and you execute KBDSCLK on the command
line and specify the k and s options, it changes the keyboard and screen lock settings of the TSR
instance. Options w, p, and b are ignored, regardless of order. If the TSR is not loaded, w, p, and b
can be used with k and s in any order.

• The p option can be used on the command line to set a password for unlocking the screen and key-
board.

Table 26: Keyboard and Screen Lock Utility Options

Option Description

p=pwd [b] Function: Sets a password to enable/disable the keyboard and screen lock. Maximum character length is
128.
Option:
b Scans keyboard input for a password to set locks when they are not set. (Be careful using this option. It
can interfere with keyboard input for applications that are running!)

+|- k Function: Enables/disables keyboard input. To allow keyboard input, use +k. To lock the keyboard,
use -k.
Default: Locked

+|- s Function: Enables/disables screen output. To allow screen output, use +s. To disable it, use -s.
Default: Disabled

x[h#] Function: Displays wallpaper or graphic and then exits the KBSCLK utility. Once the utility has exited (no
longer running as a TSR), the keyboard and screen are not locked.
Default: 3 second graphic/wallpaper display, then unload TSR.
Options:
h Allows use of the Home key to bypass BootWorks and begin production boot processes.
# Specifies the time for the graphic to display. During that time, you can use the Home key to bypass the
BootWorks processes. If zero is used, the graphic is displayed for 3 seconds and no bypass is allowed.

c Function: Clears the screen and exits the program. Used mostly for troubleshooting.

t Function: Sets video text mode (MODE CO80) and exits. Used mostly for troubleshooting.

w=file Function: Specifies the name of a graphic/wallpaper file to display. This is valid only if the x option is used.
Valid files are pcx files with 640x480x16 color.
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SIDgen
Imaging or cloning Windows NT/2000 computers can be a problem when domains are used to manage
servers and client computers. Domains require that each computer have a unique security ID (SID). Since
this SID must be unique, sharing an image of one computer with other computers in the domain causes
conflicts.

To avoid these conflicts, Altiris eXpress includes SIDgen, a native 32-bit security attribute modification
utility that works on Windows NT 4.0 and 2000 workstations and servers (including Primary and Backup
Domain Controllers).

Step-by-step instructions for installing SIDgen and viewing/changing SIDs are in the Security ID topics.

How SIDgen Works

When SIDgen is run on a computer, it backs up the registry, then generates a unique SID for the computer.
It searches all registry hives and replaces appropriate entries with the newly generated SID. Then, SIDgen
replaces file system security assignments (NTFS permissions).

This entire process is transparent to the user. Security entries still list the same users/groups and all user
preferences remain intact. If any errors occur during the replacement process, SIDgen restores the registry
to its original state. If successful, everything appears normal.

You can use SIDgen parameters to specify options when you run it from a script or a batch file.

Table 27: SIDgen Command-Line Parameters

Parameter Details

/clean Function: Cleans a previous run, including all temporary files. SIDgen creates some temporary files
that cannot be removed until after the computer restarts.

/data:<sync
filename>

Function: Synchronizes permissions between Primary Domain Controllers (PDC), Backup Domain
Controllers (BDC) and member NT workstations.
When running SIDgen on a PDC, you need to synchronize the changes with all the other computers
in its domain. This file is created by the PDC and contains the previous and new SIDs to synchronize
with backup domain controllers and domain members. See the Scenarios section below for
examples of how to use this parameter.

/install Function: Installs the utility as a service (prompts for an account and password)....

/log:<log filename> Function: Creates a log file. (If the filename is omitted, C:\SIDGEN.LOG is created.)

/name:<new name> Function: Changes the computer name along with the SID. (If the <new-name> portion is omitted,
you will be prompted upon execution of the utility.)

/nofs Function: Bypasses NTFS checking. This switch causes any permissions set up on user-created
groups or user accounts to become unknown. Use this switch only if you are using default groups to
assign permissions and those groups do not have a full administrator account (that is, their
administrator does not have access to some of the files on an NTFS partition).

/remove Function: Removes the service entry.

/start Function: Runs in unattended mode (automatically starts interactive mode without prompting).
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/verbose Function: Includes verbose information in log.

Table 27: SIDgen Command-Line Parameters

Parameter Details
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Appendix B: Error Messages

This section presents some error messages generated by Ibmaster.exe and Ibclient.exe. They are divided
into the following groups:

• General (SeeTable 28, “General Error Messages,” on page 113)
• Client (See Table 29, “Client Error Messages,” on page 115)
• Communication (See Table 30, “Communication Error Messages,” on page 115)
• Critical (See Communication Error Messages115)
• Memory (See Table 29, “Client Error Messages,” on page 115)
• Partition (See Table 33, “Partition Error Messages,” on page 117)
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General Error Messages

Table 28: General Error Messages

Error Message Description

"Error reading . . ."
"Error writing . . ."

Explanation: An error occurred while reading or writing to the disk.
Possible causes:
• Faulty disk hardware.
• A write-protected disk. The BIOS in some computers has an anti-virus capability

which attempts to protect the disk from Master Boot Record (MBR) viruses by
write-protecting the first sector or track on the hard disk.

"Error reading from file."
"Error writing to file."
"Error opening file for reading."
"Error opening file for writing."
"Error saving image info to file."
"Error closing file."
"Error reading image information."

Explanation: An image file could not be accessed.
Possible causes:
• The file does not exist, or cannot be read (for downloads).
• The image file is corrupt.
• The directory does not exist or cannot be written to (for uploads).
• The disk where the image file is being written is full.

"Geometry Error . . ."
"Invalid geometry exception . . ."

Explanation: There was an error converting cylinders, heads, and sectors to logical
blocks or vice versa.
Possible cause: Invalid or corrupt BIOS drive geometry settings.

"No such drive . . ." Explanation: The specified drive could not be accessed.
Possible cause: An invalid drive letter was entered.

"Error reading drive parameters
from BIOS."

Explanation: The program received an error from the BIOS while trying to read disk
geometry information.
Possible Cause: Often occurs when trying to run a DOS application from Windows.

"Bad magic number. File is not an
image file."
"Bad magic number. Buffer doesn't
contain image data."
"Bad file version number. Cannot
read the file."
"Bad version number. Buffer doesn't
contain image data."

Explanation: The file is not recognized as an image file.
Possible causes:
• The file is not a valid image file.
• File was created with a different version of the imaging program, which is not

compatible.
• Data loss is occurring over the network.

"Too many clients for current license
count."

Explanation: More clients connected to the Console or Master computer than the
license allows.
Action: Upgrade your license to support more nodes. Call your authorized reseller for
more information.
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"This program is not licensed for
multicasting (peer-to-peer imaging)."

Explanation: Multicasting works only when the license count is greater than one.
Action: Upgrade your license to support more nodes. Call your authorized reseller for
more information.

"Exiting with error code . . ." Explanation: The program failed.
Possible causes:
• The operator aborted the program prematurely.
• A serious program error occurred.
Action: A descriptive error message should appear before this message to give you
information about the problem that is causing the program to exit. If you do not see a
preceding descriptive message, notify Altiris Technical Support. Write down the error
code and a description of what was happening before the error occurred.

Table 28: General Error Messages

Error Message Description
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Client Error Messages

Communication Error Messages

Table 29: Client Error Messages

Error Message Description

"The master PC ended the transfer
before we received all of the data."

Explanation: The Master computer sent a "goodbye" packet before the image-transfer
was finished. The download didn't finish, so the client disk will be in an indeterminate
state.
Possible cause: The user aborted the download before it was complete.

"Error: Received cluster chunk with
wrong version . . . (want .. .)."
"Client and master versions do not
match."
"Error: Received cluster map with
wrong version . . ."
"Error: End of Block packet has
wrong version . . . (want . . .)."

Explanation: The Master computer sent a packet with the wrong version number.
Possible cause: The Master computer and clients are running different versions, and
there are packet-header differences.
Action: Make sure both master and client programs are updated to the same software
version.

"Error: Received Wrong NetBlock . .
. (expected . . .)."
"Received Wrong segment . . .
(expected . . .)."

Explanation: The Master computer moved on to the next segment in an image
transfer before the client successfully received all of the data in a previous segment.
Possible cause: The client may have lost contact with the Master computer during a
download.

"Error: Master started before we
could register."

Explanation: The client received an unknown packet before it was ready to begin the
download.
Possible cause: The "download confirmation" packet sent from the Master to the
client is lost.
Action: Re-send the image.

"Error decoding buffer."
"Error while getting image info from
master."

Explanation: The client was unable to decode packet or image information.
Possible cause: Data corruption in a packet somewhere between the Master
computer and the client (likely), or a bug in either the master or client software (much
less likely).
Action: Call Altiris if you see this message and you believe your network is operating
reliably.

Table 30: Communication Error Messages

Error Message Description

"Error opening IP socket."
"Error canceling IP listen packets."
"IP SendPacket error, code . . ."
"IP Error sending packet ..."
"Error sending farewell packet: ECB
code . . ."
"IP error getting local target
address."
"Unable to bind socket 0x . . ."

Explanation: An error was returned from a call to the network protocol stack.
Possible causes:
• The IP protocol stack isn't loaded.
• An internal error occurred in the protocol stack code.

Note: The same errors can occur with IPX.
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Critical Error Messages

Table 31: Critical Error Messages

Error Message Description

"Compression failure, result is 0x. . ."
"Decompression failure, result 0x . . ."

Explanation: Compression or decompression failure.
Possible causes:
• A decompression failure can be caused by corrupt data in an image file or

data accessed across the wire.
• A compression failure is probably caused by a bug in the program.
Action: If you get a compression or decompression failure on a file that you know
to be good (i.e. not corrupted), isolate the system from the network and try to
reproduce the error. This will determine if the error is on the network or in the
Altiris program. If the problem recurs on the isolated system, report the error to
Altiris.

"Unable to send packet: buffer too big." Explanation: The program tried to send a packet that was larger than the internal
limit.
Action: Isolate the system from the network and try to reproduce the error. This
will determine if the error is on the network or in the Altiris program. If the problem
recurs on the isolated system, report the error to Altiris.

"Unable to register multicast cleanup
function."

Explanation: Indicates a failure in the program’s library routines.
Action: Isolate the system from the network and try to reproduce the error. This
will determine if the error is on the network or in the Altiris program. If the problem
recurs on the isolated system, report the error to Altiris.

"Unhandled exception detected.
Please call technical support."

Explanation: A top-level handler in the program detected an exception from an
unknown location in the program.
Action: Isolate the system from the network and try to reproduce the error. This
will determine if the error is on the network or in the Altiris program. If the problem
recurs on the isolated system, report the error to Altiris.

"Error: Missing chunk number . . . too
big."

Explanation: Indicates an internal error in the client.
Action: Isolate the system from the network and try to reproduce the error. This
will determine if the error is on the network or in the Altiris program. If the problem
recurs on the isolated system, report the error to Altiris.

"Error: Received non cluster map block
type 0x . . ."

Explanation: The client received a block of data containing unexpected
information.
Action: Isolate the system from the network and try to reproduce the error. This
will determine if the error is on the network or in the Altiris program. If the problem
recurs on the isolated system, report the error to Altiris.
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Memory Error Messages

Partition Error Messages

"Out of range index . . . in removeItem.
ElementCount is . . ."
"Error removing child subtree."
"Invalid item to remove."
"Error: Attempted removal of top-level
container segment."
"Error: unable to copy source segment."
"Error getting download info space
requirements."
"Error getting image info space
requirements."
"Error getting bitmap space
requirements."
"Error encoding image info into buffer."
"Error encoding bitmap."

Explanation: Internal program error.
Action: Please report the error to Altiris. Write down the error code and message
and a description of what was happening just before the error occurred.

"Container segment has invalid Partition-
table slot . . ."

Explanation: A partition table in an extended partition contains a reference to a
nonexistent slot in the partition table.
Action: Please report this error to Altiris.

Table 32: Memory Error Messages

Error Message Description

"Insufficient memory for . . ."
"Ran out of memory while . . ."
"Exception . . . while allocating . . ."

Explanation: The program is out of memory.
Possible cause: The Altiris program requires 16 MB to run. It could also be a lack of
conventional memory.
Action: Add the emm386.exe file, and load as many drivers, devices, etc. as possible
into high memory. Check the Altiris support forum for information on memory errors.

"Error adding . . ." Explanation: There was a problem building an internal list structure.
Possible cause: This is almost always a result of memory exhaustion.

Table 33: Partition Error Messages

Error Message Description

"Collision in partition-table . ."
"Collision with . . ."

Explanation: More than one partition was defined for a given partition table slot. It can
mean one of two things:
• The on-disk partition-tables (including partition tables in extended partitions) are

corrupt.
• The program was unable to merge an image file with the local disk contents

because both the image and the local disk contain a partition definition that must
reside in the same slot.

Table 31: Critical Error Messages

Error Message Description
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"No partitions to process." Explanation: No partitions were found in the partition table. The program has nothing
to image (upload).

"Segment boundary error: doesn't
start on track boundary."
"Invalid partition . . . "

Explanation: An invalid partition definition exists.
Possible cause: The invalid entry might be in the partition table’s extended partitions.
Action: Try running ibmaster.exe with the -sz or -szf switch.

"Error: No partition-table segment to
update."
"Error: Expected container segment
not found."

Explanation: An extended partition was found that contained no internal partition
table, or contained no internal definitions.
Action: The invalid configuration can be resolved by removing the invalid partition
definition (using FDISK or similar utility).

"Not enough free disk space to
accept image."
"Underlap error while placing
segment."
"Overlap error while placing
segment."

Explanation: The local disk doesn't have enough free space to accept the image
being downloaded.
Possible cause: The image may have more data than can fit on the client computer
hard drive, or the partition cannot be resized to fit the drive.

"Collision at beginning of disk while
trying to place boot record."

Explanation: The program was unable to place the boot record on the disk.
Possible cause: Another partition may be defined to “cover” the required space. This
usually indicates corruption in the target disk's partition table, because it is illegal for a
partition to occupy the space required by the boot record.
Action: Run FDISK to remove all partitions, then reboot the computer and run FDISK/
MBR. Also check for viruses.

"This image requires that the
destination drive have the same
geometry . . ."

Explanation: The image being transferred contains a geometry-dependent partition,
and the geometry of the source disk does not match the geometry of the target disk.
This means the disks are not seen as identical drives by the drive controller.

"Error flushing MBR sector." Explanation: The program was unable to write data to the first sector on the hard disk.
The image transfer is incomplete because the partition-table and/or master boot record
code was not successfully written, and the disk is in an indeterminate state.
Possible cause: This may be caused by a BIOS setting that prevents programmatic
access to the boot sector (see the CMOS setup).

Table 33: Partition Error Messages

Error Message Description
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