Hlavní uzel programu Plánovač úloh

Plánovač úloh

Pomocí programu Plánovač úloh můžete naplánovat spuštění příkazů, programů nebo skriptů v zadanou dobu:

  • Před použitím programu Plánovač úloh si přečtěte část Seznam.
  • Nápovědu ke konkrétním úlohám získáte v části Jak provést.
  • Všeobecné informace získáte v části Pojmy.
  • Pokyny pro řešení problémů získáte v části Odstraňování problémů.


Seznam programu Plánovač úloh

Seznam

V následující tabulce jsou uvedeny nejčastěji prováděné akce pomocí programu Plánovač úloh. Úplný seznam pokynů k programu Plánovač úloh naleznete v části Jak provést.

Krok | Odkaz
Před naplánováním spuštění úlohy musíte úlohu přidat. | Plánování nové úlohy
Po vytvoření naplánovaných úloh můžete upravit program, plán nebo zadání konkrétní úlohy. | Změna naplánované úlohy
Naplánované úlohy, které již nejsou nadále potřebné, lze zcela odstranit. | Odstranění naplánované úlohy
Pokud se naplánovaná úloha spustí v době, kdy počítač používáte, lze úlohu ukončit a později opět spustit. | Ukončení spuštěné naplánované úlohy
Všechny spuštěné naplánované úlohy lze dočasně ukončit nebo pozastavit a později opět spustit. | Dočasné zastavení všech naplánovaných úloh


Jak provést…

  • Plánování úloh
  • Správa programu Plánovač úloh


Plánování úloh
  • Spuštění programu Plánovač úloh
  • Plánování nové úlohy
  • Změna naplánované úlohy
  • Odstranění naplánované úlohy
  • Ukončení spuštěné naplánované úlohy
  • Okamžité spuštění úlohy


Spuštění programu Plánovač úloh

  • Program Plánovač úloh můžete spustit poklepáním na ikonu Tento počítač a na ikonu Naplánované úlohy.
  • Poklepáním na ikonu Naplánované úlohy a na ikonu Přidat naplánovanou úlohu spustíte Průvodce naplánovanou úlohou, který vás provede plánováním úlohy.


Plánování nové úlohy
  1. Spusťte program Plánovač úloh.
  2. Poklepejte na ikonu Přidat naplánovanou úlohu.
  3. Postupujte podle pokynů Průvodce naplánovanou úlohou.

Poznámky

  • Chcete-li nakonfigurovat upřesňující nastavení úlohy, zaškrtněte políčko Po klepnutí na tlačítko Dokončit chci upřesnit vlastnosti této úlohy na poslední obrazovce průvodce.
  • Pokud chcete, aby byla nová úloha opakovaně spouštěna při každém spuštění, zaškrtněte políčko Po klepnutí na tlačítko Dokončit chci upřesnit vlastnosti této úlohy na poslední obrazovce průvodce a potom klepněte na kartu Plán a tlačítko Upřesnit.
  • Vyžaduje-li program parametry, zaškrtněte políčko Po klepnutí na tlačítko Dokončit chci upřesnit vlastnosti této úlohy na poslední obrazovce průvodce, potom klepněte na kartu Úloha a zadejte argumenty do textového pole Spustit za cestou k úloze.
  • Přesvědčte se, zda je v počítači přesné systémové datum a přesný čas. Program Plánovač úloh tyto informace používá pro určení okamžiku spuštění naplánované úlohy. Chcete-li zkontrolovat nebo změnit datum a čas, poklepejte na ukazatel času na hlavním panelu.


Změna naplánované úlohy
  1. Spusťte program Plánovač úloh.
  2. Pravým tlačítkem myši klepněte na úlohu, kterou chcete změnit, a klepněte na příkaz Vlastnosti.
  3. Postupujte podle jednoho nebo více následujících pokynů:
    • Chcete-li změnit spouštěný program, zadejte do textového řádku Spustit cestu k novému programu.
    • Pokud chcete změnit plán úlohy, klepněte na kartu Plán.
    • Jestliže chcete upravit nastavení úlohy, klepněte na kartu Nastavení.

Poznámky

  • Pokud jste změnili uživatelský účet nebo spouštěný program, je potřeba zadat heslo uživatelského účtu.
  • Vyžaduje-li program úlohy parametry příkazového řádku, zadejte je za cestu k úloze do pole Spustit.
  • Jestliže cesta k programu úlohy obsahuje mezery, umístěte na začátek a na konec celé cesty uvozovky ("").
  • Přesvědčte se, zda je v počítači přesné systémové datum a přesný čas. Program Plánovač úloh tyto informace používá pro určení okamžiku spuštění naplánované úlohy. Chcete-li zkontrolovat nebo změnit tyto informace, poklepejte na ukazatel času na hlavním panelu.


Odstranění naplánované úlohy
  1. Spusťte program Plánovač úloh.
  2. Pravým tlačítkem myši klepněte na úlohu, kterou chcete odstranit, a klepněte na příkaz Odstranit.

Poznámky

  • Odstraněním naplánované úlohy dojde pouze k odstranění plánu ze seznamu časových plánů. Programový soubor nebude odstraněn z pevného disku.
  • Naplánovanou úlohu můžete odstranit také stisknutím klávesy DELETE.


Ukončení spuštěné naplánované úlohy
  1. Spusťte program Plánovač úloh.
  2. Pravým tlačítkem myši klepněte na úlohu, kterou chcete ukončit, a potom klepněte na příkaz Ukončit úlohu.

Poznámky

  • Pokud naplánovaná úloha spustí jiný program, ukončí tento příkaz pouze původní naplánovanou úlohu, ne však druhou úlohu.
  • Chcete-li znovu spustit ukončenou úlohu, klepněte pravým tlačítkem myši na úlohu a poté klepněte na příkaz Spustit.


Okamžité spuštění úlohy
  1. Spusťte program Plánovač úloh.
  2. Pravým tlačítkem myši klepněte na úlohu, kterou chcete spustit, a potom klepněte na příkaz Spustit.

Poznámky

  • Úlohu lze zastavit klepnutím na příkaz Ukončit úlohu v nabídce Soubor.
  • Pokud se úloha měla spustit, ale nestalo se tak, klepněte v nabídce Upřesnit na příkaz Zobrazit protokol a zkontrolujte protokol úlohy.


Správa programu Plánovač úloh
  • Zobrazení protokolu dříve naplánovaných úloh
  • Zobrazení naplánovaných úloh na vzdálených počítačích
  • Dočasné zastavení všech naplánovaných úloh
  • Ukončení programu Plánovač úloh
  • Nastavení účtu služby AT


Zobrazení protokolu dříve naplánovaných úloh
  1. Spusťte program Plánovač úloh.
  2. V nabídce Upřesnit klepněte na příkaz Zobrazit protokol.


Zobrazení naplánovaných úloh na vzdálených počítačích
  1. Na pracovní ploše poklepejte na ikonu Okolní počítače.
  2. Poklepejte na počítač, na kterém chcete zobrazit naplánované úlohy.
  3. Klepněte na ikonu Naplánované úlohy.

Poznámky

  • Úlohy na vzdáleném počítači se systémem Windows můžete zobrazit pouze tehdy, pokud jste správcem vzdáleného počítače.
  • Úlohy na vzdáleném počítači se systémem Windows můžete upravovat pouze tehdy, pokud má vzdálený počítač nainstalován software registru a sdílí x$, kde x je pevný disk, na kterém se nachází složka Naplánované úlohy. Na počítači se systémem Windows také musí být uveden konkrétně váš uživatelský účet s právem přístupu k vzdálenému registru. Poklepáním na panel Hesla v okně Ovládací panely můžete určit uživatele s přístupem k vzdálenému registru.


Dočasné zastavení všech naplánovaných úloh
  1. Spusťte program Plánovač úloh.

  2. V nabídce Upřesnit klepněte na příkaz Pozastavit program Plánovač úloh.

Poznámky

  • Tento příkaz je užitečný, pokud spouštíte další program (například hru) nebo instalujete software a nechcete, aby se současně spustily naplánované úlohy.
  • Úlohy, které by se spustily v době, kdy je program Plánovač úloh pozastaven, se spustí v dalším naplánovaném čase.
  • Chcete-li pokračovat v provádění plánů všech úloh, klepněte v nabídce Upřesnit na příkaz Pokračovat v používání programu Plánovač úloh .


Pozastavení programu Plánovač úloh
  1. Spusťte program Plánovač úloh.
  2. V nabídce Upřesnit klepněte na příkaz Ukončit používání programu Plánovač úloh.

Poznámka

  • Vypnete-li program Plánovač úloh, naplánované úlohy se nespustí a program Plánovač úloh se při následujícím spuštění systému Windows automaticky nespustí.


Nastavení účtu služby AT
  1. Spusťte program Plánovač úloh.
  2. V nabídce Upřesnit klepněte na příkaz Účet služby AT.
  3. Klepněte na možnost Tento účet a zadejte uživatelský účet, který bude spouštět úlohy naplánované pomocí příkazu at.
  4. Do textových polí Heslo a Potvrdit heslo zadejte správné heslo účtu.

Poznámky

  • Služba AT je dostupná pouze na počítačích se systémem Windows NT.
  • Můžete také klepnout na možnost Systémový účet. Pokud tak učiníte, spustí program Plánovač úloh pomocí účtu místního systému, který vyžaduje práva správce, úlohy příkazu at.

  • Určený uživatelský účet musí mít příslušná oprávnění ke spuštění všech úloh naplánovaných pomocí příkazu at. Jestliže například naplánujete program, který mohou spustit pouze správci, musíte určit účet správce.


Pojmy programu Plánovač úloh

Pojmy

Tato část poskytuje všeobecné informace o programu Plánovač úloh.

  • Úvod do programu Plánovač úloh
  • Použití programu Plánovač úloh
  • Program Plánovač úloh a příkaz At
  • Program Plánovač úloh a zabezpečení
  • Odstraňování problémů


Úvod do programu Plánovač úloh

Pomocí programu Plánovač úloh můžete naplánovat spuštění úloh (například programu Defragmentace disku) v době, která vám nejvíce vyhovuje. Program Plánovač úloh se spouští při každém spuštění systému Windows a pracuje na pozadí.

Pomocí programu Plánovač úloh lze:

  • Plánovat úlohy, které se mají spouštět denně, jednou za týden či za měsíc nebo v určenou dobu (například při spuštění počítače).
  • Změnit plán úlohy.
  • Ukončit naplánovanou úlohu.
  • Upravit způsob spuštění úlohy v naplánované době.


Použití programu Plánovač úloh

Operační systém Windows automaticky nainstaluje program Plánovač úloh. Chcete-li použít plánovací služby, poklepejte v okně Tento počítač na složku Naplánované úlohy.

Jestliže chcete přidat úlohy, poklepejte na ikonu Přidat naplánovanou úlohu, která spustí Průvodce naplánovanou úlohou. Úlohy lze přidat přetažením skriptů, programů nebo dokumentů z Průzkumníka systému Windows nebo z pracovní plochy do okna Naplánované úlohy.

Pomocí programu Plánovač úloh můžete také upravit, odstranit, pozastavit nebo ukončit naplánované úlohy, zobrazit protokol dříve naplánovaných úloh nebo zobrazit úlohy naplánované na vzdáleném počítači.

Podrobné informace o používání programu Plánovač úloh získáte v části Jak provést.

Nejlepší využití programu Plánovač úloh

V operačním systému Windows můžete pomocí programu Plánovač úloh naplánovat spuštění jakékoli aplikace. Chcete-li program Plánovač úloh využít co nejlépe, přesvědčte se před přidáním úlohy, zda je v počítači správně nastaveno systémové datum a čas.


Program Plánovač úloh a příkaz At

Kromě programu Plánovač úloh můžete automaticky spouštět úlohy také pomocí příkazu at.

Program Plánovač úloh není to samé, jako příkaz at, ale oba programy navzájem spolupracují. Naplánujete-li úlohu příkazem at, zobrazí se v seznamu úloh v okně Naplánované úlohy.

Programem Plánovač úloh můžete upravit vlastnosti úlohy naplánované pomocí příkazu at. Pokud tak však učiníte, musíte úlohu dále řídit pomocí programu Plánovač úloh. Úlohu již nelze řídit příkazem at.

Chcete-li určit uživatelský účet, který bude spouštět úlohy naplánované pomocí příkazu at, klepněte v okně Tento počítač na ikonu Naplánované úkoly a v nabídce Upřesnit klepněte na příkaz Účet služby AT.

Poznámka

  • Služba AT je dostupná pouze na počítačích se systémem Windows NT.


Zabezpečení programu Plánovač úloh

Program Plánovač úloh a zabezpečení

V programu Plánovač úloh lze nastavit zabezpečení přiřazením uživatelského jména a hesla konkrétní úloze. Po nastavení uživatelského jména a hesla nemůže být úloha stornována nebo odstraněna jiným uživatelem.

Poznámky

  • Funkce zabezpečení je dostupná pouze na počítačích se systémem Windows NT.
  • Před tím, než budete moci pokračovat v plánování úlohy, je potřeba v Průvodci naplánovanou úlohou zadat uživatelské jméno. Hesla nejsou vyžadována.
  • Zaškrtnutím políčka Po klepnutí na tlačítko Dokončit chci upřesnit vlastnosti této úlohy na poslední obrazovce průvodce můžete změnit nebo nastavit nové heslo.


Odstraňování problémů s programem Plánovač úloh

Pokud se naplánovaná úloha nespustí v očekávané době, klepněte pravým tlačítkem myši na úlohu a potom klepněte na příkaz Vlastnosti. Na kartě Úloha ověřte, zda je zaškrtnuto políčko Povoleno. Na kartě Plán ověřte, zda je naplánování nastaveno správně.

Pokud se program úlohy nespustí správně, bude možná nutné přidat argumenty příkazového řádku. Chcete-li získat další informace o konkrétním programu a jeho argumentech příkazového řádku, postupujte jedním z následujících způsobů:

  • Je-li dostupná, zobrazte nápovědu online programu.

  • Do příkazového řádku zadejte následující příkaz: (kde program je název programu)

    • program /?


Součásti systému Windows NT nejsou nainstalovány

Program nelze spustit

Možné důvody:

    • Správce systému program odstranil.
    • Správce systému změnil zásady přidružené k souboru.
    • Program není v počítači nainstalován.
    • Program byl omylem odstraněn.
    • Soubor je poškozen.

Pokud váš počítač řídí správce systému, měli byste ho požádat, aby zjistil, proč nelze program spustit.