


The Contact Manager database
Welcome to the Contact Manager database! This database is designed to help you quickly and easily manage 
your personal and business contacts. With this database, you can:

· Save information on all of your personal and business contacts.

· Keep a permanent record of the time and subject of all calls.

· Easily send electronic mail to any contact.

· Set reminders of future events.

· Print labels or envelopes.

· Even export your contact list to Microsoft Word.

To see an overview of the application, click    .

To start working right away, click    .



The Switchboard form
The Switchboard form is the first thing you’ll see when you start the Contact Manager application. You can click 
the buttons on the Switchboard form to go to the other parts of the application, such as the Contacts form, where 
you can enter your contacts, or the Contact List report, which you can print. 



The Contacts form
On the Contacts form, you can enter and later retrieve data on all of your contacts. To enter or change 
information, just click the mouse in any box on the form and start typing. You can use the navigation bar at the 
bottom of the form to move between contacts.



Using the tabs on the Contacts form
The Contacts form uses tabs to display more information in less space. As you click the tabs along the top of the 
form, the information shown changes. Each tab contains a subset of the information about a contact: basic 
information, phone call history, personal information, corporate address, or shipping address. 



Sending electronic mail
If you enter e-mail addresses for your contacts, you can quickly create new e-mail messages by clicking the E-
mail button on the Contacts form. This will open a new e-mail message in your default e-mail editor. Just type 
your message and click Send.



Working with reminders
To enter a reminder for a contact, click the Add Reminder button on the Contacts form. You enter the text and 
date for the reminder on the form shown below. Whenever you open your database, all the reminders for the 
current day are displayed. However, if you enter a reminder for today, it won't be displayed until you close and 
reopen the database.



The Contact List and Call Summary reports
The Contact Manager database includes a number of reports that you can print to summarize information. Two of
these are the Contact List and Call Summary reports. You can preview any report by clicking Preview Reports on
the main Switchboard form.



The Reminders report
The Reminders report provides a complete list of all the reminders entered in your database. You can print this 
report and keep it with your calendar to remind you of upcoming appointments. To preview the Reminders report,
click Preview Reports on the main Switchboard form.



Work with your contacts
Microsoft Access provides you with a great deal of power and flexibility. Choose a category below to see the 
things that you can do with the Contact Manager database. 

What do you want to do?

            Sort, find, and filter your contacts  
            Add, edit, and delete information  
            Print  
            Remove sample data  
            Take care of your database  
            Use your data with other programs  



Sort, find, and filter your contacts
Although your Contact Manager database may contain a lot of information, you don’t have to view it all at one 
time. With Microsoft Access, you can find certain contacts by searching for specific values, filter your contacts, 
and sort contacts in the order you prefer.

What do you want to do?

            Switch between viewing one contact and viewing many contacts  
            Sort contacts  
            Find specific information  
            Replace specific information  
            Use wildcard characters to search for information  
            Filter contacts by entering values in a blank view of your form or datasheet  
            Filter contacts by selecting values in your form or datasheet  
            Find a specific contact by scrolling  
            Remove a filter from a form  
            Move between contacts by using navigation buttons  



Add, edit, and delete information
Editing information is simple with the Contact Manager database. The topics listed below will help you enter new 
contacts into your database, change the contents of contacts that you’ve already entered, or delete a contact 
that you no longer require.

What do you want to do?

            Add a new address  
            Save an address  
            Delete a contact  
            Copy or move data from one field to another  
            Copy or move data from multiple fields in Datasheet view  
            Copy or move records to a datasheet  
            Duplicate a value from the previous record  
            Add a new value to a combo box  
            Edit the data in a field  
            Undo changes when adding or editing data  
            Check the spelling of data in Datasheet view  
            Check the spelling of data in Form view  
            Automatically correct typing when I  ’  m entering data  
            Select fields and records in Datasheet view  



Print
The reports in your database can be previewed on screen or printed on your printer. 

What do you want to do?

            Print a report  
            Set margins, page orientation, and other report features  
            Print envelopes  



Take care of your database

What do you want to do?

            Repair a damaged database  
            Back up a database  
            Restore a database from a backup copy  
            Compact a database to free disk space  
            Make a change to a switchboard  



Use your data with other programs
The Contact Manager database is designed to make it easy to use your data for many purposes. For example, 
you can export any of your data to Microsoft Word, or you can print envelopes or labels for some or all of your 
contacts.

What do you want to do?

            Merge data with Microsoft Word  
            Print envelopes  



Use Show Me Help
The Contact Manager database includes Show Me Help to get you started on common procedures. 

1 On the Contact Manager menu bar, click Show Me.
2 Click the Contents tab.
3 Double-click a book to see the topics within the book.
4 Double-click a topic to see that topic.



Print a book from Help contents
If you’d like to work from a printed copy instead of the on-screen Help, it’s easy to print a book from the Help 
contents.

1 On the Contact Manager menu bar, click Show Me.
2 Click the Contents tab.
3 Double-click a book to see the topics within the book.
4 Click Print .
5 Choose a printer and click OK.



Remove sample data
When you first open the Contact Manager database, it will contain some sample data. This data lets you explore 
the capabilities of the application without needing to enter your own contacts first. Before you start entering your 
own contacts, you should delete this sample data. 

Once you delete the sample data, you can’t return it to the database.

1 On the Switchboard form, click the Administration button. This will open the Administration Switchboard form.
2 On the Administration Switchboard form, click the Remove Sample Data button.
3 Click Yes to confirm that you’d like to delete the sample data.



Switch between viewing one contact and many contacts
In the Contact Manager database, you can view your data in Datasheet view or in Form view. In Datasheet view, 
you view multiple contacts at one time; in Form view, you concentrate on a single contact. By default, the 
Contacts form opens in Form view, but you can easily switch to Datasheet view at any time.

To switch from Form view to Datasheet view
1 Open the Contacts form.
2 On the View menu, click Datasheet View.

To move from Datasheet view to Form view

1 Open the Contacts form.
2 On the View menu, click Form View.



Add a new value to a combo box
The Contact Manager database uses combo boxes in several places so you can choose from a list of values. For
example, the initial set of values in the Contact Type combo box on the Contact tab of the Contacts form is 
Buyer, Manager, and Seller. It’s easy to add new values to this list. For example, here's how you could add 
Assistant as a Contact Type.

1 In the Contact Type combo box, select the value in the field and type Assistant in its place.
2 Press ENTER.
3 Click Yes to confirm that you want to create a new Contact Type.
Your new contact type will now be available in the combo box.



Print envelopes
You can print labels or envelopes for any of the contacts in your Contact Manager database. You can print one, 
several, or all envelopes.

1 On the Main Switchboard form, click Preview Reports.
2 On the Reports Switchboard form, click Print Labels or Envelopes.
3 On the Print Envelopes tab, select either the shipping or company address.
4 Select the contacts you want to print envelopes for, or select the Select All Contacts check box to print a 

complete set of envelopes.



Add a new address 
1 On the Main Switchboard, click Enter/View Contacts. 

2 Click New Record        on the toolbar.
3 Type the data you want, and then press TAB to go to the next field.
4 To enter other information, click one of the tabs at the top of the form.



Save a record
Microsoft Access automatically saves the record you are adding or editing as soon as you move the insertion 
point to a different record, or close the form or datasheet you are working on.

· To explicitly save the data in a record while you are editing it, click Save Record on the Records menu. 



Delete a record
1 On the Main Switchboard, click Enter/View Contacts. 
2 Click the record you want to delete.

3 Click Delete Record        on the toolbar.



Copy or move data from one field to another
1 On the Main Switchboard, click Enter/View Contacts. 
2 Select the data you want to copy or cut.
            How?  

3 To copy the data, click Copy        on the toolbar.

To move the data, click Cut        on the toolbar.
4 To replace the current value of the destination field, select the whole field. 

To insert the data into the existing data, position the insertion point where you want to paste the data.

5 Click Paste        on the toolbar.
For information on troubleshooting paste problems, click    .



Copy or move data from multiple fields in Datasheet view
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View. 
2 Select the fields or columns you want to copy or cut.
            How?  

3 To copy the data, click Copy        on the toolbar.

To move the data, click Cut        on the toolbar.
4 Select the destination field or fields.

5 Click Paste        on the toolbar.
For information on troubleshooting paste problems, click    .



Copy or move records to a datasheet
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View. 
2 Select the record or records you want to copy or move. 
            How?  

Note      If you're copying or moving records from another application, be sure the data is arranged in a 
spreadsheet or table, or separated by tab characters, before you select it.

3 To copy records, click Copy     on the toolbar.

To move records, click Cut     on the toolbar.
4 Open the datasheet you want to paste the records into. If necessary, rearrange the columns of the datasheet 

to match the order of the data you are copying or moving.
5 To replace records with the records you selected, select the records you want to replace, and then click Paste 

    on the toolbar.
To append records to the end of the datasheet, click Paste Append on the Edit menu.

If the source datasheet has more fields than the destination datasheet, Microsoft Access doesn't paste the extra 
fields. For information on troubleshooting paste problems, click    .



Troubleshoot problems when pasting data

What do you need help with?

            I can't paste the data. Why not?  
            The data I pasted is in the wrong field. Why?  



Microsoft Access can't paste the data. Why not?
There are several reasons why Microsoft Access will not paste some or all of your data:

· You tried to paste an entire field or fields without selecting a destination. You must select the field or fields that
you want to paste to. For information on selecting fields, click    .

· You tried to paste more fields than the datasheet you're pasting to has, or more than the number of fields 
you selected as a destination. Microsoft Access doesn't paste the extra fields.
· You tried to paste a value that's not compatible with the data type of the field. For example, you tried to 
paste a combination of letters and numbers into a field with the Number data type.
· You tried to paste text that's too long for the field. The setting in the FieldSize property determines the 

maximum size of a field value. Check the field in table Design view to see the setting.
· You tried to paste a duplicate value into the table's primary key or into a field that has the Indexed property 

set to No Duplicates. Check the field in table Design view to see the setting.
· You tried to paste data into a hidden field. This is not permitted. To display hidden columns, click Unhide 

Columns on the Format menu.
· You tried to remove data from or paste data into a disabled, locked, calculated, or AutoNumber field.
· You don't have permissions to add or edit data in the database object.
· A value you tried to paste isn't allowed in the field based on the settings of the ValidationRule, InputMask, 

Required, or AllowZeroLength properties.
· The validation macro specified for the BeforeUpdate or OnInsert properties canceled the update. The data 

you tried to paste did not meet the validation requirements.



The data I pasted is in the wrong field. Why?
· When you paste records into a datasheet, Microsoft Access places them in the order they appear in the 

columns of the datasheet, regardless of the names of the fields. If you want the data to be pasted according to
corresponding field names, paste them into a form in Form view.

· When you paste records into a form, Microsoft Access places them into fields with the same name as the 
source fields, regardless of their order on the form. However, if there are no matching field names, the data is 
placed according to the form's tab order, which may not be the order you intend.



Insert the value that is in the same field in the previous record
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View.
2 Click in the field in which you want to insert the value.
3 Press CTRL+APOSTROPHE (').



Edit the data in a field
1 On the Main Switchboard, click Enter/View Contacts. 
2 To edit data within a field, click in the field you want to edit.

To replace the entire value, move the pointer to the leftmost part of the field until it changes into the plus 

pointer    ,    and then click. 
3 Type the text you want to insert. 
Notes      
· If you make a typing mistake, press BACKSPACE. If you want to cancel your changes in the current field, press

ESC. If you want to cancel your changes in the entire record, press ESC again before you move out of the 
field.

· When you move to another record, Microsoft Access saves your changes.



Expand a field or text box to make it easier to edit 
1 On the Main Switchboard, click Enter/View Contacts. 
2 Click the field you want to edit. 
3 Press SHIFT+F2.
Note      To expand a property box in Design view of tables, queries, forms, reports, and macros, you can also 
right-click a property box, and then click Zoom.



Undo changes when adding or editing records

· Click Undo        on the toolbar to take back your most recent change.
· Click Undo Saved Record on the Edit menu if you have already saved changes to the current record, or 
have moved to another record. 

As soon as you begin editing another record, apply or remove a filter, or switch to another window, you can't use 
these methods for correcting changes. 



Troubleshoot editing data in a field
There are several kinds of fields in forms or datasheets that you can't edit. The following fields display values just
as regular fields do, but if you try to enter data into them, nothing happens:

· AutoNumber fields. If a field has an AutoNumber data type, Microsoft Access automatically assigns the next 
consecutive number or unique random number to this field for each record you add. This type of field is often 
used as a record ID number or primary key. When you start adding a new record, Microsoft Access 
automatically fills in the field's value for you and you can't edit it.

· Calculated fields. A Calculated field displays values that Microsoft Access calculates. They are usually based 
on other fields in your tables, but calculated fields are not stored in tables. You can't edit calculated fields.

· Locked or disabled fields. If a control on a form has the Locked property set to Yes or the Enabled property 
set to No, you can't edit the data in the field.



Check the spelling of data in Datasheet view
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View.
2 Select the records, columns, fields, or text within a field whose spelling you want to check.
            How?  

3 Click Spelling        on the toolbar.
Note      In the Spelling dialog box, click Add if you want to add the word that is in the Not In Dictionary box to 
the custom dictionary listed in the Add Words To box.



Check the spelling of data in Form view
1 On the Main Switchboard, click Enter/View Contacts.
2 Select the field or text whose spelling you want to check.

3 Click Spelling        on the toolbar.
Note      In the Spelling dialog box, click Add if you want to add the word that is in the Not In Dictionary box to 
the custom dictionary listed in the Add Words To box.



Automatically correct typing when I'm entering data
Use AutoCorrect to automatically correct text that you frequently mistype, and to automatically replace 
abbreviations with long names. For example, you can create an entry "esq" for "Martin R. Esquivel." Whenever 
you type esq followed by a space or punctuation mark, Microsoft Access automatically replaces "esq" with the 
name Martin R. Esquivel.

1 On the Tools menu, click AutoCorrect.
2 Select the Replace Text As You Type check box.
3 In the Replace box, type the text that you want corrected automatically.
4 In the With box, type the corrected text.
5 Click Add.
Notes      
· AutoCorrect won't correct text that was typed before you selected the Replace Text As You Type check box.
· If in the preceding example you actually want "esq" to appear in one case, clear the Replace Text As You 

Type box, type esq in a field and save the field by moving to another record. Then select the Replace Text 
As You Type box again. Microsoft Access will not change the previously typed and saved "esq."



Stop the automatic correction of an entry I make when I'm entering data
1 On the Tools menu, click AutoCorrect.
2 Click the entry you want to delete in the box at the bottom.
3 Click Delete.



Add an AutoCorrect entry while checking spelling
1 In the Spelling dialog box, in the Change To box, type the corrected text.
2 Click AutoCorrect in the Spelling dialog box.
When you type the text that is in the Not In Dictionary box as you add data to tables or forms, Microsoft Access 
will automatically change it to the text in the Change To box. 



Stop automatic corrections that occur when I'm entering data
1 On the Tools menu, click AutoCorrect.
2 Clear the check boxes for the options you want to turn off.



Selecting fields and records in Datasheet view
The following table lists mouse techniques for selecting data or records in Datasheet view.

To select Click
Data in a field Where you want to start selecting and drag

across the data.
An entire field The left edge of the field in a datasheet, 

where the pointer changes into    .
Adjacent fields The left edge of a field and drag to extend 

the selection.
A column The field selector.
Adjacent columns The field name at the top of the column 

and then, without releasing the mouse, 
drag to extend the selection.

A record The record selector.
Multiple records The record selector of the first record, and 

then drag to extend the selection.
All records Select All Records on the Edit menu.

The following table lists keyboard techniques for selecting data or records in Datasheet view.

To select Do this
Data in a field Move the insertion point to the start of the 

text you want to select, and then hold down
SHIFT and press the arrow keys to move to 
the end of the selection.

An entire field Move the insertion point to the field, and 
press F2.

Adjacent fields With a field selected, hold down SHIFT and 
press the appropriate arrow key.

The current column Press CTRL+SPACEBAR.
The current record Press SHIFT+SPACEBAR.
Multiple records Press SHIFT+SPACEBAR, and then 

SHIFT+UP ARROW or SHIFT+DOWN ARROW.

Moving between records using navigation buttons in Datasheet or Form view
The navigation buttons are located at the bottom of the window in Datasheet  or Form view. You can use these 
buttons to quickly move between records.



Resize rows in Datasheet view
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View.
2 Position the pointer between two record selectors at the left side of the datasheet, as shown in the following 

illustration.

3 Drag the edge of the row until the row is the desired height.
Notes
· This resizes all the rows in the datasheet at the same time.
· You can't undo changes to the size of rows using the Undo command on the Edit menu. To undo changes, 

close the datasheet, and then click No when asked if you want to save changes to the layout of the datasheet.



Resize a column in Datasheet view
1 On the Main Switchboard, click Enter/View Contacts. Then, on the View menu, click Datasheet View..
2 Position the pointer on the right edge of the column you want to resize, as shown in the following illustration.

3 Drag until the column is the desired width.
Note      You can't undo changes to the width of columns using the Undo command on the Edit menu. To undo 
changes, close the datasheet, and then click No when asked if you want to save changes to the layout of the 
datasheet.



Find a specific record by scrolling in a datasheet or form
If there are more records than fit in your Datasheet view or continuous form window, you can use the scroll box 
on the scroll bar to find a specific record.

· Drag the scroll box up or down on the scroll bar.
Next to the scroll box, Microsoft Access displays the number of the record at the top of the screen.

If you have a Microsoft IntelliMouse™, you can use the wheel button to scroll to a specific record depending on 
your current view.

View Description
Datasheet 
or subform 
displayed 
as a 
datasheet

The wheel 
button scrolls 
row by row 
but the cursor
does not 
move.

Single form 
or subform 
displayed 
as a single 
form

The wheel 
button goes 
to the next or 
previous 
record, and 
the cursor 
moves as 
well.

Continuous 
form or 
sub-form 
displayed 
as a 
continuous 
form

The wheel 
button goes 
to the next or 
previous 
record, but 
the cursor 
does not 
move.



Switch between views of a form
· Click the View   button   on the toolbar. To change to the view indicated by the graphic, click the button itself. To 

see a list of other views to choose from, click the arrow next to the button.



Sort records
1 On the Main Switchboard, click Enter/View Contacts. 
2 Click the field you want to use for sorting records. 
3 Do one of the following:

· To sort in ascending order, click Sort Ascending    . 

· To sort in descending order, click Sort Descending    . 
Note      In a form, you can sort on only one field at a time; in a datasheet, you can select two or more adjacent 
columns at the same time, and then sort them. Microsoft Access sorts records starting with the leftmost selected 
column. When you save the form or datasheet, Microsoft Access saves the sort order.



Remove a sort order from a form
· In Datasheet view or Form view, click Remove Filter/Sort on the Records menu. If you specified the sort 

order in the Advanced Filter/Sort window where you also specified criteria for a filter, you can delete the sort 
order in the Sort cell in the design grid and still leave the filter's criteria intact.



Find specific occurrences of a value in a field
You can find all occurrences of a specified value at once, or each occurrence one at a time. 

1 On the Main Switchboard, click Enter/View Contacts. 
2 Select the field (column) you want to search, unless you want to search all fields. (Searching a single field is 

faster than searching the entire table.)

3 Click Find        on the toolbar.
4 In the Find What box, type the value you want to find.

If you don't know the exact value you want to find, you can use wildcard characters in the Find What box to 
specify what you're looking for. For examples of wildcard characters and how to use them, click    . 

4 Set any other options you want to use in the Find dialog box.
5 To find the first occurrence of the value, click Find First. To find the next occurrence of the value and all 

subsequent occurrences, continue clicking Find Next.



Replace specific occurrences of a value in a field
You can replace all occurrences of the specified value at once or each occurrence one at a time.

1 On the Main Switchboard, click Enter/View Contacts. 
2 Select the field (column) you want to search, unless you want to search all fields. (Searching a single field is 

faster than searching the entire table.)
3 On the Edit menu, click Replace.
4 In the Find What box, type the value you want to find; in the Replace With box, type the value you want to 

replace it with.
If you don't know the exact value you want to find, you can use wildcard characters in the Find What box to 
specify what you're looking for. For examples of wildcard characters and how to use them, click    . 

4 Set any other options you want to use in the Replace dialog box.
5 To replace all occurrences of the specified value at once, click Replace All. 

To replace each occurrence one at a time, click Find Next, and then click Replace; to skip an occurrence and
find the next one, click Find Next.



Filter records by entering values in a blank view of your form or datasheet
1 On the Main Switchboard, click Enter/View Contacts. 

2 Click Filter By Form        on the toolbar to switch to the Filter By Form window.
3 Click the field in which you want to specify the criteria that records must meet to be included in the filtered 
set of records.
4 Enter your criteria by selecting the value you're searching for from the list in the field (if the list includes field 
values), or by typing the value into the field.    

· To find records in which a check box, toggle button, or option button is or is not selected, click the check 
box or button until it's the way you want. To return it to a neutral position so that it won't be used as criteria 
for filtering records, continue clicking the check box or button until it's grayed. 

· To find records in which a particular field is empty or not empty, type Is Null or Is Not Null into the field. 
(You can select these options from the list in fields with a Memo, OLE Object, or Hyperlink data type, and 
in calculated fields in queries.)

If you specify values in more than one field, the filter returns records only if they contain the same values you 
specified in each of those fields.

5 To specify alternative values that records can have to be included in the filters results, click the Or tab at the 
bottom of the window, and enter more criteria.
The filter returns records if they have all the values specified on the Look For tab or all the values specified 
on the first Or tab or all the values specified on the second Or tab, and so on.

6 Click Apply Filter        on the toolbar.
Note      When you save a table or form, Microsoft Access saves the filter. You can reapply the filter when you 
need it, the next time you open the table or form.



Filter records by selecting values in a form, subform, or datasheet
1 In a field on a form or datasheet, find one instance of the value you want records to contain in order to be 

included in the filter's results.

2 Select the value, and then click Filter By Selection        on the toolbar. How you select the value 
determines what records the filter returns. For more information on selecting values, click    

.
Repeat step 2 until you have the set of records you want.

Notes

· When you save a table or form, Microsoft Access saves the filter. You can reapply the filter when you need it, 
the next time you open the table or form.

· You can also filter for records that do not have a certain value. After selecting a value, right-click it, and then 
click Filter Excluding Selection.



Ways to select values for a filter to affect what records are returned
You can select all or part of a value in a field. How you select the value determines what records the filter returns.

Selecting Finds records in which Example
The entire contents 
of a field (or placing 
the insertion point in 
a field without 
selecting anything)

The entire contents of 
that field matches the 
selection.

You select the value 
"Berlin" in the City field. 
The filter returns all 
records with Berlin as the 
city. 

Part of a value 
starting with the first 
character in a field

The value in that field 
starts with the same 
characters you selected.

In the CompanyName 
field containing the value 
"France restauration," you
select only "Fran." The 
filter returns all records 
that have a company 
name starting with "Fran,"
such as Franchi S.p.A. 
and Frankenversand.

Part of a value 
starting after the first
character in a field

All or any part of the 
value in that field 
contains the same 
characters you selected.

In the CompanyName 
field containing the value 
"Old World Delicatessen,"
you select the letters 
"Del." The filter returns all 
records that have "del" 
anywhere in the 
CompanyName field, 
such as Ernst Handel, 
Galería del gastrónomo, 
and Que Delícia.



Clear all the fields in the Filter By Form window

· Click Clear Grid        on the toolbar.



Delete an Or tab at the bottom of the Filter By Form window
1 Click the Or tab you want to delete.
2 On the Edit menu, click Delete Tab.



Remove a filter from a form

· To remove a filter and show the records that were displayed previously in the form, click Remove Filter      
on the toolbar in Datasheet view or Form view.

Note        Removing a filter doesn't delete it. You can reapply the filter by clicking Apply FIlter        on the 
toolbar.



About using wildcard characters to search for partial or matching values 
You use wildcard characters as placeholders for other characters when you are specifying a value you want to 
find and you:

· Know only part of the value.
· Want to find values that start with a specific letter or match a certain pattern.
You can use the following characters in the Find and Replace dialog boxes, or in queries, commands, and 
expressions, to find such things as field values, records, or file names.

Character Usage Example
* Matches any number of 

characters. It can be used 
as the first or last 
character in the character 
string.

wh* finds what, white,
and why

? Matches any single 
alphabetic character.

B?ll finds ball, bell, 
and bill

[ ] Matches any single 
character within the 
brackets.

B[ae]ll finds ball and 
bell but not bill

! Matches any character not
in the brackets.

b[!ae]ll finds bill and 
bull but not bell

- Matches any one of a 
range of characters. You 
must specify the range in 
ascending order (A to Z, 
not Z to A).

b[a-c]d finds bad, 
bbd, and bcd

# Matches any single 
numeric character.

1#3 finds 103, 113, 
123

Notes      
· Wildcard characters are meant to be used with text data types, although you can sometimes use them 

successfully with other data types, such as dates, if you don't change the Regional Settings properties for 
these data types.

· When using wildcard characters to search for an asterisk (*), question mark (?), number sign (#), opening 
bracket ([), or hyphen (-), you must enclose the item you're searching for in brackets. For example, to 
search for a question mark, type [?] in the Find dialog box. If you're searching for a hyphen and other 
characters simultaneously, place the hyphen before or after all the other characters inside the brackets. 
(However, if you have an exclamation point (!) after the opening bracket, place the hyphen after the 
exclamation point.) If you're searching for an exclamation point (!) or closing bracket (]), you don't need to 
enclose it in brackets.

· You can't search for the opening and closing brackets ([ ]) together because Microsoft Access interprets this 
combination as a zero-length string. 

· If you're searching for values in a table other than a Microsoft Access table, such as a Microsoft SQL Server 
table, you may need to use different wildcard characters. Check the documentation for that data source for 
more information.



Print a report
Before you print a report for the first time, you might want to check the margins, page orientation, and other page 
setup options. For more information, click    .

1 On the Main Switchboard, click Preview Reports.
2 Select the report you want to print. It will open in Print Preview.
3 On the File menu, click Print. 
4 Enter the settings you want in the Print dialog box.

· Under Printer, specify a printer.
· Under Print Range, specify all pages or a range of pages.
· Under Copies, specify the number of copies and whether they should be collated.

4 Click OK.

Tip      To print a report without bringing up the dialog box, click Print        on the toolbar.



Set margins, page orientation, and other page setup options
1 On the Main Switchboard form, click Preview Reports.
2 Select the report you want to print. It will open in Print Preview.
3 On the File menu, click Page Setup.
4 Click the following tabs for the options you want to set:

· Margins. To set margins and whether to print data only.
· Page. To set orientation, paper size, and printer.
· Columns. To set number, size, and layout of columns for forms, reports, and macros only.

5 Click OK.
6 On the File menu, click Save.



Repair a damaged database
In most cases, Microsoft Access will detect that a database is damaged when you try to open or compact it and 
give you the option to repair the database at that time. In some situations, Microsoft Access may not detect that a
database is damaged. If a database behaves unpredictably, perform the following procedure.

To repair the current database

· On the Tools menu, point to Database Utilities, and then click Repair Database.

To repair a database that isn't open in Microsoft Access

1 Close the current database.
2 On the Tools menu, point to Database Utilities, and then click Repair Database.
3 Specify the name and location of the database you want to repair, and click Repair.



Back up a database
1 Close the database. 
2 Using the Windows Explorer, My Computer, Microsoft Backup, the MS-DOS copy command, or other backup 

software, copy the database file (an .mdb file) to a backup medium of your choice.
Notes      
· If you are backing up to a floppy disk and your database file exceeds the size of the disk, you cannot use 

Windows Explorer or My Computer to back up your database; you must use Microsoft Backup or backup 
software so that you can copy the file over more than one disk.

· You can back up individual database objects by creating a blank database and then importing the objects you 
want from the original database.

· You can't use the FileCopy statement in a second instance of Microsoft Access to back up a database you 
have open in the first instance of Microsoft Access.



Restore a database from a backup copy
· Depending on what method was used originally to produce the backup copy, use the Windows Explorer, My 

Computer, Microsoft Backup, MS-DOS copy or restore commands, or other backup software to copy the 
backup database file to your database folder.

Caution      If the existing database file in the database folder and the backup copy have the same name, 
restoring the backup copy may replace the existing database file. If you want to save the existing file, rename it 
before you copy the backup file.



Compact a database to defragment the file and free disk space
If you delete tables, your database can become fragmented and use disk space inefficiently. Compacting the 
database makes a copy of the database, rearranging how the database file is stored on disk.

To compact the current database

· On the Tools menu, point to Database Utilities, and then click Compact Database.

To compact a database that isn't open in Microsoft Access

1 Close the current database.
2 On the Tools menu, point to Database Utilities, and then click Compact Database.
3 In the Database To Compact From dialog box, specify the database you want to compact, and click 

Compact.
4 In the Compact Database Into dialog box, specify a name, drive, and folder for the compacted database.
5 Click Save.
If you use the same name, drive, and folder, and the database is compacted successfully, Microsoft Access 
replaces the original file with the compacted version.

Notes      
· If you delete records from the end of a table that has an AutoNumber field, when you compact the database, 

Microsoft Access will reset the AutoNumber value for the next added record to a value of one more than the 
last undeleted AutoNumber value.

· A database will not compact if you don't have enough storage space on your disk for both the original and 
compacted versions of the database. Delete any unneeded files and try again.



Merge data using the Microsoft Word Mail Merge Wizard
1 On the Main Switchboard, click Merge It With MS Word.
2 Follow the instructions in the Microsoft Word Mail Merge Wizard. 
3 In the Microsoft Word window, click Insert Merge Field to insert the desired fields into the document. 
Note      You can also begin the operation of merging data into form letters from within Microsoft Word. For more 
information, see your Microsoft Word documentation.



Make a change to an existing switchboard
1 Open the database.
2 Do one of the following to open the Switchboard Manager dialog box:

· If you created the switchboard by using the Database Wizard, click Change Switchboard Items in the 
opening switchboard.

· If you created the switchboard by using the Switchboard Manager, click Add-ins on the Tools menu, and 
then click Switchboard Manager.

3 Click the switchboard you want to edit, and then click Edit.
4 Click the item on the switchboard you want to change, and then do one of the following:

· To change the text of the item, the command performed by the item, or the object that's opened or run 
when you click the button, click Edit. 

· To add an item, click New, type the text for the item, and then click a command in the Command box. 
Depending on which command you click, Microsoft Access displays another box below the Command box.
Click an item in this box, if necessary. For example, if you click one of the form commands in the 
Command box, click the name of the form you want to open.

· To delete an item, click Delete.
· To move an item, click Move Up or Move Down.

5 When you've finished changing items, click Close.




