


Introducing Norton File Compare

Norton File Compare lets you easily compare different versions of a text file, see what 
changed between versions, and selectively undo changes. You can use Norton File 
Compare to compare any two text files, so it is ideal for comparing different versions of 
initialization (INI) files, program source code files, and even HTML files designed for 
viewing on the World Wide Web. You can also use Norton File Compare together with 
Norton Registry Tracker to track modifications and undo changes made to critical files and 
Windows registry settings.
Norton File Compare provides an easy way to completely manage file comparisons:

You can identify file differences quickly by text color-coding in the side-by-side file 
displays.

You can undo selected changes easily, and see the results of undo operations before 
you commit to them.

You can launch a text editor instantly to make changes directly to either of the files 
being compared.

You can customize the display and specify changes to be ignored.
You can switch to INI viewing mode to compare INI files which sorts the INI file 

sections and entries alphabetically.
You can compare registry export (REG) files displayed as fully-expanded registry keys 

and values similarly to how they are displayed in Norton Registry Editor
When used with Norton Registry Tracker, you can have Norton File Compare compare 
registry key settings or versions of initialization (INI) files that changed across snapshots, 
and selectively undo changes that occurred between snapshots. By allowing you to undo 
specific changes between snapshots, it provides the perfect complement to the Quick Fix 
and Restore features of Norton Registry Tracker.
To compare files, click here        to start Norton File Compare.

{button ,AL(`Introducing Norton Registry Tracker;Introducing Norton Registry 
Editor;Display characteristics;Undoing changes;Comparing files with Norton File 
Compare',0,`',`')}    Related Topics



Comparing files with Norton File Compare

When you first open Norton File Compare, it prompts you for two filenames, then 
compares the files and displays the results in a special two-pane display. The panes are 
synchronized such that scrolling the display scrolls the files in both panes.
To get an overall sense of what's changed between the files, the Comparison Statistics 
window gives you a quick score of the lines added to the newer file, lined deleted from the
older file, and lines moved (lines that are identical but whose position is different in the 
two files).
Norton File Compare tries to display identical lines side-by-side to make comparisons 
easier. To do so, Norton File Compare "pads" the display with blank lines. These lines don't
represent actual blank lines in the files, but are there to help you quickly recognize file 
similarities. You can distinguish padded lines from "real" blank lines by having Norton File 
Compare show you line numbers. Lines that exist in the files are preceded by line 
numbers; padding lines are not.
Lines that differ in the two files are displayed in a different color (red by default) to help 
you find them quickly. Lines that have been moved are displayed in blue by default. You 
can change these colors and the font used for the display panes from the Display Options 
tab of the Norton File Compare Settings dialog box.
For identical lines whose position is different in the two files, Norton File Compare tells you
how the lines have moved. Read across the panes to discover where the lines in the older 
file were moved to and where the lines in the newer file were moved from.

{button ,AL(`Introducing Norton File Compare;To open Norton File Compare;To set 
comparison options;To set display options',0,`',`')}    Related Topics



Ignoring certain changes

You can have Norton File Compare ignore certain text file characteristics and changes, if 
they're not important to you. This prevents unimportant changes from showing up in the 
file comparison. From the Comparison tab of the Norton File Compare Options dialog box 
you can check any of these options:

Ignore All Tabs And Spaces
Norton File Compare will completely disregard any whitespace characters in the files. Neither
adding new whitespace characters nor changing existing ones will be considered a change 
to the files. For example, "one two three" would be considered identical to "onetwothree" if 
this box is checked.

Ignore Changes In Tabs And Spaces
Norton File Compare will ignore changes in the length of existing whitespace areas, but will 
still consider the addition of new whitespace characters as changes. For example, "one two" 
would be considered identical to "one two,” but different from "onetwo" if this box is 
checked.

Ignore Upper/Lower Case Changes
For example, "Hello World" would be considered the same as "hello world" if this box is 
checked.

{button ,AL(`Introducing Norton File Compare;To set comparison options',0,`',`')}    Related
Topics



Display characteristics

You can customize the text characteristics used in the Norton File Compare display panes. 
From the Display tab of the Norton File Compare Options dialog box you can control these 
display characteristics:

Show Comparison Statistics
Checking this displays the Comparison Statistics window, which gives you a quick score of 
the lines added to the newer file, lined deleted from the older file, and lines moved (lines 
that are identical but whose position is different in the two files).

Show Line Numbers
Checking this displays line numbers in both panes of Norton File Compare. Showing the line 
numbers makes it easier to understand how lines have moved in the file, by letting you see 
where they have moved from and to. It also helps you distinguish blank lines that exist in the
files (which would be numbered) from those added to the display for "padding" to make 
identical lines appear in parallel in the two panes.

Fonts and Colors
You can also specify the color Norton File Compare uses to display differing and moved text, 
and the font style and size used for the display panels.

{button ,AL(`Introducing Norton File Compare;To set display options;To view INI files in 
Norton File Compare;To view differences only',0,`',`')}    Related Topics



Searching within files

Norton File Compare helps you search through the files you are comparing. There are two 
basic types of searches Norton File Compare can perform:

Text search
Norton File Compare searches for specific text that you enter. You can specify whether or not
this type of search is case-sensitive.

Block search
Norton File Compare searches for groups ("blocks") of text that either match or differ 
between the two files being compared. For purposes of this type of search, any pair of files 
that is compared can be thought of as potentially consisting of blocks of text that are 
identical, separated by blocks of text that are different. Block searches are a good way to 
find text that has changed between versions of the file.

{button ,AL(`Introducing Norton File Compare;To search files',0,`',`')}    Related Topics



Undoing changes

Norton File Compare makes it easy to undo specific changes that were made to a file. 
Simply open the old and new versions of the file in Norton File Compare, highlight the 
changes you want reversed in the newer version of the file, and then choose Undo 
Selected Changes from the Options menu. 
Norton File Compare shows you how the file will look after the selected changes are 
reversed. The affected lines are displayed in a different color to make them easy to pick 
out. You can either save the reversed changes over the newer file, save them as a 
separate file, or cancel the operation if the reversed changes don't meet your needs.
The Undo feature of Norton File Compare complements the Restore feature of Norton 
Registry Tracker: Restore lets you restore entire files or registry keys from the system 
"snapshots" it takes, while Undo lets you compare the versions of files and registry keys 
stored in the snapshots, and undo specific changes that have been made between 
snapshots.

Note that using Undo to reverse registry changes updates the registry directly, 
without "showing" you those changes first. You should always have a backup of your registry
for insurance before making any changes directly to the registry.

{button ,AL(`About Norton Registry Tracker snapshots;Introducing Norton File Compare;To 
undo changes;To find orphan registry values',0,`',`')}    Related Topics



Setting Norton Registry Tracker exclusions

Norton Registry Tracker tracks changes made to critical data and files on your computer. It
stores a series of "snapshots" of the items you specify, and takes a new snapshot 
whenever a tracked item is modified in any way. It can show you how registry keys, INI 
files, or folders have been modified on your system, and lets you restore your system to a 
previous state from any of its stored snapshots.
Certain data of no critical value may change frequently on your system, and you may wish
to exclude this data from tracking. This prevents Norton Registry Tracker from taking 
unessential snapshots.
It's easy to set Norton Registry Tracker exclusions from Norton File Compare. Select the 
item (registry key, INI file entries, or files within a folder listing) you wish to exclude in the 
newer pane of Norton File Compare, then choose Exclude from the Options menu.
You can likewise cancel Norton Registry Tracker exclusions from Norton File Compare by 
choosing Edit Exclusions from the Options menu.

{button ,AL(`Introducing Norton File Compare;To set or remove Norton Registry Tracker 
exclusions;Introducing Norton Registry Tracker;To remove items from tracking;Excluding 
items from tracking',0,`',`')}    Related Topics





To open Norton File Compare

You can open any of the Norton Utilities programs from Norton Utilities Integrator. 
To open Norton File Compare:
1 Double-click Norton Utilities Integrator on the Windows desktop.
2 Click Find and Fix Problems in the left pane.
3 Click Norton File Compare in the right pane.

Or click here    
    to open Norton File Compare now.

{button ,AL(`Introducing Norton File Compare;To open files for comparison',0,`',`')}    
Related Topics



To open files for comparison

When you start Norton File Compare, you are automatically prompted for the files to open 
for comparison. If you subsequently want to change one of the files that is being 
compared, use Open Left Pane and Open Right Pane to open new files in Norton File 
Compare.
To open files when you start Norton File Compare
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the new version of the file you want to 

compare.
To open new files for comparison while you are in Norton File Compare
1 Choose Open Left Pane or Open Right Pane from the File menu.
2 Select the file you want to view.
3 Click Open.

You can also launch Norton File Compare directly from Norton Registry Tracker. Norton
File Compare lets you compare different versions of files and registry keys stored in Norton 
Registry Tracker snapshots.

{button ,AL(`Introducing Norton File Compare;Introducing Norton Registry Tracker',0,`',`')}
Related Topics



To edit a file
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Edit Text from the File menu.
5 Select the file you want to edit.

Norton File Compare opens the file in your default text editor, usually Windows 
Notepad.

{button ,AL(`Introducing Norton File Compare',0,`',`')}    Related Topics



To print files
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Print from the File menu.
5 Specify any print options you want in the Print dialog box.
6 Click OK. Norton File Compare prints both files that are open for comparison.
To print only the file showing in the left or right pane 
1 Right click the pane containing the file you want to print.
2 Choose Print This File from the context menu.
3 Specify any print options you want in the Print dialog box.
4 Click OK.

To print line numbers, make sure the option settings for the display are set to show 
line numbers. To print only the file differences, choose Show Differences Only from the View 
menu before you print.

{button ,AL(`Introducing Norton File Compare;To set display options;Display 
characteristics;To show differences only',0,`',`')}    Related Topics



To set comparison options
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Settings from the Options menu.
5 Check the file comparison options you want on the Comparison tab.

{button ,AL(`Introducing Norton File Compare;To set display options;Ignoring certain 
changes;To print files;To view INI files in Norton File Compare',0,`',`')}    Related Topics



To set display options
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Settings from the Options menu.
5 Click the Display tab.
6 Select the display options you want.

{button ,AL(`Introducing Norton File Compare;Display characteristics',0,`',`')}    Related 
Topics



To undo changes
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Highlight the lines you want to undo in the newer file.
5 Choose Undo Selected Changes from the Options menu.

Norton File Compare displays the file as it will look after undoing the changes. The lines
that result from the Undo process appear in the color you chose for differing text (the 
default is red).

6 Click Save to save the changes, overwriting the newer file.
Or,
Click Save As to save the restored original file with a different name.

You may need to restart Windows before you see any effects from Undo operations on
INI files and registry keys.

{button ,AL(`Introducing Norton File Compare;Undoing changes',0,`',`')}    Related Topics



To search files
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Search from the Options menu.
5 Select the search options you want in the Search dialog box.

When using the Search For Matching or Non-Matching Block options, make sure Show 
Differences Only is not checked on the View menu.

6 Click Search Up or Search Down to search up or down from the current position in the 
file.

{button ,AL(`Introducing Norton File Compare;Searching within files',0,`',`')}    Related 
Topics



To set or remove Norton Registry Tracker exclusions

Exclusions are registry keys, files, or INI file entries that are excluded from Norton Registry
Tracker tracking. You can set or remove them in Norton File Compare as well as from 
within Norton Registry Tracker.
To start Norton File Compare and open files for comparison
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
To set Norton Registry Tracker exclusions from Norton File Compare
1 Select the items you want excluded by selecting them in the pane displaying the newer

version of the file or Norton Registry Tracker snapshot you are comparing.
2 Choose Exclude from the Options menu.
To remove Norton Registry Tracker exclusions from Norton File Compare
1 Choose Edit Exclusions from the Options menu.
2 Click the Text Files, Folders, or Registry Keys tab, as appropriate.
3 Check the Show Exclusions check box (Text files and Folders tabs only).
4 If necessary, click the plus signs to show the exclusion you want to cancel.
5 Click the exclusion to select it.
6 Click Remove.

{button ,AL(`Introducing Norton Registry Tracker;To remove items from tracking;Excluding
items from tracking;Introducing Norton File Compare;Setting Norton Registry Tracker 
exclusions',0,`',`')}    Related Topics



To display file properties
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Right-click in the pane that contains the file.
5 From the context menu, choose Properties.

{button ,AL(`Introducing Norton File Compare;To edit a file',0,`',`')}    Related Topics



To view INI files in Norton File Compare
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose INI Mode from the View menu.

Norton File Compare automatically switches to its "registry mode" display when 
comparing registry export (REG) files or Norton Registry Tracker registry snapshots.

{button ,AL(`Introducing Norton File Compare;About Norton Registry Tracker 
snapshots;Comparing files with Norton File Compare',0,`',`')}    Related Topics





This side-by-side display shows the two files you have opened for comparison. Lines that 
differ between the files are printed in a different color, as are identical lines whose positions 
differ in the two files. For identical lines whose position is different in the two files, read 
across the panes to discover where the lines in the older file were moved to and where the 
lines in the newer file were moved from.
Norton File Compare tries to display identical lines side-by-side to make comparisons easier. 
To do so, it "pads" the display with blank lines. These lines don't represent actual blank lines 
in the files, but are there to help you quickly recognize file similarities. You can distinguish 
padded lines from "real" blank lines by having Norton File Compare show you line numbers. 
Lines that exist in the files are preceded by line numbers; padding lines are not.



Lets you edit the file displayed in the left pane. The selected file appears in your default text 
editor. The path and filename, or the Norton Registry Tracker snapshot date and time, are 
displayed to the left of this button.

If you have opened Norton File Compare from Norton Registry Tracker, the filename to
the left of the button is the temporary file used to store a Norton Registry Tracker snapshot. 
Norton Registry Tracker snapshots are denoted by (~snpN) and (~fcN), where N is the 
snapshot or INI mode temporary file number.



Lets you edit the file displayed in the right pane. The selected file appears in your default 
text editor. The path and filename, or the Norton Registry Tracker snapshot date and time, 
are displayed to the left of this button.

If you have opened Norton File Compare from Norton Registry Tracker, the filename to
the left of the button is the temporary file used to store a Norton Registry Tracker snapshot. 
Norton Registry Tracker snapshots are denoted by (~snpN) and (~fcN), where N is the 
snapshot or INI mode temporary file number.



Prints the contents of the left pane.



Prints the contents of the right pane.



Prints the files displayed in the left and right panes.



Prints the file or files you have specified, and lets you select the printer and set printer 
options.



Select this option button to search for groups of text in the two panes that are identical. For 
purposes of this type of search, any pair of files that is compared can be thought of as 
potentially consisting of blocks of text that are identical, separated by blocks of text that are 
different.

Show Differences Only (on the View menu) should be unchecked to use this feature.



Select this option button to search for groups of text in the two panes that are not identical. 
For purposes of this type of search, any pair of files that is compared can be thought of as 
potentially consisting of blocks of text that are identical, separated by blocks of text that are 
different.

Show Differences Only (on the View menu) should be unchecked to use this feature.



Select this option button to search for a particular word or phrase in the left or right panes.



This text box becomes active when you select the Text option button. Enter the word or 
phrase you want Norton File Compare to search for in the left and right panes.



Check this box to do a case-sensitive text search. In a case-sensitive search "ABC" would not
be considered a match for "abc."



Use this command button to search upward in the file panes for selected search criteria.



Use this command button to search downward in the file panes for selected search criteria.



Check this box to have Norton File Compare ignore whitespace characters (tabs and spaces) 
when it compares files.



Check this box to have Norton File Compare ignore any changes to whitespace characters 
(tabs and spaces) when it compares files.



Check this box to have Norton File Compare ignore any uppercase or lowercase differences 
between the two files displayed in the left and right file panes.



Check this box to display comparison statistics. The Comparison Statistics window displays 
the number of lines that have been moved, deleted, or added between the two versions of 
the file you are comparing.



Check this box if you want line numbers displayed in the left and right panes.



Sets the color Norton File Compare uses to display lines that differ between two files. Click 
the paint can button to specify a color; the text in the box will reflect the color you select.



Sets the color Norton File Compare uses to display identical lines whose position is different 
in the two files. Click the paint can button to specify a color; the text in the box will reflect 
the color you select.



Displays the Font dialog box, which lets you specify the font, font size, and font style used 
for the Norton File Compare display.



Displays how the file looks with the selected changes undone. Changes that are being 
undone are colored.



Click this button to undo all selected changes. The newer file displayed in Norton File 
Compare is overwritten with the undone changes.

You may need to restart Windows for reversed changes to take effect. 



Click this button to save the file with undone changes with a different filename than the 
newer file displayed in Norton File Compare.



Applies the Undo operation directly to the Windows registry. This reverts the registry to the 
state it was in before the selected changes that are being undone. The display at the left 
represents the registry as it will look after the changes.

Warning: The registry is fundamental to the proper functioning of your system. You 
should only change registry entries if you know what you are doing, and are confident 
of the results.



Excludes only the selected key from tracking. If any subkeys are being tracked, they will not 
be excluded.



Excludes the selected key from tracking, together with all subkeys it contains.





To view differences only
1 Click here        to open Norton File Compare.
2 In the Load Left File dialog box, choose the first version of the file you want to compare.
3 In the Load Right File dialog box, choose the second version of the file you want to 

compare.
4 Choose Show Differences Only from the View menu.




