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How to use this help file
This file may be read chapter by chapter. To do so, click the "summary or contents" button 
on top of this page. A page named "Contents" appears. The fat and underlined text refers to 
links that will take you to the chapters if you double click on it. The normal underlined text 
takes you to subheadings within the chapters. To return from a jump, push the "previous" 
button. Some images contain links too. The "linked" elements in such an image are marked 
by a box (see for instance the drawing toolbox). If the mouse pointer is over a link, the 
pointer changes into a pointing hand. Dotted underlined text (like the one above) will give a 
pop-up window. To quit the pop-up window, click anywhere except on a link. To get help on 
one of the two main window types, activate one of them by clicking on it and then push the 
help icon under the menu bar.
To know more about the options in a particular dialogue window, push the help button in the 
dialogue window concerned or use the "?" button in the top right corner of that window if it 
is available.
In this help file, fat text indicates either a heading or some kind of definition. Italic fat text 
refers to the menu or to menu items.
Use the "index" push-button on top of this window in order to search for keywords.
If you can not find what you are looking for, drop me a line at: deweille@bigfoot.com.



Introduction
XL-Plot is the eXtra-Light version of the freeware program Serf. Serf, is a program that is 
specifically meant for electrophysiologists and can be found on the web as well.

The primary purpose of XL-Plot is to create a figure for scientific publication rapidly. It 
contains a few basic statistical functions, such as Students t-test and linear correlation of 
two sets of data (two columns in a spreadsheet). XL-Plot has a number of build-in functions 
that can be fitted to the data in columns on a spreadsheet or to a curve in a graph. The user 
can easily add fitting functions of his own design. Additional options are (Fast) Fourier 
Transformation and Matrix inversion. The latter can be useful to solve a set of linear 
equations simultaneously.

XL-Plot accepts tab-delimited ASCII (*.txt files) and it outputs a vector drawing (*.his file; a 
XL-Plot format that may be exported to other vector drawing programs).
The program is build around two types of window both having their own menu and 
preference settings:
* Windows showing vector drawings (drawing sheets).
* Windows showing columns of numerical data (spreadsheets).
Items in the two types of window may communicate such that a modification in a column in 
a spreadsheet results in a change in the associated graph. By using copy and paste 
functions from the menu, data may be copied to a spreadsheet or to a drawing sheet 
resulting in a column of numbers or a graph respectively. 

      Open file, same as the File>Open menu item.
      Save file, same as the File>Save menu item.
      Delete, the deleted item is copied to the clipboard.
      Copy to clipboard.
      Paste clipboard contents.
      Repeat last action.
      Help, this file.





The spreadsheet
A spreadsheet is a text document that organises data in columns and rows. A blank 
spreadsheet can be created by using the File>new menu option. An existing spreadsheet is
read by using the File>open option from the menu or clicking the open file icon. From the 
open file dialogue window select type=ASICII *.txt.

There are two ways to enter data in a spreadsheet cell. i) Click on the cell you wish to edit 
and type the new text. Upon pressing the return key or one of the arrows on the keyboard 
the old text is replaced by the new text. Depending on which key was pressed, a next 
neighbour cell is highlighted. ii) Click on the cell you wish to edit and then click in the edit 
box. Modify the text in the edit box and press the return key. The cursor in the edit box can 
be moved using the arrow keys on the keyboard. The latter method is recommended to edit 
formulas, as cell references can be entered by the mouse rather than the keyboard. Text is 
considered to represent a formula or an equation if the first character is a "=" sign (e.g. 
=1+2). Formulas are hidden and show up only in the edit box. The spreadsheet merely 
shows the result of the equation (e.g. 3 in the previous example).
Selecting multiple cells. 
There are two ways to select multiple cells. i) Click on a cell and, while maintaining the left 
mouse button depressed, move the mouse pointer. ii) Click on a cell and release the left 
mouse button. Then press the shift key and click on a second cell, release the left mouse 
button and release the shift key. Now multiple cells are highlighted.
Selecting rows.
Click on a row key (showing the row index). To select multiple rows, click in a row key and 
move the mouse while keeping the left mouse button depressed. A second way to select 
multiple rows is to click on a row key and then on a second key, while depressing the shift 
key on your keyboard.
Selecting columns.
Click on a column key (showing the column index). To select multiple columns, click in a 
column key and move the mouse while keeping the left mouse button depressed. A second 
way to select multiple columns is to click on a column key and then on a second key, while 
depressing the shift key on your keyboard. The third way is to click on a column key and 
then to click on other column keys while keeping the control key depressed. This option is 
available only for multiple column selection and results in a selection of columns that is not 
contingent.

Formulas
Create equations by typing the "=" character as the first character in a cell. After having 
saved the spreadsheet on disk, the file may be imported in Microsoft Excel. Most of the 
functions, though not all, will be recognised by Excel. The following math functions are 
supported in XL-Plot:



+ addition (e.g. =1+2)
- subtraction or negation
* multiplication
/ division
** or ^ power (e.g. 2**3)
AND or & logical AND
OR      or | logical OR
NOT or ~ logical NOT
>= larger than or equal, returns 1 (true) or 0 (false)
<= smaller than or equal
= equals (returns 1 if equal, else returns 0)
> larger than (e.g. 5>2 returns 1 (true))
< smaller than
cin returns the column index of the spreadsheet cell
lin returns the line (row) index of the spreadsheet cell
sqrt(v) or sqr(v)    square root of v (e.g. =sqr(4))
exp(v) exponential of v
ln(v) natural logarithm of v
log(v) decimal logarithm of v
pi returns half the circumference of a circle with unit radius
rand(v) returns a random number between 0 and v
sin(v) sine of v, argument in radians
cos(v) cosine of v
tan(v) tangent of v
asin(v) arcsine of v, returns angle in radians
acos(v) arccosine of v
atan(v) arctangent of v
sign(v) sign of v, returns -1 or +1
int(v) returns the integer value of v
min(range) minimum value of the range of spreadsheet cells, where range is of the form: 

"Cn:Lm,Cnn:Lmm" with n,m,nn and mm being indices of columns "C" or lines 
"L".

max(range) maximum of the range of cells
sum(range) sum of the range of cells
average(range) average of the range of cells
mean(range) synonym of average
stdev(range) standard deviation of the range of cells
sem(range) standard error of the mean of the range of cells 
cell(c,l) returns the numerical value of the spreadsheet cell at column c and line l. If 

the cell contains text, if the cell is empty or if the formula it contains is 
erroneous, the function returns 0 (zero). 

binom(n,k) returns the coefficient of the k'th term of an n-binomial.
chidist(c2,df) returns the probability of a chi-2 at df degrees of freedom.
tdist(t,df,s) returns the probability of a t-value at df degrees of freedom, single sided (s=1)

or double sided (s=2).

How to enter the range of cells or a reference to a single cell in a formula.
Several functions such as SUM() and SEM() require a range of spreadsheet cells as 
argument. There are two ways to enter such a range in a formula: i) Type it (e.g. 
"mean(C2:L2,C2:L300)", N.B.: do not type the quotation characters), or ii) in the spreadsheet
edit box type "=mean(" and place the cursor behind the bracket "(". Then right-button-click 
the first cell of the range in the spreadsheet and move the mouse while keeping the right 
mouse button depressed. Release the mouse button at the last cell to be included. The 
range selected for the function appears in the edit box, the closing bracket ")" is added and 
the corresponding cells in the spreadsheet are highlighted in yellow. Many functions, like 



sin(), only demand a single parameter. If you wish this parameter to be a reference rather 
than a number, type for instance "=sin[C2:L3]". A second way to enter the reference is the 
following: in the edit box type "=sin" (N.B. no bracket here), then right-button click the cell 
that contains the argument. The text string will then read: "=sin[Cn,Lm]", where n and m are
the indices of the cell containing the argument. Observe that the type of bracket used is not 
important for the mathematical result: "{", "(" and "[" are OK. However for mouse-editing 
they make a difference: only the reference to a single cell is entered after a square bracket 
"[" or any symbol other than "{" or "(", whereas a range of cells will appear after "{" or "(". 

How to modify the range of cells in a formula.
Again there are two ways to do this: i) re-type the new range, or ii) Click on the cell 
containing the formula. Next, place the cursor anywhere between the brackets delimiting the
function's argument. Then right-button-click the new first cell in the spreadsheet and move 
the mouse while maintaining the right button depressed. The new range replaces the old 
one automatically. The reference of single-argument functions can be changed similarly.

What happens if you copy and paste a formula?
When you paste a formula onto a cell in the same or another spreadsheet, the column and 
line (row) indices are incremented or decremented such that the relative distance between 
the cell that receives the formula and the cell(s) the formula is referring to remain(s) the 
same in the original and the copy. An example explains this more clearly. Say a cell at 
column 2, line 3 contains the formula "=SIGN[C1:L5]". After having copied the cell you paste
it at column 2, line 4. The formula in the receiving cell will then read: "=SIGN[C1:L6]". If you 
don't want the index to change when pasting, put a "$" sign in front of the index in the 
original cell (e.g. "=SIGN[C1:L$5]"). 

What will happen to references if you delete or insert spreadsheet cells?
If a (number of) cell(s) is deleted or inserted, the cells below or to the right of the 
deleted/inserted cell(s) will shift position. The references contained in the shifted cells are 
updated such that they still refer to the same cell as before, with one exception: cells 
referring to deleted cells will not be updated. Hence, the former cells will refer to cells that 
have taken the position of the deleted cells. XL-Plot does not warn you of such a mishap, 
unless the formula containing the reference has become nonsense (not because it can not 
detect such events, but to prevent overclicking). 

How to create a function that depends on a running index.
Either the current column index or the current line index can be used as a running index to 
create "functions". To do this use "cin" (column index) or "lin" (line index) in your formula 
e.g. "=sqrt(3+lin*3) will result in "3" if the cell containing the formula is at line 2. It will 
return "6" if it is at line 11.

What is the function "cell()" good for?
Cell(c,l) retrieves the contents of a cell at column c and line (row) l. As c and l may be 
functions themselves, the indices may thus be the result of a calculation or a Boolean 
expression.

Self-referencing
Self referencing as for example in "=1+cell(cin,lin)", is not recommended and in general will 
be punished by unpredictable results. However, no error message is issued, since it is 
possible to construct perfectly stable systems of cells that contain self references or circular 
references. 

The Edit menu.
The edit menu allows you to copy, paste, delete and otherwise manipulate data in the 
spreadsheet. As the functions of most of the menu items is self evident, they will not be 



described here. Even so, a few points merit attention.
* When pasting the clipboard contents on the spreadsheet, it suffices to click the top left cell

where you wish to paste. The structure of the clipboard contents will determine how many 
cells will be modified.

* When pasting on the spreadsheet after having highlighted entire rows or columns, the 
paste becomes an "insert/paste". This is not a bug, but a shortcut. 

* Copy vs. Copy values. When copying text from a spreadsheet cell you copy the text you 
have previously entered in the cell. This text might have been a formula (e.g. "=exp(-
20*[C1:L1])"). When you paste the contents of the clipboard, the new cell will contain 
"=exp(-20*[Cn:Lm])", where n and m will depend on source and destination. If you wish to 
copy (and thus paste afterwards) the numerical result of the equation rather than the 
equation itself, use copy values. Note that this is a slightly different approach than used 
by Microsoft Excel, where you make this choice upon pasting rather than upon copying.

* Delete removes cells from the spreadsheet, while Clear replaces them by empty cells.
* When deleting, be aware that references to the deleted cells may not be valid anymore. 

XL-Plot does not protest, unless formulas really make no sense.
* When using the Replace menu item, formulas will be affected too. Hence "Replace 4 by 7"

will change references if they contain the number 4.
* The Remove Links item will remove all links with the selected columns in all graphs in all 

drawing sheets. To remove the link with only one graph, select the graph and then choose 
the Edit>Remove Link item from the drawing sheet menu. More on links elsewhere.

* The Save Prefs menu item writes the current window settings (in this case just its size) to 
disk. Newly created windows will have this default size.

The Fill menu
In order to copy the contents of a single cell to a range of cells use the Fill>right  
commands or the Fill>down  commands.    First, left-mouse-button select a range of cells 
and then issue one of the commands from the Fill menu. Right copy will copy the contents 
of the left-most cells to the right, right value will copy the numerical value (rather than the 
formula, if be) to the right, right increment will copy the numerical value of the left-most 
cell to the right, incrementing by 1 as it proceeds to the right, right decrement does 
similarly, but decrementing by 1. Right interpolation fills empty cells (and only empty 
cells) by interpolating between the numerical values of non-empty cells that need to be 
contained in the highlighted selection. If the beginning and/or end of the range of selected 
cells is empty, extrapolation is carried out if possible. Extrapolation is carried out only if the 
highlighted selection of cells contains at least two non-empty cells. Cells containing non-
numerical text are considered to represent the value 0 (zero). Now, if you wish to carry out 
the same fill command with another selection of cells, right-mouse-button select the new 
range and the last issued fill command will be carried out automatically. Note that right-
mouse select applies to the fill menu only. Hence, it does not repeat for instance a previous 
Edit>delete action. Use the repeat icon in the icon bar or Edit>Repeat last from the 
menu to repeat edit actions. 
The Fill>down commands behave analogously by copying the contents of the top-most 
cell(s) downward.

The Modify/Data menu
Line Plot and Bar Plot
These menu items are used to create a graph on a drawing sheet. Before issuing one of 
these two commands you need to indicate which of the columns contain the data to be 
plotted. There are two ways to do this:
Method 1) select a column that contains data for the x-axis by clicking on the column key at 
the top of the spreadsheet and then select Modify/Data>Set X-column from the menu. 
Then select a column that contains the y-data and choose Modify/Data>Set Y-column 
from the menu. Optionally, you may select a column that contains values for the error bars 



(a symbol whose size indicates the statistical error in the associated y-data point) by 
choosing the Modify/Data>Set Error-column from the menu. Hence, this method allows 
you to select at maximum three columns, but the order of the columns is unimportant.
Method 2) select a number of columns that you wish to use for your graph. When you issue 
the Plot command a dialogue window will pop up asking you to specify which of them 
contain x, y or error data. Here the order of columns is important. An x-column (there may 
be more than one) has to precede the associated y-columns. An error column refers to the 
column preceding it. Hence, if column 1 contains x-data and column 2 error data, the error 
bars will be plotted horizontally as they are assumed to refer to errors in the x-data. Two x-
columns have to be separated by at least 1 column containing y-data. 

 
 Use the left and right button in the dialogue box to go to the next or previous column.

Create histogram in a  new document or on the 
 clipboard. By default, the histogram will be created in a drawing window of its own. To 

transport the new histogram to another drawing sheet, select the histogram by clicking once
on it, then copy or delete it (^c or ^x or the copy or delete command from the Edit menu) 
and paste it (^v or the paste command from the Edit menu) onto the other drawing sheet. If 
you select the "create histogram on clipboard" option, the histogram will be created on the 
clipboard. This is, however, less intuitive as nothing seems to happen until you issue the 
paste command after having selected a drawing sheet.
After being drawn, the graph will be linked to the columns in the spreadsheet, meaning that 
a modification in one of the columns will alter the graph.

 Columns that maintain a link with a graph are marked by a '°' character in front of 
the column index. The link can be removed by either clicking on the graph and selecting 
Edit>Remove Link from the drawing sheet menu or by selecting the columns and selecting
Edit>Remove Links from the spreadsheet menu. The latter action will also remove links 
with other graphs on other drawing sheets if they exist. More on links elsewhere.

Frequency histogram
Creates a frequency histogram or a probability-density histogram of the currently selected 
column. Only one column can be selected for this option. In the dialogue window that pops 
up, the minimum value and the maximum value in the column are indicated along with a 
suggested number of classes (bins) for the histogram. This number of classes is estimated 
using the formula: Nclass=1 + 3.322 10log(N), where N is the number of data points in the 
spreadsheet column. Check the "normalise" box if you wish to create a probability-density 
function, leave it unchecked otherwise.

Get Column Stats
After having selected one or two columns, this menu item pops up a box showing statistics 
of the column(s) including mean, estimation of the standard deviation, error of the mean 
and, in case of two columns, the Student's t-test probabilities.

Resize column/line length
Graphs that contain a lot of data points (>5000) slow down the process of data manipulation
and in general are rather useless. If a link between the graph and columns in the 
spreadsheet exist, the number of data points can be reduced by choosing 
Modify/Data>Resize column/line length from the menu. The number of data points will 
be reduced either by removing every n-th
data point or by averaging n points to give a single point in return. You can select the final 
number of points in the selection of spreadsheet cells (and hence the graph) by indicating it 
in the dialogue window that pops up.

Sort numerical data



Numbers in a range of selected spreadsheet cells can be sorted in ascending or descending 
order using this menu item. A dialogue window will ask you to give these details. If 
spreadsheet cells in more than one column are selected, the cells in the "key column" will be
sorted and the data in the neighbouring cells in the same row (line) will be moved upwards 
or downwards along with the data in the "key column". 

For the Do Fit and the Set Fit function items see the "Fitting a function to data" topic.

Set Column Widths
The column widths in your spreadsheet can be changed by placing the mouse cursor 
between two column keys. The mouse cursor will change shape. Now press the left mouse 
button and drag it to the left or the right. A vertical line will appear, indicating the new 
width. Release the mouse button. This way the size of a single column changes. In order to 
modify the widths of all columns homogeneously, use the Modify/Data>Set Column 
Widths from the menu. A dialogue window will pop up. Fill in the width in number of screen 
pixels (default 60). All columns, not only those selected, will adopt the new width.

Set Line Heights
The line heights in your spreadsheet can be changed by placing the mouse cursor between 
two line (row) keys. The mouse cursor will change shape. Now press the left mouse button 
and drag it up or down. A horizontal line will appear, indicating the new height. Release the 
mouse button. This way the size of a single line changes. In order to modify the heights of all
rows homogeneously, use the Modify/Data>Set Line Heights from the menu. A dialogue 
window will pop up. Fill in the height in number of screen pixels (default 20). All rows, not 
only those selected, will adopt the new height.

Fourier transform
The Fourier transform of data contained in 1, 2 or 3 columns can be taken and will be 
returned in the form of new columns of data in the same spreadsheet or as a graph on a 
drawing sheet (depending on your choice in the dialogue window that will appear after 
selection of this menu option). If the data points are not equidistant, you need to provide a 
column of x-data. These x-data are then used to create columns of equidistant points by 
interpolation before the transform is taken. Therefore, data points are equidistant upon 
return. Forward Fourier transformation (from the time domain to the frequency domain) is 
assumed, unless a column of x-data is provided that mentions the x-unit: "mHz", "Hz" or 
"KHz" in the spreadsheet cell just above the column of numerical data. Note that inverse 
transformation (from the frequency to the time domain) of columns that lack imaginary data 
may lead to results that have no physical meaning. For the forward transform, a column of 
imaginary data is not required. When issuing the Modify/Data>Fourier transform 
command, a dialogue window pops up that asking to specify which column contains the x, 
real and imaginary data. 

Invert augmented matrix
This option allows you to solve a system of N linear equations with N unknowns. When you 
select a range of spreadsheet cells that contains the N*(N+1) augmented matrix, make sure 
that the dimensions (N lines and N+1 columns) are correct. If not, it is assumed that the 
entire spreadsheet is intended to be inverted. As the result of the inversion will be pasted in-
place, the data in the entire spreadsheet will be modified. As an example, suppose there are 
three unknowns a=1, b=2 and c=3 and you have three equations: 2a+3b-c=5, a+b+c=6 
and -2b+3c=5. Fill in the matrix as follows:



After inversion the result will be:

The last column lists the result: a=1, b=2 and c=3.



The drawing sheet
The primary function of the drawing sheet is to display graphs that you have created from a 
spreadsheet. In addition to this function, you can draw rectangles, circles, lines and add text 
to your graph to complete the presentation of the data. The graphical elements ("objects") 
of the drawing sheet are stored internally as vector drawings (as opposed to bitmaps) and 
can be exported to other vector drawing programs by copying a selection of objects in XL-
Plot (^c or Edit>Copy from the menu or clicking the copy icon), followed by a "paste" in the
receiving program.
A blank drawing sheet can be created by using the File>new menu option. An existing 
drawing sheet is read by using the File>open option from the menu or clicking the open file
icon. From the open file dialogue window select type=Histogram files *.his.

How to select a graphical object.
An object is selected by clicking once on it. Eight little squares then mark the bounding 
rectangle (selection box) of the selected object. By clicking on empty space between 
objects, the previous selection is abolished and the selection box disappears. 
How to select multiple objects.
Multiple objects can be selected by pressing the shift key on your keyboard, while clicking 
once on each object to include. To un-select an object in a list of selected objects, click once 
again on the object you wish to exclude from the selection, while maintaining the shift key 
depressed. A second way to select multiple objects is to depress the right mouse button and 
dragging the mouse while keeping the button depressed. All objects that are entirely within 
the rectangle that now appears will be selected. To select all objects on the sheet, choose 
Edit>Select all from the menu. 
How to move objects.
Click once on the object you wish to move, thereby selecting it. Then click again and, while 
maintaining the right mouse button depressed, drag the object to the new location on the 
sheet. Multiple objects are moved similarly.
How to size objects.
Select the object. It has 8 little squares around it. When the mouse cursor gets over one of 
them it changes into a vertically, horizontally or a diagonally pointing pair of arrows. Depress
the right mouse button and drag the pointer until the object has the appropriate size. Use 
the corner squares to change dimension in two directions and use the other squares to 
change size in one direction only. If you are sizing objects such as squares or circles, you 
may wish that the bounding rectangle remains or becomes a square. Press the shift key 
while dragging to do so, release the shift key only after having released the mouse button. In
order to maintain the original proportions of the object, press the control (Ctrl) key and 
release it after having released the mouse button. N.B. If multiple objects are selected, the 
effects of the shift and the control keys will apply to the bounding rectangle of the ensemble 
of objects rather than each individual object. If text is sized, the result will be the best 
approximation given the restraints of the true-type character set of the text object in 
question. 
Sizing graphs.
Graphs behave like other objects in this respect with one exception: data symbols (squares, 
circles) will keep their original sizes. Text on the graph axes will also change size, unless the

 Fix text size box in the Axes dialogue window has been checked.
Sizing lines
Sizing lines is a slightly different from other objects. When selecting a line segment, only two
little selection squares appear at the ends of the line. When the mouse cursor moves over 
one of them it changes into a cross. Depress the right mouse button and drag it. The end of 
the line segment will follow the cross. If the shift key is pressed while dragging, the line will 
become horizontal, vertical or will make an angle of 45° with the x-axis, depending on how 



close it was to one of those conditions when the shift key was pressed. The control key has 
no effect here. 

The drawing tool window.
<Click one of the buttons to know more about it.>

Whenever the window of a drawing sheet is activated (e.g. by clicking on it) its menu 
replaces the previously displayed menu in the main window and the drawing tool window 
pops up. The name of the file associated with the drawing window is shown in its title bar. 
The drawing tool window contains a series of buttons that allow you to draw objects or to 
modify their appearance. The larger buttons in the upper row are for modification, while the 
smaller ones in the lower row are mostly for creation. The function of each button will be 
described in detail below.

 This is the default tool upon activation of a drawing window. It is used to select graphical 
objects on the sheet, to move and to size them.

 Use this tool if you wish to include text in the drawing sheet. The cursor changes shape. 
The default true-type character set (font) will be used, unless you click on a location that 
already contains text. In the latter case the original font will be used and text can be 
modified. You remain in "text mode" until another tool in the drawing tool window is 
selected.    

 Use this tool if you wish to draw a line. The cursor changes shape. After having drawn a 
line, the default tool (the pointer) is automatically selected. In order to draw a perfect 
horizontal, vertical or diagonal line, depress the shift key on the keyboard while you draw a 
line.

 Use this tool to draw a transparent (open) rectangle. In order to draw a perfect square, 
keep the shift key depressed while you draw. The cursor changes into the pointer tool after 
having drawn the rectangle.

 Use this tool to draw a filled (closed) rectangle. In order to draw a perfect square, keep 
the shift key depressed while you draw. The cursor changes into the pointer tool after having
drawn the rectangle.

 Use this tool to draw a transparent (open) ellipse. In order to draw a perfect circle, keep 
the shift key depressed while you draw. The cursor changes into the pointer tool after having
drawn the ellipse.

 Use this tool to draw a filled (closed) ellipse. In order to draw a perfect circle, keep the 
shift key depressed while you draw. The cursor changes into the pointer tool after having 
drawn the ellipse.

 With the magnifying glass you can zoom in into a particular scene of the drawing. The 
centre of magnification will be where you left mouse click on the sheet. To zoom out right 
mouse click on the sheet. The tool will remain the magnifying glass until you select another 
tool.

    
 XL-Plot uses 8 bit indexed colour bitmaps having palettes that may be different for each

drawing window and that may be modified by the user. To find out what are the colour and 
the colour index of a particular pixel on the sheet, use the pipette tool. When clicking on a 
location on the sheet, the box right of the pipette tool (the colour index box) will indicate 
the colour and its index. The pipette will stay until another tool is selected. If you select an 
object on the drawing sheet using the pointer tool and then right mouse click on the colour 
index box, then the fill colour of the selected object will change into the pipette colour. Left
mouse clicking on the colour index box will change the border colour of the object. 



 Has the same effect as the menu item Tools>Text Font. If no objects on the drawing 
sheet are selected, this option will allow you to set the default true type font. If a (text) 
object is selected it will allow you to change its font. When editing a text object, an alternate
dialogue window pops up allowing insertion of special characters, such as ± or ².

 If    a text object is selected, this option will rotate the text 90°.
 Has the same effect as the menu item Tools>Align. Use this button to align and/or 

redistribute multiple selected objects. A dialogue window pops up in which you can specify 
the alignment. The following alignment rules are observed:
1) If "line width" is unchecked, the floating point coordinates of the extremes (left-most, top-
most etc.) of    the object are used for alignment. If "line width" is checked, half the line width
(=pensize) is added to the extremes for alignment.
2) Text bottom alignment refers to the imaginary line the text is sitting on, ignoring eventual 
underhang (as in the letter "g"). Hence the letters "a" and "q" will be aligned conventionally 
as in this text. Text top alignment will be carried out with respect to the upper limit of the 
bounding selection rectangle (the box on the sheet with the 8 little squares).
3) Redistribution is carried out with respect to the outer-most objects. 

 To change the colour of text, lines and border lines of objects click this button. A dialogue
window displaying the palette associated with the current drawing sheet pops up. The 
current border colour of the object is highlighted by a white square. When you click in one of
the little squares the border lines of the object change colour and the dialogue window 
disappears. The first little box in the palette (index=0) is transparent. Hence, it will remove 
the border lines of the object (unless the object is a line or text, since the object would 
disappear altogether). If the selected object is an undissociated graph, the colour of the axes
will change. To change the colour of other elements of a graph, double click on the element 
concerned. If this option is used while no object is selected, the default line colour will be 
changed. 

 To change the fill colour of objects click this button. A dialogue window displaying the 
palette associated with the current drawing sheet pops up. The current fill colour of the 
object is highlighted by a white square. Clicking in one of the little squares changes the fill 
colour of the object and the dialogue window disappears. The first little box in the palette 
(index=0) is transparent. Hence it will change a filled square into a open square. If the 
selected object is an undissociated graph, the fill colour of all circles and polygons will 
change, generally leading to undesirable results. A better way to change the colour of    
elements of a graph is to double click on the element concerned. If this option is used while 
no object is selected, the default fill colour will be changed.

 Has the same effect as the menu item Tools>Pen Size. Click this button to change line 
width (pensize). A dialogue window pops up indicating the current line width of the object. 
Upon selection of the new width, the dialogue window disappears. If the selected object is an
undissociated graph, the line width of the axes will change. To change the line width of other
elements of a graph, double click on the element concerned. If this option is used while no 
object is selected, the default pensize will be changed. Pen size is in computer screen 
pixels. When printing a drawing sheet the overall appearance of the design will remain the 
same. Hence, the resolution may change when printing, but not the line width.

 This box displays the current default background colour (here yellow), foreground 
colour (here blue) and the size and name of the current default true-type font ("Arial" in this 
example). If you wish to change the border colour of a selected object into the current 
foreground colour, left mouse click in this box. To change the fill colour, right mouse click.

How to change the colour palette.
The program uses 8 bit indexed colour bitmaps to display the contents of a drawing sheet. 
Each drawing sheet has its own dedicated palette. You may change drawing object colours 



by clicking the  or the 
 buttons in the drawing tool window or by selecting the menu items Tools>Outline 

colour or Tools>Fill colour. Whereas the drawing tool buttons only allow you to pick a 
colour, the menu items also allow you to modify the palette itself. After having selected one 
of the two menu items, a dialogue window pops up displaying the current palette. To save or 
load a palette, push the "save" or "load" buttons. A second window comes up requesting a 
"*.mpl" file name. Do not change the "*.mpl" extension. To revert to the program-defined 
default palette, push "default". To change the RGB (red, green, blue) values of one of the 
palette entries, click on a little coloured box in the palette. The selected box is highlighted 
by a white square around it and the box marked "old" now displays the selected colour along
with its index number. Next move the Red, Green and Blue slide bars to change the colour. 
The new colour appears in the "new" box. To enter the new colour in the palette, push the 
"OK" button. To copy the colour from one index to another, carry out the following sequence:
1) Click the little box to be copied, 2) push the "from" button, 3) click the little box to copy 
to, 4) push the "to" button and finally 5) push the "Copy" button. To create a gradient of 
colours carry out the following sequence: 1) Click the little box that contains the starting 
colour, 2) push the "from" button, 3) click the little box where you wish to end the gradient, 
4) push the "to" button and finally 5) push the "Spread" button. Push the "Done" button 
when you're done editing.



The Tools menu. 

The actions of the menu items in this menu are almost identical to those of the  Align, 
 Outline colour, 
 Fill colour, 
 Text Font and 
 Pen Size icons in the drawing tool box. In short: they allow you to align multiple objects, 

to change the (border-)line colour, the fill colour, true-type text font (size, bold etc.) and the 
width of lines respectively. In order to change the colour palette of the current (and only the 
current) sheet, choose either the Outline colour or Fill colour menu item. Upon selection 
of one of these menu items a dialogue window pops up that contains, apart from the option 
to select a new colour index, several options to change the red-green-blue values of the 
palette entries.      



Alternate characters.

This dialogue window shows the alternate ASCII character set associated with the current 
text font. Alternate characters can be inserted in a text object being edited by:
1) mouse-selecting a character and pushing the "insert" button or
2) typing the <Alt> code formed by the combination of the numbers in the first column and 
row. For example to insert a ±, type 0177, while maintaining the <Alt> key depressed. NB, 
the leading 0 should be typed also.
The insert button is disabled if no text object is currently being edited. Each drawing sheet 
has its own alternate character dialogue window, so many of them may be open 
simultaneously. The font in this window is updated each time a new text object is selected.



The Edit menu. 
* After having selected a number of graphical objects, these objects can be copied to the 
clipboard by issuing the Edit>Copy command from the menu, typing "Ctrl C" on the 
keyboard or by clicking the copy icon in the icon bar on top of the main window. To paste the
object(s) elsewhere on the drawing sheet or onto another drawing sheet, click once at the 
location on the sheet where the new object has to go and issue the Edit>Paste command 
from the menu, type "Ctrl V" on the keyboard or click the paste icon in the icon bar. If the 
copied object is an undissociated graph, the coordinates of the data points may be pasted 
onto a spreadsheet as well. In the latter case, links between the spreadsheet columns and 
the data in the graph are established, such that a modification in the spreadsheet column 
will cause the graph to be redrawn with the new modified data. * To break the link with the 
spreadsheet, issue the Edit>Remove Link command from the menu. To delete objects, 
issue the Edit>Delete command from the menu, type "Ctrl X" on the keyboard or click the 
delete icon in the icon bar. The object has not disappeared altogether, as it has been copied 
to the clipboard. Hence it can still be pasted elsewhere. All objects on a drawing sheet can 
be selected by the Edit>select all menu item. This item is especially useful if objects have 
become invisible, extremely small or have been moved outside of the drawing sheet.
* Multiple objects can be grouped into a single composite object by the Edit>Associate 
command or by typing "Ctrl A" on the keyboard. Edit>Dissociate or "Ctrl D" does the 
reverse, it dissociates a composite object into multiple objects. When dissociating a graph, it
looses the possibility to have its axes or its data redefined and is reduced to a mere set of 
vectors. This dissociation of graph and its hidden data is irreversible.
* The order in which objects appear on the screen may be changed by one of the 
Edit>Arrange>xx commands. To make the selected object the front-most object issue 
Arrange>to front. To move it to the background use Arrange>to back. The 
Arrange>approach (Ctrl A) or Arrange>remove (Ctrl R) commands do the same thing 
one step at a time, thus allowing an object to be inserted between two other objects.
* When exporting an object as vectors (WMF) to another program, a polygon such as a curve
in a graph can be exported as a single object or as a series of line segments (multiple 
objects). Some programs find it difficult to dissociate a polygon into line segments. If that is 
the case, choose the "multiple objects" option. Set your choice using the Edit>Copy 
preferences menu item.
* The Edit>Save prefs menu item saves the current window size and the current default 
text font to disk. These settings will then apply to newly created or opened drawing 
windows.



Curve properties.
When double-clicking on one of the elements of a curve in a graph, the "curve properties" 
dialogue window pops up, allowing the user to edit the attributes of a curve in a graph or to 
fit a curve. The data points in a graph may be connected by line segments and/or be 
represented by symbols. Use the "connect points with line" checkbox to switch drawing 
of line segments on or off. If checked, the "line width" slide bar and the "line colour" push 
button define the thickness of the line connecting the data points and allow you to select the
line colour respectively. In the latter case, a second dialogue window ,displaying the palette 
associated with the current drawing window, pops up. The current line colour is highlighted 
by a white square. When you click in one of the little squares, the colour changes and the 
dialogue window disappears. The first little box in the palette (index=0) is transparent.
The "symbol" panel groups a number of options that define form, size and colour of the 
symbol representing each data point in the currently selected curve. Note that if the 
"connect points with line" checkbox is unchecked and symbol is "none", the curve 
disappears completely. The associated data however, remain available. If the "bars" option is
selected, XL-Plot draws a bar between the data point and the x-axis of the graph. This option
is used for example when drawing dwell time histograms or probability-density distributions. 
The "symbol size" has no effect when in "bar mode". If the currently selected curve has error
data associated with it, then error bar drawing may be switched on or off by selecting the 
appropriate checkboxes in the upper right panel of the dialogue window.
The "fit" panel shows three push buttons:
1) Before starting to fit, push the "Function" button to select a fitting function. A second 
dialogue window will pop up, displaying several fit options and fit functions.
2) Push the "Do Fit" button to start fitting. After fitting, the same window pops up again, 
now showing the fitted parameters and the error of fit.
3) To remove a fitted curve, push the "Remove" button.
Two vertical red lines are drawn in the graph on the drawing sheet. These two lines delimit 
the x-range of data points that will be used to obtain the fit. The slide bars marked "fit 
range from" and "to" control the positions of the two red lines. The "line width" slide bar and
the "line colour" push button determine width and colour of the fitted function trace. The 
Fitting functions to data chapter supplies additional information.
The lower left corner of the dialogue window indicates whether the graph data are linked 
with columns of data on a spreadsheet and if so, to which spreadsheet and which columns. 



How to modify the axes of a graph
To modify the axes of a graph, double click on one of its elements (ticks or text such as the 
numbers along one of the axes). Make sure that the graph is not associated with other 
objects. A dialogue window pops up showing both X and Y axis options if the object is a line 
plot and Y-axis options only if the object is a bar plot. For each of the axes the beginning 
(minimum) and end (maximum) values are defined by the text in the edit boxes "From" and 
"To". The distance between major and minor ticks can be set by editing the "Major tick 
every" and "Minor tick every" boxes. Note that if "scale type" is set to "log", the "Major tick" 
edit box is labeled "Major tick log". This edit box then shows log-base 10 as default, but this 
may be changed to any other base as long as it is larger than zero. The place where the Y 
axis crosses the X axis can be set in the "Y axis crosses at" edit box. If the value entered 
here is lower than in the "From" box or larger than in the "To" box, the axes will not intersect 
in the graph.
The orientation of ticks and scale type is set by selecting the appropriate  radiobutton.
Per default, axes are drawn with ticks having numbers alongside. If     X or Y calibration 
bar is checked, a horizontal or vertical calibration bar is drawn in stead with a size equal to 
the value entered in the "Bar size" edit box. The position of the calibration bar is determined 
by the values entered in the "Bars(s) at" edit boxes.
The units of the axes or any other text that accompanies an axis can be entered in the 
lower-most edit box. 
Each time a graph the user sizes a graph, the text size changes too. This behaviour can be 
switched off by checking  Fixed text size.



Layout of error bars
This dialogue window pops up after having double-clicked on one of the error bars in a 
graph. Use the upper slide bar to change the error bar width and the slide bar below it to 
change the pen width. The pen colour can be changed by pushing the "pen colour" button. A
second dialogue window will then pop up containing 256 little coloured squares. Click on the 
one with the colour of your choice. The error bars depict    SEM. To show only the upper half 
(+SEM) or lower half (-SEM), (un)check the appropriate check boxes. If the graph contains 
many data points, the error bars may clutter the graph. In that case, the confidence limits 
may be depicted by a line that runs parallel to the data points (option: draw as a line). 



How to deal with links between spreadsheets and drawing sheets.
Establishing and removing links.
Links between a spreadsheet column and a graph are established in three ways.
1) By pasting the contents of the clipboard on both the spreadsheet and the drawing sheet.
2) By copying one or more spreadsheet columns and issuing the Modify/Data>Line Plot or
the Modify/Data>Bar Plot from the spreadsheets menu.
3) By copying a graph and pasting it on a spreadsheet.
If a spreadsheet column and a graph on a drawing sheet are linked, data in the graph can be
modified by modifying the numbers in the spreadsheet column. For example, removal of    a 
spreadsheet cell will result in the removal of a data point in the graph. The modifications 
take effect immediately. There are two important exceptions to this rule.
1) If an entire "linked" column is deleted from the spreadsheet, the plot on the drawing 
sheet will remain intact. The link is simply removed. 
2) If a number of cells (but not all the cells) in a linked column are cleared (^x or 
Edit>Clear), the effect on the graph will be delayed until the next edit operation on the 
same column. This gives you time to eventually paste fresh data in the column without 
loosing the link. Similarly, inserting empty cells into a column does not produce an 
immediate effect on the graph either.

 Columns in a spreadsheet that maintain a link with a graph are marked by a '°' character
in front of the column index.
A link can be removed by either clicking on the graph and selecting Edit>Remove Link 
from the drawing sheet menu or by selecting the columns and selecting Edit>Remove 
Links from the spreadsheet menu. The latter action will also remove links with other graphs 
on other drawing sheets if they exist. Hence, to remove only the link with one graph, select 
the graph and then choose the Edit>Remove Link item from the drawing sheet menu.

How to know what is linked to what?
To know whether a curve in a graph is linked to a spreadsheet and if so, to which column(s), 
double-click on an element (line segment or symbol) of the curve. The "curve properties" 
dialogue window appears. In the lower left corner of this window you find the name of the 
spreadsheet (if any) to which the curve is linked along with information about columns that 
contain the x, y and error bar data. In some cases, especially in very crowded graphs, a 
curve may be completely hidden by other curves that are drawn over it. In that case, select 
the column in the spreadsheet that is suspected to contain the data while depressing the 
control key on the keyboard.

 Now a question mark appears in the column index key. Then return to the graph 
and double click on any curve while depressing the control key. The "curve properties" 
dialogue window appears with information about which curve is linked to the spreadsheet 
column with the question mark.



Fitting a function to data. 

Functions can be fitted to your data in each of the two types of window. The function can be 
one of the build-in functions (marked by an asterix in the Fit dialogue window) or one that is 
defined by the user. Before starting the fit routine the user has to select or define i) the 
function to fit and ii) the range of data points to fit the function to. The way to do this differs 
slightly for each of the two windows. 

The spreadsheet.
i) The fit routine requires two arrays of data: one for the x-values and one for the y-values. 
These data correspond to two columns that needs to be indicated. There are several ways to
do this. a) By selecting a column and choosing Modify/Data->Set X-column from the 
menu, then selecting a second column and choosing Modify/Data->Set Y-column from the
menu. An x and a y will appear in the column bar. A third column may be chosen using 
Modify/Data->Set Error-column, that may be used as a weight during fitting. A second 
(more rapid) way is b) to select two columns (not less, not more), the first column will be 
considered to contain the x-data and the second will be considered to contain the y-data. If 
you wish c) to fit only a part of the numerical data in two adjacent columns, you may select 
the spreadsheet cells that contain the data to be fitted. ii) Click the set fit function item 
from the Modify/Data menu to choose a function. To start the fit routine select Do fit from 
the same menu. 

The drawing window.
Only data in an undissociated graph can be fitted. Once a graph is dissociated, it is reduced 
to a simple set of vector elements. To fit one of the curves in a graph, double click on one of 
its elements (the line elements or the symbols, but not one of the axes of the graph) and a 
dialogue window will pop up containing, amongst others, two slide bars titled "fit range 
from" and "to" and two buttons saying "function" and "Do fit". Moreover, two red vertical 
lines will appear in the graph. i) Use the slide bars to indicate which data points to fit. ii) use 
the "function" button to select the fitting function. Then proceed by clicking "Do fit".

The "Select Fit function" and "Fit" dialogue window.
To choose a function in this window, either double click one of the functions listed under "list 
of functions" or click once and push the "<<" button. The function name and its formula now
appear in the upper left edit box. The formula can be modified in order to create a new one. 
During compilation of a formula, lower case letters will be converted to upper case, hence 
the compiler does not distinguish between them. Before using the newly created formula, 
click the ">>" button to save it.
The variables to fit are listed underneath the edit box. Do not attempt to use "X", "Y" or 
function names such as "exp" as variable names since they are reserved and will lead to 
unexpected results. The user can put constraints on the range of values that the fit 
parameters may adopt by checking V<0 (variable must be negative), fixed (do not fit this 
parameter, but keep it constant) or V>0 (variable must be positive). The maximum of fit 
iterations can be set in the "iterations" edit box. The following functions may be used in fit 
formulas:
+ addition
- subtraction or negation
* multiplication
/ division
** or ^ power (e.g. 2**3)
AND or & logical AND
OR      or | logical OR
NOT or ~ logical NOT
>= larger than or equal, returns 1 (true) or 0 (false)



<= smaller than or equal
= equals (returns 1 if equal, else returns 0)
> larger than (e.g. 5>2 returns 1 (true))
< smaller than
sqrt or sqr square root
exp exponential
ln natural logarithm
log decimal logarithm
pi half the circumference of a circle with unit radius
sin sine, argument in radians
cos cosine
tan tangent
asin arcsine, returns angle in radians
acos arccosine
atan arctangent
y returns the y-data value (y[i]) corresponding to the current x-data value (x[i]). 

(e.g. y<=val returns 0 if y[i] larger than val. This option can be used for 
example for thresholding.)

Click the "cancel" or "OK" button to quit the fit dialogue window.
Start fitting by selecting "Do Fit" from the context described above. After estimation of the 
fit parameters, the same fit dialogue window pops up, now showing the estimated variables 
and the chi-2 error of fit underneath the formula edit box. In case of fitting a curve to a 
graph, the fitted function is drawn. The estimated parameters may be copied as text to the 
clipboard by pressing the copy icon in the fit dialogue window.
Build-in fit functions are: line, Hill, Bolzmann, 1, 2 or 3 eponentials, Gaussians (1, 2 or 3, 
equidistant or both equidistant and equivariance), hyperbola, parabola, power, Lorenzians, 
logistic, log, log normal and Langmuir.

Linear regression. 
If the first function (*line) of the list of functions is selected, a single step, linear regression 
routine is used rather than the iterative non-linear curve fitting routine. In that case, the 
correlation coefficient, r, and the probability, P, that correlation is absent between X and Y 
data is shown upon return.



Select level
Choose here which level to analyse. 0 (zero) is the closed level, 1 corresponds to one 
channel open in the upward direction (outward unitary current), 2 corresponds to two 
channels open simultaneously etc. Negative mumbers: -1,-2 etc. correspond to    downward 
(inward) unitary currents.



New File
Select here whether to create a new window to manipulate numerical data (spreadsheet) or 
a new window for vector drawing (drawing sheet). 



 The home key is a diagonally pointing arrow on the keyboard, located between the 
alphanumerical keypad and the numerical keypad in a group of 6 isolated keys.



Any signal may be considered as a sum of sines and cosines of different frequencies and 
amplitudes. The Fourier transform is an algorithm that calculates the amplitudes as a 
function of frequency. The result is a series of cosine coefficients (the so-called real part) and
a series of sine coefficients (the imaginary part). The frequency spectrum plots (R²+I²) as a 
function of frequency, where R and I are the cosine and sine coefficient respectively. An 
important property of the Fourier transform is that it is its own inverse function. Hence, the 
Fourier transform of the Fourier transform gives the original signal. 



Standard Error of the Mean.



An edit box  is a element in a dialogue window that contains text that can be edited. To do
so, click in the box. The Mouse pointer changes from an arrow into a hair pointer and a 
cursor blinks in the box. Then type your text.






