
Capture Screen 3.0 Information

Capture Screen is a utility program that allows you to visually take control of remote 
machines.

Capture Screen allows you to do the following:

1. See the desktop and windows of connected machines.
2. See almost real-time updates of connected machines.
3. Interact with the connected machine by keyboard and mouse interaction.
4. Send a message to be displayed on the connected machine.
5. Save the current image of the other machine to bitmap format.
6. Transfer files between remote and local machines.

These abilities give way to many possible uses:

1. Fix technical support problems remotely.
2. Change system settings on remote machines.
3. Monitor 'Servers' for errors.
4. Watch users work remotely without letting them know you're watching.

Benefits of using Capture Screen
1. Capture Screen uses DCOM so you don't need to waste CPU time on the remote machine 
when you aren't connected to it.

- Capture Screen only launches its communication program when it is required.
2. Capture Screen uses ZLIB compression for very fast image transmissions.
3. Capture Screen is simple to use and simple to install.



Capture Screen Installation 

Installing Capture Screen is very easy. If you are installing Capture Screen on to Windows 
95 you must also install DCOM for Windows 95. Windows NT comes with DCOM already 
installed. DCOM for Windows 95 is available at http://www.microsoft.com/com. Please read 
the readme text file for last minute changes.

In order for Capture Screen to work the following must be accomplished:

1. The Capture Screen and ViewIt Server application must be installed on all machines that 
will run Capture Screen.
2. The ViewIt Server application must be installed on all machines that will be connected to 
remotely.

To configure a machine to run Capture Screen
1. Run the installation program that comes with Capture Screen.
2. Follow the instructions throughout the install, but when asked what type of install to do 
choose 'Capture Screen Install'.
3. Finish the install to set the machine up.

To configure a machine to be connected to by Capture Screen.
1. Run the installation program that comes with Capture Screen.
2. Follow the instructions throughout the install, but when asked what type of install to do 
choose 'ViewIt Server Install'.
3. Finish the install to set the machine up.

(Note: There is a silent installation for this install. If you run the setup program with a -S 
command line parameter the
install will set a machine up to be connected to without going through the dialogs.)

That's it! You should be able to connect to the remote machine now.

Installation for advanced users



How Capture Screen Works 

Capture Screen utilizes DCOM. DCOM or Distributed Component Object Model is a 
technology that allows applications to control other applications remotely. Capture Screen 
utilizes DCOM in order to communicate to remote machines. Capture Screen consists of 
several files. These files are:

CaptureScreen.exe- The main application executable for connected to a remote machine.
ViewIt.exe - The DCOM executable that must reside and be registered on 
the remote machine.
ViewIt_95.reg - A Windows 95 RegEdit import file. This file will register the 
ViewIt.exe program with full access.
ViewIt_NT.reg - A Windows NT RegEdit import file. This file will register the 
ViewIt.exe program with full access.
Capture.hlp - The Capture Screen help file.
Capture.cnt - The Capture Screen help contents file.
RegisterViewIt_95.bat - A sample batch file to install ViewIt Server on Windows 95. (If 
you don't want to use the install program.)
RegisterViewIt_NT.bat - A sample batch file to install ViewIt Server on Windows NT. (If 
you don't want to use the install program.)
License.txt - Licensing information for Capture Screen
Readme.txt - Last minute informational file.

Capture Screen works by using DCOM to communicate to the ViewIt.exe program. When 
Capture Screen needs to connect to a remote machine it calls (through DCOM) a remote 
machine and asks it to launch the ViewIt.exe program. Once ViewIt.exe is launched it sends 
and retrieves the necessary information back to Capture Screen. Therfore, for Capture 
Screen to work properly you must register and install the ViewIt.exe program properly.



System Requirements 

Requirements for Capture Screen to run are the following:

1. The computer system must be running Windows 95 or Windows NT 4. (Newer versions 
have not been tested.)

2. The computer system must have Windows networking set up. The easiest way to tell if 
your network will work is if you can go into Network Neighborhood and see the names of 
other computers. (A Windows NT Domain Network configuration works well.)

3. DCOM must be installed. (Windows NT 4 comes with DCOM, Windows 95 must have DCOM
installed from Microsoft's web site.)



Starting Capture Screen 

When you start Capture Screen this is the window that you will initially see. 

     

There are several things that can be done from this view. You can:

1. Connect to a remote machine.
2. Set configuration options.
3. Select a Registered Key File



Connecting to a Remote Machine 

To connect to a remote machine you need to do the following:

1. Start the Capture Screen program.
2. Under the 'File' menu choose 'New Connection'.
3. Either type in the name of a machine to connect to (the name listed in Network 
Neighborhood), press the 'Browse for Machine' button to find a machine to connect to, or 
use the drop-down list of the most recent machines you connected to.

  

4. Press 'OK' to connect to the machine. If the machine name is valid the connection should 
occur in a couple of seconds. If the machine is invalid, Windows will search for quite a while 
to find the machine before giving up. (It's wise to browse for a machine to make sure you get
the right name.)

5. If the remote machine is connected to correctly then you will have a new window open 
with the remote machines display in it. This view may appear squished due to Capture 
Screen fitting in the entire display of the remote machine into its window. (You can view the 
screen normally in Full Screen mode.)



 

You are now connected to the remote machine. To close the connection to the remote 
machine choose the 'File' menu 'Close Connection' item. With Capture Screen's new Multiple 
Document Interface (MDI) you can have many different connections opened at one time.

From here you can do the following:

1. Go into Full Screen mode (Interactive mode) where you can view and interact with the 
remote computers.
2. Send a message to the remote machine.
3. Save the current image to a bitmap file.
4. Set Configuration Options
5. Transfer files to/from the remote machine.
6. Open another remote connection. (Same as descibed above.)
7. Refresh the current remote connection display by pressing the 'Refresh' button.
8. Arrange open windows by using the Window menu or toolbar.



Set Configuration Options

There are several options that can be set in Capture Screen from the View | Options menu.

You can:

Set the Auto-Refresh time in seconds. 
This allows you to alter how quickly the screen will attempt to refresh in Full Screen mode. 
This option can make a big difference in how Full Screen mode functions. If you set this 
option too high you will be waiting around for refreshes to occur. If you set this option too 
low you may try to refresh quicker than your network can retrieve the image of the remote 
screen. (The slower the refresh the less CPU time is used on the remote PC. Usually Capture 
Screen is unrecognizable as being running.) This option is usually fine if set between 2 and 5
seconds.

Set Resolution
There are two type of resolution that can be returned from the remote machine. High 
resolution and Low. High resolution returns a color image of the remote machine but can 
take slightly longer to retrieve the image. Low resolution returns a black and white image 
that increases network transfer speed. Low resolution should be used on slower networks or 
when maximum real-time interaction is required.

  



Send a Message to the Remote Machine
 
Once you are connected to a machine you can send a message to that machines desktop. 
This is done from the main window of Capture Screen. 

To send a message do the following:

1. Make sure you are connected to a remote machine.
2. Under the 'File' menu choose 'Send Message'.
3. Type the message you wish to send in the Send Message Dialog and press OK.

 

Your message has now been sent to the remote machine. You can press the 'Refresh' button 
to see the message on the remote machine.



Save the Current Captured Image to a Bitmap File. 

You can save any captured image to a bitmap file from the main window. 

To save a bitmap do the following:

1. From the 'File' menu choose 'Save Capture'. 
2. Select a folder and a name for the bitmap and choose OK.



Full Screen Mode 

Full Screen Mode is the mode you will go in to to interactively work with the remote 
computer. 

To enter Full Screen mode do the following:

1. Make sure you are connected to a remote machine.
2. From the 'View' menu choose 'Full Screen'.

- Your entire view will now be the remote computer's screen.
3. From here you can work with the machine just like it is your computer.

- You can use your mouse just as if you were on the other computer.
- You can use the keyboard with the exception of a couple of keys.

Full Screen Options (Very Important)
When you are in full screen mode there is a menu of options that you can get to. To open 
this menu you need to use the Tilde key (~). The tilde is used because it is a rare key to 
need. When you press the tilde a menu will pull up with the following options:

Refresh
This will perform a one time refresh of the remote computers view.

Auto Refresh
This will enter you in auto-refresh mode which will update the remote computer 
automatically at a specified time interval. You can change the time interval through the 
options dialog. To turn off auto-refresh mode, press the tilde again and re-choose auto-
refresh. When auto-refresh is not engaged, the screen will refresh when you use the mouse 
or keyboard. (If a process, such as opening a window, takes a while the normal refresh will 
not show this. You can either use auto-refresh or continually hit the refresh menu item.)

Copy and Paste Clipboard Data (Only Text)
Copy Clipboard
This will take any text in the clipboard on the remote machine and put it into your local 
clipboard. You can then paste that text on your local machine.

Example:
1. Connect to a remote machine.
2. Go into Full Screen mode.
3. Open a text file in Notepad on a remote machine.
4. Select some text and choose Edit | Copy. The text is now in the remote clipboard.
5. Press the tilde to pull up the menu.
6. Choose 'Copy Clipboard'. The text in the remote clipboard is now in your local clipboard.
7. Start Notepad on your machine.
8. Choose Edit | Paste to paste the text into Notepad.

Paste Clipboard
This will take any text in your local clipboard and put it into the remote machines clipboard. 
You can then remotely paste the clipboard data into an application.

Example:
1. Type some text into Notepad on your machine.



2. Select the text and choose Edit | Copy. The text is now in your clipboard.
3. Connect to any remote machine.
4. Go into Full Screen Mode.
5. Press the tilde to pull up the menu.
6. Click on 'Paste Clipboard'. The text that was in your clipboard is now in the remote 
clipboard.
7. Start notepad on the remote machine. 
8. Choose Edit | Paste to paste the text into Notepad.

Close
Close Full Screen mode and return to the main window of Capture Screen.



Menu Items

Capture Screen menu items are as follows:

File Menu
New Connection - Create a new window connected to a remote machine.
Close Connection - Close the current connection to a remote machine.
Save Capture - Save the current screen image of a remote machine to a bitmap.
Send Message - Send a text message to popup on a remote machine.
Transfer File - Transfer a file from or to a remote machine.

View Menu
Refresh - Refresh the current captured image
Full Screen - Enter into Full Screen Mode
Options - Configure program options

Window Menu
Cascade - Stagger the currently open windows.
Tile Horizontally - Arrange the currently open windows horizontally.
Tile Vertically - Arrange the currently open windows vertically.
Minimize All - Minimize all open windows.
Arrange All - Arrange any open icons.

Help Menu
Help Contents - Open up help on Capture Screen
Key File - Select a license key file. (For registration purposes)
About - Information about Capture Screen



Capture Screen Toolbar

The toolbar for Capture Screen offers the following options:

 

New Connection - Open a new remote connection.
Save Capture - Save the current remote screen to a bitmap file.
Send Message - Send a text message to be displayed on the remote machine.
Transfer File - Transfer a file to or from a remote machine.
Refresh - Refresh your display of the currently connected machine.
Full Screen - Enter into Full Screen mode.
Options - Open the dialog to set configuration options.
Cascade - Stagger the currently open windows.
Tile Horizontally - Arrange the currently open windows horizontally.
Tile Vertically - Arrange the currently open windows vertically.
About - Information about Capture Screen.



Registering Capture Screen

Capture Screen comes with a 60 execution trial period. Once this trial period has expired you
must purchase Capture Screen or remove it from your system. Please read the Capture 
Screen License for additional information. When you register Capture Screen we will send 
you a Key File to license the application.

To purchase Capture Screen you may do the following:

Visit Lollop Software on the internet at:    http://www.macatawa.org/~spruitr

or

E-Mail me at: spruitr@freenet.macatawa.org

Capture Screen is Copyright © 1998 Lollop Software. All Rights Reserved. 



Advanced Installation 

This section is for advanced users who want to customize installation of Capture Screen. The
majority of users should be able to use the installation program for all of their needs. The 
installation comes with several files. Please see the file section for a description of these.

What the installation program does:

To configure a machine to run Capture Screen
1. Copy all files to the folder you would like to store Capture Screen.
2. Run the ViewIt_NT.reg (or ViewIt_95.reg) file located in this folder.

- This will setup registry entries and security for ViewIt. 
- If you want to change security settings for ViewIt you can do so through 

DCOMCNFG.EXE or by modifying the registry file.
(Modify these settings at your own risk, Capture Screen might not work properly if 

some settings are modified.)
3. Run the ViewIt.exe file located in this folder.

- This will register the location of the ViewIt executable with Windows.
4. Run CaptureScreen.exe to launch Capture Screen.

To configure a machine to be connected to by Capture Screen.
1. Copy ViewIt.exe and ViewIt_NT.reg (or ViewIt_95.reg) to a folder on the remote machine 
for storage.
2. Run the ViewIt_NT.reg (or ViewIt_95.reg) file located in this folder.

- This will set up registry entries and security for ViewIt. 
- If you want to change security settings for ViewIt you can do so through 

DCOMCNFG.EXE or by modifying the registry file.
(Modify these settings at your own risk, Capture Screen might not work properly if 

some settings are modified.)
3. Run the ViewIt.exe file located in this folder.

- This will register the location of the ViewIt executable with Windows.
4. From a remote machine connect to this machine.

Note: The installation program handles all of this for you. Also, if you run the setup.exe 
program that comes with Capture Screen with a -S it will perform a silent installation for a 
machine to be connected to. (Install #2 above).



Selecting a Key File 

The Key File is used to register your Capture Screen program. Without a registered Key File 
you will only be allowed to use Capture Screen 60 times. After you have used Capture 
Screen 60 times, the main window will still appear but you will not be able to connect to a 
remote computer. 

To Select a Key File:
1. Under the 'Help' menu choose 'Select Key File'.
2. In the 'Select Key File' dialog you can either type in the path of the Key File or press the 
'key' button to browse for the file.
3. Press 'OK' to accept the Key File you have selected.
4. Restart Capture Screen for the changes to take affect.

Notes:
- If you are using the Trial version of Capture Screen you will not have a key file.
- When you register Capture Screen a Key File will be sent to you. You then need to place the
key file where Capture Screen can reach it.
- If you are running a multiple user copy of Capture Screen, the Key File needs to be where 
all users can get to it.



Transferring Files 

Capture Screen allows you to transfer files either from a remote machine or too a remote 
machine.

 

To transfer a file from a remote machine to your machine
1. Connect to the remote machine.
2. From the 'File' menu choose 'Transfer File'.
3. Select the 'Remote File to Local File' radio button.
4. In the 'Remote File' edit box type in the name and path of the remote file.
5. In the 'Local Folder' edit box type in a local path where you would like to copy the file to. 

- You can also press the 'Browse' button to select a folder.
6. Press the 'Transfer' button and the file will be transferred from the remote computer.

To transfer a file from a local machine to a remote machine
1. Connect to the remote machine.
2. From the 'File' menu choose 'Transfer File'.
3. Select the 'Local File to Remote File' radio button.
4. In the 'Local File' edit box type in the name and path of a local file.

- You can also press the 'Browse' button to select a folder.
5. In the 'Remote Folder' edit box type in the path where you would like to copy the file to.
6. Press the 'Transfer' button and the file will be transferred to the remote computer.




