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Preface

4D Write is a plug-in that extends word processing capabilities to your 
4th Dimension databases. It is one of several plug-ins that, together 
with 4th Dimension, form the 4th Dimension environment.

About this Manual
This manual introduces 4D Write and describes how to create and use 
4D Write documents in 4th Dimension. It explains how to use 
4D Write to create letters, memos, and other documents. It explains 
how to enter and edit text in these documents and how to use these 
documents in conjunction with data in your database and in other 
plug-ins.

Cross-Platform 
Considerations

This manual introduces 4D Insider and explains how to use it on both 
the Windows® and Mac™ OS (Macintosh and Power Macintosh) 
platforms. Although the concepts and functionality of both versions of 
4D Write are nearly identical, the manual addresses any differences 
where necessary. Such differences may include the graphical user 
interface and keyboard commands.

The graphics in this manual illustrate 4D Write in the Windows 95 
environment. The two versions of the same screen are only presented 
if there are any major differences between them.

Hypertext 
Navigation

If you are reading this manual in electronic format (Adobe™ Acrobat 
PDF), you can take advantage of the hypertext links that it contains. 
Each word that appears in blue has a hypertext link. However, text in 
the “Table of Contents” and “Index” is not in blue, but each entry has 
a built-in hypertext link.
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When you click a hypertext link, you immediately move to the page 
that contains more information. To return to your original page, click 
the Previous page button .

You can also navigate the document by clicking the bookmarks, which 
are located to the left of the window that displays the manual pages.

Chapter 
Descriptions

This manual is divided into the following chapters:

■ Chapter 1, “Introduction,” provides an overview of 4D Write.

■ Chapter 2, “Managing 4D Write Documents,” explains how to create 
and open 4D Write documents within your database and in external 
windows.

■ Chapter 3, “Entering and Editing Text,” describes how to perform basic 
text operations in 4D Write document windows.

■ Chapter 4, “Formatting Text,” shows how to customize the appearance 
of 4D Write documents. 

■ Chapter 5, “Using Data,” explains how to use information from your 
4th Dimension database in 4D Write documents.

■ Chapter 6, “Printing,” describes how to print 4D Write documents.

Conventions This manual uses certain conventions to help you understand the 
material.

The following explanatory notes are used:

Note Text emphasized like this provides annotations and shortcuts that will 
help you use 4th Dimension more productively.

4D Server Throughout the manual, 4th Dimension and 4D Server/4D Client are 
referred to simply as 4th Dimension. Differences between the operation 
of the two products are explained in 4D Server notes, which provide 
information about using 4D Server/4D Client. This information is 
provided only when the operation of 4D Server/4D Client differs from 
that of 4th Dimension.

Notes like this alert you to important pieces of information and alert 
you to situations where data might be lost.
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All 4D Write commands added to 4th Dimension are preceded by the 
letters WR. In this manual, 4D Write commands (which do not return 
values) are printed in all uppercase letters using a special font, for 
example: WR ON COMMAND. 4D Write functions (which return 
values) are shown with an initial capital letter: WR Get styled text.

In addition, all table names are shown in brackets in the text to help 
distinguish them from the names of fields, forms, and other items. For 
instance, the Companies table is written as the [Companies] table.
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1 Introduction

This chapter provides basic information about 4D Write. It includes 
the following:

■ An overview of 4D Write’s capabilities

■ Integration with 4th Dimension

Overview
The 4D Write plug-in extends word processing capabilities to your 
4th Dimension databases. It is one of several plug-ins that, together 
with 4th Dimension, form the 4th Dimension environment. 4D Write 
allows you to include documents such as letters, reports, memos, and 
notes in your 4th Dimension forms. When used in a form, a 4D Write 
area appears as part of your data, just like a name or any other piece of 
information.

You can also treat 4D Write as a separate application by using it in 
external windows. Your work within these windows can be 
independent of your database or linked to information in your 
database or in other plug-ins.
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Integration with 4th Dimension

4D Write with a 
4th Dimension 
Database

4D Write offers more than the typical word processing features. As part 
of the 4th Dimension environment, 4D Write operates in conjunction 
with 4th Dimension databases.

4D Write enables you to attach word processing documents to each 
record in your database. The following figure shows a letter attached to 
a record in the Contacts database.

Text is typed directly in the document and is saved with the record, 
like any other field entry.

In addition, 4D Write documents can use data from 4th Dimension 
records. You can write reports and letters that automatically import or 
extract information from the database. For example, the letter shown 
in the figure draws the person’s name and address from the record to 
which it is attached.
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Integration with 4th Dimension
4D Write as an 
Independent 
Application

You can also use 4D Write in an external window as a stand-alone 
application with special access to the 4th Dimension database.

The following figure shows a promotional letter that includes fields 
from a 4th Dimension database.

Field references 
in text
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2 Interface

Introduction
4D Write can either be used in an included area or in an external win-
dow. Whichever you choose, the interface elements remain identical. 
The purpose of this chapter is to describe the 4D Write interface and to 
explain how it allows you to access the 4D Write features.

Note In this chapter, we will usually use the term window to designate 
either a 4D Write area or a 4D Write window. When necessary, the 
distinction will be made explicitly.
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The 4D Write Window
The 4D Write window appears as follows:

The 4D Write windows consists mainly of the following elements,

■ A document area

■ A menu bar, located at the top of the 4D Write window;

■ Four toolbars, located above the menu bar;

■ A horizontal ruler, located above the text area;

■ A status bar, located at the bottom of the window; and

■ Two scroll bars and two splitters.

Menu Bar

Toolbars

Ruler

Text area

Status Bar

 
Splitter

Splitter

Vertical scrollbar

Horizontal scrollbar
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The Menu Bar The menu bar is displayed at the top of the 4D Write window:

Moving the Menu Bar The 4D Write menu bar can be moved in the same way as the toolbars 
can. It can be moved to any side of the 4D Write window. It can also 
be displayed as a floating palette when located above the text area or 
outside the 4D Write Window.

¨̈̈̈ To move the 4D Write menu bar:

1 Place the mouse cursor above the grayed area located on the left of 
the menu bar.

2 Click and hold down the left mouse button.
The cursor becomes a cross and you can drag the menu bar.

3 Drag the menu bar over the upper part of the window
OR
move the menu bar over the text area or outside the 4D Write 
window.

4 Release the mouse button.
If you have moved the menu bar to the upper part of the 4D Write 
window or to its sides, it appears attached to that side of the window. If 
you have moved the menu bar to the text area or outside the 4D Write 
window, it is then displayed as a palette:

Note If you close the Menu bar palette, you will need to use the following 
key combination to display the menu bar again:
Ctrl+Shift+M on Windows
Cmd+Maj+M on Mac OS
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The Toolbars There are four toolbars in 4D Write:

They are designed to allow you to have a quick access to some features 
that would otherwise require the use of menu commands. For more 
information about the functions of each of those toolbars refer to “4D 
Write Toolbars”, on page 46.

Moving a Toolbar Menu bars can be moved to the four sides of the 4D Write window. 
They can also be displayed as a floating palettes when located above 
the text area or outside the 4D Write Window.

1 Place the mouse cursor above the grayed area located on the left of 
the toolbar.

2 Click and hold down the left mouse button.
The cursor becomes a cross and you can drag the toolbar.

3 Drag the toolbar over the upper part of the window
OR
move the toolbar over the text area or outside the 4D Write window.

4 Release the mouse button.
If you have moved the toolbar to the upper part of the 4D Write win-
dow or to its sides, it appears attached to that side of the window. If 
you have moved the toolbar to the text area or outside the 4D Write 
window, it is then displayed as a palette:
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The ruler The ruler displays the position and type of tab stops, the position of 
margins and the position of the first line indent. The ruler consists of 
two main parts:

■ The ruler itself:

This part displays the location and type of tab stops as well as the 
location of the margins.

■ A pop-up menu is located at the left end of the ruler.

This menu allows you to select a type of tab to set when you click in 
the ruler.

Fore more information, about how to use the ruler, refer to “Setting 
Tabs”, on page 124.

The Status Bar The status bar is located at the bottom of the 4D Write window. It 
displays, from left to right: the current page number; the total number 
of pages in the document; the line and column number of the cursor 
location; and the status of the CAPS LOCK and NUM LOCK keys. It 
also displays a progress bar when a time consuming operation is being 
executed.

First Line Indent 
marker

Left Margin marker

Tab Stop 
marker

Right 
Margin marker
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The 4D Write Menus
4D Write includes ten menus:

■ The File menu
This menu is used for printing, for managing files and to access prefer-
ences.

■ The Edit menu
This menu is used to access standard features such as Cut/Paste, undo 
or re-do operations and to access Find/Replace features. It also allows 
you to modify the character case and to select the whole document.

■ The View menu
This menu is used to choose how the document is displayed.

■ The Insert menu
This menu is used to insert variables (date and time, page number), 
pictures, page breaks, columns, tables and 4D expressions.

■ The Style menu
This menu is used to define the style and case attributes of the selected 
text.

■ The Colors menu
This menu is used to select a color for characters or style attributes.

■ The Paragraph menu
This menu allows you to define the line spacing and the justification 
of the currently selected paragraph or paragraphs. It also allows you to 
select and insert bullets, and to copy/paste the ruler.

■ The Format menu
This menu allows you to have access to the format dialogs for style 
sheets, characters, tab stops, borders and columns.

■ The Tools menu
This menu allows you to select a spellchecker, to define a language for 
the document, to display and edit the properties of the document 
(title, subject, author and notes) and to display document statistics 
(word count, number of characters, paragraphs and so on). It also 
allows you to update or freeze the 4D references in the document.

■ The Help menu
On Windows this menu allows you to open the on-line help.
20 4D Write Reference Manual



The 4D Write Menus
The File Menu The File menu allows you to access the standard file management 
features, the printing features as well as the preferences:

■ New
Selecting this command displays a new empty document in the text 
area. If the document on which you are working is not saved, a dialog 
is presented to give you an option to save that document first.

■ Open
Selecting the Open menu command opens the standard Open file dia-
log box that corresponds to the platform you are working on.

■ Save
Selecting the Save menu command saves the current document at its 
current location. If the current document is a document that was never 
saved the Save menu command is grayed.

■ Save as
Selecting the Save as menu command displays the standard Save file 
dialog. If the document on which you are working is a new document, 
selecting the Save as menu command has the same effect as selecting 
the Save menu command.
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■ Preferences
Selecting the Preferences menu command displays the Document 
Preferences dialog:

This dialog allows you to set the preferences of the document, such as 
ruler units, header and footer options, binding options, widow and 
orphan control and the selection of the spellchecker. For more 
information about how to use this dialog, refer to “Setting 
Preferences”, on page 72.

■ Page Setup
Selecting the Page Setup menu command displays the Page Setup dia-
log of the current printer.
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■ Print Preview
Selecting the Print Preview menu command displays the print pre-
view window:

The Print Preview window displays the pages of the document as it will 
be printed. It also allows you to start or cancel the printing. For more 
information about this window, refer to “Previewing the Document”, 
on page 191.

■ Print
Selecting the Print menu command displays the Print dialog for the 
current printer.
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■ Print merge
Selecting the Print merge menu command displays the Print Mailing 
dialog:

This dialog allows you to choose a selection of records for each of 
which a version of the current document will be printed. For more 
information about how to use this dialog, refer to “Printing a Merge 
Document”, on page 189.

■ Go to full window
This command expands the 4D Write window to the screen size (on 
Mac OS) or to the size of the window of the application (Windows). 
The 4D Write menu bar temporarily replaces the 4th Dimension menu 
bar.

The Edit Menu The Edit menu allows you to:

■ Copy/Paste text and pictures;

■ Cancel or repeat the last operation executed by the program;

■ Find and replace formatting or text;

■ Select all of the text (including the pictures that are in the text flow);

■ Modify the character case for the current selection;

■ Display the current selection; or

■ Go to a specific page.
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The Edit menu offers the following commands:

■ Undo Action
Selecting the Undo Action menu command reverses the last action 
taken by the user. If the last action cannot be undone, the command 
menu is dimmed and its title becomes Cannot Undo Action.

■ Redo Action
Selecting the Redo Action menu command re-does the last action 
taken by the user. If the last action cannot be repeated, the command 
menu is dimmed and its title becomes Cannot Redo Action.

■ Cut
Selecting the Cut menu command deletes the current selection and 
places it in the clipboard.

■ Copy
Selecting the Copy menu command copies the current selection and 
places it in the clipboard.

■ Paste
Selecting the Paste menu command inserts a copy of the contents of 
the clipboard at the location of the insertion point, or replaces a selec-
tion with the contents of the clipboard if anything is selected.

Note If the contents of the clipboard is an image and Page View mode is 
selected, 4D displays the Paste Picture dialog. This dialog allows you to 
set where the picture will be pasted (floating or within the text, for 
example). For more information about this, refer to “The Paste Picture 
Dialog”, on page 111.

■ Delete
Selecting the Delete menu command deletes the current selection.
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■ Select all
Selecting the Select all selects all the elements present in the area 
being edited (characters, tables and pictures).

Note If Page View mode is selected, and the cursor is located in either the 
header or footer area, only the contents of that area will be selected.

■ Find
Selecting the Find menu command Displays the Find dialog:

The Find dialog is used to define character, style, border or format 
searches. For more information about how to use this dialog, refer to 
“Finding Text”, on page 92.

Find Next
Selecting the Find Next menu command triggers a search based on the 
last character or format search you performed.
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■ Replace
Selecting the Replace displays the Replace dialog:

This dialog allows you to define searches in the same way the Find 
dialog does. It also allows you to define a character string that will 
replace that string you searched for. Replacements are not limited to 
characters and can be extended to character, paragraph, border and 
style formats. For more information about replacing characters, refer to 
“Finding and replacing sequences of characters”, on page 105.

■ Replace Next
Selecting the Replace Next menu command triggers a search based on 
the last character or format search you performed, followed by a 
replacement identical to the last replacement executed.

■ Change case
Selecting the Change case menu command displays a submenu:

This submenu allows you to modify that character case of the current 
selection.

■ lower case converts the selected text to lower case.

■ UPPER CASE converts the selected text to upper case.
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■ Title Case converts the first letter of each word in the selection to 
upper case.

■ tOGGLE CASE converts all upper case letters in the selection to 
lower case and vice-versa.

■ Show selection
Selecting the Show selection menu command scrolls the document in 
order to display either the insertion point or the current selection. If 
either is already displayed, this command has no effect.

■ Go to page
Selecting the Go to page menu command displays the Go to Page 
dialog:

For more information about this dialog, refer to “Going to a Specified 
Page”, on page 85

Once you have entered a page number, clicking OK displays the 
corresponding page.

The View Menu The View menu allows you to:

■ Select Page View mode.

■ Select the elements you want to display in the 4D Write window (tool-
bar, rulers, headers, footers, 4D references, pictures, invisible charac-
ters, frames, menu bar and status bar).

The menu commands of the View menu are the following:

■ Normal
Selecting the Normal menu command displays the document as an 
uninterrupted series of paragraphs without columns, headers or foot-
ers. When this mode is selected, a checkmark is displayed next to the 
Normal menu command. Selecting this option unchecks the Page 
menu command.
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■ Page
Selecting the Page menu command displays the document as a succes-
sion of separate pages, and displays text columns. When this mode is 
selected, a checkmark is displayed next to the Page menu command. 
Selecting this option unchecks the Normal menu command.

■ Toolbars
Selecting the Toolbars menu command displays a submenu:

In this submenu, toolbars whose name is preceded by a checkmark are 
displayed. Selecting the name of a toolbar, when there is a checkmark 
next to it, hides the corresponding toolbar. Selecting the name of a 
toolbar, when there is no checkmark next to it, displays the corre-
sponding toolbar.

■ Rulers
Selecting the Rulers can either hide or display the rulers. When rulers 
are displayed, a checkmark is displayed next to the Rulers menu com-
mand. 

Note When the Page View mode is selected, both horizontal and vertical 
rulers are displayed. When the Normal view mode is selected, only the 
horizontal ruler is displayed. The Rulers menu command only affects 
the rulers that are displayed by the current view mode.

■ Header
When in Page view mode, selecting the Header menu command dis-
plays the document’s header area. The header area is displayed in a 
separate area located at the top of the current page. When the Normal 
view mode is selected this command is disabled since that mode can-
not display the header area.

■ Footer
When in Page view mode, selecting the Footer menu command dis-
plays the document’s footer area. The footer area is displayed in a sepa-
rate area located at the bottom of the current page. When the Normal 
view mode is selected this command is disabled since that mode can-
not display the Footer area.
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■ References
Selecting this command displays the values of the references. When a 
checkmark appears before the References menu command, references 
are displayed, otherwise the computed values of references are dis-
played. For more information about displaying values or references, 
refer to “Showing References or Values”, on page 185.

■ Pictures
When a checkmark is displayed next to the Pictures menu command, 
4D Write displays the picture. When no checkmark is displayed next to 
the Pictures menu command, 4D Write displays frames instead of pic-
tures. This make the display faster.

Note This menu command also affect the printing of pictures.

■ Invisible characters
When a checkmark is displayed next to the Invisible characters menu 
command, 4D Write displays invisible characters. Selecting this menu 
item when it is checked unchecks it, and vice-versa.

■ Margins
This menu command is only accessible when Page view mode is 
selected. When Page view mode is selected, selecting the Margins 
menu command displays or hides the margins of the document. When 
margins are displayed, a checkmark is displayed next to the Margins 
menu command.

■ Horizontal scrollbars
Selecting Horizontal scrollbars displays or hides the horizontal scroll-
bar. When the horizontal scrollbar is displayed, a checkmark is dis-
played next to the Horizontal scrollbars menu command.

■ Vertical scrollbars
Selecting Vertical scrollbars displays or hide the horizontal scrollbar. 
When the horizontal scrollbar is displayed, a checkmark is displayed 
next to the Vertical scrollbars menu command.

■ Menu bar
Selecting Menu bar displays or hides the menu bar. When the menu 
bar is displayed, a checkmark is displayed next to the Menu bar menu 
command. When the menu bar is hidden, you can display it again by 
pressing the following combinations of keys: Ctrl + Shift + M on Win-
dows and Command + Shift + M on Mac OS.
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■ Status bar
Selecting the Status bar displays or hide the horizontal scrollbar. 
When the horizontal scrollbar is displayed, a checkmark is displayed 
next to the Status bar menu command.

The Insert Menu The Insert menu allows you to insert variables (date and time, page 
number), page breaks, column breaks, and 4D expressions. If the 
insertion point is located in the text, the element is inserted at the 
insertion point, otherwise it replaces the current selection.

The Insert menu includes the following menu commands:

■ Date and time
Selecting the Date and time menu command displays the Insert date 
dialog.

This dialog allows you to select the current date, the current time or 
both as well as their display formats. For more information about this, 
refer to “Inserting the Current Date and Time”, on page 90.
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■ Page number
Selecting the Page number menu command displays the Insert page 
number dialog.

Once the format selected, clicking OK inserts the page number at the 
location of the insertion point. For more information, refer to 
“Inserting the page number”, on page 91.

■ Special character
Selecting the Special character displays the Select Special character 
dialog:

This dialog allows you to pick a specific character by viewing it before-
hand. For more information, refer to “Inserting a Special Character”, 
on page 92.

■ Hyphen
Selecting the Hyphen menu command inserts a hyphen at the cursor 
location. For more information, refer to “Inserting and Removing 
Hyphens”, on page 90.

■ Non Breaking space
Selecting the Non Breaking space menu command inserts a non 
breaking space at the insertion point.
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■ Column break
Selecting Column break menu command inserts a column break at 
the insertion point.

■ Page break
Selecting Page break inserts a page break at the insertion point.

■ 4D Expression
Selecting the 4D Expression menu command displays the Insert 4D 
Expression dialog:

This dialog allows you to select a field or to define a 4D expression. For 
more information about this dialog, refer to “Referencing Fields and 
Expressions”, on page 177.

The Style Menu The Style menu allows you to modify style attributes for the current 
selection. Style attributes can be combined by sequentially selecting 
styles.
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■ Plain
Selecting the Plain menu command allows you clear all style attributes 
that would be applied to the current selection. Case, font, size and 
color attributes are not affected by this function.

■ Bold
Selecting the Bold menu command applies the bold style to the cur-
rent selection.

■ Italic
Selecting the Italic menu command applies the italic style to the cur-
rent selection.

■ Shadow
Selecting the Shadow menu command applies the shadowed style to 
the current selection. This style is not the standard Mac OS Shadow 
effect, but an attribute defined by 4D Write. This makes the attribute 
available on both Windows and Mac OS platforms.

■ Strikethrough
Selecting the Strikethrough menu command scores out the current 
selection.

■ Underline
Selecting the Underline command menu displays a submenu that 
allows you to choose a type of underline.

■ No underline selects no underline for the current selection.

■ Single underline underlines the selection with a single stroke.

■ Word underline underlines only the words of the selection with a 
single stroke.

■ Double underline underlines the current selection with a double 
line.

■ Hatched underline underlines the current selection with a doted 
line.

■ Superscript
Selecting Superscript applies the superscript attribute to the current 
selection.
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■ Subscript
Selecting Subscript applies the subscript attribute to the current selec-
tion.

■ Capitals
Selecting Capitals displays the characters in the current selection in 
upper case (the case in which the text is typed is still stored but not 
shown).

■ Small capitals
Selecting Small capitals displays the current selection, using uppercase 
characters of the next lower size to display text entered in lower case.

Please note that, during a character search, a small capitals character is 
not considered as an uppercase character. In other words, an “a” 
character will be displayed as “A” if you select the small capitals style 
attribute. It will however be returned by a search on the “a” character.

The Colors Menu The Colors menu will allow you to modify color attributes of the 
selected elements.

For a selected piece of text, the elements for which you can set the 
color are the following:

■ the Characters;

■ the Character background;

■ the Stroke of the Strikethrough effect;

■ the Line that underlines a piece of text;

■ the shadow for the Shadowed effect;

■ the Paragraph background; and

■ the Text borders

The menu commands of the Colors menus and their effect are the fol-
lowing:
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■ Text
Selecting the Text menu command displays a color submenu. The 
color selected using this submenu will be applied to the current text 
selection.

■ Back
Selecting the Back menu command displays a color submenu. The 
color selected using this submenu will be applied to the background of 
the current text selection.

■ Strikethrough
Selecting the Strikethrough menu command displays a color sub-
menu. If the Strikethrough style is selected for the current selection, 
the selected color will apply to the stroke of the Strikethrough effect. If 
the Strikethrough style is not selected for the current selection, the 
selected color will be stored and will appear if the Strikethrough style is 
selected at a later time.

■ Underline
Selecting the Underline menu command displays a color submenu. If 
the Underline style is selected for the current selection, the selected 
color will apply to the line of the Underline effect. If the Underline 
style is not selected for the current selection, the selected color will be 
stored and will appear if the Underline style is selected at a later time.

■ Shadow
Selecting the Shadow menu command displays a color submenu. If 
the Shadow style is selected for the current selection, the selected 
color will apply to the shadow of the Shadow effect. If the Shadow 
style is not selected for the current selection, the selected color will be 
stored and will appear if the Shadow style is selected at a later time.

■ Borders back
Selecting the Borders back menu command displays a color submenu. 
The selected color will apply to the background of all the paragraphs of 
the current selection.

■ Borders line
Selecting the Borders line menu command displays a color submenu. 
If borders are selected for the current selection, the selected color will 
apply to those borders. If no borders are selected for the current selec-
tion, the selected color will be stored and will appear if borders are 
selected at a later time.
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The Paragraph 
Menu

The Paragraph menu allows you to set for the selected paragraphs:

■ whether the paragraph has a bullet and the character used for the bul-
let;

■ the alignment; and

■ the line spacing.

It also allows you to copy the contents of the ruler for a paragraph and 
apply it to other paragraphs.

The menu commands of the Paragraph menu are the following:

■ Copy Ruler
Selecting the Copy Ruler menu command copies the current settings 
of the ruler. The copied settings are the following: tab type and loca-
tion, first line indent, and margin settings as well as all the paragraph 
attributes.

Note If you select several paragraphs, the ruler can only be copied if it is 
identically defined for each of those paragraphs.

■ Paste ruler
Selecting the Paste ruler pastes the ruler that was previously copied 
using the Copy Ruler menu command. For more information, refer to 
the previous paragraph.
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■ Bullets
Selecting the Bullets menu command displays the following submenu:

This submenu allows you to select a specific type of bullet for the para-
graphs of the current selection. The selected bullet will appear at the 
beginning of the first line of the paragraph. If you select the Other sub-
menu command, the Select Special Character dialog is displayed.

For more information about the use of the Select Special character 
dialog refer to “Setting bullets”, on page 129.

Note Only the default bullets share the same appearance on both Windows 
and Mac OS platforms.

■ Align left
Selecting the Align left menu command applies a left alignment to all 
the paragraphs of the selection.

■ Align center
Selecting the Align center menu command centers all the paragraphs 
of the selection between their margins.
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■ Align right
Selecting the Align right menu command aligns the paragraphs in the 
selection with their right margins.

■ Full justification
Selecting the Full justification menu command fully justifies all para-
graphs of the selection between their margins.

■ Single spaced
Selecting the Single spaced menu command applies the default line 
spacing to all the paragraphs of the selection.

■ 1.5 Line spaced
Selecting the 1.5 Line spaced menu command applies a line spacing of 
one and a half line to all the paragraphs of the selection.

■ Double spaced
Selecting the Double spaced menu command applies a line spacing of 
two lines to all the paragraphs of the selection.

■ Other
Selecting the Other menu command displays the Other line spacing 
dialog:

The line spacing that is entered in this dialog will be applied to the 
selected paragraphs. For more information, refer to “Setting Line Spac-
ing”, on page 123. 

The Format Menu The Format menu allows you to access the dialogs that set character, 
paragraph, tab, border and column formats. It also enables you to 
access the style sheet management dialog.
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■ Character
Selecting the Character menu command displays the Character dialog.

This dialog allows you to set several attributes of the characters of the 
selection at once. For more information about how to use this dialog, 
refer to “Changing Text Attributes at Once”, on page 138.

■ Paragraph
Selecting the Paragraph menu command displays the Paragraphs dia-
log.

This dialog allows you to set the paragraph properties for the selected 
paragraphs. For more information about how to use this dialog, refer 
to “Formatting Paragraphs”, on page 120.
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■ Tabs
Selecting the Tabs menu command displays the tabs dialog.

This dialog allows you to define the location and type of the tab stops 
for the selected paragraphs. For more information about how to set 
tabs, refer to “Setting Tabs”, on page 124.

■ Borders
Selecting the Borders menu command displays the Borders dialog:

This dialog allows you to select the location and type of border you 
want to apply to the selected paragraphs. For more information about 
this point, refer to “Setting Borders for a Paragraph”, on page 150.
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■ Style Sheets
Selecting the Style Sheets menu command displays the Style Sheets 
dialog:

This dialog allows you to create, modify, import and apply style sheets. 
For more information about style sheets, refer to “Managing Style 
Sheets”, on page 140.

■ Columns
Selecting Columns displays the Columns dialog.

This dialog allows you to set the width, the spacing and the number of 
columns of the document. For more information about Columns in 
4D Write, refer to “Managing Columns”, on page 169.
42 4D Write Reference Manual



The 4D Write Menus
The Tools Menu The Tools menu allows you to access several utility features such as 
spellchecking, statistics and document information and the language 
selection. Using the Tools menu also allows you to display either 
values or references and to force an update of the references.

The Tools menu contains the following menu commands:

■ Table Wizard
Selecting theTable Wizard menu command displays the table wizard:

The table wizard allows you to define the table settings when creating 
a table. For more information about creating tables, refer to “Managing 
Tables”, on page 154.
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■ Spelling

Selecting the Spelling menu command displays a spellchecker 
selection dialog, or, if any spellchecker is currently selected, it displays 
the Spelling dialog.

For more information about how to use the Spelling dialog, refer to 
“Using a Spelling Checker”, on page 116.

■ Language
Selecting the Language menu command displays the language selec-
tion dialog.

For more information about the use of the language in your document. 
Please refer to “Choosing the Language”, on page 117.
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■ Document Information
Selecting the Document Information menu command displays the 
Document Information dialog:

In this dialog, you can store useful extra information with your docu-
ment. This includes a title, a subject, an author, a company and some 
note. Once you have entered this data, click OK to close the dialog and 
validate your entry or Cancel to ignore the changes.

■ Document Statistics
Selecting the Document Statistics displays the Document Statistics 
dialog:

This dialog displays statistics related to the current document. It 
includes the total number of lines, the total number of pages, the total 
number of characters, the total number of words, the total number of 
4D objects and the size of the document file.
454D Write Reference Manual



Chapter 2  Interface
■ Compute references now
Selecting the Compute references now menu command recomputes 
all references and expressions in the document based on the current 
values in the database.

■ Freeze references
Selecting the Freeze references menu command replaces each refer-
ence by its current value and converts it into a character string. This 
action cannot be canceled.

4D Write Toolbars
4D Write toolbars are located in the upper part of the 4D Write win-
dow.

Toolbars are used to quickly access features that are often used. There 
are four toolbars in 4D Write:

■ The Standard toolbar

■ The Style toolbar

■ The Borders toolbar,

■ The Format toolbar
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The Standard 
Toolbar

The Standard toolbar is organized into five groups of buttons:

■ the file management buttons;

■ the print management buttons;

■ the character search buttons;

■ the copy/paste buttons;

■ the Undo and Redo buttons;

■ the view management buttons; and

■ the insertion icon

The File Management 
Icons

These are the file management buttons:

From left to right, these buttons are: the New Document button, the 
Open Document button and the Save Document button.

Clicking the New Document button displays a new empty document 
in the text area. If the document on which you are working is not 
saved, a dialog is displayed and asks you if you want to save the current 
file.

Clicking the Open Document button opens the standard Open file 
dialog box that corresponds to the platform you are working on. If the 
document on which you are working is not saved, a dialog is displayed 
asking if you want to save the current file before opening a new 
document.

Clicking the Save Document button saves the current document at its 
current location. If the current document is a document that was never 
saved a Save file dialog is displayed.
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The Print Management 
buttons

The print management buttons consists of two buttons:

From left to right the two buttons are: the Print Preview button and 
the Print button.

Clicking the Print preview button has the same effect as selecting the 
Print Preview menu command in the File menu. For more 
information about the effect of this menu command, please refer to 
“The File Menu”, on page 21.

Clicking the Print button has the same effect as selecting the Print 
menu command in the File menu. For more information about the 
effect of this menu command, please refer to “The File Menu”, on 
page 21.

The Find button Clicking the Find button has the same effect as selecting the Find 
menu command in the Edit menu. For more information about the 
effect of this menu command, please refer to “The Edit Menu”, on 
page 24.

The Copy/Paste 
Management buttons

The copy/paste buttons consists of three buttons:

From left to right the three buttons are: the Cut button, the Copy 
button and the Paste button.

Clicking the Cut button has the same effect as selecting the Cut menu 
command in the Edit menu. For more information about the effect of 
this menu command, please refer to “The Edit Menu”, on page 24.

Clicking the Copy button has the same effect as selecting the Copy 
menu command in the Edit menu. For more information about the 
effect of this menu command, please refer to “The Edit Menu”, on 
page 24.

Clicking the Paste button has the same effect as selecting the Paste 
menu command in the Edit menu. For more information about the 
effect of this menu command, please refer to “The Edit Menu”, on 
page 24.
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The Undo 
and Redo buttons

The Undo and Redo buttons are displayed as follows:

Clicking the Undo button has the same effect as selecting the 
Undo Action menu command in the Edit menu. For more 
information about the effect of this menu command, please refer to 
“The Edit Menu”, on page 24.

Clicking the Redo button has the same effect as selecting the 
Redo Action menu command in the Edit menu. For more information 
about the effect of this menu command, please refer to “The Edit 
Menu”, on page 24.

The View Management 
buttons

There are two view management buttons:

From left to right these buttons are: the View Invisible button and the 
View References button.

Clicking the View invisible button has the same effect as selecting the 
Invisible Characters menu command in the View menu. For more 
information about the effect of this menu command, please refer to 
“The View Menu”, on page 28.

Clicking the View invisible button has the same effect as selecting the 
References menu command in the View menu. For more information 
about the effect of this menu command, please refer to “The View 
Menu”, on page 28.

The Insertion buttons There are two insertion buttons:

From left to right these buttons are: the Insert Current Hour button 
and the Insert Current Date button.

Clicking the Insert Current Hour button inserts the current time at the 
insertion point. The time format is then “HH:MM”.

Clicking the Insert Current Date button inserts the current date at the 
insertion point. The time format is then “Day, Month Day of the 
month, YYYY” (Friday, March 5, 1999 for example).
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The Style Toolbar The Style Toolbar consists of the following:

■ the Style Sheet drop-down list;

■ the Font drop-down list;

■ the Font size drop-down list; and

■ the Style buttons;

The Style Sheet Drop-
down List

The style sheet drop-down list allows you to select a style sheet and 
apply it to the current selection. The style sheets that appear in that list 
are the style sheets that are available in the current document. 

The Font Drop-down List The Font drop-down list allows you to select a font and apply it to the 
current selection. The fonts that appear in that list are the fonts that 
are currently installed in your system. These fonts are the same as the 
fonts available in the Characters dialog.

The Font Size Drop-
down List

The Font size drop-down list allows you to select a font size and apply 
it to the current selection.

The Style buttons There are three style buttons:

From left to right these buttons are: the Bold button, the Italic button 
and the Single Underline button.

Clicking the Bold button applies the Bold style to the current selection 
or removes it if it was already selected. The effect of this button is 
identical to effect of the Bold menu command from the Style menu.

Clicking the Italic button applies the Italic style to the current 
selection or removes it if it was already selected. The effect of this 
button is identical to effect of the Italic menu command from the 
Style menu.
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Clicking the Single Underline button applies the Single underline style 
attribute to the current selection or removes it if it was already 
selected.

The Format Toolbar The Format Toolbar consists of three button sets :

■ the text alignment buttons;

■ the line spacing buttons; and

■ the bullet button.

The Text Alignment 
buttons

There are four text alignment buttons:

From left to right, the buttons are: the Left Aligned button, the 
Centered, the Right aligned button and the Full Justified button. This 
set of button allows you to set the text alignment of the current 
selection.

Clicking the Left aligned button aligns the paragraphs of the current 
selection to the left. The effect of this button is similar to the Align 
Left menu command from the Paragraph menu.

Clicking the Centered button centers the selected paragraphs between 
their margins. The effect of this button is similar to the Align Center 
menu command from the Paragraph menu.

Clicking the Right aligned button aligns the paragraphs of the current 
selection with their right margins. The effect of this button is similar to 
the Align Right menu command from the Paragraph menu.

Clicking the Full justified button fully justifies the current selection. 
The effect of this button is similar to the Full Justification menu 
command from the Paragraph menu.
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The Line Spacing 
buttons

There are three line spacing buttons:

From left to right, these buttons are: the Single Spaced button, the 1.5 
Line Spaced button and the double spaced button. Those buttons allow 
you to modify the line spacing for the current selection.

Clicking the Single Spaced button applies the default line spacing to 
the current selection. The effect of that button is similar to the Single 
Spaced menu command of the Paragraph menu.

Clicking the 1.5 Line Spaced button applies a line spacing of one and a 
half line to all the paragraphs of the selection. The effect of that button 
is similar to the 1.5 Line Spaced menu command of the Paragraph 
menu.

Clicking the Double Spacing button applies a line spacing of two lines 
to the current selection. The effect of that button is similar to the 
Double Spaced menu command of the Paragraph menu.

The Bullet button Clicking the Bullet button inserts a bullet at the beginning of the first 
line of each paragraph that belongs to the current selection. The style 
of bullet shown is determined by the bullet paragraph formatting 
option of each paragraph. Clicking once more on the Bullet button 
will remove the bullets.

The Borders Toolbar The Borders Toolbar consists of two button sets:

■ the individual border buttons,

■ the frame buttons,

The Toolbars allows you to separately or globally define borders for the 
paragraphs of the current selection.
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The Separate Borders 
buttons

There are four separate borders buttons :

From left to right these buttons are: the Left border button, the Top 
border button, the Right Border button and the Bottom border button. 
These buttons allow you to separately define the borders of the 
paragraphs of the current selection.

Clicking the Left Border button displays the left border of the 
paragraphs of the current selection.

Clicking the Top Border button displays the top border of the 
paragraphs of the current selection.

Clicking the Right Border button displays the Right border of the 
paragraphs of the current selection.

Clicking the Bottom Border button displays the bottom border of the 
paragraphs of the current selection.

The Frame buttons There are three frame buttons:

From left to right these buttons are: the All Borders button, the Inside 
Borders buttons and the No Borders buttons. These buttons allow you 
to set several paragraph borders at once.

Clicking The All Borders button displays the external borders that 
outline the paragraphs of the current selection.

Clicking The Inside Borders button displays the external borders that 
outline the paragraphs of the current selection as well as the bottom 
and top borders of all the paragraphs of the selection.

Clicking the No Borders button remove any border present in the 
selection.
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3 Managing 4D Write 
Documents

This chapter explains the basics of managing 4D Write documents:

■ How to create, open, and save 4D Write documents in both database 
records and in external windows;

■ Compatibility with 4th Dimension;

■ Multi-platform document management;

■ Opening a document in an external window;

■ Creating a 4D Write area in a form;

■ Creating a new document;

■ Opening an existing document;

■ Saving a document; and

■ Setting preferences for document

Compatibility with 4th Dimension
The minimum requirements for 4D Write 6.5 with the current 4D 
environments on Mac OS and Windows are as follows:

Mac OS version Windows version

4th Dimension (single user) 6.5 PPC only 6.5

4D Server 6.5 Client PPC 
only 6.5
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Multi-platform Document Management
4D Write, like 4th Dimension and 4D Server, is a multi-platform 
program. This means that, a database created under Mac OS that uses 
4D Write can be opened and run under Windows with no 
modifications, and vice versa.

Format Management
4D Write allows you to use different file formats when opening or sav-
ing a file. Those formats appear in the drop down lists in the Open file 
and Save file dialogs.

The file formats available in 4D Write are the following :

■ 4D Write 6.5 document
This format is 4D Write 6.5 native format. A 4D Write 6.5 document 
saved using this format will keep all its features. This format is 
available for both opening and saving a document. 

■ 4D Write 6.5 templates
This format is 4D Write 6.5 native format for templates, for more 
information about the templates in 4D Write and their use, please refer 
to  "Saving a Document as a Template", on page 70. This format is 
available for both opening and saving a document.

■ 4D Write 6.0 document
This is the native format for the previous version of 4D Write. This 
format is available only when opening a document.

■ RTF document
RTF stands for Rich Text Format. It allows file transfer between 
platforms while keeping basic formatting intact. This format is 
available for both opening and saving a document.
56 4D Write Reference Manual



Format Management
■ HTML document
HTML stands for Hypertext Mark-up Language. This format is mainly 
used for serving pages on a web server. This format is available for both 
opening and saving a document.

■ Windows Text document
This format is the basic windows text format, it does not embed any 
character formatting, and it uses the Windows extended ASCII table. 
This format is available for both opening and saving a document.

■ Macintosh Text document
This format is the basic Mac OS text format, it does not embed any 
character formatting and uses the Mac OS extended ASCII table. This 
format is available for both opening and saving a document.

■ Unicode text document
The unicode format is designed to avoid the character conversion that 
takes place when a document is opened on another platform, or on 
another system. It also allows the contents to be always retrieved 
independently of the script manager.

File Equivalents on 
Mac OS and 
Windows

The following table indicates the file equivalents of 4D Write 
documents on Mac OS and Windows.

Document
Mac OS Windows

Type Creator Extension 

4D Write 6.5 document 4WR7 4DW7 4W7
RTF TEXT 4DW7 RTF
Windows Text only TEXT 4DW7 TXT
Mac OS text only TEXT 4DW7 TXT
Unicode text document TEXT 4DW7 TXT
HTML document 4DW7 TXT
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Opening 4D Write in an External Window
You can use 4D Write in its own window. When used in its own 
window, 4D Write operates as if it were a separate application.

¨̈̈̈ To open 4D Write in an external window:

1 If you are not in the User environment, choose User in the Use menu.
The Plug-Ins menu is located in the User environment menu bar 
whenever any plug-ins are installed. If you have installed 4D Write, 
4D Write appears as an item in the Windows menu. If you have 
installed additional plug-ins, they appear in the same menu. 

2 Choose 4D Write from the Plug-Ins menu.
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Opening 4D Write in an External Window
A 4D Write document opens in an external window. 

The external window contains the 4D Write menu bar. The menus in 
this menu bar allow you to manage your document. For example, use 
the Style menu to apply a different style to selected text. The 
4th Dimension menus remain available in the standard menu bar at 
the top of your screen.

Windows Control
menu box

Maximize/
Minimize/

buttons
Close

4D Write
Zoom boxClose boxMacintosh

menu bar

4D Write 
toolbars

Ruler

Document
area

4D Write 
toolbars

Document
area

Ruler
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The external window also contains four toolbars. The role of those 
toolbars is to make access to specific features easier and faster. For 
example, to apply the Bold character style you can either select Bold 
from the Style menu or click the  icon in the Character toolbar. 
Toolbars also increase your control over the 4D Write interface since 
they can be moved within the 4D Write window or be separately used 
as palettes.

The ruler below the 4D Write toolbars allows you to set the margins, 
first line indent, and tabs.

The Standard toolbar allows you to quickly access some of the features 
that are accessible through the File, Display, and Insert Menus.

The Style toolbar allows you to set the format of characters and to 
select a style.

The Format toolbar allows you to set paragraph alignment, line 
spacing and the presence of bullets at the beginning of paragraphs.

The borders toolbars allows you to set the features of the borders for a 
paragraph.

4D Write windows also integrate splitters that allow you to divide the 
document area and therefore display different areas of the same 
document at the same time. For more information about splitters, refer 
to the section “Splitting the 4D Write window”, on page 82.

The document area below the ruler is where you edit your document. 

¨̈̈̈ To view more of the document area by enlarging the window to full 
screen size:

■ In Windows, click the Maximize button.
On the Macintosh, click the Zoom box.

Opening Multiple 
Documents

You can open additional 4D Write windows by choosing 4D Write 
from the Windows menu. Operating several 4D Write documents at the 
same time enables you to compare documents, copy and paste 
between documents, and move from one document to another simply 
by clicking in the appropriate window.
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The titles of all 4D Write windows appear at the bottom of the 
Windows menu. You can bring any document to the front by choosing 
it from the Windows menu.

Saving Documents When you save a document, its title bar changes to the file name it is 
saved unders.

Closing Documents To close an external window at any time:

■ In Windows, select Close from the Control menu.
On the Macintosh, click the Close box.

Window
name

Open
windows
614D Write Reference Manual



Chapter 3  Managing 4D Write Documents
Creating a 4D Write Area in a Form
You can create 4D Write areas in any database form. You can use 
4D Write in an input form, providing a document in each record for 
notes, reports, letters, or other information. You can also use a 
4D Write area in an output form to display or print a document.

Note If you use 4D Write externals in output forms used with the 4D 
commands MODIFY SELECTION and DISPLAY SELECTION, the speed of 
the display will be slower.

The following figure shows a 4D Write area in an input form. A letter is 
being created for Marcel Vandergaard. The letter will be saved 
automatically with Molly’s record when the record is accepted.

When used in a form, 4D Write areas have the same features as 
external windows, except that there is no Close box. By default, the 
four toolbars are opened (Standard, Style, Format and Borders).

4D Write area

Document 
area
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¨̈̈̈ To view a 4D Write area at full screen size:

■ In Windows, click the Maximize button.
On the Macintosh, click the Zoom box.
OR

■ Choose Goto Full Window from the 4D Write File menu.
Note that the expanded area now has a Close box.

¨̈̈̈ To view the area in the form again:

■ Choose Return to Form from the 4D Write File menu.
OR

■ Click the Close box.

¨̈̈̈ To create a 4D Write area in a form:

1 If you are not already in the Design environment, choose Design from 
the Use menu.
The Structure window appears, showing the database tables and fields.

To save the contents of the 4D Write area with each record in a table, 
you must create a Picture or BLOB field in a way that associates it with 
the area. As with all plug-ins, the contents of a 4D Write area can be 
stored in a Picture field. Starting with version 6.5, you can also store a 
4D Write area in a BLOB field.

The remainder of the steps assume that you will save the contents of 
the area with each record.

2 Add a Picture field to the table whose form will have the 4D Write 
area.
For information on creating a Picture or BLOB field, refer to the 
4th Dimension Design Reference.

3 Give the Picture or BLOB field a name ending with an underscore (_).
For example, you can name the field Letter_.

4 Choose Explorer from the Tools menu to open the Explorer window.

5 In the Forms tab within the Explorer window, select the form to which 
you want to add the 4D Write area, and click Edit.
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The Form Editor opens:

6 In the Form editor, use the Plug-in area Object tool to draw an area for 
4D Write.
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4D Write can use the entire form or it can share space with fields and 
other form elements.

When you finish drawing the object, 4th Dimension displays the 
Property list window, with the Variable object type selected.

Drawing an area to 
display the document

Plug-in area Tool
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7 Click the Type drop-down list, and select 4D Write

The Type drop-down list lists the plug-ins you have installed. If 
4D Write is not displayed here, it has not been installed. In this case, 
close the database and install 4D Write before continuing with this 
exercise.

In the form editor, the object now displays the following message :

8 In the Variable name box, name the 4D Write area by entering the 
name of the Picture field, minus the underscore. 
For example, if you named the Picture or BLOB field Letter_, you 
would name the 4D Write area Letter.

Giving the 4D Write area this name associates it with the field, 
ensuring that its contents will be automatically saved with each record. 
If you do not automatically save the contents of the area, 4D Write will 
give you the opportunity to save the contents of the area on disk when 
you accept the record.

An external object is one of several types of active objects. For more 
information on external objects, refer to the 4th Dimension Design 
Reference and the 4th Dimension Language Reference.

9 Click the Close box
OR
Deselect the Variable Name box.
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4th Dimension closes the dialog box and displays the form with the 
4D Write area. The area displays the 4D Write icon, the area name, and 
the message that the document will be saved with the Picture or BLOB 
field.

Saving Documents

Proper Naming of 
4D Write Areas

If the area name does not correspond with the Picture or BLOB field 
name or if the Picture field does not exist, 4D Write warns you that the 
document will not be saved with the record— the document could be 
saved if a Picture or BLOB field with the appropriate name existed.

Saving the 4D Write 
Document as a Separate 
File

In some cases, you may not want the document to automatically be 
saved with the record. For example, you might want to store your 
documents on disk and load them procedurally. In this, case, you 
would not want to create a Picture or BLOB field to store the 
documents.
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Renaming the Area If you later want to automatically save the document with the record, 
you can go back and rename the 4D Write area. If the area name does 
not correspond with the Picture or BLOB field name, you can correct 
the name by double-clicking on the 4D Write area in the form. This 
shows the property list for the 4D Write area, so you can type the 
correct name in the Variable name box.

If the Picture or BLOB 
Field Does Not Exist

If the Picture field or BLOB does not yet exist, you can create the 
Picture or BLOB field in the Structure window. In fact, it does not 
matter which you create first—the Picture field or the 4D Write area. If 
you wish, you can create the 4D Write area on the form first and then 
go back and create the corresponding Picture or BLOB field.

Creating a New Document
You can create a new, blank document in either an external window or 
a 4D Write area at any time. In either case, the new document replaces 
the current document. If you have made changes to the current 
document, you will be prompted to save the changes before 4D Write 
opens the new document.

¨̈̈̈ To create a new document:

■ Choose New from the 4D Write File menu.

Opening Documents in 4D Write 
You can open documents in any 4D Write external window or 
4D Write area. The file formats 4D Write can open are described in the 
section “Format Management”, on page 56.

¨̈̈̈ To open a document in an external window or 4D Write area:

1 Choose Open from the 4D Write File menu.
A standard Open File dialog box appears.

2 Choose a file format from the Format pop-up menu in order to see 
only the corresponding files.

3 Select a document.

4 Click Open.
The newly opened document replaces the current document in the 
current 4D Write window.
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Saving 4D Write Documents
You can save the text entered in a 4D Write document regardless of 
whether the document was created in an external window or in a 
form. 4D Write offers several ways to save documents.

■ As part of a record

■ As a Macintosh or Windows file

■ As a template for a 4D Write area

Saving a Document 
with a Record

If you have created a 4D Write area on a form and have created a 
Picture or BLOB field to store the area’s contents, any text entered in 
the area is automatically saved with each record when the record is 
accepted. 

You can also save a document created in a 4D Write area as a separate 
file. For more information, refer to  "Saving a Document as a File", on 
page 69.

Saving a Document 
as a File

Any document that you create using 4D Write can be saved as a 
separate file. You use the familiar Save and Save As… menu items from 
the 4D Write File menu to save and update individual documents. 

Documents you have saved can be opened by choosing Open from the 
4D Write File menu. It makes no difference whether the document has 
been created in an external window or in a form; the document can be 
saved or opened in either place.

¨̈̈̈ To save a 4D Write document as a file:

1 Choose Save As… from the 4D Write File menu.
Note that you choose this menu item from the 4D Write File menu, 
rather than from the 4th Dimension File menu.

4D Write displays the Save the File as: dialog box.

2 If necessary, choose the file format in which you would like to save the 
document from the Save File as type: pop-up menu.
By default, 4D Write documents are saved in the standard 4D Write file 
format. You can also save the current document in other formats.

For more information about the file formats and their meanings, 
please refer to "Format Management", on page 56.

Enter a unique filename for the document.
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3 Click Save.
4D Write saves the document under the filename you entered.

¨̈̈̈ To update a document you have saved: 

■ Choose Save from the 4D Write File menu. 
The original file is updated.

Saving a Document 
as a Template

You may need to create a standard document containing elements that 
are the same for every document, such as a standard report format or 
letter heading. Instead of recreating the elements each time, you can 
save the document as a template used by every document displayed in 
a particular 4D Write area in a form.

Note You can create templates only for 4D Write areas on forms; they 
cannot be used for external windows. When you use 4D Write in an 
external window, the Save as Template menu item is dimmed.

The saved template is used by every document displayed in the 
4D Write area. Each document starts with the same template, but any 
unique modifications you make to any document are saved with the 
record. There can be only one template for each 4D Write area on a 
form.
70 4D Write Reference Manual



Saving 4D Write Documents
The 4D Write area in the following figure uses a template to display the 
name and address from the person’s record. Each person’s record 
displays the name and address in the same manner.

¨̈̈̈ To save a 4D Write document as a template:

■ Choose Save as Template from the 4D Write File menu.
4D Write saves the document, giving it the same name as the 4D Write 
area on the form, plus an underscore. For example, the template file for 
the “WPArea” area is named “WPArea_”.

Note 4D Write assigns the filename and always saves the template in the 
database folder, so no Save File dialog box is displayed when you 
choose Save as Template.

In Windows, the name of your area can contain a maximum of seven 
characters.

You can also create a template by saving a 4D Write document and 
giving it same name as the 4D Write area, plus an underscore. The 
template file must be in the same folder as the database structure table. 
You can temporarily disable the use of a particular template file by 
changing the template filename.

Template displays 
name and address
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¨̈̈̈ If you modify the template and want to incorporate the changes: 

■ Choose Save as Template from the 4D Write File menu again. 
4D Write asks you if you would like to replace the existing template 
file. Clicking the OK button updates the template.

Multi-Platform 
Templates

To share templates between Mac OS and Windows clients, regardless of 
the server platform, the procedure is as follows.

The process is transparent for users. If the server is a Windows 
machine, the name of the template file should be AreaName_.4WT and 
if the server is a Macintosh machine the name of the template file 
should be AreaName_. 

Setting Preferences
4D Write lets you set preferences for a document. You can choose the 
ruler units and the document display mode. By choosing the 
document display mode, you determine the document’s appearance, 
including whether headers and footers are displayed and whether a 
frame appears around the document’s text area on screen.

¨̈̈̈ To set preferences for a document:

■ Choose Preferences from the 4D Write File menu.
The Document Preferences dialog box appears
72 4D Write Reference Manual



Setting Preferences
The Document Preferences dialog box is divided into two different 
pages, each of which is accessible using a Tab control.

The Document page allows you to set the following options:

■ Units: You can choose the units that will be displayed in the 
document’s ruler. The ruler is used to set the margins, first line indent 
and tabs for the document.

■ Headers and footers

■ Different on first page: checking this check box will allow you to 
define different headers and footers for the first page and for the 
remainder of the document.

■ Different on left and right page: checking the option will allow you 
to define different header and footers for the left and right pages. If 
this option is left unchecked, the headers and footers will be 
defined once for both types of pages.

■ First page is:
This menu allows you to select the side of the first page. Selecting Right 
sets the side of the first page to Right. Selecting Left sets the side of the 
first page to Left.

■ First page Number:
This box allows you to set the page number of the first page. Automatic 
page numbers will be updated accordingly.

■ Binding:
This box allows you to set the value of the space left for the binding of 
your document. If the Opposite pages option is checked, the value 
entered will be applied to opposite pages as it is required when binding 
a book of double-sided pages. If the Opposite pages option is not 
checked, the value of the binding is always applied to the same side of 
the page, as required in binding a book of single-sided pages. The 
Binding value is expressed in the unit selected in the Unit drop-down 
list.

■ Opposite pages:
When this option is checked the space allocated to the binding is set to 
manage double-sided pages. When this option is not selected the space 
allocated to the binding takes remains constant for left and right 
pages, as required for single-sided pages.
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■ Paragraph:

■ Default Tab Spacing
This box allows you to set the default value for tab spacing. This 
value will be applied to all the paragraphs that have no custom set-
tings.

■ Widow and Orphan control
Checking this box will prevent the first line of a paragraph from 
being left at the end of a page, and it will also prevent the last line 
of a paragraph from being left at the beginning of a page.

The Spellchecking page allows you to select your current spellchecker 
and dictionary. 

Selecting a 
spellchecker

4D Write enables the use of a spellchecker that complies with the 
Common Speller Application Programming Interface (C.S.A.P.I). This 
standard is currently the one in use with Microsoft™ products. 
Licenses for such spellcheckers are available from spellchecker 
publishers.

¨̈̈̈ To select a spellchecker:

1 In the 4D Write window, choose Preferences from the File menu.
The preference dialog is then displayed.
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2 Click the Spellchecking Tab control.
The Spellchecking page is then displayed:

3 In the Spellchecker area, click the Browse button.
An Open file dialog is then displayed.

4 Make sure the Show drop down menu displays either All readable 
documents or CSAPI spellchecker.

5 Select the spellchecker.

6 Click OK.

Selecting a 
dictionary

4D Write enables the use of a dictionary that complies with the 
Common Speller Application Programming Interface (C.S.A.P.I). This 
standard is currently the one in use with Microsoft™ products. 
Licenses for such dictionaries are available from dictionary publishers.

¨̈̈̈ To select a dictionary :

1 In the 4D Write window, choose Preferences from the File menu.
The preference dialog is then displayed.

2 Click the Spellchecking Tab control.
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The Spellchecking page is then displayed:

3 In the dictionary area, click the Browse button.
An Open file dialog is then displayed.

4 Make sure the Show drop down menu displays either All readable 
documents or CSAPI spellchecker.

5 Select the dictionary.

6 Click OK.
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4 Entering and Editing Text

This chapter describes how you interact with the 4D Write windows in 
your database. It also explains how to perform basic text editing 
operations, such as entering text, deleting text, and copying and 
pasting text.

The chapter includes explanations of the following:

■ Using 4D Write in an external window and in a form

■ Entering and editing text

■ Finding and replacing text

■ Creating headers and footers

■ Inserting pictures

■ Viewing document statistics
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The 4D Write Window
The 4D Write window contains a blank area in which you can type 
and display documents. You can display the 4D Write window as an 
external window or as part of a record.

Using 4D Write in an 
External Window

When you open 4D Write as an external window, the document has its 
own menu bar. 4th Dimension’s menu bar stays at the top of the screen 
and all the toolbars are displayed below it.

Windows

Title bar

Window

Window
corner

border

4D Write
menu bar

Control-menu

Minimize
button

Close
button

Maximize
button

Drag box

4D Write

Macintosh

Zoom box

Title bar
Close box

menu bar
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Moving the Window

¨̈̈̈ To move the window, drag the Title bar.

Adjusting the Window 
Size and Proportions

¨̈̈̈ To adjust the window in Windows:

1 Point to a corner or a border of the window.
The pointer becomes a double-headed arrow.

2 Drag the corner or border until the window is the desired size. 

¨̈̈̈ To adjust the window on the Macintosh:

■ Drag the Size box in the bottom right-hand corner of the window.

Maximizing the Window

¨̈̈̈ To expand a 4D Write window to take up the full screen:

■ In Windows, click the Maximize button, or choose Maximize in the 
Control menu.

On the Macintosh, click the Zoom box.

When you expand the window to full screen size, 4th Dimension’s 
menu bar remains at the top of the screen and 4D Write’s menu bar 
remains within the 4D Write window.

4D Write
menu bar
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Closing the Window

¨̈̈̈ To close a 4D Write window: 

■ On the Macintosh, click the Close box.
In Windows, select Close from the Control menu.

Using 4D Write in a 
Form

When 4D Write is used in a form, the 4D Write menu bar appears at the 
top of the 4D Write area. You can choose menu items from either the 
4th Dimension menu bar or from the 4D Write menu bar. 

Expanding a 4D Write 
Area to Full Screen

¨̈̈̈ To expand a 4D Write area:

■ Choose Goto Full Window from the File menu.
OR
In Windows, click the Maximize button or choose Maximize from the 
Control menu.
On the Macintosh, click the window’s Zoom box. 

On both platforms, the document expands to fill the entire screen and 
4D Write’s menu bar temporarily replaces 4th Dimension’s menu bar. 

4D Write
menu bar
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If the 4D Write area on the form is too small to be used without being 
expanded, it is displayed as a grey area:

When you click this area during data entry, the document area 
automatically expands to full screen size.

Note The size below which the 4D Write area is displayed as a button is 400 
pixels wide and 550 pixels high. However, in the design environment, 
the area is always displayed as an area, whatever its size.

Adjusting the Window 
Size and Proportions of 
the Expanded Window

¨̈̈̈ To adjust the expanded window in Windows:

1 Point to a corner or a border of the window.
The pointer becomes a double-headed arrow.

2 Drag the corner or border until the window is the desired size.

¨̈̈̈ To adjust the expanded window on the Macintosh:

■ Drag the Resize box in the bottom right-hand corner of the window. 

Returning to the Form When the document window is expanded, Goto Full Window in the 
File menu changes to Return to Form.

¨̈̈̈ To reduce the window and return to the form:

■ Choose Return to Form from the File menu, 
OR
In Windows, select Close from the Control menu.
On the Macintosh, click the Close box.
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Scrolling The vertical and horizontal scroll bars work as in all Macintosh and 
Windows applications, regardless of whether you are using 4D Write in 
an external window or in a form. Use the scroll bars to move through 
the document and bring hidden areas into view.

Scrolling does not change the position of the insertion point (the 
flashing vertical bar which shows where your typing will appear) or the 
current selection. After scrolling to another part of the document, you 
can return to the location of the insertion point or the selection by 
choosing Show Selection from the Edition menu. If a large block of text 
is selected, Show Selection scrolls the document to the top of the 
selected text.

Splitting the 
4D Write window

4D Write allows you to split the document area into several panes. 
Dividing the document area into panes enables separate scrolling of 
each part of the document. The document area can be divided both 
horizontally and vertically. Splitting the document area is useful when 
you want to simultaneously enter, modify or compare text located in 
different places in the document.

Splitting the document area vertically allows you to display several 
areas of the current document side by side.

Scroll arrow

Scroll bar
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¨̈̈̈ To split a window vertically:

1 In the 4D Write window, move the cursor over the split box located on 
the left of the horizontal scroll bar.
The cursor becomes a split indicator.

2 Drag the split indicator to where you want to position the border of 
the new pane.

¨̈̈̈ To split a window horizontally:

1 In the 4D Write window, move the cursor over the split box located 
above the vertical scroll bar.
The cursor becomes a split indicator.

2 Drag the split indicator to where you want to position the border of 
the new pane.

¨̈̈̈ To remove a pane:

1 Move the cursor over the border of the pane you want to delete.
The cursor becomes a split indicator.

2 Double-click on the border.
The pane disappears.

¨̈̈̈ To move the border between two panes:

1 Move the cursor over the border that you want to move.
The cursor becomes a split indicator.

2 Drag the border to its new location.

¨̈̈̈ To move insertion point into a particular pane:

1 Click or drag in the pane to locate the insertion point or make a 
selection, just as you would normally.
Note that only one pane will show the current selection or insertion 
point at a time. Any keys which would normally scroll the window or 
change the insertion point or the selection will only affect the view or 
the selection in that pane, until you click or select in a different pane.
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Special Keys In addition to scrolling, some keyboards offer keys that allow you to 
quickly find locations in a document.

Key Explanation

Home Displays the beginning of the document
End Displays the end of the document
Page Up Scrolls one page up (does not modify the cur-

rent selection)
Page Down Scrolls one page down (does not modify the 

current selection)
Ctrl (or Command) + 
left arrow

Moves the insertion point to the beginning of 
the current word or to the beginning of the 
previous word if the insertion point was already 
at the beginning of the current word.

Ctrl (or Command) + 
right arrow

Moves the insertion point to the end of the cur-
rent word or to the end of the following word if 
the insertion point was already at the end of 
the current word

Ctrl + Delete 
(Ctrl/Command + For-
ward Delete on Macin-
tosh)

Deletes the next word located on the right of 
the cursor.

Ctrl + Backspace 
(Ctrl/Command + For-
ward Delete on Macin-
tosh)

Deletes the next word located on the left of the 
cursor

Shift (in combination 
with any of the above 
keys to move the inser-
tion point or view)

Extends the current selection
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Click Combinations In addition to scrolling, 4D Write allows you to use the following click 
combination.

Note that if you hold down the mouse button and drag on the last click, 
you can select more than one of the thing indicated. So if you double-
click-and-drag, you will select whole words as you drag. If you drag in 
the left margin, you will select whole lines, and so on.

Going to a Specified 
Page

The Goto Page... command in 4D Write’s Edit menu presents a dialog 
box where you enter the number of the page to which you want to go:

¨̈̈̈ To go to a specific page:

1 Choose Goto page from the Edit menu.
The goto page dialog is then displayed.

2 Enter the page number of the page to which you want to go.

3 Click OK.

Note The page number you enter is the page number as the document will 
be printed, taking into account the page numbering as it is defined in 
the Preferences.

Combination Explanation

Single click Moves the insertion point, deselecting any text 
that was selected

Double-click Selects the word that was double-clicked and 
the following space (if any)

Triple-click Selects the paragraph
Click in left margin Selects the line next to the click.
Double-click in left 
margin

Selects the paragraph next to the click.

Shift + Click Extends the current selection to the location of 
the click.
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Entering Text
You enter text by typing on your keyboard. In a new document, you 
start on the first line. In a document already containing text, you can 
enter text on any existing line.

¨̈̈̈ To enter text:

1 Position the pointer where you want to enter text, then click.
A blinking insertion point appears where you clicked. When you start 
a new document, the insertion point automatically appears at the 
beginning of the first line.

2 Begin typing your document.
4D Write automatically wraps at the paragraph margin to create new 
lines as you type. This is commonly referred to as “word wrap.” Press 
Return (Macintosh) or Enter (Windows) only when you want to start a 
new paragraph.

You can also enter text copied into the Clipboard. Choose Paste from 
either the 4th Dimension or the 4D Write Edit menu to enter the 
contents of the Clipboard into your document at the insertion point, 
or to replace the current selection with the contents of the clipboard if 
you have part of the document selected.

Correcting Mistakes If you make a mistake, you can correct it using standard word 
processing techniques. 

¨̈̈̈ To remove one or more characters to the left of the insertion point:

■ In Windows, use the Backspace key.
On the Macintosh, use the Delete key.

¨̈̈̈ To remove the character to the right of the insertion point:

■ In Windows, press the Delete key.
On the Macintosh, press Shift-Delete or the Del key (available on some 
keyboards).

¨̈̈̈ To type over text:

■ Select the text and type the replacement text.
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Undo/Redo In order to provide you with more flexibility when editing your 
document, 4D Write manages a sequential queue of all the “Undoable” 
actions. If you have modified your document and do not like the 
result, you can undo, one at a time, all the actions you have performed 
on the text. You can undo many kinds of changes, including typing, 
text replacements, and formatting changes.

If, when canceling actions, you cancel some actions that you did not 
want to cancel, 4D Write allows you to “redo” those actions. Once you 
start canceling actions the Redo Action command becomes activated. 
This command operates in the same way as the Undo Action 
command does. It manages the same queue of actions as the Undo 
command does.

Note The only actions that cannot be undone are changes to the document 
settings (margins, tabulations, preferences and picture settings).

¨̈̈̈ To undo a change you made to your document:

■ Choose Undo from the 4D Write Edit menu.
Choosing this menu item will undo the last change you made. The 
type of change last made is reflected in the menu item itself. For 
example, if the last change you made was to paste text, the menu item 
would be listed as Undo Paste. If the last change you made involved 
typing, the menu item would be listed as Undo Typing.

¨̈̈̈ To redo an action that was just canceled:

■ Choose Redo Action from the 4D Write Edit menu.
Choosing this menu item will re-do the last change you undid. The 
type of change last action canceled is reflected in the menu item itself. 
For example, if the last action you canceled was pasting text, the menu 
item would be listed as Redo Paste. If the last change you made 
involved typing, the menu item would be listed as Redo Typing.
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Selecting Text 
to Edit

After you’ve typed text, you can revise it. You revise text by selecting 
the text—anything from a single character to the entire document—
and then applying a command or action to it.

¨̈̈̈ To select an area of text:

■ Click to set the insertion point and drag the cursor in either direction.
To extend the selection after you have released the mouse button, hold 
down the Shift key while you click and drag some more.

¨̈̈̈ To select a single word and its following space (if any):

■ Double-click the word.
To extend the selection by whole words, select a word by 
double-clicking it and then Shift-click in either direction, or hold 
down the mouse button on the second click and drag.

¨̈̈̈ To select all the text in the document:

■ Choose Select All from the 4D Write Edit menu.

Removing Text You can discard text completely or keep a copy of it on the Clipboard. 
Text copied into the Clipboard can be pasted into another document 
or pasted into the Scrapbook (on the Macintosh) or ClipBook (in 
Windows).

¨̈̈̈ To remove text permanently:

1 Select the text you want to remove.

2 Choose Clear from the 4D Write Edit menu.
OR
In Windows, press the Backspace or Delete key.
On the Macintosh, press the Delete key.

¨̈̈̈ To remove selected text while keeping a copy of it on the Clipboard:

1 Select the text you want to remove.

2 Choose Cut from the 4D Write Edit menu.

You usually cut text from your document when you want to move it to 
a new location.

Any text you remove can immediately be restored to its original 
position by choosing Undo from the 4D Write Edit menu.
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Replacing Text

¨̈̈̈ To replace text:

1 Select the text you want to replace

2 Type the new text over the selection
OR
Choose Paste from the 4D Write Edit menu to replace the text with 
the contents of the Clipboard.

¨̈̈̈ To replace text with a blank line (carriage return):

1 Select the text you want to replace.

2 In Windows, press the Enter key.
On the Macintosh, press the Return key.

To restore any text that you have replaced, choose Undo from the 
4D Write Edit menu.

Moving or Copying 
Text

Revisions often involve moving text from one place to another. You 
can cut a sentence from one paragraph and paste it into another. You 
can also copy a selection, leaving the original in place, and paste the 
copy onto another page.

¨̈̈̈ To move or copy text:

1 Select the text you want to move or copy.

2 Choose Cut or Copy from the 4D Write Edit menu.
Cut removes the selection. Copy leaves the original selection in place. 
Both commands store the selected material in the Clipboard, where it 
remains until it is replaced by the next selection you cut or copy.

3 Click to set the insertion point where you want to place the material 
from the Clipboard.
You can insert the text in the original document or in another one. 

4 Choose Paste from the 4D Write Edit menu.
The cut or copied text appears at the insertion point.

Note When using two applications that both manage RTF format for the 
clipboard, you can copy/cut and paste to transfer text from one 
application to the other. In this case, the styles will be maintained.
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Inserting and 
Removing Hyphens

After text is written, you can insert hyphens within words to enhance 
the page layout. You can manually insert “hard” hyphens into your 4D 
Write documents using the “-” key. You can also use 4D Write Edit 
menu commands to insert and remove hyphens automatically; these 
are “soft” hyphens. If a word with a soft hyphen is relocated to where 
it does not require the hyphen (for example, in the middle of a line), 
the hyphen does not appear. It will reappear if the word is later put in 
a position where it requires it again. You can insert any number of soft 
hyphens in a word to make it break at the proper place when it is at 
the end of a line.

The Soft Hyphen command is disabled if the insertion point is next to a 
punctuation character, such a a period, comma, or parenthesis.

¨̈̈̈ To insert a soft hyphen:

1 Place the cursor where the word is to be separated at the end of a line.

2 Select the Soft Hyphen command in the 4D Write Insert menu.
The word is hyphenated.

Inserting the 
Current Date and 
Time

4D Write allows you to insert the current date and time in a document. 
The date and time can either be dynamically updated or can keep the 
value they had at the time of the insertion.

¨̈̈̈ To insert the current date or the current time or both:

1 Click where you want to insert the date and time.

2 Select Date and Time from the Insert menu.
The Insert Date dialog appears:

3 Select the date from the left scrollable list.
The date will appear in the preview area according to the format you 
entered.
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4 Select the time from the right scrollable list.
The time will appear in the preview area according to the format you 
entered.

5 Select the Automatic update check box, if you want to be able to 
update the date and time values in the document at a later time.

6 Click the OK button.
The date or time (or both) you selected are then inserted in the 4D 
Write document.

Updating the Date and 
Time

Provided you selected the Automatic update check box when you 
inserted the date and time value, 4D Write can update them with the 
new current time and date values. 4D Write updates those values 
when:

■ the document is opened again

■ you select the Compute references now menu commands from the 
Tools menu

Inserting the page 
number

4D Write allows you to insert the current page number as an automatic 
variable. Inserting the page number (for instance in footers) will 
display the page number of each page in the footers.

¨̈̈̈ To insert the page number:

1 Click where you want to insert the page number.

2 Select Page Number Insert menu.
The Insert Page Number dialog appears:

You can choose:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for roman numbering.
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3 Choose the page number format you want to use.

4 Click OK.
The page number is then inserted at the insertion point.

Inserting a Special 
Character

4D Write can assist you to insert any character in the current font. This 
is particularly useful with foreign-language characters or symbols for 
which you can’t to remember the correct keystrokes.

¨̈̈̈ To Insert a special character:

1 Choose Special character from the Insert menu.
The select special character dialog is then displayed:

2 Select the font in which the character is supposed to be displayed.
The characters available in that font are displayed.

3 Select the character you want to insert
OR
Enter its ASCII code in the text box.

4 Click OK.
The character is then inserted at the insertion point.

Finding Text
You can use 4D Write to locate occurrences of:

■ a particular character sequence, 

■ particular character formatting

■ particular paragraph formatting,

■ particular border formatting,

■ a paragraph or sequence of characters that uses a particular stylesheet,
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■ any combination of the conditions listed above.

To perform such a search, you will use the Find dialog, in which all the 
search criteria will be defined.

Principle In 4D Write, a character search is based on two types of criteria:

■ the actual sequence of characters,

■ the character, paragraph and border formats as well as the stylesheet 
that are applied to the sequence of characters.

If more than one format is specified, text will only be located that 
matches all of the formats specified. For example, specifying both the 
sequence of characters and the format parameters focuses the search 
on that sequence of characters with that specific formatting. Specifying 
only a format will focus the search on all the sequences of characters to 
which this format was applied. For more information about setting a 
character search, refer to  the section “Setting a Character Search,” on 
page 98

The Find dialog You can access the Find dialog by choosing Find from the Edit menu 
or by clicking on the icon in the Standard toolbar. 

The Find dialog includes one entry area, one display area, three check 
boxes and four format buttons. It also includes the standard Cancel 
and OK buttons that allow you to respectively cancel or trigger the 
search.
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The Entry area The Entry area is the area in which you will enter the actual sequence 
of characters you are looking for in your document. 4D Write records 
all the sequences of characters you have looked for since the opening 
of the current document. Clicking on the arrows  located next to 
the entry area displays a drop-down menu that includes all the 
sequences of characters you have been looking for in that document:

This feature allows you to select a sequence of characters you have 
already searched for, without having to re-enter it.

The format buttons The format buttons give you access to specific settings you may search 
for. These settings are dealt with in four separate categories, each of 
which corresponds to a button: Character, Paragraph, Borders and 
StyleSheets. This allows you to extend the search to a sequence of 
characters with a specific character format or to, for instance, search 
for any paragraph that uses a specific stylesheet.

¨̈̈̈ To set a character format for a search:

1 Click on the Character button .
The following dialog is then displayed:

This dialog is identical to the Character format dialog.
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2 Set the character format you want to search for by setting it as you 
would in the Character format dialog.
For more information about how to set a character format, refer to  the 
section “Changing Text Attributes at Once,” on page 138.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
character settings you just entered.

¨̈̈̈ To set a paragraph format for a search:

1 Click on the Paragraph button .
The following dialog is then displayed:

This dialog is identical to the Paragraph format dialog.

2 Set the paragraph format you want to search for by setting it as you 
would in the Paragraph format dialog.
For more information about how to set a paragraph format, refer to  
the section “Setting paragraph formats using the Paragraph dialog,” on 
page 130.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
paragraph settings you just entered.
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¨̈̈̈ To set a border format for a search:

1 Click on the Borders button .
The following dialog is then displayed:

This dialog is identical to the border format dialog.

2 Set the border format you want to search for by setting it as you 
would in the border format dialog.
For more information about how to set a border format, refer to  the 
section “Setting Borders for a Paragraph,” on page 150.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
border settings you just entered.

¨̈̈̈ To select a stylesheet for a search:

1 Click on the StyleSheets button .
The following dialog is then displayed:

This dialog displays the list of stylesheets available for the document.

2 Click on the stylesheet on which you want to perform a search.
96 4D Write Reference Manual



Finding Text
3 Click OK to confirm your settings.
The Find dialog is then displayed.

The preview area The preview area displays the format criteria, other than the sequence 
of characters, that you have defined in your search. The following is an 
example of what the display area would display if you had set the 
options to find any sequence of character that uses the Arial font with 
a size of 10 located in a paragraph with a left indent of 1 cm as well as 
a top border.

The Search Options There are three character options that can be set using the three check 
boxes of the Find dialog:

■ Full word
When this option is selected, 4D Write will look for the sequence of 
characters that was entered in the entry area, but will only select the 
occurrences where the sequence is a specific word. For example if the 
sequence of characters you are looking for is “part”, 4D write will select 
“part” as a whole word but would not select “part” in “partition”.

■ Case sensitive
When this option is checked, 4D Write will only stop on the sequence 
of characters whose case match the one entered in the entry area.

■ Wrap
When this option is selected the search will loop through the entire 
document. If this option is not selected, the search will go from the 
insertion point to the end of the document.
974D Write Reference Manual



Chapter 4  Entering and Editing Text
Setting a Character 
Search

¨̈̈̈ To define a character search:

1 Choose Find from the Edit menu.
OR
Click the Find icon .
4D Write displays the Find dialog box.

2 Type the text you want to locate in the Find text box.
In addition to entering text, you can paste Tab or Return characters in 
the Find area to search those characters.

3 Select all options you want.
To find the text only when it appears as a whole word, click the 
Full Word check box.

To find the text only when it occurs with the capitalization as you 
typed it in the Find: text box, click the Case Sensitive check box.

To perform the character search in the whole document, click the 
Wrap check box. For more information about the Wrap option, refer to 
 the section “The Search Options,” on page 97

You can add more specific search criteria by defining specific formats 
using the format buttons. For information about how to use those 
possibilities, refer to  the section “The format buttons,” on page 94.

4 Click the Find button.
4D Write closes the dialog box and locates and selects the first 
occurrence of text that matches the criteria you entered in the dialog 
box.
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5 To locate and select the next occurrence of the text, choose Find Next 
from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence of the sequence of characters or it reaches the end of the 
search.

Finding and Replacing Text and formats
4D Write allows you to locate and replace the following:

■ a particular character sequence, 

■ particular character formatting

■ particular paragraph formatting,

■ particular border formatting,

■ a paragraph or sequence of characters that uses a particular stylesheet,

■ any combination of the conditions listed above.

A “Find and Replace” operation can be of two types. You can locate 
and replace a sequence of characters and replace them with another 
sequence of characters. For more information about finding and 
replacing sequences of characters, refer to  the section “Finding and 
replacing sequences of characters,” on page 105. You can also locate 
and replace formats or stylesheets and replace them by other formats 
or stylesheets. For more information about finding and replacing 
formats, refer to  the section “Finding and Replacing Formats,” on 
page 106.
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The Replace Dialog The Replace dialog is the dialog in which you define both the Find 
criteria and the Replace criteria.

It consists of three main areas:

■ The “Replace” area which is identical to the Find area in the Find 
dialog

This area is the area in which the sequence of characters or format you 
want to replace are defined. If you have already searched for a 
sequence of characters or a format in the current document, the 
replace area reflects the last search you have performed.
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■ The “With” area

This area is the area in which you define the sequence of character or 
format that is intended to replace the sequence of character or format 
4D Write searches for.

■ The dialog buttons

These buttons allow you to command the Replace actions or to close 
the Replace dialog.

The Replace area This area is identical to the Find area in the Find Dialog. For more 
information about the Find dialog, refer to the section “The Find 
dialog,” on page 93.

The With area This area is the area in which you define the sequence of characters 
that will replace the sequence you are searching for. In the case of a 
format replacement, it also is the area in which the new format to 
apply will be defined.

■ The Entry area
The Entry area is the area in which you will enter the actual sequence 
of characters that will replace the sequence you are searching for. 4D 
Write records all the sequences of characters you have used in the 
Replace dialog since the opening of the current document. Clicking on 
the arrows  located next to the entry area displays a drop-down 
menu that includes all the sequences of characters you have used as 
replacement sequences:

This feature allows you to select a sequence of characters you used 
searched for, without having to re-enter it.
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■ The format buttons
The format buttons give you access to specific settings you may want 
to set. These settings are dealt with in four separate categories, each of 
which corresponds to a button: Character, Paragraph, Borders and 
StyleSheets. This allows you to define replacement formats that will 
either be applied to the replacement sequence or to the sequence 
selected by the search. 

¨̈̈̈ To set a replacement character format:

1 Click on the Character button .
The following dialog is then displayed:

This dialog is identical to the Character format dialog.

2 Set the character format you want to apply by setting it as you would 
in the Character format dialog.
For more information about how to set a character format, refer to  the 
section “Changing Text Attributes at Once,” on page 138.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
character settings you just entered.
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¨̈̈̈ To set a paragraph format to apply:

1 Click on the Paragraph button .
The following dialog is then displayed:

This dialog is identical to the Paragraph format dialog.

2 Set the paragraph format you want to apply by setting it as you would 
in the Paragraph format dialog.
For more information about how to set a paragraph format, refer to  
the section “Setting paragraph formats using the Paragraph dialog,” on 
page 130.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
paragraph settings you just entered.
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¨̈̈̈ To set a border format to apply:

1 Click on the Borders button .
The following dialog is then displayed:

This dialog is identical to the border format dialog.

2 Set the border format you want to apply by setting it as you would in 
the border format dialog.
For more information about how to set a border format, refer to  the 
section “Setting Borders for a Paragraph,” on page 150.

3 Click OK to confirm your settings.
The Find dialog is then displayed and the preview area displays the 
border settings you just entered.

¨̈̈̈ To select a stylesheet for a search:

1 Click on the StyleSheets button .
The following dialog is then displayed:

This dialog displays the list of stylesheets available for the document.

2 Click on the stylesheet you want to apply.

3 Click OK to confirm your settings.
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The Find dialog is then displayed.

■ The preview area

The preview area displays the format criteria as you defined them using 
the format buttons.

Finding and 
replacing sequences 
of characters

¨̈̈̈ To locate and replace a sequence of characters:

1 Choose Replace from the Edit menu.
4D Write displays the Replace dialog box.

2 Type the text you want to locate in the Replace text box.

3 Select all options you want, in the Replace area.
To find the text only when it appears as a whole word, click the 
Full Word check box.

To find the text only when it occurs with the capitalization as you 
typed it in the Find: text box, click the Case Sensitive check box.

To perform the character search the text throughout the whole 
document, click the Wrap check box. For more information about the 
Wrap option, refer to  the section “The Search Options,” on page 97

You can add more specific search criteria by defining specific formats 
using the format buttons. For information about how to use those 
possibilities, refer to the  the section “The format buttons,” on page 94.
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4 Type the replacement text in the With text box.
In addition to entering text, you can paste Tab or Return characters in 
the With area to use them as replacement characters.

5 Select all options you want, in the Replace area.

You can add some specific formats to the replacement sequence. For 
information about how to use those possibilities, refer to the section 
“The format buttons,” on page 94.

6 Click the Replace button
OR
Click the Replace all button
If you click on the Replace button, 4D Write closes the dialog box, 
locates and replaces the first occurrence of text that matches the 
criteria you entered in the dialog box.

If you click on the Replace all button, 4D Write closes the dialog box, 
locates and replaces all the occurrences of text that matches the criteria 
you entered in the dialog box.

7 To locate and replace the next occurrence of the text, choose 
Replace Next from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence of the sequence of characters and replaces it or until it 
reaches the end of the search.

Note Selecting Check Boxes in the Borders, Characters and Paragraph 
dialogs:
You may need to click a check box twice to select it. When you first 
enter the expanded Find dialog box, the check boxes are greyed to 
indicate that the style attributes are not part of the search or replace 
criteria. When you click a greyed check box, with the exception of the 
Plain check box, it is deselected and becomes empty. When you click it 
again, the check box is selected.

Finding and 
Replacing Formats

¨̈̈̈ To locate and replace a format:

1 Choose Replace from the Edit menu.
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4D Write displays the Replace dialog box.

2 DO NOT type any text in the Replace text box and make sure this text 
box is empty.

3 Define the format or combination of formats you want to replace, 
using the four format buttons. 
For information about how to use the format dialogs, refer to  the 
section “The format buttons,” on page 94.

4 Define the replacement formats, using the four format buttons of the 
With area. 
For information about how to use the format dialogs, refer to  the 
section “The format buttons,” on page 94.

5 DO NOT type any text in the With text box and make sure this text 
box is empty.

6 Click the Replace button
OR
Click the Replace all button
If you click on the Replace button, 4D Write closes the dialog box, 
locates and replaces the first occurrence of characters whose formats 
match the formats you entered in the dialog box and replaces them by 
the replacement formats.

If you click on the Replace All button, 4D Write closes the dialog box, 
locates and replaces every occurrence of characters whose formats 
match the formats you entered in the dialog box and replaces them by 
the replacement formats.
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7 To locate and replace the next occurrence of formats, choose 
Replace Next from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence and replaces it or until it reaches the end of the search.

Creating Headers and Footers
Initially, a document consists of only the main body of text. In 
4D Write, the main body of text is called the document portion of the 
text. A document first opens in the View Document mode. In this 
mode, you can modify anything in the main body of text.

Later, you may want to add headers and footers to your document. The 
header of a document contains material that appears at the top of each 
page, such as the name of the document or your company logo. The 
footer contains material that appears at the bottom of each page, such 
as the chapter name and/or the page number. 

You can display headers and footers only if your document is in the 
Page View mode. 4D Write also allows you to differentiate headers and 
footers depending on which page type they are (first page, left page or 
right page). For more information on this feature, refer to  the section 
“Setting Preferences,” on page 72.

¨̈̈̈ To create a header or footer:

1 Choose Page from the View menu.
4D Write displays both header and footer areas.

2 Enter the text you want in the header or footer. 
In addition to entering text, you can add pictures, references to data or 
the current date or page number. A current date reference 
automatically displays the current date. For more information about 
how to insert the current date or the current page number, refer 
respectively to  the section “Inserting the Current Date and Time,” on 
page 90 or to  the section “Inserting the page number,” on page 91. For 
information on referencing data, refer to Chapter 5.

3 To return to the main document, click in the main edition area.
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Resizing Headers 
and Footers

¨̈̈̈ To resize a header or footer area:

1 Choose Page from the View menu.
4D Write displays both header and footer areas and the vertical ruler is 
displayed.

2 Click in the Header or Footer area.
The vertical limits of the area are displayed on the vertical ruler.

3 Place the mouse cursor over the upper or lower limit of the area.
The cursor becomes a double-sided arrow.

4 Drag the upper or lower limit of the area to its new location.

The footer or header area is then modified accordingly.

Modifying Headers 
and Footers

In the Normal view mode, you can modify only the main body of text. 
To modify the header or footer, you must first make sure that you are 
in the Page mode. You can then modify the definition of the header 
and footer by click in their respective area.

Note You must be in the Page View mode to modify a document’s header or 
footer.
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Working with Pictures
4D Write allows you to paste pictures into the header, footer, or main 
body of your document. You can use any picture that you can copy to 
the Clipboard. 

After you paste a picture into a document, you can manipulate it in the 
following ways:

■ Move

■ Scale

■ Resize

■ Hide

The principle is to paste the picture in your 4D Write document. 4D 
Write allows you to choose between pasting the picture in the text 
flow and pasting it as a background picture. Pasting the picture into 
the text flow will manage the picture as a character of the paragraph in 
which it is pasted. Pasting the picture as a background picture will 
affect it a fixed position in the page and will allow you to manage it in 
a separate layer as the text.

Picture Formats 4D Write handles the following picture formats:

■ PICT

■ Bitmap

■ EMF (Windows only)
110 4D Write Reference Manual



Working with Pictures
The Paste Picture 
Dialog

The Paste picture dialog is the dialog that appears each time you paste 
a picture in 4D Write while Page mode is selected:

A radio button allows you to select one of two different modes:

■ Paste picture in text flow
Choosing this option will insert the picture in the text flow at the 
insertion point. 

■ Paste picture in page
Choosing that mode will paste the picture as a background graphics. It 
also gives you access to the following options and settings.

■ In current page
Choosing this option pastes the picture only in the current page.

■ In all pages
Choosing this option pastes the picture in each page of the docu-
ment.

■ In right pages
Choosing this option pastes the picture only in each right page of 
the document.

■ In left pages
Choosing this option pastes the picture only in each left page of the 
document.

■ Not in first page
Choosing this option prevents the picture from appearing in the 
first page.
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■ Behind text
Choosing this option will place the picture behind the text.

The options In right pages, In left pages and Not in first page may be 
disabled depending on your preferences settings. For more information 
about setting preferences, refer to the  the section “Setting 
Preferences,” on page 72.

Pasting a Picture 
in the Text Flow

When you paste picture in the text flow, it is managed as a character in 
a paragraph.

¨̈̈̈ To place a picture in the text flow:

1 Copy the picture to the Clipboard.

2 In your 4D Write document, click where you want to insert the picture.

3 Choose Paste from the Edit menu.
If the Page mode is selected 4D Write displays the Paste picture dialog. 
If the Normal mode is selected, the picture is directly pasted in the text 
flow.

4 When in the Page view mode, select Paste picture in text flow.

5 Click OK.
The picture is then pasted in the text flow.

Pasting a Picture 
in the Page

When you paste picture in the page, it keeps its position and appears 
in a different layer to the text.

¨̈̈̈ To paste a picture in a page:

1 Copy the picture to the Clipboard.

2 Choose Page from the View menu.

3 Choose Paste from the Edit menu.
4D Write displays the Paste picture dialog. 

4 Select Paste picture in page.

5 Select the paste options.
For more information about those options, refer to  the section “The 
Paste Picture Dialog,” on page 111.

6 Click OK.
The picture is then pasted in the page and it is displayed according to 
your settings.
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Selecting a Picture You select a picture to change its size or to copy, move, or delete it. 

¨̈̈̈ To select a picture:

1 Position the pointer over the picture.
When over the picture, the pointer changes to a plus sign .

2 Click the picture.
A box with handles appears around the picture to indicate that it is 
selected.

Scaling a Picture Scaling changes the size of a picture by increasing or decreasing its 
height and width by the same percentage, retaining the picture’s 
proportions.

¨̈̈̈ To scale a picture:

1 Select the picture you want to scale.

2 Double-click on the picture.
The Picture Properties dialog box appears.

3 Check the Relative check box.

4 Check the Keep proportions box.

5 Type a percentage in either the Width or Height box.

6 Click the OK button.

4D Write scales the picture to the size you specified.
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Resizing a Picture You resize a picture by selecting the picture and dragging one of its 
handles.

¨̈̈̈ To adjust the width of a picture using the handles:

■ Drag the handle at the center of the right side.

¨̈̈̈ To adjust the width of a picture using the Picture Properties dialog:

1 Select the picture you want to scale.

2 Double-click on the picture.
The Picture Properties dialog box appears.

3 Make sure the Relative check box is deselected.

4 Check the Keep proportions box if you want the height to be modified 
according to the picture’s current proportions.

5 Type a value in the Width box.

6 Click the OK button.
4D Write modifies the picture.

¨̈̈̈ To adjust the height of a picture using the handles:

■ Drag the handle at the center of the bottom edge.

¨̈̈̈ To adjust the height of a picture using the Picture Properties dialog:

1 Select the picture you want to scale.

2 Double-click on the picture.
The Picture Properties dialog box appears.

3 Make sure the Relative check box is deselected.

4 Check the Keep proportions box if you want the width to be modified 
according to the picture’s current proportions.

5 Type a value in the Height box.

6 Click the OK button.
4D Write modifies the picture.

¨̈̈̈ To adjust the height and width of a picture:

■ Drag the handle at the lower right corner.

Note Dragging may change the picture’s proportions.
114 4D Write Reference Manual



Working with Pictures
¨̈̈̈ To return a picture to its original size:

■ Click the handle at the upper right corner.

Moving a Picture When you paste a picture in the background of the page, it appears in 
the upper left corner of the page. You can move the picture to any 
location you wish on the page.

When moving a picture located in the text flow of the document, you 
can only set its horizontal position since it is managed as a character. 
To set its horizontal position, you need to set and enter a tab stop 
before it. For more information about setting tab stops, refer to  the 
section “Setting Tabs,” on page 124.

¨̈̈̈ To move a background picture:

■ Drag the picture to the location you want.
An outline of the picture moves as you drag, showing the picture’s 
current location.

Hiding and Showing 
Pictures

Hiding all of the pictures in a document lets you scroll more rapidly. 
4D Write is preset to show pictures. 

¨̈̈̈ To hide all pictures:

■ Choose Pictures from the 4D Write View menu.
4D Write replaces each picture with a box that has the same 
dimensions. When pictures are hidden, the check mark is removed 
from the Pictures command menu. 

¨̈̈̈ To show all pictures:

■ Choose Pictures from the 4D Write View menu.

Removing a Picture You can remove a picture from your document by deleting it, cutting 
it, or replacing it with text.

¨̈̈̈ To permanently delete the picture:

1 Select the picture by clicking it.

2 Choose Clear from the 4D Write Edit menu or press the Delete key.

¨̈̈̈ To remove the picture and copy it to the Clipboard:

1 Select the picture by clicking it.
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2 Choose Cut from the 4D Write Edit menu.

¨̈̈̈ To replace the picture with text:

1 Select the picture by clicking it.

2 Type the text.

Note You can replace a picture by text only when it was inserted in the text 
flow.

Using a Spelling Checker
To use a spelling checker, you should have already selected a spelling 
checker and a dictionary in the 4D Write Preferences dialog. For more 
information, refer to  the section “Setting Preferences,” on page 72.

¨̈̈̈ To automatically check the spelling in your document:

1 Place the insertion point in the document for which you want to 
perform the check.
OR
If you want to check part of the document, select that part of the 
document.

2 Choose Spelling from the 4D Write Tools menu.
If a spelling checker is correctly set in the Preferences, the check 
begins. Otherwise, 4D Write displays a selection for you to select a spell 
checker. For more information, refer to  the section “Setting 
Preferences,” on page 72.

If the spell checker encounters a mistake, the following dialog is 
displayed:

Possible mistake

Action buttons

Suggested correction

Other suggestions
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The following options are available:

■ Ignore: the possible mistake will not be corrected and the checking 
resumes.

■ Ignore all: any occurrence of the current possible mistake will be 
ignored and the checking resumes.

■ Change: the selected possible mistake is replaced by the suggested 
correction displayed in the Change to area, and the checking resumes.

■ Change all: the selected possible mistake and all its other occurrences 
are replaced by the suggested correction displayed in the Change to 
area, and the checking resumes.

■ Add: the possible mistake is left untouched and is added to the current 
user dictionary, then the checking resumes.

If the correction displayed in the Change to area does not suit your 
needs, you can either select another one from the Suggestions area by 
clicking it or manually enter a new correction in the Change to area.

Choosing the Language Selecting a language for the document allows you to make sure the 
current dictionary is compatible with the current language. 

¨̈̈̈ To select a language: 

1 Choose language from the Tools menu.
The Language dialog is then displayed:

2 Select a language from the list.

3 Click OK.
The new language is set.
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Viewing Document Statistics
You can display the number of lines, characters, words, paragraphs, 
pictures, database objects and pages in your document, as well as the 
size of your document and the number of database objects it includes.

¨̈̈̈ To view these statistics:

1 Choose Statistics from the 4D Write File menu.
4D Write displays a Document Statistics message box with information 
about the document.

2 Click the Close button to close the message box and return to your 
document.
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4D Write enables you to customize the appearance of documents. You 
can perform basic formatting changes to paragraphs by setting 
paragraph margins, first line indent, alignment, line spacing, and tabs. 
You can also modify selected text to display and print in a different 
font, font size, style, or color. For example, you can select the title of a 
book and make it italic. 

You can use custom style sheets to apply several text attributes at once. 
For example, if you want document headings to appear in 14 point 
text and in the Avant Garde font, you can define a Heading style sheet 
with these attributes. Once a style sheet is defined, you can apply it to 
text anywhere in your document.

In this chapter, you will learn how to:

■ Set the margins, first line indent, borders and tabs for a paragraph

■ Set text alignment and line spacing

■ Change the font, font size, style, and color attributes of text

■ Manage character and paragraph style sheets

■ Manage separately colors for the text and its style

■ Insert page breaks

■ Insert arrays

■ Manage columns

■ Insert column breaks
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Formatting Paragraphs

The Ruler The 4D Write ruler appears just below the toolbars. You can use the 
ruler to set margins, vertical separators and tab stops.

The ruler shows the settings for the paragraph in which you are 
working. The Left and Right Margin markers show the margin settings. 
The tab stop markers and the First Line Indent marker indicate where 
the tabs and first line indent are located.

After you press Return (on the Macintosh) or Enter (in Windows), 
4D Write creates a new paragraph with the same ruler settings as the 
previous one. This lets you continue the document with the same 
formatting from one paragraph to the next. You can use the ruler to 
change some of the settings for the paragraph in which you are typing. 
When you select one or more paragraphs, you can change the settings 
for all of them at once. The ruler lets you change the position of: 

■ left and right margins;

■ tab stops; and

■ the first line indent.

Displaying and Hiding 
the Ruler

You can hide the ruler when you do not need it by choosing Ruler 
from the 4D Write View menu. To show the ruler again, choose Ruler 
from the 4D Write Format menu. When the ruler is displayed, a 
checkmark is displayed next to the Ruler menu command.

Selecting 
Paragraphs

¨̈̈̈ To select a single paragraph:

■ Click anywhere in the paragraph.

¨̈̈̈ To select several paragraphs:

■ Drag through the paragraphs to select them.

First Line Indent 
marker

Left Margin marker

Tab Stop 
marker

Right 
Margin marker
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¨̈̈̈ To select every paragraph in the body of the document:

■ Choose Select All from the 4D Write Edit menu.

Setting the Margins 
and First Line indent

Using the ruler, you can position the left and right margin for the 
currently selected paragraphs.

On the ruler, grey triangles  mark the left and right margins. 
The First Line Indent marker  indicates where the first line of the 
paragraph begins. 

When you open a new document, the margins are preset based on the 
width of a standard 8.5 inch page. The left and right margins are 
located 2.5 cm away from the paper borders. Using the ruler you can 
change those values as long as they remain smaller than the values set 
for the document margins. When moving the left paragraph margin, 
the first line indent is moved accordingly. You can change the location 
of the left margin, the right margin, and the first line indent by 
dragging their markers to the left or right. All three markers move 
independently and you can position the left and right margins to 
within an inch apart.

¨̈̈̈ To set the left or right margin using the ruler:

■ Drag the Left  or Right  Margin marker to the desired position.
4D Write displays dotted lines down the page as guides to help you 
align margins.

Note When dragging the markers, they snap to a grid set to 0.25 cm (or 1/8 
of an inch or 10 pixels). To temporarily deactivate the grid, hold down 
the Command key (on Mac OS or the Ctrl key (on Windows) while 
dragging the marker.

¨̈̈̈ To set the left or right document margin using the ruler:

1 Select the Page mode by choosing Page from the view menu.

2 Drag the Left  or Right  Margin marker to the desired 
position.

First Line Indent 
marker

Left Margin marker

Tab Stop 
marker

Right 
Margin marker
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4D Write displays margin guides to help you align margins. Left and 
Right margin guides appear as dotted lines when you drag the margin 
markers.

To set the first line indent:

■ Drag the First Line Indent marker .

Aligning Text 4D Write lets you align text with the left or right margin, center text 
between the margins, or fully justify text so it is aligned with both 
margins like text in newspaper columns. 

You can set text alignment using the text alignment icons on the 
Format toolbar or the menu items in the Paragraph menu. 

¨̈̈̈ To align text with the left margin using the ruler:

■ Click the Left Alignment icon  or choose Align left from the 
Paragraph menu.

Centered text

Left aligned text

Right aligned text

Format

Text alignment buttons
toolbar
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¨̈̈̈ To align text with the right margin using the ruler:

■ Click the Right Alignment icon  or choose Align right from the 
Paragraph menu.

¨̈̈̈ To center text between the left and right margins using the ruler:

■ Click the Center Alignment icon  or choose Align center from the 
Paragraph menu.

¨̈̈̈ To align text to both the left and right margins using the ruler:

■ Click the Left and Right Alignment icon  or choose Full justification 
from the Paragraph menu.

Setting Line Spacing 4D Write lets you determine the spacing between lines in a paragraph. 
The following figure shows a paragraph with double-spacing and 
another paragraph with single-spacing.

To change line spacing, you can use either the Format toolbar or the 
4D Write Paragraph menu. Both offer single, one-and-one half, and 
double-spacing.

Double-spacing

Single-spacing

Single-spacing
One-and-a-half spacing
Double spacing
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You can also use the Paragraph menu to set the line spacing to a 
different value.

¨̈̈̈ To choose single-spacing:

■ Click the  icon or choose Single spaced from the Format menu.

¨̈̈̈ To choose one-and-one-half-spacing:

■ Click the  icon or choose 1.5 line spaced from the Format menu.

¨̈̈̈ To choose double-spacing:

■ Click the  icon or choose Double Spaced from the Format menu.

¨̈̈̈ To set a custom value for the line spacing:

1 Select Other from the Paragraph menu.
The line spacing dialog is then displayed:

2 Enter the number of lines that you want to set the new line spacing to.

3 Click OK.

Setting Tabs By default, documents are preset with tab stops every centimeter across 
the page. You can use these tab stops even though they do not appear 
on the ruler. Just press Tab to move the insertion point to the next tab 
stop. You can also set other tab stops anywhere along the ruler. The 
default spacing between tabs can be set in the Preferences dialog. For 
more information about this point, refer to “Setting Preferences”, on 
page 72.

Note When you set a tab stop, any preset tab stops to the left of it are 
removed.
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¨̈̈̈ To set a tab stop using the ruler:

1 Click on the drop-down menu located on the left of the ruler.

This menu allows you to select the type of tab stop that you want to 
insert.

2 Select the type of tab stop.

3 Click in the ruler to insert the tab stop.
The tab stop is inserted where you click. You can modify its location by 
dragging it in the ruler.

¨̈̈̈ To move a tab marker:

■ Drag it to the right or left.

¨̈̈̈ To delete a tab marker:

■ Drag it anywhere below the ruler.

Creating Tabs using the 
Tabs dialog

When you want to set one or more tabs at the same time for a 
paragraph, it is more convenient to use the Tabs dialog. Using that 
dialog you can define the type of a tab stop, its position and the fill 
character you want to use.

4D Write uses different tab markers to indicate tab alignment. 

Note The vertical separator operates like a left-aligned tab but it also displays 
a vertical separator at its location. It is mainly used in tables.

Tab Marker Alignment

Left-aligned
Decimal 
Center-aligned
Right-aligned
Vertical separator
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The following table illustrates the use of tabs and fill characters.

¨̈̈̈ To create a tab setting, follow these steps:

1 Choose Tabs from the Format menu
The Tab Options dialog box appears.

The tab markers defined for the current paragraph are listed in the Tabs 
area. The types of tab markers are listed on the left, in the Alignment 
area. The types of fill characters for leaders are listed on the right.

2 Click on the Add button to create a tab stop.
The Add button creates a new entry in the Tabs area.

Dashes used as 
fill characters

Left-aligned

Decimal

Center-
aligned

Right-aligned
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3 Enter the new position value in the position area.

4 Click the Set button.
The new position value for the tab is then updated in the Tabs area.

5 Click the Alignment radio button for the type of tab you want.

6 Click the Leader radio button for the fill character you want. 
4D Write lets you select dots, dashes or a solid line. You can also enter 
any character by clicking the Other radio button and by entering the 
fill character you want. 

7 Click OK.
To close the dialog box without putting the changes you made into 
effect, click the Cancel button.

¨̈̈̈ To delete a tab setting, follow these steps:

1 Choose Tabs from the Format menu
The Tab Options dialog box appears.

2 In the scrollable area, select the tab you want to delete.

3 Click the Delete button.
The tab stop is removed from the scrollable area.

4 Click the OK button.
The setting for this Tab is removed from the current paragraph.
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Changing Tab 
Alignment and Fill 
Character

¨̈̈̈ To change the type, alignment or fill character of a tab, follow these 
steps:

1 On the ruler, double-click the tab marker
OR
Choose Tabs from the Format menu
The Tabs dialog box appears.

The tab markers defined for the current paragraph are listed in the Tabs 
area. The types of tab markers are listed on the left, in the Alignment 
area. The types of fill characters for leaders are listed on the right.

2 Click on the tab stop you want to modify.

3 Enter the new position value in the position area.

4 Click the Set button.
The new position value for the tab is then updated in the Tabs area.

5 Click the Alignment radio button for the type of tab you want.

6 Click the Leading radio button for the fill character you want. 
4D Write lets you select dots, dashes or a solid line. You can also enter 
any character by clicking the Other radio button and by entering the 
fill character you want. 

7 Click OK.
To close the dialog box without putting the changes you made into 
effect, click the Cancel button.
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Setting bullets 4D Write allows you to set a bullet type for the paragraph currently 
selected. You can choose between six standard bullets (black square, 
white square, black circle, white circle, diamonds and clubs), or set 
your own character as a bullet.

¨̈̈̈ To select a standard bullet:

1 Choose Bullet from the paragraph menu.
A hierarchical menu is then displayed.

2 Select the standard bullet you want to display.

¨̈̈̈ To select a customized bullet:

1 Choose Bullet from the paragraph menu.
A hierarchical menu is then displayed.

2 Select Other.
The character selection dialog is then displayed:

3 Select the character you want to use as a bullet
OR
Enter its ASCII code in the text box.
1294D Write Reference Manual



Chapter 5  Formatting Text
4 Click OK.
The bullet is then displayed at the beginning of the paragraph and will 
remain as a paragraph setting.

Setting paragraph 
formats using the 
Paragraph dialog

Using the Paragraph dialog you can define various formats for a 
paragraph:

■ The left and right margins;

■ The first line indent;

■ The bullet character;

■ The line spacing; and

■ The alignment.

The Paragraph dialog is displayed by selecting Paragraph from the 
Format menu.

The Paragraph dialog is divided into three main areas.

■ The indent area
This area is the area in which you can set the values for the margins 
and the first line indent.
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■ The Format area
This area is the area in which you can set the alignment, the bullets 
and the line spacing.

■ The preview area
This area is the area in which is displayed the preview of the current 
properties you selected. Each time you modify the settings of the 
dialog, the preview is updated.

The Paragraph dialog also includes five buttons:

■ The Cancel button closes the paragraph dialog and cancels any 
modification that was done since it was last opened.

■ The OK button applies the selected formatting to all paragraphs in the 
current selection.

■ The Default button sets all the paragraph format back to the default 
values set for the current style sheet (if any).

■ The None button removes any format applied to the paragraph.

■ The Revert button reverts the format options to their initial values.

¨̈̈̈ To set the margins in the Paragraph dialog:

1 Check the indent check box.
This activates the spaces for entering values for the indents.

2 Enter the values to which you want to set the margins.
Left corresponds to the left margin, Right corresponds to the right 
margin and First line corresponds the first line indent.

¨̈̈̈ To set the alignment:

1 Check the Alignment check box.
When the check box is checked, it activates the drop-down menu.
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2 Select the alignment setting you want to use from the Alignment 
drop-down menu.

¨̈̈̈ To select a bullet:

1 Check the Bullet check box.
When the check box is checked, it activates the Bullet drop-down 
menu.

2 Select the bullet setting you want to use from the Bullet drop-down 
menu.
If you choose the Other item, the custom bullet selection dialog is 
then displayed. For more information about how to use this dialog, 
refer to “Setting bullets”, on page 129.

¨̈̈̈ To set the line spacing:

1 Check the Line spacing check box.
When the check box is checked, it activates the entry area.

2 Enter the line spacing value you want to use.
This number must be expressed in number of lines.

Setting colors
4D Write allows you to separately assign colors to the text and to its 
style attributes. You can, for instance, set a different color for a piece of 
text and for the line that underlines it. Different colors can be set for 
the following:

■ the text characters;

■ the background of the text;

■ the strikethrough line;

■ the underline line;

■ the shadow effect;

■ the border background; and

■ the border line.
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Setting a color 
for a character

¨̈̈̈ To set a color for the current selection of characters:

1 Select Text in the Colors menu.
A hierarchical menu is then displayed.

2 Select the color you want to apply to the selection.
Once you have selected the color, it is applied to the characters of the 
current selection. If you choose to define a custom color, select Other. 
For more information about how to define a custom color, refer to 
“Setting a Custom Color in Windows”, on page 134 or to “Changing 
Text Attributes at Once”, on page 138, depending on the platform you 
are currently using. 

Setting a color for 
style effect

To set a color for a style effect applied to the current selection of 
characters:

1 Select the style effect in the Colors menu.
The corresponding hierarchical menu is then displayed.

Notes • For the Strikethrough and Underline menu commands, an 
“Automatic” item is displayed at the top of the hierarchical menu. 

Back Strikethrough Underline Shadow Borders Back Borders LIne
1334D Write Reference Manual



Chapter 5  Formatting Text
Selecting this Item will assign the color that is currently selected for 
the text.

• For the Back and Borders Back menu commands, a “None” 
command is displayed at the top of the hierarchical menu. Selecting 
this Item will assign no color to the corresponding style effect, making 
the background transparent.

2 Select the color you want to apply to the selection.
Once you have selected the color, it is applied to the style effect for the 
current selection. If you choose to define a custom color, select Other. 
For more information about how to define a custom color, refer to 
“Setting a Custom Color in Windows”, on page 134 or to “Setting a 
Custom Color on the Macintosh”, on page 134, depending on the 
platform you are currently using. 

Setting a Custom Color 
on the Macintosh

After you choose Other... from the Colors submenu, the Apple Color 
Picker dialog box appears, enabling you to create a custom color. For 
more information about how to use the system colorpickers, please 
refer to the documentation that came with your system.

Setting a Custom Color 
in Windows

After you choose Other... from the Colors submenu, the expanded 
Color dialog box appears, enabling you to create a custom color. You 
can add the colors you create here to the Custom Colors palette. For 
more information about how to use the Color dialog box, please refer 
to the documentation that came with your system.
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Showing Invisible 
Formatting 
Characters

You can display the characters that show where the Tab, Return (or 
Enter) and space characters are located. Ordinarily, these characters are 
invisible. 

¨̈̈̈ To show invisible formatting characters:

■ Choose Invisibles Characters from the 4D Write View menu.
The invisible characters appear. 

The following table describes each formatting character.

Copying Paragraph 
Formatting

You can copy paragraph settings and apply them to other paragraphs 
to ensure that all paragraphs to which you apply the settings have 
exactly the same formatting. Copying paragraph settings also lets you 
quickly change an element of a document. For example, after you 
change the formatting of a heading, you can easily apply the new 
formatting to headings throughout the document.

 Character Description

Indicates a tab.
Indicates a hard carriage return.
Indicates a space.
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The following paragraph format settings are copied. These settings are 
shown in the 4D Write formatting Ruler.

■ Margins and first line indent

■ Alignment

■ Line spacing

■ Tabs

¨̈̈̈ To copy paragraph formatting:

1 Click in the paragraph whose formatting you want to copy.

2 Choose Copy Ruler from the 4D Write Paragraph menu.
4D Write stores the paragraph settings separately from the normal 
clipboard. The contents of the Clipboard are not affected.

3 Click in the paragraph to which you want to apply the copied settings.
You can apply the paragraph settings to more than one paragraph by 
selecting them before the next step.

4 Choose Paste Ruler from the 4D Write Format menu.
The formatting you copied is applied to the selected paragraphs.

Changing Text Attributes
The font, type size, style, and color used for text are text attributes. 
When you create a new document, 4D Write automatically sets the 
font to Arial on Windows or New York on Mac OS, the size to 12 point, 
the style to plain, and the color to black. Any text that you type will 
have those attributes.

If you change any text attributes, 4D Write applies the new settings to 
text as you type. You can apply different attributes to text you have 
already typed by selecting the text and then changing the attributes. 
You can view the attributes of any text by clicking within the text and 
choosing Characters from the Format menu or using the Style Toolbar. 
Check marks appear in the menus next to the text attributes that are in 
effect.
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Changing the Font All fonts installed in your system appear in the font drop-down list of 
the Style toolbar menu and are available for use in your documents.

¨̈̈̈ To change the font:

1 Select the text you want to change or click where you want to type 
text using a new font.

2 Choose the font from the font drop-down list of the Style toolbar.

If you had selected text before this step, the font of the selection 
changes to the one chosen. If you type new text, it will appear in the 
chosen font.

Changing Text Size Text size is measured in points. A point is roughly equal to 1/72 inch. 
The font size drop-down list shows sizes ranging from 8 to 72 points.

¨̈̈̈ To change the text size:

1 Select the text you want to resize or click where you want to type 
using a different text size.

2 Choose the size from the font size drop-down menu.

When you choose a size, it is applied to your selection. 4D Write 
adjusts the line spacing, if necessary, to accommodate the new size.
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Note You can directly enter a value into the value box if you want to assign a 
size that is not available in the list.

Changing Text Style Styles can help you emphasize text or enhance a document’s 
appearance.

¨̈̈̈ To change the style of text:

1 Select the text you want in a different style or click where you want to 
type using a new style.

2 Choose a style from the 4D Write Style menu.
Styles include Plain, Bold, Italic, Underline, Strikethrough, Shadow, 
Superscript, and Subscript. You can apply more than one style to 
selected text. If you want to modify the case of the selection you can 
also select Capitals or Small capitals.

After you choose a style, your selection changes to the new style and a 
check mark appears next to the style in the Style menu. If a style is in 
effect for only part of your selection, a dash is displayed to the left of 
the style name.

Note If you want to select the Bold, Italic or Underline style you can 
respectively use the icons , located in the Style Toolbar.

Changing Text 
Attributes at Once

You can easily change several text attributes at once. Using the 
Character dialog box, you can change the font, size, color, and style of 
text. You can also set the color for the style effects. These attributes are 
applied to the currently selected text or, if no text is selected, to the 
text that you type.

If you want to use the same combination of attributes many times, you 
can create a custom style sheet. A style sheet specifies a collection of 
attributes. You apply a style sheet to text by selecting the text and 
choosing the style sheet name from the Style Sheet drop-down list in 
the Style toolbar.
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Using the Character 
Dialog Box

¨̈̈̈ To change several text attributes in the Character dialog box:

1 Select Character from the 4D Write Format menu.
The Character dialog box appears.

The dialog box shows the font, font size, color, and styles currently in 
effect and provides sample text with those attributes.

2 To change the font, choose the font from the Font scrollable list
OR
Enter its name in the font box.

3 To change the color for either the text or the style effects selected, 
choose the color from the Color picture menus.
You can choose any of the basic colors available in the picture menu or 
create a custom color by selecting Other.... For information on creating 
a custom color, refer to the “Setting a Custom Color” sections in this 
chapter.

4 To change the text size, enter the size in the Size box or select a size in 
the Size list.

Current font and font size

Style attributes

Font list

Underline status

Style effects color

Preview area
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5 Select the check boxes for the style attributes you want.
Styles include Plain, Bold, Italic, Strikethrough, Shadow, Superscript, 
and Subscript. You can also select the character case using the Capitals 
and Small Capitals radio button. 

Clicking once on a check box will select it. Clicking twice will “gray” it, 
which means that this attribute will be left unchanged in your 
selection. If, for instance, the Bold attribute is set only for some 
character in your selection, the Bold check box will appear in grey. 
Leaving that check box in gray will leave the Bold attribute untouched.

6 Select the underline attribute you want in the Underline drop-down 
list.
You can choose Single underline to display only one line under the 
selection, Word underline to underline only words, Double underline 
to display two lines under the selection or Hatched underline to 
display a doted underline.

7 To accept the attributes you set, click OK.
To return to the original text attributes and start over, click the Revert 
button. To close the dialog box without applying any changes, click 
the Cancel button. To go back to the default settings (if any) that apply 
to the current selection, click the Default button. To set no attributes 
for the current character selection, click the None button.

Managing Style Sheets
4D Write manages two types of style sheets. Style sheets that apply 
only to characters and style sheets that apply to paragraphs. You can 
create your own style sheets in a document. Each character style sheet 
specifies a combination of attributes that can be applied to text. For 
example, you might specify a Header style sheet that creates text in 
18 point, Bold style, in the Avant Garde font. A paragraph style sheet 
allows you to set attributes for a paragraph, which includes the 
character formats, border settings, tab settings and paragraph settings.

The Style Sheet pop-up menu lists a documents style sheets. You use 
this menu to apply existing style sheets to the text in your document. 
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Style sheets apply only to the current document. They do not apply to 
all documents, even if the documents are in a 4D Write area. You can 
save style sheets and load them into other documents. You can also 
use documents containing style sheets as templates for 4D Write areas. 
For more information on templates, refer to “Saving a Document as a 
Template” in Chapter 2.

Defining a Custom 
Style Sheet

¨̈̈̈ To define a new custom style sheet:

1 Choose Style sheets from the Format menu.

The Style sheets dialog box appears. It displays the list of style sheets 
for the current document. In the center, the preview area can either 
display the definition or a sample of the style sheet currently 
highlighted in the style sheet list.

2 Click the New button on the right of the dialog to create a new style 
sheet.
The following New style sheet dialog is displayed.
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This dialog allows you to specify which properties you want to use as a 
starting point:

■ the current text properties,

■ the properties of an existing style sheet,

■ no text properties at all.

3 Choose the option you want to start with.
Selecting Empty will define no properties for the new style sheet. 
Selecting Using current text properties will assign the properties of the 
current selected text to the new style sheet. Selecting Using a copy of 
style sheet will assign the properties of that style sheet to the new style 
sheet. If you choose this option, you need to select a style sheet from 
the drop-down list located on the right of the radio buttons.

4 Click the Create button.
The following dialog is then displayed:

If you chose a starting point that uses preset properties this dialog 
displays them accordingly. In this dialog you can: Define a shortcut 
that will trigger the application of the style sheet, edit the name of the 
style sheet and define the settings of the style sheet.

5 Click in the Name text box and edit the name of the style sheet.
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6 Click in the Shortcut text box and enter the character you want to use 
as a shortcut.

This character will have to be used with the combination of the 
Command and Shift keys on Mac OS and Ctrl and Shift on Windows.

Note It is recommended that you use numbers as shortcuts in order to avoid 
potential conflicts with normal 4D Write shortcuts.

7 Using the drop-down list, select whether the style sheet will apply to a 
paragraph or to character.
If you choose Applies to characters, the Borders, Paragraph and Tabs 
buttons become disabled.

8 Click the Character button to set the character properties.
For more information about how to set character attributes, please 
refer to “Changing Text Attributes at Once”, on page 138.

If you selected Applies to characters as the scope of this style sheet, you 
will not need to set any parameters for borders, tabs and paragraphs, 
therefore you can directly go to step 12.

9 Click the Borders button to set the borders properties of the style 
sheet.
For more information about how to set border attributes, please refer 
to “Setting Borders for a Paragraph”, on page 150.

10 Click the Paragraph button to set the paragraph properties of the 
style sheet.
For more information about how to set paragraph attributes, please 
refer to “Setting paragraph formats using the Paragraph dialog”, on 
page 130.

11 Click the Tabs button to set the tab properties of the style sheet
OR
Deselect the Set tabs if you do not want to set tabs properties.
For more information about how to set tabs properties, please refer to 
“Setting Tabs”, on page 124.

You can now make sure the properties you have defined are correct by 
checking the preview area. If you want to check the style sheet 
definition, click the Description tab control. The preview area will then 
display the settings defined for that style sheet.
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12 Click the OK button to create the style sheet
OR
Click the None button to reset all the settings and start over
OR
Click the Revert button to get back to the original settings
OR
Click the Cancel button to cancel all the settings and go back to the 
Style sheet dialog.

Once you click OK, the style sheet is automatically saved and the Style 
sheets dialog is displayed again.

13 Click the Close button.
This style sheet can then be selected from the Style sheet drop-down 
list. 
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Modifying a Style 
Sheet

¨̈̈̈ To modify an existing style sheet:

1 Choose Style sheets from the Format menu.

The Style sheets dialog box appears. It displays the list of style sheets 
for the current document.

2 In the Styles list, click on the style sheet you want to edit.

3 Click the Edit button.

4 The Edit Style sheet dialog is then displayed.
The preview area as well as the style sheet settings reflect the current 
settings of the selected style sheet.
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5 Click in the Name text box if you want to edit the name of the style 
sheet.

6 Click in the Shortcut text box to modify the character you want to use 
as a shortcut.

This character will have to be used with the combination of the 
Command and Shift keys on Mac OS and Ctrl and Shift on Windows.

7 Using the drop-down list, select whether the style sheet will apply to a 
paragraph or to character.
If you selected Applies to character, the Borders, Paragraph and Tabs 
buttons become disabled.

8 Click the Character button to set the character properties.
For more information about how to set character attributes, please 
refer to “Changing Text Attributes at Once”, on page 138.

If you selected Applies to characters as the scope of this style sheet, you 
will not need to set any parameters for borders, tabs and paragraphs, 
therefore you can directly go to step 12.

9 Click the Borders button to modify the border properties of the style 
sheet.
For more information about how to set border attributes, please refer 
to “Setting Borders for a Paragraph”, on page 150.

10 Click the Paragraph button to modify the paragraph properties of the 
style sheet.
For more information about how to set paragraph attributes, please 
refer to “Setting paragraph formats using the Paragraph dialog”, on 
page 130.

11 Click the Tabs button to modify the tab properties of the style sheet
OR
Deselect the Set tabs if you do not want to set tabs properties.
For more information about how to set tabs properties, please refer to 
“Setting Tabs”, on page 124.

You can now make sure the properties you have defined are correct by 
checking the preview area. If you want to check the style sheet 
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definition, click the Description tab control, the preview area will then 
display the settings defined for that style sheet.

12 Click the OK button to validate the modifications of the style sheet
OR
Click the None button to reset all the settings and start over
OR
Click the Revert button to get back to the original settings
OR
Click the Cancel button to cancel all the settings and go back to the 
Style sheet dialog.

Once you click OK, the style sheet is automatically modified and the 
Style sheet dialog is displayed again.

13 Click the Close button.

Saving and Loading 
Style Sheets

Style sheets created in the Style Sheet dialog are saved in the document 
file. You can then import the style sheets into any other 4D Write 
document.

¨̈̈̈ To import style sheets from another document:

1 Select Style sheets from the Format menu.

The Style sheets dialog appears.

2 Click the Import button.
An Open File dialog box appears.

3 Select the document from which you want to import the style sheets 
file and click the Open button.
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The style sheets are loaded into the document. After the style sheets 
are loaded, they immediately become available to the document.

4 Click the Close button.
The Style sheets closes.

Applying Custom 
Style Sheets

Applying a Character 
Style Sheet

¨̈̈̈ To apply a character style sheet to text:

1 Select the text to which you want to apply the style sheet.

2 Choose the character style sheet from the Style Sheet drop-down list 
in the Style toolbar.

The text is given the attributes of the selected style sheet.

Applying a Paragraph 
Style Sheet

¨̈̈̈ To apply a paragraph style sheet to a paragraph or a selection of 
paragraphs:

1 Place the cursor in the paragraph to which you want to apply the 
paragraph style sheet,
OR
Select some text in the paragraph to which you want to apply the 
paragraph style sheet,
OR
Select text that overlaps all the paragraphs to which you want to 
apply the paragraph style sheet.
148 4D Write Reference Manual



Managing Style Sheets
2 Choose the paragraph style sheet from the Style Sheet drop-down list 
in the Style toolbar.

The paragraph is then given the attributes of the selected paragraph 
style sheet.

Applying a Style 
Throughout a 
Document

4D Write allows you to update the formatting of all the text in the 
document that uses a particular style sheet. This feature is useful when 
you want to make sure that all the occurrences of text that use that 
style sheet accurately respect the style sheet attributes.

¨̈̈̈ To update a style sheet throughout the document:

1 Select Style sheets from the Format menu.
The Style Sheets dialog is displayed. 

2 In the Styles list, select the style sheet you want to update throughout 
the document. 

3 Click the Apply button.
All the attributes of that style sheet are applied to each occurrence of 
text that uses it. 

Deleting a Style 
Sheet

You can delete a style sheet at any time. Text that uses that style sheet 
will remain unchanged but they will cease to be defined as using that 
style sheet.

¨̈̈̈ To delete a style sheet:

1 Select Style sheets from the Format menu.
The Style Sheets dialog is displayed. 

2 In the Styles list, select the style sheet you want to delete. 

3 Click the Delete button.
The style sheet is deleted as well as any reference to it.
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Setting Borders for a Paragraph
4D Write allows you to define borders for a paragraph. A border setting 
can be defined for either a separate paragraph or a paragraph style 
sheet.

The Borders Dialog The Borders dialog is the dialog in which borders are set. This dialog is 
used when you design a style sheet that uses border formats or when 
you want to set borders for a paragraph or a set of paragraphs.

When you click the Borders button in the Edit Style sheet dialog, or 
when you select Borders from the format dialog, the Borders dialog is 
displayed:

This dialog consists of three main area:

■ The Borders area:

This area is the area in which borders can be selected. It consists of 
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seven check boxes and a preview area. The preview area displays the 
border according to the check boxes you selected.

■ The Left, Top, Right and Bottom check boxes
When those check boxes are selected, the corresponding border is 
set for the paragraph. When those are grayed, it means that the cor-
responding border is not selected for each paragraph that belong to 
the current selection. In this case, leaving the check box untouched 
will leave the setting for that border untouched.

■ The All check box
When this check box is selected, it selects the Left, Top, Right and 
Bottom check boxes and the corresponding borders.

■ The Between paragraphs check box
When this check box is selected, a border is displayed between the 
paragraphs of the selection (if there is more than one).

■ The From text check box
When this check box is selected, the entry area located next to it 
allows you to set the distance between the upper, lower, right and 
left limits of the characters and the border lines.

■ The Frame area:

This area is the area in which the frame of the borders can be selected. 
Clicking on the frame type will assign it to the borders.

■ The Frame area:

This area is the area in which the colors for the border lines and the 
border background will be selected.
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■ The Lines picture menu

The color selected in this picture menu will apply to the line of the 
borders.

■ The Back picture menu

The color selected in this picture menu will apply to the back-
ground of the borders.

The Borders dialog also includes five buttons:

■ The Cancel button
This button closes the Borders dialog. If the Borders dialog was called 
from another dialog (Edit style sheet, Find or Replace), clicking on the 
Cancel button calls back the dialog from which it was called.

■ The OK button
This button closes the Borders dialog and validates its contents. If the 
Borders dialog was called from another dialog (Edit style sheet, Find or 
Replace), clicking on the OK button calls back the dialog from which it 
was called.

■ The Default button
This button assigns the default settings back in the Borders dialog. 
Default settings are typically style sheet settings that were altered for 
the selected paragraph before the Borders dialog was opened.

■ The Revert button
This button assigns the original settings back in the Borders dialog. The 
original settings are the settings that were first displayed when you 
opened the Borders dialog.

■ The None button
This button resets all the settings back in the Borders dialog. Clicking 
on the None button deselects any border, frame or color.
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¨̈̈̈ To define and apply a border setting to a paragraph or a selection of 
paragraphs:

1 Place the cursor in the paragraph to which you want to apply the 
border settings,
OR
Select some text in the paragraph to which you want to apply the 
border settings,
OR
Select text that overlaps all the paragraphs to which you want to 
apply the border settings.

2 Select Borders from the Format menu.
The Borders dialog is then displayed

3 Select the borders you want to select by clicking on the corresponding 
check box.
For more information about the meaning of those check boxes, refer to 
“The Borders Dialog”, on page 150.

4 Select the frame type you want to select by clicking on the frame in 
the Frame style area.
1534D Write Reference Manual



Chapter 5  Formatting Text
5 Click OK to validate the modifications you just made
OR
Click the None button to reset all the settings and start over
OR
Click the Revert button to get back to the original settings
OR
Click the Default button to get back to the default style sheet settings
OR
Click the Cancel button to cancel all the settings and go back to the 
Style sheet dialog.

Managing Tables
4D Write manages graphical tables, although they are actually stored 
as formatted paragraphs. This means that if a table needs significant 
modification, it is often easier to re-create it. 

4D Write allows you to insert and define graphical tables in your 
documents. For each table you can:

■ select predefined table templates,

■ define the number of rows and columns,

■ set an automatic text format,

■ set different automatic values and styles for each column,

■ set different automatic values, colors and styles for specific rows.

The Table Wizard In 4D Write, tables are created and modified using 4D Write’s Table 
Wizard. The Wizard Table is displayed by selecting Table Wizard in 
the Tools menu.
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The table wizard appears as follows:

The table wizard mainly consist of three pages and a preview area:

■ The Template page
This page is the page in which you can select a template for the table, 
define the table size and set the global text format.

■ The Columns page
The Column page is the page in which you can define column widths, 
and assign automatic values as well as custom text format.

■ The Rows page
The Rows page is the page in which you can select the line spacing 
between rows, select predefined values for the first and last rows, set a 
color and a text format for specific rows.

■ The preview area
The preview area displays a preview of the table as you set it, 
modifications are displayed on the fly.
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The Template Page The template page is the default page on which the table wizard opens:

This page consists of three element:

■ The Table type drop-down list:

Selecting an Item from this list will apply the corresponding template 
to the table you are creating.

■ The Size area:

This is the area in which you set the number of rows and columns for 
the table you are creating, by respectively entering those numbers in 
the Rows and Columns boxes.
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■ The Text format area

This area is the area in which you select the format of the text that will 
be entered in the table. The Font drop-down list lets you select the font 
that will be applied to the text. The Size drop-down list lets you select 
the size of the font that will be applied to the text. The Vertical 
separator check box lets you choose whether you want to display 
separators between columns. When you click the More button, the 
Character dialog is displayed. For more information about how to use 
this dialog, refer to “Using the Character Dialog Box”, on page 139.

The Columns Page The Column page is the page in which you define the format and 
automatic contents for columns:
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This page consists of three main interface elements:

■ The Style for drop-down list:

This list allows you to select the column to which the settings in the 
Columns page will apply. For example, if you select Column 1, the 
settings that will be defined in the Values and Format areas will only 
apply to the first column. If you want to set the format of several 
columns, you will need to select one column at a time and define their 
formats separately.

■ The Values area:

The value area is the area in which you select predefined values for the 
current column. A radio button offers you three choices:

■ None
If you select this choice, no predefined value will be used for the 
current column.

■ Predefined
If you select this choice, the Start value area is activated. This allows 
you to select a type of predefined value from the drop-down list and 
to define which value to start with. The values you can select are:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for roman numbering,
• Monday, Tuesday for days,
• January, February for months.
For more information about selecting a predefined value, refer to 
“Inserting a predefined value as an Automatic Column Value”, on 
page 165.
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■ 4D Field
If you select this choice, the field value is then inserted in each row 
and the number of rows will depend on the number of selected 
records. Since you then benefit from the Order by and Query fea-
tures of 4D, you can narrow your record selection and rearrange it. 
For more information about selecting a field as a column value, 
refer to “Inserting a 4D Field as an Automatic Column Value”, on 
page 162.

■ The Format area:

This is the area in which you select the format and alignment of the 
text that will be entered in the column. When selected, it overrides the 
format defined in the Template page. It also allows you to define the 
alignment for the text and the Column width. This area consists of the 
following elements:

■ The alignment drop-down list
This list lets you choose the alignment between Left, Centered, 
Right and Decimal.

■ The Fixed Width check box
When this option is selected, it activates the value box located next 
to the check box. You can then enter a fixed value for the width of 
the current column.

■ The Text Format button
Clicking on this button opens the normal Character formatting dia-
log, so that you can choose character formatting for the contents of 
the column. For more information about how to use the Character 
formatting dialog, refer to “Using the Character Dialog Box”, on 
page 139.
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The Rows Page The Rows page is the page in which you define the style, the color and 
the automatic contents for rows:

This page consists of three main interface elements:

■ The Style for drop-down list:

This list allows you to select the row to which the settings that are 
currently set in the Columns page will apply. For example, if you select 
Odd rows, the settings that will be defined in the Values and Format 
areas will only apply to the odd rows of the table. If you want to set the 
format for several types of rows, you will need to select one type of row 
at a time and define their formats separately. The types of rows 
available are:

■ First Row
The chosen settings will only apply to the first row.

■ Odd Rows
The chosen settings will only apply to odd rows, excluding the first 
and last rows.

■ Even Rows
The chosen settings will only apply to even rows, excluding the last 
row.

■ Last Row
The chosen settings will only apply to the last row.
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■ The Values area:

The value area is the area in which you select predefined values for the 
current type of rows. A radio button offers you two choices:

■ None
If you select this choice, no predefined value will be used for the 
current column.

■ Predefined
If you select this choice, the Start value box is activated. This allows 
you to select a type of predefined value from the drop-down list and 
to define which value to start with. The values you can select are:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for roman numbering,
• Monday, Tuesday for days,
• January, February for months.
For more information about selecting a predefined value, refer to 
“Inserting a predefined value as an Automatic Row Value”, on 
page 166.

■ The Colors area:

The Colors area is the area in which you can separately select a color 
for the lines and background of the current type of rows.

■ The Format area:

This area is the area in which you select the format of the text that will 
be entered in the row and its alignment. When selected, it overrides 
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the format defined in the Template page. It also allows you to define 
the border formats. This area consists of the following elements:

■ The Line spacing value box
This box is the box in which you enter the line spacing value for the 
current type of rows.

■ The Leave empty check box
When this option is selected, the row will remain empty even in 
columns for which you have selected automatic values.

■ The Text Format button
Clicking on this button calls the Character dialog. For more infor-
mation about how to use the Character dialog, refer to “Using the 
Character Dialog Box”, on page 139.

■ The Borders button
Clicking on this button calls the Borders dialog. For more informa-
tion about how to use the Borders dialog, refer to “The Borders Dia-
log”, on page 150.

Setting Predefined 
Values

4D Write allows you to set automatic values in your tables. There are 
two types of automatic values:

■ 4D Fields, and

■ predefined values such as automatic numbering, months, days.

4D Write allows you to insert 4D fields or Formulas in columns and 
also manages predefined values in both rows and columns.

Inserting a 4D Field as an 
Automatic Column Value

¨̈̈̈ To insert a 4D Field as an automatic column value:

1 Select Table Wizard from the Tools menu.
The Table wizard is then displayed.

2 Click on the Columns tab control.
The Column page is displayed.

3 In the Style for drop-down list, select the column in which you want 
the 4D Field to appear.

4 Choose  in the Value area.

5 Click the Field selection button .
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The Insert 4D expression dialog is then displayed:

In the Field page, you can select the field that will be inserted. In the 
Format area, you can select one of the predefined display format or 
define a specific display format. For more information, about display 
format, please refer to the 4th Dimension User Reference manual.For 
more information about how to use the Insert 4D Expression dialog, 
refer to “Referencing Fields and Expressions”, on page 177.

6 Expand the hierarchical list of the table that contains the field you 
want to insert.

7 Double-click on the Field that you want to insert as a value.
It is then displayed in the area next to the 4D Field button.

The numbers of selected records for that table is displayed at the 
bottom of the Values area. For each record, the value of the record will 
be displayed in a row.
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8 If you want to select some specific records, click the Find button.
The Query editor is then displayed:

Edit the query as you would in 4D. For more information about 
queries, please refer to the 4D User Reference manual.

Once you are done executing your query and if the number of records 
matches the size of the table, the Column page is displayed again and 
the number of records is modified accordingly. If the number does not 
match the array, the following dialog is then displayed:

If you click on the Leave unchanged button, the Column page is 
displayed again and the size of the table remains unchanged. If you 
click on the Resize button, the Column page is displayed again and the 
number of rows was modified to match the number of records.
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9 If you want to modify the sort order, click the Order button.
The 4D Order by dialog is then displayed:

You can then define the sort order. For more information about 
defining the sort order, please refer to the 4th Dimension User 
Reference manual. Once the Order by is defined, it is used to define the 
sequence of values in the table.

10 Once you are done defining your selection and sorting it, you are done 
with the insertion of 4D Fields as values.
You can then resume the remainder of the creation of the table.

Inserting a predefined 
value as an Automatic 
Column Value

¨̈̈̈ To insert a predefined value as an automatic column value:

1 Select Table Wizard from the Tools menu.
The Table wizard is then displayed.

2 Click on the Columns tab control.
The Columns page is displayed.

3 In the Style for drop-down list, select the column in which you want 
the predefined values to appear.

4 Choose  in the Value area.
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5 Select the type of predefined value from the value drop-down list.

For more information about the options you can select, please refer to 
“The Columns Page”, on page 157.

6 Select the starting value.
The starting value is always a number but it will apply to any kind of 
selected value. For example, if you enter 2 as a starting value and select 
the month value, the first value will be February.

7 Once you are done with the Predefined value settings, proceed with 
the remainder of the table configuration.

Inserting a predefined 
value as an Automatic 
Row Value

¨̈̈̈ To insert a predefined value as an automatic row value:

1 Select Table Wizard from the Tools menu.
The Table wizard is then displayed.

2 Click on the Rows tab control.
The Rows page is displayed.

3 In the Style for drop-down list, select the row type in which you want 
the predefined values to appear.
For more information about the Style drop-down list, refer to “The 
Rows Page”, on page 160.

4 Choose  in the Value area.

5 Select the type of predefined value from the value drop-down list.

For more information about the options you can select, please refer to 
“The Rows Page”, on page 160.
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6 Select the starting value.
The starting value is always entered as a number but this allows you to 
select any kind value. For example, if you enter 2 as a starting value 
and select the month value, the first value display will be February.

7 Once you are done with the Predefined value settings, proceed with 
the remainder of the table configuration.

Creating a Table Before creating a table, you should make sure the element that will be 
entered in the table will fit in the columns. Since 4D Write does not 
manage the concept of cells, reaching the limit of a column or entering 
a Carriage Return does extend the height of the “cell”.

¨̈̈̈ To create a table:

1 Select Table Wizard from the Tools menu.
The Table wizard is then displayed.

2 In the Template page, select the template by selecting it from the 
Table Type drop-down menu:

3 Enter the number of rows and columns in the Rows and Columns 
boxes.

4 If you want, define a global character format for the table in the Text 
format area.
For more information about the effect of the character options, refer to 
“The Template Page”, on page 156.

5 Click on the Column Tab control to set the column options.
The Columns page is then displayed.

6 Using the Style for drop-down list, select the Column you want to 
modify.
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7 For the current column, you can either set predefined values or a 4D 
Field as automatic values.
For more information about inserting a 4D Field as an automatic 
column value, refer to “Inserting a 4D Field as an Automatic Column 
Value”, on page 162. For more information about inserting a 
predefined value as an automatic column value, refer to “Inserting a 
predefined value as an Automatic Column Value”, on page 165.

8 In the Format area, set the alignment, format and width of the current 
column.
For more information about the options of the Format area, refer to 
“The Columns Page”, on page 157.

9 Restart step 6 through 8 for each column you want to set.

10 Click on the Rows tab control to set the rows options.
The Rows page is then displayed.

11 Using the Style for drop-down list, select the type of row you want to 
modify.
For more information about the types of row you can select, refer to 
“The Rows Page”, on page 160. 

12 For the current type of row, you can set predefined values as 
automatic values.
For more information about inserting a predefined value as an 
automatic row value, refer to “Inserting a predefined value as an 
Automatic Row Value”, on page 166.

13 In the Format area, set the border, formats and line spacing of the 
current row.
For more information about the options of the Format area, refer to 
“The Rows Page”, on page 160.

14 Using the Back and Line picture menus, select a color for the line and 
for the background of the selected type of rows.

15 Restart step 11 through 14 for each type of row you want to set.

16 Click OK to create the table.

Note Since 4D Write does not manage cells in tables as rows and columns, 
once a table is created it is usually easier to create it again than to 
modify it.
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Managing Columns
4D Write allows you to manage text columns in your documents. 
When you set columns in a 4D Write document, they apply to the 
whole document. In 4D Write, columns are chained from the leftmost 
column to the rightmost column. In other words, when entering text, 
the text flow will start filling the left column and continue with the 
column directly to the right until it reaches the end of the page. Once 
the end of the page is reached, the text flow cycles through the next 
page. In order to be able to balance the page settings, 4D Write also 
allows you to insert column breaks.

Note For a proper display of columns, you should always select the Page 
viewing mode.

The current section will describe how to :

■ set columns in a document,

■ modify columns in a document,

■ insert and remove a column break in a column.

The Columns Dialog The Columns dialog is the dialog in which you define the column 
settings for the current document. The Columns dialog displayed by 
selecting Columns from the Format menu:

The Column dialog consists of two main areas:

■ The Columns area
This area is the area in which you can define the number of columns, 
their width and the space between them.
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The Column area includes the following interface elements:

■ The Number drop-down list:
This list allows you to select the number of columns that will 
appear in the document. No more than ten columns can be created.

■ The Width box
This box is used to set the width of the columns. The value entered 
is applied to each columns and has no influence on the number of 
columns. If there is not enough room to accommodate the value 
entered, 4D Write will select the highest possible value and reduce 
the Spacing value accordingly.

■ Spacing
This box is used to set the space between columns. If there is not 
enough room to accommodate the value entered, 4D Write will 
select the highest possible value and reduce the Width value accord-
ingly. 4D Write will always maintain a minimum value for the col-
umn width.

■ The Vertical Separator check box
When this check box is selected, a vertical separator is displayed 
between the columns.

■ The preview area
This area displays in real-time the effect of the value you are entering 
in the Columns area.

When you work with columns, it is required to be in Page view mode. 
If Normal view mode is selected, only one column is displayed, which 
is often easier for editing.
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Setting columns for 
a document

¨̈̈̈ To define columns in a 4D Write document:

1 Select Columns from the Format menu.
The Columns dialog box is then displayed:

2 Choose the number of columns from the Column drop-down list.
The preview area is modified accordingly.

3 Enter the value for the column width in the Width area.
OR
Enter the value for the space between columns in the Spacing box.
Setting only one of those two values lets 4D Write assign a 
complementary value to the other one.

4 Click the OK button.
The 4D Write document is modified according to the column settings.

Modifying the 
Column Width 
Using the Ruler

¨̈̈̈ To resize a column:

1 Choose Page from the View menu.
The 4D Write ruler displays the column limits.

2 Place the mouse cursor over the column limit.
The cursor becomes a double-sided arrow.
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3 Drag the limit of the column to its new location.
The column is then modified accordingly.

Modifying the 
Columns Settings

¨̈̈̈ To modify the column settings of a 4D Write document:

1 Select Columns from the Format menu.
The Columns dialog box is then displayed:

Its contents reflects the current settings.

2 Choose the settings you want to modify.
You can modify any parameter from the number of columns to their 
size. For more information about the options you can set, refer to “The 
Columns Dialog”, on page 169.

3 Enter the value for the column width in the Width area.
OR
Enter the value for the space between columns in the Spacing box.
Setting only one of those two values lets 4D Write assign a 
complementary value to the other one.

4 Once you have defined the new settings, click the OK button.
The 4D Write document is modified according to the new column 
settings.

Note When modifying the column settings you may want to check the 
position of column and page breaks, since they may need to be moved 
to match the new settings.
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Managing Column 
Breaks

Inserting a column break moves characters or paragraphs located after 
the insertion point to the top of the next column. You can use column 
breaks to balance your columns. When inserted, a column break 
appears as follows:

Column breaks are automatically displayed when the invisible 
characters are displayed. When in Normal view mode, column breaks 
are always displayed. When in Page view mode, they are displayed 
only when the invisible characters are displayed.

¨̈̈̈ To insert a column break:

1 Select Page from the View menu, if you are in the Normal View mode.
The Page viewing mode is selected and the borders of the columns are 
properly displayed.

Note To work with columns, you must be in Page view mode.

2 Place the cursor where you want to insert the column break in the 
column.
This action establishes the insertion point.

3 Select Column Break from the Insert menu.
The column break is then inserted and any paragraph that was located 
after the insertion point is moved to the next column.

¨̈̈̈ To remove a column break:

1 Click just after the column break.

2 On the Macintosh, press Backspace. In Windows, press Backspace or 
Delete.
The column break is deleted.
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Creating a Page Break
Specifying where a page break occurs can improve the appearance of a 
document. You can use page breaks to start a section at the top of a 
new page or to eliminate lines of text at the top of an otherwise blank 
page.

¨̈̈̈ To create a page break:

1 Click at the location where you want the page break to occur.
This action establishes the insertion point.

2 Choose Page Break from the 4D Write Insert menu.

In the Normal mode (selected using the Page Command from the 
View menu), a dotted horizontal gray line marks the page break.

Page breaks are automatically displayed when the invisible characters 
are displayed. When in Normal view mode, page breaks are always 
displayed. When in Page view mode, they are displayed only when the 
invisible characters are displayed.

In the Page View mode, a new page is created as shown.

All text to the right of and below the insertion point moves to the top 
of the next page.
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¨̈̈̈ To remove a page break:

1 Drag to select the blank space preceding the page break.

2 On the Macintosh, press Delete.
In Windows, press Backspace or Delete.
The page break is deleted.
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4D Write enables you to use information from your database in a 
document. For example, you might create a form letter that you want 
to customize for each person in your database.

To facilitate this, 4D Write 6.5 allows you to embed 4D fields or 
expressions in your documents. For example, an expression could 
determine an employee’s monthly salary or the amount of an 
employee’s profit sharing check.

This chapter explains how to do the following:

■ Reference and modify fields and expressions in a document;

■ Show the current values of fields and expression;

■ Freeze the values of fields and expressions;

■ Insert data using the Table Wizard

Referencing Fields and Expressions
You can 4D fields and expressions into a 4D Write document. You can 
display the referenced data as references or as their immediately 
calculated values based on data from your 4th Dimension database.

When fields and expressions are shown as references, they are 
surrounded by reference (« ») symbols. 4D Write inserts these symbols 
when you insert the field in the document.
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The following figure shows the use of references in a form letter. The 
letter uses field references for the person’s name and address and an 
expression for the letter’s date.

When the references are converted to values, the values are displayed 
as regular text.

The values from field references and expressions always refer to the 
current record. They are updated whenever the current record changes.

Field references for 
name and address
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Inserting a 
4th Dimension Field

You can insert the contents of a field in a 4D Write document. The 
field information displayed is dynamic. If you change the information 
in the current record, you will need to update it by selecting Compute 
references now from the Tools menu.

4D Write also allows you to insert data into a table in your document 
using the table wizard. For more information, refer to “Managing 
Tables”, page 154

You can display and print data from the current record. When the 
document is displayed in a form, the current record is the record being 
displayed. When the document is displayed in an external window, 
the current record is the record currently open on the screen.

You can print merge data from a selection of records to create form 
letters and reports that draw information from each record in the 
selection. For information on printing merge documents, refer to 
“Printing a Merge Document”, page 189.

There are two ways to insert a 4th Dimension database field—using the 
Insert menu or using keyboard commands and the mouse.

¨̈̈̈ To insert a 4th Dimension database field using the Insert menu:

1 Click where you want the field to be located.
The insertion point should be blinking at this location.

2 Choose 4D Expression from the Insert menu.
The following dialog box is displayed.

The hierarchical list displays the names of your database tables.
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3 Expand the table in which the field is located.

4 Select the field by clicking it in the Field list.
The display formats that match the type of field you just selected are 
displayed in the Format list.

5 If you want to apply a display format to that field, select one from the 
Format area.
OR
Enter a new display format in the edition area located above the 
Cancel button.
For more information about display formats, refer to the 
4th Dimension Design Reference manual.

6 Click OK.
The field is added to your document.
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¨̈̈̈ To insert a 4th Dimension database field using keyboard commands:

1 Click where you want the field to be located.
The insertion point should be blinking at this location.

2 In Windows, press the right mouse button to display a pop-up menu 
of database tables.
On the Macintosh, press Ctrl and the mouse button to display a pop-
up menu of database tables.
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3 Choose the table from the popup menu and then field from the 
submenu beside the table.
When you release the mouse button, the field reference is displayed in 
the document.

Viewing Field Values To view the field values, you must show the values for the referenced 
data. For more information, refer to “Showing References or Values”, 
page 185.

Modifying Field 
References

¨̈̈̈ To change the field reference:

■ Double-click the field reference.
The Insert 4D Expression dialog box is displayed, enabling you to 
change the field reference.

Inserting an 
Expression

You can insert any valid expression in a document. The expression can 
be any of the following:

■ A 4th Dimension variable;

■ A 4th Dimension function;

■ A plug-in function, such as a 4D Write function;

■ A project method that returns a value; or

■ Any valid 4th Dimension expression

Field reference
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Inserting expressions enables you to use the power of 4D’s procedural 
language within 4D Write documents. You can perform calculations, 
concatenate information from several fields, and so forth.

The following are examples of expressions:

If an expression returns text that includes carriage returns and tabs, 
4D Write formats the text according to the settings of the paragraph in 
which the expression is inserted.

¨̈̈̈ To insert an expression:

1 Click where you want the expression to be located.
The insertion point should now be blinking.

2 Choose 4D Expression from the Insert menu.
The following dialog box is displayed.

Expression Comment
Current time A 4th Dimension function
Current date-vDate A statement that performs a calculation
Salute A project method that returns a value
WR Count A 4D Write function
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3 Click the Expression tab control.
The Expression page is then displayed.

4 Click the Edit button.
The Formula Editor is then displayed.

5 Edit your 4D Expression.
For more information about the use of formula editor, refer to the 
4th Dimension User Reference Manual.
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6 Click OK to validate your expression.
The Insert 4D Expression dialog is displayed again. This time the 
contents of the Expression page reflect the 4D Expression you just 
edited.

7 If you want to apply a display format to that expression, select one 
from the Format area.
OR
Enter a new display format in the edition area located above the 
Cancel button.
For more information about display formats, refer to the 
4th Dimension Design Reference manual.

8 Click OK to insert your 4D Expression in the document.

Viewing Expression 
Values

To view the value of the expressions, refer to “Showing References or 
Values”, page 185.

Modifying Expressions

¨̈̈̈ To modify an expression:

■ Double-click the expression.
The Insert 4D Expression appears, allowing you to change the 
expression.

Showing References or Values
¨̈̈̈ To show the references or the values in a document:

■ Choose References from the View menu.
When references are shown, a check mark must be displayed next to 
the Reference menu command. When values are displayed, the check 
mark is not displayed.

Freezing References
Once the values are displayed, you may wish to “freeze” them. 
Freezing references converts their currently displayed values to regular 
text and removes the associated references. This enables you to keep a 
permanent record of a document or portion of a document you 
created. For example, you can freeze a report containing financial data 
so that any further modifications to the data do not impact the report.
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¨̈̈̈ To freeze the references:

■ Choose Freeze Reference from the Tools menu.

Note The Freeze Reference operation cannot be undone.

Computing References
You must force the computation of references each time you need to 
update them. References are only computed when you request it.

To force the computation of the references:

■ Choose Compute References Now from the Tools menu.
The values of the references are instantaneously updated.
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7 Printing 

You can print any 4D Write document in a variety of ways. For 
example, a form letter that includes fields from a 4th Dimension 
database can be print merged to provide a copy for each person in a 
group, or a single letter can be printed for a specific person.

This chapter describes how to:

■ Print only the current document

■ Print merge a document once for each record in a selection

■ Print a document as part of a record

Printing the Current Document
4D Write can create stand-alone documents such as memos, letters, 
and notes in either external windows orin 4D Write areas in forms. 
The following figure shows a letter in a 4D Write area. 
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To print only the letter shown, choose Print… from the 4D Write File 
menu. Margin settings, page breaks, and any other paragraph format 
features incorporated in the document are used during printing.

As a general rule, when the references are displayed, they will be 
printed as shown. On the other hand, if the references are being 
displayed as values, these values will be re-computed before the 
document is printed, using the values of fields in current records. This 
applies both to direct printing and to print previews. For more 
information about displaying references or value, refer to “Showing 
References or Values”, page 185.

The contents of the header and footer are printed, even if the 
document is in Normal view mode, in which headers and footers are 
not displayed on the screen.

¨̈̈̈ To print a document:

1 If necessary, choose Page Setup from the 4D Write File menu to 
modify the page setup.
The Page Setup dialog box presents different choices depending on the 
printer driver that you have selected. The 4D Write page setup is 
independent from that of 4th Dimension.

2 Choose Print from the 4D Write File menu.
4D Write displays the standard Print File dialog box.

3 On the Macintosh, click the Print button (or it may be an OK button).
In Windows, click the OK button.
The document is printed.
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Printing a Merge Document
Printing a Merge Document
You may often use 4D Write to create documents, such as form letters 
and reports, that draw information from records. You can print such a 
document once for each record in the current selection.

The following figure shows a form letter that will be printed for a 
group of people listed in the Contacts database. 

In the letter, field references are inserted for the name and address 
fields. When the letter is print merged, the data from the fields is 
inserted so the correct name and address are printed for each person.

To print such a document, choose Print Merge from the 4D Write File 
menu. This command prints the document once for each record in the 
current selection. Margin settings, page breaks, and any other 
formatting features are included.

¨̈̈̈ To print merge a document:

1 If necessary, choose Page Setup from the 4D Write File menu to 
modify the page setup.
The Page Setup dialog box presents different choices depending on the 
printer driver that you have selected. The 4D Write page setup is 
independent from that of 4th Dimension.

Field references

Field references 
for salutation
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2 Choose Print Merge from the 4D Write File menu.
4D Write displays the Create Merge Selection dialog box.

3 Click the table you want to use as the master table for this document.
The document will be printed once for each record in the master table. 
The dialog box indicates the number of selected records in the master 
table. 

4 To change the selection of records, click the Find button.
4D Write displays the 4th Dimension Query editor, which you can use 
to search for a specific group of records. For information on using the 
Search editor, refer to the 4th Dimension User Reference manual.

If no records are selected, the Print button is disabled.

5 To sort the records from the master file, click the Sort button.
4D Write displays the 4th Dimension Order by editor, which you can 
use to sort the records in the selection. For information about using 
the Sort editor, refer to the 4th Dimension User Reference manual.

6 Click the Print button.
4D Write displays the standard Print File dialog box.

7 On Mac OS, click the Print button (or it my be an OK button).
In Windows, click the OK button.
The document is printed once for each record in the selection.
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Previewing the Document
You can preview a document by choosing Print Preview from the 
4D Write File menu. The data for the referenced fields is drawn from 
the first record in the selection.

The following figure shows the letter being previewed on screen.

A set of icons appear to the left of the previewed document.

■ Print icon: Clicking this prints the document. The Page Setup dialog 
box is not presented before printing.

■ Stop icon: Clicking this quits the print preview and returns you to the 
original document.

■ Next Page icon: Clicking this displays the next page of the document. 
If the last page is already displayed, the icon appears dimmed.

Print icon

Stop icon

Previous Page icon

Next Page icon

Zoom menu
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■ Previous Page icon: Clicking this displays the previous page of the 
document. If there are no previous pages, the icon appears dimmed.

■ Zoom drop-down list: Clicking this displays a list of zoom ratios. 
Selecting one of those ratios will apply it to the print preview.

Printing a Document as Part of a Record
You may want to print a 4D Write document as part of a record. The 
information on the document appears together with each record just 
as it does on the screen, except that the 4D Write area on the printout 
will expand to print the entire document.

When you print a record, you follow 4th Dimension printing 
instructions. The 4D Write instructions for page setup, headers and 
footers, page breaks, column breaks and so on, do not apply.

¨̈̈̈ To print a record or group of records:

1 Select the record or records you want to print.
For information on selecting records, refer to the 4th Dimension User 
Reference manual.
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2 Choose Print from the 4th Dimension File menu.
The Print Form dialog box appears. You use this dialog box to select the 
form you want to use to print the records.

3 Select the form and click OK.
The Page Setup dialog box appears.

4 Make any necessary modifications to the Page Setup dialog box and 
click OK.
The standard Print File dialog box appears

5 Make any necessary modifications to the Print File dialog box. 
On the Macintosh, click the Print button (or it may be an OK button).
In Windows, click the OK button.
The records are printed. The 4D Write area behaves like a variable 
frame Text field. The 4D Write area expands vertically to print all the 
information on the document. 
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Previewing the 
Record

The following figure shows a record being previewed on the screen. 
You can preview a record before printing by selecting the Preview on 
Screen (Macintosh) or Print Preview (Windows) check box in the Print 
File dialog box.

For more information on variable frame printing, refer to the 
4th Dimension Design Reference.
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