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What is SynEdit?
SynEdit is a 32-bit text editor for Windows. While it can serve as a good replacement for Notepad, it also 

offers many powerful features for Web page authors and programmers, and supports a good subset of the features 
found in other similar programs, like UltraEdit and EditPlus. It provides you with drag and drop editing, opens files of 
nearly unlimited size, and you can have over 255 files open at once in a tabbed workspace. 

It has powerful and fully customisable keyword and delimiter highlighting for HTML, ASP, Perl, Java, C/C++
and many other programming languages, based on the pre-configured syntax profiles or user defined syntax 
profiles. 

Additionally, SynEdit provides support for project/workspace saving and restoration, as well as supporting 
command-line compilers and viewers. No longer need you use just any old text editor to write the code for your your 
free command line C compiler.    Other features include a cliptext window for commonly used keywords and phrases,
and a convenient file browser for quickly navigating the directory tree to open files. 
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Basic Editing
SynEdit uses much the same editing interface as most popular text editors and word processing packages.

It implements a multiple document interface, and lets you select text in one window and to drag and drop it into 
another. Additionally, it provides clipboard support and the usual set of search functions.

SynEdit color codes the files you open according to the scheme you have setup using the Tools -> 
Options dialog. If you have color coding set to automatic, SynEdit color codes as you type. However, color coding 
can take quite a while on large files, and it is recommended that you disable automatic color coding when you are 
editing large files, and that you use the manual color coding toolbar button to refresh the color coding only when you
make substantial changes to your document.
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Creating New Files
You can instantly create a new editing window for a new file by selecting the Window -> New Window 

menu command. Selecting the New File option from the File menu opens the "New File" dialog, which gives you the
option of creating a blank file, or of using one of a number of templates. SynEdit comes with a number of simple 
code skeletons for a number of programming languages, and you can create your own templates in SynEdit and 
save them templates using the Export as Template command under the File menu.
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Opening Files
You can open files of virtually any type in SynEdit, provided that they are in a plain-text type format. 

SynEdit does not support the editing of binary- type files. The source files for virtually every programming language 
are saved as plaintext files, and can be opened using SynEdit.

You can open files using the File -> Open menu command, or the Open File toolbar button. Additionally, 
you can use the file browser (to left of the workspace) to quickly open files by double-clicking on them.
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Saving Files
SynEdit saves all files in plain text format. No color coding information is preserved when files are saved, 

although you can Export as RTF files for printing or formatting using word processor software. 
The Save item under the File menu will save the changes to the current open file. Save As saves these 

changes to a different filename, and the Save All item saves the contents of all open documents.
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Exporting Files for Printing
To print color coded hard copies of your code for addition to word-processor coduments, you can use the 

Export as RTF menu item under the File menu. This saves your code in Rich Text Format (RTF), a common format 
used by all popular word processors. Note that this Rich Text formatted file is not compatible with the original source 
file [of course, you already knew that]. 
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Exporting Files as Templates
To reuse a file as a template, save it using the Export as Template option under the File menu. You can 

then enter a meaningful description for your new template, which will be saved under the \TEMPLATES\ directory in 
the SynEdit program directory.
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Find and Find Next
To search for a certain piece of text, use the Find menu option under the Search menu. Clicking the Find 

button on the dialog will take you to the first occurrence of the text you wish to find, and Find Next wil cycle through 
the next occurrences. 

Selecting text in the current window and selecting the Find Next item under the Search menu (or pressing 
F3) will find the next occurrence of the selected text, so you don't have to use the Find function dialog box.

If you wish to search for an extended piece of text containing multiple lines, use the Extended Find menu 
command. It is otherwise identical to the Find command.
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Searching and Replacing
The Replace item under the Search menu lets you search for a specific piece of text and replace it with 

another automatically. The Extended Replace menu command allows you to search for extended pieces of text 
containing carriage returns. It is otherwise identical to the Replace command.
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Changing Text Case
The Format menu provides you with a number of commands that allow you to modify the case of selected text:

To Upper Case makes all letters in the selection upper case
To Lower Case makes all letters in the selection lower case
Capitalize First make all letters in the selection lower case, but the first letter a capital (sentence formatting)
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Trimming Spaces
To remove unwanted spaces in text, there are a number of commands under the Format menu. These are:

Trim Leading Spaces will remove any spaces at the beginning of the selection
Trim Trailing Spaces will remove any spaces at the end of the selection
Trim Spaces will remove all spaces at the beginning and end of the selection
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Tabs to Spaces
The Tabs to Spaces function will convert all tabs in your document to runs of spaces of a length that you 

specify.
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Setting SynEdit up Using Default Profiles
The Default Profiles tab of the Options dialog lets you quickly set SynEdit up with preset options. You can 

use the presets that SynEdit is distributed with, or you can create your own. Each time you apply a Default Profile, 
you effectively overwrite the program's current settings for delimiters, you completely change the keyword lists, as 
well as the display font, etc. This function saves you having to set up SynEdit manually each time you want to use a 
different programming language. Additionally, if you've just configured SynEdit for a new language, I strongly 
suggest that you export the settings as a profile to preserve your efforts.

Selecting Apply This Profile will alter the program settings to the settings contained within the profile. 
Selecting Export Settings as Profile will save the settings currently shown on the Options dialog as a 

profile. You should specify a meaningful name for your new profiles. All profiles are saved under the \PROFILES\ 
directory in the SynEdit program directory.
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Customizing Keyword Lists
SynEdit keeps three keyword lists for syntax highlighting. 
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Saving and Restoring a Workspace
SynEdit supports the saving and restoration of workspaces for project-based work. For example, you might

have all of the pages for a web site open. Saving a workspace file lets you open all of these files automatically 
simply by selecting the Restore Workspace option in the Advanced menu.

The "Project" files are are saved using this function are simply a list files. When these files are opened, 
SynEdit will attempt to open the filenames contained in the project file. If you have moved these files after saving a 
workspace files, the workspace file will no longer function correctly.
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Configuring SynEdit for use with command-line compilers and 
viewers

To make SynEdit useful as a programmer's editing environment, it is able to function as a host for a 
command line compiler (or viewer). Configuring SynEdit to work with a command line compiler is simple. Simply 
specify the command line of the compiler, and insert the parameters the place of the file to be compiled in the 
Configure Compiler/Viewer dialog. When the Run Compiler/Viewer option is selected, these parameter tokens 
will be replaced by the filename of the file in the current window. 
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Load in Default Viewer
This opens the currently open file in the associated program on your system. For example, opening 

a .HTML file on your system might bring up Internet Explorer. Using this function on that system, selecting Load in 
Default Viewer would open the current file in Internet Explorer or whatever program is associated with .HTML files.
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Disclaimer
YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, YOU UNDERSTAND THIS 

AGREEMENT, AND UNDERSTAND THAT BY CONTINUING THE INSTALLATION OF THE SOFTWARE, BY 
LOADING OR RUNNING THE SOFTWARE, OR BY PLACING OR COPYING THE SOFTWARE ONTO YOUR 
COMPUTER HARD DRIVE, YOU AGREE TO BE BOUND BY THE LICENSE AGREEMENT'S TERMS AND 
CONDITIONS. THE TERMS AND CONDITIONS OF THIS AGREEMENT ARE NOT NEGOTIABLE AND 
AUTOMATICALLY SUPERCEDE ANY OTHER REFERENCES APPERTAINING TO THE RIGHTS AND LIABILITIES
OF PERSONS USING THIS SOFTWARE. USAGE OF THE SOFTWARE CONSTITUTES AGREEMENT TO THE 
TERMS STATED IN THE LICENSE AGREEMENT. THE AUTHOR AND COPYRIGHT HOLDER ACCEPTS NO 
RESPONSIBILITY FOR DAMAGES TO PERSONS, PROPERTY OR DATA INCURRED THOUGH USE OF THIS 
PROGRAM
                        
                        SynEdit is Copyright © Matthew Inman 1999.



Copyright
SynEdit is Copyright (c) Matthew Inman 199. All Rights Reserved.
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License Agreement
Commercial Use of this product is Prohibited. Under no circumstances shall you, the end-user, be permitted, 
allowed or authorized to commercially exploit the Software, or any portion thereof, such as a screen display or a 
screenshot. Neither you nor anyone at your direction shall do any of the following acts: 

· Rent the Software; 
· Sell the Software without the express and signed permission of the Author; 
· Lease or lend the Software; 
· Offer the Software on a pay-per-use basis; 
· Distribute the Software for money or any other consideration without the express permission of the Author; 
· In any other manner and through any medium whatsoever commercially exploit the Software or use the 

Software for any commercial purpose except for the purpose of examination and review, or for the use of 
the program in its function as an editor and a programming platform. If you are using SynEdit in a 
commercial environment, you agree to indemnify the author and copyright holder from any claims or 
damaged arising as a result of running or otherwise using the software. 

Additional Prohibited Uses: Neither you, nor anyone at your direction, shall take the following action in regard to 
the Software: 

· Modify, disassemble, reverse engineer or decompile the Software; 
· Translate the Software; 
· Reproduce the Software; 

Distributive Concessions: The Software may be distributed freely and without charge provided that:
· No fee is charged for the software that includes sale of the product itself that do not cover the cost of 

reproduction and/or distribution (shareware vendors may contact the Author at the address given in the 
Contact Information section of this helpfile should they wish to discuss these terms. Owners of Webpages 
may also feel free to link to either the SynEdit webpage or the compressed distributable, provided that it is 
accessible to users without cost or password access). 

· No modifications are made to the product and that it is distributed intact and unchanged, with all of its 
component files. 

SynEdit is Copyright © Matthew Inman 1999.



Other Legal Issues
All trademarks are the property of their respective owners. 
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Contacting the Author
 I'm 19 years old, and at university, so I am forced to use command-line compilers and freeware 

programming languages, and there were no genuinely free programmer's text editors our there (well, none that 
were any good, anyway), so here is SynEdit. It has been released for the benefit for students and developers alike, 
and I hope that    it proves to be useful. 

I, Matthew Inman, can be contacted at developer@syned.com. If you have any queries, bug reports, 
suggestions or complements, I'd be glad to hear from you. While I do not request a registration fee, I'm really 
interested to find out where my software is going, and what you're using it for. 

SynEdit is Copyright © Matthew Inman 1999.



Reusing Files as Cliptext Libraries
You can export any text file as a cliptext library by selecting the Export as Cliptext Library command in 

the File menu. Once exported, the filename of the library appears in the "ClipText Libraries" list on the cliptext pane 
to the right of the main window, and will appear in the \CLIPTEXT\ subdirectory of the SynEdit folder. Each line in a 
text file becomes one item in a cliptext library. 
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Indenting and Unindenting Text
To indent or unindent the selected text, use the Indend Selection and Unindent Selection commands in 

the Format menu. Indenting a selection adds four spaces to the beginning of each line spanned by the selection, or 
the current line if there is no selection. Unindenting a selection reverses this effect.
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Opening Image Files
SynEdit lets you open image file for editing by passing the file to your currently associated editor for images

of type .BMP, .GIF and JPG. For this menu item to function you must have a correctly associated image editor (eg. 
Windows Paint, Photoshop) installed on your computer system.
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Accessing the Editor Options Dialog
The Editor Options dialog may be accessed from the Preferences submenu within the File menu. It can 

also be accessed from the Editor Options toolbar button (  ). 
The Editor Options dialog contains all of the options governing the behavior of the editor. The various areas

of the editor's operation are separated and spread over a number of tabs:
· The Keywords Tab
· The Delimiters Tab
· The Editor Setup Tab
· The Color Setup Tab
· Setting SynEdit up Using Default Profiles
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The Keywords Tab
To specify which keywords you wish SynEdit to highlight, you must configure the Keyword lists. You can do 

this by adding individual keywords to the lists manually, using the Add Keyword button, which adds a keyword to 
the current list. To select which list you are currently working on, click on the matching sub-tab, which are marked 
Keyword List 1, Keyword List 2 and Keyword List 3. 

Alternatively, you can import Keyword Lists using the Import Keyword List function. These are files with 
the .kwd extension. They are plain text files, containing one keyword per line. As the import filter scan through the 
file, it adds each keyword or phrase on each line to a keyword list, starting with Keyword List 1. When the filter 
encounters the sequence \NL\ in the file, it switches to the next keyword list. All items subsequent to this label are 
added to Keyword List 2, and the next \NL\ encountered causes the following keywords to be added to Keyword 
List 3. Any extra \NL\ labels are ignored. 

SynEdit comes with a number of pre-generated keyword list files, and you can also export your own 
Keyword files using the Export Keyword button. This saves you the trouble of manually writing the keywords up in 
a keyword file if you want to use them later. Also, to reuse editor settings for various programming languages, see 
how to use Default Profiles.
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The Delimiters Tab
In much the same manner as SynEdit color codes identifiers using keywords, programmer's remarks can 
also be highlighted, as well as things like string literals and HTML tags. Checking a box for a specific type 
of delimiter specifies that you wish SynEdit to color everything between two delimiting characters a certain 
color (eg, for HTML tags, you want SynEdit to highlight everythin between < and >).    You can specify up to 
8 sets of delimiters, each with its own hilighting color. 

NOTE: Many files have line-based comments. To have SynEdit highlight from a starting token to the end of the 
line, specify \n (backslash 'n').
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The Color Setup Tab
This tab lets you specify what colors you want the keywords in your three lists to be given, as well as any 

text between delimiting characters.
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The Editor Setup Tab
This tab contains all of the other particulars of the editor's appearance. You can select a window font and 

size, although it its recommended that you use one of the non-proportional screen fonts that ship with Windows, 
such as FixedSys and Courier. 

The other options on this tab are:
· Tab Width - Instead of inserting a TAB character when you press TAB, SynEdit inserts the number of 

space characters specified here. This setting also specifies the number of spaces inserted and removed 
from the beginning of lines when you use the Indent and Unindent formatting functions.

· Code Keywords First, then Delimiters - This specifies which you want color coded first. When this box is 
checked, SynEdit color codes keywords on its first pass, then coded delimiters. Unchecked, delimiters are 
color coded first, then keywords. This is important for some languages. In HTML, you would code delimiters
first, to differentiate tags from displayable text, and keywords second, so that the tag attributes can be 
readily identified. Meanwhile, in C++, you would want to code keywords before delimiters, so that keywords
don't crop up in comment blocks.

· Save Backups when Files are Opened - Specifies whether you want to have a backup of any opened 
files. 

· Color Code Files Automatically - This specifies whether you want SynEdit to regularly color code the 
ENTIRE document (it will color code each line as you type regardless of this setting). This can take up to 
about 30 seconds for large files, and can prove to be unacceptable. If your source files are over 100K in 
size, you might want to consider disabling this option.

· Wordwrap to Window Edge - Sets whether or not to wrap text at the edge of the document window. This 
setting affects the behavior of the Go to Line function, and causes the Indent/Unindent Selection 
formatting options to create possibly undesirable effects.
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Go to Line
Jumps to the line specified and highlights it, if it exists within the file. This function is affected by the 

Wordwrap setting, as it works on the lines actually displayed on screen, not in terms of carriage-returns and 
linefeeds.
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For God's Sake, Please Don't do These Things
When SynEdit is installed on your machine, the setup program will create three directories: CLIPTEXT, 

TEMPLATE and PROFILES. DO NOT DELETE THESE DIRECTORIES AS YOU WILL BUGGER THE PROGRAM.
If you do just so happen to delete them inadvertently, simply create them again. Furthermore, DO NOTE DELETE 
THE DEFAULT PROFILES IN THE PROFILE DIRECTORY. These are important to the program's operation.

Also, dragging and pasting pictures into you code is allowed, but any images you insert will NOT be saved 
unless you export files as RTF. 

Setting the page margins so that there is no actual printable area will result in your printer endlessly spitting
out blank pages until it is switched off, or the document is deleted from the spooling que. 
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Known Bugs and Limitations
Known Bugs:

There are no known bugs at the time of this release!

Minimum System Specs:
· Requires WIn 95/98/NT4
· I Recommend you run this program on a Pentium 100, minimum.
· 16MB RAM absolute minimum, 32MB recommended.

Limitations:
· Can only open files to limit of physical and virtual memory, or 2GB, whichever comes first.
· Estimated maximum of 255 files open at once. Usually less, unless you've got 128mb of RAM.
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Toolbar Buttons
The Toolbar provides you with quick access to the most commonly used features of SynEdit. 
New
Open
Save
Save All
Copy
Cut
Paste
Undo
Indent
Unindent
Raise Case
Lower Case
Capitalize First
Find
Replace
Refresh Color Coding
Editor Options
Run Compiler/Viewer
Configure Compiler/Viewer
Load in Default Viewer
Help Contents
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Printing Files
SynEdit provides limited support for you to print your color coded program code. Select the Print option in 

the File menu to print your entire source file. You can make chages to your printer settings by selecting Print Setup 
frm the File menu, and you can adjust the margins of your page by selecting the Page Setup item under the File 
menu.
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AutoCompleting Words
Synedit can be setup to automatically replace common spelling and typing errors (eg. recieve -> receive), 

as well as to replace simple mnemonics with larger blocks of text when entered. You can do so using the Phrase 
Autocomplete item in the Preferences submenu, under the File menu.

· To add a phrase or mnemonic to complete to the list, select the Add Phrase button. This will open a 
dialog that will prompt you for the phrase to be automatically completed and what to replace it with.

· To remove a phrase or mnemonic from the list, select the Remove Phrase button. This will remove the 
currently highlighted item.

· To change the replacement text for a phrase or mnemonic, select the Edit Phrase button. This will let 
you edit the replacement text for that phrase.
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Configuring the Utilities Menu for quick application launching
To access commonly used applications from SynEdit, the Utilities menu can be configured to hold jumps to 

20 different programs. To add and remove programs from the Utilities menu, select the Configure Utilities item 
from the Utilities menu. This will display the Configure Utilities options dialog.

· To add a utility to the list, select the Add Utility button. This will add an application to the list.
· To remove a utility from the list. select the Remove Utility button. This will remove the selected item 

from the list.
· To edit a utility's command line, select the Edit Utility button to edit that utility's command line string.
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Configuring SynEdit to recognize different languages
SynEdit automatically recognizes files from the languages C, C++, HTML, Java and Perl based on the file 

extensions of these files. However, if you want to add new languages or file types to the list of those that SynEdit 
recognises, you can use the Language Recognition dialog, in the Preferences submenu. This lets you associate 
certain file extensions with the preconfigured syntax profiles that have been created earlier. You can create your own
Syntax Profiles by using the Create New Language Profile menu item under the    Advanced menu.

Once a file extension is associated with a syntax profile, SynEdit will use the new syntax profile for color 
coding the contents of files with the specified extensions. File extensions that SynEdit does NOT recognize are 
highlighted according to the editor's current scheme in effect. To set the default setup for unknown file types, use the
Editor Options dialog, also under the Preferences submenu.
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Setting Synedit up for a New Language
To customize SynEdit for use with a new programming language, you need to create a new Syntax 

Profile. You can do this using the Export Settings as Profile function in the Editor Options dialog box, or you can 
select Create Language Profile frm the Advanced menu. All you need to do is provide the keywords to be 
highlighted, delimiters, and the color setup for your language.

To enable SynEdit to automatically highlight files of this new language type, use the Language Recognition 
command in the Advanded menu. This allows you to assign certain language profiles to files that you open with a 
specific file extension. 
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Creating New Language Profiles
To give SynEdit capability to hilight a new language, you can use the Create New Language Profile 

command, under the Advanced menu. This lets you specify the keywords and delimiters that the language requires 
highlighted. Once you have created a new profile, you can configure SynEdit to automatically recognise files of this 
new type using the Language Recognition dialog, which you can access from the Preferences menu, beneath the
File menu.
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