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To create hypergraphics you use Hotspot Editor, an application that lets you open any 
standard Windows bitmap or metafile and add hot spots to it. You can then save the bitmap 
in hypergraphic format, with the picture and hot spots combined. Using Hotspot Editor, you 
can define hot spots that link to other Help topics and graphics, that execute a Help macro, 
or that access multimedia events (if provided for by external DLLs). After you create a 
hypergraphic and save it with Hotspot Editor, you can add it to Help topics exactly like any 
other bitmap. The only restriction is that hypergraphic files produced by Hotspot Editor must
be included by reference using the bmc, bmr, or bml format. 

Although you can create similar effects in the Help file by carefully creating and positioning 
several individual bitmaps next to each other and formatting each of them as hot spots, 
Hotspot Editor is more efficient and much easier to use. Using several bitmaps to simulate a 
single-image hypergraphic also has the drawback of requiring Help to perform multiple 
locating operations when displaying the topic. Usually this means Help must read the disk 
several times, slowing overall performance, especially on CD-ROM.



Add Hotspots 

Add Hotspots
After opening an image file in Hotspot Editor, you can create hot spots that link to text, 
graphics, or multimedia events. You insert hot spots to the areas of the picture that you want
to be hot, just as you determine what text you want to be hot in the topic files. For example, 
you might want to make a button in a screen shot a hot spot that creates a pop-up window 
when the user chooses the hot spot.
For each hot-spot you add to an image, you follow the same two steps.

To add a hot spot

 1. Draw the hot spot rectangle on top of the image. This defines the region that the user 
will click to activate the hot spot.

 2. Define the properties for the hot spot. This determines what action Help will take when 
the user choose the hot spot.

Drawing Hot Spots
A hot spot can be any rectangular area of the graphic image. Defining a hot spot is similar to
drawing a rectangle in a draw or paint program.

To draw a hot spot on an image
 1. Position the mouse pointer on the bitmap where you want to define a hot spot and 

press the left mouse button. This creates the anchor for one corner of the hot-spot 
rectangle.

 2. While holding down the left mouse button, drag the mouse until the rectangle encloses 
the area you want to define as the hot spot. A flexible box stretches from the anchor 
point to the position of the mouse pointer, expanding and contracting as you move the 
mouse.

 3. When you are satisfied with the size of the hot-spot rectangle, release the mouse 
button. After you release the mouse button, the hot-spot rectangle displays eight sizing 
handles, indicating that it is the currently selected hot spot. You can use the sizing 
handles to resize the rectangle.

You can draw hot spots so that they overlap each other; however, in the built Help file, only 
the top most hot spot is active in a stack of overlapped hot spots.



Create Tabbing Order 

In the built Help file, users can select the hot spots either with the mouse or with the 
keyboard. When using a keyboard, users press the TAB key to move from one hot spot to the
next. This is called the tabbing order. 
Hotspot Editor creates the tabbing order in the same order that you create the hot spots 
within the graphic.

To create a specific tabbing order
Define each hot spot in the same order you want users to follow in the built Help file.

Viewing the Tabbing Order
After you have created one or more hot spots, you can view the tabbing order by using the 
Select command on the Edit menu.

To view the tabbing order in a hypergraphic

From the Edit menu, choose Select.

The Select dialog box appears, listing all the defined hot-spots in the hypergraphic. The hot 
spots are displayed in the order in which they were created, with the first hot spot at the top 
of the list box.

Changing the Tabbing Order
If you have already created hot spots in a hypergraphic, and later you want to change the 
tabbing order, you can use commands on the Edit menu to do so.

To change the tabbing order
 1. From the Edit menu, choose Select. The Select dialog box appears with the hot spots 

listed in the current tabbing order

 2. Select the hot spot that you want to move to the top of the tabbing order.

 3. . Choose the Select button. The hot-spot rectangle displays eight sizing handles, 
indicating that it is the currently selected hot spot.

 4. From the Edit menu, choose Delete. Or press the DEL key. The hot spot is deleted.

 5. From the Edit menu, choose Undo. The hot spot is restored to the hypergraphic, and it is
moved to the top of the tabbing order. To view the new tabbing order, use the Select 
command.

From the Edit menu, choose Select to view the new tabbing order.

The selected hot spot is at the top of the tabbing order.

Note: If you did not assign unique identifiers to each hot spot, it may be impossible to tell 
that the tabbing order has changed.

 6. Repeat steps 1-5 to move another hot spot.



Hotspot Attributes 

Hotspot Attributes
After creating a hot spot, you must define its attributes in the Attributes dialog box. Hot-spot
attributes include binding information for the hot spot, the hot-spot name, and the bounding 
box coordinates.
 
The following describes the hypergraphic attributes.

Context String
Specifies binding information for the hot spot, in the form of a context string or a macro.

Type
Indicates the type of action to be taken when the user chooses the hot spot. The four 
binding types are pop-up, jump, macro, and searchable.

Attribute
Specifies whether the hot spot is to be visible or invisible when displayed to the user in the 
Help window. Hot spots are always visible in Hotspot Editor.

Hotspot ID
Specifies a unique identifier for the hot spot. The hot-spot name is used internally by 
Hotspot Editor to make it easier to identify hot spots in the Select dialog box. Hotspot Editor 
assigns an incremental number to the hot-spot name; however, you can type your own 
unique name.

Bounding Box Coordinates
Displays the coordinates for the hot-spot rectangle: left, right, top, and bottom. The 
coordinates are measured in pixels and are restricted to the size of the graphic image.
To define attributes for a hot spot
 1. Select the hot spot and choose Attributes from the Edit menu. Or click the hot spot with 

the right mouse button. Or double-click the hot spot with the left mouse button. Or 
select the hot spot and press ENTER. The Attributes dialog box appears .

 2. Complete the Attributes dialog box and choose OK. The attributes defined for the hot 
spot appear in the Hotspot Editor status bar. For more information about each attribute, 
see the preceding attributes table.

 3. Repeat this process for each hot-spot region that you want to define.

To define a jump hot spot
 1. From the Type list, choose Jump.
 2. In the Context String box, type the context string of the topic Help jumps to when the 

user chooses the hot spot.
 3. Choose OK.

To define a pop-up hot spot
 1. From the Type list, choose Pop-up.
 2. In the Context String box, type the context string of the topic that Help displays in the 

pop-up window when the user chooses the hot spot.



 3 Choose OK.

To define a macro hot spot
 1. From the Type list, choose Macro.
 2. In the Context String box, type the macro (or macros) that Help executes when the user

chooses the hot spot. For a Help macro, type the macro.
 3. Choose OK.

To define a searchable hot spot
 1. From the Type list, choose Searchable.
 2. In the Context String box, type the keyword (or keywords) that you want to associate 

with this hypergraphic. Separate each keyword with a semicolon.
 3. Choose OK.

To define the appearance of the hot spot
 1. Choose Visible or Invisible for the binding attribute. Visible hot spots are outlined in black 

or are displayed in inverse video.
 2. Choose OK.

To change the default name assigned to the hot spot
 1. In the Hotspot ID box, type the name you want to assign to the hot spot. This name 

helps you identify the hot spots in the graphic if you use the Select command 
(described in the next section). If you don't enter a hot-spot name, Hotspot Editor 
appends a number at the end of the name Hotspot.

 2. Choose OK.

To change the size or location of the hot spot
 1. Edit the bounding box values. The numbers used in the bounding boxes represent 

pixels.
 2. Choose OK.

Setting Preferences
When you define a hot spot, Hotspot Editor uses the binding information and hot-spot 
identifier stored in the Preferences dialog box. To change the default values, edit them. 
Setting your own preferences for hot-spot attributes saves time and effort when creating 
hypergraphics that require settings different from Hotspot Editor's internal defaults. Hotspot 
Editor assigns the attributes you enter to subsequent hot spots created with these 
preferences.

The following table shows the default setting for each attribute.

Field Default entry
Context String (Empty)
Type Jump
Attribute Invisible
Hotspot ID Hotspot

To change Hotspot Editor preferences

 1. From the Edit menu, choose Preferences.



 2. In the Context String box, type a context string or macro.
 3. Select the binding type.
 4. Select the binding attribute
 5. Type a hot-spot name. This entry affects only the hot-spot name. Hotspot Editor 

continues to assign numbers incrementally to each new hot spot.
 6. Choose OK.



Editing Hotspots 

After you create a hot spot, you can select it for editing and then cut, copy, paste, delete, 
resize, or move it. When editing hot spots, all attributes defined for the hot spot remain with 
the hot spot.

Selecting Hot Spots
A selected hot spot contains eight sizing handles that you can use to resize the hot-spot 
rectangle.

To select a hot spot
Click the hot spot with the left mouse button.
Or press TAB or SHIFT+TAB until you select the hot spot you want.

To select a hot spot using the Select command
 1. From the Edit menu, choose Select. The Select dialog box appears. All hot spots defined 

for the hypergraphic appear in the Hotspots box. By default, Hotspot Editor does not 
select a hot spot in the list unless one was selected before choosing the Select 
command. In that case, Hotspot Editor highlights the currently selected hot spot.

 2. In the Hotspots box, select a hot-spot name. Hotspot Editor displays the binding 
information for the selected hot-spot name.

 3. Choose the Select button. The hot spot shows eight sizing handles to indicate that the 
hot spot is selected.

Deleting Hot Spots
To delete a hot spot:
 1. Select the hot spot.
 2. From the Edit menu, choose Delete. Or press the DEL key.

Cutting or Copying Hot Spots
Hotspot Editor lets you transfer hot spots to and from the Clipboard using the Cut, Copy, and
Paste commands on the Edit menu. Transferring hot spots is useful to:

Create multiple versions of the same hot spot with the same attributes.
Move a hot spot from one image file to another.
Save time when repeatedly defining hot spots in a hypergraphic.

To cut or copy a hot spot to the Clipboard
 1. Select the hot spot.
 2. From the Edit menu, choose Cut or Copy. Hotspot Editor transfers the selected hot spot 

to the Clipboard using Hotspot Editor's proprietary clipboard format.

Pasting Hot Spots
You can paste images or hot spots from the Clipboard into Hotspot Editor. Pasting an image 
is the same as opening the file. If you paste a hot spot, Hotspot Editor pastes it in the upper-
left corner. You can paste a hot spot into the same image file or another image file.

To paste a hot spot:
From the Edit menu, choose Paste.
The hot spot is pasted in the upper-left corner of the hypergraphic being edited.



Moving Hot Spots
After you create a hot spot, you can move it anywhere within the current image area.

To move a hot spot:
 1. Select the hot spot.
 2. Position the mouse pointer in the center of the selected hot spot. The pointer changes 

to a hand, indicating that you can move the hot spot.
 3. Drag the hot spot to the new location and release the mouse button when the hot spot 

is where you want it. The hot-spot sizing handles disappear while dragging and 
reappear when you release the mouse button.

Resizing Hot Spots
The eight sizing handles on a hot spot let you change its size the same way you change the 
size of a window.

To resize a hot spot:
 1. Select the hot spot.
 2. Position the mouse pointer on the sizing handle on the border or corner that you want 

to change. The pointer changes to a two-headed arrow.
 3. Drag the sizing handle until the rectangle is the size you want. If you drag a side 

handle, the rectangle changes size on only one side, the side of the border you drag. If 
you drag a corner, the two adjoining sides that form the corner change size at the same
time.

 4. Release the mouse button.



Saving Hypergrapic 

After you have defined all the hot spots and made all your changes to the image, you save it
as a hypergraphic.

To save a hypergraphic
From the File menu, choose Save As to save the file with hot spots using the .SHG filename 
extension provided by Hotspot Editor.

Hotspot Editor saves your graphic with the appropriate hot-spot coding. You can now include
this graphic in your Help file using a bmc, bml, or bmr reference.



Edit and Replace Images 

Sometimes you will create a hypergraphic and then discover that you need to change the 
original picture used in the hypergraphic. Since you cannot use Hotspot Editor to change the
graphic, you must use the graphics application that created the original image. 
However, after an image has been saved as a hypergraphic (.SHG file), it cannot be opened 
again in the original graphics program. Because Hotspot Editor does not alter the original 
bitmap or metafile when creating the hypergraphic, you can edit the original bitmap (.BMP) 
or metafile (.WMF) in the graphics program and then re-import it into Hotspot Editor after 
you have made your changes.

To edit or replace the bitmap in a hypergraphic
 1. Open the original bitmap or metafile in the graphics application you used to create the 

image. Or create a new bitmap for the hypergraphic.
 2. Make your changes to the image.
 3. Save the edited image in the graphics application.
 4. Copy the image to the Clipboard.
 5. Start Hotspot Editor and open the hypergraphic that contains the graphic you want to 

replace.
 6. From the Edit menu, choose Replace.    The new or edited graphic replaces the original 

bitmap.

Note:
If the new image is smaller than the original graphic included in the hypergraphic, Hotspot 
Editor may move the hot spots to ensure that they are still on top of the image.

 7. Save the changes to the hypergraphic. 






