Nabídka Okno

Window (Okno)

Podnabídka Window (Okno) na hlabní nabídce nabízí následující volby:

  • Cascade (Kaskáda) - uspořádat okna jedno přes druhé do kaskády (zkuste Shift+F5 , abyste viděli, co to znamená)
  • Tile vertical (Dlaždice svisle) - uspořádat okna vertikálně jako dlaždice (zkuste Shift+F4 , abyste viděli, co to znamená)
  • Tile horizontal (Dlaždice vodorovně) - uspořádat okna jako dlaždice vodorovně
  • Classic (Klasické uspořádání) - uspořádat okna způsobem známým z raných verzí SuperMemo , tj. s okny statistik vhodně srovnanými s oknem prvku . Toto uspořádání je užitečné, provádíte-li opakování a chcete trvale sledovat pokrok v učení. Toto uspořádání můžete uložit jako trvalé pomocí Layout (Rozložení): Save as default (Uložit jako výchozí) (viz níže). Můžete také požádat SuperMemo, aby okna uspořádalo tímto způsobem jen při spuštění opakování. Pro tento účel zatrhněte Classic layout at learning (Klasické rozložení při učení) dostupné na Tools (Nástroje) : Options (Volby) : Learning (Učení)
  • Layout (Rozložení)
    • Save as default (Uložit jako výchozí - uložit aktuální rozložení oken jako výchozí (default) rozložení. Při každém spuštění SuperMemo se toto rozložení použije
    • Restore default (Obnovit výchozí) - obnovit výchozí rozložení oken naposledy uložené pomocí Layout: Save as default (viz výše)
    • Program default (Programové výchozí rozložení) - obnovit výchozí rozložení oken používané programem SuperMemo při jeho prvním spuštění. Aby toto rozložení bylo trvalé, musíte použít Layout (Rozložení): Save as default (Uložit jako výchozí) (viz výše)
  • View (Zobrazit)
    • Toolbar (Nástrojový panel) - zobrazit nebo skrýt nástrojový panel
    • Speedbar (Rychlý nástrojový panel) - zobrazit nebo skrýt tento panel
    • Status bar (Stavový pruh) - zobrazit nebo skrýt stavový pruh
    • Hints (Popisky) - zapnout nebo vypnout zobrazení popisků
  • Next (Další) - aktivovat následující okno na pracovní ploše SuperMemo
  • Previous (Předchozí) - aktivovat předchozí okno na pracovní ploše SuperMemo
  • Arrange icons (Uspořádat ikony) - uspořádat ikony na pracovní ploše SuperMemo.

****


Přidat nový prvek

Obsah : Technický popis : Okno prvku
Přidat nový

Tlačítko Přidat nový na spodní straně obrazovky umožňuje přidávat do SuperMemo novou látku k učení (nové prvky).

Kliknete-li na Přidat nový (Add new), SuperMemo přidá do vašeho systému vědomostí nový prvek a vytvoří dvě editační pole: jedno pro otázku a druhé pro odpověď. Do těchto polí můžete napsat své vlastní texty.

Stisknete-li Esc, budete moci vidět nove vytvořený prvek tak, jak se bude objevovat při opakováních .

Mezi editací otázky a odpovědi můžete přepínat pomocí Ctrl+T . Můžete také rychle přepnout na editaci otázky stisknutím Q nebo na editaci odpovědi stisknutím A. Stisknutím Esc se editace ukončí.

Profesionální úroveň

Chcete-li jít dál než k jednoduchému režimu otázek a odpovědí, můžete si nadefinovat šablonu (template) , která bude určovat vzhled nově vytvořených prvků (např. font, barvu, velikost, počet a typ komponent atd.).

Chcete-li použít víc než jednu šablonu pro různé větve svého stromu vědomostí , přečtěte si stránku o kategoriích .


Advanced English 97

Obsah :

Advanced English 97 na 2 CD-ROM

Úvod

Advanced English je studijní materiál ve tvaru otázka - odpověď, navržený pro studující anglické slovní zásoby a gramatiky. V kombinaci se SuperMemo je to pravděpodobně nejlepší a nejrychlejší cesta k dokonalému zvládnutí angličtiny přesahujícímu jazykové znalosti průměrných rodilých mluvčích. Advanced English si můžete objednat na dvou CD-ROM u distributora pro Českou republiku

Historie

Advanced English je vlastní materiál vyvinutý v SuperMemo World z hlediska používání SuperMemo . Systém byl poprvé realizován v osmi částech v roce 1992 jen jako textová verze pro SuperMemo 6. V roce 1993 byl vydán jako jeden kus obsahující 35 000 položek a navržen pro použití se SuperMemo 7. V roce 1994 byla zlepšená verze vybavena 25 000 zvukovými nahrávkami a vydána na CD-ROM.

V dalších letech byla Advanced English soustavně vylepšována prostřednictvím nových jazykových konstrukcí a přizpůsobena pro používání se SuperMemo 8. Všichni uživatelé předchozích verzí by měli ocenit nové vydání, i když již probrali podstatnou část AE 1994.

Vlastnosti

  1. 40 000 položek modernizovaného lexikografického materiálu s novými oblíbenými frázemi, jako jsou např.: network computer, website, HTML, CDR, DVD, Prozac, taxol, Ecstasy, rowbike, mad cow disease a mnoho jiných.
    1. Přístup k jednotlivým položkám: (1) podle lexikální kategorie, (2) pomocí vyhledání podřetězce, (3) abecední, (4) podle priority položek v procesu učení, (5) podle obtížnosti položky a mnoho jiných.
    2. Systém je možno libovolně editovat a rozšiřovat vkládáním textů, překladů, zvuků, poznámek, fonetického přepisu a mnoha jiných komponent.
    3. Kategorizace látky do stromu vědomostí s hlavními kategoriemi: (1) Všeobecná angličtina, (2) Věda a technika, (3) Ekonomie, Právo a Politické vědy a (4) Kutura a historie. Například výraz excitatory synapse je možno najít podle kategorie v Advanced English: Sciences, Technology and Medicine: Medical Sciences: Physiology: excitatory synapse.
    4. Fonetický přepis obsahující 72 000 položek zapsaných pomocí mezinárodní fonetické abecedy IPA (registr přepisů je možno rozšiřovat a editovat).
    5. Okamžitý fonetický přepis při přesunu myši (program nahradí anglické texty jejich fonetickým přepisem pomocí IPA).
    6. Aktualizovaný zvukový materiál obsahující 27 000 nahrávek, z nichž více než 5 000 je zcela nových (americká výslovnost). Všechny zvuky jsou seřazeny v editovatelném zvukovém registru podle jména.
    7. Zvláštní sekce (systémy vědomostí) pro zkoušení výslovnosti, pravopisu a porozumění mluvenému slovu.
    8. Další vědomostní systémy, jako je English Grammar (anglická gramatika) atd.
    9. Všechny nové skvělé rysy SuperMemo 8 , jako jsou: prohlížení položek náležejících do určité kategorie, náhodné zkoušení podle kategorií, náhodné učení, filtry položek, operace s rozsahy a podmnožinami položek, přidávání uzlů, ordinální čísla položek, cesta k položce atd. včetně všech vlastností dřívějších verzí SuperMemo 7
    10. Příjemný grafický a místy i hudební doprovod.
    11. Uživatelé v České republice dostávají systém s překladem cca 2000 položek do češtiny, u nichž je možno získat okamžitý překlad přesunutím myši. Překladový soubor bude průběžně rozšiřován.
  • Obsah AE 97

    Kromě toho, že Advanced English obsahuje přes 20 000 položek všeobecné angličtiny, klade velký důraz i na vědu, techniku, medicinu, podnikání a ekonomii. Pokrývá prakticky všechny oblasti a jazykové aspekty, které by měl znát moderní vzdělaný člověk. Hlavní kategorie v Advanced English jsou:

    •
      • všeobecná angličtina: přes 20 000 položek
      • lékařské vědy 2500
      • idiomy a přísloví 2000
      • technika 1300
      • podnikání a hospodářství 1200
      • zoologie 900
      • slang 800
      • informatika 700
      • sport 600
      • gramatika 500
      • hovorová angličtina 500
      • chemie 400
      • humorná angličtina 400
      • potraviny 400
      • urážlivá angličtina 400
      • matematika 400
      • vojenská technika 400
      • botanika 400
      • frázová slovesa 400
      • náboženství 400
      • zeměpis 400
      • politické vědy 300
      • zemědělství 300
      • hudba 300
      • další kategorie, např.: geologie, britská angličtina, přejatá slova, telekomunikace, fyzika, architektura, užitečné fráze, metrické jednotky a čísla, nepravidelná slovesa, množná čísla, eufemizmy, zkratky, antonyma, literatura, historie a další.
  • Objednávka Advanced English 97

    Pošlete svou objednávku na adresu ELK, Generála Píky 3, 613 00 Brno, tel. 05-529912, fax 529911, e-mail elk@supermemo.cz .

    Další články

    Build your vocabulary with SuperMemo (Wozniak, Biedalak, Spotlight 1996)

    •


Analýza procesu učení

Obsah : Technický popis : Hlavní nabídka: Statistika: Analýza
Analýza procesu učení

Dialogový panel dostupný z Tools : Statistics: Analysis v SuperMemo poskytuje matice a grafy, které ilustrují aktuální stav procesu učení v právě otevřeném systému vědomostí. Některé z těchto grafů je možno chápat i bez znalosti Algoritmu SM-8 ; avšak většina z nich vyžaduje všeobecné znalosti o tom, jak SuperMemo vypočítává optimální intervaly mezi opakováním.
Na nabídce Analysis jsou dostupné následující karty:

Distributions (Rozdělení)

  • Interval distribution (Rozdělení intervalů) - rozdělení intervalů mezi opakováními u daného systému vědomostí

    A-Factor distributio n (Rozdělení A-faktorů) - rozdělení A-Faktorů v daném systému vědomostí (všimněte si, že rozdělení samotné se v Algoritmu SM-8 nepoužívá, pouze výsledky z něho)

    Repetitions distribution (Rozdělení opakování) - rozdělení počtu opakování v daném systému vědomostí (berou se v úvahu jen probrané prvky , tj. neexistuje kategorie s nulovým počtem opakování)

    Lapses distribution (Rozdělení selhání) - rozdělení počtu selhání (zapomenutí) jednotlivých prvků systému vědomostí (v úvahu se berou jen probrané prvky ).

    •

    Curves (Křivky) - pro výpočet matice RF je nezávisle vyneseno čtyři sta křivek. Ty odpovídají dvaceti kategoriím počtu opakování vynásobených dvaceti kategoriemi A-Faktorů (všimněte si, že pro první opakování jsou sloupce matice RF indexovány podle počtu selhání paměti místo A-Faktoru). Volbou správné karty na spodním okraji grafu můžete vybrat křivku zapomínání, o kterou se zajímáte. Vodorovná osa představuje čas vyjádřený jako: (1) U-Faktor, tj. poměr po sobě následujících intervalů mezi opakováním nebo (2) počet dnů (jen v případě prvního opakování). Svislá osa představuje retenci vědomostí v procentech.

    Modré kroužky představují opakování (čím větší je kroužek, tím větší je počet opakování). Červená křivka koresponduje s nejlépe odpovídající křivkou zapomínání získanou exponenciální regresí.
    Vodorovná zelená čára koresponduje s     požadovaným indexem zapomínání , kdežto svislá zelená čára zobrazuje časový okamžik, v němž se aproximovaná křivka zapomínání protíná s čarou požadovaného indexu zapomínání. Tento časový okamžik určuje hodnotu příslušného faktoru R. Hodnoty O-faktoru a R-faktoru jsou zobrazeny v horní části grafu. Za nimi následuje počet případů opakování použitý pro vynesení grafu.
    Všimněte si, že na začátku procesu učení neexistuje žádná historie učení a žádná data opakování, která by bylo možno využít pro výpočet R-faktorů. Z toho důvodu se počáteční hodnoty matice RF berou z Wozniakova modelu paměti a odpovídají parametrům paměti podprůměrného studenta (model průměrného studenta nebyl použit, protože konvergence od slabéhostudenta nahoru je rychlejší než konvergence v opačném směru).

    Grafy

  • G-FI graph - G-FI graph correlates the expected forgetting index with the grade obtained at repetitions. You can imagine that the forgetting curve graph might use average grade instead of retention on its vertical axis. If you correlated this grade with the forgetting index (which is 100% minus retention), you arrive at the G-FI graph

    G-AF graph - G-AF graph correlates the first grade obtained by an item with the ultimate estimation of its A-Factor value. At each repetition, the current element's old A-Factor estimation is removed from the graph and the new estimation is added. This graph is used by the Algorithm SM-8 to quickly estimate the first value of A-Factor at the moment when all we know about an element is the first grade it has scored in its first repetition

    DF-AF graph - DF-AF graph shows decay constants of power approximation of R-Factors along columns of the RF matrix. The horizontal axis represents A-Factor , while the vertical axis represents D-Factor (i.e. Decay Factor). D-Factor is a decay constant of power approximation of curves that can be inspected with the Approximations tab of the Analysis dialog box

    First interval graph - the length of the first interval after the first repetition depends on the number of times a given item has been forgotten. Note that the first repetition may also mean the first repetition after forgetting. In other words, a twice repeated item will have the repetition number equal to one after it has been forgotten (i.e. the repetition number will not equal three). The first interval graph shows exponential regression curve that approximates the length of the first interval for different numbers of memory lapses (including the zero-lapses category that corresponds with newly memorized items).

    •

    Matrices

  • O-Factor matrix - matrix of optimal factors indexed by the repetition number and A-Factor (only for the first repetition, A-Factor is replaced with memory lapses)

    R-Factor matrix - matrix of retention factors

    Cases matrix - matrix of repetition cases used to compute the corresponding entries of the RF matrix (double click an entry to view the relevant forgetting curve). This matrix can be edited manually

    Optimal intervals - matrix of optimum intervals derived from the OF matrix

    D-Factor vector - vector of D-Factor values for different A-Factor values (also repetition cases used in computing particular D-Factors)

    •

    3-D Graphs - 3-D graphs that visually illustrate the changes to OF, RF and Cases matrices

    Approximations - twenty power approximation curves that show the decline of R-Factors along columns of the RF matrix. For each A-Factor , with increasing values of the repetition number, the value of R-Factor decreases (at least theoretically it should decrease). Power regression is used to illustrate the degree of this decline that is best reflected by the decay constant called here D-Factor. By choosing the A-Factor tab at the bottom of the graph, you can view a corresponding R-Factor approximation curve. The horizontal axis represents the repetition number, while the vertical axis represents R-Factor. The value of D-Factor is shown at the top of the graph. The blue polyline shows R-Factors as derived from repetition data. The red curve shows the fixed-point power approximation of R-Factor (fixed-point approach is used as for the repetition number equal two, R-Factor equals A-Factor). The green curve shows the fixed-point power approximation of R-Factor taken from the OF matrix. This is equivalent to substituting the D-Factor obtained by fixed-point power approximation of R-Factors with D-Factor obtained from DF-AF linear regression.


Volby: Přidávání

Options (Volby): Appending (Přidávání)

Karta Appending (Přidávání) v Tools (Nástroje) : Options (Volby) poskytuje volby ovlivňující způsob přidávání nových prvků do souhrnu vědomostí:

  • Default item template (Implicitní šablona položky) - jméno šablony , která se použije pro vytváření nových položek přidávaných pomocí AddNew (Přidat nový) nebo Edit (Editovat) : Add a new item (Přidat novou položku) ( Ctrl+A ). Cjcete-li změnit vzhled nově přidávaných položek, můžete tuto šablonu změnit. Implicitní šablona závisí na právě vybrané kategorii vědomostí (každá kategorie má svou vlastní šablonu). Nejjednodušší způsob, jak změnit šablony přiřazené jednotlivým kategoriím, je tento:
    1. zvolte Tools (Nástroje) : Categories (Kategorie)
    2. dvakrát klikněte na pole Template (Šablona) náležející k dané kategorii
    3. vyberte šablonu v registru šablon
    4. zvolte Apply (Použít)
  • Chcete-li změnit implicitní šablonu položek pro jednu kategorii, můžete také zvolit tuto kategorii ve stahovacím seznamu na nástrojovém panelu a změnit Default item template (Implicitní šablonu položek) v Tools (Nástroje) : Options (Volby) : Appending (Přidávání)
    •
    • Default topic template (Implicitní šablona témat) - jméno šablony , která se používá pro vytváření nových témat přidávaných pomocí Edit (Editovat) : Add a new topic (Přidat nové téma)
    • Current hook (Aktuální kotva) - místo ve stromu vědomostí , kam se přidávají nové položky pomocí AddNew (Přidat nový) nebo Edit (Editovat) : Přidat novou položku ( Ctrl+A ). To je tzv. kotevní uzel aktuálně vybrané kategorte vědomostí (každá kategorie má svůj kotevní uzel)
    • Default font (Implicitní font) - font používaný v textových komponentách u nichž nebyl vytvořen nebo propojen žádný font (když poprvé spustíte SuperMemo, používá jen jeden font: implicitní font)
    • Children limit per contents node (Mezní počet dcer na uzel) - z důvodů výkonnosti SuperMemo umožňuje omezit počet prvků , které mohou být dcerami jednoho prvku v okně obsahu . Udržujete-li tento počet v rozsahu 20-100, můžete si být jisti, že váš souhrn bude možno snadno prohlížet a že prohlížení bude mnohem rychlejší než u větších uzlů.
    • Automatic category hook node change (Automatická záměna kotvy kategorie) Pokusíte-li se do jednoho uzlu přidat víc prvků než je číslo zadané v Children limit per contents node (výše), SuperMemo vás pomocí dialogového panelu Category change (Záměna kategorie) požádá, abyste vybrali novou kotvu pro přidávání položek. V tomto dialogovém panelu můžete SuperMemo požádat, aby pro vás vždy vybíralo kotvu automaticky. V takovém případě máte dvě možnosti:
      1. Záměna To terminal branches (na koncové větve) vybere nejvzdálenější uzel na spodku stromu vědomostí vyrůstajícího z kořenového uzlu . Jestliže poslední uzel již obsahuje víc dcer než je požadovaná mez, vezme se v úvahu jeho poslední dcera atd., dokud se pro nové prvky nenajde nějaké místo. Změna na koncové větve usnadňuje sledování historie přidávání nových položek, ale způsobuje "přetížení" spodní části stromu a zvýšení počtu úrovní ve stromě vědomostí
      2. Záměna To sparsiest branches (na nejřidší větve) vybere ten kořenový uzel , který má nejméně dcer. Jsou-li již všechny dcery zaplněny, vybere větev s nejméně potomky a vyhledává volná místa u jejich dcer. Změna na nejřidší větve vytváří optimální strukturu stromu vědomostí, avšak nebude možno vidět posloupnost, ve které byly položky přidávány. Budou rozptýleny v "koruně" stromu těžko předvídatelným způsobem. To sparsiest branches je implicitní volba
  • Pro usnadnění "růstu" stromu vědomostí nabízí SuperMemo v místní nabídce obsahu volbu Tools (Nástroje): Arrange in folders (Uspořádat do složek). Tato volba umožňuje vytvořit v dané větvi zvolený počet složek a položky do těchto složek rovnoměrně rozdělit. Složka zde znamená prázdný vynechaný prvek, který slouží jako zástupný prvek pro jiné položky
    •
    • Confirm category hook change (Potvrdit změnu kotvy kategorie) - rozhodnout, zda má SuperMemo při každém výskytu přetečení větve uživateli nabídnout dialogový panel Category change (Změna kategorie).


Prohlížeč

Prohlížeč prvků je okno s podmnožinou prvků uložených v právě otevřeném souhrnu vědomostí.

Když prohlížeč otevřete, umístí se vlevo a okno prvku bude vpravo. Tímto způsobem si můžete prohlížet jednotlivé prvky, když se výběr v prohlížeči mění (jen když je stisknuto synchronizační tlačítko).

Okno prohlížeče se skládá z následujících komponent:

  • Nadpis - jméno prohlížeče a počet prvků zobrazených v prohlížeči
  • Nástrojový panel umožňující přístup k nejčastěji používaným operacím prohlížeče
  • Seznam prvků - seznam prvků obsažených v prohlížeči s následujícími sloupci:
    • Sel (výběr) - kliknutím na toto pole se odpovídající řádek vybere (např. pro zařazení do nově vytvořené podmnožiny prvků). Vybraný řádek se označí znaménkem plus ve sloupci Sel. Výběry jsou užitečné při zpracování podmnožin prvků
    • No (počet) - počet prvků v prohlížeči
    • Title (nadpis) - nadpis prvku
    • Reps (počet opakování) - počet opakování věnovaných danému prvku (od posledního zapomenutí)
    • Laps (počet selhání) - počet případů, kdy byl daný prvek zapomenut
    • Intrv (interval) - aktuální interval daného prvku
    • LastRep (poslední opakování) - datum posledního opakování daného prvku
    • NextRep (příští opakování) - datum příštího opakování daného prvku
    • Ord - ordinální číslo daného prvku (např. používané při třídění (řazení) fronty čekajících prvků )
    • FI - index zapomínání přiřazený danému prvku
    • Type (typ) - typ daného prvku: téma nebo položka (viz též: Témata a položky )
    • ElNo - fyzické číslo daného prvku v souhrnu vědomostí

Podle některých polí je možno prohlížeč třídit (řadit). Chcete-li prohlížeč seřadit, klikněte na nadpis pole. Např. chcete-li jej seřadit podle data posledního opakování, klikněte na LastRep.

Profesionální úroveň

Pokročilé operace s prohlížeči jsou dostupné v místní nabídce prohlížeče , která je dostupná po kliknutí pravým tlačítkem.

***


Nabídka prohlížečů

Místní nabídka prohlížeče

Nejdůležitější operace prohlížečů prvků jsou dostupné z místní nabídky prohlížeče. Otvírá se stisknutím Alt+F10 nebo kliknutím pravým tlačítkem myši na okno prohlížeče .

Místní nabídka prohlížeče obsahuje následující volby:

  • View (Zobrazit) - zobrazí právě vybraný prvek v okně prvku
  • Search (Vyhledat)
    • Find (Najít) - najít první prvek v prohlížeči s názvem obsahujícím daný řetězec. Vyhledávání začíná prvkem následujícím za právě vybraným prvkem
    • Find next (Najít další) - opakuje poslední operaci vyhledávání Search: Find (např. pro vyhledání dalšího prvku s tímtéž řetězcem)
  • Subset (Podmnožina) - podmnožina operací (viz též: Použití podmnožin )
    • Select element (Vybrat prvek) - označit právě vybraný prvek jako součást podmnožiny . Označení se nejsnáze provede pomocí klávesy Ins . Označené prvky mají v levém sloupci znaménko plus. Později můžete označené prvky zpracovávat pomocí dalších voleb, např. Subset (Podmnožina): Save selection (Uložit výběr) nebo Child (Dcera): Selected (Vybrané)
    • Select all elements (Vybrat všechny prvky) - označit všechny prvky prohlížeče jako podmnožinu
    • Save selection (Uložit výběr) - uložit označené prvky do souboru podmnožiny (viz výše Select element)
    • Save all (Uložit vše) - uložit celý obsah prohlížeče do souboru podmnožiny
    • Select browser range (Zvolit rozsah prohlížeče) - označit všechny prvky v řádcích očíslovaných čísly v daném rozsahu. Například zadáte-li rozsah 10-20, prvky v řádcích 10 - 20 se označí jako součást podmnožiny
    • Select element range (Zvolit rozsah prvků) - označit všechny prvky s čísly z určitého rozsahu. Číslo prvku vyjadřuje fyzické umístění prvku v daném souhrnu vědomostí a používá se jako jednoznačný identifikátor prvku. Číslo prvku se zobrazuje ve sloupci ElNo
    • Unselect browser range (Zrušit výběr rozsahu prohlížeče) - zrušit pznačení všech prvků v řádcích očíslovaných čísly v daném rozsahu
    • Unselect element range (Zrušit výběr rozsahu prvků) - zrušit označení všech prvků s čísly z určitého rozsahu
    • Unselect-Subtract (Zrušit výběr - odečíst) - zrušit označení všech prvků patřících do určitého souboru podmnožiny
    • Unselect-Intersect (Zrušit výběr - průnik) - zrušit označení všech prvků, které nelze najít v daném souboru podmnožiny
    • Add subset file (Přidat soubor podmnožiny) - vytvořit nový prohlížeč jako součet aktuálního prohlížeče a souboru podmnožiny
    • Subtract subset file (Odečíst soubor podmnožiny) - vytvořit nový prohlížeč jako rozdíl aktuálního prohlížeče a souboru podmnožiny (tj, obsahující všechny prvky patřící do daného prohlížeče a nepatřící do souboru podmnožiny)
    • Intersect subset file (Průnik se souborem podmnožiny) - vytvořit nový prohlížeč jako průnik aktuálního prohlížeče a souboru podmnožiny (tj. obsahující všechny prvky náležející jak do prohlížeče, tak do souboru podmnožiny)
    • Delete (Vymazat) - vymazat soubor podmnožiny
  • Child (Dcera) - otevřít dceřinný prohlížeč s podmnožinou prvků uložených v právě používaném prohlížeči
    • Memorized (Probrané) - otevřít dceřinný prohlížeč se všemi probranými prvky obsaženými v aktuálním prohlížeči
    • Pending (Čekající) - otevřít dceřinný prohlížeč se všemi čekajícími prvky obsaženými v daném prohlížeči
    • Dismissed (Vynechané) - otevřít dceřinný prohlížeč se všemi vynechanými prvky obsaženými v daném prohlížeči
    • Selected (Vybrané) - otevřít dceřinný prohlížeč se všemi prvky, které jsou označeny znaménkem plus v levém krajním sloupci (viz výše Subset (Podmnožina): Select element (Vybrat prvek))
  • Sort (Seřadit) - seřadit prohlížeč podle daného sloupce
    • By title (Podle názvu) - seřadit prohlížeč abecedně podle názvů prvků
    • By element number (Podle čísla prvku) - seřadit prohlížeč podle čísel prvků (sloupec ElNo)
    • By ordinal number (Podle ordinálních čísel) - seřadit prohlížeč podle ordinálních čísel
    • By repetitions (Podle počtu opakování) - seřadit prohlížeč podle počtu opakování prvku
    • By forgetting (Podle zapomínání) - seřadit prohlížeč podle počtu selhání paměti , tj. počtu, kolikrát byl prvek zapomenut
    • By last repetition (Podle posledního opakování) - seřadit prohlížeč podle data posledního opakování
    • By next repetition (Podle příštího opakování) - seřadit prohlížeč podle data příštího opakování
  • Random (Náhodný výběr)
    • Random review (Náhodné prohlížení) - skočit na náhodně vybraný prvek v prohlížeči. Tato volba je užitečná při rychlém prohlížení látky obsažené v prohlížeči.
    • Random test (Náhodný test) - spustit náhodný test na obsahu prohlížeče. Všechny prvky se budou opakovat standardním způsobem, avšak opakování nebude mít vliv na proces učení
    • Random learning (Náhodné učení) - spustit náhodné učení prvků v prohlížeči. Probrané prvky nebudou ovlivněny, avšak čekající prvky budou probírány (učeny).
  • Process all (Zpracovat vše) - zpracovávat všechny prvky obsažené v prohlížeči např. probrat všechny čekající prvky, přesunout prvky ve stromě vědomostí atd.
    • Remember (Zapamatovat) - probrat všechny dosud neprobrané prvky v prohlížeči.
    • Forget (Zapomenout) - odstranit všechny probrané prvky z procesu učení a umístit je na konec fronty čekajících prvků
    • Dismiss (Vynechat) - vynechat všechny prvky v prohlížeči
    • Add to drill (Přidat do záv. procvičování) - přidat všechny prvky v prohlížeči do fronty závěrečného procvičování.
    • Move to branch (Přesunout do větve) - přesunout všechny prvky v prohlížeči mdo zvolené větve ve stromě vědomostí
    • Move to category (Přeunout do kategorie) - přesunout prvky v prohlížeči so zvolené kategorie obsahu
  • Export
    • Export as text (Exportovat jako text) - exportovat všechny prvky v prohlížeči jako textový soubor. Takový soubor je možno importovat do jiného systému vědomostí.
    • Transfer (Přenést) - přenést všechny prvky v prohlížeči do jiného systému vědomostí.
  • Tools (Nástroje)
    • Save pending (Uložit čekající) - uložit čekající prvky z prohlížeče do fronty čekajících prvků (tato volba je aktivní, jestliže používáte prohlížeč s obsahem fronty čekajících prvků). Tuto volbu můžete použít pro seřazení fronty čekajících prvků podle ordinálních čísel, podle názvu atd. Například pro seřazení fronty čekajících prvků podle čísel prvků: (1) zvolte View : Pending, (2) klikněte na sloupec ElNo a (3) zvolte Tools: Save pending na místní nabídce prohlížeče
  • Close (Zavřít) - zavřít prohlížeč

****


Nástrojový panel prohlížečů

Nástrojový panel prohlížeče

Nástrojový panel prohlížečů se zobrazuje na horním okraji okna prohlížeče :

Použití jednotlivých tlačítek:

  • Pop-up menu button (Tlačítko místní nabídky) - otevřít místní nabídku dostupnou také kliknutím pravým tlačítkem na oblast obsahu
  • Synchronize button (Synchronizační tlačítko) - zobrazovat odpovídající prvky v okně prvku při změně výběru v okně prohlížeče
  • Element align button (Tlačítko vyrovnat prvek) - vyrovnat okno prohlížeče s oknem prvku tak, aby bylo možno pohodlně prohlížet prvky v prohlížeči (všimněte si, že synchronizační tlačítko musí být pro tento účel stisknuto)
  • View button (Tlačítko zobrazit) - zobrazit právě vybraný prvek v okně prvku
  • Search button (Tlačítko vyhledat) - vyhledat texty ve sloupci nadpisu počínaje právě vybraným prvkem
  • Random jump button (Tlačítko náhodný skok) - skočit na prvek náhodně vybraný ze všech prvků v prohlížeči
  • Home button (Tlačítko domů) - skočit na první prvek v prohlížeči
  • End button (Tlačítko konec) - skočit na poslední prvek v prohlížeči
  • Filter button (Tlačítko filtr) - nastavit výchozí filtr pro prvky zobrazené v prohlížeči.

***


Kategorie-změna

Změna kategorie

Aby bylo zajištěno, že se výkonnost programu nesníží v důsledku nadměrného počtu dcer v jednom uzlu stromu vědomostí , SuperMemo poskytuje uživatelem definovaný parametr Tools (Nástroje) : Options (Volby) : Appending (Přidávání) : Children limit per contents node (Mezní počet dcer na uzel) . Nastavením této hodnoty můžete zajistit, že SuperMemo vás bude varovat, když překročíte stanovenou mez (můžete ji nastavit na hodnotu od 1 do 1000). Zdá se být rozumné nepřidávat do jednoho uzlu víc než několik položek, aby je bylo možno snadno prohlížet v okně obsahu . Pravděpodobně tedy nastavíte mez na 10-60.

Zvolíte-li jednu z voleb pro přidávání (např. Edit (Editovat) : Add a new item (Přidat novou položku) , SuperMemo zkontroluje počet dceřinných položek v aktuálním kotevním prvku kategorie a zobrazí dialogový panel Category Change (Změna kategorie), abyste mohli vybrat novou kategorii nebo nechali SuperMemo určit novou kotvu automaticky.

V dialogovém panelu Category Change můžete zvolit:

  • OK - chcete-li nechat SuperMemo vybrat novou kotvu automaticky. Nový kotevní uzel bude přirozeně potomkem kořene katagorie určeného pomocí Tools (Nástroje) : Categories (Kategorie)
  • Change limit (Změnit mez) - změnit mezní počet dcer na jeden uzel stromu vědomostí
  • Select node (Vybrat uzel) - ručně vybrat nový kotevní uzel v okně obsahu (zvolením Make hook (Vytvořit kotvu) v místní (kontextové) nabídce)

Chcete-li, aby SuperMemo vždy vybralo nový kotevní uzel automaticky, můžete zatrhnout políčko Do not show this dialog box (Nezobrazovat tento dialogový panel).

Zvolíte-li automatický výběr nového kotevního uzlu aktuální kategorie, měli byste vědět, že si můžete vybrat mezi dvěma režimy výběru nové kotvy:

  • výběr nové kotvy na nejřidším místě mezi potomky kořene aktuální kategorie ( Tools (Nástroje) : Options (Volby) : Appending (Přidávání) : Automatic category hook node change (Automatická změna kotevního uzlu kategorie: To sparsiest branches (Na nejřidší větve))
  • výběr nové kotvy na poslední větvi kořene aktuální kategorie, která nepřekračuje mezní počet dcer (Tools: Options: Appending : Automatic category hook node change: To terminal branches (Na koncové větve)).

****


Kategorie

Pracujete-li se souhrnem vědomostí, který obsahuje látku náležející do různých předmětů, budete pravděpodobně chtít mít různé předměty v různých sekcích stromu vědomostí (v okně obsahu ). Pravděpodobně také budete chtít navrhovat své položky jinak pro otázky z literatury a jinak pro otázky z matematiky.

Abyste mohli mít různé předměty odděleny, zavádí SuperMemo pojem kategorie . Kategorie je úsek stromu vědomostí v okně obsahu . Používá se pro uložení látky týkající se jednoho předmětu (oboru). Prvky přidávané do dané kategorie mohou používat svou vlastní šablonu , která určuje vzhled jednotlivých komponent , barvy, fonty, velikosti obrazů, počet zvukových komponent atd.

Zkuste vytvořit novou kategorii:

  1. vyberte větev ve stromě vědomostí v okně obsahu (např. na ni klikněte)
  2. stiskněte Ctrl+D (všimněte si změny ve stahovacím seznamu na hlavním nástrojovém panelu )
  3. stiskněte Ctrl+A , abyste mohli přidat první dceřinný prvek do své nové kategorie
  4. klikněte na Contents (Obsah) na horní straně okna prvku , abyste viděli, že nově přidaný prvek se stal prvním dceřinným prvkem v kategorii.

Kategorie vědomostí je charakterizována následujícími atributy:

  • category name (název kategorie) - název kategorie (např. Zeměpis)
  • default template (výchozí šablona) - šablona , která určuje vzhled prvků v kategorii
  • root node (kořenový uzel) - prvek , který je předkem všech prvků obsažených v kategorii (tj. všechny prvky v kategorii jsou potomky kořenového uzlu). Implicitně se jako název kategorie používá název kořenového prvku (např. Zeměpis)
  • hook node (kotevní uzel) - potomek kořenového uzlu (nebo kořenový uzel samotný), ke kterému se přidávají nové prvky jako dceřinné prvky pomocí Add new (Přidat nový) (nebo Ctrl+A ). Všimněte si, že Add new přidává prvky ke kotvě aktuální kategorie (jak byla vybrána ve stahovacím seznamu na hlavním nástrojovém panelu ). Jakmile počet dceřinných prvků v daném kotevním uzlu překročí definovanou mezní hodnotu, je zvolen nový kotevní uzel (buď uživatelem nebo automaticky programem SuperMemo). Podle definice je nový kotevní uzel vždy potomkem kořenového uzlu (nebo je s ním totožný).

Funkce Tools (Nástroje) : Categories (Kategorie) může být užitečná při spravování velkého počtu kategorií. Jednotlivé atributy dané kategorie tam mohou být měněny (název, šablona, kořen a kotva). Název kategorie je možno změnit (v Tools (Nástroje) : Categories (Kategorie)) napsáním nové hodnoty. Výchozí šablonu je možno změnit napsáním nového jména nebo dvojitým kliknutím na pole šablony a vybráním nové šablony z šablonového registru . Nové kořenové nebo kotevní uzly mohou být vepsány nebo vybrány z položek obsažených v textovém registru (včetně názvů). Všimněte si, že pohodlnější je určit kořenové a kotevní uzly pomocí voleb na místní nabídce obsahu : Create new category (Vytvořit novou kategorii) , Make hook (Vytvořit kotvu) a Make root (Vytvořit kořen) .

Tlačítka na spodní straně okna Kategorie mají následující funkce:

  • Add (Přidat) - přidat novou kategorii
  • Delete (Vymazat) - vymazat právě vybranou kategorii
  • Link (Propojit) - propojit novou hodnotu s právě vybraným polem v aktuální kategorii
  • OK - uložit změny v informačním souboru kategorie ( appnodes.dat v podadresáři info )
  • Cancel (Zrušit) - zrušit změny na atributech kategorie
  • Help (Nápověda) - zobrazit tuto stránku souboru nápovědy

Funkce Tools (Nástroje) : Categories (Kategorie) je nejužitečnější pro (1) vymazání kategorie, (2) změnu šablony kategorie a (3) změnu názvu kategorie.

Pro vytvoření nové kategorie je nejlépe použít Create new category (Vytvořit novou kategorii) na místní nabídce v okně obsahu . Také pro určení kořene a kotvy je lepší použít Make hook (Vytvořit kotvu) a Make root (Vytvořit kořen) na téže nabídce.

Typický způsob práce s kategoriemi:

  1. Zvolte větev v okně obsahu (tato větev se stane kořenem a první kotvou nově vytvářené kategorie)
  2. Zvolte Create new category (Vytvořit novou kategorii) ( Ctrl+D ) na místní nabídce obsahu
  3. Pro změnu výchozí šablony použijte Tools (Nástroje) : Categories (Kategorie) a dvojitě klikněte na Default Template (Výchozí šablona) (pro aktuální kategorii můžete použít také Tools (Nástroje) : Options (Volby) : Appending (Přidávání) : Default Item Template (Výchozí šablona položky))
  4. Pro změnu kategorie (např. chcete-li začít pracovat s Chemií místo Zeměpisu), zvolte novou kategorii ve stahovacím seznamu kategorie na nástrojovém panelu (stahovací seznam první zleva)

Jakmile pochopíte pojem kategorie, bude pro vás velmi snadné zvládat velký počet položek náležejících do zcela odlišných oblastí vědomostí.

****


Schránky-používání

Používání schránek

Schránky se používají jako dočasné paměti pro prvky a komponenty . Pracují podobně jako schránka Windows. Nejprve objekt umístíte do schránky a pak jej můžete libovolněkrát někam vložit. Když se program ukončí, schránky se vyprázdní. Všechny schránky mají tvar barevné popelnice umístěné na nástrojovém panelu. Když se schránka naplní, nafoukne se. Obsah schránek můžete prohlížet tak, že na ně nakrátko umístíte kurzor myši (jen když jsou zapnuty popisky). Schránku lze vyprázdnit Ctrl+kliknutím.

Na nástrojovém panelu jsou tři druhy schránek:

  • Schránka prvku (Element ClipBox)
  • Schránka komponenty (Component ClipBox)
  • Schránka hyperpropojení = hyperlinková schránka (Hyperlink ClipBox)

Schránka prvku se používá pro kopírování celých prvků. Pro umístění prvku do schránky použijte některou z následujících metod:

  • Stiskněte Ctrl a přetáhněte prvek do schránky. Před přetahováním musíte Ctrl-kliknout na prázdné místo prvku (kde není žádná komponenta), jinak by se přetáhla komponenta nebo by se spustila nějaká jiná akce.
  • Není-li v okně prvku žádné volné místo, můžete umístit prvek do schránky bez přetahování stisknutím tlačítka Move to ClipBox (Přesunout do schránky) na místní nabídce prvku

Chceteli duplikovat obsah prvku do jiného prvku, přetáhněte obsah schránky prvku na cílový prvek. Tato operace má podobný účinek jako Apply Template (Použít šablonu) nebo Duplicate (Duplikovat) (obě funkce jsou dostupné z místní nabídky prvku ). Všimněte si však, že Duplicate je jediná operace v této skupině, která zvýší počet prvků v systému vědomostí . Schránku můžete vyprázdnit pomocí Ctrl+click.

Schránka komponenty se používá pro kopírování komponent. K umístění komponenty do schránky použijte některou z následujících metod:

  • Přetáhněte komponentu do schránky se stisknutou klávesou Ctrl
  • Pokud hlavní nástrojový panel není viditelný, můžete komponentu umístit do schránky bez přetahování stisknutím Move to ClipBox (Přesunout do schránky) na místní nabídce komponenty

Chcete-li komponentu okopírovat přetáhněte obsah schránky komponenty na správné místo v cílovém prvku. Schránku můžete vyprázdnit pomocí Ctrl+klik.

Hyperlinkovou schránku je možno použít pro vytváření hyperpropojení ( hyperlinks ). Hyperlink je propojení mezi komponentou a jiným prvkem. Kliknutím na hyperpropojenou komponentu se přesunete do propojeného prvku. Hyperpropojení se vytvoří takto: (1) umístěte hyperpropojovanou komponentu do hyperlinkové schránky stejně, jak se komponenta umísťuje do schránky komponenty (viz výše) (2) vytvořte hyperpropojení mezi komponentou uloženou v hyperlinkové schránce a daným prvkem přetažením obsahu hyperlinkové schránky na prvek. Tyto dva kroky otevřou cestu k přístupu na propojený prvek z propojené komponenty kliknutím. Hyperlinkovou schránku můžete vyprázdnit pomocí Ctrl+click.

Časté otázky

Otázka:
Jak mohu vyprázdnit schránku? V SuperMemo 8 se vyprázdnila kliknutím.
Odpověď:
V SuperMemo 98 musíte Ctrl+kliknout. Je to ochrana před příliš snadnou ztrátou obsahu schránky.

***


Místní nabídka komponenty

Vzhled a chování každé komponenty je možno měnit pomocí voleb dostupných v její místní nabídce. Místní nabídka komponenty se otvírá kliknutím pravým tlačítkem myši na komponentu. Místní nabídku aktuální komponenty můžete otevřít také stisknutím Ctrl+Alt+F10 . Aktuální komponenta je vyznačena rámečkem se stínem. Mez komponentami můžete přepínat pomocí Ctrl+T . Ctrl+T vybere další komponentu ve směru hodinových ručiček, kdežto Ctrl+Shift+T vybere komponentu proti směru hod. ručiček.

V následujícím seznamu jsou uvedeny všechny volby, které můžete najít v místní nabídce komponent různých typů. Protože tyto volby jsou stejné pro různé typy komponent, jsou zde popsány všechny. U dané komponenty se nemusí zobrazit volby, které pro ni nemají význam (např. Insert OLE object se objevuje jen u komponenty OLE , kdežto Delete je společné všem komponentám.

Důležité! Nezaměňujte tento popis místní nabídky s místní nabídkou komponent HTML v prezentačním režimu (to je typická nabídka prohlížeče Internetu) nebo s místní nabídkou komponent OLE v editačním režimu (ta závisí na implementaci konkrétního serveru OLE použitého při editaci daného souboru OLE).

Místní nabídky komponent obsahují následující volby:

  • Insert HTML link (Vložit propojení HTML) - vložit propojení na zdrojový kód HTML v komponentách HTML v editačním režimu
    • Element (Prvek) - vložit hyperpropojení na jiný prvek v souhrnu vědomostí (podrobnosti viz Insert HTML link (Vložit propojení HTML) )
    • Text registry (Textový registr) - vložit hyperpropojení na jiný text v textovém registru (obsahující neformátovaný text a text HTML)
    • HTML file (Soubor HTML) - vložit hyperpropojení na samostatný soubor HTML umístěný kdekoliv na vašem pevném disku nebo na síťovém disku
    • Web address (Webová adresa) - vložit hyperpropojení na soubor dostupný na Internetu
    • Registry image (registrový obrázek) - vložit obrázek z obrazového registru
  • Insert OLE object (Vložit objekt OLE) - vložit soubor do vaší komponenty OLE . Tento soubor může být dokument MS Word, tabulkový list Excelu, mapa mysli produktu MindMan , obrázek Corelu, rovnice z MS Equation, chemický vzorec, animace, video, atd. Počet použitých souborů je omezen jen servery OLE nainstalovanými ve vašich Windows. Jakmile vytvoříte souhrn vědomostí s objekty OLE, můžete rozšiřovat své soubory mezi uživatele, kteří nemají odpovídající serverové aplikace. Například jestliže vložíte mapu mysli produktu MindMan a váš zákazník nemá nainstalován MindMan, bude přesto moci používat váš souhrn. Nebude však moci editovat mapu mysli. K tomu by musel mít nainstalován MindMan. Dialogový panel zobrazený prostřednictvím Insert OLE object umožňuje zvolit jednu ze dvou možností:
    • vytvořit nový soubor OLE (musíte si jen vybrat ze seznamu serverů OLE dostupných ve vaší instalaci, např. Bitmap Image, Wave Sound, WordPad Document, atd.)
    • vytvořit soubor OLE z původního dokumentu (např. dokumentu MS Word nebo grafu MS Excel)
  • OLE properties (Vlastnosti OLE) - zobrazit vlastnosti objektu OLE
  • Search source (Vyhledat zdroj) - vyhledat zdroj komponenty HTML
  • Links (Propojení)
    • Registry member (člen registru) - propojit aktuální komponentu s vybraným členem registru . Například používáte-li obrazovou komponentu a chtěli byste zobrazit obrázek, který již byl použit v jiných komponentách, zvolte Links (Propojení): Registry member (Člen registru), zvolte obraz v obrazovém registru a klikněte na Link (nebo stiskněte Enter)
    • Font - propojit aktuální komponentu s vybraným fontem uloženým ve fontovém registru
    • Hyperlink (Hyperpropojení) - propojit aktuální komponentu s jiným prvkem . Všimněte si, že mnohem jednodušší je vytvářet hyperpropojení pomocí hyperlinkové schránky
    • Play on click (Přehrát při kliknutí) - propojit aktuální komponentu s jinou přehrávatelnou komponentou (např. zvukem, video, skriptem, atd.). Když uživatel klikne na vaši komponentu, propojená komponenta se přehraje.
    • External file (Externí soubor) - propojit aktuální komponentu s externím souborem (tj. souborem nezabudovaným do vašeho souhrnu vědomostí). Všimněte si, že propojení k externím souborům zmenšují velikost souhrnu, avšak propojení se může snadno poškodit, jestliže se soubor přesune na jiné místo nebo když přemístíte svůj souhrn na jiný počítač. Na rozdíl od External file volba Import file zabuduje externí soubor do souhrnu a zvětší tak jeho velikost
    • Delete registry link (Vymazat propojení k registru) - vymazat aktuální propojení k registru v aktuální komponentě. Touto operací se odstraní propojení vytvořená pomocí Links (Propojení): Registry member (Člen registru) a Links : External file (Externí soubor) . Všimněte si, že bylo-li vymazané propojení posledním propojením na příslušný člen registru, tento člen se může vymazat s varováním nebo bez varování ( závislosti na typu registru) (srovnej: Edit (Editovat): Delete file (Vymazat soubor) )
  • Import file (Importovat soubor) - importuje soubor do registru a vytváří propojení mezi aktuální komponentou a nově vytvořeným členem registru. Například chcete-li, aby vaše zvuková komponenta přehrávala daný soubor WAV, zvolte Import file (Importovat soubor), vyberte zvukový soubor WAV v dialogovém panelu a klikněte na Open (Otevřít). Váš soubor WAV bude zabudován do zvukového registru a u aktuální komponenty se zaregistruje propojení s tímto souborem. Na rozdíl od volby External file (Externí soubor) vytvoří Import file kopii importovaného souboru v adresáři elements (prvky) a zvětší tak velikost souhrnu vědomostí
  • Image (Obraz) - volby týkající se obrazových komponent
    • Stretch image (Roztáhnout obraz) - zobrazit aktuální obraz roztažený na velikost aktuální komponenty. Je-li obraz menší nebo větší než obrazová komponenta, bude zmenšen nebo zvětšen na odpovídající velikost
    • Edit hit-area (Editovat oblast hit ) - editovat hot-spots používaná skriptovými příkazy DRAGMATCH a HITTEST
    • Transparent (Průhledná) - učinit aktuální komponentu průhlednou. Pozadí obrazu bude průhledné a zobrazí se komponenty nebo obraz pozadí ležící pod aktuální komponentou
  • Sound and video (Zvuk a video) - volby týkající se zvukových komponent a videokomponent
    • Show panel (Zobrazit panel) - zobrazit ovládací panel s tlačítky play, stop, rewind atd.
    • Extract section (Vyjmout úsek) - vybrat úsek zvukového souboru nebo video souboru pro přehrátí komponentou. Například chcete-li vytvořit řadu cvičení založených na jedné a téže delší videoscénce, můžete použít tuto volbu k tomu, aby se v každém cvičení přehrával jen určitý úsek video souboru a neplýtvalo se prostorem na disku
    • Recorder (Magnetofon) - zobrazit alternativní ovládací panel pro zvukové komponenty, s tlačítky určenými pro porovnávání zvuku nahraného uživatelem s originálním zvukem. Tento panel je užitečný při procvičování výslovnosti, kdy se předpokládá, že uživatel nahraje svou výslovnost a porovná ji s originální nahrávkou výslovnosti rodilého mluvčího.
    • Frames (Snímky) - zvolit rychlé převíjení video (tj. počet snímků, které se mají přeskočit při převíjení)
  • Shape (Geometrické komponenty) - volby týkající se geometrických komponent
    • Line thickness (Tloušťka čáry) - zvolit tloušťku čáry
    • Line style (Styl čáry) - zvolit styl čáry (např. plná, čárkovaná, tečkovaná atd.)
    • Brush style (Styl štětce) - zvolit styl geometrické textury (např. plná, křížová atd.)
  • Script (Skript) - editovat skript ve skriptových komponentách
  • Button text (Text tlačítka) - změnit text na tlačítkách používaných ve skriptových a programových komponentách
  • Text - změnit vlastnosti různých textových komponent (text, kontrola pravopisu (Spell-Pad), zvuk a RTF)
    • New font (Nový font) - definovat nový font, uložit jej ve fontovém registru (ne v případě komponent RTF) a použít jej v aktuální komponentě
    • Edit font (Editovat font) - editovat právě používaný font (např. modifikovat jej ve fontovém registru)
    • Center text (Vystředit text) - vystředit text v textové nebo zvukové komponentě
    • Transparent (Průhledný) - udělat text v textové nebo zvukové komponentě průhledný. Průhledné texty zviditelňují komponenty nebo obraz v pozadí ležící pod aktuální textovou komponentou. Jinak se zobrazují na homogenním pozadí daném volbou Color (Barva)
    • Keep in lexicon (Podržet v lexikonu) - rozhodnout, zda se má text uložený v dané komponentě uložit do lexikonového registru
    • Case sensitive (Rozlišovat malá a velká) - způsobit, že Spell-Pad bude rozlišovat mezi malými a velkými písmeny
    • Copy transcription (Kopírovat přepis) - okopírovat fonetický přepis aktuální textové komponenty do schránky (registr fonetického přepisu nesmí být prázdný)
  • Color (Barva) - zvolit barvu aktuální komponenty (tato volba je silnější než atribut transparent (průhledný) v textových komponentách)
  • Default color (Implicitní barva) - zvolit implicitní barvu pro komponentu (implicitní barva bude stejná jako barva pozadí v aktuálním prvku)
  • Border (Okraj) - zobrazit nebo skrýt okraj kolem aktuální komponenty
  • Display at (Zobrazit při) - určit, kdy má být komponenta viditelná. Jestliže vymažete všechny zatrhovací políčka, komponenta se stane neviditelnou (např. může fungovat jako zástupná komponenta (placeholder) pro zvuk nebo skript )
  • Answer (Odpověď) - udělat z komponenty odpověď, tj. zviditelnit ji až po žádosti o zobrazení odpovědi. Všimněte si, že Answer je rychlý způsob pro volbu odpovídající podmnožiny v Display at (výše). Klikněte na Answer a pozorujte změny v dialogovém panelu zobrazeném pomocí Display at
  • MCT (výběrový test) -určit, které komponenty se zúčastní v testu výběru z několika možností.
    • None (Žádná) - komponenta se nepoužívá ve výběrovém testu nebo se používá jen jako otázka, poznámka atd.
    • Wrong (Chybná) - komponenta vyjadřuje nesprávnou odpověď ve výběrovém testu. Jestliže uživatel na tuto komponentu klikne, bude oznámkován známkou Fail (Špatně)
    • Correct (Správná) - komponenta vyjadřuje správnou odpověď ve výběrovém testu. Jestliže na ni uživatel klikne, bude oznámkován známkou Good (Dobře)
  • Delete (Vymazat) - vymazat aktuální komponentu. Jestliže tato komponenta používá poslední propojení na daný člen registru (tj. žádné jiné komponenty nejsou s tímto členem propojeny), člen bude rovněž vymazán (v případě zvuku, obrazu, videa, atd. budete nejprve požádáni o potvrzení výmazu registrového souboru)
  • Edit (Editovat)
    • Copy (Kopírovat) - okopírovat obsah komponenty do schránky (např. propojený text, propojený obraz atd.)
    • Paste (Vložit) - vložit obsah schránky do komponenty (jen když obsah shránky odpovídá typu komponenty)
    • Paste special (Vložit jinak) - vložit speciální objekt OLE
    • Move to ClipBox (Přesunout do schránky) - přesunout komponentu do schránky komponenty a hyperlinkové schránky
    • Edit file (Editovat soubor) - editovat registrový soubor spojený s komponentou (např. zvukový soubor ve zvukové komponentě nebo bitmapový soubor v obrazové komponentě). Edit file bude používat implicitní editor určený pro editaci souborů daného typu ve vaší instalaci Windows
    • Delete file (Vymazat soubor) - vymazat soubor spojený s aktuální komponentou (porovnej s Delete registry link )
  • Mode (Režim) - určit, jak se bude komponenta zobrazovat a zpracovávat
    • Presentation mode (Prezentační režim) - zobrazit komponentu tak, jak ji bude vidět uživatel
    • Editing mode (Editační režim) - připravit komponentu pro editaci nebo změnu velikosti
    • Dragging mode (Přetahovací režim) - připravit komponentu k přetahování nebo změně velikosti
    • Send to back (Poslat dozadu) - poslat komponentu za všechny komponenty, které právě leží pod ní.
  • Component (Komponenta)
    • Select next component (Vybrat následující komponentu) - nastavit aktuální komponentu do prezentačního režimu a nastavit následující komponentu do editačního režimu
    • Select previous component (Vybrat předchozí komponentu) - nastavit aktuální komponentu do prezentačního režimu a nastavit předchozí komponentu do editačního režimu (proti směru hodinových ručiček)

Časté otázky

(Bonnie Smithson, USA, Feb 24, 1998)
Otázka:
Jak dám obrázek do komponenty odpovědi?
Odpověď:
Přidejte obrazovou komponentu a v místní nabídce komponenty zatrhněte Answer

(Gabor Schmera, USA, Dec 13, 1997)
Otázka:
Jak přidám do svých položek položku "magnetofon" (jako je to v Advanced English 97) ?
Odpověď:
Přidejte zvukovou komponentu a v místní nabídce zatrhněte Recorder

****


Nástrojový panel tvoření komponent

Nástrojový panel tvoření komponent se zobrazí v horní části okna prvku , jestliže zvolíte kartu Compose (Vytvářet):

Použití jednotlivých tlačítek:

  • Tlačítka místních nabídek - otevřít místní nabídky, dostupné také kliknutím pravým tlačítkem na plochu zobrazení prvku a na jednotlivé komponenty
    • Element pop-up (Místní nabídka prvku) - otevřít místní nabídku prvku s operacemi týkajícími se právě zobrazeného prvku
    • Component pop-up (Místní nabídka komponenty) - otevřít místní nabídku komponenty s operacemi týkajícími se aktuálního typu komponenty
  • Tlačítka komponent - vytváření různých typů komponent (viz níže):
    • Textová komponenta - jednoduché textové komponenty
    • Komponenta s obohaceným textem (rich text) - textové komponenty s různými fonty, barvami a formátováním
    • Komponenta HTML - komponenty pro webové prohlížeče zobrazující texty HTML, formátování, obrazy, rámy, tabulky, skripty (např. JavaScript) atd.
    • Komponenta typu Spell-Pad - textové komponenty, které umožňují vyhodnocení vkládaného textu (např. při procvičování pravopisu)
    • Obrazová komponenta - obrazové komponenty
    • Zvuková komponenta - komponenty WAV nebo MIDI
    • Videokomponenta - videokomponenty AVI
    • Skriptová komponenta - skriptové komponenty SuperMemo pro provádění přetahovacích cvičení (typu drag-and-drop), ukazovacích cvičení (typu point-and-click), skrývání a zobrazování komponent, přehrávání zvuků nebo jiných skriptů atd.
    • Komponenta OLE - pro zobrazování a editaci objektů vytvořených jinými aplikacemi (např. dokumenty Wordu, tabulkové listy Excelu, mapy mysli MindMan , obrázky Corelu, rovnice, strukturované vzorce atd.)
    • Programová komponenta - pro rozšiřování SuperMemo pomocí externích programů a DLL
    • Komponenta elipsa
    • Komponenta obdélník
    • Komponenta zaoblený obdélník
    • Komponenta čára
  • Tlačítka režimu zobrazení komponent - mění způsob zobrazení komponent a jejich použití:
    • Tlačítko Editing mode (Editační režim) - nastavit všechny komponenty do režimu, který umožňuje editovat texty, editovat objekty OLE atd.
    • Tlačítko Dragging mode (Přetahovací režim) - nastavit všechny komponenty do režimu, který umožňuje přetahování a změnu velikosti komponent
    • Tlačítko Presentation mode (Prezentační režim) - nastavit všechny komponenty tak, aby se zobrazily jako při učení
  • Tlačítko Component tags (tagy komponent) - zobrazuje čísla komponent, typ a jméno
  • Tlačítko Alignment and size (Rozložení a velikost) - umožňuje měnit velikost a umístění všech komponent,které jsou právě v editačním nebo přetahovacím režimu.

Všechna tlačítka komponent uvedená výše umožňují přidávat nové komponenty do oblasti zobrazení prvku. Pro přidání komponenty do prvku je zapotřebí třikrát kliknout myší:

  1. na tlačítko odpovídající zvolenému typu komponenty
  2. na levý horní roh oblasti, kam se má komponenta umístit
  3. na pravý spodní roh oblasti komponenty

Například chcete-li vytvořit jednoduchou textovou komponentu, klikněte na textové tlačítko, klikněte na dva body na oblasti zobrazení prvku a napište text.
Chcete-li vytvořit jednoduchou obrazovou komponentu, klikněte na obrazové tlačítko, klikněte na dva body v oblasti zobrazení prvku, klikněte pravým tlačítkem na právě vytvořený obdélník obrázku, na místní nabídce komponenty (obrazové) zvolte Import file (Importovat soubor) a vyberte obraz, který se má zobrazit.

****


Editační nástrojový panel v okně obsahu

Editační nástrojový panel se objeví v horní části okna obsahu , zvolíte-li kartu Edit (Editovat) (implicitně):

Použití jednotlivých ovládacích prvků:

  • Tlačítko místní nabídky - otevřít místní nabídku, dostupnou také kliknutím pravým tlačítkem na oblast zobrazení obsahu
  • Tlačítko Zobrazit (View button) - zobrazit právě vybraný prvek obsahu v okně prvku
  • Tlačítko zobrazení okna prvku (Element align button) - zobrazit okno prvku a vyrovnat je s oknem obsahu pro pohodlné prohlížení prvků v okně obsahu (synchronizační tlačítko (synchronize button) přitom musí být stlačeno)
  • Tlačítko zobrazení druhého okna obsahu (Contents align button) - otevřít druhé okno obsahu a vyrovant obě okna pro pohodlné provádění operací přetahování
  • Tlačítko uzavření úrovně (Close level button) - složit (zavinout) mateřský prvek právě vybraného prvku (pro snazší zavinutí celého stromu vědomostí zobrazeného v okně obsahu)
  • Tlačítko synchronizace (Synchronize button) - zobrazovat odpovídající prvky v okně prvku po změně výběru v okně obsahu)
  • Tlačítko synchronizace dat prvku (Element data synchronize button) - zobrazovat odpovídající parametry prvku v okně dat prvku při změně výběru v okně obsahu
  • Rozvinovací seznam pro přetahování (Drag-and-drop combo box) - vybrat režim operací přetahování v okně obsahu
  • Tlačítko kotvy (Hook button) - z právě vybraného uzlu udělat kotvu aktuální kategorie obsahu . Tím budou všechny přidávané prvky dcerami vybraného uzlu
  • Tlačítko najít (Find button) - vyhledat řetězec mezi právě rozvinutými uzly stromu vědomostí
  • Tlačítko Zapamatovat (Remember button) - uvést všechny potomky právě vybraného uzlu do procesu učení
  • Tlačítko Zapomenout (Forget button) - odstranit potomky právě vybraného uzlu z procesu učení (a dát je na konec fronty čekajících prvků )
  • Tlačítko vynechat (Dismiss button) - vynechat potomky právě vybraného uzlu, tj. zneviditelnit je pro proces učení
  • Tlačítko uložit (Save button) - uložit rozvinuté uzly stromu vědomostí do textového souboru

Profesionální úroveň

Kliknutím pravým tlačítkem myši se otevře místní nabídka obsahu s pokročilými operacemi prováděnými na stromě vědomostí .

****


Místní nabídka obsahu

Nejdůležitější operace na stromu vědomostí zobrazeném v okně obsahu jsou dostupné z místní nabídky obsahu. Tato nabídka se otvírá stisknutím Alt+F10 nebo kliknutím pravým tlačítkem na okno obsahu.

Místní nabídka obsahu mí následující volby:

  • View (Zobrazit) - zavést okno prvku do popředí a zobrazit v něm právě vybraný prvek obsahu
  • Review (Prohlížet) - prohlížet látku náležející do právě vybrané větve stromu vědomostí
  • Edit (Editovat) - editovat operace (dostupné také pomocí tlačítek na horní straně okna obsahu)
    • Add (Přidat) - přidat nový prvek jako dceřinný prvek (dceru) právě vybraného prvku (dcera je prvek, který je o jednu úroveň níž ve stromě vědomostí )
    • Sibling (Sestra) - přidat nový prvek jako sesterský prvek (sestru) právě vybraného prvku (sestra je prvek, který je na stejné úrovni ve stromě vědomostí)
    • Insert (Vložit) - vložit nový prvek na místo právě vybraného prvku (právě vybraný prvek se posune o jednu polohu dolů)
    • Delete (Vymazat) - vymazat právě vybraný prvek a jeho dcery (pokud existují)
    • Title (Název) - editovat název právě vybraného prvku (všimněte si, že můžete název editovat i na místě, kliknete-li na právě vybraný prvek)
  • Search (Vyhledat) - vyhledat názvy
    • Find (Najít) - najít řetězec v prvním názvu v rozvinutých větvích pod právě vybraným prvkem
    • Find next (Najít další) - opakovat poslední hledání provedené pomocí Search: Find
  • Category (Kategorie) - volby pro správu kategorií obsahu
    • Create new category (Vytvořit novou kategorii) - vytvořit novou kategorii obsahu s právě vybraným prvkem jako kořenem . Kategorie převezme název svého kořenového prvku jako svůj název. Můžete jej změnit na kratší nebo mnemotechnický název. Právě vybraný prvek se také stane prvním kotevním prvkem (kotvou) kategorie
    • Make root (Vytvořit kořen) - udělat právě vybraný prvek kořenovým prvkem (kořenem) aktuální kategorie (aktuální kategorie je kategorie vybraná ve stahovacím seznamu (combo-box) na nástrojovém panelu ). Kořen je prvek, který je předkem všech prvků v kategorii
    • Make hook (Vytvořit kotvu) - udělat právě vybraný prvek kotevním prvkem (kotvou) aktuální kategorie (aktuální kategorie je kategorie vybraná ve stahovacím seznamu (combo-box) na nástrojovém panelu ). Když změníte kotvu, všechny nově přidávané prvky budou dcerami kotvy (jen v rámci aktuální kategorie)
  • Node operations (Uzlové operace) - operace, které se týkají všech dcer nebo všech potomků dané větve
    • Status (Stav)
      • Remember (Zapamatovat) - uvést celou větev do procesu učení
      • Forget (Zapomenout) - odstranit všechny prvky větve z procesu učení
      • Dismiss (Vynechat) - vynechat všechny prvky ve větvi
      • Undismiss (Zrušit vynechání) - přidat vynechané prvky ve větvi do fronty čekajících prvků a zrušit jejich status vynechaných prvků
      • Make items (Samé položky) - udělat všechny prvky ve větvi položkami (viz též: Témata a položky )
      • Make topics (Samá témata) - udělat všechny prvky ve větvi tématy
      • Reset history (Vynulovat historii) - vynulovat historii opakování pro všechny prvky ve větvi
    • Forgetting index (Index zapomínání) - změnit index zapomínání v celé větvi
      • Set forgetting index (Nastavit index zapomínání) - přiřadit daný index zapomínání všem prvkům ve větvi
      • Default forgetting index (Implicitní index zapomínání) - nastavit pro všechny prvky ve větvi implicitní index zapomínání. Implicitní index zapomínání se nastavuje pomocí Tools (Nástroje) : Options (Volby) : Learning (Učení) : Forgetting index (Index zapomínání)
    • Ordinal (Ordinální číslo) - změnit ordinální číslo v celé větvi
      • Set ordinal (Nastavit ordinální číslo) - dát všem prvkům totéž ordinální číslo
      • Set position ordinal (nastavit ordinální číslo podle polohy) - dát všem prvkům ordinální číslo rovné jejich fyzické poloze v souhrnu vědomostí (např. pro třídění fronty čekajících prvků v pořadí přidávání prvků do souhrnu)
      • Set pending ordinal (Nastavit ordinální číslo dle fronty) - dát všem prvkům ordinální čísla rovná jejich poloze ve frontě čekajících prvků
      • Spread ordinals (Rozdělit ordinální čísla) - dát všem prvkům ordinální čísla narůstající ve stejných krocích od dané dolní meze po danou horní mez
      • Modify ordinal (Modifikovat ordinální čísla) - zvětšit nebo zmenšit ordinální čísla v celé větvi
    • Template (Šablona) - operace se šablonou v celé větvi
      • Merge with template (Sloučit s šablonou) - sloučit všechny prvky ve větvi s danou šablonou (viz Používání šablon )
      • Add template (Přidat šablonu - přidat šablonu ke všem prvkům ve větvi (viz Používání šablon )
    • Set title (Nastavit nadpis) - nastavit daný nadpis
  • Count (Spočítat) - spočítat všechny prvky splňující určité kritérium
    • Items (Položky) - spočítat všechny položky ve větvi (viz také: Témata a položky )
    • Topics (Témata) - spočítat všechna témata ve větvi
    • Memorized (Probrané) - spočítat všechny probrané prvky ve větvi (tj. prvky, které se zúčastňují opakování)
    • Pending (Čekající) - spočítat všechny čekající prvky ve větvi
    • Dismissed (Vynechané) - spočítat všechny vynechané prvky ve větvi
  • Tools (Nástroje)
    • Arrange in folders (Uspořádat do složek) - seskupit všechny prvky ve větvi do určitého počtu větví se stejným počtem dceřinných prvků. Například obsahuje-li vaše větev 100 prvků, můžete použít Arrange in folders pro vytvoření 10 prázdných prvků použitých jako zástupné prvky (placeholders) pro zbývající položky. Každý z nově vytvořených prvků bude mít 10 dcer. Tedy všech vašich 100 položek bude rozčleněno do 10 větví, z nichž každá má 10 dcer
    • Browse node (Prohlížet uzel) - dát všechny potomky právě vybrané větve do prohlížeče prvků
    • Transfer node (Přenést uzel) - přenést celou větev do jiného souhrnu
    • Save as subset (Uložit jako podmnožina) - uložit všechny prvky větve do podmnožiny prvků (viz: Používání podmnožin )
    • Export as text (Exportovat jako text) - exportovat všechny prvky v aktuální větvi jako text
    • Export learning (Exportovat proces učení) - exportovat proces učení ze všech prvků v aktuální větvi
    • Random test (Náhodný test) - spustit náhodný test na všechny prvky aktuální větve
    • Move empty elements (Přesunout prázdné prvky) - přesunout všechny prázdné prvky do vybrané větve v souhrnu
  • Customize (Přizpůsobit)
    • Font - změnit font používaný v okně obsahu
  • Switch window (Přepnout okno) - přepnout na okno prvku (tatáž klávesová zkratka, Ctrl+Shift+W , vás převede zpět z okna prvku do okna obsahu).

****


Okno obsahu

V okně obsahu SuperMemo je zobrazen strom vědomostí vědomostního systému čili souhrnu vědomostí.

Nejdůležitější součásti okna obsahu jsou:

  • Strom vědomostí (uprostřed okna)
  • Nadpis v horní části s úplnou cestou k aktuálnímu souhrnu na pevném disku (nebo síťovém disku)
  • Nástrojové panely (pod nadpisem):
    • Editační nástrojový panel - tlačítka používaná v nejobvyklejších operacích na stromě vědomostí
    • Datový pruh - informace o prvku , který je právě vybrán ve stromě vědomostí
    • Karta názvu - editační oblast pro editaci názvu prvku
  • Editační tlačítka na spodní straně okna:
    • View (Zobrazit) - zobrazit právě vybraný prvek v okně prvku
    • Review (Prohlížet) - postupně prohlížet prvky v právě vybrané větvi
    • Add (Přidat) - přidat nový prvek jako dceru (dceřinný prvek) právě vybraného prvku (dcera je prvek, který je o jednu úroveň níž ve stromě vědomostí )
    • Sibling (Sestra) - přidat nový prvek jako sestru (sesterský prvek) právě vybranéhoprvku (sestra je prvek, který je na téže úrovni ve stromě vědomostí)
    • Insert (Vložit) - vložit nový prvek na místo právě vybraného prvku (vybraný prvek se posune o jednu polohu níž)
    • Delete (Vymazat) - vymazat právě vybraný prvek a všechny jeho dcery (pokud existují)
    • Choose (Zvolit) - zvolit právě vybraný prvek. Toto tlačítko je aktivní, jen když jiná volba v SuperMemo potřebuje vybrat prvek. V takovém případě se otevře okno obsahu a uživatel může ukázat na požadovaný prvek a kliknout na Choose)

Na výše uvedeném obrázku označují červené ikony tvaru dopravní značky "stop" vynechané prvky (tj. prvky, které se nezúčastňují učení), kdežto ikony "L" označují prvky, které se zúčastňují procesu učení. Ikony L jsou světle modré, jestliže prvek je čekající , a tmavě modré, je-li prvek probraný (byl již studován).

Znaménko plus vlevo od prvku označuje, že prvek má dceřinné prvky. Dcery můžete vidět, když na znaménko plus kliknete. Znaménko minus vlevo od prvku znamená, že prvek s dcerami je možno zavinout. Kliknete-li na znaménko minus, všechny dcery zmizí a znaménko minus bude nahrazeno znaménkem plus.

Profesionální úroveň

Okno obsahu poskytuje rovněž řadu pokročilých funkcí ze své místní nabídky . Místní nabídka se otvírá kliknutím pravým tlačítkem na okno obsahu nebo stisknutím Alt+F10 .

Časté otázky

(Noel Clary, USA, Sep 18, 1998)
Otázka:
Když dvakrát kliknu na prvek bez dcer, zobrazí se mi v okně prvku . Avšak má-li dcery, jeho větev se otevře nebo zavře. Jak si mohu snadno prohlížet obsah prvků s dcerami v okně prvku?
Odpověď:
Klikněte na View (Zobrazit) na spodní straně okna obsahu

(Jim Ivy, USA, June 4, 1997)
Otázka:
Jaký je rozdíl mezi tématem a položkou ?
Odpověď:
Témata se používají pro předkládání vědomostí podobně jako kapitoly v knize, kdežto položky se používají pro zkoušení vědomostí prostřednictvím opakování (např. mají strukturu otázka - odpověď). Hlavní rozdíl je, že témata se nezúčastňují opakování, ale předkládají se před učením posloupnosti položek. To pomáhá pochopit předmět jako celek před začátkem opakování. Viz též: Témata a položky

(Pawel Galecki, Poland, Feb 10, 1998)
Otázka:
Vytvořil jsem svůj vlastní souhrn vědomostí, který obsahuje 700 položek v kořenovém uzlu. Systém se při každém otevření načítá téměř 60 sekund! Jak to mohu urychlit?
Odpověď:
Z důvodů zvýšení výkonnosti byste měl omezit počet prvků na kategorii na 50 -100. Provedete to tak, že nastavíte nižší mezní hodnotu počtu dceřinných prvků v Tools : Options : Appending : Children limit per hierarchy node. Pro "rozsekání" své kategorie o 700 položkách použijte Tools: Arrange in folders v místní nabídce obsahu .

****


Volby: Přístup k datům

Options (Volby): Data access (Přístup k datům)

Karta Data access (Přístup k datům) na Tools (Nástroje) : Options (Volby) poskytuje volby ovlivňující přístup k datům a volby v SuperMemo jako: cesta k CD-ROM, úroveň obtížnosti, míra editovatelnosti systému:

  • Secondary storage (Sekundární paměť) - cesta k sekundární paměti (např. CD-ROM), v níž jsou uloženy velké multimediální soubory. Jestliže je cesta prázdná, cesta k sekundární paměti bude stejná jako cesta k primární paměti , tj. tam, kde je uložen systém vědomostí . Data daného registru můžete přesunout z CD-ROM na svůj pevný disk pomocí Tools (Nástroje): Internalize files (Změnit soubory na interní) na místní nabídce registru . Vymažete-li cestu k sekundární paměti, budete pak moci používat systém vědomostí bez jednotky CD-ROM.
  • Access level (Úroveň přístpu) - určuje úroveň obtížnosti SuperMemo (totéž jako File (Soubor) : Level (Úroveň) ):
    • Beginner (Začátečník) - poskytuje jen základní volby: Learn (Učit se) , Add new (Přidat nový) , Contents (Obsah) , Search (Vyhledat) atd.
    • Basic (Základní) - přidává možnost vytváření a editace komponent , editace názvů atd.
    • Professional (Profesionální) - poskytuje přístup ke všem volbám implementovaným do SuperMemo
  • Access mode (Režim přístupu) - určuje stupeň editovatelnosti systému:
    • read-only (jen čtení) - umožňuje pouze prohlížet systém vědomostí (např. na CD-ROM)
    • learn-only (jen učení) - umožňuje prohlížet systém vědomostí, učit se novou látku a opakovat nevyřízenou látku . Modifikace systému vědomostí není možná.
    • full access (úplný přístup) - umožňuje učit se a editovat systém vědomostí bez omezení
  • Password (Heslo) - Heslo, které je požadováno při otvírání systému vědomostí. Upozornění: SuperMemo nepoužívá přísná bezpečnostní opatření. Neukládejte prosím do programu důvěrná data, protože je možno je prohlížet libovolným editorem souborů. Heslo může být užitečné, chcete-li svým dětem zabránit v "zamíchání" vaší látky nebo svému kolegovi v náhodných opakováních s vaším systémem vědomostí.
  • Hide navigation toolbar (Skrýt navigační nástrojový panel) - skrýt nadpis a navigační nástrojový panel v okně prvku . Tato volba se může použít k převzetí plné kontroly nad navigací ve vašem systému vědomostí, který chcete rozšířit mezi své kolegy (např. svou multimediální prezentaci). Místo používání tlačítek Contents (Obsah) , Search (Vyhledat), Next (Další) atd. si můžete přidat svá vlastní tlačítka nebo hyperpropojení. Například Advanced English 97 začíná se skrytým nástrojovým panelem, aby se snížila možnost, že začínající uživatel zabloudí ven z úvodu do základů Advanced English
  • Debugging version (Ladicí verze) - maximalizovat kontrolu chyb v SuperMemo a hlásit i chyby, které by jinak uživatele nerušily. Všimněte si, že v důsledku ověřování registrových propojení v reálném čase je ladicí verze SuperMemo podstatně pomalejší
  • SuperMemo 7 audiovisual files path (Cesta k audiovizuálním souborům SuperMemo 7) - cesta k obrazům a zvukům importovaným ze SuperMemo 7 . Tuto volbu budete potřebovat jen v případě, že importujete nějaké databáze SuperMemo 7 šířené na CD-ROM .

****


Desatero

Obsah
Desatero správného učení

SuperMemo vám pomůže zorganizovat učení a minimalizovat čas potřebný pro opakování. Není to však rozhodující prvek pro úspěch v učení. U nezanedbatelné části potenciálních uživatelů znemožňuje používání metody SuperMemo již pouhá osobnost studenta. Hlavní problém, podobně jako u mnoha jiných lidských činností, je vytrvalost. Jen silně motivovaní jednotlivci jsou schopni vydržet v opakování, které se může stát nesnesitelně jednotvárné. Pro jiné může značné duševní zatížení a vynakládání času zastínit dlouhodobý přínos. Na nepřipraveného studenta však čekají ještě další překážky. Nejdůležitější z nich probereme v následujících odstavcích:

    2. Výběr studované látky
    4. Pravidelnost
    6. Umírněnost
    8. Jednoduchost
    10. Jednoznačnost
    12. Koncentrace
    14. Uvědomění si duševních stavů, kterými prochází typický student
    16. Radost
    18. Zdraví
    20. Mnemotechnické desatero

Výběr studované látky

Protože SuperMemo usnadňuje učení, můžete mít nutkání učit se mnohem víc, než opravdu potřebujete. Až za nějakou dobu objevíte skutečný rozsah vědomostí, o které máte zájem, a skutečnost, že ačkoliv je SuperMemo mimořádně účinné, není všemohoucí a v omezeném čase vám umožní zvládnout jen omezené množství znalostí. Budete-li pracovat neumírněně, dříve nebo později budete zahlceni množstvím opakování a objevíte skutečnou kapacitu SuperMemo (průchodnost), která je úměrná dennímu přídělu času.

Práce se SuperMemo klade přísná omezení na množství nových znalostí, které je možno se naučit za jednotku času a vyžaduje mimořádně přesný výběr látky. Ve volbě fakt a pravidel pro zapamatování byste měli používat kritérium použitelnosti. Může se vám zdát, že velké množství položek stojí zato znát, ale protože kapacita paměti je omezená, je možno zvládnout jen malý zlomek a při výběru byste měli dávat přednost položkám s největší použitelností v každodenních situacích. Nepromarníte mnoho času, zahrnete-li položky, které byste si i tak zapamatovali díky jejich intenzivnímu dennímu používání. Proto raději zahrnujte všechny důležité položky, o kterých si nejste jisti, že si je zapamatujete. Pro výběr látky k učení platí ještě jedno obecné pravidlo: nejprve byste měli zvládnout základní aspekty studovaného předmětu a teprve v pozdějších stádiích učení zacházet do podrobností. Puntičkářské "šprtání" učebnic stránku za stránkou nutně vede k nadbytku podrobností za cenu základních znalostí. Důležitým psychologickým aspektem přístupu od obecného ke speciálnímu je, že můžete brzy odhalit velký užitek pocházející z dokonalých znalostí většiny základních fakt ve svém oboru a být tím ještě víc povzbuzeni k rozšiřování svého systému vědomostí do detailnějších oblastí. S překvapením si všimnete, jak nová pravidla a fakta zapadají do toho, co jste se již naučili.

Dobré základy usnadňují pronikat do nových struktur vědomostí, poskytují další povzbuzení k práci a zbavují vás nezdravého dojmu, že získáváte vědomosti pro vědomosti.

Pravidelnost

Nejčastějším důvodem neúspěchů při používání SuperMemo je malá pravidelnost ze strany studenta. Skutečně, nepravidelná opakování jsou v rozporu s metodou SuperMemo. Potom není divu, že pro ty, kteří nedodržují pravidelnost, se nedostaví úspěch. Pravidelné učení se SuperMemo je jedním z nejdůležitějších faktorů a vyžaduje silnou vůli a rozhodnost. SuperMemo je nejen dobrou terapií pro špatnou paměť, ale pomáhá také rozvíjet železnou vůli. Důležitost pravidelnosti vyplývá z toho, že SuperMemo vypočítává optimální intervaly mezi opakováními a to studentovi neumožňuje opakování opožďovat nebo naopak přesouvat na dřívější dobu. To by se nemělo chápat jako nedostatek metody, ale jako základní vlastnost paměti, která má pevný mechanismy regulace pamatování a mazání vzpomínek. Každý den zpoždění nejen zvyšuje podíl zapomenutých položek, ale vede také k nevyhnutelnému hromadění práce, kterou je třeba dohnat v následujících dnech. To přináší dodatečný stres studentovi, který s každým promarněným dnem má menší sklon vrátit se k opakování. V SuperMemo se dosahuje nejlepších výsledků, když student používá metodu každý den po určitou dobu. Pracovat každý druhý den, i když je to méně efektivní, je mnohem lepším řešením, než pracovat každý druhý týden atd. Systematická práce se SuperMemo je základním předpokladem úspěchu a ti, kteří nehodlají pracovat pravidelně, by neměli doufat, že SuperMemo vynahradí jejich lenost. Budeme-li parafrázovat známé rčení, můžeme říci, že SuperMemo je jako sex: nemůžeme je přenechat jiným. Provádějte svá opakování pravidelně, tak jak provádíte své každodenní rituály.

Umírněnost

Často se stává, že začínající uživatel SuperMemo8, překvapený výsledky dosaženými přítelem, který tuto metodu využívá, zahájí nadměrně ambiciózní program získávání nových znalostí. Věc, kterou on či ona často přecení, je jeho nebo její schopnost učení a také vytrvalost. SuperMemo nezaručuje, že student bude úspěšný. Vyžaduje určité dovednosti a pracovní strategii, která se vyvíjí po delší dobu. Skutečnost, že student je schopen se naučit myriády položek za krátkou dobu nutně neznamená, že tentýž student bude mít dostatek vytrvalosti k tomu, aby vytrval s opakováním nově naučené látky. Neznamená to také, že naučené položky jsou správně strukturovány a uchovají se v paměti tak snadno, jak byla naučeny. K nebezpečím neumírněnosti přispívají dva faktory:

  1. Rychlost učení (rychlost osvojování vědomostí) podstatně klesá během prvního roku používání SuperMemo a tento pokles je nejmarkantnější v několika prvních týdnech.
  2. Naučení nové látky je mnohem jednodušší proces než udržení získaných vědomostí v paměti. Špatně strukturované položky projeví svou zlomyslnou nepoddajnost až po několika opakováních.

Než začnete rozsáhle rozšiřovat svůj vědomostní systém, je absolutně nutné, abyste prověřili svou schopnost:

  1. Formulovat jednoduché, jasné a jednoznačné položky (absolutní začátečníci prakticky bez výjimky vytvářejí velké množství nesprávně strukturovaných položek),
  2. Pracovat se SuperMemo souvisle delší dobu (jen nejvytrvalejší jedinci jsou schopni vydržet “memomaratony” trvající déle než 1 hodinu).

Umírněnost a chladné posouzení svých potřeb a schopností jsou tudíž velmi důležité předpoklady úspěšného používání SuperMemo. Doporučená doba práce se SuperMemo je 5-20 minut denně pro začátečníky a ne více než 1-2 hodiny pro pokročilé studenty.

Jednoduchost

Je velmi smutné vidět nadšeného začátečníka SuperMemo plýtvat časem při učení monstrózních položek, které nejen nejdou “nacpat” do paměti, ale navíc jsou absolutně redundantní, pokud jde o potřeby studenta. Představte si studenta, který si chce zapamatovat všechny evropské státy a snaží se nabiflovat dlouhý seznam jejich názvů. Typická situace je, že si zapamatuje většinu názvů na seznamu, ale obvykle udělá chybu v tom, že zapomene uvést jeden nebo dva z nich. Výsledkem je, že položka je znovu a znovu považována za zapomenutou a že student nepozoruje žádný pokrok v učení. Pomocí mnemotechniky by se student mohl naučit celý seznam v určitém pořadí, ale to asi nepředstavuje tu znalost, kterou chce opravdu mít. Velká většina vzdělaných lidí není schopna vyjmenovat úplný seznam evropských států, pokud nepoužijí trik spočívající v tom, že si v duchu představují mapu Evropy a postupně jí systematicky procházejí. Je zřejmé, že naučit se seznam států nestačí k tomu, abychom něco věděli o zeměpisu Evropy a trik s procházením nelze provést, pokud student nezná nic jiného. Dobrý student SuperMemo se nebude pokoušet naučit celý seznam v rámci jedné položky. Použije některý ze svých triků pro strukturování vědomostí a rozdělí seznam na mnoho položek. V závislosti na tom, jaký druh vědomostí by mohl být užitečný, může student používat například tyto triky:

  • seskupování položek podle zeměpisného umístění jednotlivých států,
  • podle jejich přináležitosti (např. k EU, východní Evropě, Skandinávii, NATO),
  • podle příslušnosti k jazykové skupině atd.

Tyto triky určitě vyvolají zavedení určité redundance informací, ale chytrý student jistě využije redundanci ke svému prospěchu. Monstrózní položky zaberou mnohem více času a vytvoří mnohem méně užitečné znalosti než tytéž položky rozdělené do mnoha podpoložek. Aby byla zajištěna úplná schopnost si znalost vybavit, měl by se použít mnohostranný přístup k uložené vědomosti, tj. měly by být položeny všechny možné kombinace otázek týkajících se daného vztahu. Například přeje-li si někdo pamatovat si, že nejčastější příčinou smrti jsou srdeční choroby, které způsobují téměř 40% úmrtí v západních zemích, následující otázka by mohla být nedostatečná:

Co je nejčastější příčinou úmrtí v západních zemích?

Neumožní vám zapamatovat si procentuální podíl úmrtí způsobených srdečními chorobami, ani to, že podíl 40% odpovídá západním zemím. Mnohostranná sada otázek by mohla vypadat takto:

  • Co je nejčastější příčinou úmrtí v západních zemích?
  • Ve které skupině zemí jsou srdeční choroby nejčastější příčinou smrti?
  • Jaký procentuální podíl úmrtí v západních zemích připadá na srdeční choroby?
  • Jaké choroby jsou zodpovědné za 40% úmrtí v západních zemích?

Jsou srdeční choroby nejčastější příčinou smrti v západních zemích?

Takovou sadu položek se student naučí rychleji a v jeho poměti zůstane trvalejší stopa, i když jsou položky redundantní a zaberou dost času. Jednoduchost a mnohostranný přístup při strukturování vědomostí jsou nejúčinnější nástroje k tomu, aby opakování pomocí SuperMemo byla opravdu efektivní ve smyslu duševní zátěže a kvality znalostí.

Podrobnější analýzu formulování systému vědomostí pro učení se SuperMemo najdete v Strukturování vědomostí a jejich reprezentace

Jednoznačnost

Skutečnost, že vaše položky jsou jednoduché, ještě nezaručuje, že je snadné si je zapamatovat. Jednou z velkých překážek při tvoření snadných vědomostních systémů je problém interference, čili zmatku pocházejícího z toho, že různé položky mohou mít podobné otázky nebo podobné odpovědi. Například si představte, že se chcete naučit něco programu SuperMemo a vytvoříte speciální vědomostní systémy věnované tomuto účelu. Uvažujme dvě následující položky vašeho vědomostního systému týkajícího se SuperMemo:

  1. Q: Jak se nazývají položky, které se vzájemně podobají?
    A: dvojznačné položky (ambiguous items)
  2. Q: Jak se nazývají podobně vypadající položky?
    A: dvojsmyslné položky (equivocal items)

Nepotřebujete mít mnoho zkušeností se SuperMemo, abyste předpověděli, že student, který chce zvládnout vědomostní systém obsahující takové dvě položky si bude neustále plést dvojznačné položky s dvojsmyslnými položkami dokud nezjistí, že má dvě položky, jejichž otázky jsou sémanticky identické, ale odpovědi jsou různé. Tento problém lze jednoduše napravit tak, že se zformuluje položka se dvěma volitelnými odpověďmi:

Q: Jak se nazývají položky, které se vzájemně podobají?

A: a. dvojznačné položky nebo
(OR) b. dvojsmyslné položky

V takovém případě stačí jedna z těchto odpovědí, aby byla položka klasifikována jako zapamatovaná (pokud si uživatel nepřeje zapamatovat oba termíny a nenahradí OR za AND). Problém interference je obzvlášť viditelný při pokusech o zapamatování čísel. Zde nemůže stačit žádný jednoduchý trik spočívající v rozdělení položek. Prastarým řešením tohoto problému je mnemotechnika. Jedna oblíbená mnemotechnická metoda je přiřadit číslům obrázky a pokusit se zapamatovat si scénky tvořené těmito obrázky místo pamatování si čísel. například místo položky:

Q: Jaká je hodnota konstanty p ?
A: 3.14

se student může naučit univerzální seznam 10 obrázků odpovídajících 10 číslicím, např.:

  1. harpuna (protože 1 vypadá jako harpuna),
  2. mince (protože mince má dvě strany),
  3. trojnožka (protože trojnožka má tři nohy),
  4. pes (protože pes má čtyři nohy) atd.

a formulovat mnemotechnickou položku takto:

  • A: Jaká je hodnota konstanty p ?

    Q: 3.14 protože: p se rýmuje s leží a ... na trojnožce leží balón (balón představuje desetinnou tečku), náhle někdo propíchne balón harpunou a skočí po něm velký pes.

    •

    • Ačkoliv konstrukce obrazové scénky se může zdát nešikovná a časově náročná, dává nakonec položky, které si ve většině případů lze snáze zapamatovat než položky složené z čísel. Konečný výsledek je úspora času.

    Koncentrace

    Ve snaze získat víc a víc vědomostí může mít student tendenci dávat ledabylé odpovědi a spěšně skákat od jedné otázky ke druhé, aby zkrátil čas opakování. Při rychlém opakování nehrozí žádné nebezpečí za předpokladu, že rychlosti se dosahuje díky jednoduchosti položek, a nikoliv nedbalostí při odpovědích. Často je možné automaticky odpovědět na otázku, aniž bychom pochopili její skutečný význam. Místo aby odpovědi byly sémantické, tj. založené na významu, stávají se syntaktické či doslovné, založené na automatickém opakování znění položky. Takto získané vědomosti mají nejen malou hodnotu, ale ještě nebezpečnější je, že student může získat pocit deziluze, pokud jde o metodu SuperMemo, protože nedosahuje adekvátního pokroku v získávání požadovaných znalostí. Aby nedocházelo k takovým výsledkům, musí student neustále kontrolovat proces učení tím, že si klade následující otázky:

    • Je daná položka opravdu důležitá pro znalosti, které chci získat?
    • Zajišťuje schopnost odpovědět na otázku, že si skutečně přesně pamatuji, co si chci pamatovat?
    • Mám-li nějaké problémy se zapamatováním dané položky, je tato položka skutečně formulována nejjednodušším a nejjednoznačnějším způsobem?
    • Mám-li problémy s jednoduchou a jednoznačnou položkou, jakou mnemotechnickou metodu bych mohl použít, abych problém vyloučil?
    • Jsou následující prvky učebního procesu vhodně zvoleny?
      • Rozsah předmětu, který chci zvládnout, ve srovnání s mými schopnostmi učit se a s časem, který mám k dispozici.
      • Stupeň, v kterém chci zvládnout detaily znalostí.
      • Úroveň retence (míry udržení informací v paměti), které chci dosáhnout.
      • Množství času, které si mohu dovolit strávit při učení se SuperMemo.

    Všechny tyto otázky si musíme klást znovu a znovu a neustále musíme udržovat stav nejvyšší bdělosti a koncentrace. Stupeň zlepšení získaný zvládnutím schopnosti koncentrace je mimořádně vysoký a stojí za to. Ledabylá práce má za následek slabé výsledky a vyvolává desiluzi.

    Uvědomění si duševních stavů, kterými prochází typický student

    Může být velmi užitečné uvědomovat si od samého začátku stadia, jimiž prochází typický student během vývoje jeho pochopení a postoje vůči SuperMemo. Poznatky uvedené níže byly získány ze stovek dopisů a dotazníků zaslaných do SuperMemo World, a také z osobních kontaktů autora s desítkami studentů, začátečníků i pokročilých.

    90% studentů začíná svůj vztah se SuperMemo díky dobrému mínění, které o programu slyšeli od svých kolegů nebo si přečetli v tisku. Jinými slovy, počáteční postoj je kladný a plný očekávání. Po nastudování základů SuperMemo se reakce studentů velmi různí a jsou vysoce závislé na všeobecné úrovni inteligence a dosaženém vzdělání, zejména vzhledem k exaktním vědám. Podstatná skupina studentů bývá zklamána v důsledku mechanické a opakovací podstaty SuperMemo. V této skupině silně převládají jednotlivci bez vysokoškolského vzdělání nebo se vzděláním humanitního směru. Na druhém konci spektra jsou jednotlivci se silným zázemím v matematice, fyzice nebo informatice, kteří asi mají méně problémů se zvládnutím základů SuperMemo a jejichž první kontakt s metodou pravděpodobně posílí jejich pozitivní postoj. Z této skupiny získává SuperMemo největší počet nadšených příznivců. Pouze 75% jednotlivců pokračuje s učením déle než měsíc! Ti, kteří odpadnou, uvádějí následující důvody: (1) nevěří v SuperMemo (10%, bez vysokoškolského vzdělání nebo se vzděláním humanitního směru), (2) nevěří ve své vlastní schopnosti učení (5%, většinou jednotlivci nad 45 roků a ženy v domácnosti), (3) nemají čas na opakování (25%, většinou soukromí podnikatelé, lékaři, právníci, atd.) a (4) hodlají se vrátit k učení později (60%, studenti). Pouze ti studenti, kteří projdou prvním měsícem učení, mohou skutečně potvrdit užitečnost metody. Mezi těmi je procentuální podíl pozitivních odpovědí 95%! Většina z nich pokládá SuperMemo za skvělou pomoc při učení (50%) nebo užitečný produkt (45%); pouze 5% dotázaných nemělo vyhraněný názor nebo pokládalo SuperMemo za nic zvláštního. Firma SuperMemo World neobdržela jediný dotazník od studenta, který zkoušel pracovat se SuperMemo déle než měsíc a byl s metodou nebo programem všeobecně nespokojený. Procento “odpadlíků” však zůstává vysoké i po jednom měsíci. Po absolvování měsíce učení a opakování si většina studentů přeje používat SuperMemo trvale, ale pro stovky důvodů není schopna držet krok s náročnými rozpisy opakování. Nejrozšířenější názor je, že obnoví opakování v blíže nespecifikované budoucnosti. Tady začíná být vidět hlavní nevýhoda SuperMemo: nedává překvapující výsledky zadarmo! Poskytuje překvapující výsledky, ale jen při tvrdé a systematické práci. Ve shonu naší dynamicky se rozvíjející civilizace se všichni příliš často držíme pravidla, že lepší je vejce dnes než slepice zítra. 10 minut strávených obchodním hovorem, čtením vědeckého článku nebo psaním zprávy se zdá přinášet okamžitý výsledek. Těchže 10 minut strávených rozumným opakováním se SuperMemo vám může ušetřit několik hodin nebo dokonce dnů v průběhu života, ale tato úspora je těžko “uchopitelná”, dokonce i pro zkušeného studenta. Navíc může student po delší době opakování snadno dojít k nesprávnému názoru, že vědomosti již zvládl a nepotřebuje již žádné další opakování. Tak i nejnadšenější studenti zahodí celé týdny opakování; navíc klamný příkaz Tools : Mercy (Milost může snadno vyvolat dojem, že s procesem učení je všechno OK. Pro průměrného uživatele znamená přestávka v učení zvýšení doby učení asi o 20%.

    Neměli byste zapomínat, že nejste jediní, kteří říkají Udělám to zítra nebo příští týden, nebo Myslím, že si to ještě dobře pamatuji. Zapomínání je jako radioaktivní záření: je bez zápachu, bez chuti, a když nakonec pocítíte jeho moc, poškození je již nenávratné.

    Radost

    Existuje bezpečný způsob, jak zjistit, bude-li určitý student úspěšný při práci se SuperMemo nebo ne. Nachází-li radost v dlouhých sezeních při opakování, nutně dokáže ohromné věci. Přestože se na první pohled zdá, že učení a opakování se SuperMemo je jednotvárné, nemusí tomu tak být. Zde je pár příkladů dodatečných činností, které provázejí opakování a poskytují skvělý základ pro to, aby práce se SuperMemo byla zajímavá:

    • Modifikace položek, které asi nesplňují pravidlo jednoduchosti a jednoznačnosti.
    • Odstranění položek, které již nestojí za to si nadále pamatovat.
    • Křížová analýza vědomostního systému, jejíž smysl je vyloučit rozpory nebo redundanci. Všimněte si, že jakýkoliv typ redundance je nežádoucí. Například je-li ve vědomostním systému některé cizí slovo dvakrát, zavádí systém do optimalizačního procesu nežádoucí šum; avšak je-li totéž slovo v různých kontextech, může se zvýšit jeho sémantická asociativnost a zvýšit faktory A (v SuperMemo jsou to E-faktory) ve všech položkách, kterých se to týká.
    • Přidávání položek.
    • Analýza opakovaných položek:
      2. Co daný fakt nebo pravidlo znamená? Je v souladu s ostatními mně známými fakty?
      4. V jakých situacích mohu použít znalost, kterou se učím? Jaký bude její přínos nebo uspokojení z ní?
      6. V jakých situacích jsem zjistil, že bych se měl danou položku naučit? Byl jsem opravdu schopen využít její znalost?
    • Prohlížení všech statistických dat používaných pro monitorování studentova pokroku, atd.

    Jestliže se proces učení zdá být únavný a jednotvárný, student se musí vážně zamyslet nad všemi výše uvedenými předpoklady úspěchu. Nedostatek nadšení je prvním příznakem nesprávného používání metody. Na druhé straně, pokud se SuperMemo používá rozumně a důsledně, začnete na ně mít návyk a zjistíte, že je pro váš osobní a profesionální úspěch absolutně nepostradatelné.

    Zdraví

    Ve většině lidských aktivit pomáhá celkové zdraví dosahovat lepších výsledků v procesu učení. Stále víc je všeobecně známo, jak si udržovat zdraví a dobrou kondici. Přesto však může být užitečné vyjmenovat zde nejdůležitější zásady, které by si měl každý student pamatovat:

    • Dostatek spánku. Právě během spánku se provádí převod mezi krátkodobou a dlouhodobou pamětí. Zejména fáze spánku nazývaná REM je cenná a každý, kdo ponocuje, snižuje podíl spánku REM v následující noci. Intenzivní intelektuální práce může vyvolávat větší potřebu spánku a studentovi by nemělo nic bránit v tom, aby ji uspokojil. Nikdo ještě neměl prospěch z toho, že se snažil ušetřit čas kratším spánkem. Snaží-li se student napodobit Edisona, nutně sníží svou výkonnost. Únava způsobená nedostatkem spánku je jedním z hlavních činitelů, které mohou zruinovat sezení se SuperMemoSuperMemo8. Na druhé straně 40 minut SuperMemo denně pravděpodobně zvýší vaši přirozenou potřebu spánku až o hodinu!
    • Tělesné cvičení je pro úspěšného studenta absolutně nezbytné. Bez něho se dýchací a oběhový systém nemůže snadno přizpůsobit zvýšenému požadavku na kyslík při intenzivní intelektuální práci. Student, který není v dobré tělesné kondici, bývá ospalý a není schopen dosáhnout dostatečné úrovně bdělosti v dlouhých sezeních se SuperMemo. Bolesti zad, únava očí, problémy s hemeroidy, nepořádek v trávicím ústrojí, opakovaná duševní vyčerpání a mnoho jiných potíží těžce pracujícího studenta - to jsou problémy, kterým je možno předcházet dobrou kondicí u fyzicky aktivních jednotlivců. Důsledkem provozování sportu může být dlouhotrvající zvýšení srdeční činnosti a spotřeby kyslíku. Zejména doporučujeme běhání, bruslení na kolečkových bruslích, jízdu na kole, plavání, atd.
    • Je všeobecně známo, že kouření a alkohol jsou hlavní příčiny velké škály neduhů, které nejen narušují proces učení, ale jsou také nebezpečné lidskému zdraví a dlouhodobě ohrožují i život. Alkoholismus je znám svým toxickým vlivem na mozek a je hlavní vnější příčinou senilní demence (ztráty paměti ve stáří). Je také známo, že snižuje počet receptorů NMDA v mozku (receptory související s pamětí) a snižuje retenci ve všech testech paměti. Ovlivňuje jak krátkodobou, tak dlouhodobou paměť. Kouření je nejvíc známo tím, že přispívá ke vzniku srdečních chorob a rakoviny. I studen, který příliš nedbá o svou budoucnost, by měl vědět, že kouření způsobuje také vysoký tlak, zvýšenou citlivost nervového systému, cerebrální hypoxii (snížené okysličování mozku) a mnoho jiných jevů, které jsou při učení vysoce nežádoucí.
    • Přiměřená výživa je pro úspěšné učení nepostradatelná. Je obtížné uvádět konkrétní pokyny, až na to, že konzumovaná potrava by měla splňovat všeobecné zásady zdravé výživy. Například každý ví z vlastní zkušenosti, že dobrý oběd dodá chuť do učení, ale na druhé straně výzkumy ukazují, že úroveň duševní bdělosti po jídle podstatně klesá. Je také známo, že nízkotučná dieta zabraňuje arterioskleróze a měla by se pokládat za žádoucí. Jiný výzkum však ukazuje, že snížená hladina lipoproteinů v krvi (skupina tukových komponent) má v testech inteligence negativní vliv na výkonnost. Průměrná zdravá strava by měla uspokojit všechny potřeby výživy studenta, tak aby žádné doplňky nebyly nutné. Pravidelný příděl vitaminů, zejména B a C, nebo minerálních přípravků však může mít preventivní hodnotu.
    • Čaj a kávu používá mnoho lidí jako stimulátory, zejména v případě nedostatku spánku. I když má čaj a káva kladný vliv na bdělost, vysoké dávky kofeinu a teinu (aktivní složky kávy a čaje) mohou vyvolávat neklid, problémy s koncentrací a, což je nejhorší, poruchy spánku. Oba tyto nápoje a také všechny druhy koly obsahující kofein by se měly konzumovat umírněně.
    • Ve stavu odpočinku využívá mozek jen malou část kyslíku, který se váže na hemoglobin v plících. Avšak v případě intenzivní intelektuální práce může spotřebovávat 30 i více procent celkového přísunu kyslíku. Jak zjistíte, SuperMemo je obzvlášť unavující technika, především proto, že nutí váš mozek pracovat na nejvyšší otáčky (opakování jsou naplánována na co nejdelší intervaly). Průměrný netrénovaný student pocítí již po 20 minutách souvislého opakování nepřekonatelnou ospalost. Většina lidí zjistí, že nemohou pracovat se SuperMemo déle než 1 hodinu a každá minuta nad touto mezí jim působí duševní muka. To ukazuje na velkou důležitost přístupu čerstvého vzduchu do místnosti při učení. Dostatek spánku, čerstvý vzduch a nadšení pro práci jsou nejlepší spojenci studenta, který si přeje trávit se SuperMemo dlouhá sezení a dosahovat báječných výsledků.

    Mnemotechnické desatero

    1. Vytvořte si svůj vlastní vědomostní systém obsahující jen vědomosti, které nejvíc potřebujete. Než vytvoříte obecný obraz oboru, který chcete zvládnout, nezacházejte příliš do detailů. Too much pudding will choke the dog (Příliš mnoho pudinku psa zadusí).
    2. Pracujte s metodou SuperMemo pravidelně stejně dlouhou dobu každý den. No pain, no gain (Bez bolesti (námahy) nelze nic získat).
    3. Nepřepínejte se. More haste, less speed (Více spěchu, menší rychlost).
    4. Než začnete intensivně rozšiřovat svůj vědomostní systém, vyzkoušejte si svou schopnost formulovat snadno zapamatovatelné položky, své duševní schopnosti a kolik času si můžete dovolit věnovat dlouhodobému procesu opakování. Look before you leap (podívej se, než skočíš).
    5. Dbejte na to, aby vaše položky byly co nejjednodušší a aby se dotazovaly na všechny důležité aspekty studovaného faktu nebo pravidla. Small is beautiful (Co je malé, to je milé).
    6. U nejméně poddajných položek šetřete budoucí čas strávený opakováním využitím mnemotechniky. A stitch in time saves nine (jeden včasný steh ušetří devět dalších).
    7. Koncentrujte se a nepřestávejte myslet. Opakování by mělo být vědomé, ne automatické. All troubles come from ignorance (všechny potíže pocházejí z neznalosti).
    8. Není-li pro vás práce se SuperMemo příjemná, přestaňte přidávat položky a věnujte větší pozornost očistě svého vědomostního systému od neužitečného a špatně strukturovaného harampádí. Nothing succeeds like success (nic se nedaří lépe než úspěch).
    9. Udržujte se v dobré formě. Nezkracujte spánek, pravidelně cvičte a zbavte se všech zlozvyků jako je kouření a pití alkoholu. Healthy flesh nurtures healthy spirit (v zdravém těle zdravý duch).
    10. Čas od času si přečtěte tato pravidla a zformulujte je jako položky SuperMemo, které by bylo možno umístit do vašeho vědomostního systému. Learn fast and forget about forgetting (Učte se rychle a zapomeňte na zapomínání (říká SuperMemo World). Například: Otázka: Jaká je nejlepší metoda pro překonání nepoddajných položek? Odpověď: použít Delete (Vymazat)!

    ****


Editovat

Edit (Editovat)

Podnabídka Edit (Editovat) na hlavní nabídce nabízí následující volby:

  • Add a new item (Přidat novou položku) - přidat novou položku do aktuálního systému vědomostí . Položka je prvek , který se zúčastňuje opakování a často má tvar otázka - odpověď (viz též: Témata a položky )
  • Add a new topic (Přidat nové téma) - přidat nové téma do aktuálního systému vědomostí. Téma je prvek, který se nezúčastňuje opakování a uvádí souhrnný přehled studovaných vědomostí (viz též: Témata a položky )
  • Delete element (Vymazat prvek) - vymazat právě zobrazený prvek
  • Edit text (Editovat text)
    • Edit first question (Editovat první otázku) - editovat první textovou komponentu , která je viditelná v době otázky
    • Edit first answer (Rditovat první odpověď) - editovat první textovou komponentu, která je označena jako odpověď
    • Edit all (Editovat vše) - přepnout všechny textové komponenty do editačního režimu
    • Add pronunciation (Přidat výslovnost) - přidat dvojici slovo-fonetický přepis do registru fonetického přepisu
    • Apply filter (Použít filtr) - zpracovat všechny texty používané prvky v systému vědomostí pomocí filtračního souboru (např. nahradit množinu řetězců jinou množinou řetězců, odstranit ohraničené poznámky, přesunout ohraničené poznámky do registru poznámek atd.)
  • Menus (Nabídky) - umožnit otevření dostupné místní nabídky pro jednotlivá okna nebo komponenty
    • Element (Prvek) - otevřít místní nabídku pro právě zobrazený prvek
    • Component (Komponenta) - otevřít místní nabídku pro právě vybranou komponentu v právě zobrazeném prvku
    • Contents (Obsah) - otevřít místní nabídku pro okno obsahu
    • Browser (Prohlížeč) - otevřít místní nabídku pro právě aktivní prohlížeč
    • Registry (Registr) - otevřít místní nabídku pro právě aktivní okno registru

  • ****

    •


Nástrojový panel editace

Editační nástrojový panel

Editační nástrojový panel se objeví v horní části okna prvku , zvolíte-li kartu Edit (Editovat):

Použití jednotlivých tlačítek:

  • Tlačítka místních nabídek - otevřít místní nabídky dostupné také kliknutím pravým tlačítkem myši na oblast zobrazení prvku a na jednotlivé komponenty
    • Místní nabídka prvku (Element pop-up) - otevřít místní nabídku prvku s operacemi týkajícími se právě zobrazeného prvku
    • Místní nabídka komponenty (Component pop-up ) - otevřít aktuální místní nabídku komponenty s operacemi týkajícími se typu aktuální komponenty
  • Tlačítka vlastností komponent - změnit vlastnosti právě vybrané komponenty:
      • Tlačítko Písmo (Font) - změnit font právě vybrané textové komponenty nebo komponenty typu rtf
      • Tlačítko Zvětšit velikost písma - zvětšit velikost fontu v textové komponentě nebo velikost vybraného textu v komponentě rtf
      • Tlačítko Zmenšit velikost písma - zmenšit velikost fontu nebo vybraného textu v textové komponentě nebo v komponentě rtf
      • Tlačítko Tučně - změnit atribut "bold" fontu v textových komponentách
      • Tlačítko Kurzíva - změnit atribut "italics" fontu v textových komponentách
      • Tlačítko Podtrženo - změnit atribut "underline" fontu v textových komponentách
      • Tlačítko Barva písma - změnit barvu fontu v právě vybrané textové nebo rtf komponentě
      • Tlačítko Barva komponenty - změnit barvu právě vybrané komponenty
  • Tlačítko Test opakování - otestovat cyklus opakování na právě zobrazeném prvku (tj. prověřit, zda komponenty odpovědi nejsou viditelné v době otázky a zobrazí se po stisknutí tlačítka Zobrazit odpověď (Show answer)

    Tlačítko Uložit šablonu (Save template) - uložit aktuální rozložení a atributy komponent jako šablonu pro pozdější použití v jiných prvcích

    Tlačítko Použít šablonu (Apply template) - vymazat všechny komponenty a použít dříve uloženou šablonu

    Tlačítka Režimu zobrazení komponent - změnit způsob zobrazení a zacházení s komponentami:

    •
      • Tlačítko Editační režim (Editing mode) - nastavit všechny komponenty do režimu, který umožňuje editovat texty, objekty OLE atd.
      • Tlačítko Přetahovací režim (Dragging mode) - nastavit všechny komponenty do režimu, který umožňuje přetahování a změnu rozměrů myší
      • Tlačítko Prezentační režim (Presentation mode) - nastavit všechny komponenty tak, jak je bude vidět student během učení
  • Tlačítko Návěští komponenty (Component tags) - zobrazit čísla komponent, jejich typ a jméno

    Tlačítko Umístění a velikost (Alignment and size) - umožnit změnu velikosti a vyrovnání všech komponent, které jsou právě v editačním nebo přetahovacím režimu .

    •

    • ****


Okno dat prvku

Okno Data prvku

Statistická okna Statistics (Statistika) a Element data (Data prvku) je možno nepohodlněji zobrazit stisknutím F5 (nebo zvolením Window (Okno) : Classic ). Tím se statistická okna uspořádají klasickým způsobem poprvé zavedeným v SuperMemo 3.0 (1988):

Data prvku zobrazená na levé straně okna dat prvku:

  • Repetitions (Počet opakování) - počet opakování věnovaných položce, jejíž data jsou zobrazena. Pokud byla položka zapomenuta, zobrazí se v závorkách počet selhání paměti (memory lapses)
  • Interval - aktuální interval položky, tj. počet dnů mezi Posledním opakováním (Last repetition) a Příštím opakováním (Next repetition).
  • Last repetition (Poslední opakování) - datum posledního opakování položky
  • Next repetition (Příští opakování) - datum, kdy by se mělo provést příští opakování položky
  • A-Factor - A-faktor spojený s položkou. A-faktor je míra obtížnosti položky. Čím vyšší je A-faktor, tím je položka snazší. Nejobtížnější položky mají A-faktor rovný 1,3
  • U-Factor - podíl starého intervalu a nového intervalu. Jen u položek, které byly opakovány pouze jednou, se U-faktor rovná prvnímu intervalu. U-faktory jsou důležitým prvkem algoritmu SM-8. Pokud algoritmus neznáte, U-faktor pro vás nemá velký význam
  • Forgetting index (Index zapomínání) - plánovaná pravděpodobnost zapomenutí položky při příštím opakování (v procentech). Index zapomínání je možno změnit na požadovanou hodnotu (např. pomocí Forgetting index na místní nabídce v okně obsahu ). Například je-li index zapomínání 10%, máte 90% pravděpodobnost, že si budete položku při příštím opakování pamatovat
  • Future repetitions (Budoucí opakování) - odhadnutý počet opakování položky v příštích 30 letech. Tato hodnota je odvozena z A-faktoru, Počtu opakování (Repetitions) a matice optimálních faktorů (viz Algoritmus SM-8 )
  • First grade (První známka) - známka, kterou položka dostala při prvním opakování. Tato hodnota je důležitá, protože pro rychlé určení A-faktoru položek hned po jejich prvním opakování se používá korelace známka versus A-faktor
  • Ordinal (Ordinální číslo) - ordinální číslo (ordinal number) spojené s prvkem. Ordinální čísla se mohou používat pro třídění (řazení) položek ve frontě čekajících prvků , frontě závěrečného procvičování atd. Čím nižší je ordinální číslo, tím vyšší je priorita položky. Ordinální čísla mají rozsah od 0 do 100
  • Type (Typ) - typ prvku: položka nebo téma (viz též: Témata a položky )
  • Status - aktuální status prvku: vynechaný (dismissed), čekající (pending) nebo probraný (memorized)

Popis dat případně zobrazených v pravé části okna prvku najdete v eldata.htm na stránce SuperMemo World.

Když dvakrát kliknete na okno dat prvku, zobrazí se historie opakování prvku.

****


Okno prvku

Obsah : Technický popis
Okno prvku

V okně prvku v SuperMemo se zobrazuje obsah jednotlivých prvků (elements) .

Nejdůležitější komponenty okna prvku jsou:

  • Oblast zobrazení prvku (ve středu okna), v níž jsou umístěny jednotlivé komponenty , například otázka, odpověď, video, komponenty html , atd.
  • Nadpis (zcela nahoře) s názvem právě zobrazeného prvku.
  • Nabídka: Soubor (File) a Nápověda (Help) . Tato nápověda je viditelná jen na začátečnické a základní úrovni . Na profesionální úrovni je tato nabídka sloučena s hlavní nabídkou hlavního okna .
  • Nástrojové panely na horní straně okna:
    • Tlačítka nástrojového panelu Navigovat používaná pro pohyb mezi prvky a k vyhledávání prvků.
    • Tlačítka nástrojového panelu Vytvořit (Compose) používaná pro přidávání nových komponent do oblasti zobrazení prvku (viz níže).
    • Tlačítka nástrojového panelu Editovat pro rychlou modifikaci vlastností komponent.
    • Karta Cesta (Path) - přesné umístění aktuálního prvku ve stromě vědomostí (tj. cesta potomků (descendants) v okně obsahu (contents window ).
    • Karta Nadpis (Title) - editační oblast pro editaci názvu prvku
  • Tlačítka pro učení na spodní straně okna:
    • Učit se (Learn) - opakování nevyřízené látky a učení nové látky
    • Přidat nový (Add new) - přidat nový prvek
    • Zapamatovat (Remember) - zavést aktuální prvek do procesu učení
    • Zapomenout (Forget) - vyjmout aktuální prvek z procesu učení
    • Vynechat (Dismiss) - ignorovat aktuální prvek v procesu učení, tj. odstranit jej jak z procesu učení, tak z fronty čekajících prvků (pending queue)
  • Kliknete-li na prázdnou oblast vpravo od tlačítek pro učení, otevře se dialogový panel parametry prvku (element parameters) .
    •

    • Profesionální úroveň

    Okno prvku nabízí také řadu pokročilých voleb ze své místní nabídky (pop-up menu). Místní nabídka se otvírá kliknutím pravým tlačítkem myši na oblast zobrazení prvku (nikoliv na některou z jeho komponent). Nejste-li si jisti, kde jsou komponenty umístěny, nebo pokrývají-li komponenty celou oblast zobrazení prvku, klikněte pravým tlačítkem na prázdnou oblast vpravo od běžců karet (tj. Navigovat, Vytvořit, atd.). Místní nabídku můžete otevřít také stisknutím Alt+F10 .

    Časté otázky

    Otázka:
    Jak se vymaže     prvek v SuperMemo 98?
    Odpověď:
    Vyberte si jednu z následujících možností:

    • Edit (Editovat) : Delete element (Vymazat prvek) na hlavní nabídce
    • Klikněte na tlačítko Delete (Vymazat) v okně obsahu
    • Zvolte Edit (Editovat) : Delete (Vymazat) na místní nabídce obsahu
    • Stiskněte Del v okně obsahu
    • Zvolte Delete element (Vymazat prvek) na místní nabídce prvku
    • Stiskněte Shift+Ctrl+Del v okně prvku

    (Ryszard Kosowicz, Krakow, Poland, May 16, 1997)
    Otázka:
    Jak mohu rychle okopírovat text položky do jiné položky bez dvojího použití schránky (pro otázku a pro odpověď)?
    Odpověď:
    Použijte Duplicate (Duplikovat) na     místní nabídce prvku (nebo stiskněte Ctrl+Alt+U na kopírovaném prvku)

    (Doug Edmunds, USA, Nov 4, 1997)
    Otázka:
    Jaký je nejrychlejší způsob kontroly čísla právě zobrazeného     prvku ?
    Odpověď:
    Stiskněte     Ctrl+G

    ****


Místní nabídka prvku

Obsah : Tecnický popis : Okno prvku
Místní nabídka prvku

Nejdůležitější operace s prvkem zobrazeným v okně prvku jsou dostupné z místní (kontextové) nabídky prvku. Nabídku otevřete stisknutím Alt+F10 nebo kliknutím pravým tlačítkem na prázdnou oblast prvku (tj. oblast nepokrytou komponentami; kliknutím na komponentu by se otevřela místní nabídka komponenty. Je-li váš prvek zcela zaplněn komponentami, můžete také kliknout pravým tlačítkem na nástrojový panel prvku (kromě tlačítka Next (Další), které má svou vlastní místní nabídku).

Místní nabídka prvku má následující volby:

  • Classify (Klasifikovat) - nastavit umístění prvku v procesu učení
    • Forget (Zapomenout) - odstranit zobrazený prvek z procesu učení a dát ho na konec fronty čekajících prvků
    • Remember (Zapamatovat) - uvést zobrazený prvek do procesu učení (opakování). Volitelně je možno zadat první interval, např. jste-li si jisti, že si položku budete pamatovat ještě za dva měsíce, můžete ušetřit čas, když zvolíte interval 60.aniž byste poškodili proces učení. Když prvek jednou proberete (poprvé se jej učíte), bude se vám periodicky vracet k opakování
    • Dismiss (Vynechat) - ignorovat zobrazený prvek při opakování (v procesu učení). Bude nadále dostupný pro prohlížení nebo vyhledávání v souhrnu vědomostí, nebude však vstupovat do procesu učení, dokud explicitně nezadáte Remember (Zapamatovat) (viz výše)
    • Add to drill (Přidat k procvičování) - přidat zobrazený prvek do fronty závěrečného procvičování
  • Edit (Editovat)
    • Duplicate (Duplikovat) - vytvořit kopii právě zobrazeného prvku na tomtéž místě stromu vědomostí . Tato volba je velmi užitečná pro vytváření položek s vynechávkou (cloze deletion items) . Máte-li problémy s vytvářením dobře strukturovaných položek, můžete zkusit tyto položky. Vezměte prostě větu, která vyjadřuje vědomost, kterou se chcete naučit. Vytvořte několik kopií této věty pomocí Duplicate a vymažte kritická slova nebo fráze z každé kopie (duplikátu). Nahraďte vynechané části třemi tečkami a dejte vynechaný text do pole odpovědi. Je to velmi efektivní technika učení pro začátečníky
    • Edit title (Editovat název) - otevřít kartu názvu s editačním polem, které umožňuje editovat název prvku. Používejte tuto volbu nebo Alt+T pro rychlé generování názvu z textových polí v prvku. Chcete-li editovat existující název, můžete dát přednost kliknutí na kartu Title (Název) v horní části okna prvku . Tím se zabrání generování nového názvu
    • Edit parameters (Editovat parametry) - otevřít dialogový panel s parametry prvku . Tato volba, dostupná rovněž pomocí Ctrl+Shift+P, je nejužitečnější pro následující účely: změnu indexu zapomínání (např. pro zvýšení kvality zapamatování), změnu ordinálního čísla (nejčastěji používáno pro třídění fronty čekajících prvků ) a změnu kategorie , ke které prvek patří. Rozhodnete-li se v tomto posledním případě, že vaše položka bude patřit raději do Fyziky než do Chemie, můžete v Edit: Edit parameters: Category (Kategorie) zvolit Fyzika, a položka se přesune do odpovídající větve stromu vědomostí . Funkci Edit parameters (Editovat parametry) můžete použít také pro přidání poznámky k položce nebo k zobrazení historie opakování prvku
    • Swap components (Zaměnit komponenty) - zaměnit texty a fonty mezi první textovou komponentou, jež není odpovědí, a první textovou komponentou odpovědi. Obvykle tuto volbu potřebujete pro záměnu otázek a odpovědí, když se učíte dvojjazyčné dvojice slovíček. Je to nejužitečnější ve spojení s Duplicate (viz výše). Klávesová zkratka pro záměnu komponent je Ctrl+Shift+S
    • Move to ClipBox (Přesunout do schránky) - přesunout právě zobrazený prvek do schránky prvků. Tímto způsobem můžete snadno přenést obsah aktuálního prvku do jiného prvku. Jakmile přejdete na druhý prvek, jednoduše přetáhnete obsah schránky prvku do oblasti zobrazení prvku
    • Reset repetition history (Vynulovat historii opakování) - vynulovat historii opakování pro právě zobrazený prvek. Tuto volbu můžete použít, když podstatně změníte obsah prvku, takže je to, jako byste se učili novou vědomost.
  • Template (Šablona) - operace se šablonami
    • Save as template (Uložit jako šablonu) - uložit právě zobrazený prvek jako šablonu v registru šablon. To umožňuje přenesení vzhledu prvku na jiné prvky.
    • Apply template (Použít šablonu) - vymazat všechny komponenty a zavést (načíst) šablonu z registru šablon
    • Merge with template (Sloučit se šablonou) - sloučit právě zobrazený prvek s šablonou z registru šablon. Proces slučování začíná načtením zvolené šablony. Pak SuperMemo přenese všechny souhlasné objekty registrů ze staré šablony do nové šablony. Všimněte si prosím, že SuperMemo vás nebude varovat, nemůže-li najít souhlasnou komponentu. Například obsahuje-li váš prvek obrázek a vy jej sloučíte s šablonou, která nemá obrazovou komponentu, obraz se vymaže. Pro slučování šablon neexistuje žádná funkce "krok zpět" (undo).
    • Add to template (Přidat do šablony) - přidávání šablony je podobné slučování se šablonou, avšak obsah nové šablony se prostě "naloží" na starou šablonu. Tak můžete vytvořit šablonu s obrazem a přidat tento obraz do vybraných prvků přidáním šablony s obrazem. Při slučování se šablonou je počet komponent roven počtu komponent ve slučované šabloně, kdežto při přidávání šablony je počet komponent roven součtu počtu komponent v prvku a v šabloně
    • Save to file (Uložit do souboru) - uložit aktuální prvek jako soubor šablony. Tento soubor je později možno načíst do jiného souhrnu vědomostí pomocí Load from file (Načíst ze souboru) (viz níže). Šablonové soubory si můžete prohlížet libovolným textovým editorem. Všimněte si, že v těchto souborech nejsou uloženy objekty registrů, ale jen odkazy na příslušné soubory. Šablonový soubor je tedy užitečný, jen pokud zůstává zdrojový souhrn vědomostí na svém původním místě na disku. Jakmile je přesunut, odkazy v souboru šablony budou nepoužitelné
    • Load from file (Načíst ze souboru) - načíst soubor šablony uložený pomocí Save to file (viz výše). Načtením souboru šablony se vymažou všechny komponenty a vytvoří se nové komponenty specifikované v šabloně
  • Selection (Výběr) - provádění operací na skupině vybraných komponent. Komponenty vyberete tím, že je dáte do editačního režimu nebo do přetahovacího režimu
    • Link registry member (Propojit člen registru) - propojit daný člen registru se všemi vybranými komponentami. Komponenty musí být téhož typu. Například jsou-li komponenty obrazy, propojíte s nimi obrazový soubor z obrazového registru. Jsou-li to texty, propojíte je s členem textového registru atd.
    • Link registry font (Propojit font) - propojit vybraný font z registru fontů se všemi vybranými komponentami. Komponenty musí být textové nebo zvukové
    • Alignment and size (Vyrovnání a velikost) - uspořádat skupinu komponent nebo změnit jejich velikost. To usnadňuje vyrovnání levých okrajů komponent, jejich rovnoměrné rozmístění, sjednocení jejich velikosti atd.
  • Background (Pozadí) - určit obraz v pozadí použitý pro právě vybraný prvek. Chcete-li změnit pozadí ve všech prvcích, použijte Tools (Nástroje) : Options (Volby) : SuperMemo : Default background image (Implicitní obraz v pozadí)
    • Import file (Importovat soubor) - importovat obrazový soubor pro použití jako pozadí v právě zobrazeném prvku. Tento soubor bude nejprve zabudován do obrazového registru. Soubor musí být ve formátu BMP
    • Link from registry (Propojit z registru) - propojit prvek s obrazem z obrazového registru. Propojený obraz se zobrazí jako pozadí
    • Arrangement (Uspořádání) - určit způsob zobrazení obrazu v pozadí
      • Top-left (Levý horní) - zobrazit obraz pozadí v levém horním rohu oblasti zobrazení prvku
      • Center (Střed) - zobrazit obraz pozadí ve středu oblasti zobrazení prvku
      • Tile (Dlaždice) - vytvořit dlaždice z obrazu pozadí na celé oblasti zobrazení prvku, tj. zaplnit prvek mnoha kopiemi těsně přiléhajících bitmapových obrazů
      • Stretch (Rozprostřít) - rozprostřít obraz pozadí tak, aby přesně vyplnil celou oblast zobrazení prvku. Je-li obraz pozadí menší než tato oblast, roztáhne se
    • Delete (Vymazat) - odstranit obraz pozadí
  • Color (Barva) - určit barvu pozadí prvku
  • AutoPlay (Autom. přehrání) - zajistit, aby prvek automaticky přehrál první přehrávatelnou komponentu při každém zobrazení prvku. Přehrávatelné komponenty jsou: zvuk, video, skript a programová komponenta
  • Topic (Téma) - označit aktuální jako téma (jako protiklad položky ). Pokud Topic není zatrženo, prvek je pokládán za položku. To je nejdůležitější pro stanovení toho, jak bude s prvkem zacházeno v procesu učení. Témata se předkládají pouze jednou a pak jsou z procesu učení vynechána (dismissed). Používají se jen jako shrnující úvod do studované látky. Položky vstupují do procesu učení a opakují se neustále. Představují vědomosti, které je třeba si uchovat v paměti (viz též: Témata a položky )
  • Components (Komponenty)
    • Component order (Pořadí komponent) - změnit pořadí komponent. Pořadí komponent je důležité pro kladení komponent přes sebe. Je také důležité pro funkci automatického přehrávání AutoPlay (viz výše). AutoPlay přehraje první přehrávatelnou komponentu v pořadí komponent. Podobně SuperMemo automaticky generuje název prvku z textu první textové komponenty v pořadí komponent
    • Test repetition cycle (Testovat cyklus opakování) - otestovat cyklus opakování bez provádění opakování. To umožňuje vidět, zda se všechny komponenty zobrazí v patřičných krocích cyklu: zobrazit odpověď, známkovat, další prvek, atd.
    • Repeat AutoPlay (Opakovat autom. přehrání) - znovu přehrát první přehrávatelnou komponentu (tu, která se přehrává pomocí AutoPlay). To může být užitečné ve cvičeních výslovnosti, když chcete znovu slyšet studované slovo
    • Previous component (Předchozí komponenta) - vybrat předchozí komponentu a převést ji do editačního režimu (právě vybraná komponenta se převede do prezentačního režimu )
    • Next component (Následující komponenta) - vybrat následující komponentu a převést ji do editačního režimu
  • Delete components (Vymazat komponenty) - vymazat všechny komponenty v právě zobrazeném prvku
  • Delete element (Vymazat prvek) - vymazat právě zobrazený prvek (totéž jako Ctrl+Shift+Del). Všimněte si, že dcery aktuálního prvku se ve stromě vědomostí se rovněž vymažou
  • Mode (Režim)
    • Editing (Editační) - nastavit všechny komponenty do editačního režimu
    • Dragging (Přetahovací) - nastavit všechny komponenty do přetahovacího režimu
    • Presentation (Prezentační) - nastavit všechny komponenty do prezentačního režimu
    • Switch window (Přepnout okno) - přepnout do okna obsahu (tatáž klávesová zkratka, Ctrl+Shift+W, vás převede zpět z okna obsahu do okna prvku)
  • Jump to (Skočit na) - zobrazit jiný prvek v okně prvku
    • Next (Následující) - zobrazit následující prvek podle pořadí prvků zadaného v místní nabídce tlačítka Next (Další)
    • Previous (Předchozí) - zobrazit předchozí prvek podle pořadí prvků zadaného v místní nabídce tlačítka Next (Další)
    • Next element (Následující prvek) - zobrazit následující prvek ve stromě vědomostí
    • Previous element (Předchozí prvek) - zobrazit předchozí prvek ve stromě vědomostí
    • Last element (Poslední prvek) - zobrazit poslední prvek souhrnu vědomostí, tj. poslední dceru poslední dcery ... kořenového uzlu stromu vědomostí
    • First element (První prvek) - zobrazit kořenový uzel celého souhrnu vědomostí
    • Parent element (Mateřský prvek) - Zobrazit mateřský prvek aktuálního prvku

Časté otázky

(Bonnie Smithson, USA, Feb 24, 1998)
Otázka:
Jak dát obrázky do odpovědi?
Odpověď:
Zatrhněte Answer (Odpověď) v místní nabídce obrazové komponenty

****


Dialogový panel Parametry prvku

Zvolíte-li Edit parameters (Editovat parametry) na místní nabídce prvku , stisknete Ctrl+Shift+P , nebo dvakrát kliknete na prázdné místo vpravo od tlačítek pro učení na spodním okraji okna prvku , otevře se dialogový panel s editovatelnými parametry prvku .

Tento dialogový panel má následující pole:

  • Element title (Název prvku) - název prvku
  • Element number (Číslo prvku) - je to fyzické umístění prvku v systému vědomostí
  • Interval - interval mezi posledním opakováním a příštím opakováním (ve dnech)
  • Next repetition (Příští opakování) - datum příštího opakování
  • A-factor - aktuální A-faktor spojený s prvkem (A-faktory určují obtížnost prvku)
  • Forgetting index (Index zapomínání) - aktuální index zapomínání požadovaný pro prvek
  • Ordinal (Ordinální číslo) - aktuální ordinální číslo přiřazené prvku
  • Category (Kategorie) - pole, které umožňuje přemístit prvek do jiné kategorie obsahu (jsou-li kategorie definovány )
  • Comment (Poznámka) - pole, v němž se zobrazuje poznámka spojená s prvkem
  • History (Historie) - tlačítko pro zobrazení okna s historií opakování prvku

Dialogový panel parametrů prvku pravděpodobně použijete v následujících situacích:

  1. Změna ordinálního čísla prvku (otevřete dialog a napište nové ordinální číslo). Jednotlivá ordinální čísla také můžete měnit editací v okně dat prvku
  2. Změna indexu zapomínání prvku (otevřete dialog, stiskněte Alt+F a napište nový index zapomínání). Jednotlivé indexy zapomínání můžete měnit také editací v okně dat prvku
  3. Přesunutí prvku do jiné kategorie obsahu (otevřete dialog, zvolte jinou kategorii v poli Category (Kategorie) a klikněte na OK)
  4. Přidání poznámky (napište poznámku do pole Comment)
  5. Prohlížení historie opakování pro daný prvek (klikněte na History). Historii opakování si také můžete prohlížet dvojitým kliknutím na okno dat prvku .

****


Časté otázky

Časté otázky o SuperMemo
Máte-li dotaz, který není na tomto seznamu, napište na SuperMemo World .

Otázky uvedené v tomto seznamu obsahují pouze dotazy z nedávné doby. Zvolte si jedno z následujících témat:

  1. Techniky rychlého učení (SuperMemo, mind maps, MegaMemory atd.)
  2. Používání SuperMemo 98 pro Windows (viz též: Používání SuperMemo 8 )
  3. Objednání SuperMemo a jeho instalace
  4. Formulování vědomostí v SuperMemo
  5. Používání Advanced English se SuperMemo
  6. Knihovna SuperMemo
  7. SuperMemo for Windows CE (NEW: Dec 30)
  8. Ostatní: Windows CE, Psion, Linux, Unix, Dos, PalmPilot
  • Všechny soubory FAQ si můžete stáhnout pomocí následující šablony: http://www.supermemo.com/help/faq*.htm
    •

    • Další otázky a odpovědi najdete také v souboru faq.htm na webové stránce SuperMemo World (anglicky).

    *


Časté otázky o AE97

Časté otázky o Advanced English 97

(Marcin Piekarniak, Poland, Dec 2, 1997)
Otázka:
Jak se dá snadno zálohovat Advanced English 97 ? V Advanced English 94 bylo možno celý systém komprimovat do souboru 1,4 MB!
Odpověď:
Jen SuperMemo 8.4 řeší tento problém elegantně. Můžete zazálohovat jen proces učení. Tím se budou ukládat jen data náležející položkám v procesu učení (nikoliv položky samotné). Pro export dat použijte File (Soubor) : Export: Learning process (Proces učení). Později, pro reinstalaci Advanced English 97, můžete proces učení obnovit pomocí File: Import : Learning process.

(Pawel Brzozowski, Poland, Mar 11, 1998)
Otázka:
Jak mohu z Advanced English odstranit obrázky?
Odpověď:
Můžete vymazat podadresář ELEMENTS. Tím se eliminují všechny multimediální soubory z vašeho pevného disku. Pouze zvuky zůstanou neovlivněny. Ty jsou uloženy na CD-ROM Advanced English č.2 .
Alternativně můžete použít Node operations (Uzlové operace): Template (Šablona): Merge with template (Sloučit s šablonou) na místní nabídce okna obsahu pro aplikaci nové šablony na celý věd. systém Advanced English. Pokud vaše šablona nebude obsahovat obrazovou komponentu, všechny obrazy se vymažou.

(Bobby Faulkner, US, Jan 4, 1998)
Otázka:
Ačkoliv jsem rodilý mluvčí, při čtení o Advanced English na vaší webové stránce jsem si myslel, že by bylo užitečné to zkusit, nejen pro mne, ale také pro mé dvě dospívající děti. Moje dcera bude v roce 1999 studovat na University of Washington a zajímá se o žurnalistiku. Protože zatím neznám obsah Advanced English a soudím jen podle toho, co jsem viděl na demonstrační verzi SuperMemo, věřím, že budu spokojen! Souhlasíte se mnou?
Odpověď:
Procházeli jsme látku s rodilými Američany a ti mívali problémy s více než 50% položek. Všichni souhlasili s tím, že učení s Advanced English by bylo užitečné pro jejich jazykové znalůosti! Advanced English skutečně obsahuje spoustu pokročilé slovní zásoby, specializovanou terminologii (technika, medicina, podnikání atd.), přísloví, idiomy atd., které stojí za to znát. Navíc je "GRE rich", tj. obsahuje úplnou slovní zásobu pro zkoušky GRE. Jsou zde však dva problémy:

  1. látka je seřazena podle obtížnosti a položky v prvních 2000 by prostě mohly být málo náročné. To je možno řešit: (1) promícháním fronty čekajících prvků (Tools (Nástorje): Randomize (Náhodný výběr): Pending (Čekající prvky)), nebo (2) učením jen jednotlivých sekcí, např idiomů, přejatých slov atd.
  2. nerodilí mluvčí oceňují každou položku, která je přímým přínosem pro jazykové znalosti. Často se stanou "závislí". Látka má povahu křížovky a může být zábavná, ale ... najde rodilý mluvčí dostatek motivace, aby ji pravidelně probíral?

Otázka:
Jak mohu upgradovat svou instalaci Advanced English 97 na SuperMemo 8.4 ?
Odpověď:
Spusťte SM8CZZIP.EXE a okopírujte nový SM8.EXE na do adresáře zvoleného pro instalaci Advanced English na místo starého SM.EXE. Když poprvé spustíte Advanced English, upgrade se provede automaticky. Své registrační heslo můžete zadat tímtéž způsobem, jak je uvedeno v pokynech, které jste dostal pro registraci SuperMemo 8.4.

(Jan Gromadzki, Poland, Jul 11, 1998)
Otázka:
Koupil jsem si Advanced English 97 a nemohu se dostat přes úvod. Jsou tam šipky ukazující na ikony, které neexistují. Kde je chyba?
Odpověď:
Potřebujete do svého počítače nainstalovat zvukovou kartu (to je uvedeno v minimálních požadavcích!). Některé skriptové příkazy nepracují bez zvukové karty a úvodní část rozsáhle využívá skripty. Chcete-li používat Advanced English bez zvuku, proveďte následující:

  • stiskněte Ctrl+P (spustí se dialogový panel Options (Volby))
  • zvolte kartu Data access
  • zatrhněte kulaté tlačítko Full Access (Úplný přístup) (tím se změní režim přístupu na úplný (Full) na rozdíl od režimu Read-Only (jen čtení), který je nastaven na začátku úvodu)
  • zrušte zatržení Hide Navigation (Skrýt navigační panel) (aby se zobrazil navigační nástrojový panel, který by se jinak zapnul pomocí skriptů po uvedení uživatele do dalších složitostí programu)
  • vymažte cestu zobrazenou v poli Secondary storage (Sekundární paměť) (tato cesta ukazuje, kde se mají hledat zvukové soubory používané v Advanced English; bez zvukové karty jsou tyto soubory zbytečné a vymazání cesty urychlí program)

(Jorge Adam Cleto Cohn, Brazil, Nov 5, 1998)
Otázka:
Je vědomostní systém English Grammar v Advanced English založen jen na cvičeních, nebo obsahuje i teoretický přehled gramatiky?
Odpověď:
Neobsahuje žádný teoretický přehled. Všechny položky jsou založeny na praktických příkladech.

(Gabor Schmera, US, Dec 13, 1997)
Otázka:
Jak přidám do svých položek "magnetofon" (jak je to v Advanced English 97 )?
Odpověď:
Přidejtezvukovou komponentu a na její místní nabídce zatrhněte Recorder.

(Adam Salamon, Poland, Nov 4, 1997)
Otázka:
Za poslední rok jsem probral 10 000 položek z Advanced English 94. Mohu nyní upgradovat na Advanced English 97 ?
Odpověď:
Bohužel neexistuje jednoduchý způsob!. Můžete zkusit jedno z následujících řešení:

  • Přestaňte se učit novou látku v Advanced English 94, zahajte učení s Advanced English 97, pokračujte v opakováních s AE94 a postupně mažte dublovanou látku z AE94 (doporučujeme při velkém počtu probraných položek)
  • Vypněte zvuk v AE94, importujte probrané položky do zvláštní větve v AE97 a provádějte opakování jen v AE97 (zvuky z AE94 budou ztraceny). To bude vyžadovat mnoho diskového prostoru!
  • Vzdejte se Advanced English 94 úplně (v případě, že počet probraných položek je menší než 2000-3000)

(Anatolyi Lipatov, Ukraine, Jul 12, 1998)
Otázka:
Používám Advanced English, abych si zlepšil svou angličtinu a obchodní angličtinu. Nyní se hlásím na zkoušku CFA (to je program "Chartered Financial Analyst" instituce "Association of Investment Management and Research"). Existuje několik organizací vyvíjejících a rozšiřujících metodologickou látku pro přípravu na zkoušku. Pro zvládnutí zkoušky je třeba se naučit spoustu látky. Jaký je podle vás nejlepší způsob použití SuperMemo pro učení a jaký přístup bych měl použít pro přípravu své vlastní databáze. Je k tomu nutná znalost programování?
Odpověď:
Žádné speciální znalosti pro vytvoření jednoduchého systému vědomostí v SuperMemo nejsou nutné. Pomocí Ctrl+A (tj. Add new item (Přidat nový prvek)) získáte z 90% funkční systém! Všechny pokročilé editační volby je možno obejít při správné formulaci otázek a odpovědí. Snad by bylo užitečné, kdybyste se naučil, jak se přidávají obrázky (viz nápovědu). O strukturování vědomostí se víc dozvíte v článku Knowledge Structuring and Representation ; avšak nic nefunguje lépe než učit se na vlastních omylech při formulování vědomostí pro učení se SuperMemo.

(Michal Grodzki, Poland, Aug 20, 1998)
Otázka:
Radíte uživatelům Advanced English 97 , aby si dělali záložní kopie pomocí File : Export: Learning process. Tím se však nezálohuje látka zavedená uživatelem. Jaké je nejlepší řešení v případě, když přidávám do Advanced English mnoho svých položek?
Odpověď:
Můžete zkusit jednu z následujících možností:

  1. Udržujte si svou látku ve zvláštním systému vědomostí . Takový systém můžete zálohovat zkomprimováním souboru <název věd. systému>.kno a adresáře <název věd. systému> do jednoho archivu (např. pomocí WinZip)
  2. Dáváte-li přednost přidávání svých položek do Advanced English (např. abyste mohl prohledávat celou látku jednou akcí), můžete zálohovat obsah jedné větve jejím převedením do prázdného systému vědomostí pomocí Tools (Nástroje): Transfer node (Převést uzel) na místní nabídce obsahu nebo exportováním větve jako text pomocí Tools: Export as text (také na místní nabídce obsahu). Později můžete obnovit svou zálohovanou větev po reinstalaci Advanced English pomocí Tools: Transfer node v opačném směru nebo v posledním případě pomocí File : Import: Text.

(Dr Faust Malnig, Germany, May 1, 1997)
Otázka:
Proč SuperMemo World nelicencuje profesionální anglický slovním místo vyvíjení vlastní látky pro Advanced English?
Odpověď:
Žádný slovník není přizpůsoben specifickým potřebám SuperMemo. Definice v Advanced English jsou vytvořeny s ohledem na snadnost zapamatování, stručnost a jednoznačnost. To je jedinečný materiál, který nelze licencovat z žádného zdroje.

(E.Kubala, Denmark, Dec 17, 1998)
Otázka:
Bude Advanced English pracovat s dánskou verzí Windows? Dostanu překlady v polštině?
Odpověď:
Ano. Advanced English bude pracovat v jakékoliv jazykové verzi Windows. Budete moci zobrazovat překlady v polštině. Může však být nezbytné změnit vybrat odpovídající polský font v Tools (Nástroje) : Options(Volby) : Language (Jazyk) : Translation font (Písmo překladu) (implicitně se používá systémový font, takže v dánských Windows by se vám asi správně nezobrazovala diakritika).

(Artur Osadowski, Poland, Sep 5, 1998)
Otázka:
Ovlivňuje nastavení Access Mode v Tools : Options : Data access přístupnost zvuků na CD-ROM?
Odpověď:
Ne. Aby bylo zajištěno, že SuperMemo bude správně načítat zvuky z CD-ROM, musíte jen zadat správnou cestu v Tools (Nástorje): Options (Volby): Data access (Přístup k datům): Secondary storage (Sekundární paměť)

(Wojciech Gawrys, Poland, Feb 21, 1998)
Otázka:
Jsem administrátorem sítě. Mohu nainstalovat jen jednu kopii Advanced English a nechat ji používat řadou studentů současně?
Odpověď:
Ne. SuperMemo 8 nenabízí možnost vícenásobného přístupu. Pro velké skupiny studentů by bylo nejlepší vybrat z Advanced English prvých 500 až 1000 položek a poskytnout každému studentovi jeho vlastní kopii.

****


Časté otázky o formulaci vědomostí

Časté otázky o formulaci vědomostí v SuperMemo
Do you have a question about writing simple and effective collections for SuperMemo? Write to wozniak@supermemo.com .
If you would like to have your items evaluated, please send 3-5 for review. Do not send whole collections in an e-mail attachment

(John Gibney, Australia, Sep 16, 1998)
Question:
In your materials you write that users should avoid memorizing sets (e.g. countries of Europe) or long sequences (e.g. the alphabet). What if I want to remember the sequence of a form of Tai Chi?
Answer:
Let us consider an example in which you want to memorize the entire sequence of letters in the alphabet. It won't be very effective if you use the following item:

Q: What is the sequence of letters in the alphabet?
A: A,B,C,D,E,F,G,H,I,J,K,L,M,N,O,P,Q,R,S,T,U,V,W,X,Y,Z

You will notice that you frequently stumble on parts of the sequence and need to stop repetitions just to exercise the entire sequence in the traditional way (like we all learn poems by rote).

However, you can approach this in a way that guarantees quick effects:

Q: What is the sequence of letters in the alphabet between A and E?
A: A,B,C,D,E

Q: What is the sequence of letters in the alphabet between D and H?
A: D,E,F,G,H

Q: What is the sequence of letters in the alphabet between G and K?
A: G,H,I,J,K

etc. etc.

After 2-3 weeks of repetitions, you may take on an extra task of recalling the whole sequence after each repetition of these simplified items. This will make sure you can recite the entire alphabet quickly. You will also frequently rehearse that parts of the sequence that are harder for your memory (e.g. V,W,X,Y,Z) as opposed to those that are much simpler (e.g. A,B,C,D,E)

(Noel Clary, USA, Sep 6, 1998)

Item reviewed:

Q: a rod-and-tube element temperature sensor consists of:
A: a high expansion metal tube containing a low expansion rod. The rod & tube are attached on one end. The tube changes length with changes in temperature, causing the free end of the rod to move

Suggestions:

This is a typical case of combining a number of items in one with detriment to the ability to recall the combined item. The suggestion here is to split the item into a number of simpler items that reproduce the same information in student's memory:

Q: What are the two parts of a rod-and-tube temperature sensor?
A: rod and tube

Q: What is the expandability of the tube in rod-and-tube sensor?
A: high

Q: What is the expandability of the rod in rod-and-tube sensor?
A: low

Q: How is temperature indicated in the rod-and-tube sensor?
A: tube moves relative to the rod

Q: Where are rod and tube connected?

etc. etc.

(Noel Clary, USA, Sep 6, 1998)

Item reviewed:

Q: Step 5 HVAC duct design: Size ducts by the selected design method. Calculate system ..., then select ...

Suggestions:

Cloze deletions (i.e. questions with blanks) are generally a good learning tool; however, in most cases it is better to keep a single deletion per question

(Jim Ivy, USA, June 4, 1997)
Question:
What is the difference between a topic and an item ?
Answer:
Topics are used to present knowledge (like chapters in a book), while items are used to test knowledge by means of repetitions (e.g. they have the question-and-answer structure). The main difference is that topics do not take part in repetitions but are only presented before learning a sequence of items. This helps to approach the subject as a whole before repetitions begin. See also: Topics vs. items

(Deron Isaac, USA, May 21, 1997)
Question:
How can I edit texts of items during repetitions without backing out of the test mode?
Answer:
Choose Q to edit the question, A to edit the answer, or E to edit all text components . You can also edit all properties of all components by using pop-up menus available with right button click on a component in question.

Question:
What is the purpose of the option Tools : Categories ?
Answer:
SuperMemo 98 introduces the concept of a category to help you keep items related to different subjects in different branches of the knowledge tree ( contents window ). It also makes it possible to give different item groups different appearance (e.g. size of text components , screen layout, font, color, and many more). Read more: Using categories

(Anatolyi Lipatov, Ukraine, Jul 12, 1998)
Question:
I am using Advanced English to enhance my English and business English. Now I am registering for CFA examination (that is Chartered Financial Analyst program of Association of Investment Management and Research). There are several organizations developing and distributing methodological stuff for preparing to the exam. A lot of things should be memorized for passing the exam. What do you think the best way to fit SuperMemo for memorization and what approach should I use to prepare my own knowledge base for memorizing the material. Is special programming knowledge needed for it?
Answer:
No specialist knowledge is needed to prepare simple knowledge systems in SuperMemo. With Ctrl+A (i.e. Add new item ) you get 90% of functionality! All advanced editing options can be worked around by an appropriate questions-and-answer approach. Perhaps it would be useful yet to learn how to add images to your items (see help for details). To learn more about effectively structuring knowledge in SuperMemo you might want to read Knowledge Structuring and Representation ; however, nothing works better as learning on one's own mistakes in formulating knowledge for learning with SuperMemo

(David Mckenzie, New Zealand, Apr 8, 1998)
Question:
Is there any point in keeping collections separate?
Answer:
No. Once you master contents categories and templates , there is no point. You gain global search, global registries , global repetitions, global optimization, etc. This would not be advisable back in SuperMemo 7 as item difficulty measure (E-factor) was dependent on the average difficulty of items in the collection. Presently, the item difficulty measure ( A-Factor , or absolute difficulty factor) is absolute and does not depend on the context in which an item is placed (see: Algorithm SM-8 ). Only the length of the first interval will significantly be affected by the average difficulty of items in the collection. However, this shall not bear dramatically on the speed of learning . Especially that variable forgetting index for individual items makes it possible to set different first intervals for whole contents categories or branches of the knowledge tree

Question:
What should I use Duplicate for? What for do I need the same item in the same collection ?
Answer:
You can duplicate an item , if you want to add to the another item which is only slightly different. This way you can spare some time by reediting the old item instead of typing in the new one

See also: Knowledge structuring and representation in learning

**


Časté otázky o paměti a učení
Máte dotaz týkající se paměti, učení nebo SuperMemo? Napište Dr Wozniakovi , autorovi SuperMemo.

SuperMemo může skutečně zlepšit vaši paměť
Pokud rádi hltáte knihy ... SuperMemo se vám bude líbit !
 Maximální rychlost učení není to, co opravdu potřebujete!
SuperMemo zrychluje učení 50krát?
SuperMemo můžete použít i pro biflování na zkoušku
8leté děti s úspěchem používají SuperMemo
Na vašem IQ nezáleží
Intervaly použité v SuperMemo nejsou optimální intervaly!
Na době vaší odezvy nezáleží
Jaký druh hudby je pro učení nejlepší?
Obrazy si pamatujeme lépe než slova
Žádný jiný software se nemůže vyrovnat SuperMemo
Je možno použít SuperMemo pro zapomínání?
Co je lepší: SuperMemo nebo MegaMemory?
Co je lepší: SuperMemo nebo SuperLearning?
Co je lepší: SuperMemo nebo mapy mysli Tonyho Buzana?
Mapy mysli se můžete učit se SuperMemo
Mapy mysli lépe pochopíte, když je ... rozdělíte na kousky
Mapu mysli můžete přidat do komponenty odpovědi
Učení map mysli není v rozporu s principem minimální informace
Otázky a odpovědi mohou pro efektivní učení stačit
Využívá SuperMemo krátkodobou nebo dlouhodobou paměť?
Abyste si informace pamatovali trvale, potřebujete opakovat
Je princip minimální informace v rozporu s potřebou asociativních vědomostí ?
 Může SuperMemo pomoci pacientům s ADD (Attention Deficit Disorder)
SuperMemo je v rozporu s některými výsledky zveřejněnými Tonym Buzanem
Uživatelé SuperMemo 2 mohou být iritováni!
Známky v závěrečném procvičování nemají vliv na interval
Vyšší (lepší) známky mohou mít za následek kratší intervaly
I nízký index zapomínání může vyvolávat dlouhé intervaly
První opakování se nemusí provádět následující den
Svou retenci si můžete vypočítat podle indexu zapomínání
Intervaly jsou lehce randomizovány

Další odpovědi najdete níže.

(Elena and Rachel, US, Dec 12, 1997)
Question:
How is SuperMemo supposed to improve someone's memory?
Answer:
We do not claim that SuperMemo improves memory. We say that it allows you to learn fast with high retention of knowledge. The fact is that improving your memory will be a nice side effect, but this will happen not by virtue of the SuperMemo method but by virtue of intense learning. SuperMemo makes it possible to learn fast by organizing your learning process. For more see: General principles of SuperMemo

(Crizeldo G. Cariaso, MD, Philippines, Dec 17, 1997)
Question:
I am a medical doctor who is into resident training as of this moment. Do you advice me to use your product if I read about 100 pages of documents and books a day and have to remember it?
Answer:
Absolutely! You should realize, however, that you will be able to remember only a fraction of the material. An exemplary algorithm would be:

  1. divide your time to: 70% reading, 30% SuperMemo
  2. in SuperMemo time slot formulate questions in reference to the most important facts and rules you have learned, and memorize them . Those shall stick to your memory for good (if you regularly run repetitions as scheduled by the program).

The sad fact is that reading 100 pages daily is really a feat, and even the mere typing in the material to SuperMemo will limit you to 20-100 questions per day (depending on time available and the speed of typing). Even this small proportion will still provide you with amazing build-up of knowledge! It is very important that you intelligently select what must and what does not have to be memorized

(Tomasz Szynalski, Poland, Oct 18, 1998)
Question:
What value of the forgetting index ensures the optimum ratio of ( retention )/(time spent per day)?
Answer:

Paradoxically, the highest speed of learning can be accomplished ... without SuperMemo! In our daily life we pick up lots of facts that stay in our memory for long with few repetitions in lifetime! The problem is that these are usually not exactly the facts or rules that are critical to our goals. In other words, not the speed of acquiring new items counts but the speed of acquiring new items bearing a given contents.

It is difficult to determine exactly what forgetting index brings the highest acquisition rate . Simulation experiments have consistently pointed to the value of 25-30%. You can even plot speed-vs.-forgetting graph using your own actual learning material in SuperMemo 98 using Tools : Statistics : Simulation. You will probably also arrive to similar results

As you perhaps know, SuperMemo disallows of the forgetting index above 20%. This comes from the fact that you should aim at achieving high speed of learning combined with high retention of the learned material. Setting the forgetting index above 20% would be like giving up SuperMemo altogether and coming back to remembering only that what is easy to remember. In highly interlinked material where new knowledge depends on the previously acquired knowledge, high forgetting rate can even be more harmful

Nevertheless, if you want to maximize the speed of learning with little control over what actually stays in your memory, set the forgetting index to 20%

Question:
On what basis do you ground your claim that SuperMemo increases the speed of learning from 10-50 times?
Answer:
For knowledge retention of 95%, it can be computed that the number of repetitions in an average learning lifetime (i.e. about 55 years) is 50 times greater for equally spaced repetitions than for progressive repetitions (as used in SuperMemo). For repetitions with no regular spacing scheme, this number may even be greater. Moreover, the greater the required knowledge retention, the greater the increase in the knowledge acquisition rate (classical forms of learning almost never reach knowledge retention above 10%!!!). In practice, users of SuperMemo claim that it increases their speed of learning from 50% to 2000%. These values are, however, highly subjective, as they do not account for so-called intractable items, which are practically not memorizable without SuperMemo. In other words, students tend to underestimate the fact that they reach knowledge retention from 90-99%, which would hardly be achievable using any other method.

(Jerzy Duda, Poland, Oct 1, 1997)
Question:
What is the lowest age at which a child can start using SuperMemo?
Answer:
The younger the child the more difficult the entry into the learning process. However, with a dose of parental guidance, even first-graders can cope with SuperMemo. The learning process itself is simple and repetitive and the child can quickly enter regular repetitions. Definitely, SuperMemo 98 at the beginner level is much less daunting than SuperMemo 7 for the initial entry. As a documented example, 9-year-old Agata Czaplinska from Gliwice, Poland, memorized 150 new English words in 2 months working nearly on her own. In another case, 8-year-old Annalynn Clary from Monroe, Louisiana (USA) memorized Cross Country material (1673 items) in 100 days working 30 minutes per day (5 days per week)

(Elena and Rachel, US, Dec 12, 1997)
Question:
Do people with higher IQ benefit more from SuperMemo?
Answer:
People with higher IQ are more likely to find clever uses for SuperMemo and they are usually faster to grasp the principles of the program. They are also more likely to become addicted to SuperMemo as one of their most important applications. However, recent research indicates no significant correlation between IQ and any of 30 major studied learning parameters used in SuperMemo

Question:
Why is the first interval after which the first repetition takes place not equal in all cases?
Answer:
It is randomly modified to speed up computing its optimal value. Additionally, random dispersion of intervals around the optimum value prevents repetitions from being packed on a given day, while neighboring days have lots of room to accommodate new items.

(Tomasz Szynalski, Poland, Oct 18, 1998)
Question:
What retention can I obtain with the forgetting index set to 9%? What if I then change it to 12%?
Answer:
The formula that relates the forgetting index to the retention looks like this ( source ):

retention = -(forgetting index)/ln(1-(forgetting index))

If you accomplish the forgetting index of 9%, the retention will equal 95.4%. For 12%, the same figure will be 93.9%. Note that if your material is very difficult, your measured forgetting index may be higher than the requested forgetting index. This comes from the fact that SuperMemo imposes some boundary conditions on the increase of intervals. Elements that have been forgotten more than five times should be reformulated with a view to reducing their difficulty or increasing their mnemonic component.

If you initially set the forgetting index to 9% and later on increase it to 12%, you will probably start with retention of 94-95% which will later gradually decrease to 92-93% (after the change)

(David Mckenzie, New Zealand, Apr 8, 1998)
Question:
Why does not the first repetition after forgetting occur the next day after the unsuccessful repetition (this is advised by Tony Buzan and others)?
Answer:
In SuperMemo, the length of the first interval is computed from the forgetting curve plotted in the course of repetitions. This is to make sure that a defined proportion of items is remembered (usually 80-97%). This proportion is programmed by means of the forgetting index . Depending on the forgetting index, the length of the first interval may range from 1 to 20 days, and is not set arbitrarily. It is computed from the record of repetitions and determined by the desired forgetting index (requested forgetting index is the proportion of items that are not remembered at repetitions). While Buzan’s recommendation is valid in many cases, you should not forget that SuperMemo computes intervals with a high degree of accuracy that cannot otherwise be easily achieved

(Constantin Ilieu, Bulgaria, 1993)
Question:
In your materials I found a contradiction. On one hand you claim that once learned knowledge is constantly maintained in the student's memory, on the other you say that after ceasing repetitions, I will gradually forget what I have learnt. Which is true?
Answer:
Both facts are true. The term maintained is understood as kept in memory by means of repetitions, not as remains in memory for ever

(Manfred Kremer, Germany, Sep 7, 1998)
Question:
I noticed that frequently I get Optimum Interval in Element Data window shorter than the last interval displayed as Interval. Is it a bug in SuperMemo?
Answer:
No. If your forgetting index is very low, e.g. 3%, SuperMemo will often conclude that you will stand 97% chance of remembering a given element only if your next interval is shorter than the presently used one. In such cases, it will not accept the new value and the new interval will be at least 5% longer than the previous interval. Please note that the forgetting index equal 3% should only be used for selected high-priority items. Keeping the forgetting index at this level throughout the collection will make repetitions annoying frequent and ineffective

(Ryszard Siwczyk, Poland, Nov 4, 1997)
Question:
Does the response time at repetitions influence the next interval?
Answer:
No. Repetition timer is only used to compute the average response time and Workload.

(Grzegorz Malewski, Poland, Dec 10, 1997)
Question:
Do grades at final drill affect the learning process?
Answer:
No. They are only used to eliminate items from the final drill queue.

(Spud Science, USA, Feb 14, 1998)
Question:
What is the best (most effective) way to set up a new series of question and answer pairs in SuperMemo?
Answer:
See SuperMemo Decalog . For a more academic reading in the subject you can have a look at Knowledge Structuring and Representation...

Question:
I think that lower grades, e.g. 3, should produce shorter intervals in comparison to higher grades, e.g. 5. It is not always so in the SuperMemo method.
Answer:
In SuperMemo, lower grades may produce longer intervals because of the two following reasons:

  1. Grade 3 may result in the enhancement of the so-called spacing effect, which may be less visible for Grade 5. The spacing effect says that longer intervals, and consequently greater recall efforts, produce more stable memory engrams. SuperMemo does not arbitrarily set the function of optimal intervals. It computes intervals which are most likely to result in the forgetting index defined in Tools : Options : Learning : Forgetting index ; hence; the possibility of longer intervals for lower grades.
  2. all intervals are always slightly dispersed around the optimal value for the sake of more accurate plotting of forgetting curves

See also: Why can I not see the correlation?

Question:
Why can I not see the correlation between intervals and the grades given in learning?
Answer:
Your impression of no correlation between grades and intervals is quite common among those who begin their work with SuperMemo. It results from the fact that at memorizing new items, first intervals are randomly dispersed around a fixed value. This value comes from the model of an average student, and can be modified only after the repetitions have shed some light on if the value should be increased, decreased or kept at the same level. Consequently, it will often happen that a lower grade will produce a longer interval and vice versa. At memorizing new items, grades cannot be used to estimate item difficulty because the program has no way of knowing if good grades come from easiness of items or from the fact that a given group of items has just been input to the knowledge system (inputting items is a form of repetition). You will start noticing the correlation between grades and intervals in a week or two.

(Matt Cassidy, New Zealand, Sep 11, 1997)
Question:
Is it possible that with forgetting index equal to 3% I get the first interval equal to 6 days?
Answer:
Yes. Especially if the material you work with is relatively easy. You should also remember about random dispersion of intervals. In isolated cases, dispersion might produce intervals substantially longer (or shorter) than the optimum interval. For more read about Algorithm SM-8 .

(Jake White, USA, May 14, 1997)
Question:
Should not final drill continue keeping a queue of no less than 10 newly learned words in order to make sure that when repeated again and again they will really be imprinted well in short-term memory.
Answer:
This solution may indeed eliminate contextual dependency in final drill (remembering items only because of having them in a given context); however, this would involve lots of extra repetitions that would contradict the principle of SuperMemo: maximum effect at minimum time. Additionally, the learner would risk activating the spacing effect, i.e. reducing the probability of recall as a result of excessive repetition! The best solution to contextual dependency is (1) random shuffling of final drill queue with Tools : Randomize : Drill and (2) concentration (not grading well items that were remembered only due to appearing in a given context).

Question:
I have heard that baroque music is the best for improving memory; particularly Bach and Vivaldi. Does it also work in association with SuperMemo?
Answer:
The claim that any particular kind of music is best for memory is unlikely to be true. Indeed, music can have powerful impact on our emotions and, consequently, on remembering. It has been found that it is similar in effects to caffein. However, a study that measures impact of a particular kind of music on recall in a group of people can be compared to trying to find the optimum size of a shoe for an average citizen. Depending on the musical education of an individual, the same kind of music may bring a variety of emotion from relaxation, through agitation to aggression. While Four Seasons may have a positive impact on the mind of majority of the population, the best bet would be that everyone should stick with the music he or she likes. Be it punk or funk. The truth is that all that is good for the mind and health is good for remembering.

(Miss E216, US, Nov 25, 1997)
Question:
We are 7-th graders and work on a project related to memory. We have a question to Dr Wozniak: "Why do we better remember pictures than word combinations?"
Answer:
In the course of evolution, humans practised visual memory a lot. They did not deal with maths or abstractions. That is why there are parts of our brain built specially to serve visual memory. As you know, evolution gives better adapted individuals a better chance for survival. Those who could remember better, e.g. shape of the prey or enemy, could survive better, and pass their "good" genes to the next generation. Calculating a differential was not needed in apes or early humans. That is why evolution did not built a specialized calculator into our brain. It has, however, built a calculator for processing visual data. You "type in" the picture, and get a short answer: "danger!" or "food!". Those simple signals are easier to remember than ... streams of bits of a complex image. Evolution and memory are fun, aren't they.

Question:
Can I use SuperMemo to memorize mind maps?
Answer:
Yes. You can build mind maps directly in SuperMemo; however, it is easier to import them from specialized mind map software (e.g. MindMan ). You can include MindMap objects with the OLE component or you can simply import them as graphics (as BMP or GIF files).

For example, import your mind map as graphics to an image component and check Answer on the image component pop-up menu . Add a text component, e.g. "What is the structure of mind map X?".
During repetitions grade yourself less than Pass (3) each time your forget any part of the mind map! Do not forget that you should reinforce "weak links" in the mind map with separately formulated items of simple question-answer or question-picture form. Each time you forget part of the mind map, see if you have reinforced the forgotten links in separate items!

(Julien Seetharamdoo, UK, Jan 3, 1997)
Question:
I would like to know how to memorise mind maps?
Answer:
The best method is to split the mind-map into simple individual pieces and memorize these pieces separately! The pieces must be chosen in such a way that ensuring that you remember all of them you can guarantee that you can recall the whole map. You can find more information about this in knowledge structuring in repetition spacing

(Julien Seetharamdoo, UK, Feb 19, 1998)
Question:
I am trying to use SuperMemo 8 to learn mind maps created using MindMan 3.0 . I have imported the mind maps as BMP files to the image registry but haven't been able to append them as answers to questions. How do I do this?
Answer:
It is faster to import files directly to image components:

  1. Create an image component in the element window
  2. Use Import file to import the BMP file (right click to open the pop-up menu with Import file).
  3. Check Answer on the pop-up menu to make sure that the image is not visible at question time.

NB: If you already have images in the registry, you can use Link Registry Member on the image component pop-up menu (instead of Import file).

Question:
Isn't memorizing mind maps in opposition to the minimum information principle ?
Answer:
No. Minimum information principle should not be interpreted as minimum information on the screen, or minimum number of bytes to represent the item. It should be interpreted in terms of information that has to be stored in your memory. If you produce and item that links the image of a horse and a cow, the association is very simple. No mater how intricate the pictures of the horse and the cow are. The essence of mind maps is that they are easy to remember, i.e. if well-designed, they comply excellently with the minimum information principle.

Question:
Which learning method is more effective: traditional SuperMemo with questions and answers, or the new hypermedia SuperMemo with videos, games, puzzles, and tests?
Answer:
Simple questions and answers are extremely effective and easy to create; however, some users find classic SuperMemo too boring. If the psychological factor plays a part, the variety provided by SuperMemo 8 may substantially add to the effectiveness of learning. The answer to the question will depend on the application domain and the mentality of the student.

(Elena and Rachel, US, Dec 12, 1997)
Question:
Does SuperMemo improve short-term memory or long-term memory?
Answer:
SuperMemo builds up long-term memory but helps you increase your mnemonic skills that will result in the impression that your short-term memory works better.
You can also look at this like that: SuperMemo loads knowledge to short-term memory and this is transferred to long-term memory. The effect on long-term memory is stable but the speed of putting things into short-term memory may increase due to training. Short-term memory improvement comes slowly with training, but long-term memory build-up comes immediately upon employing SuperMemo!

( Prof. Witold Abramowicz , Poland, 1993)
Question:
Does the minimum information principle not stands in conflict with the ages old rule that the learned knowledge should be highly associative in nature?
Answer:
No. The minimum information principles concerns the representation of knowledge in SuperMemo databases, not in the student's memory, and it does not prevent great advantages coming from proper structuring of the learned material. In the optimum situation, the student should first construct a cohesive model of the learned subject, and only then, apply SuperMemo to make sure that the learned knowledge is sustained in memory as a whole. The knowledge may be highly associative, but strictly targeted neural stimulation, achieved by means of granular representation of knowledge in SuperMemo, is necessary to effectively induce molecular processes responsible for memory formation. Indeed SuperMemo has been conceived in such a was so as to make it easier to formulate knowledge in a structured way (topics) and later learn it in a way typical for SuperMemo (items). See also: Topics vs items

(Anatolyi Lipatov, Ukraine, Jul 12, 1998)
Question:
I am using Advanced English to enhance my English and business English. Now I am registering for CFA examination (that is Chartered Financial Analyst program of Association of Investment Management and Research). There are several organizations developing and distributing methodological stuff for preparing to the exam. A lot of things should be memorized for passing the exam. What do you think the best way to fit SuperMemo for memorization and what approach should I use to prepare my own knowledge base for memorizing the material. Is special programming knowledge needed for it?
Answer:
No specialist knowledge is needed to prepare simple knowledge systems in SuperMemo. With Ctrl+A (i.e. Add new item) you get 90% of functionality! All advanced editing options can be worked around by an appropriate questions-and-answer approach. Perhaps it would be useful yet to learn how to add images to your items (see help for details). To learn more about effectively structuring knowledge in SuperMemo you might want to read Knowledge Structuring and Representation ; however, nothing works better as learning on one's own mistakes in formulating knowledge for learning with SuperMemo.

(Pawel Dzierwa, Poland, June 3, 1997)
Question:
Personal question to Dr Wozniak: If you did not have SuperMemo at hand, which competitive product would you use?
Answer:
I would probably pick one of the programs that most closely follow the SuperMemo paradigm, e.g. Edukom or PowerMemo. Only later would I choose from better known products that are less focused on repetition spacing such as Langmaster or YDP 's Collins Dictionary. However, as a software developer involved in the design and implementation of SuperMemo since 1987, I would rather opt for implementing the program from scratch. Back in 1987, the first version was written in 16 evenings . I would have to give up all the bells and whistles, but it is the core that matters most. And it would be most difficult to give up the control over what new options might yet be implemented. Thanks for a tickling question

(Colin Quiney, Canada, Jan 22, 1998)
Question:
Do you think SuperMemo can be beneficial in patients with ADD (Attention Deficit Disorder)?
Answer:
User's ability to focus on repetitions is one of pre-conditions of success with SuperMemo. Seemingly, this would make ADD patients poor SuperMemo learners. Perhaps the report submitted by Maarten Mols from Holland sheds some different light on the issue: SuperMemo in a school for special education .

Question:
Tony Buzan claims that 75% of information is lost if not reviewed in 24 hours. Does it not defeat the validity of SuperMemo in which the first interval is often longer than a week?
Answer:
No. Buzan's claim may refer to textbook knowledge or complex knowledge structures (e.g. large mind maps). However, it does not seem accurate in the light of results obtained with SuperMemo. This is particularly visible in case of the so-called well-structured learning material (e.g. simple questions and answers). In SuperMemo, if the student chooses the retention of 95%, the typical value of the first interval falls in the range 2-5 days depending on the student and the difficulty of the learned material. For retention 25%, the same interval might be as long as one month, though it cannot be verified experimentally with SuperMemo which limits the range of the forgetting index from 3-20%, which implies the overall retention in the range of 85-99%. For more see: Theoretical background of SuperMemo

(William McGhee, Jun 22, 1998)
Question:
Could SuperMemo be used to extinguish behaviours as well as reinforce them?
Answer:
Forgetting is a molecular process that cannot easily be induced by natural methods. The more so, there are no sensitive methods to induce selective forgetting, though lesion to some parts of the cerebral cortex may produce roughly localized amnesia. However, there is a component of forgetting that may be influenced. This component is interference. Whenever we learn new things, they always interfere with previously learned material. The interference may enhance some of memories while obliterating others. This fact can be used to employ SuperMemo in forgetting, by formulating and memorizing a large number of contradictory items that strongly interfere with remembered facts that are to be forgotten. For example, if you learn the meaning of the word "indict" and you want to later forget it, you might try to learn words like "indite" or some meaningless like "dictin", "incid", "endict", etc. However, you should not expect the effectiveness of such a procedure to be anything but disappointing.

Question:
I used SuperMemo 2 shareware, and was accustomed to repeating forgotten items on the next day. It is very irritating that in SuperMemo 98 I do not have this possibility
Answer:
SuperMemo will schedule forgotten items in intervals that are determined by the forgetting index . The greatest increase in the speed of learning in newer versions of SuperMemo as compared with SuperMemo 2 resulted from substantially increasing the length of the first interval. The student may be left with the feeling that he is likely to forget the item again if it is not repeated on the next day. Statistically, however, he will forget no more than the proportion defined by the forgetting index (specified in Tools : Options : Learning : Forgetting index). By reducing the forgetting index to less than 5%, the length of the first interval is likely to drop to 1-2 days in most cases. Moreover, if you are particular about repeating a given item on the next day, you can choose Ctrl+M to commit or recommit an item with a selected first interval

Question:
I have an exam for a driver's license in 2 weeks. How can I best memorize the Traffic Regulations collection for SuperMemo? How can I increase the frequency of repetitions?
Answer:
Although SuperMemo is not a cramming tool, and it would be much safer to start 2-3 months before the exam, the following shall work pretty well: (1) Set Tools : Options : Learning : Forgetting index at 3%. (2) When memorizing difficult items, choose Ctrl+M and provide the first interval value equal to one day. (3) Memorize the collection in equal portions in the period spanning from today to 2-4 days before the exam. Use Tools : Random review intensely over the last 2-4 days

Question:
(1) I want to spend my money on the MegaMemory program delivered on cassette tapes. How would you convince me, that I should rather spend money on buying SuperMemo (2) Is SuperMemo the same as SuperLearning developed by Dr Georgi Lozanov from Bulgaria? (3) Which techniques produce a greater increase in the speed of learning: SuperMemo or the mind maps proposed by Tony Buzan?
Answer:
The mnemonic techniques (Tony Buzan, MegaMemory, etc.), SuperLearning (Dr Georgi Lozanov) and SuperMemo are all complementary, and make up three independent pillars of effective learning. All of them have to do with optimization:

  • In SuperLearning the stress is put on optimizing the cognitive environment which produces the best effects in the learning process
  • In mnemonic techniques, the representation of knowledge is optimized in order to produce the most durable memory engrams
  • In SuperMemo, the optimization concerns the spacing of repetitions

To be a successful student, you have to (1) apply mnemonic techniques while (2) using SuperMemo in a (3) optimum cognitive environment. The important advantage of SuperMemo is that many capable students develop quite good tricks as far as mnemonic techniques are concerned. They can also reasonably master their own physiology to subject it to the learning effort. However, they have no way of optimizing the spacing of repetitions. Mostly due to the fact that the amount and complexity of computation needed to determine the intervals require the use of a computer and the technology proprietary to SuperMemo World . You are advised to follow the teachings of Tony Buzan, Kevin Trudeau or Dr Georgi Lozanov; however, if you are a capable student, you can safely commit your foremost priority to learning how to optimize your learning schedule. As for now, SuperMemo is the world's best tool developed to assist you in this task.

**


Časté otázky o SuperMemo 8

Otázky týkající se SuperMemo 8 jsou často podobné otázkám o SuperMemo 98, proto jsme je zařadili do jednoho souboru, přejděte prosím na něj.


Otázky o SM98

Časté otázky o SuperMemo 98
Máte dotaz o používání SuperMemo 98? Npište na elk@supermemo.cz (česky) nebo na support@supermemo.com (anglicky).
Poslední modifikace:

SuperMemo není obtížné!
Běhen opakování můžete editovat prvky
Můžete se podívat, které položky budou opakovány v daný den
SuperMemo si umí pamatovat velikost svých oken
Tuto položku se můžete učit později
Můžete si stáhnout souhrny vědomostí pro učení
Můžete snadno vymazat prvek
Můžete si nainstalovat cizí klávesnici ve Windows
Obrázky mohou sloužit jako odpovědi
SuperMemo může být po dovolené milosrdné!
Můžete zobrazovat strukturní vzorce v chemii
Můžete zjistit nejobtížnější položky
V závěr. procvičování nejsou známky důležité
Můžete změnit polohu okna otázky
Můžete měnit pořadí učení jednotlivých prvků
Můžete přidávat matematické vzorce
Můžete rychle kopírovat prvky
Pro prohlížení souborů CHM potřebujete Internet Explorer
Můžete použít odlišný font pro otázky a odpovědi
Nebojte se virové nákazy!
Tvoření hyperpropojení je jednoduché
Nezapomínejte zálohovat !
 Můžete odstranit všechny informace o procesu učení
Můžete určovat prioritu prvků
Kategorie pomáhají organizovat látku do skupin
Používejte jen jeden souhrn!
U SuperMemo neexistuje problém roku 2000!
Můžete vymazat všechny výskyty 'xxxx'
Mezi položkami a tématy je důležitý rozdíl
Hodiny vás nemají při opakování pobízet ke spěchu
Můžete přidat magnetofon (záznamník zvuku)
Můžete vidět číslo aktuálního prvku
Vy i vaše manželka můžete rozšiřovat tentýž souhrn
Můžete rychle měnit položky na témata
Můžete si nainstalovat ikonu SuperMemo na svou pracovní plochu
Dokončení závěrečného procvičování není kritické
SuperMemo se může zpomalovat!
Zdrojový kód SuperMemo 98 je dlouhý 70,000 řádků (Delphi 3.0)
Zobrazení odpovědi je možno vynechat
SuperMemo může obsahovat miliardu položek
Identické texty se ukládají jen jednou
Můžete vystředit text v textových komponentách
Můžete vypnout popisky nebo skrýt stavový pruh
Můžete se učit šachové pozice pomocí šachového fontu
Název se může lišit od textu otázky
Můžete globálně změnit rozložení komponent
Můžete kopírovat prvky přes Schránku
Můžete importovat zvukové soubory přímo do zvukového registru
Můžete si upravit názvy známek
Můžete najednou importovat mnoho souborů GIF
Strom vědomostí se podobá rodokmenu
Po zvolení kategorie se zobrazí poslední přidaný prvek
Je možné měnit barvu pozadí u mnoha prvků najednou
Hodiny nelze vypnout
Je možno vyhledávat obraz
Můžete zaměnit otázky a odpovědi v celém souhrnu
Můžete rychle importovat souhrny SuperMemo 8 do SuperMemo 98
Strom vědomostí je pro učení volitelný
Můžete zálohovat proces učení ve velkých souhrnech
Můžete vidět přesnou historii opakovní dané položky
Komponenty se zobrazují v tomtéž pořadí, v jakém byly přidávány do prvku
Můžete rychle přeložit rozhraní SuperMemo do svého jazyka
Můžete přenést šablonu z jednoho souhrnu do druhého
SuperMemo nebude v budoucnu ztrácet své autorské vlastnosti
Můžete svým studentům zabránit v editaci souhrnu
Zde můžete najít obsah souborů používaných SuperMemo
Používejte Copy nebo Move místo File: Save as
Můžete zobrazit všechny čekající prvky v dané větvi
Můžete snadno opakovat zvuky, zobrazit překlad nebo fonetický přepis
Můžete vždy vymazat závěrečné procvičování
Je-li SuperMemo nestabilní ... zkontrolujte nejprve svůj počítač
S pomocí SuperMemo se můžete vypořádat s každou zkouškou
Nelze měnit font použitý v nadpisech v okně prvku
Se zobrazením vzorců MS Equation v SuperMemo mohou být problémy

Další odpovědi najdete v další části tohoto souboru

(Crizeldo G. Cariaso, MD, Philippines, Dec 17, 1997)
Otázka:
Zdá se, že váš software vyžaduje mnoho času ... je křivka učení velmi strmá?
Odpověď:
Váš názor není neobvyklý. Avšak SuperMemo je mnohem jednodušší, než vypadá. Zkuste tohle:

  1. zvolte Add new (Přidat nový) (Ctrl+A) a napište do příslušných editačních polí otázku a odpověď
  2. zvolte Learn (Učit se) (Ctrl+L) - začnete se učit nashromážděnou látku

Pro dobré využití SuperMemo toho o moc víc nepotřebujete!!! Po nějaké době budete ještě potřebovat vědět, jak se zálohuje pomocí File (Soubor) : Organize (Organizovat): Copy (Kopie). Další informace najdete v oddíle Abeceda SuperMemo

(Deron Isaac, USA, May 21, 1997)
Otázka:
Jak mohu editovat texty položek během opakování, aniž bych musel odejít z režimu učení?
Odpověď:
Stiskněte Q, chcete-li editovat otázku, A, chcete-li změnit odpověď, nebo E chcete-li editovat všechny textové komponenty . Můžete rovněž editovat všechny vlastnosti všech komponent pomocí místních nabídek dostupných stisknutím pravého tlačítka myši na komponentě v poli otázky

(Matt Cassidy, New Zealand, Aug 18, 1997)
Otázka:
Jak je možno si prohlížet položky určené k opakování na daný den?
Odpověď:
Použijte Tools (Nástroje) : Workload (Zátěž) a dvakrát klikněte na den, který vás zajímá.

(Thomas Clark, USA, Nov 24, 1997)
Otázka:
Proč si SuperMemo nepamatuje velikost jednotlivých oken? Musím je měnit po každém spuštění programu!
Odpověď:
Uložte si prosím rozložení oken pomocí Window : Save as default ( Ctrl+Shift+F5 ).

(Grzegorz Malewski, Poland, Dec 10, 1997)
Otázka:
Ovlivňují známky v závěrečném procvičování proces učení?
Odpověď:
Ne. Slouží pouze pro eliminaci položek z fronty záv. procvičování.

Otázka:
Jak mohu odložit učení některého prvku při probírání nové látky?
Odpověď:
Zvolte Forget na místní nabídce prvku ( Ctrl+R ). Tím se položka umístí na konec fronty čekajících prvků .

(Roger Dykes, USA, May 20, 1998)
Otázka:
Jaké souhrny vědomostí jsou dostupné pro SuperMemo 98 ?
Odpověď:
Viz Knihovnu SuperMemo

Otázka:
Jak vymažu prvek v SuperMemo 98?
Odpověď:
Zvolte jednu z následujících možností:

  • Edit : Delete element na hlavní nabídce
  • Klikněte na tlačítko Delete v okně obsahu
  • zvolte Edit : Delete na místní nabídce obsahu
  • Stiskněte Del v okně obsahu
  • Zvolte Delete element na místní nabídce prvku
  • Stiskněte Shift+Ctrl+Del v okně prvku

(Ryszard Siwczyk, Poland, Nov 4, 1997)
Otázka:
Ovlivňuje doba odpovědi při opakování následující interval?
Odpověď:
Ne

(David Seagull, USA, Jul 10, 1998)
Otázka:
Jak mohu nadefinovat francouzskou klávesnici pro používání SuperMemo ve Windows 95?
Odpověď:
V Ovládacích panelech Windows zvolte Klávesnice a na kartě Jazyk přidejte Francouzsky (např. Francouzsky-Kanada). Nastavte volbu Francouzsky jako výchozí

(Jim Ivy, USA, June 4, 1997)
Otázka:
Jaký je rozdíl mezi tématem a položkou ?
Odpověď:
Témata se používají pro předkládání vědomostí (jako kapitoly v knize), kdežto položky se používají pro zkoušení vědomostí prostřednictvím opakování (např. mohou mít strukturu otázka - odpověď). Hlavní rozdíl je v tom, že témata se nezúčastňují opakování, ale předkládají se pouze jednou před učením posloupnosti položek. To pomáhá přistupovat k předmětu jako celku před začátkem opakování. Viz také: Témata a položky

(Bonnie Smithson, USA, Feb 24, 1998)
Otázka:
Jak dám obrázek do odpovědi?
Odpověď:
Zatrhněte Answer (Odpověď) na místní nabídce obrazové komponenty

(Charles Maggio, USA, July 7, 1997)
Otázka:
Používám program ChemDraw pro vytváření strukturních vzorců organických látek. Jak je mohu vkládat do obrazových komponent?
Odpověď:
Vzorce z programu ChemDraw i vzorce generované jinými aplikacemi můžete vložit, pokud aplikace podporuje OLE 2.0. Nepoužívejte zde obrazovou komponentu, použijte komponentu OLE

(Gabor Schmera, USA, Dec 13, 1997)
Otázka:
Jak mohu do svých položek přidat komponentu "magnetofon" (jako v Advanced English 97 )?
Odpověď:
Přidejte zvukovou komponentu a na její místní nabídce zatrhněte Recorder

Otázka:
Jak mohu změnit polohu okna Otázka na obrazovce?
Odpověď:
Klikněte na okno dvakrát se stisknutou klávesou Alt (Alt-klik). Pak je bude možno přetahovat myší. Alternativně můžete zvolit Dragging mode (Přetahovací režim) na místní nabídce otázky nebo místní nabídce prvku (v posledním případě budou přetahovatelné všechny komponenty). Chcete-li změnit jeho polohu trvale, měl byste použít šablonu. Viz Používání šablon .

(John Gibney, Australia, Sep 1, 1998)
Otázka:
Jak je možno nejjednodušším způsobem měnit pořadí probírání prvků ?
Odpověď:
Můžete setřídit (seřadit) frontu čekajících prvků v pořadí výskytu ve stromě vědomostí pomocí File : Reset: Sort by hierarchy (Seřadit podle hierarchie). Můžete rovněž nastavit ordinální čísla jednotlivých prvků a zvolit File : Reset: Sort by ordinals (Seřadit podle ordinálních čísel). A nakonec, můžete vyhledávat jednotlivé prvky a probírat je individuálně stisknutím Ctrl+M

Otázka:
Odjel jsem na dovolenou a můj proces učení je "v háji".Co mám dělat?
Odpověď:
Použijte Tools (Nástroje) : Mercy (Milost)

(Gabor Schmera, USA, Dec 13, 1997)
Otázka:
Rád bych do svých položek dával matematické vzorce. Jaký je nejjednodušší způsob? Rovnice jsem vytvořil pomocí MS Word 97.
Odpověď:
Pro zobrazení komponent vygenerovaných jinými aplikacemi použijte komponentu OLE (pokud podporují OLE 2.0)

(Pawel Galecki, Poland, Feb 10, 1998)
Otázka:
Vytvořil jsem vlastní souhrn vědomostí , který obsahuje 700 položek v kořenové kategorii. Systém se při každém otevření zavádí skoro 60 sekund! Jak jej mohu urychlit?
Odpověď:
Z důvodů výkonnosti byste měl omezit počet prvků na kategorii na 50-100. Nastavte nižší hodnotu v Tools (Nástroje) : Options (Volby) : Appending : Children limit per hierarchy node (Počet dceřinných prvků na uzel hierarchie). Pro rozdělení vaší 700prvkové kategorie zvolte Tools (Nástroje): Arrange in folders (Uspořádat do složek) na místní nabídce okna prvku

(Ryszard Kosowicz, Krakow, Poland, May 16, 1997)
Otázka:
Jak mohu rychle okopírovat text položky do jiné položky, aniž bych musel použít schránku dvakrát (pro otázku a pro odpověď)?
Odpověď:
Použijte Duplicate na místní nabídce prvku (nebo stiskněte Ctrl+Alt+U na kopírovaném prvku)

(Eryk Horloza, Poland, June 3, 1997)
Otázka:
Jak mohu používat různé fonty pro otázku a odpověď v SuperMemo 98?
Odpověď:
Nejrychlejší způsob je:

  1. Add a new item (Přidat novou položku) pomocí Ctrl+A
  2. Na místní nabídce komponenty Otázka zvolit Text: New font (nebo Links: Font, pokud jste font již nadefinovali)
  3. Vybrat odpovídající font Otázky
  4. Opakovat kroky 2 a 3 pro komponenty Odpovědi
  5. Na místní nabídce prvku zvolit Template (Šablona): Save as template (Uložit jako šablonu). Zapamatujte si jméno nově vytvořené šablony pro další krok
  6. V Tools (Nástroje) : Options (Volby) : Appending : Default item template (Výchozí šablona položky) napište jméno nové šablony
  7. Zvolte znovu Ctrl+A a prověřte, zda se vaše nová šablona aplikuje správně

Nyní se bude vaše nová šablona s novými fonty používat při každém přidání nové položky. Máte-li ve svém souhrnu vědomostí víc než jednu kategorii , měli byste místo Tools (Nástroje) : Options (Volby) : Appending : Default item template použít raději Tools (Nástroje) : Categories .

Otázka:
Můj počítač byl napaden virem a SuperMemo hlásí problém s integritou. Co mám dělat?
Odpověď:
Zkuste File (Soubor) : Recover (Zotavit)

(Peter Cool, The Netherlands, Nov 9, 1998)
Otázka:
Nainstaloval jsem nápovědu pro SuperMemo 98, ale nefunguje mi. Po instalaci souboru nápovědy a hhupd.exe uvidím po vyvolání nápovědy přesýpací hodiny (na krátkou chvíli). Potom se již nic neděje.
Odpověď:
Musíte si nainstalovat prohlížeč HTML (hhupd.exe) nad Internet Explorer 3.0. Formát CHM byl firmou Microsoft vyvinut později a vyžaduje, aby na počítači byl nainstalován Internet Explorer. Microsoft bohužel neumožňuje instalaci podmnožiny.

(David Mckenzie, New Zealand, Apr 8, 1998)
Otázka:
Jak vytvořit hyperpropojení (hyperlink) ?
Odpověď:
Přetáhněte (Ctrl-drag) komponentu do Hyperlinkové schránky (na hlavním nástrojovém panelu ), přejděte na propojovaný prvek a přetáhněte obsah Hyperlinkové schránky do okna prvku .
Pamatujete-li si číslo propojovaného prvku, je rychlejší zadat toto číslo ve volbě Links: Hyperlink na místní nabídce komponenty

(Marcin Piekarniak, Poland, Dec 2, 1997)
Otázka:
Jak mohu snadno zálohovat Advanced English 97 ? V Advanced English 94 bylo možno celý systém komprimovat do souboru o velikosti 1,4 MB!
Odpověď:
Je možné zálohovat proces učení, aniž by se zálohoval obsah Advanced English (obsah je zálohován na vašem originálním CD-ROM Advanced English). Díky tomu se ukládají jen data týkající se položek v procesu učení (nikoliv položky samotné). Použijte File (Soubor) : Export: Learning process (Proces učení). Později, po nové instalaci Advanced English 97, můžete proces učení obnovit pomocí File : Import: Learning process

(Mariusz Szepietowski, Poland, Dec 7, 1997)
Otázka:
Jak mohu ze souhrnu vědomostí odstranit informace o procesu učení? Rád bych se začal učit od začátku.
Odpověď:
Použijte File (Soubor) : Reset: Collection (Souhrn vědomostí). Na konci tohoto procesu zvolte řazení fronty čekajících prvků buď podle hierarchie (ve většině systémů) nebo podle ordinálních čísel (např. v Advanced English 97 )

Otázka:
Mám ve svém souhrnu vědomostí látku s různou prioritou učení. Může mi SuperMemo pomoci věnovat více pozornosti látce s vyšší prioritou?
Odpověď:
Ano. Měl byste zmenšit hodnotu indexu zapomínání pro látku s vysokou prioritou (index zapomínání je procentuální podíl položek, které si nepamatujete při opakování ). V okně obsahu zvolte položku nebo uzel , které mají mít vyšší prioritu, a na místní nabídce zvolte Node operations (Uzlové operace): Forgetting index (Index zapomínání): Set forgetting index (Nastavit index zapomínání). Výchozí hodnota indexu zapomínání je 10% a může být nastavena na 3-5% pro látku s vysokou prioritou nebo jen na 20% pro méně důležité větve stromu vědomostí .

Otázka:
Jaký je účel volby Tools (Nástroje) : Categories (Kategorie) ?
Odpověď:
SuperMemo 98 zavádí koncepci kategorie , aby bylo možno ukládat položky vztahující se k různým předmětům do různých větví stromu vědomostí ( okno obsahu ). Umožňuje rovněž, aby různé skupiny položek měly odlišný vzhled (např. velikost textových komponent , rozložení na obrazovce, font, barvu atp.). Viz též: Používání kategorií

(Manfred Kremer, Germany, Sep 7, 1998)
Otázka:
Všiml jsem si, že často dostávám Optimální interval v Okně dat prvku kratší než poslední interval zobrazený jako Interval. Je to závada SuperMemo?
Odpověď:
Ne. Je-li váš index zapomínání velmi nízký, např. 3%, SuperMemo často dospěje k závěru, že 97procentní pravděpodobnosti toho, že si budete daný prvek pamatovat, je možno dosáhnout, jen když je následující interval kratší než poslední použitý interval. V takových případech nepřijme novou hodnotu a nový interval bude alespoň o 5% delší než předchozí interval. Uvědomte si prosím, že index zapomínání rovný 3% by se měl používat jen pro vybrané položky s velmi vysokou prioritou. Budete-li mít index zapomínání na této úrovni v celém souhrnu vědomostí, bude opakování nepříjemně časté a neefektivní

(David Mckenzie, New Zealand, Apr 8, 1998)
Otázka:
Má smysl udržovat několik oddělených souhrnů vědomostí?
Odpověď:
Ne. Když zvládnete kategorie obsahu a šablony , nemá to smysl. Získáte globální vyhledávání, globální registry , globální opakování, globální optimalizaci atd. Nelze to doporučit ve starší verzi SuperMemo 7, protože míra obtížnosti (E-faktor) závisela na průměrné obtížnosti položek v souhrnu. V současné době je míra obtížnosti položky absolutní ( A-Faktor neboli absolutní faktor obtížnosti) a nezávisí na kontextu, ve kterém je položka umístěna (viz Algoritmus SM-8 ). Průměrnou obtížností položek v souhrnu je významně ovlivněna jen délka prvního intervalu. To však neovlivňuje dramaticky rychlost učení . Zejména díky tomu, že proměnný index zapomínání pro jednotlivé položky umožňuje nastavit odlišné první intervaly pro celé kategorie nebo větve ve stromě vědomostí

(Volker Goretzki, Germany, May 6, 1997)
Otázka:
Rád bych ze souhrnu vědomostí odstranil všechny výskyty řetězce "xxxx". Jak to provést?
Odpověď:
(1) Zvolte Search : Text, (2) v nabídce zvolte Find and replace (Najít a nahradit), např. stisknutím Ctrl+R, (3) do pole Find what (Najít co) napište 'xxxx', (4) ponechejte pole Replace with (Nahradit čím) prázdné a (5) zvolte Replace All (Nahradit vše)

(Doug Edmunds, USA, Nov 4, 1997)
Otázka:
Jaký je nejrychlejší způsob kontroly čísla právě zobrazeného prvku ?
Odpověď:
Stiskněte Ctrl+G

(Brian Canova, USA, Aug 28, 1998)
Otázka:
Já a manželka používáme systém vědomostí Medical Biology . Jak můžeme oba přidávat nové prvky a synchronizovat naše úsilí tak, abychom oba měli nové prvky i druhého z nás?
Odpověď:
SuperMemo nemá žádné mechanizmy pro sdílení dat mezi studenty v reálném čase. Existuje však poměrně složitý algoritmus, který můžete používat. Zkoušejte to prosím, jen pokud jste pokročilý uživatel SuperMemo:

  1. Udržujte čtyři různé systémy vědomostí:
    1. BRIAN - váš původní souhrn Medical Biology
    2. WIFE - kopie Medical Biology pro vaši manželku (vytvořená např. pomocí File (Soubor) : Copy (Kopírovat) nebo Ctrl+Shift+C )
    3. BRIAN-NEW - nový systém, do kterého budete přidávat novou látku vy osobně (vytvořený pomocí File : New (Nový))
    4. WIFE-NEW - nový systém, do kterého bude přidávat novou látku vaše manželka
  3. Opakování provádějte jen v systémech BRIAN a WIFE
  4. Periodicky přenášejte nově vytvořené prvky z BRIAN-NEW do BRIAN a WIFE a také z WIFE-NEW do BRIAN a WIFE

Celé systémy nebo jen jednotlivé větve můžete přenášet pomocí Tools (Nástroje) : Transfer node (Přenést uzel) na místní nabídce obsahu v okně obsahu

P.S: V nové verzi plánujeme plné sdílení dat mezi studenty (v současné době mohou být sdíleny jen velké multimediální soubory). Viz též: 1. adresář prvky , 2. File (Soubor): Semi-Copy (Kopírovat částečně)

(Piotr Wysocki, Poland, May 14, 1997)
Otázka:
Jak mohu změnit položku na téma a naopak bez použití uzlových operací v okně obsahu ?
Odpověď:
Zatrhněte nebo zrušte zatržení v poli Topic (Téma) na místní nabídce prvku (dostupné kliknutím pravým tlačítkem na prázdném místě prvku). Viz též: Témata a položky .

(Judy Citron, UK, May 26, 1998)
Otázka:
Váš program mi byl velmi doporučován, takže jsem si jej stáhla z Internetu. Ale když jej spustím, zdá se mi, že jsem se dostala do slepé uličky - nevidím žádný přehled o tom, co dělá a jak se s ním pracuje. Ztratila jsem někde něco? Dostanu svou plochu nějakou ikonu?
Odpověď:
Před naší firmou je jeden z nejobtížnějších úkolů - zajistit, aby lidé jako vy si mohli sednout k SuperMemo a pochopit je za 5 minut. Je to již čtyři roky, co neustále experimentujeme s různými přístupy. Snad se to vyřeší se SuperMemo 98 s jeho úrovněmi obtížnosti . SuperMemo nabízí některé nové hodnoty a ty je třeba pochopit, než z něj můžete mít dobrý užitek. Proto ta obtížnost. Dvě základní operace, které se musíte naučit, jsou:

  • přidávání nové látky (Ctrl+A)
  • učení (Ctrl+L)

Zbytek je nepovinný!
Pokud jde o ikonu: používáte-li Windows 95 nebo Windows NT 4.0, postupujte takto:

  1. klikněte pravým tlačítkem na pracovní plochu (na místo, kde chcete mít ikonu)
  2. zvolte New (Nový objekt): Shortcut (Zástupce)
  3. klikněte na Browse (Prohlížet)
  4. vyberte soubor SM98.EXE (najdete jej v adresáři SM98 na tomtéž místě, kam jste stáhla a spustila SM98ZIP.EXE; například: jestliže jste jej stáhla do c:\download\supermemo\sm98zip.exe (resp. sm98czip.exe), spusťte sm98zip.exe a sm98.exe najdete v \download\supermemo\sm98\sm98.exe)

(David Mckenzie, New Zealand, Sep 3, 1998)
Otázka:
Co se má dělat, když se nedokončí závěrečné procvičování na daný den? Možnosti asi jsou: 1. Vymazat je, 2. Provést je jako první akci v následujícím dnu, 3. Provést je příští den, ale s dalšími položkami pro záv. procvičování. (Obvykle dělám 3.)
Odpověď:
Nejlepší by bylo dokončit záv. procvičování každý den. Druhá nejlepší možnost je asi vynechat záv. procvičování ( Learn (Učit se) : Cut drills (Zrušit záv. procvičování)). To je dáno tím, že veškerá opakování provedená s datem jiným než původně naplánovaným jsou v rozporu s výpočty prováděnými programem SuperMemo. Můžete SuperMemo jednoduše oklamat tak, že si myslí, že prvek znáte lépe, než jak vyplývá z opakování. A nakonec, nejhorší by bylo procházet závěrečným procvičováním před opakováním následující den (z téhož důvodu). Je to ještě složitější, když váš první interval pro zapomenuté položky je poměrně dlouhý (např. přes 5 dnů). Za těchto okolností by provádění závěrečného procvičování následující den mohlo být užitečnější, než kdyby se neprovedlo vůbec.

P.S. V budoucnosti možná přidáme volbu Unscheduled repetition (Neplánované opakování), v níž budete moci programu SuperMemo oznámit, že se provádí mimořádníé opakování. Přirozeně by závěrečné procvičování automaticky provádělo Neplánované procvičování.

Otázka:
Kolik řádků zdrojového kódu je v různých verzích SuperMemo? V jakém jazyce byly napsány?
Odpověď:

  • SuperMemo 1 - 3,000 řádků (Turbo Pascal 3)
  • SuperMemo 2 - 4,000 řádků (Turbo Pascal 4)
  • SuperMemo 5 - 8,000 řádků (Turbo Pascal 5)
  • SuperMemo 6.7 - 13,000 řádků (Borland Pascal 7)
  • SuperMemo 7.5 - 27,000 řádků (Borland Pascal 7 for Windows)
  • SuperMemo 8.4 - 55,000 řádků (Delphi 1.0)
  • SuperMemo 98 - 69,016 řádků (Aug 30, 1998)(Delphi 3.02)

(Anatolyi Lipatov, Ukraine, Aug 28, 1998)
Otázka:
Když přidávám nové prvky v okně obsahu , stává se, že při učení se ihned zobrazí odpověď, i když komponenta odpovědi je označena jako Answer. Je to chyba?
Odpověď:
Ne. To je standardní chování pro témata . Musíte zrušit zatržení Topic (Téma) na místní nabídce prvku . Témata jsou pokládána za shrnující přehled vědomostí a nerespektují atribut Answer na místní nabídce komponenty . Zobrazí se prostě tak, jak jsou a čekají, až kliknete na Další prvek (Next repetition) (tj. přeskakují Zobrazit odpověď a známkování) (viz též: Témata a položky )

(Tomasz Szynalski, Poland, Sep 7, 1998)
Otázka:
Používám SuperMemo 6 Public Domain [for DOS] již roky (tato verze se mi zdá dostatečná!). Nedávno jsem si však všiml, že trpí problémem tisíciletí (přechodem k letopočtu 2000) ("millennium bug")! Když si koupím SuperMemo 98 , mohu si být jist, že můj proces učení bude bezpečný?
Odpověď:
V SuperMemo 6 je skutečně problém Y2K. Avšak pravděpodobně se týká jen zacházení s daty v měsíčním kalendáři opakování. To by samo o sobě nemělo mít vliv na proces učení! SuperMemo 8 a SuperMemo 98 jsme rozsáhle testovali na "millennium bug". Nenašli jsme žádné problémy. Mnoho uživatelů nám hlásilo, že zkoušeli totéž. Je-li v pořádku váš hardware a operační systém, můžete si být jist bezpečností svého procesu učení. Navíc můžete v případě potíží vždy využít našich služeb .

(Matt Cassidy, New Zealand, Oct 2, 1997)
Otázka:
Existuje nějaký mezní počet prvků určitého systému vědomostí ?
Odpověď:
 SuperMemo 98 bylo navrženo tak, aby v něm teoreticky mohla být víc než miliarda prvků ; avšak z různých důvodů (např. rychlosti) pravděpodobně nemá smysl překročit 100 000. Největší systém testovaný v SuperMemo World v srpnu 1998: 65,000 položek (uživatelé hlásili systémy s 120 000 prvky). Rychlost programu s velkým počtem dlouhých textů můžete podstatně zvýšit tím, že zrušíte zatržení Tools (Nástroje) : Options (Volby) : Data access (Přístup k datům): Compile lexicon on-the-fly (Kompilovat lexicon za chodu)

(Shaun Hoffland, UK, Jul 15, 1997)
Otázka:
Přidám-li identickou textovou komponentu do každé položky v dané větvi v okně obsahu , bude se text duplikovat a zvětšovat tak velikost systému vědomostí ?
Odpověď:
Ne. Všechny texty jsou uloženy v registru jen jednou. Každá položka odkazuje na totéž místo registru, aniž by se zvětšovala velikost systému vědomostí.

(Jake White, USA, May 14, 1997)
Otázka:
Učím se rumunská slovíčka. Jak mohu vystředit slovo v komponentě otázky?
Odpověď:
Zkuste Text: Center text (Vystředit text) na místní nabídce komponenty (dostupné kliknutímpravým tlačítkem).

(Zoran Maximovic, Yugoslavia, May 29, 1997)
Otázka:
Jak mohu nezávisle vypnout popisky (hints) a skrýt stavový pruh v SuperMemo 98?
Odpověď:
Chcete-li vypnout popisky, zrušte zatržení políčka Hints na nástrojovém panelu . Pro tentýž účel můžete (také na začátečnické a základní úrovni) dvojitě kliknout na oblast popisků na stavovém pruhu . Chcete-li skrýt stavový pruh, zrušte zatržení Window : View: Status bar na hlavní nabídce

(Lloyd M. Uhler Jr, Jun 12, 1998)
Otázka:
Mám fonty pro šach a chtěl bych používat SuperMemo pro zapamatování šachových pozicí. Mohu importovat materiál vytvořený v MS Word?
Odpověď:
Zkuste použít komponentu OLE .

(Ryszard Kosowicz, Krakow, Poland, May 16, 1997)
Otázka:
Proč SuperMemo automaticky nemění název, když edituji pole otázky v položce ?
Odpověď:
Protože někdy autor systému vědomostí chce, aby byly rozdílné. Chcete-li aktualizovat název, stiskněte Alt+T a Enter (tím se vybere Title (Název) na nástrojovém panelu, vygeneruje se nový název z první textové komponenty a nový název se uloží do systému vědomostí).

(Doug Edmunds, USA, Nov 4, 1997)
Otázka:
Jak mohu globálně změnit rozložení otázky, odpovědi, font, barvu pozadí atd.
Odpověď:
Postup:

  1. Vytvořte novou šablonu s novým rozložením (dbejte na to, aby počet a pořadí komponent bylo stejné jako v původní šabloně).
  2. Uložte šablonu pomocí Template Šablona): Save as template (Uložit jako šablonu) (na místní nabídce prvku )
  3. V okně obsahu zvolte větev , která se má změnit
  4. Na místní nabídce obsahu zvolte Node operations: Merge template (Sloučit šablonu) a zvolte svou novou šablonu
  5. Při slučování se uchovají jen texty, obrazy, zvukové soubory atd. Všechno ostatní se vezme z nové šablony

Varování! Předem si vytvořte záložní kopii svého systému vědomostí . Vynecháte-li v nové šabloně omylem jednu komponentu, odstraní se ze všech prvků uzlu! Neexistuje zde žádná operace "krok zpět"

(Doug Edmunds, USA, Nov 4, 1997)
Otázka:
Jak se vloží obsah Schránky na nové místo?
Odpověď:
Přetáhněte jej myší.

(Keith Gibson, USA, Sep 3, 1997)
Otázka:
Jak mohu zavést zvukovou položku přímo do zvukového registru v SuperMemo 98?
Odpověď:
Zvolte Import files (Importovat soubory) na místní nabídce registrů .

(Richard Hardstein, USA, June 5, 1997)
Otázka:
Z amerického hlediska bych rád známkoval kvalitu odpovědi (tj. výborně, dobře, dostatečně…) tlačítky A, B, C, D & F, aby to bylo v souladu s univerzálním americkým systémem známkování. Je to možné v SuperMemo 98?
Odpověď:
Můžete změnit názvy známek zvolením Tools (Nástroje) : Options (Volby) : Language (Jazyk): Localization table (Lokalizační tabulka) . Nahraďte prostě slovo Bright písmenem A, Good písmenem B atd. Po stisknutí OK SuperMemo začne používat nové názvy.

(Christian Roessel, Germany, July 21, 1998)
Otázka:
Ve svém systému vědomostí mám šablonu , která se skládá ze dvou obrazových komponent . A mám velké množství souborů GIF očíslovaných 1.gif, 2.gif, 3.gif atd. Je možné importovat 1.gif do první obrazové komponenty, 2.gif do druhé, 3.gif do první komponenty následující položky atd.?
Odpověď:
Ne přesně. Budete muset přejmenovat své obrazové soubory na a1.gif, b1.gif, a2.gif, b2.gif. Pak přejděte na první položku, k níž chcete přidat tyto soubory, a zvolte File (Soubor) : Import: Multimedia files (Multimediální soubory). Všechny prvky , které nemají odpovídající obrazy, budou ignorovány a odpovídající soubory budou přeskočeny.

(John Gibney, Australia, Sep 1, 1998)
Otázka:
Jaký je rozdíl mezi dceřinnými prvky a potomky ve stromě vědomostí ?
Odpověď:
Dcery (dceřinné prvky) daného prvku jsou ty prvky, které se zobrazí, když kliknete na znaménko plus vlevo od prvku. Jsou propojeny s mateřským prvkem a posunuty o jeden stupeň doprava. Potomky daného prvku jsou všechny dcery všech dcer atd. Použijeme-li analogie s rodinou, potomci jednotlivce zahrnují děti, vnuky, pravnuky atd.

(Tomasz Chudy, Poland, Oct 17, 1998)
Otázka:
Jak mohu globálně změnit barvu pozadí prvku v celém systému vědomostí?
Odpověď:
Měl byste provést toto (jen když používáte šablonu typu Otázka-Odpověď v celém systému vědomostí nebo používáte-li jiné stejnorodé šablony):

  1. Vytvořte nový prvek (např. stisknutím Ctrl+A)
  2. Změňte barvu pozadí prvku pomocí Color (Barva) (dostupné na místní nabídce prvku v okně prvku )
  3. Uložte nově vytvořený prvek jako šablonu pomocí Template (Šablona): Save as template (Uložit jako šablonu) (dostupné na místní nabídce prvku v okně prvku)
  4. Slučte všechny prvky v systému s novou šablonou pomocí Node operations (Uzlové operace): Template (Šablona): Merge with template (Sloučit s šablonou) (dostupné na místní nabídce obsahu v okně obsahu )

Důležité: Předem si vytvořte záložní kopii. Funkce Merge template je nevratná!

(Peter J. Cool, The Netherlands, Oct 7, 1998)
Otázka:
Rád bych ve svém systému vědomostí zaměnil všechny otázky a odpovědi. Jak to mohu provést?
Odpověď:
Postup (jen když v celém systému vědomostí používáte šablony typu otázka-odpověď):

  1. Vytvořte nový prvek (např. pomocí Ctrl+A)
  2. Změňte pořadí komponent prvku pomocí Components (Komponenty): Component order (Pořadí komponent) (dostupné na místní nabídce prvku v okně prvku )
  3. Uložte nově vytvořený prvek jako šablonu pomocí Template (Šablona): Save as template (Uložit jako šablonu) (dostupné na místní nabídce prvku v okně prvku )
  4. Slučte všechny prvky systému vědomostí s novou šablonou pomocí Node operations (Uzlové operace): Template (Šablona): Merge with template (Sloučit s šablonou) (dostupné na místní nabídce obsahu v okně obsahu )

Důležité: Nejprve si vytvořte záložní kopii. Operace Merge template je nevratná!

(Marcin Piekarniak, Poland, Dec 2, 1997)
Otázka:
Proč se po zvolení kategorie obsahu zobrazí poslední položka v kategorii, nikoliv první?
Odpověď:
Když přidáváte nové položky, chcete vědět,která byla přidána jako poslední. Ke kořeni se můžete snadno přemístit pomocí tlačítka na navigačním nástrojovém panelu (nebo stisknutím Ctrl+Alt+Up )

(Erwin Anema, The Netherlands, Aug 28, 1997)
Otázka:
Mohu při opakování se SuperMemo 98 skrýt hodiny? Rozptylují mne.
Odpověď:
Hodiny nemůžete skrýt, ale můžete skrýt nástrojový panel kliknutím na tlačítko s křížkem na pravé straně skupiny tlačítek.

(David Mckenzie, New Zealand, Apr 8, 1998)
Otázka:
Jak vyhledávat prvek, který neobsahuje žádný text (jen obraz)?
Odpověď:
Použijte Search (Vyhledat) : Image (Obraz). Pomocí Ctrl+F můžete vyhledávat jméno obrazu nebo můžete prostě rolovat v poli Otázka. Pak stiskněte Ctrl+B, aby se zobrazil seznam všech prvků používajících vybraný obraz.

(Noel Clary, USA, Aug 17, 1998)
Otázka:
Vytvořil jsem svou vlastní databázi o instalatérství a klimatizaci. Můj index zapomínání je dost vysoký. Jsou v SuperMemo nějaké nástroje, které by mi pomohly napravit situaci?
Odpověď:
Můžete použít View (Zobrazit) : Special (Speciální): Leeches (Nepoddajné položky) a najít všechny prvky , které způsobují většinu problémů při učení. Pak se musíte zamyslet nad tím, proč jsou tyto prvky tak těžké pro naučení. Obvykle jsou příliš složité, příliš dlouhé, příliš nudné nebo příliš podobné jiným prvkům v systému vědomostí. Můžete nám také poslat 3-4 nejobtížnější položky, abychom si je prohlédli a navrhli vám řešení. Viz také: Leeches (Nepoddajné položky) . Můžete se také podívat na pokročilejší texty: Principles of knowledge structuring

Otázka:
Jsou systémy vědomostí SuperMemo 98 kompatibilní se SuperMemo 8.4?
Odpověď:
Ano. Stačí otevřít starý systém vědomostí (zvolte soubor *.kno ve File : Open) a celý proces upgradu proběhne automaticky.

(Nita L. Wunderlich, USA, Aug 24, 1998)
Otázka:
Jak mohu účinně využívat hierarchii vědomostí v procesu učení?
Odpověď:
Strukturování vědomostí pomocí hierarchie vědomostí není velmi důležité pro proces učení samotný, ale značně zjednodušuje manipulaci s velkým množstvím faktů náležejících do různých předmětů. Hierarchie vědomostí se nejsnáze zvládá pomocí kategorií. Viz též: Kategorie vědomostí

(Michal Grodzki, Poland, Aug 20, 1998)
Otázka:
Radíte uživatelům Advanced English 97 dělat záložní kopie pomocí File : Export: Learning process. Avšak to nezálohuje látku přidanou uživatelem. Jaké je nejlepší řešení v případě, když chci do Advanced English přidávat mnoho vlastních položek?
Odpověď:
Můžete zkusit jedno z následujících řešení:

  1. Uchovávejte svou látku ve zvláštním systému vědomostí . Takový systém můžete zálohovat komprimací souboru <název systému>.kno a adresáře <název systému> do jednoho archivu (např. pomocí WinZip)
  2. Dáváte-li přednost přidávání svých položek do Advanced English (např. abyste mohl látku prohledávat jednou akcí), můžete zálohovat obsah jedné větve jejím přenosem tdo prázdného systému pomocí Tools (Nástroje): Transfer node (Přenést uzel) na místní nabídce obsahu nebo exportem větve jako textu pomocí Tools (Nástroje): Export as text (tké na místní nabídce obsahu). Později můžete obnovit zálohované soubory po reinstalaci Advanced English pomocí Tools (Nástroje): Transfer node v opačném směru nebo pomocí File : Import: Text v posledním případě.

(Dr Janusz Murakowski, USA, Nov 18, 1997)
Otázka:
Jaký je význam Full History of Repetitions (Úplná historie opakování) v Tools (Nástroje) : Options (Volby) : Learning (Učení) ? Jak mohu zobrazit historii opakování?
Odpověď:
Pomocí Full History of Repetitions se ukládají všechny jednotlivá opakování do zvláštního souboru ( \info\reps.dat ). Informace o historii opakování daného prvku je možno prohlížet dvojitým kliknutím na lokno dat prvku nebo zvolením History v dialogovém panelu parametry prvku dostupném z místní nabídky prvku .

(Volker Goretzki, Germany, Feb 22, 1998)
Otázka:
Podle jakých pravidel se řídí překrývání komponent ?
Odpověď:
Komponenty se zobrazují v pořadí, ve kterém jsou přidávány do prvku . Pro změnu tohoto pořadí použijte Component order (Pořadí komponent) na místní nabídce okna prvku .

(Jaroslaw Mekarski, Poland, Apr 15, 1997)
Otázka:
Pomocí Tools (Nástroje) : Options (Volby) : Language : Localization table jsem nadefinoval své národní rozhraní pro SuperMemo, ale některá tlačítka stále mají anglické názvy. Jak je mohu také přeložit?
Odpověď:
Můžete definovat pouze rozhraní SuperMemo pro začátečnickou a základní úroveň . Proto je seznam řetězců pro překlad tak krátký. Pro SuperMemo na profesionální úrovni by měl seznam přes 2000 řetězců místo pouhých 39 řetězců použitých ve zjednodušeném SuperMemo.

(Marcin Piekarniak, Poland, Dec 2, 1997)
Otázka:
Jak mohu přenášet šablonu mezi systémy vědomostí ?
Odpověď:
Použijte Template (Šablona): Save to file (Uložit do souboru) a Template: Load from file (Načíst ze souboru) na místní nabídce prvku . Pro uložení nové šablony do šablonového registru použijte Template: Save as template (Uložit jako šablonu). Viz též: Používání šablon .

(Zoran Maximovic, Yugoslavia, Aug 16, 1998)
Otázka:
Plánujete napsat verzi SuperMemo pro vývoj a prohlížení systémů vědomostí? Podobně jako Acrobat Reader a Adobe Acrobat?
Odpověď:
Ne. To by bylo v rozporu s naší zásadou, že učební látka by měla být vysoce přizpůsobena pro individuálního uživatele a rozšiřována individuálními poznámkami a vodítky. Chtěli bychom, aby všichni uživatelé věděli, jak se mění učební látka, která je obtížná na zapamatování. Pro dobré strukturování látky neexistuje univerzální vzorec. Dobrá položka pro jednoho studenta může jinému působit problémy. Může to být způsobeno interferencí vědomostí pocházející od odlišné kultury, jazyka nebo prostě různé látky uložené v tomtéž systému vědomostí. Mimochodem, není pravda, že SuperMemo v režimu jen čtení by bylo viditelně rychlejší v důsledku vyloučení editačních voleb. Velikost kódu by mohla být snížena o 30-40%, což by mělo za následek prakticky nepostřehnutelné snížení doby zavádění. Volby pro čtení a prezentaci by pracovaly stejným způsobem jako v úplné verzi. Všimněte si, že mimo režimy jen čtení a jen učení zavádí SuperMemo 98 ještě tři úrovně obtížnosti , které pokrývají některé cíle dosahované oddělením prezentačních a autorských funkcí.

(Jim Ivy, USA, June 4, 1997)
Otázka:
Jak mohu zabránit svým studentům v editaci obsahu systému vědomostí v SuperMemo 98?
Odpověď:
Můžete zapnout režim jen čtení nebo jen učení ( Tools (Nástroje) : Options (Volby) : Data access : Access mode (Režim přístupu)) a pak používat SuperMemo v začátečnickém nebo základním režimu .

(Armin Werner, Germany)
Otázka:
Jaký je obsah a funkce jednotlivých souborů v adresářích SuperMemo?
Odpověď:
Viz: Soubory používané programem SuperMemo

Otázka:
Proč není v nabídce File(Soubor) položka Save as (Uložit jako)?
Odpověď:
Protože File (Soubor) : Copy (Kopírovat) dělá přesně to, co by dělalo Save As. Odlišný název však naznačuje, že systém není uložen v paměti, ale je za provozu aktualizován na pevném disku. Proto jej místo ukládání pod jiným jménem musíte okopírovat na nové místo.

Otázka:
K čemu se používá Duplicate ? K čemu potřebuji tutéž položku v tomtéž systému vědomostí ?
Odpověď:
Můžete duplikovat položku , chcete-li přidat jinou položku, která se jen málo liší. Můžete ušetřit čas editováním staré položky místo psaní nové.

(Shaun Hoffland, UK, May 25, 1997)
Otázka:
Jak si mohu prohlížet všechny čekající nebo vynechané prvky v dané větvi ve stromě vědomostí ?
Odpověď:
Pravděpodobně nejjednodušší metoda je:

  • vybrat uzel v okně obsahu
  • zvolit Tools (Nástroje): Browse Node (Prohlížet uzel) na místní nabídce (dostupné kliknutím pravým tlačítkem myši) nebo stisknout Shift+Ctrl+V
  • zvolit Child (Dcera): Pending (Čekající) nebo Child: Dismissed (Vynechané) na místní nabídce prohlížeče (rovněž kliknutí pravým tlačítkem)

Po výše uvedené posloupnosti operací bude prohlížeč obsahovat jen čekající nebo vynechané prvky náležející do vybraného uzlu.

(Tomas Klinkovsky, Czech Republic, Aug 7, 1998)
Otázka:
Jak mohu v Advanced English provádět následující akce pomocí klávesnice:

  • překládat texty
  • zobrazit fonetický přepis
  • opakovat zvuk

Odpověď:
V SuperMemo 8.4 můžete opakovat zvuk stisknutím Ctrl+F10 . V SuperMemo 98 můžete navíc zobrazit překlady stisknutím Alt+U a fonetický přepis stisknutím Alt+Y.

Otázka:
Všimla jsem si, že File (Soubor): Recover (Zotavit) neobnovuje frontu pro závěrečné procvičování . Co když se poškodí soubor drill.dat ? Znemožní to učení?
Odpověď:
Ne. drill.dat je dočasný soubor a je možno jej vždy odstranit pomocí Learn (Učit se) : Cut drills (Zrušit závěrečné procvičování) s nepatrným škodlivým vlivem na proces učení.

(Tomas Klinkovsky, Czech Republic, Aug 7, 1998)
Otázka:
Proč nejsou tipy nad šedými tlačítky?
Odpověď:
To je implicitní chování komponent v Delphi (SuperMemo 98 bylo napsáno v Delphi 3.02)

(Vaclav Losik, Czech Republic, Apr 10, 1997)
Otázka:
Jak doplnit chybějící překlady hlášené funkcí File : Recover ?
Odpověď:
Dostanete-li při obnově hlášení jako Missing translation for Member #186: "virtually every" můžete doplnit překlad pomocí následujícího postupu:

  1. zvolte Search (Vyhledat) : Text
  2. vložte do editačního pole text, jehož překlad chybí (např. virtually every)
  3. napište překlad do tabule překladu okna registru (vpravo dole).

(Tomasz Szynalski, Poland, August 1998)
Otázka:
Proč bych měl upgradovat z SuperMemo 8.4 na SuperMemo 98?
Odpověď:
Protože je rychlejší, můžete ve svých tématech ukládat neomezenou délku textu, můžete importovat soubory HTML atd. Viz: Co je nového?

(Artur Osadowski, Poland, Sep 5, 1998)
Otázka:
Ovlivňuje nastavení Access Mode (Režim přístupu) v Tools (Nástroje) : Options (Volby) : Data access (Přístup k datům) dostupnost zvuků na CD-ROM?
Odpověď:
Ne. Abyste zajistil správné načítání zvuků programem SuperMemo z CD-ROM, musíte jen zadat správnou cestu v Tools (Nástroje): Options (Volby): Data access: Secondary storage (Sekundární paměť) .

Otázka:
Co mám dělat, když SuperMemo zobrazuje podivná chybová hlášení, často padá a File : Recover nefunguje?
Odpověď:
Zajistěte, aby vaše Windows byly stabilní a abyste neměli žádné problémy s hardwarem. Pokud hlášení zobrazují Windows a nikoliv SuperMemo samotné (např. moduly jako Kernel, User, Ctl3D atd.), problém pravděpodobně není v SuperMemo. Některé hardwarové problémy jsou častým důvodem takových situací, zejména pokud se podobná hlášení objevují i v jiných aplikacích. Zkontrolujte v prvé řadě paměť, pevný disk, systémový setup a základní desku.
V případě, že jste si jist, že funkce File: Recover není schopna zotavit systém z důvodů vztahujících se k SuperMemo, napište na support@supermemo.com

(Anatolyi Lipatov, Ukraine, Jul 12, 1998)
Otázka:
Používám Advanced English pro rozšíření znalostí angličtiny a obchodní angličtiny. Nyní se hlásím na zkoušku CFA (Chartered Financial Analyst program of Association of Investment Management and Research). Existuje několik organizací vyvíjejících a rozšiřujících metodologické postupy pro přípravu na zkoušku. Na zkoušku je nutné se naučit spoustu věcí. Jaký by byl nejlepší způsob použití SuperMemo pro učení a jaký postup mám použít pro přípravu své vlastní báze vědomostí pro naučení látky. Je k tomu nutná znalost progrtamování?
Odpověď:
Pro zhotovení jednoduchých systémů vědomostí v SuperMemo nejsou nutné žádné speciální znalosti. Pomocí Ctrl+A (tj. Add new item ) dostanete 90% funkce! Všechny pokročilé editační volby mohou být obejity odpovídajícím přístupem typu otázka - odpověď. Snad by bylo užitečné naučit se, jak se do položek přidávají obrazy (viz nápovědu). Chcete-li se dovědět víc o efektivním strukturování vědomostí v SuperMemo, přečtěte si Knowledge Structuring and Representation ; avšak nejlépe funguje, když se při formulování vědomostí pro učení se SuperMemo učíte na vlastních chybách.

(Jan Gromadzki, Poland, Jul 11, 1998)
Otázka:
Koupil jsem si Advanced English 97 a nemohu se dostat přes úvod. Jsou tam šipky ukazující na ikony ... které neexistují. Kde je chyba?
Odpověď:
Potřebujete do svého počítače nainstalovat zvukovou kartu (je to uvedeno v minimálních požadavcích !). Některé skriptové příkazy nepracují bez zvukové karty a úvodní část do značné míry používá skripty. Chcete-li používat Advanced English bez zvukové karty, postupujte takto:

  • stiskněte Ctrl+P (otevře se dialogový panel Options (Volby) )
  • zvolte kartu Data access (Přístup k datům)
  • označte kulaté tlačítko Full Access (Úplný přístup) (tím dostanete režim úplného přístupu k datům na rozdíl od režimu "jen čtení", který je nastaven v úvodu)
  • zrušte zatržení Hide Navigation (Skrýt navigaci) (aby se zobrazil navigační nástrojový panel , který se jinak zapíná skripty po uvedení uživatele do některých složitostí programu)
  • vymažte cestu zobrazenou v Secondary storage (Sekundární paměť) (tato cesta ukazuje, kde jsou zvukové soubory používané v Advanced English; bez zvukové karty jsou tyto soubory zbytečné a vymazáním cesty se program zrychlí).

(Zoran Maximovic, Yugoslavia, Aug 16, 1998)
Otázka:
Jak mohu změnit font nadpisů oken v SuperMemo (tj. font na pruhu s třemi tlačítky na pravé straně: minimalizovat, maximalizovat a zavřít), a jak v nabídkách?
Odpověď:
Tyto fonty je možno měnit jen pro celá Windows. Klikněte například pravým tlačítkem na plochu, zvolte Vlastnosti, zvolte Vzhled a vyberte Schéma.

(Tomasz Szynalski, Poland, Dec 2, 1998)
Otázka:
Když v komponentě OLE vytvořím vzorec pomocí MS Equation, je rovnice nepřirozeně velká a zkreslená. Jak mohu tuto závadu napravit?
Odpověď:
Interpretaci objektů OLE provádí aplikace, v tomto případě MS Equation. Musíte problém vyřešit v MS Equation nastavením atributů zobrazení (např. zde zmenšením fontů).

***


Nabídka Soubor

File (Soubor)

Podnabídka File (Soubor) na hlavní nabídce obsahuje následující volby:
(Poznámka: popis platí pro profesionální úroveň. Na začátečnické a základní úrovni se zobrazí jen některé z uvedených voleb)

  • New (Nový) - vytvořit nový prázdný souhrn. Chcete-li vytvořit svůj souhrn, dejte mu jméno a příponu kno
  • Open (Otevřít) - otevřít souhrn pro používání. Nejrychlejší způsob otevření souhrnu je napsat jeho jméno následované tečkou a libovolným znakem. Například chcete-li otevřít souhrn biologie, napište biologie.x nebo biologie.a
  • Organize (Organizovat) - kopírovat, přesunout, mazat soubory patřící k souhrnu
    • Copy (Kopírovat) - okopírovat právě otevřený souhrn na nové místo. Chcete-li okopírovat systém, napište jméno cílového systému (dejte mu příponu KNO). Pokud cílový systém již existuje, bude před kopírováním vymazán. Všimněte si, že příkaz Copy je ekvivalentní příkazu Save As (Uložit jako) (odlišný název se používá pro indikaci toho, že systém není uchováván v paměti počítače, nýbrž na pevném disku.)
    • Semi-Copy (Kopírovat částečně) - okopírovat právě otevřený systém bez podadresáře ements . Tento adresář obsahuje multimediální objekty jako videosoubory, zvukové soubory, bitmapy atd. V hypermediálních systémech zabírají tyto soubory více než 95% velikosti systému. Semi-Copy je možno použít pro rychlé zálohování velkých systémů vědomostí, jejichž multimediální objekty již jsou zálohovány nebo se od posledního zálohování příliš nezměnily. Navíc můžete používat Semi-Copy pro vytvoření kopie systému pro jiného člena rodiny používajícího tentýž systém vědomostí na tomtéž počítači (nebo téže LAN)
    • Move (Přesunout) - okopírovat právě otevřený systém vědomostí a vymazat jeho originál
    • Delete (Vymazat) - vymazat právě otevřený systém vědomostí po potvrzení
    • Garbage (Odpadky) - vymazat vybrané soubory pro snížení velikosti systému vědomostí (úspora bude největší v případě, že používáte mnoho vlastních nahrávek při procvičování výslovnosti)
    • View report (Zobrazit hlášení) - zobrazit libovolný textový soubor, zejména soubor hlášení SuperMemo (implicitně: textové soubory s příponou txt z adresáře reports , např. recover .txt, mercy .txt atd.)
  • Recover (Zotavit) - odstranit problémy integrity v systému vědomostí (např. jako důsledek fyzického poškození souborů systému vědomostí)
  • Reset (Vynulovat) - vymazat vybraná data týkající se procesu učení
    • Collection (Systém vědomostí) - vymazat všechna data týkající se rozplánování opakování ze souhrnu. Jinými slovy, systém bude vypadat, jakoby ještě nebyl v procesu učení používán. Funkce File (Soubor): Reset (Vynulovat): Collection (Systém vědomostí) je užitečná, jestliže chcete svůj systém vědomostí předat jinému uživateli nebo jej šířit komerčně. File: Reset: Collection odstraní všechna data týkající se vašeho procesu učení a ponechá všechny položky ve stavu čekání (nebo vynechané položky). Na konci tohoto procesu budete dotázáni, chcete-li nastavit posloupnost fronty čekajících prvků podle polohy prvků ve stromě vědomostí (odpověď yes na dotaz Do you want to sort pending queue by hierarchy? (Chcete seřadit frontu čekajících prvků podle hierarchie?) nebo podle rostoucích ordinálních čísel prvků (odpověď yes na dotaz Do you want to sort pending queue by ordinals? (Chcete seřadit frontu čekajících prvků podle ordinálních čísel?)
    • Repetition history (Historie opakování) - vymazat soubor reps.dat, který obsahuje historii opakování jednotlivých prvků. Všimněte si, že tento soubor není v algoritmu SM-8 používán a je volitelný.
    • Optimization matrices (Optimalizační matice) - vynulovat jen optimalizační matice používané v procesu učení (RF, OF atd.)
    • Forgetting index record (Záznam Indexu zapomínání ) - vynulovat záznam o známkách používaný při výpočtu naměřeného indexu zapomínání
    • Sort pending by hierarchy (Seřadit frontu čekajících prvků podle hierarchie) - setřídit frontu čekajících prvků podle polohy jednotlivých prvků ve stromě vědomostí (v okně obsahu ). Tvar stromu vědomostí můžete určovat přetahováním prvků a uzlů (drag-and-drop). Po setřídění bude na prvním místě ve frontě čekajících prvků první dcera první dcery první dcery ... . Na posledním místě bude poslední dcera poslední dcery ... hlavního uzlu
    • Sort pending by ordinal (Seřadit frontu čekajících prvků podle ordinálních čísel) - seřadit frontu čekajících prvků podle ordinálních čísel (nejprve nižší ordinální čísla))
  • Import (Importovat) - importovat externí soubory
    • Learning process (Proces učení) - znovu zavést proces učení zálohovaný pomocí Export: Learning process (Proces učení) (viz níže). Pokud soubory s příponou Ir1 nebo lr2 chybějí, můžete přesto tuto volbu použít; profil uživatele a historie opakování však budou ztraceny. Například exportujete-li svůj soubor procesu učení s názvem my knowledge.txt , bude provázen soubory my knowledge.lr1 (profil uživatele) a my knowledge.lr2 (historie opakování). Proces učení můžete importovat, i když soubory lr1 a lr2 chybějí
    • Q'n'A text (Text otázek a odpovědí) - importovat standardní soubor otázek a odpovědí vytvářený programem SuperMemo pro DOS, Windows, Mac nebo Amiga. Tyto textové soubory je možno vytvářet i ručně. Například:
    •

  • Q: řeka
    A: rivero

    Q: škola
    A: lernejo

    Q: naděje
    A: esperanto

    •

    Tato volba je obzvlášť užitečná, používá-li se pro rychlé vytvoření systému vědomostí s otázkami a odpověďmi rozpoznávání řeči (například pomocí Dragon Naturally Speaking)

    •
      • Translation (Překlad) - importovat soubor s překladem textového registru do zvoleného jazyka
      • Text - importovat textový soubor dříve vygenerovaný pomocí File (Soubor): Export: As text (Jako text), File: Export: Subset as text (Podmnožinu jako text) nebo Export as text (Exportovat jako text) na místní nabídce obsahu
      • Multimedia files (Multimediální soubory) - importovat soubory typu BMP, GIF nebo WAV vygenerované programem SuperMemo pro počítače Amiga nebo Macintosh (nebo jinými nástroji). Jména souborů jsou 1.BMP, 2.BMP atd. a jsou importovány do první obrazové nebo zvukové komponenty v posloupnosti prvků počínaje právě zobrazeným prvkem. 1.BMP bude importován do aktuálního prvku, 2.BMP do prvku s následujícím číslem prvku (tj. číslo aktuálního prvku +1) atd.
    • Export (Exportovat) - exportovat externí soubory
      • Learning process (Proces učení) - uložit proces učení do textového souboru. Díky tomu není nutno zálohovat celé velké systémy, jako je např. Advanced English. Stačí uložit proces učení a později jej znovu zavést (restore). Je možno vzít původní systém vědomostí (např. Advanced English ) a poskytnout mu data z tohoto textového souboru. Spolu s textovým souborem se vytvoří také dva soubory se stejným jménem jako textový soubor, ale s příponami lr1 a lr2. Jsou to učební profil uživatele (kopie info/sm8opt.dat ) a historie opakování (kopie info/reps.dat ). Tyto soubory (lr1 a lr2) jsou nepovinné. Jejich vymazáním pozbude záloha procesu učení informace o profilu uživatele a historii opakování; nebrání to však obnově (restore) procesu učení (profil uživatele se bude muset vytvořit znovu)
      • As text (Jako text) - exportovat celý systém vědomostí jako textový soubor (prvky, jejich poloha ve stromě vědomostí a všechny komponenty). Všimněte si, že se nepřenáší profil uživatele ani nepoužité členy registrů. Tento soubor je později možno importovat do jiného systému pomocí Import: Text
      • Subset as text (Podmnožinu jako text) - exportovat podmnožinu jako text. Tato volba je stejná jako Export: As text s výjimkou, že se exportují pouze prvky náležející do vybrané podmnožiny. Viz též: Používání podmnožin
      • Q'n'A text (Text otázek a odpovědí) - exportovat soubory otázek a odpovědí SuperMemo, přičemž se použije první komponenta otázky a první komponenta odpovědi každého prvku (pokud existují)
      • Translation (Překlad) - exportovat překladový soubor, který je po modifikaci možno importovat zpět pomocí Import: Translation
      • Lexicon - exportovat lexikon ve formátu otázka/odpověď pro import do SuperMemo. Například systém WORDS použitý v Cross Country byl vygenerován pomocí této volby ve spojení s volbou Import: Q-A text (Text otázek a odpovědí)
    • Registration (Registrace)
      • Input password (Zadat heslo) - zadat registrační heslo. Tato volba je aktivní jen u neregistrovaného SuperMemo a měla by se použít pro předání registračního hesla obdrženého od dodavatele po úhradě registračního poplatku. Viz: Registrace SuperMemo
      • Request password (Vyžádat heslo) - otevřít dialogový panel, který umožňuje poslat distributorovi e-mail s registračními údaji uživatele. Uživatel obratem obdrží pokyny pro platbu
      • Unregister (Zrušit registraci) - odstranit registrační data z právě používaného systému vědomostí. Tuto volbu musíte použít před redistribucí svého vlastního systému vědomostí! Distribucí registrovaných systémů rušíte svou uživatelskou licenci a rozšiřujete své registrační údaje jiným uživatelům
    • Level (Úroveň) - umožňuje volit mezi začátečnickou, základní a profesionální úrovní
    • Exit (Konec) - ukončit SuperMemo
    • 1-10 - otevřít jeden z posledních deseti otevřených systémů vědomostí

    Časté otázky

    (David Mckenzie, New Zealand, Apr 8, 1998)
    Otázka:
    Má smysl udržovat několik oddělených     souhrnů vědomostí?
    Odpověď:
    Ne. Když zvládnete     kategorie obsahu a šablony , nemá to smysl. Získáte tím globální vyhledávání, globální registry , globální opakování, globální optimalizaci atd. Nelze to doporučit ve starší verzi SuperMemo 7, protože míra obtížnosti (E-faktor) závisela na průměrné obtížnosti položek v souhrnu. V současné době je míra obtížnosti položky absolutní ( A-Faktor neboli absolutní faktor obtížnosti) a nezávisí na kontextu, ve kterém je položka umístěna (viz Algoritmus SM-8 ). Průměrnou obtížností položek v souhrnu je významně ovlivněna jen délka prvního intervalu. To však neovlivňuje dramaticky rychlost učení . Zejména díky tomu, že proměnný index zapomínání pro jednotlivé položky umožňuje nastavit odlišné první intervaly pro celé kategorie nebo větve ve stromě vědomostí .

    ****


Soubory a adresáře v SuperMemo

Soubory používané při typické instalaci SuperMemo:

Adresář SuperMemo - obvykle c:\sm8 nebo c:\sm98

    • sm98.exe - program: SuperMemo 98
    • bin - některé pracovní soubory používané programem SuperMemo
      • sm8.ini - textový soubor s některými parametry používanými SuperMemo. Tento soubor je možno ručně modifikovat. Provádějte to však opatrně a před provedením změn si vytvořte záložní kopii
      • tips.txt - textový soubor s tipy používanými v Question of the Day (Otázce dne) . Tento soubor můžete ručně modifikovat
      • smhelp.chm - soubor nápovědy pro SuperMemo (pokud tento text nečtete přes Internet, pravděpodobně čtete tento soubor). Stáhnete-li si shorthelp.chm (nápověda o velikosti 0,5 MB místo 2.0 MB), měli byste jej přejmenovat na smhelp.chm, chcete-li, aby jej SuperMemo používalo místo souboru úplné nápovědy. Český soubor nápovědy se jmenuje smczhelp.chm, česká nápověda se otvírá pomocí F2.
    • systems - systémy vědomostí (souhrny) používané SuperMemo
      • <jméno systému>.kno - soubor s nejdůležitějšími parametry systému vědomostí, například celkovým počtem prvků, počtem probraných prvků, datem vytvoření systému vědomostí atd.
      • <jméno systému vědomostí> - adresář se zbývajícími soubory systému vědomostí
        • ks.ini - textový soubor s některými parametry používanými systémem vědomostí. Tento soubor můžete ručně modifikovat. Provádějte to prosím opatrně a před provedením změn si vytvořte záložní kopii
        • info - nejdůležitější informační soubory
          • compon.dat - binární soubor s rozložením a atributy všech komponent použitých v systému vědomostí
          • elinfo.dat - informace o jednotlivých prvcích: A-faktor , datum posledního opakování, počet opakování, index zapomínání atd.
          • contents.dat - informace o struktuře stromu vědomostí . Každý prvek má v tomto souboru zaznamenán svůj mateřský prvek (matku), sesterské prvky (sestry) a první dceřinný prvek (dceru), spolu s počtem dcer a počtem potomků
          • reps.dat - historie opakování všech jednotlivých prvků. Tento soubor je nepovinný a můžete jej odstranit pomocí File : Reset: Repetition history
          • burden.dat - soubor s počtem opakování naplánovaných na každý den a ukazatelem na první položku na seznamu opakování pro daný den
          • intact.dat - soubor podmnožiny prvků se všemi čekajícími prvky (tj. fronta čekajících prvků )
          • sm8opt.dat - soubor záznamu optimalizačních dat používaných Algoritmem -SM8 . Další informace o tomto záznamu najdete v: Implementace SuperMemo s sm8opt.dll
          • appnodes.dat - informace o všech kategoriích obsahu
          • drill.dat - soubor podmnožiny prvků se všemi prvky naplánovanými pro závěrečné procvičování (tj. fronta závěrečného procvičování).Tento soubor můžete vymazat (fronta záv. procvičování se vyprázdní)
          • history.dat - soubor podmnožiny prvků s posledními 50 navštívenými prvky. Tento soubor můžete vždy vymazat
        • registry - registry používané systémem vědomostí (kromě registrů překladu a přepisu; viz níže)
          • text.* - soubory textového registru
            • text.inf - informace o všech členech registru uložených v textovém registru (např. počet použitých prvků, ukazatel na soubor text.reg, v němž je uloženo jméno členu registru, ukazatel na soubor text.lst, v němž je uložen seznam prvků používajících daný člen atd.)
            • text. lst - seznam všech prvků používajících všechny jednotlivé členy textového registru
            • text.ptr - podmnožina registru , v níž je uložena setříděná podmnožina všech členů v textovém registru
            • text.reg - jména všech členů textového registru. Tento soubor si můžete prohlížet libovolným editorem. Rozhodnete-li se editovat tento soubor, nikdy neměňte délku jednotlivých záznamů. To by porušilo integritu textového registru
          • font.* - soubory fontového registru
          • sound.*, atd.
        • elements - multimediální soubory spojené s jednotlivými registry, například video, zvuk, obrazy, html , OLE , skripty , atd. Všechny tyto soubory můžete editovat, ale nesmíte je přejmenovat nebo přesunout, protože by to porušilo integritu systému vědomostí. Adresář prvků je možno přenést na sekundární paměť (např. pomocí File : Semi-Copy) a uložit na CD-ROM nebo CDR. Tak je možno ušetřit místo na pevném disku. Adresářový strom v elements postupně roste, jak přidáváte do systému nové soubory. Je však omezen na 40 souborů na adresář, aby se maximalizovala výkonnost média CD-ROM
        • translat - překladové registry dostupné pro systém vědomostí (viz: Tools : Options : Language : Collection translation). Tento adresář můžete vymazat, překlady však potom nebudou dostupné
        • subsets - podmnožiny prvků vytvořené uživatelem. Tento adresář můžete vymazat, pokud podmnožiny nepotřebujete. Další informace: Používání podmnožin
        • reports - textový soubor s hlášeními vygenerovanými programem SuperMemo (např. hlášení recovery , hlášení o importu překladu, hlášení o přenosu atd.). Tento adresář můžete vymazat, pokud hlášení nepotřebujete
        • files - ostatní soubory používané SuperMemo (např. šablonové soubory). Tento adresář můžete vymazat
        • temp - dočasné soubory používané SuperMemo. Tento adresář můžete vždy vymazat. Uvědomte si však, že ztratíte své záznamy vytvořené při procvičování výslovnosti
    • translat - soubory lokalizační tabulky SuperMemo používané pro zobrazení rozhraní SuperMemo v různých jazycích (viz: Tools : Options : Language : Localization table )
    • phonetic - registry fonetického přepisu (viz: Tools : Options : Language : Phonetic transcription)
    • filters - filtrové soubory pro zpracování textů v systémech vědomostí (přípona flt)
    • alg - algoritmus plug-in - soubory DLL a doprovodné soubory

Časté otázky

(Marcin Piekarniak, Poland, Dec 2, 1997)
Otázka:
Jak lze snadno zálohovat Advanced English 97? V Advanced English 94 bylo možno celý systém zkomprimovat na soubor o velikosti 1,4 MB!
Odpověď:
Můžete zálohovat jen proces učení. Tak se ukládají jen data týkající se položek v procesuučení (nikoliv položky samotné). Pro export dat použijte File : Export: Learning proces. Později, po reinstalaci Advanced English 97, můžete obnovit proces učení pomocí File : Import: Learning process.

****


Filtr prvků

Funkci View (Zobrazit) : Special: Filter je možno použít pro nalezení prvků, které splňují určitou množinu kritérií, např. počet opakování, počet selhání paměti , délka aktuálního intervalu, status (probrané, čekající nebo vynechané), typ (položka nebo téma) atd.

Pro výběr minimálních a maximálních hodnot hledaného rozsahu je možno použít následující pole:

  • Repetitions (Počet opakování) - počet opakování provedených s daným prvkem
  • Lapses (Počet selhání) - počet případů, kdy byl daný prvek zapomenut
  • Interval - počet dnů mezi posledním opakováním a následujícím opakováním.
  • Last repetition (Poslední opakování) - počet dnů mezi datem prvního dne procesu učení a datem posledního opakování (číslování dnů najdete v Tools (Nástroje) : Workload)
  • Next repetition (Příští opakování) - počet dnů mezi prvním dnem procesu učení a datem příštího opakování
  • A-Factor - hodnota A-Faktoru přiřazená danému prvku
  • Forgetting index (Index zapomínání) - pravděpodobnost zapomenutí daného prvku při každém opakování
  • Ordinal number (Ordinální číslo) - ordinální číslo přiřazené prvku.

Nechcete-li použít dané kritérium, zrušte zatržení odpovídající danému poli. Jestliže je chcete použít, zatrhněte příslušné políčko a zadejte minimální a maximální hodnoty.

Pole Type a Status umožňují vyhledat položky a témata s různým statusem (čekající, probrané a vynechané). Například chcete-li vyhledat všechny probrané položky, zatrhněte Item, Topic a Memorized a ostatní pole ponechejte nezatržená.

Jakmile kliknete na OK, všechny prvky splňující zadaná kritéria budou nalezeny a zobrazí se v prohlížeči .

Parametry filtrů se mezi relacemi ukládají do souboru <adresář supermemo>\<systems>\<název systému vědomostí>\ks.ini v sekci [Filter].

Dialogový panel filtru se používá také v View (Zobrazit) : Special: Leeches (Nepoddajné položky) .

****


Filtrové soubory

Obsah : Technický popis: Pokročilé funkce
Filtrové soubory

Filtrové soubory s příponou flt je možno v SuperMemo používat pro globální zpracování textů v souhrnu vědomostí (vědomostním systému). Například je výhodnější provádět vícenásobné náhrady textu pomocí filtru než ručně jednotlivě pomocí Najít a zaměnit (Find and replace) v místní nabídce registry .

Filtrové soubory podporují specifikaci filtrových souborů ze SuperMemo 6 a SuperMemo 7; budete je však většinou používat za následujících okolností:

  1. náhradu velkého počtu textů v souhrnu (vědomostním systému) vybraným řetězcem
  2. odstranění poznámek a jiných vymezených textů ze souhrnu

Ostatní volby jsou podporovány jen pro kompatibilitu a jsou lépe prováděny jinými funkcemi programu.

Filtrové soubory jsou textové soubory, které je možno ručně editovat. Skládají se z úseků, jako jsou [REPLACE], [DELIMITERS], [CUT], atd. Každá sekce obsahuje seznam argumentů umístěných na jednotlivých řádcích. Například úsek [REPLACE] bude obsahovat dvojice řetězců: řetězce, které se mají nahradit a řetězce, které se mají dát na místo odstraněných řetězců.

Příklad obsahu filtrového souboru:

  • [DELIMITERS]
    < > cut
    { } cut
    [REPLACE]
    histol: histologie:
    physiol: fyziologie:
    mem: ''
    endocr: ''

    •

    Otevřete-li textový registr pomocí Search (Vyhledat) : Text, zvolíte na místní nabídce registru Apply filter (Použít filtr) a vyberete tak soubor, provedou se s texty v celém souhrnu vědomostí následující změny:

    1. všechny texty ohraničené špičatými závorkami budou odstraněny
    2. všechny texty ohraničené složenými závorkami budou odstraněny
    3. texty histol: a physiol: budou nahrazeny histologie: a fyziologie:
    4. texty mem: a endocr: budou odstraněny

    Filtrové soubory jsou obvykle uloženy v podadresáři filters .

    ****


Slovník pojmů

Obsah : Slovník pojmů
Slovník pojmů

access mode (režim přístupu) - rozsah činností dostupných uživateli vědomostního systému (souhrnu vědomostí) . Existují tři režimy:

  1. jen čtení - uživatel může vědomostní systém jen prohlížet.
  2. jen učení - uživatel může vědomostní systém prohlížet, učit se novou látku a provádět opakování.
  3. úplný přístup - uživatel může libovolně měnit obsah vědomostního systému.

acquisition rate (rychlost osvojování) - rychlost učení, obvykle vyjadřovaná v počtu prvků naučených za rok za minutu. Například jestliže se při 20 minutách denního učení dosáhne 10 000 položek za rok, rychlost osvojování je 500 položek/rok/min. V SuperMemo se rychlost osvojování může měnit od 100 do 1000 v závislosti na obtížnosti látky, indexu zapomínání a stupni procesu učení (rychlost osvojování může v prvním roce podstatně klesat; později se asymptoticky stabilizuje).

active recall (aktivní vyvolání) - proces, ve kterém se jednotlivé informace aktivně vyvolávají z paměti, na rozdíl od pasivního prohlížení. Například při pasivním prohlížení si můžeme přečíst, že 50% manželství v USA se rozvede. Při aktivním vyvolání byste si museli tuto informaci vyvolat z paměti: Jaká část manželství v USA se rozvádí? Odpovíte-li správně 50%, pak pravděpodobnost, že si v budoucnosti tuto informaci vybavíte v paměti, je mnohem vyšší než v případě pasivního prohlížení.

A-factor (faktor A) - číslo spojené s každým prvkem v souhrnu . Toto číslo odráží obtížnost prvku. Čím vyšší je faktor A, tím je prvek snazší. Nejobtížnější prvky mají faktor A rovný 1,3. Faktor A je definován jako poměr mezi druhým a prvním optimálním intervalem použitým při opakováních . Faktory A můžete vidět v okně dat prvku . Viz též: Algoritmus SM-8 použitý v SuperMemo

browser (prohlížeč) - okno s podmnožinou prvků SuperMemo . Prohlížeče jsou většinou dostupné z nabídky View (Zobrazit) a poskytují řadu funkcí dostupných z místní nabídky prohlížeče . Viz též: Okno prohlížeče

burden (zátěž) (v okně statistiky ) číslo, které je odhadem průměrného počtu prvků , které je třeba denně zopakovat:

zátěž = 1/I1+1/I2+ ... + 1/In
kde:
In - aktuální interval nté položky

category (kategorie) - pojmenovaná větev větev stromu vědomostí , do níž se přidávají prvky patřící k dané třídě vědomostí (např. můžete mít následující kategorie: Všeobecné vědomosti, Rodina, Internet, Práce atd.). Každá kategorie je charakterizována (1) jménem, (2) šablonou položek (která určuje vzhled položek kategorie, např. barvu, písmo, velikost, atd.), (3) kořenový uzel ( uzel stromu vědomostí , který je předkem všech prvků přidaných do kategorie) a (4) hkotevní uzel (hook node) (uzel stromu vědomostí, ke kterému se přidávají nové prvky jako dceřinné prvky (children) , dokud se nedosáhne mezního počtu dceřinných prvků . Kategorie je možno editovat pomocí Tools (Nástroje) : Categories (Kategorie)

child (dceřinný prvek, dcera) (v okně obsahu ) - prvek , který je umístěn jednu úroveň pod prvkem, který je jeho matkou. Všechny prvky se stejným odsazením ve stromě vědomostí jsou dcery své matky (vzájemně jsou sestry), kdežto potomci jsou všechny prvky pod úrovní svého předka

ClipBox (Schránka) - dočasná oblast pro prvky nebo komponenty v paměti. Pracuje podobně jako schránka Windows. Nejprve umístíte objekt do schránky a potom jej můžete libovolněkrát načíst ze schránky. Ukončením programu se schránky vyprázdní. Existují tři druhy schránek umístěných na nástrojovém panelu: Schránka prvků (používá se pro kopírování prvků), schránka komponent (používá se pro kopírování komponent) a schránka hyperpropjení (používá se pro vytváření hyperpropojení). Viz Používání schránek

cloze deletion (položka s vynechávkou) - položka , v níž je část otázky nahrazena třemi tečkami a přesunuta do pole odpovědi. Například:

  • Otázka: Nejvyšší procento gramotnosti v Africe bylo dosaženo v ...(stát)(1998)?
    Odpověď: Tanzánie

    Tyto položky mohou být nejjednodušším a velmi efektivním způsobem pro nápravu složitosti položky. Máte-li položky, které neustále vyvolávají problémy, zkuste použít tento způsob

    •

    collection (souhrn, systém vědomostí, vědomostní systém) - studovaná látka používaná v SuperMemo . Souhrn se skládá z jednotlivých vědomostí nazývaných prvky. Nejjednodušší prvky se skládají z otázky a odpovědi. Souhrn daného jména je uložen v adresáři téhož jména a všechna jeho důležitá statistická data a data procesu učení jsou uložena v souboru s příponou KNO

    component (komponenta) - jakýkoliv objekt umístěný ve viditelném poli prvku . Např. text otázky, obrázek, videokomponenta, doplňovací pole pro kontrolu pravopisu atd.

    contents window (okno obsahu) - okno, ve kterém se zobrazuje hierarchická struktura vědomostí v souhrnu vědomostí (vědomostním systému). Je dostupné kliknutím na Obsah (Contents) v okně prvku . Viz též: Okno prvku

    database (databáze) - jiný termín používaný pro souhrn vědomostí SuperMemo v dřívějších verzích SuperMemo

    descendant (potomek) - (v okně obsahu ) - prvek , který je umístěn o jednu nebo několik úrovní pod prvkem, který je jeho předkem. Všechny prvky se stejným odsazením ve stromu vědomostí jsou dcery své matky (navzájem jsou sestry), potomci jsou všechny prvky pod úrovní předka

    dismiss (vynechat) - operace, která zcela odstraní prvek z procesu učení (viz: forget (zapomenout) , remember (zapamatovat )

    dismissed element (vynechaný prvek) - prvek , který je ignorován v procesu učení a není udržován ve frontě čekajících položek . Vynechaný prvek je možno zavést do procesu učení pomocí Zapamatovat (Remember)

    dragging mode (přetahovací režim) - způsob zobrazení komponent , při kterém mohou být snadno přetahovány (metodou drag and drop) na nové místo v okně prvku . Další dva základní režimy jsou: prezentační režim (komponenty se zobrazují jako při učení) a editační režim (komponenty je možno snadno editovat, např. napsáním nového textu atd.). Komponenty v přetahovacím režimu jsou obvykle tmavší než v ostatních dvou režimech. Chcete-li komponentu přetáhnout, stiskněte nad komponentou tlačítko myši a přemístěte ji na nové místo

    editing mode (editační režim) - způsob zobrazení komponent , při kterém mohou být komponenty snadno editovány (např. modifikací textu). Ostatní dva základní režimy jsou: prezentační režim (komponenty vypadají jako při učení) a přetahovací režim (komponenty je možno snadno přetahovat myší na jiné místo). Editační režim nejsnáze poznáte podle toho, že komponenty jsou ohraničeny rámečkem, jehož velikost je možno měnit

    element (prvek) - jedna stránka uložená v SuperMemo (např. dvojice otázka - odpověď). Všechny prvky dohromady tvoří souhrn (collection) vědomostí ( nazývaný též vědomostní systém nebo systém vědomostí). Prvky se dělí na témata (shrnující, syntetická látka) a položky (testovací látka). Téma souhrnným způsobem předkládá určitou část studované látky. Položky představují testovací otázky nebo cvičení pro procvičování látky uvedené v tématech. V nejjednodušším případě mají témata formu stránky textu a položky jsou formulovány jako otázky a odpovědi. Každý prvek je reprezentován v okně obsahu jako jedna větev vědomosti nebo list. Jednotlivé prvky se zobrazují v okně prvku .

    element browser (prohlížeč prvků) - viz prohlížeč

    element subset (podmnožina prvků) - podmnožina prvků uložených do souboru. Podmnožinu prvků můžete vytvořit pomocí prohlížeče prvků (např. Subset (Podmnožina): Save all (Uložit vše) nebo Subset (Podmnožina): Save selection (Uložit výběr)). Podmnožinu prvků si můžete prohlížet pomocí View (Zobrazit) : Subset (Podmnožina) . Viz též: Používání podmnožin

    element window (okno prvku) - okno, ve kterém je zobrazen jeden prvek souhrnu vědomostí . Implicitně se v tomto okně zobrazují tlačítka Obsah (Contents), Vyhledat (Search), Historie atd. na nástrojovém panelu

    final drill (závěrečné procvičování) - poslední etapa učení prováděná daný den, v níž se opakují pouze prvky oznámkované známkou horší než Dobře (Good, 4), a to tak dlouho, dokud nejsou ohodnoceny známkou alespoň Dobře

    forget (zapomenout) - operace, která odstraňuje prvek z opakování a umisťuje ho na konec fronty čekajících prvků (viz též: vynechat , zapamatovat )

    forgetting index (index zapomínání) - podíl prvků , které si uživatel nezapamatuje při učení (obvykle vyjádřený v procentech). Index zapomínání je možno v SuperMemo naprogramovat mezi 3% a 20%. Tím způsobem může student regulovat rychlost učení na úkor retence a naopak. Implicitní index zapomínání je možno nastavit pomocí Tools (Nástroje) : Options (Volby) : Learning (Učení) : Forgetting index (Index zapomínání) a indexy zapomínání pro jednotlivé prvky pomocí Forgetting index v dialogovém panelu parametry prvku

    full access mode (režim úplného přístupu) - režim funkce SuperMemo, ve kterém jsou dostupné všechny editační možnosti. Ostatní dva režimy jsou jen čtení , ve kterém je možné jen prohlížení souhrnu vědomostí, a jen učení , ve kterém je možno se učit, avšak všechny editační možnosti jsou vypnuty. Chcete-li zapnout režim úplného přístupu: (1) zvolte v hlavní nabídce Tools (Nástroje) : Options (Volby) (nebo stiskněte Ctrl+P) a (2) zvolte Data access (Přístup k datům) : Access mode (Režim přístupu) : Full access (Úplný přístup)

    hierarchy (hierarchie) - stromová struktura, jsou organizovány jednotlivé prvky souhrnu vědomostí SuperMemo. Hierarchie vědomostí je zobrazena v okně obsahu . Kořenový prvek (první prvek) v hierarchii se nazývá hlavní uzel (master node). Jednotlivé uzly stromu mohou mít každý až tisíc dceřinných prvků, avšak z důvodů výkonnosti se doporučuje omezit počet prvků v uzlu nejvýše na sto.

    hierarchy (hierarchie) - větev / uzel / list - viz uzel stromu vědomostí

    hint (popisek) - text umožňující pochopení položky nabídky nebo tlačítka v programu SuperMemo . Popisek se zobrazí, když umístíte kurzor myši na tlačítko nebo nabídku. Popisky se zobrazují, jen když je zaškrtnuto políčko popisků na hlavním nástrojovém panelu . Popisky se zobrazují na stavovém pruhu na spodní straně obrazovky (stavový pruh můžete zobrazit pomocí Window (Okno) : View (Zobrazit): Status bar (Stavový pruh)). Kromě zaškrtávacího políčka popisků můžete popisky zapínat a vypínat také: 1. dvojitým kliknutím na oblast popisku na stavovém pruhu a 2. volbou Window (Okno) : View (Zobrazit): Hints (Popisky)

    hook node (kotevní uzel) - uzel stromu vědomostí , ke kterému se jako dceřinné prvky přidávají nové prvky náležející do určité kategorie . Kotevní uzel je buď totožný s kořenovým uzlem , nebo je jeho dcerou či potomkem . Jakmile se překročí mezní počet dceřinných prvků kotevního uzlu, zvolí se nový kotevní uzel. Nový kotevní uzel bude pochopitelně potomkem kořenového uzlu aktuální kategorie

    hyperlink (hyperpropojení) - spojení vytvořené mezi komponentou a prvkem odlišným od prvku, jemuž komponenta náleží. Hyperpropojení umožňují navigovat v hyperprostoru vědomostí kliknutím na jednotlivé komponenty místo používání příkazů navigačního nástrojového panelu. Hyperpropojení můžete vytvořit pomocí Hyperlink v místní nabídce koponenty . Můžete komponentu také přetáhnout se stisknutou klávesou Ctrl (Ctrl+drag) do schránky hyperpropojení a umístit ji na hyperpropojený prvek

    item (položka) - prvek, který se zúčastňuje opakování a často má tvar otázka - odpověď (viz téma ). Viz též: Témata a položky

    knowledge tree (strom vědomostí) / hierarchie - stromová struktura, v níž jsou organizovány jednotlivé prvky každého souhrnu vědomostí SuperMemo. Strom vědomostí je zobrazen v okně obsahu . Kořenový prvek (první prvek) stromu se nazývá hlavní uzel (master node). Jednotlivé uzly stromu mohou mít až tisíc dceřinných prvků, z důvodů výkonnosti se však doporučuje neumisťovat do jednoho uzlu víc než sto dceřinných prvků. Strom vědomostí se nazývá také hierarchie

    knowledge tree node/branch/leaf (uzel / větev / list stromu vědomostí) - jeden prvek ve stromě vědomostí zobrazený v okně obsahu a odpovídající jednomu tématu nebo položce v souhrnu . Nové uzly můžete přidávat pomocí Add (přidat), Sibling (sestra) a Insert (Vložit) v okně obsahu, nebo pomocí Edit : Add a new item (Přidat novou položku) na hlavní nabídce . V posledním případě se nově přidaný prvek zaplní obsahem implicitní šablony položek . Jestliže prvek obsahuje dceřinné prvky, nazývá se také větev (branch). V okně místní nabídky Obsahu jsou k dispozici některé operace pro celé větve, např. Export as text, Reset, Browse, Count items, atd.

    knowledge system (vědomostní systém, systém vědomostí) - alternativní výraz používaný pro souhrn vědomostí (collection) SuperMemo

    lapse (selhání) - zapomenutí daného prvku . Pod počtem selhání rozumíme, kolikrát byl daný prvek zapomenut, tj. ohodnocen při opakování horší známkou než Dostatečně (3)

    Lapses (Počet selhání) - jeden z parametrů procesu učení , který odráží naměřený index zapomínání , tj.podíl prvků , které jsme si nezapamatovali při opakování (prvky ohodnocené známkou horší než Dostatečně (3) se pokládají za zapomenuté)

    learn-only mode (režim "jen učení") - režim funkce SuperMemo, v němž jsou dostupné pouze volby pro učení. Zbývající dva režimy jsou jen čtení (read-only) , v němž jsou dostupné jen volby pro prohlížení, a úplný přístup , v němž jsou zapnuté všechny volby. Chcete-li zapnout režim jen učení, (1) zvolte v hlavní nabídce Tools (Nástroje) : Options (Volby) (nebo stiskněte Ctrl+P) a (2) zvolte Data access : Access mode : Learn-only (Jen učení). Režim jen učení je užitečný například tehdy, chcete-li rozšířit svůj souhrn mezi skupinu studentů. Tak se budou studenti moci učit z vašeho souhrnu, ale nebudou moci měnit jeho obsah

    leech (nepoddajný prvek) - obzvlášť obtížný prvek , který způsobuje problémy při učení. Definice nepoddajného prvku je specifikována prostřednictvím filtrového dialogového panelu používaného v View (Zobrazit) : Special : Leeches (Nepoddajné prvky)

    level (úroveň) - stupeň složitosti SuperMemo poskytovaný uživatelům různě obeznámeným s programem. Existují tři úrovně s rostoucí složitostí, dostupné z nabídky File (Soubor): Level (Úroveň) . Jsou to: Beginner (Začátečnická), Basic (Základní) a Professional (Profesionální)

    memorized element (probraný prvek) - prvek , který se zúčastňuje procesu učení (tj. je opakován v intervalech nabízených programem SuperMemo ). Z probraného prvku je možno udělat čekající prvek pomocí Forget (Zapomenout) nebo vynechaný prvek pomocí Dismiss (Vynechat)

    memory lapse (selhání paměti) - viz lapse

    minimum information principle (princip minimální informace) - princip efektivního učení říká, že jednoduché prvky formulované pro aktivní vyvolání přinášejí mnohem lepší výsledky v učení než složité prvky, i když jeden složitý prvek může být ekvivalentní velkému počtu jednodušších prvků.

    mnemonic hyperspace (mnemotechnický hyperprostor) - rozšíření koncepce map mysli Tonyho Buzana použitím hyperpropojení mezi komponentami mapy mysli a editovatelností mapy mysli. Mapy mysli jsou pokládány za skvělou formu reprezentace vědomostí pro čely učení. SuperMemo umožňuje vytvářet jednoduché mapy mysli, které obsahují multimediální objekty. Může rovněž využívat mapy mysli generované pomocí MindMan (prostřednictvím místní aktivace OLE )

    ordinal number (ordinální číslo) - číslo přiřazené každému prvku indikující důležitost prvku. Čím nižší je ordinální číslo, tím větší je důležitost. Implicitně se ordinální číslo nastavuje na číslo prvku v aktuálním souhrnu . První prvek, který přidáte, tedy bude mít ordinální číslo 2 (kořen stromu vědomostí dostane ordinální číslo 1), druhý prvek dostane 3 atd. Ordinální čísla jsou užitečná při třídění souhrnu vědomostí nebo jeho podmnožin . Nejdůležitější je, že příkaz File (Soubor) : Reset (Vynulovat): Sort pending by ordinal (Třídit čekající prvky podle ordinálních čísel) seřadí frontu čekajících prvků podle ordinálních čísel a umožňuje tak rozhodovat o pořadí učení nových položek modifikací jejich ordinálních čísel (např. pomocí příkazu Edit element parameters (Editovat parametry prvku) aktivovaného stisknutím Ctrl+Shift+P )

    outstanding element (nevyřízený prvek) - prvek, který čeká na opakování (splňující kritéria optimálního intervalu). Každý prvek v procesu učení programem SuperMemo určeno datum příštího opakování. V tento den nebo později je prvek pokládán za nevyřízený

    outstanding material (nevyřízená látka) - všechny nevyřízené prvky , tj, prvky, jejichž datum příštího opakování je menší nebo rovno dnešnímu datu

    pending element (čekající prvek) - prvek , který čeká na probírání (učení) ve frontě čekajících prvků . Nově přidané prvky jsou umístěny do fronty čekajících prvků. Chcete-li některý prvek umístit na konec fronty čekajících prvků, stiskněte tlačítka zapamatovat a zapomenout (v tomto pořadí)

    pending queue (fronta čekajících prvků) - fronta prvků,které čekají na probrání (učení). Fronta čekajících prvků se modifikuje při používání ovládacích prvků pro učení. Například tlačítko Zapamatovat odstraňuje aktuální prvek z fronty čekajících prvků, kdežto tlačítko Zapomenout posílá probraný prvek zpět na konec fronty čekajících prvků. Fronta čekajících prvků určuje pořadí učení nových prvků

    presentation mode (prezentační režim) - způsob zobrazení komponent tak, jak budou vypadat při prohlížení souhrnu vědomostí. Ostatní dva základní režimy jsou: editační režim (komponenty jsou připraveny pro editaci, např. vymazání textu, atd.) a přetahovací režim (komponenty je možno snadno přetahovat myší)

    primary storage (primární paměť) - místo na pevném disku uživatele, kde je uložen aktuální souhrn. Viz též: sekundární paměť

    programmed component (programovaná komponenta) - komponenta , která může spustit binární soubor napsaný v některém jazyce (DLL nebo EXE). Programované komponenty umožňují rozšířit rozsah aplikací SuperMemo na jakoukoliv představitelnou oblast

    read-only mode (režim jen čtení) - režim funkce SuperMemo, ve kterém je dostupné pouze prohlížení. Ostatní dva režimy jsou jen učení , ve kterém je možné i učení, a úplný přístup , ve kterém jsou zapnuty všechny možnosti. Zapnutí režimu jen čtení: (1) zvolte na hlavní nabídce Tools : Options (nebo stiskněte Ctrl+P ) a (2) zvolte Data access : Access mode : Read-only (Jen čtení). Režim jen čtení se zapne automaticky, jestliže se otevře souhrn vědomostí na CD-ROM. V tom případě nemůžete změnit režim jen čtení na jiný režim

    remember (zapamatovat) - operace, která uvádí prvek do procesu učení (viz: vynechat , zapomenout )

    registry (registr) - setříděná množina pojmenovaných objektů (zvaných člen registru ) které se používají při vytváření prvků v SuperMemo. Objekty uložené v registrech mohou mít formu zvuku, videa, obrazu, spustitelného programu, DLL, fontu, textu, atd. Jednotlivé objekty můžete propojovat s komponentami v prvcích vědomostí pomocí Links (Propojení): Registry member (Člen registru) na místní nabídce komponenty . Po zvolení odpovídajícího jména objektu v registru zvolte Link (Propojit) a objekt se objeví ve vybrané komponentě. Viz též: Registry

    registry index (registrový index) - pořadové číslo daného členu v setříděném pořadí členů registru v daném registru . Například lexikonový registr může začínat slovem Ababa s registrovým indexem1 a končit slovem Zodiac s registrovým indexem 23293. Viz: poloha v registru

    registry member (člen registru) - jeden objekt uložený v daném registru

    registry position (poloha v registru) - číslo odpovídající fyzické poloze daného členu registru v registru . Toto číslo je možno vidět na spodní straně okna registru . Viz: registrový index

    registry subset (podmnožina registru) - množina členů registru uložená v souboru. Podmnožiny registrů se většinou používají ve vyhledávacích operacích. Například můžete použít Ctrl+S k vyhledání všech textů obsahujících slovo virus. Ty se zobrazí jako podmnožina registru v okně textového registru . Můžete znovu použít Ctrl+S k vyhledání slova AIDS a vytvořit tak užší podmnožinu, která bude obsahovat slovo virus i slovo AIDS

    registry window (okno registru) - kterékoliv z několika oken, která zobrazují obsah jednotlivých registrů . Tato okna jsou dostupná na nabídce Search (Vyhledat) (např. Search: Text , Search: Font, Search: File: Image). Viz též: Okno registru

    repetition (opakování) - akt, při kterém je daný prvek procvičován pomocí následujících kroků:

      2. zobrazení otázky (čili podnět)
      4. zodpovězení otázky (čili reakce na podnět)
      6. porovnání odpovědi se správnou odpovědí a oznámkování (sebou samým nebo programem) za reakci na podnět

    Všimněte si, že všechna opakování se uskutečňují v den vybraný programem SuperMemo s použitím algoritmu optimálních intervalů ( Algoritmus SM-8 )

    repetition spacing (optimální intervaly mezi opakováním) - technika optimalizace procesu učení výpočtem optimálních intervalů mezi jednotlivými opakováními jednotlivých vědomostí (nazývaných prvky ). SuperMemo je průkopníkem aplikace optimálních intervalů při učení (poprvé implementováno jako software v roce 1987 ) a získalo světový věhlas díky zvýšené produktivitě učení

    retention (retence) - podíl vědomostí uchovaných v paměti v daném čase. Všimněte si, že retence má větší hodnotu než 100% minus index zapomínání . Index zapomínání odpovídá pravděpodobnosti zapomenutí v okamžiku opakování , kdežto retence odpovídá průměrné pravděpodobnosti vzpomenutí si mezi posledním a příštím opakováním. Přesný vzorec dávající do vztahu index zapomínání a retenci najdete v: Theoretical aspects of SuperMemo

    root node (kořenový uzel) - uzel stromu vědomostí , do kterého se přidávají všechny prvky náležející do dané kategorie . Například uzel s názvem Chemie může být kořenovým uzlem všech prvků týkajících se chemie.

    secondary storage (sekundární paměť) - místo, kde jsou uloženy některé soubory souhrnu vědomostí (obvykle největší a nejméně se měnící soubory). Například u velmi velkých souhrnů je možno uchovávat multimediální soubory na CD-ROM (sekundární paměť), kdežto všechny často používané nebo modifikované soubory jsou uloženy na pevném disku ( primární paměť ). Když vytvoříte nový souhrn, primární paměť je totožná se sekundární pamětí. Pomocí File : Organize : Semi-copy můžete okopírovat svůj souhrn do nové primární paměti a ponechat největší soubory na původním místě (sekundární paměti). Sekundární paměť je možno prohlížet nebo modifikovat pomocí Tools : Options : Data access : Secondary storage

    sibling (sestra) (v okně obsahu ) - prvek , který je umístěn na téže úrovni jako daný prvek

    subset (podmnožina) - (1) podmnožina prvků : množina prvků uložených v souboru nebo (2) podmnožina registru : množina členů registru uložená v souboru. Podmnožinu prvků můžete vytvořit pomocí prohlížeče prvků (např. Subset (Podmnožina) : Save all (Uložit vše) nebo Subset : Save selection (Uložit výběr)). Podmnožinu prvků si můžete prohlížet pomocí View (Zobrazit) : Subset (Podmnožinu). Podmnožiny registrů se většinou používají v operacích vyhledávání. Například můžete použít Ctrl+S k vyhledání všech texů obsahujících slovo virus. Ty se zobrazí jako podmnožina registru v okně textového registru . Můžete pak použít Ctrl+S znovu pro vyhledání slova AIDS a vytvořit tak užší podmnožinu, která bude obsahovat jak slovo virus, tak slovo AIDS

    SuperMemo - (1) metoda rychlého učení založená na výpočtu optimálních intervalů mezi opakováním ; (2) počítačový program implementující [1] (viz obrázek na konci tohoto souboru)

    template (šablona) - opakovaně použitelná definice vzhledu prvku . Může definovat typ a atributy jednotlivých komponent, např. velikost, barvu, písmo, obrazové soubory, azarovnání, atd. Všechny šablony použité v daném souhrnu vědomostí jsou uchovávány v šablonovém registru . Viz též: Šablony

    topic (téma) - prvek, který se nezúčasňuje opakování a používá se pro zobrazení shrnujícího přehledu vědomostí obsažených v prvcích zvaných položky . Zvolíte-li Učit se (Learn) , témata budou předkládána před učením příslušných položek a vynechána ihned při prvním opakování. V optimálním případě uvádějí témata studujícího do studovaných vědomostí poskytnutím syntetického přehledu. Student si později udržuje vědomosti v paměti jenopakováním položek. V dobře strukturovaném souhrnu jsou témata vždy mateřskými prvky položek, ve kterých jsou vědomosti rozčleněny do menších kousků. Když student ztrácí během opakování souvislost, může si stisknutím Ctrl+Alt+Up zobrazit mateřský prvek aktuální položky. Tak je možno rychle prohlížet shrnující látku v tématu. Viz též: Témata a položky

    Hlavní obrazovka SuperMemo 98 ( Profesionální úroveň )

    ****


Úvod do SuperMemo

ABC Rady a tipy Přehledy Popis Slovník pojmů Podpora
Obsah : ABC
Abeceda SuperMemo 98

SuperMemo vám pomůže učit se rychleji!

Pro učení vám stačí pouze dvě operace:

  • Add new (Přidat nový prvek) - přidávat novou látku do SuperMemo (klávesnice: Ctrl+A)
  • Learn (Učit se) - učit se sebranou novou látku (klávesnice: Ctrl+L)

Abeceda SuperMemo je:

  • Abyste rozšiřovali své znalosti, přidávejte novou látku pomocí Add new (Přidat nový prvek) (Ctrl+A)
  • Buďte důslední v každodenním učení pomocí Learn (Učit se) (Ctrl+L)
  • Chovejte lásku k vědění (tj. mějte radost z učení)

Míříte-li vysoko, můžete si přečíst také Desatero SuperMemo nebo zbytek tohoto souboru nápovědy.


Stažení nápovědy

Obsah : Nápověda
Stažení nápovědy pro SuperMemo 98

Nápovědu k SuperMemo 98 si můžete stáhnout jako jeden soubor SMCZHELP.CHM . Ten umístěte do podadresáře sm98/bin. Nápovědu v SuperMemo pak vyvoláte např. stisknutím F1 nebo F2.

Úsporná verze nápovědy: Adresář se všemi soubory české nápovědy ve formátu html bez obrázků si můžete stáhnout jako samorozbalovací soubor SM98CZHL.EXE .

Časté otázky

(Peter Cool, The Netherlands, Nov 9, 1998)
Otázka:
Nainstaloval jsem si nápovědu pro SuperMemo 98, avšak nefunguje. Po instalaci souboru nápovědy a hhupd.exe uvidím po vyvolání nápovědy krátce "přesýpací hodiny". Pak již se nic neděje.
Odpověď:
Musíte si nainstalovat prohlížeč HTML (hhupd.exe) přes Internet Explorer 3.0. Formát CHM byl vyvinut firmou Microsoft a vyžaduje, aby na vašem počítači byl nainstalován Internet Explorer. Microsoft bohužel neumožňuje instalaci podmnožiny.

****


Nabídka Nápověda

Nápověda (Help)

Help (Nápověda ) na hlavní nabídce poskytuje následující volby:

  • Welcome (Vítejte) - otevřít soubor nápovědy, který právě čtete. Začněte s úvodní stránkou
  • Contents (Obsah) (F1) - otevřít soubor nápovědy počínaje stránkou vztahující se k danému kontextu nebo, není-li žádný kontext definován, počínaje obsahem. Například jste-li v okně obsahu , stisknutím F1 se otevře stránka okna obsahu
  • FAQ - otevřít soubor nápovědy počínaje nejčastějšími otázkami o SuperMemo
  • (jen v lokalizovaných verzích) Nápověda (F2) - soubor nápovědy v místním jazyce (např. polsky, česky, holandsky, atd.)
  • Hints and tips (Rady a tipy) - otevřít soubor nápovědy počínaje nejužitečnějšími radami a tipy
  • Internet update (Aktualizace z Internetu) - otevřít tuto nápovědu přímo z internetové stránky SuperMemo. Tuto volbu můžete použít, nemůžete-li najít některé informace a doufáte, že aktualizovaná verze nápovědy vám lépe pomůže.
  • Question of the Day (Otázka dne) - ekvivalent tipu dne u jiných programů. V SuperMemo jsou tipy formulovány jako jednoduché otázky a odpovědi. Rozhodnete-li se zavést některé tipy do procesu učení, klikněte prostě na tlačítko Remember (Zapamatovat) na dialogovém panelu Question of the Day. Myslíte-li si,že tip nestojí za učení, klikněte na Dismiss (Vynechat). Všimněte si, že tipy v SuperMemo jsou "minimetafory" pro vzor položek SuperMemo!
  • Support (Podpora) - získat podporu prostřednictvím Internetu (viz též: Technická podpora )
    • SuperMemo website (Internetové stránky SuperMemo) (- připojit se na vybrané části internetových stránek SuperMemo Website: FAQ , Novinky , Knihovna SuperMemo atd.
    • Send E-mail (Poslat elektronickou poštu) - poslat e-mail výrobci, distributorovi pro Českou republiku ap.
    • Your feedback (Zpětná vazba) - vyplnit a e-mailem poslat uživatelský dotazník.
      Address
      • Reseller (Prodejce) - zobrazit název firmy , adresu, telefon, fax, e-mailovou adresu, URL a registrační e-mailovou adresu místního prodejce
      • Developer (Vyvinuto) - zobrazit adresu SuperMemo World , telefony, website a e-mail
  • About (O produktu) - dialogový panel s datem vydání a verzí (jestliže jste stáhli SuperMemo z internetové stránky místního prodejce, najdete zde i jeho adresu a informace o technické podpoře ve svém rodném jazyce)

Pokud soubor nápovědy smhelp.chm není přítomen v podadresáři bin , SuperMemo se pokusí otevřít aktuální nápovědu na internetové stránce SuperMemo .

Důležité! Vždy můžete použít zkompilovaný obsah internetové stránky SuperMemo Website pro aktualizaci svého souboru nápovědy. K tomu účelu proveďte následující kroky:

  1. Přejděte na stránku stahování nápovědy
  2. Stáhněte si aktuální soubor smczhelp.chm.
  3. Okopírujte tento soubor do adresáře bin . Po jeho umístění do podadresáře bin spustíte českou nápovědu pomocí F2 (nebo z nabídky Help).

Jestliže SuperMemo nemůže najít soubor smczhelp.chm, pokusí se spojit s odpovídající stránkou na www.supermemo.cz/help/ na webové stránce SuperMemo.

****


Rady a tipy

Obsah : Rady a tipy
Rady a tipy pro uživatele SuperMemo

Začátečnická úroveň

  1. Chcete-li do SuperMemo přidat nový prvek , stiskněte Ctrl+A a napište text otázky a odpovědi
  2. Chcete-li se učit, stiskněte Ctrl+L nebo klikněte myší na tlačítko Učit se na spodní straně obrazovky
  3. Chcete-li přejít na základní úroveň, zvolte Soubor (File) : Úroveň (Level) : Základní (Basic)

Základní úroveň

  1. Chcete-li se naučit jen právě zobrazený prvek , stiskněte Ctrl+M nebo klikněte na tlačítko Zapamatovat (Remember) na spodní straně obrazovky. Všimněte si, že stisknutí Ctrl+M během opakování je ekvivalentní novému probírání prvku, tj. prvek se začne opakovat znovu od krátkých intervalů. Tuto volbu byste měli použít, že položku editujete, čímž se zvýší pravděpodobnost, že si ji nebudete při příštím opakování pamatovat.
  2. Chcete-li přemístit prvek na konec fronty prvků čekajících na probírání (učení), stiskněte tlačítko Zapomenout (Forget) (během opakování , kdy tlačítko není viditelné, můžete provést totéž stisknutím Ctrl+R)
  3. Chcete-li některý prvek odstranit z procesu učení čili ignorovat jej při opakování a učení nových položek, zvolte tlačítko Vynechat (Dismiss) . Tím se prvek stane v procesu učení neviditelný, ale stále bude dostupný pro prohlížení, vyhledávání, atd. (během opakování, kdy tlačítko není viditelné, můžete dosáhnout téhož stisknutím Ctrl+I).
  4. Chcete-li prvek úplně odstranit, stiskněte Ctrl+Shift+Del. Tím se prvek trvale odstraní ze systému (souhrnu)
  5. Chcete-li vyhledat všechny prvky obsahující daný podřetězec znaků, stiskněte Ctrl+F, napište podřetězec a stiskněte Enter
  6. Chcete-li editovat text v dříve zavedených prvcích, vyhledejte prvek, klikněte na text a upravte jej pomocí editačních kláves
  7. Chcete-li se učit jen látku patřící do vybrané větve v okně obsahu , zvolte tuto větev a klikněte na tlačítko Prohlížet (Review) (na spodní straně okna obsahu)
  8. Máte-li podezření, že některý soubor vašeho souhrnu vědomostí je poškozen, stiskněte Ctrl+F12 a proveďte rychlou kontrolu integrity všech nejdůležitějších souborů
  9. Chcete-li využívat všech možností SuperMemo, můžete zvolit Soubor (File ): Úroveň (Level) : Profesionální nebo stisknout Ctrl+Alt+F12 . Pokud nepoužíváte obrazovku s nízkou rozlišovací schopností, doporučujeme vám tento režim, protože vám poskytuje spoustu nástrojů, které vám pomohou rozumět procesu učení.

Profesionální úroveň

  1. Chcete-li se podívat na kalendář opakování, stiskněte Ctrl+W nebo zvolte Tools (Nástroje) : Workload (Zátěž)
  2. Statistika při učení se automaticky zapne, zvolíte-li Tools (Nástroje) : Options (Volby) : Learning (Učení) a zatrhnete Classic layout at learning (Klasické rozložení při učení)
  3. Dáváte-li přednost klávesnici před myší, přečtěte si o klávesových zkratkách
  4. Jestliže jste měli delší přestávku v učení, použijte Tools (Nástroje) : Mercy (Milost) . Nezapomeňte si přečíst Kritéria funkce Milost !
  5. Chcete-li najít nejobtížnější nebo špatně strukturované prvky, použijte View (Zobrazit) : Special : Leeches (Nepoddajné položky) . To je pro rychlé učení velmi důležité!
  6. Stavový pruh se zapíná a vypíná zatržením nebo zrušením zatržení ve Window (Okno) : View (Zobrazit): Status bar (Stavový pruh) . Totéž platí pro nástrojový panel, urychlovací panel (speedbar) a popisky zobrazované při umístění kurzoru myši na tlačítku nebo nabídce
  7. Pokud se vám nelíbí rozložení oken, uspořádejte je tak, jak si přejete, a zvolte Window (Okno) : Layout (Rozložení): Save as default (Uložit jako implicitní) nebo prostě stiskněte Ctrl+Shift+F5
  8. Chcete-li provést náhodný test na uzlu v okně obsahu , vyberte uzel a zvolte Random test v místní nabídce obsahu (dostupné například po kliknutí pravým tlačítkem myši). Pro probrání položek, které se zdají zajímavé, použijte Ctrl+R
  9. Chcete-li změnit vzhled svých položek, přečtěte si o šablonách
  10. Chcete-li pokročit dál a nespokojujete se jen s prostými otázkami a odpověďmi, můžete zkusit vytvářet výběrové testy (výběr z několika možností), ukazovací testy (ukázání myší na správnou odpověď), atd. Více o tom najdete v Tvoření testovacích prvků .

****


HTML

Komponenta HTML

If you would like to display HTML files in SuperMemo or write your our HTML code, include an HTML component available from the Compose tab at the top of the element window . Note, however, that HTML components need shdocvw.dll library installed in Windows (if you have Internet Explorer installed, you have this library in place).

To add an HTML component, click three points:

  1. HTML button on the Compose tab
  2. Top-left corner of the area you want your HTML file displayed (in the element window )
  3. Bottom-right corner of the area you want your HTML file displayed

The HTML component will show as a rectangle with an edit area inside.

If you want to import a ready HTML file, right-click the HTML editor, and choose Import file. Pick the file in the dialog box and choose OK. Your HTML file will be displayed in the HTML component.

After creating an HTML component, you can also start typing in your HTML code. For simplicity, in SuperMemo you do not need to use tags such as html, head, title, body, etc. You can begin HTML coding from scratch with simple tags such as <b> (bold font), <i> (italics), <hr> (horizontal line), etc. Naturally, you can use the entire spectrum of tags available to modern HTML browsers. When you are finished with coding, type Esc to see the results of your work.

If you would rather write your HTML text in your favorite HTML editor, press F9 (or choose Edit : Edit file from the HTML component pop-up menu ) and your HTML code will open in the HTML editor registered for editing HTML files in Windows.

Please note that the pop-up menu in the HTML component is mode sensitive, i.e. it will display Internet browsing options in presentation modes (and in learning modes) and editing options in editing and dragging modes . In presentation mode you will be able to use options such as Add to favorites, Print, etc. In editing mode you will be able to use options such as Insert link, Import file, Edit file, etc.

The simplest way to switch between presentation and editing modes is to choose one of the following:

  • Alt+click over the element display area
  • press Ctrl+T until you reach the HTML component
  • click the Editing mode button (blue-notebook) on the Edit tab

Professional level

If you want to insert hyperlinks to other elements, registry texts, HTML files, URL addresses on the Internet, registry images, etc. read about the option Insert HTML link on the HTML component pop-up menu .

The HTML component can interpret JavaScript. If you know some JavaScript commands, you can enhance your SuperMemo presentation with scripted HTML components.

***


HTML link

Komponenta: Vložit propojení HTML

Insert HTML link (Vložit propojení (odkaz) HTML) se objevuje na místní nabídce komponenty HTML . Místní nabídka komponenty HTML se otevře kliknutím pravým tlačítkem na komponentu HTML. Místní nabídku můžete otevřít také stisknutím Ctrl+Alt+F10 , pokud je komponenta HTML aktuální komponentou. Aktuální komponenty můžete přepínat pomocí Ctrl+T .

Podnabídka Insert HTML link (Vložit propojení HTML) může být použita pro vkládání různých hyperpropojení do zdrojového kódu HTML. Tato hyperpropojení zahrnují ta, která jsou normálně interpretována webovými prohlížeči. Taková propojení jsou pro SuperMemo specifická a umožňují propojování na jiné prvky a členy registrů , např. text, soubory HTML a obrazy.

Aby bylo možno vložit odkaz (hyperpropojení), komponenta HTML musí být v editačním režimu , tj. její zdrojový kód HTML musí být dostupný pro editaci.

Podnabídka Insert HTML link na místní nabídce komponenty obsahuje následující volby:

  • Element (Prvek) - vložit hyperpropojení na jiný prvek v systému vědomostí . Než zvolíte Insert HTML link: Element, vyberte text, který hodláte propojit. Když tuto volbu provedete, SuperMemo otevře okno obsahu a požádá vás o zvolení prvku, na který se má provést propojení. Jakmile tento prvek vyberete, klikněte na tlačítko Choose (Zvolit) na spodním okraji okna obsahu. Když přepnete zpět do prezentačního režimu (např. pomocí Esc), vaše komponenta HTML zobrazí hyperpropojení. Když na toto hyperpropojení kliknete, SuperMemo zobrazí propojený prvek v okně prvku . Na předchozí prvek se vrátíte kliknutím na < na navigačním nástrojovém panelu (nebo stisknutím Alt+B )
  • Text registry (Textový registr) - vložit hyperpropojení na jiný text v textovém registru . Než zvolíte Insert HTML link: Text registry, vyberte text, který chcete propojit hyperpropojením. Když tuto volbu provedete, SuperMemo otevře textový registr a požádá vás o výběr textu, na nějž je směřováno propojení. Jakmile text vyberete, klikněte na tlačítko Link (Propojit) na spodním okraji okna textového registru. Když přepnete zpět do prezentačního režimu (např. stisknutím Esc), vaše komponenta HTML zobrazí hyperpropojení. Když na toto hyperpropojení kliknete, SuperMemo zavede propojený text do komponenty HTML (všimněte si, že kliknutím na hyperpropojení k prvku se zamění zobrazený prvek, kdežto textové hyperpropojení jen změní text v komponentě HTML). Na předtím zobrazený text se vrátíte kliknutím na Back (Zpět) na místní nabídce komponenty HTML. Všimněte si, že nabídka HTML v prezentačním režimu je typická nabídka, kterou najdete v internetových prohlížečích. Protože kliknutím na hyperpropojení se nezmění prvek, Back by se mělo používat k opětovnému načtení předchozího kódu HTML (V případě propojování prvků byste místo toho použili tlačítko < na navigačním nástrojovém panelu)
  • HTML file (Soubor HTML) - vložit hyperpropojení na samostatný soubor HTML. Než zvolíte Insert HTML link: HTML file, vyberte text,který má být propojen. Když volbu provedete, SuperMemo otevře dialogový panel pro výběr souboru a požádá vás o vybrání souboru HTML na vašem pevném disku nebo na síťovém disku. Jakmile soubor vyberete, klikněte na tlačítko Open (Otevřít). Když přepnete zpět do prezentačního režimu (např. stisknutím Esc), vaše komponenta HTML zobrazí hyperpropojení. Kliknete-li na toto hyperpropojení, SuperMemo načte propojený soubor do vaší komponenty HTML (všimněte si, že kliknutím na hyperpropojení prvku se zamění zobrazený prvek, kdežto hyperpropojení na soubor pouze změní soubor zobrazený komponentou HTML). Na předtím zobrazený text přejdete kliknutím na Back (Zpět) na místní nabídce komponenty HTML
  • Web address (Webová adresa) - vložit hyperpropojení na soubor dostupný na Internetu (www). Než zvolíte Insert HTML link: Web address, vyberte text, který chcete propojit. Když tuto volbu provedete, SuperMemo otevře dialogový panel a požádá vás o napsání internetové adresy (URL). Když přepnete zpět do prezentačního režimu (např. stisknutím Esc), vaše komponenta HTML zobrazí hyperpropojení. Kliknete-li na toto hyperpropojení, SuperMemo načte propojený soubor z Internetu (jen když máte on-line spojení na Internet nebo když byl požadovaný soubor uložen vaším webovým prohlížečem). Na předtím zobrazený text se vrátíte zvolením Back na místní nabídce komponenty HTML
  • Registry image (Registrový obraz) - vložit obraz z obrazového registru . Když provedete tuto volbu, SuperMemo otevře obrazový registr a požádá vás o vybrání obrazu, který chcete propojit (podporované formáty: BMP, GIF a JPG). Jakmile obraz vyberete, klikněte na tlačítko Link (Propojit) na spodním okraji okna obrazového registru. Když přepnete zpět do prezentačního režimu (např. stisknutím Esc), vaše komponenta HTML zobrazí obraz vložený do vašeho kódu HTML.

****


Obsah

Obsah nápovědy pro SuperMemo 98
  • První kroky se SuperMemo
    • Abeceda SuperMemo 98
    • Minimální požadavky
    • Co je nového v SuperMemo 98
    • Instalace
    • Rady a tipy : Jak pracovat se SuperMemo 98
    • Desatero SuperMemo
    • Stažení nápovědy k SuperMemo 98
  • Přehledy
  • Rychlé odpovědi a odstraňování závad
    • Otázka dne
    • Časté otázky a odpovědi
      • Otázky týkající se SuperMemo 98
      • Otázky týkající se paměti a mnemotechniky
    • Technická podpora
  • Popisy nabídek, tlačítek, oken a dialogových panelů
  • Teoretické základy SuperMemo
  • Historie
  • Slovník pojmů
  • Odkazy na literaturu

***


Installing SuperMemo (for dummies)

Instalace SuperMemo pro začátečníky

Níže jsou uvedeny pokyny pro instalaci SuperMemo a jeho různých komponent na váš počítač. Znáte-li základy používání Windows, např. kopírování souborů, tvoření adresářů, atd., můžete vynechat modré rámečky.

Důležité! Stáhněte všechny komponenty vždy do téhož adresáře, např. sm98, a spusťte stažené soubory EXE. Tím se vytvoří všechny potřebné soubory a umístí se na patřičná místa.

Tento text popisuje následující postupy:

  1. Instalace SuperMemo
  2. Zadání hesla
  3. Instalace nápovědy
  4. Instalace vědomostních systémů stažených z knihovny SuperMemo
  5. Instalace SuperMemo 98 na nainstalované SuperMemo 8
  6. Instalace SuperMemo 98 na Advanced English
  7. Kde je mé SuperMemo?

Viz též: Časté otázky a odpovědi

Instalace SuperMemo 98

  1. Vytvořte ve svém počítači nový adresář, do něhož budou uloženy všechny soubory používané SuperMemo. Například vytvořte na svém pevném disku C: adresář c:\sm98.
    Adresář c:\sm98 můžete ve Windows vytvořit takto:
    1. Dvakrát klikněte na ikonu Tento počítač na pracovní ploše
    2. Dvakrát klikněte na ikonu označenou (C:)
    3. Zvolte v nabídce Soubor: Nový: Složka (vytvoří se nová složka připravená k novému pojmenování)
    4. Napište SM98, aby se nahradilo implicitní jméno Nová složka.
    5. Jestliže počítač odpoví Nelze přejmenovat ..., pak již složka c:\sm98 existuje.
  2. Stáhněte si SuperMemo 98 z www.supermemo.cz
    Stažení SuperMemo 98:
    1. Přejděte na stránku Stáhněte si
    2. Klikněte na sm98czip.exe
    3. Když se vás prohlížeč zeptá, zda chcete soubor Otevřít nebo Uložit na disk, zvolte Uložit na disk.
    4. Na dialogovém panelu uložení zadejte dříve založený adresář (ve vašem případě c:\sm98), nebo prostě napište cestu pro uložení, např. c:\sm98\sm98czip.exe
  3. Spusťte soubor sm98czip.exe, např. dvojím kliknutím na jeho ikonu ve Windows. Tím se vytvoří soubor sm98cz.exe, což je vlastní program SuperMemo.
    Spuštění instalačního souboru SuperMemo staženého z Internetu:
    1. Klikněte na tlačíto Start
    2. Zvolte Spustit
    3. Napište jméno souboru. Ve vašem případě to je: c:\sm98\sm98czip.exe
  4. Přidejte ikonu SuperMemo na pracovní plochu (nebo do složky podle vašeho výběru) zadáním cesty k sm98cz.exe
    Umístění ikony na pracovní plochu:
    1. Minimalizujte nebo zavřete všechny aplikace (např. můžete kliknout pravým tlačítkem na spodní lištu a zvolit Minimalizovat všechna okna)
    2. Klikněte pravým tlačítkem na oblast pracovní plochy (nebo do cílové složky)
    3. Zvolte Nový objekt : Zástupce (Windows vytvoří na pracovní ploše novou ikonu nadepsanou Nový zástupce a otevře dialogový panel s několika dotazy)
    4. Vyplňte příkazový řádek. Ve vašem případě to bude c:\sm98\sm98cz.exe. Pokud jste stáhli SuperMemo do jiného adresáře, cesta se může lišit. Například jestliže jste stáhli sm98czip.exe do d:\supermemo, váš příkazový řádek bude vypydat d:\supermemo\sm98cz.exe.
    5. Klikněte na tlačítko Další v dialogovém panelu Vytvořit zástupce.
    6. Do pole Zadejte název pro zástupce napište vámi zvolený název. Například napište SuperMemo (potom se vaše ikona bude jmenovat SuperMemo)
    7. Klikněte na tlačítko Dokončit (všimněte si, že na vaší pracovní ploše se vytvořila nová ikona se zvoleným názvem)

    Od nynějška můžete SuperMemo spouštět dvojím kliknutím na tuto ikonu.

    Jiná metoda vytvoření ikony je popsána v odstavci Kde je mé SuperMemo?

  5. Spusťte SuperMemo dvojím kliknutím na ikonu vytvořenou v předešlém kroku. Své dobrodružství s rychlým učením zahajte přečtením Abeceda SuperMemo . Doporučujeme vám také, abyste si stáhli Soubory nápovědy pro SuperMemo
  6. Stažené SuperMemo 98 budete moci po nějakou dobu volně používat. Po spotřebování tzv. kreditu bude nutné, abyste se zaregistrovali a uhradili licenční poplatek (viz Ceník ). Přejděte na stránku Objednávka , vyplňte formulář a odešlete na e-mailovou adresu sales@supermemo.cz . Obratem vám pošleme pokyny k uhrazení licenčního poplatku. Po jeho obdržení vám e-mailem pošleme vaše registrační heslo a pokyny k zadání hesla.
  7. Nevíte-li si s něčím rady, obraťte se prosím s dotazem na faq@supermemo.cz . Nebojte se klást otázky, díky nim můžeme zlepšit naši podporu v budoucnu.

Zadání hesla

SuperMemo 98 je chráněno heslem. Bez hesla může běžet jen omezenou dobu. Abyste lépe pochopili důvody, proč jsme heslo zavedli, přečtěte si Registrace SuperMemo . Během jednoho dne od uhrazení částky za licenci pro program vám elektronickou poštou pošleme heslo a další pokyny. Nemusíte mít obavy, že heslo ztratíte. Jakmile je jednou do programu SuperMemo zadáte, už je pravděpodobně nebudtete potřebovat. Jestliže je ztratíte, můžete je od nás znovu dostat, napíšete-li na sales@supermemo.cz . Heslo se zadává pomocí nabídky File : Registration : Input password. Jinak můžete SuperMemo používat několik dní, v určitém okamžiku vás požádá o zadání hesla.

Instalace nápovědy

Nápověda SuperMemo (Help) poskytuje podrobné pokyny pro pužívání SuperMemo a a řadu užitečných přehledů. Nápovědu k SuperMemo můžete používat buď "on-line" na www.supermemo.cz/help nebo (anglicky) na www.supermemo.com/help , nebo si můžete stáhnout soubor (max. 2 MB), který umožňuje prohlížet nápovědu "off-line".

Stažení nápovědy:

  1. Přejděte na stránku Stáhněte si
  2. Stáhněte soubor nápovědy smczhelp.chma uložte jej do podadresáře bin adresáře SuperMemo (např. jako c:\sm98\bin\smczhelp.chm)
  3. Podobně můžete stáhnout anglickou nápovědu (je o něco rozsáhlejší) z www.supermemo.com (postupujte podle pokynů).
  4. Spusťte SuperMemo 98.
  5. Nápovědu otevřete stisknutím F2 (česká nápověda) nebo F1 (anglická nápověda).

Instalace vědomostních systémů stažených z knihovny SuperMemo

  1. Pokud dosud nemáte nainstalované SuperMemo, začněte s Instalací SuperMemo 98
  2. Stáhněte si systémy vědomostí, které si chcete nainstalovat, z Knihovny SuperMemo nebo z SuperMemo Library ).
  3. Spusťte stažený soubor, např. dvojitým kliknutím na jeho ikonu ve Windows. (Někdy bude nutné zadat heslo.) Vytvoří se všechny soubory systému vědomostí uložené do podadresáře systems v adresáři SuperMemo (c:\sm98\systems\). Pamatujte, že stažený soubor musí být v adresáři SuperMemo!

    Poznámka: Stáhnete-li si Japanese, podívejte se prosím sem .

    Příklad postupu pro stažení a instalaci vědomostního systému z Knihovny SuperMemo:
    1. Přejděte na stránku Knihovna SuperMemo.
    2. Klikněte na vybraný vědomostní systém.
    3. Stáhněte jej na svůj počítač.
    4. Klikněte na Objednávka napište název věd. systému, který objednáváte atd. a odešlete nám e-mail. Popřípadě použijte jiný prostředek ( telefon, pošta ).
    5. Pošleme vám pokyny pro úhradu licenčního poplatku.
    6. Po uhrazení vám obratem pošleme heslo, popřípadě fakturu (sdělíte-li nám adresu firmy, IČO a DIČ).
    7. Spusťte stažený soubor a zadejte heslo.
    8. Vzniklý adresář s vědomostním systémem umístěte do podadresáře systems.
    9. Spusťte SuperMemo a otevřte nový vědomostní systém pomocí nabídky Soubor (File).

    Příklad postupu pro stažení a instalaci vědomostního systému Medical Biology ze SuperMemo Library:

    1. Go to SuperMemo Library page at SuperMemo Store
    2. Click Medical Biology
    3. Click Order
    4. Fill out the order form
    5. Click Place a secure order
    6. Click the download icon
    7. Choose Save when your browsers asks you if you want to Open or Save the file
    8. In the File Save dialog box point to the SuperMemo directory (c:\sm98 by default), or simply type the path to which to save, e.g. c:\sm98\medbiol.exe
    9. Run the downloaded file (e.g. click Start, click Run and type in the name of the file such as c:\sm98\medbiol.exe). This will create Medical Biology files in the directory systems (e.g. c:\sm98\systems\medbiol.kno, etc.)
    10. Run SuperMemo (e.g. by double clicking its icon created earlier )
    11. Choose File : Open in SuperMemo
    12. Choose the file medbiol.kno
    13. Choose the button Learn in SuperMemo to start learning

Instalace SuperMemo 98 do dřívějších instalací

Dále je popsán postup instalace SuperMemo 98 do již existujících instalací, například SuperMemo 8 z Advanced English ap.

  1. Stáhněte si SuperMemo 98 a uložte stažený soubor sm98czip.exe do adresáře SuperMemo 8 (obvykle c:\sm8)
  2. Spusťte soubor sm98czip.exe, např. dvojím kliknutím ve Windows. Vytvoří se soubor sm98cz.exe, což je vlastní program SuperMemo 98 v počeštěné verzi.
  3. Přejmenujte soubor sm8.exe na sm8.old, aby bylo zajištěno, že omylem nespustíte SuperMemo 8.
  4. Přejmenujte soubor sm98cz.exe na sm8.exe. Tím se v podstatě nahradí stará verze SuperMemo novou.
  5. Jakmile otevřete svůj vědomostní systém v SuperMemo 98, automaticky se upgraduje. Jen rozměry oken se mohou mírně změnit. Velikost oken můžete pozměnit a uložit nové rozložení pomocí Ctrl+Shift+F5.

Kde je mé SuperMemo?

Pokud si nejste jisti, kde je SuperMemo umístěno ve vašem počítači, můžete je najít pomocí Windows:
  1. Klikněte na Start
  2. Klikněte na Najít
  3. Klikněte na Soubory či složky
  4. Napište jméno souboru do pole Název s použitím následujících voleb:
    • sm98cz.exe - hledáte-li SuperMemo 98
    • sm8.exe - hledáte-li SuperMemo 8
    • sm98czip.exe - hledáte-li umístění instalačního souboru SuperMemo 98 staženého z Internetu
    • smhelp.chm - hledáte-li nápovědu SuperMemo
    • helpczip.exe - hledáte-li instalační soubor pro nápovědu SuperMemo stažený z Internetu.
  5. Všechna umístění hledaného souboru se zobrazí ve sloupci ve složce
  6. Soubory ve sloupci název můžete spustit dvojím kliknutím. Můžete je také přetáhnout na pracovní plochu Windows a vytvořit novou ikonu. Například přetáhnete-li soubory s názvem sm98cz, vytvoříte novou ikonu SuperMemo 98.

Časté otázky

(Peter Cool, the Netherlands, Oct 31, 1998)
Otázka:
Při pokusu o instalaci SuperMemo 98 jsem dostal následující dvě hlášení:

  1. Cannot find sm8.ini (Okopíroval jsem sm98.exe do svého hlavního adresáře SuperMemo 8)
  2. This control requires version 4.7 or greater of comctl32.dll

Odpověď:
Problémy spočívají ve vaší knihovně comctl32.dll ve Windows. Staré instalace Windows 95 mohou obsahovat dřívější verzi této knihovny. Použijte prosím URL uvedené níže pro stažení a bezplatný update (asi 500K; ver. 4.72). To vám nejen dovolí spustit SuperMemo, ale zlepší to také stabilitu jiných aplikací W95 a NT.

http://acadiacom.softseek.com/Programming/DLLs_and_Libraries/Review2_16871_index.html

(Natalie Burgess, USA, Nov 10, 1998)
Otázka:
Používám souhrn Japanese mix, ale nezobrazují se mi japonské znaky, nýbrž anglické znaky. Okopírovala jsem fonty zvané hiragana.ttf a katakana.ttf ze složek sm98\systems\... do své složky d:\Windows\Fonts. Je ještě něco jiného, co musím udělat, abych měla tyto fonty dostupné ve Windows 95?
Odpověď:
Ano. Místo kopírování fontů jste je měla nainstalovat. Ve Windows 95 použijte Control panel (Ovládací panel): Fonts (Písma): Install New Font (Nainstalovat nový font). Na panelu Složky zvolte umístění, kde je možno váš font TTF najít (sm98\systems\...)


Instalace SuperMemo

Obsah :
Instalace SuperMemo z Internetu
  1. Stáhněte soubor sm98czip.exe
  2. Spusťte stažený soubor (sm98czip.exe)
  3. Spusťte soubor sm98.exe (vytvořený v předchozím kroku rozbalením sm98czip.exe)

Jste-li začátečník, přečtěte si prosím Instalace SuperMemo pro začátečníky . Zde najdete tři postupy rozepsané do jednotlivých kroků - pro stahování souborů, kopírování souborů a instalci studované látky, a také upgradování dřívějších verzí SuperMemo.

***


Jazyk

Options (Volby): Language (Jazyk)

Karta Language (Jazyk) v Tools (Nástroje) : Options (Volby) nabízí volby, které pomáhají mezinárodním uživatelům používat daný systém vědomostí :

  • Program - toto pole je pouze informační. Zobrazuje jazykovou verzi SuperMemo. Uživatel je nemůže měnit.
  • Collection translation (Překlad systému vědomostí) - umožňuje vybrat jazyk, do něhož bude systém vědomostí překládán. Existují-li registrové soubory s příslušným překladem, budete moci vidět překlad jednotlivých textů pomocí Shift+klik (kliknutí levým tlačítkem myši při stisknuté klávese Shift) (všimněte si, že přeložit je možno jen textové komponenty, tj. nikoliv texty typu Spell-Pad, RTF nebo HTML). Pokud takové soubory neexistují, budou vytvořeny a uživatel bude moci začít překládat svůj systém vědomostí (např. pomocí Shift+klik, po němž se v tomto případě zobrazí prázdné pole překladu, které je možno vyplnit). Pomocí tlačítka Delete (Vymazat) je možno vymazat právě používaný překladový registr. Viz též: Překládání systémů vědomostí do jiných jazyků
  • Translation font (Písmo překladu) - zvolit písmo, které se bude používat pro zobrazení textů překladů
  • Translate sounds on mouse move (Přeložit zvuky při pohybu myši) - je-li zatrženo toto pole a používá se okamžitý překlad ( Tools (Nástroje) : Options (Volby) : Mouse (Myš) : Translation (Překlad) : On mouse move (Při přesunu myši)), zvukové komponenty (tj. textový popis zvuk. komponenty) se přeloží při přesunu myši.
  • Localization language (Jatyk lokalizace) - zvolit jazyk rozhraní SuperMemo používaný na začátečnické a základní úrovni . Nové rozhraní můžete vytvořit během 5 minut pomocí Lokalizační tabulky (viz níže)
  • Localization table (Lokalizační tabulka) - úplný seznam řetězců používaných programem SuperMemo na začátečnické a základní úrovni . Tento seznam můžete přeložit během 3 minut do svého rodného jazyka a tím lokalizovat SuperMemo. V případě potřeby můžete zvolit font překladu v levém dolním rohu dialogového panelu lokalizační tabulky.
  • Phonetic transcription(Fonetický přepis) - zvolit fonetický přepis pro jazyk, který popužíváte ve svém systému vědomostí. V SuperMemo World trvale pracujeme na našem registru fonetického přepisu angličtiny (v současné době má 72,000 členů a stále roste). Můžete si jej zakoupit v Knihovně SuperMemo spolu s jinými výukovými materiály.

Časté otázky

(Dusko Ivanisevic, New Zealand, Oct 1, 1998)
Otázka:
Jak mohu přidávat ke slovům fonetický přepis?
Odpověď:
Stiskněte Ctrl+Alt+P a napište slovo a jeho přepis. Pokud se dialogový panel přepisu neobjeví, nezvolil jste fonetický přepis (phonetic transcription) v Options (Volby) . V takovém případě proveďte následující:

  1. Zvolte Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis)
  2. Zvolte hotový soubor fonetického přepisu nebo napište jméno nového registru fonetického přepisu (v posledním případě budete budovat registr fonetického přepisu od základu).
  3. V případě potřeby zvolte na levé straně Font a vyberte písmo pro přepis (např. font IPA dostupný v Advanced English )
  4. Jakmile se dané slovo objeví na obrazovce, stiskněte Alt+Y , aby se přepsaly všechny texty (nebo na text umístěte kurzor myši).

****


Učit se

Obsah : Technický popis
Učit se

Tlačítko Učit se (Learn) na spodní straně obrazovky umožňuje učit se látku uloženou v SuperMemo.

Učení v SuperMemo je založeno na posloupnosti opakování . Každé opakování se skládá z následujících kroků:

  1. Podívejte se na otázku a pokuste se na ni odpovědět (v duchu nebo nahlas).
  2. Zvolte Zobrazit odpověď (Show answer) (ve spodní části obrazovky) a podívejte se na správnou odpověď.
  3. Porovnejte svou odpověď z kroku 1 s odpovědí zobrazenou na obrazovce
  4. Vyberte známku, která vyjadřuje přesnost vaší odpovědi (např. Výborně (Good), Nesprávně (Fail), atd.)
  5. Pokračujte kliknutím na tlačítko Další prvek (Next repetition) (a přejděte ke kroku 1).

Stupnice známek je definována takto (místo kliknutí na tlačítko můžete stisknout klávesu uvedenou v závorce):

Výborně (Bright) (klávesová zkratka: 5), výborná odpověď
Dobře (Good) (4), správná odpověď po krátkém zaváhání
Dostatečně (Pass) (3), odpověď utvořená s obtížemi, popřípadě s menší chybou
Nesprávně (Fail) (2), nesprávná odpověď, při níž si řeknete: To jsem věděl!
Špatně (Bad) (1), nesprávná odpověď; správná odpověď je vám trochu povědomá
Nula (0), odpověď si vůbec nepamatujete; máte pocit, že jste ji nikdy neviděli.

V SuperMemo pravděpodobně nebudete známky Nula nebo Špatně potřebovat, snad kromě prvního setkání s položkou.

V SuperMemo si nejprve látku snažíte zapamatovat a opakujete si ji, až vás o to program požádá.

Všimněte si důležitého rozdílu: látku se učíte svým tempem v den podle vašeho výběru, avšak opakovat ji musíte ve dnech, kdy to SuperMemo požaduje! To není omezení programu. Je to omezení způsobené naší pamětí. Síla SuperMemo spočívá v optimálním naplánování času opakování . Nejlepší je, můžete-li program spustit nejméně jednou každý den, abyste ověřili, je-li nějaká látka naplánována na tento den k opakování.

Odkládání opakování je nejpravděpodobnější příčina malého úspěchu učení se SuperMemo!

Časté otázky

(Deron Isaac, USA, May 21, 1997)
Otázka:
Jak mohu editovat texty položek během opakování , aniž bych opustil režim zkoušení?
Odpověď:
Stiskněte Q, chcete-li editovat otázku, nebo A, chcete-li editovat odpověď, nebo E, chcete-li editovat všechny textové komponenty . Všechny vlastnosti všech komponent můžete editovat také pomocí místních nabídek (pop-up menus) dostupných po kliknutí pravým tlačítkem myši na příslušnou komponentu.

(Matt Cassidy, New Zealand, Aug 18, 1997)
Otázka:
Jak si mohu prohlédnout položky určené k opakování na daný den?
Odpověď:
Použijte Tools (Nástroje) : Workload (Zátěž) a dvakrát klikněte na příslušný den.

(Grzegorz Malewski, Poland, Dec 10, 1997)
Otázka:
Ovlivňují známky při závěrečném procvičování proces učení?
Odpověď:
Ne. Používají se pouze pro eliminaci položek z fronty závěrečného procvičování.

Otázka:
Jak mohu odložit probírání (učení) prvku , když se učím novou látku?
Odpověď:
Zvolte Forget (Zapomenout) na místní nabídce prvku ( Ctrl+R ). Tím se položka umístí na konec fronty čekajících prvků .

(Ryszard Siwczyk, Poland, Nov 4, 1997)
Otázka:
Ovlivňuje doba reakce při opakování příští interval?
Odpověď:
Ne

Otázka:
Odjel jsem na dovolenou a můj proces učení je v maléru. Co mám dělat?
odpověď:
Použijte Tools (Nástroje) : Mercy (Milost)

Otázka:
Můj počítač byl napaden virem a SuperMemo hlásí problémy s integritou. Co mám dělat?
Odpověď:
Zkuste File (Soubor) : Recover (Zotavit)

(Mariusz Szepietowski, Poland, Dec 7, 1997)
Otázka:
Jak mohu odstranit informace o procesu učení ze souhrnu vědomostí? Rád bych se začal učit úplně od začátku.
Odpověď:
Použijte File (Soubor) : Reset (Vynulovat): Collection (Souhrn). Na konci tohoto procesu zvolte řazení (sorting) fronty čekajících prvků buď podle hierarchie (ve většině systémů) nebo podle ordinálních čísel (např. v Advanced English 97 ).

Otázka:
Mám ve svém souhrnu vědomostí uloženou látku s různou prioritou učení. Může mi SuperMemo pomoci věnovat větší pozornost látce, která má vysokou prioritu?
Odpověď:
Ano. Měl byste snížit hodnotu indexu zapomínání pro látku s vysokou prioritou (index zapomínání je podíl položek, na které si nevzpomenete při opakování ). V okně obsahu zvolte položku nebo uzel , který má mít vyšší prioritu, a na místní nabídce zvolte Node operations (Uzlové operace): Forgetting index (Index zapomínání): Set forgetting index (Nastavit index zapomínání) . Index zapomínání je implicitně 10% a je možno jej nastavit na 3-5% pro látku s vysokou prioritou nebo jen na 20% pro méně důležité větve stromu vědomostí .

****


Nabídka Učit se

Učit se (Learn)

Podnabídka Learn (Učit se) na hlavní nabídce poskytuje následující volby:

  • All (Vše) - procházet všemi etapami učení: Nevyřízená látka, nová látka a závěrečné procvičování . V orvní etapě se provádějí opakování naplánovaná na aktuální den a všechny předchozí dny (pokud v nich neproběhlo opakování příslušné položky). Ve druhé etapě se probírají a učí nové prvky (pokud existují). Ve třetí a poslední etapě se provádí procvičování, v němž se všechny prvky oznámkované horší známkou než dobře ( 4) opakují tak dlouho, až dostanou známku alespoň dobře. Learn (Učit se): All (Vše) je ekvivalentní stisknutí tlačítka Učit se (Learn) na spodním okraji okna prvku
  • Outstanding material (Nevyřízená látka) - opakovat nevyřízenou látku . Provádí se opakování naplánovaná na aktuální den a všechny předchozí dny (pokud u nich zůstala nějaká nevyřízená látka)
  • New material (Nová látka) - učit se čekající prvky uložené ve frontě čekajících prvků
  • Random learning (Náhodné učení) - učit se nové prvky náhodným výběrem z celého systému vědomostí (srovnej Contents (Obsah ): Review (Prohlížet) )
  • Final drill (Závěrečné procvičování - opakovat jen prvky naplánované pro závěrečné procvičování
  • Cut drills (Zrušit procvičování) - vymazat položky naplánované pro závěrečné procvičování (tj. poslední etapu Learn (Učit se): All (Vše)). Prvky pro závěrečné procvičování jsou uloženy v souboru <adresář věd. systému>/info/drill.dat . Funkce Cut drills prostě vymaže tento soubor a umožní přeskočit etapu závěrečného procvičování. Záv. procvičování můžete přeskočit, máte-li mnoho nevyřízených položek . V takovém případě má často přednost dohnání nevyřízené látky.

****


Volby: Učení

Karta Learning (Učení) v Tools (Nástroje) : Options (Volby): obsahuje volby ovlivňující způsob učení:

  • Forgetting index (Index zapomínání) - určit implicitní index zapomínání daný všem prvkům uvedeným do souhrnu vědomostí. Index zapomínání určuje rychlost učení. Když poprvé spustíte SuperMemo, je nastaven na 10%. To znamená, že SuperMemo naladí proces učení tak, aby pravděpodobnost zapomenutí daného prvku při opakováních byla 10 %. Index zapomínání můžete snížit na 3 % za cenu podsatného zpomalení učebního procesu. Můžete jej také zvýšit až na 20 %, čímž se značně zvýší rychlost učení za cenu snížení retence vědomostí . Další zvyšování indexu zapomínání nemá smysl, protože jak retence, tak rychlost učení klesá (můžete si o tom přečíst v oddíle Theoretical aspects of SuperMemo nebo se o tom přesvědčit pomocí Tools (Nástroje) : Statistics (Statistika): Simulation (SImulace)).

    Každému jednotlivému prvku je možno na     místní nabídce prvku ( Ctrl+Shift+P ) nastavit individuální index zapomínání pomocí Edit (Editovat): Edit parameters (Editovat parametry) ). Než však tuto hodnotu změníte, jejich index zapomínání bude určen implicitní hodnotou nastavenou v Tools : Options : Learning: Forgetting index.
  • Classic layout at learning (Klasické rozložení při učení) - po stisknutí tlačítka Learn (Učit se) uspořádat okno prvku a okno statistiky klasickým způsobem (zavedeným v SuperMemo 3.0 ). Chcete-li během opakování sledovat všechny statistiky učení, zatrhněte toto políčko. Chcete-li si prohlédnout klasické rozložení, než se rozmyslíte, zvolte Window (Okno) : Classic (F5).
  • Full repetition history (Úplná historie opakování) - udržovat úplnou historii opakování jednotlivých prvků . Chcete-li ušetřit nějaké místo na pevném disku, zrušte zatržení tohoto políčka (velikost historie opakování můžete vidět v <adresáři souhrnu>/info/reps.dat (nemažte prosím tento soubor ručně, použijte File (Soubor) : Reset (Vynulovat): Repetition history (Historii opakování)). Historii opakování si můžete prohlížet dvojitým kliknutím na okno dat prvku nebo zvolením History v Edit: Edit parameters na místní nabídce prvku ( Ctrl+Shift+P )
  • Always randomize final drill (Vždy náhodné pořadí závěrečného procvičování) - před přechodem do etapy závěrečného procvičování zamíchat pořadí opakování
  • Sound feedback (Zvuková reakce) - rozhodnout, jak bude SuperMemo reagovat na dobré a špatné známky:
    • None (Žádná) - žádný zvuk jako reakce na známku
    • Default (Implicitní) - použít implicitní zvuky Windows pro indikaci špatných a dobrých známek
    • Custom (Vlastní) - definovat vlastní zvuky pomocí Options (Volby) : Learning (Učení): Custom sounds (Vlastní zvuky) (viz níže)
  • Custom sounds (Vlastní zvuky) - jestliže je zatrženo Options : Learning: Sound feedback (Zvuková reakce), položka Custom sounds umožňuje vybírat členy zvukového registru jako reakci na známkování. Například máte-li ve zvukovém registru člen se jménem Fail (= špatně) obsahující dlouhé pípnutí a v členu Tada veselý signál tadá, můžete napsat tato dvě jména do Custom sounds: Success=Tada, Failure=Fail. Zvuky můžete vyzkoušet stisknutím tlačítek play (přehrát) vpravo. Pro import zvuků do zvukového registru použijte Search (Vyhledat) : File (Soubor): Sound (Zvuk) a na místní nabídce registru zvolte Import files (Importovat soubory).

***


Nepoddajné položky

Nepoddajné prvky

Volbu View (Zobrazit) : Special (Speciální): Leeches (Nepoddajné prvky = (pijavice)) je možno použít pro nalezení prvků, které v procesu učení působí problémy. Tato volba využívá dialogový panel filtru prvku , který je možno použít pro nalezení všech prvků splňujících určitou množinu kritérií, například počet opakování, počet selhání paměti , délka aktuálního intervalu, status ( probraný , čekající nebo vynechaný), typ ( položka nebo téma ) atd.

Smyslem nalezení nepoddajných položek ( leeches , doslova "pijavice") je upravit tyto položky s využitím mnemotechniky . Alternativně můžete tyto prvky odložit (např. zabývat se jimi později), vynechat je (využívat je jen jako reference, např. pomocí Search : Find elements), nebo je prostě vymazat.

Důležité!
Chcete-li maximalizovat efektivnost svého procesu učení, měli byste se naučit pravidelně používat View : Leeches a odstraňovat ze svého systému vědomostí nejtěžší a špatně strukturované prvky

Pro volbu nejmenších a největších hodnot odpovídajících rozsahu definovanému jako obtížné prvky můžete použít tato pole:

  • Repetitions (Počet opakování) - počet opakování provedených s daným prvkem. To není dobré kritérium pro definování nepoddajných prvků, a proto je implicitně vypnuto
  • Lapses (Počet selhání) - počet, kolikrát byl daný prvek zapomenut. To je přednostní pole pro definování nepoddajných prvků. Například chcete-li najít všechny prvky, které byly zapomenuty nejméně 5krát, nastavte Minimum na 5 a Maximum na 100 (nebo nějakou jinou hodnotu, která je větší než maximální počet selhání)
  • Interval - počet dnů mezi posledním opakováním a příštím opakováním. Je vhodné omezit intervaly na nějaké hodnoty (např. od 1 do 50 dnů), aby byla brána v úvahu skutečnost, že i když byl prvek několikrát zapomenut, jestliže prošel intervalem určité délky, aniž by byl zapomenut.
  • Last repetition (Poslední opakování) - počet dnů od prvního dne procesu učení do data posledního opakování (viz Tools : Workload, kde je uvedeno číslování dnů). Toto pole by se nemělo používat pro vyhledávání nepoddajných prvků
  • Next repetition (Příští opakování) - počet dnů od prvního dne procesu učení do data příštího opakování. Toto pole by se nemělo používat pro vyhledávání nepoddajných prvků
  • A-Factor - hodnota A-Faktoru přiřazená danému prvku. To není dobré kritérium pro definici nepoddajných prvků. Chcete-li je použít, zvolte nižší rozsah A-faktorů (např. od 1,3 do 1,5)
  • Forgetting index (Index zapomínání) - pravděpodobnost zapomenutí daného prvku při každém opakování. Index zapomínání nastavuje uživatel a v žádném případě není mírou obtížnosti prvku. Můžete jej však použít pro nalezení položek s nižší prioritou (definovaných např. větším indexem zapomínání). Tak můžete zostřit kritéria nepoddajnosti pro prvky, které mají nižší prioritu
  • Ordinal number (Ordinální číslo) - číslo přiřazené danému prvku. Ordinální číslo nastavuje uživatel a v žádném případě není mírou obtížnosti prvku. Můžete je však použít pro nalezení prvků s nižší prioritou (definovanou například vyšším ordinálním číslem). Tak můžete zostřit kritéria nepoddajnosti pro prvky, které mají nižší prioritu

Nechcete-li použít některé kritérium, zrušte zatržení políčka. Chcete-li je použít, zatrhněte příslušné políčko a zadejte odpovídající minimální a maximální hodnoty.

Pole Type (Typ), Status, Item (Položka), Topic (Téma) a Memorized (Probrané) by se pro vyhledávání nepoddajných položek neměla použít. Podle definice jsou všechny nepoddajné položky probrané.

Když kliknete na OK, všechny nepoddajné položky splňující zadaná kritéria se zobrazí v prohlížeči .

Parametry nepoddajných položek jsou uloženy v souboru <adresář supermemo>\<systems>\<jméno systému vědomostí>\ks.ini v sekci [Leech].

****


Úrovně

SuperMemo poskytuje tři úrovně pro uživatele, kteří jsou na různém stupni obeznámeni s programem:

  1. Začátečnická úroveň - to je výchozí (implicitní) úroveň, která poskytuje jen nejzákladnější operace pro používání programu (viz obr. níže)
  2. Základní úroveň - v této úrovni jsou hlavně přidány editační možnosti (např. karty Compose (Vytvářet) a Edit (Editovat) na nástrojovém panelu okna prvku )
  3. Profesionální úroveň - tato úroveň poskytuje plnou funkčnost SuperMemo (viz obr. níže)

Úrovně v SuperMemo je možno měnit pomocí File (Soubor): Level (Úroveň). Navíc je pro přepínání mezi profesionální a základní úrovní možno použít klávesovou zkratku Ctrl+Alt+F12. Zkratka Ctrl+Alt+F12 v začátečnickém režimu přepíná do základního režimu.

Jak Začátečnická, tak Základní úroveň má jednoduché rozhraní, které je možno lokalizovat pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Localization table (Lokalizační tabulka) .

Začátečnická úroveň

Profesionální úroveň

***


Lokalizaèní tabulka

Lokalizacní tabulka

With Tools : Options : Language : Localization table, you can quickly translate the entire interface of SuperMemo to your native language (only at the beginner and basic levels ). The whole translation can be done in 5 minutes, as the entire interface of basic SuperMemo consists of only 39 strings!

This is the procedure:

  1. Choose Tools : Options : Language
  2. Click the field Localization language (or press Alt+I)
  3. Type the name of your language (e.g. Spanish)
  4. Choose Localization table
  5. In the column Translation, type in the translation of texts displayed in the column Original
  6. If necessary, select a localization font by clicking the font button in the left-bottom corner of the localization table
  7. Choose OK and your translation will appear in the interface of the program

The translation file is a text file. It is kept at <SuperMemo directory> \translat\<language>.tra

You can download some SuperMemo interfaces from International Interfaces for SuperMemo. If you do not find an interface in your language, we will be happy to add your own translation. You can send it via e-mail to support@supermemo.com .

To change the interface in SuperMemo using a downloaded interface file do the following:

  1. Download an interface file from International Interfaces for SuperMemo (only 1000 bytes!)
  2. Copy the interface file to the subdirectory translat in the SuperMemo directory (the filename is <language name>.tra)
  3. Choose the interface's name in Tools : Options : Language : Localization language

An alternative approach is to:

  1. Download an interface from International Interfaces for SuperMemo (only 1000 bytes!)
  2. Choose Tools : Options : Language : Localization table
  3. Type the language name in the Localization language field (you do not have to use the name of the downloaded file)
  4. Choose Import in Localization table and select the downloaded interface file (the filename is <interface name>.tra).

**


Hlavní nabídka

Obsah : Technický popis : Hlavní okno
Hlavní okno

Hlavní okno SuperMemo je viditelné, jen když je zatrženo File (Soubor) : Level (Úroveň): Professional (profesionální) , tj. není viditelné v základním a začátečnickém režimu.

Hlavní součásti hlavního okna jsou:

  • Nadpis - zobrazuje jméno právě používaného systému vědomostí. Chcete-li vidět úplnou cestu ke svému souhrnu, otevřete okno obsahu , např. kliknutím na Contents (Obsah) na navigačním nástrojovém panelu okna prvku (cesta se zobrazí v nadpisu okna obsahu)
  • Nabídka:
    • Podnabídka File (Soubor) obsahuje volby pro správu souborů souhrnu vědomostí SuperMemo (zvaných též "vědomostní systém"), např. pro vytvoření nového souhrnu, vymazání souhrnu, obnovu poškozených souborů , atd. Umožňuje rovněž volit mezi Základní, Začátečnickou a Profesionální úrovní
    • Podnabídka Edit (Editovat) obsahuje editační možnosti, např. přidání prvku , vymazání prvku, editaci prvku, atd.
    • Podnabídka Search (Vyhledat) umožňuje vyhledávat texty, soubory, prvky atd.
    • Podnabídka Learn (Učit se) obsahuje volby pro učení, např. Random learning (Náhodné učení)
    • Podnabídka View (Zobrazit) umožňuje zobrazovat podmnožiny prvků v prohlížečích prvků (např. probraných prvků, obtížných prvků, nevyřízených prvků atd.
    • Podnabídka Tools (Nástroje) obsahuje různé nástroje, např. Options (Volby) , kalendář opakování, nástroje pro přerozdělení opakování , statistické nástroje atd.
    • Podnabídka Window (Okno) umožňuje vhodně uspořádat okna na pracovní ploše SuperMemo
    • Podnabídka Help (Nápověda) obsahuje volby, které mohou být užitečné k tomu, abyste se o SuperMemo dozvěděli více: tuto nápovědu, Otázku dne , přímé propojení na webové stránky SuperMemo a e-mailové adresy na technickou podporu SuperMemo
  • Urychlovací pruh (speedbar) - obsahuje řadu urychlovacích tlačítek, která dublují některé funkce nabídky a umožňují rychle provádět nejčastěji používané operace. Abyste poznali funkci jednotlivých tlačítek, umístěte na tlačítko kurzor myši, vyčkejte asi 1 vteřinu a přečtěte si popisek (volba Window (Okno) : View (Zobrazit): Hints (Popisky) musí být zaškrtnuta)
  • Nástrojový panel - obsahuje některé často používané nástroje, např. datum, hodiny, stopky, schránky pro kopírování prvků a komponent atd.
  • Stavový pruh - obsahuje nejčastěji používané statistické údaje procesu učení a pruh popisků, kde se zobrazují popisky (např. v okamžiku, kdy umístíte ukazatel myši na tlačítko nebo položku nabídky)

Všimněte si, že urychlovací pruh, nástrojový panel a stavový pruh je možno zobrazit nebo skrýt pomocí volby Window (Okno) : View (Zobrazit).

Časté otázky

(Thomas Clark, USA, Nov 24, 1997)
Otázka:
Proč si SuperMemo nepamatuje velikosti jednotlivých oken? Musím je měnit po každém spuštění programu!
Odpověď:
Uložte prosím své rozložení oken pomocí Window (Okno) : Save as default (Uložit jako implicitní) ( Ctrl+Shift+F5 ).

****


Milost

Mercy (Milost)

Funkci Mercy (Milost) je možno používat pro odsunutí nevyřízených opakování na pozdější dobu, např. po delší přestávce v učení. Může vám také pomoci provést opakování dříve, např. před dovolenou.

Varování! Každým použitím funkce Mercy přidáváte nadbytečné hodiny práce potřebné pro zvládnutí téhož množství látky! Nadbytečná pracovní zátěž je důsledkem přestávek v učení, nikoliv funkce Mercy!

Rychlé přerozdělení nevyřízených opakování se provede takto:

  • 1. Zvolte Tools (Nástroje) : Mercy (Milost) (např. stisknutím Ctrl+Y ).

    2. Zvolte maximální přijatelný počet položek na den a napište jej do pole Number of items per day (Počet položek za den). Alternativně můžete zvolit období, během něhož by se měly všechny nevyřízené položky zopakovat; napište je do pole Rescheduling period (Období přerozdělení).

    3. Zvolte Update (Aktualizovat), např. stisknutím Enter. Tím se zobrazí parametry přerozdělení: počet položek na den, délka období přerozdělení, datum, kdy se zopakují poslední nevyřízené položky atd. (pro zjištění, co znamenají jednotlivé parametry, použijte popisky (hints).

    4. Jste-li spokojeni, zvolte OK. V opačném případě napište nové parametry nebo zavřete dialogový panel zvolením Cancel (Zrušit).

    •

    Chcete-li provádět opakování před dobou nepřítomnosti, můžete posunout pozdější opakování na dřívější dobu:

  • 1. Zvolte Tools (Nástroje) : Mercy (Milost) (např. stisknutím Ctrl+Y ).

    2. Klikněte na zatrhovací políčko Consider future repetitions (Brát v úvahu pozdější opakování).

    3. Do editačního pole Gathering period (Sběrné období) napište počet dnů do konce vaší nepřítomnosti.

    4. Stiskněte Enter a zkontrolujte datum vpravo od Gathering period.

    5. Do editačního pole Rescheduling period napište počet dnů do začátku vaší nepřítomnosti.

    6. Stiskněte Enter a zkontrolujte datum vpravo od Rescheduling period.

    7. Jestliže Number of items per day (Počet položek na den) nepřekračuje realistickou hodnotu (podle vašeho odhadu), zvolte OK. V opačném případě napište nové parametry nebo ukončete dialogový panel zvolením Cancel (Zrušit).

    •

    Jste-li pokročilý uživatel a rozumíte tomu, jak Mercy pracuje, můžete stisknout tlačítko Criteria (Kritéria) a nastavit svá vlastní kritéria třídění pro funkci Mercy!

    Krátká historie přerozdělování položek v SuperMemo

    V červnu 1991 si novinář z časopisu Computer World Andrzej Horodenski uvědomil, že pro líné uživatele SuperMemo by byla mimořádně užitečná volba nazvaná Mercy (Milost). Umožňovala by uživatelům přerozdělovat nevyřízená opakování po prázdninách. Pouze o měsíc později vydala firma SuperMemo Worldsmw novou verzi SuperMemo 6 pro DOSget_SM6_PD, která obsahovala navrhovanou volbu.

    První algoritmus funkce Mercy byl založen na solidních teoretických základech. Kritérium třídění položek bylo minimalizovat pokles retence v důsledku použití Mercy. Avšak volba kritéria třídění nebyla příliš šťastná. Je snadné si uvědomit, že nárůst intervalů u položek s krátkým intervalem je mnohem zhoubnější než tentýž nárůst u položek s dlouhým intervalem. V důsledku toho by se uživatelé použivší Mercy lopotili se spoustou těžko zapamatovatelných položek, což by zase přispívalo ke ztrátě odvahy přetížené mysli. Je obtížné odhadnout, kolik lidí se "zaseklo" při použití Mercy a v důsledku toho odpadlo z rodiny uživatelů SuperMemo.

    Do SuperMemo 6 pak byla přidána nová volba. Nazývala se Wipe (Smést) a byla určena k odstranění všech položek s krátkým intervalem a s vysokou obtížností (vyjádřenou faktory E) z procesu učení. Avšak funkce Wipe ba mohla napáchat víc škody než špatně koncipovaná funkce Mercy. Uživatelé by často nahromadili položky funkcí Mercy a pak by je vyloučili z učebního procesu pomocí Wipe. Brzy by poznali, že by se nedostavil žádný skutečný pokrok v učení. V důsledku toho by opět odpadli ke škodě celkové obliby SuperMemo.

    V roce 1994 byl navržen nový algoritmus funkce Mercy. Nové kritérium třídění: minimalizovat poškození dlouhodobého procesu učení. Ukázalo se, že algoritmus je neobyčejně složitý, ale změnil funkci Mercy k nepoznání. Velmi brzy se ukázalo, že volba Wipe se stala zcela zbytečnou. Nová funkce Mercy by mohla být uživateli zneužívána stejně jako stará, ale způsobila by méně škod a méně zklamání. Mercy přežila a nebyla z následujících verzí SuperMemo odstraněna. Konec konců věříme, že bychom měli dát lidem šanci rozhodnout se, co potřebují, i když si tu a tam mohou způsobit újmu.

    Mnohem později začalo být jasné, že druhá funkce Mercy má skrytý háček. Je-li zneužívána často, je schopna opakovaně prodlužovat první interval nově probíraných položek (o těch se předpokládalo, že jsou pro dlouhodobý učební proces méně důležité). Tento problém ještě složitější vinou skutečnosti, že všechny algoritmy SuperMemo implementované v letech 1989-1996 byly vysoce citlivé na odkládání opakování, zejména v časných stadiích učení. V důsledku toho položky, které byly výrazně odloženy použitím Mercy a které by v opakováních dosahovaly dobrých výsledků, by dosahovaly neúměrně dlouhých intervalů.

    Tyto problémy byly částečně vyřešeny v prosinci 1996 implementací následujících vlastností SuperMemo:

    1. Odstraněním citlivosti k odkládání opakování v algoritmu SM-8 indexováním optimalizačních matic kategoriemi opakování místo počty opakování (například položka opakovaná dvakrát by byla v případě zpoždění opakování interpretována jako opakovaná 2,4krát).

    2. Implementací nového multikriteriálního heuristického algoritmu Mercy, který kombinuje dřívější důraz na minimalizaci poškození dlouhodobého procesu učení s věnováním zvláštní pozornosti položkám, které byly do vědomostního systému přidány v poslední době.

    A nakonec, v prosinci 1997 byla funkce Mercy rozšířena o volbu Criteria . Tato volba uživateli umožňuje vybírat si vlastní kritéria pro funkci Mercy. Doufáme, že to je konec 5 let trvajícího procesu, během něhož jsme se snažili pochopit, co vlastně lidé od funkce Mercy očekávají. Uživatel může zvažovat následující kritéria třídění: důležitost položky (indikovaná ordinálním číslem a indexem zapomínání), opoždění položky, investice (do položky), snadnost (položky) a doba uvedení položky do procesu učení. Poslední kritérium je obzvlášť důležité, jestliže vědomosti nedávno zavedené do procesu učení mají mimořádnou důležitost. Viz též Kritéria Mercy .

    ****


Kritéria funkce Milost

Kritéria Mercy

Dialogový panel Tools (Nástroje) : Mercy (Milost) : Criteria (Kritéria) je možno použít pro určení kritérií, na jejichž základě mají být seřazeny položky přerozdělené pomocí Tools (Nástroje) : Mercy (Milost) .

Varování! Každým použitím funkce Mercy přidáváte nadbytečné hodiny práce potřebné pro zvládnutí téhož množství látky! Nadbytečná pracovní zátěž je důsledkem přestávek v učení, nikoliv funkce Mercy!

Jestliže jste se právě vrátili z dovolené nebo jste měli slabou vůli pro učení, pravděpodobně budete chtít přerozdělit nevyřízená opakování na nějaké delší časové období. Můžete se tak vyhnout přetížení při opakování položek, které pro vás má SuperMemo v zásobě. Avšak v závislosti na povaze látky nahromaděné ve vašem systému budete možná chtít použít úplně jiná kritéria. Například jestliže jste krátce před odjezdem na dovolenou přidali množství důležitých informací majících vztah k vaší práci, budete možná chtít projít tuto nedávno zavedenou látku. V jiných případech si možná budete chtít ulehčit napětí pramenící z návratu k opakování tím, že si vyberete nejprve nejsnazší látku, nebo si pozvednout morálku tím, že vyberete nejposlednější položky a uvědomíte si, kolik ztrácíte zanedbáváním opakování. Můžete také chtít minimalizovat ztrátu u dlouhodobého procesu učení tím, že začnete s prvky, do kterých jste nejvíc investovali nebo jejichž opakování bylo nejvíc zpožděno.

Kritéria řazení používaná funkcí Mercy :

  1. Importance (důležitost) - důležitost prvků daná ordinálními čísly a indexem zapomínání. Toto kritérium použijte pro upřednostnění látky, kterou jste označili jako látku s vysokou prioritou
  2. Lateness (opoždění) - míra zpoždění opakování prvků. Pravděpodobnost zapomenutí v důsledku zpoždění je větší u prvků s krátkým intervalem. Toto kritérium použijte pro minimalizaci množství zapomenutých prvků při opakování přerozdělené látky
  3. Investment (investice) - investice vašeho času věnovaného učení prvků. Investice je dána počtem opakování, počtem selhání paměti a především délkou intervalu. Toto kritérium použijte pro zachránění látky, na které jste netvrději pracovali. I když je to látka, u níž je nejmenší pravděpodobnost zapomenutí, každé selhání paměti v případě látky s velkou investicí má za následek nejbolestnější nárůst pracovní zátěže.
  4. Easiness (snadnost) - snadnost prvků daná intervalem a počtem selhání paměti (čím méně je selhání a čím delší je interval, tím snazší je prvek). Toto kritérium použijte pro maximalizaci rychlosti a minimalizaci stresu při zpracování nevyřízené látky. Kritérium Easiness můžete zvolit v době krize (tj. když nemůžete věnovat opakování dostatečnou pozornost). Tak se můžete rychle zbavit většiny nevyřízené látky, aniž byste přidávali mnoho opakování nově zapomenutých prvků. Díky tomu se budete zabývat nejobtížnější částí, až před sebou budete vidět brzký konec strádání. Všimněte si, že A-faktory by mohly, avšak nejsou použity pro určení snadnosti.
  5. Recency (nedávnost) - jak nedávno byly prvky zavedeny do procesu učení. Nedávnost je určena (1) intervaly (kratší intervaly naznačují nedávnost), (2) počtem selhání paměti (selhání vylučuje nedávnost) a (3) počtem opakování (nedávné položky mají proveden menší počet opakování). Toto kritérium použijte, když nedávno probraná látka má pro vás velkou prioritu (např. v případech, kdy jste se před odjezdem na dovolenou učili důležitou látku mající vztah k zaměstnání). Toto kritérium je velmi užitečné také v případě, kdy procházíte krizí v opakování (Musím s tím SuperMemem opravdu trávit tolik času?). Kritérium nedávnosti vám pomůže si rychle uvědomit, kolik úžasné látky jste se nedávno naučili a jaká škoda by byla ji ztratit. Je-li přestávka dost dlouhá, uvidíte také, jak velkou část prvků jste již ztratili!

Varování! Nadměrným používáním kritérií Recency a Easiness se může stát, že těžší prvky s dlouhým intervalem získají nesmírně dlouhé intervaly! Za rok nebo za dva můžete být velmi zklamáni, když zjistíte, že některé prvky dostaly velmi dlouhé intervaly bez jediného opakování a prakticky úplně zmizely z vaší paměti!

Vpravo od posuvníků je možno vidět procentuální hodnoty dopadu jednotlivých kritérií řazení. Změňte tyto hodnoty posunutím. Například chcete-li opakovat přerozdělenou látku tak, že nejsnazší látka přijde na řadu první, posuňte všechny posuvníky doleva a posuvník Easiness nechte vpravo (Easiness=100%).

Všimněte si, že kritérium investice nemůže klesnout pod 2%. Ostatní kritéria nemusí mít na řazení žádný vliv. To má zabránit situaci, ve které všechna kritéria mají hodnotu 0%.

Chcete-li rychle přerozdělit nevyřízená opakování pomocí dané množiny kritérií, postupujte takto:

  1. Zvolte Tools : Mercy (např. stisknutím Ctrl+Y )
  2. Zvolte Criteria a nastavte posuvníky podle svých preferencí
  3. Zvolte maximální přijatelný počet opakování na den a napište jej do pole Number of items per day (Počet položek na den). Alternativně můžete zvolit období, během něhož by se měla nevyřízená opakování zvládnout, a napište je do pole Rescheduling period (Období přerozdělení)
  4. Zvolte Update (AKtualizovat), např.stisknutím Enter. Tím se zobrazí parametry přerozdělení: počet položek na den, délka období přerozdělení, datum, kdy se budou provádět poslední nevyřízená opakování, atd.
  5. Jste-li se svou volbou spokojeni, klikněte na OK. V opačném případě napište nové parametry a zvolte opět Update.

****


Minimální požadavky

Obsah : Technický popis
Minimální požadavky

Základní požadavky

  • Počítač 486 (doporučeno Pentium)
  • 4 MB paměti (doporučeno 8 MB)
  • 4 MB prostoru na disku (doporučeno více pro rozsáhlejší vědomostní systémy čili souhrny (collections) studované látky.
  • Monitor SVGA s rozlišovací schopností 800x600
  • Windows 95, Windows 98, nebo Windows NT 4.0 (nebo vyšší) s podporou Internetu. Některé starší instalace mohou vyžadovat aktualizaci na comctl32.dll (viz oddíl FAQ ).

Další požadavky

  • pro používání komponent HTM nebo aktualizace z webu: MS Internet Explorer 4.0 (nebo vyšší) (nebo nainstalované knihovny shdocvw.dll a mshtml.dll)
  • pro editaci HTML WYSIWYG: editor WYSIWYG HTML
  • pro používání konzultací prostřednictvím e-mailu: software pro e-mail ve Windows (viz: technická podpora )
  • pro používání zvuku a videa: zvuková karta (např. pro Advanced English ).
  • pro používání vědomostních systémů na CD-ROM (např. Advanced English ): 4rychlostní jednotka CD-ROM.
  • Pro používání editovatelných map mysli (mind-maps): MindMan 3.0 (nebo vyšší)

Viz též: Technická podpora

Časté otázky

(Peter Cool, the Netherlands, Oct 31, 1998)
Otázka:
Při pokusu o instalaci SuperMemo 98 jsem dostal následující dvě hlášení:

  1. Cannot find sm8.ini (Okopíroval jsem sm98.exe do svého hlavního adresáře SuperMemo 8)
  2. This control requires version 4.7 or greater of comctl32.dll

Odpověď:
Problémy jsou ve vaší knihovně comctl32.dll ve Windows. Staré instalace Windows 95 mohou obsahovat starší verzi této knihovny. Použijte prosím URL uvedené níže pro stažení bezplatného updatu (asi 500K; ver. 4.72). To vám nejen umožní spustit SuperMemo, ale zlepší to také stabilitu jiných aplikací W95 a NT.

http://acadiacom.softseek.com/Programming/DLLs_and_Libraries/Review2_16871_index.html

****


Modifikovat v podmnožině

Nástroje: Modifikovat v podmnožině

Podnabídka Tools (Nástroje) : Modify in subset (Modifikovat v podmnožině) umožňuje modifikovat parametry komponent v prvcích náležejících do vybrané podmnožiny . Jsou to pokročilé a nevratné operace, proto důrazně doporučujeme systém vědomostí předem zálohovat.

  • Set original sound names (Nastavit původní jména zvuků) - změnit text ve zvukových komponentách na původní jméno členu zvukového registru asociovaného se zvukovou komponentou.
  • Copy component texts (Kopírovat texty komponent) - kopírovat texty mezi komponentami ve vybrané podmnožině prvků.
  • Change keep in lexicon (Změnit "keep in lexicon") - změnit status Keep in lexicon v textových komponentách vybrané podmnožiny prvků (např. pro eliminaci určitého textového pole z lexikonu)
  • Change display at status (Změnit status "Zobrazit při") - změnit status Display at (Zobrazit při) vybrané komponenty ve vybrané podmnožině prvků
  • Change size (Změnit velikost) - změnit velikost vybrané komponenty ve zvolené podmnožině prvků.

****


Myš

Options (Volby): Mouse (Myš)

Karta Mouse (Myš) na Tools (Nástroje): Options (Volby) umožňuje definovat reakce programu na akce myši:

  • Translation (Překlad) - jak se provádí překlad textových komponent pomocí myši
    • On mouse move (Při přesunu myši) - překlad se objeví, když se kurzor myši přesune na danou textovou komponentu
    • On middle button click (Na kliknutí prostředním tlačítkem) - překlady se objeví, když se na danou textovou komponentu klikne prostředním tlačítkem myši
    • On Shift+click (Na shift+klik) - překlady se objeví v dialogovém panelu k tomu určeném při kliknutí tlačítkem při stisknuté klávese Shift (tato volba umožňuje rovněž editaci originálních textů a textů překladů)
  • Phonetic transcription (Fonetický přepis) - jak se provádí fonetický přepis textových komponent pomocí myši
    • On mouse move (Při přesunu myši) - přepisy se objeví, když se na danou textovou komponentu přesune kurzor myši
    • On middle button click (Na kliknutí prostředním tlačítkem) - přepisy se objeví, když se na danou textovou komponentu klikne prostředním tlačítkem myši
    • On Shift+click (Na shift+klik) - přepisy se objeví při kliknutí na textovou komponentu se stisknutou klávesou Shift
  • Edit texts (Editovat texty) - jak je možno texty editovat
    • On Alt+click (Na alt+klik) - kliknutím na komponentu při stisknuté klávese Alt je možno editovat texty
    • On click (Na kliknutí) - kliknutím na komponentu je možno editovat texty (výchozí nastavení)
  • Drag components (Přetahovat komponenty) - jak je možno komponenty přetahovat
    • On Ctrl+drag (to ClipBox) (Přetahování se stisknutou klávesou Ctrl) (do schránky) Komponenty je možno přetahovat do schránky komponenty nebo do hyperlinkové schránky při stisknutí klávesy Ctrl
    • On Alt+dblclick (Alt +dvojité kliknutí) - komponenty je možno přetahovat pomocí Alt+šipkových kláves po dvojitém kliknutí při stisknuté klávese Alt na komponentu.

  • ****

    •


Navigovat

Navigační nástrojový panel

Na horní straně okna prvku standardně najdete navigační nástrojový panel:

Význam jednotlivých tlačítek:

  • Obsah (Contents) - otevřít okno obsahu se stromovou strukturou vědomostí uložených v aktuálním souhrnu vědomostí
  • Vyhledat (Search) - otevřít seznam slov použitých v aktuálním souhrnu
  • Zpět (Back) (<) - přesunout zpět na poslední navštívený prvek (totéž jako Alt+B)
  • Vpřed (Ahead) (>) - znovu navštívit prvky, které byly prohlíženy před použitím Zpět (<)
  • Historie (History) - zobrazit seznam naposledy navštívených prvků
  • Další (Next) - přejít na následující prvek (interpretace tohoto tlačítka závisí na nastavení voleb tlačítka Další (Next))
  • Domů (Home) - přejít na hlavní uzel celého souhrnu vědomostí
  • Předchozí prvek (Previous element) - přejít na předchozí prvek v okně obsahu
  • Matka (Parent) - přejít na mateřský prvek právě zobrazeného prvku
  • Další prvek (Next element) - přejít na následující prvek v okně obsahu
  • Konec (End) - přejít na poslední prvek ve stromě vědomostí v okně obsahu
  • Synchronizovat (Synchronize) - zapnout / vypnout výběr právě zobrazeného prvku v okně obsahu. Stlačte toto tlačítko, chcete-li mít vždy možnost vidět polohu zobrazeného prvku v okně obsahu
  • Okamžitý překlad (Instant translation) - zapnout / vypnout překlad textů při umístění kurzoru myši na text v okně prvku
  • Okamžitý přepis (Instant transcription) - zapnout / vypnout fonetický přepis textů při umístění kurzoru myši na text v okně prvku
  • Tisk (Print) - vytisknout právě zobrazený prvek

Profesionální úroveň

Všimněte si, že navigační nástrojový panel nebude viditelný, jestliže je zatrženo Tools (Nástroje) : Options (Volby) : Data access (Přístup k datům) : Hide navigation toolbar (Skrýt navigační nástrojový panel).

****


OLE

Komponenta OLE

Přejete-li si zobrazit v SuperMemo soubory vytvořené v MS Word, Excel, Corel, Microsoft Equation, PowerPoint, MindMan atd., můžete použít komponentu OLE. V komponentě OLE se mohou zobrazovat soubory vytvořené v jakékoliv aplikaci podporující OLE 2.0. Jestliže aplikace podporuje aktivaci na místě (in-place), budete také moci tyto soubory editovat, aniž byste ukončili SuperMemo. Například vložíte-li do kokponenty OLE dokument MS WOrd a přepnete do editačního režimu , nabídky a nástrojové panely SuperMemo budou nahrazeny nabídkami a panely Wordu.

Stejně jako všechny ostatní komponenty je komponenta OLE dostupná pomocí karty Compose (Vytvářet) na horní straně okna prvku . Abyste mohli editovat soubory vložené do komponenty OLE, budete potřebovat odpovídající aplikaci (např. MS Word, Corel, MindMan atd.). Nepotřebujete však žádný software pro zobrazení těchto souborů v prezentačním režimu .

Při přidávání komponenty OLE klikněte na tři body:

  1. Tlačítko OLE na kartě Compose (Vytvářet)
  2. Levý horní roh oblasti, kde chcete soubor OLE zobrazit (v okně prvku )
  3. Pravý dolní roh této oblasti

Komponenta OLE se zobrazí jako prázdný obdélník.

Chcete-li naimportovat hotový soubor, klikněte pravým tlačítkem na komponentu OLE a zvolte Insert OLE object (Vložit objekt OLE), klikněte na Create from File (Vytvořit ze souboru) na dialogovém panelu Insert Object (Vložit objekt) a vyberte soubor napsáním jeho jména nebo kliknutím na Browse (Prohlížet).

Chcete-li vytvořit nový soubor a editovat jeho obsah, klikněte pravým tlačítkem na komponentu OLE a zvolte Insert OLE object (Vložit objekt OLE), a vyberte si ze seznamu serverů OLE dostupných ve vaší instalaci Windows. Když kliknete na OK, příslušný server se vyvolá a vy budete moci svůj soubor editovat (např. rovnici Microsoft Equation, graf Excelu, prezentaci PowerPoint atd.). Když stisknete Esc, SuperMemo zobrazí soubor v prezentačním režimu (tj. tak, jak bude vypadat při učení na počítači uživatele vašeho systému vědomostí ).

Všimněte si prosím, že místní nabídka komponenty OLE je závislá na režimu, tj. v editačním režimu zobrazí místní nabídku serveru OLE a v prezentačním režimu standardní volby SuperMemo. V prezentačním režimu budete moci používat volby jako Display At, Answer, Border, atd. V editačním režimu budete moci používat volby závislé na serveru OLE (např. je-li váš server MS Excel, budete moci používat Cut, Copy, Format cells atd.).

Nejjednodušší způsob přepínání mezi prezentačním a editačním režimem je některá z následujících možností:

  • Kliknout se stisknutou klávesou Alt na oblast zobrazení prvku
  • Stiskat Ctrl+T , dokud nedosáhnete komponenty OLE
  • kliknout na tlačítko Editing mode (modrý zápisník) na kartě Edit

Profesionální úroveň

Vykazuje-li váš server OLE problémy se stabilitou nebo nespolupracuje se SuperMemo hladce, váš soubor OLE možná stále ještě dobře pracuje v prezentačním režimu. Budete moci redistribuovat svůj systém vědomostí bez obav z provozu na stroji uživatele.

Časté otázky

(Tomasz Szynalski, Poland, Dec 2, 1998)
Otázka:
Když v komponentě OLE vytvořím rovnici pomocí MS Equation, rovnice je nepřirozeně dlouhá a zdeformovaná. Co s tím mám dělat?
Odpověď:
Objekt OLE je vytvářen aplikací, v tomto případě MS Equation. Musíte problém vyřešit v MS Equation nastavením atributů zobrazení (v tomto případě např. zmenšením velikosti fontů).

****


Volby

Volby (Options)

Podnabídka Tools (Nástroje) : Options (Volby) na hlavní nabídce otevře dialogový panel voleb, který umožňuje nastavit některé parametry programu SuperMemo a právě otevřeného systému vědomostí .

Dialogový panel Options (Volby) obsahuje následující karty (tabs):

  • Learning (Učení) - volby ovlivňující proces učení, např.: rychlost učení, rozložení oken, zvukovou odezvu atd.
  • Data access (Přístup k datům) - volby ovlivňující přístup k datům a volby v SuperMemo jako jsou: cesta k CD-ROM, úroveň obtížnosti, stupeň editovatelnosti systému (např. jen čtení , jen učení , úplný přístup atd.), heslo atd.
  • Appending (Přidávání) - volby, které ovlivňují způsob přidávání nových prvků do systému vědomostí , např.: vzhled položek , umístění přidávaných položek ve stromě vědomostí atd.
  • Language (Jazyk) - možnosti lokalizace, například: jazyk, do něhož se aktuální systém vědomostí překládá, jazyk rozhraní SuperMemo , řetězce používané v překladu rozhraní atd.
  • Mouse (Myš) - interpretace chování myši. Například když jsou editovány nebo překládány komponenty atd.
  • SuperMemo - další volby, například obraz pozadí, font rozhraní atd.

Profesionální úroveň

Globální volitelné parametry SuperMemo jsou uloženy v souboru sm8.ini v podadresáři SuperMemo bin.
Volby týkající aktuálního systému vědomostí jsou uloženy v souboru ks.ini v podadresáři systému vědomostí (pojmenovaném stejně jako systém vědomostí).

***


Přehledy

Obsah : Přehledné články
Nápověda SuperMemo 98: Přehledné články

Instalace pro začátečníky - jednotlivé komponenty SuperMemo si můžete snadno stáhnout z Internetu (včetně systémů vědomostí )

  1. Témata versus položky - témata jsou prvky, které se používají k uvádění shrnujících úvodů ke studované látce
  2. Používání registrů - registry v SuperMemo se používají k ukládání objektů, jako jsou texty, obrazy, zvuky, fonty, knihovny DLL, objekty OLE atd.
  3. Používání šablon - šablony je možno používat k rychlému vytváření mnoha složitých položek majících stejný vzhled
  4. Používání skriptů - skripty mohou dát vašemu souhrnu znalostní život. Je to něco jako počítačové prográmky, ale mnohem jednodušší!
  5. Tvoření pokročilých testů - můžete vytvářet testy s výběrem z několika možností, testy s přetahováním na správné místo metodou drag-and-drop, testy využívající kliknutí myší, atd.
  6. Používání podmnožin - můžete si ukládat podmnožiny prvků na disk a později je používat pro testování, prohlížení, statistiku, atd.
  7. Používání HTML - z prostředí SuperMemo si můžete prohlížet dokumenty HTML nebo celé www stránky.
  8. Používání OLE - k SuperMemo můžete přidávat soubory vytvořené v MS Word, Excel, MindMan, MS Equation, atd.
  9. Používání Mercy ("milost") a kritéria Mercy - jestliže zanedbáte opakování a máte mnoho položek k opakování, pomůže vám funkce Mercy
  10. Používání textových filtrů - pomocí textových filtrů můžete rychle zpracovávat texty ve svých souhrnech znalostí (např. nahradit nebo odstranit velký počet různých řetězců)
  11. Používání prvkových filtrů - pomocí prvkových filtrů můžete vyhledat prvky splňující určitá kritéria
  12. Zjištování obtížné látky - pomocí View : Special : Leeches můžete rychle zjistit nejobtížnější prvky v souhrnu znalostí (vědomostním systému)
  13. Překlady vědomostních systémů do jiných jazyků - svůj vědomostní systém můžete snadno přeložit do jiného jazyka
  14. Překlad uživatelského rozhraní SuperMemo - uživatelské rozhraní SuperMemo můžete přeložit do svého rodného jazyka během několika minut
Požadavek:

Kdybyste si v tomto oddíle rádi prečetli článek na určité téma, napište nám prosím (anglicky) na webmaster@supermemo.com nebo česky na elk@supermemo.cz .

****


Princip

Obsah :
Obecné principy SuperMemo
Problém zapomínání

Všimli jste si už, že brzy po naučení nějaké nové studijní látky si z ní pamatujete jen velmi málo? Čím méně máte příložitostí přezkoušet si, co jste se naučili, tím vyšší je rychlost, kterou se nové vědomosti vypařují z vaší paměti. Již dlouho je známo, že repetitio mater studiorum est (latinsky: opakování je matka moudrosti (dosl. učení)). Jinými slovy, nejlepší cesta k pamatování je opakování naučené látky. Můžete však zjistit, že je dosti frustrující, musíte-li opakovat starou látku, zatímco vaši učitelé po vás stále žádají, abyste se učili novou a novou látku. Kdy však najdete čas pro obojí. Obvykle najdete nějaký kompromis. Většinu času strávíte učením nových věcí, přičemž zapomínáte, co jste se naučili dříve a opakujete si jen tu látku, kterou právě potřebujete pro zkoušky nebo jiné příležitosti. Důsledkem je katastrofa! Většina vašeho času je ztracena, protože zapomenete většinu z toho, co jste se naučili. Můžete přirozeně získat obecné pochopení studovaného jevu, ale pochopení je také založeno na paměti a je stejně prchavé. Je jen otázkou času, kdy nenávratně ztratíte většinu toho, co jste do učení investovali. Je výše uvedená situace nevyhnutelná? Každodenní tlak nám opravdu nedovoluje opakovat to, co jsme se dříve naučili. Výukové systémy na celém světě jsou organizovány tak, že trestají ty, kteří nezvládnou novou látku. Jsme tlačeni do nesmyslné situace. Jsme opravdu nuceni mrhat svým časem ... čili svým životem. SuperMemo umožňuje několikanásobně snížit čas nutný pro opakování a může vyřešit některé z vašich problémů s učením.

A pokud nejste pod tlakem učení nové látky ... tím lépe. SuperMemo vám pomůže organizovat vaši paměť. I když se rozhodnete strávit jen 3 minuty denně učením!

SuperMemo řeší problém zapomínání

Jakmile se naučíte nějaký fakt, je nejlepší si svou paměť občerstvit krátce předtím, než dojde k zapomenutí. Předpovědět okamžik zapomenutí však může být velmi obtížné. Některá fakta zapomeneme rychleji, jiná mohou zůstat v naší paměti po celá léta. Naštěstí jsou v procesu zapomínání jisté pravidelnosti, které nám mohou pomoci optimalizovat doby opakování. Naučíte-li se souhrn látky s novými vědomostmi, nazývejme tyto kousky vědomostí položkami, můžete pozorovat pomalý ale trvalý pokles podílu položek, který si pamatujete. Použijete-li k vynesení křivky zapomínání počítač, můžete snadno předvídat, kdy bude daná část položek zapomenuta. Rozhodnete-li se, že si budete trvale pamatovat nejméně 90% látky, můžete se pokusit naplánovat svá opakování do okamžiku, kdy si stále ještě pamatujete 90% toho, co jste se naučili. Je známo, že většinu látky si budete pamatovat ještě za dobu dvakrát tak dlouhou, než byl zvolený interval. Neexistuje však žádný lepší způsob! Proces zapomínání má náhodný charakter a v okamžiku opakování nemůžete jednoduše říci, která položka vydrží déle a kterou zapomenete brzy. Situace bude ještě komplikovanější, když si uvědomíte, různé položky mají různou obtížnost a vyžadují různé intervaly opakování. Navíc položky, které již byly jednou nebo dvakrát opakovány, potřebují mnohem méně občerstvování, než ty, které jste se právě naučili.

Je toho na vás příliš? Nezoufejte. Nalezení pravidelností v procesu učení bylo věnováno mnoho úsilí. Výsledkem je, že byly vyvinuty účinné algoritmy, které je schopny rychle určit nejlepší možný interval pro opakování položky nezávisle na její obtížnosti a počtu předchozích opakováních. Tyto algoritmy jsou implementovány do programu SuperMemo. SuperMemo je program pro Windows (dostupný i na jiných platformách ), který bude řídit vaše opakování bez větší účasti z vaší strany. Není to bezbolestné řešení, protože vám nedovolí učit se bez úsilí. Může však být přísně vědecky demonstrováno, že SuperMemo pomáhá mnohonásobně zvyšovat rychlost učení . Umožňuje totiž těsně se přibližovat maximální přirozené schopnosti lidského mozku ukládat a uchovávat informace . V průběhu života vám SuperMemo umožní učit se 10-50krát rychleji než konvenčními metodami a dosahovat retence vědomostí 95%. SuperMemo minimalizuje účinky zapomínání a celkovou dobu potřebnou pro učení. Provádí se to plánováním opakování vědomostí v pečlivě určených intervalech zvaných optimální intervaly. Ty se vypočítají na základě dvou protichůdných kritérií:

  1. Intervaly by měly být co nejdelší, aby se dosáhlo nejmenší frekvence opakování a nejlépe se využil tzv. spacing efekt , který říká, že delší intervaly mezi opakováním, až po jistou mezní hodnotu, způsobují lepší zapamatování.
  2. Intervaly by měly být co nejkratší, aby bylo zajištěno, že si vědomost ještě stále pamatujeme.

V praxi se tato dvě kritéria převedou na následující:

Intervaly by měly být tak dlouhé, jak je to nutné pro to, aby vybraný malý zlomek informací nebyl zapomenut. Tento zlomek, zvaný index zapomínání , se může měnit od 3% pro pomalejší a velmi přesné učení do 20 % pro bleskové učení charakterizované nižší retencí vědomostí.

Jestliže index zapomínání klesne pod 3%, rychlost osvojování vědomostí se stane nepřijatelně nízká. Na druhé straně, rychlost osvojování vědomostí má vrchol při hodnotě indexu zapomínání asi 20 %. Nad touto hodnotou se jak retence, tak rychlost osvojování snižují . Všimněte si, že tradiční učení, v němž jsou opakování prováděna v náhodném čase, je možno přirovnat k optimalizovanému učení s indexem zapomínání nad 50%. Takové učení je nejen pomalé, ale především může být nepřijatelně nízká retence vědomostí a v důsledku toho si student místi důležitých věcí pamatuje jen věci, které jsou snadné k zapamatování. Protože optimální intervaly se pro jednotlivá pravidla a fakta, která je třeba se naučit, liší, SuperMemo potřebuje, aby studované vědomosti byly rozděleny na co nejmenší kousky zvané položky. Kdyby se položky musely opakovat kolektivně, např. jako celé kapitoly učebnice při tradičním učení, celkové optimální intervaly by musely být tak krátké, jak nutné pro nejobtížnější položku v systému. Tím by se učení stalo ještě méně efektivní než při učení klasickými metodami. Rozdělení vědomostí na malé kousky umožňuje programu SuperMemo určovat optimální intervaly pro každou položku. Jednoduchost položek je snad ještě důležitější než z cytofyziologických důvodů. Jednoduché položky umožňují plnou stimulaci pravých neuronových synapsí v pravý čas. Důsledkem složitých položek jsou řetězce různorodých nervových impulsům a tím nepředvídatelných složitých paměťových striktur na buněčné úrovni. Tím se optimalizace učení ztěžuje nebo dokonce zcela znemožňuje. Používání optimálních intervalů a jednoduchost položek jsou předpokladem pro rychlost a vysokou retenci. Rychlost učení však není nejdůležitějším prvkem vzdělávání. Nejdůležitější je kvalita vědomostí a jejich uplatňování. SuperMemo umožňuje učit se velmi rychle, ale výběr studované látky a její reprezentace je na uživateli.

Shrnutí
  1. Klíčem k efektivnímu učení je minimalizace počtu opakování nutných pro uchování vědomostí v paměti.
  2. SuperMemo minimalizuje čas potřebný pro učení určováním optimálních intervalů, které by měly uplynout mezi jednotlivými opakováními.
  3. Vědomosti studované pomocí SuperMemo musí být rozděleny na nejmenší možné kousky zvané položky
  4. Při používání SuperMemo nesmíte zapomínat na to, že kvalita učení bude záviset na výběru látky a způsobu jejího rozdělení na jednotlivé položky.

Viz také:

  • Forget about forgetting (populárně vědecký článek o podstatě SuperMemo)
  • Long-term learning process with SuperMemo (čísla popisující výsledky dlouhodobého používání SuperMemo)
  • Scientific conquest of forgetful memory (první článek o SuperMemo publikovaný v roce 1992)
  • Build your vocabulary with SuperMemo (jednoduchý článek o tom, jak SuperMemo pomáhá naučit se slovíčka)
  • Interview with the author of SuperMemo (1994)
  • Using SuperMemo without a computer
  • Algorithm used in SuperMemo (popis algoritmu používaného v SuperMemo pro dosažení optimálně rozloženého opakování)

Poznámky:

Retaining information (Uchovávání informací)

Musíte si pamatovat, že rychlost učení bude silně záviset na způsobu, jakým budou reprezentovány informace, tj. jak zformulujete látku používanou při opakování. Optimalizace reprezentací je zvláštní problém a tvrzení, že SuperMemo vám umožní učit se nejvyšší možnou rychlostí, byste měli chápat tak, že SuperMemo vám umožní učit se největší rychlostí možnou pro daný materiál, vaše mentální charakteristiky a vaše všeobecné podmínky pro učení. Reprezentace vědomostí má tak zásadní význam, že rozdíl v čase potřebném pro opakování může snadno dosáhnout poměru 1:100!!! Nejjednodušší pravidla reprezentace vědomostí: udržujte položky jednoduché, zajímavé a používejte mnemotechnické metody (tj. používejte obrazovou reprezentaci, živé příklady, metafory, přirovnání, mapy mysli atd.). Viz též: 20 rules of formulating knowledge in learning (20 pravidel pro formulaci vědomostí při učení).

Optimal interval (Optimální interval)

Jeden z nejdřívějších přístupů k určení optimálních intervalů byl popsán v: Wozniak, P.A., Gorzelanczyk, E.J., 1994, Optimization of repetition spacing in the practice of learning. Acta Neurobiologiae Experimentalis, Vol. 54, p. 59-62

Spacing effect (Intervalový jev)

Intervalový jev spočívá v efektivnějším tvoření paměťových vzpomínek při distribuované prezentaci stimulů v protikladu k hromadné prezentaci. Průkopnický článek o intervalovém jevu: Hintzman D.L. (1974) Theoretical implications of the spacing effect. Theories in cognitive psychology: The Loyola Symposium (Ed.R.L. Solso), p. 77-99

****


Otázka dne

Help (Nápověda) : Question of the Day (Otázka dne) je ekvivalentní tipu dne v jiných programech. Hlavní rozdíl je v tom, že tipy jsou formulovány ve formě otázka - odpověď a mohou být zavedeny do procesu učení jako obvyklé položky SuperMemo

Otázka dne nabízí následující volby:

  • Show Question of the Day on starting SuperMemo (Zobrazovat otázku dne při spuštění SuperMemo) - zatrhnete-li toto políčko, bude každá lekce se SuperMemo začínat Otázkou dne. To doporučujeme jak začátečníkům, tak těm, kteří ještě nejsou dobře obeznámeni s novými možnostmi SuperMemo
  • Next question (Další otázka) - zobrazit další otázku
  • Remember (Zapamatovat) - uvést právě zobrazenou otázku do procesu učení, tj. učit se ji jako jakýkoliv jiný prvek v SuperMemo
  • Delete (Vymazat) - nikdy již tuto otázku nezobrazovat, tj. vymazat ji z množiny otázek (místo delete by bylo možno použít i název dismiss, aby byla zřejmá analogie s funkcí Dismiss (Vynechat) v SuperMemo; všimněte si však, že Dismiss v SuperMemo nevymaže vynechané prvky )
  • Close (Zavřít) - zavřít dialogový panel Question of the Day (Otázka dne)

Otázky v Question of the Day jsou na rozdíl od tipů použitých v jiných aplikacích předkládány v logickém pořadí, tj. nikoliv náhodně. Protože tipy můžete vymazat nebo se je učit, nebude nikdy důsledkem nudné opakování.

Profesionální úroveň

Text všech tipů najdete v souboru <adresář supermemo>/bin/tips.txt

****


Recover (Zotavit)

Volba File (Soubor) : Recover (Zotavit) umožňuje zotavení z problémů integrity ve vašem systému vědomostí (vzniklých například fyzickým poškozením souborů systému vědomostí). Funkci Recover můžete rychle spustit pomocí Ctrl+F12 nebo kliknutím na ikonu "červený kříž" na rychlém nástrojovém panelu (horní strana hlavního okna ).

Všimněte si, že funkce Recover je dostupná jen v režimu úplného přístupu . Do tohoto režimu se přepnete pomocí Tools: Options nebo stisknutím Ctrl+P a zvolením Full access (Úplný přístup) na nabídce Data access (Přístup k datům) : Access mode (Režim přístupu). Implicitně se úplný přístup také zapne, když přejdete na profesionální´úroveň .

Problémy s integritou v systému vědomostí se mohou objevovat v případě poruch hardwaru nebo systémového softwaru. Vadné clustery, ztracené sektory, znehodnocené data atd. je často možno napravit záměnou postižených souborů (např. vadný soubor AVI atp.). Vyskytnou-li se však problémy v indexových souborech SuperMemo, v nichž jsou uložena optimalizační data používaná algoritmem optimálních intervalů , může problém napravit jen File: Recover.

Důležité! Nikdy nespouštějte funkci Recover, aniž byste předem zálohovali soubory systému vědomostí (např. pomocí File : Semi-Copy)!

Než začnete se zotavováním, zvolte odpovídající volby zotavení v dialogovém panelu Recovery Options (Volby zotavení) .

Funkce Recover nedokáže napravit některé typy chyb. Zde jsou uvedeny některé z nich:

  • poškození binárních souborů, např. BMP, WAV, AVI, EXE atd. Nahraďte tyto soubory z originálního CD-ROM nebo ze zálohy. Nemáte-li tyto soubory zálohovány, budete je muset odstranit vymazáním (Delete) v odpovídajícím registru nebo je znovu vytvořit.
  • poškození matic OF, RF, Cases atd. Tyto matice jsou uloženy v souboru s příponou KNO. V případě chyb naznačujících poškození těchto datových struktur použijte File : Reset: Optimization matrices. Ztratíte některá data shromážděná programem SuperMemo o vaší výkonnosti s danou učební látkou, ale budete moci obnovit práci bez ztráty procesu učení. Alternativně můžete obnovit soubor SM8OPT.DAT z některé z dřívějších záloh.
  • poškození textových souborů jako TRA, SCR, INI atd. Prohlédněte tyto soubory některým textovým editorem a opravte jejich obsah. Můžete rovněž editovat legální soubory TRA pomocí Tools: Options : Language : Localization table .
  • Další informace: Soubory používané programem SuperMemo

Poznámka: Narazíte-li na problém, který nelze napravit pomocí File : Recover (s výjimkou výše uvedených), oznamte nám to prosím na support@supermemo.com (vytvořte prosím záložní kopii poškozeného systému vědomostí , např. pomocí File : Semi-Copy).

****


Volby Zotavit

Voby funkce Recover (Zotavit)

Po zvolení File (Soubor) : Recover (Zotavit) se před začátkem kontroly systému vědomostí a jeho zotavování zobrazí dialogový panel Recovery Options (Volby zotavení).

Volby zotavování jsou:

  • Basic recovery (Základní zotavení) - rychlá kontrola integrity procesu učení v aktuálním systému vědomostí
  • Rebuild registries (Znovu vytvořit registry) - zatrhnete-li toto políčko, všechny registry v systému vědomostí se znovu vytvoří a porovnají se starými verzemi. Všechny rozdíly budou ohlášeny jako chyba. Tento trvá dosti dlouho, proto jej spouštějte, jen když máte vážné problémy s registry nebo když připravujete svůj systém pro zveřejnění a chcete se ujistit, že jeho integrita je úplná
  • Verify filespace (Ověřit prostory souborů) - zatrhnete-li toto políčko, všechny soubory v sekundární paměti (tj.adresář ELEMENTS) budou zkontrolovány, mají-li správná jména, číslování, duplikáty, prázdné sloty atd. Jestliže jste udělali chybu při zálohování adresáře ELEMENTS nebo jste experimentovali s ručním sloučením dvou verzí ELEMENTS ze dvou různých verzí téhož systému vědomostí a mohlo dojít k nějakým problémům s integritou při pojmenování souborů
  • Rebuild lexicon (Znovu vytvořit lexikon) - pokud jste provedli rozsáhlé úpravy lexikonu a chtěli byste se vrátiti k původnímu úplnému lexikonu, můžete zatržením tohoto políčka lexikon znovu zkompilovat
  • Verify translation (Ověřit překlad) - tuto volbu můžete použít pro ověření, že váš překladový registr je správně seřazen a že všechny textové komponenty v systému vědomostí jsou přeloženy nebo ohlášeny jako komponenty s chybějícím překladem

Pro rychlou kontrolu svého procesu učení nezatrhujte žádná políčka z Recovery Options. Naopak, chcete-li rychle provést maximální kontrolu a zotavení systému vědomostí, zvolte Check all (Zkontrolovat vše) a pak OK.

****


Technický popis

ABC Rady a tipy Přehledy Popis Slovník pojmů Podpora
Obsah : Technický popis
Nápověda SuperMemo 98: Technický popis

Minimální požadavky

Instalace SuperMemo

Registrace SuperMemo

Okna používaná v SuperMemo

  • Hlavní okno
    • Nástrojový panel
    • Stavový pruh
  • Okno prvku
    • Navigační nástrojový panel
    • Vytvářecí nástrojový panel
    • Editační nástrojový panel
  • Okno obsahu
    • Editační nástrojový panel
  • Registrové okno
  • Okno prohlížeče
  • Okno statistiky
  • Okno dat prvků

Hlavní nabídka

Kontextově závislé místní nabídky

  • Místní nabídka prvku
  • Místní nabídka komponenty
  • Místní nabídka obsahu
  • Místní nabídka registrů
  • Místní nabídka prohlížeče

Klávesové zkratky

Popisy pro pokročilé

  • Volby funkce Recovery (Zotavení)
  • Přetečení mezního počtu dceřinných prvků
  • Soubory používané programem SuperMemo
  • Vydejte svůj vlastní CD-ROM na bázi SuperMemo

***


Registrace

Postup při registraci

Jestliže vás SuperMemo požádá o heslo, nebo je-li pod navigačním nástrojovým panelem červený registrační pruh, používáte blokovanou kopii SuperMemo. Pro odblokování použijte heslo obdržené po zaslání objednávky a uhrazení registračního poplatku. Zadejte je ve File (Soubor): Registration (Registrace): Input password (Zadejte heslo) nebo proveďte registrační postup popsaný níže.

Červený registrační pruh vypadá např. takto:

Chcete-li zaregistrovat SuperMemo, klikněte sem (spotřebovaný kredit: 23 %)

Používáte-li blokované SuperMemo, máte k dispozici kredit 100 bodů. Jakmile kredit spotřebujete, budete požádáni o zadání registračního hesla. Spotřebovaný kredit je zobrazen v závorce na červeném registračním pruhu (viz výše).

SuperMemo si můžete zaregistrovat u distributora pro Českou republiku nebo distributora pro Slovenskou republiku a stát se registrovaným uživatelem SuperMemo:

  1. Klikněte na červený registrační pruh. Otevře se registrační dialogový panel (tento panel můžete otevřít také tak, že (1) zvolíte Register (Registrovat), když vás SuperMemo žádá o heslo nebo (2) zvolíte File: Registration: Request password)
  2. Vyplňte pole Jméno (Name), Stát (Country) a Telefon (Phone)
  3. Klikněte na Registrovat (Register)
  4. Na otázku Poslat nyní e-mail (Send e-mail now)? odpovězte Ano (Yes).

Prostřednictvím těchto čtyř kroků pošlete e-mail se svými registračními údaji na adresu register@supermemo.cz . Jako odpověď dostanete další pokyny (jak za SuperMemo zaplatit, jak získat registrační heslo a jak heslo zadat).

Možná se divíte, proč je mechanismus registrace tak složitý. Výhodou je, že....

můžete volně šířit samotné SuperMemo mezi svými kolegy, aniž byste porušili svou uživatelskou licenci!

Důležité! Rozšiřovat můžete pouze následující tři soubory:

  • sm98.exe ( SuperMemo 98 )
  • \bin\tips.txt (soubor s otázkami pro Question of the Day (otázku dne))
  • \bin\smhelp.chm ( soubor nápovědy )

Zejména nesmíte šířit své vědomostní systémy ( collections ). V těch jsou obsažena vaše registrační data. Jejich šířením spolu se SuperMemo porušíte svou uživatelskou licenci.

Chcete-li šířit své vlastní vědomostní systémy, musíte před umístěním svého vědomostního systému na web nebo před jeho předáním kolegům použít File: Registration: Unregister.

Časté otázky

(Michael Duggan, Canada, Oct 7, 1998)
Otázka:
Mám potíže s odblokováním SuperMemo. Dostanu dialogový panel, který se mě ptá, zda chci nyní poslat e-mail. Kliknu na Yes. Ale místo odeslání mých informací pro registraci dostanu chybové hlášení "Cannot send e-mail - user abort" (Nemohu odeslat e-mail - zrušeno uživatelem). Jak se mám zaregistrovat?
Odpověď:

  1. Všichni uživatelé, kteří objednají SuperMemo, jsou zaregistrováni automaticky
  2. Chybové hlášení může vyplývat z problémů v komunikaci mezi SuperMemo a vaším softwarem pro e-mail. Jestliže na otázku Send e-mail now?odpovíte No, SuperMemo vygeneruje textový soubor, který můžete poslat e-mailem na register@supermemo.cz

(Ken Little, USA, Nov 11, 1998)
Otázka:
ČetI jsem, že jsem automaticky zaregistrován při koupi pomocí kreditní karty; nedostal jsem však heslo pro odstranění červeného pruhu. Napište mi prosím, co mám dělat. Nemohu čekat s používáním programu.
Odpověď:

  1. Jste automaticky zaregistrován v naší databázi zákazníků a můžete ihned začít používat program.
  2. Během jednoho pracovního dne dostanete další pokyny, které vám pomohou odstranit červený pruh

(Thomas Niedermaier, Austria, Nov 16, 1998)
Otázka:
Poslali jste mi e-mail s heslem pro odblokování SuperMemo, ale kam je zadám? Když kliknu na červený pruh, SuperMemo mě požádá o poslání e-mailu.
Odpověď:
V pokynech, které jste dostal, je uvedeno, že pro zadání hesla můžete použít File (Soubor) : Registration (Registrace): Input password (Zadat heslo).

***


Registry

Okno registrů

Registry jsou setříděné množiny objektů používaných v SuperMemo, například textů, obrazů, zvuků, fontů atd.
Používáním registrů se v SuperMemo zmenšuje celková velikost souhrnů vědomostí a usnadňuje se opakované používání objektů již zavedených do příslušného vědomostního systému. Více informací o registrech najdete v oddíle Používání registrů .

Všechny existující registry jsou dosažitelné v podnabídce Search (Vyhledat) hlavního okna .
Okno registrů se používá pro přístup k individuálním členům registru a skládá se z následujících tabulí:

  • nadpis (nadpis okna) - název registru a celkový počet členů registru
  • nástrojový panel (nahoře) - tlačítka umožňující volbu nejčastěji používaných operací pomocí myši
  • editační pole (pod nástrojovým panelem) - pole používané pro doplňkové vyhledávání, tj. vyhledávání členů napsáním počátečních písmen jejich jmen
  • seznam jmen členů (levá strana okna) - abecední seznam jmen jednotlivých členů registru
  • objektové pole (pravá horní část okna) - pole, které se používá pro zobrazení objektu právě vybraného v seznamu členů (vlevo). V některých registrech je toto pole prázdné (např. zvukový registr, šablonový registr, programový registr atd.) nebo je rozděleno na dvě části (např. v textovém registru se zobrazují překlady textů, v lexikálním registru se zobrazuje fonetický přepis jednotlivých slov, v překladovém registru se zobrazují originální texty atd.)
  • seznam prvků (vpravo dole) - po kliknutí na tlačítko List (Seznam) na spodní straně okna registru se seznam prvků vyplní všemi prvky, které používají daný člen registru . Je-li počet prvků používajících člen větší než maximální počet povolený v SuperMemo, zobrazí se jen podmnožina prvků
  • stavový pruh (spodní část okna nad editačními tlačítky) - informace o právě vybraném členu: registrový index (tj. poloha členu registru v registru), počet prvků používajících člen, fyzická poloha v registru , počet tzv. "filespace slot" (pokud existují) a cesta k souboru členu registru (je-li relevantní). "filespace slot" je číslovaná poloha souboru v adresáři elements (prvky) . První soubor dostane slot 1, druhý slot 2 atd. (např. 1.bmp, 2.htm, 3.wav atd.).
  • editační tlačítka (spodní část okna):
    • List (Seznam) - vytvořit seznam prvků, které používají právě vybraný člen registru (seznam se zobrazí v seznamu prvků v pravé dolní části okna)
    • Go to (Přejít na) - přejít na první prvek používající právě vybraný člen registru
    • Browse (Prohlížet) - zobrazit všechny prvky používající právě vybraný člen registru v prohlížeči prvků . Všimněte si, že Browse button (Tlačítko prohlížet) na nástrojovém panelu je možno použít pro zobrazení všech prvků, které používají všechny členy registru náležející do aktuální podmnožiny
    • Link (Propojit) - propojit právě vybraný člen registru s požadujícím zdrojem (např. zvolíte-li Links (Propojení): Registry member (Člen registru) na místní nabídce zvukové komponenty , komponenta se propojí se zvukovým objektem asociovaným se členem zvukového registru vybraného v okamžiku stisknutí Link). Ze sémantických důvodů se tlačítko Link v registru šablon nazývá Apply (Aplikovat) (šablony se nepropojují, nýbrž aplikují na zdrojový prvek)
    • Add (Přidat) - přidat do registru nový člen registru
    • Rename (Přejmenovat) - změnit jméno právě vybraného členu registru
    • Delete (Vymazat) - vymazat právě vybraný člen registru. Všimněte si, že asociovaný objekt registru, např. zvukový soubor, font atd. bude rovněž vymazán (pokud není uložen na CD-ROM)

Profesionální úroveň

Klinutím pravým tlačítkem myši na okno registru se otevře místní nabídka registrů s pokročilými operacemi s registry.

Časté otázky

(Volker Goretzki, Germany, May 6, 1997)
Otázka:
Rád bych ze souhrnu vědomostí odstranil všechny výskyty řetězce 'xxxx'. Jaký je nejjednodušší způsob?
Odpověď:
(1) Zvolte Search (Vyhledat) : Text (Text), (2) zvolte v nabídce Find and replace (Najít a nahradit), např stisknutím Ctrl+R, (3) do pole Find what (Najít co) napište 'xxxx', (4) pole Replace with (Nahradit čím) ponechejte prázdné a (5) zvolte Replace All (Nahradit vše)

(Dusko Ivanisevic, New Zealand, Oct 1, 1998)
Otázka:
Jak mohu k některým slovům přidávat fonetický přepis?
Odpověď:
Stiskněte Ctrl+Alt+P a napište slovo a jeho přepis. Pokud se dialogový panel přepisu neobjeví, nezvolil jste fonetický přepis v Options (Volby) . V takovém případě proveďte následující kroky:

  1. Zvolte Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis)
  2. Vyberte hotový soubor přepisů nebo napište jméno pro nový registr fonetického přepisu (v posledním případě budete tvořit registr fonetického přepisu od začátku)
  3. V případě potřeby zvolte vlevo Font pro výběr fontu fonetického přepisu (např. font IPA dostupný z Advanced English )
  4. Jakmile se dané slovo objeví na obrazovce, převeďte všechny texty na fonetický přepis stisknutím Alt+Y (nebo použijte zobrazení fonetického přepisu pomocí myši).

****


Nabídka Registry

Místní nabídka registrů

Místní nabídka registrů obsahuje nejdůležitější operace dostupné z nabídky Search (Vyhledat) . Tato nabídka se otvírá stisknutím Alt+F10 nebo kliknutím pravým tlačítkem na okno registru .

Místní nabídka registrů obsahuje následující volby:

  • View (Zobrazit)
    • List elements (Seznam prvků) - vytvořit seznam všech prvků používajících právě vybraný člen registru
    • View element (Zobrazit prvek) - dát první prvek používající právě vybraný člen registru do okna prvku
    • Go to element (Přejít na prvek) - umístit okno prvku do popředí a provést View element (Zobrazit prvek)
    • Random pick (Náhodný výběr) - skočit na náhodně vybraný člen registru v aktuální podmnožině registru . Tato volba je velmi cenná pro velmi rychlé prohlížení obsahu registru. Pro provedení Random pick můžete použít F11
    • Clear - tato volba, obvykle prováděná pomocí Esc, je užitečná při zpětném sledování operací v okně registru. Pořadí akcí prováděných příkazem Clear:
    1. přeskočit ze seznamu prvků na seznam členů registru (je-li ohnisko na seznamu prvků)
    2. přeskočit z editačních polí objektu na seznam členů registru (je-li ohnisko na jednom z editačních polí)
    3. Přeskočit ze seznamu členů na editační stahovací seznam (combo-box) v horní části okna registru (je-li ohnisko na seznamu členů)
    4. Vynulovat obsah editačního stahovacího seznamu v horní části, je-li ohnisko na editačním stahovacím seznamu
    5. zavřít okno registru, je-li ohnisko na editačním stahovacím seznamu a seznam je prázdný
    4.
  • Edit (Editovat)
    • Edit text - editovat text právě zobrazený v textovém registru. Tato volba se nejčastěji provádí pomocí Ctrl+E
    • Edit translation (Editovat překlad) - editovat překlad odpovídající právě zobrazenému členu textového registru (Ctrl+T). Všimněte si, že význam těchto příkazů v překladových registrech je opačný a Edit text se skutečně použije pro editaci překladu
    • Copy path (Kopírovat cestu) - okopírovat cestu k souboru odpovídajícímu aktuálnímu členu registru do schránky
  • Search and replace (Vyhledat a nahradit)
    • Find (Najít) - najít všechny členy v aktuální podmnožině registru , jejichž jména obsahují daný řetězec. Umístit výsledky vyhledávání do nově vytvořené podmnožiny registru . Pro prohledávání všech členů registru (na výskyt řetězce) použijte zkratku Ctrl+S. Použijte ji také pro vyhledávání s logickou funkcí AND.
    • Find first (Najít první) - najít první člen registru v aktuální podmnožině, jehož jméno obsahuje daný řetězec. Vyhledávání začíná členem, který následuje po právě vybraném členu. Klávesová zkratka pro Find first, Ctrl+F, je zde velmi užitečná.
    • Find next (Najít další) - opakovat poslední operaci Find first (vyhledávání můžete opakovat stisknutím F3)
    • Find and replace (Najít a nahradit) - najít členy v aktuální podmnožině registru , jejichž jména obsahují daný řetězec, a nahradit tento řetězec jiným řetězcem. Tuto operaci můžete opakovat na všech jednotlivých členech s individuálním potvrzením, nebo nahradit všechny řetězce naráz. Upozornění: všechny jména členů registru musí být jednoznačná, jestliže vaše operace náhrady vygeneruje jméno, které již existuje, nové jméno bude programem SuperMemo modifikováno tak, aby bylo jednoznačné. Obvykle to vede k výskytu nesmyslných znaků na konci nového jména
    • Apply filter (Použít filtr) - zpracovat texty v aktuálním registru pomocí filtrového souboru (např. nahradit množinu řetězců jinou množinou řetězců, odstranit ohraničené poznámky atd.)
  • Browse current (Prohlížet aktuální) - umístit všechny prvky , které používají právě vybrané členy registru, do prohlížeče prvků
  • Browse all (Prohlížet vše) - umístit všechny prvky, které používají všechny členy v aktuální podmnožině , do prohlížeče prvků
  • Import files (Importovat soubory) - importovat množinu souborů do registru. Například máte-li množinu hotových bitmapových nebo zvukových souborů, můžete je všechny importovat do obrazového, resp. zvukového registru, než je použijete ve svých prvcích.
  • Export as text (Exportovat jako text) - exportovat všechna jména členů registru do textového souboru. Nejčastěji to budete provádět pro kontrolu obsahu registru pomocí svého oblíbeného programu pro kontrolu pravopisu
  • Import text (Importovat text) - importovat text se jmény členů registru vygenerovaný operací Export as text (viz výše). Například po kontrole pravopisu
  • Tools (Nástroje)
    • Play (Přehrát) - přehrát zvuk nebo video odpovídající aktuálnímu členu registru ve zvukovém registru nebo video registru
    • Sort for frequency (Seřadit podle frekvence) - seřadit registr podle počtu prvků používajících jednotlivé členy registru
    • Sort for priority (Seřadit podle priority) - seřadit registr podle priority členů. Priorita je zde určena poměrem (počet uživatelů)/(velikost souboru). Tato volba je užitečná, chcete-li najít nejméně používané členy, které zabírají nejvíce místa (například před vydáním svého souhrnu vědomostí na CD-ROM)
    • Internalize files (přesunout soubory na interní paměť) - přesunout všechny soubory spojené s registrem ze sekundární paměti do primární paměti . Externí soubory, tj. soubory neasociované se souhrnem vědomostí, budou rovněž přesunuty (externí soubory jsou ty soubory, které jste propojili pomocí Links (Propojit): External file (Externí soubor) na místní nabídce komponenty ). Tuto volbu můžete například použít, když chcete urychlit přístup na malý systém rozšiřovaný na CD-ROM. Internalize files přesune všechny soubory z CD-ROM na pevný disk. Tak budete také moci vymazat cestu k sekundární paměti a úplně vyloučit používání CD-ROM
    • Recover (Zotavit) - obnovit dvojité registry. Dvojitý registr je dvojice registrů, v nichž každý člen jednoho registru ukazuje na jeden nebo několik členů druhého registru. Například registr fonetického přepisu je dvojitý registr a skládá se ze dvou registrů: slov a přepisů slov
    • Compute files size (Vypočítat velikost souborů) - vypočítat velikost všech objektových souborů spojených s registrem (např. bitmapových souborů, zvukových souborů, AVI souborů atd.)
    • Match to subset (Vybrat dle podmnožiny) - najít všechny členy registru , jejichž uživatelé patří do dané podmnožiny prvků
    • Select untranslated (Vybrat nepřeložené) - vygenerovat novou podmnožinu registru v textovém registru se všemi členy, které dosud nebyly přeloženy. Tato volba je užitečná, když překládáte svůj souhrn vědomostí a chcete mít rychle přeloženy ty texty, které dosud nemají překlad v překladovém registru
  • Subset (Podmnožina)
    • Previous subset (Předchozí podmnožina) - otevřít nadmnožinu aktuální podmnožiny registru ( Ctrl+Alt+Left )
    • Next subset (Následující podmnožina) - otevřít nejbližší podmnožinu aktuální podmnožiny registru (Ctrl+Alt+Right). Například provádíte-li vyhledávání s funkcí AND v registru pomocí Ctrl+S, můžete procházet všemi stádii vyhledávání pomocí Ctrl+Alt+Left a Ctrl+Alt+Right
    • Delete subset (Vymazat podmnožinu) - vymazat právě používanou registrovou podmnožinu (samozřejmě nemůžete vymazat první množinu obsahující celý registr)
  • Close (Zavřít) - zavřít okno registru

****


Nástrojový panel registrů

Nástrojový panel v okně registrů poskytuje rychlý přístup k nejčastěji používaným operacím:

Význam jednotlivých tlačítek:

  • Pop-up menu button (tlačítko místní nabídky) - otevřít místní nabídku, dostupnou také kliknutím pravým tlačítkem na okno registru
  • List button (tlačítko Seznam) - seznam uživatelů členu registru (vpravo dole)
  • Goto button (tlačítko Přejít na) - přejít na prvního uživatele právě vybraného členu registru
  • View button (tlačítko Zobrazit) - zobrazit první uživatele právě vybraného členu registru
  • Find button (tlačítko Najít) - najít podřetězce v aktuální podmnožině registru
  • Replace button (tlačítko Nahradit) - nahradit řetězce v aktuální podmnožině registru
  • Superset button (tlačítko Nadmnožina) - přesunout se na předchozí podmnožinu (pokud existuje). Například po vyhledávání v registru pomocí Ctrl+S jsou výsledky vyhledávání zobrazeny jako nová podmnožina registru. Zpět na rodičovskou podmnožinu se můžete přesunout kliknutím na tlačítko Superset nebo stisknutím Ctrl+Alt+Left
  • Subset button (tlačítko Podmnožina) - přesunout na následující podmnožinu (pokud existuje). Například po vyhledávání v registru pomocí Ctrl+S jsou výsledky vyhledávání zobrazeny jako nová podmnožina registru. Můžete znovu vyhledávat a vytvořit ještě další podmnožinu (vyhledávání s logickou funkcí AND). Mezi podmnožinami se můžete pohybovat stisknutím Ctrl+Alt+Left a Ctrl+Alt+Right
  • Random jump button (tlačítko Náhodný skok) - náhodně vybrat nový člen registru (např. za účelem rychlého prohlížení registru)
  • Font button (tlačítko Font) - změnit právě vybraný font (jen člen fontového registru)
  • Path button (tlačítko Cesta) - zobrazit cestu na vybraný objekt registru (např. obrazový soubor). Zobrazit dostupnost souboru v primární a sekundární paměti (liší-li se od primární paměti) a velikosti souborů
  • Transcription button (tlačítko Přepis) - poskytnout mapu znaků pro editaci registru fonetického přepisu (jen v registru fonetického přepisu)
  • Browse button (tlačítko Prohlížet) - dát všechny prvky používající aktuální vybranou podmnožinu členů registru do prohlížeče prvků (všimněte si, že tlačítko Browse (Prohlížet) dává do prohlížeče jen uživatele vybraného členu, kdežto tlačítko Browse na nástrojovém panelu dává do prohlížeče všechny uživatele všech členů aktuální podmnožiny)
  • Import button (tlačítko Import) - importovat soubory přímo do registru
  • Stretch button (tlačítko Roztáhnout) - roztáhnout obrazy tak, aby zcela zaplnily zobrazovací panel vpravo (jen v obrazovém registru)
  • Export button (tlačítko Export) - exportovat právě vybraný člen (pokud existuje)

Profesionální úroveň

Kliknutím pravým tlačítkem na okno registru se otevře místní nabídka registru s pokročilými operacemi pro registry.

****


Používání registrů

Registry v SuperMemo jsou univerzální úschovny pro objekty. Každý registr se skládá z množiny členů registru seřazených podle jejich jména. Například obrazový registr je množina obrazových členů, seřazených podle jmen obrazů odpovídajících jednotlivým obrazovým objektům uložených v daném souhrnu vědomostí. Používáním registrů SuperMemo minimalizuje prostor použitý multimediálními soubory tím, že každý objekt je v registru uložen jen jednou a je opakovaně používán jednotlivými prvky prostřednictvím přístupu do jednotlivých registrů. Například importujete-li obrazový soubor do obrazové komponenty daného prvku (pomocí Import file (Importovat soubor)), můžete později propojit jinou obrazovou komponentu s uloženým obrazovým objektem zadáním jeho registrového jména (pomocí Links (Propojení): Registry member (Člen registru) ). Implicitně je jméno totéž jako jméno původního obrazového souboru, avšak při importu je můžete změnit.

V SuperMemo se používají následující typy registrů:

  • lexikonový registr, v němž jsou uložena slova používaná v souhrnu vědomostí a udržován záznam o členech textového registru, které používají dané slovo. Lexikonový registr je dostupný pomocí Search (Vyhledat) : Find word (Najít slovo) nebo pomocí Search na navigačním nástrojovém panelu )
  • textový registr, v němž jsou uloženy všechny textové řetězce použité v souhrnu (včetně textů RTF, textů HTML a textů typu Spell-Pad). Textový registr je dostupný pomocí Search (Vyhledat) : Text
  • překladový registr, v němž jsou uloženy texty překladů odpovídající textovému v právě vybraném jazyce ( Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Collection translation (Překlad souhrnu)). Překladový registr, je-li vytvořen, je dostupný pomocí Search (Vyhledat): Other texts (Jiné texty): <Language> registry (zde <language> je název jazyka překladu, např. Czech, German atd.). Aktuální jazyk překladového registru je možno změnit pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Collection translation (Překlad souhrnu)
  • registr fonetického přepisu, což je jediný "dvojitý" registr, který se skládá ze dvou spojených registrů: jednoho, který obsahuje jednotlivá slova, a druhého, jenž obsahuje jejich odpovídající přepisy. Registr fonetického přepisu je dostupný pomocí Search (Vyhledat): Other texts (Jiné texty): Pronunciation by word (Výslovnost podle slov) (jednotlivá slova) nebo Search : Other texts: Pronunciation by sound (Výslovnost podle zvuku) (přepisy), je-li nainstalován. Registr přepisu vhodný pro daný jazyk můžete vybrat pomocí Tools : Options : Language : Phonetic transcription (Fonetický přepis)
  • obrazový registr, v němž jsou uloženy všechny obrazy použité v souhrnu (např. BMP, GIF, JPG atd.). Obrazový registr je dostupný pomocí Search (Vyhledat) : File (Soubor): Image (Obraz)
  • zvukový registr, v němž jsou uloženy všechny zvuky použité v souhrnu (např. WAV, MID, RMI atd.). Zvukový registr je dostupný pomocí Search (Vyhledat): File (Soubor): Sound (Zvuk)
  • video registr, v němž jsou uloženy videosoubory AVI. Video registr je dostupný pomocí Search (Vyhledat): File (Soubor): Video
  • registr OLE, v němž jsou uloženy Objekty OLE importované z jiných aplikací (například soubor MS Word nebo graf Excelu). Registr OLE je dostupný pomocí Search (Vyhledat) : File (Soubor): OLE object (Objekt OLE)
  • programový registr, v němž jsou uloženy externí binární soubory spouštěné vaším souhrnem vědomostí ( DLL a EXE ). Programový registr je dostupný pomocí Search (Vyhledat): File (Soubor): Program
  • skriptový registr, v němž jsou uloženy všechny skripty používané v souhrnu vědomostí. Skriptový registr je dostupný pomocí Search: File: Script
  • fontový registr, v němž jsou uloženy všechny neimplicitní fonty použité v souhrnu. Fontový registr je dostupný pomocí Search: Font
  • šablonový registr, v němž jsou uloženy všechny šablony definované v souhrnu vědomostí. Na rozdíl od jiných registrů nelze propojit šablonu s prvkem nebo komponentou. Šablona se na prvek aplikuje a nahradí obsah tématu nebo položky (viz: Používání šablon ). Šablonový registr je dostupný pomocí Search (Vyhledat): Template (Šablonu)

Nemá smysl, aby lexikonový registr obsahoval všechna slova použitá v souhrnu vědomostí. Rozdíl mezi lexikonovým registrem a zbývajícími registry spočívá v tom, že jednotlivá slova nejsou uložena jako propojení do registru; vymazání slova z lexikonového registru tedy nezpůsobí jeho vymazání ze souhrnu vědomostí. Toto slovo se stane nedostupné pro vyhledávání pomocí Search: Find word (Najít slovo) ( Ctrl+H ).

Překlady textů jsou rovněž uloženy jako registry. Jsou ekvivalentní textovým registrům a mohou být snadno nahrazeny okopírováním a přejmenováním registrových souborů (např. v adresáři registry nahradí příkaz copy German.* text.* všechny texty v souhrnu jejich německými překlady, za předpokladu, že registr German byl vytvořen jako překlad souhrnu, např. exportem v kódu ASCII z textového registru).

V komponentách, v nichž se používají jednotlivé objekty, jsou uloženy pouze odkazy na registrové objekty, nikoliv objekty samotné. Například ve zvukové komponentě může být uložen odkaz na zvukový registr obsahující její zvukový soubor a na textový registr obsahující její text. Tento přístup zajišťuje, že rozsáhlé objekty (např. videosoubory) mohou být opakovaně používány, aniž by se plýtvalo prostorem na disku. Pokaždé, když importujete nový objekt pomocí Import file (Importovat soubor) na místní nabídce komponenty , přidáváte jej do příslušného registru. Podobně, pokaždé, když napíšete nový text do textové komponenty, komponenty typu spell-pad (kontrola pravopisu) nebo zvukové komponenty, přidáváte ji do textového registru.

Když propojíte člen registru pomocí Links (Propojení): Registry member (Člen registru) , zvětší se počet odkazů tohoto členu o jedničku. Jinými slovy, SuperMemo ví, kolik komponent v souhrnu používá určitý člen. Vymažete-li poslední odkaz na určitý člen, tj. počet odkazů klesne na nulu, odpovídající registrový objekt se vymaže s potvrzením nebo i bez potvrzení. Například vymaže-li se poslední komponenta používající daný obraz, budete dotázáni, chcete-li obraz odstranit z obrazového registru. Avšak vymaže-li se ze souhrnu vědomostí poslední odkaz na daný text, odpovídající člen textového registru se vymaže bez potvrzení.

****


Přehled

Obsah (Contents): Přehled (Review)

Tlačítko Přehled (Review) na spodní straně okna obsahu je možno použít pro učení vybrané větve stromu vědomostí . Například jestliže váš systém vědomostí obsahuje větve Matematika, Fyzika, Chemie a Biologie, můžete se nejprve chtít učit Chemii, dříve než se budete učit ostatní předměty. V tom případě postupujte takto:

  1. Otevřte okno obsahu (např. kliknutím na Obsah (Contents) na Navigačním nástrojovém panelu na horní straně okna prvku )
  2. Najděte ve stromě vědomostí Chemii (otvírejte jednotlivé větve kliknutím na znaménko plus)
  3. Vyberte Chemii (např. kliknutím na ni)
  4. Klikněte na tlačítko Přehled (Review) na spodní straně okna obsahu

Funkce Přehled (Review) bude postupně procházet větve Chemie a nabízet vám k učení všechny čekající položky (tj. prvky, které jste se ještě neučili). Učení bude probíhat přesně stejně jako při stisknutí tlačítka Učit se (Learn) s tím rozdílem, že se budou brát v úvahu jen položky z Chemie.

Jakmile budou všechny prvky ve větvi Chemie probrány, funkce Přehled (Review) vás o této skutečnosti bude informovat a začne prohlížet všechny probrané prvky. Díky tomu můžete použít funkci Přehled (Review) i pro zopakování některé části látky před zkouškou. Pamatujte však, že všechny akce prohlížení provedené jinou metodou než SuperMemo (tj. jinou než pomocí Učit se (Learn) ) narušují algoritmus . Když si látku prohlížíte, SuperMemo bude mylně předpokládat, že si ji dobře pamatujete, a může stanovit intervaly.které jsou příliš dlouhé. V důsledku toho může naměřený index zapomínání podstatně vzrůst a vy můžete být zklamáni tím, jak málo si pamatujete.

Důležité! Nepoužívejte nadměrně funkce Review (Přehled) a Random test (Náhodný test), jestliže vám opravdu záleží na uchování vědomostí po celá léta!

***


Skripty

Psaní skriptů

Script components make it possible to use simple script language to play with components in a given element (and not only). This makes it possible to create interactive presentations, animation, video subtitling, etc.

To create a script do the following:

  1. create an element in the desired shape
  2. add a script component from the Compose toolbar
  3. right-click the component and choose Script on the pop-up menu
  4. write the script and choose OK

While writing the script, use the script editor’s pop-up menu that makes it possible to insert full command syntax into the editor (right-click the editor to open the pop-up menu).

For example, to repeatedly play music from a sound component designated by number tag 3, you could write:

PLAY 3
GOTO 1

To view component number tags click 148 speed-button on the Edit toolbar, or choose Component Order on the element pop-up menu . Note, that when you right-click within the element window , you will either open a component pop-up menu (if you click over a component) or element pop-up menu (when you click an empty area within the element).

The best way to learn more about scripts is to inspect script components within collections shipped with SuperMemo (e.g. Cross Country, Advanced English or Video English). Alternatively you can download a free collection Testing knowledge in SuperMemo from SuperMemo Library .

Note: apostrophe is reserved in scripts for delimiting string variables. If you need to include an apostrophe in a string, use a backquote instead. For example:

TEXTOUT 3 ‘I`m delighted to have met Monica’

Script commands used in SuperMemo

  1. To insert a comment into the script, put it in a separate line and precede it with a semicolon
    Syntax: ;<Comment>
  2. To display a given registry image in an image component use DISPLAY. Its first argument is the number of the image component in the element. Its second argument is the name of the image registry member
    Syntax: DISPLAY <Component> <Image Registry member>
  3. To start a Drag&Match exercise , use DRAGMATCH. For multiple labels and multiple images use
    Syntax: DRAGMATCH [<Label List>] [<Image list>]
    For example: DRAGMATCH [1,3,4,5] [6,7,8,9]
    For single image component with specified hit areas and multiple labels use
    Syntax: DRAGMATCH <Component> [<Label List>] [<Rectangle List>]
    For example: DRAGMATCH 1 [1,2] [(100,100,30,20),(150,200,50,20)]
    Use Edit Hit-Area on the image pop-up menu to determine the positions of rectangles without worrying about coordinates.
  4. To determine if labels erase background of the image on which they are dropped in Drag&Match exercises, use DRAGTEXTMODE
    Syntax: DRAGTEXTMODE OPAQUE|TRANSPARENT
  5. To display another element of the collection use ELEMENT with the number of the element as the argument
    Syntax: ELEMENT <Number>
  6. To change a font in a text, sound or Spell-Pad component, use FONT.
    Syntax: FONT <Component> <Font registry member>
  7. To execute a frame of an animation sequence, use FRAME. The <Component> argument specifies the image component within which the animation is executed (alternatively, BACKGROUND can be used to execute animation in element entire background). <Image Registry member> indicate the image that makes up the executed frame
    Syntax: FRAME <Component>|BACKGROUND <Image Registry member>
  8. To change the flow of script execution use GOTO with script label or script line as an argument:
    Syntax: GOTO <Label>|<Line>
  9. To hide a component use HIDE
    Syntax: HIDE <Component>
  10. To design Point&Click exercises use HITTEST. Use an image that displays the hit area as the first argument, and a list of points that specify the correct hit area.
    Syntax: HITTEST <Component> [<list of points: (x1,y1)(x2,y2), etc.>]
    For example: HITTEST 1 [(10,10),(100,10),(100,100),(10,100)]
    Use Edit Hit-Area on the image pop-up menu to determine the position of the hit area without worrying about coordinates. The hit area may include no more than five points
  11. To jump to a particular label in the script you need to define the label with LABEL.
    Syntax: LABEL <Name>
  12. To move a component to a new location use MOVE:
    Syntax: MOVE <Component> <X> <Y>
  13. To play a sound, video, script or execute a binary object, use PLAY:
    Syntax: PLAY <Component> <Registry member>
  14. To show a hidden component, use SHOW:
    Syntax: SHOW <Component>
  15. To play a sound or video without suspending the execution of the script use START.
    Syntax: START <Component>
  16. To stop the script use STOP.
    Syntax: STOP
  17. To display a particular text in a text component use TEXTOUT.
    Syntax: TEXTOUT <Component> ''<Text>''
  18. To change the display status of a component (from hide to show, or from show to hide), use TOGGLE.
    Syntax: TOGGLE <Component>
  19. To translate a text component to the currently selected translation language choose TRANSLATE (see Tools : Options : Language for interface and collection translation options).
    Syntax: TRANSLAT <Component>
  20. To play user recorded sound in the sound component use UPLAY (to display the recorder panel in sound components check Recorder on sound component pop-up menu )
    Syntax: UPLAY <Component>
  21. To suspend the execution of a script for a number of milliseconds use WAIT.
    Syntax: WAIT <Milliseconds>
  22. To suspend the execution of a script until a given frame is displayed in a video sequence, or until a given position is reached in a sound track, use WAITFRAME with the frame or position as an argument.
    Syntax: WAITFRAME <Component> <Frame>
  23. To suspend the execution of a script until a grade is provided (e.g. in Drag&Match exercises or Point&Click exercises ) use WAITGRADE.
    Syntax: WAITGRADE

***


ABC

Search (Vyhledat)

Podnabídka Search (Vyhledat) na hlavní nabídce nabízí následující volby:

  • Find elements (Najít prvky) - najít všechny prvky obsahující daný řetězec. Všimněte si, že některé řetězce mohou být zobrazeny pomocí obrazů nebo objektů OLE . Ty se při vyhledávání neobjeví. Výsledky vyhledávání se zobrazí v prohlížeči prvků . Jestliže prohlížeč ukončíte, můžete se k výsledkům posledního vyhledávání vždy vrátit pomocí View (Zobrazit) : Result (Výsledky). Řetězce nalezené při vyhlrdávání je možno zobrazit také v textovém registru jako první podmnožinu
  • Find texts (Najít texty) - najít textové řetězce v textovém registru , které obsahují daný podřetězec. Když textový registr zavřete, výsledky je možno později zobrazit přechodem na první podmnožinu v textovém registru (příkaz Search: Text následovaný Ctrl+Alt+Right ). Můžete také provádět vyhledávání s logickým operátorem AND zvolením Ctrl+S a vyhledáváním druhého řetězce
  • Find word (Najít slovo) - otevřít lexikonový registr, což umožňuje najít jednotlivá slova použitá v systému vědomostí (kromě slov použitých v bitmapových (rastrových) obrázcích nebo objektech OLE ). Všimněte si, že vypnete-li kompilaci lexikonu za chodu (např. pro urychlení SuperMemo), některá slova mohou ze seznamu zmizet!
  • Text - otevřít textový registr se všemi texty uloženými v systému vědomostí (k textům náleží následující komponenty : text, Spell-Pad, RTF, HTML text a zvuková komponenta)
  • Other texts (Jiné texty)
    • Translation (Překlad) - otevřít překladový registr (pokud existuje). Překladový registr se vybírá pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Collection translation (Překlad systému vědomostí
    • Pronunciation by word (Výslovnost podle slova) - otevřít "lexikální dvojče" registru fonetického přepisu (je-li načten). Registr fonetického přepisu se vybírá pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis)
    • Pronunciation by sound (Výslovnost podle zvuku) - otevřít "přepisové dvojče" registru fonetického přepisu (je-li načten). Registr fonetického přepisu se vybírá pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis)
    • Comment (Poznámka) - otevřít registr poznámek. Poznámky se přidávají k prvkům pomocí Comment na dialogovém panelu parametrů prvku v Edit: Element parameters ( Shift+Ctrl+P ) na místní nabídce prvku
  • Font - otevřít registr fontů
  • File (Soubor)
    • Image (Obraz) - otevřít obrazový registr
    • Sound (Zvuk) - otevřít zvukový registr
    • Video - otevřít videoregistr
    • Script - otevřít skriptový registr.Všimněte si, že můžete editovat skripty přímo ve skriptovém registru
    • Program - otevřít programový registr, tj. registr s objekty jako spustitelné soubory, DLL, soubory WinHelp (formát HLP) atd.
    • OLE Object - otevřít registrs OLE objekty vytvořenými v jiných aplikacích (např. MS Word, MS Excel atd.)
  • Template (Šablona) - otevřít šablonový registr
  • Go to element no (Přejít na prvek č.) - přejít na prvek daného čísla,tj. zobrazit jej v okně prvku . Všechny prvky mají jednoznačná čísla, která odpovídají jejich fyzickému umístění v systému vědomostí . Můžete také používat klávesovou zkratku Ctrl+G. Tuto zkratku můžete použít i pro zobrazení čísla právě zobrazeného prvku. Číslo právě zobrazenéhoprvku je také zobrazeno v nadpisu okna dat prvku a také v poli Number (Číslo) na dialogovém panelu parametrů prvku ( Shift+Ctrl+P ).

Časté otázky

(Volker Goretzki, Germany, May 6, 1997)
Otázka:
Rád bych odstranil všechny výskyty řetězce 'xxxx' ze systému vědomostí . Jaký je nejjednodušší způsob?
Odpověď:
(1) Zvolte Search : Text, (2) zvolte Find and replace (Najít a nahradit) na nabídce , např. stisknutím Ctrl+R, (3) do pole Find what (Najít co) napište 'xxxx' , (4) pole Replace with (Nahradit čím) ponechte prázdné, a (5) zvolte Replace All (Nahradit vše).


Nabídka Vyhledat

Nabídka Search (Vyhledat)

Podnabídka Search (Vyhledat) na hlavní nabídce má následující volby:

  • Find elements (Najít prvky) - najít všechny prvky obsahující daný řetězec. Všimněte si, že některé řetězce mohou být zobrazeny prostřednictvím obrazů nebo objektů OLE . Ty se ve vyhledaných prvcích nezobrazí. Výsledky vyhledávání se zobrazí v prohlížeči prvků . Jestliže prohlížeč opustíte, můžete se k výsledkům posledního vyhledávání vždy vrátit pomocí View (Zobrazit) : Result (Výsledek). Řetězce nalezené při vyhledávání je možno zobrazit též v textovém registru jako první podmnožinu .
  • Find texts (Najít texty) - najít všechny textové řetězce v textovém registru , které obsahují daný podřetězec. Když textový registr zavřete, můžete si výsledky později prohlížet přechodem na první podmnožinu v textovém registru (Search (Vyhledat): Text následované stisknutím Ctrl+Alt+Right ). Je také možno vyhledávat s logickou funkcí AND (AND-search) zvolením Ctrl+S a vyhledávat druhý řetězec z prvků vybraných prvním vyhledáváním.
  • Find word (Najít slovo) - otevřít lexikonový registr, který umožňuje najít jednotlivá slova použitá v systému vědomostí (kromě slov použitých v bitmapových (rastrových) obrazech nebo objektech OLE ). Všimněte si, že vypnete-li kompilaci lexikonu "za chodu" (např. pro urychlení SuperMemo), některá slova mohou v seznamu chybět!
  • Text - otevřít textový registr se všemi texty uloženými v systému vědomostí (texty jsou obsaženy v následujících komponentách : text, Spell-Pad, rich text, HTML text a zvukové komponenty).
  • Other texts (Jiné texty)
    • Translation (Překlad) - otevřít překladový registr (je-li zaveden). Překladový registr se volí pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Collection translation (Překlad systému vědomostí)
    • Pronunciation by word (Výslovnost podle slov) - otevřít slovní (lexikální) část dvojice registru fonetického přepisu (je-li zaveden). Registr fonetického přepisu se vybírá pomocí Tools (Nástroje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis).
    • Pronunciation by sound (Výslovnost podle zvuku) - otevřít přepisovou část dvojice registru fonetického přepisu (je-li zaveden). Registr fonetického přepisu se vybírá pomocí Tools (Nástorje) : Options (Volby) : Language (Jazyk) : Phonetic transcription (Fonetický přepis).
    • Comment (Poznámka) - otevřít registr poznámek. Poznámky se připojují k prvkům pomocí funkce Comment (Poznámka) na dialogovém panelu parametrů prvku v Edit (Editovat): Element parameters (Parametry prvku) ( Shift+Ctrl+P ) na místní nabídce prvku
  • Font - otevřít fontový registr
  • File (Soubor)
    • Image (Obraz) - otevřít obrazový registr
    • Sound (Zvuk) - otevřít zvukový registr
    • Video - otevřít video registr
    • Script - otevřít skriptový registr. Všimněte si, že skripty můžete editovat přímo ve skriptovém registru
    • Program - otevřít programový registr, tj. registr s objekty, jako jsou spustitelné soubory, DLL, soubory WinHelp (formát HLP) atd.
    • OLE Object - otevřít registr s objekty OLE vytvořenými v jiných aplikacích (např. MS Word, MS Excel atd.)
  • Template (Šablona) - otevřít šablonový registr
  • Go to element no (Přejít na prvek č.) - přejít na prvek s daným číslem, tj. zobrazit jej v okně prvku . Všechny prvky mají jedinečná čísla odpovídající jejich fyzickému umístění v systému vědomostí . Pro funkci Go to element no můžete použít zkratku Ctrl+G. Zkratku Ctrl+G můžete použít také pro zobrazení čísla právě zobrazeného prvku. Číslo právě zobrazeného prvku je také zobrazeno v nadpisu okna dat prvku a v poli Number dialogového panelu parametrů prvku ( Shift+Ctrl+P )

Časté otázky

(Volker Goretzki, Germany, May 6, 1997)
Otázka:
Rád bych ze svého systému vědomostí odstranil všechny výskyty řetězce 'xxxx'. Jaký je nejjednodušší způsob?
Odpověď:
(1) Zvolte Search : Text, (2) zvolte Find and replace na menu , např. stisknutím Ctrl+R, (3) do pole Find what (Najít co) napište 'xxxx', (4) pole Replace with (Nahradit čím) ponechte prázdné a (5) zvolte Replace All (Nahradit vše).

***


Klávesové zkratky

Klávesové zkratky používané v SuperMemo

Jednotlivé klávesy

  • A – Editovat první odpověď
  • E – Edit texty
  • Q – Editovat první otázku
  • Ins - Vložit prvek (v okně obsahu ) nebo Vybrat prvek (v prohlížeči )
  • Tab - Další ovládací prvek

Funkční klávesy

  • F1 - Help (Nápověda)
  • F2 - Přeložená nápověda
  • F5 - Klasické rozložení
  • F6 - Následující okno
  • F9 - Editovat soubor komponenty
  • F11 - Náhodné prohlížení nebo Náhodná změna (v registru nebo prohlížeči )
  • F12 - Recover (Zotavit)

Shift+klávesa

  • Shift+Tab - Předchozí ovládací prvek
  • Shift+F4 - Dlaždice svisle
  • Shift+F5 - Kaskáda
  • Shift+F6 - Předchozí okno

Ctrl+klávesa

  • Ctrl+Tab - Další okno
  • Ctrl+Del - Vymazat aktuální komponentu
  • Ctrl+F5 - Implicitní volba uživatele
  • Ctrl+F11 - Náhodné učení
  • Ctrl+A – Přidat novou položku (totéž jako Alt+N)
  • Ctrl+B - Tučný font
  • Ctrl+C - Kopírovat do schránky
  • Ctrl+D - Dismiss (Vynechat) (v okně prvku ) nebo Create new category (Vytvořit novou kategorii) (v okně obsahu )
  • Ctrl+E - Vstoupit do editačního režimu (v okně prvku )
  • Ctrl+F - Najít prvky (v hlavním okně) nebo Najít (v ostatních oknech)
  • Ctrl+G - Přejít na prvek s daným číslem (viz nadpis okna dat prvku )
  • Ctrl+H - Najít slovo
  • Ctrl+I - Kurzíva
  • Ctrl+K - Link registry member (Propojit člen registru)
  • Ctrl+L - Learn (Učit se)
  • Ctrl+M - Memorize (Probrat) / Commit (Zapamatovat)
  • Ctrl+N - Nový
  • Ctrl+O - Otevřít
  • Ctrl+P - Options (Volby)
  • Ctrl+Q - Importovat soubor (v komponentě ) (např. přidat zvuk ke zvukové komponentě)
  • Ctrl+R - Forget (Zapomenout) / Reset (Odložit)
  • Ctrl+S - Vyhledat texty obsahující daný řetězec (globálně nebo v registrech )
  • Ctrl+T - Editovat další komponentu
  • Ctrl+V - Vložit ze schránky
  • Ctrl+W - Zátěž
  • Ctrl+X - Vyjmout do schránky
  • Ctrl+Y - Mercy (Milost)

Shift+Ctrl+klávesa

  • Shift+Ctrl+Del - Vymazat právě zobrazený prvek (v okně prvku )
  • Shift+Ctrl+Tab - Předchozí okno
  • Shift+Ctrl+F5 - Uložit jako implicitní (rozložení oken)
  • Shift+Ctrl+C - Kopírovat
  • Shift+Ctrl+D - Přidat do závěrečného procvičování
  • Shift+Ctrl+F - Propojit registrový font (v textových komponentách) nebo Změnit font (v komponentách RTF)
  • Shift+Ctrl+K - Propojit externí soubor
  • Shift+Ctrl+L - Testovat cyklus opakování
  • Shift+Ctrl+N - Analýza
  • Shift+Ctrl+P - Editovat parametry prvku
  • Shift+Ctrl+O - Editovat pořadí komponent
  • Shift+Ctrl+S - Přidat sestru (v okně obsahu )
  • Shift+Ctrl+S - Zaměnit otázku a odpověď (v okně prvku )
  • Shift+Ctrl+T - Editovat předchozí komponentu (viz Ctrl+T)
  • Shift+Ctrl+W - Přepnout okno
  • Shift+Ctrl+X - Textový registr
  • Shift+Ctrl+Y - Kopírovat přepis
  • Shift+Ctrl+V - Prohlížet větev v okně obsahu
  • Alt+klávesa
    •
    • Alt+PgUp - Následující prvek ve stromě vědomostí (v okně prvku )
    • Alt+PgDn - Předchozí prvek ve stromě vědomostí (v okně prvku )
    • Alt+Home - První prvek ve stromě vědomostí (v okně prvku )
    • Alt+End - Poslední prvek ve stromě vědomostí (v okně prvku )
    • Alt+Up - Přetáhnout nahoru všechny komponenty v přetahovacím režimu (v okně prvku )
    • Alt+Left -Přetáhnout vlevo všechny komponenty v přetahovacím režimu (v okně prvku )
    • Alt+Right - Přetáhnout vpravo všechny komponenty v přetahovacím režimu (v okně prvku )
    • Alt+Down - Přetáhnout dolů všechny komponenty v přetahovacím režimu (v okně prvku )
    • Alt+F4 - Uknčit program (nebo zavřít právě aktivní okno)
    • Alt+F10 - Otevřít místní nabídku právě aktivního okna
    • Alt+F11 - Náhodný test nebo Obnovit náhodný test
    • Alt+A – Vpřed (opak Alt+B) nebo Zobrazit odpověď (během opakování)
    • Alt+B – Zpět (opak Alt+A)
    • Alt+C - Contents (Obsah)
    • Alt+D – Vynechat (Dismiss)
    • Alt+E – Nabídka Edit (Editovat)
    • Alt+F – Nabídka File (Soubor)
    • Alt+G – Zrušit známku
    • Alt+H – Nabídka Help (Nápověda)
    • Alt+L – Nabídka Learn (Učit se)
    • Alt+M – Zapamatovat / Probrat
    • Alt+O – Nabídka Tools (Nástroje)
    • Alt+P - Cesta v obsahu
    • Alt+R – Zapomenout / Odložit
    • Alt+S – Nabídka Search (Vyhledat)
    • Alt+T - Editovat název (v okně prvku nebo v okně obsahu )
    • Alt+U - Přeložit všechny textové komponenty v okně prvku
    • Alt+V – Nabídka View (Zobrazit)
    • Alt+W – Nabídka Window (Okno)
    • Alt+X - Následující prvek (v okně prvku ), jak je definován v místní nabídce tlačítka Next
    • Alt+Y - fonetický přepis všech textových komponent v okně obsahu

    Ctrl+Alt+klávesa

    • Ctrl+Alt+P - Přidat dvojici výslovnosti
    • Ctrl+Alt+S - Uložit aktuální prvek jako implicitní šablonu pro aktuální kategorii
    • Ctrl+Alt+U - Duplikovat prvek
    • Ctrl+Alt+Right - Změnit podmnožinu na vyšší (v okně registru )
    • Ctrl+Alt+Left - Změnit podmnožinu na nižší (v okně registru )
    • Ctrl+Alt+Up - Přesunout na mateřský prvek právě zobrazeného prvku (v okně prvku )
    • Ctrl+Alt+F10 - Otevřít místní nabídku právě aktivní komponenty
    • Ctrl+Alt+F12 - Zobrazit nebo skrýt SuperMemo

    ***


SM8

Obsah :
SuperMemo 8 pro Windows

SuperMemo 8 pro Windows je program pro učení s pomocí počítače. Používá řadu nedávno vyvinutých technologií, které umožňují zefektivnit proces učení. Může být používán individuálními studenty nebo autory výukových systémů. Poskytuje veškeré autorské prostředky potřebné pro vyvíjení atraktivních a účinných interaktivních hypermediálních kurzů a prezentací.

Nejdůležitější technologie použité v SuperMemo 8 jsou:

  • optimální intervaly mezi opakováním - SuperMemo 8 usnadňuje správnou reprezentaci látky určené k učení a umožňuje uživateli vytvářet jednoduché kvizové prvky založené na aktivním vybavování. Například dvojice otázka-odpověď, testy pravopisu, testy výslovnosti, testy s přetahováním a umisťováním, testy výběru z několika možností, mapy mysli, programované vyučovací procedury a mnoho dalších.
  • mnemotechnická hypermédia - SuperMemo 8 kombinuje všechny oblíbené počítačové formáty dat, např. HTML, grafiku, zvuk, animaci, video atd. Tyto formáty jsou rozšířeny programovatelností pomocí interpretovaných skriptových a binárních komponent vyvinutých pro procedurální učení (EXE nebo DLL). Všechny prvky zúčastňující se učení jsou umístěny ve stromové struktuře nazývané strom vědomostí , která zjednodušuje přístup k vědomostem a navigaci. Všechny komponenty včetně textu, zvuků, grafiky atd. mohou být propojovány pomocí tzv. hyperlinků (hyperpropojení) s jinými částmi studované látky.
  • lineární a selektivní režimy učení - při učení je možno postupovat v pořadí naprogramovaném autorem nebo v pořadí zvoleném studentem (např. režim výběru a učení, vyhledání a učení, náhodné učení atd.).
  • dva typy informací - striktně odděleny jsou informace určené pro učení a vědomosti určené pro zkoušení (opakování) studované látky. Navíc je možno zahrnout dostudované látky i informace sloužící jen jako referenční nebo poznámky.
  • atributy zpracování vědomostí - všechny části látky používané při učení jsou jasně označeny jako: (1) referenční látka, (2) nezpracovaná učební látka (neprobrané prvky) (seřazená podle priority učení), (3) zpracovaná látka (probrané prvky) (steříděné podle priority zkoušení). Program poskytuje množství statistických údajů, které ilustrují pokrok ve zpracování jednotlivých částí látky

Obecné kroky používané v SuperMemo 8

  • student nebo autor vytvoří souhrn stránek obsahující studovanou látku. V nejjednodušším případě jsou to otázky a odpovědi; tyto stránky však mohou obsahovat i grafiku, video, zvuk, speciální cvičení, referenční látku, spustitelné moduly, hyperpropojení, objekty OLE atd.
  • (volitelně) autor vytvoří strom vědomostí organizováním všech stránek do stromové struktury (tento strom je také možno použít pro automatickou tvorbu scénáře učení)
  • (volitelně) pro větší skupinu studentů nebo zákazníků může učitel nebo studenti sami vytvářet podmnožiny systému učení pro individuální použití jednotlivými studenty (včetně statistiky učení, editovatelné látky, individuálních poznámek a anotací atd.). Alternativním řešením je kopie sudované látky na CD-ROM
  • student provádí učení. Program může skrýt autorskou obálku za učebním kurzem. Díky tomu může student prakticky projít celým kurzem a znát přitom jen funkci tlačítka Učit se (Learn)

Poznámka: před vydáním kurzu na CD-ROM v SuperMemo 8 není žádná fáze kompilace. Autor může poskytnout studentům volnou ruku pro rozšiřování a zlepšování systému!

Důležité! SuperMemo 8 se ideálně hodí pro samouky. Všechny složitosti programu mohou být vynechány, stačí používat pouze dvě volby: (1) Přidat nový (Add new) , která do systému přidává nové prvky - dvojice otázka - odpověď, a (2) Učit se (Learn) , která umožňuje zkoušení zadané látky. Díky tomuto režimu se SuperMemo stalo nejpopulárnější softwarovou aplikací vyvinutou v Polsku.

Seznam nejvýznačnějších rysů SuperMemo 8

  • Standardní vlastnosti SuperMemo, které najdete také v dřívějších verzích (SuperMemo 8 je nadmnožinou SuperMemo 7 pro Windows ):
    • Možnost vytváření nezávisle pojmenovaných souhrnů studované látky nazývaných systémy vědomostí, souhrny vědomostí (knowledge collections), v dřívějších verzích databáze .
    • Algoritmus optimálních intervalů široce známý jako metoda SuperMemo se používá k výpočtu optimálních intervalů mezi opakováními konkrétních informací v procesu učení.
    • Obsažná statistika pro prohlížení procesu učení zahrnuje: denní a měsíční kalendář opakování, průměrný počet položek pro opakování na den, průměrnou dobu opakování, očekávaný počet opakování v budoucnu, rozdělení obtížnosti, rozdělení intervalů mezi opakováním atd.
    • Nástroje pro řízení procesu učení, např.: selektivní probírání a odkládání jednotlivých prvků, přerozdělování nevyřízených opakování atd.
    • Různé prohlížeče prvků (pro probrané prvky, obtížné prvky, podmnožiny prvků, prvky vybrané filtrem položek atd.)
    • Nástroje pro editaci prvků, např. pro operace se schránkami, duplikaci prvků atd.
    • Nástroje pro správu souborů systému vědomostí, jako Copy (Kopírovat), Delete (Vymazat), Move (Přesunout), Transfer (Přenést), Export, Import atd.
    • Rychlé vyhledávání textových podřetězců, vyhledávání se záměnou atd.
    • Proces zotavení pro záchranu poškozených souborů.
  • Nové vlastnosti SuperMemo 8 neobsažené v dřívějších verzích:
    • Moderní rozharní (MDI, nástrojové panely, místní nabídky, popisky, Otázka dne při spuštění, kontextová nápověda, konfigurovatelnost, automatické uložení konfigurace atd.)
    • Hypermédia (zvuk, grafika, animace, video, HTML, skripty, binární komponenty atd.) a všechny nástroje pro vytváření prvků systému vědomostí a změnu vlastností jednotlivých komponent (např. hyperpropojení, přiřazování registrů , barva, font, velikost, umístění,video, zvuk atd.)
    • Standardní navigační nástroje ( Obsah (Contents) , Search (Vyhledat), Back (Zpět), Forward (Vpřed), Historie atd.)
    • vědomosti, které mohou být organizovány do stromové struktury zvané strom vědomostí. Pro práci jen s určitými větvemi stromu vědomostí je k dispozici řada nástrojů.
    • Udržování objektových registrů s rychlým přístupem ke všem objektům v systému: textům, slovům, obrazům, fontům, skriptům, programům, překladovým řetězcům, přepisům atd. včetně přístupu ke všem prvkům používajícím určité objekty. Všechny registry včetně úplného lexikonu se aktualizují za chodu (tj. neexistuje žádná zvláštní vytvářecí operace). Registry jsou editovatelné.
    • Možnost skrytí autorské obálky SuperMemo za studovanou látku (tím jsou studenti vystaveni nejjednoduššímu možnému rozhraní ). Včetně režimů "jen čtení" a "jen učení" navíc k režimu úplného přístupu.
    • Prakticky neomezený počet prvků, který může být uložen v učebním kurzu.
    • Nástroje pro snadné vydávání kurzů a prezentací na CD-ROM (včetně zvlášť dostupné velmi příznivé licence pro samotné SuperMemo 8).
    • Značně zlepšený algoritmus optimálních intervalů mezi opakováním
    • Snadný import databází vytvořených v SuperMemo 7.
    • Export a import samotného procesu učení.
  • Zvláštní vlastnosti v SuperMemo 8:
    • programovatelnost (systémy vědomostí mohou být rozšiřovány pomocí skriptů a programových komponent napsaných v libovolném programovacím jazyce)
    • uživatelem definovaný stupeň pozornosti věnované jednotlivým prvkům nebo celým větvím stromu hierarchie. Změnou tzv. indexu zapomínání jednotlivých prvků je možno řídit pravděpodobnost jejich zapomenutí!
    • šablony prvků používané pro rychlé tvoření velkého počtu stránek navržených ve stejném stylu
    • interaktivní překlad celého kurzu do jiných jazyků a překlad rozhraní programu (řetězce překladu jsou uchovávány v překladovém registru podobně jako jiné objekty v systému)
    • uživatel si může nastavit podle svých požadavků zvukovou odezvu při učení
    • nástroje pro tvoření lexikálních databází spojených s daným kurzem
    • náhodné učení a náhodné prohlížení celého systému prvků v prohlížečích a v registrech
    • velký počet nových statistických parametrů dokumentujících pokrok v učení
    • ladicí verze usnadňují hledání chyb v systému
    • atd.

Další podrobnosti o SuperMemo 8 najdete v History of SuperMemo 8 Development (Historie vývoje SuperMemo) .

Minimální požadavky:

    • 486 DX
    • 4 MB RAM (doporučeno 8 MB)
    • 2,5 MB prostoru na pevném disku (další prostor bude potřebný pro systém vědomostí,který budete chtít vytvořit)
    • Windows 3.11, Windows 95 nebo Windows NT 4.0
    • doporučené rozlišení 800x600

Navíc může být užitečný následující hardware:

    • zvuková karta (při vývoji systémů vědomostí používajících zvuk nebo video, jako je např. Advanced English, Video English, Cross Country nebo Deine Chancen)
    • Jednotka CD-ROM (při používání věd. systémů šířených na CD-ROM, např. Advanced English, Video English, Cross Country nebo Deine Chancen)
    • 256 barev (při používání systémů vědomostí bohatých na grafiku.

***


SM98

Obsah
SuperMemo 98 pro Windows

SuperMemo 98 pro Windows je program pro učení pomocí počítače. Používá řadu technologií, které zefektivňují proces učení. Bůže být používán individuálními studenty nebo autory učební látky. Poskytuje veškeré autorské prostředky potřebné pro vytváření atraktivních a efektivních interaktivních hypermediálních kurzů a prezentací. Může vám pomoci zapamatovat si vše, o čem se domníváte, že byste si měli pamatovat. Ve svém základním režimu vyžaduje znalost pouze dvou operací: Přidávání nových prvků ( Add new ) (přidávání nové látky) a Učení ( Learn ) (učení a přezkušování látky)

Nejdůležitější technologie použité v SuperMemo 98

  • optimální intervaly (repetition spacing) - SuperMemo 98 zahrnuje metodu opakování v optimálních intervalech, moderní metodu rychlého učení založenou na výpočtu optimálních intervalů mezi opakováním . Tato metoda velmi zvyšuje rychlost učení nové látky a prakticky vylučuje problém zapomínání. Tato metoda je vlastnictvím SuperMemo World a byla hlavní oporou úspěchu SuperMemo v posledních osmi letech
  • aktivní vyvolání (active recall) - SuperMemo 98 usnadňuje správnou prezentaci látky použité při učení a pomáhá uživateli vytvářet jednoduché testovací prvky založené na aktivním vyvolání z paměti. Například dvojice otázka a odpověď, testy pravopisu, testy výslovnosti, testy s přetahováním na odpovídající místo, testy s kliknutím na správnou možnost, testy s výběrem z několika možností , mapy mysli, programované procedury učení a mnohé jiné.
  • mnemotechnická hypermédia - SuperMemo 98 kombinuje všechny oblíbené počítačové formáty dat, např. HTML, grafiku, zvuk, animaci, video atd. Tyto formáty jsou rozšířeny programovatelností pomocí interpretovaných skriptových a binárních komponent vyvinutých pro procedurální učení (EXE nebo DLL). Všechny prvky zúčastňující se učení jsou umístěny ve stromové struktuře nazývané strom vědomostí , která zjednodušuje přístup k vědomostem a navigaci. Všechny komponenty včetně textu, zvuků, grafiky atd. mohou být propojovány pomocí tzv. hyperlinků s jinými částmi studované látky.
  • lineární a selektivní režimy učení - při učení je možno postupovat v pořadí naprogramovaném autorem nebo v pořadí zvoleném studentem (např. režim výběru a učení, vyhledání a učení, náhodné učení atd.).
  • dva typy informací - striktně odděleny jsou informace určené pro učení a vědomosti určené pro zkoušení (opakování) studované látky. Navíc je možno zahrnout do studované látky i informace sloužící jen jako referenční nebo poznámky.
  • atributy zpracování vědomostí - všechny části látky používané při učení jsou jasně označeny jako: (1) referenční látka, (2) nezpracovaná učební látka (neprobrané prvky) (seřazená podle priority učení), (3) zpracovaná látka (probrané prvky) (seřazené podle priority zkoušení). Program poskytuje množství statistických údajů, které ilustrují pokrok ve zpracování jednotlivých částí látky.

Obecné kroky používané v SuperMemo 98

  • student nebo autor vytvoří souhrn stránek obsahující studovanou látku. V nejjednodušším případě jsou to otázky a odpovědi; tyto stránky však mohou obsahovat i grafiku, video, zvuk, speciální cvičení, referenční látku, spustitelné moduly, hyperpropojení, objekty OLE atd.
  • (volitelně) autor vytvoří strom vědomostí organizováním všech stránek do stromové struktury (tento strom je také možno použít pro automatickou tvorbu scénáře učení)
  • (volitelně) pro větší skupinu studentů nebo zákazníků může učitel nebo studenti sami vytvářet podmnožiny systému učení pro individuální použití jednotlivými studenty (včetně statistiky učení, editovatelné látky, individuálních poznámek a anotací atd.). Alternativním řešením je kopie sudované látky na CD-ROM
  • student provádí učení. Program může skrýt autorskou obálku za učebním kurzem. Díky tomu může student prakticky projít celým kurzem a znát přitom jen funkci tlačítka Učit se (Learn).

Poznámka: před vydáním kurzu na CD-ROM v SuperMemo 98 není žádná fáze kompilace. Autor může poskytnout studentům volnou ruku pro rozšiřování a zlepšování systému!

Důležité! SuperMemo 98 se ideálně hodí pro samouky. Všechny složitosti programu mohou být vynechány, stačí používat pouze dvě volby: (1) Přidat nový (Add new) , která do systému přidává nové prvky - dvojice otázka - odpověď, a (2) Učit se (Learn) , která umožňuje zkoušení zadané látky. Díky tomu se SuperMemo stalo nejpopulárnější softwarovou aplikací vyvinutou v Polsku. Viz: Abeceda SuperMemo 98

Obr. 1. SuperMemo v základním režimu lze zvládnout za několik minut

Seznam nejvýznačnějších rysů SuperMemo 98

  • Standardní vlastnosti SuperMemo najdete také v dřívějších verzích:
    • Možnost vytváření nezávisle pojmenovaných souhrnů studované látky nazývaných systémy vědomostí, souhrny vědomostí (knowledge collections).
    • Algoritmus optimálních intervalů široce známý jako metoda SuperMemo se používá k výpočtu optimálních intervalů mezi opakováními konkrétních informací v procesu učení.
    • Obsažná statistika pro prohlížení procesu učení zahrnuje: denní a měsíční kalendář opakování, průměrný počet položek pro opakování na den, průměrnou dobu opakování, očekávaný počet opakování v budoucnu, rozdělení obtížnosti, rozdělení intervalů mezi opakováním atd.
    • Nástroje pro řízení procesu učení, např.: selektivní probírání a odkládání jednotlivých prvků, přerozdělování nevyřízených opakování atd.
    • Různé prohlížeče prvků (pro probrané prvky, obtížné prvky, podmnožiny prvků, prvky vybrané filtrem položek atd.)
    • Nástroje pro editaci prvků, např. pro operace se schránkami, duplikaci prvků atd.
    • Nástroje pro správu souborů systému vědomostí, jako Copy (Kopírovat), Delete (Vymazat), Move (Přesunout), Transfer (Přenést), Export, Import atd.
    • Rychlé vyhledávání textových podřetězců, vyhledávání se záměnou atd.
    • Proces zotavení pro záchranu poškozených souborů
  • Vlastnosti SuperMemo 98 neobsažené v SuperMemo 7 :
    • Moderní rozhraní (MDI, nástrojové panely, místní nabídky, popisky, Otázka dne při spuštění, kontextová nápověda, konfigurovatelnost, automatické uložení konfigurace atd.)
    • Hypermédia (zvuk, grafika, animace, video, HTML, skripty, binární komponenty atd.) a všechny nástroje pro vytváření prvků systému vědomostí a změnu vlastností jednotlivých komponent (např. hyperpropojení, přiřazování registrů , barva, font, velikost, umístění,video, zvuk atd.)
    • Standardní navigační nástroje ( Obsah (Contents) , Search (Vyhledat), Back (Zpět), Forward (Vpřed), Historie atd.)
    • vědomosti, které mohou být organizovány do stromové struktury zvané strom vědomostí. Pro práci jen s určitými větvemi stromu vědomostí je k dispozici řada nástrojů.
    • Udržování objektových registrů s rychlým přístupem ke všem objektům v systému: textům, slovům, obrazům, fontům, skriptům, objektům OLE, programům, překladovým řetězcům, přepisům, souborům HTML atd. včetně přístupu ke všem prvkům používajícím určité objekty. Všechny registry včetně úplného lexikonu se aktualizují za chodu (tj. neexistuje žádná zvláštní vytvářecí operace). Registry jsou editovatelné.
    • Možnost skrytí autorské obálky SuperMemo za studovanou látku (tím jsou studenti vystaveni nejjednoduššímu možnému rozhraní ). Včetně režimů "jen čtení" a "jen učení" navíc k režimu úplného přístupu.
    • Prakticky neomezený počet prvků, který může být uložen v učebním kurzu.
    • Nástroje pro snadné vydávání kurzů a prezentací na CD-ROM (včetně zvlášť dostupné velmi příznivé licence pro samotné SuperMemo 98).
    • Značně zlepšený algoritmus optimálních intervalů mezi opakováním (rovněž s možností udělení licence pro vývojáře software v podobě zvláštního modulu DLL).
    • Export a import samotného procesu učení.
  • Nové vlastnosti SuperMemo 98, které nejsou v SuperMemo 8 :
    • rychlejší 32bitová aplikace podporující dlouhá jména souborů
    • neomezená délka textů
    • podpora formátu RTF
    • podpora formátu HTML
    • podpora OLE
    • transparentní texty a obrázky
    • obrazy na pozadí v okně prvku
    • tři úrovně složitosti : začátečník, základní a profesionální (aby bylo SuperMemo pro začátečníky ještě snazší)
    • volitelný font rozhraní
    • vestavěná simulace procesu učení
    • automatické promíchání závěrečného procvičování
    • Otázka dne
    • další informace najdete v Co je nového v SuperMemo 98
  • Zvláštní vlastnosti v SuperMemo 98:
    • programovatelnost (systémy vědomostí mohou být rozšiřovány pomocí skriptů a programových komponent napsaných v libovolném programovacím jazyce)
    • uživatelem definovaný stupeň pozornosti věnované jednotlivým prvkům nebo celým větvím stromu hierarchie. Změnou tzv. indexu zapomínání jednotlivých prvků je možno řídit pravděpodobnost jejich zapomenutí!
    • šablony prvků používané pro rychlé tvoření velkého počtu stránek navržených ve stejném stylu
    • interaktivní překlad celého kurzu do jiných jazyků a překlad rozhraní programu (řetězce překladu jsou uchovávány v překladovém registru podobně jako jiné objekty v systému)
    • uživatel si může nastavit podle svých požadavků zvukovou odezvu při učení
    • nástroje pro tvoření lexikálních dvojic spojených s daným kurzem
    • náhodné učení a náhodné prohlížení celého systému prvků v prohlížečích a v registrech
    • velký počet nových statistických parametrů dokumentujících pokrok v učení
    • ladicí verze usnadňují hledání chyb v systému
    • atd.

Obr. 2. SuperMemo v profesionálním režimu umožňuje prohlížet podrobné statistiky učení a vytvářet pokročilé hypermediální kurzy

Další kroky:

  • Objednávka
  • Stažení a instalace SuperMemo 98
  • Abeceda SuperMemo - na začátečnické úrovni je to velmi jednoduché!
  • Další podrobnosti:
    • Historie SuperMemo
    • Co je nového v SuperMemo 98

  • ****

    •


SuperMemo 98 - Co je nového/title>

SuperMemo 98: Co je nového

Nové vlastnosti SuperMemo 98 v porovnání se SuperMemo 8.4 :

  • 32bitová aplikace
  • zvýšená rychlost (např. načítání prvků o 400%, vyhledávání o 200%, prohlížení v Obsahu 100%, prohlížení v prolížečích 100%, zotavení 80% atd.)
  • dlouhá jména souborů
  • neomezená délka textů
  • neomezený počet prvků v prohlížeči
  • podpora RTF
  • podpora HTML (včetně hyperpropojení k jiným prvkům, registrovým textům a obrázkům , externí soubory HTML a soubory dostupné z Internetu)
  • podpora JavaScript (v komponentách HTML)
  • podpora OLE (např. pro zahrnutí souborů z Word, Corel, MS Equation, MindMan , atd.)
  • podpora různých typů obrazových souborů (WMF, GIF, JPG aj.)
  • transparentní texty a obrazy
  • obrazy v pozadí v okně prvku
  • tři úrovně složitosti : začátečnická, základní a profesionální (pro usnadnění začátků se SuperMemo)
  • volitelný font rozhraní
  • zabudovaná simulace učebního procesu
  • nové operace prohlížečů : třídění podle sloupců, prvků určených k zapamatování, zapomenutí, vynechání, k závěrečnému procvičování, atd.
  • automatické míchání při závěrečném procvičování
  • Otázka dne
  • podpora prostřednictvím Internetu přímo z programu
  • Nápověda HTML
  • jednokrokový upgrade souborů vytvořených pod SuperMemo 8.4 (prostě se otevře soubor kno)
  • možnost instalace algoritmu optimálních intervalů typu plug-in vyvinutého třetí stranou. (např. neural network SuperMemo )

Viz také: Minimální požadavky

***


Karta SuperMemo

Options (Volby): SuperMemo

Karta SuperMemo v Tools (Nástroje) : Options (Volby) nabízí následující volby:

  • SuperMemo interface font (Písmo rozhraní SuperMemo) - definovat font použitý pro dialogové panely v SuperMemo. Chcete-li aktuální font změnit, klikněte na Change font (Změnit písmo)
  • Default background image (Výchozí obraz pozadí) - definovat obraz zobrazený implicitně na pozadí všech prvků v okně prvku . Napište jméno vybraného členu obrazového registru . Chcete-li předem přidat obraz do registru, zvolte Search (Vyhledat) : File (Soubor): Image (Obraz): Import files (Importovat soubory). Výchozí obraz pozadí je vždy zobrazen v režimu dlaždice. Chcete-li přidat jednotlivým prvků individuální pozadí nebo zvolit daný režim zobrazení, např. vystředit, roztáhnout, dlaždice atd., použijte volby Background (Pozadí) na místní nabídce prvku ( Alt+F10 v okně prvku)
  • Plug-In Algorithm (Algoritmus plug-in) - nainstalovat externí algoritmus intervalů mezi opakováním dodaný jako DLL (viz: Neural Network SuperMemo ). Chcete-li nahradit algoritmus SM8 vlastním "plug-in" DLL, zvolte Install a vyberte DLL. Chcete-li obnovit výchozí stav, zvolte Restore default (Obnovit výchozí). Uvědomte si prosím, že byste měli svůj plug-in nainstalovat před zahájením procesu učení. Po začátku učení nemůžete algoritmus přepínat, aniž byste předtím svůj systém vědomostí vynulovali. Algoritmus plug-in je přiřazen danému systému vědomostí, nikoliv programu SuperMemo všeobecně. Díky tomu můžete provádět opakování různých systémů vědomostí pomocí různých algoritmů (včetně svého vlastního algoritmu, pokud umíte napsat svou vlastní DLL ).

***


Statistika

Okno statistiky

Okna statistiky, Statistics (Statistika) a Element data (Data prvku) je možno pohodlně zobrazit stisknutím F5 (nebo zvolit Window (Okno) : Classic (Klasické) ). Tím se okna statistiky uspořádají do klasického tvaru zavedeného poprvé v SuperMemo 3.0 (1988):

Parametry učení zobrazené v okně statistiky:

  • Date (Datum) - aktuální datum
  • First day (První den) - datum, kdy začal proces učení daného systému vědomostí
  • Day (Den) - počet dnů v procesu učení (tj. počet dnů mezi hodnotou Date a First day)
  • Memorized (Probrané) - celkový počet položek uvedených do procesu učení volbami Učit se (Learn) nebo Zapamatovat (Remember) a p. Jestliže se položka zúčastňuje opakování, je to probraná položka
  • Pending (Čekající) - celkový počet prvků (tj. témat a položek), které ještě nebyly uvedeny do procesu učení, ale mohou být probrány pomocí Učit se (Learn) , Learn (Učit se : New material (Nová látka), Remember (Zapamatovat) atd. Všechny čekající prvky jsou umístěny v tzv. frontě čekajících prvků , která určuje pořadí učení nových prvků. Vynechané (dismissed) položky nejsou ve frontě čekajících prvků.
  • Dismissed (Vynechané) - celkový počet prvků (tj. témat nebo položek), které byly vyloučeny z procesu učení a jsou uchovány jen jako referenční materiál. Vynechané položky nejsou ani čekající, ani probrané. Všechna témata, která jsou uložena ve frontě čekajících prvků , jsou automaticky vynechána po první prezentaci (viz: Témata a položky )
  • Total (Celkem) - Celkový počet témat a položek v systému vědomostí. Dodejme, že I Memorized+Pending+Dismissed=Total. Vymazané (deleted) prvky nepřispívají do celkového počtu prvků v systému.
  • Outstanding (Nevyřízené) 0+0 - počet nevyřízených položek naplánovaný pro opakování na daný den. První číslo (před znaménkem plus) indikuje počet položek naplánovaných na daný den a dosud nezpracovaných. Druhé číslo (za znaménkem plus) znamená počet položek, které již dnes byly opakovány, ale byly oznámkovány známkou horší než Dobře (Good, 4). To jsou položky, které tvoří frontu závěrečného procvičování.
  • Default FI (Výchozí index zapomínání) - implicitní index zapomínání přiřazovaný novým prvkům přidávaným do systému. Index zapomínání je obecně podíl položek, které si nepamatujeme při opakování. Všem prvkům je možno nastavit index zapomínání jednotlivě. Jako výchozí hodnotu dostanou všechny na počátku index zapomínání rovný Default FI. Nejsnazší způsob, jak změnit index zapomínání velkého počtu prvků, je použít volbu Forgetting index na místní nabídce v okně prvku
  • Average FI (Průměrný index zapomínání) - průměrný index zapomínání, který říká, jaká je průměrná hodnota indexu zapomínání v celém systému vědomostí. Není-li index zapomínání jednotlivých prvků ručně změněn, je Average FI roven Default FI.
  • Measured FI (Naměřený index zapomínání) - hodnota indexu zapomínání naměřená při opakováních, tj. skutečný podíl položek, které si uživatel při opakování nepamatoval. Je zcela normální, je-li Measured FI vyšší než Average FI. To je způsobeno dvěma faktory: (1) žádný proces učení není dokonalý a každý uživatel se čas od času dopustí odkladu opakování, (2) SuperMemo klade jistá omezení na délku intervalů, v důsledku čehož je někdy opakování naplánováno na pozdější dobu, než by odpovídalo indexu zapomínání. Například omezení ve výpočtech intervalů zabraňují tomu, aby nový interval byl kratší než starý (s výjimkou případu, kdy je položka zapomenuta). Pro nízké hodnoty indexu zapomínání a položky s nízkým A-Faktorem by mohl být nový interval mnohdy kratší než starý!
  • Burden (Zátěž) - průměrný počet opakování na den. Tato hodnota je rovna součtu převrácených hodnot všech intervalů. Interpretace tohoto přístupu je tato: každá položka s intervalem 100 dnů je v průměru opakována 1/100 krát za den. Tedy součet převrácených hodnot intervalů je dobrým indikátorem celkové zátěže v systému vědomostí.
  • Repetitions (Počet opakování) - průměrný počet opakování na jednu probranou položku v systému vědomostí.
  • Lapses (Počet selhání) - průměrný počet případů, kdy byly jednotlivé prvky zapomenuty (počítá se jen s probranými prvky).
  • Interval - průměrný interval probraných prvků v systému vědomostí.
  • A-Factor - průměrná hodnota A-Faktoru mezi probranými položkami v systému. A-Factor je mírou obtížnosti položky. Čím vyšší je A-Faktor, tím snazší je položka
  • Last Rep (Poslední opakování) - průměrné datum posledního opakování mezi probranými položkami v systému
  • Next Rep (Příští opakování) - průměrné datum příštího opakování mezi probranými položkami v systému
  • Test - počet položek ve frontě náhodného testu (používá se pouze při spuštění náhodných testů pomocí Tools (Nástroje) : Random tests (Náhodné testy).

****


Stavový pruh

Stavová pruh se zobrazuje na spodním okraji obrazovky (jen když je zatrženo Window (Okno) : View (Zobrazit): Status bar (Stavový pruh).

Na stavovém pruhu se stručně a graficky zobrazují informace dostupné též v okně statistiky . V prvním poli se zobrazuje počet Probraných /(Probraných + Čekajících prvků). Jinými slovy, zobrazuje, jaký podíl čekajících prvků již byl probrán. Druhé pole zobrazuje počet Nevyřízených /(maximální počet Nevyřízených). Ilustruje, kolik nevyřízených prvků naplánovaných pro aktuální den je třeba ještě zopakovat (před znaménkem plus) nebo je třeba procvičit v závěrečném procvičování (za znaménkem plus). Na pruhu postupu se zobrazují tytéž informace v grafické formě. Modrá barva ukazuje podíl prvků zvládnutých úspěšně (tj. se známkou Výborně (5) nebo Dobře (4)). Červená barva ukazuje podíl prvků prošlých se známkou horší než Dobře (4). A bílá barva ukazuje podíl prvků, které ještě neprošly (nebyly vyřízeny).

Pravá část stavového pruhu se používá pro zobrazení textu popisků pro položky nápovědy, tlačítka, statistické parametry atd. Jak jste si pravděpodobně všimli, tato část zežloutne, jakmile se kurzor myši umístí na tlačítko, položku nabídky, atd. Popisky je možno zapínat a vypínat dvojitým kliknutím na popisek.

***


Podmnožiny

Používání podmnožin

Podmnožiny jsou soubory, v nichž jsou uloženy množiny prvků (implicitní přípona podmnožiny jesub). Každý prvek je uložen jako čtyřbajtové číslo prvku. V důsledku toho je velikost souborů podmnožin v bajtech rovna čtyřnásobku počtu prvků podmnožiny. Tytéž soubory podmnožin mohou být používány různými souhrny vědomostí, avšak takové použítí má smysl, jen když mají souhrny totéž číslování prvků (např. jsou-li to kopie téhož původního souhrnu)

Tvoření podmnožin

Pro vytvoření podmnožiny můžete použít některou z následujících voleb:

  • Subset (Podmnožina): Save all (Uložit vše) na místní nabídce prohlížeče - uložit obsah prohlížeče do souboru podmnožiny (např. tato volba použitá na prohlížeči otevřeném pomocí View (Zobrazit): Memorized (Probrané) vytvoří podmnožinu všech probraných prvků)
  • Tools (Nástroje): Save as subset (Uložit jako podmnožinu) na nabídce obsahu - uložit větev obsahu do souboru podmnožiny
  • Subset (Podmnožina): Save selection (Uložit výběr) na místní nabídce prohlížeče - uložit všechny vybrané prvky v prohlížeči (výběr se provádí kliknutím na levý krajní sloupec nebo pomocí podmnožinových operací, jako jsou Add (Sečíst), Subtract (Odečíst) a Intersect (Průnik)). Poněvadž operace s dceřinnými prvky v prohlížeči mění jeho obsah, mohou být rovněž užitečné při vytváření souborů podmnožin.

Všimněte si, že operace s podmnožinami v registrech ve spojení s Browse current (Prohlížet aktuální) a Browse all (Prohlížet vše) jsou zde také užitečné. Například: vyhledejte daný podřetězec a zvolte Browse all. Vytvoříte prohlížeč se všemi prvky používajícími nalezené texty. Tento prohlížeč je možno uložit jako soubor podmnožiny (Subset: Save all)

Používání podmnožin

Podmnožiny je možnopoužívat v řadě voleb, z nichž nejdůležitější jsou:

  • File (Soubor) : Export: Subset as text (Podmnožinu jako text) - vyexportuje soubor podmnožiny jako textový soubor podmnožiny prvků, který je možno importovat do jiného souhrnu vědomostí
  • File (Soubor): Export: Translation (Překlad) - exportuje překlad textů použitých v prvcích z podmnožiny
  • Tools (Nástroje): Match to subset (Přizpůsobit podmnožině) na místní nabídce registru - všechny členy registru , které jsou používány prvky obsaženými v souboru podmnožiny. Například pomocí Search and replace: Find v registru je možno snadno najít podřetězce, které jsou používány danou podmnožinou prvků a obsahují vybraný hledaný podřetězec
  • View (Zobrazit) : Subset (Podmnožinu) - otevře daný soubor podmnožiny v prohlížeči
  • Tools (Nástroje) : Random test (Náhodný test): Subset (Podmnožina) - spustí náhodný test na podmnožině prvků.

****


Podpora

Obsah : Podpora
Technická podpora pro uživatele SuperMemo

Všichni uživatelé jsou oprávněni bezplatně využívat podporu prostřednictvím Internetu.

Narazíte-li na otázku týkající se SuperMemo, na kterou nedokážete odpovědět, postupujte prosím podle níže uvedených kroků:

  1. Dokumentace SuperMemo. Podívejte se na obsah v tomto souboru nápovědy a zkuste najít stránku s odpovědí na váš problém. Nenajdete-li ji tam, kde jste očekávali, poznamenejte si prosím, proč. To je pro zlepšení naší dokumentace velmi důležité !
  2. Soubory s častými otázkami a odpověďmi (FAQ). Nemůžete-li najít odpověď v obsahu, zkuste ji najít v souborech FAQ
  3. Fulltextové vyhledávání. Není-li odpověď v souborech FAQ, zkuste fulltextové vyhledávání. Napište hledané klíčové slovo do editačního pole nadepsaného Type in the keyword to find (Napište hledané klíčové slovo) v levém horním rohu obrazovky nápovědy a stiskněte Enter (není-li toto pole viditelné, klikněte na Show (Zobrazit) na nástrojovém panelu). Prohlížíte-li si toto pole přímo z internetové stránky SuperMemo, použijte náš vyhledávací stroj Excite search engine . Nemůžete-li vyhledáváním klíčového slova najít to, co chcete, zapište si klíčové slovo, abychom mohli zlepšit mapování klíčových slov.
  4. Podpora prostřednictvím elektronické pošty. Pokud stále ještě neznáte odpověď na svůj problém, napište svému místnímu distributorovi uvedenému v panelu prodejců v Help (Nápověda) : About nebo napište na support@supermemo.com , kde dostanete podporu v anglickém jazyce. Snažte se prosím vysvětlit, proč nemůžete najít odpověď na svůj problém v naší technické dokumentaci (co jste hledali, kde a s jakými klíčovými slovy). To je velmi důležité pro zlepšení našich služeb!!!

Viz též: Jak kontaktovat svého národního distributora, Jak kontaktovat výrobce a Minimální požadavky pro SuperMemo 98

****


Šablony

Šablony se v programu SuperMemo používají pro vytváření velkého množství podobně vypadajících prvků .

První věc, kterou je třeba udělat při práci se šablonami, je vytvořit prvek obsahující všechny komponenty , které jsou společné všem prvkům, které budou s použitím této šablony vytvořeny. Všechny komponenty by měly mít své vlastnosti nastaveny tak, jak je to žádoucí pro celou množinu prvků.

Jakmile je to provedeno, můžete použít Template (Šablona): Save as template (Uložit jako šablonu) na místní nabídce prvku (otevřené např. pomocí Alt+F10). Kterýkoliv prvek je možno uložit jako šablonu.

Šablony se ukládají do registru šablon a je možno je zobrazit pomocí Search (Vyhledat) : Template (Šablona).

Šablonu je možno zavést z registru na kterýkoliv prvek pomocí Template (Šablona): Apply template (Použít šablonu). Zavedením šablony se odstraní všechny existující komponenty a atributy a prvek bude vypadat přesně stejně jako prvek, který byl uložen jako šablona.

Chcete-li, aby se některá šablona vždy používala při přidávání prvků patřících do dané kategorie, (1) použijte Tools (Nástroje) : Categories (Kategorie) , (2) přejděte do řady odpovídající zvolené kategorii, (3) dvojitě klikněte na pole Default template (Implicitní šablona), (4) propojte šablonu z registru šablon pomocí tlačítka Link (Propojit), (5) zavřete okno Append categories kliknutím na OK.

Tím bude zajištěno, že vaše šablona se použijte pokaždé, když zvolíte Edit (Editovat) : Add a new item (Přidat novou položku) nebo stisknete Ctrl+A (jen když je zvolená kategorie indikována na nástrojovém panelu hlavního okna).

Chcete-li změnit návrh položek používajících danou šablonu, můžete použít Template (Šablona): Merge template (Sloučit šablonu) (na místní nabídce prvku ) nebo Node operations (Uzlové operace): Merge with template (Sloučit se šablonou) v okně obsahu (pro všechny položky nebo všechna témata v dané větvi).

Merge with template (Sloučit se šablonou) sloučí prvek se šablonou z registru šablon. Proces slučování začíná zavedením (načtením) vybrané šablony. Potom SuperMemo přenese všechny odpovídající objekty registru ze staré šablony do nové šablony. Všimněte si prosím, že SuperMemo vás nebude varovat, nemůže-li najít odpovídající komponentu. Například jestliže váš prvek obsahuje obraz a vy jej sloučíte se šablonou, která obraz nemá, obraz se vymaže. Při slučování šablon neexistuje žádná funkce "krok zpět". Proto buďte při používání Merge with template opatrní, zejména když slučujete šablonu s mnoha prvky najednou.
Všimněte si, že Merge with template neovlivní žádné položky, jestliže šablona je typu téma (a naopak). Viz též: Témata a položky

Chcete-li přidat nové komponenty do skupiny prvků, použijte Node operations (Uzlové operace): Add template (Přidat šablonu). Tím se uchovají staré komponenty a přidají nové komponenty z přidané šablony.

Příkaz Add to template je podobný příkazu Merge with template, avšak obsah nové šablony se prostě "naloží" na starou šablonu. Tak můžete vytvořit šablonu s obrazem a přidat tento obraz do vybraných prvků přidáním šablony s obrazem. Při slučování šablon se počet komponent rovná počtu komponent ve slučované šabloně, kdežto při přidávání šablon je počet komponent roven součtu komponent v prvku a šabloně.

Chcete-li přenášet šablony (nebo jednotlivé prvky) mezi různými souhrny vědomostí, použijte Template: Save to file (Uložit do souboru) a Template: Load from file (Zavést ze souboru).

***


Pokročilé testy

Tvoření pokročilých testů pro SuperMemo

Creating multiple choice tests, drag&match tests, etc.

Apart from standard question-answer items, you can also create a variety of other tests such as:

  • multiple choice tests
  • spelling tests
  • pronunciation tests
  • drag&match tests
  • point&click tests, and more

Multiple choice test

To create a multiple choice test do as follows:

  1. Create text components: question, correct answer and a couple of wrong answers
  2. On the pop-up menu of the correct answer component choose MCT and check the submenu item Correct
  3. On the pop-up menu of wrong answer components choose MCT : Wrong
  4. Test the item by trying to click particular components. The correct response should be highlighted green, and you should get the correct or wrong response feedback (e.g. with custom sounds, etc.)

Spelling test

To create a spelling test, simply place a Spell component in the element window and fill it out with the correct spelling (or with spelling variants separated by a slash). Press Esc to move to the presentation mode , and test the spelling by typing in the text in the spelling field and pressing Enter. Remember that SuperMemo tries to match the first string among correct answers separated by the slash; therefore you should remember to keep the appropriate sequence of correct answers.

Pronunciation test

To create a pronunciation test, place a Sound component in the element window and check the Recorder option on the component pop-up menu . Link the correct pronunciation WAV file by using Import file or Links : Registry member on the same pop-up menu. Your pronunciation test is ready. The user can now record himself by pressing the microphone button and play his own or the correct pronunciation by using blue and green play buttons respectively. Finally, he can erase his recording by pressing the crossed-out button. All user recording are kept in TEMP subdirectory of the collection directory and can only be deleted with the recorder crossed-out button. To clean all recordings, go to the TEMP directory and delete all WAV files.

Creating Drag&Match and Point&Click exercises is more difficult and requires using scripts and the hit-area editor.

Point&Click test

An element used for the Point&Click test must contain an image component. The user is supposed to click the right place in the picture. This test may be used, for example, to click the described organ on an anatomical cross-section image. Another example is pointing to the recognized picture in a word recognition test. Here, the question can be a recording of the recognized word, and the test will require clicking the pictorial representation of the word.
To create Point&Click test, place a script component in the element (make sure it is the first playable component, e.g. by placing the script before placing all other components).
To make sure that the script is run as you enter the element, check Autoplay on element pop-up menu . The script must contain the HITTEST command that will evoke Point&Click test, and all other components of the test if necessary (e.g. playing the question).

In the example below, the script plays the component with the question (component no 3) and calls the HITTEST command to execute the test. HITTEST says that the image component used in the test has the number 4, and that the coordinates of the correct selection area are [(387,10)(444,237)(546,229)(536,4)]

Note that these coordinates can be determined by means of Edit Hit-Area on the image component pop-up menu (see below).

It is worth to remember that the numbers of components on a page can be displayed with the 148 button on the Edit tab in the element window. Alternatively, Component order on element pop-up menu can be chosen for the same purpose.

Here is the script:

START 3

HITTEST 4 [(387,10)(444,237)(546,229)(536,4)]

WAITGRADE

GOTO 2

Commands WAITGRADE and GOTO 2 make sure that after the test (i.e. after the grade is given to the user), the script goes back to line 2 and makes it possible to resume the Point&Click test.

Single Drag&Match test

This is a test for matching text components with hot spots in a single image components. The user is supposed to drag the text components and drop them at appropriate places in the image component. Single Drag&Match is implemented with a DRAGMATCH script command.

For example:

Let us imagine an exercise in which the users is to drag text components numbered 5, 6, 7 and 8 to appropriate hot spots on the image component number 2. Let us now assume that the hotspot for dragging the text number 5 is delimited by a rectangle having the following coordinates: (123,315,264,357). By analogy, components 6, 7 and 8 have also their own hot spot rectangle coordinates. The following script might do what is needed in this exercise:

DRAGTEXTMODE TRANSPARENT

SHOW 5

SHOW 6

SHOW 7

SHOW 8

DRAGMATCH 2 [5,6,7,8] [(123,315,264,357)(34,37,64,77)(43,37,58,177)(21,25,53,37)]

WAITGRADE

GOTO 2

In the above script, DRAGTEXTMODE makes sure that texts are transparently displayed on the image upon dropping. The SHOW commands will redisplay all text components after executing GOTO 2 (dragging will make the components invisible). DRAGMATCH will define the appropriate relationships between text components and hot spot rectangles in the image component number 2. WAITGRADE will suspend the execution of the script until all texts are dragged into appropriate places or until the first mistake is made by the user. Finally, GOTO 2 will allow repeated execution of the exercise until satisfactory performance.

To simplify determining the correct rectangle coordinates, you can use the command Edit Hit-Area on the image component pop-up menu . This command is described below.

Multiple Drag&Match test

This is a test for matching text components with a number of image components. The users is supposed to drag the text components to appropriate image components. Multiple Drag&Match is also implemented with a DRAGMATCH script command. This time its syntax differs slightly. There is no image argument. Instead, a list of images is used to match a list of text components.

For example:

Let us imagine an exercise in which the user is supposed to drag text components numbered 2, 3, 4 and 5 to image components numbered 6, 8, 7, and 9. Those two lists of components will form the two arguments of the multiple DRAGMATCH script command. Again DRAGTEXTMODE determines if the texts erase the background or are displayed transparently:

DRAGTEXTMODE OPAQUE

SHOW 2

SHOW 3

SHOW 4

SHOW 5

DRAGMATCH [2,3,4,5] [6,8,7,9]

WAITGRADE

GOTO 2

The behavior of the above script is analogous to the behavior of the script described in the previous section devoted to single DRAGMATCH command.

Hit Area Editor

Hit area editor is used to easily determine the coordinates of image hot spots for HITTEST script command and for single DRAGMATCH script command.

To use Hit Area Editor follow the steps listed below:

  1. Close the Script Editor if you are in the middle of writing a script
  2. Right click the image whose hot spots you want to edit
  3. Chose Edit Hit Area on the pop-up menu
  4. At the bottom of the Hit Area Editor choose the command for which editing is to be used: HitTest or DragMatch
  5. For DragMatch exercise, click in turn top-left and bottom-right corners of rectangles describing the hot spots (you can create up to ten rectangles)
  6. For HitTest exercise, click in turn all corners of the hot spot area (the area cannot be more than pentagonal, i.e. you should click no more than five points)
  7. If you make a mistake, you can clean the editing area by choosing Clear
  8. After you are done with editing, click Copy to move the edited coordinates to clipboard
  9. Now you can close Hit Area Editor and return to Script Editor
  10. Place the cursor in the appropriate place of the DRAGMATCH or HITTEST command and paste the coordinates from the clipboard (e.g. with Shift+Ins or Ctrl+V)

***


Teorie

Obsah :
Teoretické aspekty optimálních intervalů mezi opakováním: simulace procesu učení Piotr Wozniak,
1990-1998
Tento text je převzat z článku od P.A.Wozniaka " Optimization of learning : Simulation of the learning process conducted along the SuperMemo schedule, Master's Thesis, Technical University of Poznan, 1990" a upraven pro zveřejnění jako nezávislý článek na www (P.A.Wozniak, 28. července 1998).
(originální text obsahoval dodatečné obrázky vztahující se k rychlosti zapomínání; ty sem nebyly zahrnuty)

Jednoduchý model simulace umožňuje předvídat výsledky dlouhodobého procesu učení založeném na časových intervalech mezi opakováním. Pravděpodobnost zapomenutí při každém opakování je dána indexem zapomínání. Pomocí Algoritmu SM-8 a reálného rozdělení A-faktorů je možné předvídat průběh učení na mnoho let dopředu pomocí počítačové simulace (simulace pro předvídání budoucího procesu učení založená na reálných datech uživatele byla zahrnuta do SuperMemo 98 prostřednictvím funkce Tools (Nástroje) : Statistics (Statistika): Simulation (Simulace)).

Pokračování tohoto textu najdete na www.supermemo.com/english/ol/theory.htm


Nástrojový panel

Hlavní nástrojový panel

Hlavní nástrojový panel se zobrazuje na horní straně hlavního okna pod panelem rychlých funkcí (jen na professionální úrovni ).

wpe1.gif (3671 bytes)

Použití jednotlivých ovládacích prvků:

  • Stahovací seznam Kategorie - výběr aktuální kategorie vědomostí. Tím bude určen vzhled nově přidávaných prvků a jejich umístění ve stromu vědomostí v okně obsahu
  • Čas - zobrazení aktuálního času
  • Datum - zobrazení aktuálního data
    Upozornění! S datem byste nikdy neměli manipulovat za účelem řízení procesu učení! V poli Datum nelze zadat datum menší než je datum zahájení procesu učení
  • Stopky - časovač používaný pro měření celkové doby opakování při dané relaci (lekci) (může se používat i k jiným účelům, např. měření intervalů videotitulků atd.)
  • Spouštěcí tlačítko stopek - spouští a zastavuje stopky (časovač)
  • Nulování stopek - nuluje čítač stopek
  • Schránka prvku - dočasná paměť pro prvky, kterou je možno použít pro duplikování obsahu prvku
  • Schránka komponenty - dočasná paměť pro komponenty, kterou je možno použít pro kopírování komponent
  • Schránka hyperpropojení - dočasná paměť pro komponenty, kterou je možno použít pro tvoření hyperpropojení
  • Tlačítko pro zastavení skriptů - blokuje skripty (např. při ladění skriptu, který přešel do nekonečné smyčky)
  • Tlačítko Skrýt nástrojový panel - skryje nástrojový panel (nástrojový panel je možno obnovit pomocí Window (Okno): View (Zobrazit): Toolbar (Nástrojový panel))
  • Zatrhovací políčko pro popisky - zapíná a vypíná zobrazování popisků .

***


Nabídka Nástroje

Nástroje

Podnabídka Tools (Nástroje) na hlavní nabídce obsahuje následující volby:

  • Options (Volby) - otevřít dialogový panel s volbami, např. implicitní font rozhraní, implicitní index zapomínání, implicitní šablona položek, cesta k souborům na CD-ROM atd.
  • Workload (Zátěž) - otevřít denní a měsíční kalendář opakování
  • Mercy (Milost) - otevřít dialogový panel, který umožňuje přeplánovat opakování (např. před nebo po přestávce způsobené dovolenou)
  • Categories (Kategorie) - otevřít seznam kategorií vědomostí definovaných uživatelem s možností definovat nové kategorie, editovat stávající kategorie, mazat kategorie atd.
  • Statistics (Statistika)
    • Analysis (Anylýza) - otevřít dialogový panel s různými statistikami týkajícími se procesu učení a algoritmu SM-8
    • Simulation (Simulace) - otevřít dialogový panel, který umožňuje simulovat učení v průběhu mnoha let pomocí reálných dat nashromážděných během opakování
    • Plug-In - vyvolat statistickou proceduru definovanou pomocí algoritmu pulg-in (jen byl-li nainstalován externí plug-in a implementuje-li statistickou proceduru)
    • Report (Hlášení) - vygenerovat textový soubor se statistikou zobrazenou v okně statistiky
    • Files (Soubory) - vypočítat velikost všech souborů v daném souhrnu vědomostí (včetně sekundární paměti )
  • Randomize (Náhodné uspořádání) - náhodně uspořádat frontu čekajících prvků nebo frontu závěrečného procvičování
  • Random test (Náhodný test) - spustit náhodná opakování na různých podmnožinách aktuálního souhrnu vědomostí (náhodná opakování se nezapočítávají do učebního procesu) (srov. Contents (Obsah) : Review (Prohlížet) )
  • Random review (Náhodné prohlížení) - náhodně prohlížet prvky aktuálního souhrnu vědomostí (srov. Contents : Review )
  • Modify in subset (Modifikovat v podmnožině) - měnit různé parametry prvků náležejících do vybrané podmnožiny (např. velikost, zobrazit status atd.).

****


Téma

Témata a položky

Souhrn vědomostí (zvaný též vědomostní systém) v SuperMemo je množina prvků . Každý prvek tvoří jednu stránku informací viditelnou na obrazovce. Prvky v SuperMemo mohou být dvou typů: témata a položky .

Témata se používají pro předkládání úvodních souhrnných vědomostí studentovi, kdežto položky se používají pro procvičování těchže vědomostí za účelem jejich uchování v paměti.

Téma může obsahovat například následující text:

Jimmy Carter, narozen r.1924, státník USA a 39. prezident (1977-1981), narozen v Plains, Georgia. Studoval na námořní akademii (US Naval academy) a sloužil v americkém námořnictvu (US Navy) až do roku 1953, kdy převzal rodinnou farmu pro pěstování burských oříšků a jiné podniky. Jako guvernér státu Georgia (1970-1974) prováděl osvětovou politiku vůči barevným občanům a jejich právům. V roce 1976 získal nominaci Demokratické strany na prezidenta a těsně zvítězil nad Geraldem Fordem. Zorganizoval mírovou dohodu mezi Egyptem a Izraelem (1979) a intenzivně se zabýval lidskými právy. Jeho prezidentství skončilo potížemi s americkými rukojmími v Iránu a se sovětskou invazí do Afghanistanu; byl poražen Ronaldem Reaganem ve volbách v roce1980

K procvičování znalosti faktů uvedených výše je možno použít následující položky typu otázka - odpověď:

Q (Otázka): Ve kterém roce se narodil Jimmy Carter?
A (Odpověď): 1924

Q: Kdo byl 39. prezident USA?
A: Jimmy Carter

Q: Kdy se stal Jimmy Carter prezidentem?
A: 1977

Q: Jakou akademii studoval Carter?
A: Námořní akademii USA

Q: Jaké podnikání převzal Jimmy Carter v roce 1953?
A: burské oříšky

atd. atd.

Témata a položky se zpracovávají v procesu učení odlišně:

  • témata se předkládají pouze jednou před uvedením jednotlivých položek (po prvním opakování se témata vynechají a odstraní se z procesu učení)
  • položky se zúčastňují standardních opakování SuperMemo a opakují se tolikrát, aby bylo jisté, že se trvale uchovají v paměti

V optimálním případě by položky měly být dcerami nebo potomky tématu, z kterého jsou odvozeny. Díky tomu se student může kdykoliv vrátit k mateřskému tématu kliknutím na tlačítko "mateřský prvek" na navigačním nástrojovém panelu (šipka nahoru). Matku dané položky je také možno zobrazit stisknutím Ctrl+Alt+Up .

V následující tabulce jsou shrnuty rozdíly mezi položkami a tématy:

Vlastnosti | Témata | Položky
Délka | Mohou být delší, mohou obsahovat delší texty a bohatší grafiku | Musí být co nejkratší a nejjednodušší
Opakování | Předkládají se v procesu učení pouze jednou (pak se vynechávají). Neopakují se. | Opakují se tolikrát, až je zajištěno jejich trvalé uložení v paměti
Účel | Používají se pro úvod do vědomostí | Používají se pro přezkušování vědomostí
Tvoření | Chcete-li z prvku udělat téma, zatrhněte na místní nabídce prvku pole Topic (Téma) | Chcete-li z prvku udělat položku, zrušte na místní nabídce prvku zatržení pole Topic (Téma)
Cyklus opakování | Témata se předkládají tak, jak jsou (i když některé komponenty jsou označeny jako Answer (Odpověď) ) | Nejprve s předkládají (zobrazují) komponenty označené jako First question (první otázka). Komponenty označené jako Answer (odpověď) se zobrazují až po stisknutí tlačítka Show answer
Zpracování | Jsou určeny pro pasivní prohlížení a čtení | Jsou určeny pro aktivní vyvolávání informace z paměti
Informační obsah | Obsahují informace procvičované v několika (mnoha) položkách | Obsahují vybranou informaci, která je jen jednou částí tématu
Podstata | Syntetická (shrnující) | Stimul -reakce (nejčastěji: otázka a odpověď)
Umístění ve stromě vědomostí | Nejlépe jako mateřský prvek položek, které se týkají téhož předmětu | Nejlépe jako dceřinné prvky mateřského tématu

Zvolíte-li Add new (Přidat nový) nebo stisknete-li Ctrl+A , přidáte do spuhrnu novou položku. Add new (Přidat nový) přidává položky jako potomky aktuální kategorie obsahu . Chcete-li položku změnit na téma, zvolte na místní nabídce prvku Topic. Když nabídku znovu otevřete, mělo by být Topic zatrženo. To indikuje, že aktuální prvek je interpretován jako téma.

Pro tvoření zdravé struktury vědomostí v souhrnu používejte následující kroky:

  1. Otevřte okno obsahu kliknutím na Contents (Obsah) v okně prvku
  2. Najděte místo, kam chcete přidat své téma
  3. Přidejte prvek pomocí Add (Přidat), Insert (Vložit) nebo Sibling (Sestra) na spodní straně okna obsahu
  4. Pomocí Add (Přidat) přidejte první položku
  5. Zvolte Sibling (sestra) pro přidávání zbývajících položek
  6. Klikněte na své téma a zvolte View (Zobrazit), aby se otevřelo okno prvku
  7. Na místní nabídce prvku zatrhněte Topic (Téma)
  8. Editujte obsah tématu
  9. Klikněte na Contents (Obsah)
  10. Klikněte na první položku a zvolte View (Zobrazit), aby se otevřela v okně prvku
  11. Editujte obsah položky (pro urychlení práce můžete používat šablony )
  12. Přejděte na krok 9 a opakujte kroky 9 - 11, dokud nebudete hotovi.

****


Překlad

Obsah :
Překlad systému vědomostí SuperMemo do jiných jazyků

Podrobné pokyny pro překlad systému vědomostí do daného jazyka:

Vytvoření překladového registru

Chcete-li preložit svuj systém vědomostí do jiného jazyka, začnete vytvořením překladového registru:

  1. Zvolte File (Soubor) : SuperMemo : Level (Úroveň) : Professional
  2. Zvolte Tools (Nástroje) : Options (Volby) : Language (Jazyk)
  3. Do pole Collection translation (Překlad systému vědomostí) napište název jazyka
  4. Zavřete dialogový panel Options (Volby) kliknutím na OK
  5. Přeložte systém vědomostí pomocí interaktivního překladu (jednodušší a spolehlivejší, avšak vyžaduje používání SuperMemo) nebo pomocí textových souboru (snazší pro týmovou práci a nevyžaduje od překladatelů znalost SuperMemo).

Interactive translation (single translator)

To proceed with interactive translation of your collection do the following (recommended for an individual translator):

  1. Make sure that no repetitions have been done in your collection (pending queue will be used to proceed in the optimum translation sequence)
  2. Make sure the translation registry for your language has been created (i.e that you passed all steps from the previous paragraph). You can see translation registry files at <SuperMemo directory>\systems\<your collection name>\translat\<translation language>.*
  3. Go to the first element in the pending queue (e.g. open the pending browser with View : Pending)
  4. Right-click the button Next ( on the navigation toolbar ) and choose Next pending element (this way you will be moving along the pending queue why pressing Alt+PgUp and Alt+PgDn).
  5. Use Alt+PgUp and Alt+PgDn to move between pages (or Ctrl+G to jump to a specific page; note that page numbers are not related to the order in the pending queue ).
  6. On each page, locate all text components and use Shift+click to open translation dialog box for each
  7. Type in the translation in the lower pane (the original stays unchanged in the upper pane). Note that the texts you have translated in earlier pages will already be translated
  8. See useful tips below for more information

Translation in text files (team translation)

To proceed with translation in text files do the following (recommended for team translation):

  1. Make sure the translation registry for your language has been created (i.e that you passed all steps from the paragraph devoted to creating the translation registry). You can see translation registry files at <SuperMemo directory>\systems\<your collection name>\translat\<translation language>.*
  2. Decide which branches of the knowledge tree in the contents window should be translated by individual translators
  3. Create subset files for each branch. For this purpose do the following:
    • click the selected branch in the contents window
    • open the pop-up menu with right-click
    • choose Tools : Save as subset from the pop-up menu
  1. Export individual branches as text files with File : Export : Translation:
    • choose Sorting : By occurrence
    • choose Output texts : Not translated
    • choose Output elements : Subset
    • use Browse to select the subset files created in the previous step
    • leave Do not output duplicated entries unchecked
    • leave Output context checked
  1. Let the translators replace ??? strings in exported text files with appropriate translations (do not change anything else in the file!)
  2. As soon as individual translated files are becoming available, import them with File : Import : Translation
  3. Note that the same strings translated differently by different authors will be merged. This is not an error-proof procedure and you will have to manually resolve the import conflicts. Import : Translation will generate a report with all merged entries listed. The fastest way to resolve merged strings is:
    • copy the original string from the import report file to the clipboard
    • using Search : Text, paste the string in the search input box
    • correct the translation directly in the text registry as it appears on the screen

Useful tips:

  1. In most elements, you can use PgDn and PgUp instead of Alt+PgUp and Alt+PgDn
  2. Do not change the original texts in text files, even if you find mistakes! Otherwise, your translation will not be importable to the mother collection
  3. You can easily review, search for and change translations by using Search : Other texts : <Language> translation. The same can be accomplished with Search : Text with this difference that search and sorting will concern only the original texts
  4. The percent of the work done can be viewed in the caption of the translation registry (Search : Other texts : <Language> translation)
  5. When working in a team, try to minimize the differences in translating individual entries by frequently exporting and importing back partly translated files. This will also reduce the duplicated effort of translators working on different branches
  6. To see untranslated entries in text registry ( Search : Text), you can choose Select untranslated on the registry pop-up menu . Untranslated members will be displayed as a registry subset .

**


Nabídka Zobrazit

Obsah : Technický popis : Hlavní nabídka
Zobrazit (View)

Podnabídka View (Zobrazit) v hlavní nabídce nabízí následující volby:

  • All (Vše) - otevřít prohlížeč se všemi prvky uloženými v aktuálním souhrnu vědomostí
  • Pending (Čekající) - otevřít prohlížeč se všemi čekajícími prvky , tj. prvky, které čekají na probrání ve frontě čekajících prvků
  • Memorized (Probrané) - otevřít prohlížeč se všemi prvky, které již byly probírány (učeny)
  • Dismissed (Vynechané) - otevřít prohlížeč se všemi prvky, které byly vynechány , tj. odstraněny z procesu učení (např. stisknutím tlačítka Dismiss (Vynechat) v okně prvku )
  • Outstanding (Nevyřízené) - otevřít prohlížeč se všemi prvky naplánovanými pro opakování na daný den . Ty zahrnují aktuální opakování a opakování z nedávného období, po které s opakování neprovádělo.
  • Drill (Procvičování) - otevřít prohlížeč se všemi prvky naplánovanými pro závěrečné procvičování
  • Subset (Podmnožina) - otevřít prohlížeč s prvky uloženými v souboru podmnožiny (přípona SUB). Soubory podmnožin je možno vytvářet v prohlížeči pomocí voleb, jako jsou např. Subset (Podmnožina) : Save all (Uložit vše) nebo Subset: Save selection (Uložit výběr) atd.
  • Last (Poslední) - otevřít prohlížeč s obsahem naposledy používaného prohlížeče
  • Results (Výsledky) - otevřít prohlížeč s prvky vybranými při poslední operaci vyhledávání (provedené pomocí Ctrl+F nebo Search (Vyhledat) : Find elements (Najít prvky)
  • Special (Speciální) - otevřít podnabídku se specializovanějšími prohlížeči:
    • Range (Rozsah) - otevřít prohlížeč s prvky, které spadají do zvoleného rozsahu (např. čísla od 1 do 1000)
    • Topics (Témata) - otevřít prohlížeč se všemi prvky, které jsou tématy (viz: Témata a položky )
    • Items (Položky) - otevřít prohlížeč se všemi prvky, které jsou položkami
    • History (Historie) - otevřít prohlížeč se seznamem naposledy prohlížených prvků
    • Node (Uzel) - otevřít prohlížeč se všemi potomky právě vybraného uzlu v okně obsahu
    • Filter (Filtr) - otevřít prohlížeč se všemi prvky, které splňují určitá kritéria, například počet opakování, délka intervalu, index zapomínání , status (např. čekající , probraný atd.) a další
    • Leeches (Nepoddajné) - otevřít prohlížeč s nejobtížnějšími prvky v souhrnu (všimněte si, že parametry filtru jsou již nastaveny tak, aby nalezení nepoddajných položek bylo snadné).

  • ****

    •