
Stone's WebWriter features
- 32-bit Windows 95 program
- In English (Danish version available)
- Dynamic help text in all dialog boxes makes it easy to understand and use the functions in WebWriter and at the 

same it makes it easy to use as a learning tool for learning the HTML language.
- Right click menus for fast and easy editing of text and previously inserted HTML codes via dialog boxes.
- Coloring of the HTML codes. Colors are interchangeable
- Templates. Design your own templates and save time.
- Projects. Update whole projects to Internet, replace through entire projects etc.
- Intelligent code insertion. Does not fill up your document with unnecessary HTML code (which increases download 

time).
- Import links from Netscape Bookmarks, Internet Explorers Favorites and any HTML document.
- Unlimited number of open documents. Unlimited length of document..
- Mini explorer with fast access to documents and copying, moving, renaming, deletion etc. Insert links and objects 

with drag and drop.
- Internal browser (requires MS Internet Explorer on the computer)
- Transfer to Internet. Updating of changed files on Internet..
- Built-in image viewer. Supports GIF, JPEG and GIF animations.
- Auto detects the size of inserted images.
- Dialog boxes for inserting links, images, sound, tables, frames, forms, lists, meta information etc.
- Insertion of user defined HTML tags.
- Validates your HTML tags
- Script editor. Supports Java with syntax coloring, java object hierarchy etc.
- See the Transfer time for your website at different modem speeds.
- Lots of keyboard shortcuts.
- Extended Replace can replace text and code in all documents in a project, in a folder or in all open documents.



What is an HTML Document?
A HTML-document is a text document without formatting and can actually be made in    Notepad. 
By inserting different HTML-codes, that can be read by a diversity of browsers (e.g. Netscape and Internet Explorer),
you can format text, make tables, insert pictures and sounds, establish links to other HTML-documents etc.

WebWriter contains a long series of commands and    dialog boxes, that makes it easier and faster to construct a 
website. You can easily get started without knowing much about HTML coding.

You must be aware of the fact that is no such thing of a 100 % unity on a HTML standard. Some HTML-tags work 
only in some browsers and although the same tag works in both Netscape and Internet Explorer it might not give 
the same result.
That's why you ought to check your website in all the popular browsers. 

The HTML-tags that WebWriter inserts, work in the newest versions of both Netscape and Internet Explorer

Related topics:
{button ,JC("WebWrite.hlp",11)} Why Not Use a WYSIWYG Editor?
{button ,JC("WebWrite.hlp",13)} Learn HTML with WebWriter 
{button ,JC("WebWrite.hlp",14)} Further Information About WebWriter 



Why Not Use a WYSIWYG Editor?
There are several WYSIWYG-editors on the market, that is programs, where you in principle work with a HTML-
document, as in a desktop publishing program. All tag interpretation takes place beneath the user interface.

The problem is that these editors still aren't reliable. The viewing is never perfect so you have to open your 
document in your browsers anyway to see how it really looks.

And you cannot be a 100 % sure of the tag interpretation and therefore you will often have to change the tag to 
make the side look as you want it to. 

Furthermore these WYSIWYG-editors have a    tendency to pour (superfluous) tag into your document, which means 
that the site will take longer time to download for the reader. 

In addition it is unfortunately a fact that most of these programs simply destroy tags.

Finally they naturally work somewhat slower than text based editors.

Related topics:
{button ,JC("WebWrite.hlp",10)} What is an HTML document?
{button ,JC("WebWrite.hlp",13)} Learn HTML with WebWriter
{button ,JC("WebWrite.hlp",14)} Further Information About WebWriter 



Learn HTML With WebWriter
If you want to make advanced websites it is a good idea to learn a little about HTML programming.

WebWriter has a built-in dynamic help function that can be used to learn the different tags. 
When you move the mouse over a control, you can see a small help text at the bottom of the dialog box, a text that
partly tells more of the function of the control and partly shows the concerned HTML tag.

Related topics:
{button ,JC("WebWrite.hlp",10)} What is an HTML document?
{button ,JC("WebWrite.hlp",11)} Why Not Use a WYSIWYG Editor?
{button ,JC("WebWrite.hlp",14)} Further Information About WebWriter



Further Information About HTML, Java etc.
If you want to learn more HTML and all the tags I can recommend the HTML Reference Library.. HTMLib is in 
Windows help file format, and can be integrated into. See HTML-help file. HTML Reference Library is found on well-
stocked shareware sites on Internet.

Another possibility is the Web Design Group's Help file Distribution Page at:
http://www.htmlhelp.com/distribution/

Newest edition of "World Wide Web FAQ" can be found on Internet.

You will find a very good introduction to Javascript at
http://home.netscape.com/

Related topics:
{button ,JC("WebWrite.hlp",10)} What is an HTML-document?
{button ,JC("WebWrite.hlp",11)} Why Not Use a WYSIWYG Editor?
{button ,JC("WebWrite.hlp",13)} Learn HTML with WebWriter



Layout
Define what you want with the site. Is it for example the content or the artificial impression that is most important?
If you would like people to read your text you must make sure that the text is easily read. That is, be aware of your 
choice of fonts and colors and be careful with multicolored backgrounds.

Always check your site in both Netscape and Internet Explorers newest versions. Partly because they interpret some
parameters differently and partly because not all HTML element work in both browsers. 
It is at very bad idea to make a site that only half of your visitors can see properly. And writing that the site is 
optimized for Internet Explorer or Netscape is ok, but don't count on anyone opening another browser just to see 
your site. 

In WebWriter all the HTML-elements and parameters you find in various dialog boxes work in the newest version of 
both Netscape and Internet Explorer. You can find some of the browser specific HTML elements in the HTML tag box,
but otherwise you'll have to seek them out yourself if you insist on making a site that is reserved for special users.

Check your site in different screen resolutions. The site should also be viewable with 640x480 in 256 colors.

Related topics:
{button ,JC("WebWrite.hlp",21)} Using Graphics
{button ,JC("WebWrite.hlp",22)} Using Colors
{button ,JC("WebWrite.hlp",23)} Using Effects



Using Graphics
Use graphics with care. Graphics take up more space that text and it takes more time to feed into your browser. If 
your graphics take up too much place you risk that people don't want to wait for your page.

Don't flood your site with graphics and take care that you optimize your images through color reduction and 
compression, so that it takes up as little space as possible.

In WebWriter you can get a survey of how much space your site takes up including graphics, and an estimate of 
how much time it takes to read the site with different modems. Right-click in a document or on a .htm/.html-file and
choose Properties.

If you want to be sure that your graphics is shown correctly it must consist of colors from the Netscape palette. You 
can find several image processing programs specially designed to optimize GIF- and JPEG-images concerning 
palette, color reduction and compression.

Notice that many people turn graphics off, to get a faster download. Your site ought to work without graphics - as a 
minimum the visitor should have an idea about what the site contains to be able to decide whether to turn on 
graphics or not.

Related topics:
{button ,JC("WebWrite.hlp",20)} Layout
{button ,JC("WebWrite.hlp",22)} Using Colors
{button ,JC("WebWrite.hlp",23)} Using Effects



Using Colors
You should consider that many people still use only 256 colors. If you use 256 colors, you'll experience some funny 
adventure surfing Internet. This is caused by some people's use of colors.

It isn't enough that your page does only show 256 simultaneous colors. If you want to be absolutely certain at the 
colors are right no matter what browser is used and no matter if it's on a Mac or a PC, then you should use colors 
from the Netscape palette.

The Netscape palette consist of 216 colors made up by 6 values: 0, 51, 102, 153, 204 and 255, for respectively red, 
green and blue. E.g. (0,0,0)= black, (255,0,0)=red. In all 6x6x6 combinations = 216.

WebWriter has a built-in Web color dialog box, from where you can choose "web safe" colors. If you want to use the 
Windows standard color dialog box    in stead, you just have to turn off the Web color dialog box in the menu 
Functions under Properties on the General tab.

Related topics:
{button ,JC("WebWrite.hlp",20)} Layout
{button ,JC("WebWrite.hlp",21)} Using Graphics
{button ,JC("WebWrite.hlp",23)} Using Effects



Using Effects
There are a lot of effects, that can help vitalizing a website, but they are to be used with care. They may increase 
the time of download considerably and they may also - badly used - make the site more or less unreadable. 

Sound
If you embed background sound then keep it at 10-30 KB. If you will offer your visitor harmonious sound that 
demands a bigger file you ought to make it optional by making a link to the sound file and make a note about what 
kind of music it is you are about to hear. 
Note that midi files take up considerably less space compared to the playing time than wave-files do.

Marquees
IS generally a bad idea. They are difficult to read because they never move at the right speed. The nice thing about 
reading text is that you decide your own reading speed. Marquees/illuminated signs belong on building etc. Where 
there isn't room enough for all the text. 

Moving text in the status line
Absolutely banned, should you ask for my opinion. It's hard to read (cf. Marquees), and then it hides more relevant 
information from the program! Besides it might even appear to be wasted,    because many people don't even look 
down there. 

ActiveX, Java etc.
With ActiveX, Java etc. you can make all kinds of funny stuff. It just isn't sure that your visitor considers it funny that
half a megabyte of unidentified file is downloaded to his or her harddisk. Therefore - any files over 30 KB: Give a 
warning, tell what it is, and give if possible/convenient the possibility to deselect the ActiveX control and see your 
site anyway. 

Rule of thumb You cannot count on that many people bother to wait for more than 10-20 seconds unless you are 
dealing out free beer or something and that's why every single page on your website should not be bigger than 30-
50 KB, everything included.

Related topics:
{button ,JC("WebWrite.hlp",20)} Layout
{button ,JC("WebWrite.hlp",21)} Using Graphics
{button ,JC("WebWrite.hlp",22)} Using Colors



Starting a New Web Page
You get started by clicking New in the File menu. This makes the template dialog box appear to let you choose 
which template you want your side based on. Choose "Empty document", if you want to start from scratch. (When 
you open WebWriter an empty document opens for you.)

If you start with an empty document, you can insert the basic HTML tags that are necessary in a document by 

choosing Basic tags, new doc... in the Insert menu or by clicking. . 
Then a    dialog box appears to give you a chance to choose a document title, text color, link color and background 
color or a background picture. After this you can start typing your contents.

If the page will contain frames you have to remove the check mark in "Include <BODY>".

Related topics:
{button ,JC("WebWrite.hlp",10)} What is an HTML document?
{button ,JC("WebWrite.hlp",55)} Basic tags
{button ,JC("WebWrite.hlp",51)} Formatting Text
{button ,JC("WebWrite.hlp",52)} Inserting Links, Pictures, Sound, Tables etc.



Formatting Text
You format the text with HTML tags by marking it with the mouse (or via the keyboard with the prevailing Windows 
95 keyboard shortcuts) and choosing the desired command in the Format menu or by right clicking with the mouse 
and choosing among the command in the context-sensitive menu. 
Read more under Formatting text 

Note! You have to insert tags for carriage return and paragraph. Place the cursor where you want the carriage 
return and choose Line break in the Insert menu or by pressing Ctrl+Enter

Related topics:
{button ,JC("WebWrite.hlp",110)} Formatting text
{button ,JC("WebWrite.hlp",52)} Inserting Links, Pictures, Sound, Tables etc.



Inserting Links, Pictures, Sound, Tables etc.
You can insert links to other HTML documents, pictures etc. by placing the cursor where you want the link in the 
document and the choose the object in the Insert menu. 

You might also right-click where you want the tag and then choose an Object dialog box in the right-click menu. 

You may also drag and drop objects (other htm-filer, image files, sound files etc.) from the WebWriter Explorer with 
the mouse to the desired spot in your document.

Related topics:
{button ,JC("WebWrite.hlp",51)} Formatting Text
{button ,JC("WebWrite.hlp",160)} Links
{button ,JC("WebWrite.hlp",210)} Pictures



Editing Previously Inserted HTML Tags
Basic tags, i.e. the documents background color / -picture, link color etc. Are easily edited by clicking.

If you want to change the font size, the justification in a cell, a link etc., the easiest way is to right click in the tag in 
question. The relevant dialog box appears with a survey of the currently chosen settings and the possibility to 
change every single one of them. 

If you just want to change a single color tag you just have to mark the tag (name or numbers) and choose Colors 
from the Insert menu. 

Related topics:
{button ,JC("WebWrite.hlp",54)} Change the Title of the Web Page



Change the Title of the Web Page
It's nice and easy to change the title by choosing Rename title in the Functions menu or in the right click 
menu.

Note! The title is not the same as the filename. The title is the text shown in the title line of the browser and on 
the tabs in WebWriter. In the title you are free to use space, upper and lower case,    special characters etc. 

You should keep the filenames within the DOS conventions (8 lower case letters, no special characters), unless 
you are sure your Internet provider supports long filenames.

Related topics:
{button ,JC("WebWrite.hlp",53)} Editing Previously Inserted HTML Tags



Basic Tags

Choose Basic tags, New page... in the Insert menu.

From the Basic tags dialog box the HTML tags that are required to start are inserted into your document, and it 
gives you the opportunity to choose a title for the document, color for text and background or to choose a 
background picture. 
By clicking you can search your computer for usable pictures.

Document type
Information about which HTML standard your document contains..

Basic tags for documents with frames. 
By removing the check mark in "Include <BODY>", the <BODY>-tag is omitted. That is relevant, if the document 
will contain frames. Information about background, text colors etc. are in the <BODY> tag in the documents, the 
will appear in the frames. 

Include colors
Check this if you want to replace the standard colors for background, text and links in your document.



Approval in Browser
You can use WebWriters internal browser, and you can connect a series of external browsers to look through your 
websites. 

Internal browser
Note! In order to use the WebWriters internal browser MS Internet Explorer 3.01 (or later) must be installed on 
your computer. 

Open the internal browser by choosing Internal Browser in the View menu or by pressing    the F12 key. 
(If you get the message "Unspecified error", read the readme.txt file in the WebWriter folder. 

External browser
You can open the active document in en external browser by choosing View page in external browser in the View 
menu or by pressing the F11 key. 
You have to specify the path to the external browsers. See Web browserScribble82.

If you have installed more browsers, you'll get a menu with the installed browsers. 

You can avoid the menu by holding the Shift key down, when you press the F11 key or click . This opens the 
first browser on the list. 

You can turn off the browser menu by removing the check mark in "Show menu" on the Program paths tab under 
Settings in the Functions menu. 

Here you may also specify whether WebWriter should automatically save your document before showing it in the 
browser.

Related topics:
{button ,JC("WebWrite.hlp",61)} Validating HTML tags
{button ,JC("WebWrite.hlp",62)} Survey of the Web Site's Connections
{button ,JC("WebWrite.hlp",63)} Time of Transfer
{button ,JC("WebWrite.hlp",64)} Parent Page



Validating HTML Tags
Choose Validate HTML tags in the Functions menu to check the tags in the active document. This function might
help you finding possible error in your tag. 

The function checks if there are an equal number of start- and end tag signs("<" and ">"), and if there are an equal 
number of start- and end tags of the different elements. 

The function does not discover all errors and it cannot always tell you where in the document your error is 
But you will get an idea of what to be looking for and in some cases WebWriter may give you a precise report as to 
in which line the error(s) was (were) found. 

Please realize that one single error can release more error messages. For instance the tag "<B>fed</<B>" will 
release a message that there are an uneven number of "<B>" and "</B>", that there are an uneven number of "<"
and ">" AND that some "<" and ">" were misplaced, but all 3 errors stand corrected in one stroke by deleting the 
superfluous start tag "<".

Related topics:
{button ,JC("WebWrite.hlp",60)} Approval in Browser
{button ,JC("WebWrite.hlp",62)} Survey of the Web Site's Connections
{button ,JC("WebWrite.hlp",63)} Time of Transfer
{button ,JC("WebWrite.hlp",64)} Parent Page



Survey of the Web Site's Connections
You can see, which connections (links, pictures etc.) A document contains. Right click on the file in the WebWriter 
Explorer and choose Properties. Choose the Connections Tab.
By using the buttons in the toolbar you can choose to see all connections at once or just one type of connection. 

You can select one or more (hold Shift or Ctrl down while you choose) and copy them to be inserted in another 
document. (Copy by pressing Ctrl+C or right click and choosing Copy in the right click menu.

Related topics:
{button ,JC("WebWrite.hlp",60)} Approval in Browser
{button ,JC("WebWrite.hlp",61)} Validating HTML tags
{button ,JC("WebWrite.hlp",63)} Time of Transfer
{button ,JC("WebWrite.hlp",64)} Parent Page



Time of Transfer 
Right click a document in the Explorer and choose Properties. On the Transfer time tab you'll see a list of how 
much space the document with connected graphics etc. take up and a calculation of the optimal transfer time at 
different modem speeds.

(Remember it's no use producing a beautiful page with cool graphics, heavy background music etc. if it gets so big 
that no one bothers to wait for it) 

Related topics:
{button ,JC("WebWrite.hlp",60)} Approval in Browser
{button ,JC("WebWrite.hlp",61)} Validating HTML tags
{button ,JC("WebWrite.hlp",62)} Survey of the Web Site's Connections
{button ,JC("WebWrite.hlp",64)} Parent Page



Parent Page
You can ease the checking if you work with frames. If you work on a page that is to be read into a page with frames 
(The Initial Page), you might prefer to se the Initial Page in the browser rather than seeing only the page you are 
currently working on.

Open the Initial Page and right click in it and check Parent Page in the right click menu. Every time you click View 
in external browser in the View menu the Parent Page is opened, no matter which document is active.

Note! 
1        This Function does only work in the external browser. The internal browser will always show the active 
document 
2        This function needs you to have checked the Save document when opening browser in the Program 
Paths Tab under Settings... in the Functions menu. 

Related topics:
{button ,JC("WebWrite.hlp",60)} Approval in Browser
{button ,JC("WebWrite.hlp",61)} Validating HTML tags
{button ,JC("WebWrite.hlp",62)} Survey of the Web Site's Connections
{button ,JC("WebWrite.hlp",63)} Time of Transfer



WebWriter Explorer
By selecting and right clicking files in WebWriter Explorer you can execute simple tasks as rename, copy, move and 
delete files.

And you can make links to HTML pages and images by dragging the file in question into the document. The link is 
inserted were you let go of the mouse button. 

You may change how files are shown by choosing View in the View menu. Choose between Big icons, Small 
icons, List and Details. 
If you choose details you'll see a list of information on every file: size, date of creation, change and opening, 
attributes etc. (You can make the Explorer bigger by placing the mouse between the explorer and the word 
processor and then pull.

Related topics:
{button ,JC("WebWrite.hlp",71)} Opening Documents
{button ,JC("WebWrite.hlp",72)} Fast Closing of Documents
{button ,JC("WebWrite.hlp",73)} Opening Image And Sound Files
{button ,JC("WebWrite.hlp",74)} View Another Type of File in the Explorer



Opening Documents
There are more ways to open documents. 

-    double click on the desired file in WebWriter Explorer on the left side of the program window. 
-    you can open more file simultaneously by selecting the desired files holding down the control key. Right click on 
one of the selecting files and choose Open. 
-    double click the desired file in Stones Project Explorer on the left side of the program window.
-    you can open all files in a project by double clicking on the project in the Project Explorer 
-    click File and choose one of the 4 most recently closed files at the bottom of the menu. 
-    click File and Open. The Open dialog box usually shows all HTML documents. On the "File types" list you can 
choose to see WebWriter templates (*.wws) and    text files (*.txt).

Related topics:
{button ,JC("WebWrite.hlp",72)} Fast Closing of Documents
{button ,JC("WebWrite.hlp",73)} Opening Image And Sound Files
{button ,JC("WebWrite.hlp",74)} View Another Type of File in the Explorer



Fast Closing of Documents 
Click the small button with the X beside the drive box to close the active document. 

If you have hidden WebWriter Explorer you can also close a document by hitting Ctrl+F4 or by right clicking 
somewhere in the document, (outside any colored tag) choose Close document.

Related topics:
{button ,JC("WebWrite.hlp",71)} Opening Documents
{button ,JC("WebWrite.hlp",73)} Opening Image And Sound Files
{button ,JC("WebWrite.hlp",74)} View Another Type of File in the Explorer



Opening Image and Sound Files 
You can open image files .gif and .jpg, and sound files .wav and .mid, (and all other files) from The WebWriter 
Explorer by double clicking them. 

By default files open in whatever program they belong to (is "associated" to).

In the case of image files you can specify them to be opened in another program, like a viewer, that opens faster 
than your favorite graphic editor. The path to the desired program must be specified.. See Graphic 
programScribble85.

Tip!
If you have no viewer you can specify the path to your browser. As your browser probably is open because you are 
working on a website it'll be must faster (and use less memory) than if you'd use a graphic editor.

Related topics:
{button ,JC("WebWrite.hlp",71)} Opening Documents
{button ,JC("WebWrite.hlp",72)} Fast Closing of Documents
{button ,JC("WebWrite.hlp",74)} View Another Type of File in the Explorer



View Another Type of File in the Explorer 
You decide what type of file is to be shown in WebWriter Explorer by clicking in the file filter under the explorer.

-    First button shows HTML manuscripts (.htm and .html).
- Second button shows image files (.gif and .jpg).
- Third button shows sound files (.wav, .au and .mid).
- Fourth button shows all files (*.*).

You might also change the type of file through the menu: View - Type of file or by right clicking in the explorer.

Related topics:
{button ,JC("WebWrite.hlp",71)} Opening Documents
{button ,JC("WebWrite.hlp",72)} Fast Closing of Documents
{button ,JC("WebWrite.hlp",73)} Opening Image And Sound Files



Settings, Survey

Here you can specify settings for WebWriter.
When you have finished your selections, choose Save, to save the settings in the Windows 95 Registry for future 
sessions.

See:
{button ,JC("WebWrite.hlp",81)} Text Editor
{button ,JC("WebWrite.hlp",82)} Browser
{button ,JC("WebWrite.hlp",83)} HTML Help File
{button ,JC("WebWrite.hlp",84)} E-mail Address
{button ,JC("WebWrite.hlp",85)} Graphics Program
{button ,JC("WebWrite.hlp",86)} Save Document When Viewing in Browser
{button ,JC("WebWrite.hlp",88)} View Template Dialog Box
{button ,JC("WebWrite.hlp",89)} Date of Updating
{button ,JC("WebWrite.hlp",90)} HTML File Type
{button ,JC("WebWrite.hlp",91)} Converting Extended Characters
{button ,JC("WebWrite.hlp",92)} Image Viewing
{button ,JC("WebWrite.hlp",93)} Color Selection
{button ,JC("WebWrite.hlp",94)} Font Selection
{button ,JC("WebWrite.hlp",95)} Button Style
{button ,JC("WebWrite.hlp",96)} Use Archive Flag 
{button ,JC("WebWrite.hlp",97)} Unknown HTML Tags
{button ,JC("WebWrite.hlp",98)} Initial Folder
{button ,JC("WebWrite.hlp",99)} Date Format



Text Editor 
Click Settings... in the Functions menu. The settings for the text editor are on the Text editor tab.

Tag coloring
Specify how WebWriter colors the HTML tag.

Choose between "WebWriter 2", "WebWriter 1", "User" or "None".

If you choose User you can specify colors for text and background for ordinary text, HTML-elements, attributes, 
values and comments. If you select the "Same background" the other text types get the same background color as 
the "Ordinary text".

Font
Change font in WebWriters text editor.

Tabulator
Specify how many characters the text is indented with the tabulator key. 

Text wrap
Determines if the text as default is wrapped or not, when a document is opened

Convert tags to upper case automatically
Converts HTML-elements and -parameters every tike the document is saved. Please note that it is more time 
consuming to Save a document with this option turned on.



Browser
Click Settings... in the Functions menu. The Web browser settings are specified on the Program Path tab. 

Internal browser
If you have MS Internet Explorer on your computer, you can use it as an internal browser.

External browsers
Here you can specify the path to one or more web browsers, in which you can open your HTML documents by 
choosing View in external browser in the View menu or by hitting F11. 

by clicking "Add" you can install a browser in WebWriter.
In the produced dialog box you can make WebWriter find both Netscape and Internet Explorer by clicking the 
respective buttons. 
You can search for browser on your hard drive by clicking the file button. 

In addition you have to fill in the "Name" field, which is the name the browser gets in the browser menu, if you 
install more than one browser.

Click "Edit" to change the data for the selected browser. Click "Delete" to delete the selected browser.

If you temporarily want WebWriter to open the web page in the upper browser without showing you a menu you 
should unselect the "Show menu" field. 
When you want to see the menu with the installed browsers, select the "Show menu" field again. 

Related topics:
{button ,JC("WebWrite.hlp",86)} Save Document When Viewing in Browser



HTML Help File
Click Settings in the Functions menu. The HTML-help file is specified on the Program Path tab.

You can specify the path to an external HTML-help file as e.g. the HTML Reference Library. 
Then you can open the help file by choosing HTML-help in the Help menu or by pressing Shift+F1. 
You can select an HTML-element or an HTML-attribute, and press Shift+F1 to get direct help.

{button ,JC("WebWrite.hlp",14)} Further Information on HTML



E-mail Address
Click Settings in the Functions menu. The E-mail address is specified on the General tab. 

Here you can specify an E-mail address that you frequently insert into your HTML-documents. The E-mail address 
and the stated description will de default choices in the    E-mail dialog box.



Graphic Program
Click Settings in the Functions menu. The path to the graphic program is set on the Program paths tab.

Specify the path to a graphics program you want to use for viewing and editing .gif- and .jpg-files. Click     to 
search for the program.
When the path is specifiedyou can open images by double clicking them in WebWriter Explorer.



Save Document When Viewing in Browser
Click Settings in the Functions menu. The path to the graphics program is specified on the Program Path tab. 

Here you can specify the path to a graphics program, that you want to use for viewing and editing .gif- and .jpg-
files. Click to search for your favorite graphics program.
When the path is specified, you can open image files in the program by double clicking them in WebWriter Explorer.

Note! 
If you are working with frames and you use the "Parent Page" function you have to check this field, or save the 
original document manually, because your parent document does not contain the name of the temporary file and 
therefore it will open the original file into the browser.

{button ,JC("WebWrite.hlp",82)} Browser



View Template Dialog Box
Click Settings in the Functions menu. The setting is on the Layout tab.

Select the "View Template dialog box, if you want to see the template dialog box when you click . Remove the 
check select if you want an empty document.



Date of Updating 
Click Settings in the Functions menu. The setting is on the HTML-facilities tab.

If you select "Insert Date of Updating when the document is saved", WebWriter automatically updates the Date of 
Updating, when you save changes in a document. 

If a document does not contain a WebWriter-Date of Updating beforehand, when you save a document, you will be 
asked if you want Date of Updating inserted. If your answer is no, this function will be turned off. 

(What happens is that this comment is inserted in the beginning of the document: "<!---Minus Autodate--->"). 

If, later on, you decide to have a Date of Updating in the document in question, you can choose "Insert, Date of 
Updating", the date is inserted (and the above mentioned comment is deleted).

If you want to add a text e.g.    "This page was updated on", or if you want the date to be bold, italic or have another
size, you must place text and HTML tags outside the comment tags that    WebWriter has inserted, if not your 
additions will be deleted the next time you run the date command.

Related topics:
{button ,JC("WebWrite.hlp",99)} Date Format



HTML File Type
Click Settings in the Functions menu. The setting is on the HTML-facilities tab.

If you select "Save HTML-documents as ".html"-files", the HTML documents are saved with the file type ".html" in 
stead of ".htm".



Converting Extended Characters
Click Settings in the Functions menu. The setting is done on HTML-facilities tab.

If you select in "Automatically Convert Extended Characters", WebWriter automatically inserts the international tags
for the extended characters in the .htm-file, when you Save your document, and replaces the tags with extended 
characters, when you open the document.

You must be aware that it may take some seconds to save long documents. If you want to avoid waiting time, while 
working on a document, you should use the "Save with Extended characters" in the "File"-menu, when you have 
finished editing and are ready to at transfer to the server.



Image Viewing
Click Settings in the Functions menu. The setting is on the Layout tab.

Select the "View images in explorer", if you want WebWriter to show a miniature, when you select an image file in 
the explorer



Color Selection
Click Settings in the Functions menu. The setting is on the HTML-facilities tab.

Select the "Use Web color dialog box", if you want to make use of the Web color dialog box, that secures that the 
chosen colors are shown correctly independent of the receivers color solution, operating system and browser. 
Unselect if you want to use the Windows default color dialog box.



Font Selection 
Click Settings in the Functions menu. The setting is on the HTML-facilities tab.

You can choose between 2 lists with fonts, when you format writing in the Font dialog box.

If you select the "Use Web font list" you get a limited list of standard fonts. When you choose a font from this list, a 
priority list is inserted, so that a similar font is inserted, if the user doesn't have the chosen font installed on his 
computer. The list does also contain the corresponding MacIntosh fonts.

If you remove the check select you'll get a list of all fonts installed on your own computer. (But remember if he who 
visits your site, doesn't have the chosen font installed he will just see a default font, usually Times New Roman).



Button Style
Click Settings in the Functions menu. The settings are made on the Layout tab.

Select the "Use old style button in toolbar" if you prefer the old, clearer buttons in the toolbar to the new flat ones.



Use Archive Flag
Click Settings in the Functions menu. The setting is on the Layout tab.

Select the "Use archive flag on updating project to Internet", if you want WebWriter to keep track of which files have
been transferred to Internet by setting the files archive flag. 

You must draw your attention to the fact that backup programs on supplementary backup use the archive flag. In 
other words, if you transfer a file to Internet, the archive flag will be set and the backup program thinks that the file 
hasn't been changed since the last backup and vice versa. If you make a backup of a changed file WebWriter 
believes that the file has been updated to Internet.

If you turn this facility on, you'll have to make sure it works together with your backup program. E.g. you can see to 
it that you do always take a full backup of your website-files and tell the backup program not to touch the archive 
flags or make a backup immediately after updating your website.



Unknown HTML Tag
Click on Settings in the Functions menu. The selection of "Keep unknown contents in HTML tag on right click 
editing" is made in the HTML facilities tab.

Unknown contents can be both errors in the HTML tag and it can be attributes that WebWriter does not know. 

For beginners it may be of advantage not to check this option because this might help you clean your tag of error 
simply by right clicking it.

Advanced users who are able to find possible errors themselves and who use advanced attributes (e.g. Java events),
should check this option.



Initial Folder 

Here you can choose in which folder you want the open dialog box to start when WebWriter is started.



Date Format

Click Settings in the Functions menu. Choose the Diverse tab.
Specify the desired date format in the text box "Date format" as in the specifications mentioned below 

c Shows date with Windows' short date format followed by time in the Windows long time format.
d Shows number of day without preceding zero (1-31).
dd Shows number of day with preceding zero (01-31).
ddd Shows name of the day in short version (mon-sun).
dddd Shows name of the day in full version (monday-sunday).
ddddd Shows date in Windows' short date format.
dddddd Shows date in Windows' long date format.
m Shows number of month without preceding zero (1-12). If m immediately precedes h or hh, vises minutes 
in stead of month.
mm Shows number of month with preceding zero (01-12). If m immediately precedes h or hh, vises minutes in 
stead of month.
mmm Shows name of the month in abridged version (jan-dec).
mmmm Shows name of the month in full version (january-december).
yy Shows year as a double-figured number (00-99).
yyyy Shows year as a quadrupled number (0000-9999).
h Shows hour without preceding zero (0-23).
hh Shows hour with preceding zero (00-23).
n Shows minutes without preceding zero (0-59).
nn Shows minutes with preceding zero (00-59).
s Shows seconds without preceding zero (0-59).
ss Shows seconds with preceding zero (00-59).
t Shows hour in Windows' short time format.
tt Shows hour in Windows' long time format.
am/pm Utilizes the 12-hour watch for the preceding time specification, and sets 'am' after hours before noon and 

'pm' after noon. Use upper or lower case.
a/p Utilizes the 12-hour watch for the preceding time specification, and sets 'a' after hours before noon and 'p' 

after noon. Use upper or lower case.
ampm Uses Windows' 12-hour watch.
/ Shows Windows' date separator.
: Shows Windows' time separator.
'xx'/"xx" Characters surrounded by quotation characters are shown unchanged and do not effect the formatting. 

Example:
No later than dddd, 'the' d mmmm, yyyy, at. hh:mm AM/PM
Gives this result:
No later than wedneysday the 15. february, 1998, at. 10:30 AM

Related topics:
{button ,JC("WebWrite.hlp",89)} Date of Updating



Adding Your Own HTML Tags 
Choose the HTML Tag Box... in the View menu. Click "Add" to add a tag. User defined tags are checked with an 
"*".

You can edit existing user tag by clicking the tag and choosing "Edit" (or "Delete" to delete it). 

Move the User tags up and down by clicking .
The upper 9 user tags can be inserted from User tags in the Insert menu.



Uninstalling WebWriter
WebWriter can be uninstalled from Windows Control Panel. Click "Add/remove programs" and find Stone's 
WebWriter on the list.

Furthermore WebWriter has written some keys in the Registry. You can leave them there, men if you want to remove
them it is very simple:

1 Open Registry by choosing Run in the Start menu and type "regedit".

2 Click the plus sign on the second key called "HKEY_CURRENT_USER". Click the    plus sign on the "Software" key.

3 Find the folder "Stone's Software" double click it and find the folder "WebWriter". Right click it and choose Delete. 
Confirm this by answering yes.



The Status Line

WebWriters Status line shows a series of useful information. Which information is shown depends on whether it is 
the word processor of the explorer that is in focus.

Focus on the text editor 
You get that by clicking in the open document.

1 File name and path is shown in the first field of the status line.

2 Number of characters in the document is shown in the second field in the status line. 

3 Position in the document is shown in the third field. First value is the line number, the second number is the 
characters position on the line.

Note! A line ends with a carriage return sign (a "hard" line break). This means that when text is wrapped in the text 
editor (with 'soft' line breaks) one line of text may cover several lines in the editor. 

4 Date - the actual data in the fourth field on the WebWriter Status line.

Focus on WebWriter Explorer 
Is obtained by clicking a file in the Explorer 

1a Document title is shown in the first field if it is an HTML document

1b The height and width of the image is shown if it is am image file. 

2 File size is shown in the second field



Text Formatting
You can format text in two ways using the Font dialog box:

1 Mark a text area and click the Font dialog button. Choose a font, a size or a color and all of the marked text will be
formatted. If part of the marked text had another font, size or color this formatting will be removed, just like when 
you format text in a text editor. 

2 Place the cursor in a font tag and right click. This will bring out the font dialog box and you may change 
any settings. WebWriter will find the end tag belonging to the start tag you have clicked inside, and mark all of the
text in between. Any inserted formatting of the text within the tags will not be altered as shown below. 

<FONT FACE="Times New Roman" SIZE=2>
If you right click in the first font tag and change the font tag to 
<FONT FACE="Courier">
this font will still be Courier,
</FONT>
after having changed this font from Times New Roman to something else 
</FONT>

If you want to change for all of the text you will have to mark all of it and use method number 1.

Size
Size can be specified absolutely (1-7) or relatively (+-n) in relation to the basic font size. 

Default basic font size is 3, but can be changed with the <BASEFONT>-element, that is found in WebWriters HTML 
tag box "Insert, HTML tags".

The dialog box shows the actual font
If you right click in the tag with the "Courier" font, the dialog box will tell that the size is 2, even if it doesn't appear 
to be in the tag in which you right clicked. On opening the font dialog box the document is searched for the values 
that apply to the text. 

WebWriter economizes on the tags.
If you change the size to 3, the tag "SIZE=3" is inserted. If you do not change the size no tag will be inserted, as it 
isn't necessary. 

Using bold, italic and underlined text
You can also specify the typography in the Font dialog box. It operates in the same way no matter if you have 
marked some area of text (1) or right clicked in an already existing font tag(2).

Mixed typography
If parts of the marked text is for example bold, the "Typography" field will be empty and the Mixed typography will 
state "bold".

If you do not change the typography settings the formatting will be preserved. But if you choose "bold" all of the 
marked text will be bold - and if you choose "normal", all of the text will be normal.

Exception: Tables
For the moment it is still a fact that tables does not bother about surrounding font formatting. If you want to format 
text in a table, you have to format the text in every single cell.

This will probably be changed in the next version of the leading browsers, therefore WebWriter checks outside the 
table to see if there is any HTML tag concerning the text in the table, and reflect that in the font dialog box. But 
although WebWriter shows that the font in a table cell is Arial you still have to make sure the tag is actually inserted
i each and every cell.



Form, Survey
The dialog box is used to build a form, which the user can fill in and send to you.

The Form can contain text fields with different properties and radio buttons, check boxes and choice boxes that give
you the opportunity to construct a form, that can give you as precise information of possible. Finally the form should
contain a "Submit" button, that mails the form to you and a "Clear all" button that provides the user with a chance 
to delete all his entries when finished. 

A small program handles the Form, typically a CGI script, that most Internet providers make available to their 
customers. You can get information from your provider on how to fill in the "Method", "Action" and "Data 
format ????" fields.

Se:
{button ,JC("WebWrite.hlp",116)} Create a New Form
{button ,JC("WebWrite.hlp",117)} Text Field
{button ,JC("WebWrite.hlp",118)} Password Field
{button ,JC("WebWrite.hlp",119)} Hidden Field
{button ,JC("WebWrite.hlp",120)} Text Box 
{button ,JC("WebWrite.hlp",121)} Radio Button
{button ,JC("WebWrite.hlp",122)} Check Box
{button ,JC("WebWrite.hlp",123)} Combo Box
{button ,JC("WebWrite.hlp",124)} Submit Button
{button ,JC("WebWrite.hlp",125)} Reset Button



Create a New Form
The form must be surrounded by the FOR element, <FORM></FORM>. 
Open the Form Dialog Box by choosing Form... in the Structure menu.
Select "New form" in the Form Dialog Box. Fill in the attached fields:

Name
Specify a name that identifies the form. 

Method
Specify which method the form should use. Depends on the protocol in use. Default method is GET.

Action
Is usually filled in with the address of the CGI script that handles the form.

Data format
This field should only be filled in if the protocol that handles the form does not specify a format itself.

Advanced
This is an extra field that gives you the opportunity to include java events and such. Having no default attribute, 
both attribute and value must be specified, e.g. OnSubmit="return MyFunction()". 
A Java script can for example be used to check if a field has been filled in when the form is submitted. (OnSubmit).

Related topics:
{button ,JC("WebWrite.hlp",117)} Text Field
{button ,JC("WebWrite.hlp",118)} Password Field
{button ,JC("WebWrite.hlp",119)} Hidden Field
{button ,JC("WebWrite.hlp",120)} Text Box
{button ,JC("WebWrite.hlp",121)} Radio Button
{button ,JC("WebWrite.hlp",122)} Check Button
{button ,JC("WebWrite.hlp",123)} Combo Box
{button ,JC("WebWrite.hlp",124)} Submit Button
{button ,JC("WebWrite.hlp",125)} Reset Button



Text Field (Form Dialog Box)
In the text field the user can write any text.

Name
Identifies the element.

Text
The text in the text field.

Size
Specifies the length of the text field.

Max. number of characters
You may provide the field with a limit to the possible amount of characters in the field. 

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",118)} Password Field
{button ,JC("WebWrite.hlp",119)} Hidden Field
{button ,JC("WebWrite.hlp",120)} Text Box



Password Field (Form Dialog Box)
The same as a text fieldScribble117, but on keying in stars are shown in stead of characters

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",117)} Text Field
{button ,JC("WebWrite.hlp",119)} Hidden Field
{button ,JC("WebWrite.hlp",120)} Text Box



Hidden Field (Form Dialog Box)
Hidden fields can (as the name implies) not be seen in the form. They are typically used to send information with 
the form that the user is not supposed to change. 
Hidden fields can also be used to give commandos to the program that handles the form.

Hidden files have the same attributes as a text fieldScribble117.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",117)} Text Field
{button ,JC("WebWrite.hlp",118)} Password Field
{button ,JC("WebWrite.hlp",120)} Text Box



Text Box (Form Dialog Box)
The text box can contain more lines of text as opposed to the text field that can only consist of one line.

Name
Identifies the element.

Width
Defines the width of the text box.

Lines
Defines the height of the text box specified in number of lines.

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",117)} Text Field
{button ,JC("WebWrite.hlp",118)} Password Field 
{button ,JC("WebWrite.hlp",119)} Hidden Field



Radio Button (Form Dialog Box)
The radio button is used to give the user some alternatives, from which only one can be selected. Radio buttons 
with the same name belong together. When the user chooses a radio button, all the other radio buttons with the 
same name are automatically deselected.

Name
Identifies the element.

Text
The text, that is returned in the form, if the user has selected the concerned radio button.

Checked
States if the radio button shall be selected when the form is shown. Only one radio button in each group of radio 
buttons can be selected.

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",122)} Check Box
{button ,JC("WebWrite.hlp",123)} Combo Box



Check Box (Form Dialog Box)
The check box is used to give the user a choice between 2 alternatives.

Name
Identifies the element.

Text
The text, which is returned in the form, if the user has checked this check box.

Checked
States if the check box is to be checked when the form is shown.

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",121)} Radio Button
{button ,JC("WebWrite.hlp",123)} Combo Box



Combo Box (Form Dialog Box)
The combo box gives a list of different items to choose from. 

Name
Identifies the element.

Lines
Specify how many items (<OPTION>) the combo box will contain. The texts for the items are specified after the 
<OPTION> element.

The <OPTION> element can consist of the following parameters: DISABLED, SELECTED and VALUE. 
If no element is selected with the SELECTED parameter, the upper item is selected as standard when the form is 
shown.

If you want another text returned in stead of the one shown to the user you'll have to use the VALUE parameter.

Example of a combo box:

<SELECT NAME="TV-channels">
<OPTION VALUE="NBC">NBC – where the stars come out at night
<OPTION SELECTED="True">CNN
<OPTION>BBC World
</SELECT>

The combo box has 3 options:
· NBC
· CNN
· BBC World
CNN is chosen as standard, when the form is shown.
If the user selects NBC - where the starts come out at night, only NBC is returned. Otherwise CNN or ABC is 
returned.

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",121)} Radio Button
{button ,JC("WebWrite.hlp",122)} Check Box



Submit Button (Form Dialog Box)
The Submit button is used to submit the form, when the user has finished filling it in.

Name
Identifies the element.

Text
The text shown in the button.

Advanced
An extra field that gives you the possibility to include Java events.

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",125)} Reset Button



Reset Button (Form Dialog Box)
The Reset button is used to delete all that has been written in the form.

Name
Identifies the element.

Text
The text shown in the button.

Advanced
An extra field that gives you the possibility to include Java events..

Related topics:
{button ,JC("WebWrite.hlp",115)} Form
{button ,JC("WebWrite.hlp",124)} Submit Button



Transfer to Internet, Survey 
You can transfer files to and from Internet directly from WebWriter:

See:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Create a New Connection 
Click Transfer to Internet in the functions menu. 
Click New in the Connection menu in the "Transfer to Internet" window.

Fill in the fields:

Server
The name of the server on Internet, e.g. "ftp.myprovider.com" or "www.mydomain.com".

Start folder
The path to the folder, in which you want to start when the connection is established, e.g.    "public_html/graphics".

User
The user name (User-ID), you got from your Internet provider. 

Password
The password you got from your Internet provider. Check "Save tag", if you want the password to be remembered 
by your computer. 

Choose "Save as..." in the Connection menu to save the connection. Type the name you want for the connection 
and click OK. The connection will be added to the list of connections. 

Related topics:
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Edit Connection
Click Transfer to Internet in the functions menu. 
Click Properties in the Connection menu in the "Transfer to Internet"-window.

Make the desired changes in these fields: Server, Start folder, User and Password and choose Save as... in the 
Connection menu.

Click OK to save the connection with its original name.

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Establish Connection
If you haven't already connected to Internet, you must do so now (e.g. with Windows "Dial-up networking").

Choose Transfer to Internet in the Functions menu. 

Choose Connect in the Connection menu in the "Transfer to Internet"-window. 
Note! Don't click "Connect", before the connection to Internet is fully established.

Select the desired connection from the list "Connection" or create a new connection.

Choose Connect in the Connection menu.

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Transfer Files to Internet (Upload)
1. If you are connected to the ftp server on Internet and the Transfer to Internet window is visible.

You can transfer files from a) WebWriter Explorer, b) The Project survey and c) the text editor.

a) WebWriter Explorer. Mark the desired files in WebWriter Explorer, drag the files with the mouse and drop them on
the server file survey.
b) The Project survey. Drag the desired file from The WebWriters Project Survey and drop it on the server file survey.
c) The Text Editor. Right click in the active document and choose "Transfer to Internet...". Choose "Start transfer" in 
the "Connection" menu.

2. If you are not connected to the ftp-server on Internet.

(Dial up Internet.)

a. Mark files
You can mark files for transfer in a) WebWriter Explorer, b) The Project Survey or c) The Text Editor.

a) WebWriter Explorer. Mark the desired files in WebWriter Explorer. Right click and choose "Transfer to Internet...".
b) Project survey. Mark the desired file in WebWriters Project survey, right click and choose "Transfer to Internet...".
c) Text Editor. Right click in the active document and choose "Transfer to Internet...". 

b. Connect to the ftp-server and start transfer 

The "Transfer to Internet"-window is opened.

Choose the desired connection in the combo list of connections and choose Connect in the Connection menu.

Choose Start transfer in the Connection menu.

WebWriter "beeps", when the transfer is finished. 

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Transfer Files From Internet (Download)
Establish the desired connection.
See Establish connectionScribble133.

Check the desired files in the server window. Right click and choose Transfer to.... Choose the folder to which you 
want the files transferred.

You can drag the checked files with the mouse and drop them on the WebWriter Explorer. The files are transferred to
the active folder.

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet 
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Update Project on Internet
Go to the Project survey (The "Projects" tab in WebWriters main windows) and right click the    project, you want to 
update.
In the right click menu you choose Update project on Internet....

In the resulting windows a survey of the projects files is shown including image files, sound files etc. 

If you have checked the "Use archive flag on updating project to Internet" under Settings in the Functions menu, 
only files that have been changed since the last update will be checked for Transfer. Otherwise all files in the project
will be checked.

You can tag or untag files. Choose OK, when finished.

Connect to Internet and establish the desired connection.
See Establish connectionScribble133.

Choose Start transfer in the Connection menu, when the connection too the server is established.

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",137)} Delete files and folders



Delete Files and Folders
You delete files and folders by checking them and hitting Delete on the keyboard.
Note! Folders must be empty to be deleted.

Related topics:
{button ,JC("WebWrite.hlp",131)} Create a new connection
{button ,JC("WebWrite.hlp",132)} Edit connection
{button ,JC("WebWrite.hlp",133)} Establish connection
{button ,JC("WebWrite.hlp",134)} Transfer files to Internet
{button ,JC("WebWrite.hlp",135)} Transfer files from Internet
{button ,JC("WebWrite.hlp",136)} Update project on Internet



Projects, Survey
You can organize your web pages in projects. This gives you a good general view and it give you the possibility to 
execute functions like open files, find, replace and updating of an entire project to Internet at once.

A project consists of The Root Directory and the attached web pages, that are identified by file name and the 
relative path for the projects Root Directory.

See:
{button ,JC("WebWrite.hlp",141)} Create a new project
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",143)} Edit Root Directory
{button ,JC("WebWrite.hlp",144)} Open all documents
{button ,JC("WebWrite.hlp",136)} Update project to Internet
{button ,JC("WebWrite.hlp",145)} Find in project
{button ,JC("WebWrite.hlp",146)} Replace in project



Create a New Project
Right click on an empty area in the project survey and choose New project.

Choose the projects The Root Directory in the resulting dialog box and choose OK.

Type in the project's name and press Enter.

Related topics:
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",143)} Edit Root Directory
{button ,JC("WebWrite.hlp",144)} Open all document
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",145)} Find in Project
{button ,JC("WebWrite.hlp",146)} Replace in Project



Add Documents
Right click the project and choose Add document in the right click menu. Check the document(s), you wish to add 
to the project, and choose OK.

If you want to add the active document in the text editor to the project, you just have to right click the project and 
choose Add the active document in the right click menu.

Related topics:
{button ,JC("WebWrite.hlp",141)} Create a new Project
{button ,JC("WebWrite.hlp",143)} Edit the Root Directory
{button ,JC("WebWrite.hlp",144)} Open all documents
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",145)} Find in Project
{button ,JC("WebWrite.hlp",146)} Replace in Project



Edit the Root Directory 
If you have moved the documents in a project to another folder, you can edit The Root Directory by right clicking on
the project or the Root Directory and choose Edit the Root Directory....

Select the new Root Directory and choose OK.

Related topics:
{button ,JC("WebWrite.hlp",141)} Create a new Project
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",144)} Open all documents
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",145)} Find in Project
{button ,JC("WebWrite.hlp",146)} Replace in Project



Open All Documents
Open all files in a project by right clicking the project and choose Open all documents.

Related topics:
{button ,JC("WebWrite.hlp",141)} Create a new Project
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",143)} Edit the Root Directory
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",145)} Find in Project
{button ,JC("WebWrite.hlp",146)} Replace in Project



Find in Project
This function finds all occurrences of a text string in all documents of the project and shows them on a list in 
WebWriters main window. You can double click in the search result to open a document and place the cursor on the 
search string.

Right click the project, you want to search in. Choose Find in project... in the right click menu.. See    Extended 
FindScribble250.

Related topics:
{button ,JC("WebWrite.hlp",141)} Create a new Project
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",143)} Edit the Root Directory
{button ,JC("WebWrite.hlp",144)} Open all documents
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",146)} Replace in Project



Replace in Project
This function finds all occurrences of a text string in all documents in the project and replaces them with the 
specified replacement text.

Right click the project in which you wish to replace. Choose Replace in project... in the right click menu. See    
Extended ReplaceScribble251.

Se også:
{button ,JC("WebWrite.hlp",141)} Create a new Project
{button ,JC("WebWrite.hlp",142)} Add documents
{button ,JC("WebWrite.hlp",143)} Edit the Root Directory
{button ,JC("WebWrite.hlp",144)} Open all documents
{button ,JC("WebWrite.hlp",136)} Update Project to Internet
{button ,JC("WebWrite.hlp",145)} Find in Project



The Root Directory
The Root Directory is used as a relative reference as in his example:
You want to update a project to Internet with the Root Directory "c:\Internet\HomePage\". The project consists of the
files: "c:\Internet\HomePage\index.htm" and "c:\Internet\HomePage\Graphics\picture.gif". If the project is transferred
to the folder "User/MyName/" on the ftp server, the file "index.htm" is transferred to the "User/MyName/" folder and 
the file "picture.gif" is transferred to the "User/MyName/Graphics/" folder.

Related topics:
{button ,JC("WebWrite.hlp",140)} Projects



Frames, Survey
You can divide the browser window into smaller windows or frames. It can be appropriate to use frames, if you have 
some information, you want to keep on screen even if the user changes to another page, such as an index or a logo.

The idea of frames is that the page that you read into your browser (the initial page) contains information about 
how the windows is to be divided into frames, and which HTML documents, are to be shown in the different frames. 

The initial page must not contain a <BODY></BODY> element, because the page in itself does not contain anything
for the user to see, but only links to the documents, that are to be read into each frame. A page with frames has the
following structure:

<HTML>
<HEAD>
</HEAD>

<FRAMESET>
<FRAME>
</FRAMESET>
<NOFRAMES>
</NOFRAMES>

</HTML>

<NOFRAMES> contains a short text and possibly alternative links for users whose browsers cannot work with 
frames.
 
Frames work among others in Netscape 2.0 and Internet Explorer 3.0 (and newer).

Choose Frames... in the Structure menu to get the Frame dialog box. 
When you use absolute values (pixels) the scale on the graphical model shows how it will look on a 800x600 screen.

See:
{button ,JC("WebWrite.hlp",151)} Division into frames
{button ,JC("WebWrite.hlp",152)} The Frame Properties
{button ,JC("WebWrite.hlp",153)} Browser Cannot Read Frames
{button ,JC("WebWrite.hlp",154)} Editing the Scale of the Frames



Dividing Into Frames (Frame dialog box)
Under "Division of window" you specify if the browser window shall be divided into rows or columns, and how many 
you want.

Under "Division of rows(/columns)" you decide into how many frames each row or column is to be divided.

Related topics:
{button ,JC("WebWrite.hlp",150)} Generally on Frames
{button ,JC("WebWrite.hlp",152)} The Frame Properties
{button ,JC("WebWrite.hlp",153)} Browser Cannot Read Frames
{button ,JC("WebWrite.hlp",154)} Editing the Scale of the Frames



The Frames Properties (Frame dialog box)
For each frame a series of properties are specified to fix appearance and behavior.

Name
The name is used to identify the frame, if for instance you put a link in one frame to open a page in another frame 
when the link is clicked. An example: If you make a link that opens the document "myside.htm" in the frame "text", 
the links should look like this: 
<A HREF="myside.htm" TARGET="text">Min side</A>

Address
Specifies the address of the document, you want to be opened in the frame.

Margin
Margin sets the distance between the frame and the contents.

Scrolling
"Auto" means that the frame gets scroll bars if needed (if all text etc. cannot be shown in the frame at once). "Yes" 
means that the scroll bars always will be there and "No" means never. 

Adjustment of frame size allowed.
Uncheck this to enable the user to resize your frames. Please realize that this function has influence on the 
surrounding frames.

Dimensions
In "Dimensions" you specify width and height of the checked frame. Default values are relatively in percent of the 
browser windows actual size. If you uncheck the "%" the value for the current frame is in pixels. The size of the 
frame border is specified in pixels.

Related topics:
{button ,JC("WebWrite.hlp",150)} Generally on Frames
{button ,JC("WebWrite.hlp",151)} Division into frames
{button ,JC("WebWrite.hlp",153)} Browser Cannot Read Frames
{button ,JC("WebWrite.hlp",154)} Editing the Scale of the Frames



Browser Cannot Read Frames 
Some browsers cannot read frames. Therefore you ought to specify an alternative text.

In "Alt. text" in the Frame dialog box you can write an alternative text, that is shown if the users browser cannot 
show frames. This text can also contain graphics and links to your own or other pages. The contents are not shown 
if the browser supports frames.

Related topics:
{button ,JC("WebWrite.hlp",150)} Generally on Frames
{button ,JC("WebWrite.hlp",151)} Division into frames
{button ,JC("WebWrite.hlp",152)} The frames properties
{button ,JC("WebWrite.hlp",154)} Editing the Scale of the Frames



Editing the Scale of the Frames 
You can edit the mutual scale of the frames by right clicking the <FRAMESET ...> tag.

Relative values ends with a % character. If you remove the % character the value becomes absolute (in pixels). If 
there is more than one frame in a row or a column, one of these should be represented by an asterisk (*). "*" means
that the frame is assigned the remaining space of the windows.

When you create frames in WebWriters dialog box WebWriter always gives one of the frames in each unity the size 
"*". A comma separates each measurement.

Example:
<FRAMESET ROWS="100%" COLS="140,50%,*">

This frame is divided into 3 columns. The first column is 140 pixels wide, the second column width is 50% of the 
width of the browser window and the third column fills out the rest.

Related topics:
{button ,JC("WebWrite.hlp",150)} Generally on Frames
{button ,JC("WebWrite.hlp",151)} Division into frames
{button ,JC("WebWrite.hlp",152)} The frames properties
{button ,JC("WebWrite.hlp",153)} Browser Cannot Read Frames



Links, Survey 
Choose Link... from the Insert menu
From the Link dialog box you can insert a link to another HTML page locally or anywhere in the world.

See: 
{button ,JC("WebWrite.hlp",161)} Address
{button ,JC("WebWrite.hlp",162)} Links From Netscape, Internet Explorer and Other Web Documents
{button ,JC("WebWrite.hlp",163)} Target
{button ,JC("WebWrite.hlp",164)} Name
{button ,JC("WebWrite.hlp",165)} Description



Address (Link dialog box)

By clicking  you can    search for HTML documents on your computer. 
If you choose a file from another folder than that of the document, the relative path is inserted. That means that 
your website can find other local web pages even if they are not in the same folder. 
But remember that to make it work when the page is on the web server it has to have exactly the same relative 
folder structure and placement of the pages they refer to.

If the document is in the same folder or on another drive, then only the file name is inserted and the file must be 
placed in the same folder as the document, that contains the link.

Related topics:

{button ,JC("WebWrite.hlp",162)} Links From Netscape, Internet Explorer and Other Web Documents
{button ,JC("WebWrite.hlp",163)} Target
{button ,JC("WebWrite.hlp",164)} Name
{button ,JC("WebWrite.hlp",165)} Description



Links From Netscape, InternetExplorer and other web documents (Link dialog box)
From the Links dialog box you can choose a link among your "Netscape Bookmarks", "Internet Explorer Favorites" or
among links in another HTML-document.

Netscape and Explorer
Click the "Netscape" button and get a survey of Netscape's Bookmarks. Click the "Explorer" button to get a dialog 
box with Explorers Favorites.
Check one or more and choose OK. 

Only the first of the checked links are shown in the dialog box "Links", but all are inserted into the document, when 
you choose OK. 

Have you filed in the Target parameter, all the links will get the specified value.
The Name parameter value is only provided to the first link.

Web docs
Click the "Web pages" button and find an HTML document, in which you want to find some links. When you have 
chosen a document a list of all links in the document is shown. Check one or more and choose "OK".

Related topics:
{button ,JC("WebWrite.hlp",161)} Address
{button ,JC("WebWrite.hlp",163)} Target
{button ,JC("WebWrite.hlp",164)} Name
{button ,JC("WebWrite.hlp",165)} Description



Target (Link dialog box)
"Target" is the name of the window or the frame in which the document in question is to be opened.

Maybe you'll insert a link in the frame "Index". When the link is clicked the document should for example be opened
in the frame called "Documents". 
Specify "Documents" in the "Target" field.

Frames are named when they are made ("Structure, Frames"), or by right clicking in the tag "<FRAME ...>".

Furthermore you can choose between these predefined names in the combo box:

_blank the document is opened in a new unnamed window
_self the document is opened in the actual frame
_parent the document is opened over the "initial" document
_top the document is opened on top level.

Furthermore frame names of all open documents are shown in the combo box.

Related topics:
{button ,JC("WebWrite.hlp",161)} Address
{button ,JC("WebWrite.hlp",162)} Links From Netscape, Internet Explorer and Other Web Documents
{button ,JC("WebWrite.hlp",164)} Name
{button ,JC("WebWrite.hlp",165)} Description



Name (Link dialog box)
Specify a name, if the link should be able to be target to another link. Is used to specify target internally in a 
document. 

Target can be a link itself 
<A HREF="onward.htm" NAME="myname">Click here to go onward from my name</A>

Target can also be an (invisible) target 
<A NAME="myname"></A>

If you want to make an invisible target, you should only fill in th "Name" field.

To For at refer to a target you just put a # in front of the name 

<A HREF="#myname">Go to my name on this page</A>
if the target is in the same document and
<A HREF="anotherdocument.htm#myname">Go to myname in another document</A>
if the target is in another document.

Related topics:
{button ,JC("WebWrite.hlp",161)} Address
{button ,JC("WebWrite.hlp",162)} Links From Netscape, Internet Explorer and Other Web Documents
{button ,JC("WebWrite.hlp",163)} Target
{button ,JC("WebWrite.hlp",165)} Description



Description (Link dialog box)
"Description" is the description the reader sees and can click upon. By default WebWriter inserts the file name. If 
you forget to fill in the "Description" field, the link cannot be seen on the web page. 

Related topics:
{button ,JC("WebWrite.hlp",161)} Address
{button ,JC("WebWrite.hlp",162)} Links From Netscape, Internet Explorer and Other Web Documents
{button ,JC("WebWrite.hlp",163)} Target
{button ,JC("WebWrite.hlp",164)} Name



Templates, Survey
On starting a new web page, you can base it on a template. You can use one of WebWriters standard templates, or 
you can create your own templates. 
The template can contain text, images, links, tables, frames etc.., that is to be reused on more pages. 

See:
{button ,JC("WebWrite.hlp",171)} Create web page based on a template
{button ,JC("WebWrite.hlp",172)} Create new template
{button ,JC("WebWrite.hlp",173)} Create template based on existing document
{button ,JC("WebWrite.hlp",174)} Edit template
{button ,JC("WebWrite.hlp",175)} Delete template



Create Web Page Based on a Template 
Click New in the File menu. 
In the Template-dialog box you can choose, what template your document is to be based upon. Choose "Empty 
document", if you want to start with a blank document.

Related topics:
{button ,JC("WebWrite.hlp",172)} Create new template
{button ,JC("WebWrite.hlp",173)} Create template based on existing document
{button ,JC("WebWrite.hlp",174)} Edit template
{button ,JC("WebWrite.hlp",175)} Delete template



Create New Template
Create a page just as you would have anew other web page. When you save the template, you choose Save as... 
in the File menu. In the "Save as"-dialog box you change the file type to "Template". 

Save the template in the "Template" folder in the WebWriter folder.

Related topics:
{button ,JC("WebWrite.hlp",171)} Create web page based on a template
{button ,JC("WebWrite.hlp",173)} Create template based on existing document
{button ,JC("WebWrite.hlp",174)} Edit template
{button ,JC("WebWrite.hlp",175)} Delete template



Create Template Based on Existing Document 
Click New in the File menu. 

Click "New template...". Choose the document, you want to base the template upon.

Specify the template's name and press OK.

Check the template and press OK to start a new web page based on the new template. Press Close, if you want to 
start a new one.

Related topics:
{button ,JC("WebWrite.hlp",171)} Create web page based on a template
{button ,JC("WebWrite.hlp",172)} Create new template
{button ,JC("WebWrite.hlp",174)} Edit template
{button ,JC("WebWrite.hlp",175)} Delete template



Edit Template 
Click New in the File menu. 

Check the template, you want to edit and click "Edit template...". The template is opened in WebWriters text editor 
to be edited.

Related topics:
{button ,JC("WebWrite.hlp",171)} Create web page based on a template
{button ,JC("WebWrite.hlp",172)} Create new template
{button ,JC("WebWrite.hlp",173)} Create template based on existing document
{button ,JC("WebWrite.hlp",175)} Delete template



Delete Template 
Click New in the File menu. 

Check the template, you want to delete and click "Delete template...". 

Related topics:
{button ,JC("WebWrite.hlp",171)} Create web page based on a template
{button ,JC("WebWrite.hlp",172)} Create new template
{button ,JC("WebWrite.hlp",173)} Create template based on existing document
{button ,JC("WebWrite.hlp",174)} Edit template



Scripts, Survey
Scripts can add new functionality to a website. Scripts are based on real programming languages, such as Java and 
Visual Basic. Scripts are embedded in the HTML document with the <SCRIPT> element and are interpreted by 
Internet browser. Read more: Further information on HTML, Java etc.Scribble14.

Note! This requires that the user's browser can read the script language in question and that the user has enabled 
scripting.

In WebWriters Script editor you can create and edit scripts for insertion into your HTML-manuscript. The Script 
editor has a series of help functions for the preparation of Java scripts and it color tags the Java tag.

See:
{button ,JC("WebWrite.hlp",181)} Create new script
{button ,JC("WebWrite.hlp",182)} Open a script
{button ,JC("WebWrite.hlp",183)} Edit a script
{button ,JC("WebWrite.hlp",184)} Save a script
{button ,JC("WebWrite.hlp",185)} Java object tree



Create New Script
Choose Script editor in the functions menu to open the Script editor.

Choose new in the files menu or click .

Insert the script in your HTML document by choosing Update and close in the Files menu or click .

Related topics:
{button ,JC("WebWrite.hlp",182)} Open a script
{button ,JC("WebWrite.hlp",183)} Edit a script
{button ,JC("WebWrite.hlp",184)} Save a script
{button ,JC("WebWrite.hlp",185)} Java object tree



Open a Script
Choose Script editor in the Functions menu to open the Script editor.

Choose Open in the File menu or click .

Insert the script into your HTML-document by choosing Update and close in the File menu or click    .

Related topics:
{button ,JC("WebWrite.hlp",181)} Create new script
{button ,JC("WebWrite.hlp",183)} Edit a script
{button ,JC("WebWrite.hlp",184)} Save a script
{button ,JC("WebWrite.hlp",185)} Java object tree



Edit a Script
Right click in the <Script>-element in the HTML-manuscript. WebWriter opens the Script editor with the script ready
for editing.

Update the script in your HTML-document by choosing Update and close in the File menu or click .

Related topics:
{button ,JC("WebWrite.hlp",181)} Create new script
{button ,JC("WebWrite.hlp",182)} Open a script
{button ,JC("WebWrite.hlp",184)} Save a script
{button ,JC("WebWrite.hlp",185)} Java object tree



Save a Script
Right click in the <Script>-element in the HTML-manuscript. WebWriter opens the Script editor with the script 
inserted.

Choose Save as... in the File menu or click . Give the script file a name and choose OK. 
The script file has been saved and can be inserted in another HTML-document.

Related topics:
{button ,JC("WebWrite.hlp",181)} Create new script
{button ,JC("WebWrite.hlp",182)} Open a script
{button ,JC("WebWrite.hlp",183)} Edit a script
{button ,JC("WebWrite.hlp",185)} Java object tree



Java Object Tree (Skript Editor)
Choose JavaScript in the Script-combo box in the toolbar.

Click the Java object tree in the View menu or press the  button to show Java object treeet.

The Java object tree shows a survey of the object hierarchy of the Java Script language with associated properties
 and methods 

. 

And furthermore a list of reserved words  - that is words that are used by the Java language and for that reason 
they are not allowed as names for variables etc.

Double click an object property or method or a reserved word to insert it in the Java script.

Related topics:
{button ,JC("WebWrite.hlp",181)} Create new script
{button ,JC("WebWrite.hlp",182)} Open a script
{button ,JC("WebWrite.hlp",183)} Edit a script
{button ,JC("WebWrite.hlp",184)} Save a script



Tables
Choose Table in the Structure menu to design a table in the Table dialog box.

Caption
You may specify a caption to be placed over the table.

Width
You can specify the table width- in pixels or in % of the browser width.

Border
Specifies the width of the border of the table. If you do not want any frame just make it 0. 

Distance between cells
Specify the distance between the cells of the table. 

Distance from text to cell wall
Specifies the distance between the cell text and the cell wall.

Color
Specify the background color of the table.

Word Wrap
You can choose if the text should be allowed to wrap either right or left round the table, or if    word wrap isn't 
allowed. 

Text alignment 
Determines how the text is justified horizontally (right/left) and vertically (top/bottom) inside the cells of the table.

Text
The text for the checked cell is inserted in the "Text:" field. Every time you hit the Enter key you go to the next cell, 
until you have reach the last one, by the you return to the top cell.

Reset
With this button you can delete all your setting and all text in the dialog box and start all over with a new table.

Adjustment of cells in the dialog box
You can change the size of the rows and the columns by grabbing the borderline and dragging it to the desired size. 

Note! The size of the cells in the dialog box has no influence on the actual size in the HTML document.

Related topics:
{button ,JC("WebWrite.hlp",191)} Editing cells individually



Editing Cells Individually
You can edit the attributes for a single cell by right clicking in the cell element <TD>, after inserting the table tag.

You can edit text justification, number of rows and columns you want the cell to expand and the width and height of 
the cell.

Note!    If you choose, that a cell should span over more rows or columns you must delete a similar amount of 
neighboring cells, if you want all cells to remain inside the frames of for the table.

Related topics:
{button ,JC("WebWrite.hlp",190)} Tables



HTML Tag Box 
Insert tag in the document
Check the desired tag and click    "Insert" to insert the tag in the document. You can work on in the document 
without closing the HTML tag box, if you want to insert a new tag somewhere in your document. 

Choose Close when you have finished or click the HTML tag box button in the toolbar.

Quick Insertion.
Double click the desired tag to insert it in the document and simultaneously close the HTML tag box.

Note! 
If you want a tag with both start end ending and you want them both inserted in your document all you have to do 
is to click /double click the leftmost column. If you have selected some text in the document the tags will encircle it.
If you only insert a start or ending tag any selected text will be replaced.

Special characters
You can jump to the Special Character Tag Box by clicking this button.

Related topics:
{button ,JC("WebWrite.hlp",100)} Adding your own HTML tags



Images, Survey 
You can insert .gif and .jpg, images plus GIF-animations in your HTML documents.

WebWriter contains a series of help functions, that give a fast survey of your image files and make it easy to insert 
images in your HTML-documents.

Related topics:
{button ,JC("WebWrite.hlp",211)} See Available Images 
{button ,JC("WebWrite.hlp",212)} Insert Image From Dialog Box
{button ,JC("WebWrite.hlp",213)} Insert Image From WebWriter Explorer
{button ,JC("WebWrite.hlp",214)} Insert Image From Image viewer



See Available Images 
See a single image
You can see an image by right clicking the image file in The WebWriter Explorer and choose Properties.

Quick View 
Click the  radio button in Explorer to get a survey of all image files in the active folder. Click an image file. The 
image is shown in WebWriter Explorer.

In the Status line you can see the image files size and the dimensions of the image.

See all images in the folder
Choose Image viewer in the File menu. All images in the active folder are shown in a miniature format in the 
Image viewer.

Related topics:
{button ,JC("WebWrite.hlp",212)} Insert Image From Dialog Box
{button ,JC("WebWrite.hlp",213)} Insert Image From WebWriter Explorer
{button ,JC("WebWrite.hlp",214)} Insert Image From Image viewer



Insert Image From Dialog Box 

Choose Graphics... in the Insert menu.

By clicking  you can search for useful images on your computer.

Path
If you choose a file from another folder than that of your document, the relative path is inserted. That means that 
your website can find images, even if they are not in the same folder, as is the page itself. 
But remember that to make it work when the page is on the web server, you have to have exactly the same 
(relative) folder structure and location of image files.

If the document is in the same folder or on another drive, only the file name is inserted and the file is then to be 
placed in the same folder as the document containing the link. 

Alternative text
Id text that shown in stead of the image, if the reader has turned off graphics in his/her browser.

Frame
Specify width and height of the frame around the image. The value "0" means that the image is shown without 
frame. 

Alignment
Decides how text is justified related to the image. Choose "Right" or "Left", if you want text wrapping.

Height and width
The images dimensions are auto detected by WebWriter, when you find the image with file dialog box. 

The dimensions are stated in pixels, and it is a good idea to have them specified because that makes it possible for 
the browser to read the text before reading the images. 

If you haven't inserted the image as described above, you can check the image file in The WebWriter Explorer and 
read width and height on the Status line. If you want the image to be shown in another size than the original format,
you can specify the desired measurements in the    fields.

You can also specify a width in % of the browser window's width and height. This opportunity should only be used in 
special cases because you never know which size the recipient's browser is, and your images may look strange!

Related topics:
{button ,JC("WebWrite.hlp",211)} See Available Images 
{button ,JC("WebWrite.hlp",213)} Insert Image From WebWriter Explorer
{button ,JC("WebWrite.hlp",214)} Insert Image From Image viewer



Insert Image From WebWriter Explorer 

You can insert an image by dragging it from The WebWriter Explorer with the mouse and dropping it in the 
document where you want it to be. WebWriter inserts the necessary HTML-tags including the images height and 
width.

Related topics:
{button ,JC("WebWrite.hlp",211)} See Available Images 
{button ,JC("WebWrite.hlp",212)} Insert Image From Dialog Box
{button ,JC("WebWrite.hlp",214)} Insert Image From Image viewer



Insert Image From Image Viewer 

Place the cursor in the HTML document where you want the image inserted.

Choose Image viewer in the File menu. All images in the active folder are shown in miniature format in the Image 
viewer.

Right click on the desired image and choose Insert in document.

Related topics:
{button ,JC("WebWrite.hlp",211)} See Available Images 
{button ,JC("WebWrite.hlp",212)} Insert Image From Dialog Box
{button ,JC("WebWrite.hlp",213)} Insert Image From StonesExplorer



Sound

Choose Sound in the Insert menu.

By clicking  you can search for sound files on your computer. 

Path
If you choose a file from a sub folder to the folder where your document is then the relative path is inserted; 
otherwise only the filename will be inserted, and then the file must be in the same folder as the document 
containing the link. 

Two different elements
The sound is inserted with both Netscape's <EMBED> element and Explorers <BGSOUND> element, to make sound
work in both browsers.



Line

Choose Horizontal line... in the Insert menu.

Height
The height of the line in pixels.

Length
Length can be specified relatively in % (percent of the width of the actual browser window) or as a value in pixels. If 
you want the relative value just select the % check box.

Shadow
If you check "No shadow" the line will be massive without 3D effect.

Alignment 
Choose between Left aligning, Right aligning and centering the line



Meta information

Choose Meta information... in the Insert menu

In the Meta dialog box you have the possibility too insert a series of information about your website, that can be 
read by different search engines on Internet. Some search engines do only search for Meta information. If the site 
has no Meta information it will not be recorded. The website is labeled according to the Meta information.

On the Name list you can choose the most ordinary types of Meta information. Choose "More..." to add your own 
type. Choose a type and fill in the "Content" field. Check the types you want in the document. The Meta information
is inserted in the <HEAD> section of the document.



List
Choose List... in the Structure menu.

Type
The items can be ordered or unordered with bullets. You can the ordered type (numbers or characters) or the 
bullets in the combo box: "Type".

Items
Items are added or removed with the buttons. Enter the text for each item in the field: "Text:" and press "Enter".

On Enter you go to the next item until you reach the end, by then you start over again. You can also click on an 
item with the mouse to fill in the "Text:" field.

Auto generating list
WebWriter can create a list automatically if you select some text and choose "List..." (in the Structure menu, in 
the right click menu or on the toolbar). For each line break ("Enter") WebWriter encounters an item is created. 

The items are read into the List dialog box where you can finish the text.



Extended Find
Extended search provides you with the opportunity to search for a text string in all open documents, all documents 
in a project or all documents in a folder on the hard drive.

Choose Extended Find... in the Edit menu.
Specify search string, criteria and search area.
By checking the "Distinguish between upper and lower case" the search will only find exact match of letters. 
By checking the "Find only entire word" only whole words will be searched for. 

Choose "Find all".

The result and the search are shown as a list in the bottom of WebWriters main window. In the list you'll find 
information about the document's name and path, in which line the text has been found and a bit of the subsequent
text. Double click on a search result to open the document with the cursor right on the searched text. 

{button ,JC("WebWrite.hlp",251)}    Extended Replace



Extended Replace 
Extended replace

Extended replace provides you with the opportunity to replace a text string in all open documents, all documents in 
a project or all documents in a folder on the hard drive.

Choose Extended replace in the Edit menu.
Specify search string, criteria and search area.
By checking the "Distinguish between upper and lower case" the search will only find exact match of letters. 
By checking the "Find only entire word" only whole words will be searched for. 

Choose "Find all".

{button ,JC("WebWrite.hlp",250)}    Extended Find



File (main menu)
Contains commands for handling files.

New...
Opens the template dialog box, for opening an empty document, et document based on the default template or a 
document based on a user defined template. 
Furthermore you can create new and edit existing templates from the template dialog. Read more under Templates.

Open...
open HTML-documents, WebWriter-templates and ordinary text files from this menu item.

Close file
Closes the active document.

Close all
Closes all documents.

Save
Saves the active document.

Save as...
Saves the active document with a new name.

Save with Extended Characters
Saves the active document and converts the danish characters æ, ø and å to international tags in the .htm-file. 

Under "Functions, Options, Diverse" you can set WebWriter on automatic conversion, every time you save.

Please not that it might take more seconds to save long documents. 
If you want to avoid waiting time, while working on a document, use the "Save with Extended Characters" is stead, 
when you have finished editing and is ready to transfer the document to the web server.

Save all
Saves all open documents.

Image viewer
Shows a miniature of all images in the active folder.

Properties
Show properties for the active document. Among other things links in the document, transfer time, size etc.

Print
Prints the active document.

Printer Setup...
Choose printer, paper format, paper orientation etc.

Exit
Exits WebWriter.



Edit (main menu)
Contains commands for editing in the active document.

Undo
Reverses the latest action. You can undo up to 100 actions.
If you have inserted tag from a dialog box or made other major operations, you some times have to choose "Undo" 
twice: first the new text is deleted then the old text is inserted. 

Redo
Redo the latest undo. You can redo up to 100 actions.

Cut
Cuts the selected text to Windows clipboard.

Copy
Copies the selected text to Windows clipboard.

Paste
pastes the text from the clipboard at the cursor in the active document.

Select all
Selects all text in the active document.

Find...
Finds text in the document.
Choose between searching in the area from the documents start and to cursor (Direction:: Backward) or in the rest 
of the document (Direction: Forward) 

By checking "Difference between upper and lower case" WebWriter distinguishes between upper and lower case in 
the search process. By checking "Find only entire words" only whole words are found.

Find next
Finds the next occurrence of the search string from the Find dialog box.

Replace...
Finds and replaces text in the document.

Extended find...
Extended FindScribble250 gives you the opportunity to search for a text string in all open documents, all 
documents in a project or all documents in a folder on the hard drive. 

Extended replace...
Extended ReplaceScribble251 gives you the opportunity to replace a text string with another in all open documents,
all documents in a project or all documents in a folder on the hard drive.

Go to line...
Goes to the chosen line. Can be helpful in big documents, or if you, after having run "Functions, Check tags" have 
got a report on an error in certain line. 

Tip! You can see in which line the cursor is situated in the second field in the Status line under the document 
window.

Extended characters
"Replace extended characters with tags" inserts international HTML tags for the danish letters.
"Replace tags with extended characters" finds the international HTML tags for extended characters and inserts the 
danish letters in stead.

Convert tags to UPPER CASE
Finds all HTML-elements and -parameters in the document and change them to upper case.

Delete HTML tags
Deletes all HTML tags in the document.



View (main menu)
View
In the "View"-sub menu you can choose between big icons, small icons, survey or details in WebWriter Explorer.

File types
I the "File types"-sub menu you can choose between seeing HTML-documents, image files, graphics files, sound files
or all files in WebWriter Explorer.

WebWriter Explorer
Specifies if WebWriter Explorer is shown or not.

HTML tag box
Toolbox with a list of many often used HTML tags, and the possibility to add your own tags.

Search results
Specifies if the list of search results found with "Extended search... A is shown or not.

Update
With this command (or by hitting F5) you can update WebWriter Explorer, the project survey and the document title 
on the tab, if you have changed it after opening the document.

Show page in external browser
Opens the active document in your WWW-browser. See: WebbrowserScribble82.

If you have installed more browsers, a menu is shown, from which you can choose.

Internal browser
Shows the actual document in the internal browser. The function demands that you have MS Internet Explorer 3 or 
newer situated on your computer.



Format (main menu)
Contains commands, that inserts HTML tags for formatting the selected text. Selected text is not deleted, but will be
surrounded by the formatting tags. 

Bold
Inserts the tag <B></B> around the selected text.

Italic
Inserts the tag <I></I> around the selected text.

Underlined
Inserts the tag <U></U> around the selected text.

Font size +1
Inserts tag that increases the font size by 1 related to the rest of the text.

If you want further enlargement you can exchange +1 with +2 etc. after the tag has been inserted or you could use
the headline formats.

Font size -1
Inserts tag that decreases the font size by 1 related to the rest of the text. Do you want further decrease you can 
exchange -1 with -2 etc. after the tag has been inserted.

Heading
The sub menu items "Heading 1-6" inserts the tag for the 6 HTML default headings,    <H1></H1>    - <H6></H6>, 
around the selected text. In addition to the text formatting, the tag also gives a line break. Some Search machines 
on Internet search for the HTML-headline tags.

Typewriter      
Inserts the tag <TT></TT> around the selected text, so that the text is formatted as classic typewriter font. 

Preformatted text
Inserts the tag <PRE></PRE> around the selected text, so that the text preserves its original formatting concerning
line break and layout.

Center
Inserts the tag <CENTER></CENTER>, to center the selected text.

Right align
Inserts tag that right aligns the selected text.

Full justification
Inserts the JUSTIFY parameter to the selected text

Font...
Dialog box for formatting selected text concerning font, color, size and typography



Insert (main menu)
This menu contains commands for inserting elements like line break, lines, links, images etc. Common to these 
commands is furthermore that they delete and replace any selected text.

User tags
Inserts your own tags. See: adding user tagsScribble100.

Line break
Inserts a line break at the cursor 

Paragraph
Starts a new paragraph at the cursor

Horizontal line
Inserts a standard line (horizontal) at the cursor.
The line automatically fills out the window in the browser. 

Basic tags, new page...
Shows a dialog box for inserting the basic HTML tags. See Basic tagsScribble55.

Link...
Shows a dialog box for inserting a link to another HTML-page locally or in the world somewhere.
See LinksScribble160.

Image...
Shows a dialog box for inserting graphics in the document. See ImagesScribble210.

Horizontal line
Shows en dialog box to insertion of a horizontal line. See LineScribble225.

Sound...
Shows a dialog box    for inserting sound in the document. See SoundScribble220.

E-mail address...
Produces is a dialog box    for inserting a E-mail address on the HTML-page, that the reader can be clicking on to 
send a e-mail to the    address in question. Description is the visible description that the link gets in the document 

You can specify a default E-mail address and a default-description in "Functions, Options, E-mail.

Color...
Shows a dialog box, where you can choose a color. A tag is then inserted, that match the chosen color. 

If you want to replace an existing color tag, then select it and choose "Color".
Meta-information
Shows a dialog box for inserting meta-information. See Meta-information.

Date of Updating
Inserts the actual date. See Date of UpdatingScribble89.

Comment
Inserts a comment in the HTML document, not visible in the browser. Comments can make it easier to navigate in 
and maintain HTML-documents.

You can comment text and HTML tag in your document by selecting the desired and press the "Comment" button.



Structure (main menu)
Contains commands to construct frames, tables and lists.

Table...
Shows a dialog box for compilation of tables. See TabellerScribble190.

Row
Inserts the tag <TR></TR>, that defines the selected as a row, (which can contain a number of data fields/cells). 

Table cell
Inserts the tag <TD></TD>, that defines the selected as a table cell.

List...

Shows en dialog box for preparation of a list. See List.

Item
Inserts the tag <LI> that gives a new item in an existing list. If you select some text, before choosing the command,
the selected word will be surrounded by the tags <LI></LI>.

Frames...
Shows en dialog box for dividing the browser window into frames. See FramesScribble150.

Form
The dialog box is used to build a form that the user can fill in and send to you. See FormScribble115.



Functions (Main menu)
Contains different program functions.

Text wrap
Turns text wrap on/off in the active document.

Parent Page 
Defines the active document as the parent page. This means that this document is opened into the browser, even if
another document is active when you choose "open page in external browser". This is for instance useful, if you 
work with a document that is to be viewed on a page with frames. To return to the normal setting, just activate the 
initial page and click on the menu item to remove the check. 
 

You just have to define the page with the frames as the parent page.

To return to the default setting, you must activate the parent page and click on the menu item to remove the 
checkmark.

See Parent PageScribble64.

Edit title
Changes the title of the HTML-page (the title, that appears on the browsers and WebWriters Title line).

Check HTML tags
Checks the HTML tag in your document for errors. See Check HTML tagsScribble61.

Script editor...
Opens the script editor, for composing Java scripts etc. See ScriptsScribble180.

Transfer to Internet...
Transfers your web pages, images etc. to Internet. See Transfer to Internet, Survey.

Settings...
Here you can specify options for WebWriter.
When you have finished your choices, you must choose Save, to save the settings in Windows 95 Registry so that 
they will take effect the next time you open the program.
See {button ,JC("WebWrite.hlp",430)} Settings



Help (main menu)
Help
This help file, which opens when you hit F1.

Search for help on...
Shows the search function to search for a specific word in the help file.

Keyboard shortcuts
Shows a survey of keyboard shortcuts in WebWriter.

About...
Information on WebWriter and on where and how to contact the programmer and get updates of WebWriter. 
Double click the web address in the "About" box to open your web browser with WebWriters homepage on the net.

And you can also just select the address and copy it via Windows clipboard.



Shortcuts - sorted by function
Shortcut Action 

Help
F1 Help
SHIFT+F1 HTML-help

General functions
CTRL+N New empty document
CTRL+O Open document...
CTRL+P Print document
CTRL+S Save the active document

Navigate in the program
CTRL+TAB Toggles between the documents
CTRL+ALT+TAB Toggles between document and other controls
TAB Toggles between controls e.g. Drive box > Folder box > File box > File filter
SHIFT+TAB Toggles between controls e.g. File filter > File box > Folder box > Drive box

Arrow keys Moves around in a control e.g. between files in File box
ESC Closes a dialog box or breaks off tag formatting (same as "Cancel")
F10 Access to menu
Shift+F10 Access to right click menus
CTRL+F4 Close the active document
ALT+F4 Close WebWriter

WebWriter Explorer
Enter Open file
F2 Rename file
DEL Delete file
CTRL+C Copy file
CTRL+X Cut file
CTRL+V Insert file

Document editing
CTRL+F Find
F3 Find next
CTRL+H Replace...
CTRL+G Go to line...

CTRL+A Select all
CTRL+C Copy text
CTRL+V Insert text
CTRL+X Cut text
CTRL+Z Cancel last action
DEL Delete (checked text)

Text formatting
CTRL+B Bold
CTRL+I Italic
CTRL+U Underline
CTRL+SHIFT+C Center the checked
CTRL+SHIFT+1 Heading H1
CTRL+SHIFT+2 Heading H2
CTRL+SHIFT+3 Heading H3
CTRL+SHIFT++ Increase font with 1
CTRL+SHIFT+- Decrease font with 1

Layout/structure-tags
SHIFT+ENTER New paragraph
CTRL+ENTER Line break

CTRL+SPACE Hard space (&nbsp;)
CTRL+SHIFT+D Data field (cell) in table
CTRL+SHIFT+L Line
CTRL+SHIFT+R Row in table
CTRL+SHIFT+U Item for list
CTRL+SHIFT+F color tag...



HTML-dialog boxes
CTRL+SHIFT+E E-mail 
CTRL+SHIFT+G Graphics
CTRL+SHIFT+H Link
CTRL+SHIFT+I Options
CTRL+SHIFT+K Comment 
CTRL+SHIFT+O List
CTRL+SHIFT+Q Basic tags
CTRL+SHIFT+S Font 
CTRL+SHIFT+T Table
CTRL+SHIFT+V Horizontal line

F8 Open WebWriters HTML-tag box

Functions
F5 Update document title on tab
F6 Insert AutoDate
F7 Show/hide WebWriter Explorer
F9 Checks HTML-tag for errors
F11 Open document in external browser
F12 Open document in internal browser
SHIFT+F11 Open document in external default browser
CTRL+SHIFT+I Script editor
CTRL+SHIFT+W Transfer to Internet-dialog box

User tags 
CTRL+1 til CTRL+ 9

{button ,JC("WebWrite.hlp",341)} Keyboard shortcuts - sorted by key



Shortcuts - Sorted by key
{button ,JC("WebWrite.hlp",340)} Keyboard shortcuts - sorted by function

Shortcut Action

F1 Help
F2 Rename file in explorer
F3 Find next
F5 Update document title on tab
F6 Insert AutoDate
F7 Show/hide WebWriter Explorer
F8 Open WebWriters HTML-tag list
F9 Check HTML-tag for errors
F10 Access to menu
F11 Open document in external browser
F12 Open document in internal browser

SHIFT+F1 HTML-help
SHIFT+F10 Access to the right click menus
SHIFT+F11 Open document in external default browser
SHIFT+ENTER New paragraph

DEL Delete (checked text in document or file in Explorer)
ESC Closes dialog boxes, breaks off tag formatting (same as "Cancel")

CTRL+TAB Toggles between the documents
CTRL+ALT+TAB Toggles between document and controls
TAB Toggles between controls e.g.. Drive > Folder > File > File filter box
SHIFT+TAB Toggles between controls e.g.    File filter > File > folder > Drive box

Arrow key Moves around in a control e.g. between files in the File box

CTRL+A Select all
CTRL+B Bold
CTRL+C Copy (text in document or file in Explorer)
CTRL+F Find
CTRL+G Go to line...
CTRL+H Replace...
CTRL+I Italic
CTRL+N New empty document
CTRL+O Open document...
CTRL+P Print document
CTRL+S Saves the active document
CTRL+U Underline
CTRL+V Insert (text in document or file in Explorer)
CTRL+X Cut (text in document or file in Explorer)

CTRL+Z Cancel last action
CTRL+1 till CTRL+ 9 User tags 
CTRL+F4 Close the active document
CTRL+ENTER Line break
CTRL+SPACE Hard space (&nbsp;)

CTRL+SHIFT+1 Heading H1
CTRL+SHIFT+2 Heading H2
CTRL+SHIFT+3 Heading H3

CTRL+SHIFT+B Line break
CTRL+SHIFT+C Center the checked
CTRL+SHIFT+D Data field (cell) in table
CTRL+SHIFT+E E-mail (dialog box)...
CTRL+SHIFT+F Color tag...
CTRL+SHIFT+G Graphics (dialog box)...
CTRL+SHIFT+H Link (dialog box)...

CTRL+SHIFT+I Options (dialog box)...
CTRL+SHIFT+I Script editor



CTRL+SHIFT+K Comment (dialog box)...
CTRL+SHIFT+L Horizontal line
CTRL+SHIFT+O List (dialog box)...
CTRL+SHIFT+P New paragraph
CTRL+SHIFT+Q Basic tags (dialog box)...

CTRL+SHIFT+R Row in table
CTRL+SHIFT+S Font (dialog box)...
CTRL+SHIFT+T Table (dialog box)...
CTRL+SHIFT+U Item for list
CTRL+SHIFT+V Horizontal line (dialog box)...
CTRL+SHIFT+Z Cancel dialog box-handling

CTRL+SHIFT+W Transfer to Internet-dialog
CTRL+SHIFT++ Increase font by 1
CTRL+SHIFT+- Decrease font by 1
ALT+down arrow Color formats the HTML-tag in the line (like F8)
ALT+F4 Close WebWriter



HTML Tag Does Not Work in the Browser 
There may be one or more reasons that a tag apparently has no effect in the browser.

1 The changes, you have made, have not been saved in the .htm-file, that the browser reads. If you use 
WebWriters "open page in browser"-function, it happens automatically, but if you e.g. change to the browser 
with Alt+Tab or via Windows 95" process line, you have to ensure that the file is saved.

2      The browser hasn't updated the page. This is done by choosing "Update"/"Reload" in the browser. In 
Netscape you can hold down Shift while clicking on the "Reload"-button to make sure that all is updated from the
file. You have to do this if you edit frames in a document. 

3      There are errors in the tag. Check the attribute names, value specifications that all parts of the tag is 
present, that there are start- "<" and end-characters ">" around all tags, and that different tags are not 
"entangled into each other". The tags have to be symmetrically, e.g.: Right: <B><I>Text</I></B>. Wrong: 
<B><I>Text</B></I>.

4      The browser does not know the tag. It may be because the browser is older, or the tag is browser specific. 
Some tag does only work in Netscape, some only in Internet Explorer. 

And it changes all the time, therefore no attempt has been made to give an account of this in WebWriter, as you 
could easily end up with some wrong information. 

Anyway you should check your documents in more browsers - older versions too, you cannot expect all of your 
viewers to have the newest version of their browser.



Read the Readme File

Read the readme.txt-file in the WebWriter folder. It contains the latest information about bugs etc.



Check Out "Tips & FAQ" on WebWriters Homepage

You can find tips and answers to frequently asked questions on WebWriters homepage: 
http://www.image.dk/~stone/



Updates

You can find the newest version of Stone's WebWriter on the World Wide Web on this address
http://www.image.dk/~stone/



Contact to the Programmer

If you find any bugs or have comments to the program please send me an email at
stone@image.dk.



Rights

Stone's WebWriter must be registered. 
You can register WebWriter free for private use (i.e. for use at home to make your own personal, non-commercial 
homepage). See more on WebWriters homepage http://www.image.dk/~stone/.

Do not pass on WebWriter on diskette or CD-rom or place it for download on Internet, BBS or elsewhere without 
my written permission..

Related topics:
{button ,JC("WebWrite.hlp",400)} Updates
{button ,JC("WebWrite.hlp",401)} Contact to the Programmer



Interface, Settings
Click Settings in the Functions menu. These settings are on the Interface tab.:

{button ,JC("WebWrite.hlp",95)} Use Old Style button on the toolbar
{button ,JC("WebWrite.hlp",88)} Show template dialog box on clicking the    "New document"-button
{button ,JC("WebWrite.hlp",92)} Show images in Stones Explorer.
{button ,JC("WebWrite.hlp",96)} Use archive flag on updating project to the Internet
{button ,JC("WebWrite.hlp",112)} Put shortcut on Desktop
{button ,JC("WebWrite.hlp",113)} Put in Explorers "Send to"-menu
{button ,JC("WebWrite.hlp",114)} Show file name in stead of title on tabs




