
NetShow Player
Use NetShow Player to request .asf files and live ASF streams. .Asf files refer to stored ActiveX 
streaming format files. These files can be played locally, from NetShow Server, or from an HTTP 
server. Live ASF streams refer to ASF information streamed from a Net Show Channel Manager. 
Similar to your television set or to a radio, NetShow Player can “grabs” the live ASF stream as the 
information moves across the network and renders the audio and/or video.

Click part of the NetShow Player diagram below to learn the name and other information about that 
part. 



File Menu
The File menu provides controls to:

· Open an .asf or .asx file.
· Type the path to an .asf file or a live ASF stream
· Open the Properties dialog box which contains many of the player’s settings including how many 

times to play an .asf file, what UDP port to use, and whether to receive multicasting.
· Exit the application.



Go Menu
Use the Go menu to open your browser and access the newest information on the NetShow Web 
page. The Go menu also has a NetShow Software Updates option that takes you to the NetShow 
Web page where you can download the latest version of NetShow Player.



View Menu
The View menu enables you to set NetShow Player so that it always stays on top. The View menu 
also contains options to view Statistics of the .asf file or live Asf stream, Play Settings for NetShow 
Player, and Markers if you are watching an .asf file. 



Help Menu
Use the Help menu to open the Troubleshooting Guide, the contents of this help file, or to find 
NetShow Player version information.



Title Bar
The title bar contains the title or alias of the streaming information that NetShow Player is receiving. 
Titles correspond to .asf files. A stream alias corresponds to live ASF streaming. The title bar makes it
easy to identify streaming information even if NetShow Player is paused, stopped, or at an 
unrecognizable point.



Current Time/Total Time Indicator
The Current Time/Total Time indicator displays how far along in the .asf file you are and the complete 
playing time for the .asf file. Both of these time indications are measured to the tenth of a second.



Play/Pause Button
The Play/Pause button toggles between Play and Pause. When the .asf files begins rendering, the 
Pause button is active because the .asf file is playing. If you pause or stop the .asf file, the Play 
button becomes active.



Stop Button
Click the Stop button to stop playing an .asf file. When you do, the slider returns to the beginning of 
the .asf file. Stopping the .asf file does not break communication with the server. You can click the 
NetShow Player Play button to begin playing the .asf file again.



Previous Marker Button
Markers are a feature of streaming .asf files. Click the Previous Marker button to go back to the last 
marker in the .asf file. The Previous Marker button is active only if the .asf file contains markers and 
after you have passed a marker.



Multicasting
Multicasting is how NetShow Channel Manager streams ASF information so that multiple NetShow 
players can receive the information without creating separate streams for each player. Multicasting 
always refers to a live broadcast of streaming ASF information.



Unicasting
Unicasting is the term used to describe how NetShow Server streams an .asf file to a NetShow player
because for every player that request an .asf file, a distinct connection is made between NetShow 
Server and NetShow Player. Unicasting has nothing to do with live ASF streaming and NetShow 
Channel Managers do not unicast.



Rewind Button
The rewind functionality for an .asf file is available only if you are streaming the .asf file from NetShow
Server and the .asf file was created from video using VidToAsf. If the Rewind button is not active, you
cannot rewind the .asf file.



Fast Forward Button
The fast-forward functionality is available only if you are streaming the .asf file from NetShow Server 
and the .asf file was created from video using VidToAsf. If the Fast Forward button is not active, you 
cannot fast forward through the .asf file.



Next Marker Button
Markers are a feature of .asf files that are analogous to tracks on a compact disc. Click Next Marker 
to move to the next marker in the .asf file. The Next Marker button is active only if you are streaming 
an .asf file from NetShow Server and the .asf file contains markers. Because markers must be 
created when the .asf file is being built, not every .asf file will contain markers.



Marker Indicators
The vertical lines under the slider indicate the location of markers. Markers are a feature of 
streaming .asf files from NetShow Server. If you place the mouse on an marker, the name of the 
marker and the time that it marks appears. Markers do not appear in an .asf file streamed from a 
HTTP server.



Slider
The slider indicates the current time in the .asf file. You can use the slider to move forward or 
backward in the .asf file. This is the same as using the Previous Marker and Next Marker buttons; 
that is, you must be streaming the .asf file from NetShow Server in order to move forward or 
backward in the .asf file. 

The slider does not move if you are receiving a live ASF stream.



NetShow Player Window
When playing an .asf file or receiving a live ASF stream, the images or video appear in the player 
window (provided that there are visuals in the stream). When the mouse icon is a hand, clicking in the
window has the same effect as clicking the Play/Pause button.



Opening an .asf File 
NetShow Player has two ways that you can play .asf files. Use Open File to open the .asf file or .asx 
file by browsing servers and directories, or use Open Location to type the direct path to an .asf 
or .asx file. If you open an .asf file locally, you will not be streaming the file; you will be playing the file 
from your computer’s cache. If you open an .asx file, you will be streaming the .asf file. If you enter an
.asf file’s URL, you can stream the file from NetShow Server or    HTTP Server.

See Also:

 Browsing to Open an .asf File
 Entering the Path to an .asf File
 Entering the Path to a Live ASF Stream



Browsing to Open an .asf File
Use Open File to find an .asf file when you aren’t sure of the exact path to the file, but you are sure 
that you have access to it.

1 On the File menu, click Open File.
2 In the Open dialog box, browse to the directory that contains the .asf file.
3 To begin playing the .asf file, double-click it.

NetShow Player appears, buffers some of the .asf file, and then begins playing it.
See Also:

 Opening an .asf File
 Entering the Path to an .asf File



Entering the URL for an .asf File
Use Open Location when you know the exact location of an .asf file. 

1 On the File menu, click Open Location.
2 In the Open Location dialog box, type the path to the .asf file. 

You can use either the HTTP or MMS protocol.
3 To begin playing the .asf file, click OK.

NetShow Player appears, creates a buffer for the .asf file, and then begins playing it.
See Also:

 Opening an ASF File
 Entering the Path to a Live ASF Stream
 Browsing to Open an ASF File



Entering the Path to a Live ASF Stream
Use Open Location when you know the path to a live ASF stream.

1 On the File menu, click Open Location.
2 In the Open Location dialog box, use the MSB protocol and type the path to the Channel 

Manager. 
3 To receive the live ASF stream, click OK.

NetShow Player appears, buffers a bit of ASF stream and then begins rendering it.
See Also:

 Opening an ASF File
 Entering the Path to a Live ASF Stream



Microsoft NetShow Player Properties Dialog Box
The Microsoft NetShow Properties dialog box is the main source of information within NetShow 
Player. The Properties dialog box contains six pages of information, or seven if the .asf file contains 
markers. Each property page presents specific information about NetShow Player, the .asf file, or the 
live ASF stream. Click on the page below to learn more about its properties.

See Also:

 General property page
 Details property page
 Settings property page
 Statistics property page
 Advanced property page
 Channel property page
 Codecs property page
 Markers property page



Viewing General Information
Data contained in the General property page comes from the creator of the .asf file or live ASF 
stream. This information is added during creation and can provide details about the content. Not 
all .asf files or live ASF streams contain general information.

 To view the General property page
· On the File menu, click Properties.

The General property page opens.
See Also:

 General property page



General Information Property Page
The General property page exposes any Title, Author, Copyright, Rating, and/or Description 
information that the author included with the .asf file or live ASF stream. 

See Also:

 Properties dialog box
 Viewing the General property page
 Details property page
 Statistics property page
 Advanced property page
 Codecs property page
 Channel property page
 Settings property page
 Markers property page



Channel Property Page
The Channel property page offers information about the Channel Manager that is streaming the live 
ASF stream such as the name, its location, a phone number to call, email address, and description of 
the channel. This information is contingent on the system adminstrator making it available.

See Also:

 General property page
 Details property page
 Advanced property page
 Codecs property page
 Markers property page
 Settings property page
 Statistics property page



Viewing the Codecs Used 
You can view the codecs that were used in the .asf file or live ASF stream with the Codecs property 
page. This page identifies the codecs associated with the various image, audio, and video files and 
whether or not the codec is installed on your computer. Understanding which codecs were used in 
building the .asf file and whether or not your computer has those codecs installed will help you track 
potential rendering problems.

 To view the Codecs property page
1 On the File menu, click Properties.

The General property page opens.
2 Click the Codecs property page.
See Also:

 Codecs property page



Codecs Property Page
The Codecs property page identifies the codecs used in the .asf file and whether or not those codecs
are installed on your computer. The Codecs property page also provides the URL to the NetShow 
codecs web page. Please see this URL if you want more information about the codec.

See Also:

 Viewing the Codecs Property page
 Properties dialog box
 General property page
 Settings property page
 Details Property Page
 Statistics property page
 Markers property page
 Channel property page
 Advanced property page



Viewing the Details of the .asf File
Whereas the General property page shows any additional information that may have been added to 
the .asf file or live ASF stream, the Details property page provides specific information about the .asf 
file such as length, date of creation, and so on.

 To view the Details property page
1 On the File menu, click Properties.

The General property page opens.
2 Click the Details property page.

The Details property page opens.
See Also:

 Details page



Details Property Page
The Details property page provides information (in addition to the General property page) that is 
useful for understanding how the .asf streams across the network. This information is part of the .asf 
file, but is not placed there by the author. NetShow Player picks up this information from the .asf file or
live ASF stream. The Details property page includes:

· Source Link      Path to the streaming .asf file. This will say Multicast if the source is a live ASF 
stream.

· Creation Date      Date when the .asf file or live ASF stream was created.
· Duration      Length of the .asf file. This will be blank for a live ASF stream.
· Bandwidth      Bandwidth that the .asf file or live ASF stream was designed for. The content author 

determines the bandwidth during the build process.
· Error Correction      Describes the error correction used (if any).
· Image Width      Width of the widest image in the .asf file or width of the NetShow Player screen for

a live ASF stream.
· Image Height      Height of the tallest image in the .asf file or the NetShow Player screen for a live 

ASF stream.
See Also:

 Properties dialog box
 Viewing the General property page
 General property page
 Settings property page
 Statistics property page
 Advanced property page
 Codecs property page
 Channel property page
 Markers property page



Statistics Property Page
Use the Statistics property page to monitor how well NetShow Player is receiving ASF data. This 
ASF information can be either from an .asf file or a live ASF stream. The Statistics property page 
contains a three-color pie chart that interprets the number of packets of ASF data that were received, 
recovered, and/or lost. There is also a progress bar along the bottom of the Statistics property page 
that displays the reception quality over the last 30 seconds.

See Also:

 Properties dialog box
 General property page
 Settings property page
 Details property page
 Advanced property page
 Codecs property page
 Channel property page
 Markers property page



Settings Property Page
The Settings property page enables you to choose how many times to play an .asf file. You can also 
choose the size of the NetShow Player window and the type of controls available on NetShow Player.

See Also:

 Properties dialog box
 General property page
 Details property page
 Advanced property page
 Codecs property page
 Channel property page
 Markers property page



Markers Property Page
The Markers property page displays the times and a description of all markers in the .asf file. The 
Markers property page appears only if the .asf file contains markers.

See Also:

 Using Markers
 Properties dialog box
 General property page
 Settings property page
 Details property page
 Advanced property page
 Codecs property page



Advanced Property Page
The Advanced property page enables you to:

· Adjust the .asf file’s buffering time.
· Select a UDP port 
· Name a proxy server and port for HTTP streaming
· Choose if you want to use TCP
· Turn off multicasting

See Also:

 Properties dialog box
 General property page
 Settings property page
 Details property page
 Channel property page
 Codecs property page
 Markers property page



Adjusting the Number of Times an .asf File Will Play
You can set NetShow Player to play an .asf file a fixed number of times, or continuously.

 To set the number of times an .asf file will play
1 On the View menu, click Settings.

The Settings property page opens.
2 On the Settings property page, select Play Count and then specify the number of times you want 

to play the .asf file.
—Or—

 To play the .asf file continuously
1 On the View menu, click Settings.

The Settings property page opens.
2 On the Settings property page, select Play Forever.
See Also:

 Properties dialog box
 General Information
 Details
 Using Markers
 Statistics



Viewing Statistics of the Streaming .asf File
If the .asf file you are watching seems “choppy” or the file stops playing while NetShow buffers .asf 
data, you can check how much information you are receiving. The Statistics property page displays 
several types of information. 

 To view the Statistics property page
· On the View menu, click Statistics.

The Statistics property page appears.
See Also:

 Statistics Page



Adjusting the Window Size
Unless specified otherwise, the NetShow Player window sizes to the height and width of the .asf file. 
If you want, you can resize the player window based on the original size of the .asf file.

 To resize the NetShow Player window
1 On the View menu, click Play Settings.

The Settings property page opens.
2 From the Window Size menu, select a size.

Default Size is the original .asf file size. Half Size is half of the original .asf file size. Double Size 
is two times the original .asf file size.

3 Click Apply and then click OK.



Hiding and Displaying Controls
You can set NetShow Player to three possible control views—No Controls, Simple Controls, or Full 
Controls. No Controls means that none of the player controls are visible. The Simple Controls option 
displays all controls except the Previous Marker, Next Marker, Fast Forward, and Rewind buttons. Full
Controls displays all player controls.

 To adjust NetShow Player controls
1 On the View menu, click Play Settings.

The Settings property page opens.
2 On the Controls menu, select a controls view.
3 Click Apply and then click OK.



Markers
A marker is a pointer to a specific point in an .asf file. Use markers to jump forward or backward in 
an .asf file. Markers exist in an .asf file only if the author creates them. If an .asf file contains markers,
there will be vertical dashes under the slider. Place the pointer on a dash to see the name and time of
the marker.



Using Markers
You can access markers in an .asf file either by clicking the Previous Marker or Next Marker button, 
or by choosing a marker in the Markers property page. 

 To use the Markers property page
1 On the View menu, click Markers.

The Markers property page opens.
2 In the list of markers, select the marker you want to go to and then click the Go To Marker button.

NetShow Player finds the marker, but the Microsoft NetShow Properties dialog box remains.
3 To return to NetShow Player, click OK.

NetShow Player buffers the .asf information and then plays the .asf file from that marker.
— Or —

 To use the Next Marker or Previous Marker button
· Click Next Marker or Previous Marker to move forward or backward one marker.

The slider moves one marker for each time you click Next Marker or Previous Marker. After the 
slider moves to the marker, NetShow Player buffers the .asf information and then plays the .asf file 
from that marker.

See Also:

 Properties dialog box
 Markers property page



Setting a Proxy Server for HTTP Streaming
If you want to stream .asf files from HTTP Server through a firewall, you probably will need to set a 
proxy server.

 To set a proxy server
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, select the Use proxy for HTTP streaming check box.
4 In the Server box, specify the name of an HTTP proxy server.
5 In the Port box, specify the number of the port that the server will use.

Port 80 is the usual port number to specify.



Using a UDP Port to Receive an .asf File
If you require a specific UDP port to receive streaming information through a firewall, you can set the 
port using NetShow Player. 

 To set a UDP port
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, select the Use the following UDP port check box.
4 Enter the number of the UDP port.



Adjusting an .asf File’s Buffer Time
You can adjust the amount of information that NetShow Player uses for buffering during playback. By 
minimizing the amount of information that is buffered, you will decrease the time it takes for an .asf file
to start rendering; however, you may experience interrupts or delays, especially when receiving 
streaming information over the Internet. 

By maximizing the buffer information, you will increase the time it takes for an .asf file to start 
rendering, but you will decrease the number of interrupts or delays.

Note    Any changes made in the buffering time will not take effect until the next .asf file is streamed.

 To adjust the buffering time
1 On the File menu, click Properties.

The General property page appears.
2 Click the Advanced property page.
3 On the Advanced property page, adjust the Buffering Time slider.

When you first open the Advanced property page, the slider appears in its default position.



Troubleshooting
Troubleshooting information will come in the post-Beta release.

Return to overview.



*Insert existing text here and delete this text. Do not remove the following paragraph.




