
#1    <<YourApp>> Help Index

How To ...
<<add your application-specific "how to" topics here>>

Commands
File menu
Edit menu
Record menu
View menu
Window menu
Help menu
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#2K3 $4 File menu commands

The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Send... Sends the active document through electronic mail.
Exit Exits <<YourApp>>.
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#5Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation.
Cut Deletes data from the document and moves it to the clipboard.
Copy Copies data from the document to the clipboard.
Paste Pastes data from the clipboard into the document.
Paste Link Pastes from the clipboard a link to data in another application.
Insert New 
Object  

Inserts and embeds an object, such as a chart or an equation in a document.

Links List and edit links to embedded documents.
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#6View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

#7Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Split Split the active window into panes.
Window 1, 
2, ...

Goes to specified window.
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#8Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Help 
Topics

Offers you an index to topics on which you can get help.

About Displays the version number of this application.
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#9K10 $11 New command (File menu)

Use this command to create a new document in <<YourApp>>.    Select the type of new file 
you want to create in the File New dialog box.    << Remove previous sentence if your 
application supports only one document type. >>

You can open an existing document with the Open command.

Shortcuts
Toolbar: {bmc filenew.bmp}
Keys: CTRL+N
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#12File New dialog box

<< Delete this help topic if your application supports only one document type. >>

Specify the type of document you wish to create:
<< List your application's document types here >>
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#13K14 $15 Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

You can create new documents with the New command.

Shortcuts
Toolbar: {bmc fileopen.bmp}
Keys: CTRL+O
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#16File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
<< List your application's file types here. >>

Drives
Select the drive in which <<YourApp>> stores the file that you want to open. 

Directories
Select the directory in which <<YourApp>> stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 
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#17K18 $19 Close command (File menu)

Use this command to close all windows containing the active document.    <<YourApp>> 
suggests that you save changes to your document before you close it.    If you close a 
document without saving, you lose all changes made since the last time you saved it.    
Before closing an untitled document, <<YourApp>> displays the Save As dialog box and 
suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:
{bml scmenu.bmp}
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#20K21 $22 Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, <<YourApp>> displays the Save As dialog box so 
you can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts
Toolbar: {bmc filesave.bmp}
Keys: CTRL+S
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#23K24 $25 Save As command (File menu)

Use this command to save and name the active document.    <<YourApp>> displays the 
Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.
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#26Send command (File menu)

Use this command to send the active document through electronic mail.    This command 
presents a mail window with the active document attached to it.    You may then fill out the 
To: field, Subject: field, etc., and add text to the body of the message if you wish.    When you
are finished you may click the "Send" button to send the message.
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#27File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters.    <<YourApp>> adds 
the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

<< Add other File Save As dialog box options depending on which ones your application 
chooses via the OFN_ flags of the OPENFILENAME structure used by the CFileDialog. >>
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#28 K29 $30 1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.
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29 files: managing
30 File 1, 2, 3, 4 command



#31K32 $33 Exit command (File menu)

Use this command to end your <<YourApp>> session.    You can also use the Close 
command on the application Control menu.    <<YourApp>> prompts you to save documents
with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

{bmc appexit.bmp}
Keys: ALT+F4
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#34Undo/Can't Undo command (Edit menu)

<< Your application's user interface for Undo may differ from the one described below.    
Modify this help text accordingly. >>

Use this command to reverse the last editing action, if possible.      The name of the 
command changes, depending on what the last action was.    The Undo command changes to
Can't Undo on the menu if you cannot reverse your last action.

Shortcuts
Toolbar: {bmc editundo.bmp}
Keys: CTRL+Z or

ALT-BACKSPACE
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#35Redo command (Edit menu)

<< Write application-specific help here. >>
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#36Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar: {bmc editcut.bmp}
Keys: CTRL+X
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#37Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts
Toolbar: {bmc editcopy.bmp}
Keys: CTRL+C
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#38Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts
Toolbar: {bmc editpast.bmp}
Keys: CTRL+V
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#39K40 $41 Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in <<YourApp>>, such as File Open.    A check mark appears next 
to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.
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#42K43 $44 Toolbar
{bml hlptbar.bmp}

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in <<YourApp>>,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

<< Add or remove toolbar buttons from the list below according to which ones your 
application offers. >>

Click To
{bmc filenew.bmp} Open a new document.

{bmc fileopen.bmp} Open an existing document.    <<YourApp>> displays the Open dialog 
box, in which you can locate and open the desired file.

{bmc filesave.bmp} Save the active document or template with its current name.    If you 
have not named the document, <<YourApp>> displays the Save As dialog box.

{bmc fileprnt.bmp} Print the active document.

{bmc editcut.bmp} Remove selected data from the document and stores it on the 
clipboard.

{bmc editcopy.bmp} Copy the selection to the clipboard.

{bmc editpast.bmp} Insert the contents of the clipboard at the insertion point.

{bmc editundo.bmp}Reverse the last editing.    Note:    You cannot undo some actions.

{bmc recfirst.bmp} Go to the first record in the current selection.

{bmc recprev.bmp} Go to the previous record in the current selection.

{bmc recnext.bmp} Go to the next record in the current selection.

{bmc reclast.bmp} Go to the last record in the current selection.
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#45K46 $47Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.
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#48K49 $50Status Bar
{bml hlpsbar.bmp}

The status bar is displayed at the bottom of the <<YourApp>> window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.
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#51New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.
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#52Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 
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#53Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.
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#54Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.
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#55Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.

55 HID_WINDOW_TILE_VERT



#56Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.
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#57Split Command (Window menu)

Use this command to split the active window into panes.    You may then use the mouse or 
the keyboard arrows to move the splitter bars.    When you are finished, press the mouse 
button or enter to leave the splitter bars in their new location.    Pressing escape keeps the 
splitter bars in their original location.    << In a single document interface application, this 
command will appear on the View menu. >>
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#581, 2, ... command (Window menu)

<<YourApp>> displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active window.  
Choose a document from this list to make its window active.    
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#59Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using <<YourApp>> and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.
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#60Using Help command (Help menu)

Use this command for instructions about using Help.

60 HID_HELP_USING



#61About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
<<YourApp>>.
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#62$63Context Help command 
{bml curhelp.bmp}

Use the Context Help command to obtain help on some portion of <<YourApp>>.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the <<YourApp>> window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1
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#64Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
{bmc bullet.bmp} Application Control-menu button
{bmc bullet.bmp} Document Control-menu button
{bmc bullet.bmp} Maximize button
{bmc bullet.bmp} Minimize button
{bmc bullet.bmp} Name of the application
{bmc bullet.bmp} Name of the document
{bmc bullet.bmp} Restore button
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#65 Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave 
in your application. >>
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#66Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.
{bml curarw4.bmp}

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.
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#67Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.
{bmc curarw4.bmp}

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7
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#68$69Minimize command (application Control menu)

Use this command to reduce the <<YourApp>> window to an icon.

Shortcut
Mouse: Click the minimize icon {bmc scmin.bmp} on the title bar.
Keys: ALT+F9

68 HID_SC_MINIMIZE
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#70Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut
Mouse: Click the maximize icon {bmc scmax.bmp} on the title bar; or double-click the

title bar.
Keys: CTRL+F10 enlarges a document window.
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#71Next Window command (document Control menu)

Use this command to switch to the next open document window.    <<YourApp>> 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6
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#72Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    <<YourApp>> 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6
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#73Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.
{bml appexit.bmp}

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box
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#74Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.
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#75Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.
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#76$77Ruler command (View menu)

<< Write application-specific help here. >>
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#78$79Choose Font dialog box

<< Write application-specific help here. >>
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#80$81Choose Color dialog box

<< Write application-specific help here. >>
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#82$83Find command (Edit menu)

<< Write application-specific help here. >>
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#84$85Find dialog box

<< Write application-specific help here. >>

84 AFX_HIDD_FIND
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#86$87Replace command (Edit menu)

<< Write application-specific help here. >>
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#88$89Replace dialog box

<< Write application-specific help here. >>
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#90$91Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item 
changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4
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#92$93Clear command (Edit menu)

<< Write application-specific help here. >>
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#94$95Clear All command (Edit menu)

<< Write application-specific help here. >>
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#96$97Next Pane

<< Write application-specific help here. >>
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#98$99Prev Pane

<< Write application-specific help here. >>
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#100Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>

100 HIDR_DOC1TYPE





#101No Help Available

No help is available for this area of the window.
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#102 No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>

102 AFX_HIDP_default


