
ADOBE® PHOTOSHOP® 4.0.1 READ ME

This file contains last-minute product information and updates to the Adobe Photoshop 
documentation. Please refer to the Getting Started guide for installation instructions. For 
troubleshooting and performance information, see the user guide or online Help.

IMPORTANT

Please complete your registration card and mail it today or use the on-line registration software 
provided with Adobe Photoshop to register your copy. You must register to receive technical 
support and important product update information.

Serial Numbers 

You can find the serial number on the registration card or on the first page of the user guide. Use 
this new number to initialize the program. Do not use the serial number on the Adobe Photoshop 
box. 

If you are upgrading from an earlier version of Adobe Photoshop, use the original serial number 
that came with that version. The seven-digit number that appears on your Upgrade Registration 
Card (e.g. PWW401V) is for reporting purposes only; you cannot use this number to install the 
application.

If you are upgrading from Adobe Photoshop LE, your old serial number will not work; please use 
the serial number included in your upgrade package. If your serial number does not work or you 
did not receive a full version serial number with your Photoshop LE upgrade package, please 
contact the reseller from whom you purchased the upgrade, or contact Adobe Systems at 800-
492-3623 or 206-628-2749.

Initialization and Preferences Files

Adobe Photoshop's initialization file (Photos40.ini) is located in the Prefs subdirectory under the 
directory where Photoshop is installed. The preferences file (Photos40.PSP) is also located in the
same Prefs directory. Versions 3.0.4 and earlier of Photoshop installed these files under the 
Windows directory.

Using QuickTime® for Windows® 

The Adobe Photoshop 4.0 Application CD-ROM includes version 2.12 of QuickTime for Windows. 
QuickTime for Windows is required to run the interactive movies on the Adobe Photoshop 
Application and Tutorial CD-ROMs. QuickTime 2.12 may be found in the Quiktime folder at the 
root level of the Photoshop 4.0 Application CD-ROM. To install QuickTime, follow the instructions 
in the Read Me file in the Quiktime folder.

4.0.1 Changes

Photoshop 4.0.1 is an update to Photoshop 4.0 that fixes a variety of minor problems that were 
discovered after Photoshop 4.0 shipped. The most notable fixes include the following:

* The fastcore.8bx plug-in--which in version 4.0 contained optimizations for both standard 
Pentium(tm)/Pentium Pro systems and systems with MMX(tm) technology--has now been divided
into two separate plug-ins. The fastcore.8bx plug-in provides standard Pentium/Pentium Pro 
optimizations. The new mmxcore.8bx plug-in provides optimizations for systems with MMX 



technology. The previous fastcore plug-in could cause crashes on some MMX systems, but those 
problems have been fixed with these two new plug-ins. (NOTE: Both fastcore.8bx and 
mmxcore.8bx are installed in the Extensions folder inside your Photoshop Plugins folder. The 
mmxcore plug-in will not affect Photoshop's performance if you are not using a system with MMX 
technology.)
* Photoshop 4.0.1 can now support systems with more than 1 GB of RAM. In addition, Photoshop
can now create a scratch disk on a hard disk partition or volume that is greater than 2 GB.
* Decimal percentages are now allowed when resizing images using the Image Size dialog.
* The quality of the results obtained when scaling images by large percentages using Free 
Transform has been improved.
* LZW-compressed TIFF files will now open faster.
* Inaccuracies of the Info palette's reading of the white point in CMYK images have been 
corrected.

In addition, the Fade command in the Filter menu can now be used on paint strokes as well as 
filter operations.

UNDOCUMENTED FEATURES

The following sections describe features in Photoshop 4.0 that are not described in the 
documentation.

Support for 16 Bits/Channel Images 

Adobe Photoshop 4.0 can read and import RGB and grayscale images that contain 16 bits of 
data per channel. You can also convert a flattened 8 bits/channel image to 16 bits/channel by 
choosing Image > Mode > 16 Bits/Channel. When working with a 16 bits/channel image, you can 
make selections using the marquee, lasso, and polygon lasso tools, and apply Levels and Curves
adjustments. In order to take full advantage of Photoshop's features, you can convert a flattened 
16 bits/channel image to 8 bits/channel by choosing Image > Mode > 8 Bits/Channel.

Image Cache Preference 

Photoshop 4.0 uses a scheme called image caching to help speed the redraw of high-resolution 
images. With image caching, Photoshop uses lower resolution versions of an image to update the
image on-screen when performing basic operations, such as compositing, layering, and applying 
color adjustments. You can adjust the image cache setting and determine whether or not  
Photoshop uses the image cache to display histograms.

To change the cache settings:

1. Choose File > Preferences > Memory & Image Cache.

2. For Cache Levels, enter a value between 1 and 8. A higher value results in greater image 
caching and quicker screen redraw, but also uses more hard disk space and RAM, and can 
increase the time it takes to open a file.

If you are working with small files (for example, frames of QuickTime movies or screen images), 
you may want to use a Cache Levels setting of 2 or 3. If you are working with large files (for 
example, files larger than 4096 pixels high or wide), you may want to use a setting higher than 4.

3. To increase the speed of histogram displays, select Use cache for histograms. Selecting this 
option produces a faster, though slightly less accurate, histogram display when you choose 
Image > Adjust > Levels or Image > Histogram.



4. Click OK.

Support for ICC profiles

As documented in the User Guide, Photoshop 4.0 can use ICC profiles to generate separation 
tables automatically. In order to use this feature, you must select the Custom Install option when 
installing Photoshop and choose to install the ICC profiles. Note that you must install the 
Photoshop application at the same time in order for the ICC profiles to be recognized. You should 
not install the Photoshop application and the ICC profiles separately.

Pasting data from Adobe Illustrator®

You can paste artwork copied to the Clipboard from Adobe Illustrator (version 4.0 and later). Also, 
see the information below, under Improving Performance and Troubleshooting, for more 
information about importing Adobe Illustrator files.

Batch processing

When batch processing a set of files, you can choose to override Open commands that have 
been recorded. To do this, choose Batch from the Actions palette menu and select Override 
Action 'Open' Commands. This option is useful when you would like to batch process a set of files
that are stored in a different folder than is specified by a previously recorded Open command.

Also note that you cannot batch process a Windows shortcut. You must place the actual file in the
batch folder in order for it to be processed.

Desaturate Command

The Image > Adjust > Desaturate command removes all color values from a color layer or image, 
leaving only the grayscale values.

Relative Move Option in Numeric Transform

Deselecting the Relative Move option in the Numeric Transform dialog box causes 
transformations to occur with respect to the 0, 0 position on the rulers.

Guides

Guides snap to the edges of current selections and to the 50% boundaries of alpha channels. 
The 50% boundary of an alpha channel is the border that encloses all pixels lighter than 50% 
gray. Guides also maintain their relative positions to the image contents when you resize the 
image or resize, rotate, or flip the work canvas.

Lock Guides Command

The View > Lock Guides command lets you lock or unlock the position of guides in an image. You
cannot move or change the orientation of a locked guide. If guides are locked they will not be 
scaled when the image they are in is resized. A checkmark next to the Lock Guides command 
indicates that guides are locked.



Selecting 

You can drag a selection marquee partially beyond the canvas boundaries without clipping the 
selection border. The original selection border remains intact when you drag it back within the 
canvas boundaries.

Viewing

To zoom in or zoom out on an image without resizing the window, press Ctrl+Alt+(+) or Ctrl+Alt+
(-), respectively. There are no shortcuts for zooming in to the maximum magnification or zooming 
out to the minimum magnification.

Layers 

You can use the following features and shortcuts when working with layers:

* To display the context menu listing the layers in the image at the current pointer location, press 
Ctrl and click with the right mouse button in the image.

* To move a selected layer one level up in the Layers palette, press Ctrl+]. To move one level 
down, press Ctrl+[. To move a layer to the topmost level of the Layers palette, press Ctrl+Shift+]. 
To move to the bottommost level of the palette (above the background), press Ctrl+Shift+[.

* When a layer mask is visible (when you are viewing its grayscale channel), double-clicking the 
layer mask thumbnail in the Layers palette lets you change the layer mask options. Otherwise, 
double-clicking the layer mask thumbnail in the Layers palette lets you change the layer
options.

* To toggle the layer mask channel display on and off, press \.

* To duplicate an existing layer mask on the selected layer, click on the layer where you want to 
add the duplicate layer mask to make it the active layer, then drag the layer mask thumbnail you 
want to duplicate to the New layer mask button at the bottom of the Layers palette. To duplicate 
the layer mask and reverse the hidden and revealed areas, press Alt as you drag the layer mask 
thumbnail.

* To load the boundaries of a layer mask as a selection, Ctrl-click the layer mask thumbnail in the 
Layers palette. To add or subtract the layer mask boundaries from an existing selection, press 
Ctrl+Shift or Ctrl+Alt, respectively, and click the layer mask thumbnail. To intersect the layer mask 
boundaries, press Ctrl+Alt+Shift, and click the layer mask thumbnails.

* When dragging a layer from one document to another, you can align the dragged layer with the 
destination document by holding the Shift key.  If the two documents are of the same pixel 
dimensions, the dragged layer will be dropped into the destination document in the same location.
If the two documents are of different dimensions, then the dragged layer will be centered in the 
destination document.

Rebuilding the Font Menu 

If you've added or removed fonts from your system since starting Photoshop, you can rebuild the 
Font menu in the Type Tool dialog box to include all the fonts that are installed on your system. To
do this, hold down Shift and click in the image with the type tool pointer.



Saving in JPEG format

When saving in the JPEG format, you can choose to save the image without paths by deselecting
the Save Paths option in the JPEG Options dialog box. Saving an image without path data can 
help reduce file size.

Using Photoshop JPEG files with JAVA applications

Many JAVA applications have trouble reading JPEG files that include thumbnails. If you find that a
JAVA application will not read your Photoshop JPEG files, try saving JPEG files with the 
thumbnail turned off. The Thumbnail option can be disabled in the Save dialog box.

Filling the Work Canvas

To fill the work canvas (the area surrounding the image when the window is resized to be larger 
then the image) with the current foreground color, Shift-click in the canvas with the paint bucket 
tool selected.

Resetting the Timer 

To reset the timer in the Timing display, hold down Alt, position the pointer over the triangle at the 
bottom of the program window, hold down the mouse button, and choose Timing from the menu.

Resizing Large Images 

Adobe Photoshop supports a maximum image size of 30,000 by 30,000 pixels. When you resize 
or resample large images, your results are limited by this constraint. For example, if the height of 
the image is 14 inches, the maximum resolution is 2142 (i.e., 30,000/14 = 2142). If you edit the
resolution of the image, Photoshop will adjust the dimensions accordingly.

USING ADOBE PHOTOSHOP WITH WINDOWS

The following sections include useful information about using Adobe Photoshop 4.0 with different 
versions of Windows.

Shared Files

Many files installed by Photoshop - such as Win32s 1.30.167 (installed on Windows 3.x only), 
TWAIN, TWAIN_32, Kodak PhotoCD, MSVCRT20.DLL and MSVCRT40.DLL (Photoshop does 
not install MSVCRT20.DLL under Windows 95 because it is included in the operating system) - 
are shared with other programs. When you install or uninstall other programs that use these 
shared files, the file versions used by Photoshop may be overwritten or deleted. If you experience
problems with features that depend on shared files, reinstall Photoshop.

Note that you must manually uninstall shared files installed by Photoshop if you are running under
the Win32s subsystem. Shared files are not automatially uninstalled by choosing the Uninstall 
command.

Windows 3.1 and the Win32s Subsystem



In order to run Adobe Photoshop 4.0 under Windows 3.1x,  you need to have the Microsoft 
Win32s subsystem installed on your system. Win32s allows 32-bit applications like Adobe 
Photoshop 4.0 to run unmodified under 16-bit Windows 3.1x. If you are installing under Windows 
3.1x and have selected Typical Install,  Compact Install, or have selected Program Files in the 
Custom Install dialog  box,  Adobe Photoshop Setup will install Win32s (version 1.30, build 167) 
automatically unless a newer version is present on your system. Older versions of Win32s on 
your system are overwritten.

Windows for Workgroups

If you are using Windows for Workgroups 3.11, you may experience problems with Adobe 
Photoshop, especially when printing files larger than 40 MB. These problems are due to the 
inability of some system BIOS chips to handle 32-bit file access. To correct the problem, you can 
turn off 32-bit file access. In the Windows Control Panel, choose the 386 Enhanced option. Select
Virtual Memory, and then click on the Change button. Disable the "Use 32-bit File Access" option 
and click OK.

Windows 95

If you are using Windows 95 and experience memory errors or errors when saving an Adobe 
Photoshop document, change the minimum and maximum virtual memory settings in Windows 95
to 2 times the amount of RAM on your system. For example, if your system has 32 MB of RAM, 
navigate to Control Panel > System > Performance > Virtual Memory>Let me specify my own 
virtual memory settings, and set the minimum and maximum virtual memory values to 64. Setting 
the virtual memory to these fixed values enables Photoshop to control use of the hard drive space
for its scratch disk for the best performance, rather than letting Windows 95 manage it. For 
optimum performance, make sure that Photoshop's primary scratch disk is assigned to a partition 
or hard drive that is not the same partition or hard drive Windows 95 uses for its virtual memory. 
For more information, see "Assigning scratch disks" on page 364 of the user guide or see the 
same section in online Help.

Windows NT

Adobe Photoshop 4.0 can be run under Windows NT 3.51 and 4.0 for Intel-based systems only. It
will not run under other types of Windows NT such as Windows NT for DEC Alpha or Windows 
NT for PowerPC.

Running Adobe Photoshop under Windows NT with dual processors can improve by 80% the 
program's performance on mathematical or computational-intensive operations (such as 
converting a document from RGB mode to CMYK); by 20% to 30% for less intensive operations; 
and by 10% for screen redrawing.

Some third-party plug-in modules (such as those for scanners) may not work with Adobe 
Photoshop under Windows NT because they are 16-bit modules, whereas Adobe Photoshop is a 
32-bit application. Windows NT requires a 32-bit TWAIN source module to scan images, and will 
not work with the same scanner software that worked with Windows 3.1. If you experience 
problems when trying to scan images under Windows NT, try using the scanner manufacturer's 
TWAIN_32 source module. Contact the third-party manufacturer for information on the availability 
of 32-bit versions of scanning modules.

Changing Monitor Bit Depth in Windows NT



When using Adobe Photoshop with Windows NT, do not attempt to change bit depth while 
running Adobe Photoshop. If you need to change your monitor's bit depth, Quit Photoshop. 
Change your monitor's bit depth, then relaunch Photoshop.

File Associations in Windows 95 and Windows NT 4.0

Upon installation, Photoshop will automatically register itself with Windows as the default editing 
application for many of the graphics file formats that it supports, such as TIFF, EPS and JPEG 
files. If you have any files on your system in one of the registered formats, they will be displayed 
with Photoshop icons, and double-clicking on one of these files will automatically launch the 
Photoshop application. This will be true even if the files were originally created with a different 
application. Windows requires that all files with the same three-letter extension be registered with 
the same application.

If you would prefer to define a different default application for opening a particular file type, it's 
easy to do so yourself:
1. On the desktop, use the mouse to select a file of the type you want to open.
2. While holding down the [Shift] key, right-mouse-click on the file.
3. In the context menu that appears when you right-mouse-click, select the "Open with..." option. 
The Open With dialog appears.
4. In the Open With dialog, select the name of the application you want to use to open the file. If 
you don't see the desired application in the list, you can use the Other... button to find it.
5. Enable the "Always use this program to open this type of file" checkbox.
6. Click O.K.

Alternatively, you can reinstall the application that you want to use to open a given file type, and it
will re-register itself as the default application.

Batch Processing in Windows NT

If you are using the Batch command when running Photoshop under Windows NT, you must save
your batched files to a folder other than your source folder to avoid having Photoshop 
continuously process the same files.

Windows NT and Wintab32.dll

If you are running Windows NT 3.51 or NT 4.0 and have the file Wintab32.dll present on your 
system the following error message will appear while Adobe Photoshop 4.0 is loading: 

"Tools:Photoshp.exe-Entry Point Not Found. The procedure entry point UTRegister could not be 
located in the dynamic link library kernel32.dll."

This message is harmless and will allow you to continue.

OS/2 Warp

Adobe Photoshop 4.0 is not designed (nor was it tested) to be run under the IBM® OS/2® Warp 
operating system.

Running Adobe Photoshop Over a Network 

Adobe Photoshop 4.0 is not designed (nor was it tested) to be run when Windows is multi-
launched over a network. If you want to run Adobe Photoshop on multiple Windows systems, 



make sure that each system has its own copy of Windows and Adobe Photoshop installed on the 
hard drive.

IMPROVING PERFORMANCE AND TROUBLESHOOTING 

The following sections describe how to improve your system's performance when working with 
Adobe Photoshop 4.0, and how to correct some common problems which may occur.

Compressed Drives and Virtual Memory 

Adobe Systems recommends that you do not set either the Windows swap file or Adobe 
Photoshop's scratch disk to a compressed disk drive. For more information, see "Assigning 
scratch disks" on page 364 of the user guide.

Redrawing Images 

When your video driver is set to 256 colors, Photoshop does not redraw an open image in the 
background when the foreground image is edited. To have Adobe Photoshop redraw every open 
image when a palette change occurs in 256-color mode, add the following line to your 
Photos40.ini file:

REDRAWBKDOCS=1

Matrox Millennium® Graphics Board

If you notice slow screen redraw speeds on a system using the Matrox Millennium graphics 
board, make sure that you are using the latest version of the video driver for this board. 
Alternatively, adding the following line to your Photos40.ini file may improve performance:

INVERTDIB=1

Importing Adobe Illustrator® Files

The EPSParsr.8by plug-in installed with Photoshop 4.0 should successfully import most generic 
encapsulated postscript files as well as most Adobe Illustrator files. If you are having problems 
importing Adobe Illustrator files in 88 or 1.0/1.1 format, or Illustrator files containing text which 
uses Multiple Master fonts, you may have more success with the aiparser.8by plug-in. To use the 
aiparser plug-in, drag it from the the goodies/plugins folder on the Photoshop 4.0 Application CD 
to your Photoshop 4.0 plug-ins folder. You must also remove the EPSParsr.8by plug-in from your 
Photoshop 4.0 plug-ins folder.

Please note that, when you use the aiparser instead of the epsparsr plug-in, you will not be able 
to import generic postscript files that were not created with Adobe Illustrator. Also, some 
advanced features of Adobe Illustrator, such as gradient and pattern fills, may not be supported.

Incompatibilities with Utilities and Device Drivers

This section describes some common problems that may result when using pressure-sensitive 
tablets or the Powertoy utility.

* Pressure-sensitive Pens and Tablets



After restarting your computer, the tablet and stylus report a pressure level of zero. Click or drag 
once with the stylus on the tablet to reset the tablet's pressure sensitivity and to paint.

Under Windows 3.1, Adobe Photoshop 4.0 supports only pressure-sensitive digitizing tablets that 
are 100% compatible with the Microsoft Pen Windows specification. Under Windows NT and 
Windows 95, Adobe Photoshop 4.0 supports only pressure-sensitive digitizing tablets that are 
100% compatible with the WinTab32 specification.

If the pen's highest pressure doesn't reach 100%, a problem exists in the driver software. For the 
latest driver software, contact the tablet manufacturer. The following are contact phone numbers 
for some of the leading manufacturers:

Wacom Technology Corporation: www.wacom.com  Tel: 800-922-6613
ALTEK Corporation (Kurta tablets): Tel: 301-572-2552
CalComp: www.calcomp.com Tel: 800-451-7568
Hitachi:  408-735-0577

* QuickRes Utility and Color Depth

After changing the color depth of a Photoshop image using QuickRes, the color in the image may 
appear altered. (QuickRes is a Microsoft Powertoy utility that allows changing the color depth 
without restarting the system or the application.) To set the colors correctly, restart Adobe 
Photoshop.

Enabling a Printer Device to Convert RGB to CMYK

RGB graphics created in Adobe Photoshop 2.5 and later include data called RGB tags that 
instruct Photoshop to use its own algorithms when converting RGB data to CMYK for 
separations. Unless RGB tags are disabled, Photoshop converts all RGB data to CMYK rather 
than letting the printer perform the conversion. When printing to a PostScript Level 2 device, 
disabling the RGB tags enables the printer to convert the RGB data to CMYK data.

To disable RGB tags in Photoshop for Windows:

1. Make a backup copy of the Photos40.ini initialization file.
2. Use a text editor that saves in text-only format and open the original Photoshop initialization 
file.
3. In the [Photoshop] section of the Photoshop initialization file, add the following line, exactly as 
shown:

DISABLERGBTAGS=1

4. Save the Photoshop initialization file as text-only and restart Photoshop.

Enabling Asynchronous I/O for Virtual Memory

When asynchronous I/O is enabled for Photoshop's virtual memory, it allows multiple virtual 
memory operations to be overlapped. In some cases, this can make Photoshop seem to be more 
responsive, but it can also cause slower overall performance on some systems. In Photoshop 
3.0, asynchronous I/O for virtual memory was enabled by default. In Photoshop 4.0, 
asynchronous I/O is disabled by default.

You can enable asynchronous I/O yourself in order to find out whether it improves Photoshop's 
performance on your system. Simply add the following line, exactly as it appears, to your 



Photos40.ini file:

VMASYNCIO=1

If you find that performance is degraded with asynchronous I/O enabled, you can turn it off simply
by deleting the line above from your Photos40.ini file.

Multiprocessor Extension

The MThread.8bx plug-in installed with Photoshop 4.0 provides support for systems with multiple 
processors. If you are experiencing problems running on a multiprocessor machine, ensure that 
you have only one copy of this plug-in in your Plugins folder.

Function Key Defaults

F1 - Help
F2 - Cut
F3 - Copy
F4 - Paste
F5 - Show/Hide Brushes Palette
F6 - Show/Hide Colors Palette
F7 - Show/Hide Layers Palette
F8 - Show/Hide Info Palette
F9 - Show/Hide Actions Palette
F12 - Revert
Shift-F5 - Fill
Shift-F6 - Feather
Shift-F7 - Select > Inverse

Viewing Desktop File Thumbnails

Some video drivers may cause the Photoshop 4.0 desktop file thumbnails to appear as black 
rectangles. If you experience this problem, select the icon, right-click to display its context menu, 
and choose Properties from the menu. Click Photoshop Image and try some of the other settings 
under Icon Thumbnails. You will only see Icon thumbnails if you have 32,767 or more colors, and 
are running Windows 95 with the Plus! Pack or Windows NT 4.0. To force Windows to update a 
Photoshop (or any other) icon, select the icon and press F5. 

Enabling Debug Messages

If you are a software developer (or anyone who uses debuggers) running Windows 3.1x or 
Windows for Workgroups 3.1x, installation of Photoshop may cause your debug messages to be 
ignored. To correct this, simply remove the following entry  from your system.ini file:

OutputTo=NUL
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