
Contents

Click an icon or a title to find information.

How Do I    Step-by-step instructions for common tasks

Search    Index of help topics and features

Additional Help    Glossary, Tips and Tricks, Common Questions, and other information

Using Help    Hints on learning Help



Using Help

The following information explains basic features of a Help topic (this screen is a Help topic).

Pop-up definitions are dot-underlined, coloured words and phrases that you click to see a 
"pop-up" window that displays information.    The pop-ups below explain the buttons on the 
top of this Help screen, and are examples of the pop-ups found in Help.    Click once to read 
them, then click again to close them.

      Contents      Search      Back      History      Print      Close

Jump terms are underlined, coloured words and phrases that move you to another Help 
topic.    To read the topic about context-sensitive Help, click this jump term:    context-
sensitive Help, then click the Back button to return to this Help topic.

The light bulb is an icon containing a hint.    Click the light bulb to read the hint.

Text following a route icon shows the menus and buttons you choose to access a feature.

Text following an exclamation point is important information.

Text following a reference icon directs you to the printed documentation.    Many Help topics 
contain graphics you can click to display a pop-up definition.    However, when a graphic 
appears in front of the title, it is not a pop-up.

See Also
Quick tour Main Menu
Watch quick tour of Using Help
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alphanumeric
Composed of letters or numerals or both.
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Keystrokes

Purpose
Use the following keystrokes to access InfoCentral features.

To Use This Feature Press
Add new Object Ctrl+A
Clear to End Ctrl+E
Clear View Ctrl+W
Clear Line Ctrl+L
Collapse All Alt+-
Collapse Connections Minus (-)
Connect Object Ctrl+K
Copy Ctrl+C
Create new iBase Ctrl+N
Cut Ctrl+X
Delete Object Ctrl+D
Edit Information Alt+Enter
Exit InfoCentral Alt+F4
Expand Connections Plus (+)
Expand by Type Alt++
FastFind Ctrl+F
Find-By-Connection Alt+F2
Find-By-Example Shift+F2
Go To Beginning of Screen Home
Go To Beginning of List Ctrl+Hom

e
Go To End of Screen End
Go To End of List Ctrl+End
Go To Next Item on Line Right 

Arrow
Go To Next Line Down 

Arrow
Go To Next Object Ctrl+Right
Go To Next Screen PgDn
Go To Previous Item on 
Line

Left Arrow

Go To Previous Line Up Arrow
Go To Previous Object Ctrl+Left
Go To Previous Screen PgUp
Hoist Object Ctrl+H
Open iBase Ctrl+O
Move Object to Beginning Shift+Ho

me
Move to End of List Shift+End
Move Object to Next Line Shift+Dow

n
Move Object to Previous 
Line

Shift+Up

Paste Ctrl+V
Print Ctrl-P
Relate a File Ctrl+R



Save iBase Ctrl+S
Save As F3
Scroll Down Ctrl+Dow

n
Scroll Up Ctrl+Up
Telephone Ctrl+T
Toggle View Enter
Undo Ctrl+Z
View Information Ctrl+I
View Calendar Alt+C
View Previous Tab Ctrl+Tab
View Address Book Ctrl+B

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Go To
Load Menu System
Move Object To



Glossary

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A

alphanumeric
ASCII

B

Back button

C



calendar view
category
check box
Clipboard
collapse
connection
connection description
connection information
constant
Contents button
copy
cut

D

dialog box
display list
deselect
drag
drop-down list

E

event
expand

F

field
field type
flatten

G

group title pad

H

History button
hoist
host edition
housekeeping

I

iBase
insertion point



J

jump term

K

No entries

L

list

M

memo
menu
menu bar
mouse pointer

N

No entries

O

object
object category
object information
one-way connection
outline view

P

paste
pop-up definition
private information
promote
properties

Q

No entries

R

radio button
record



related file
remote edition
route

S

scroll bar
Search button
shred
sort

T

tab
template
toggle
trash can
two-way connection

U

undo
unzoom

V

valid range
volume

W

wildcard

X

No entries

Y

No entries

Z

zoom



Context-Sensitive Help

Purpose
Use F1 to get context-sensitive Help in a dialog box or menu.

Steps

1 Press F1 while a menu item is highlighted or when a dialog box or window is open.
or
Choose the Help button in a dialog box.

See Also
Write Contextual Help
Write Contextual Hint



Outline View Menu Commands

Purpose
The Outline View menu bar includes several InfoCentral menu bar items.

Choose from the following options for more information:
File
Edit
Object
Find
View
List
Tools
Help

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menus: The Big Picture
Load Menu System
Using Calendar: The Big Picture
Watch quick tour of Using Calendar



About InfoCentral

Purpose
Use About InfoCentral to view the name and organisation of the user, copyright 
information, and the version of InfoCentral you are using.

Steps

1 Choose About InfoCentral from the Help menu.

2 Read the information, then choose OK.

See Also
WordPerfect Main Street Products
System Status
Watch quick tour of InfoCentral Basics



Help Menu

Purpose
Use the options on the Help menu to get online Help.    Some Help items are available only
on the Outline View Help menu.

Choose from the following options for more information.
Contents
Search for Help on
How Do I
Quick Tour
Coaches
About InfoCentral

See Also
Menu Commands
Using Help
Watch quick tour of Using Help



Additional Help

What is InfoCentral    Product and feature information

What's New    New features and enhancements

Common Questions    Answers to basic questions about InfoCentral

Tips and Tricks    Hints and shortcuts to accomplish common tasks

Keystrokes    Keyboard navigation

Glossary    Terms and definitions

Print Help Topics    Print multiple Help topics

Available Products    Additional Novell Main Street applications



What's New

In addition to the new look and feel of the Toolbar, InfoCentral 1.1 has been improved with 
the following new features.

Choose from the following topics:

Add Connected Object
Alarm Status
Import/Export iBase
GroupWise Calendar Synchronization
Recurring Events
Today's Tasks



Common Questions

Purpose
Get answers about InfoCentral by clicking any of the following frequently asked questions.

          General Questions
What is an iBase?
What is an Object?
What is a Category?
What is a Connection?
What is a Connection Description?
What is the Outline View?
How Do I Start a New iBase?

          Common Questions About Objects and Connections
How Do I Add an Object?
How Do I Create a New Object Category?
How Do I Delete an Object?
How Do I Undelete an Object?
How Do I Clear an Object?
How Do I Find an Object?
How Do I Use Search Criteria?
How Do I Objects by Connection?

          Common Questions About Preferences
How Do I Change the Toolbar?
How Do I Change the Colour of an Object?
How Do I Turn Off the Mr. and Ms. Prefix?
How Do I Set an Alarm Sound?
How Do I Set Up My Modem?
How Do I Set Up Autodialing Scenarios?

          Common Questions About Using the Outline View
What is a Tab?
How Do I Create or Edit a Tab?
How Do I Move a Tab?
What is the InfoPad For?
How Do I Look Up Addresses?
How Do I Look Up Objects Alphabetically?
How Do I Sort Objects Alphabetically?

          Common Questions About Using InfoCentral to Communicate
How Do I Send E-mail from InfoCentral?
How Do I Autodial a Phone Number?
How Do I Schedule a Phone Call Event?
How Do I Log a Phone Call?

          Common Questions About the Calendar
What is the Calendar View?
How Do I Schedule an Event?
How Do I Schedule a Recurring Event?



How Do I Set Up a Task?
How Do I Follow-Up with People?
How Do I Follow-Up With Organisations?
How Do I Follow-Up on Tasks?
How Do I View My Schedule in Outline View?
How Do I Coordinate with GroupWise?

          Common Questions About Advanced Features
How Do I Attach a Document to an Object?
How is a Related File Created?
How Do I Type Text Automatically?
How Do I Relocate of My Related Files?
What is a Field?
How Do I Add, Change, or Move a Field?
How Do I Import My Data into InfoCentral?
How Do I Import Letter Addresses?
How Do I Export and Update an iBase?



Tips and Tricks

Purpose
Learn about ways to save time or optimize InfoCentral by clicking a tip or trick listed 
below.

          General Tips and Tricks
Make InfoCentral Run Faster
Start a Timer
Set Passwords for iBases

          Calendar Tips and Tricks
List Today's Schedule in Outline View
Enter Dates Quickly into Fields
Change How an Alarm Sounds

          Outline View Tips and Tricks
Look at Objects with New Perspective
Find Objects with Little Information

          Related File Tips and Tricks
Attach a Document to an Object
Extract Information from iBase and Put in Document
Include Information of Connected Objects in Document
Type Text Automatically in Document



Start Up Options

Purpose
Use startup options to make InfoCentral run differently.    You can include startup options 
on the command line in the Properties dialog box for InfoCentral.

Steps

1 Highlight the InfoCentral program icon in Windows Program manager.

2 Choose Properties from the Windows File menu.

3 Type a space after "WPIC.EXE" on the command line, type one of the following startup 
options, then choose OK:

                  /AUTHOR
Display the Publisher Info dialog box when exporting an iBase.    Also displays 
InfoCentral Help ID numbers on all dialog boxes.

                  /I
Starts InfoCentral with the iBase that you specify.    For example, /ipersonal launches 
the Personal iBase when you start InfoCentral.    Note that you do not need to include 
a space between the startup option and the name of the iBase.

                  /LARGEPRINT
Displays the text in the Outline View in a larger font.

                  /PENOFF
Turns off the comb edit field when running under the Pen Windows operating system.



Follow-Up with People and Organisations

Object or Connection Information, Follow Up

Purpose
Use the Follow-Up Date field to enter a date on which you need to follow up with, respond 
to, or make contact with a person or organisation.    Follow-Ups are displayed in Today's 
Schedule for the current day.    For example, if today were Dec. 1, 1994, and several weeks
ago you entered this date in the Follow-Up field for Marc Sabatini, he would be displayed 
under Follow-Ups for today when you displayed Today's Schedule in the Outline View.

Steps

1 Right-click a person or organisation object, then choose Information.

2 Specify a date in the Follow-Up field by typing it or using the Calendar Tool. 

3 Choose OK.

4 Choose FastFind from the Find menu.

5 Type the date that you specified in step 2 in the Find text box, then choose OK to display
Today's Schedule for that day.

6 Double-click Follow-Ups for Today.

See Also
Calendar Tool
Create or Edit Date Field
Date Differences
Date Not Understood
Follow-Up on Tasks
Today's Schedule



What is InfoCentral

InfoCentral is a personal information manager (PIM), plus a lot more.    Patent pending 
iConnect technology lets you create intelligent connections between people, places, and 
things, looking at the relationships in a whole new way.    Randomly scattered data becomes 
organised and accessible.    Your world of information will never be the same.

When you start InfoCentral, you will find an easy-to-use set of tools to handle your 
immediate needs and serve as a long-term solution in your business, home, and school.    For
example,

          You can quickly add or import all the people in your personal address book.    
You can also extract names and addresses from existing files on disk.

          You can keep track of important information on all your business contacts.    
Things like companies, meetings, agendas, memos, and letters are all logically 
connected.

          You can keep track of events like appointments, birthdays, anniversaries, 
meetings, and so on.

          You can move seamlessly in and out of your word processor, spreadsheet, 
graphics, and other applications, creating files and connecting them to objects in your 
information base (iBase).

          Keep track of anything that interests you.    Use InfoCentral to organise your 
notes from school or your home video collection.    Your imagination is the only limit.

The stand alone version of InfoCentral includes four iBases already filled with content, and a 
number of iBase templates to give you a head start.    Use the templates to track your own 
information or to get ideas about how you can use InfoCentral.

See Also
Adding an Object
Connecting Objects
Creating a Related File
iBases versus Databases
Glossary
What's New in Version 1.1
 Using InfoCentral



InfoPad
The InfoPad tab is like any other tab.    It is set up for you like a scratch pad, where you can 
work with data in a freeform way.    It is wise to keep this tab free of lists and save lists to 
other tabs.    For tips on using, see Using InfoPad.



Follow-Up on Tasks

Task Object, Next Follow-Up On

Purpose
Use Next Follow-Up On, located on any Task object, to specify a due date for a task.    For 
example, suppose that you wish to remind yourself to take out the garbage by Friday the 
10th.    Using Next Follow-Up On, you can specify this date and the task will show as being 
due on that date when you use Today's Tasks, Today's Schedule, or the Calendar View for 
that date.

Steps

1 Right-click a Task object, then choose Information.

2 Specify a date in the Next Follow-Up On field by typing it or using the Calendar Tool. 

3 Choose OK.

4 Choose FastFind from the Find menu.

5 Type the date that you specified in step 2 in the Find text box, then choose OK to display
Today's Schedule.

6 Double-click Tasks at the end of the Today's Schedule listing.

See Also
Calendar Tool
Create or Edit Date Field
Date Differences
Date Not Understood
Follow-Up with People or Organisations
Today's Schedule



XDATE$

Purpose
Returns a date string in the form MM/DD/YYYY based on an argument containing the 
number of days past 01/01/1800.

Syntax
XDATE$(Nbr_of_days)

Examples
XDATE$(69460)
Returns 02/05/1990 where 69460 is a numeric constant.

XDATE$(Nbr_of_days)
Returns 02/15/1991 where Nbr_of_days is a numeric variable set to the value 69835.

See Also
XDAYS



XSECS

Purpose
Returns the number of seconds that the time contained in its argument is past midnight.    
The parametre (for example "This_time$") must in the 24-hour format HH:MM.

Syntax
XSECS(This_time$)

Examples
XSECS("01:00")
Returns 3600 where "01:00" is a string constant.

XSECS(Meeting_time$)
Returns 46800 where Meeting_time$ is a string variable set to the value "13:00".

See Also
XTIME$



XTIME$

Purpose
Returns a time string in the form "HH:MM" based on a numeric    argument representing 
the number of seconds past midnight.    The string returned is in the 24hour format 
HH:MM.

Syntax
XTIME$(Nbr_of_secs)

Examples
XTIME$(3720)
Returns 01:02 where 3720 is a numeric constant.

XTIME$(Sleep_until)
Returns 12:00 where Sleep_until is a numeric variable set to the value 43200.

See Also
XSECS



CHR$

Purpose
A string function that returns the character represented by the decimal ASCII character 
code value of its numeric argument.    Char_number represents the desired ASCII character
code and has a value from zero to 255.    For example, the escape key is CHR$(27), the 
space key is CHR$(32), and upper case A is CHR$(65).

Syntax
CHR$(Char_number)

Examples
CHR$(67)
"C" where 67 is a numeric constant.

CHR$(Nbr)
"a" Nbr is a numeric variable set to the value 97.

See Also
ASC



DEL$

Purpose
A string function that returns the string contained in its string argument but with the 
characters deleted from the string starting at the character position specified in its first 
numeric argument for the length specified in its second numeric argument.    Spaces count
as characters in computing the position and length.

Syntax
DEL$(Text$,Position,Length)

Examples
DEL$("It is very hot today.",7,5)
Returns "It is hot today." where "It is very hot today." is a string constant and 7 and 5 are 
numeric constants.

DEL$(Sentence$,Adj_location,Adj_length)
Returns "I watered the tree." where Sentence is a string variable set to the value "I 
watered the tallest tree", Adj_location and Adj_length are numeric variables set to the 
values 15 and 8 respectively.



FORMAT$

Purpose
Returns the string contained in its first string argument, with formatting based upon the 
format mask contained in its second string argument.

Syntax
FORMAT$(Text$,Mask$)
FORMAT$(Number,Mask$)

Parameters
Text$
The text string.

Mask$
Controls the formatting of Text$.

Number
A number.

Examples
FORMAT$("123456.789","$*,***,**#.##")
Returns "$123,456.78 "    the trailing space for a positive number.

FORMAT$("123456.789","$#,###,###.##")
Returns "$    123,456.78"

FORMAT$("123.45","*,**#.##;(*,**#.##)")
Returns "(123.45)" When a specific mask is given for negative values, then the minus sign 
is not automatically inserted and the mask must provide for showing that the value is 
negative.

FORMAT$("78.90","### %")
Returns " 78 %"



INS$

Purpose
Returns the string contained in its first string argument but with the string contained in its 
second string argument inserted at the character position specified in its numeric 
argument.    Spaces count as characters in computing the insert position.

Syntax
INS$(Text$,Position,Insert$)

Examples
INS$("It is hot today.",7,"darned ")
Returns "It is darned hot today." where "It is hot today." and "darned " are both string 
constants.

INS$(Sentence$,Location,Adjective$)
Returns "I have a fast computer." where Sentence$ is a string variable set to the value "I 
have a computer.", Location is a numeric variable set to the value 10, and Adjective$ is a 
string variable set to the value "fast".



LCASE$

Purpose
Returns the string named in the parentheses in lowercase.

Syntax
LCASE$(Mixed_text$)

Examples
LCASE$("aBcDeFgHiJkLmNoPqRsTuVwXyZ")
Returns "abcdefghijklmnopqrstuvwxyz" where "aBcDeFgHiJkLmNoPqRsTuVwXyZ" is a 
string constant.

LCASE$(Last_name$)
Returns "morris" where Last_name$ is a string variable set to the value "Morris".

See Also
UCASE$



LEFT$

Purpose
Returns the left-most portion of its string argument.    The length of this portion is specified
by its numeric argument.

Syntax
LEFT$(Text$,Length)

Parameters
Text$
The string argument.

Length
The number of characters (including the leftmost character) of Text$ to be returned.    If 
Length exceeds the number of characters contained in the string argument Text$, then the
entire string is returned.    Spaces are counted as characters

Examples
LEFT$("Jetson Industries, Inc.",6)
Returns "Jetson" where "Jetson Industries, Inc." is a string constant and 6 is a numeric 
constant.

LEFT$(Greeting$,Length)
Returns "Hello" where Greeting$ is a string variable set to the value "Hello there!" and 
Length is a numeric variable set to the value 5.

LEFT$(City$,99)
Returns "San Francisco" where City$ is a string variable set to the value "San Francisco" 
and 99 is a numeric constant.    Since the length argument, 99, is a value greater than the 
length of the string argument, then the unchanged value of the string argument is simply 
returned.

See Also
MID$
RIGHT$



LJUST$

Purpose
Returns a string that is of the length specified by its second argument, composed of the 
string in its first argument, and suffixed or padded at the right with a series of repeated 
pad characters as specified by its third argument.

Syntax
LJUST$(Text$,Length,Pad_character$)

Examples
LJUST$("Good morning",15,"!XYZ")
Returns "Good morning!!!" where Good morning is a string constant, 15 is a numeric 
constant, and !XYZ is another string constant.    Only the first character of the pad 
character argument is used to pad out the result.    In this example it is the "!" of the "!
XYZ" that is repeated to provide the necessary pad characters.

LJUST$(Country$,Length,Pad_char$)
Returns "Panama...." where Country$ is a string variable set to the value "Panama", 
Length is a numeric variable set to the value 10, and Pad_char$ is a string variable set to 
the value ".".

See Also
RJUST$



XDAYS

Purpose
Returns the number of days that its date argument is past    the date 01/01/1800.    
This_date$ may be in one of two forms, MM/DD/YYYY or MM/DD/YY.    When the two-digit 
year form is used, the year is assumed to be the right-most two digits of the four-digit 
year in the range of years from 1911 through 2010.

Syntax
XDAYS(This_date$)

Examples
XDAYS("02/01/1990")
Returns 69456 where 69456 is a numeric constant.

XDAYS(This_date$)
Returns 69821 where This_date$ is a string variable set to the value "02/01/1991".

See Also
XDATE$



MID$

Purpose
Returns the middle portion of its string argument.    The starting character position of the 
desired portion is specified by its first numeric argument and the length of the portion is 
specified by its second numeric argument.

Syntax
MID$(Text$,Start,Length)
MID$(Text$,Start)

Parameters
Start
A numeric value that specifies the starting character position of the string contained in 
Text$.

Length
A numeric value that specifies the number of characters from the specified starting 
position within Text$ that are to be returned.    Length is an optional argument.    When not 
given, the entire right portion of the string contained in Text$ starting at Start is returned.  
If the value of Length exceeds the number of characters contained in the string argument 
Text$, then the entire string is returned.    Spaces are counted as characters in computing 
the starting position and length.

Examples
MID$("Gary Lee Davis",6,3)
Returns "Lee" where "Gary Lee Davis" is a string constant and 6 and 3 are numeric 
constants.

MID$(Greeting$,Start,Length)
Returns "morning" where Greeting$ is a string variable set to the value "Good morning to 
all", and Start and Length are numeric variables set to the values 6 and 7 respectively.

MID$(City$,5)
Returns "Francisco" where City$ is a string variable set to the value "San Francisco" and 5 
is a numeric constant.    Since the length argument is not specified, then all of the string 
contained in City$ starting at character position 5 is returned.

See Also
LEFT$
RIGHT$



REP$

Purpose
A string function that has two string arguments and two numeric arguments.    REP$ 
returns the string contained in its first string argument with the characters beginning at 
the position specified by its first numeric argument replaced by a number of characters 
contained in its second string argument, the number of which is specified in its second 
numeric argument.    Length may be a numeric constant or numeric variable.    If the 
argument is zero, it returns a null value; if it is less than zero it causes a runtime error; if it
is greater than 255 it is truncated to 255.

Syntax
EP$(Text$,Length,Substitute_text$,Sub_length)

Parameters
Text$
The text argument.

Length
The length of Text$.

Substitute_text$
The substitute text argument.

Sub_length
The length of Substitute_text$.

Examples
REP$("Get noodles",5,"up and down",2)
Returns "Get up" where "Get noodles" is the string constant whose first 4 characters are 
extracted, 5 is a numeric constant specifying where the characters from the second string 
are to be inserted, "up and down" is the string constant whose first 2 characters are 
inserted, and 2 is a numeric constant specifying how many characters of the string "up 
and down" to insert.

REP$(First_names$,First_length,Last_names$,Len2)
Returns "Brian Levantine" where First_names$ is a string variable that is set to the value 
"Brian John Harry" and whose first 5 characters are extracted, First_length is a numeric 
variable set to the value 6 which specifies where the characters from the second string are
to be inserted, Last_names$ is a string variable set to the value "Levantine Smith Jones"    
and whose first 9 characters are to be inserted, and Len2 is a numeric variable set to the 
value 9 which specifies how many characters to insert from the string contained in 
Last_names$.



RIGHT$

Purpose
Returns the right-most portion of its string argument.    The length of this portion is 
specified by its numeric argument.

Syntax
RIGHT$(Text$,Length)

Parameters
Text$
The string argument.

Length
The number of characters including the right-most character to return. If Length exceeds 
the number of characters contained in the string argument Text$ then the entire string will
be returned.    Spaces are counted as characters.

Examples
RIGHT$("My name is Marc Sabatini",13)
Returns "Marc Sabatini" where "My name is Marc Sabatini" is a string constant and 13 is a 
numeric constant.

RIGHT$(Address$,Length)
Returns "Ave" where Address$ is a string variable set to the value "1317 Grant Ave" and 
Length is a numeric variable set to the value 3.

RIGHT$(Address$,100)
Returns "1317 Grant Ave"    where Address$ is a string variable set to the value "1230 
Grant Ave" and 100 is a numeric constant.    Since the length argument is a value greater 
than the length of the string argument, then the entire value of the string is returned.

See Also
LEFT$
MID$



RJUST$

Purpose
Returns a string the length specified by its second argument, composed of the string in its 
first argument, and prefixed, or padded in the front, with a series of repeated pad 
characters as specified by its third argument.

Syntax
JUST$(Text$,Length,Pad_character$)

Examples
RJUST$("This is a test!",20,"*ABC")
Returns "*****This is a test!" where This is a test! is a string constant, 20 is a numeric 
constant, and *ABC is another string constant.    Only the first character of the pad 
character argument is used to pad out the result.    In this example it is the "*" of the 
"*ABC" that is repeated to provide the necessary pad characters.

RJUST$(Greeting$,Length,Pad_char$)
Returns "          Hello"    where Greeting$ is a string variable set to the value "Hello", Length 
is a numeric variable set to the value 10, and Pad_char$ is a string variable set to the 
value " "

See Also
LJUST$



Add Connected Object

Object, Add Connected

Purpose
Use Add Connected to connect a newly added object to the object that is highlighted or 
selected in the Outline View.

Steps

1 Highlight the object in the Outline View that you wish to connect a new object to.

2 Choose Add Connected from the Object menu.

3 Select a category, then choose OK.

4 Type the name of the new object, then choose OK.

5 Type information about the new object, then choose OK.

6 Select a connection description, then choose OK.

7 If you wish to connect the object you just added, choose Yes, then follow the prompts.

See Also
Add New Object



Today's Tasks

View, Today's Tasks

Purpose
Use Today's Tasks to display the tasks that are currently due in the Outline View.

Steps

1 Choose Today's Tasks from the View menu.

See Also
Today's Schedule



 Hint
You can drag an object from the Outline View to the Calendar tab to create an event related 
to that object.    You can specify the date, time, alarm options, and connection description.    
The event is displayed under the object in the Outline View as well as the Calendar View.

For example, suppose Marc Sabatini is an object listed in the Outline View.    You wish to 
schedule a meeting and include Marc as a participant.    Drag Marc to the Calendar tab.    
Select Meeting from the list box, then choose OK.    Type a description for the meeting and 
any other information you wish, then choose OK.    Select the Participant description, choose 
OK, type connection information, then choose OK.



 Hint
You can specify a date in any date field that is a certain number of days before or after the 
current date by using the following abbreviations:

d a days ago
d days in the future

m a months ago
mmonths in the future
y a years ago

y years in the future
yes yesterday's date

t today
totomorrow

For example, if you type 65 d a in a date field, InfoCentral inserts a date 65 days before the 
current date.    5 m would display a date five months from the current date. -2 d would 
display the day two days ago.    You must type lowercase letters.



Autodialing a Normal Phone Line

Purpose
If you simply wish to dial out on a normal phone line, make the following settings in 
Telephone Preferences.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or

Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Make sure the Country and Area/City Code text boxes are correct for your dialing area.
or
If you are taking InfoCentral on a notebook computer on a trip to another area code, 
change the Area/City code when you get there.

3 Choose OK.

See Also
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance with a Calling Card
Autodialing Long Distance from Office with Card
Autodialing Long Distance with Access Code
Autodialing In-Area Toll Calls



Autodialing Internal Office Extensions and Outside Lines

Purpose
If you are at work and use a PBX or Centrix type phone system that allows you to dial 
internal numbers by extension, but requires a numeric sequence to get an outside line, 
make the following settings in Telephone Preferences.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or

Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Make sure the Country and Area/City Code text boxes are correct.

3 Select the Enabled check box in the To Access an Outside Line group box.

4 Type the numeric sequence required to get the outside line in the First Dial text box.

Many PBX systems require you to dial a 9 to get the outside line.    For example, type 9, 
(the number 9 plus a comma) in the First Dial text box. Commas are interpreted as 
pauses, which often makes the interface between modem and PBX work better.

5 Type the prefix number in the Internal PBX Prefix of text box and the number of digits 
you wish dialled in the Dial Last Digit text box.

For example, suppose all phone numbers in your PBX are identified by a prefix (for 
example, "222"), but to other employees your extension is 25000.    Type 222 in the 
Internal PBX Prefix of text box and 5 in the Dial Last Digit text box.    When you dial other
employees, the 22 will not be used.    When you dial any other number in your iBase that
does not begin with 222, the First Dial sequence (9) will be attached before the phone 
number, even if it is long distance.

See Also
Autodialing Normal Phone Line
Autodialing Long Distance with a Calling Card
Autodialing Long Distance from Office with Card
Autodialing Long Distance with Access Code
Autodialing In-Area Toll Calls



 Hint
You do not have to type the entire beginning or ending time.    For example, type 10a for 
10:00 am or 7p for 7:00 pm.



connection information
The information stored on a connection, such as an employee's starting date at a company.



 Hint
If you live in an area that does not have daylight saving time, you can specify the same date
in Start and Stop Date text boxes.    If you type a space, the daylight saving time for your 
area will be used.



 Hint
If you wish to assign the Hot Key to another function key, you must type the name of the key
enclosed in braces, for example {F12}.    If you wish to assign the Hot Key to a nonfunction 
key, you can press that key.    Use the plus sign to use the Shift or Control keys.    For 
example, {Ctrl+F12} or {Shift+F12}.    Shift will only work with valid ASCII characters such 
as * or #.



Outline View
The main InfoCentral screen in which you add, connect, list, and work with objects.    When 
you click a new tab, a new Outline View displays.    Compare with Calendar View. 



Example
Suppose you've defined a person's connection to an organisation as "Employee" who will 
start at the organisation sometime in the future.    Because the person is not an employee of 
the company yet, InfoCentral adds "Future" to this particular connection description ("Future 
Employee").



Example
Suppose the connection between Marc Sabatini and Atlantic Metals is "Employee."    In the 
Connection Information dialog box, 1/1/91 is Marc's starting date, and 6/26/94 is his ending 
(or termination) date.    Today's date is 7/9/94.    When you expand Marc's connections in the 
Outline View, the connection description with Atlantic Metals is "Former Employee" because 
Marc has since left the company.

Now suppose you wish to know what Marc's connection to Atlantic Metals was on 6/1/94, 
about five weeks ago.    Simply collapse Marc's connections, change the Viewing Date to 
6/1/94, then re-expand.    Note that on this date the connection was "Employee."



Autodialing Long Distance with Access Code or Account Number

Purpose
If you are at work and use a PBX or Centrix type phone system that allows you to dial 
internal numbers by extension, but long distance numbers require an access code or 
accounting number, make the following settings in Telephone Preferences.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or
Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Make sure the Country and Area/City Code text boxes are correct.

3 Select the Enabled check box in the To Access an Outside Line group box.

4 Type the numeric sequence required to get the outside line in the First Dial text box.

Many PBX systems require you to dial a 9 to get the outside line.    For example, type 9, 
(the number 9 plus a comma) in the First Dial text box. Commas are interpreted as 
pauses, which often makes the interface between modem and PBX work better.

5 Type the prefix number in the Internal PBX Prefix of text box and the number of digits 
you wish dialled in the Dial Last Digit text box.

For example, suppose all phone numbers in your PBX are identified by a prefix (for 
example, "222"), but to other employees your extension is 25000.    Type 222 in the 
Internal PBX Prefix of text box and 5 in the Dial Last Digit text box.    When you dial other
employees, the 22 will not be used.    When you dial any other number in your iBase that
does not begin with 222, the First Dial sequence (9) will be attached before the phone 
number, even if it is long distance.

6 Type the accounting number into the Account # text box.

7 To make use of a long distance access code, select the Enabled check box in the For 
Long Distance or Calling Card Calls group box.

8 Type your access number in the Access number field, but do not include the 1 or an area
code.    The Country Code and Area codes are dialled automatically.

9 Choose OK.

See Also
Autodialing Normal Phone Lines
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance with a Calling Card
Autodialing Long Distance from Office with Card
Autodialing In-Area Toll Calls





one-way connection
A connection that can be described in only one way.    For example, a person's connection to 
a company is described as "Employee."    One-way descriptions are used for all 
person/organisation, person/thing, and person/event connections.



Reschedule an Event

Purpose
You can easily reschedule an event, such as a meeting, appointment, or telephone call.    
For example, suppose that Marc Sabatini calls and says he cannot make it for lunch today,
but he will be available on Friday at 1:00.    Using the steps below, you can reschedule the 
date and time for such an event.

Steps

1 Right-click the event in the Outline View, then choose Information.
or
Right-click the event in the Calendar View.

2 Specify a new date and time in the Date and Time fields, then choose OK.

If you are in the Calendar Day View, you can also drag the event and drop it on a 
different day of the month.

See Also
Add a New Event
Follow-Up on Tasks



Example
Type C:\*.*, then choose Find All to list all file and directory objects on that drive.



 Hint
You can abbreviate the objects you wish to find.

Type joh sm to find John Smith.
Type info to find InfoCentral. 
Type 1/1/95 to list the Today's Schedule for New Year's day 1995.



Example
If you type John in text box 1, select And, then type Mary in text box 2, InfoCentral searches 
for files that contain the words "John" and "Mary." If you select Or with the same text, files 
are found that contain "John" or "Mary."



field
A place in a dialog box where you can add information such as names, addresses, telephone 
numbers, and so on.    You can customise fields in the Object Information or Connection 
Information dialog boxes.



 Hint
Try starting LazyKeys and moving it to an unused corner of the screen.    When you need to 
insert special characters, it will be right at your fingertips.



 Hint
The first record is the template that all records follow during the import.    If you click  
and find that other records require a change, then make the change and that record 
becomes the template.    Only one template is used to import all records.



Examples
Suppose you are setting up a meeting in which you wish several people to participate.    Click
Participants  on the Meeting Object Information dialog box, then add the people you wish 
to invite to the meeting using the In Connection With dialog box. 

Suppose you wish to delegate a task to someone.    Click Delegated To  on the Task Object
Information dialog box, then use In Connection With to find the person you wish to do the 
task.



pop-up definition
A graphic or dot-underlined, coloured word that you can click to display a definition or 
explanation.



Contents button
A Help button you can use to return to the main Contents screen which helps you quickly 
navigate through specific areas of Help.



Search button
A Help button you can use to search for Help topics by typing keywords.



Back button
A Help button you can use to return to the last topic you opened.



History button
A Help button you can use to display the last 40 Help topics you opened, with the most 
recent at the top of the list.    To reopen a topic, double-click it.



Print button
A Help button you can use to print the current Help topic.



 Hint
You can reduce the size of the Help window and move it to keep it on-screen while you follow
the steps.

Choose Always on Top from the Help menu to display the Help window "on top" of other 
applications, even when it is minimized.    Or, size both the Help and the application windows
so they do not overlap.



Close button
A Help button you can use to close the Help window.



 route
The path that indicates where a feature is found.    The hand icon points to the steps you 
take to access the feature.



jump term
A graphic or underlined, coloured word or phrase you can choose to go to a related Help 
topic.



dialog box
Dialog boxes let you communicate with an application.    They display warnings and 
messages, and they let you select and implement options by choosing appropriate 
command buttons.    Dialog boxes have a title bar and a control menu, but they do not have 
a menu bar.    You can drag the title bar of the dialog box different locations on the screen.    
Most dialog boxes must be closed before you can work in the Outline View or Calendar View.

When a dialog box option is unavailable and cannot be used, it will appear dim.    If 
subsequent actions make the item available, it will change to a normal appearance.



Select Object

Purpose
Use the mouse or arrow keys to select (highlight) objects.    You can then expand an 
object's connections, or get object or connection information.

Steps

1 Move the mouse pointer on an object, then click once to select it.
or
Use the up or down arrow keys to select the object you wish in the list.

2 Double-click to expand an object's connections.
or
Press Enter.

See Also
Edit Connection Description
Edit Object or Connection Information
Go To
Move Object To
Watch quick tour of Organizing Objects



Write Contextual Hint

Object Information or Connection Information, Right-Click Field, Field Properties, OK, 
Contextual Hint

Purpose
Use Contextual Hint to write a brief helpful statement.    Field contextual hints appear at 
the bottom of the Object Information dialog box when the insertion point is in a field.    
Menu item contextual hints appear as prompts at the top of the screen when a menu item 
is highlighted. Example

Steps

1 Right-click an object, then choose Information.

2 Right-click a field, choose Field Properties, then choose OK.

3 Type a brief message in the Contextual Hint text box, then choose OK.

See Also
Write Contextual Help
Customizing Fields: The Big Picture



Write Contextual Help

Object Information or Connection Information, Right-Click Field, Field Properties, OK, 
Contextual Help

Purpose
Use Contextual Help to write explanatory text or examples about a field.    Later, when 
filling in this field, you can press Shift+F1 to display the information.

Steps

1 Right-click an object, then choose Information.

2 Right-click a field, choose Field Properties, then choose OK.

3 Type explanatory text in the Contextual Help text box, pressing Enter to start new 
paragraphs.

4 Choose OK.

Note that the text you type automatically wraps in the text box so that it can be resized 
later as needed.

See Also
Write Contextual Hint
Customizing Fields: The Big Picture



File Menu

Purpose
Use the options on the File menu to open, save, import, export, clean up and optimize 
your iBase, manage files, and print.

Choose from the following options for more information.
Name New iBase
Open iBase
Save
Save As
File Properties
Passwords
iBase Information
Housekeeping
Remote
Import
Export
Print
Exit

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menus: The Big Picture
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Load Menu System
Printing iBase Information: The Big Picture
Setting Preferences: The Big Picture
Using Remote iBases: The Big Picture
Working with File Objects: The Big Picture



two-way connection
A connection that can be described in two ways.    For example, Father/Son, Husband/Wife, 
Accounting Firm/Client, Division/Headquarters.    Two-way connection descriptions occur 
between person/person, organisation/organisation, thing/thing, organisation/thing, 
organisation/event, and event/event connections.



Edit Menu

Purpose
Use the options on the Edit menu to undo previous actions, cut, copy, paste, use OLE 
functions, edit object information, edit categories and connections, and go to specific 
objects in your iBase.

Choose from the following options for more information.
Undo
Cut
Copy
Paste
Paste Special
Preferences
Information
Categories
Connections
Go To

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menu: The Big Picture
Editing Information: The Big Picture
Load Menu System

 



Object Menu

Purpose
Use the options on the Object menu to add, delete, and connect objects, edit object 
information, and attach related files and memos to objects.

Choose from the following options for more information.
Add
Information
Delete
Connect
Connect Multiple
Create Related File
Attach Memo
Trash Can

See Also
Adding Objects: The Big Picture
Adding and Managing Tasks: The Big Picture
Connecting Objects: The Big Picture
Creating Related Files: The Big Picture
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menu: The Big Picture
Load Menu System
Watch quick tour of Adding and Connecting



Find Menu

Purpose
Use the options on the Find menu to find objects in your iBase, or find files on your hard 
drive or network.

Choose from the following options for more information.
FastFind
FastFind Files
Find-By-Example
Find-By-Connection
Search External Files

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Finding Objects: The Big Picture
Load Menu System
Watch quick tour of Finding Objects



View Menu

Purpose
Use the options on the View menu to view your iBase in different ways.

Choose from the following options for more information.
All Categories
All Drives
Display
View Calendar
Tab Index
Tab Properties
Today's Schedule
Toggle View
Previous Tab

See Also
Customise Menu Bar
Customise Menu Hot Key
Customise Menu
Customizing My Menus: The Big Picture
Load Menu System
Watch quick tour of Organizing Objects
Watch quick tour of Using Calendar
Working with File Objects: The Big Picture



List Menu

Purpose
Use the options on the List menu to modify a list of objects.

Choose from the following options for more information.
Hoist
Expand
Collapse
Expand by Type
Collapse All
Clear Line
Clear to End
Clear View
Flatten Outline
Promote to Left
Sort Alphabetically
Move Item To

See Also
Customise Menu Bar
Customise Menu Hot Key
Customise Menu
Customizing My Menus: The Big Picture
Load Menu System
Modifying Lists of Objects: The Big Picture
Organizing with Tabs: The Big Picture
Watch quick tour of Organizing Objects



Tools Menu

Purpose
Use the options on the Tools menu to dial a phone number, take notes, calculate, get an 
alphabetical or address book index, lookup area codes, states and countries, and use the 
timer.

Choose from the following options for more information.
Telephone
LazyKeys
Send
Alphabetic Index
Address Book
Lookup Area Codes
Lookup States
Lookup Countries
Elapsed Timer

See Also
Customise Menu Bar
Customise Menu Hot Key
Customise Menu
Customizing My Menus: The Big Picture
Load Menu System
Communicating with InfoCentral: The Big Picture



Calendar View Menu Commands

Purpose
The Calendar View menu bar includes several InfoCentral menu bar items.

Choose from the following options for more information.
File
Edit
View
Object
Tools
Help

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menus: The Big Picture
Load Menu System
Using Calendar: The Big Picture
Watch quick tour of Using Calendar



Menu Commands

Purpose
InfoCentral has two kinds of menus:    an Outline View menu and a Calendar View menu.

Choose from the following options for more information.
Outline View Menu Commands
Calendar View Menu Commands

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System



menu item
An item that appears after you have opened a menu from the menu bar.    For example, Save
As is a menu item on the File menu.    You can customise both menu and menu bar items 
using the Customise Menu and Customise Menu Bar features.



Abandon Remote iBase

File, Remote, Abandon Remote

Purpose
When you check out a remote iBase, the remote and host iBases are each given a special 
label that is used to remind you that an iBase has been checked out.    Use Abandon 
Remote to remove these labels.    You can abandon an iBase from either the remote edition
or the host edition.

Steps

1 Choose Remote from the File menu, then choose Abandon Remote.

2 Choose Abandon.

See Also
Check In Remote iBase
Check Out Remote iBase
Reconcile Differences
Using Remote iBases: The Big Picture



Assign Accelerator Key

Menu Item, Customise Menu Hot Key (F12), Properties of this Menu Selection, List

Purpose
Use Accelerator Key Assignments to select the accelerator key you wish to assign to the 
menu item you are customizing.    You can assign 2 accelerator keys to a menu item.

Steps

1 Highlight a menu or menu bar item.

2 Press the Customise Menu Hot Key (F12).

3 Choose Properties of this Menu Selection, then choose the List button for Accelerator 
Key or Additional Key.

4 Use the scroll bar to move through the list until you find the keystroke you wish.

The list shows you which keys have already been assigned.    You cannot assign the 
same accelerator key to two different menu items.

5 Select the keystroke you wish, then choose OK.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Customizing My Menus: The Big Picture
Load Menu System



Add New Object

Add

Purpose
Use Add New Object to categorize an object, then name it. 

Steps

1 Click Add  on the Toolbar.

2 Select a category from the list box, then choose OK.
or
Type a new category in the Select Category of New Object text box, then choose New 
Category.
or
Select a category, then choose Setup Category to edit the category.

3 Type a name for the object, then choose OK.

For last names with more than one name, such as Roberto De La Madrid, use quotes.    
For example, type Roberto "De La Madrid" in the Name text box.

4 Type information about the object, such as an address, phone number, birthday, then 
choose OK.

5 If you wish to connect the new object to another object, choose Yes, then double-click 

the  icon on another object, specify a connection description, then choose OK.
or
Choose No to not connect the new object at this time.

See Also
Add New Object (Name then Categorize)
Add Preferences
Adding Objects: The Big Picture
Create or Edit Category
Create or Edit Connection Description
Edit Object or Connection Information
Watch quick tour of Adding and Connecting



Add New Object (Name then Categorize)

Add

Purpose
Use Add New Object to name an object, then categorize it. 

Steps

1 Click Add  on the Toolbar.

2 Type the name of the object in the New Object Name text box.

3 Choose Person, Organisation, Place/Thing, or Event.

4 If the category you wish (for a non-person object) doesn't exist in the list box, type the 
new category, then choose New Category.
or
Select a category, then choose Setup Category to edit it.
or
Choose OK to use the category.

See Also
Add New Object (Categorize then Name)
Add Preferences
Adding Objects: The Big Picture
Create or Edit Category
Create or Edit Connection Description
Edit Object or Connection Information
Select Type of Organisation, Place/Thing, Event
Watch quick tour of Adding and Connecting



menu bar
The area at the top of a window containing headings for pull-down menu operations.    For 
example, File is a menu bar item.    It contains menu items such as Save As and 
Housekeeping.    You can customise menu and menu bar items using the Customise Menu 
and Customise Menu Bar features.



Name of New Object

Add, OK

Purpose
Use Add a New Object to name the object you are adding.

Steps

1 Click Add  on the Toolbar.

2 Choose a category, then choose OK.
or
Type a new category and choose New Category.
or
Choose a category, then choose Setup Category.

3 Type the object's name, then choose OK.

See Also
Add New Object
Add Preferences
Adding Objects: The Big Picture
Create or Edit Category
Create or Edit Connection Description
Edit Object or Connection Information
Watch quick tour of Adding and Connecting
Watch quick tour of InfoCentral Basics



Add Preferences

Add, Preferences

Purpose
Use Add Preferences to check for identical objects in categories, capitalize initial letters, 
make predictions about gender and names of new people, assign default titles for new 
people, and choose whether you first categorize or name a new object.

Steps

1 Click Add  on the Toolbar, then choose Preferences.

2 Select or deselect the following options:

          Check for Duplicates
Displays a Duplicate Record message if duplicate information is detected while you're 
adding an object.

          Capitalize First Letters
Capitalizes the first letter of each word in an object's name when you add an object.

          Predict Gender
Predicts whether a person object is male or female, and makes the appropriate selection
in the Gender field.

          Predict Formal Name
Suggests an equivalent formal name (for names such as Bob, Mike, and Joe) and inserts 
it in the First Name field.

          Predict Informal Name
Suggests a common nickname for names such as Robert, Michael, and Joseph and 
inserts it in the Dear field.

          Generate Default Titles
Predicts the appropriate title (such as Mr. or Ms.) for person type objects.    You can 
change the default titles.

          Select Category, then Enter Info
Lets you select a category for an object, then name it.

          Enter Info, then Select Category
Lets you name an object, then select a category for it.

See Also
Add New Object
Add New Object (Name then Categorize)
Adding Objects: The Big Picture



Create or Edit Category
Create or Edit Connection Description
Connection Preferences
Import Preferences



Scheduling Events: The Big Picture

Purpose
You can add several kinds of event objects to your calendar, including appointments, 
meetings, telephone calls, or a new event type that you create.

Choose from the following options for more information.

          Add an Appointment, Meeting, or Phone Call
How to add a pre-categorized event object, or create and add your own kind of event.

          Include Participants
How to connect participants to the meetings and other events you set up.

          Connect Event to Location
How to connect a event to a location or place object in your iBase, such as a room or 
building.

          Set an Alarm
How to set alarms to remind you of the events you schedule.

          Delete Event Object
How to delete event objects from the Calendar View.

          Undelete Event Object
How to restore a deleted scheduled object and other objects.

          List Today's Schedule
How to list your day's schedule in the Outline View.

See Also
Watch quick tour of Using Calendar



Adding Objects: The Big Picture

Purpose
You can add nearly any kind of object to an iBase, including persons, places, things, 
organisations, events, and tasks.

The following tasks illustrate the process of adding an object.

Add New Object

Create or Edit Category

Edit Object Information

Connect Object with Another

Edit Connection Information

See Also
Watch quick tour on Adding and Connecting
Watch quick tour on InfoCentral Basics



Address Book

Tools, Address Book

Purpose
Use Address Book to look up addresses and phone numbers of people or organisations.    
You can then add such objects one at a time to the object list.

Steps

1 Choose Address Book from the Tools menu.

2 Select People to list addresses and phone numbers of people.
or
Select Organisation to list the numbers of companies and organisations.

3 Type the name of the person or organisation you wish to look up in the Last Name, First 
text box.
or
Choose one of the vertical alphabetic letters to go directly to the entries beginning with 
that letter.

4 Choose Add to View to add the selected object to the Outline View.

5 Select Show Connected Addresses and Phone Numbers to display the addresses and 
phone numbers of objects connected to the objects you list.

6 Choose from the following options:
Telephone
Object Info

See Also
Alphabetic Index
FastFind
Find-By-Connection
Find-By-Example
Print Address Book
Watch quick tour of Finding Objects



Calendar View
The view on a tab which displays the Calendar.    Only one tab in each iBase may be set to 
display a calendar view.    Compare with Outline View. 



LazyKeys

Tools, LazyKeys

Purpose
Use LazyKeys to insert special characters into    fields.    You can run LazyKeys from 
InfoCentral or from Windows Program Manager. 

Steps

1 Choose LazyKeys from the Tools menu.

2 Choose from the following options, then press Alt+F4 to close LazyKeys.

          Size
Increase or decrease the size of the LazyKeys dialog box.

          Title
Turn the title bar on or off.

          Style
Choose from several character styles.

          Reg
Display the US character set.

          Ext
Display the extended character set.

          Cap
Toggle between uppercase and lowercase character set.

          BS
Backspace.

          CR
Perform a carriage return.

          Tb
Insert a tab.

          Sh
Shift between lowercase and uppercase characters.



Print Address Book (Options)

File, Print, Address Book, Options

Purpose
Use Print Address Book Options to customise the appearance of the printed Address Book.

Steps

1 Choose Print from the File menu, then choose Address Book.

2 Choose Options.

3 Choose from the following options:

          Large
Print on large page.

          Medium
Print on medium page.

          Small
Print on small page.

          Cover Page
Print a cover page for the address book. 

          Page Header
Print headers at the top of each page.

          Addresses
Include addresses of people and organisations.

          Odd Pages Only
Print odd pages only for double-sided printing.

          Even Pages Only
Print even pages only for double-sided printing.

          Both Odd & Even
Print all pages.

          Print Each Category on Separate Page
Print a new page for each category.

          Do not Split Objects Across Pages
Keep objects and their addresses together on one page.



          Print only Those With Phone Numbers
Omit people and organisations that dont have phone numbers.

          Alternate Left/Right Margins
Leave space for hole punching on double-sided pages.

See Also
Print Address Book
Print Margins (Options)
Setup Printer
Restore Default Print Options



Alarm Notification Preferences

File, Preferences, Alarm

Purpose
Use Alarm Notification Preferences to choose the sound you will hear when you are 
notified by an alarm.    You can also set how long the alarm will play and how many 
minutes between renotification.

Steps

1 Choose Preferences from the Edit menu, then choose Alarms.

2 Select a tune from the Tune list box.

3 Choose Play Tune to hear the tune you select.

4 Select the duration you wish the alarm to play.

5 Specify the number of minutes you wish between notification in the Default "Remind 
Again" Time text box, then choose OK.

See Also
Create or Edit Check Box Field



Calendar File Menu

Purpose
Use the options on the Calendar File menu to save your iBase, view iBase information, and
exit InfoCentral.

Choose from the following options for more information.
Save
iBase Information
Exit

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System



 Hint
If you have WordPerfect 6.0 for Windows or Ami Pro 2.0 for Windows, you can use the 
following keystrokes in the Keystrokes to Send to the Application text box.    Note that the 
keystrokes are different if you are using a prototype file.

WordPerfect 6.0 for Windows
{Pause:.5}{Alt+F}N{Ctrl+V}{PgUp}{Alt+F}A{Enter}
{Pause:.1}@@FullFileName@@{Enter}{Ctrl+V}

WordPerfect 6.0 for Windows (with prototype file)
{Pause:.5}{Alt+F}O@@FullFileName@@{Enter}
{Pause:.1}{Page Down}{Ctrl+V}{PgUp}

Ami Pro 2.0 for Windows
{Alt+F}N{Enter}{Ctrl+V}{Ctrl+Home}{Alt+F}
A@@FullFileName@@{Enter}

Ami Pro 2.0 for Windows (with prototype file)
{Alt+F}O@@FullFileName@@{Enter}{Ctrl+End}
{Ctrl+V}{Ctrl+Home}



All Categories

View, All Categories

Purpose
Use All Categories to list all categories available for objects in your iBase.    The list of 
categories appears at the bottom of your list if objects are already displayed.

Steps

1 Choose All Categories from the View menu.

2 Click  to display objects for a specific category.

See Also
All Drives
FastFind
Find-By-Connection
Find-By-Example
Finding Objects: The Big Picture
Watch quick tour of Finding Objects
Watch quick tour of Organizing Objects



All Drives

View, All Drives

Purpose
Use All Drives to list the drives available on your computer, and work with them in much 
the same way you work with any other objects.

Steps

1 Choose All Drives from the View menu.

2 Click  to view the subdirectories on a drive.

3 Click  until the subheading Files appears.

4 Highlight a file, click , then choose OK.
or
Type wildcard characters to view the specific files you wish.

See Also
All Categories
FastFind
Find-By-Connection
Find-By-Example
Finding Objects: The Big Picture
Watch quick tour of Finding Objects
Watch quick tour of Organizing Objects



Create or Edit Alpha/Numeric Field

Object Information, Setup Field, Add New Field, Alpha/Numeric, OK

Object Information, Alpha or Numeric Field, Setup Field, Field Properties, 
Alpha/Numeric, OK

Purpose
Use Alpha/Numeric Field Setup to create or edit the fields in the Object or Connection 
Information dialog box that use numbers and letters.    Alpha/Numeric fields are ideal for 
displaying titles, names, address information, numbers, or other text.    Note the wide 
range of options (listed below) that you can use to change the way text looks or behaves 
when in an Alpha/Numeric field.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add an Alpha/Numeric field, 
then choose Add New Field.

3 Choose Alpha/Numeric, type a name for the field, then choose OK.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Case
Field Entry Options
Field Initial Value Calculation
Field Template Format
Field Valid Range



Alphabetic Index

Tools, Alphabetic Index

Purpose
Use Alphabetic Index to select a category and list the objects in that category.    After the 
objects are listed, you can add objects one at a time to the Outline View.

Steps

1 Choose Alphabetic Index from the Tools menu.

2 Select the category whose objects you wish to list.

3 Select the letter from the vertical list of alphabet letters.
or
Type the object's name (last name first) in the Item text box.

4 Select the desired object from the Item list box, then choose Add to View.

5 Select Close when you are finished adding objects.
or
Choose one of the following options for more information:
Create or Edit Category
Edit Object Information

See Also
Address Book
FastFind
Find-By-Connection
Find-By-Example
Finding Objects: The Big Picture
Watch quick tour of Finding Objects



Autodialing Long Distance with a Calling Card

Purpose
If you wish to always use a calling card to dial long distance numbers, make the following 
settings in Telephone Preferences.

            Note that InfoCentral currently only supports calling cards that call an Access 
number.    For those that begin with 0 and drop the Country Code, InfoCentral does not 
automatically do that for you.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or
Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Make sure the Country and Area/City Code text boxes are correct for your dialing area.
or
If you are taking InfoCentral on a notebook computer on a trip to another area code, 
change the Area/City code when you get there.

3 Skip the text boxes in the To Access an Outside Line area unless they also apply.

4 Select the Enabled check box in the For Long Distance or Calling Card Calls area.

5 Type your calling card's access number or the 800 number you use with your credit card
in the Access number field, then choose OK.

If the card number is always entered after the phone number is dialled, then type it in 
the Card # text box.    If the card number is typed before the phone number is dialled, 
then include it as part of the Access #.    When dialing long distance numbers, 
InfoCentral dials the Access number first, the phone number, and then the Card number.

See Also
Autodialing Normal Phone Lines
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance from Office with Card
Autodialing Long Distance with Access Code
Autodialing In-Area Toll Calls



iBases versus Databases

If you are familiar with database applications, you will find that WordPerfect InfoCentral 
follows a different paradigm, or model, for storing and retrieving information.    In a 
traditional database, the data is subordinate to the design, and you must view the data from
the perspective set up by that design.    In InfoCentral, the design is subordinate to the data, 
and you view the data from its own perspective.    In other words, the data's relationship to 
other objects determines the view.

A database must be designed before data can be entered.    Database design requires 
anticipating all the information the user might need and allocating fields in a record form for 
all of that information.    A decision to track additional information after a database has been 
in use can require redesigning the database.

InfoCentral, on the other hand, uses an object-oriented paradigm. There are no "records" in 
the sense of a traditional database.    Data are entered as objects and then connected to 
each other.    Objects can be connected to an almost unlimited number of other objects with 
an almost unlimited number of connection descriptions.

The "design" of the iBase is completely dependent on the objects you add and the 
connections you describe.

Database applications let you generate reports to look at the data in different ways.    With 
InfoCentral, however, you simply use the options on the Find menu to get the view of data 
that you wish, and then print it.

See Also
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Using Content iBases
Using InfoPad
Using Tabs to Organise: The Big Picture
Using Template iBases
Watch quick tour of InfoCentral Basics
Watch quick tour of Finding Objects
Watch quick tour of Using Content iBases
 Using InfoCentral: Getting Started

 



Attach Memo

Right-Click Object, Attach Memo

Purpose
Use Attach Memo to attach notes to objects and edit notes.    When an object has a memo 
attached to it, a memo icon  appears next to it.    You can attach memos to filename, 
drivename, and directory objects as well.

Memos are handy if, for example, you need to remind yourself of the contents of a 
particular file, or what to talk about when you call a person.

Steps

1 Right-click an object, then choose Attach Memo.

2 Type the memo, then choose OK.

See Also
Creating Related Files: The Big Picture
Watch quick tour of Creating Related Files



 Hint
If the description you wish does not appear in the list, select {New Description}, then 
choose OK, type the new description, then choose OK again.



Create or Edit Calculation Field

Object Information, Setup Field, Add New Field, Calculation, OK

Object Information, Calculation Field, Setup Field, Field Properties, Calculation, OK

Purpose
Use a Calculation field to create a formula that is then calculated in a field.    The formula 
that you create can include field names (for example, Billing_Time) and system variables 
(for example, Sys_Date4$) and cannot exceed 128 characters.    Example

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a calculation field, then 
choose Add New Field.

3 Choose Calculation, type a name for the field, then choose OK.

4 Type the formula you wish calculated in the field when you add an object with this field.
or
If you wish the calculated results carried forward the next time you add an object with 
this field, Select Calculate Once When Object is Added, Then Carry Forward Fixed Value.

5 Choose OK.

See Also
System Date and Time Variables



Calendar Cut, Copy, Paste

Calendar Notes, Edit, Cut, Copy, or Paste

Purpose
Use Cut with Paste to move selected text or object, or use Copy with Paste to copy the 
selected object.    You can cut and paste text in fields.    You can cut and paste objects in 
the Outline View.

Steps
To cut or copy text or an object,
1 Select the text you wish to cut or copy.

2 Choose Cut or Copy from the Edit menu.

To paste text,
1 Position the cursor in the text or list of objects where you wish to insert the text or 

object.
or
Choose Notepad from the Tools menu, then position the cursor in the Notepad where 
you wish to insert the text.

2 Choose Paste from the Edit menu.

See Also
Move Object To
Watch quick tour of Using Calendar



Calendar Date Differences

Calendar, Tools, Date Differences

Purpose
Use Date Differences to quickly calculate the number of days between two dates.    This is 
useful for calculating the amount of time between current and future events and 
appointments.

Steps

1 In the Calendar View, choose Date Differences from the Tools menu.

2 Type the Beginning Date and the Ending Date, then press the Tab key.
or
Enter a Beginning Date or an Ending Date, type a number in the Days Difference text 
box, then press the Tab key. Example

See Also
Change Current Viewing Date
Watch quick tour of Using Calendar



Create Import File

Purpose
Before you import a file, you need to create it.    InfoCentral accepts comma and tab 
delimited ASCII import files only.    

Steps

1 Create an import file using a text editor, such as Windows Notepad.
or
Generate an import file from your database. Example

See Also
Begin Import
Check Import Summary
Check Import Completion
Create or Select Import Scenario
Import Categories
Importing Data into iBase: The Big Picture
Select Import File



Calendar Go To Features

Edit, Go To

Purpose
Use the Calendar Go To features to move to specific dates in the Calendar View.

Steps

1 Choose Go To from the Edit menu.

2 Choose from the following options:

          Today
Go to the current day.

          Date
Go to a specific day.

          Next
Go to the next day, week, month, year, calendar item or page.

          Previous
Go to the previous day, week, month, year, calendar item or page.

          Scroll
Scroll the schedule up or down.

          First Time
Go to the first time in the schedule.

          Last Time
Go to the last time in the schedule.

See Also
Calendar Go To Today
Go To
Go To Date
Watch quick tour of Using Calendar



Calendar Go To Today

Edit, Go To, Today

Purpose
Use Go To Today to quickly return to the current day in the Calendar View.

Steps

1 Click Today  on the Toolbar.

See Also
Calendar Go To Features
Go To Date
Watch quick tour of Using Calendar



Calendar Notes for Day

View, Notes for Day

Purpose
Use Notes for the Day to move the insertion point to the Notepad while you are in the 
Calendar Day View or Week View.

Steps

1 Choose Notes for the Day from the View menu.
or
Select Notes on the Scheduler.

See Also
Watch quick tour of Using Calendar



Calendar Preferences

Calendar, File, Preferences, Calendar

Purpose
Use Calendar Preferences to change the time range and interval for the Calendar Day and 
Week Views, and for Today's Schedule when you display it in Outline View.

Steps

1 Choose Preferences from the Edit menu, then choose Calendar.

2 Specify a Beginning Time, Ending Time, and an Interval of 15, 30, or 60 minutes. 

3 Choose OK.

See Also
Calendar Date Differences
Calendar Views
Elapsed Timer
Today's Schedule



Connect Objects to Objects on Other Tabs

Purpose
You can connect an object on one tab with an object on another tab.    For example, 
suppose that Marc Sabatini was listed on your InfoPad.    You can connect him with the 
Atlantic Metals company on the Calls to Make tab.

Steps

1 Select an object, then click Connect  on the Toolbar.

Note that the mouse pointer appears with the Connect icon .

2 Click another tab, find the object you wish to connect to, then double-click the object.

See Also
FastFind



Previous Calendar View

Calendar, View, Previous View

Purpose
Use Previous View to see the last Calendar View that you had displayed.

Steps

1 Choose Previous View from the View menu.

See Also
Calendar Views
Previous Tab
Today's Schedule



Select Import File

File, Import, Data, Type Scenario Name, New Scenario, Add

Purpose
Use Import: Input File to select the file that contains the data you wish to import into an 
InfoCentral iBase.

Steps

1 Choose Import from the File menu, then choose Data.

2 Type a scenario name, choose New Scenario, then choose Add.

3 Select the drive, pathname, and directory that contains the import file you wish to use.

You can click the List Files of Type drop-down list to quickly list all files in the current 
directory that are comma-separated ASCII (.CSV) or tab-separated ASCII (.TAB) files.

See Also
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select First Import Receiving Category
Select Second Import Receiving Category



ASCII
American Standard Code for Information Interchange.    One of the standard formats for 
representing characters on a computer.



Calendar Tool

Calendar View, Add, Event, OK, Calendar Tool

Object Information, Calendar Tool

Connection Information, Calendar Tool

Purpose
Use Calendar Tool to specify the date you wish to insert into the date field in the Object 
Information dialog box.

Steps

1 From the Object Information or Connection Information dialog box, click .

2 Click the date you wish to insert into the date field, then choose OK.
or
Choose from the following options:

          Today
Enter the current date.

          << >> 
Move to a different month, then click a date.

          Go To
Type the date you wish to go to.

See Also
Change Current Viewing Date
LazyKeys
Using Calendar: The Big Picture



Example
If you enter 1/5/94 as a Beginning Date and 500 in the Days Difference text box, then press 
the Tab key, 05/20/95 appears in the Ending Date text box.



Calendar Views

Calendar, View, Day, Week, or Year View

Purpose
Use the Calendar Day, Week, and Year Views to look at your schedule from different 
viewpoints. 

Steps

1 From the Calendar View, click Day  to see today's schedule.
or

Click  to see the schedule for the week.
or

Click  to see a view of the entire year.

See Also
Previous Calendar View
Today's Schedule



Using Calendar: The Big Picture

Purpose
Use the Calendar to organise your time, schedule events, your tasks, and to keep track of 
your life.

Choose from the following options for more information.

          Change Calendar View
How to switch to the three different calendar views, including Day View, Week View, and
Year View.

          Go To Today
How to display the calendar view for today if you are at a different date.

          Go To Specific Date
How to go to exactly the date you wish in the calendar.

          Add an Event Object
How to schedule an event, such as a meeting or appointment.

          Add Task Object
How to note and prioritize tasks.

          Connect Events to Participants and Locations
How to include participants in meetings, and connect events with locations.

          Delegate Tasks by Connecting
How to assign tasks to others.

          Calculate Date Differences
How to calculate the difference between two dates.

          Set Calendar Preferences
How to change the time interval that is displayed in the calendar view.

          Set Alarm Notify Preferences
How to change the type of alarm sound, duration, and repeat options.

          Print Calendar
How to print the information in your Calendar.

See Also
Watch quick tour of Using Calendar





Adding and Managing Tasks: The Big Picture

Purpose
You can prioritize the tasks you add to your calendar.    Uncompleted tasks are carried to 
the next day.

Choose from the following options for more information.

          Add Task Object
How to add a task object.

          Prioritize Tasks
How to prioritize your tasks.    You can select from the six pre-defined priority levels, or 
create more levels.

          Delegate Tasks
How to connect a task to a person.

          Delete Tasks
How to delete tasks and other objects.

          Undelete Tasks
How to select from the last several objects that have been deleted.

See Also
Watch quick tour of Using Calendar



Create or Edit Category

Add, Setup Category or New Category

Edit, Categories, Setup Category or New Category

Purpose
Use Setup Category to create, edit, or delete a category.    You can also restrict category 
access.

            You cannot change the category type for an existing category.    If you delete a
category, any objects within the category are also deleted.

Steps

1 Type the new category name in the Category Name text box.

2 Select from the following category classes, then choose OK.

          Person
People are people no matter what their relationship is to you or to other objects.    Do 
not categorize a person as a "Father" or "Brother-in-Law."    Such labeling belongs on the
connection description between people.

          Organisation
Use for a business, an institution, a religious organisation, an association, a league, a 
society, or a corporation.

          Place/Thing
Use for possessions, property, projects, locales, monuments, material, elements, 
matter, substances, cloth, dry goods, fabric, textiles, data, facts, figures, and so on.

          Event
Use for any event, usually with a beginning and ending time.    For example, 
appointments, meetings, classes, lectures, sermons, concerts, natural events (such as 
an eclipse), and so on.

          Task
Also known as a "To Do" item, use for any assignment, duty, chore, job, errand, 
commission, mission, trust, or responsibility that you need to accomplish by a certain 
date.

          Not Specified
Use this class when you cannot decide how to categorize at this time.

          Private Category
If you wish to restrict access to the category, select Private Category.    



          Display Colour
Choose a display colour from the Display Colour list box, then choose OK. 

See Also
Add New Object
Connect Object
Create or Edit Connection Description



Move Field

Object Information or Connection Information, Setup Field, Move

Purpose
Use Move Field to move a field in the Object Information dialog box.

Steps

1 Select a field in the Object Information or Connection Information dialog box.

2 Right-click the field, then choose Move.
or
Choose Setup Field, then choose Move.

3 Use the Up and Down Arrow keys to select another location for the field.

4 Press Enter.

See Also
Select Different Field



Change Current Viewing Date

Edit, Preferences, Viewing Date

Purpose
Use Change Current Viewing Date to specify the date that is used when displaying 
connection descriptions.    After changing the Viewing Date, you will need to collapse and 
re-expand the connections of an object to see the effects of the new Viewing Date. 
Example

Steps

1 Choose Preferences from the Edit menu, then choose Viewing Date.

2 Type the new date.
or
Choose Today to set Viewing Date to the current date.

3 Choose OK.



check box
A small box next to an option in a dialog box.    Clicking an empty check box selects the 
option; clicking a marked check box deselects the option.



Check In Remote iBase

File, Remote, Check In

Purpose
Use Check In to check in the remote edition of an iBase.    You can have only one remote 
copy of an iBase.

Steps

1 Choose Open from the File menu, then select the host edition of the iBase you are 
checking in.

2 Choose Remote from the File menu, then choose Check In.

3 Choose OK.

See Also
Abandon Remote iBase
Check Out Remote iBase
Reconcile Differences
Using Remote iBases: The Big Picture



Check In Remote iBase: Reconcile Differences

File, Remote, Check In

Purpose
As you check in a remote iBase to the host iBase, there may be differences in one-way or 
two-way connection descriptions or information, or differences in object information.    Use 
Difference in Objects or Connections Detected to reconcile these differences.

Steps

1 Choose Remote from the File menu, then choose Check In.

2 Specify the directory and filename of the remote iBase, then choose OK.

3 Choose from the following options:

          Cancel Check-In
Quit the check in process.

          Accept Host
Use the information as specified in the host edition.

          Accept Remote
Use the information as specified in the remote edition.

          Info
Edit the host or remote edition information for the object or connection.

See Also
Abandon Remote iBase
Check In Remote iBase
Check Out Remote iBase
Using Remote iBases: The Big Picture



Check Out Remote iBase

File, Remote, Check Out

Purpose
Use Check Out to create a remote edition of an iBase.    You can check out only one remote
edition.    When you are finished with a remote edition, you can check it back in to the host
edition and blend the changes.

Steps

1 Choose Remote from the File menu, then choose Check Out.

2 Type your name, then type the complete path and name for the remote iBase.

3 Choose OK.

See Also
Abandon Remote iBase
Check In Remote iBase
Reconcile Differences
Using Remote iBases: The Big Picture



Create or Edit Check Box Field

Object Information, Setup Field, Add New Field, Check Boxes, OK

Object Information, Check Box Field, Setup Field, Field Properties, Check Boxes, OK

Purpose
Use Check Box fields to set up selectable options in the Object or Connection Information 
dialog boxes.    For example, suppose you wish to note the favorite ice cream of all the 
people in your iBase.    You could set up a check box for each popular flavor, then select 
those flavors that apply to a given person.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Check Box field, then 
choose Add New Field.

3 Choose Check Box, type a name for the field, then choose OK.

4 Type a description in the Description text box for each Check Box.

5 If you wish a Check Box to be selected as the default, select Default for that Check Box.

6 Choose from the following options:
Write Contextual Help
Write Contextual Hint

See Also
Create or Edit Alarm Notification Check Boxes
Customizing Fields: The Big Picture



Using Remote iBases: The Big Picture

Purpose
Remote makes it possible for two people to work in the same iBase at the same time, then
blend their changes.

The following tasks illustrate the process of using a remote iBase.

Check Out Remote iBase

Check In Remote iBase

Reconcile Differences

Abandon Remote iBase



Calendar Edit Menu

Purpose
Use the options on the Calendar Edit menu to undo the most recent action; cut, copy, and 
paste text; go to specific dates; and set preferences.

Choose from the following options for more information.
Undo
Cut
Copy
Paste
Alarm Notification Preferences
Calendar Preferences
Go To

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System



Clear Line, Clear View, Clear to End

Select Object, Clr Line

Clr View

Select Object, List, Clear to End

Purpose
Use Clear Line, Clear View, and Clear to End to clear a single object and its immediate 
connections, clear all objects from the entire Outline View, or clear the currently selected 
object plus all objects below it. 

Steps
To clear a single object and its displayed connections,
1 Right-click the object, then choose Clear Line.
or

Select the object, then click Clr Line  on the Toolbar.

To clear all objects from the Outline View,
1 Click Clr View  on the Toolbar.

To clear the selected object and all objects below it in the list,
1 Choose Clear to End from the List menu.

See Also
Collapse Connections
Expand Connections
Watch quick tour of Organizing Objects



Autodialing Long Distance with Calling Card at the Office

Purpose
If you always use a calling card to dial long distance numbers from a PBX type system, 
make the following settings in Telephone Preferences.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or
Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Make sure the Country and Area/City Code text boxes are correct.
or
If you are taking InfoCentral on a notebook computer on a trip to another area code, 
change the Area/City code when you get there.

3 Skip the text boxes in the To Access an Outside Line area unless they also apply.

4 Select the Enabled check box in the To Access an Outside Line group box.

5 Type the numeric sequence required to get the outside line in the First Dial text box.

Many PBX systems require you to dial a 9 to get the outside line.    For example, type 9, 
(the number 9 plus a comma) in the First Dial text box. Commas are interpreted as 
pauses, which often makes the interface between modem and PBX work better.

6 Type the prefix number in the Internal PBX Prefix of text box and the number of digits 
you wish dialled in the Dial Last Digit text box.

For example, suppose all phone numbers in your PBX are identified by a prefix (for 
example, "222"), but to other employees your extension is 25000.    Type 222 in the 
Internal PBX Prefix of text box and 5 in the Dial Last Digit text box.    When you dial other
employees, the 22 will not be used.    When you dial any other number in your iBase that
does not begin with 222, the First Dial sequence (9) will be attached before the phone 
number, even if it is long distance.

7 Type your calling card's access number or the 800 number you use with your credit card
in the Access number field, then choose OK.

If the card number is always entered after the phone number is dialled, then type it in 
the Card # text box.    If the card number is typed before the phone number is dialled, 
then include it as part of the Access #.    As a general rule, using the calling card is 
enough for accounting and an additional accounting code is not necessary.    Telephone 
options are used in the following order when dialing a long distance number:

First Dial
Access #
Country Code
Area/City Code



The Phone Number (from Object Information)
Card #
Account #

See Also
Autodialing Normal Phone Lines
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance with a Calling Card
Autodialing Long Distance with Access Code
Autodialing In-Area Toll Calls



Outline View Buttons

          

Expand connections.    For example, click this button to display connected objects.

          

Collapse connections.    For example, click this button to remove connected objects from
the view.

          
No further connections exist.

          
Open an OLE object.    For example, a graphic that you have created in Windows 
Paintbrush.



collapse
Collapsing an object removes other objects connected to it from the displayed list.    The  
button indicates that an object can be collapsed.



Collapse Connections

List, Collapse or Collapse All

Purpose
Use Collapse to remove from the Outline View all connected objects and files displayed 
beneath an object.    Use Collapse All to collapse all subordinate objects.

Steps

1 Select the object you wish to collapse.

2 Click  next to the object.
or
Press the minus (-) key.
or
Choose Collapse or Collapse All from the List menu.

See Also
Expand Connections
Watch quick tour of Organizing Objects



Connect Multiple Objects

Select Object, Object, Connect Multiple, Double-click Other Objects

Purpose
Use Connect Multiple Objects to relate and describe the assocation between multiple 
objects.    You can connect objects located on different tabs.

Steps

1 Select an object on the Display List.

2 Choose Connect Multiple from the Object menu.

3 Double-click the object you wish to connect to the object you selected in step 1. 

4 Select the desired connection description, then choose OK.
or
If the description you wish is not displayed, choose New Description, type the new 
description, then choose OK.

You may be asked to enter starting and ending dates.    Choose OK to finish connecting 
the object.

5 Choose Yes to continue connecting objects.
or
Choose No return to the Outline View. 

See Also
Create or Edit Connection Description
Watch quick tour of Adding and Connecting



Connect Objects

Right-Click Object, Connect, Double-click Other Object

Drag and Drop Object on Another Object

Purpose
Use Connect Objects to relate and describe the association between two objects.    You can
connect objects located on different tabs.

Steps

1 Select an object on the Outline View.

2 Click Connect  on the Toolbar.

Note that when Connect mode is on, the mouse pointer has the Connect icon  next to
it.    You can click 

 again to turn it off.

3 Double-click the object you wish to connect to the object you selected in step 1. 

4 Select a connection description, then choose OK.
or
Choose New Description, type the new description, then choose OK.

5 Specify starting and ending dates (if necessary).

See Also
Add New Objects
Connect Multiple Objects
Watch quick tour of Adding and Connecting



Clipboard
An area of memory where text and graphics are stored after being cut or copied, to await 
further action.    The item remains on the Clipboard until you cut or copy another item or 
until you exit the operating system or turn off your computer.



constant
A value that does not change.



Connecting Objects: The Big Picture

Purpose
You can connect two objects, connect multiple objects, or connect objects between tabs.    
When you connect objects, you can select or create a connection description and add 
information to the connection.

Choose from the following options for more information.

          Connect Objects
How to connect two objects in the Outline View or Calendar View.

          Add Information to Connection
How to place information on a connection.

          Edit Connection Information
How to edit the information you have added to a connection.

          Edit Connection Description
How to select a connection description for an object, or create your own.

          Connect Multiple Objects
How to connect one object with several other objects.

          Connect Objects to Objects on Other Tabs
How to connect an object that is displayed on one tab with an object listed on another 
tab.

See Also
Watch quick tour of Adding and Connecting



connection
A relationship between objects.    Connections describe the relationship and store information
pertinent to the relationship.



View Menu in Calendar

Purpose
Use the options on the Calendar View menu to change the Calendar view, get notes for 
the day, see a tab index, go to the previous view or tab, and see the contents of the trash 
can.

Choose from the following options for more information.
Day View
Week View
Year View
Notes for Day
Tab Index
Previous View
Previous Tab
Trash Can

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System
Using Calendar: The Big Picture



Calendar Object Menu

Purpose
Use the options on the Calendar Object menu to add and delete calendar objects, get 
information about them, and attach memos to them.

Choose from the following options for more information.
Add
Information
Delete
Attach Memo

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System
Using Calendar: The Big Picture



Create or Edit Connection Description

Right-Click Object, Connect, Double-Click Another Object, New Description

Purpose
Use Setup Connection Description to edit or create new one-way or two-way connection 
descriptions.

Steps

1 Right-click an object, choose Connect, then double-click another object.
or
Choose Connections from the Edit menu, then select the categories between which you 
wish to create or edit connections.

2 Select a connection description from the list box, then choose Setup Description.
or
Choose New Description.

3 Type a one-way or two-way description.

4 If this is a family relationship, select the Family relation check box.

5 If available, choose from the following options:

          Add to View
Add all objects to the Outline View that use the selected connection description.

          Count
Count the number of connections that use the selected connection.

          Delete
Remove a connection description from the iBase.

See Also
Create or Edit Category
Create or Edit Tab



Calendar Tools Menu

Purpose
Use the options on the Calendar Tools menu to dial phone numbers, calculate differences 
in dates, use the notepad and LazyKeys, lookup area codes, states, and countries, and use
the elapsed timer.

Choose from the following options for more information.
Telephone
Date Differences
Lazykeys
Lookup Area Codes
Lookup States
Lookup Countries
Elapsed Timer

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System
Using Calendar: The Big Picture



Field Case

Object Information, Setup Field, Select Field Type, OK

Purpose
Use Case to specify the case of the text that is entered into a field.

Steps

1 Choose from the following options:

          As Entered
Leave letters in the case they are entered in.

          Capitalized
Capitalize the first letter of a word.

          UPPER
Capitalize all letters in the word.

          lower
Make all letters in the word lowercase.



 Hint
When entering a new piece of information, do you think "I wish to enter a person named 
Marc Sabatini" or "I wish to enter Marc Sabatini, who is a person"?    The default Add New 
Object setting lets you categorize, then name.    However, if you prefer to name and then 
categorize new information, select Enter Info, then Select Category in Add Preferences.



Create or Edit Connection Field

Object Information, Setup Field, Add New Field, Connection, OK

Object Information, Connection Field, Setup Field, Field Properties, Connection, OK

Purpose
Use Connection Field Setup to create or edit a Connection field.    For example, you can 
connect a field to a category and list those categories that are related to the object.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Connection field, then 
choose Add New Field.

3 Choose Connection, type a name for the field, then choose OK.

4 Select a category in the Connect To Category list box.

5 Select a category in the right list box (the category that is related to the object).

6 Specify a maximum height for the field in the Maximum Height of Connection Field text 
box.

7 Select Indexed List (Using Alpha/Numeric Buttons) if you wish to list the items in the 
field alphabetically.

See Also
Customizing Fields: The Big Picture
Define the Relationship



Connection Preferences

Edit, Preferences, Connections

Purpose
Use Connection Preferences if you wish to be prompted to type connection information 
after connecting objects and if you wish to be prompted to make connections after adding 
an object.    You can also group connections by class when you expand them.

Steps

1 Choose Preferences from the Edit menu, then choose Connections.

2 Select the check boxes for those objects that you wish to be prompted for.

3 Select the last two options if you wish to be prompted to connect a new object to 
existing objects and if you wish to group connections by Person, Organisation, 
Place/Thing, or Event.

4 Choose OK.

See Also
Display Preferences



Select Categories to Edit Connections

Edit, Connections

Purpose
Use Setup Connection to select the two category types between which you wish to create 
or edit a connection description, to delete a connection description, or to view the setup of
an existing connection description.

Steps

1 Choose Connections from the Edit menu.

2 Choose the two category types that you wish to create or edit a connection description 
for.
or
Choose the two category types that you wish to view the connection descriptions for.

3 Choose OK.

See Also
Create or Edit Connection Description
Describe Connection



Connections Exist

Connect Already Connected Objects

Purpose
This dialog box appears as a reminder that you have already connected the objects you 
are trying to connect.

Steps

1 Connect two objects that already have one or more connections between them.

2 Choose New Connection.

3 Choose Connection Info to see information about the current connection.

See Also
Create or Edit Connection Description



Undelete

Object, Trash Can

Purpose
Use the Trash Can to retrieve items you have deleted and empty the Trash Can.    You can 
undelete any of the last several objects you have deleted.

Steps
To restore a deleted item,
1 Choose Trash Can from the View menu.

2 Select the item you wish to restore to the object list, then choose Undelete.

To empty the trash can,
1 Choose Trash Can from the View menu, then choose Empty Trash.

2 Choose Proceed to empty the trash can. 
or
Choose Cancel to empty the trash can at a later time.

See Also
Housekeeping



Copy File

Right-Click File Object, Object Information, Copy

Purpose
Use Copy File to copy a file object to another directory or drive.

Steps

1 Select a file object.

2 Choose File Properties from the File menu, then choose Copy.

3 Specify the pathname and directory where you wish to copy the file.

4 Choose OK.

See Also
Delete File

Edit File Properties



Copy To Clipboard

Select Object, Edit, Copy

Purpose
Use Copy to Clipboard to copy an object to the Windows Clipboard and specify an object 
related to that object.    You can then paste the object(s) elsewhere.

Steps

1 Select an object.

2 Click  on the Toolbar.

3 Select a related object from the list box, then choose OK.

4 Go to another location (such as another tab), then choose Paste from the Edit menu.

See Also
Paste



Create Directory

File, File Properties, Create Directory

Purpose
Use Create Directory to create a new directory.

Steps

1 Choose File Properties from the File menu, then choose Create Directory.

2 Type the name of the new directory in the text box, then choose OK.

See Also
Delete Directory
File Display Settings
Rename Directory



Describe Related File

Right-Click Object, Create Related File, Select a Related File Type, OK, Select 
Organisation or Person, OK

Purpose
Use Create Related File if you wish a description to appear next to a related file object in 
addition to the file's regular information.    For example, if the file type is Letter, you could 
describe it as "Letter to Mom and Dad."

Steps

1 Type a description in the Description text box, then choose OK.

See Also
Edit File Properties
File Display Settings



Create Related File: Advanced Options

Right-click Object, Create Related File, New Type or Setup Type, Advanced

Purpose
Use Advanced Setup Options to customise the way a related file is created when your 
application starts.

            If you specify a prototype (or template) filename, you will need to alter the 
keystrokes you send to the application.    Click on the Hint icons below for more 
information.

Steps

1 Right-click an object, then choose Create Related File.

2 Select a related file type, then choose Setup Type.
or
Type a new related file type, then choose New Type.

3 Select an application (and location) for the file type.

4 Choose Advanced, then choose from the following options:

          Command Line
Specify the location of the application that you will use to create the related file.    The 
command line contains a drive, directory name, and program name.    For example, C:\
WPWIN60\WPWIN60.EXE or C:\WINDOWS\PBRUSH.EXE.    Use the Browse button to 
search your disk for a program.

          Prototype Filename
Specify a template file that you wish to use every time you create this related file type.

          Working Directory
Specify a working default DOS directory for the application that is set before the 
application is launched.    When this is not filled in then the directory where the program 
is launched from is used.    Many programs require that the working directory be set to 
the directory where the program is launched from.    When in doubt, leave this text box 
empty.

          Data File Directory
Specify a directory where you wish to store related files of this type.    For example, if 
you have a related file type called "Memos," then you could specify C:\DOCUMENTS\
MEMOS as the location.

          Data File Extension
Specify an extension for the related file.



          Instance Filename
Quickly switch to the application instead of restarting it if it is already running.    You can 
use this option only if an application supports multiple instances.    Smaller applications, 
such as Notepad and Windows Write, do.    Larger applications do not.

          Send Default Text Via
Specify how the default text specified in the Default Text is sent to the application.    
Send text via the Windows Clipboard, and ASCII text file, or choose not to send text.    
When text is sent via the Windows Clipboard, it is pasted into the application by the 
paste/Clipboard accelerator key for that application.    This pasting is specified in the 
Keystrokes to Send to the Application option.    When the default text is sent via a plain 
ASCII text file, the name of the file is usually passed to the application on the 
application launch command line.

          Always Launch New Instance
If an application is already running, this setting will not switch to it, but start a new 
instance of the application, thus letting you work with several smaller applications, such
as Windows Notepad or Paint Brush, simultaneously.    Larger applications do not support
multiple instances and will report an error if you try to launch additional instances of 
them once they're already running.

          Pass Filename on Command Line
Specify whether or not the text file created when the Send Default Text Via option is set 
to Text File, is passed on the command line when the application is launched.

          Keystrokes to Send to the Application
Specify the keystrokes unique to your application that you wish to invoke when the 
application starts.    

See Also
Create or Edit Related File Type
Creating Related Files: The Big Picture
Extracting Field Information to Insert in Related File
How a Related File is Created
Select a Related File Type
Specify Default Text and Variables
Watch quick tour of Creating Related Files



Create Related File: Create or Edit File Type

Create a Related File, New Type or Setup Type

Purpose
A Related File Type is the set of instructions that is sent to an application when it starts to 
create a related file.    Use Setup File Type to create, edit, or delete a related file type.    For 
example, you can name or rename the file type (for example, Letter, Spreadsheet, or 
Graphic), specify or re-specify an application, and set up a connection description that will 
describe the file and the object you connect it to.

Steps

1 From the Create a Related File dialog box, select a file type then choose Setup Type.
or
Type a new file type name, then choose New Type.

2 Verify or re-specify the type of the file in the File Type text box.
or
If you wish to delete the file type, choose Delete.

3 Select an application from the Windows Application drop-down list.
or
If the application does not appear in the list, scroll to the top of the list and select 
{Custom Setup}.

When you choose OK, you will be asked to provide information about the application.

4 Select Prompt for Related Person/Organisation if you wish to be prompted to include the 
information from related people or organisations during the creation of a related file.

5 Select a connection description from the Connection Description drop-down list. 

6 If you wish to delete a related file type, highlight the name of the type, then choose 
Delete.

7 Choose from the following advanced Related File options, or choose OK:
Change Location of Related Files
Send Text and Variables to Application
Extract Field Information for Related File
Turn On Features When Application Starts
Open a Template When Application Starts
Include Related Person or Organisation

See Also
Creating Related Files: The Big Picture
Edit File Properties
How a Related File is Created
Watch quick tour of Creating Related Files





Create Related File: Create or Edit Default Text

Right-click Object, Create Related File, New Type or Setup Type, Default Text

Purpose
Use Setup Default Text to create or edit the text that will be placed into each new related 
file that you create.    To quickly insert pre-defined text and variables, use the Description, 
Address Block, or Standard Letter buttons.    You can type the text you wish typed 
automatically in every new related file.    You can also specify variables that represent the 
field information you wish extracted and placed in every new related file.

Steps
To quickly insert pre-defined related file text,
1 Right-click the object you wish to create a related file for.

2 Highlight the Related File type that you wish to use, choose Setup Type, then choose 
Default Text.
or
Choose New Type, type a description, choose OK, then choose Default Text.

3 Choose from the following options, then choose OK:

          Description
Insert the file description into the file.    For example, if you type "Memo to all 
employees" as the description of a related file, choosing Description inserts the 
@@FileDesc@@ variable, which will insert this description into the related file.

          Address Block
Inserts field variables that will extract a person's name, his title at a company, the 
company name, and address information.    InfoCentral places this information in the 
resultant related file.

          Standard Letter
Inserts the standard letter format, including today's date, the standard address block, a 
RE: notation, "Dear" and "Sincerely," your name, your initials and your assistant's 
initials ("wpi" for WordPerfect InfoCentral), and the name of the file so you can locate it 
later.

To customise related file text and variables,
1 Follow steps 1 and 2 above.

2 Change the text after you have used one of the three options used in step 3 above.

For example, type "RE:" before the @@FileDesc@@ Description variable so that 
something such as "RE: Memo to all employees" appears in the related file.    Or, cut 
##Address_Block## to the Clipboard (Ctrl+X), then paste it (Ctrl+V) below the $
$Object_Desc$$ to produce a different result.    You can rearrange the text and variables 
any way you wish.



3 Choose from the following for more information about customizing related file text and 
variables, then choose OK:
Extract Field Information for Related File
Learn About Proper Text and Variable Notation
Insert Standard Related File Variables
Insert System Date and Time Variables

See Also
Creating Related Files: The Big Picture
How a Related File is Created
Select Field Object
Watch quick tour of Creating Related Files



Create Related File: Select Related Person or Organisation

Setup File Type (Prompt for Related), Create a Related File, OK

Purpose
If you are attaching a document to an organisation, use Create Related File: Select 
Person to select a related person that has information (such as an address or phone 
number) that you wish to extract and insert into a related file.    If you are attaching a 
document to a person, use Create Related File: Select Organisation to select a related 
organisation that has information that you wish to use in the related file.

            To extract information from related persons or organisations into a related file,
the Prompt for Related Person/Organisation setting, found on the Setup File Type dialog 
box, must be turned on.

Steps
To include a related organisation,
1 Highlight the person to whom you wish to connect a related file, then choose  from 

the Toolbar.

2 Highlight the related file type that you wish to use to create the related file, then choose
Setup Type.
or
Choose New Type to setup a new related file type.

3 Select Prompt for Related Person/Organisation and make any other settings you wish for
the related file type, then choose OK.

4 Choose OK on the Create Related File dialog box.

5 Select an organisation from the Select an Organisation list box.
or
Choose Select a Different Organisation, then double-click an organisation listed in the 
Outline View.
or
Select No Related Organisation, then choose OK.

6 Type a description for the related file, then choose OK.

To include a related person,
1 Follow steps 1 through 4 above, except highlight an organisation.

2 Select a person from the Select a Person list box, then choose OK.
or
Choose select No Related Person, then choose OK.
or
Choose Home Address to use the person's address rather than the address of the 
organisation.

3 Type a description for the related file, then choose OK.



See Also
Create or Edit Connection Description
Create or Edit Related File Type
Select a Related File Type
Select Related Organisation
Watch quick tour of Creating Related Files



Creating Related Files: The Big Picture

Purpose
Use Create Related Files to easily create the documents, graphics, or spreadsheets that 
you wish to connect to objects.    You personalise (or select) the applications you wish to 
use to create related files the first time you use this feature.

Select one of the following options for more information about creating related files:

          How a Related File is Created
What happens when a related file is created and how the related file is named 
automatically for you.    Also learn why proper file extensions and names are essential.

          Personalise Your Applications
How to set up your applications the first time you use the Create Related File feature so 
they are started automatically later.

          Locate Applications
How to tell InfoCentral where the applications that you plan to use for creating related 
files are located.

          Select Related File Type
How to select one of the default related file types (such as Document, Letter, or 
Graphic), which include pre-defined settings that enable you to create related files 
quickly.

          Describe Related File
How to give the related file a description that will appear in the Outline View when it is 
connected to an object.

          Expand to See Related File
How to expand an object's connections so you can see the related file you just 
connected to it.

          Create or Edit Related File Type
Learn what a "related file type" is and how to create a new one or customise an existing
one; for example, name or rename the file type, specify a new application, change an 
application, describe the connection between the related file and the object you connect
it to, prompt for related people or organisations, or delete a file type.

          Related File Advanced Options
How to change the location of where related files are stored, turn on certain features 
automatically when your application starts, change related file extensions, and control 
how your application starts and runs.

          Setup Default Text
How to type text automatically when your related file application starts; how to use 
system and field variables that insert the current date and time or extract information 



from fields.

          Include a Related Person or Organisation
How to extract information from the people or organisations that are connected to the 
people or organisations to which you are connecting a related file.

See Also
Watch quick tour of Creating Related Files



Customise Menu Hot Key

Edit, Preferences, Menu, Customise Hot Key

Purpose
Use Customise Menu Hot Key to assign the Hot Key function to a key.    The default Hot Key
is F12.

            Do not map the Hot Key function to a key that has already been assigned a 
shortcut key function.    Check the settings in the Assign Accelerator Key feature.

Steps

1 Choose Preferences from the Edit menu, choose Menu, then Customise Hot Key.

2 Type the key. 

3 Choose OK.

See Also
Customise Menu
Customise Menu Bar
Load Menu System



Customizing Fields: The Big Picture

Purpose
You can create, edit, or delete the information fields in the Object Information or 
Connection Information dialog boxes.    Many fields let you add special options, such 
calculates values in fields automatically.

Choose from the following options for more information.

          Object or Connection Information
How to display the information fields that you can customise.

          Select Different Field
How to select a field so you can move, rename, delete, or edit it.

          Delete Field
How to remove the field you select.

          Undelete Field
How to record any of the last several fields you have deleted.

          Add New Field
How to add any of 10 different field types, including check boxes, radio 
buttons, telephone, memo, and titles for a group of fields.

          Edit Field
How to rename a field, change a field's special options, and write helps and 
hints for the field.

          Move Field
How to move a field to another location on the dialog box.

          Zoom or Unzoom Field
How to change the viewing size of the Object Information or Connection 
Information dialog boxes.



Customizing My Menus: The Big Picture

Purpose
You can customise the InfoCentral menu bar and menu items.    Menu settings are stored in
the WPICMENU.MNW file.    Before you customise a menu, you should copy this file to a 
different directory for safe keeping.

Choose from the following for more information.

          Customise Menu Hot Key
How to change the key that activates the Customise Menu and Menu Bar features.

          Customise Menu
How to create or edit menu items on a menu (such as Clear Line on the List menu).

          Customise Menu Bar
How to create or edit menu bar items (such as the File menu).

          Assign Accelerator Keys
How to personalise shortcut keys to features on menus.

          Perform Built-In Commands
How to execute InfoCentral's many pre-defined commands.

          Launch Programs from Menus
How to execute other applications from the menu items you create or edit.

          Sprout New Menu
How to create new menus or cascading menus.

          Load Menu System
How to choose the file that contains the menu structure that you have customised.



Cut

Edit, Cut

Purpose
Use Cut to remove text or objects.    You can use Paste to retrieve cut text or objects.

Steps

1 Select the object or text you wish to cut.

2 Click .

See Also
Copy to Clipboard
Paste



Create or Edit Date Field

Object Information, Setup Field, Add New Field, Date, OK

Object Information, Date Field, Setup Field, Field Properties, Date, OK

Purpose
Use Date fields to display dates.    You can choose to display a date in several different 
formats using system date variables.    

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Date field, then choose 
Add New Field.

3 Choose Date, type a name for the field, then choose OK.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Entry Options
Field Initial Value Calculation
Field Range

2 Choose from the following options unique to Date fields:

          Expanded Date
Display the expanded, spelled out version of the date (for example, "Saturday, April 9th,
1993").

          Elapsed Timespan
Display the elapsed time between today and the date (for example, "3 years 9 months 
12 days ago").

See Also
Customizing Fields: The Big Picture



Date Not Understood

Object Information, Date Field, Invalid Date, OK

Purpose
This dialog box appears if the date you have specified is not in a format that InfoCentral 
recognizes. 

Steps

1 Choose OK and respecify the date.

See Also
Calendar Tool



Daylight Saving Time Preferences

Edit, Preferences, Daylight Saving Time

Purpose
Use Daylight Saving Time to specify the beginning and ending dates for Daylight Saving 
Time.

Steps

1 Choose Preferences from the Edit menu, then choose Daylight Saving Time.

2 Specify the Start and Stop date for the time changes. 

3 Choose OK.

See Also
Calendar Preferences



Delete Menu Line

Menu with Line, Customise Menu Hot Key (F12), Delete the Adjacent Ruled Separator

Purpose
Use Delete Adjacent Ruled Separator to remove the lines that appear above or below a 
menu item (for example, the lines on the View menu above or below the Sort the List 
menu item).

Steps

1 Highlight a menu item that has a line above or below (or both above and below).

2 Press the Customise Menu Hot Key (F12).

3 Choose Delete the Adjacent Ruled Separator.

4 If the menu item has a line above or below it, select Previous Line or Next line, then 
choose OK.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System



copy
To duplicate text and place it on the Clipboard.



Delete Connection

Right-Click Connection Description, Delete

Purpose
Use Delete Connection to delete the currently selected connection description in the 
Outline View.    Deleting a connection only unconnects two objects; it does not delete the 
connection description.

Steps

1 Select a connection description between two objects.

2 Click  on the Toolbar.

3 Choose Delete.

See Also
Delete File
Delete Directory
Delete Object



Delete Directory

Right-Click Directory Object, Delete

Purpose
Use Delete Directory to delete the currently selected directory.

Steps

1 Select a directory object from the Outline View.

Directory objects have a  icon next to them.

2 Right-click, then choose Delete.

3 Make sure you wish to delete the directory, then choose Delete.

See Also
Delete File
Delete Object
Delete Connection



Delete Field

Object Information or Connection Information, Setup Field, Delete

Purpose
Use Delete Field to remove a field from the Object Information or Connection Information 
dialog box.

Steps

1 Select a field in the Object Information or Connection Information dialog box.

2 Right-click, then choose Delete.

See Also
Field Trash Can
Move Field
Select Different Field



Delete File

Right-Click Filename Object, Delete

Purpose
Use Delete File to delete the currently selected file object.

Steps

1 Select a file object in the Outline View.

File objects have a  icon next them.

2 Right-click and choose Delete.

3 Choose Delete or Shred.

See Also
Delete Connection
Delete Directory
Delete Object



cut
To remove text and place it on the Clipboard.



Delete Object

Right-Click Object, Delete

Select Object, Delete

Purpose
Use Delete Object to move an object from the Outline View to the Trash Can.    Only objects
can be placed in the Trash Can.    When you wish to undelete an object, you can restore it 
from the Trash Can.

Steps

1 Right-click an object, then choose Delete.
or

Select an object, then click Delete  on the Toolbar.

See Also
Undelete
Undo



Example
If you knew that an object used the connection "Employee," but you couldn't remember the 
name of the object, you could use Find-By-Example to find the object.



Describe Connection

Right-Click Object, Connect, Double-Click Another Object

Drag and Drop Object on Another Object

Purpose
Use Describe Connection to select, create, edit, or delete a one-way or two-way 
connection description.

            If you delete a category, all objects in that category are also deleted.

Steps

1 Select a one-way or two-way connection description from the list box, then choose OK.
or
Select a description, then choose Setup Description to edit it.
or
Choose New Description to create a new description.

2 If available, choose Delete to delete the category.

3 If available, choose Add to View to display all objects with the selected category.

See Also
Connections Exist
Create or Edit Connection Description
Watch quick tour of Adding and Connecting



Field Entry Options

Purpose
Use Field Entry Options to customise how information is entered into fields.

Steps

1 Choose from the following options:

          Compulsory
Keep the field from being left empty.

          Carry Forward
Fill in a field with the value that was entered the last time an object or connection of the
same type was added.    For Carry Forward to work properly, you must turn on the 
option, close the Object Information dialog box, re-open it, then type the text that you 
wish to carry forward to the next object of the same type.    A Carry Forward value is 
entered into a field only when you close an object.    Example

          Address Field
Designate the field for addresses only.

          Numbers Only
Ensure that only numbers can be entered in the field. Example

          Display Only
Designate the field for viewing purposes only.

See Also
Field Initial Value Calculation
Select Field Type to Create or Edit



Field Initial Value Calculation

Object Information, Setup Field, Field Setup: Select Field Type, OK

Purpose
Use Initial Value Calculation to calculate a value in a field when you click a field or when 
you press Tab to exit the field.    You can use initial value calculations in all fields except 
Connection and Group Title types.    Example

            Make sure that the Initial Value Calculation does not conflict with the other 
field properties, such as Template Format, Field Ranges, and Field Entry Options.    For 
example, do not use the Carry Forward Field Entry Option and Initial Value Calculation at
the same time.

Steps

1 Choose from the following options:
Date and Time Functions
Extract Information from Other Fields
Mathsematical Operators
Miscellaneous System Variables
String Functions
System Date and Time Variables
Text in Initial Value Fields
Variable Functions



Autodialing In-Area Toll Calls

Purpose
If you have taken a laptop to a different area code, and tried to autodial a phone number, 
you may have had to change some settings in your autodialing application.    Beginning in 
1995, when all callers in North America will be able to dial the full phone number (country 
code, area code, and local number) no matter where they are in North America, you can 
use Telephone Preferences to take advantage of this change.    Use Telephone Preferences 
to set up InfoCentral if you wish to use this dialing scenario.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or
Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Check the Enabled check box in the In-Area Toll Calling group box.

3 Type the local prefixes (three digits) in the Non-Toll Prefixes text box, separating each 
number with a comma (not a comma and a space), then choose OK.

For example, Provo-Orem InfoCentral users would type the following:
 

221,222,224,225,226,227,228,300,342,345,369,371,373,374,375,376,377,378,379,423,
429,465,470,489,754,756,763,768,785,789

See Also
Autodialing Normal Phone Lines
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance with a Calling Card
Autodialing Long Distance from Office with Card
Autodialing Long Distance with Access Code



Using Quick Tour

Purpose
The quick tour provides eight easy-to-understand presentations that explain InfoCentral 
basics.    You can start the quick tour from the Help menu, or you can run quick tour 
segments from many Help topics like this one.

            To run the quick tour, the following files must be located in the same directory:
WPIC.EXE, WPIC11UK.HLP, WPICQT.EXE, CCBUTTON.VBX, and VBRUN300.DLL.    The 
quick tour working directory must be the same location as these files.

Steps

1 Choose Quick Tour from the Help menu to display the quick tour menu.
or
Click a quick tour jump from a Help topic, such as the ones listed under See Also.

While the quick tour is running, you can type p to pause it.    Type p again to resume the
quick tour.

See Also
iBases versus Databases
Using the Coach
Quick tour Main Menu
Watch quick tour of InfoCentral Basics
Watch quick tour of Adding and Connecting
Watch quick tour of Finding Objects
Watch quick tour of Using Calendar
Watch quick tour of Creating Related Files
Watch quick tour of Organizing Objects
Watch quick tour of Using Content iBases
Watch quick tour of Getting Help



Using the Coaches

Purpose
The Coach feature is an interactive tutorial that can guide you through a task.    For 
example, suppose you wish to import information into an iBase.    Unlike a regular tutorial, 
the Import Coach actually helps you import a real import file as you use the Coach.

Steps

1 Choose Coaches from the Help menu, then choose Quick Start, FastFind, or Import.

2 Follow the prompts carefully and type the required information.

3 Choose Quit Coach, then Yes at any time to exit the Coach.

See Also
Finding Objects: The Big Picture
Importing Data into iBase: The Big Picture
Using the Quick Tour



Using Text in Initial Value Fields

Purpose
You can have a field automatically filled in with text every time an object is added as long 
as you enclose the text in quotes in the Initial Value Calculation text box.    For example, if 
you type "San Francisco" in the Initial Value Calculation text box, the field will contain San 
Francisco.

Steps

1 In the Object Information or Connection Information dialog box, click the field in which 
you wish to set an initial text value.

2 Right-click the field, then choose Field Properties.
or
Right-click the field, then choose Add New Field to add a new field below the one you 
selected in step 1.

3 Type a name for the field, if necessary.

4 Select a field type, then choose OK.

5 Type the text (enclosed in quotes) in the Initial Value Calculation text box that you wish 
to appear in the field every time an object is created, then choose OK.

See Also
Field Initial Value Calculation
Specify Text for Related File



Using Information from Other Fields

Purpose
You can use the information from other fields in an initial value calculation by using the 
field name as a variable name.    You can also combine information from more than one 
field to determine what automatically appears in a Calculation or Initial Value Calculation 
field. Example 1    Example 2

Steps

1 In the Object Information or Connection Information dialog box, click the field in which 
you wish to set an initial text value.

2 Right-click the field, then choose Field Properties.
or
Right-click the field, then choose Add New Field to add a new field below the one you 
selected in step 1.

3 Type a name for the field, if necessary.

4 Select a field type, then choose OK.

5 Type the information from other fields that you wish to include in the field you're 
working on, then choose OK.

See Also
Field Initial Value Calculation



Edit Directory Information

Right-Click Directory Object, Information

Purpose
Use Directory Properties to type a description for a directory, add a memo to the directory,
and delete or rename the directory.

Steps

1 Right-click a directory object, then choose Information.

2 Type a description for the directory.

3 Type a new name for the directory.

4 Choose from the following options:
Attach a Memo
Delete Directory

See Also
Edit Object Information



Display Case

File, File Properties, Display Case

Purpose
Use Display Case to change directory and file names to all uppercase or lowercase letters, 
or to capitalize the first letter.

Steps

1 Choose File Properties from the file menu, then choose Display Case.

2 Select the case option you wish for files and directories.

3 Choose OK.

See Also
File Display Settings



Display Preferences

Edit, Preferences, Display

View, Display

Purpose
Use Display Preferences to choose options for the Toolbar, Outline buttons, and Zoom 
feature.    You can also choose display colours for objects and non-objects, such as 
connection descriptions.

Steps

1 Choose Display from the View menu.
or
Right-click the space between buttons on the Toolbar, then choose Display.

2 Choose from the following options:

          Toolbar Appearance
Choose the way the Toolbar displays.    Select Hide to turn off the Toolbar.

          Desktop View
Choose whether to show or hide the Outline buttons, turn the Tab bar on or off, and 
select the default colours for all objects and non-objects (connection descriptions).    To 
change the colour of individual categories, use Create or Edit Category.

          Keep Zoom Settings
Set the Zoom setting (Zoom or Unzoom) for the Object Information and Connection 
Information dialog boxes.

See Also
Create or Edit Category
Create or Edit Tab



Duplicate Record

Add New Object, Select Category, Name of Existing Object

Purpose
You are trying to add an object that already exists.    You can turn this message off using 
Add Preferences.

Steps

1 Choose Add Anyway to add the object.
or
Choose Cancel.

See Also
Add New Object (Categorize then Name)
Add Preferences



Elapsed Timer

Tools, Elapsed Timer

Purpose
Use Elapsed Timer to time phone calls or keep track of how long you work on a project.    
The timer is located in the lower right corner of the window. 

Steps

1 Choose Elapsed Timer from the Tools menu, then choose Start/Stop to start the timer.
or
Choose Start/Stop when you wish to stop the timer.
or
Choose Clear to reset the timer to 00m00s.

Note that the timer changes colours when it is running, stopped, or reset.    The "m" 
stands for minutes; the "s" for seconds.



ComputerCentral
This iBase contains information on hundreds of companies in the computer industry.    
Products, support telephone numbers, and key people for each company are included.



event
A meeting, flight, hotel stay, or anything you wish to schedule on your Calendar.    Like any 
other object, an event object can be displayed in the Outline View as well. 



deselect
To remove the X from a check box, or to remove a check mark from a menu item.



Exit

File, Exit

Purpose
Use Exit to quit InfoCentral.    You can save any changes you have made in the current 
iBase and return to Program Manager.    If you have not made any changes, InfoCentral 
returns you to Program Manager.

Steps

1 Choose Exit from the File menu.
or
Press Alt-F4.



Expand
Expanding an object displays other objects connected to it, along with connection 
descriptions.    The  button indicates that object can be expanded.



Expand Connections

Right-Click Object, Expand

Select Object, List, Expand by Type

Purpose
Use Expand to display an object's subordinate objects and related files.    Use Expand by 
Type to expand a main level heading according to the People, Organisations, 
Places/Things, Events, and File categories.

Steps
To expand the outline of an object,
1 Select the object.

2 Click  next to the object.
or
Press the plus key (+).
or
Choose Expand or Expand by Type from the List menu.

See Also
Collapse Connections



Example
Suppose that you need to write to all your friends to verify their phone numbers.    To do this,
you could choose the Person category, then select Main_Telephone on the Select Field Object
dialog box.    When you choose OK, the Main_Telephone variable is inserted into the Default 
Text to Place into Each New File window at the cursor position.    This variable represents 
the Main Telephone field in the Object Information dialog box for a person.    To save some 
time when you create your letters, you could also type the following line before this variable:
"I am checking everyone's phone number.    Please let me know if the following number I 
have for you is incorrect:"    Now when you create a Related File with this Related File type, 
any information that is contained in the Main Telephone field for the object that you are 
creating a related file for will be "pulled" into the letter along with the text that you have 
typed.



Create or Select Export Scenario

File, Export

Purpose
Use Export to select an existing export scenario (pattern) or to create a new export 
scenario.

Steps

1 Choose Export from the File menu.

2 Select an Export Scenario from the Export Scenario list box, then choose OK.
or
Choose New Scenario, type the name of the new scenario, choose OK, then choose Add.

See Also
Begin Export
Check Export Summary
Check Export Completion
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields
Select Export File



Check Export Completion

Begin Export, Export Completed

Purpose
Use Export Completed to make sure the export happened the way you wished it to.

Steps

1 Read the information on the dialog box, then choose OK.

See Also
Begin Export
Check Export Summary
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields
Select Export File



Begin Export

Check Export Summary, Begin Export

Purpose
Use Begin Export after you have examined the information on the Export: Summary dialog
box and you are ready to perform the export.

Steps

1 Choose Begin Export on the Export: Summary dialog box.

If you wish to cancel the export process, choose Cancel.

See Also
Check Export Summary
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields
Select Export File



ConsumerCentral
This iBase contains addresses and consumer service telephone numbers for hundreds of 
companies.    Tabs are set up for you to find manufacturers and dealers for things like major 
appliances, audio equipment, and sporting goods.



Select Export Connected Category

File, Export, New Scenario, Select Export Category, Include Connected Category, OK

Purpose
Use Export: Connected Category to specify the related category of objects that you wish 
to export. 

Steps

1 Choose the related category of objects that you wish to export.

2 Choose from the following options, then choose OK.

          Backup
Return to the Export: Category dialog box.

          Former/Future
Export connections that have a Starting Date field in the future or an Ending Date field 
in the past.

See Also
Begin Export
Check Export Summary
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Fields
Select Export File



Check Export Summary

Select Export Fields, OK

Purpose
Use Export: Summary to view or change information about the export scenario you have 
selected.

Steps

1 Read the information about the export summary, then choose Begin Export.
or
Choose from the following options:

          Export Scenario
Rename the export scenario.

          Delete Scenario
Delete the export scenario.    Choosing this option returns you to the Export dialog box 
where you can create or select another scenario.

          Setup
Select different categories and output file for the export scenario.

See Also
Begin Export
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields
Select Export File



 Hint
This dialog box appears only if you selected Include a Connected Category in the Export: 
Category dialog box.



Select Export Category

File, Export, New Scenario, OK

Purpose
Use Export: Category Name to specify the object category that you wish to export.

Steps

1 Select the Category that contains the objects you wish to export.

2 Choose from the following options, then choose OK:

          Include Connected Category
Export this category plus others that are connected to objects in this category.

          Export Objects
Restrict the export to objects that match the export criteria and appear in the current 
display list.

See Also
Begin Export
Check Export Summary
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Connected Category
Select Export Fields
Select Export File



Field Template Format

Object Information, Setup Field, Field Properties, Field Type, OK

Purpose
Use Template Format to define how characters entered in a field are to be automatically 
reformatted.    Leave this text box empty if you wish the format of characters to remain as 
they are entered.

Steps

1 Type the template format in the Template Format text box.

2 Choose from the following for examples of template formats:
Alpha or Numeric Field Example
Currency Field Example
Number Field Example

See Also
Field Initial Value Calculation



Select Export Fields

New Scenario, Select Export Category, Select Export Connected Category, Select 
Export File, OK

Purpose
Use Export: Select Fields to specify which fields from the selected categories you wish to 
export.

Steps

1 Drag category items and field information from the iBase Fields list box (the items you 
wish to export) and drop them in the Fields to be Exported list box. Example
or
Choose All Fields to export all the fields in the list.

2 Choose from the following options:

          

Return to the first export category in your iBase or in the current Outline View.

          

Browse through each export category that you have set up.

          Reset/Revert
Redisplay the lists as they were before you started dragging and dropping items.

          Backup
Go back to the previous dialog box (to change or remind yourself of the settings you 
made).

          iBase Info
Get information about the current iBase.

See Also
Begin Export
Check Export Summary
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export File





Exporting iBase Information: The Big Picture

Purpose
Use Export to export objects, object information, and connection descriptions from the 
current iBase to another iBase, database, or spreadsheet.    You can export to either a tab 
or comma/space delimited export file.    You can export to comma/space or tab delimited 
export files only.

The following tasks illustrate the process of a first time export.
Create or Select Export Scenario

Select Export Category

Select Export Connected Category

Select Default Connection

Specify Output File

Select Export Fields

Check Export Summary

Begin Export

Check Export Completion



FastFind

FastFind

Purpose
Use FastFind when you have a rough idea of what information you wish to find.    FastFind 
searches for objects of a particular class or category.    You can also search for a particular 
date and list Today's Schedule for that date.

Steps

1 Click FastFind  on the Toolbar.

2 Type the name of the object in the Find text box. 

3 Choose Find All to find all objects in your iBase that match the name you typed in step 
2.
or
Choose Find People, Organisations, Places/Things, or Find Events to narrow the search to
a particular class of objects.

See Also
FastFind Files
FastFind Preferences
Find By Category
Finding Objects: The Big Picture
Today's Schedule
Watch quick tour of Finding Objects



FastFind Preferences

FastFind, Preferences

Purpose
Use FastFind Preferences to specify how you are notified of the results of a FastFind search.

Steps

1 Click FastFind  on the Toolbar, then choose Preferences.

2 Select how you wish to be notified when FastFind does not find a match.

3 Select from the following options, then choose OK.

          Confirmation Sounds
Sounds a tune when a FastFind is successful.

          Default Push Button
Records the object title and other query options you used for the last FastFind.

See Also
FastFind
FastFind Files
Finding Objects: The Big Picture
Watch quick tour of Finding Objects



Create or Edit Field

Object Information, Setup Field

Purpose
Use Setup Field in Object Information to add, edit, move, delete, and select a different 
field.    You can also undelete fields that you have deleted.

Steps

1 Right-click a field in the Object Information dialog box.
or
Tab to a field, then choose Setup Field.

2 Choose from the following options:
Field Properties
Add New Field
Delete Field
Undelete Field
Move Field
Select Different Field

See Also
Customizing Fields: The Big Picture
Edit Object or Connection Information



Select Field Type to Create or Edit

Right-click Object, Information, Setup Field, Add New Field or Field Properties

Purpose
Use Field Properties to select a field type that you can use to either create or edit a field.

Steps
To edit an existing field,
1 Right-click a field in the Object Information or Connection Information dialog box, then 

choose Field Properties.
or
Tab to a field, choose Setup Field, choose Field Properties, then choose OK.

To create a new field,
1 Right-click the field below which you wish to add a new field, then choose Add New 

Field.
or
Tab to a field below which you wish to add a new field, then choose Add New Field.

2 Type a new name in the Field Name text box, then choose OK
or
Select a field from the Field Type list box, then choose OK.

3 Choose from the following options:
Create or Edit Alarm Notification Field
Create or Edit Alpha/Numeric Field
Create or Edit Calculation Field
Create or Edit Check Box Field
Create or Edit Connection Field
Create or Edit Date Field
Create or Edit Group Title Field
Create or Edit Memo Field
Create or Edit Number or Currency Field
Create or Edit Radio Button Field
Create or Edit Task Priority Radio Button
Create or Edit Telephone, Modem, or Fax Line Field
Create or Edit Time Field

See Also
Customizing Fields: The Big Picture



Field Trash Can

Object Information, Setup Field, Field Trash Can

Purpose
Use Field Trash Can to restore a deleted field.    The field is restored after the currently 
active field.    If the Trash Can is empty, it is not available.

Steps

1 In Object Information, tab to the field that precedes the location of where you wish to 
restore a deleted field.

2 Choose Setup Field, then choose Field Trash Can.

3 Select the field you wish to restore.

4 Choose Undelete.

See Also
Customizing Fields: The Big Picture
Edit Object Information
Undelete



File Display Settings

File, File Properties, Display Format

Purpose
Use File Display Settings to specify the way files are displayed and sorted in the Outline 
View.

Steps

1 Choose File Properties from the File menu, then choose Display Format.

2 Select Clear to remove the current order.

3 Select the check boxes in the order that you wish file information displayed and sorted.

See Also
Display Case
Sort the List



Edit File Properties

Right-Click File Object, Information

Purpose
When files are displayed in the Outline View, use File Properties to get information about 
that file.    You can also open, copy, delete, move, rename, type a description for, attach a 
memo to, and set attributes for the file.

Steps

1 Right-click a file object, then choose Information.

2 Change the file name, location, and attributes for the file.

3 Choose from the following options:
Attach Memo
Copy File
Delete File
Open File

See Also
Edit Object or Connection Information
Edit Directory Information
Edit Object Information



Find by Category

FastFind, By Category

Purpose
Use Find by Category to find objects of a particular category.    For example, you can find 
all objects in the "Hotel Chain" category, or just those in the same category that start with
the letter "m."

Steps

1 Click FastFind  on the Toolbar, then choose By Category.
or
Type the text in the Find text box that you wish to include in the search, then choose By 
Category.

2 Select a category from the Select Category list box.

3 Choose Find All to find all objects in the category you selected.
or
If you specified text in step 1, choose Find to find all objects that match the category 
and contain the text as the first letter.

See Also
FastFind
Find-By-Example
Find-By-Connection
Finding Objects: The Big Picture
Watch quick tour of Finding Objects



Find-By-Connection

Find, Find-By-Connection

Purpose
Use Find-By-Connection to find objects according to the connections between them.    
Example

Steps

1 Choose Find-By-Connection from the Find menu.

2 Select the object categories that define the one-way or two-way connections you wish 
to find.

3 Choose the following option:
Describe Connection

See Also
FastFind
Find by Category
Find-By-Example
Finding Objects: The Big Picture
Watch quick tour of Finding Objects



Describe Connection(s) to Find

Find, Find-By-Connection, People and Organisations, Place/Things, or Events

Purpose
Use Describe Connection to specify the one-way or two-way connection description you 
wish to find.

Steps

1 Select the connection description from the list box.

2 Choose Add to View to list those connections that are used with objects in your iBase.

See Also
FastFind
Find-By-Connection
Find-By-Example
Finding Objects: The Big Picture
Watch quick tour of Finding Objects



Field Range

Object Information, Setup Field, Field Properties, OK

Purpose
Use Valid Range to enter the maximum or minimum value, number of digits or characters, 
or earliest and latest time that a field is allowed to contain.

Steps

1 Type the maximum value, number of digits or characters, or earliest and latest time that
you wish allowed in the field. 

See Also
Field Entry Options
Field Initial Value Calculation



Find-By-Example

Find, Find-By-Example

Purpose
Use Find-By-Example to search for objects that share similar information in a specific 
Object Information field.    Those objects that match the search criteria you specify are 
appended to the Outline View.

            You cannot search for information contained in Group Title fields.    For 
example, the bar labelled "Home Address" above the address fields is not searchable.

Steps

1 Choose Find-By-Example from the Find menu.

2 Select a category, then choose OK.

3 Type the word(s) contained in the objects that you wish to search for, then choose OK.
or
Choose Last Query to repeat the search you performed last time.
or
Choose from the following topics, which explain how to perform more complex searches 
using logical operators, relation operators, and wildcards:

                  Searching Text Fields
How to search for objects that contain specific information in Alpha/Numeric, 
Calculation, Connection, and Memo fields.

                  Searching Numeric Fields
How to search for objects that contain specific information in Currency, Date, Fax 
Line, Modem Line, Telephone, and Time fields.

                  Searching Selectable Fields
How to search for objects that have certain check boxes or radio buttons selected.

See Also
Watch quick tour of Finding Objects



Find-By-Example: Searching Text Fields

Purpose
Text fields include Alpha/Numeric, Calculation, Connection, and Memo fields.    You can 
search these fields using logical operators, numeric operators, the asterisk (*) wildcard, or 
combinations (for example, an asterisk and a logical operator).    If you are searching an 
Alpha/Numeric field that has the Numeric Only option turned on, still consider it a Text 
field.

You can type letters, numbers, spaces, extended characters, and punctuation as long as 
they match the full text contained in the field.    The search is not case sensitive unless 
you are using extended characters.    For example, if you type FRANK as the search string 
in the Last Name field of a person object, InfoCentral finds Anne Frank and Jeff Frank but 
not Henry Franks, Joseph Franklin, Howard Frankenhoff, or Dr. Frankenstein.

            You cannot use Parentheses to group parts of the search string.

Steps

1 Choose Find-By-Example from the Find menu.

2 Select a category, then choose OK.

3 Choose from the following options, then choose OK:
Logical Operators
Relational Operators
Asterisk Wildcard Character



Finding Objects: The Big Picture

Purpose
You can find the information in your iBase in a variety of ways.

Choose from the following options for more information.

          Use FastFind
How to find information when you have a rough idea of what you wish to find.

          Find-By-Example
How to to find objects using search criteria such as relational operators, logical 
operators, and wildcards.

          Find-By-Connection
How to find objects according to the connections between them.

          Find All Categories
How to list all categories available for objects in your iBase.

          Use Alphabetic Index
How to select a category and list the objects in the category.

          Use Address Book
How to look up addresses and phone numbers of people or organisations.

See Also
Watch quick tour of Finding Objects



flatten
To move all objects to the left side of the screen and remove connection descriptions.



Flatten Outline

List, Flatten Outline

Purpose
Use Flatten Outline to view all objects as main level objects, without connection 
descriptions.    Flatten Outline moves all objects to the left side of the screen and removes 
connection descriptions from the display.

Objects are displayed with coloured text.    Connection descriptions are displayed with 
regular text.

Steps
To view all objects in main level format,
1 Choose Flatten Outline from the List menu.

You can click  next to an object to display connections.

To return to the view before flattening the outline,
1 Choose Undo Flatten from the Edit menu before performing any other actions.

See Also
Collapse Connections
Expand Connections
Promote to Left
Undo
Watch quick tour of Organizing Objects



***DELETED TOPIC***



Go To

Edit, Go To

Purpose
Use Go To to quickly select a different object in the list of objects.

Steps

1 Choose Go To from the Edit menu.
2 Choose from the following options:

          Parent
Move to the parent, or first, object in a group of expanded objects.

          Next
Move to the next item on the line, the next line, the next object, or the next screen.

          Previous
Move to the previous item on the line, the previous line, the previous object, or the 
previous screen.

          Begin of
Move to the beginning of the list, node, or screen.

          End of
Move to the end of the list, node, or screen.

          Scroll
Scroll to the previous line or the next line.

See Also
Keystrokes



Go To Date

Calendar Views, Edit, Go To, Date

Calendar Views, Go To

Purpose
Use Go To Date to quickly move to a particular date in the Calendar View. 

Steps

1 Click Go To .

2 Specify a date in the Date text box.

See Also
Calendar Go To Features



Create or Edit Group Title Field

Object Information, Setup Field, Add New Field, Group Title, OK

Object Information, Group Title Field, Setup Field, Field Properties, Group Title, OK

Purpose
Use Group Title fields to divide and organise the Object or Connection Information dialog 
boxes with a group title pad, which can contain lines and text.    For example, above all of 
your address fields, you could create a group title pad such as "Home Address."

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Group Title field, then 
choose Add New Field.

3 Choose Group Title, type a name for the field, then choose OK.

4 Type a group title in the Group Title text box.

5 Select Left, Right, or Centre to justify the title in the Object Information dialog box.

6 Select Full Width, Right Column, or Left Column to specify the position and length of the 
group title pad.

7 Select Spaces, Single Line, or Double Line to specify the appearance of the group field 
pad, then choose OK.

See Also
Customizing Fields: The Big Picture
Select Field Type to Create or Edit



Hoist

Right-Click Object, Hoist

Select Object, Hoist

Purpose
Use Hoist to focus on one specific object by moving it to the top of a list and clearing all 
other objects from the Outline View.    Example

Steps

1 Select the object you wish to hoist.

2 Click Hoist  on the Toolbar.

You can choose Undo Hoist from the Edit menu to list objects as they were before you 
hoisted.

See Also
Collapse Connections
Expand Connections
Toggle View
Undo
Watch quick tour of Organizing Objects



hoist
To move the selected object to the top of the screen, and expand it once.    All other objects 
are cleared from the list.



Housekeeping

File, Housekeeping

Purpose
Use Housekeeping to perform maintenance on the current iBase.    Doing so can make 
InfoCentral run faster.

Steps

1 Choose Housekeeping from the File menu.

2 Choose one or more of the following options, choose OK, then choose Proceed. 

          Verify iBase Integrity
Check the integrity of the iBase.    If problems are detected, InfoCentral makes the 
necessary corrections.

          Empty the Object Trash Can
Purge all the objects.    You cannot undelete objects after they have been deleted from 
the trash can.

          Empty the Field Trash Can
Purge all the fields in the field trash can.    You cannot undelete fields after they have 
been deleted from the trash can.

          Empty Completed Tasks
Purge all the Task items that you have marked completed in the Calendar.

          Empty Old Calendar Events
Purge any event in the Calendar that occurred prior to the date you specify in this 
option.

          Shred Private Information
Purge any information in the current iBase that is marked private.

          Remove Connections
Purge the connections to external files that InfoCentral can no longer find.



iBase
Short for information base.    A collection of all objects and connections stored on disk under 
a single name.



iBase Password Required

During Startup

Purpose
You must type a password before you can open this iBase.

Steps

1 Type your password, then choose OK.

See Also
iBase Passwords



iBase Passwords

File, Passwords

Purpose
Passwords provide you with a way to limit access to iBases.    There are four different types
of access rights that can be assigned using passwords.    When you try to open an iBase 
with a password, you will be prompted to type the password.

            Remember the password you assign to an iBase.    InfoCentral cannot open the
iBase if you forget its password.

Steps
To create, change, or remove a password,
1 Choose Passwords from the File menu.

2 Type the password(s) you wish to assign for any or all of the following access rights, 
choose OK, re-type the highest level password that you assigned, then choose OK again:

          Read-Only Access
View iBase without making changes.

          Read and Write Access
View iBase and make changes to it. 

          Private Objects
View iBase, make changes to it, and view and make changes to any private objects.

          All of the Above
View iBase, make changes to it (including private objects), and change setup options 
such as passwords.

See Also
iBase Password Required



Create or Select Import Scenario

File, Import, Data

Purpose
Use Import to select an existing import scenario (pattern) or to create a new import 
scenario.

Steps

1 Choose Import from the File menu, then choose Data.

2 Choose one of the import scenarios from the Import Scenario list box, then choose OK.
or
Type a new scenario name in the Import Scenario text box, then choose New Scenario.

See Also
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select Import File
Select First Import Receiving Category
Select Second Import Receiving Category



Check Import Completion

Purpose
Use Import Completed to make sure the import happened the way you wished it to.

Steps

1 Read the information on the dialog box, then choose OK.

See Also
Begin Import
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Importing Data into iBase: The Big Picture
Select Import File
Select First Import Receiving Category
Select Second Import Receiving Category



Begin Import

Check Import Summary, Begin Import

Purpose
Use Begin Import to start the import process and evaluate how the process is going.    You 
can cancel the import process any time during the import.

Steps

1 Choose Begin Import on the Import: Summary dialog box.
or
Choose Cancel if you wish to terminate the import process.

See Also
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select Import File
Select First Import Receiving Category
Select Second Import Receiving Category



Example
Suppose you have an import record with five fields:

Marc Sabatini, Atlantic Metals Inc., President, 4545 Main Street, 123-456-7890

If you have properly created your input file, the Field/Field Value list box should display the 
record above like this:

#1      Marc Sabatini
#2      Atlantic Metals Inc.
#3      President
#4      4545 Main Street
#5      1234567890

Drag Marc Sabatini to the Receiving Field and drop him in the Full Name person field 
location.    Drag Atlantic Metals Inc. and drop it on the Organisation Name location.    Drag 
President and drop it on Job Title.    This record then becomes the template for all other 
records.



Match Import Fields

New Import Scenario, Select Import File, Select Receiving Categor(ies), Select Default
Connection, Import Preferences, OK

Purpose
Use Import: Match Fields to translate input record data into objects, connections, and field 
information. 

Steps

1 Drag field items from the Field/Field Value list box (the items from your input file) and 
drop them in the appropriate locations in the Receiving list box. Example

2 Choose from the following options:

          

Return to the first input record you set up in the Receiving Field.

          

Browse through each input receiving field that you have set up.

          Reset/Revert
Redisplay the lists as they were before you started dragging and dropping items.

          Backup
Go back to the previous dialog box (to change or remind yourself of the settings you 
made).

          iBase Info
Get information about the current iBase.

See Also
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Preferences
Importing Data into iBase: The Big Picture
Select Import File
Select First Import Receiving Category
Select Second Import Receiving Category





Import Categories

File, Import, Structure

Purpose
Use Import Structure to import categories and their information fields from another iBase.  
You cannot import categories that already exist in the current iBase.

            Only object information fields are imported.    No information (data) is 
imported.

Steps

1 Choose Import from the File menu, then choose Structure.

2 Type the name of the category you wish to import in the Category Name text box.

Type ALL in the Category Name text box if you wish to import all the categories in the 
specified iBase.

3 Type the name of the iBase you wish to import the categories from in the From iBase 
text box.

4 Choose Import.

If the categories already exist in the current iBase, InfoCentral will ask you if you wish to
skip the category.

See Also
Create or Select Import Scenario
Edit Object or Connection Information
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture



 Hint
If you wish to stop making connections, or turn the  icon back to the regular mouse 
pointer, click Connect 

 on the Toolbar.



Check Import Summary

File, Import, Data, Import Scenario, Input File, Split Input Record, Match Import Fields, 
OK

Purpose
Use Import: Summary to view or change information about the import scenario you have 
selected.

Steps

1 Read the information about the import summary, then choose Begin Import.
or
Choose from the following options:

          Import Scenario
Rename the import scenario.

          From Record
Select a record to begin the import from.

          Delete Scenario
Delete the import scenario.    Choosing this option returns you to the Import dialog box 
where you can create or select another scenario.

          Setup
Select another import file and different options for the scenario.

See Also
Begin Import
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select Import File
Select First Import Receiving Category
Select Second Import Receiving Category



Import Preferences

File, Import, Data, Input File, Split Input Record, OK

Purpose
Use Import: Add Preferences to specify several import options.

Steps

1 Specify your preferences, then choose OK.

          Consolidate Duplicates
If duplicate information is detected during the import, this option combines the object 
information fields and creates one object.

          Capitalize First Letters
Capitalizes the first letter of each word in an object's name when you add or import an 
object.

          Predict Gender
Predicts whether the object (of person type) is male or female in the person field.

          Predict Formal Name
Suggests an equivalent formal name (for names such as Bob, Mike, and Joe) and inserts 
it in First Name field.

          Predict Informal Name
Suggests a common nickname for names such as Robert, Michael, and Joseph and 
inserts it in the Dear field.

          Generate Default Titles
Predicts the appropriate title (such as Mr., Mrs., and Miss) for person type objects.    You 
can change the default titles.

See Also
Add New Object
Add Preferences
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Edit Object or Connection Information
Exporting iBase Information: The Big Picture
Import Categories
Importing Data into iBase: The Big Picture
Match Import Fields
Name New Object
Select Import File



Select First Import Receiving Category
Select Second Import Receiving Category



Select Default Import or Export Connection

New Import Scenario or New Export Scenario, Split Input Record or Include Connected
Category, OK

Purpose
Use Export or Import: Default Connection to specify the one-way or two-way connection 
description that connects the two categories that you are importing or exporting. 

Steps

1 Select the connection that describes the relationship between the objects you are 
importing or exporting. 
or
Select All Connections to import or export objects in the two categories that are 
connected by any connection description.

If you make a mistake, or change your mind, choose Backup to return to the Import: 
Receiving Category or Export: Category dialog boxes.

2 Choose OK.

See Also
Create or Select Export Scenario
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields
Select First Import Receiving Category
Select Second Import Receiving Category



Select First Import Receiving Category

File, Import, Data, Input File, OK

Purpose
Use Import: Receiving Category to select the categories into which you will import the 
record data from your import file.

Steps

1 Select the category you wish field data to be converted to during the import, then 
choose OK.
or
If you wish one piece of field data to be connected to another piece of data (for 
example, a person and a company), select Split Each Input Record, then choose OK. 
Example

See Also
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Categories
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select Import File
Select Second Import Receiving Category



Select Second Import Receiving Category

New Import Scenario, Input File, Select First Import Receiving Category, Split Input 
Record, OK

Purpose
Use Import: Second Receiving Category to select a category for import record data that 
you plan to connect to the category that you selected on the Import: Receiving Category 
dialog box.

Steps

1 Select the category you wish the second object imported into from the Second Category
to Receive Data list box, then choose OK.

See Also
Begin Import
Check Import Summary
Check Import Completion
Create Import File
Create or Select Import Scenario
Exporting iBase Information: The Big Picture
Import Preferences
Importing Data into iBase: The Big Picture
Match Import Fields
Select Import File



Check your database or spreadsheet documentation for information about exporting records 
in the required format.



Importing Data into iBase: The Big Picture

Purpose
Use Import Data to import data from an exported database or spreadsheet file.    You can 
import data from many popular database and spreadsheet applications.    The data you 
import is translated into objects and connections.

The following tasks illustrate the process of a first time import.
Create Import File

Create Import Scenario

Select Import File

Select First Category

Select Second Category

Select Default Connection

Set Import Preferences

Match Import Fields

Check Import Summary

Begin Import

Check Import Completion



Connect Events and Tasks

Object Information, Connection Field

Select Object, Object, Information, Connection Field

Purpose
Use In Connection With to connect events and tasks from your Calendar to other objects in
your iBase.    Example

Steps

1 Right-click an event or task object, then choose Information. 

2 Click  for Participants, Location, or Delegated To.

3 Choose a letter to list objects of the specified type beginning with that letter.
or
Choose All to list all objects of the specified type.

You can select the Last, First check box to list people according to last name first.

4 Select the object you wish to connect, then click  to move it to the list box on the left.

You can select an object in the left list box, then click  to move it back.

5 Describe how the objects you are including as participants, delegating to, or using a 
location are connected to the event or task.

6 Add Connection Information as necessary.

7 Choose from the following options:

          Connection Info
View connection information for the selected object.

          New Object
Add a new object if the object you wish is not listed.

          Object Info
Change Object Information for the selected object.

See Also
Today's Schedule
Alphabetic Index





Create Related File: Personalise Applications

Right-Click Object, Create Related File

Purpose
Use InfoCentral Personaliser to select the applications that you wish to use to create 
related files (that is, files that you can connect to objects).    You can choose word 
processor, spreadsheet, and graphics applications the first time you use Create Related 
Files.    Should you change applications later, use Create or Edit Related File Type to re-
select your applications.

Steps

1 Select an object, click Related  on the Toolbar, then choose OK.

2 Select the word processor, spreadsheet, and graphics programs you plan to use while 
creating related files.

See Also
Creating Related Files: The Big Picture
Watch quick tour of Creating Related Files



Using InfoScan

File, Import, InfoScan

Purpose
Use InfoScan to convert the address block information in your documents into object and 
connection information in the currently opened iBase.    For example, if you have many 
letters on your hard drive that contain names, organisations, addresses, and phone 
numbers, you can transfer this information into InfoCentral without re-entering it.

            For InfoScan to work properly, you must verify that the address blocks that 
you intend to convert are in the proper format, which is explained below.

Steps
To check proper address block format,
1 Make sure that the address blocks in each document you intend to scan are among the 

first 100 lines of text in that document.

2 Each line of your address blocks must be one of the following 7 types:

Name
Organisation
Address type #1 (Street Address)
Address type #2 (City and/or State)
Phone number
Postcode
Nonaddress (for example, "Apartment #25")

3 The address block must have no fewer than three lines and no more than six lines.    
Each line must be separated by a single hard return.

4 The first line of the address block must be one of the types listed in step 2 above except
the non-address type.
or
A hard return must immediately precede the first line of the address block.

5 A line type can only be used once in an address block. For example, you cannot have 
two organisation lines or two phone number lines.

The following compares those address blocks that InfoScan recognizes, and those it 
doesn't.

          Not Recognized
Marc Sabatini
Sales Division
Atlantic Metals, Inc.
5678 State Street
Mail Stop 222
Icecube, Alaska 87412



          Recognized
Marc Sabatini
Atlantic Metals, Inc.
(907) 555-1000
5678 State Street
Icecube, Alaska 87412

          Not Recognized
Cindy Rafael
CEO
ACME Heaters
(907) 555-2000
1234 Main Street
Icecube,
Alaska 87214

          Recognized
Cindy Rafael
ACME Heaters
1234 Main Street
Icecube, Alaska 87214

Steps
To use InfoScan,
1 Choose Import from the File menu, then choose InfoScan.

2 Type the location of the documents you wish to scan.

3 Select the filename extensions of those files that you wish to exclude from scanning, 
then choose OK.

InfoScan scans your documents and places address block information in the 
INFOSCAN.CSV file.    Commas are used to separate each line, and a hard return is 
placed at the end of the address block.    If no address blocks are recognized, then the 
INFOSCAN.CSV file is deleted.

See Also
Exporting iBase Information: The Big Picture
Import Categories
Importing Data into iBase: The Big Picture



Launch a Program

Menu or Menu Bar Item, Customise Menu Hot Key (F12), Properties of This Menu 
Selection, Launch a Program

Purpose
Use Launch a Program to specify an application you would like to start from a menu or 
menu bar item.

Steps

1 Highlight a menu or menu bar item.

2 Press the Customise Menu Hot Key (F12).

3 Choose Properties of This Menu Selection.

4 Select Launch a Program, then choose OK.

5 In the Command Line text box, type the full pathname of the command you wish to 
launch, then choose OK.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System



list
All objects displayed on a view.



Example
If you specified "Atlantic Metals" on the Add New Object dialog and chose Organisation, you 
can use this dialog box to categorize the object as a Company, Account, or Corporation.



Listing Objects: The Big Picture

Purpose
The InfoCentral Find features can also be used to list objects the Outline View.

Choose from the following options for more information.

          List with FastFind
How to quickly and easily create a list of existing objects with similar characteristics.

          List by Example
How to create a list when you wish to list objects within the same category and with 
similar properties.

          List by Connection
How to find all objects with a similar connection, such as all client/accounting firm 
connections.

          List All Categories
How to create a list of most or all of the objects in your iBase or in a certain category.    
You can then expand the categories to list objects.

          List All Drives
How to list all drives on your computer.    This list can be expanded to display 
subdirectories and files.

          List with Alphabetic Index
How to list objects alphabetically of a particular category.

          List Today's Schedule
How to list the Calendar View schedule in the Outline View.

See Also
Watch quick tour of Organizing Objects



Lookup Area Codes

Tools, Lookup, Area Codes

Purpose
Use Lookup Area Codes to find area codes for locations around the world.    If multiple area 
codes are used within a country or state, area codes for specific regions and cities are also
listed.

Steps

1 Choose Lookup from the Tools menu, then choose Area Codes.

2 Type the country code, then the area code you wish to find.    The code for North 
America is 1.
or
Scroll to the desired area code.

If your modem is set up correctly, you can choose Dial Directory Information to dial 
directory assistance for the highlighted area code.

3 Choose OK.

See Also
Lookup Countries
Lookup States
Modem Preferences
Telephone People and Organisations



Lookup Countries

Tools, Lookup, Countries

Purpose
Use Lookup Countries to find area codes and time zone information for nations around the 
world.    If multiple area codes are used within a country, area codes for regions and cities 
are also listed.

Steps

1 Choose Lookup from the Tools menu, then choose Countries.

2 Type the name of the country you wish to find.
or
Scroll to the desired country, region, or city.

3 Choose OK.

See Also
Address Book
Lookup States
Lookup Area Codes
Telephone People and Organisations



Lookup States

Tools, Lookup, States

Purpose
Use Lookup States to find area codes and time zones for the 50 states.    Canadian 
provinces and U.S. territories are not included.    If multiple area codes are used within a 
state, area codes for specific cities are also listed.

Steps

1 Choose Lookup from the Tools menu, then choose States.

2 Type the abbreviation for the state you wish to find.
or
Scroll to the desired state or city.

If your modem is set up correctly, you can choose Dial Directory Information to dial 
directory assistance for the highlighted state.

3 Choose OK.

See Also
Modem Preferences
Telephone People and Organisations



memo
Text attached to an object (not to be confused with a related file).



Create or Edit Memo Field

Object Information, Setup Field, Add New Field, Memo, OK

Object Information, Memo Field, Setup Field, Field Properties, Memo, OK

Purpose
Use Memo Field fields when you need to type a lot of notes about an object.    For example,
you can set up a "Directions" Memo field under an address field that explains how to find a
particular address.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Memo field, then choose
Add New Field.

3 Choose Memo, type a name for the field, then choose OK.

4 Specify a size for the memo editing window.

5 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Initial Value Calculation
Field Template Format

See Also
Attach Memo
Customizing Fields: The Big Picture



Customise Menu Bar

Menu Bar Item, Customise Menu Hot Key (F12), Properties of this Menu Selection

Purpose
Use Menu Selection Properties to add, edit, move, or delete a menu bar item.

            Before you customise your menu, you should copy all files in your local 
InfoCentral directory with a .MNW extension to another directory for safe keeping.    This 
will let you restore the default menu settings.

Steps

1 Highlight a menu bar item by pressing the Alt key, then using the arrow keys to move 
along the menu bar.

2 Press the Customise Menu Hot Key (F12).

3 If you wish to rename the menu item, type a name in the Selection text box.

4 Choose from the following options:
Write Contextual Hint
Perform a Built-in Command
Sprout New Menu
Launch a Program

5 Choose from the following options:

          Move Selection
Move the menu you highlighted to the Right or Left on the menu bar.

          Add New Selection
Add a new menu bar item to the right or left of the currently highlighted menu bar item.

          Delete Menu Selection
Delete menu bar item you highlighted.

          Paste Selection
Undelete the last menu bar item you deleted.

          Properties
Edit the currently highlighted menu bar item.

See Also
Customise Menu Hot Key
Customise Menu
Load Menu System





Customise Menu

Menu Item, Customise Menu Hot Key (F12), Properties of this Menu Selection

Purpose
Use Menu Selection Properties to customise a menu item (for example, Clear View is a 
menu item on the List menu).

            Before you customise your menu, you should copy all files in your local 
InfoCentral directory with a .MNW extension to another directory for save keeping.    This
will let you restore the default menu settings.

Steps

1 Highlight a menu item.

2 Press the Customise Menu Hot Key (F12).

3 Choose from the following options:

          Properties
Edit the currently highlighted menu item.

          Add New Selection
Add a new menu item above or below the currently highlighted menu item.

          Move Selection
Move the menu you highlighted up or down on the menu.

          Delete Selection
Delete menu item you highlighted.

          Paste Selection
Undelete the last menu bar item you deleted.

          Delete Ruled Separator
Remove the lines that appear above or below a menu item.

4 If you wish to rename the menu item, type a name in the Selection text box.

5 Choose from the following options:
Assign Accelerator Key
Write Contextual Hint
Perform a Built-in Command
Sprout New Menu
Launch a Program

See Also
Customise Menu Bar



Customise Menu Hot Key
Delete Adjacent Ruled Separator
Load Menu System



Searching Numeric Fields

Purpose
Numeric fields include Currency, Date, Fax Line, Modem Line, Telephone, and Time fields.   
You can use relational and logical operators to search for objects with specific information 
in such fields.

            You cannot use Parentheses to group parts of the search string.    You also 
cannot use the asterisk wildcard character for Numeric field searches.

Steps

1 Choose Find-By-Example from the Find menu.

2 Select a category, then choose OK.

3 Choose from the following options, then choose OK:
Date Range Search Examples
Using Logical Operators
Using Logical and Relational Operators
Using Relational Operators



Modem Preferences

Edit, Preferences, Modem

Telephone, Preferences, Modem Preferences

Purpose
Use Modem Preferences to choose the modem type, port, baud rate, dialing method, and 
dialing speed for your modem.

Steps

1 Choose Preferences from the Edit menu, then choose Modem.

2 Specify the settings you wish for your modem.

3 Choose OK.

See Also
Telephone People and Organisations
Create or Edit Telephone or Modem or Fax Line Field
Edit Object Information



Modifying Lists of Objects: The Big Picture

Purpose
You can display a list of objects in many different ways.

Choose from the following options for more information.

          Expand Connections
How to display an object's subordinate objects and related files.

          Collapse Connections
How to close an object's lowest subordinate objects or related files.

          Clear Objects
How to clear one line of objects, all objects, or from a particular object to the end of the 
list.

          Hoist an Object
How to focus on one specific object by moving it to the top of a list and clearing all 
other objects from the Outline View.

          Delete an Object
How to delete an object from your iBase (as opposed to clear it from the view).

          Undelete an Object
How to select from the last several objects you have deleted, then restore them.

          Promote an Object
How to move an object at a lower level in the object list to the next available slot at the 
highest level.

          Flatten Object Outline
How to view all objects as main level objects, without connection descriptions.

          Move Objects in List
How to move the selected object to another location in the list.

          Save List to Tab
How to save a displayed list of objects to a tab (other than the InfoPad tab).

See Also
Watch quick tour of Organizing Objects



Move Object To

List, Move Item To

Purpose
Use Move Item To to move the selected object to another location in the list.

            File, Drive, File Mask, and Date objects cannot be moved.

Steps

1 Select an object in the current iBase.

2 Choose Move Item To from the List menu, then choose from the following options:

          Beginning
Move objects to the top of the list.

          End of List
Move objects to the bottom of the list.

          Next Line
Move objects to the next available first level line in the list.

          Previous Line
Move objects to the previous first level line in the list.

See Also
Go To
Keystrokes
Watch quick tour of Organizing Objects



TravelCentral
This iBase contains information on hotels, airlines, convention centres, restaurants, car 
rental agencies, and more for cities around the world.    The information is focused on 
business travel, rather than tourist information.



Non-Compatible Modem Preferences

Edit, Preferences, Modem Preferences, Non-Compatible, OK

Telephone, Preferences, Modem Preferences, Non-Compatible, OK

Purpose
If you do not have a Hayes-compatible modem, use Non-Compatible Modem Preferences 
to customise InfoCentral so it will work with your modem.

Even though you may have a Hayes-compatible modem, you can use Non-Compatible 
Modem Preferences to gain more control over your modem, or to meet special 
requirements.

Steps

1 Choose Preferences from the Edit menu, then choose Modem.

2 Select Non-Compatible, then choose OK.

3 Make the settings for your modem, then choose OK.

See Also
Modem Preferences
 Your Modem Documentation



Create or Edit Number or Currency Field

Object Information, Setup Field, Add New Field, Number or Currency, OK

Object Information, Time Field, Setup Field, Field Properties, Number or Currency, OK

Purpose
Use Number or Currency fields to include numeric values or currencies in an Object or 
Connection Information dialog box.    For example, suppose you wish to note your 
employees' annual salaries.    You could set up a "Salary" field that displayed a value with 
the currency symbol.    You can set the format of numbers, and use several types of 
currency symbols.

            Changes you make to the currency symbol and format in the Windows 
International Control Panel are not included in a Currency field's Template Format.    Such
changes must be made directly in the Currency field itself.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Number or Currency 
field, then choose Add New Field.

3 Choose Number or Currency, type a name for the field, then choose OK.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Entry Options
Field Initial Value Calculation
Field Template Format
Field Range

See Also
Customizing Fields: The Big Picture



object
A piece of information that has a name and can be related to other things.    Specific people, 
organisations, events, tasks, and places can all be objects.



Edit Object or Connection Information

Right-Click Object, Information

Right-Click Connection, Information

Purpose
Use Object Information or Connection Information to add information about an object or 
connection.    You can also create, edit, or delete information fields, print field information, 
and change categories.    Later, when you wish to find information, you can search for 
information in specific fields using the Find By Example options.

            Exercise caution while creating, editing, or deleting fields or changing 
categories.    Changes made to one object will affect all other objects in the same 
category.    Before you change a field, consider the other objects that may use the field.

Steps

1 Highlight an object or connection description, then click  on the Toolbar.

2 Type information you wish in the fields. 

Use the scroll bar on the right of the dialog box (if available) to view more information 
fields.

3 Choose from the following options, then choose OK:
Attach Memo
Calendar Tool
Find-By-Example
In Connection With
Print Object Information
Select Category
Create or Edit Field
Zoom or Unzoom



Searching Selectable Fields

Purpose
Because selectable fields include check box and radio button fields, no variables or 
operators are used.    Instead, you simply select the check box or radio buttons and 
InfoCentral finds all objects with those that are selected.

Choose from the following from the following for more information.

          Radio Button Searches
If you wish to search for all your priority 2 tasks, you would select priority 2 in the Find-
By-Example: Enter Criteria dialog box.    If you wish to find all task objects regardless of 
priority, select the ALL radio button.

          Check box Searches
Suppose you wish to search for all appointments that have alarms set.    Simply select 
the alarm check box of those appointment objects you wish to search for in the Find-By-
Example: Enter Criteria dialog box.

See Also
Searching Numeric Fields
Searching Text Fields



Logical Operators

Purpose
The following logical operators can be used in either Text or Numeric type fields.    You can 
use three kinds of logical operators.    Note that you can use logical operators with the 
asterisk wildcard character:

          AND
Used if both sides of the statement is true.    For example, the statement "J* AND *n" in a
First Name field would find all persons with the first name John, Joan, Johann, JoAnn, 
Jason, Jordan, and so on.

          OR
Used if either side of the statement is true.    For example, the statement "J* OR K*" in a 
Last Name field would find all persons with last names that begin with either J (Jameson,
Johnson, Jones, or Jerzinski) or K (Keith, Kray, Kirk, Knudsen, or Kwong).

          NOT
Used if only one side of the statement is true.    For example, the statement "J* NOT *n" 
in a First Name field would find all persons with first names that begin with J and do not 
end with N (Jake, Jack, Jose, Janet, Jesse, Jessica, and Jane, but not John, Joan, JoAnn, or 
Jordan).

See Also
Date Range Search Examples
Searching Numeric Fields
Searching Selectable Fields
Searching Text Fields
Using Logical Operators
Using Logical and Relational Operators
Using Relational Operators



Paste Special

Select Object, Edit, Paste Special

Purpose
Use Paste Special to describe the OLE 2.0 compatible object that you wish to connect to 
an object in your iBase.    You can embed the object, or you can create a paste link.

Steps

1 Minimize InfoCentral and start an OLE 2.0 compatible application.

2 Create the document, graphic, or other file as you normally would.

3 Copy the file to the Windows Clipboard, then exit the application.

4 Maximize InfoCentral, select an object, then choose Paste Special from the Edit menu.

5 Type a description in the Description text box.

6 Select Paste (Embed) or Paste (Link), then choose OK.

Note that OLE objects have a  icon next to them.

See Also
Connect Multiple Object
Connect Object
Create Related File



Open File

File, File Properties, Open

Purpose
Use Open File to open a file object listed in the Outline View.      If you open a data file, the 
Windows application it is associated with will open and retrieve the file.    If the file is an 
executable (for example, .EXE, .COM, .BAT), the file will execute.

Steps

1 Right-click a file object.

2 Choose Open.



Paste

Edit, Paste

Purpose
Use Paste to retrieve the contents of the Windows Clipboard.    For example, you can cut 
an object in one tab, select another tab, and paste the object.

Steps

1 Place the insertion point where you wish to paste the information.

2 Click  on the Toolbar.

See Also
Copy to Clipboard
Cut
Paste Special



Perform a Built-In Command

Menu or Menu Bar Item, Customise Menu Hot Key (F12), Properties of this Menu 
Selection, Perform Built-in Command

Purpose
Use Perform a Built-in Command to link a menu or menu bar item with one of InfoCentral's
many internal commands.

Steps

1 Highlight a menu or menu bar item, then press the Customise Menu Hot Key (F12).

2 Choose Properties of this Menu Selection.
or
Choose Add New Selection Above or Below.

3 Select Perform a Built-in Command, then choose OK.

4 Type the first few letters of the command.
or
Select a command from the list box, then choose OK.

Note that descriptions for the commands appear at the bottom of the dialog box as you 
scroll through the list.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Sprout New Menu
Launch a Program
Load Menu System



Relational Operators

Purpose
Use relational operators for general searches.    While the best use of relational operators 
is for Numeric fields like Currency, Date, and Time, you can also use them for some Text 
field searches.    The following is a list of all the relational operators with examples of each.

            Relational operators should be followed by a variable or string that is 
surrounded by quotes, for example ="7/9/95".    You cannot combine relational operators
with the asterisk (*) wildcard.

          =
Finds all objects with field information equal to the string or variable.    For example, 
="7/9/95" in a date search field finds objects with 7/9/95 in that date field; ="" finds all 
objects that do not contain information in the field.    This operator is also ideal for 
finding Fax, Modem, or Telephone fields that contain no number.

          >
Finds all objects with field information greater than the string or variable.    For example, 
>"7/9/95" finds all objects with dates after but not including 7/9/95 in that date field; >1
in any text box finds any object that contains any information in that field.    This 
operator is ideal if you wish to find Fax, Modem, or Telephone fields that contain a 
number.

          <
Finds all objects with field information that is less than the string or variable.    For 
example, <"7/9/95" finds all objects with dates before but not including 7/9/95 in that 
date field.

          <=
Finds all objects with field information that is less than or equal to the string or variable. 
For example, <="7/9/95" finds all objects with dates before and including 7/9/95 in that 
date field.

          >=
Finds all objects with field information that is greater than or equal to the string or 
variable.    For example, >="7/9/95" finds all objects with dates after and including 
7/9/95 in that date field.

          ><
Finds all objects with fields not equal to the string or variable.    For example, ><"smith" 
in a name search field finds all people not of the name "Smith"; ><"" in a search field 
finds all objects that contain something in that field.    This operator is also ideal for 
finding Fax, Modem, or Telephone fields.

See Also
Logical Operators
Logical with Relational Operators





Previous Tab

View, Previous Tab

Purpose
Use Previous Tab to go to the last tab that was displayed.

Steps

1 Choose Previous Tab from the View menu.

See Also
Previous View
Tab Index



Print Address Book

File, Print, Address Book

Purpose
InfoCentral keeps track of all the addresses you enter when you add objects.    Use Print 
Address Book to print out a list of these addresses.    You can specify which information you
wish to print from the address book.

Steps

1 Choose Print from the File menu, then choose Address Book.

2 Type the number of copies you wish in the Copies text box.

3 Choose from the following options, then choose Print:

          Print
List people alphabetically.

          Organisations
List organisations alphabetically.

          Persons & Organisations
Include both people and organisations in the alphabetical list.

          Connected Persons
Print a list of connected people beneath each person or organisation in the list.

          Connected Organisations
Print a list of connected organisations beneath each person or organisation in the list.

          Former/Future Connections
Show connections that are no longer or not yet valid.

          Entire iBase
Include all objects in the iBase in the printed address book.

          Current Tab (As Listed)
Print only those people or organisations listed on the current tab, in the order shown.

          Current Tab (Sorted)
Print only those people or organisations listed on the current tab, in alphabetical order.

          Those Telephoned in Last X Months
Print only those people or organisations who have a telephone call event connected to 
them that falls within the specified time.



          Those with Field X
Print only those people or organisations whose information dialog boxes contain a 
specific field name.

          Set to X
Print only those people or organisations whose information dialog boxes contain this 
text in the specific field named above.

See Also
Print Address Book (Options)
Print Margins (Options)
Setup Printer
Restore Default Print Options



Right-Click Method

Purpose
Use the right-click method throughout InfoCentral to access QuickMenus, and to edit 
objects, categories, connections, fields, and tabs.

Steps

1 Move the mouse pointer to an object, field, or connection.

2 Click the right mouse button.
or
If you have set up your mouse for left-handed use, click the left mouse button.

See Also
Select Object



Print Current Tab

File, Print, Current Tab

Purpose
Use Print Current Tab to print objects displayed on the current tab.

Steps

1 Click  on the Toolbar.

2 Type the number of copies you wish in the Copies text box.

3 Choose Print.

See Also
Print Current Tab (Options)
Print Margins (Options)
Setup Printer
Restore Default Print Options



WineCentral
This iBase contains information on fine wines of the world.    Organised by growing region, 
the information includes vineyards, wineries, labels, price ranges, classifications, and 
festivals.



Example
You can type hints such as "Include the Territory Code" or "Enter Driver's Licence Nbr if no SS
Nbr".    For a menu item Help prompt, type something such as "Starts My Favorite Windows 
Application".



Example
Suppose you are going to add objects that have the same values in a field (for example, a 
group of objects that have the same state or country information).    When you begin to add 
a group of such objects, change the value on the first new object and it will be reused for 
each subsequent new object until you change the value again.



Print Mailing Labels (Options)

File, Print, Mailing Labels, Options

Purpose
Use Options from the Print Mailing Labels dialog box to customise how labels print and 
which object addresses are used.

Steps

1 Choose Print from the File menu, then choose Mailing Labels.

2 Choose Options.

3 Choose from the following options:

          Restart From Currently Selected Item
Start printing labels beginning with the currently selected object.

          Skip Labels on First Sheet
Skip the designated number of labels on the first sheet printed.

          Prompt when more than one address is known
Select an address if more than one address is listed for an object.

          Always use home address when available
Use the address entered in the home address field of an object.    If there is no address 
in this field, the organisation address or any other available address is used.

          Always use organisation address when available
Use the address entered in the organisation address field of an object.    If there is no 
address in this field, the home address or any other available address is used.

See Also
Print Mailing Labels
Printing iBase Information: The Big Picture
Setup Printer



Print Mailing Labels

File, Print, Mailing Labels

Purpose
Use Print Mailing Labels to print labels for all objects with expanded connections in the 
current      Outline View.    Unexpanded objects are not printed.

Steps

1 Choose Print from the File menu, then choose Mailing Labels.

2 Select the type of label you are using from the Type of Label list box.

3 Choose Test Print if you wish to see where the labels will print on the page. 

4 Choose Print All Pages to print an address label for each object on the current tab.

If an object doesn't have an address, a label is printed with only the name of the object.
See Also

Edit Object Information
Print Address Book
Print Calendar
Print Current Tab
Print Mailing Labels (Options)
Print Object Information
Printing iBase Information: The Big Picture
Setup Printer



Print Object Information

File, Print, Object Info

Object Information, Print

Purpose
Use Print Object Information to print the information for a selected object, for all objects in
the Outline View, or for all objects in the iBase.

Steps

1 Choose Print from the File menu, then choose Object Info.

2 If you wish more than one copy, type the number of copies you wish in the Copies text 
box.

3 Choose from the following options, then choose Print:

          Current Item
Print the Object Information dialog box for the selected item.

          Current Tab (As Listed)
Print the Object Information dialog box for each object listed on the current tab.

          Current Tab (Sorted)
Print the Object Information dialog box for each object listed on the current tab, in 
alphabetical order.

          Entire iBase
Print the Object Information dialog box for each object in the current iBase.

          Those with Field Set To
Print only those Object Information dialog boxes with specific information. Example

See Also
Edit Object Information
Print Address Book
Print Calendar
Print Current Tab
Print Mailing Labels
Print Margins (Options)
Print Object Information (Options)
Printing iBase Information: The Big Picture
Restore Default Print Options



Print Object Information (Options)

File, Print, Object Info, Options

Object Information, Print, Options

Purpose
You can change object information printing options to customise the way the printed 
property forms appear.

Steps

1 Choose Print from the File menu, then choose Object Information.

2 Choose Options.

3 Choose from the following options:

          Layout Size
Specify the size of the printout.    The sizes indicate the relative size of the printout, not 
the paper size.

          Include
Specify whether to include a cover page, fields that are empty, and any memos 
attached to the property dialog box.

          Print Odd/Even
Print only odd, only even, or both odd and even pages. 

          Options
Specify whether to print each Object Information dialog on a new page and whether to 
alternate headings on left and right margins.

See Also
Edit Object Information
Print Object Information
Print Margins (Options)
Printing iBase Information: The Big Picture
Restore Default Print Options
Setup Printer



Restore Default Print Options

File, Print, Address Book; Calendar; Current Tab; or Object Info, Restore

Purpose
Use the Restore option to return to InfoCentral default printing options after making 
changes.

Steps

1 Choose Print from the File menu, then choose Address Book, Calendar, Current Tab, or 
Object Information.

2 Choose Restore, then choose OK.

See Also
Print Address Book
Print Address Book (Options)
Print Calendar
Print Calendar (Options)
Print Current Tab
Print Current Tab (Options)
Print Mailing Labels
Print Mailing Labels (Options)
Print Margins (Options)
Print Object Information
Print Object Information (Options)
Printing iBase Information: The Big Picture
Setup Printer



Setup Printer

File, Print, Address Book; Calendar; Current Tab; Mailing Labels; or Object Info, Select

Purpose
Use Print Setup to specify a printer and set printer options.

Steps

1 Choose Select from the Address Book, Calendar, Current Tab, Mailing Labels, or Object 
Information Print dialog boxes.

2 Choose the options to set up your printer, then choose OK.

See Also
 Windows Printer Setup documentation



Printing iBase Information: The Big Picture

Purpose
You can print the information in your iBase in a variety of ways.

Choose from the following options for more information:

          Print Address Book
How to print the names, addresses, and phone numbers of persons, 
organisations, and their connections.

          Print Calendar
How to specify a range of dates to print; set margins, layout size, and odd and
even printing.

          Print Current Tab
How to print the currently displayed tab as it appears and control margins, 
layout size, and odd and even printing.

          Print Mailing Labels
How to print address blocks from the objects in the current Outline View.    You
can choose the type of label you wish to print on (Avery, 3M, and so on) and 
set other options.

          Print Object Information
How to print the information for a selected object, for all objects in the 
Outline View, or for all objects in the iBase.

          Setup Printer
How to set up your local or network printer.



Promote to Left

Right-Click Object, Promote to Left

Purpose
Use Promote to Left to move an item at a lower level in the object list to the next available
slot at the highest level.

Steps

1 Select the object you wish to promote, then choose Promote to Left from the List menu.

See Also
Flatten Outline
Move Object To
Watch quick tour of Organizing Objects



Print Margins (Options)

File, Print, Address Book; Calendar; Current Tab; Mailing Labels; or Object Info, 
Margins

Purpose
Use the Print Margins option to set different margins for printed pages.

Steps

1 Choose Print from the File menu, then choose Current Tab, Address Book, or Object 
Information.

2 Choose Margins.

3 Specify the desired margins in the Left, Right, Top, and Bottom text boxes, then choose 
OK.

Note that margins are set according to the Layout Size.

See Also
Print Address Book (Options)
Print Calendar (Options)
Print Current Tab (Options)
Print Mailing Labels (Options)
Print Object Information (Options)
Restore Default Print Options



radio button
One of a set of buttons found next to options in a dialog box.    Only one radio button in a set 
can be selected at a time.



Create or Edit Radio Button Field

Object Information, Setup Field, Add New Field, Radio Button, OK

Object Information, Radio Button Field, Setup Field, Field Properties, Radio Button, OK

Purpose
Use Radio Button fields to set up a range of choices.    For example, suppose you wish to 
note how expensive a restaurant is.    You could set up radio buttons for "Expensive," 
"Moderate," and "Inexpensive."    Only one radio button choice can be selected at a time.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Radio Button field, then 
choose Add New Field.

3 Choose Radio Button, type a name for the field, then choose OK.

4 Type descriptions in the Description text boxes for each Choice.

5 If you wish a Choice to be selected as the default, select Default for that radio button.

6 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Initial Value Calculation

See Also
Create or Edit Task Priority Radio Button Field
Customizing Fields: The Big Picture



related file
A file, such as a document, letter, graphic, or worksheet, that is connected to one or more 
objects in an iBase.    Related files are created with applications other than InfoCentral.



Reminder of Remote iBase

During Startup of Host or Remote iBase

Purpose
Use Reminder to remind you that a copy of the iBase exists and that this is either the host 
or remote edition.

Steps

1 Read the information, then choose OK.

See Also
Abandon Remote iBase
Check In Remote iBase
Check Out Remote iBase



Example
This is useful when a field is to contain a string of numbers for non-mathsematical purposes. 
For example, a US Social Security Number (for example, ###-##-####).    If you wish a 
mathsematical value in the field, you'd need a decimal point and the hyphen would be used 
to indicate a negative value.



Save iBase

File, Save

Purpose
Use Save to save the current iBase.    You should make frequent backups of your iBase.

Steps

1 Click  on the Toolbar.

See Also
Selecting Files and Directories: The Big Picture



Example
For example, suppose you set up an initial value that automatically inserts today's date into 
the date field of a Meeting object.    The date will remain in the field the next time you view 
the field.



Find-By-Example: Using the Asterisk Wildcard Character

Purpose
Use the asterisk (*) wildcard to find objects that contain words or word strings that begin 
or end with specific letters.    For example, if you type f* in the First Name field of a person 
object, InfoCentral would find all people with the first name that begins with F, that is, 
Frank, Francis, Fergus, Fanny, and so on.

Here are some more examples of wildcard uses:

          Finding Words That Begin with Specific Text
An asterisk at the end of a text string finds all words or word strings that begin with the 
text string.    For example, wat* could find all people named Watson, all organisations 
named Watts Electronics, or all place/thing object named Water Bill for July, etc.).

          Finding Words That End with Specific Text
An asterisk at the beginning of a text string finds all words or word strings that end with 
the text.    For example, *inc could find all organisations that end in "Inc." such as Inc. 
and Jordan River Inc., but not Inc. Magazine.

          Finding Whole Words
Asterisks on both sides of a text string find whole words or words that begin with the 
specified text string.    This is especially useful for Memo fields, where you may be 
looking for a word within many words.    For example, *ships* finds "we were two ships 
passing in the night" but not "relationship."    Typing *g* finds Guy Smily, Greta Sacchi, J.
Paul Getty, and Alfred Von Guttenberg, but not Jorge.

See Also
Logical Operators
Relational Operators



Date and Time Functions

Purpose
Use Date and Time Functions to automatically fill in fields with date and time information. 
Example 1 Example 2 Example 3

Choose from the following functions for more information:
XDAYS
XDATE$
XSECS
XTIME$

See Also
Create Related File: Standard System Variables
Date and Time Functions
Field Initial Value Calculation
Logical Operators
Logical Operators with Relational Operators
Mathsematical Operators
Miscellaneous System Variables
Relational Operators
String Functions
System Date and Time Variables
Variable Functions



Using Format Template Functions

Purpose
Use a Format Template function to include the Field Format Template as part of the string. 
Example

Steps

1 Type the format template function you wish in the Initial Value Calculation text box, then
choose OK.

See Also
Field Initial Value Calculation
Field Template Format



drag
To move or connect an object by positioning the pointer on the item you wish, pressing the 
mouse button, moving the mouse, then releasing the mouse button.



Search External Files (Specify Criteria)

Find, Search External Files

Purpose
Use Search External Files or Search Criteria to specify the criteria that will be used to 
search your hard drive or network for files.

Steps

1 Choose Search External Files from the Find menu.

2 Type the path, filename, and extension parametres in the Show Files Matching text box.
or
Choose Browse to find the files you wish.

3 Choose from the following options, then choose OK.
or
Choose Make Default to make the current settings the default for all subsequent 
searches, until you change them again.

          Text to Search for
Search for text in files with conditional search parametres. Example

          Ignore Case
List files containing the text of the string in upper case, lower case, and mixed case.

          Whole Words Only
Search for separate words, not text strings that are part of other words.

          Last Update Date
Limit the search to specific dates. 

          Last Update Time
Limit the search to specific times.

          File Size
Limits the search to specific file sizes.

          Set
Search for files that have the Read-Only, Archive, System, Hidden attribute.

          Not Set
Search for files that do not have the Read-Only, Archive, System, Hidden attribute.

          Either
Ignore Read-Only, Archive, System, Hidden attributes.



          Files to Skip
Define up to 40 file extensions to skip during the search.

          Make Default
Makes the current settings the default for all searches.

See Also
FastFind
FastFind Files
Find-By-Example
Find By Category
Find-By-Connection
Watch quick tour of Finding Objects



Securing and Cleaning Up My iBase: The Big Picture

Purpose
InfoCentral offers several options to help you secure the data in your iBase, maintain its 
integrity, and keep informed of overall changes.

Choose from the following options for more information.

          Set iBase Passwords
How to secure your iBase with four different levels of passwords.

          Do Housekeeping on iBase
How to clean up, optimize, and verify the integrity of your iBase.

          View iBase Information
How to get information about the current iBase.

          View System Status
How to get information about the system status of InfoCentral.



Select Different Field

Object Information, Setup Field

Connection Information, Setup Field

Purpose
Use Select Different Field to select a field in the Object Information or Connection 
Information dialog box.

Steps

1 Right-click a field in the Object Information or Connection Information dialog box.
or
Choose Setup Field.

2 Choose Select Different Field.

3 Move the arrow keys to a different field, then press Enter.

See Also
Edit Object Information



Example
You may have a Total Nights field with an initial calculation of:

XDAYS(Leave_Date)XDAYS(Arrive_Date)

As new objects are added, this formula gives the difference, in days, between the two dates.



Select Category

Edit, Categories

Purpose
Use Select Category to select the category you wish to edit.    You can also create a new 
category.

Steps

1 Choose Categories from the Edit menu.

2 Select a category, then choose Setup Category to edit it.
or
Type a new category name in the Select Category text box, then choose New Category.

3 Choose Close.

See Also
Create or Edit Category



Selecting Files and Directories: The Big Picture

Purpose
Use the select file and directory features to browse files and directories, and select files of 
a particular type.

Choose from the following options for more information.

          Name New iBase
How to specify the name a new iBase.

          Open iBase
How to open an iBase that has already been created.

          Select Import File
How to specify the file you wish to import into your iBase.

          Select Export File
How to specify the file to which you wish to export iBase information.

          Browse Files and Directories
How to look through your hard drive or network to find the files you need.



Create Related File: Select Field Object

Right-click Object, Create Related File, New Type or Setup Type, Setup Related File, 
Default Text, Field from an Object

Purpose
Use Select Field Object to specify the category and field that you wish to extract 
information from during the process of creating a related file.    Example

Steps

1 Right-click an object, then choose Create Related File.

2 Choose New Type or Setup Type, then choose Default Text.

3 Choose Field Object.

4 Select a category, select a category field, then choose OK.

See Also
Create Related File: Create or Edit Default Text
Watch quick tour of Creating Related Files



Create Related File: How a File is Created

When you create a related file, InfoCentral switches to the application if it's already running, 
or launches it if it's not running.    If you have specified any special keystrokes or default text 
for the related file type, they are sent to the application just as if you were typing them.

InfoCentral creates a name for the new file based on the first two characters of the first two 
words of the object you are creating a related file for.    For example, if you highlighted Kate 
Robinson, InfoCentral would start the filename with "KARO."    If you had already created a 
related file for Karen Robertson, whose files would also start with "KARO," then InfoCentral 
would use "K2RO" for Kate so her files would start differently than Karen's.    Rather than use 
random names or sequential numbers for the new files you create, InfoCentral uses this 
mnemonic scheme to embed a little bit of meaning in the filenames it creates for those 
times when you're searching subdirectories of DOS outside of InfoCentral.

The four character mnemonic ("KARO" or "K2RO" in the above example) is referred to as the 
"File Tracking ID" for an object and is stored in the object in a field named File Tracking ID at 
the bottom of the Object Information dialog box.    If you change the characters in this field 
for an object, InfoCentral will use these new characters as the first characters of new files 
created for this object.    Changing this field only changes the mnemonic used for future 
related files, and does not effect or disturb the names of related files you have already 
created and connected to an object.

The next four characters of a related file filename are assigned by InfoCentral based upon 
the date on which the file is created.    If the date is May 20th, 1994, it would add "4520" ("4"
for 1994, "5" for the 5th month of the year, and "20" for May 20th) to create a filename like 
"KARO4520" or "K2RO4520."    The 4 in "4520" stands for 1994, the 5 for May, and the 20 for
the 20th of May.    What about the months of October, November, and December?    They're 
represented as A, B, and C.    For example, November 3rd, 1994 would be "4B03."    Such 
naming conventions will help you locate files more easily later.

Finally, InfoCentral adds a filename extension to the new filename it's creating based on the 
settings you have made in the Advanced Options dialog box.    If you're creating a document 
in WordPerfect 6.1 for Windows, ".WPD" is added, while ".XLS" might be added if you're 
creating a spreadsheet with Microsoft Excel, or ".SHW" if you're creating a slide show 
presentation in WordPerfect Presentations.

If you wish to change the default extension that InfoCentral assigns to related files, note that
the filename extension used in naming a new file is associated with one particular Windows 
application.    This is because when files are launched in Windows (and InfoCentral), the 
application that is called upon to launch the file is determined by this extension.    When you 
double-click a file named "KARO4415.DOC," Windows launches the file by looking up the 
file's extension ".DOC" in the [Extensions] section of the WIN.INI Windows control file, which 
is usually located in your Windows directory.    If the extension ".DOC" is associated there 
with WordPerfect for Windows, then the file is launched in WordPerfect for Windows.    
Likewise, if the extension ".DOC" is associated in the WIN.INI file with Word for Windows, 
then the file is launched in Word for Windows.    Windows allows only one application to be 
associated with each filename extension in the WIN.INI control file.    In other words, you 
should keep your filename extensions unique to each Windows application you use.

 



Select Type of Object

Add (Name Then Categorize), Specify Person; Organisation; Place/Thing; or Event

Purpose
Use Select Type of Organisation, Thing, or Event to categorize an object. Example

Steps

1 Click Add  on the Toolbar.

2 Choose Person, Organisation, Place/Thing, or Event.

3 Select a category from the list box.
or
Type a new category in the Select text box, then choose New Category to create a new 
category.
or
Select a category, then choose Setup Category to edit the category.

4 Choose OK.

See Also
Create or Edit Category



Set an Alarm

Right-Click Event Object, Alarm Status

Purpose
If you have created a meeting or event object, you can set an alarm to remind you of the 
event or task.

Steps

1 Right-click an event object, such as a meeting.

2 Select the Alarm Notification check boxes for the advanced warning times you wish.    
You can select more than one advanced warning time.

3 Choose OK.

See Also
Add an Event Object
Add Task Object
Create or Edit Alarm Notification Check Boxes



Setting Preferences: The Big Picture

Purpose
InfoCentral lets you customise just about everything from the way alarms sound to how 
your menus are structured.

Choose from the following options for more information:

          Add Preferences
How to set options for the way objects are added, including duplication checks, gender 
prediction, and default titles.

          Alarm Preferences
How to choose the way the alarm sounds.

          Calendar Preferences
How to change the time interval for the Day, Week, and Outline Views.

          Connections Preferences
How to set the way connections are handled as you add objects.

          Daylight Saving Time
How to set Daylight Saving Time, or turn it off.

          Display Preferences
How to change the appearance of the Toolbar, choose the colour for objects and non-
objects, turn tabs on or off, and set Zoom settings.

          Customise Menu Hot Key
How to choose the key you wish to use for customizing menus.

          FastFind Preferences
How to set messages and sounds that will help you find objects.

          Load Menu System
How to specify a file that contains your own customised menu structure.

          Modem Preferences
How to make settings for your modem, even if it is not Hayes-compatible.

          Name Preferences
How to set the way names are handled while you add them.

          Telephone Preferences
How to specify settings such as country codes, area codes, prefixes, suffixes, and 
internal PBX numbers.



          Viewing Date Preferences
How to view your iBase as if you were looking at it in the past or future.



Edit File Mask Properties

FastFind Files, Drive Letter *.*, Find Files, Object, Information

Purpose
When you display drive letters (for example, O:\*.*) in the Outline View you may not know 
what the drive contains.    To make drive letters more meaningful, use File Mask Properties 
to attach a description to the drive file mask.    For example, if a drive contains all of your 
company's reports, and it is mapped to W:\*.*, type Company Reports in the Edit File 
Mask Properties dialog box.    Descriptions appear with the drive letter in the Outline View.

Steps

1 Right-click a drive letter that has the *.* wildcard characters.

2 Choose Information.

3 Type a short description for the drive letter, then choose OK.

See Also
Describe Related File
Edit File Information
Edit Object Information
FastFind



Add an Event Object

Calendar, Add, Event or Meeting, OK

Purpose
Use Add to schedule or add an event type object (for example, a meeting) to your 
Calendar View or to Today's Schedule. 

Steps
To add an event to the Calendar View,
1 Choose View Calendar from the View menu, then click Day  or Week 
.

2 Double-click the time you wish to schedule an event.

3 Select the event category you wish, then choose OK.

4 Specify information about the event, then choose OK.

To add an event to Today's Schedule,
1 Double-click the time you wish to schedule an event.

2 Select the event category you wish.

3 Specify information about the event, then choose OK.

See Also
Add Task Object
Connect Events and Tasks
Create or Edit Alarm Nofification Check Boxes
Create or Edit Category
Set an Alarm
Today's Schedule



WordPerfect Main Street Products

Purpose
WordPerfect Main Street products offer exciting ways to help you be more productive at 
home, school, and at the office.

Choose from the following options for more information.

WordPerfect Works
LetterPerfect
ExpressFax
Grammatik
Kap'n Karaoke
Random House Webster's School and Office Dictionary
WordPerfect Clip Art Premium Collection
WordPerfect Clip Art for the Office
WordPerfect Clip Art for Home
WordPerfect Clip Art for Kids
Wallobee Jack



WordPerfect Works
The easiest way to write, budget, file, draw, and paint:    A complete small office suite, 
WordPerfect Works includes word processor, spreadsheet, database, communications, and 
graphics applications.    Available for Macintosh, Windows, and DOS.



LetterPerfect
Big WordPerfect features in a small package:    A slimmed and simplified word processor 
application, LetterPerfect is just right for students, people with limited space on their hard 
disk, and those with light document creation needs.    Available for Macintosh and DOS.



ExpressFax
The easiest way to send and receive fax and data:    A complete communications application,
ExpressFax+ lets you access online services as well as turning your computer into a fax 
machine.    The correct modem hardware is, of course, required. Available for Macintosh and 
Windows.



Grammatik
The easiest way to improve your writing:    A sophisticated grammar checker, Grammatik can
be adapted to give you specific advice for different writing styles like business letters, 
memos, and so on.    Available for Macintosh, Windows, and DOS.



Random House Webster's School and Office Dictionary
Quick and easy definitions:    A complete online version of the dictionary, this product also 
lets you look up words by their definition.    It even helps you with spelling.    Available for 
Macintosh and Windows.



WordPerfect Clip Art Premium Collection
The easiest way to draw attention:    The Premium Collection has over 4,000 brilliant images 
on CDROM.    The pictures can be used with any application that accepts graphics.    Available
on CDROM for Macintosh and Windows.



WordPerfect Clip Art for the Office
The best way to improve your business image:    This package has hundreds of images for 
business use.    The pictures can be used with any application that accepts graphics.    
Available for Macintosh and Windows.



WordPerfect Clip Art for Home
Add pizazz to birthday cards, invitations, and more:    This package has hundreds of images 
for home use.    The pictures can be used with any application that accepts graphics.    
Available for Macintosh and Windows.



WordPerfect Clip Art for Kids
Big help for the small artist: This package has hundreds of delightful images designed for 
children.    The pictures can be used with any application that accepts graphics.    Available 
for Macintosh and Windows.



Wallobee Jack
Interactive cartoon adventures:    A world of adventure for the whole family on a CDROM.    
Wallobee Jack titles like "The Bingi Burra Stone" and "The Thai Sun Adventure" are a great 
way to introduce children to a computer.    Available on CDROM for Macintosh and Windows.



Kap'n Karaoke
Sing along to your favorite tunes:    An easy interface and exciting sound effects make this 
product exciting fun for all ages.    Plays all general MIDI files.    Available for Macintosh and 
Windows.



Add Task Object

Calendar, Add, Task, OK

Purpose
Use Add to note and prioritize a task in your Calendar View.

Steps

1 Choose View Calendar from the View menu, then open the Calendar Day View.

2 Select Tasks on the day view scheduler.

3 Double-click in the Task Display list (located under the Task radio button).

4 Select the type of task, then choose OK.

5 Name the task (for example, "Buy Groceries"), then choose OK.

6 Specify information about the task, such as a follow-up date, and a priority.

You can also type notes about the task in the Notes text box.

7 Choose OK.

See Also
Add an Event Object
Connect Events and Tasks
Create or Edit Task Priority Radio Button Field
Create or Edit Category
Follow Up on Tasks
Set an Alarm



 Hint
You can change the template iBases to suit your needs.    You can rename the sample objects
and edit the information on them to reflect real objects, or you can delete the sample 
objects from the iBase. You can also export the structure of the templates and import that 
structure into another iBase.



Prioritize Tasks

Right-Click Task Object, Priority Field

Purpose
Use the task priority field to prioritize the tasks in your Calendar.    The Task Display list 
tasks according to the priority you select.

Steps

1 Right-click a task object.

2 Select the priority level you wish to assign to this task.

3 Choose OK.

See Also
Add an Event Object
Add Task Object
Connect Events and Tasks
Create or Edit Task Priority Radio Button Field
Create or Edit Category
Set an Alarm



Delete Notes

Purpose
You can delete the notes in the Notes for the Day display area in the Calendar Day or 
Week View.

Steps

1 Highlight the notes you wish to delete.

2 Press Delete.

See Also
Undelete
Undo



Logical Operators with Relational Operators

Purpose
The following examples show you how to combine logical operators with relational 
operators, which can be a useful method for pinpointing a certain range of information.

          Example 1
Suppose you wish to find all the people in your iBase that live in certain postal code 
areas.    To do so, you could type >"84056" AND <"84059" in the Postal Code date 
search field.

          Example 2
Let's say you need to list all the appointments that fall within August 1, 1994 and 
August 5, 1994.    To do so, type >"8/1/94" AND <"8/5/94" in a Date search field.

          Example 3
Suppose that you wish to find all your meetings for the week of March 2027.    Type one 
of the following in a Date search fields:

>="3/20/94" AND <="3/27/94"
>"3/19/94" AND <"3/28/94"

          Example 4
Suppose you wish to list your schedule of appointments for a two week period except 
the three day July 4th weekend.    Type the following in the appointment's date search 
field:

>"6/26/94" AND < "7/2/94" OR > "7/4/94" AND < "7/9/94"

See Also
Relational Operators



Log a Phone Call

Purpose
You can keep track of your phone calls by adding a telephone call event object.

Steps

1 Select a person or organisation object.

2 Click Telephone  on the Toolbar.

3 Choose Log Call.

4 Specify information about the phone call, such as a description (for example, "Chat with 
My Broker"), the date of the call, and a reminder of when you need to call back.

5 Choose OK.

See Also
Elapsed Timer



Save Lists to Tabs

Purpose
Once you have displayed a list of objects using the Modify List features, you can save the 
list on a tab for future reference.

            Do not save lists to the InfoPad. This is a good place to view object lists, or use
it like a "scratch pad."

Steps

1 Select the tab to which you wish to save the list (not the InfoPad).
or
Right-click an empty tab, choose Tab Properties, and create a new tab.

2 Use the features on the Find or Tools menus (such as FastFind, Find-By-Example, or 
Alphabetic Index) to list the objects you wish to display.

3 Use the features on the List menu (such as Hoist, Expand, and Collapse) until the list of 
objects is displayed the way you wish.

4 Right-click the tab on which the list is displayed, then choose Tab Properties.

5 Choose Save View.

You can also select Always Save on the Tab Properties dialog box, which saves lists 
automatically when you change tabs.

See Also
Clear Line, Clear View, Clear to End
Collapse Connections
Create or Edit Tab
Expand Connections
FastFind
Find-By-Connection
Find-By-Example
Flatten Outline
Hoist
Move Item To
Move Tabs
Promote to Left
Search External Files
Tab Index
Watch quick tour of Organizing Objects



Find-By-Example: Date Range Search Examples

Purpose
A great use for the Find-By-Example feature is to find objects that fall within a particular 
date range.    The following examples illustrate how use the feature in this way.

          Example 1
Let's say that you wished to find all your meetings for the week of March 2027.    Type 
one of the following in the Meeting Date search field:

>="3/20/94" and <="3/27/94"
>"3/19/94" and <"3/28/94"

          Example 2
Suppose that the only thing you can remember about a person in your iBase is that she 
was born on 5/5/55.    To find that person, type ="5/5/55" in the person's Birthday field.

          Example 3
Suppose you wish to list your schedule of appointments for a two week period except 
the three day July 4th weekend.    Click in the appointment's date field and type the 
following:

>"6/26/94" AND < "7/2/94" OR > "7/4/94" AND < "7/9/94"

          Example 4
Let's say you need to find all people that have birthdays in the month of March.    Type 
3* in the Birthday search field.    To find all people born in 1960, type *60.    Typing 6/24*
finds all those born on June 24th.    Note that typing *24* does not find all people born 
on the 24th of a month.    You also cannot use wildcards with operators for date range 
searches.

See Also
Using Logical Operators
Using Logical and Relational Operators
Using Relational Operators
Using the Asterisk Wildcard



Move Tabs

Purpose
You can move tabs from one location to another in the Outline View.

Steps

1 Drag a tab and drop it on another location in the Outline View.

See Also
Create or Edit Tab
Save Lists to Tabs
Tab Index



Mathsematical Operators

Purpose
Use Mathsematical Operators to add, subtract, multiply, and divide values.    You can get 
such values from other fields, but they must either be numeric fields or produce a string 
interpreted as a value. Example

The following table lists the mathsematical operators you can use.
Operator What it Does
+ A+B returns A plus B.

-A-B returns A minus B.
* A*B returns the product of A and B.
\ A\B returns integer(A) divided by integer(B).
^ A^B returns A raised to the power B.
MOD A MOD B returns the modula, or remainder, of A\B

See Also
Field Initial Value Calculation



Sort Alphabetically

List, Sort Alphabetically

Purpose
Use Sort Alphabetically to arrange main level objects in a displayed list alphabetically.    All
connections and subordinate objects remain with the main level object they are connected
to.    People are sorted by last name.

Steps

1 Choose Sort Alphabetically from the List menu.

If you wish to display the list as it was before the sort, choose Undo Sort from the Edit 
menu.

See Also
Alphabetic Index
Watch quick tour of Organizing Objects



Default Text Field and System Variable Notations

Purpose
The following variable notations can be used in the Setup Default Text feature to specify 
different fields from which you can extract information when creating a related file, such 
as a letter.    For example, the "@@" notation is used to enclose a system date variable, 
which, when passed to a related file that you create, will insert the current date.

@@
Used for a system variable such as the current date, time, filename or file description.    
For example, @@Relationship_Desc@@.

$$
Used for the field name of a person object.    For example, $$Object_Desc$$.

%%
Used for the field name of a non-person object (an object that's not a person).    For 
example, %%Object_Desc%%.

##
Used for the field name of a non-person object if you identify one, otherwise a field 
name from a person object.    For example, ##Address_Line_1##.

^^
Used for the field name of a field on a connection description dialog box.    For example 
^^Direct_Line^^.

<
Used to suppress a line if there is no information in a field to extract.    For example, 
##Country##< inserts any information contained in an object's "Country" field.    If 
there is no information in the Country field, then InfoCentral removes the line so you do 
not have a blank line in your resultant document.



Sprout New Menu

Menu or Menu Bar Item, Customise Menu Hot Key (F12), Properties of this Menu 
Selection

Purpose
Use Sprout New Menu to create a new menu bar menu or a new cascading menu from a 
menu item.

Steps

1 Highlight a menu or menu bar item.

2 Press the Customise Menu Hot Key (F12).

3 Choose Properties of this Menu Selection.
or
If you are creating a new menu bar menu, choose Add New Menu to Left or Right, then 
name the menu bar item.

4 Select Sprout a Menu.
or
Select Sprout a Cascading Menu.

5 Choose OK.

You can now highlight the new menu or cascading menu, press the Customise Menu Hot
Key (F12) again, and add new menu items.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key
Load Menu System
Perform a Built-In Command



Create Related File: Insert Standard System Variables

Purpose
The following standard related file system variables explain what is inserted into a related 
file when your application starts.    You can type these variables directly in the Setup 
Default Text box.    For more information about inserting variables that extract information 
from specific fields found in Object or Connection Information dialog boxes, see Select 
Field Object.

          @@FileName@@
The DOS filename of the file being created.    For example, BRKN4815.WRI.

          @@FullFileName@@
The DOS filename, including its full path and drive, of the file being created.    For 
example, C:\LETTERS\BRKN4815.WRI.

          @@FileDesc@@
The description you enter for the file when it's created.    This is ideal for inserting after 
the "RE:" notation in a letter (for example, RE: Memo To All Employees), which is the 
description you type before the Windows application starts to create the related file.

          @@Relationship_Desc@@
Inserts the description of the relationship between two objects, if you are including the 
information of a related object.    For example, if you have set up a related file type to 
prompt for a related person or organisation, this variable will extract the description of a
connection between two objects (such as a person's title at a company).

          $$Object_Desc$$
Inserts the full name of the person for whom you are creating a related file.

          %%Object_Desc%%
Inserts the description of the non-person object as it appears in the Outline View.    For 
example, the name of a company, restaurant, project, or possession.

          ##Address_Block##
This variable first searches for non-person address information.    If it cannot find non-
person address information, then person address information is used.    For example, if 
you selected Prompt for Related Person/Organisation on the Setup Related File Type 
dialog box, and you are creating a letter for a person who is connected to a company, 
and that company has address information, then this variable will extract that address 
information.    If no address information is specified, then the person's address 
information is extracted.

          ##Country##
Inserts the country information from the non-person object identified, or the person 
object if no non-person object has been identified.

          $$Dear$$



Inserts the contents of the "Dear" field in a person object. For example, if you are 
creating a related file for Robert Jones, this variable extracts "Bob".



iBase Information

File, iBase Information

Purpose
Use iBase Information to view key information about the current iBase, such as its size, 
the total number of objects it contains, and the date the iBase was last updated.

Steps

1 Choose iBase Information from the File menu.

2 Choose OK.

See Also
About InfoCentral
Housekeeping



System Status

Help, About InfoCentral, Status

Purpose
Use System Status to get information about the version of InfoCentral you are using, its 
release date, the version of DOS you are using, and from which directory you are running 
InfoCentral.    You can also get information about your Windows configuration.

Steps

1 Choose About InfoCentral from the Help menu.

2 Choose Status.

See Also
About InfoCentral
iBase Information



tab
Coloured dividers at the bottom of the screen, used for saving views of different lists of 
objects.



Tab Index

Right-Click Tab Scroll Bar

View, Tab Index

Purpose
Use Tab Index to view a list of all existing tabs.    You can switch to a tab and view its 
properties from Tab Index.

Steps

1 Choose Tab Index from the View menu.

2 Select the tab name you wish from the Tab Name list box.

3 Choose OK to display that tab.
or
Choose Properties to display that tab and view the Tab Properties dialog box.

See Also
Create or Edit Tabs



Example
You may have a Completion Time field with the initial value calculation of:

XTIME$(XSECS(Sys_Time2$)+3600)

The number of seconds past midnight that the current time falls is incremented by one hour 
(3600 seconds) and then converted to system time format 2 (hh:mm:ss).



Print Current Tab (Options)

File, Print, Current Tab, Options

Purpose
Use Print Current Tab Options to customise how objects on the current tab appear on the 
printed page.

Steps

1 Choose Print from the File menu, then choose Current Tab.

2 Choose Options.

3 Choose from the following options:

          Layout Size
Specify the size of the printout.

          Print Odd/Even
Print only odd, only even, or both odd and even pages. 

          Outline Style
Specify the style of the printed outline.    You can choose to separate objects by spaces, 
bullets, or lines.

          Options
Specify whether to include a cover page or header with the iBase and tab names on 
each page, and whether to alternate headings on left and right margins.

See Also
Print Current Tab
Print Margins (Options)
Restore Default Print Options
Setup Printer



Create or Edit Tab

Right-Click Tab, Tab Properties

View, Tab Properties

Purpose
Use Tab Properties to create a new tab or edit an existing tab.    Tabs let you save lists of 
objects and organise your iBase by categories.

Steps

1 Right-click a tab, then choose Tab Properties.

2 Type the tab name in the Tab Name text box.

3 Select a tab colour from the Colour group box.

4 Choose Save View to save the current list of objects regardless of the Save options you 
select.
or
Choose Delete to delete the current tab.
or
Choose from the following options:

          Outline View
Use the tab to display object lists.

          Calendar View
Use the tab as a Calendar View in which Calendar objects are available.

          Always Save
Save the list every time you make a change.

          Save with Confirmation
Save the list as you are leaving the tab, with your confirmation.

          Never Save
Preserve the original list.    Any changes made after selecting this option are saved in 
the iBase but not in the display list.

See Also
Calendar Views
Previous Tab
Tab Index



Communicating with InfoCentral: The Big Picture

Purpose
InfoCentral offers a variety of features to help you communicate with people and 
organisations.

Choose from the following topics for more information.

          Dial a Phone Number
How to dial phones numbers for those person or organisation objects for which you have
included phone numbers.

          Dial from Address Book
How to conveniently dial phone numbers from the Address Book.

          Log a Phone Call
How to create an telephone event object should you wish to record a telephone call for 
future reference.

          Lookup Area Codes
How to find an area code for a particular city, state, or country.

          Use Elapsed Timer
How to use the Elapsed Timer to time events, such as the length of time you are on the 
phone with a client.

          Mail a File
How to attach a file to a mail item, and type subject and message information for the 
mail item.

          Set Telephone Preferences
How to add or edit country, area, and city codes, as well as telephone number prefixes 
and suffixes.

          Set Daylight Saving Time
How to set up Daylight Saving Time so the time will change in your iBase automatically.

          Set Modem Preferences
How to set up your Hayes- or non-Hayes compatible modem.





Telephone People and Organisations

Right-Click Person or Organisation Object, Telephone

Select Person or Organisation Object, Telephone

Purpose
Use Telephone to look up phone numbers for an object.    You can also select a phone 
number and dial through a connected modem.    Use Telephone Preferences to set up 
dialing options.

            The Telephone feature is only an autodialer.    It cannot be used to fax or 
connect your computer with another modem.    Use Modem Preferences to correctly set 
up your computer's connection with your modem.    Also, to properly dial international 
numbers you must provide square brackets around country codes (for example, [33] 12 
123 4567).

Steps

1 Right-click a Person or Organisation object.

2 Click Telephone  on the Toolbar.

3 Scroll to the desired phone number.

4 Choose Dial to dial the number.

See Also
Daylight Saving Time Preferences
Modem Preferences
Communicating Using InfoCentral: The Big Picture
Telephone People and Organisations
Telephone Preferences



Telephone Preferences

Telephone, Preferences

Address Book, List by People or Organisation, Telephone, Preferences

Purpose
Use Telephone Preferences to add or edit country, area, and city codes, as well as 
telephone number prefixes and suffixes.    You can auto-dial any in-house, local, in-state, or
long-distance telephone number.

Steps

1 Choose Preferences from the Edit menu, then choose Telephone.
or
Choose Telephone  on the Toolbar, choose Preferences, then choose Telephone.

2 Choose from the following topics to learn how to set up specific dialing scenarios:
Autodialing Normal Phone Lines
Autodialing Office Extensions/Outside Lines
Autodialing Long Distance with a Calling Card
Autodialing Long Distance from Office with Card
Autodialing Long Distance with Access Code
Autodialing In-Area Toll Calls

See Also
Communicating Using InfoCentral: The Big Picture
Telephone People and Organisations
Create or Edit Telephone, Modem, or Fax Line Field



Create or Edit Telephone, Modem, or Fax Line Field

Object Information, Setup Field, Add New Field, Telephone, Modem, or Fax Line, OK

Purpose
Use Telephone, Modem, or Fax Line fields to display phone numbers, modem numbers, or 
fax lines in the Object or Connection Information dialog boxes.    For example, suppose you
wish to note people's pager numbers.    You could create a Telephone field that recorded 
such a number.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Telephone, Modem, or 
Fax Line field, then choose Add New Field.

3 Choose Telephone, Modem, or Fax Line, type a name for the field, then choose OK.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Entry Options
Initial Value Calculation
Valid Range

5 Choose from the following Display options unique to this dialog box:

          Local Time
Display the local time of the telephone, modem, or fax line you specify.

          Region Description
Display a description of the region of the number specified.

See Also
Customizing Fields: The Big Picture
Telecommunicating: The Big Picture
Telephone People and Organisations
Telephone Preferences



template
The term "template" can refer to several kinds of pre-defined structures.    Templates provide
a framework and make data easier to work with.

For example, InfoCentral comes with template iBases that contain several objects related to 
the template type.    You can use this kind of template to build upon.    See Using Template 
iBases for more information.

A template might also be a particular type of file, such as a prototype file used in the Create 
Related File (Advanced Options) feature.

A template can be the fields that you set up in the Match Import Fields or Select Export 
Fields features.    The way you set up the fields the first time is used for the other records you
are importing or exporting.



Files to Skip

Find, Search External Files, Files to Skip

Purpose
Use Files to Skip to define up to 40 file extensions to skip during a search of external files.

Steps

1 Choose Search External Files from the Find menu.

2 Choose Files to Skip.

3 Specify the file extensions you wish to skip.    You can use the * and ? wildcard 
characters.

4 Choose OK.

See Also
FastFind Files
Finding Objects: The Big Picture
Search External Files



Create or Edit Time Field

Object Information, Setup Field, Add New Field, Time, OK

Object Information, Time Field, Setup Field, Field Properties, Time, OK

Purpose
Use Time fields to set up a place where you can note a time in the Object or Connection 
Information dialog boxes.    You can choose from a wide range of time formats using 
system time variables.    For example, you could use a Time field to record the start time of
an event.

Steps

1 Right-click any object in the Outline or Calendar View.

2 Right-click the field above the location where you wish to add a Time field, then choose 
Add New Field.

3 Choose Time, type a name for the field, then choose OK.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Entry Options
Field Initial Value Calculation
Field Range

See Also
Customizing Fields: The Big Picture



drop-down list
A list of options that appears when a list button is selected.



FastFind Files

Find, FastFind Files

Purpose
Use FastFind Files to quickly locate files on your hard drive and display them in the Outline
View.

Steps

1 Choose FastFind Files from the Find menu.

2 Using the * and ? wildcard characters, type the files, directories, and drives in the Find 
text box that you wish to list.

See Also
FastFind
FastFind Preferences
Find-By-Connection
Find-By-Example



Today's Schedule

View, Today's Schedule

Purpose
Use Today's Schedule to list the current day's schedule, follow-ups, unscheduled events, 
and tasks on the current tab.    If you have scheduled meetings, appointments, or events 
for today, they are conveniently displayed in a time outline that lets you work with them 
like any other object.    If you have specified today as the Follow-Up date for a particular 
person or organisation, that person or organisation is listed as well.    Your tasks are 
displayed by priority.

Steps

1 Choose Today's Schedule from the View menu.
or
Choose FastFind  on the Toolbar, enter the date or type today in the Find text box, 
then choose Find All.

If you have a list displayed on your screen, the day's schedule is added to the bottom of
the list.

2 Work with the event objects just like any other object, such as connecting them to 
people.

3 Highlight the day (for example, Thursday, August 18, 1994) and press Left Arrow or 
Right Arrow to go back a day or forward a day.

4 While the day is highlighted, right click to display the Calendar View for that day.

See Also
Add an Event Object
Add Task Object
Clear Line, Clear View, Clear to End
Connect Objects
Follow Up on People and Organisations
Follow Up on Tasks
Using Calendar: The Big Picture
Watch quick tour of Using Calendar



Toggle View

View, Toggle View

Purpose
Use Toggle View to display connections to the selected object or to conceal connections to 
the current object.

Steps
To display connections,
1 Select the object you wish to display connections for, then choose Toggle View from the 

View menu.
or
press the Enter key.

The connections one level below the selected object are displayed.

To conceal connections,
1 Select the object for which you wish to turn off the connections display, then choose 

Toggle View from the View menu.
or
press the Enter key.



Undelete

File, File Properties, Undelete

Purpose
Use Undelete File to undelete a file that you have recently deleted.    You cannot delete a 
file that you have shredded.

Steps

1 Choose File Properties from the File menu, then choose Undelete.

See Also
Delete a File
Delete Object



Example
You could have an Action Date field used the day after you've created a certain type of 
object or connection.    It might have the calculation of:

XDATE$(XDAYS(Sys_Date2$)+1,2)

which inserts today's date incremented by one in the system date format 2 (mm/dd/yyyy).



Undo

Edit, Undo

Purpose
Use Undo to reverse your last command.    You can reverse many InfoCentral commands 
including Cut, Delete, Find, Flatten, Hoist, Promote, Sort, Clear Line, Clear View, and other 
features.

Steps

1 Click Undo  on the Toolbar.

See Also
Calendar Cut, Copy, Paste
Clear Line, Clear View, Clear to End
Cut
Copy to Clipboard
Delete File
Delete Object
FastFind
Flatten Outline
Hoist
Promote to Left
Sort the List



Unknown Gender

Object Information, Gender Field

Purpose
Use Unknown Gender to specify the gender of the person you just added.

Steps

1 Choose Male, Female, or Unknown.

See Also
Add Preferences



Using Content iBases

Purpose
InfoCentral comes with four iBases that are already loaded with information for you to use:
ComputerCentral, ConsumerCentral, TravelCentral, and WineCentral.    You can edit the 
information in these iBases and add information.

            The information in these iBases is as correct and complete as possible at the 
time they were created.    The information is, of course, subject to change.

Steps

1 Choose Open from the File menu.

2 Double-click the ibases directory icon.

3 Select an iBase from the list box (computer.ica, consumer.ica, travel.ica, or wines.ica), 
then choose Open.

See Also
Add New Object
Edit Object Information
Using Template iBases
Watch quick tour of Using Content iBases
 Using InfoCentral: iBases and Templates



Using Template iBases

Purpose
Templates are empty iBases that contain specialised object categories, connection 
descriptions, and tab names.    There are a few sample objects added to these iBases to 
help you see how the templates can be used.    The templates give you a place to start. 

Steps

1 Choose Open from the File menu.

2 Double-click the iBases directory icon, then double-click the template directory icon.

There are nine templates: automobile records, CD collection, contact manager, 
gardening, home and family records, party/wedding planner, real estate, stamp 
collection, and video collection.

3 Select a template iBase from the list box (auto.ica, cd.ica, contact.ica, gardning.ica, 
home.ica, party.ica, real_est.ica, stamp.ica, or video.ica).

4 Choose Open.

See Also
Exporting iBase Information: The Big Picture
Using Content iBases
Watch quick tour of Using Content iBases
 Using InfoCentral: iBases and Templates



Using InfoPad

Purpose
Use the InfoPad tab like a scratch pad, where you work with data in a free-form way.

            You should not save or plan to save a list on the InfoPad unless you plan to 
rename the InfoPad tab.    We recommend creating other tabs to save lists to.

Steps

1 Click the InfoPad tab.

See Also
Calendar Views
Create and Edit Tab
Save Lists to Tabs
Watch quick tour of Organizing Objects
Watch quick tour of Using Calendar



Using Other iBases: The Big Picture

Purpose
You do not have to use just one iBase, you can use several.    If you wish to move 
information from one iBase to another, use the Export and Import features.

Choose from the following for more information.

          Name New iBase
How to create a new iBase.

          Open Another iBase
How to open an iBase that already exists.

          Save iBase to Another iBase
How to save an iBase with an iBase name that already exists.    This option replaces the 
latter iBase.

          Rename iBase
How to rename an iBase.

          Delete iBase
How to delete the currently opened iBase.



Organizing with Tabs: The Big Picture

Purpose
Use Tabs to divide an iBase into different lists of objects for quick and easy access.    Tabs 
are like windows for your information.    They do not change the information, but give you 
a different view of it. You can connect and move objects between tabs.

Choose from the following for more information.

          Create or Edit Tabs
How to create a new tab or edit an existing tab.

          Connect Objects to Objects on Other Tabs
How to connect an object that is displayed on one tab with an object listed on another 
tab.

          Save Lists to Tabs
How to save object lists to tabs for future reference.

          Move Tabs
How to move a tab to another location in the Outline View.

          Use Tab Index
How to view a list of all existing tabs, and the properties of the tab you select.

See Also
Watch quick tour of Organizing Objects



View Calendar

View, View Calendar

Purpose
Use View Calendar to display the Calendar View.    This feature performs the same action 
as clicking the Calendar tab.

Steps

1 Choose View Calendar from the View menu.
or
Click the Calendar tab.

See Also
Calendar Views
Using Calendar: The Big Picture
Watch quick tour of Using Calendar



Edit Volume Properties

Right-Click Volume Object, Information

Purpose
Use Volume Properties to create or edit the name and description of a volume.    You can 
also attach memos to volumes.

Steps

1 Right-click a volume (such as H: or R:), then choose Information.

2 Type a description in the Volume Description text box.

3 If you wish to rename the volume, type a new name in the Volume Name text box.

4 Choose Memo to attach a memo to the volume.

5 Choose OK.

See Also
Edit File Information
Edit Directory Information



List Directory

View, All Drives, Directory Object, Files Connection

Purpose
Use List Directory to list all the files in the currently selected directory object.

Steps

1 Double-click a directory object, then double-click the file you wish to open.

2 Use wildcard characters to specify the files you wish to list, then choose OK.
or
Choose Show All to list all files.

See Also
Display Case
File Display Settings
Working with File Objects: The Big Picture



Working with File Objects: The Big Picture

Purpose
Files, directories, and volumes can be displayed in the Outline View just like any other 
object.

Choose from the following for more information.

          Search External Files
How to use a wide variety of search criteria and parametres to find exactly the file you 
wish.

          View All Drives
How to display all drives as objects in the Outline View.

          Open a File
How to launch or execute a file from InfoCentral.

          Copy a File
How to copy a file.

          Delete a File
How to delete or shred a file.

          Undelete a File
How to restore a deleted file.

          Mail a File
How to attach a file to a mail message and type subject and message information.

          Attach Memos to File or Directory
How to remind yourself of the contents of a particular drive or directory.

          Rename or Move File
How to rename or move a file.

          Create a Directory
How to create directories.



          Rename a Directory
How to rename a directory.

          Delete Directory Object
How to delete a directory.

          Change Display Case
How to change directory and filenames to uppercase, lowercase, or a combination.

          Change File Display Settings
How to change the way file information is displayed in the Outline view.



Writing Notes and Memos: The Big Picture

Purpose
You can keep daily notes in your calendar and attach memos to event and task objects.

Choose from the following options for more information:

          Keep Daily Notes
How to keep daily notes.    Notes are day-specific, meaning that they are not carried 
from day to day.

          Delete Notes
How to delete the notes you do not wish anymore.

          Cut, Copy, and Paste Notes
How to put notes somewhere else, like in another day's note pad on the Clipboard.

          Attach Memos to Objects
How to attach memos to event or task objects.



Zoom or Unzoom

Object Information, Zoom or Unzoom

Purpose
Use Zoom to display only those fields that contain information.    Use Unzoom to dispaly all
fields, whether or not they have information.    For example, if one of your Object 
Information dialog boxes has 20 fields, but only 5 of those fields contain information, you 
could click Zoom to reduce the dialog box size to include only those 5 fields.

Steps

1 In the Object Information or Connection Information dialog box, choose Zoom or 
Unzoom.

Note that the larger, unzoomed view contains a scroll bar on the right side of the dialog 
box, which you can use to view more information.



Delete Tab

Right-Click Tab, Delete

Purpose
Use Delete Tab to delete the current tab.    You cannot undelete a tab.

Steps

1 Right-click a tab.

2 Choose Delete.

See Also
Delete Object



Editing Information: The Big Picture

Purpose
You can edit objects, connections, connection descriptions, categories, tabs, and memos.

Choose from the following options for more information.

          Edit Object Information
How to edit the information for an object, such as addresses, phone numbers, and 
names.

          Edit Connection Information
How to edit the information on a connection, such as a person's starting or ending dates
at a company.

          Edit Connection Description
How to edit the way a connection is described, such changing "Employee" to "Staff 
Member."

          Edit Categories
How to edit the way objects are classified.

          Edit Memos
How to attach memos to objects and edit them.

          Edit Tabs
How to use the pre-defined tabs, edit them, or create your own.



connection description
A label that describes the relationship between two connected objects.    For example, a 
connection description called Staff Member would describe the relationship between a 
person and the organisation the person is connected to.    If this person has since left the 
organisation, InfoCentral would describe the person as a Former Staff Member depending on 
the current Viewing Date setting.



 Hint
This dialog box appears if you selected the Split Each Input Record into Two Connected 
Objects option in the Import: Receiving Category dialog box or the Include a Connected 
Category option in the Export: Category dialog box.



Select Export File

File, Export, Type Scenario Name, New Scenario, Add, Select Export Categor(ies), 
Select Default Connection, Select Export Output File

Purpose
Use Export Output File to select the file you wish to export iBase information to.

Steps

1 Select the drive, path, directory, and filename to which you wish to export information.

Use List Files of Type to quickly locate comma/space or tab delimited export files that 
you have defined previously.

See Also
Begin Export
Check Export Summary
Check Export Completion
Create or Select Export Scenario
Exporting iBase Information: The Big Picture
Importing Data into iBase: The Big Picture
Select Export Category
Select Export Connected Category
Select Export Fields



Example
Suppose you wish to export only name, address, and telephone information.    Drag these 
fields from the iBase Fields list box to the Fields to be Exported list box.    The order you drag 
them over is the order the information will be in the export records.



Example
If you had expanded several levels of objects before you found the object you wished to 
view, you could use Hoist to clear the other objects and connections and move the selected 
object to the top of the screen.



Example
You can specify a field name from the Object Information dialog box, such as Country Name 
or Postcode, then specify which objects you wish included in the address book using letters 
or wildcard characters.



Example
Specify a field name from Object Information, such as Country Name or Postcode.    Then use
letters or wildcard characters to specify the contents of the field each object property must 
have in order to be printed (such as all objects with the country field set to Italy).



 Hint
Any time an object in the selected category appears in the object list, the object will display 
in the colour you select here.



 Hint
If you mark a category private, you will need to type a password when you start InfoCentral 
to access the category options.



 Hint
Depending on the size of the selected iBase, InfoCentral can take several minutes to do a 
housekeeping.    You may wish to use the Housekeeping feature at night or at a time when 
you will not be using your computer.



Example
If you have a record that contains both a company name and an employee name, you could 
select this option to create two objects, the company and the employee, that are connected. 
If you do not select this option, the information would be imported as one object, (such as 
the company would be the object and the employee name would only appear as an 
information field for the company object.)



 Hint
You cannot create a connection description from these dialog boxes.    You must select a 
connection description that has already been defined.



 Hint
When you empty the trash, InfoCentral performs housekeeping on the iBase.    A warning 
dialog box will appear and display the approximate amount of time it will take to complete 
the housekeeping.



 Hint
If you clear objects by mistake, you can choose Undo Clear from the Edit menu.    This will 
replace any items that have been removed.



 Hint
If you assign passwords for Read-Only Access and Read and Write Access, Read and Write 
access would be the highest level password.



 Hint
Page refers to the printed page.    Because the Outline View does not indicate where a page 
begins or ends, pages break at the same place regardless of the Layout Size.



 Hint
The Test Print option prints Xs to show where lines of text appear.    It is a good idea to do a 
test print on a regular sheet of paper if you are not sure what type of label to select.    You 
can compare the test print to your labels to see if text lines are in the correct position for 
your labels.



 Hint
You can also start and stop the timer by clicking the timer display.    Double-click the timer 
display to reset it.



System Date and Time Variables

Purpose
Use system date and time variables to fill in fields with the current date and time in the 
format that you specify.    For example, if today were the first day of January, 1995, then 
specifying the sys_date4$ in the Initial Value Calculation text box for a date field would 
display Sun., January 1, 1995 in that field when you tabbed out of the field.

You can also insert a system date or time variable into the Create Related File: Setup 
Default Text feature so that the current date or time is inserted into a related file when you
create it.    To do this, you need to drop the dollar sign "$" from the system date or time 
variable and enclose it with the double at symbols "@@."    For example, if you wish to 
insert Sun., January 1, 1995 into a letter, you would specify @@sys_date4@@ in the 
Setup Default Text feature.

The following lists the available system time and variables:

          SYS_DATE1$
Current date in MM/DD/YY form (for example, 1/2/94).

          SYS_DATE2$
Current date in MM/DD/YYYY form (for example, 1/2/1994).

          SYS_DATE3$
Current date in January 2, 1994 form.

          SYS_DATE4$
Current date in Tue., January 2, 1994 form.

          SYS_DATE5$
Current date in Tuesday, January 2, 1994 form.

          SYS_DATE6$
Current date in short form selected in the Windows Control Panel.

          SYS_DATE7$
Current date in long form selected in the Windows Control Panel.

          SYS_DATE8$
Current date in the Windows Control Panel short form; displays with a two digit year and
leading zero.

          SYS_DATE9$
Current date in the Windows Control Panel short form; forces four digit year and leading 
zero.

          SYS_TIME1$
Current time in 5:38 pm form.



          SYS_TIME2$
Current time in 5:38:33 pm form.

          SYS_TIME3$
Current time in 17:38 form.

          SYS_TIME4$
Current time in 17:38:33 form.

          SYS_TIME5$
Current time in form selected in the Windows Control Panel with seconds.

          SYS_TIME6$
Current time in form selected in the Windows Control Panel with no seconds.

See Also
Field Initial Value Calculation
Specify Default Text for Related File



Example
Below is an example a comma and space delimited import file.    Note that the first two fields
contain objects, the third contains a connection description, and the last contains object 
information.
Marc Sabatini, Atlantic Metals, President, 4545 Main Street



Load Menu System

Edit, Preferences, Menu, Load Menu System

Purpose
Use Load Menu System to select the file that contains the customised menu structure you 
wish to use with InfoCentral.    You can choose from the pre-defined menu structures, or 
create your own.

Steps

1 Choose Preferences from the Edit menu, choose Menu, then Load Menu System.

2 Select a menu file.

WPICMENU.MNW is the normal menu structure.    WPICQUIK.MNW offers quicker 
keyboard access to features.

3 Choose Load.

See Also
Customise Menu
Customise Menu Bar
Customise Menu Hot Key



Example
You could have a Freight Amount field with an initial calculation of Weight_In_KG*130.00.    
As new objects are added, the weight of the object in kilograms is multiplied by the amount 
130.00 to give the Freight Amount for the object.    Since this field is a Currency field instead 
of a Calculation field, you can type over the computed value if necessary.



Define the Relationship

Select Type of Field, Connection, OK, Multiple Relations

Purpose
If you are setting up a connection field in Object Information, and several two-way 
connections exist, use Define the Relationship to choose a reverse relation.

Steps

1 Select a connection description, then choose OK.



Example
The following formula uses the value from a Cost $ field (not a Currency Type field), converts
the value to Yen, then displays the value using the currently specified Format Template 
characters.

FORMAT$((Cost_$*1.37),"*,***,***.##")



Example
A Social Security Number field might have a format template of "###-##-####" so that 
the numbers you type in the field are arranged into the correct format.    Pound signs are 
replaced with the characters or digits that you type in the field while other characters (such 
as hyphens) are placed between the numbers.



Example
A Fastener Cost field might need four digits of precision to the right of the decimal point if 
such objects are usually very inexpensive, so a formatting template of "$#.####" might be 
appropriate.    Pound signs "#" are replaced with the digits you type in the field while other 
characters (such as $ and .) insert the dollar sign and decimal point.



Example
A Thread Tolerance field might need three digits of precision to the right of the decimal 
point, so a formatting template of "####.###" might be appropriate.



Example
A Time Charge field on a Phone Call object could have a calculation of:

FORMAT$(INT(XSECS(End_Time)XSECS(Start_Time)*60)*(Rate_Per_Hour/60),"$#,###.##")

The number of seconds past midnight that the call started is subtracted from the number of 
seconds past midnight that the call ended.    These elapsed seconds are then multiplied by 
60, giving the elapsed time of the call in minutes.    Any partial minutes are dropped and the 
number of minutes is multiplied by the billing rate per hour, divided by 60 (the billing rate 
per minute).    The final amount is formatted with a leading dollar sign, a decimal point, and 
two digits to the right of the decimal.



 Hint
If you are setting up a telephone field, we recommend leaving the minimum text box at zero 
to allow someone to advance through the field without entering a telephone number.



 Hint
This is useful for automatically capturing things such as the time an object or connection is 
created, where the value of the field should not be disturbed when subsequent changes are 
made.



Browse Files and Directories

Find, Search External Files, Browse

Purpose
Use Browse to look through your hard drive and network drives for files and directories.    
The Browse feature is available from the Search External Files dialog box and many other 
dialog boxes.

Steps

1 Choose Search External Files from the Find menu.

2 Choose Browse.

3 Use the Browse options to find or select the file or directory that you wish.

4 Double-click the file or directory to insert it into the text box.

See Also
Selecting Files and Directories: The Big Picture



field type
Specifies what type of information can be entered into a field.    Anything can be typed into 
an Alpha or Numeric field, only telephone numbers can be typed into a Telephone field, and 
so on.



group title pad
A graphic element that divides a dialog box into groups of fields and controls.    The pad is 
composed of lines or spaces, and the text of the group title.



host edition
The master copy of an iBase when a remote copy is checked out.    Compare with remote 
edition.



housekeeping
The process of cleaning an iBase.    Housekeeping can remove deleted items from the trash 
can, old events and tasks from the calendar, and private information from the iBase.    See 
also shred.



insertion point
A symbol (usually blinking horizontal or vertical bar) that designates the position on the 
screen where text will be inserted or deleted.    Compare with mouse pointer.



Recurring Event

Tools, Recurring Event

Purpose
Use Recurring Event to schedule events that repeat over time (for example, a standing 
lunch appointment every week on the same day, or an annual check up appointment with 
your doctor).

Steps

1 Choose Recurring Event from the Tools menu.

2 Choose Appointment, Event, or Meeting.

3 Type the number of recurring events, then choose OK.

4 Type a description of the event, for example "Lunch with Mom."

5 Type the date of the first recurring event in MM/DD/YY format.

For example, if the date of the first recurring event is March 1, 1995, then you would 
type 3/1/95.

6 Choose how often the event will take place using the options listed below, then choose 
OK.

7 Type the recurring event's starting time in HH:MM format, then choose OK.

Be sure to add a "p" for "PM" or an "a" for "AM."    If you do not type anything, 
InfoCentral will assume you mean AM.

8 Type the recurring event's ending time in HH:MM format, then choose OK.

          Specified Number of Days
Repeats the event every day for the number of times that you specified earlier.

          Week
Adds an event once a week on the day and for number of times that you specified 
earlier.

          Specified Number of Weeks
Adds an event on the same day of the week every number of weeks you indicate.    For 
example, use this setting if the appointment you are scheduling occurs every 2 weeks.

          Month (same Weekday)
If you specify August 2, 1994, a Tuesday, as the first recurring appointment, the next 
event would be scheduled on September 6, 1994, which is also a Tuesday.

          Month (same Day)



If you schedule the first recurring event on the 10th of the month, the next one will be 
scheduled on the 10th of the next month, regardless of the day.

          Year
Adds the event every year on the day you specify.

See Also
Reschedule an Event



Hoist and Promote

List, Hoist and Promote

Purpose
Use Hoist and Promote to gather the current object's most pertinent connections.    
Compared to Hoist, which brings the highlighted object to the top of the list, and shows a 
connection description heading of other connected objects, Hoist and Promote brings the 
highlighted object to the top, and lists the next most pertinent object underneath.

Steps

1 Highlight or select the object that you wish to hoist.

2 Choose Hoist and Promote from the List menu.

Note that not only is the object that you selected in step 1 brought to the top of the 
Outline View, but the next most prominent object is listed as well.

See Also
Hoist



mouse pointer
A symbol that indicates a position on screen as you move the mouse on your desk.    The 
mouse pointer may change in appearance while performing certain functions.    Compare 
with insertion point.



object category
A classification of similar objects.    For example, "Company" is a category for business 
organisations.



object information
Information stored on an object, such as a person's home address and telephone number.



paste
To copy the contents of the Clipboard at the insertion point.



private information
Information in an iBase protected by a password.    If the password is not entered when 
opening the iBase, private information will not be visible.



promote
To move an object all the way to the left and to the bottom in a list.



properties
The information, or parametres, that define an item and specify how it will function.    For 
example, name, colour, display options, and save options are the properties of a tab.



record
In a traditional database, a group of fields that contain related information.    For example, all
object and connection information about a person in a database would be one record.



remote edition
The checked out copy of an iBase.    Compare with host edition.



scroll bar
The bars on the right side and bottom of a window or dialog box that let you move vertically 
and horizontally.    To scroll, click on the scroll arrows or drag the scroll box.



shred
To permanently remove all private information from an iBase.    A shredded object cannot be 
undeleted.



sort
To rearrange a list in a particular order.    For example, you can sort a list alphabetically.



Miscellaneous System Variables

Purpose
Besides the standard system date and time system variables, you can also use the 
following system variables.

          Category$
Category of current object. For example, "CATEGORY Category$" clears all the fields for 
the designated object category.    Strings are set to null and numerics are set to zero.    
This is useful when preparing to assign values to these fields and then inserting a new 
object in the IBase with an INSERT.    Category$ specifies the category whose fields you 
wish to clear.    

          Sys_Cat_Count
Returns the number of available categories, subject to your access rights.

          Sys_choice
Loaded with the choice selected after a MENU command.

          Sys_clip_board$
Insert contents of the Windows Clipboard.

          Sys_Cur_Dir
The current directory.ErrReturns the last system error.

          Sys_field_count
Number of fields the last read object has on its Information dialog box.

          Sys_iBase$
Contains the name of the currently active iBase including the full path to the iBase.

          Sys_Info_ID
Object ID of object if Object Information dialog box is displayed.

          Sys_object_ID
Object number of current object.

          Sys_object_type$
Object type of current object, such as Person, Place, Thing.

          Sys_Prog_Dir
The directory the program was loaded from.    In Windows, this is the same as 
Sys_Work_Dir.

          Sys_Work_Dir
The current directory at startup.



          Sys_Zoom_State
Returns 1 if the Information dialog box is zoomed, or returns 0 if the dialog box is not 
zoomed.

See Also
Create Related File: Standard System Variables
Date and Time Functions
Field Initial Value Calculation
Logical Operators
Logical Operators with Relational Operators
Mathsematical Operators
Relational Operators
String Functions
System Date and Time Variables
Variable Functions



toggle
To turn a feature on and off with the same command.



trash can
An area of memory where deleted information is stored to await possible recovery.    
Housekeeping can permanently delete information from the trash can.



undo
Reverses the last change you made.



unzoom
To increase the size of a dialog box by displaying all fields whether they have information in 
them or not.    See also Zoom.



valid range
The maximum or minimum value, number of digits or characters, or earliest and latest time 
that the field is allowed to contain.



volume
The name assigned to a disk or disk partition.    Often associated with a drive or device.    For 
example, C: is a volume.



wildcard
Character used to replace one character (?) or any number of characters (*).    Usually used 
in searching and finding operations.



zoom
To decrease the size of a dialog box by displaying only the fields that have information in 
them.    See also unzoom.



Name New iBase

File, New

Purpose
Use Name New iBase to begin a new iBase file.

Steps

1 Click  on the Toolbar.

2 Type the name of the new iBase, then choose Create.

See Also
Add New Object
Edit Object or Connection Information
Open iBase
Selecting Files and Directories: The Big Picture



Open iBase

File, Open

Purpose
 Use Open to open an existing iBase.

Steps

1 Click  on the Toolbar.

2 Select the iBase you wish to open, then choose Open.

See Also
Name New iBase



Save As

File, Save As

Purpose
Use Save As to save an iBase with a different name.

Steps

1 Choose Save As from the File menu.

2 Type a new name for the iBase, then choose Save.

See Also
Name New iBase



Combining iBases or Parts of iBases: The Big Picture

Purpose
Use Import/Export iBase to combine the objects and connections in one iBase with those 
of another.    This is particularly useful if you wish to transfer information to another iBase, 
then update it periodically.    Objects and connections are exported to an ".OMG" file, which
you then import into a receiving iBase.

Choose from the following for more information.

          Export iBase: Select Range
How to specify the part of the iBase you wish to export to another iBase.

          Publish an iBase
How to include information with an exporting iBase for publishing purposes.

          Import iBase: Match Fields
How to match the fields of the receiving iBase with those of the source iBase.

          Import iBase: Reconcile Object and Connection Differences
How to reconcile the differences that may exist in the objects and connections that your
are importing into an iBase.

          Import iBase: Select Alternate Category
How to select a different category if one does not exist in a receiving iBase.

          Import iBase: Create New Category
How to create a new category if one does not exist in a receiving iBase.



Example
For example, suppose that you are planning a business trip that will last several weeks.    
During this time, you have scheduled several appointments and tasks, which involve 
collecting more business contacts.    As such, you have elected to take InfoCentral on the 
road with you to compile this information.    The problem is, you have recorded all of your 
business appointments and tasks in your GroupWise calendar.    Fortunately, you do not have
to reenter all these appointments into InfoCentral; you can use GroupWise Calendar 
Import/Export to "mirror" the appointments and tasks in your InfoCentral Calendar.    In short,
you have a "remote" copy of your GroupWise calendar, with all the contact management 
power of InfoCentral.



Delete iBase

File, Delete iBase

Purpose
Use Delete iBase to delete the entire iBase.

            Delete an iBase with caution.    Once an iBase is deleted, you will not be able 
to recover it.

Steps

1 Select the iBase you wish to delete, then choose OK.

2 Verify that you wish to delete the iBase, then choose Delete.



Create Related File: Application Location

Right-click Object, Create Related File, OK, Personalise Applications

Right-click Object, Create Related File, Setup Type, Locate Application

Purpose
Use Application Location to search for the application you have chosen for the related file 
you wish to create.

Steps

1 Follow one of the routes above, then select Fixed Drives, Network Drives, or Fixed and 
Network Drives.

2 Choose Scan Drives to search the type of drive you selected.
or
Choose Specify Location to type the exact location and filename for the application.

See Also
Watch quick tour of Creating Related Files



Name Preferences

Edit, Preferences, Names

Purpose
Use Name Preferences to customise the way first, middle, last, and maiden names appear. 
You can also change the appearance of postfixes and titles.

Steps

1 Choose Preferences from the Edit menu, then choose Names.

2 Select the combination of options that you wish, then choose OK.

If you do not wish a particular name to appear at all, deselect the check box.    Select or 
deselect the radio buttons to vary the options for the names.

See Also
Setting Preferences: The Big Picture



Print Calendar

File, Print, Calendar

Purpose
Use Print Calendar to print the information you have placed in your Calendar, including 
event objects, tasks, and reminders.

Steps

1 Choose Print from the File menu, then choose Calendar.

2 Select Today to print today's calendar.
or
Select Next X Days and specify the days to print.
or
Select All Dates From and specify a range of dates.

3 Choose Print.

See Also
Print Address Book
Print Current Tab
Print Mailing Labels
Print Margins (Options)
Print Object Information
Printing iBase Information: The Big Picture
Restore Default Print Options



Print Calendar (Options)

File, Print, Calendar, Options

Purpose
Use Print Calendar Options to customise the appearance of the printed Calendar.

Steps

1 Choose Print from the File menu, then choose Calendar.

2 Choose Options.

3 Choose from the following options:

          Layout Size
Specify the size of the printout.

          Print Tasks for
Print tasks for the first day, all days, or not print task information.

          Print Reminders for
Print reminders for those objects which contain a date in the Follow-Up Date field.    You 
can print the first day only, for all days, or not print reminders.

          Print Odd/Even
Print only odd, only even, or both even and odd pages.

          Options
Specify whether to include a cover page, print days on separate pages, skip events 
without times, list objects that are connected to calendar objects, print alternate left 
and right margin headings for duplex printing, and print in address book format those 
individuals who are connected to calendar objects.

See Also
Print Address Book
Print Calendar
Print Current Tab
Print Mailing Labels
Print Margins (Options)
Print Object Information
Printing iBase Information: The Big Picture
Restore Default Print Options



Example
Suppose a field named Home Telephone has (801) 222-5000 in it.    If a Calculation field 
named Home is created with Home_Telephone in the Calculation text box, then the Home 
field will automatically have (801) 222-5000 placed in it when you use Tab to select it.



Rename iBase

File, File Properties, iBase Rename

Purpose
Use Rename iBase to rename an iBase with a different name.

Steps

1 Choose File Properties from the File menu, then choose iBase Rename.

2 Select the iBase you wish to rename.

3 Specify a new name, then choose OK.

See Also
Delete iBase
Save As
Save iBase
Working with File Objects: The Big Picture



Example
Suppose you have an iBase with geographical information and there is a "Population" field 
and an "Area in Sq.Miles" field.    You can create a "Population Density"    field that 
automatically calculates the density.    When creating the numeric Population Density field, 
enter Population/Area_in_Sq.Miles in the Initial Value Calculation field.    These calculations 
work especially well in the Numeric and Calculation fields, but can be used in other field 
types as well.



Send E-mail

Purpose
Use Send to attach a file to a mail item, and type subject and message information for the 
mail item.    InfoCentral works with WP Office 3.x and 4.x as well as GroupWise 4.1 and any
VIM, MAPI, CMC, or Digital Team Link compatible e-mail application.

Steps

1 Select a file in the Outline View.

2 Choose Send from the Tools menu.

3 Type the mail item's subject in the Subject text box.

4 Type a message in the Message text box, then choose OK.

See Also
GroupWise Update
Paste Special
Select Related File Type



Create Related File: Select File Type

Right-Click Object, Create Related File, Select a Related File Type

Purpose
Use Create a Related File to select a file type (for example, letters, graphics, and 
spreadsheets) you wish to relate to an object.    If the file type that you wish does not 
appear, you can create or edit one.

Steps

1 Select a file type from the File Type list box, then choose OK.
or
Choose New Type to create a new file type.
or
Select a file type, then choose Setup Type to edit an existing file type.

See Also
Create or Edit Related File Type
Creating Related Files: The Big Picture
Watch quick tour of Creating Related Files



Print Topics

Purpose
You can print one or several Help topics.

Steps
To print a single Help topic,
1 Display the topic.

2 Choose the Print button at the top of the Help window.
or
Choose Print Topic from the File menu.

To print several topics,
1 Choose Print Topics from the File menu.

2 Choose from the following sequences of topics:

Creating a Related File
Exporting/Importing iBases
Exporting Data
Importing Data
Find or Query By Example
Printing iBase Information
Using the Calendar
Adding and Scheduling Events
Adding and Managing Tasks
Autodialing and E-mailing
Listing Objects in the Outline View
Arranging and Organizing a List of Objects
Organizing Views with Tabs
Customizing Object and Connection Fields
Customizing Menus and Menu Bars
Setting Preferences

3 Select the topics you wish to print.

4 Choose Print.

Each topic is printed one at a time.



***DELETED TOPIC***



***DELETED TOPIC***



***DELETED TOPIC***



***DELETED TOPIC***



Edit Alarm Notification Check Boxes

Right-click Event Object, Alarm Notification Field, Field Properties, OK, Alarm 
Notification (Check Boxes)

Purpose
Use Alarm Notification Check Box Field Setup to create or edit Alarm Notification Check 
Box fields.    For example, the pre-defined alarms are set to notify you when the event is 
due and 3, 5, 10, and 30 minutes before that.    You could change these advanced warning 
times to 2, 6, 10, and 45 minutes.

Steps

1 Right-click an event object (such as a meeting).

2 Right-click the Alarm Notification field, choose Field Properties, then choose OK.

3 Type advanced warning time descriptions (such as "20 minutes") in the Description text 
boxes next the check boxes of your choice.

Make sure that that the Alarm/Notification check box in the Special Features group box 
is selected; otherwise, alarms will not signal.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint

See Also
Alarm Notification Preferences



Create or Edit Task Priority Radio Button Fields

Right-click Task Object, Priority Field, Field Properties, OK, Priority (Radio Button)

Purpose
A Priority Radio Button field is a special kind of radio button that is used for task objects 
only.    Use them to set up task priorities.    The pre-defined priority format is "1, 2, 3, 4" 
and so on, but you could change the priorities to something that makes more sense to 
you.

Steps

1 Right-click a task object in the Task display area of the Calendar Day View.

2 Right-click the Priority field, choose Field Properties, then choose OK.

3 Type descriptions in the Description text boxes (for example, "1" or "Urgent") for the 
Choice radio buttons you select.

4 Choose from the following options:
Write Contextual Help
Write Contextual Hint
Field Initial Value Calculation

See Also
Add Task Object
Create or Edit Field
Customizing Fields: The Big Picture



Alarm Status

Tools, Alarm Status

Purpose
Use Alarm Status to see the appointments and meetings for which you have alarms 
pending.

Steps

1 Choose Alarm Status from the Calendar Tools menu.

2 View the appointments that have alarms set.

3 Choose OK.

See Also
Alarm Notification Preferences



STR$

Purpose
Returns a leading sign (or leading space if the number is positive) and the string value of 
its numeric argument.

Syntax
STR$(Number)

Examples
STR$(123)
Returns the string value "123" where 123 is a numeric constant.

STR$(Qrts_in_gal)
Returns the string value " 4" where Qrts_in_gal is a numeric variable set to the value 4.    A
leading space is returned in lieu of a plus sign for positive numbers.

MID$(STR$(500),2)
Returns the string value "500" where 500 is a numeric constant.    The leading space that 
STR$ returns for positive values is removed using the MID$ function.



Export iBase: Select Range

File, Export, iBase

Purpose
Use Export iBase: Select Range to specify the objects and connections in an iBase that you
wish to export.    Why Use This Feature?

Steps

1 Choose Export from the File menu, then choose Object.

2 Choose from the following options, then choose OK:

          Entire iBase
Export all objects and connections in the iBase.

          Objects and Connections Created or Changed on or after
Export only those objects and connections created or changed on or after the date you 
specify in the text box.

          Objects and Connections on Current Tab
Export only the objects and connections exactly as they are displayed on the current 
Tab.

          Objects and First-Level Connections on Current Tab
Export the objects on the Tab plus any first-level connections.

See Also
Creating Categories while Importing
Matching Fields during Import
Reconciling Differences between iBases



Import iBase: Field Type Error

The Import Field Type Error message appears if you tried to drag a field of one kind on a field
of another kind.    Click OK, then drag the field to another field of the same name, or drop it 
on <Add Field> to create a new field in the receiving iBase.



Variable Functions

Purpose
The following is a list of the variable functions you can use with InfoCentral Initial Value 
Calculation Fields.
ABS
ASC
INSTR
INT
LEN
RND
SGN
VAL

See Also
Create Related File: Standard System Variables
Date and Time Functions
Logical Operators
Logical Operators with Relational Operators
Mathsematical Operators
Miscellaneous System Variables
Relational Operators
String Functions
System Date and Time Variables



Import iBase: Verify Information

File, Import, iBase

Purpose
Use Import iBase to read information about the .OMG file that contains the objects and 
connections that you wish to import into a receiving iBase.    After verifying the 
information, you can begin the import.    If the information is wrong, you can re-select the 
proper .OMG file or open a different receiving iBase.

Steps

1 Choose Import from the File menu, then choose iBase.

2 Read the information about the import .OMG file and the receiving iBase to verify that 
you are importing from and to the correct source and destination.

3 If the .OMG file is incorrect, choose Go Back to select another file.
or
Choose OK to begin the object import.

See Also
Combine iBases or Parts of iBases: The Big Picture
Creating a New Category When Importing iBase
Matching or Adding Fields
Reconciling Differences in Objects and Connections
Select Differenct Category When Importing iBase



Example
Suppose that you have been keeping track of your CD collection in your personal iBase.    A 
friend asks if she could have the CD information that you've been collecting.    Because you 
wish to give her only the CD information and not all of your personal information, you could 
list the CDs on a tab, expand connections as necessary, then select the Objects and 
Connections on Current Tab option to export only the CD information.



Import iBase: Create New Category

File, Import, iBase

Purpose
Use Import iBase: Create New Category if a category you are importing does not exist in 
the receiving iBase.    For example, suppose you have a thing category called "Sail Boat" 
that you are exporting from one iBase to another.    However, the Sail Boat thing category 
does not exist in your receiving iBase.    Use Create New Category to quickly create it.

Steps

1 Choose Import from the File menu, then choose iBase.

2 Select the .OMG import file that represents the iBase you wish to import, then choose 
OK.

3 If necessary, match the fields with the incoming iBase with those of the receiving iBase, 
then choose OK.

4 If you chose the wrong .OMG import file earlier, or mismatched fields, choose Go Back 
to amend your selections.

5 Choose New Category, confirm the spelling of the new category, then choose OK.

See Also
Combine iBases or Parts of iBases: The Big Picture
Matching or Adding Fields
Reconciling Differences in Objects and Connections
Select Differenct Category When Importing iBase



Import iBase: Reconcile Differences

File, Import, iBase

Purpose
Use Difference in Objects or Connections to reconcile Object or Connection Information 
differences between a receiving iBase and the iBase that you are importing.    The 
asterisks represent the information that is different.    You can accept the local, or receiving
iBase version of the information, or the imported version of the information.

Steps

1 Choose Import from the File menu, then choose iBase.

2 Select the .OMG import file that represents the iBase you wish to import, then choose 
OK.

3 If necessary, match the fields with the incoming iBase with those of the receiving iBase, 
then choose OK.

4 If a category doesn't exist in the receiving iBase, select a category from the list box, 
then choose OK.
or
Choose New Category and create a new category, then choose OK.

5 Choose Accept Local Version to accept the version of the information as it is in the 
receiving iBase.
or
Choose Accept Imported Version to accept the version of the information as it is in the 
imported version.

See Also
Combine iBases or Parts of iBases: The Big Picture
Creating a New Category When Importing iBase
Matching or Adding Fields
Select Different Category When Importing iBase



String Functions

Purpose
Click any of the following string functions for more information.
CHR$
DEL$
FORMAT$
INS$
LCASE$
LEFT$
LJUST$
MID$
REP$
RIGHT$
RJUST$
STR$
STRING$
TRIM$
TRIML$
TRIMR$
UCASE$

See Also
Create Related File: Standard System Variables
Date and Time Functions
Logical Operators
Logical Operators with Relational Operators
Mathsematical Operators
Miscellaneous System Variables
Relational Operators
System Date and Time Variables
Variable Functions



***DELETED TOPIC***



STRING$

Purpose
Returns a string composed of specified character repeated for a specified length.    Length 
may be a numeric constant or numeric variable. If the argument is zero, it returns a null 
value.    If it is less than zero it causes a runtime error.    If it is greater than 255 it is 
truncated to 255.    This function takes two arguments.    The first is a numeric argument 
that defines the length of string desired.    The second argument defines the character that
is to be repeated.    The second argument may be either a numeric or a string.    If the 
second argument is numeric then the STRING$ function takes the number it represents as 
the decimal ASCII character code that should compose the output string.    If the second 
argument is a string then the STRING$ function uses the first character of the string to 
compose the output string.

Syntax
STRING$(Length,ASCII_value)
STRING$(Length,Character$)

Examples
STRING$(7,65)
Returns "AAAAAAA" where 7 and 65 are both numeric constants.    The 7 represents the 
desired length of the string while the 65 represents the desired ASCII character number 
that should be repeated in the string.    The ASCII character number for the upper case 
letter "A" is 65.

STRING$(Length,Middle_initial$)
Returns "CCCCCCCCCCCCCCC" where Length is a numeric variable set to the value 15 
while Middle_initial$ is a string variable set to the value "C".



Import iBase: Select Alternate Category

File, Import, iBase, Select Alternate Category

Purpose
If you are importing an object of a particular category, and that category does not exist in 
the receiving iBase, you can use Import iBase: Select Alternate Category to select or 
create a category.

Steps

1 Choose Import from the File menu, then choose iBase.

2 Select the .OMG import file that represents the iBase you wish to import, then choose 
OK.

3 If necessary, match the fields with the incoming iBase with those of the receiving iBase, 
then choose OK.

4 If you chose the wrong .OMG import file earlier, or mismatched fields, choose Go Back 
to amend your selections.

5 Select a category from the list box.
or
Choose New Category and create a new category.

6 Choose OK.

See Also
Combine iBases or Parts of iBases: The Big Picture
Creating a New Category When Importing iBase
Matching or Adding Fields
Reconciling Differences in Objects and Connections



Import iBase: Match Fields

File, Import, iBase

Purpose
Use Import iBase: Unmatched Fields if there are fields in the imported iBase that do not 
match those in the target or receiving iBase.    You can either match the incoming fields 
with those that already exist (if they are of the same type), or create a new field in the 
receiving iBase.    For example, if you are importing objects that have a "Billing Time" field,
but the objects in the receiving iBase do not have this field, you can either match it with 
an existing Time field, or create a new field.

Steps

1 Choose Import from the File menu, then choose iBase.

2 Select the .OMG import file that represents the iBase you wish to import, then choose 
OK.

3 If you chose the wrong .OMG import file, choose Go Back to select a different one, then 
choose OK.

4 Drag a field in the Input Field list box and drop it on the matching field in the Receiving 
Field list box.

If you try to match fields of two different types, such as a Date field and a Telephone 
field, you will get an error message.    The fields you match must be of the same type.

5 If a field in the Input Field list box does not match a field in the Receiving Field list box, 
drag the field on <Add Field> to add it to the receiving iBase.

6 Choose OK.

See Also
Combine iBases or Parts of iBases: The Big Picture
Creating a New Category When Importing iBase
Reconciling Differences in Objects and Connections
Select Different Category When Importing iBase



Publisher Info

File, Export, iBase, Specify Range, Select Export File

Purpose
If you are using the Export iBase feature for publishing purposes, you can use Publisher 
Info to specify the name, source ID field, iBase version, and release date of the iBase you 
are publishing.    This dialog box appears only if you have started InfoCentral with the 
/AUTHOR startup option.

Steps

1 Type the information that you wish to appear as a person imports the iBase you are 
publishing.

2 Choose OK.



GroupWise Update

Calendar, File, GroupWise

Purpose
Use GroupWise Update to exchange appointments and tasks between the WordPerfect 
GroupWise 4.1 and InfoCentral calendars.    Example

            Because the GroupWise Update feature exports from and imports to certain 
fields in the event and task objects (such as the Meeting Date, Description, and Priority 
fields), you should not delete or change any of the pre-defined fields of these object 
types.    If you do, the GroupWise Update feature will not function properly.

Steps

1 If you are not already in the InfoCentral Calendar, click the Calendar tab.

2 Choose GroupWise Update from the File menu.

3 Choose from the following options, then choose OK.

          Import
Get appointments and tasks from your copy of GroupWise and add them as new event 
and task objects to your InfoCentral Calendar.

          Export
Transfer event and task objects from the InfoCentral Calendar into your GroupWise 
Calendar.

          Time Period
Specify the range of days that include the events and tasks that you wish to import or 
export.    The From: and To: notes indicate the range you have specified.

                    Note that GroupWise task priorities that include letters (for example, A1, C5, 
and Z2) are converted to numbered priorites (for example, 1, 5, and 2).    GroupWise 
priorities that contain only a letter are converted to priority 1 in InfoCentral.

See Also
Send E-mail



ABS

Purpose
Returns the absolute value of its numeric argument.    The absolute value of a negative 
number is the number converted to positive.    The absolute value of a positive number is 
the same number.

Syntax
ABS(Number)

Examples
ABS(12)
Returns 12 where 12 is a numeric constant.

ABS(Nbr)
Returns 550 where Nbr is a numeric variable set to the value 550.

ABS(Positive_Nbr)
Returns 700 where Positive_Nbr is a numeric variable set to the value 700.

See Also
SGN



ASC

Purpose
Returns the decimal ASCII character code of its string argument.    The ASCII character 
code that is returned has a value from zero to 255.    If Character$ contains a string longer 
than one character, the ASCII code value of the first character is returned.

Syntax
ASC(Character$)

Examples
ASC("A")
Returns 65 where "A" is a string constant.

ASC(Initials)
Returns 66 where Initials is a string variable set to the value BLT.

See Also
CHR$



INSTR

Purpose
Returns the character position of the first character position where its second string 
argument occurs in its first string argument.    Token$ must occur in the same case in Text$
to be detected.    That is, "Alpha" is not the same as "alpha."

Syntax
INSTR(Text$,Token$)

Examples
INSTR("See Spot run fast.","Spot")
Returns 5 where "See Spot run fast" and "Spot" are both string constants.

INSTR(Sentence$,Verb$)
Returns 10 where Sentence$ is a string variable set to the value "See Spot run fast" and 
Verb$ is a string variable set to the value "run".

INSTR("My name is Jerry","jerry")
Returns 0 where "My name is Jerry" and "jerry" are both string constants.    Since the cases
dont match in "jerry" and "Jerry" then no occurrence is found and INSTR returns zero.



INT

Purpose
Returns the largest integer less than or equal to the value of its numeric argument.    
Number may be positive, negative, or zero.

Syntax
INT(Number)

Examples
INT(89.2468)
Returns 89 where 89.2468 is a numeric constant.

INT(Nbr)
Returns 500 where Nbr is a numeric variable set to the value 500.01 Nbr

INT(Nbr)
Returns .34 where Nbr is a numeric variable set to the value 12.34.    The fractional 
component of a number may be determined by subtracting its integer component from 
itself.



LEN

Purpose
Returns the length, or number of characters contained in its string argument.    The 
number of characters includes spaces.

Syntax
LEN(Text$)

Examples
LEN("How long is this text?")
Returns 22 where "How long is this text?" is a string constant.

LEN(My_name)
Returns 13 where My_name is a string variable set to the value "Marc Sabatini."



RND

Purpose
Returns a random number with a value from .0000001 and .9999999.    The random 
number generator that is used by the RND function is reseeded by its numeric argument.   
Reseeding a random number generator causes it to generate a different series of 
numbers.    Using a component of the system time, or the seconds past midnight, as a 
seed value is a common practice to assure that the series of random numbers varies with 
each session of use of the random number generator.

Syntax
RND(Seed_value)

Examples
RND(5)
Returns a random number with a value from .000001 and .999999 where 5 is a numeric 
constant and used by the RND function to seed the random number generator.



SGN

Purpose
Returns the sign of its numeric argument.    If Number is positive, SGN returns the value 1.  
If it is negative, SGN returns the value 1.    If it is zero, SGN returns the value 0.

Syntax
SGN(Number)

Examples
SGN(23)
Returns 1 where 23 is a numeric constant.

SGN(Nbr)
Returns 1 where Nbr is a numeric variable set to the value 450.

See Also
ABS



TRIM$

Purpose
Returns a copy of its string argument with any leading and trailing spaces removed.

Syntax
TRIM$(Text$)

Examples
TRIM$("    Hi there    ")
Returns "Hi there" where "    Hi there    " is a string constant.    Both leading and trailing 
spaces are removed by the TRIM$ function.

TRIM$(Full_name$)
Returns "Marc Sabatini" where Full_name$ is a string variable set to the value "      Marc 
Sabatini    "

See Also
TRIML$
TRIMR$



TRIML$

Purpose
Returns a copy of its string argument with any leading spaces removed.

Syntax
TRIML$(Text$)

Examples
TRIML$("    This is it    ")
Returns "This is it    " where "    This is it    " is a string constant.

TRIML$(Last_name$)
Returns "Johnson    " where Last_name$ is a string variable set to the value "    Johnson    "

See Also
TRIM$
TRIMR$



TRIMR$

Purpose
Returns a copy of its string argument with any trailing spaces removed.

Syntax
TRIMR$(Text$)

Examples
TRIMR$("    Big test    ")
Returns "    Big test" where "    Big test    " is a string constant.

TRIMR$(Type_of_car$)
Returns "    Jaguar" where Type_of_car$ is a string variable set to the value "    Jaguar    "

See Also
TRIM$
TRIML$



UCASE$

Purpose
Returns a string that is its string argument with any lowercase letters converted to 
uppercase.

Syntax
UCASE$(Mixed_text$)

Examples
UCASE$("Converts this")
Returns "CONVERTS THIS" where "Converts this" is a string constant.

UCASE$(Last_name$)
Returns "DA SILVA" where Last_name$ is a string variable set to the value "da Silva".

See Also
LCASE$



VAL

Purpose
Returns the numeric value of its string argument.

Syntax
VAL(String_value$)

Examples
VAL("123.45")
Returns 123.45 where "123.45" is a string constant.

VAL(Retail)
Returns 41.50 where Retail is a string variable set to the value "41.50".

See Also
STR$



INSERT

Purpose
Inserts a new object into the iBase.    Category$ is a mandatory argument.

Syntax
INSERT Category$ ERRORTO=Label

Parameters
$Category$
Specifies the category for the inserted object.

Label
The statement label where macro execution resumes if an exception occurs during the 
INSERT.

Examples
CLEAR CATEGORY "Person"
INSERTPerson
NewApptObj=Sys_object_ID
READ REWIND
READ NewApptObj
EXTRACT NewApptObj
SETVALUE First_Name$, Glen
SETVALUE Last_Name$,Morris
UPDATE
DISPLAYObject+Str$(Sys_object_ID)+insertedWAITFORKEY

Clears all fields associated with the object category Person.    Two fields    first names and 
last names    are assigned values.    A new Person object is inserted and its assigned object 
ID is placed into the Sys_object_ID system variable.    READ REWIND gives the instruction 
to go to the beginning of iBase, and READ NewApptObj instructs Find new object by its ID. 
The EXTRACT string ensures that a new object will be extracted from iBase, while the 
SETVALUE strings set new object information.    Finally, the iBase is updated with the 
changed object.



Cleanup iBase

File, Housekeeping, Shred Private Information, OK

Purpose
Use Cleanup iBase to select the information in your iBase marked as private that you wish 
to shred.

            Use this option with caution.    You will not be able to restore the information 
that you shred.

Steps

1 Choose Housekeeping from the File menu.

2 Select Shred Private Information, then choose OK.

3 Choose from the following options.

          Shred all Attached Memos
Purge all memos that you have attached to the objects that you have marked as 
private.

          Shred the Contents of all Memo Fields
Purge the contents of all memo fields for those objects that you have specified as 
Private.

          Shred all Connection Descriptions that are not in use
Purge all connection descriptions that you have not used to connect objects.

          Shred all File Titles
Purge the titles of the files you have connected to objects (not the files themselves).

See Also
Housekeeping
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ODMA Support

Purpose
ODMA (Open Document Management API) lets you use other ODMA-supporting document 
management systems you have installed instead of WordPerfect's file management dialog.

Steps
To use a WordPerfect file management dialog,
1 Request a WordPerfect file management dialog box from the current document 

managment system.

To return to your document management system,
1 Open a WordPerfect file managment dialog box.

2 Choose the appropriate button.

See Also
Managing Files



Open a Copy of a File

Purpose
Use Open As Copy to open a document as a read-only copy. You can read the document 
and make changes to it, but you must save it with a different filename.

Steps

1 Choose Open from the File menu, then select Open As Copy.

2 Specify the filename you wish, then choose Open.

3 Read the file or make changes to it.

4 Choose Save As from the File menu, type a new name for the file, then choose Save.

See Also
Opening Files



 Hint
Find allows you to use multiple wildcard characters (* and ?) in your search string.



Select Directory

Purpose
Use the folder icon to select the directory you wish. It appears next to text boxes where 
you need to specify a directory name. When you choose OK, the directory you selected 
appears in the text box.

Steps

1 Click the folder icon.

2 Select the drive and directory you wish to list the files in.

Choose a QuickList entry.

3 Choose OK.



Filename

Purpose
Use the Filename text box to specify the file you wish. You can type in the full pathname of
a file, or select it from the list of files in the current directory. You can also use the History 
list to access a list of previously opened files or selected directories.

Steps
To select a particular filename,
1 In a directory dialog box, select the drive and directory you wish to list the files in.

Choose a QuickList entry.
2 Specify the name of the file you wish to open, select or save.

3 Choose OK.
Right-click on the files list, then choose the option you wish.

To select a previously selected filename or directory,
1 In a directory dialog box, click the arrow to the right of the Filename text box.

2 Select the name of the file you wish to open, or the directory you wish to use.

3 Choose OK.

See Also
Directories List
Drives
List files
File Options
QuickList



List Files of Type

Purpose
Use the List Files of Type drop-down list to choose the type of files you wish to display. For 
example, choosing Text Files (*.txt) displays all the files in the current directory with a .TXT
extension.

Steps

1 In a directory dialog box, choose the file type you wish to display in the list files.

See Also
Directories List
Drives
List files
QuickList
Save File As Type



Drives

Purpose
Use the Drives drop-down list to choose the drive in which you wish to list directories and 
files.

Steps

1 In a directory dialog box, choose the drive you wish.

See Also
Directories List
List files
QuickList



List files

Purpose
Use the list files box to view the files in the currently selected drive and directory, and to 
select the files you wish to use.

Steps

1 In a directory dialog box, select the type of files you wish to list.

2 Select the drive and directory whose files you wish to list.
Select a QuickList item.

3 Select the file(s) you wish.

4 Choose OK.
Right-click on the files list, then select the option you wish.
See Also

Directories List
Drives
List files Display
File Options
List Files of Type
QuickList
Save File As Type



QuickList

Purpose
Use the QuickList to access directories or files without entering the full path every time. 
Use the QuickList options to change the default directory display in your directory dialog 
boxes and to edit your QuickList.

Steps
To display the QuickList,
1 Enter any directory dialog box, then choose QuickList.

2 Choose Show QuickList, Show Directories, or Show Both.

To use the QuickList,
1 Select the QuickList item you wish.

2 Select the file(s) you wish.

3 Choose OK.
Right-click on the files list, then select the option you wish.
See Also

Add or Edit QuickList Item
Delete QuickList Item
Print Lists
Open/Save As Setup



Viewer

Purpose
Use the Viewer to display, print, or play files without retrieving them into the document 
window.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a file from 
the list files.

2 Choose View.

3 Right-click on the Viewer window, then select an option from the QuickMenu to use 
Viewer features.

4 Choose Close from the Control menu to exit the Viewer.

See Also
Additional Information about Viewer
Viewer Info
Viewing Files



File Options

Purpose
Use the File Options pop-up list to choose options you wish to perform on the selected 
file(s) or directory.

Steps

1 In a directory dialog box, select the file(s) you wish to affect. 

2 Choose File Options, then choose from the following options:
Copy
Move
Rename
Delete
Change Attributes
Print
Print List files
Create Directory
Remove Directory
Rename Directory



Directories List

Purpose
Use the Directories list box to view a list of directories and subdirectories in a selected 
drive and to select the directory you wish to use.

Steps

1 In a directory dialog box, select a drive from the Drives drop-down list, then double-click
directory names to list their subdirectories.

 
2 Double-click a directory name to select that directory and display the names of the files 

in it.

3 Right-click on the Directories list, then choose Create Directory to create a subdirectory 
within a selected directory.

Choose Remove Directory to remove the selected directory.

See Also
Create Directory
Drives
File Options
Print Lists
QuickList
Remove Directory



Sorting Files

Open/Save As Setup, Sort By and Sort Order

Purpose
Use Sort By to sort filenames in the files list box by filename, extension, size, date/time, 
descriptive name, or descriptive type. Use Sort Order to specify an ascending or 
descending order.

Steps

1 Enter any directory dialog box, then choose Setup.

2 Select a Sort By option.

3 Select a Sort Order.

4 Choose OK.

See Also
Create Speedup Files
List files Display
Open/Save As Setup



List files Display

Open/Save As Setup, List files Display

Purpose
Use List files Display to specify which elements of a file's description will display in the list 
files box.

Steps

1 Enter any directory dialog box, then choose Setup.

2 Select a Show option.

3 Select Show Column Labels if you wish to display headings for Custom Columns.

4 Select Show Hidden/System Files if you wish to display hidden and system files.

5 Select Change Default Directory to change the default directory every time you move to
a new directory.

6 Choose OK.

See Also
Create Speedup Files
Open/Save As Setup
Sorting Files



Create Speedup Files

Open/Save As Setup, Create Speedup Files

Purpose
Use Create Speedup Files to make files display faster when you are displaying Document 
Summary information (descriptive name and type) in the list files.

Steps

1 Enter any directory dialog box, then choose Setup.

2 Select Custom Columns or Descriptive Name, Filename.

3 Select Create Speedup Files.

4 Specify a directory to store the speedup files.

5 If the directory specified does not exist, choose Yes to create the directory.

See Also
List files Display
Open/Save As Setup
Sorting Files



Save File As Type

Purpose
Use the Save File As Type drop-down list to choose the format of the file you wish to save.

Steps

1 In a directory dialog box, select the drive and directory where you wish to save your file.

2 Specify the name of the file you wish to save.

3 Choose the format you wish.

4 Choose OK to save the file in the selected format.

See Also
Directories List
Drives
Filename
List files
QuickList
Save Format



Viewing Files

Viewer, select a file

Purpose
Use the Viewer to display, print, or play the contents of text, graphics, audio-visual, sound,
cursor, icon, and fax files. The Viewer may not show all formatting exactly as it appears in 
the file.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a file from 
the list files.

2 Choose View.

Use the controls in the Viewer to play, stop, reset, fast forward, rewind, or move to the 
beginning or end of audio-visual or sound file.

3 To use features supported by the Viewer, right-click inside the Viewer window, then 
select an option from the QuickMenu. The QuickMenu will change, depending on what 
type of file you are viewing.
Copy to Clipboard
Document Summary
Document Text
Find
Find Next
Find Previous
Font
Go To Page
Graphic Conversion
Hex Display
Invert
Next Page
Previous Page
Print
Remove Highlights
Rotate
Viewer Info
Word Wrap
Zoom

4 Choose Close from the Viewer Control menu to exit the Viewer.

See Also
Printing from the Viewer
Viewer Info
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 folder icon
A small file folder icon next to a text box. The folder icon appears on dialog boxes and is 
used to access another dialog box to select files or change directories. Sometimes called a 
list button.



directory dialog box
Dialog boxes that allow you to open, save, name, find, view, copy, move, rename, delete, 
and print files. They also let you create and remove directories. Directory dialog boxes 
appear when you use any feature that retrieves or saves a file, such as Open, Save As, Insert
File, and so on.



dialog box
Dialog boxes let you communicate with an application. They display warnings and messages,
and they let you select and implement options by choosing appropriate command buttons. 
Dialog boxes have a title bar and a control menu, but they do not have a menu bar. They can
be moved to different locations on the screen. Most dialog boxes must be closed before you 
can work in the document window, but a few will allow you to move between the window 
and the dialog box.

When a dialog box option is unavailable and cannot be used, it will appear dim. If 
subsequent actions make the item available, it will change to a normal appearance.



Viewer Info
Lets you display default settings by viewer or file type.



Find Next
Lets you find the next occurrence of the current Viewer search text. (Find Next appears only 
if you have used Find in a text file.)



Find Previous
Lets you find the previous occurrence of the current Viewer search text. (Find Previous 
appears only if you have used Find in a text file.)



Add or Edit QuickList Item

QuickList, Add Item

Purpose
Use Add QuickList Item to add items to the list of directories and files you use frequently. 
Use Edit QuickList Item to edit your list of frequently used directories and files.

Steps
To add a QuickList item,
1 Enter any directory dialog box.

2 Right-click on the QuickList, then choose Add Item.

3 Specify the directory or filename you wish to add to the QuickList.

4 Type a descriptive name.

5 Choose OK.

To edit a QuickList item,
1 Enter any directory dialog box.

2 Select the item you wish to edit.

3 Right-click on the QuickList, then choose Edit Item.

4 Make the changes you wish.

5 Choose OK.

See Also
Delete QuickList Item
QuickList



Change File Attributes

Purpose
Use Change Attributes to change the Archive, Read-Only, Hidden, and System attributes of
one or more files. 

Steps

1 In a directory dialog box, select the file(s) you wish to change. Make sure the selected 
files are not already open.

2 Right-click on the files list, then choose Change Attributes.

3 Choose from the following options:
Archive
Read-Only
Hidden
System

4 Choose OK.

See Also
File Options



 Hint
To open a file without choosing OK, double-click a filename in the list files box of a directory 
dialog box that lets you open files.



Remove Highlights
Removes any highlights placed in the Viewer file by Find.



Drag and Drop Capabilities

Purpose
Use the drag-and-drop capabilities built into directory dialog boxes to launch applications, 
open files, package files as OLE objects, and create Windows Program Manager icons for 
applications.

Steps
To launch an application,
1 In a directory dialog box, drag a filename from the list box onto the .EXE file for the 

application you wish to launch.

This launches the application and opens the selected file within it.

To open a file in an open application,
1 Open the application you wish to work in.

2 Open a directory dialog box in another application.

3 Drag the filename of the file you wish from the files list onto the title bar of the 
application.

To package a file as an OLE object,
1 Open a directory dialog box.

2 Drag the filename of the file you wish from the files list into an open document window 
in a different application.

To create an application icon,
1 Open a directory dialog box.

2 Drag an .EXE file into a Program Group in Windows Program Manager.

See Also
Managing Files
Opening Files



 Hint
Filenames can be a maximum of eight characters, followed by a period and a three-
character extension. When you name a document, do not use the following characters:    * + 
= [ ] : ;      < > ? / \ |. A period can be used only to separate the first part of the filename from
the filename extension. For example, if you specify the filename GIRAFFE.ABCD, WordPerfect
applications will read and record the name as GIRAFFE.ABC. 

If you do not specify an extension, WordPerfect applications save the file with the extension 
that identifies the format selected. Specify a filename that ends with the period if you do not
wish to add the default extension.



 Hint
You will not be able to recover the files or subdirectories after you delete them.

If you do not select a different directory before choosing Remove Directory, the application 
will remove the current directory.



Rename Directories

Purpose
Use Rename Directory to give directories new names.

Steps

1 In a directory dialog box, right-click on the Directories list, then choose Rename 
Directory.

2 Specify the new location or name for the selected directory, then choose Rename.

See Also
Create Directory
Remove Directory



Archive
Archives or backs up the file(s) the next time you run a third-party backup program.



Copy Files

Purpose
Use Copy to copy one file or multiple files into other drives or directories.

Steps

1 In a directory dialog box, select the file(s) you wish to copy. 

2 Right-click on the files list, then choose Copy.

3 Specify the path or filename for the file(s).

4 Select Do not replace files with the same size, date, and time to avoid copying files that 
are identical to the files they would replace.

5 Choose Copy.

You can also copy files by selecting a filename from the list box and dragging it to 
another drive or directory in the Directories list box or the QuickList.

See Also
Move Files
Rename Files



Create Directory

Purpose
Use Create Directory to create a new directory or subdirectory in the current drive.

Steps

1 In a directory dialog box, select the drive or directory you wish to add a directory to.

2 Right-click on the Directory list, then choose Create Directory.

3 Type a name for the directory.

4 Choose Create.

See Also
File Options
Remove Directory
Rename Directory



Read-Only
Protects the file(s) from being modified or deleted.



Custom Columns
If you also select Show Column Labels, Custom Columns lets you select from a list of column 
types to display in a list files.



Delete Files

Purpose
Use Delete to delete one or more files.

Steps

1 In a directory dialog box, select the file(s) you wish to delete. 

2 Right-click on the files list, then choose Delete.

3 Choose Delete.

See Also
Copy Files
File Options
Move Files



Hidden
Hides the file(s) in directory dialog box list filess and QuickFinder Search Results lists, and 
makes it a hidden file for DOS.



 Hint
To select a column label, click a blank space between column labels with the right mouse 
button, then choose an option. You may need to scroll right to find a blank space.
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Network

Purpose
Use the Network options list to view and edit network settings. The number and type of 
options will vary depending on your network software. Network only appears if your 
computer is connected to a network.

Steps

1 Enter any directory dialog box, then choose Network.

Depending on the network driver and version you are using, the options that appear will
vary. Choose the Help buttons on the Network dialog boxes for more information.
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System
Identifies the file(s) to DOS as part of your computer's operating system. The file(s) are not 
displayed in directory dialog box list filess or QuickFinder Search Results lists.



Move Files

Purpose
Use Move to move one or more files to a different drive or directory.

Steps

1 In a directory dialog box, select the file(s) you wish to move.

2 Right-click on the files list, then choose Move.

3 Type the path or filename you wish the file(s) moved to.

Click the list button, select the directory you wish the files moved to, then choose OK.

4 Choose Move.

You can also move files by selecting a filename from the list box and pressing Alt or Shift
while dragging it to another drive or directory in the Directories list box or the QuickList.

See Also
Copy Files
File Options



Managing Files

Purpose
In WordPerfect applications, file management capabilities are provided in directory dialog 
boxes. For example, you can use this dialog box to select directories, choose macros, 
locate specific files, open documents, and save documents as new or renamed files. You 
can find and select directories and files using the drive, directory, and list filess. You can 
also change network connection or document management options if you are connected 
to a network or have alternate document management programs.

To find a more specific Help topic about your task, use the Search button above to look up 
the title of a specific dialog box or option.

            The options that appear on this dialog box will change depending on its title 
and the application in which it appears.

Choose from the following options for more information:
Filename
List files
Save File As Type
Directories List
QuickList
Drives
List Files of Type

See Also
Drag and Drop Capabilities
File Options
Network
ODMA Support
Opening Files
Saving Files



Open/Save As Setup

Purpose
Use Open/Save As Setup to specify how you wish to display the list files and to set the 
Speedup Files options for directory dialog boxes.

Steps

1 Enter any directory dialog box, then choose Setup.

2 Make the changes you wish, then choose OK.

Choose from the following options for more information:
Create Speedup Files
List files Display
Sorting Files

See Also
Managing Files



Print Files

Purpose
Use Print to print one or more files without opening them into the current document 
window.

Steps

1 In a directory dialog box, select the file(s) you wish to print. 

2 Right-click on the files list, then choose Print.

3 Choose Print.

See Also
File Options
Print Lists



Print Lists

Purpose
Use Print List to print a list of selected files or all files displayed in the list files box, the 
Directory List, or the QuickList.

Steps
To print a list files,
1 In a directory dialog box, choose Setup, then select the List files Display options you 

wish. The information displayed on a printed list files is identical to the information 
displayed in the list files box.

2 Select the files in the list files that you wish to include on the printed list. Skip this step 
if you wish to print the entire list files.

3 Right-click on the files list, then select Print List files.

4 Choose the type of list you wish to print.

5 Select Include Subdirectories to print subdirectories in addition to the list.

6 Choose Setup, select a printer, orientation, and paper size and source, then choose OK.

7 Choose Change, select a font, style, and size, then choose OK.

8 Choose Print.

To print a directory list,
1 Enter any directory dialog box, then right-click on the Directories List.

2 Choose Print Directory List.

3 Select the printing option you wish.

4 Choose Setup, select a printer, orientation, and paper size and source, then choose OK.

5 Choose Change, select a font, style, and size, then choose OK.

6 Choose Print.

To print a QuickList,
1 Enter any directory dialog box, then choose QuickList.

2 Choose Print QuickList.

3 Select the printing option you wish.

4 Choose Setup, select a printer, orientation, and paper size and source, then choose OK.

5 Choose Change, select a font, style, and size, then choose OK.

6 Choose Print.



See Also
File Options
Print Files



Remove Directory

Purpose
Use Remove Directory to remove a directory and to delete any subdirectories and files 
contained in the directory you wish to remove. If you do not select a different directory, 
the application will delete the current directory.

Steps

1 In a directory dialog box, select the directory you wish to remove.

2 Right-click on the Directories list, then choose Remove Directory.

3 Choose Yes to delete the selected directory, including all files and subdirectories in it.

See Also
Create Directory
Delete Files
File Options
Rename Directory



Rename Files

Purpose
Use Rename to give one or more files new names and locations.

Steps

1 In a directory dialog box, select the file(s) you wish to rename.

2 Right-click on the files list, then choose Rename.

3 Specify the new path or filename for the selected file(s), then choose OK.

4 Choose Rename.

See Also
File Options
Move Files
Select Directory
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Viewer Find

Purpose
Use Viewer Find to highlight all occurrences of the search words or phrases in the file.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a text file 
from the list files.

2 Choose View.

3 Right-click inside the Viewer window, then choose Find from the QuickMenu.

4 Type the text you wish to find. If you wish to find a phrase, enclose it in quotation 
marks.

5 Select Match Whole Word Only if you do not wish to find the search text within other 
words, like "cat" in "vacation."

6 Select Case Sensitive if you wish to search for capital letters just as you have typed 
them.

7 Press Enter.

8 Choose Find Next or Find Previous to locate other instances of the search text.

9 Choose Close.

See Also
Viewer
Viewing Files



Viewer Font

Purpose
Use Viewer Font to select the font (size and typeface) you wish to display in the Viewer.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a text file 
from the list files.

2 Choose View.

3 Right-click inside the Viewer window, then choose Font from the QuickMenu.

4 Select a font and point size.

5 Select Bold or Italic if you wish the entire Viewer text in bold or italic.

6 Choose OK.

See Also
Printing from the Viewer
Viewer
Viewing Files
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application
Software designed to carry out a certain kind of action or activity, such as word processing, 
electronic mail, or spreadsheet entries. Sometimes called a program.



Control menu
The menu containing commands that will open, close, maximize, minimize, or restore a 
window or dialog box. You can display a Control menu by clicking the Control-menu box or by
pressing Alt+Spacebar.



double-click
To press and release the mouse button twice in rapid succession.



filename
The name given to a data file used by applications to perform open and save operations. In 
DOS and Windows applications, filenames can have as many as eight characters with an 
optional extension of as many as three characters. The filename and extension are 
separated with a period.



Saving Files

File, Save or Save As

Purpose
You can save hundreds of files on a hard disk, which works like a filing cabinet with 
directories and subdirectories as file drawers and folders that group similar files. You can 
save files with new names, save them in different directories, or save them in different 
formats. If you do not specify a directory or format, WordPerfect applications save files in 
the current directory and default format.

You should use Save periodically to avoid losing your work if a power or system failure 
occurs. You can also use the Backup features to avoid losing your work.

Steps

1 Choose Save or Save As from the File menu.

2 Select the directory where you wish to save the file from the Directories list box or the 
QuickList.

Type the full path for the file before the filename.

3 Type a filename for the file.

Select the file you wish to replace with the saved file.

4 Choose the format you wish.

5 Choose Save to save the file in the selected format.

See Also
Opening Files
Save File As Type
Save Format



list button
In dialog boxes, a way to get to another dialog box to select files or change directories. It 
appears as a small file-folder button next to a text box.
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path
The address that tells a computer where to locate a directory or file on a disk or network. A 
path includes the drive, the root directory, and any subdirectory names that branch from the
root directory.



QuickMenu
A pop-up menu that lists a specific set of items that apply to a particular feature. You can 
open a QuickMenu by placing the mouse pointer over the object and pressing the right 
mouse button. You select the option you wish by clicking it with the left mouse button.



root directory
The fundamental directory of a disk, created when the disk is formatted.
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 Hint
Choose an option from the Save File As Type list to save a file in a format other than the 
default for the current application. WordPerfect applications save the file with a default 
extension that identifies the selected file type and format. You can type a period at the end 
of the filename to save the file without an extension, or type your own extension.

Some extensions have special meaning in WordPerfect applications, DOS, or Windows. These
include .ALL, .BAT, .BIF, .COM, .DLL, .EXE, .INI, .PRS, .SET, .WCM, .WPT, and .WWK. Do not 
use these extensions when saving documents unless you have a specific reason for doing so.



 Hint
Click and drag to select a continuous range of items. You can also click an item at one end of
the range, then hold down the Shift key and click the item at the other end of the range.

Press Ctrl while clicking each item you wish to select noncontinuous items. Press Ctrl+/ to 
select all items.

Click inside the list files, then type the first letters or numbers of the filename to move to a 
specific file in a list files sorted by filename, size, or date/time. When the list files is sorted 
by extension, descriptive name, or descriptive type, those items are used in searching.
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Document Text
Lets you view the body of a document (instead of the Document Summary).



Save Format

Purpose
The Save Format dialog box appears when you attempt to save a document which was 
converted from another format when you opened the document. 

Save Format allows you to save the file in the current default format, the original format, 
or in another format.

Steps

1 Open a document that was saved in a format other than your current default format, 
make any changes you wish, then choose Save from the File menu.

2 Choose the default format or the original format.

Choose Other, choose OK, then choose the format you wish. 

3 Choose OK.

See Also
Managing Files
Open/Save As Setup
Save File as Type
Saving Files



Hex Display
Lets you display a file in hexadecimal mode. You can print any kind of file as a hexidecimal 
document.



Copy to Clipboard
Lets you copy selected text from the Viewer to the Clipboard.



Document Summary
Lets you view the Document Summary of a file (instead of the body of the document).



Word Wrap
Lets you wrap document text in the Viewer window so all text shows regardless of the 
window size.



Opening Files

File, Open

Purpose
Use Open to open as many as nine documents or windows in the same application. Open 
works with documents you have previously saved as files on a hard disk or floppy disk. 
When you wish to edit a document that is saved on disk, you need to open a copy of the 
file into a window. The file then becomes active in your computer's memory so that you 
can edit it. The changes you make are not recorded on disk until you save the file again.

Steps

1 Choose Open from the File menu.

2 Select the drive and directory you wish to list the files in.

3 Select the file you wish. 

Type the full path, separated by commas, of as many as nine files at one time to open 
multiple files.

4 Choose OK.

See Also
Managing Files
Open a Copy of a File
Saving Files



Find
Lets you find words or phrases in the document displayed in the Viewer.



Font
Lets you change the font that will show in the Viewer.
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Viewer Go To Page

Viewer, right-click, Go To Page

Purpose
Use Viewer Go To Page to view multiple-page fax files.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a text file 
from the list files.

2 Choose View.

3 Right-click inside the Viewer window, then choose Go to Page from the QuickMenu.

4 Specify the page number you wish to view.

5 Choose OK.

See Also
Viewer
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Invert
Lets you change the display of fax files from black on white to white on black and vice versa.



Rotate
Lets you rotate the current page of a fax file 180 degrees.



Zoom
Lets you change your view of a fax, cursor, or icon file. You can enlarge faxes up to 200% or 
reduce them down to 50%. You can enlarge cursor and icon files up to 800%.

Zoom does not actually size the image, it only changes your view.



Print
Lets you print all or part of a text or hex file, select printers, change fonts, and specify 
margins.



Printing from the Viewer

Viewer, right-click, Print

Purpose
Use Print to print all or part of a text or hex file, select printers, change fonts, and specify 
margins.

Steps

1 Enter any directory dialog box or QuickFinder search results list, then select a text file 
from the list files.

2 Choose View.

3 Right-click inside the Viewer window, then choose Print from the QuickMenu.

4 Specify the pages you wish to print.

5 Choose Setup to select a printer or change printer options, then choose OK.

6 Select display Font to print using the current display font.

Select Specific Font, choose Change, select a font and a point size for printing, then 
choose OK.

7 Select Inches or Centimetres, then specify the margins for printing.

8 Choose Print.

See Also
Viewing Files
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 Hint
You can use wildcard characters to include specific types of files. For example, typing c:\
october\*.shw will include all files in the OCTOBER subdirectory of the C: drive with the 
extension .SHW; typing c:\october\*.* includes all files in the OCTOBER subdirectory.



Viewer Info

Viewer, right click, Viewer Info

Purpose
Use Viewer Info to display viewer capabilities by viewer and file type.

Steps

1 Right-click inside the Viewer, then choose Viewer Info.

2 Select Viewer to display available viewers.

Select File Type to display available file types.

3 Select the viewer you wish to display the file types it can view.

Select the file type you wish to display the compatible viewers.

4 Choose OK.

See Also
Viewing Files



Additional Information about Viewer

Using the Viewer
The Viewer has been designed to:

          Help you find a specific file quickly, especially when you know something 
about the content of the file.

          Help you create documents by copying parts of the document you are viewing
into another document.

          Provide viewing capabilities for files located by a QuickFinder search. The 
Viewer highlights the word or phrase searched for and displays the document at the first
occurrence of the search text.

          Let you assign viewers to specific types of files.

          Let you look at or hear a file before you use it in a document.

          Let you print all or part of a file without retrieving it into a document.

If a Viewer window is displayed, you can select a filename in any list box to view the 
contents of that file.

How the Viewer Works
The Viewer provides a quick display of the contents of a file. The Viewer can display text, 
graphics, codes, and faxes. It also plays audiovisual and sound files.

To enhance its speed, the Viewer has been designed to display document contents, but 
not all of the formatting. Thus, the Viewer does not provide full WYSIWYG viewing of file 
contents. Files display both text and graphics in the Viewer window. If a file you are 
viewing contains only graphics, you can view them if they are in a supported graphics 
format.

Types of Files the Viewer Displays

          WordPerfect documents (4.2, 5.x, and 6.0 formats)

          WordPerfect graphics files (.WPG)

          Sound files (Waveform, MIDI)

          Various non-WordPerfect document and spreadsheet files (including 
documents created in Word for Windows, AmiPro, and Lotus 123 spreadsheets)

          Various graphics file formats

          Fax files (DCX and some TIFF formats)



          List of files contained in a ZIP file

          Cursor and icon files

See Also
Viewer
Viewing Files
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 Hint
If you try to open a file that was created in a format other than the format the current 
application uses, the Convert File Format message box appears. Choose OK to convert the 
file.

If a WordPerfect application cannot convert the file, an error message will inform you that 
the file format is unknown. If this occurs, you may wish to use the original program to save 
the file in DCA/RTF or RTF format. If neither of these formats is available, you can save the 
file as an ASCII (DOS) text file. However, some formatting features in your file may be lost 
when you open it into the current application.



Graphic Conversion
Lets you convert graphics for viewing. If you choose Disable Graphics Conversion from the 
QuickMenu, you can use the conversion button in the Viewer to convert individual graphics 
files for viewing.



Exclude Files
Ignores all specified file types. All files with .EXE, .COM, and .DLL extensions are excluded by
default.



Expand Browse Dialog
Lets you specify how the Create and Edit Index dialog boxes appear. If you select Expand 
Browse Dialog, the Filename, Drives, and Directories display each time the dialog box is 
opened. (Applies to all indexes.)



Extended Characters in Non-WP Documents
Lets you specify how extended characters in documents other than WordPerfect formats are 
treated in the index. If you are indexing a document created in Windows, choose Interpret as
ANSI; if you are indexing a document created in DOS, choose Interpret as ASCII. If you have 
both or are unsure, select Exclude.



Include Numbers in Index
Indexes numbers as well as letters.



Index Contains
Lets you specify how much of a document to index.



Index Level
Lets you specify an area to search for word patterns (for example, on the same line, or in the
same paragraph).



Index WordPerfect Documents Only
Indexes only WordPerfect 5.1/5.2 and 6.0 documents (but not WordPerfect 4.0 documents).



Location for Index Files
Lets you specify the default location for index files. (Applies to all indexes.)



Delete QuickList Item

QuickList, Delete Item

Purpose
Use Delete Item to remove an item from a QuickList.

Steps

1 Enter any directory dialog box.

2 Select the item you wish to delete.

3 Right-click on the QuickList, then choose Delete Item.

4 Choose Yes.

See Also
Add or Edit QuickList Item
QuickList
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Go to Page
Lets you specify the page number you wish to view.



Next Page
Lets you move to the next page of the fax file.



Previous Page
Lets you move to the previous page in the fax file.



UNC Drive Mappings

Purpose
When your computer is part of a network, use Universal Naming Convention (UNC) drive 
mapping formats anywhere you specify a filename.

Steps

1 Enter any directory dialog box or QuickFinder search results list.

2 Specify the filename of the file, using the following syntax for drive mapping 
conventions:
UNC Format = \\Server\Volume\Dir\Dir etc...
Acceptable = //Server/Volume/Dir/Dir etc...

Novell Format = Server/Volume:Dir\Dir etc...
Acceptable = Server\Volume:Dir/Dir etc...

3 Choose OK.

See Also
Managing Files




