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This file contains important information that is not included in the printed documentation or online Help.

This file contains information on the following topics: 

> Support Information
> New Features
> Corrections and Additions to Online Help
> Tips and Tricks for Using Word Pro
> Macro and Script Information

Support Information

>Telephone numbers
For all PC desktop products, call Customer Service: 1-800-343-5414, or Technical Support for all 
Windows Desktop applications: 1-978-988-2500.

The hours are Monday - Friday, 8:00 a.m. - 8:00 p.m. (Eastern time).

>Lotus Customer Support
You can access all available customer support numbers in your country by following the instructions 
below.

1. In Word Pro, choose Help - Help Topics.
2. Click the Contents tab.
3. Double-click the Troubleshooting Help topic.
4. Double-click the Lotus Customer Support Help topic.
5. Double-click the desired country.
6. Click the desired topic.

>Support from CompuServe
If you subscribe to CompuServe, you can download updated LotusScript Help and other information. In 
CompuServe, visit the Word Pro forum (type "GO WORDPRO").

>Support on the Internet
If you have an Internet connection, you can download updated LotusScript Help and other information 
from the Lotus Support Web page. To access the Lotus Web page, your computer should have a 
WinSock-based connection to the Internet. Follow the directions provided with your browser for 
downloading files. The Web site is located at:

http://www.support.lotus.com/ftp/pub/desktop/wordpro

You can access the same material using an FTP client program. The FTP site is located at: 

ftp://ftp.support.lotus.com

You can find more information about Lotus products and upgrades by going to the Lotus home page. The 
Lotus Web site is located at:

http://www.lotus.com



New Features for Word Pro Release 9
* Java integration
* Internet Setup Assistant
* HTML Export Assistant
* High fidelity Internet output via Net-It
* ViaVoice integration
* Text wrap around the contours of a graphic
* Custom Menu Editor
* Outline Assistant
* Click Here Management
* ADA compliance for users with disabilities

Corrections and Additions to Online Help

>TeamMail
If you are using Lotus Notes® as your e-mail application, you can use TeamMail to send selected text in 
your document out as e-mail. Because DDE only works with Notes, this option is not available with other 
e-mail applications.

>>Using TeamMail with Notes for Windows 3.1:
Any version of Notes designed for Windows 3.1 requires the following lines in the WIN.INI file:

[LotusMail]
Program=<path to notes files>\notes.exe NoDialogs
Application=notes

>>Using TeamMail with cc:Mail 2.x:
cc:Mail 2.x requires the following lines in theWIN.INI file:

[LotusMail]
Program=<path to ccmail files>\wmail.exe SENDMAIL
Application=wmail

Note: Lotus applications designed for Windows 3.1 require the path to the mail program to be listed in the
AUTOEXEC.BAT file. When you use Windows 95 or Windows NT with Lotus mail applications designed 
for Windows 95, it is not necessary to list paths in the AUTOEXEC.BAT file. However, older versions of 
cc:Mail (2.1 and earlier) may require this listing. If cc:Mail is not working properly, check the 
AUTOEXEC.BAT file and make sure that the path to the cc:Mail program is listed correctly.

>>Using TeamMail with Notes v4 or later:
TeamMail checks the registry for information about the installed mail package. However, Notes 4.x does 
not write information to the registry. If you are using Notes 4.x, make sure that the lines specified above 
for Notes v3 are in the WIN.INI file.

If you are using Notes 4.1 or later, the registration information is automatically entered in the registry.

>Using OLE 2 applications with embedded objects
When you launch an OLE 2 embedded object (either by double-clicking on the object, or by choosing the 
object's context-sensitive menu and choosing Edit), Word Pro launches the application "in place," and 
allows you to modify the object. When you complete any modifications, the server application remains in 
memory, even though it no longer displays. 



If you are working on a computer with a limited amount of memory, you can close the document after 
editing the object (which also closes the server application), or you can launch a separate instance of the 
object instead of editing it "in place."

>>To launch an application as a separate instance

1. Select the object.
2. Choose the object's context-sensitive menu.

For example, if the object is a Lotus 1-2-3® Workbook, choose the Workbook menu, then choose 
Edit - Object. 

3. Choose Open.
4. When you finish making changes, close the application to copy the changes back to your document 

and release the application from memory.

>Using Ami Pro and Word Pro at the same time
You may need to use both Ami Pro and Word Pro at the same time. You can run them without any 
conflicts, unless you are using embedded objects in other applications. 

If you embedded Ami Pro objects in other applications (for example, in Notes), Word Pro edits and saves 
these objects when you launch them. When changes are saved back to the container application, the 
changes are saved in the Ami Pro format and can be edited by users who have Ami Pro installed.

You can convert embedded Ami Pro objects to Word Pro objects by modifying the Windows registry. Word
Pro can then update embedded Ami Pro objects and convert them to the Word Pro format when they are 
launched by the parent application. For information about converting objects, contact Lotus Customer 
Support.

Caution: Once you convert Ami Pro embedded objects to the Word Pro format, the objects are no longer 
editable in Ami Pro. If you are still using Ami Pro in your organization, or if you expect to send documents 
containing embedded Ami Pro objects to Ami Pro users, Lotus advises you not to modify the registration 
database.

Word Pro tips
The following tips are provided by the Lotus Customer Support department.

How to make the Install program efficient

To maximize the efficiency of the Install program, before you run it, you should perform the following 
procedure to defragment and reclaim lost clusters on your hard drive(s). You do not have to convert lost 
clusters to files, but if you do not, the information stored in those clusters will be deleted.

On systems using Windows 95 or NT 4.0, complete the following steps:
1. Open Windows Explorer.
2. Right-click your hard drive letter (for example, C:).
3. Choose Properties.
4. Click the Tools tab.
5. Click Check Now under "Error-checking status."
6. Click Start.

Once it finishes, you can begin defragmenting the hard drive.
7. Click Defragment Now under Defragmentation status.
8. Click Start.

How to get started using Word Pro for the World Wide Web



There are a few ways to get started using Word Pro to create HTML documents. HTML documents are 
widely used on the Web, and can be viewed by Internet browsers, such as Netscape and Internet 
Explorer.

Use the Internet SmartMasters
1. From the File menu, choose New Document.
2. Click the Create from any SmartMaster tab.
3. Select the desired Internet category under "Select a type of SmartMaster."
4. Select the desired SmartMaster under "Select a look."
5. Click OK.

Use the HTML Export Assistant to convert existing documents to HTML
1. Open the document to be converted to HTML.
2. From the File menu, choose Internet, and then choose HTML Export Assistant.
3. Make any desired selections on the Content, Layout, and Preview & Save panels.

Note: For more information on the HTML Export Assistant, click the desired tab and then click Help.

Open documents from the Internet in Word Pro
Word Pro allows you to open Web pages directly from the Internet using a Uniform Resource Locator 
(URL).

1. From the File menu, choose Internet, and then choose Open from Internet.
2. Select "Web - to open a file on the Web" under "Server type."
3. Type the Web URL in the "Address" box.
4. Click Open to open the Web page in Word Pro.

Note: This process requires connection to the Internet, and may also require some additional setup 
(from the File menu, choose Internet, and then choose Setup).

How do I change the default font used by a specific SmartMaster?

1. From the File menu, choose New Document.
2. Select the SmartMaster to be changed and click OK.
3. From the Text menu, choose Text Properties.
4. Click the Text Format tab in the Text Properties Infobox.
5. Select the desired font, font size and color.
6. Click the Style Tab in the Text Properties Infobox.
7. Click Redefine Style.
8. Click OK to close the Redefine Style Infobox.
9. From the File menu, choose Save As.
10. Change the file type to "Lotus Word Pro SmartMaster (*.MWP)."
11. Enter any text in the "Description" box.
12. Select the folder where your SmartMasters are stored.

To determine the SmartMaster location on your system, choose File, User Setup, Word Pro 
Preferences, and then click the Locations tab.

13. Type the file name for your SmartMaster and click Save.
Note: If you are saving the SmartMaster using an existing name, you are asked if you want to 
overwrite it.

14. Make the desired selections from the Save As SmartMaster Options dialog box and click OK.

How can I mass-convert my files from other word processors to the Word Pro format?

1. From the File menu, choose Import/Export.
2. Under "Select the import or export operation," select "Import data from another application."
3. Under "Select your options," select "Import and convert into Word Pro document(s)."
4. Click Import.
5. Select the documents to be converted.



Note: You can select multiple documents by holding down CTRL and selecting the documents.
6. Click Open to convert the documents to Word Pro format.

Note: The documents are not displayed on the screen during the conversion process.

A common page numbering format includes the total number of pages after the page number, for 
example, "Page X of XX", where 'X' is the number of that page and 'XX' is the total number of 
pages in the document. How can you implement this type of page numbering in Word Pro?

You can display page numbers, such as "Page 3 of 15" in a 15-page document, by following these steps:

1. Place the insertion point in the header or footer. 
2. In the Header/Footer bar, click Insert Field.
3. Select "Page x of xx."

How can you temporarily type beyond the left and right page margins of a document (also known 
as a "margin release")?

1. From the View menu, choose Show/Hide, and then choose Ruler.
2. On the ruler, drag the left margin indicator (bar at the left margin) or one of the indention indicators 

(triangles at the left margin) anywhere between the current margin and the edge of the page.
You can now type past the margins.

If you need to release the left margin repeatedly, or you want to create a style that uses a margin release, 
you can set a negative indent for a paragraph.

1. Place the insertion point in the paragraph you want to modify.
2. From the Text menu, choose Text Properties. 
3. Click the Alignment tab.
4. Specify a negative value in the "Indent from margin" box. 
5. If you only want to use a negative indent for certain lines of the paragraph, click Options, make the 

changes in the appropriate boxes, and click OK.

What are some helpful hints to reduce the size of documents?

Below are five helpful hints to decrease the size of documents in Word Pro.

• Make sure Word Pro is saving files in a format optimized for smaller files. 

When you use this format, displaying and saving files takes slightly longer, but the amount of disk 
space required is greatly reduced. Choose File - User Setup - Word Pro Preferences. Click the 
Enable tab and select "Small file format" in the "Performance" box.

• Don't embed fonts within the file. 

Most of the time, embedding fonts in the file is not needed. Choose File - Document Properties - 
Document, click the Options tab, deselect "Embed fonts in document," and click OK.

• Remove unneeded paragraph styles from the document. 

If you're only using one paragraph style in a document, you may save a few kilobytes of space by 
removing the other paragraph styles. Place the insertion point in the document text, choose Text - 
Named Styles - Manage, select the paragraph style or styles you don't need, click Delete, click Yes, 
and click Close.

• Use sections rather than divisions, if possible.



Since each division is a mini-document with its own styles, page layout, and other formatting 
information, it requires additional disk space. If you want the information in the division to have the 
same format as the rest of the document, consider using a section instead.

• Disable the "Fast graphic display" option.

Choose File - User Setup - Word Pro Preferences. Click the Enable tab, deselect "Fast graphic 
display" in the "Performance" box, and click OK. Graphics within the document may take a little 
longer to display, but the amount of space saved could be great, depending on their size.

When I type, why does the computer overwrite the text already present in my document?

There are two typing modes in Word Pro: Typeover mode and Insert mode.

Insert mode "pushes" existing text out of the way as you type. This is the standard mode for word 
processing.

Typeover mode overwrites any text that exists at the insertion point with the text you type.

You can switch between Insert and Typeover modes by pressing INSERT on your keyboard.

After making changes in the InfoBoxes, how can you go back to the document without using the 
mouse?

Press ALT+ENTER to return to the document at the location of the insertion point.

In Ami Pro, you could use floating headers and footers to create multiple headers and footers. 
Where is this functionality in Word Pro?

You can use sections in Word Pro to create multiple headers and footers. You can continue or discontinue
the headers and footers from the previous page in the Create Section dialog box. If you deselect the 
options, you can create multiple headers and footers in your document. You can also use different 
headers and footers with each new division (Create - Division), or with each new page layout (Page - 
Insert Page Layout).

In Ami Pro, you could link documents back to the original style sheet. Can you do this in Word 
Pro?

Word Pro does not have an option to link documents back to the original SmartMaster because all the 
information from a SmartMaster is copied directly into the document. To save newly created paragraph 
styles to your SmartMaster, you must copy the paragraph styles to the SmartMaster and save the 
SmartMaster itself.

1. Open the SmartMaster (.MWP file) you want to change. 
2. From the Text menu, choose Named Styles, and then choose Manage. 
3. Click Copy From.
4. Select "Another file." 
5. Click Browse and select the file containing the desired paragraph styles.
6. Click Open.
7. Select the paragraph styles to bring over and click Copy. 

Note: Word Pro may display a message. Click the appropriate button.
9. Click Close to return to the SmartMaster. 
10. When you are ready to save the SmartMaster, choose File - Save.

You can use the same procedure to copy the paragraph styles from the newly modified SmartMaster to 
other documents.



Sometimes, the "Ask the Expert" feature does not return the correct topic. Why is this?

The "Ask the Expert" feature is context-sensitive. The topics returned are determined by the text used in 
your query, and the object that is currently in focus in the document at the time of the query.

For example, if you need to locate topics on frames, be sure that a frame is selected in the document 
when you "Ask the Expert."

Is there a way to preview a Word Pro document?

Yes. You can perform most file management tasks, including previewing a file, from the common 
Windows dialog boxes, such as File - Open and File - Close. The following procedure describes how to 
preview a file in the File - Open dialog box. You also can use these same steps in any dialog box that 
displays files.

1. From the File menu, choose Open.
2. Right-click on the document that you want to preview and choose Preview.

Other file management tasks that you can perform include copying files, deleting files, and renaming files.

How do you assign a printer bin to a specific page?

To assign a printer bin to a specific page that is different from the rest of the document, you must insert a 
page layout and then modify it.

1. Click on the desired page.
2. From the Page menu, choose Insert Page Layout.
3. Select an option in the "Insert page layout with page style" box.
4. In the "Start page layout" box, select where the new layout should begin.
5. Click Insert & Edit.
6. Click the Size & Margins tab on the Page layout InfoBox.
7. Deselect "Use settings from printer driver."
8. Select an alternate option in the "Printer bin" box.

The settings in the "Printer bin" box are now used for all pages using the current page layout. 

To set different printer bins for each page, you must insert a new page layout and change the printer bin 
for each individual page. For more information on inserting a page layout, see the online Help.

How do you "reveal codes" in Word Pro?

The status bar displays the font name, font size, font color, whether a word is bold, italic, and/or 
underlined, and the style assigned to selected text. You can change any of these settings by clicking the 
corresponding part of the status bar. 

The InfoBox is a single place where you can change the properties of text, pages, frames, tables, table 
cells, headers, footers, columns, OLE objects, and Word Pro drawings.

The InfoBox has features that make your tasks easier.

* You can leave the InfoBox open on your screen while you work in a document.
* You can collapse the InfoBox to save screen space.
* You can drag the InfoBox to a different part of the Word Pro workspace.
* When you make a choice in the InfoBox, the text on your screen changes instantly.



If you type your choice in an InfoBox text box instead of selecting a highlighted option, the change occurs 
only when you tab or click outside the InfoBox.

The Set View Preferences dialog box allows you to control how the document is displayed. This menu 
allows you to view marks, rulers, grids, and so on. To open the Set View Preferences dialog box, choose 
View - Set View Preferences.

How do you insert bullets in the middle of a sentence?

Word Pro includes a feature that allows you to insert any character at the location of the insertion point.

1. Place the insertion point at the desired location for the bullet.
2. From the Text menu, choose Insert Other, and then choose Symbol.
3. Select the font in the "Font" box.
4. Select the symbol to insert.
5. Click Insert.
6. Click Done.

More than one character can be inserted when the Insert Symbol box is displayed.

How do you open multiple documents at the same time?

With the File - Open box displayed, press CTRL and select the desired files. 

You can also select a sequence of files by selecting the first file in a list, and then holding down 
SHIFT while you select the last file in the list.

Is there a way to modify a page number in a Word Pro document?

Right-click on the page number and choose Edit Page Number.

Macro and Script Information
The following information is for LotusScript and Ami Pro macro developers. Included at the end of this 
section are the most recent changes to the Word Pro object model. This information includes elements of 
Word Pro that have were available to LotusScript, elements that were hidden, and elements that were 
completely removed from the object model.

>Ami Pro macro compatibility
You can use many of the Ami Pro macros in Word Pro. However, some Ami Pro macro functions are not 
supported in Word Pro. Macros using these functions do not run successfully.

The first time you run an Ami Pro macro in Word Pro, it converts to the Word Pro format. If the macro 
uses an unsupported function, Word Pro displays a message. If a macro runs without displaying a 
message, test the macro to make sure it behaves as you would expect.

Specific information about unsupported macro functions and other suggestions for converting macros are 
available from Lotus Customer Support.

>Using LotusScript
You can install the LotusScript Help file by doing a custom Install. (See the Custom Install section.) 
Because the LotusScript Help file for Word Pro is still under construction, the file that you install is not 
complete. To obtain the latest version of the Word Pro LotusScript Help file, you can do one of the 
following:



* Order an updated Help file from Customer Support.
* Download the updated Help files from CompuServe. See the Support section.
* Download the files from the Lotus Customer Support website. See the Support section.

>TeamSecurity passwords with LotusScript
Word Pro Release 9 allows you to automate document password protection using the DocControl class.

>>Assigning a new password or removing a password
If a document has no password, you can use LotusScript to assign one. If a password protected 
document is open, you can use LotusScript to change the password or remove it.

>>Restricting LotusScript password access
If you do not want LotusScript to be able to change the password for a document, you can restrict access 
to the TeamSecurity dialog box for a document as follows:

1. From the File menu, choose TeamSecurity.
2. Click the Access tab.
3. Select "Anyone with this password" under "Who can open this dialog, and change access, editing 

rights, and other protection options."
4. Click Change.
5. Type the desired password, and when prompted, type it again for verification.

Once access to the TeamSecurity dialog box is restricted, you can't use LotusScript to change, add, or 
remove a document password.

>New Word Pro LotusScript elements
There are many new LotusScript elements that were added to the Word Pro Release 9 object model. 
Information on the new elements is provided in the LotusScript Help file. You can also use the LotusScript
Expression Assistant to help construct LotusScript statements and view the documentation for the new 
elements.

>Deleted Word Pro LotusScript elements
The following classes, methods, and properties were deleted from the Word Pro object model, usually 
due to a change in functionality. If you have existing scripts that use these classes, properties, or 
methods, you should modify them.

Elements that were removed only from certain classes are noted as such.

>>Deleted classes
Column class
FormatPreferences class
Formula class
Index class
Script class

>>Deleted methods
CanHaveFootnotes method
ChangeAllEditsToEditor method
EmbedFormula method
PrepareToDestroy method
UndoRedo method

>>Deleted properties
ColumnGap property Deleted from Column class
CommentColor property



CreateFromBitmap method Deleted from Graphic class
CreateFromMetafile method Deleted from Graphic class
CreateNew method Deleted from Graphic class
DataFormat property Deleted from Graphic class
DataObjectGetDataHere method Deleted from Graphic class
DirectiveColor property
DoneWithRightMouseMenu method Deleted from Graphic class
EncryptPassword property
EncryptPassword2 property
ErrorColor property
ExcludeRectBottom property
ExcludeRectLeft property
ExcludeRectRight property
ExcludeRectTop property
ExternallyControlledUndo property Deleted from Graphic class
FastFormatType property
FirstSpellString property
FixMargins property
FontName property Deleted from Script class
FontSize property
FooterStyleName property
GetAfidHelpFileName property
GetAfidHelpInfo property Deleted from Graphic class
GetRightMouseMenu method Deleted from Graphic class
GetUndoWhatDesc Deleted from Graphic class
HeaderStyleName property
IconShowingBeforeCleanScreen property
IdentifierColor property
ImportPicture method Deleted from Graphic class
IsChartLink property Deleted from Graphic class
IsDraw property Deleted from Graphic class
IsEquation property Deleted from Graphic class
IsExternalFile property Deleted from Graphic class
IsFooter property Deleted from BaseContainer class
IsHeader property Deleted from BaseContainer class
IsLotusChart property Deleted from Graphic class
KeywordColor property
LinkedFileName property Deleted from Graphic class
LockForNotesUserName property
MouseButtonForManipulation property
MouseButtonForSelection property
MouseProperty property
NextSpellString property
NumberOfCharacters property
Offset property
OLEAutomation property
OpionDeclare property
PrettyPrinting property
PrintDocDescription property
RightMousePropId property Deleted from Graphic class
RightMousePropText property Deleted from Graphic class
SaveData method Deleted from Graphic class
SaveSnapshot method Deleted from Graphic class
Script property
ServerFormat property Deleted from Graphic class
SnapshotOffset property



SnapshotPath property
SnapshotSize property
SpellString property
TabWidth property
Undo method Deleted from Graphic class
UndoEnable property
UndoLevels property Deleted from Script class
UseEncrypt property
UseExcludeRect property
VersionRemarks property
WaterMarkName propert Deleted from Graphic class
WidthOfColumn property

>Hidden Word Pro LotusScript elements
The following methods and properties were hidden in Word Pro Release 9. Hidden elements still work in 
Word Pro, but do not appear in the Object Browser or LotusScript class reference Help for Word Pro. If 
you use a custom Install and install the Word Pro type library, these elements also do not appear.

Hidden elements are obsolete properties, classes, methods, or events. You should not use them in your 
applications because they will not be supported, and will be removed from the Word Pro object model in 
the future.

Elements that were hidden only in certain classes are noted as such.

>>Hidden methods
Bisect method
DeselectRuler method
FastFormat method
Find method Hidden in WPApplication class
GetDefaultPageSize method
GetOne method
GetPageRange method
GetTocProperties method
HasProperty method
InsertFrame method
IsTemporary method
Next method Hidden in Layout class
NextItem method
PreviousItem method
Query method
QueryDrop method
RemoveProperty method
RestoreWindowFromCleanScreen method
SaveEnvelopeMaster method
SelectRuler method
SetTocProperties method
TheoreticalScaledSize method

>>Hidden properties
AsciiCRLFType property
DdeLinksFromMarker property
DivisionsRequired property
DuplexType property
ExternalFileID property
ExternalFileName property
Format property



Foundry property Hidden in TextDocument class
GetConversationHandle property
IsAsciiCRLF property Hidden in TextDocument class
IsAsciiKeepStyle property Hidden in TextDocument class
IsCentered property
IsContents property
IsDivisionExternal property Hidden in TextDocument class
IsExportedToNotesFX property Hidden in DDELink class
IsExportedToOldNotesFX property Hidden in Bookmark class
IsHoverHelp property
IsLinked property Hidden in Bookmark class
IsOnClipboard property Hidden in Bookmark class
NoteColor property
NumCols property Hidden in PrintSettings class
NumRowsToFit property
PageNumberStyle property
PaneColor property
PrintInBackground property
WasPasted property Hidden in Bookmark class


