
The current user ID and selected vocabulary are displayed here.



Lists the available macros for the user and vocabulary specified at the bottom of the window.    An X preceding a 
macro indicates that there is no pronunciation associated with that macro.    To view or edit a macro, double-click 
the macro.    To train a macro pronunciation, click the macro and select Train from the Pronunciations menu.
Train the Macro Name 



Import a Macro File

You can import the following macro file formats only:
n VoiceType Dictation 1.0 and 1.1 Voice Action files.    (Only the dictation macros can be imported.)
n VoiceType Dictation 2.0 exported macro files.

To import a macro file, on the File menu click Import:
1 Select the type of file you want to display in the Files of type list.
2 Select the drive and directory where the macro file is located.
3 Type the file name or select a file name from the File list.
4 Click Open.

A window appears, listing all the defined macros in the macro file you imported.

Click Contents at the top of this window for other tasks.



This window lists the Name, Vocabulary, Type, and Description of all the defined macros in the imported file.



This column lists the vocabulary where the macro can be used.    All means that the macro can be used with all 
vocabularies.



This column lists either macro or template.    Template indicates that the macro has fields for data input.



This column describes the macro.



After you select one or more macros to import, click this button to insert the macros into the list of dictation 
macros in the Dictation Macro Editor window.
Note:

If the macro has the same name as an existing macro, you are asked to either overwrite the existing macro or 
cancel.



Closes the Import Selection window without importing any macros.



Export a Selected Macro

The selected macros are written to a file.

To export the selected macros, on the File menu click Export:
1 Select the drive and directory where you want to store your macro file.
2 Select the file type you want to display in the Save as type list.
3 Type a file name or select a file from the Save as type list.
4 Click Save.
Note:

If you select an existing file, the file is overwritten.

Click Contents at the top of this window for other tasks.



Type a unique name for this macro.    When you say the macro name during dictation, the action you defined is 
carried out.
Name a Macro or Template 



Type a description for this macro.    The description is displayed in the Dictation Macro Editor window.    This field 
is optional.



Select this option to use the macro for all vocabularies on your computer.



Select this option to use this macro only for the vocabulary that was active when you started the Dictation Macro
Editor.



Type the text of the macro.    This is the text that is inserted into the dictation text when you say the macro 
name.



Inserts a date or time variable into your macro text at the cursor location.    You can select from a list of date 
and time formats.    When the macro expands, the current date or time is inserted.



Inserts a call to an external program.    This function is provided as an interface for programmers.



Inserts an existing macro into your macro text.



Saves the macro and closes the window.



Applies the macro for the current session without saving the macro.    You can select Apply to test your macro 
before saving it.



Closes the window without creating a macro.



Click this button to select settings that control the way the macro expands.



Inserts the selected date or time format at the cursor location in your macro text and closes the window.



Closes the window without inserting a date or time into your macro text.



Select this option to start an executable file when the macro expands.    Type the executable file name in the 
Executable Name entry field and the function name in the Function Name field.    You can optionally specify 
parameters for the DLL call.



Select this option to insert the result of the last DLL call made in the macro.



Select this option to execute a call function when the macro expands.    Type an executable in the Executable 
Name entry field.    You can optionally specify parameters to supply to the function.



Inserts the program link into the dictation macro and closes the window.



Closes the window without inserting any program links.



Inserts the selected macro into the macro text at the cursor location and closes the window.



Closes the window without inserting any macros.



When this box is checked, a space is not inserted between the expanded macro text and the preceding text.



When this box is checked, a space is not inserted between the expanded macro and the following text.



When this box is checked, a space is not inserted when the expanded macro precedes or follows a digit.



Select this option to expand the macro while dictating.    Otherwise, the macro expands when it is 
transferred to the destination window.
Note:

A template cannot have delayed expansion.



Select this option to expand the macro only when it is transferred to the destination window.
Note:

A template cannot have delayed expansion.



Select this option to make no formatting changes to the word following the macro.



Select this option to capitalize the first letter of the word following the macro.



Select this option to format the word following the macro in all uppercase letters.



Select this option to format the word following the macro in all lowercase letters.



Saves the options you selected and closes the window.



Closes the window without saving any changes.



To change the macro name, delete the old name and type a new, unique name.



To change or add a description, type a description in the entry field.    The description you type will be listed in 
the Dictation Macro Editor window.



Select this option to use the macro for all vocabularies on your computer.



Select this option to use this macro only for the vocabulary that was active when you started the Dictation Macro
Editor.



Make any changes to the macro text in this field.    This is the text that is displayed when the macro expands.



Inserts a date or time variable into your macro text at the cursor location.    You can select from a list of date and 
time formats.    When the macro expands, the current date or time is inserted.



Inserts a call to an external program.    This function is provided as an interface for programmers.



Inserts an existing macro into your macro text.



Saves the modified macro and closes the window.



Applies the macro for the current session without saving the macro.    You can select Apply to test your macro 
before saving it.



Closes the window without making any changes to the existing macro.



Click this button to select settings that control the way the macro expands.



Modify an Existing Macro

Select the macro name in the Dictation Macro Editor window.    In the Edit menu click Modify.

After you modify the macro, you can test your new macro.
1 Click Apply to apply the macro for the current session without saving it.
2 Test the macro.
3 When you are satisfied with the macro, click Save.

Click Contents at the top of this window for other tasks.



Type a unique name for the template.    When you say the template name during dictation, the action you 
defined is carried out.



Type a description for this template.    The description is displayed in the Dictation Macro Editor window.



Select this option to use the template for all vocabularies on your computer.



Select this option to use this template only for the vocabulary that was active when you started the Dictation 
Macro Editor.



Type the text of the template.    This is the text that is inserted into the dictation text when you say the template 
name.    Click New to add a field.
Tip

You can right-click to access a pop-up menu.    Select New Field to insert a new field or Paste Field to insert 
a field that was copied to the clipboard.



Adds a new field into the template text at the cursor location.
Note

Ensure that the cursor is not within a field.



Click this button to edit a field.    The cursor must be within the field you want to modify.
Tips
n To select a field and open the Insert Template Field window, double-click the field.
n To edit, delete, or copy a field, right-click on the field to access a pop-up menu.    Select Edit, Delete, or Copy.



Deletes a field.    The cursor must be within the field you want to delete.



Select this option to allow regular text to be entered into the field.



Select this option to allow only single letters to be entered into the field.    You must specify the letters using the 
phonetic alphabet assigned to each letter.



Select this option to allow only single digits to be entered into the field.



Select this option to allow only a word from a predefined list to be entered into the field.    You create the 
predefined list by typing words and adding them to the list.



Type the text you want to display in the status area of the dictation window when the cursor is in the field.    This 
is optional.



Type the default text to display in the field if the user makes no entry.    The default text is displayed between the
square brackets that enclose the template field.    This field is optional.



This field is active only when List is selected as the type of field.    Type a word to add to the list and then say or 
click Add.



Adds a new word to the list after you type the word in the Edit List entry field.



Deletes a word in the list box.    You must first select the word in the list that you want to delete.



Adds the field definition to the template.    Square brackets define the boundaries of the field.    Any default text is
displayed between the square brackets.

If the field is a List field, the Train window is displayed for any words in the list that do not have associated 
pronunciations.



Closes the window without inserting the field.



To change the name of the template, delete the old name and type a new, unique name.



Type a description to identify the template.    This description displays in the Dictation Macro Editor window next 
to the template name.



Select this option to use the template for all vocabularies on your computer.



Select this option to use this template only for the vocabulary that was active when you started the Dictation 
Macro Editor.



Make any changes to the template text in this field.    This is the text that is displayed when the template 
expands.    To add a field, click New.



Modify an Existing Template 

Select the template in the Dictation Macro Editor window.    In the Edit menu click Modify.

After you modify the template, you can test your new template.
1 Click Apply to apply the template for the current session without saving it.
2 Test the template.
3 When you are satisfied with the template, click Save.

Click Contents at the top of this window for other tasks.



Type the text you want to locate.



Check this box to search the macro names for the Search For text.



Check this box to search the descriptions for the Search For text.



Check this box to search the macro text for the Search For text.



Check this box to match the case of the Search For text.



Contains the results of the search.



Modifies a macro or template selected in the search results list.    The Modify Macro window or the Modify 
Template window appears.



Selects all the macros in the search results list.



Deselects all entries in the search results window.



Searches for the text in the Search For field in the locations specified.    The results of the search are listed in the 
search results box.



Closes the window.



Type a name and description for the macro.    Select the option for the vocabulary where you want to use the 
macro.



Select the vocabulary where you want to use the macro.



Click a button to insert a date and time, programming link, or macro into your macro text.



Click this button to get help for the Create Macro window.



Column one lists the available date and time formats you can insert into your macro text.    Column two shows 
how the format appears when it converts to the current date and time.



Click this button to get help for the Insert Date or Time window.



Type an executable file to start when the macro expands.



Type a function name to call when the macro expands.    Required for a DLL call.



This field is optional.    Type parameters for a DLL call or system call.



Click this button to get help for the Insert Program Link window.



Lists the available macros for the current user.    Select a macro to insert into the macro text.



Click this button to get help for the Insert Macro window.



Click this button to get help for the Search window.



Type the name and description of the template.    Select the option for the vocabulary where you want to use the 
template.



Select the option for the vocabulary where you want to use the template.



Click this button to get help for the Create Template window.



Click this button to get help for the Insert Template Field window.



You can type a new name or description for the macro or change the vocabulary where you want to use the 
macro.



You can change the vocabulary where you want to use the macro.



Click this button to get help for the Modify Macro window.



You can type a new name or description for the template or change the vocabulary where you want to use the 
template.



You can change the vocabulary where you want to use the template.



Click this button to get help for the Modify Template window.



Select the field to search on to locate the macros or templates you want to find.



Click this button to get help for the Import window.



Click this button to get help for the Export window.



Make Sure You're the Selected User

Your speech information is saved in a file and is updated each time you dictate and make corrections.    It is 
important to make sure that ViaVoice knows that you are the user and does not update another user's files.    
Check the user setting each time you start a ViaVoice session.

To change, or add a user:
1 Click Start, Programs, IBM ViaVoice, Tools, ViaVoice Options.
2 Click the User tab.
3 If your name is listed, select it.

Or:
If your name is not listed, click Add User; type your last name, then first name; and click OK.

4 Make sure your name is listed as the user and click OK.

Click Contents at the top of this window for other tasks.



Back Up Your Speech Information

Your speech information is saved in a file and is updated each time you dictate and make corrections.    It is 
important to back up your personal speech files on a regular basis.

To back up your speech files:
1 Open ViaVoice Enrollment.
2 Select your name from the User Names list.
3 Click Backup.
4 Type a description for your backup.
5 Select the drive where you want to store your backup.
6 Click Backup.

Click Contents at the top of this window for other tasks.



Create a Macro

1 Click Create Macro on the Edit menu.
2 Type a unique name for the macro.
3 Type a description of the macro.
4 Select the vocabulary where the macro can be used.
5 Optional: Click Options to view or select settings that control how the macro expands.

Insert Macro Options
6 Type the macro text.
7 Optional: Insert a date and time, programming link, or another macro into the dictation macro.

Click Date/Time to insert a variable that automatically expands to the current date and time.
Click Prg. Link to insert a call to an external program.
Click Macro to insert an existing macro.

8 Click Apply to use the macro for the current session without saving it.    The Create Macro window remains 
open.
Or:
Click Save to save the macro and close the window.

Then Train the Macro Name 

Macro Example
Suppose you want to create a macro to put your company name and address at the beginning of your letters.
1 Click Create Macro on the Edit menu.
2 Type inside-address in the Name field.
3 Type Company Address in the Description field.
4 Type the following in the Macro Text field.    Press Enter at the end of each line.

Cash Laundry Service
20 Brian Place
Evans Manor, FL 33422

5 If the information in the Macro Text field is correct, click Save.
Then Train the Macro Name 

Click Contents at the top of this window for other tasks.



Name a Macro or Template

How you name your macro is important.    If a macro name is a common word that is part of the ViaVoice 
dictation vocabulary it will always be recognized as the macro if the macro is defined for the current dictation 
vocabulary.    A good convention to follow is to name your macro as two or more words spoken together as a 
single word, such as “sign-off” for a letter closing.    You can still dictate the words “sign” and “off” as separate 
words, but each time you say sign off as one word, you'll get your personalized closing.
Note:

Hyphenate a macro name that is two words (for example, inside-address).

Train the Macro Name 

Click Contents at the top of this window for other tasks.



Create a Template

1 Click Create Template on the Edit menu.
2 Type a unique name for the template.
3 Type a description for the template.
4 Select the vocabulary where this template can be used.
5 Optional: Click Options to select settings that control how the template expands.

Insert Macro Options 
6 Type the template text.
7 Click New to insert a field into the template text.

Insert Fields into a Template    
8 Optional: Insert a date or time, program link, or a macro into the template.

Click Date/Time to insert a variable that automatically expands to the current date and time.
Click Prg. Link to insert a call to an external program.
Click Macro to insert an existing macro.

9 Click Apply to use the template for the current session without saving it.    The Create Template window 
remains open.
Or:
Click Save to save the template and close the window.

Train the Macro Name 

Template Example
Suppose you work in a medical office that has a database of patient information.    The information needed for 
the database is as follows:

Title (Mr., Mrs., ...)
Patient name 
Social Security number
Age
Symptoms
Action taken

You want to create a template to input data for the database.    The template will have fixed text to define the 
fields.
1 Type patient-info in the Name field.
2 Type Patient Information in the Description field.
3 Type the following in the Macro Text field.    Press Enter at the end of each line.

Title:
Patient:
Social Security no:
Age:
Symptoms:
Action taken:

4 Position the cursor where you want the field to appear.    Then create each field and place it next to the 
appropriate text.
List To select one of the following titles: Mr., Mrs., Ms.
Spell To spell the patient's name.
Digit To dictate only single digits for the Social Security number.
Digit To dictate the patient's age.
Text To dictate the patient's symptoms.
Text To dictate the action taken.

Then Train the Macro Name 

Click Contents at the top of this window for other tasks.





Insert Fields into a Template

1 Make sure the cursor in the template text is positioned where you want the field inserted.    If necessary, click 
Cancel to return to the Create Template window.

2 Select the type of template you want to insert.
3 In the Prompt Text field, type the text you want to display in the status area of the dictation window when the 

cursor is in the field.    This is optional.
4 In the Default Text field, type the default text to display in the field if the user makes no entry.    The default 

text is displayed within the square brackets of the field.    This is optional.
5 If you are creating a List field (note that this field is grayed out for all other types of fields) in the Edit List entry

field, type any word you want to add to the word list and click Add.
6 In the Edit List, select any word you want to delete and click Delete.
7 Click OK to insert the field into the template text.

Or:
Click Cancel to close the window without inserting the field.

Click Contents at the top of this window for other tasks.



Train the Macro Name

When you save a macro, the macro name is checked to see if there is an associated pronunciation.    If no 
pronunciation is found, the Train Word message window appears, with the message that a pronunciation for your 
macro was not found.    You are asked if you want to add a pronunciation now.
n If you click Yes, the Train Word window appears.
n If you click No, a red X appears next to the macro name in the Dictation Macro Editor window.    This indicates 

that the name was not recognized.    To train the macro name, select the macro in the Dictation Macro Editor    
window, select Train from the Pronunciations menu.

To train a macro name:
1 Make sure the correct information appears in the Written Like field.
2 Click the record button .

3 When the record button starts to blink, say the macro name and then click the stop button .
4 Click the playback button  to check the quality of your recording of the macro name.
5 If the recording sounds clear, click Add to save the recording and then select Done to close the Train Word
window.    If the recording does not sound clear, click the record button and say the macro name again.

When you click Add, your macro becomes part of your dictation macro library.    The red X will disappear from 
the list of macros in the Dictation Macro Editor window.

Click Contents at the top of this window for other tasks.



Edit a Macro or Template

1 In the Dictation Macro Editor window, click the macro or template you want to modify.
2 Select Modify from the Edit menu.
3 Make the necessary changes.

After you modify the macro, you can test your new macro or template.
1 Click Apply to apply the macro or template for the current session without saving it.
2 Test the macro or template.
3 When you are satisfied with the macro or template, click Save.
Tip

To select a macro and open the Modify Macro or Modify Template window, double-click the macro or template 
name in the Dictation Macro Editor window.

Click Contents at the top of this window for other tasks.



Insert a Date or Time Variable

You can insert a date or time variable into your macro or template text.    When the macro or template expands, 
the current date or time appears.

1 If this is a new macro or template, click Create Macro or Create Template on the Edit menu.    If this is an 
existing macro or template, select the macro or template in the Dictation Macro Editor window and click 
Modify on the Edit menu, or double-click the macro or template name in the Dictation Macro Editor window.

2 In the Macro Text field, position the cursor where you want the date or time variable inserted.
3 Click Date/Time to display the Insert Date or Time window.
4 Select a date or time format from the list.
5 Click OK to insert the variable into your macro or template text and close the window.

Or:
Click Cancel to close the window without inserting a date or time variable.

Click Contents at the top of this window for other tasks.



Insert a Program Link

You can insert a program link into your macro or template.    Program links are provided for developers who want 
to link to other programs.

1 If this is a new macro or template, click Create Macro or Create Template on the Edit menu.    If this is an 
existing macro or template, select it first and click Modify on the Edit menu, or double-click the macro or 
template name in the Dictation Macro Editor window.

2 In the Macro Text field, position the cursor where you want the program link inserted.
3 Click Prg. Link to display the Insert Program Link window.
4 Select DLL Call to start an executable file when the macro or template expands.    Type an executable file 

name and function name.    You can optionally type parameters.

or

Select DLL String to insert the result of the last DLL call made in the macro.

or

Select System Call to execute the specified call function when the macro or template expands.    Type an 
executable file name.    You can optionally type parameters.

5 Click OK to insert the program link into the macro or template and close the window.
Or:
Click Cancel to close the window without inserting a program link.

Click Contents at the top of this window for other tasks.



Insert a Nested Macro

You can insert an existing macro into the dictation macro or template text.    Template macros cannot be inserted 
in other macros.

1 If this is a new macro or template, select Create Macro or Create Template on the Edit menu.    If this is an 
existing macro or template select it first, and select Modify from the Edit menu, or double-click the macro or 
template name in the Dictation Macro Editor window.

2 In the Macro Text field, position the cursor where you want the nested macro inserted.
3 Click Macro to display the Insert Macro window.
4 Select a macro to insert from the alphabetic list of macro names.
5 Click OK to insert the macro into the text and close the window.

Or:
Click Cancel to close the window without inserting any macros into the macro text.

Note:
Options specified in the child macro are overridden by those in the parent macro.    You can nest a maximum of
six levels of macros in a dictation macro.

Click Contents at the top of this window for other tasks.



Insert Keystrokes

If your application supports ‘Key’ dictation, you can specify keystrokes in your macro to perform a function in 
your destination window when the text is transferred.    The ‘Key’ Dictation Option must be enabled in your 
application for the transfer to work correctly.

n Editing Keys
Enclose keys such as TAB, HOME, and ENTER in square brackets.    For example: [ESC].

n Keystrokes and    combinations

[Backspc] [Tab] [Enter]
[Esc] [End] [Home]
[Left] [Right] [Up]
[Down] [Insert] [Delete]
[Ctrl+A]—[Ctrl+Z] [ALT+A]—[ALT+Z] [Ctrl+0]—[Ctrl+9]
[Alt+0]—[Alt+9] [Ctrl+Shift+End] [Ctrl+Shift+Home]
[Ctrl+Home]

NOTE
The words in the brackets must be spelled as indicated above, but can be in uppercase, lowercase, or mixed 
case.    Remember that the function specified by the key does not take effect until transferred to the destination 
window.

Click Contents at the top of this window for other tasks.



Insert Macro Options

You can control how the macro or template expands when you say the macro name.    To view or select the 
following settings, click Options in the Create Macro or Create Template window.
Spacing
n Join to previous word

Check this box if you do not want a space inserted between the expanded macro text and the preceding text.
n Join to next word

Check this box if you do not want a space inserted between the expanded macro text and the following text.
n Join to digits

Check this box if you do not want a space inserted when the expanded macro text precedes or follows a digit.
Expansion
n Immediate

Select this option to expand the macro while dictating.    Otherwise, the macro expands when it is transferred 
to the destination window.

n Delayed
Select this option to expand the macro only when it is transferred to the destination window.
Note:
A template macro cannot be set for delayed expansion.

Formatting of Next Word
n None

Select this option to make no formatting changes to the word following the macro.
n Capital

Select this option to capitalize the first letter of the word following the macro.
n Uppercase

Select this option to format the word following the macro in all uppercase letters.
n Lowercase

Select this option to format the word following the macro in all lowercase letters.

Click Contents at the top of this window for other tasks.



Import Macros

To import a macro file:
1 Select Import from the File menu in the Dictation Macro Editor window.
2 In the Import Macros window, select the type of file you want to display in the File list.
3 Select the drive and directory where the macro file is located.
4 Type the file name or select a file name from the File list.
5 Click Open.

The Import Selection window appears, listing all the defined macros in the macro file you imported.

To import one or more macros from the macro file:
1 Click on one or more macros (you must hold down Ctrl key to select more than one) that you want to import.
2 Click Import.

The selected macros are inserted into the list of available macros in the Dictation Macro Editor window.
Note:

You cannot have two different macros with the same name.    If you select a macro name that already exists, 
an Import Duplicates window appears.    You can choose to overwrite the macro with the same name or cancel.

Click Contents at the top of this window for other tasks.



Export Macros

1 In the Dictation Macro Editor window, select the macros you want to export (you must hold down the Ctrl key 
to select more than one).

2 In the File menu of the Dictation Macro Editor window select Export.
3 Select the drive and directory where you want to store your exported macro file.
4 Type a new file name or select a file from the File list.
5 Click Save.

The selected macros are saved to the specified file.
Note:

If you select an existing file, the file will be overwritten.

Click Contents at the top of this window for other tasks.



Search for a Macro

1 Click Search on the Edit menu of the Dictation Macro Editor window.
2 In the Search For field, type the word or words you want to locate.
3 Check the boxes for the fields to search on.    You can check more than one.
4 Click Match Case if you want the search to be case sensitive.
5 Click Search to begin the search.    The results are displayed in the search results box.
6 To view or edit a macro, select one or more macros or templates from the search results box.    Click Modify.

Click Contents at the top of this window for other tasks.



Change the Spacing After a Period

1 In the Dictation Macro Editor window, click the period macro.
2 Select Modify from the Edit menu.
3 To determine the number of spaces after a period that are in the macro, press the End key and count the 

number of left arrow key presses that move you back to the period.    To change this number, press the delete 
key to remove spaces and press the space bar to add spaces.

4 Click Options and ensure that the Join to previous word check box is checked.
5 Click OK and then Save.

Click Contents at the top of this window for other tasks.



Make Macros Available for All Vocabularies

1 Select Continuous General Dictation for the Vocabulary in the ViaVoice Options User Tab.
2 Start the Dictation Macro Editor.
3 Double click the macro name for inclusion in all vocabularies.
4 Click All to change the vocabulary from Continuous General Dictation to All.
5 Save the macro.
6 Repeat steps 3 through 5 for each macro.

Click Contents at the top of this window for other tasks.



Make Macros Available for Specific Vocabularies

1 Select the vocabulary you want in the ViaVoice Options User Tab in the Vocabulary field.
2 Start the Dictation Macro Editor.
3 Import the macros from the Continuous General Dictation file by doing the following:

a.    Select Import from the File menu.
b.    As the file name, type
x:\viavoice\users\yourname\startus.dct      where x:\viavoice is the drive and directory where you installed 
ViaVoice and where <yourname> is the user ID.    Note that this file will only be available if you had migrated 
this user before and there were dictation macros available for this user.

4 Click Open and select the macros you want to import and click Import.
5 Double click the macro name for inclusion in the vocabulary.
6 Change the vocabulary from All to the current vocabulary.
7 Save the macro.
8 Repeat steps 5 through 7 for each macro.

Click Contents at the top of this window for other tasks.



Click this button to get help for the Options window.



Cut, Copy, and Paste Information
1 Select the information you want to copy or remove.
2 Click Edit, then click Copy (Ctrl+Insert)to copy or Cut (Shift+Delete) to remove.
3 In the main dictation macro editor window click where you want to place the information.
4 Click Edit, click Paste (Shift+Insert).

NOTE
You cannot paste multiple copies of the same dictation macro in the main dictation macro editor window.    You 
can duplicate macros by clicking Edit and changing the name between steps 2 and 3 in the sequence above.




