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This Help system includes topics that you can call directly from the GWRUN Program. To get 
context-sensitive help, press the Help button in the window of your choice.    



The Index contains a list of all Help topics available for the Advantech GWRUN Program. For 
information on how to use Help,    choose Using Help from the Help menu.



File menu commands

The File menu includes commands that enable you to open, close,    and printer setup.. 

The File menu offers the following commands:

Open Opens an existing strategy.
Close Closes an opened strategy.
FAI Conversion Converts FAI binary files to ASCII files.
HIST 
Conversion

Converts HISTORICAL TRENDING binary files to ASCII files.

Print Setup Selects a printer and printer connection.
Exit Exits GWRUN.



Setup Menu

The Setup menu includes commands that enable you to install, add, or remove an I/O 
device, and also to assign the Strategy to a particular Task. Commands are as follows:

Change-Password
Administration

View menu commands

The View menu includes commands that enable you to zoom to fit the screen, changing the 
view of selected items in the GENIE Strategy. The View Menu also enables the toolbar, 
toolbox, and status bar      to be displayed when in a Strategy Editor Window, show the labels 
under each icon block, or to show the grid when in a Display Window (Show Grid). 
Commands are:

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Event Log Shows or hides the event dialog window.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple strategys in the application window:

New Window Creates a new window that views the same strategy.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 2, ... Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get 
help.

Using Help Provides general instructions on using help.
About Displays the version number of this application.



Open command (File menu)

Use this command to Open an existing strategy. Normally, existing strategies will be stored 
in the GENIE\STRATEGY directory.

Use this command to open an existing strategy in a new window. 

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which GENIE stores the file that you want to open. 

Directories
Select the directory in which GENIE stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active strategy.

You can also close a strategy by using the Close icon on the strategy's window, as shown 
below:



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
strategys you closed.    Choose the number that corresponds with the strategy you want to 
open.



Exit command (File menu)

Use this command to end your GWRUN session.    You can also use the Close command on 
the application Control menu.    GWRUN prompts you to save strategys with unsaved 
changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Change Password
Enter a password for the Lock feature in Runtime.    The password can consist of as little as 
no characters or spaces, for which simply the ESC key will unlock the strategy.    The 
password can, however, contain up to 16 characters or spaces, with no constraints on 
format.



Administration
The administrator may add and delete users with the use of this dialog box for the Lock 
feature in Runtime.    Enter a Supervisor Password, .each users ID and password.    The user 
ID and password can consist of as little as no characters or spaces, for which simply the ESC 
key will unlock the strategy.    The user ID and password can, however, contain up to 16 
characters or spaces, with no constraints on format



Run Menu

The Run menu is actually a command that allows you to access GWRUN Runtime    directly 
from the Strategy Editor menu bar. Use this command to test a previously stored strategy by
pressing RUN with your mouse. 



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in GWRUN, such as File Open.    A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in GWRUN,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open an existing strategy.    GWRUN displays the Open dialog box, in which you can 
locate and open the desired file.

Print the active strategy.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the GWRUN window.    To display or hide the 
status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open strategy window at the bottom of the main window, then some 
or all of the icons may not be visible because they will be underneath this strategy window.



1, 2, ... command (Window menu)

GWRUN displays a list of currently open strategy windows at the bottom of the Window 
menu.    A check mark appears in front of the strategy name of the active window.    Choose a
strategy from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using GWRUN and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of 
GWRUN.



Context Help command 

Use the Context Help command to obtain help on some portion of GWRUN.    When you 
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the GWRUN window, such as another Toolbar 
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and strategy.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Strategy Control-menu button
Maximize button

Minimize button

Name of the application

Name of the strategy

Restore button



Scroll bars

Displayed at the right and bottom edges of the strategy window.    The scroll boxes inside the
scroll bars indicate your vertical and horizontal location in the strategy.    You can use the 
mouse to scroll to other parts of the strategy.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the GWRUN window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a strategy window.



Next Window command (strategy Control menu)

Use this command to switch to the next open strategy window.    GWRUN determines which 
window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (strategy Control menu)

Use this command to switch to the previous open strategy window.    GWRUN determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single strategy, the Close command on the 
strategy Control menu closes only one window at a time.    You can close all windows at once 
with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a strategy window

ALT+F4 closes the window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



Find command (Edit menu)

<< Write application-specific help here. >>



Find dialog box

<< Write application-specific help here. >>



Replace command (Edit menu)

<< Write application-specific help here. >>



Replace dialog box

<< Write application-specific help here. >>



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item 
changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>



GENIE Runtime Help
The GENIE Runtime system allows simultaneous execution of control, graphics, alarming, 
trending, datalogging, file transfer, and multiple I/O drivers. Its purpose is to execute 
strategies created in the GENIE Strategy Editor and Display Editor. 

Runtime Operation

The GENIE Runtime system behaves in different ways, depending on the choices made by 
the designer who created the strategy and corresponding displays. Its overall behavior is 
determined by the way in which Strategy Editor blocks have been arranged and connected, 
in conjunction with the Scan Period(s) set in the SETUP/TASKS menu. (Refer to the Setup 
Menu section in Chapter 2.2.3:Strategy Editor Menu Bar)    If the Display has been designed 
with output capability -- buttons, numeric displays that can be edited, etc., the associated 
parameters can be changed during GENIE Runtime. Most commands and data are entered 
using the keyboard or via the mouse, which are both functional during GENIE Runtime.

Starting Runtime

Starting the GENIE Runtime session is performed from WINDOWS, DOS, or from the GENIE 
Strategy Editor menu bar.

1)    If Running from WINDOWS, enter the Advantech GENIE group, and double-click on the 
GENIE Runtime icon. Open the desired strategy file with the suffix ".gni", and press START on
the GENIE Runtime Menu Bar. 

2)    If running from the DOS prompt, type:

win gwrun <strategy>

where strategy is the name of the strategy.gni file that was designed with the Strategy 
Editor. Make sure that the GENIE\STRATEGY directory is in your path (autoexec.bat).

3) You can also create a new icon with GWRUN <strategy> as the command line. This will 
cause the strategy to be loaded and started upon running.

4)    If running from the Strategy Editor menu bar, after you have saved the currently 
displayed strategy, press "RUN" with your mouse.

Runtime Menu Bar

The Runtime Menu Bar consists of a number of menus that enable you to manipulate files, 
start or stop running your strategy,    or manipulate windows. There is also on-line help 
available through a help menu.

Runtime Menus
File Menu
Start Menu item



Stop Menu item
Resume Menu item
Pause Menu item
Lock Menu item
Window Menu
Help Menu

Following is a description of the Runtime menus:

File Menu

The File menu includes commands that enable you to open and close    existing GENIE 
Strategy Files. Commands include:

Open
Use this command to Open an existing strategy. Normally, existing strategies will be stored 
in the GENIE directory.

Close
Use this command to Close your strategy. Make sure that you save it first.

FAI Conversion
Use this command to convert from BINARY file type to ASCII file type when performing HI-
Speed (FAI) Logging. Converts the file (FAIXX.DAT, where XX = HI-Speed Logging Graph 
number) format from Binary to ASCII after acquisition is complete when using the HI-Speed 
Logging Display Item in the GENIE Runtime System. This allows for viewing of the file 
contents with a standard ASCII Editor outside of the GENIE program.    This menu item 
generally must be used when the strategy is not running,    or when high speed data is not 
logging to disk.    The Status Bar at the screen bottom displays information as to when an 
incorrect file conversion attempt has been made during Runtime.

HIST Conversion
Use this command to Convert the Historical Trending Display Item Log files from Binary to 
ASCII format. These files have a naming convention as follows:

YYMMDD##.HST

where:

YY = Year file was created
MM = Month file was created
DD = Day file was created
## = Historical Trending Graph Number

after acquisition is complete in the GENIE Runtime System. When converting the format to 
ASCII,    you can then examine the contents using any standard ASCII editor.

Exit
Use this command to Exit the GENIE Runtime System.

Start Menu Item



A command that enables you to start your strategy as soon as you press "start".

Stop Menu Item

A command that enables you to stop your strategy as soon as you press "stop".

Resume Menu Item

A command that enables you to Resume your strategy after previously Pausing.

Pause Menu Item

A command that enables you to pause your strategy temporarily, to be continued at the 
same spot at a later time.

Lock Menu Item

A command that enables you to "lock" your strategy from inputs from the keyboard or 
mouse.    Refer to section 2.2.3, "Strategy Editor Menu Bar" under the section 
Setup/Runtime Preference for information on setting a password.    

To "unlock" a "locked" strategy, press the ESC key, followed by typing the password that was
chosen in Setup/Runtime Preference.    If no password is selected in Setup/Runtime 
Preference, then simply pressing the ESC key will "unlock" the strategy.

Window Menu

The Window menu includes commands that enable you to arrange multiple windows within 
GENIE. You can also select between a Runtime Window, Strategy Editor Window or a Display 
Window for a chosen file here. 

Runtime Toolbar

To display or hide the Toolbar at the top of the Strategy Editor    screen    , highlight the 
View/Toolbar command with your mouse. The Toolbar and its associated buttons allow you to
perform certain menu operations more quickly than actually going through the menus.    
Button commands are as follows:

Open an Existing Strategy

This button opens an existing strategy file.



Close the Current Strategy

This button closes currently displayed strategy.

Printer Setup

This button displays the print setup dialog box.

Start Runtime

This button starts the strategy running.

Stop Runtime

This button stops the currently running strategy.

Resume Runtime

By pressing this button, runtime may be resumed after first pausing.

Pause Runtime

Pressing this button pauses runtime until the Resume button is pressed.

Select Display

A series of buttons that allow you to toggle between defined displays in your strategy.    Up 
to eight displays may be accessed through the buttons.    The displays are defined 
numerically by their label in the Strategy Editor.

Context Sensitive Help



This button changes the mouse cursor to a special help cursor that allows you to select an 
object and display help for clicked buttons, menus, and windows. 

Runtime Status Bar

To display or hide the Status Bar at the bottom of the Runtime screen, highlight the 
View/Status Bar command with your mouse. The Status Bar allows you to get quick, concise 
help on menu commands.    As you highlight a menu item with your mouse, you can view 
information on the item in the status bar at the bottom of the runtime window. Also during 
runtime,    status information is displayed such as any errors that have occured, or whether 
the strategy is running normally.    Errors generally include hardware driver errors or errors 
due to timing problems.    The error codes are listed in the Appendix under Runtime Error 
Code Listing.

Exiting GENIE Runtime

When you have finished working in Runtime exiting back to WINDOWS/DOS is performed by 
pressing the STOP menu item on the Runtime menu bar. After you stop the runtime system, 
you can either re-start by pressing start, or you can exit the GENIE Runtime system by 
entering the File menu and pressing Exit.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that GENIE is sending output to the printer.  
The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>



KEvent Log Menu

Use this menu to enable the Event Log Viewer.    This allows you to view events such as :

1) Login/out times
2) Strategy Start and Stop times
3) Alarms and Alarm Acknowledgement



Runtime

The GENIE Runtime system allows simultaneous execution of control, graphics, alarming, 
trending, datalogging, file transfer, and multiple I/O drivers. Its purpose is to execute 
strategies created in the GENIE Strategy Editor and Display Editor. 

Runtime Operation

The GENIE Runtime system behaves in different ways, depending on the choices made by 
the designer who created the strategy and corresponding displays. Its overall behavior is 
determined by the way in which Strategy Editor blocks have been arranged and connected, 
in conjunction with the Scan Period(s) set in the SETUP/TASKS menu. (Refer to the Setup 
Menu section in Chapter 2.2.3:Strategy Editor Menu Bar)    If the Display has been designed 
with output capability -- buttons, numeric displays that can be edited, etc., the associated 
parameters can be changed during GENIE Runtime. Most commands and data are entered 
using the keyboard or via the mouse, which are both functional during GENIE Runtime.

Starting Runtime

Starting the GENIE Runtime session is performed from WINDOWS, DOS, or from the GENIE 
Strategy Editor menu bar.

1)    If Running from WINDOWS, enter the Advantech GENIE group, and double-click on the 
GENIE Runtime icon. Open the desired strategy file with the suffix ".gni", and press START on
the GENIE Runtime Menu Bar. 

2)    If running from the DOS prompt, type:

win gwrun <strategy>

where strategy is the name of the strategy.gni file that was designed with the Strategy 
Editor. Make sure that the GENIE\STRATEGY directory is in your path (autoexec.bat).

3) You can also create a new icon with GWRUN <strategy> as the command line. This will 
cause the strategy to be loaded and started upon running.

4)    If running from the Strategy Editor menu bar, after you have saved the currently 
displayed strategy, press "RUN" with your mouse.

Runtime Menu Bar

The Runtime Menu Bar consists of a number of menus that enable you to manipulate files, 
start or stop running your strategy,    or manipulate windows. There is also on-line help 
available through a help menu.

Runtime Menus
File Menu
Start Menu item



Stop Menu item
Resume Menu item
Pause Menu item
Lock Menu item
Window Menu
Help Menu

Following is a description of the Runtime menus:

File Menu

The File menu includes commands that enable you to open and close    existing GENIE 
Strategy Files. Commands include:

Open
Use this command to Open an existing strategy. Normally, existing strategies will be stored 
in the GENIE directory.

Close
Use this command to Close your strategy. Make sure that you save it first.

FAI Conversion
Use this command to convert from BINARY file type to ASCII file type when performing HI-
Speed (FAI) Logging. Converts the file (FAIXX.DAT, where XX = HI-Speed Logging Graph 
number) format from Binary to ASCII after acquisition is complete when using the HI-Speed 
Logging Display Item in the GENIE Runtime System. This allows for viewing of the file 
contents with a standard ASCII Editor outside of the GENIE program.    This menu item 
generally must be used when the strategy is not running,    or when high speed data is not 
logging to disk.    The Status Bar at the screen bottom displays information as to when an 
incorrect file conversion attempt has been made during Runtime.

HIST Conversion
Use this command to Convert the Historical Trending Display Item Log files from Binary to 
ASCII format. These files have a naming convention as follows:

YYMMDD##.HST

where:

YY = Year file was created
MM = Month file was created
DD = Day file was created
## = Historical Trending Graph Number

after acquisition is complete in the GENIE Runtime System. When converting the format to 
ASCII,    you can then examine the contents using any standard ASCII editor.

SCRIPT
Use this command to Run a Script.    The    Scripting Language feature is a critical part of 
GENIE 2.0+ that sets it apart from other icon-based data acquisition and control programs.    
The Scripting Language will allow you to step GENIE through separate strategies and various
stages of your process, experiment, or test without operator intervention.



Ramp and soak cycles can be implemented for batch control applications.    Disk logging can 
be turned on and off automatically at certain points in the automation sequence.    Valves 
can be opened and closed.    If an emergency condition takes place,    the script can be made 
to branch to a specific shutdown strategy.

Using any standard ASCII editor, such as the GenPad Script Editor (icon interface provided in 
GENIE program group), you can write a script that acts on your GENIE Strategies and    User 
Program block variables within the Strategies, with one or many lines of program 
statements. The scripting language uses C-like syntax as does the User Program block and, 
in fact, shares variables with the User Program block(s) in your Strategies.

Script
A Script consists of one or more statements that follow the correct syntax. The script runs 
during GENIE Runtime like a batch file -- that is, it performs each line in sequential order. 
Function calls are made one at a time,    and each function must be completed before the 
next line is executed in the script. Check the GENIE Reference Manual, EXTENDED Features 
for detailed information on Scripting Language syntax.

Exit
Use this command to Exit the GENIE Runtime System.

Start Menu Item

A command that enables you to start your strategy as soon as you press "start".

Stop Menu Item

A command that enables you to stop your strategy as soon as you press "stop".

Resume Menu Item

A command that enables you to Resume your strategy after previously Pausing.

Pause Menu Item

A command that enables you to pause your strategy temporarily, to be continued at the 
same spot at a later time.

Lock Menu Item

A command that enables you to "lock" your strategy from inputs from the keyboard or 
mouse.    Refer to section 2.2.3, "Strategy Editor Menu Bar" under the section 
Setup/Runtime Preference for information on setting a password.    

To "unlock" a "locked" strategy, press the ESC key, followed by typing the password that was
chosen in Setup/Runtime Preference.    If no password is selected in Setup/Runtime 
Preference, then simply pressing the ESC key will "unlock" the strategy.



Window Menu

The Window menu includes commands that enable you to arrange multiple windows within 
GENIE. You can also select between a Runtime Window, Strategy Editor Window or a Display 
Window for a chosen file here. 

Runtime Toolbar

To display or hide the Toolbar at the top of the Strategy Editor    screen    , highlight the 
View/Toolbar command with your mouse. The Toolbar and its associated buttons allow you to
perform certain menu operations more quickly than actually going through the menus.    
Button commands are as follows:

Open an Existing Strategy

This button opens an existing strategy file.

Close the Current Strategy

This button closes currently displayed strategy.

Printer Setup

This button displays the print setup dialog box.

Start Runtime

This button starts the strategy running.

Stop Runtime

This button stops the currently running strategy.

Resume Runtime



By pressing this button, runtime may be resumed after first pausing.

Pause Runtime

Pressing this button pauses runtime until the Resume button is pressed.

Select Display

A series of buttons that allow you to toggle between defined displays in your strategy.    Up 
to eight displays may be accessed through the buttons.    The displays are defined 
numerically by their label in the Strategy Editor.

Context Sensitive Help

This button changes the mouse cursor to a special help cursor that allows you to select an 
object and display help for clicked buttons, menus, and windows. 

Runtime Status Bar

To display or hide the Status Bar at the bottom of the Runtime screen, highlight the 
View/Status Bar command with your mouse. The Status Bar allows you to get quick, concise 
help on menu commands.    As you highlight a menu item with your mouse, you can view 
information on the item in the status bar at the bottom of the runtime window. Also during 
runtime,    status information is displayed such as any errors that have occured, or whether 
the strategy is running normally.    Errors generally include hardware driver errors or errors 
due to timing problems.    The error codes are listed in the Appendix under Runtime Error 
Code Listing.

Exiting GENIE Runtime

When you have finished working in Runtime exiting back to WINDOWS/DOS is performed by 
pressing the STOP menu item on the Runtime menu bar. After you stop the runtime system, 
you can either re-start by pressing start, or you can exit the GENIE Runtime system by 
entering the File menu and pressing Exit.



FAI Conversion

Use this command to convert from BINARY file type to ASCII file type when performing HI-
Speed (FAI) Logging. Converts the file (FAIXX.DAT, where XX = HI-Speed Logging Graph 
number) format from Binary to ASCII after acquisition is complete when using the HI-Speed 
Logging Display Item in the GENIE Runtime System. This allows for viewing of the file 
contents with a standard ASCII Editor outside of the GENIE program.    This menu item 
generally must be used when the strategy is not running,    or when high speed data is not 
logging to disk.    The Status Bar at the screen bottom displays information as to when an 
incorrect file conversion attempt has been made during Runtime.



HIST Conversion

Use this command to Convert the Historical Trending Display Item Log files from Binary to 
ASCII format. These files have a naming convention as follows:

YYMMDD##.HST

where:

YY = Year file was created
MM = Month file was created
DD = Day file was created
## = Historical Trending Graph Number

after acquisition is complete in the GENIE Runtime System. When converting the format to 
ASCII,    you can then examine the contents using any standard ASCII editor.



SCRIPT 

Use this command to Run a Script.    The    Scripting Language feature is a critical part of 
GENIE 2.0+ that sets it apart from other icon-based data acquisition and control programs.    
The Scripting Language will allow you to step GENIE through separate strategies and various
stages of your process, experiment, or test without operator intervention.

Ramp and soak cycles can be implemented for batch control applications.    Disk logging can 
be turned on and off automatically at certain points in the automation sequence.    Valves 
can be opened and closed.    If an emergency condition takes place,    the script can be made 
to branch to a specific shutdown strategy.

Using any standard ASCII editor, such as the GenPad Script Editor (icon interface provided in 
GENIE program group), you can write a script that acts on your GENIE Strategies and    User 
Program block variables within the Strategies, with one or many lines of program 
statements. The scripting language uses C-like syntax as does the User Program block and, 
in fact, shares variables with the User Program block(s) in your Strategies.

Script
A Script consists of one or more statements that follow the correct syntax. The script runs 
during GENIE Runtime like a batch file -- that is, it performs each line in sequential order. 
Function calls are made one at a time,    and each function must be completed before the 
next line is executed in the script. Check the GENIE Reference Manual, EXTENDED Features 
for detailed information on Scripting Language syntax.



Start Menu item

A command that enables you to start your strategy as soon as you press "start".



Stop Menu item

A command that enables you to stop your strategy as soon as you press "stop".



Resume Menu

A command that enables you to Resume your strategy after previously Pausing.



Pause Menu item

A command that enables you to pause your strategy temporarily, to be continued at the same spot at a 
later time.



Lock Menu Item

A command that enables you to "lock" your strategy from inputs from the keyboard or mouse.    Refer to 
section 2.2.3, "Strategy Editor Menu Bar" under the section Setup/Runtime Preference for information 
on setting a password.    

To "unlock" a "locked" strategy, press the ESC key, followed by typing the password that was chosen in 
Setup/Runtime Preference.    If no password is selected in Setup/Runtime Preference, then simply 
pressing the ESC key will "unlock" the strategy.

Exiting the Runtime Application

When you have finished your work in the Strategy Editor and desire to return to Windows or DOS, clicking
on the Exit command in the File submenu will accomplish this task. You will be prompted as to whether 
you would like to save any changes that were made in the current session. Upon giving the appropriate 
response, you will exit the Strategy Editor -- thus exiting the GWRUN program.






