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Cisco TCP/IP Suite Monitor Application
The Cisco TCP/IP Suite Monitor application displays information about the status of Cisco 
TCP/IP Suite features.

Click graphic fields for more information.



File Menu
The File menu lets you store Monitor statistics in a file, print the statistics, and exit Monitor.



Display Menu
The Display menu lets you specify the statistics to display, and update (refresh) the display.



Options Menu
The Options menu enables or disables the toolbar, bubble help, and the status bar, and lets 
you specify program attributes.



Help Menu
The Help menu lets you display information on using Help and the Monitor version number.



ARP Table Button
The ARP Table button, or ARP Table from the 
Display menu, displays the contents of the ARP 
(Address Resolution Protocol) cache.
By viewing the contents of the ARP cache and 
comparing information displayed with the known 
IP and hardware address pairs, you can be sure 
that one system on the network is not using 
another system's IP address.    Checking the ARP 
cache is useful when the workstation frequently 
loses connection when communicating with 
another host on the network.

ARP Table Statistics
The ARP Table lists the contents of the ARP (Address Resolution Protocol) cache. The ARP 
Table contains these columns:
Host Network Address

Identifies the IP address of the local hosts with which your workstation is communicating. 
For example, 192.168.240.56.

Hardware Address
Identifies the hardware address of each host.    For example, AA:00:04:00:01:60.

Arp Flags
Identifies whether an entry is temporary or permanent in the ARP cache.



Buffer Statistics Button
The Buffer Statistics button, or Buffer Statistics 
from the Display menu, shows the amount of RAM 
(Random Access Memory) space available for 
temporary storage of data.

Buffer Statistics
The Buffer Statistics indicate the amount of RAM (Random Access Memory) space available 
for temporary storage of IP data. The Buffer Statistics table identifies the number of buffers 
in use, the percentage of buffers in use, and the number of denied memory requests.    For 
example:

Cisco TCP/IP Suite Buffer Statistics:
35 out of 96 buffers in use.

3 buffers allocated to Data.
8 buffers allocated to Socket Structures.
12 buffers allocated to Protocol Control Blocks.
3 buffers allocated to Routing Table Entries.
4 buffers allocated to Kernel Fork-Processes.
2 buffers allocated to Interface Addresses.
2 buffers allocated to Multicast Addresses.
1 buffers allocated to Link-Level Multicast Addresses.

1 out of 16 page clusters in use.
44 Kbytes allocated to Cisco TCP/IP Suite buffers (9% in use).
0 requests for memory denied.



Connection Table Button
The Connection Table button, or Connection Table 
from the Display menu, lists the workstation's 
current TCP/IP connections.

Connection Table Statistics
The Connection Table lists the workstation's current TCP/IP connections. The Connection 
Table contains these columns:
Proto

Identifies the networking protocol being used for each connection.
Rcv-Q

Identifies the number of bytes waiting to be processed.
Snd-Q

Identifies the number of bytes waiting to be sent to the remote host.
Local Addr (Port)

Identifies the IP address and port of the workstation being used for each connection.
Foreign Addr (Port)

Identifies the address and port being used on the remote host.
State

Identifies the status of the connection.



Interface Table Button
The Interface Table button, or Interface Table from 
the Display menu, displays information about all 
interfaces on the workstation.    When the statistics 
display, double-click an entry to view the Interface 
display window and receive more information about 
the entry.

Interface Table Statistics
The Interface Table displays information about all interfaces on the PC. The Interface Table 
contains these columns:
Name

The name of the interface.
MTU

The MTU (Maximum Transmission Unit) for the interface.    MTU path discovery 
determines the maximum TCP packet that can be sent through the network.    By 
determining the largest, most efficient packet size possible with the hardware at each 
hop, performance is increased.    This feature is described in RFC-1191.

Network
The network number for the interface or the interface status. If the network is shown as 
****DOWN****, ensure that the interface is enabled with the Cisco TCP/IP Suite 
Configuration Utility.    If the device is an Ethernet device, a SLIP interface cannot be 
running simultaneously.

Address
The IP address of the interface.

IPkts
The number of incoming packets.

Ierrs
The number of incoming errors detected.

Opkts
The number of outgoing packets.

Oerrs
The number of outgoing errors.

Collis
The number of detected collisions.

Double-click an entry to view the Interface display window and receive more information 
about the entry.



Interface Display Window
The Interface display window lists additional information about an interface entry, and 
contains these fields:
Flags

Any flags in effect for the interface.
IP Address

The IP address of the interface.
IP Sub-Net Mask

The subnet mask for the interface.
IP Broadcast Address

The broadcast address for the interface.



Protocol Statistics Button
The Protocol Statistics button, or Protocol Statistics 
from the Display menu, presents detailed 
networking statistics for all current connections.

Protocol Statistics
The Protocol Statistics list the number of packets sent and received for each TCP/IP protocol. 
For example:

Cisco TCP/IP Suite Protocol Statistics:
10 TCP connections initiated.
10 TCP connections established.
10 TCP connections closed.
77 TCP segments timed for RTT.
67 TCP segments updated for RTT.
7 TCP delayed ACKs sent.
105 TCP packets sent.
58 TCP data packets sent.
3887 TCP data bytes sent.
27 TCP ACK-only packets sent.
20 TCP control packets sent.
118 TCP packets received.
70 TCP packets received in sequence.
5982 TCP bytes received in sequence.
9 TCP packets were out of order.
67 TCP packets had ACKs.
10 TCP packets had duplicate ACKs.
3897 TCP bytes ACKed.
1297 IP packets received.



Routing Table Button
The Routing Table button, or Routing Table from the
Display menu, identifies the hosts or networks with
which the PC is communicating and the routes 
being used.

Routing Table Statistics
The Routing Table identifies the hosts or networks with which the PC is communicating and 
the routes being used. The Routing Table contains these columns:
Destination

The IP addresses of hosts or networks with which the workstation is communicating.
Gateway

The IP address of the default route.
Flags

Any flags in effect for the route.
Refcnt

The number of applications currently using each route (the reference count).
Use

The total number of times each route has been used.
Interface

The name of the interface using the route.
MTU

The maximum transmission unit for each route.    MTU path discovery determines the 
maximum TCP packet that can be sent through the network.    By determining the largest,
most efficient packet size possible with the hardware at each hop, performance is 
increased. This feature is described in RFC-1191.



Refresh Button
The Refresh button, or Refresh from the Display 
menu, updates the statistics appearing in the 
table.

Save Button
The Save button, or Save As from the File menu, 
saves statistics in a file using the Save As dialog 
box.

Print Button
The Print button, or Print from the File menu, 
prints statistics using the Print dialog box.

Exit Button
The Exit button, or Exit from the File menu, closes 
the Monitor application.

File Menu
The File menu contains these commands:
Save As

Saves the displayed statistics to a file.    The shortcut button is:

Print
Prints the displayed statistics.    The shortcut button is:

Print Setup
Lets you change printer options.

Exit
Closes the Monitor application.    The shortcut button is:



Save As Dialog Box
The Save As dialog box lets you save statistics to a file:
File Name

The name of the file in which to save the statistics.
Save File As Type

The file format for the file.
Directories

The directory for the file.
Drives

The drive for storing the file.
Network

Connects to another network location so you can assign it a new drive letter.



Print Dialog Box
The Print dialog box lets you print the displayed statistics:
Printer

Shows the active printer and printer connection.    Click the Setup button to change the 
printer and printer connection.

Print Range group
Lets you specify the pages you want to print:    All pages; just the data you selected in 
the statistics window; or a specific page range.

Print Quality
Determines how clear the printout is, based on the capabilities of your printer.

Copies
The number of copies you want to print.

Collate Copies
Whether you want each copy printed in page number order (checked), or whether you 
want all copies of each page printed together, so that, for example, all page ones are 
printed first before printing page two (unchecked).

Setup button
Lets you select a printer and set other printer options using the Print Setup dialog box.



Print Setup Dialog Box
The Print Setup dialog box lets you select a printer, page orientation and dimensions, paper 
source and other options:
Printer group

Lets you select either the default printer, or another printer that you have installed.
Orientation group

Determines whether the printout is in portrait or landscape orientation.
Paper group

Determines the size of the paper and the paper tray that is used.
Options button

Additional options that you can set for the selected printer.
Network button

Lets you connect to a printer on your network.



Display Menu
The Display menu contains these commands:
ARP Table

Displays the contents of the ARP (Address Resolution Protocol) cache.    By viewing the 
contents of the ARP cache and comparing information displayed with the known IP and 
hardware address pairs, you can be sure that one system on the network is not using 
another system's hardware or IP address.    Checking the ARP cache is useful when the 
workstation frequently loses information when communicating with another host on the 
network.    The shortcut button is:

Buffer Statistics
Indicates the amount of RAM (Random Access Memory) space available for temporary 
storage of data.    The Buffer Statistics table identifies the number of buffers in use, the 
percentage of buffers in use, and the number of denied memory requests.    The shortcut 
button is:

Connection Table
Lists the workstation's current TCP/IP connections. The Connection Table lists the network
protocol, number of bytes being transferred, IP address and port information, and 
connection status.    The shortcut button is:

Interface Table
Displays information about all interfaces on the workstation. The Interface Table lists 
interface name, MTU, network, address, packet, and error information. When the 
statistics display, double-click an entry to view the Interface display window and receive 
more information about the entry.    The shortcut button is:

Protocol Statistics
Presents detailed networking statistics for all current connections.    The shortcut button 
is:

Routing Table
Identifies the hosts or networks with which the workstation is communicating and the 
routes being used. The Routing Table lists route destination, gateway, flags, reference 
count, use, interface, and MTU (Maximum Transmission Unit) information.    The shortcut 
button is:

Refresh



Refreshes the displayed statistics.    The shortcut button is:



Options Menu
The Options menu contains these commands:
Program

Sets Monitor program options using the Program dialog box.
Toolbar

Displays or hides the toolbar, which is the bar of shortcut buttons beneath the menu.
Bubble Help

Enables or disables bubble help, which is the quick popup help you get when moving the 
cursor over the toolbar buttons.

Status Bar
Displays or hides the status bar at the bottom of the main window.



Program Dialog Box
The Program dialog box lets you specify a refresh rate and how hosts are identified in the 
statistics.    It contains these fields:
Refresh Interval (Sec)

The number of seconds you would like to elapse before the Monitor application updates 
the information in the table.

Save Settings on Exit
Determines whether the values you set in this dialog box are saved and used the next 
time you start Monitor.

Symbolic Display group
Determine how hosts are identified in the statistics.
None

Hosts are identified by IP address.
Host Table

Hosts are identified by the name assigned to the IP address in your host table.
DNS

Hosts are identified by the name assigned to the IP address in the DNS server.    
Because the DNS servers must be queried for these names, Monitor might run more 
slowly.



Host Table Radio Button
The Host Table radio button indicates that the Monitor application should identify all hosts by
their host names as defined in the host table.



DNS Radio Button
The DNS radio button indicates that the Monitor application should identify all hosts by their 
host names as defined in DNS (Domain Name System).    Enabling this radio button can 
generate many queries to DNS domain servers and the Monitor application can, therefore, 
run slower.



Help Menu
The Help menu contains these commands:
Contents

Displays the contents page of this help file.
Search for Help on

Searches this help files index.
How to Use Help

Displays help information for using the Windows help system.
About Monitor

Displays version information for the application.



Toolbar
The Monitor toolbar buttons let you display the ARP table, list buffer statistics, display the 
current connections, list interfaces and their configurations, list protocol statistics, or display 
the routing table. Additional buttons let you refresh the screen, save output to a file, print 
output, or exit the Monitor application.

Click graphic fields for more information.



Statistics Table
Each Monitor activity displays its output differently in the statistics table:
· The ARP Table displays the contents of the ARP cache.
· The Buffer Statistics identify the number of RAM (Random Access Memory) buffers in use,

the percentage of buffers in use, and the number of denied memory requests.
· The Connection Table lists the PC's current TCP/IP connections.
· The Interface Table displays information about all interfaces on the PC.
· The Protocol Statistics list detailed networking statistics for all current connections.
· The Routing Table identifies the hosts or networks with which the PC is communicating 

and the routes being used.
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Using Monitor
The Monitor application provides detailed information about your PC's TCP/IP 
communications.
To use Monitor:

Click a Toolbar button from those that follow or select the associated option from the Display
menu:

Key Purpose
Display the ARP Table, which lists the contents 
of the ARP (Address Resolution Protocol) cache.
Display Buffer Statistics, which list the amount 
of RAM (Random Access Memory) available for 
temporary IP data storage.
Display the Connection Table, which lists the 
workstation's current connections.
Display the Interface Table, which lists 
information about all interfaces on the 
workstation.
Display the Protocol Statistics, which list the 
number of packets sent and received for each 
TCP/IP protocol.
Display the Routing Table, which lists the hosts 
or networks with which the workstation is 
communicating.



Setting the Refresh Rate
To change the frequency at which statistics are updated (the refresh rate): 

1. Select Program from the Options menu.
2. Enter a new value in seconds in the Refresh Interval edit box.
3. To save the refresh interval for the next time you use Monitor application, check the Save

Settings On Exit check box.
4. Click OK.



Enabling or Disabling Host Names
To display host names instead of IP addresses, or IP addresses instead of host 
names:

1. Select Program from the Options menu.
2. To display host names as defined in your host table, click Host Table.    To display host 

names as defined in the DNS server, click DNS    To display only IP addresses, click None.
3. To save your changes for the next time you use the Monitor application, check the Save 

Settings On Exit check box.
4. Click OK.



Saving Monitor Statistics in a File
To save statistics in a file:

1. Click the Save button or choose Save As from the File menu.
2. Enter the required information.
3. Click OK.



Printing Monitor Statistics
To print Monitor statistics: 

1. Click the Print button or choose Print from the File menu.
2. Enter the required information.
3. Click OK.
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Monitor Concepts
Monitor provides detailed information about your PC's TCP/IP communications.    When you 
click a toolbar button or choose a menu option, Monitor gathers the requested information 
and displays it in a table for your review.    Monitor lets you establish how frequently the 
information is updated and lets you determine if hosts should be identified by host name or 
IP address.    If desired, you can print the currently displayed statistics for later review.
ARP Cache

The ARP cache contains IP-to-hardware-address mappings for local systems with which the 
workstation is communicating. By viewing the contents of the ARP cache and comparing the 
information displayed with known IP and hardware address pairs, you can be sure that one 
system on the network is not using another system's IP address.    Checking the ARP cache is
useful when the workstation frequently loses connection when communicating with another 
host on the network.    To resolve network delivery problems, scan the ARP cache for the 
hardware address of the host with the delivery problem. If the correct hardware address 
does not appear in the ARP cache, another machine is using the target host's IP address.
Buffer Statistics

Buffer statistics indicate how much space is available for temporary storage of IP data being 
sent or received.    To verify that all requests for memory are being honored, examine the 
PC's buffer statistics.    Occasionally, some requests for memory may be denied.    This is 
acceptable behavior.    However, if you consistently encounter denied requests for memory, 
contact your network administrator.
Interface Setup

The Interface table displays information about the PC's interfaces and their configuration.    If
desired, you can obtain more information about an interface entry by double-clicking the 
entry.    The Interface dialog box appears.
Protocol Statistics

The Protocol statistics table presents detailed networking statistics for all current 
connections.
Routing Table

The Routing table identifies the hosts or networks with which the workstation is 
communicating and the routes being used.




