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Glossary
-A-
active drawing window
active layer
Angular text
Annotation
Application Control-menu
application window
arrow keys
arrowhead
arrowhead type
arrowhead size
ASCII file
attributes
AUTOEXEC macro

-B-

BasicCAD
bezier
bill of materials
bitmaps
bookmark

-C-

calculations
chamfer depth
character font
click
Clipboard
color table
command prompt
control points
coordinate
current layer
cursor crosshairs

-D-
d.p.i.
defaults
Delta X
Delta Y
dialog box
digitizer
dimension offset
directory
display grid
dithering
DOS keystrokes
dots per inch
drag
drawing Control-menu
drawing origin



Drawing Units
drawing window
drive

-E-
Enclose mode
endpoint
entity

-F-
file
file format
filename
fillet radius
font
font cartridges
function keys

-G-
gap size
graphics tablet
Group

-H-
highlighting box
highlighting nodes

-I-
icons
inactive layer
Info Box
insertion entity
intensity
invisible layer

-L-
landscape
layer

-M-
Macro
Main Toolbox
measurement
menu
merge
message
mirror normal

-N-
nodes
non-scalable
normal view
note

-O-
options



origin
overshoot

-P-
parts list
path
portrait
precision
prefix
printer driver (file)

-R-
read-only
reference point
regenerate
resolution
rubber band line

-S-
scalable
scale
section
select node
selection box
snap grid
startup macro
static zoom
suffix
symbol
symbol file
Symbol Toolbox

-T-
terminator
text style
tick mark
tolerance
Toolbox
Touch Mode
TrueType fonts

-U-
units

-V-
vector entity
vertex
view
visible layer

-W-

window
WIN.INI file

-X-



X coordinate

-Y-

Y coordinate

-Z-

zoom destination
zoom factor
zoom origin
zoom static
zoom window



Drawing Control-Menu Commands
The drawing Control-menu contains these commands:

Restore command
Move command
Size command
Minimize command
Maximize command
Close command
Next command



Menu Commands
File menu

New
Open
Close
Save
Save As
Save Selection
Save Bitmap
Merge
Load Selection
Load Symbol
Load Bitmap
Import DXF
Import IGES
Import HPGL
Import Text
Import XY
Export DXF
Export IGES
Export WordPerfect
Record Macro
Stop Recording Macro
Execute Macro
Record Options
Digitizer Menu Load
Digitizer Menu Disable All
Digitizer Menu Enable All
Digitizer Menu Remove All
Digitizer Menu Create
Run
Print
Printer Setup
Exit

Edit menu
Undo
Redo
Cut
Copy
Paste
Erase
Erase Last
Unerase
Stretch
Extend
Join
Combine
Smooth
Mirror
Break Line
Segment
Cutoff
Line To Curve



Curve To Line
Vector Conversion
Trim One Line
Trim Two Lines
Trim Between Lines
Trim Double Lines
Fillet
Chamfer
Select Previous
Select All
Entity Select
Select Rotate
Select Scale
Select Zoom
Select Ortho
Array
Circular Array
Group Define
Group Explode
Symbol Explode

View menu
Regenerate
Zoom In
Zoom Out
Zoom Window
Zoom
Align Drawing
Zoom Previous
Fit to Window
Original Size
Pan
Origin
View Read
View Save
Show Main Toolbox
Show Snap Toolbox
Show Hot Toolbox
Show Symbol Toolbox
Show Status Bar
Show Coordinate Bar
Show Rulers
Show Polar Coordinates
Show Color Table
Show Line Style Box
Show Info Box
Show Attribute

Options menu
Set Color
Load Color Table
Save Color Table
Text Options
Layer Setup
Select Layer
Move Layer



Save Layer
Delete Layer
Set Layer Color
Set Layer Line Style
Separate by Color
Units
Crosshair
Set Handles
DOS Keystrokes
Fill Wide Lines
Snap Grid
Display Grid
Grid Options
Point Line Distance
Options

Draw menu
Text
Text Arc
Arrow
Box
Circle-1
Circle-2
Circle-3
Circle-4
Tangent Two Lines
Tangent Three Lines
Ellipse
Arc-1
Arc-2
Arc-3
Arc-4
Arc-5
Elliptical Arc
Quarter Circle
Semi-Circle
Hatch
Hatch Line
Hatch Fill
Polygon-1
Polygon-2
Point Mark
Tick Marks

Lines menu
Line
Curve
Bezier Curve
Ortho Line
Parallel-1
Parallel-2
Perpendicular To Line
Perpendicular From Line
Tangent To Circle
Tangent From Circle
Tangent Between Circles



Sketch

Point menu
Line Snap
Gravity
Midpoint
Intersect-1
Intersect-2
Center of Gravity
Point XY
Point Relative
Point Polar
Point Line Snap
Line Snap Move
Gravity Move
Midpoint Move
Intersect-1 Move
Intersect-2 Move
Center of Gravity Move

Dimension menu
Dimension
Extended
Baseline
Coordinate
Progressive
Distance Only
Diameter
Radius
Progressive Radius
Angle
Arc
Chamfer
Angle, Distance-Two Points
Angle Between Two Lines
Area
Material List
Calculator
Attribute
Balloon
Pullout

Window menu
New Window
Cascade
Tile Horizontal
Tile Vertical
Arrange Icons
Close All

Help menu
Help Index
How to Use Help
About DesignCAD

Control menus



Restore
Move
Size
Minimize
Maximize
Close

DesignCAD menu only:    Switch To
Drawing Control-menu only:    Next



Arc-1 command
Use the Arc-1 command to draw an arc if you know the points for the center and radius of the arc.

Angle
The angle is entered in Drawing Units in the Angle box in the Command Line.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Same as
Use the Same as button to have the arc drawn with the same angle as another arc in the drawing.

Shortcuts
Toolbox:
Keys: A

See Also:    Drawing Arcs, Drawing Arc with Center and Radius



Same As Button

The Same as button draws an entity using the same options as an entity already on the screen.

To do this, select the Same as button in the Command Line.    Then select the entity in the drawing with 
the options you want.    The options in the Command Line will change to reflect those of the selected 
entity.



Vector Entity

A vector entity is made up of straight line segments.    These individual line segments can be seen by 
selecting the entity with the Point Select Mode from the Toolbox.

A vector entity is drawn when the Save as vector form box is selected with various DesignCAD 
commands.



Save As Vector Form Box

The Save as vector form box saves a drawing entity as a vector entity.

When an entity is saved in its vector form, the individual points used to make up the entity can be moved 
or deleted.



Vector
A vector is a straight line segment used to construct a vector entity.    These individual line segments can 
be seen by selecting the entity with the Point Select Mode from the Toolbox.

A vector is drawn with the Line command.



Arc-2 command
Use the Arc-2 command to draw an arc using points set for the beginning and end of the arc.

Radius
The radius is entered in Drawing Units in the Radius box in the Command Line.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Same as
Use the Same as button to have the arc drawn with the same radius as another arc in the drawing.

Shortcut
Mouse:

See Also:    Drawing Arcs, Drawing Arc with Beginning and End



Arc-3 command
Use the Arc-3 command to draw an arc using any three points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Arcs, Drawing Arc with Three Points



Arc-4 command
Use the Arc-4 command to draw an arc using points set for the center, beginning, and end of the arc.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Arcs, Drawing Arc with Center, Beginning, and End



Arc-5 command
Use the Arc-5 command to draw an arc using points set for the beginning, end, and radius of the arc.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Arcs, Drawing Arc with Beginning, End, and Radius



Arrange Icons command
Use the Arrange Icons command to straighten any icons on the screen and place them along the bottom 
of the screen.    Different views of the drawing window become icons when they are minimized.    These 
icons can be moved around the screen.

See Also:    Arranging Windows and Icons



Icons

Icons are little graphical symbols or buttons illustrating different DesignCAD windows.    When a 
DesignCAD drawing window is minimized with the Minimize button, it becomes an icon.    The drawing 
window is maximized by double-clicking the icon.



View

A view is a window used by DesignCAD to display a section or part of the current drawing.    Entities can 
be added, deleted, or edited in the views.    The views can be saved as separate drawings.



Window

A window is a separate view of a drawing.



Arrow command
Use the Arrow command to draw an arrow through several points.    The arrowhead is drawn at the last 
point.

Arrowhead Size
The size of the arrowhead is entered in the Arrowhead size box in the Command Line.

Arrowhead Type
The arrowhead type is selected in the Arrowhead Type box in the Command Line.

Same as
Use the Same as button to have the arrow drawn with the same size or type of arrowhead as another 
arrow in the drawing.

Shortcuts
Mouse:
Keys: >

See Also:    Drawing Regular Lines



Arrowhead

An arrowhead is drawn at the end of a line drawn with the Arrow command.    The arrowhead type and 
arrowhead size can be changed in the Command Line at the top of the screen.



Arrowhead Types

The Arrow and Dimension commands draw arrows through a set of points.    At the end of the arrow is the 
arrowhead.

There are 12 arrowhead types available, these are:

None
Normal
Slash

Filled Circle
Filled (Short)
Filled (Long)

Hollow Circle
Hollow (Short)
Hollow (Long)

Normal (60º)
Filled (60º)
Hollow (60º)



Arrowhead Size Box

The Arrowhead Size box in the Command Line allows you to change the size of an arrowhead.



Attribute command
Use the Attribute command to assign information to an object in the drawing.    This information can later 
be extracted from the drawing file and used with other programs for applications such as parts lists and 
bills of materials.

Text
The text for the attribute is entered in this box in the Command Line.    Up to 80 characters can be 
entered.

Size
The size of the attribute is entered in the Size box in the Command Line.

Show attributes
Attributes will not be displayed on the screen unless the Show Attribute option is selected in the Options 
menu or the Show attributes box is selected in the Command Line.    Whether the attribute is displayed on
the screen or not, it will be copied, deleted, etc., as a normal entity.

Attributes can be extracted and used by the Material List command.    This command creates a list of all 
attributes in a drawing and outputs this information to the printer or a disk file for use by other 
applications.

Shortcuts
Mouse:
Keys: $

See Also:    Drawing Attributes, Show Attribute option



Bill of Materials

The Bill of Materials is a list of attributes in a drawing generated by the Material List command.



Balloon command
Use the Balloon command to add information to a drawing in a text balloon.

Text
The text is entered in the Text box in the Command Line.

Balloon Size
The size of the balloon drawn around the text is entered in the Balloon Size box in the Command Line.

Dimension Line button
The arrowhead type and size can be set by choosing the Dimension Line button in the Command Line.

Same as
Choose the Same as button to have the balloon drawn with the same arrowhead and text size as another 
balloon in the drawing.

Shortcut
Mouse:

See Also:    Drawing a Balloon around Information



Bezier Curve command
Use the Bezier Curve command to draw a bezier curve through four points.    The second and third points 
are control points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Bezier Curves



Control Points

Control points are used with the Bezier Curve command to determine the tangents of the curve at the 
endpoints.    The farther the control points are from the first and last points, the more they influence the 
curve.



Box command
Use the Box command to draw a box or rectangle defined by two points.

Align to any angle
The box can be drawn aligned to any angle by selecting the Align to any angle box in the Command Line. 
When this box is selected, two points are set for the first side of the box.    The points can be set at any 
angle.    A third point is set for the opposite edge of the box.

Shortcuts
Mouse:
Keys: ]

See Also:    Drawing Simple Polygons, Drawing a Box



Break Line command
Use the Break Line command to break a line entity consisting of two or more line segments into separate 
line entities.    Each of the lines will be defined by two endpoints.

Shortcuts
Mouse:
Keys: |

See Also:    Breaking a Line, Breaking Lines



Cascade command
Use the Cascade command to arrange all open views on the screen so that a small amount of each 
window is visible.

See Also:    Cascading Windows



Center of Gravity command
Use the Center of Gravity command to find the geographic center of an entity.

Shortcut
Mouse:

See Also:    Choosing Point Commands, Setting Points, Center of Gravity Move command



Center of Gravity Move command
Use the Center of Gravity Move command to move the pointer to the geographic center of an entity 
without setting a point.

Shortcut
Mouse:

See Also:    Choosing Point Commands, Setting Points, Center of Gravity command



Chamfer command
Use the Chamfer command to "cut off" the corner of a line or arc entity with a straight line.

The "chamfer depth" is entered in the Chamfer box in the Command Line.

Keep original lines
The original lines used to make up the corner of the object will be removed, unless the Keep original lines 
box in the Command Line is selected.

Shortcuts
Mouse:
Keys: Ctrl+F

See Also:    Chamfering Lines



Chamfer Depth

The chamfer depth is the depth, or radius, of the line that cuts off the corner of the entity.



Circle-1 command
Use the Circle-1 command to draw a circle using points set for the center and radius.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the circle as a vector entity.

Shortcuts
Mouse:
Keys: O

See Also:    Drawing Circles, Drawing Circle with Center and Radius



Circle-2 command
Use the Circle-2 command to draw a circle using two points set for the diameter.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the circle as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Circles, Drawing Circle with Diameter



Circle-3 command
Use the Circle-3 command to draw a circle by setting any three points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the circle as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Circles, Drawing Circle with Three Points



Circle-4 command
Use the Circle-4 command to draw a circle with a point set for the center.

Radius
The radius length is entered in Drawing Units in the Radius box in the Command Line.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Same as
Use the Same as button to have the circle drawn with the same radius as another circle in the drawing.

Shortcut
Mouse:

See Also:    Drawing Circles, Drawing Circle with Center and Radius Length



Circular Array command
Use the Circular Array command to duplicate selected objects a certain number of times in a circle or arc.

No. of copies
The number of copies to be duplicated is entered in the No. of copies box in the Command Line.

Angle
The angle of the circle or arc is entered in the Angle box in the Command Line.

Use original as the 1st copy
If the Use original as 1st copy box is selected in the Command Line, the original entity will be used as the 
location of the first copy.

Fixed handle
Use the Fixed handle box in the Command Line to have the center point remain in the same position 
when you set a point for the primary handle.

Shortcut
Mouse:

See Also:    Copying Objects in a Circle



Tangent Two Lines command
Use the Circle Tangent Two Lines command to draw a circle tangent to two lines.

Radius
The radius of the circle is entered in Drawing Units in the Radius box in the Command Line.

Same as
The circle can be drawn using the same radius as a circle in the drawing by choosing the Same as button 
in the Command Line.

Shortcut
Mouse:

See Also:    Drawing Tangent Circles



Tangent Three Lines command
Use the Circle Tangent Three Lines command to draw a circle tangent to three lines.    The radius of the 
circle is determined by the placement of the three lines.

Shortcut
Mouse:

See Also:    Drawing Tangent Circles



Close command
Use the Close command to close all windows containing the active drawing.    When this command is 
selected you are asked if you want to save the current drawing.    Select the Yes button to save the current
drawing.    Select the No button to close the current drawing without saving it.    Select the Cancel button 
to return to the drawing screen without saving or closing the current drawing.    If you close a drawing 
without saving, you lose all changes made since the last time you saved it.

You can also close a drawing by using the Close command in the drawing Control-menu.

Shortcut
Keys: Ctrl+F4

See Also:    Closing a Drawing, Closing a Drawing and Exiting DesignCAD



Drawing Control-Menu

The drawing Control-menu is a menu with commands that control a drawing window, for example you can
move, resize and close a drawing window.



Close All command
Use the Close All command to close all the open windows.

See Also:    Closing a Window



Close command (Control menu)
Use the Close command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: Ctrl+F4 closes a drawing window

Alt+F4 closes the DesignCAD window or a dialog box

See Also:    Closing a View



Combine command
Use the Combine command to combine two or more lines into a single line.    Each line that is to be 
combined must be connected to the next line.    Therefore, each line selected for this command must 
share an endpoint with the previous line.

If the lines being combined are drawn in different colors or line types, the line resulting after they are 
combined will use the characteristics of the first line selected.    If the lines are selected at the same time, 
the combined line will use the characteristics of the first line drawn.

See Also:    Combining Lines



Apply Button
The Apply button lets you "apply" a selected option to an entity in the drawing.

For example, to have an object drawn in a different color, first select the object.    Then select the new 
color in the color table.    Next, select the Apply button.



Color Table

The color table is the list of colors displayed when the Show Color Table command is selected.

These colors can be edited with the Set Color command, or by double-clicking a color in the color table.    
The new colors can be saved with the Save Color Table command.    A new color table can be loaded with
the Load Color Table command.



Static Zoom

To "Static Zoom" a drawing means to permanently change the zoom of the drawing.    When the Static 
Zoom button is selected in the Command Line, the actual size and position of the drawing changes, rather
than just the view of the drawing.



Show Hot Toolbox option
Use the Show Hot Toolbox option to create a Hot Toolbox containing only those commands that you use 
most often.

Commands are selected in the Main or Snap Toolboxes and "dragged" to the Hot Toolbox.

Shortcut
Keys: Shift+Alt+T

See Also:    Creating Hot Toolbox



Main Toolbox
The Toolbox can be displayed on the screen to give quick mouse access to the most-commonly used 
DesignCAD commands.

To hide or display the Toolbox, choose the Show Main Toolbox option in the View menu.

See Also:    Showing Main Toolbox, Hiding Main Toolbox, Changing Toolbox Columns, Customizing 
DesignCAD



Crosshair option
Use the Crosshair option to activate the cursor crosshair.    You can use the cursor crosshairs to line up 
points and entities on the screen.

Shortcut
Keys: Ctrl+H

See Also:    Displaying the Cursor Crosshairs



Cursor Crosshairs

The crosshairs are horizontal and vertical lines attached to the pointer on the screen.



Curve command
Use the Curve command to draw a curve through three or more points.    Up to 200 points can be set for 
the curve.

Save as vector form
The curve can be saved as a vector entity by choosing the Save as vector form box in the Command 
Line.

Shortcuts
Mouse:
Keys: C

See Also:    Drawing Curves, Converting Curves



Curve To Line command
Use the Curve To Line command to change a curve entity to a line entity

See Also:    Converting Lines



Cutoff command
Use the Cutoff command to "cut off" a section of a drawing.    Then use other DesignCAD commands to 
erase, copy, move, or edit the section.

Cut selected entities only
The Cut selected entities only box in the Command Line allows you to select the entities you want to cut.   
Entities within the selection box but not selected will not be cut.

Shortcut
Mouse:

See Also:    Breaking Lines



Erase Last command
Use the Erase Last command to delete the last line or entity drawn.    This command can be repeated until
each entity is deleted.

Shortcut
Keys: Ctrl+E

See Also:    Deleting Entities



Dimension command
Use the Dimension command to draw dimensioning information about an object.    Dimensions can be 
drawn vertically, horizontally, or aligned to any angle.

HOR
Choose this button to have the dimension measured horizontally.

VER
Choose this button to have the dimension measured vertically.

ALO
Choose this button to have the dimension aligned to any angle.

The following dimension options can be changed with the dimension commands:

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcuts
Mouse:
Keys: @

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Lines





Dimension Line button

Use the Dimension Line button to set the position, dimension offset, arrowhead type, and arrowhead size 
of the dimension.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the dialog box.

See Also:    Position of Dimension Arrows, Dimension Arrowhead Type, Dimension Arrowhead Size



Dimension Extension Line button

Use the Dimension Extension Line button to set the overshoot length, fixed length, or variable length of 
the extension line for the dimension.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the dialog box.

See Also:    Dimension Options, Changing Dimension Options, Extension Line



Dimension Text button

Use the Dimension Text button to set the format, precision, location, orientation, and size of the text 
information for the dimension.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the dialog box.

See Also:    Dimension Options, Changing Dimension Options, Dimension Text



Dimension Prefix and Suffix button

Use the Dimension Prefix and Suffix button to set the prefix and suffix for the dimension text.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the dialog box.

See Also:    Dimension Options, Changing Dimension Options, Dimension Prefix, Dimension Suffix



Dimension Tolerance button

Use the Dimension Tolerance button to set the positive and negative tolerance information for the drawing
as well as the size of the tolerance.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the dialog box.

See Also:    Dimension Options, Changing Dimension Options, Tolerancing Information



Dimension Angle command
Use the Dimension Angle command to draw dimensioning information for an angle.    Points are set for the
center, beginning, and end of the angle to be measured.    A fourth point is set for the location of the 
dimension text information.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
Selecting the Save as vector form box in the Command Line saves the dimension as a vector entity.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Drawing Angle Dimensions



Dimension Arc command
Use the Dimension Arc command to dimension the length of an arc.    Points are set on the arc and at the 
location for the dimension text information.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
Selecting the Save as vector form box in the Command Line saves the dimension as a vector entity.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Arcs



Dimension Coordinate command
Use the Dimension Coordinate command to draw coordinate dimensions relative to a base point.    The 
first point is the drawing origin, or reference point, from which subsequent points are dimensioned.

If the second point is set above or below the first point, the X-value, or horizontal distance, from the 
reference point will be placed in the dimension.    If the second point is set to the right or left of the first 
point, the Y-value, or vertical distance, from the reference point will be placed into the dimension.

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Save as vector form
Selecting the Save as vector form box in the Command Line saves the dimension as a vector entity.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Lines



Drawing Origin

The origin of a drawing is the location of the point with the coordinates 0, 0.

The origin lies in the lower left corner of the DesignCAD screen before any zooms, pans, or rotates are 
performed.

When the Dimension Coordinate command is selected, a point is set for the origin.    This will be the point 
that the subsequent points are measured from.

When the Origin command is selected, a point is set for the new origin of the drawing.    This point is used 
as the origin until it is changed or another drawing is retrieved.



Reference Point

A reference point is a point in the drawing used to define a unit of measurement or a coordinate position.

When the Dimension Coordinate command is selected a point is set for the reference point so that 
subsequent points can be measured from this location.



Dimension Diameter command
Use the Dimension Diameter command to draw diameter dimensions for a circle or arc.

Pre-Defined Extension
Choose this button to have the dimension drawn with a pre-defined extension line.

Dimension Outside Circle
Choose this button to have the dimension text and arrowheads drawn outside the circle.

Dimension Inside Circle
Choose this button to have the dimension arrowheads drawn inside the circle.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
Selecting the Save as vector form box in the Command Line saves the dimension as a vector entity.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Circles



Dimension Radius command
Use the Dimension Radius command to draw radius dimensions for a circle or arc.

Pre-Defined Extension
Choose this button to have the dimension drawn with a pre-defined extension line.

Dimension Outside Circle
Choose this button to have the dimension text and arrowheads drawn outside the circle.

Dimension Inside Circle
Choose this button to have the dimension arrowheads drawn inside the circle.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
Selecting the Save as vector form box in the Command Line saves the dimension as a vector entity.

Same as
The dimension can be drawn with the same options as another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Circles



Dimension Distance Only command
Use the Dimension Distance Only command to dimension a line without extension lines and arrows.

HOR
Choose this button to have the dimension measured horizontally.

VER
Choose this button to have the dimension measured vertically.

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Lines



Dimension Extended command
Use the Dimension Extended command to draw successive dimensions extended along several points.

HOR
Choose this button to have the dimension measured horizontally.

VER
Choose this button to have the dimension measured vertically.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Drawing Extended Dimensions



Dimension Baseline command
Use the Dimension Baseline command to draw baseline dimensions.

HOR
Choose this button to have the dimension measured horizontally.

VER
Choose this button to have the dimension measured vertically.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Lines



Dimension Progressive command
Use the Dimension Progressive command to draw the dimensions of a line progressively from a base 
point.

HOR
Choose this button to have the dimension measured horizontally.

VER
Choose this button to have the dimension measured vertically.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Drawing Progressive Dimensions



Dimension Progressive Radius command
Use the Dimension Progressive Radius command to draw radius dimensions progressively.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Extension Line
Overshoot Length
Fixed Length
Variable Length

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Drawing Progressive Dimensions



Dimension Chamfer command
Use the Dimension Chamfer command to draw the dimensions for a chamfered line.

Dimension Line
Position of Dimension Arrows
Dimension Arrowhead Type
Dimension Arrowhead Size

Dimension Text
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix and Suffix
Dimension Prefix
Dimension Suffix

Dimension Tolerance
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Save as vector form
The dimension can be saved as a vector entity by choosing the Save as vector form box in the Command
Line.

Same as
The dimension can be drawn with the same options of another dimension entity in the drawing by 
selecting the Same as button in the Command Line.

Shortcut
Mouse:

See Also:    Adding Dimensions, Changing Dimensions, Dimensioning Lines



Display Grid

The display grid is a series of "guide lines" drawn on the screen.    The display grid helps locate points in a
drawing.    The grid is not printed when the drawing is printed.



Set Color command
Use the Set Color command to change the color specifications of the colors in the color table.

The changes made to the color table can be saved with the Save Color Table command.    The new color 
table can be loaded with the Load Color Table command.

Dialog box options
Red Set the new color for the red value in this box.
Green Set the new color for the green value in this box.
Blue Set the new color for the blue value in this box.
Current The original color is shown in this box.
New The new color is shown in this box.

Shortcut
Mouse: Double-click the color in the color table.

See Also:    Customizing the Color Table, Save Color Table command



Ellipse command
Use the Ellipse command to draw an ellipse, or oval using three points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the ellipse as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Elliptical Circles



Elliptical Arc command
Use the Elliptical Arc command to draw an elliptical arc, or part of an ellipse or oval, between two points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the arc as a vector entity.

Shortcut
Mouse:

See Also:    Drawing Elliptical Arcs



Display Grid option
Use the Display Grid option to activate the display grid.

The display grid type and size are set with the Grid Options command.

Shortcut
Keys: G

See Also:    Setting the Display Grid



Snap Grid option
Use the Snap Grid option to activate the snap grid.

The snap grid size is set with the Grid Options command.

Shortcut
Keys: Ctrl+G

See Also:    Setting Grids, Setting the Grid Sizes



Entity Select command
Use the Entity Select command to select all entities of a certain type in the drawing.

The following entities can be selected with the Entity Select command:

Vector Symbol
Ellipse Point mark
Text Angular Dimension
Curve Linear Dimension
Back Arc Diameter/Radius Dimension
Ellipse Arc Arc Dimension
Bezier Curve Radius Progress Dimension
Attribute Linear Progress Dimension
Circle or Arc Chamfer Dimension
Hatch Coordinate Dimension
Text Arc Bitmap
Arrow

See Also:    Selecting Entities, Selecting Certain Entities



Erase command
Use the Erase command to selectively erase lines or entities in the drawing.    Set a point on each line or 
entity to be erased.

More than one entity can be erased at a time with this command by setting points on several entities or 
setting points in opposite corners of a rectangular selection box.    All entities selected within this box will 
be erased.

Shortcut
Keys: E

See Also:    Erasing Entities



Exit command
Use the Exit command to end your DesignCAD session.    You can also use the Close command on the 
application Control-menu to exit DesignCAD.    DesignCAD prompts you to save any open drawing with 
unsaved changes.

Shortcuts
Mouse: Double-click the application Control-menu button.
Keys: Alt+F4

See Also:    Exiting DesignCAD



Export DXF command
Use the Export DXF command to export a drawing in a DXF drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Extending Lines



Extend command
Use the Extend command to extend or shorten a line by moving one of the points defining the end of the 
line.    The line maintains the same angle after it has been extended.

See Also:    Extending Lines, Editing Lines



Fillet command
Use the Fillet command to "round off" the corner of a line or arc entity with a smooth arc.

Fillet Radius
The "fillet radius" is entered in Drawing Units in the Fillet radius box in the Command Line.

Keep original lines
The original lines used to make up the corner of the entity being filleted are removed unless the Keep 
original lines box is selected in the Command Line.

Same as
The line can be filleted with the same radius as another line in the drawing by selecting the Same as 
button in the Command Line.

Shortcuts
Mouse:
Keys: F

See Also:    Filleting Lines



Fill Wide Lines option
Use the Fill Wide Lines option to fill all lines in the drawing with a width greater than 0.00 Drawing Units.

See Also:    Filling Wide Lines, Changing Line Characteristics



Fit to Window command
Use the Fit to Window command to zoom a drawing so that it fills the entire drawing window.

Shortcut
Keys: Ctrl+W

See Also:    Zooming a Drawings, Restoring a Drawing to Former Size



Character Font

The character font is the typeface that the text is drawn in.



Load Color Table command
Use the Load Color Table command to load a different color table onto the screen.

The color table is displayed when the Show Color Table option is selected.    The color table can be 
changed with the Set Color command.    The new color table can be saved with the Save Color Table 
command.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Getting Color Table, Loading Color Table



Gravity command
Use the Gravity command to snap to the nearest point in a drawing and set a point.

Shortcuts
Mouse:
Keys: .

See Also:    Choosing Point Commands, Setting Points, Gravity Move command



Gravity Move command
Use the Gravity Move command to "snap" the pointer to the nearest point without setting a point.

Shortcuts
Mouse:
Keys: ,

See Also:    Choosing Point Commands, Setting Points, Gravity command



Grid Options command
Use the Grid Options command to set the display grid size and type, and the snap grid size.

Dialog box options
Display Grid Type Choose the display grid type from this box.
Display Grid Size Enter the display grid size in this box.
Snap Grid Size Enter the snap grid size in this box.
Enable display grid This box enables or disables the display grid.
Enable snap grid This box enables or disables the snap grid.
Save Options Choose this box to save the grid options to the DCW.INI file.

See Also:    Setting Grids, Setting the Grid Sizes



Group Define command
The Group Define command defines one or more entities as a single object, or Group, so that the entities 
can be selected and edited as a single object.

See Also:    Defining a Group



Group Explode command
The Group Explode command "explodes," or "undefines," a Group so that the individual entities can be 
selected and edited separately.

See Also:    Undefining a Group



Hatch command
Use the Hatch command to add hatch patterns to an area.

Hatch Angle
The angle of the hatch pattern is entered in the Hatch Angle box in the Command Line.

Hatch Scale
The size of the pattern is entered in the Hatch Scale box in the Command Line.

Hatch Pattern
The hatch pattern is selected by choosing the Hatch Pattern button in the Command Line.

Same as
The hatch can be drawn using the same angle, scale, and pattern of other hatch areas in the drawing by 
choosing the Same as button in the Command Line.    Then choose the hatch area in the drawing.

See Also:    Hatching a Selected Area, Hatch Patterns



Hatch Line command
Use the Hatch Line command to add hatch patterns to an area enclosed by a line.

Hatch Angle
The angle of the hatch pattern is entered in the Hatch Angle box in the Command Line.

Hatch Scale
The size of the pattern is entered in the Hatch Scale box in the Command Line.

Hatch Pattern
The hatch pattern is selected by choosing the Hatch Pattern button in the Command Line.

Same as
The hatch can be drawn using the same angle, scale, and pattern of other hatch areas in the drawing by 
choosing the Same as button in the Command Line.    Then choose the hatch area in the drawing.

See Also:    Hatching a Line Entity, Hatch Patterns



Hatch Fill command
Use the Hatch Fill command to add hatch patterns inside an area.

Hatch Angle
The angle of the hatch pattern is entered in the Hatch Angle box in the Command Line.

Hatch Scale
The size of the pattern is entered in the Hatch Scale box in the Command Line.

Hatch Pattern
The hatch pattern is selected by choosing the Hatch Pattern button in the Command Line.

Selection Only
If the entity is selected before the command is chosen, you can choose the Selection Only box to limit the 
hatch boundary to only those lines that are selected.

Same as
The hatch can be drawn using the same angle, scale, and pattern of other hatch areas in the drawing by 
choosing the Same as button in the Command Line.    Then choose the hatch area in the drawing.

See Also:    Hatching an Enclosed Area, Hatch Patterns



Help Index command
Use the Help Index command to display help for DesignCAD commands.

To use the Help Index
Click an underlined topic.
-or-
Press the Tab key until you highlight the topic you want, then press Enter.

To scroll in the Help window
Click the scroll bars on the right side of the screen.
-or-
Press the up or down arrow keys.

To return to the previous topic
Click the Back button.
-or-
Press B to return to the previous topic.

To open the Search feature in Help
Click the Search button.
-or-
Press S to select the Search feature.

To close the Help window
Choose Exit from the Help File menu.
-or-
Press Alt+F to open the Help File menu.
Press x to choose the Exit command.

Shortcuts
Keys: F1 

-or-
Shift+F1

See Also:    Finding Information in Help, Help Instructions



Options command
Use the Options command to change default options for DesignCAD.

This command allows you to change:

Toolbox
Symbol Toolbox
Macro
Coordinate Bar
View
Drawing
Text
Cursor
Grid
General Dimension
Dimension Text
Dimension Prefix and Suffix
Digitizer Menu
Miscellaneous

See Also:    Changing Default Options



Import DXF command
Use the Import DXF command to open a drawing in DXF drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Intersect-1 command
Use the Intersect-1 command to snap to the intersection of two lines.

Shortcuts
Mouse:
Keys: N

See Also:    Choosing Point Commands, Setting Points, Intersect-1 Move command



Intersect-2 command
Use the Intersect-2 command to snap to the intersection of two lines by setting two points.

Shortcut
Mouse:

See Also:    Choosing Point Commands, Setting Points, Intersect-2 Move command



Intersect-1 Move command
Use the Intersect-1 Move command to "snap" the pointer to the intersection of a line without setting a 
point.

Shortcuts
Mouse:
Keys: Ctrl+N

See Also:    Choosing Point Commands, Setting Points, Intersect-1 command



Intersect-2 Move command
Use the Intersect-2 Move command to "snap" the pointer to the intersection of two lines without setting a 
point.

Shortcut
Mouse:

See Also:    Choosing Point Commands, Setting Points, Intersect-2 command



Join command
Use the Join command to connect the points of two or more lines in the drawing.    Set two points in 
opposite corners of the area to be joined.    The endpoints within the selection box will all be moved to one
location.

See Also:    Joining Lines



Layer Setup command
Use the Layer Setup command to set the current layer for the drawing, name a layer, and display the 
layer commands.

A DesignCAD drawing can have up to 256 layers or subdivisions.

Dialog Box Options
Current layer
When you create a new drawing, the entities are added to the current layer.    The current layer is 
shown in the Coordinate Bar at the top of the screen.    The current layer defaults to Layer 1 unless 
otherwise specified.

No.
You can set the number of the current layer in this box.

Name
You can set the name of the current layer in this box.

Multilayer
Choose the Multilayer box to manipulate entities in the layers.

Visible/Invisible
Each layer can be set to visible or invisible status.    A visible, or active, layer is displayed on the 
screen.    An invisible, or inactive, layer is not visible on the screen.

Editable/Uneditable
A visible layer can be edited or can be "uneditable."    An invisible layer cannot be editable.

Layer Names
Layers can be named for easy identification.

Commands
Choose the Commands button to open any of these commands:

Select Layer
Move Layer
Save Layer
Delete Layer
Set Layer Color
Set Layer Line Style
Separate by Color

See Also:    Editing Layers, Manipulating Layers, Setting Layer Options



Current Layer

The current layer is the layer currently being used.    The current layer is displayed in the Layer box in the 
Coordinate Bar at the top of the screen.



Active Layer

Layers can be active or inactive.    Active layers are visible on the screen.



Inactive Layer

Layers can be active or inactive.    Inactive layers are not visible on the screen.



Set Layer Color command
Use the Set Layer Color command to set the color for an entire layer.    All entities in the layer will be 
changed to the new color.    Subsequent entities drawn in the layer will be drawn in the current color 
shown in the Toolbox.

See Also:    Manipulating Layers



Delete Layer command
Use the Delete Layer command to delete all the objects in a layer.    All the objects in the current layer will 
be deleted.

This command erases existing objects only.    It does not prevent objects from being drawn in the current 
layer after the command is issued.

See Also:    Editing Layers, Manipulating Layers



Set Layer Line Style command
Use the Set Layer Line Style command to set the type, width, and scale of the lines in a layer.    The lines 
in the layer will be drawn in the new line style.    Subsequent lines drawn in the layer will be drawn using 
the current line style shown in the Toolbox.

Dialog box options
Line Type Choose the line type from this box.
Scale Enter the scale for the line in this box.
Width Enter the width for the line in this box.

See Also:    Manipulating Layers



Move Layer command
Use the Move Layer command to move all the objects in a layer to a different layer.    All the objects in the 
current layer will be moved to the new layer.    The current layer will be empty.

This command changes existing objects only.    It does not prevent objects from being drawn in the current
layer after the command is issued.

See Also:    Manipulating Layers, Selecting and Moving Layers



Save Layer command
Use the Save Layer command to save an entire layer as a separate drawing.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Manipulating Layers



Select Layer command
Use the Select Layer command to select all the objects in a layer.    All the objects in the current layer will 
be selected.

See Also:    Manipulating Layers, Selecting and Moving Layers



Separate by Color command
Use the Separate by Color command to separate the objects of the current layer into separate layers 
according to color.    All the objects drawn in Color 1 will be moved to Layer 1, objects in Color 2 will be 
moved to Layer 2, etc.

See Also:    Manipulating Layers, Separating Colors into Layers



Line command
Use the Line command to draw a line between points.    Up to 200 points can be set with this command.

Shortcuts
Mouse:
Keys: V

See Also:    Line Types, Drawing Lines



Angle, Distance Two Points command
Use the Angle, Distance-Two Points command to calculate the angle and distance between two points 
and displays that information in a dialog box.

Dialog box options
Angle precision

This box sets the number of decimal places for angular measurement:
Angle format

This box sets the format for angular measurement information:
Distance precision

This box sets the number of decimal places for linear measurement:
Distance format

This box sets the format for linear measurement information:

Shortcuts
Mouse:
Keys: <

See Also:    Calculating Angle of Two Points, Adding Angle of Objects to Drawing



Angle Between Two Lines command
Use the Angle Between Two Lines command to find the angle between two lines.

Dialog box options
Precision

The angular precision box sets the number of decimal places for angular measurement:
Format

The angular format box sets the format for angular measurement information:

Shortcut
Mouse:

See Also:    Calculating Angle of Two Lines, Displaying Angle of Two Lines



Line Snap command
Use the Line Snap command to snap to the nearest line in the drawing and set a point.

Shortcuts
Mouse:
Keys: K

See Also:    Choosing Point Commands, Setting Points, Line Snap Move command



Line Snap Move command
Use the Line Snap Move command to "snap" the pointer to the nearest line without setting a point.

Shortcuts
Mouse:
Keys: Ctrl+K

See Also:    Choosing Point Commands, Setting Points, Line Snap command



Line To Curve command
Use the Line To Curve command to change a line entity to a curve entity

See Also:    Converting Lines



Merge command
Use the Merge command to merge two or more drawings into one drawing.    The second drawing will be 
scaled to the Drawing Units of the drawing on the screen.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Merging Drawings



Midpoint command
Use the Midpoint command to snap to the midpoint of the nearest line.

Shortcuts
Mouse:
Keys: F2

See Also:    Choosing Point Commands, Setting Points, Midpoint Move command



Midpoint Move command
Use the Midpoint Move command to "snap" the pointer to the midpoint of the nearest line without setting a
point.

Shortcuts
Mouse:
Keys: Ctrl+F2

See Also:    Choosing Point Commands, Setting Points, Midpoint command



Minimize command (Control menu)
Use the Minimize command to reduce the DesignCAD window to an icon.

Clicking the  in the upper-right corner of the window is the same as choosing the Minimize command.

See Also:    Minimizing Windows



Maximize command (Control menu)
Use the Maximize command to enlarge the active window to fill the available space.

A drawing window expands to fill the DesignCAD window.
The DesignCAD window expands to fill the entire screen.

Clicking the  in the upper-right corner of the window is the same as choosing the Maximize command.

Shortcut
Mouse: Double-click title bar

See Also:    Maximizing Windows



Move command (Control menu)
Use the Move command to display a four-headed arrow so you can move the active window or dialog box
with the arrow keys.

Note:    This command is not available if the window is maximized.

See Also:    Moving and Sizing Windows



Next command (Control menu)
Use the Next command to switch to the next open drawing window.    DesignCAD determines which 
window by the order in which you opened the windows.

Shortcut
Keys: Ctrl+F6

See Also:    Switching to a Different Drawing Window



New command
Use the New command to create a new drawing in DesignCAD.    You can open an existing drawing with 
the Open command.

Shortcuts
Mouse:
Keys: Y

See Also:    Creating a New Drawing, New Drawings



Open command
Use the Open command to open an existing file in a new window.    You can have several drawings open 
at once, depending on the size of each drawing.

If you have a drawing on your screen that you no longer want to use, choose the Close command to 
close it.

You can create new drawings with the New command.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

Set Handles
The Set Handles box allows you to set handles of the drawing to determine how it will be loaded.    If 

handles were set before the drawing was saved, up to two points can be set to designate the 
primary and secondary handles.    If no handles were set when the drawing was saved, up to four 
points can be set for the lower left, lower right, upper left, and upper right corners of the drawing 
respectively.

Shortcuts
Mouse:
Keys: Ctrl+F12

See Also:    Opening a Drawing, Opening an Existing Drawing, Opening Drawings



Directory

A directory is a subdivision of a disk that works like a filing system to help you organize your drawings.    
For example, you can create a directory called SYMBOL to store all your symbols.



Drive

The drive is the mechanism in your computer that turns a disk to retrieve and store information.    Personal
computers often have one hard drive labeled C and two drives labeled A and B that read removable disks.



Origin command
Use the Origin command to move the drawing origin of the drawing.    The drawing origin is the location of 
coordinate 0, 0.    It lies in the lower left corner of the screen before any zooms, pans, rotates, etc., are 
performed.

The Zoom, Rotate, and Pan commands may change the location of the origin on the screen, but it 
remains at the same point on the drawing unless it is changed with the Origin command, Zoom Static 
command, or at the time the drawing is retrieved.

See Also:    Setting a New Origin



Original Size command
Use the Original Size command to return the drawing to its original size after a zoom command.

Shortcut
Keys: Ctrl+O

See Also:    Zooming a Drawing



Ortho Line command
Use the Ortho Line command to draw a straight line exactly vertically or horizontally.    Up to 200 points 
can be set with this command.

Shortcut
Mouse:

See Also:    Drawing Regular Lines



Pan command
Use the Pan command to pan, or move, the drawing across the screen.

Shortcut
Mouse:

See Also:    Zooming Entire Drawing, Panning Drawings



Parallel-1 command
Use the Parallel-1 command to draw a line parallel to any other line, curve, circle, arc, ellipse, or elliptical 
arc.

Shortcuts
Mouse:
Keys: =

See Also:    Drawing Parallel Lines



Parallel-2 command
Use the Parallel-2 command to draw a line parallel to any other line or curve.

Distance
The distance the parallel line is drawn from the original line is set in the Distance box in the Command 
Line.

Shortcut
Mouse:

See Also:    Drawing Parallel Lines



Perpendicular To Line command
Use the Perpendicular To Line command to draw a line perpendicular from a point in the drawing to an 
existing line.

Shortcut
Mouse:

See Also:    Drawing Perpendicular Lines



Perpendicular From Line command
Use the Perpendicular From Line command to draw a perpendicular line to any other line or curve.

Distance
The distance of the perpendicular line is entered in the Distance box in the Command Line.

Shortcut
Mouse:

See Also:    Drawing Perpendicular Lines



Point Mark command
Use the Point Mark command to mark a point in the drawing with a small cross, box, circle, or 
combination of these objects.

Cross
Choose this button to have the point mark drawn as a single cross.

Cross and Box
Choose this button to have the point mark drawn as a cross inside a box.

Cross and Circle
Choose this button to have the point mark drawn as a cross inside a circle.

Cross, Circle, and Box
Choose this button to have the point mark drawn as a cross inside a circle and a box.

Point Mark Size
Enter the size for the point mark in this box.

Same as
Choose this button to have the point mark drawn the same as a point mark in the drawing.    Then select 
the point mark in the drawing.

Shortcut
Mouse:

See Also:    Marking Points



Point Move command
Use the Point Move command to move or delete a point in the drawing.

Shortcut
Keys: *

See Also:    Moving Points



Polygon-1 command
Use the Polygon-1 command to draw a regular polygon by setting two points for the first side.

No. of sides
The number of sides of the polygon is entered in the No. of sides box in the Command Line.

Same as
Select the Same as button to have the polygon drawn with the same number of sides as another polygon 
in the drawing.

Shortcut
Mouse:

See Also:    Drawing Simple Polygons, Drawing a Polygon with Corner Points



Polygon-2 command
Use the Polygon-2 command to draw a regular polygon by setting a point for the center and a point for the
corner of the polygon.

No. of sides
The number of sides for the entity is entered in the No. of sides box in the Command Line.

Same as
Select the Same as button to have the polygon drawn with the same number of sides as another polygon 
in the drawing.

Shortcut
Mouse:

See Also:    Drawing Simple Polygons, Drawing a Polygon with Center and Corner



Print command
Use the Print command to print DesignCAD drawings.    To specify a printer and its connection, use the 
Printer Setup command.

Dialog Box Options
Drawing Size

The drawing size is shown in the Drawing Size box at the top of the dialog box.    Choose the units of
measurement from the Units box.

Print Area
The print area displays the scale, height, and width of the drawing.

Center Drawing Choose the Center Drawing box to have the drawing centered on the paper.
Fit to Paper Choose the Fit to Paper box to have the drawing fill the entire paper.

Panel
The Panel box displays the number of panels the drawing will use.

Mark Choose the type of panel mark from the Mark box.
Mark Panel Number This box determines if panels will be numbered or not.

Number of Copies
You can enter the number of copies to be printed in this box.

Paper Size
The Paper Size box shows the size of the paper loaded in the printer.

Margin You can change the size of the top, bottom, left, and right paper margins.
Orientation Drawings are either printed in Portrait or LandScape orientation.

Print Selection
This box is available when an entity is selected before the Print command is issued.    Choosing this 

box allows you to print only the selected entity.
Print to File

Choosing this box saves the drawing file to disk.
Preview

Choose this button to preview the entire drawing before you print it.
Printer Setup

Choose this button to setup the printer.

Shortcuts
Mouse:
Keys: Ctrl+Shift+F12

See Also:    Printing, Printing and Plotting Drawings



D.P.I. -- Dots Per Inch

The dots per inch, or d.p.i., determine how many dots the printer uses to output per inch in the drawing.



Printer Setup command
Use Printer Setup command to select a printer.

Dialog Box Options
Printer

Select the printer you want to use; only installed printers appear.    You install printers and configure 
ports through the Windows Control Panel.    For information on installing printers, see your system 
documentation.

Use Printer Font Only
This command allows you to set the printer to use printer fonts only.    This aids in printing text at 

lower resolutions.
Setup

Displays Setup dialog box for the selected printer.    The dialog box that appears depends on the 
printer.

See Also:    Print Options dialog box, Printer Setup



Print Options Dialog Box
Use the Print Options dialog box to select printing options for your printer.

Dialog Box Options
Units

Choose units of measurement used in your drawing.
Inches
Meters
Centimeters
Millimeters

Print Area
Enter the measurements of the drawing to be printed.

Scale
Height
Width

Center Drawing
Select this box to center the drawing on the paper.

Fit to Paper
Select this box to have the drawing fill the paper.

Panel
Choose the type of panel mark to be used to mark panels.

None
Corner
Outline Box

Mark Panel Number
Select this box to mark the panels with a corresponding number.

Number of Copies
Enter the number of copies you want printed.

Paper Size
Enter the margins for the printing area of your paper.

Top
Bottom
Left
Right

Orientation
Choose the Page Orientation for your drawing.

Portrait
LandScape

Print Selection
Select this box to print only the objects selected.

Print to File
Select this box to send the drawing to a disk rather than a printer.

Preview
Select this option to preview your drawing before it is printed.

Printer Setup
Select this option to display the Printer Setup command.

See Also:    Printing, Printer Setup



Font Cartridges

If your printer uses a font cartridge, it is important to select it; otherwise you won't have access in 
DesignCAD to all of the fonts available on your printer.



Dithering

Dithering determines how DesignCAD prints a drawing.



Point Relative command
Use the Point Relative command to set a point using relative X and Y coordinates.

Dialog box options
DX Enter the Delta X coordinate in this box.
DY Enter the Delta Y coordinate in this box.
Move cursor without setting point Choose this box to move the cursor without setting a point.

Shortcut
Keys: '

See Also:    Choosing Point Commands, Points and Command Selection



Point XY command
Use the Point XY command to set a point using X and Y coordinates.

Dialog box options
X Enter the X coordinate in this box.
Y Enter the Y coordinate in this box.
Move cursor without setting point Choose this box to move the cursor without setting a point.

Shortcut
Keys: :

See Also:    Choosing Point Commands, Points and Command Selection



Point Polar command
Use the Point Polar command to set a point using polar coordinates.

Dialog box options
Distance Enter the distance from the last point in this box.
Angle Enter the angle from the last point in this box.
Move cursor without setting point Choose this box to move the cursor without setting a point.

Shortcut
Keys: ;

See Also:    Choosing Point Commands, Points and Command Selection



Pullout command
Use the Pullout command to add information to a drawing with a pullout line.

Text
The text is entered in the Text box in the Command Line.

Dimension Line button
The arrowhead type and size can be set by choosing the Dimension Line button in the Command Line.

Dimension Text button
The text location, orientation, and size can be set by choosing the Dimension Text button in the Command
Line.

Same as
Choose the Same as button to have the balloon drawn with the same arrowhead and text size as another 
balloon in the drawing.

Shortcut
Mouse:

See Also:    Pulling Out Information in a Drawing



Quarter Circle command
Use the Quarter Circle command to draw a quarter circle, or 90 degree arc, between two points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the quarter circle as a vector entity.

Shortcuts
Mouse:
Keys: (

See Also:    Drawing Part of a Circle



Record Macro command
The Record Macro command creates a macro.    After selecting the command, type up to eight characters 
for the macro name.    Every action you perform becomes part of the macro.

The Record Options command can be selected to save certain options with the macro.

When a macro is being recorded, a small dot appears on the Status Bar at the bottom of the screen.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

Note:    Macros must be stored in the current directory that DesignCAD was installed in to appear in the 
Macro Optoins dialog box.

See Also:    Using Macros, Creating Macros, Recording Macro Options



Execute Macro command
The Execute Macro command executes a macro.    The macro name is chosen from the File Name box. A 
point is set for the "startup" cursor position.    

The macro will be performed starting at the point set for the "startup" cursor position.

When a macro is being executed, a small triangle appears on the Status Bar at the bottom of the screen.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Using Macros, Running a Macro



Stop Recording Macro command
Choose the Stop Recording Macro command after performing the steps to record a macro.

A macro is recorded with the Record Macro command.

Shortcut
Keys: &

See Also:    Using Macros



Record Options command
The Record Options command is active while the macro is being executed.    This command allows you to
save and change options within the macro.

Use this command to record options such as layer, color, line style and number of points set while 
recording a macro.

Dialog box options
Record Layer Information

Choose this box to record layer information such as layer color, layer name, and current layer with 
the macro.

Record Color Information
Choose this box to record the current color of the drawing with the macro.

Record Line Style Information
Choose this box to record the current line style and width of the lines drawn within the macro.

Record Input Information
Choose this box to record most information entered in the Command Line or the Text Block dialog 

box.    If the Record Input Information box is disabled, most information entered in the Command 
Line or Text Block dialog box will not be recorded with the macro.

If both the Record Input Information and the Record Points Set boxes are disabled, neither input or 
point information will be recorded.    When the macro is executed, DesignCAD will execute the 
commands, stopping when it reaches the input for the points.    The macro will pause until points 
are set or until Enter is pressed.    This allows interactive macros.

If the Record Points Set box is enabled and the Record Input Information box is disabled, the point 
information will be recorded and the input information will not.    When the macro is executed, 
DesignCAD will execute the commands, set the points, and wait for further information to be 
entered or Enter to be pressed.

Record Command Options
Choose this box to record all drawing options including color, line type, dimension options, and layer 

options.    However, some information entered in the Command Line or in the Text Block dialog box
is not recorded with the Macro Record Options command.

Record Points Set
Choose this box to record any points set within the macro.

See Also:    Using Macros, Recording Macro Options



Redo and Undo commands
Use the Redo command to "undo" the previous Undo command, returning the drawing to its previous 
state.    This command can only be selected after an Undo command.

Use the Undo command to "undo" the last command issued, such as a move, copy, or scale command.

Shortcut
Keys: Ctrl+Z

See Also:    Undoing and Redoing Commands



Regenerate command
Use the Regenerate command to quickly refresh the screen.

The Regenerate command is a quick way to refresh the screen and regenerate any lines that look as if 
they have been partially erased.

Shortcut
Keys: Ctrl+R

See Also:    Repairing Lines



Repeat command
The Repeat command repeats the last command completed.

Shortcut
Keys: F3

See Also:    Repeating Commands



Array command
Use the Array command to duplicate selected objects a certain number of times in a straight line, at any 
angle and offset, or in a rectangular array.

No. of copies
The number of times the objects are to be copied is entered in the No. of copies box in the Command 
Line.

No. of rows
The number of rows the objects are to be copied in is entered in the No. of rows box in the Command 
Line.

Use original as 1st copy
Select the Use original as 1st copy box in the Command Line to have the first copy drawn in the same 
location as the selected object.

Fixed handle
Use the Fixed handle box in the Command Line to have the center point remain in the same position 
when you set a point for the primary handle.

Shortcut
Mouse:

See Also:    Copying Objects in a Row



Restore command (Control menu)
Use the Restore command to return the active window to its size and position before you chose the 
Maximize or Minimize command.

Clicking the  in the upper-right corner of a maximized window is the same as choosing the Restore 
command.

Shortcut
Mouse: Double-click the title bar

See Also:    Restoring a Drawing Window to Its Former Size



Save command
Use the Save command to save the current drawing and its current name, location, and file format.    
When you save a drawing for the first time, DesignCAD displays the Save As dialog box so you can name
your drawing.    If you want to change the name, location, or format of an existing drawing before you save
it, choose the Save As command.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

Shortcuts
Mouse:
Keys: Shift+F12

See Also:    Saving Drawings, Saving a Drawing, Saving a New, Unnamed Drawing



Save As command
Use the Save As command to save the current drawing with a specified file format, or lock a file so that it 
can be read only.

Note:    To save a drawing with its existing name, format, and location, use the Save command.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

Shortcut
Keys: F12

See Also:    Saving an Existing Drawing, Saving Your Drawings



Save Color Table command
Use the Save Color Table command to save changes made to the color table to disk.

The color table is displayed when the Show Color Table option is selected.    The color table can be 
changed with the Set Color command.    The new color table can be loaded with the Load Color Table 
command.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Saving Color Table



Segment command
Use the Segment command to break a line, arc, circle, or curve entity into segments of equal length.

No. of sections
The number of segments the entity is broken into is entered in the No. of sections box in the Command 
Line.

See Also:    Segmenting Entities



Select Mode command
Use the Select Mode to select entities within the drawing.

Shortcut
Mouse:

See Also:    Selecting Objects



Select All command
Use the Select All command to select all the entities in a drawing.    You can then use other DesignCAD 
commands to edit the highlighted entities.

See Also:    Selecting Entities, Selecting All Entities



Select Previous command
Use the Select Previous command to select the last object selected.

This command is useful when selecting complicated entities.

See Also:    Selecting Entities, Selecting Last Entity



Load Selection command
Use the Load Selection command to load a drawing and select it.    Up to four points can be set for the 
lower left, lower right, upper left, and upper right corners of the drawing.    When the points are set, or 
Enter is pressed, the drawing is loaded and the entities are selected.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

Shortcut
Keys: Ctrl+F9

See Also:    Loading and Selecting Objects



Select Ortho command
Use the Select Ortho command to force a line or lines to be vertical or horizontal.    All line segments 
within 10 degrees of vertical or horizontal will be moved so that they lie exactly vertical or horizontal.

See Also:    Straightening Lines



Select Rotate command
Use the Select Rotate command to rotate selected entities.

Rotate Angle
The angle the objects are to be rotated is entered in the Rotate Angle box in the Command Line.

Rotate Stepping Angle
The rate at which the rotate angle changes is entered in the Rotate Stepping Angle box in the Command 
Line.

See Also:    Rotating Objects



Save Selection command
Use the Save Selection command to save selected objects to disk as a separate drawing.

The new drawing can be loaded later with the Open or Load Symbol commands.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Saving Selected Objects



Select Scale command
Use the Select Scale command to scale objects along the X or Y axis.    This command "stretches" objects
to make them taller, shorter, or wider.

Scale X
The amount the object is to be scaled along the X axis is entered in the Scale X box in the Command 
Line.

Scale Y
The amount the object is to be scaled along the Y axis is entered in the Scale Y box in the Command 
Line.

See Also:    Scaling Objects with Select Scale, Scaling Objects with Selection Box, Scaling Objects with 
Constant Aspect Ratio



Select Zoom command
Use the Select Zoom command to zoom, or scale, objects to be larger or smaller.

Zoom factor
The zoom factor is entered in the Zoom factor box in the Command Line.

This command does not make a new copy of the objects.    The original objects are resized.

See Also:    Zooming Selected Objects



Semi-Circle command
Use the Semi-Circle command to draw a semi-circle, or 180 degree arc, between two points.

Save as vector form
Selecting the Save as vector form box in the Command Line saves the semi-circle as a vector entity.

Shortcuts
Mouse:
Keys: )

See Also:    Drawing Part of a Circle



Show Attribute option
Use the Show Attribute option to display attributes drawn with the Attribute command.

Shortcut
Keys: Shift+Alt+A

See Also:    Displaying Attributes



Point Select Mode command
Use the Point Select Mode to display all the points making up an entity.

You can use the Point Select Mode to cut a line into two sections.

The Point Select Mode can also be used to bend a line, or add a vertex to a line entity.

Shortcut
Mouse:

See Also:    Selecting Objects



Size command (Control menu)
Use the Size command to display a four-headed arrow so you can size the active window with the arrow 
keys.

Note:    This command is not available if the window is maximized.

See Also:    Sizing a Window



Vertex

A vertex is a corner added to a line entity with the Point Select Mode.



Show Coordinate Bar option
Use the Show Coordinate Bar option to display the Coordinate Bar at the top of the screen.

Shortcut
Keys: Ctrl+Alt+B

See Also:    Showing the Coordinate Bar



Coordinate Bar
The Coordinate Bar displays the current X and Y coordinates of the cursor, the Delta X and Delta Y 
coordinates of the cursor, and the current layer of the drawing.

The Show Polar Coordinates option changes the Coordinate Bar to display polar coordinates, or the angle
and distance from the last point.

See Also:    Showing Coordinate Bar, Hiding Coordinate Bar



Delta X Coordinate

The Delta X coordinate is the horizontal distance from the cursor to the last point set.    The Delta X 
coordinate is shown in the Coordinate Bar at the top of the screen.



Delta Y Coordinate

The Delta Y coordinate is the vertical distance from the cursor to the last point set.    The Delta Y 
coordinate is shown in the Coordinate Bar at the top of the screen.



Show Info Box option
Use the Show Info Box option to display an Info Box on the screen.    The Info Box displays information on
a selected entity such as the entity type, color, area, length, and number of points.    The information 
shown in the Info Box depends on the type of entity selected.

Shortcut
Keys: Ctrl+I

See Also:    Showing Info Box



Show Snap Toolbox option
Use the Show Snap Toolbox option to display the Snap Toolbox on the screen.

Shortcut
Keys: Shift+Alt+N

See Also:    Showing Snap Toolbox



Snap Toolbox
The Snap Toolbox can be displayed on the screen to provide quick mouse access to the most-commonly 
used DesignCAD point commands.

To hide the Snap Toolbox, choose the Show Snap Toolbox option in the View menu.

See Also:    Showing the Snap Toolbox, Hiding Snap Toolbox, Changing Toolbox columns, Customizing 
DesignCAD



Show Status Bar option
Use the Show Status Bar option to display the Status Bar at the bottom of the screen.

Shortcut
Keys: Shift+Alt+B

See Also:    Showing the Status Bar



Status Bar
The Status Bar at the bottom of the screen displays command information, the current zoom factor of the 
drawing, and the number of points set.    When a macro is being recorded, a small dot appears in the 
Status Bar.    When a macro is being executed, a small triangle appears in the Status Bar.

See Also:    Showing Status Bar, Hiding Status Bar



Show Polar Coordinates option
Use the Show Polar Coordinates option to display the polar coordinates of points in the drawing in the 
Coordinate Bar.

The Options command allows you to change the format and precision of the polar coordinates displayed 
in the Coordinate Bar.

Shortcut
Keys: J

See Also:    Changing Coordinate Bar Information



Polar Coordinates

Polar coordinates are the angle and distance of a point from another point.



Show Main Toolbox option
Use the Show Main Toolbox option to display the Toolbox on the screen.

Shortcut
Keys: Shift+Alt+M

See Also:    Showing Main Toolbox



Sketch command
Use the Sketch command to draw a freehand curve following the movement of the cursor.

Shortcut
Mouse:

See Also:    Cleaning Up a Line



Smooth command
Use the Smooth command to smooth a line or curve in the drawing.    If the entity selected with this 
command is a line, it will be converted to a curve.    If the entity selected is a curve, it will be converted to 
a smoother curve.

See Also:    Smoothing Lines



Stretch command
Use the Stretch command to stretch objects.    The area to be stretched is defined by two points set in 
opposite corners.    Then a point is set for the original location of the point.    A second point is set for the 
new position of this point.    The objects contained in the area are stretched so that the first point is moved
to the new location.

See Also:    Stretching Objects, Stretching a Line



Switch To command (DesignCAD Control menu)
Use the Switch To command to display a list of all open applications.

Shortcut
Keys: Ctrl+Esc

See Also:    Switching to a Different Drawing Window



Symbol Explode command
Use the Symbol Explode command to "undefine" a symbol so that the individual entities can be 
manipulated separately.

See Also:    Manipulating Symbols



Load Symbol command
Use the Load Symbol command to load a DesignCAD symbol into the drawing.    When a symbol is 
loaded, an "insertion entity" is added to the drawing.    The symbol file (.DW2 file) must be present when 
the symbol is loaded.    If the symbol file is modified, the change will be reflected in all the drawing using 
that symbol.

Points are set for the lower left and lower right corners of the symbol.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Loading Symbols, Installing Symbols



Tangent To Circle command
Use the Tangent To Circle command to draw a line tangent from a point to a circle, ellipse, arc, or elliptical
arc.

Shortcut
Mouse:

See Also:    Drawing Tangent Lines



Tangent From Circle command
Use the Tangent From Circle command to draw a line tangent to two circles.

Shortcut
Mouse:

See Also:    Drawing Tangent Lines



Tangent Between Circles command
Use the Tangent Between Circles command to draw a line tangent to a circle, ellipse, arc, or elliptical arc 
from a point on the entity.

Shortcut
Mouse:

See Also:    Drawing Tangent Lines



Text command
Use the Text command to draw a string of text.

Text
The text is entered in the Text box in the Command Line.    Up to 80 characters can be entered.

Size
The size of the text is entered in the Size box in the Command Line.

Font
Use the Font box in the Command Line to change the font.

Angle
The angle of the text is entered in the Angle box in the Command Line.    The angle of the text is also 
determined by the location of the points set with the Text command.

Orientation
Text can be left-justified, centered, or right-justified by selecting the orientation in the Orientation box in 
the Command Line.

Bold
Choose this button to have the text drawn in bold.

Italic
Choose this button to have the text drawn in italic.

Text Block
Several lines of text can be entered by choosing the Text Block button in the Command Line.    The text is 
entered in the text window.    Pressing Enter starts a new line.    The space between the lines is set in the 
Line Spacing box.

Same as
Text can be drawn with the same options as other text in the drawing by selecting the Same as button in 
the Command Line.

After all the options are set, points are set for the lower-left and lower-right corners of the text string.

Shortcuts
Mouse:
Keys: T

See Also:    Drawing Text, Text Options, Aligning Text



Tick Marks command
Use the Tick Marks command to draw short lines, or tick marks, along a line, curve, ellipse, or circle entity.
These tick marks are spaced at equal intervals along the entity.

Sections
The number of tick marks drawn is entered in the No. of tick marks box in the Command Line.

Divisions
The number of divisions per tick mark is entered in the No. of divisions per tick mark box in the Command
Line.

Large tick mark
The size of the large tick marks is entered in Drawing Units in the Large Tick mark box in the Command 
Line.

Small tick mark
The size of the small tick marks is entered in Drawing Units in the Small Tick mark box in the Command 
Line.

Shortcut
Mouse:

See Also:    Drawing Short Line Segments



Tile Horizontal command
Use the Tile Horizontal command to tile all open windows horizontally on the screen.

See Also:    Tiling Windows



Tile Vertical command
Use the Tile Vertical command to tile all open windows vertically on the screen.

See Also:    Tiling Windows



Trim One Line command
Use the Trim One Line command to "trim" one line or arc so that its endpoint is precisely at its intersection
with another line.

Trim shorter end
Choose the Trim shorter end box in the Command Line to have the shorter end erased when the line is 
trimmed.

Shortcut
Mouse:

See Also:    Trimming Lines



Trim Two Lines command
Use the Trim Two Lines command to "trim" two non-parallel lines or arcs so they meet precisely at a 
corner.    Each line is maintained at its original angle and is extended or shortened to meet the other line.

Trim shorter end
Choose the Trim shorter end box in the Command Line to have the shorter end erased when the line is 
trimmed.

Shortcuts
Mouse:
Keys: B

See Also:    Trimming Lines



Trim Between Lines command
Use the Trim Between Lines command to "trim" a line between its intersection with two other lines.

Shortcut
Mouse:

See Also:    Trimming Lines



Trim Double Lines command
Use the Trim Double Lines command to "trim" two sets of parallel lines at their intersection.

Select trim area
Choose the Select trim area box in the Command Line to trim the lines within a specified area.

Select trim lines and area
Choose the Select trim lines and area box in the Command Line to trim certain lines within an area.

Shortcuts
Mouse:
Keys: Ctrl+B

See Also:    Trimming Lines



Undo and Redo commands
Use the Undo command to "undo" the last command issued, such as a move, copy, or scale command.

Use the Redo command to "undo" the previous Undo command, returning the drawing to its previous 
state.    This command can only be selected after an Undo command.

Shortcut
Keys: Ctrl+Z

See Also:    Undoing and Redoing Commands



Unerase command
Use the Unerase command to "unerase" the previous Erase or Erase Last command.    This command 
can be repeated to "unerase" each erased entity, as long as no other command is selected.

Shortcut
Keys: !

See Also:    Unerasing Commands, "Unerasing" Entities



Units command
Use the Units command to set the Drawing Units of a specified distance in the drawing.

Set two points for the distance to be measured.

Original
The original distance between these two points will be displayed in the Original box.

New
Type the distance these points represent in the New distance box.

Shortcut
Keys: U

See Also:    Measuring the Units



Drawing Units

Drawing Units are the units of measurement for a drawing.    These units can represent inches, 
millimeters, feet, etc.



New Window command
Use the New Window command to open a new view of the drawing.

DesignCAD allows several different windows, or views, to be opened simultaneously.    These views can 
be "zoomed" or "panned" independently.

The current view information can be saved to a file using the View Save command.    The View Read 
command can be used to read a view file from disk.

See Also:    Opening a New Window, Closing a Window



Zoom command
Use the Zoom command to temporarily change the size of the current drawing based on a "zoom factor."  
Points can be set for the "zoom origin" and "zoom destination."

Zoom factor
The zoom factor for the drawing is entered in the Zoom factor box in the Command Line.

Static Zoom
The Static Zoom button can be selected to permanently change the zoom of the drawing.

Shortcut
Keys: Z

See Also:    Zooming Entire Drawing, Zooming a Drawing



Static Zoom button
Use the Static Zoom button to permanently change the zoom of the drawing.    When Static Zoom is 
selected, the actual size and position of the drawing changes, rather than just the view of the drawing.



Zoom Factor

The "zoom factor" is the relative size the drawing is to be increased or decreased.



Zoom Origin

The zoom origin is the point into which the drawing is to be zoomed.



Zoom Destination

The zoom destination is the location to which the first point, or zoom origin, will be moved when the 
drawing is zoomed.



Zoom In command
 
Use the Zoom In command to zoom into a drawing based on one point and a zoom factor.

The zoom factor is based on the percentage defined in View Options of the Options command.

Shortcuts
Mouse:
Keys: +

See Also:    Zooming a Drawing



Zoom Window

The zoom window determines the area to be zoomed to fill the screen.    Two points are set in opposite 
corners of the area to be zoomed.



Zoom Out command
Use the Zoom Out command to zoom out of a drawing based on one point and a zoom factor.

The zoom factor is based on the percentage defined in the Options command.

Shortcuts
Mouse:
Keys: -

See Also:    Zooming a Drawing



Zoom Previous command
Use the Zoom Previous command to return the drawing to the previous configuration before the last 
zoom.

Shortcut
Keys: Ctrl+P

See Also:    Zooming a Drawing



Group

A Group is several entities defined as a single object.



Fillet Radius

The fillet radius is the radius of the arc used to "fillet" two lines with the Fillet command.



Active Drawing Window

The active drawing window is the window, or view, of the drawing containing the cursor.    DesignCAD 
commands such as pan and zoom will affect only this window.



Arrow Keys

"Arrow keys" is the collective name for the up arrow, down arrow, left arrow, and right arrow keys.    These 
keys can be used to move the cursor on the drawing screen, select commands from the Command Menu,
or select information boxes in dialog boxes.



Click

Clicking the mouse button means to point to an item on your screen and then quickly press and release 
the mouse button.    You choose entities on the screen and move around in a drawing by clicking.    
Double-clicking, pointing to an item and quickly pressing the mouse button twice, is a convenient shortcut 
for many of the tasks you will perform in DesignCAD.



Coordinate

The coordinate is the X and Y location of a point on the screen.    These X, Y, Delta X, and Delta Y 
coordinates are displayed in the Coordinate Bar at the top of the screen.



Defaults

Preset option settings such as text size, paper size, and arrowhead type set when DesignCAD is 
installed.



Dialog Box

The dialog box displays the available command options for you to review or change.



Drag

Dragging the mouse means to hold down the mouse button while moving the mouse.



Drawing Window

The drawing window is the rectangular area on your screen in which you view and work on drawings.



Application Window

An application window is a window that contains a running application.    The window displays the menus 
and provides the workspace for a drawing.    The application window shares its borders and title bar with 
drawing windows that are fully enlarged.



File

A file is a drawing that has been created, then saved under a unique filename.    In DesignCAD, all 
drawings are stored as files.



File Format

The file format refers to the format in which data is stored in a file.    DesignCAD stores drawings in .DW2 
format.



LandScape

LandScape refers to the horizontal page orientation used with the Print command.    The opposite 
orientation is "portrait," or vertical, orientation.



Macro

A Macro is a sequence of actions that is named and stored.    When you run a Macro, DesignCAD 
performs all of its assigned actions in sequence.    Macros can be assigned to keystrokes.



Measurement

A measurement is a measured distance.



Menu

A menu is a list of commands that drops down from the Command Menu bar.    The Command Menu bar 
is displayed across the top of an application window and lists menu names, such as File and Edit.



Merge

To merge means to combine one or more drawings into a single drawing with the Merge command.



Message

A message is a notice on the screen that informs you of a problem or asks for more information.    
Messages appear in the Status Line at the bottom of your screen, or in a message box.



Normal View

The normal view is the view you see when you start DesignCAD.



Showing Hot Toolbox
Choose the Hot Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Hot Toolbox, Customizing DesignCAD



Options

Options are the choices you have in a dialog box.



Path

The path is the drive, directory, and filename for a drawing.    For example, the complete path for 
DesignCAD 2-D for Windows might be C:\WDC\WDC.EXE.



Portrait

Portrait refers to the vertical page orientation chosen with the Print command.    The opposite of portrait is 
"landscape," or horizontal, orientation.



Printer Driver (File)

The printer driver is a file for each of the printers supported by DesignCAD.    The file includes codes for 
controlling the printer, a list of the fonts available on the printer, and the dimensions of the characters in 
each font.    These files have the extension .PRD.    You select a printer driver with the Print Setup 
command in the File menu.



Read-Only

Read-only refers to a drawing attribute that allows you to view, but not make changes to, a drawing using 
the same filename.    In DesignCAD, you can designate that a drawing be read-only when you open it to 
prevent accidental changes.



Scale

The scale, or height and width of an object can be changed with DesignCAD.



Units

The units of a drawing are the distance one Drawing Unit represents.



X Coordinate

The X coordinate is the location of the cursor on the X, or horizontal, grid.    The X coordinate is displayed 
in the Coordinate Bar at the top of the screen.



Y Coordinate

The Y coordinate is the location of the cursor on the Y, or vertical, grid.    The Y coordinate is displayed in 
the Coordinate Bar at the top of the screen.



Filename

The filename includes the name and extension of a drawing.    A filename can contain up to eight 
characters.    A filename extension includes three characters.



Graphics Tablet

A graphics tablet, or digitizer, is used to move the cursor, set points, and enter commands.    With a 
graphics tablet, you can "trace" a drawing from paper onto the screen.



Hot Toolbox
A Hot Toolbox can be created in DesignCAD to contain those commands that you use most often.

See Also:    Showing Hot Toolbox, Hiding Hot Toolbox, Changing Toolbox columns, Customizing 
DesignCAD



Rubber Band Line

A rubber band line is drawn while commands are being set with some DesignCAD commands to show 
how the completed line, arc, circle, or arc will be drawn.



TrueType Fonts

TrueType fonts are used in DesignCAD to eliminate the rough edges printed with some fonts.    With 
TrueType fonts, the printer output more closely resembles the fonts shown on the screen.



AUTOEXEC Macro

The AUTOEXEC Macro can be created to run at the beginning of each DesignCAD session.    This Macro 
can be used to perform tasks necessary for your specific application.



Endpoint

An endpoint is a point at the end of a line to designate the end of the line.    This endpoint can be moved 
with DesignCAD commands.    Pressing the Ctrl and Shift keys allows you to delete an endpoint in Point 
Select Mode.



Entity

An entity is the combination of lines used to create an object in DesignCAD.    A single entity can be drawn
with one line or several lines.    An entity can be copied, scaled, or saved with DesignCAD commands.



Highlighting Box

The highlighting box is the highlighted lines and select nodes that appear when an object is selected with 
the Select command.



Highlighting Nodes

The highlighting nodes, or select nodes, are small highlighted squares used to mark the corners of an 
object selected with the Select command.



Select Node

The select nodes, or highlighting nodes, are small highlighted squares used to mark the corners of an 
object selected with the Select command.



Nodes

A node is a small highlighted square used to mark the edges of the highlighting box drawn should be 
shown when an object is selected with the Select command.



Parts List

A parts list is a list of all the attributes in a drawing.    This list is compiled by the Material List command.



Selection Box

The selection box is the highlighted lines and select nodes that appear when an object is selected with 
the Select command.



Extension Line

The extension line is the part of the dimension that extends from the point to be dimensioned to the 
arrowheads of the dimension.

See Also:    Dimension Options, Changing Dimension Options



Extension Line Overshoot

The extension line overshoot is the distance the extension line extends past the dimension line.

See Also:    Dimension Options, Changing Dimension Options



Overshoot

The overshoot is the distance the extension line extends, or "overshoots," past the dimension line.



Precision

The precision of a dimension determines the numeric value that the dimension will be accurate to.    For 
example, you can have the dimension precision set at .0001 Drawing Units, or 100 Drawing Units.



Prefix

The dimension prefix is the characters drawn before the dimension text.



Suffix

The dimension suffix is the characters drawn after the dimension text.



Terminator

The terminator is the arrowhead drawn at the end of the line drawn with the Arrow or Dimension 
commands.    There are 12 arrowhead types.



Tolerance

The dimension tolerance is the amount of variation from the accuracy.    These numbers can be displayed 
as positive or negative values.



Layer

A layer is a subdivision of a DesignCAD drawing.    A DesignCAD drawing can have up to 256 layers.    
Dividing a drawing into layers allows you to plot or print only certain layers.    You can save individual 
layers as separate drawings, delete entire layers, move the objects in one layer to another layer, or 
change the color, line type, or line width of the objects in a particular layer.



Symbol

A symbol is an independent DesignCAD drawing, or commonly-used figure.    To create a symbol, simply 
draw it and save it.

You can also load a pre-drawn DesignCAD symbol with the Load Symbol command.



Insertion Entity

An "insertion entity" to the drawing file is added to a drawing when a symbol is loaded with the Symbol 
Load command.    The symbol file must be present when the symbol is loaded.    If the symbol file is 
modified, the change will be reflected in all the drawings using that symbol.



Section

A section is a part of the drawing contained in a rectangle defined by dragging the cursor.    The defined 
section is then used with other drawing commands.



Intensity

Intensity refers to the lightness or darkness of a drawing printed with the Print command.



Tick Mark

A tick mark is a small line drawn with the Tick Marks command.



Application Control-menu

The Application Control-menu, in the upper-left corner of the DesignCAD screen displays a menu with 
commands for sizing and moving the DesignCAD window, switching to other applications, and closing 
DesignCAD.



Control-Menu
A menu that includes commands with which you can control the size and position of the DesignCAD 
window and switch to another application.

Shortcut
Keys: Alt+Space bar



Attributes

An attribute is information assigned to an entity in a drawing.    These attributes can be shown or hidden 
on the screen.

The Material List command compiles all of the attributes in a drawing into a parts list.



Copy command
Use the Copy command to copy selected text or objects onto the Clipboard.    This command is 
unavailable if you have no selected text or objects.

Copying text or objects to the Clipboard replaces the contents previously stored there.

Shortcuts
Mouse:
Keys: Ctrl+C

See Also:    Copying Objects



Clipboard

The Clipboard is a temporary storage area for cut or copied text or graphic objects.    You can paste the 
contents of the Clipboard into any DesignCAD drawing or into a file of another application.    The 
Clipboard holds the information until you cut or copy another piece of text or a graphic.



Cut command
Use the Cut command to remove selected text or objects from a drawing and put it on the Clipboard.    
This command is unavailable if you have no selected text or objects.

Cutting text or objects to the Clipboard replaces the contents previously stored there.

Shortcuts
Mouse:
Keys: Ctrl+X

See Also:    Cutting Objects



Paste command
Use the Paste command to insert a copy of the Clipboard contents into the drawing.    This command is 
unavailable if the Clipboard is empty.

Shortcuts
Mouse:
Keys: Ctrl+V

See Also:    Pasting Objects



Import IGES command
Use the Import IGES command to import a drawing in IGES drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Import HPGL command
Use the Import HPGL command to import a drawing in HPGL drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Import Text command
Use the Import Text command to import a drawing in Text drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Import XY command
Use the Import XY command to import a drawing in XY drawing file format.

Dialog box options
Straight line
Choose the Straight line button to have a straight line drawn between the X and Y coordinate points.
Curved line

Choose the Curved line button to have a curved line drawn between the X and Y coordinate points.
Small squares

Choose the Small squares button to have a small square drawn at each X and Y coordinate location.
Small circles

Choose the Small circles button to have a small circle drawn at each X and Y coordinate location.
Mark size

If the Small squares or Small circles buttons are chosen, enter the size of the squares or circles in 
the Mark size box.

Color
Choose the Color box to determine the color of the entities.

See Also:    Exporting Drawings, Converting Files



Export IGES command
Use the Export IGES command to export a drawing in IGES drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Export WordPerfect command
Use the Export WordPerfect command to export a drawing in WordPerfect drawing file format.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Exporting Drawings, Converting Files



Show Color Table option
Use the Show Color Table option to display the color table and set the color to be used for subsequent 
lines or entities drawn in the drawing.    The color table in the Toolbox displays the current drawing color.

Dialog box options
Same as

Use the Same as button to have the current color reflect the same color as an entity in the drawing.   
First select the command, then choose the color in the color table.    Then, choose the Same as 
button in the color table.

Apply button
To have an entity drawn in a different color select the Apply button.

The color table can be edited with the Set Color command.    The new color table can be saved with the 
Save Color Table command.    A new color table can be loaded with the Load Color Table command.

Shortcut
Mouse:
Keys: H

See Also:    Setting Drawing Color, Changing Colors, Changing Entity Color



Show Line Style Box option
Use the Show Line Style Box option to display the line type box.

Dialog box options
Line type

The line type is chosen from the Line type box.    There are 13 line types available with DesignCAD.
Scale

The Scale of the line is entered in the Scale box in the Line Type box.
Width

The Width of the line is entered in the Width box in the Line Type box.
Fill Wide Line

Choose the Fill Wide Line box to have lines with a width greater then 0.00 filled.
Apply button

Use the Apply button to change the line type, scale, or width of an entity in the drawing.
Same as

Use the Same as button to have the line drawn with the same type, scale, or width of an entity in the 
drawing.

Shortcuts
Mouse:
Keys: /

See Also:    Line Types, Changing Line Characteristics



Text Options command
Use the Text Options command to display the options for text.

This command changes the font, style, size, angle, and spacing for text.    You can also display attributes 
using this command.

Dialog box options
Font

Use the Font box to choose the font for text in the drawing.    The fonts available depend on the fonts
installed with your printer.

Font Style
Use the Font Style box to determine the style of the text.    The font style can be either normal, italic, 

bold, or bold italic.
Size

Enter the size for the text in the Size box.
Angle

Enter the angle for the text in the Angle box.
Spacing

Enter the spacing between lines for the Text Block dialog box in the Spacing box.
Display Attribute

Choose the Display Attribute box to have attributes created with the Attribute command displayed in 
the drawing.

Save Options
Choose the Save Options box to save the text options to the DCW.INI file.

Sample
The Sample box shows an example of the new font and style.

OK
Choose the OK button to use the new text options.

Cancel
Choose the Cancel button to return to the drawing without changing the text options.

Shortcut
Keys: F7

See Also:    Text Options, Changing Text Options



Set Handles command
Use the Set Handles command to set handles for a drawing before saving it.    One or two points can be 
set for the lower left and lower right corners of the drawing.    If no points are set with this command, the 
drawing handles default to the lower left and lower right corners of the screen.

See Also:    Setting Drawing Handles



DOS Keystrokes option
Use the DOS Keystrokes option to use the keystrokes associated with DesignCAD for DOS.    This 
command helps you to learn the DesignCAD drawing commands if you are familiar with DOS or are not 
familiar with Windows.

See Also:    Using DOS Keystrokes, DOS Keystroke Commands



How to Use Help command
Use the How to Use Help command to get more information on how to use the Help Index command.    
The How to Use Help command explains how to choose a Help topic, use commands and buttons, jump 
from topic to topic, copy and print Help topics.

See Also:    Finding Information in Help, Help Instructions



About DesignCAD command
Use the About DesignCAD command to display the version number of your copy of DesignCAD for 
Windows, the copyright notice, installed math coprocessors, and the available disk space and memory.

See Also:    Finding Information on DesignCAD



Parts of DesignCAD Screen
Command Line
Command Menu bar
Coordinate Bar
Rulers
Drawing Area
Main Toolbox
Maximize button
Minimize button
Restore button
Scroll bars
Snap Toolbox
Status Bar
Title Bar
Window Control-menu



Rulers
The vertical and horizontal rulers help you align entities and keep track of where you are in the drawing.

See Also:    Showing Rulers, Hiding Rulers



Maximize Button
The Maximize button is located at the right end of the title bar in the application and drawing windows 
when they are not fully enlarged.

When you click the maximize button, the following occurs:

The application window enlarges to fill the screen.
A drawing window enlarges to fill the DesignCAD window.

Note:    Maximized windows have no borders.

See Also:    Maximize command, Maximizing Windows



Minimize Button
The Minimize button is located at the right end of the title bar in an application window.

Clicking the Minimize button is the same as choosing Minimize from the application Control-menu.    The 
application window shrinks to an icon.

See Also:    Minimize command, Minimizing Windows



Title Bar
The Title Bar is located along the top of a window and contains the name of the application and drawing.

To move the window, drag the title bar.

Note:    You can also move dialog boxes by dragging their title bars.

A title bar may contain the following elements:

Application Control-menu button
Drawing Control-menu button
Maximize button
Minimize button
Name of the application
Name of the drawing
Restore button



Restore Button
The Restore button is located at the right end of the title bar in a maximized application window.

Clicking the Restore button is the same as choosing Restore from the application Control-menu:    The 
application window returns to its previous size.

See Also:    Restore command, Restoring a Drawing Window to Its Former Size



Window Control-Menu
The window Control-menu is located at the left end of the title bar in an application window.

To display commands that control the size and position of an application window, click the application 
Control-menu box or press Alt+Space bar.

The window Control-menu contains these commands:

Restore command
Move command
Size command
Minimize command
Maximize command
Close command
Next command



Command Menu Bar
The Command Menu bar is located below the title bar, along the top of the application window, and 
contains    DesignCAD commands.

To view all the commands in a menu, do one of the following:

Click the menu name.
-or-

Press Alt and the underlined letter of the menu name.

See Also:    Choosing Commands, Using Menus



Command Line
The Command Line is located below the Command Menu bar, at the top of the drawing screen.    Before a
command is selected, or when a command that does not require any information to be input, the 
Command Line contains icons for file management commands such as Open, Save, Print, Copy, Cut, and
Paste.    The Command Line also contains any user-defined macro buttons.

When a command is selected, the Command Line allows you to enter text, and other options for each 
command.    For example, when the Text command is selected the following information is displayed in the
Command Line:

The Text is entered in the Text box.    The font can be changed in the Font box.    The size and angle of the
text can be changed in the Size and Angle boxes.    The orientation, left, right, or centered, is entered in 
the Orientation box.    Text can be drawn in bold or italic font by choosing the Bold and Italic buttons.    Text
can be drawn in a block by choosing the Text Block command.    Text can be drawn with the same options 
as other text in the drawing by choosing the Same As button and setting a point on the text in the drawing.

See Also:    Parts of the DesignCAD Screen



Scroll Bars
The Scroll bars are displayed at the right and bottom edges of the drawing window.    The scroll boxes 
inside the scroll bars indicate your vertical and horizontal location in a drawing.    You can use the mouse 
to scroll to other parts of the drawing.

Vertical bar scroll
Item Mouse action

Click to scroll up one unit.
Drag to move to an approximate location in the drawing.

Click to scroll down one unit.

Horizontal scroll bar
Use the horizontal scroll bar to move left and right, just as you use the vertical scroll bar to move up and 
down.

See Also:    Parts of the DesignCAD Screen



Drawing Area
The Drawing Area is the area in which the entities appear in your drawing.    The scroll bars can be used 
to move the drawing inside the drawing area.

Use the rulers at the top and left of the drawing area to position the cursor within the drawing area.

See Also:    Scroll Bars, Rulers



Alphabetic Listing
-A-

Aligning text
Angle dimension
Arranging icons
Arranging views

-B-
Bending lines
Bold text
Breaking a line

-C-
Canceling a menu
Canceling a command
Cascading windows
Centered text
Chamfering lines
Changing text font
Changing entity color
Changing text options
Changing Toolbox columns
Choosing commands
Cleaning up a line
Clearing the screen
Clicking the mouse
Closing a drawing
Closing a view
Combining drawings
Combining lines
Command Menu bar
Commands
Converting curves
Converting drawings
Converting lines
Copying objects
Copying objects with handles
Creating drawings
Creating Hot Toolbox
Customizing the color table
Customizing DesignCAD
Customizing Toolbox columns
Cutting lines

-D-

Definitions of terms
Deleting entities
Deleting a layer
Deleting points
Dimension basics
Dimension options
Drawing angle dimensions



Dimensioning arcs
Dimensioning circles
Dimensioning lines
Dragging the mouse

-E-

Editing drawings
Editing entities
Editing layers
Editing lines
Editing tools
Erasing an entity
Erasing the screen
Error message
Exiting DesignCAD
Extending lines
File formats
Filleting lines
Filling wide lines

-G-

Getting color table

-H-

Help Instructions
Hiding Coordinate Bar
Hiding Info Box
Hiding Main Toolbox
Hiding Rulers
Hiding Snap Toolbox
Hiding Status Bar
Hiding Symbol Toolbox

-I-

Inserting an entity
Intersecting lines
Italic text

-J-

Joining lines

-L-

LandScape page orientation
Left-justified text
Loading a color table
Loading objects
Loading files
Loading symbols

-M-



Marking points
Maximizing drawings
Maximizing windows
Menus
Merging drawings
Minimizing windows
Mirroring objects
Mouse shortcuts
Moving objects
Moving objects with handles
Moving windows

-N-

Naming drawings
New drawings

-O-

Opening a file created by another application
Opening drawings
Opening views

-P-

Page orientation
Page size
Panning drawings
Portrait page orientation
Printing
Plotting drawings

-R-

Redoing commands
Regenerating the screen
Repairing lines
Repeating commands
Retrieving files
Right-justified text
Rotating objects

-S-

Saving color table
Saving drawings
Saving Layers
Scroll bars
Segmenting entities
Selecting commands
Selecting entities
Selecting Layers
Setting cursor step size
Setting points



Setting the snap grid
Setup
Shortcut Keys
Shortening lines
Showing Coordinate Bar
Showing Info Box
Showing Main Toolbox
Showing Rulers
Showing Snap Toolbox
Showing Status Bar
Showing Symbol Toolbox
Smoothing lines
Starting DesignCAD
Straightening lines
Stretching objects
Stretching a line
Switching windows

-T-

Text alignment
Text options
Tiling windows
Toolbox
Trimming lines

-U-

Undoing an action
Undoing commands
Unerasing commands
Units of measurement
Unselecting entities
Using menus
Using symbols
Using the mouse

-V-

Viewing drawings

-W-

Windows

-Z-

Zooming a drawing



Aligning Text
Left-aligning text

After the Text command is selected, choose the Left alignment option in the Orientation box in the 
Command Line.

Set a point for the lower left corner of the text.
Set a point for the lower right corner of the text.

Centering text
After the Text command is selected, choose the Center alignment option in the Orientation box in the 

Command Line.
Set a point for the center of the text.
Set a point for the lower right corner of the text.

Right-aligning text
After the Text command is selected, choose the Right alignment option in the Orientation box in the 

Command Line.
Set a point for the lower right corner of the text.
Set a point for the lower left corner of the text.

See Also:    Text Options command, Centered Text, Left-justified Text, Right-justified Text, Text Alignment, 
Text Options, Changing Text Options.



Angle Dimension
Drawing dimensions aligned to any angle

Choose the Dimension command.
Choose the Align to any angle button in the Command Line.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

Drawing angled dimensions without extension lines
Choose the Dimension Distance Only command.
Choose the Align to any angle button in the Command Line.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

Drawing angle dimensions
Choose the Dimension Angle command.
Set a point for the center, or vertex, of the angle to be measured.
Set a point for the beginning of the angle to be dimensioned.
Set a point for the end of the angle to be measured.
Set a point for the location of the text information.

See Also:    Angular Text Format, Angular Text Precision, Dimension Angle command, Dimension 
command, Dimension Distance Only command, Dimension Basics, Dimension Options, Drawing Angle 
Dimensions



Arranging Icons
Different views of the drawing window become icons when they are minimized.    You can move these 
icons around the screen.

Arranging Icons
Choose the Arrange Icons command from the Window menu.

See Also:    Arrange Icons command, Minimize command, Maximize command, Maximizing Windows, 
Minimizing Windows



Arranging Views
Cascading windows

Choose the Cascade command from the Window menu.

Tiling windows
Choose the Tile Horizontal command from the Window menu.

-or-
Choose the Tile Vertical command from the Window menu.

See Also:    Cascade command, Tile Horizontal command, Tile Vertical command, Cascading Windows, 
Minimize command, Maximize command, Maximizing Windows, Minimizing Windows



Bending Lines
Activate the Point Select Mode.
Select the line to be bent.
Move the pointer to point to the place in the line that is to be bent.
Set a point.
Move the pointer to the new corner, or vertex, of that line.
Set a point for the new corner of the entity.

See Also:    Editing Lines, Moving Points



Bold Text
Normal text

Bold text

Changing text style with command
After the Text command is selected, choose the Bold button in the Command Line.

Changing text style with Text Options
Choose the Text Options command from the Options menu.
Choose the Bold in the Font Style box.
Choose the OK button.

Text can be changed to bold after it is drawn with the Show Info Box option.

Changing style of selected text
Select the text to be changed.
Choose the Show Info Box option.
Choose the Bold button.

See Also:    Text Options, Changing Text Options, Text Options command



Breaking a Line
Select the line to be broken.
Choose the Break Line command.

See Also:    Break Line command, Editing Lines



Canceling a Command
Cancel button
Choosing the Cancel button discards the options you have selected, closes the dialog box, and returns 
you to your drawing.    When DesignCAD completes an action that cannot be canceled, the Cancel button 
changes to the Close button.

See Also:    Undoing an Action



Cascading Windows
The Cascade command organizes your open windows by lining them up on the screen so that all the title 
bars show.

Choose the Cascade command from the Window menu.

See Also:    Cascade command, Arranging Windows and Icons, Moving Windows, Opening Views, Tiling 
Windows, Manipulating the Views, Windows



Centered Text
After the Text command is selected, choose the Center alignment option in the Orientation box in the 

Command Line.
Set a point for the center of the text.
Set a point for the lower right corner of the text.

See Also:    Aligning Text, Text Alignment, Text Options command, Changing Text Options, Text Options



Chamfering Lines
Choose the Chamfer command.
Type the chamfer depth in the Chamfer depth box in the Command Line.
To keep the original line after the chamfer has been cut, choose the Keep original lines box.
Set a point on the first line to be chamfered.
Set a point on the second line.

See Also:    Chamfer command, Editing Lines



Changing Toolbox Columns
You can change the number of columns in a toolbox, using the Options command in DesignCAD.

Changing Main Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Main Toolbox.

Changing Snap Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Snap Toolbox.

Changing Hot Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Hot Toolbox.

See Also:    Options command, Customizing Toolbox Columns



Cleaning up a Line
Select the line to be smoothed.
Choose the Smooth command.

See Also:    Smooth command, Smoothing Lines



Clearing the Screen
Choose the New command from the File menu.
When asked if you want to save the drawing, choose the Yes button to save the drawing.
Choose the No button to clear the screen without saving the drawing.

See Also:    New command, Erasing the Screen, Closing a Drawing



Clicking the Mouse
Pointing to an item on your screen and then quickly pressing and releasing the mouse button is called 
clicking.    You choose entities on the screen and move around in a drawing by clicking.    Double-clicking, 
pointing to an item and quickly pressing the mouse button twice, is a convenient shortcut for many of the 
tasks you will perform in DesignCAD.

See Also:    Mouse Techniques, Using the Mouse



Closing a View
Double-click the drawing Control-menu box in the upper-left corner of the drawing window.

-or-
Press Ctrl+F4 to choose the Close command.

See Also:    Control-menu Close command



Changing Entity Color
Select the entity to be changed.
Choose the Show Color Table option.
Choose the color.
Choose the Apply button.

Setting color same as an entity
Choose the Show Color Table option.
Choose the Same as box.
Select the entity with the color you want.
Select the entity to be changed.
Choose the Apply button.

Changing current color of selected object
Select the object to be changed.
Choose the Show Info Box option.
Choose the Color button.
Choose the color.

See Also:    Show Color Table option, Show Info Box option



Combining Drawings
DesignCAD allows you to merge more than one drawing into a single drawing.    DesignCAD opens the 
first drawing, then merges the second drawing on top of it.    The Drawing Units of the second drawing are
matched to those of the drawing already on the screen.

Merging a drawing
Choose the Merge command from the File menu.
Choose the file you want to merge with the current drawing from the File Name box.
Set a point for the lower left corner of the drawing.
Set a point for the lower right corner of the drawing.
Set a point for the upper left corner of the drawing.
Set a point for the upper right corner of the drawing.

See Also:    Merge command



Combining Lines
Activate the Select Mode.
Select the first line.
Press Shift and set a point on the next line.
Choose the Combine command from the Edit menu.

See Also:    Combine command, Editing Lines



Converting Curves
Select the curve to be changed.
Choose the Curve To Line command.

See Also:    Curve To Line command, Converting Lines



Converting Drawings
DesignCAD allows you to convert, or transfer, drawing files to and from other programs. A file saved in a 
drawing application usually includes formatting codes not recognized by other applications.

DesignCAD allows you to import drawings from other drawing file formats into DesignCAD.

Importing DXF file formats
Choose Import DXF from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing IGES file formats
Choose Import IGES from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing HPGL file formats
Choose Import HPGL from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing Text file formats
Choose Import Text from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing XY file formats
Choose Import XY from the File menu.
Choose the file from the File Name box.
Choose the OK button.

DesignCAD allows you to export drawings from other drawing file formats into DesignCAD.

Exporting DXF file formats
Display the drawing you want to export on the screen.
Choose Export DXF from the File menu.

Exporting IGES file formats
Display the drawing you want to export on the screen.
Choose Export IGES from the File menu.

Exporting WordPerfect file formats
Display the drawing you want to export on the screen.
Choose Export WordPerfect from the File menu.

See Also:    Compatible File Formats



Converting Lines
Converting a curve

Select the curve to be changed.
Choose the Curve To Line command.

Curving a line
Select the line to be changed.
Choose the Line To Curve command.

See Also:    Curve To Line command, Line To Curve command



Copying Objects
Activate the Select Mode.
Select the object to be copied.
Move the pointer to the area inside the selection box.
Press Ctrl and set a point.
Move the selection box to the new location.
Set a point.

See Also:  Copy command, Copying Objects with Handles, Mirroring Objects



Copying Objects with Handles
Copying an object to an exact location

Activate the Select Mode.
Select the object to be copied.
Press Ctrl and click the left mouse button inside the selection box.
Set a point for the handle.
Set a point for the new location of the handle.

-or-
Press Alt+Ins to activate the selection box.
Use the arrow keys to move the cursor until the selection box surrounds the object.
Press Ins.
Move the pointer inside the selection box.
Press Ins.
Move the cursor to the point for the handle.
Set a point.
Move the cursor to the new location of the handle.
Set a point.

Copying several objects to an exact location
Activate the Select Mode.
Select the first object.
Press Shift while selecting other objects.
Press Ctrl and click the left mouse button inside the selection box.
Set a point for the handle of the objects.
Set a point for the new location of the handle.

-or-
Press Shift+Ins to set a point on the other object.
Move the cursor inside the selection box.
Press Ins.
Move the pointer inside the selection box.
Press Ins.
Set a point for the handle of the objects.
Set a point for the new location of the handle.

See Also:    Copying Objects



Creating Hot Toolbox
Choose the Show Hot Toolbox option from the View menu.
Choose a command from the Main Toolbox.
Press and hold down the left mouse button.
Drag the icon to the Hot Toolbox.
Release the mouse button.

-or-
Choose the Options command.
Choose the Toolbox category.
Choose the icon in the Available Tools box.
Choose the Add button.
Choose the OK button.

Removing icon from Hot Toolbox
Choose the Options command.
Choose the Toolbox category.
Choose the icon in the Current Content box.
Choose the Delete button.
Choose the OK button.

Closing a Toolbox
Choose the Toolbox Control-menu box in the upper left corner of the Toolbox.

See Also:    Hot Toolbox, Changing Toolbox Columns, Customizing Toolbox Columns



Customizing the Color Table
The colors in the color table can be changed to meet your specifications.

Choose the Set Color command from the Options menu.
Move the sliding box or click the arrows to change the red, green, and blue color values.
Choose the OK button.

Saving the Color Table
Customize the color table with the Set Color command.
Choose the Save Color Table command from the Options menu.
Type a name for the color table in the File Name box.
Choose the OK button.

See Also:    Set Color command, Save Color Table command



Customizing DesignCAD
 
DesignCAD allows you to determine how the screen looks by moving, changing, and deleting items such 
as the color table, Toolboxes, Command Line, Status Bar, and Coordinate Bar.

DesignCAD also lets you create your own commands by writing macros and using the BasicCAD 
programming language.

Customizing the Screen
Customizing the Color Table
Creating Hot Toolbox
Creating Symbol Toolbox
Showing and Hiding Information
Customizing Toolbox Columns

Using Macros
Creating Macros
Running a Macro

Using BasicCAD
Running BasicCAD Programs



Customizing Toolbox Columns
You can change the number of columns in a toolbox in DesignCAD.

Changing Main Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Main Toolbox.
Choose the OK button.

Changing Snap Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Snap Toolbox.
Choose the OK button.

Changing Hot Toolbox columns
Choose the Options command from the Options menu.
Choose the Toolbox category.
Type the new number of columns for the Hot Toolbox.
Choose the OK button.

See Also:    Options command



Cutting Lines
Activate the Point Select Mode.
Select the entity to be cut.
Press the Ctrl key and move the pointer near the line until the scissors appear.
Press the Ctrl key and set a point.

See Also:    Editing Lines



Deleting Objects
Select the entity to be erased.
Choose the Erase command from the Edit menu.

Erasing several entities
Activate the Select Mode.
Select the first entity.
Press Shift while selecting each entity.
Choose the Erase command from the Edit menu.

Deleting last entity drawn
Choose the Erase Last command from the Edit menu.

See Also:    Erase command, Erase Last command, Editing Entities, Using the Clipboard



Deleting a Layer
Choose the layer to be deleted in the Layer box in the Coordinate Bar.
Choose the Delete Layer command in the Options menu.

See Also:    Delete Layer command, Editing Layers



Deleting Points
Select the entity to be changed.
Press Ctrl+Shift while setting point on point to be deleted.

-or-
Activate the Point Select Mode.
Select the entity to be changed.
Set two points on the point to be deleted.

See Also:    Moving Points, Editing Lines



Dimension Basics
There are several options and characteristics that must be understood when using the dimension 
commands.

Understanding Dimension Basics
Dimension options



Dimension Options
When the Dimension command is selected, several dimension options are shown in the Command Line.   
These options can be changed for each dimension.

Dimension Line button
Position of Dimension Arrows
Dimension Offset
Dimension Arrowhead Type
Dimension Arrowhead Size

Extension Line button
Overshoot Length
Fixed Length
Variable length

Dimension Text button
Linear Text Format
Angular Text Format
Linear Text Precision
Angular Text Precision
Dimension Text Location
Dimension Text Orientation
Dimension Text Size

Dimension Prefix, Suffix button
Dimension Prefix
Dimension Suffix

Dimension Tolerance button
Positive or Negative Dimension Tolerance
Positive and Negative Dimension Tolerance
No Dimension Tolerance
Dimension Tolerance Size

Saving a Vector Dimension



Dragging the Mouse
DesignCAD allow you to "drag" the mouse to choose entities on the screen.    To do this, hold down the 
left mouse button and move the mouse so that the rubber band box on the screen encloses the entities to
be selected.    Once all the entities are enclosed within the rubber band box let go of the left mouse 
button.

See Also:    Mouse Techniques, Using the Mouse



Editing Drawings
Editing Entities
Editing Lines
Erasing an Entity
Deleting Entities
Segmenting Entities
Stretching Objects



Editing Entities
Combining Lines



Editing Lines
Bending Lines
Breaking Lines
Chamfering Lines
Combining Lines
Cutting Lines
Deleting Points
Extending Lines
Filleting Lines
Joining Lines
Moving Points
Shortening Lines
Smoothing Lines
Straightening Lines
Stretching a Line
Trimming Lines



Editing Tools
Erasing an Entity
Regenerating the Screen
Undoing and Redoing Commands
"Unerasing" Objects
Using the Clipboard



Erasing an Entity
Select the entity to be erased.
Choose the Erase command from the Edit menu.

-or-
Select the entity to be erased.
Press Delete key.

Erasing several entities
Choose the first entity.
Press Shift while selecting each entity.
Choose the Erase command from the Edit menu.

-or-
Choose the first entity.
Press Shift while selecting each entity.
Press Delete key.

Deleting last entity drawn
Choose the Erase Last command from the Edit menu.

See Also:    Erase command, Erase Last command, Deleting Entities



Error Message
If you try to choose a command without meeting certain guidelines, such as selecting entities, an error 
message will appear in the center of the screen.

Removing an error message
Choose the OK button.

-or-
Press Enter.

See Also:    Error Messages



Exiting DesignCAD
If you have made changes to a drawing since you last saved, DesignCAD asks whether or not you want 
to save the changes before quitting, even if you close Windows without closing DesignCAD first.

Exiting DesignCAD
Choose the Exit command from the File menu.

Shortcut
Mouse: Double-click the application Control-menu button
Keys: Alt+F4

See Also:    Exit command



Extending Lines
Select the line to be extended.
Choose the Extend command from the Edit menu.
Set a point on the endpoint to be extended.
Move the pointer to the new location for the endpoint.
Set a point for the new endpoint.

-or-
Activate the Point Select Mode.
Press Shift key and select the endpoint.
Move mouse in desired direction.
Set a point for the new endpoint.

See Also:    Extend command, Editing Lines



File Formats
ASCII Text Files
AutoCAD DXF Files
DesignCAD 2-D ASCII Files
DesignCAD 2-D Binary Files
DesignCAD 3-D ASCII Files
DesignCAD 3-D Binary Files
Hewlett Packard Plotter (HPGL) Files
IGES (Initial Graphics Exchange Standard) Files
WordPerfect Files
X, Y Coordinate Files



Opening a File Created by Another Application
In DesignCAD, you can open files created with different applications.

DesignCAD imports these file formats:
Hewlett Packard Plotter (HPGL) Files
ASCII Text Files
X, Y Coordinate Files
AutoCAD DXF Files
IGES (Initial Graphics Exchange Standard) Files

To open a file created by another application
Choose one of the Import commands from the File menu.

See Also:    Importing Drawings, Exporting Drawings



Filleting Lines
Choose the Fillet command.
Type the fillet radius in the Fillet radius box in the Command Line.
To keep the original line after the fillet has been cut, click the Keep original lines box.
To have the fillet cut with the same radius as another fillet in the drawing, choose the Same as button.   

Then set a point on the fillet in the drawing.
Set a point on the first line to be filleted.
Set a point on the second line.

See Also:    Fillet command, Editing Lines



Changing Text Font
A font is a collection of type faces or styles used to give your text a particular look.    Your choice of fonts 
depends on the printer fonts you have installed.

To change the text font
Choose the Text Options command in the Options menu.
In the Font box, the font type.
Choose the OK button.

Changing current font of selected entity
Select the entity to be changed.
Choose the Show Info Box option.
Choose the Font button.
Choose the font.

See Also:    Text Options command, Show Info Box option, Text Options, Changing Text Options



Help Instructions
You can find information in Help by using the index or Search feature.    To return to the Help Index after 
you read the instructions below, click the Back button or press B.

For complete instructions on how to use Help, press F1 while the Help window is active.

To use the Help Index
Choose an underlined topic.

To scroll in the Help window
Move the scroll bars with a mouse.

-or-
Press the up or down arrow keys.

To return to the previous topic
Choose the Back button.

To open the Search feature in Help
Choose the Search button.

To close the Help window
Choose the Exit command from the Help File menu.

See Also:    Help Index command



Hiding Coordinate Bar
Choose the Coordinate Bar option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Coordinate Bar, Customizing DesignCAD



Hiding Info Box
Choose the Info Box option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Info Box, Customizing DesignCAD



Hiding Main Toolbox
Choose the Main Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Main Toolbox, Customizing DesignCAD



Hiding Snap Toolbox
Choose the Snap Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Snap Toolbox, Customizing DesignCAD



Hiding Status Bar
Choose the Status Bar option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Status Bar, Customizing DesignCAD



Inserting an Entity
Choose the Load Symbol command from the File menu.
Choose the symbol name from the File Name box.
Choose the OK button.
Set a point for the lower left corner of the symbol.
Set a point for the lower right corner of the symbol.

See Also:    Merge command, Load Symbol command, Load Selection command, Loading Objects, 
Loading Symbols



Intersecting Lines
Choose the Intersect-1 command.
Set a point on one of the lines.

Choose the Intersect-2 command.
Set a point on one of the lines.
Set a point on the intersecting line.

Snapping to intersection without setting a point
Choose the Intersect-1 Move command.
Set a point on one of the lines.

Choose the Intersect-2 Move command.
Set a point on one of the lines.
Set a point on the intersecting line.

See Also:    Intersect-1 command, Intersect-2 command



Italic Text
Normal text

Italic text

Setting text style within command
After the Text command is selected, choose the Italic button in the Command Line.

Setting text style with Text Options command
Choose the Text Options command in the Options menu.
Choose Italic in the Font Style box.
Choose the OK button.

Changing text style of selected text
Select the text.
Choose Show Info Box from the View menu.
Click the Italic button in the Info Box.

See Also:    Text Options, Changing Text Options, Text Options command



Joining Lines
Choose the Join command from the Edit menu.
Set a point in one corner of the area to be joined.
Set a second point in the opposite corner of the area.

See Also:    Join command, Editing Lines



Shortcut Keys
A Arc-1
< Angle, Distance-Two Points
> Arrow
$ Attribute
] Box
| Break Line
Ctrl+F Chamfer
O Circle-1
Ctrl+F4 Close
Ctrl+C Copy
Ctrl+H Crosshair
C Curve
Ctrl+X Cut
@ Dimension
G Display Grid
E Erase
Ctrl+E Erase Last
Alt+F4 Exit
F Fillet
Ctrl+W Fit to Window
. Gravity
, Gravity Move
N Intersect-1
Ctrl+N Intersect-1 Move
V Line
K Line Snap
Ctrl+K Line Snap Move
Ctrl+F9 Load Selection
F2 Midpoint
Ctrl+F2 Midpoint Move
Y New
Ctrl+F12 Open
Ctrl+O Original Size
= Parallel-1
Ctrl+V Paste
; Point Polar
' Point Relative
Ctrl+S Point Select Mode
Ins Point Set
: Point XY
Shift+S Preset Point Mode
Ctrl+Shift+F12 Print
( Quarter Circle
Ctrl+Z Redo
Ctrl+R Regenerate
F3 Repeat
Shift+F12 Save
F12 Save As
S Select Mode
) Semi-Circle
Shift+Alt+A Show Attribute
H Show Color Table
Ctrl+Alt+B Show Coordinate Bar



Shift+Alt+T Show Hot Toolbox
Ctrl+I Show Info Box
/ Show Line Style Box
Shift+Alt+M Show Main Toolbox
Shift+Alt+R Show Rulers
Shift+Alt+N Show Snap Toolbox
Shift+Alt+B Show Status Bar
J Show Polar Coordinates
Ctrl+G Snap Grid
& Stop Recording Macro
T Text
F7 Text Options
B Trim Two Lines
Ctrl+B Trim Double Lines
Ctrl+Z Undo
! Unerase
U Units
Z Zoom
+ Zoom In
- Zoom Out
Ctrl+P Zoom Previous

See Also:    Function Keys, DOS Keystroke Commands



LandScape Page Orientation
Choosing LandScape page orientation box rotates your drawing 90 degrees, and prints it sideways on the
page.

See Also:    Changing Page Orientation, Portrait Page Orientation, Printing, Printer Setup command



Left-Justified Text
After the Text command is selected, choose the Left alignment option in the Orientation box in the 

Command Line.
Set a point for the lower left corner of the text.
Set a point for the lower right corner of the text.

See Also:    Centered Text, Right-justified Text, Aligning Text, Text Alignment, Text Options command, Text
Options, Changing Text Options



Loading a Color Table
Choose the Load Color Table command from the Options menu.
Choose the color table name from the File Name box.
Choose the OK button.

See Also:    Load Color Table command, Getting Color Table



Loading Objects
Choose the Load Selection command from the File menu.
Choose the drawing name from the File Name box.
Choose the OK button.
Set a point for the lower left corner of the object.
Set a point for the lower right corner of the object.

See Also:    Load Selection command, Load Symbol command, Merge command, Loading Symbols, 
Inserting an Entity



Loading Symbols
Choose the Load Symbol command from the File menu.
Choose the symbol name from the File Name box.
Choose the OK button.
Set a point for the lower left corner of the symbol.
Set a point for the lower right corner of the symbol.

See Also:    Load Symbol command, Load Selection command, Merge command, Loading Objects, 
Inserting an Entity



Marking Points
DesignCAD offers four ways to mark points in a drawing.    These visible points designate reference points
such as center of gravity and midpoint indications.    A single point defines each point mark.

Marking points
Choose the Point Mark command.
To mark the point with a cross, choose the cross box in the Command Line.
To mark the point with a cross inside a box, choose the box and cross box in the Command Line.
To mark the point with a cross inside a circle, choose the circle and cross box in the Command Line.
To mark the point with a cross inside a circle and a box, choose the box, circle, and cross box in the 

Command Line.
To change the size of the point mark, type that number in the Point mark size box.
To draw the point mark the same size as a point mark in the drawing, choose the Same as box.    Then 

choose a point mark in the drawing.
Set a point on the point to be marked.

See Also:    Point Mark command



Maximizing Drawings
You can enlarge any drawing window to fill the entire DesignCAD window.    When you maximize a 
drawing window, other open drawing windows remain open, even though they are hidden.

Maximizing a drawing window
Choose the Maximize button in the upper-right corner of the window you want to expand.

See Also:    Maximize command, Maximizing Windows



Maximizing Windows
You can enlarge any drawing window to fill the entire DesignCAD window.    When you maximize a 
drawing window, other open drawing windows remain open, even though they are hidden.

Maximizing a drawing window
Choose the Maximize button in the upper-right corner of the window you want to expand.

See Also:    Maximize command, Maximizing Drawings



Menus
Using commands

Choosing a Menu Command
Closing a Menu
Interrupting an Action
Command Menu Bar
Repeating an Action

Using dialog boxes
Closing a Dialog Box
Selecting an Item in a List in a Dialog Box
Setting Options in a Dialog Box
Typing and Editing in Dialog Boxes
Typing Measurements in a Dialog Box



Selecting an Item in a List in a Dialog Box
Related dialog box options are often grouped into a scrollable list to save space.

To select an item
Point to an item and click the mouse button.

-or-
Press Alt and the under lined letter in the list name.    Then press the up and down arrows to select an 

item.

Note:  You can also press a letter to go straight to the first item in the list beginning with that letter.

To select an item
To display the list, click the down arrow.

-or-
Press Alt and the down arrow key.
Select an item.

Note:    Some boxes include a text area in which you can type a response instead of selection from a 
list.

To hide the list
Click the down arrow again.

-or-
Press Alt and the up arrow.

Use the controls on this box to increase or decrease the measurement one increment at a time.

To select an item
Click the up and down arrows in the dialog box.

-or-
Press the up and down arrows on the keyboard.

Note:    This box includes a text area in which you can type a measurement instead of selecting from 
the list.

See Also:    Using Dialog Boxes, Setting Options in a Dialog Box



Typing and Editing in Dialog Boxes
Some dialog boxes contain text boxes in which you can type a response.

To replace text in a text box
Select the text you want to replace by:

Dragging the mouse pointer over the text you want to replace.
-or-

Holding down the Alt key and pressing the underlined letter in the text box.
Type your response.    DesignCAD deletes the selected text as soon as you start typing.

See Also:    Using Dialog Boxes, Selecting Options



Typing Measurements in a Dialog Box
DesignCAD accepts measurement for certain items.

To type measurements in a dialog box
Move to the text box in which you want to type a measurement.
Type a number.

See Also:    Using Dialog Boxes, Typing and Editing in Dialog Boxes



Merging Drawings
DesignCAD allows you to merge more than one drawing into a single drawing.    DesignCAD opens the 
first drawing, then merges the second drawing on top of it.    The Drawing Units of the second drawing are
matched to those of the drawing already on the screen.

Merging drawings
Choose Merge from the File menu.
Choose the name of the drawing in the File Name box.
Choose the OK button.
Set a point for the lower left corner of the drawing.
Set a point for the lower right corner of the drawing.
Set a point for the upper left corner of the drawing.
Set a point for the upper right corner of the drawing.

See Also:    Merge command, Combining Drawings



Mirroring Objects
Horizontally Mirroring Objects
Vertically Mirroring Objects
Mirroring Objects Based on Custom Mirror
Mirroring Objects Based on Custom Normal



Horizontally Mirroring Objects
Select the object to be mirrored.
Choose the Mirror command.
Choose the Mirror Horizontally button in the Command Line.
Choose the Make Copy box to have a copy of the entity drawn.
Set a point for the location of the imaginary mirror.

See Also:    Vertically Mirroring Objects



Vertically Mirroring Objects
Select the object to be mirrored.
Choose the Mirror command.
Choose the Mirror Vertically button in the Command Line.
Choose the Make Copy box to have a copy of the entity drawn.
Set a point for the location of the imaginary mirror.

See Also:    Horizontally Mirroring Objects



Mirroring Objects Based on Custom Mirror
Select the entity to be mirrored.
Choose the Mirror command.
Choose the Custom Mirror button in the Command Line.
Choose the Make Copy box in the Command Line to have a copy of the entity drawn.
Set a point for the primary handle of the imaginary mirror.
Set another point for the secondary handle of the imaginary mirror.

See Also:    Vertically Mirroring Objects, Horizontally Mirroring Objects



Mirroring Objects Based on Custom Normal
Select the entity to be mirrored.
Choose the Mirror command.
Choose the Custom Normal button in the Command Line.
Choose the Make Copy box in the Command Line to have a copy of the entity drawn.
Set a point for the primary handle of the "normal."
Set point for the secondary handle of the "normal."

See Also:    Vertically Mirroring Objects, Horizontally Mirroring Objects



Mirror Normal

The mirror "normal" is an imaginary line that is perpendicular to the mirror.



Mouse Shortcuts
The following table provides a review of basic mouse techniques you will need to know to work in 
DesignCAD.    For more information and practice using these skills, see the documentation that came with
your mouse.

To Do This
Point Position the mouse pointer on or next to something.
Click Position the pointer then quickly press and release the left mouse button.
Double-click Position the pointer then quickly press and release the left mouse button twice.
Drag Position the pointer.    Press and hold the left mouse button as you move the mouse to the

desired position.    Then release the button.

Middle mouse button
Sometimes when you select a DesignCAD command you will need to press Enter.    If you have a three-
button mouse, you can press the middle button for the Enter key.

Setting points
You can select a command before setting the points required for the command.    For example, you can 
draw a line by selecting the Line command.    Then set the points for the line.

See Also:    Selecting Commands with a Mouse



Moving Objects
Activate the Select Mode.
Select the entity to be moved.
Move the pointer to the area inside the highlighting box.
Press and hold down the left mouse button.    Drag the pointer in the desired direction.
Move the selection box to the new location.
Release the mouse button.

-or-
Press Alt+Ins.
Use the arrow keys to move the selection box to the new location.
Press Ins to set a point.

See Also:    Moving Objects with Handles, Moving Objects Vertically, Moving Objects Horizontally



Moving Objects with Handles
Moving an entity to an exact location

Activate the Point Select Mode.
Select the entity to be moved.
Press and hold down the left mouse button.    Drag the pointer across the entity.
Set a point for the reference point.
Move the pointer to the new location.
Press the right mouse button to set a gravity point on the second entity.

-or-
Move the cursor to the upper corner of the entity.
Press Alt+Ins to activate the selection box.
Use the arrow keys to drag the selection box across the entity.
Press Ins to set a point.
Set a point for the reference point.
Use the arrow keys to move the pointer to the new location.
Press . to set a gravity point on the second entity.

Moving several objects to an exact location
Activate the Select Mode.
Select the first entity.
Press Shift while selecting other objects.
Click the left mouse button inside the selection box.

-or-
Press Ins to set a point inside the selection box.
Set a point for the handle of the objects.
Set a point for the new location of the handle.

See Also:  Moving Objects



Moving Windows
You sometimes need to move a window to see another window behind it.    You cannot drag a window 
completely off the screen; at least some of the title bar must remain visible.    If the DesignCAD window is 
maximized, it must be restored before you can move it.

Moving a window
Point to the title bar of the window.
Drag it to the new position.

-or-
Press Alt+- to choose the drawing Control-menu box.
Press M to choose the Move command.
Press the arrow keys to position the outline of the window.
When the window is where you want it, press Enter.

See Also:    Switching Windows



Naming Drawings
The Save command in DesignCAD saves drawings with any acceptable DOS filename.    That is, the 
filename can be from one to eight characters long, followed by a period and a three-character filename 
extension.    You can use any characters except spaces and the following characters: * ? , ; [ ] + = \ / : | < 
>. You cannot use a period except to separate the filename extension.

Filename extensions distinguish between types of files.    For example, DesignCAD binary drawing files 
have the extension .DW2, DesignCAD ASCII drawing files have the extension .DC2, and backup files 
have the extension .BAK.

If you do not add a filename extension to drawing filenames, DesignCAD adds .DW2 by default.

DesignCAD assumes specific filename extension.    If you use other extensions for your files, type the 
extension every time you type the filename.

DesignCAD uses the following filename extensions:

Extension Meaning
.DW2 Binary file
.DC2 ASCII file
.BAK Backup file
.EXE Program file
.DAT Data file
.SYS Program file
.MNU Menu file
.PMT Prompt file
.B2D Drawing Configuration file

See Also:    Saving a New, Unnamed Drawing



New Drawings
After you close a drawing in DesignCAD, you can create a new empty drawing.

Creating a new drawing
Choose the New command from the File menu.

DesignCAD gives the new drawing a temporary name, such as Untitled-View1.    You give the drawing a 
new name when you save it.

See Also:    Your First DesignCAD Drawing, Creating a New Drawing, Saving a New, Unnamed Drawing



Opening Drawings
Before you can work on an existing drawing, it must be open on the screen.

Opening an existing drawing
Choose the Open command from the File menu.
In the File Name box, type the filename of the drawing you want to open.

-or-
Double-click the name in the File Name box or click the arrows in the scroll bar to choose the filename.
Choose the OK button.

If the drawing you want is not listed in the File Name box, choose a new drive or directory in the Open 
dialog box.

Listing a drawing in the File Name box
Choose the Open command from the File menu.
If the file is in a different sub directory, choose the directory in the Directories box.
If the file is on a different drive, choose the drive letter in the Drives box.
Choose the OK button.

Note:    If the Directories box does not display the directory that contains the file, you may have to move 
higher in the directory hierarchy to find the file.    For example, if you have two sub directories under drive 
C and you want to list the contents of another sub directory, you must first double-click the C:\ directory 
and then double-click the second directory.

The File menu lists the four most-recently opened drawings.

Opening a recent drawing
Choose the file from the File menu.

See Also:    Creating a New Drawing, Opening a File Created by Another Application, Opening an 
Existing Drawing



Opening Views
Choose the New Window command from the Window menu.

Drawing commands effect all views of the drawing.

Making a drawing view active
Choose the name of the drawing view you want to make active from the Window menu.
-or-
Click inside the view you want to make active if there is more than one window open.

See Also:    New Window command, Changing the View



Page Orientation
The page orientation refers to how a drawing will be printed on the page.    DesignCAD can print a 
drawing in LandScape or portrait mode.

Setting print orientation
Choose the Print command.
In the Orientation Box, choose the Portrait or LandScape box.
Choose the OK button.

See Also:    Changing Page Orientation, Printing, Printer Setup command, Portrait Page Orientation, 
LandScape Page Orientation



Page Size
When you start a drawing, DesignCAD assumes you will print on paper that is 8.5 by 11 inches in portrait 
orientation.    However, you can change the paper size loaded into your printer within the Printer Setup 
options box.

Setting page size
Choose the Printer Setup command in the File menu.
Choose the Setup button.
Choose the Options button.
In the Paper box, choose the size of the paper you want to use.
Choose the OK button.

See Also:    Setting the Paper Size, Printing, Printer Setup command



Setting the Paper Size
DesignCAD prints drawings on paper determined by the size set with the Print command.

Setting the paper size
Choose the Print command
In the Paper Size box, enter the paper margins.
Choose the OK button.

See Also:    Printing, Printer Setup command



Panning Drawings
Choose the Pan command.
Press and hold the left mouse button.
Move the pointer in the desired direction.
Release the mouse button.

-or-
Choose the Pan command.
Press Alt+Ins.
Use the arrow keys to move the cursor in the desired direction.
Set a point.

See Also:    Pan command



Portrait Page Orientation
Portrait page orientation forces a drawing to be printed with the drawing width the same direction as the 
printer width.

See Also:    Changing Page Orientation, Page Orientation, Printing, LandScape Page Orientation, Printer 
Setup command



Printing
DesignCAD allows you to produce extremely high resolution drawings on ordinary dot matrix and laser 
printers or plotters.    

Once you choose a printer and the appropriate Print Setup options, printing is simple just choose the Print
command from the File menu.

The printer you use affects how DesignCAD displays and prints your drawing.    For instructions on 
installing your printer and connecting it to your computer, see your Windows documentation and your 
printer manual.

With the Print command, you can print an entire drawing or just selected objects.    The Print command 
allows you to change the number of dots-per-inch used to print a drawing, the orientation of the image 
printed on the paper, and the light intensity used to print the drawing.

See Also:    Printing a Drawing, Printing Several Copies, Printing Part of a Drawing



Printing Part of a Drawing
Select the part of the drawing to be printed.
Choose Print from the File menu.
In the Print box, select Selection.
Choose the OK button.

Shortcut
Keys: F5

See Also:    Print command



Plotting Drawings
The plotter you use affects how DesignCAD displays and plots your drawing.    For instructions on 
installing your plotter and connecting it to your computer, see your Windows documentation and your 
plotter manual.

DesignCAD allows you to produce extremely high resolution drawings on ordinary plotters.    Once you 
choose a plotter and the appropriate Printer Setup options, plotting is simple, just choose the Print 
command from the File menu.

If you have installed a plotter, first select it from the list of available plotters and printers in the Printer 
Setup command.    Then choose the Print command to send your drawing to the plotter instead of the 
printer.

See Also:    Printing, Printer Setup, DesignCAD Print Options



Repairing Lines
Choose the Regenerate command from the View menu.

See Also:    Regenerate command



Repeating Commands
Before the command is selected, double-click the command icon in the Toolbox.

-or-
After the command is selected, press F3 to choose the Repeat command.

See Also:    Repeating an Action, Repeat command



Retrieving Files
Choose the Open command from the File menu.
In the File Name box, type the filename of the drawing you want to open.
Choose the OK button.

See Also:    Opening Drawings, Open command, Loading Files



Right-Justified Text
After the Text command is selected, choose the Right alignment option in the Orientation box in the 

Command Line.
Set a point for the lower right corner of the text.
Set a point for the lower left corner of the text.

See Also:    Left-justified Text, Centered Text, Text Alignment, Aligning Text, Text Options command, Text 
Options, Changing Text Options



Rotating Objects
Rotating an object with the keyboard

Select the objects to be rotated.
Choose the Select Rotate command from the Edit menu.
Type the rotation angle in the Rotate angle box in the Command Line.
Press Enter.

Rotating an object with the mouse
Activate the Select Mode.
Select the object to be rotated.
Double-click a selection node on the highlighting box activate the rotate mode.
Press and hold down the mouse button on a corner node of the highlighting box.
Move the pointer in the desired direction.
Release the mouse button.

See Also:  Select Rotate command



Saving Color Table
Customize the color table with the Set Color command.
Choose the Save Color Table command from the Options menu.
Type a name for the color table in the File Name box.
Choose the OK button.

See Also:    Set Color command, Save Color Table command, Customizing Color Table



Saving Drawings
Choose the Save command from the File menu.
In the File Name box, type a filename.
Choose the OK button.

See Also:    Closing a Drawing, Saving a New, Unnamed Drawing, Saving an Existing Drawing, Save 
command, Save As command. Saving Drawing to Drive or Directory



Saving an Existing Drawing
The Save command records any changes made to an active drawing.    The drawing name and location 
remain the same.    You should save drawings frequently as you work.

To save an existing drawing
Choose the Save command from the File menu.

Shortcut
Keys: F10

See Also:    Closing a Drawing, Saving a New, Unnamed Drawing, Saving an Existing Drawing, Save 
command, Save As command



Saving Layers
Choose the layer to be saved in the Layer box in the Coordinate Bar.
Choose the Save Layer command from the Options menu.
Type the file name in the File Name box.
Choose the OK button.

See Also:    Save Layer command, Editing Layers, Layer Setup command



Segmenting Entities
Choose the Segment command from the Edit menu.
Type the number of sections in the Number of sections box in the Command Line.
Set a point on the entity to be segmented.

See Also:    Segment command, Editing Entities



Selecting Objects
Selecting an Entity
Selecting an Entity with Selection Box
Selecting Several Entities
Selecting All Entities
Selecting Last Entity Selected
Selecting Certain Entities
"Unselecting" Entities



Selecting an Entity
Activate the Select Mode.
Move the pointer near the entity.
Set a point.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting an Entity with Selection Box
Activate the Select Mode.
Move the pointer to the corner of the entity.
Press and hold down mouse button.
Drag the selection window until the entity is enclosed.
Release the mouse button.

-or-
Use the arrow keys to move the pointer to the corner of the entity.
With the Num Lock off, press Alt+Ins to activate the selection box.
Use the arrow keys to "drag" the selection box.
Press Ins to set a point.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting Several Entities
Activate the Select Mode.
Select the first entity.
Press Shift while selecting other entities.

Selecting several entities in same area
Activate the Select Mode.
Move the pointer to the corner of the first entity.
Press and hold down the left mouse button.
Drag the mouse until the selection window includes all the entities to be selected.
Release the mouse button.
-or-
Use the arrow keys to move the pointer to the first entity.
Press Ins to select the entity.
Press Alt+Ins to activate the selection box.
Use the arrow keys to move the pointer until the selection box encloses all entities to be selected.
Press Ins to set a point and select the entities.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting All Entities
Choose the Select All command from the Edit menu.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting Last Entity Selected
Choose the Select Previous command from the Edit menu.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting Certain Entities with the Keyboard
Choose the Entity Select command from the Edit menu.
Choose the check box next to the entity types you want to select.
Choose the OK button.

See Also:    Using the Mouse, Using a Digitizer, Using the Keyboard



Selecting Layers
Choose the layer to be selected in the Layer box in the Coordinate Bar.
Choose the Select Layer command in the Options menu.

See Also:    Select Layer command, Editing Layers, Layer Setup command



Setting Points
The basis to using all DesignCAD drawing commands is the location of points.    Points determine the 
diameter of a circle and the radius of an arc.    Some commands use control points to draw a curve.

DesignCAD offers a variety of point commands.    With DesignCAD, point commands can be selected 
from the Command Menu, the Snap Toolbox, the digitizer menu, or issued with shortcut keys.

Using Points with DesignCAD Commands
Setting Regular Points
Setting Gravity Points
Snapping to Lines
Entering Coordinates for Points



Setting the Snap Grid
The snap grid is an imaginary grid placed over your drawing.    Each point set with the Point Set command
is located exactly on one of the grid points.    The cursor movement follows the snap grid.

Enabling the snap grid
Choose the Snap Grid option from the Options menu.

Setting the snap grid size
Choose the Grid Options command from the Options menu.
Type the size in the Snap grid size box.
Choose the Enable snap grid box to enable the snap grid.
Choose the OK button.

See Also:    Snap Grid option, Display Grid option



Setup
The DesignCAD Setup program installs the DesignCAD files, including the DesignCAD program and on-
line Help.    The Setup program automatically creates the DesignCAD 2-D program group, the DesignCAD
2-D Setup icon, and the DesignCAD 2-D application icon.

Setting up DesignCAD on a hard disk
If Windows is not already running, type WIN at the DOS prompt.

-or-
If Windows is running, close any open applications.
Insert the DesignCAD Installation disk (disk 1) into the appropriate drive.
Choose Run from the File menu.
Type A:INSTALL or B:INSTALL.
Press Enter.
To accept the path that Install proposes, choose the Continue button.

-or-
To choose your own directory, type a new path in the Install To box, then choose the Continue button.
If Install detects that the directory in the path doesn't exist, do one of the following:

To create the directory, choose the Yes button.
To edit the path, choose the No button, edit the path in the Install To box, then choose the Continue 
button.

If Install detects a previous version of DesignCAD in the directory you specified, do one of the 
following:
To overwrite the directory, choose the Continue button.
To keep the old version, choose the Change Directory button, then type a different path in the Install 
To box.

When Install asks if you want to update the startup file AUTOEXEC.DCM, do one of the following:
To update the file, choose the Update button.

When Setup is complete, choose the OK button.

See Also:    Installing Symbols



Shortening Lines
Select the line to be extended.
Choose the Extend command from the Edit menu.
Set a point on the endpoint to be shortened.
Move the pointer to the new location for the endpoint.
Set a point for the new endpoint.
-or-
Activate the Point Select Mode.
Press Shift and select the endpoint to be shortened.
Move the pointer in the desired direction.
Set a point for the new endpoint.

See Also:    Extend command, Editing Lines



Showing Coordinate Bar
Choose the Coordinate Bar option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Coordinate Bar, Customizing DesignCAD



Showing Info Box
Choose the Info Box option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Info Box, Customizing DesignCAD



Showing Main Toolbox
Choose the Main Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Main Toolbox, Customizing DesignCAD



Showing    Snap Toolbox
Choose the Snap Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Snap Toolbox, Customizing DesignCAD



Showing Status Bar
Choose the Status Bar option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Status Bar, Customizing DesignCAD



Smoothing Lines
Select the line to be smoothed.
Choose the Smooth command

See Also:    Editing Lines



Starting DesignCAD
You can start DesignCAD using either the mouse or the keyboard.    If Windows is not already running, 
type WIN at the command prompt.    

Starting DesignCAD
Double-click the DesignCAD icon.

-or-
Press Ctrl+Tab simultaneously until the DesignCAD group is highlighted.
Use the arrow keys to choose the DesignCAD icon.
Press Enter.

See Also:    Closing a Drawing and Exiting DesignCAD



Starting the Program
You can start DesignCAD using either the mouse or the keyboard.    If Windows is not already running, 
type WIN at the command prompt.    

The DesignCAD icon

Starting DesignCAD with a mouse
Double-click the DesignCAD icon.

Starting DesignCAD with the keyboard
Press Ctrl+Tab simultaneously until the DesignCAD group is highlighted.
Use the arrow keys to choose the DesignCAD icon.
Press Enter.

See Also:    Opening DesignCAD files, Before You Begin Your Work with DesignCAD, Beginning Work on 
a Drawing



Opening DesignCAD Files
You can start DesignCAD from either Windows or the command prompt.

To start DesignCAD from the Windows Program Manager
Switch to the Program Manager window.
Open the group window that contains the DesignCAD icon.
Double-click the DesignCAD icon.

-or-
Use the arrow keys to select the DesignCAD icon.    Then press Enter.

To start DesignCAD from the Windows File menu
Choose Run from the Program Manager file.
If DesignCAD is in your path, type WDC.
If DesignCAD is not in your patch, type the path for DesignCAD -- for example:    C:\WDC\WDC.EXE.
Choose the OK button.

To start DesignCAD from the command prompt
At the command prompt, type WIN WDC.
Press Enter.

Tip:    To open an existing file automatically when you start DesignCAD from the command prompt, type 
WIN WDC filename.



Straightening Lines
Straightening a curve

Select the curve to be changed.
Choose the Curve To Line command.

Straightening a line
Select the line to be straightened.
Choose the Select Ortho command from the Edit menu.

See Also:    Editing Lines



Stretching Objects
Activate the Select Mode.
Select the object to be stretched.
Select the Stretch command from the Edit menu.
Set a point to the right of the endpoint to be stretched.
Set a point in the opposite corner of the object to be stretched.
Set a point on the object to be stretched.
Set a point for the new location of the endpoint of that object.

See Also:    Editing Entities



Stretching a Line
Activate the Select Mode.
Select the line to be stretched.
Select the Stretch command from the Edit menu.
Set a point to the right of the endpoint to be stretched.
Set a point in the opposite corner of the entity to be stretched.
Set a point on the entity to be stretched.
Set a point for the new location of the endpoint of that line.

See Also:    Editing Lines



Switching Windows
Switching to a Different Drawing Window
Moving Windows
Opening Views



Text Alignment
Left-aligning text

After the Text command is selected, choose the Left alignment option in the Orientation box in the 
Command Line.

Set a point for the lower left corner of the text.
Set a point for the lower right corner of the text.

Centering text
After the Text command is selected, choose the Center alignment option in the Orientation box in the 

Command Line.
Set a point for the center of the text.
Set a point for the lower right corner of the text.

Right-aligning text
After the Text command is selected, choose the Right alignment option in the Orientation box in the 

Command Line.
Set a point for the lower right corner of the text.
Set a point for the lower left corner of the text.

See Also:    Aligning Text, Text Options command, Text Options, Changing Text Options



Tiling Windows
Choose the Tile Horizontal command from the Window menu.

-or-
Choose the Tile Vertical command from the Window menu.

See Also:    Arranging Views, Moving Windows, Cascading Windows, Opening Views, Manipulating the 
Views, Windows



Trimming Lines
Trimming One Line
Trimming Two Lines
Trimming Between a Line
Trimming Four Lines



Trimming One Line
Choose the Trim One Line command.
To trim the shorter end, choose the Trim shorter end box in the Command Line.
Set a point on the line to be trimmed.
Set a point on the line intersecting that line.

-or-
Choose the Trim One Line command.
To trim one line, disable the Trim shorter end box in the Command Line.
Set a point on the line to be trimmed.
Set a point on the line intersecting that line.

See Also:    Trim one line command



Trimming Two Lines
Choose the Trim Two Lines command.
To trim the shorter end, choose the Trim shorter end box in the Command Line.
Set a point on the first line.
Set a point on the second line.

-or-
Choose the Trim Two Lines command.
To trim one line, disable the Trim shorter end box in the Command Line.
Set a point on the first line to be trimmed.
Set a point on the line intersecting that line.

See Also:    Trim Two Lines command



Trimming Between a Line
Choose the Trim Between Lines command.
Set a point on the line to be trimmed.
Set a point on the first intersecting line.
Set a point on the second intersecting line.

See Also:    Trim Between Lines command



Trimming Four Lines
Choose the Trim Double Lines command.
To trim the lines within a specified area, choose the Select trim area box in the Command Line.

-or-
To trim certain lines within an area, choose the Select trim lines and area box in the Command Line.    

Then select each of the four lines to be trimmed.
Set a point in the corner of the lines to be trimmed.
Set a point in the opposite corner of the lines to be trimmed.

See Also:    Editing Lines, Trim Double Lines command



Undoing Commands
Choose the Undo command from the Edit menu.

See Also:    Redoing Commands



Unerasing Commands
If you erase a command by mistake

Choose the Unerase command from the Edit menu.

See Also:    Erasing Entities, Undoing Commands



Units of Measurement
The units of measurement for a drawing are called Drawing Units.    Drawing Units can be inches, 
centimeters, feet, miles, or any unit of measurement that makes sense for the drawing.

See Also:    Units command



"Unselecting" Entities
If you select an entity by mistake, press the Shift key and select the entity again.

-or-
Click outside the highlighting box.

-or-
Set a point outside the highlighting box.

See Also:    Selecting Objects



Using Symbols
Installing Symbols
Loading Symbols
Manipulating Symbols
Creating Symbols



Viewing Drawings
Opening a New Window
Manipulating the Views



Filling Wide Lines
The Show Line Style Box option allows you to set the width of a line.    These wide lines are "hollow," 
unless they are filled in with the Fill Wide Lines option.

Choose the Fill Wide Lines option in the Options menu.

See Also:    Changing Line Characteristics, Show Line Style Box option



WIN.INI File
WIN.INI is the Windows settings file which contains information about your Windows applications, 
including the default locations for the DesignCAD files, utilities, fonts, and WDC.INI.



Windows
Arranging all open drawing windows
Closing a window
Expanding a window to maximum size
Opening multiple views of a drawing
Restoring a drawing window to its former size
Sizing a window



Arranging All Open Drawing Windows
If you open several drawing windows, or views, the screen may be cluttered and some windows may be 
hidden.

Arranging all open drawing windows
Choose Cascade from the Window menu.

See Also:    Arranging Windows and Icons, Windows



Closing a Window
When you finish working on a drawing, you can close the drawing window.    DesignCAD prompts you to 
save changes before it closes the drawing.    When you quit DesignCAD, all open drawing windows are 
closed.

Closing a drawing window
Choose the Close command from the Edit menu.

-or-
Choose the Close command from the drawing Control-menu.

To close all open windows
Choose the Close All command from the Window menu.

See Also:    Opening a New Window, Windows



Expanding a Window to Maximum Size
You can enlarge any drawing window to fill the entire drawing window.    When you enlarge, or "maximize,"
a drawing window, other open drawing windows remain open, even though they are hidden.

Expanding the DesignCAD window to maximum size
Choose the Maximize command from the application Control-menu.

See Also:    Restoring a Drawing Window to Its Former Size



Opening Multiple Views of a Drawing
The New Window command opens several views, or windows, of the current drawing. These views can 
be "zoomed" and "panned" independently.

Opening multiple views
Choose the New Window command from the Window menu.

Drawing commands effect all views of the drawing.

See Also:    Opening a New Window



Restoring a Drawing Window to Its Former Size
If you have enlarged a drawing window or an application window to its maximum size, you must restore it 
to its former size before you can move or size it.

Restoring a drawing window to its former size
Choose the Restore command from the drawing Control-menu.

See Also:    Expanding a Window to Maximum Size, Restore command



Sizing a Window
You can make a window smaller to view more than one window at a time, or make it larger to see more of
a drawing's contents.    You cannot move or size a window that has been enlarged to its maximum size.

Sizing a drawing window
If the window is enlarged to its maximum size, restore it to its original size by choosing Restore from 

the drawing Control-menu.
Choose the Size command from the Control menu.

-or-
Press Ctrl+F8.

When the mouse pointer appears as a , use the arrow keys to select the border you 
want to move.

When the mouse pointer appears as a , use the arrow keys to move the borders.
Note:    To return the window to its former size, press Esc.

When the window is the size you want, press Enter.

Sizing an application window
If the window is enlarged to its maximum size, restore it to its original size by choosing Restore from 

the application Control-menu.
Choose Size from the Control menu.

-or-
Press Ctrl+F8.

When the mouse pointer appears as a , use the arrow keys to select the border you 
want to move.

When the mouse pointer appears as a , use the arrow keys to move the borders.
Note:    To return the window to its former size, press Esc.

When the window is the size you want, press Enter.

See Also:    Maximizing Windows, Minimizing Windows



Zooming a Drawing
Choose the Zoom command from the View menu.
Type the zoom factor on the Command Line.
To permanently change the zoom factor of the drawing, click the Static Zoom box on the Command 

Line.
Set a point for the zoom origin.
Set a point for the zoom destination.

Zooming a drawing with window
Choose the Zoom Window command in the Toolbox.
Set two points for the zoom window.

Zooming in a drawing
Choose the Zoom In command in the Toolbox.
Set a point for the zoom origin.
That point is moved to the center of the screen.    The drawing is zoomed according to the zoom factor 

set in the Options command.

Zooming out a drawing
Choose the Zoom Out command in the Toolbox.
Set a point for the zoom origin.
That point is moved to the center of the screen.    The drawing is zoomed according to the zoom factor 

set in the Options command.

See Also:    Zoom command, Zoom In command, Zoom Out command



Mathematical Calculations and Equations

By inserting operators between numbers in the Calculator dialog box, you can perform the following 
calculations:

45*23
(6+23)*4
SQRT(9)
SIN(45)

The expression can contain mathematical functions and the following operators:

+ Addition
- Subtraction
* Multiplication
/ Division
^ Raises a number to a power



Commands
Canceling
Closing a Dialog Box
Closing a Menu
Interrupting an Action
Reversing an Action

Choosing
Choosing a Menu Command
Repeating an Action

Macros
Using Macros

Shortcuts
Shortcut Keys
Creating a Hot Toolbox



Closing a Dialog Box
Click the Cancel button.

-or-
Press Esc.

See Also:    Using Dialog Boxes



Closing a Menu
Click outside the menu.

-or-
Press Esc.

Note:    After you press Esc to close a menu, the menu name is still selected.    To return to your drawing, 
press Esc again.

See Also:    Canceling a Menu



Interrupting an Action
Press Esc.
If DesignCAD does not stop the process, press Esc again.

See Also:    Canceling a Command



Reversing an Action
Choose the Undo command from the Edit menu.

Note:    You must choose Undo before performing any other action.

See Also:    Undoing an Action, Undoing Commands



Choosing a Menu Command
Point to the menu name.
To display the menu, click the left mouse button.
Point to a command name.
Click the command name with the left mouse button.

-or-
Press Alt and the underlined letter in the menu name.
To choose a command, press the underlined letter in the command name.

A command name followed by an ellipsis (...) indicates that a dialog box exists so you can set the options 
you want.

See Also:  Setting Options in a Dialog Box.



Setting Options in a Dialog Box
Point to the option and click the left mouse button.

-or-
Hold down the Alt key and press the underlined letter in the option name.

To carry out the options you set
Choose the OK button.

-or-
Press Enter.

To cancel changes to options settings
Choose the Cancel button.

-or-
Press Esc.

See Also:    Using Dialog Boxes



Repeating an Action
Before the command is selected

Double-click the command in the Toolbox.

After the command is selected
Press F3.

See Also:    Repeating Commands



Using Macros
Creating

Getting Help on Creating Macros
Recording a Macro
Creating Macros that Run Automatically
Creating User-Defined Macros

Running
Running a Macro

Reference information
BasicCAD Programming Language



Getting Help on Creating Macros
For help on creating, changing, and running macros, see Recording a Macro.
For a list of all BasicCAD statements and functions, including descriptions, syntax, and examples, see 

Using BasicCAD.

See Also:    Creating Macros



Recording a Macro
Choose the Record Macro command from the File menu.
Type the name for the macro in the Record Macro Name box.
Choose the OK button.
Set a point for the startup cursor position.
Perform the actions you want to record.
Choose the Stop Recording Macro command.

See Also:    Getting Help on Creating Macros, Recording Macro Options



Creating Macros that Run Automatically
Choose the Options command from the Options.
Choose the Macro category.
Choose the Startup Macro box.
Choose the startup macro name.
Choose the OK button.

See Also:    Creating Macros



Running a Macro
Choose the Execute Macro command from the File menu.
Select the macro you want to run in the Macro Name box.
Choose the OK button.
Set a point for the startup cursor position.

See Also:    Creating Macros, Using Macros



Creating Drawings
Your First DesignCAD Drawing
Creating a New Drawing
Saving a New, Unnamed Drawing



Creating a New Drawing
Choose New from the File menu.

Note:    DesignCAD gives the new drawing a temporary name, such as DesignCAD 2-D (Untitled View1), 
until you save it with a unique filename.

See Also:    New Drawings, Your First DesignCAD Drawing, New command, Creating Drawings



Saving a New, Unnamed Drawing
Choose Save from the File menu.

-or-
Choose Save As from the File menu.
To save the drawing in the current drive and directory, type a name of up to eight characters in the File

Name box.
Choose the OK button.

Until you give a new drawing a unique filename, DesignCAD temporarily names new drawings.

Note:  DesignCAD automatically adds a .DW2 extension unless you specify a different extension.

See Also:    Saving Your Drawings, Saving Drawings, Saving Drawing to Drive or Directory



Your First DesignCAD Drawing
Before You Begin Your Work with DesignCAD
Starting DesignCAD
Beginning Work on a Drawing
Working with Drawings
Saving Your Work
Closing a Drawing and Exiting DesignCAD



Keyboard, Mouse and Digitizer
Keyboard
Controlling the Cursor
Function Keys
Keyboard Techniques
Selecting Commands with the Keyboard
Selecting Objects with the Keyboard
Shortcut Keys
Using Arrow Keys
Using Dialog Boxes

Mouse
Mouse Techniques
Moving Vertically and Horizontally
Selecting Commands with a Mouse
Selecting Entities with a Mouse

Digitizer
Digitizer Techniques
Selecting Commands with a Digitizer
Selecting Entities with a Digitizer
Using a Digitizer



Function Keys 

You can use the function keys on your keyboard to perform many tasks faster.



Selecting Commands with the Keyboard
Pressing the Alt key and the underlined letter of each menu accesses the Command Menu.    When you 
press Enter, the menu will "pull-down."    Pressing the underlined letter of the desired command selects 
commands from the menus.

To choose a command from a menu, you can press a shortcut key.    In DesignCAD, shortcut keys are 
listed after the command names in the Command Menu.

Choosing the Open command
Press Alt+F to open the File menu.
Press O to choose the Open command.

-or-
Press Ctrl+F12 to choose the Open command.

When you open a menu the first command is highlighted.    Use the arrow keys on the keyboard to move 
the highlight bar and choose a command.

Secondary menus
To choose the Load Selection command, choose the word "Load" from the Edit menu.    Then move the 
highlight bar to Load Selection and press the Enter key.    Because an arrow follows the word "Load," a 
secondary menu with more commands will "pop up" on the screen.

See Also:    Using the Keyboard, Keyboard Techniques



Controlling the Cursor
The arrow keys or the number keys on the numeric keypad move the cursor, or pointer.    If the Num Lock
is on, the cursor moves in small steps when you press the number keys.    The same is true if you press 
the Shift key and the arrow keys simultaneously.    If the Num Lock is off, the cursor moves in larger 
steps.

See Also:    Using Arrow Keys, Setting the Cursor Step Size



Selecting Objects with the Keyboard
Selecting an Entity with Keyboard
"Unselecting" an Entity with Keyboard
Selecting Several Entities with Keyboard
Selecting All Entities with Keyboard
Selecting Last Entity Selected with Keyboard
Selecting Certain Entities with Keyboard



Selecting an Entity with Keyboard
Press S to activate the Select Mode.
Use the arrow keys to move the pointer to the entity.
Set a point on the entity to select it.

"Dragging" the selection box
Press S to activate the Select Mode.
Use the arrow keys to move the pointer to the corner of the entity.
With the Num Lock off, press Alt+Ins to activate the selection box.
Use the arrow keys to "drag" the selection box.
Press Ins to set a point.

See Also:    Using the Keyboard, Controlling the Cursor, Using Arrow Keys



Unselecting an Entity with Keyboard
If you select an entity by mistake, press the Shift key and select the entity again.

-or-
Set a point outside the highlighting box.

See Also:    Using the Keyboard, Controlling the Cursor, Using Arrow Keys



Selecting Several Entities with Keyboard
Selecting several entities one at a time

Press S to activate the Select Mode.
Use the arrow keys to move the pointer to the first entity.
Set a point on the first entity to be selected.
Move the pointer to the next entity to be selected.
Press Shift+Ins to set a point on the next entity to be selected.

Selecting several entities in the same area with Enclose Mode
Press S to activate the Select Mode.
Use the arrow keys to move the pointer to the first entity.
Press Alt+Ins to activate the selection box.
Use the arrow keys to move the pointer until the selection box encloses all entities to be selected.
Press Ins to set a point and select the entities.

Selecting several entities in same area with Touch Mode
Press S to activate the Select Mode.
Use the arrow keys to move the pointer to the first entity.
Press Alt+Ins to activate the selection box.
Use the arrow keys to move the pointer until the selection box touches all entities to be selected.
Press Ctrl+Ins to select the entities.

See Also:    Using the Keyboard, Controlling the Cursor, Using Arrow Keys



Selecting All Entities with Keyboard
Press Alt+E to open the Edit menu.
Press A to choose the Select All command.

See Also:    Using the Keyboard, Controlling the Cursor, Using Arrow Keys



Selecting Last Entity Selected with Keyboard
Press Alt+E to open the Edit menu.
Press v to choose the Select Previous command.

See Also:    Using the Keyboard, Controlling the Cursor, Using Arrow Keys



Using Dialog Boxes

The OK, Cancel, and Close command buttons appear in many dialog boxes.    You can choose one of 
these buttons when you finish setting options in a dialog box.

OK button
The OK button closes the dialog box and completes the command using the selected options.    For 
example, choosing the OK button in the Open dialog box opens the drawing.    To choose the OK button, 
click the button or press Enter when it is selected.

Cancel button
Choosing the Cancel button discards the options you have selected, closes the dialog box, and returns 
you to your drawing.    To choose the Cancel button, press the Esc key.

Close button
When DesignCAD completes an action that cannot be canceled, the Cancel button changes to the Close 
button.

The Close button closes the dialog box without reversing any completed changes.    You can also use the 
Close command on the Control menu in the upper-left corner of the dialog box.

The Tab, Space bar, and arrow keys move the selection box in Command Line and Dialog boxes.

See Also:    Closing a Dialog Box, Typing and Editing in Dialog Boxes, Selecting Options in a Dialog Box, 
Selecting an Item in a List in a Dialog Box



Using Arrow Keys
If you are not using a mouse, you can select menus by pressing Alt and the arrow keys. Once a menu is 
pulled down, you can choose the command you want by pressing the arrow keys.    You can choose a 
command from the menu by pressing Enter.

See Also:    Controlling the Cursor



Mouse Techniques
The following table provides a review of basic mouse techniques you will need to know to work in 
DesignCAD.    For more information and practice using these skills, see the documentation that came with
your mouse.

To Do This
Point Position the mouse pointer on or next to something.
Click Position the pointer then quickly press and release the left 

mouse button.
Double-click Position the pointer then quickly press and release the left 

mouse button twice.
Drag Position the pointer.    Press and hold the left mouse button as 

you move the mouse to the desired position.    Then release the
button.

Middle mouse button
Sometimes when you select a DesignCAD command you will need to press Enter.    If you have a three-
button mouse, you can press the middle button for the Enter key.

Setting points
The Preset Point Mode allows you to set points before selecting a command.    If the Preset Point Mode is
not active, you must select a command before setting the points required for the command.    For 
example, you can draw a line by selecting the Line command.    Then set the points for the line.

See Also:    Mouse Shortcuts



Selecting Entities with a Mouse
Selecting Entity
"Unselecting" an Entity
Selecting Several Entities
Selecting All Entities
Selecting Last Entity Selected
Selecting Certain Entities



Selecting an Entity with the Mouse
Activate the Select Mode in the Toolbox.
Move the pointer near the entity.
Click the left mouse button.

"Dragging" the selection box
Activate the Select Mode in the Toolbox.
Move the pointer to the corner of the entity.
Press and hold down mouse button.
Drag the selection window until the entity is enclosed.
Release the mouse button.

See Also:    Using the Mouse, Mouse Techniques



Unselecting an Entity with the Mouse
If you select an entity by mistake, press the Shift key and select the entity again.

-or-
Click outside the highlighting box.

See Also:    Using the Mouse, Mouse Techniques



Selecting Several Entities with the Mouse
Selecting several entities one at a time

Activate the Select Mode in the Toolbox.
Select the first entity.
Press Shift while selecting other entities.

Selecting several entities in same area with Enclose mode
Activate the Select Mode in Toolbox.
Move the pointer to the corner of the first entity.
Press and hold down the left mouse button.
Drag the mouse until the selection window includes all the entities to be selected.
Release the mouse button.

Selecting several entities in same area with Touch mode
Activate the Select Mode in Toolbox.
Move the pointer to the corner of the first entity.
Press and hold down Ctrl and the left mouse button.
Drag the mouse until the selection window includes all the entities to be selected.
Release the mouse button.

See Also:    Using the Mouse, Mouse Techniques



Selecting All Entities with Mouse
Choose the Select All command from the Edit menu.

See Also:    Using the Mouse, Mouse Techniques



Selecting Last Entity Selected with Mouse
Choose the Select Previous command from the Edit menu.

See Also:    Using the Mouse, Mouse Techniques



Selecting Certain Entities with Mouse
Choose Entity Select from the Edit menu.
Click the check box next to the entity types you want to select.
Click the OK button.

See Also:    Using the Mouse, Mouse Techniques



Moving Vertically and Horizontally
The mouse can be forced to move horizontally by pressing Ctrl+Alt.    Pressing Shift+Alt forces the 
mouse to be moved vertically.

See Also:    Using the Mouse



Digitizer Techniques
The digitizer moves the cursor, or pointer, sets points, and chooses DesignCAD commands.

To Do This
Point Position the pointer on or next to something.
Click Position the pointer then quickly press and release the button.
Double-click Position the pointer then quickly press and release the button twice.
Drag Position the pointer.    Press and hold the button as you move the cursor to the desired 

position.    Then release the button.

Setting points
The Preset Point Mode allows you to set points before selecting a command.    If the Preset Point Mode is
not active, you must select a command before setting the points required for the command.    For 
example, you can draw a line by selecting the Line command.    Then set the points for the line.

See Also:    Using a Digitizer



Selecting Entities with a Digitizer
Selecting an Entity with Digitizer
"Unselecting" an Entity with Digitizer
Selecting Several Entities with Digitizer



Selecting an Entity with Digitizer
Activate the Select Mode in the Toolbox.
Move the pointer near the entity.
Click the first digitizer button.

"Dragging" the selection box
Activate the Select Mode in the Toolbox.
Move the pointer to the corner of the entity.
Press and hold down the digitizer button.
Drag the selection window until the entity is enclosed.
Release the digitizer button.

See Also:    Using a Digitizer, Digitizer Techniques



Unselecting an Entity with Digitizer
If you select an entity by mistake, press the Shift key and select the entity again.

-or-
Click outside the highlighting box.

See Also:    Using a Digitizer, Digitizer Techniques



Selecting Several Entities with Digitizer
Selecting several entities at a time

Activate the Select Mode in the Toolbox.
Select the first entity.
Press Shift while selecting other entities.

Selecting several entities in same area with Enclose mode
Activate the Select Mode in Toolbox.
Move the pointer to the corner of the first entity.
Press and hold down the first digitizer button.
Drag the digitizer until the selection window includes all the entities to be selected.
Release the digitizer button.

Selecting several entities in same area with Touch mode
Activate the Select Mode in Toolbox.
Move the pointer to the corner of the first entity.
Press and hold down Ctrl and the first digitizer button.
Drag the digitizer until the selection window includes all the entities to be selected.
Release the digitizer button.

See Also:    Using a Digitizer, Digitizer Techniques



Selecting Commands with a Digitizer
If you have a digitizer, you can choose commands from the Command Menu.    To choose a drawing 
command, move the digitizer cursor, or stylus,    to that menu and press the first button on the cursor.

Selecting Open command
Choose File menu.
Choose Open command.

-or-
Choose Open command on Command Line.

See Also:    Using a Digitizer, Digitizer Techniques



Using a Digitizer
DesignCAD supports many different digitizers, also called graphics tablets and digitizing tablets.

The digitizer moves the cursor, or pointer, sets points, and enters DesignCAD commands.    To move the 
pointer, merely move the stylus or cursor around the digitizer.    The DesignCAD pointer will move around 
the screen in the same way.

Your digitizer may have either a stylus, a pen-like device; or a cursor, also called a puck.    Depressing a 
stylus onto the digitizer sets a point.    Pressing the button or barrel switch on a stylus sets a gravity point.

See Also:    Digitizer Techniques, Selecting Commands with a Digitizer, Selecting Entities with a Digitizer



Selecting Commands with a Mouse
If you have a mouse, you can move the pointer to a menu in the Command Menu.
You can use the mouse or the arrow keys to move the highlight bar up and down the menus to choose a 
command.

You can use the mouse to choose a command from the Command Menu.

Selecting a command
Point to a menu, then click the left mouse button.
Point to a command in the menu, then click the left mouse button.

-or-
Point to a command in the Toolbox, then click the left mouse button.

-or-
Point to a command in the Command Line, then click the left mouse button.

See Also:    Mouse Shortcuts, Using a Mouse, Mouse Techniques



BasicCAD Programming Language
The following is an alphabetic list of all BasicCAD statements and functions.

-A-

ANYKEY Statement
Assignment Statement

-C-

CHAIN Statement
CLEAR Statement
CLOSE Statement
CLS Statement
COLOR Statement

-D-

DIM Statement
DO WHILE Statement

-E-

END Statement
ENTITY Statement
EXIT DO Statement
EXIT FOR Statement

-F-

FOR ... NEXT Statement

-G-

GET ATTR Statement
GET Statement
GET XY Statement
GOSUB Statement
GOTO Statement

-I-

IF (Group) Statement
IF (single line) Statement
INPUT Statement
INPUT# Statement

-L-

LABELS Statement
LAYER Statement
LOCATE Statement
LOOP Statement



-M-
MESSAGE Statement

-O-

ON ERROR Statement
OPEN Statement

-P-

POINTVAL Statement
PRECISION Statement
PRINT # Statement
PRINT Statement
PUT Statement
PUTATTR Statement

-R-

REGEN Statement
RESUME Statement
RETURN Statement
RUN Statement

-S-

SET POINT Statement
STOP Statement

-T-

TAB Statement

-W-

WCLOSE Statement
WINDOW Statement

Built-In Functions:
SYS Function
SYS$ Function

DesignCAD Commands in Program:
ENCRYPT Utility



Assignment Statement
Use the Assignment statement to assign a value to a numeric variable.

Syntax:
variable = expression
stringvar = expressionlist

Variable can be any numeric variable name.    Expression can be any valid numeric expression.    
Stringvar is any valid string variable name.    Expressionlist is one or more string or numeric expressions 
separated by commas.    Numeric expressions can be assigned to a string - they are evaluated and 
converted to ASCII format.    Using more than one expression allows you to concatenate strings.



ANYKEY Statement
Use the ANYKEY statement to wait for a single key press.    This statement waits for and reads a 
keystroke from the keyboard.    This statement can be used with or without a variable.    If a variable is 
used, the value of the key pressed is assigned to that variable.    String variables or numeric variables can
be used.    If a numeric variable is used, the ASCII code for the keystroke is assigned to the variable.

This statement is useful if you want to pause for a keypress after printing to the bottom of the screen or a 
text window.

Syntax:
ANYKEY {variable}



CHAIN Statement
Use the CHAIN statement to transfer control to another BasicCAD program.    This statement is used to 
run another BasicCAD program, leaving all the variables from the current program intact when the other 
program is executed.    A string variable or constant can be used for the program name.

The CHAIN statement causes the new program (programname) to replace the current program in 
memory.    To return to the original program, you must execute another CHAIN or RUN statement from the
new program.    The execution of a program called by the CHAIN statement always begins at the first line 
in the called program.

The RUN statement is similar to the CHAIN statement, but the RUN statement clears all variables before 
executing the new program.

Syntax:
CHAIN programname

See Also:    RUN Statement



CLEAR Statement
Use the CLEAR statement to erase all variables in the program.    This statement is used to erase and de-
allocate all variables in the program.    It can be used to free memory or to re-initialize variables.

Syntax:
CLEAR



CLOSE Statement
Use the CLOSE statement to close a disk file.    This statement is used with the OPEN statement.    If a 
disk file has been opened for input or output, it should be closed after being used.

A disk file left open when the program ends is automatically closed.    However, the CLOSE statement 
must be used to close an open file before that file number if used again.

Syntax:
CLOSE {filenumber}

Filenumber is the number of the file to be closed.    If it is omitted, all open files will be closed.



CLS Statement
Use the CLS statement to clear a text window.    This statement clears all the text inside the text window.   
If a text window is not open, then this statement has no effect.

Syntax:
CLS

See Also:    WINDOW Statement



COLOR Statement
Use the COLOR statement to set the text color in a text window.    This statement is used to set the color 
of the text in a text window.    The COLOR statement affects only the text displayed with PRINT 
statements after the COLOR statement is executed.    The text color remains set at the specified color 
until the next COLOR statement is executed.

Syntax:
COLOR foreground {,background}

Foreground is the foreground color for the text.    Background is the background color.    The colors can 
range from 0 to 255.



DIM Statement
Use the DIM statement to specify the size of one or more arrays.    The DIM statement is used to allocate 
storage for arrays.    An array is a single variable with several elements, addressed with a subscript in 
parentheses such as A(20).

An array must be dimensioned before it is used.    Any numeric expression can be used for the array size. 
String arrays are allowed.    All arrays are one-dimensional - that is, an array can have only one subscript.

An array cannot be re-dimensioned.    A DIM statement must be executed only once.    A variable array 
must be dimensioned before the variable is used.

Syntax:
DIM variable (expression) {,variable(expression)...}



DO WHILE Statement
Use the DO WHILE statement with a LOOP statement to execute a series of instructions in a loop.

The DO WHILE statement is used to start a loop that will be executed as long as the logical expression 
logexpression is true.    When a LOOP statement is encountered, program execution is transferred back to
the DO WHILE statement and the logical expression is checked again.    When the expression is false, 
execution continues after the LOOP statement.

The logical expression consists of one or more relational expressions separated by AND or OR.    A logical
expression can also be preceded by NOT.

A relational expression consists of two numeric or string expressions separated by one of the following 
relational operators:    <, <=, =, >=, >, <>.

When using a DO loop, be sure the logical expression will eventually change to False, or the loop will 
never end.    (Any BasicCAD program can be terminated by pressing the Esc key, however.

DO WHILE loops can be nested up to eight levels deep.

Syntax:
DO WHILE logexpression
.
.
.
LOOP



LOOP Statement
Use the LOOP statement with a DO WHILE statement to execute a series of instructions in a loop.

The DO WHILE statement is used to start a loop that will be executed as long as the logical expression 
logexpression is true.    When a LOOP statement is encountered, program execution is transferred back to
the DO WHILE statement and the logical expression is checked again.    When the expression is false, 
execution continues after the LOOP statement.

The logical expression consists of one or more relational expressions separated by AND or OR.    A logical
expression can also be preceded by NOT.

A relational expression consists of two numeric or string expressions separated by one of the following 
relational operators:    <, <=, =, >=, >, <>.

When using a DO loop, be sure the logical expression will eventually change to False, or the loop will 
never end.    (Any BasicCAD program can be terminated by pressing the Esc key, however.

DO WHILE loops can be nested up to eight levels deep.

Syntax:
DO WHILE logexpression
.
.
.
LOOP



END Statement
Use the END statement to terminate the program and return to DesignCAD.    The END statement can be 
placed anywhere in the program.    An END statement at the end of the program is optional.    This 
statement does the same thing as the STOP statement.

Syntax:
END

See Also:    STOP Statement



ENTITY Statement
Use the ENTITY statement to access an entity in the drawing by entity number.    The ENTITY statement 
is used to read an entity into the SYS function variables 90-99, and set points on the screen for each point
of the entity.    This makes it possible to process all entities in the drawing.

Syntax:
ENTITY expression



EXIT DO Statement
Use the EXIT DO statement to exit a DO loop prematurely.    This statement can be used to exit a DO loop
from anywhere within the loop.    This makes it easy to exit a DO loop without using a label and a GOTO 
statement.

Syntax:
EXIT DO



EXIT FOR Statement
Use the EXIT FOR statement to exit a FOR NEXT loop prematurely.    This statement can be used to exit 
a FOR-NEXT loop from anywhere within the loop.    This makes it easy to exit a FOR-NEXT loop without 
using a label and a GOTO statement.

Syntax:
EXIT FOR



FOR ... NEXT Statement
Use the FOR...NEXT statement to execute a section of the program a certain number of times.    

The program statements after the FOR statement and before the NEXT statement are called the loop.    
Each time the loop is executed, the counter is incremented.    If it is greater than the test value, the loop is 
exited and the program branches to the line following the NEXT statement.    (If the STEP expression is 
negative, then the loop is exited when the counter is less than then test value.)

FOR-NEXT loops can be nested, that is, one FOR-NEXT loop can be placed inside another.    The FOR-
NEXT loops can be nested up to 8 levels deep.

Syntax:
FOR variable = expression TO expression {STEP expression}

The variable is used as the counter.    The first expression is the initial value of the counter variable.    The 
second expression, after TO, is the test or final value of the counter.    The optional STEP expression can 
be used to specify the amount that the counter is incremented each iteration.



GET Statement
Use the GET statement to read a record from a random access file.    The record length is specified in the 
OPEN statement.

When the GET statement is executed, the designated record (recordnumber) of the file will be read into 
the string variable (stringvar).    The MKS$ and the CVS functions can be used to convert numeric values 
to and from four-byte strings file input and output.

Syntax:
GET file, recordnumber, stringvar



GETATTR Statement
Use the GETATTR statement to get entity type, group status, and layer of an entity.

Syntax:
GETATTR entity, type {,select, layer, group, color}

Entity is the entity number - 1 for the first entity in the drawing, 2 for the second, etc.    Type is the entity 
type, as shown:

1 = Line
2 = Oval
3 = Text
4 = Curve
5 = Arc
11 = Bezier Curve
15 = Attribute
16 = Circle, Circular Arc
17 = Hatch
21 = New Layer
22 = Text Arc
23 = Layer Names
24 = Arrow
26 = Symbol
31 = Plane
32 = Grid
33 = Grid Line
70 = Point Mark
74 = Dimension, Angle
75 = Dimension 
76 = Dimension, Diameter/Radius
77 = Dimension, Arc
78 = Dimension, Radius Progressive
79 = Dimension, Progressive
80 = Dimension, Chamfer
81 = Dimension, Coordinate
90 = Bitmap Image

Select is 0 if the entity is not selected, or 1 if the entity is currently selected.    Layer is the layer number of 
the entity.    Group is the group ID number if the entity is part of a Group, or 0 otherwise.    Color is the 
color of the entity.

Type, select, layer, group, and color must be BasicCAD variables, not expressions, since they will be 
assigned values.



GETXY Statement
Use the GETXY statement to get the X and Y coordinates of the current cursor position.    This statement 
can be used to assign the X and Y coordinates of the current cursor position to two variables.    It is very 
useful in getting the "current" position to provide a reference location for the rest of the program.

Syntax:
GETXY variable variable {variable}



GOSUB Statement
Use the GOSUB statement to call a subroutine.    This statement is used to transfer program execution to 
another statement out of the normal sequence of execution, and resume execution after the GOSUB 
statement when a RETURN statement is encountered - it calls a subroutine.    A RETURN statement must
be used to return from a subroutine called by a GOSUB statement.

Syntax:
GOSUB label
RETURN

Label can be any valid BasicCAD label.



RETURN Statement
Use the RETURN statement to return from a subroutine called by a GOSUB statement.

Syntax:
GOSUB label
RETURN

Label can be any valid BasicCAD label.



GOTO Statement
Use the GOTO statement to branch to another statement.    This statement is used to transfer program 
execution to another statement out of the normal sequence of execution.

Syntax:
GOTO label

Label can be any valid BasicCAD label.



IF (single line) Statement
Use the IF statement to execute a BasicCAD statement under certain conditions.    The logical expression 
consists of one or more relational expressions separated by AND or OR.    A logical expression can also 
be preceded by NOT.

A relational expression consists of two numeric or string expressions separated by one of the following 
relational operators:    <, <=, =, >=, >, <>.

Syntax:
IF logexpression THEN statement

Logexpression is a logical expression that can be answered true or false.    If the expression is true, then 
the statement is executed; otherwise, it is not.



IF (Group) Statement
Use the IF statement to execute a set of BasicCAD statements under certain conditions.    The ELSE 
section is optional, but the END IF is required.

The logical expression consists of one or more relational expressions separated by AND or OR.    A logical
expression can also be preceded by NOT.

A relational expression consists of two numeric or string expressions separated by one of the following 
relational operators:    <, <=, =, >=, >, <>.

With the Group IF statement, the IF statement line must end with the word THEN (except for comments).  
In contrast, the single-statement IF must have the conditionally executed statement following the word 
THEN on the same line.

Syntax:
IF logexpression THEN 
statements
.
.
{ELSE
statements
.
.}
END IF

Logexpression is a logical expression that can be answered true or false.    If the expression is true, then 
the first set of statements is executed, otherwise the second set is executed.    



INPUT Statement
Use the INPUT statement to read a value from the keyboard and assign it to a variable.    This statement 
is used to ask the user for input and assign the entered value to a variable.    

If a single string variable is used, the entire string input from the keyboard is assigned to the variable.

If numeric variables are used, the numbers input from the keyboard are assigned to the corresponding 
variables.

If more than one variable is used with the INPUT statement, any strings input should be enclosed in 
quotes (" ").

Values read with the INPUT statement can be any valid BasicCAD expressions - they do not have to be 
simple constants.    For example, the user can enter SQRT(2) or 45/2 when a number is requested.

Syntax:
INPUT string, variable list
INPUT variable list

String is an optional message to be displayed for the user.    Variable list is one or more variables, 
separated by commas, to which the input values are to be assigned.



INPUT# Statement
Use the INPUT # statement to read a line from a disk file and assign it to a variable.    This statement is 
used to read a line from a disk file and assign it to a numeric variable or to a string variable.    The INPUT 
statement reads an entire line from the disk file.

When this statement is executed, a line from the file is read and a value is assigned to each variable.    If 
the line from the file has fewer values than there are variables, the leftover variables are not modified.

Strings values in the file should be enclosed in quotes if there are multiple values on a line.    If an entire 
line from the file is to be read into a single string variable, use a single string variable with the INPUT # 
statement.

Values read can be any valid BasicCAD expressions - they do not have to be simple constants.

The file must have been opened using the OPEN statement before the INPUT # statement is executed.    
The BasicCAD function (file) can be used to determine whether the end-of-file has been reached.

Syntax:
INPUT # file, variablelist

File is the file number that was used in the OPEN statement.    Variablelist is a set of one or more 
variables separated by commas.    The variables can be string or numeric variables.



LAYER Statement
Use the LAYER statement to turn drawing layers on or off, and to set the current layer.    This statement 
can be used to set a layer to be visible/invisible or editable/uneditable.    It can also be used to set the 
current layer.    The following values can be used with the Layer command:

0 -- Invisible and not editable
2 -- Visible but not editable
4 -- Editable but invisible
6 -- Visible and editable
14 -- Set as current layer

The first expression is the layer number, and the second expression must be one of the above values.    
The LAYER function can be used to get the current status of a layer.    See the BasicCAD function 
descriptions in this manual.

The REGENERATE statement should be used to regenerate the drawing if the visibility of layers has 
been changed.    Otherwise, entities from invisible layers may remain on the screen, and entities from 
visible layers may not appear on the screen.

Syntax:
LAYER (expression) = expression



LOCATE Statement
Use the LOCATE to position the cursor in a text window.    This statement positions the cursor in the text 
window that was opened by the WINDOW statement.    The next PRINT or INPUT statement will begin at 
the specified row and column.

This statement has no effect if a text window is not open.

Syntax:
LOCATE row, column

See Also:    WINDOW Statement



MESSAGE Statement
Use the MESSAGE statement to output data to the screen.    This statement is used to output numeric 
and/or string expressions to the DesignCAD screen.    It is similar to the PRINT statement, except that a 
dialog box is opened for each message statement, and the program pauses until the user presses the OK
button.    This command uses the Windows Message Box function.

If more that one line is to be output, chr$(13) can be included in the output expressions.

Syntax:
MESSAGE {list of expressions}



ON ERROR Statement
Use the ON ERROR statement to set up an error handling routine.    After the ON ERROR has been 
executed, any BasicCAD error will cause the execution to be transferred to the specified label.    Program 
execution will continue there until a RESUME statement is encountered.

This statement is used to trap errors in a program.    The ERR function can be used to determine the error
code.

Syntax:
ON ERROR GOTO label

See Also:    RESUME Statement



OPEN Statement
Use the OPEN statement to open a file for input or output for the INPUT #, PRINT #, GET, or PUT 
statements.

A file must be opened before it is accessed by the INPUT # or PRINT # statements.    To open a file for 
sequential input, use the "I" parameter before the file name.    To open a file for sequential output, use "O".
(This is the letter O, not the number zero.)    You can use "A" to append data to a file - this is like "O," but if
the file exists, data will be output to the end of the file.

To open a file for random access (for GET and PUT), use "R."    If random access is specified, then the 
record length must also be specified.    This value represents the number of bytes that will be read or 
written with the GET and PUT statements.

Syntax:
OPEN "A", filenumber, filename
OPEN "I", filenumber, filename
OPEN "O", filenumber, filename
OPEN "R", filenumber, filename, recordlength

Printer output can be specified for the file name in order to output to the printer.    However, LPT1 can be 
used only for output, with OPEN "O".

The filenumber can be from one to four.    Up to four files can be opened at one time.    Filename can be 
any valid DOS file name, including the path.



POINTVAL Statement
Use the POINTVAL statement to assign the coordinates of one of the points that has been set to two 
variables.    The two variables will be assigned the X and Y coordinates of a point that has been set in 
DesignCAD.    A third variable can be used for the Z coordinate, for 3-D applications.    The expression 
determines which point will be assigned to the variables.    The number of points currently set can be 
determined in the system function SYS(1).    An error will occur if expression is greater than the number of
points set, SYS(1).

Syntax:
POINTVAL variable variable {variable} expression



PRECISION Statement
Use the PRECISION statement to set the precision for PRINT statements and for numeric-to-string 
conversion.    This statement determines the number of digits to the right of the decimal point to be used in
PRINT statements and in numeric-to-string conversions.

For example, a precision of zero can be used to print or assign only whole numbers.    A precision of four 
can be used to print numbers to the nearest .0001 .

The PRECISION statement affects only the conversion of an expression - it does not affect the value of a 
numeric variable.

The precision remains the same until it is changed again by the PRECISION statement.

Syntax:
PRECISION expression



PRINT Statement
Use the PRINT statement to output data to the screen.    This statement is used to output numeric and/or 
string expressions to the DesignCAD screen.    It is identical to the PRINT # statement, except that the 
data is output to the screen rather than to disk.

Only one line of output can be displayed at a time, unless a text window is open.    If more that one line is 
to be output, the print statements can be separated by ANYKEY statements.    This requires the user to 
press a key before the next line is displayed.

If a text window is open, the PRINT statement will be displayed in the window.    The LOCATE and TAB 
statements can be used to position the output for the window.

The PRINT statement can be terminated with a semicolon (";") to leave the cursor at the end of the line of 
a text window.    The next PRINT statement will begin at that location.

The MESSAGE statement is similar to the PRINT statement, but the MESSAGE statement opens a dialog
box for the message, and the user must press the OK button to continue after the message is displayed.

Syntax:
PRINT {list of expressions}

See Also:    WINDOW Statement



PRINT# Statement
Use the PRINT # statement to output data to a disk file.    This statement is used to output numeric and/or 
string expressions to a disk file.    It is identical to the PRINT statement, except the data is output to disk 
rather than the screen.

The file must have been opened using the OPEN statement before this statement is executed.    Numeric 
expressions are output in ASCII format.    A carriage-return and line-feed are output after each PRINT # 
statement.

The PRINT # statement can be used to output to a printer by opening the file LPT1 with the OPEN 
statement.    If no expressions are used with a PRINT # statement, then a blank line is output.

Syntax:
PRINT # file, {list of expressions}

File is the file number that was used in the OPEN statement.



PUT Statement
Use the PUT statement to output a record to a random access file.    The record length is specified in the 
OPEN statement.

When the PUT statement is executed, the string (stringvar) will be written to the file at the designated 
record (recordnumber).

If the string to be output is less than the record length, it will be padded with undefined characters.    If the 
string is longer than the record length, it will be truncated.

The MKS$ and the CVS functions can be used to convert numeric values to and from four-byte strings file
input and output.

Syntax:
PUT file, recordnumber, stringexpression



PUTATTR Statement
Use the PUTATTR statement to set the entity type, group status, and layer of an entity.    The specified 
entity will be assigned the specified attributes.

Syntax:
PUTATTR entity, type, {select, layer, group, color}

Entity is the entity number - 1 for the first entity in the drawing, 2 for the second, etc.

Type is the entity type, as shown:

1 = Line
2 = Oval
3 = Text
4 = Curve
5 = Arc
11 = Bezier Curve
15 = Attribute
16 = Circle, Circular Arc
17 = Hatch
21 = New Layer
22 = Text Arc
23 = Layer Names
24 = Arrow
26 = Symbol
31 = Plane
32 = Grid
33 = Grid Line
70 = Point Mark
74 = Dimension, Angle
75 = Dimension 
76 = Dimension, Diameter/Radius
77 = Dimension, Arc
78 = Dimension, Radius Progressive
79 = Dimension, Progressive
80 = Dimension, Chamfer
81 = Dimension, Coordinate
90 = Bitmap Image

Select is zero if the entity is not to be selected, and one if the entity is to be selected.    Layer is the layer 
number to be assigned to the entity.    Group is the group ID number if the entity is to become part of that 
Group, or zero if it is not to be part of a Group.    Color is the color for the entity.



REGEN Statement
Use the REGEN statement to regenerate the drawing on the screen.    This statement performs the same 
function as the DesignCAD Zoom command with a zoom factor of one, and no points set.

Drawing regeneration may be necessary after changing layers with the BasicCAD LAYER statement, or 
after assigning values to the SYS function.    In addition, it is sometimes useful to regenerate the drawing 
after parts of the drawing have been erased.

Syntax:
REGEN



RESUME Statement
Use the RESUME statement to resume program execution after an ON ERROR statement.    This 
statement is used to continue program execution after an ON ERROR unit has activated by a BasicCAD 
error.

Syntax:
RESUME {label}

Label can be used to specify the location at which program execution will resume.    If the label is omitted, 
the program execution will resume at the statement following the statement that caused the error.

See Also:    ON ERROR Statement



RUN Statement
Use the RUN statement to transfer control to another BasicCAD program.    This statement can be used to
run another BasicCAD program or a COM or EXE program from within your BasicCAD program.

Running another BasicCAD program with the Run statement
When this statement is used to run another BasicCAD program, all the variables from the current program
are cleared when the other program is executed.    A string variable or constant can be used for the 
program name.

The RUN statement causes the new program (programname) to replace the current program in memory.   
To return to the original program, you must execute another RUN or CHAIN statement from the new 
program.    The execution of a program called by the RUN statement always begins at the first line in the 
called program.

If the file extension of the BasicCAD program is omitted, .BSC will be used.    To use an encrypted 
BasicCAD program, specify the extension .BSX .

The CHAIN statement is similar to the RUN statement, but the CHAIN statement leaves all variables 
intact when the new program is executed.

Running a COM or EXE program with the Run statement
To run a program from within BasicCAD, just specify the program name with the Run statement.    For 
example, 

run "edit.com"

will run the DOS editor EDIT.    The BasicCAD program will continue to run while EDIT.COM is being 
executed.

With the Run statement, you can run both DOS and Windows applications.

Syntax:
RUN programname



SETPOINT Statement
Use the SET POINT statement to require the user to set a number of points.    This statement displays the
message in string, and allows the user to set a number of points.

Expression is the number of points to be set.    The user can press Enter or Esc before all the points are 
set.    The system function SYS(1) is the current number of points set - it can be checked to determine if 
enough points were set.

Syntax:
SETPOINT string expression



STOP Statement
Use the STOP statement to terminate the program and return to DesignCAD.    The STOP statement can 
be placed anywhere in the program.    A STOP statement at the end of the program is optional.    This 
statement does the same thing as the END statement.

Syntax:
STOP

See Also:    END Statement



TAB Statement
Use the TAB statement to move the cursor in a text window to a certain column.    The next PRINT 
statement will begin at that column.

If the new column is less than the current column, the cursor will move to the next line.    The average 
character width of the current font is used to calculate character columns, since in Windows different 
characters may have different widths.

Syntax:
TAB column



WCLOSE Statement
Use the WCLOSE statement to close the text window or dialog box.    The drawing behind the text window
will be replaced.

A text window that is opened by the WINDOW command remains on the screen until it is closed or until 
the program terminates.

Syntax:
WCLOSE

See Also:    WINDOW Statement



WINDOW Statement
Use the WINDOW statement to open a window or dialog box for subsequent PRINT statements.    This 
statement opens a text window, or dialog box on the screen.

As long as the text window is open, all PRINT statements are displayed in the window.    The text window 
remains open until a WCLOSE statement is executed or until the program terminates.

The CLS, LOCATE, and TAB statements can be used to clear the screen and position the cursor in the 
text window.    The COLOR statement can be used to set the text color inside the window.

Only one text window can be opened at a time.

Syntax:
WINDOW nrows, ncols

Nrows and ncols are the number of rows and columns for the text window - they determine the window 
size.



LABELS Statement
Use the LABELS statement to provide a reference to locations in the program for GOTO statements.

Syntax:
labels:

Labels can be up to seven characters long, may consist of letters and numbers, and must begin with a 
letter.    A BasicCAD statement can optionally follow a label on a line.



SYS Function
The SYS function returns the value of a DesignCAD System Variable.    The variable returned is 
determined by the value of the argument.    This function is described below.

The SYS function represents many different DesignCAD system variables.    SYS(1), for example, is the 
number of points set, and SYS(3) is the current layer.    A list of the available SYS variables follows.

1 - Number of points set
3 - Current layer
4 - Current line type
5 - Line type scale
6 - Current line width
7 - Current precision
9 - Number of entities in the drawing

10 - Units of measurement for display - 1=inches, 2.54=cm.
11 - Units per inch on output.
12 - Default text size
13 - Default text angle
14 - Display grid type
15 - Display grid enable/disable
17 - Snap grid on or off
19 - Display grid size
20 - Snap grid size
21 - Attribute display enable/disable
22 - Save parameters with drawing, enable/disable
23 - Mathematical or geographical angles
24 - Fill wide lines enable/disable
25 - Sound on/error only/off
26 - Manipulate current layer only
27 - Status line format
29 - Point type
30 - Large cursor step size
31 - Small cursor step size

32 - Drawing unit size
34 - Returns 1 if entities are selected, 0 otherwise.    If SYS(34) is set to 0, any selected entities are 

deselected.
35 - Number of sides in the rubber band polygon
36 - Silent mode (1 for silent, 0 for normal)
37 - Cursor step consistent with Screen or Drawing
38 - Text mirror disable
39 - Point mark type

40 - Crosshair enable/disable
41 - Rubber band line enable/disable

60 - Tick mark segments
61 - Tick mark segment division
62 - Text horizontal scale

Functions 90-99 are values for an entity just selected with the Entity statement.
90 - Entity type
91 - Entity line type



92 - Entity color
93 - Entity layer
94 - Group Number (Solid number in DesignCAD 3-D)
96 - 128 or greater if entity is selected.
97 - Line type scale.
98 - Line thickness
99 - Number of points

101 - Dimension type
103 - Tolerance enable/disable
104 - Arrowhead type
106 - Dimension precision

120 - Minimum X value in the drawing.
121 - Minimum Y value in the drawing.
122 - Maximum X value in the drawing.
123 - Maximum Y value in the drawing.

134 - Printer top margin
135 - Printer bottom margin
136 - Printer left margin
137 - Printer right margin

150 - Angle mode - 0=degrees, 1=grads, 2=radians, 3=degrees-minutes-seconds, 4=bearings.
151 - Distance mode - 1=normal, 2=fractions, 3=feet-inches.
152 - Scale drawings on retrieval and copy option

181 - Number of available BasicCAD symbols.

190 - Handle 1 X value
191 - Handle 1 Y value
192 - Handle 2 X value
193 - Handle 2 Y value

300 - Current drawing color, Red      value.
301 - Current drawing color, Green value.
302 - Current drawing color, Blue    value.
303 - Hatch pattern color,      Red      value.
304 - Hatch pattern color,      Green value.
305 - Hatch pattern color,      Blue    value.
306 - Rubber band color,          Red      value.
307 - Rubber band color,          Green value.
308 - Rubber band color,          Blue    value.
309 - Grid color,                        Red      value.
310 - Grid color,                        Green value.
311 - Grid color,                        Blue    value.

312 - Point color,                      Red      value.
313 - Point color,                      Green value.
314 - Point color,                      Blue    value.
315 - Highlight color,              Red      value.
316 - Highlight color,              Green value.
317 - Highlight color,              Blue    value.
318 - Dimension color,              Red      value.
319 - Dimension color,              Green value.
320 - Dimension color,              Blue    value.



321 - Background color,            Red      value.
322 - Background color,            Green value.
323 - Background color,            Blue    value.
324 - Foreground color,            Red      value.
325 - Foreground color,            Green value.
326 - Foreground color,            Blue    value.
327 - Entity point color,        Red      value.
328 - Entity point color,        Green value.
329 - Entity point color,        Green value.
330 - Background color.

401 - Angular        dimension prefix
402 - Linear          dimension prefix
403 - Radius          dimension prefix
404 - Diameter      dimension prefix
405 - Chamfer        dimension prefix
406 - Coordinate dimension prefix

407 - Angular        dimension suffix
408 - Linear          dimension suffix
409 - Radius          dimension suffix
410 - Diameter      dimension suffix
411 - Chamfer        dimension suffix
412 - Coordinate dimension suffix

413 - Dimension layer
415 - Linear text location
416 - Linear text position
417 - Angular text position
418 - Linear text direction
419 - Angular text direction
421 - Extended text type
424 - Linear text type
425 - progressive text direction
428 - angular dimension type
433 - Angular dimension precision
437 - Line connecting inward arrows
438 - Dimension text size 
439 - dimension text horizontal scale
440 - dimension text slant
441 - dimension tolerance text size
442 - overshoot of Dimension extension lines
443 - gap of Dimension extension lines
444 - length of Dimension extension lines
445 - arrow size
446 - balloon size
447 - Dimension line offset for baseline dimension
450 - Dimension arc prefix 
451 - Dimension arc suffix
452 - Radius dimension text position
453 - Dimension text position
454 - Dimension text position
455 - Chamfer dimension text position
456 - Radius dimension text direction
457 - Dimension text direction
458 - Linear dimension text direction



459 - Chamfer dimension text direction
460 - Dimension arrowhead type
462 - Dimension arrowhead scale

To use the SYS function in a BasicCAD program, use it like you would any other function.

The SYS function is different from the other BasicCAD functions in that you can assign a value to a SYS 
variable.    In other words, you can use the SYS function on the left side of the equal sign in an 
assignment statement.    

SYS variables nine (the number of entities in the drawing) and 90-93 (entity characteristics) cannot be 
modified by assigning a value to the SYS function - they are read-only variables.

When some of the SYS variables are modified, the DesignCAD drawing screen should be regenerated 
with the REGEN statement or the DesignCAD Zoom command.    BasicCAD does NOT check for valid 
SYS assignments or screen regeneration - if you change the SYS variables, your BasicCAD program is 
responsible for all validity checking.

The SYS variables 90-93 can be used together with the BasicCAD ENTITY statement to read the entity 
type, color, line type, and layer of the entity referred to by the last ENTITY statement.



SYS$ Function
The SYS$ function returns the value of a DesignCAD System Variable.    The variable returned is 
determined by the value of the argument.

The SYS$ function represents several different DesignCAD system variables, in string format.    SYS$, for
example, is the current path name.    A list of the available SYS$ functions follows:

1 - Entity text string.    This is the text from a Text or Attribute entity that was "loaded" with an ENTITY 
statement.

2 - Current drawing name.
5 - Current drive.
6 - Current path name.
7 - Current time.
8 - Current date.
9 - Command line parameter used with DesignCAD.
20 - DesignCAD drawing    path name
21 - DesignCAD symbol      path name
22 - DesignCAD bitmap      path name
23 - DesignCAD macro        path name
24 - DesignCAD BasicCAD path name
25 - DesignCAD view          path name
26 - DesignCAD color        path name
27 - DesignCAD DXF            path name
28 - DesignCAD IGES          path name
29 - DesignCAD HPGL          path name
30 - DesignCAD XY file    path name
31 - DesignCAD text          path name
33 - DesignCAD WPG            path name
34 - DesignCAD LST            path name

To use the SYS$ function in a BasicCAD program, use it like you would any other string function.



ENCRYPT Utility
ENCRYPT - BasicCAD Program Encryption Utility

If you write a BasicCAD program for distribution, it is possible that you do not want to distribute the source
code for your program.    Since BasicCAD programs are interpreted and do not have a separate 
executable format, the ENCRYPT utility has been provided to allow you to distribute your programs 
without distributing the source code.

BasicCAD programs have a file extension of .BSC, and encrypted BasicCAD programs have a file 
extension of .BSX.    Either form can be read and executed by DesignCAD.    To encrypt a program, enter 
ENCRYPT program where program is the name of your BasicCAD program (with a .BSC extension).    An
encrypted copy of your program will be created with an extension of .BSX .    The encrypted version can 
be executed, but since it is encrypted it cannot be listed, printed, or edited.

The Encrypt program should be run from the MS-DOS window, since it is a DOS application.

Encrypting a BasicCAD program makes no noticeable degradation in performance, as it does in other 
CAD languages.

Note:    The ENCRYPT program only encrypts programs - it does NOT decrypt, or un-encrypt.    BE SURE
TO KEEP A COPY OF YOUR SOURCE CODE!

Also, remember that NO ENCRYPTION METHOD IS UNBREAKABLE, and this one is no exception.    
American Small Business Computers makes no guarantee as to the security of the encryption methods 
used by the ENCRYPT program.



Error Messages
-A-
An error has occurred in your application.
Application Error:    WDC caused a General Protection Fault.

-C-
Current layer is always visible!

-E-
Error reading file.
Error writing file.

-F-
File was not found.

-I-
Insufficient memory.
Invisible layer cannot be edited!

-N-
No attribute entities for this drawing.
No entity was selected.
Not a DesignCAD color palette format.
Not a DesignCAD file format.

-P-
Please select entity to be modified first.
Please select line to be modified first.
Printer is out of paper or is not connected to your computer.
Printer out of paper.

-R-
Replace existing file?
Replace existing Macro?

-S-
Save current drawing?

-T-
The filename is not valid.

-U-
Unknown item.



An error has occurred in your application.
A problem has occurred in your application.

To correct this error
If you suspect insufficient memory, free some memory.



Application Error:    WDC caused a General 
Protection Fault.
An application error has occurred.

To correct this error
You must restart DesignCAD for Windows.



Current layer is always visible!
The current layer cannot be set to be "invisible."

To correct this error
Choose another layer to be the current layer.
Disable the Visible box.



Invisible layer cannot be edited!
A layer must be visible in order to be editable.

To correct this error
Choose the layer number.
Enable the Visible box.
Enable the Editable box.



No attribute entities for this drawing.
There must be attribute entities in the drawing for the Material List command to compile a materials list.

To correct this error
Add attributes to the drawing with the Attribute command.
Choose the Material List command.



Error reading file.
An error occurred reading the file.

To correct this error
Check the filename and path.
Open the file again.



Error writing file.
An error occurred writing the file.

To correct this error
Check the filename and path.
Save the file again.



File was not found.
The specified file was not found on the specified drive and/or directory.

To correct this error
Check the drive, directory, and file name of the file.



Insufficient memory.
There is not enough memory to perform the task.

To correct this error
Quit any other applications you are running.
Close any windows you do not need.



No entity was selected.
There were not any entities selected when a command was issued.    Some commands cannot be 
performed unless entities are selected.

To correct this error
Select the entities.
Select the command again.



Not a DesignCAD color palette format.
The file specified in the Load Color Table dialog box was not a color palette format.

To correct this error
Re-check the file extension.
Choose a file with the .PAL extension in the Color Table dialog box.



Not a DesignCAD file format.
The file specified was not a DesignCAD file.

To correct this error
Double-check the drawing file extension.
Choose a file with the .DW2 or .DC2 extension.



Please select entity to be modified first.
An entity was not selected before an editing command was chosen.

To correct this error
Choose the entity to be changed.
Choose the command.



Please select line to be modified first.
A line was not selected before an editing command was chosen.

To correct this error
Choose the line to be changed.
Choose the command.



Printer is out of paper or is not connected to your 
computer.
DesignCAD is trying to print a drawing and the printer is either out of paper or not connected.

To correct this error
Check the paper tray for the printer.

-or-
Check the printer connection.



Replace existing file?
The specified filename already exists.

To correct this error
Choose Yes to have the file saved with the current filename.

-or-
Choose No to return to the dialog.
Enter a new name for the file.



Replace existing Macro?
The specified macro name already exists.

To correct this error
Choose Yes to have the macro saved with the same macro name.

-or-
Choose No to return to the dialog box.
Enter a new name for the macro.



Save current drawing?
The Close or Exit command have been selected before the drawing has been saved.

To correct this error
Choose Yes to save the drawing.

-or-
Choose No to close the drawing without saving it.

-or-
Choose Cancel to return to the drawing without saving or closing it.



The filename is not valid.
An invalid filename has been entered for a drawing.

To correct this error
Check the filename and extension.



Unknown item.
DesignCAD has discovered an unknown item.

To correct this error
Repeat the command.



Printer out of paper.
DesignCAD is trying to print a drawing and the printer is either out of paper.

To correct this error
Check the paper tray for the printer.



Line Types
There are 13 line types available with DesignCAD.    These are:

Solid

Dashed
Hidden

Center
Phantom
Dotted

Dashdot
Border
Divide

Custom-1
Custom-2

Custom-3
Custom-4

See Also:    Changing Line Characteristics



Showing and Hiding Information
With DesignCAD, you can display information such as Toolboxes, the Command Line, and an Info Box.    
This information can also be "hidden" or removed temporarily from the screen so that the drawing area 
does not become cluttered.

Showing Main Toolbox
Showing Snap Toolbox
Showing Status Bar
Showing Symbol Toolbox
Showing Coordinate Bar
Showing Rulers
Showing Info Box
Hiding Main Toolbox
Hiding Snap Toolbox
Hiding Status Bar
Hiding Symbol Toolbox
Hiding Coordinate Bar
Hiding Rulers
Hiding Info Box



Position of Dimension Arrows
Dimension arrows can be drawn:

Inside the dimension extension lines

Outside the dimension extension lines

Setting the position of dimension arrows
After a Dimension command is selected, choose the Dimension Line button in the Command Line.
Choose the arrow button next to the Position box to choose the arrow position.
Choose the Same as button to have the dimension drawn in the same position as other dimensions.    

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set the points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Arrowhead Type
The dimension arrowhead type is chosen with the Dimension Line button in the Command Line after a 
Dimension command is selected.    You can change any dimension arrowhead by selecting the dimension,
then selecting the Show Info Box option.    Next, choose the new arrowhead type in the arrowhead type 
box.

There are 12 dimension arrowhead types available.    These are:

None
Normal
Slash

Filled Circle
Filled (Short)
Filled (Long)

Hollow Circle
Hollow (Short)
Hollow (Long)

Normal (60º)
Filled (60º)
Hollow (60º)

Setting the arrowhead type
After a Dimension command is selected, choose the Dimension Line button in the Command Line.
Choose the arrow button next to the Arrowhead Type box to choose the arrowhead type.
Choose the Same as button to have the arrowhead drawn with the same type as other dimensions.    

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set the points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Arrowhead Size
The dimension arrowhead size is set in Drawing Units in the Size box of the Dimension Line button.

Setting the arrowhead size
After the Dimension command is selected, choose the Dimension Line button in the Command Line.
Choose the Arrowhead Size box.
Type the size of the arrowhead in Drawing Units.
Choose the Same as button to have the arrowhead drawn in same size as other dimensions.    Then 

set a point on the existing dimension in the drawing.
Set the points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Overshoot Length
The overshoot length is set in the Overshoot box with the Extension Line button.    This determines the 
distance the extension line extends past the dimension line.

Setting the overshoot length
After a Dimension command is selected, choose the Extension Line button in the Command Line.
Choose the Overshoot box.
Type the Overshoot length.
Choose the Same as button to have the overshoot drawn with the same length as other dimensions.    

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set the points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Fixed Length
When the Fixed Length button is selected with the Extension Line button, you can set a distance for the 
fixed length.    This determines the distance the extension line extends from the dimension line.    The 
extension line is always drawn a certain distance from the dimension line.

Setting a fixed length
After a Dimension command is selected, choose the Extension Line button in the Command Line.
Choose the Fixed Length check box.
Type the Fixed Length in Drawing Units.
Choose the Same as button to have the extension line drawn with the same fixed length as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set the points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Variable Length
When the Variable Length button is selected with the Extension Line button, you can set a distance for the
gap size.    This determines the distance between the extension line and the object being dimensioned.

Setting a variable length
After a Dimension command is selected, choose the Extension Line button in the Command Line.
Choose the Variable Length check box.
Type the Gap Size in Drawing Units.
Choose the Same as button to have the extension line drawn with the same gap size as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Text Size
The dimension text size is entered in Drawing Units in the Size box of the Dimension Text button.

Setting the dimension text size
After a Dimension command is selected, choose the Dimension Text button in the Command Line.
Choose the Text Size box.
Choose the Same as button to have the dimension text drawn the same size as other dimensions.    

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Prefix
The dimension prefix is entered in the Prefix box of the Dimension Prefix, Suffix button.

Setting the dimension prefix
After a Dimension command is selected, choose the Dimension Prefix, Suffix button in the Command 

Line.
Choose the Prefix box.
Type a new prefix, or choose one from the box.
Choose the Same as button to have the dimension text drawn with the same prefix as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Suffix
The dimension suffix is entered in the Suffix box of the Dimension Prefix, Suffix button.

Setting the dimension suffix
After a Dimension command is selected, choose the Dimension Prefix, Suffix button in the Command 

Line.
Choose the Suffix box.
Type a new suffix, or choose one from the box.
Choose the Same as button to have the dimension text drawn with the same suffix as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Postive or Negative Dimension Tolerance
With DesignCAD you can display positive or negative tolerance numbers with each dimension.    This 
option is selected with the Dimension Tolerance button.

Setting the positive or negative dimension tolerance
After a Dimension command is selected, choose the Dimension Tolerance button in the Command 

Line.
Choose the Positive or Negative Tolerance box.
Type the tolerance measurement.
Choose the Same as button to have the dimension drawn with the same tolerance as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Postive and Negative Dimension Tolerance
With DesignCAD you can display both positive and negative tolerance numbers with each dimension.    
This option is selected with the Dimension Tolerance button.

Setting the positive and negative dimension tolerance
After a Dimension command is selected, choose the Dimension Tolerance button in the Command 

Line.
Choose the Positive and Negative Tolerance box.
Type the positive tolerance measurement in the first box.
Type the negative tolerance measurement in the second box.
Choose the Same as button to have the dimension drawn with the same tolerance as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



No Dimension Tolerance
With DesignCAD you can choose not to display any tolerance numbers with a dimension.    This option is 
selected with the Dimension Tolerance button.

Setting no dimension tolerance
After a Dimension command is selected, choose the Dimension Tolerance button in the Command 

Line.
Choose the None box.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Saving a Vector Dimension
The Save as Vector form box in the Command Line saves the dimension as a vector entity.

Saving a vector dimension
After a Dimension command is selected, choose the Save as vector form box.

See Also:    Dimension Options, Changing Dimension Options



Symbol File

The symbol file is a .DW2 file containing information about a symbol.    If the symbol file is modified, the 
change will be reflected in all the drawings using that symbol.    This file must be present when the symbol
is loaded.    The symbol file is loaded when a symbol is retrieved with the Symbol Load command.



Entering Coordinates for Points
You can enter the exact coordinates of a point using several different DesignCAD commands.

The Coordinate Bar at the top of the screen displays the X, Y, Delta X, and Delta Y coordinates of the 
cursor.    The Coordinate Bar can also be used to enter coordinates.

Setting X and Y coordinates
Choose the Point XY command in the Point menu.
Type the X coordinate for the cursor in the X coordinate box.
Type the Y coordinate for the cursor in the Y coordinate box.
Choose the OK button.

Setting relative X and Y coordinates
Choose the Point Relative command in the Point menu.
Set a point for the reference point.

-or-
Press Enter to use the last point as the reference point.
Type the horizontal distance from the current cursor location in the Delta X coordinate box.
Type the vertical distance from the current cursor location in the Delta Y coordinate box.
Choose the OK button.

Setting polar X and Y coordinates
Choose the Point Polar command in the Point menu.
Set a point for the reference point.

-or-
Press Enter to use the last point as the reference point.
Type the distance from the current cursor location in the Distance coordinate box.
Type the angle from the current cursor location in the Angle box.
Choose the OK button.

See Also:    Setting Points, Choosing Point Commands



Minimizing Windows
Clicking the Minimize button at the right end of the title bar in an application window shrinks the 
application window to an icon.    This is the same as choosing Minimize from the application Control-
menu.

These icons can be moved around the screen with the Arrange Icons command.    This command 
straightens any icons on the screen and places them along the bottom of the screen.

See Also:    Maximize button, Windows



Moving Points
Activate the Point Select Mode.
Select the entity to be changed.
Set a point on the point to be moved.
Set a point for the new location of the first point.

See Also:    Point Move command, Deleting Points



Undoing an Action
Canceling an action that is in progress

Press Esc.

See Also:    Undoing Commands



Canceling a Menu
Click outside the menu.

-or-
Press Esc to cancel the menu.
To return to your drawing, press Esc again.

See Also:    Closing a Menu



Erasing the Screen
Choose the New command from the File menu.
When asked if you want to save the drawing, choose the Yes button to save the drawing.
Choose the No button to clear the screen without saving the drawing.

See Also:    Clearing the Screen



Using the Mouse
Clicking the Mouse
Dragging the Mouse

Selecting Commands with a Mouse
Selecting Entities with the Mouse

Mouse Techniques



Using Menus
The Command Menu lists all DesignCAD commands.    You can choose commands from the menus using
the mouse, keyboard, or digitizer.

Selecting Commands with a Mouse
Selecting Commands with the Keyboard
Selecting Commands with a Digitizer

If an ellipsis (...) follows a command name, a dialog box appears so you can set the options for the 
command.

You can close a menu without choosing a command.

Canceling a menu
Click outside the menu.

-or-
Press Esc to cancel the menu.
To return to your drawing, press Esc again.



Editing Layers
Deleting a Layer
Saving Layers
Selecting Layers



Getting Color Table
Choose the Load Color Table command.
Type the name of the color table you want.
Choose the OK button.

See Also:  Set Color command, Load Color Table command, Loading Color Table



Loading Files
Loading Color Table
Loading Symbols
Loading and Selecting Objects
Merging Drawings
Importing Drawings



Text Arc command
The Text Arc command draws text in an arc.

Text
The text is entered in the Text box in the Command Line.

Size
The size of the text is entered in the Size box in the Command Line.

Font
Use the Font box in the Command Line to change the font.

Angle
The angle of the text is entered in the Angle box in the Command Line.    The angle of the text is also 
determined by the location of the points set with the Text command.

Orientation
Text can be left-justified, centered, or right-justified by selecting the orientation in the Orientation box in 
the Command Line.

Bold
Choose this button to have the text drawn in bold.

Italic
Choose this button to have the text drawn in italic.

Same as
Text can be drawn with the same options as other text in the drawing by selecting the Same as button in 
the Command Line.

After all the options are set, points are set for the lower-left, center, and lower-right points of the text 
string.

Shortcut

Mouse:

See Also:    Drawing Text in an Arc



Backward Arc
A backward arc is drawn with earlier versions of DesignCAD.



Toolbox

A Toolbox contains icons that issue DesignCAD commands.    These icons can quickly be selected with 
the mouse, digitizer, or keyboard.



Area command
Use the Area command to calculates the area of part of the drawing.

Dialog box options
Show Result in Acres

The area of an entity can be calculated in acres when the Show Result in Acres box is selected in 
the dialog box.

Precision
The Precision box determines the number of decimal places the measurement will display.

Select Lines
When the Select Lines box is selected in the Command Line, lines can be selected in the drawing.

See Also:    Adding Area to Drawing, Calculating Area



Calculating Area
Calculating the area

Choose Area from the Dimension menu.
Set points around the area to be measured.
Press Enter.

Calculating the area in acres
Choose Area from the Dimension menu.
Set points around the area to be measured.
Choose the Acres box to have the area measured in acres.
Press Enter.

Calculating the area of an entity
Choose Area from the Dimension menu.
Choose the Select Lines box in the Command Line.
Set a point on the entity to be measured.
Press Enter.

See Also:    Adding Area Drawing, Area command



Info Box

The Info Box appears when you double-click an entity or choose the Show Info Box option from the View 
menu.

The Info Box displays information such as color, line type, angle, height, text style and font for the 
selected entity.    This information can be changed by choosing the appropriate box in the Info Box.

The information displayed in the Info Box depends on the type of entity selected.



Displaying Attributes
Choose the Show Attribute option in the Options menu.

-or-
Choose the Attribute command from the Dimension menu.
Choose the Show attribute box in the Command Line.

See Also:    Show Attribute option



Bookmark

A bookmark is a marked location in the Help file that you have named for reference purposes.



BasicCAD

BasicCAD is a powerful programming language that comes with DesignCAD 2-D for Windows.    With 
BasicCAD, you can write a program and execute it as you would any other DesignCAD command.

BasicCAD is similar to standard Quick Basic.    It provides the capability to execute DesignCAD 
commands as well as Basic statements.    This gives BasicCAD the flexibility of Basic with the power of 
DesignCAD.



Command Prompt

The command prompt, or DOS prompt, appears when you are in MS-DOS.

Your prompt probably looks like this:

C:\>

You must enter WIN at this prompt to start Windows.



Digitizer

A digitizer, or graphics tablet, is used to move the cursor, set points, and enter commands.    With a 
graphics tablet, you can "trace" a drawing from paper onto the screen.



Note

A note, or annotation, is a comment added to the help file.    Annotations appear in a separate pane.



Annotation

A annotation, or note, is a comment added to the help file.    Annotations appear in a separate pane.



Snap Grid

The snap grid is an imaginary grid placed over your drawing.    Each point set with the Point Set command
is located exactly on one of the grid points.    The cursor movement follows the snap grid.



Regenerate

To regenerate means to quickly refresh the screen.

The Regenerate command is a quick way to refresh the screen and repair any lines that look as if they 
have been partially erased.



Resolution

The resolution of a drawing determines the total number of dots per inch printed with each drawing.

With DesignCAD, you can print drawings with different resolutions.    Depending on your printer, the 
printer setup dialog box allows you to choose between 300 d.p.i., 150 dpi, or 75 dpi.



Text Style

Text style refers to how the text looks in the drawing.    By choosing the appropriate buttons in the Text 
command or Info Box, text can be drawn bold or italic.



Zoom Static

Zoom static permanently changes the "zoom," or size of the drawing.



Mirror command
The Mirror command creates a mirrored image of selected objects.    Points are set for the location and 
orientation of an imaginary mirror.    The mirror can be drawn horizontally, vertically, at a custom angle, or 
"normal" to a line perpendicular to the mirror.

Mirror Vertically
Choose this button in the Command Line to have the object mirrored vertically.

Mirror Horizontally
Choose this button in the Command Line to have the object mirrored horizontally.

Custom Mirror
Choose this button in the Command Line to have the object mirrored based on a mirror defined by two 
points.

Custom Normal
Choose this button in the Command Line to have the object mirrored based on an imaginary line that is 
perpendicular to the mirror.

Make Copy
Choose this box to have a copy of the object drawn when the it is mirrored.

Shortcut

Mouse:

See Also:    Mirroring Objects



Align Drawing command
The Align Drawing command changes the size and location of the drawing based on four points.    The 
first point set with the Align Drawing command is moved to the location of the second point.    The third 
point is moved to the location of the fourth point.    The Align Drawing command scales and rotates the 
drawing so that the first and third points fit into the second and fourth points.    This command changes the
actual size and position of the drawing.

See Also:    Aligning a Drawing



View Read command
The View Read command reads the view configuration from a disk file that was previously saved with the 
View Save command.

DesignCAD can read view files in either binary or ASCII format.    Binary view files are saved with the 
extension *.B2D.    ASCII view files are saved with the extension *.A2D.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Opening Drawing Views



View Save command
The View Save command saves the current view configuration to disk so that it can be read with the View
Read command.

DesignCAD allows you to open several views of a drawing, edit the objects, and save the view 
configurations as a single file.    You can then open the view configurations with DesignCAD.

DesignCAD can save view files in either binary or ASCII format.    Binary view files are saved with the 
extension *.B2D.    ASCII view files are saved with the extension *.A2D.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Saving Drawing Views



Point Line Distance command
The Point Line Distance command sets the distance for the Point Line Snap command.

Original
The Original box shows the original distance.

New
Enter the new distance for the Point Line Snap command in the New box.

See Also:    Setting Points Along a Line



Point Line Snap command
The Point Line Snap command sets a point a certain distance from a point on a line in the drawing.    The 
first point is erased.    If the line is not straight, the distance along the line will be measured.    If the line 
bends between the first point and the new point, the straight-line distance between the points will be 
shorter than the distance specified.

The distance is set with the Point Line Distance command.

Shortcut

Mouse:

See Also:    Setting Points Along a Line



Run command
The Run command executes programs created with the BasicCAD programming language.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Running BasicCAD Programs



Preset Point Mode command
In DesignCAD, points can be set before or after the command is selected.    Normally, the command is 
selected and then the points are set.    However, the Preset Point Mode allows you to set the points, then 
select the command.

Shortcuts

Mouse:
Keys: Shift+S

See Also:    Setting Points First



Save Bitmap command
The Save Bitmap command saves a bitmap to disk.    This command saves screen images in .BMP file 
format.    These bitmaps are compatible with many Paint and Desktop Publishing packages.

When a bitmap is saved, only the colors on the screen are saved.    The drawing itself is not saved.

Two points can be set for the lower left and upper right corners of the drawing.    If no points are set, any 
toolboxes displayed on the screen will be saved with the bitmap.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Saving Bitmaps, Reading Bitmaps



Load Bitmap command
The Load Bitmap command reads a bitmaps from disk and displays it on the screen.    This command 
reads bitmaps generated with the Save Bitmap command and most .BMP format files.    The bitmaps 
being read must be compatible with the graphics adapter being used.

Dialog Box Options
File Name

Type a new filename to save a drawing with a different name or in a different file format.
Note:  You cannot save a drawing in a different file format with the same name.    Use the current 

name, or select a name in the list to save a drawing with an existing filename.
Note:  A filename can contain up to eight characters and an extension of up to three characters.    

DesignCAD adds the extension you specify in the Save File As Type box.
Drives

Select the drive in which you want to store the drawing.
Directories

Select the directory in which you want to store the drawing.
Save File As Type

DesignCAD converts drawings to many other file formats.    What appears in the list depends on 
which converters you install with DesignCAD.

See Also:    Saving Bitmaps, Reading Bitmaps



Bitmaps

A bitmap, or screen image, is a copy of the screen created with the    Save Bitmap command and 
imported with the    Load Bitmap command command.

A bitmap is only for viewing purposes and cannot be edited or manipulated as a regular drawing.

It is possible to "trace over" a bitmap with DesignCAD drawing commands.

The bitmap being read must be compatible with the graphics adapter being used.



Vector Conversion command
The Vector Conversion command converts DesignCAD entities to vector entities.

See Also:    Converting Entities



Converting Entities
Select the entity to be converted.
Choose Vector Conversion from the Edit menu.

See Also:    Vector Conversion command



Material List command
The Material List command counts all the attributes in a drawing and displays a list.

Attributes are drawn with the Attribute command.

The list can be saved to a disk file so that it can be used with other software, such as database systems.

See Also:    Drawing Attributes, Listing Attributes



Show Rulers option
Use the Show Rulers option displays the rulers at the top and left edge of the drawing area.

The vertical and horizontal rulers help you align entities and keep track of where you are in the drawing.

Shortcut
Keys: Shift+Alt+R

See Also:    Showing Rulers, Hiding Rulers



Showing Rulers
Choose the Rulers option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Rulers, Customizing DesignCAD



Hiding Rulers
Choose the Rulers option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Rulers, Customizing DesignCAD



Zoom Window command
Use the Zoom Window command to zoom into an area in the drawing based on two points set for a zoom 
window.

Shortcut

Mouse:

See Also:    Zooming a Drawing



Calculator command
Use the Calculator command to perform calculations on the screen.

The expression entered in the Calculator command can contain a formula or expression.

Dialog box options
Text

The expression is entered in this box.
Compute

Choose this button to have the mathematical expression calculated.

See Also:    Calculating Information



Calculating Information
Choose Calculator from the Info secondary menu in the Dimension menu.
Type the calculation.
Choose the Compute button.
Choose the OFF button to end the command

See Also:    Inserting calculations, Calculator command



Inserting Calculations into Drawing
In the Calculator dialog box, highlight the text.
Press Ctrl+C to copy the text to the Clipboard.
Choose the OK button.
Choose the Text command.
Choose the Text box in the Command Line.
Press Ctrl+V to paste the Clipboard contents.
Set the points for the text.
The calculation will be inserted into the drawing.

See Also:    Calculating information, Calculator command



Creating User-Defined Macros
DesignCAD allows you to assign the macro buttons in the Command Line to macros.    These macros can
be selected by choosing the macro button or by pressing the keystroke associated with that button.

Assigning Buttons to Macros
Choose the Options command.
Choose the Macro category.
Use the options under Modify Macro Settings to define the macro buttons.

Button to Change    Select the buttons, icons, and macros for the macro buttons.
Which    Select the macro button to change.
Icon    Select the icon to use for the defined macro button.

Available Macros    Select the macro to define for the button from the list of available macros.
Keystroke    Shows the keystroke used for the defined macro.
Change    Select this button to change the button definitions.
Startup macro    Select the macro file to be used as the startup macro.

Choose the OK button.

See Also:    Creating Macros



Digitizer Menu Create command
Use the Digitizer Menu Create command to create a digitizer menu.    The menu created with this 
command does not appear on the screen.    The menu contains several selection boxes.    These selection
boxes are spaces where commands are selected.

See Also: Creating a Digitizer Menu



Digitizer Menu Load command
Use the Digitizer Menu Load command to load the "data" portion of the digitizer menu.    The "paper" 
portion of the menu should be attached to the digitizer before the digitizer is loaded.

A maximum of 10 digitizer menus can be loaded at once.

Note:    You cannot draw inside the area containing the digitizer menu, unless you disable the digitizer 
menu first.

See Also: Loading a Digitizer Menu



Digitizer Menu Disable All command
Use the Digitizer Menu Disable All command to disable all active digitizers.    So that the entire digitizer 
drawing area can be used.

See Also: Disabling Digitizer Menus



Digitizer Menu Enable All command
Use the Digitizer Menu Enable All command to enable all disabled menus.

See Also: Enabling Digitizer Menus



Digitizer Menu Remove All command
Use the Digitizer Menu Remove All command to remove all active and inactive digitizer menus so that the
entire digitizer drawing area can be used.

See Also:    Removing Digitizer Menus



Symbol Toolbox

A Symbol Toolbox is a Toolbox containing frequently-used symbols.    A Symbol Toolbox is created within 
the Options command.



Show Symbol Toolbox option
Use the Show Symbol Toolbox command to show or hide the Symbol Toolbox.

Shortcut:
Key Shift+Alt+Y

See Also:    Showing Symbol Toolbox, Hiding Symbol Toolbox



Hiding Symbol Toolbox
Choose the Symbol Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Symbol Toolbox, Customizing DesignCAD



Showing Symbol Toolbox
Choose the Symbol Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Hiding Symbol Toolbox, Customizing DesignCAD
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Loading a Digitizer Menu
Attach the paper template onto the digitizer.
Select the Digitizer Menu Load command from the Digitizer Menu secondary menu in the File menu.
Choose the digitizer menu name in the File Name box.
Choose the OK button.
Set a point in the lower left corner of the digitizer menu.
A rubber band box shows how the digitizer menu will be loaded.
Set a point in the upper right corner of the digitizer menu.

Note:    You cannot draw inside the area containing the digitizer menu, unless you disable the digitizer 
menu first.

See Also:    Digitizer Menu Load command



Creating a Digitizer Menu
To create the digitizer template using DesignCAD commands, remember these tips:

Draw a box around the menu and around each command box.    Both the menu and the command boxes 
must be rectangular in shape.

Inside each selection box, draw text or a picture to be associated with that command box.

Print this digitizer menu to scale so that it may be placed on the digitizer.

Load the file containing the digitizer template.
Choose the Digitizer Menu Create command from the Digitizer Menu secondary menu in the File 

menu.
Enter the name of the digitizer in the File Name box.
Choose the OK button.
Set a point in the lower left corner of the digitizer template.
A rubber band box shows how the menu is drawn.
Set a point in the upper right corner of the digitizer template.
Set a point in the lower left corner of the command box.
A rubber band box shows how the command box is drawn.
Set a point in the upper right corner of the command box.
Enter the command name in the Command box.

-or-
Choose the Use Keystroke box.
Choose the Press a Key Now button.
Press the shortcut key for the command.

-then-
Choose the OK button.
Set two more points for the next command box.

-or-
Press Enter or click the middle mouse button to end the command.

Note:    Use the DCMACRO.SYS file to find the correct command names to enter in the Command box.

See Also:    Digitizer Menu Create command
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Disabling All Digitizer Menus
After a digitizer menu has been loaded, choose the Digitizer Menu Disable All command from the 

Digitizer Menu secondary menu in the File Menu.

See Also:    Digitizer Menu Disable All command



Disabling One Digitizer Menu
Choose the Digitizer Menu category in the Options command.
Choose the Disable button next to the digitizer menu to disable the digitizer menu.

See Also: Enabling One Digitizer Menu
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Enabling All Digitizer Menus
After a digitizer menu has been disabled, choose the Digitizer Menu Enable All command from the 

Digitizer Menu secondary menu in the File menu.

See Also:    Digitizer Menu Enable All command



Enabling One Digitizer Menu
Choose the Digitizer Menu category in the Options command.
Choose the Enable button next to the digitizer menu to enable the digitizer menu.

See Also: Disabling One Digitizer Menu
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Removing All Digitizer Menus
After a digitizer menu has been loaded, choose the Digitizer Menu Remove All command from the 

Digitizer Menu secondary menu in the File menu.

See Also:    Digitizer Menu Remove All command



Removing One Digitizer Menu
Choose the Digitizer Menu category in the Options command.
Clear the check mark next to the digitizer menu name to remove the digitizer menu.

See Also:    Loading a Digitizer Menu
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Selecting Command First
Choose the command.
Set the points for the command.

See Also:    Setting Points First



Setting Points First
Activate the Preset Point Mode.
Set the points for the command.
Choose the command.

See Also:    Preset Point Mode
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Using Symbol Toolbox
A Symbol ToolboxSymbolToolbox can be created using the Options command.    This Toolbox can contain 
any DesignCAD symbols you have loadeded.    These symbols can then be loaded into a drawing by 
simply choosing them from the Toolbox.

Using Symbol Toolbox
Choose the symbol in the Symbol Toolbox.
Set a point for the primary handle.
Set a point for the secondary handle.
The symbol will be loaded according to the two points set.

See Also:    Creating Symbol Toolbox
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Creating Symbol Toolbox
Choose Options from the Options menu.
Choose the Symbol Toolbox category.
Type the correct path for the drive and directory of your symbol files in the Directory box.
Choose the symbol you want to add in the Available Symbols box.
Choose the Add button.
The symbol will be added to the Current Content box.
Choose the OK button.

Note:    Use the Delete button to delete symbols from the Symbol Toolbox.

See Also:    Using Symbol Toolbox
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Saving the Configuration
DesignCAD automatically saves the system configuration for each drawing to disk when you save the 
drawing.    When a configuration is saved, it becomes the default configuration for DesignCAD.    This 
configuration is loaded whenever DesignCAD is run.

The configuration information includes DesignCAD options and view information.    Information such as 
the Drawing Unit size, precision, text size and font, and dimension options are all saved with the drawing.

This option can be disabled.

See Also:    Customizing the Screen
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Using Keystroke Commands
DesignCAD Windows allows you to use shortcut keys common to Windows applications or DOS 
applications.

The DOS Keystrokes option allows you to use DOS keystrokes instead.

Enabling DOS keystrokes
Choose the DOS Keystrokes option from the Options menu.

See Also:    Customizing DesignCAD, DOS Keystrokes command. DOS Keystroke Commands
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Using a Mouse
The mouse controls a pointer on the screen.    You move the pointer by sliding the mouse over a flat 
surface in the direction you want the pointer to move.    You don't press the mouse button when you move 
the mouse.    If you run out of room to move the mouse, lift it and then put it down.    The pointer doesn't 
move while the mouse is in the air.

With DesignCAD, a mouse moves the cursor, or pointer, sets points, draws lines, and chooses commands
from the Command Menu.    In addition, a mouse can choose commands from the Main Toolbox, the Snap
Toolbox, or a Hot Toolbox.

A mouse usually contains two or three buttons.    The buttons on the mouse are defined as:

Left Button: Point Set command
Right Button: Gravity command
Middle Button: Enter key

"Pointing" the mouse
Moving the mouse to place the pointer over an item is called pointing.

"Clicking" the mouse
Pointing to an item on your screen and then quickly pressing and releasing the mouse button is called 
clicking.    You choose entities on the screen by clicking.    Double-clicking, pointing to an item and quickly 
pressing the mouse button twice, is a convenient shortcut for many of the tasks you will perform in 
DesignCAD.

"Dragging" the mouse
DesignCAD allows you to move and copy commands by choosing entities on the screen and "dragging" 
the mouse.    To do this, select the entities.    Then hold down the left mouse button and move the mouse 
so that the highlighting box is moved across the.    Once the highlighting box is in the location you want, 
release the left mouse button.

Moving the mouse
The mouse can be forced to move horizontally by pressing Ctrl+Alt.    Pressing Shift+Alt forces the 
mouse to be moved vertically.

Special Mouse Operations
The mouse may have two or three buttons.    In DesignCAD, these buttons are used to manipulate and 
edit objects.

In Point Select Mode:
Right Mouse Button
Clicking - Adds a vertex, or corner, to a line.
Double-Clicking - Adds point to a line.

Left Mouse Button
Clicking - Snaps to nearest point.
Double-Clicking - Deletes nearest point.

In Select Mode:
Right Mouse Button
Clicking - Selects entity.
Double-Clicking - Opens Info Box for selected object.

Left Mouse Button
Clicking - Snaps to nearest point.



Double-Clicking - Snaps to nearest point and enables selection box for scaling.

See Also:    Mouse Shortcuts, Selecting Commands with the Mouse, Mouse Techniques



Using the Keyboard
The keyboard can be used to issue most DesignCAD commands.    Points are set, the cursor, or pointer, 
is moved, and options are entered from the keyboard.

Keys are often used in combinations or sequences.    For example, Ctrl+F1 keystroke means to hold 
down the Control key while pressing F1.

Shortcut Keys can be invoked from the keyboard by pressing a key or set of keys.

See Also:    Controlling the Cursor, Selecting Commands with the Keyboard, Selecting Objects with the 
Keyboard



Selecting Commands
To choose a command from a menu, you can use the mouse or press a shortcut key.    In DesignCAD, 
shortcut keys are listed after the command names in the Command Menu.

Selecting Commands with a Mouse
Selecting Commands with the Keyboard
Selecting Commands with a Digitizer

See Also:    Commands, Shortcut Keys



Opening an Existing Drawing
Before you can work on an existing drawing, it must be open on the screen.

Opening an existing drawing
Choose Open from the File menu. DesignCAD displays the Open dialog box.
In the File Name box, type the filename of the drawing you want to open.

-or-
Double-click the name in the File Name box or use the arrows in the scroll bar to choose the filename.
Choose the OK button.

If the drawing you want is not listed in the File Name box, choose a new drive or directory in the Open 
dialog box.

Choosing the Set Handles box in the Open dialog box allows you to set handles for the drawing.    If the 
drawing was saved with handles, you can set up to two points for the location of the pre-defined handles.  
If the drawing was not saved with handles, you can set up to four points for the location of the lower left, 
lower right, upper left, and upper right corners respectively.

The File menu lists the four most-recently opened drawings.

Opening a recent drawing
Choose the file from the File menu.

Tip:    You can see a list of all the files with a specific extension in a drive or directory by typing an asterisk
(*), a period (.), and the extension in the File Name box.

See Also:    Opening DesignCAD Files, Opening a Drawing, Opening Drawings, Opening a File Created 
by Another Application



Setting Drawing Handles
DesignCAD allows you to set drawing handles when you save or open a drawing.    Up to two points can 
be set on the screen to determine the lower left and lower right corners of the drawing.

If the Set Handles command is not selected, and no points are set with the Open command, the drawing 
handles will be set at the lower left and lower right corners of the drawing.

Saving a drawing with handles
Choose the Set Handles command from the Options menu.
Set up to two points for the drawing handles.
Press Enter if only one point is set.
Choose the Save command from the File menu.
Type the filename from the File Name box.
Choose the OK button.

Opening a drawing with handles
Choose the Open command from the File menu.
Select the filename from the File Name box.
Choose the Set Handles box.
Choose the OK button.
Set up to two points for the drawing handles.
Press Enter if only one point is set.

See Also:    Copying Objects with Handles, Moving Objects with Handles



Speeding Up Basic Tasks
If you have a mouse, you can use the commands in the Toolboxes to perform many basic tasks quickly, 
such as drawing a line, setting a point, drawing a circle, and drawing polygons.    For example, you can 
quickly choose the command to draw a polygon by clicking the polygon button.

If you forget which button accomplishes a particular task, you can view a brief description in the Status 
Bar at the lower-left corner of the screen    Point to a command in the Main Toolbox and hold down the left
mouse button.    To avoid activating the button, continue to press the mouse button.    Drag the mouse 
pointer away from the button on the Main Toolbox, then release the mouse button.

See Also:    Shortcut Keys, Mouse Shortcuts



Saving Your Drawings
When you are working in DesignCAD, you are actually working on a copy of your drawing temporarily 
stored in the computer's memory.    To save your work for future use, you must give the drawing a name 
and store it on a disk, either a hard disk or a floppy disk.

Saving a drawing
Choose the Save command from the File menu.    If you are saving the drawing for the first time, 

DesignCAD displays the Save As dialog box.
DesignCAD saves the drawing in the current directory and automatically adds a .DW2 extension to the

filename unless you specify another extension.
Choose the OK button.

You can choose a new drive or directory in the Save dialog box to save the drawing in a different drive or 
directory.

See Also:    Saving a Drawing, Saving Drawings



Closing a Drawing
If a drawing has changed, DesignCAD asks if you want to save the changes before closing the drawing or
quitting DesignCAD.    If you choose the "Yes" button, but haven't named the drawing, DesignCAD 
displays the Save As dialog box.

Closing a drawing
Double-click the drawing Control-menu box in the upper-left corner of the drawing window.

-or-
Choose the Close command from the File menu.

See Also:    Clearing the Screen



Choosing Commands
You can choose commands from the menus or press the shortcut keys assigned to the most commonly 
used commands.    The Command Menu lists the shortcut key to the right of the command name.

If an ellipsis (...) follows a command name, a dialog box appears so you can set the options for the 
command.

You can close a menu without choosing a command.

Canceling a menu
Click outside the menu.

-or-
Press Esc to cancel the menu.
To return to your drawing, press Esc again.

See Also:    Selecting Commands with a Mouse, Selecting     Commands with the Keyboard  , Selecting 
Commands with a Digitizer



Selecting Options
The OK, Cancel, and Close command buttons appear in many dialog boxes.    You can choose one of 
these buttons when you finish setting options in a dialog box.

OK button
The OK button closes the dialog box and completes the command using the selected options.    For 
example, choosing the OK button in the Open dialog box opens the drawing.    To choose the OK button, 
you can either click the button or press Enter.

Cancel and Close buttons
Choosing the Cancel button discards the options you have selected, closes the dialog box, and returns 
you to your drawing.    When DesignCAD completes an action that cannot be canceled, the Cancel button 
changes to the Close button.

The Close button closes the dialog box without reversing any completed changes.    To choose the Cancel
button, you can click the button or press the Esc key.    You can also use the Close command on the 
Control menu in the upper-left corner of the dialog box.

See Also:    Using Dialog Boxes, Typing and Editing in Dialog Boxes



Selecting a Menu
If you have a mouse, you can move the pointer to the menu in the Command Menu.    You can also press 
Alt and move to the menu with the arrow keys.

When you press the left mouse button or Enter, the menu will "pull-down."

You can use the mouse or the arrow keys to move the highlight bar up and down the menu to choose a 
command.    You can also press the highlighted letter of the command you want to choose.

Secondary menus
To choose the Load Selection command, choose the word "Load" from the Edit menu.    Then move the 
highlight bar to Load Selection and press the left mouse button or the Enter key.    Because an arrow 
follows the word "Load," a secondary menu with more commands will "pop up" on the screen.

Using arrow keys
If you are not using a mouse, you can select menus by pressing Alt and the arrow keys. Once a menu is 
pulled down, you can choose the command you want by pressing the arrow keys.    You can choose a 
command from the menu by pressing Enter.

See Also:    Using Menus, Selecting Commands with a Mouse, Selecting Commands with the Keyboard, 
Selecting Commands with a Digitizer



Switching to a Different Drawing Window
With DesignCAD, you can have more than one view of a drawing open at a time.    You can open several 
drawing views, depending on how much memory is available on your computer.      A separate drawing 
window is opened for each view.    The Window menu lists the views sequentially.

The window you are currently working in, the window containing the cursor, is called the active window.    
The view you are working in is called the active view.    Drawing commands affect each window.    To work 
in a different view, you must make that drawing window active.

Making a drawing window active
From the Window menu, choose the name of the drawing view you want to make active.

Making the next open window active
If the window you want to work in is visible, click anywhere within its borders.

-or-
Press Alt to choose the drawing Control-menu box.
Press Enter to open the drawing Control-menu box.
Choose the Next command.

-or-
Press Ctrl+F6 to choose the Next command.

See Also:    Windows, Moving and Sizing Windows, Opening a New Window



Moving and Sizing Windows
Arranging Windows and Icons
Moving Windows
Maximizing Windows
Minimizing Windows
Restoring a Drawing Window to its Former Size
Closing a Window



Arranging Windows and Icons
Cascading windows

Choose the Cascade command from the Window menu.

Tiling windows
Choose the Tile Horizontal command from the Window menu.

-or-
Choose the Tile Vertical command from the Window menu.

Arranging Icons
Different views of the drawing window become icons when they are minimized.    You can move these 
icons around the screen.

Choose the Arrange Icons command from the Window menu.

See Also:    Tiling Windows, Cascading Windows, Arranging Icons



Cursor Pointer Shapes
Pointing to different parts of the screen, causes the pointer shape to change, allowing you to perform 
different tasks.    Some commands also change the pointer shape.

If the pointer assumes a shape you do not want to use, press Esc to restore the pointer to its usual 
shape.

The following table lists the common pointer shapes.

Shape Significance
The Select Mode is active, or the pointer is in the menus, scroll 
bars, Toolbox, or drawing area.    You can choose a menu and 
command, click a button, set points, or move an object.

The Point Select Mode is active.    You can select an entity, show
the points of that entity, and move or delete points.

The Preset Point Mode is active.    You can set points before 
selecting a command.

DesignCAD is performing a task that will take a few seconds.

The pointer is in a selection box.    You can change the size of 
an object vertically.



You can change the size of an object horizontally.

You can change the size of an object diagonally.

You can change the diagonal width or height of an open window.

You can move entities to new positions, or "pan" the drawing 
across the screen with the Pan command.

Text command is selected.    You can move the cursor and the 
text box to the location for the text and set a point.



Shift+F1 has been pressed to select the Help Index command.   
You can select a command to find specific information on the 
command.

When you are setting points for a command, this cursor 
appears.

The Select Scale or Select Zoom command is active and the 
cursor is on either the top or bottom center nodes of the 
selection box.

The Select Scale or Select Zoom command is active and the 
cursor is on either the left or right center nodes of the selection 
box.

The Point Select Mode is active.    A line can be bent with this 
cursor.

The Point Select Mode is active and the Ctrl and Shift keys are 
being pressed.    A point can be removed from the drawing with 
this cursor.



The Extend command is active.    You can set a point on an 
endpoint and "stretch" it to a new point.

A point has been selected.    You can move or delete the point.

The Point Select Mode is active and the Ctrl key is pressed.    
This activates the Cut Line command.

The Sketch command is active.    Move the cursor around the 
screen to draw a freehand curve.

When the Select Mode is active and a selection node of an 
object has been double-clicked, this cursor will rotate the corner 
nodes of the selection box.

The Zoom In command is selected.    A point is set for the zoom 
origin. That point is moved to the center of the screen.



The Zoom Out command is selected.    A point is set for the 
zoom origin. That point is moved to the center of the screen.

The Zoom command is selected.    Set a point for the zoom 
origin and a point for the zoom destination.
The Show Hot Toolbox option has been selected and an icon 
from the Toolbox is being dragged to the Hot Toolbox.
The Same as button has been chosen in the Command Line or 
a command box.    You can select an entity in the drawing.

See Also:    Using a Mouse



Loading and Selecting Objects
Choose the Load Selection command from the File menu.
Choose the drawing name from the File Name box.
Choose the OK button.
Set a point for the lower left corner of the drawing.    This point sets the location of the drawing.    If only

one point is set, the drawing will be drawn the size and angle at which it was saved.
Set a point for the lower right corner of the drawing.    This point determines the size and angle of the 

drawing.
Set a point for the upper left corner of the drawing.    This point determines the slant of the drawing.
Set a point for the upper right corner of the drawing.    The drawing will be loaded and the objects will 

be selected.

See Also:    Load Selection command, Loading Objects, Selecting Objects



Choosing Point Commands
DesignCAD offers several ways to choose the various point commands.

Button Command Shortcut Keys
Center of Gravity
Center of Gravity Move
Gravity .
Gravity Move ,
Intersect-1 N
Intersect-1 Move Ctrl+N
Intersect-2
Intersect-2 Move
Line Snap K
Line Snap Move Ctrl+K
Midpoint F2
Midpoint Move Ctrl+F2
Point Line Snap

Point Polar ;

Point Relative '

Point Set Ins

Point XY :

Coordinate Bar
Pressing F6 chooses the X coordinate box in the Coordinate Bar at the top of the screen.    The 
Coordinate Bar allows you to set a specific coordinate for the X, Y, Delta X, and Delta Y cursor locations 
or polar coordinates.

See Also:    Setting Points with DesignCAD Commands



Setting Points with Commands
You can select a DesignCAD drawing command before setting points.    With most commands, a "rubber 
band line" shows you how the entity will be drawn as the points are being set.    With most commands, 
after all the points are set, you must press Enter or click the middle mouse button to end the command.

By activating the Preset Point Mode first, you can set the points for a command and then select the 
command.

When you zoom, move, or rotate an object, the points and lines may not lie exactly at the correct position 
on the screen.    The pointer, however, remains exactly on top of the dots or pixels on the screen.    A point 
set on top of another point using the Point Set command may be a fraction of a dot off, although it will 
appear to be correct.    The difference is seen when the drawing is zoomed.    The Gravity command 
prevents this error from occurring.

See Also:    Setting Points with DesignCAD Commands, Selecting Command First, Setting Points First



Opening a New Screen
Choose the New command from the File menu.
When asked if you want to save the drawing, choose the Yes button to save the drawing.
Choose the No button to clear the screen without saving the drawing.

-or-
Press Esc.
Choose the Cancel button to return to the drawing screen.

See Also:    Clearing the Screen



Setting a New Origin
The Zoom, Rotate, and Pan commands may change the location of the origin on the screen, but it 
remains at the same point in the drawing.    The Origin command, the Zoom Static button, or the load 
commands can change the origin of the drawing.

Setting the origin
Set a point at the location for the new origin.
Choose the Origin command from the View menu.

Until it is changed again, the origin will be at that point.

See Also:    Changing the Origin



Printing a Drawing
It is a good idea to save your drawing before you print.    That way, if a printer error or other problem 
occurs, you will not lose any of the work you have done since you last saved your drawing.

Printing a drawing
Display the drawing you want to print in the active window.
Choose the Print command from the File menu.
Change any print options in the Print Options dialog box.
Choose the Print button.

Canceling printing
Press Esc.

See Also:    Printing Part of a Drawing, Printing Several Copies, Printing, Printer Setup, DesignCAD Print 
Options



Printing Selected Objects
DesignCAD allows you to print only those objects selected in the drawing with the Print command.

Printing part of a drawing
Select the objects you want to print.
Choose the Print command.
If the Print Selection box is not selected, choose it.
Choose the Print button.

See Also:    Selecting Objects, Printing, Printer Setup, DesignCAD Print Options



Printer Setup
Because various printers have different printing capabilities, the dialog box that appears when you choose
the Printer Setup command depends on the printer.

Most printers can accommodate different paper sizes, orientations, and paper sources.    You can set the 
default paper size, orientation, and paper source for your drawing in this dialog box.

Selecting printer setup options
Choose the Printer Setup command from the File menu.
Choose the printer you want to use in the Printer box, if more than one is available.
Choose the Setup button.
Select the appropriate options.
Choose the OK button.

See Also:    Printing, Printer Setup command, DesignCAD Print Options



Setting the Print Quality
With DesignCAD, you can print drawings with different resolutions.    Depending on your printer, the 
printer setup dialog box allows you to choose between 300 d.p.i., 150 d.p.i., or 75 d.p.i..    This resolution 
determines the total number of dots-per-inch printed with each drawing.

Setting the dots per inch for a drawing
Display the drawing you want to print in the active window.
Choose the Printer Setup command from the File menu.
Choose the Setup button.
Choose the dots per inch in the Resolution box.
Choose the OK button.

See Also:    Printing, Printer Setup



Changing Page Orientation
DesignCAD offers you a choice between "portrait" (vertical) and "landscape" (horizontal) page 
orientations.    You can change the orientation of a drawing within the Print dialog box.

Setting print orientation
Choose the Print command from the File menu.
Choose Portrait in the Orientation box to have your drawing printed with the drawing width the same 

direction as the printer width.
Choose Landscape in the Orientation box to have your drawing rotated 90 degrees, or printed 

sideways on the page.
Choose the Print button.

See Also:    Printing, Printer Setup



Changing Paper Size
Depending on the printer you have installed, you can choose different paper sizes to print a DesignCAD 
drawing.    You can change the paper size loaded into your printer within the Options dialog box.

Setting paper size
Choose the Print command from the File menu.
In the Paper box, choose the size of the paper you want to use.    The options available will depend on 

the printer you selected.
Choose the source of the paper you want to use.    The options available will depend on the printer you

selected.
Choose the Print button.

See Also:    Printing, Printer Setup



Setting Dithering
Depending on the printer you have selected, you may have four options related to dithering in the Options
dialog box:    None, Coarse, Fine, and Line Art.

None    This option turns off dithering.    DesignCAD prints graphics in black and white with no gray 
shading.

Coarse    Select this option if you have specified a resolution value of 300 dots per inch or more in the 
Print dialog box.

Fine    Select this option if you have specified a resolution value of 200 dots per inch or less in the Print 
dialog box.

Line Art    Select this option if the drawing you want to print includes well-defined borders between black, 
white, and gray shadings.    Do not use this option if you are printing scanned images that include 
continuous variations in intensity and hue.

Setting dithering
Choose the Printer Setup command in the File menu.
Choose the Setup button.
Choose the Options button.
Choose option in the Dithering dialog box.
Choose the OK button.

See Also:    Printing, Printer Setup



Setting Intensity
You can control the intensity of a drawing depending on the printer you choose.    The Intensity option 
decreases or increases the darkness of    your drawings.    Moving the icon to the left, or pressing the left 
arrow key, sets the intensity to darker.    Moving the icon to the right, or pressing the right arrow key, sets 
the intensity to lighter.    Setting the icon in the middle sets the intensity to normal.

Controlling intensity
Choose the Printer Setup command.
Choose the Setup button.
Choose the Options button.
Choose the Intensity Control box.
Move the page control in the Intensity Control dialog box.
Choose the OK button.

See Also:    Printing, Printer Setup



Selecting TrueType Fonts
Depending on the printer you choose with the Printer Setup command, TrueType fonts can be printed as 
graphics.    These fonts require less printer memory and may speed up printing time.

Printing TrueType as graphics
Choose the Printer Setup command.
Choose the Setup button.
Choose the Options button.
Choose the Print TrueType as Graphics check box.
Choose the OK button.

See Also:    Printing, Printer Setup



Using the Help Window
The Help window has buttons you can use to move around the Help system easily.    If a particular feature
is not available, the button associated with it is dimmed.

By choosing a button at the top of the Help window, you can display a list of Help topics, search for a list 
of topics that include a key word, and move forward or backward through the Help topics.

The Help window marks some words with a dotted or solid line and displays them in color if you have a 
color display.    Words marked with a solid line are "jump terms."    When you click a jump term, you 
immediately move to a Help topic associated with that word.    Clicking a word or phrase marked with a 
dotted line displays a definition of that term.

Getting help about Help
Choose the How to Use Help command from the Help menu.
Choose the information you want to see.

See Also:    Arranging Windows and Icons, Getting Help as You Work, Finding Information in Help, Help 
Instructions



Finding Information in Help
There are three ways to find the information you need in Help:

Use the Search feature in Help.
Get context-sensitive Help as you work.
Use the Help Index.

Getting help in a dialog box
With the dialog box displayed, press F1.

Getting help on a command
Press Shift+F1.
Choose a command in the Command Menu.

Getting help on a key combination
Press Shift+F1.
Press a key combination.

Getting a definition
In a Help topic, choose a term or phrase with a dotted line.

-or-
Press Tab to select a term with a dotted line.
Press Enter to read the definition.

Minimizing Help
Click the Minimize button in the upper-right corner of the Help window.

-or-
Choose Minimize from the Control menu.

This procedure closes the Help window.    However, the Help icon remains on the desktop.    When you 
press F1, Help reappears.    The last topic you viewed is displayed in the window.

Closing Help
Choose the Exit command from the Help window.

See Also:    Arranging Windows and Icons, Getting Help as You Work, Using the Help Window, Help 
Instructions



Marking Topics
A bookmark marks specific references in the Help window.    With DesignCAD, you can place bookmarks 
at Help topics you use frequently.    Once you have placed a bookmark at a topic, you can display that 
topic quickly by choosing the bookmark from the Bookmark menu in Help.

Placing a bookmark
Display the topic.
Choose the Define command from the Bookmark menu.
To use the title as the bookmark name, choose the OK button.

-or-
To use a different name, type a name for the bookmark.    Then choose the OK button.

Selecting a marked topic
Open the Bookmark menu.
Choose the name of the bookmark you want to view.

Removing a bookmark
Choose the Define command from the Bookmark window.
Select the bookmark you want to remove.
Choose the Delete button.
Choose the OK button.

See Also:    Using the Help Window



Adding Notes
You can add your own comments to Help topics.    These comments can be up to 2,000 characters long, 
using any characters on the keyboard.    When you add a comment, Help places a paper clip symbol to 
the left of the title of the topic to remind you that you have added text to the topic.    DesignCAD does not 
print comments when the topic is printed.

Adding text to a Help topic
Display the topic.
Choose the Annotate command from the Help Edit menu.
Type the text.
Choose the Save button.

Viewing a comment
Display the topic.
Choose the paper clip symbol.
Choose the Cancel button.

Removing a comment
Display the topic.
Choose the paper clip symbol.
Choose the Delete button.

See Also:    Using the Help Window



Setting Regular Points
The Point Set command sets a point at the cursor location.    There are several ways to set a point with 
the Point Set command.    You can press the Ins key on the keyboard.    You can also set a point by 
pressing the left button on a mouse or the first button on a digitizer.

See Also:    Setting Points with DesignCAD Commands, Choosing Point Commands



Setting Gravity Points
Choose the Gravity command.
Move the pointer near the point.
Click the left mouse button.

-or-
Move the pointer near the point.
Set a point.

Moving to gravity without setting a point
Choose the Gravity Move command.
Move the pointer near the point.
Press Enter.

Finding the center of gravity
Choose the Center of Gravity command.
Move the pointer near the point.
Press Enter.

Finding center of gravity without setting a point
Choose the Center of Gravity Move command.
Move the pointer near the entity.
Press Enter.

See Also:    Setting Points with DesignCAD Commands, Choosing Point Commands



Snapping to Lines
Snapping to a line

Choose the Line Snap command.
Move the pointer near the line.
Click the left mouse button.

-or-
Set a point.

Snapping to line without setting a point
Choose the Line Snap Move command.
Move the pointer near the line.
Click the left mouse button.

-or-
Set a point.

See Also:    Setting Points with DesignCAD Commands, Choosing Point Commands



Selecting Points
The Point Select Mode allows you to display all the points making up an entity.    After a line or entity is 
selected, each point making up that entity is highlighted with a small square, or select node.    This 
command selects entities so that you can use other commands to move, add, or delete points. 

Showing points
Activate the Point Select Mode.
Move the pointer near the entity.
Click the entity to select it.

-or-
Press Ins to select the entity.

See Also:    Choosing Point Commands, Point Select Mode



Moving and Copying Objects
Moving Objects
Moving Objects with Handles
Moving Objects Vertically
Moving Objects Horizontally
Copying Objects
Copying Objects with Handles



Drawing Multiple Copies
Copying Objects in Row
Copying Objects in Circle



Drawing Regular Arcs
Drawing Arc with Center and Radius
Drawing Arc with Beginning and End
Drawing Arc with Three Points
Drawing Arc with Center, Beginning, and End
Drawing Arc with Beginning, End, and Radius



Drawing Arc with Center and Radius
Choose the Arc-1 command.
To change the angle of the arc, type that number in the Angle box in the Command Line.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
To have the arc drawn with the same angle as another arc, choose the Same as box.    Then set a 

point on the arc in the drawing.
Set a point for the center of the arc.
Set a point for the beginning of the arc.

See Also:    Arc-1 command



Drawing Arc with Beginning and End
Choose the Arc-2 command.
To change the radius of the arc, type that number in the Radius box in the Command Line.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
To have the arc drawn with the same angle as another arc, choose the Same as box in the Command 

Line.    Then set a point on the arc in the drawing.
Set a point for the beginning of the arc.
Set a point for the end of the arc.

See Also:    Arc-2 command



Drawing Arc with Three Points
Choose the Arc-3 command.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the beginning of the arc.
Set a point for the center of the arc.
Set a point for the end of the arc.

See Also:    Arc-3 command



Drawing Arc with Center, Beginning, and End
Choose the Arc-4 command.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the center of the arc.
Set a point for the beginning of the arc.
Set a point for the end of the arc.

See Also:    Arc-4 command



Drawing Arc with Beginning, End, and Radius
Choose the Arc-5 command.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the beginning of the arc.
Set a point for the end of the arc.
Set a point for the center, or radius, of the arc.

See Also:    Arc-5 command



Drawing Elliptical Arcs
Choose the Elliptical Arc command.
To save the arc as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the center of the arc.
Set a point for the beginning of the arc.
Set a point for the end of the arc.

See Also:    Elliptical Arc command



Drawing Part of a Circle
Drawing quarter circle

Choose the Quarter Circle command.
To save the quarter circle as a vector entity, choose the Save as vector form box in the Command 

Line.
Set a point for the beginning of the quarter circle.
Set a point for the end of the quarter circle.

Drawing semi-circle
Choose the Semi-Circle command.
To save the semi-circle as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the beginning of the semi-circle.
Set a point for the end of the semi-circle.

See Also:    Quarter Circle command, Semi-Circle command



Drawing Regular Curves
Choose the Curve command.
To save the curve as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the beginning of the curve.
Set one or more points for the center of the curve.
Set a point for the end of the curve.
Press Enter.

See Also:    Curve command



Drawing Bezier Curves
Choose the Bezier Curve command.
Choose the Save as vector form box in the Command Line to save the curve as a vector entity.
Set a point for the beginning of the curve.
Set a point for the first control point.
Set a point for the second control point.
Set a point for the end of the curve.
Press Enter to end the command.

See Also:    Bezier Curve command



Drawing Freehand Curves
Choose the Sketch command.
Press and hold down the left mouse button.
Move the pointer in a curve motion.
Release the mouse button.

-or-
Press Alt+Ins to start the Sketch command.
Use the Alt and arrow keys to move the cursor.
Press Enter or Ins to end the command.

See Also:    Sketch command



Drawing Regular Circles
Drawing Circle with Center and Radius
Drawing Circle with Diameter Points
Drawing Circle with Three Points
Drawing Circle with Center and Radius Length



Drawing Circle with Center and Radius
Choose the Circle-1 command.
To save the circle as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the center of the circle.
Set a point for the radius of the circle.

See Also:    Circle-1 command



Drawing Circle with Diameter Points
Choose the Circle-2 command.
To save the circle as a vector entity, choose the Save as vector form box in the Command Line.
Set a point for the endpoint of the diameter.
Set a point for the other endpoint of the diameter.

See Also:    Circle-2 command



Drawing Circle with Three Points
Choose the Circle-3 command.
To save the circle as a vector entity, choose the Save as vector form box in the Command Line.
Set three points anywhere on the circle.

See Also:    Circle-3 command



Drawing Circle with Center and Radius Length
Choose the Circle-4 command.
Type the length in the Radius box in the Command Line.
To save the circle as a vector entity, choose the Save as vector form box in the Command Line.
To have the radius length the same as another circle in the drawing, click the Same as box in the 

Command Line.    Then set a point on the other circle in the drawing.
Set a point for the center of the arc.

See Also:    Circle-4 command



Drawing Tangent Circles
Drawing Circle Tangent to Two Lines
Drawing Circle Tangent to Three Lines



Drawing Circle Tangent to Two Lines
Choose the Tangent Two Lines command.
Type the length of the radius in the Radius box in the Command Line.
To have the radius drawn the same length as another circle in the drawing, choose the Same as box.    

Then set a point on the circle in the drawing.
Set a point on the first line.
Set a point on the second line.

See Also:    Tangent Two Lines command



Drawing Circle Tangent to Three Lines
Choose the Tangent Three Lines command.
Set a point on the first line.
Set a point on the second line.
Set a point on the third line.

See Also:    Tangent Three Lines command



Drawing Elliptical Circles
Choose the Ellipse command.
To save the arc as a vector entity, choose the Save as vector form box.
Set a point for the center of the ellipse.
Set a point for one axis of the ellipse.
Set a point through which the ellipse passes.

See Also:    Ellipse command



Drawing Regular Lines
Drawing a line

Choose the Line command.
Set a point for the beginning of the line.
Set up to 198 points for the line.
Set a point for the end of the line.
Press Enter.

Drawing an ortho line
Choose the Ortho Line command.
Set a point for the beginning of the line.
Set up to 198 points for the line.
Set a point for the end of the line.
Press Enter.

Drawing an arrow
Choose the Arrow command.
To change the size of the arrowhead, type the size in the Arrowhead Size box in the Command Line.
To change the type of arrowhead, choose the arrowhead type in the Arrowhead Type box in the 

Command Line.
To have the arrowhead drawn the same as another arrow, choose the Same as box in the Command 

Line.    Then choose another arrow entity in the drawing.
Set a point for the beginning of the arrow.
Set up to 198 points for the arrow.
Set a point for the end of the arrow.
Press Enter.

See Also:    Changing Line Characteristics



Drawing Parallel Lines
Drawing parallel lines with two points

Choose the Parallel-1 command.
Set a point on the line to which the parallel line is to be drawn.
Set a point at the location of the parallel line.

Drawing a parallel line with distance
Choose the Parallel-2 command.
Type the distance the parallel is to be drawn from the line in the Distance box in the Command Line.
Set a point on the line to which the parallel line is to be drawn.
Set a point the direction the parallel line is to be drawn.

See Also:    Changing Line Characteristics



Drawing Perpendicular Lines
Drawing a perpendicular line

Choose the Perpendicular To Line command.
Set a point for the beginning of the perpendicular line.
Set a point on the line the perpendicular line is to be drawn to.

Drawing a perpendicular line
Choose the Perpendicular From Line command.
Type the length of the perpendicular line in the Distance box in the Command Line.
Set a point on the line to which the perpendicular line is to be drawn.
Set a point the direction the perpendicular line is to be drawn.

See Also:    Changing Line Characteristics



Drawing Tangent Lines
Drawing a tangent from a point

Choose the Tangent To Circle command.
Set a point for the beginning of the line.
Set a point on or near the entity.

Drawing a tangent between circles
Choose the Tangent Between Circles command.
Set a point on or near the first circle.
Set a point on or near the second circle.

Drawing a tangent from a circle
Choose the Tangent From Circle command.
Set a point on or near the entity.
Set a point for the end of the line on or near the line tangent to the circle.    The endpoint of the line will 

be even with the second point.

See Also:    Changing Line Characteristics



Drawing Short Line Segments
Drawing tick marks

Choose the Tick Marks command.
Type the number of sections of tick marks in the Sections box in the Command Line.
Type the number of divisions of tick marks in the Divisions box in the Command Line.
Type the large tick mark size in the Large tick mark box in the Command Line.
Type the small tick mark size in the Small tick mark box in the Command Line.
Set a point on the entity.
Set a point to indicate which side of the entity the tick marks will be drawn.

Centering tick marks
Choose the Tick Marks command.
Type the number of sections of tick marks in the Sections box in the Command Line.
Type the number of divisions of tick marks in the Divisions box in the Command Line.
Type the large tick mark size in the Large tick mark box in the Command Line.
Type the small tick mark size in the Small tick mark box in the Command Line.
Set two points on the entity in the same location.

See Also:    Changing Line Characteristics



Changing Line Characteristics
The Show Line Style Box option selects the line pattern, width, and scale for lines drawn in DesignCAD.    
There are 13 line types to choose from.

Changing line style
Choose the Show Line Style Box option.
Choose the Line Type box.
Choose the new line type.
To change the scale of the line, choose the Scale box and type the new scale or use the arrow buttons

to change the scale in .10 Drawing Unit increments.
To change the width of the line, choose the Width box and type the new scale or use the arrow buttons

to change the width in .10 Drawing Unit increments.
To have the line drawn with the same scale and width of another line in the drawing, choose the Same 

as button.    Then set a point on the line in the drawing.

Changing line style of selected lines
Select the lines to be changed.
Choose the Show Line Style Box option.
Choose the line type from the line type menu.
To change the scale of the line, choose the Scale box and type the new scale or use the arrow buttons

to change the scale in .10 Drawing Unit increments.
To change the width of the line, choose the Width box and type the new scale or use the arrow buttons

to change the width in .10 Drawing Unit increments.
To have the line drawn with the same scale and width as another line in the drawing, choose the Same

as button.    Then set a point on the line in the drawing.
Choose the Apply box.

Removing line style menu
Choose the window Control-menu in the upper left corner of the menu.

-or-
Choose Show Line Style Box in the Options menu.

When the Fill Wide Lines option is selected wide lines are filled.

Filling wide lines
Choose the Fill Wide Lines option.

-or-
Choose the Show Line Style Box option.
Choose the Fill Wide Line box.

See Also:    Show Line Style Box option



Drawing Simple Polygons
Drawing a Polygon with Corner Points
Drawing a Polygon with Center and Corner



Drawing a Box
Choose the Box command.
Set a point for the first corner of the box.
Set a point for the opposite corner of the box.

Drawing a diagonal box
Choose the Box command.
Choose the Align to any angle box in the Command Line.
Set a point for the first corner of the box.
Set a point for the opposite corner of the box.
Set a point for the opposite edge of the box.

See Also:    Box command



Drawing Polygon with Corner Points
Choose the Polygon-1 command.
Type the number of sides in the Number of sides box in the Command Line.
To have the polygon drawn with the same number of sides as a polygon in the drawing, choose the 

Same as box in the Command Line.    Then set a point on the polygon in the drawing.
Set a point for the corner of the polygon.
Set a point for the opposite corner of the first side of the polygon.

See Also:    Polygon-1 command



Drawing Polygon with Center and Corner
Choose the Polygon-2 command.
Type the number of sides in the Number of sides box in the Command Line.
To have the polygon drawn with the same number of sides as a polygon in the drawing, choose the 

Same as box in the Command Line.    Then set a point on the polygon in the drawing.
Set a point for the center of the polygon.
Set a point for the first corner of the polygon.

See Also:    Polygon-2 command



"Unerasing" Objects
If you erase an entity by mistake

Choose the Unerase command from the Edit menu.

See Also:    Unerase command, Erasing Objects



Redoing Commands
After an Undo command, choose the Redo command from the Edit menu.

See Also:    Undoing Commands



Cutting Objects
Select the entity.
Choose the Cut command from the Edit menu.

See Also:    Cut command



Pasting Objects
Choose the Paste command from the Edit menu.

See Also:    Paste command



Changing Lines
Bending Lines
Deleting Points
Extending Lines
Moving Points
Stretching a Line



Breaking Lines
Defining a section

Choose the Cutoff command.
Set a point in the corner of the section.
Set a point in the opposite corner of the section.

Breaking a line
Select the line to be broken.
Choose the Break Line command.

Segmenting entities
Choose Segment from the Edit menu.
Type the number of sections in the No. of sections box in the Command Line.
Set a point on the entity to be segmented.
To see how the line was segmented, select the line.

See Also:    Breaking a Line, Break Line command, Editing Lines



Drawing Regular Text
Drawing Text
Drawing Text in a Block
Centered Text
Left-justified Text
Right-justified Text
Drawing Text in an Arc



Drawing Text
Choose the Text command.
Choose the Text box in the Command Line and type the text.
Type the size of text in the Size box in the Command Line.
Type the angle of the text in the Angle box in the Command Line.
To draw the text left justified, choose Left in the Orientation box.
To have the text drawn in bold text, choose the Bold button.
To have the text drawn in italic text, choose the Italic button.
Set a point for the lower left corner of the text.
Set a point for the lower right corner of the text.

To have the text drawn with the same options as other text in the drawing, choose the Same as button. 
Then select the text in the drawing.

See Also:    Text command



Drawing Text in a Block
Choose the Text command.
Type the text size in the Size box in the Command Line.
Type the angle of the text in the Angle box in the Command Line.
Choose the Bold button in the Command Line to have the text drawn in bold text.
Choose the Italic button in the Command Line to have the text drawn in italic text.
Choose the Text Block button in the Command Line.
Type the text in the Text box.
Type the distance between lines in the Line box.
Choose the OK button.
Set a point for the upper left corner of the text.
Set a point for the angle of the text.    Press the middle mouse button or Enter to have the text drawn 

without setting a point for the angle.

To have text drawn with the same options as other text in the drawing, choose the Same as button in 
the Command Line.    Then set a point on the text in the drawing.

See Also:    Text command



Drawing Attributes
The Attribute command assigns information to an object in the drawing.    This information can later be 
extracted from the drawing file and used with other programs for applications such as parts lists and a Bill 
of Materials lists.

Attributes will not be displayed on the screen unless the Show Attribute option is selected in the View 
menu.    Whether the attribute is displayed on the screen or not, it will be copied, deleted, etc., as a normal
entity.

Attributes can be extracted and used by the Materials List command.    This command creates a list of all 
attributes in a drawing and outputs this information to the printer or a disk file for use by other 
applications.

Adding attributes
Choose the Attribute command.
Choose the Attribute box in the Command Line and type the text.
If the show attributes options is selected, type the size of the attribute in the Size box.
Set a point for the lower left corner of the attribute.

Displaying attributes
Choose the Attribute command.
Choose the Show attributes box in the Command Line.

-or-
Choose Show Attribute from the View menu.

See Also:    Text Options, Changing Text Options



Adding Information to a Drawing
Drawing a Balloon around Information
Pulling out Information in a Drawing



Drawing a Balloon Around Information
Choose the Balloon command.
Choose the Text box in the Command Line and type the text for the balloon.
Type the size of the balloon, or circle, to be drawn around the text in the Balloon Size box in the 

Command Line.
Choose the Line box in the Command Line to set the arrowhead type, size, and line position.
To have the balloon drawn with the same options as another balloon in the drawing, choose the Same 

as button.    Then set a point on the balloon in the drawing.
Set a point for the balloon arrowhead.
Set a point for the direction of the extension line.
Set a point for the location of the text information.
Press Enter.

See Also:    Balloon command, Pullout command



"Pulling Out" Information In a Drawing
Choose the Pullout command.
Choose the Text box in the Command Line and type the text for the pullout.
Choose the Line button in the Command Line to change the position, size, and type of the arrowhead.
Choose the Text button in the Command Line to change the format, precision, location, orientation, 

and size of the text.
To have the pullout drawn with the same options as another pullout in the drawing, click the Same as 

button.    Then set a point on the balloon in the drawing.
Set a point for the pullout arrowhead.
Set a point for the direction of the extension line.
Set a point for the location of the text information.
Press Enter.

See Also:    Balloon command, Pullout command



Setting Font
The Text Options command sets the character font, style, size, angle, and spacing for text in the drawing. 
The font selected with this command determines how text drawn with the Attribute, Text, and Dimension 
commands will look.    The size of the text is set with these various commands. 

Choosing the font
Choose Text Options from the Options menu.
Choose the new font name in the Font box.
Choose a new style in the Font Style box.
Choose the text size in the Size box.
Choose the text angle in the Angle box.
Choose the spacing for text in the Text Block dialog box in the Spacing box.
Choose the OK button.

See Also:    Changing Text Font, Changing the Text and Font



Changing Text Layer and Color
Changing the layer of text

Select the text to be changed.
Choose Show Info Box from the View menu.
Choose the Layer box in the Info Box.
Choose the new layer.

Changing the text color
Select the text to be changed.
Choose Show Info Box from the View menu.
Choose the Color box in the Info Box.
Choose the new color in the Info Color box.
Choose the OK button.

See Also:    Text Options



Changing Text and Font
Changing the text

Select the text to be changed.
Choose Show Info Box from the View menu.
Choose the Content box in the Info Box.
Type the new text in the Text box.
Choose the OK button.

Changing the font
Select the text to be changed.
Choose Show Info Box from the View menu.
Choose the Font box in the Info Box.
Choose the new font in the Font dialog box.
Choose the OK button.

See Also:    Text Options



Changing Height, Length, and Angle
Changing the text height

Select the text to be changed.
Choose Show Info Box from the View menu.
Click the Height box in the Info Box.
Type the new text size in the Height box.

Changing the text length
Select the text to be changed.
Choose Show Info Box from the View menu.
Click the Length box in the Info Box.
Type the new text size in the Length box.

Changing the text angle
Select the text to be changed.
Choose Show Info Box from the View menu.
Click the Angle box in the Info Box.
Type the new text angle in the Angle box.

See Also:    Text Options



Changing Text Style
Select the text to be changed.
Choose Show Info Box from the View menu.
Choose the Bold button in the Style box.
Choose the Italic button in the Style box.

See Also:    Text Options



Scaling Objects with Select Scale
Scaling Selected Objects
Changing Scale Center



Scaling Objects with Selection Box
Scaling One Side of Object



Scaling Objects with Constant Aspect Ratio
Scaling Three Sides of Object



Scaling Selected Objects
Changing the width of an object

Select the object to be scaled.
Choose Select Scale from the Edit menu.
Click the left or right select nodes.
Move the pointer in the desired direction.
Set a point.

-or
Use the arrow keys to move the pointer to the left or right select nodes.
Press Alt+Ins.
Use the arrow keys to move the pointer.
Set a point.

Changing the height of an object
Select the object to be scaled.
Choose Select Scale from the Edit menu.
Click the top or bottom select nodes.
Move the pointer in the desired direction.
Set a point.

-or-
Use the arrow keys to move the pointer to the top or bottom select nodes.
Press Alt+Ins.
Use the arrow keys to move the pointer.
Set a point.

Changing diagonal width or height of object
Select the object to be scaled.
Choose Select Scale from the Edit menu.
Click the left or right select nodes.
Move the pointer in the desired direction.
Set a point.

-or-
Use the arrow keys to move the pointer to the select nodes.
Press Alt+Ins.
Use the arrow keys to move the pointer.
Set a point.

See Also:    Select Scale command



Changing Scale Center
Select the object to be scaled.
Choose Select Scale from the Edit menu.
Set a point on the center point.
Move the pointer in the desired location.
Set a point at the new location of the center.

See Also:    Cursor Pointer Shapes, Select Scale command



Finding Angle of Points and Lines
Calculating Angle of Two Points
Adding Angle of Objects to Drawing
Calculating Angle of Two Lines
Displaying Angle of Two Lines



Finding Area
Calculating Area
Adding Area to Drawing



Performing Calculations
Calculating Information
Inserting Calculation Into Drawing



Adding Area to Drawing
In the Area dialog box, highlight the text.
Press Ctrl+C to copy the text to the Clipboard.
Choose the OK button.
Choose the Text command from the Toolbox.
Choose the Text box in the Command Line.
Press Ctrl+V to paste the Clipboard contents.
Set the points for the text.

See Also:    Area command, Calculating Area



Calculating Angle of Two Points
Choose the Angle, Distance-Two Points command.
Set two points for the angle and distance to be measured.
Choose the Format box in the Angle box to set the angle format.
Choose the Precision box in the Angle box to set the angle precision.
Choose the Format box in the Distance box to set the linear format.
Choose the Precision box in the Distance box to set the linear precision.

See Also:    Angle, Distance-Two Points command, Adding Angle of Objects to Drawing



Adding Angle of Objects to Drawing
In the Angle and Distance dialog box, highlight the text.
Press Ctrl+C to copy the text to the Clipboard.
Choose the OK button.
Choose the Text command.
Click the Text box in the Command Line.
Press Ctrl+V to paste the Clipboard contents.
Set the points for the text.

See Also:    Angle, Distance-Two Points command, Calculating Angle of Two Points



Calculating Angle of Two Lines
Choose the Angle Between Two Lines command.
Set a point on the first line of the angle to be measured.
Set a point on the second line.
Choose the Format box to choose the format.
Choose the Precision box to choose the precision.
Choose the OK button.

See Also:    Displaying Angle of Two Lines, Angle Between Two Lines command



Displaying Angle of Two Lines
In the Angle Between Two Lines dialog box, highlight the angle text.
Press Ctrl+C to copy the text to the Clipboard.
Choose the OK button.
Choose the Text command.
Choose the Text box in the Command Line.
Press Ctrl+V to paste the Clipboard contents.
Set the points for the text.

See Also:    Calculating Angle of Two Lines, Angle Between Two Lines command



Zooming Selected Objects
Zooming an object

Select the object to be zoomed.
Choose the Select Zoom command from the Edit menu.
Click a point on the highlighting box.
Move the pointer in the desired direction.    A rubber band box shows how the object will be zoomed.
Click the left mouse button.

-or-
Move the cursor to a node on the highlighting box.
Press Alt+Ins.
Use the arrow keys to move the pointer to the desired location.
Set a point.

Moving the zoom center
Select the object to be zoomed.
Choose the Select Zoom command from the Edit menu.
Set a point on the center point mark in the highlighting box.
Move the pointer in the desired direction.
Click the left mouse button.

See Also:    Select Zoom command



Understanding Dimension Basics
There are several options and characteristics that must be understood when using the dimension 
commands.

Extension line
Extension Line Overshoot
Gap
Dimension line
Terminator or arrowhead
Dimension text
Tolerancing information



Dimensioning Lines
Drawing Horizontal Dimensions
Drawing Vertical Dimensions
Drawing Angle Dimensions
Drawing Chamfered Dimensions
Drawing Baseline Dimensions
Drawing Extended Dimensions
Drawing Progressive Dimensions



Drawing Horizontal Dimensions
Choose the Dimension command.
Choose the Horizontal button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

Drawing horizontal dimensions without extension lines
Choose the Dimension, distance only command.
Choose the Horizontal button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

See Also:    Dimensioning Lines, Changing Dimension Options



Drawing Vertical Dimensions
Choose the Dimension command.
Choose the Vertical button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

Drawing vertical dimensions without extension lines
Choose the Dimension, distance only command
Choose the Vertical button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

See Also:    Dimensioning Lines, Changing Dimension Options



Drawing Angle Dimensions
Choose the Dimension Angle command.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the center, or vertex, of the angle to be measured.
Set a point for the beginning of the angle to be dimensioned.
Set a point for the end of the angle to be measured.
Set a point for the location of the text information.

Drawing dimensions aligned to any angle
Choose the Dimension command.
Click the Align to any angle button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

Drawing angled dimensions without extension lines
Choose the Dimension, distance only command.
Choose the Align to any angle button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the beginning of the dimension.
Set a point for the end of the dimension.
Set a point for the location of the text information.

See Also:    Dimensioning Lines, Changing Dimension Options



Drawing Chamfered Dimensions
Choose the Dimension Chamfer command.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the chamfered line.
Set a point for the extension line.
Set a point for the end of the extension line.
Set a point for the text location.

See Also:    Dimensioning Lines, Changing Dimension Options



Dimensioning Coordinate Points
Choose the Coordinate Dimension command.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the origin, or reference point.
Set a point for the point to be measured.
Set a point for the text location.
Press Enter.

See Also:    Changing Dimension Options



Dimensioning Circles
Drawing Diameter Dimensions with Pre-Defined Extension Line
Drawing Diameter Dimensions Outside Circle
Drawing Diameter Dimensions Inside Circle
Drawing Radius Dimensions with Pre-Defined Extension Line
Drawing Radius Dimensions Outside Circle
Drawing Radius Dimensions Inside Circle



Drawing Diameter Dimensions with Pre-Defined 
Extension Line

Choose the Diameter Dimension command.
To have the dimension drawn with a pre-defined extension line, choose the Pre-defined Extension 

button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Diameter Dimensions Inside Circle
Choose the Diameter Dimension command.
To have the dimension arrowheads drawn inside the circle, choose the Dimension Inside Circle button 

in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Diameter Dimensions Outside Circle
Choose the Diameter Dimension command.
To have the dimension text and arrowheads drawn outside the circle, choose the Dimension Outside 

Circle button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the direction of the extension line.
Set a point for the location of the text information.
Press Enter.

See Also:    Changing Dimension Options



Drawing Radius Dimensions with Pre-Defined 
Extension Line

Choose the Radius Dimension command.
To have the dimension drawn with a pre-defined extension line, choose the Pre-defined Extension 

button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Radius Dimensions Inside Circle
Choose the Radius Dimension command.
To have the dimension arrowheads drawn inside the circle, choose the Dimension Inside Circle button 

in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Radius Dimensions Outside Circle
Choose the Radius Dimension command.
To have the dimension text and arrowheads drawn outside the circle, choose the Dimension Outside 

Circle button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the circle or arc to be dimensioned.
Set a point for the direction of the extension line.
 Set a point for the location of the text information.
Press Enter.

See Also:    Changing Dimension Options



Dimensioning Arcs
Drawing Arc Dimensions
Drawing Diameter Dimensions with Pre-Defined Extension Line
Drawing Diameter Dimensions Outside Arc
Drawing Diameter Dimensions Inside Arc
Drawing Radius Dimensions with Pre-Defined Extension Line
Drawing Radius Dimensions Outside Arc
Drawing Radius Dimensions Inside Arc



Drawing Arc Dimensions
Choose the Dimension Arc command.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be measured.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Diameter Dimensions Outside Arc
Choose the Diameter Dimension command.
To have the dimension text and arrowheads drawn outside the arc, choose the Dimension Outside Arc 

button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Diameter Dimensions Inside Arc
Choose the Diameter Dimension command.
To have the dimension arrowheads drawn inside the arc, choose the Dimension Inside Arc button in 

the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Radius Dimensions with Pre-Defined 
Extension Line

Choose the Radius Dimension command.
To have the dimension drawn with a pre-defined extension line, choose the Pre-defined Extension 

button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Radius Dimensions Inside Arc
Choose the Radius Dimension command.
To have the dimension arrowheads drawn inside the arc, choose the Dimension Inside Arc button in 

the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be dimensioned.
Set a point for the location of the text information.

See Also:    Changing Dimension Options



Drawing Radius Dimensions Outside Arc
Choose the Radius Dimension command.
To have the dimension text and arrowheads drawn outside the arc, choose the Dimension Outside Arc 

button in the Command Line.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point on the arc to be dimensioned.
Set a point for the direction of the extension line.
 Set a point for the location of the text information.
Press Enter.

See Also:    Changing Dimension Options



Changing Dimension Options
Angular Text Format
Angular Text Precision
Dimension Arrowhead Size
Dimension Arrowhead Type
Dimension Offset
Dimension Prefix
Dimension Suffix
Dimension Text Location
Dimension Text Orientation
Dimension Text Size
Dimension Tolerance Text Size
Fixed Length
Linear Text Format
Linear Text Precision
No Dimension Tolerance
Overshoot Length
Position of Dimension Arrows
Positive and Negative Dimension Tolerance
Positive or Negative Dimension Tolerance
Saving a Vector Dimension
Variable Length



Drawing Baseline Dimensions
Choose the Baseline Dimension command.
Choose the Horizontal button to draw horizontal dimensions.
Choose the Vertical button to draw vertical dimensions.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the first measurement position.
Set a point for the second measurement position.
Set a point for the final measurement position.
Set a point for the location of the dimension text information.
Press Enter.

See Also:    Dimensioning Lines, Changing Dimension Options



Drawing Extended Dimensions
Choose the Extended Dimension command.
Choose the Horizontal button to draw horizontal dimensions.
Choose the Vertical button to draw vertical dimensions.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the first measurement position.
Set a point for the second measurement position.
Set a point for the final measurement position.
Set a point for the location of the dimension text information.
Press Enter.

See Also:    Dimensioning Lines, Changing Dimension Options



Drawing Progressive Dimensions
Drawing successive dimensions

Choose the Progress Dimension command.
Choose the Horizontal button to draw horizontal dimensions.
Choose the Vertical button to draw vertical dimensions.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the base point.
Set a point for the first measurement position.
Set a point for the final measurement position.
Set a point for the location of the dimension text information.
Press Enter.

Drawing successive dimensions
Choose the Progressive Radius Dimension.
To have the dimension drawn with the same options as another dimension in the drawing, choose the 

Same as button.    Then set a point on the dimension in the drawing.
Set a point for the base point.
Set a point for the first measurement position.
Set a point for the final measurement position.
Set a point for the text location.
Press Enter.

See Also:    Dimensioning Lines, Changing Dimension Options



Changing Dimension Layer and Color
Changing the dimension layer

Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Layer box in the Info Box.
Choose the new layer number.

Changing the dimension color
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Color box in the Info Box.
Choose the new color from the Info Color box.
Choose the OK button.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Dimension Position
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Position box in the Info Box.
Choose the new position.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Arrowhead Type
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Arrow Type box in the Info Box.
Choose the new arrowhead.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Dimension Location and Orientation
Changing the dimension location

Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Location box in the Info Box.
Choose the new dimension location.

Changing the dimension orientation
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Orientation box in the Info Box.
Choose the new dimension orientation.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Dimension Size and Tolerance
Changing the dimension size

Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Text Size box in the Info Box.
Type the new text size.

Changing the dimension tolerance
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Click the Single Tolerance box or the Double Tolerance box in the Info Box.
Type the new values for the tolerance.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Dimension Prefix and Suffix
Changing the dimension prefix

Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Prefix box in the Info Box.
Type the new prefix.

Changing the dimension suffix
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Suffix box in the Info Box.
Type the new suffix.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Changing Colors
Changing drawing color

Choose the Show Color Table option in the Toolbox.
Choose the color from the color table.

Changing color of selected objects
Select the object to be changed.
Choose the Show Color Table option in the Toolbox.
Choose the color.
Choose the Apply button.

Changing color of entity in Info Box
Select the entity to be changed.
Choose Show Info Box in the View menu.
Choose the Color button.
Choose the color.
Choose the OK button.

Setting color same as an entity
Choose the Show Color Table option in the Toolbox.
Choose the Same as box.
Select the entity with the color you want.
Select the entity to be changed.
Choose the Apply button.

Removing the color table
Choose the window Control-menu in the upper right corner of the menu.

-or-
Choose the Show Color Table option from the Options menu.

See Also:    Changing Entity Color



Hatching a Selected Area
Choose the Hatch command from the Draw menu.
Type the size of the hatch pattern in the Hatch Scale box in the Command Line.
Type the angle of the hatch pattern in the Hatch Angle box in the Command Line.
Select the hatch pattern in the Hatch Pattern box in the Command Line.
To have the hatch pattern drawn with the same options as another hatch pattern in the drawing, 

choose the Same as button.    Then set a point on the hatch pattern in the drawing.
Set points around the area to be hatched.
Press Enter.

See Also:    Hatch Patterns, Selecting a Hatch Pattern



Hatching a Line Entity
Choose the Hatch Line command from the Draw menu.
Select the line to be hatched.
Type the size of the hatch pattern in the Hatch Scale box in the Command Line.
Type the angle of the hatch pattern in the Hatch Angle box in the Command Line.
Select the hatch pattern in the Hatch Pattern box in the Command Line.
To have the hatch pattern drawn with the same options as another hatch pattern in the drawing, 

choose the Same as button.    Then set a point on the hatch pattern in the drawing.
Press Enter.

See Also:    Hatch Patterns, Selecting a Hatch Pattern



Hatching an Enclosed Area
Choose the Hatch Fill command from the Draw menu.
Type the size of the hatch pattern in the Hatch Scale box in the Command Line.
Type the angle of the hatch pattern in the Hatch Angle box in the Command Line.
Select the hatch pattern in the Hatch Pattern box in the Command Line.
If the entity is selected before the command is chosen, you can click the "Selection Only" box to limit 

the hatch boundary to only those lines that are selected.
To have the hatch pattern drawn with the same options as another hatch pattern in the drawing, 

choose the Same as button.    Then set a point on the hatch pattern in the drawing.
Set a point inside the area to be hatched.

See Also:    Hatch Patterns, Selecting a Hatch Pattern



Editing a Hatch Pattern
Erasing a pattern

Activate the Select Mode.
Move the pointer to the hatched area.
Select the hatch pattern.

-or-
Choose the Entity Select command from the Edit menu.
Choose Hatch.
Choose the OK button.
Choose the Erase command from the Edit menu.
Note:    Choosing the Entity Select command then the Edit command erases all hatch patterns in the 

drawing.

See Also:    Hatch Patterns, Selecting a Hatch Pattern



Setting Layer Options
Choose the Layer Setup command from the Options menu.
Type the layer number in the Number box.
Type a name for the layer in the Name box.
Choose the Multilayer box to manipulate entities in the layers.
The Layer Status box displays information for the layers.
Choose the Commands button to choose one of the layer commands.
Choose the OK button.

Current layer
When you create a new drawing, the entities are added to the current layer.    The current layer is shown 
in the Coordinate Bar at the top of the screen.    The current layer defaults to Layer 1 unless otherwise 
specified.

Visible/Invisible layers
Each layer can be set to visible or invisible status.    A visible layer is displayed on the screen.    An 
invisible layer is not visible on the screen.    A visible layer can be edited or can be "uneditable."    An 
invisible layer cannot be editable.

See Also:    Setting Invisible Layers, Setting Visible Layers, Setting Uneditable Layers, Setting Editable 
Layers,    Setting Current Layer, Manipulating Current Layer Only



Manipulating Current Layer Only
Choose the Layer Setup command from the Options menu.
Type the current layer number in the Number box.
Type a name for the layer in the Name box.
Choose the Multilayer box to disable it
Press Enter.

See Also:    Setting Layer Options



Setting Current Layer
Select the Layer box in the Coordinate Bar.
Choose the arrow button

-or-
Press Alt+down arrow.
Choose the layer number you want to be active.

See Also:    Setting Layer Options



Setting Invisible Layers
Choose the Layer Setup command in the Options menu.
Double-click the layer in the Layer Status box.

-or-
Press Tab.
Choose the layer.
Then press Alt+Shift+Ins in the Layer Status box.
Choose the Visible box to disable it.
Press Enter.

See Also:    Setting Visible Layers, Setting Layer Options



Setting Visible Layers
Choose the Layer Setup command in the Options menu.
Double-click the layer in the Layer Status box.

-or-
Press Tab.
Choose the layer.
Then press Alt+Shift+Ins in the Layer Status box.
Choose the Visible box to enable it.
Press Enter.

See Also:    Setting Invisible Layers, Setting Layer Options



Setting "Uneditable" Layers
Choose the Layer Setup command in the Options menu.
Double-click the layer in the Layer Status box.

-or-
Press Tab.
Choose the layer.
Then press Alt+Shift+Ins in the Layer Status box.
Choose the Editable box to disable it.
Press Enter.

See Also:    Setting Editable Layers, Setting Layer Options



Setting Editable Layers
Choose the Layer Setup command in the Options menu.
Double-click the layer in the Layer Status box.

-or-
Press Tab.
Choose the layer.
Then press Alt+Shift+Ins in the Layer Status box.
Choose the Editable box to enable it.
Press Enter.

See Also:    Setting Uneditable Layers, Setting Layer Options



Changing Layer Colors and Line Style
Changing color of layer

Choose the Set Layer Color command in the Options menu.
Choose the new color for the current layer.
Choose the OK button.

There are 13 line types available.

Changing the line style in layers
Choose the Set Layer Line Style command in the Options menu.
Choose the line type in the Line Type box.
To change the scale of the line, type the value in the Scale box.
To change the width of the line, type the value in the Width box.
Choose the OK button.

See Also:    Manipulating Layers



Saving and Deleting Layers
Saving layer

Choose the layer to be saved in the Layer box in the Coordinate Bar.
Choose the Save Layer command from the Options menu.
Type the file name in the File Name box.
Choose the OK button.

Deleting a layer
Choose the layer to be deleted in the Layer box in the Coordinate Bar.
Choose the Delete Layer command in the Options menu.

See Also:    Manipulating Layers, Saving Layers, Editing Layers, Deleting a Layer



Selecting and Moving Layers
Selecting an entire layer

Choose the layer to be selected in the Layer box in the Coordinate Bar.
Choose the Select Layer command in the Options menu.

Moving entities to different layers
Choose the Move Layer command in the Options menu.
Choose the layer number the current layer is to be moved to in the selection box.
Choose the OK button.

See Also:    Manipulating Layers, Editing Layers, Selecting Layers



Separating Colors into Layers
Choose the Separate by Color command in the Layer secondary menu in the Options menu.

See Also:    Separate by Color command, Manipulating Layers, Editing Layers



Installing Symbols
DesignCAD comes with over 400 pre-drawn symbols you can use in your drawings.    These symbols are 
found in separate libraries.

You can install symbols by running SETUP, the DesignCAD installation program.

Installing symbols
If Windows is not already running, enter WIN at the DOS prompt.

-or-
If Windows is running, close any open applications.
Insert DesignCAD disk #1 into the correct drive.
Choose Run from the File menu.
Enter A:SETUP or B:SETUP.
To accept the path that Setup proposes, choose the Continue button.

-or-
To choose your own directory, type a new path in the Install To box, then choose the Continue button.
Choose the Install Symbols box to enable it.
Choose the Install DesignCAD box to disable it.
Choose the Install Sample Drawings box to disable it.
Select the symbol libraries you want to install.
Follow instructions.
When Setup is complete, choose the OK button.

See Also:    Loading Symbols, Creating Symbols, Symbols Libraries



Manipulating Symbols
In DesignCAD, symbols are defined as a single entity.    That is, the entire symbol is selected, moved, 
edited, and erased with DesignCAD commands.

To change a single line or entity in a symbol, you must first "explode" the symbol with the Symbol Explode
command.

Exploding a symbol
Choose the Symbol Explode command from the Edit menu.
Set a point on the symbol to be exploded.
Press Enter.

See Also:    Using Symbols



Creating Symbols
It is easy to create your own custom symbols in DesignCAD.    Simply follow these rules:

Create the symbol in Layer 0.    When you retrieve a drawing each layer normally remains in the same 
layer.    However, when a drawing or symbol is saved in Layer 0 it is retrieved into the current layer.    
This lets you make a symbol and load the symbol into any layer of the drawing.

Set one or two points for the drawing handles with the Set Handles command before saving the 
drawing.    When you save a drawing DesignCAD defines these points as reference points.    These 
"reference points" determine the size and scale of a drawing or symbol when it is retrieved.

Set the correct Drawing Units before saving the symbol.    The Drawing Units determine the size of the 
symbol.    If a symbol is retrieved using a single point it will be scaled according to the Drawing Units 
of the current drawing.

Creating your own symbols
Choose 0 in the Layer box in the Coordinate Bar.
Draw the symbol.
Choose the Save command to save the symbol.

See Also:    Using Symbols



Defining a Group
Select the entities to be defined as a Group.
Choose the Group Define command from the Edit menu.
Press Enter.

See Also:    Defining and Undefining Groups, Group command, "Undefining" a Group



"Undefining" a Group
"Exploding" a group

Select the Group to be exploded.
Choose the Group Explode command from the Edit menu.
Press Enter.

See Also:    Defining and Undefining Groups, Group Explode command, Defining a Group



Combining Two Drawings
DesignCAD allows you to merge more than one drawing into a single drawing.    DesignCAD opens the 
first drawing, then merges the second drawing on top of it.    The Drawing Units of the second drawing are
matched to those of the drawing already on the screen.

Merging a drawing
Choose the Merge command from the File menu.
Choose the file you want to merge with the current drawing from the File Name box.
Set a point for the lower left corner of the drawing.
Set a point for the lower right corner of the drawing.
Set a point for the upper left corner of the drawing.
Set a point for the upper right corner of the drawing.

See Also:    Merge command, Combining Drawings



Opening a New Window
Opening multiple views

Choose the New Window command from the Window menu.

Drawing commands effect all views of the drawing.

Making a drawing view active
From the Window menu, choose the name of the drawing view you want to make active.

See Also:    Closing a Window, Arranging All Open Drawing Windows, Opening Views, Opening Multiple 
Views of a Drawing



Manipulating the Views
Different views of the drawing window become icons when they are minimized.    

Minimizing drawing windows
Choose the Minimize button in the upper right corner of the drawing window.

You can move these icons around the screen.    The Arrange Icons command straightens any icons on the
screen and places them along the bottom of the screen.

Arranging Icons
Choose the Arrange Icons command from the Window menu.

See Also:    Opening a New Window, Arranging All Open Drawing Windows



Changing Coordinate Bar Information
Showing Angle and Distance coordinates

Choose Show Polar Coordinates from the View menu.
The Coordinate Bar will change to show the Angle and Distance coordinates.

Showing X, Y, Delta X, Delta Y coordinates
If a check mark in next to Show Polar Coordinates in the View menu, choose the command.
The Coordinate Bar will change to show the X, Y, Delta X, and Delta Y coordinates.

See Also:    Coordinate Bar



Setting the Display Grid
The display grid helps you set points and draw entities.    This grid does not appear when the drawing is 
printed.

Enabling the Display Grid
Choose the Display Grid option from the Options menu.

See Also:    Display Grid command, Snap Grid command



Setting the Grid Sizes
Choose the Grid Options command from the Options menu.
Type the display grid size in Drawing Units in the Display Grid Size box.
Type the display grid type in the Display Grid Type box.
Type the snap grid size in Drawing Units in the Snap Grid Size box.
Choose the Enable Display Grid box to enable the display grid.
Choose the Enable Snap Grid box to enable the snap grid.
Choose the OK button.

See Also:    Setting the Display Grid Size, Setting the Snap Grid



Displaying Cursor Crosshairs
The Crosshair option turns the cursor crosshairs on or off.    These crosshairs can be used to line up 
points on the drawing screen.

Displaying the cursor crosshairs
Choose the Crosshair option from the Options menu.

See Also:    Crosshair command



Measuring the Units
The Units command sets the units of measurement for the drawing.    These units of measurement are 
called Drawing Units.    Drawing Units can be inches, centimeters, feet, miles, any unit of measurement 
that makes sense for the drawing.

Setting Drawing Units
Choose the Units command from the Options menu.
Set two points a certain distance apart.
Type the distance these points represent in the New distance box.
The original distance is shown in the Original distance box.
Choose the OK button.

See Also:    Units command



Compatible File Formats
Import File Formats

ASCII text files
AutoCAD DXF format files
DesignCAD 2-D ASCII files
DesignCAD 2-D Binary files
DesignCAD 3-D ASCII files
DesignCAD 3-D Binary files
Hewlett Packard plotter (HPGL) files
IGES (Initial Graphics Exchange Standard) format files 
X, Y coordinate files

Export File Formats

IGES (Initial Graphics Exchange Standard) format files 
AutoCAD DXF format files
PostScript format files
WordPerfect graphics files



Importing Drawings
DesignCAD allows you to import drawings from other drawing file formats into DesignCAD.

Importing DXF file formats
Choose Import DXF from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing IGES file formats
Choose Import IGES from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing HPGL file formats
Choose Import HPGL from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing ASCII text file formats
Choose Import ASCII from the File menu.
Choose the file from the File Name box.
Choose the OK button.

Importing XY file formats
Choose Import XY from the File menu.
Choose the Straight Line button to import straight lines.
Choose the Curved Line button to import curved lines.
Choose the Small Squares button to import small squares.
Choose the Small Circles button to import small circles.
Choose the Mark Size box to set the size of point marks.
Choose the Color button to set the color.
Choose the color from the Line Color box.
Choose the OK button.
Choose the OK button.
Choose the file name from the File Name box.
Choose the OK button.

See Also:    DXF Format Files, IGES Format Files, HPGL Format Files, DesignCAD 2-D ASCII Format 
Files, XY Format Files, Opening a File Created by Another Application



Exporting Drawings
DesignCAD allows you to transfer drawing files to other programs.

Exporting DXF file formats
Display the drawing you want to export on the screen.
Choose the Export DXF command from the File menu.

Exporting IGES file formats
Display the drawing you want to export on the screen.
Choose the Export IGES command from the File menu.

Exporting WordPerfect file formats
Display the drawing you want to export on the screen.
Choose the Export WordPerfect command from the File menu.

See Also:    DXF Format Files, IGES Format Files, PostScript Format Files, WordPerfect Format Files, 
DesignCAD Drawing File Formats



ASCII File Format
DesignCAD drawing files can be saved with a .DC2 file extension by choosing the ".DC2" extension in the
Save As command.    This is an ASCII file format, where the data is written in character format.    Each 
"record" in the file is actually a line in a text file.

There are four types of records, or lines, in the file:

Header Line
Entity Line
Point Line
String Line

See Also:    Understanding System Parameters, Point Definitions



Header Line
The header line tells, among other things, how many entity lines are to follow.    The header line contains 
up to seven numbers:

1 -- The minimum X coordinate in the file
2 -- The minimum Y coordinate in the file
3 -- The horizontal length of the drawing
4 -- The vertical height of the drawing
5 -- A zero for compatibility with DesignCAD 2-D
6 -- A zero for compatibility with DesignCAD 3-D
7 -- Version number

The coordinates are in arbitrary units.    The Drawing Units Size -- entity type 40 -- can be used to 
determine the "real world" coordinates or the size of one Drawing Unit.

See Also:    Understanding System Parameters, Point Definitions



Entity Line
The entity line tells the type of drawing entity and how many points are to follow.    The entity line contains 
six or twelve numbers:

1 -- The type of entity:
0 -- Handles
1 -- Line
2 -- Oval
3 -- Text
4 -- Curve
5 -- Arc
11 -- Bezier Curve
15 -- Attribute
16 -- Circle, Circular Arc
17 -- Hatch
22 -- Text Arc
23 -- Layer Names
25 -- Symbol
31 -- Plane
32 -- Grid
33 -- Grid line
70 -- Point
74 -- Dimension Angle
75 -- Dimension
76 -- Dimension Diameter and Radius
77 -- Dimension Arc
78 -- Dimension Progressive Radius
79 -- Dimension Progress
80 -- Dimension Chamfer
81 -- Dimension Coordinate
90 -- Bitmap Image

2. The number of points to follow (0-200)
-or-
The layer number (0-255) if entity is 21

3. The line pattern scale (1 -- normal)
-or-
The hatch pattern scale

4. The line width
5. The line type (0-8)
6. The color (0-255)
7. Reserved    -- Optional to dimension entities
8. Dimension Format -- Optional to dimension entities
9. Group ID -- Optional to entity grouping
10. Red Color (0-255)
11. Green Color (0-255)
12. Blue Color (0-255)

See Also:    Understanding System Parameters, Point Definitions



Point Line, ASCII
The Point line contains point coordinates.    Each line contains two numbers:    X coordinate and Y 
coordinate of the point on the screen.    There is one point per line.    These values will change when the 
drawing is retrieved according to the size, location, and angle of the drawing when it is loaded.

There can be no more than 200 points per entity.    A line or curve entity with more than 200 points may be
used by splitting it into two or more entities.

If the entity type is 40 or 41, then the number of points represents the number of lines that follow that 
entity.    Each line may have more than one value, and these values do not represent points.

The point line can contain an X, Y, and Z coordinate.    However, the Z coordinate is ignored in 
DesignCAD 2-D.

See Also:    Understanding System Parameters, Point Definitions



String Line
The string line contains a string of text.    There is one string per line.    Strings are found in entities drawn 
with the Text, Text Arc, Attribute, Hatch, Symbol, and dimension commands.

There can be no more than 80 characters per string length.

The string line must be terminated with a carriage return character.    Trailing blanks will be used to 
determine the string length.

See Also:    Understanding System Parameters, Point Definitions



Understanding System Parameters
The system parameters follow entity type 41.    The system parameters are saved with each drawing 
when the Save Parameters With Drawing box is selected in the Miscellaneous Options dialog box.    
These consist of:

Line 1:
1 -- Drawing Unit size
2 -- Large cursor step size
3 -- Small cursor step size

Line 2:
1 -- Reserved
2 -- Display grid type
3 -- Display grid enable
5 -- Snap grid enable
6 -- Dimension text format
7 -- Dynamic dimension enable
8 -- Tolerance enable
9 -- Dimension arrowhead type
10 -- Dimension text location
11 -- Dimension precision
12 -- Fill wide lines enable
13 -- Angular dimension type
14 -- Angular dimension precision
15 -- Point mark

Line 3:
1 -- Display grid size
2 -- Default text size
3 -- Default text angle
4 -- Drawing Units per inch on output
5 -- Snap grid size

Line 4:
1 -- (Not used in this version)    0
2 -- (Not used in this version)    1.0
3 -- (Not used in this version)    1.0
4 -- (Not used in this version)    1.0
5 -- (Not used in this version)    1.0

Line 5:
1 -- "Simplex2.vfn" - (Not used in this version)

Line 6:
1 -- (blank line) (Not used in this version)

Line 7 (optional):
1 -- dimension text size
2 -- dimension text horizontal scale
3 -- dimension text slant
4 -- dimension tolerance text size
5 -- dimension extension line overshoot



Line 8 (optional):
1 -- dimension extension line gap
2 -- dimension extension line length
3 -- dimension arrowhead scale
4 -- dimension balloon size
5 -- baseline dimension offset

Line 9 (optional):
1 -- dimension layer
2 -- dimension type
3 -- angular dimension type
4 -- dimension precision
5 -- angular dimension precision
6 -- dimension tolerance enabled/disabled

See Also:    ASCII File Format



Point Definitions
Entity number Entity type Points

0 Drawing handle 1 -- Primary handle
2 -- Secondary handle(optional)

1 Line 1-200:    Points for line
2 Ellipse 1 -- Center

2 -- Axis
3 -- Ellipse pass through
4 -- Minimum X, Y position
5 -- Maximum X, Y position

3 Text 1 -- Lower left corner
2 -- Lower right corner

4 Curve 1-200:    Points for curve
5 Elliptical Arc 1 -- Center

2 -- Beginning point
3 -- End point
4 -- Minimum X, Y (optional)
5 -- Maximum X, Y (optional)
6 -- Radius 1 (optional)
7 -- Radius 2 (optional)

11 Bezier Curve 1 -- Beginning
2 -- First control point
3 -- Second control point
4 -- End

15 Attribute 1 -- Text location
16 Circle 1 -- Center

2 -- Beginning
3 -- End
4 -- Minimum X, Y (optional)
5 -- Maximum X, Y (optional)

17 Hatch 1-200:    Area to be hatched
22 Text Arc 1 -- Center

2 -- Beginning
3 -- End
4 -- Beginning point for text
5 -- Minimum X, Y (optional)
6 -- Maximum X, Y (optional)

23 Layer Names None
One name for each "point"

24 Arrow 1-198:    1-n -- Line
n --    Position of arrowhead

26 Symbol 1 -- Lower left corner (primary handle)
2 -- Lower right corner (secondary handle)
3 -- Upper right corner
4 -- Upper left corner
5 -- Primary handle
6 -- Secondary handle

31 Plane 1-200: 1 -- First vertex
2 -- Second vertex
3- n -- Vertex plane
First and last - Same

32 Grid None
Number of points on Command Line tells how many grid line follow.

33 Grid Line None



Number of points on Command Line tells how many grid line follow.
70 Point Mark 1 -- Mark location
74 Dimension Angle 1 -- Center

2 -- Beginning
3 -- End
4 -- Beginning first dimension line
5 -- End first dimension line
6 -- Beginning second dimension line
7 -- End second dimension line
8 -- Text height, arrowhead size

75 Dimension 1 -- Beginning distance to be measured
2 -- End distance to be measured
3 -- Beginning extension line
4 -- End extension line
5 -- Beginning dimension line
6 -- End dimension line
7 -- Text height, arrowhead size

76 Dimension 1 -- Beginning dimension line
Diameter/Radius 2 -- End dimension line

3 -- Beginning distance to be measured
4 -- End distance to be measured
5 -- Beginning extension line
6 -- End extension line
7 -- Text height, arrowhead size

77 Dimension Arc 1 -- Center
2 -- Beginning
3 -- End
4 -- Beginning extension line
5 -- End extension line
6 -- Text height, arrowhead size

78 Dimension 1 -- Base
Radius Progress 2 -- Beginning of extension arc

3 -- End of extension arc
4 -- Beginning dimension line
5 -- End dimension line
6 -- Text height, arrowhead size

79 Dimension 1 -- Base
Progress 2 -- Beginning dimension line

3 -- End dimension line
4 -- Beginning first extension line
5 -- End first extension line
6 -- Beginning second extension line
7 -- End second extension line
8 -- Text height, arrowhead size

80 Dimension 1 -- Beginning distance to be measured
Chamfer 2 -- End distance to be measured

3 -- Beginning dimension line
4 -- End dimension line
5 -- Text height, arrowhead size

81 Dimension 1 -- Base
Coordinate 2 -- Beginning extension line

3 -- End extension line
4 -- Text size, arrowhead type

90 Bitmap Image 1 -- Upper left corner
2 -- Upper right corner
3 -- Lower right corner



4 -- Lower left corner
5 -- Lower left corner
6 -- Upper right corner

See Also:    ASCII File Format



Binary File Format
The DesignCAD .DW2 file is a binary file containing the following information:

Header Line
Entities

See Also:    DesignCAD 2-D Binary Files



Binary Header Line
The header line is the following format (sizes are in bytes):

Size Description
2 Drawing type:    1099 -- 2-D; 1199 -- 3-D
2 DesignCAD version number
2 Data type:    4 -- single precision; 8 -- double precision

See Also:    Binary File Format



Binary Entity
The entities are in the following format:

Size Description
2 Entity code
2 Number of bytes in entity

(Not including entity code and this field)
n Information for the entity

Drawing size entity    The first entity in the drawing is the "Drawing Size" entity.    It has the following 
format:

Size Description
2 Drawing Size Entity Code -- 1200
2 Number of bytes -- 16
4 X drawing minimum
4 Y drawing minimum
4 X drawing width
4 Y drawing height

Parameter entities    The following parameter entities may appear in the drawing:

Entity Size Parameters
1300 2 Number of digits of accuracy
1301 2 Display attribute flag
1302 2 Font type
1303 2 Snap grid enable
1304 2 Beep type
1305 2 Current layer manipulation
1306 2 Dimension type
1307 2 Dynamic dimensioning enable
1308 4 Large cursor step size
1309 4 Drawing Unit scale
1310 4 Snap grid size
1311 4 Text size
1312 4 Text angle
1313 4 Drawing Units per inch on output
1314 4 Drawing Unit size
1328 3/color Color Palette: R,G,B bytes for each color
1329 4 Grid size
1333 2 Display grid enable
1334 2 Display grid type
1335 4 Small cursor step size
1340 Variable Layer names
1350 2 Arrowhead type
1351 2 Dimension tolerance
1352 2 Dimension type
1353 2 Angular dimension precision
1354 2 Dimension precision
1355 4 Dimension text position
1356 2 Wide lines fill
1357 2 Point mark
1359 4 Text horizontal scale
1360 4 Text slant



1365 Variable Character font name
1366 4 Dimension text size
1367 4 Dimension text horizontal scale
1368 4 Dimension text slant
1369 4 Dimension tolerance text size
1370 4 Dimension extension overshoot length
1371 4 Dimension extension gap size
1372 4 Dimension extension length
1373 4 Dimension arrowhead size
1374 4 Balloon size
1375 4 Dimension baseline offset
1376 2 Default dimension layer
1377 2 Default dimension color
1378 4 Dimension arrowhead scale

Drawing entities    The drawing entities are in the following format:

Size Description
2 Entity number
2 Number of bytes in entity attributes section

Attributes section
Size Description
2 Number of points
6 Color -- Red, green, and blue values
2 Solid ID
2 Group number (0 if not a Group)
2 Line type
4 Line width
4 Line type style

Points section
Size Description
n*4 X coordinate for all points in the entity
n*4 Y coordinate for all points in the entity
2 Number of bytes of text -- only if command has string
n Text -- only if command has string

See Also:    Binary File Format



Creating Macros
Choose the Record Macro command from the File menu.
Type the name for the macro in the Record Macro Name box.
Choose the OK button.
Set a point for the startup cursor position.
Perform the actions you want to record.
Choose the Stop Recording Macro command.

Note:    Macros should be saved to the directory where DesignCAD was installed so that they will appear 
in the Macro Options dialog box.    The default directory is C:\DCAD.

See Also:    Recording Macro Options



Materials List File Format
Attributes are listed in alphabetical order.    The attribute string is terminated with a line feed and carriage 
return.    The attribute can not be longer than 80 characters.

Columns Contents
1 Quantity
2 Quantity
3 Quantity
4 Quantity
5 Quantity
6 Quantity
7 Comma
8 Attribute string

See Also:    Material List command, Attribute command



Saving a Drawing
Saving an existing drawing

Choose the Save command from the File menu.

Saving an unnamed drawing
Choose the Save As command from the File menu.
In the File Name box, type a filename.    DesignCAD saves the drawing in the current drive and 

directory and automatically adds the default file extension .DW2 unless you specify another filename
extension.

To save the drawing to a different directory, choose the directory in the Directories box.
To save the drawing in a different drive, choose the drive in the Drives box.
Choose the OK button.

Saving all open drawings
When you quit DesignCAD by choosing Exit from the File menu, DesignCAD closes all drawings and 
verifies that you want to save changes.

See Also:    Saving Drawings, Saving your Drawings, Saving a New, Unnamed Drawing



Saving Selected Objects
Select the object to be saved.
Choose the Save Selection command from the File menu.
Type the drawing name in the File Name box.
Choose the OK button.

See Also:    Save Selection command, Opening Drawings, Guidelines for Naming Files



Guidelines for Naming Files
DesignCAD saves drawings with any acceptable DOS filename.    That is, the filename can be from one to
eight characters long, followed by a period and a three-character filename extension.    You can use any 
characters except spaces and the following characters: * ? , ; [ ] + = \ / : | < >. You cannot use a period 
except to separate the filename extension.

Filename extensions distinguish between types of files.    For example, DesignCAD binary drawing files 
have the extension .DW2, DesignCAD ASCII drawing files have the extension .DC2, and backup files 
have the extension .BAK.

If you do not add a filename extension to drawing filenames, DesignCAD adds .DW2 by default.

DesignCAD assumes specific filename extension.    If you use other extensions for your files, type the 
extension every time you type the filename.

DesignCAD uses the following filename extensions:

Extension Meaning
.A2D ASCII View file
.B2D Binary View file
.BMP Bitmap file
.DC2 ASCII file
.DCM DesignCAD Macro file
.DLL Resource file
.DW2 Binary file
.EXE Program file
.HLP Help file
.PAL Color table file
.SYS Program file

See Also:    Saving a New, Unnamed Drawing



Setting Cursor Step Size
The Cursor category in the Options command sets the distance the cursor moves.    There are two cursor 
step sizes, a large one and a small one.    Pressing an arrow key moves the cursor the distance of the 
large cursor step size.    Pressing an arrow key simultaneously with the Shift key moves the cursor the 
distance of the small cursor step size.    If your keyboard has a numeric keypad, the number keys will 
move the cursor the large cursor step size when the Num Lock is off or the small cursor step size when 
the Num Lock is on.

Setting the cursor step size
Choose the Options command from the Options menu.
Choose the Cursor category.
Type a new value for the Large Cursor Step Size.
Type a new value for the Small Cursor Step Size.
Choose the OK button.

See Also:    Using Arrow Keys



Using a Mouse or Digitizer
If you have a mouse or digitizer, you can use it to move the cursor, or pointer.    The pointer movement 
corresponds to the movement of the mouse or digitizer stylus.

See Also:    Keyboard, Mouse, and Digitizer



Drawing Handles

A DesignCAD drawing can be saved with two reference points called "drawing handles."

The default drawing handles are normally the lower left and lower right corners of the screen.    To specify 
handles other than these, select the Set Handles command or Set Handles box.    Then, set a point for the
primary handle, or lower left corner.    A second point can be set for the secondary handle, or lower right 
corner.



Highlight Bar

The highlight bar shows you which command or option is being changed.



Point Set command
Use the Point Set command to set a point at the current cursor location.

Shortcuts
Mouse: left mouse button
Digitizer: first button
Keys: Ins

See Also:    Choosing Point Commands, Points and Command Selection



Geographic Center
The geographic center is the center of gravity of an entity.

See Also:    Center of Gravity command, Center of Gravity Move command.



Enclose Mode

The Enclose mode is automatically activated when the Select Mode is active.    The Enclose mode 
highlights only those entities entirely within the selection box.



Touch Mode

To activate the Touch mode, you must press Ctrl while dragging the mouse and selecting the entities.    
The Touch mode highlights any entity touched by the selection box.



Linear Text Format
There are four linear dimension text formats to choose from when drawing information in DesignCAD    
These are:

Format Example
Decimal 1.500
Fractional 1 1/2
Engineering 1' 6.75"
Architectural 1' 6-3/4" 

Setting the linear text format
After a Dimension command is selected, choose the Dimension Text button in the Command Line.
Click the Format box.
Choose the arrow button to choose the dimension text format.
Choose the Same as button to have the dimension drawn with the same text format as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension command, Line Angle command



Linear Text Precision
You can choose from these linear precision formats in DesignCAD:

10000000
1000000
100000
10000
1000
100
10
1
1.0
1.00
1.000
1.0000
1.00000
1.000000
1.0000000

Setting the linear text precision
After a Dimension command is selected, choose the Dimension Text button in the Command Line.
Choose the Precision box.
Choose the arrow to choose the dimension precision.
Choose the Same as button to have the dimension text drawn with the same precision as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Angle command, Line Angle-2 command



Angular Text Format
There are five angular dimension text formats to choose from when drawing information in DesignCAD.    
These are:

Format Example
Decimal Degrees 45.0
Grads 50.0g
Radians 0.393rad
Degrees/Minutes/Seconds 45°0'0"
Surveyor's Units N 45°0'0"E 

Setting the angular text format
After the Dimension Angle command is selected, choose the Dimension Text button in the Command 

Line.
Choose the Format box.
Choose the arrow button to choose the angular text format.
Choose the Same as button to have the dimension drawn with the same text format as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Angle command, Angle Between Two Lines command



Angular Text Precision
You can choose these angular precision formats in DesignCAD:

1
1.0
1.00
1.000
1.0000
1.00000
1.000000

Setting the angular text precision
After the Dimension Angle command is selected, choose the Dimension Text button in the Command 

Line.
Choose the Precision box.
Choose the arrow to choose the angular text precision.
Choose the Same as button to have the dimension text drawn with the same precision as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension command, Angle, Distance Two Points command



Changing Dimension Format and Precision
Changing the dimension format

Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Format box in the Info Box.
Choose the new text format.

Changing the dimension precision
Select the dimension to be changed.
Choose Show Info Box from the View menu.
Choose the Precision box in the Info Box.
Choose the new text precision.

See Also:    Understanding Dimension Basics, Changing Dimension Options



Hewlett Packard Plotter (HPGL) Format Files
An HPGL file is created using Hewlett-Packard Graphics Language, or an HP Plotter file.    You can create
an HPGL file within DesignCAD by selecting an HP plotter in DesignCAD and then plotting to a disk file.    
Virtually any application that supports an HP plotter can be used to create HPGL files.

If your software does not allow you to plot to a disk file instead of directly to the plotter, there are software 
packages available that allow you to redirect plotter output from a serial or parallel port to a disk file.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



ASCII Text Files
An ASCII text file is created using a word processor.    DesignCAD allows you to convert an ASCII text file 
to a different file format so that you can merge text with your drawings.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



XY Coordinate Files
An ASCII file of X, Y or X, Y, Z coordinates can be translated into a different file format.    An X, Y 
coordinate file should have each set of coordinates on a separate line.    Each number should be 
separated by one or more spaces, or a comma.    Each line should be terminated by a carriage return and,
optionally, a line feed character.

A blank line separating a series of    X, Y or X, Y, Z coordinates will indicate the end of a line or curve and 
the beginning of another.

If the lines in a file contain three coordinates per line (X, Y, and Z), the file can be translated into a 
DesignCAD 3-D file.    The Z coordinate may be ignored if you select an output file format that does not 
support three dimensions.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



AutoCAD DXF Format Files
A DXF file is created using AutoCAD.    This conversion format makes DesignCAD compatible with many 
third-party software packages that utilize the DXF format.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



IGES (Initial Graphics Exchange Standard) Format 
Files
IGES (Initial Graphics Exchange Standard) Format Files

IGES is a standard format supported by most larger computer-aided design systems.    This makes it 
possible to transfer DesignCAD drawings to other CAD systems.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



DesignCAD 2-D ASCII Format Files
DesignCAD 2-D ASCII files are created with DesignCAD 2-D and saved with the extension .DC2.

See Also:    ASCII File Format, Opening a File Created by Another Application, Importing Drawings, 
Exporting Drawings



DesignCAD 2-D Binary Format Files
DesignCAD 2-D binary files are created with earlier versions of DesignCAD 2-D and saved with the 
extension .DW2.

See Also:    Binary File Format, Opening a File Created by Another Application, Importing Drawings, 
Exporting Drawings



DesignCAD 3-D Binary Format Files
DesignCAD 3-D binary files are created with DesignCAD 3-D and saved with the extension .DW3.

See Also:    Binary File Format, Opening a File Created by Another Application, Importing Drawings, 
Exporting Drawings



DesignCAD 3-D ASCII Format Files
DesignCAD 3-D binary files are created with DesignCAD 3-D and saved with the extension .DC3.

See Also:    ASCII File Format, Opening a File Created by Another Application, Importing Drawings, 
Exporting Drawings



PostScript Format Files
Encapsulated PostScript format files are supported by PostScript printers, as well as many popular 
desktop publishing programs.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



WordPerfect Graphics Files
WordPerfect graphics files are saved with the extension .WPG and are supported by WordPerfect.

See Also:    Opening a File Created by Another Application, Importing Drawings, Exporting Drawings



Set Handles Box

The Set Handles box allows you to set drawing handles before you open a drawing.



Gap

The extension line gap size is the distance between the points set for dimensioning and the beginning of 
the extension line.

See Also:    Dimension Options, Changing Dimension Options



Dimension Line

The dimension line is the line drawn on either side of the dimension text to the extension line.    The 
dimension line contains the dimension terminator.

See Also:    Dimension Options, Changing Dimension Options



Dimension Text

The dimension text is the dimension distance, tolerance information, prefix, and suffix drawn inside the 
dimension line.

See Also:    Dimension Options, Changing Dimension Options



Tolerancing Information

The dimension tolerance is the positive and negative values given to the amount of variation allowed from
the standard measurement.

See Also:    Dimension Options, Changing Dimension Options



Setting Dimension Offset
After the Baseline Dimension command is selected, choose the Dimension Line button in the 

Command Line.
Type the dimension offset in the Offset box.
Choose the Same as button to have the dimension drawn with the same offset as other dimensions.    

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set the points for the baseline dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Offset

The dimension offset determines the distance between the numbers drawn with the Dimension Baseline 
command.



Gap Size

The "gap size" is the amount of space between the dimension information and the entity being 
dimensioned.



Dimension Text Location
The dimension text can be drawn in these locations:

Center of the dimension line

Above the dimension line

Below the dimension line

Center and to the right of the dimension line

Above and to the right of the dimension line

Below and to the right of the dimension line

Center and to the left of the dimension line

Above and to the left of the dimension line

Below and to the left of the dimension line

Setting the dimension text location
After a Dimension command is selected, choose the Dimension Text button in the Command Line.
Choose the Location box.
Choose the arrow button to choose the dimension text location.
Choose the Same as button to have the dimension text drawn in the same location as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Text Orientation
Dimension text can be drawn with these orientations:

Alo. N -- Along the dimension line, normal

Per. N -- Perpendicular to dimension line, normal

Hor. N -- Horizontal to dimension line, normal

Ver. N -- Vertical to dimension line, normal

Alo. R -- Along dimension line, reversed

Per. R -- Perpendicular to dimension line, reversed

Hor. R -- Horizontal to dimension line, reversed

Ver. R -- Vertical to dimension line, reversed

Setting the dimension orientation
After a Dimension command is selected, choose the Dimension Text button in the Command Line.
Choose the Orientation box.
Choose the arrow button to choose the dimension text orientation.
Choose the Same as button to have the dimension text drawn with the same orientation as other 

dimensions.    Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Dimension Tolerance Text Size
The Dimension Tolerance Text Size is entered in Drawing Units in the Text Size box of the Dimension 
Tolerance button.

Setting the dimension tolerance text size
After a Dimension command is selected, choose the Dimension Tolerance button in the Command 

Line.
Type the tolerance text size in the Size box.
Choose the Same as button to have the dimension drawn with the same text size as other dimensions.

Then set a point on the existing dimension in the drawing.
Choose the Default button to reset the dimension options.
Set points for the dimension.

See Also:    Dimension Options, Changing Dimension Options



Copying Objects to Clipboard
Select the objects to be copied to the Clipboard.
Choose the Copy command from the Edit menu.

See Also:    Copy command



Copying Objects in a Row
Select the object to be copied.
Choose the Array command.
Type the number of copies in the No. of copies box in the Command Line.
Type the number of rows in the No. of rows box in the Command Line.
To have the first copy located on the original entity, choose the Use original as first copy box.
To force the handle to remain in the same place, choose the Fixed handle box in the Command Line.
Set a point for the handle of the first copy.
Set a point for the second copy.    This point determines the direction and spacing of the objects.
Set a point for the location of the second row if more than one row was specified in the Command 

Line.

See Also:    Array command



Copying Object in a Circle
Select the object to be copied.
Choose the Circular Array command.
Type the number of copies in the No. of copies box in the Command Line.
Type the angle for the arc in the Angle box in the Command Line.
To have the first copy located on the original object, choose the Use original as first copy box.
To force the handle to remain in the same place, choose the Fixed handle box in the Command Line.
Set a point for the center of the circle.

See Also:    Circular Array command



Selecting Printer
You can only select a printer in DesignCAD that you have installed on your system.    For more 
information on installing printer software, see your Windows documentation.

Selecting printer setup options
Choose the Printer Setup command from the File menu.
Choose the printer you want to use, if more than one is available.
Choose the OK button.

See Also:    Printing, Printer Setup, Printer Driver (File)



Keyboard Techniques
The following table provides a review of basic keyboard techniques you will need to know to work in 
DesignCAD.

To Do This
Double-click Press Alt+Shift+Ins
Drag selection box Press Alt+Ins
Move horizontally Press Ctrl+Alt
Move vertically Press Shift+Alt
Repeat last command Press F3
Select Coordinate Bar Press F6

By activating the Select Mode before selecting an entity, you can perform these commands:

To Do This
Scale Zoom Move pointer to highlighting node, press Shift
Select several entities Select first entity, press Shift+Ins to select next entity
Copy entities Select entity, press Ctrl+Ins inside selection box

By activating the Point Select Mode before selecting an entity, you can perform these commands:

To Do This
Extend line Move pointer to end of line, press Shift+Ins
Cut line Move pointer to line, press Ctrl+Ins
Delete point Move pointer to point, press Ctrl+Shift

Setting points
The Preset Point Mode allows you to set points before selecting a command.    If the Preset Point Mode is
not active, you must select a command before setting the points required for the command.

See Also:    Controlling the Cursor, Selecting Commands with the Keyboard, Selecting Objects with the 
Keyboard



DOS Keystroke Commands
A Arc-1
< Angle, Distance-Two Points
Ctrl+A Angle Between Two Lines
> Arrow
$ Attribute
] Box
| Break Line
Ctrl+F Chamfer
O Circle-1
Ctrl+C Copy
+ Crosshair
Ctrl+F11 Cursor Step Size
C Curve
Ctrl+X Cut
@ Dimension
G Display Grid
E Erase
Ctrl+E Erase Last
F8 Exit
F Fillet
Ctrl+W Fit to Window
F7 Text Options
. Gravity
, Gravity Move
Ctrl+F12 Grid Options
F4 Group Explode
# Hatch
F1 Help Index
I Show Info Box
N Intersect-1
Ctrl+N Intersect-1 Move
L Layer Setup
V Line
K Line Snap
Ctrl+K Line Snap Move
Ctrl+F9 Load Selection
Ctrl+Q Macro Record Options
F2 Midpoint
Ctrl+F2 Midpoint Move
Y New
F9 Open
Ctrl+O Original Size
= Parallel-1
P Point Mark
* Point Move
; Point Polar
' Point Relative
Ctrl+S Point Select Mode
Ins Point Set
: Point XY
F5 Plot
F5 Print
( Quarter Circle



Ctrl+U Redo
Ctrl+R Regenerate
F3 Repeat
F10 Save
Shift+X Save Selection
Ctrl+F5 Select All
Shift+O Select Ortho
Shift+P Select Previous
S Select Mode
Shift+R Select Rotate
Shift+Z Select Zoom
) Semi-Circle
Shift+Alt+A Show Attribute
H Show Color Table
Ctrl+Alt+B Show Coordinate Bar
/ Show Line Style Box
Shift+Alt+T Show Hot Toolbox
Shift+Alt+M Show Main Toolbox
J Show Polar Coordinates
Shift+Alt+R Show Rulers
Shift+Alt+N Show Snap Toolbox
Shift+Alt+B Show Status Bar
Ctrl+G Snap Grid
& Stop Recording Macro
T Text
F7 Text Options
B Trim Two Lines
Ctrl+B Trim Double Lines
Ctrl+U Undo
! Unerase
U Units
Z Zoom
{ Zoom In
} Zoom Out
Ctrl+P Zoom Previous

You can use the function keys on your keyboard to perform many tasks faster.

F1
Set a point at the intersection of 
two lines

F1

F2
Set point at intersection of two 
lines

F2

Move pointer to intersection of two 
lines without setting point

Ctrl+F2

F3
Repeat the last command F3

F4
Explode Group into individual 
entities

F4

F5



Send drawing to printer F5

F6
Send drawing to plotter F6

F7
Set text options F7

F8
Exit DesignCAD and end 
current session

F8

F9
Open existing drawing F9
Load a selected part of a drawing Ctrl+F9

F10
Save current drawing F10

F11
Set cursor step size Ctrl+F11



Setting Print Options
After the Print command is selected, you can choose print options from the print options box.

The Drawing Size of your drawing is displayed at the top of the dialog box.    Information such as print 
area, paper size, and panel marks can be changed within this dialog box.

Setting Drawing Units
Setting Print Area
Paneling Drawing
Printing Several Copies
Setting Paper Margins
Printing Selected Objects
Printing to File
Previewing a Drawing
Setting Up Printer



Setting Drawing Units with Print command
By selecting the Units box, your drawing can be printed using one of several units of measurement 
available.

Changing the Drawing Units
Open the drawing to be printed.
Choose the Print command.
Choose the units of measurement in the Units box.

Inches
Meters
Centimeters
Millimeters

Choose the Print button

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Setting Print Area
Changing Drawing Scale
Changing Drawing Height
Changing Drawing Width
Centering Drawing



Changing Drawing Scale
Open the drawing to be printed.
Choose the Print command.
Choose the Fit to Paper box to disable it.
Type the new scale in the Scale box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Changing Drawing Height
Open the drawing to be printed.
Choose the Print command.
Choose the Fit to Paper box to disable it.
Type the new height in the Height box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Changing Drawing Width
Open the drawing to be printed.
Choose the Print command.
Choose the Fit to Paper box to disable it.
Type the new width in the Width box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Centering Drawing
Open the drawing to be printed.
Choose the Print command.
Choose the Center Drawing box to enable it.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Paneling a Drawing
If the drawing size is larger than the paper loaded in the printer, the Panel section of the Print Options 
dialog box displays the number of panels, rows, columns, and panel mark options if the drawing is to be 
printed in panels.

Panel marks, or lines, can be drawn inside the corner of each panel to help you put the drawing together 
once it is printed.    These panel marks can be drawn in the corner of each panel or around the entire 
panel, outlining the drawing.    These panels can contain numbers so that you can put them together 
sequentially.

Marking Panels
Numbering Panels

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Marking Panels
Open the drawing to be printed.
Choose the Print command.
Choose the type of panel mark in the Mark box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Numbering the Panels
Open the drawing to be printed.
Choose the Print command.
Choose the Mark Panel Number box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Panel Marks

Panel marks are lines drawn inside the corner of each panel to help you put the drawing together once it 
is printed.    These panel marks can be drawn in the corner of each panel or around the entire panel, 
outlining the drawing.    These panels can contain number so that you can put them together sequentially.



Printing Several Copies
The DesignCAD Print Options dialog box allows you to print several copies of a drawing at once.

Printing more than one copy
Open the drawing to be printed.
Choose the Print command.
Type the number of copies to be printed in the Number of Copies box.
Choose the Print button.

See Also:    Print command, Printing, Printer Setup, Printing a Drawing



Setting Paper Margins
The Paper section of the Print Options dialog box displays the size of paper loaded in your printer at the 
top of the box.    The page margins and orientation are changed within this section.

Changing Page Margins
Setting Page Orientation

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Changing Page Margins
Open the drawing to be printed.
Choose the Print command.
Type the top page margin in the Top box.
Type the bottom page margin in the Bottom box.
Type the left page margin in the Left box.
Type the right page margin in the Right box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Setting Page Orientation
Open the drawing to be printed.
Choose the Print command.
Choose Portrait in the Orientation box to have your drawing printed with the drawing width the same 

direction as the printer width.
Choose Landscape in the Orientation box to have your drawing rotated 90 degrees, or printed 

sideways on the page.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Printing to File
The Print to File box in the Print Options dialog box allows you to send a drawing to a disk file.

Printing part of a drawing
Choose the Print command.
Choose the Print to File box.
Choose the Print button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Previewing a Drawing
Previewing Drawing
Setting Margins
Setting Margins without Redraw
Entering Exact Margins
Positioning Drawing
Changing Drawing Scale
Previewing Panels



Previewing Panels
Choose the Print command.
Choose the Preview button.
Choose the Panel button to display the Preview Panel dialog box.
Type the column number of the panel you want to preview in the Column box.
Type the row number of the panel you want to preview in the Row box.
Choose the OK button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Changing Drawing Scale with Print Preview
Choose the Print command.
Choose the Preview button.
Choose the Scale button to display the Preview Scale dialog box.
Choose the Center Drawing box to have the drawing centered on the paper.
Choose the Fit to Paper box to have the drawing fill the entire page when printed.

-or-
Disable the Fit to Paper button to have the drawing printed with adjustable width and height.
Type the drawing scale in the Scale box.
Type the drawing height in the Height box.
Type the drawing width in the Width box.
Press Enter.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Positioning Drawing
Choose the Print command.
Choose the Preview button.
Choose the Position button.
Set a point inside the drawing in the preview box.
Use the arrow keys or the mouse to drag the drawing to its new location.
Set another point.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Previewing Drawing
The Preview button in the Print Options dialog box allows you to see how the drawing will be printed on 
the page.    The Preview screen also shows you how a drawing will be printed in panels if it is too large to 
print on a single page.

Previewing drawings
Choose the Print command.
Choose the Preview button.
The panel coordinates show the number, column, and row of the current panel.
The pointer coordinates show the X and Y coordinates of the pointer in relation to the drawing.
Choose the Print button to print the drawing.
Choose the Current Panel box to print the current panel if your drawing has more than one panel.

-or-
Choose the All button to print the entire drawing.
Choose the OK button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Setting Margins
Choose the Print command.
Choose the Preview button.
Choose the Margins button to display the margins.
Choose the Top Left margin handle to change the margins.
Move the margin handles.
Choose the Print button to print the drawing.
Choose the Current Panel box to print the current panel if your drawing has more than one panel.

-or-
Choose the All button to print the entire drawing.
Choose the OK button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Setting Margins without Redrawing Screen
Choose the Print command.
Choose the Preview button.
Choose the Margins button to display the margins.
Press Shift and choose the Top Left margin handle to change the margins.
Press Shift and while moving the left margin handle.
Choose the Print button to print the drawing.
Choose the Current Panel box to print the current panel if your drawing has more than one panel.

-or-
Choose the All button to print the entire drawing.
Choose the OK button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Entering Exact Margins
Choose the Print command.
Choose the Preview button.
Choose the Margins button to display the margins.
Press Ctrl and choose the a margin handle.
Type the new margin in the margin box.
Choose the OK button.
Choose the Print button to print the drawing.
Choose the Current Panel box to print the current panel if your drawing has more than one panel.

-or-
Choose the All button to print the entire drawing.
Choose the OK button.

See Also:    Setting Print Options, Print command, Printing, Printer Setup, Printing a Drawing



Panel Coordinates

The Panel Coordinates shows the number, row, and column of the panel you are viewing.



Pointer Coordinates

The Pointer Coordinates shows where the pointer is in relation to the drawing.    When the pointer is on 
one of margin handles, the pointer coordinates displays the margin options.



Setting Up Printer
The Printer Setup button in the Print Options dialog box opens the Printer Setup command.    The Printer 
Setup command allows you to choose from a list of available printers and plotters.

For more information on installing printers and plotters, refer to your Windows, printer, or plotter 
documentation.

The dialog box that appears depends on the type of printer or plotter you choose.      You can also change 
Printer Setup options within this dialog box.

See Also:    Printing, Printer Setup, DesignCAD Print Options



Reading and Saving Views
Saving Drawing Views
Opening Drawing Views



Saving Drawing Views
Choose the drawing view to be saved.
Choose View Save from the File menu.
Type the name of the drawing view in the File Name box.
Press Enter.

See Also:    View Read command, View Save command



Opening Drawing Views
Choose View Read from the File menu.
Type the name of the drawing view in the File Name box.
Press Enter.

See Also:    View Read command, View Save command



Recording Macro Options
Recording Layer, Color, and Line Style
Recording Command Options
Recording Input Information
Recording Points
Disabling Record Input Information



Recording Layer, Color, and Line Style
The Record Layer Information box records layer information such as layer color, layer name, and current 
layer with the macro.    The Record Color Information box records the current color of the drawing with the
macro.    The Record Line Style Information box records the current line style and width of the lines drawn 
within the macro.

Recording options
When the macro is being recorded, choose the Record Options command from the File menu.
Choose the Layer Info box in the Save box.
Choose the Color Info box in the Save box.
Choose the Line Style Info box in the Save box.
Choose the OK button.

See Also:    Recording a Macro, Recording Macro Options



Recording Command Options
The Record Options box records all drawing options including color, line type, dimension options, and 
layer options.    However, information entered in the Command Line or in the Text Block dialog box is not 
recorded with the Record Options box.

Recording options
When the macro is being recorded, choose the Record Options command from the File menu.
Choose the Command Opts box in the Save box.
Choose the OK button.

See Also:    Recording a Macro, Recording Macro Options



Recording Input Information
The Record Input Information box records any information entered in the Command Line or the Text Block
dialog box.

Recording options
When the macro is being recorded, choose the Record Options command from the File menu.
Choose the Input Info box in the Save box.
Choose the OK button.

See Also:    Recording a Macro, Recording Macro Options



Recording Points
The Record Points Set box records any points set within the macro.

Recording options
When the macro is being recorded, choose the Record Options command from the File menu.
Choose the Points Set box in the Save box.
Choose the OK button.

See Also:    Recording a Macro, Recording Macro Options



Disabling Record Input Information
If the Record Input Information box is disabled, any information entered in the Command Line or Text 
Block dialog box will not be recorded with the macro.

If both the Record Input Information box and the Record Points Set box are disabled, neither input or 
point information will be recorded.    When the macro is executed, DesignCAD will execute the 
commands, stopping when it reaches the input for the points.    The macro will pause until points are input 
or until Enter is pressed.

If the Record Points Set box is enabled and the Record Input Information box is disabled, the point 
information will be recorded and the input information will not.    When the macro is executed, DesignCAD 
will execute the commands, set the points, and wait for further information to be entered or Enter to be 
pressed.

Disabling input information
When the macro is being recorded, choose the Record Options command from the File menu.
Disable the Input Info in the Save box.
Choose the OK button.

See Also:    Macro Options



Aligning a Drawing
Choose the Align Drawing command from the View menu.
Set a point for the first reference point.
Set a point for the new location of the first reference point.
Set a point for the second reference point.
Set a point for the location of the second reference point.

See Also:    Align Drawing command



Scaling Three Sides of Object
DesignCAD allows you scale objects disproportionately along the X, horizontal, or Y, vertical, axis.    This 
command "stretches" three side of the object to make them taller, shorter, or wider.

Changing the width of an object
Select the object to be scaled.
Press Shift and click the left or right select nodes.
Press Shift and move the pointer in the desired direction.
Set a point.

Changing the height of an object
Select the object to be scaled.
Press Shift and click the top or bottom select nodes.
Press Shift and move the pointer in the desired direction.
Set a point.

Changing diagonal width or height of object
Select the object to be scaled.
Press Shift and click the left or right select nodes.
Press Shift and move the pointer in the desired direction.
Set a point.

See Also:    Select Scale command



Scaling One Side of Object
DesignCAD allows you scale objects disproportionately along the X, horizontal, or Y, vertical, axis.    This 
command "stretches" one side of the object to make it taller, shorter, or wider.

Changing the width of an object
Select the object to be scaled.
Choose the left or right select nodes.
Move the pointer in the desired direction.
Set a point.

Changing the height of an object 
Select the object to be scaled.
Choose the top or bottom select nodes.
Move the pointer in the desired direction.
Set a point.

Changing diagonal width or height of object 
Select the object    to be scaled.
Choose the left or right select nodes.
Move the pointer in the desired direction.
Set a point.

See Also:    Select Scale command



Setting Points Along a Line
Choose the Point Line Distance command from the Options menu.
Type the distance.
Choose the Point Line Snap command from the Point menu.
Set a point for the starting point.
Set a point for the direction.

See Also:    Setting Regular Points, Entering Coordinates for Points, Selecting Points



Selecting a Hatch Pattern
Hatch patterns can be used to "fill in" areas and entities in the drawing with solid or line drawings.    These
hatch patterns are drawn as scalable and non-scalable patterns.

When the Hatch, Hatch Fill, or Hatch Line commands are selected, the hatch pattern.    When the Hatch 
button in the Command Line is selected, the Hatch Pattern dialog box is opened.

You can use the mouse, arrow keys, or Tab and Space bar to choose a hatch pattern within the Hatch 
Pattern dialog box.

Selecting a hatch pattern
Choose the Hatch command from the Draw menu.
Choose the Hatch button in the Command Line.
Choose the Hatch button in the Command Line.
Press Enter.
Set the points for the hatch.
Press Enter.

See Also:    Using Hatch Patterns, Hatch Patterns



Scalable

The size of scalable hatch patterns is entered when the Hatch commands are selected.    The size of 
these patterns will change when a drawing is zoomed and can be changed with the Info Box.



Non-Scalable

The size of non-scalable patterns cannot be changed and will not change when a drawing is zoomed.



Running BasicCAD Programs
Choose the Run command from the File menu.
Type the program name in the File Name box.
Press Enter.

See Also:    Run command



Moving Objects Vertically
Activate the Select Mode.
Select the object to be moved.
Move the pointer to the area inside the selection box.
Press Alt+Shift while dragging the pointer.
Move the selection box to the new location.
Set a point.

See Also:    Moving Objects, Moving Objects with Handles, Moving Objects Horizontally



Moving Objects Horizontally
Activate the Select Mode.
Select the object    to be moved.
Move the pointer to the area inside the selection box.
Press Alt+Ctrl while dragging the pointer.
Move the selection box to the new location.
Set a point.

See Also:    Moving Objects, Moving Objects with Handles, Moving Objects Vertically



Visible Layer

A visible layer is an active layer that is displayed on the screen.



Invisible Layer

An invisible layer is an inactive layer that is not displayed on the screen.



Using Printer Fonts
If your printer cannot handle TrueType fonts at lower resolution, such as 75 d.p.i. which can be used to 
print a "preview" of a drawing, a Use Printer Font check box can be selected in the Printer Setup dialog 
box.

Using printer fonts
Choose the Printer Setup command from the File menu.
Choose the Use Printer Font Only box if it is available.
Choose the OK button.

See Also:    Printing, Printer Setup, DesignCAD Print Options



Viewing Bitmaps
Saving Bitmaps
Reading Bitmaps



Saving Bitmaps
Open the drawing.
Choose Save Bitmap from the File menu.
Set a point in the lower left corner of the area to be saved.
Set a point in the upper right corner of the area to be saved.

-or-
Press Enter to save the entire bitmap.
Type the bitmap file name in the File Name box.
Choose the OK button.

See Also:    Save Bitmap command, Reading Bitmaps



Reading Bitmaps
Choose Load Bitmap from the File menu.
Type the bitmap file name in the File Name box.
Choose the OK button.
Set a point for the lower left corner of the bitmap.
Set a point for the upper right corner of the bitmap.

See Also:    Load Bitmap command, Saving Bitmaps



Listing Attributes
Choose the Material List command from the Dimension menu.
Choose the Save command from the File menu to save the list.
Choose the Print command from the File menu to print the list.
Choose the Printer Setup command from the File menu to setup the printer.
Choose the Window Control-menu to close the Material List window.

See Also:    Material List command, Attribute command



The Command Line
Command Line
Default Command Line



Default Command Line

The Command Line displays the most-commonly used file commands.

Click To
Cut Cuts object and places it in Clipboard.
Copy Copies object    to Clipboard.
New Opens new drawing screen.
Open Opens drawing.
Paste Pastes Clipboard contents to drawing.
Print Prints current drawing.
Save Saves current drawing.

When a command is selected that requires information to be entered, the Command Line 
commands are hidden.    The Command Line then contains information for the selected 
command.

See Also:    Parts of the DesignCAD Screen



Saving Drawing to Drive or Directory
Choose the Save As command from the File menu.
In the File Name box, type the complete path and filename.

-or-
In the File Name box, type the filename.    Then choose a new directory in the Directories box.
Choose a new drive in the Drives box.
Choose the OK button.

See Also:    Saving a Drawing, Saving Drawings



Setting Text Style
Setting style within the command

Choose the Text command.
Type the text in the Text box in the Command Line.
Choose the Bold button to have the text drawn in bold type.
Choose the Italic button to have the text drawn in italic type.

Setting style with the Text Options command
Choose the Text Options command.
Choose the text style in the Style box.
Choose the OK button.

See Also:    Changing Text Options



Setting Text Height and Angle
Setting style within the command

Choose the Text command.
Type the text in the Text box in the Command Line.
Type the text size in the Text Size box in the Command Line.
Type the text angle in the Text Angle box in the Command Line.

-or-
Set two points for the lower left and lower right corners of the text.

Setting style with the Text Options command
Choose the Text Options command.
Enter the text size in the Size box.
Enter the text angle in the Angle box.
Choose the OK button.

See Also:    Changing Text Options



Setting Text Orientation
Choose the Text command.
Type the text in the Text box in the Command Line.
Choose Left in the Orientation box to have the text left-justified.
Choose Center in the Orientation box to have the text centered.
Choose Right in the Orientation box to have the text right-justified.

See Also:    Changing Text Options



Setting Preferences
Changing Default Options
Default Options



Changing Default Options
When you choose the Options command in the Options menu, DesignCAD displays the Options dialog 
box.

The Options dialog box is divided into two parts:    the Category box on the left and the options panel on 
the right.    When you select a category, the panel changes to display the options and default settings in 
that category.    You determine the default settings for any category by selecting or clearing the options in 
the panel.    The new default settings take effect when you choose another category or close the dialog 
box.

Setting options
Choose Options from the Options menu.
In the Category box, choose the category containing the default options you want to change.
In the panel on the right, choose the options to specify the default settings you want DesignCAD to 

use.
Select another category or close the dialog box by choosing the OK or Cancel button.

Changing startup file
Change the options. 
Choose the Save options box.
Choose the OK button.

Note:    The Save options box saves the current options to the DCW.INI file.

See Also:    Options command, Default Options



Default Options
Toolbox
Symbol Toolbox
Macro
Coordinate Bar
View
Drawing
Text
Cursor
Grid
General Dimension
Dimension Text
Dimension Prefix and Suffix
Digitizer Menu
Miscellaneous



Symbol Toolbox Options
Symbol Toolbox
Select the Symbol Toolbox category to specify the number of columns in the Symbol Toolbox and to 
create a Symbol Toolbox.

Symbol Toolbox
Use options under "Symbol Toolbox" to set toolbox columns, specify the directory for the symbol files, and
add symbols to the symbol menu.    The maximum size for a toolbox is 18 by 18.

Column No    Select this option to set the number of columns in the Symbol Toolbox.
Directory Use this option to enter the drive and directories for the symbols files.
Current Content    Displays the contents of the Symbol Toolbox.
Available Symbols    Select the symbol to assign to the toolbox from the list of available symbol.

Add    Adds the selected symbol to the Symbol Toolbox.
Delete    Deletes the selected symbol from the Symbol Toolbox.

See Also:    Options command, Changing Default Options



Digitizer Menu Options
Digitizer Menu
Use the Digitizer Menu category to set digitizer menu options

Modify Digitizer Menu
Use options under "Modify Digitizer Menu" to remove, disable, and enable the current digitizer menus.

DigiMenu    The options modify the digitizer menus loaded in DesignCAD.
Check box    When the check box next to the digitizer menu name is checked, the digitizer menu 

is loaded.    Clear the check mark next to the digitizer menu name to remove the digitizer menu.
Enable    When the Enable button next to the digitizer menu is selected, the digitizer menu is 

active.
Disable    When the Disable button next to the digitizer menu is selected, the digitizer menu is no 

longer active.

See Also:    Options command, Changing Default Options



Toolbox Options
Select the Toolbox category to specify the number of columns in the Main, Snap, and Hot toolboxes.    
Then each time you open the drawing, the toolbox columns will be set.    Once the drawing is open, you 
can change the toolbox columns at any time by changing the appropriate options.

Toolbox Column No.
Use options under Toolbox Column No. to set individual toolbox columns.    The maximum size for a 

Toolbox is 18 by 18.

Main Toolbox Column no:    Select this option to set the number of columns in the Main Toolbox.
Snap Toolbox Column no:    Select this option to set the number of columns in the Snap Toolbox.
Hot Toolbox Column no:    Select this option to set the number of columns in the Hot Toolbox.

Hot Toolbox
Use options under Hot Toolbox to add or delete tools to the Hot Toolbox.

Current Content    Shows the current icons in the Hot Toolbox.
Available Tools    Choose the tool icons from this box.    Use the scroll bar to view additional tools.
Add    Select this button to add a selected tool to the Hot Toolbox.
Delete    Select this button to delete a selected tool from the Hot Toolbox.

See Also:    Options command, Changing Default Options



Macro Options
Select the Macro category to define the macro buttons in the Command Line, set macro options, and 
define the startup macro.

Modify Macro Settings
Use options under Modify Macro Settings to set macro options.

Button to Change    Select the buttons, icons, and macros for the macro buttons.
Which    Select the macro button to change.
Icon    Select the icon to use for the defined macro button.
Available Macros    Select the macro to define for the button from the list of available macros.
Keystroke    Shows the keystroke used for the defined macro.
Change    Select this button to change the button definitions.

Save    Select the macro record options to be saved with each macro.
Layer Info Choose this box to record layer information such as layer color, layer name, and 

current layer with the macro.
Color    Choose this box to record the current color of the drawing with the macro.
Line Style    Choose this box to record the current line style and width of the lines drawn within the

macro.
Input    Choose this box to record most information entered in the Command Line or the Text Block

dialog box.    If the Record Input Information box is disabled, most information entered in the 
Command Line or Text Block dialog box will not be recorded with the macro.

If both the Record Input Information and the Record Points Set boxes are disabled, neither input or
point information will be recorded.    When the macro is executed, DesignCAD will execute the 
commands, stopping when it reaches the input for the points.    The macro will pause until points 
are set or until Enter is pressed.    This allows interactive macros.

If the Record Points Set box is enabled and the Record Input Information box is disabled, the point
information will be recorded and the input information will not.    When the macro is executed, 
DesignCAD will execute the commands, set the points, and wait for further information to be 
entered or Enter to be pressed.

Command Opts      Choose this box to record all drawing options including color, line type, 
dimension options, and layer options.    However, some information entered in the Command 
Line or in the Text Block dialog box is not recorded with the Macro Record Options command.

Points Set    Choose this box to record any points set within the macro.
Startup macro    Select the macro file to be used as the startup macro.

Note:    Macros should be stored in the directory where DesignCAD was installed so that they will appear 
in the Macro Options dialog box.    The default directory is C:\DCAD.

See Also:    Options command, Changing Default Options



Coordinate Bar Options
The options under Coordinate Bar change the Coordinate Bar information.

Coordinates Display Type    This option switches between Cartesian and Polar coordinates.
Cartesian    Choose this option to have the X, Y, Delta X, and Delta Y coordinates displayed in the 

Coordinate Bar.
Polar    Choose this option to have the polar coordinates, or angle and length from last point, 

displayed in the Coordinate Bar.
Distance Format    This option sets the format that the coordinates are displayed in Coordinate Bar.

Decimal - 1.400
Fractional - 1-1/2
Engineering - 1' 6.75"

Precision (Fractional Digits)    Use this option to set the precision of fractional digits displayed in the 
Coordinate Bar.

10000000
1000000
100000
10000
1000
100
10
1
1.0
1.00
1.000
1.0000
1.00000
1.000000
1.0000000

Angle Format    This option sets the angle format for polar coordinates.
Decimal degrees - 45.0
Grads - 50.0g
Radians - 0.393rad
Degree/minutes/seconds - 45º0'0"
Surveyor's units - N 45º0'0"E

Angles    Use this option to set Mathematical or Geographical angles.
Mathematical    With Mathematical angles, the degrees progress counter-clockwise with zero 

degrees to the right.
Geographical    With Geographical angles, the degrees progress clockwise with zero degrees 

straight up.

See Also:    Options command, Changing Default Options



View Options
Select the View Options category to disable or enable screen elements.

Show/Hide
Select options under Show/Hide to enable or disable individual screen elements.    A check mark in the 

box indicates that the element will be displayed on the screen.

Main Toolbox    The Main Toolbox contains the most-commonly used drawing commands.
Snap Toolbox    The Snap Toolbox contains the most-commonly used point commands.
Hot Toolbox    The Hot Toolbox can contain the commands you use most often.
Status Bar    The Status Bar displays information on selected commands, the zoom factor, and the 

number of points set.
Coordinate Bar    The Coordinate Bar displays the X, Y, Delta X, Delta Y or polar coordinates of the 

cursor and the current layer.
Rulers    The Rulers show where the cursor is in the drawing.
Color Table    The Color Table displays the current color and color table.
Line Style Box    The Line Style Box displays the current line style, line width, and line scale.

Zoom In/Out Enter the percentage a drawing is zoomed with the Zoom In and Zoom Out commands.

See Also:    Options command, Changing Default Options



Drawing Options
Select the Drawing Options category to set options for DesignCAD drawing commands.

Modify Drawing Options
Use options under Modify Drawing Options to set line, color, point mark, and point options.

Line Style Select the line type, scale, and width for lines in the drawing with this option.
Line Type Select the line type from the available list of line types.
Scale Enter the scale for the line.
Width Enter the width of the line.
Fill Wide Line Choose this box to have wide lines filled.

Color Use this option to set the default color for DesignCAD.
Point Mark    Use this option to select the default point mark for marks drawn with the Point Mark 

command.
Point Mark Size Enter the size of the point mark in Drawing Units.

Point Type Select the type of point made with DesignCAD commands with this option.
Hatch Pattern Select Hatch pattern to choose the hatch pattern.

See Also:    Options command, Changing Default Options



Text Options
Select the Text category to set the text size, angle, font, style, and spacing.

Text Options
Use the options under Text Options to set the text information.

Font    This option determines the font used for text in the drawing.    The fonts available depend on 
your system.    See your windows documentation on how to install fonts.

Font Style    This option determines the font style used for text in the drawing.
Regular    Regular text is drawn normally, without italics or bold.
Italic    This option draws italics text.
Bold    This option draws bold text.
Bold Italic    This option draws both bold and italic text.

Size    Type the size for the text in this box.
Angle    Type the angle of the text in this box.
Spacing    Type the amount of spacing between each letter in this box.
Display Attribute    Choose this box to have attributes drawn with the Attribute command displayed on

the screen.

See Also:    Options command, Changing Default Options



Cursor Options
Select the Cursor category to set the large and small cursor step size and to determine cursor step 
consistency.

Cursor Options
Use options under Cursor Options to set cursor step information.

Large Step Size    This option determines the distance the cursor will move when an arrow key is 
pressed.

Small Step Size    This option determines the distance the cursor will move when an arrow key is 
pressed with the Shift key.

Cursor Step Relative to: Screen or Drawing    This option determines if the cursor step size will be 
consistent with the drawing or the screen.

Screen    This option sets the cursor step sizes to remain consistent with the screen.    That is, 
when the drawing is zoomed, the cursor step sizes remain the same relative to the screen, not 
the drawing.    After a zoom command has been performed, the cursor step values may have 
changed.    The cursor will move the same distance across the screen when an arrow key is 
pressed.

Drawing    This option sets the cursor step sizes to remain consistent with the drawing.    That is, 
the cursor step sizes will not change when the drawing is zoomed.

See Also:    Options command, Changing Default Options



Grid Options
Select the Grid Options category to set options for the snap and display grids.

Grid Options
Use options under Grid Options to set the grid types and sizes for DesignCAD.

Display grid type    This option sets the line type for the display grid.
Display grid size    Select this option to set the display grid size.
Snap grid size    This option sets the snap grid size.
Enable display grid    This option displays or "hides" the display grid.
Enable snap grid    Select this option to enable or disable the snap grid.

See Also:    Options command, Changing Default Options



General Dimension Options
Use the General Dimension category to set options for dimensions.

Dimension Options
Use options under Dimension Options to set the arrowhead, extension line, layer, color, and text sizes for 
the dimension commands.

Arrowhead    Select this option to set options for the arrowhead associated with the dimension.
Type    This option sets the arrowhead, or terminator, type for the dimension arrows.
Size    This option sets the size for the arrowhead.

Extension Line    Select this option to set overshoot and extension lengths.
Overshoot    This option sets the overshoot, or distance the extension line extends past the 

dimension line.
Fixed Length    This option sets the distance between the dimension information and the entity to be

a certain length.
Variable Length    Select this option to set the distance between the dimension information and the 

entity to be a variable length.
Gap Size    This option sets the "gap size," or space between the dimension information and the 

entity being dimensioned.
Default Layer    Select this option to set the default layer for all dimensions.
Default Color    This option sets the default color for all dimensions.
Text Size    This options sets the default text size for all dimensions.
Tolerance Size    This option sets the positive and negative values given to the amount of variation 

allowed from the standard measurement.
Balloon Size    Use this option to set the default size for the balloon drawn around text with the Balloon

command.    The size of the balloon is determined by multiplying this number by the text size.    The 
minimum size for the balloon size is 1.5 Drawing Units.

Dim Base Offset    This option sets    the distance between the numbers drawn with the Dimension 
Baseline command.

See Also:    Options command, Changing Default Options



Dimension Text Options
Use the Dimension Text category to set the text options for the dimension commands.

Modify Dimension Text Options
Use options under Modify Dimension Text Options to set the linear and angular dimension format and 
precision.

Linear Dimension Use options under Linear Dimension to set linear format and precision.
Format Choose the linear text format.    There are four linear dimension text formats to choose from:
Format Example
Decimal 1.500
Fractional 1 1/2
Engineering 1' 6.75"
Architectural 1' 6-3/4" 

Precision Choose the linear text precision.    You can choose these linear precision formats:
10000000
1000000
100000
10000
1000
100
10
1
1.0
1.00
1.000
1.0000
1.00000
1.000000
1.0000000

Angular Dimension Use options under Angular Dimension to set angular format and precision.
Format Choose the angular text format.    There are five angular dimension text formats to choose 

from:
Format Example
Decimal Degrees 45.0
Grads 50.0g
Radians 0.393rad
Degrees/Minutes/Seconds 45°0'0"
Surveyor's Units N 45°0'0"E 

Precision Choose the angular text precision.    You can choose these angular precision formats:
1
1.0
1.00
1.000
1.0000
1.00000
1.000000

Text Size Set the dimension text size.

See Also:    Options command, Changing Default Options



Dimension Prefix & Suffix Options
Use the Prefix & Suffix category to set the text preceding and following the dimension information for the 
dimension commands.

Prefix
Use options under "Prefix" to set the prefix text for the dimension commands.

Linear Prefix text for linear dimensions.
Angular Prefix text for angular dimensions.
Arc Prefix text for arc dimensions.
Radius Prefix text for radius dimensions.
Diameter Prefix text for diameter dimensions.
Chamfer Prefix text for chamfer dimensions.
Coord Prefix text for coordinate dimensions.

Suffix
Use options under "Suffix" to set the suffix text for the dimension commands.

Linear Suffix text for linear dimensions. 
Angular Suffix text for angular dimensions.
Arc Suffix text for arc dimensions.
Radius Suffix text for radius dimensions.
Diameter Suffix text for diameter dimensions.
Chamfer Suffix text for chamfer dimensions.
Coord Suffix text for coordinate dimensions.

See Also:    Options command, Changing Default Options



Miscellaneous Options
Use the Miscellaneous category to set options that do not fall under a specific category.

Point Line Snap Distance    This option sets the distance used for the Point Line Snap command.
Retrieve/Copy Scale    This option determines if the drawing handles used to load or copy a drawing 

are scalable or changeable.
Fixed    When this option is selected, drawings or symbols being loaded will be rotated to fit 

between two points.    The drawings will not be scaled.    The drawings are retrieved at the size 
they were saved, regardless of the distance between the two points.

Changeable    When this option is selected, drawings or symbols being loaded will be rotated and 
sized to fit between two points.

Sound    This options turns the sound on or off.
Off
Error Only
On

Create Backup Copy    This option determines if a backup copy will be saved when the drawing is 
saved with the Save command.

Save Parameters with Drawing    This option determines if system parameters such as Drawing Units
size, cursor type, and sound are saved with the drawing file.

See Also:    Options command, Changing Default Options



Drawing Text in an Arc
Choose the Text Arc command.
Type the text in the Text box in the Command Line.
Choose the font in the Font box in the Command Line.
Type the text size in the Text Size box in the Command Line.
Type the angle of the text in the Text Angle box in the Command Line.
Choose the orientation of the text in the Orientation box in the Command Line.
Choose the Bold button in the Command Line to have the text drawn in bold.
Choose the Italic button in the Command Line to have the text drawn in italic.
Choose the Same as button in the Command Line to have the text drawn with the same options as text

in the drawing.    Then choose the text in the drawing.
Set a point for the corner of the text arc.
Set a point for the middle of the text arc.
Set a point for the end of the text arc.

See Also:    Text Arc command



Finding Information on DesignCAD
Choose the About DesignCAD command from the Help menu.
Choose the OK button.

See Also:    About DesignCAD command



Shortcut Keys
Default Shortcut Keys
DesignCAD DOS Keystrokes



Understanding Material List File Format
Materials List File Format



ASCII File

DesignCAD drawing files can be saved with a .DC2 file extension by choosing the ".DC2" extension in the
Save As command.    This is an ASCII file format, where the data is written in character format.    Each 
"record" in the file is actually a line in a text file.

There are four types of records, or lines, in the file.



Angular Text

The Angular Text options such as format and precision determine how text 
drawn using the Dimension Angle and Line Angle-2 commands.



Bezier

A Bezier is a curve drawn using the Bezier Curve command.    Points are set 
for the endpoints and the control points.



DOS Keystrokes

DOS Keystrokes are the Shortcut Keys used in the DOS version of DesignCAD.
In DesignCAD 2-D for Windows, you may use either the original keystroke 
commands created for the DOS version, or the new shortcut keys created for 
the Windows version.



Function Key Commands
F1

Get help on command or a 
message

F1

Go to the next field Alt+F1
Get help on a selected command 
or key combination

Shift+F1

Go to previous field Alt+Shift+F1

F2
Set a point at the midpoint of line F2
Move the cursor to the midpoint of 
line without setting a point.

Ctrl+F2

F3
Repeat the last completed 
command

F3

F4
Close the current drawing Ctrl+F4
Exit DesignCAD and end current 
session

Alt+F4

F6
Select Coordinate Bar F6
Choose next window as active 
window

Ctrl+F6

F7
Change text options F7

F9
Load a selected part of a 
drawing

Ctrl+F9

F12
Save a new, unnamed drawing or 
save a drawing with a different name

F12

Open a new drawing Ctrl+F12
Save changes to a drawing Shift+F12
Print the current drawing Ctrl+Shift+F12

See Also:    Shortcut Keys, DOS Keystroke Commands



Hiding Hot Toolbox
Choose the Hot Toolbox option from the Show/Hide secondary menu in the View menu.

See Also:    Showing Hot Toolbox, Customizing DesignCAD



Scalable Hatch Patterns

ANGLE

ANS131 ANS132 ANS133

ANS134 ANS135 ANS136 ANS137

ANS138 BLOCKS BRASS BRICK

BRICK2 CLAY CONCRET CORK

CROSS DASH DECKING DOLOMITE

DOTS EARTH FLEX GLASS

GRASS GRATE HBONE HEATRANS

HEX HONEY INSULATE LINES

MUD NET NET3 NONSKID

PARKET PLASTIC PLASTIC1 SHINGLES

SQUARES STARS STEEL TILE

TRIANGLE WEAVE ZIGZAG



Non-Scalable Hatch Patterns

WIN_SOLID WIN_HORIZONTAL WIN_VERTICAL

WIN_FWDDIAGON
AL

WIN_BKDIAGONAL WIN_CROSS

WIN_DIAGROSS



Application Control-Menu Button
The Application Control-menu button opens the Application Control-menu, in the upper-left corner of the 
DesignCAD screen.

See Also:    Title Bar



Drawing Control-Menu Button
The drawing Control-menu button opens the drawing Control-menu.

See Also:    Title Bar



Selecting Certain Entities
Selecting Certain Entities with the Keyboard
Selecting Certain Entities with Mouse






