Wprowadzenie do programu Microsoft FrontPage Express

Program FrontPage Express jest edytorem stron sieci Web, w którym mo¿na w pe³ni korzystaæ z mo¿liwoœci jêzyka HTML (Hypertext Markup Language). Programu FrontPage Express mo¿na u¿ywaæ do tworzenia i formatowania stron sieci Web w jêzyku HTML, pracuj¹c w widoku WYSIWYG ("what you see is what you get"), dziêki czemu widaæ, jak formatowanie i uk³ad strony bêd¹ wygl¹daæ w rzeczywistoœci.

Program FrontPage Express wspó³pracuje równie¿ z poleceniem Opcje folderów (dostêpnym z menu Widok okna "Mój komputer"), umo¿liwiaj¹cym szybkie i ³atwe dostosowanie wygl¹du folderów.

Korzystaj¹c z ³atwych w u¿yciu funkcji programu FrontPage Express mo¿na tworzyæ bogate i niezwykle wymyœlne strony sieci Web. Mo¿na na przyk³ad:

  • Stosowaæ tagi HTML z listy na pasku narzêdzi, bez koniecznoœci wpisywania ich.

  • Zaznaczaæ fragmenty tekstu i akapity, po czym formatowaæ je za pomoc¹ jednego klikniêcia przycisku paska narzêdzi.

  • Wstawiaæ obrazy utworzone przez siebie lub wybrane z ulubionych kolekcji (kolekcje nie s¹ do³¹czone do programu FrontPage Express).

  • Otwieraæ istniej¹ce strony sieci Web bezpoœrednio z sieci Web (jeœli jest zainstalowany Kreator publikacji w sieci Web) albo z pliku na komputerze lub w sieci.

  • Zapisywaæ wyniki pracy bezpoœrednio w sieci Web (u¿ywaj¹c Kreatora publikacji w sieci Web) lub w pliku.

  • Dodawaæ neony (przewijaj¹cy siê tekst).

Program FrontPage Express oferuje wiele funkcji programu Microsoft FrontPage Editor w mniejszym pakiecie. £atwo jest przejœæ od programu FrontPage Express do Microsoft FrontPage bez koniecznoœci nauki od podstaw nowego programu i metod tworzenia stron sieci Web. Program FrontPage oferuje dodatkowe funkcje programów FrontPage Editor i FrontPage Explorer.


Personalizacja folderów przy u¿yciu stylu sieci Web

Obecnie, cokolwiek mo¿esz zrobiæ na stronie sieci Web, mo¿esz równie¿ zrobiæ w dowolnym folderze na dysku twardym!

Kiedy wyœwietlasz zawartoœæ komputera u¿ywaj¹c stylu sieci Web, mo¿esz dostosowaæ t³o dowolnego folderu za pomoc¹ polecenia Opcje folderów (dostêpnego z menu Widok okna "Mój komputer"). Co wiêcej, mo¿esz przekszta³ciæ dowolny folder w stronê sieci Web u¿ywaj¹c tego polecenia i programu FrontPage Express.

Kiedy folder zostanie przekszta³cony w stronê sieci Web, mo¿esz u¿yæ programu FrontPage Express, aby dodaæ ³¹cza do programu Outlook Express lub innych sk³adników, wstawiæ formanty ActiveX, dostosowaæ styl i rozmiar czcionek lub dodaæ znaki wodne. Mo¿esz u¿ywaæ tej funkcji po prostu dla zabawy lub aby wspó³u¿ytkowaæ najœwie¿sze informacje w dostosowanych, udostêpnianych folderach. W obu przypadkach mo¿esz tworzyæ foldery dok³adnie dostosowane do swoich potrzeb.


Zaawansowane funkcje programu FrontPage Express

Korzystaj¹c z ³atwych w u¿yciu funkcji programu FrontPage Express mo¿esz tworzyæ bogate i niezwykle wymyœlne strony sieci Web:

  • Dodawaj kolory t³a i znaki wodne.

  • Korzystaj ze sk³adników WebBot, aby dodaæ bogat¹ funkcjonalnoœæ bez z³o¿onego programowania. Sk³adnik WebBot jest "obiektem dynamicznym" na stronie sieci Web, który zostaje uruchomiony, gdy autor strony zapisuje j¹ na serwerze sieci Web lub, w pewnych przypadkach, gdy u¿ytkownik ogl¹da tê stronê. Program FrontPage obejmuje sk³adniki WebBots, które dodaj¹ do stron sieci Web funkcje Time Stamp, Include i Search. (Aby mieæ mo¿liwoœæ korzystania z pe³nego zestawu funkcji WebBot, obejmuj¹cego np. obs³ugê formularzy, paski nawigacyjne i wiele innych, mo¿esz zainstalowaæ program Microsoft FrontPage.)

  • U¿ywaj formantów ActiveX, aby zwiêkszyæ mo¿liwoœci stron sieci Web.

  • Wstawiaj nowe tagi HTML, gdy staj¹ siê dostêpne, u¿ywaj¹c polecenia Wstawka HTML.

  • Wszystkie tagi HTML ogl¹daj i edytuj bezpoœrednio na stronie sieci Web. Kolorowe kodowanie w programie FrontPage Express u³atwia odró¿nienie tagów od zawartoœci.


Przejœcie do programu FrontPage

Kiedy uznasz, ¿e mo¿esz tworzyæ bardziej zaawansowane strony sieci Web, z ³atwoœci¹ przejdziesz od programu FrontPage Express do Microsoft FrontPage. Program ten bêdzie wygl¹da³ znajomo, poniewa¿ program FrontPage Express zosta³ zaprojektowany na podstawie edytora FrontPage Editor dostêpnego w programie Microsoft FrontPage.

Program Microsoft FrontPage jest pe³nym pakietem dla autorów stron sieci Web i administratorów witryn sieci Web. Zestaw dwóch programów, FrontPage Express i FrontPage, jest doskona³¹ kombinacj¹ dla organizacji, w których u¿ytkownicy maj¹ nauczyæ siê najpierw prostego ogl¹dania i edytowania (FrontPage Express), a nastêpnie przejœæ do nieograniczonego edytowania, ogl¹dania i administrowania sieci¹ Web (FrontPage).

Program FrontPage dostarcza pe³nego œrodowiska projektowego dla autorów sieci Web, z nastêpuj¹cymi sk³adnikami:

  • Program FrontPage Editor umo¿liwia tworzenie, ogl¹danie i zapisywanie dokumentów HTML. Obejmuje on szablony, kreatory i sk³adniki WebBot, pozwalaj¹ce na tworzenie bogatych stron sieci Web. Poniewa¿ program FrontPage Editor dzia³a równie¿ jako mini-przegl¹darka, mo¿na u¿ywaæ go do importowania stron z dowolnego miejsca w Internecie lub intranecie.

  • Program FrontPage Explorer umo¿liwia administrowanie, ogl¹danie i manipulowanie witrynami sieci Web. Mo¿esz zaprojektowaæ i przetestowaæ witrynê sieci Web na komputerze osobistym, a nastêpnie skopiowaæ ca³¹ witrynê na serwer sieci Web. Mo¿esz równie¿ u¿yæ programu FrontPage Explorer jako osobistego serwera sieci Web, aby uruchomiæ witrynê sieci Web bezpoœrednio z pulpitu, jako czêœæ sieci intranet lub jako publiczn¹ witrynê w sieci Web.