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This help file is designed to demonstrate various techniques used when creating help files.    It interacts 
with the Rich Edit example.    Page 1 contains information regarding Rich Edit.    Page 2 contains 
examples of more sophisticated help file techniques.    Complete RTF source for this help file can be 
found in RICHEDIT\HELP.    You can rebuild RICHEDIT.HLP from this source using the BUILDHLP.BAT 
file provided.
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Sample Fonts
Windows system fonts

Sample Graphics
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Computer Based Training
Simulation

Having Fun
Game



The Index contains a list of all Help topics available for the Help Example. For information on how to use 
Help, press F1 or choose Using Help from the Help menu.



Edit Menu

The Edit menu includes commands that enable you to move text to and from the clipboard, to delete text, 
and to undo a previous editing operation.

For more information, select the Edit menu command name.

Copy Copies text to the clipboard.
Cut Deletes text and moves it to the clipboard.
Paste Moves text from the clipboard to the edit window.
Undo Cancels a previous operation.
Font Enables you to select a font for the text.



File Menu

The File menu includes commands that enable you to open and save files, establish a new workspace, 
and to print.

For more information, select the File menu command name.

New
Open
Save
Save As
Print
Exit



Help Menu

The Help menu includes commands that enable you to access online documentation regarding the Rich 
Edit application.



Glossary

clipboard



Copying Text

Highlight the text you wish to copy and then use the Copy command to copy it to the clipboard.    You can 
paste this text into your document using the Paste command.    (This topic is associated with the 
keywords "copy" and "clipboard.")



Deleting Text

Delete text in the Rich Edit editor by highlighting it and hitting the backspace key.    Deleted text does not 
go to the clipboard and cannot be recovered.    (This topic is associated with the keywords "delete" and 
"clipboard.")



Exiting

To exit Rich Edit, choose the Exit command from the File menu.



Font Command (Edit menu)

Use this option when you want to change the font of text selected in the Edit Window or to set a font for 
new text.



Copy Command (Edit menu)

Use this command to copy text to the clipboard.



Cut Command (Edit menu)

Use this command to move text to the clipboard.



Paste Command (Edit menu)

Use this command to place text from the clipboard.



Undo Command (Edit menu)

Use the command to cancel the last action performed..



Exit Command (File menu)

Use this command to quit the Rich Edit example.



New Command (File menu)

Use this command to start a new document in Rich Edit.



Open Command (File menu)

Use this command to load an existing .RTF file from disk into the Edit Window.



Print Command (File menu)

Use this command to send the contents of the Rich Edit Edit Window to a printer.



Save Command (File menu)

Use this command to write your document to a file on disk.



Save As Command (File menu)

Use this command to specify a new name for your document and write it to a file on disk.



Context Sensitive Topics

This Help system includes topics that you can call directly from the Rich Edit sample application. To get 
context-sensitive help from Rich Edit highlight any Rich Edit menu command using the keyboard and 
press F1 to get help on the command. Each topic has a unique context identifier, listed in the [MAP] 
section of the Help project file:

[MAP]
#define HELPID_FILE           100
#define HELPID_FILE_NEW       101
#define HELPID_FILE_OPEN      102
#define HELPID_FILE_SAVE      103
#define HELPID_FILE_SAVE_AS   104
#define HELPID_FILE_PRINT     105
#define HELPID_FILE_EXIT      106
#define HELPID_EDIT           200
#define HELPID_EDIT_UNDO      201
#define HELPID_EDIT_COPY      202
#define HELPID_EDIT_CUT       203
#define HELPID_EDIT_PASTE     204
#define HELPID_EDIT_FONT      205
#define HELPID_HELP           300
#define HELPID_EDIT_WINDOW    400



Edit Window

The edit window contains the body of your document.    You can edit and format text in the edit window.



Bitmaps by Reference

A bitmap can be placed in a sentence , just like any character. Click on this bitmap to open a 
pop-up box with more information.

You can also put bitmaps at the left margin of the Help window. Text will automatically wrap along the right 
edge of the bitmap.

Or the bitmap can be at the right window margin, and text will automatically wrap along its left edge.



The coding for this bitmap is:

text... text...

Note: You cannot code bml or bmr bitmaps 
as hotspots in this version of Help.



Visually Placed Bitmap

This icon was pasted from the Clipboard into the Help topic file



Windows System Fonts

This is Courier 10 point.

This is Helv 10 point. 

This is Modern 12 point.

This is Roman 12 point.

This is TMS RMN 12 point.



Note: Although they are available in Windows, 
the Script and Symbol fonts do not display 
with this version of Help shipped with the 3.0 SDK.

This is Script 12 point.

This is Symbol 12 point (Symbol font).



Vowels and Consonants

Find the meaning in the word below by clicking on the letters one at a time.

Borland



The letter B is for best of breed development tools.



O is for Object-Oriented Programming.



R is Rapid Application Development.



L is for leader in development tools.



A is for awesome.



N is for no SDK required.



D is for debugging power.



Tutorial Lesson

There are three things to remember about your life vest:



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.
How to put it on.



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.
How to put it on.
How to inflate it.



Help can be authored with interactive instructional segments:



Congratulations!

You have found a topic that has no context-string identifier. It is accessible from a browse sequence only.

Can you think of a reason to author such a topic?



Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp 

          italic
          underline
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Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp 

          italic
          underline



Eureka!

You found a topic that is accessible from a keyword search only. This topic is not linked through hypertext 
in any way.

You can use this technique to access topics without having to index them and author jumps. You can also 
access topics like this directly from your application through the use of multiple keyword tables.





Windows Keys

The keyboard topics below come from Help for Windows. You can create similar keyboard topics for your 
application's Help. Choose from the following list to review the keys used in Windows:

Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.

End or Ctrl+Right Arrow Moves to the end of a field.

Home or CTRL+Left Arrow Moves to the beginning of a field.

PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).

SHIFT+TAB Moves from field to field in reverse order.

ALT+letter Moves to the option or group whose underlined letter matches the one 
you type.

DIRECTION key Moves from option to option within a group of options.

ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the command.

ESC Closes a dialog box without completing the command. (Same as Cancel)

ALT+DOWN ARROW Opens a drop-down list box.

ALT+UP or DOWN ARROW Selects item in a drop-down list box.

SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.

CTRL+SLASH Selects all the items in a list box.

CTRL+BACKSLASH Cancels all selections except the current selection.

SHIFT+ DIRECTION key Extends selection in a text box.

SHIFT+ HOME Extends selection to first character in a text box.

SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.

Or, deletes selected text.

Delete Deletes the character to the right of the cursor.

Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the Help 
window is already open, pressing F1 displays the "Using Windows Help" 
topics.

In some Windows applications, pressing F1 displays a Help topic on the 
selected command, dialog box option, or system message.

SHIFT+F1 Changes the pointer to  so you can get Help on a specific command, 
screen region, or key. You can then choose a command, click the screen 
region, or press a key or key combination you want to know more about.

(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.

Letter key Chooses the menu, or menu item, whose underlined letter matches the 
one you type.

Alt+letter key Pulls down the menu whose underlined letter matches the one you type.

LEFT or RIGHT ARROW Moves among menus.

UP or DOWN ARROW Moves among menu items.

Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Ctrl+Esc Switches to the Task List.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application. (See Help 
Keys)



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left or right.

SHIFT+DOWN or UP Selects one line of text up or down.

SHIFT+END Selects text to the end of the line.

SHIFT+HOME Selects text to the beginning of the line.

SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is already 
selected.

SHIFT+PAGE UP Selects text up one window.

Or, cancels the selection if the previous window is 
already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.

CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or end 
(DOWN ARROW) of the paragraph.

CTRL+SHIFT+END Selects text to the end of the document.

CTRL+SHIFT+HOME Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.

ALT+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are 
running as icons.

Alt+ENTER Switches a non-Windows application between running in a window and 
running full screen.

DIRECTION key Moves a window when you have chosen Move from the Control menu.

Or, changes the size of a window when you have chosen Size from the 
Control menu.





Clipboard

The clipboard is a place in memory in which items, such as text, is stored after a Copy or Cut operation.    
It can be retrieved via a Paste operation.    Only one item can occupy the clipboard at a time.

If you click the "clipboard" term within the Copying Text or Glossary topic, this Help topic will be displayed 
in a pop-up window.

This topic is also tagged with the keyword "clipboard," for use with the WinHelp Search option.



 




