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Overview

WebSurfer is a client application which allows you to browse multimedia information on the World Wide 
Web (WWW).    WebSurfer displays hypertext documents and supports multimedia such as sound, video, 
and interactive graphics.
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About the World Wide Web

The WWW is a set of servers on the Internet that are interconnected through hypertext. Hypertext is a 
method of presenting information where you can expand selected items at any time to provide information
about the item.    These selected items are links which allow you to move from document to document and
server to server.



WebSurfer Features

WebSurfer includes the following features:

· Displays formatted documents (electronic text in a variety of fonts, bold and italic, bulleted lists, 
extended characters sets)

· Browses hypertext-linked documents
· Provides and supports links to FTP, Gopher, and Telnet
· Displays hypermedia documents including interactive graphics, sounds, and movies
· Lets you create Hotlist folders for organizing documents
· Lets you instantly access other tools without closing WebSurfer
· Provides context-sensitive menus using right mouse button
· Supports caching of information downloaded to your local drive from the Web
· Tracks the links of your search through the Web, and allows quick backtracking

· Supports external editors and viewers, such as WEBSpider, NEWTView, and NEWTSound, so you 
can view text, image, video files, and listen to sound files



What is Hypertext?

The Web attempts to organize all the information on the Internet, plus whatever local information you 
want as a set of hypertext documents that use the Hypertext Markup Language (HTML) document format.

Hypertext is a method of presenting information where selected words in the text can be expanded at any 
time to provide other information about the word.    These words are links to other documents, which may 
be text, files, graphics, or anything.

HTML enables text formatting, embedded pictures, and hypertext links (anchors) to other documents and 
different locations within documents.    An HTML anchor is a reference to another document or object, or 
to a place within a document.    These references are made through a standard Universal Resource 
Locator (URL), which is a text string consisting of the resource type, the Internet address of the machine, 
and the location of the item on that machine.



About Uniform Resource Locators (URLs)

Uniform Resource Locators (URLs) let you identify where a resource resides anywhere on the Internet by 
pointing at other Web documents on HTTP servers.    If you know the document’s URL you can point your 
browser to the document via its URL, though generally you will be navigating via other Web documents 
and will not need to know the URLs. URLs provide information about resource type, location, and path.

Resource types indicate the type of server on which the document resides.    WebSurfer supports the 
following resource types:
http:// is the HTTP Server
ftp:// is the FTP Server
file:// is the local HTML file
telnet:// is the Telnet Server
gopher:// is the Gopher Server
mailto:// is an e-mail address
news:// is the usenet news GROUP

For example the NetManage home page document title is NetManage Home Page and its URL is:
http://www.netmanage.com:80/netmanage/index.html
where:

http is the resource type (HTTP Server)
//www.netmanage.com:80 is the resource location
/netmanage/index.html is the pathname and filename
Note: When downloading a file from an FTP URL, a separate dialog box will indicate your progress.    You

can use WebSurfer while one or more FTP transfers continue in the background.
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Using WebSurfer

When you start WebSurfer, the default document window containing the NetManage logo will normally 
appear.    However, in some case this might not happen as Automatic Internet can download pointers to a 
new default. To display the NetManage home page, single-click on the NetManage logo.    The interface 
consists of the document window and the menus and controls surrounding the document.

The Title bar at the top of the window displays the document title.    The Menu bar displays all the menu 
names, with each menu containing drop down lists of commands.    The Toolbar contains buttons that 
serve as shortcuts for WebSurfer menu items.

Below the Toolbar is the Dialog bar which displays the URL address of the current document.    As you 
move the mouse around the document, the Status bar displays the URLs for any anchors or links over 
which the mouse passes.

A document can contain text and pictures, some of which are hypertext links to other multimedia 
documents or objects.    The links are highlighted in blue (default).    You can change the document format,
that is, how it appears on your screen by using the Style Schemes command from the Settings menu.

To gather information about the document you are currently viewing, choose the Properties command 
from the Retrieve menu.    The Properties dialog box displays information such as:    title, URL, file type, 
and the local file where the document is located.

You can browse through the document and single-click using the left mouse button on the highlighted text
to link to another document.    WebSurfer downloads and displays the new document, including any 
graphics that may be a part of it.    To return to the previous page, choose the Back command from the 
Retrieve menu or the Back toolbar icon.    To return the home page, choose the Home command from the 
Retrieve menu or the Home toolbar icon.

You can display the Hotlist window by choosing the Show Window command from the Hotlist menu or the 
Hotlist toolbar icon.    The Hotlist window now appears in the left pane, while the current document 
appears in the right pane.    You can also drag and drop the URL of an anchor or link to any Hotlist folder 
by clicking the right mouse button and dragging the anchor to the Hotlist folder.



Opening Documents in WebSurfer

There are two methods of opening documents in WebSurfer:    opening a document through its URL 
pathname, or opening an existing local .HTM file from the local file system.



Opening Documents using URL Pathnames

While navigating through a Web document, you can open another document by:

· single-clicking the left mouse button on the highlighted text to link to it.
· entering a document’s URL pathname by selecting the Go To URL option under the Retrieve menu.

· entering a document’s URL pathname in the Dialog bar and pressing the Return key.

All three methods will retrieve the selected document from the network or local cache (local drive) and 
display it for you.    



Opening Documents using URL Pathnames

You can open existing local .HTM files from your local file system. This is useful if you want to edit your 
own .HTM files.    Simply select the Open Local File command from the Retrieve menu and select 
the .HTM file you want to edit.    Then, choose either the Edit HTML command or the View/Play button in 
the Properties option dialog box to edit the document.    Both options will display the .HTM file in the 
default text view if the file is a text file.    It will display the file with the default image viewer if it is an image
file, and will play the file with the default player if it is a sound or movie file.

After you have edited and saved the file, you can view its changes immediately by selecting the Refresh 
From Disk command from the Retrieve menu.



Using the Hotlist

The Hotlist contains items (documents) that you find particularly interesting and want to access regularly 
without having to search for them within the Web.    You can display the Hotlist by choosing the Show 
Window command from the Hotlist menu, selecting    the Hotlist toolbar icon, or by positioning the mouse 
cursor on the left hand border of the WebSurfer window and dragging the border to the right.    The Hotlist 
appears in the left pane of the WebSurfer window, while the selected document is displayed in the right 
pane.

The Hotlist feature lets you add items, create folders for organizing items, display folder properties, import
Mosaic or Netscape hotlist information, and merge existing hotlist items into your current hotlist.



Adding Items to Your Hotlist

You can add items to your Hotlist by choosing the Add Item command from the Hotlist menu. Or,    or by 
placing the cursor on the highlighted link or image, clicking the right mouse button and dragging it a folder
in your Hotlist. 



Viewing Files in WebSurfer

WebSurfer supports external viewers so you can edit text, view image, and movie files, and listen to 
sound files.    Use the File Manager file association system to determine the appropriate viewer program 
for viewing different kinds of files.    For example, associate files with the .TXT extension with a viewer 
such as notepad or write.    To view .GIF images, you must have a GIF image viewer and associate it to 
the . GIF extension.



Caching Documents

A major feature that WebSurfer provides is the ability to cache documents or files. Caching keeps a copy 
of documents that you have opened, in your local cache (local drive).    When you revisit a document, that 
is, reopen a previously opened document, you do not have to wait while the information downloads all 
over again from the network.

See Also
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Default Caching Behavior

When you retrieve a document from the Web, it is downloaded directly from the network and 
automatically placed in your local cache for the current session. If you want to reuse a document you 
have already retrieved during the current session, WebSurfer will retrieve it for you automatically from 
your local cache.

However, when you close the current session, all documents in your local cache will not be saved.    If you
want to re-visit a document you opened during a previous session, then the document is automatically 
retrieved from the network and once again placed in your local cache.

Default caching behavior for documents is specified by using the Preferences command (global behavior 
of all documents) and the Properties command (individual behavior of a specific document).    Note that 
the settings for the caching behavior of a document in the Properties dialog overrides those set in the 
Preferences command.



Overriding Default Caching Behavior

There are several ways you can override the default caching behavior of documents:

Choose the Refresh From Network command under the Retrieve menu to automatically refresh a 
document retrieved from your local cache with its latest version from the network.

To retrieve documents directly from the network and not your local cache, regardless of how many times 
you re-visit the same document, deselect the Reuse Retrieved Documents Within Session checkbox 
located on both the Properties and Preferences dialog boxes.    These are documents you are re-visiting 
in the current session.

To save documents to your local drive between sessions, select the Save Cached Documents Between 
Sessions option, located on both the Properties and Preferences dialog boxes.    Use this option to 
retrieve the same document from your local drive between sessions.



Using Short Cut Menus

Instead of using the standard menus to find the command you need, click the right mouse button on an 
image or empty space in the current document to display short cut menus.    The short cut menus contain 
several commands such as letting you edit or modify images, add the document to your Hotlist, or directly
mail the document to another user.

See Also
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Short Cut Menu for Document Images

To display the short cut menu for an image:

1. Place the cursor on the image you want to edit or modify.

2. Click the right mouse button.    A short cut menu with the following commands appear.

· Save Image As lets you save the selected image to a file.
· Edit Image lets you save the image to your default image viewer.
· Refresh Image reloads the most current version of the image from the network.



Short Cut Menu for Document Text

To display the short cut menu for document (not including images):

1. Place the cursor anywhere in the document, except on an image.

2. Click the right mouse button.    A short cut menu with the following commands appears:

· Open lets you open the desired .HTM file
· Save As lets you save the current document to a file.
· Save Background As lets you save the current document's background images.
· Reload lets you reload the most current version of the document from the network.
· Text Editor displays the unformatted version of the document in your local text editor (default is 

notepad).
· HTML Editor displays the formatted version of the document in your local HTML editor (default is 

WebSpider).



Importing NCSA MOSAIC.INI and Netscape File Information

If you have already used NCSA Mosaic or Netscape you may have created your own menus and hotlists. 
You can easily import your user created information from an NCSA Mosaic or Netscape file intact into 
WebSurfer Information includes user created menu items and hotlist items.

To import the user created menu items and hotlist items from an MOSAIC.INI or Netscape file into 
WebSurfer:

1. Choose the Import MOSAIC.INI file or Import Netscape command from the Hotlist menu.

2. Select the desired drive, and directory and enter the name of MOSAIC.INI or Netscape Bookmark    
file or files whose contents you want to import.

3. Choose the OK button.



Accessing Resources on Gopher, FTP, and Telnet

Although you may be accessing resources mainly located on HTTP servers, you may also want to access
resources on the Internet that reside on Gopher, FTP, and Telnet servers.

If you access a resource (double-clicking on the link or entering its URL) that is located on Gopher or FTP,
you will be dropped into the NetManage Gopher or FTP server application.

Selecting a resource that is located on Telnet temporarily drops you out of the Web and starts a Telnet 
session.    When you end the Telnet session, you will return to the Web.    Several sample URLs are 
shown below:
ftp://anonymous:@ftp.netmanage.com.21
gopher://gopher.netmanage.com.70
file://localhost/c:/



Open Local File...

Open an existing .HTM file from your local drive.    Use this option if you are creating your own HTML 
document and want to access from your local drive.

To open a file on the local drive:

1. Choose the Open Local File... command from the Retrieve menu.

2. Select the desired drive, and directory and file you want to open.

3. Choose the OK button.



Save As...

Saves the current WebSurfer document to a file.



Save Background As

Lets you save the current document's background image.



New Configuration

Creates a new configuration file.    When you choose this command, the application provides you with a 
default configuration template (file).

To select a new configuration:

Choose the New Configuration command from the File menu.



Open Configuration...

Opens an existing configuration file.    When you choose Open Configuration..., the application allows you 
to load an existing configuration file.

To open an existing configuration file:

1. Choose the Open Configuration... command from the File menu.

2. Select the desired drive, directory and file.

3. Choose the OK button.



Save Configuration

Saves configuration parameter changes to the current configuration file.

To save configuration parameter changes:

Choose the Save Configuration command from the File menu.



Save Configuration As...

Saves configuration parameter changes to a new configuration file.

To save configuration parameter changes:

1. Choose the Save Configuration As... command from the File menu.

2. Select the desired drive, and directory and enter the new file name.

3. Choose the OK button.



Print...

You can print the local HTML document by choosing the Print command from the File menu. To see how 
the current HTML document will look when you print it, choose the Print Preview command, also located 
on the File menu.

To print:

1. Choose the Print... command from the File menu.

2. Choose the All option from Print Range, and choose the OK button.



Print Preview

Shows you how the current HTML document will look when you print it.    You can print the current file, 
view the next and previous pages, view the file in one or two page format, and zoom in or out of the file.

To view the contents of the currents window in print preview:

1. Choose the Print Preview command from the File menu.

2. Select the desired buttons for printing, viewing in two page format or zooming in and out.

3. Select the Print Preview command again to return to the previous view of the file.



Print Setup...

Allows you to modify the printer configuration.

To modify the printer setup:

1. Choose the Print Setup... command from the File menu.

2. Select either the default printer or a specific printer.

3. Select additional options according to the specific printer.

4. Choose the OK button.



Exit

Exit allows you close the application:

To do this:

Choose the Exit command from the File menu.



Copy

Allows you to copy the contents of the URL edit box at the top of the main WebSurfer window into the 
Clipboard.

For example, you can copy a URL pathname from the URL edit box and paste it into an e-mail message 
or other application via the Clipboard.



Paste

Paste lets you to paste the contents of the Clipboard into the URL edit box at the top of the main 
WebSurfer window.    

For example, you can paste a URL pathname from a Word file directly into the URL edit box instead of 
manually typing it in.



Find...

Find lets you search for specified text in the current document.    To find specified text:

1. Choose the Find... command from the Edit menu.

2. Enter the text you want to find in the Find What text box.

3. Select the desired options.

4. Choose the Find Next button.

5. Choose the Cancel button you want to finish the search.



Source

Lets you display the current HTML file (current document) in an unformatted or formatted version.    The 
HTML file can be a text, image, sound or movie file.    In the unformatted version, the HTML file is 
displayed in the text editor if the file is a text file, with the default image viewer if an image file, and plays 
the file with the default player if a sound or movie file.    In the formatted version, the HTML file is 
displayed using the local HTML editor.    The default HTML editor is WebSpider.

Note: You can only edit an HTML file you created.    You cannot edit an HTML file that was created by 
another user.

To display the unformatted version:

1. Choose the Source and then Text Editor commands from the Retrieve menu.

2. An unformatted version of the HTML file appears in the default text editor, image viewer or default 
player.

The Text Editor command provides the same function as the View/Play button on the Properties menu.

To display the formatted version:

1. Choose the Source and then HTML Editor commands from the Retrieve menu.

2. A formatted version of the HTML file appears in the local HTML editor.    The default is WebSpider.



Go To URL...

Retrieves a document directly from the network or from your local drive (depending how you set 
WebSurfer preferences) and displays it.    After the document is retrieved, it is automatically placed in your
local drive.

To display the selected URL:

1. Choose the Go To URL... command from the Retrieve menu.    The WebSurfer - Go To Document 
dialog box appears.    Note the server type http://    appears automatically for your convenience.

2. Enter the URL address of the document you want to display and choose the OK button.

For example, to display the NetManage home page, enter the URL:
http://www.netmanage.com



Reload From Network

Replaces the selected document (URL) with the latest version from the network and places it in local 
storage.

To refresh a document (URL) with its latest version from the network:

1. Open the document you want to refresh.

2. Choose the Refresh From Network command from the Retrieve menu.

The document will be refreshed and placed in local storage.



Reload From Disk

Refreshes the local document from the local file system.    Use this option if you have made changes to a 
local file and want to see those changes.

To refresh a local file:

After modifying a local .HTM file, choose the Refresh From Disk command from the Retrieve menu.

The modified file will be saved on your local drive.



History...

WebSurfer keeps a history of documents you have viewed within the current session thus allowing you to 
easily access previous selections.

To view a history of documents, choose the History... command from the Retrieve menu to display the 
WebSurfer-History dialog box.    You will see a list of every document you have looked at in the current 
session.    The document you are currently looking at will be highlighted.    To display a document, double-
click on the item, or choose the item and choose the Go To button.



Back

Allows you to view the previously viewed URL.

To do this:

Choose the Back command from the Retrieve menu, or use the Back toolbar button.



Forward

Allows you to revisit the URL you were viewing before you selected the Back option.

To do this:

Choose the Forward command from the Retrieve menu, or use the Forward toolbar button.



Home

Returns you to the document you entered as the startup document in the Preferences menu.

To return to the document indicated as the startup document in the Preferences menu:

Choose the Home command from the Retrieve menu, or use the Home toolbar button



Properties...

Allows you to change the properties of a selected document only.    You can change its title, file type, add 
a memo about the document, change its file location, and look at the file's text if it is a text file, or see or 
hear it if it is an image or sound file.

Note: If you want to make global changes to all documents, refer to the Preferences option under the 
Settings menu.

To do this:

1. Display the URL whose properties you want to change.

2. Choose the Properties... command from the Retrieve menu.    The URL Properties dialog box 
appears, containing the following text boxes:

Title Description of URL Title

URL URL pathname

Type File type, such as a Word, sound,image or HTML file

Memo Special information about the URL you may want to 
include

Local File File location of the URL

Save in Hotlist Save the current document in your Hotlist

Reuse retrieved document within session Select this if you want to reuse a document you 
already retrieved in the current session.    If you re-
visit a document, that document is retrieved from 
your local cache (local drive) and not the network.

Save cached document between sessions Select this if you want a document you retrieved 
from the network to be automatically saved on your 
local drive.      When you retrieve this document 
during another session, it is loaded from your local 
drive, not the network.

View/Play Shows the file in the default text view if the file is a 
text file.

Displays the file with the default image viewer if an 
image file; and plays the file with the default player if
a sound or movie file.

Connection Status... 

Displays the current connectivity status.    Status information includes the host name, bytes, rate, time, 
operation, and URL.

You can stop one connection, all connections or clear the screen of inactive connections.



Cancel All

Allows you to cancel anything that is currently being retrieved through the network.



Find...

Lets you search for text in the Hotlist.



Show Window

Lets you display or hide the Hotlist window.



Add Item

Add Item lets you add the current document or selected link to your hotlist.

To add the current document to your Hotlist:

1. Display your Hotlist.

2. Select the folder to which you want to add the item.

3. Choose the Add Item... command from the Hotlist menu.    The document title of the item now appears
in your Hotlist.



New Item...

New Item lets you create a new Hotlist entry.    To do this:

1. Display the Hotlist and select the folder into which you want to place the new entry.

2. Choose the New Item... command from the Hotlist menu.    The New Item dialog box appears.

3. Enter the name of the item, as you want it to appear in your Hotlist, in the Name text box.

4. Enter the item’s URL pathname in the URL text box.

5. Choose the OK button.



Delete Item

Delete Item lets you delete an item from the Hotlist.    To do this:

1. Display the Hotlist and select the item you want to delete.

2. Choose the Delete Item command from the Hotlist menu.    A prompt appears asking you to confirm 
your deletion request.

3. Choose the OK button to delete the item.



Item Properties...

Item Properties lets you change the name and URL pathname of a Hotlist item.    To do this:

1. Display the Hotlist and select the item whose properties you want to change.

2. Choose the Item Properties... command from the Hotlist menu.    The WebSurfer - Item Properties 
dialog box appears.

3. Make changes to the item’s name and URL pathname.

4. Choose the OK button.



New Folder

New Folder lets you create a new Hotlist folder.    To do this:

1. Display the Hotlist and select the location where you want to add the folder.

2. Choose the New Folder... command from the Hotlist menu.    The New Folder dialog box appears.

3. Enter the new folder name in the Name text box.

4. Choose the OK button.



Delete Folder

Delete Folder lets you delete an existing folder and all its items.    To do this:

1. Display the Hotlist and select the folder you want to delete.

2. Choose the Delete Folder command from the Hotlist menu.    A prompt appears asking you to confirm 
your deletion request.

3. Choose the OK button.

Caution:    Both the folder and all its items are deleted.



Folder Properties...

Folder Properties lets you change a Hotlist folder’s name.    To do this:

1. Display the Hotlist and select the folder whose name you want to change.

2. Choose the Folder Properties... command from the Hotlist menu.    The WebSurfer - Folder Properties
dialog box appears.

3. Enter the folder name in the Name text box.

4. Choose the OK button.



Import Mosaic Hotlist...

Lets you import user created information from an NCSA Mosaic file.    Information such as user created 
menu items, hotlist items, configuration information, and so on can be imported intact into WebSurfer.

To import the contents from a MOSAIC.INI file into WebSurfer:

1. Choose the Import Mosaic Hotlist... command from the Hotlist menu.

2. Select the desired drive, and directory and enter the name of MOSAIC.INI file whose contents you 
want to import.

3. Choose the OK button.



Import Netscape Hotlist...

Lets you to import user created information from a Netscape Hotlist.    Information such as user created 
menu items, hotlist items, configuration information, and so on can be imported intact into WebSurfer.

To import the contents from a Netscape bookmark file (.HTM file) into WebSurfer:

1. Choose the Import Netscape Hotlist... command from the Hotlist menu.

2. Select the desired drive, and directory and enter the name of Netscape Bookmark file (.HTM file) 
whose contents you want to import.

3. Choose the OK button.



Export Hotlist as HTML...

Lets you save your Hotlist as an HTML file.



Merge Hotlist...

Lets you merge another Hotlist that is in its database format into your current Hotlist.



Preferences...

You can set preferences in WebSurfer to indicate the startup document, network software, document 
viewers, proxy server, and global document retrieval behavior of all documents.    To do this:

Choose the Preferences command from the Settings menu.    The WebSurfer - Preferences dialog box 
appears.    Preferences are grouped within seven tabs:    General, Network, Viewers, Proxies, Cache, 
Hotlist, and Plug In.



General Tab
· Startup Document:    Select either Browse Files or Load Now.    Browse Files displays the WebSurfer 

Browse Startup Files dialog box where you can choose the selected .HTM file you want to appear 
when you start the application.    Load Now automatically displays the selected .HTM file upon starting
the application.

· Disable backgrounds and color:    Overrides the current document's background image and color 
settings.

· Text Editor:    Identifies the text editor that is used for displaying the unformatted version of an HTML 
file.    

· HTML Editor:    Identifies the HTML editor that is used for displaying the formatted version of an HTML
file.    WebSpider is the default editor.



Network Tab
· Supports Asynchronous Host Name Resolution:    WebSurfer uses a different interface to resolve host

names.    If you experience problems accessing Gopher hosts you may want to try deselecting the 
Supports Asynchronous Host Name Resolution.    (The default is selected).

· Maximum number of connections:    The maximum number of connections, used for downloading, you
can have at the same time.    For example, if you specify eight connections and you are downloading 
a document that has 20 images, then only the first eight images are downloaded simultaneously.      
Then the remaining images are downloaded one at a time.



Viewers Tab

You can associate MIME (Multi-purpose Internal Mail Extensions) types with the following actions:    Inline 
Viewer, External Viewer, Save As, and Ask User.    You can also specify the Telnet and Gopher programs 
to run. 

See also

Adding and Modifying Viewers



Adding and Modifying Viewers

To associate a new or modify an existing action with a MIME type, do the following:

1. Choose the Add or Modify button from the Viewers tab on the Preferences menu.

2. Select a predefined or enter a new MIME type in the MIME type text box.

3. Enter the standard extension for the selected MIME type.    Refer to any general HTML book for more 
information about MIME type extensions.

4. Select an action from one of the following:

· Inline Viewer:    Browser automatically handles the MIME type.
· External Viewer:    A separate or specialized application handles the MIME type.
· Save As...:    Displays the Save As dialog    box at the time you encounter the MIME type in a 

document.
· Ask User:    Prompts you to select an action (one of the other three actions) at the time you 

encounter the MIME type.

5. Choose the OK button.



Proxies Tab

You can use the HTTP proxy, FTP proxy, and Gopher proxy.    Enter the server name and port number (80
is the default).    You can also choose to exclude certain proxy servers by choosing the Proxy Exclude 
button and entering the host and domain name of the proxy.



Cache Tab
· Reuse Retrieved Documents Within Session: Select this if you want to reuse a document you already 

retrieved in the current session.    If you re-visit a document, that document is retrieved from your local
cache (local drive) and not the network.

· Save Cached Documents Between Sessions: Select this if you want a document you retrieved from 
the network to be automatically saved on your local drive.    When you retrieve this document during 
another session, it is automatically loaded from your local drive, not the network.

· Memory Cache: Determines the size of your memory cache for local storage of documents.
· Disk Cache:    Determines the size of your disk cache for local storage of documents.
· Disk Cache Directory:  Determines the size of your disk cache directory for local storage of 

documents.



Hotlist Tab

Confirm On:    Displays a confirmation prompt when you try to move or delete an item, or delete a folder.

Automatically Close Hot list window:    Automatically closes the Hotlist window after you have selected a 
Hotlist item.

Hotlist File: Displays the pathname of the current Hotlist.    You can choose and load the Hotlist you want 
to use in the current session by using the Browse button.    The Hotlist pathname C:\netmanag.32\
webSurf.hot is the default.

Set Font:    Lets you change the font type of Hotlist items.



Plug In

WebSurfer now supports embedded third-party applications.    To add embedded third-party applications, 
do the following:

1. Choose the Preferences command from the Settings menu.

2. Choose the Plug In tab.

3. Add the name of the directory of the Plug In application you want to access.



Defer Images

Defer Images lets you retrieve images manually.    Select this command if you do not want images to be 
automatically rendered.    This is useful in preventing display flicker.



Style Schemes...

Lets you set style guidelines for the document that is currently displayed    You can select scheme 
elements, font types and styles, point size, foreground/background colors, document color, and margins.

To set the style scheme for a URL file:

1. Display the URL file whose style scheme you want to set.

2. Choose the Style Scheme... command from the Settings menu.    The Style Schemes dialog box 
appears.    You can set the following options:

Style Schemes Description

Preview Element whose attributes you want to change (You can also 
scroll for scheme elements by name in the Scheme Elements 
text box)

Element Attributes Description

Scheme Elements Element whose style/attributes you want to change

Indent Determines, in inches, how far the selected element is indented
within the document

Font Font type of the selected element

Font Style Font style of the selected element

Size Point size of text of the selected element

Foreground color Color of the text of the selected element

Background color Background color or highlight of the text

Effects:    Strikeout/Underline Selected element will have a line through it or under it 

Document Attributes Description

Document Color Color of the document background

Overall Font Size Globally increase or decreases

by one point size all the

scheme elements

Margins Left and right margins of the document during display

Printing Left, right, top, and bottom margins of document for printing

Log

Helps you to diagnose client transmission and WWW server retrieval problems.    

1. Choose the Log... command from the Settings menu.

2. Choose the Start button to start logging, or the Stop button to stop logging.

3. Choose the Save button to save the contents of the log window to the WWW.LOG file.

4. Choose the Print button to print the contents of the log window.

5. Choose the Copy button to copy the contents of the log window onto the clipboard.



6. Choose the Clear button to clear the log window.

7. Choose the Close button to close the Log... command dialog 



Toolbar ...

Lets you display or hide the application's toolbar.    The toolbar gives you quick mouse access to several 
of the application's tools.



Smart Buttons

Lets you display enlarged toolbar icons with descriptions.



Status Bar

Lets you display or hide the application's status bar.    The status bar is displayed at the bottom of the 
window where it shows messages and provides statistics about the current application.



Dialog Bar

Displays the current URL.    You can also go to another URL by entering it in the Dialog bar and pressing 
the Return key.    You can display or hide the Dialog bar by selecting/deselecting the Dialog bar option 
from the Settings menu.



Customize...

You can now launch other Chameleon applications directly through the WebSurfer Tools menu instead of 
Program Manager. All applications other than NEWTNews will appear in separate windows.    Choose the 
Customize command from the Tools menu and select the application you want to activate.    The selected 
application automatically opens in another window while WebSurfer is still open.

See also

Activating NEWTNews

Activating Other Tools



NetSearch

NetSearch displays the Internet Search Tools and Directories document.



Activating NEWTNews

Because the NEWTNews application is now designed as an OLE (object linking and embedding) server, 
you can now activate and view the NEWTNews application within the WebSurfer application.    Use 
NEWTNews as you normally would and return to WebSurfer at anytime.    To do this:

Choose the Customize command and then the News option from the Tools menu.    Or, choose the 
Customize command to display the WebSurfer -Customize Tools dialog box, and then select the news 
option and choose the OK button.

NEWTNews is automatically activated within the WebSurfer application window.    You can display or hide 
the Hotlist.    Return to WebSurfer at any time by choosing the Return to WebSurfer command from the 
Connections menu or choose the Escape button.



Activating Other Tools

You can also activate other applications directly through the WebSurfer Tools menu without having to use 
the Program group.    All applications other than NEWTNews will appear in separate windows.    Use the 
Customize command from the Tools menu and select the application you want to activate.    The selected 
application automatically opens in another window while WebSurfer is still open.



Troubleshooting

If you experience difficulties using the WebSurfer application, refer to the following item:

o Verify that the installation and setup verification steps have been successfully completed. NEWTSound 
and NEWTView are NetManage sound and viewer applications provided for your convenience.    
However, if you get a message, "Failed to launch viewer for file *.bmp, *.gif etc., check file associations;
check for viewer;"    do the following:

1. Go to File Manager.

2. Select Associate option in File Menu.

3. For the file type bmp, gif, etc., select the viewers using the Browse button. 

Example viewers are:    PAINTBRUSH.EXE, WINGIF.EXE, and so on.

You can also add, modify or delete viewers automatically.    Choose the Settings menu, and then 
Preferences and Viewers tab.

o When you get messages "Unable to resolve the hostname" Check for the following:
Can you ping the hostname?

If you have upgraded to the current version, Make sure that you are not using the old configuration file
and that the corresponding entry for this application is removed from the TCPIP section of the WIN.INI
file

Check whether the correct configuration file is opened in Custom, and all the settings are correct.

o If you are not retrieving any images in the documents, see whether the Defer Image Display option in 
Preferences is enabled.    Disabling it will help you to retrieve the images automatically.

o If you have problems in retrieving the updated documents for example, Stock Quote information and 
reading newspaper articles, make sure that the Reuse documents retrieved documents within session 
is disabled.    If it is enabled, then the cached documents are displayed instead of the new updated 
documents from the network.



Diagnose Connection

Choose the Diagnose Connection command to start Ping and verify that the server is available.



Contents

Using Help

To choose a Help topic:

Mouse Point to the underlined topic you want to view and click the mouse button. When the 
pointer is over an item you can choose, the pointer changes to a hand icon.

Keyboard Press Tab to move the highlight to the underlined topic you want to view, and then 
press Enter.

To exit Help:

Mouse 1:    Point to the File menu and click the mouse button.

2:    Click the Exit command.

Keyboard 1:    Press Alt.

2:    Type the letter F.

3:    Type the letter X.

About WebSurfer...

Choose the About WebSurfer... command from the Help menu to do the following:

Choose the Copy button to copy the application version information into the Windows Clipboard.    You 
can then paste this information into any application.

Choose the OK button to continue.

 




